Legal Information

Acknowledgements

Microsoft ® is a U.S. registered trademark of Microsoft Corporation

Windows ® and MS Windows ® are U.S. registered trademarks of Microsoft Corporation.

Adobe ® Acrobat ® are trademarks of Adobe Systems Incorporated.

Notice

The hardware and/or software described in this document are furnished under a license and may be used or copied only in accordance with the terms of such license.

If software is for use in the performance of a U.S. Government prime contract or subcontract, Software is delivered and licensed as "Commercial computer software" as defined in DFAR 252.227-7014 (June 1995), or as a "commercial item" as defined in FAR 2.101(a) or as "Restricted computer software" as defined in FAR 52.227-19 (June 1987) or any equivalent agency regulation or contract clause. Use, duplication or disclosure of Software is subject to Agilent Technologies’ standard commercial license terms, and non-DOD Departments and Agencies of the U.S. Government will receive no greater than Restricted Rights as defined in FAR 52.227-19(c)(1-2) (June 1987). U.S. Government users will receive no greater than Limited Rights as defined in FAR 52.227-14 (June 1987) or DFAR 252.227-7015 (b)(2) (November 1995), as applicable in any technical data.

© Agilent Technologies, Inc. 2001


Call Processing

Call Processing

Last updated: December 9, 2008

This page provides links to descriptions of the numerous settings and operations available in the test set for base station emulation and call processing including

  • Test Set Operating Modes
  • Base Station Emulation Configuration
  • Call Processing Status and Operations

If you have trouble finding the information you need in the links below, use the search field at the top of this page to search the contents of this guide. If you are new to using the test set, it may be helpful to review the Getting Started with Call Processing page.

For details about to which revisions of the 3GPP specifications the test set is compliant, see Test Adherence to Standards and What 3GPP TS 05.05 Requirements are supported? .

Test Set Operating Modes

  • Active Cell Operating Mode
  • Test Mode Operating Modes
  • Fast Device Tune
  • CW
  • Cell Off

Base Station Emulation Configuration

Call Control Call Parms
Connection Types Configuring the Broadcast Channel (BCH)

Establish a Connection with the Mobile Station

  • Establishing an Active GSM Link with the Mobile Station
  • Establishing a Data Connection with the Mobile Station
  • Call Processing Ladder Diagrams

Configuring the Traffic Channel (TCH) Parameters

  • Frequency Banded Parameters
  • Band Selection Parameters
  • Channel Mode Setup
  • Configuring Mobile Station Operating Parameters
  • Frequency Hopping
  • Call Signaling Parameters (Lab Application Only)
    • Dedicated Control Channel (DCCH) Features
      • Calls via the SDCCH
      • Combined and Non-Combined BCH/SDCCH
    • Repeated Downlink FACCH
    • Repeated SACCH
Paging Parameters

Configuring the Packet Data Traffic Channel (PDTCH)

  • Frequency Banded Parameters
  • Band Selection Parameters
  • Bursted Parameters
  • Downlink PDTCH Power Control
  • Supported Multislot Classes
  • Configuring Mobile Station Operating Parameters
  • EGPRS Data Rate Configurations
  • Incremental Redundancy
  • Modulation Coding Scheme/Puncturing Scheme (MCS/PS)
  • Frequency Hopping (Lab Application Only)
  • Downlink Dual Carrier (Lab Application Only)
  • TTI Mode Configuration (Lab Application Only)
  • Flexible Timeslot (Lab Application Only)

Cell Info

  • Cell Operation
  • Cell Parameters
  • Cell Identification Parameters
  • Cell Lists
    • 3G FDD Neighbour Cells (Lab Application Only)
 Receiver Control

Protocol Logging

DUT PDP Setup

Ping

Protocol Control (Lab Application Only)

  • Temporary Block Flow (TBF) Parameters
    • Delayed Downlink TBF
    • Extended Uplink TBF
    • TBF Re-establishment

Short Message Service (SMS) (Lab Application Only)

  • Cell Broadcast Service (CBS)

Measurement Reports (Lab Application Only)

Digital Audio Interface (DAI) Description (Lab Application Only)

Real-Time Vocoder

Calling Party Number Parameters (Lab Application Only)

Network Identity and Time Zone (Lab Application Only)

Call Processing Status and Operations

  • How the Test Set Performs a Dualband Handover
  • External Trigger Setup
    • Frame Triggers
    • Protocol Message Based Triggers
    • Neighbour Cell Synchronization Trigger (Lab Application Only)
    • Demodulation Trigger Delay (Lab Application Only)
  • GSM/GPRS Control Program Example
  • E-OTD (Enhanced Observed Time Difference) (Lab Application Only)
  • A-GPS (Assisted-GPS) (Lab Application Only)
  • Configurable Timers (Lab Application Only)
  • Dual Transfer Mode (Lab Application Only)
  • UMA/GAN Test System (Lab Application Only)
  • Two-Cell Test System (Lab Application Only)
    • Two-Cell Test System Ladder Diagrams (Lab Application Only)
  • Testing a GPRS Mobile Station
  • Mobile Calculate BER Test
  • FM Broadcast
  • Global Position System
  • Packet Paging (Lab Application Only)


Measurements

Measurements

Last updated: December 3, 2008

Description of How a Measurement is Made

The following table contains links to all the measurements offered in the GSM/GPRS/EGPRS Test Applications (TA) and Lab Applications (LA). The columns to the right of these links indicate which TAs and LAs the measurements are applicable to. For more information on a specific measurement, please click the link to the measurement's description.

If you have trouble finding the information you need below, use the search field at the top of this page to search the contents of this guide.

 | Applicable to:
 | GSM TA | GPRS TA | EGPRS TA | GSM/GPRS LA | EGPRS LA
Analog Audio Measurement Description | Yes | No | Yes | Yes | Yes
Audio Frequency Measurement Description | Yes | No | Yes | Yes | Yes
Audio Level Measurement Description | Yes | No | Yes | Yes | Yes
Bit Error Measurement | Yes | Yes | Yes | Yes | Yes
Block Error Rate (BLER) Reports Description | No | Yes | Yes | Yes | Yes
Block Error Measurement | No | Yes | Yes | Yes | Yes
Data Throughput Monitor | No | No | No | Yes | Yes
Decoded Audio Measurement Description | Yes | No | Yes | Yes | Yes
Distortion Measurement Description | Yes | No | Yes | Yes | Yes
Dynamic Power Measurement Description | Yes | Yes | Yes | Yes | Yes
EDGE Dynamic Power (EDP) Measurement | Yes | Yes | Yes | Yes | Yes
EGPRS SRB Bit Error Measurement | Yes | Yes | Yes | Yes | Yes
Fast Bit Error Measurement Description | Yes | Yes | Yes | Yes | Yes
Fast Device Tune Capable Measurement | Yes* | Yes* | Yes* | Yes | Yes
Frequency Stability Measurement Description | Yes | Yes | Yes | Yes | Yes
GPRS Bit Error Measurement | Yes | Yes | Yes | Yes | Yes
GSM Bad Frame Indication (BFI) Measurement Description | No | No | No | Yes | Yes
GSM Bit Error Measurement | Yes | Yes | Yes | Yes | Yes
GSM Frame Erasure Rate (FER) Measurement Description | No | No | No | Yes | Yes
In-Band Frame Error (IFER) Measurement Description | No | No | No | Yes | Yes
I/Q Tuning Measurement Description | Yes | Yes | Yes | Yes | Yes
Measurement Reports | No | No | Yes | Yes | Yes
Modulation Accuracy Measurement Description | No | No | Yes | No | Yes
Multi-tone Audio Measurement Description | Yes | No | No | Yes | Yes
Output RF Spectrum Measurement Description | Yes | Yes | Yes | Yes | Yes
Phase and Amplitude versus Time Measurement Description | Yes* | Yes* | Yes* | Yes | Yes
Phase and Frequency Error Measurement Description | Yes | Yes | Yes | Yes | Yes
Power versus Time Measurement Description | Yes | Yes | Yes | Yes | Yes
RACH Measurement Description | Yes | Yes | Yes | Yes | Yes
Receiver Sensitivity Testing in GPRS and EGPRS | No | Yes | Yes | Yes | Yes
Repeated SACCH Frame Erasure Rate (FER) Measurement Description | No | No | No | Yes | Yes
SINAD Measurement Description | Yes | No | Yes | Yes | Yes
Spectrum Monitor Description | Yes | Yes | Yes | Yes | Yes
Transmit Power Measurement Description | Yes | Yes | Yes | Yes | Yes
Uplink State Flag (USF) BLER | No | No | No | Yes | Yes
* Requires a feature license.

Description of each Measurement's Adherence to the Standards

  • Test Adherence to Standards
  • What 3GPP TS 05.05 Requirements are supported?

Measurement Calibration

  • Calibrating the Test Set
  • User Calibration Summary

Amplitude Offset

  • Amplitude Offset

Related Topics

Measurement Reports


Manual Operation

Manual Operation

This page provides links to information on using the test set from the front panel including: Call Processing Operations (such as making a call, handovers), Call Processing Configuration (configuring the test set's base station emulator), Making Measurements (how to use the measurements in general, and also how to perform 3GPP TS 34.121 tests, see Performing Individual Measurements and 3GPP TS 51.010 Tests ), Data Channel , Test Set Configuration (such as amplitude offsets, GPIB and LAN ports), General Manual Operation (such as Help Mode, which provides context-sensitive GPIB command syntax assistance, and Save and Recall Registers, which provide a way to return to frequently used setups).

Call Processing Operations

  • How Do I Set Up a Call?
    • Setting Up the Call Parameters
    • Establishing a Mobile Terminated Call
    • Establishing a Mobile Originated Call
  • How Do I End a Call?
  • How do I Make Rach Measurements?
  • How Do I Change the Payload Pattern Sent to the Mobile Station?
    • Change the GSM Downlink Speech Payload
    • Change the GPRS/EGPRS Payload Pattern
  • How Do I Set Up and Use the Frequency Hopping Feature?
  • How Do I Perform a Handover?
  • How Do I Perform an EGPRS Handover?
  • How Do I Access the Medium Access Control (MAC) Parameters? (GPRS/EGPRS LA Only)
  • How to view Measurement Reports (LA Only)
  • How to use the Adaptive Multi-Rate (AMR) and Wideband AMR (AMR-WB) Features (LA Only)
  • How to use Protocol Logging (LA Only)
  • How to use the Short Message Service Features (LA Only)
  • Enabling the HTTP Interface
  • How to use Timing Advance Control. (LA Only)
  • How do I test Incremental Redundancy? (EGPRS LA only)
  • How do I test MCS Switching? (EGPRS LA only)
  • How do I change the Downlink TBF Puncturing Scheme? (EGPRS LA only)
  • How Do I Use the Data Throughput Monitor? (LA Only)
  • How Do I Perform Calling Party Number Verification? (LA Only)
  • How Do I Set Up and Test Cell Selection and Transitions? (LA Only)
  • How Do I Set the TBF Parameters? (GPRS/EGPRS LA Only)
  • How Do I Set Up and Use the Dual Transfer Mode Feature? (LA Only)
  • How to access DUT PDP Setup (GPRS/EGPRS LA Only)
  • How to use the Digital Audio Interface Features (LA Only)
  • How Do I Use Real-Time Vocoder?
  • How Do I Set Up and Use the Configurable Timers?
  • How Do I use Mobile Calculate BER Test

Call Processing Configuration

  • How Do I Change Call Parameters?
  • How Do I Change Cell Operation Parameters?
  • How Do I Change Cell Parameters?
  • How Do I Change Cell Identification Parameters?
  • How Do I Change Cell List Parameters?
  • How Do I Change Paging Parameters?
  • How Do I Set the Training Sequence Code (TSC)?
  • How to Configure Access Burst Power Control
  • How to Configure Access Burst Power Control for DCS
  • How Do I Configure the Speech Source?
  • How Do I Configure the Call Signaling Parameters? (LA Only)
  • How to access Protocol Control
  • How Do I Configure the Control Channel Parameters?
  • How Do I Configure the PDTCH Parameters?
  • How Do I Configure the Type of Bursts used to Carry the Packet Control Acknowledgments? (LA Only)
  • How Do I Change the MS TX Level?
  • How Do I Change the EGPRS Modulation Coding Scheme?
  • How Do I Assign Different Modulation Coding Schemes / Puncturing Schemes to Each Downlink of a Multislot Burst?
  • How Do I Gain Access to All the EGPRS Multislot Configurations?
  • How do I change the EGPRS Demodulation Type to Normal? (EGPRS TA Only)

Making Measurements

  • Performing Individual Measurements and 3GPP TS 51.010 Tests [image] click here for instructions for performing 3GPP TS 51.010 tests.
  • How Do I Make GSM Measurements on a Mobile?
  • How Do I Make GPRS Measurements on a Mobile?
  • How Do I Make EGPRS Measurements on a Mobile?
  • How Do I Change Measurement Setup in GSM?
  • How Do I Change Measurement Setup in GPRS?
  • How Do I Change Measurement Setup in EGPRS?
  • How Do I Turn Off a GSM Measurement?
  • How Do I Turn Off a GPRS Measurement?
  • How Do I Turn Off a Measurement in EGPRS?

Data Channel

  • Configuring the Test Set and Starting a Data Connection for GPRS Measurements
  • Configuring the Test Set and Starting a Data Connection for EGPRS Measurements
  • How Do I End the GPRS Data Connection?
  • How Do I End the EGPRS Data Connection?
  • How to "ping" an IP address from the test set

Test Set Configuration

  • How Do I Configure the Test Set for My Test System? (GPIB address, amplitude offsets, etc.)
  • How Do I Configure the AUDIO OUT Port?
  • How Do I Configure Test Signals in CW Operating Mode?
  • How Do I Make an External Device Connection?
  • How Do I Make a FM Broadcast test? How Do I Make a FM Broadcast test?

General Manual Operation

  • Front Panel Connectors
  • Rear Panel Connectors
  • Remote/Local Mode
  • Printing and Saving Screen Images
  • Instrument Status Area
  • Preset Descriptions
  • Receiver Control
  • Help Mode
  • Save and Recall Registers
  • How Do I Configure the Test Set to Restart State?


Programming

Programming

The test set is programmable through a GPIB (General Purpose Interface Bus) located on the rear panel. This page provides links to documentation to help you program the test set. The table below lists the programming examples for the individual measurements and specifies the TAs and LAs that it applies to. The General Programming section contains even more links to general programming instructions.

If you have trouble finding the information you need below, use the "Search" functionality to search the contents of this guide.

Programming Guide and Comprehensive Examples

The following list contains links to example programs. It is recommended that you follow the first link in the list below if you have not programmed the test set before.

  • Programming: Getting Started Guide for E1968A GSM/GPRS Mobile Test Application Revision A.02 and E6701C GSM/GPRS Lab Application Revision C.02 - This guide provides a general approach to setting up a connection and obtaining measurement results programmatically. It gives an overview of how to configure the test set's base station emulator, perform key call processing operations and perform measurements.
  • GSM/GPRS Control Program Example - This example is a complete control program for testing wireless devices in a manufacturing environment.
  • Testing a GPRS Mobile Station - This procedure details the parameters that you should set in the test set as well as other steps that are necessary to test a GPRS capable mobile station.
  • Programming a Channel Mode Change - This example demonstrates how to change a mobile station's channel mode to enhance full-rate speech via GPIB.

Programming Examples for Individual Measurements

 | Applicable to:
 | GSM TA | GPRS TA | EGPRS TA | GSM/GPRS LA | EGPRS LA
Programming an Audio Level Measurement | Yes | No | No | Yes | Yes
Programming an Audio Frequency Measurement | Yes | No | No | Yes | Yes
Programming a Bit Error Measurement | Yes | Yes | No | Yes | Yes
Block Error Rate (BLER) Reports Description | No | Yes | Yes | Yes | Yes
Programming a Block Error Measurement | No | Yes | Yes | Yes | Yes
Programming a Phase and Amplitude vs. Time Measurement (CONTinuous Waveform) Programming a Phase and Amplitude vs. Time Measurement (CONT2 Waveform) Programming a Phase and Amplitude vs. Time Measurement (Discrete Waveform) | Yes * | Yes* | Yes* | Yes | Yes
Programming a Decoded Audio Measurement | Yes | No | No | Yes | Yes
Programming a Digital Audio Interface (DAI) Test | Yes | No | No | Yes | Yes
Programming a Distortion Measurement | Yes | No | No | Yes | Yes
Programming a Downlink Multi-Tone Audio Measurement | Yes | No | No | Yes | Yes
Programming a Dynamic Power Measurement | Yes | Yes | Yes | Yes | Yes
Programming an EDGE Dynamic Power Measurement | No | No | Yes | No | Yes
Programming a Fast Bit Error Measurement | Yes | No | No | Yes | Yes
Programming a GSM Bad Frame Indication (BFI) Measurement | No | No | No | No | Yes
Programming a Frame Erasure Rate (FER) Measurement | No | No | No | No | Yes
Programming an AMR In-Band Frame Error Rate Measurement | No | No | No | Yes | Yes
Programming an I/Q Tuning Measurement | Yes | Yes | Yes | Yes | Yes
Programming a Modulation Accuracy Measurement | No | No | Yes | No | Yes
Programming an Output RF Spectrum Measurement | Yes | Yes | Yes | Yes | Yes
Programming a Phase and Frequency Error Measurement | Yes | Yes | Yes | Yes | Yes
Programming a Power versus Time Measurement | Yes | Yes | Yes | Yes | Yes
Programming a RACH Measurement | Yes | Yes | No | Yes | Yes
Programming a SINAD Measurement | Yes | No | No | Yes | Yes
Programming the Spectrum Monitor | Yes | Yes | Yes | Yes | Yes
Programming the Spectrum Monitor Calibration | Yes | Yes | Yes | Yes | Yes
Programming a Transmit Power Measurement | Yes | Yes | Yes | Yes | Yes
Programming an Uplink Multi-Tone Audio Measurement | Yes | No | No | Yes | Yes
Program to Establish Dual Transfer Mode Operation | No | No | No | Yes | Yes
* Requires a feature license.

General Programming

  • Preset Descriptions
  • Receiver Control
  • Status Subsystem Overview
  • Obtaining Measurement Results
  • Test System Synchronization
  • Using GPIB Command Debug Mode
  • UI Log


GPIB Commands

GPIB Commands

This page provides links to all of the test set's GPIB subsystems. Select a subsystem link below for a description of the subsystem and links to all of the GPIB commands within that subsystem.

If you have trouble finding the information you need below, use the search field at the top of this page to search the contents of this guide.

GPIB Command Conventions

  • GPIB Command Conventions to understand how GPIB commands are represented.

Call and Connection Processing

  • CALL Subsystem to control the mobile and setup and control the cell.

Measurement Control

  • SETup Subsystem to configure a measurement.
  • INITiate Subsystem or READ? Subsystem to start a measurement.
  • FETCh? Subsystem or READ? Subsystem to get measurement results.
  • CALCulate Subsystem to perform data processing on measurement results
  • ABORt Subsystem to stop a measurement.

Status

  • STATus Subsystem Description to communicate Test Set status.

IEEE 488.2 Common Commands

  • IEEE 488.2 Common Commands

Instrument Selection

  • AFGenerator Subsystem
  • RFANalyzer Subsystem (not controlled as an instrument)
  • RFGenerator Subsystem

Test Set Configuration

  • CALibration Subsystem
  • DISPlay Subsystem
  • SYSTem Subsystem

GPIB Command Change Summary for GSM and GPRS

  • E1968A GSM/GPRS GPIB COMMAND CHANGES to see a summary of E1960A GSM commands and E1964A GPRS commands that were deleted, changed, or added for the combined E1968A GSM/GPRS Mobile Test Application. Describes functionality added to both technologies and new methods employed for various measurements in the E1968A.

Listing of Commands

For a complete list of the GPIB commands in this application: GSM/GPRS/EGPRS Listing of Commands


Protocol Logging

Protocol Logging

This section is only applicable to the lab applications.

With a lab application, the test set can capture the protocol messages exchanged between the test set and a wireless device. The protocol messages are forwarded via the test set's LAN port to the Wireless Protocol Advisor (WPA) software (which is included with your lab application), so that they can be displayed and analyzed. If you are using the data channel feature of the test set as an IP router to exchange data between the wireless device and a network server, then the WPA can also monitor these communications.

The Wireless Protocol Advisor software runs on a personal computer under the Windows operating system. It is tailored for the capture, display, and analysis of message exchange protocols between the test set (emulating a base station), and a wireless device. The software connects with the test set through the LAN port, to capture messages and data used to set up and maintain links and transfer data. Messages and data can be filtered to include specific protocol layers and message fields.

IMPORTANT
Most of the information necessary to establish a connection and to display, filter, store, print, and analyze the message exchange between the test set and a mobile station is accessible through the Help feature available on-line when the WPA application is running.

This online help is also available for download at:

http://www.agilent.com/find/e6584a

To help you get started using the WPA, the Agilent E6584A Wireless Protocol Advisor Operating Guide is available at:

http://cp.literature.agilent.com/litweb/pdf/1000-1868.pdf

Additional information, including PC operating system requirements and additional protocol logging reference information is listed below.

PC Operating System Requirements

Logging protocol messages requires an external PC with the following system requirements:

  • Protocol Logging Requirements

Starting and Stopping Protocol Logging

There are several ways to control the logging of signaling messages.

The primary method for starting and stopping is through features found in the WPA software.

The following information describes features available through the test set's remote and manual user interface for performing these functions:

  • Activating Protocol Logging From the Test Set

Related Topics

Protocol Layers and Messages

Protocol Logging and Data Channel Troubleshooting

Protocol Logging During Ping

Logging SMS Messages

Analyzing protocol logs of Packet Switched Data


Data Channel

Data Channel

This section is only applicable to the lab applications.

The Data Channel feature allows you to use the test set as a router while you exchange IP datagrams between the mobile station and remote servers.

Supported Data Channel Services

The test set supports GSM Circuit Switched Data (CSD) and both GPRS and EGPRS Packet Switched Data (PSD).

IP Setup

For information regarding IP Setup, click on the following links:

  • IP Address Requirements
  • DUT PDP Setup
    • DUT IP Address
    • DNS Server IP Addresses
    • QoS Profile
  • DUT Routing State

Data Channel Applications

There are several applications of the Data Channel:

  • Ping
  • WAP Test with the Data Channel (link your WAP device to a wml server)
  • Modem Functional Test with the Data Channel (e.g. to test a wireless modem, connect a PC with an html browser to the modem, and route the data through the test set to an html server)
  • FTP Throughput Test with the Data Channel (use FTP to transfer data to and from an FTP source)
  • Base Station Emulation with the Data Channel (use the test set as a router to transfer datagrams from your application to a wireless device)
  • Data Throughput Monitor (only applicable to the lab applications)

Related Topics

Protocol Logging and Data Channel Troubleshooting


Troubleshooting

Troubleshooting

This page provides links to troubleshooting information including: Contact Information , Measurement Troubleshooting , Call Processing Troubleshooting , Protocol Logging and Data Channel Troubleshooting , Error Indicators , GPIB Command Debug and Troubleshooting , and Other (such as block diagrams and known issues).

IMPORTANT
If you install application firmware on a test set with incompatible hardware, the test set may lock up. See Test Set Lockup During Power Up Sequence .

Some features may be inaccessible or may not perform to specifications without a hardware upgrade to your test set or a proper license. For more details, please see:

http://www.agilent.com/find/8960upgrades

Contact Information

  • Contact Us

Measurement Troubleshooting

The following table contains links to the troubleshooting sections for the measurements offered in the GSM/GPRS/EGPRS Test Applications (TA) and Lab Applications (LA). The columns to the right of these links indicate which TAs and LAs the measurements are applicable to. Please click the measurement's troubleshooting link for troubleshooting information on a specific measurement.

 | Applicable to:
 | GSM TA | GPRS TA | EGPRS TA | GSM/GPRS LA | EGPRS LA
AMR In-Band Frame Error (IFER) Measurement Troubleshooting | Yes | No | No | Yes | Yes
Analog Audio Troubleshooting | Yes | No | No | Yes | Yes
Bit Error Troubleshooting | Yes | Yes | No | Yes | Yes
Block Error Troubleshooting | No | Yes | Yes | Yes | Yes
Decoded Audio Troubleshooting | Yes | No | No | Yes | Yes
Dynamic Power Troubleshooting | Yes | Yes | Yes | Yes | Yes
EDGE Dynamic Power Troubleshooting | Yes | Yes | Yes | Yes | Yes
Fast Bit Error Troubleshooting | Yes | No | No | Yes | Yes
Frequency Stability Measurement Troubleshooting | Yes | Yes | Yes | Yes | Yes
I/Q Tuning Troubleshooting | Yes | Yes | Yes | Yes | Yes
Modulation Accuracy Troubleshooting | No | No | Yes | No | Yes
Multi-Tone Audio Troubleshooting | Yes | No | Yes | Yes | Yes
ORFS Troubleshooting | Yes | Yes | Yes | Yes | Yes
Phase and Amplitude versus Time Troubleshooting | Yes* | Yes* | Yes* | No | No
Phase and Frequency Error Troubleshooting | Yes | Yes | Yes | Yes | Yes
Power versus Time Troubleshooting | Yes | Yes | Yes | Yes | Yes
RACH Troubleshooting | Yes | Yes | No | Yes | Yes
Spectrum Monitor Troubleshooting | Yes | Yes | Yes | Yes | Yes
Transmit Power Troubleshooting | Yes | Yes | Yes | Yes | Yes
# This measurement is only applicable to the GSM/GPRS/EGPRS test applications with the required feature license.

Call Processing Troubleshooting

  • GPRS Data Connection Troubleshooting (GPRS Only )
  • EGPRS Connection Troubleshooting
  • Troubleshooting Training Sequence Code
  • Troubleshooting the Two-Cell Test System (LA Only)
  • Troubleshooting External Device Connection (LA Only)
  • Troubleshooting Dual Transfer Mode (LA Only)

Protocol Logging and Data Channel Troubleshooting

  • Protocol Logging and Data Channel Troubleshooting

Error Indicators

  • Error Messages
  • Error Message Log
  • Fixed Timer Messages
  • Manual User Error Messages
  • Integrity Indicator

GPIB Command Debug and Troubleshooting

  • Using GPIB Command Debug Mode
  • UI Log

Other

  • Calibrating the Test Set


Configuration

Configuration

Last updated: December 2, 2008

This page provides links to configuration information including: Test Set Configuration Information (identification, hardware configuration), Configuring the Test Set (such as setting amplitude offsets, configuring GPIB and LAN ports) and Selecting an Application .

If you have trouble finding the information you need below, use the search field at the top of this page to search the contents of this guide.

Test Set Configuration Information

  • Obtaining Identification Information *IDN?
  • Hardware Configuration Report

Configuring the Test Set

  • Amplitude Offset
  • Confidence Levels
  • Configuring the Test Set's AUDIO OUT port
  • Configuring the Test Set's GPIB Address
  • Configuring the Test Set's LAN
  • Configuring System Time and Date
  • Display Brightness
  • Display Mode (Track/Fast)
  • External Device Connection (Lab Application only)
  • Restart on Fatal Error
  • Test Set Beeper
  • Timebase Description/Configuration
  • Calibrating the Test Set

Selecting an Application

  • Application Switching


Release Notes

Release Notes

The links below contain information on the features in the test and lab applications for each release of the firmware.

Test Applications

GSM/GPRS/EGPRS (E1968A) Test Application Revision Information

GSM (E1960A) Revision Information (Discontinued as of April 1, 2003)

GPRS (E1964A) Revision Information (Discontinued as of April 1, 2003)

Lab Applications

E6701A/B/C/D/E/F/T/U GSM/GPRS/EGPRS Lab Application Revision Information

E6704A EGPRS Lab Application Revision Information


Getting Started with Call Processing

Getting Started with Call Processing

Last updated: December 2, 2008

Most of the information in the Call Processing section describes the features and functionality available while in Active Cell Operating Mode and one of the Test Mode Operating Modes . While in these modes, the test set includes a base station emulator which allows you to establish a connection between the test set and your wireless device (with signaling while in Active Cell Operating Mode or by the device synchronizing to the downlink while in a test mode operating mode).

The base station emulator can be configured by changing various parameters. Most of these parameters are described at the following links: Cell Operation , Cell Parameters , Cell Identification Parameters , Cell Lists , Configuring the Broadcast Channel (BCH) , Configuring the Traffic Channel (TCH) Parameters , Configuring the Packet Data Traffic Channel (PDTCH) , and Receiver Control . To find information on a specific parameter, you can also use the search field at the top of this page to search the contents of the guide.

For more details on establishing a call in Active Cell operating mode, see Call Processing Ladder Diagrams and How Do I Set Up a Call? .

You can perform other call processing operations such as Calling Party Number Parameters , Short Message Service (SMS) , Measurement Reports , Dual Transfer Mode , and Two-Cell Test System .


Configuring the Test Set's AUDIO OUT port

Configuring the Test Set's AUDIO OUT port

Last updated: December 2, 2008

Description

The AUDIO OUT connector on the test set's front panel can be configured to carry one of two signals:

  • Audio Generator
  • FM Demod

By default, the AUDIO OUT connector is configured to carry the output from the built in audio generator. This signal is typically used to stimulate a system to measure its audio performance. When the audio generator's signal is selected for output at the front panel AUDIO OUT connector, use the AFGenerator commands to control the signal.

When testing AMPS systems, it may be useful to configure the AUDIO OUT connector to carry the analog FM Demod signal. This provides the demodulated FM signal for external analysis and baseband processing. Fixed bandwidth bandpass, expandor, and de-emphasis filters can be selected to control the FM Demod signal. When the FM Demod signal is selected for output at the front panel AUDIO OUT connector, use the SYSTem:AUDio:OUTPut commands to control the signal.

For front panel operation, to select the signal source for output to the AUDIO OUT connector, press System Config hardkey, then select Audio Out Port ( F1 ) on the System Config Screen (2 of 2).

Programmatically, to select the signal source for output to the AUDIO OUT connector, use the SYSTem:AUDio:OUTPut:SOURce commands.

Example

OUTPUT 714;"SYSTem:AUDio:OUTPut:SOURce AFGenerator" !Selects Audio Generator signal for output
                                                    !at the front panel AUDIO OUT port.

NOTE
Refer to the Technical Specifications in the Application Datasheet for specifications of the AUDIO OUT connector. There will be no guaranteed performance for the signal present at the AUDIO OUT connector when FM Demod signal is selected for output.

Related Topics

How Do I Configure the AUDIO OUT Port?


Restart on Fatal Error

Restart on Fatal Error

Last updated: December 2, 2008

Description

The Restart on Fatal Error feature provides the ability to configure the test set to automatically restart when a fatal error occurs. Restart on Fatal Error does not apply when a fatal error occurs during the test set's power up sequence.

The Restart on Fatal Error State is retained regardless of whether the test set is restarted manually or through the Restart on Fatal Error feature. The test set's default setting for the Restart on Fatal Error State is Off. If the Restart on Fatal Error State is set to On and a fatal error occurs, the test set prints the fatal error condition on the test set's front panel. The test set then waits for 25 seconds before restarting.

The following error message is then displayed on the test set's front panel once the test set completes its power up sequence: " Warning; 8960 has been restarted after a non-recoverable error occurred. " All errors in the error/event queue can be queried using the command SYSTem:ERRor? .

Configurable Parameters

Restart on Fatal Error State is the only parameter that needs to be configured to allow the test set to restart if a fatal error is encountered. The command to set this parameter is SYSTem:FATal:ERRor:RESTart .

How Do I Configure the Test Set to Restart State?

The following procedure details how to configure the test set to automatically restart if a fatal error is encountered during operation.

  1. Press SYSTEM CONFIG .
  2. Press Instrument Setup ( F1 ).
  3. Scroll down and highlight the Restart on Fatal Error State parameter.
  4. Press the knob to change the state to On as shown in the figure below.

Related Topics

SYSTem:FATal:ERRor:RESTart


Test Set Beeper

Test Set Beeper

Last updated: December 2, 2008

Description

This parameter allows you to change the beeper state to on or off. A beep will indicate error conditions caused during manual or remote operation of the test set.

A 100 ms, 1.24 kHz audible tone (beep) is generated when an error message is logged and the beeper state is set to on. If two errors are generated in quick succession, two beeps are generated to indicate that more than one error has been logged.

The beeper state can be manually set in the Instrument Setup window found in the SYSTEM CONFIG screen.

Example

OUTPUT 714;"SYSTEM:BEEPER:STATE OFF"

Related Topics

SYSTem:BEEPer


Display Brightness

Display Brightness

Last updated: December 2, 2008

Description

This parameter allows you to adjust the brightness of the test set's display. The test set's display screen has two brightness settings:

  • medium brightness
  • high brightness

Example

OUTPUT 714;"DISPLAY:BRIGHTNESS MEDIUM" ! sets screen brightness to medium.

Related Topics

DISPlay:BRIGhtness


Confidence Levels

Confidence Levels

Last updated: December 2, 2008

What are Confidence Levels?

Using confidence levels for your measurements can reduce your test time. Confidence levels simply end the measurement early, that is, before all the multi-measurements you specified are taken. It ends the measurement early only if it determines statistically that the rest of the measurements should pass. You specify the level of certainty that you are satisfied with, for example, you may decide that you are satisfied in passing a measurement on your mobile if the test set is 95% confident that the rest of the measurements will pass.

Note, the test set only reduces your test time if it determines that the measurement will pass. If it determines that a future measurement may fail, or if a measurement does actually fail, the test set continues as normal executing your test plan.

It is not possible to determine the amount of time by which confidence levels reduce your test time as this is determined by a number of factors, some of which cannot be controlled. The following list details some of the factors:

  • The confidence level that you select. This can be set between 80% to 99.99%. Obviously, the lower the level you select, the greater the potential for a reduction in test time.
  • The stability of the mobile station's results. That is, if the individual results are variable (that is, differ significantly but are still within the limits), then the measurement will take longer. However, if the results returned are very similar and well within the limits then the measurement will end sooner.
  • The test limits that you select. For example, the tighter your test limits the longer the measurement will take.

To ensure that the prediction of the measurement result is accurate there is a minimum number of measurements made by the test set. This number is independent of the confidence level you set. However, this number is dependent on the multi-measurement count and is shown below.

Minimum Number of Measurements
Multi-Measurement Count | Minimum Number of Measurements
1-4 | Same as multi-measurement count
5-999 | 4

How do you set Confidence Levels?

You can set confidence levels for a measurement using its relevant SETup subsystem. Currently the only measurement in GSM with the confidence level feature is Phase and Frequency Error.

Confidence levels are only relevant when the measurement's multi-measurement count is on. Therefore if you turn on the confidence level feature for a measurement the test set automatically enables that measurement's multi-measurement count feature.

The following procedure and example show the steps needed when you are using confidence intervals via the GPIB.

  1. Set-up the mobile station and the test set for your required measurement.
  2. Use the SETup subsystem to turn the measurement's multi-measurement count on and specify the count number.
  3. Use the SETup subsystem to turn on the measurement's confidence state and set its confidence level.
  4. If required, use the SETup subsystem to set the measurements pass/fail limits. The test set uses the defaults pass/fail values if you do not specify any.
  5. Start the measurement using the INITiate subsystem.
  6. Use the FETCh? command to obtain the measurement results.

Programming Example

The following example uses the GSM Phase and Frequency Error measurement to demonstrate the use of confidence levels.

10  OUTPUT 714;"SETUP:PFERROR:CONTINUOUS OFF" !Configures a PFER measurement to
20                                            !single trigger mode.
30  OUTPUT 714;"SETUP:PFERROR:TRIGGER:SOURCE AUTO"!Configure trigger source
40                                                !to auto.
50  OUTPUT 714;"SETUP:PFERROR:SYNC MIDAMBLE" !Configures a PFER measurement so
60                                           !that burst synchronization, which
70                                           !will synchronize the timing of the
80                                           !measurement algorithm relative to
90                                           !the data sample, will be set
100                                          !to midamble.
110 OUTPUT 714; "SETUP:PFERROR:COUNT 20" !Sets the multi-measurement count state on,
                                          !and the number of measurements to 20.
120 OUTPUT 714; "SETUP:PFERROR:CONFIDENCE 90" !Sets the confidence level feature on,
                                              !and the level to 90%.
130 OUTPUT 714;"INITIATE:PFERROR" !Starts the PFER measurement.
140 OUTPUT 714;"FETCH:PFERROR:FAIL?"
150 ENTER 714;Integrity, Rms_ph_err_fail, Peak_ph_err_fail, Freq_err_fail, Number_of_meas
160 END

Using Confidence Levels with the Phase and Frequency Error Measurement

Currently the only measurement in GSM with the confidence level feature is Phase and Frequency Error. The Phase and Frequency Error measurement actually consists of three measurements: RMS Phase Error, Peak Phase Error and Frequency Error. The test set will not end a Phase and Frequency Error measurement early until it determines statistically that all three individual measurements should pass, with a level of confidence that is at least as high as the confidence level you set.

For example, if you set the confidence level to 95%, the test set only ends the measurement when it is:

  • at least 95% confident that the RMS Phase Error will pass, and
  • at least 95% confident that the Peak Phase Error will pass, and
  • at least 95% confident that the Frequency Error will pass.

The level of confidence with which the complete Phase and Frequency Error measurement passes early is equal to the product of the confidence levels with which each of the three individual measurements passed early. This means that for this example, the test set will only end the measurement early if there is at least an 85.74% (95% x 95% x 95%) level of confidence that the measurements that have still to be taken will pass.


Display Mode (Track/Fast)

Display Mode (Track/Fast)

Last updated: December 2, 2008

Description

There are two display modes to select from when operating the test set remotely.

  • Display mode fast
  • Display mode track

Fast Mode

When operating remotely, there is often no need for the display to be updated as measurements are made. Using the fast display mode will increase the speed of the test set when it is operated remotely.

Fast mode is designed for remote use only. The test set returns to track mode if you change to manual operation.

  • No screen or menu items are visible (except error messages).
  • Error messages will be displayed in their normal location.
  • "This instrument is being operated remotely" will be displayed at the bottom of the screen.

Example

OUTPUT 714;"DISPLAY:MODE FAST" !Selects fast mode

Track Mode

The track display mode is used to allow users to see what the test set is doing while it is being controlled remotely. Track mode is the default mode of the test set.

  • Any changes made remotely will be updated on the screen if that screen is displayed.
  • The error message window will be displayed as required when an error occurs.

Example

OUTPUT 714;"DISPLAY:MODE TRACK"!Selects track mode

Related Topics

DISPlay:MODE


External Device Connection

External Device Connection

Last updated: December 2, 2008

Description

You can connect your 8960 test set to an external device (such as another 8960 test set) over an IP network. Once you've established this connection, you can test supported end-to-end services between two wireless devices (such as W-CDMA end-to-end video calls), or configure a two-cell test system to test a single mobile's cell transitions, such as handovers and cell selections/reselections.

You can establish an External Device Connection while your test set is in any operating mode. However, most services utilizing the External Device Connection feature require active cell mode operation.

When connecting two test sets, it is recommended that you connect them via a hub, rather than through a gateway or WAN link, or connect them directly using a LAN crossover cable. This helps minimize the risk of lost data due to delayed packets.

External Device Connection Setup for Two 8960s

External 8960 Connection Setup

  • External 8960 IP Address

    Before establishing a connection with another 8960, you must first specify its IP address.

    Ext 8960 IP Addr cannot be set to the same value as LAN IP Address or DUT IP Address . If LAN IP Address is set to the value of Ext 8960 IP Addr , Ext 8960 IP Addr is reset to a blank field.

    GPIB command: SYSTem:COMMunicate:LAN:EXTernal:ADDRess

  • Connect to External 8960

    This action establishes a TCP/IP connection with the 8960 at the address specified by External 8960 IP Address .

    If the External Device Connection Status is Connected , then this action is ignored by the test set.

    GPIB command: SYSTem:COMMunicate:LAN:EXTernal:CONNect

  • Disconnect from External 8960

    This action disconnects the TCP/IP connection with the connected external 8960.

    If the External Device Connection Status is Disconnected , then this action is ignored by the test set.

    GPIB command: SYSTem:COMMunicate:LAN:EXTernal:DCONnect

LAN Connection Information

  • External Device Connection Status

    The External Device Connection Status is displayed in the LAN Connection Information window of both tests sets, regardless of which test set initiated the connection. The possible states of the external device connection are: Not Connected , Connecting , Connected and Disconnecting .

    When the External Device Connection status is Connected , ExtDev is displayed in the Instrument Status Area of both test sets:

    GPIB command: SYSTem:STATus:COMMunicate:LAN:EXTernal[:CONNected][:STATe]

  • Connected Device IP Address

    Once a connection has been established between the two test sets, the IP address of each test set is displayed in the other test set's LAN Connection Information window.

    GPIB command: SYSTem:STATus:COMMunicate:LAN:EXTernal[:CONNected]:ADDRess

  • LAN (Self) IP Address

    For your convenience, the IP address of the test set is shown in its LAN Connection Information window. This is a duplicate display of its LAN IP Address setting, which you set from the Instrument Setup ( F1 ) menu on its System Config screen, or using the SYSTem:COMMunicate:LAN[:SELF]:ADDRess command.

DUT IP Address Information

The DUT IP Address Information window indicates the IP address(es) currently in use by the DUT, and whether the IP address was assigned by the current test set or the external test set. Note that DUT IP Address must be set to a different value in both test sets.

Once an IP route is established between a test set and a device on the LAN, internet protocols do not provide a mechanism to re-establish the connection with another test set. Thus, when a mobile has an active PDP context with one test set and transitions to another, a tunnel is created to route data to and from the mobile via the originating test set. The originating test set must continue to act as the end-point for the IP connection, regardless of the location of the mobile, and to forward any received packets to the test set currently serving the mobile. This forwarding of packets is referred to as "tunneling".

During tunneling, the mobile uses the DUT IP Address provided by the originating test set, not the DUT IP Address of the serving test set. To help indicate this situation, the DUT IP Address setting on the serving test set is grayed out. Also, DUT IP Address Origin on the serving test set displays External 8960 and the IP address currently in use by the mobile is displayed under DUT IP Address 1 .

  • DUT IP Address Origin

    Displays either This 8960 or External 8960 to indicate which test set assigned the IP address currently in use by the mobile.

  • DUT IP Address 1

    Displays the IP address currently in use by the mobile.

  • DUT IP Address 2
  • DUT IP Address 3
  • DUT IP Address 4

Other Considerations

The external device connection is not affected by a partial preset. However, the external device connection is disconnected as a result of a full preset.

Before initiating an external device connection between two test sets, you can verify that the two test sets are able to communicate by pinging one test set from the other. To do so, on test set #1:

  • Press the Call Setup key, then the left More key until the Ping menu is available.
  • Select Ping , then Ping Setup ( F1 ).
  • Set Device to Ping to Alternate ( CALL:DATA:PING:SETup:DEVice ).
  • Set the Alternate Ping Address to the IP address of test set #2 ( CALL:DATA:PING:SETup:ALTernate:IP:ADDRess ).
  • Select Start Ping ( F3 ) ( CALL:DATA:PING:STARt ).

Related Topics

How Do I Make an External Device Connection?

SYSTem:COMMunicate

SYSTem:STATus

Troubleshooting External Device Connection

Configuring the Test Set's LAN

Two-Cell Test System

Data Throughput Monitor


Configuring the Test Set's GPIB Address

Configuring the Test Set's GPIB Address

Last updated: December 2, 2008

Description

The GPIB address is an integer between 0 and 30. The test set comes with a default address of 14 and may be set/queried using the SYSTem subsystem or manually through the system configuration screen by selecting the parameter and changing the number with the knob or the keypad.

The GPIB address is a non-volatile parameter. The GPIB address is not affected by any reset operation and can only be changed by direct access to the parameter itself.

Related Topics

SYSTem:COMMunicate:GPIB:[:SELF]:ADDRess


Hardware Configuration Report

Hardware Configuration Report

Last updated: December 2, 2008

Description

You can generate a list of the test set's hardware configuration over the LAN or GPIB.

The LAN query is the easiest and most direct way to query the test set's hardware configuration. This method uses your web browser to display a formatted report.

The GPIB query returns an unformatted character string that must be buffered and saved to an HTML file to provide formatted text.

LAN Query

  1. Refer to the SYSTEM CONFIG screen to determine the LAN address.
  2. Open a web browser and enter <LAN address>/iconfig. For example, if your LAN address is 130.2.2.147, you would enter:

    130.2.2.147/iconfig

  3. The web browser will then display formatted text. A partial list of the hardware configuration information is shown below:

GPIB Query

Use the following Basic example as a model to store the test set's configuration as an HTML file.

GPIB Example:

10    DIM Buf1$[20000],Buf2$[20000] ! This is the minimum space for the arrays
20    OUTPUT 714;"SYSTEM:CONFIGURE:INFORMATION:HARDWARE:VERBOSE?"
30    ENTER 714;Buf1$,Buf2$
40    CREATE "HW.htm",1              ! Create an HTML file
50    ASSIGN @File TO "HW.htm"
60    OUTPUT @File;Buf1$,Buf2$
70    END

In the future, the hardware configuration report may increase in length. More space would then need to be allocated for the arrays.

Display the HTML file using a web browser or HTML text editor.

Related Topics

SYSTem:CONFigure

SYSTem:CURRent:TA

SYSTem:APPLication

Obtaining Identification Information *IDN?

Rear Panel Connectors


Obtaining Identification Information *IDN?

Obtaining Identification Information *IDN?

Last updated: December 2, 2008

Description

Test set information is returned from a *IDN? query. The *IDN? query provides information about the Manufacturer, Model Number, Serial Number, and Firmware Revision. *IDN? is defined in IEEE Std. 488.2-1992, 10.14.

Test Set Information

*IDN? query returns identification information as a comma separated string.

DIM A$[100]
OUTPUT 714;"*IDN?" !returns manufacturer,model number, serial number and "0"
                   !separated by commas
ENTER 714;A$
PRINT A$           !prints, for example "Agilent Technologies, 8960 Series 10 E5515B,
                   !US38020105,0
  • Agilent Technologies is the manufacturer.
  • Printable ASCII characters excluding comma and semicolon up to a 25-character string.
    Model number example: 8960 Series 10 E5515B
  • Printable ASCII characters excluding comma and semicolon up to a 10-character string.
    Serial number example: US00000123
  • Printable ASCII characters excluding comma and semicolon up to a 20-character string.
    Firmware revision example: 0

NOTE
The *IDN? query will always indicate that the firmware revision is zero. SYSTem:APPLication[:CURRent]:REVision? is the recommended way to query the firmware revision.

Related Topics

*IDN?


Configuring the Test Set's LAN

Configuring the Test Set's LAN

Last updated: December 2, 2008

Description

LAN IP Address

CAUTION
Always verify that the test set is responding to a new LAN IP Address by pinging the test set. If the test set does not respond to the ping, cycle power. This will ensure that the test set will respond to the new LAN IP Address.

The LAN address is a character string with a maximum of 15 characters and a format of A.B.C. D where A is between 0 and 223 (excluding 127, which is assigned for use as the Internet host loopback address), and B, C, and D are between 0 and 255. No embedded spaces are allowed. The address may be manually set/viewed in the system configuration screen. The LAN address can be set/queried using the SYSTem subsystem.

The LAN address is a non-volatile parameter. The LAN address is not affected by any reset operation and can only be changed by direct access to the parameter itself.

NOTE
If the LAN address is set to a different network class, the subnet mask will change to the default net mask for the new network class.

For convenience the DATA port on the front panel may be configured as a LAN port. When an RJ45 jumper cable, (part number E5515-61160) is connected from the LAN PORT on the rear panel, to the ETHERNET TO FRONT PANEL port also on the rear panel, the user has LAN access from the front panel of the test set. Without the RJ45 jumper cable, the test set connection to a LAN is the rear-panel, LAN PORT connector.

The LAN address cannot be changed when the Operating Mode is set to Active Cell .

LAN Default Gateway

The LAN router, (default gateway), is a character string with a maximum of 15 characters and a format of A, B, C, D, where A is between 0 and 223 , and B, C, and D are between 0 and 255, no embedded spaces are allowed. If the default gateway is set to a format not allowed with the LAN address or the subnet mask that have been selected, the default gateway will be set to a null string, indicated by a blank field on the test set display. The address may be manually set/viewed in the system configuration screen. The LAN default gateway can be set/queried using the SYSTem subsystem.

The LAN default gateway is the address of a router that routes messages between networks and or subnets. If this value is not specified, LAN communications will be limited to the network and subnet specified by the LAN IP address and the subnet mask. Your network administrator will know if a default gateway is needed and if so, the address of the router. If the default gateway address is not needed by your network, it may be disabled by entering any of the following values: "0" (zero), "" (null string), "0.0.0.0"

The LAN default gateway is a non-volatile parameter. The LAN default gateway is not affected by any reset operation and can only be changed by direct access to the parameter itself.

LAN Subnet Mask

The LAN subnet mask address is a character string with a maximum of 15 characters and a format of A, B, C, D, where A , B, C, and D are between 0 and 255. No embedded spaces are allowed. The address may be manually set/viewed in the system configuration screen. The LAN subnet mask address can be set/queried using the SYSTem subsystem.

The subnet mask number combined with the IP address identifies which network and subnet your computer is on. Contact your system administrator for the correct subnet mask for your network.

The subnet mask determines the boundaries between the subnet ID and the host ID.

The LAN subnet mask is a non-volatile parameter. The LAN subnet mask is not affected by any reset operation and can only be changed by direct access to the parameter itself or by changes to the LAN IP Address.

NOTE
If the LAN address is set to a different network class, the subnet mask will change to the default net mask for the new network class.

The subnet mask number is obtained from your network administrator.

LAN 2 PORT

NOTE
You may not be able to set the LAN 2 PORT address due to hardware restriction. Contact your sales representative for more information.

The LAN 2 PORT allows you to use the Data Channel functionality with High Data Rate. To use the Data Channel functionality (to establish a Packet Data connection, for example), you must connect your data server to the LAN 2 PORT , rather than to the LAN 1 PORT as in the past.

LAN 1 PORT is still used for all other LAN operations such as protocol logging, firmware downloads and screen captures.

You must configure the address of the LAN 2 PORT using the LAN IP Address 2 (Data+) setting (see Configuring the Test Set's LAN for general information about LAN IP addresses). LAN IP Address 2 (Data+) must not be identical to the LAN IP Address setting, and must be on the same subnet as the LAN IP Address setting. If LAN IP Address or Subnet Mask is changed such that LAN IP Address 2 (Data+) is identical to or is no longer on the same subnet as LAN IP Address , then LAN IP Address 2 (Data+) is set to 0.0.0.0 and a warning is posted.

Manual operation: LAN IP Address 2 (Data+) is accessible from the Instrument Setup menu on the System Config Screen .

Related Topics

SYSTem:COMMunicate:LAN[:SELF]:ADDRess


Amplitude Offset

Amplitude Offset

Last updated: December 2, 2008

Description

Amplitude offsets compensate for loss or gain between the test set's RF IN/OUT front panel connector and the mobile station's RF connector.

To access the amplitude offset feature, press the SYSTEM CONFIG key, followed by the RF IN/OUT Amptd Offset ( F5 ) key.

Amplitude offset settings are preserved during power cycles or instrument preset.

Setting Up Amplitude Offsets and Frequency Points

Up to 20 frequency points can be assigned an amplitude offset. Negative amplitude offset values should be entered when there is a loss through the RF cabling and test fixtures and positive values should be entered when there is a gain.

The RF IN/OUT Amplitude Offset table displays the current (on/off) state of the amplitude offset feature. There are also 20 rows for entering frequencies and 20 rows for entering corresponding offset values. To enter values in the table use the RF IN/OUT Amplitude Offset Setup menu.

To set up amplitude offsets remotely, one comma-separated string is sent to set up frequency points and another comma-separated string assigns the corresponding amplitudes.

GPIB Commands

OUTPUT 714;"SYSTEM:CORRECTION:SFREQUENCY 1710.2 MHZ,1805.2 MHZ,1784.8 MHZ,1879.8 MHZ"
!sets the first 4 frequencies in the amplitude offset table.

OUTPUT 714;"SYSTEM:CORRECTION:SGAIN -2.55,-3.12,-3.68,-4.23"
!sets the first 4 amplitude offsets in the amplitude offset table.

Turning amplitude offsets on/off

When the RF IN/OUT Amplitude Offset State is on, all offsets that are not individually turned off are applied and the word "Offset" appears in the Instrument Status Area of the test set's display.

If the RF IN/OUT Amplitude Offset State is off, none of the amplitude offsets are applied.

GPIB Command

OUTPUT 714;"SYSTEM:CORRECTION:STATE ON"
!Sets the RF IN/OUT Amplitude Offset State to On

NOTE
If the RF IN/OUT Amplitude Offset State is turned off , none of the amplitude offsets are on, even if values are entered for the individual offsets.

Examples of Amplitude Offset Behavior

When the amplitude offset table entries accurately represent the loss in all components (cabling, connectors, and test fixturing) in the signal path between the test set and the mobile station, the test set will make the necessary adjustments in both receiver and transmitter measurements.

Mobile Station Receiver Example

When you set a transmit power level, the test set uses the amplitude offset value to adjust the power so that the test set's transmit power level refers to the power level received at the mobile station.

As shown in Amplitude Offset Mobile Station Receiver Example , with the test set's transmit power set to -85 dBm and a -3 dB amplitude offset the actual power level transmitted from the test set will be automatically offset to -82 dBm. With a 3 dB loss in the signal path the mobile station will receive -85 dBm, the actual setting.

Amplitude Offset Mobile Station Receiver Example

Mobile Station Transmitter Example

When you measure power from the mobile station, the displayed and queried values are offset to show the level at the mobile station.

As shown in Amplitude Offset Mobile Station Transmitter Example , with the mobile station transmitting 12 dBm and a -3 dB amplitude offset is entered, the measured power at the test set would be 9 dBm. The displayed power level is automatically adjusted to 12 dBm to show the level at the mobile station.

If the expected power, which can be set manually or automatically is 12 dBm, the test set's internal hardware adjusts itself to receive 9 dBm which is the actual power from the mobile station after 3 dB loss in the network.

Amplitude Offset Mobile Station Transmitter Example

Amplitude Offsets Between Frequency Settings

If mobile station testing is performed at frequencies that do not have amplitude offsets assigned to them, the test set will estimate an amplitude offset based on the nearest settings. For example, the following screen shows five amplitude offsets for frequencies ranging from 890.2 MHz to 1710.2 MHz.

RF IN/OUT Amplitude Offset Setup

For test frequencies between the lowest (890.2 MHz) and highest (1710.2 MHz) frequency points that are not entered in the table, the test set will calculate offsets using piece-wise linear interpolation.

The graph shown in Amplitude Offset Interpolation is a conceptual representation of the test set's amplitude offset configuration using the settings from the RF IN/OUT Amplitude Offset table in RF IN/OUT Amplitude Offset Setup . Each of the five points are shown on a non-scaled frequency versus amplitude offset graph. At a test frequency of 890.4 MHz, which is midway between point number one (-1 dB) and point number two (-2 dB) the test set applies an offset of -1.5 dB. Be aware that since amplitude offsets are in units of dB, this piece-wise linear interpolation does not produce a linear transition from point to point.

Amplitude Offset Interpolation

If testing is done outside the range of frequencies bounded by the lowest and highest frequency entries, the test set simply uses the amplitude offset that is paired with the nearest frequency point.

IMPORTANT
It is highly recommended that amplitude offsets are set up for each test frequency. This eliminates inaccuracies due to the mismatch between the test set's linear interpolation and the actual frequency response of the RF path between the test set and mobile station.

Related Topics

SYSTem:CORRection


Application Name

Application Name

Last updated: December 2, 2008

Description

The following queries give you details about the application name. To query or switch applications you must use the application's name as it appears in the catalog (without regard to case).

  • To query the name of the all applications installed in the test set use this GPIB query.

OUTPUT 714;"SYSTEM:APPLICATION:CATALOG:NAME?"

  • To query the name of the selected application (running or not) use this GPIB query.

OUTPUT 714;"SYSTEM:APPLICATION:SELECT:NAME?"
  • To query the name of the currently running application use this GPIB query.

OUTPUT 714;"SYSTEM:APPLICATION:CURRENT:NAME?"

  • To query the number of applications installed in the test set use this GPIB query.

OUTPUT 714;"SYSTEM:APPLICATION:CATALOG:NAME:COUNT?"

The application names can also be displayed in the Application Setup menu on the test set's display.

Related Topics

SYSTem:APPLication


Application Revisions and Licenses

Application Revisions and Licenses

Last updated: December 2, 2008

Description

Different revisions of the applications in your test set provide different capabilities. The selected application revision is loaded after the next application switch or power cycle of the test set. Once you select a revision the revision does not change unless you select another revision.

You can query the selected revision, all available revisions, and the total count of available revisions for a selected application. These queries are helpful when selecting revisions but are not usually necessary when switching applications.

NOTE
The Agilent E1960A GSM Mobile Test Application revisions prior to A.04.00 do not support application switching. If you select a revision prior to A.04.00 you will not have a path to switch back to later revisions.

If you accidentally switch to a non-supported revision, use the firmware upgrade process to load firmware with the correct revision.

Application Revision Queries and Commands

These are commands to query revision information or select a revision.

  • To query a selected application revision (running or not) use this GPIB command:

OUTPUT 714;"SYSTEM:APPLICATION:SELECT:REVISION? `AMPS/136 MOBILE TEST'"
  • To query the revision of the application currently running use this GPIB command:

OUTPUT 714;"SYSTEM:APPLICATION:CURRENT:REVISION?"
  • To query all of the revisions available for a application use this GPIB command:

OUTPUT 714;"SYSTEM:APPLICATION:CATALOG:REVISION? `AMPS/136 MOBILE TEST'"
  • To select a revision of an application use this GPIB command:

OUTPUT 714;"SYSTEM:APPLICATION:SELECT:REVISION `GSM mobile test','A.04.01'"

    After switching to a different revision of your application, you may need to calibrate the test set. See the on-line reference guide for your application for more information.

  • To query the number of revisions for a specified application:

OUTPUT 714;"SYSTEM:APPLICATION:CATALOG:REVISION:COUNT? `GSM MOBILE TEST'"

Application License Status Query

The application license status can be queried for a particular application and revision using the following GPIB query:

OUTPUT 714;"SYSTEM:APPLICATION:CATALOG:LICENSE? `GSM mobile test','A.04.01'"

This query returns one of the following:

  • "LIC" - This revision of application appears to have a LICense. The application may have been developed before licensing and therefore needs no license.
  • "NLIC" - This application does not appear to have a license. Selecting a Not LICensed revision will result in an error +130.
  • "PART" - Some PART of the application does not appear to have a license.
  • "UNKN" - This application has UNKNown license status.

You can also query a list of all licensed applications, formats and features using the following GPIB query:

OUTPUT 714;"SYSTem:APPLication:CATalog:LICense:APPLication:ALL?"

NOTE
If you switch to a not licensed revision the test set will reboot to the SYSTEM CONFIG screen. You will be unable to select any other screen or make any measurements. Query or view the Application Setup menu to determine the licensed versions of applications available.

Revision and license information can be viewed and selected from the SYSTEM CONFIG screen, by selecting the Application Setup menu. Revisions are shown with their license status. After the revision number is a letter. That letter indicates the revision license status; Licensed "L", Not Licensed "N", or Unknown "U".

  • "L"- This revision of application appears to have a License. The application may have been developed before licensing and therefore needs no license.
  • "N" - This application does not appear to have a license. Selecting a Not licensed revision will result in an error +130.
  • "P" - Some Part of the application does not appear to have a license.
  • "U" - This application has Unknown license status.

Related Topics

Application Switching


Configuring System Time and Date

Configuring System Time and Date

Last updated: December 2, 2008

Description

The test set provides the following time and date settings:

  • Time

    This field provides entry of the local time in hours and minutes.

    The Universal Coordinated Time field will track changes made to the Time field.

  • Date

    This field provides entry of the local date.

  • Universal Coordinated Time (UTC)

    Also known as Zulu, Greenwich Mean Time, or UCT, this field provides entry of universal time in hours and minutes.

    The Time field will track changes made to the Universal Coordinated Time (UTC) field.

  • Universal Coordinated Time (UTC) Date
  • Time Zone

    The Time Zone field provides entry of a time offset to the universal coordinated time (UTC). Based on each new time zone setting and the current UTC, a new local time value is calculated and automatically entered into the Time field.

These features are accessed by pressing the SYSTEM CONFIG hardkey followed by the Instrument Setup ( F1 ) softkey.

Related Topics

SYSTem:DATE


Application Switching

Application Switching

Last updated: December 2, 2008

Description

Different radio formats (such as GSM, AMPS, CDMA 2000 or TIA/EIA 136) can be tested when additional applications are purchased from Agilent Technologies. The test set allows you to switch between different applications. A reboot is necessary to make a newly selected application functional. The reboot happens automatically when the you tell the test set to switch applications. Switching to another application takes about one minute.

Some radio formats are combined as fast switching applications. Switching formats in a fast switching application takes less than 2 seconds.

Application Switching GPIB Command

In order to switch to another application use this GPIB command:

OUTPUT 714;"SYSTEM:APPLICATION:SELECT:NAME `GSM MOBILE TEST'"

Sending this command causes the test set to reboot.

Application Revision and Licensing

Each application must have a valid license and revision to function. Licensed revisions of applications are available from Agilent Technologies.

It may take several seconds before revision, model, and name information is returned.

Application Switching Programming Example

This program example shows you how to switch to the GSM Mobile Test Application.

  1. Query the list of application names to get exact spelling of the GSM Mobile Test Application. This is not necessary if you already know the exact name.
  2. Query the test set to get a list of all revisions for "GSM Mobile Test." This is not necessary if you are not changing revisions.
  3. Select a revision of "GSM Mobile Test." This is required if you are changing revisions.
  4. Select the GSM test application. This will switch applications and cause the test set to reboot.

10    OUTPUT 714;"SYSTEM:APPLICATION:CATALOG:NAME?"
20    !Queries all of the application names
30    ENTER 714;N$
40    PRINT "The CATALOG names that are loaded are ";N$
50    OUTPUT 714;"SYSTEM:APPLICATION:CATALOG:REVISION? `GSM MOBILE TEST'"
60    !Queries all revisions of GSM MOBILE TEST
70    ENTER 714;Cat_rev$
80    PRINT "The revisions for the GSM Mobile Test Application are ";Cat_rev$
90    OUTPUT 714;"SYSTEM:APPLICATION:SELECT:REVISION `GSM MOBILE TEST','A.04.01'"
100   !Selects a revision
110   OUTPUT 714;"SYSTEM:APPLICATION:SELECT:NAME `GSM MOBILE TEST'"
120   !Switches the application to GSM MOBILE TEST
130   END

Related Topics

Application Revisions and Licenses


Timebase Description/Configuration

Timebase Description/Configuration

Last updated: December 2, 2008

Description

The time base source is selected by the test set, either an internal time base or an external source (if a suitable signal is detected) is used as the reference oscillator. If a 10 MHz +/- 100 ppm signal, that has an input level from 0 to +13 dBm is connected to the 10 MHz REF IN connector on the rear panel, the test set will automatically select the external timebase.

You can read the status window at the bottom of the test set display for the EXT REF indicator, or query the test set to verify if it is using an external time base or an internal time base. You may also query the test set to verify if the time base is locked. The reference oscillator functionality is controlled through the SYSTEM subsystem.

Example:

OUTPUT 714;"SYSTEM:ROSCILLATOR[:TIMEBASE]?" !returns INT or EXT
                                            !(internal or external) timebase.
OUTPUT 714;"SYSTEM:ROSCILLATOR:LOCKED?" !returns 1 or 0 (locked or unlocked)
                                        !condition for timebase

Related Topics

SYSTem:ROSCillator


User Calibration Summary

User Calibration Summary

Description

The test set provides the summary of the calibration that have been performed, which includes:

  • The exact time and temperature at which the calibration are performed, and whether the calibration is passed
  • CDMA GPSOne Time offset for both US Cellular and PCS band
  • Current Operating Temperature

The calibration summary are accessed by pressing the SYSTEM CONFIG hardkey followed by the User Calibration Summary ( F11 ) softkey. The following figure shows a typical user calibration summary.

Related Topics

Calibrating the Test Set


DUT PDP Setup

DUT PDP Setup

Last updated: December 2, 2008

This section is only applicable to the lab application.

The test set can support up to a maximum of four primary PDP Contexts at present. Since each primary PDP Context has its own IP address and QoS Profile, there are four DUT IP addresses and four sets of QoS Profiles that can be configured in the test set. You can set the reliability class, traffic class and traffic handling priority of each QoS Profile.

DUT IP Address

You can enter up to a maximum of four DUT IP addresses for your DUT, each one associates with a PDP Context. All DUT IP addresses are constrained to be unique and within the same IP subnet as the LAN address of the instrument. Any attempt to enter a DUT IP address outside this range is rejected and an error message generated. If the LAN address of the instrument is changed to a value outside the current subnet then all configured DUT IP addresses are cleared and an error message generated. Similarly if the subnet mask is changed to a value that makes any DUT IP address is outside the same subnet as the instrument LAN address, the DUT IP addresses are cleared and an error message generated.

These settings are non-volatile (they persist across partial and full presets and power-cycling the test set).

See IP Address Requirements for more information.

GPIB command: CALL:MS:IP:ADDRess[1]|2|3|4

DNS Server IP Addresses

As part of the PS data call setup procedures, the MS can include PPP/IPCP messages that ask the network for the IP addresses of the DNS servers that it should use to resolve domain names. These PPP/IPCP messages are carried as part of the PDP Context Activation message and in them the MS can request either the Primary DNS Server address or the Secondary DNS Server address or both. If the MS requests either one or both of the DNS server addresses and they are set to 0.0.0.0, the test set does not respond to the MS, returns an error, and then proceeds with the PDP Context Activation. If the MS requests both of the DNS server addresses and either one contains a value other than 0.0.0.0, that address is sent to the MS.

These settings are non-volatile (they persist across partial and full presets and power-cycling the test set).

You can set the Primary and Secondary DNS Server IP Address for the DUT. The GPIB command to set the Primary DNS Server IP Address is CALL:MS:DNSServer:PRIMary:IP:ADDRess . Then GPIB command to set the Secondary DNS Server IP Address is CALL:MS:DNSServer:SECondary:IP:ADDRess .

QoS Profile

For each DUT IP Address one Primary PDP context and up to three secondary PDP contexts are available in the test set. You can set the QoS Profile for each PDP context. Upon receiving the Activate PDP Context Request message from the DUT, the test set sends the Activate PDP Context Accept message to allocate a QoS Profile to the DUT. The allocation of QoS Profile is based on the following rules:

  • If the MS requests an IP address and a QoS Profile the IP address shall take precedence in matching the context.
  • If the MS requests its subscribed QoS, it is supplied with the first free IP address and the associated QoS Profile.
  • If the MS request matches an unused QoS Profile and the QoS Profile is also associated with a free IP address, that IP address and associated QoS Profile is given to the MS.
  • If the MS request matches more than one defined QoS Profiles, it is supplied with the first free IP address associated with the matched QoS Profile.
  • If the MS requests a QoS Profile that does not match a predefined one the first free IP address and associated QoS Profile is given to the MS.
  • If a PDP Context is requested and no DUT IP address is available, for example, all the DUT IP addresses are either null or already been assigned to another PDP Contexts, then the PDP Context Request will be rejected with the cause code Insufficient Resources .

You can configure the Override Requested Reliability Class, Subscribed Reliability Class, Traffic Class and Traffic Handling Priority for each QoS Profile.

Override Requested Reliability Class

If the MS requests a particular reliability class in its Activate PDP Context Request message, you can configure the test set to override this request and instead, assign the reliability class you have chosen. This value is sent only if the state of the Override Requested Reliability Class parameter is turned on.

You can use CALL:PPRocedure[:QOSProfile[1]|2|3|4]:PDPContext:AACCept:QOService:RCLass:ENForce:STATe to set the Override Requested Reliability Class state, CALL:PPRocedure[:QOSProfile[1]|2|3|4]:PDPContext:AACCept:QOService:RCLass:ENForce:VALue to set the Override Requested Reliability Class value, use CALL:PPRocedure[:QOSProfile[1]|2|3|4]:PDPContext:AACCept:QOService:RCLass:ENForce:[SVALue] to set the state and value simultaneously.

Subscribed Reliability Class

Instead of requesting a specific reliability class, the MS can also request its subscribed class within the request message. You can specify the subscribed class to be sent to the MS. This value is sent only if the state of the Override Requested Reliability Class parameter is turned off.

The GPIB command to set Subscribed Reliability Class is CALL:PPRocedure[:QOSProfile[1]|2|3|4]:PDPContext:AACCept:QOService:RCLass:SUBScribed .

NOTE
The Subscribed Reliability Class is only applicable for pre R99 PDP Context Request messages.

Traffic Class

You can specify the Traffic Class for each QoS Profile. Traffic classes have increasing priority according to the order Background, Interactive, Streaming and Conversational. Conversational class is for traffic which is very delay sensitive while background class is the most delay insensitive traffic class.

Traffic Class is sent to MS if an Activate PDP Context request is accepted.

The GPIB command to set Traffic Class is CALL:PPRocedure[:QOSProfile[1]|2|3|4]:TCLass .

Traffic Handling Priority

Traffic Handling Priority specifies the relative importance for handling of the SDUs (Service Data Units) for each QoS Profile. Traffic Handling Priority is ignored if the Traffic Class is conversational, streaming or background.

Traffic Handling Priority is sent to MS if an Activate PDP Context request is accepted.

The GPIB command to set Traffic Handling Priority is CALL:PPRocedure[:QOSProfile[1]|2|3|4]:THPRiority .

Packet Flow Identifier (PFI)

Packet Flow Contexts are optionally supported in the network to manage the Quality of Service (QoS) between multiple Packet Flows. A Packet Flow is used to identify the transfer through a collection of one or more Logical Link Control (LLC) layer Service Access Points (SAPs) which are governed by a similar Quality of Service (QoS). Individual Packet Flows are uniquely identified by a Packet Flow Identifier (PFI) value which is determined by the Serving GPRS Support Node (SGSN) in the core network. A Packet Flow Context (PFC) is essentially the information structure associated between the Base Station Subsystem (BSS) and the SGSN associated with a specific Packet Flow, whereby the PFC is addressed by a Packet Flow Identifier (PFI) value assigned by the SGSN.

The PFI associated with a particular packet flow between the network and the DUT is initially provided by the SGSN during PDP Context establishment. Multiple PDP Contexts may share or be associated to the same PFC and the PFC can be used to determine whether a common physical resource may be used to multiplex data from multiple PDP Contexts or whether individual resource/TBF are required for different PDP Contexts.

The Packet Flow Identifier can be set as one of the following values:

  • 0: Best-Effort
  • 2: Short Message Service
  • 8-127: Dynamically assignable range

Before using the PFI parameter, you must set the Packet Flow Context State to ON, the GPIB command to set the Packet Flow Context State is CALL[:CELL]:PFContext[:STATe] . The GPIB command to set the PFI for each QoS Profile is CALL:PPRocedure[:QOSProfile[1]|2|3|4]:PFI .

Operating Consideration

The PDP Context Modification procedure is not supported in the test set, once a PDP context has been established changing the associated QoS Profile shall result in the deactivation of the PDP context.

Related Topics

GSM Circuit Switched Data (CSD)


IP Address Requirements

IP Address Requirements

Last updated: December 2, 2008

Description

The test set provides a field for entering the IP Address for a wireless device being tested using the packet and CS (circuit switched) data channels.

There are two requirements for the DUT IP Address field:

  1. The network portion (see IP Address Formatting ) of the wireless device's DUT IP address must be the same as the network and subnet portion of the test set's LAN IP Address.
  2. The host portion of the wireless device's DUT IP address must be unique. (It should not be the same as any other host on the network or subnet that the test set is connected to.) In other words, DUT IP Address must be set to a different value in all test sets within the same network. Further, each DUT IP Address within the test set ( DUT IP Address , DUT IP Address 2 , etc.) must be set to a different value.

How Network Addresses Are Assigned

Network IDs are assigned by the NIC (Network Information Center). The network portion (first two bytes) of the class B address in the example above would be acquired from the NIC by a network administrator to avoid conflicts with other networks. The network administrator is then free to allocate subnets as needed since subnetting is not visible outside the network.

If you do not know the IP address the test set and/or DUT should be set to, or which unique host IDs are available, you should contact your network administrator.

How to Interpret IP Addresses

The network portion of the LAN IP Address depends on the address classification as shown below:

LAN IP Address Classification

Class A = 1.0.0.0 to 127.255.255.255
Class B = 128.0.0.0 to 191.255.255.255
Class C = 192.0.0.0 to 223.255.255.255
Class D = 224.0.0.0 to 247.255.255.255

An IP Address consists of a 4-byte (32 bit) number. Each byte is in a decimal form separated from other bytes by a dot. This is referred to as a "dotted decimal" format.

NOTE
The test set does not allow LAN IP Addresses in the range of 127.0.0.0 to 127.255.255.255 because these addresses are assigned for use as the Internet host loopback address.

The IP address class defines which bytes contain the network portion of the address. For Class A addresses, the first byte from the left identifies the network. For class B it is the first two bytes from the left, and for class C it is the first three bytes. Class D addresses are multicast, which are used when a datagram is directed to multiple hosts. See IP Address Formatting .

IP Address Formatting
Class | Byte 1 | Byte 2 | Byte 3 | Byte 4
A | Network | Host
B | Network |  | Host
C | Network |  |  | Host
D | Multicast

Determining the Test Set's Network Address

If the test set's LAN IP Address is set to 130.29.183.121, as shown below, the first two bytes represent the network portion since this is a Class B address.

If the test set is on a subnet, the Subnet Mask must be applied to determine the subnet address. This is done by performing bit-wise AND logic between the binary values of the LAN IP Address and Subnet Mask. See Applying the Subnet Address .

Applying the Subnet Address
LAN IP Address | 130 |  |  |  |  |  |  |  | 29 |  |  |  |  |  |  |  | 183 |  |  |  |  |  |  |  | 121
Subnet Mask | 255 |  |  |  |  |  |  |  | 255 |  |  |  |  |  |  |  | 255 |  |  |  |  |  |  |  | 0
Subnet Mask (Binary) | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0
LAN IP Address (Binary) | 1 | 0 | 0 | 0 | 0 | 0 | 1 | 0 | 0 | 0 | 0 | 1 | 1 | 1 | 0 | 1 | 1 | 0 | 1 | 1 | 0 | 1 | 1 | 1 | 0 | 1 | 1 | 1 | 1 | 0 | 0 | 1
Subnet Address (Binary) | 1 | 0 | 0 | 0 | 0 | 0 | 1 | 0 | 0 | 0 | 0 | 1 | 1 | 1 | 0 | 1 | 1 | 0 | 1 | 1 | 0 | 1 | 1 | 1 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0
Subnet Address | Network130 |  |  |  |  |  |  |  | Network 29 |  |  |  |  |  |  |  | Subnet 183 |  |  |  |  |  |  |  | Host 0

As shown in the table above, the Subnet Mask splits the 16 bit host portion of the class B address into an 8-bit subnet ID and an 8-bit host ID.

In this example the DUT IP Address would need to be set to 130.29.183.XXX to match the test set's subnet ID. The host portion of the LAN IP Address is identified by the bits corresponding to the 0 bits in the Subnet Mask. Therefore, the last byte in the DUT IP Address must not be 121 or any address that corresponds with any other host on the subnet at 130.29.183.XXX

This setting is non-volatile (it persists across partial and full presets and power-cycling the test set).


E1968A, E6701E/F/T/U, E6704A GSM/GPRS/EGPRS Online User's Guide

Revision 2008-12-08

What's New in the User's Guide?

  • The contents have been updated and now include documentation for the E6701G GSM/GPRS/EGPRS Mobile Lab Application revision G.00.00. The E6701G is a subscription release to anyone with a current GSM/GPRS/EGPRS Lab Application Annual Contract.

  • If you have an older GSM/GPRS/EGPRS application, then this guide will contain features that are not available in your application. Refer to the Release Notes to determine what these features are and to download the guide that is specific to your application.

Take Advantage of Your GSM, GPRS, and EGPRS Mobile Test and Lab Applications

  • Click on the links in the Contents box to find specific information about your test and lab application.

  • If you are unfamiliar with this product, or don't know where to find the information you need, see Getting Started with the GSM/GPRS/EGPRS Test and Lab Applications .

  • The User's Guide is updated frequently. Check the web monthly to verify that you have the latest version of this guide:

http://www.agilent.com/find/e1968a.

  • The online version of this guide is available at:

http://wireless.agilent.com/rfcomms/refdocs/gsmgprs/


E6701T User Documentation

E6701T User Documentation

Last updated: December 2, 2008

The features and functionality present in the E6701T Special GSM/GPRS/EGPRS Lab Application are identical to those offered in the E6701E GSM/GPRS/EGPRS Lab Application, with the exceptions described in this document. For information on how to use the features that are common to the E6701E and E6701T, see the GSM/GPRS/EGPRS online user's guide located at:

http://wireless.agilent.com/rfcomms/refdocs/gsmgprs/default.php

The E6701T can only be loaded onto an E5515C with Special High Data Rate Hardware (or a test set with the equivalent hardware upgrades). Contact your local Agilent Sales Representative for more information, or visit www.agilent.com/find/8960upgrades.

In a test set with Special High Data Rate Hardware, the standard Protocol Processor is replaced with a High Data Rate Protocol Processor, and the test set's rear panel is modified to include a new LAN 2 PORT , which you must use for sending data to the test set (previously the LAN 1 PORT was used for this purpose).

LAN 2 PORT

The Special High Data Rate Hardware required to run the E6701T includes a modified rear panel with a new LAN 2 PORT . To use the E6701T Data Channels functionality (to establish an Packet-Switched Data connection, for example), you must connect your data server to LAN 2 PORT , rather than to LAN 1 PORT as in the past. LAN 1 PORT is still used for all other LAN operations such as protocol logging, firmware downloads and screen captures.

The LAN 2 PORT connects directly to the test set's High Data Rate protocol processor, as shown in the block diagram below.

You must configure the address of the LAN 2 PORT using the LAN IP Address 2 (Data+) setting (see Configuring the Test Set's LAN for general information about LAN IP addresses). LAN IP Address 2 (Data+) must not be the identical to the LAN IP Address setting, and must be on the same subnet as the LAN IP Address setting. If LAN IP Address or Subnet Mask is changed such that LAN IP Address 2 (Data+) is identical to or is no longer on the same subnet as LAN IP Address , then LAN IP Address 2 (Data+) is set to 0.0.0.0 and a warning is posted.

LAN IP Address 2 (Data+) is accessible from the Instrument Setup menu on the System Config Screen . The GPIB command for LAN IP Address 2 (Data+) is SYSTem:COMMunicate:LAN[:SELF]:ADDRess2<sp><string> . See SYSTem:COMMunicate:GPIB:[:SELF]:ADDRess for range information.

External Device Connection/Two-Cell Test System Considerations

  • When establishing an External Device Connection using one or more test sets running the E6703U, you must connect both the LAN 1 PORT and LAN 2 PORT to the LAN switch.
  • When establishing an External Device Connection from a test set running the E6703U, the destination test set displays the E6703U's LAN IP Address 2 (Data+) under Connected Device IP Address .
  • When establishing an External Device Connection to a test set running the E6703U, you must set the originating test set's Ext 8960 IP Addr to the LAN IP Address 2 (Data+) of the E6703U test set (unless you've connected the two test sets via a hub and have connections to the E6703U test set's LAN 1 PORT and LAN 2 PORT ; in that case you can set Ext 8960 IP Addr to the E6703U test set's LAN IP Address or LAN IP Address 2 (Data+) .)
  • When performing two-cell PS data transfer cell reselections (see Two-Cell Test System ), the data rate is limited by the data rate capability of the test set that established the PDP context with the mobile. This is because when a mobile has an active PDP context with one test set and transitions to another, a tunnel is created to route data to and from the mobile via the originating test set. The originating test set must continue to act as the end-point for the IP connection, regardless of the location of the mobile, and to forward any received packets to the test set currently serving the mobile. Thus, to achieve high data rates during cell reselection using a high data rate test set and a standard test set, you must start the PDP context on the high data rate test set.

Additional Information

  • The SYSTem:APPLication:CATalog[:NAME]? query includes "1xEV-DO Lab App T" , "CDMA 2000 Lab App T" , "GSM/GPRS Lab App T" , "GSM/GPRS_WCDMA Lab App T" and "WCDMA Lab App T" .
  • The SYSTem:APPLication:CATalog:LICense:APPLIcation:ALL? query includes "E6701T","GSM/GPRS LA rev T" , "E6702T","CDMA2000 LA rev T" , "E6703T","WCDMA LA rev T" , "E6706T","1xEV-DO LA rev T" , "E6706T-102","1xEV-DO Re A ETAP" and "E6785T","GSM/GPRS_WCDMA LA rev T" .
  • In the E6701T, the SYSTem:APPLication[:CURRent][:NAME]? query returns "GSM/GPRS Lab App T" .
    Note: You must have the E6704A license to support EGPRS in the E6701T.


E6701U User Documentation

E6701U User Documentation

Last updated: December 2, 2008

The features and functionality present in the E6701U Special GSM/GPRS/EGPRS Lab Application are identical to those offered in the E6701F GSM/GPRS/EGPRS Lab Application, with the exceptions described in this document. For information on how to use the features that are common to the E6701F and E6701U, see the GSM/GPRS/EGPRS online user's guide located at:

http://wireless.agilent.com/rfcomms/refdocs/gsmgprs/default.php

The E6701U can only be loaded onto an E5515C with Special High Data Rate Hardware (or a test set with the equivalent hardware upgrades). Contact your local Agilent Sales Representative for more information, or visit www.agilent.com/find/8960upgrades.

In a test set with Special High Data Rate Hardware, the standard Protocol Processor is replaced with a High Data Rate Protocol Processor, and the test set's rear panel is modified to include a new LAN 2 PORT , which you must use for sending data to the test set (previously the LAN 1 PORT was used for this purpose).

LAN 2 PORT

The Special High Data Rate Hardware required to run the E6701U includes a modified rear panel with a new LAN 2 PORT . To use the E6701U Data Channels functionality (to establish an HSDPA PS Data connection, for example), you must connect your data server to the LAN 2 PORT , rather than to the LAN 1 PORT as in the past. You must also use the LAN 2 PORT to establish an External Device Connection between two test sets.

LAN 1 PORT is still used for all other LAN operations such as protocol logging, firmware downloads and screen captures.

The LAN 2 PORT connects directly to the test set's High Data Rate protocol processor, as shown in the block diagram below.

LAN IP Address 2 (Data+)

You must configure the address of the LAN 2 PORT using the LAN IP Address 2 (Data+) setting (see Configuring the Test Set's LAN for general information about LAN IP addresses). LAN IP Address 2 (Data+) must not be identical to the LAN IP Address setting, and must be on the same subnet as the LAN IP Address setting. If LAN IP Address or Subnet Mask is changed such that LAN IP Address 2 (Data+) is identical to or is no longer on the same subnet as LAN IP Address , then LAN IP Address 2 (Data+) is set to 0.0.0.0 and a warning is posted.

Manual operation: LAN IP Address 2 (Data+) is accessible from the Instrument Setup menu on the System Config Screen .

GPIB command: SYSTem:COMMunicate:LAN[:SELF]:ADDRess2<sp><string> . See SYSTem:COMMunicate:GPIB:[:SELF]:ADDRess for range information.

External Device Connection/Two-Cell Test System Considerations

  • When establishing an External Device Connection using one or more test sets running the E6703U, you must connect both the LAN 1 PORT and LAN 2 PORT to the LAN switch.
  • When establishing an External Device Connection from a test set running the E6703U, the destination test set displays the E6703U's LAN IP Address 2 (Data+) under Connected Device IP Address .
  • When establishing an External Device Connection to a test set running the E6703U, you must set the originating test set's Ext 8960 IP Addr to the LAN IP Address 2 (Data+) of the E6703U test set (unless you've connected the two test sets via a hub and have connections to the E6703U test set's LAN 1 PORT and LAN 2 PORT ; in that case you can set Ext 8960 IP Addr to the E6703U test set's LAN IP Address or LAN IP Address 2 (Data+) .)
  • When performing two-cell PS data transfer cell reselections (see Two-Cell Test System ), the data rate is limited by the data rate capability of the test set that established the PDP context with the mobile. This is because when a mobile has an active PDP context with one test set and transitions to another, a tunnel is created to route data to and from the mobile via the originating test set. The originating test set must continue to act as the end-point for the IP connection, regardless of the location of the mobile, and to forward any received packets to the test set currently serving the mobile. Thus, to achieve high data rates during cell reselection using a high data rate test set and a standard test set, you must start the PDP context on the high data rate test set.


EGPRS Data Rate Configurations

EGPRS Data Rate Configurations

Last updated: December 2, 2008

This section is only applicable to EGPRS. This section assumes that you have the most recent hardware and software revisions in your test set. For details on what configurations your test set supports, see:

http://www.home.agilent.com/upload/cmc_upload/All/ms12table30905.html

IMPORTANT
You may need to upgrade the hardware in your test set to get the capability described here. If you install application firmware on a test set with incompatible hardware, the following may occur:

  • Your test set may lock up.
  • The application may not run.
  • Some features in the application may not be accessible, or may not perform to specifications.

Please review the hardware requirement information at

http://www.agilent.com/find/8960upgrades

to determine if a hardware upgrade is required for your testing needs.

This section details the test set's operation for the following:

  • Supported Configurations
  • Operating Considerations for Supported Configurations
  • All Configurations
  • Why use Unsupported Data Rate Configurations?

By default, the test set does not make available multislot configurations or modulation coding schemes that it does not support for combinations of the following parameters: Operating Mode, Connection Type, Multislot Configuration, and Modulation Coding Scheme (MCS).

Unsupported data rate configurations can be enabled using the CALL:DATA:RATE:CONFig command (see CALL:DATA:RATE:CONFig[:EGPRs] ) or from the test set's front panel (see How Do I Gain Access to All the EGPRS Multislot Configurations? ). The value of this parameter can be set to either Supported or All.

Supported Configurations

The test set provides consistent support for the configurations indicated by an LA or LA/TA in the following table, where LA signifies that the test set provides consistent support for the specified multislot configuration in the Lab Application and LA/TA signifies that the test set provides consistent support for the specified multislot configuration in both the Lab Application and the Test Application. The multislot configurations in the table are indicated as Downlink x Uplink. ETSI Type A, BLER, Auto, ETSI Type B (Unack), ETSI Type B (Ack), and SRB Loopback are all connection type parameters. MCS-1 through MCS-4 use GMSK modulation, while MCS-5 through MCS-9 use 8PSK modulation.

Supported Multislot Configurations by Operating Mode and Connection Type

 | Active Cell Operating Mode EGPRS Serving Cell |  |  |  |  |  | EGPRS BCH+PDTCH Operating Mode |  | All Configurations Allowed
 | ETSI Type A |  | BLER |  | Auto ETSI Type B (Unack) ETSI Type B (Ack) SRB Loopback
 | MCS-1 to MCS-4 | MCS-5 to MCS-9 | MCS-1 to MCS-4 | MCS-5 to MCS-9 | MCS-1 to MCS-6 | MCS-7 to MCS-9 | MCS-1 to MCS-4 | MCS-5 to MCS-9 | MCS-1 to MCS-9
1x1 | LA/TA | LA/TA | LA/TA | LA/TA | LA/TA | LA/TA | LA/TA | LA/TA | LA/TA
1x2 | LA/TA | LA/TA |  |  | LA/TA | LA/TA | LA/TA | LA/TA | LA/TA*
1x3 | LA/TA | LA/TA |  |  | LA/TA | LA/TA | LA/TA | LA/TA | LA/TA*
1x4 | LA/TA | LA/TA |  |  | LA/TA | LA/TA | LA/TA | LA/TA | LA/TA*
1x5 | LA/TA | LA/TA |  |  | LA/TA | LA/TA | LA/TA | LA/TA | LA/TA*
2x1 | LA/TA | LA/TA | LA/TA | LA/TA | LA/TA | LA/TA | LA/TA | LA/TA | LA/TA
2x2 | LA/TA | LA/TA | LA/TA | LA/TA | LA/TA | LA/TA | LA/TA | LA/TA | LA/TA
2x3 | LA/TA | LA/TA |  |  | LA/TA | LA/TA | LA/TA | LA/TA | LA/TA*
2x4 | LA/TA | LA/TA |  |  | LA/TA | LA/TA | LA/TA | LA/TA | LA/TA*
3x1 | LA/TA | LA/TA | LA/TA | LA/TA | LA/TA | LA/TA | LA/TA | LA/TA | LA/TA
3x2 | LA/TA | LA/TA | LA/TA | LA/TA | LA/TA | LA/TA | LA/TA | LA/TA | LA/TA
3x3 | LA/TA | LA/TA | LA/TA | LA/TA | LA/TA | LA/TA | LA/TA | LA/TA | LA/TA
4x1 | LA/TA | LA/TA | LA/TA | LA/TA | LA/TA | LA/TA | LA/TA | LA/TA | LA/TA
4x2 | LA/TA | LA/TA | LA/TA | LA/TA | LA/TA | LA/TA | LA/TA | LA/TA | LA/TA
5x1 | LA/TA | LA/TA | LA/TA | LA/TA | LA/TA | LA/TA | LA/TA | LA/TA | LA/TA

*Not available for the BLER connection type

See All Configurations for more details.

Operating Considerations for Supported Configurations

Attempting to set the test set to an unsupported downlink multislot configuration or modulation coding scheme generates the following warning messages

GPRS/EGPRS functionality restriction; Requested multislot configuration not supported .

GPRS/EGPRS functionality restriction; Requested modulation coding scheme not supported.

If you change the Connection Type to an option that makes the current multislot configuration and modulation coding scheme combination unsupported, the multislot configuration is reset to the default value of 2x1. For example, if the multislot configuration is 1x2 and the modulation coding scheme setting is MCS-5, changing the connection type from ETSI Type B to BLER causes the multislot configuration to return to the default value of 2x1.

All Configurations

To gain access to the multislot configurations and modulation coding schemes not indicated as supported in the table above, you must set the EGPRS Data Rate Configurations parameter value to All.

When you change the EGPRS Data Rate Configurations parameter value to All , the following warning message appears on the front panel screen:

Warning: Not all EGPRS data rate configurations are supported .

Remember that although you now have access to all EGPRS data rate configurations, the performance of those not supported by the test set is not guaranteed.

The following multislot configurations are not available in the EGPRS Test Application, regardless of the EGPRS Data Rate Configuration parameter setting:

  • 2 Down, 4 Up
  • 3 Down, 3 Up
  • 4 Down, 2 Up
  • 5 Down, 1 Up

NOTE
Multislot configurations that have more uplink timeslots than downlink timeslots are not available while the Connection Type is set to BLER , regardless of the EGPRS Data Rate Configuration parameter setting.

Why use Unsupported Data Rate Configurations?

While the test set may not currently guarantee support for all EGPRS data rate configurations, some unsupported configurations can still be used to verify your mobile station's capabilities if you need to perform a quick verification rather than intensive testing. When using unsupported configurations the following considerations apply:

  1. In general, unsupported configurations may work if you minimize other activities such as receiver measurements (or protocol logging in the lab application).
  2. If you want to use the data channel (lab application only) to verify your mobile station's ability to transmit 2 timeslots using 8PSK modulation use the following combination:
    • multislot configuration - 2x2
    • modulation coding scheme - MCS-5
    • connection type - Auto
    • data channel application - something with intermittent data like WAP transfers. (Avoid ftp transfers.)

    Additionally, you should perform activities such as receiver measurements and protocol logging one at a time. For example, turn off logging while performing a receiver measurement and turn off receiver measurements while using protocol logging. Unidirectional transfers such as uplink FTP or downlink FTP are also a good way to minimize loading in the downlink or uplink, respectively.

Related Topics

CALL:DATA:RATE:CONFig[:EGPRs]

How Do I Gain Access to All the EGPRS Multislot Configurations?

Gain Access to All EGPRS Data Rate Configurations

Modulation Coding Scheme/Puncturing Scheme (MCS/PS)

Supported Multislot Classes


Modulation Coding Scheme/Puncturing Scheme (MCS/PS)

Modulation Coding Scheme/Puncturing Scheme (MCS/PS)

Last updated: December 2, 2008

This section is only applicable to EGPRS when the test set's operating mode is EGPRS BCH + PDTCH.

Different modulation coding scheme / puncturing scheme (MCS/PS) values can be assigned to each downlink of a multislot burst if the operating mode is set to EGPRS BCH+PDTCH.

Modulation Coding Scheme / Puncturing Scheme Options

The MCSs are grouped by modulation type. MCS-1 through MCS-4 use GMSK modulation, while MCS-5 through MCS-9 use 8PSK modulation. The differences in data rates within these groups of MCSs is affected by the different modulation types in conjunction with puncturing and coding schemes. The amount of coding used for different MCSs decreases as the MCS number increases. Therefore, MCS-1 has the greatest amount of coding and the slowest data rate while MCS-4 has less coding and a higher data rate. MCS-9 doesn't use as much coding as MCS-5, 6, 7, or 8 and coupled with 8PSK modulation, achieves the highest data rate of all the MCS used by EGPRS.

You may specify a MCS/PS for each downlink burst in a multislot configuration. The following list contains all the MCS/PS available. The GPIB commands to assign separate MCS/PS to individual bursts are CALL:(PDTCH|PDTChannel):MCSCheme:EBPTest[:BURSt1] and CALL:(PDTCH|PDTChannel):MCSCheme:EBPTest:BURSt<2|3|4|5> .

  • GMSK / 8PSK Options

    Modulation coding schemes MCS1 through MCS4 use GMSK modulation while MCS5 to MCS9 use 8PSK modulation. The set of puncturing schemes available is different across different modulation coding schemes are shown in the table below.

    Modulation Coding Scheme (MCS)

    Data Rate

    (kb/s)

    Puncturing Scheme 1

    (PS1)

    Puncturing Scheme 2 (PS2)

    Puncturing Scheme 3 (PS3)
    MCS 1 | 8.8 | Yes | Yes | No
    MCS 2 | 11.2 | Yes | Yes | No

    MCS 3

             14.8 Yes Yes Yes
    MCS 4 | 17.6 | Yes | Yes | Yes
    MCS 5 | 22.4 | Yes | Yes | No
    MCS 6 | 29.6 | Yes | Yes | No
    MCS 7 | 44.8 | Yes | Yes | Yes
    MCS 8 | 54.4 | Yes | Yes | Yes
    MCS 9 | 59.2 | Yes | Yes | Yes

    NOTE
    Modulation Coding Schemes MCS7-MCS9 allow two data blocks to be embedded in each radio block. These data blocks can have the same or different puncturing schemes. For example, if you choose MCS9 PS 3-2 from the MCS / PS menu of the front panel, the test set uses MCS 9, with puncturing scheme 3 on the first data block and puncturing scheme 2 on the second data block. For more information, see How Do I Assign Different Modulation Coding Schemes / Puncturing Schemes to Each Downlink of a Multislot Burst? .

  • 8PSK ClearCoded

    When 8PSK ClearCoded is selected, no encoding is performed on the downlink. The GPIB command mnemonic for 8PSK ClearCloded is EPSKCC.

  • As Burst 1

    The As Burst 1 setting of this parameter uses the modulation coding scheme and puncturing scheme is assigned to the first burst of the multislot downlink. The As Burst 1 setting cannot be assigned to burst 1 of the multislot downlink. The GPIB command mnemonic for 8PSK ClearCloded is EPSKCC.

Operating Considerations

In order to assign different modulation coding schemes and puncturing schemes to each burst in a multislot downlink, the operating mode must be set to EGPRS BCH+PDTCH or EGPRS BCT+PDTCH+TCH.

Related Topics

How Do I Assign Different Modulation Coding Schemes / Puncturing Schemes to Each Downlink of a Multislot Burst?

CALL:(PDTCH|PDTChannel):MCSCheme:EBPTest[:BURSt1]

CALL:(PDTCH|PDTChannel):MCSCheme:EBPTest:BURSt<2|3|4|5>

EGPRS Data Rate Configurations

Supported Multislot Classes


How Do I Change the EGPRS Modulation Coding Scheme?

How Do I Change the EGPRS Modulation Coding Scheme?

Last updated: December 2, 2008

This section is not applicable to GSM or GPRS.

There are two ways to change the EGPRS downlink and uplink Modulation Coding Schemes (MCS):

  • B. Change the MCS immediately
  • C. Change the MCS during a handover

Both are explained below.

A. Configure the Serving Cell to EGPRS

  1. Press the CALL SETUP key.
  2. Press Operating Mode ( F1 ) and select Active Cell (EGPRS) .

B. Change the MCS immediately

  1. Press the CALL SETUP key.
  2. Press the PDTCH Parameters ( F9 ) key.
  3. Press the Modulation Coding Scheme ( F11 ) key.
  4. Select either Downlink Modulation Coding Scheme or Uplink Modulation Coding Scheme and set the value you want. The modulation format is different depending on the MCS you select:
    • MCS-1 through MCS-4 use a GMSK modulation format.
    • MCS-5 through MCS-9 use an 8PSK modulation format.
  5. Press the Close Menu ( F6 ) key.

C. Change the MCS during a handover

  1. Press the CALL SETUP key.
  2. Press the Handover Parameters ( F5 ) key.
  3. Press the EGPRS Handover Setup .
  4. Select either Downlink Modulation Coding Scheme or Uplink Modulation Coding Scheme and set the value you want. The modulation format is different depending on the MCS you select:
    • MCS-1 through MCS-4 use a GMSK modulation format.
    • MCS-5 through MCS-9 use an 8PSK modulation format.
  5. Press the Handover Execute ( F5 ) key to change the MCS, or press the Close Menu ( F6 ) key to leave the MCS unchanged.
  6. After the handover is executed, press the PDTCH Parameters ( F9 ) key, then Modulation Coding Scheme ( F11 ) to check that the MCS has been changed.


How Do I Change the Payload Pattern Sent to the Mobile Station?

How Do I Change the Payload Pattern Sent to the Mobile Station?

Last updated: December 2, 2008

Change the GSM Downlink Speech Payload

This procedure details how to access the speech payload.

  1. Press CALL SETUP .
  2. Press Operating Mode ( F1 ) and chose Active Cell (GSM) or GSM BCH + TCH . Note that speech data is transmitted on the downlink TCH.
  3. Press TCH Parameter s F8 .
  4. Press More on the bottom right corner to display the TCH Parms menu (2 of 2 ).
  5. Press Speech (F10) . This brings up the Speech menu (as shown below) with the list of choices for the Downlink Speech Source.

Change the GPRS/EGPRS Payload Pattern

This procedure details how to access the data payload pattern.

  1. Press CALL SETUP .
  2. Press Operating Mode ( F1 ) and chose the appropriate operating mode for the payload pattern. See Payload Pattern (BLER) or Payload Pattern (OTHER) for information on valid operating modes.
  3. Press More on the lower left corner to display the Control menu ( 2 of 2 ).
  4. Press the Protocol Control ( F4 ) to display a list of protocol layers.
  5. Press LLC (F3) .
  6. Press Payload Pattern (F2) . This displays a Payload Patterns menu similar to the figure below.

Related Topics

CALL:TCHannel:CUSTom:DATA


Configuring the Test Set and Starting a Data Connection for EGPRS Measurements

Configuring the Test Set and Starting a Data Connection for EGPRS Measurements

Last updated: December 2, 2008

This section is only applicable to EGPRS.

Test Set Configuration

How Do I Start a Data Connection?

Test Set Configuration

Setup parameters for this measurement are assumed to be set to their default (Full preset) values unless otherwise stated. This procedure also assumes that the BCH parameter for band is set up correctly for your mobile station and that the appropriate RF IN/OUT Amplitude Offsets have been set to offset loss between the mobile station and the test set.

  1. Press the CALL SETUP key.
  2. Press Operating Mode ( F1 ) and select Active Cell (EGPRS) .
  3. Press the Data Conn Type ( F2 ) key, and select ETSI Type A. (See Connection Types for other connection types that can be used with EGPRS measurements.)
  4. Select PDTCH Parameters ( F9 ) from the Call Parms menu.
  5. Select Modulation Coding Scheme ( F11 ) from the PDTCH Parms menu. The Modulation Coding Scheme popup menu appears.
  6. Select Uplink Modulation Coding Scheme and select one of the modulation coding schemes.

    NOTE
    If you wish to measure 8PSK modulated signals, select an MCS in the range of MCS-5 through MCS-9. MCS-1 through MCS-4 use GSMK modulation.

  7. Press the Close Menu ( F6 ) key.

How Do I Start a Data Connection?

  1. Connect the mobile.

  2. Turn the mobile on and wait for Attached in the Active Cell: field.

    NOTE
    For mobiles that don't perform an EGPRS attach automatically, set the mobile to data mode. For example, your mobile station may have a connectivity setting for GPRS that allows you to specify whether you are always on-line or only use GPRS when it is needed.

  3. Press the Start Data Connection ( F3 ) key and watch for the Active Cell: field changing to Transferring .


How Do I Gain Access to All the EGPRS Multislot Configurations?

How Do I Gain Access to All the EGPRS Multislot Configurations?

Last updated: December 2, 2008

This section is only applicable when the test set's operating mode is Active Cell (EGPRS). If you wish to gain access to all the EGPRS Multislot Configurations while the test set's operating mode is EGPRS BCH+PDTCH see Gain Access to All EGPRS Data Rate Configurations .

Some multislot configurations are not selectable by default when the system type is EGPRS. You can gain access to these configurations by setting the value of the EGPRS Data Rate Configuration parameter to All. However, the performance of the unsupported data rate configurations is not guaranteed.

CAUTION
You may need to upgrade the hardware in your test set before installing the application firmware described here. If you install application firmware on a test set with incompatible hardware, the following may occur:

  • Your test set may lock up.
  • The application may not run.
  • Some features in the application may not be accessible, or may not perform to specifications.

Please review the hardware requirement information at

http://www.agilent.com/find/8960upgrades

to determine if a hardware upgrade is required for your testing needs.

Procedure

  1. Press the CALL SETUP key.
  2. Press Operating Mode ( F1 ) and select Active Cell (EGPRS) .
  3. Select PDTCH Parameters ( F9 ) from the Call Parms menu.
  4. Press the More softkey on the right side of the front panel display to access the PDTCH Parms ( 2 of 3 ) menu.
  5. Press Multislot Config ( F7 ). Notice that some of the selections are grayed out.
  6. Press the More softkey on the right side of the front panel display to access the PDTCH Parms ( 1 of 3 ) menu.
  7. Select Modulation Coding Scheme ( F11 ) from the PDTCH Parms menu. The Modulation Coding Scheme popup menu appears.
  8. Scroll to EGPRS Data Rate Configurations and select All from the pop-up menu. The following warning message appears:
    Warning: Not all EGPRS data rate configurations are supported
  9. Press Close Menu ( F6 ).
  10. Press the More softkey on the right side of the front panel display to access the PDTCH Parms ( 2 of 3 ) menu.
  11. Press Multislot Config ( F7 ). Notice that all the selections accessible now.

Related Topics

EGPRS Data Rate Configurations


How do I make Modulation Accuracy Measurements?

How do I make Modulation Accuracy Measurements?

Last updated: December 2, 2008

This section is only applicable to EGPRS.

Measuring 3GPP TS 51.010 Section 13.17.1 Modulation Accuracy

The following topics are discussed in this section:

  • A. Test Set Configuration
  • B. Start a Data Connection
  • C. Start the Measurement
  • D. Setup the Measurement
  • E. How to view IQ Imbalance Results
  • F. View the Modulation Accuracy Graphical Results

After obtaining the measurement results, verify that they meet the conformance requirements defined in 3GPP 51.010 section 13.17.1.

A. Test Set Configuration

Setup parameters for this measurement are assumed to be set to their default (Full preset) values unless otherwise stated. This procedure also assumes that the BCH parameter for band is set up correctly for your mobile station and that the appropriate RF IN/OUT Amplitude Offsets have been set to offset loss between the mobile station and the test set.

  1. Press the CALL SETUP key.
  2. Press Operating Mode ( F1 ) and select Active Cell (EGPRS) .
  3. Press the Data Conn Type ( F2 ) key, and select ETSI Type A. (See Modulation Accuracy Measurement Description for other connection types that can be used with this measurement.)
  4. Select PDTCH Parameters ( F9 ) from the Call Parms menu.
  5. Select Modulation Coding Scheme ( F11 ) from the PDTCH Parms menu. The Modulation Coding Scheme popup menu appears.
  6. Select Uplink Modulation Coding Scheme and select one of the following modulation coding schemes: MCS-5 (8PSK), MCS-6 (8PSK), MCS-7 (8PSK), MCS-8 (8PSK), or MCS-9 (8PSK) .

    NOTE
    The Modulation Accuracy measurement is only useful for measuring 8PSK signals, therefore, it is necessary to select a modulation and coding scheme using 8PSK modulation for the measured signal.

  7. Press the Close Menu ( F6 ) key.

B. Start a Data Connection

  1. Connect the mobile.

  2. Turn the mobile on and wait for Attached in the Active Cell field.

    NOTE
    For mobiles that don't perform an EGPRS attach automatically, set the mobile to data mode. For example, your mobile station may have a connectivity setting for GPRS that allows you to specify whether you are always on-line or only use GPRS when it is needed.

  3. Press the Start Data Connection ( F3 ) key and watch for the Active Cell field changing to Transferring .

C. Start the Measurement

  1. Press the Measurement selection key.
  2. Select the EGPRS Modulation Accuracy measurement.

    The measurement results for the default measurement setup are displayed.

D. Setup the Measurement

  1. Press the Modulation Accuracy Setup ( F1 ) key.
  2. You can set the measurement parameters as needed for your measurement, for example, statistical measurement results can be turned on by selecting the Multi-Measurement Count parameter and changing to the value to something greater than zero. For this example, enter 5 .
  3. Press the Close Menu ( F6 ) key.

    The measurement results now include statistical results.

E. How to view IQ Imbalance Results

  1. Press the Modulation Accuracy Setup ( F1 ) key.
  2. To view results for IQ Imbalance, select IQ Imbalance Calculate State and select On .
  3. Press the Close Menu ( F6 ) key.

    The measurement results now include IQ Imbalance results.

F. View the Modulation Accuracy Graphical Results

The procedures below all start from the Control menu. (This is the menu on the left in the previous figure.)

  • General
  • View the EVM and Demodulated Symbols Graph
  • View the Magnitude and Phase Error Graphs
  • View the Sample EVM Histogram

General

  1. Press the Change View ( F2 ) key.
  2. Press the EVM Demod Symbols ( F2 ) key, Magnitude Error Phase Error ( F3 ) key, or the Sample EVM Histogram ( F5 ) key to display their respective measurement graphs.
  3. Use the Return ( F6 ) key to return to the Control menu.

  4. You can access the other graphs from any one graph's display by pressing Next Graph ( F5 ) until the graph you want is displayed.

View the EVM and Demodulated Symbols Graph

  1. Press the Change View ( F2 ) key.
  2. Press the EVM Demod Symbols ( F2 ) key to display the graphical EVM and Demod Symbols measurement results. You can change the EVM % per division by pressing Axis Control ( F1 ) and then %/ div ( F3 )and entering the desired value. For the following example, 1.00 % was the value used.

    Press Return ( F6 ) to return to Graph Control . You can also turn on markers to see the Demodulated symbols, EVM, Magnitude Error, and Phase error for individual symbols. Also, notice that the previous figure shows the demodulated symbols in octal. You can change the display to show the demodulated symbol values in binary by pressing the Demod Symbols ( F4 ) key and selecting Binary .

  3. Use the Return ( F6 ) key to return to the Control menu.

View the Magnitude and Phase Error Graphs

  1. Press the Change View ( F2 ) key.
  2. Press the Magnitude Error Phase Error ( F3 ) key to display the graphical Magnitude and Phase Error measurement results. The graphs display error versus symbol position. You can alter the error axis of the magnitude error graph by pressing Axis Control ( F1 ) and then %/div ( F3 ) and entering the desired value. For the following example, 5.00 % was the value used. The phase error graph's error axis is altered by pressing deg/div ( F4 ).

    Press Return ( F6 ) to return to Graph Control . You can also turn on markers to see the Magnitude Error and Phase error for individual symbols. Also, notice that the previous figure shows the demodulated symbols in octal. You can change the display to show the demodulated symbol values in binary by pressing the Demod Symbols ( F4 ) key and selecting Binary .

  3. Use the Return ( F6 ) key to return to the Control menu.

View the Sample EVM Histogram

  1. Press the Change View ( F2 ) key.
  2. Press the Sample EVM Histogram ( F5 ) key to display the sample EVM histogram and the 95th Percentile EVM measurement results. You can also turn on markers to measure the probability for a particular range of EVM percentages.
  3. Use the Return ( F6 ) key to return to the Control menu.
Changing the Sample EVM axis

You can change the Maximum Sample EVM displayed on the graph to increase the resolution of the histogram.

  1. Press Return ( F6 ).
  2. Press Return ( F6 ) again.
  3. Press Modulation Accuracy Setup ( F1 ).
  4. Select Histogram Maximum Sample EVM and select from the list. The proceeding figure used the 100% setting. The following figure uses the 10% setting. The vertical orange line is the 95th percentile EVM. The 10.00+ displayed as the limit of the x axis indicates that there were samples with an EVM that exceeded 10 and are not displayed on the graph.
  5. Press Change View (F2).
  6. Press Sample EVM Histogram (F5). You can now use the markers.
  7. Use the Return ( F6 ) key to return to the Control menu.

Related Topics

Modulation Accuracy Measurement Description


How Do I End the EGPRS Data Connection?

How Do I End the EGPRS Data Connection?

Last updated: December 2, 2008

This section is not applicable to GSM or GPRS.

  1. Press the CALL SETUP key.
  2. Press the End Data Connection ( F3 ) key, or end the data connection from the mobile.
  3. To ensure the data connection has ended check for Attached in the Active Cell field.


How Do I Perform an EGPRS Handover?

How Do I Perform an EGPRS Handover?

Last updated: December 2, 2008

This section is not applicable to GSM or GPRS.

  1. Press the CALL SETUP key.
  2. Press the Handover Parameters ( F10 ) key.
  3. Press the EGPRS Handover Setup key.
  4. Change the various parameters, for example Traffic Band .
  5. Press the Handover Execute ( F5 ) key to complete the handover, or press the Close Menu ( F6 ) key to abort the handover.
  6. Check for Transferring in the Active Cell field.
  7. After the handover is executed, press the PDTCH Parameters ( F9 ) key to check that the changes have been implemented on the PDTCH Parms menus (1 of 3) and (2 of 3).


How Do I Make EGPRS Measurements on a Mobile?

How Do I Make EGPRS Measurements on a Mobile?

Last updated: December 2, 2008

This section is not applicable to GSM or GPRS.

A. Establish a data connection.

  1. Press the blue SHIFT key.
  2. Press the green Preset key.
  3. Press the CALL SETUP key.
  4. Press Operating Mode ( F1 ) and select Active Cell (EGPRS) .
  5. Connect the mobile.

  6. Turn the mobile on and wait for Attached in the Active Cell: field.

    NOTE
    For mobiles that don't perform EGPRS attach automatically, set the mobile to data mode.

  7. Press the Start Data Connection ( F3 ) key and watch for the Active Cell: field changing to Transferring .

B. Select measurements.

  1. Press the Measurement selection key.
  2. Highlight a measurement and press the knob.
  3. Repeat steps 1 and 2 to add measurements.


How Do I Assign Different Modulation Coding Schemes / Puncturing Schemes to Each Downlink of a Multislot Burst?

How Do I Assign Different Modulation Coding Schemes / Puncturing Schemes to Each Downlink of a Multislot Burst?

Last updated: December 2, 2008

This section is only applicable when the test set's operating mode is EGPRS BCH+PDTCH or EGPRS BCH+PDTCH+TCH .

This section details how to:

  • Assign MCS / PS to Each Downlink of a Multislot Burst
  • Gain Access to All EGPRS Data Rate Configurations

Assign MCS / PS to Each Downlink of a Multislot Burst

  1. Press CALL SETUP
  2. Press Operating Mode ( F1 )
  3. Select EGPRS BCH+PDTCH from the Operating Mode popup menu.
  4. Press PDTCH Parameters ( F9 )
  5. Press More on the bottom right of the screen so that 2 of 3 is displayed.
  6. Press Multislot Config ( F7 )
  7. Choose a multislot configuration from the Multislot Config menu. The figure below shows a portion of the Multislot Config menu. The gray entries are unsupported. Note: If you set the EGPRS Data Rate Configuration to All , the entries in the Multislot Config menu change, see Gain Access to All EGPRS Data Rate Configurations .
  8. Press More on the bottom right of the screen so that 1 of 3 is displayed.
  9. Press MCS / PS ( F11 )
  10. Select a Modulation Coding Scheme / Puncturing Scheme (MCS / PS) for each downlink burst of the multislot configuration you selected in step seven. The figure below shows how the MCS/PS menu appears when the selected multislot configuration contains two downlink bursts.

Gain Access to All EGPRS Data Rate Configurations

  1. Follow steps 1-4 of Assign MCS / PS to Each Downlink of a Multislot Burst .
  2. Press MCS / PS ( F11 )
  3. Highlight the Data Rate Configuration parameter in the MCS / PS menu.
  4. Choose which configuration you want from the Configs Available menu. Notice if you choose All, when you push the knob the test set displays a warning that states, " Warning; Not all EGPRS data rate configurations are supported ". Press CANCEL to make this warning disappear.
  5. Follow steps 5-10 of Assign MCS / PS to Each Downlink of a Multislot Burst to assign an MCS/PS for each downlink of a multislot burst or press Close Menu ( F6 ).

Related Topics

Modulation Coding Scheme/Puncturing Scheme (MCS/PS)


How Do I Change Measurement Setup in EGPRS?

How Do I Change Measurement Setup in EGPRS?

Last updated: December 2, 2008

This section is not applicable to GSM or GPRS.

A. Select a measurement.

  1. Press the Measurement selection key.
  2. Highlight a measurement to set up and press the knob.

B. Set up the measurement.

  1. Press the measurement's setup ( F1 ) key.
  2. Highlight a parameter and press the knob.

  3. Enter a value or make a selection and press the knob.

    NOTE
    For Statistical measurement results, change the Multi-Measurement Count parameter from Off to a number >1.

  4. Press the Close Menu ( F6 ) key.


How do I make EGPRS SRB Bit Error Measurements?

How do I make EGPRS SRB Bit Error Measurements?

Last updated: December 2, 2008

This section is only applicable to EGPRS.

The following topics are discussed in this section:

  • A. Test Set Configuration
  • B. Start a Data Connection
  • C. Start the Measurement
  • D. Setup the Measurement

A. Test Set Configuration

Setup parameters for this measurement are assumed to be set to their default (Full preset) values unless otherwise stated. This procedure also assumes that the BCH parameter for band is set up correctly for your mobile station and that the appropriate RF IN/OUT Amplitude Offsets have been set to offset loss between the mobile station and the test set.

  1. Press the CALL SETUP key.
  2. Press Operating Mode ( F1 ) and select Active Cell (EGPRS) .
  3. Press the Data Conn Type ( F2 ) key, and select SRB Loopback.
  4. Select PDTCH Parameters ( F9 ) from the Call Parms menu.
  5. Select Modulation Coding Scheme ( F11 ) from the PDTCH Parms menu. The Modulation Coding Scheme popup menu appears.
  6. Select Uplink Modulation Coding Scheme and select any of the modulation coding schemes.
  7. Press the Close Menu ( F6 ) key.

B. Start a Data Connection

  1. Connect the mobile.

  2. Turn the mobile on and wait for Attached in the Active Cell: field.

    NOTE
    For mobiles that don't perform an EGPRS attach automatically, set the mobile to data mode. For example, your mobile station may have a connectivity setting for GPRS that allows you to specify whether you are always on-line or only use GPRS when it is needed.

  3. Press the Start Data Connection ( F3 ) key and watch for the Active Cell: field changing to Transferring .

C. Start the Measurement

  1. Press the Measurement selection key.
  2. Select the EGPRS SRB Bit Error measurement.

    The following graphic shows an example of EGPRS SRB Bit Error results. Notice that the number of bits actually tested exceeds the number requested. This occurs because the test set rounds up the number requested to the nearest number that results in an integral number of bursts.

D. Setup the Measurement

  1. Press the Bit Error Setup ( F1 ) key.
  2. You can set the measurement parameters as needed for your measurement, for example, you may want to change the Number of bits to test . You may also want to set up a Measurement Timeout to prevent the measurement from "hanging" if the test set is unable to complete the measurement for any reason.
  3. Press the Close Menu ( F6 ) key.

Related Topics

EGPRS SRB Bit Error Measurement


How Do I Turn Off a Measurement in EGPRS?

How Do I Turn Off a Measurement in EGPRS?

Last updated: December 2, 2008

This section is not applicable to GSM or GPRS.

  1. Press the Measurement selection key.
  2. Highlight the measurement you want to turn off.
  3. Press the Close Measurement ( F4 ) key.
  4. Press the Close Menu ( F6 ) key.


FETCh:SBERror

FETCh:SBERror

Last updated: December 2, 2008

GPIB Command Conventions

  • FETCh:SBERror[:ALL]?
  • FETCh:SBERror:BITS?
  • FETCh:SBERror:COUNt?
  • FETCh:SBERror:DELay?
  • FETCh:SBERror:ICOunt?
  • FETCh:SBERror:INTegrity?
  • FETCh:SBERror:RATio?

FETCh:SBERror[:ALL]?

Function

GSM TA

 This command is not applicable to GSM.

GSM/GPRS LA

 This command is not applicable to the GSM/GPRS lab application.

GPRS TA

This command is not applicable to GPRS.
EGPRS LA

Queries the SRB Loopack bit error measurement. Query returns integrity indicator, bits tested, bit error ratio, and bit error count.
EGPRS TA

Query

Integrity indicator

  • Range: See Integrity Indicator .
  • Resolution: 1

Bits tested

  • Range: 0 to 999,345 and 9.91 E+37 (NAN)
  • Resolution: 1

Bit error ratio

  • Range: 0 to 100 and 9.91 E+37 (NAN)
  • Resolution: 0.01

Bit error count

  • Range: 1 to 999,345 and 9.91 E+37 (NAN)
  • Resolution: 1
Requirements GSM/GPRS/
EGPRS TA

Revision: A.03 and above
GSM/GPRS/ EGPRS LA

Revision: C.03 and above

Programming Example

OUTPUT 714;"FETCh:SBERror?"

FETCh:SBERror:BITS?

Function

GSM TA

 This command is not applicable to GSM.

GSM/GPRS LA

 This command is not applicable to the GSM/GPRS lab application.

GPRS TA

This command is not applicable to GPRS.
EGPRS LA

Queries the number of bits actually tested. The number of bits actually tested will exceed the number requested because the test set rounds up the number requested to the nearest number that results in an integral number of bursts.
EGPRS TA

Query

Bits tested

  • Range: 0 to 999,345 and 9.91 E+37 (NAN)

  • Resolution: 1
Requirements GSM/GPRS/
EGPRS TA

Revision: A.03 and above
GSM/GPRS/ EGPRS LA

Revision: C.03 and above

Programming Example

OUTPUT 714;"FETCh:SBERror:BITS?"

FETCh:SBERror:COUNt?

Function

GSM TA

 This command is not applicable to GSM.

GSM/GPRS LA

 This command is not applicable to the GSM/GPRS lab application.

GPRS TA

This command is not applicable to GPRS.
EGPRS LA

Queries the number of bits that were in error during the last bit error test. See Bit Error Measurement

EGPRS TA

Query

Range: 1 to 999,345 and 9.91 E+37 (NAN)

Resolution: 1
Requirements GSM/GPRS/
EGPRS TA

Revision: A.03 and above
GSM/GPRS/ EGPRS LA

Revision: C.03 and above

Programming Example

OUTPUT 714;"FETCh:SBERror:COUNt?"

FETCh:SBERror:DELay?

Function

GSM TA

 This command is not applicable to GSM.

GSM/GPRS LA

 This command is not applicable to the GSM/GPRS lab application.

GPRS TA

This command is not applicable to GPRS.
EGPRS LA

Queries the delay (in bursts) that the test set used during the last EGPRS SRB bit error measurement to correlate uplink information bits with downlink information bits.

This value is displayed in the Loopback Delay field.

This value can be determined automatically, or manually set by the user. See SETup:SBERror:MANual:DELay and SETup:SBERror:LDControl:AUTO .

Refer also to the EGPRS SRB Bit Error Measurement for a description of loopback delay and how it is used in the EGPRS SRB bit error measurement.
EGPRS TA

Query

Range: 0 to 20 and 9.91 E+37 (NAN)

Resolution: 1
Requirements GSM/GPRS/
EGPRS TA

Revision: A.03 and above
GSM/GPRS/ EGPRS LA

Revision: C.03 and above

Programming Example

OUTPUT 714;"FETCh:SBERror:DELay?"

FETCh:SBERror:ICOunt?

Function

GSM TA

 This command is not applicable to GSM.

GSM/GPRS LA

 This command is not applicable to the GSM/GPRS lab application.

GPRS TA

This command is not applicable to GPRS.
EGPRS LA

Queries the intermediate count of bits tested (measurement progress report). See Measurement Progress Report

EGPRS TA

Query

Range: 0 to 999

Resolution: 1
Requirements GSM/GPRS/
EGPRS TA

Revision: A.03 and above
GSM/GPRS/ EGPRS LA

Revision: C.03 and above

Programming Example

OUTPUT 714;"FETCh:SBERror:ICOunt?"

FETCh:SBERror:INTegrity?

Function

GSM TA

 This command is not applicable to GSM.

GSM/GPRS LA

 This command is not applicable to the GSM/GPRS lab application.

GPRS TA

This command is not applicable to GPRS.
EGPRS LA

Returns the integrity indicator value for the last EGPRS SRB bit error measurement performed. Zero indicates a normal result.

See Integrity Indicator for descriptions of non-zero integrity indicators.
EGPRS TA

Query

Range: See Integrity Indicator .

Resolution: 1
Requirements GSM/GPRS/
EGPRS TA

Revision: A.03 and above
GSM/GPRS/ EGPRS LA

Revision: C.03 and above

Programming Example

OUTPUT 714;"FETCh:SBERror:INTegrity?"

FETCh:SBERror:RATio?

Function

GSM TA

 This command is not applicable to GSM.

GSM/GPRS LA

 This command is not applicable to the GSM/GPRS lab application.

GPRS TA

This command is not applicable to GPRS.
EGPRS LA

Queries the ratio of bits in error to the number of bits tested during the last EGPRS SRB bit error test and returns it as a percentage. See Bit Error Measurement

EGPRS TA

Query

Range: 1 to 100 and 9.91 E+37 (NAN)

Resolution: 0.01
Requirements GSM/GPRS/
EGPRS TA

Revision: A.03 and above
GSM/GPRS/ EGPRS LA

Revision: C.03 and above

Programming Example

OUTPUT 714;"FETCh:SBERror:RATio?"


SETup:SBERror

SETup:SBERror

Last updated: December 2, 2008

GPIB Command Conventions

  • SETup:SBERror:CLSDelay[:STIMe]
  • SETup:SBERror:CLSDelay:TIME
  • SETup:SBERror:CLSDelay:STATe
  • SETup:SBERror:CONTinuous
  • SETup:SBERror:COUNt
  • SETup:SBERror:LDControl:AUTO
  • SETup:SBERror:MANual:DELay
  • SETup:SBERror:TIMeout[:STIMe]
  • SETup:SBERror:TIMeout:TIME
  • SETup:SBERror:TIMeout:STATe

SETup:SBERror:CLSDelay[:STIMe]

Function

GSM TA

 This command is not applicable to GSM.

GSM/GPRS LA

 This command is not applicable to the GSM/GPRS lab application.

GPRS TA

This command is not applicable to GPRS.
EGPRS LA

Selects/queries the closed loop signalling delay time in seconds for EGPRS SRB Bit Error measurements and sets the delay state to ON. The units (S|MS) are optional, if no units are specified than units default to S.

The delay time defines how long the test set should wait before starting an SBER measurement. The downlink signalling operation must be completed and the test set must send a close loop command to the mobile station before the measurement can begin. The delay time allows time for the loop to close.

When a close loop message is set to the mobile station the closed loop signalling delay time will hold off the SBER measurement from starting for the specified time period.
EGPRS TA
Setting

Range: 0 to 5 seconds

Resolution: 100 ms

Query

Range: 0 to 5 seconds

Resolution: 100 ms
*RST Setting 500 ms

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.03 and above
GSM/GPRS/ EGPRS LA

Revision: C.03 and above

Programming Example

OUTPUT 714;"SETUP:SBERROR:CLSDELAY:STIME 400 MS"
! Sets state to on and delay time

SETup:SBERror:CLSDelay:TIME

Function

GSM TA

 This command is not applicable to GSM.

GSM/GPRS LA

 This command is not applicable to the GSM/GPRS lab application.

GPRS TA

This command is not applicable to GPRS.
EGPRS LA

Selects/queries the closed loop signalling delay time in seconds for EGPRS SRB Bit Error measurements. The units (S|MS) are optional, if no units are specified than units default to S.

The delay time defines how long the test set should wait before starting an SBER measurement. The downlink signalling operation must be completed and the test set must send a close loop command to the mobile station before the measurement can begin. The delay time allows time for the loop to close.

When a close loop message is set to the mobile station the closed loop signalling delay time will hold off the SBER measurement from starting for the specified time period.
EGPRS TA
Setting

Range: 0 to 5 seconds

Resolution: 100 ms

Query

Range: 0 to 5 seconds

Resolution: 100 ms
*RST Setting 500 ms

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.03 and above
GSM/GPRS/ EGPRS LA

Revision: C.03 and above

Programming Example

OUTPUT 714;"SETUP:SBERROR:CLSDELAY:TIME 600MS"
! Sets delay time

SETup:SBERror:CLSDelay:STATe

Function

GSM TA

 This command is not applicable to GSM.

GSM/GPRS LA

 This command is not applicable to the GSM/GPRS lab application.

GPRS TA

This command is not applicable to GPRS.
EGPRS LA

Selects/queries the closed loop signalling delay state for EGPRS SRB Bit Error measurements. If the state is off the test set will not wait to start a SBER measurement after a downlink signalling operation has completed.

The delay time defines how long the test set should wait before starting and SBER measurement after a downlink signalling operation has completed and after the test set has sent a close loop command to the mobile station.

When a close loop message is set to the mobile station the closed loop signalling delay time will hold off the SBER measurement from starting for the specified time period.
EGPRS TA
Setting Range: 1 | ON

 |
0 | OFF

Query

Range: 1 | 0
*RST Setting 1 | ON

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.03 and above
GSM/GPRS/ EGPRS LA

Revision: C.03 and above

Programming Example

OUTPUT 714;"SETup:SBERror:CLSDelay:STATe ON"

SETup:SBERror:CONTinuous

Function

GSM TA

 This command is not applicable to GSM.

GSM/GPRS LA

 This command is not applicable to the GSM/GPRS lab application.

GPRS TA

This command is not applicable to GPRS.
EGPRS LA

Sets/queries the trigger state to single trigger mode or continuous trigger mode for EGPRS SRB BER measurement.
EGPRS TA
Setting

Range: 0 | OFF | 1 | ON

Query

Range: 0 | 1
*RST Setting

0 | OFF

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.03 and above
GSM/GPRS/ EGPRS LA

Revision: C.03 and above

Programming Example

OUTPUT 714;"SETup:SBERror:CONTinuous OFF"
! Sets SBER measurement to single trigger mode.

SETup:SBERror:COUNt

Function

GSM TA

 This command is not applicable to GSM.

GSM/GPRS LA

 This command is not applicable to the GSM/GPRS lab application.

GPRS TA

This command is not applicable to GPRS.
EGPRS LA

Sets/queries the number of bits to test. This is the number of information bits to test. Information bits exclude stealing flags and midamble bits.

Due to the burst structure, the number of bits actually tested can be larger. The actual number of bits tested is available as a measurement result. See FETCh:SBERror:COUNt?

EGPRS TA
Setting

Range: 1 to 999,000

Resolution: 1

Query

Range: 1 to 999,000

Resolution: 1
*RST Setting

50,000

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.03 and above
GSM/GPRS/ EGPRS LA

Revision: C.03 and above

Programming Example

OUTPUT 714;"SETup:SBERror:COUNt 75000"
! Sets the number of bits to test to 75000.

SETup:SBERror:LDControl:AUTO

Function

GSM TA

 This command is not applicable to GSM.

GSM/GPRS LA

 This command is not applicable to the GSM/GPRS lab application.

GPRS TA

This command is not applicable to GPRS.
EGPRS LA

Sets/queries loopback delay control mode. If loopback delay control mode is automatic (Auto), the test set will determine the loopback delay value that will allow correlation between uplink information bits with downlink information bits.

If loopback delay control mode is manual (not Auto), the test set will use the loopback delay value entered in the Loopback Delay field. Refer to. see SETup:SBERror:MANual:DELay

Refer also to the Bit Error Measurement for a description of loopback delay and its use in the EGPRS SRB BER measurement.
EGPRS TA
Setting

Range: 0 | OFF | 1 | ON

Query

0 | 1
*RST Setting

1 (automatic)

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.03 and above
GSM/GPRS/ EGPRS LA

Revision: C.03 and above

Programming Example

OUTPUT 714;"SETup:SBERror:LDControl:AUTO OFF"
! Sets SBER delay to manual the user must select the manual frame delay number.

SETup:SBERror:MANual:DELay

Function

GSM TA

 This command is not applicable to GSM.

GSM/GPRS LA

 This command is not applicable to the GSM/GPRS lab application.

GPRS TA

This command is not applicable to GPRS.
EGPRS LA

Sets/queries the number of bursts the test set will wait before correlating uplink bursts received with downlink bursts sent when loop delay control mode is manual (AUTO OFF). To set the delay mode to manual, refer to SETup:SBERror:LDControl:AUTO .

This value is displayed in the Loopback Delay field when Auto is not displayed. (If you want to display this value and Auto is currently displayed, press the front-panel key labeled OFF ).

Refer to Bit Error Measurement for a description of loopback delay and how it is used in this measurement.
EGPRS TA
Setting

Range: 0 to 20

Resolution : 1

Query

Range: 0 to 20

Resolution : 1
*RST Setting

1

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.03 and above
GSM/GPRS/ EGPRS LA

Revision: C.03 and above

Programming Example

OUTPUT 714;"SETup:SBERror:MANual:DELay 4"
! Sets delay of 4 bursts.

SETup:SBERror:TIMeout[:STIMe]

Function

GSM TA

 This command is not applicable to GSM.

GSM/GPRS LA

 This command is not applicable to the GSM/GPRS lab application.

GPRS TA

This command is not applicable to GPRS.
EGPRS LA

Sets/queries the timeout value in seconds for the trigger state during EGPRS SRB BER measurements and turns the timeout state on. The units (S|MS) are optional, if no units are specified than units default to S.
EGPRS TA
Setting

Range: 0.1 to 999

Resolution: 0.1

Query

Range: 0.1 to 999Resolution: 0.1
*RST Setting

10 seconds

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.03 and above
GSM/GPRS/ EGPRS LA

Revision: C.03 and above

Programming Example

OUTPUT 714;"SETup:SBERror:TIMeout 8"
! Sets SBER measurement timeout to 8 seconds and the state to on.

SETup:SBERror:TIMeout:TIME

Function

GSM TA

 This command is not applicable to GSM.

GSM/GPRS LA

 This command is not applicable to the GSM/GPRS lab application.

GPRS TA

This command is not applicable to GPRS.
EGPRS LA

Sets/queries the timeout value in seconds for the trigger state during EGPRS SRB BER measurements. The units (S|MS) are optional, if no units are specified than units default to S (seconds).
EGPRS TA
Setting

Range: 0.1 to 999

Resolution: 0.1

Query

Range: 0.1 to 999Resolution: 0.1
*RST Setting

10 seconds

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.03 and above
GSM/GPRS/ EGPRS LA

Revision: C.03 and above

Programming Example

OUTPUT 714;"SETup:SBERror:TIMeout:TIME 8"
! Sets SBER measurement timeout to 8 seconds.

SETup:SBERror:TIMeout:STATe

Function

GSM TA

 This command is not applicable to GSM.

GSM/GPRS LA

 This command is not applicable to the GSM/GPRS lab application.

GPRS TA

This command is not applicable to GPRS.
EGPRS LA

Sets/queries the timeout state for EGPRS SRB BER measurements.
EGPRS TA
Setting

Range: 0 | OFF | 1 | ON

Query

Range: 0 | 1
*RST Setting

0 | OFF

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.03 and above
GSM/GPRS/ EGPRS LA

Revision: C.03 and above

Programming Example

OUTPUT 714;"SETup:SBERror:TIMeout:STATe ON"
! Sets the timeout state to on.


Downlink Corruption

Downlink Corruption

Last updated: December 2, 2008

This section is only applicable to the GPRS and EGPRS lab applications.

In order to stress the mobile station's receiver and force the use of incremental redundancy and retransmission MCS switching, the downlink corruption feature allows you to specify the corruption of some downlink GPRS and EGPRS PDTCH blocks. Corrupting the downlink data will cause data retransmissions and will therefore cause bad BER and BLER results as well as cause deterioration in the IP data throughput.

Downlink Corruption Parameters

Parameter | GPIB Command
Downlink Corruption State | CALL:(PDTCH|PDTChannel):DOWNlink:CORRuption[:STATe]
Sequence Length | CALL:(PDTCH|PDTChannel):DOWNlink:CORRuption:SEQuence:LENGth
Blocks in Sequence to Corrupt | CALL:(PDTCH|PDTChannel):DOWNlink:CORRuption:SEQuence:CBURsts
Corruption applied to Burst [n] | CALL:(PDTCH|PDTChannel):DOWNlink:CORRuption:BURSt<[1]|2|3|4>[:STATe]
First Corrupted Symbol | CALL:(PDTCH|PDTChannel):DOWNlink:CORRuption:SYMBol:STARt
Number of Symbols to Corrupt | CALL:(PDTCH|PDTChannel):DOWNlink:CORRuption:SYMBol:LENGth
Corruption Pattern | CALL:(PDTCH|PDTChannel):DOWNlink:CORRuption:PATTern

Setting the Number of Symbols to Corrupt parameter to a value greater than or equal to the Sequence Length, forces all blocks to be corrupted.

If you enter a value for either Number of Symbols to Corrupt or First Corrupted Symbol that would cause the corruption to exceed symbol number 147, the test set changes the last of those values you entered to a value making the total of the two parameters equal to 147.

There is no link between the blocks to be corrupted and the Block Sequence Number (BSN).

The corruption sequence is restarted when the Downlink Corruption State is set to On.

Operating Considerations

Downlink corruption can only be used in the following operating modes:

  • Active Cell when the serving cell is set to GPRS or EGPRS, and the connection type is Auto, BLER, ETSI TYPE B (Unack), ETSI Type B (ACK), or SRB Loopback.

  • GPRS BCH +PDTCH or GPRS BCH+PDTCH+TCH

  • EGPRS BCH +PDTCH or EGPRS BCH+PDTCH+TCH

Changes can be made to Downlink Corruption in other operating modes, but there is no effect the test set's operation until the operating mode is a valid one.

Downlink Corruption is applicable to all the connection types.

Related Topics

How to Setup Corruption of Downlink Blocks


Downlink Dual Carrier

Downlink Dual Carrier

Last updated: December 4, 2008

This section is only applicable to the EGPRS lab applications.

The Downlink Dual Carrier (DLDC) assigns PDTCH resources to a mobile on two different carriers. With DLDC-based transfer, the downlink throughput theoretically scales linearly with the total number of timeslots allocated to a downlink TBF.

DLDC Assignment Types

Any changes to the connection state, the DLDC state or the PDTCH parameters in the test set may result in the mobile receiving an assignment message (e.g. Packet Uplink/Downlink Assignment) with updated ASSIGNMENT TYPE IE field and CARRIER ID IE field, indicating that the assignment is an `Assignment on single carrier only', `Dual Carrier Assignment' or `Modification of existing assignment' by carrier ID.

The following table outlines the Assignment Type and Carrier ID that included in the assignment message associated with the actions.

Note: PDTCH1 specifies PDTCH resource on `Carrier ID 0' and PDTCH2 specifies PDTCH resource on `Carrier ID 1'.

Current PS State | Current DLDC State | Action | Assignment Type | Carrier ID
Packet Idle | On | Start Data Connection | Dual Carrier Assignment | N/A
Packet Transfer | Off | Change DLDC State to ON | Modification of Existing Assignment | Carrier ID = 1
Packet Transfer | On | Change DLDC State to OFF | Single Carrier Assignment | Carrier ID = 0
Packet Transfer | On | Change one of the following parameters on PDTCH1: - USF - P0 - PDTCH Band - PDTCH ARFCN - MAIO - PDTCH Multislot Config - Custom PDTCH Multislot Config - PDTCH Frequency Hopping State | Modification of Existing Assignment | Carrier ID = 0
Packet Transfer | On | Change one of the following parameters on PDTCH2: - Multislot Config - Custom Multislot Config - P0 - Frequency Hopping State - ARFCN - MAIO | Modification of Existing Assignment | Carrier ID = 1
Packet Transfer | On | Change one of the following parameters: - TTI Mode - RTTI USF Mode - PDTCH MS Output Power Control - PDTCH MS Tx or Gamma Levels - Downlink MCS - Uplink MCS - MA Table - PDTCH1 HSN | Dual Carrier Assignment | N/A

Constrains on PDTCH Configuration

When setting the PDTCH configuration for DLDC Configuration, the following overriding restrictions apply:

  • The PDTCH Traffic Band value must be the same as BCH Band Value. The deferred PDTCH Traffic Band value must be the same as the current BCH Band value.
  • For the PDTCH1, the Supported Multislot Classes is applied. However due to hardware constraint, the maximum downlink or uplink timeslots on PDTCH2 can NOT exceed 5, the sum of the downlink an uplink timeslots on PDTCH2 can NOT exceed 7, the combined sum of downlinks can NOT exceed 10.

  • The frequency of the PDTCH1 and PDTCH2 can NOT be the same at any given TDMA frame, details as follows:

    1. If both of the PDTCHs are in a frequency hopped configuration, you are only permit to configure MAIO and hopping state of PDTCH2, the MA table value and HSN are configured derived from those parameters of the PDTCH1 automatically.

    2. If only one of the PDTCHs is in a frequency hopped configuration, the MA table value is NOT allowed to include the ARFCH used by the non-hopped PDTCH.

    3. If both PDTCHs are non-hopped, they must use different Traffic ARFCNs.

Configurable Parameters

The DLDC settings are as shown in the table below:

Parameter | GPIB Command
Downlink Dual Carrier State | CALL:(PDTChannel|PDTCH):DLDCarrier[:STATe]
PDTCH2 Traffic Channel | CALL:(PDTC2|PDTCH2|PDTChannel2):ARFCn[:SELected]
PDTCH2 Frequency hopping state | CALL:(PDTC2|PDTCH2|PDTChannel2):FHOPping[:STATe]
PDTCH2 MAIO | CALL:(PDTC2|PDTCH2|PDTChannel2):FHOPping:MAIOffset[:SELected]
PDTCH Multislot Config | CALL:(PDTCH|PDTChannel):MSLot:CONFig
PDTCH2 Custom Multislot Config | CALL:(PDTCH|PDTChannel):MSLot:CONFig:CUSTom:TSLots
PDTCH2 Multislot Config | CALL:(PDTC2|PDTCH2|PDTChannel2):MSLot:CONFig
PDTCH2 Custom Multislot Config | CALL:(PDTC2|PDTCH2|PDTChannel2):MSLot:CONFig:CUSTom:TSLots
PDTCH2 GPRS Uplink timeslot <n> usage |
PDTCH2 MCS/PS Burst 1 | CALL:(PDTC2|PDTCH2|PDTChannel2):MCSCheme:EBPTest[:BURSt1]
PDTCH2 MCS/PS Burst <2-5> | CALL:(PDTC2|PDTCH2|PDTChannel2):MCSCheme:EBPTest:BURSt<2|3|4|5>
PDTCH2 P0 | CALL:(PDTC2|PDTCH2|PDTChannel2):PZERo:LEVel
PDTCH2 Power Reduction Level | CALL:(PDTC2|PDTCH2|PDTChannel2):PREDuction:LEVel
PDTCH2 Power Reduction Level Burst <1-5> | CALL:(PDTC2|PDTCH2|PDTChannel2):PREDuction:BURSt<1|2|3|4|5>

How to set the DLDC mode?

The following procedure details how to access and configure the DLDC mode.

  1. Press CALL SETUP .
  2. Press the More key on the lower right corner to display the PDTCH parms (3 of 3).
  3. Press DLDC Mode ( F8 ) to display the DLDC Setup menu. Use the knob to select the parameter that you want to set.

Operating Considerations

The DLDC mode is only available in the Active Cell(EGPRS) and EGPRS BCH+PDTCH operating mode. However, parameters associated with DLDC can be changed in other operating modes, but do not effect the test set's operation until the operating mode is changed to the above values.

When the DLDC mode is enabled, performing the following measurements when the data connection type is ETSI-B or SRB loopback will result in the measurement returning an `Unsupported Configuration' integrity indicator value:

  • GPRS Bit Error Measurement
  • Block Error Measurement (when `ETSI B Ack Measurement Mode' is set to `Loopback')
  • EGPRS SRB Bit Error Measurement

Related Topics

TTI Mode Configuration


Frequency Hopping

Frequency Hopping

Last updated: December 2, 2008

This section is only applicable to the lab applications.

Frequency hopping is the technique of improving the signal to noise ratio in a link by adding frequency diversity. The base station commands the mobile station to activate frequency hopping as the mobile station moves toward the edge of a cell or into an area of high interference. When frequency hopping is activated in the mobile station, the base station assigns the mobile station a set of RF channels, rather than a single RF channel. A frequency hopping algorithm is also assigned to the mobile and is used to inform the mobile of the pattern of the available frequencies it is to use. In a GSM/GPRS/EGPRS network, frequency hopping is specified in individual cells based on the number of frequencies offered by a specific cell. The advantages that frequency hopping offers are:

  • Improved voice quality and prevention of dropped calls in GSM
  • Improved data throughput in GPRS and EGPRS

Overview

The test set offers two basic forms of frequency hopping algorithms: cyclic and pseudo random. When set to the cyclic form, the test set and the mobile station are cycled through a fixed repeated pattern of frequencies. There are a total of 64 different frequency patterns that the test set can generate and use. The hopping sequence the mobile station uses depends on the Hopping Sequence Number (HSN) specified in the test set. An HSN of zero corresponds to the cyclic hopping sequence, and values 1 through 63 correspond to the pseudo random patterns. The ARFCNs used in the hopping sequence pattern are determined by the contents of the test set's Mobile Allocation (MA) Table. The entry of the MA Table at which the hopping sequence begins is called the Mobile Allocation Index Offset (MAIO). Note that an MAIO of zero corresponds to the first entry of the MA Table.

An MA Table is a list of the ARFCNs present in the Cell Allocation (CA) Table that share the same frequency band. There is a separate MA Table for each frequency band. The ARFCNs in the MA Table must be chosen from the test set's Cell Allocation (CA) Table because the CA Table contains all the ARFCNs available for use in the cell. If a handoff to another band occurs, the test set uses the MA Table for the band that it was instructed to handoff to.

The following table shows which ARFCNs represent each frequency band in the test set's default CA Table. The default CA Table contains all the ARFCNs listed in the third column. There is a separate MA Table for each frequency band. The values in each row of the third column show the MA Tables for each corresponding frequency band. For example, when the test set's selected frequency band is PCS, the default values contained in MA Table for the PCS band are: 520, 661,810. Note that there the default MA Table for the T-GSM810 band is empty.

Frequency Band | ARFCN Range | Default ARFCN
DCS | 512 to 885 | 520, 661, 810, 885
EGSM | 0 to 124 and 975 to 1023 | 1, 124, 975
GSM450 | 259 to 293 | 259, 293
GSM480 | 306 to 340 | 306, 340
GSM750 | 438 to 511 | 438, 511
GSM850 | 128 to 251 | 128, 251
PCS | 512 to 810 | 520, 661, 810
PGSM | 1 to 124 | 1, 124
RGSM | 0 to 124 and 955 to 1023 | 1, 124, 955, 975
T-GSM810 | 350 to 425 | none

The MA Tables and the CA Table can be manually or automatically configured. Sixteen is the maximum number of entries for an MA Table.

When the MA Table is configured automatically, any changes to the CA Table are populated in the MA Table of the appropriate frequency band. The state of each entry in an MA Table can be manually set.

To maintain measurement accuracy, the measurement down converter is set to an ARFCN in the selected MA Table. This ARFCN is called the Measurement ARFCN.

NOTE
In order for frequency hopping to occur, the Frequency Hopping State parameter must be enabled and there must be more than one ARFCN in the MA Table for the selected band.

Configuration of Frequency Hopping Parameters

Parameter

 GPIB Commands

Frequency Hopping State

CALL:(PDTCH|PDTChannel):FHOPping[:STATe]

Cell Allocation (CA) Table

CALL:CA:TABLe

CALL:CA:TABLe:POINts?

Mobile Allocation (MA) Table Configuration Mode

  •

GSM GPIB Commands

CALL:TCHannel:MA:TABLe:CONFig:AUTO

    •

  •

GPRS/EGPRS GPIB Commands

CALL:(PDTCH|PDTChannel):MA:TABLe:CONFig:AUTO

    •

Mobile Allocation (MA) Table Automatic Configuration

  •

GSM GPIB Commands

CALL:TCHannel:MA:TABLe[:AUTO]:[SELected]?

    •

  •

GPRS/EGPRS GPIB Commands

CALL:(PDTCH|PDTChannel):MA:TABLe[:AUTO][:SELected]?

    •

Mobile Allocation (MA) Table Manual Configuration

  •

GSM GPIB Commands

CALL:TCHannel:MA:TABLe:MANual:[SELected]

    •

  •

GPRS/EGPRS GPIB Commands

CALL:(PDTCH|PDTChannel):MA:TABLe:MANual[:SELected]

    •

Mobile Allocation (MA) Table Points Manual Configuration

  •

GSM GPIB Commands

CALL:TCHannel:MA:TABLe:MANual:POINts:[SELected]?

    •

  •

GPRS/EGPRS GPIB Commands

CALL:(PDTCH|PDTChannel):MA:TABLe:MANual:POINts[:SELected]?

    •

Mobile Allocation (MA) Table Points Automatic Configuration

  •

GSM GPIB Commands

CALL:TCHannel:MA:TABLe[:AUTO]:POINts:[SELected]?

    •

  •

GPRS/EGPRS GPIB Commands

CALL:(PDTCH|PDTChannel):MA:TABLe[:AUTO]:POINts[:SELected]?

    •

Mobile Allocation Index Offset (MAIO)

  •

GSM GPIB Command

CALL:TCHannel:FHOPping:MAIoffset:[SELected]

    •

  •

GPRS/EGPRS GPIB Command

CALL:(PDTCH|PDTChannel):FHOPping:MAIOffset[:SELected]

    •

Hopping Sequence Number (HSN)

  •

GSM GPIB Command

CALL:TCHannel:FHOPping:HSNumber

    •

  •

GPRS/EGPRS GPIB Command

CALL:(PDTCH|PDTChannel):FHOPping:HSNumber

    •

Measurement ARFCN

  •

GSM GPIB Command

CALL:TCHannel:MA:MEASurement:ARFCn:(SELected]

    •

  •

GPRS/EGPRS GPIB Command

CALL:(PDTCH|PDTChannel):MA:MEASurement:ARFCN[:SELected]

    •

Operating Considerations

Frequency hopping can only occur when the Operating Mode is set to one of the following: Active Cell (with GSM, GPRS or EGPRS as the
Serving Cell
), GSM TCH, GPRS BCH+PDTCH, or EGPRS BCH+PDTCH. Frequency Hopping parameters can be changed in any Operating Mode, but the test set's operation is not effected until it is set to a valid Operating Mode.

The Cell Allocation (CA) table is transmitted on the BCCH whenever there is a presence of a BCH.

Frequency Hopping in applicable to the following Connection Types: ETSI Type A, ETSI Type B (Unack), ETSI Type B (Ack), BLER, Auto, SRB Looback.

The Operating Mode must be set to Cell Off before the CA Table can be changed. The maximum number of entries the CA table and MA table can contain is sixteen, and the MA values can only be chosen from the CA Table values.

If frequency hopping is enabled, the adjacent burst power implies the burst power before and after the traffic channel bursts. The Adjacent Burst Power can be set using the GPBI command:
CALL:TCHannel:PREDuction:ADJacent
 or
CALL:(PDTCH|PDTChannel):PREDuction:ADJacent
.

The RF
Amplitude Offset
 applied to the Test Set's RF signal generator output (for mobile station receiver measurements) is the middle frequency/offset pair in the RF In/Out Amplitude Offset table. This single offset value is applied to the RF output for all hopped channels. (Note: If there is an even number of frequency/offset pairs in the RF In/Out Amplitude Offset table, the offset used is the higher of the two middle pairs. For example, if there are 4 frequency / offset pairs, the offset of pair 3 is used).

When the
BCH Type
 is set to
Combined
, Frequency Hopping cannot take place on the SDCCH.

Related Topics

How Do I Set Up and Use the Frequency Hopping Feature?


Incremental Redundancy

Incremental Redundancy

Last updated: December 2, 2008

This section is only applicable to the EGPRS lab application.

Support for incremental redundancy in the test set allows you to verify a mobile station's implementation of Type II hybrid ARQ (incremental redundancy), as well as stress the mobile station's memory and processor. The Wireless Protocol Advisor (WPA) software (see Protocol Logging ) also provides full tracing of the current modulation and coding scheme and the puncturing scheme.

Downlink TBF

By default, the test set sends 1/3 convolutionally encoded RLC data blocks using puncturing scheme 1 (PS1). When incremental redundancy is enabled, the test set begins transmitting RLC data blocks using PS1 and retransmits blocks using the next puncturing scheme based either on Negative Acknowledgments (NACKs) received from the mobile station for specific RLC block numbers or, if there is no new data to send, for RLC blocks that have not yet been acknowledged or not acknowledged. For additional retransmissions, the test set continues to cycle through the available puncturing schemes for the selected modulation and coding scheme (MCS) until the blocks are acknowledged.

The mobile station must be able to store the original received bits in memory for failed block transmissions, combine those bits with retransmissions of the same block using different puncturing schemes, and decode the combined bits until the decode is successful.

You can force the mobile station to NACK RLC blocks by defining some downlink blocks to be corrupted intentionally by the test set. See Downlink Corruption for more information.

Handling of the MS_OUT_OF_MEMORY indication

When the mobile station no longer has enough memory to perform incremental redundancy, it indicates this by setting the MS_OUT_OF_MEMORY field in the EGPRS Packet Downlink Ack/Nack message. In response to this indication, the test set stops sending new blocks to the mobile station and only retransmits blocks that have already been NACKed by the mobile station. Only when the mobile station sends an indication that enough memory has been freed up for normal operation does the test set begin transmitting new blocks.

Uplink TBF

The test set does not allow you to change the state of incremental redundancy for uplink TBFs. This situation exists because the test set does not yet support link adaptation to MCS below MCS-5. This would require splitting RLC blocks in half for transmission and then resegmenting the split blocks by the receiver. By ordering the mobile station to not resegment retransmitted RLC data blocks in RLC MAC control messages, the test set is turning on incremental redundancy for uplink TBFs, as specified in 3GPP TS 04.60, Section 9.3.2.1.

Forcing Uplink Retransmissions

You can observe the use of incremental redundancy on uplink TBFs by setting up the test set to intentionally NACK a percentage of correctly received uplink blocks. Incorrectly received blocks are always NACKed and do not affect the specified percentage of good blocks to be NACKed.

NOTE
The value of the NACK Good Blocks percentage is not the exact percentage of correctly received blocks that will be NACKed. This value is used to evaluate the probability of any individual block begin NACKed.

Operating Considerations for NACK Good Blocks

The operating mode must be Active Cell and the serving cell must be EGPRS. However, the forced uplink retransmission parameter can be changed in other operating modes, but does not affect the test set's operation until the operating mode is changed to Active Cell.

The forced uplink retransmission parameter is applicable in all connection types.

Window Size

This section is only applicable to the EGPRS lab application. The Window Size for GPRS operation is fixed to 64 bits. According to 3GPP TS 51.010, section 14.18.7, one of the conditions that Incremental Redundancy requires for the MS to achieve a long-term throughput of 20 kbps per time slot measured between the LLC an RLC/MAC layer is that the transmit window size be set to Maximum.

The window size parameters set the RLC window size on the downlink for EGPRS. The window size can be set to the maximum allowable value for the number of downlink slots or the minimum window size for all timeslots. The maximum and minimum allowed window sizes can be found in 3GPP TS 04.60, Table 9.1.9.2.1.

The test set allows you to set the window size for different Data Connection Types. The parameters available in the test set are:

  • Window Size (Current)

    This parameter sets the window size for the current Data Connection Type.

    The GPIB command to set this parameter is CALL:(PDTCH|PDTChannel):WINDow:SIZE:SELected .

  • Window Size (Auto)

    This parameter sets the window size that the test set uses when the Data Connection Type is set to Auto .

    The GPIB command to set this parameter is CALL:(PDTCH|PDTChannel):WINDow:SIZE:AUTO .

  • Window Size (Other)

    This parameter sets the window size that the test set uses when the Data Connection Type is not set to Auto .

    The GPIB command to set this parameter is CALL:(PDTCH|PDTChannel):WINDow:SIZE:OTHer .

The window size specified by these parameters will be used with the next TBF that is established, not with the current TBF if one is in progress.

These parameters are applied to both uplink and downlink TBFs.

NOTE
When the window size is set to "Maximum", it is not possible to reconfigure the multi-slot configuration to one which reduces the number of active uplink or downlink slots while the TBF is in progress. This restriction is implemented to conform to 3GPP TS 04.60, Section 9.1.9.2 which specifies that the window size may be changed to a larger size during a TBF, but not to a smaller one.
If the multi-slot configuration is changed while a TBF is in progress, the test set stores this value and uses it the next time a TBF is established.

How Do I Configure the Window Size?

This procedure is only applicable to the EGPRS lab application. (The Window Size for GPRS operation is fixed to 64 blocks.) This procedure describes how you manually configure the RLC/MAC Window Size parameter for different Data Connection Types in the test set.

  1. Press CALL SETUP .
  2. Press the left More key.
  3. Press Protocol Control ( F4 ).
  4. Press RLC/MAC ( F2 ).
  5. Press the left More key.
  6. Press Window Size ( F3 ). This displays the Window Size Parameters menu.
  7. Use the knob to highlight, select and change the value of the parameters listed in this menu.

To configure the Window Size via the GPIB interface, use the command appropriate for your Data Connection Type. See Window Size for more information.

Support for the Incremental Redundancy Performance Specification

The test set currently allows you to configure all the fields in the protocol stack according to the Method of Test for Incremental Redundancy Performance defined in 3GPP TS 51.010 Section 14.18.7. It is currently necessary to use a method external to the test set to evaluate the throughput between the LLC and RLC/MAC layers.

Parameters used for Configuring Incremental Redundancy

Parameter | GPIB Command
Incremental Redundancy State | CALL:(PDTCH|PDTChannel):IREDundancy[:STATe]
NACK Good Blocks State and Percentage | CALL:(PDTCH|PDTChannel):UPLink:RETRansmit:FORCe:PROBability:SPERcentage
NACK Good Blocks State | CALL:(PDTCH|PDTChannel):UPLink:RETRansmit:FORCe:PROBability[:STATe]
NACK Good Blocks Percentage | CALL:(PDTCH|PDTChannel):UPLink:RETRansmit:FORCe:PROBability:PERCentage

Operating Considerations

The operating mode must be Active Cell and the serving cell must be EGPRS. However, parameters associated with Incremental Redundancy can be changed in other operating modes, but do not effect the test set's operation until the operating mode is changed to Active Cell.

The Incremental Redundancy State parameter is only applicable when the connection type is set to Auto.

Related Topics

How do I test Incremental Redundancy?

Tips for analyzing protocol logs of Incremental Redundancy and Retransmission MCS Switching

Retransmission MCS Switching

Puncturing Schemes

Downlink Corruption


Tips for analyzing protocol logs of Incremental Redundancy and Retransmission MCS Switching

Tips for analyzing protocol logs of Incremental Redundancy and Retransmission MCS Switching

Last updated: December 2, 2008

This section is only applicable to the EGPRS lab application.

You can use the Wireless Protocol Advisor (WPA) to observe and analyze messages and information related to incremental redundancy and retransmission modulation and coding scheme switching. This section contains some examples of how you can modify the WPA view to make it easier to access certain fields.

Your default WPA traffic overview column setup may look similar to Default WPA Traffic Overview .

Default WPA Traffic Overview

To more easily see the changes in modulation and coding scheme and to observe any changes in puncturing scheme, you can add protocol field columns to the traffic overview (see WPA Traffic Overview with additional Protocol Field Columns ). If you add the Coding and Puncturing Scheme Indicator field from the RLC_MAC layer, you can see what MCS and PS are being used to send each EGPRS RLC Data message. Adding BSN1 and BSN2, also from the RLC_MAC layer, allows you to see which blocks are being sent and when they are retransmitted. BSN2 is the block sequence number for the second block sent as part of an MCS that sends two RLC blocks at once, therefore, it is only useful if you are using MCS-7, MCS-8, or MCS-9.

NOTE
Refer to the WPA Help for protocol field column configuration instructions. This is accessible from WPA by clicking the help button or for download at

http://www.agilent.com/find/e6584a

WPA Traffic Overview with additional Protocol Field Columns

Related Topics

How do I test Incremental Redundancy?

Incremental Redundancy

How do I test MCS Switching?

Retransmission MCS Switching

Puncturing Schemes


Retransmission MCS Switching

Retransmission MCS Switching

Last updated: December 2, 2008

This section is only applicable to the EGPRS lab application.

The ability of an EGPRS network to adapt the link to the existing radio environment by changing the modulation and coding scheme (MCS) is a fundamental EGPRS capability. There are nine modulation coding schemes used by an EGPRS system, each using different data and channel coding rates with either GMSK or 8PSK modulations. During an established communication, the modulation coding schemes can only be changed within families defined in the 3GPP standard.

Allow MCS Switching

When you enable MCS Switching, the following transitions are supported:

  • MCS9 -> MCS6
  • MCS8 -> MCS6 (padding)
  • MCS7 -> MCS5

The data rate for MCS6 (padding) is 13.6kbit/s. See Modulation Coding Scheme/Puncturing Scheme (MCS/PS) for the data rates of other MCSs.

Downlink Resegmentation

Link adaptation to MCS below MCS5 requires the original RLC data block to be resegmented between two radio blocks. When you enable downlink resegmentation in the test set, all the downlink transitions defined in the 3GPP standard become available:

  • MCS9 -> MCS6 -> MCS3
  • MCS8 -> MCS6 (padding) -> MCS3 (padding)
  • MCS7 -> MCS5 -> MCS2
  • MCS4 -> MCS1

Resegmentation is only supported on the downlink.

The data rate is 13.6kbit/s for MCS3 (padding) and 27.2kbit/s for MCS6 (padding). See Modulation Coding Scheme/Puncturing Scheme (MCS/PS) for the data rates of other MCSs.

Retransmissions before MCS Switch

You can test the mobile station's ability to decode data and header information when the test set switches the modulation and coding scheme used for retransmission of downlink blocks. The test set is triggered to switch the modulation coding scheme based on a user specified number of retransmissions. Once a block has been Not Acknowledged (NACK) by the mobile station and retransmitted the number of times you specify, the test set switches to a modulation coding scheme with a greater probability of being received correctly. The user can force this condition by defining some downlink blocks to be corrupted intentionally by the test set. See Downlink Corruption for more information.

MCS Switch Behavior in Uplink TBFs

You may observe some interesting behavior regarding the MCS on Uplink TBFs. For example, the uplink TBF may start using a different MCS than the one you've specified for the test set to communicate to the MS via RLC MAC Control messages.For the first transmission of RLC data blocks, when the commanded MCS is MCS-7, MCS-5 is used, and for MCS-9, MCS-6 is used. (Refer to 3GPP TS 04.60 Section 8.1.1 for more information.)You can observe this MS behavior using the Wireless Protocol Advisor.

Additionally, you may observe an MCS different than the one commanded being used for the Uplink TBF during additional transmissions as well. This is allowed and typically occurs when the transmission only requires as many radio blocks as are available using an alternate MCS. For example, if the commanded MCS is MCS-9 which sends 2 RLC data blocks, and the mobile station only needs to send one RLC data block, it may choose to send it using MCS-6, which sends only one data block and is also more robust. These exceptions are also specified in 3GPP TS 04.60 Section 8.1.1.

Parameters used for MCS Switching Configuration

Parameter | GPIB Command
Allow MCS Switching | CALL:(PDTCH|PDTChannel):MCSCheme:SWITch[:STATe]
Retransmissions before MCS Switch | CALL:(PDTCH|PDTChannel):MCSCheme:SWITch:RETRansmit
Downlink Resegmentation State | CALL:(PDTCH|PDTChannel):MCSCheme:SWITch:RESegment[:STATe]

Operating Considerations

The operating mode must be Active Cell and the serving cell must be EGPRS. However, parameters associated with MCS Switching can be changed in other operating modes, but do not effect the test set's operation until the operating mode is changed to Active Cell.

MCS Switching is only applicable when the connection type is set to Auto.

Related Topics

How do I test MCS Switching?

Tips for analyzing protocol logs of Incremental Redundancy and Retransmission MCS Switching

Downlink Corruption

Window Size

Incremental Redundancy


Puncturing Schemes

Puncturing Schemes

Last updated: December 2, 2008

This section is only applicable to the EGPRS lab application.

When not using incremental redundancy (see Incremental Redundancy ), you can specify which puncturing scheme should be used for RLC block transmissions on the downlink TBF.

Parameters used for Configuring the Puncturing Scheme

Parameter | GPIB Command
Modulation and Coding Scheme | CALL:(PDTCH|PDTChannel):MCSCheme
Incremental Redundancy State | CALL:(PDTCH|PDTChannel):IREDundancy[:STATe]
Puncturing Scheme | CALL:(PDTCH|PDTChannel):MCSCheme:PSCHeme

Operating Considerations

The operating mode must be Active Cell and the serving cell must be EGPRS. However, puncturing scheme parameters can be changed in other operating modes, but do not effect the test set's operation until the operating mode is changed to Active Cell.

The puncturing scheme parameter is applicable to all connection types except ETSI A.

Incremental redundancy must be turned off before changes to the puncturing scheme are allowed.

To avoid invalid puncturing scheme settings for selected modulation and coding schemes, any change to the Downlink Modulation Coding Scheme parameter causes the Puncturing Scheme to be reset to PS1 . This reset also occurs in the situation where Downlink Modulation Coding Scheme has been set to As Uplink and a change is made to the Uplink Modulation Coding Scheme parameter.

If you attempt to use an invalid puncturing scheme, the test set returns the following error: " Data out of range ".

Related Topics

How do I change the Downlink TBF Puncturing Scheme?


TTI Mode Configuration

TTI Mode Configuration

Last updated: December 2, 2008

This section is only applicable to the EGPRS lab applications.

The TTI mode controls the data transfer latency of a PDTCH block. The two values that the TTI mode can be set are RTTI (Reduced Transmission Time Interval) and BTTI (Basic Transmission Time Interval). The data transfer latency is halved to approximately 10ms when using RTTI mode compared with BTTI. In RTTI mode, you can also select the USF mode and coding scheme to be used for control messaging.

BTTI

In the EGPRS system before Release 7 of the 3GPP standards, the data transfer latency is referred to as transmission time interval (TTI), which is classified as the Basic Transmission Time Interval (BTTI). With BTTI-based transfer, a PDTCH block in the PDTCH multiframe is transmitted across 4 consecutive frames on a single PDTCH physical channel as shown in the figure below.

Since a frame is approximately 4.615ms, the 4 frames gives a TTI of 20ms in a given direction of transfer.

RTTI

Release 7 of the 3GPP standards introduces the capability to reduce the TTI on EGPRS connections by pairing two PDTCH physical channels on different timeslots for data transfer. Usually the pairing timeslots have all frequency characterization in common. In this configuration, defined as Reduced TTI (RTTI), a PDTCH block interleaved over 4 bursts is transmitted on both PDTCHs in the PDTCH-pair across 2 frames as shown in the figure below. Since the number of frames required for transmission has halved, the TTI is halved to approximately 10ms.

The PDTCH timeslots are grouped into pairs for TBF transfer when the TTI mode is configured to RTTI. Furthermore the TTI mode of the downlink and uplink TBFs must be the same. Therefore only multislot configurations with both an even number of downlink and uplink timeslots shall be valid for RTTI mode.

The TTI mode remains BTTI if an attempt is made to change the TTI mode to RTTI when an invalid multislot configuration is configured. Conversely, if an attempt is made to set an invalid multislot configuration when the TTI mode is currently set to RTTI, the new multislot configuration is applied while the TTI mode shall be forced to BTTI.

RTTI USF Mode

The USF Mode is signaled to the mobile station during Packet Uplink Assignment/Reassignment process. The two USF modes that can be selected for an RTTI configuration are BTTI USF mode and RTTI USF mode.

  • BTTI USF mode

    In the RTTI configuration using BTTI USF mode, a given USF is interleaved over the 4 bursts associated with a PDTCH. The USF on the lowest PDTCH of a PDTCH-pair allocates resource in the first reduced radio block period of the next basic radio block period, and the USF on the highest PDTCH of a PDTCH-pair allocates resource for the second reduced radio block period of the next basic radio block period. (Here assume the Assigned USF Granularity is set to 1, otherwise each USF allocates 4 reduced block periods in the same position of consecutive basic radio block periods)

    In the BTTI USF mode, the coding scheme of MCS-0 is used for control messaging.

  • RTTI USF mode (CS1)

    In the RTTI configuration using RTTI USF mode, a separate USF is associated and interleaved over each reduced radio block on the downlink. The USF assigned in the first reduced radio block period on the downlink assigns resource for the second reduced radio block period on the uplink in the same basic radio block period. The USF assigned during the second reduced radio block period on the downlink assigns resource for the first reduced radio block period on the uplink in the next reduced radio block period.

    In the RTTI USF mode (CS1), the coding scheme of CS-1 is used for control messaging.

  • RTTI USF mode (MCS-0))

    The RTTI USF mode (MCS-0) is the same as RTTI USF mode (CS1) with the only exception that the coding scheme of MCS-0 is used for control messaging.

Configurable Parameters

  • TTI Mode

    The TTI Mode allows the selection of whether BTTI or RTTI mode is used for the TBF transmission. The GPIB command to set this parameter is CALL:(PDTCH|PDTChannel):TTI[:MODE] .

  • RTTI USF Mode

    The RTTI USF Mode allows the selection of the USF mode to use for an RTTI configuration, and for the case of RTTI USF mode, also whether CS-1 or MCS-0 is used for control messaging. The GPIB command to set this parameter is CALL:(PDTCH|PDTChannel):USFlag:RTTI[:MODE] .

How to set the TTI mode?

The following procedure details how to access and configure the TTI mode.

  1. Press CALL SETUP .
  2. Press PDTCH parms ( F9 ).
  3. Press the Mor e key on the lower right corner to display the PDTCH parms (3 of 3).
  4. Press TTI Mode ( F7 ). Use the knob to select the TTI mode that you want.

The following procedure details how to access and configure the RTTI USF mode parameter.

  1. Press CALL SETUP .
  2. Press the More key on the lower left corner to display the Control menu (2 of 3).
  3. Press the Protocol Control softkey ( F4 ) to display a list of protocol layers.
  4. Press the RLC/MAC softkey ( F2 ).
  5. Press the MAC control softkey ( F2 ), use the knob to highlight and set the RTTI USF mode.

Operating Considerations

The RTTI configuration is only applicable in Active Cell (EGPRS), EGPRS BCH+PDTCH and EGPRS BCH+TCH+PDTCH operating mode. However, parameters associated with RTTI can be changed in other operating modes, but do not effect the test set's operation until the operating mode is changed to the above values.

When the TTI mode is set to RTTI, performing the following measurements will result in the measurement returning an `Unsupported Configuration' integrity indicator value.

  • GPRS Bit Error Measurement
  • Block Error Measurement
  • EGPRS SRB Bit Error Measurement
  • Block Error Rate (BLER) Reports Description
  • Uplink State Flag (USF) BLER

Related Topics

Downlink Dual Carrier


3G FDD Neighbour Cells

3G FDD Neighbour Cells

Last updated: December 2, 2008

This section is only applicable to the lab applications.

The test set can transmit a list of 3G FDD Neighbour Cells and the associated measurement parameters. The Mobile Station can then decode the information carried about the 3G FDD neighbour cells and subsequently make measurements on them. You can:

  • Configuring 3G FDD Neighbours Table
  • Configuring 3G Measurement Reports Parameters

Configuring 3G FDD Neighbours Table

You can specify 3G FDD Neighbour cells for the 3G FDD radio interface technology within a GSM/GPRS/EGPRS cell. The test set transmits the list of 3G FDD neighbour cells for the mobile station to decode and measure.

The default 3G FDD neighbour cell list is empty, so there is no information in the list for the test set to transmit to the mobile station. The 3G FDD neighbour cell list must have at least one valid entry in order for the test set to broadcast the information to the mobile station. For each 3G FDD neighbour cell specified the following information must always be provided: UARFCN, scrambling code indication, scrambling code, diversity indicator and the reporting priority. The test set uses the scrambling code indicator to indicate whether or not the scrambling code and diversity indicator are used. The scrmabling code indicator is only applicable if you are setting the 3G FDD neighbour list via GPIB command, it is not present on the MUI.

The number of 3G FDD neighbour cells that may be specified depends on a combination of the number of unique UARFCNs and the number of unique scrambling codes used. The table below shows which combinations of unique UARFCNs and scrambling codes the test set will allow.

Table 1: Unique UARFCN and Scrambling Code Restrictions
Number of Unique UARFCNs | Number of Unique Scrambling Codes
1 | 13
2 | 6
3 | 6
4 | 4
5 | 0

For example, if no unique scrambling codes are used, there can five unique UARFCNs specified. That is, if you wish to have 5 different 3G FDD neighbour cells, no scrambling codes can be used.

Once the FDD neighbour cell list is specified, the test set transmits the list information via a Packet System Information 3 Quater message on the Packet Broadcast Control Channel (PBCCH) , if it is present within the cell. If the PBCCH is not present the list information is transmitted via a System Information 2 Quater message on the Broadcast Control Channel (BCCH).

NOTE
The test set transmits only the list of neighbour cells, it does not generate any of the FDD neighbour cell signals.

The 3G FDD Neighbours Table allows you to configure the UARFCN, Reporting Priority, Scrambling code, and Diversity for each 3G FDD Neighbour Cell.

The GPIB commands to configure the 3G FDD Neighbour Cell List are as follows:

Parameter | Command
3G FDD Neighbour Cell List | CALL[:CELL]:UTRAN:FDDuplex:TABLe You can query the number of points in the specified cell list with the command CALL[:CELL]:UTRAN:FDDuplex:TABLe:POINts? .
Extended 3G FDD Neighbour Cell List | CALL[:CELL]:UTRAN:FDDuplex:TABLe:EXTended You can query the number of points in the specified cell list with the command CALL[:CELL]:UTRAN:FDDuplex:TABLe:EXTended:POINts? .

Settings to the 3G FDD neighbour cell parameters are stored, but not applied until the neighbour cell is enabled.

You can also control 3G FDD neighbour cell parameters via the test set's front panel. The following procedure explains how to access the menus that allow you to configure simulated 3G FDD Neighbour Cell parameters, when available. The Neighbour Cell menus are located in the Cell List menu.

  1. Press CALL SETUP .
  2. Press Cell Info ( F6 ).
  3. Press Cell Lists ( F4 ).-
  4. Press 3G FDD Neighbours ( F4 ).
  5. Use the knob to scroll to and highlight the Neighbour Cell you wish to configure.
  6. Press the knob. This displays the 3G FDD Neighbour Cell menu (similar to the figure below) that contains the configurable parameters for that Neighbour Cell.

    NOTE: You must enable the neighbour cell (set the State parameter to On), before you can access the other neighbour cell parameters.

  7. Use the knob to highlight the desired parameter. Rotate the knob or use the number keys to set the value for the parameter.

Configuring 3G Measurement Reports Parameters

The following table lists the configurable measurement parameters and their associated commands. See 3GPP TS 04.018 Version 8.23.0 and 3GPP TS 05.08 Version 8.16.0 for more details on the information elements defined in the table.

Parameter | GPIB Command
3G Measurement Parameters Inclusion | CALL[:CELL]:UTRAN[:ALL]:MPDescr
3G Search Priority | CALL[:CELL]:UTRAN[:ALL]:MPDescr:TGSPriority
FDD GPRS Qoffset | CALL[:CELL]:UTRAN[:ALL]:MPDescr:FDDinfo:QOFFset:GPRS
FDD Measurement Parameters Inclusion | CALL[:CELL]:UTRAN[:ALL]:MPDescr:FDDinfo
FDD Multi-RAT Reporting | CALL[:CELL]:UTRAN[:ALL]:MPDescr:FDDinfo:MREPorting
FDD Qmin | CALL[:CELL]:UTRAN[:ALL]:MPDescr:FDDinfo:QMINimum
FDD Qoffset | CALL[:CELL]:UTRAN[:ALL]:MPDescr:FDDinfo:QOFFset[:GSM]
FDD Reporting Quantity | CALL[:CELL]:UTRAN[:ALL]:MPDescr:FDDinfo:RQUantity
FDD Reporting Offset | CALL[:CELL]:UTRAN[:ALL]:MPDescr:FDDinfo:ROFFset
FDD Reporting Threshold | CALL[:CELL]:UTRAN[:ALL]:MPDescr:FDDinfo:RTHReshold
Qsearch_C_initial | CALL[:CELL]:UTRAN[:ALL]:MPDescr:QSC:INITial
Qsearch C | CALL[:CELL]:UTRAN[:ALL]:MPDescr:QSC
Qsearch_I | CALL[:CELL]:UTRAN[:ALL]:MPDescr:QSI
Qsearch P | CALL[:CELL]:UTRAN[:ALL]:MPDescr:QSP

The 3G measurement reports parameters can also be configured manually by doing the following steps:

  1. Press CALL SETUP .
  2. Press the left More key to advance the Control menu to ( 2 of 3 ).
  3. Press Measurement Reports ( F6 ).
  4. Press Configure ( F2 ).
  5. Press 3G Meas Parameters ( F2 )
  6. Use the knob to highlight the desired parameter. Rotate the knob or use the number keys to set the value for the parameter.

Operating Considerations

The 3G FDD neighbour cell settings are sent with the transmitted signal when the test set's Operating Mode is set to one of the following: GSM BCH, GPRS BCH, EGPRS BCH, GSM BCH+TCH, GPRS BCH+PDTCH, EGPRS BCH+PDTCH, or Active Cell with the Serving Cell set to GSM, GPRS, or EGPRS.

Related Topics

Measurement Reports

CALL:UTRan


How do I make a GSM Bad Frame Indication (BFI) Measurement?

How do I make a GSM Bad Frame Indication (BFI) Measurement?

Last updated: December 2, 2008

This section is only applicable to the lab applications and to GSM.

This procedure assumes that the BCH parameter for Cell Band is set up correctly for your mobile station and that the appropriate RF IN/OUT Amplitude Offsets have been set to offset loss between the mobile station and the test set.

Measuring 3GPP TS 51.010 Section 14.1.1 BFI

  1. Press the CALL SETUP key.
  2. Press BCH Parameters ( F7 ).
  3. Press Cell Power ( F7 ) and set cell power to a value 20 dB above the reference sensitivity level for the band in which you are testing. Reference sensitivity levels can be found in 3GPP TS 05.05 section 6.2.
  4. Press Return ( F12 ).
  5. Press TCH Parameters ( F8 ).
  6. Press Downlink Traffic Power ( F7 ) and select Power Reduction Level One (PRL One) . Enter 9 dB . (Set the power reduction level to 9 dB when performing 3GPP TS 51.010 test 14.1.1, 14.1.2, 14.1.5 or 14.1.6. The power used for downlink traffic channels will then be 11 dB above the reference sensitivity level if the cell power is set 20 dB above this level.)
  7. Verify that the Power Reduction Level Used Burst is set to PRL One .
  8. Press Traffic Channel ( F9 ) and enter a value in the middle of the ARFCN range for the band in which you are testing.
  9. Press MS TX Level ( F10 ) and enter the value for maximum power for the band in which you are testing.
  10. Press Channel Mode Setup ( F11 ).
  11. Press Channel Mode Config ( F7 ) and select the correct Logical Speech Channel .
  12. Connect the mobile station to the test set and turn in on. Allow it to camp to the test set's signal.
  13. Establish a GSM phone call.

    NOTE
    You MUST establish the GSM phone call before the following configuration steps. The measurement does not work correctly if you configure speech type and the mobile loopback before a call is established.

  14. Press the More softkey on the right side of the front panel display to access the TCH Parms ( 2 of 2 ) menu.
  15. Press Speech ( F10 ) and select SID.

    NOTE
    Step 15 is omitted and SIDs are not sent if the Logical Speech Channel is set to AFS (Adaptive Full) or AHS (Adaptive Half). This means that more frames are available for the measurement on AFS and AHS speech channel and there is no count of incorrectly marked SIDs.

  16. Press Mobile Loopback ( F9 ) and select Type A.
  17. Press the Measurement Selection key.
  18. Select GSM Bad Frame Indication . The measurement will start.
  19. Press Bad Frame Ind Setup ( F1 ).

    NOTE
    Notice that the default Samples to Test value is 492000 . This is the number specified in 3GPP TS 51.010 test 14.1.1, 14.1.2, 14.1.5 and 14.1.6 for this test. This measurement can take over 45 minutes to complete this number of samples.

  20. Select Speech Frame Delay and enter the appropriate value for your mobile station. You may not get expected results if this is not configured correctly. See Speech Frame Delay for more details about this parameter.
  21. Verify the measurement results meet the conformance requirements defined in 3GPP TS 51.010 section 14.1.1, 14.1.2, 14.1.5 or 14.1.6. Acceptable performance for the BFI test limit error rate is less than or equal to 0.041%.

Related Topics

GSM Bad Frame Indication (BFI) Measurement Description


How Do I Make a Repeated SACCH Frame Erasure Rate (FER) Measurement?

How Do I Make a Repeated SACCH Frame Erasure Rate (FER) Measurement?

Last updated: December 2, 2008

This section is only applicable to the lab applications and is not applicable to GPRS or EGPRS.

This procedure assumes that the BCH parameter for Cell Band is set up correctly for your mobile station and that the appropriate RF IN/OUT Amplitude Offsets have been set to offset loss between the mobile station and the test set.

  1. Press the CALL SETUP key.
  2. Press TCH Parameters ( F8 ).
  3. Press Traffic Channel ( F9 ) and enter a value on the low end of the ARFCN range for the band in which you are testing.
  4. Press MS TX Level ( F10 ) and enter the value for maximum power for the band in which you are testing.
  5. Press Return ( F12 ).
  6. Connect the mobile station to the test set and turn in on. Allow it to camp to the test set's signal.
  7. Establish a GSM phone call.
  8. Press BCH Parameters ( F7 ).
  9. Press Cell Power ( F7 ) and set cell power to the reference sensitivity level for the band in which you are testing. Reference sensitivity levels can be found in 3GPP TS 05.05 section 6.2.
  10. Press the Measurement Selection key.
  11. Select GSM Frame Erasure Rate . The measurement will start. If the measurement is progressing, the count in the bottom left of the measurement's screen increments.
  12. Press FER Setup ( F1 ).

    NOTE
    Notice that the default Samples to Test value is either 13736 (for DCS and PCS) or 6696 (for all other bands). These are the numbers specified in 3GPP TS 51.010. (For FACCH/F, refer to section 14.2.3, table 14-9. For FACCH/H, refer to section 14.2.4, table 14-10.) This measurement can take over 30 minutes to complete this number of samples.

  13. Modify the setup parameters as you see fit.
  14. Verify the measurement results meet the conformance requirements specified in 3GPP 51.010 (For FACCH/F, refer to section 14.2.3, table 14-9. For FACCH/H, refer to section 14.2.4, table 14-10.) The minimum samples tested is 13736 and the Frame Erasure Rate depends on which cell band the mobile station is operating.

A typical measurement report is shown above.

Related Topics

GSM Frame Erasure Rate (FER) Measurement Description


How Do I Set Up and Use the Frequency Hopping Feature?

How Do I Set Up and Use the Frequency Hopping Feature?

Last updated: December 2, 2008

This section is only applicable to the lab applications.

The following procedures assume the BCH Parameters for the Cell Band are set up correctly for your mobile station and the appropriate RF IN/OUT Amplitude Offsets have been set to the offset loss between the mobile station and the test set.

This section details the manual operation procedures for:

  • Changing the Cell Allocation (CA) Table
  • Setting up Frequency Hopping for GSM Traffic Channels
  • Setting up Frequency Hopping for GPRS Packet Data Channels
  • Setting up Frequency Hopping for EGPRS Packet Data Channels
  • Viewing Frequency Hopping with the Spectrum Monitor

Changing the Cell Allocation (CA) Table

The CA Table lists all the channels available to the cell. The entries in the CA Table are important because the MA Tables can only use channels that are in the CA Table. The following procedure details how to change the CA Table.

  1. Press the CALL SETUP key.
  2. Press Operating Mode ( F1 ) and choose Cell Off from the menu.
  3. Press Cell Info ( F6 )
  4. Press Cell Lists ( F4 ).

  5. Press CA Table ( F2 ). The CA Table menu that appears should look similar to the figure below.

    Note: The entries in the CA Table below contains the test set's default values.

    NOTE
    The Operating Mode must be Cell Off in order to change any values in the CA Table . If the Operating Mode is not Cell Off all the entries in the CA Table will be gray.

Setting up Frequency Hopping for GSM Traffic Channels

  1. Press the CALL SETUP key.
  2. Press Operating Mode ( F1 ) and select Active Cell ( GSM, GPRS, or EGPRS ) or GSM BCH+TCH
  3. Press TCH Parameters ( F8 )
  4. Press the More key on the right side of the screen so 2 of 2 is displayed.
  5. Press Frequency Hopping ( F11 ).
  6. Press Freq Hopping ( F7 ) and turn the state to On .
  7. Press HSN ( F8 ) and choose a Hopping Sequence Number.

  8. Press MA Table ( F9 ). A menu similar to the figure below appears that shows all the ARFCNs that are currently in the MA Table for the selected band. The figure below is the default MA Table for the PCS band.

    • To change the state of any ARFCN, you must first set the MA Table Configuration to Manual. Notice when the MA Table Configuration is set to Manual all of the table entries change from gray to black.

    • To change the values that are in the MA Table , you must change the Cell Allocation (CA) Table first by adding/changing ARFCNs for the desired band. See Changing the Cell Allocation (CA) Table for the manual operation procedure for changing the CA Table .

  9. Press Meas ARFCN ( F11 ) to set the Measurement ARFCN. Use the knob to scroll through the choices for the Measurement ARFCN.
  10. Originate a call between the test set and the mobile station.
  11. View the frequency hopping. The Spectrum Monitor that is incorporated into the test set is a useful instrument for this purpose. See Viewing Frequency Hopping with the Spectrum Monitor for an example of how you might view frequency hopping. Note: The Traffic Channel ( F9 ) field under the TCH Parms menu disappears from the front panel when frequency hopping is enabled.

Setting up Frequency Hopping for GPRS Packet Data Channels

  1. Press the CALL SETUP key.
  2. Press Operating Mode ( F1 ) and select Active Cell ( GPRS ) or GPRS BCH+PDTCH .
  3. Press PDTCH Parameters ( F9 )
  4. Follow steps 4-9 in Setting up Frequency Hopping for GSM Traffic Channels .
  5. Start a data connection.
  6. View the frequency hopping. The Spectrum Monitor that is incorporated into the test set is a useful instrument for this purpose. See Viewing Frequency Hopping with the Spectrum Monitor for an example of how you might view frequency hopping.

Setting up Frequency Hopping for EGPRS Packet Data Channels

  1. Press the CALL SETUP key.
  2. Press Operating Mode ( F1 ) and select Active Cell ( EGPRS ) or EGPRS BCH+PDTCH .
  3. Press PDTCH Parameters ( F9 )
  4. Follow steps 4-9 in Setting up Frequency Hopping for GSM Traffic Channels .
  5. Start a data connection.
  6. View the frequency hopping. The Spectrum Monitor that is incorporated into the test set is a useful instrument for this purpose. See Viewing Frequency Hopping with the Spectrum Monitor for an example of how you might view frequency hopping.

Viewing Frequency Hopping with the Spectrum Monitor

This procedure assumes that the BCH parameter for Cell Band is set up correctly for your mobile station and that the appropriate RF IN/OUT Amplitude Offsets have been set to offset loss between the mobile station and the test set.

  1. Set up frequency hopping for a GSM, GPRS, or EGPRS connection. See Setting up Frequency Hopping for GSM Traffic Channels , Setting up Frequency Hopping for GPRS Packet Data Channels , or Setting up Frequency Hopping for EGPRS Packet Data Channels .
  2. Press Instrument Selection.
  3. Choose Spectrum Monitor from the Instrument Selection list.
  4. Select Frequency Span (F1) and set it to zero. The zero span mode of operation allows you to see whether or not an ARFCN was present in a particular frame.
  5. Press the Trigger Setup (F4) and choose Protocol from the Trigger Source list.
  6. Press Time Span (F8) and set to 15 ms.

  7. Press Trigger Arm (F3) to Continuous. You should see a screen similar to the figure below. The frequency should appear to be hopping as it changes in a cyclic or random way, depending on the setting for the HSN. The figure below is a plot of power vs. time when frequency hopping is enabled and the Measurement ARFCNs are 1 and 10 for the PGSM band.

  8. The figure below is a plot of power vs. time when frequency hopping is off and when the Measurement ARFCNs are 1 and 10 for the PGSM band.

Related Topics

Frequency Hopping

Spectrum Monitor Description

CALL:TCHannel

CALL:(PDTCH|PDTChannel)

CALL:CA


How do I test Incremental Redundancy?

How do I test Incremental Redundancy?

Last updated: December 2, 2008

This section is only applicable to the EGPRS lab application.

Observing Incremental Redundancy

The only way to observe the puncturing scheme changes made by the incremental redundancy algorithm is to use the protocol logging capability of the test set. One way to observe this is to use your mobile station as a modem and transfer a file over the air. Transferring something large allows you to more easily observe changes. See Modem Functional Test with the Data Channel or FTP Throughput Test with the Data Channel for more details. For help setting up the Wireless Protocol Advisor (WPA) for protocol logging see Protocol Logging .

Procedure

This procedure assumes that the BCH parameter for Cell Band is set up correctly for your mobile station and that the appropriate RF IN/OUT Amplitude Offsets have been set to offset loss between the mobile station and the test set. Additionally, this procedure also assumes that the WPA is running and has already established a connection with the test set.

NOTE
The parameter values chosen below set up the protocol stack according to the Method of Test for Incremental Redundancy Performance defined in 3GPP TS 51.010 Section 14.18.7. See Support for the Incremental Redundancy Performance Specification for more details.

  1. Press the CALL SETUP key.
  2. Press Operating Mode ( F1 ) and select Active Cell (EGPRS) .
  3. Select PDTCH Parameters ( F9 ) from the Call Parms menu.
  4. Select MS TX Level ( F10 ) from the PDTCH Parms menu. The MS TX Level popup menu appears. Enter the value that corresponds to the maximum transmit power on the uplink for the active Cell Band.
  5. Select Modulation Coding Scheme ( F11 ) from the PDTCH Parms menu. The Modulation Coding Scheme popup menu appears.
  6. Select Uplink Modulation Coding Scheme and select MCS-9 .
  7. Select Incremental Redundancy and select On .
  8. Press the More softkey on the right side of the front panel display to access the PDTCH Parms ( 2 of 2 ) menu.
  9. Select Multislot Config ( F7 ) and select the maximum number of timeslots supported by the mobile station you are testing.
  10. Press the More softkey on the left side of the front panel display to access the Control ( 2 of 2 ) menu.
  11. Select Protocol Control ( F4 ).
  12. Select RLC/MAC ( F2 ).
  13. Select the Block Poll Rate and enter 32 .
  14. Press the More softkey on the left side of the front panel display to access the RLC/MAC Ctrl ( 2 of 2 ) menu.
  15. Select Window Size and select Maximum .
  16. Start protocol logging.
  17. Start transferring data.
  18. Set Cell Power to -97 dBm.
  19. Stop protocol logging when the data transfer is complete. See Tips for analyzing protocol logs of Incremental Redundancy and Retransmission MCS Switching for help with analyzing the log.

Related Topics

Tips for analyzing protocol logs of Incremental Redundancy and Retransmission MCS Switching


How do I test MCS Switching?

How do I test MCS Switching?

Last updated: December 2, 2008

This section is only applicable to the EGPRS lab application.

Observing MCS Switching

It is necessary for you to use the protocol logging capability of the test set to observe the MCS changes. One way to observe this is to use your mobile station as a modem and transfer a file over the air. Transferring something large allows you to more easily observe changes. See Modem Functional Test with the Data Channel or FTP Throughput Test with the Data Channel for more details. For help setting up the Wireless Protocol Advisor for protocol logging see Protocol Logging .

Setup and Activate MCS Switching

This procedure assumes that the BCH parameter for Cell Band is set up correctly for your mobile station and that the appropriate RF IN/OUT Amplitude Offsets have been set to offset loss between the mobile station and the test set. Additionally, this procedure also assumes that the WPA is running and has already established a connection with the test set.

  1. Press the CALL SETUP key.
  2. Press Operating Mode ( F1 ) and select Active Cell (EGPRS) .
  3. Select PDTCH Parameters ( F9 ) from the Call Parms menu.
  4. Select Modulation Coding Scheme ( F11 ) from the PDTCH Parms menu. The Modulation Coding Scheme popup menu appears.
  5. Highlight Downlink Modulation Coding Scheme and verify that the value is set to As Uplink .
  6. Scroll to Uplink Modulation Coding Scheme and select to change to the value you desire. For example, if you choose MCS-9 and add downlink corruption, the MCS switches to MCS-6 as retransmissions are requested.
  7. Press Close Menu ( F6 ).
  8. Press the More softkey on the left side of the front panel display to access the Control ( 2 of 3 ) menu.
  9. Select Protocol Control ( F4 ).
  10. Select RLC/MAC ( F2 ).
  11. Press the More softkey on the left side of the front panel display to access the RLC/MAC Ctrl ( 2 of 2 ) menu.
  12. Select Retransmission MCS Switching ( F1 ). The Retransmission MCS Switching popup menu appears.
  13. Select Allow MCS Switching and select On .
  14. Select Retransmissions before MCS switch and enter 2 . This forces the test set to switch the MCS when a block the mobile station requests retransmission of the same block twice.

    NOTE
    Another way to observe MCS Switching is corrupt some of the downlink blocks. See How to Setup Corruption of Downlink Blocks .

  15. If you want to enable link adaptation to MCS below MCS5, select Downlink Resegmentation from this menu and select On .
  16. Select Close Menu ( F6 ).
  17. Start protocol logging.
  18. Start transferring data.
  19. Stop protocol logging when the data transfer is complete. See Tips for analyzing protocol logs of Incremental Redundancy and Retransmission MCS Switching for help with analyzing the log.

How to Setup Corruption of Downlink Blocks

To force the mobile station to request retransmission of blocks and therefore force the test set to switch to a more robust MCS, you can set up the deliberate corruption of downlink blocks.

  1. Press the CALL SETUP key.
  2. Press the More softkey on the left side of the front panel display to access the Control ( 2 of 3 ) menu.
  3. Select Protocol Control ( F4 ).
  4. Select Layer 1 ( F1 ).
  5. Select PDTCH Downlink Corruption ( F1 ). The Downlink Corruption popup menu appears.
  6. Select Downlink Corruption and select On . Parameters for configuring the downlink corruption appear. See Downlink Corruption for more information.

How to View the Downlink Corruption Blocks in the Wireless Protocol Advisor (WPA)

This procedure assumes that the BCH parameter for Cell Band is set up correctly for your mobile station and that the appropriate RF IN/OUT Amplitude Offsets have been set to offset loss between the mobile station and the test set.

  1. Setup the Downlink Corruption parameters on the test set. See How to Setup Corruption of Downlink Blocks for more details.
  2. Configure the WPA test set filter to filter the Layer 1 Information protocol.
  3. Start the WPA. See How to use Protocol Logging for more details.
  4. Press Start Data Connection (F3).
  5. Stop the WPA. See How to use Protocol Logging for more details.
  6. View the message decode for Downlink Frame Integrity messages (for Layer 1 Protocol). The figure below is an example of a Downlink Frame Integrity message.

    .

Related Topics

Tips for analyzing protocol logs of Incremental Redundancy and Retransmission MCS Switching


How do I change the Downlink TBF Puncturing Scheme?

How do I change the Downlink TBF Puncturing Scheme?

Last updated: December 2, 2008

This section is only applicable to the EGPRS lab application.

  1. Press the CALL SETUP key.
  2. Press Operating Mode ( F1 ) and select Active Cell (EGPRS) .
  3. Select PDTCH Parameters ( F9 ) from the Call Parms menu.
  4. Select Modulation Coding Scheme ( F11 ) from the PDTCH Parms menu. The Modulation Coding Scheme popup menu appears.
  5. Select either Downlink Modulation Coding Scheme or Uplink Modulation Coding Scheme and set the value you want. The modulation format is different depending on the MCS you select:
    • MCS-1 through MCS-4 use a GMSK modulation format.
    • MCS-5 through MCS-9 use an 8PSK modulation format.
  6. Select Puncturing Scheme and scroll to the desired value. The puncturing schemes available depend on the modulation and coding scheme you selected above.
    • MCS-1, MCS-2, MCS-5, and MCS-6 allow PS 1 and PS 2.
    • MCS-3, MCS-4, MCS-7, MCS-8, and MCS-9 allow PS 1, PS 2, and PS 3.

    The Incremental Redundancy parameter must be set to Off for you to specify which puncturing scheme is to be used. When Incremental Redundancy is On , the puncturing scheme setting is controlled by an algorithm in the test set.

Related Topics

Puncturing Schemes


FETCh:<BFINdication|BFI>

FETCh:<BFINdication|BFI>

Last updated: December 2, 2008

GPIB Command Conventions

  • FETCh:<BFINdication|BFI>[:ALL]?
  • FETCh:<BFINdication|BFI>:COUNt[:UBFRames]?
  • FETCh:<BFINdication|BFI>:COUNt:BSID?
  • FETCh:<BFINdication|BFI>:ICOunt?
  • FETCh:<BFINdication|BFI>:INTegrity?
  • FETCh:<BFINdication|BFI>:NSID?
  • FETCh:<BFINdication|BFI>:RATio[:UBFRames]?
  • FETCh:<BFINdication|BFI>:RATio:BSID?
  • FETCh:<BFINdication|BFI>:SAMPles?

FETCh:<BFINdication|BFI>[:ALL]?

Function

GSM/GPRS LA

This query returns the bad frame indication measurement results. The integrity indicator, number of samples counted, number of undetected bad frames, number of SIDs reported as bad frames, and the number of SIDs sent are returned.
EGPRS LA
GSM TA

This command is not applicable to the GSM Test Application.

GPRS TA

 This command is not applicable to GPRS.

EGPRS TA

 This command is not applicable to EGPRS.

Query

Integrity indicator:

  • Range: See Integrity Indicator .
  • Resolution: 1

Samples

  • Range: 0 to 999999 and 9.91E+37 (NAN)
  • Resolution: 1

Undetected Bad Frames

  • Range: 0 to 999999 and 9.91E+37 (NAN)
  • Resolution: 1

SIDs marked as BFI

  • Range: 0 to 999999 and 9.91E+37 (NAN)
  • Resolution: 1

SIDs sent

  • Range: 0 to 999999 and 9.91E+37 (NAN)
  • Resolution: 1
Requirements GSM/GPRS/ EGPRS LA

Revision: C.03 and above

FETCh:<BFINdication|BFI>:COUNt[:UBFRames]?

Function | GSM/GPRS LA | This query returns the number of undetected bad frames.
 | EGPRS LA
 | GSM TA | This command is not applicable to the GSM Test Application.
 | GPRS TA | This command is not applicable to GPRS.
 | EGPRS TA | This command is not applicable to EGPRS.
Query |  | Range: 0 to 999999 and 9.91 E+37 (NAN) Resolution: 1
Requirements | GSM/GPRS/ EGPRS LA | Revision: C.03 and above

FETCh:<BFINdication|BFI>:COUNt:BSID?

Function | GSM/GPRS LA | This query returns the number of SIDs reported as bad frames.
 | EGPRS LA
 | GSM TA | This command is not applicable to the GSM Test Application.
 | GPRS TA | This command is not applicable to GPRS.
 | EGPRS TA | This command is not applicable to EGPRS.
Query |  | Range: 0 to 999999 and 9.91 E+37 (NAN) Resolution: 1
Requirements | GSM/GPRS/ EGPRS LA | Revision: C.03 and above

FETCh:<BFINdication|BFI>:ICOunt?

Function | GSM/GPRS LA | Queries the intermediate count (measurement progress report) of samples.
 | EGPRS LA
 | GSM TA | This command is not applicable to the GSM Test Application.
 | GPRS TA | This command is not applicable to GPRS.
 | EGPRS TA | This command is not applicable to EGPRS.
Query |  | Range: 0 to 999999 and 9.91 E+37 (NAN)
Requirements | GSM/GPRS/ EGPRS LA | Revision: C.03 and above

FETCh:<BFINdication|BFI>:INTegrity?

Function | GSM/GPRS LA | This query returns the integrity indicator value for the last bad frame indication measurement performed. Zero indicates a normal result. See Integrity Indicator for descriptions of non-zero integrity indicators.
 | EGPRS LA
 | GSM TA | This command is not applicable to the GSM Test Application.
 | GPRS TA | This command is not applicable to GPRS.
 | EGPRS TA | This command is not applicable to EGPRS.
Query |  | Range: See Integrity Indicator . Resolution: 1
Requirements | GSM/GPRS/ EGPRS LA | Revision: C.03 and above

FETCh:<BFINdication|BFI>:NSID?

Function | GSM/GPRS LA | This query returns the number of SIDs sent to the mobile station.
 | EGPRS LA
 | GSM TA | This command is not applicable to the GSM Test Application.
 | GPRS TA | This command is not applicable to GPRS.
 | EGPRS TA | This command is not applicable to EGPRS.
Query |  | Range: 0 to 999999 and 9.91 E+37 (NAN) Resolution: 1
Requirements | GSM/GPRS/ EGPRS LA | Revision: C.03 and above

FETCh:<BFINdication|BFI>:RATio[:UBFRames]?

Function | GSM/GPRS LA | This query returns the ratio of the number of undetected bad frames to the number of samples counted.
 | EGPRS LA
 | GSM TA | This command is not applicable to the GSM Test Application.
 | GPRS TA | This command is not applicable to GPRS.
 | EGPRS TA | This command is not applicable to EGPRS.
Query |  | Range: 0 to 100% and 9.91 E+37 (NAN) Resolution: 0.1
Requirements | GSM/GPRS/ EGPRS LA | Revision: C.03 and above

FETCh:<BFINdication|BFI>:RATio:BSID?

Function | GSM/GPRS LA | This query returns the ratio of the number of SIDs reported as bad frames to the number of SIDs sent.
 | EGPRS LA
 | GSM TA | This command is not applicable to the GSM Test Application.
 | GPRS TA | This command is not applicable to GPRS.
 | EGPRS TA | This command is not applicable to EGPRS.
Query |  | Range: 0 to 100% and 9.91 E+37 (NAN) Resolution: 0.1
Requirements | GSM/GPRS/ EGPRS LA | Revision: C.03 and above

FETCh:<BFINdication|BFI>:SAMPles?

Function | GSM/GPRS LA | This query returns the number of samples counted.
 | EGPRS LA
 | GSM TA | This command is not applicable to the GSM Test Application.
 | GPRS TA | This command is not applicable to GPRS.
 | EGPRS TA | This command is not applicable to EGPRS.
Query |  | Range: 0 to 999999 and 9.91 E+37 (NAN) Resolution: 1
Requirements | GSM/GPRS/ EGPRS LA | Revision: C.03 and above


FETCh:FFERate

FETCh:FFERate

Last updated: December 2, 2008

GPIB Command Conventions

  • FETCh:FFERate[:ALL]?
  • FETCh:FFERate:COUNt?
  • FETCh:FFERate:ICOunt?
  • FETCh:FFERate:INTegrity?
  • FETCh:FFERate:RATio?
  • FETCh:FFERate:SAMPles?

FETCh:FFERate[:ALL]?

Function

GSM/GPRS LA

This query returns the FACCH frame error rate measurement results. The integrity indicator, samples counted, frame erasure ratio, and frame erasure count are returned.
EGPRS LA
GSM TA

This command is not applicable to the GSM Test Application.

GPRS TA

 This command is not applicable to GPRS.

EGPRS TA

 This command is not applicable to EGPRS.

Query

Integrity indicator:

  • Range: See Integrity Indicator .
  • Resolution: 1

Samples

  • Range: 0 to 999999 and 9.91E+37 (NAN)
  • Resolution: 1

Frame erasure ratio

  • Range: 0 to 100% and 9.91E+37 (NAN)
  • Resolution: 0.001

Frame erasure count

  • Range: 0 to 999999 and 9.91E+37 (NAN)
  • Resolution: 1
Requirements GSM/GPRS/ EGPRS LA

Revision: C.03 and above

FETCh:FFERate:COUNt?

Function | GSM/GPRS LA | This query returns the frame erasure count, or the number of retransmissions made.
 | EGPRS LA
 | GSM TA | This command is not applicable to the GSM Test Application.
 | GPRS TA | This command is not applicable to GPRS.
 | EGPRS TA | This command is not applicable to EGPRS.
Query |  | Range: 0 to 999999 and 9.91 E+37 (NAN) Resolution: 1
Requirements | GSM/GPRS/ EGPRS LA | Revision: C.03 and above

FETCh:FFERate:ICOunt?

Function | GSM/GPRS LA | Queries the intermediate count (measurement progress report) of samples tested.
 | EGPRS LA
 | GSM TA | This command is not applicable to the GSM Test Application.
 | GPRS TA | This command is not applicable to GPRS.
 | EGPRS TA | This command is not applicable to EGPRS.
Query |  | Range: 0 to 999999 and 9.91 E+37 (NAN)
Requirements | GSM/GPRS/ EGPRS LA | Revision: C.03 and above

FETCh:FFERate:INTegrity?

Function | GSM/GPRS LA | This query returns the integrity indicator value for the last FACCH frame erasure rate measurement performed. Zero indicates a normal result. See Integrity Indicator for descriptions of non-zero integrity indicators.
 | EGPRS LA
 | GSM TA | This command is not applicable to the GSM Test Application.
 | GPRS TA | This command is not applicable to GPRS.
 | EGPRS TA | This command is not applicable to EGPRS.
Query |  | Range: See Integrity Indicator . Resolution: 1
Requirements | GSM/GPRS/ EGPRS LA | Revision: C.03 and above

FETCh:FFERate:RATio?

Function | GSM/GPRS LA | This query returns the frame erasure rate which is the ratio of frames erased to frames sampled.
 | EGPRS LA
 | GSM TA | This command is not applicable to the GSM Test Application.
 | GPRS TA | This command is not applicable to GPRS.
 | EGPRS TA | This command is not applicable to EGPRS.
Query |  | Range: 0 to 100% and 9.91 E+37 (NAN) Resolution: 0.001
Requirements | GSM/GPRS/ EGPRS LA | Revision: C.03 and above

FETCh:FFERate:SAMPles?

Function | GSM/GPRS LA | This query returns the number of samples counted.
 | EGPRS LA
 | GSM TA | This command is not applicable to the GSM Test Application.
 | GPRS TA | This command is not applicable to GPRS.
 | EGPRS TA | This command is not applicable to EGPRS.
Query |  | Range: 0 to 999999 and 9.91 E+37 (NAN) Resolution: 1
Requirements | GSM/GPRS/ EGPRS LA | Revision: C.03 and above


SETup:<BFINdication|BFI>

SETup:<BFINdication|BFI>

Last updated: December 2, 2008

GPIB Command Conventions

  • SETup:<BFINdication|BFI>:CONTinuous
  • SETup:<BFINdication|BFI>:SAMPles
  • SETup:<BFINdication|BFI>:SFDelay
  • SETup:<BFINdication|BFI>:TIMeout[:STIMe]
  • SETup:<BFINdication|BFI>:TIMeout:TIME
  • SETup:<BFINdication|BFI>:TIMeout:STATe

SETup:<BFINdication|BFI>:CONTinuous

Function

GSM/GPRS LA

This command sets/queries the trigger state to single trigger mode or continuous trigger mode for the bad frame indication (BFI) measurement.
EGPRS LA
GSM TA

This command is not applicable to the GSM Test Application.

GPRS TA

 This command is not applicable to GPRS.

EGPRS TA

 This command is not applicable to EGPRS.
Setting

Range: 0 | OFF | 1 | ON

Query

Range: 0 | 1
*RST Setting

0 | OFF
Requirements GSM/GPRS/ EGPRS LA

Revision: C.03 and above

Programming Example

OUTPUT 714;"SETup:BFI:CONTinuous OFF"
! Sets BFI measurement to single trigger mode.

SETup:<BFINdication|BFI>:SAMPles

Function

GSM/GPRS LA

This command sets/queries the number of samples to be taken by the bad frame indication measurement.
EGPRS LA
GSM TA

This command is not applicable to the GSM Test Application.

GPRS TA

 This command is not applicable to GPRS.

EGPRS TA

 This command is not applicable to EGPRS.
Setting

Range: 1 to 999999

Resolution: 1

Query

Range: 1 to 999999

Resolution: 1
*RST Setting

492000
Requirements GSM/GPRS/ EGPRS LA

Revision: C.03 and above

Programming Example

OUTPUT 714;"SETup:BFI:SAMPles 555000"
! Sets the number of samples to measure to 555000.

SETup:<BFINdication|BFI>:SFDelay

Function

GSM/GPRS LA

This command sets/queries the speech frame delay to be used by the bad frame indication measurement. This is the delay expressed in frames from sending data on the downlink to it being looped back on the uplink by the mobile station. For more information on this parameter, please see Speech Frame Delay .
EGPRS LA
GSM TA

This command is not applicable to the GSM Test Application.

GPRS TA

 This command is not applicable to GPRS.

EGPRS TA

 This command is not applicable to EGPRS.
Setting

Range: 1 to 15
Resolution: 1

Query

Range: 1 to 15
Resolution: 1
*RST Setting

5
Requirements GSM/GPRS/ EGPRS LA

Revision: C.03 and above

Programming Example

OUTPUT 714;"SETup:BFI:SFDelay 4"
! Sets the speech frame delay to 4 frames.

SETup:<BFINdication|BFI>:TIMeout[:STIMe]

Function

GSM/GPRS LA

This command sets/queries the timeout value in seconds for bad frame indication (BFI) measurements and turns the timeout state to On. The units (S|MS) are optional. If no units are specified then units default to S (seconds).
EGPRS LA
GSM TA

This command is not applicable to the GSM Test Application.

GPRS TA

 This command is not applicable to GPRS.

EGPRS TA

 This command is not applicable to EGPRS.
Setting

Range: 0.1 to 9999

Resolution: 0.1

Query

Range: 0.1 to 9999

Resolution: 0.1
*RST Setting

3000 seconds
Requirements GSM/GPRS/ EGPRS LA

Revision: C.03 and above

Programming Example

OUTPUT 714;"SETup:BFI:TIMeout:STIMe 4000"
! Sets BFI measurement timeout to 4000 seconds and the state to on.

SETup:<BFINdication|BFI>:TIMeout:TIME

Function

GSM/GPRS LA

 This command sets/queries the timeout value in seconds for bad frame indication (BFI) measurements. The units (S|MS) are optional. If no units are specified then units default to S (seconds).
EGPRS LA
GSM TA

This command is not applicable to the GSM Test Application.

GPRS TA

 This command is not applicable to GPRS.

EGPRS TA

 This command is not applicable to EGPRS.
Setting

Range: 0.1 to 9999

Resolution: 0.1

Query

Range: 0.1 to 9999Resolution: 0.1
*RST Setting

3000 seconds
Requirements GSM/GPRS/ EGPRS LA

Revision: C.03 and above

Programming Example

OUTPUT 714;"SETup:BFI:TIMeout:TIME 4000"
! Sets BFI measurement timeout to 4000 seconds.

SETup:<BFINdication|BFI>:TIMeout:STATe

Function

GSM/GPRS LA

 This command sets/queries the timeout state for bad frame indication measurements.
EGPRS LA
GSM TA

This command is not applicable to the GSM Test Application.

GPRS TA

 This command is not applicable to GPRS.

EGPRS TA

 This command is not applicable to EGPRS.
Setting

Range: 0 | OFF | 1 | ON

Query

Range: 0 | 1
*RST Setting

0 | OFF
Requirements GSM/GPRS/ EGPRS LA

Revision: C.03 and above

Programming Example

OUTPUT 714;"SETup:BFI:TIMEout:STATe ON"
! Sets the timeout state to on.


SETup:FFERate

SETup:FFERate

Last updated: December 2, 2008

GPIB Command Conventions

  • SETup:FFERate:CONTinuous
  • SETup:FFERate:FRINterval[:FS]
  • SETup:FFERate:FRINterval:HS
  • SETup:FFERate:SAMPles[:SELected]
  • SETup:FFERate:TIMeout[:STIMe]
  • SETup:FFERate:TIMeout:TIME
  • SETup:FFERate:TIMeout:STATe

SETup:FFERate:CONTinuous

Function

GSM/GPRS LA

This command sets/queries the trigger state to single trigger mode or continuous trigger mode for the FACCH Frame Erasure Rate (FER) measurement.
EGPRS LA
GSM TA

This command is not applicable to the GSM Test Application.

GPRS TA

 This command is not applicable to the GPRS Test Application.

EGPRS TA

 This command is not applicable to the EGPRS Test Application.
Setting

Range: 0 | OFF | 1 | ON

Query

Range: 0 | 1
*RST Setting

0 | OFF
Requirements GSM/GPRS/ EGPRS LA

Revision: C.03 and above

Programming Example

OUTPUT 714;"SETup:FFERate:CONTinuous OFF"
! Sets FER measurement to single trigger mode.

SETup:FFERate:FRINterval[:FS]

Function

GSM/GPRS LA

This command sets/queries the minimum interval between FACCH/F frames being sent to the mobile station.
EGPRS LA
GSM TA

This command is not applicable to the GSM Test Application.

GPRS TA

 This command is not applicable to the GPRS Test Application.

EGPRS TA

 This command is not applicable to the EGPRS Test Application.
Setting

Range: 0.120 to 1.000 seconds
Resolution: 0.001

Query

Range: 0.120 to 1.000 seconds
Resolution: 0.001
*RST Setting

0.120
Requirements GSM/GPRS/ EGPRS LA

Revision: C.03 and above

Programming Example

OUTPUT 714;"SETup:FFERate:FRINterval 0.525"
! Sets the FACCH/F frame interval to 0.525 seconds.

SETup:FFERate:FRINterval:HS

Function

GSM/GPRS LA

This command sets/queries the minimum interval between FACCH/H frames being sent to the mobile station.
EGPRS LA
GSM TA

This command is not applicable to the GSM Test Application.

GPRS TA

 This command is not applicable to the GPRS Test Application.

EGPRS TA

 This command is not applicable to the EGPRS Test Application.
Setting

Range: 0.157 to 1.000 seconds
Resolution: 0.001

Query

Range: 0.157 to 1.000 seconds
Resolution: 0.001
*RST Setting

0.157
Requirements GSM/GPRS/ EGPRS LA

Revision: F.00.27 and above

Programming Example

OUTPUT 714;"SETup:FFERate:FRINterval:HS 0.157"
! Sets the FACCH/H frame interval to 0.157 seconds.

SETup:FFERate:SAMPles[:SELected]

SETup:FFERate:SAMPles:(DCS|EGSM|GSM450|GSM480|GSM750|GSM850|PCS|PGSM|RGSM|TGSM810)

Function

GSM/GPRS LA

This command sets/queries the number of samples to be taken by the FACCH frame erasure error (FER) measurement for the specified band.

The FER sample number is a frequency banded parameter. Refer to Frequency Banded Parameters for a detailed description of the implications of being a banded parameter.
EGPRS LA
GSM TA

This command is not applicable to the GSM Test Application.

GPRS TA

 This command is not applicable to the GPRS Test Application.

EGPRS TA

 This command is not applicable to the EGPRS Test Application.
Setting

Range: 1 to 999999

Resolution: 1

Query

Range: 1 to 999999

Resolution: 1
*RST Setting

DCS and PCS bands:13736
All other bands: 6696
Requirements GSM/GPRS/ EGPRS LA

Revision: C.03 and above

Revision D.03 adds the TGSM810 band.

Programming Example

OUTPUT 714;"SETup:FFERate:SAMPles 55000"
! Sets the number of samples to measure to 55000.

SETup:FFERate:TIMeout[:STIMe]

Function

GSM/GPRS LA

 This command sets/queries the timeout value in seconds for the FACCH frame erasure rate (FER) measurements and turns the timeout state to On. The units (S|MS) are optional. If no units are specified then units default to S (seconds).
EGPRS LA
GSM TA

This command is not applicable to the GSM Test Application.

GPRS TA

 This command is not applicable to the GPRS Test Application.

EGPRS TA

 This command is not applicable to the EGPRS Test Application.
Setting

Range: 0.1 to 9999

Resolution: 0.1

Query

Range: 0.1 to 9999

Resolution: 0.1
*RST Setting

2000 seconds
Requirements GSM/GPRS/ EGPRS LA

Revision: C.03 and above

Programming Example

OUTPUT 714;"SETup:FFERate:TIMeout:STIMe 1500"
! Sets measurement timeout to 1500 seconds and the state to on.

SETup:FFERate:TIMeout:TIME

Function

GSM/GPRS LA

This command sets/queries the timeout value in seconds for the FACCH frame erasure rate (FER) measurements. The units (S|MS) are optional. If no units are specified then units default to S (seconds).
EGPRS LA
GSM TA

This command is not applicable to the GSM Test Application.

GPRS TA

 This command is not applicable to the GPRS Test Application.

EGPRS TA

 This command is not applicable to the EGPRS Test Application.
Setting

Range: 0.1 to 9999

Resolution: 0.1

Query

Range: 0.1 to 9999Resolution: 0.1
*RST Setting

2000 seconds
Requirements GSM/GPRS/ EGPRS LA

Revision: C.03 and above

Programming Example

OUTPUT 714;"SETup:FFERate:TIMeout:TIME 1500"
! Sets measurement timeout to 1500 seconds.

SETup:FFERate:TIMeout:STATe

Function

GSM/GPRS LA

This command sets/queries the timeout state for FACCH frame erasure rate (FER) measurements.
EGPRS LA
GSM TA

This command is not applicable to the GSM Test Application.

GPRS TA

 This command is not applicable to the GPRS Test Application.

EGPRS TA

 This command is not applicable to the EGPRS Test Application.
Setting

Range: 0 | OFF | 1 | ON

Query

Range: 0 | 1
*RST Setting

0 | OFF
Requirements GSM/GPRS/ EGPRS LA

Revision: C.03 and above

Programming Example

OUTPUT 714;"SETup:FFERate:TIMeout:STATe ON"
! Sets the timeout state to on.


GSM Bad Frame Indication (BFI) Measurement Description

GSM Bad Frame Indication (BFI) Measurement Description

Last updated: December 2, 2008

This section is only applicable to the lab applications and is not applicable to GPRS or EGPRS.

You can use the GSM Bad Frame Indication (BFI) measurement to verify the mobile station's ability to detect bad frames under DTX conditions.

How is the BFI Measurement Made?

The test set must be set to operate as a base station transmitting in DTX mode. In this mode, there are periods where no transmission occurs. The BFI measurement is made by transmitting GMSK modulated pseudo-random bit sequence (PRBS) data in the periods where no transmission should occur. The mobile station should indicate these frames as bad by setting all the bits to zero before looping them back to the test set. From the number of frames with bits not set to zero, the test set returns results indicating the rate of undetected bad frames.

Operating Considerations

The BFI measurement can only be performed in Active Cell Operating Mode.

The connection type must be Auto.

The BFI measurement in the test set supports full-rate (FR), half-rate (HR), adaptive full-rate (AFS) and adaptive half-rate (AHS) speech channel modes. See Channel Mode Setup for more information about channel modes.

For expected results, the test set must be properly configured. See How do I make a GSM Bad Frame Indication (BFI) Measurement? or Programming a GSM Bad Frame Indication (BFI) Measurement for the proper procedure.

BFI Measurement Parameters

  • Samples to Test - The number of frames to be looped back from the mobile station and received by the test set for the measurement to complete.
  • Speech Frame Delay

    The mobile station's loopback delay expressed in frames. The default setting for this parameter is 5. However, this value is mobile station specific. You may not get expected results if this is not configured correctly. You can determine the speech frame delay using the test set. To do this, perform the Bit Error Measurement and use the value it automatically displays for the Loopback Delay.

    The GPIB command to set this parameter is SETup:<BFINdication|BFI>:SFDelay .

  • Trigger Arm - (See Trigger Arm (Single or Continuous) Description .)
  • Measurement Timeout - (See Measurement Timeouts .)

BFI Measurement Results

  • Integrity Indicator - (see Integrity Indicator )
  • Frames Sampled - The number of frames looped back from the mobile station and received by the test set.
  • SIDs Sent - The number of SIDs sent to the mobile station by the test set.
  • Undetected Bad Frames - The number of bad frames that are echoed back to the test set by the mobile station without the BFI bit being set.
  • SIDs Marked as BFI - The number of SID frames with the BFI bit set.
  • Undetected Bad Frame Rate - The ratio of Undetected Bad Frames to Frames Sampled.
  • SIDs Marked as BFI Rate - The ratio of SIDs Marked as BFI to SIDs Sent.

Related Topics

Programming a GSM Bad Frame Indication (BFI) Measurement


GSM Frame Erasure Rate (FER) Measurement Description

GSM Frame Erasure Rate (FER) Measurement Description

Last updated: December 2, 2008

This section is only applicable to the lab applications and is not applicable to GPRS or EGPRS.

You can use the GSM Frame Erasure Rate (FER) measurement to verify the mobile station's reference sensitivity for control channels.

How is the FER Measurement Made?

The test set measures FER by sending a Layer 3 message that does not require a Layer 3 response from the mobile station. It does require acknowledgment in the form of an RR frame from the mobile station. When the test set does not receive the RR frame in acknowledgment, it retransmits the Layer 2 message. The test set counts the number of times it resends Layer 2 messages.

The test set uses an MM Information message with all the optional fields omitted for the Layer 3 message.

You can make the Frame Erasure Rate Measurement on a full-rate FACCH channel (FACCH/F) or a half-rate FACCH channel (FACCH/H).

Operating Considerations

The FER measurement can only be performed in Active Cell Operating Mode.

The connection type must be Auto.

FER Measurement Parameters

  • Samples to Test - The number of samples to be taken by the measurement.
  • Minimum Frame Interval (FACCH/F)- The minimum interval between FACCH frames (full rate) being sent to the mobile station.
  • Minimum Frame Interval (FACCH/H)- The minimum interval between FACCH frames (half rate) being sent to the mobile station.
  • Trigger Arm - (See Trigger Arm (Single or Continuous) Description .)
  • Measurement Timeout - (See Measurement Timeouts .)

FER Measurement Results

  • Integrity Indicator - (see Integrity Indicator )
  • Frames Sampled - The count of samples tested.
  • Frames Erased - The count of frames requiring retransmission by the test set.
  • Frame Erasure Rate - The ratio of Frames Erased to Frames Sampled.

Related Topics

Programming a Frame Erasure Rate (FER) Measurement

How Do I Make a Repeated SACCH Frame Erasure Rate (FER) Measurement?

SETup:FFERate

FETCh:FFERate

Test Adherence to Standards


Programming a GSM Bad Frame Indication (BFI) Measurement

Programming a GSM Bad Frame Indication (BFI) Measurement

Last updated: December 2, 2008

This section is only applicable to the lab applications.

  • General Programming Procedure
  • Programming Example: 14.1.1.1 Bad Frame Indication - TCH/FS - Random RF input

General Programming Procedure

The following procedure assumes that the mobile station's antenna output is connected to the RF IN/OUT connector.

  1. Set up the BFI measurement parameters using the SETup:BFI commands (see SETup:<BFINdication|BFI> ). See BFI Measurement Parameters for information about the configurable parameters.
  2. Set up the System Type if your mobile station does not support the default (see CALL[:CELL]:BCHannel:SCELl ). To change the System Type:
    • Turn the cell off by changing the operating mode to OFF using the following command: CALL:OPERating:MODE .
    • Change the system type to GSM, GPRS or EGPRS as desired using the following command: CALL[:CELL]:BCHannel:SCELl .
    • Turn the cell back on using the CALL:OPER:MODE command.
  3. Set up the Broadcast Channel.
    • Set up the cell band using the following command: CALL[:CELL]:BAND<[:SELected]|:GSM> .
    • Set up the cell power using the following command: CALL[:CELL]:POWer[:SAMPlitude][:SELected] . (Set cell power to a value 20 dB above the reference sensitivity level for the band in which you are testing when performing 3GPP TS 51.010 test 14.1.1.)
  4. Set the mobile station's transmit level using the following command: CALL:MS:TXLevel[:SELected] . (Set the mobile station's transmit level to maximum power when performing 3GPP TS 51.010 test 14.1.1.)
  5. Set up the Downlink Traffic Power to be different from the cell power by defining a Power Reduction Level using the following command: CALL:TCHannel:PREDuction:LEVel([1]|2) (Set the power reduction level to 9 dB when performing 3GPP TS 51.010 test 14.1.1. The power used for downlink traffic channels will then be 11 dB above the reference sensitivity level if the cell power is set 20 dB above this level.) Assign the Power Reduction Level you just defined to the GSM burst using the following command: CALL:TCHannel:PREDuction:BURSt .
  6. Establish a GSM call. See Step 4: Make a Connection for more details.
  7. Reconfigure the Traffic Channel.
    • Set the TCH to transmit in Discontinuous Transmission (DTX) mode by setting the downlink speech to "SID" using the following command: CALL:TCHannel:DOWNlink:SPEech .
    • Set the mobile station loopback to Type A using the following command: CALL:TCHannel:LOOPback . In a Type A loopback, the mobile station loops back every good speech frame and loops back bad speech frames as all zeros.
  8. Initiate the BFI measurement using the following command: INITiate:<measurement mnemonic>[:ON] . The <measurement mnemonic> for the BFI measurement is either BFINdication or BFI.
  9. Use FETCh:<BFINdication|BFI>[:ALL]? to obtain the measurement results.

Programming Example: 14.1.1.1 Bad Frame Indication - TCH/FS - Random RF input

10       OUTPUT 714;"*RST"
20       OUTPUT 714;"SET:BFI:SAMP 492000"
30       OUTPUT 714;"SET:BFI:SFD 4"
40       OUTPUT 714;"CALL:POW -82"
50       OUTPUT 714;"CALL:MS:TXL 30"
60       OUTPUT 714;"CALL:TCH:PRED:LEV2 9"
70       ! Turn on the mobile station and allow it to camp.
80       OUTPUT 714;"CALL:ORIG:SEQ"
90       OUTPUT 714;"CALL:ORIG:DONE?"
100       ENTER 714;Orig
110       IF NOT Orig THEN
120         PRINT "CALL FAILED"
130         STOP
140       END IF
150       OUTPUT 714;"CALL:TCH:DOWN:SPE SID"
160       OUTPUT 714;"CALL:TCH:LOOP A"
170       OUTPUT 714;"INIT:BFI"
180       OUTPUT 714;"FETC:BFI?"
190       ENTER 714;Integrity,Samples,Ubframes,Bsid,Sidsent
200       OUTPUT 714;"CALL:TCH:LOOP OFF"
210       OUTPUT 714;"CALL:TCH:DOWN:SPE ECHO"
220       END

Related Topics

GSM Bad Frame Indication (BFI) Measurement Description

How do I make a GSM Bad Frame Indication (BFI) Measurement?

SETup:<BFINdication|BFI>

FETCh:<BFINdication|BFI>

Programming: Getting Started Guide for E1968A GSM/GPRS Mobile Test Application Revision A.02 and E6701C GSM/GPRS Lab Application Revision C.02


Programming a Frame Erasure Rate (FER) Measurement

Programming a Frame Erasure Rate (FER) Measurement

Last updated: December 2, 2008

This section is only applicable to the lab applications.

The following procedure assumes that an active link is established between the test set and the mobile station. See Establishing an Active GSM Link with the Mobile Station .

  1. Configure FER measurement parameters using the SETup subsystem.
  2. Set the cell power to the reference sensitivity level for the cell band you are testing.
  3. Use the INITiate command to begin a FER measurement.
  4. Use the FETCh? command to obtain FER measurement results.

Programming Example

10    OUTPUT 714;"SET:FFER:TIM 3000" !Set measurement timeout
20    OUTPUT 714;"SET:FFER:CONT OFF" !Set trigger to single
30    ! Set the cell power to the reference sensitivity level
40    OUTPUT 714;"CALL:POW -102"
50    OUTPUT 714;"INIT:FFER" !Initiate the measurement
60    OUTPUT 714;"FETC:FFER?"!Fetch the measurement results
70    ENTER 714;Integrity,Samples,Fer,Retx_count
80    END

Returned values

The measurements returned by this program are:

  • Integrity returns the Integrity Indicator (0 means a successful measurement with no errors).
  • Samples returns the number of samples counted.
  • Fer returns the ratio of frame erasures to total frames tested.
  • Retx_count returns the number of retransmitted frames.

Related Topics

SETup:FFERate


E6704A EGPRS Lab Application Revision Information

E6704A EGPRS Lab Application Revision Information

Last updated: December 2, 2008

This document describes features and functionality that are part of the Agilent Technologies E6704 EGPRS Lab Application releases. This document contains the original features, as well as enhancements that have been added over time.

CAUTION
Loading an application onto your E5515 Test Set that is not compatible with your E5515's hardware revision can cause your E5515 to lock-up. For information on application/E5515 compatibility refer to:

http://www.agilent.com/find/E5515

and select the relevant link, either E5515B Release Notes or E5515C Release Notes. Always refer to this information before loading an application.

Select the appropriate link below to view the required release.

  • D.02 Release - April 2005
  • D.01 Release - January 2005
  • C.03.48 Release - April 2004
  • C.03 Release - December 2003
  • C.01 Release - February 2003

D.02 Release - April 2005

This release of the E6704A EGPRS Lab Application is an extension of the E6701D GSM/GPRS Lab Application, D.01 release. The E6704A provides all of the functionality within the E6701D and additionally provides EGPRS-specific Call Processing and Measurement features. For more information on the features inherited from the E6701D, refer to E6701A/B/C/D/E/F/T/U GSM/GPRS/EGPRS Lab Application Revision Information .

This firmware release adds EGPRS Multislot Class 12 Capability. This release also adds enhancements to the EDGE Dynamic Power measurement.

Hardware Requirements

See www.agilent.com/find/8960upgrades

Call Processing

NOTE
There is currently no combined GPRS + EGPRS mode available. Therefore, a mobile station that supports GPRS but not EGPRS will not be able to attach when the serving cell is set to EGRPS. The GPRS serving cell setting should be used instead. See CALL[:CELL]:BCHannel:SCELl for more information.

  • More EGPRS data rate configurations are available in this release. The test set with the Lab Application license now supports EGPRS Multislot Class 12. The following multislot configurations are supported (indicated as Downlink x Uplink): 1x1, 1x2,1x3,1x4, 2x1, 2x2, 2x3, 3x1, 3x2, and 4x1. The test set with the Test Application licenses support EGPRS multislot class 10 operation. This includes the same multislot configurations as the Lab Application with the exception of: 1x3, 1x4, and 2x3.See EGPRS Data Rate Configurations for more information. The GPIB command for this feature is:
    • CALL:DATA:RATE:CONFig[:EGPRs] .

Measurements

  • The EDGE Dynamic Power measurement has been updated to allow the testing of GMSK modulated signals in the GSM and GPRS test modes in addition existing ability to test GMSK and 8PSK modulated signals in EGPRS test modes. For more details, refer to EDGE Dynamic Power (EDP) Measurement . The new commands added for this measurement include:
    • SETup:EDPower
    • INITiate
    • FETCh:EDPower
    • READ

D.01 Release - January 2005

This release of the E6704A EGPRS Lab Application is an extension of the E6701D GSM/GPRS Lab Application, D.01 release. The E6704A provides all of the functionality within the E6701D and additionally provides a number of EGPRS-specific Call Processing and Measurement features. For more information on the features inherited from the E6701D, refer to E6701A/B/C/D/E/F/T/U GSM/GPRS/EGPRS Lab Application Revision Information .

This firmware release adds the ability for you to assign a different Modulation Coding Scheme / Puncturing Scheme to each downlink of the multislot configuration. This release also adds the EDGE Dynamic Power measurement.

Hardware Requirements

  • A hardware upgrade is required to support the additional multislot configurations. For more details see:

    www.agilent.com/find/8960upgrades

Call Processing

NOTE
There is currently no combined GPRS + EGPRS mode available. Therefore, a mobile station that supports GPRS but not EGPRS will not be able to attach when the serving cell is set to EGRPS. The GPRS serving cell setting should be used instead. See CALL[:CELL]:BCHannel:SCELl for more information.

  • The capability has been added to allow a different Modulation Coding Schemes / Puncturing Schemes to be assigned to each uplink burst of the multislot configuration. See Modulation Coding Scheme/Puncturing Scheme (MCS/PS) for more information. The new commands for this feature are:
    • CALL:(PDTCH|PDTChannel):MCSCheme:EBPTest[:BURSt1]
    • CALL:(PDTCH|PDTChannel):MCSCheme:EBPTest:BURSt<2|3|4|5> .
  • More EGPRS data rate configurations are available in this release. See EGPRS Data Rate Configurations for more information. The GPIB command for this feature is:
    • CALL:DATA:RATE:CONFig[:EGPRs] .

Measurements

  • The EDGE Dynamic Power measurement has been added. For more details, refer to EDGE Dynamic Power (EDP) Measurement . The new commands added for this feature include:
    • SETup:EDPower
    • INITiate
    • FETCh:EDPower
    • READ

C.03.48 Release - April 2004

This release of the E6704A EGPRS Lab Application is an extension of the E6701C GSM/GPRS Lab Application, C.03.48 release and an enhancement release to the C.03 E6704A release. The E6704A provides all of the functionality within the E6701C and additionally provides a number of EGPRS-specific Call Processing and Measurement features. For more information on the features inherited from the E6701C, refer to E6701A/B/C/D/E/F/T/U GSM/GPRS/EGPRS Lab Application Revision Information .

This firmware release enhances support for link adaptation and adds the new EGPRS SRB Bit Error measurement as well as the ability to select the demodulation type used when the system type is EGPRS. This release also includes fixes to known problems. See Known Problems Corrected in this Release below.

Hardware Requirements

  • Previous hardware requirements apply.

Call Processing

NOTE
There is currently no combined GPRS + EGPRS mode available. Therefore, a mobile station that supports GPRS but not EGPRS will not be able to attach when the serving cell is set to EGRPS. The GPRS serving cell setting should be used instead. See CALL[:CELL]:BCHannel:SCELl for more information.

  • Link adaptation capability has been enhanced to add downlink resegmentation. See Downlink Resegmentation for more information. The new commands for this feature are:
    • CALL:(PDTCH|PDTChannel):MCSCheme:SWITch:RESegment[:STATe] .
  • EGPRS Demodulation Type has been added as a parameter. See EGPRS Demodulation Type for more information. The new GPIB command added for this feature is:
    • CALL:FUNCtion:EGPRs:DEMod .

Measurements

  • The EGPRS SRB Bit Error measurement has been added. For more details, refer to EGPRS SRB Bit Error Measurement . The new commands added for this feature include:
    • SETup:SBERror
    • INITiate
    • FETCh:SBERror
    • READ

Known Problems Corrected in this Release

For information on issues and workarounds in specific firmware releases, see the Know Issues website at:

http://wireless.agilent.com/rfcomms/issues

Known problems that existed in early versions of firmware that no longer exist in the A.03.48 release are listed below.

  • SRB Loopback Connection does not work properly.
  • Command SET:PVT:TXP:METHOD displayed on the front panel when in Help mode for setting the PVT measurement TX Power Method is not a valid command.
  • Unexpected BLER measurement results when using ETSI Type B Connection Type and Modulation Coding Scheme settings of MCS-7, MCS-8, and MCS-9.
  • The ETXP measurement incorrectly returns a Parameter Error measurement integrity when measuring RACH signals.
  • During multislot uplink EGPRS transfers, the second burst of signaling information is corrupt.
  • If the FBER measurement is setup and started while the operating mode is EGPRS Test Mode, changing the operating mode to Active Cell (EGPRS) causes a measurement timeout failure to occur.
  • In EGPRS MCS5-9, the test set transmits incorrect USF values for USF values other than 0.

C.03 Release - December 2003

This release of the E6704A EGPRS Lab Application is an extension of the E6701C GSM/GPRS Lab Application, C.03 release. The E6704A provides all of the functionality within the E6701C and additionally provides a number of EGPRS-specific Call Processing and Measurement features. For more information on the features inherited from the E6701C, refer to E6701A/B/C/D/E/F/T/U GSM/GPRS/EGPRS Lab Application Revision Information .

This firmware release adds support for incremental redundancy and link adaptation. In addition, there is a new EGPRS measurement, Modulation Accuracy. Existing measurements applicable to EGPRS have been enhanced and are now able to measure signals using 8PSK modulation.

Hardware Requirements

  • E5515C requires option H03/K03 to support the E6704A. Starting in February 2004, the E5515C ships with this option as standard hardware.

Call Processing

NOTE
There is currently no combined GPRS + EGPRS mode available. Therefore, a mobile station that supports GPRS but not EGPRS will not be able to attach when the serving cell is set to EGRPS. The GPRS serving cell setting should be used instead. See CALL[:CELL]:BCHannel:SCELl for more information.

  • Incremental Redundancy capability has been added. See Incremental Redundancy for more information. The new command added for incremental redundancy is:
    • CALL:(PDTCH|PDTChannel):IREDundancy[:STATe]
  • To force the use of the incremental redundancy capability in the mobile station, the ability to configure the test set to NACK uplink blocks has been added. For more information see Forcing Uplink Retransmissions . The new commands to support this feature are:
    • CALL:(PDTCH|PDTChannel):UPLink:RETRansmit:FORCe:PROBability:SPERcentage
    • CALL:(PDTCH|PDTChannel):UPLink:RETRansmit:FORCe:PROBability:PERCentage
    • CALL:(PDTCH|PDTChannel):UPLink:RETRansmit:FORCe:PROBability[:STATe]
  • The ability to change the puncturing scheme used for downlink PDTCHs has been added. See Puncturing Schemes for more information. The new command for this feature is:
    • CALL:(PDTCH|PDTChannel):MCSCheme:PSCHeme
  • Link adaptation capability has been added. See Retransmission MCS Switching for more information. The new commands for this feature are:
    • CALL:(PDTCH|PDTChannel):MCSCheme:SWITch[:STATe]
    • CALL:(PDTCH|PDTChannel):MCSCheme:SWITch:RETRansmit
  • To support the use of the link adaptation capability, the ability to intentionally corrupt downlink blocks has been added. See Downlink Corruption for more information. The new commands for this feature are:
    • CALL:(PDTCH|PDTChannel):DOWNlink:CORRuption[:STATe]
    • CALL:(PDTCH|PDTChannel):DOWNlink:CORRuption:SEQuence:LENGth
    • CALL:(PDTCH|PDTChannel):DOWNlink:CORRuption:SEQuence:CBURsts
    • CALL:(PDTCH|PDTChannel):DOWNlink:CORRuption:SYMBol:LENGth
    • CALL:(PDTCH|PDTChannel):DOWNlink:CORRuption:SYMBol:STARt
    • CALL:(PDTCH|PDTChannel):DOWNlink:CORRuption:PATTern
    • CALL:(PDTCH|PDTChannel):DOWNlink:CORRuption:BURSt<[1]|2|3|4>[:STATe]
  • The ability to set the downlink TBF window size to maximum or minimum has been added. See CALL:(PDTCH|PDTChannel):WINDow:SIZE[:ALL] for more information.
  • The ability to specify whether the mobile station being tested uses symmetric or asymmetric RLC frames has been added. See CALL:MS:TX:FRAMe:SEGMentation .
  • The front panel user interface has been enhanced to allow changes to the Serving Cell parameter without manually switching the cell off. To accommodate this, three new selections have been added to the Operating Mode menu. These are:
    • Active Cell (GSM) - GSM only BCH
    • Active Cell (GPRS) - GSM + GPRS BCH
    • Active Cell (EGPRS) - GSM + EGPRS BCH

    In addition, the selection Active Cell is no longer available. See Active Cell Operating Mode for more information.

  • The default for the serving cell parameter has changed from EGPRS to GPRS. See CALL[:CELL]:BCHannel:SCELl for more information.
  • Control of EGPRS Supplementary Polling has been added. See CALL:(PDTCH|PDTChannel):ESPolling for command and configuration details.
  • A new cell parameter has been added allowing you to specify the EGPRS Link Quality Measurement Mode. See CALL:MS:LQMMode for command and configuration details.
  • EGPRS data rate configurations that are not supported in the test set by default can be accessed. See EGPRS Data Rate Configurations for more information. The new command implemented to support this feature is: CALL:DATA:RATE:CONFig[:EGPRs] .

Measurements

  • New measurements:
    • EGPRS Modulation Accuracy has been added. See Modulation Accuracy Measurement Description for more information. Information on new commands added for this measurement can be found at:
      • SETup:EMACcuracy
      • INITiate
      • FETCh:EMACcuracy
      • READ
  • The following measurements have been enhanced to support both GMSK and 8PSK EGPRS modulation and coding schemes (MCS-1 through MCS-9).
    • Output RF Spectrum - see GPRS and EGPRS Output RF Spectrum Measurement
    • Phase and Frequency Error - see Phase and Frequency Error Measurement Description
    • Power versus Time - see Power versus Time Measurement Description
  • The EGPRS Transmit Power measurement specific command SETup:ETXPower:MODulation, used to specify which modulation format is to be measured, has been replaced by a receiver control that is common to all measurements. See Modulation Format Control (EGPRS only) for more information.

C.01 Release - February 2003

These are the original features of the E6704A EGPRS Lab Application.

The E6704A EGPRS Lab Application is an extension of the E6701C GSM/GPRS Lab Application, C.01 release. The E6704A provides all of the functionality within the E6701C and additionally provides a number of EGPRS-specific Call Processing and Measurement features. For more information on the features inherited from the E6701C, refer to E6701A/B/C/D/E/F/T/U GSM/GPRS/EGPRS Lab Application Revision Information .

Hardware Requirements

Special hardware requirements apply for the E6704A EGPRS Lab Application. Please contact your local sales representative for more details.

Features Specific to the E6704A EGPRS Lab Application

The following features are available in the E6704A EGPRS Lab Application over and above the features provided by the E6701C and E1968A:

Call Processing

  • The following call processing commands have been added which are specific to EGPRS:
    • Modulation Coding and Puncturing Schemes
      For more details refer to CALL:(PDTCH|PDTChannel):MCSCheme , CALL:(PDTCH|PDTChannel):MCSCheme:EBPTest[:BURSt1] , and CALL:(PDTCH|PDTChannel):MCSCheme:EBPTest:BURSt<2|3|4|5> .
    • Switched Radio Block (SRB) Loopback Connection Type
      For more details refer to CALL:FUNCtion:CONNection:TYPE .

Measurements

  • The following measurements provide support for both GMSK and 8PSK EGPRS modulation coding schemes (MCS-1 through MCS-9):
    • EGPRS Transmit Power
      For more details refer to EGPRS Transmit Power (ETXP) Measurement .
    • Block Error
      For more details refer to Block Error Measurement .
  • The following measurements provide support for GMSK EGPRS modulation coding schemes (MCS-1 through MCS-4):
    • Dynamic Power
      For more details refer to Dynamic Power Measurement Description .
    • Output RF Spectrum
      For more details refer to Output RF Spectrum Measurement Description .
    • Power versus Time
      For more details refer to Power versus Time Measurement Description .
    • Phase and Frequency Error
      For more details refer to Phase and Frequency Error Measurement Description .
    • I/Q Tuning
      For more details refer to I/Q Tuning Measurement Description .


EGPRS Demodulation Type

EGPRS Demodulation Type

Last updated: December 2, 2008

This section is only applicable to the EGPRS test application.

The EGPRS Demodulation Type setting allows you to select between reduced or normal demodulation. EGPRS transmitter measurement speed is increased when using the reduced demodulation type.

Operating Considerations

EGPRS Demodulation Type can only be configured when the operating mode is Active Cell with an EGPRS Serving Cell . The EGPRS BCH + PDTCH operating mode uses Normal demodulation only while a GBER, BLER, or SBER measurement is running. Once the GBER, BLER, or SBER measurement closes, the test set automatically reverts to the Reduced demodulation setting as the EGPRS demodulation type. EGPRS BCH operating mode always uses Normal demodulation.

The test set automatically switches to normal demodulation when a call processing function needs to be performed or a receiver measurement is being made.

Related Topics

CALL:FUNCtion:EGPRs:DEMod


How do I change the EGPRS Demodulation Type to Normal?

How do I change the EGPRS Demodulation Type to Normal?

Last updated: December 2, 2008

This section is only applicable to the EGPRS test application.

This procedure assumes that the BCH parameter for Cell Band is set up correctly for your mobile station and that the appropriate RF IN/OUT Amplitude Offsets have been set to offset loss between the mobile station and the test set. You can only change the EGPRS demodulation type while in Active Cell (EGPRS).

  1. Press the CALL SETUP key.
  2. Press Operating Mode ( F1 ) and select Active Cell (EGPRS) .
  3. Press Data conn Type ( F2 ) and select ETSI Type A .
  4. Press the More softkey on the left side of the front panel display to access the Control ( 2 of 2 ) menu.
  5. Select Protocol Control ( F4 ).
  6. Select Layer 1 ( F1 ).
  7. Select EGPRS Demod ( F2 ). The EGPRS Demod popup menu appears.
  8. Select Normal .

Related Topics

EGPRS Demodulation Type


Frequency Banded Parameters

Frequency Banded Parameters

Last updated: December 2, 2008

The majority of the test set's parameters are active regardless of the frequency band selected. There are a number of parameters that allow you to specify a band; DCS, EGSM, GSM450, GSM480, GSM750, GSM850, T-GSM810, PCS, PGSM or RGSM. These exceptions are called frequency banded parameters.

Frequency banded parameters are activated upon selection of a band. Parameters that select frequency bands include cell band and traffic band (see Band Selection Parameters ).

You can set parameter values for a band that is not currently selected, and the test set stores the settings for future use. For example, during a call on the PGSM band, the MS TX level can be set to 10 for the DCS frequency band. When a handover (see How the Test Set Performs a Dualband Handover ) to the DCS band is made, the MS TX level of 10 for DCS will already be set.

If you do not specify a frequency band when setting frequency banded parameters, settings to the parameter are made in the currently selected band.

  • GSM Frequency Banded Parameters
  • GPRS and EGPRS Frequency Banded Parameters

GSM Frequency Banded Parameters

The following table lists all the frequency banded parameters that apply to GSM. If you need more information on any of the parameters contained in this table, click the corresponding GPIB command link.

Parameter | GPIB Command
Broadcast Channel (ARFCN) | CALL[:CELL]:BCHannel[:ARFCn][:SELected]
BA Table | CALL[:CELL]:BA:TABLe[:SELected]
BA Table Points | CALL[:CELL]:BA:TABLe:POINts[:SELected]?
Traffic Channel (ARFCN) | CALL:TCHannel[:ARFCn][:SELected]
MS TX Level | CALL:MS:TXLevel[:SELected]
TCH Timing Advance | CALL:MS:TADVance[:SELected]
Control Channel Power | CALL[:CELL]:MS:TXLevel:CCHannel[:SELected]
Traffic Channel (ARFCN) | CALL:TCHannel[:ARFCn][:SELected]
Traffic Channel MAIO | CALL:TCHannel:FHOPping:MAIoffset:[SELected]
Traffic Channel Automatically Populated MA Table Values (Query) | CALL:TCHannel:MA:TABLe[:AUTO]:[SELected]?
Traffic Channel -Number of Automatic MA Table Values (Query) | CALL:TCHannel:MA:TABLe[:AUTO]:POINts:[SELected]?
Traffic Channel Manual MA Table Setting | CALL:TCHannel:MA:TABLe:MANual:[SELected]
Traffic Channel -Number of Manual MA Table Values (Query) | CALL:(PDTCH|PDTChannel):MA:TABLe:MANual:POINts[:SELected]?
Traffic Channel Measurement ARFCN | CALL:TCHannel:MA:MEASurement:ARFCn:(SELected]
FER Measurement: Number of Samples | SETup:FFERate:SAMPles[:SELected]
ORFS Measurement: Modulation Limit(s) | SETup:ORFSpectrum:MODulation:LIMit:MANual<[1]|2>[:SELected]
ORFS Measurement: Switching Limit(s) | SETup:ORFSpectrum:SWITching:LIMit:MANual[:SELected]

GSM Programming Example

This section provides an example of how to use frequency banded parameters.

The following procedure assumes that an active link is established between the test set and the mobile station. See Establishing an Active GSM Link with the Mobile Station .

10  OUTPUT 714;"CALL:TCH:PGSM 124" !Sets traffic channel to 124 for PGSM band.
20  OUTPUT 714;"CALL:MS:TXL:PGSM 7" !Sets the mobile station uplink power control
30                                  !level to 7 for PGSM band.
40  ! Now set up frequency banded parameters for DCS band.
50  OUTPUT 714;"CALL:TCH:DCS 850" !Sets traffic channel to 850 for DCS band.
60                                !The default traffic channel for the DCS
70                                !band is 30.
80  OUTPUT 714;"CALL:MS:TXL:DCS 5" !Sets the mobile station uplink power control
90                                 !level to 5 for the EGSM band. The default level is
100                                !15.
110 ! Now change the traffic channel band to DCS. The TCH and uplink power control level
120 ! parameters are set to the values you specified above, not the default values.
130 OUTPUT 714;"CALL:TCH:BAND DCS"
140 ! Now query the traffic channel and uplink power control level.
150 OUTPUT 714;"CALL:TCH?"
160 ENTER 714;Channel
170 OUTPUT 714;"CALL:MS:TXL?"
180 ENTER 714;Tx_lev
190 ! Print the current values.
200 PRINT "The default TCH for the DCS band is 698. The current TCH is: ";Channel
210 PRINT "The default Tx Level is 10. The current Tx Level is: ";Tx_lev
220 END

GPRS and EGPRS Frequency Banded Parameters

The following table lists all the frequency banded parameters that apply to GPRS and EGPRS. If you need more information on any of the parameters contained in this table, click the corresponding GPIB command link.

Parameter | GPIB Command
Broadcast Channel (ARFCN) | CALL[:CELL]:BCHannel[:ARFCn][:SELected]
BA Table | CALL[:CELL]:BA:TABLe[:SELected]
BA Table Points | CALL[:CELL]:BA:TABLe:POINts[:SELected]?
EGPRS Multislot Class | CALL:MS:REPorted:MCLass:EGPRS[:SELected]?
EPSK Power Class | CALL:MS:REPorted:PCLass:EPSK[:SELected]?
GMSK Power Class | CALL:MS:REPorted:PCLass:GMSK[:SELected]?
GPRS Multislot Class | CALL:MS:REPorted:MCLass:GPRS[:SELected]?
Packet Data Traffic Channel (ARFCN) | CALL:(PDTCH|PDTChannel)[:ARFCn][:SELected]
Packet Traffic Channel MAIO | CALL:(PDTCH|PDTChannel):FHOPping:MAIOffset[:SELected]
Packet Traffic Channel Automatically Populated MA Table Values (Query) | CALL:(PDTCH|PDTChannel):MA:TABLe[:AUTO][:SELected]?
Packet Traffic Channel -Number of Automatic MA Table Values (Query) | CALL:(PDTCH|PDTChannel):MA:TABLe[:AUTO]:POINts[:SELected]?
Packet Traffic Channel Manual MA Table Setting | CALL:(PDTCH|PDTChannel):MA:TABLe:MANual[:SELected]
Packet Traffic Channel -Number of Manual MA Table Values (Query) | CALL:(PDTCH|PDTChannel):MA:TABLe:MANual:POINts[:SELected]?
Packet Traffic Channel Measurement ARFCN | CALL:(PDTCH|PDTChannel):MA:MEASurement:ARFCN[:SELected]
Timing Advance | CALL:(PDTCH|PDTChannel):MS:TADVance[:SELected]
Uplink Burst TX Level | CALL:(PDTCH|PDTChannel):MS:TXLevel[:SELected]:BURSt<[1]|2|3|4|5>
FER Measurement: Number of Samples | SETup:FFERate:SAMPles[:SELected]
ORFS Measurement: Modulation Limit(s) | SETup:ORFSpectrum:MODulation:LIMit:MANual<[1]|2>[:SELected]
ORFS Measurement: Switching Limit(s) | SETup:ORFSpectrum:SWITching:LIMit:MANual[:SELected]

Programming Example

The following procedure assumes that a data connection has been established between the test set and the mobile station (connection status is Transferring). See Step 4: Make a Connection .

10  OUTPUT 714;"CALL:PDTCH:PGSM 124" !Sets packet data traffic channel to 124 for PGSM
20                                   !band.
30  OUTPUT 714;"CALL:PDTCH:MS:TXL:PGSM:BURS 7;BURS2 10" !Sets the mobile station uplink
40                                  !power control level for burst 1 to 7 and burst 2
50                                  !to 10 for the PGSM band.
60  ! Now set up frequency banded parameters for DCS band.
70  OUTPUT 714;"CALL:PDTCH:DCS 850" !Sets packet data traffic channel to 850 for DCS band.
80                                  !The default packet data traffic channel for the DCS
90                                  !band is 30.
100 OUTPUT 714;"CALL:PDTCH:MS:TXL:DCS:BURS 5;BURS2 7" !Sets the mobile station uplink
110                                !power control level for burst 1 to 5 and burst 2 for
120                                !for the EGSM band.  The default levels are 10.
130 ! Now change the packet data traffic channel band to DCS. The PDTCH and uplink power
140 ! control level parameters are set to the values you specified above, not the
150 ! default values.
160 OUTPUT 714;"CALL:PDTCH:BAND DCS"
170 ! Now query the packet data traffic channel and uplink power control levels.
180 OUTPUT 714;"CALL:PDTCH?"
190 ENTER 714;Channel
200 OUTPUT 714;"CALL:PDTCH:MS:TXL:BURS?"
210 ENTER 714;Tx_lev_burs1
220 OUTPUT 714;"CALL:PDTCH:MS:TXL:BURS2?"
230 ENTER 714;Tx_lev_burs2
240 ! Print the current values.
250 PRINT "The default PDTCH for the DCS band is 698. The current PDTCH is: ";Channel
260 PRINT "The default Tx Levels are 10. The current Tx Level for Burst 1 is: ";Tx_lev_burs1
270 PRINT "The default Tx Levels are 10. The current Tx Level for Burst 2 is: ";Tx_lev_burs2
280 END

Related Topics

Band Selection Parameters

How the Test Set Performs a Dualband Handover

Configuring the Broadcast Channel (BCH)

Configuring the Traffic Channel (TCH) Parameters

Configuring the Packet Data Traffic Channel (PDTCH)

Receiver Control

Frequency Bands


Band Selection Parameters

Band Selection Parameters

Last updated: December 2, 2008

Band selection parameters allow you to choose the frequency band for different channel types in GSM, GPRS or EGPRS:

  • GSM Band Selection Parameters
  • GPRS and EGPRS Band Selection Parameters

The following table summarizes the frequency bands and ARFCNs specified in 3GPP TS 45.005, and whether they are supported in the test set.

Band | DL to UL Frequency Separation (MHz) | 3GPP TS 45.005 Downlink Frequency (MHz) | 3GPP TS 45.005 Uplink Frequency (MHz) | ARFCN Range | Supported in the Test Set?
T-GSM 380 | 10 | 390.2 - 399.8 | 380.2 - 389.8 | * | No
T-GSM 410 | 10 | 420.2 - 429.8 | 410.2 - 419.8 | * | No
GSM 450 | 10 | 460.4 - 467.6 | 450.4 - 457.6 | 259-293 | Yes
GSM 480 | 10 | 488.8 - 496 | 478.8 - 486 | 306-340 | Yes
GSM 710 | 30 | 728 - 746 | 698 - 716 | * | No
GSM 750 | 30 | 777 - 792 | 747 - 762 | 438-511 | Yes
T-GSM 810 | 45 | 851 - 866 | 806 - 821 | 350-425** | Yes
GSM 850 | 45 | 869 - 894 | 824 - 849 | 128-251 | Yes
P-GSM | 45 | 935 - 960 | 890 - 915 | 1-124 | Yes
E-GSM | 45 | 925 - 960 | 880 - 915 | 0-124 975-1023 | Yes
R-GSM | 45 | 921 - 960 | 876 - 915 | 0-124 955-1023 | Yes
T-GSM 900 | 45 | 915.4 - 921 | 870.4 - 876 | * | No
DCS 1800 | 95 | 1805 - 1880 | 1710 - 1785 | 512-885 | Yes
PCS 1900 | 80 | 1930 - 1990 | 1850 - 1910 | 512-810 | Yes
*ARFCN Range for T-GSM 380, T-GSM 410, T-GSM 810, T-GSM 900 and GSM 710 is (ARFCN_FIRST to ARFCN_FIRST+ARFCN_RANGE). ARFCN_FIRST and ARFCN_RANGE are contained in SI14 message information. **In the test set, the ARFCN_FIRST and ARFCN_RANGE for T-GSM 810 are 350 and 75 separately.

GSM Band Selection Parameters

Parameter | GPIB Command
Cell Band | CALL[:CELL]:BAND<[:SELected]|:GSM>
Traffic Band | CALL:TCHannel:BAND
RF Generator Band | CALL[:CELL]:RFGenerator:FREQuency[:SELected]

Operating Considerations for GSM

Cell Band Parameter

  • Changes to the Frequency Bands parameter will be reflected in the traffic band parameter.
  • When the operating mode is active cell and the call connected state is connected, changes to the cell band parameter will disconnect any call in progress.
  • When the operating mode is GSM BCH test mode (GBTest) or GSM BCH+TCH test mode (GBTTest), the cell band parameter should be used. See CALL:OPERating .

Traffic Band Parameter

  • When the operating mode is active cell and the call connected state is connected, changes to the traffic band parameter cause an inter-band channel assignment. See How the Test Set Performs a Dualband Handover .
  • When the operating mode is active cell and the call connected state is connected, changes to the traffic band parameter are not reflected in the cell band parameter.
  • When the operating mode is set to GSM BCH+TCH (GBTTest), the traffic band parameter should be used. See CALL:OPERating .

RF Generator Band Parameter

  • When the operating mode is set to CW, the test set operates like a signal generator with level and frequency controls. See CW .

GPRS and EGPRS Band Selection Parameters

Parameter | GPIB Command
Cell Band | CALL[:CELL]:BAND<[:SELected]|:GSM>
Packet Data Traffic Channel Band | CALL:(PDTCH|PDTChannel):BAND
RF Generator Band | CALL[:CELL]:RFGenerator:FREQuency[:SELected]

Operating Considerations for GPRS and EGPRS

Cell Band Parameter

  • Changing the cell band parameter to a new band changes the packet data traffic channel band to the new band as well.
  • When the data connection status is transferring (see Data Connection Processing State Synchronization ), changing the cell band parameter will disconnect any data connection in progress.

Packet Data Traffic Channel Band Parameter

  • When the data connection status is transferring (see Data Connection Processing State Synchronization ), changing the packet data traffic band parameter selects the PDTCH ARFCN and uplink burst TX level parameters.

RF Generator Band Parameter

  • When the operating mode is set to CW, the test set operates like a signal generator with level and frequency controls. See CW .

Related Topics

Configuring the Broadcast Channel (BCH)

Configuring the Traffic Channel (TCH) Parameters

Configuring the Packet Data Traffic Channel (PDTCH)

Receiver Control

CALL:OPERating

CALL:CONNected[:STATe]?

CALL:STATus[:STATe]:DATA?

Programming: Getting Started Guide for E1968A GSM/GPRS Mobile Test Application Revision A.02 and E6701C GSM/GPRS Lab Application Revision C.02


Test Set Block Diagram

Test Set Block Diagram

Last updated: December 2, 2008

The hardware architecture of the test set provides a number of parallel signal paths through the instrument. This parallel architecture allows the measurement hardware to run some measurements concurrently. See Concurrent Measurements .

Description

RF Interface Module

Input and output signals are routed through the RF Interface module. The RF Interface module consists of:

  • A directional bridge for sampling incoming power.
  • Hybrid power splitters which create 4 bidirectional ports (two receiver ports and two source ports). The directional bridge couples power to the Power Detector.
  • RF amplifiers.
  • Video gain circuits.
  • Fast and thermal power detectors.

The RF Interface module provides two identical RF Source path connections to the In/Out port of the instrument. There is about 25 dB of isolation between the two source paths. There is about 35 dB of isolation between the source paths and either receiver path. The RFIO module has nominally 23 dB of insertion loss in the source path. A temperature sensing circuit facilitates compensation for path loss variation with temperature.

The source signals can be looped back through the input signal path to cross-calibrate the Measurement Downconverter and the Power Detector.

The sampled input power from the directional bridge can be amplified by as many as two 18 dB range amplifiers and then can be directed to the fast detector or the thermal detector. The input power to the fast detector is detected by a diode detector that is part of a feedback loop. The input to the thermal detector is measured in a bridge using a pair of RMS thermal detectors in a feedback loop.

Signal Downconversion

The test set's downconversion receiver section has two downconversion modules; a Measurement Downconversion Module for making measurements, and a Demodulation Downconversion Module for maintaining the radio link.

Demodulation Downconverter Module

The Demodulation Downconverter module is used as part of the demodulation receiver that maintains the radio link.

Measurement Downconverter Module

The Measurement Downconverter module provides high quality (wide dynamic range, spurious free) signals to the Analog To Digital Converter module's measurement sampler input.

The Measurement Downconverter module is designed for very high performance operation to ensure accurate and repeatable measurement results. The Measurement Downconverter module contains two downconversion stages, two local oscillators, and a logarithmic IF envelope detector . Both first and second LO synthesizers are tunable. The first LO is used when tuning to the RF input frequency, and the second LO is used when setting second IF frequency, which is fed to the measurement sampler on the Analog To Digital Converter module.

Link Subsystem

The Link Subsystem maintains the radio link for all CDMA formats. The Link Subsystem has two parts:

  • Protocol Processor
  • Optional Link Subsystem hardware

The Protocol Processor module is responsible for maintaining the radio link between the test set and the mobile station under test. The primary tasks of the Protocol Processor module are:

  • Generating the protocol messaging necessary for the forward channel and sending that protocol stream to the test set's RF source for transmission to the mobile station.
  • Decoding the protocol messaging received from the mobile station under test on the reverse channel.
  • Computing measurement results which are associated with data bits contained within the mobile stations messaging, such as bit error ratio and frame error rate.

The optional Link Subsystem hardware provides additional signaling link control for CDMA signaling formats. These include:

  • Layer 1 digital signal processing.
  • Providing I/Q baseband signals which are sent to the I/Q modulator in the RF Source

Analog To Digital Converter Module

Following the Measurement Downconverter and Demodulation Downconverter IF 1 is the Analog to Digital Converter module. The purpose of the Analog to Digital Converter module is to convert the downconverted analog signals into digital data streams which can be processed by the Digital Signal Processing module.

In order to maintain the radio link of non-CDMA formats, the downconversion path through the Demodulation Downconverter module has a dedicated A/D conversion path.

To optimize measurement throughput, the fast RF power detector also has a single dedicated A/D path. This allows power measurements, in many cases, to be made concurrently with other measurements. The two outputs from the Measurement Downconverter module and the Audio In signal share a single multiplexed A/D path.

The outputs of the various analog to digital converters on the Analog to Digital Converter module share a common data bus with the Digital Signal Processing module.

Digital Signal Processing Module

The Digital Signal Processing (DSP) module is responsible for a variety of tasks within the overall test set architecture. These tasks are:

  • Demodulate data from the radio under test (data received from the Demodulation Downconverter module) and sending the demodulated data bits to the Protocol Processor module.
  • For some systems, perform audio measurements using audio information sent to the DSP module from the Protocol Processor module.
  • Execute a variety of signal processing algorithms to perform measurements on the radio system of the currently loaded TA (data received from the power detector ADC, the measurement ADC and, in some cases, data received from the Demodulation Downconverter ADC).

The DSP processor communicates with the Host Processor and the Protocol Processor, as well as controlling the configuration and synchronization of the Analog To Digital Converter module.

Host Processor Module

The Host Processor module is responsible for a variety of tasks within the overall test set architecture. These tasks include:

  • Control of the manual user interface (MUI).
  • Executing commands and processing data received from the LAN interface.
  • Executing commands and processing data received from the GPIB interface.
  • Controlling hard disk access.
  • Control of all RF and audio hardware modules.
  • Routing measurement results received form the Digital Signal Processing and Protocol Processor modules to the appropriate output device (display, GPIB, LAN, serial, etc.).

Voltmeter/Counter

Voltmeter

The voltmeter is used to measure internal voltages for instrument self-diagnostics.

Frequency Counter

The Frequency Counter is used to measure external frequencies from the front panel Audio IN, High or Low BNC connectors, and to measure internal signals for diagnostics. The external input can receive a signal between 20 Hz and 50 MHz, with a level from 25 mV to 8 V rms.

Audio Section

Audio Analysis Path

Externally applied audio signals can be analyzed through the test set's DSP module for such characteristics as AC level, SINAD, or distortion.

The audio signal to be analyzed is input to the test set using the front panel Audio IN High/Low connectors. The signal is then routed to the Analog To Digital Converter module's measurement sampler for analysis by the DSP module.

The Audio In connector accepts signals from 20 Hz to 15 KHz, at input levels from 10 mV to 20 V peak.

Audio 1 Path

The Audio 1 path provides analog baseband signals used for frequency modulation of the test set's RF sources. Up to four separate audio sources may be summed together in any combination to provide the composite Audio 1 output. These include the external FM input, internal direct digital synthesis (DDS,) regenerated SAT, and audio echo input.

The external FM input accepts an externally supplied audio signal with a peak voltage between 0.25 and 2 V peak.

The internal DDS generates low distortion audio signals from DC to 20 KHz with 0.1 Hz resolution. One to four signals may be generated and internally summed, with independent level control of each waveform.

The SAT regeneration circuit outputs a signal which is phase-locked to a received SAT signal. This is useful for testing situations where the test set needs to emulate a mobile station.

The audio echo input is used for retransmitting the received audio after a selectable time delay, to check both radio transmit and receive paths simultaneously.

For most applications, only one or two of these Audio 1 path sources are enabled at any given time.

Audio 2 Path

The Audio 2 path provides a secondary means for sending analog baseband signals to the FM modulator. Audio 2 contains only one source, a DDS similar to that used for Audio 1.

Typically, the Audio 2 path DDS is used for cases where multiple signals must be summed together with the lowest possible distortion. Another potential use of Audio 2 would be to obtain higher output levels than Audio 1 is capable of (up to twice as much), assuming the two outputs are set to the same frequency and phase, and then summed together at the Baseband Generator module.

Audio 2 is rarely used in practice because the DDS used for Audio 2 is the same DDS that is used for the front panel audio output.

Audio Out Path

Any one of four inputs may be coupled to the front panel audio output connector. These include a 4 channel DDS (shared with Audio 2), receiver discriminator audio from the Demodulation Downconverter module, audio echo from the Analog To Digital Converter module, and audio vocoder.

The front panel output is capable of providing signal levels up to 9 V peak into > 600 ohm loads, and up to 0.8 V peak into an 8 ohm load (e.g. speaker). The output level is calibrated for all modes except discriminator audio,
The discriminator audio has an uncalibrated volume control provided due to the high tolerances involved.

Typically the DDS mode is used to feed the MIC input of a radio, or it may simply be used as a general purpose low distortion function generator.

Audio echo can be selected to route the received audio to the front panel audio output connector.

RF Sources

The test set has up to two identical RF sources. The RF sources are used to provide analog or digitally modulated RF carriers for use in parametric testing of mobile stations encompassing a variety of cellular radio formats. In general, the sources have a frequency range of 292 MHz to 2.7 GHz and an amplitude range of -10 dBm to -127 dBm.

The RF sources consist of a Synthesized Signal Generator module followed by a Vector Output module and an RF Attenuator module. Baseband modulation information is supplied to the RF sources from a Baseband Generator module preceded by an Audio Section module.

Baseband Generators

The purpose of the Baseband Generator module is to provide, for the modulation type currently in effect, properly formatted baseband signals to the modulation circuits on the RF Source modules.

The Baseband Generator performs several functions related to the generation and processing of these base-band modulation signals. These are:

  • Transform data and clock signals from the Protocol Processor module into base-band analog I/Q modulation signals for the I/Q modulator in the Vector Output module
  • Transform data from the Protocol Processor module into baseband FSK modulation for the FM modulator in the Signal Generator module
  • Provide baseband FM path source selection, gain adjustment and summing node for analog FM signals from the Audio module and internally generated baseband FSK signals which are output to the FM modulator in the Signal Generator module
  • Transform burst and adjacent timeslot signals from the Protocol Processor module into baseband burst modulation signals for the burst modulator in the Vector Output module


Access Burst Type for Packet Control Acknowledgments

Access Burst Type for Packet Control Acknowledgments

Last updated: December 2, 2008

Introduction

The Packet Control Acknowledgment message is sent from the mobile station to the network on the PACCH. The format in which this message can be sent is either a RLC/MAC control block that uses the PACCH block format or as four identical access bursts that uses the PACCH uplink short acknowledgment block format. The access bursts format can be either 8-bit or 11-bit. The PACCH block formats defined in 3GPP TS 44.004 are shown below:

If the Packet Control Acknowledgment message is sent in response to a Packet Polling request message, the TYPE_OF_ACK parameter in the System Information (SI) messages indicate whether the Packet Control Acknowledgment message is formatted either as a normal RLC/MAC control block or as four access bursts. Otherwise, the CONTROL_ACK_TYPE parameter in the SI messages indicate the format of the Packet Control Acknowledgment message.

Configuring the Test Set

The test set provides two options for the type of bursts used to carry control acknowledgments from the mobile station to the test set.

Any delay between the last signaling from the mobile station to the network and the control acknowledgment allows a change in the timing advance required. Since access bursts are shorter than normal bursts, they are less likely to collide with subsequent timeslots when the base station redetermines the required timing advance.

For the procedure to manually configure the type of bursts to carry control acknowledgments, see How Do I Configure the Type of Bursts used to Carry the Packet Control Acknowledgments? .

The command to set the Control Acknowledgment Type is CALL[:CELL]:PCAType .

The command to set the Access Burst Type is CALL[:CELL]:(PBCCH|PBCChannel):PRACh:LENGth . The setting for Access Burst Type parameter is

Note: In half-rate Dual Transfer Mode the value of the Control Acknowledgment Type is ignored and Normal Bursts are used.

How Do I Configure the Type of Bursts used to Carry the Packet Control Acknowledgments?

This procedure details how to configure the type of bursts used to carry the control acknowledgment messages sent from the mobile station to the test set. The Packet Control Acknowledgment Type parameter can only be configured when the Operating Mode is set to Cell Off.

  1. Press CALL SETUP .
  2. Press Operating Mode ( F1 ), and select Cell Off.
  3. Press Cell Info ( F6 ).
  4. Press Cell Operation ( F1 ). This brings up the Cell Operation menu.
  5. Use the knob to scroll down and highlight Packet Control Ack Type .
  6. Select the type of bursts you wish to carry the control acknowledgments. If you set the Packet Control Ack Type to Four Access Bursts , also set the access burst type (8-bit or 11-bit). The PRACH Length parameter is used to set the access burst type.
  7. Press Close Menu ( F6 ).
  8. Press Return ( F6 ).
  9. Press Operating Mode ( F1 ), and select an Active Cell operating mode.
  10. Be sure to set the Operating Mode to an Active Cell Operating Mode or a Test Mode Operating Mode.

Impact on Other Measurements

If four access bursts are used to carry the control acknowledgments, then the increased use of access bursts may cause GPRS measurements to run more slowly since these bursts are skipped by the measurement.

Related Topics

How Do I Configure the Type of Bursts used to Carry the Packet Control Acknowledgments?


Active Cell Operating Mode

Active Cell Operating Mode

Last updated: December 2, 2008

This section contains the following:

  • Active Cell Operating Mode
  • Setting the Test Set's Operating Mode to Active Cell
  • Serving Cell
  • GSM Serving Cell (or Active Cell (GSM) Operating Mode)
  • GPRS Serving Cell (or Active Cell (GPRS) Operating Mode)
  • EGPRS Serving Cell (or Active Cell (EGPRS) Operating Mode)
  • Persistent Attach

Active Cell Operating Mode

The operating mode changes the way in which the test set interacts with the mobile station. Active cell operating mode provides active signaling between the mobile station and the test set's base station emulator. That is, the test set has active control of the uplink and downlink, including all signaling operations, uplink demodulation and downlink generation.

In active cell operating mode the base station emulator, using the test set's modulated source, generates a downlink (base station to mobile station direction) broadcast channel (BCH) which represents a cell. The mobile station can "camp" to this signal, just as it would camp to a cell on a real network, and perform an attach procedure to register the mobile station with the test set. The test set and mobile station can then initiate connections that allow for the transfer of information, like a GSM voice call or a data connection using GPRS or EGPRS.

Test set test modes are used when it is not possible, or not desired, to communicate via over-the-air signaling with the mobile station, but downlink stimulus and uplink measurements are still needed. For more details on test modes provided by the test set, see Test Mode Operating Modes .

NOTE
Trying to set any of the network configuration parameters while the operating mode is Active Cell generates the following error:

GSM/GPRS operation rejected; Attempting to set <MCC|MNC|LAC|NCC|BCC|RAC> while generating a BCH .

Setting the Test Set's Operating Mode to Active Cell

The test set's operating mode is set using the command, CALL:OPERating:MODE . Specifying the `CALL' parameter selects Active Cell Mode.

On the test set's front panel, the Active Cell operating mode parameter is coupled with the serving cell parameter.

Serving Cell

The serving cell setting determines type of base station the test set emulates when the operating mode is set to Active Cell. This parameter determines what information is sent on the broadcast channel and the messages, parameter, and fields that the test set uses when signaling the mobile station.

You can set the serving cell to either GSM, GPRS, or EGPRS. The choice of serving cells available to you depends on the licenses you have for the test or lab application you are currently using. When the serving cell is GPRS or EGPRS, the test set provides GPRS or EGPRS specific information on the BCH, such as System Information 13 data. This setting is independent of the Connection Type setting, which determines the type of call or data connection permitted.

NOTE
When the serving cell is GPRS or EGPRS, it is still possible to make GSM voice calls. If the mobile station is GPRS or EGPRS capable it still sees the cell as being GPRS/EGPRS enabled and may attempt an attach procedure. It is still possible to initiate and accept GSM voice calls when the mobile station is GPRS attached.

When the serving cell is GSM, a GPRS or EGPRS capable mobile should not attempt to attach or be capable of accepting a data connection.

NOTE
The test set currently does not provide a combined GPRS + EGPRS operating mode. Therefore, a mobile station that supports GPRS but not EGPRS will not be able to attach when the serving cell is set to EGPRS. The GPRS serving cell setting should be used instead.

Configuring the Serving Cell

To set the Serving Cell remotely, use the following process:

  • Turn the cell off by setting the operating mode to OFF using the command CALL:OPERating:MODE .
  • Use the command CALL[:CELL]:BCHannel:SCELl to set the serving cell to GSM, GPRS, or EGPRS.
  • Turn the cell back on by setting the operating mode to CALL using the command CALL:OPERating:MODE .

On the test set's front panel, the Serving Cell is coupled with some of the Operating Mode parameters. To set the serving cell manually, press the CALL SETUP key and Operating Mode ( F1 ). Select the type of cell you want to be active. The coupling between operating mode and serving cell is shown in the following table.

MUI Operating Mode settings and Serving Cell
Operating Mode | Serving Cell
Active Cell (GSM) | GSM
Active Cell (GPRS) | GPRS
Active Cell (EGPRS) | EGPRS

GSM Serving Cell (or Active Cell (GSM) Operating Mode)

When the serving cell parameter is set to GSM, the test set emulates a base station that supports only GSM. The mobile station "camps" to the test set and it is possible to originate GSM voice calls from either the mobile station or the test set. This allows the following measurements to be performed under essentially identical conditions to that which the mobile station would experience on a real network.

  • Dynamic Power (DPOW) - see Dynamic Power Measurement Description
  • GSM Analog Audio - see Analog Audio Measurement Description
  • GSM Bad Frame Indication (lab application only)- see GSM Bad Frame Indication (BFI) Measurement Description
  • GSM Bit Error Rate - see GPRS Bit Error Measurement
  • GSM Decoded Audio - see Decoded Audio Measurement Description
  • GSM Fast Bit Error - see Fast Bit Error Measurement Description
  • GSM Frame Erasure Rate (lab application only) - see GSM Frame Erasure Rate (FER) Measurement Description
  • I/Q Tuning - see I/Q Tuning Measurement Description
  • Multi-tone Audio - see Multi-tone Audio Measurement Description
  • Output RF Spectrum (ORFS) - see Output RF Spectrum Measurement Description .
  • Transmit Power (TXP) - see Transmit Power Measurement Description
  • Phase and Frequency (PFER) - see Phase and Frequency Error Measurement Description
  • Power versus Time (PVT) - see Power versus Time Measurement Description

NOTE
The Auto connection type is the only valid connection type when the serving cell is set to GSM. See Connection Types for more information.

To set the Serving Cell remotely, use the GPIB command CALL[:CELL]:BCHannel:SCELl . To set the Serving Cell manually, press the CALL SETUP key, Operating Mode ( F1 ), then select Active Cell(GSM) .

GPRS Serving Cell (or Active Cell (GPRS) Operating Mode)

When the serving cell parameter is set to GPRS, the test set emulates a base station that supports both GSM and GPRS. The mobile station "camps" to the test set and performs an attach procedure to register the mobile station with the network. It is still possible to originate GSM voice calls from either the mobile station or the test set. Additionally, a Packet Data Traffic Channel (PDTCH) can then be established and data can be transferred in both the downlink and uplink directions. This allows measurements to be performed under essentially identical conditions to that which the mobile station would experience on a real network.

NOTE
Use the GPRS serving cell if your mobile station supports GPRS, but not EGPRS. When the serving cell is EGPRS, a GSM + EGPRS BCH is provided. There is currently no combined GPRS + EGPRS mode available. Therefore, a mobile station that supports GPRS but not EGPRS will not be able to attach when the serving cell is set to EGPRS.

The Connection Type parameter is used to set the type of data connection. See Connection Types for details about the different connection types and when it is appropriate to use each.

For GPRS mobile stations which support a single uplink timeslot or two adjacent uplink timeslots, the following measurements can be made when a data connection has been established.

  • Dynamic Power (DPOW) - see Dynamic Power Measurement Description
  • GPRS Bit Error Rate (GBER) - see GPRS Bit Error Measurement
  • GPRS Block Error Rate (BLER) - see Block Error Measurement
  • GSM/GPRS Transmit Power (TXP) - see Transmit Power Measurement Description
  • I/Q Tuning (IQT) - see I/Q Tuning Measurement Description
  • Output RF Spectrum (ORFS) - see Output RF Spectrum Measurement Description .
  • Phase and Frequency (PFER) - see Phase and Frequency Error Measurement Description
  • Power versus Time (PVT) - see Power versus Time Measurement Description

Additionally, all the measurement specified in GSM Serving Cell (or Active Cell (GSM) Operating Mode) still apply when a GSM voice call is established.

To set the Serving Cell remotely, use the GPIB command CALL[:CELL]:BCHannel:SCELl . To set the Serving Cell to GPRS manually, press the CALL SETUP key, Operating Mode ( F1 ), then select Active Cell(GPRS) .

For a typical scenario detailing the steps you might take to test a GPRS mobile station, see Testing a GPRS Mobile Station .

EGPRS Serving Cell (or Active Cell (EGPRS) Operating Mode)

When the serving cell parameter is set to EGPRS, the test set emulates a base station that supports GSM and EGPRS. The mobile station "camps" to the test set and performs an attach procedure. It is still possible to originate GSM voice calls from either the mobile station or the test set. Packet Data Traffic Channel (PDTCH) can be established so data can be transferred in both the downlink and uplink directions. The additional EGPRS capability activated by setting the serving cell to EGPRS includes modulation and coding schemes that differ from those used for GPRS. This allows measurements to be performed under essentially identical conditions to that which the mobile station would experience on a real network.

NOTE
When the serving cell is EGPRS, a GSM + EGPRS BCH is provided. There is currently no combined GPRS + EGPRS mode available. Therefore, a mobile station that supports GPRS but not EGPRS will not be able to attach when the serving cell is set to EGPRS. The GPRS serving cell setting should be used instead.

The Connection Type parameter is used to set the type of data connection. See Connection Types for details about the different connection types and when it is appropriate to use each.

For EGPRS mobile stations which support a single uplink timeslot or two adjacent uplink timeslots, the following measurements can be made under essentially identical conditions to that which the mobile station would experience on a real network:

  • EGPRS Modulation Accuracy (EMAC)- see Modulation Accuracy Measurement Description
  • EGPRS Transmit Power (ETXP) - see EGPRS Transmit Power (ETXP) Measurement
  • GPRS Block Error (BLER) - see Block Error Measurement
  • Output RF Spectrum (ORFS) - see Output RF Spectrum Measurement Description
  • Phase and Frequency (PFER) - see Phase and Frequency Error Measurement Description
  • Power versus Time (PVT) - see Power versus Time Measurement Description

Additionally, all the measurement specified in GSM Serving Cell (or Active Cell (GSM) Operating Mode) still apply when a GSM voice call is established.

To set the Serving Cell remotely, use the GPIB command CALL[:CELL]:BCHannel:SCELl . To set the Serving Cell to EGPRS manually, press the CALL SETUP key, Operating Mode ( F1 ), then select Active Cell(EGPRS) .

Persistent Attach

The Persistent Attach parameter provides a way for you to switch between a GPRS serving cell and EGPRS serving cell if the operating mode is Active Cell.

When the Persistent Attach state is OFF the test set's connection status will become IDLE when the operating mode is switched between Active Cell (serving cell GPRS) and Active Cell (serving cell EGPRS).

When the Persistent Attach state is ON the connection status will stay in the ACTIVE or PDP ACTIVE state when the operating mode is set to Cell Off. When the connection status remains in the ACTIVE or PDP ACTIVE state the GMM remains in the registered state which allows the mobile station to request an RAU without reattaching. Also, when Persistent Attach is ON, the information that is reported from the test set is not cleared when the operating mode is set to Cell Off.

To change between Active Cell (serving cell GPRS) and Active Cell (serving cell EGPRS) when the Persistent Attach state is ON and the operating mode is Active Cell (serving cell GPRS or EGPRS), you must first change the operating mode to Cell Off before switching to a different serving cell. For example, if the operating mode is Active Cell (serving cell GPRS) and you want to change to Active Cell (serving cell EGPRS) you must first change the operating mode to Cell Off, change cell parameters if desired, and finally change the operating mode to Active Cell (serving cell EGPRS). Persistent Attach will not work if the operating mode is changed to an operating mode other than Active Cell (serving cell GPRS or EGPRS) at any point in the transition from a GPRS serving cell to an EGPRS serving cell or vise versa.

The command to change the Persistent Attach state is CALL:MS:PATTach[:STATe] . Persistent Attach State is a Cell Parameter. See How Do I Change Cell Parameters? for instructions to manually change cell parameters.

Related Topics

Configuring the Broadcast Channel (BCH)

CALL:OPERating

CALL[:CELL]:BCHannel:SCELl

Configuring the Traffic Channel (TCH) Parameters

Configuring the Packet Data Traffic Channel (PDTCH)

Testing a GPRS Mobile Station

Programming: Getting Started Guide for E1968A GSM/GPRS Mobile Test Application Revision A.02 and E6701C GSM/GPRS Lab Application Revision C.02

GPRS Data Connection Troubleshooting

Connection Types


Broadcast Allocation (BA) Tables

Broadcast Allocation (BA) Tables

Last updated: December 2, 2008

The Broadcast Allocation (BA) table in the test set provides a list of (P)BCH ARFCNs for each band that the mobile station must measure. This provides a means for you to stress the mobile station's receiver, especially when the traffic channel and the (P)BCH are in different bands. You can:

  • Configuring the BCH BA Table
  • Configuring the PBCCH BA Table
  • Configuring General Measurement Reports Parameters

NOTE
The test set does not actually generate a signal for each (P)BCH in the BA table, but it instructs the mobile station to make measurements and report signal level.

Configuring the BCH BA Table

The BCH BA Table allows you to configure 32 BCH GSM neighbours cells. You can set the ARFCN(channel), BCC, NCC, Reporting Priority, and State for each Neighbour Cell.

The GPIB commands to configure the Neighbour Cell parameters in the BCH BA Table are as follows:

Parameter | Command
Neighbour Cell State | CALL[:CELL]:BA:TABLe:NCELl<n>[:STATe]:<band>
Neighbour Cell ARFCN | CALL[:CELL]:BA:TABLe:NCELl<n>:ARFCn:<band>
Neighbour Cell BCC | CALL[:CELL]:BA:TABLe:NCELl<n>:BCCode:<band>
Neighbour Cell NCC | CALL[:CELL]:BA:TABLe:NCELl<n>:NCCode:<band>
Neighbour Cell Reporting Priority | CALL[:CELL]:BA:TABLe:NCELl<n>:RPRiority:<band>

The parameters of each enabled Neighbour Cell in the BCH BA Table are broadcast in the System Information (SI) messages. Settings to the neighbour cell parameters are stored, but not applied until the neighbour cell is enabled.

The default value of the ARFCN for each BCH GSM neighbour cell depends on the selected broadcast band:

Default ARFCNs in BA Table

Band | Default ARFCNs (BCH GSM neighbour cell 1 to 32)
P-GSM | 20, 1, 62, 124, 9, 18, 36, 45, 54, 63, 72, 81, 90, 99, 108, 117, 7, 14, 21, 28, 35, 42, 49, 56, 63, 70, 77, 83, 91, 97, 104, 111
E-GSM | 20, 975, 37, 124, 986, 1008, 1019, 7, 18, 30, 53, 64, 76, 87, 99, 110, 10, 21, 30, 40, 50, 60, 70, 80, 90, 100, 111, 120, 980, 990, 1000, 1010
DCS | 512, 698, 885, 537, 562, 587, 612, 637, 662, 712, 737, 762, 787, 812, 837, 862, 525, 538, 551, 564, 577, 590, 603, 616, 629, 642, 655, 668, 681, 694, 707, 720
PCS | 512, 660, 810, 530, 550, 570, 590, 610, 630, 650, 690, 710, 730, 750, 770, 790, 531, 548, 566, 584, 602, 620, 638, 656, 674, 692, 711, 728, 746, 764, 782, 800
GSM850 | 150, 128, 190, 251, 138, 148, 158, 168, 178, 188, 198, 208, 218, 228, 238, 248, 135, 142, 149, 156, 163, 170, 177, 184, 191, 198, 205, 212, 219, 226, 233, 240
R-GSM | 20, 955, 28, 124, 969, 984, 999, 1014, 5, 21, 35, 50, 65, 80, 95, 110, 12, 24, 36, 48, 60, 72, 84, 96, 108, 120, 966, 977, 988, 1000, 1011, 1023
GSM450 | 270, 259, 276, 293, 262, 264, 267, 269, 272, 275, 277, 280, 282, 285, 287, 290, 260, 262, 264, 266, 268, 270, 273, 274, 276, 278, 280, 283, 284, 286, 288, 292
GSM480 | 310, 306, 323, 340, 309, 311, 314, 316, 319, 321, 324, 327, 329, 332, 334, 337, 308, 310, 312, 314, 317, 318, 320, 322, 325, 326, 328, 330, 333, 335, 336, 338
GSM750 | 450, 438, 474, 511, 444, 449, 454, 459, 465, 470, 476, 481, 487, 493, 499, 505, 442, 446, 450, 454, 458, 462, 466, 471, 475, 478, 482, 486, 490, 494, 498, 504
T-GSM810 | 380, 350, 388, 425, 356, 362, 367, 373, 379, 384, 390, 396, 401, 407, 413, 418, 354, 358, 363, 366, 370, 374, 378, 382, 386, 391, 394, 398, 402, 406, 410, 414

The BCH BA Table can also be configured manually by doing the following steps:

  1. Press CALL SETUP .
  2. Press Cell Info ( F6 ).
  3. Press Cell Lists ( F4 ).
  4. Press GSM Neighbours (BCH) ( F1 ).
  5. Use the knob to scroll to and highlight the Neighbour Cell you wish to configure.
  6. Press the knob. This displays the BCH Neighbour Cell menu (similar to the figure below) that contains the configurable parameters for the that Neighbour Cell.
  7. Use the knob to highlight the desired parameter. Rotate the knob or use the number keys to set the value for the parameter.

Configuring the PBCCH BA Table

The PBCCH BA Table allows you to configure 32 PBCCH GSM neighbour cells. You can set the ARFCN, BCC, NCC, RAC, Reporting Priority, and State for each Neighbour Cell.

The GPIB commands to configure the Neighbour Cell parameters in the PBCCH BA Table are as follows:

Parameter | Command
Neighbour Cell State | CALL[:CELL]:(PBCCH|PBCChannel):BA:TABLe:NCELl<n>[:STATe]
Neighbour Cell ARFCN | CALL[:CELL]:(PBCCH|PBCChannel):BA:TABLe:NCELl<n>:ARFCn
Neighbour Cell BCC | CALL[:CELL]:(PBCCH|PBCChannel):BA:TABLe:NCELl<n>:BCCode
Neighbour Cell NCC | CALL[:CELL]:(PBCCH|PBCChannel):BA:TABLe:NCELl<n>:NCCode
Neighbour Cell RAC | CALL[:CELL]:(PBCCH|PBCChannel):BA:TABLe:NCELl<n>:RACode
Neighbour Cell Reporting Priority | CALL[:CELL]:(PBCCH|PBCChannel):BA:TABLe:NCELl<n>:RPRiority

The parameters of each enabled Neighbour Cell in the PBCCH BA Table are broadcast in the Packet System Information (PSI) messages. Settings to the neighbour cell parameters are stored, but not applied until the neighbour cell is enabled.

NOTE: PSI messages are only transmitted when the Packet Broadcast Control Channel (PBCCH) is enabled.

The default value of the ARFCN for each PBCCH GSM neighbour cell is:

Default ARFCNs in PBCCH BA Table

 | Default ARFCNs (PBCCH GSM neighbour cell 1 to 32)
PBCCH BA Table | 20, 1, 62, 124, 9, 18, 36, 45, 54, 63, 72, 81, 90, 99, 108, 117, 7, 14, 21, 28, 35, 42, 49, 56, 63, 70, 77, 83, 91, 97, 104, 111

You can also control these parameters via the test set's front panel. The following procedure explains how to access the menus that allow you to configure simulated Neighbour Cell parameters that are transmitted on the PBCCH, when available. The Neighbour Cell menus are located in the Cell List menu.

  1. Press CALL SETUP .
  2. Press Cell Info ( F6 ).
  3. Press Cell Lists ( F4 ).
  4. Press GSM Neighbours (PBCCH) ( F2 ).
  5. Use the knob to scroll to and highlight the Neighbour Cell you wish to configure.
  6. Press the knob. This displays the PBCCH Neighbour Cell menu (similar to the figure below) that contains the configurable parameters for that Neighbour Cell.

    NOTE: You must enable the neighbour cell (set the State parameter to On), before you can access the other neighbour cell parameters.

  7. Use the knob to highlight the desired parameter. Rotate the knob or use the number keys to set the value for the parameter.

    NOTE: Since these parameters are sent on the PBCCH, these settings only apply the PBCCH state is On. See Packet Broadcast Control Channel (PBCCH) for more details.

Configuring General Measurement Reports Parameters

The GPIB commands to configure general measurement reports parameters in the (P)BCH BA Table are as follows:

Parameter | Command
Network Control Order | CALL[:CELL]:BCHannel:NCORder
Multiband Reporting | CALL[:CELL]:BCHannel:MREPorting
Network Control Reporting Period (Idle) | CALL[:CELL]:BCHannel:NCONtrol:RPERiod:IDLE
Network Control Reporting Period (Transfer) | CALL[:CELL]:BCHannel:NCONtrol:RPERiod:TRANsferring
Network Control Non-DRX Period | CALL[:CELL]:(PBCCH|PBCChannel):NCONtrol:NDRX:PERiod
Reporting Rate | CALL[:CELL]:BCHannel:REPorting:RATE
Reporting Type | CALL[:CELL]:BCHannel:REPorting:TYPE
Serving Band Reporting | CALL[:CELL]:BCHannel:SBReporting
Scale Ord | CALL[:CELL]:BCHannel:SORD

The general measurement reports parameters can also be configured manually by doing the following steps:

  1. Press CALL SETUP .
  2. Press the left More key to advance the Control menu to ( 2 of 3 ).
  3. Press Measurement Reports ( F6 ).
  4. Press Configure ( F2 ).
  5. Press General Meas Parameters ( F1 )
  6. Use the knob to highlight the desired parameter. Rotate the knob or use the number keys to set the value for the parameter.

Related Topics

Measurement Reports

3G FDD Neighbour Cells

CALL:BA

CALL:(PBCCH|PBCChannel)

CALL:BCHannel


Configuring the Broadcast Channel (BCH)

Configuring the Broadcast Channel (BCH)

Last updated: December 2, 2008

The broadcast channel parameters are configured using the following call processing subsystem commands.

For a complete list of GPIB commands in the call processing subsystem, refer to CALL Subsystem .

Broadcast Channel Parameters

Parameter | GPIB Command
Cell Band | CALL[:CELL]:BAND<[:SELected]|:GSM>
Cell Power | CALL[:CELL]:POWer[:SAMPlitude][:SELected]
Cell Power State | CALL[:CELL]:POWer:STATe[:SELected]
Broadcast Channel (ARFCN) | CALL[:CELL]:BCHannel[:ARFCn][:SELected]
IMSI Attach Flag State | CALL:IATTach
Paging IMSI | CALL:PAGing:IMSI
Auto IMEI Request | CALL:IMEI

Operating Considerations

There are a number of parameters for the broadcast channel and the traffic channel (see Configuring the Traffic Channel (TCH) Parameters ) that can be configured, however the test set's default parameters should allow a properly functioning mobile station to successfully camp on the cell and make a call under most circumstances.

Parameters can be queried from the test set regardless of the state of the test set.

The 3 Digit MNC for PCS parameter defines if the PCS BCCH should be configured using the standard 2-digit MNC (J-STD-007 coding), or the PCS 3-digit MNC (J-STD-007A coding, section 2.10.5.1.3). The PCS 3-digit MNC is used on the PCS BCCH instead of the 2-digit MNC only when the current cell band is PCS and the 3 Digit MNC for PCS parameter is set to on.

Related Topics

Cell Parameters

Connection Types

Access Burst Power Control

Frequency Banded Parameters

Band Selection Parameters


Block Polling Parameters

Block Polling Parameters

Last updated: December 2, 2008

The block polling parameters allow you to specify the block polling interval the test set uses to sample blocks sent or received by the mobile station for applicable connection types. There are three connection types the test set offers that apply to block polling interval parameters: Auto , BLER , and ETSI Type B (Ack) . Additionally, there is a separate block polling interval field that you can set that applies to the currently selected connection type. Therefore, there are four block polling interval configurable parameters:

  • Block Polling Interval (Current)

    This parameter is only applicable when the test set's connection type is Auto, BLER or ETSI Type B.

    The command to set this parameter is CALL:FUNCtion:DATA:BLOCk:POLLing:INTerval[:SELected] .

  • Block Polling Interval (Auto)

    This parameter is only applicable to the lab applications.

    The command to set this parameter is CALL:FUNCtion:DATA:BLOCk:POLLing:INTerval:AUTO .

  • Block Polling Interval (BLER)

    The command to set this parameter is CALL:FUNCtion:DATA:BLOCk:POLLing:INTerva:BLER .

  • Block Polling Interval (ETSI B Ack)

    The command to set this parameter is CALL:FUNCtion:DATA:BLOCk:POLLing:INTerval:ACKB .

You can configure the block polling interval for the valid connection types at any time with the exception of Block Polling Interval (Current). The test set does not allow you to set the block polling interval for the currently selected connection type if the connection type is not applicable to the block polling interval parameters.

The command to set the connection type is CALL:FUNCtion:CONNection:TYPE .

How Do I Configure the Block Polling Interval Parameters?

  1. Press CALL SETUP .
  2. Press the bottom left Mor e key until Control menu ( 2 of 3 ) appears.
  3. Press Protocol Control ( F4 ).
  4. Press RLC/MAC ( F2 ).
  5. Press Block Polling Parameters ( F4 ). This opens the Block Polling Parameter menu in the center of the screen.
  6. Use the knob to highlight and change the desired parameter.

Related Topics

Protocol Control


Cell Allocation (CA) Table

Cell Allocation (CA) Table

Last updated: December 2, 2008

The cell allocation (CA) table is a list of BCH ARFCNs available within the cell. The default CA Table contains ARFCNs within all available bands (PGSM, EGSM, DCS, PCS, RGSM, T-GSM810, GSM450, GSM480, GSM850, GSM750).

An MA Table is a list of the ARFCNs present in the CA Table that share the same frequency band. There is a separate MA Table for each frequency band. The ARFCNs in the MA Table must be chosen from the test set's CA Table because the CA Table contains all the ARFCNs available for use in the cell. If a handoff to another band occurs, the test set uses the MA Table for the band that it was instructed to handoff to. A maximum of sixteen entries are allowed in the CA Table and the MA Table. Table. Note: There would need to be sixteen ARFCNs in the CA Table that have the same frequency band for an MA Table to have sixteen entries. If this were the case, the MA Table for all the other frequency bands would not contain any entries.

When the MA Table is configured automatically, any changes to the CA Table are populated in the MA Table of the appropriate frequency band. The state of each entry in an MA Table can be manually set. See Setting up Frequency Hopping for GSM Traffic Channels for instructions to manually change the MA Table.

See Changing the Cell Allocation (CA) Table for instructions on how to manually change the CA Table.

See CALL:CA:TABLe for the GPIB command to change the CA Table.

Related Topics

Frequency Hopping


Frequency Bands

Frequency Bands

Last updated: December 2, 2008

A cell's frequency band determines which frequency range the test set uses to communicate with a mobile station. The actual frequencies (uplink and downlink) used inside the frequency range are determined by the ARFCN.

The frequency ranges and channel arrangements, as well as the formulas that describe the actual frequency of the ARFCN, are detailed in the 3GPP TS 45.005 Version 5.9.0 Release 5 (with the exception of the T-GSM810 band) and the tables below.

 | GSM 450 | GSM 480 | GSM 750
Programming Mnemonic | GSM450 | GSM480 | GSM750
UL/DL Frequency Separation (MHz) | 10 | 10 | 30
Uplink Frequency (MHz) | Range: 450.4 through 457.6 Resolution: .2 | Range: 478.8 through 486 Resolution: .2 | Range: 747 through 762 Resolution: .2
Downlink Frequency (MHz) | Range: 460.4 through 467.6 Resolution: .2 | Range: 488.8 through 496 Resolution: .2 | Range: 777 through 792 Resolution: .2
ARFCN | 259 through 293 | 306 through 340 | 438 through 511
Uplink (UL) Formula (MHz) | FUL(n) = 450.6 + 0.2*(n-259) | FUL(n) = 479 + 0.2*(n-306) | FUL(n) = 747.2 + 0.2*(n-438)
Downlink (DL) Formula (MHz) | FDL(n) = FUL(n)+10 | FDL(n) = FUL(n)+10 | FDL(n) = FUL(n)+30
 | GSM 850 | T-GSM810
Programming Mnemonic | GSM850 | TGSM810
UL/DL Frequency Separation (MHz) | 45 | 45
Uplink Frequency (MHz) | Range: 824 through 849 Resolution: .2 | Range: 806 through 821 Resolution: .2
Downlink Frequency (MHz) | Range: 869 through 894 Resolution: .2 | Range: 851 through 866 Resolution: .2
ARFCN | 128 through 251 | 350-425
Uplink (UL) Formula (MHz) | FUL(n) = 824.2 + 0.2*(n-128) | FUL(n) = 806 + .2*(n-350)
Downlink (DL) Formula (MHz) | FDL(n) = FUL(n)+45 | FDL(n) = FUL(n)+45

 | PGSM 900 (Primary GSM) | EGSM 900 (Extended GSM) | RGSM 900 (Railways GSM)
Programming Mnemonic | PGSM | EGSM | RGSM
UL/DL Frequency Separation (MHz) | 45 | 45 | 45
Uplink Frequency (MHz) | Range: 890 through 915 Resolution: .2 | Range: 880 through 915 Resolution: .2 | Range: 876 through 915 Resolution: .2
Downlink Frequency (MHz) | Range: 935 through 960 Resolution: .2 | Range: 925 through 960 Resolution: .2 | Range: 921 through 960 Resolution: .2
ARFCN | 1 through 124 | 0 through 124 975 through 1023 | 0 through 124 955 through 1023
Uplink (UL) Formula (MHz) | FUL(n) = 890 + 0.2*n | FUL(n) = 890 + 0.2*n (for n = 0 through 124) FUL(n) = 890 + 0.2*(n-1024) (for n = 975 through 1023) | FUL(n) = 890 + 0.2*n (for n = 0 through 124) FUL(n) = 890 + 0.2*(n-1024) (for n = 955 through 1023)
Downlink (DL) Formula (MHz) | FDL(n) = FUL(n)+45 | FDL(n) = FUL(n)+45 | FDL(n) = FUL(n)+45

DCS 1800 | PCS 1900
Programming Mnemonic | DCS | PCS
UL/DL Frequency Separation (MHz) | 95 | 80
Uplink Frequency (MHz) Range: 1710 through 1785
Resolution: .2

Range: 1850 through 1910
Resolution: .2
Downlink Frequency (MHz) Range: 1805 through 1880
Resolution: .2

Range: 1930 through 1990
Resolution: .2
ARFCN

512-885

512-810
Uplink (UL) Formula (MHz) | FUL(n) = 1710.2 + 0.2*(n-512) | FUL(n) = 1850.2 + .2*(n-512)
Downlink (DL) Formula (MHz) | FDL(n) = FUL(n)+95 | FDL(n) = FUL(n)+80

You can specify the traffic channel (ARFCN) using the GPIB commands listed in the section describing the traffic channel, see TCH Parameters .

Operating Considerations

If a handover is attempted during a GSM call to a traffic band not supported by the mobile station, the call is dropped and the test set displays the following message, "GSM call disconnected; Channel assignment failure (Timer T3107 expiry)". The call will not be disconnected if the test set changes from one supported traffic band to the another during a call.

If the traffic channel is changed while a call is connected, the call will be dropped.

Changes to the Cell Band parameter are reflected in the Traffic Band parameter.

Related Topics

Frequency Banded Parameters


Cell Identification Parameters

Cell Identification Parameters

Last updated: December 2, 2008

User Configurable Cell Identification Parameters

The following table lists the GPIB Commands to set the Cell Identification parameters. Please click the parameter's corresponding GPIB command link for more information on a specific parameter. The GPIB Command tables give a description of the parameter, as well as valid settings and firmware requirements.

All of the parameters listed below are located in the Cell Identification menu of the test set's front panel. See How Do I Change Cell Identification Parameters? for the procedure to configure the cell parameters. Refer to the Operating Considerations below before attempting to configure the cell parameters.

Parameter | GPIB Command
3 Digit MNC for PCS1900 | CALL:PMNCode
3 Digit MNC for GSM 850 | CALL:G850MNCode
Base Station Color Code | CALL:BCCode
Cell Identity* | CALL[:CELL]:BCHannel:CIDentity
Location Area Code | CALL:LACode
Mobile Country Code | CALL:MCCode
Mobile Network Code | CALL:MNCode
Network Color Code | CALL:NCCode
Routing Area Code | CALL:RACode
* Only applicable to the lab application.

Operating Considerations

NOTE
The following parameters are located in the Cell Parameters menu in the E6701D lab application and E1968A test application: Base Station Color Code, Location Area Code, Mobile Country Code, Mobile Network Code, Network Color Code, and Routing Area Update.

The test set's default parameters should allow a properly functioning mobile station to successfully camp on the cell and make a connection under most circumstances.

Parameters can be queried from the test set regardless of the state of the test set.

Parameter MNC, MCC, LAC, RAC, NCC, BCC, and Persistent Attach can not be set unless the Operating Mode is Cell Off. See CALL:OPERating:MODE .

If the test set is in a test mode (see Test Mode Operating Modes ) operating mode, any BCH parameter can be set at any time.

The 3 Digit MNC for PCS1900 parameter defines if the PCS BCCH should be configured using the standard 2-digit MNC (J-STD-007 coding), or the PCS 3-digit MNC (J-STD-007A coding, section 2.10.5.1.3). The PCS 3-digit MNC is used on the PCS BCCH instead of the 2-digit MNC only when the current cell band is PCS and the 3 Digit MNC for PCS parameter is set to on . 3 Digit MNC for PCS1900 can not be set unless the Operating Mode is Cell off and Cell Band is PCS1900.

The 3 Digit MNC for GSM850 parameter defines if the BCCH should be configured using the standard 2-digit MNC (J-STD-007 coding), or the 3-digit MNC (J-STD-007A coding, section 2.10.5.1.3). The 3-digit MNC for GSM850 is used on the BCCH instead of the 2-digit MNC only when the current cell band is GSM850 and the 3 Digit MNC for GSM850 parameter is set to on . 3 Digit MNC for GSM850 can not be set unless the Operating Mode is Cell off and Cell Band is GSM850.

Related Topics

Configuring the Broadcast Channel (BCH)


Cell Lists

Cell Lists

Last updated: December 2, 2008

Please click one of the following Cell Lists to for more information.

  • Broadcast Allocation (BA) Tables
  • Cell Allocation (CA) Table
  • 3G FDD Neighbour Cells

For information on how to manually access the Cell Lists, see How Do I Change Cell List Parameters? .


Cell Operation

Cell Operation

Last updated: December 2, 2008

NOTE
The E6701E E.00.08 lab application introduced changes to the location of many parameters in the test set. These changes are not present in any lab application revisions prior to the E6701E revision E.00.08.

If you have a revision prior to the E6701E E.00.08, it is important that you use the downloadable CHM Help File that is specific to your test or lab application revision. This can easily be found in the Release Notes .

Cell Operation parameters are cell related parameters that directly impact the test set's cell behavior. Important Cell Operation parameters are displayed on the test set's Cell Information screen.

User Configurable Cell Operation Parameters

The following table lists the GPIB Commands to set the Cell Operation parameters. Please click the Cell Operation parameter that corresponds to the GPIB command link for more information on the parameter. The GPIB Command tables give a description of the parameter, as well as valid settings and firmware requirements.

All of the parameters listed below are located in the Cell Operation menu of the test set's front panel. See How Do I Change Cell Operation Parameters? for the procedure to configure the cell operation parameters. Refer to the Operating Considerations below before attempting to configure the cell parameters.

Parameter | GPIB Command
BCH Type* | CALL[:CELL]:BCHannel:TYPE
Cell Change Notification (CCN) GSM State* | CALL[:CELL]:CCNactive:GSM[:STATe]
Cell Change Notification (CCN) 3G State* | CALL[:CELL]:CCNactive:UTRan[:STATe]
Dual Transfer Mode* | CALL[:CELL]:DTMode
Enhanced Dual Transfer Mode* | CALL[:CELL]:DTMode:ENHanced
EPC Mode* | CALL:SIGNaling:MS:EPControl:MODE[:STATe]
EPC Continuous* | CALL:SIGNaling:MS:EPControl:CONTinuous[:STATe]
EPC Maximum Step Size* | CALL:SIGNaling:MS:EPControl:STEP:MAXimum
Extended Uplink TBF State* | CALL:SIGNaling:MS:EPControl:STEP:MAXimum
MSC/SGSN Revision | CALL[:CELL]:BCHannel:MSCRevision
Mobile DTX State | CALL:MS:DTX[:STATe]
Downlink DTX State* | CALL:TCHannel:DOWNlink:DTX[:STATe]
Packet Control Ack Type* | CALL[:CELL]:PCAType
Persistent Attach | CALL:MS:PATTach[:STATe]
PBCCH | CALL[:CELL]:(PBCCH|PBCChannel)[:STATe]
PRACH Length | CALL[:CELL]:(PBCCH|PBCChannel):PRACh:LENGth
Packet Flow Context (PFC) State* | CALL[:CELL]:PFContext[:STATe]
Packet (P)SI Status Indication State* | CALL[:CELL]:PSINdication
Serving Cell | CALL[:CELL]:BCHannel:SCELl
TX Level FACCH Signaling | CALL:SIGNaling:MS:TXLevel:FACCH
* Only applicable to the lab application.

Operating Considerations

The test set's default parameters should allow a properly functioning mobile station to successfully camp on the cell and make a connection under most circumstances.

Parameters can be queried from the test set regardless of the state of the test set.

If the test set is in a test mode (see Test Mode Operating Modes ) operating mode, any BCH parameter can be set at any time.

For more information about the Mobile DTX State and Downlink DTX State, see Discontinuous Transmission .

When TX Level FACCH Signaling is set to on, measurements are aborted and restarted as a result of mobile TX power level changes. However, when TX Level FACCH Signaling is set to off, measurements are not aborted and restarted. This may cause the integrity result for some measurements to indicate an under range or over range condition until the mobile's TX power level is within the specified measurement range. For more information about measurement integrity, see Integrity Indicator .

Related Topics

Configuring the Broadcast Channel (BCH)


Cell Parameters

Cell Parameters

Last updated: December 2, 2008

User Configurable Cell Parameters

The following table lists the GPIB Commands to set the Cell Parameters . Please click the Cell Parameter's corresponding GPIB command link for more information on the Cell Parameter. The GPIB Command tables give a description of the parameter, as well as valid settings and firmware requirements.

All of the parameters listed below are located in the Cell Parameters menu of the test set's front panel. See How Do I Change Cell Parameters? for the procedure to configure the cell parameters. Refer to the Operating Considerations below before attempting to configure the cell parameters.

Parameter | GPIB Command
Band Indicator | CALL[:CELL]:BINDicator
BEP Period* | CALL[:CELL]:BCHannel:BEPPeriod
BEP Period2* | CALL[:CELL]:BCHannel:BEPPeriod2[:SVALue]
Block Sequence Countdown Value Max* | CALL[:CELL]:BCHannel:BSEQuence:CVALue:MAXimum
C2 Penalty Time* | CALL[:CELL]:BCHannel:PTIMe
C2 Temporary Offset* | CALL[:CELL]:BCHannel:TOFFset
Cell Bar Access* | CALL[:CELL]:BCHannel:CBAR:ACCess
Cell Bar Qualify* | CALL[:CELL]:BCHannel:CBAR:QUALify
Cell Reselect Hysteresis* | CALL[:CELL]:BCHannel:CRHYsteresis
Cell Reselect Offset* | CALL[:CELL]:BCHannel:CROFfset
DRX Timer Max* | CALL[:CELL]:BCHannel:DRXTimer:MAXimum
IMSI Attach State | CALL[:CELL]:IATTach[:STATe]?
MS TX Power Max CCH (GSM) | CALL[:CELL]:BCHannel:MS:TXLevel[:SELected]
MS TX Power Max CCH (GPRS)* | CALL[:CELL]:(PBCCH|PBCChannel):MS:TXLevel[:SELected]
MS TX Power Max CCH DCS1800 Offset | CALL[:CELL]:MS:CCHannel:POWer:OFFSet:DCS
N AVG I* | CALL[:CELL]:BCHannel:N:AVGI
NCC Permitted* | CALL[:CELL]:BCHannel:NCCPermitted
PC Measurement Channel* | CALL[:CELL]:BCHannel:PCMChannel
RX Lev Access Min* | CALL[:CELL]:BCHannel:RLAMinimum
SACCH LAPDm Format | CALL:(SACCH|SACChannel):LAPDModified:FORMat
T AVG T* | CALL[:CELL]:BCHannel:T:AVGT
T AVG W* | CALL[:CELL]:BCHannel:T:AVGW
Network Mode of Operation* | CALL[:CELL]:NMOPeration
* Only applicable to the lab application.

Operating Considerations

NOTE
The E6701E lab application introduces many of the parameters in the above menu that are not available in the E6701D lab application and E1968A test application. Also, the following parameters that are located in the Cell Parameters menu in the E6701D lab application and E1968A test application have been relocated to different menus in the E6701E lab application: Call Originate Timeout, EGPRS Link Quality Measurement Mode, Get IMEI at Call Setup, Asymmetric Guard Period Length, Paging IMSI, Paging Mode, Paging Multiframes, Repeat Paging, Uplink Frame Segmentation. Please use the CHM Help File for the specific application revision that you have.

The test set's default parameters should allow a properly functioning mobile station to successfully camp on the cell and make a connection under most circumstances.

Parameters can be queried from the test set regardless of the state of the test set.

Changes to this parameter (except Band Indicator and IMSI Attach State) can only be made when the Operating Mode is set to Off. See CALL:OPERating:MODE .

Related Topics

Configuring the Broadcast Channel (BCH)


Connection Types

Connection Types

Last updated: December 2, 2008

  • AUTO
  • BLER
  • ETSI Type A
  • ETSI Type B (Unacknowledged)
  • ETSI Type B Acknowledged
  • Switched Radio Block Loopback
  • Operating Considerations

AUTO

The AUTO connection type emulates a typical real world scenario where a GPRS or EGPRS capable mobile can initiate either a voice call or a data connection (not simultaneously). Alternatively the test set can initiate a voice call to simulate the mobile being called. Voice calls have priority over data connections. If a voice call is in progress, data transfer requests will be ignored. Originating a mobile terminated voice call while a data transfer is in progress will cause the data connection to be terminated.

Also see Operating Considerations .

BLER

This connection type is not applicable to GSM.

The BLER connection type ensures that an Agilent proprietary data connection type is used which allows the test set to obtain BLock Error Rate (BLER) measurement reports from the mobile station (see Block Error Rate (BLER) Reports Description ). In addition, the BLER connection type allows you to perform other GPRS measurements at the same time (except BER and ORFS due to Modulation).

Also see Operating Considerations .

ETSI Type A

This connection type is not applicable to GSM.

The ETSI Type A connection type ensures that packet data traffic channel (PDTCH) bursts are only transmitted on the uplink, not on the downlink. The number of downlink bursts is determined by the setting of the command CALL:(PDTCH|PDTChannel):MSLot:CONFig .

  • Protocol Data Unit Count

    The Protocol Data Unit (PDU) count value can be set to one of two values: 0 or 4095. When the PDU is set to zero, the test set commands the mobile station to continually transmit PDUs as long as there is a connection between the mobile station and the test set. The default PDU count is 4095. When the PDU count is set to 4095 the test set commands the mobile station to send 4095 PDUs on the uplink TBF before the mobile station terminates the connection between the mobile station and the test set.

    NOTE
    The mobile station is not required to support a continuous transmission of PDUs. If the mobile station being tested does not support continuous transmission of PDUs, the number of PDUs that are transmitted is 4095.

    The PDU count can be set in any operating mode, however the PDU count cannot be set during data transfer if the connection type is ETSI Type A, ETSI Type B (Unacknowledged) , or ETSI Type B Acknowledged . If an attempt is made to change the PDU count while in an invalid connection type the change will not occur and the front panel will display a message that states "Call operation rejected; Protocol request ignored".

    The PDU count is only accessible via the GPIB command CALL:FUNCtion:DATA:ETSIA:PDUNit|PDU:COUNt .

Also see Operating Considerations .

ETSI Type B (Unacknowledged)

This connection type is not applicable to GSM.

The ETSI Type B connection type ensures that one or more downlink (PDTCH) bursts are present, which can be used to loopback data through the uplink. ETSI Type B is required if you want to perform BER measurements in active cell mode.

Also see Operating Considerations .

ETSI Type B Acknowledged

This connection type is not applicable to GSM.

The ETSI Type B Acknowledged connection type is almost identical to the ETSI Type B (Unacknowledged) connection type, except that it features an acknowledged downlink. The acknowledged downlink ensures maximum compatibility with different mobile station types.

Also see Operating Considerations .

Switched Radio Block Loopback

This connection type is only applicable to EGPRS.

The Switched Radio Block (SRB) Loopback connection type allows an EGPRS mobile to perform a layer one loopback while in a signaling mode. This ETSI defined standard test mode within the mobile is sometimes known as ETSI test mode C.

Also see Operating Considerations .

Operating Considerations

The operating mode must be Active Cell for any connection types to be used. For more information about Active Cell operating mode, see Active Cell Operating Mode .

These settings are not coupled to the serving cell which must be set to GPRS or EGPRS to allow the GPRS or EGPRS mobile to accept or originate data connections. See Serving Cell for more information.

Related Topics

CALL:FUNCtion:CONNection:TYPE


Packet Control Acknowledgment Burst

Packet Control Acknowledgment Burst

Last updated: December 2, 2008

The Packet Control Acknowledgment message is sent from the mobile station to the test set in response to System Information messages or a Packet Polling Request message. The format of the Packet Control Acknowledgment message can be configured in the test set as an RLC/MAC control block or as four identical access bursts. The format of the Packet Control Acknowledgment message is determined by the TYPE_OF_ACK parameter if the acknowledgment message is sent in response to a Packet Polling Request message. Otherwise, the format of the Packet Control Acknowledgment message is determined by the CONTROL_ACK_TYPE parameter contained in the System Information messages, the indicates which format the Packet Control Acknowledgment message is to use.

Related Topics

Cell Operation


Control Channel Setup

Control Channel Setup

Last updated: December 2, 2008

This section is only applicable to GPRS and EGPRS.

User Configurable Associated Control Channel Parameters

Parameter | GPIB Command
EGPRS Link Quality Measurement Mode | CALL:MS:LQMMode
Send Packet System Information on PACCH | CALL:(PACCH|PACChannel):PSInfo
Periodic PSI List | CALL:(PACCH|PACChannel):PSI:PERiodic:LIST
Packet (P)SI Status Indication Response | CALL:(PACCH|PACChannel):PSINdication:RESPonse
Send encapsulated SI on PACCH | CALL:(PACCH|PACChannel):SI
Periodic (P)SI repetition time | CALL:(PACCH|PACChannel):PSI:PERiodic:TIME
Custom SI List | CALL:(PACCH|PACChannel):SI:CUSTom:SI1|2|3|4|13[:STATe] CALL:(PACCH|PACChannel):SI:CUSTom:SI2:BIS[:STATe] CALL:(PACCH|PACChannel):SI:CUSTom:SI2:TER[:STATe] CALL:(PACCH|PACChannel):SI:CUSTom:SI2:QUATer[:STATe]
Custom PSI List | CALL:(PACCH|PACChannel):PSInfo:CUSTom:PSI1|2|3|5|8|13|14[:STATe] CALL:(PACCH|PACChannel):PSInfo:CUSTom:PSI3:BIS[:STATe] CALL:(PACCH|PACChannel):PSInfo:CUSTom:PSI3:QUATer[:STATe]

For the procedure to access the Control Channel Parameters, see How Do I Configure the Control Channel Parameters? .

EGPRS Link Quality Measurement Mode

See the GPIB command description.

Send Packet System Information on PACCH

You can configure the test set to control if and when the Packet Associated Control Channel (PACCH) Packet System Information (PSI) messages are sent.

The GPIB command to set this parameter is CALL:(PACCH|PACChannel):PSInfo .

Periodic PSI List

The Periodic PSI List setting allows you to select the manner that the PSI messages will be transmitted periodically on the PACCH when a packet-switched connection is available. The two manners are:

  • Standard

    In the standard manner, the PSI messages are sent in a fixed interval which is determined by the Periodic (P)SI repetition time , and in the following decision:

    • If PBCCH is not present in the cell, for a PS-only connection transmit PSI13 and for a DTM connection transmit PSI14 on the PACCH.
    • If PBCCH is present in the cell, for a PS-only connection transmit PSI1, and for a DTM connection transmit PSI14 on the PACCH.

    See Packet Broadcast Control Channel (PBCCH) for instructions on how to configure the PBCCH.

  • Custom

    In the custom manner, the PSI messages are sent in a fixed interval which is determined by the Periodic (P)SI repetition time . The test set transmits a customizable set of PSI messages defined by the Custom PSI List on the PACCH. The test sets also transmits a customizable set of encapsulated SI messages defined by the separated Send encapsulated SI on PACCH .

Periodic (P)SI repetition time

The Periodic (P)SI repetition time setting allows you to modify the repetition rate of periodic PSI and/or SI messages which are transmitted on the PACCH when the periodic SI and/or PSI transmission is enabled.

Packet (P)SI Status Indication Response

The Packet (P)SI Status Indication Response setting allows you to modify the behavior of the test set in response to a Packet SI Status Indication or Packet PSI Status Indication message received from the DUT.

  • MS Requested

    The test set response the Packet SI Status Indication or Packet PSI Status Indication message in a manner determined by the message content supplied by the DUT.

  • Custom

    The test set response the Packet SI Status Indication or Packet PSI Status Indication message in the following decision:

    • Transmit a customizable set of PSI messages which are determined by Custom PSI List on the PACCH.
    • Transmit a customizable set of encapsulated SI messages which are determined by Custom SI List within the Packet Serving Cell SI messages on the PACCH.

Send encapsulated SI on PACCH

The Send encapsulated SI on PACCH setting allows you to configure whether the SI messages encapsulated in Packet Serving Cell SI messages are transmitted periodically on the PACCH.

Custom SI List

The Custom SI List Setting allows you to configure a specific set of SI messages to be transmitted on the PACCH. You can enable the transmission of SI 1, SI 2, SI 2bis, SI 2ter, SI 2quater, SI 3, SI 4 or SI 13 by setting the Custom SI List. The customizable set of SI messages will be transmit:

  • At a periodic interval on a PS connection if the Send encapsulated SI on PACCH is set to ON and the Periodic PSI List is set to custom .
  • As a pre-specified response to a Packet SI Status Indication received from the DUT.

Custom PSI List

The Custom PSI List Setting allows you to configure a specific set of PSI messages to be transmitted on PACCH. You can enable the transmission of PSI 1, PSI 2, PSI 3, SI 3bis, SI 3quater, SI 5, SI 8, SI 13 or SI 14 by setting the Custom PSI List. The customizable set of PSI messages will be transmit:

  • At a periodic interval on a PS connection if the Send Packet System Information on PACCH is set to ON and the Periodic PSI List is set to custom .
  • As a pre-specified response to a Packet PSI Status Indication received from the DUT.

Operating Considerations

The control channel parameters can be changed in any Operating Mode , however the settings is only applicable when the test set is in Active Cell Operating Mode .

Refer to the 3GPP TS 45.002 Version 6.8.0 Section 6.3 for more details on PSI messages.

Related Topics

How Do I Configure the Control Channel Parameters?


Dedicated Control Channel (DCCH) Features

Dedicated Control Channel (DCCH) Features

Last updated: December 2, 2008

Stand Alone Dedicated Control Channel (SDCCH)

This section contains the following:

  • Calls via the SDCCH
  • Combined and Non-Combined BCH/SDCCH
  • Configurable Parameters
  • Operating Considerations

Calls via the SDCCH

Call connection setup may take place on either the FACCH (Fast Associated Control Channel) or the SDCCH (Stand Alone Dedicated Control Channel) during call setup. When FACCH signaling is used, the mobile station is immediately assigned to a traffic channel. The call set-up signaling usually occurs on the SDCCH, after which the network assigns the mobile station to a traffic channel on which voice transfers occur. You can configure which control channel the test set uses for call setup signaling using the Assignment Channel parameter and you can configure which control channel the test set assigns the mobile station to following call setup with the Destination Channel parameter. Additionally, you can choose to stall the connection setup process when the SDCCH is in use, and choose when you want the connection setup to continue or return to idle mode. Call setup signaling and transmitter measurements take slightly longer to complete when the Assignment Channel is set to SDCCH since the frequency at which the SDCCH frames occur is lower than the FACCH frame count on the TCH.

Combined and Non-Combined BCH/SDCCH

3GPP TS 05.02 Section 6.4 lists the permitted channel combinations. Support for the SDCCH and SACCH is given by the test set through combination v (FCCH + SCH + CCCH + BCCH + SDCCH/4 + SACCHC/C4). Combination v is referred to as the `Combined BCH/SDCCH'. The test set also supports the channel combination iv and vii (where iv is FCCH + SCH + BCCH + CCCH and vii is SDCCH/8 + SACCH/C8), which is referred to as the `Non-Combined BCH/SDCCH'. In the non-combined case, the SDCCH and the SACCH each have 8 sub-channels and exist on a separate physical channel from the BCH of the channel combination iv. The BCH Type setting determines which timeslot the SDCCH is fixed to. The value of the SDCCH ARFCN is set to that of the BCH ARFCN. The table below summarizes how other parameters are affected by the BCH Type setting.

BCH Type and SDCCH Settings

BCH Type | SDCCH ARFCN | SDCCH Timeslot | SDCCH Subchannel Range
Combined | BCH ARFCN | 0 (Same as the BCH timeslot) | 0-3 (default = 0)
Non-Combined | BCH ARFCN | 2 | 0-7 (default = 0)

Configurable Parameters

The following parameters affect the SDCCH.

  • Assignment Channel

    This parameter allows you to set the channel type that is used for call setup signaling. The options for this setting are: TCH or SDCCH. The TCH setting immediately assigns a TCH for call setup signaling, which provides the fastest signaling process. The SDCCH setting assigns a SDCCH to perform the call setup signaling, which is normally used in a network.

    This parameter only affects the test set's operation when the operating mode is set to Active Cell (GSM, GPRS, or EGPRS) . This parameter cannot be modified during call setup signaling.

    The GPIB command to set this parameter is CALL:TCHannel:SIGNaling:ASSignment:CHANnel .

  • BCH Type

    This parameter allows you to choose the channel combination the test set utilizes. The options for the BCH Type are: Combined or Non-Combined. The combined and non-combined channel combinations are described in Combined and Non-Combined BCH/SDCCH .

    The test set does not support Frequency Hopping on the Packet Data Traffic Channel when the BCH Type is set to Non-Combined .

    This setting does not affect the test set's operation when the operating mode is set to Cell Off or CW . You can configure this parameter only when the operating mode is set to Cell Off .

    The GPIB command to set this parameter is CALL[:CELL]:BCHannel:TYPE .

  • Destination Channel

    This parameter allows you to set the control channel to which the mobile station is assigned once the call setup is complete. There are two options: TCH or SDCCH. When SDCCH is selected the mobile station remains on the SDCCH until one of the following actions occur: the call is ended, the mobile station performs a handover to a TCH, or the Destination Channel is changed to TCH. The Destination Channel can also perform a channel assignment from a TCH to a SDCCH. You cannot perform receiver measurements while the mobile station is on the SDCCH, as there is no connected traffic bearer. To indicate that there is not traffic bearer, the text "Traffic bearer unavailable while destination channel is SDCCH" is displayed in red text at the bottom of the front panel as shown in the figure below.

    Internal handovers to the test set's deferred settings always result in a handover to the TCH. If the Destination Channel was set to SDCCH before the deferred handover was executed, the Destination Channel is automatically changed to TCH.

    External handovers, which require two test sets (see Two-Cell Test System ), allow you to configure the Destination Channel, as well as other parameters, that you wish to be assigned to the mobile station once the handover is complete.

    This parameter only affects the test set's operation when the operating mode is set to Active Cell (GSM, GPRS, or EGPRS) , and when the Assignment Channel is set to SDCCH . This parameter cannot be modified during call setup signaling.

    The GPIB command to set this parameter is CALL:TCHannel:SIGNaling:DESTination:CHANnel .

  • SDCCH Subchannel

    This parameter allows you to set the SDCCH Subchannel. The range fore the SDCCH Subchannel depends on the BCH Type setting, see BCH Type and SDCCH Settings for more information.

    NOTE: The Cell Broadcast Channel (CBCH) is transmitted on SDCCH subchannel 2 when Cell Broadcast is enabled. Therefore, an error results and the setting is not applied if you attempt to set the SDCCH subchannel to 2 while Cell Broadcast is enabled.

    This parameter only affects the test set's operation when the operating mode is set to Active Cell (GSM, GPRS, or EGPRS) , and when the Assignment Channel is set to SDCCH . This parameter cannot be modified during call setup signaling.

    The GPIB command to set this parameter is CALL:TCHannel:SIGNaling:(SDCCH|SDCChannel):SUBChannel .

  • SDCCH MS Timing Advance

    This parameter specifies the Timing Advance for the MS to use while on an SDCCH. This parameter only affects the test set's operation when the operating mode is set to Active Cell (GSM, GPRS, or EGPRS) , and when the Assignment Channel is set to SDCCH . This parameter cannot be modified during call setup signaling.

    This is a Frequency Banded Parameter. See Frequency Banded Parameters for more information.

    Note: Since separate parameters must be used to set the MS Timing Advance while on a TCH or SDCCH, it is possible that these parameters do not match. The channel assignment may fail if the MS Timing Advance for these parameters do not correlate when a channel assignment from a TCH to SDCCH (or from an SDCCH to a TCH) occurs.

    The GPIB command to set this parameter is CALL:TCHannel:SIGNaling:(SDCCH|SDCChannel):MS:TADVance[:SELected] .

  • SDCCH MS TX Level

    This parameter specifies the power level for the MS (Mobile Station) to use while on an SDCCH. This parameter only affects the test set's operation when the operating mode is set to Active Cell (GSM, GPRS, or EGPRS) , and when the Assignment Channel is set to SDCCH . This parameter cannot be modified during call setup signaling.

    This is a Frequency Banded Parameter. See Frequency Banded Parameters for more information.

    The GPIB command to set this parameter is CALL:TCHannel:SIGNaling:(SDCCH|SDCChannel):MS:TXLevel[:SELected] .

Operating Considerations

Any changes to the SDCCH parameters result in new channel assignments when the mobile station is assigned to a SDCCH. No new channel assignments are sent to the mobile station when it is assigned to the TCH and changes are made to SDCCH parameters.

Packet data transfer cannot take place while the mobile station is assigned to the SDCCH. If a packet switched session is attempted while the mobile station is on SDCCH, an error is displayed on the test set's front panel.

Related Topics

How Do I Configure the Call Signaling Parameters?


Dual Transfer Mode

Dual Transfer Mode

Last updated: December 9, 2008

This section is only applicable to the lab applications, and to mobile stations that support Dual Transfer Mode operation.

This section details the following:

  • Dual Transfer Mode (DTM) Overview
  • Non-enhanced DTM
  • Enhanced DTM
  • Operating Considerations
  • Configurable Parameters
  • Reported Parameters

Dual Transfer Mode (DTM) Overview

Dual Transfer Mode (DTM) operation is a simultaneous CS (circuit switched) voice call and PS (packet switched) session on the same ARFCN.

See Dual Transfer Mode Concepts for more information.

Receiver Measurements

The GSM Bit Error (BER) measurement or Fast Bit Error (FBER) measurement can be run on a circuit switched timeslot during a dual transfer mode. Likewise, the GPRS BER and Block Error (BLER) measurements can be run simultaneous provided the connection type is set to ETSI Type B (Ack or Unack) or BLER. Other measurements available in DTM are GPRS BLER and the In-Band Frame Error (IFER).

Transmitter Measurements

All transmitter measurements are available during a DTM session. Transmitter measurements are restricted to a maximum of two uplinks. Therefore, transmitter measurements are not available for the 2x3 DTM multislot configuration.

Non-enhanced DTM

Once the Non-enhanced DTM is enabled, the test set allows a DTM session to be established if a CS connection (CS Voice Call) or a PS session has been established first. However, the PS session is aborted if a CS voice call is established while the PS session is active. see DTM Enable .

NOTE
CS data calls are not supported by the test set in conjunction with DTM in the test set.

Scenario 1: CS -> CS + MO PS

In this scenario a voice call (MO or MT) has been established and the MS requests a PS session. A DTM assignment message is used by the test set to request the MS to move the existing TCH to a timeslot specified by DTM Multislot Configuration and DTM CS Timeslot Position . DTM parameters are used to configure the CS voice call and PS session. Some TCH and PDTCH based parameters will have no effect during a DTM session. Once the voice call is dropped, the DTM connection is effectively finished and the TCH and PDTCH will revert to using their own configuration settings as normal.

Scenario 2: CS -> CS + MT PS

Establishing a mobile terminated PS session when a CS connection exists is similar to establishing a mobile originated PS session. The difference is that when establishing a mobile terminated PS session, there is no DTM Request message sent, because the data is sent from the test set.

Scenario 3: PS -> CS + PS

When a PS session exists and a mobile terminated or mobile originated CS voice call is attempted, the test set aborts the PS session before initiating the CS connection. Once the DCCH has been established for the CS voice call, the DUT may request the re-establishment of the packet resources by sending a DTM Request message. When a PS session is re-established, the TCP recovers and resends any lost IP data rather than recover the aborted downlink TBF. DTM parameters are used to configure the CS voice call and PS session. Some TCH and PDTCH based parameters will have no effect during a DTM session. Once the voice call is dropped, the DTM connection is effectively finished and the TCH and PDTCH will revert to using their own configuration settings as normal.

Scenario 4: Handover in a DTM session

Once a DTM session has been established, some Handover Setup parameters become inaccessible and will only become available again upon the release of the CS call. If a handover occurs, the deferred DTM parameters are used to configure the CS + PS session. See Immediate and Deferred Parameters for more information.

Enhanced DTM

The only difference between Non-enhanced DTM and Enhanced DTM is the behavior in the PS <-> PS + CS scenario, Enhanced DTM allows a CS voice call to be established without aborting the PS session, the test set can also delay the release of the CS connection until sufficient Packet System Information messages have been received by the MS so that the PS can be maintained without the presence of the CS connection. see Enhanced DTM Enable .

Operating Considerations

DTM capability is available in the following operating modes: Active Cell (GPRS), Active Cell (EGPRS), GPRS BCH+PDTCH+TCH , and EGPRS BCH + PDTCH + TCH .

DTM capability is available in the following connection types: ETSI Type A, ETSI Type B (Unack), ETSI Type B (Ack), BLER, Auto, and SRB Loopback.

If the mobile station requests a DTM session while on a circuit switched data call, a warning will be generated and the DTM Request will be rejected.

If the mobile station is not capable of DTM operation, it enters GPRS Suspend state after establishing the CS connection, which inhibits the test set from attempting any DTM procedures.

The test set does not support DTM operation while the Destination Channel is set to SDCCH. If a DTM session is in progress and a channel assignment occurs (that is, the Destination Channel and the Assignment Channel settings are changed to SDCCH), the DTM session is aborted prior to applying the change.

The PS data can not be sent on the timeslot used by the CS connection in the test set.

Configurable Parameters

Immediate and Deferred Parameters

Some of the DTM parameters have two styles: Immediate and Deferred. The Immediate DTM parameters are used when an attempt to establish DTM occurs and after DTM is triggered. The related PDTCH parameters revert after the DTM session has been released. This also holds true for some TCH and PDTCH Handover Setup parameters. The deferred DTM parameters are used instead when the handover occurs during a DTM session.

Selection of DTM vs. PDTCH Parameters

The table below shows the various connection transitions and how these transitions affect the DTM trigger status and the parameters selected for channel assignment.

Current Channel Configuration | Destination Channel Configuration | Current DTM Trigger Status | Resultant DTM Trigger Status | Parameters selected for channel assignment
None | * | Not Triggered | Not Triggered | N/A
CS | None | Not Triggered | Not Triggered | N/A
CS | CS | Not Triggered | Not Triggered | N/A
CS | PS | Not Triggered | Not Triggered | PDTCH
CS | CS+PS | Not Triggered | Triggered | DTM
PS | None | Not Triggered | Not Triggered | N/A
PS | CS | Not Triggered | Not Triggered | N/A
PS | PS | Not Triggered | Not Triggered | PDTCH
PS | CS+PS | Not Triggered | Triggered | DTM
CS+PS | None | Triggered | Not Triggered | N/A
CS+PS | CS | Triggered | Triggered | N/A
CS+PS | PS | Triggered | Not Triggered | PDTCH
CS+PS | CS+PS | Triggered | Triggered | DTM

* indicates any Channel Configuration.

  • DTM Enable

    The operating mode must be set to Cell Off in order to change the state of DTM. DTM must be enabled in the test set in order to have simultaneous circuit switched voice and packet switched data connection. see Non-enhanced DTM for more information.

    The command to enable DTM is CALL[:CELL]:DTMode .

  • Enhanced DTM Enable

    The operating mode must be set to Cell Off in order to change the state of Enhanced DTM. Enhanced DTM must be enabled if you do not want to abort the PS session when an attempt to establish a simultaneous CS voice call is made. See Enhanced DTM for more information

    The command to enable DTM is CALL[:CELL]:DTMode:ENHanced .

  • DTM CS Timeslot Position

    This parameter allows you to set the timeslot position to be used within the DTM Multislot Configuration that the CS timeslot occupies. Valid CS timeslot positions vary depending on the selected multislot configuration. Also, the test set allows you to set the deferred timeslot position to be used within the deferred DTM Multislot Configuration that the CS timeslot will occupy following a handover execution. Valid deferred CS timeslot positions vary depending on the selected deferred DTM Multislot Configuration. See DTM Multislot Configuration for more information.

    The command to set the immediate CS timeslot position is CALL:(PDTCH|PDTChannel):DTMode:CSWitched:TSLot . The command to set the deferred CS timeslot position is CALL:SETup:DTMode:CSWitched:TSLot . For instructions on how to manually set the CS timeslot position see Configure DTM CS Timeslot Position .

  • DTM CS Half Rate Sub Channel

    This parameter indicates whether or not the half-rate subchannel is used for the CS connection while DTM is triggered. Note that the value will only have an effect when the current speech channel mode uses a Half Rate TCH channel (i.e. AHS and HS).

    The command to set the immediate CS Half Rate Sub Channel is CALL:(PDTCH|PDTChannel):DTMode:CSWitched:HRSPeech:SCHannel . The command to set the deferred CS Half Rate Sub Channel is CALL:SETup:DTMode:CSWitched:HRSPeech:SCHannel . For instructions on how to manually set the CS Half Rate Sub Channel, see Configure DTM CS Half Rate Sub Channel .

  • DTM Multislot Configuration

    You can set the DTM Multislot Configuration that is used when an attempt to establish DTM occurs and after DTM is triggered.

    When the DTM is enabled, if a CS connection is active and an attempt is made to start a PS session while the multislot configuration for the PS session is DTM Invalid. the DTM attempt is rejected and a warning indicating an invalid DTM multislot configuration is generated.When the Enhanced DTM is enabled, if a PS session is active and an CS connection establishment is attempted whist the multislot configuration for the PS session is DTM Invalid, an encapsulated immediate assignment is sent to the DUT, causing the PS session to abort and the CS connection to establish. A warning is generated indicating an invalid DTM multislot configuration is being used.The PDTCH multislot configuration reverts after the DTM session is released. See Selection of DTM vs. PDTCH Parameters for more information.

    The command to set the immediate DTM Multislot Configuration is CALL:(PDTCH|PDTChannel):DTMode:MSLot:CONFig . The command to set the deferred DTM Multislot Configuration is CALL:SETup:DTMode:MSLot:CONFig . For instructions on how to manually set the DTM Multislot Configuration see Configure DTM Multislot Configuration .

    You are allowed to position timeslots within the TDMA frame as much flexibility as possible. See Flexible Timeslot . To customized the DTM multislot configuration, use the GPIB command CALL:(PDTCH|PDTChannel):DTMode:MSLot:CONFig to set the multislot configuration to `Custom' , then use the GPIB command CALL:(PDTCH|PDTChannel):DTMode:MSLot:CONFig:CUSTom:TSLots to customize the multislot combination as your requirement. Note that all the timeslots in DTM custom multislot configuration must be contiguous.

  • DTM Traffic Band

    The test set allows you to set the destination Band to be used in DTM-based channel assignment (or reassignment). Also, the test set allows you to set the deferred DTM Traffic Band to be used following a handover execution.

    The command to set the immediate DTM Traffic Band is CALL:(PDTCH|PDTChannel):DTMode:BAND . The command to set the deferred DTM Traffic Band is CALL:SETup:DTMode:BAND . For instructions on how to manually set the DTM Traffic Band see Configure DTM Traffic Band .

  • DTM Traffic Channel

    The test set allows you to set the destination Traffic Channel to be used in the DTM-based channel assignment (or reassignment). Also, the test set allows you to set the deferred DTM Traffic Channel to be used following a handover execution.

    The command to set the immediate DTM Traffic Channel is CALL:(PDTCH|PDTChannel):DTMode:ARFCn[:SELected] . The command to set the deferred DTM Traffic Channel is CALL:SETup:DTMode:ARFCn[:SELected] . For instructions on how to manually set the DTM Traffic Channel see Configure DTM Traffic Channel .

  • DTM Frequency Hopping

    The test set allows you to set whether the destination DTM channel assignment (or reassignment) implements frequency hopping or not. Also, the test set allows you to set the deferred DTM Frequency Hopping to be used following a handover execution. The PDTCH MA table is used for DTM Frequency Hopping, indexed by the DTM Band.

    The command to set the immediate DTM Frequency Hopping is CALL:(PDTCH|PDTChannel):DTMode:FHOPping[:STATe] . The command to set the deferred DTM Frequency Hopping is CALL:SETup:DTMode:FHOPping[:STATe] . For instructions on how to manually set the DTM Frequency Hopping see Configure DTM Frequency Hopping .

    The PDTCH Frequency Hopping reverts after the DTM session is released. See Selection of DTM vs. PDTCH Parameters for more information.

  • DTM Coding Schemes

    The test set allows you to set the coding scheme for GPRS to use after the DTM channel assignment (or reassignment). Also, the test set allows you to set the deferred DTM Coding Schemes to be used following a handover execution.

    The command to set the immediate DTM Coding Schemes is CALL:(PDTCH|PDTChannel):DTMode:CSCHeme:UPLink . The command to set the deferred DTM Coding Schemes is CALL:SETup:DTMode:CSCHeme . For instructions on how to manually set the DTM Coding Schemes see Configure DTM Coding Scheme .

    The PDTCH Coding Schemes reverts after the DTM session is released. See Selection of DTM vs. PDTCH Parameters for more information.

  • DTM MS Tx Levels

    When the MS Output Power Selection Mode is selected in either MS TX Lev mode or Alpha Gamma mode, the DTM Parameter and the DTM Handover Setup are changed to either MS TX Lev mode or Alpha Gamma mode followed.

    • MS TX lev

      The test set allows you to set the ordered MS transmit power level for the individual bursts of the DTM session. Also, the test set allows you to set the deferred DTM MS Tx Levels to be used following a handover execution.

      The command to set the immediate DTM MS Tx Levels is CALL:(PDTCH|PDTChannel):DTMode:MS:TXLevel[:SELected]:BURSt<[1]|2|3|4|5> . The command to set the deferred DTM MS Tx Levels is CALL:SETup:DTMode:MS:TXLevel[:SELected]:BURSt<[1]|2|3|4|5> . For instructions on how to manually set the DTM MS Tx Levels see Configure DTM MS Tx Levels .

      The PDTCH MS Tx Levels reverts after the DTM session is released. See Selection of DTM vs. PDTCH Parameters for more information.

    • Alpha and Gamma The test set allows you to set the power control power parameters alpha and gamma for the individual bursts of the DTM session. Also, the test set allows you to set the deferred DTM Gamma and DTM CS Gamma to be used following a handover execution.

      The GPIB command to set the DTM Gamma Burst parameter is CALL:(PDTCH|PDTChannel):DTMode:MS:GAMMa:BURSt<[1]|2|3|4>[:SELected] . The GPIB command to set the Deferred DTM Gamma Burst parameter is CALL:SETup:DTMode:MS:GAMMa:BURSt<[1]|2|3|4>[:SELected] . See MS Output Power for more information.

  • DTM Power Reduction Reference

    The test set allows you to modify the downlink power reduction reference level of the bursts present in the DTM session. Also, the test set allows you to set the deferred DTM Power Reduction Reference to be used following a handover execution.

    The command to set the immediate DTM Power Reduction Reference is CALL:(PDTCH|PDTChannel):DTMode:PZERo:LEVel . The command to set the deferred DTM Power Reduction Reference is CALL:SETup:DTMode:PZERo:LEVel . For instructions on how to manually set the DTM Power Reduction Reference see Configure DTM Power Reduction Reference .

    The PDTCH Power Reduction Reference reverts after the DTM session is released. See Selection of DTM vs. PDTCH Parameters for more information.

  • DTM Measured Burst

    The test set allows you to set the burst to be measured in the DTM session.

    The command to set the DTM Measured Burst is CALL:(PDTCH|PDTChannel):DTMode:MSLot:MEASurement:BURSt . For instructions on how to manually set the DTM Measured Burst see Configure DTM Measured Burst .

    The PDTCH Measured Burst reverts after the DTM session is released. See Selection of DTM vs. PDTCH Parameters for more information.

  • DTM Uplink State Flag

    The test set allows you to modify the assigned uplink state flag for TBF use in the DTM session. Also, the test set allows you to set the deferred DTM Uplink State Flag to be used following a handover execution.

    The command to set the immediate DTM Uplink State Flag is CALL:(PDTCH|PDTChannel):DTMode:USFLag[:ASSigned] . The command to set the deferred DTM Uplink State Flag is CALL:SETup:DTMode:USFLag[:ASSigned] . For instructions on how to manually set the DTM Uplink State Flag see Configure DTM Uplink State Flag .

    The PDTCH Uplink State Flag reverts after the DTM session is released. See Selection of DTM vs. PDTCH Parameters for more information.

  • DTM Manual Unassigned USF

    The test set allows you to modify the manual unassigned uplink state flag value for TBF use in the DTM session.

    The command to set the DTM Manual Unassigned USF is CALL:(PDTCH|PDTChannel):DTMode:USFLag:UNASsigned[:MANual] . For instructions on how to manually set the DTM Manual Unassigned USF see Configure DTM Manual Unassigned USF .

    The PDTCH Manual Unassigned USF reverts after the DTM session is released. See Selection of DTM vs. PDTCH Parameters for more information.

  • Operating Mode

    There are two test mode operating modes that are offered specifically to support DTM in addition to the Active Cell operating mode (serving cell GPRS or EGPRS). See Operating Considerations details.

    The command to set the operating mode is CALL:OPERating:MODE .

Reported Parameters

Additional mobile station parameters are available via GPIB and reported on the Call Setup screen. These parameters consist of the following:

  • DTM Class

    The supported GPRS and EGPRS DTM Class are displayed on the Call Setup screen for the selected cell band, however you may query which GPRS DTM Class the mobile station supports for any of the following bands: PGSM, EGSM, DCS, PCS, RGSM, T-GSM810, GSM450, GSM480, GSM750, GSM850. In addition to which DTM class the mobile station supports for GPRS and EGPRS, the test set also displays if the class reported by the mobile station provides support for half rate DTM operation.

    Note: The test set reports whether or not the mobile station can support half rate operation. However, the test set does not support half rate operation in DTM and so will not establish a half rate DTM connection.

    Supported DTM Multislot Classes

    DTM GPRS/EGPRS Multislot Class

    1

    2

             3

    4

             5

    5

             6

    7

             8

    9

             9 10

    11

             12

    30

    31

    32

    33

    Half-Rate Supported

    No

    Yes

             Yes Yes

    No

    Yes

    Yes

             Yes

    *

    No

    Yes

    Yes

             Yes

    Yes

    Yes

    Yes

             Yes

    Yes

    *DTM GPRS/EGPRS Multislot Class 8 is not used. It is interpreted as Multislot Class 5.

    The command to query the GPRS DTM Class is CALL:MS:REPorted:DTMClass:GPRS[:SELected]? .

    The command to query the EGPRS DTM Class is CALL:MS:REPorted:DTMClass:EGPRs[:SELected]? .

  • Connection Status

    The Connection Status of the CS voice and the packet switched data connection states are simultaneously displayed and updated when DTM is enabled.

    The GPRS Suspended connection status is included in the packet switched state reported by the test set. GPRS Suspended is displayed when a GPRS mobile station suspends packet switched data transfer in order to transfer CS traffic rather than establish a DTM connection. Note: If your existing GPIB code queries the connection status, it must be updated to accept the new GPRS Suspended parameter.

    The command to query the voice connection status is CALL:STATus[:STATe][:VOICe]? . The command to query the data connection status is CALL:STATus[:STATe]:DATA?

Related Topics

Commands Disabled During Dual Transfer Mode Operation

Dual Transfer Mode Concepts

How Do I Set Up and Use the Dual Transfer Mode Feature?

Program to Establish Dual Transfer Mode Operation

Troubleshooting Dual Transfer Mode


Dual Transfer Mode Concepts

Dual Transfer Mode Concepts

Last updated: December 2, 2008

Dual Transfer Mode (DTM) is the simultaneous existence of both a Circuit Switched (CS) connection and a Packet Switched (PS) session. The simultaneous CS and PS connections can be activated on the same ARFCN and frame. The test set offers two test mode operating modes for receiver testing of adjacent timeslots which can use different channel coding and modulation formats -GMSK or 8PSK, in addition to the Active Cell operating modes.

"For DTM, a multislot configuration consists of a single traffic channel and one or more full rate packet data traffic channels together with associated control channels allocated to the same mobile station. This multislot configuration may occupy up to 3 basic physical channels." (3GPP TS 05.02 version 8.10.0 Release 1999)

The PS data can be sent both on the timeslot used by the CS connection and the timeslot(s) not used by the CS connection. The timeslot configurations are restricted so that the timeslots allocated in each direction are contiguous and there is only one timeslot allocated to the CS connection.

The following figure shows an example of a 2x3 (2 uplinks, 3 downlinks) multislot configuration for a class A mobile in DTM.

There are three Layer 3 RR management messages that facilitate DTM operation.

  • DTM Request

    Occurs when a mobile originated message requests the establishment of a PS session.

  • DTM Assignment Command

    Occurs when a mobile terminated message is sent to reconfigure the CS voice session parameters (for example: timeslot, ARFCN, and cell band) and establish uplink and/or PS session.

  • Packet Assignment

    Occurs when a mobile terminated message assigns an uplink and/or downlink PS session without changing the existing CS voice call configuration.

Related Topics

Dual Transfer Mode


Commands Disabled During Dual Transfer Mode Operation

Commands Disabled During Dual Transfer Mode Operation

Last updated: December 2, 2008

The following commands are incompatible during an active Dual Transfer Mode (DTM) session in Active Cell operating mode or while the test set's operating mode is set to either GPRS BCH+TCH+PDTCH or EGPRS BCH+TCH+PDTCH. If any of the these commands are attempted while there is an active DTM session or while the test set is in a DTM test operating mode, they are stored and applied when the test set ends the DTM session or leaves the DTM operating mode.

Parameter | Command
TCH Channel | CALL:TCHannel[:ARFCn][:SELected]
TCH Band | CALL:TCHannel:BAND
TCH Timeslot | CALL:TCHannel:TSLot
TCH Power Level | CALL:TCHannel:PREDuction:LEVel([1]|2)
TCH PRL Used Burst | CALL:TCHannel:PREDuction:BURSt
Deferred TCH Settings | CALL:SETup:TCHannel[:ARFCn][:SELected] CALL:SETup:TCHannel:BAND CALL:SETup:TCHannel:TSLot
Frequency Hopping State | CALL:TCHannel:FHOPping[:STATe]
Frequency Hopping Mobile Allocation (MA) Table Configuration Mode | CALL:TCHannel:MA:TABLe:CONFig:AUTO
Frequency Hopping Mobile Allocation (MA) Table Automatic Configuration | CALL:TCHannel:MA:TABLe[:AUTO]:[SELected]?
Frequency Hopping Mobile Allocation (MA) Table Manual Configuration | CALL:TCHannel:MA:TABLe:MANual:[SELected]
Frequency Hopping Mobile Allocation (MA) Table Points Manual Configuration | CALL:TCHannel:MA:TABLe:MANual:POINts:[SELected]?
Frequency Hopping Mobile Allocation (MA) Table Points Automatic Configuration | CALL:TCHannel:MA:TABLe[:AUTO]:POINts:[SELected]?
Frequency Hopping Mobile Allocation Index Offset (MAIO) | CALL:TCHannel:FHOPping:MAIoffset:[SELected]
Frequency Hopping -Hopping Sequence Number (HSN) | CALL:TCHannel:FHOPping:HSNumber
Frequency Hopping Measurement ARFCN | CALL:TCHannel:MA:MEASurement:ARFCn:(SELected]
PDTCH Continuous Timing Advance State | CALL:(PDTCH|PDTChannel):MS:TADVance:CONTinuous
PDTCH Timing Advance Value | CALL:(PDTCH|PDTChannel):MS:TADVance[:SELected]
PDTCH Multislot configuration | CALL:(PDTCH|PDTChannel):MSLot:CONFig
PDTCH Traffic Band | CALL:(PDTCH|PDTChannel):BAND
PDTCH Traffic Channel | CALL:(PDTCH|PDTChannel)[:ARFCn][:SELected]
PDTCH Frequency Hopping State | CALL:(PDTCH|PDTChannel):FHOPping[:STATe]
PDTCH Coding Scheme (GPRS) | CALL:(PDTCH|PDTChannel):CSCHeme:UPLink
PDTCH DL/UL MCS (EGPRS) | CALL:(PDTCH|PDTChannel):MCSCheme
PDTCH MS TX Level | CALL:(PDTCH|PDTChannel):MS:TXLevel[:SELected]:BURSt<[1]|2|3|4|5>
PDTCH P0 (Power Reduction Reference) | CALL:(PDTCH|PDTChannel):PZERo:LEVel
PDTCH Measured Burst |


Flexible Timeslot

Flexible Timeslot

Last updated: December 9, 2008

This section is only applicable to the GPRS/EGPRS lab applications.

The flexible timeslot function allows you to position timeslots within the TDMA frame as much flexibility as possible. You can use the GPIB command CALL:(PDTCH|PDTChannel):MSLot:CONFig to set the multislot configuration to `Custom' , then use the GPIB command CALL:(PDTCH|PDTChannel):MSLot:CONFig:CUSTom:TSLots to customize the multislot combination as your requirement.

Constrains on Flexible Timeslot Configuration

When using the Flexible Timeslot Multislot Configuration, the following overriding restrictions apply:

  • Any downlink timeslot can be selected except
    • `0' when BCH ARFCN is equal to PDTCH ARFCN
    • `1' when B CH ARFCN is equal to PDTCH ARFCN and PBCCH is ON .
  • As the hardware of the test set can only demodulate up to 6 contiguous timeslots, All uplink timeslots must lie within a 6 timeslot window which cannot not cross the TDMA frame boundaries. For active cell operation the uplink timeslot window must also include all timslots that the mobile uses to transmit on. For example, the timeslots that the PACCH is transmitted on.
  • Timeslot 0 and 7 can not be used simultaneously if frequency hopping is on.
  • If the sum of the downlink and uplink timeslots exceed seven, timing advance must be in the range 32 to 63

How to set the Flexible Timeslot

The following procedure details how to access and configure the Flexible Timeslot Multislot Configuration.

  1. Press CALL SETUP .
  2. Press PDTCH parms ( F9 )
  3. Press the Mor e key on the lower right corner to display the PDTCH parms (2 of 3).
  4. Press Multislot Configuration ( F7 ).
  5. Press Custom Multislot Cfg ( F8 ), Use the knob to turn on/off the downlink and uplink timeslots as you need.
  6. After setting, press Apply Changes ( F5 ) and check the custom timeslot settings on the screen.

Operating Considerations

The flexible timeslot is only available in the following operating modes: Active Cell, GPRS BCH+PDTCH, EGPRS BCH+PDTCH, GPRS BCH+TCH+PDTCH and EGPRS BCH+TCH+PDTCH.

The `Burst to Measure' setting is apply to the relative uplink burst. For example, if uplink timeslots 2 and 5 have active bursts, value `1' of `Burst to Measure' refers to uplink timeslot 2 and value `2' of `Burst to Measure' refers to the uplink timeslot 5

The following measurements do not support non contiguous uplink timeslots:

  • Transmit Power measurement
  • Phase and Frequency Error Measurement
  • Power versus Time Measurement
  • Output RF Spectrum Measurement
  • EGPRS Transmit Power Measurement
  • Modulation Accuracy Measurement.

The following measurements do not support non overlapped timeslots:

  • Transmit Power measurement
  • Phase and Frequency Error Measurement
  • Power versus Time Measurement
  • Output RF Spectrum Measurement
  • IQ Tuning Measurement
  • Dynamic Power Measurement
  • EGPRS Transmit Power Measurement
  • Modulation Accuracy Measurement
  • EGPRS Dynamic Power Measurement.

Related Topics

How Do I Configure the PDTCH Parameters?

Supported Multislot Classes


FM Broadcast

FM Broadcast

Last updated: December 2, 2008

  • Description
  • FM Broadcast Parameters

Description

You can use the test set coupled with the audio measurement features to test the Mobile Station with full range of FM (frequency modulated) Broadcast signals. The FM Broadcast signals are generated by utilizing two RF sources in the test set and an external mixing device (E5520 FM Adaptor).

FM Broadcast test system

The following diagram shows a typical FM Broadcast test system configuration.

The FM Broadcast test system is made up of the test set, FM Adapter and Mobile Station. The FM Adapter connects to the RF OUT ONLY port of the test set directly. The Mobile Station connects to the output of the FM Adapter with RF antenna. To make measurement on the received audio signal, the Mobile Station's demodulated FM output connects to the High AUDIO IN connector of the test set.

When the test set is in CW operating mode and FM broadcast mode, one of the test set's RF sources is fixed at 1 GHz and the other source provides an FM signal from 890 MHz to 990 MHz. The FM Adapter mixes the 1 GHz Local Oscillator signal with the FM signal, then the filters it to provide a stable and accurate resultant signal at the user specified FM broadcast frequency (10 MHz to 110 MHz). The test set also allows you to set parameters such as internal frequency deviation, FM broadcast power and amplitude offset when the test set is in FM Broadcast mode. Once the test set is generating the FM signal and is properly connected to the Mobile Station, the Mobile Station's FM receiver performance is ready to analyzed. A common method of analyzing the FM signal that has been demodulated by the Mobile Station is to connect the Mobile Station's demodulated FM output to the test set's High AUDIO INPUT connector, perform and run the appropriate Audio Analyzer measurements.

NOTE
The FM Broadcast test is only available when the operating mode is set to CW .

FM Broadcast Parameters

RF Output Config

There are two RF generator configuration setting:

  • Normal: This mode is the normal CW operating mode in which the test set generates a CW signal.
  • FM broadcast: In this mode, the test set generates the signals that are sent through the RF OUT ONLY port to the FM Adapter to produce an FM Broadcast signal. The FM Broadcast parameters do not appear on the front panel of the test set and the GPIB command that set the FM Broadcast parameters do not apply until the RF Output Configure parameter is set to this mode.

This parameter only applies when RF Output Configure is set to FM Broadcast.

The GPIB command to set this parameter is CALL[:CELL]:RFGenerator:CONFigure .

FM Broadcast Frequency

This parameter sets the frequency at which the test set broadcasts the FM signal.

This parameter only applies when RF Output Configure is set to FM Broadcast.

The GPIB command to set this parameter is CALL[:CELL]:RFGenerator:FMBRoadcast:FREQuency .

FM Broadcast Power

  • FM Broadcast Power State

    This parameter sets whether the FM Broadcast Power setting is applied.

    This parameter only applies when RF Output Configure is set to FM Broadcast.

    The GPIB command to set this parameter is CALL[:CELL]:RFGenerator:FMBRoadcast:POWer:STATe .

  • FM Broadcast Power

    This parameter sets the power at which the test set broadcasts the FM signal.

    This parameter only applies when RF Output Configure is set to FM Broadcast.

    The GPIB command to set this parameter is CALL[:CELL]:RFGenerator:FMBRoadcast:POWer:AMPLitude .

FM Broadcast Amplitude Offset menu

  • Adapter Conversion Gain

    This parameter sets the loss of the FM Adapter. The test set compensates for the loss by increasing the signal strength at the RF OUT ONLY port.

    This parameter only applies when RF Output Configure is set to FM Broadcast.

    The GPIB command to set this parameter is CALL[:CELL]:RFGenerator:FMBRoadcast:ADAPter:GAIN .

  • Amplitude Offset State

    This parameter sets whether the FM Broadcast mode Amplitude Offset setting is applied.

    This parameter only applies when RF Output Configure is set to FM Broadcast.

    The GPIB command to set this parameter is CALL[:CELL]:RFGenerator:FMBRoadcast:CORRection:STATe .

  • Amplitude Offset

    This parameter sets the FM Broadcast mode Amplitude Offset setting that is applied to the RF OUT ONLY port.

    This parameter only applies when RF Output Configure is set to FM Broadcast.

    The GPIB command to set this parameter is CALL[:CELL]:RFGenerator:FMBRoadcast:CORRection:GAIN .

Internal FM Deviation

  • Internal FM Deviation State

    This parameter sets whether the FM Broadcast mode Internal FM Deviation setting is applied.

    This parameter only applies when RF Output Configure is set to FM Broadcast.

    The GPIB command to set this parameter is CALL[:CELL]:RFGenerator:FMBRoadcast:FM:INTernal:STATe .

  • Internal FM Deviation

    This parameter is used to control the FM Deviation of the internal audio source. The internal audio source is the amount the modulated signal deviates from the carrier frequency.

    This parameter only applies when RF Output Configure is set to FM Broadcast.

    The GPIB command to set this parameter is CALL[:CELL]:RFGenerator:FMBRoadcast:FM:INTernal:DEViation .

Internal FM Frequency

This parameter sets the test set's internal FM frequency. (This is simply the modulation frequency.)

This parameter only applies when RF Output Configure is set to FM Broadcast.

The GPIB command to set this parameter is CALL[:CELL]:RFGenerator:FMBRoadcast:FM:INTernal:FREQuency .

Related Topics

How Do I Make a FM Broadcast test?


Frame Trigger Parameters

Frame Trigger Parameters

Last updated: December 2, 2008

Frame Trigger Parameters

The frame trigger is a positive-going TTL compatible pulse that is one GSM bit wide, it is aligned to the downlink TDMA frame timing. The test set provides a frame trigger for synchronizing other test equipment to a measurement it is available at the rear-panel TRIG OUT connector.

The frame trigger has 3 parameters that the user must set. See CALL:TRIGger .

  • External Trigger State (on or off)
  • External Trigger Timeslot (0 to 7)
  • External Trigger Symbol (0 to 1250)

External Trigger State (on or off)

The External Trigger State parameter turns the external frame trigger on and off. See CALL:TRIGger[:OUTPut]:FRAMe:STATe for command information.

External Trigger Timeslot (0 to 7)

The External Trigger Timeslot parameter causes the external frame trigger pulses to align with the timeslot you specify. See CALL:TRIGger[:OUTPut]:FRAMe:TSLot for command information.

External Trigger Symbol (0 to 1250)

The External Trigger Symbol parameter causes the external frame trigger pulses to occur a user specified number of bits after bit 0 of the selected timeslot. See CALL:TRIGger[:OUTPut]:FRAMe:SYMBol for command information.

Operating Considerations

Each frame is made up of 8 time slots. Time slots are defined in "ETSI GSM 05.10 Ver. 4.9.0 Section 5. Time slots 0 and 4 are 157 bit periods long, time slots 1, 2, 3, 5, 6, 7 are 156 bit periods long, the average time slot is 156.25 bits in duration. The external trigger timeslot can be set to any time slot 0 through 7, the external trigger bit position can be set from 0 through 1250. If the trigger bit position is set to 1250, that is one full frame beyond the setting of the external trigger timeslot, (156.25 * 8 = 1250).

When the cell activated state is OFF, the frame trigger output is disabled (set to 0 volts) since there is no reference downlink TDMA frame structure available. However, the frame trigger state command ( CALL:TRIGger[:OUTPut]:FRAMe:STATe ) is not affected when there are changes to cell activated state.

The frame trigger can be set manually from the CALL SETUP screen by pressing the Cell Info softkey, then External Trigger Setup soft key.

Related Topics

CALL:TRIGger


Global Position System

Global Position System

Last updated: December 2, 2008

This section is only applicable to the lab applications.

  • Description
  • GPS Parameters
  • How Do I Set up the GPS Feature?
  • Related Topics

Description

The GLOBAL POSITIONING SYSTEM (GPS) function allows you to generate GPS signals to calibrate the GPS receiver of the mobile.

GPS system employs 37 satellites in orbit to provide positioning services. Satellite GPS signal has 3 components: L1 (1575.42MHz) / L2 (1227.60MHz) carrier signals, ranging codes and navigation message. Two kinds of ranging codes are defined: coarse/acquisition (C/A) code for normal positioning and precision (P) code for finer positioning purpose. The L1 is used to carry the C/A code with 1.023Mcps spreading rate, while L2 is usually used to carry the P code with 10.23Mcps spreading rate. For each satellite, a unique Space Vehicle Identifier (SV-ID) is assigned and will be used to determine the phase of spreading code for this specific satellite. The navigation messages usually contain positioning parameters.

Normally P code and L2 are only designed for military use, so the test set only simulates single satellite signal containing C/A code carried by L1 with default navigation messages, and pseudo random sequence data for the calibration of GPS receivers.

NOTE
The GPS feature is only available in the CW operating mode.

GPS Info

The following diagram shows the GPS parameter information.

  • GPS RF Generator Frequency:

    Since the test set only simulates single satellite signal containing C/A code carried by L1, the frequency is fixed at 1575.42MHz. It's a non-configurable parameter.

  • GPS Power:

    This parameter defines the cell power of GPS signal. The power range of GPS signal is -125dBm to -70dBm.

    NOTE
    The power range that you can set on the test set is affected when there is an Amplitude Offset.

  • GPS Satellite ID (SV ID):

    This setting defines which satellite is generating the GPS signal.

  • GPS Navigation Message Type:

    This setting defines the actual navigation message that will be transmitted on GPS frame. If Default Navigation is selected, the GPS frames is filled with the default navigation message defined in the GPS standard. If Raw is selected, the GPS frames is filled with PN sequence.

  • GPS Raw Payload Pattern:

    This setting defines the data type that will be transmitted on GPS frames when Raw data payload is selected. You can select PN9 or PN15.

  • GPS Baseband Filter Type:

    This setting defines the filter that will be used to filter the GPS baseband signal when the GPS signal is generated. A Gaussian or Rectangle filter with 10 MHz bandwidth is supported in this feature.

GPS Parameters

The following table lists all the configurable GPS parameters.

Parameter | GPIB Command
RF Gen Configure | CALL[:CELL]:RFGenerator:CONFigure
GPS Power | CALL[:CELL]:RFGenerator:GPS:POWer:AMPLitude
GPS Power State | CALL[:CELL]:RFGenerator:GPS:POWer:STATe
GPS Power & State | CALL[:CELL]:RFGenerator:GPS:POWer[:SAMPLitude]
GPS Satellite ID (SV ID) | CALL[:CELL]:RFGenerator:GPS:SVID
GPS Navigation Message Type | CALL[:CELL]:RFGenerator:GPS:NMESsage
GPS Raw Payload Pattern | CALL[:CELL]:RFGenerator:GPS:RAW:PPATtern
GPS Baseband Filter Type | CALL[:CELL]:RFGenerator:GPS:BFILter
GPS RF Generator Frequency | CALL[:CELL]:RFGenerator:GPS:FREQuency
GPS RF Generator Frequency 2 | CALL[:CELL]:RFGenerator:GPS:FREQuency2

How Do I Set up the GPS Feature?

The following procedure details how to access the GPS feature.

  1. Press the CALL SETUP key.
  2. Press Operating Mode ( F1 ) and select CW .
  3. Press RF Gen Configure ( F10 ) from the Control Parms menu, then select GPS menu.
  4. Press GPS Parameters ( F9 ), Use the knob to highlight the parameter and change the value.

Related Topics

CW


Handover Control

Handover Control

Last updated: December 2, 2008

  • Network Assisted Cell Change (NACC) Handover Procedure
  • PS Handover Procedure
  • Frame Synchronization
  • Synchronized Handovers
  • Handover Control Parameters
  • Handover Parameters

Network Assisted Cell Change (NACC) Handover Procedure

The NACC Handover procedure provides enhancements to the standard handover mechanism, whereby the DUT (supporting the NACC Handover procedures) may perform the exchange of the destination cell's SI messages on the source cell prior to performing the actual handover to the destination cell. This allows the required destination cell's SI content to be available to the DUT much sooner than the case whereby it must acquire from the BCH of the destination cell.

You can enable the NACC Handover procedure by setting NACC Completion message, Cell Change Notification GSM State and Cell Change Notification 3G state parameters. the Packet Neighbor Cell Data and PMO Forces NC2 State parameters also affect the NACC Handover procedure. See Handover Control Parameters for more information.

The NACC Handover procedure is only applicable in the Active Cell operating modes. The NACC Handover procedure is supported in all the connection types except SRB loopback.

PS Handover Procedure

The PS Handover adds the capability for a handover of a DUT in the Packet Transfer state to essentially maintain packet resources as part of the handover procedure. Therefore the PS Handover procedure obviates the need to perform resource re-establishment on the BCH of the destination cell before packet transfer can continue following the handover.

You can enable the PS Handover procedure by setting the PS Handover State. The Packet Neighbor Cell Data and PMO Forces NC2 State parameters also affect the PS Handover procedure. See Handover Control Parameters for more information.

In general, a network which supports PS Handover functionality shall also support Packet Flow Context (PFC) procedures. Therefore, if PFC procedures are disabled, the configuration of the PS Handover functionality is also disabled. See Cell Operation for more information.

PS Handover functionality is only applicable when there is an external device connection present between the source and destination cells associated with the procedure.

Access to the PS Handover State parameter can be obtained by selecting Handover Parameters ( F10 ), Ext Handover Setup ( F10 ). Note that the external handover menu is only available if the test set currently have an External Device Connection .

The PS Handover procedure in only applicable in the Active Cell operating modes and in the Auto connection type.

Frame Synchronization

To perform anything other than a non-synchronized handover the frame structures in the two-cell test system have to be synchronized. The Frame Synchronization allows the slave test set to synchronize to the BCH of the master in the two cell test system with a given offset of bit positions (Bit Offset) and frame number (Frame Number Offset). You can also set the Power Correction Gain by which the power level that the master is instructed to output is decreased to compensate for gains in the RF path between the master and slave.

The terminology "slave" and "master" are used to refer to the test sets involved in synchronization. The test set at which the synchronization process is initiated is the slave and it adjusts its frame structure to align with the other unit which is the master. Only the slave is aware that the two frame structures are aligned.

The frame synchronization feature requires the following connections to be present between the slave and master units:

  • Both units must use a common 10 MHz reference clock to ensure that the frame structures remain synchronized after the synchronization process has completed. Either the 10 MHz clock output from one unit must be connected to the 10 MHz clock input of the other, or both units must use a common 10 MHz clock from a source external to both of them.
  • Both units must be connected to a common LAN and have established connection using the External Device Connection control on the System Config screen (2 of 2) .
  • There must be an RF connection between the two units capable of delivering -30 dBm to the slave unit from the master since the synchronization is done by the slave instrument demodulating the BCH of the master to align its frame structure using the SCH.
Of the above connections only the 10 MHz clock one must be maintained continuously after the synchronization process has completed.

To start Frame Synchronization, you should first send the Frame Synchronization event. The Frame Synchronization event causes the slave to align its BCH frame structure with the master's. The procedure has two phases, in the first phase the frame of the slave unit is shortened by 2 bit periods until the starting points of the frames are aligned, in the second phase a single extended frame is created to accommodate the Frame Synchronization Offset. Positive values of Frame Synch Offset cause the frame structure of the slave unit to lead the frame structure of the master by that number of bit periods. Positive values of Frame Number Offset cause the frame number of the slave unit's aligned frame to be greater than that of the master unit (modulo 2715648).

See Frame Synchronization Setup for more information about how to set the Frame Synchronization parameters.

Synchronized Handovers

The handover type that can be implemented using the two-cell architecture include:

  • Non-synchronized handover
  • Synchronized handover
  • Pre-synchronized handover
  • Pseudo-synchronized handover
These handovers all make use of the HANDOVER_COMMAND but they provide different Information Elements within it. The Synchronization Indication may be omitted or included to inform the mobile of the type of handover. If the type of handover is pre-synchronized a Timing Advance IE is included. If the handover type is pseudo-synchronized the Time Difference (Report Observed Time Difference) IE is included.

The Synchronized Handover feature requires the following connections to be present between the slave and the master units:

  • The common 10 MHz clock connection required to maintain frame synchronization (see 3.4.1).
  • The common LAN connection (see 3.4.1).

See External Handover Setup for more information about how to set the Synchronized Handover parameters.

Handover Control Parameters

Parameter | GPIB Command
Packet Timeslot Reconfigure | CALL:(PDTCH|PDTChannel):PMESsage:PTReconfig
Packet Power Timing Advance | CALL:(PDTCH|PDTChannel):PMESsage:PPTadvance
Packet Neighbor Cell Data | CALL:(PDTCH|PDTChannel):PMESsage:PNCData[:STATe]
PMO Forces NC2 State | CALL:(PDTCH|PDTChannel):PMESsage:(PMORder|PMO):NC2[:STATe]
NACC Completion Message | CALL:(PDTCH|PDTChannel):PMESsage:NACChange:COMPletion

The following procedure details how to set the Handover Control parameter.

  1. Press the CALL SETUP screen key.
  2. Press the left More key until screen 2 of 3 is displayed.
  3. Press Protocol Control ( F4 )
  4. Press RLC/MAC ( F2 )
  5. Press Handover Control ( F3 ) and the Handover Control menu appears in the center of the screen.
  6. Use the knob to highlight and set the Handover Control Parameters.

Note the PS Handover State parameter is not located in the Handover Control menu. See PS Handover Procedure for details on how to set the PS Handover State.

NOTE
The Rel 6 PS Data handover has not been fully tested.

Packet Timeslot Reconfigure

Control over the Packet Timeslot Reconfigure message and the Packet Power Timing Advance message provides you with power control settings for mobiles that do not fully support the Packet Timeslot Reconfigure (PTR) message.

You can configure the test set to send a Packet Timeslot Reconfigure (PTR) message to the mobile for reconfiguring PDTCH parameters.

When you configure the PTR message to be used, the test set sends a PTR message to the mobile when applying deferred or immediate PDTCH parameters to an active data connection (that is, data connection status is Transferring).

When you configure the test set to not use the PTR message, the test set sends an alternative message to the mobile instead of a PTR message. The alternative message that is sent to the mobile depends on the type of data connection (set using CALL:FUNCtion:CONNection:TYPE ):

  • If the data connection type is BLER a Packet Downlink Assignment (PDA) message is sent.
  • If the data connection type is ETSI Type A a Packet Uplink Assignment (PUA) message is sent.
  • If the data connection type is ETSI Type B, both PDA and PUA messages are sent.

If you change the PTR state while the data connection status is Transferring, any changes you make will take effect immediately during the current data connection.

Packet Power Timing Advance

You can configure whether or not the test set sends a Packet Power Timing Advance (PPTA) message to the mobile when applying deferred or immediate PDTCH parameters to an active data connection (that is, data connection status is Transferring).

Handover Parameters

Then Handover Parameters include the Frame Synchronization Setup parameters, the External Handover Setup parameters and the Synchronized Handover Information and Reports parameters.

Frame Synchronization Setup

Access to the Frame Synchronization Setup menu can be obtained by selecting Handover Parameters ( F10 ), Ext Handover Setup ( F11 ). This key also brings up a Frame Synch Execute ( F5 ) execution key. Note that the Frame Synchronization Setup menu is only available if the test set currently have an External Device Connection .

Parameter | GPIB Command
Synchronize Frames | CALL:HANDover|HANDoff:FSYNchronize[:IMMediate]
Bit Offset | CALL:HANDover|HANDoff:FSYNchronize:OFFSet:BIT
Frame Number Offset | CALL:HANDover|HANDoff:FSYNchronize:OFFSet:FNUMber
Power Correction Gain | CALL:HANDover|HANDoff:FSYNchronize:POWer:CORRection:GAIN

External Handover Setup

Access to the External Handover Setup menu can be obtained by selecting Handover Parameters ( F10 ), Ext Handover Setup ( F10 ). Note that the external handover setup menu is only available if the test set currently have an External Device Connection .

Parameter | GPIB Command
PS Handover State | CALL:HANDover|HANDoff:EXTernal:PSWitched[:STATe]
Synchronization Indication | CALL:HANDover|HANDoff:EXTernal:SYNChronize:INDication[:STATe]
Handover Type | CALL:HANDover|HANDoff:EXTernal:SYNChronize:TYPE
Report Observed Time Difference (ROT) | CALL:HANDover|HANDoff:EXTernal:SYNChronize:ROT[:STATe]
Normal Cell Indication (NCI) | CALL:HANDover|HANDoff:EXTernal:SYNChronize:NCI[:STATe]
Timing Advance | CALL:HANDover|HANDoff:EXTernal:SYNChronize:TADVance[:STATe]

Synchronized Handover Information and Reports

Access to the Synchronized Handover Information and Reports can be obtained by pressing Call Setup and then the left more key until 3 of 4 of the Control menu is displayed, pressing Handover Info & Reports ( F4 ).

Parameter | GPIB Command
Frame Synchronization Status | CALL:HANDover|HANDoff:EXTernal:INFormation:FSYNch:STATus?
Mobile Observed Time Difference | CALL:HANDover|HANDoff:EXTernal:INFormation:OTDifference?

Related Topics

Two-Cell Test System

Cell Operation

CALL:(PDTCH|PDTChannel)

CALL:CCNactive

CALL:HANDover|HANDoff


Handover Parameters

Handover Parameters

Last updated: December 2, 2008

  • Frame Synchronization Setup
  • PS Handover Procedure
  • Handover Control Parameters

Frame Synchronization Setup

The frame synchronization feature requires the following connections to be present between the slave and master units:

  • Both units must use a common 10 MHz reference clock to ensure that the frame structures remain synchronized after the synchronization process has completed. Either the 10 MHz clock output from one unit must be connected to the 10 MHz clock input of the other, or both units must use a common 10 MHz clock from a source external to both of them.
  • Both units must be connected to a common LAN and have established connection using the "External Device Connection" control on the "System Config" screen (2 of 2).
  • There must be an RF connection between the two units capable of delivering -30 dBm to the slave unit from the master since the synchronization is done by the slave instrument demodulating the BCH of the master to align its frame structure using the SCH.
Of the above connections only the 10 MHz clock one must be maintained continuously after the synchronization process has completed.

Synchronized Handovers

This is a generic term to cover several different forms of handover:

  • Non-synchronized handover
  • Synchronized handover
  • Pre-synchronized handover
  • Pseudo-synchronized handover
These handovers will be implemented using the two-box architecture to handover from cell A to cell B, where cell A is the "slave" unit whose frame structure is synchronized to the "master" unit which provides cell B, the destination cell.These handovers all make use of the HANDOVER_COMMAND but they provide different Information Elements within it. The Synchronization Indication may be omitted or included to inform the mobile of the type of handover. If the type of handover is pre-synchronized a Timing Advance IE may be included. If the handover type is pseudo-synchronized the Time Difference IE is included.

The Synchronized Handover feature requires the following connections to be present between the slave and the master units:

  • The common 10 MHz clock connection required to maintain frame synchronization (see 3.4.1).
  • The common LAN connection (see 3.4.1).

Related Topics

Two-Cell Test System

Cell Operation

CALL:(PDTCH|PDTChannel)

CALL:CCNactive

CALL:HANDover|HANDoff


Logical Link Control (LLC) Layer Configurable Parameters

Logical Link Control (LLC) Layer Configurable Parameters

Last updated: December 2, 2008

This section is only applicable to GPRS/EGPRS.

There are two parameters associated with the Logical Link Control (LLC) protocol layer that you can modify. These parameters are:

  • BLER Frame Check Sequence
  • Payload Patterns
  • Payload Pattern Data Options

BLER Frame Check Sequence

The BLER Frame Check Sequence parameter allows you to force the Logical Link Control (LLC) Frame Check Sequence (FCS) to be corrupted when establishing a BLER mode data connection. When the parameter is set to CORRupt, the test set transmits an invalid FCS to the mobile station. This setting may enable some mobiles to establish a BLER mode data connection which would not otherwise be possible with a valid FCS.

Setting this parameter to VALid ensures that the cyclic redundancy check code within the FCS is valid.

This parameter is only applicable when the data connection type is set to BLER using CALL:FUNCtion:CONNection:TYPE BLER.

If you change this parameter while the data connection type is any type other than BLER, the setting has no effect until a new BLER mode data connection is established.

This command along with CALL:FUNCtion:DATA:BLER:POLLing:INTerval and CALL:FUNCtion:DATA:FRAMe:STARt provide you with additional control over BLER data connection type settings. This may enable the test set to establish a BLER mode data connection with mobile stations which cannot connect under normal conditions.

Payload Patterns

There are two parameters that allow you to specify the type of downlink payload pattern to be sent to the mobile station.

  • Payload Pattern (BLER)

    The Payload Pattern (BLER) setting allows you to specify the type of downlink payload pattern to be sent to the mobile station when the connection type is set to BLER (see CALL:FUNCtion:CONNection:TYPE ), the operating mode is set to Active Cell, with the Serving Cell set to GPRS or EGPRS, and the Logical Link Control (LLC) Frame Check Sequence (FCS) parameter is set to CORRupt (see CALL:FUNCtion:DATA:BLER:LLC:FCSequence ). See Payload Pattern Data Options for a list of your choices for Payload Pattern data.

    NOTE
    If the Payload Pattern (BLER) is set to any value other than GMMinfo , and you want to change the setting of the LLC Frame Check Sequence parameter from CORRupt to VALid, it is strongly recommended that you end the data connection before making this change. After the LLC Frame Check Sequence parameter has been set to VALid, the data connection can be restarted using CALL:FUNCtion:DATA:START .

  • Payload Pattern (OTHER)

    The Payload Pattern (OTHER) setting allows you to specify the type of downlink payload pattern to be sent to the mobile station when the operating mode is set to GPRS BCH+PDTCH of EGPRS BCH+PDTCH, or when the operating mode is set to Active Cell (Serving Cell GPRS or EGPRS) and the connection type is ETSI Type B or SRB loopback. See Payload Pattern Data Options for a list of your choices for Payload Pattern data.

  • Multi Source Payload Pattern (OTHER)

    Multi Source Payload Pattern (OTHER) setting allows you to specify the type of each of downlink burst payload pattern to be sent to the mobile station when the operating mode is set to EGPRS BCH+PDTCH and the EGPRS Test Mode Payload Mapping is set to Multi Source, ClearCoded.See Payload Pattern Data Options for a list of your choices for Payload Pattern data.

Payload Pattern Data Options

  • GMMinfo

    This option is only applicable to Payload Pattern (BLER) . The payload pattern is set to send GMM Information messages. When using Payload Pattern (BLER) , if the BLER FCS ( CALL:FUNCtion:DATA:BLER:LLC:FCSequence ) is set to VALid, this type of payload pattern is always sent regardless of the setting of this command.

  • ZEROs

    The payload pattern is set to all zeros.

  • ONES

    The payload pattern is set to all ones.

  • ABIT

    The payload pattern is set to alternate bits.

  • APAIRs

    The payload pattern is set to Alternate Pairs.

  • AQUads

    The payload pattern is set to Alternate Quads.

  • PRBS15

    The payload pattern is set to pseudo-random binary sequence 15 data.

  • PRBS9

    The payload pattern is set to pseudo-random binary sequence 9 data.

  • FIXED2B

    The payload pattern is set to Fixed 2B Hexadecimal data.

  • CUSTOM

    You may set the values for the custom payload pattern that is repeated in each Radio Link Control (RLC) data block or use the default pseudo random bit sequence (PRBS) custom data pattern. The size of the custom payload pattern can be 1 to 174 octets, since the maximum size of the RLC data block that is transmitted using 8PSK clearcoded (no coding scheme is used in transmission) is 174 octets. The custom payload pattern is applied across the GSM, GPRS, and EGPRS formats. That is, the same custom payload pattern is used for the custom GSM downlink Speech , Payload Pattern (BLER) , Payload Pattern (OTHER) and GPRS/EGPRS downlink Multi Source Payload Pattern (OTHER) .

    If you specify a custom payload pattern that is longer than the length of the RLC data block, the portion of custom payload pattern is truncated to the length of the RLC data block and the end data is disregarded. If the custom payload pattern is shorter than the length of the RLC data block, the custom payload pattern is repeated as many times as necessary to fill the RLC data block.

    There is no access through the front panel to configure the custom payload pattern. The GPIB command to configure the Custom pattern is CALL:(PDTCH|PDTChannel):CUSTom:DATA .

    The query for this commands returns only the defined custom payload pattern rather than the repeated or truncated pattern used to fit to the size of the data frame.

    PRBS9 is available when the operating mode is set to any operating mode except for GSM BCH, GPRS BCH, EGPRS BCH, Cell Off and CW.

Related Topics

Protocol Control


Mobile Calculate BER Test

Mobile Calculate BER Test

Last updated: December 2, 2008

  • Description
    • Clearcoded payload on TCH
    • ClearCoded payload on EGPRS PDTCH
    • ClearCoded payload vs. 8PSK ClearCoded
  • Configurable Parameters
  • Operating Considerations

Description

This test set provides the ability that allows Mobile Station to calculate the BER when the test set transmits downlink ClearCoded payload pattern to the Mobile Station. The following diagram shows a typical test configuration.

Clearcoded payload on TCH

During Mobile Calculate BER test, the test set generates a downlink TCH at a known level with data using the clearcoded pattern you specify. Clearcoded speech is transmitted on full rate (including enhanced full rate) TCH channel and the speech source is PRBS9, PRB15 or Custom. Through the following two diagrams, you can differentiate the Clearcoded payload transmission and a normal transmission on a full rate TCH channel.

Channel coding and interleaving for full rate TCH

Channel coding and interleaving for full rate TCH

Figure 1 illustrates how channel coding and interleaving is applied at full rate on TCH channel. GSM uses a voice coder to generate 260-bit voice frame on TCH channel. The 260-bit are added with error-correction bits in GSM codec which acts as a channel coder. As a result, the 456 bits of speech data are sliced up into 8 blocks of 57-bit for each of them. Each TCH frame carries two 57-bit blocks of data from two different 456-bit speech segments. The remaining 2 bits are used for stealing bits (SB). Figure 2 illustrate an example how ClearCoded payload bits are directly filled onto TCH bursts. The two 57-bit fields are filled with information bits without channel coding and interleaving. The training sequence bits, tail bits and guard bits are not shown. The following table lists the difference between normal transmission over full rate TCH channel and ClearCoded payload over full rate TCH channel.

The difference between Normal transmission and ClearCoded payload
 | Normal transmission | ClearCoded payload
Number of bits before channel coding per burst | 65 bits | 114bits
Channel Coding | Yes | No
Interleaving | Yes | No

ClearCoded payload on EGPRS PDTCH

During Mobile Calculate BER test, the test set generate a downlink EGPRS PDTCH at a known level with data using the clearcoded pattern you specify. (See Payload Patterns ). The ClearCoded information bits are directly applied to the specific bit positions which are determined by the modulation and coding scheme selected.

  • MCS 1-4

    Since the USF, header and data are interleaved together in MCS1-4, it is impossible to delimit the field for data bit, USF and header when they are interleaved together. Hence, 114 raw data bits sourced from the data generator are directly applied to the burst bits [0,56] and[59,115].

    • e(B, j) and e(B,59+j) = i(B,57+j) for j=0,1,...,56
    • e(B, 57) = hl(B) and e(B,58) = hu(B)

    The two bits labeled hl(B) and hu(B) on burst number B are flags used for indication of control signaling.

  • MCS 5/6

    In MSC5 and MCS6, 312 data bits are available in each burst for ClearCoded payload bits. The remaining 36 bits are used for USF, header and SB which is coding scheme identification. The mapping is

    • e(B, j) = di (312B+j) for j=0,1,...,155
    • e(B, j) = di (312B+j-36) for j=192,193,...,347

    Where B represents the burst number, di(k) are the ClearCoded payload bits. The ClearCoded payload is applied directly to bits [0,155] and [192,347] of the burst. The bit swapping and channel coding is not performed. But for the filed of SB, USF and header, the channel coding and interleaving is still needed.

    The following diagram illustrates the e(B,j) bits for burst number B. The test set applies the 312 ClearCoded payload bits to the 2 block of 156 data bits. The next burst contains the next 312 bits of the ClearCoded payload sources, and so on.

    Channel coding and interleaving for full rate TCH
  • MSC 7/8/9

    MCS 7/8/9 is nearly identical to MCS 5/6, only 306 data bits are available per burst for ClearCoded payload. The mapping and diagram below illustrate this.

    • e(B, j) = di (306B+j) for j=0,1,...,152
    • e(B, j) = di (306B+j-42) for j=195,193,...,347

    Where B represents the burst number, di(k) are the ClearCoded payload bits. But for the field of SB, USF and header, the channel coding and interleaving are still needed.

    Channel coding and interleaving for full rate TCH

    The test box applies the 312 source ClearCoded payload bits to the 2 blocks of 156 data bits. The next burst contains the next 312 bits of the ClearCoded payload sources and so on.

ClearCoded payload vs. 8PSK ClearCoded

ClearCoded payload is different from the existing 8PSK ClearCoded. 8 PSK ClearCoded is only applicable for 8PSK bursts. When 8PSK ClearCoded is applied, the ClearCoded payload bits are applied to the whole 348 bits per burst including the fields for stealing bits(SB), USF, header and data in normal data transmission. But the ClearCoded payload is applicable for both GMSK and 8PSK bursts. When ClearCoded payload for 8PSK bursts with a selected modulation and coding scheme (MCS) from MCS1 to MCS9, only data field is filled with ClearCoded payload, the other fields such as SB, USF and header are still filled with encoded data. However, only if 8PSK ClearCoded is enabled, the ClearCoded payload is applied to the whole bits of a burst regardless of whether ClearCoded payload is enabled.

 | Burst | Applied fields
8PSK ClearCoded | 8 PSK burst only | The whole burst
ClearCoded payload | GMSK and 8PSK burst | Only data fields

Configurable Parameters

Mobile Calculate BER test has the following configurable parameters:

TCH ClearCoded State

This parameter allows you to enable ClearCoded speech on TCH. This parameter only affects the test set's operation when the operating mode is set to GSM BCH+TCH, the channel mode for TCH is set to FR Speech or EFR Speech and the TCH speech source is set to PRBS 9, PRBS 15 or Custom. This parameter is not available in GPRS BCH+PDTCH+TCH. This is because the header and data of a RLC/MAC block are interleaved and clearcoded payload become impossible.

The GPIB command to set this parameter is CALL:TCHannel:CLEarcoded:STATe .

Multi Source Payload Pattern for downlink Burst [n]

This parameter allows you to set the payload pattern for each of the downlink burst which is configured independently. This parameter only affects the test set's operation when the operating mode is set to EGPRS BCH+PDTCH test mode and when EGPRS Test Mode Payload Mapping is Multi Source, ClearCoded. See Payload Patterns for more information.

The GPIB command to set this parameter is CALL:FUNCtion:DATA:PAYLoad:PATTern[:OTHer]:MSOurce:BURSt<n> .

EGPRS Test Mode Payload Mapping

This parameter allows you to enable the ClearCoded payload and set the payload mapping scheme. One of the following is selected as the payload mapping scheme used for EGPRS BCH+PDTCH test mode.

  • Single Source, Normal: ClearCoded payload is disabled and the payload from the same data source spreads over all the downlink PDTCH channels. The modulation and coding scheme is determined by MCS/PS setting.
  • Single Source, ClearCoded: ClearCoded payload is enabled and the payload from the same data source spreads over all the downlink PDTCH channels. The payload is directly applied to the bursts of PDTCH channel without channel coding and interleaving. If "8PSK Clearcoded" is selected in MCS/PS setting, the payload spreads over the whole burst including the headers, SB and USF fields. Otherwise, they are coded an interleaved only when the payload is Clearcoded.
  • Multi Source, ClearCoded: ClearCoded payload is enabled and the payload for each of the downlink PDTCH channels is independently generated. The payload is directly applied to the bursts of PDTCH channel without channel coding and interleaving. If "8PSK Clearcoded" is selected in MCS/PS setting, the payload is filled into the whole burst including the headers, SB and USF fields. Otherwise, they are coded an interleaved only when the payload is Clearcoded.

The GPIB command to set this parameter is CALL:(PDTCH|PDTChannel):EGPRS:MAPPing .

TCH Speech Source

This parameter allows you to set the speech data configuration that is transmitted on the downlink TCH. This is a TCH parameter, see Speech for more information.

The GPIB command to set this parameter is CALL:TCHannel:DOWNlink:SPEech .

PDTCH Payload Pattern (Other)

This parameter allows you to set the type of downlink payload pattern to be used when the test set's operating mode is set to a valid connection type. This is a Logical Link Control (LLC) Layer parameter, see Payload Patterns for more information.

The GPIB command to set this parameter is CALL:FUNCtion:DATA:PAYLoad:PATTern[:OTHer] .

PDTCH Payload Pattern BLER

This parameter allows you to set the type of downlink payload pattern to be used when the test set's operating mode is set to BLER in Active Cell operating mode, and the LLC Frame Check Sequence parameter is set to CORRupt . This is a Logical Link Control (LLC) Layer parameter, see Payload Patterns for more information.

The GPIB command to set this parameter is CALL:FUNCtion:DATA:PAYLoad:PATTern:BLER .

Operating Considerations

The ClearCoded payload are available when the operating mode is set to GSM BCH+TCH, EGPRS BCH+PDTCH.

Related Topics

How Do I use Mobile Calculate BER Test

Logical Link Control (LLC) Layer Configurable Parameters

Configuring the Traffic Channel (TCH) Parameters

CALL:FUNCtion

CALL:TCHannel

CALL:(PDTCH|PDTChannel)


Configuring Mobile Station Operating Parameters

Configuring Mobile Station Operating Parameters

Last updated: December 2, 2008

The mobile station operating parameters are configured using the following call processing subsystem commands.

For a complete list of GPIB commands in the call processing subsystem, refer to CALL Subsystem .

GSM Mobile Station Operating Parameters

Parameter | GPIB Command
IMSI Attach Flag State | CALL:IATTach
Maximum Control Channel Power | CALL[:CELL]:MS:TXLevel:CCHannel[:SELected]
Defines an additional offset value used to increase the Max CCHannel value for DCS band only | CALL[:CELL]:MS:CCHannel:POWer:OFFSet:DCS
Mobile DTX State | CALL:MS:DTX[:STATe]
Mobile station TX Level | CALL:MS:TXLevel[:SELected]
Timing Advance | CALL:MS:TADVance[:SELected]

GPRS and EGPRS Mobile Station Operating Parameters

Parameter | GPIB Command
Deferred Uplink Burst TX Level for selected band | CALL:SETup:(PDTCH|PDTChannel):MS:TXLevel[:SELected]:BURSt<[1]|2|3|4|5>
Guard Band Period Length | CALL:MS:TX:BURSt:GPLength
Maximum Control Channel Power | CALL[:CELL]:MS:TXLevel:CCHannel[:SELected]
Defines an additional offset value used to increase the Max CCHannel value for DCS band only | CALL[:CELL]:MS:CCHannel:POWer:OFFSet:DCS
Persistent Attach | CALL:MS:PATTach[:STATe]
Uplink Burst TX Level for DCS band | CALL:(PDTCH|PDTChannel):MS:TXLevel[:SELected]:BURSt<[1]|2|3|4|5>
Uplink Burst TX Level for EGSM band | CALL:(PDTCH|PDTChannel):MS:TXLevel[:SELected]:BURSt<[1]|2|3|4|5>
Uplink Burst TX Level for PCS band | CALL:(PDTCH|PDTChannel):MS:TXLevel[:SELected]:BURSt<[1]|2|3|4|5>
Uplink Burst TX Level for selected PDTCH band | CALL:(PDTCH|PDTChannel):MS:TXLevel[:SELected]:BURSt<[1]|2|3|4|5>
Uplink Burst TX Level for selected PGSM band | CALL:(PDTCH|PDTChannel):MS:TXLevel[:SELected]:BURSt<[1]|2|3|4|5>
Uplink Frame Segmentation | CALL:MS:TX:FRAMe:SEGMentation

Operating Considerations

GSM

There are a number of parameters for the broadcast channel (see Configuring the Broadcast Channel (BCH) ) and the traffic channel (see Configuring the Traffic Channel (TCH) Parameters ) that can be configured, however the test set's default parameters should allow a properly functioning mobile station to successfully camp on the cell and make a call under most circumstances.

When Operating Mode = Active Cell, if a call is connected, changes to these parameters, including a change to the value of the parameter's current setting, causes signaling on the downlink to automatically initiate the change. No separate command is necessary to initiate the change. If a call is not connected, changes to the parameter are stored for when the next call is established

GPRS and EGPRS

For details on the parameters you can use to configure the PDTCH, see Configuring the Packet Data Traffic Channel (PDTCH) .


Paging Parameters

Paging Parameters

Last updated: December 2, 2008

User Configurable Paging Parameters

The following table lists the GPIB Commands to set the Paging Parameters . Please click the Paging Parameter's corresponding GPIB command link for more information on the Paging Parameter. The GPIB Command tables give a description of the parameter, as well as valid settings and firmware requirements.

All of the parameters listed below are located in the Cell Parameters menu of the test set's front panel. See How Do I Change Paging Parameters? for the procedure to configure the cell parameters. Refer to the Operating Considerations below before attempting to configure the cell parameters.

Parameter | GPIB Command
Call Originate Timeout | CALL:ORIGinate:TIMeout
Paging Identity Type* | CALL:PAGing:IDENtity[:TYPE]
Paging IMSI | CALL:PAGing:IMSI
Paging Mode | CALL:PAGing:MODE
Paging Multiframes | CALL:PAGing:MFRames
Repeat Paging | CALL:PAGing:REPeat[:STATe][:SELected]
TMSI* | CALL[:CELL]:TMSI[:VALue]
TMSI Assignment* | CALL[:CELL]:TMSI:ASSignment
* Only applicable to the lab applications.

Operating Considerations

The test set's default paging parameters should allow a properly functioning mobile station to successfully camp on the cell and make a connection under most circumstances.

Parameters can be queried from the test set regardless of the state of the test set.

Paging Identity Type, TMSI Assignment, and the TMSI value can only be configured when the Call Status is Idle and the Data Connection Status is Idle or Attached. The TMSI value is only accessible via the front panel when the Paging Identity Type is set to TMSI or when TMSI Assignment is set to On . Paging Identity Type, TMSI Assignment, and the TMSI value only apply when the test set's Operating Mode is Active Cell (GSM, GPRS or EGPRS).

The TMSI value used for both test sets in a Two-Cell Test System is the TMSI setting in the test set that initiates the External Device Connection. The TMSI setting is greyed out in the test set that does not initiate the External Device Connection for the entire duration that the test sets are connected. Changes to the TMSI value via GPIB are not applied to the test set that did not initiate the External Device Connection until the connection between has terminated.

For more information about the Paging Mode, Paging Multiframes, and Repeat Paging parameters, see Configuring Mobile Station Operating Parameters .

Related Topics

How Do I Change Paging Parameters?


Configuring the Packet Data Traffic Channel (PDTCH)

Configuring the Packet Data Traffic Channel (PDTCH)

Last updated: December 2, 2008

This section is not applicable to GSM.

This section contains the following:

  • GPRS and EGPRS Packet Data Traffic Channel Parameters
  • How Do I Configure the PDTCH Parameters?
  • Using Deferred Parameters
  • Supported Multislot Classes
  • Operating Considerations

GPRS and EGPRS Packet Data Traffic Channel Parameters

The GPRS and EGPRS packet data traffic channel parameters are configured using the following call processing subsystem commands. Click on the link to the GPIB command to find more information about the parameter.

For a complete list of GPIB commands in the call processing subsystem, refer to CALL Subsystem .

The following parameters are accessible on the front panel under the PDTCH Parameters (F9) on the Call Setup screen. See How Do I Configure the PDTCH Parameters? for more information.

Parameter | GPIB Command
BLER Block Polling Interval | CALL:FUNCtion:DATA:BLOCk:POLLing:INTerval[:SELected]
Data Connection Frame Number Type | CALL:FUNCtion:DATA:BLOCk:POLLing:INTerval:ACKB
Data Connection LLC Frame Check Sequence | CALL:FUNCtion:DATA:BLER:LLC:FCSequence
Data Connection Type | CALL:FUNCtion:CONNection:TYPE
Downlink Burst Current Absolute Power Level | CALL:(PDTCH|PDTChannel):POWer[:AMPLitude]:BURSt<[1]|2|3|4|5>?
Downlink Burst Power Reduction Selection | CALL:(PDTCH|PDTChannel):PREDuction:BURSt<[1]|2|3|4|5>
Downlink Power Reduction Level (dB) | CALL:(PDTCH|PDTChannel):PREDuction:LEVel<1|2>
EGPRS Modulation Coding Scheme for Active Cell Operating Mode | CALL:(PDTCH|PDTChannel):MCSCheme ( EGPRS Only )
EGPRS Modulation Coding Scheme for BCH+PDTCH Test Mode Operating Mode | CALL:(PDTCH|PDTChannel):MCSCheme:EBPTest[:BURSt1] (EGPRS Only) CALL:(PDTCH|PDTChannel):MCSCheme:EBPTest:BURSt<2|3|4|5> ( EGPRS Only )
EGPRS Supplementary Polling | CALL:(PDTCH|PDTChannel):ESPolling
First Burst to Loop (Downlink) | CALL:(PDTCH|PDTChannel):MSLot[:FIRSt]:DOWNlink:LOOPback[:BURSt]
GPRS PDTCH Coding Scheme | CALL:(PDTCH|PDTChannel):CSCHeme ( GPRS Only ) CALL:(PDTCH|PDTChannel):CSCHeme:UPLink ( GPRS Only ) CALL:(PDTCH|PDTChannel):CSCHeme:DOWNink ( GPRS Only )
Incremental Redundancy State for EGPRS | CALL:(PDTCH|PDTChannel):IREDundancy[:STATe]
Multislot Configuration | CALL:(PDTCH|PDTChannel):MSLot:CONFig
Meas Burst | CALL:(PDTCH|PDTChannel):MSLot:MEASurement:BURSt
P0 for Downlink PDTCH | CALL:(PDTCH|PDTChannel):PZERo:LEVel
Packet Data Traffic Channel (ARFCN) | CALL:(PDTCH|PDTChannel)[:ARFCn][:SELected]
Packet Data Traffic Channel Band | CALL:(PDTCH|PDTChannel):BAND
Packet Power Timing Advance State | CALL:(PDTCH|PDTChannel):PMESsage:PPTadvance
Packet Timeslot Reconfigure State | CALL:(PDTCH|PDTChannel):PMESsage:PTReconfig
Payload Pattern (BLER) | CALL:FUNCtion:DATA:PAYLoad:PATTern:BLER
Payload Pattern (OTHER) | CALL:FUNCtion:DATA:PAYLoad:PATTern[:OTHer]
Persistent Attach | CALL:MS:PATTach[:STATe]
Puncturing Scheme for EGPRS | CALL:(PDTCH|PDTChannel):MCSCheme:PSCHeme
Unused Downlink Burst Current Absolute Power Level | CALL:(PDTCH|PDTChannel):POWer[:AMPLitude]:UNUSed?
Unused Downlink Burst Power Reduction Selection | CALL:(PDTCH|PDTChannel):PREDuction:UNUSed
Adjacent Downlink Burst Current Absolute Power Level | CALL:(PDTCH|PDTChannel):POWer[:AMPLitude]:BURSt<[1]|2|3|4|5>?
Adjacent Downlink Burst Power Reduction Selection | CALL:(PDTCH|PDTChannel):PREDuction:ADJacent
Deferred Parameters
Deferred Packet Data Traffic Channel Band | CALL:SETup:(PDTCH|PDTChannel):BAND
Deferred Packet Data Traffic Channel (ARFCN) | CALL:SETup:(PDTCH|PDTChannel)[:ARFCn]:(DCS|EGSM|GSM450|GSM480|GSM750|GSM850|PCS|PGSM|RGSM|TGSM810)
Deferred GPRS PDTCH Coding Scheme | CALL:SETup:(PDTCH|PDTChannel):CSCHeme
Deferred EGPRS Modulation Coding Scheme for Active Cell Operating Mode | CALL:SETup:(PDTCH|PDTChannel):MCSCheme ( EGPRS Only )
Deferred Multislot Configuration | CALL:SETup:(PDTCH|PDTChannel):MSLot:CONFig
Deferred P0 for Downlink PDTCH | CALL:SETup:(PDTCH|PDTChannel):PZERo:LEVel

How Do I Configure the PDTCH Parameters?

This section contains two procedures. The first procedure explains how to configure the immediate PDTCH parameters. The second procedure explains how to set the deferred PDTCH parameter. See Using Deferred Parameters for more information on deferred parameters.

  • How Do I Configure the Immediate PDTCH Parameters?
    1. Press the CALL SETUP key.
    2. Press Operating Mode ( F1 ) and select Active Cell (GPRS, or EGPRS) .
    3. Select PDTCH Parameters ( F9 ) from the Call Parms menu.
    4. Press the More softkey on the bottom right hand side of the front panel display to access the PDTCH Parms ( 2 of 3 ) menu.
    5. Press Multislot Config ( F7 ), this displays the Multislot Config menu.
    6. Use the knob to scroll to and highlight the configuration you want.
  • How Do I Configure the Deferred PDTCH Parameters?
    1. Press the CALL SETUP key.
    2. Press Operating Mode ( F1 ) and select Active Cell (GPRS, or EGPRS) .
    3. Select Handover Parameters ( F10 ) from the Call Parms menu.
    4. Select GPRS Handover Setup ( F8 ) from the Handover menu. This displays the GPRS Handover Setup menu.
    5. Use the knob to scroll to and highlight Multislot Config .
    6. Press the knob, and the Multislot Config menu is displayed. Use the knob to select which configuration you want.

Using Deferred Parameters

Deferred parameters allow you to set up multiple parameters without implicit over-the-air signalling taking place. Using deferred parameters offers the following benefits:

  • Code construction is more succinct.
  • Only one signaling exchange between the test set and the mobile station sets up multiple parameters rather than a separate exchange for each parameter.
  • Once the current data connection has been established, you can set up the next set of deferred parameters.

Supported Multislot Classes

As shown in the table of configurable parameters, the command to configure the multislot configuration is CALL:(PDTCH|PDTChannel):MSLot:CONFig . The effect this command has on the number of uplink and downlink timeslots depends on the Connection Type (see CALL:FUNCtion:CONNection:TYPE ).

  • Type A - The multislot configuration command only affects the number of uplink timeslots, therefore configurations D1U1, D2U1, D3U1, D4U1, D5U1 and D6U1 will appear similar.
  • BLER - The multislot configuration command only affects the number of downlink timeslots, therefore, D2U2 and D2U1 will appear similar. Note that in BLER mode it is not possible to have more uplinks than downlinks.

The actual timeslots used in each configuration are fixed as in the table below.

Multislot Configuration | Downlink Timeslots Used | Uplink Timeslots Used
D1U1 | 3 | 3
D1U2 | 3 | 3,4
D1U3 | 3 | 3,4,5
D1U4 | 3 | 3,4,5,6
D1U5 | 3 | 2,3,4,5,6
D1U6 | 2 | 1,2,3,4,5,6
D2U1 | 3,4 | 4
D2U2 | 3,4 | 3,4
D2U3 | 3,4 | 3,4,5
D2U4 | 3,4 | 3,4,5,6
D2U5 | 2,3 | 2,3,4,5,6
D3U1 | 3,4,5 | 4
D3U2 | 3,4,5 | 4,5
D3U3 | 3,4,5 | 4,5,6
D3U4 | 2,3,4 | 3,4,5,6
D4U1 | 3,4,5,6 | 5
D4U2 | 3,4,5,6 | 5,6
D4U3 | 2,3,4,5 | 4,5,6
D5U1 | 2,3,4,5,6 | 5
D5U2 | 2,3,4,5,6 | 5,6
D6U1 | 1,2,3,4,5,6 | 5
Custom | You can position the timeslots flexibly. See Flexible Timeslot | You can position the timeslots flexibly. See Flexible Timeslot

Note: When a multislot configuration change is executed, all measurements will be stopped before the change is made, and re-started after the change has taken effect.

The default Medium Access Mode for multislot configurations that have three or more uplinks is Extended Dynamic Allocation .

NOTE
The current multislot configuration does not change when you switch between GPRS and EGPRS serving cells unless the current multislot configuration is not supported in the serving cell that you are switching to. In this case the multislot configuration changes to the default configuration 2x1.

  • GPRS Multislot Classes

    The test set supports GPRS mobile stations with multislot class 1-12, multislot class 30-34 and multislot class40-45. The following multislot configurations are supported (indicated as Downlink x Uplink): 1x1, 1x2, 1x3, 1x4, 1x5, 1x6, 2x1, 2x2, 2x3, 2x4, 2x5, 3x1, 3x2, 3x3, 3x4, 4x1, 4x2, 4x3, 5x1, 5x2 and 6x1. The test set's operating mode must be Active Cell ( Serving Cell GPRS), GPRS BCH+PDTCH or GPRS BCH+TCH+PDTCH for all the GPRS multislot configurations to be supported.

    When the connection type is BLER, the only multislot configurations available are those with the number of downlinks greater than or equal to the number of uplinks in the multislot configuration.

  • EGPRS Multislot Classes

    The test set with the Lab Application license supports EGPRS mobile stations with multislot class 1-12, multislot class 30-34 and multislot class40-45. The following multislot configurations are supported (indicated as Downlink x Uplink): 1x1, 1x2, 1x3, 1x4, 1x5, 1x6, 2x1, 2x2, 2x3, 2x4, 2x5, 3x1, 3x2, 3x3, 3x4, 4x1, 4x2, 4x3, 5x1, 5x2 and 6x1.

    See EGPRS Data Rate Configurations for details on which multislot configurations are supported for EGPRS mobile stations and other operating considerations.

Operating Considerations

The immediate multislot configuration parameter is available in all the operating modes except Cell Off and CW. Note that although you can configure the multislot configuration when the operating mode is set to GPRS BCH and EGPRS BCH, these settings do not effect the test set's operation.

When the connection type is set to BLER or SRB Loopback, the multislot configuration cannot have more uplinks than downlinks.

When configuring the base station emulator you must configure the broadcast channel (see CALL:BCHannel ) and the packet data traffic channel (PDTCH). There are a number of parameters for the BCH and the PDTCH that can be configured; however, the test set's default parameters should allow a properly functioning GPRS or EGPRS mobile station to successfully establish a data connection under most circumstances.

The PDTCH (ARFCN) is a frequency banded parameter (see Frequency Banded Parameters ).

Related Topics

Frequency Bands

Flexible Timeslot

Configuring the Broadcast Channel (BCH)

Configuring Mobile Station Operating Parameters

Packet Data Traffic Channel Band Parameter

CALL:(PDTCH|PDTChannel)

Testing a GPRS Mobile Station

GPRS Data Connection Troubleshooting

Modulation Coding Scheme/Puncturing Scheme (MCS/PS)


Receiver Control

Receiver Control

Last updated: December 2, 2008

The test set normally sets all receiver parameters automatically using data connection control settings. You may want to control the test set's receiver parameters manually rather than allowing the test set to control them. This ability is referred to as manual receiver control.

  • How Do I Access the Receiver Control Parameters?
  • Selecting Manual or Automatic Receiver Control
  • Expected Power Control
  • Measurement Frequency
  • Measurement Channel in BCH Only Mode
  • Uplink Frequency
  • Expected Burst
  • Modulation Format Control (EGPRS only)
  • Expected CW Power (CW Operating Mode only)
  • Measurement Burst (GPRS and EGPRS only)
  • Effects on Receiver Control When Changing Operating Mode
  • Asymmetric Guard Period Length
  • Uplink Frame Segmentation

How Do I Access the Receiver Control Parameters?

This section details how to access the Receiver Control parameter.

  1. Press the Call Setup key.
  2. Press Receiver Control ( F12 ).

Selecting Manual or Automatic Receiver Control

  • Automatic receiver control modes are the default for all operating modes. This means parameters such as the receiver's expected power, measurement frequency, and modulation format settings are set automatically according to the control parameters you specify (for example, Traffic Channel, Packet Data Traffic Channel, Packet Data Traffic Band, MS TX Level, and Modulation and Coding Scheme).
  • Manual mode allows you to override some or all of the automatic settings by first selecting the manual mode for the setting and then specifying the desired value. You can view the affected settings by selecting F12 ( Receiver Control ) from the Call Setup screen. A full or partial preset of the test set, including cycling power, returns the test set back to auto mode.

GPIB Examples

The following program examples use simple commands to perform a single function. Complex commands that enable manual receiver control and set a specified parameter at the same time are also available. See RFANalyzer for a listing of all receiver control syntax.

OUTPUT 714;"RFANalyzer:CONTrol:MEASurement:FREQuency:AUTO OFF" !Enables manual control of the measurement receiver's frequency.

OUTPUT 714;"RFANalyzer:MANual:MEASurement:FREQuency 825.030 MHZ" !Tunes the measurement receiver to 825.030 MHz through manual receiver control.

OUTPUT 714;"RFANalyzer:CONTrol:MEASurement:FREQuency:AUTO ON" !Returns measurement receiver frequency tuning control to auto.

Manual control parameter values are stored internally (as long as the test set is powered on). Enabling manual control of a parameter without providing a new value causes a previously stored value to immediately take effect. This allows you to pre-define manual control parameter values in your program before enabling manual control.

Expected Power Control

To make accurate measurements, the test set needs to know how much power to expect at the test set's RF IN/OUT port; referred to as the Expected Power. It gets this value from the call control MS TX Level setting during automatic receiver control, or by the user specifying the expected power with the expected power control set to manual.

You can set the expected power level beyond the capability of the test set's hardware because expected power is intended to reflect the potential range of RF power at the DUT . This range of RF power is meant to accommodate the use of a gain or loss network between the DUT and the test set. See Amplitude Offset for details about amplitude offset.

The upper and lower limits of expected power provide boundaries for the combination of amplitude offset and expected power. If you set expected power to +52 dBm and the amplitude offset to -3 dB, the calculated receiver power will be 49 dBm, but the test set shall be set to +43 dBm, the upper limit of the hardware. If the calculated value of receiver power goes below -25 dB, the lower limit of the hardware, the test set shall be set to -25 dB.

The expected power from the mobile is set manually using the following settings:

  • To set the test set receiver's expected power setting to manual use RFANalyzer:CONTrol:POWer:AUTO .

OUTPUT 714;"RFANalyzer:CONTrol:POWer:AUTO OFF"

  • To set the power level that the test set's receiver is expecting the mobile station uplink burst to transmit at for the GPRS system type, use RFANalyzer:MANual:POWer:BURSt<[1]|2|3|4|5|6|7> . Each burst is set individually.

    For example, the commands below set the receiver's expected power setting for burst 1 and burst 2.

OUTPUT 714;"RFANalyzer:MANual:POWer:BURSt1 15 DBM"

OUTPUT 714;"RFANalyzer:MANual:POWer:BURSt2 19 DBM"

    NOTE: Setting the manual expected burst power will not set expected power control to manual.

NOTE
During manual receiver control, make sure you are using the correct operating mode for the type of measurement you are making. Trying to measure a CW signal while in active cell mode will likely result in an error. This error occurs because the test set uses the expected power setting for the operating mode you are using, and uses different methods to measure analog and digital signals.

It is recommended that you specify the expected power each time you perform a handoff to a new band or traffic channel type during manual receiver control. This ensures that the correct expected power is set for the new channel settings.

Auto Expected Power Control

The expected power is derived from the MS TX Level setting for the specified system type when using automated control:

  • GSM:
    • CALL:MS:TXLevel[:SELected]
  • GPRS and EGPRS:
    • CALL:(PDTCH|PDTChannel):MS:TXLevel[:SELected]:BURSt<[1]|2|3|4|5>

Operating Considerations

The expected power control parameter is applicable to all operating modes, with the exception of CW.

Measurement Frequency

Measurement frequency is used to tune the test set's measuring receiver for all bands:

  • To set the receiver to manual mode and change the measurement frequency use RFANalyzer:MANual:MEASurement[:MFRequency] .

OUTPUT 714;"RFANalyzer:MANual:MEASurement 942.6 MHZ" !Enables manual measurement
!receiver control and sets the test set's measurement receiver frequency to 942.6 MHz.

Auto Measurement Frequency Control

If the receiver control parameter is set to auto, the test set's receiver frequency is set using the parameters in the following table. See CALL:TCHannel[:ARFCn][:SELected] traffic channel details and CALL:TCHannel:BAND for traffic band details. See CALL[:CELL]:BAND<[:SELected]|:GSM> for cell band details. See CALL:BCHannel for broadcast channel details.

Test Set Receiver Frequencies (Auto)
Operating Mode | Measurement Band | Measurement Frequency
Cell Off | Cell Band | Broadcast Channel (1)
Active Cell | TCH Traffic Band (3) | TCH Traffic Channel (2,4)
GSM BCH | Cell Band | Broadcast Channel (1)
GSM BCH+TCH | TCH Traffic Band | TCH Traffic Channel (2)
GPRS BCH | Cell Band | Broadcast Channel (1)
GPRS BCH+PDTCH | PDTCH Traffic Band | PDTCH Traffic Channel (2)
EGPRS BCH | Cell Band | Broadcast Channel (1)
EGPRS BCH+PDTCH | PDTCH Traffic Band | PDTCH Traffic Channel (2)
CW | Cell Band | Broadcast Channel (1)
Table Footnotes
1 | Actual frequency depends on current broadcast band (PGSM, EGSM, GSM450, GSM480, GSM750, GSM850, PCS, DCS or RGSM) and is defined in GSM as the uplink frequency.
2 | Actual frequency depends on current traffic channel band (PGSM, EGSM, GSM450, GSM480, GSM750, GSM850, PCS, DCS or RGSM) and is defined in GSM as the uplink frequency.
3 | TCH Traffic Band when the system type is GSM; PDTCH Traffic Band when the system type is GPRS or EGPRS
4 | TCH Traffic Channel when the system type is GSM; PDTCH Traffic Channel when the system type is GPRS or EGPRS

Measurement Channel in BCH Only Mode

Measurement Channel in BCH Only Mode sets which channel is measured by the test set in BCH Only operation mode. You can choose to measure one of the following channels: RACH, TCH or PDTCH.

NOTE
RACH here represents uplink channel type not burst type as in "Expected Burst" on page 10 setting.

  • To set the Measurement Channel in BCH Only Mode use RFANalyzer:CONTrol:BTESt:CHANnel .

OUTPUT 714;"CALL:OPERATING:MODE GBTest"
!Sets the operating mode to GSM BCH.

OUTPUT 714;"RFANalyzer:CONTrol:BTESt:CHANnel TCH"
!Sets the Measurement Channel in GSM BCH Only Mode to TCH.

You are suggested to set the "Measurement Frequency" on page 7 and "Expected Power Control" on page 6 to Auto when selecting a measurement channel in BCH Only Mode. the test set's receiver frequency and Expected Power Level is set automatically using the parameters in the following table.

Measurement Channel | Measurement Band | Measurement Frequency | Expected Power Level
RACH | Cell Band | Broadcast Channel (1) | 0 (5)
TCH | TCH Traffic Band (3) | TCH Traffic Channel (2,4) | TCH MS TX Level
PDTCH | PDTCH Traffic Band | PDTCH Traffic Channel (2) | PDTCH MS TX Level
Table Footnotes
1 | Actual frequency depends on current broadcast band (PGSM, EGSM, GSM450, GSM480, GSM750, GSM850, PCS, DCS or RGSM) and is defined in GSM as the uplink frequency.
2 | Actual frequency depends on current traffic channel band (PGSM, EGSM, GSM450, GSM480, GSM750, GSM850, PCS, DCS or RGSM) and is defined in GSM as the uplink frequency.
3 | TCH Traffic Band when the system type is GSM; PDTCH Traffic Band when the system type is GPRS or EGPRS
4 | TCH Traffic Channel when the system type is GSM; PDTCH Traffic Channel when the system type is GPRS or EGPRS
5 | Fix to the maximum MS TX Level

Operating Considerations

The Measurement Channel in BCH Only Mode receiver control parameter is only applicable to the following operating modes:

  • GSM BCH
  • GPRS BCH
  • EGPRS BCH

If the operating mode is set to GSM BCH , PDTCH is greyed on the front panel; if the operating mode is set to GPRS BCH or EGPRS BCH , TCH is greyed on the front panel.

When Operating Mode is switched from one BCH only Mode to another:

  • if the value of Measurement Channel in BCH Only Mode is valid in current operating mode, the value keeps unchanged.
  • if the value of Measurement Channel in BCH Only Mode is not valid in current operating Mode, the value is reset to RACH.

Uplink Frequency

Uplink Frequency sets the test set's demodulation receiver frequency, used to demodulate information from the mobile's uplink transmission:

  • To set the receiver to manual mode and set the demodulation receiver frequency use RFANalyzer:MANual:UPLink[:MFRequency] .

OUTPUT 714;"RFANalyzer:MANual:UPLink 942.6 MHZ" !Enables manual demodulation
!receiver control and sets the test set's demodulation receiver frequency to 942.6 MHz.

NOTE
Manual control of the demodulation receiver frequency is rarely needed. Use the measurement receiver when manual receiver frequency control is required. Automatic control is always used when the cell operating mode is active cell.

Operating Considerations

The uplink frequency receiver control parameter is only applicable to the following operating modes:

  • GSM BCH
  • GSM BCH+TCH
  • GPRS BCH
  • GPRS BCH+PDTCH
  • EGPRS BCH
  • EGPRS BCH+PDTCH

Expected Burst

See Expected Burst for more information.

Operating Considerations

The expected burst receiver control parameter is only applicable to the following operating modes:

  • GSM BCH
  • GSM BCH+TCH
  • GPRS BCH
  • GPRS BCH+PDTCH
  • EGPRS BCH
  • EGPRS BCH+PDTCH

Modulation Format Control (EGPRS only)

The expected modulation format is used by transmitter measurements which support both GMSK and 8PSK signals. The Modulation Format Control parameter allows you to select either Auto or Manual mode.

Auto Mode

If the modulation format control is set to Auto, the test set determines which modulation format to expect based on the current Operating Mode, current System Type, and the current Uplink Modulation and Coding Scheme. Coding Schemes MCS-1, MCS-2, MCS-3, and MCS-4 use GMSK modulation while MCS-5, MCS-6, MCS-7, MCS-8, and MCS-9 use 8PSK modulation.

The following table indicates which modulation format the test set expects based on each combination of operating parameters.

NOTE
8PSK is represented as EPSK in the test set.

Automatic Determination of Measurement Modulation Format
Operating Mode | System Type | Uplink Coding Scheme (CS) or Modulation and Coding Scheme (MCS) | Expected Modulation
Active Cell (GSM) | GSM | N/A | GMSK
Active Cell (GPRS) | GSM | N/A | GMSK
 | GPRS | CS1 - CS4 | GMSK
Active Cell (EGPRS) | GSM | N/A | GMSK
 | EGPRS* | MCS1 - MCS4 | GMSK
 |  | MCS5 - MCS9 | EPSK
GSM BCH | GSM | N/A | GMSK
GSM BCH+TCH | GSM | N/A | GMSK
GPRS BCH | GPRS | CS1 - CS4 | GMSK
GPRS BCH+PDTCH | GPRS | CS1 - CS4 | GMSK
EGPRS BCH | EGPRS | MCS1 - MCS4 | GMSK
 |  | MCS5 - MCS9 | EPSK
EGPRS BCH+PDTCH | EGPRS | MCS1 - MCS4 | GMSK
 |  | MCS5 - MCS9 | EPSK
CW | N/A | N/A | GMSK
Cell Off | N/A | N/A | GMSK

NOTE
* When the operating mode is Active Cell (EGPRS) and the connection type is BLER, the expected modulation is GMSK because the uplink TBF uses the PACCH. All control channels use GMSK modulation.

Manual Mode

If the modulation format control is set to Manual, you can set the modulation format the test set should expect for each uplink burst individually.

  • To set the modulation format control setting to manual, use CALL:MODulation[:FORMat]:CONTrol:AUTO .

OUTPUT 714;"CALL:MODulation:CONTrol:AUTO OFF"
  • To set the modulation format the transmitter measurements are expecting for each uplink burst, use CALL:MODulation[:FORMat]:MANual:BURSt[1]|2|3|4|5|6|7 . Each burst is set individually.

OUTPUT 714;"CALL:MODulation:MANual:BURSt EPSK"

OUTPUT 714;"CALL:MODulation:MANual:BURSt2 EPSK"

Operating Considerations

Modulation Format Control is only available in Active Cell (EGPRS), EGPRS BCH, and EGPRS BCH+PDTCH operating modes. Attempting to change the modulation format control parameter value in other operating modes generates the following error:
Operation rejected: Command is not supported in this operating mode.

You can make changes to the expected modulation format for each individual uplink burst in any operating mode programatically using GPIB commands. These parameters are only accessible via the front panel when the operating mode is valid for this parameter.

Changes to operating mode cause the modulation format control parameter value to be reset to Auto. However, the individual burst settings are not reset and retain any changes you have made.

NOTE
When the operating mode is either EGPRS BCH or EGPRS BCH+PDTCH and the modulation format control is set to Auto, the test set assumes that the uplink uses the same modulation format as is specified for the downlink to automatically determine the modulation format. If this is not the case, you should set the modulation format control to Manual and set the appropriate modulation format settings.

Expected CW Power (CW Operating Mode only)

The expected CW power from the mobile is set manually using the following setting:

  • To set the power level that the test set's receiver is expecting the mobile station to transmit at in CW operating mode, use RFANalyzer:CW:EXPected:POWer .

OUTPUT 714;"RFANalyzer:CW:EXPected:POWer 15 DBM"

See Expected Power Control for more information on expected power settings.

Measurement Burst (GPRS and EGPRS only)

Measurement Burst sets the mobile uplink burst number on which the measurement is performed (not the absolute timeslot number, but the burst number relative to the first uplink burst in the TDMA frame):

  • To set the measurement burst use CALL:(PDTCH|PDTChannel):MSLot:MEASurement:BURSt .

OUTPUT 714;"CALL:PDTCH:MSL:MEAS:BURS 2" !Sets the receiver to measure the second uplink !burst.

    The Measurement Burst parameter is always controlled manually. The choice of bursts available is based on the selection table shown under the multislot selection command, CALL:(PDTCH|PDTChannel):MSLot:CONFig .

Effects on Receiver Control When Changing Operating Mode

After selecting the operating mode to use and setting one or more receiver controls to manual, the receiver control settings remain as you set them until you change operating mode. Changing operating mode causes all receiver parameters to return to automatic control.

Asymmetric Guard Period Length

For information about this parameter see the description in the GPIB command for this parameter, which is located at CALL:MS:TX:BURSt:GPLength .

This parameter is located in the Receiver Control menu on the front panel. Refer to How Do I Access the Receiver Control Parameters? for instructions on how to access this menu.

Uplink Frame Segmentation

For information about this parameter see the description in the GPIB command for this parameter, which is located at CALL:MS:TX:FRAMe:SEGMentation .

This parameter is located in the Receiver Control menu on the front panel. Refer to How Do I Access the Receiver Control Parameters? for instructions on how to access this menu.

Related Topics

Test Mode Operating Modes


MAC Control

MAC Control

Last updated: December 2, 2008

There are several user configurable RLC/MAC protocol layer parameters. These include:

  • Medium Access Mode
  • Uplink State Flag (USF)
  • Assigned USF Granularity
  • Relative Reserved Block Period (RRBP)
  • Power Reduction Mode

Assigned USF Granularity

USF granularity specifies the number of RLC/MAC blocks that need to be transmitted by the mobile station on an uplink TBF.

Whenever the mobile station detects an assigned USF value on an assigned PDCH, the mobile station will transmit either a single RLC/MAC block or a sequence of four RLC/MAC blocks on the same PDCH for that TBF except if that TBF is running in extended uplink TBF mode, in which case the mobile station may transmit RLC/MAC block(s) for other TBFs assigned on the same PDCH. The number of RLC/MAC blocks to transmit is controlled by the USF Granularity parameter characterizing the uplink TBF.

USF granularity can take on two values:

  • 1 - the mobile station transmits one RLC/MAC block on an uplink TBF per decoded USF
  • 4 - the mobile station transmits four RLC/MAC blocks on an uplink TBF per decoded USF
Any changes to this parameter while a TBF is in progress will take place immediately.

The GPIB command to set this parameter is CALL:(PDTCH|PDTChannel):MACCess[:DYNamic]:USFLag[:ASSigned]:GRANularity .

Power Reduction Mode

The Power Reduction (PR) field in the Packet Downlink Assignment and Packet Uplink Assignment message is used to help the mobiles in the GPRS/EGPRS network to determine the transmission power used to transmit a current downlink RLC/MAC blocks. The PR field consists of PR Mode and P0 values.

The GPIB command to set P0 is CALL:(PDTCH|PDTChannel):PZERo:LEVel .

The GPIB command to set PR Mode is CALL:(PDTCH|PDTChannel):PREDuction:MODE .

Related Topics

Protocol Control


Temporary Block Flow (TBF) Parameters

Temporary Block Flow (TBF) Parameters

Last updated: December 2, 2008

This section is only applicable to the lab applications.

  • Frame Start Position
  • Uplink Data Timeout
  • Delayed Downlink TBF
  • Extended Uplink TBF
  • TBF Re-establishment
  • Packet Uplink Ack/Nack Interval
  • Final Block Polling
  • Early Re-Transmissions
  • T3192 TBF Release Timer
  • ARAC on receipt of PRR

Other information on this page includes:

  • Operating Considerations

Frame Start Position

The Frame Start Position parameter allows you to specify the type of frame numbering scheme to be used when establishing a data connection.

Changing the frame numbering scheme may enable the test set to establish a data connection with mobile stations which cannot connect under normal conditions.

There are three possible settings:

  • Relative: the test set sends the starting frame number to the mobile as a relative offset from the current frame.
  • Absolute: the test set sends the starting frame number to the mobile as an absolute frame number.
  • Immediate: the test set sends the starting frame number as an immediate assignment.

This parameter is located in the TBF Control parameters menu on the test set's front panel. To access this menu, see How Do I Set the Temporary Block Flow (TBF) Control Parameters? .

If the type of data connection you want to establish is BLER, the commands CALL:FUNCtion:DATA:BLER:LLC:FCSequence and CALL:FUNCtion:DATA:BLER:POLLing:INTerval may also be helpful in enabling the test set to establish a data connection with mobile stations which cannot establish a BLER data connection under normal conditions.

The GPIB command to set the Frame State Position parameter is CALL:FUNCtion:DATA:FRAMe:STARt .

Uplink Data Timeout

The Uplink Data Timeout parameter helps to determine whether the radio link has failed and whether the uplink flow of data messages has been interrupted for an extended period of time.

Note, this parameter only takes effect in the following data connection types: ETSI A, ETSI B (UNACK) and SRB Loopback.

You can turn on or turn off the Uplink Data Timeout timer by setting the Uplink Data Timeout parameter.

  • When the Uplink Data Timeout parameter is set to a numeric timeout value, The Uplink Data Timeout timer will run whenever an uplink TBF is active. Each time a valid RLC data block message is received by the RLC/MAC layer the timer is reset to 0, but if the timer expires then the uplink is assumed to have been lost and the connection (uplink and any downlink TBF's) will be released. This timer is to track RLC data message only, reception of RLC control message will not reset the timer.
  • When the Uplink Data Timeout parameter is set to OFF, the TBF will not be released.

This parameter is located in the TBF Control parameters menu on the test set's front panel. To access this menu, see How Do I Set the Temporary Block Flow (TBF) Control Parameters? .

You can set the state and duration of the Uplink Data Timeout timer. To set them separately, use CALL:(PDTCH|PDTChannel):TBFLow:UPLink:DLOSt:TIMer:STATe to set the state of the timer, CALL:(PDTCH|PDTChannel):TBFLow:UPLink:DLOSt:TIMer:DURation to set the duration of the timer; use CALL:(PDTCH|PDTChannel):TBFLow:UPLink:DLOSt:TIMer[:SDURation] to set the state and duration simultaneously.

Delayed Downlink TBF

A delayed release of the downlink TBF is when the release of the downlink TBF is delayed following the transmission of a final data block, rather than instantly releasing the TBF. A delayed downlink TBF allows re-use of a downlink TBF for subsequent data transfers without the need for TBF re-establishment, thereby reducing the latency involved between downlink transfers.Support for or use of delayed downlink TBF is not advertised to the mobile station in any way, and therefore is not contained in the System Information messages. The mobile station does not require any changes to support delayed downlink TBF operation.

The connection status displays `Transferring' when Dual Transfer Mode (DTM) is not enabled and `Connected/Transfer' when DTM is enabled until the downlink TBF has been released.

You can set the Delayed Downlink TBF state and duration. To set them separately, use CALL:(PDTCH|PDTChannel):TBFLow:DOWNlink:DELayed[:SDURation] to set the Delayed Downlink TBF state, CALL:(PDTCH|PDTChannel):TBFLow:DOWNlink:DELayed:STATe to set the Delayed Downlink TBF duration; use CALL:(PDTCH|PDTChannel):TBFLow:DOWNlink:DELayed:DURation to set the state and duration simultaneously.

For more information about the delayed release of the downlink TBF, refer to 3GPP TS 44.060 Version 6.14 Section 9.3.1a.

Extended Uplink TBF

The Extended Uplink TBF parameter extends the time period before an uplink TBF is released. The TBF is extended for a period of time (set by the network), following the reception of a data block marked with a Countdown Value of zero (CV=0). 3GPP TS 44.060 Version 6.14.0 states, "In the extended uplink TBF mode, the uplink TBF may be maintained during temporary inactive periods, where the mobile station has no RLC information to send." An extended uplink TBF allows the mobile station to reuse the uplink TBF for subsequent data transfers without the need for TBF re-establishment, thereby reducing the latency involved between uplink data transfers.The network's support for extended uplink TBF is broadcasted on the (P)BCCH within a (Packet) System Information message. The mobile station must have explicit support for the extended uplink functionality to operate correctly.

You can set the Extended Uplink TBF state with the GPIB command CALL:(PDTCH|PDTChannel):TBFLow:DOWNlink:DELayed[:SDURation] , set the Extended Uplink TBF Duration with the GPIB command CALL:(PDTCH|PDTChannel):TBFLow:UPLink:EXTended:DURation .

TBF Re-establishment

When the TBF Re-establishment state is set to On, the test set allows the re-establishment of an uplink TBF before the current TBF is released. Therefore, if the mobile station requires a new uplink TBF it does not have to wait for the current TBF to be released before establishing the next uplink TBF. Instead, the mobile station begins requesting a new TBF as soon as the final acknowledgment for the current uplink TBF has been received from the network.

The GPIB command to set the TBF Re-establishment state is CALL:(PDTCH|PDTChannel):TBFLow:REEStablish[:STATe] .

For more information about TBF Re-establishment, refer to 3GPP TS 44.060 Version 6.14.

Packet Uplink Ack/Nack Interval

The Packet Uplink Ack/Nack Interval parameters allows you to specify the number of RLC block periods to wait before the test set sends the Packet Uplink Ack/Nack RLC control message to Mobile Station during an uplink TBF. You can influence the data throughput by setting the parameters. A high Packet Uplink Ack/Nack Interval value which exceeds the size of RLC transmit window may cause the RLC transmit window to stall, a low Packet Uplink Ack/Nack Interval value may prevent downlink data being sent to the MS as RLC control messages have higher priority than RLC data.

For multislot configurations that have fewer downlink timeslots than uplink timeslots, the test set attempts to match the specified Ack/Nack period in a `best effort' manner. If the requested number of Ack/Nack messages would exceed the available downlink bandwidth, the lowest value possible is used instead. For example: For a 1D2U multislot configuration with Packet Uplink Ack/Nack Interval set to "1", the test set's 'best effort' value used is "2".

Just as the test set allows for the RLC transmit "Window Size" parameter to be different for GPRS and EGPRS, it also allows for the Packet Uplink Ack/Nack Interval to be configured individually for GPRS and EGPRS operations. These parameters are:

  • Packet Uplink Ack/Nack Interval (GPRS):

    The valid range of this parameter is 1 to 63. The GPIB command to set this parameter is CALL:FUNCtion:DATA:PUPLink:ACKNack:INTerval:GPRS .

  • Packet Uplink Ack/Nack Interval (EGPRS):

    The valid range of this parameter is 1 to 1023. The GPIB command to set this parameter is CALL:FUNCtion:DATA:PUPLink:ACKNack:INTerval:EGPRs .

This parameter is located in the TBF Control parameters menu on the test set's front panel. To access this menu, see How Do I Set the Temporary Block Flow (TBF) Control Parameters? .

Final Block Polling

The Final Block Polling parameter allows you to control the uplink data throughput by setting the polling rate.

When a downlink TBF needs to be released (i.e. there is no more data to transfer at the RLC layer), the network will send the last data block with the Final Block Indicator bit set to 1. It will also set the bit or bits required to poll. This will indicate to the DUT that this data block is the last in the TBF and that it should send a Packet Downlink ACK/NACK message so that the TBF can be released according to 3GPP TS 44.060 section 9.3.2.6. These ACK/NACK messages will take transmission priority over data blocks for the DUT and each time it receives a valid poll it must respond with the appropriate message.

There are two possible settings for this parameter:

  • Normal: The poll bit is set every time a RLC data block with the Final Block Indicator is set. The DUT will send a control block in the place of a data block when it receive a RLC data block with poll bit set, thus reducing uplink data throughput in the process.
  • Reduced: the test set poll twice within each RRBP period, initiated by the FBI being set. The first poll happens on the first instance of the FBI transmission. The second poll happens approximately halfway through the RRBP period. The exact timing of the poll is determined internally in the protocol stack via the frame numbers. An RRBP period is about 100ms, so the uplink data throughput will be increased.

This parameter is located in the TBF Control parameters menu on the test set's front panel. To access this menu, see How Do I Set the Temporary Block Flow (TBF) Control Parameters? .

The GPIB command to set this parameter is CALL:(PDTCH|PDTChannel):TBFLow:DOWNlink:FBIndicator:POLLing .

Early Re-Transmissions

This setting affects the BLER accuracy when the ETSI B Ack Measurement mode of BLER measurement is `Polling' and the packet transfer mode is `Acknowledged'. You can improve the accuracy of BLER measurement by setting the Early Re-Transmission Sate to OFF.

In Acknowledged Packet Transfer mode, the test set assigns the RLC data blocks a specific status value while they reside in the stack awaiting transmission. This status is used to determine which block is transmitted and when the block will be transmitted. The statuses include:

  • RECEIVED - new blocks are given this status when they arrive in the stack. These blocks have not yet been transmitted.
  • PENDING_ACK - blocks that have just been transmitted are given this status.
  • NACKED - blocks that are NACKED by the DUT, i.e. requiring a re-transmission. These will be stored in the stack in a queue until such a time as it can be re-transmitted, then it will be set to pending_ack.
  • ACKED - blocks that are acknowledged are given this status. These blocks will normally be deleted immediately after becoming acked.

When the DUT requests a re-transmission of a block it will be marked as NACKED in the stack. If there are no other NACKED blocks in the stack then this block will be re-transmitted before any other blocks, if there are other NACKED blocks already waiting then they will be processed first. After these NACKED blocks are sent their status moves to PENDING_ACK. When the Early Re-transmission State is set to ON, the PENDING_ACK block is selected for transmission if there is no NACKED or RECEIVED block in the stack. This means that a RLC block is sent to the DUT more than one time before the test set know the status of the initial transmission. This will affect the accuracy of BLER results in two ways:

  1. The DUT may have more than one attempt to successfully decode a data block.
  2. If a RLC block is sent to the DUT more than one time before receiving the Packet Downlink ACK/NACK message and the previous ones were failed to be decoded but the last one passed, then the test set will mark the block as ACKED and will not record any BLER for it.

When the Early Re-transmission State is set to OFF, the test set first determines if it is required to poll the DUT. If the test set determines that a poll is required, it sends the last data block to the DUT that has already been `ACKED'. As the block has already been counted for BLER and as the DUT has already acked it, it is safe to re-transmit it. Note that the test set determines the last `ACKED' data block from the bitmap of the Packet Downlink ACK/NACK message.

This parameter is located in the TBF Control parameters menu on the test set's front panel. To access this menu, see How Do I Set the Temporary Block Flow (TBF) Control Parameters? .

The GPIB command to set this parameter is CALL:(PDTCH|PDTChannel):TBFLow:DOWNlink:RETRansmit[:STATe] .

T3192 TBF Release Timer

See Configurable Timers for more information.

The GPIB command to set the Timer is CALL[:CELL]:TBFLow:T3192 .

ARAC on receipt of PRR

When the ARAC on receipt of PRR parameter is set to ON , the test set sets the ARAC request bit in the PACKET UPLINK ASSIGNMENT message when assigning an EGPRS TBF. The mobile then provides the network with its radio access capabilities for the frequency bands it supports by sending a PRR (PACKET RESOURCE REQUEST) message, and an ADDITIONAL MS RADIO ACCESS CAPABILITIES message if all the requested information does not fit in the PACKET RESOURCE REQUEST.

Currently, setting the ARAC request bit in the PACKET UPLINK ACK/NACK message is not supported by the test set.

The ARAC on receipt of PRR parameter is only available when the operating mode is set to Active Cell (EGPRS) .

The GPIB command to set the ARAC upon PRR State parameter is CALL:(PDTCH|PDTChannel):ARAC:PRRequest[:STATe] .

See 3GPP TS 44.060 section 7.1.2.2.1a and 3GPP TS 44.018 section 3.5.2 for more information about how to request the Additional MS Radio Access Capability information.

Operating Considerations

It is recommended that you should not change the Frame Start Position parameter while the data connection status is Starting , as there is no guarantee whether the new setting or the previous setting will be used for the current data connection.

The delayed downlink TBF, extended uplink TBF, and TBF Re-establishment parameter settings only take affect when the Operating Mode is set to Active Cell (serving cell GSM, GPRS, or EGPRS) and the Data Conn Type is set to Auto .

The Operating Mode must be set to Cell Off when you change the Extended Uplink TBF state. If not, the following error appears on the test set's front panel.

" GSM/GPRS operation rejected; Attempting to set BCH parameter while generating a BCH "

Related Topics

Manual Operation: How Do I Set the TBF Parameters?


Configuring the Traffic Channel (TCH) Parameters

Configuring the Traffic Channel (TCH) Parameters

Last updated: December 2, 2008

This section is not applicable to GPRS and EGPRS.

The traffic channel parameters are configured using the following call processing subsystem commands.

For complete GPIB command syntax, see CALL:TCHannel .

The TCH Parameters can be accessed on the front panel by pressing TCH Parameters ( F8 ) on the Call Parms menu, see How Do I Change Call Parameters? .

TCH Parameters

Parameter | GPIB Command
Traffic Channel Band | CALL:TCHannel:BAND
Traffic Channel (ARFCN) | CALL:TCHannel[:ARFCn][:SELected]
Timeslot | CALL:TCHannel:TSLot
Mobile Loopback | CALL:TCHannel:LOOPback
Speech | CALL:TCHannel:DOWNlink:SPEech
Channel Mode | CALL:TCHannel:CMODe[:VALue]
Speech Channel | CALL:TCHannel:CMODe:HRSPeech:SCHannel
Downlink Burst Current Absolute Power Level | CALL:TCHannel:POWer[:AMPLitude]?
Downlink Burst Power Reduction Selection | CALL:TCHannel:PREDuction:BURSt
Downlink Power Reduction Level (dB) | CALL:TCHannel:PREDuction:LEVel([1]|2)
Unused Downlink Burst Current Absolute Power Level | CALL:TCHannel:POWer[:AMPLitude]:UNUSed?
Unused Downlink Burst Power Reduction Selection | CALL:TCHannel:PREDuction:UNUSed
Adjacent Downlink Burst Current Absolute Power Level | CALL:TCHannel:POWer[:AMPLitude]:ADJacent?
Adjacent Downlink Burst Power Reduction Selection | CALL:TCHannel:PREDuction:ADJacent

Operating Considerations

Any changes to the TCH parameters result in new channel assignments when the mobile station is assigned to a TCH. No new channel assignments are sent to the mobile station when it is assigned to the SDCCH and changes are made to TCH parameters.

When configuring the base station emulator you must configure the broadcast channel (see CALL:BCHannel ) and the traffic channel (TCH). There are a number of parameters for the BCH and the TCH that can be configured; however, the test set's default parameters should allow a properly functioning mobile station to successfully camp on the cell and make a call under most circumstances.

When the Operating Mode is Active Cell and a call is connected, changes to the traffic channel number (ARFCN) or traffic channel timeslot, including a change to the value of the parameter's current setting, causes signaling on the downlink FACCH to initiate a channel reassignment, see How the Test Set Performs a Dualband Handover . This configures the TCH to use the new parameter. If a call is not connected, changes to the parameter are stored for when the next call is established.

When the operating mode is GSM BCH+TCH (see CALL:OPERating:MODE ), changes to the traffic channel number (ARFCN) or traffic channel timeslot will reconfigure the downlink TCH accordingly, but there will be no signaling initiated. The change will be immediate. If a TCH is not being generated, changes to the parameter are stored for when the next call is established.

Mobile Loopback

The loopback type must be set before starting a Fast Bit Error or a Bit Error measurement. A downlink TCH with PRBS data is generated at a known level, and the mobile receives it, loops it back to its transmitter, and returns the PRBS data to the test set. A comparison is then made in the test set between data sent and the data received, and the BER is calculated.

Currently, The test set provides the following loopback types:

  • Loopback type A - BER with Frame Erasure (FE) or Residual BER
    When the mobile loopback is set to type A, the comparison is made between the required class of bits within the 260 bits of speech data presented to the channel coder of the test set and the 260 bits of speech data received by the channel decoder of the test set. The mobile will indicate in the speech frame if the downlink frame was received and was found to have CRC errors which would cause the speech frame to be erased. The mobile indicates this on the uplink by setting all bits in the uplink speech frame to 0.
  • Loopback type B - BER without Frame Erasure (FE) or Non Residual BER
    When the mobile loopback is set to type B, the comparison is made between the required class of bits within the 260 bits of speech data presented to the channel coder of the test set and the 260 bits of speech data received by the channel decoder of the test set. The mobile does not provide any indication of whether or not the downlink speech frame was erased.
  • Loopback type C - Fast BER
    When the mobile loopback is set to type C, the comparison is made between the 114 bits of interleaved data presented to layer 1 in the test set and the 114 bits of interleaved data received by layer 1 in the test set. Note, this loopback type can only be used in the Fast BER measurement.
  • Loopback type D - BER with Frame Erasure and Unreliable Frame Rate Signaling
    The functionality of mobile loopback type D is for the most part identical to that of mobile loopback type A with one exception: loopback type D will include Unreliable Frames Rate (UFR) signaling in addition to the Frame Error Rate (FER). Hence the FER display during mobile loopback type D measurement is actually FER plus UFR.

The GPIB command to set the this parameter is: CALL:TCHannel:LOOPback .

Max Frames Allowed for Assignment Parameter

The Max Frames Allowed for Assignment parameter is used to specify the maximum number of TDMA frames the MS is allowed to take for a channel assignment. This is only applicable to changes in TCH Band, TCH ARFCN or TCH Timeslot. Changes to any other TCH parameter will not cause an error to be generated if the number of frames taken to perform the change exceeds the setting of the Channel Assignment TDMA Frames Allowed parameter. GSM 05.10 specifies a maximum of 26 frames allowed for assignment parameter, (GSM 11.10 extends the allowed period to approximately 28 frames for a channel assignment and approximately 31 frames for a handover), although specific MS implementations may take less. The test set allows you to set the Max Frames Allowed for Assignment parameter with the range of 15 to 999. If the mobile station does not complete the assignment within the user-specified time, the test set will generate a special RR sublayer error "Channel assignment exceeded specified number of frames", see +256 GSM protocol failure; No response to disconnect (Timer T305 expiry) . This is a non-fatal error, and does not cause the call to drop. If the channel assignment seriously fails, and timer T3107 expires, The test set only reports the "channel assignment fail" error and ignore the "Channel assignment exceeded specified number of frames" error. Note that the "Channel assignment exceeded specified number of frames" error is not generated if MS DTX State is "On". (See CALL:MS:DTX[:STATe] ) This is because when a mobile phone is in DTX mode, it is not required to transmit on the new channel, at least not until a SACCH, FACCH, or SID frame is ready and therefore the MS may actually have changed channel in the correct time, but had nothing to transmit.

This parameter is only accessible using the GPIB interface. The GPIB command to set this parameter is CALL:COUNt:TDMA:FRAMes? .

Speech

The downlink speech source controls what kind of speech data is transmitted on the downlink TCH. A TCH with speech data is generated when the call control status is connected (see Call Processing State Synchronization ) or when in GSM BCH+TCH operating mode.

When an FBER measurement is activated, PRBS15 data is transmitted on the downlink TCH, overriding the user setting of the downlink speech source. Any changes to the downlink speech source will be accepted and saved but not applied until the FBER measurement becomes inactive.

The command to set the Downlink Speech Source is CALL:TCHannel:DOWNlink:SPEech . The settings available for the downlink speech are as follows:

  • None

  • Echo

    Retransmits the uplink speech frames back on the downlink with a settable delay of 0 and 1 seconds. The speech echo loopback delay setting can be changed in any operating mode. The speech echo loopback delay can be set regardless of the speech source, however it is only applicable when the speech source is set to Echo .

    The command to set the speech echo loopback delay is CALL:TCHannel:DOWNlink:SPEech:LOOPback:DELay .

  • PRBS15

    The 260 speech frame bits (prior to channel coding) are generated using a pseudo random bit sequence.

  • PRBS 9

    The 114 speech frame bits (without channel coding and interleaving) are generated using a pseudo random bit sequence. PRBS9 is available when the operating mode is set to any operating mode except for GSM BCH, GPRS BCH, EGPRS BCH, Cell Off and CW.

  • SIN300

    The sequence of 260 speech bit frames represent a sine wave at 300 Hz.

  • SIN1000

    The sequence of 260 speech bit frames represent a sine wave at 1000 Hz.

  • SIN3000

    The sequence of 260 speech bit frames represent a sine wave at 3000 Hz.

  • Multi-Tone

    Control of the audio generator is given to the Multi-Tone Audio Instrument.

  • SID (Silence Descriptors)

    Silence Descriptors configure the test set to simulate a base station operating in Discontinuous Transmission (DTX) mode. The parameter is only applicable to the lab applications.

  • CUSTom

    You may set the values that make up the custom payload pattern that is repeated in each speech frame or use the default pseudo random bit sequence (PRBS) custom data pattern. The same custom payload pattern is used for GSM, GPRS and EGPRS connections.

    If you specify a custom payload pattern that is longer than the length of the speech frame, only the portion of the pattern that fits in the speech frame will be used so the end data will not be used. If the custom payload pattern is shorter that the length of the speech frame, the custom payload pattern is repeated as many times as necessary to fill the speech frame.

    There is no access through the front panel to configure the custom payload pattern. The GPIB command to configure the Custom pattern is CALL:TCHannel:CUSTom:DATA . The query for this command returns only the defined custom payload pattern rather than the repeated or truncated pattern used to fit to the size of the speech frame.

Related Topics

Configuring the Broadcast Channel (BCH)

Configuring Mobile Station Operating Parameters

Receiver Control

Traffic Band Parameter

CALL:TCHannel

Fast Bit Error Measurement Description

How Do I Change the Payload Pattern Sent to the Mobile Station?

How Do I Configure the Speech Source?

Frequency Bands

Mobile Calculate BER Test


Test Mode Operating Modes

Test Mode Operating Modes

Last updated: December 2, 2008

The operating mode changes the way in which the test set interacts with the mobile station. Active cell operating mode is the default setting and is used when emulating a normal GSM, GPRS, or EGPRS cell. You use one of the test set's test mode operating modes when it is not possible, or not desired, to communicate using over-the-air signalling with the mobile station, but downlink stimulus and uplink measurements are still needed.

Refer to the following sections for more details on each test mode operating mode:

  • GSM Test Mode Operation
    • GSM BCH
    • GSM BCH+TCH
  • GPRS Test Mode Operation
    • GPRS BCH
    • GPRS BCH+PDTCH
    • GPRS BCH+PDTCH+TCH
  • EGPRS Test Mode Operation
    • EGPRS BCH
    • EGPRS BCH + PDTCH
    • EGPRS BCH + PDTCH + TCH
  • Fast Device Tune
  • Cell Off
  • CW

If you require details on active cell operating mode for GSM or GPRS, see Active Cell Operating Mode .

GSM Test Mode Operation

Active cell mode is the default operating mode and is used when emulating a normal GSM cell. When a GSM test mode is selected (GBTest or GBTTest), the choices of downlink stimulus, selected by Operating Mode, are:

  • GSM BCH (broadcast channel) (see GSM BCH )
  • GSM BCH+TCH (broadcast channel + traffic channel) (see GSM BCH+TCH )

See CALL:FUNCtion for test function GPIB syntax.

When the test set's operating mode is a GSM test mode:

  • No over-the-air signaling is available.
  • No capability to demodulate and decode uplink RACH bursts is available.
  • When the operating mode is set to one of the test modes, auto triggering sets the trigger source to RF Rise. See RF Rise Trigger Source: .

Expected Burst

This parameter is only used when the test set's operating mode is set to a test mode. The expected burst type should be set when in one of the test modes with the CALL:BURSt:TYPE command. If it is not set, the test set may not synchronize to the input signal's midamble.

A TCH can have one of eight midamble patterns. These patterns are called Training Sequence Codes (TSC). The Expected Burst parameter allows you to set the test set to expect a certain midamble pattern (TSC0 through TSC7) from the mobile. Alternatively, selecting RACH for this parameter allows you to set the test set to expect the special midamble pattern used by a RACH burst.

For details on the GPIB command, see CALL:BURSt . (If you are using the test set manually, you can set the Expected Burst by pressing Receiver Control ( F12 ) on the Call Setup screen.)

OUTPUT 714;"CALL:BURST:TYPE TSC5" !Sets the test set to expect a TCH with midamble
    !pattern TSC5.

See Receiver Control for more information.

GSM BCH

  • The test set generates a BCH without a TCH. BCH configuration and timeslot configuration are the same as when the operating mode is set to active cell.
  • Cell power is set using the CALL:POWer command.
  • By default, the test set expects the mobile station to transmit on the uplink BCH. The test set's receiver frequency can be set manually, which de-couples the automatic setting.
  • Changes to the mobile station TX level will couple to the expected power, and the mobile station TX Level parameter will be transmitted on the downlink BCCH.
  • All measurements are available to you as if the operating mode was set to active mode.

BCH Operating Mode Using Auto Receiver Control

The following example shows how to set up a test mode measurement using the GSM BCH test operating mode. In this example the test set is configured to transmit a BCH on PGSM channel 21, and receive the mobile station on PGSM channel 21 at a power level of 12.

  1. Select GSM BCH test mode (GBTest).

OUTPUT 714;"CALL:OPERATING:MODE GBTest"
  2. Select PGSM as the broadcast band.

OUTPUT 714;"CALL:CELL:BAND PGSM"
  3. Configure the receiver control to auto.

OUTPUT 714;"RFANALYZER:CONTROL:AUTO ON"
  4. Set the BCH to channel 21.

OUTPUT 714;"CALL:BCH:PGSM 21"
  5. Set the mobile station TX level to 12.

OUTPUT 714;"CALL:MS:TXLEVEL 12"
  6. To make the measurement, set up the mobile station to transmit on PGSM channel 21 at a power level of 12.

BCH Operating Mode Using Manual Receiver Control

The following example shows how to set up a GSM test mode measurement using the GSM BCH operating mode. In this example the test set is configured to transmit a BCH on PGSM channel 21. Manual receiver control is used to configure the test set to measure a signal from the mobile station at 895 MHz and 14 dBm.

  1. Select GSM BCH test mode.

OUTPUT 714;"CALL:OPERATING:MODE GBTest"
  2. Select PGSM as the broadcast band.

OUTPUT 714;"CALL:CELL:BAND PGSM"
  3. Set the BCH to channel 21.

OUTPUT 714;"CALL:BCH:PGSM 21"

  4. Configure the receiver control to manual.

OUTPUT 714;"RFANALYZER:CONTROL:AUTO OFF"
  5. Configure the test set's receiver frequency to 895 MHz.

OUTPUT 714;"RFANALYZER:MANUAL:MEASUREMENT:FREQUENCY 895 MHZ"
  6. Set the receiver's power level to 14 dBm.

OUTPUT 714;"RFANALYZER:MANUAL:POWER:BURST1 14 DBM"
  7. To make the measurement, set up the mobile station to transmit at 895 MHz and at a power level of 14 dBm.

GSM BCH+TCH

  • The test set generates BCH+TCH on the downlink path. The BCH+TCH burst modulation is the same as when the operating mode is set to active cell.
  • Cell power is set using the CALL:POWer command.
  • Manually synchronizing the mobile station to the BCCH is not under direct control of the test set. You are responsible for this synchronization.
  • Changes to the TCH timeslot and TCH ARFCN will reconfigure the downlink (although no channel assignment signaling will take place).
  • By default, the test set's receiver is configured to receive the mobile station's signal at the TCH uplink frequency. The test set's receiver frequency can be set manually, which decouples the automatic setting.
  • Changes to the mobile station TX level will couple to the expected power, and the mobile station TX Level parameter will be transmitted on the downlink BCCH and SACCH.
  • Changes to TCH timing advance will also appear on the downlink SACCH. Whether the mobile station makes use of these parameters is a function of the mobile station.
  • All measurements are available to you, the same as if the operating mode was active mode.

BCH+TCH Operating Mode Using Auto Receiver Control

The following example shows how to set up a GSM test mode measurement using the "GSM BCH + TCH" (GBTTest) test mode operating mode. In this example the test set is configured to transmit a BCH on PGSM channel 21, a TCH on PGSM channel 31, and receive the mobile station on PGSM channel 31 at power level 12.

  1. Select GSM BCH+TCH test mode.

OUTPUT 714;"CALL:OPERATING:MODE GBTTest"
  2. Configure the receiver control to auto.

OUTPUT 714;"RFANALYZER:CONTROL:AUTO ON"
  3. Set the BCH to channel 21.

OUTPUT 714;"CALL:BCH:PGSM 21"
  4. Set the TCH to channel 31.

OUTPUT 714;"CALL:TCH:PGSM 31"
  5. Set the mobile station TX Level to 12.

OUTPUT 714;"CALL:MS:TXLEVEL 12"
  6. To make the measurement, set the mobile station to transmit on PGSM channel 31 at a power level of 12.

BCH+TCH Operating Mode Using Manual Receiver Control

The following example shows how to set up a GSM test mode measurement using the "GSM BCH+ TCH" (GBTTest) test mode operating mode. In this example the test set transmits a BCH on PGSM channel 21 and a TCH on PGSM channel 31. Manual receiver control is used to configure the test set to measure a signal from the mobile station at 895 MHz. Expected power is set at +14 dBm.

  1. Select GSM BCH+TCH test mode.

OUTPUT 714;"CALL:OPERATING:MODE GBTTest"
  2. Select PGSM as the broadcast band (the TCH will automatically be set to this band).

OUTPUT 714;"CALL:CELL:BAND PGSM"
  3. Set the BCH to channel 21.

OUTPUT 714;"CALL:BCH:PGSM 21"
  4. Set the TCH to channel 31.

OUTPUT 714;"CALL:TCH:PGSM 31"
  5. Configure the receiver control to manual.

OUTPUT 714;"RFANALYZER:CONTROL:MEASUREMENT:FREQUENCY:AUTO OFF"
OUTPUT 714;"RFANALYZER:CONTROL:POWER:AUTO OFF"
  6. Configure the test set's receiver frequency to 895 MHz.

OUTPUT 714;"RFANALYZER:MANUAL:MEASUREMENT:FREQUENCY 895 MHZ"
  7. Set the receivers power level to 14 dBm.

OUTPUT 714;"RFANALYZER:MANUAL:POWER:BURST1 14 DBM"
  8. To make the measurement, set up the mobile station to transmit at 895 MHz and at a power level of 14 dBm.

CW

When the test set's downlink function is set to CW, the test set operates like a signal generator with level and frequency controls. The Call Parms selections change from Cell Power to RF Gen Power, from Cell Band to RF Gen Band, from Broadcast Chan to RF Gen Channel. The CW setting also gives you the opportunity to set output frequency using the RF Gen Freq parameter.

  • The test set generates an unmodulated CW downlink signal.
  • The RF generator's power is set using the CALL[:CELL]:POWer[:SAMPlitude]:CW command.
  • The downlink frequency is controlled by the RF Gen Freq field. The RF generator's frequency is set using the CALL[:CELL]:RFGenerator:FREQuency[:SELected] command, in this mode the user has direct control of the output frequency without making a channel selection.
  • By default, the test set's receiver is configured to receive the mobile station's signal at the current RF generator channel setting. The test set's receiver frequency can be set manually, which decouples the automatic setting. See RFANalyzer:MANual:MEASurement[:MFRequency] .
  • No uplink demodulation or channel decoding is available. BER and uplink audio measurements will not return any results.

CW Operating Mode Using RF Generator Frequency

The following example shows how to set up an operating mode using the CW mode. In this example the test set transmits a CW signal on DCS frequency 1805.4 MHz at an output power level of -80 dBm.

  1. Set the RF generator output power to -80 dBm.

OUTPUT 714;"CALL:CELL:POWER:SAMPLITUDE:CW -80"
  2. Select the CW mode.

OUTPUT 714;"CALL:OPERATING:MODE CW"
  3. Configure the test set's output frequency to 1805.4 MHz.

OUTPUT 714;"CALL:CELL:RFGENERATOR:FREQUENCY 1805.4 MHZ"

GPRS Test Mode Operation

GPRS BCH

When Cell Operating Mode is set to "GPRS BCH" (PBTest) test mode operating mode, the base station emulator produces the BCH but does not attempt to demodulate the uplink. Non-functional features (for example, "Start Data Connection") of the BS Emulator do not result in an execution error.

GPRS BCH+PDTCH

When Cell Operating Mode is set to "GPRS BCH + PDTCH" (PBPTest) test mode operating mode, the base station emulator produces the BCH and PDTCH. To specify the positions of the PDTCH use CALL:(PDTCH|PDTChannel)[:ARFCn][:SELected] and CALL:(PDTCH|PDTChannel):MSLot:CONFig . The locations of the specified uplink are demodulated but no signaling for control of a data connection is performed and PRACH bursts are not demodulated.

In this mode the following features are available:

  • Generation of BCH + PDTCH on the downlink.
  • If you manually synchronize the mobile station with the BCH, and then turn on the mobile station's own PDTCH, and both uplink and downlink use the same ARFCN and timeslot(s), what is sometimes known as a "forced" call is in progress. Demodulation and channel decoding of the uplink are available, although no messages are decoded.

    Manually synchronizing the mobile station to the BCH is usually initiated from the mobile station keypad, or over a special mobile station test bus. This is not under the direct control of the base station emulator and is your responsibility.
  • When a "forced" call is in progress (as defined above), BER and BLER measurements can be made.
  • Changes to the Multislot Configuration or PDTCH ARFCN [PDTCH Band] reconfigure the downlink (although no channel assignment signalling takes place). The BS Emulator's receiver is configured to receive at the modified frequency, timeslot and timing advance in the same way as when Cell Operating Mode is set to "Active Cell" (CELL).

GPRS BCH+PDTCH+TCH

This operating mode supports Dual Transfer Mode (DTM) operation to allow for mobile station receiver testing on adjacent timeslots which use GMSK modulation. The PDTCH channel parameters indirectly control certain TCH parameters. Therefore, some parameters are unavailable in this operating mode. For details on which commands are unavailable, see Commands Disabled During Dual Transfer Mode Operation

Fast Device Tune

See Fast Device Tune .

Cell Off

If you set Cell Operating Mode "OFF" it causes the following actions:

  • If Cell Operating Mode was currently using CALL:OPERating OFF, the setting is ignored and the operation is assumed to have successfully completed immediately.
  • If a mobile station is attached or a data connection is in progress, no attempt is made to use over-the-air signaling to disconnect or detach.
  • All signaling operations, uplink demodulation and downlink (BCH, and PDTCH) generation are stopped.
  • There is no RF power output.

Expected Burst

This parameter is only used when the test set's operating mode is set to "GPRS BCH" (PBTest) or "GPRS BCH + PDTCH" (PBPTest). When operating mode is set to Active Cell, the test set automatically selects the correct burst type.

A PDTCH can have one of eight midamble patterns. These patterns are called Training Sequence Codes (TSC). The Expected Burst parameter allows you to set the test set to expect a certain midamble pattern (TSC0 through TSC7) from the mobile. Alternatively, selecting RACH for this parameter allows you to set the test set to expect the special midamble pattern used by a RACH burst.

For details on the GPIB command, see CALL:BURSt . (If you are using the test set manually, you can set the Expected Burst by pressing Receiver Control ( F12 ) on the Call Setup screen.)

OUTPUT 714;"CALL:BURST:TYPE TSC5" !Sets the test set to expect a TCH with midamble
    !pattern TSC5.

See Receiver Control for more information.

RLC/MAC Header State

This parameter is only used when the test set's operating mode is set to "GPRS BCH + PDTCH" (PBPTest).

The RLC/MAC header state parameter allows you to select whether or not a valid Radio Link Control (RLC)/Medium Access Control (MAC) header is present on the downlink PDTCH burst(s):

  • If the RLC/MAC header state is set to OFF, all 53 octets (for CS4 encoding, for other coding schemes the number of octets will be less) in the burst are filled with PRBS data.
  • If the RLC/MAC header state is set to ON, the first 3 octets in the burst contain a valid RLC/MAC header indicating the burst sequence number and the power reduction value. The remaining 50 octets (for CS4 encoding, for other coding schemes the number of octets will be less) in the burst are filled with PRBS data.

If the RLC/MAC header state is changed when the operating mode is any mode other than GPRS BCH+PDTCH, the setting is remembered until GPRS BCH+PDTCH is next used.

For details on the GPIB command, see CALL:PBPTest:RLCMac[:HEADer]:STATe . (If you are using the test set manually, the RLC/MAC Header field is in the Call Parms window, screen 2 of 3, F10).

OUTPUT 714;"CALL:PBPTest:RLCMac:HEADer:STATe ON" !Enables the RLC/MAC header.

EGPRS Test Mode Operation

EGPRS BCH

When Cell Operating Mode is set to "EGPRS BCH" (EBTest) test mode operating mode, the base station emulator produces the BCH but does not attempt to demodulate the uplink. Non-functional features (for example, "Start Data Connection") of the BS Emulator do not result in an execution error.

EGPRS BCH + PDTCH

When Cell Operating Mode is set to "EGPRS BCH + PDTCH" (EBPTest) test mode operating mode, the base station emulator produces the BCH and PDTCH. To specify the positions of the PDTCH use CALL:(PDTCH|PDTChannel)[:ARFCn][:SELected] and CALL:(PDTCH|PDTChannel):MSLot:CONFig . The locations of the specified uplink are demodulated but no signaling for control of a data connection is performed and PRACH bursts are not demodulated.

In this mode the following features are available:

  • Generation of BCH + PDTCH on the downlink.
  • If you manually synchronize the mobile station with the BCH, and then turn on the mobile station's own PDTCH, and both uplink and downlink use the same ARFCN and timeslot(s), what is sometimes known as a "forced" call is in progress. Demodulation and channel decoding of the uplink are available, although no messages are decoded.

    Manually synchronizing the mobile station to the BCH is usually initiated from the mobile station keypad, or over a special mobile station test bus. This is not under the direct control of the base station emulator and is your responsibility.
  • When a "forced" call is in progress (as defined above), BER and BLER measurements can be made.
  • Changes to the Multislot Configuration or PDTCH ARFCN [PDTCH Band] reconfigure the downlink (although no channel assignment signalling takes place). The BS Emulator's receiver is configured to receive at the modified frequency, timeslot and timing advance in the same way as when Cell Operating Mode is set to "Active Cell" (CELL).

EGPRS BCH + PDTCH + TCH

This operating mode supports Dual Transfer Mode operation to allow for mobile station receiver testing on adjacent timeslots which use different channel coding and potentially different modulation. The PDTCH channel parameters indirectly control certain TCH parameters. Therefore, some parameters are unavailable in this operating mode. For details on which commands are unavailable, see Commands Disabled During Dual Transfer Mode Operation .

OFF Behavior

If you set Cell Operating Mode "OFF" it causes the following actions:

  • If Cell Operating Mode was currently using CALL:OPERating OFF, the setting is ignored and the operation is assumed to have successfully completed immediately.
  • If a mobile station is attached or a data connection is in progress, no attempt is made to use over-the-air signaling to disconnect or detach.
  • All signaling operations, uplink demodulation and downlink (BCH, and PDTCH) generation are stopped.
  • There is no RF power output.

Expected Burst

This parameter is only used when the test set's operating mode is set to "EGPRS BCH" (EBTest) or "EGPRS BCH + PDTCH" (EBPTest). When operating mode is set to Active Cell, the test set automatically selects the correct burst type.

A PDTCH can have one of eight midamble patterns. These patterns are called Training Sequence Codes (TSC). The Expected Burst parameter allows you to set the test set to expect a certain midamble pattern (TSC0 through TSC7) from the mobile. Alternatively, selecting RACH for this parameter allows you to set the test set to expect the special midamble pattern used by a RACH burst.

For details on the GPIB command, see CALL:BURSt . (If you are using the test set manually, you can set the Expected Burst by pressing Receiver Control ( F12 ) on the Call Setup screen.)

OUTPUT 714;"CALL:BURST:TYPE TSC5" !Sets the test set to expect a TCH with midamble
    !pattern TSC5.

See Receiver Control for more information.

Related Topics

Active Cell Operating Mode

Configuring the Broadcast Channel (BCH)

Configuring the Traffic Channel (TCH) Parameters

CALL:OPERating

Receiver Control

Configuring the Packet Data Traffic Channel (PDTCH)

Fast Device Tune


Test Mode Burst Timing Error Measurement

Test Mode Burst Timing Error Measurement

Last updated: December 4, 2008

This section is applicable to the lab application and the test application.

Burst Timing Error (BTE) is the time difference between the expected and calculated sync code location within a burst. The expected sync code location is determined by the uplink slot number. You can enable burst timing error test in the test mode.

With BTE in test modes, BTE measurement result is provided to you only if at least one uplink traffic channel is configured and the mobile transmits on the uplink traffic channel. If no uplink transmission is detected, NAN is returned indicating burst timing error result.

The command to set the Test Mode BTE state is CALL:FUNCtion:TBTerror[:STATe] .

How do I configure the Test Mode Burst Time Error parameters?

This procedure describes how you manually configure the Test Mode BTE parameters.

  1. Press CALL SETUP .
  2. Press the left More key until screen 2 of 2 of the Control menu is displayed.
  3. Press Protocol Control ( F4 ).
  4. Press Layer 1 ( F1 ).
  5. Press Test Mode BTE State ( F3 ). This displays the Test Mode BTE State menu.
  6. Use the knob to highlight the parameter and to change the parameter setting.

Operating Considerations

The Test Mode BTE is not available in Cell Off and CW operating mode.

The Test Mode BTE is only used for normal bursts.

BTE in test modes can increase the test speed in manufacturing.

When there are no uplink signals on PDTCH or TCH in test modes for more than 480ms, no Burst Timing Error result is available.

Related Topics

Protocol Control

CALL:FUNCtion:TBTerror[:STATe]


Training Sequence Code (TSC)

Training Sequence Code (TSC)

Last updated: December 2, 2008

A (PD)TCH can have one of eight midamble patterns. These patterns are called Training Sequence Codes (TSCs). The test set's BCC and Expected Burst parameters must be set to the TSC used by the mobile station in order for the test set to synchronize with the mobile station.

  • Expected Burst

    This parameter only applies when the Operating Mode is set to one of the Test Mode Operating Modes . The Expected Burst parameter allows you to configure the test set to decode a certain uplink midamble pattern (TSC0 through TSC7). Alternatively, selecting RACH for this parameter allows you to set the test set to expect the special midamble pattern used by a RACH burst. The Expected Burst TSC can be set with the CALL:BURSt:TYPE[:SELected] command. If the Expected Burst TSC is not set, the test set may not synchronize to the mobile station's input signal.

  • BCC (Base Station Colour Code)

    The BCC (Base Station Color Code) parameter allows you to configure the test set to generate a certain downlink TSC (0 through 7). The command to set this parameter is CALL[:CELL]:BCCode .

    When the Operating Mode is set to one of the Test Mode Operating Modes or Active Cell Operating Mode , both the BCC (Base Station Color Code) and the Expected Burst must be set to the same TSC value on the test set that your mobile station uses. This ensures synchronization between the test set and the mobile station.

    NOTE
    The test set will only synchronize to the mobile station when the Operating Mode is set to Active Cell (GSM, GPRS or EGPRS) if the Expected Burst matches the BCC (Base Station Colour Code) .

See How Do I Set the Training Sequence Code (TSC)? for a detailed procedure on how to manually configure the uplink and downlink TSCs.

How Do I Set the Training Sequence Code (TSC)?

This section details how to set the Training Sequence Code (TSC). When the test set's operating mode is a test mode, you must set both the downlink and uplink TSC. The uplink TSC is set by following the Expected Burst Procedure , and the downlink TSC is set by following the BCC (Base Station Colour Code) Procedure parameter.

When the test set's operating mode is Active Cell , the test set utilizes the value that the BCC (Base Station Colour Code) parameter is set to for both the uplink and downlink TSC. That is, the mobile station transmits the uplink TSC to match the BCC setting.

BCC (Base Station Colour Code) Procedure

This procedure details how to set the BCC (Base Station Colour Code) parameter. (This parameter is the same as the downlink TSC and the downlink midamble.)

  1. Press the CALL SETUP screen key.
  2. Press Operating Mode ( F1 ), and use the knob to highlight and select Cell Off.
  3. Press Cell Info ( F6 ).
  4. Press Cell Identification ( F3 ). Use the knob to highlight and select BCC (Base Station Colour Code). The value that you set the BCC parameter to is the downlink Training Sequence Code (TSC).
  5. Press Close Menu ( F6 ).
  6. Press Return ( F6 ) to go back to the Call Setup Screen .
  7. Press Operating Mode ( F1 ), and use the knob to highlight and select an Active Cell Operating Mode or Test Mode Operating Mode.

    NOTE
    The test set will only synchronize to the mobile station when the Operating Mode is set to Active Cell (GSM, GPRS or EGPRS) if the Expected Burst matches the BCC (Base Station Colour Code) .

    Also, the default value for the BCC is 5. This setting for the BCC (or downlink TSC) must match the downlink TSC used by your mobile station.

Expected Burst Procedure

This procedure is only applicable when the test set is in one of the Test Mode Operating Modes .

This procedure details how to set the Expected Burst parameter.The setting for this parameter is the setting for the uplink TSC. When the test set is in one of the test mode operating modes or active cell operating mode, the downlink TSC (see BCC (Base Station Colour Code) Procedure ) must match the uplink TSC.

  1. Press the CALL SETUP screen key.
  2. Press Operating Mode ( F1 ), and use the knob to highlight and select one of the Test Mode Operating Modes (depending on your requirements) .
  3. Press Receiver Control ( F12 ). Use the knob to highlight and change the Expected Burst. The value that you set the Expected Burst parameter to is the uplink Training Sequence Code (TSC).
  4. Press Close Menu ( F6 ).

Related Topics

Troubleshooting Training Sequence Code


Two-Cell Test System Ladder Diagrams

Two-Cell Test System Ladder Diagrams

Last updated: December 2, 2008

This section is only applicable to the Lab Applications.

Description

  • Mobile-Initiated Cell Reselection from W-CDMA/HSPA to GSM/GPRS/EGPRS or W-CDMA/HSPA (Idle Mode: Camped or Attached)
  • Mobile-Initiated Cell Reselection from GSM/GPRS/EGPRS to W-CDMA/HSPA (PDP Active, with or without Data Flow)
  • Network-Initiated Cell Reselection from W-CDMA/HSPA to GSM/GPRS/EGPRS (PDP Active, with or without Data Flow)
  • Network-Initiated Cell Reselection from GSM/GPRS/EGPRS to W-CDMA/HSPA (PDP Active, with or without Data Flow)
  • Network-Initiated Handover from W-CDMA/HSPA to GSM/GPRS/EGPRS
  • Network-Initiated Handover from GSM/GPRS/EGPRS to W-CDMA/HSPA

Mobile-Initiated Cell Reselection from W-CDMA/HSPA to GSM/GPRS/EGPRS or W-CDMA/HSPA
(Idle Mode: Camped or Attached)

Mobile-Initiated Cell Reselection from GSM/GPRS/EGPRS to W-CDMA/HSPA
(PDP Active, with or without Data Flow)

Network-Initiated Cell Reselection from W-CDMA/HSPA to GSM/GPRS/EGPRS
(PDP Active, with or without Data Flow)

Network-Initiated Cell Reselection from GSM/GPRS/EGPRS to W-CDMA/HSPA
(PDP Active, with or without Data Flow)

Network-Initiated Handover from W-CDMA/HSPA to GSM/GPRS/EGPRS

Network-Initiated Handover from GSM/GPRS/EGPRS to W-CDMA/HSPA

Related Topics

Two-Cell Test System


Two-Cell Test System

Two-Cell Test System

Last updated: December 2, 2008

This section is only applicable to the Lab Applications.

Description

The range of transmission of a battery-powered mobile device is limited. Hence for good coverage, it is necessary for the mobile to efficiently move from one cell to another as it roams around the network. The mobile must transition to new cells as users cross cell boundaries and RF conditions in the current cell degrade. Some cell transitions can be performed autonomously by the mobile, as a result of the measurements it has made on its serving cell and the surrounding cells. Cell transitions may also be ordered by the network based on measurement reports from the mobile (note that in the two-cell test system, you must order the network-initiated cell transitions; it is not possible for the test sets to automatically order the transitions based on measurement reports from the mobile).

As a mobile moves around the network, it constantly updates the network by sending measurement reports regarding the serving cell as well as any neighbor cells specified in the serving cell's neighbor cell list. When the mobile is idle (not sending data), it can easily measure the RF conditions of the current cell and surrounding neighbor cells. While transmitting data, a GSM/GPRS/EGPRS mobile must make measurements in free timeslots, a W-CDMA/HSPA mobile must use compressed mode to make measurements on surrounding cells, or simply perform "blind" handovers (handover as directed by the network, without first measuring the target cell).

The two-cell test system provides a way to test a mobile's cell transition and cell selection procedures between cells of the same or different Radio Access Technologies (RATs). Cell selection and transition procedures are documented in 3GPP TS 51.010 (GSM/GPRS/EGPRS), and 3GPP TS 34.121 section 8 and 34.123 (W-CDMA/HSPA). GSM/GPRS/EGPRS mobile measurements for cell reselection, the criteria for cell selection and reselection, and cell reselection algorithms that determine when to initiate the cell transition process are defined in 3GPP TS 05.08. W-CDMA/HSPA cell reselection information is available in 3GPP TS 25.304.

Overview of Cell Transitions

This section describes various cell transitions that a mobile may perform, either autonomously (without being ordered by the network) or by network initiation. Cell transitions may occur while the mobile is in idle mode or actively transferring data.

Cell selection does not involve transitioning between cells; rather, it is the process by which the mobile selects a serving cell once it has completed its power-up sequence. When the mobile is powered on, it must determine which cell to camp to (register with and/or attach to).

Handover refers to a cell transition that occurs when a circuit-switched (CS) connection is in place (such as CS voice, CS data, or Dual Transfer Mode). Handovers can only be initiated by the network. During a handover, the network sends the mobile a Handover command, which provides information about the destination cell, including the traffic channel configuration (in the two-cell test system, this information is determined by the destination test set's current configuration; the originating test set retrieves this information from the destination test set before ordering the handover).

For a GSM/GPRS/EGPRS DTM (Dual Transfer Mode) connection (wherein the mobile simultaneously has a CS voice call and a packet-switched data connection), the network sends a Handover command to transition the CS connection, but the mobile is responsible to abort the PS (packet-switched) connection and re-establish the PS data flow after arriving at the new cell. If DTM is not supported in the new cell, the mobile performs the cell change and drops the PS data connection.

Handovers Available in the Two-Cell Test System
 |  | Destination cell : GSM/GPRS/EGPRS |  | Destination cell : W-CDMA/HSPA
 | Mobile State | Network-Initiated | Mobile-Initiated | Network-Initiated | Mobile-Initiated
Originating cell : GSM/GPRS/EGPRS | CS Voice | Yes | N/A 1 | Yes | N/A 1
 | CS Data | No |  | No
 | Dual Transfer Mode | Yes |  | Partial 2
Originating cell : W-CDMA/HSPA | CS Voice | Yes |  | No
 | CS Data | No |  | No
 | Simultaneous Services | No |  | No
1 Handovers can only be initiated by the network, as defined by 3GPP. 2 Because simultaneous services in the W-CDMA/HSPA application does not support two-cell test system handovers, when you handover a GSM/GPRS/EGPRS DTM connection to a W-CDMA/HSPA cell, the voice portion of the connection is handed over and the data portion should be suspended by the mobile.

Cell reselection is the process of changing the mobile's serving cell (either in idle mode or while actively transmitting data). Cell reselections can be initiated by the mobile or network. When the network initiates a cell reselection, it sends a Packet Cell Change Order (GPRS/EGPRS) or a Cell Change Order (W-CDMA/HSPA), which provides the parameters necessary for the mobile to find and synchronize to the destination cell. If the mobile was actively transferring data at the time of the cell reselection, any subsequent allocation of traffic channel resources to continue the packet data transfer are handled by signaling between the mobile and destination cell, and does not involve the origination cell.

Idle mode cell reselection refers to cell transitions that occur when the mobile is in idle mode.

In mobile-initiated idle mode cell reselection, the mobile decides on the basis of its own measurements to move from one cell to another to achieve improved RF quality. The network is not aware of the reselection until the mobile appears on the destination cell. The alternate cells a mobile may search for and transition to are determined by the serving cell's broadcast list of neighbors.

In network-initiated idle mode cell reselection, the network orders the mobile to transition to a new cell while in idle mode, using a Packet Cell Change Order (PCCO) or a Cell Change Order (CCO).

Idle Mode Cell Reselections Available in the Two-Cell Test System

Destination cell : GSM/GPRS/EGPRS Destination cell : W-CDMA/HSPA

Mobile State Network-Initiated Mobile-Initiated Network-Initiated Mobile-Initiated
Originating cell : GSM/GPRS/EGPRS | Camped but not attached | N/A 1 | Yes | N/A 1 | Yes
Attached | Yes | Yes | Yes | Yes
PDP active | Yes | Yes | Yes | Yes
Originating cell : W-CDMA/HSPA | Camped but not attached | N/A 2 | Yes | N/A 2 | Yes
Attached | Yes | Yes
PDP active (but not actively transferring data) | Yes | N/A 3 | No | N/A 3

1 In a GSM/GPRS/EGPRS cell, network-initiated cell reselection is only possible when the mobile is attached or PDP active, as defined by 3GPP.

2 In a W-CDMA/HSPA cell, for Release 99 mobiles, network-initiated cell reselection is only possible when the mobile is PDP active, as defined by 3GPP.

3 Mobile-initiated cell reselection is not possible from a W-CDMA/HSPA cell when the mobile is PDP active in CELL_DCH, as defined by 3GPP. Note that if you turn off the serving W-CDMA/HSPA test set's cell power, the mobile will find the other test set and establish radio resources with it to continue data transfer on the existing PDP context; however, this is not the same as a mobile-initiated reselection to the other test set.

PS data transfer mode cell reselection refers to cell transitions that occur when the mobile is PDP active and actively transferring PS data (such as GPRS, HSPA, or W-CDMA PS data). Whether the cell reselection is initiated by the mobile or by the network, the mobile is responsible for aborting the current data flow and restarting it upon arrival in the new cell. Any data packets routed to the old cell are lost and it is assumed that the higher layer protocol that was generating packets manages retransmission of any lost data to the mobile once it complete its transition to the new cell. A cell update procedure is performed by the mobile upon arrival to the new cell. The new cell is not responsible for re-establishing the PDP context, but rather the mobile or the network entity it was communicating with (for example, FTP server).

In network-initiated PS data transfer mode cell reselections, the current serving cell sends the mobile a PCCO or CCO to command it to change cells.

PS Data Transfer Mode Cell Reselections Available in the Two-Cell Test System
 |  | Destination cell : GSM/GPRS/EGPRS |  | Destination cell : W-CDMA/HSPA
 | Mobile State | Network-Initiated | Mobile-Initiated | Network-Initiated | Mobile-Initiated
Originating cell : GSM/GPRS/EGPRS | Actively transferring PS Data | Yes | Yes | Yes | Yes
Originating cell : W-CDMA/HSPA | Actively transferring PS Data | Yes | N/A 1 | No | N/A 1
1 Mobile-initiated cell reselection is not possible from a W-CDMA/HSPA cell when the mobile is PDP active in CELL_DCH, as defined by 3GPP. Note that if you turn off the serving W-CDMA/HSPA test set's cell power, the mobile will find the other test set and establish radio resources with it to continue data transfer on the existing PDP context; however, this is not the same as a mobile-initiated reselection to the other test set.

Two-Cell Test System Overview

You can connect two test sets via an External Device Connection to test your mobile's cell selection and cell transition behavior. The test sets can be configured to emulate two GSM/GPRS/EGPRS cells, or one GSM/GPRS/EGPRS cell and a W-CDMA/HSPA cell (the appropriate lab application must be installed on each test set). At this time you cannot emulate transitions between two W-CDMA/HSPA cells.

Once the system is configured (see Two-Cell Test System Physical Layout and Requirements ) and the mobile is powered on, the mobile performs the cell selection process by selecting one of the test sets in the system with which to communicate. After the mobile has camped on a test set, the mobile's cell transition procedures are ready to be tested.

To influence mobile-initiated cell transitions, you can change the properties of each cell (such as lowering, or turning off Cell Power in one of the test sets, or changing Cell Parameters , Reselection Parameters and Access Restriction Parameters ). Note however that to cause a network-initiated cell transition, you must manually order the transition using the Execute External 8960 Handover immediate action ( CALL:HANDoff:EXTernal[:IMMediate] ). The test sets do not automatically order cell transitions based upon the mobile's measurement reports, you must initiate the transition. However, you can monitor the mobile's measurement reports on the test sets as you change the properties of the two-cell system.

Two-Cell Test System Physical Layout and Requirements

The figure below shows the recommended system layout of the two-cell test system.

The requirements for the physical layout of the two-cell test system are as follows:

  • Two Test Sets

    The two-cell test system requires two test sets which emulate the two cells for the mobile to transition between. The inter-RAT two cell test system scenarios assume that one test set is running a GSM/GPRS/EGPRS application/format while the other is running a W-CDMA/HSPA application/format.

  • Ethernet (LAN) Connection

    The two-cell test system relies on an ethernet connection ( External Device Connection ) between the two test sets to allow them to exchange control messages during cell reselections and handovers. Before establishing the External Device Connection , you must set Ext 8960 IP Addr to the LAN IP Address of the other test set. You must also set DUT IP Address to a different value in each test set.

    It is recommended that you connect the test sets via an ethernet switch or hub, rather than through a gateway or WAN link, to minimize the chance of data loss due to delayed packets. You can also connect the test sets directly via a cross-over cable, however it is then not possible to capture any protocol message logs from the Wireless Protocol Advisor (WPA), or to communicate with external servers.

  • RF Interface

    The mobile must be able to communicate with both test sets. To accomplish this, it is recommended that you use an RF splitter to connect the mobile to both test sets simultaneously.

  • GPIB Connection

    GPIB connection between both test sets and a controlling PC are necessary if remote control of the instruments in the system is required.

  • Ethernet Switch or Hub

    An Ethernet switch or hub is needed in order for the mobile to connect to external servers as well as for connecting the PC running WPA to the test sets.

Operating Considerations

  • Important : DUT IP Address must be set to a different value in each test set in the two-cell test system.
  • The operating mode in both test sets must be set to Active Cell in order to perform cell transitions, as this is the only operating mode that provides signaling to the mobile.
  • While operating in the GSM/GPRS/EGPRS application/format, the connection type must be set to Auto in both test sets of the two-cell test system in order to maintain IP-based data connections during cell reselection. Any other connection type setting terminates the active data connection during cell reselection and does not restart the data connection once cell reselection is complete.
  • The DUT IP Address setting is inaccessible if the mobile is connected to the current test set but using an IP address originally assigned by the other test set. Refer to the External Device Connection documentation ("DUT IP Address Information") for additional information.
  • It is recommended that you configure the neighbor cell list in each test set to contain the other test set's information (using the SIB 11 Cell Info List in W-CDMA/HSPA or the Cell Lists in GSM/GPRS/EGPRS). This enables the mobile to measure the other test set before transitioning to it (some mobiles will not perform a "blind" handover) and allows you to view the mobile's measurement reports for the test set. Ensure that you have properly configured the mobile measurement reports to match the destination test set's configuration (using the Compressed Mode settings in W-CDMA/HSPA or the Measurement Reports settings in GSM/GPRS/EGPRS).
  • Network Control Order in the GSM/GPRS/EGPRS application determines how the mobile should perform cell reselections. If Network Control Order is set to NC0 or NC1 in the test set to which the mobile is currently attached, it may not respond to network-initiated attempts at cell reselection. Also, if the test set to which the mobile is attached has Network Control Order set to NC2 , the mobile may not perform autonomous cell reselection.

Related Topics

How Do I Set Up and Test Cell Selection and Transitions?

Troubleshooting the Two-Cell Test System

Two-Cell Test System Ladder Diagrams

External Device Connection

DUT IP Address

GSM/GPRS/EGPRS Cell Configuration

  • Cell Parameters
  • Cell Identification Parameters

W-CDMA/HSDPA Cell Configuration

  • Cell Parameters
  • Cell Reselection Parameters
  • Cell Access Restriction Parameters

GSM/GPRS/EGPRS Neighbor List Configuration

  • Cell Lists

W-CDMA/HSDPA Neighbor List Configuration

  • SIB11 Cell Info List

GSM/GPRS/EGPRS Mobile-Reported Measurement

  • Measurement Reports

W-CDMA/HSDPA Mobile-Reported Measurement

  • UE Reported Measurements


Bursted Parameters

Bursted Parameters

Last updated: December 2, 2008

This section is not applicable to GSM.

The majority of the test set's base station emulator parameters allow you to set or query a single value which is applied to all allowed burst (or timeslot) locations. However, there are a number of parameters for GPRS and EGPRS that have a :BURSt suffix. The :BURSt suffix indicates that the parameter name refers to a set of parameters, one for each of the possible bursts. These are called bursted parameters.

Bursted parameters use the concept of an active burst. An active burst is a timeslot that is expected to contain RF power relating to a traffic channel based on the multislot configuration. Bursted parameters are activated when the burst you have set a value for becomes active.

Bursted parameters are useful when changing the multislot configuration. For example, they allow you to specify the uplink burst TX level for a burst that is not currently active.

The GPIB command for each bursted parameter lets you specify one of the allowable bursts. If you do not specify a burst number, then burst one is assumed. The burst numbers you specify are relative from the first active uplink or downlink burst.

GPRS and EGPRS Bursted Parameters
Parameter | GPIB Command
Downlink Burst Absolute Power Level | CALL:(PDTCH|PDTChannel):POWer[:AMPLitude]:BURSt<[1]|2|3|4|5>?
Downlink Burst Power Reduction Selection | CALL:(PDTCH|PDTChannel):PREDuction:BURSt<[1]|2|3|4|5>
Manual Receiver Power Level | RFANalyzer:MANual:POWer:BURSt<[1]|2|3|4|5|6|7>
Uplink Burst TX Level | CALL:(PDTCH|PDTChannel):MS:TXLevel[:SELected]:BURSt<[1]|2|3|4|5>
Modulation Coding Scheme/Puncturing Scheme | CALL:(PDTCH|PDTChannel):MCSCheme:EBPTest:BURSt<2|3|4|5>
Gamma | CALL:(PDTCH|PDTChannel):MS:GAMMa:BURSt<[1]|2|3|4|5>[:SELected]

Operating Considerations

The following bursted parameters are also frequency banded parameters (see Frequency Banded Parameters ):

  • Uplink Burst TX Level
  • Manual Receiver Power Level

Related Topics

Configuring the Packet Data Traffic Channel (PDTCH)


Call Processing Ladder Diagrams

Call Processing Ladder Diagrams

Last updated: December 2, 2008

The following diagrams illustrate the procedures used by the test set for several key call processing operations.

  • Mobile Originated Call Procedure
  • Mobile Terminated Call Procedure
  • Combined LA/RA Procedure
  • Combined GPRS/IMSI Attach Procedure (for class A and B mobiles)
  • PDP Context Activation Procedure (mobile station originated)

Mobile Originated Call Procedure

Mobile Terminated Call Procedure

Combined LA/RA Procedure

Combined GPRS/IMSI Attach Procedure (for class A and B mobiles)

PDP Context Activation Procedure (mobile station originated)


Real-Time Vocoder

Real-Time Vocoder

Last updated: December 2, 2008

This section is only applicable to the lab applications and the test application with a required feature license.

  • Overview
  • Setting Real-Time Vocoder Parameters
  • Real-Time Vocoder Headroom Information
  • Operating Consideration

Overview

The real-time vocoder functionality allows you to perform the functional test for the analog voice capability of the mobile station. When the test set is configured in real-time vocoder mode.

  • the test set can real-timely encode the analog audio signal applied at the test set's AUDIO IN connector using the appropriate vocoder algorithm (depending upon the selected voice service option) and then sends the encoded audio frames to the mobile station. See A Simplified Signal Flow for Real-Time Encoding .
  • Also, the test set can simultaneously decode the encoded audio frames that is received on the traffic channel using the appropriate vocoder algorithm (depending upon the selected voice service option) and then converts to an analog signal output at the test set's AUDIO OUT connector. See A Simplified Signal Flow for Real-Time Decoding .

A Simplified Signal Flow for Real-Time Encoding

A Simplified Signal Flow for Real-Time Decoding

Setting Real-Time Vocoder Parameters

The following parameters can be set from the Real-Time Vocoder Parameters menu. To access the Real-Time Vocoder Parameters menu, see How Do I Use Real-Time Vocoder? .

  • Expected Audio In Peak Voltage

    Sets the peak voltage of the analog audio signal that is applied at the test set's AUDIO IN connector when the test set is in the real-time vocoder mode. It is used to adjust the audio input path gain for real-time encoding. Whenever you change this setting, it is not applied until the test set is set to the real-time vocoder mode.

    GPIB command: CALL:RTVocoder:INPut:VOLTage[:EXPected][:SELected]

  • Maximum Audio Out Peak Voltage

    Sets the maximum peak voltage of the analog audio signal that is expected to output at the test set's AUDIO OUT connector when the test set is in the real-time vocoder mode. Whenever you change this setting, it is not applied until the test set is set to the real-time vocoder mode.

    Setting this value makes the test set adjust the audio output path gain to achieve the desired audio output level at the test set's AUDIO OUT port. However, the actual output signal also depends on the voice signal decoded from the received voice data. The decoded signal may not be normalized to DAC (Digital to Analog Converter) full scale range. So it is possible that the final signal level is lower than the configured level.

    GPIB command: CALL:RTVocoder:OUTPut:VOLTage[:MAXimum][:SELected]

  • Voice Activity Detection (VAD) Algorithm

    Sets the VAD Algorithm used in the speech codec. The process of separating conversational speech and silence is called the Voice Activity Detection (VAD). The primary function of a voice activity detector is to provide an indication of speech presence in order to facilitate speech processing as well as possibly providing delimiters for the beginning and end of a speech segment. Refer to 3GPP TS 26.094 section 3 and 4 for more information about the VAD options.

    GPIB Command: CALL:RTVocoder:VADetection:AMRate:ALGorithm[:SELected]

  • Voice Activity Detection (VAD) State

    Sets whether or not the voice activity detection is implemented in the speech codec.

    GPIB Command: CALL:RTVocoder:VADetection[:STATe][:SELected]

Real-Time Vocoder Headroom Information

The following results are displayed on the Real-Time Vocoder Information window when a voice call is established and the test set is in the real-time vocoder mode.

  • Encoder Headroom

    Indicates the headroom of the audio samples to the full scale of the ADC (Analog to Digital Converter). This result is updated at about one second period and calculated as follows:

    Encoder Headroom (dB) = 20 *Log ((ADC full scale) / (maximum absolute value of the input sample))

    When the input signal is over-range, the headroom is clipped to zero.

    GPIB command: CALL:RTVocoder:ENCoder:HEADroom[:SELected]?

  • Decoder Headroom

    Indicates the headroom of the decoded data samples to the full scale of the DAC (Digital to Analog Converter). This result is updated at about one second period and calculated as follows:

    Decoder Headroom (dB) = 20 *Log ((DAC full scale) / (maximum absolute value of the output sample)).

    GPIB command: CALL:RTVocoder:DECoder:HEADroom[:SELected]?

Operating Consideration

  • The Operation Mode must be set to Active Cell to use with the real-time vocoder.

  • The real-time vocoder can work along with the complementary Digital Audio Interface to perform live end to end testing (including microphone and loudspeaker if desired). See Digital Audio Interface (DAI) Description .

    Real-Time Vocoder Audio Path
  • The real-time vocoder supports all current Logical Speech Channels. See Table 1: Logical Speech Channels .
  • The test set is configured in real-time vocoder mode when the Speech Source is set to "Real-Time Vocoder".
  • When the Speech Source is set to Real-Time Vocoder , all of the measurements and instruments except for the Frame Error Rate measurement, Audio Generator and Data throughput Monitor, are unavailable. This is because many of the DSP resources are consumed to meet the real-time requirements for vocoder frame delivery or analog audio generation.
  • When the Speech Source is set to Real-Time Vocoder , you can not change the audio source parameters such as output level and the source to be routed to the AUDIO OUT connector (see AFGenerator Subsystem ).
  • When the input signal is over-range, the headroom value is equal to zero.

Related Topics

How Do I Use Real-Time Vocoder?


Channel Mode Setup

Channel Mode Setup

Last updated: December 2, 2008

This section is only applicable to GSM.

The channel mode function allows you to command a mobile to switch between the available channel modes either before a call is originated, or while a call is connected with any or all of the supported measurements running. In half rate speech mode you can also set the half rate sub channel. Table 1: Logical Speech Channels contains all the Logical Speech Channel modes available.

If you change the channel mode when no call is connected, the mobile is requested to go into the selected channel mode the next time a mobile originated or mobile terminated call is initiated.

If you change the channel mode when a call is connected, the mobile is requested to go into the selected channel mode immediately.

You should only change the channel mode when the test set is in active cell operating mode.

Table 1: Logical Speech Channels

Logical Speech Channel | Default | GPIB Command
FS (Full), EFS (Enhanced Full), HS (Half), AFS (Adaptive Full), AHS (Adaptive Half), WFS (AMR-WB Full) | FS (Full) | CALL:TCHannel:CMODe:LSPeech:CHANnel

The following measurements are supported in enhanced full rate, full rate and half rate speech modes:

  • Analog Audio (AAUDio)
  • GSM Bit Error
  • GSM Fast Bit Error (FBERror)
  • Dynamic Power (DPOWer)
  • I/Q Tuning (IQTuning)
  • Output RF Spectrum (ORFSpectrum)
  • Phase and Frequency Error (PFERror)
  • Power versus Time (PVTime)
  • Transmitter Power (TXPower)

You can initiate a Decoded Audio (DAUDio) measurement in enhanced full rate and half rate speech modes. However, this measurement is not supported in this channel mode and the integrity indicator will report that the results are questionable (see Decoded Audio Troubleshooting ).

The following measurement is also supported in AFS (Adaptive Full) and AHS (Adaptive Half) speech modes:

  • AMR In-Band Frame Error (IFER)

If the mobile station is not capable of performing a loopback type I, meaningful results will not be generated for the IFER measurement. Also, if the Speech Frame Delay is set to Auto, the IFER measurement will not begin at all if the mobile station does not support loopback type I. See In-Band Frame Error (IFER) Measurement Description .

If you switch the channel mode between the different speech modes when the downlink speech source is set to Echo (see CALL:TCHannel:DOWNlink:SPEech ), you may hear momentary audio bursts from the mobile.

The Channel Mode can be manually selected by navigating to the TCH Parms menu, and pressing Channel Mode Setup ( F11 ). The TCH Parms menu is accessed by pressing F8 on the Call Parms menu, see How Do I Change Call Parameters? .

Related Topics

Programming a Channel Mode Change


Front Panel Connectors

Front Panel Connectors

Last updated: December 2, 2008

Description

AUDIO IN

The input to the audio analyzer is a floating input differential amplifier. Both the AUDIO IN High and AUDIO IN Low BNC connectors should be connected to provide noise immunity. Refer to the Technical Specifications in the Application Datasheet for more information.

AUDIO OUT

This BNC connector accesses the test set's Audio Generator and FM Demod signals. The Audio Generator is used to stimulate a system to measure audio performance characteristics. The FM Demod allows the user to access the demodulated FM signal for external analysis and baseband processing. Refer to the Technical Specifications in the Application Datasheet for more information.

NOTE
There will be no guaranteed performance for the signal present at the AUDIO OUT connector when FM Demod signal is selected for output.

DATA

This RJ-45 connector provides front panel access to the rear panel LAN connection. This connector is used for downloading firmware upgrades, or new test applications into the test set. No other types of communication are possible with the LAN port.

The the DATA connector on the front panel is connected internally to the ETHERNET TO FRONT PANEL connector on the rear panel. In order to use the front panel DATA connector, connect the rear panel LAN PORT, to the rear panel ETHERNET TO FRONT PANEL connector with the LAN jumper cable.

The LAN jumper cable, part number E5515-61160, is supplied with the test set.

DVM

Not functional for this release.

RF IN/OUT

This Type-N connector is the default path for all RF signals out of the test set, and is always used as the RF input. Refer to the Technical Specifications in the Application Datasheet for more information. See also RF OUT ONLY .

RF OUT ONLY

NOTE
This port cannot be used with the E1960A GSM test application or with the GSM personality in a test application suite (such as the E1985A GSM_AMPS/136_GPRS suite).

This Type-N connector is an optional path for all RF signals out of the test set. It is intended to be used for duplexed testing. Front panel selection of this port is provided by the RF Output Port ( F6 ) control on the System Config screen, and by the RFGenerator:OUTPut[:DESTination] IO/OUT command. The same amplitude offsets and output power settings are used for either selected port (RF IN/OUT or RF OUT ONLY). Refer to the Technical Specifications in the Application Datasheet for more information.

Related Topics

Analog Audio Measurement Description


Help Mode

Help Mode

Last updated: December 2, 2008

Description

This section explains:

  • What is Help Mode?
  • How do I use the help mode?

What is Help Mode?

The help mode implemented in your test set provides context sensitive GPIB command syntax assistance. When you put the test set into help mode, the test set displays the GPIB command syntax necessary to perform an action remotely for each action you perform from the front panel.

For example, if you put the test set into help mode and then select the test set's GPIB address, the GPIB command syntax for changing it remotely appears in the bottom left hand corner of the test set's screen.

NOTE
Operating the test set in Help Mode does not prevent you from changing parameters from the front panel. The parameters you change while in Help Mode are applied just as they would be normally.

How do I use the help mode?

  1. Put the test set into help mode by pressing the HELP key on the front panel.

    The Help annunciator should now be displayed in the bottom of the screen.

  2. Navigate to the screen and perform the action for which you would like to know the GPIB command syntax. For example, you could navigate to the Audio Generator instrument, and select Frequency ( F3 ). The GPIB command syntax to perform this action remotely appears in the bottom left of the screen.

    Refer to the user documentation on each command for more information.


Receiver Sensitivity Testing in GPRS and EGPRS

Receiver Sensitivity Testing in GPRS and EGPRS

Last updated: December 2, 2008

This section is not applicable to GSM.

The test set can be used to perform receiver sensitivity testing on GPRS mobiles in a number of ways. This section provides a comparison of the BER and BLER measurements, and looks at the different testing methods and configurations that can be used to verify the performance of a mobile's receiver. The section contains:

  • BER and BLER Testing Overview
  • Standards Definition for Reference Sensitivity
  • Different Test Configurations
  • Testing Multislot Configurations with Power in Adjacent Downlink Timeslots

ETSI standards referred to in this section are the Release 99 versions of 4.14, 5.02, 5.03, 5.05 and 11.10. The ETSI GSM 11.10 standard has now been superseded by 3GPP 51.010.

BER and BLER Testing Overview

Traditionally, GSM mobile receiver sensitivity testing is done using bit error rate (BER) testing. In the case of GPRS and EGPRS, the standards refer to the use of Block Error Rate (BLER) rather than BER.

BLER is similar to BER, but the resolution is at a block, rather than a bit level. A block consists of four radio bursts. The number of data bits in a block depends on the channel-coding scheme that is in use. There are four different channel coding schemes (CS-1 through CS-4) with varying levels of error protection used within GPRS. Similarly for EGPRS, there are nine different modulation and coding schemes (MCS-1 through MCS-9) using different modulation combined with varying levels of error protection. The reference sensitivity for mobiles varies depending on the coding scheme that is in use and the power class of the mobile (that is, the maximum power that it transmits.)

In a BER measurement, the method typically involves transmitting a sequence of bits (usually a pseudo-random binary sequence (PRBS)) from the test set to the mobile. This data is transmitted at a low power level (usually somewhere close to the reference sensitivity level of the mobile's receiver.) The mobile receives and re-transmits (typically at a much high power level to avoid introducing further bit errors) all the received data back to the test set. The test set compares the received data with the transmitted data and calculates the bit error rate. There are different BER tests defined within the standards for GSM, depending on whether channel coding is considered or not.

For a BLER measurement, the data is transmitted in a similar way to the BER measurement, but the computation is based on the number of blocks received in error by the mobile compared to the number of blocks sent. A block consists of four bursts. Each block has a Block Check Sequence (BCS) associated with it. If the BCS is bad, the block is counted as being in error.

In normal operation, the mobile receives the blocks and, if the Medium Access Control (MAC) header polling bit is set, sends back an ACK (Acknowledged) or NACK (Not Acknowledged) response, depending on whether the block was properly received. The transmitting device (that is, the base station) can record the relative number of negatively acknowledged blocks to the total number of blocks acknowledged by the mobile. This data can be used to calculate the BLER as a ratio. The advantage of this method is that a network can monitor BLER performance in normal use.

It is also possible for a mobile to loop back all the data received to a test set and for the test set to do the BLER calculation in a similar way to a traditional BER test. The test set allows you to do this (see Block Error Measurement ).

Standards Definition for Reference Sensitivity

The Release 99 GSM 5.05 standard defines the reference sensitivity of GPRS mobiles. The following table shows the reference sensitivity input levels for GPRS mobiles in the various bands under static conditions.

The BLER in each case must be less than or equal to 10%.

GSM450, GSM480, GSM750, GSM850, PGSM (GSM900), DCS1800, PCS1900, RGSM, T-GSM810 | Reference level under static conditions (dBm)
PDTCH/CS-1 | -104
PDTCH/CS-2 | -104
PDTCH/CS-3 | -104
PDTCH/CS-4 | -101
PDTCH/MCS-1 | -104
PDTCH/MCS-2 | -104
PDTCH/MCS-3 | -104
PDTCH/MCS-4 | -101.5
PDTCH/MCS-5 | -98
PDTCH/MCS-6 | -96
PDTCH/MCS-7 | -93
PDTCH/MCS-8 | -90.5
PDTCH/MCS-9 | -86

The input levels provided in the above table are referenced to a normal PGSM mobile (MS), and must be corrected by the following values for other MS:

  • GSM 450, GSM480, GSM750, GSM850 and PGSM class 4 or 5 (small) MS: +2 dB
  • DCS1800 class 1 or 2 MS: +4 dB
  • DCS1800 class 3 and PCS1900 class 1 or 2 MS: +2 dB
  • PCS1900 class 3 MS: 0 dB

The mobile is also required to receive data when there is power in adjacent timeslots with respect to the following two situations:

  1. The mobile has to receive data in an adjacent timeslot intended for it as well as the timeslot in question. In this case, the standards specify that the mobile must be able to cope with a difference in power levels between the timeslots of up to 6 dB, without degradation of performance.
  2. The mobile has to be able to receive data in the presence of power in an adjacent timeslot not intended for the mobile. In this case the difference in power levels can be up to 20 dB.

Different Test Configurations

There are different configurations available in the test set for testing GPRS and EGPRS mobiles. Some of these are available in Active Cell operating mode and others are GPRS BCH+PDTCH and EGPRS BCH+PDTCH Test Mode operating modes. All of these configurations allow transmitter tests to be performed. Only the following allow receiver tests to be performed:

  • Active Cell Operating Mode with the ETSI Type B (Unacknowledged) Connection Type
  • Active Cell Operating Mode with the ETSI Type B (Acknowledged) Connection Type
  • Active Cell Operating Mode with the BLER Connection Type
  • Active Cell Operating Mode with the Switched Radio Block Loopback Connection Type
  • GPRS BCH+PDTCH Test Operating Mode
  • EGPRS BCH+PDTCH Test Operating Mode

Further details of each of these configurations are provided in the following sections.

Active Cell Operating Mode

Five of the connection types available in Active Cell operating mode are BLER, ETSI Type A, ETSI Type B (Unacknowledged), ETSI Type B (Acknowledged), and Switched Radio Block Loopback. The ETSI test modes A and B are defined in GSM 04.14:

  • ETSI Test Mode Type A forces the mobile into a transmit mode. Once in this mode the logical downlink is removed (although in the test set, the source remains active). This mode is not suitable for any type of receiver testing.
  • ETSI Test Mode Type B (Unacknowledged) places the mobile into a loop-back mode, where all the data transmitted on the downlink is sent back on the uplink. In an asymmetric configuration (for example, 2x1) it is possible to select which timeslot is looped back. In this mode, the downlink temporary block flow (TBF) is specified to operate in the unacknowledged Radio Link Control (RLC) mode. This simplifies BER measurements, but it is not possible to do a simple packet ACK/NACK based BLER measurement. It is however possible for the test set to compute BLER in a similar way to a BER measurement.
  • ETSI Test Mode Type B (Acknowledged) places the mobile into a loop-back mode, where all the data transmitted on the downlink is sent back on the uplink. In an asymmetric configuration (for example, 2x1) it is possible to select which timeslot is looped back. In this mode, the downlink temporary block flow (TBF) operates in the Acknowledged Radio Link Control (RLC) mode, making it possible to do a simple packet ACK/NACK based BLER measurement or to compute BLER in a similar way to a BER measurement. Which is used depends on the setting of the ETSI B Acknowledged Measurement Mode. See ETSI B Acknowledged Measurement Method Mode for more information.
  • Switched Radio Block Loopback places the mobile into a loop-back mode, where all the data transmitted on the downlink is sent back on the uplink. In this mode, only one timeslot is used and the downlink temporary block flow (TBF) operates in the Unacknowledged Radio Link Control (RLC) mode. This connection type is appropriate for performing BER measurements on an EGPRS mobile station. When the mobile station is in Switched Radio Block Loopback mode, you must use the EGPRS SRB Bit Error Measurement. The GPRS Bit Error Measurement of the Block Error Measurements provide results in this configuration, but they would not be useful.

In Active Cell operating mode both BER measurement (see GPRS Bit Error Measurement ), an SRB BER measurement (see EGPRS SRB Bit Error Measurement ), and a test set calculated BLER measurement (see Block Error Measurement ) are provided. However, it is not possible to run any of these measurements simultaneously.

In the case of a BER measurement, all of the GPRS coding schemes include a Frame Check Sequence (FCS). In normal operation, if a mobile (or the test set) receives a block for which any of the bursts fail this check, the entire block is discarded. The BER measurement allows you to specify how bad blocks are interpreted. Either of the following two settings can be used:

  1. The test set assumes that all of the data bits in the block are zero for the purposes of BER calculation, resulting in an average BER for a block in error of 50% rather than a BLER of 100%. This is the default setting.
  2. The test set takes into account all of the bits to be used for the BER calculation exactly as they are received from the mobile.

The BLER connection type is an Agilent proprietary method that makes use of standard signaling messages. This connection method sends GPRS Mobility Management (GMM) Information messages to the mobile with the polling bit set in the MAC header. This forces the mobile to respond with ACK/NACK messages, which allows the test set to calculate BLER (see Block Error Measurement ). Note that the default BLER connection mode does not send a PRBS on the downlink, so results may be different from those when compared with an equivalent BER test or when the test set calculates the BLER (where a PRBS is used by default).

Test Mode

In GPRS Test Mode BCH+PDTCH, a BER measurement can be made in a similar way as the method used with the ETSI test mode B (Unacknowledged) connection type. The primary difference is that the mobile must use some proprietary method for looping back the data from the downlink timeslot of interest. Only Layer 1 signaling is provided in this mode. For this reason it is not possible to make an ACK/NACK based BLER measurement in this test mode, although the test set calculated BLER measurement is still available.

EGPRS Test Mode BCH+PDTCH can be used to make BLER measurements in the same manner as GPRS Test Mode BCH+PDTCH.

Additional Features Related to Data Connection Reliability

There are some additional features that you can configure which improve the reliability of these connection methods with different manufacturers' mobiles.

For example, when using the BLER connection type, by default a message is sent to the mobile in every block. This can cause some mobiles to be overrun, so to counteract this the polling rate can be slowed down (see CALL:FUNCtion:DATA:BLER:POLLing:INTerval ). Note that this additionally slows down the rate that the mobile transmits at, so if transmitter measurements are being made in parallel, these are also slowed down because there are fewer bursts available to make measurements on.

Another situation that can occur when using the BLER connection type is that mobiles can respond to the GMM information message in different ways. The GMM information elements are all optional. The test set transmits none of these elements, effectively sending a header with an empty message. In some cases this causes the mobile to respond differently from what could be expected. To overcome this problem, the Logical Link Control (LLC) Frame Check Sequence (FCS) can be deliberately corrupted (see CALL:FUNCtion:DATA:BLER:LLC:FCSequence ). This causes the mobile to discard the LLC blocks, preventing the messages from reaching the GMM layer in the mobile. In the meantime, the RLC/MAC layer keeps responding to the polls and transmits ACK/NACK messages, allowing the test set to compute BLER (and make transmitter measurements).

When a TBF is established in all of the active cell data connection types, the test set uses a relative starting frame number by default. If you have not yet implemented this mandatory part of the standards, options have been added to use an absolute starting frame number or to start immediately (see CALL:FUNCtion:DATA:FRAMe:STARt ).

The following additional features are also available:

  • In the BLER mode data connection, it is possible to transmit a PRBS or other specific payload patterns. This is done by selecting the corrupt LLC FCS option (see CALL:FUNCtion:DATA:BLER:LLC:FCSequence ) then selecting the payload pattern you want using CALL:FUNCtion:DATA:PAYLoad:PATTern:BLER . Note that if you want to switch between the corrupt and valid FCS messages, it is recommended that you should end the current data connection and then restart it.

  • In GPRS BCH+PDTCH Test Operating Mode, and in Active Cell Mode with the Connection Type set to ETSI Type B, you can perform test set calculated BLER measurements (see Block Error Measurement ), send a number of additional fixed patterns other than the default PRBS (see CALL:FUNCtion:DATA:PAYLoad:PATTern:ETSIB ), and perform a true bit-wise BER measurement (see GPRS Bit Error Measurement ).

In all test set operating modes, it is possible to switch on the power in unused timeslots using the CALL:(PDTCH|PDTChannel):PREDuction:UBURst . The power level for all the unused downlink timeslots can be set to either Power Reduction Level 1 (PRL1) or Power Reduction Level 2 (PRL2). This allows adjacent channel rejection tests to be done. Note that all unused timeslots are set to the same level; that is Off, PRL1 or PRL2.

Testing Multislot Configurations with Power in Adjacent Downlink Timeslots

As mentioned previously, there are two configurations that need to be tested. Using the test set, it is possible to set up power differences between adjacent active downlink timeslots.

The test set uses power control mode A for setting the downlink power. The standards specify a maximum difference of 10 dB between active timeslots. The test set provides even greater flexibility by allowing you to specify a maximum difference of up to 25 dB (although the source accuracy is currently only specified up to a difference of 20 dB). This allows greater dynamic range in GPRS testing. See CALL:(PDTCH|PDTChannel):PREDuction:LEVel<1|2> .

Because an indication of the power difference is included in the RLC/MAC header, there may be some cases where mobiles are confused by the use of differences greater than 10 dB.

The reason power control mode B has not been implemented in the test application (which allows a difference of up to 30 dB) is that this requires fixed allocation mode. Only dynamic allocation mode has been implemented in the test application. Fixed Allocation is available in the lab application.

The multislot configuration can be set up in any of the test set's operating modes/ data connection types (ETSI Type A, ETSI Type B, BLER and BCH+PDTCH test mode), to any one of the supported multislot configurations, that is 1x1, 2x1, 3x1, 4x1, 2x2 or 3x2.

In each case, there are two power levels (PRL1 and PRL2) that can be set on the downlink for the active timeslots (see CALL:(PDTCH|PDTChannel):PREDuction:BURSt<[1]|2|3|4|5> ). PRL1 and PRL2 are the levels below the P0 level at which bursts can be transmitted. (The P0 level is the amount by which the PDTCHs are reduced below the BCH level when the PDTCHs and BCH are on different ARFCN (Absolute Radio Frequency Channel Numbers). The P0 level can differ from the BCH level by up to 30 dB. According to the standard, the P0 level must be set to an even number. Each used burst can be set to either PRL1 or PRL2.The P0 level can be set independently (see CALL:(PDTCH|PDTChannel):PZERo:LEVel ). PRL1 and PRL2 are both set relative to P0. To achieve the maximum level difference between active timeslots, set PRL1 to 0 dB and PRL2 to 25 dB, or set PRL1 to 25 dB and PRL2 to 0 dB. Assign PRL1 to the first burst and PRL2 to the second burst. If you want more details on power reduction levels, including a figure which illustrates GPRS power reduction levels, refer to Downlink PDTCH Power Control .

Example of Multislot Receiver BLER Testing

It is possible to perform multislot BLER testing on the test set with downlinks at different power levels. In BLER mode, the count of ACK/NACK messages is not currently associated to individual timeslots. For normal use this is acceptable, as the standards specify that BLER must be within limits for the multislot configuration as a whole.

If you want to attribute BLER to a single timeslot with other timeslots at higher levels in a multislot downlink, then the following type of procedure can be used. Note that this procedure assumes that your mobile's multislot performance is of an acceptable standard.

The procedure is to first verify that the mobile has a BLER of zero when the downlink timeslots are at different powers, but all received timeslots are above the reference sensitivity level. The levels of all timeslots are then reduced, but the relative difference between them is maintained. When performing reference sensitivity level testing, only one of the timeslots should be close to or below the reference sensitivity level. In this case, any BLER is likely to be attributable to this lower power timeslot. To verify this, perform a BER measurement in either ETSI test mode B or in the GPRS Test Mode BCH+PDTCH (see Example of Multi-slot Receiver BER Testing ). You should also ensure that the power is switched off in unused timeslots (see CALL:(PDTCH|PDTChannel):PREDuction:UBURst ) to remove any possibility of power in unused bursts affecting the test results.

    Set the Connection Type to BLER.

    Set up the multislot configuration (for example, 2x1) in the required band.

    Make sure the BCH and the PDTCH's are on different ARFCN's. (If they are the same, then the standard requires all downlink timeslots to be transmitted at the same power level - namely that of the BCH.)

    Set the Cell Power to a suitably high level well above the reference sensitivity level of the mobile (for example, -80 dBm).

    Set P0 to a suitable level (for example, 0 dB).

    Set PRL1 and PRL2 to appropriate levels (for example, 0 and 6).

    Assign the first burst to PRL1 and the second to PRL2 (which means the first timeslot is transmitted at -80 dBm and the second at -86 dBm.)

    Set the BLER measurement to single trigger mode, and specify the number of blocks to measure, for example 100. See SETup:BLERror .

    Start the BLER measurement.

    Check that the result is zero. If not, adjust the parameters in steps 4 through 6 above until the result is zero.

    Change the P0 level to reduce both the downlink levels (for example 14 dB, causing the first burst to now be transmitted at -94 dBm and the second at -100 dBm.)

    Start the BLER measurement again.

    Record the BLER results.

Example of Multi-slot Receiver BER Testing

In GPRS BCH+PDTCH Test Mode or ETSI Test Mode B, the first downlink burst to be looped back can be specified. By default this is the first active timeslot, but you can change this if required.

For example, to measure BER on a second received timeslot that is at a lower power level than the first, perform the following procedure:

    Set the operating mode to GPRS BCH+PDTCH Test Mode or set the operating mode to Active Cell and the connection type to ETSI Test Mode B. If you want to use GPRS BCH+PDTCH Test Mode, set the mobile into an appropriate loopback mode.

    Ensure that the BCH and PDTCH's are on different ARFCN's. (If they are the same, then the standard requires all downlink timeslots to be transmitted at the same power level - namely that of the BCH.)

    Set the cell power and P0 level to the values you want, for example -70 dBm and 14 dB.

    Set the multislot configuration to 2x1.

    Set the PRL1 level to the value you want, for example 0 dB. (The level transmitted is cell power - P0 - PRL1, in this example, -84 dBm).

    Set the PRL2 level to a higher value, for example 10 dB. (The level transmitted is cell power - P0 - PRL2, in this example, -94 dBm).

    Assign PRL1 to the first burst that you are interested in.

    Assign PRL2 to the second burst.

    Set the first burst to loop back to 2 (that is, the second received downlink.)

    Start the BER measurement.

Related Topics

Testing a GPRS Mobile Station

Block Error Measurement

Bit Error Measurement

CALL:FUNCtion

CALL:(PDTCH|PDTChannel)

GPRS Data Connection Troubleshooting


Testing a GPRS Mobile Station

Testing a GPRS Mobile Station

Last updated: December 2, 2008

This section is not applicable to GSM or EGPRS.

This section provides a description of how you may want to use the test set to test a GPRS mobile station which supports a single uplink timeslot or two adjacent uplink timeslots. The section contains:

  • Test Overview
  • Procedure
  • Operating Considerations

If you want a detailed description of how to write a basic control program that performs fundamental manufacturing tests on a GPRS mobile station, see Programming: Getting Started Guide for E1968A GSM/GPRS Mobile Test Application Revision A.02 and E6701C GSM/GPRS Lab Application Revision C.02 .

Test Overview

To test a GPRS mobile station, you need to perform the following steps:

1. Configure the base station emulator, mobile station, and measurement execution parameters

2. Switch on the GPRS mobile station, perform an attach and establish a data connection

3. Make measurements and obtain results

4. Reconfigure the data connection and make more measurements (if required)

5. Disconnect the Mobile Station from the base station emulator

These steps are described in more detail in the next section.

Procedure

1. Configure the base station emulator, mobile station, and measurement execution parameters

Before starting to transfer data and make measurements on a GPRS mobile station, you may need to configure some, or all of the following parameters:

  • Broadcast channel (BCH) parameters:

    • Cell Band (see CALL[:CELL]:BAND<[:SELected]|:GSM> )

    • Broadcast Channel (ARFCN) (see CALL[:CELL]:BCHannel[:ARFCn][:SELected] )
    • Cell Power (see CALL[:CELL]:POWer:AMPLitude[:SELected] )
    • Serving Cell (see CALL[:CELL]:BCHannel:SCELl )
  • Packet data traffic channel (PDTCH) parameters:
    • Packet Data Traffic Channel Band (see CALL:(PDTCH|PDTChannel):BAND )
    • Packet Data Traffic Channel (ARFCN) (see CALL:(PDTCH|PDTChannel)[:ARFCn][:SELected] )
    • Packet Data Traffic Channel Coding Scheme (see CALL:(PDTCH|PDTChannel):CSCHeme:UPLink )
    • Downlink Packet Data Traffic Channel Power Control:
      • Downlink Power Reduction Mode (see CALL:(PDTCH|PDTChannel):PREDuction:MODE )
      • Downlink Power Reference Level (dB) (see CALL:(PDTCH|PDTChannel):PZERo:LEVel )
      • Downlink Power Reduction Level (dB) (see CALL:(PDTCH|PDTChannel):PREDuction:LEVel<1|2> )
      • Downlink Burst Power Reduction Selection (see CALL:(PDTCH|PDTChannel):PREDuction:BURSt<[1]|2|3|4|5> )

        Note: In order to make use of power reduction levels, you must set the downlink PDTCHs to be on a different ARFCN from the broadcast channel. This is because the power level across all timeslots on the BCH must remain constant. Therefore, power reduction levels are ignored if the BCH and PDTCH are on the same ARFCN.

      • Unused Downlink Burst Power Reduction Selection (see CALL:(PDTCH|PDTChannel):PREDuction:UNUSed )

        Note: In order to make use of power reduction levels, you must set the downlink PDTCHs to be on a different ARFCN from the broadcast channel. This is because the power level across all timeslots on the BCH must remain constant. Therefore, power reduction levels are ignored if the BCH and PDTCH are on the same ARFCN.

    • Packet Data Traffic Channel Protocol Control:
      • Packet Timeslot Reconfigure (see CALL:(PDTCH|PDTChannel):PMESsage:PTReconfig )
      • Packet Power Timing Advance (see CALL:(PDTCH|PDTChannel):PMESsage:PPTadvance )
      • Data Connection Frame Number Type (see CALL:FUNCtion:DATA:FRAMe:STARt )
      • Data Connection LLC Frame Check Sequence (see CALL:FUNCtion:DATA:BLER:LLC:FCSequence )
      • BLER Block Polling Interval (see CALL:FUNCtion:DATA:BLER:POLLing:INTerval )
      • Payload Pattern (BLER) (see CALL:FUNCtion:DATA:PAYLoad:PATTern:BLER )
      • Payload Pattern (OTHER) (see CALL:FUNCtion:DATA:PAYLoad:PATTern[:OTHer] )

    • Connection Type (see CALL:FUNCtion:CONNection:TYPE )

      Note: The BLER, ETSI Type A, and ETSI Type B Connection Types allow you to establish the continuous data connection with the test set required for testing in a manufacturing environment. Please see Connection Types for descriptions of the different connection types and they're uses.

    • Multislot Configuration (see CALL:(PDTCH|PDTChannel):MSLot:CONFig )
    • First Downlink Burst to Loop (see CALL:(PDTCH|PDTChannel):MSLot[:FIRSt]:DOWNlink:LOOPback[:BURSt] )
  • Mobile station operating parameters:
    • PDTCH MS TX Level (see CALL:(PDTCH|PDTChannel):MS:TXLevel[:SELected]:BURSt<[1]|2|3|4|5> )
    • Guard Period Length (see CALL:MS:TX:BURSt:GPLength )
  • Measurement execution parameters:
    • The SETup subsystem is used to configure measurement parameters. For a brief description of this subsystem and links to the GPIB commands, see SETup Subsystem . For a more detailed description of measurement execution parameters along with programming examples, see Step 3: Set the Measurement Parameters .
  • Deferred parameters (if required):
    • Deferred parameters allow you to set up a new data connection ahead of time.This is useful if you plan to reconfigure the data connection after your first set of measurements to make more measurements on the new channel. The settings you make are only applied when a channel change is executed using the CALL:HANDover|HANDoff[:IMMediate] . For a list of the deferred parameters see Configuring the Packet Data Traffic Channel (PDTCH) . For more details on using deferred parameters see Using Deferred Parameters .

2. Switch on the GPRS mobile station, perform an attach and establish a data connection

Ensure the GPRS mobile station you want to test has either a GSM Test SIM card, or a standard SIM card installed. When you connect your mobile station to the test set and switch the mobile station on, it should automatically perform a GPRS attach. (For those mobile stations which do not automatically perform a GPRS attach, you may have to instruct the mobile station to go into a data mode. The method for doing this will vary from one mobile station to another. For example, you may have to press a key on the mobile station's keypad, or make a selection from the mobile station's on-screen menu system.)

The mobile station must be GPRS attached before you can use the command CALL:FUNCtion:DATA:START to start the data connection. You can verify that a data connection has been successfully established, by checking that the connection status is "transferring". (If you require more details on connection states see Data Connection Processing State Synchronization ).

If you have problems starting the data connection with your mobile station under normal conditions, you may want to try changing the frame numbering scheme using the command CALL:FUNCtion:DATA:FRAMe:STARt .

If you have problems establishing a data connection using the BLER Connection Type specifically, you may want to change the setting of the Data Connection LLC Frame Check Sequence (see CALL:FUNCtion:DATA:BLER:LLC:FCSequence ) or the BLER Block Polling Interval (see CALL:FUNCtion:DATA:BLER:POLLing:INTerval ).

If you require more troubleshooting information related to getting the mobile to perform a GPRS attach, or start a data connection, see GPRS Data Connection Troubleshooting .

3. Make measurements and obtain results

Now that the data connection is successfully established, you can start making concurrent transmitter measurements and gathering results. Output RF Spectrum, Transmit Power, Phase and Frequency Error, and Power versus Time are all available for GPRS. In addition, you can make Receiver Bit Error, or Block Error measurements in parallel with your transmitter measurements depending on the connection type you want to use.

The FETch subsystem is used to obtain transmitter and receiver measurement results. For a description of this subsystem along with links to the GPIB commands, see FETCh? Subsystem .

You may want to vary the downlink power to stress the mobile's receiver during your testing (see Downlink PDTCH Power Control ).

If you want the test set to perform Transmit Power, and Phase and Frequency Error measurements on both bursts of a multislot configuration which features two adjacent uplink timeslots, you can select only one burst at a time to measure (using the command CALL:(PDTCH|PDTChannel):MSLot:MEASurement:BURSt ). In order to optimize your test code, the recommended method is to select the first burst you want to measure, perform the first set of Transmit Power, and Phase and Frequency Error measurements and then repeat these measurements after you have selected the second burst. To select a multislot configuration with two adjacent uplink timeslots (that is, D2U2 or D3U2) use CALL:(PDTCH|PDTChannel):MSLot:CONFig . Note that the Power versus Time measurement can measure over both bursts in a multislot configuration with two adjacent uplink timeslots. If you require more details on the Power versus Time measurement, see Power versus Time Measurement Description .

For more details on the process of making measurements and gathering results, see Step 5: INITiate and FETCh Measurements .

4. Reconfigure the data connection and make more measurements (if required)

In order to test the mobile station using different parameters, such as channel number, channel band, or mobile station transmit level, you have to reconfigure the data connection. To do this, you can execute a channel change using the CALL:HANDover|HANDoff[:IMMediate] . This applies the deferred parameters that you set earlier (see Deferred Parameters above). If you require more details on the process of reconfiguring the data connection, see Step 6: Reconfigure Test Set and Mobile Station Connection Parameters .

Note that additional PDTCH protocol control parameters are available in case your mobile station does not support the Packet Timeslot Reconfigure (PTR) message. (If you require details on these parameters, see CALL:(PDTCH|PDTChannel):PMESsage:PPTadvance and CALL:(PDTCH|PDTChannel):PMESsage:PTReconfig ).

5. Disconnect the Mobile Station from the base station emulator

When your testing is complete, you need to end the data connection (using CALL:FUNCtion:DATA:STOP ) and then initiate the GPRS detach procedure from the mobile station. If you require more details, see Step 7: End the Connection . You should note that the GPRS detach procedure is optional in a testing environment. The test set can be left in the Attached data connection state and will recognize if a different mobile station performs a GPRS attach.

Operating Considerations

Downlink PDTCH Power Control

For GPRS-specific testing of mobile stations, you must take into consideration the multislot mode of operation (where a single packet data connection uses multiple timeslots on the same ARFCN possibly at different power levels). In GPRS, downlink power levels are referenced to the power reduction reference level (which in turn is referenced to the BCCH). ETSI refers to these power reduction levels as PR values, and the reference level is known as P0. In the test set, the power reduction levels are implemented as two values (PRL1 and PRL2) which can be mapped to any downlink burst.

P0, PRL1, and PRL2 are shown in the figure below. Note that the BCH (including GPRS indicator) is shown on the same ARFCN in the figure only to illustrate the BCH level. To make use of power reduction levels, you must set the downlink PDTCHs to be on a different ARFCN from the BCH.

GPRS Power Reduction Levels

Use the following commands to set the BCH power, P0 reference level, and PDTCH power reduction levels:

  • To set the Cell Power (BCH power level), use CALL[:CELL]:POWer:AMPLitude[:SELected] .
  • To set the P0 Reference Level, use CALL:(PDTCH|PDTChannel):PZERo:LEVel .
  • To set the Downlink Power Reduction Level (dB) for PRL1 and PRL2, use CALL:(PDTCH|PDTChannel):PREDuction:LEVel<1|2> .
  • To make the Downlink Burst Power Reduction Selection (either PRL1 or PRL2) for each PDTCH burst, use CALL:(PDTCH|PDTChannel):PREDuction:BURSt<[1]|2|3|4|5> .
  • To make the Unused Downlink Burst Power Reduction Selection (either PRL1 or PRL2) for all PDTCH bursts that are not being used for transmitting downlink PDTCH(s), use CALL:(PDTCH|PDTChannel):PREDuction:UNUSed .

Related Topics

Programming: Getting Started Guide for E1968A GSM/GPRS Mobile Test Application Revision A.02 and E6701C GSM/GPRS Lab Application Revision C.02

GPRS Serving Cell (or Active Cell (GPRS) Operating Mode)

Broadcast Channel Parameters

Configuring the Packet Data Traffic Channel (PDTCH)

Receiver Sensitivity Testing in GPRS and EGPRS

GPRS Data Connection Troubleshooting


Preset Descriptions

Preset Descriptions

Last updated: December 2, 2008

Description

The test set is capable of accepting several different preset commands.

At no time during a preset operation, does transmit power exceed the last user setting of the transmit power. The input power is not set to any value lower than the last user setting of the input power. This is to avoid power spikes on the output and possible receiver damage on the input during transitions associated with preset operations.

Partial Preset

Partial preset saves setup time because measurement setup parameters remain unchanged. This is the recommended way to place the test set in a known condition.

When you fast switch between formats in a fast switching test application the test set behaves as if a partial preset has occurred. The table below lists some key partial preset results.

Example

OUTPUT 714;"SYSTEM:PRESET3" !Command for a partial preset when user in
                            !remote operation.

SYSTEM:PRESET3 is the recommended command for a partial preset operation. The SYSTEM:PRESET[1] command is not recommended for use at this time.

Press the green Preset key on the front panel to perform a partial preset.

Partial Preset Behavior
Function | Partial Preset Result
Trigger Arm | no change
Measurement parameters | no change
Calibration data | no change
Enable registers | no change
Positive Transition Filter registers | no change
Negative Transition Filter registers | no change
Contents of RAM | no change
Contents of output queue | no change
Contents of error queue | no change
Maskable Message Display State | no change
Operating Mode | Active Cell
Measurements | aborted and inactivated
Measurement results | NAN
Measurement integrity indicator | 1 = no result available
Transmit Power State | ON
Cell Activated State | ON
Call in progress | aborted
Call Control Status | Idle
Call Counters | cleared
Call Error Counters | cleared
SACCH | cleared
Pending Service request | not cleared

Full Preset

A full preset requires you to select new measurements and configure their parameters. If measurement parameters do not need to be changed, use a partial preset to save time.

Example

OUTPUT 714;"*RST" !Recommended command for a full preset, sets trigger arm to single.

OUTPUT 714;"SYSTEM:PRESET2" !Command for a full preset, sets trigger arm to continuous.

The *RST common command is the recommended command for a full preset operation.

NOTE
Transmit power is not set to OFF during a full preset, transmit power is set to the default value.

Full Preset Behavior
Function | Full Preset Result
Trigger Arm | Continuous (manual operation full preset or SYSTEM:PRESET2 command)
Trigger Arm | Single (remote operation full preset, *RST command)
Measurement Parameters | all set to defaults
Maskable Message Display State | On (manual operation full preset)
Maskable Message Display State | Off (remote operation full preset)

Status Preset

The STATUS:PRESET command sets the status system as defined in "SCPI 1995 Volume 2: Command Reference" section 20.7. All of the enable registers are set to 0, all PTR registers are set to 1, and all NTR registers are set to 0.

Example

OUTPUT 714;"STATUS:PRESET" !Presets the STATus subsystem.

Related Topics

SYSTem:PRESet


Instrument Status Area

Instrument Status Area

Last updated: December 2, 2008

Description

The instrument status area is found on the bottom center of the test set's display.

Status Area of the Test Set Display

Background

You can initiate more than one measurement at a time with the test set. The test set's display can show a maximum of 2 measurements. When 3 or more measurements are initiated, or the MEASUREMENT screen is not displayed, the Background annunciator reminds you that measurements are active but not displayed.

<Operating Mode> Status

The call processing status and the operating modes are displayed in this area. This area may change (depending on the application that is active) in order to provide application specific information.

Sys Type

The current system type is displayed in this area. This area may change (depending on the application that is active). It might be IS-856 (for 1xEV-DO), IS-95 , IS-2000 , GSM , GPRS , EGPRS , FDD (for W-CDMA), IS-136 , DIG-136 .

External Device Connection

This annunciator is only applicable to the GSM/GPRS/EGPRS and W-CDMA/HSPA lab applications. When the test set is connected to another test set using an External Device Connection, this area contains ExtDev . Otherwise, this area is blank. For details, see the related links under Related Topics.

Logging

This annunciator indicates whether or not your lab application is connected to Wireless Protocol Advisor. When your lab application is connected to Wireless Protocol Advisor Logging: Active is displayed, when your Lab Application is not connected to Wireless Protocol Advisor Logging: Idle is displayed. If your Application is a test application, this area is blank.

Sync Annunciators

These annunciators indicate whether the test set has successfully completed a synchronization. This annunciator can contain " C OPC ", " S OPC " or " CS OPC ". For details, see the related links under Related Topics.

DBUS - INT

This annunciator turns on when Option 004 hardware is installed and the application is a cdma2000, 1xEV-DO, or W-CDMA lab application that supports this functionality. For details, see the related links under Related Topics.

Shift

This annunciator indicates that the blue SHIFT key has been pressed, and that the next key you press performs the shifted function indicated, also in blue.

Int Ref/Ext Ref

When the internal time base is used (there is no suitable external time base connected to the rear panel 10MHz REF IN connector), Int Ref turns on. When a suitable external time base is connected to the rear panel 10MHz REF IN connector, Ext Ref turns on.

Offset

This annunciator indicates that the Amplitude Offset state is set to On. For details, see the related links under Related Topics.

R L T S

This annunciator indicates the state of four different conditions of the test set:

  • Remote annunciator. ` R ' turns on when the test set is operated remotely.
  • Listen annunciator. ` L ' turns on when the test set is listening to a command.
  • Talk annunciator. ` T ' turns on when the test set is providing information over GPIB.
  • SRQ annunciator. ` S ' turns on when an SRQ is active.

Help

When the Help functionality is active, this annunciator turns on. Use the HELP hardkey to activate/deactivate the Help functionality. When the help functionality is active, when you select a setting the associated GPIB command is displayed at the bottom of the screen.

Physical Layer Subtype

This area is applicable to the 1xEV-DO applications. It indicates the current Physical Layer Subtype, either PLSub0 (Physical Layer Subtype 0) or PLSub2 (Physical Layer Subtype 2). For details, see the related links under Related Topics.

Application Type

This area is applicable to the 1xEV-DO applications. It indicates the current application being used, such as FTAP , RTAP , FETAP , RETAP , or DPkt . For details, see the related links under Related Topics.

Related Topics

External Device Connector: External Device Connection

Logging: Protocol Logging

Offset: Amplitude Offset


How Do I Use Real-Time Vocoder?

How Do I Use Real-Time Vocoder?

Last updated: December 2, 2008

The following procedure provides an example usage of Real-Time Vocoder. It is assumed that a mobile station's antenna output is connected to the test set's RF IN/OUT connector, an external audio source (such as a microphone) is connected to the test set's AUDIO IN port, and an external audio receiver (such as a loudspeaker) is connected to the test set's AUDIO OUT port.

General Procedure

  1. Press the blue SHIFT key and then the green Preset key to fully reset the test set.
  2. Follow the procedure described in How Do I Set Up a Call? to establish a voice call.
  3. Press TCH Parameters ( F8 ).
  4. Press the More key until 2 of 3 of the TCH Parms is displayed.
  5. Press Speech Setup ( F10 ).
  6. Press Speech Source and Select Real-Time Vocoder from the pop-up menu.
  7. press the Return ( F12 ) key.
  8. Press the More key on the lower left side of the display until 3 of 3 of call control is displayed.
  9. Select Real-Time Vocoder ( F2 ).
  10. Select Real-Time Vocoder Parms ( F1 ). The Real-Time Vocoder Parameters menu is displayed. Set the parameters as desired and then press the close menu ( F6 ) key when finish the setting.
  11. Speak into the mobile station. Verify that the voice is heard from the loudspeaker. The voice encoded by the mobile station is sent to the test set over the RF link. The test set then demodulates, decodes the signal and converts it to an analog signal output to the AUDIO OUT connector. The signal is then played by the loudspeaker.
  12. Speak over the microphone. Verify that the voice is heard from the mobile station's speaker. The analog voice signal inputs to the test set over the Audio In connector. The test set samples, encodes the signal, and modulates it onto the RF link. The mobile station when receiving the RF signal, then demodulates, decodes, and converts the signal into an analog audio output to its speaker.
  13. A typical display during real-time vocoder operation is shown below. For an explanation of the encoder headroom and decoder headroom results, see Real-Time Vocoder Headroom Information .

Related Topics

Real-Time Vocoder


How Do I Configure the Call Signaling Parameters?

How Do I Configure the Call Signaling Parameters?

Last updated: December 2, 2008

This section is only applicable to the lab application.

  1. Press CALL SETUP .
  2. Press TCH Parameters ( F8 ).
  3. Press More on the bottom, right-hand side of the screen until you reach the third TCH Parms menu ( 3 of 3 ).
  4. Press Call Signaling Parameters ( F1 ). This displays the Call Signaling Parameters menu.
  5. To change a parameter in this menu, use the knob to scroll to, highlight, and change the parameter settings.

    NOTE: The SDCCH Subchannel and the Destination Channel are only accessible when the Assignment Channel is set to SDCCH (Normal) .

Related Topics

Stand Alone Dedicated Control Channel (SDCCH)


How Do I Change Cell Identification Parameters?

How Do I Change Cell Identification Parameters?

Last updated: December 2, 2008

This section details how to access and change cell parameters. There are several configurable cell identification parameters. For more information, see Cell Identification Parameters .

Select the Cell Parameters menu.

  1. Press the CALL SETUP key.
  2. Press the Cell Info ( F6 ) key.
  3. Press the Cell Identification ( F3 ) key.


How Do I Change Cell List Parameters?

How Do I Change Cell List Parameters?

Last updated: December 2, 2008

This section details how to access and change cell parameters. There are three types of cell lists that you can configure: the BA Tables (both BCH and PBCCH), the CA Table and the UTRAN FDD neighbour cell list. For more information, see Cell Lists .

Select the Cell Parameters menu.

  1. Press the CALL SETUP key.
  2. Press the Cell Info ( F6 ) key.
  3. Press the Cell Lists ( F4 ) key.


How Do I Change Cell Operation Parameters?

How Do I Change Cell Operation Parameters?

Last updated: December 2, 2008

This section details how to access and change cell parameters. There are several configurable cell operation parameters. For more information, see Cell Operation .

Select the Cell Parameters menu.

  1. Press the CALL SETUP key.
  2. Press the Cell Info ( F6 ) key.
  3. Press the Cell Operation ( F1 ) key.


How Do I Change Cell Parameters?

How Do I Change Cell Parameters?

Last updated: December 2, 2008

This section details how to access and change cell parameters. There are several configurable cell parameters. For more information, see Cell Parameters .

A. Select the Cell Parameters menu.

  1. Press the CALL SETUP key.
  2. Press the Cell Info ( F6 ) key.
  3. Press the Cell Parameters ( F2 ) key.

B. Set a cell parameter.

  • To change cell parameters:

    1. The operating mode must be set to "Cell Off" to change the grayed out parameters, (see Operating Mode in the Call Setup Screen).
    2. Set network cell parameter to the desired value. (Highlight the parameter, press the knob.)
    3. After you have set all the cell parameters to desired values, remember to change the operating mode back to what you had it set to (before you set it to Cell Off to change the Cell Parameters).


How Do I Configure the AUDIO OUT Port?

How Do I Configure the AUDIO OUT Port?

Last updated: December 2, 2008

A. Select a signal to output at the AUDIO OUT port.

  1. Press the SYSTEM CONFIG key.
  2. Press the More key on the left side of the display for additional system parameters.
  3. Press the Audio Out Port ( F1 ) key.
  4. Turn the knob to highlight a selection and then press the knob.

NOTE
To facilitate the change of signal selection for output to the front-panel AUDIO OUT port while performing different tasks, you can also access the Audio Out Port settings from several other menus: Audio Generator control menu, Swept Audio Setup menu, Call Parms menu (2 of 3) in AVC Test operating mode, and Call Parms menu (2 of 3) in Active Cell operating mode with AMPS system selected. Changing the selection on one menu will be applied to all other menus.

NOTE
Selection of FM Demod signal routed to the front-panel AUDIO OUT port is useful only in AMPS system. There will be no guaranteed performance for the signal present at the Audio Out Port when FM Demod is selected for output.

B. Set FM Demod signal.

When FM Demod signal is selected for output to the front-panel AUDIO OUT port, a bandpass filter, expander circuit, and de-emphasis circuit can be individually inserted or bypassed in the FM Demod signal path.

  1. Press the SYSTEM CONFIG key.
  2. Press the More key.
  3. Press the FM Demod Setup ( F2 ) key.
  4. Turn the knob to highlight a selection and then press the knob.
  5. Enter a value or selection and press the knob.
  6. Press the Close Menu ( F6 ) key.

NOTE
If the FM Demod Setup settings are changed while the Audio Out Port selection is not FM Demod (see A. Select a signal to output at the AUDIO OUT port. ), the values will be stored for use when Audio Out Port is set to FM Demod.


How Do I Make an External Device Connection?

How Do I Make an External Device Connection?

Last updated: December 2, 2008

Description

You can connect your 8960 test set to an external device (such as another 8960 test set) over an IP network. Once you've established this connection, you can test supported end-to-end services between two wireless devices (such as W-CDMA end-to-end video calls), or configure a two-cell test system to test a single mobile's cell transitions, such as handovers and cell selections/reselections.

You can establish an External Device Connection while your test set is in any operating mode. However, most services utilizing the External Device Connection feature require active cell mode operation.

When connecting two test sets, it is recommended that you connect them via a hub, rather than through a gateway or WAN link, or connect them directly using a LAN crossover cable. This helps minimize the risk of lost data due to delayed packets.

External Device Connection Setup for Two 8960s

External 8960 Connection Setup

  • External 8960 IP Address

    Before establishing a connection with another 8960, you must first specify its IP address.

    Ext 8960 IP Addr cannot be set to the same value as LAN IP Address or DUT IP Address . If LAN IP Address is set to the value of Ext 8960 IP Addr , Ext 8960 IP Addr is reset to a blank field.

    GPIB command: SYSTem:COMMunicate:LAN:EXTernal:ADDRess

  • Connect to External 8960

    This action establishes a TCP/IP connection with the 8960 at the address specified by External 8960 IP Address .

    If the External Device Connection Status is Connected , then this action is ignored by the test set.

    GPIB command: SYSTem:COMMunicate:LAN:EXTernal:CONNect

  • Disconnect from External 8960

    This action disconnects the TCP/IP connection with the connected external 8960.

    If the External Device Connection Status is Disconnected , then this action is ignored by the test set.

    GPIB command: SYSTem:COMMunicate:LAN:EXTernal:DCONnect

LAN Connection Information

  • External Device Connection Status

    The External Device Connection Status is displayed in the LAN Connection Information window of both tests sets, regardless of which test set initiated the connection. The possible states of the external device connection are: Not Connected , Connecting , Connected and Disconnecting .

    When the External Device Connection status is Connected , ExtDev is displayed in the Instrument Status Area of both test sets:

    GPIB command: SYSTem:STATus:COMMunicate:LAN:EXTernal[:CONNected][:STATe]

  • Connected Device IP Address

    Once a connection has been established between the two test sets, the IP address of each test set is displayed in the other test set's LAN Connection Information window.

    GPIB command: SYSTem:STATus:COMMunicate:LAN:EXTernal[:CONNected]:ADDRess

  • LAN (Self) IP Address

    For your convenience, the IP address of the test set is shown in its LAN Connection Information window. This is a duplicate display of its LAN IP Address setting, which you set from the Instrument Setup ( F1 ) menu on its System Config screen, or using the SYSTem:COMMunicate:LAN[:SELF]:ADDRess command.

DUT IP Address Information

The DUT IP Address Information window indicates the IP address(es) currently in use by the DUT, and whether the IP address was assigned by the current test set or the external test set. Note that DUT IP Address must be set to a different value in both test sets.

Once an IP route is established between a test set and a device on the LAN, internet protocols do not provide a mechanism to re-establish the connection with another test set. Thus, when a mobile has an active PDP context with one test set and transitions to another, a tunnel is created to route data to and from the mobile via the originating test set. The originating test set must continue to act as the end-point for the IP connection, regardless of the location of the mobile, and to forward any received packets to the test set currently serving the mobile. This forwarding of packets is referred to as "tunneling".

During tunneling, the mobile uses the DUT IP Address provided by the originating test set, not the DUT IP Address of the serving test set. To help indicate this situation, the DUT IP Address setting on the serving test set is grayed out. Also, DUT IP Address Origin on the serving test set displays External 8960 and the IP address currently in use by the mobile is displayed under DUT IP Address 1 .

  • DUT IP Address Origin

    Displays either This 8960 or External 8960 to indicate which test set assigned the IP address currently in use by the mobile.

  • DUT IP Address 1

    Displays the IP address currently in use by the mobile.

  • DUT IP Address 2
  • DUT IP Address 3
  • DUT IP Address 4

Other Considerations

The external device connection is not affected by a partial preset. However, the external device connection is disconnected as a result of a full preset.

Before initiating an external device connection between two test sets, you can verify that the two test sets are able to communicate by pinging one test set from the other. To do so, on test set #1:

  • Press the Call Setup key, then the left More key until the Ping menu is available.
  • Select Ping , then Ping Setup ( F1 ).
  • Set Device to Ping to Alternate ( CALL:DATA:PING:SETup:DEVice ).
  • Set the Alternate Ping Address to the IP address of test set #2 ( CALL:DATA:PING:SETup:ALTernate:IP:ADDRess ).
  • Select Start Ping ( F3 ) ( CALL:DATA:PING:STARt ).

Related Topics

External Device Connection


How Do I Configure the Test Set for My Test System?

How Do I Configure the Test Set for My Test System?

Last updated: December 3, 2008

This section is not applicable to GPRS.

A. Configure instrument information and setup.

  1. Press the SYSTEM CONFIG key.
  2. Press the Instrument Setup ( F1 ) key.
  3. Change an Instrument Setup Value and then press the Close Menu ( F6 ) key.

CAUTION
Always verify that the test set is responding to a new LAN IP Address by pinging the test set. If the test set does not respond to the ping, cycle power. This will ensure that the test set will respond to the new LAN IP Address.

B. Set amplitude offsets.

  1. Press the System Config button on the right side of the screen.
  2. Press the RF IN/OUT Amptd Offset ( F5 ) key on the Configuration Summary screen shown in part A.
  3. On the RF IN/OUT Amplitude Offset screen, press the RF IN/OUT Amptd Offset Setup ( F2 ) key.
  4. Enter the test frequencies and their associated amplitude offsets. Twenty test frequencies and amplitude offsets can be set.
  5. Press the Close Menu ( F6 ) key.
  6. Press the Return ( F6 ) key to return to the Configuration Summary screen.

C. Check the message log.

  1. Press the System Config button on the right side of the screen.
  2. Press the Message Log ( F7 ) key and view the message log.
  3. You can clear the message log by pressing Clear Message Log ( F10 )
  4. Press the Return ( F12 ) key.


How Do I Configure the Control Channel Parameters?

How Do I Configure the Control Channel Parameters?

Last updated: December 2, 2008

Procedure

This procedure assumes that the BCH parameter for Cell Band is set up correctly for your mobile station and that the appropriate RF IN/OUT Amplitude Offsets have been set to offset loss between the mobile station and the test set.

  1. Press CALL SETUP .
  2. Press the bottom left More key until Control menu ( 2 of 3 ) appears.
  3. Press Protocol Control ( F4 ).
  4. Press RLC/MAC ( F2 ).
  5. Press the bottom left More key until RLC/MAC Ctrl menu (2 of 2) appears.
  6. Press Control Channel Setup ( F5 ).
  7. Press Control Channel Parameters ( F1 ). This opens the Control Channel Parameter menu in the center of the screen.
  8. Use the knob to highlight the parameter and to change the parameter setting.

Related Topics

Control Channel Setup


How Do I Configure Test Signals in CW Operating Mode?

How Do I Configure Test Signals in CW Operating Mode?

Last updated: December 2, 2008

  1. Press the CALL SETUP key.
  2. Press the Operating Mode ( F1 ) key and set the operating mode to CW .
  3. Press the Cell Power ( F7 ) key and set the signal output power level to meet your testing needs.
  4. Press the RF Gen Freq ( F8 ) key and set the signal output center frequency to meet your testing needs.
  5. Press the Receiver Control ( F12 ) key and manually set the test set's receiver control parameters (such as Expected CW Power, Measurement Frequency, and Uplink Frequency) to the desired values.

Related Topics

CW

Receiver Control


How Do I Configure the Speech Source?

How Do I Configure the Speech Source?

Last updated: December 2, 2008

Procedure

This procedure details how to select the speech source on the test set.

  1. Press CALL SETUP .
  2. Press TCH Parameters ( F8 ).
  3. Press the More key until screen 2 of 2 of the TCH Parms menu is displayed.
  4. Press Speech Setup ( F10 ) and the Speech Setup menu appears in the center of the screen as shown in the figure below.
  5. Highlight Speech Source and select the desired speech source from the Speech list.

    • If you choose Echo from the Speech list, you can set the Speech Echo Loopback Delay from the Speech Setup list.
    • If you do not select Echo as the Speech Source , the Speech Echo Loopback Delay parameter is grayed out (and it cannot be set) as it is only applicable when Speech Source is Echo. The figure below is an example of what the Speech Setup menu looks like when you do not choose Echo as the Speech Source .

Related Topics

Speech


How Do I Set Up and Use the Dual Transfer Mode Feature?

How Do I Set Up and Use the Dual Transfer Mode Feature?

Last updated: December 2, 2008

Dual Transfer Mode is only applicable to the lab applications.

This section details how to:

  • Configure DTM Parameters
  • Configure Specific Features that Dual Transfer Mode Adds/Changes
  • Establish a Dual Transfer Mode Connection
  • Analyze the Dual Transfer Mode Properties
    • Supported DTM Class
    • Connection Status while in Dual Transfer Mode

Configure DTM Parameters

Enable/Disable Dual Transfer Mode

This procedure details how to enable/disable Dual Transfer Mode. The test set's default setting for this parameter is on. See DTM Enable for more information.

  1. Press Call Setup .
  2. Press Operating Mode ( F1 ) and select Cell Off from the Operating Mode menu.
  3. Press Cell Info ( F6 ).
  4. Press Cell Operation ( F1 ). The Cell Operation menu is displayed in the center of the screen.
  5. Use the knob to scroll down the menu options and find the Dual Transfer Mode parameter.
  6. Press Close Menu (F6).
  7. Press Return (F6).
  8. Press Operating Mode ( F1 ) and select an option that supports Dual Transfer Mode from the Operating Mode menu. See Operating Considerations to find which Operating Modes support Dual Transfer Mode.

Enable/Disable Enhanced Dual Transfer Mode

This procedure details how to enable/disable Enhanced Dual Transfer Mode. The test set's default setting for this parameter is OFF . See Enhanced DTM Enable for more information.

  1. Press Call Setup .
  2. Press Operating Mode ( F1 ) and select Cell Off from the Operating Mode menu.
  3. Press Cell Info ( F6 ).
  4. Press Cell Operation ( F1 ). The Cell Operation menu is displayed in the center of the screen.
  5. Use the knob to scroll down the menu options and find the Dual Transfer Mode (Enhanced) parameter.
  6. Press Close Menu (F6).
  7. Press Return (F6).
  8. Press Operating Mode ( F1 ) and select an option that supports Dual Transfer Mode from the Operating Mode menu. See Operating Considerations to find which Operating Modes support Dual Transfer Mode.

Configure DTM Measured Burst

This procedure details how to configure DTM Measured Burst. See DTM Measured Burst for more information.

  1. Press Call Setup .
  2. Press PDTCH Parameters ( F9 ).
  3. Press More on the bottom right side of the screen until menu 2 of 3 of PDTCH Parms is displayed.
  4. Press Measured Burst ( F8 ). Use the knob or the number key pad to highlight and change DTM Measured Burst .

Configure DTM Manual Unassigned USF

This procedure details how to configure DTM Manual Unassigned USF. See DTM Manual Unassigned USF for more information.

  1. Press Call Setup .
  3. Press More on the bottom left side of the screen until menu 2 of 3 of Control is displayed.
  4. Press Protocol Control ( F4 ).
  5. Press RLC/MAC ( F2 ).
  6. Press MAC Control ( F2 ). Use the knob or the number key pad to highlight and change the Assigned USF Allocation to a value less than 100% . Change Unassigned USF Mode to Manual USF .
  7. Use the knob or the number key pad to highlight and change DTM Manual Unassigned USF.

Configure DTM Multislot Configuration

This procedure details how to configure immediate and deferred DTM Multislot Configuration. See DTM Multislot Configuration for more information.

Immediate DTM Multislot Configuration

  1. Press Call Setup .
  2. Press PDTCH Parameters ( F9 ).
  3. Press More on the bottom right side of the screen until menu 3 of 3 of PDTCH Parms is displayed.
  4. Press DTM Parameters ( F7 ). Use the knob or the number key pad to highlight and change DTM Multislot Configuration .

Deferred DTM Multislot Configuration

  1. Press Call Setup .
  2. Press Handover Parameters ( F10 ).
  3. Press DTM Handover Setup ( F9 ).
  4. Use the knob or the number key pad to highlight and change DTM Multislot Configuration.

Configure DTM Traffic Band

This procedure details how to configure immediate and deferred DTM Traffic Band. See DTM Traffic Band for more information.

Immediate DTM Traffic Band

  1. Press Call Setup .
  2. Press PDTCH Parameters ( F9 ).
  3. Press More on the bottom right side of the screen until menu 3 of 3 of PDTCH Parms is displayed.
  4. Press DTM Parameters ( F7 ). Use the knob or the number key pad to highlight and change Traffic Band .

Deferred DTM Traffic Band

  1. Press Call Setup .
  2. Press Handover Parameters ( F10 ).
  3. Press DTM Handover Setup ( F9 ).
  4. Use the knob or the number key pad to highlight and change Traffic Band.

Configure DTM Traffic Channel

This procedure details how to configure the immediate and deferred DTM Traffic Channel. See DTM Traffic Channel for more information.

Immediate DTM Traffic Channel

  1. Press Call Setup .
  2. Press PDTCH Parameters ( F9 ).
  3. Press More on the bottom right side of the screen until menu 3 of 3 of PDTCH Parms is displayed.
  4. Press DTM Parameters ( F7 ). Use the knob or the number key pad to highlight and change Traffic Channel .

Deferred DTM Traffic Channel

  1. Press Call Setup .
  2. Press Handover Parameters ( F10 ).
  3. Press DTM Handover Setup ( F9 ).
  4. Use the knob or the number key pad to highlight and change Traffic Channel.

Configure DTM Frequency Hopping

This procedure details how to configure immediate and deferred DTM Frequency Hopping. See DTM Frequency Hopping for more information.

Immediate DTM Frequency Hopping

  1. Press Call Setup .
  2. Press PDTCH Parameters ( F9 ).
  3. Press More on the bottom right side of the screen until menu 3 of 3 of PDTCH Parms is displayed.
  4. Press DTM Parameters ( F7 ). Use the knob or the number key pad to highlight and change Frequency Hopping .

Deferred DTM Frequency Hopping

  1. Press Call Setup .
  2. Press Handover Parameters ( F10 ).
  3. Press DTM Handover Setup ( F9 ).
  4. Use the knob or the number key pad to highlight and change Frequency Hopping.

Configure DTM Coding Scheme

This procedure details how to configure immediate and deferred DTM Coding Schemes. See DTM Coding Schemes for more information.

Immediate DTM Coding Scheme

  1. Press Call Setup .
  2. Press PDTCH Parameters ( F9 ).
  3. Press Coding Scheme ( F11 ). Use the knob or the number key pad to highlight and change DTM Coding Scheme .

Deferred DTM Coding Scheme

  1. Press Call Setup .
  2. Press Handover Parameters ( F10 ).
  3. Press DTM Handover Setup ( F9 ).
  4. Use the knob or the number key pad to highlight and change Coding Scheme.

Configure DTM MS Tx Levels

This procedure details how to configure immediate and deferred DTM MS Tx Level for the individual bursts of the DTM connection. See DTM MS Tx Levels for more information.

Immediate DTM MS Tx Levels

  1. Press Call Setup .
  2. Press PDTCH Parameters ( F9 ).
  3. Press More on the bottom right side of the screen until menu 3 of 3 of PDTCH Parms is displayed.
  4. Press DTM Parameters ( F7 ). Use the knob or the number key pad to highlight and change MS TX Level for the individual bursts.

Deferred DTM MS Tx Levels

  1. Press Call Setup .
  2. Press Handover Parameters ( F10 ).
  3. Press DTM Handover Setup ( F9 ).
  4. Use the knob or the number key pad to highlight and change MS Tx Level for the individual bursts.

Configure DTM Power Reduction Reference

This procedure details how to configure immediate and deferred DTM Power Reduction Reference. See DTM Power Reduction Reference for more information.

Immediate DTM Power Reduction Reference

  1. Press Call Setup .
  2. Press PDTCH Parameters ( F9 ).
  3. Press Downlink Traffic Power( F7 ). Use the knob or the number key pad to highlight and change DTM P0 (Power Reduction Reference) .

Deferred DTM Power Reduction Reference

  1. Press Call Setup .
  2. Press Handover Parameters ( F10 ).
  3. Press DTM Handover Setup ( F9 ).
  4. Use the knob or the number key pad to highlight and change P0 (Power Reduction Reference).

Configure DTM Uplink State Flag

This procedure details how to configure immediate and deferred DTM Uplink State Flag. See DTM Uplink State Flag for more information.

Immediate DTM Uplink State Flag

  1. Press Call Setup .
  3. Press More on the bottom left side of the screen until menu 2 of 3 of Control is displayed.
  4. Press Protocol Control ( F4 ).
  5. Press RLC/MAC ( F2 ).
  6. Press MAC Control ( F2 ). Use the knob or the number key pad to highlight and change DTM Uplink State Flag (USF) .

Deferred DTM Uplink State Flag

  1. Press Call Setup .
  2. Press Handover Parameters ( F10 ).
  3. Press DTM Handover Setup ( F9 ).
  4. Use the knob or the number key pad to highlight and change Uplink State Flag.

Configure DTM CS Timeslot Position

The following procedures detail how to choose both immediate and deferred DTM CS Timeslot the test set will use. See DTM CS Timeslot Position for more information.

NOTE: You can only configure DTM CS Timeslot parameter when Multislot Config parameter setting is supported by DTM. For the list of multislot configurations that DTM supports, see DTM Multislot Configuration .

Immediate DTM CS Timeslot

  1. Press Call Setup .
  2. Press PDTCH Parameters ( F9 ).
  3. Press More on the bottom right side of the screen until menu 3 of 3 of PDTCH Parms is displayed.
  4. Press DTM Parameters ( F7 ). Use the knob or the number key pad to highlight and change DTM CS Timeslot.

Deferred DTM CS Timeslot

  1. Press Call Setup .
  2. Press Handover Parameters ( F10 ).
  3. Press DTM Handover Setup ( F9 ).
  4. Use the knob or the number key pad to highlight and change DTM CS Timeslot.

Configure DTM CS Half Rate Sub Channel

The following procedures detail how to choose both immediate and deferred DTM CS Timeslot the test set will use. See DTM CS Half Rate Sub Channel for more information.

Immediate DTM CS Half Rate Sub Channel

  1. Press Call Setup .
  2. Press PDTCH Parameters ( F9 ).
  3. Press More on the bottom right side of the screen until menu 3 of 3 of PDTCH Parms is displayed.
  4. Press DTM Parameters ( F7 ). Use the knob or the number key pad to highlight and change DTM CS Half Rate Sub Channel.

Deferred DTM Half Rate Sub Channel

  1. Press Call Setup .
  2. Press Handover Parameters ( F10 ).
  3. Press DTM Handover Setup ( F9 ).
  4. Use the knob or the number key pad to highlight and change DTM CS Half Rate Sub Channel.

Configure DTM CS MS TX Level

This procedure details how to configure DTM CS MS TX Level.

Immediate DTM CS MS TX Level

  1. Press Call Setup .
  2. Press PDTCH Parameters ( F9 ).
  3. Press More on the bottom right side of the screen until menu 3 of 3 of PDTCH Parms is displayed.
  4. Press DTM Parameters ( F7 ). Use the knob or the number key pad to highlight and change DTM CS MS TX Level .

Deferred DTM CS MS TX Level

  1. Press Call Setup .
  2. Press Handover Parameters ( F10 ).
  3. Press DTM Handover Setup ( F9 ).
  4. Use the knob or the number key pad to highlight and change DTM CS MS TX Level.

Configure Specific Features that Dual Transfer Mode Adds/Changes

The test set's display is slightly altered while the Dual Transfer Mode feature is enabled. The following procedures assumes that DTM is enabled and the Operating Mode is set to Active Cell (serving cell GPRS or EGPRS).

Choose the Connection Type

Dual Transfer Mode allows a circuit switched voice connection to be established in any connection type, thus the connection type only effects the data connection.

  1. Press CALL SETUP.
  2. Press Data Conn Type ( F2 ) and choose the type of data connection.

Establish a Mobile Terminated Data Connection

  1. Press CALL SETUP.
  2. Press Data Conn Type ( F2 ) on screen 1 of 2 of the Control menu.
  3. Press Start Data Connection ( F4 ).

Configure the Paging IMSI

  1. Press CALL SETUP .
  2. Press Paging IMSI (F5) on screen 1 of 3 of the Control menu.

Configure and Execute a Handover

The Handover Parameters are accessed from the Call Parms menu.

  1. Press CALL SETUP .
  2. Press Handover Parameters ( F10 ).
  3. Press GSM Handover Setup ( F7 ) or EGPRS Handover Setup ( F8 ).
  4. Set the parameters in the Handover Setup menu.
  5. Press Handover Execute (F5).

Establish a Dual Transfer Mode Connection

This procedure details how to establish an active DTM connection. This procedure assumes that the BCH parameter for band is set up correctly for your mobile station and that the appropriate RF IN/OUT Amplitude Offsets have been set to offset loss between the mobile station and the test set.

  1. Enable/Disable Dual Transfer Mode
  2. Configure the DTM parameters (including the Operating Mode and Data Conn Type ). See Configurable Parameters .
  3. Establish a Call
  4. Establish a packet switched data connection. See How Do I Start a Data Connection? for instructions on how to start a mobile terminated data connection.

Analyze the Dual Transfer Mode Properties

This section assumes that Dual Transfer Mode is enabled.

Supported DTM Class

  1. Press Call Setup .
  2. Observe the DUT Class Information section of the Call Setup screen. The DTM Class GPRS and the DTM Class EGPRS reports indicate which class the DUT supports. Note: The +HR string appears to the right of the class information if the DUT supports Half Rate Dual Transfer Mode Operation. Conversely the +HR string will not be displayed if the DUT does not support Half Rate Dual Transfer Mode operation.

Connection Status while in Dual Transfer Mode

  1. You can observe the connection status in the bottom center portion of the screen. The connection status is displayed in the following form: circuit switched voice connection `/' packet switched data connection.

    If no valid circuit switched voice connection is established, the connection status only displays the packet switched data connection status, as if Dual Transfer Mode were not enabled.

    The mobile station must support Class A operation in order to establish a DTM connection. If the mobile station does not support Class A operation, GPRS Suspended connection status is displayed. The Suspended packet switched data connection status indicates that the packet switched connection has been suspended in order to transfer data on the circuit switched connection rather than to establish a DTM connection.

Related Topics

Dual Transfer Mode


How Do I End a Call?

How Do I End a Call?

Last updated: December 2, 2008

This section is not applicable to GPRS.

  1. Press the CALL SETUP key.
  2. Press the End Call ( F3 ) key, or end the call from the mobile.
  3. Check for Idle in the Active Cell Status: field.


How Do I Make a FM Broadcast test?

How Do I Make a FM Broadcast test?

Last updated: December 2, 2008

This section is only applicable to GSM, GPRS or EGPRS TA applications.

  • How to configure the parameters to perform FM receiver testing?
  • How to set up and test the Mobile Station's demodulated FM output?

How to configure the parameters to perform FM receiver testing?

  1. Turn off RF IN/OUT Amplitude Offsets.

    1. Press SYSTEM CONFIG key .
    2. Press RF IN/OUT Amptd Offset ( F5 ).
    3. Press RF IN/OUT Amptd Offset Setup ( F2 ).
    4. Set the RF IN/OUT Amptd Offset State to Off.

  2. Set the Operating Mode to CW.

    1. Press CALL SETUP key .
    2. Set the Operating Mode to CW.

  3. Configure the FM Broadcast Parameters .

    1. Press RF GEN Configure ( F10 ), this displayed the RF GEN Configure menu .
    2. Use the knob to scroll to and highlight FM Broadcast. The test set is in the correct mode to perform FM receiver testing.
    3. All the FM Broadcast parameters are now visible in the control menu and you can use the knob to set the FM Broadcast Parameters .

How to set up and test the Mobile Station's demodulated FM output?

This procedure provides an example method for testing the Mobile Station's FM receiver performance. It involves the test set's audio analyzer measurement capability.

  1. Set up the FM Broadcast test system.
    1. Connect the FM Adapter to the test set's RF OUT ONLY port.
    2. Connect the Mobile Station's RF antenna to the output of the FM Adapter.
    3. Connect the Mobile Station's demodulated FM output to the test set's HI AUDIO INPUT connector.

    The test set's AUDIO INPUT connectors (HI or LO) are different inputs, therefore unless a different measurement is needed, it is recommended that you ground the LO connector and connect the audio signal to the HI connector.

  2. Initiate the Audio Analyzer measurement in the test set.

    1. Press Measurement Selection key .
    2. Select GSM Analog Audio.

  3. Press Analog Audio Setup ( F1 ), this displayed the Analog Audio Setup menu .

  4. Configure the GSM Analog Audio measurement parameters.

    For example, to view the measurement results for the SINAD Distortion Rate State, the state must be set to ON.

Related Topics

FM Broadcast


How Do I Make GSM Measurements on a Mobile?

How Do I Make GSM Measurements on a Mobile?

Last updated: December 2, 2008

This section is not applicable to GPRS.

Establish a Call

Select Measurements

Establish a Call

  1. Press the blue SHIFT key.
  2. Press the green Preset key.

  3. Connect the mobile to the test set's RF IN/OUT port.

  4. Turn on the mobile and wait for it to camp.

    NOTE
    If the mobile does not camp check that it is set to the correct cell band.

  5. On the mobile press 1 , 2 , 3 , and then press send.
  6. Check for Connected in the Active Cell Status: field.

Select Measurements

  1. Press the Measurement selection key.
  2. Highlight a measurement and press the knob.
  3. Repeat pressing the Measurement selection key, highlight a measurement and press the knob to add measurements.


How Do I Make a Bit Error Measurement?

How Do I Make a Bit Error Measurement?

Last updated: December 2, 2008

Bit Error Ratio is defined in 3GPP TS 51.010 version 5.9, section 14.2.

Measuring the Bit Error Ratio

This procedure assumes that the BCH parameter for Cell Band is set up correctly for your mobile station and that the appropriate RF IN/OUT Amplitude Offsets have been set to offset loss between the mobile station and the test set. For more details see How Do I Configure the Test Set for My Test System? .

To make bit error measurements your mobile must be fitted with a Test SIM card and have ETSI Type B connection capability.

  1. Press the CALL SETUP key.
  2. Press the More key (bottom right) to obtain the Call Parms (3 of 3) screen.
  3. Press the Multislot Config ( F7 ) key and select 1 down, 1 up .
  4. Press the Data Conn Type ( F4 ) key and select ETSI Type B .
  5. Connect the mobile.

  6. Turn the mobile on and wait for Attached in the Active Cell: field.

    For mobiles that don't perform GPRS attach automatically, set the mobile to data mode.

  7. Press the Start Data Connection ( F3 ) key and watch for the Active Cell field changing to Transferring .
  8. Press the Measurement selection key.
  9. Select the Bit Error measurement.
  10. Press the Bit Error Setup ( F1 ) key.
  11. Set the measurement parameters as needed for your measurement situation, including:
    Measurement Timeout = 13.0 s

    A typical bit error ratio measurement result is shown above.

    To see the effect of cell power on the bit error ratio, press the Cell Power ( F7 ) key on the Call Parms (1 of 3) screen and slowly reduce the power while observing the Bit Error display.

Related Topics

Bit Error Measurement

Programming a Bit Error Measurement


How Do I Make a Block Error Measurement?

How Do I Make a Block Error Measurement?

Last updated: December 2, 2008

The Block Error (BLER) measurement which the test set provides is based on GPRS receiver tests defined in 3GPP 51.010, section 14.16 (GPRS) and section 14.18.1 (EGPRS).

Measuring GPRS/EGPRS Block Error

Block error (BLER) measurements cannot be run concurrently with bit error (BER) measurements. Starting a BLER measurement while a BER measurement is currently running, closes the BER measurement.

  1. Press the CALL SETUP key.
  2. Press the More key (bottom right) to obtain the Call Parms (3 of 3) screen.
  3. Connect the mobile.

  4. Turn the mobile on and wait for Attached in the Active Cell field.

    For mobiles that don't perform GPRS attach automatically, set the mobile to data mode.

  5. Press the Start Data Connection ( F3 ) key and watch for the Active Cell field changing to Transferring .
  6. Press the Measurement selection key.
  7. Select the GPRS Block Error measurement.
  8. Press the Block Error Setup ( F1 ) key.
  9. Set the measurement parameters as needed for your measurement situation, including:
    Measurement Timeout = 13.0 s
    Number of blocks to test = 100
  10. If you are testing the a GPRS mobile station, verify the BLER measurement result for the PDTCH/MCS1 to 4 does not exceed 10% at input levels according to the tables in 3GPP TS 51.010 version 5.9, section 14.16.1.2.

    If you are testing an EGPRS mobile station, verify the BLER measurement result for the PDTCH/MCS5 to 9 does not exceed 10% or 30% depending on coding schemes at input levels according to the tables in 3GPP TS 51.010 version 5.9, section 14.18.1 .

    A typical block error measurement result is shown above.

    To see the effect of cell power on the block error, press the Cell Power ( F7 ) key on the Call Parms (1 of 3) screen and slowly reduce the power while observing the Block Error Ratio display.

Related Topics

Block Error Measurement


How Do I Make a Fast Bit Error Measurement?

How Do I Make a Fast Bit Error Measurement?

Last updated: December 2, 2008

Measuring Fast Bit Error

NOTE
To make fast bit error measurements your mobile must be fitted with a Test SIM card.

  1. Establish a call with the mobile.
  2. Press the Measurement selection key.
  3. Select the Fast Bit Error measurement.

    You should hear a warbling sound from the mobile's loudspeaker. This is the PRBS-15 data which the test set sends to the mobile.

  4. Press the Fast Bit Error Setup ( F1 ) key.
  5. Set the measurement parameters as needed for your measurement, including:
    Measurement Timeout = 13.0 s

    To see the effect of cell power on fast bit error rate, press the Cell Power ( F7 ) key and slowly reduce the power while observing Fast Bit Error display.

Related Topics

Fast Bit Error Measurement Description


How Do I Make a IQ Tuning Measurement?

How Do I Make a IQ Tuning Measurement?

Last updated: December 2, 2008

Measuring IQ Tuning

NOTE
This measurement can only be performed with your mobile in test mode and transmitting either all ones or all zeros.

  1. Press the Measurement selection key.
  2. Select the IQ Tuning measurement.
  3. Press the More key (bottom right) to obtain the Call Parms (3 of 4) screen.
  4. Press the Receiver Control ( F7 ) key and select Manual .
  5. Press the ( F11 ) key and set the expected power level from your mobile.
  6. Press the IQ Tuning Setup ( F1 ) key.
  7. Set the measurement parameters as needed for your measurement, including:
    Multi-Measurement Count = 50
    Trigger Source = Immediate
  8. Switch on your mobile and set it to transmit a series of all zeros.

    The results are displayed on the IQ Tuning screen. Notice that when the mobile is transmitting a series of all zeros the carrier offset is at +67.708 kHz.

  9. Change the settings on the mobile to transmit a series of all ones.

    The results are displayed on the IQ Tuning screen. Notice that when the mobile is transmitting a series of all ones the carrier offset is at -67.708 kHz.

  10. Press the Graph ( F2 ) key to access the IQ Tuning bar graph.

    A typical IQ Tuning graph is shown above. On the display, the bar representing each offset and the carrier frequency (Fc) is shown in yellow.

    If you require details on how to navigate through the Output RF Spectrum graph menus, see IQ Tuning Graph Menus .

IQ Tuning Graph Menus

Related Topics

I/Q Tuning Measurement Description


How Do I Make an Output RF Spectrum Measurement?

How Do I Make an Output RF Spectrum Measurement?

Last updated: December 2, 2008

Measuring 3GPP TS 13.16.3 / 13.16.4 Output RF Spectrum

This procedure assumes that the BCH parameter for Cell Band is set up correctly for your mobile station and that the appropriate RF IN/OUT Amplitude Offsets have been set to offset loss between the mobile station and the test set. For more details see How Do I Configure the Test Set for My Test System? .

  1. Connect the mobile.

  2. Turn the mobile on and wait for Attached in the Active Cell field.
    Note: For mobiles that don't perform a GPRS attach automatically, set the mobile to data mode.

  3. Press the Start Data Connection ( F3 ) key and watch for the Active Cell field changing to Transferring .
  4. Press the Measurement selection key.
  5. Select the Output RF Spectrum measurement.
  6. Press the ORFS Setup ( F1 ) key.
  7. Press the Measurement Setup ( F1 ) key.
  8. Set the measurement parameters as needed for your measurement, including:
    Measurement Timeout = 20 s.
  9. Press the Modulation Frequencies ( F2 ) key and set up your required offset frequencies for ORFS due to modulation.
  10. Press the Close Menu ( F6 ) key.
  11. Press the Switching Frequencies ( F3 ) key and set up your required offset frequencies for ORFS due to switching.
  12. Press the Close Menu ( F6 ) key.
  13. Press the Return ( F6 ) key.
  14. Press the Change View ( F2 ) key.
  15. Press the Modulation Numeric ( F1 ) key.

    The figure above displays the ORFS measurement results. Note that the results are in dB relative to the 30 kHz BW Power shown on the screen.
  16. Press the Switching Numeric ( F2 ) key to display the measurement results for ORFS due to switching.

    A typical measurement results screen for ORFS due to switching is shown above.

  17. Press the Graph ( F3 ) key then the Modulation ( F1 ) key to access the ORFS due to modulation bar graph.

    A typical ORFS due to modulation graph is shown above. On the display, the bar representing each offset is shown in yellow and the center frequency is indicated by a white vertical line. There are two limit lines displayed; the absolute limit line is green and the relative limit line is blue. The pass/fail result is relevant to the displayed measurement.

  18. Press the Switching ( F2 ) key to access the ORFS due to switching bar graph.

    A typical ORFS due to switching graph is shown above. On the display, the bar representing each offset is shown in blue and the center frequency is indicated by a white vertical line.

    In this case, the marker is turned on and positioned at the 600 kHz offset. The signal level and frequency of the offset where the marker is positioned, are shown at the top of the display above the graph.

    The marker can be turned on by pressing the Graph Control ( F5 ) key then the Marker Position ( F2 ) key. Set the required marker position using the knob or the numeric entry keys. In addition, the axis values can be changed by pressing the Axis Control ( F1 ) key. This allows you to zoom in or out to look at particular sections of the graph in more detail.

  19. Press the Modulation and Switching ( F3 ) key to access a screen displaying both graphs, as shown in the example below.

    Note that each of the graphs have their own graph controls on F4 and F5 .

    Any failing results are displayed in red.

    If you require details on how to navigate through the Output RF Spectrum graph menus, see Output RF Spectrum Graph Menus .

  20. Press the More key then the Switching Time Domain ( F1 ) key to access a screen displaying Switching Time Domain Graph, as shown in the example below:

    A typical ORFS due to switching Time Domain graph is shown above. On the display, the X axis shows the time of the burst trace data, and the Y axis shows the power value of the burst trace data. A vertical pink line is placed in the middle of bit 0 (or symbol 0 for 8PSK) of each burst. The center position of bit 0 of the burst that you have selected to measure is referred to as 0 us. The start and stop time of the trace data is displayed below the graph. A Marker can be turned on and scrolled across trace data. In this case, the marker is turned on and positioned at the 492.407 us. The signal level and time of the offset where the marker is positioned are shown at the top of the display above the graph.

    Note, the highest level of the Switching ORFS Time Domain trace may not be exactly the same as the result displayed in the Switching ORFS Numeric result screen, since the sampling rate for these two results are different.

  21. Verify the results from the test set meet the conformance requirements detailed in 3GPP TS 51.010 (Version 5.9) section 13.16.3.2 for GPRS mobile stations and 13.17.4.2 for EGPRS mobile stations.

Output RF Spectrum Graph Menus

Related Topics

Output RF Spectrum Measurement Description


How Do I Make a Phase and Frequency Error Measurement?

How Do I Make a Phase and Frequency Error Measurement?

Last updated: December 2, 2008

Measuring 3GPP TS 51.010 Section 13.1 Phase and Frequency Error

This procedure assumes that the BCH parameter for Cell Band is set up correctly for your mobile station and that the appropriate RF IN/OUT Amplitude Offsets have been set to offset loss between the mobile station and the test set. For more details see How Do I Configure the Test Set for My Test System? .

  1. Connect the mobile.

  2. Turn the mobile on and wait for Attached in the Active Cell field located in the bottom center of the screen. Note: For mobiles that don't perform a GPRS attach automatically, set the mobile to data mode.

  3. Press the Start Data Connection ( F3 ) key and watch for the Active Cell field changing to Transferring .
  4. Press the Measurement selection key.
  5. Select the Phase & Frequency Error measurement.
  6. Press the Phase & Freq. Setup ( F1 ) key.
  7. Set the measurement parameters as needed for your measurement situation, including:
    Measurement Timeout = 10 s
  8. Verify that the RMS phase error is not greater than 5 degrees, and the peak phase error is not greater than 20 degrees. Also verify that the mobile station's carrier frequency is accurate to within 0.1 ppm. PCS was the Cell Band used while capturing the results below. For the PCS band the Frequency error should not exceed +/- 195.26 Hz.

    A typical phase and frequency error measurement result is shown above.

  9. Press the Change View ( F2 ) key.
  10. Press the Graph ( F2 ) key to access the peak phase error graph.

    A typical peak phase error graph is shown above.

    The marker can be turned on by pressing the Graph Control ( F5 ) key then the Marker Position ( F2 ) key. Set the required marker position using the knob or the numeric entry keys. In addition, the axis values can be changed by pressing the Axis Control ( F1 ) key. This allows you to zoom in or out to look at particular sections of the graph in more detail.

    A typical peak phase error graph is shown above. This graph is zoomed in to show bits ranging from 100.0 to 120.0 at a 1.0 degrees per division setting. The Y-axis reference point is changed to 5.0 degrees.

    In this case, the marker is turned on and positioned at bit 104. The phase error at the marker and its bit position are shown at the top of the display above the graph.

    If you require details on how to navigate through the phase and frequency error graph menus, see Phase and Frequency Error Graph Menus .

Phase and Frequency Error Graph Menus

Related Topics

Phase and Frequency Error Measurement Description

Programming a Phase and Frequency Error Measurement

SETup:PFERror

FETCh:PFERror

Phase and Frequency Error Troubleshooting


How Do I Make a Power Versus Time Measurement?

How Do I Make a Power Versus Time Measurement?

Last updated: December 2, 2008

This section is only applicable to the lab application and a test application with the required feature license.

The pass/fail result the test set returns indicates whether the entire burst falls within power and timing ranges determined by a point-by-point comparison of the power versus time measurement mask defined in 3GPP TS 05.05 Annex B for either GMSK or EPSK bursts.

Measuring 3GPP TS 51.010 Section 13.3 Power versus Time

This procedure assumes that the BCH parameter for Cell Band is set up correctly for your mobile station and that the appropriate RF IN/OUT Amplitude Offsets have been set to offset loss between the mobile station and the test set. For more details see How Do I Configure the Test Set for My Test System? .

NOTE
This measurement procedure assumes that your mobile supports four adjacent uplink timeslots.

  1. Press the CALL SETUP key.
  2. Press PDTCH Parameters ( F9 ),
  3. Press the More key (bottom right) to obtain the Call Parms (2 of 2) screen.
  4. Press the Multislot Config ( F7 ) key and select 1 down, 5 up .
  5. Connect the mobile.

  6. Turn the mobile on and wait for Attached in the Active Cell field.
    Note: For mobiles that don't perform a GPRS attach automatically, set the mobile to data mode.

  7. Press the Start Data Connection ( F3 ) key and watch for the Active Cell field changing to Transferring .
  8. Press the Measurement selection key.
  9. Select the Power vs Time measurement.
  10. Press the Power vs Time Setup ( F1 ) key.
  11. Press the Measurement Setup ( F1 ) key.
  12. Set the measurement parameters as needed for your measurement situation, including:
    Burst Capture Range = All; Measurement Timeout = 10 s
  13. Press the Burst Meas Offsets ( F2 ) key and then Burst 1 Meas Offset ( F1 ), Burst 2 Meas Offset ( F2 ), Burst 3 Meas Offset ( F3 ), or Burst 4 Meas Offset ( F4 ) to set up your required time offset values for each burst.

    NOTE
    For statistical analysis the test set allows you to set up to 12 time markers. These markers do not define the mask but allow you to obtain measurement results from specified points on the mask. If you want to define your own custom mask, you can do this using the Custom Mask Setup parameters within the Power vs Time Setup menu.

    Offsets are referenced to bit zero in a normal burst. To obtain results from measurement points before bit 0, enter negative offset values.

  14. Press the Close Menu ( F6 ) key.

    A typical summary results screen is shown above.

  15. Press the Return ( F6 ) key twice.
  16. Press the Change View ( F2 ) key.
  17. Press the Burst numeric Results ( F2 ) key then Burst 1 Numeric Results ( F1 ), Burst 2 Numeric Results ( F2 ), Burst 3 Numeric Results ( F3 ), or Burst 4 Numeric Results ( F4 ) to view the offset measurement results for each burst.

    A typical numeric measurement results screen for offsets is shown above.

  18. Press the Return ( F6 ) key.
  19. Press the Graph ( F3 ) key to access the full graph view of the four adjacent uplink bursts.

    The structure of the Power versus Time graph menus are slightly different depending on the number of uplink bursts in the multislot configuration. If you require details on how to navigate through the Power versus Time graph menus, see either:

    • Power versus Time Graph Menus .

    A typical full graph view of four adjacent uplink bursts is shown above.

    Two types of pass/fail results are provided:

    • An overall measurement pass/fail indicator is positioned in the bottom left corner of the display:
      • The text "Pass" is shown in a green-colored font if the measurement has passed the entire mask.
      • The text "Fail" is shown in a red-colored font if the measurement has failed any part of the mask.
    • Individual pass/fail indicators are provided for each section of the mask. On the display, text labels corresponding to the following sections change color to indicate a pass or fail (green indicates a pass; red indicates a fail):
      • Rise section( Rise )
      • Active (useful) section of Burst 1,2,3,4 ( B1, B2, B3, B4 )
      • Guard period between burst 1 and 2, burst 2 and 3, burst 3 and 4. ( GP1, GP2, GP3 ) (Note: these indicators is only available if you are measuring more than two uplinks)
      • Fall section

    When the Multi-Measurement Count parameter is set to a number greater than 1, it is possible for some, or all of the individual pass/fail indicators to show a pass while the overall pass/fail indicator shows a fail. This is because the individual pass/fail indicators relate to the last of the multi-measurements made, whereas the overall mask pass/fail indicator is an accumulative result from all the multi-measurements made.

    You can zoom in to individual sections of the graph by pressing the Guard Period ( F2 ), and then press Guard Period 1 (F1), Guard Period 2 (F2), or Guard Period 3 ( F3 ) keys. In addition, you can control a marker or change axis values by pressing the Graph Control ( F5 ) key, Marker position ( F2 ).

    A typical graph view of the falling edge of burst 2 is shown above. You can access this view by pressing the Guard Period ( F2 ) key then the Guard Period 2 ( F1 ) key.

    In this case, the marker is turned on and positioned on the falling edge. The marker can be turned on by pressing the Graph Control ( F5 ) key then the Marker Position ( F2 ) key. Set the required marker position using the knob or the numeric entry keys. The signal level at the marker and its position along the x-axis are shown at the top of the display above the graph.

Power versus Time Graph Menus

Related Topics

Power versus Time Measurement Description


How Do I Change Measurement Setup in GSM?

How Do I Change Measurement Setup in GSM?

Last updated: December 2, 2008

This section is not applicable to GPRS or EGPRS.

A. Select a measurement.

  1. Press the Measurement selection key.
  2. Highlight the measurement to be set up and press the knob.

B. Set up the measurement.

  1. Press the setup key ( F1 ) for the measurement selected.
  2. Highlight a parameter and press the knob.

  3. Enter a value or make a selection and press the knob.

    NOTE
    For statistical measurement results, change the Multi-Measurement Count parameter from Off to a number >1.

  4. Press the Close Menu ( F6 ) key.


How Do I Make a Transmit Power Measurement?

How Do I Make a Transmit Power Measurement?

Last updated: December 2, 2008

This section is only applicable to the lab applications and a test application with the required feature license.

This section contains the measurement procedures for:

  • Measuring 3GPP TS 51.010 13.16.2 GPRS Transmitter Output Power
  • Measuring 3GPP TS 51.010 13.16.2 EGPRS Transmitter Output Power

Measuring 3GPP TS 51.010 13.16.2 GPRS Transmitter Output Power

This procedure assumes that the BCH parameter for Cell Band is set up correctly for your mobile station and that the appropriate RF IN/OUT Amplitude Offsets have been set to offset loss between the mobile station and the test set. For more details see How Do I Configure the Test Set for My Test System? .

Measuring a single burst with Transmit Power (TXP) Measurement

  1. Establish a call with the mobile.
  2. Press the Measurement selection key.
  3. Select the Transmit Power measurement.
  4. Press the GSM/GPRS TX Power Setup ( F1 ) key, set the Burst Capture Range to Single .
  5. Set the other measurement parameters as needed for your measurement situation.

A typical measurement result is shown above.

Measuring multiple bursts with Transmit Power (TXP) Measurement

  1. Connect the mobile.

  2. Turn the mobile on and wait for Attached in the Active Cell: field.
    Note: For mobiles that don't perform a GPRS attach automatically, set the mobile to data mode.

  3. Press the Start Data Connection ( F3 ) key and watch for the Active Cell: field changing to Transferring .
  4. Press the Measurement selection key.
  5. Select the Transmit Power measurement.
  6. Press the GSM/GPRS TX Power Setup ( F1 ) key, set the Burst Capture Range to All .
  7. Set the other measurement parameters as needed for your measurement situation.

    A typical measurement result when the Burst Capture Range is set to All the is shown above.

Measuring 3GPP TS 51.010 13.16.2 EGPRS Transmitter Output Power

This procedure assumes that the BCH parameter for Cell Band is set up correctly for your mobile station and that the appropriate RF IN/OUT Amplitude Offsets have been set to offset loss between the mobile station and the test set. For more details see How Do I Configure the Test Set for My Test System? .

Measuring a single burst with EGPRS Transmit Power (ETXP) Measurement

  1. For instructions on how to setup the test set and start an EGPRS data connection, refer to Configuring the Test Set and Starting a Data Connection for EGPRS Measurements .
  2. Press the Measurement selection key.
  3. Select the EGPRS Transmit Power measurement.
  4. Press the EGPRS TX Power Setup ( F1 ) key, set the Burst Capture Range to Single .
  5. You can set the other measurement parameters as needed for your measurement situation, for example:
    Measurement Timeout = 5.0 s

A typical 8PSK measurement result is shown above.

Measuring multiple bursts with Transmit Power (TXP) Measurement

  1. For instructions on how to setup the test set and start an EGPRS data connection, refer to Configuring the Test Set and Starting a Data Connection for EGPRS Measurements .
  2. Press the Measurement selection key.
  3. Select the Transmit Power measurement.
  4. Press the GSM/GPRS TX Power Setup ( F1 ) key.
  5. Use the knob to set the Burst Capture Range to All . Set the other measurement parameters as needed for your measurement situation.

A typical 8PSK measurement result when the Burst Capture Range is set to All is shown above.

Related Topics

Transmit Power Measurement Description


How Do I use Mobile Calculate BER Test

How Do I use Mobile Calculate BER Test

Last updated: December 2, 2008

This section is only applicable to the lab applications and the GSM/EGPRS test applications with the required feature license.

  • How to use Mobile Calculate BER on TCH
  • How to use single source Mobile Calculate BER on EGPRS PDTCH
  • How to use multi source Mobile Calculate BER on EGPRS PDTCH

How to use Mobile Calculate BER on TCH

  1. Press CALL SETUP .
  2. Press Operating Mode (F1 ) and set the operating mode to GSM BCH+TCH.
  3. Press TCH Parameters ( F8 ).
  4. Press Channel Mode Setup ( F11 ). The Channel Mode menu is displayed. Set the Channel Mode to FR Speech or EFR Speech.
  5. Set the TCH Clearcoded State to ON.
  6. Press the right More key until screen 2 of 2 is displayed.
  7. Press Speech Setup ( F10 ). This displayed the Speech Setup menu.
  8. Set the Speech Source to PRBS-9, PRBS-15 or Custom.

How to use single source Mobile Calculate BER on EGPRS PDTCH

  1. Press CALL SETUP .
  2. Press Operating Mode (F1 ) and set the operating mode to EGPRS BCH+PDTCH.
  3. Press the left More key until screen 2 of 2 is displayed.
  4. Press Channel Protocol Control ( F4 ).
  5. Press LLC ( F3 ).
  6. Press Payload Pattern Setup ( F2). This displayed the Payload Pattern menu.
  7. Set the Payload Pattern (Other) to proper pattern.
  8. Press PDTCH Parameters (F9 ).
  9. Press MCS/PS (F11 ). This displayed the MCS/PS menu.
  10. Set the EGPRS Test Mode Payload Mapping to Single Source, ClearCoded.

How to use multi source Mobile Calculate BER on EGPRS PDTCH

  1. Press CALL SETUP .
  2. Press Operating Mode (F1 ) and set the operating mode to EGPRS BCH+PDTCH.
  3. Press PDTCH Parameters (F9 ).
  4. Press the right More key until screen 2 of 2 is displayed.
  5. Press Multislot Config ( F7). This displayed the Multislot Config menu.
  6. Use the knob to highlight the parameter and to change the parameter setting.
  7. Press Return (F12 ).
  8. Press PDTCH Parameters (F9 ).
  9. Press MCS/PS (F11 ). This displayed the MCS/PS menu.
  10. Set the EGPRS Test Mode Payload Mapping to Multi Source, ClearCoded.
  11. Press Return (F12 ).
  12. Press the left More key until screen 2 of 2 is displayed.
  13. Press Protocol Control ( F4 ).
  14. Press LLC ( F3 ).
  15. Press Payload Pattern Setup ( F2). This displayed the Payload Pattern menu.
  16. Use the knob to highlight the parameter and to change the Multi Source Payload Pattern (Other) setting.
  19. Use the knob to highlight the parameter and to change the Multi Source Payload Pattern (Other) setting..

Related Topics

Mobile Calculate BER Test

Logical Link Control (LLC) Layer Configurable Parameters

Configuring the Traffic Channel (TCH) Parameters

CALL:FUNCtion

CALL:TCHannel

CALL:(PDTCH|PDTChannel)


How Do I Change Paging Parameters?

How Do I Change Paging Parameters?

Last updated: December 2, 2008

  1. Press the CALL SETUP key.
  2. Press the Paging Parameters ( F5 ) key. This displays the Paging Parameters menu similar to the one shown below. NOTE: You must set TMSI Assignment to On before you can set the TMSI parameter.

  3. To change a parameters, scroll to and highlight it using the knob, enter a value, and press the knob to store the value.

Refer to the Operating Considerations below before attempting to configure the cell parameters.


How do I Make Rach Measurements?

How do I Make Rach Measurements?

Last updated: December 2, 2008

This section details how to make RACH measurements for the different operating modes the test set offers. These procedures assume that the BCH parameter for Cell Band is set up correctly for your mobile station and that the appropriate RF IN/OUT Amplitude Offsets have been set to offset loss between the mobile station and the test set. An example scenario is given.

Overview of Measurement Procedure in Active Cell Mode

  1. Set operating mode to Active Cell.
  2. Press Receiver Control (F12).
  3. Set the Expected Power Control to Manual and set the Manual Burst Power.
  4. Set the test set's Measurement Frequency to the frequency the RACH will arrive on. The simplest way to do this is to set the manual channel (that is, the expected ARFCN) to the ARFCN of the BCH. Alternatively, you could set the expected frequency to the uplink frequency of the BCH ARFCN.
  5. Ensure trigger mode is set to Auto.

Once the RACH measurement is completed, in order to make further measurements on the TCH, ensure you reset the receiver control to Auto.

Overview of Measurement Procedure in Test Mode

This procedure assumes that the BCH parameter for the cell band is set up correctly for your mobile station and the appropriate RF IN/OUT Amplitude Offsets have been set to offset loss between the mobile station and the test set.

  1. Press CALL SETUP
  2. Set Operating Mode to any non-Active Cell mode that has a Broadcast Channel (BCH). These operating modes include: GSM BCH , GSM BCH+TCH , GPRS BCH , GPRS BCH+PDTCH , EGPRS BCH and EGPRS BCH+PDTCH .
  3. Press Receiver Control ( F12 )

  4. Set the Expected Power Control parameter to Manual . and set the Manual Power for each uplink burst in the multislot configuration.

  5. Set the Measurement Frequency to the expected BCH receiver frequency.
  6. Press Close Menu ( F6 )
  7. Press Measurement selection
  8. Select Power vs Time .
  9. Press Change View ( F2 )
  10. Press Burst 1 Numeric Results ( F2 ). Note: Changing views after the measurement is complete will loose your measurement results.

  11. Using your proprietary commands, initiate the mobile to generate a sequence of RACH bursts on the BCH, or set the Expected Power Control parameter to Manual .

  12. Set the Measurement Frequency to the expected BCH receiver frequency.
  13. Start the appropriate measurement.
  14. Make a mobile originated call. While the Operating Mode is set to one of the modes in step 1, the test set will not respond to a random access burst which allows the mobile station to generate additional random access bursts.

Example Procedure

The following procedure details how to manually make a GSM power versus time RACH measurement while the Operating Mode is GSM BCH+TCH.

  1. Press CALL SETUP
  2. Press Operating Mode ( F1 ) and choose GSM BCH+TCH from the Operating Mode menu.
  3. Press Receiver Control ( F12 )

  4. Set the Expected Power Control parameter to Manual .

  5. Set the Measurement Frequency to the expected BCH receiver frequency.
  6. Press Close Menu ( F6 )
  7. Press Measurement selection
  8. Select Power vs Time .
  9. Press Change View ( F2 )
  10. Press Burst 1 Numeric Results ( F2 ). Note: Changing views after the measurement is complete will loose your measurement results.

  11. Originate a call from the mobile station. The results are automatically displayed on the front panel. You can confirm the measurement was on the random access burst by observing the burst is shorter than a normal burst. The useful part of a RATCH burst is 312.2 µs. The results should be similar to the figure below.

  12. Press Graph (F4). This shows the graphical representation of the data. The display should look similar to the figure below.This clearly shows the random access burst is shorter than a normal traffic channel burst, as the green lines show boundaries for a normal burst.

  13. To make further measurements on the TCH ensure that the Receiver Control is returned to Auto.

Related Topics

RACH Measurement Description


How Do I Set Up a Call?

How Do I Set Up a Call?

Last updated: December 2, 2008

This section is only applicable to GSM. The procedures detailed in this section are:

  • Setting Up the Call Parameters
  • Establishing a Mobile Terminated Call
  • Establishing a Mobile Originated Call

Setting Up the Call Parameters

This procedure assumes the mobile station is initially turned off. The control menu and the Call Parms menu provide access to all the parameters needed to set up a call.

  1. Press Call Setup .
  2. Press Operating Mode ( F1 ) and set the operating mode to Active Cell ( Serving Cell GSM , GPRS or EGPRS ).
  3. Press Connection Type ( F2 ). Auto is the only connection type that is applicable to GSM.
  4. Press BCH Parameters ( F7 ).
  5. Press Cell Power ( F7 ) and ensure the cell power is at a sufficient level. (The default value is -85 dBm.)
  6. Press Cell Band ( F8 ) and select the cell band that your mobile station supports.
  7. Press Broadcast Chan ( F9 ) and set the ARFCN.
  8. Turn on the mobile station. Watch for the connection status field to change from Idle to Attached .
  9. Press Originate Call ( F3 ) and accept a call from the test set.
  10. To establish a call, see the procedures for Establishing a Mobile Terminated Call and Establishing a Mobile Originated Call .

Establishing a Mobile Terminated Call

The following procedure assumes that you have properly set up all the call parameters, see Setting Up the Call Parameters .

  1. Press Originate Call ( F4 )
  2. Accept the call from the test set.
  3. The connection status field changes from Attached to Setup Request and then to Connected when the call is established.

Establishing a Mobile Originated Call

The following procedure assumes that you have properly set up all the call parameters, see Setting Up the Call Parameters .

  1. Dial a number on the mobile station.
  2. Press the button on the mobile station that sends a call.
  3. The connection status field changes from Attached to Setup Request and then to Connected when the call is established.


How Do I Use the Spectrum Monitor?

How Do I Use the Spectrum Monitor?

Last updated: December 2, 2008

The following procedure shows a typical usage of the spectrum monitor in each of its two modes of operation; Swept Mode and Zero Span mode.

  1. Establish a call with the mobile.

    The spectrum monitor can also be used with any of the test set's test mode operating modes.

  2. Press the Instrument selection key.
  3. Select Spectrum Monitor .

    The spectrum monitor is displayed with the default settings as shown above. The Swap Window Positions ( F5 ) key is only displayed when other measurements are active at the same time as the spectrum monitor.

  4. Set the axis control as needed for your testing situation using the Frequency Span ( F1 ), Reference ( F2 ), and dB/div ( F3 ) keys. See Table 1: Frequency Span, Resolution Bandwidth and Dynamic Range to find the valid Frequency Span entries while in swept mode. To set the reference level manually ( Auto is the default), press the Reference ( F2) key then use the DATA ENTRY keys to enter the value you want.
  5. Press the Trigger Setup ( F4 ) key to access the Trigger Setup menu.
  6. Set the trigger settings to meet your testing needs. For example:

    • If you want the Spectrum Monitor to sweep immediately and continuously, ensure that Trigger Arm ( F3 ) is set to Continuous .
    • If you want to use external triggering, so that the Spectrum Monitor is triggered from a signal applied to the TRIG IN connector on the test set's rear panel, set Trigger Source ( F1 ) to External .
    • Trigger Delay ( F2 ) allows you to specify the point, relative to the trigger event where samples are taken (a negative trigger delay value collects pre-trigger samples). The same trigger delay setting is used for swept mode and zero span mode.
    • Res Bw allows you to set the resolution bandwidth. If you want the resolution bandwidth coupled with the with the Frequency Span , set this field to AUTO by pressing the gray DATA ENTRY softkey labeled ON , otherwise use the knob or the numeric DATA ENTRY softkeys to set the resolution bandwidth. See Table 1: Frequency Span, Resolution Bandwidth and Dynamic Range to find the valid entries for the resolution bandwidth while in swept mode. Note that changing the resolution bandwidth does not modify the zero span resolution bandwidth setting.

  7. Press the Return ( F6 ) key to exit the Trigger Setup menu.
  8. Press the Display ( F6 ) key to access the display settings.

    A typical spectrum monitor trace display is shown above. In this case, the Display menu is open allowing you to access all of the display control settings using the ( F1 ) through ( F12 ) keys.

    The following list provides examples of some of the settings you may want to adjust:

    • Detection Method ( F2 ) determines the algorithm used to find the value that represents each frequency bin. See Detection Method for more information.

    • Peak Threshold ( F4 ) and Peak Excursion ( F5 ) set the peak threshold and peak excursion levels respectively. A peak is identified by using the peak threshold and peak excursion value. A point is only marked as a peak if it rises and falls more than the peak excursion value from the peak threshold value.

    • Marker Mode ( F8 ) sets the mode of the active marker. Position mode activates a single frequency marker. Delta mode freezes the active marker at its current location and uses it as a reference marker. A second marker is created at the position of the reference marker and is used as a delta marker, reporting any change in amplitude or frequency from that of the reference marker.

    • Peak Search ( F10 ) moves the active marker to the highest peak on the spectrum monitor display, returning the numeric amplitude and frequency values.

    • Marker -> Expected Freq ( F11 ) sets the base station emulator's expected frequency to the frequency of the active marker. This setting is not available in zero span mode.

    • Marker -> Expected Power ( F12 ) sets the base station emulator's expected power level to the amplitude of the active marker.

    A typical swept mode spectrum monitor display is shown above. In this case, the active marker is marker 1, which is set to Delta mode.

  9. Press the Return ( F6 ) key to exit the Display menu.
  10. To set the spectrum monitor to zero span mode, press the Frequency Span ( F1 ) key and use the numeric DATA ENTRY keys to enter a value of 0 MHz , or use the down-arrow key to reduce the span to zero.

    A typical zero span mode spectrum monitor display is shown above. Like swept mode, the Y-axis represents absolute amplitude. However, the X-axis now represents time rather than frequency.

  11. Press the Trigger Setup ( F6 ) key. In zero span mode, additional trigger setup controls are available to you:
    • If you want to change the view window over which you are looking at the signal, use the Time Span ( F8 ) and Time Offset ( F9 ) keys. The measurement is made for the duration of the time span, beginning at the time defined by the trigger event plus the trigger delay plus the time offset.
    • If you want to change the resolution bandwidth, press the Zero Span RBW ( F7 ) key and select a value. (To measure the total power of a signal you must select a resolution bandwidth greater than or equal to the signal bandwidth.) See Table 1: Frequency Span, Resolution Bandwidth and Dynamic Range to find the valid entries for the resolution bandwidth while in zero span mode. Note that changing the zero span resolution bandwidth does not modify the swept mode resolution bandwidth.

    A typical zero span mode spectrum monitor display showing a bursted signal. The viewing window has been adjusted to zoom in on a single burst.

    If the temperature of the test set drifts outwith the calibrated temperature range of the spectrum monitor, a Measurement Uncalibrated message is displayed. To calibrate the spectrum monitor for the current temperature, press the Calibrate Measurement ( F11 ) key on the Trigger Setup menu.

Related Topics

Spectrum Monitor Description


How Do I Configure the Test Set for My Test System?

How Do I Configure the Test Set for My Test System?

Last updated: December 2, 2008

A. Configure instrument information and setup.

  1. Press the SYSTEM CONFIG key.
  2. Press the Instrument Setup ( F1 ) key.
  3. Change an Instrument Setup Value and then press the Close Menu ( F6 ) key.

CAUTION
Always verify that the test set is responding to a new LAN IP Address by pinging the test set. If the test set does not respond to the ping, cycle power. This will ensure that the test set will respond to the new LAN IP Address.

B. Set amplitude offsets.

  1. Press the System Config button on the right side of the screen.
  2. Press the RF IN/OUT Amptd Offset ( F5 ) key on the Configuration Summary screen shown in part A.
  3. On the RF IN/OUT Amplitude Offset screen, press the RF IN/OUT Amptd Offset Setup ( F2 ) key.
  4. Enter the test frequencies and their associated amplitude offsets. Twenty test frequencies and amplitude offsets can be set.
  5. Press the Close Menu ( F6 ) key.
  6. Press the Return ( F6 ) key to return to the Configuration Summary screen.

C. Check the message log.

  1. Press the System Config button on the right side of the screen.
  2. Press the Message Log ( F7 ) key and view the message log.
  3. You can clear the message log by pressing Clear Message Log ( F10 )
  4. Press the Return ( F12 ) key.


How Do I Set the TBF Parameters?

How Do I Set the TBF Parameters?

Last updated: December 2, 2008

This section is only applicable to the lab applications. This section contains procedures that answer the following questions:

  • How Do I Set the Extended Uplink TBF State?
  • How Do I Set the Temporary Block Flow (TBF) Control Parameters?

How Do I Set the Extended Uplink TBF State?

  1. Press CALL SETUP .
  2. Press Operating Mode ( F1 ) and select Cell Off with the knob.
  3. Press Cell Info ( F6 ).
  4. Press Cell Operation ( F1) .
  5. Scroll to and highlight the Extended Uplink TBF State using the knob.
  6. Use the knob to highlight the ON or OFF in the Value column.
  7. Press Close Menu ( F6 ).
  8. Press Return ( F6 ).
  9. Press Operating Mode ( F1 ) and select an Active Cell operating mode.

How Do I Set the Temporary Block Flow (TBF) Control Parameters?

This section details how to access and configure the TBF control parameters. If you wish to set the Extended uplink duration, please follow the above procedure ( How Do I Set the Extended Uplink TBF State? ) to first enable the Extended Uplink TBF.

  1. Press CALL SETUP .
  2. Press the bottom left More key until the Control menu 2 of 3 is displayed.
  3. Press Protocol Control ( F4 ).
  4. Press RLC/MAC ( F2) .
  5. Press TBF Control ( F5) .
  6. Configure the necessary parameters. Use the knob to highlight and set the TBF Control parameters. Note: The state of the delayed downlink TBF is automatically set to On , when this parameter is set to a value. If you wish to turn this value Off, use the knob to highlight the parameter and press the OFF key.

The delayed downlink TBF, extended uplink TBF, and TBF re-establishment affect the test set's operation when the Operating Mode is set to Active Cell (serving cell GSM, GPRS, or EGPRS) and the Data Conn Type is set to Auto .

Related Topics

Temporary Block Flow (TBF) Parameters


How Do I Turn Off a GSM Measurement?

How Do I Turn Off a GSM Measurement?

Last updated: December 2, 2008

This section is not applicable to GPRS or EGPRS.

  1. Press the Measurement selection key.
  2. Highlight the measurement you want to turn off.
  3. Press the Close Measurement ( F4 ) key.
  4. Press the Close Menu ( F6) key.


How Do I Set Up and Test Cell Selection and Transitions?

How Do I Set Up and Test Cell Selection and Transitions?

Last updated: December 2, 2008

This section is only applicable to the Lab Applications.

Description

  • Set Up the Two-Cell Test System
  • Mobile-initiated Cell Selection/Reselection
    • Mobile-initiated Cell Selection
    • Mobile-initiated Cell Reselection (Idle Mode)
    • Mobile-initiated Cell Reselection (PS Data Transfer Mode)
  • Network-Initiated Cell Reselection and Handover
    • Network-initiated Cell Reselection (Idle Mode and PS Data Transfer Mode)
    • Handover (CS Voice and DTM)

Set Up the Two-Cell Test System

This procedure details how to set up the two-cell test system.

All of the procedures in this section require that you first set up the two-cell test system as follows:

  1. Connect the two test sets via an External Device Connection .
  2. If remote control of the test sets in the two-cell test system is required, connect each test set GPIB port to the controlling PC.
  3. Connect the mobile's RF port to both test sets in the two-cell test system via an RF splitter.
  4. Compensate for the losses through the splitter by setting the Amplitude Offset for each test set.
  5. Important : you must set DUT IP Address to a different value in each test set.
    In the GSM/GPRS/EGPRS application, DUT IP Address is accessible from DUT PDP Setup ( F2 ). In the W-CDMA/HSDPA application, DUT IP Address is accessible from DUT IP Setup ( F2 ).
  6. If you wish to emulate a GSM/GPRS/EGPRS cell in one or both test sets:
    • Set Operating Mode ( F1 ) to Cell Off .
    • Set the BCH Cell Band to the proper value for your mobile, then set Broadcast Chan to a different value in each test set ( BCH Parameters ( F7 )).
    • Set TCH Traffic Channel and PDTCH Traffic Channel to a different value in each test set ( TCH Parameters ( F8 ) and PDTCH Parameters ( F9 )).
    • Set Cell Identity , LAC , RAC , NCC and BCC to a different value in each test set ( Cell Info ( F6 ), Cell Identification ( F3 )).
    • Set Persistent Attach State to On in both test sets ( Cell Info ( F6 ), Cell Operation ( F1 )).
    • Set IMSI Attach State to On in both test sets ( Cell Info ( F6 ), Cell Parameters ( F1 )).
    • Select Cell Info ( F6 ), Cell Lists ( F4 ):
      1. Select GSM Neighbours (BCH) ( F1 ), set Cell State to On and set Neighbor Cell 1 ARFCN , NCC and BCC to match the Broadcast Chan , NCC and BCC settings in the other test set (if both test sets are emulating a GSM/GPRS/EGPRS cell).
      2. Select 3G FDD Neighbors ( F4 ), set UARFCN State to On and set UARFCN and Cell 1 Scrambling Code to match the DL Channel and Primary Scrambling Code settings in the other test set (if the other test set is emulating a W-CDMA/HSDPA cell).
    • Set Cell Parameters as desired to affect the cell selections/reselections ( Cell Info ( F6 )).
    • To allow mobile-initiated cell reselections, set Network Control Order to 0 or 1 ( Measurement Reports ( F6 ), Configure ( F2 ), General Meas Parameters ( F1 )).
    • Set Cell Power ( F7 ) as desired ( BCH Parameters ( F7 )).
    • Ensure that Data Connection Type ( F2 ) is set to Auto in both test sets.
    • Set Operating Mode ( F1 ) to Active Cell (GSM) , Active Cell (GPRS) or Active Cell (EGPRS) as desired in each test set.
  7. If you wish to emulate a W-CDMA/HSDPA cell in one of the test sets:
    • Set Operating Mode ( F1 ) to Cell Off .
    • Set DL Channel to the proper value for your mobile ( Channel (UARFCN) Parms ( F12 ).
    • Set Primary Scrambling Code as desired ( Generator Info ( F3 ), Downlink Channel Codes ( F2 ), Shared Channel Codes ( F2 )).
    • Select SIB11 Cell Info List ( F3 ):
      1. Select SIB11 GSM Cells 1-4 Info List ( F4 ), set GSM 1st Cell State to On and set GSM 1st Cell NCC , BCC , Shared ARFCN Indicator and ARFCN to match the Broadcast Chan , NCC and BCC settings in the other test set.
    • Set LAC , RAC and Cell Identity to different values from the other test set, and set ATT (IMSI Attach) Flag State to Set ( Cell Info ( F2 ), Cell Parameters ( F1 )).
    • Set Cell Parameters , Reselection Parameters and Access Restriction Parameters as desired to affect the cell selections/reselections ( Cell Info ( F2 )).
    • Set Cell Power ( F7 ) as desired.
    • Set GPRS Radio Access Bearer as desired ( Data Channels ( F4 ), Packet Data Setup ( F1 )).
    • Set Operating Mode ( F1 ) to Active Cell .

Mobile-initiated Cell Selection/Reselection

Mobile-initiated Cell Selection

This procedure allows you to observe which cell the mobile selects from the two-cell test system once it has completed its power-up sequence.

  1. Set Up the Two-Cell Test System
  2. Power on the mobile.
  3. Wait for the mobile to perform its cell selection algorithms and camp on one of the test sets in the two-cell test system.
  4. Check to see which test set the mobile registers with/attaches to.

Mobile-initiated Cell Reselection (Idle Mode)

This procedure assumes that you have Set Up the Two-Cell Test System , the mobile has been powered on and is camped on one of the cells in the system as is described in the Mobile-initiated Cell Selection procedure.

Note, mobile-initiated cell reselection is not possible from a W-CDMA/HSDPA cell when the mobile is PDP active. If you turn off the serving W-CDMA/HSDPA test set's cell power, the mobile will find the other test set and establish a PDP Context with it; however, this is not the same as a mobile-initiated reselection to the other test set.

  1. Change the cell characteristics of one or both of the test sets in the two-cell test system such that the test set to which the mobile is not currently camped has more desirable characteristics than the one to which it is camped. For example, change the Cell Power of one or both of the test sets so that the test set that was not initially selected has a much stronger signal (or simply turn the cell power off in the test set the mobile is currently camped on).
  2. Verify that the mobile did in fact reselect the more appropriate cell by observing the changes in the connection status of both test sets in the two-cell test system. If the mobile automatically registers/attaches with the other test set, it is easy to see which cell the mobile is camped on by observing the connection status window. You can also originate a voice call from the mobile to determine to which cell it is currently camped.
  3. Repeat steps 1 and 2 if you want to force the mobile to return to the other test set in the two-cell test system.

Mobile-initiated Cell Reselection (PS Data Transfer Mode)

This procedure assumes that you have Set Up the Two-Cell Test System and the mobile has been powered on and is camped on one of the cells in the system as is described in the Mobile-initiated Cell Selection procedure.

Note, mobile-initiated cell reselection is not possible from a W-CDMA/HSDPA cell when the mobile is PDP active. If you turn off the serving W-CDMA/HSDPA test set's cell power, the mobile will find the other test set and establish a PDP Context with it; however, this is not the same as a mobile-initiated reselection to the other test set.

  1. Start a GPRS/EGPRS data connection between the mobile and the external server and configure the other test set for the type of data connection you wish to transfer to (by selecting the Operating Mode and Coding Scheme for GPRS/EGPRS or the GPRS Radio Access Bearer and CQI Value for W-CDMA/HSDPA).
  2. Press the Instrument Selection key and select Data Throughput Monitor on both test sets. Observe the transfer of data on the current serving cell. You can also observe the DUT IP counters present on the Call Setup screen in GPRS/EGPRS or on the Data Channels screen in W-CDMA/HSDPA.
  3. Change the cell characteristics of one or both of the test sets in the two-cell test system such that the test set which the mobile is not currently camped on has more desirable characteristics than the one it is currently camped on. For example, change the Cell Power of one or both of the test sets so that the test set that was not initially selected has much stronger signal (or simply turn the cell power off in the test set the mobile is currently camped on).
  4. Verify that the mobile did in fact reselect the more appropriate cell by observing the Data Throughput Monitor display and IP counters on both test sets.
  5. Repeat steps 1 through 4 if you want to force the mobile to return to the other test set in the two-cell test system.

Network-Initiated Cell Reselection and Handover

Network-initiated Cell Reselection (Idle Mode and PS Data Transfer Mode)

This procedure explains how to test both idle mode and packet-switched data transfer mode cell reselections. This procedure assumes that you have Set Up the Two-Cell Test System and the mobile has been powered on and is camped on one of the cells in the system as is described in the Mobile-initiated Cell Selection procedure. No CS voice call should be connected in this procedure.

Note, in a W-CDMA/HSDPA cell, for Release 99 mobiles, network-initiated cell reselection is only possible when the mobile is PDP active.

  1. For idle mode cell reselections from a GSM/GPRS/EGPRS cell, ensure that the mobile is attached or PDP active. For idle mode cell reselection from a W-CDMA/HSDPA cell, ensure that the mobile is PDP active. For PS data transfer mode cell reselection, ensure that there is an active GSM/GPRS/EGPRS or W-CDMA/HSDPA data connection between the mobile and test set by observing the Data Throughput Monitor .
  2. If the current serving cell is GSM/GPRS/EGPRS, select Handover Parameters ( F10 ), Ext Handover Setup ( F9 ). If the current serving cell is W-CDMA/HSDPA, select Handovers ( F5 ), 1 of 2 ( MORE ), External 8960 Handover ( F1 ).

    Note: The external handover menus are only available if the two test sets currently have an External Device Connection . This can be verified by observing the External Device Connection Setup screen ( SYSTEM CONFIG , More ( 1 of 2 ), External Device Connection ( F4 )), or the ExtDev status indicator in the Instrument Status Area :

  3. Press Ext Handover Execute or Execute Ext 8960 Handover ( F5 ). This instructs the network to send a PCCO message if the current serving cell is GPRS/EGPRS or a CCO message if the current serving cell is W-CDMA/HSDPA.
  4. Ensure that the (packet) cell change order was successful by viewing connection status on both test sets (for idle mode cell reselection) or the Data Throughput Monitor display and IP counters on both test sets (for PS data transfer mode cell reselection).
  5. Repeat steps 1 through 4 if you want to force the mobile to return to the other test set in the two-cell test system.

Handover (CS Voice and DTM)

This procedure only applies to CS (Circuit-Switched) voice and DTM (Dual Transfer Mode) handovers. This procedure assumes that you have Set Up the Two-Cell Test System and the mobile has been powered on and is camped on one of the cells in the system as is described in the Mobile-initiated Cell Selection procedure.

Note, because simultaneous services are not supported in the W-CDMA/HSDPA application, handing over a GSM/GPRS/EGPRS DTM connection to a W-CDMA/HSDPA cell is unsupported, and may result in undetermined behavior.

  1. Establish a mobile originated or mobile terminated CS voice call with one of the test sets, (or a DTM connection if your GSM/GPRS/EGPRS mobile supports it and your two-cell test system is emulating two GSM/GPRS/EGPRS cells). The voice connection status should display Connected (for a DTM connection, the connection status window displays the voice and data connection status in the form: voice/data).
  2. If the current serving cell is GSM/GPRS/EGPRS, select Handover Parameters ( F10 ), Ext Handover Setup ( F9 ). If the current serving cell is W-CDMA/HSDPA, select Handovers ( F5 ), 1 of 2 ( MORE ), External 8960 Handover ( F1 ).

    Note: The external handover menus are only available if the two test sets currently have an External Device Connection . This can be verified by observing the External Device Connection Setup screen ( SYSTEM CONFIG , More ( 1 of 2 ), External Device Connection ( F4 )), or the ExtDev status indicator in the Instrument Status Area :

  3. Press Ext Handover Execute or Execute Ext 8960 Handover ( F5 ). This instructs the network to begin its handover procedure.
  4. Ensure that the handover was successful by viewing the connection status window. During the handover, both test sets display Handover . The destination test set then transitions to Connected , while the originating test set transitions to Idle .
  5. Repeat steps 1 through 4 if you want to force the mobile to return to the other test set in the two-cell test system.

Related Topics

Two-Cell Test System


Printing and Saving Screen Images

Printing and Saving Screen Images

Last updated: December 2, 2008

Printing and Saving Screen Images

The test set's local area network (LAN) connection can be used to dump the currently-displayed screen image into a personal computer's web browser. The computer must either be connected to an existing LAN or have a LAN adapter installed that can be connected directly to the test set.

Computer Requirements for LAN Communications with the Test Set

The computer used to capture screen images from the test set must meet the following requirements:

  • 10 Base-T, IEEE 802.3 compliant, ethernet network interface using TCP/IP protocol and configured to run in half-duplex mode.
  • Windows 95, 98, 2000 or NT 4.0 (Windows 95, Windows 98, Windows 2000 and Windows NT 4.0 are U.S. registered trademarks of Microsoft Corporation.)

Test Set to Computer Connections

The test set's LAN connection can be made at either the rear-panel LAN PORT or at the front-panel DATA port. When using the DATA port, be sure to have the factory supplied jumper cable installed between the rear-panel LAN PORT and the ETHERNET TO FRONT PANEL port.

Connections from the test set to the computer must be made using the correct type of LAN cable:

  • If the test set is being connected to the computer through an existing network, use a standard LAN cable.
  • If the test set is being connected directly to the computer's LAN adapter, use a crossover LAN cable (such as the one shipped with the test set or with an older test application upgrade kit).

Capturing the Screen Image

  1. Press the test set's SYSTEM CONFIG key to display the test set's LAN settings, and record the LAN IP Address for use later in this procedure.
  2. Start a web browser application on your computer.
  3. Display the test set screen that you want to capture.
  4. Enter the following address/location into your web browser: http://<lan address>/display.htm
    where <lan address> is the LAN IP address of the test set .
  5. Within a few seconds, the test set's screen image appears in your browser. If the image does not appear on your browser within 30 seconds, refer to Test Your LAN Connections and Configuration by "Pinging" the Test Set below.
  6. To print the image, select File , Print .
  7. To save the file:
    1. Select File , or right-click on the image, and select Save As or Save Picture As .
    2. Enter the desired file name and directory path for saving the image as a GIF file.

The image can now be retrieved from your directory and used as needed.

Test Your LAN Connections and Configuration by "Pinging" the Test Set

Perform this operation only if you were not successful in downloading the test set screen image into your browser.

  1. Display the Command Prompt window on your computer. This is typically done in the Microsoft Windows operating system by selecting Start -> Programs -> Command Prompts .
  2. At the command prompt, enter the following command: ping <lan address>. The <lan address> is the test set's LAN IP address. (The command prompt does not have to be at the root (c:\) level before entering the command.)

    This example shows what should happen when you enter the ping command for a test set with the LAN IP address of 111.22.333.44. The test set should reply back to the Command Prompt screen indicating that data was received.
  3. If the message " Request Timed Out " is displayed instead of a reply from the test set, try entering the command again. If the request times out again, your LAN connections are incorrect and/or your LAN settings for the two devices do not match.

Troubleshooting LAN Connections

If your web browser did not display the test set's screen, or you could not "ping" your test set from your browser, refer to the following information to find the cause and fix the problem.

Try Altering Connections

  • If you are using the test set's front panel DATA port, make sure the jumper between the rear-panel LAN PORT and ETHERNET TO FRONT PANEL port is in place; or try connecting directly to the rear-panel LAN PORT.
  • Try using a different type of LAN cable. If you were using a crossover cable, try using a standard LAN cable; if using a standard LAN cable, try using a crossover cable. If this doesn't fix the problem, be sure to replace the cable with the type recommended in Test Set to Computer Connections above.

Reconfigure the Computer and Test Set LAN Settings

If the test set's image is still not displayed on your web browser, and the ping command still indicates that the test set is not communicating with the computer, you need to verify that the LAN settings for the computer and the test set are compatible. The following sections provide general guidelines in getting the LAN settings configured for both instruments to communicate with each other.

Perform the configuration in the following order:

  1. Configure the computer's LAN settings.
  2. Restart Windows on the computer to start using the new LAN configuration.
  3. Configure the test set's LAN settings to work with the computer's settings. (It is important that the computer be configured and re-started before configuring the test set's LAN settings.)
  4. Turn the test set off and back on to make sure it finds the computer's newly-configured LAN card on power up.

LAN Setting Guidelines

  • It is highly recommended that the Subnet Mask be set to 255.255.248.0 for the test set and the computer when using a direct computer-to-test set connection.
  • The first three groups of numbers for the LAN IP Address of the test set and the computer must match. Example; if the test set's LAN IP Address is set to 130.29.189.33, the computer's LAN IP address must begin with 130.29.189.

    The number in the fourth group of digits in the computer's and test set's LAN IP Addresses must NOT match. Example; if the test set is set to LAN IP Address 130.29.189.33, set the computer's LAN IP Address to 130.29.183.34 (or 130.29.183.77, 130.29.183.42...- just so the last number is not also set to 33). The last entry in the IP Address must not be >254 or 0.

Changing the LAN Setting on Your Computer

Network configuration procedures vary between operating systems. You may have to refer to your computer's help system, or your LAN adapter card's documentation, for assistance.

Perform the following steps to alter the network settings for most PCs using a Microsoft Windows operating system.

Access the Network Settings

  1. Double-click on the My Computer icon on the Windows desk top.
  2. Double-click on the Control Panel icon.
  3. Double-click on the Network icon.
  4. Select the TCP/IP -> [your Ethernet network adapter] entry from the list of components. Note: Do not select TCP/IP Dial-Up Adapter settings if present.
  5. Select Properties to access the TCP/IP settings screen.
Accessing Your Computer's LAN Settings

Set the IP Address and Subnet Mask

  1. Select the IP Address tab on the TCP/IP Properties screen.
  2. Select Specify an IP Address .
  3. Enter the IP Address for the computer. Remember, the last entry in the IP Address must not be >254 or 0.
  4. Enter the Subnet Mask (255.255.248.0).
Specifying the Computer's IP Address and Subnet Mask

Remove Any Gateway Setting

  1. Select the Gateway tab.
  2. If present, remove any existing setting.
  3. Click OK until you have closed the Network settings window.
Accessing the Gateway Setting

Restart Windows

Depending on your LAN network adapter, your computer may or may not apply the network configuration changes as they are made. It is import that you restart Windows NOW to make sure new LAN settings are in effect when you try to connect to the test set.

Changing the LAN Settings on Your Test Set

  1. Press the SYSTEM CONFIG key on the test set to display the current LAN settings.
  2. Press the F1 ( Instrument Setup ) key.

    NOTE
    Changing the LAN IP Address may alter the Subnet Mask setting. Therefore, change the LAN IP Address first, then change the Subnet Mask. Also, The last entry in the IP Address must not be >254 or 0.

  3. Turn the knob to highlight the setting you want to change.
  4. Press the knob to select the setting.
  5. Enter the new value using the keypad, and press the knob to complete the setting.
  6. Turn the test set off and back on to start using the new settings.


Rear Panel Connectors

Rear Panel Connectors

Last updated: December 2, 2008

Description

BASEBAND I/O

Four pins are functional on this connector:

  • I channel (pin 9)
  • Q channel (pin 26)
  • Ground
  • Ground

CLK IN

Not functional for this release.

COUNTER IN

Not functional for this release.

DATA IN

Not functional for this release.

DATA VALID IN

Not functional for this release.

ETHERNET TO FRONT PANEL

This RJ-45 connector is used with a separate LAN jumper cable to connect the front panel DATA connector to the rear panel LAN PORT.

The the DATA connector on the front panel is connected internally to the ETHERNET TO FRONT PANEL connector on the rear panel. In order to use the front panel DATA connector the user must connect the rear panel LAN PORT, to the rear panel ETHERNET TO FRONT PANEL connector with the LAN jumper cable.

The LAN jumper cable, part number E5515-61160, is supplied with the test set.

EXT INTERFACE CONTROL

Not functional for this release.

EXT SIG GEN/FRAME SYNCH

Not functional for this release.

FM MOD IN

This BNC connector allows you to use an external signal to frequency modulate the test set's RF generator. It has a fixed sensitivity of 20 KHz/volt, and a frequency range of 100Hz to 20 KHz.

GPIB

This GPIB connector allows test set control with compatible devices.

LAN PORT

This RJ-45 connector provides connection for downloading firmware upgrades, new applications and for acquiring screen captures. In the lab application only, the LAN PORT is also used for protocol logging and to transfer data to the test set.

PRINTER

Not functional for this release.

SERIAL 1

Not functional for this release.

SERIAL 2

Not functional for this release.

SERIAL 3

Not functional for this release.

TEST SET SYNCH IN

Not functional for this release.

TEST SET SYNCH OUT

Not functional for this release.

TIMEBASE ADJUST

This is the timebase adjust cover. Removing this screw allows access for timebase adjustment.

TRIG IN

This BNC connector provides the capability for you to trigger measurements or instruments from an external source. Setting the Trigger Source setting to External for measurements or instruments which support this feature causes the measurement or instrument to trigger when a positive-going TTL compatible pulse is applied to this connector. Currently, the only measurement or instrument which supports this feature is the Spectrum Monitor.

TRIG OUT

This BNC connector allows you to synchronize the test set to other equipment via a trigger signal.

VGA OUT

This DB-15 connector allows you to simultaneously route the test set's display to another monitor.

10 MHZ REF IN

This BNC connector accepts an external 10 MHz timebase signal. The nominal input impedance is 50 ohm. This version of test set can only accept a 10 MHz timebase signal.

10 MHZ REF OUT

This BNC connector provides a 10 MHz timebase signal to external test equipment. The accuracy of this signal is determined by the timebase used. The nominal output impedance is 50 ohm with a typical level of 0.5 V rms.

Related Topics

Frame Trigger Parameters

Timebase Description/Configuration

SYSTem:ROSCillator

Configuring the Test Set's GPIB Address

Description


Remote/Local Mode

Remote/Local Mode

Last updated: December 2, 2008

Description

Remote Mode

When the test set is operated remotely, all of the keys on the front panel of the test set are disabled (except the LOCAL key and the power switch). During remote operation the test set is controlled by the Remote User Interface, (RUI).

Any open menus are be closed, and any manual entries are be aborted when the test set transitions from local mode to remote mode.

The remote annunciator (R) will appear in the Instrument Status Area of the test set's display indicating that the test set is in remote mode.

When the test set is in remote mode press the LOCAL key on the front panel in order to gain manual control.

Local Mode

During local mode all front panel keys and the knob are enabled. During local operation the test set is controlled by the Manual User Interface, (MUI).

The remote annunciator (R) is turned off when the test set is operated in local mode.

Related Topics

Configuring the Test Set's GPIB Address


Save and Recall Registers

Save and Recall Registers

Last updated: December 2, 2008

Description

The test set provides up to five save/recall registers . Each register is identified by a number (1-5).

This section details the following:

  • Recalling Saved Registers
  • Deleting Saved Registers
  • Settings that are Saved
  • Settings that are not Saved
  • Saving Current Settings to a Register

Recalling Saved Registers

Press the Register recall hardkey.

Use the knob to scroll to a register that is labeled Full and press the knob.

When a register is recalled, the test set will clear all active measurements and display the Call Setup Screen. Registers can only be recalled in the format they were saved in. For example, in a fast switching application, a register that is saved in a specific format must also be recalled in that same format. If a register is attempted to be recalled in a format other than the one it was saved in, the following error will occur:

CAUTION
If the test set has had hardware options installed since the last time a registers were saved, delete the registers and re-save them. Failure to perform this step could result in a non-recoverable firmware "assert" when performing a register recall.

Deleting Saved Registers

Pressing the DELETE hardkey will display a menu indicating which registers have been saved (they are labeled "Full").

Use the knob to scroll to a register and press the knob. Select Yes to confirm the selection.

Settings that are Saved

All functions and parameters that have an associated static state or settable value will be saved. For example:

  • Cell parameters (System ID, Network ID, etc.)
  • Call control parameters (System Type, Operating Mode, etc.)
  • Measurement setup parameters (Trigger Arm state, Measurement Timeout, etc.)
  • Call Parms (Cell Power, Cell Band, etc.)

Settings that are not Saved

Functions that trigger immediate actions, such as originating a call or calibrating a measurement are not saved.

Settings saved in non-volatile memory (settings that are unchanged when power is cycled or the test set is preset) are not saved. For example:

  • LAN IP Address
  • Date/Time
  • RF IN/OUT Amplitude Offset
  • All other settings on the Instrument Setup menu on the System Config screen.
  • Measurement results
  • Call status
  • Active measurements

Read-only call processing results such as Mobile Station Information tables are not saved.

Saving Current Settings to a Register

To save the current state of the test set, press the SAVE hardkey.

A menu will be displayed that shows the status of all five registers. If the register status is "Full", the register has had instrument settings saved to it. If the register status is "Empty", it does not currently contain any instrument settings.

Use the knob to scroll to a register and press the knob. If the selected register is currently Full, select Yes in the Overwrite Save Reg? window and it will be overwritten.

CAUTION
When a test set application is upgraded using the 8960 File Utility Program, the new revision of the application will not automatically retain save/recall registers from the old revision. Prior to the application upgrade, it is recommended that you record the critical settings (such as call setup information) from registers that you will want to re-save after the test application upgrade.

Related Topics

SYSTem:REGister


Getting Started with the GSM/GPRS/EGPRS Test and Lab Applications

Getting Started with the GSM/GPRS/EGPRS Test and Lab Applications

Last updated: December 2, 2008

This online user's guide provides detailed information about your application's features and functionality, as well as how to use these features to test your wireless device.

The Contents menu on the left-hand side of this page provides access to all of the information contained within this online user's guide. The following is a description of these Contents topics. If you have trouble finding the information you need by navigating through the Contents topics, use the search field at the top of this page to search the contents of this guide.

  • Call Processing : Describes how to configure the test set's base station emulator and perform key call processing operations.
  • Measurements : Describes the measurements and instruments available within your application. Provides a list of which key conformance tests are supported by the test set.
  • Manual Operation : Describes how to configure the test set and perform call processing operations and measurements from the front panel.
  • Programming : Describes how to configure the test set and perform call processing operations and measurements by remote program.
  • GPIB Commands : Provides details on all of the GPIB syntax available to control the test set by remote program.
  • Protocol Logging : (lab application only) Describes how to capture the exchange of data and control information between the test set and wireless device.
  • Data Channel : (lab application only) Describes how to use the test set as a router while you exchange data between your wireless device and remote servers.
  • Troubleshooting : Provides troubleshooting information for performing measurements and key call processing events. Includes a test set block diagram.
  • Configuration : Describes how to set amplitude offsets, switch between applications, and configure the test set (such as GPIB and LAN ports).
  • Fast Switching : Explains how to use fast switching test and lab applications.
  • Release Notes : Lists the features and functionality of the applications for each release of the firmware.
  • Downloadable Manuals : Provides a portable version of this online user's guide, which you may download to your computer.

For pricing and availability, brochures and datasheets for these applications, visit these product pages:

  • E1968A GSM/GPRS/EGPRS Mobile Test Application


How Do I Change Call Parameters?

How Do I Change Call Parameters?

Last updated: December 2, 2008

  1. Press the CALL SETUP key.

    When the mobile is in voice call or transferring data ( Active Cell: field is connected or Transferring ) some call parameters cannot be changed.

  2. On the Call Parms menu press F7 , F8 , F9, F10 or F12 .
  3. Enter a value or highlight a selection and press the knob.


How Do I Change the MS TX Level?

How Do I Change the MS TX Level?

Last updated: December 2, 2008

There are two ways to change the MS TX Level:

  • Change the level immediately
  • Change the level during a handover

Both are explained below.

A. Change the MS TX level immediately.

  1. Press the CALL SETUP key.
  2. On the Call Parms menu (3 of 3) press the MS TX Level ( F8 ) key.
  3. Set a new MS TX level and press the knob.
  4. Press the Close Menu ( F6 ) key.

B. Change the MS TX level during a handover.

  1. Press the CALL SETUP key.
  2. Press the Handover Parameters ( F10 ) key.
  3. Select and change the MS TX Level .
  4. Press the Handover Execute ( F5 ) key to change the MS TX level, or press the Close Menu ( F6 ) key to leave the level unchanged.
  5. Use the More key to check that the MS TX level has been changed on the Call Parms menu (3 of 3).


Configuring the Test Set and Starting a Data Connection for GPRS Measurements

Configuring the Test Set and Starting a Data Connection for GPRS Measurements

Last updated: December 2, 2008

This section is only applicable to EGPRS.

Test Set Configuration

How Do I Start a Data Connection?

Test Set Configuration

Setup parameters for this measurement are assumed to be set to their default (Full preset) values unless otherwise stated. This procedure also assumes that the BCH parameter for band is set up correctly for your mobile station and that the appropriate RF IN/OUT Amplitude Offsets have been set to offset loss between the mobile station and the test set.

  1. Press the CALL SETUP key.
  2. Press Operating Mode ( F1 ) and select Active Cell (GPRS) .
  3. Press the Data Conn Type ( F2 ) key, and select ETSI Type A. (See Connection Types for other connection types that can be used with EGPRS measurements.)
  4. Select PDTCH Parameters ( F9 ) from the Call Parms menu.
  5. Select Coding Scheme ( F11 ) from the PDTCH Parms menu. The Coding Scheme popup menu appears.
  6. Select one of the coding schemes.
  7. Press the Close Menu ( F6 ) key.

How Do I Start a Data Connection?

  1. Connect the mobile.

  2. Turn the mobile on and wait for Attached in the Active Cell: field.

  3. Press the Start Data Connection ( F3 ) key and watch for the Active Cell: field changing to Transferring .


How Do I End the GPRS Data Connection?

How Do I End the GPRS Data Connection?

Last updated: December 2, 2008

This section is only applicable to GPRS.

  1. Press the CALL SETUP key.
  2. Press the End Data Connection ( F3 ) key, or end the data connection from the mobile.
  3. To ensure the data connection has ended check for Attached in the Active Cell: field.


How Do I Perform a Handover?

How Do I Perform a Handover?

Last updated: December 2, 2008

This section assumes the BCH parameter for Cell Band is set up correctly for your mobile station and the appropriate RF IN/OUT Amplitude Offsets have been set to offset the mobile station and the test set. For more information see How Do I Configure the Test Set for My Test System? .

  1. If you would like a log of the protocol messages exchanged between the test set and the mobile station, use the Wireless Protocol Advisor (WPA). For more information see How to use Protocol Logging .
  2. Press the CALL SETUP key.
  3. Select Operating Mode ( F1 ) and choose Active Cell with a desired Serving Cell ( GSM , GPRS , or EGPRS ).
  4. Start a voice or data connection with the test set.
  5. Press the Handover Parameters ( F10 ) key.
  6. To perform a handover on a GSM call, press GSM Handover Setup ( F7 ). To perform a handover with a GPRS data connection, press GPRS Handover Setup ( F8 ).
  7. Change the various parameters, for example, for a GSM handover, you can change the Traffic Band .
  8. Press the Handover Execute ( F5 ) key to complete the handover, or press the Close Menu ( F6 ) key to abort the handover.
  9. Check the Active Cell field for Connected if you made a GSM Handover, or Transferring if you made a GPRS Handover.

Related Topics

AMR: Verify successful Handovers


How Do I Make GPRS Measurements on a Mobile?

How Do I Make GPRS Measurements on a Mobile?

Last updated: December 4, 2008

This section is not applicable to GSM.

A. Establish a data connection.

  1. Press the blue SHIFT key.
  2. Press the green Preset key.
  3. Connect the mobile.

  4. Turn the mobile on and wait for Attached in the Active Cell: field.

    For mobiles that don't perform GPRS attach automatically, set the mobile to data mode.

  5. Press the Start Data Connection ( F3 ) key and watch for the Active Cell: field changing to Transferring .

    If you have problems establishing a data connection using the default BLER Data Connection Type (that is, Data Conn Type ( F4 ) is set to BLER ), you may want to change the setting of the BLER FCS (Frame Check Sequence) or the Block Poll Rate . To change these settings, press the More key to access the Control menu ( 2 of 2 ), then press the Protocol Control ( F4 ) key. Block Poll Rate is available under the RLC/MAC ( F1 ) key and BLER FCS is available under the LLC ( F2 ) key. Select a parameter and change its setting.

B. Select measurements.

  1. Press the Measurement selection key.
  2. Highlight a measurement and press the knob.
  3. Repeat steps 1 and 2 to add measurements.


How Do I Change Measurement Setup in GPRS?

How Do I Change Measurement Setup in GPRS?

Last updated: December 2, 2008

This section is not applicable to GSM.

A. Select a measurement.

  1. Press the Measurement selection key.
  2. Highlight a measurement to set up and press the knob.

B. Set up the measurement.

  1. Press the measurement's setup ( F1 ) key.
  2. Highlight a parameter and press the knob.

  3. Enter a value or make a selection and press the knob.

    For Statistical measurement results, change the Multi-Measurement Count parameter from Off to a number >1.

  4. Press the Close Menu ( F6 ) key.


How Do I Turn Off a GPRS Measurement?

How Do I Turn Off a GPRS Measurement?

Last updated: December 2, 2008

This section is not applicable to GSM.

  1. Press the Measurement selection key.
  2. Highlight the measurement you want to turn off.
  3. Press the Close Measurement ( F4 ) key.
  4. Press the Close Menu ( F6 ) key.


CALL:TRIGger

CALL:TRIGger

Last updated: December 2, 2008

GPIB Command Conventions

  • CALL:TRIGger[:OUTPut][:ALL]:STATe:OFF

  • CALL:TRIGger[:OUTPut]:FRAMe:NIDLe:STATe
  • CALL:TRIGger[:OUTPut]:FRAMe:STATe
  • CALL:TRIGger[:OUTPut]:FRAMe:SYMBol
  • CALL:TRIGger[:OUTPut]:FRAMe:SYNChronize
  • CALL:TRIGger[:OUTPut]:FRAMe:SYNChronize:OFFSet
  • CALL:TRIGger[:OUTPut]:FRAMe:TSLot

  • CALL:TRIGger[:OUTPut]:HFRame:STATe
  • CALL:TRIGger[:OUTPut]:HFRame:FOFFset

  • CALL:TRIGger[:OUTPut]:MFRame:(PDTCH|PDTChannel):STATe
  • CALL:TRIGger[:OUTPut]:MFRame:(PDTCH|PDTChannel):FOFFset
  • CALL:TRIGger[:OUTPut]:MFRame:BCHannel:STATe
  • CALL:TRIGger[:OUTPut]:MFRame:BCHannel:FOFFset

  • CALL:TRIGger[:OUTPut]:RBLock:(PDTCH|PDTChannel):STATe
  • CALL:TRIGger[:OUTPut]:RBLock:(PDTCH|PDTChannel):FOFFset

  • CALL:TRIGger[:OUTPut]:PMESsage[:TSET][:TX]:PUASsignment:STATe
  • CALL:TRIGger[:OUTPut]:PMESsage[:TSET][:TX]:PUASsignment:FOFFset
  • CALL:TRIGger[:OUTPut]:PMESsage:DUT:TX:PUASsignment:STATe
  • CALL:TRIGger[:OUTPut]:PMESsage:DUT:TX:PUASsignment:FOFFset
  • CALL:TRIGger[:OUTPut]:PMESsage[:TSET][:TX]:PDASsignment:STATe
  • CALL:TRIGger[:OUTPut]:PMESsage[:TSET][:TX]:PDASsignment:FOFFset
  • CALL:TRIGger[:OUTPut]:PMESsage:DUT:RX:PDASsignment:STATe
  • CALL:TRIGger[:OUTPut]:PMESsage:DUT:RX:PDASsignment:FOFFset
  • CALL:TRIGger[:OUTPut]:PMESsage[:TSET][:TX]:PTReconfig:STATe
  • CALL:TRIGger[:OUTPut]:PMESsage[:TSET][:TX]:PTReconfig:FOFFset
  • CALL:TRIGger[:OUTPut]:PMESsage:DUT:TX:PTReconfig:STATe
  • CALL:TRIGger[:OUTPut]:PMESsage:DUT:TX:PTReconfig:FOFFset
  • CALL:TRIGger[:OUTPut]:PMESsage[:TSET][:TX]:PPCTadvance:STATe
  • CALL:TRIGger[:OUTPut]:PMESsage[:TSET][:TX]:PPCTadvance:FOFFset
  • CALL:TRIGger[:OUTPut]:PMESsage[:TSET][:TX]:PIASsignment:STATe
  • CALL:TRIGger[:OUTPut]:PMESsage[:TSET][:TX]:PIASsignment:FOFFset
  • CALL:TRIGger[:OUTPut]:PMESsage:DUT:TX:PIASsignment:STATe
  • CALL:TRIGger[:OUTPut]:PMESsage:DUT:TX:PIASsignment:FOFFset
  • CALL:TRIGger[:OUTPut]:PMESsage:DUT:RX:PIASsignment:STATe
  • CALL:TRIGger[:OUTPut]:PMESsage:DUT:RX:PIASsignment:FOFFset
  • CALL:TRIGger[:OUTPut]:PMESsage[:TSET][:TX]:IREQuest:STATe
  • CALL:TRIGger[:OUTPut]:PMESsage[:TSET][:TX]:IREQuest:FOFFset
  • CALL:TRIGger[:OUTPut]:PMESsage[:TSET][:TX]:AACCept:STATe
  • CALL:TRIGger[:OUTPut]:PMESsage[:TSET][:TX]:AACCept:FOFFset
  • CALL:TRIGger[:OUTPut]:PMESsage[:TSET][:TX]:DREQuest:STATe
  • CALL:TRIGger[:OUTPut]:PMESsage[:TSET][:TX]:DREQuest:FOFFset
  • CALL:TRIGger[:OUTPut]:PMESsage[:TSET][:TX]:PDPAccept:STATe
  • CALL:TRIGger[:OUTPut]:PMESsage[:TSET][:TX]:PDPAccept:FOFFset
  • CALL:TRIGger[:OUTPut]:PMESsage[:TSET][:TX]:PDPRequest:STATe
  • CALL:TRIGger[:OUTPut]:PMESsage[:TSET][:TX]:PDPRequest:FOFFset

CALL:TRIGger[:OUTPut][:ALL]:STATe:OFF

Function

GSM TA

This command is not applicable to the GSM test application.
GPRS TA This command is not applicable to the GPRS test application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.

GSM/GPRS LA

 Disable all triggers.

EGPRS LA
Requirements GSM/GPRS LA

Revision: C.01 and above

EGPRS LA

Revision: A.01 and above

Programming Example:

OUTPUT 714;"CALL:TRIGGER:STATE:OFF"
! Disable all triggers

CALL:TRIGger[:OUTPut]:FRAMe:NIDLe:STATe

Function

GSM TA

Enables a trigger signal on every frame except the Idle Frame.
GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Setting

 0 | OFF | 1 | ON

Query

 0 | 1

*RST setting

 0

Requirements

 GSM/GPRS TA Revision: A.01 and above
GSM/GPRS LA

Revision: C.01 and above

Programming Example:

OUTPUT 714;"CALL:TRIGGER:FRAME:NIDLE:STATE 1"
! Enable the Every Frame except Idle trigger

CALL:TRIGger[:OUTPut]:FRAMe:STATe

Function | GSM TA | Enables a trigger signal on every frame.
 | GPRS TA
 | EGPRS TA
 | GSM/GPRS LA
 | EGPRS LA
Setting |  | 0 | OFF | 1 | ON
Query |  | 0 | 1
*RST setting |  | 0
Requirements | GSM/GPRS TA | Revision: A.01 and above
 | GSM/GPRS LA | Revision: C.01 and above

CALL:TRIGger[:OUTPut]:FRAMe:SYMBol

Function | GSM TA | Sets the symbol position on the Every Frame trigger.
 | GPRS TA
 | EGPRS TA
 | GSM/GPRS LA
 | EGPRS LA
Setting |  | Range: 0 to 1250
Query |  | Range: 0 to 1250
*RST setting |  | 0
Requirements | GSM/GPRS TA | Revision: A.01 and above
 | GSM/GPRS LA | Revision: C.01 and above

CALL:TRIGger[:OUTPut]:FRAMe:SYNChronize

Function

GSM TA

This command is not applicable to the GSM test application.
GPRS TA This command is not applicable to the GPRS test application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.

GSM/GPRS LA

 Sends the neighbour cell synchronization trigger output.

EGPRS LA

Requirements

 GSM/GPRS TA Revision: A.01 and above
GSM/GPRS LA

Revision: C.01 and above

Programming Example:

OUTPUT 714;"CALL:TRIGger:FRAMe:SYNChronize"
! Send the neighbour cell synchronization trigger

CALL:TRIGger[:OUTPut]:FRAMe:SYNChronize:OFFSet

Function

GSM TA

This command is not applicable to the GSM test application.
GPRS TA This command is not applicable to the GPRS test application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.

GSM/GPRS LA

Sets the symbol offset prior to the 0'th frame for the neighbour cell synchronization trigger.

EGPRS LA

Setting

 Range: 0 to 150 symbols
Resolution: 1 symbol

Query

 Range: 0 to 150 symbols
Resolution: 1 symbol

*RST setting

 0
Requirements GSM/GPRS LA

Revision: C.01 and above

Programming Example:

OUTPUT 714;"CALL:TRIG:FRAM:SYNC:OFFS 5"
! Causes the synchronization trigger to occur 5 symbols before the first symbol of the 0'th frame

CALL:TRIGger[:OUTPut]:FRAMe:TSLot

Function

GSM TA

Sets the timeslot on the Every Frame trigger.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Setting

 Range: 0 to 7

Query

 Range: 0 to 7

*RST setting

 0

Requirements

 GSM/GPRS TA Revision: A.01 and above
GSM/GPRS LA

Revision: C.01 and above

Programming Example:

OUTPUT 714;"CALL:TRIGger:FRAMe:TSLot 5"
! Set the timeslot of the Every Frame trigger to 5

CALL:TRIGger[:OUTPut]:HFRame:STATe

Function

GSM TA

This command is not applicable to the GSM test application.
GPRS TA This command is not applicable to the GPRS test application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.

GSM/GPRS LA

Enables a trigger signal on every hyperframe.

EGPRS LA

Setting

 0 | OFF | 1 | ON

Query

 0 | 1

*RST setting

 0

Requirements

 GSM/GPRS TA Revision: A.01 and above
GSM/GPRS LA

Revision: C.01 and above

Programming Example:

OUTPUT 714;"CALL:TRIGGER:HFRAME:STATE 1"
! Enable the hyperframe trigger

CALL:TRIGger[:OUTPut]:HFRame:FOFFset

Function

GSM TA

This command is not applicable to the GSM test application.
GPRS TA This command is not applicable to the GPRS test application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.

GSM/GPRS LA

Sets the frame offset on the hyperframe trigger.

EGPRS LA

Setting

 Range: 0 to 2715647

Query

 Range: 0 to 2715647

*RST setting

 0

Requirements

 GSM/GPRS TA Revision: A.01 and above
GSM/GPRS LA

Revision: C.01 and above

Programming Example:

OUTPUT 714;"CALL:TRIGGER:HFRAME:FOFFSET 2000"
! Set the hyperframe trigger to occur at frame 2000

CALL:TRIGger[:OUTPut]:MFRame:(PDTCH|PDTChannel):STATe

Function

GSM TA

This command is not applicable to the GSM Test Application.

GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

Enables a trigger signal on every PDTCH multiframe.

EGPRS LA

Setting

 0 | OFF | 1 | ON

Query

 0 | 1

*RST setting

 0

Requirements

 GSM/GPRS TA Revision: A.01 and above
GSM/GPRS LA

Revision: C.01 and above

Programming Example:

OUTPUT 714;"CALL:TRIGger:MFRame:PDTCh:STATe 1"
! Enable the multiframe trigger

CALL:TRIGger[:OUTPut]:MFRame:(PDTCH|PDTChannel):FOFFset

Function

GSM TA

 This command is not applicable to the GSM Test Application.

GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

Sets the frame offset on the PDTCH multiframe trigger.

EGPRS LA

Setting

 Range: 0 to 51

Query

 Range: 0 to 51

*RST setting

 0

Requirements

 GSM/GPRS TA Revision: A.01 and above
GSM/GPRS LA

Revision: C.01 and above

Programming Example:

OUTPUT 714;"CALL:TRIGger:MFRame:PDTCh:FOFFset 25"
! Set the multiframe trigger to occur at frame 25

CALL:TRIGger[:OUTPut]:MFRame:BCHannel:STATe

Function

GSM TA

This command is not applicable to the GSM test application.
GPRS TA This command is not applicable to the GPRS test application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.

GSM/GPRS LA

Enables a trigger signal on every BCH multiframe.

EGPRS LA

Setting

 0 | OFF | 1 | ON

Query

 0 | 1

*RST setting

 0

Requirements

 GSM/GPRS TA Revision: A.01 and above
GSM/GPRS LA

Revision: C.01 and above

Programming Example:

OUTPUT 714;"CALL:TRIGGER:MFRAME:BCHANNEL:STATE 1"
! Enables the BCH multiframe trigger

CALL:TRIGger[:OUTPut]:MFRame:BCHannel:FOFFset

Function

GSM TA

This command is not applicable to the GSM test application.
GPRS TA This command is not applicable to the GPRS test application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.

GSM/GPRS LA

Sets the frame offset on the BCH multiframe trigger.

EGPRS LA

Setting

 Range: 0 to 50

Query

 Range: 0 to 50

*RST setting

 0

Requirements

 GSM/GPRS TA Revision: A.01 and above
GSM/GPRS LA

Revision: C.01 and above

Programming Example:

OUTPUT 714;"CALL:TRIGGER:MFRAME:BCHANNEL:FOFFSET 24"
! Sets the BCH multiframe trigger to occur on frame 24

CALL:TRIGger[:OUTPut]:RBLock:(PDTCH|PDTChannel):STATe

Function

GSM TA

This command is not applicable to the GSM test application.
GPRS TA This command is not applicable to the GPRS test application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.

GSM/GPRS LA

Enables a trigger signal on a Radio Block.

EGPRS LA

Setting

 0 | OFF | 1 | ON

Query

 0 | 1

*RST setting

 0

Requirements

 GSM/GPRS TA Revision: A.01 and above
GSM/GPRS LA

Revision: C.01 and above

Programming Example:

OUTPUT 714;"CALL:TRIGGER:RBLOCK:PDTCH:STATE 1"
! Enables the Radio Block trigger

CALL:TRIGger[:OUTPut]:RBLock:(PDTCH|PDTChannel):FOFFset

Function

GSM TA

This command is not applicable to the GSM test application.
GPRS TA This command is not applicable to the GPRS test application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.

GSM/GPRS LA

Sets the frame to trigger on within the Radio Block.

EGPRS LA

Setting

 Range: 0 to 3

Query

 Range: 0 to 3

*RST setting

 0

Requirements

 GSM/GPRS TA Revision: A.01 and above
GSM/GPRS LA

Revision: C.01 and above

Programming Example:

OUTPUT 714;"CALL:TRIGGER:RBLOCK:PDTCH:FOFFSET 2"
! Sets the Radio Block trigger to occur on frame 2 of each radio block

CALL:TRIGger[:OUTPut]:PMESsage[:TSET][:TX]:PUASsignment:STATe

Function

GSM TA

This command is not applicable to the GSM test application.
GPRS TA This command is not applicable to the GPRS test application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.

GSM/GPRS LA

Enables a trigger signal on the Packet Uplink Assignment message.

EGPRS LA

Setting

 0 | OFF | 1 | ON

Query

 0 | 1

*RST setting

 0

Requirements

 GSM/GPRS TA Revision: A.01 and above
GSM/GPRS LA

Revision: C.01 and above

Programming Example:

OUTPUT 714;"CALL:TRIGGER:PMESSAGE:PUASSIGNMENT:STATE 1"
! Enables the Packet Uplink Assignment Message trigger

CALL:TRIGger[:OUTPut]:PMESsage[:TSET][:TX]:PUASsignment:FOFFset

Function

GSM TA

This command is not applicable to the GSM test application.
GPRS TA This command is not applicable to the GPRS test application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.

GSM/GPRS LA

Sets the frame offset on the trigger for the Packet Uplink Assignment message.

EGPRS LA

Setting

 Range: 0 to 20000

Query

 Range: 0 to 20000

*RST setting

 0

Requirements

 GSM/GPRS TA Revision: A.01 and above
GSM/GPRS LA

Revision: C.01 and above

Programming Example:

OUTPUT 714;"CALL:TRIGGER:PMESSAGE:PUASSIGNMENT:FOFFSET 10000"
! Sets the Packet Uplink Assignment Message trigger to occur on frame 10000.

CALL:TRIGger[:OUTPut]:PMESsage:DUT:TX:PUASsignment:STATe

Function | GSM TA | This command is not applicable to the GSM test application.
 | GPRS TA | This command is not applicable to the GPRS test application.
 | EGPRS TA | This command is not applicable to the EGPRS Test Application.
 | GSM/GPRS LA | Enables the Expected DUT TX trigger signal on the Packet Uplink Assignment message.
 | EGPRS LA
Setting |  | 0 | OFF | 1 | ON
Query |  | 0 | 1
*RST setting |  | 0
Requirements | GSM/GPRS TA | Revision: A.01 and above
 | GSM/GPRS LA | Revision: C.01 and above

CALL:TRIGger[:OUTPut]:PMESsage:DUT:TX:PUASsignment:FOFFset

Function | GSM TA | This command is not applicable to the GSM test application.
 | GPRS TA | This command is not applicable to the GPRS test application.
 | EGPRS TA | This command is not applicable to the EGPRS Test Application.
 | GSM/GPRS LA | Sets the frame offset on the Expected DUT TX trigger for the Packet Uplink Assignment message.
 | EGPRS LA
Setting |  | Range: 0 to 20000
Query |  | Range: 0 to 20000
*RST setting |  | 0
Requirements | GSM/GPRS TA | Revision: A.01 and above
 | GSM/GPRS LA | Revision: C.01 and above

CALL:TRIGger[:OUTPut]:PMESsage[:TSET][:TX]:PDASsignment:STATe

Function | GSM TA | This command is not applicable to the GSM test application.
 | GPRS TA | This command is not applicable to the GPRS test application.
 | EGPRS TA | This command is not applicable to the EGPRS Test Application.
 | GSM/GPRS LA | Enables a trigger signal on the Packet Downlink Assignment message.
 | EGPRS LA
Setting |  | 0 | OFF | 1 | ON
Query |  | 0 | 1
*RST setting |  | 0
Requirements | GSM/GPRS TA | Revision: A.01 and above
 | GSM/GPRS LA | Revision: C.01 and above

CALL:TRIGger[:OUTPut]:PMESsage[:TSET][:TX]:PDASsignment:FOFFset

Function | GSM TA | This command is not applicable to the GSM test application.
 | GPRS TA | This command is not applicable to the GPRS test application.
 | EGPRS TA | This command is not applicable to the EGPRS Test Application.
 | GSM/GPRS LA | Sets the frame offset on the trigger for the Packet Downlink Assignment message.
 | EGPRS LA
Setting |  | Range: 0 to 20000
Query |  | Range: 0 to 20000
*RST setting |  | 0
Requirements | GSM/GPRS TA | Revision: A.01 and above
 | GSM/GPRS LA | Revision: C.01 and above

CALL:TRIGger[:OUTPut]:PMESsage:DUT:RX:PDASsignment:STATe

Function | GSM TA | This command is not applicable to the GSM test application.
 | GPRS TA | This command is not applicable to the GPRS test application.
 | EGPRS TA | This command is not applicable to the EGPRS Test Application.
 | GSM/GPRS LA | Enables the First DUT RX trigger signal on the Packet Downlink Assignment message.
 | EGPRS LA
Setting |  | 0 | OFF | 1 | ON
Query |  | 0 | 1
*RST setting |  | 0
Requirements | GSM/GPRS TA | Revision: A.01 and above
 | GSM/GPRS LA | Revision: C.01 and above

CALL:TRIGger[:OUTPut]:PMESsage:DUT:RX:PDASsignment:FOFFset

Function | GSM TA | This command is not applicable to the GSM test application.
 | GPRS TA | This command is not applicable to the GPRS test application.
 | EGPRS TA | This command is not applicable to the EGPRS Test Application.
 | GSM/GPRS LA | Sets the frame offset on the First DUT RX trigger for the Packet Downlink Assignment message.
 | EGPRS LA
Setting |  | Range: 0 to 20000
Query |  | Range: 0 to 20000
*RST setting |  | 0
Requirements | GSM/GPRS TA | Revision: A.01 and above
 | GSM/GPRS LA | Revision: C.01 and above

CALL:TRIGger[:OUTPut]:PMESsage[:TSET][:TX]:PTReconfig:STATe

Function | GSM TA | This command is not applicable to the GSM test application.
 | GPRS TA | This command is not applicable to the GPRS test application.
 | EGPRS TA | This command is not applicable to the EGPRS Test Application.
 | GSM/GPRS LA | Enables a trigger signal on the Packet Timeslot Reconfigure message.
 | EGPRS LA
Setting |  | 0 | OFF | 1 | ON
Query |  | 0 | 1
*RST setting |  | 0
Requirements | GSM/GPRS TA | Revision: A.01 and above
 | GSM/GPRS LA | Revision: C.01 and above

CALL:TRIGger[:OUTPut]:PMESsage[:TSET][:TX]:PTReconfig:FOFFset

Function | GSM TA | This command is not applicable to the GSM test application.
 | GPRS TA | This command is not applicable to the GPRS test application.
 | EGPRS TA | This command is not applicable to the EGPRS Test Application.
 | GSM/GPRS LA | Sets the frame offset on the trigger for the Packet Timeslot Reconfigure message.
 | EGPRS LA
Setting |  | Range: 0 to 20000
Query |  | Range: 0 to 20000
*RST setting |  | 0
Requirements | GSM/GPRS TA | Revision: A.01 and above
 | GSM/GPRS LA | Revision: C.01 and above

CALL:TRIGger[:OUTPut]:PMESsage:DUT:TX:PTReconfig:STATe

Function | GSM TA | This command is not applicable to the GSM test application.
 | GPRS TA | This command is not applicable to the GPRS test application.
 | EGPRS TA | This command is not applicable to the EGPRS Test Application.
 | GSM/GPRS LA | Enables the Expected DUT TX trigger signal on the Packet Timeslot Reconfigure message.
 | EGPRS LA
Setting |  | 0 | OFF | 1 | ON
Query |  | 0 | 1
*RST setting |  | 0
Requirements | GSM/GPRS TA | Revision: A.01 and above
 | GSM/GPRS LA | Revision: C.01 and above

CALL:TRIGger[:OUTPut]:PMESsage:DUT:TX:PTReconfig:FOFFset

Function | GSM TA | This command is not applicable to the GSM test application.
 | GPRS TA | This command is not applicable to the GPRS test application.
 | EGPRS TA | This command is not applicable to the EGPRS Test Application.
 | GSM/GPRS LA | Sets the frame offset on the Expected DUT TX trigger for the Packet Timeslot Reconfigure message.
 | EGPRS LA
Setting |  | Range: 0 to 20000
Query |  | Range: 0 to 20000
*RST setting |  | 0
Requirements | GSM/GPRS TA | Revision: A.01 and above
 | GSM/GPRS LA | Revision: C.01 and above

CALL:TRIGger[:OUTPut]:PMESsage[:TSET][:TX]:PPCTadvance:STATe

Function | GSM TA | This command is not applicable to the GSM test application.
 | GPRS TA | This command is not applicable to the GPRS test application.
 | EGPRS TA | This command is not applicable to the EGPRS Test Application.
 | GSM/GPRS LA | Enables a trigger signal on the Packet Power Control/Timing Advance message.
 | EGPRS LA
Setting |  | 0 | OFF | 1 | ON
Query |  | 0 | 1
*RST setting |  | 0
Requirements | GSM/GPRS TA | Revision: A.01 and above
 | GSM/GPRS LA | Revision: C.01 and above

CALL:TRIGger[:OUTPut]:PMESsage[:TSET][:TX]:PPCTadvance:FOFFset

Function | GSM TA | This command is not applicable to the GSM test application.
 | GPRS TA | This command is not applicable to the GPRS test application.
 | EGPRS TA | This command is not applicable to the EGPRS Test Application.
 | GSM/GPRS LA | Sets the frame offset on the trigger for the Packet Power Control/Timing Advance message.
 | EGPRS LA
Setting |  | Range: 0 to 20000
Query |  | Range: 0 to 20000
*RST setting |  | 0
Requirements | GSM/GPRS TA | Revision: A.01 and above
 | GSM/GPRS LA | Revision: C.01 and above

CALL:TRIGger[:OUTPut]:PMESsage[:TSET][:TX]:PIASsignment:STATe

Function | GSM TA | This command is not applicable to the GSM test application.
 | GPRS TA | This command is not applicable to the GPRS test application.
 | EGPRS TA | This command is not applicable to the EGPRS Test Application.
 | GSM/GPRS LA | Enables a trigger signal on the Packet Immediate Assignment message.
 | EGPRS LA
Setting |  | 0 | OFF | 1 | ON
Query |  | 0 | 1
*RST setting |  | 0
Requirements | GSM/GPRS TA | Revision: A.01 and above
 | GSM/GPRS LA | Revision: C.01 and above

CALL:TRIGger[:OUTPut]:PMESsage[:TSET][:TX]:PIASsignment:FOFFset

Function | GSM TA | This command is not applicable to the GSM test application.
 | GPRS TA | This command is not applicable to the GPRS test application.
 | EGPRS TA | This command is not applicable to the EGPRS Test Application.
 | GSM/GPRS LA | Sets the frame offset on the trigger for the Packet Immediate Assignment message.
 | EGPRS LA
Setting |  | Range: 0 to 20000
Query |  | Range: 0 to 20000
*RST setting |  | 0
Requirements | GSM/GPRS TA | Revision: A.01 and above
 | GSM/GPRS LA | Revision: C.01 and above

CALL:TRIGger[:OUTPut]:PMESsage:DUT:TX:PIASsignment:STATe

Function | GSM TA | This command is not applicable to the GSM test application.
 | GPRS TA | This command is not applicable to the GPRS test application.
 | EGPRS TA | This command is not applicable to the EGPRS Test Application.
 | GSM/GPRS LA | Enables the DUT TX trigger signal on the Packet Immediate Assignment message.
 | EGPRS LA
Setting |  | 0 | OFF | 1 | ON
Query |  | 0 | 1
*RST setting |  | 0
Requirements | GSM/GPRS TA | Revision: A.01 and above
 | GSM/GPRS LA | Revision: C.01 and above

CALL:TRIGger[:OUTPut]:PMESsage:DUT:TX:PIASsignment:FOFFset

Function | GSM TA | This command is not applicable to the GSM test application.
 | GPRS TA | This command is not applicable to the GPRS test application.
 | EGPRS TA | This command is not applicable to the EGPRS Test Application.
 | GSM/GPRS LA | Sets the frame offset on the DUT TX trigger for the Packet Immediate Assignment message.
 | EGPRS LA
Setting |  | Range: 0 to 20000
Query |  | Range: 0 to 20000
*RST setting |  | 0
Requirements | GSM/GPRS TA | Revision: A.01 and above
 | GSM/GPRS LA | Revision: C.01 and above

CALL:TRIGger[:OUTPut]:PMESsage:DUT:RX:PIASsignment:STATe

Function | GSM TA | This command is not applicable to the GSM test application.
 | GPRS TA | This command is not applicable to the GPRS test application.
 | EGPRS TA | This command is not applicable to the EGPRS Test Application.
 | GSM/GPRS LA | Enables the DUT RX trigger signal on the Packet Immediate Assignment message.
 | EGPRS LA
Setting |  | 0 | OFF | 1 | ON
Query |  | 0 | 1
*RST setting |  | 0
Requirements | GSM/GPRS TA | Revision: A.01 and above
 | GSM/GPRS LA | Revision: C.01 and above

CALL:TRIGger[:OUTPut]:PMESsage:DUT:RX:PIASsignment:FOFFset

Function | GSM TA | This command is not applicable to the GSM test application.
 | GPRS TA | This command is not applicable to the GPRS test application.
 | EGPRS TA | This command is not applicable to the EGPRS Test Application.
 | GSM/GPRS LA | Sets the frame offset on the DUT RX trigger for the Packet Immediate Assignment message.
 | EGPRS LA
Setting |  | Range: 0 to 20000
Query |  | Range: 0 to 20000
*RST setting |  | 0
Requirements | GSM/GPRS TA | Revision: A.01 and above
 | GSM/GPRS LA | Revision: C.01 and above

CALL:TRIGger[:OUTPut]:PMESsage[:TSET][:TX]:IREQuest:STATe

Function | GSM TA | This command is not applicable to the GSM test application.
 | GPRS TA | This command is not applicable to the GPRS test application.
 | EGPRS TA | This command is not applicable to the EGPRS Test Application.
 | GSM/GPRS LA | Enables a trigger signal on the Identity Request message.
 | EGPRS LA
Setting |  | 0 | OFF | 1 | ON
Query |  | 0 | 1
*RST setting |  | 0
Requirements | GSM/GPRS TA | Revision: A.01 and above
 | GSM/GPRS LA | Revision: C.01 and above

CALL:TRIGger[:OUTPut]:PMESsage[:TSET][:TX]:IREQuest:FOFFset

Function | GSM TA | This command is not applicable to the GSM test application.
 | GPRS TA | This command is not applicable to the GPRS test application.
 | EGPRS TA | This command is not applicable to the EGPRS Test Application.
 | GSM/GPRS LA | Sets the frame offset on the trigger for the Identity Request message.
 | EGPRS LA
Setting |  | Range: 0 to 20000
Query |  | Range: 0 to 20000
*RST setting |  | 0
Requirements | GSM/GPRS TA | Revision: A.01 and above
 | GSM/GPRS LA | Revision: C.01 and above

CALL:TRIGger[:OUTPut]:PMESsage[:TSET][:TX]:AACCept:STATe

Function | GSM TA | This command is not applicable to the GSM test application.
 | GPRS TA | This command is not applicable to the GPRS test application.
 | EGPRS TA | This command is not applicable to the EGPRS Test Application.
 | GSM/GPRS LA | Enables a trigger signal on the Attach Accept message.
 | EGPRS LA
Setting |  | 0 | OFF | 1 | ON
Query |  | 0 | 1
*RST setting |  | 0
Requirements | GSM/GPRS TA | Revision: A.01 and above
 | GSM/GPRS LA | Revision: C.01 and above

CALL:TRIGger[:OUTPut]:PMESsage[:TSET][:TX]:AACCept:FOFFset

Function | GSM TA | This command is not applicable to the GSM test application.
 | GPRS TA | This command is not applicable to the GPRS test application.
 | EGPRS TA | This command is not applicable to the EGPRS Test Application.
 | GSM/GPRS LA | Sets the frame offset on the trigger for the Attach Accept message.
 | EGPRS LA
Setting |  | Range: 0 to 20000
Query |  | Range: 0 to 20000
*RST setting |  | 0
Requirements | GSM/GPRS TA | Revision: A.01 and above
 | GSM/GPRS LA | Revision: C.01 and above

CALL:TRIGger[:OUTPut]:PMESsage[:TSET][:TX]:DREQuest:STATe

Function | GSM TA | This command is not applicable to the GSM test application.
 | GPRS TA | This command is not applicable to the GPRS test application.
 | EGPRS TA | This command is not applicable to the EGPRS Test Application.
 | GSM/GPRS LA | Enables a trigger signal on the Detach Request message.
 | EGPRS LA
Setting |  | 0 | OFF | 1 | ON
Query |  | 0 | 1
*RST setting |  | 0
Requirements | GSM/GPRS TA | Revision: A.01 and above
 | GSM/GPRS LA | Revision: C.01 and above

CALL:TRIGger[:OUTPut]:PMESsage[:TSET][:TX]:DREQuest:FOFFset

Function | GSM TA | This command is not applicable to the GSM test application.
 | GPRS TA | This command is not applicable to the GPRS test application.
 | EGPRS TA | This command is not applicable to the EGPRS Test Application.
 | GSM/GPRS LA | Sets the frame offset on the trigger for the Detach Request message.
 | EGPRS LA
Setting |  | Range: 0 to 20000
Query |  | Range: 0 to 20000
*RST setting |  | 0
Requirements | GSM/GPRS TA | Revision: A.01 and above
 | GSM/GPRS LA | Revision: C.01 and above

CALL:TRIGger[:OUTPut]:PMESsage[:TSET][:TX]:PDPAccept:STATe

Function | GSM TA | This command is not applicable to the GSM test application.
 | GPRS TA | This command is not applicable to the GPRS test application.
 | EGPRS TA | This command is not applicable to the EGPRS Test Application.
 | GSM/GPRS LA | Enables a trigger signal on the PDP Context Activation Accept message.
 | EGPRS LA
Setting |  | 0 | OFF | 1 | ON
Query |  | 0 | 1
*RST setting |  | 0
Requirements | GSM/GPRS TA | Revision: A.01 and above
 | GSM/GPRS LA | Revision: C.01 and above

CALL:TRIGger[:OUTPut]:PMESsage[:TSET][:TX]:PDPAccept:FOFFset

Function | GSM TA | This command is not applicable to the GSM test application.
 | GPRS TA | This command is not applicable to the GPRS test application.
 | EGPRS TA | This command is not applicable to the EGPRS Test Application.
 | GSM/GPRS LA | Sets the frame offset on the trigger for the PDP Context Activation Accept message.
 | EGPRS LA
Setting |  | Range: 0 to 20000
Query |  | Range: 0 to 20000
*RST setting |  | 0
Requirements | GSM/GPRS TA | Revision: A.01 and above
 | GSM/GPRS LA | Revision: C.01 and above

CALL:TRIGger[:OUTPut]:PMESsage[:TSET][:TX]:PDPRequest:STATe

Function | GSM TA | This command is not applicable to the GSM test application.
 | GPRS TA | This command is not applicable to the GPRS test application.
 | EGPRS TA | This command is not applicable to the EGPRS Test Application.
 | GSM/GPRS LA | Enables a trigger signal on the Request PDP Context Activation message.
 | EGPRS LA
Setting |  | 0 | OFF | 1 | ON
Query |  | 0 | 1
*RST setting |  | 0
Requirements | GSM/GPRS TA | Revision: A.01 and above
 | GSM/GPRS LA | Revision: C.01 and above

CALL:TRIGger[:OUTPut]:PMESsage[:TSET][:TX]:PDPRequest:FOFFset

Function | GSM TA | This command is not applicable to the GSM test application.
 | GPRS TA | This command is not applicable to the GPRS test application.
 | EGPRS TA | This command is not applicable to the EGPRS Test Application.
 | GSM/GPRS LA | Sets the frame offset on the trigger for the Request PDP Context Activation message.
 | EGPRS LA
Setting |  | Range: 0 to 20000
Query |  | Range: 0 to 20000
*RST setting |  | 0
Requirements | GSM/GPRS TA | Revision: A.01 and above
 | GSM/GPRS LA | Revision: C.01 and above


GPRS (E1964A) Revision Information

GPRS (E1964A) Revision Information

Last updated: December 2, 2008

This document describes features and functionality that are part of the E1964A GPRS Mobile Test Application releases. This document contains the enhancements that have been added over time.

CAUTION
Loading an application onto your E5515 Test Set that is not compatible with your E5515's hardware revision can cause your E5515 to lock-up. For information on application/E5515 compatibility refer to:

http://www.agilent.com/find/E5515

and select the relevant link, either E5515B Release Notes or E5515C Release Notes. Always refer to this information before loading an application.

Select the appropriate link below to view the required release.

  • A.04 Release June 2002
  • A.03 Release March 2002
  • A.02 Release July 2001
  • A.01 Release February 2001

A.04 Release June 2002

This firmware release adds new frequency bands, a spectrum monitor, and a multislot enhancement to the Output RF Spectrum measurement.

This firmware release will run on an E5515C chassis with Option 002. If you have previously been using any revision of the E1964A GPRS test application on an E5515A or E5515B chassis then this revision will also run. However, if you wish to run this test application on an E5515A or E5515B chassis for the first time, contact your local sales representative.

For access to the spectrum monitor feature you require your chassis to be one of the following:

  • an E5515C.
  • an E5515B with serial number US40350362 or GB40470454 or higher.
  • an E5515B with E5515BU option 085.
  • an E5515A with E5515BU option 085.

Call Processing

This release provides you with the GSM450, GSM480, GSM750 and RGSM frequency bands.

The BA Table can now accept multiple entries, whereas previously they could only accept one entry. For more information refer to CALL:BA .

Measurements

  • A Spectrum Monitor measurement feature has been added. This allows you to find, identify and measure transmitted signals from your mobile phone. It can also be used for spur measurements in the transmit band. For more details refer to Spectrum Monitor Description .
  • The Output RF Spectrum measurement has been enhanced, allowing you to measure multislot configurations with two adjacent uplink timeslots:
    • The ORFS due to modulation measurement is performed for only one burst at a time in the multislot configuration, which you specify using the command RFANalyzer:MANual:MEASurement:BURST.
    • The ORFS due to switching measurement is performed over both adjacent bursts in the multislot configuration.

    For more information refer to GPRS and EGPRS Output RF Spectrum Measurement .

Other

None

A.03 Release March 2002

This firmware release provides you with a new measurement; Block Error Rate, and adds new features to the existing Output RF Spectrum, Power versus Time, and Bit Error Rate measurements.

This firmware release will run on an E5515C chassis with Option 002. If you have previously been using any revision of the E1964A GPRS test application on an E5515A or E5515B chassis then this revision will also run. However, if you wish to run this test application on an E5515A or E5515B chassis for the first time, contact your local sales representative.

Call Processing

  • Power in Unused Bursts on Downlink PDTCH ARFCN
    Two new commands are now provided which relate to the power levels in unused bursts on the downlink PDTCH ARFCN. These commands are:
    • Unused Downlink Burst Power Reduction Selection (see CALL:(PDTCH|PDTChannel):PREDuction:UBURst )
      This command is used to set or query the power reduction level that is applied to all unused bursts on the downlink PDTCH ARFCN.
    • Unused Downlink Burst Current Absolute Power Level (see CALL:(PDTCH|PDTChannel):POWer[:AMPLitude]:UBURst? )
      This query returns the current absolute power level of the unused bursts on the downlink PDTCH ARFCN.
  • Additional Data Connection Commands
    Two commands allow you to set the payload pattern for downlink data. These commands are:
    • CALL:FUNCtion:DATA:PAYLoad:PATTern:BLERPayload Pattern (BLER) (see CALL:FUNCtion:DATA:PAYLoad:PATTern:BLER ).
      This command sets/queries the type of downlink payload pattern to be sent to the mobile when the data connection type is set to BLER in Active Cell operating mode, and the LLC Frame Check Sequence connection parameter is set to Corrupt.
    • CALL:FUNCtion:DATA:PAYLoad:PATTern:ETSIB

      CALL:FUNCtion:DATA:PAYLoad:PATTern:ETSIB

      Payload Pattern (OTHER) (see CALL:FUNCtion:DATA:PAYLoad:PATTern[:OTHer] ).
      This command sets/queries the type of downlink payload pattern to be used when the test set's operating mode is set to either EGPRS BCH+PDTCH Test Mode or Active Cell with serving cell being EGPRS and the data connection type set to ETSI Type B (Unack or Ack) or SRB Loopback.

Measurements

  • Block Error Rate measurement (using either ETSI Test Mode B, BCH+PDTCH Test Mode, or the Agilent proprietary BLER mode).
    This measurement is based on GPRS receiver tests defined in 3GPP 51.010 section 14.16. For more information refer to Block Error Measurement .

  • The Power versus Time measurement has been enhanced to provide an optional relaxed mask specification for the PCS band, as defined in 3GPP 51.010-1 section 13.3.5(c). For more information refer to SETup:PVTime:LIMit:ETSI:PCS .
  • The Output RF Spectrum measurement has been enhanced allowing you to test using either the ETSI defined, or your own specified limits. The commands used to set up your own limits are:
    • SETup:ORFSpectrum:LIMit:SOURce
    • SETup:ORFSpectrum:SWITching:LIMit:MANual[:SELected]
    • SETup:ORFSpectrum:MODulation:LIMit:MANual<[1]|2>[:SELected]
  • The Bit Error Rate measurement has been enhanced, allowing you to specify how the measurement interprets blocks with errors that are received from the mobile. For more information refer to SETup:GBERror:ZBBLocks .

Other

  • RF Out Only front panel connector
    This release enables control of the type-N RF Out Only connector on the test set's front panel. This connector provides an optional path for the test set's RF output. For more information refer to RF OUT ONLY and RFGenerator:OUTPut .

A.02 Release July 2001

Call Processing

  • This release provides you with GPRS operation in the GSM850 frequency band.

  • Additional data connection commands
    Three new commands have been added that may enable the test set to establish a data connection with mobiles which cannot connect using the test application default settings. These commands are:

    • Data Connection Frame Number Type (see CALL:FUNCtion:DATA:FRAMe:STARt )
      This command relates to the GPRS Attach procedure allowing you to change the TBF (Temporary Block Flow) frame starting position type.
    • Data Connection LLC Frame Check Sequence (see CALL:FUNCtion:DATA:BLER:LLC:FCSequence )
    • BLER Block Polling Interval (see CALL:FUNCtion:DATA:BLER:POLLing:INTerval )

    CALL:FUNCtion:DATA:FRAMe:STARt is applicable to all data connection types. CALL:FUNCtion:DATA:BLER:LLC:FCSequence and CALL:FUNCtion:DATA:BLER:POLLing:INTerval are only applicable when you want to establish a BLER mode data connection.

  • Additional PDTCH protocol control commands
    Two new commands are now provided in case your mobile does not fully support the Packet Timeslot Reconfigure (PTR) message.
    The PTR message is a superset message which is used to change most of the connection related parameters (for example, MS TX Level, timeslot configuration, and power control). This message is described in 3GPP TS 04.60 section 11.2.31. The Packet Power Timing Advance (PPTA) message can be used as an alternative to the PTR message, but only for changes to the MS TX Level or timing advance. This message is described in 3GPP TS 04.60 section 11.2.13.

    The two new commands are:

    • Packet Timeslot Reconfigure State (see CALL:(PDTCH|PDTChannel):PMESsage:PTReconfig )
    • Packet Power Timing Advance State (see CALL:(PDTCH|PDTChannel):PMESsage:PPTadvance )

    The recommended method for modifying PDTCH parameters during an active data connection is to use the CALL:HANDover|HANDoff[:IMMediate] to apply deferred settings. If you currently use this method, note that you will need to amend your code to specifically set CALL:(PDTCH|PDTChannel):PMESsage:PTReconfig to On.

  • RLC/MAC Header State
    This command allows you to define whether or not a valid RLC/MAC (Radio Link Control/Medium Access Control) header is present on the downlink PDTCH bursts when using the BCH+PDTCH Test Mode. The RLC/MAC Header contains a PR field which is used to indicate a power reduction level to the mobile. When the RLC/MAC Header State command is set to Off, the PR field of the RLC/MAC Header is filled with random data. For further information on this command see CALL:PBPTest:RLCMac[:HEADer]:STATe .

  • First Downlink Burst to Loop
    This command allows you to select which downlink burst of the multislot configuration you want to be looped back in the first uplink burst. Subsequent downlink bursts are looped back onto subsequent uplink bursts. This command is important for the Bit Error Rate (BER) measurement and BLock Error Rate (BLER) reports. For more details on this command, see CALL:(PDTCH|PDTChannel):MSLot[:FIRSt]:DOWNlink:LOOPback[:BURSt] .

  • Network Initiated Detach
    This new command allows you to perform a GPRS Detach procedure from the test set rather than from the mobile. For details on this command refer to CALL:FUNCtion:DATA:DETach .

  • Manual setting of the BA table entry
    Previously, you could only set the BA table entry using the command CALL[:CELL]:BA:TABLe[:SELected] . You can now set this entry using the test set's front panel. To do this, press the CALL SETUP key, press Cell Info ( F6 ), press BA Table ( F3 ) then press the knob and make a selection.

  • Extended Range for Downlink Power Reduction Levels
    The downlink PDTCH power reduction level range has been extended. You can now specify a range from 0 to 25 dB (previously 0 to 12 dB). For details on this command refer to CALL:(PDTCH|PDTChannel):PREDuction:LEVel<1|2> .

Measurements

No new measurements in this release.

Other

  • Internal graphical measurements for; Power versus Time, Output RF Spectrum and Phase and Frequency Error.
    For more details on these graphical measurements refer to one of the following step-by-step measurement procedures:
    • How Do I Make a Power Versus Time Measurement?
    • How Do I Make a Phase and Frequency Error Measurement?
    • How Do I Make an Output RF Spectrum Measurement?

  • This release gives you the first revision of GPRS which can be used for the E1985A GSM_AMPS/136 fast switching test application. This release when used with the E1985A GSM_AMPS/136_GPRS fast switching test application allows you to switch quickly between GSM, AMPS/136, and GPRS formats.

    To allow the GPRS test application to operate in the fast switching environment with GSM and AMPS/136 a number of the existing GPRS commands had to be changed. The previous commands and their new replacements are shown in the table below. If you previously used any of these commands you must change them to the new commands to allow your code to run. Otherwise, you will receive an error message. Note, this error message only appears if you are using the individual E1964A GPRS Mobile Test Application. If you are using the E1985A GSM_AMPS/136_GPRS Fast Switching Test Application, you will not receive an error message as these commands are still valid for setting the inactive GSM format.

    Command Changes in the A.02 Release

    Previous Commands

    New Commands

    CALL[:CELL]:POWer[:SAMPlitude]:GSM

    CALL[:CELL]:POWer[:SAMPlitude][:SELected]

    CALL[:CELL]:POWer:AMPLitude:GSM

    CALL[:CELL]:POWer:AMPLitude[:SELected]

    CALL[:CELL]:POWer:STATe:GSM

    CALL[:CELL]:POWer:STATe[:SELected]

    RFANalyzer:MANual:POWer:GSM[:SELected]
    :BURSt[1|2]

    RFANalyzer:MANual:POWer:BURSt<[1]|2|3|4|5|6|7>

    STATus:OPERation:NMRReady:GSM:CONDition

    STATus:OPERation:NMRReady:GSM:ENABle

    STATus:OPERation:NMRReady:GSM:NTRansition

    STATus:OPERation:NMRReady:GSM:PTRansition

    STATus:OPERation:NMRReady:GSM[:EVENt]

    STATus:OPERation:NMRReady:GPRS:CONDition

    STATus:OPERation:NMRReady:GPRS:ENABle

    STATus:OPERation:NMRReady:GPRS:NTRansition

    STATus:OPERation:NMRReady:GPRS:PTRansition

    STATus:OPERation:NMRReady:GPRS[:EVENt]

    If you require more details on this status register, see STATus:OPERation:NMRReady:GPRS Condition Register Bit Assignment .

    STATus:QUEStionable:CALL:GSM:DATA:CONDition

    STATus:QUEStionable:CALL:GSM:DATA:ENABle

    STATus:QUEStionable:CALL:GSM:DATA:NTRansition

    STATus:QUEStionable:CALL:GSM:DATA:PTRansition

    STATus:QUEStionable:CALL:GSM:DATA[:EVENt]

    STATus:QUEStionable:CALL:GPRS:CONDition

    STATus:QUEStionable:CALL:GPRS:ENABle

    STATus:QUEStionable:CALL:GPRS:NTRansition

    STATus:QUEStionable:CALL:GPRS:PTRansition

    STATus:QUEStionable:CALL:GPRS[:EVENt]

    If you require more details on this status register, see STATus:QUEStionable:CALL:GPRS Condition Register Bit Assignment .

    STATus:QUEStionable:ERRors:GSM:CONDition

    STATus:QUEStionable:ERRors:GSM:ENABle

    STATus:QUEStionable:ERRors:GSM:NTRansition

    STATus:QUEStionable:ERRors:GSM:PTRansition

    STATus:QUEStionable:ERRors:GSM[:EVENt]

    STATus:QUEStionable:ERRors:GPRS:CONDition

    STATus:QUEStionable:ERRors:GPRS:ENABle

    STATus:QUEStionable:ERRors:GPRS:NTRansition

    STATus:QUEStionable:ERRors:GPRS:PTRansition

    STATus:QUEStionable:ERRors:GPRS[:EVENt]

    If you require more details on this status register, see STATus:QUEStionable:ERRors:GPRS Condition Register Bit Assignment .
  • Screen images can be captured and saved as .GIF files. This is useful when you want to save copies of measurement results or other screen images. See Printing and Saving Screen Images for a complete explanation of this procedure.

A.01 Release February 2001

Call Processing

  • ETSI Test mode A and B
    In the initial GPRS release the only type of data connection available was the Agilent proprietary BLER method. This enhancement gives you two additional options for data connection, namely the ETSI defined Type A and Type B. For more information refer to the command CALL:FUNCtion:CONNection:TYPE .

  • Additional Timeslot Configurations
    A new command is available that allows you to select from a list of multiple timeslot configurations. These configurations are:
    • one downlink and one uplink
    • two downlinks and one uplink
    • two downlinks and two uplinks
    • three downlinks and one uplink
    • three downlinks and two uplinks
    • four downlinks and one uplink

    For more information refer to the command CALL:(PDTCH|PDTChannel):MSLot:CONFig .

  • Coding Scheme Options for Data
    A new command is available that allows you to set the PDTCH coding scheme in ETSI test mode to either CS1, CS2, CS3 or CS4. For more information on this command refer to CALL:(PDTCH|PDTChannel):CSCHeme:UPLink .

  • Deferred Settings
    A new feature allows you to set-up all your PDTCH parameters but defers their implementation until you send one handover command. This has the advantage of increasing the speed of the PDTCH change as the signalling happens only once, at the handover command, and not at the change of each individual PDTCH parameter. For more information refer to the command CALL:HANDover|HANDoff[:IMMediate] .

  • Operating Modes
    An additional two operating modes are available, namely, GPRS Test Mode BCH and GPRS Test Mode BCH + PDTCH. For more information refer to the command CALL:OPERating .

Measurements

  • Output RF Spectrum due to modulation (using ETSI Test mode A or B)
    For more information on this measurement refer to Output RF Spectrum Measurement Description .

  • Power versus Time multi-uplink mask
    For more information on this measurement refer to Power versus Time Measurement Description .

  • Multislot BER (using ETSI Test mode B only)
    For more information on this measurement refer to GPRS Bit Error Measurement .

  • Multislot tolerant Transmit Power
    For more information on this measurement refer to Transmit Power Measurement Description .

  • Multislot tolerant Phase and Frequency Error
    For more information on this measurement refer to Phase and Frequency Error Measurement Description .

Other

  • Manual User Interface
    The initial GPRS release only had remote user access. This release provides you with access to the measurements and configuration via the test set's front panel. For more information on using the test set manually refer to your GPRS Quick Guide which was delivered with your test set.

Note, due to the lack of commercially available GPRS mobile stations some of the features added to this release have not been fully verified.


Adaptive Multi-Rate (AMR) Feature Descriptions

Adaptive Multi-Rate (AMR) Feature Descriptions

Last updated: December 2, 2008

This section is only applicable to the lab applications and the test application with a required feature license.

AMR ensures that speech quality is optimized in a mobile station by verifying its ability to determine when to request a change to another codec with either more or less error correction and protection as signal quality changes.

The following topics are described in this section:

Adaptive Multi-Rate (AMR) Overview

Adaptive Multi-Rate (AMR) Channel Mode Configuration

Adaptive Multi-Rate (AMR) Codec Setup

Robust AMR Traffic Synchronization Control Channel (RATSCCH)

Operating Considerations

Adaptive Multi-Rate (AMR) Overview

The test set has two options for AMR logical speech channels: Adaptive Full-Rate Speech (AFS) and Adaptive Half-Rate Speech (AHS). During an AMR speech call setup, the test set assigns the mobile station a set of up to four codecs for use during the call. These four codecs comprise what is called the Active Codec Set (ACS) and can be defined for each AMR logical speech channel.

The test set uses one codec from the ACS at a time. The codec being used from the ACS is called the current codec. The current codec switches to other codecs in the ACS as the signal quality changes. If the signal quality decreases, then a more robust codec is used if one exists in the ACS. Likewise, if the signal quality increases, a less robust codec is used if one exists in the ACS. The point at which the current codec should change to another codec in the ACS is determined by the Threshold and Hysteresis values that can be specified in the test set. The test set allows parameters such as the AMR Logical Speech Channel, codecs that define the ACS, current codec, Threshold and Hysteresis values to be changed whether a call exists or not. A protocol log captured with the Wireless Protocol Advisor (WPA) can be used to verify that the mobile station responded properly to changes in AMR parameters. For more information see Protocol Logging .

Adaptive Multi-Rate (AMR) Channel Mode Configuration

The AMR specific logical speech channels that the channel mode can be configured to are Adaptive Full-Rate Speech (AFS) and Adaptive Half-Rate Speech (AHS). For instructions on setting the channel mode configuration on the front panel of the test set, see steps one through three of General AMR and AMR-WB Parameter Setup . The GPIB command to configure the Logical Speech Channel is CALL:TCHannel:CMODe:LSPeech:CHANnel .

Adaptive Multi-Rate (AMR) Codec Setup

The speech quality of a codec in the test set uses to code/decode a signal is inversely proportional to the amount of error correction and protection used. For example, the Adaptive Half-Rate Speech (AHS) codec with the rate of 4.75 kbps is the lowest speech quality codec available for the AHS logical speech channel, but is the most robust because it provides the most error correction and protection. Furthermore, the AHS codec with a speech rate of 7.95 kbps is the highest speech quality codec the AHS logical speech channel offers, but is the least robust because it contains the least amount of error correction and protection.

  • Active Codec Set

    An Active Codec Set (ACS) for AMR is a group of up to four codecs (codecs 1 through 4 on the front panel) the test set can command the mobile station to use. The following are general guidelines for defining the ACS:

    • There can be up to four codecs in an Active Codec Set (ACS).

    • Each codec in the ACS must have a different rate.

    • The ACS must be defined in sequential order such that the first codec is the most robust codec and the last codec is the least robust codec. If codecs one through four are not in ascending rate order the following error occurs: Illegal parameter value; Invalid AMR codec set specified.

    • If less than four codecs are desired in the codec set, the codecs must be eliminated consecutively from codec 4 to codec 2 by selecting the Unused option for each codec that is unwanted. For example, if only two codecs are desired in the ACS, codec 4 and codec 3 must be eliminated. The Unused option is not applicable to codec 1 in the ACS, as the test set requires there to be at least one codec in the ACS.

    The codecs available for the ACS depends on which AMR specific logical speech channel is selected as the channel mode. If AHS (Adaptive Half) is chosen as the AMR Logical Speech Channel, there are seven options to choose from when defining the ACS: AHS 4.75, AHS 5.15, AHS 5.9, AHS 6.7, AHS 7.4, AHS 7.95, and Unused . If AFS (Adaptive Full) is chosen as the AMR Logical Speech Channel, there are nine different options to choose from when defining the ACS: AFS 4.75, AFS 5.15, AFS 5.9, AFS 6.7, AFS 7.4, AFS 7.95, AFS 10.2 , AFS 12.2 , and Unused.

    The units used for the codec options differ between the front panel and GPIB commands. The unit of measurement used on the front panel is kbps and is used in the Table 1: AMR Configurable Parameters and Default Values , whereas the unit of measurement used for the GPIB commands is bps. The same codecs are available via the GPIB commands as on the front panel. For Example, the codecs available to choose from when AHS (Adaptive Half) Logical Speech Channel is selected in the Channel Mode Configuration window must be specified in the GPIB commands in the following form: AHS4750, AHS5150, AHS5900, AHS6700, AHS7400, and AHS7950 . Also, the codecs available when AFS (Adaptive Full) is selected as the Logical Speech Channel in the Channel Mode Configuration menu must be specified in the GPIB commands in the following form: AFS4750, AFS5150, AFS5900, AFS6700, AFS7400, AFS7950, AFS10200 , and AFS12200 .

    NOTE
    In order to activate the changes to the Active Codec Set on the front panel Apply Changes must be pressed, otherwise any changes will be discarded if the menu closes.

    Table 1: AMR Configurable Parameters and Default Values below shows the configurable parameters in the codec set (once an AMR specific Logical Speech Channel, AHS (Adaptive Half) and AFS (Adaptive Full) has been chosen) along with their corresponding GPIB commands.

Table 1: AMR Configurable Parameters and Default Values

Adaptive Half-Rate Speech (AHS) Adaptive Full-Rate Speech (AFS)

GPIB Command

Current Codec

AHS 4.75, AHS 5.15,
AHS 5.9, AHS 6.7,
AHS 7.4, AHS 7.95

AFS 4.75, AFS 5.15,
AFS 5.9, AFS 6.7,
AFS 7.4, AFS 7.95,
AFS 10.2 , AFS 12.2

CALL:TCHannel:CMODe:AFSPeech:CODec:CURRent

CALL:TCHannel:CMODe:AHSPeech:CODec:CURRent

Default Current Codec

 AHS 5.9 AFS 7.4
Codec Options

AHS 4.75, AHS 5.15,
AHS 5.9, AHS 6.7,
AHS 7.4, AHS 7.95 ,
Unused*

AFS 4.75, AFS 5.15,
AFS 5.9, AFS 6.7,
AFS 7.4, AFS 7.95,
AFS 10.2 , AFS 12.2 ,
Unused *

CALL:TCHannel:CMODe:AFSPeech:CODec

CALL:TCHannel:CMODe:AHSPeech:CODec

Default Active Codec Set Codec 1: AHS 5.9
Codec 2: AHS 6.7
Codec 3: AHS 7.4
Codec 4: AHS 7.95 		Codec 1: AFS 7.4
Codec 2: AFS 7.95
Codec 3: AFS 10.2
Codec 4: AFS 12.2

Threshold Range

 0 - 31.5 dB (Step Size: .5 dB) 0 - 31.5 dB (Step Size: .5 dB)

CALL:TCHannel:CMODe:AFSPeech:CODec:THReshold

CALL:TCHannel:CMODe:AHSPeech:CODec:THReshold

Default Threshold Values

Codec 1 to 2 Threshold: 8 dB

Codec 2 to 3 Threshold: 12 dB

Codec 3 to 4 Threshold: 16 dB

Codec 1 to 2 Threshold: 6.5 dB

Codec 2 to 3 Threshold: 15.5 dB

Codec 3 to 4 Threshold: 18.5 dB

Hysteresis Range

 0 - 7.5 dB (Step Size: .5 dB)

0 - 7.5 dB (Step Size: .5 dB)

Default Hysteresis Values

Codec 1 to 2 Hysteresis: 2 dB

Codec 2 to 3 Hysteresis: 2 dB

Codec 3 to 4 Hysteresis: 2 dB

Codec 1 to 2 Hysteresis: 2 dB

Codec 2 to 3 Hysteresis: 2 dB

Codec 3 to 4 Hysteresis: 2 dB

*The Unused option eliminates a codec if less than four codecs are desired in the Active Codec Set (ACS). The option is not applicable to codec 1. The least robust codecs must be eliminated if fewer codecs are desired in the ACS.

  • Current Codec

    The current codec is the codec within the Active Codec Set that is in use by the mobile station. The codec that is used on the downlink (or the uplink) can at most change every two speech frames. To inform the receiver of the codec that has been used for a group of two speech frames, a control message is transmitted in-band (with the speech data) every two speech frames, on specific multiframe positions. This is known as the Codec Mode Indication (CMI). The message sent by the test set to the mobile station to change the codec mode used on the uplink is called the Codec Mode Command (CMC). According to the 3GPP 51.010, Section 26.16.2, a mobile station must respond to a CMC within three speech frames. The message sent by the mobile station to request the use of a new codec on the downlink is known as the Codec Mode Request (CMR).

    In a GSM/GPRS/EGPRS system, changes in the codec mode used on the downlink should occur automatically in response to codec mode requests from the mobile station. In the test set, when an Logical Speech Channel is changed to another Logical Speech Channel, the initial codec used after the change is what the current codec was last set to while in that AMR Logical Speech Channel. Otherwise, the default current codec is the codec with the most error correction and protection for the AMR Logical Speech Channel. Codec changes can be verified by capturing a protocol log using the Wireless Protocol Advisor (WPA), see Logging Adaptive Multi-Rate (AMR) and Wideband AMR (AMR-WB) ". When the Operating Mode is Active Cell , and the Serving Cell is GSM, GPRS, or EGPRS, there are two additional choices for the current codec. These are Stress and MS Request .

    • Stress

      When the current codec is set to Stress , a Codec Mode Command (CMC) message is sent to force the mobile station to change to a different codec mode every second uplink speech frame. See Stress Testing with Frequent Changes of Codec Mode .

    • MS Request

      When the current codec is set to MS Request , the test set responds to Codec Mode Request (CMR) messages from the mobile station. CMRs are generated in response to when changes in the C/I ratio measured at the mobile station are large enough to exceed the threshold and hysteresis values. See Forcing Codec Mode Requests .

    NOTE
    It is only possible to choose Stress or MS Request when the Operating Mode is Active Cell. The Serving Cell can be GSM, GPRS, or EGPRS.

    The following error will occur if the current codec is outside the Active Codec Set: Illegal Parameter value; Invalid AMR initial codec specified.

  • Threshold and Hysteresis Values

    The codec's threshold is the Carrier to Interference (C/I) ratio at which the mobile station will request a codec mode change. Hysteresis settings create a buffer that prevents the codec mode from continually changing when the C/I ratio varies repeatedly above or below the threshold value.

    The figure below shows the how the behavior of codec changes depends on both the threshold and hysteresis values. Notice the codec change will occur at different C/I values depending on whether the change is to a more robust codec or less robust codec. For example, if the test set has commanded the mobile station to use Codec 2 and the C/I ratio increases, Codec 2 will not change to a less robust codec, Codec 3, until the Codec 2 to 3 Threshold plus Codec 2 to 3 Hysteresis point is reached. However, if the test set initially commands the mobile station to use Codec 3 and the C/I ratio is decreasing, it will not command the mobile station to switch to a more robust codec until the Codec 1 to 2 Threshold point is reached.

    Since threshold and hysteresis values determine when to switch between codec modes the number of threshold and hysteresis values that need to be chosen is one less than the total number of codecs defined in the Active Codec Set (ACS). Also, as can be seen in the figure above, the threshold value between Codec 1 and Codec 2 must be less than or equal to the threshold value between Codec 2 and Codec 3 and so on. Similarly, the sum of the threshold and hysteresis values between Codec 1 and Codec 2 must be less than or equal to the sum of the threshold and hysteresis value between Codec 2 and Codec 3 and so on. See Table 1: AMR Configurable Parameters and Default Values for the range and default settings for the threshold and hysteresis values.

Robust AMR Traffic Synchronization Control Channel (RATSCCH)

RATSCCH is used to reconfigure AMR parameters without interrupting speech transmission. The only way to configure AMR parameters while on a call without using RATSCCH is to perform a handover. Handovers change AMR configuration parameters with layer 3 signaling using FACCH and SACCH, but are much slower than RATSCCH. Use the Wireless Protocol Advisor (WPA) to verify that AMR parameters are changed by RATSCCH signaling. For tips on using the WPA to view RATSCCH messages see Verify AMR parameter changes using RATSCCH .

Operating Considerations

AMR is available when the Operating Mode is set to Active Cell and serving cell the serving cell is GSM, GPRS, or EGPRS and when the Connection Type is Auto or when the Operating Mode is GSM BCH+TCH.

Related Topics

How to use the Adaptive Multi-Rate (AMR) and Wideband AMR (AMR-WB) Features

Logging Adaptive Multi-Rate (AMR) and Wideband AMR (AMR-WB)

In-Band Frame Error (IFER) Measurement Description

FETCh:IFERror

SETup:IFERror


Timing Advance

Timing Advance

Last updated: December 2, 2008

There are two methods in which the test set may inform the MS of the Timing Advance value, an assignment method or the Continuous Timing Advance Procedure .

Background

The test set allows you to assign the MS a timing advance value to test whether it alters its transmission accordingly. The timing advance value is initially specified in the Packet Uplink or Packet Downlink Assignment messages. If the timing advance value is altered during a data connection, the new value is sent to the MS in a Packet Power Control/ Timing Advance (PPTA) message.

Continuous Timing Advance Procedure

Continuous Timing Advance is an alternative method for assigning timing advance values. In the assignment/reassignment messages, in place of a timing advance value, the MS is given a timeslot number, and an index value. With these two parameters, the MS is able to look at the correct position in the Packet Timing-Advance Control Channel/Downlink (PTCCH/D) for its timing advance value. In addition, as part of this procedure, the MS periodically sends an access burst on the Packet Timing-Advance Control Channel / Uplink (PTCCH/U) on the given timeslot. Using the Continuous Timing Advance procedure, Packet Timeslot Reconfigure (PTR) or Packet Power Control / Timing Advance (PPTA) messages are no longer sent when the timing advance value is altered during a data connection.If the Continuous Timing Advance procedure is enabled, the MS has to delay transmission of the uplink TBF until it has received its timing advance value.

Timing Advance Parameters

  • Continuous Timing Advance
    • allows you to turn on and off the Continuous Timing Advance functionality.
    • cannot be changed in the middle of a TBF. Any change takes effect when the next TBF is established.

    NOTE
    If Continuous Timing Advance is "on", the timing advance value shall not be given in Packet Timeslot Reconfigure (PTR) or Packet Power Control / Timing Advance (PPTA) messages.

  • Timing Advance
    • allows you to select the Timing Advance value that the MS should use, regardless of the method used to communicate the actual value to the MS.
    • can be changed in the middle of a TBF.

    NOTE
    If the Continuous Timing Advance procedure is on, the Timing Advance value should not be changed more often than once every two multiframes (approximately 0.5 seconds). This restriction arises due to the physical mapping of the PTCCH/D onto the GSM/GPRS multiframe structure.

You may specify both the state of Continuous Timing Advance and timing advance values when using Active Cell operating mode and all available Connection Types: Auto, ETSI A, ETSI B, and BLER.

Timing Advance and Measurements

The test set is able to adjust for up to four symbols of offset in the MS transmission. If the MS does not react to changes in timing advance, the amount of Burst Timing Error reported will change.

TX measurements should be disregarded when the Continuous Timing Advance control method is used. They may be made invalid by the access burst.

Related Topics

How to use Timing Advance Control.


Base Station Emulation with the Data Channel

Base Station Emulation with the Data Channel

Last updated: December 2, 2008

This section is only applicable to the lab applications.

You can use the Data Channel and the test set to emulate a base station. This is particularly useful when you want to have a base station available, for example when demonstrating a wireless application, or when functionally testing wireless devices on a workbench. You may also want to vary key parameters of the cell, such as transmit power, and observe how the DUT performs.

Before you use the Data Channel for Base Station Emulation, you must have the following information:

  • an IP address valid for the subnet that you will connect the test set to
  • the valid subnet mask for that subnet
  • the default gateway for that network
  • a valid IP address for the DUT

NOTE
There are restrictions regarding IP Addresses that are valid for use. See IP Address Requirements for more information.

A. Hardware Connections

Connect PC to LAN

Please consult with your IT department if you need assistance connecting your PC to the LAN. Refer to Protocol Logging for more information about setting up protocol logging.

Connect Test Set to LAN

  1. Connect the LAN port on the back of the test set to your LAN.

Direct Connection

An alternate connection may be made using the Direct Connection method of connecting to the test set. This may be preferred, since it won't be necessary to characterize the Intranet for the throughput evaluation.

Make the following connections:

  1. Connect the Logging PC directly to the LAN port of the test set using a crossover cable.
  2. When setting up the test set and PCs (see B. Test Set and DUT Setup ), set the IP addresses of the PCs and test set to any valid IP addresses, as long as they are on the appropriate subnets.

Connect DUT to the Test Set

  1. Connect the DUT to the test set.

B. Test Set and DUT Setup

Set Up Test Set

  1. Press the Sys Config key to display the System Config screen.
  2. Use the Instrument Setup softkey ( F1 ) to display the Instrument Setup menu.
  3. Enter the IP address for the test set.
  4. Use the same menu to set the Subnet Mask.
  5. Use the same menu to set the Default Gateway.
  6. Press the Call Setup key to go to the Call Setup screen on the test set.
  7. Select Data Conn Type and set the field to IP Data .
  8. Press the left More key to go to the second screen of the Control menu.
  9. Select DUT PDP Setup to open the DUT PDP Setup menu on the test set.
  10. Set the DUT's IP address (or the address of the controlling PC) in the DUT PDP Setup menu on the test set.

    Note: The entered IP address must be on the same subnet as the test set.

Set Up DUT

  1. You may need to set the IP address or other network parameters in the DUT. Set these as needed.
  2. If the device uses a dial-up connection, you may need to set up Dial-Up Networking in the device. Do this as needed.

Base station emulation is ready. You can adjust the cell settings on the test set as desired. Most Cell Parameters require the BCH to be OFF (i.e. Operating mode = Cell Off) before adjusting the settings. Cell Power is an example of a setting that does not require BCH to be OFF. Changing Cell Power, however, or making ARFCN changes would force the DUT to re-camp.

To use Base Station Emulation to transfer data, you must make a data connection with the DUT. See C. Data Connection .

C. Data Connection

The DUT must complete a successful PDP Context activation before datagrams can be transferred. With the test set this involves two steps:

First, the DUT must perform a GPRS attach.

  1. Connect the DUT to the RF IN/OUT port of the test set.
  2. Turn the DUT on and wait for Attached to appear in the Active Cell: field on the test set's front panel display.

For DUTs that don't perform a GPRS attach automatically, you may have to set the DUT to data mode.

Second, the DUT must request a PDP Context Activation.

  1. Use the DUT or the server to initiate transfers. The DUT will request an activation, an IP address will be assigned by the test set, and the PDP Context will be active.
  2. This can be observed by looking for "PDP Active" in the Active Cell Status: field.

You can also perform some measurements while using the Data Channel:

  • BLER measurements are supported.
  • TX measurements are supported.
  • BER measurements are not supported.
  • Logging is possible during Data Channel operation.

How do You Know When You Have Succeeded?

You have made a successful data connection if you can:

  • Look at the DUT and verify that the data you were trying to transfer has actually transferred.
  • See data transfer in both directions by viewing the number of packets transferred in the Counters window of the Call Setup screen on the test set.

Related Topics

Protocol Logging and Data Channel Troubleshooting


FTP Throughput Test with the Data Channel

FTP Throughput Test with the Data Channel

Last updated: December 2, 2008

This section is only applicable to the lab applications.

The Data Channel facilitates File Transfer Protocol (FTP) via the device. Typically this is done with a dial-up connection to an external PC using a GPRS PCMCIA modem or an external GPRS modem.

With appropriate evaluation tools on the Control PC, you can measure the throughput of the modem. Many commercial FTP programs provide detailed information on transfer speed.

To empirically measure the throughput, the performance of the network must be known. For this reason, it is not recommended to perform this evaluation while connected to the Internet. A Direct Connection or Intranet connection should be used instead.

A. Hardware Connections

Connect PC to LAN

Please consult with your IT department if you need assistance connecting your PC to the LAN. Refer to Protocol Logging for more information about setting up protocol logging.

Connect Test Set to LAN

  1. Connect the LAN port on the back of the test set to your LAN.

Direct Connection

An alternate connection may be made using the Direct Connection method of connecting to the test set. This may be preferred, since it won't be necessary to characterize the Intranet for the throughput evaluation.

Make the following connections:

  1. Connect the Logging PC directly to the LAN port of the test set using a crossover cable.
  2. When setting up the test set and PCs (see B. Test Set and DUT Setup ), set the IP addresses of the PCs and test set to any valid IP addresses, as long as they are on the appropriate subnets.

Connect DUT to the Test Set

  1. Connect the modem to the PC as appropriate for your application.
  2. Connect the DUT to the test set.

B. Test Set and DUT Setup

Set Up Test Set

  1. Press the Sys Config key to display the System Config screen.
  2. Use the Instrument Setup softkey ( F1 ) to display the Instrument Setup menu.
  3. Enter the IP address for the test set.
  4. Use the same menu to set the Subnet Mask.
  5. Use the same menu to set the Default Gateway.
  6. Press the Call Setup key to go to the Call Setup screen on the test set.
  7. Select Data Conn Type and set the field to Auto .
  8. Press the left More key to go to the second screen of the Control menu.
  9. Select DUT PDP Setup to open the DUT PDP Setup menu on the test set.
  10. Set the DUT's IP address (or the address of the controlling PC) in the DUT PDP Setup menu on the test set.

    Note: The entered IP address must be on the same subnet as the test set.

Set Up DUT

  1. You may need to set the IP address or other network parameters in the controlling PC or the GPRS device. Set these as needed.
  2. If using a dial-up connection, you may need to set up Dial-Up Networking in your PC. Do this as needed.

C. Data Connection

In order to test the throughput of the DUT during active data transfer, the DUT and test set must first complete a successful PDP Context activation. With the test set this involves two steps:

First, the DUT must perform a GPRS attach.

  1. Connect the DUT to the RF IN/OUT port of the test set.
  2. Turn the DUT on and wait for Attached to appear in the Active Cell: field on the test set's front panel display. Some modems may need to attempt data transfer before it attaches to the test set. Sometimes the modem will attach if the number *99# is dialed.

For DUTs that don't perform a GPRS attach automatically, you may have to set the DUT to data mode.

Second, the DUT must request a PDP Context Activation.

  1. Use the DUT or the server to initiate transfers. The DUT will request an activation, an IP address will be assigned by the test set, and the PDP Context will be active.
  2. This can be observed by looking for "PDP Active" in the Active Cell Status: field.

You can also perform some measurements while using the Data Channel:

  • BLER measurements are supported.
  • TX measurements are supported.
  • BER measurements are not supported.
  • Logging is possible during Data Channel operation, but it may affect throughput times.

How do You Know When You Have Succeeded?

You have made a successful data connection if you can:

  • You see the data that was transferred on your DUT.
  • Measure the throughput.
  • See data transfer in both directions by observing the Counters field in the Call Setup screen of the test set.

Related Topics

Protocol Logging and Data Channel Troubleshooting


DUT Routing State

DUT Routing State

Description

The test set allows you to test the router function of a device. The test set acts as a router and it enables the routing of packets to the DUT.

DUT Routing

How does DUT works as a router

As the above figure, if the test set is sets as follows:

1. 8960 Ext IP = 130.129.183.15

2. DUT IP = 130.29.179.201

3. Host IP = 192.168.104.0

4. 8960 Routing table

Dest Mask Gateway Interface
130.29.179.201 0xFFFFFFFF 192.168.200.1 fap0
192.168.104.0 0xFFFFFF00 192.168.200.1 fap0

The IP packets that are addressed to the DUT are sent via the over-the-air interface to the DUT. When the DUT Routing State is enabled, any packet that has an address that matches the subnet mask (any address in the range 192.168.104.0 to 192.168.104.255) is sent over the air to the DUT. The DUT forwards the packet to its controller (typically a router). The router then takes care of forwarding the packet to the intended host.

How to Configure the DUT Routing State

This test set allows you to enter a maximum of four DUT IP addresses. For GSM/GPRS/EDGE LA application, you may use all four DUT IP Addresses. For all other LA applications, you are allowed to use only one DUT IP Address. For each DUT IP address, there is one associated subnet route. These subnet routes are hardcoded as follows:

Hardcoded Subnets
DUT | Network Route | Network Route Mask
1 | 192.168.104.0 | 255.255.255.0
2 | 192.168.105.0 | 255.255.255.0
3 | 192.168.106.0 | 255.255.255.0
4 | 192.168.107.0 | 255.255.255.0

Configuring the CDMA2000 DUT Routing State

If the test set's DUT IP Address is set to 146.208.232.214, the Route 192.168.1.4.0/24 Traffic to DUT is set to On, as shown below. This is done by performing that the address in the range 192.168.104.0 to 192.168.104.255 forward to the DUT which IP address is 146.208.232.214.

Routes chosen Requirements

There are two requirements for choosing routes:

  • Allows ease of reference: the set of all four subnets can be denoted by 192.168.104.0/22.
  • The subnets are chosen in an attempt to minimize the chances that you might already be using the same address for other nodes on the network. For example, it is assumed typical private networks tend to use IP address in the 192.168.1.x and 192.168.100.x ranges.

NOTE
NOTE
NOTE
NOTE
NOTE
The routes can not be set over MUI and not be availa
ble over RUI.

The LAN IP Address, LAN IP Address 2 and the DUT IP Address are all required on the same subnet. If you turn on DUT routing, any attempt to enter a LAN IP Address, LAN IP Address 2 or DUT IP Address within the range of any of the fixed network routes is rejected and an error message generated.The routes can not be set over MUI and not be available over RUI.

Operating Consideration

For CDMA2000, the DUT Routing State can not be changed when operating mode is set to Active Cell and the call or data status is other than IDLE.

For 1xEV-DO, the DUT Routing State can not be changed when operating mode is set to Active Cell and the data status is other than IDLE .

For WCDMA and GGE, the DUT Routing State can be changed when the operating mode is Cell Off

The 8960 can not be proxy ARPing for any of the new routed packets or advertising these new routes via RIP (Routing Information Protocol) or OSPF (Open Shortest Path First) or similar traffic management protocols.

The targeting of the IP address ranges to the 8960 for forwarding OTA (Over-The-Air technology) is the responsibility of the external LAN configuration.

If the Secondary PDP context is being used and the Primary PDP context clears off, no DUT routing subnet packets is forwarded to the DUT. Similarly, if the Secondary PDP context is at a higher priority than the Primary PDP context and the traffic on the Secondary PDP context takes up all the available bandwidth, DUT routing subnet packets is not forwarded to the DUT.

When attempts to turn on DUT routing, error checking is performed if any of the IP addresses or LAN subnet mask are set to an address that brings out any conflict with any of fixed network routes the operation is rejected and the operation rejected error message is displayed.

Related Topics

Data Channel


Modem Functional Test with the Data Channel

Modem Functional Test with the Data Channel

This section is only applicable to the lab applications.

The Data Channel enables testing of wireless modems or GPRS devices with built-in modems, typically using dial-up connections. If the modem is not built-in, it is usually controlled from another device such as a PC.

Before you use the Data channel for modem testing, you must have the following information:

  • an IP address valid for the subnet that you will connect the test set to
  • the valid subnet mask for that subnet
  • the default gateway for that network
  • a valid IP address for the modem or its controlling PC (even though the modem is the Device Under Test (DUT), typically a PC will be assigned the IP address)

NOTE
There are restrictions regarding IP Addresses that are valid for use. See IP Address Requirements for more information.

A. Hardware Connections

Connect Logging PC to LAN

Please consult with your IT department if you need assistance connecting your PC to the LAN. Refer to Protocol Logging for more information about setting up protocol logging.

Connect Test Set to LAN

  1. Connect the LAN port on the back of the test set to your LAN.

Connect DUT (Modem and Control PC) to the Test Set

  1. Connect the modem to the PC as appropriate for your application.
  2. Connect the DUT to the test set.

B. Test Set and DUT Setup

Set Up Test Set

  1. Press the Sys Config key to display the System Config screen.
  2. Use the Instrument Setup softkey ( F1 ) to display the Instrument Setup menu.
  3. Enter the IP address for the test set.
  4. Use the same menu to set the Subnet Mask.
  5. Use the same menu to set the Default Gateway.
  6. Press the Call Setup key to go to the Call Setup screen on the test set.
  7. Select Data Conn Type and set the field to IP Data .
  8. Press the left More key to go to the second screen of the Control menu.
  9. Select DUT PDP Setup to open the DUT PDP Setup menu on the test set.
  10. Set the DUT's IP address (or the address of the controlling PC) in the DUT PDP Setup menu on the test set.

    Note: The entered IP address must be on the same subnet as the test set.

Set Up DUT

  1. You may need to set the IP address or other network parameters in the controlling PC or the GPRS device. Set these as needed.
  2. If using a dial-up connection, you may need to set up Dial-Up Networking in your PC. Do this as needed.

C. Modem Functional Test

In order to test the functioning of the DUT, it must first complete a successful PDP Context activation. With the test set this involves two steps:

First, the DUT must perform a GPRS attach.

  1. Connect the DUT to the RF IN/OUT port of the test set.
  2. Turn the DUT on and wait for Attached to appear in the Active Cell: field on the test set's front panel display. Some modems may need to attempt data transfer before it attaches to the test set. Sometimes the modem will attach if the number *99# is dialed.

For DUTs that don't perform a GPRS attach automatically, you may have to set the DUT to data mode.

Second, the DUT must request a PDP Context Activation.

  1. Use the DUT to initiate data transfers. The DUT will request an activation, an IP address will be assigned by the test set, and the PDP Context will be active.
  2. This can be observed by looking for "PDP Active" in the Active Cell Status: field.

You can also perform some measurements while using the Data Channel:

  • BLER measurements are supported.
  • TX measurements are supported.
  • BER measurements are not supported.
  • Logging is possible during Data Channel operation.

How do You Know When You Have Succeeded?

You have made a successful data connection if you can:

  • Browse the Internet over the DUT.
  • See data transfer in both directions by observing the Counters field in the Call Setup screen of the test set.
  • Look at the DUT and its PC and verify that the data you were trying to transfer has actually transferred.

Related Topics

Protocol Logging and Data Channel Troubleshooting


Ping

Ping

This section is only applicable to the lab applications.

Ping is a tool to help check system interconnects. The test set has a Ping feature that allows you to ping either the DUT IP Address or an alternate address specified by you (see How to "ping" an IP address from the test set ). An IP datagram (technically an Internet Control Message Protocol (ICMP) Echo Request message) is sent from the test set to the ping target, and expects a response. You can define the size of the IP datagram. The default is 64 bytes. The response information is displayed on the test set's front panel display. This feature can be controlled through the front panel or through GPIB control.

NOTE
For Multiple PDP Context, a selection of DUT to ping will result in the pinging of DUT IP Address 1, the only way to ping each of the remaining DUT related IP addresses is to set them manually as Alternate Device to ping.

Ping is the simplest implementation of the Data Channel feature. If you are trying to debug a system that is not responding to a full network setup (for example a WAP setup), try pinging the DUT from a computer attached to the network. Experiment with very large packets, very long timeouts and continuous pings.

How to ping the DUT

The following procedure details how to ping a DUT

  1. Press the CALL SETUP screen key.
  2. Press the More key until screen 2 of 3 of the Control menu is displayed.
  3. Press Ping ( F3 ).
  4. Press Ping Setup ( F1 ) and the Ping Setup menu appears in the center of the screen.
  5. Use the knob to highlight Device to Ping and set it to Alternate .
  6. Use the knob to highlight Alternate Ping Address and use the number key pad to imput the IP Address of the device to ping.

How to ping an Alternate Device

The following procedure details how to ping a Alternate Device

  1. Press the CALL SETUP screen key.
  3. Press the More key until screen 2 of 3 of the Control menu is displayed.
  4. Press Ping ( F3 ).
  5. Press Ping Setup ( F1 ) and the Ping Setup menu appears in the center of the screen.
  6. Use the knob to highlight Device to Ping and set it to Alternate .
  7. Use the knob to highlight Alternate Ping Address and use the number key pad to imput the IP Address of the device to ping.

How to Read the Ping Results

If the connection is good, then the device returns a packet to the test set and the packet transfer information is displayed on the test set's screen (see Ping Data Display ). The figure below shows the kind of information that is displayed on the Ping screen. In this example, the Ping Count has been set to ping 10 times. Note that on average it took 1248 msec to complete a ping.

Ping Data Display

Operating Considerations

  • When pinging the DUT, the DUT must either accept a network initiated PDP Context activation or have requested a PDP Context (for GPRS or EGPRS) or the instrument status should be Connected + Data (for GSM CSD).
  • There are restrictions regarding IP Addresses that are valid for use. See IP Address Requirements for more information.
  • Ping is only available in Active Cell operating mode and when the data connection type is set to Auto.
  • When the Ping originates from the test set and the target is the DUT, the Downlink Source address is always the IP address of the test set, and Uplink Destination Address is the same value.
  • Your mobile station must support ping for you to be able to successfully ping the DUT IP Address.

Related Topics

Manual Operation: How to "ping" an IP address from the test set

GPIB Commands: CALL:DATA

Protocol Logging During Ping

Data Channel

Protocol Logging and Data Channel Troubleshooting

DUT PDP Setup


Protocol Logging During Ping

Protocol Logging During Ping

This section is only applicable to the lab applications.

Ping data passing between the test set and the mobile station can be logged using the Wireless Protocol Advisor (WPA) (see Protocol Logging ). The log results during ping depend on the method used. Here are several methods and descriptions of the log results.

  • Method 1: Ping the Mobile Station from the Test Set
  • Method 2: Ping an Alternate IP Address From the Test Set
  • Method 3: Using Ping From Other Devices
  • Ping Log

Method 1: Ping the Mobile Station from the Test Set

To capture a protocol log while pinging the mobile station from the test set, start a capture in the WPA and then follow the steps in Ping the DUT from the test set .

Looking at the Protocol Log

Note that the Source Address for the IP datagram in the Down direction is an unknown IP address. This is an internal address the test set uses to originate IP traffic from the test set to the mobile station.

See Ping Log for more information about the log.

Method 2: Ping an Alternate IP Address From the Test Set

To capture a protocol log while pinging an alternate IP address from the test set, start a capture in the WPA and then follow the steps in Ping an alternate address from the test set .

If your Alternate Ping Address is anything but the mobile station address, the test set's protocol logging does not log this ping. The test set's logging only captures messages exchanged between the test set and the mobile station. If you have a network logging device on your LAN, it will show that the source IP address is the test set's LAN IP address. If your Alternate Ping Address is the mobile station address, then the data is logged by the test set, and the Source Address for the datagram in the Down direction that contains the ping data is the same IP address as in Method 1.

Method 3: Using Ping From Other Devices

Any device on the network that has a ping feature can ping any other device, including the mobile station. For example, if you have a PC on the LAN that the test set is connected to, you can use ping from that PC to ping the mobile station.

Example procedure of pinging the mobile station from another device (e.g. a Windows PC):

  1. Start protocol logging. See Protocol Logging .
  2. Open a MS DOS command prompt on the PC.
  3. Type the following command

    ping xxx.xxx.xxx.xxx

    where xxx.xxx.xxx.xxx is the IP address of the mobile station.

  4. The ping should respond as normal.
  5. Stop logging.

In this case, the Source_Address for the datagram in the Down direction that contains the ping data is the IP address of your PC.

Ping Log

The Ping can be logged using the Wireless Protocol Advisor (WPA) (see Protocol Logging ), and certain information can be derived from the log of the Ping.

  • "Down" in the "Direction" column of the WPA indicates that this is a downlink message and is therefore passing from the test set to the mobile station.
  • Ping is an Internet Control Message Protocol message.
  • Type is ECHO_MESSAGE, which is the instruction to the peer layer at the destination address to generate an ECHO_REPLY message.
  • The IP address of the mobile station is the Destination Address on the downlink datagram and is the Source Address on the uplink datagram. The alternate address is an address within the test set that originated the Ping data packet.
  • The Type, Code, Checksum, Identifier and Sequence Number are all listed.

Related Topics

Ping


WAP Test with the Data Channel

WAP Test with the Data Channel

This section is only applicable to the lab applications.

The Data Channel facilitates the functional test of a Wireless Application Protocol (WAP) device such as a WAP-enabled mobile station.

Logging data during this process provides protocol data at useful points in the stack, which may help in debugging the Device Under Test (DUT).

Before you use the Data channel for WAP, you must have the following information:

  • an IP address valid for the subnet that you will connect the test set to
  • the valid subnet mask for that subnet
  • the default gateway for that network (not the same as the WAP gateway)
  • a valid IP address for the DUT
  • the default WAP gateway address (this may be required by the DUT)
  • There are restrictions regarding IP Addresses that are valid for use. See IP Address Requirements for more information.

NOTE
There are restrictions regarding IP Addresses that are valid for use. See IP Address Requirements for more information.

A. Hardware Connections

Connect PC to LAN

Please consult with your IT department if you need assistance connecting your PC to the LAN. Refer to Protocol Logging for more information about setting up protocol logging.

Connect Test Set to LAN

  1. Connect the LAN port on the back of the test set to your LAN.

Connect DUT to the Test Set

  1. Connect the DUT to the test set. There may be several ways to connect to the RF link of the DUT. The connection diagram shows a connection to the DUT's antenna.

B. Test Set and DUT Setup

Set Up Test Set

  1. Press the Sys Config key to display the System Config screen.
  2. Use the Instrument Setup softkey ( F1 ) to display the Instrument Setup menu.
  3. Enter the IP address for the test set.
  4. Use the same menu to set the Subnet Mask.
  5. Use the same menu to set the Default Gateway.
  6. Press the Call Setup key to go to the Call Setup screen on the test set.
  7. Verify that the Operating Mode ( F1 ) is set to Active Cell and the Connection Type ( F2 ) is set to Auto .
  8. Press the left More key to go to the second screen of the Control menu.
  9. Select DUT PDP Setup to open the DUT PDP Setup menu on the test set.
  10. Set the DUT's IP address in the DUT PDP Setup menu on the test set.

    NOTE
    The DUT IP address must be on the same subnet as the test set.

Set Up DUT

  1. You may need to set some network parameters in the WAP device (the DUT). Some typical parameters include a home page, Primary Port, or Data Bearer. Set these as needed.
  2. You may also need to set a default WAP gateway (may be called Primary IP Address). Do this if necessary. Some network setups may require that the WAP gateway be on the same side of the firewall as the DUT and test set.

C. Data Connection

The objective of the WAP evaluation is to successfully transfer WAP datagrams. The DUT must complete a successful PDP Context activation before datagrams can be transferred. With the test set this involves two steps:

First, the DUT must perform a GPRS attach.

  1. Connect the DUT to the RF IN/OUT port of the test set.
  2. Turn the DUT on and wait for Attached to appear in the Active Cell: field on the test set's front panel display.

For DUTs that don't perform a GPRS attach automatically, you may have to set the DUT to data mode.

Second, the DUT must request a PDP Context Activation.

  1. Use the DUT to initiate data transfers. The DUT will request an activation, the DUT's IP address will be assigned by the test set, and the PDP Context will be active.

    Additional Information:

    If the Network initiates a data transfer before the DUT has requested a PDP context, the 8960 will send a Request_PDP_Context_Activation message. No data will be sent to the DUT until a PDP Context has been activated.

  2. This can be observed by looking for "PDP Active" in the Active Cell Status: field.

You can also perform some measurements while using the Data Channel:

  • BLER measurements are supported.
  • TX measurements are supported.
  • BER measurements are not supported.
  • Logging is possible during Data Channel operation.

How do You Know When You Have Succeeded?

You have made a successful data connection if you can:

  • Look at the WAP device and verify that the pages you were trying to transfer have actually transferred.
  • See data transfer in both directions by observing the Counters field in the Call Setup screen.

Related Topics

Protocol Logging and Data Channel Troubleshooting


Medium Access Mode

Medium Access Mode

This section applies only to the lab applications.

The test set provides you with control over resource allocation. This allows you to define difficult scenarios for the mobile station and more comprehensively exercise its protocol. Four modes for uplink resource allocation are provided:

Fixed Allocation

Automatic Dynamic Allocation

Dynamic Allocation

Extended Dynamic Allocation

Medium Access Mode

  • Fixed Allocation

    In the fixed allocation mode, the mobile station is allocated uplink blocks based on the number of octets the mobile station needs to transfer all its data. The mobile station requests these octets in the RLC octet count parameter in either the Packet Resource Request message or the Packet Downlink Ack/Nack message. There are two types of Temporary Block Flows (TBFs) that might be requested by the mobile station:

    • An open-ended TBF - The mobile station sets the RLC octet count to 0 (zero). The test set then provides an arbitrary number of octets and the mobile station continues to make resource requests until it has been able to transfer all its data.
    • A close-ended TBF - The mobile station sets the RLC octet count to a value greater than 0, requesting a specific number of octets. The test set provides resources for this request.

    Maximum Octet Allocation

    You can use the maximum octet allocation parameter to limit the number of octets that the test set provides in any single allocation to a mobile station requesting a close-ended TBF. When this parameter is turned off, the mobile station is provided with exactly what it requests. When the maximum octet allocation value is set to a value greater than zero, this is the maximum amount of octets that the mobile station may transfer on the uplink. If this allocation does not satisfy the mobile station's requirement for a data transfer then it must request further fixed allocations until its needs are met. Therefore, you can control the number of reallocations by limiting the maximum number of octets per allocation. Forcing requests for more allocations utilizes the mobile station's protocol more extensively.

    Why can fixed allocation only be used when the connection type is set to Auto?

    Fixed allocation is valid only while using the auto connection type. It cannot be used in the ETSI test modes connection types because the test specification mandates that Dynamic Allocation or Extended Dynamic Allocation must be used. In BLER mode there is no uplink Temporary Block Flow (TBF), so the allocation type is unused. Connections established while the connection type is set to auto do use uplink TBFs and have no restrictions on the choice of allocation type.

    As fixed allocation is only valid when using the auto connection type, when an invalid connection type is selected, the current TBFs end, and the test set changes the allocation mode setting to a valid selection (dynamic mode or extended dynamic allocation).

  • Automatic Dynamic Allocation

    When automatic dynamic allocation is used the test set automatically determines whether Dynamic Allocation or Extended Dynamic Allocation is used based on the number of uplink bursts per frame.

  • Dynamic Allocation

    When dynamic allocation is used, the mobile station monitors the downlink for a USF value that matches its assigned USF. When it finds a match, the mobile station can then transfer the data blocks on the allocated uplink block.

    Dynamic allocation is valid while using the following Connection Types: Auto, ETSI Type A, ETSI Type B, and BLER. The dynamic allocation setting is used when there is one or two uplink bursts per frame.

  • Extended Dynamic Allocation

    When extended dynamic allocation is used the mobile station only monitors the USF of the first downlink burst of the multislot configuration. When a USF in the first downlink burst matches the assigned USF, the mobile station can then transfer data blocks on all the uplink timeslots. Extended dynamic allocation mode is used for class B mobile stations which cannot simultaneously receive and transmit and when there are more than two uplink bursts present in the frame.

    The default Medium Access Mode for multislot configurations that have three or more uplinks is extended dynamic allocation.

Configurable Parameters

The table below lists all the configurable parameters in the MAC Control menu. Click on any of the links within the table for more information. The GPIB Command links take you to the GPIB Command table which contains the command description, setting range, *RST values, and a programming example.

Parameter | GPIB Command
Medium Access Mode | CALL:(PDTCH|PDTChannel):MACCess
Assigned Uplink State Flag (USF) BLER | CALL:(PDTCH|PDTChannel):MACCess[:DYNamic]:USFLag[:ASSigned]
Unassigned USF Mode | CALL:(PDTCH|PDTChannel):MACCess[:DYNamic]:USFLag:UNASsigned:MODE
Manual Unassigned USF | CALL:(PDTCH|PDTChannel):MACCess[:DYNamic]:USFLag:UNASsigned[:MANual]
Maximum Octet Allocation | CALL:(PDTCH|PDTChannel):MACCess:FIXed:MOALlocation:NUMBer
Relative Reserved Block Period (RRBP) | CALL:(PDTCH|PDTChannel):RRBPeriod

Allocation Mode and USF BLER

USF BLER results are displayed only when the allocation mode is dynamic, automatic dynamic, or extended dynamic. In fixed mode, the mobile station is not sending data blocks dependent upon the USF value. Instead, the mobile station ignores the USF on the downlink because it is given a block allocation by the network or, in this case, the test set.

Related Topics

How Do I Access the Medium Access Control (MAC) Parameters?


Access Burst Power Control

Access Burst Power Control

The test set allows you to control two parameters broadcast on the BCCH which are associated with the power of mobile station access bursts:

  • MS TX Power Max CCH (GSM)
  • MS TX Power Max CCH (GPRS)
  • MS TX Power Max CCH DCS1800 Offset

MS TX Power Max CCH (GSM)

The value of this parameter is the maximum transmit power level that may be used by the mobile station for its next access burst on the broadcast channel. See CALL[:CELL]:BCHannel:MS:TXLevel[:SELected] for more information about this parameter.

MS TX Power Max CCH (GPRS)

The value of this parameter is the maximum transmit power level that may be used by the mobile station for its next access burst on the packet broadcast control channel. See CALL[:CELL]:(PBCCH|PBCChannel):MS:TXLevel[:SELected] for more information about this parameter.

MS TX Power Max CCH DCS1800 Offset

The value of this parameter corresponds to a power offset used by class 3 DCS1800 mobile stations. Mobile stations prior to class 3 do not support power levels 29-31. Therefore, for DCS 1800, the power control levels 29, 30, and 31 are not valid values for the MS TX Power Max CCH (GSM or GPRS) parameter to ensure backwards compatitibility. However, class 3 mobile stations do support the extended power range. The DCS1800 Max CCH Power Offset is provided for procedures where a class 3 DCS 1800 mobile stations should use its extended power range.

A class 3 DCS 1800 mobile station shall use the power level defined in the MS TX Power Max CCH (GSM or GPRS) parameter plus the value of the power offset. As illustrated in the following table, when the MS TX Power Max CCH's value is 0, setting the Power Offset value to 1,2, or 3 can be used to achieve output power corresponding to power levels 31, 30, and 29 respectively.

Power Offset Parameter Values
Value | Offset | Power Control Level | Maximum Output Power
0 | 0 dB | 0 | 30 dBm
1 | 2 dB | 31 | 32 dBm
2 | 4 dB | 30 | 34 dBm
3 | 6 dB | 29 | 36 dBm

Related Topics

How to Configure Access Burst Power Control


A-GPS (Assisted-GPS)

A-GPS (Assisted-GPS)

Last updated: December 3, 2008

This section is only applicable to the lab applications.

You can use the test set as a base station or network emulator in a system for testing the A-GPS capability of mobile stations. The test set provides the ability to send A-GPS messages over the air to and receive responses from the mobile station.

A-GPS Solution in the Test Set

To allow the testing of A-GPS capability of a mobile stations, the test set provides an "RRLP pipe" mode. The test set provides a mechanism for passing encoded RRLP messages over the air to the mobile station and retrieving the mobile station's response. The test set does not provide for encoding or decoding the A-GPS messages. It also does not validate the message contents. The complete RRLP message must be encoded and decoded external to the test set. The test set accepts hexadecimal character strings to represent the RRLP binary message content.

You can enable/disable automatic header creation and segmentation of the RRLP binary message by setting the RRLP Header state.

  • When the RRLP Header state is set to ON, the Application Protocol Data Unit (APDU) ID and APDU Flags field are present in the RRLP messages, the test set creates the APDU ID and APDU Flags field. The individual RRLP messages can be up to 1000 bytes, or 2000 characters of hex.
  • When the RRLP Header state is set to OFF, the Application Protocol Data Unit (APDU) ID and APDU Flags field are not present in the RRLP messages. You must create the APDU ID and APDU Flags field and include them in the hexadecimal message.The individual RRLP messages can be no longer than 251 characters of hex. However, the first two octets of the message sent by the mobile are also checked to ensure they carry the correct Protocol Discriminator, Skip Indicator and Message Type.

The RRLP pipe can only be setup and controlled using GPIB commands. See CALL:PPRocedure:PMEasurement:PIPE for information about each of the RRLP pipe commands.

NOTE
When the test set's RRLP layer is in RRLP pipe mode, the standard RRLP message interface for E-OTD testing in the test set is disabled. However, either type of RRLP message (E-OTD or A-GPS) can be sent in the RRLP pipe mode. Messages sent using the RRLP pipe mode must be encoded external to the test set. See E-OTD (Enhanced Observed Time Difference) for more information about the E-OTD testing in the test set.

You can reset the MS positioning stored information by sending the GPIB command CALL:PPRocedure:PMEasurement:MS:RESet .

How does the A-GPS Solution Work?

RRLP messages sent using the RRLP pipe mode pass transparently through the RRLP layer in the test set and are sent over the RF interface to the mobile station using standard GSM control channels via the layer 3 RR entity. Layer 3 segmentation is performed as required.

Related Topics

CALL:PPRocedure:PMEasurement:PIPE


MS Output Power

MS Output Power

This section is only applicable to the lab application.

  • Description
  • Configurable Parameters
  • How Do I Configure the Alpha and Gamma Parameter?
  • Operating Considerations
  • Related Topics

Description

The test set provides two methods to set the MS output power for a PS connection.

  1. MS TX Level:

    Set the MS TX level directly.

  2. Alpha and Gamma:

    Set the a (alpha) and T ch (gamma) parameters. The MS output power is determined by the following arithmetic.

    P CH = min[T 0 -T ch -a*(C+48), P MAX )]

    where:

    • T 0 : 39dBm for GSM 400, GSM 700, GSM 850 and GSM 900; 36dBm for DCS 1800 and PCS 1900
    • T ch : MS and channel specific power control parameter sent to MS
    • a: system parameter broadcast on PBCCH or optionally sent to MS
    • C: the normalized received signal level at the MS
    • P MAX : the maximum allowed output power in the cell

Configurable Parameters

MS output power selection mode

This parameter specifies the method by which the MS output power is determined for a PS connection. The method used is either the directly setting of MS TX Level or the more complete solution relation to power control parameters a (alpha) and T ch (gamma).

The GPIB command to set the MS output power selection mode is CALL:(PDTCH|PDTChannel):MS:OPSMode .

MS TX Level

The GPIB command to set the MS TX Level parameter is CALL:(PDTCH|PDTChannel):MS:TXLevel[:SELected]:BURSt<[1]|2|3|4|5> .

The GPIB command to set the Deferred MS TX Level parameter (which is used during the handover) is CALL:SETup:(PDTCH|PDTChannel):MS:TXLevel[:SELected]:BURSt<[1]|2|3|4|5> .

Alpha

This parameter is systematic, broadcast on PBCCH or optionally sent to MS in an PLC control message. It determines the proportion of the measured broadcast channel to be used in the above arithmetic.

The GPIB command to set the Alpha parameter is CALL:(PDTCH|PDTChannel):MS:ALPHa .

Gamma

This parameter is an MS and channel specific power control parameter, sent to the MS in an RLC control message. The gamma values are specified on a per timeslot basis, and the number of the uplink timeslots can be up to 5. Each set of gamma setting is available on a per band basis.

The GPIB command to set the Gamma Burst parameter is CALL:(PDTCH|PDTChannel):MS:GAMMa:BURSt<[1]|2|3|4|5>[:SELected] .

The GPIB command to set the Deferred Gamma Burst parameter is CALL:SETup:(PDTCH|PDTChannel):MS:GAMMa:BURSt<[1]|2|3|4|5>[:SELected] .

How Do I Configure the Alpha and Gamma Parameter?

This procedure is only applicable to the lab application. This procedure describes how you manually configure the ARAC Control parameters in the test set.

  1. Press the CALL SETUP screen key.
  2. Press PDTCH Parameters ( F9 ).
  3. Press MS TX Level ( F10 ).
  4. Set MS Output Power Selection Mode to Alpha Gamma.
  5. To change a parameter in this menu, use the knob to scroll to, highlight, and change the parameter settings.

Operating Considerations

The Alpha and Gamma parameters are only available when the operating mode is set to Active Cell .

Related Topics

Dual Transfer Mode


Logging Adaptive Multi-Rate (AMR) and Wideband AMR (AMR-WB)

Logging Adaptive Multi-Rate (AMR) and Wideband AMR (AMR-WB)

Last updated: December 3, 2008

This section is only applicable to the lab applications.

You can use the Wireless Protocol Advisor (WPA) to observe and analyze messages and information related to AMR. This section contains some suggestions of how to modify the WPA view to make it easier to access certain fields.

  • Verify a Codec Mode Change During a Call
  • Verify that the Mobile Station can pass the Stress Test
  • View Codec Mode Requests from the Mobile Station
  • Verify successful Handovers
  • Verify AMR parameter changes using RATSCCH
  • Verify the Usage of Discontinuous Transmission (DTX)

WPA help is accessible from WPA by clicking the help button or for download at: http://www.agilent.com/find/e6584a

Verify a Codec Mode Change During a Call

For the manual operation procedure for setting up this test, see Change the Codec During a Call . In the Measurement Setup screen of the WPA, filter the Layer 1 Information protocol messages and set up a column that displays the Coding Scheme Used in the Traffic Overview screen. The Coding Scheme Used is found in the Layer 1 Information. Change the Current Codec (see General AMR and AMR-WB Parameter Setup , steps 7-9). To verify that a mobile station can handle a change in the Codec Mode, run the WPA while a call is connected, and analyze the Coding Scheme Used and verify that the changes occurred. The column that displays the Coding Scheme Used allows you to quickly see any changes that occurred during the protocol log.

The figure below shows a protocol log while a call is connected.

Verify that the Mobile Station can pass the Stress Test

For the manual operation procedure for setting up this test, see Stress Testing with Frequent Changes of Codec Mode , There are several columns in the WPA that can be set up to prove that the mobile station is capable of being forced into different active codec modes during a call. While the same information could be viewed in the message decode, the columns make it easy to view the codec changes. In the Layer 1 Information protocol messages, the Codec Mode Command, Codec Mode Request, and Codec Mode Indication are sufficient to see the if the mobile station is responding properly. For more detailed information on the Codec Mode Command and Codec Mode Request columns, set up additional columns with corresponding interpretation. For example, if you would like more information on the Codec Mode Request, set up a column that displays Interpretation of Codec Mode Request under Layer 1 Information protocol.

The figure below shows a protocol log while a call is connected. The Codec Mode Command column verifies the test set is forcing the mobile station to a different codec mode on every third uplink.

View Codec Mode Requests from the Mobile Station

For the manual operation procedure for setting up this test, see Forcing Codec Mode Requests .

Be sure to set the Current Codec mode to MS Request for this test.

A quick way to verify in WPA that the mobile station is requesting and responding to messages from the test set is to set up the Codec Mode Request and the Coding Scheme Used columns. These messages are found in Layer 1 Information protocol. Once the column is set up, start the protocol log and change the downlink traffic power on the test set. After the protocol logging has stopped, analyze the columns to see if the Codec Mode Requests changed with the Coding Scheme Used.

The figure below shows a protocol log while a call from the mobile station was connected to the test set. The Current Codec was set to MS Request on the test set. The Codec Mode Request column verifies the mobile station generated requests to change codec modes while the downlink traffic power was changed on the test set.

Verify successful Handovers

For the manual operation procedure for setting up this test, see Handovers While an AMR or AMR-WB Call is Active . To analyze handover parameters only, set the Test Set Message Filter in the WPA to filter only the GSM Layer 3 ( GSM L3 ) protocol. When the GSM L3 message is an Assignment Command type, all handover parameters except the Logical Speech Channel can be checked and verified in the message decode, as shown in the figure below. Layer 1 messages that are AMR Frame Information type show the Logical Speech Channel type.

NOTE
If the test set is configured to only filter the Layer 3 messages, it must be reconfigured to filter the Layer 1 messages before they will appear in the Traffic Overview of the WPA..

Verify AMR parameter changes using RATSCCH

For the manual operation procedure for setting up this test, see Change Parameters using RATSCCH . The following are RATSCCH messages in the WPA: AMR Threshold Req, AMR Config Req, and AMR Ack. Setting up a Test Set Message Filter to only see RATSCCH protocol messages makes them much easier and quicker to locate. AMR Threshold Req messages display all the threshold and hysteresis values that are in the codec set. AMR Config Req shows the all the active codec modes that make up the codec set. The AMR Ack message acknowledges that the message has been sent.

For example, the message highlighted (in blue) in the figure below is an AMR Threshold Req message. The message decode for the highlighted message, shown in the lower portion of the figure, lists all the threshold and hysteresis values. Since the number of sets of threshold and hysteresis values is one less than the number of codecs in the set, it is clear there are only three codecs in the Active Codec Set (ACS) because there are two sets threshold and hysteresis values. The third set of threshold and hysteresis values is reserved for when there are four codecs in the ACS.

Verify the Usage of Discontinuous Transmission (DTX)

For the manual operation procedure for setting up this test, see Discontinuous Transmission (DTX) . It is possible to verify and monitor that the transmission and decoding of the many types of frames associated with DTX. View the message decode to see whether or not DTX was used. To see this without looking at each message decode, set up a column that displays DTX-USED. The DTX messages are found in GSM L3 protocol. This column will display if DTX was used or if DTX was not used. The figure below shows an example of a protocol log of a call established between the mobile station and the test set, with the DTX-USED column set up and a message decode view. The red arrow in the diagram shows where the message decode view lists if DTX was used or if DTX was not used.

Related Topics

How to use the Adaptive Multi-Rate (AMR) and Wideband AMR (AMR-WB) Features


Security Information

Security Information

This section is only applicable to the lab application.

NOTE
Authentication and Ciphering procedure requires a special licence.

You can specify which security procedure (Authentication or ciphering) is performed using the Security Info setting. Authentication and ciphering procedure are described in 3GPP TS 24.008, 33.102, 42.009, 43.020.

NOTE
Authentication and Ciphering procedure can causes higher rate throughput when it turns on depending on the protocol processor.

Authentication

The authentication procedure checks the validity of a subscriber's SIM card to ensure that the MS is allowed to use network resources. During Authentication, the network challenges the MS which attempting to connect to it and sends an authentication request which contains a random number(RAND). The MS then runs the Authentication Algorithm(A3) using Ki and RAND as input parameters and returns the result, signed response(SRES) to the network. A3 and Ki are stored securely and never sent over the air interface(Um). On receipt of the SRES, the network tests to see if this is the expected response. If it is the expected response, MM/GMM procedure processing continues, otherwise the network simply rejects the connection or bar the SIM.

Configurable Parameters

You can set the following parameters before an authentication procedure is started:

  • Authentication State

    When this parameter is set to ON, the test set will perform an authentication challenge to the MS. If the authentication challenge is successful, the required MM or GMM procedure connection proceeds as normal, otherwise an AUTHENTICATION ERROR message is generated and the service request is rejected. For GPRS, Authentication only performed during Attach or Routing Area Update procedure.

    The GPIB command to set the Authentication parameter is CALL:SECurity:AUTHenticate:STATe .

  • Random(RAND) Value

    RAND is a 128 bit random number used as a challenge to MS in an authentication request.

    The GPIB command to set the Random(RAND) Value is CALL:SECurity:AUTHenticate:RANDom[:SELected] .

  • XRESThe Authentication Algorithm is implemented on per network and SIM card basis. There is no way that all the Authentication Algorithm variations of network SIM and test SIMs could be supported. In order to avoid implementing multiple A3 algorithms, the test set supports input of the expected response(XRES). When authentication is enabled, the test set compares the SRES sent from the MS with the input XRES. If they don't match, an AUTHENTICATION FAILED error message is reported and action is taken depend on the user selection of ACTION ON FAILSURE. The test SIM uses the A3 algorithm defined in 3GPP TS 34.108.

    The GPIB command to set the XRES Value is CALL:SECurity:AUTHenticate:XRESult[:SELected] .

Authentication Results

The authentication results are reported by the test set include:

  • Success
  • Synch Failure
  • Unknown
  • RES Does Not Match

Authentication results are reported separately for the packet switched(PS) and circuit switched(CS) domains:

  • Authentication Result: MM (CS domain)

    This result indicates the success or failure of the MS and test set to authenticate in the CS domain.

    GPIB command: CALL:SECurity:AUTHenticate:RESult[:MM][:SELected]? .

  • Authentication Result: GMM (PS domain)

    This result indicates the success or failure of the MS and test set to authenticate in the PS domain.

    GPIB command: CALL:SECurity:AUTHenticate:RESult:GMM[:SELected]? .

Ciphering

When Authentication is complete, ciphering of data transferred between MS and network can be achieved. During Ciphering, the raw data and the Ciphering Key(Kc) are used as the input to the Ciphering Algorithm. Then the resultant data is transmitted over the air interface and decrypted using the same algorithm and ciphering key at the other end.

You can set the following parameters before an ciphering procedure is started:

  • Ciphering Key(Kc)

    Ciphering Key is a 64 bit number used as an entry parameter to the selected encryption algorithm.

    The GPIB command to set the Ciphering Key(Kc) is CALL:SECurity:CIPHering[:KEY] .

  • Cipher Key Sequence Number (CKSN)

    The CKSN can be used by the test set to indicate the Kc stored within the MS to use for ciphering. See 3GPP TS 24.008 section 10.5.1.2 for more details.

    The GPIB command to set the CKSN is CALL:SECurity:CIPHering:CKSNumber .

  • GSM Ciphering Algorithm

    GSM Ciphering Algorithm determines which ciphering algorithm is used for GSM voice or circuit switched data.

    The GPIB command to set the GSM Ciphering Algorithm is CALL:SECurity:CIPHering:GSM:ALGorithm .

  • GPRS Ciphering Algorithm

    GPRS Ciphering Algorithm determines which ciphering algorithm is used for GPRS packet switched data.

    The GPIB command to set the GPRS Ciphering Algorithm is CALL:SECurity:CIPHering:GPRS:ALGorithm .

NOTE
The A5/3 encryption and GEA3 Encryption have not been fully tested.

How Do I Configure the Authentication and Ciphering State?

This procedure is only applicable to the EGPRS lab application. This procedure describes how you manually configure the ARAC Control parameters in the test set.

  1. Press the CALL SETUP screen key.
  2. Press More on the bottom left side of the screen until menu 3 of 3 of Control is displayed.
  3. Press Security Info ( F3 ).
  4. Press Authentication Parameters ( F1 ). This displays the Authentication Parameters menu.
  5. To change a parameter in this menu, use the knob to scroll to, highlight, and change the parameter settings.
  6. Press Close Menu ( F6 ) and then press Authentication Parameters ( F1 ). This displays the Ciphering Parameters menu.
  7. To change a parameter in this menu, use the knob to scroll to, highlight, and change the parameter settings.

Operating Considerations

The Security Information parameters are only available when the operating mode is set to Active Cell .

When Authentication is enabled, the call setup and GMM Attach procedures will take slightly longer.

When Ciphering is enabled, as more processing time will be required to run the Ciphering Algorithm. This may have an impact on maximum data throughput and the increased processor load may effect WPA logging.

The Security Information parameters can be changed after the security procedure started. And if the ciphering procedure is active, you can still change the algorithm.

Related Topics

Protocol Control


Call Signaling Parameters

Call Signaling Parameters

Please click one of the following Call Signaling Parameters for more information.

  • Dedicated Control Channel (DCCH) Features
  • Repeated Downlink FACCH
  • Repeated SACCH
  • Cell Selection Indicator

For information on how to manually access the Call Signaling Parameters, see How Do I Configure the Call Signaling Parameters? .


HTTP Interface for Cell Broadcast Service - Introduction

HTTP Interface for Cell Broadcast Service - Introduction

This section is only applicable to lab applications and the test application with a required feature license.

This section explains HTTP interface for configuring and sending cell broadcast messages. You can use the HTTP interface to interface with custom programs. You can also use the HTTP interface to control the test set's cell broadcast service parameters through the address bar of an internet browser.

HTTP Overview

HTTP is the client/server based protocol used to deliver virtually all files and data on the World Wide Web. If you'd like a more detailed description of HTTP protocol, refer to Internet RFCs `HTTP/1.0 - RFC 1945' and `HTTP/1.1 - RFC 2616', which can be downloaded from http://www.rfc-editor.org/rfc.html.

When you use HTTP in a web browser, you enter the "address" for the web page you wish to view. These addresses can be generalized into the following format:

In this example, the web browser is the HTTP client and it uses the information in this address to open a connection to an HTTP server and send a request.

  • "http://" is the protocol specifier, telling the browser what protocol to use for the request.
  • <ip_address> is the IP address of the server.
  • <port> is the port number on which to communicate with the server. The default port for HTTP is 80.
  • <request_URL> provides information to the server on the location of the resource that's being requested and can also be used to provide information to the resource.

HTTP for Cell Broadcast Messages

The test set acts as a server for cell broadcast messages. If you have a PC and your test set connected to a network or directly connected together, you can open a web browser (client) and send a request to the test set using the test set's IP address and a correctly configured request URL. For example, Once the sets set is configured to allow the use of the HTTP interface and cell broadcast service is enabled in the test set, you might send the following from the web browser if your test set's IP address was 111.111.111.112.

NOTE
It is not necessary to specify a port number because the test set uses 80, which is the default port for HTTP.

Setting the message 1 state to ON, starting the cell broadcast service, and sending the above URL causes an cell broadcast message to arrive at the mobile station attached to the test set's RF port. This message contains the text "Hello".

For instructions on how to configure URL messages for the HTTP interface, see HTTP Interface Configuration for Cell Broadcast Service Messages .

Related Topics

Cell Broadcast Service (CBS)


HTTP Interface Configuration for Cell Broadcast Service Messages

HTTP Interface Configuration for Cell Broadcast Service Messages

Last updated: December 3, 2008

This section is only applicable to lab applications and the test application with a required feature license.

Please keep in mind that an HTTP address requires all the components shown in the URL below, and that this section focuses on the request URL portion of the address. See HTTP Overview for more information regarding other components of the HTTP address.

If you wish to use the HTTP interface to configure and send cell broadcast messages to the mobile station attached to the test set's RF port, you must do the following:

  1. Enable the Test Set's HTTP Interface
  2. Enable the Cell Broadcast Service
  3. Configure the Request URL

Enable the Cell Broadcast Service

Once the HTTP interface is enabled (see Enable the Test Set's HTTP Interface ), you can do the following through the HTTP interface:

  • Enable the Cell Broadcast Service

    You can do this by sending an HTTP command to the test set with the following request URL format:

    /cbsms/start

    If the cell broadcast format started successfully, the following message is displayed in your internet browser:

    Cell Broadcast service started OK

  • Disable the Cell Broadcast Service

    You can do this by sending an HTTP command to the test set with the following request URL format:

    /cbsms/stop

    If the cell broadcast format started successfully, the following message is displayed in your internet browser:

    Cell Broadcast service stopped

Configure the Request URL

When using the HTTP interface in the test set for sending cell broadcast messages, you must configure a request URL.

Requests to send cell broadcast messages to the mobile station attached to the test set using the HTTP interface must be configured using the following rules:

  1. The request URL format accepted by the test set is:

    /cbsms/message<n>/?parameter1=value1&parameter2=value2&parameter3=value3......

    NOTE
    "/cbsms/message<n>/?" must be specified at the beginning of the request URL (following the IP address and port number) in order for the test set to recognize the HTTP request as a request to send a cell broadcast message to the mobile station. The <n> represents the message number which must be 1,2, or 3.

    The parameters and values variables provides the content of the cell broadcast message as well as additional information for header configuration and test set configuration. All configurable parameters and values are detailed in Request URL Parameters .

  2. An HTTP error code of 400 (Bad Request) is returned to the client initiating an HTTP request and the message is not forwarded on to the mobile station if any parameter values in the request URL do not adhere to the constraints detailed in Request URL Parameters .
  3. Parameters in the request URL can be in any order.
  4. When a text message is being submitted via the `TEXT' parameter, HTTP URL escaping restrictions apply. Therefore, all space characters must be replaced with the `%20' character sequence. Other characters that require escape characters when used in URLs are detailed in the following table.

    Character to URL Escape Sequence Mapping

  5. Accepted HTPP request methods

    Both POST and GET HTTP requests are accepted by the test set for sending cell broadcast messages.

    If POST is used as the request method, the URL request parameters detailed in Request URL Parameters are not included in the request URL, but are included in the request body instead. Therefore, the request URL in POST requests contains only `cbsms/message<n>' (when <n> must be a 1, 2 or 3).

Request URL Parameters

Parameter Use and expected value Inclusion
CODE Specifies the 10-bit message code element of the cell broadcast message's serial number.Expected value: decimal number in the range 0-1023

Optional (default*= 0)

Including this parameter affects the setting for CALL:SMService:CBRoadcast:MESSage[<n>]:CODE .
DATA Specifies the binary data to be sent in the message.Expected value: 0-2460 length character string of ASCII formatted hexadecimal characters

Optional -This parameter cannot be included in the same request as the TEXT parameter.

Including this parameter affects the settings for CALL:SMService:CBRoadcast:MESSage[<n>]:CONTent and CALL:SMService:CBRoadcast:MESSage[<n>]:CDATa .
DCS Specifies the 8-bit data coding scheme of the cell broadcast message.Expected value: Decimal number in the range 0-255

Optional -This parameter cannot be included in the same request as the DCSHEX parameter. (default*= 1)

Including this parameter affects the settings for CALL:SMService:CBRoadcast:MESSage[<n>]:DCSCheme[:SPECify] and CALL:SMService:CBRoadcast:MESSage[<n>]:DCSCheme:VALue .
DCSHEX Specifies the 8-bit data coding scheme of the cell broadcast message.Expected value: string of hex characters in the range 0 - FF

Optional -This parameter cannot be included in the same request as the DCS parameter. (default*= not used).

Including this parameter affects the settings for CALL:SMService:CBRoadcast:MESSage[<n>]:DCSCheme[:SPECify] and CALL:SMService:CBRoadcast:MESSage[<n>]:DCSCheme:VALue .
GSCOPE Specifies the 2-bit geographical scope element of the cell broadcast message's serial number.Expected value: decimal number in the range 0-3

Optional (default*= 0)

Including this parameter affects the setting for CALL:SMService:CBRoadcast:MESSage[<n>]:GSCope .
ID Specifies the 16-bit message identifier of the cell broadcast message.Expected value: Decimal number in the range 0-65535

Optional -This parameter cannot be included in the same request as the IDHEX parameter. (default*= 0)

Including this parameter affects the setting for CALL:SMService:CBRoadcast:MESSage[<n>]:IDENtifier .
IDHEX Specifies the 16-bit message identifier for the cell broadcast message.Expected value: String of hex characters in the range 0 - FFFF

Optional -This parameter cannot be included in the same request as the ID parameter. (default*= not used)

Including this parameter affects the setting for CALL:SMService:CBRoadcast:MESSage[<n>]:IDENtifier .
REPETITION Specifies the repetition period for the message in seconds. This parameter may be included in HTTP requests to configure any of the individual cell broadcast messages however the associated value is be applied to ALL of the messages regardless of which message the HTTP request was for.Expected value: Decimal number in the range 1 - 1800

Optional -This parameter cannot be included in the same request as the REPUNITS parameter. (default*= 30)

Including this parameter affects the setting for CALL:SMService:CBRoadcast:REPetition[:SEConds] .
REPUNITS Specifies the repetition period for the message in units. The actual repetition period used will be 1.883 seconds multiplied by the value specified. This parameter may be included in HTTP requests to configure any of the individual cell broadcast messages but the associated value shall be applied to ALL of the messages regardless of which one the HTTP request was for.Expected value: Decimal number in the range 1 - 1024

Optional -This parameter cannot be included in the same request as the REPETITION parameter. (default= not used)

Including this parameter affects the setting for CALL:SMService:CBRoadcast:REPetition:UNITs .
STATE Specifies if the message should be transmitted when the cell broadcast service is running.Expected value: Decimal number in the range 0 - 1 where 0=OFF, 1=ON.

Optional (default*: Message 1=ON, Message 2 and 3 = OFF)

Including this parameter affects the setting for CALL:SMService:CBRoadcast:MESSage[<n>]:STATe .
TEXT

Specifies the text to be sent in the message.

Expected Value: 0 to 1395 length character string of 7-bit text characters.

Optional -This parameter cannot be included in the same request as the DATA parameter.

Including this parameter affects the setting for CALL:SMService:CBRoadcast:MESSage[<n>]:CONTent and CALL:SMService:CBRoadcast:MESSage[<n>]:CTEXt .
UPDATE Specifies the 4-bit update number element of the cell broadcast message's serial number.Expected value: Decimal number in the range 0-15

Optional (default*= 0)

Including this parameter affects the setting for CALL:SMService:CBRoadcast:MESSage[<n>]:UPDate .

*This value is the setting for the parameter when the test set is powered on. If a parameter is not included, the setting for the parameter does not revert to the default settings, but retains the current parameter settings.

Example Cell Broadcast Request URL Strings

Example Text Cell Broadcast Request URL

To send a text based cell broadcast message with the following message details:

  • Geographic Scope: Cell Wide/Normal
  • Message Code: 5
  • Update Number: 1
  • Message ID: 2
  • Data Coding Scheme: 1
  • Text: "This is a text message for message one"
  • State: On (message 1)
  • Repetition Period: 10 seconds

you would format the cell broadcast HTTP request URL as follows:

/cbsms/message1/?GEOSCOPE=3&CODE=5&UPDATE=1&ID=2&DCS=1&TEXT=This%20is%20a%20text%20message%20for%20message%20one&REPETITION=10

Example Binary Cell Broadcast Request URL

To send a binary message with the following message details:

  • Geographic Scope: PLMN Wide / Normal Display
  • Message Code: 13
  • Update Number: 1
  • Message ID: 6
  • Data Coding Scheme: 245
  • Data: 014FA553000FF110
  • State: On (message 2) Message 1 is on by default, so it does not need to be included in the above URL.

you would format the cell broadcast message as follows:

/cbsms/message2/?GEOSCOPE=1&CODE=13&UPDATE=1&ID=6&DCS=245&DATA=014FA553000FF110&STATE=1

Subsequent Message Configuration

Messages can be updated over HTTP while the cell broadcast service is enabled and running. For example, if message 1 and message 2 are configured as described in Example Text Cell Broadcast Request URL and Example Binary Cell Broadcast Request URL and you wish to change the contents of the text message sent in message 1 to "This is an updated text message for message one", you would send the following URL:

/cbsms/message1/?TEXT=This%20is%20an%20updated%20text%20message%20for%20message%20one&UPDATE=2

Notice that the update number has changed from 1 to 2 to indicate to the mobile station that the contents of the message have been altered.

If you wish to stop transmitting message 2, you would send the following URL:

/cbsms/message2/?STATE=0

Related Topics

HTTP Interface for Cell Broadcast Service - Introduction


Configurable Timers

Configurable Timers

The Configurable Timers are only applicable to the lab applications.

Description

This is the list of configurable timers with a brief explanation and their default values. You can specify the value of the following timers which are used by the mobile.

Timer Name

Description

Value

Default Value

GPIB command

T3212
Periodic Location Update Timer

Periodic Location Update Timer controls how often the mobile performs the periodic location update procedure.

0 to 255 decihours (1 decihour = 6 minutes)

A value of "0" will disable the periodic location area updating.

0

CALL:PPRocedure:LAU|LAUPdate:T3212

T3312
Periodic Routing Area Update Timer

Periodic Routing Area Update Timer controls how often the mobile performs the periodic routing area update procedure. The value of the Period Routing Area Update Timer is sent to the mobile as part of the "ATTACH ACCEPT" or "ROUTING AREA UPDATE ACCEPT" messages.

Note, the T3312 does not start until the T3314 GMM Ready Timer has expired, so the T3314 must be enabled to start periodic routing area updates.

0 to 11160s1

A value of "0" will disable the periodic routing area updating.

0

CALL:PPRocedure:RAU|RAUPdate:T3312

T301
Call Originate Timer

Call Originate Timer controls the time the test set alerts a mobile station when attempting a mobile terminated call.

0 to 999s

1

CALL:ORIGinate:TIMeout

T308
Call Release Timer

Call Release Timer set the time that the test set waits after sending a "RELEASE" message until receiving a "RELEASE COMPLETE" message.

On the first timeout the 8960 re-transmits the RELEASE, on a second timeout the Mobility Management connection is released and the 8960 reports an error.

1 to 60000ms

1000ms

CALL[:CELL]:T308

T3192
TBF Release Timer

TBF Release Timer is used on the mobile when the mobile station has received all of the RLC data blocks and it waits from release of the TBF after reception of the final block. When the timer expires, the mobile station releases the resources associated with the TBF and begins to monitor its paging channel.

0, 80ms, 120ms, 160ms, 200ms, 500ms, 1000ms, 1500ms.

500ms

CALL[:CELL]:TBFLow:T3192

T3314
GMM Ready Timer

GMM Ready Timer is used to transition GMM layer from "READY" to "STANDBY" state after transmission of the last PDU. In the "STANDBY" state, the mobile only performs Routing Area Updates if necessary, no Cell Updates are performed.

0 to 11160s1, or OFF2

OFF

CALL:PPRocedure:T3314

CALL:PPRocedure:T3314:STATe

1 Rounding Rules: As the size of the layer 3 message field for setting T3312 and T3314 is limited, the rounding rules are applied to the actual value sent to the mobile to provide large range of values. You do not need to consider the rules when setting the timer, however, the rounding rules will affect the WPA decoding results.

  • Values of 0s to 60s will be rounded up to the nearest even number of seconds.
  • Values of 61s to 1860s will be rounded up to the nearest minute.
  • Values of 1861s to 11160s will be rounded up to the nearest decihours (1 decihour = 6 minutes)

2 T3314 also have a value of "OFF" which keeps GMM in READY state and continues cell updates.

Operating Consideration

The Location Update Timer (T3212) and TBF Release Timer (T3192) can only be set when the Cell Operation Mode is "Cell Off".

Related Topics

Fixed Timer Messages


Calling Party Number Parameters

Calling Party Number Parameters

This section is only applicable to the lab application.

The test set allows you to specify the calling party number (CPN) parameters sent to the called mobile station so that you can evaluate the mobile station's behavior in response to the CPN (for example, to see whether the mobile station displays the calling party's number as expected).

When you originate a call from the test set, the calling party number parameter is sent to the called mobile station via the SETUP message. See How Do I Perform Calling Party Number Verification? for the detailed procedure.

When you send the SMS messages, the test set also allows you to enter the originating address. The address setting for messages is different from that for calling party number. See Mobile Terminated SMS (MT SMS)- Sending a Message to the Mobile Station for more information.

Operating Considerations

The Calling Party Number feature is only applicable to Active Cell Operating Modes with Connection Type set to Auto. The feature is only applicable to GSM traffic channel connection.

Parameter Descriptions

The following gives the parameter and value descriptions defined in 3GPP TS 24.008 Section 10.5.4.9.

  • Calling Party Number Inclusion ( CALL:CPNumber:INCLusion ): specifies whether or not the calling party number parameters ( CALL:CPNumber<[:SELected]> , CALL:CPNumber:PLAN , CALL:CPNumber:PRESentation[:INDicator] , CALL:CPNumber:SCReening[:INDicator] and CALL:CPNumber:TYPE ) are sent to the called mobile station. If Exclude is selected, the parameters are not included in the message.
  • Calling Party Number ( CALL:CPNumber<[:SELected]> ): indicates the ASCII representation of each character in the calling party number.
  • Number Type ( CALL:CPNumber:TYPE ): specifies the type of number used for the calling party number.
    Number Type

    Test Set's front panel

    Description

    NUMBER_TYPE Field Value

    Unknown

    Unknown number type

    000

    International

    International number

    001

    National

    National number

    010

    Network

    Network specific number

    011

    Dedicated

    Dedicated PAD access, short code

    100
  • Number Plan ( CALL:CPNumber:PLAN ): specifies the numbering plan used for the calling party number.
    Numbering Plan
    Test Set's front panel Description

    NUMBER_PLAN Field Value

    Unknown

    Unknown numbering plan

    0000

    ISDN/Telephony

    ISDN/Telephony numbering plan

    0001

    Data

    Data numbering plan

    0011

    Telex

    Telex Numbering plan

    0100

    Private

    Private numbering plan

    1001

    National

    National numbering plan

             1000
  • Presentation Indicator ( CALL:CPNumber:PRESentation[:INDicator] ): specifies whether or not to allow the calling party number to be displayed on the called mobile station's screen.
    Presentation Indicator
    Test Set's front panel

    Description

    PI Field Value

    Allowed

    Presentation allowed

    00

    Restricted

    Presentation restricted

    01

    Number Not Avail

    Address not available

    10
  • Screening Indicator ( CALL:CPNumber:SCReening[:INDicator] ): specifies how the calling number is screened.
    Screening Indicator
    Test Set's front panel

    Description

    SI Field Value

    User Not Screen

    User provided, not screened

    00

    User Verify Pass

    User provided, verified passed

    01
    User Verify Fail

    User provided, verified and failed

             10

    Network

    Network provided

    11

Related Topics

How Do I Perform Calling Party Number Verification?


Cell Selection Indicator

Cell Selection Indicator

This section is only applicable to the lab applications.

  • Description
  • Manual Operation
  • Operating Considerations

Description

The Cell Selection Indicator (CSI) parameter specifies whether the optional CSI IE (information element) is present in the Layer 3 Channel Release message, and also if the CSI IE is present which cell information is present within the CSI IE (either GSM or UTRAN FDD). The CSI IE indicates on which frequency/cell the cell selection after channel release will be performed.

For more information about Cell Selection Indicator, please refer to 3GPP TS 44.018 Section 10.5.2.1e.

The actual cell information that is populated in the CSI IE (if present) is taken from the currently configured Neighbor Cell entries. (See Cell Lists for more information about the Neighbor Cells.) The entries used for populating the CSI IE are the first N enabled entries in the appropriate Neighbor Cell list with the following constraints:

  • The maximum number of cells presented in the CSI IE is 2.
  • If the Cell Selection Indicator is currently set to GSM, the BCH GSM Neighbor Cell List shall be used to populate the CSI IE.
    • The enabled entries in the GSM Neighbor Cell List should be the entries with Cell State = ON.
    • If the GSM Neighbor Cell List contains equal or more than 2 enabled entries, the CSI IE should present the cell information of the first two enabled entries in the GSM Neighbor Cell List.
    • If the GSM Neighbor Cell List contains less than 2 enabled entries, the CSI IE should present the cell information of all the enabled entries in the GSM Neighbor Cell List.
  • If the Cell Selection Indicator is currently set to UTRAN (FDD), the 3G FDD Neighbor Cell List shall be used to populate the CSI IE
    • The enabled entries in the UTRAN (FDD) Neighbor Cell List should be the entries with UARFCN State = ON. If one or more Scrambling Codes are enabled for the given UARFCN then they are classed as separate entries in the CSI IE.
    • If the UTRAN (FDD) Neighbor Cell List contains equal or more than 2 enabled entries, the CSI IE should present the cell information of the first two enabled entries in the UTRAN (FDD) Neighbor Cell List.
    • If the UTRAN (FDD) Neighbor Cell List contains less than 2 enabled entries, the CSI IE should present the cell information of all the enabled entries in the UARFCN (FDD) Neighbor Cell List.

    For example if UARFCN 1 and UARFCN 2 are both enabled. UARFCN 1 has 2 enabled Scrambling Codes, then only the 2 entries from UARFCN 1 shall be present in the CSI IE. However if UARFCN 1 had one Scrambling Code (or none) enabled, then the CSI IE shall contain the UARFCN 1 entry and the UARFCN 2 entry.

If the current value of the Cell Selection Indicator parameter is not OFF and the associated neighbor cell list does not contain any enabled entries, then the CSI IE shall not be presented in the Layer 3 Channel Release message.

The GPIB command to set the Cell Selection Indicator parameter is CALL:TCHannel:SIGNaling:DCCHannel:CSINdicator .

Manual Operation

The following procedure details how to set the Cell Selection Indicator.

  1. Press the CALL SETUP screen key.
  2. Press TCH Parameters ( F8 ).
  3. Press the More key until screen 3 of 3 of the TCH Parameters menu is displayed.
  4. Press Call Signaling Parameters ( F7 ) and the Call Signaling Parameters menu appears in the center of the screen.
  5. Use the knob to highlight and set CSI in DCCH Release .

Operating Considerations

The Cell Selection Indicator can be modified in any operating mode, however the values will only be applicable in Active Cell Operating Modes.

In Two-Cell Test System , if the content of the neighbor cell entries presented in the CSI IE within the Layer 3 Channel Release message (which is sent from the test set that the mobile is currently camped to) does not address the current configuration of the other test set, the mobile station will camp to the original cell if it determines this cell as still suitable.

Related Topics

3G FDD Neighbour Cells


Digital Audio Interface (DAI) Description

Digital Audio Interface (DAI) Description

This section is only applicable to the lab applications and the test application with a required feature license.

Digital Audio Interface (DAI) is a special interface to offer a platform that complete the conformance of speech codec test and the SLR/RLR (Sending/Receiving Loudness Rating) performance test of the analogue and acoustic devices. Through DAI, you can insert and extract speech data in both the transmit and receive directions. Note that only the speech coder/decoder test is discussed in this section.

See 3GPP TS 44.014 for more information about Digital Audio Interface information.

  • Digital Audio Interface (DAI) Overview
    • Digital Audio Interface (DAI) test process
  • Digital Audio Interface (DAI) Typical Test System Configuration
    • Digital Audio Interface (DAI) Downlink Test steps
    • Digital Audio Interface (DAI) Uplink Test steps
  • Digital Audio Interface (DAI) Parameters

Digital Audio Interface (DAI) Overview

The following figure shows the location of Digital Audio Interface in the Mobile Station. You can test the codec implementation of the Mobile Station based on a number of digital audio files sending or receiving through the Digital Audio Interface.

The interface provides the data exchange of 13 bit linear PCM at 8000 samples per second. In order to keep the pin count low, the data are transferred on a duplex set of serial lines at 104 kbits/s.

Digital Audio Interface (DAI) test process

DAI test process are displayed as the following steps:

  1. SS (System Simulator) sends a TEST_INTERFACE message by means of the layer 3 message or applies the appropriate test control signal on the DAI to activate a test.
  2. After more than one second, test system applies a reset pulse.
  3. Mobile Station starts test by issuing clock pulse with the release of the reset pulse at the same time.
  4. Uplink speech transcoding/DTX function test: Encode the first speech sample bit at first falling clock edge requests from the SS. The data transmission starts at the next earliest possible interleaved block TDMA frame after the release of the reset pulse.
  5. Downlink speech transcoding/DTX function test: Decode the first speech sample bit at the first falling clock edge requests from the SS. The data transmission starts at the next earliest possible interleaved block TDMA frame after the release of the reset pulse.
  6. By the end of the reset pulse, the Mobile Station transcoder is reset. The DAI is always in one of the active states (Test of speech decoder/DTX function (downlink), Test of speech encoder/DTX function (uplink), Test of acoustic devices and A/D and D/A).

The figure below shows the timing of the Digital Audio Interface:

Digital Audio Interface (DAI) Typical Test System Configuration

The following diagram shows a typical Digital Audio Interface test system configuration.

The Digital Audio Interface (DAI) typical test system is made up of Custom Test Station, GSM Mobile Station, 8960 Test set. The Customer Test Station connects with the Test Set via the GP-IB Interface and http Interface with Host Lan Cable. The Customer Test Station connects with the Mobile Station via Digital Audio Interface with suitable LAN Cable. The Test set connects with the Mobile Station via RF Interface.

The Customer Test Station acts as the control center of the DAI test system. The Customer Test Station can download/upload digital audio file into the test set using the 8960 DAI File Manager software, start the DAI Test, command the test set to start/stop playing or recording the digital audio files, and query the play or record status of the digital audio file by sending GPIB command to the test set.

The Customer Test Station or Controller releases reset pulse to command the Mobile Station to start test by issuing clock pulses when data transfer. The DAI doesn't have access to send the reset pulse.

The figure below shows the detailed view of the Digital Audio Interface test path. The test file is associate with codecs which can be Full Rate Speech (FS), Enhanced Full Rate Speech (EFS) and Half Rate Speech (HS), Adaptive Full Rate Speech (AFS), Adaptive Half Rate Speech (AHS) and Wideband Adaptive Full Rate Speech (WFS).

You can Test the Speech Decoder by performing the Digital Audio Interface (DAI) Downlink Test steps and the Speech Encoder by performing the Digital Audio Interface (DAI) Uplink Test steps .

Digital Audio Interface (DAI) Downlink Test steps

DAI Downlink Test is used to test the performance of the Speech Decoder in the Mobile Station. To perform a downlink test, You should follow the following steps:

  1. Select which Logical Speech Channel is to be tested in the test set.
  2. Customer test station upload the COD/DEC reference file into the test set via the HTTP interface, indicating which codec it applies to. An error message is displayed if the parse checking failed on the COD reference file.
  3. Starts a voice call between the test set and the DUT (either Mobile Originated or Mobile Terminated).
  4. Set the DAI Test Interface to `Speech Decoder' in the test set, this action will result in the Layer 3 Test_Interface message being sent to DUT over the air interface. However, for the mobile stations which do not respond to the layer 3 Test_Interface message, Customer test station should send the test control signal through the DAI to notify the DUT to enter the Speech Decoder test mode.
  5. Customer test station applies reset pulse to DUT.
  6. Customer test station starts recording the OUT file from the Mobile Station.
  7. The test set starts playing the COD/DEC reference file which has been uploaded to it.
  8. Customer Test Station requests interrupt from the test set until the COD/DEC reference file playing complete.
  9. Customer test station stops recording the OUT files from Mobile station and processes results.
  10. Set the DAI Test Interface to `Off' in the test set and stop the voice call connection.

See How to play the Digital Audio Interface (DAI) File for instructions on how to play the COD/DEC file and upload the digital audio file via the test set.

See Programming a Downlink DAI Test for instructions on how to program a automatic DAI Downlink Test.

Digital Audio Interface (DAI) Uplink Test steps

DAI Uplink Test is used to test the performance of the Speech Encoder in the Mobile Station.To perform a uplink test, You should follow the following steps:

  1. Select which Logical Speech Channel is to be tested in the test set.
  2. Starts a voice call between the test set and the DUT (either Mobile Originated or Mobile Terminated).
  3. Set the DAI Test Interface to `Speech Encoder' in the test set, this action will result in the Layer 3 Test_Interface message being sent to DUT over the air interface. However, for the mobile stations which do not respond to the layer 3 Test_Interface message, Customer test station should send the test control signal through the DAI to notify the DUT to enter the Speech Encoder test mode.
  4. Customer test station applies reset pulse to DUT.
  5. The test set to start recording the COD file it received from the DUT.
  6. Customer test station start playing the INP file to the Mobile Station.
  7. The test set stop COD file recording.
  8. Customer test station download the COD file from the test set via HTTP interface.
  9. Set the DAI Test Interface to OFF and stop the call connection.

See How to record the Digital Audio Interface (DAI) File for instructions on how to record the COD/DEC file and download the digital audio file via the test set.

See Programming a Uplink DAI Test for instructions on how to program a automatic DAI Uplink Test.

Impact on Other Measurements

The following measurements shall be shut down for the duration of the play/record operation.

  1. GSM Bit Error
  2. GSM Fast Bit Error
  3. AMR In-band Frame Error

Digital Audio Interface (DAI) Parameters

  • DAI Test Interface

    This parameter allows you to select which component in the mobile station is to be tested (Speech Encoder, Speech Decoder, or Acoustic), or just command the mobile station to work in normal state by setting the DAI to `Off'. The DAI Test Interface setting is stateless. Selecting the DAI Test Interface will result in the Layer 3 Test_Interface command being sent to the MS.

    If an attempt is made to select Speech Decoder, Speech Encoder or Acoustic while the Operating Mode is not active cell an error message is generated: " Cell operation rejected; Protocol request ignored ."

    The GPIB command to set this parameter is CALL:TCHannel:DAINterface:TINTerface .

  • Start COD Play

    This parameter is used to start playing the COD/DEC reference file in the test set.

    The following conditions are checked if you attempt to start playing a COD/DEC file. If one of these conditions is not met, an error message is generated:

    • COD/DEC reference file has been downloaded successfully.
    • COD/DEC reference file matches the currently set 'Logical Speech Channel'.
    • If 'logical Speech Channel' is AMR' then the COD/DEC file refers to only those AMR codec rates specified in the codec set and all codec rate changes are on odd or even frames. See Adaptive Multi-Rate (AMR) Feature Descriptions for more information.
    • Voice call is in progress.

    The GPIB command to set this parameter is CALL:DAINterface:PLAY:STARt .

  • Stop COD Play

    This parameter is used to stop playing the COD/DEC reference file in the test set.

    The GPIB command to set this parameter is CALL:DAINterface:PLAY:STOP .

  • Playing StatusThis parameter queries the Playing Status of the COD/DEC reference file.

    The GPIB command to set this parameter is CALL:DAINterface:PLAY:STATus .

  • Start COD Record

    This parameter is used to start recording the COD file in the test set.

    The following conditions are checked if you attempt to start recording a COD/DEC file. If one of these conditions is not met, an error message is generated:

    • The test set is capable of recording for the specified Logical Speech Channel.
    • Voice call is in progress.

    In addition to the above conditions, an error message is generated on the following conditions:

    • The record COD file reaches its 2 MByte limit.
    • The voice call end for any reason during recording and the recording terminate immediately.

    The GPIB command to set this parameter is CALL:DAINterface:RECord:STARt .

  • Stop COD Record

    This parameter is used to stop recording the COD file in the test set.

    The GPIB command to set this parameter is CALL:DAINterface:RECord:STOP .

  • Recording Status

    This parameter queries the Recording Status of the COD file.

    The GPIB command to set this parameter is CALL:DAINterface:RECord:STATus .

  • Playing / Recording Progress

    The Playing Progress indicates how far through playing the uploaded COD/DEC reference file the test set is.

    The Recording Progress indicates how far through the maximum possible capture COD file the test set is.

    The Playing / Recording Progress indicators are displayed on the front panel and updated frequently.

Operating Considerations

The Digital Audio Interface test is only available in active cell operating mode. If the 'Operating Mode' is changed to anything other than 'Active Cell', any active playing or recording of COD/DEC files is stopped.

On either full or partial preset the following actions are taken

  • any uploaded COD/DEC file is removed.
  • any recorded (or partially recorded) COD file is removed.
  • playing or recording is stopped
  • play and record indicators go to `idle', and Progress and Record Buffer Usage indicators go to `0%'.

The DAI Test also applies to the Dual Transfer Mode, You can perform the test on the voice call portion of the DTM connection.

Related Topics

Logging Digital Audio Interface (DAI) Messages

How to use the Digital Audio Interface Features

Programming a Digital Audio Interface (DAI) Test

CALL:DAINterface

CALL:TCHannel

STATus:OPERation


Logging Digital Audio Interface (DAI) Messages

Logging Digital Audio Interface (DAI) Messages

This section is only applicable to the lab applications.

You can use the Wireless Protocol Advisor (WPA) to observe and analyze messages and information related to Digital Audio Interface.

WPA help is accessible from WPA by clicking the help button or for download at: http://www.agilent.com/find/e6584a

Follow the procedure below for setting up the DAI logging test:

  1. Starts the WPA
  2. Starts a voice call
  3. Starts the WPA logging
  4. Set the DAI test interface to Speech Decoder
  5. Set the DAI test interface to Encoder
  6. Set the DAI test interface to Acoustic
  7. Set the DAI test interface to Off.

See How to use the Digital Audio Interface Features for instructions on how to execute each step. You will see the following protocol log after you finish it.

The captured log allows you to determine exactly what is being exchanged between the test set and the mobile station. In this example, an Test_Interface message was sent from the test set to the mobile station four times. You can look in the decode of the captured message to verify all the parameters associated with that message. For more information about the Test_Interface message, see 3GPP TS 44.014, Section 8.11.

Related Topics

Digital Audio Interface (DAI) Description


Demodulation Trigger Delay

Demodulation Trigger Delay

You can specify a delay of up to 200 symbols for uplink channel demodulation to compensate for any delay introduced on the test set's downlink channel by an external source. A time delay might be introduced to simulate a physical distance between the MS and the test set while performing E-OTD tests (see E-OTD (Enhanced Observed Time Difference) for more information). If the downlink delay were too great, the connection between the MS and the test set might be lost.

Operating Considerations

Configuring the Demodulation Trigger Delay

The demodulation trigger delay is configured via GPIB only. See CALL:DEModulation for more information.

Operating Mode

You can set the value of the trigger delay in any operating mode.

The demodulation trigger delay is only usable in the following operating modes:

  • Active Cell
  • GSM BCH
  • GPRS BCH
  • GSM BCH + TCH
  • GPRS BCH + PDTCH

Related Topics

CALL:DEModulation


Discontinuous Transmission

Discontinuous Transmission

This section is only applicable to the lab applications.

Discontinuous Transmission (DTX) is used to reduce the transmission rate during inactive speech periods while maintaining an acceptable level of output quality. When a pause is detected during a voice call, The radio transmissions for the duration of the pause are discontinued or suspended.

The DTX option tends to reduce interference in adjacent cells and to mobile stations close to the base station. Since transmit time is reduced when DTX is used, the power consumption of hand-held terminals is reduced, which gives users the option of fitting their terminals with smaller batteries. Pauses in normal speech occur at a rate that makes speech appear to have about a 50% duty cycle. This means that a TCH channel is only used for speech transmission about half the time a speaker is using the phone.

The possibility of invoking DTX functions have extended the original speech codec specifications to include two additional function modules: Voice Activity Detection (VAD) and Comfortable Noise Generator (CNG), VAD classifies the input signal into active speech, inactive speech or background noise. Based on the VAD decisions, DTX inserts Silence Insertion Descriptor (SID) frames during the silence intervals. During silence, SID's are periodically sent to the CNG module, which generates ambient noise during periods of inactive speech on the receive side.

When DTX is employed on a TCH, not all TDMA frames may be transmitted. However, the following subset shall always be transmitted, except for TCH/AFS, TCH/WFS, O-TCH/WFS, TCH/AHS, O-TCH/AHS and O-TCH/WHS, and hence can be employed to assess quality and signal level during DTX.

TDMA frame subset for DTX
Type of Channel | TDMA frame subset always to be transmitted TDMA frame number (FN) modulo 104
TCH/F | 52,53,54,55,56,57,58,59
TCH/HS, subchannel 0 | 0,2,4,6,52,54,56,58
TCH/HS, subchannel 1 | 14,16,18,20,66,68,70,72
TCH/H, data, subchannel 0, uplink | 52,54,56,58,60,62,65,67,69,71
TCH/H, data, subchannel 0, downlink | 56,58,60,62,65,67,69,71,73,75
TCH/H, data, subchannel 1, uplink | 70, 72, 74, 76, 79, 81, 83, 85, 87, 89
TCH/H, data, subchannel 1, downlink | 66, 68, 70, 72, 74, 76, 79, 81, 83, 85

This subset of TDMA frames is always used for transmission during DTX. For speech TCH, when no signalling or speech is to be transmitted these TDMA frames are occupied by the SID (Silence Descriptor) frame, see 3GPP TS 46.012 and 3GPP TS 46.031 for detailed specification of the SID frame and its transmission requirements.

DTX function can be enabling in both uplink and downlink directions in the test set.

Enabling Mobile DTX

You can command a DTX capable MS to enable uplink discontinuous transmission by setting the Mobile DTX State parameter. The following procedure details how to set the Mobile DTX.

  1. Press the CALL SETUP screen key.
  2. Press Cell Info ( F6 )
  3. Press Cell Operation ( F1 ) and the Cell Operation menu appears in the center of the screen.
  4. Use the knob to highlight and set Mobile DTX state to ON.

Enabling Downlink DTX

There are four ways to enable the downlink DTX.

  • Set the Speech Source to SID . the test set will only send the AMR-SID frames or the SID frames in the TDMA frame subset listed in TDMA frame subset for DTX table and turn its power off in all the other TDMA frames.
  • Enable the Mobile DTX (See Enabling Mobile DTX ), set the Downlink DTX State to ON, set the Speech Source to echo. In this way, you can acquire a downlink DTX transmission with voice and SID frames. The following procedure details how to set the Downlink DTX State.
    1. Press the CALL SETUP screen key.
    2. Press Cell Info ( F6 )
    3. Press Cell Operation ( F1 ) and the Cell Operation menu appears in the center of the screen.
    4. Use the knob to highlight and set Downlink DTX State to ON.

    Note, if you enable the Mobile DTX and set the Speech Source to echo, but without setting the Downlink DTX State to ON, for non-AMR codecs, the test set will transmit the Layer 2 fill frame as a FACCH in all the downlink TDMA frames allocated to the user; for AMR codec, SID-Fill frames will be transmitted.

  • Upload a DAI file with DTX information in it to the test set, then playback the DAI file to the MS. In this way you can also acquire a downlink DTX transmission with voice and SID frames. See Digital Audio Interface (DAI) Description .
  • Use the Real-Time Vocoder with Voice Activity Detection enabled.

Impact on Other Measurements

The Downlink DTX State is ignored when the Bad Frame Indication measurement is running. See GSM Bad Frame Indication (BFI) Measurement Description for more information

Operating Considerations

During the discontinuous transmission, the SACCH measurement report will be based on the AMR-SID frames for AMR codec, or the TDMA frame subset which contains the SID frames for non-AMR codecs.

Related Topics

Digital Audio Interface (DAI) Description


E-OTD (Enhanced Observed Time Difference)

E-OTD (Enhanced Observed Time Difference)

Last updated: December 3, 2008

This section is only applicable to the lab applications.

Description

The test set provides testing for the E-OTD (Enhanced Observed Time Difference) provision of the location services (LCS) capability described in 3GPP TS 03.71 . The test set can be used as the serving cell in an E-OTD test system. It can perform the main location services interactions such as issuing location requests to the MS and receiving location estimates or measurement results in response. The E-OTD solution in the test set allows you to test both MS-based or MS-assisted E-OTD.

E-OTD Solution Features

The E-OTD solution in the test set includes:

  • Neighbour Cell Synchronization Trigger


Enhanced Power Control

Enhanced Power Control

This section is only applicable to the lab applications.

By sending the number of power steps by which the mobile is to change (in the range -2 to +4) on EPCCH rather than the destination power level that is sent in the SACCH L1 header, the Enhanced Power Control (EPC) allows the network to change the power level on the uplink more quickly than the Normal Power Control method.

The EPCCH (Enhanced Power Control Channel) has been added to carry the magnitude of the power step commanded to the mobile on downlink. This is sent on a modified SACCH that called SACCH/TP. The SACCH/TP is encoded with a convolutional encoder that different than the normal SACCH and the parity bits attached to the SACCH/TP have been reduced from 40 to 18 which leaves 40 bits spare across 4 bursts. These 10 bits per burst, together with the normal 2 'stealing' bits per burst are replaced by the EPCCH whose 3-bit value is encoded as 12 bits in each burst.

EPC Configurable Parameters

  • EPC Mode

    This parametr directly maps to the EPC_mode field of the assignment message when establishing a channel. If the EPC Mode is set to ON then the channel will be established with EPC capability. If EPC mode is changed while channels are active the test set sends an ASSIGNMENT COMMAND to change the existing channel to the new EPC Mode.

  • EPC Continuous

    This parameter is only applicable when the EPC Mode is set to ON . It controls whether EPC signaling is used continuously or only when a change is required. If this parameter is set to ON then all SACCH L1 Headers sent on the channel have EPC enabled and the EPC step change is set to the value `no change' until a new power level is set. If "EPC Continuous" is OFF then any ordered power level change on a channel will cause the test set to execute the following sequence:

    • The EPC will be enabled in the next SACCH L1 header.
    • An EPCCH ordering a step change towards the ordered power level will be sent at the next opportunity.
    • If more EPCCHs are required they will continue to be sent until the ordered power level is reached.
    • When all required EPCCHs have been sent to reach the power level, the remaining EPCCHs in the SACCH block will be sent with the `no change' value.
    • The EPC will be disabled in the subsequent SACCH L1 headers.

  • EPC Maximum Step Size

    This parameter is only applicable when the EPC Mode is set to ON . It allows you to control the number and magnitude of steps taken to reach the destination power. The range of the change possible in the standard is from a decrease in power by 2 power levels to an increase by 4 power control levels, in steps of 1 power level. The EPC Maximum Step Size setting allows this range to be reduced. The magnitude of EPCCHs step change is always within the range of both the standard and the EPC Maximum Step Size. When a power change is ordered the test set sends EPCCHs using the greatest magnitude of step size possible, consistent with the above. This will be continued until an EPCCH of lower magnitude can be used to complete the power change. The below table shows examples of the power level step sequencing.

    EPC Maximum Step Size

    Power Level Step Sequence on EPCCH
    for power increase of 11 power levels

    Power Level Step Sequence on EPCCH
    for power decrease of 5 power levels

    4

    4,4,3

    -2,-2,-1

    3

    3,3,3,2

    -2,-2,-1

    2

    2,2,2,2,2,1

    -2,-2,-1

    1

    1,1,1,1,1,1,1,1,1,1,1

    -1,-1,-1,-1,-1

Operating Considerations

The EPC can only be used when the test set is configured to use the ASSIGNMENT COMMAND on the SDCCH. This means it is only available for TCH and the "Call Signalling Assignment Channel" must be set to SDCCH.

If FACCH signalling is ON then EPC Mode can not be set to ON and will be greyed out on the MUI. Similarly if EPC Mode is ON FACCH signalling will be greyed out. When FACCH signalling is ON , using RUI command to set the EPC Mode will reture error "Setting conflict" and vice versa.

Related Topics

Cell Operation


Equivalent PLMN List

Equivalent PLMN List

This section is only applicable to the lab application.

The test set allows you to set a list of equivalent PLMNs that will be sent in the LOCATION UPDATING ACCEPT, ATTACH ACCEPT or ROUTING AREA UPDATE ACCEPT message. Each of the items in the list contains a PLMN code (MCC plus MNC). The mobile station store the list at the end of each location update procedure. If no list is contained in the LOCATION UPDATING ACCEPT, ATTACH ACCEPT or ROUTING AREA UPDATE ACCEPT message, the stored list in the mobile station is deleted.

See 3GPP TS 24.008 for more information about Equivalent PLMN List information.

How Do I Configure the Equivalent PLMN List parameter?

This procedure describes how you manually configure the Equivalent PLMN List parameters.

  1. Press CALL SETUP .
  2. Press the left More key until screen 2 of 3 of the Control menu is displayed.
  3. Press Protocol Control ( F4 ).
  4. Press GMM/MM ( F4 ).
  5. Press the left More key until screen 2 of 2 is displayed.
  6. Press Equivalent PLMN List ( F4 ). This displays the Equivalent PLMN List menu.
  7. Use the knob to highlight the parameter and to change the parameter setting.

Operating Considerations

The Equivalent PLMN List are only available when the operating mode is set to Active Cell .

If the Operating Mode is changed to anything other than Active Cell, the Equivalent PLMN List can still be set but it will have no effect on the message content.

The list of the equivalent PLMNs can not be set discontinuously.

Related Topics

Protocol Control


Packet Paging

Packet Paging

The network initiates a packet transfer to an MS that is in the Standby state by sending one or more packet paging request messages on the downlink PPCH or PCH. The MS then responds to one packet paging request message by initiating a mobile originated packet transfer. This mobile originated packet transfer allows the MS to send a packet paging response to the network. The packet paging response is one or more RLC/MAC data blocks containing an arbitrary LLC frame. After the packet paging response is sent by the MS and received by the network, the mobility management state of the MS is Ready.

Initiate a Packet Paging Procedure

To initiate a packet paging in the test set, be sure the following requirements are met:

  • the GMM Ready Timer (T3314) is set to a non-zero value. (See Fixed Timer Messages for information about T3313.)
  • The MS is in the Attached or PDP Active state

When the GMM Ready Timer expires, any incoming data that is intend for the mobile device will result in a Packet Paging message being sent to determine the mobile's location. The paging request message will be transmitted on the appropriate paging subchannel on the PCH or PPCH.

When the test set starts a Packet Paging, it starts timer T3313. It will stop timer T3313 when a response is received from the MS. When the timer T3313 expires the network may re-initiate Packet Paging. See Configurable Timers for information about T3314

Related Topics

Fixed Timer Messages


GSM Circuit Switched Data (CSD)

GSM Circuit Switched Data (CSD)

Last updated: December 3, 2008

This section is only applicable to the lab applications.

This section discusses the GSM Circuit Switched (CSD) feature in the test set.

  • GSM CSD Capability in the Test Set
  • Bit Rate and Mode Negotiation
  • Operating Considerations

GSM CSD Capability in the Test Set

The circuit switched data (CSD) channel capability in the test set allows you to simulate a real-time GSM data transfer between your mobile station and a full network. The test set supports:

  • establishing a mobile originated circuit switched data call,
  • various bit rate, mode, and channel type combinations (See CSD Configurations .),
  • IP datagrams routing to and from the mobile station through the test set's LAN interface,
  • and terminating the PPP connection.

After establishing a CSD connection, the connection operates in full-duplex. IP datagrams originating from either the mobile station or the "network" may be transferred over this link.

The RF link is maintained even when there is no data being sent or received and is only terminated when you end the call from either the test set, mobile station, or from an attached PC. The only exception occurs if the test set determines that an error condition has been met. If this occurs, the test set drops the call.

For the duration of the CSD connection, the connection status displays "Connected + Data". For the location of the connection status on the front panel display, see Instrument Status Area .

NOTE
Only Mobile Originated CSD calls are currently supported.

Bit Rate and Mode Negotiation

Various modes and bit rates can be used in CSD connections. There are two possible modes:

  • Transparent - The raw rate-adapted bits from the over-the-air (OTA) frame are passed to PPP directly. A connection using transparent mode does not provide for re-transmissions and has no error detection mechanism beyond the CRC at Layer 1.
  • Non-Transparent - This mode uses the Radio Link Protocol (RLP) stack layer to provide a reliable transport mechanism. The RLP layer provides for the retransmission of corrupted data and uses a Frame Check Sequence (FCS) for error detection.

Bit rates can be 2400, 4800, 9600 or 14400 bps. The following table illustrates the possible configurations and the support provided by the test set.

CSD Configurations
Speed (bps) | Mode | Channel Type | Test Set Support
14400 | Transparent and Non-Transparent | Full Rate | No
9600 | Transparent and Non-Transparent | Full Rate | Yes
4800 | Transparent and Non-Transparent | Full Rate | Yes
4800 | Transparent and Non-Transparent | Half Rate | No
2400 | Transparent | Full Rate | Yes
2400 | Transparent | Half Rate | No

The test set provides the mode and bit rate requested by the mobile station, if they are supported. When the mobile station's request is not supported, a warning is generated and the call is dropped.

The test set does not have any control over the mode or bit rate requested by the mobile station. Control for this in the mobile station differs between manufacturers. Possible control methods include configuration options available via the mobile station's user interface or by establishing a dial-up connection with the mobile station and using your PC to send it AT commands. Refer to GSM 7.01 for more information.

Operating Considerations

Operating Mode

The Operating Mode must be set to Active Cell to use the CSD capability in the test set.

Connection Type

The Connection Type must be set to Auto to use the CSD capability in the test set.

NOTE
If the connection type is changed while a GSM CSD call is established, the call is dropped by the test set.

Measurements

You can make Bit Error Rate(BER) or Fast Bit Error Rate (FBER) measurements during CSD connections. See GSM Bit Error Measurement for more information.

It may be possible for you to make all the GSM transmitter measurements. If your phone goes into DTX mode and stops transmitting, it is not possible to make GSM transmitter measurements.

Related Topics

Ping


Network Identity and Time Zone

Network Identity and Time Zone

This section is only applicable to the lab applications.

The test set provide Network Identity and Time Zone (NITZ) information in the MM and GMM Information messages such that the mobile can store and use the information. The NITZ information including universal time (UT), daylight saving time (DST), and local time zone (LTZ).

See 3GPP TS 24.008 V7.2.0 for more information about MM and GMM Information messages.

NITZ Configurable Parameters

The test set sends the NITZ information in each of the following conditions:

  • GPRS registration (GPRS Attach and Routing Area Update)
  • GPRS PDP activation and Point-to-Point SMS over GPRS
  • GSM registration (IMSI Attach and Location Updating)
  • GSM call origination (voice, emergency call and CSD) and Point-to-Point SMS over GSM
  • At any time `NITZ Send Immediate' initiated in valid data connection type and connection states.

You can configure the NITZ parameters in the test set to control in which conditions the NITZ information is sent. The following table lists all the NITZ parameters that are configurable in the test set.

Parameter | GPIB Command
NITZ Universal Time-Date | CALL[:CELL]:NITZone:UTIMe:DATE[:SELected]
NITZ Universal Time-Time | CALL[:CELL]:NITZone:UTIMe:TIME[:SELected]
NITZ Local Time Zone | CALL[:CELL]:NITZone:TZONe[:LOCal][:SELected]
NITZ Daylight Saving Time Coupled | CALL[:CELL]:NITZone:DSTime[:HOURs][:SVALue][:SELected]
NITZ Daylight Saving Time Value | CALL[:CELL]:NITZone:DSTime[:HOURs]:VALue[:SELected]
NITZ Daylight Saving Time State | CALL[:CELL]:NITZone:DSTime[:HOURs]:STATe[:SELected]
NITZ Send on GPRS Registration | CALL[:CELL]:NITZone:SEND:GMM:REGistration[:STATe][:SELected]
NITZ Send on GPRS Call Origination | CALL[:CELL]:NITZone:SEND:DATA:ORIGination[:STATe][:SELected]
NITZ Send on GSM Registration | CALL[:CELL]:NITZone:SEND:MM:REGistration[:STATe][:SELected]
NITZ Send on GSM Call Origination | CALL[:CELL]:NITZone:SEND:VOICe:ORIGination[:STATe][:SELected]
NITZ Transportation in DTM | CALL[:CELL]:NITZone:SEND:TRANsport[:SELected]
NITZ Send Immediate | CALL[:CELL]:NITZone:SEND[:IMMediate]
Set NITZ Universal Time/Date to UniversalCoordinated Time/Date | CALL[:CELL]:NITZone:UTIMe:UTC[:IMMediate]

How Do I Set up and Use the NITZ Feature?

The following procedure details how to access and use the NITZ feature.

  1. Press the CALL SETUP key.
  2. Press the More key on the lower left corner to display the Control parms (3 of 4).
  3. Press NITZ ( F6 ) key.
  4. Press NITZ Setup ( F1 ) on the NITZ parms, Use the knob to highlight the parameter and change the value.

Operating Considerations

The NITZ functionality is only available in the Active Cell operating mode.

NOTE
When the NITZ information is sent via the MM and GMM Information messages, the `Universal time and local time zone' IE is always included. The `Network Daylight Saving Time' IE is only included when the `NITZ Daylight Saving Time Include State' parameter is set to ON .

Related Topics

CALL:NITZone


Packet Broadcast Control Channel (PBCCH)

Packet Broadcast Control Channel (PBCCH)

Last updated: December 3, 2008

This section is only applicable to the lab applications.

Packet Broadcast Control Channel (PBCCH) is transmitted in all operating modes except CW and Cell Off when the PBCCH is enabled. When available, the PBCCH is the channel that is used by the mobile station, in place of the BCCH, for control information and signaling related to packet services.

PBCCH can only be enabled/disabled when operating mode is Cell Off.

When the PBCCH is activated, PSI1, PSI2, PSI13, PSI3bis, and PSI13qtr are transmitted on the new channel. When the PBCCH is on, it is generated in Timeslot 1 on the same ARFCN as the BCCH. The Neighbour Cell parameters are also transmitted on the PBCCH when it is activated (see Configuring the PBCCH BA Table ).

Once activated, the PBCCH may be used by the mobile station, in place of the BCCH, to Attach to the test set. You can see requests by the mobile station to Attach by observing the PRACH count indicator.

PRACH Length

You can configure the PRACH length to be either 8 bits or 11 bits to test the mobile station's ability to properly encode the PRACH. The procedure to change the PRACH Length is included with the procedure to change the state of the PBCCH below.

PBCCH

This procedure describes how to change the state of the PBCCH.

  1. Press the Call Setup key to go to the Call Setup screen.
  2. Press the Operating Mode softkey ( F1 ) and select Cell Off .
  3. Press the Cell Info softkey ( F6 ).
  4. Press the Cell Operation softkey ( F1 ) to open the Cell Operation menu.
  5. Set PBCCH to On .
  6. Set PRACH to 8 or 11 bits as desired.
  7. Press the Return softkey ( F6 ) to go back to the Call Setup screen.
  8. Press the Operating Mode softkey ( F1 ) and select Active Cell .

To verify that the PBCCH is on, switch on the mobile station and verify that a PRACH is received during the attach procedure. The PRACH counter is on the Call Setup screen.

Related Topics

CALL:(PBCCH|PBCChannel)


Protocol Layers and Messages

Protocol Layers and Messages

This section is only applicable to the lab applications.

This section outlines in a very general sense, the test set's support for individual protocol layers, the procedures associated with them, and their respective messages. Messages not included here may be supported. Certain parameters of messages included here may not be supported.

Observation Point 1 - LAPDm Over-the-Air Messages

The Link Access Procedure on the Dm channel (LAPDm) is the protocol for use by the data link layer on the radio interface. The frame structure and procedures for proper operation of the LAPDm are described in GSM 04.06.

Operating Considerations

This observation point is not enabled by default. If you want to capture LAPDm messages using the WPA, you should enable LAPDm in the Test Set Message Filter Settings.

Observation Point 2- RLC/MAC Over-the-Air Messages

This layer contains two functions: The Radio Link Control function provides a radio-solution-dependent reliable link. The Medium Access Control function controls the access signaling (request and grant) procedures for the radio channel, and the mapping of LLC frames onto the GSM physical channel. RLC/MAC is defined in GSM 04.60 for functions operating on the Packet Data Channel (PDCH), and in GSM 04.08 for functions operating on the CCCH (Common Control Channel).

Messages

Uplink TBF establishment messages
Message | Reference | Supported
Packet Access Reject | 04.60/11.2.1 | Yes
Packet Channel Request | 04.60/11.2.5 | No
EGPRS Packet Channel Request | 04.60/11.2.5a | No
Packet Queuing Notification | 04.60/11.2.15 | No
Packet Resource Request | 04.60/11.2.16 | Yes
Packet Uplink Assignment | 04.60/11.2.29 | Yes
Additional MS Radio Access Capabilities | 04.60/11.2.32 | Yes
Downlink TBF establishment messages
Message | Reference | Supported
Packet Downlink Assignment | 04.60/11.2.7 | Yes
TBF release messages
Message | Reference | Supported
Packet TBF Release | 04.60/11.2.26 | Yes
Packet Paging messages
Message | Reference | Supported
Packet Paging Request | 04.60/11.2.10 | Yes
RLC messages
Message | Reference | Supported
Packet Downlink Ack/Nack | 04.60/11.2.6 | Yes
EGPRS Packet Downlink Ack/Nack | 04.60/11.2.6a | Yes
Packet Uplink Ack/Nack | 04.60/11.2.28 | Yes
Miscellaneous messages
Message | Reference | Supported
Packet Control Acknowledgment | 04.60/11.2.2 | Yes
Packet Cell Change Failure | 04.60/11.2.3 | No
Packet Cell Change Order | 04.60/11.2.4 | Yes
Packet Downlink Dummy Control Block | 04.60/11.2.8 | Yes
Packet Uplink Dummy Control Block | 04.60/11.2.8b | Yes
Packet Measurement Report | 04.60/11.2.9 | Yes
Packet Measurement Order | 04.60/11.2.9b | No
Packet Mobile TBF Status | 04.60/11.2.9c | Yes
Packet Enhanced Measurement Report | 04.60/11.2.9d | Yes
Packet PDCH Release | 04.60/11.2.11 | No
Packet Polling Request | 04.60/11.2.12 | Yes
Packet Power Control/Timing Advance | 04.60/11.2.13 | Yes
Packet PRACH Parameters | 04.60/11.2.14 | No
Packet PSI Status | 04.60/11.2.17 | Yes
Packet Timeslot Reconfigure | 04.60/11.2.31 | Yes

Procedures

Radio Control Link Procedures

  • Incremental Redundancy
  • Retransmission MCS Switching

Medium Access Control Procedures

  • PBCCH
  • Medium Access Mode
  • Packet Paging

Observation Point 3 - LLC Over-the-Air Messages

Logical Link Control (LLC): LLC was designed to be independent of the underlying radio interface protocols in order to allow introduction of alternative GPRS radio solutions with minimum changes to the NSS (Network Subsystem). The procedures for the LLC layer are described in GSM 04.64.

Observation Point 4 -GMM/SM Over-the-Air Messages

GPRS Mobility Management and Session Management (GMM/SM): This protocol supports mobility management functionality such as GPRS attach, GPRS detach (also applicable to the test application), security, routing area update, location update, PDP context activation, and PDP context deactivation. GMM/SM is defined in GSM 04.08

GMM Messages

Message | Reference | Supported
Attach Request | 9.4.1 | Yes
Attach Accept | 9.4.2 | Yes
Attach Complete | 9.4.3 | Yes
Attach Reject | 9.4.4 | Yes
Detach Request | 9.4.5 | Yes
Detach Accept | 9.4.6 | Yes
P-TMSI Reallocation Command | 9.4.7 | No
P-TMSI Reallocation Complete | 9.4.8 | No
Authentication and Ciphering Request | 9.4.9 | No
Authentication and Ciphering Response | 9.4.10 | No
Authentication and Ciphering Reject | 9.4.11 | No
Identity Request | 9.4.12 | Yes
Identity Response | 9.4.13 | Yes
Routing Area Update Request | 9.4.14 | Yes
Routing Area Update Accept | 9.4.15 | Yes
Routing Area Update Complete | 9.4.16 | Yes
Routing Area Update Reject | 9.4.17 | No
GMM Status | 9.4.18 | No
GMM Information | 9.4.19 | Yes

SM Messages

Messages | Reference | Supported
Activate PDP Context Request | 9.5.1 | Yes
Activate PDP Context Accept | 9.5.2 | Yes
Activate PDP Context Reject | 9.5.3 | Yes
Request PDP context Activation | 9.5.4 | Yes
Request PDP context Activation Reject | 9.5.5 | No
Modify PDP context Request | 9.5.6 | No
Modify PDP context Accept | 9.5.7 | No
Deactivate PDP context Request | 9.5.8 | Yes
Deactivate PDP context Accept | 9.5.9 | Yes
Activate AA PDP context Request | 9.5.10 | No
Activate AA PDP context Accept | 9.5.11 | No
Activate AA PDP context Reject | 9.5.12 | No
Deactivate AA PDP context Request | 9.5.13 | No
Deactivate AA PDP context Accept | 9.5.14 | No
SM Status | 9.5.15 | No

Observation Point 5- SMS Over-the-Air Messages

This observation point captures the messages exchanged between the LLC layer and the SMS sub-layers. See SMS Logging Control for more information.

Observation Point 6- GSM L3 Over-the-Air Messages

GSM Layer 3 (GSM L3) is defined in GSM 04.08. GSM L3 includes messages that are transmitted over the Common Control Channels. These are:

  • BCCH information (System information messages)
  • PAGCH messages (Immediate assignments)
  • RACH accesses

CCCH messages are useful mainly for the purpose of verifying correct channel allocation through the logging of RACH accesses and the related assignments. Note that the System Information Messages will only be visible whenever changes are made to the base station parameters. They are no continuously logged, although they are continuously broadcast on the BCCH.

All references in this section are relative to GSM 04.08 or GSM 04.60.

Message | Reference | Supported
Location Updating Request | 04.08/9.2.15 | Yes
Location Updating Accept | 04.089.2.13 | Yes
Channel Request | 04.08/9.1.8 | Yes
Immediate Assignment | 04.08/9.1.18 | Yes
Packet System information 1 | 04.60/11.2.18 | Yes
Packet System information 13 | 04.60/11.2.25 | Yes
Packet System information 2 | 04.60/11.2.19 | Yes
Packet System information 3 | 04.60/11.2.20 | Yes
Packet System information 3bis | 04.60/11.2.21 | Yes

Observation Point 7 - SNDCP Over-the-Air Messages

Subnetwork Dependent Convergence Protocol (SNDCP): This transmission functionality maps network-level characteristics onto the characteristics of the underlying network. SNDCP is specified in GSM 04.65.

Message | Reference | Supported
SN-DATA | 7.2 | Yes
SN-UNITDATA | 7.2 | Yes
SNDCP-XID | 6.8 | Yes

Observation Point 8 - IP Messages

Unlike most of the other protocols, IP only has a single type of message: the datagram. For each datagram, the IP header fields will be displayed by name and the user data will be displayed as a hex dump.

For each datagram, the following fields will be displayed:

  • Version
  • Internet Header Length
  • Type of Service
  • Total Length
  • Identification
  • Flags
  • Fragment Offset
  • Time to Live
  • Protocol
  • Header Checksum
  • Source Address - Only the IP address is displayed. No attempt is made to look up the host name
  • Destination Address - Only the IP address is displayed. No attempt is made to look up the host name
  • Data - This contains the user data and any IP options displayed in hex.

For a more detailed explanation of these fields, refer to the Internet Engineering Task Force (IETF) document RFC 791.

Observation Point 9 - RLP Over-the-Air Messages

The Radio Link Protocol (RLP) stack layer provides reliable transportation of data between the mobile station and the PPP layer by using a Frame Check Sequence (FCS) for error detection and providing for retransmission of corrupted or missing data. RLP is specified in GSM 04.22.

Observing the messages set and received by this layer is only useful if you are using GSM data channels in non-transparent mode. See GSM Circuit Switched Data (CSD) for more information.

Observation Point 10 - PPP Over-the-Air Messages

The Point-to-Point Protocol (PPP) is associated with data channels. It allows a mobile station to transfer IP packets to and from the IP layer. PPP is specified in the Internet Engineering Task Force (IETF) document RFC 1548.

For more information about data channel support in the test set, see Data Channel .

Observation Point 11 - PPP HDLC Over-the-Air Messages

The PPP High Level Data Link Control observation point provides access to the full PPP frame that is sent or received by the test set. Some header and footer octets are removed from the frame displayed in the PPP observation point. The additional octets viewable in the PPP HDLC layer are:

Front of the Frame

  • Flag
  • Address
  • Control

Back of the Frame

  • Frame Check Sequence (FCS)
  • Closing Flag

PPP Observation Point and PPP HDLC Observation Point Comparison

Operating Considerations

This observation point is not enabled by default. If you want to capture the PPP HDLC frames using the WPA, you should enable PPP_HDLC in the Test Set Message Filter Settings.

Observation Point 12 - RRLP Over-the-Air Messages

See RRLP Configuration for more information about the RRLP layer support in the test set.

Related Topics

Protocol Logging


RRLP Configuration

RRLP Configuration

This section is only applicable to the lab applications.

The test set supports the configuration, sending, and retrieving of the components of a generic RRLP message used to transport location services information between the MS and the Serving Mobile Location Centre (SMLC). The possible components of the message are:

  • Measure Position Request
  • Measure Position Response
  • Assistance Data
  • Assistance Data Acknowledgment
  • Protocol Error

Introduction

The information that follows provides the user configurations allowed by the test set for of each of these components. For more information about each of the parameters and the meanings of their respective values refer to 3GPP TS 04.31, Location Services (LCS);Radio Resource LCS Protocol (RRLP) .

Operating Considerations

RRLP Control

The configuration, sending, and retrieval of results for RRLP messages are all performed using GPIB commands only.

Test Set Requirements

You can configure the RRLP message in any operating mode.

RRLP messages can only be sent while the test set is in Active Cell operating mode.

The RRLP pipe mode must be disabled. See CALL:PPRocedure:PMEasurement:PIPE for command information. See A-GPS (Assisted-GPS) for more information about the RRLP pipe mode.

Mobile Station Requirements

For your mobile station to receive and respond to RRLP messages, it must be in one of the following states:

  • idle mode and able to monitor the CCCH,
  • in a speech call,
  • or transferring circuit switched data (CSD).

The mobile station can NOT be monitoring a PBCCH or transferring packet data. Verify that your mobile station is in one of the valid states before attempting to send it RRLP messages.

Measure Position Request

This component of the RRLP message is used to request location measurements or a location estimate from the MS. It includes instructions and can also include assistance data for the MS. The Measure Position Request component can contain several elements. Only the Positioning Instructions Element is required. The following table contains the elements and the fields and values that you can configure. You can configure the fields that have an "X" in the "User Configurable" column of the table. If there is no "X" designation, the value that is supplied by the test set for that parameter is shown in the table. The "Optional" column is used to indicate optional components and elements. You can include or exclude these components and elements using GPIB commands.

Measure Position Request Variable Parameters
Positioning Instructions
Field | User Configurable | Optional
Method Type | X |
Positioning Methods | 0 = EOTD |
Response Time | X |
Accuracy | X | X
Multiple Sets | X |
Environment Characterization | X | X
|
E-OTD Reference BTS for Assistance Data
Field | User Configurable | Optional
BCCH Carrier | Same as the serving cell |
BSIC | Same as the serving cell |
Timeslot Scheme | 157, 156, 156, 156... |
BTS Position - Type of Description | X | X
BTS Position - Sign of Latitude | X | X
BTS Position - Degrees Latitude | X | X
BTS Position - Degrees Longitude | X | X
BTS Position - Direction Altitude | X | X
BTS Position - Altitude | X | X
|
E-OTD Measurement Assistance Data
Field | User Configurable | Optional
Number of BTSs (n<= 8) | X |
BTS[n] BCCH Carrier (n<= 8) | X |
BTS[n] BSIC (n<= 8) | X |
BTS[n] Multiframe Offset (n<= 8) | X |
BTS[n] Timeslot Scheme (n<= 8) | X |
BTS[n] Rough RTD (n<= 8) | X |
BTS[n] Fine RTD (n<= 8) | X |
BTS[n] Relative North (n<= 8) | X |
BTS[n] Relative East (n<= 8) | X |
BTS[n] Relative Altitude (n<= 8) | X |
|
Release 98 Extension
Field | User Configurable | Optional
BTS[n] Expected OTD (n<= 8) | X |
BTS[n] Expected OTD Uncertainty (n<= 8) | X |

Associated GPIB commands

See CALL:PPRocedure:PMEasurement:MPRequest for the GPIB commands necessary to configure the Measure Position Request parameters.

Measure Position Response

The following table contains the elements and the fields and values of the Measure Position Response component of the RRLP message that you can retrieve using GPIB commands. The test set gives you access to the fields that have a "Yes" in the "Available" column of the table. A "No" indicates the information is not available.

Measure Position Response Message Contents
Multiple Sets Element
Parameter | Available?
Number of Measurement Information Sets | YES
Number of Reference BTS' (= x, where 1 <= x <= 3) | YES
Reference BTS Relation to Measurement Elements | YES
Reference BTS Identity Element (Optional)
Parameter | Available?
Cell ID Type (for each BTS `x' where 1 <= x <= 3) | YES
Reference LAC (for each BTS `x' where 1 <= x <= 3) | YES
Reference CI (for each BTS `x' where 1 <= x <= 3) | YES
Reference BCCH Carrier (for each BTS `x' where 1 <= x <= 3) | YES
Reference BSIC (for each BTS `x' where 1 <= x <= 3) | YES
Request Index (for each BTS `x' where 1 <= x <= 3) | YES
System Info Index (for each BTS `x' where 1 <= x <= 3) | YES
E-OTD Measurement Information Element (Optional)
Parameter | Available?
Reference Frame Number (for each set `x' where 1 <= x <= 3) | YES
Reference Time Slot (for each set `x' where 1 <= x <= 3) | YES
Reference Quality (for each set `x' where 1 <= x <= 3) | YES
Number of Measurements (for each set `x' where 1 <= x <= 3) | YES
Std Resolution (for each set `x' where 1 <= x <= 3) | YES
TA Correction (for each set `x' where 1 <= x <= 3) | YES
Number of Measured Neighbours (n) (for each set `x' where 1 <= x <= 3) | YES
BTS `n' Identity Present (n <= 10) (for each set `x' where 2 <= x <= 3 - this field is not included in the first measurement set) | YES
BTS `n' Cell ID Type (n <= 10) (for each set `x' where 1 <= x <= 3) | YES
BTS `n' LAC (n <= 10) (for each set `x' where 1 <= x <= 3) | YES
BTS `n' CI (n <= 10) (for each set `x' where 1 <= x <= 3) | YES
BTS `n' BCCH Carrier (n <= 10) (for each set `x' where 1 <= x <= 3) | YES
BTS `n' BSIC (n <= 10) (for each set `x' where 1 <= x <= 3) | YES
BTS `n' Multiframe Offset (n <= 10) (for each set `x' where 1 <= x <= 3) | YES
BTS `n' Request Index (n <= 10) (for each set `x' where 1 <= x <= 3) | YES
BTS `n' System Info Index (n <= 10) (for each set `x' where 1 <= x <= 3) | YES
BTS `n' Neighbour Time Slot (n <= 10) (for each set `x' where 1 <= x <= 3) | YES
BTS `n' Number of EOTD Measurements (for each set `x' where 1 <= x <= 3) | YES
BTS `n' Std of EOTD (n <= 10) (for each set `x' where 1 <= x <= 3) | YES
BTS `n' OTD (n <= 10) (for each set `x' where 1 <= x <= 3) | YES
Location Information Element (Optional)
Parameter | Available?
Reference Frame | YES
Fix Type | YES
GPS TOW | NO
Position Estimate - Type of Description | YES
Position Estimate - Sign of Latitude | YES
Position Estimate - Degrees Latitude | YES
Position Estimate - Degrees Longitude | YES
Position Estimate - Uncertainty Code | YES
Position Estimate - Uncertainty Semi Major | YES
Position Estimate - Uncertainty Semi Minor | YES
Position Estimate - Orientation Major Axis | YES
Position Estimate - Confidence | YES
Position Estimate - Direction of Altitude | YES
Position Estimate - Altitude | YES
Position Estimate - Altitude Uncertainty | YES
GPS Measurement Information Element (Optional)
If GPS measurement information is provided, the message will still be decoded but no information will be available on this element via GPIB.
Location Information Error Element (Optional)
Parameter | Available?
Error Reason | YES
Extension Container Element
If the Extension Container element is included, the message will still be decoded but no information will be available on this element via GPIB.
Release 98 Extension Element (Optional)
If the Release'98 Extension element is included, the message will still be decoded but no information will be available on this element via GPIB.

Associated GPIB commands

See the following for the GPIB commands necessary to query the Measurement Position Response message contents.

  • CALL:PPRocedure:PMEasurement:PRESponse:AVAilable?
  • CALL:PPRocedure:PMEasurement:PRESponse:MSETs
  • CALL:PPRocedure:PMEasurement:PRESponse:RIDentity
  • CALL:PPRocedure:PMEasurement:PRESponse:MINFormation
  • CALL:PPRocedure:PMEasurement:PRESponse:LINFormation
  • CALL:PPRocedure:PMEasurement:PRESponse:LIERror

Assistance Data

Most configurable elements of the Assistance Data component of the RRLP message are identical to related elements in the Measure Position Request message detailed in Measure Position Request Variable Parameters . Therefore, the values currently set for these common elements in the Measure Position Request message are used for constructing the Assistance Data message.

The following table contains the elements and the fields and values unique to the Assistance Data component of the RRLP message that you can configure. You can configure the fields that have an "X" in the "User Configurable" column of the table. If there is no "X" designation, the value that is supplied by the test set for that parameter is shown in the table. The "Optional" column is used to indicate optional components and elements. You can include or exclude these components and elements using GPIB commands.

Assistance Data Variable Parameters
E-OTD Reference BTS for Assistance Data (Optional)
Field | User Configurable | Optional
BCCH Carrier | Same as the serving cell |
BSIC | Same as the serving cell |
Timeslot Scheme | 157, 156, 156, 156... |
BTS Position - Type of Description | X | X
BTS Position - Sign of Latitude | X | X
BTS Position - Degrees Latitude | X | X
BTS Position - Degrees Longitude | X | X
BTS Position - Direction Altitude | X | X
BTS Position - Altitude | X | X
|
E-OTD Measurement Assistance Data (Optional)
Field | User Configurable | Optional
Number of BTSs (n<= 8) | X |
BTS[n] BCCH Carrier (n<= 8) | X |
BTS[n] BSIC (n<= 8) | X |
BTS[n] Multiframe Offset (n<= 8) | X |
BTS[n] Timeslot Scheme (n<= 8) | X |
BTS[n] Rough RTD (n<= 8) | X |
BTS[n] Fine RTD (n<= 8) | X |
BTS[n] Relative North (n<= 8) | X |
BTS[n] Relative East (n<= 8) | X |
BTS[n] Relative Altitude (n<= 8) | X |
|
More Assistance Data to be Sent(Optional)
Field | User Configurable | Optional
More Assistance Data | X |
|
Release 98 Extension (Optional)
Field | User Configurable | Optional
BTS[n] Expected OTD (n<= 8) | X |
BTS[n] Expected OTD Uncertainty (n<= 8) | X |

Associated GPIB commands

See CALL:PPRocedure:PMEasurement:ADATa for the GPIB commands necessary to configure the Measure Position Request parameters.

Assistance Data Acknowledgment

Use the CALL:PPRocedure:PMEasurement:ADATa:ACKNowledged? to query the status of the last Assistance Data message sent to the mobile station.

Protocol Error

The RRLP Protocol Error message can be sent in two directions:

  • Network to Mobile Station and
  • Mobile Station to Network .

The test set can both send and receive protocol error messages.

Network to Mobile Station

In a network, protocol error messages are only sent in response to a Measure Position Response from the mobile station. However, with the test set, you can send a protocol error message to the mobile station at any time. You can configure the error cause value to be sent and send the protocol error message using GPIB commands. See CALL:PPRocedure:PMEasurement:PERRor .

Mobile Station to Network

The mobile station can generate a protocol error message in response to either the Measure Position Request or Assistance Data messages. When this occurs, the following error message appears on the front panel display: "Protocol Error; RRLP Protocol Error Received from MS. Error Code <n>". <n> is a number between 0 and 5 and represents the value of the Protocol Error component of the RRLP message received from the MS. These values and their meanings are listed as settings for the command CALL:PPRocedure:PMEasurement:PERRor:CODE .

This error message can also be retrieved using the GPIB command SYSTem:ERRor? .

Related Topics

E-OTD (Enhanced Observed Time Difference)


Analyzing protocol logs of Packet Switched Data

Analyzing protocol logs of Packet Switched Data

This section is only applicable to the lab applications.

You can use the Wireless Protocol Advisor (WPA) to observe and analyze messages and information related to many aspects of packet switched data. This section contains some examples of how you can modify the WPA view to make it easier to access certain fields.

Your default WPA traffic overview column setup may look similar to Default WPA Traffic Overview .

Default WPA Traffic Overview

One aspect of packet switched data is polling to ascertain if packets were received correctly. For GPRS, a supplementary/poll (S/P) bit is sent to a mobile station when an update on packets received correctly or incorrectly is desired. Another parameter related to this is the Relative Reserved Block Period (RRBP). For more information on this, see Relative Reserved Block Period (RRBP) . In the test set, when the BLER connection type is used, you can configure how often the test set polls the mobile station. (See Block Polling Parameters .

To more easily see the changes in the parameters mentioned above, you can add protocol field columns to the traffic overview (see WPA Traffic Overview with additional Protocol Field Columns ). If you add the RRBP Indicator field from the RLC_MAC layer, you can see the formula the mobile station uses to calculate when to send its response to a poll. Adding SPB, also from the RLC_MAC layer, allows you to see in which blocks the S/P has been set, and therefore when the RRBP is valid or not.

In the figure below, the block polling rate has been set to 4, meaning the test set polls the mobile station every 4 blocks. You can see that the SPB value is RRBP field is valid for every 4 downlink RLC data blocks.

Refer to the WPA Help for protocol field column configuration instructions. This is accessible from WPA by clicking the help button or for download at:

http://www.agilent.com/find/e6584a

NOTE
The System Time in Agilent's Wireless Protocol Advisor is not equivalent to the GSM Frame number. The Frame Number can be viewed form the front panel in the External Trigger Summary. This summary can be found by pressing CALL SETUP, Cell Info (F6), and External Trigger Setup (F5).)

WPA Traffic Overview with additional Protocol Field Columns

Related Topics

Relative Reserved Block Period (RRBP)


Repeated Downlink FACCH

Repeated Downlink FACCH

This section is only applicable to the lab applications.

The Repeated FACCH functionality allows the downlink FACCH Blocks to be repeated to improve the robustness of FACCH signaling during handovers. You can enable the Repeated FACCH parameter in the test set to repeat all downlink FACCH blocks once.

The mobile station attempts to decode any downlink FACCH blocks independently of other received FACCH blocks. If the mobile station is unsuccessful, it uses a different decoding scheme that uses information from each identical downlink FACCH block. The repeated FACCH is sent nine frames after the first burst of the downlink FACCH containing the first instance of a LAPDm frame if a SACCH or and idle burst is transmitted between the two FACCH blocks. Otherwise, the repeated FACCH is sent eight frames after the first burst of the downlink FACCH containing the first instance of a LAPDm frame.

3GPP TS 44.006 Version 6.1.0 Release 6 Section 10.2 states, "On a channel using Repeated Downlink FACCH the value of T200 should be increased to cope with the case where an MS fails to decode the downlink FACCH block used to send the first instance of a repeated LAPDm frame."

Therefore, timer T200 is extended 42 ms to account for the maximum additional time (9 TDMA frames) that may be needed when the Repeated FACCH parameter is enabled.

The GPIB command to enable/disable the Repeated FACCH parameter is CALL:TCHannel:(FACCH|FACChannel):REPeat[:STATe] .

The following precedure details how to set the Repeated Downlink FACCH feature.

  1. Press the CALL SETUP screen key.
  2. Press TCH Parameters ( F8 ).
  3. Press the More key untill screen 3 of 3 of the TCH Parameters menu is displayed.
  4. Press Call Signaling Parameters ( F7 ) and the Call Signaling Parameters menu appears in the center of the screen.
  5. Use the knob to highlight and set Repeated FACCH.

For more information about Repeated FACCH, please refer to 3GPP TS 44.006 Section 10.

Related Topics

Fixed Timer Messages


Repeated SACCH

Repeated SACCH

This section is only applicable to the lab applications.

The Repeated SACCH functionality allows the SACCH Blocks to be repeated on both uplink and downlink to improve the robustness of the signaling link. You can choose to enable the Repeated SACCH functionality when a layer 3 message is to be sent or received in a SAPI=0 frame in the SACCH channel.

Repeated Downlink SACCH Blocks

On the downlink, you can use the Repeated SACCH parameter to set the Downlink Repeated SACCH functionality, when the Repeated SACCH is set to Continuous , each downlink SAPI=0 SACCH Blocks are repeated without any SAPI=3 SMS blocks in between. When the Repeated SACCH is set to On Request , the downlink SAPI=0 SACCH Blocks are only repeated after the test set receive SRR bit in the previous uplink SACCH Layer 1 block header from DUT. (The DUT monitors SAPI=0 SACCH Blocks and if it fails to decode then it sets the SRR (SACCH Repetition Request) bit in the next uplink SACCH block.) When the Repeated SACCH is set to Off , the downlink SACCH Blocks are not repeated.

NOTE
When the Repeated SACCH is set to On Request , the Downlink SACCH Blocks will only be repeated if the DUT has Repeated SACCH functionality implemented too.

The GPIB command to enable/disable the Repeated SACCH parameter is CALL:TCHannel:(SACCH|SACChannel):REPeat[:STATe] .

The following precedure details how to set the Repeated SACCH parameter.

  1. Press the CALL SETUP screen key.
  2. Press TCH Parameters ( F8 ).
  3. Press the More key untill screen 3 of 3 of the TCH Parameters menu is displayed.
  4. Press Call Signaling Parameters ( F7 ) and the Call Signaling Parameters menu appears in the center of the screen.
  5. Use the knob to highlight and set Repeated SACCH.

Repeated Uplink SACCH Block

On the uplink, you can use the SACCH Repeated Order parameter to set the Uplink Repeated SACCH functionality. When the SACCH Repeated Order is set to ON , all downlink SACCH Blocks shall have the SRO (SACCH Repetition Order) bit set in the Layer 1 downlink block header, the DUT repeats the SAPI=0 SACCH block when the SRO in the previous downlink SACCH block is set.

The Uplink SACCH Blocks will only be repeated if the DUT has Repeated SACCH functionality implemented too.

The GPIB command to enable/disable the SACCH Repeated Order parameter is CALL:TCHannel:(SACCH|SACChannel):REPeat:ORDer .

The following precedure details how to set the SACCH Repeated Order parameter.

  1. Press the CALL SETUP screen key.
  2. Press TCH Parameters ( F8 ).
  3. Press the More key untill screen 3 of 3 of the TCH Parameters menu is displayed.
  4. Press Call Signaling Parameters ( F7 ) and the Call Signaling Parameters menu appears in the center of the screen.
  5. Use the knob to highlight and set SACCH Repeated Order.

For more information about Repeated SACCH, please refer to 3GPP TS 44.006 and 3GPP TS 44.006 Section 11.

Related Topics

Repeated Downlink FACCH


Relative Reserved Block Period (RRBP)

Relative Reserved Block Period (RRBP)

Last updated: December 3, 2008

This section is only applicable to the lab applications.

The test set allows you to set the value of the Relative Reserved Block Period (RRBP) field of the RLC/MAC block header. This field is defined in 3GPP 04.60 Section 10.4.5.

The RRBP is only valid when the supplementary/poll (S/P) bit is set. This bit gets set when the test set needs to poll the mobile station to determine the quality of the link. When the S/P bit is set, the test set allows the mobile station a limited period of time to respond with either an acknowledgement (ACK) or not acknowledgement (NACK) for the data blocks sent to it. The value of the RRBP field is used by the mobile station to determine the number of the frame it is to use for sending the ACK/NACK response.

The table below illustrates the RRBP values used in the test set and how they map to the bits set for the RRBP field and what this means to the mobile station. The value for N is the frame number of the block received with a valid S/P bit and the corresponding RRBP.

RRBP setting in test set | RRBP field bits | Frame Number for transmitting response
0 | 00 | (N+13) mod 2715648
1 | 01 | (N+17 or N+18) mod 2715648
2 | 10 | (N+21 or N+22) mod 2715648
3 | 11 | (N+26) mod 2715648

For the command to configure the RRBP value in the test set, see CALL:(PDTCH|PDTChannel):RRBPeriod .

Why are there two possible Frame Numbers for RRBP settings 1 and 2?

If you consider how blocks are organized in a PDCH multiframe (illustrated below with B indicated a block), you can see that with an RRBP of 1 or 2 may include up to 2 Idle or PTCCH frames.

B0B1B2-Idle-B3B4B5-PTCCH-B6B7B8-Idle-B9B10B11-PTCCH

Each block, indicated by B(a number) above, contains 4 frames and each Idle or PTCCH is a single frame, so the total number of frames represented above is 52.

Therefore, consider the following examples: If the RRBP is set to 1 and was sent on B0, the response would come on B4, 17 frames later. However, if the RRBP was sent on B2, the response would have to come in B6, which is 18 frames later because there is an extra IDLE/PTCCH frame in the way.

Related Topics

Block Polling Parameters


Short Message Service (SMS)

Short Message Service (SMS)

Last updated: December 3, 2008

This section is only applicable to lab applications and the test application with a required feature license.

The Short Message Service (SMS) testing capability available in the test set allows you to test both the cell broadcast and point-to-point (mobile terminated and mobile originated messages) SMS capability of your mobile station. The point-to-point testing capability is extensive, including support for concatenated and binary SMS applications like WAP Push, MMS notifications, ringtones, picture messaging, as well as character based languages such as Chinese, Japanese, and Hebrew. In addition to the standard GPIB and front panel interface, an HTTP interface is available providing easy connectivity with commercially available SMS Gateways. Support is also available for capturing logs of the protocol messages exchanged between the test set and the mobile station during SMS verification.

  • Cell Broadcast Service (CBS) - Includes specific information on cell broadcast service parameters.
    • HTTP Interface Configuration for Cell Broadcast Service Messages - Includes specific information on configuring cell broadcast messages.
    • HTTP Interface for Cell Broadcast Service - Introduction
  • Point-to-Point SMS - Includes information on how to send and receive point-to-point SMS messages using either GSM or GPRS protocol layers.
    • Mobile Terminated SMS (MT SMS)- Sending a Message to the Mobile Station - Includes specific information on sending messages to the mobile station.
    • Mobile Originated SMS (MO SMS)- Receiving Messages Transmitted by the Mobile Station - Includes specific information on receiving messages from the mobile station.
    • HTTP Interface for SMS - Introduction - Includes information on the HTTP interface available in the test set for sending and receiving SMS messages.
  • Multimedia Service (MMS) Messages
  • Logging SMS Messages

Related Topics

How to use the Short Message Service Features


Cell Broadcast Service (CBS)

Cell Broadcast Service (CBS)

Last updated: December 3, 2008

This section is only applicable to lab applications and the test application with a required feature license.

You can test a mobile station's ability to receive Cell Broadcast messages using the Cell Broadcast Service capability in the test set.

This section covers:

Cell Broadcast Service (CBS) Overview

Cell Broadcast Message Setup

Cell Broadcast Setup -General

Cell Broadcast Messages -Content

Cell Broadcast Service (CBS) Overview

The Cell Broadcast Service in the test set allows you to send cell broadcast messages to the mobile station that are transmitted at a defined repetition interval (see Cell Broadcast Setup -General for more information). This allows the mobile station to receive the message even if entering the cell after the first transmission. The cell broadcast messages can be from one to fifteen pages in length, and are transmitted by the test set until the cell broadcast service is disabled or the state of the message(s) being transmitted is set to OFF. All messages sent from the test set are automatically segmented into the minimum number of pages possible. Cell broadcast messages contain a page parameter that indicates to the mobile station the number of the current page being received as well as the total number of pages in the message.

The test set can transmit up to three different messages at a time using the Cell Broadcast Service. If you configure the Cell Broadcast Service to transmit multiple messages, the messages are sent in sequential order at a rate of one page every multiframe until all the pages in the enabled messages are transmitted. The messages are retransmitted at specified intervals, which are set by the Repetition Period .

There are several message parameters that the test set allows you to set. It is important that you configure your mobile station to receive cell broadcast messages. This is done by enabling reception of messages in your mobile station and specifying the message parameters that it can receive, and set the parameters according to the type of cell broadcast message your mobile station is allow to receive. Cell broadcast messages are not acknowledged by the mobile station.

In addition to the pre-defined text strings, you can specify a custom text string and custom data to be sent in a cell broadcast message. See Cell Broadcast Messages -Content for more information on configuring the contents of the cell broadcast message.

Cell Broadcast Message Setup

All three of the messages available for use in the test set's Cell Broadcast Service can be configured independently. The content of each message can include either one of two predefined text messages, a custom text message or a custom binary/UCS2 message.

There are several configurable parameters for each cell broadcast message. The serial number is made up of three of these parameters: Geographical Scope, Message Code, and Update Number as shown in the diagram below. Refer to 3GPP 23.041 version 6.2.0 section 9.4.1.2.1 for more information about cell broadcast message parameters.

Serial Number
Octet 1 |  |  |  |  |  |  |  | Octet 2
7 | 6 | 5 | 4 | 3 | 2 | 1 | 0 | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
GS |  | Message Code |  |  |  |  |  |  |  |  |  | Update Number

Additionally, each message is classified by topic and allocated a message identifier, data coding scheme, and message content. The following list contains all the configurable cell broadcast message parameters offered by the test set.

  • State - allows you to configure which messages are sent using CBS. The message state must be ON for each message you want to send. The State for Message 1 is set to ON by default.

    The GPIB command for this parameter is CALL:SMService:CBRoadcast:MESSage[<n>]:STATe .

  • Geographical Scope (GS)

    This parameter indicates the geographical area over which the message code is unique and the mode that should be used by the mobile station when displaying the cell broadcast message.

    The following list contains the settings available for the Geographical Scope parameter.

    • Cell Wide / Immediate (CIMMediate) - Similar messages received in any other cell is regarded as new. The immediate display setting indicates that the cell broadcast message is displayed on the mobile station at all times. This setting corresponds to a GSCOPE request URL equal to 0.
    • PLMN Wide / Normal (PNORmal)- The message code and/or update number must change in the next cell for the cell broadcast message to be considered new. The cell broadcast message is displayed on the mobile station only when the user wants to see it.This setting corresponds to a GSCOPE request URL equal to 1.
    • Location Area Wide/Normal (LNORmal) - The cell broadcast messages with the same message code and update number are considered new in the next cell only if the next cell is in a different location area than the current cell. The normal display mode displays the message only when the user wants to see it.This setting corresponds to a GSCOPE request URL equal to 2.
    • Cell Wide / Normal (CNORmal) - Similar messages received in any other cell is regarded as new. The normal display mode displays the message when the user wants to see it. This setting corresponds to a GSCOPE request URL equal to 3.

    The GPIB command for this parameter is CALL:SMService:CBRoadcast:MESSage[<n>]:GSCope .

  • Message Code

    This parameter identifies a particular message, so that a mobile station receiving a message with the same code as a previously received message will recognize that it is a repeat, and may not display it to the user.

    The GPIB command for this parameter is CALL:SMService:CBRoadcast:MESSage[<n>]:CODE .

  • Update Number

    This parameter is used to identify a particular version of a message. This is useful for reporting a dynamic situation, where a message may be reporting one event (such as road works or road construction ahead), but the details change periodically (the length of the tail-back or traffic jam caused, for example). A mobile station which remains in one cell for a length of time receives messages with the same message code but increments the update numbers as updated versions of the same message are received. A mobile station that has just entered a cell receives only the most recent version of the message, followed by any subsequent versions. The update number wraps from 15 to 0.

    The GPIB command for this parameter is CALL:SMService:CBRoadcast:MESSage[<n>]:UPDate .

  • Message Identifier

    The parameter is a header number identifying the message topic (such as 'Weather Report' or 'Traffic Information').

    The GPIB command for this parameter is CALL:SMService:CBRoadcast:MESSage[<n>]:IDENtifier .

  • Data Coding Scheme Specification

    This parameter indicates the method used to set the data coding scheme. The methods available are Language (see Data Coding Scheme Language ) and Value (see Data Coding Scheme Value ).

    The GPIB command to specify the which method is used is CALL:SMService:CBRoadcast:MESSage[<n>]:DCSCheme[:SPECify] .

  • Data Coding Scheme Language

    This parameter sets the data coding scheme value associated with the indicated language. The data coding scheme indicates the intended handling of messages, the alphabet and coding of the message content, and the associated language of the text. Changing this parameter does not translate the text of a message, it is used to automatically configure the message's data coding scheme. This method is only appropriate for configuring text messages.

    Refer to 3GPP TS 23.038 version 6.1.0 Release 6 (section 5) for details about setting the CBS Data Coding Scheme.

    The GPIB command to specify the how the mobile station interprets the content of received text messages by specifying a language is CALL:SMService:CBRoadcast:MESSage[<n>]:DCSCheme:LANGuage .

  • Data Coding Scheme Value

    This parameter sets the 8-bit data coding scheme value that indicates the intended handling of messages, the alphabet and coding of the message content, and the associated language of the text. Changing this parameter does not translate the text of a message, it is used to automatically configure the message's data coding scheme.

    Refer to 3GPP TS 23.038 version 6.1.0 Release 6 (section 5) for details about setting the CBS Data Coding Scheme.

    The GPIB command to specify the how the mobile station interprets the content of received text messages by specifying the data coding scheme value is CALL:SMService:CBRoadcast:MESSage[<n>]:DCSCheme:VALue .

  • Content associates the message with the actual data to be sent by the test set. See Cell Broadcast Messages -Content for more specific information on the cell broadcast messages that can be sent from the test set.

    The GPIB command for this parameter is CALL:SMService:CBRoadcast:MESSage[<n>]:CONTent .

Cell Broadcast Setup -General

The settings for the parameters explained in this section apply to all cell broadcast messages.

  • Repetition Period

    The repetition period determines how often the cell broadcast messages are transmitted. The repetition period is applied to all cell broadcast messages. The test set transmits the cell broadcast message(s) in their entirety before repeating the message(s). If all the messages are transmitted before the repetition period is complete, no messages are sent until the beginning of the next repetition period. Alternatively, if the repetition period is shorter than the time required to send all the enabled messages, the test set overrides the specified repetition period and begins retransmitting the messages only after is has completely transmitted all cell broadcast message(s). The two mechanisms provided to specify the repetition period are as follows. Note: Both mechanisms configure the same repetition period parameter in the test set.

    1. Specify the repetition period as an integer value in seconds.
    2. Specify a more precise repetition period as an integer value of the number of units multiplied by the minimum interval period, where a unit represents the value of the minimum interval of time it takes to transmit a single page of a message. According to 3GPP TS 23.041 version 6.2.0 section 9.3.8, the minimum repetition rate in UMTS is one page of a cell broadcast message every 1.883 seconds.

      For example, if you set the repetition period to 3 units, the actual repetition period is 5.649 seconds.

Cell Broadcast Messages -Content

Several Cell Broadcast Service (CBS) message options are available which allow you to choose or create messages to be sent. You can set the Content parameter to Text1 , Text2 , Custom Text, or Custom Data . See the sections below for more information about these settings.

Predefined Cell Broadcast Text Messages

User Defined Text Message (Custom Text)

User Defined Text Message (Custom Data)

Predefined Cell Broadcast Text Messages

There are two predefined cell broadcast text messages. The ASCII text strings of these messages are as follows:

  • Predefined text message 1 ( Text1 )

    The quick brown fox jumps over the lazy dog

  • Predefined text message 2 ( Text2 )

    This instrument provides functional testing of cell broadcast SMS by sending up to three broadcast messages to the device under test. Two fixed text messages and user defined text or binary/UCS2 messages are available for selection. The second fixed message spans multiple pages.

User Defined Text Message (Custom Text)

You can set the cell broadcast message to send a customized text message by setting the Content parameter to: Custom Text . You can define the text for the custom text cell broadcast message using the following GPIB command:

CALL:SMService:CBRoadcast:MESSage[<n>]:CTEXt .

A custom text message can be defined only via the remote user interface and HTTP. The maximum length for the cell broadcast user defined messages is 1395 characters.

The default the custom text message is:

" Enter your text here"

NOTE
Text messages sent from the test set to the mobile station are encoded using the ETSI Default Alphabet character set. The ETSI Default Alphabet encoding shares the majority of its character codes with those used by the ASCII character set. Between the two character sets, all alphanumeric characters and most punctuation characters have identical codes.

For the custom user defined text message, the test set accepts a 7-bit ASCII string. This string is then encoded using the ETSI Default Alphabet before it is transmitted. The ASCII code for each character in this string is mapped to the ETSI Default Alphabet character with the same code. Characters present in the user defined text message whose ASCII and ETSI Default Alphabet codes are not identical will be received and displayed by the mobile station as the ETSI Default Alphabet character with the original ASCII character's code. This behavior is only noticeable with certain user defined text messages as all of the predefined text messages use only alphanumeric and basic punctuation characters.

User Defined Text Message (Custom Data)

You can set the cell broadcast message to send a customized data message by setting the Content parameter to: Custom Data . You can define the binary data/UCS2 for the custom data cell broadcast message using the following GPIB command:

CALL:SMService:CBRoadcast:MESSage[<n>]:CDATa .

A custom data message can be defined only via the remote user interface. The maximum length for the cell broadcast user defined messages is 2460 hexadecimal characters.

The default the custom data message is an empty string.

Related Topics

Short Message Service (SMS)


HTTP Interface for SMS - Introduction

HTTP Interface for SMS - Introduction

This section is only applicable to lab applications and the test application with a required feature license.

The HTTP interface in the test set provides an industry standard interface for interfacing the base station simulation capability of the test set with necessary external components for verifying SMS capability in a mobile station. The HTTP implementation in the test set also provides SMS routing capability, simulating a simple Short Message Service Center (SMSC).

Introduction to HTTP

HTTP is the client/server based protocol used to deliver virtually all files and data on the World Wide Web. If you'd like a more detailed description of HTTP protocol, refer to Internet RFCs `HTTP/1.0 - RFC 1945' and `HTTP/1.1 - RFC 2616', which can be downloaded from http://www.rfc-editor.org/rfc.html.

When you use HTTP in a web browser, you enter the "address" for the web page you wish to view. These addresses can be generalized into the following format:

In this example, the web browser is the HTTP client and it uses the information in this address to open a connection to an HTTP server and send a request.

  • "http://" is the protocol specifier, telling the browser what protocol to use for the request.
  • <ip_address> is the IP address of the server.
  • <port> is the port number on which to communicate with the server. The default port for HTTP is 80.
  • <request_URL> provides information to the server on the location of the resource that's being requested and can also be used to provide information to the resource.

HTTP Interface for SMS verification

The test set acts as both a server and a client, depending on which operation it is performing.

The test set as the server:

If you have a PC and your test set connected to a network or directly connected together, you can open a web browser (client) and send a request to the test set using the test set's IP address and a correctly configured request URL. For example, you might send the following from the web browser if your test set's IP address was 111.111.111.112.

NOTE
It is not necessary to specify a port number because the test set uses 80, which is the default port for HTTP.

Sending the URL causes an SMS message to arrive at the mobile station attached to the test set's RF port. This message contains the text "hello".

The test set acts as the server for mobile terminated SMS messages. While this is a simple example, this same information is necessary to configure an SMS Gateway or proprietary software for interfacing with the test set via HTTP.

For configuration information see:

  • HTTP Interface Configuration for Mobile Terminated SMS .

The test set as the client:

SMS messages originating from the mobile station attached to the test set are sent out the test set's LAN port as HTTP requests to the IP address for the intended receiving entity.

For configuration information see:

  • HTTP Interface Configuration for Mobile Originated SMS

Related Topics

HTTP Interface Configuration for Mobile Terminated SMS


HTTP Interface Configuration for Mobile Originated SMS

HTTP Interface Configuration for Mobile Originated SMS

This section is only applicable to lab applications and the test application with a required feature license.

Information must be provided to the test set in order for mobile originated SMS messages to be correctly routed by the HTTP SMS Router to the receiving entity. The test set's HTTP interface must be enabled before it can be used to send messages and the HTTP Interface must be configured with information about where to route the messages.

See the following sections for more information about configuring the HTTP interface for mobile originated messages.

  • Enable the Test Set's HTTP Interface
  • HTTP Interface Settings - General
  • HTTP Interface Settings for Using an SMS Gateway
  • Configuring Message URL
  • Example Text Message URL
  • Example Binary Message URL

Enable the Test Set's HTTP Interface

You must enable the HTTP interface output in the test set. This can be done via a GPIB command (see CALL:SMService:HTTProtocol:OUTPut ) or from the test set's front panel (see Enabling the HTTP Interface for Mobile Originated SMS ).

If the interface is not enabled, messages received from a mobile station are not output over HTTP.

HTTP Interface Settings - General

See HTTP SMS Router Web-based Configuration Interface for information on how to change the settings described in this section. Two of the settings are general and apply to every testing scenario:

  • DUT Sender address
  • Other 8960 IP Address or Alternative Device Destination (SMS Gateway) IP Address

DUT Sender address

The DUT Sender address setting allows you to associate a phone number with the mobile station originating the messages. This setting may not be required by the receiving entity, but is useful to allow mobile originated messages to be `replied' to correctly in a test system configuration making use of a gateway and more than two mobile stations and test sets.

Setting Type | String
Factory Setting | "1000"
Range | 0 - 20 character ASCII formatted string of BCD digits from 0-9, *, #, A-C

Other 8960 IP Address or Alternative Device Destination (SMS Gateway) IP Address

The IP Address where the HTTP SMS Router is to send the mobile originated message. You can only specify one destination IP address, therefore, if you want to use more than two test sets in a test system, you must use an intermediate SMS gateway or other software to route the messages.

If you have a test system with two test sets and are not using an SMS Gateway, you would specify the Other 8960 IP Address to be the other test set's IP Address. If you are sending the messages to another entity for routing, like an SMS Gateway, specify the IP Address of the PC on which that entity is running.

Setting Type | String
Factory Setting | ""
Range | Any valid IP address

HTTP Interface Settings for Using an SMS Gateway

See HTTP SMS Router Web-based Configuration Interface for information on how to change the settings described in this section. The following settings are only used when Alternative Device Destination (SMS Gateway) as been selected for the Output Destination. When Other 8960 is selected, these parameters are automatically configured internal to the test set.

  • Destination Port
  • Text Message URL
  • Binary Message URL
  • Request Method

Destination Port

The TCP/IP port on which the receiving entity listens for web/HTTP requests.

Setting Type | Numeric
Factory Setting | 80
Range | 0-65534

Text Message URL

Defines the URL format for SMS text messages accepted by the receiving entity, which might be an SMS gateway or proprietary software. The test set automatically selects this URL if the type of message received from the mobile station is a text message. See Example Text Message URL for more information on specifying this URL.

Setting Type | String
Factory Setting | ""
Range | 0 - 256 character ASCII formatted string

Binary Message URL

Defines the URL format for SMS binary messages accepted by the receiving entity, which might be an SMS gateway or proprietary software. The test set automatically selects this URL if the type of message received from the mobile station is any type of binary or Unicode message. See Example Binary Message URL for more information on specifying this URL.

Setting Type | String
Factory Setting | ""
Range | 0 - 256 character ASCII formatted string

Request Method

Allows you to select which HTTP request method the test set's HTTP interface is to use when sending SMS messages over HTTP. The method to use is dependent on the format accepted by the receiving entity.

Setting Type | Enum
Factory Setting | GET
Range | GET|POST

Configuring Message URL

Just as the test set requires a specific format for request URLs received at it's HTTP interface, so do SMS Gateways or customer programs receiving request URLs from the test set. This is very similar to the URL requests configuration discussed for mobile terminated SMS messages (see Configure the Request URL ).

In order to configure the text and binary URLs for the test set's HTTP interface, you must know the receiving entity's requirements for request URLs. If the message is being sent directly to another test set, it is not necessary to configure the message URLs.

Use the tags defined in the following table, Message URL Tags , when configuring the text and message URLs. When a mobile originated message arrives at the test set, the tags in the message URL are replaced with the respective message content before the request URL is sent to the receiving entity.

Message URL Tags

Tag | Replaced with
@@TEXT@@ | The ASCII text of a received text message (reformatted to meet URL escaping requirements). Should only be used for 7-bit text messages and will return the same as the @@DATA@@ tag if used for binary messages.
@@DATA@@ | The message content as a string of hex characters, not including any user data header present in the content. Should only be used for binary messages and will return the same as the @@TEXT@@ tag if used for 7-bit text messages
@@NUMBER@@ | The destination phone number of the message.
@@SENDER@@ | The assigned originating phone number of the message as defined by the Sender Address setting detailed in section 4.2.3.2
@@UDH@@ | The User Data Header of the message as a string of hex characters. Should only be used for binary messages, will return an empty string if used otherwise.
@@UHDI@@ | The User Data Header indicator of the received message, either 0 (UDH not present) or 1 (UDH present).
@@PID@@ | The Protocol Identifier of the received message as a decimal number.
@@PIDHEX@@ | The Protocol Identifier of the received message as a string of hex characters.
@@DCS@@ | The Data Coding Scheme of the received message as a decimal number.
@@DCSHEX@@ | The Data Coding Scheme of the received message as a string of hex characters.
@@SRR@@ | The Status Report Request flag of the received message, either 0 or 1.
@@MREF@@ | The Message Reference number of the message as a decimal number
@@MREFHEX@@ | The Message Reference number of the message as a string of hex characters.
@@TRANSPORT@@ | The transport that was used by the DUT when originally sending the message, this parameter is replaced with a text string of "GSM" or "GPRS" if included in the format string.

Example Text Message URL

You might configure your text message URL to look like the following:

If a text message is sent from the mobile station attached to the test set with the following information:

  • Destination number: 12345
  • Message Text: "This is a text message"

And the DUT Sender Address is configured to be `1000', the following URL request is sent by the test set to the receiving entity at the currently configured IP Address and Port Number:

/?PhoneNumber=12345&Text=This%20is%20a%20text%20message&Sender=1000

Example Binary Message URL

You might configure your binary message URL to look like the following:

Note the `Binary=1', `User=user535', and `Password=pass' parameters at the end of the format string. These do not contain any test set defined tags (see Message URL Tags ), but it can be useful to specify such extra parameters if the receiving entity, like an SMS gateway for example, requires user name and password information included in URL requests or a specific flag to inform it the message is binary.

If a binary message is sent from the mobile station attached to the test set with the following information:

  • Destination number: 54321
  • Message Content: 140601AE02056A0045C60D036262632E636F2E756B2F6D6F62696C65000701 03424243206D6F62696C652073697465000101
  • User Data Header: 0605040B8423F0
  • Protocol ID: 0
  • Data Coding Scheme: 245

The following URL request is sent by the test set to the receiving entity at the currently configured IP Address and Port Number:

/?PhoneNumber=54321&Data=140601AE02056A0045C60D036262632E636F2E756B2F6D6F62696C6500070103424243206D6F62696C652073697465000101&UDH=0605040B8423F0&PID=00&DCS=245&Binary=1&User=user535&Password=pass

Related Topics

HTTP SMS Router Web-based Configuration Interface


HTTP SMS Router Web-based Configuration Interface

HTTP SMS Router Web-based Configuration Interface

This section is only applicable to lab applications and the test application with a required feature license.

This section explains how to use the web-based interface provided for configuring the HTTP SMS Router for mobile originated SMS messages. To configure the HTTP Interface for Mobile Originated SMS, you must have an active LAN connection to the test set in order to access its http server. You can access the HTML pages for configuration via any standard internet browser.

  • Accessing the web-based HTTP SMS Router Interface
  • Current Configuration
  • Change Configuration
  • Configuration Error

Accessing the web-based HTTP SMS Router Interface

  1. Access the instrument homepage for your test by directing an internet browser to http://x.x.x.x, where `x.x.x.x' is the IP address of the test set to which the mobile station is attached that is sending the mobile originated message. The test set's homepage is displayed in the browser window, as shown below.

  2. Click on SMS (circled in red in the previous figure). This opens the HTTP SMS Router Current Configuration page.

Current Configuration

The current HTTP Interface Settings are summarized on the Current Configuration page. See Change Configuration for information on changing these settings.

NOTE
Although the enabled or disabled state of both the HTTP Input interface and the HTTP Output interface is displayed on the Current Configuration page, these settings cannot be changed using the web-based interface. For instructions on changing these settings, see Enable the Test Set's HTTP Interface .

Change Configuration

The following parameters are configured using the HTTP SMS Router Web-based Configuration Interface. For more detailed explanation of each of these parameters, see HTTP Interface Settings - General .

  • DUT Sender address
  • Other 8960 IP Address
  • Alternative Device Destination IP Address
  • Destination Port
  • Text Message URL
  • Binary Message URL
  • Request Method

Click on the Change button from the HTTP SMS Router Current Configuration page to access the HTTP SMS Router Change Configuration page.

The HTTP SMS Router Change Configuration page, shown in the figure below, allows changes to be made to the HTTP Interface Settings.

The HTTP SMS Router Change Configuration page is divided into two sections: General and Output Destination.

General

This section controls the number that is associated with the mobile station for messages output over the HTTP interface.

Output Destination

This section allows you to specify the destination for mobile originated SMS messages. If this is another test set, only the IP address of the destination test set is required for this section. For other destinations, such as an SMS Gateway running on a PC, more specific details are required.

Click the Apply Changes button to save any configuration changes you have made. The browser returns to the HTTP SMS Router Current Configuration page.

Alternatively, use the Cancel button to discard any changes you have made that you do not want saved.

Configuration Error

If any of the settings specified on the HTTP SMS Router Change Configuration page contain illegal values when the Apply Changes button is clicked, the HTTP SMS Router Configuration Error page is displayed. This page provides a description of the first error found when verifying the updated settings. Press the Back button to return to the HTTP SMS Router Change Configuration page to correct any errors.

Example Configuration Error page

Related Topics

HTTP Interface Configuration for Mobile Originated SMS


HTTP Interface Configuration for Mobile Terminated SMS

HTTP Interface Configuration for Mobile Terminated SMS

This section is only applicable to lab applications and the test application with a required feature license.

If you wish to use the HTTP interface in the test set to route SMS messages to the mobile station attached to the test set's RF port you must do the following:

  1. Enable the Test Set's HTTP Interface
  2. Specify the SMSC IP Address and Port
  3. Configure the Request URL

Enable the Test Set's HTTP Interface

You must enable the HTTP interface in the test set. This can be done via a GPIB command (see CALL:SMService:HTTProtocol:INPut ) or from the test set's front panel (see Enabling the HTTP Interface for Mobile Terminated SMS ).

If the interface is not enabled, HTTP SMS requests sent to the test set are rejected and the HTTP error code 503 (Service Unavailable) is returned to the client issuing the request.

Specify the SMSC IP Address and Port

Several different types of clients could be used to send SMS messages to the test set. Some examples are:

  • SMS Gateway
  • another test set
  • a custom http client

When setting up any of these clients, it is necessary to specify the IP Address and port number on which the test set is listening for incoming messages. These parameters are always to be configured as follows:

  • IP Address/Host Name: The IP address of the test set receiving the messages
  • Port number: 80

NOTE
When configuring an SMS Gateway, these parameters apply to the SMSC configuration. In a test system with more than one test set, each test set may be thought of as a separate SMSC and configured as such in the gateway.

Configure the Request URL

When using the HTTP interface in the test set for sending SMS messages, you must configure a request URL.

Requests to send SMS messages to the mobile station attached to the test set using the HTTP interface must be configured using the following rules:

  1. The request URL format accepted by the test set is:

    /sms/send/?parameter1=value1&parameter2=value2&parameter3=value3......

    NOTE
    "/sms/send/?" must be specified at the beginning of the request URL in order for the test set to recognize the HTTP request as a request to send an SMS message to the mobile station.

    The parameters and values variables provides the content of the SMS message as well as additional information for header configuration and test set configuration. All configurable parameters and values are detailed in Request URL Parameters .

  2. Mandatory parameters must be included in the request URL. The mandatory parameters depend on the content of the SMS message you are sending.
    SMS Message Content Type | Mandatory Parameters
    7-bit text | TEXT
    8 or 16 bit data | DATA and/or UDH
  3. An HTTP error code of 400 (Bad Request) is returned to the client initiating an HTTP request and the message is not forwarded on to the mobile station if one or both of the following is true:
    • any parameter values in the request URL do not adhere to the constraints detailed in Request URL Parameters , or
    • any mandatory parameters are not present.
  4. With the exception of SENDER, Optional parameters may be set equal to an empty value in the request URL. For example, if parameter2 is an optional parameter, then /sms/send/?parameter1=value1&parameter2=&parameter3=value3 is a valid request URL. The test set uses the default value for optional parameters when they have been set to empty values. If the SENDER parameter is included, it must be set to a sender address in the request URL. If you do not want to include a sender address with the message, leave out the SENDER parameter rather than setting it equal to an empty value.
    Optional Parameters
    UDHI
    PIDHEX or PID
    DCSHEX or DCS
    SENDER
    MMTS
    SRI
    RPATH
    TRANSPORT
  5. Parameters in the request URL can be in any order.
  6. When a text message is being submitted via the `TEXT' parameter, HTTP URL escaping restrictions apply. Therefore, all space characters must be replaced with the `%20' character sequence. Other characters that require escape characters when used in URLs are detailed in the following table.

    Character to URL Escape Sequence Mapping

    NOTE
    It is only necessary for you to use the escape characters when building a request URL manually. If you are sending messages to the mobile station through either an SMS gateway or from another 8960, the escaping is performed automatically.

Request URL Parameters

Parameter | Use and expected value | Inclusion
TEXT | 0-160 character string of 7-bit text characters. The underlying character codes specified here are used directly when sending the message OTA and will be interpreted by a receiving mobile station as per the ETSI default Alphabet specification. | This parameter must be included in all HTTP requests to send 7-bit text based SMS messages. It must not be included in the same request as either of the DATA or UDH parameters outlined below.
DATA | 0-280 ASCII formatted hex characters (the length of the combined UDH and DATA values must not exceed 280 characters) | One or both of these parameters must be included in all HTTP requests to send binary SMS messages. The UDH and data for a message may be encoded as a single hex string and specified via either of these parameters, or may instead be specified separately and sent via both parameters. Neither of these parameters may be present in the same request as the TEXT parameter outlined above.
UDH | 0-280 ASCII formatted hex characters representing the User Data Header to be included in the message content (the length of the combined UDH and DATA parameters must not exceed 280 characters)
UDHI | The User Data Header Indicator (TP-UDHI) of the message. Should be either 0 or 1 to indicate the presence of a User Data Header in the message content. If a UDH parameter (see above) containing a non-empty value is present in the request URL, the UDHI used when sending the message OTA is always 1 regardless of the presence/value of the this parameter. | Optional (Default = 0)
PIDHEX | The Protocol Identifier (TP-PID) of the message as a string of hex characters | Both of these parameters are optional but at most one may be included in any request. (Default = 0)
PID | The Protocol Identifier (TP-PID) of the message as a decimal number
DCSHEX | The Data Coding Scheme (TP-DCS) of the message as a string of hex characters | Both of these parameters are optional but at most one may be included in any request. (Default = 0)
DCS | The Data Coding Scheme (TP-DCS) of the message as a decimal number
SENDER | The phone number of the sending client as a 0 - 20 character ASCII formatted string of BCD digits from 0-9, *, #, a, b, c | Optional (Default = 1000)
MMTS | The More Messages to Send value for the SMS PDU header. Should be either 0 or 1. | Optional (Default = 1)
SRI | The Status Report Indication value for the SMS PDU header. Should be either 0 or 1. | Optional (Default = 0)
RPATH | The reply path value for the SMS PDU header. Should be either 0 or 1. | Optional (Default = 0)
TRANSPORT | The transport mechanism to use when sending the message, valid value is either `GSM' or `GPRS'. | Optional (Default = Whatever SMS transport is currently set for use in the instrument receiving the request)

Example request URL strings

Text message:

To send a text based SMS message with the following message details:

  • Originating number: 1001
  • Message Text: "This is a simple text message"

you would format the HTTP request URL as follows:

/sms/send/?TEXT=This%20is%20a%20simple%20text%20message&SENDER=1001

Binary message:

To send a binary message with the following message details:

  • Originating number: 987654321
  • Message Content: 140601AE02056A0045C60D036262632E636F2E756B2F6D6F62696C6500070103424243206D6F62696C652073697465000101
  • User Data Header: 0605040B8423F0
  • Protocol ID: 0
  • Data Coding Scheme: 245

you would format the HTTP request URL as follows:

/sms/send/?DATA=140601AE02056A0045C60D036262632E636F2E756B2F6D6F62696C6500070103424243206D6F62696C652073697465000101&PID=0&DCS=245&SENDER=987654321&UDH=0605040B8423F0

or, the test set also allows you to include the User Data Header as part of the `DATA' parameter as explained in the table Request URL Parameters . Therefore, the HTTP request URL could instead be configured as follows:

/sms/send/?DATA=0605040B8423F0140601AE02056A0045C60D036262632E636F2E756B2F6D6F62696C6500070103424243206D6F62696C652073697465000101&UDHI=1&PID=0&DCS=245&SENDER=987654321

Accepted HTTP request methods

Both POST and GET HTTP requests are accepted by the test set for sending SMS messages.

If POST is used as the request method, the URL request parameters detailed in Request URL Parameters are not included in the request URL, but are included in the request body instead. Therefore, the request URL in POST requests contains only `sms/send'.

Related Topics

HTTP Interface for SMS - Introduction


Logging SMS Messages

Logging SMS Messages

This section is only applicable to lab applications and the test application with a required feature license.

You can use the Wireless Protocol Advisor (WPA) to log SMS messages.

  • SMS Logging Control
  • Setting Up the Wireless Protocol Advisor (WPA)
    • SMS Message Log
    • Cell Broadcast Message Log

SMS Logging Control

The test set gives you access to the protocol layers necessary to allow you to observe the SMS cell broadcast and point-to-point messages. You can capture all the messages exchanged between either the LLC or the RR and these protocol layers:

  • CM - Connection Management
  • SMRL - Short Message Relay Layer
  • SMTL - Short Message Transport Layer

SMS Message Support

The messages in the following tables are examples of messages related to SMS. The table indicates whether each is supported in the test set. There may be more messages supported by the test set or by the Wireless Protocol Advisor. In addition, certain parameters in these messages may not be supported.

SMS Point-to-Point Messages
Messages | Supported
SMS_CP_DATA | Yes
SMS_CP_ERROR | Yes
SMS_CP_ACK | Yes
SMS_RL_MS2N_DATA | Yes
SMS_RL_N2MS_DATA | Yes
SMS_RL_MS2N_ERROR | Yes
SMS_RL_N2MS_ERROR | Yes
SMS_RL_MS2N_ACK | Yes
SMS_RL_N2MS_ACK | Yes
SMS_RL_MS2N_SMMA | Yes
SMS_TP_DELIVER | Yes
SMS_TP_SUBMIT_RPT | Yes
SMS_TP_STATUS_RPT | Yes
SMS_TP_DELIVER_RPT | Yes
SMS_TP_SUBMIT | Yes
SMS_TP_COMMAND | No
SMS GSM Layer 3 Cell Broadcast Messages
Messages | Supported
CB_BlockTypeFrame | Yes
User Configurable SMS Message Parameters
Mobile-Terminated SMS Parameters on Test Set | Parameters in 3GPP TS 23.040 | Message Types
Content | TP-User Data (TP-UD) - 9.2.3.24 | Deliver, Submit Report, Status Report
Message Type | TP-Message Type Indicator (TP-MTI) - 9.2.3.1 | Deliver, Submit Report, Status Report
Data Coding Scheme | TP-Data Coding Scheme (TP-DCS) - 9.2.3.10 (Defined in 3GPP TS 23.038) | Deliver, Submit Report, Status Report
Failure Cause | TP-Failure Cause (TP-FCS) - 9.2.3.22 | Submit Report if RP type is set to RP-ERR
Message Reference | TP-Message Reference (TP-MR) - 9.2.3.6 | Status Report
More Messages to Send | TP-More Messages to Send (TP-MMS) - 9.2.3.2 | Deliver, Status Report
Parameter Indicator | TP-Parameter Indicator (TP-PI) - 9.2.3.27 | Submit Report, Status Report
Protocol Identifier | TP-Protocol Identifier (TP-PID) - 9.2.3.9 | Deliver, Submit Report
Reply Path | TP-Reply Path (TP-RP) - 9.2.3.17 | Deliver
Status | TP-Status (TP-ST) - 9.2.3.15 | Status Report
Status Report Indication | TP-Status Report Indication (TP-SRI) - 9.2.3.4 | Deliver
User Data Header Indicator | TP-User Data Header Indication (TP-UDHI) - 9.2.3.23 | Deliver, Submit Report, Status Report
Originating Address | TP-Originating Address (TP-OA) - 9.2.3.7 | Deliver
Recipient Address | TP-Recipient Address (TP-RA) - 9.2.3.14 | Status Report
Mobile Originated Parameters
Mobile-Originated SMS Parameters available for query from the test set | Parameters in 3GPP TS 23.040
Coding Scheme | TP-Data Coding Scheme (TP-DCS) - 9.2.3.10 (Defined in 3GPP TS 23.038)
User Data Length | TP-User Data Length (TP-UDL) - 9.2.3.24
Destination | TP- Destination Address (TP-DA) - 9.2.3.8
Content | TP-User Data (TP-UD) - 9.2.3.24
Reference No. | TP-Message Reference (TP-MR) - 9.2.3.6
UDHI | TP-User Data Header Indication (TP-UDHI) - 9.2.3.23
Protocol Identifier | TP-Protocol Identifier (TP-PID) - 9.2.3.9
Status | TP-Status Report Request (TP-SRR) - 9.2.3.5

Setting Up the Wireless Protocol Advisor (WPA)

You can use the Wireless Protocol Advisor (WPA) to log the messages exchanged between the test set and the mobile station during SMS procedures. This tool provides a means to evaluate the mobile station's performance and to troubleshoot problems.

You can set up the WPA to capture and display as much or little information as you want. For this example, the logging filter is defined to capture only SMS protocol messages. The view filter is configured to only display the SMS CP-Data messages. This allows you to view only the messages that contain the SMS message contents being exchanged between the mobile station and the test set.

Note: The cell broadcast messages can be isolated by selecting SMSCB in the log filter or view filter.

Test Set Message Filter Setup

The test set filter is useful for limiting the amount of data sent over the LAN connecting the test set and the WPA. In the example below, all messages are sent from the test set to the WPA.

All filters are accessed from the Measurement Setup view. This can be accessed from the menu bar by clicking:

WPA Logging Filter Setup

The logging filter is useful for limiting what messages get captured in your log. Using this filter, you can choose to only log certain types of messages from certain protocol layers. In this example, we are using the logging filter to limit the captured log to SMS protocol messages.

WPA View Filter Setup

The view filter has no effect on what messages are captured. It simply limits the messages that are visible on the WPA's traffic overview. The view filter can easily be enabled and disabled by right clicking your mouse in the traffic overview and selecting View Filter Enabled from the menu that appears.

In the following view filter example, the messages in the traffic overview are limited to the CP-Data messages.

SMS Message Log

For the step-by-step procedure for setting up the test set to capture this log, refer to Mobile Originated Point-to-Point Message Transfer .

The captured log allows you to determine exactly what is being exchanged between the test set and the mobile station. In this example, an SMS message was sent from the mobile station to the test set. You can look in the decode of the captured message to verify all the parameters associated with that message. The following data is only a portion of the decode belonging to the captured message. In this data, you can see the text message that was sent to the test set. Look at the letters in Octet 28 after SM Value = in the Description column.

Octet | Binary | Hex | Description
27 | 00000110 | 06 | User Data Length=6 octet(s)
28 | 00100000 | c8 | SM Value = HELLO!
29 | 00100010 | 22 |
30 | 10010011 | 93 |
31 | 11111001 | f9 |
32 | 00001100 | 0c |
33 | 00000001 | 01 |

Cell Broadcast Message Log

Agilent's Wireless Protocol Advisor (WPA) allows you to capture the cell broadcast messages sent from the test set to the mobile station, and can be used to troubleshoot the handling of received messages. The figure below is a protocol log captured from WPA when the Cell Broadcast Service has been started and the repetition period is set to 15 seconds. The protocol log below shows the message activity necessary to transmit a 3-page cell broadcast message two different times. The test set only sends one page of the message to the mobile station at a time. The message decode of the selected message (dark blue) is shown in the bottom portion of the figure. The message decode shows several parameters, including the number of pages in the message as well as the page number of the selected page.

The figure below only shows a portion of the message decode. This page of the message contains 93 octets.

Related Topics

Protocol Logging

Protocol Layers and Messages

Short Message Service (SMS)

Cell Broadcast Service (CBS)

How to use the Short Message Service Features


Short Message Service (SMS) Messages

Short Message Service (SMS) Messages

This section is only applicable to lab applications and the test application with a required feature license.

Several Short Message Service (SMS) message options are available which allow you to choose or create the message content to be sent to the mobile station.

The Content parameter for SMS includes the following selections:

  • Text1 - see Predefined Point-to-Point Text Messages
  • Text2 - - see Predefined Point-to-Point Text Messages
  • Custom Text - see User Defined Text Message (Custom Text Message)
  • Custom Data - Defining the User Data (TP-UD) content for Binary SMS Applications

You can use the following GPIB command to select the content type to be used in mobile terminated SMS messages:

CALL:SMService:PTPoint[:MTERminated]:CONTents .

Predefined Point-to-Point Text Messages

There are two predefined point-to-point text messages. The ASCII text strings of these messages are as follows:

  • Predefined text message 1 ( Text1 ) -

    01234567890ABCDEFGHIJKLMNOPQRSTUVWXYZabcdefghijklmnopqrstuvwxyz

  • Predefined text message 2 ( Text2 ) -

    Agilent Technologies, your partner in wireless solutions.

User Defined Text Message (Custom Text Message)

You can also customize the text sent in the sms message using the Custom Text message. You can define the text for the custom message using the following GPIB command:

CALL:SMService:PTPoint[:MTERminated]:TEXT:CUSTom .

The custom text message can be defined only via the remote user interface. The maximum length for the user defined text messages is 160 characters.

The default custom text message is:

Enter your text here

NOTE
SMS text messages exchanged between the test set and the mobile station are encoded using the ETSI Default Alphabet character set. The ETSI Default Alphabet encoding shares the majority of its character codes with those used by the ASCII character set. Between the two character sets, all alphanumeric characters and most punctuation characters have identical codes.

For user defined text messages, the test set accepts a 7-bit ASCII string. This string is then encoded using the ETSI Default Alphabet before it is transmitted. The ASCII code for each character in this string is mapped to the ETSI Default Alphabet character with the same code. Characters present in the user defined text message whose ASCII and ETSI Default Alphabet codes are not identical will be received and displayed by the mobile station as the ETSI Default Alphabet character with the original ASCII character's code. This behavior is only noticeable with certain user defined text messages as all of the predefined text messages use only alphanumeric and basic punctuation characters.

Defining the User Data (TP-UD) content for Binary SMS Applications

Transmission of SMS messages necessary for concatenated and binary SMS applications like WAP Push, MMS notifications, ringtones, picture messaging, as well as character based languages such as Chinese, Japanese, and Hebrew that use UCS2 can be done by specifying the entire contents of the Deliver PDU's User Data field, including header information, in hexadecimal characters. You can define the content for the Custom Data parameter using the following GPIB command:

CALL:SMService:PTPoint[:MTERminated]:DATA:CUSTom .

The custom user data can be defined only via the remote user interface. The maximum length for the user data is 280 ASCII formatted hexadecimal characters.

The default custom user data is:

00

Related Topics

Short Message Service (SMS)

Point-to-Point SMS

Cell Broadcast Service (CBS)

How to use the Short Message Service Features

CALL:SMService


Multimedia Service (MMS) Messages

Multimedia Service (MMS) Messages

This section is only applicable to lab applications and the test application with a required feature license.

The Multimedia Service (MMS) is a WAP based application running on a wireless network. MMS makes use of the Short Message Service provided by the wireless network to notify the mobile station when an MMS is available for it to download from a server. Otherwise, MMS messages operate just like any other data transfer in the wireless network.

The test set can be used as a component in a system to verify the MMS capability of a mobile station. Other components required for such a system may include:

  • an SMS Gateway to generate and route the MMS notification message to a receiving mobile station,
  • an external software program simulating a Multimedia Service Center (MMSC) to act as the server and to generate the URL from which the MMS can be retrieved, and
  • a WAP Gateway to provide a means to download the compiled MMS from the MMSC

It is worth noting that for MMS verification, the HTTP or GPIB interfaces to the test set are only used for the mobile terminated (MT) SMS message containing the MMS notification. If you originate an MMS from the mobile station to an external receiving entity, the SMS protocol stack in the test set and therefore, the interfaces accessing that stack are never used.

MMS using the HTTP Interface

The HTTP interface in the test set provides a full IP based end-to-end test solution for MMS.

The test set's IP data channels (using either GPRS or CSD, depending on your configuration) are used to send MMS messages between the mobile station and an MMS server on a LAN/WAN.

The MMS Notification is a mobile terminated SMS message. See HTTP Interface Configuration for Mobile Terminated SMS for information on external software requirements and test set configuration.

MMS using the GPIB Interface

Similar to SMS, an external controller must parse the MMS notification into the appropriate GPIB commands for interfacing with the test set. An external MMSC is also required to exchange the MMS messages with the mobile station.

The MMS Notification is a mobile terminated SMS message. See Mobile Terminated SMS (MT SMS)- Sending a Message to the Mobile Station for information on external software requirements and test set configuration.

Related Topics

Point-to-Point SMS


Mobile Originated SMS (MO SMS)- Receiving Messages Transmitted by the Mobile Station

Mobile Originated SMS (MO SMS)- Receiving Messages Transmitted by the Mobile Station

Last updated: December 3, 2008

This section is only applicable to lab applications and the test application with a required feature license.

This section describes the test set's support for mobile originated short message service (MO SMS). The topics discussed in this section include:

  • Receiving Messages from the Mobile Station
  • Test Set Configuration for Mobile Originated SMS

Receiving Messages from the Mobile Station

Mobile Originated SMS messages are received by the test set after being transmitted over the air by the mobile station. The test set displays much of the content of these messages on the front panel, makes them available for query via GPIB, or when using the HTTP interface, acts as the SMSC and routes the message to a receiving entity. (See HTTP Interface Configuration for Mobile Originated SMS for more information about using the HTTP interface with MO SMS messages.)

  • Transportation
  • Last Received Message Parameters
  • Message Content (TP-User Data) Handling

Transportation

If the SMS message is originated by the mobile station, the transportation mechanism that was used by the mobile station is displayed on the front panel display and can also be queried (See CALL:SMService:PTPoint:MORiginated[:MESSage]:TRANsport? ).

As an example, in the following graphic you can see the details for the Last Received Message . Notice that the Transportation field contains the value GSM . This indicates that GSM protocol layers were used to deliver this message from the mobile station.

Last Received Message Parameters

The header and message elements of mobile originated SMS Submit messages made available to you by the test set are described below.

  • Coding Scheme
    • CALL:SMService:PTPoint:MORiginated[:MESSage]:DCSCheme?
  • Length
    • CALL:SMService:PTPoint:MORiginated[:MESSage]:LENGth?
  • Destination
    • CALL:SMService:PTPoint:MORiginated[:MESSage]:DESTination?
  • Content
    • See Message Content (TP-User Data) Handling for more information
    • CALL:SMService:PTPoint:MORiginated[:MESSage]:CONTents? or CALL:SMService:PTPoint:MORiginated[:MESSage]:TEXT?
  • Reference No
    • CALL:SMService:PTPoint:MORiginated[:MESSage]:MREFerence?
  • UDHI
    • CALL:SMService:PTPoint:MORiginated[:MESSage]:UDHind?
  • Protocol Identifier
    • available using GPIB only
    • CALL:SMService:PTPoint:MORiginated[:MESSage]:PIDentifier?
  • Status
    • See Status Report Mode
    • available via GPIB only
    • CALL:SMService:PTPoint:MORiginated[:MESSage]:SRRequest?
  • User Data Header Length
    • available via GPIB only
    • CALL:SMService:PTPoint:MORiginated[:MESSage]:UDHLength?

Message Content (TP-User Data) Handling

To provide uplink support for any format of message encoding, the content of all types of received MO SMS messages can be retrieved via GPIB. Unless predetermined, it is necessary to query a received message's format or data coding scheme results before determining how the contents should be interpreted.

The raw content of each MO SMS message received by the test set is made available for query as an ASCII formatted string of hex characters. This hex string represents the entire TP-UD from the message and includes any User Data Header and fill bits that may be present in the content. To aid in extracting any present header data from the content, the User Data Header Length query (see CALL:SMService:PTPoint:MORiginated[:MESSage]:UDHLength? ) is provided which returns the length (in bytes) of the received messages user data header. For example, if this query returns <x> then the first <x> * 2 characters of the returned hex string are the user data header.

For messages encoded as 7-bit text (with or without a User Data Header), a separate query is also provided to return the ASCII string representing the actual text in the message. Note that this returned string does not include any User Data Header or fill bits found in the original content, only the ASCII representation of the actual text in the message content is returned. This query returns an empty string for all non 7-bit text based messages received.

The following queries are provided for retrieving the contents of received MO SMS messages:

  • CALL:SMService:PTPoint:MORiginated[:MESSage]:CONTents? - for retrieving an ASCII formatted string of hexadecimal characters
  • CALL:SMService:PTPoint:MORiginated[:MESSage]:TEXT? - for retrieving a string of ASCII text characters

Test Set Configuration for Mobile Originated SMS

You can configure the following parameters in the test set to control handling of mobile originated SMS messages:

  • Message Loopback
  • Message Queue
  • Submit Report Mode
  • Status Report Mode
  • Submit Report Type

Message Loopback

This feature gives you the ability to simulate the complete transfer of an SMS message from an originating mobile station to a destination mobile station through the network. The test set takes the message it receives from the mobile station and sends it back to the mobile station.

This feature also allows you to perform basic tests on data formats such as binary or UCS2 as the data type received from the mobile station is returned to it using the loopback feature.

Message Queue

Individual messages from a larger concatenated message or otherwise may arrive at the test set within relatively short periods of time from one another. If an external controller responding to these messages via a polling or interrupt mechanism does not react quickly enough to the arrival of each message, it is conceivable that results for some individual messages may be overwritten in the test set before the controller has had time to extract them. In this scenario, messages can effectively be lost and it may not be possible to rebuild a complete concatenated message at the controller.

To provide complete test support for concatenated SMS, a queuing capability for MO SMS messages is provided in the test set via the GPIB interface.

Parameter | GPIB Command
Turn message queuing ON and OFF | CALL:SMService:PTPoint:MORiginated:QUEue[:STATe]
Extract the next message from the queue | CALL:SMService:PTPoint:MORiginated:QUEue:NEXT
Query the current number of messages in the queue | CALL:SMService:PTPoint:MORiginated:QUEue:COUNt?

Using the message queue

When MO SMS message queuing is ON, any received SMS-SUBMIT message from the mobile station are placed into a queue rather than overwriting existing results. The queue functions as follows:

  • You can extract messages from the queue in the order they were received from the mobile station. Only the results from the last message extracted from the queue are made available for query at any one time.
  • When a controller is finished reading the results for the current message it must inform the test set that it is finished with that message via the CALL:SMService:PTPoint:MORiginated:QUEue:NEXT command. When this command is received at the test set, the message at the head of the queue is extracted (if one exists) and its results become available for query. If no messages are present in the queue at this point then the previously available results are instead cleared.
  • When queuing messages, interrupts/polling function as follows:
    • If a message is received from the mobile station when no previous messages results are available (i.e. no previous messages have been received or a controller has indicated that it has finished reading ALL previously received messages) the newly received message's results are immediately made available for query and an interrupt is generated / polling bit is set to 1.
    • If a message is received from the mobile station when a previous message's results are still available then the message is added to the queue and no interrupt is generated/polling bit does not change (i.e. remains at 1).
    • Upon receipt of the CALL:SMService:PTPoint:MORiginated:QUEue:NEXT command informing the test set that the controller is finished reading the current message, the polling bit remains set if there was a message waiting in the queue, the results of which have now been extracted and are available for query. If no further messages were waiting in the queue at this point then the polling bit is cleared back to 0.
    • It should be noted that when queuing is `ON', no interrupts are ever generated for messages arriving at the test set when a previous messages results are still available. It is the users responsibility to make use of the polling bit to ensure such messages are all read by a controller before exiting an instance of the interrupt/polling procedure.

    NOTE
    When MO SMS message queuing is OFF, interrupts occur and the polling bit is set at the time each MO message is received from the mobile station. The polling bit used varies depending on the state of message queuing, if message queuing is ON then the CONDition bit should be used, if message queuing is OFF the EVENt bit should be used (which is cleared to 0 after being read). While message queuing is OFF, the CONDition bit is glitched (from 0 to 1 then back to 0) each time a message is received.

The maximum number of messages that can be present in the queue at any one time is 255 individual (non concatenated) messages. This guarantees queuing in the worst case for a single maximum size concatenated message regardless of external controller synchronization. In reality it is unlikely the queue will ever hold this many messages when used with the interrupt or polling mechanisms as the rate messages can be received from the mobile station is limited and a controller should be extracting and handling messages at a similar speed if not faster than they are received from the mobile station. In the case of a queue overflow, a GPIB error is returned and the newly arrived message is discarded. A status bit is included in the SMS STATus subsystem to enable interrupts/polling based on overflow of the queue, see STATus:OPERation:FEATures:COMMon:SMService Register Bit Assignments for further details.

Message queuing does not effect the operation of the existing MO loopback feature.

Related Topics

Mobile Terminated SMS (MT SMS)- Sending a Message to the Mobile Station


Responding to Mobile Originated SMS Messages

Responding to Mobile Originated SMS Messages

This section is only applicable to lab applications and the test application with a required feature license.

Submit Report and Status Report messages are both mobile terminated (MT) SMS messages sent in response to a request from the mobile station. The test set allows you to configure how it responds to these requests, either in a predetermined fashion or in a way that you specify. See the following sections for more details:

  • Submit Report Mode
  • Status Report Mode

Submit Report Mode

SMS-SUBMIT-REPORT messages are sent in response to a SMS-SUBMIT message from the mobile station to report either successful or unsuccessful reception of the message.

You can configure how the test set handles SMS-SUBMIT-REPORT responses. Two modes are available for use:

  • AUTO - SMS-SUBMIT-REPORT messages are sent automatically by the test set in response to SMS-SUBMIT messages received from the mobile station.
  • MANUAL - You control the sending of SMS-SUBMIT-REPORT messages in response to received SMS-SUBMIT messages from the mobile station. MANUAL mode allows you to specify the Submit Report Type. See Submit Report Type

Negative submit reports (sent via RP-ERR) are only explicitly sendable under the MANUAL mode of operation. When using AUTO mode, positive submit reports are sent (via an RP-ACK message) to the mobile station upon successful reception of a MO SMS message at the test set. If the test set cannot successfully receive the message (for example, if the message is corrupted) a negative submit report is returned with the relevant failure cause. It should be noted that when using AUTO mode, any value you have set for the TP-Failure Cause parameter is not used in constructing the submit report.

There are network (TR2N) and mobile station (TR2M) timers associated with the return of a SMS-SUBMIT-REPORT message. You should ensure that the time taken to respond to a SMS-SUBMIT message when using the MANUAL mode outlined above is well within the limits of these timers (by at least a couple of seconds) if a request to send an SMS-SUBMIT-REPORT is received at the test set out with these time constraints the message will not be sent to the mobile station and the error "+240: Operation rejected; Attempting to send SMS submit report after timer TR2N expired." is returned. Given the timing associated with MANUAL mode, it should only be used in conjunction with polling or interrupts.

When using MANUAL mode, it is important that the SMS-SUBMIT-REPORT message have the Message Reference and Recipient Address fields configured to match those of the mobile originated SMS-SUBMIT message to which it is responding. Without this information, the mobile station can not correlate the report to the correct message.

As an additional testing scenario for MANUAL mode, you may want to intentionally NOT send a submit report to the mobile station to force the timeout and verify your mobile station responds appropriately. This simulates the SMSC in a real network losing its ability to respond properly.

The following GPIB command is available for configuring the submit report mode:

CALL:SMService:PTPoint:MORiginated:REPort:MODE:SUBMit

Submit Report Type

  • RP-ACK - Positive submit report to indicate the MO SMS message was received correctly.
  • RP-ERROR - Negative submit report to indicate the MO SMS message was not received correctly and to return the TP-Failure Cause parameter. You can specify the value of this parameter to be returned to the mobile station. See Failure Cause for more information.

The following GPIB command is available for configuring the submit report type:

CALL:SMService:PTPoint[:MTERminated][:MESSage]:TYPE:SUBReport:RPTYpe

Status Report Mode

SMS-STATUS-REPORT messages are sent in response to a previous SMS-SUBMIT message from the mobile station which requested a status report. Requesting a status report is a mobile station feature. You may configure your mobile station to request a `receipt' or `report' for mobile originated messages. This is a mobile station configuration depending on how the feature is accessible from the user interface or proprietary interface.

Handling of SMS-STATUS-REPORT messages is configurable with two modes being provided for use:

  • AUTO - SMS-STATUS-REPORT messages are sent automatically by the test set in response to all SMS-SUBMIT messages received from the mobile station which request status reports.
  • MANUAL - You can configure the SMS-STATUS-REPORT messages sent in response to received messages from the mobile station. See Message Type for more information.

As the sending of status reports is an asynchronous event, the timing issues outlined in the previous section for submit reports is not relevant to the sending of status reports. The following setting is provided:

CALL:SMService:PTPoint:MORiginated:REPort:MODE:STATus .

Related Topics

Mobile Terminated SMS (MT SMS)- Sending a Message to the Mobile Station


Mobile Terminated SMS (MT SMS)- Sending a Message to the Mobile Station

Mobile Terminated SMS (MT SMS)- Sending a Message to the Mobile Station

Last updated: December 3, 2008

This section is only applicable to lab applications and the test application with a required feature license.

This section describes the test set's support for mobile terminated short message service (MT SMS). The topics discussed in this section include:

  • SMS Message State Synchronization
  • Transportation
  • Message Type
  • Operating Considerations
  • Sending a Text Message
  • Sending SMS messages for binary applications
  • Header Parameters
  • Message Parameters Managed by the Test Set

SMS Message State Synchronization

When sending SMS messages programmatically, you should use the SMS Message State query (see Mobile Terminated SMS Delivery Status for more information) to delay the sending of each message until the previous message has been acknowledged by the phone. If the command to send the message is received before the sending of a previous message has been acknowledged/rejected or timed out, the current message may not be sent.

Transportation

You can choose to send Point-to-Point SMS messages via either the GSM or GPRS protocol layers. The protocol layers to be used are configurable by specifying the transportation mechanism (See CALL:SMService:PTPoint[:MTERminated]:TRANsport ).

In the following graphic notice that the Transportation field in the Mobile Terminated SMS menu in the lower middle of the display is set to GPRS . This setting configures the test set to use GPRS protocol layers for delivering SMS messages to the mobile station.

Message Type

You can define the Message Type used for the SMS message sent from the test set to the mobile station. The Message types are defined as PDU types in 3GPP TS 23.040 Section 9.2.2. The Message types defined for MT SMS messages are:

  • Deliver - sending a short message from the network to the mobile station
  • Submit Report (not available when using the HTTP interface)- sends information as part of an acknowledgment to a Submit mobile originated (MO) SMS message. The header parameters in this Message Type are different depending on RP Type, which can be either RP-ERROR or RP-ACK. You can configure the value for this parameter in the test set (See CALL:SMService:PTPoint[:MTERminated][:MESSage]:TYPE:SUBReport:RPTYpe for GPIB command information.). When the RP Type is RP-ERROR a failure cause is included with other header information. The structure of Submit Report PDUs is defined in 3GPP TS 23.040 Section 9.2.2.2. Refer to Header Parameters for all the user configurable Submit Report elements.

    See Submit Report Mode for additional information about configuring Submit Reports.

  • Status Report (not available when using the HTTP interface)- sent in response to a previous SMS-SUBMIT message from the mobile station which requested a status report. Refer to Header Parameters for all the user configurable Status Report elements. Refer to Message Parameters Managed by the Test Set for the elements automatically configured by the test set.

    See Status Report Mode for additional information about configuring Status Reports.

Operating Considerations

Operating Mode and Connection Type

The operating mode must be Active Cell to send a mobile terminated SMS message.

The connection type must be Auto to send an SMS message to the mobile station.

GPRS

If you initiate a GPRS Point-to-Point mobile terminated SMS message while the mobile station is on a voice call, the request is rejected by the test set and the following message appears on the test set's front panel.

GPRS operation rejected; Attempting to send GPRS SMS message while DUT is not GPRS attached.

If the mobile station is not on a voice call, a new Packet Data Channel (PDCH) is created or an existing one is used to send the SMS message.

GSM

If you initiate a GSM Point-to-Point mobile terminated SMS message while the mobile station is on a voice call or if a data connection is established, the message is sent on the Slow Associated Control Channel (SACCH). Otherwise, if the mobile station is not on a voice call, GSM Point-to-Point SMS messages are sent on the Stand-alone Dedicated Control Channel (SDCCH).

Sending a Text Message

The default values for the message header parameters are appropriate for sending a text message. However, when sending a text message, you may want to configure whether the message is delivered through either GSM or GPRS protocol layers. See Transportation . You may also want to specify the text message sent to the mobile station. One of two predefined messages can be sent or you can define a text message yourself. See Short Message Service (SMS) Messages for more information on selecting and defining the content for text messages.

See Procedure A: Sending a Text Message to the Mobile Station for an example of how to send an ASCII Text Message to the mobile station using the front panel.

See The test set as the server: for a simple example of how to send an ASCII Text Message to the mobile station using the HTTP interface.

Sending SMS messages for binary applications

When sending messages using binary data, such as WAP Push, smart messaging, ringtones, or MMS notifications, you may want to configure some of the header values. All the parameters configurable using the test set are listed in Header Parameters .

You must configure the following parameters to successfully send a binary SMS message:

  • Data Coding Scheme (DCS)
  • User Data Header Indicator
  • Custom User Data - The Custom Data parameter is a hexadecimal string. This string, including the appropriate header information, or the UDH (User Data Header), may be generated using an SMS gateway, or you can create the string yourself. See Short Message Service (SMS) Messages for more information on selecting and defining this parameter.

Header Parameters

Unless otherwise noted, all the following parameters can be configured when you are using the HTTP interface as well as the GPIB and front panel interfaces.

  • Data Coding Scheme (DCS)
    • Used to identify the coding scheme used by the SMS message contents.

      NOTE
      There is no coupling between the Data Coding Scheme value and the content type selected to be included in mobile terminated SMS messages. See Short Message Service (SMS) Messages for more information on content type.

    • It is important for you to configure the Data Coding Scheme parameter in order for the mobile station to know what type of message it is receiving. Some examples of parameter values that you are likely to use are
      0 | ASCII Text Messages (concatenated or non-concatenated)
      4 | General binary messages (ringtones, vcards, bitmap picture messages, etc.)
      8 | UCS2 (Unicode) messages (Chinese, Japanese, Hebrew, etc.)
      245

      WAP Push and MMS notification messages

      247

      NOTE
      The Message Class for mobile terminated SMS messages is determined by two bits in the middle of the 8-bit DCS field. Therefore, the Message Class is determined by the value you specify for the DCS parameter.

    • Applicable to the following message types: Deliver, Submit Report, and Status Report. See Message Type for more information.
    • CALL:SMService:PTPoint[:MTERminated][:MESSage]:DCSCheme
  • Failure Cause
    • Used to identify the reason for the failure of a previous mobile originated short message.
    • Not available in HTTP interface because Submit Report message type is not supported
    • Applicable to the Submit Report message type only. RP type must be set to RP-ERR. See Message Type for more information.
    • CALL:SMService:PTPoint[:MTERminated][:MESSage]:FCAuse
  • Message Reference
    • Used to identify the previously submitted mobile originated short message.
    • Not available in HTTP interface because Status Report message type is not supported
    • if you are sending status reports via GPIB or the front panel, the Message Reference setting must be configured to match the value of the Message Reference of the mobile originated message to which you are responding.
    • Applicable to only the Status Report message type. See Message Type for more information.
    • CALL:SMService:PTPoint[:MTERminated][:MESSage]:MREFerence
  • More Messages to Send
    • This element is used to indicate to the mobile station if there are more messages waiting to be sent from the test set after the current message.
    • Applicable to the following message types: Deliver, Submit Report, and Status Report. See Message Type for more information.
    • CALL:SMService:PTPoint[:MTERminated][:MESSage]:MMTSend
  • Originating Address
    • Used to identify the sender of the message.
    • Applicable to only the Deliver message type. See Message Type for more information.
    • GPIB commands
      • CALL:SMService:PTPoint[:MTERminated][:MESSage]:OADDress
      • CALL:SMService:PTPoint[:MTERminated][:MESSage]:OADDress:HEXadecimal
      • CALL:SMService:PTPoint[:MTERminated][:MESSage]:OADDress:PLAN
      • CALL:SMService:PTPoint[:MTERminated][:MESSage]:OADDress:TYPE
  • Parameter Indicator
    • Used to identify the presence of optional elements within SMS-SUBMIT-REPORT and SMS-STATUS-REPORT messages. The value you specify for this parameter determines the inclusion of the Data Coding Scheme, User Data Length, and Protocol Identifier elements for all SMS-SUBMIT-REPORT messages sent from the test set.
    • Applicable to the following message types: Submit Report and Status Report. See Message Type for more information.
    • CALL:SMService:PTPoint[:MTERminated][:MESSage]:PINDicator
  • Protocol Identifier
    • Used to identify the higher layer protocol being used, or to indicate interworking with a particular type of telematic device.
    • Applicable to the following message types: Deliver, Submit Report, and Status Report. See Message Type for more information.
    • CALL:SMService:PTPoint[:MTERminated][:MESSage]:PIDentifier
  • Recipient Address
    • Used to identify the recipient of the previously submitted SMS message.
    • Not available in HTTP interface because Status Report message type is not supported
    • Applicable to only the Status Report message type. See Message Type for more information.
    • CALL:SMService:PTPoint[:MTERminated][:MESSage]:RADDress
    • CALL:SMService:PTPoint[:MTERminated][:MESSage]:RADDress:HEXadecimal
    • CALL:SMService:PTPoint[:MTERminated][:MESSage]:RADDress:PLAN
    • CALL:SMService:PTPoint[:MTERminated][:MESSage]:RADDress:TYPE
  • Reply Path
    • Used to indicate if a Reply Path exists.
    • Applicable to only the Deliver message type. See Message Type for more information.
    • CALL:SMService:PTPoint[:MTERminated][:MESSage]:RPATh
  • Status
    • Used to describe the status of the previously sent mobile originated short message.
    • not available in HTTP interface because Status Report message type is not supported
    • Applicable to only the Status Report message type. See Message Type for more information.
    • CALL:SMService:PTPoint[:MTERminated][:MESSage]:STATus
  • Status Report Indication
    • Used to indicate if a status report has been requested from the entity sending the SMS message to the mobile station.
    • Applicable to only the Deliver message type. See Message Type for more information.
    • CALL:SMService:PTPoint[:MTERminated][:MESSage]:SREPort
  • User Data Header Indicator
    • This header field indicates to the mobile station that the message content contains further header information. This should be set to 1 for any type of binary message, including concatenated text messages, as they also contain additional header information.
    • Applicable to the following message types: Deliver, Submit Report, and Status Report. See Message Type for more information.
    • CALL:SMService:PTPoint[:MTERminated][:MESSage]:UDHind
  • SMSC Address
    • The SMSC Address (RP-Originating Address) is used to identify the originating SMS Service Center address for MT transfer.
    • Applicable to the following message types: Deliver, Submit Report, and Status Report. See Message Type for more information.
    • GPIB commands
      • CALL:SMService:PTPoint[:MTERminated][:MESSage]:SADDress
      • CALL:SMService:PTPoint[:MTERminated][:MESSage]:SADDress:HEXadecimal
      • CALL:SMService:PTPoint[:MTERminated][:MESSage]:SADDress:PLAN
      • CALL:SMService:PTPoint[:MTERminated][:MESSage]:SADDress:TYPE

Message Parameters Managed by the Test Set

Some header parameters are automatically calculated by the test set and included in all SMS messages sent from the test set. These header elements are:

All MT SMS message types

  • Message Type Indicator (TP-MTI) - You can configure the message type used by the test set for MT SMS messages. The test set configures this parameter to reflect the Message Type that you have indicated. (See Message Type .) Since the HTTP interface only supports the Deliver message type for MT SMS messages, the value for this parameter always indicates the Deliver message type when the HTTP interface is used.
  • Service Centre Timestamp (TP-SCTS) - This element is configured to represent the time at which the test set received the command to send the message (either over GPIB or the front panel). (3GPP 23.040 Section 9.2.3.11)
  • User Data Length (TP-UDL) - This element is set by the test set to correctly describe the size of the user data (TP-UD) included in the message. This element may be omitted for Submit Report or Status Report message types depending on the value of the TP-Parameter Indicator parameter. (See Protocol Identifier ). (3GPP 23.040 Section 9.2.3.16)

Status Report message type

See Status Report Mode for more information about configuring how the test set sends Status Report messages.

  • Status Report Qualifier (TP-SRQ) - This header parameter is always included and is always set to 0, indicating the status report is the result of a Submit message from the mobile station. (3GPP 23.040 Section 9.2.3.26)
  • Discharge Time (TP-DT) - This header parameter is always included and always set to the current time. The current time is determined by the date and time set on the test set's System Config screen. See Configuring System Time and Date . (3GPP 23.040 Section 9.2.3.13)

Related Topics

Mobile Originated SMS (MO SMS)- Receiving Messages Transmitted by the Mobile Station

Short Message Service (SMS) Messages

Mobile Terminated SMS Delivery Status

Logging SMS Messages

How to use the Short Message Service Features


Point-to-Point SMS

Point-to-Point SMS

This section is only applicable to lab applications and the test application with a required feature license. Note, the Test Application support text only single message for Mobile Originated and Mobile Terminated Point to Point SMS even without a feature license.

The Short Message Service (SMS) as specified in 3GPP TS 23.040 version 3.9.0 provides a means for the exchange of short messages between mobile stations and a network. The test set can simulate an SMSC (Short Message Service Center) which provides for the transmission of short messages to, or reception of short messages from an intended mobile station, and the return of acknowledgments and error messages.

The test set supports the two services that comprise SMS:

  • Mobile Terminated SMS (MT SMS)- Sending a Message to the Mobile Station
    • MT SMS are SMS messages sent to the mobile station.
    • The test set allows you to specify several SMS message parameters, including the type of message, the content, and header parameters. This allows you to send SMS messages of various usages and configurations.
    • See Mobile Terminated Point-to-Point Message Transfer for simple examples to get started.
  • Mobile Originated SMS (MO SMS)- Receiving Messages Transmitted by the Mobile Station
    • MO SMS are SMS messages sent by the mobile station.
    • See Mobile Originated Point-to-Point Message Transfer for simple examples to get started.

Interfaces for Point-to-Point SMS

The test set provides two interfaces for point-to-point SMS:

  • HTTP Interface
  • GPIB Interface

These interfaces provide methods for you to control and access SMS messages sent to and received from the mobile station. These interfaces are a requirement for the test set to be able to communicate with external components used in any system for verifying the SMS capability of a mobile station.

The majority of parameters available through the GPIB interface are also accessible from the test set's front panel.

HTTP Interface

The HTTP Interface in the test set allows you to configure SMS message parameters and content, send, and receive SMS messages using HTTP protocol. This interface is useful for SMS verification because HTTP protocol is used by most commercially available SMS Gateways. The HTTP interface also allows SMS Gateways to be configured as if the test set is a Short Message Service Center (SMSC), eliminating the need for custom external software to route messages to the correct test set. This emulation of an SMSC makes it possible to route messages directly from the HTTP output interface of one test set to the HTTP input interface of another test set. Additionally, the HTTP interface also facilitates MMS message transfer to and from a mobile station if used in conjunction with compatible MMSC (Multimedia Message Service Center) software.

For more information on this interface in the test set, see the following sections:

  • HTTP Interface for SMS - Introduction
  • HTTP Interface Configuration for Mobile Terminated SMS
  • HTTP Interface Configuration for Mobile Originated SMS
  • Multimedia Service (MMS) Messages

GPIB Interface

There is also a GPIB interface for configuring SMS message parameters and content and sending and receiving SMS messages, acknowledgments, and error messages. The GPIB interface provides support for Deliver, Submit, Deliver Report, Status Report, and Submit Report message types.

When using the GPIB interface, you need to generate your own message content and set the correct header parameters for each message you send.

You may still use the GPIB interface with an SMS Gateway. To accomplish this, you must create an external software program to translate between GPIB and a protocol supported by the SMS Gateway.

  • Mobile Terminated SMS (MT SMS)- Sending a Message to the Mobile Station
  • Mobile Originated SMS (MO SMS)- Receiving Messages Transmitted by the Mobile Station

Related Topics

Mobile Terminated SMS (MT SMS)- Sending a Message to the Mobile Station

Mobile Originated SMS (MO SMS)- Receiving Messages Transmitted by the Mobile Station

Short Message Service (SMS)

Cell Broadcast Service (CBS)

Short Message Service (SMS) Messages

How to use the Short Message Service Features

CALL:SMService


Mobile Terminated SMS Delivery Status

Mobile Terminated SMS Delivery Status

This section is only applicable to lab applications and the test application with a required feature license.

The test set provides the delivery status of mobile terminated SMS messages on the front panel, or it is accessible via the GPIB or HTTP interfaces.

  • MT SMS Message States
  • Using the GPIB Interface
  • Using the HTTP Interface
  • Reject Cause

MT SMS Message States

There are six possible MT SMS message states.

  • "IDLE" - An SMS message has not been successfully sent from the test set since power-up, preset, or SMS clear.
  • "SEND" - The test set has initiated the process of sending an SMS message.
  • "ACK" - The SMS message sent by the test set was acknowledged by the mobile station before timeout.
  • "NACK" - The SMS message sent by the test set was NOT acknowledged by the mobile station and send timeout.
  • "REJ" - The SMS message sent by the test set was rejected by the mobile station. A cause value for the reject is also reported by the mobile station. See Reject Cause .
  • "FAIL" - A command to send an SMS message has been received by the test set, but it cannot send the SMS message over the air because of an error. An example of a situation that would produce such an error is if the mobile station is not connected to the test set.

Using the GPIB Interface

The CALL:SMService:PTPoint[:MTERminated]:SEND:STATe? query returns a string indicating the state of the last message sent from the test set to the mobile station.

If the delivery status returned is "REJ", you can use the CALL:SMService:PTPoint[:MTERminated]:RCAuse? query to retrieve the reject cause value returned by the mobile station. See Reject Cause for the meanings of the possible cause values.

Using the HTTP Interface

The state of the last MT SMS message sent from the test set to the mobile station can be queried from the test set using an HTTP GET request with the following URL:

/sms/mtstate

The delivery state is returned in the body of the HTTP response.

Example using an internet browser

You can query the MT SMS delivery state through the HTTP interface using an internet browser by entering the following URL:

http://<x.x.x.x>/sms/mtstate

where <x.x.x.x> is the IP address of the test set sending the SMS to the mobile station. This example is illustrated in the following figure.

If the state returned is "REJ", the body of the HTTP response also contains the reject cause value as an integer. The reject cause value is placed in the response body after the REJ characters and separated from them by a single space character. For example, "REJ 211" is returned in the HTTP response if the MT SMS was rejected with a cause value of 211. See the following figure.

See Reject Cause for the meanings of the possible cause values.

Reject Cause

Reject Cause | Hex equivalent | Description
129 | 81 | Short message Type 0 not supported
130 | 82 | Cannot replace short message
143 | 8F | Unspecified TP-PID error
145 | 90 | Message class not supported
159 | 9F | Unspecified TP-DCS error
176 | B0 | TPDU not supported
208 | D0 | (U)SIM SMS storage full
209 | D1 | No SMS storage capability in (U)SIM
210 | D2 | Error in MS
211 | D3 | Memory Capacity Exceeded
212 | D4 | (U)SIM Application Toolkit Busy
213 | D5 | (U)SIM data download error
224-254 | E0-FE | Values specific to an application
255 | FF | Unspecified error cause

Related Topics

Mobile Terminated SMS (MT SMS)- Sending a Message to the Mobile Station


Supplementary Services Pipe

Supplementary Services Pipe

This section is only applicable to the lab applications.

The Supplementary Services (SS) Pipe allows the initiating of an SS procedure and the sending/receiving of raw SS pipe data. The SS procedure started by the SS pipe may be independent of any call. For SS procedures independent of any call, the initiating side will establish a MM connection between the network and the MS according to the rules given in 3GPP TS 24.007 and 3GPP TS 24.008.

Before using the SS pipe, the SS pipe mode must be enabled via the RUI. After enabling the SS pipe, an MM Connection (either MO or MT) will be established first for sending or receiving the binary SS messages. Once an MM connection is established, it allows the sending and receiving of `raw' layer 3 SS messages. These messages will include PD (Protocol Discriminator), TI (Transaction Identifier), Message Type and FACILITY IE. Also the MM connection allows the RRLP messages to be sent/received via the RRLP pipe. See 3GPP TS 24.080 for the SS pipe message formats, TS 24.010 for the SS pipe message contents.

The Supplementary Services (SS) Pipe, along with the RRLP pipe (See RRLP Configuration ), allows the implementation of a Location Services (LCS) system. Location Services may be considered as a network provided enabling technology consisting of standardized service capabilities, which enable the provision of location applications. Currently, the SS pipe supports both MT-LR (Mobile Terminated Location Request) and MO-LR (Mobile Originated Location Request).

Mobile Terminated SS pipe Operation

A typical sequence for MT SS pipe operation is:

  1. Enable SS Pipe mode, using CALL:SSERvice:PIPE .
  2. Enable MM connection, using CALL:SSERvice:PIPE:MMConnect . Note, this command will not establish a new MM connection if one is already present, the existing MM connection will be reused instead of establishing a new one.
  3. Send the first SS message down the SS pipe, using CALL:SSERvice:PIPE[:DATA]:TX to set the binary SS message to be sent and CALL:SSERvice:PIPE[:DATA]:TX:SEND to send the SS message to the mobile via SS pipe. Note, this message must be a REGISTER SS message.
  4. Receive and Send SS messages via the SS pipe, using CALL:SSERvice:PIPE[:DATA]:RX:AVAilable? to query if unread SS Tx data are available and CALL:SSERvice:PIPE[:DATA]:RX? to query the latest binary SS message received from the mobile. To send the SS messages, using the GPIB commands as Step 3.
  5. Send and Receive RRLP messages via the RRLP pipe which use the MM connection established for theSS pipe. (See RRLP Configuration .)
  6. Send a RELEASE SS message down the SS pipe, using the GPIB commands as Step 3.
  7. Disable the MM connection, using CALL:SSERvice:PIPE:MMConnect .
  8. Disable the SS pipe mode, using CALL:SSERvice:PIPE .

Mobile Originated SS pipe Operation

A typical sequence for MO SS pipe operation is:

  1. Enable SS Pipe mode, using CALL:SSERvice:PIPE .
  2. The phone initiates the MM connection with a CM service request. (If the phone sends a "Supplementary service activation" CM SERVICE REQUEST, then a new MM connection will be established if a call is not in progress.)
  3. Phone sends first SS message this message will be a REGISTER SS message. This will be available onGPIB out the SS pipe.
  4. Receive and Send SS messages via the SS pipe, using CALL:SSERvice:PIPE[:DATA]:RX:AVAilable? to query if unread SS Tx data are available and CALL:SSERvice:PIPE[:DATA]:RX? to query the latest binary SS message received from the mobile. To send the SS messages, using the GPIB commands as Step 3.
  5. Send and Receive RRLP messages via the RRLP pipe which use the MM connection established for the SS pipe. (See RRLP Configuration .)
  6. Phone sends RELEASE SS message down the SS pipe which will terminate the MM connection as well.
  7. Disable the SS pipe mode, using CALL:SSERvice:PIPE .

Operating Considerations

The SS pipe is only available in the ACTIVE CELL operating mode.

The SS procedure started by the SS pipe is not supported in PS domain.

The SS pipe mode can only be enabled via the RUI. When enabled the SS pipe:

  • When an MM connection started by the SS session is active it is not possible to initiate any new voice calls.
  • If a call is in progress, then the SS session utilizes the existing MM connection and send/receive SS and RRLP data via the existing FACCH channel.
  • If the SS session is utilizing the FACCH channel and the call is terminated, the MM connection will be hold on until the SS session is finished.
  • When an SS RELEASE message is sent on the SS pipe from either the test set or mobile, the MM connection started by the SS session is terminated.
  • There is a user settable inactivity timer on the SS session which terminates the MM connection started by the SS session. The inactivity timer resets on data sending/receiving from the mobile via the SS pipe or the RRLP pipe. using CALL:SSERvice:PIPE:TIMeout to set the timer. The RRLP pipe response timer (see CALL:PPRocedure:PMEasurement:PIPE:RTIMe ) is disabled when the SS pipe has established the MM connection.

Related Topics

RRLP Configuration


Neighbour Cell Synchronization Trigger

Neighbour Cell Synchronization Trigger

The neighbour cell synchronization trigger is useful for synchronizing other network simulating equipment to the test set for E-OTD testing. See E-OTD (Enhanced Observed Time Difference) for more information.

This trigger is provided at the rear panel TRIG OUT connector.

Trigger Control

Control of the synchronization trigger is available only by using a GPIB command. There is one configurable parameter which allows you to determine when the trigger is fired. See CALL:TRIGger[:OUTPut]:FRAMe:SYNChronize:OFFSet .

Trigger Timing

After the test set receives the GPIB command to generate the synchronization trigger, the test set's frame count is set to 2715448. This frame occurs 200 frames before the end of the hyperframe. When the trigger is generated depends on the offset you have specified. If no offset is defined, the trigger is generated when the first symbol of the next hyperframe occurs which is when the frame count becomes 0. Otherwise, the trigger is generated before the first symbol of the next hyperframe by the number of symbols specified in the offset.

Operating Considerations

Operating Mode

You can use the synchronization trigger in the following operating modes:

  • Active Cell
  • GSM BCH
  • GPRS BCH
  • GSM BCH + TCH
  • GPRS BCH + PDTCH

Interaction with other triggers

It is important to ensure that the other triggers provided by the test set are disabled before sending the synchronization trigger. An additional signal at the trigger output interferes with the synchronization process.

Use the CALL:TRIGger[:OUTPut][:ALL]:STATe:OFF to disable all triggers before sending the synchronization trigger command.

Related Topics

CALL:TRIGger[:OUTPut]:FRAMe:SYNChronize

CALL:TRIGger[:OUTPut]:FRAMe:SYNChronize:OFFSet

E-OTD (Enhanced Observed Time Difference)

RRLP Configuration

Demodulation Trigger Delay


UMA/GAN Test System

UMA/GAN Test System

This section is only applicable to the lab applications.

The UMA/GAN Test System is intended for use in lab based functional, application, and pre-conformance testing of dual mode enabled UMA/GAN handsets.

  • UMA/GAN Concept
  • UMA/GAN Typical Test Configuration
  • UMA/GAN related procedures
  • UMA/GAN Parameters

UMA/GAN Concept

The Unlicensed Mobile Access (UMA) is an extension of GSM/GPRS mobile services into the customer's premises. It is achieved by tunnelling GSM/GPRS protocols through a broadband IP network and an unlicensed radio link in the customer's premises. Additional protocols control and manage the UMA access network, and carry bearer traffic over IP. UMA is therefore a complement to traditional GSM/GPRS radio coverage - used to enhance customer premises coverage, increase network capacity and potentially lower costs.

The first UMA specifications were published in September 2004 (R1.0.0). After the initial release, the UMA specifications were contributed to the 3GPP organization as part of 3GPP work item "Generic Access to A/Gb interfaces". On 8th April 2005, the 3GPP approved specifications for Generic Access to A/Gb interfaces for inclusion in 3GPP Release 6 (3GPP TS 43.318). There were only trivial terminology changes made to the UMA protocol and architecture specifications during the transition to 3GPP.

Under 3GPP, what was previously known as UMA is now instead referred to as Generic Access Network or GAN and the UMA Network Controller (UNC) entity is instead referred to as a Generic Access Network Controller or GANC.

The following figure gives the functional architecture of a Generic Access Network.

Two new entities are introduced by the GAN architecture:

  • UMA/GAN-enabled and dual-mode mobile station. The mobile station must be able to run procedures that detect when the user is roaming in and out of a Bluetooth or Wi-Fi network so that it can switch to and from GERAN mode.
  • Generic Access Network Controller (GANC). The GANC is equivalent in function to a Base Station Controller in a typical GERAN network; unlike a BSC however, the front end of the GANC connects to the MS via an IP access network. The GANC essentially acts as a bridge between the Bluetooth/Wi-Fi and cellular network. The GANC also includes a Security Gateway (SEGW) that terminates secure remote access tunnels for the mobile station, providing mutual authentication, encryption and data integrity for signalling, voice and data traffic.

UMA/GAN Typical Test Configuration

The figure above provides a pictorial overview of the system, the premise of which is to provide integrated lab based emulation of both a GERAN cell and a GAN "cell" for use by a connected MS. The system is designed to allow a connected MS to make either GERAN or GAN based voice, data and signaling connections as well as to exercise all applicable GAN <-> GERAN mode transitions. The system achieves this aim through simulation or inclusion of all real-world network components that are required for such procedures.

The UMA/GAN test system is comprised of the following components:

  • A test set running E6701F Lab Application Firmware.

    The system is built around the test set's existing capabilities to provide GERAN cell and core mobile network emulation. All existing controls at the test set to configure its GERAN cell and control core PLMN operation (voice call initiation, SMS, data routing etc.) remain available for use within the system as per their existing behavior in the test set.

  • One or more commercial or proprietary WLAN or Bluetooth access point.

    There are no changes required to off-the-shelf wireless access points for use in UMA/GAN, the only recommendations are that for voice operation and battery life optimization; access points that support QoS features are likely to exhibit better performance.

  • Zero or more commercial or proprietary SEGWs and AAA servers.
  • A standard PC running proprietary Agilent GANC software.

    To aid in simulation of the GAN `cell' in the system, Agilent provide proprietary test focused GANC emulation software for use with the system. This software is capable of communicating with a connected MS using the standardized GAN Up interface protocols, namely GA-RC, GA-CSR, and GA-PSR. The Agilent GANC also connects the test set in the system to make use of its core network capabilities via the same BSSAP & BSSGP protocols that are designed for this purpose in a real network (although these are run over a proprietary IP connection in the system rather than SS7 as would normally be used). The combination of these interfaces at the GANC allow a connected MS to fully make use of the GANC for accessing the test set's core network to perform GAN based speech, data and signaling procedures.

  • Any number of further networked devices (typically PCs) running network servers such as FTP, HTTP, MMSC etc. for use in end to end GAN data throughput and application test of the handset, and
  • A dual-mode GAN enabled handset.

Note: Only the test set, its associated firmware and the GANC application software in such a system are supplied by Agilent. All other components must be supplied and configured independently by yourself.

UMA/GAN related procedures

The procedures supported in the UMA/GAN Test System include:

  • GAN Discovery
  • GAN Registration
  • GAN Register Update procedures
  • GAN Deregister procedures
  • GAN vs. GERAN mode selection.
  • MO and MT voice calls via GAN
  • MO and MT GSM SMS via GAN (including binary / concatenated messages)
  • MO and MT GPRS SMS via GAN (including binary / concatenated messages)
  • Cell Broadcast SMS via GAN
  • GPRS Packet Paging via GAN
  • Speech Ciphering via GAN
  • GPRS IP data connections via GAN
  • GAN Rove-in / Rove-out procedures
  • Network initiated handover from GERAN to GAN (Handover-in)
  • MS/GANC initiated handover from GAN to GERAN (Handover-out)
  • Network initiated handover from GAN to GERAN
  • GPRS cell change order (GAN to GERAN)
  • View MS reports sent to GANC
  • View current MS GAN status
  • GAN protocol logging via Ethereal (a free third party software), cellular signaling and traffic logging via WPA.

See UMA/GAN Procedures Ladder Diagrams for the message sequence chart of UMA/GAN related procedures.

Refer to the user guide of GAN Controller (E6962A) for details on how to perform the above test procedures.

UMA/GAN Parameters

  • Access Stratum reporting

    This parameter is used to report the current access stratum in use by a connected mobile station. This is the only parameters on the test set side.

    The GPIB command to set this parameter is CALL:ASTRatum? .

  • GANC configuration and report parameters.

    Refer to the user guide of GAN Controller (E6962A).

Operating Considerations

The existing data throughput monitor at the test set can be used in the UMA/GAN test system to monitor data connections made by the MS over both GAN and GERAN access stratums.

The Wireless Protocol Analyzer can log the GERAN signaling and traffic protocols. For GAN logging, you can choose Wireshark (formerly known as Ethreal). Wireshark is a free network protocol analyzer widely used throughout the communications and IT industry. Wireshark provides very good support for logging all GAN signaling and user data messages sent between the MS and GANC and also does a pretty good job of decoding any embedded GERAN core network destined messages contained within them.

Transmitter and Receiver Measurements are available at all times at the test set in the test system as per existing test set's behavior. However, the measurement results are only available at the test set when the MS is operating in GERAN mode as otherwise there is no RF channel available to measure.

Related Topics

How to use the UMA/GAN Features


How to Configure Access Burst Power Control

How to Configure Access Burst Power Control

Last updated: December 4, 2008

  1. Press the Call Setup key.
  2. Press BCH Parameters ( F7 ). The menu on the right now displays the BCH Parms.
  3. Press Cell Band ( F8 ) and select the appropriate cell band from the popup menu.
    NOTE

    If you selected DCS, please see How to Configure Access Burst Power Control for DCS for configuration instructions for the DCS 1800 band.

  4. Press Operating Mode ( F1 ) and select Cell Off from the popup menu. The configurable parameters for controlling access burst power are only available when the test set's operating mode is Cell Off .
  5. Select Cell Info ( F6 ).
  6. Select Cell Parameters ( F2 ).
  7. Scroll to MS TX Power Max CCH (GSM or GPRS) and select it.
  8. Scroll or use the keypad to enter the power level you want. Once you've entered a new value, notice that the value the Cell Parameters area of the Cell Info screen displays changes to match the power level you've specified.

    For example, If the Cell Band is set to PGSM, and you set the MS TX Power Max CCH (GSM) to level 7 (which corresponds to 29 dBm), the maximum power the mobile station is allowed to transmit on the contol channel is 29 dBm.

  9. Press Close Menu ( F6 ) and then Return ( F6 ).
  10. Press Operating Mode ( F1 ) and select Active Cell from the popup menu.

Related Links

Access Burst Power Control


How to Configure Access Burst Power Control for DCS

How to Configure Access Burst Power Control for DCS

  1. Press the Call Setup key.
  2. Press BCH Parameters ( F7 ). The menu on the right now displays the BCH Parms.
  3. Press Cell Band ( F8 ) and select DCS from the popup menu.
  4. Press Operating Mode ( F1 ) and select Cell Off from the popup menu. The configurable parameters for controlling access burst power are only available when the test set's operating mode is Cell Off .
  5. Select Cell Info ( F6 ).
  6. Select Cell Parameters ( F2 ).
  7. Use the knob to scroll to MS TX Power Max CCH (GSM or GPRS) , press the knob to select it.
  8. Scroll or use the keypad to enter the power level you want.
    Once you've entered a new value, notice that the value of MS TX Pwr Max CCH in the Cell Parameters area of the display changes to match the power level you've specified.
    NOTE

    If you want to set the power to correspond to levels 29, 30, or 31, leave the MS TX Pwr Max CCH parameter set at 0.

  9. Scroll to DCS1800 Max CCH Power Offset and select it. The parameter area should become white.
  10. Scroll to or use the keypad to enter the value you want. See MS TX Power Max CCH DCS1800 Offset for more information.
    Once you've entered a value, notice that the value of MS TX Pwr Max CCH in the Cell Parameters area of the display changes according to the value you've chosen.

    For example, If the Cell Band is set to DCS, and you have set the MS TX Power Max CCH (GSM) to power level 0 (power level 0 is 30 dBm) and MS TX Power Max CCH DCS1800 offset to level 3 (which corresponds to a 6 dBm offset). Therefore, the maximum power the mobile station is allowed to transmit on the contol channel is 36 dBm.

  11. Press Close Menu ( F6 ) and then Return ( F6 ).
  12. Press Operating Mode ( F1 ) and select Active Cell from the popup menu.

Related Links

Access Burst Power Control


How Do I Access the Medium Access Control (MAC) Parameters?

How Do I Access the Medium Access Control (MAC) Parameters?

Last updated: December 3, 2008

This section is only applicable to the lab applications.

You can configure the medium access mode used and the associated parameters from the front panel using the following procedures.

Procedure

  1. Press the CALL SETUP key.
  2. Press Operating Mode (F1) and select Active Cell with the serving cell as GSM, GPRS, or EGPRS.
  3. Press Data Conn Type ( F2 ) and select Auto.
  4. Press the left More key to advance to Control menu ( 2 of 3 ).
  5. Select Protocol Control ( F4 ).
  6. Select RLC/MAC ( F2 ).
  7. Select MAC Control ( F2 ). The MAC Control menu appears with all the configurable parameters.
  8. The MAC Control menu appears, see Configurable Parameters section of the Medium Access Mode description for more information on the parameters in the MAC Control menu.

Related Links

Medium Access Mode


How to use the Adaptive Multi-Rate (AMR) and Wideband AMR (AMR-WB) Features

How to use the Adaptive Multi-Rate (AMR) and Wideband AMR (AMR-WB) Features

Last updated: December 3, 2008

This section is only applicable to lab applications and the test application with a required feature license.

This section describes general front panel procedures for using AMR and AMR-WB features. Use the protocol logging capability of the test set to observe the messages that occur between the mobile station and the test set. For help setting up the Wireless Protocol Advisor (WPA) for protocol logging see Protocol Logging . For help deciphering which layers to analyze to verify the following tests see Logging Adaptive Multi-Rate (AMR) and Wideband AMR (AMR-WB) .

  • General AMR and AMR-WB Parameter Setup
  • Check the Validity of Encoded Speech Data
  • Change the Codec During a Call
  • Stress Testing with Frequent Changes of Codec Mode
  • Forcing Codec Mode Requests
  • Change Parameters using RATSCCH
  • Discontinuous Transmission (DTX)
  • Handovers While an AMR or AMR-WB Call is Active

General AMR and AMR-WB Parameter Setup

  1. Press the CALL SETUP
  2. Select Operating Mode ( F1 ), and choose Active Cell (GSM, GPRS, or EGPRS) .
  3. Select Data Conn Type ( F2 ), and choose Auto .
  4. Select TCH Parameters ( F8) .
  5. Select Channel Mode Setup ( F11 ). This should change the Call Parms section label to Channel Mode .
  6. Select Channel Mode Config ( F7 ).
  7. Select (AFS) Adaptive Full , (AHS) Adaptive Half, or (WFS) Wideband Full from the Channel Model Configuration menu. Options corresponding to the Logical Speech Channel type chosen, automatically appear under the Channel Mode menu.
  8. Depending on the Logical Speech Channel chosen in the previous step, Select AFS Codec Setup ( F8 ), AHS Codec Setup ( F8 ), or WFS COdec Setup ( F8 ).
  9. Choose the desired codecs as well as the Threshold and Hysteresis values and the Current Codec .
    NOTE

    If less than four codecs are desired in the codec set for AHS or AFS , or less than three codes are desired in the codec set for WFS , select Unused in the menu of codec options.

  10. Select Apply Changes ( F5 )

Check the Validity of Encoded Speech Data

The purpose of this test is to verify that the mobile station correctly encodes and decodes speech data for various codec modes.

  1. Setup the General AMR or AMR-WB Parameters. See General AMR and AMR-WB Parameter Setup .
  2. Select Originate Call ( F3 ) to make a mobile terminated call or originate a call from the mobile station to make a mobile originated call.
  3. Speak into the microphone of the mobile station. Anything spoken into the microphone will be heard coming out of the microphone after a brief delay.

Change the Codec During a Call

The purpose of this test is to verify that a mobile station is responding to codec mode changes within a specified number of speech frames.

  1. Setup the General AMR or AMR-WB Parameters. See General AMR and AMR-WB Parameter Setup .
  2. Select Originate Call ( F3 ) to make a mobile terminated call or originate a call from the mobile station to make a mobile originated call.
  3. Start Protocol Logging. See How to use Protocol Logging .
  4. While the call is connected, select Current Codec ( F9 ) and change the field to a different codec mode.
  5. To verify that a codec was changed while a call existed, capture a protocol log of the procedure using Wireless Protocol Advisor (WPA). For more information see Verify a Codec Mode Change During a Call .

Stress Testing with Frequent Changes of Codec Mode

The purpose of this test is to verify that the mobile station is capable of responding to frequent changes of the codec mode in a specified manner by frequently changing codec modes in the downlink.

  1. Setup the General AMR or AMR-WB Parameters. See General AMR and AMR-WB Parameter Setup .
  2. Start Protocol Logging. See How to use Protocol Logging .
  3. Select Originate Call ( F3 ) to make a mobile terminated call or originate a call from the mobile station to make a mobile originated call.
  4. Select Current Codec ( F9 ) and choose Stress .
  5. Capture a protocol log to verify the mobile station responded to the commands from the test set to change the current codec used. See Verify that the Mobile Station can pass the Stress Test for more information and tips on viewing the protocol logs.

Forcing Codec Mode Requests

The purpose of this test is to verify that the mobile station is generating Codec Mode Request (CMR) messages when the assigned threshold and hysteresis values are breeched. This test is important because it simulates the mobile station's behavior in a normal GSM/GPRS/EGPRS network.

  1. Setup the General AMR or AMR-WB Parameters. See General AMR and AMR-WB Parameter Setup .
  2. Select Originate Call ( F3 ) to make a mobile terminated call or originate a call from the mobile station to make a mobile originated call.
  3. Select Current Codec ( F9 ) and choose MS Request .
  4. Start Protocol Logging. See How to use Protocol Logging .
  5. Change the downlink traffic power on the test set: Select BCH Parameters ( F7 ), then Select Cell Power ( F7 ) and change the value in the field.
  6. Stop protocol logging and analyze the log to verify that the mobile station is generating Codec Mode Requests (CMR's) in response to changes in carrier power. See View Codec Mode Requests from the Mobile Station for more information and tips on viewing the protocol logs.

Change Parameters using RATSCCH

The purpose of this test is to verify that the mobile station can perform a change of AMR or AMR-WB parameters using RATSCCH frames. For more information on RATSCCH frames see Robust AMR Traffic Synchronization Control Channel (RATSCCH) .

  1. Setup the General AMR or AMR-WB Parameters. See General AMR and AMR-WB Parameter Setup .
  2. Start Protocol Logging. See How to use Protocol Logging .
  3. Select Originate Call ( F3 ) to make a mobile terminated call or originate a call from the mobile station to make a mobile originated call.
  4. Change the Codec Set . See steps 7-9 of General AMR and AMR-WB Parameter Setup .
  5. Stop protocol logging and analyze the log of this procedure using the Wireless Protocol Advisor (WPA) to verify the changes were made on the RATSCCH. See Verify AMR parameter changes using RATSCCH more information.

Discontinuous Transmission (DTX)

The purpose of this test is verify that the mobile station can handle the amount of new frames that DTX introduces and that they are decoded properly and at the correct times. Note: The Speech mode must be set to Echo for this test to work properly.

  1. Press CALL SETUP
  2. Select TCH Parameters ( F8 )
  3. Press the bottom right More key until 2 of 2 is displayed in the TCH Parms menu.
  4. Select Speech ( F10 ) and choose Echo from the list.
  5. Setup the General AMR or AMR-WB Parameters. See General AMR and AMR-WB Parameter Setup .
  6. Select Cell Info ( F6 )
  7. Select Cell Parameters ( F2 )
  8. Set the Mobile DTX State to On
  9. Start Protocol Logging. See How to use Protocol Logging .
  10. Select Originate Call ( F3 ) to make a mobile terminated call or originate a call from the mobile station to make a mobile originated call.
  11. Analyze the protocol log on the Wireless Protocol Advisor to verify that the messages were decoded properly and at the correct time. See Verify the Usage of Discontinuous Transmission (DTX)

Handovers While an AMR or AMR-WB Call is Active

  1. Setup the General AMR or AMR-WB Parameters. See General AMR and AMR-WB Parameter Setup .
  2. Follow the normal procedure for performing a handover. See How Do I Perform a Handover? .
  3. Verify the handover was successful by analyzing a protocol log of the procedure. For more information on analyzing the protocol log on the Wireless Protocol Advisor (WPA), see Verify successful Handovers

Related Topics

Adaptive Multi-Rate (AMR) Feature Descriptions


How Do I Set Up and Use the Configurable Timers?

How Do I Set Up and Use the Configurable Timers?

Last updated: December 3, 2008

This section details how to:

  • Configure the T3212 Periodic Location Update Timer
  • Configure the T3312 Periodic Routing Area Update Timer
  • Configure the T3314 GMM Ready Timer
  • Configure the Call Originate Timer (T301) and the Call Release Timer (T308)
  • Configure the T3192 TBF Release Timer

Configure the T3212 Periodic Location Update Timer

This procedure details how to configure the T3212 Periodic Location Update Timer.

  1. Press Call Setup .
  2. Press Operating Mode ( F1 ) and select Cell Off .
  4. Press More on the bottom left side of the screen until menu 2 of 3 of Control is displayed.
  5. Press Protocol Control ( F4 ).
  6. Press GMM/MM ( F4 )
  7. Press More on the bottom left side of the screen until menu 2 of 2 of GMM/MM is displayed.
  8. Press LAU Setup ( F1 )
  9. Use the knob to scroll down the menu options and find the T3212 Period Location Update Timer parameter.
  10. Press Close Menu (F6).
  11. Press Return (F6).

Configure the T3312 Periodic Routing Area Update Timer

This procedure details how to configure the T3312 Periodic Routing Area Update Timer.

  1. Press Call Setup .
  3. Press More on the bottom left side of the screen until menu 2 of 3 of Control is displayed.
  4. Press Protocol Control ( F4 ).
  5. Press GMM/MM ( F4 )
  6. Press More on the bottom right side of the screen until menu 2 of 2 of GMM/MM is displayed.
  7. Press RAU Setup ( F2 )
  8. Use the knob to scroll down the menu options and find the T3312 Period RA Update Timer parameter.
  9. Press Close Menu (F6).
  10. Press Return (F6).

Configure the T3314 GMM Ready Timer

This procedure details how to configure the T3314 GMM Ready Timer.

  1. Press Call Setup .
  3. Press More on the bottom left side of the screen until menu 2 of 3 of Control is displayed.
  4. Press Protocol Control ( F4 ).
  5. Press GMM/MM ( F4 )
  6. Press More on the bottom left side of the screen until menu 2 of 2 of GMM/MM is displayed.
  7. Press GMM Parameters ( F3 )
  8. Use the knob to scroll down the menu options and find the T3314 GMM Ready Timer parameter.
  9. Press Close Menu (F6).
  10. Press Return (F6).

Configure the Call Originate Timer (T301) and the Call Release Timer (T308)

This procedure details how to configure the Call Originate Timer (T301) and the Call Release Timer (T308).

  1. Press Call Setup .
  2. Press Paging Parameters ( F5 ).
  3. Use the knob to scroll down the menu options and find the T308 Call Release Timer or T301 Call Originate Timer parameter.
  4. Press Close Menu (F6).
  5. Press Return (F6).

Configure the T3192 TBF Release Timer

This procedure details how to configure the T3192 TBF Release Timer.

  1. Press Call Setup .
  2. Press Operating Mode ( F1 ) and select Cell Off .
  3. Press More on the bottom left side of the screen until menu 2 of 3 of Control is displayed.
  4. Press Protocol Control ( F4 ).
  5. Press RLC/MAC ( F2 )
  6. Press TBF Control ( F5 )
  7. Use the knob to scroll down the menu options and find the T3192 TBF Release Timer parameter.
  8. Press Close Menu (F6).
  9. Press Return (F6).

Related Topics

Configurable Timers


How Do I Perform Calling Party Number Verification?

How Do I Perform Calling Party Number Verification?

Last updated: December 3, 2008

This section is only applicable to the lab application.

Procedure

  1. Press the Call Setup key.
  2. Verify that the Operating Mode ( F1 ) is set to Active Cell(GSM) or Active Cell(GPRS) or Active Cell(EGPRS) and the Data Conn Type ( F2 ) is set to Auto for this example.
  3. Press the More key in the left side twice to move to the Control Menu 3 of 3.
  4. Press Calling Party Number Parms ( F5 ). The Calling Party Number Parameters menu is displayed. See Parameter Descriptions for details.
  5. Select Calling Party Number Inclusion .
  6. Turn the knob and select Include from the drop down menu.
    • If required, select the Calling Party Number and enter a desired value.
    • Up to 20 characters from the set of 0123456789abc*# can be entered in the entry box. The digits of 0-9 are entered from the DATA ENTRY keys and the characters of "abc*#" are entered from the newly displayed softkeys on the right of the screen.
      Enter the value in the Calling Party Number text entry

      Once the entry box goes away, the Calling Party Number field can display up to 14 characters. If the length of the entered string is greater than 14 characters, only the first 11 characters followed by a "..." are displayed in the Calling Party Number field. Use the GPIB command ( CALL:CPNumber<[:SELected]> ) to query the whole string.

    • If required, select other parameters and set to the desired value. In this example, the default settings are used.
  8. Press the Close Menu ( F6 ).
  9. (Optional) To capture a protocol log for further analysis, start a capture in the Wireless Protocol Advisor (WPA) software (see Protocol Logging ) and then perform the following steps.
  10. Press the Originate Call ( F3). The test set originates a call to the mobile station.
  11. Observe the mobile station's screen. Verify that the mobile station receives and displays the calling party number. If the Calling Party Number is not displayed on the mobile station' screen, ensure that Presentation Indicator is set to "Allowed".
  12. Stop WPA.
  13. If you start a WPA capture in step 5, verify that the test set sends an SETUP message with the calling party number parameters. An example log file is shown as below.

Related Topics

Calling Party Number Parameters


How to use the Digital Audio Interface Features

How to use the Digital Audio Interface Features

This section is only applicable to lab applications and the test application with a required feature license.

This section describes general procedures for performing the Digital Audio Interface (DAI) Test from the test set's front panel.

  • How to record the Digital Audio Interface (DAI) File
  • How to play the Digital Audio Interface (DAI) File

How to record the Digital Audio Interface (DAI) File

  1. Connect the mobile station to the test set using a suitable RF connector and adaptor and connect the mobile station to the Customer test station using a suitable LAN cable.
  2. Power on the mobile station, the test set and the mobile station.
  3. Configure the DAI test mode.
    1. Press Call Setup .
    2. Press TCH Parameters ( F8 ).
    3. Press the More key until screen 2 of 3 of the TCH Parameters menu is displayed.
    4. Press Internal Test Loops ( F9 ).
    5. Press DAI Setup ( F8 ) and the DAI Setup menu appears in the center of the screen as shown in the figure below. Use the knob to select Speech Decoder. This results in the test set sending a Layer 3 message to the Mobile Station to inform it to accept the digital audio files from the test set.
  4. Select the Logical Speech Channel that is to be tested.
    1. Press Call Setup .
    2. Press TCH Parameters ( F8 ).
    3. Press Channel Mode Setup ( F11 ).
    4. Press Channel Mode Config ( F7 ) and the Channel Mode Configuration is displayed. Use the knob to highlight the Logical Speech Channel and select the desired Logical Speech Channel from the list.
  5. Start a voice call between the test set and the DUT.

    You can establish a Mobile Terminated Call by:

    1. Press Call Setup
    2. Press Originate Call ( F3 )
    3. Press the button on the mobile station that answers the call.

    Or you can establish a Mobile Originated Call by dialing a number on the mobile station and pressing the button on the mobile station that sends a call.

  6. Command the test set to start recording the digital audio file (COD/DEC reference file).
    1. Press Call Setup
    2. Press the More key until screen 3 of 3 of the Control menu is displayed.
    3. Press Digital Audio Interface ( F1 ), The following screen is displayed.

    4. Press AMR Recording Format ( F3 ), set the Recording Format.
    5. Press Start COD Record ( F2 ), notice that the softkey changes to Stop COD Record after the press.

    Note that 2MB limit is reached as the buffer indicator reaches 100%.

  7. Press Stop COD Record ( F2 ) when the COD record finished.
  8. Download the digital audio file via the http interface.

How to play the Digital Audio Interface (DAI) File

  1. Connect the mobile station to the test set using a suitable RF connector and adaptor and connect the mobile station to the Customer test station using a suitable LAN cable.
  2. Power on the mobile station, the test set and the mobile station.
  3. Select the Logical Speech Channel that is to be tested.
    1. Press Call Setup .
    2. Press TCH Parameters ( F8 ).
    3. Press Channel Mode Setup ( F11 ).
    4. Press Channel Mode Config ( F7 ) and the Channel Mode Configuration is displayed. Use the knob to highlight the Logical Speech Channel and select the desired Logical Speech Channel from the list.
  4. Upload the digital audio file via the http interface.
  5. Start a voice call between the test set and the DUT.

    You can establish a Mobile Terminated Call by:

    1. Press Call Setup
    2. Press Originate Call ( F3 )
    3. Press the button on the mobile station that answers the call.

    Or you can establish a Mobile Originated Call by dialing a number on the mobile station and pressing the button on the mobile station that sends a call.

  6. Command the test set to start playing the digital audio file (COD/DEC reference file).
    1. Press Call Setup.
    2. Press the More key until screen 3 of 3 of the Control menu is displayed.
    3. Press Digital Audio Interface ( F1 ), The following screen is displayed.

    4. Press Start COD Play ( F1 ).

Related Topics

Logging Digital Audio Interface (DAI) Messages

Digital Audio Interface (DAI) Description

Programming a Digital Audio Interface (DAI) Test

CALL:DAINterface

CALL:TCHannel

STATus:OPERation


How Do I Use the Data Throughput Monitor?

How Do I Use the Data Throughput Monitor?

Last updated: December 3, 2008

This section is only applicable to the lab applications

Description

The following procedure illustrates typical usage of the data throughput monitor.

Accessing the Monitor Controls

  1. Press the Instrument selection key.
  2. Select Data Throughput Monitor .

    The data throughput monitor is displayed with the default settings as shown above. The Swap Window Positions ( F5 ) is displayed only when another measurement or instrument is active.

    Once the data throughput monitor is selected, it can be accessed by pressing the MEASUREMENT key, followed by the Swap Window Positions ( F5 ) key if necessary.

  3. Set the axis control as needed for your testing situation using the Axis Control ( F1 ) key to access the Time Span ( F1 ), Start Data Rate ( F2 ) Stop Data Rate ( F3 ) keys. For example, if you expect data rates to exceed the default value of 100 kbps, press the ( F1 ) key followed by the ( F3 ) key and enter a new value in the Stop Data Rate field using the DATA ENTRY keys.
  4. Press the Return ( F6 ) key to exit the Axis Control menu.
  5. Select the traces you would like to display by pressing the Trace Control ( F2 ) key followed by the Trace Display ( F1 ) key. To select a trace, turn the value to On. There are six color-coded traces and any combination can be selected:
    • OTA Tx - (Over The Air Transmitted bits-per-second). This is the rate of link-layer bit transfer sent from the wireless device. In other words, OTA translates into RLP (Radio Link Protocol) in cdma2000 and 1xEV-DO, or RLC (Radio Link Control) protocol in WCDMA and GPRS, or PPP in GSM. Tx refers to the reverse or uplink channel direction.
    • OTA Rx - (Over The Air Received bits-per-second). This is the rate of link-layer bit transfer received by the wireless device. In other words, OTA translates into RLP (Radio Link Protocol) in cdma2000 and 1xEV-DO, or RLC (Radio Link Control) protocol in WCDMA and GPRS, or PPP in GSM. Rx refers to the forward or downlink channel direction.
    • IP Tx - Internet Protocol Transmitted. This is the rate of network-layer bit transfer sent by the wireless device. Tx refers to the reverse or uplink channel direction.
    • IP Rx - Internet Protocol Received. This is the rate of network-layer bit transfer received by the wireless device. Rx refers to the forward or downlink channel direction.
    • Context <n> Tx - Internet Protocol Context 1 Transmitted. This is the rate of context 1 network-layer bit transfer sent by the wireless device. Tx refers to the reverse or uplink channel direction.
    • Context <n> Rx - Internet Protocol Context 1 Received. This is the rate of context 1 network-layer bit transfer received by the wireless device. Rx refers to the forward or downlink channel direction.

    By default, the OTA Tx and OTA Rx traces are the only traces turned on.

  6. Press the Return ( F6 ) key to exit the Trace Control menu.

  7. Establish a data connection with the mobile.

    The Data Throughput Monitor will begin displaying numerical and graphical information. The numerical information pertains to the period of time beginning with the establishment of the first data connection, and the graphical traces represent up to 600 seconds of the latest data throughput statistics.

  8. Set a marker.

    Using the Trace Control menu, select a marker by pressing the corresponding F2 , F3 , F4 , or F5 keys followed by the Data Entry key labeled ON.

    Press the Return ( F6 ) key.

    After allowing the monitor to accumulate throughput for at least one minute, change the Time Span to 50 seconds (see step 3 above). This will expand the graphical view to improve resolution.

    Press the Return ( F6 ) key.

  9. Freeze the graph.

    Press the Freeze Graph (F4) key.

    Turn the knob to adjust the position of the marker. Marker results will be displayed in the summary table

  10. Press the Return ( F6 ) key to exit the Trace Control menu.
  11. Press the Resume Graph ( F4 ) key to display the most recent trace data.
  12. Press the Clear Graph ( F3 ) key to reset the traces and the numeric counters.

Changing Data Rates

Data throughput can be analyzed under various call processing and RF conditions. This section illustrates the steps required to change data rates.

It is assumed that the data throughput monitor is displayed and a data call is connected.

  1. Press the CALL SETUP key.
  2. Change the data rate (see Related Topics).
  3. Press the MEASUREMENT key.

Related Topics

Data Throughput Monitor


Enabling the HTTP Interface

Enabling the HTTP Interface

This section contains the following:

  • Enabling the HTTP Interface for Mobile Terminated SMS
  • Enabling the HTTP Interface for Mobile Originated SMS

Enabling the HTTP Interface for Mobile Terminated SMS

  1. Press the Call Setup key to go the Call Setup screen.
  2. Go to menu ( 2 of 3 ) of the Call Control menu by pressing the More key on the lower left corner of the test set.
  3. Select Short Message Service by pressing the softkey F5 .
  4. Select HTTP Setup ( F3 ). The SMS HTTP Setup menu appears.
  5. Select HTTP SMS Input State . The Input State menu appears.
  6. Select On .

Enabling the HTTP Interface for Mobile Originated SMS

  1. Press the Call Setup key to go the Call Setup screen.
  2. Go to menu ( 2 of 2 ) of the Call Control menu by pressing the More key on the lower left corner of the test set.
  3. Select Short Message Service by pressing the softkey F5 .
  4. Select HTTP Setup ( F3 ). The SMS HTTP Setup menu appears.
  5. Select HTTP SMS Output State . The Output State menu appears.
  6. Select On .

Related Topics

HTTP Interface Configuration for Mobile Terminated SMS


How to Make an AMR In-Band Frame Error Measurement

How to Make an AMR In-Band Frame Error Measurement

This section is only applicable to lab applications and the test application with a required feature license.

Measuring 3GPP TS Section 14.2.19 IFER

This procedure assumes that the BCH parameter for the Cell Band is set up correctly for your mobile station and the appropriate RF IN/OUT Amplitude Offsets have been set to offset loss between the mobile station and the test set. For more information see How Do I Configure the Test Set for My Test System? .

  1. Setup the General AMR Parameters. See General AMR and AMR-WB Parameter Setup for instructions on how to set these parameters through the front panel.
  2. Select Originate Call ( F3 ) to make a mobile terminated call or originate a call from the mobile station.

  3. Press the Measurement Selection key.

  4. Choose AMR In-Band Frame Error . The AMR IFER measurement starts automatically as soon as it is selected.

    NOTE
    There must be four codecs defined in the Active Codec Set (ACS) for the IFER measurement to initiate.

  5. Select IFER Setup ( F1 ) to set the measurement specific parameters.

  6. Verify the measurement results meet the conformance requirements in 3GPP TS section 14.2.19, tables 14.2.19-1 and 14.2.19-2, depending on which cell band your mobile station is operating in. The minimum number of samples for any cell band is 150000, however the test limit error rate is defined separately according to the cell band.

Related Topics

In-Band Frame Error (IFER) Measurement Description


How to view Measurement Reports

How to view Measurement Reports

This section is only applicable to the lab applications.

  1. Press the Call Setup key.
  2. Press the left More key to advance the Control menu to ( 2 of 3 ).
  3. Press Measurement Reports ( F6 ).
  4. Press View ( F1 ). The Meas Reports menu is displayed on the left side of the screen. From it you can select which measurement report screen you want to view, these include: Summary Measurement Reports ( F1 ) through, SACCH Measurement Reports ( F2 ), PACCH Measurement Reports ( F3 ), and Network Control Measurement Reports ( F4 ). The Summary Measurement Reports screen is displayed by default.

    NOTE: A "----" next to a parameter indicates that the test set has not received any information from the mobile station for that parameter.


How to access DUT PDP Setup

How to access DUT PDP Setup

Accessing the DUT PDP Setup menu

  1. Press the Call Setup key.
  2. Press the More key on the lower left corner to display the Control menu ( 2 of 3 ).
  3. Press the DUT PDP Setup softkey ( F2 ) to display a list of DUT PDP Setup options.


How to "ping" an IP address from the test set

How to "ping" an IP address from the test set

This section is only applicable to the lab applications and to mobile stations that have the capability to ping a device.

You can use the ping feature of the test set to:

  • Ping the DUT from the test set
  • Ping an alternate address from the test set

Ping the DUT from the test set

  1. Press the Call Setup key.
  2. Select Operating Mode ( F1 ) and set it to Active Cell .
  3. Select Data Conn Type ( F2 ) and set it to Auto .
  4. Press the left More key to display the second page of the Control Menu.
  5. Select DUT PDP Setup ( F2 ).
  6. Proess DUT PDP Setup ( F1 ).
  7. Enter the DUT IP address .

    NOTE
    The DUT's IP address must be on the same subnet as the test set's IP Address.

  8. Press F6 ( Close Menu ) to close the DUT PDP Setup menu.
  9. Press F6 ( return ) to return to the second page of the Control Menu.
  10. Select Ping ( F3 ).
  11. Select Ping Setup ( F1 ) and verify that Device to Ping is set to DUT .
  12. Initiate some type of data exchange with the mobile station. For example, access the internet from the mobile station's user interface.
  13. Select Start Ping ( F3 ).

Ping an alternate address from the test set

  1. Press the Call Setup key.
  2. Select Operating Mode ( F1 ) and set it to Active Cell .
  3. Select Data Conn Type ( F2 ) and set it to Auto .
  4. Press the More key to display the second page of the Control Menu.
  5. Select Ping ( F3 ) .
  6. Select Ping Setup( F1 ) .
  7. Set the Alternate Ping Address to your desired target IP address.
  8. Set Device to Ping to Alternate .
  9. Select Start Ping( F3 ) .

Related Topics

Ping


How to use Protocol Logging

How to use Protocol Logging

This section is only applicable to the lab applications.

Start protocol logging from the test set

If a PC with the WPA software has not yet connected with the test set, an error message will be generated. Exactly one PC running the WPA software can be connected to a test set at one time.

  1. Press the CALL SETUP key to go to the Call Setup screen.
  2. Press the More key on the left hand Control menu to go to menu 2 of 2.
  3. Press Protocol Logging ( F1 ).
  4. Press Start Protocol Logging ( F1 ) to begin logging.
  5. The Logging annunciator at the bottom of the screen shows Active . The WPA's traffic overview window begins displaying messages. When the messages start displaying and how many are displayed is determined by the trigger and filter setup in the WPA. Refer to the WPA on-line help for more information.

Stop protocol logging from the test set

  1. From the Logging menu, press Stop Protocol Logging ( F1 ).
  2. The Logging annunciator at the bottom of the screen shows Idle .

You can now view the protocol log on the Traffic Overview window of the WPA software (See Protocol Logging for more information about protocol logging).


How to access Protocol Control

How to access Protocol Control

Accessing the Protocol Control menu

  1. Press the Call Setup key.
  2. Press the More key on the lower left corner to display the Control menu ( 2 of 3 ).
  3. Press the Protocol Control softkey ( F4 ) to display a list of protocol layers.


How Do I Make a Repeated SACCH Frame Erasure Rate (FER) Measurement?

How Do I Make a Repeated SACCH Frame Erasure Rate (FER) Measurement?

Last updated: December 3, 2008

This section is only applicable to the lab applications.

This procedure assumes that the BCH parameter for Cell Band is set up correctly for your mobile station and that the appropriate RF IN/OUT Amplitude Offsets have been set to offset loss between the mobile station and the test set.

  1. Press the CALL SETUP key.
  2. Press TCH Parameters ( F8 ).
  3. Press Traffic Channel ( F9 ) and enter a value on the low end of the ARFCN range for the band in which you are testing.
  4. Press MS TX Level ( F10 ) and enter the value for maximum power for the band in which you are testing.
  5. Press the more key until 3 of 3 of the TCH Parms screen is displayed.
  6. Press Call signaling Parameters ( F7 ).
  7. Use the knob to highlight Repeated SACCH in the pop-up Call Signaling Parameters menu. Press the knob and change the value to On Request .
  8. Press Return ( F12 ).
  9. Connect the mobile station to the test set and turn in on. Allow it to camp to the test set's signal.
  10. Establish a GSM phone call.
  11. Press the Measurement Selection key.
  12. Select GSM Repeated SACCH Frame Erasure Rate . The measurement will start. If the measurement is progressing, the count in the bottom left of the measurement's screen increments.
  13. Press SACCH FER Setup ( F1 ).
  14. Modify the setup parameters as you see fit.

A typical measurement report is shown above.

Related Topics

Repeated SACCH Frame Erasure Rate (FER) Measurement Description


How to use the Short Message Service Features

How to use the Short Message Service Features

Last updated: December 4, 2008

This section is only applicable to the lab applications and the test applications with a required feature license.

This section describes general procedures for using SMS features from the test set's front panel.

  • Mobile Terminated Point-to-Point Message Transfer
  • Mobile Originated Point-to-Point Message Transfer
  • Cell Broadcast Message Transfer
  • Cell Broadcast Updated Message Transfer

Mobile Terminated Point-to-Point Message Transfer

The following procedures,

  • Procedure A: Sending a Text Message to the Mobile Station and
  • Procedure B: Sending a WAP Push Message to the Mobile Station
can be used to simulate exchanging SMS messages between the test set and the mobile station attached to the test set's RF port.

Procedure A: Sending a Text Message to the Mobile Station

  1. If you would like a log of the protocol messages exchanged between the test set and the mobile station, set up the Wireless Protocol Advisor (WPA) and start logging. See Logging SMS Messages .
  2. Connect the mobile station to the test set and power it on.
  3. After the mobile station has camped (and attached if it supports GPRS), go to the Call Setup screen by pressing the Call Setup key.
  4. Go to menu ( 2 of 3 ) of the Call Control menu by pressing the More key on the lower left corner of the test set.
  5. Select Short Message Service by pressing the softkey F5 .
  6. Select the Point to Point SMS messaging by pressing the softkey F1 .
  7. Select Mobile Terminated by pressing the softkey F2 .The Mobile Terminated SMS menu appears.
  8. Choose to use either GSM or GPRS protocol layers to be used for sending the SMS message using by selecting the Transportation parameter and scrolling to the desired value.
  9. Choose the message to send by selecting the Content parameter. Select Text2 . For additional information about the message options available, see Short Message Service (SMS) Messages .
  10. Press the Send Message softkey ( F1 ) to send the message. Observe the mobile station for indications that the message has been received. The test set display also gives an indication.
  11. If you are capturing a log, stop logging.

Procedure B: Sending a WAP Push Message to the Mobile Station

  1. If the Pt to Pt SMS control screen is not visible on the test set's front panel, use steps 1 thru 6 of Procedure A: Sending a Text Message to the Mobile Station .
  2. Select Mobile Terminated by pressing the softkey F2 .The Mobile Terminated SMS menu appears.
  3. Choose the message to send by selecting the Content parameter. Select Custom Data . Configuring the content of your custom data requires a GPIB commands. See Defining the User Data (TP-UD) content for Binary SMS Applications for information on configuring custom data.
  4. Select the Data Coding Scheme parameter and use the test set's keypad to enter 245 . This entry indicates that this message is a WAP Push message.
  5. Select the User Data Header Indicator parameter. Select 1 . This indicates that this message has a User Data Header.
  6. Press the Send Message softkey ( F1 ) to send the message. Observe the mobile station for indications that the message has been received. The test set display also gives an indication.
  7. If you are capturing a log, stop logging.

Mobile Originated Point-to-Point Message Transfer

  1. If you would like a log of the protocol messages exchanged between the test set and the mobile station, set up the Wireless Protocol Advisor (WPA) and start logging. See Logging SMS Messages .
  2. Connect the mobile station to the test set and power it on.
  3. After the mobile station has camped (and attached if it supports GPRS), go to the Call Setup screen by pressing the Call Setup key.
  4. Go to the second page of the Call Control menu by pressing the More key on the lower left corner of the test set.
  5. Select Short Message Service by pressing the softkey F5 .
  6. If you want the message received by the test set to be resent to the mobile station, first, select the Point to Point SMS messaging by pressing the softkey F1 , then select Mobile Originated by pressing the softkey F3 , then select the Loopback parameter and scroll to On .
  7. Using the mobile station's interface, set the mobile station to send either GPRS SMS or GSM SMS.
  8. Use the mobile station to send a point-to-point message with the contents "HELLO!" to any address.
  9. Observe the test set for indications that the message has been received. If the loopback option is enabled, observe the mobile station for indications that the message has been received.
  10. If you are capturing a log, stop logging.

Cell Broadcast Message Transfer

This section assumes that you have configured your mobile station to receive cell broadcast messages. This is done by enabling reception of messages in your mobile station and specifying the message parameters that it can receive.

  1. If you would like a log of the protocol messages exchanged between the test set and the mobile station, set up the Wireless Protocol Advisor (WPA) and start logging. See Logging SMS Messages .
  2. Connect the mobile station to the test set and power it on.
    NOTE

    The mobile station does not have to attach.

    The Cell Broadcast supported by the test set is GSM only. GSM Cell Broadcast does not work for some mobile stations if they are attached. You may prevent the mobile station from attaching by disabling the auto attach feature in your mobile station and only attaching when needed. Typically this setting is found under GPRS Settings on you mobile station. Alternatively, you can change the Operating Mode ( F1 ) to Active Cell (GSM) .

  3. Go to the Call Setup screen by pressing the CALL SETUP key.
  4. Go to the second page of the Call Control menu by pressing the More key on the lower left corner of the test set.
  5. Select Short Message Service by pressing the softkey F5 .
  6. Select Cell Broadcast by pressing the softkey F2 . The Broadcast SMS menu appears. You can select setup menus for three different messages, as well as the general cell broadcast setup.
  7. To setup parameters for a specific message, press the softkey next to the menu item labeled Message X Setup where X can be 1, 2, or 3. The menu for the selected message appears. The figure below shows the Message 1 Setup menu.
  8. See Cell Broadcast Message Setup for more information about each parameter in the message setup.
  9. Set parameters according to the type of cell broadcast messages your mobile station is allowed to receive.

  10. To set the cell broadcast parameters that apply to all three messages, press Cell Broadcast Setup ( F5 ). The following menu appears:

  11. Use the knob to change the Repetition Period , if desired.
  12. Start the broadcast message using the Start Cell Broadcast softkey ( F1 ). NOTE: Cell Broadcast can not be activated if the SDCCH Subchannel is set to 2.
  13. Observe the display on the mobile station to confirm that the message(s) were received.
  14. If required, stop the broadcast by pressing the Stop Cell Broadcast softkey ( F1 ).
  15. If you are capturing a log, stop logging.

Cell Broadcast Updated Message Transfer

This section assumes that you have configured your mobile station to receive cell broadcast messages. This is done by enabling reception of messages in your mobile station and specifying the message parameters that it can receive. In order for a phone to realize the contents of a message have been altered you also need to change either the Message Code or Update Number for the message.

  1. If you would like a log of the protocol messages exchanged between the test set and the mobile station, set up the Wireless Protocol Advisor (WPA) and start logging. See Logging SMS Messages .
  2. Connect the mobile station to the test set and power it on.
    NOTE

    The mobile station does not have to attach.

  3. Go to the Call Setup screen by pressing the CALL SETUP key.
  4. Go to the second page of the Call Control menu by pressing the More key on the lower left corner of the test set.
  5. Select Short Message Service by pressing the softkey F5 .
  6. Select Cell Broadcast by pressing the softkey F2 .
  7. Set parameters according to what type of cell broadcast messages your mobile station is allowed to receive. To enable a message to be sent, select Message Setup for the message you wish to send (message 1, 2, and/or 3) and set State to On . You can configure different message parameters in each of the Message Setup menus.
  8. Select the message to be sent using the Content menu for each message you want to update.

    The Custom Text and Custom Data strings are defined using the commands CALL:SMService:CBRoadcast:MESSage[<n>]:CTEXt and CALL:SMService:CBRoadcast:MESSage[<n>]:CDATa , respectively.

  9. Start the broadcast message using the Start Cell Broadcast softkey ( F1 ).
  10. Observe the display on the mobile station to confirm that the updated message(s) were received.
  11. Select Message Setup for each message to be sent as an update.
  12. Set the Update Number for these messages higher than their previous value. The update number wraps from 15 to 0.
  13. Observe the display on the mobile station to confirm that the updated message(s) have replaced the first versions.

    NOTE
    The amount of time the mobile station takes to display changes to the message(s) while the cell broadcast service is running depends on the repetition period parameter
    .

  14. If required, stop the broadcast by pressing the Stop Cell Broadcast softkey ( F1 ).
  15. If you are capturing a log, stop logging.

Related Topics

Short Message Service (SMS)

Point-to-Point SMS

Cell Broadcast Service (CBS)

Logging SMS Messages

Short Message Service (SMS) Messages


How to use Timing Advance Control.

How to use Timing Advance Control.

Last updated: December 3, 2008

  1. Press the Call Setup key.
  2. Select PDTCH Parameters ( F9 ).
  3. Press the right More key.
  4. On PDTCH Parms menu ( 2 of 3 ), select Timing Advance Control ( F10 ).
  5. Set Timing Advance Parameters as desired. This menu allows you to turn Continuous Timing Advance on and off as well as set the timing advance value.


How to use the UMA/GAN Features

How to use the UMA/GAN Features

This section is only applicable to the lab applications.

This section describes general procedures for performing the UMA/GAN Test from the test set's front panel.

  1. Connect the GANC to the test set. The "ExtDev" is displayed on the front panel when the connection between the test set and the GANC has been established. Refer to the user guide for the GANC software for details on how to set up the connection between the test set and the GANC.
  2. The "Sys Type" field displays "GAN" when the current access stratum used by the mobile station is GAN.
  3. The Voice/Data connection status display fields are used to report the current core network voice and data connection status to the MS regardless of the underlying access technology (GAN or GERAN).

Related Topics

UMA/GAN Test System

CALL:ASTRatum


UMA/GAN Procedures Ladder Diagrams

UMA/GAN Procedures Ladder Diagrams

The following diagrams illustrate the procedures used by the test set and GANC for several key UMA/GAN operations.

  • UMA/GAN Discovery procedure
  • UMA/GAN Registration Procedure
  • UMA/GAN Mobile Originated Call Procedure
  • UMA/GAN Mobile Terminated Call
  • GERAN to GAN Handover Procedure
  • GAN to GERAN Handover Procedure

UMA/GAN Discovery procedure

UMA/GAN Registration Procedure

UMA/GAN Mobile Originated Call Procedure

UMA/GAN Mobile Terminated Call

GERAN to GAN Handover Procedure

GAN to GERAN Handover Procedure


CALL:ASTRatum

CALL:ASTRatum

Last updated:December 3, 2008

GPIB Command Conventions

  • CALL:ASTRatum?

CALL:ASTRatum?

Function

GSM TA

 This command is not applicable to GSM TA.

GPRS TA

 This command is not applicable to GPRS TA.

EGPRS TA

 This command is not applicable to EGPRS TA.

GSM/GPRS LA

Queries the current access stratum in use by a connected mobile station.

  • NONE: Report not available
  • GER: Last access stratum used was GERAN
  • GAN: Last access stratum used was GAN

EGPRS LA

Query

Range: NONE | GER | GAN

*RST Setting

NONE
Requirements GSM/GPRS/ EGPRS LA

Revision: F.00.13 and above with E6962A A.00.04

Programming Example

OUTPUT 714;"CALL:ASTRatum?"


CALL:DAINterface

CALL:DAINterface

GPIB Command Conventions

  • CALL:DAINterface:PLAY:STARt
  • CALL:DAINterface:PLAY:STATus
  • CALL:DAINterface:PLAY:STOP
  • CALL:DAINterface:RECord:FORMat:AMR
  • CALL:DAINterface:RECord:STARt
  • CALL:DAINterface:RECord:STATus
  • CALL:DAINterface:RECord:STOP

CALL:DAINterface:PLAY:STARt

Function

 GSM TA This command is not applicable to the GPRS test application.

GPRS TA

 This command is not applicable to the GPRS test application.

EGPRS TA

 This command is not applicable to the EGPRS test application.

GSM/GPRS LA

 Command the test set to start playing the digital audio file. See Digital Audio Interface (DAI) Description for more information.

EGPRS LA

Requirements

 GSM/GPRS/ EGPRS TA

Revision: A.09 and above with required feature license.

GSM/GPRS/ EGPRS LA

Revision: F.00.13 and above

Programming Example

OUTPUT 714;"CALL:DAINterface:PLAY:STARt"
! Commands the test set to start playing the digital audio file.

CALL:DAINterface:PLAY:STATus

Function

 GSM TA This command is not applicable to the GPRS test application.

GPRS TA

 This command is not applicable to the GPRS test application.

EGPRS TA

 This command is not applicable to the EGPRS test application.

GSM/GPRS LA

This command queries the playing status of the digital audio file in the test set. See Digital Audio Interface (DAI) Description for more information.

EGPRS LA

Query

Range: IDLE|READ|PLAY|DONE

Requirements

 GSM/GPRS/ EGPRS TA

Revision: A.09 and above with required feature license.

GSM/GPRS/ EGPRS LA

Revision: F.00.13 and above

Programming Example

OUTPUT 714;"CALL:DAINterface:PLAY:STATus?"
! Queries the playing status of the digital audio file.

CALL:DAINterface:PLAY:STOP

Function

 GSM TA This command is not applicable to the GPRS test application.

GPRS TA

 This command is not applicable to the GPRS test application.

EGPRS TA

 This command is not applicable to the EGPRS test application.

GSM/GPRS LA

 Command the test set to stop playing the digital audio file. See Digital Audio Interface (DAI) Description for more information.

EGPRS LA

Requirements

 GSM/GPRS/ EGPRS TA

Revision: A.09 and above with required feature license.

GSM/GPRS/ EGPRS LA

Revision: F.00.13 and above

Programming Example

OUTPUT 714;"CALL:DAINterface:PLAY:STOP"
! Commands the test set to stop playing the digital audio file.

CALL:DAINterface:RECord:FORMat:AMR

Function

 GSM TA This command is not applicable to the GPRS test application.

GPRS TA

 This command is not applicable to the GPRS test application.

EGPRS TA

 This command is not applicable to the EGPRS test application.

GSM/GPRS LA

This command sets/queries the type of the digital audio file in the test set. See Digital Audio Interface (DAI) Description for more information.

EGPRS LA

Setting

Range: COD | RFC3267

Query

Range: COD | RFC3267

*RST Setting

COD

Requirements

 GSM/GPRS/ EGPRS TA

Revision: A.09 and above with required feature license.

GSM/GPRS/ EGPRS LA

Revision: F.00.13 and above

Programming Example

OUTPUT 714;"CALL:DAINterface:RECord:FORMat:AMR COD"
! Sets the type to COD.

CALL:DAINterface:RECord:STARt

Function

 GSM TA This command is not applicable to the GPRS test application.

GPRS TA

 This command is not applicable to the GPRS test application.

EGPRS TA

 This command is not applicable to the EGPRS test application.

GSM/GPRS LA

 Command the test set to start recording the digital audio file. See Digital Audio Interface (DAI) Description for more information.

EGPRS LA

Requirements

 GSM/GPRS/ EGPRS TA

Revision: A.09 and above with required feature license.

GSM/GPRS/ EGPRS LA

Revision: F.00.13 and above

Programming Example

OUTPUT 714;"CALL:DAINterface:RECord:STARt"
! Commands the test set to start recording the digital audio file.

CALL:DAINterface:RECord:STATus

Function

 GSM TA This command is not applicable to the GPRS test application.

GPRS TA

 This command is not applicable to the GPRS test application.

EGPRS TA

 This command is not applicable to the EGPRS test application.

GSM/GPRS LA

This command queries the recording status of the digital audio file in the test set. See Digital Audio Interface (DAI) Description for more information.

EGPRS LA

Query

Range: IDLE|REC|DONE

Requirements

 GSM/GPRS/ EGPRS TA

Revision: A.09 and above with required feature license.

GSM/GPRS/ EGPRS LA

Revision: F.00.13 and above

Programming Example

OUTPUT 714;"CALL:DAINterface:RECord:STATus?"
! Queries the recording status of the digital audio file.

CALL:DAINterface:RECord:STOP

Function

 GSM TA This command is not applicable to the GPRS test application.

GPRS TA

 This command is not applicable to the GPRS test application.

EGPRS TA

 This command is not applicable to the EGPRS test application.

GSM/GPRS LA

 Command the test set to stop recording the digital audio file. See Digital Audio Interface (DAI) Description for more information.

EGPRS LA

Requirements

 GSM/GPRS/ EGPRS TA

Revision: A.09 and above with required feature license.

GSM/GPRS/ EGPRS LA

Revision: F.00.13 and above

Programming Example

OUTPUT 714;"CALL:DAINterface:RECord:STOP"
! Commands the test set to stop recording the digital audio file.


CALL:DEModulation

CALL:DEModulation

GPIB Command Conventions

  • CALL:DEModulation:DELay

CALL:DEModulation:DELay

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

Sets the value of the demodulation trigger delay. The demodulation trigger will be delayed by the number of symbols specified with this command.
EGPRS LA

Setting

Range: 0 to 200 symbols
Resolution: 1 symbol
Query

Range: 0 to 200 symbols
Resolution: 1 symbol

*RST Setting

 0
Requirements GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example:

OUTPUT 714;"CALL:DEModulation:DELay 100"


CALL:NITZone

CALL:NITZone

  • CALL[:CELL]:NITZone:DSTime[:HOURs][:SVALue][:SELected]
  • CALL[:CELL]:NITZone:DSTime[:HOURs]:STATe[:SELected]
  • CALL[:CELL]:NITZone:DSTime[:HOURs]:VALue[:SELected]

  • CALL[:CELL]:NITZone:SEND[:IMMediate]
  • CALL[:CELL]:NITZone:SEND:DATA:ORIGination[:STATe][:SELected]
  • CALL[:CELL]:NITZone:SEND:GMM:REGistration[:STATe][:SELected]
  • CALL[:CELL]:NITZone:SEND:MM:REGistration[:STATe][:SELected]
  • CALL[:CELL]:NITZone:SEND:TRANsport[:SELected]
  • CALL[:CELL]:NITZone:SEND:VOICe:ORIGination[:STATe][:SELected]

  • CALL[:CELL]:NITZone:TZONe[:LOCal][:SELected]

  • CALL[:CELL]:NITZone:UTIMe:DATE[:SELected]
  • CALL[:CELL]:NITZone:UTIMe:TIME[:SELected]
  • CALL[:CELL]:NITZone:UTIMe:UTC[:IMMediate]

CALL[:CELL]:NITZone:DSTime[:HOURs][:SVALue][:SELected]

CALL[:CELL]:NITZone:DSTime[:HOURs][:SVALue]:TDMA

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA This command sets/queries the Daylight Saving Time value. See Network Identity and Time Zone for more information.
EGPRS LA

Setting

Range: 0|1|2

Query

Range: 0|1|2

*RST setting

 0
Requirements GSM/GPRS/ EGPRS LA

Revision: G.00.00 and above

Programming Example

OUTPUT 714;"CALL:NITZone:DSTime:TDMA 0"
!Sets the daylight saving time to 0.

CALL[:CELL]:NITZone:DSTime[:HOURs]:STATe[:SELected]

CALL[:CELL]:NITZone:DSTime[:HOURs]:STATe:TDMA

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA This command sets/queries whether the Network Daylight Saving Time Information Element is included in the GMM or MM Information message or not. See Network Identity and Time Zone for more information.
EGPRS LA

Setting

 Range: ON|OFF|1|0

Query

 Range: 1|0

*RST setting

 OFF
Requirements GSM/GPRS/ EGPRS LA

Revision: G.00.00 and above

Programming Example

OUTPUT 714;"CALL:NITZone:DSTime:STATe:TDMA OFF" !
!Sets the GMM or MM info message do NOT include daylight saving time Information Element.

CALL[:CELL]:NITZone:DSTime[:HOURs]:VALue[:SELected]

CALL[:CELL]:NITZone:DSTime[:HOURs]:VALue:TDMA

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA This command sets/queries the Daylight Saving Time value. See Network Identity and Time Zone for more information.
EGPRS LA

Setting

Range: 0|1|2

Query

Range: 0|1|2

*RST setting

 0
Requirements GSM/GPRS/ EGPRS LA

Revision: G.00.00 and above

Programming Example

OUTPUT 714;"CALL:NITZone:DSTime:VALue:TDMA 0"
!Sets the daylight saving time to 0.

CALL[:CELL]:NITZone:SEND[:IMMediate]

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

This command sets the NITZ Information to be immediately sent to the mobile when:

  • The Call Connection State is Connected. Note that the NITZ is sent via MM Information message in this case. But there is an exception that if the DUT is DTM capable and DTM is enabled in the test set, the setting `NITZ Transportation in DTM' CALL[:CELL]:NITZone:SEND:TRANsport[:SELected] determines which message is used to transport NITZ information.
  • The Data Connection is AUTO and the Data Connection State is Attached, Transferring or PDP active. Note that the NITZ is sent via GMM Information message in this case.

See Network Identity and Time Zone for more information
EGPRS LA
Requirements GSM/GPRS/ EGPRS LA

Revision: G.00.00 and above

Programming Example

OUTPUT 714;"CALL:NITZone:SEND" !Sets the NITZ information to be immediately sent to DUT via GMM Information message.

CALL[:CELL]:NITZone:SEND:DATA:ORIGination[:STATe][:SELected]

CALL[:CELL]:NITZone:SEND:DATA:ORIGination[:STATe]:TDMA

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

This command sets/queries whether the NITZ information is sent during a GPRS PDP activation procedure and Point-to-Point SMS over GPRS procedure.

When this parameter is set to ON, the GMM Information message with NITZ information is sent following these messages:

  • Activate PDP Context Accept from the test set
  • SMS-SUBMIT during a mobile originated Point-to-Point SMS over GPRS
or immediately before

  • SMS-DELIVER during a mobile terminated Point-to-Point SMS over GPRS

See Network Identity and Time Zone for more information
EGPRS LA

Setting

 Range: ON|OFF|1|0

Query

 Range: 1|0

*RST setting

 OFF
Requirements GSM/GPRS/ EGPRS LA

Revision: G.00.00 and above

Programming Example

OUTPUT 714;"CALL:NITZone:SEND:DATA:ORIGination:TDMA OFF"
!Sets the test set does NOT send GMM information message during a GPRS PDP activation
procedure and Point-to-Point SMS over GPRS procedure.

CALL[:CELL]:NITZone:SEND:GMM:REGistration[:STATe][:SELected]

CALL[:CELL]:NITZone:SEND:GMM:REGistration[:STATe]:TDMA

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

This command sets/queries whether the NITZ information is sent during a GPRS Attach procedure and Routing Area Update procedure.

When the parameter is set to ON, the GMM Information message with NITZ information is sent following these messages:

  • Routing Area Update Accept from the test set
  • Attach Accept from the test set

See Network Identity and Time Zone for more information
EGPRS LA

Setting

 Range: ON|OFF|1|0

Query

 Range: 1|0

*RST setting

 OFF
Requirements GSM/GPRS/ EGPRS LA

Revision: G.00.00 and above

Programming Example

OUTPUT 714;"CALL:NITZone:SEND:GMM:REGistration:TDMA OFF" !
!Sets the test set does NOT send GMM information message during a GPRS Attach procedure or
Routing Area Update procedure.

CALL[:CELL]:NITZone:SEND:MM:REGistration[:STATe][:SELected]

CALL[:CELL]:NITZone:SEND:MM:REGistration[:STATe]:TDMA

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

This command is not applicable to the EGPRS Test Application.
EGPRS LA

This command sets/queries whether the NITZ information is sent during IMSI Attach procedure and Location Updating procedure.

When this parameter is set to ON, the MM Information message with NITZ information is sent following the message listed:

  • Location Updating Accept (from the test set to the DUT)

See Network Identity and Time Zone for more information

Setting

 Range: ON|OFF|1|0

Query

 Range: 1|0

*RST setting

 OFF
Requirements GSM/GPRS/ EGPRS LA

Revision: G.00.00 and above

Programming Example

OUTPUT 714;"CALL:NITZone:SEND:MM:REGistration:TDMA OFF"
!Sets the test set does NOT send NITZ information during IMSI Attach procedure and Location
Updating procedure.

CALL[:CELL]:NITZone:SEND:TRANsport[:SELected]

CALL[:CELL]:NITZone:SEND:TRANsport:TDMA

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

This command sets/queries which message (MM Information or GMM Information) is used to transport NITZ information after "NITZ Send Immediate" setting is applied, in the cases where both GMM Infomation and MM Information messages are available. (For example, in a DTM operation.)

If the parameter is set to GSM, NITZ information is sent via MM Information message, otherwise it is sent via GMM Information message.

See Network Identity and Time Zone for more information
EGPRS LA

Setting

Range: GPRS| GSM

Query

Range: GPRS| GSM

*RST setting

 GPRS
Requirements GSM/GPRS/ EGPRS LA

Revision: G.00.00 and above

Programming Example

OUTPUT 714;"CALL:NITZone:SEND:TRANsport:TDMA GPRS" !
!Sets the NITZ information to be sent via GMM Information message.

CALL[:CELL]:NITZone:SEND:VOICe:ORIGination[:STATe][:SELected]

CALL[:CELL]:NITZone:SEND:VOICe:ORIGination[:STATe]:TDMA

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

This command sets/queries whether the NITZ information will be sent or not during a voice call origination procedure (including voice, emergency call and CSD) and Point-to-Point SMS over GSM procedure.

When this parameter is set to ON, the MM Information message with NITZ information is sent following the messages listed:

CM Service Accept message from the test set during a mobile originated call for voice, CSD, emergency call and Point-to-Point SMS over GSM

or immediately before:

  • SMS-DELIVER from the test set during a mobile terminated Point-to-Point SMS over GSM
  • SETUP message from the test set during a mobile terminated call

See Network Identity and Time Zone for more information
EGPRS LA

Setting

 Range: ON|OFF|1|0

Query

 Range: 1|0

*RST setting

 OFF
Requirements GSM/GPRS/ EGPRS LA

Revision: G.00.00 and above

Programming Example

OUTPUT 714;"CALL:NITZone:SEND:VOICe:ORIGination:TDMA OFF"
!Sets the test set does NOT send MM information message during a voice call origination
procedure and Point-to-Point SMS over GSM procedure.

CALL[:CELL]:NITZone:TZONe[:LOCal][:SELected]

CALL[:CELL]:NITZone:TZONe[:LOCal]:TDMA

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

This command sets/queries the NITZ local time zone. The format of entry is hh.mm and the resolution is 15 minutes. Thus, any entry that does not fall evenly on a 15 minute (quarter hour) boundary will be rounded to the nearest 15 minutes. See Network Identity and Time Zone for more information
EGPRS LA

Setting

Range:

  • <hour> -19 to +17
  • <minute> 0 to 59

Query

Range:

  • <hour> -19 to +17
  • <minute> 0|15|30|45

*RST setting

 "00.00"
Requirements GSM/GPRS/ EGPRS LA

Revision: G.00.00 and above

Programming Example

OUTPUT 714;"CALL:NITZone:TZONe:TDMA 00,00"
!Sets the local time zone to 00.00

CALL[:CELL]:NITZone:UTIMe:DATE[:SELected]

CALL[:CELL]:NITZone:UTIMe:DATE:TDMA

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA This command sets/queries the Universal Time-Date. The format of entry is yyyy.mm.dd. See Network Identity and Time Zone for more information.
EGPRS LA

Setting

Range:

  • <year> 2000 to 2099
  • <month> 1 to 12 (corresponds to January to December)
  • <day> 1 to the number of days in the month specified by the <month> parameter

Query

Range:

  • <year> 2000 to 2099
  • <month> 1 to 12 (corresponds to January to December)
  • <day> 1 to the number of days in the month specified by the <month> parameter

*RST setting

 "2008.01.01"
Requirements GSM/GPRS/ EGPRS LA

Revision: G.00.00 and above

Programming Example

OUTPUT 714;"CALL:NITZone:UTIMe:DATE:TDMA 2008,01,01"
!Sets the date to January 1,2008.

CALL[:CELL]:NITZone:UTIMe:TIME[:SELected]

CALL[:CELL]:NITZone:UTIMe:TIME:TDMA

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA This command sets/queries the Universal Time-Time. The format of entry is hh.mm.ss using the 24-hour clock. See Network Identity and Time Zone for more information.
EGPRS LA

Setting

Range:

  • <hour> 0 to 23
  • <minute> 0 to 59
  • <second> 0 to 59

Note that the resolution of the local time setting is minutes. The value returned for <second> will not provide useful information.

Query

Range:

  • <hour> 0 to 23
  • <minute> 0 to 59
  • <second> 0 to 59

*RST setting

 "13.00.00"
Requirements GSM/GPRS/ EGPRS LA

Revision: G.00.00 and above

Programming Example

OUTPUT 714;"CALL:NITZone:UTIMe:TIME:TDMA 13,00,00"
!Sets the universal time to 13:00.

CALL[:CELL]:NITZone:UTIMe:UTC[:IMMediate]

Function | GSM TA | This command is not applicable to the GSM Test Application.
 | GPRS TA | This command is not applicable to the GPRS Test Application.
 | EGPRS TA | This command is not applicable to the EGPRS Test Application.
 | GSM/GPRS LA | This command sets the NITZ Universal Time and Date to the Universal Coordinated Time and Date as found on the System Configuration Screen. See Network Identity and Time Zone for more information.
 | EGPRS LA
Requirements | GSM/GPRS/ EGPRS LA | Revision: G.00.00 and above
Programming Example OUTPUT 714;"CALL:NITZone:UTIMe:UTC" !Sets the NITZ Universal Time and Date to be the Universal Coordinated Time and Date.


CALL:NMOPeration

CALL:NMOPeration

GPIB Command Conventions

  • CALL[:CELL]:NMOPeration

CALL[:CELL]:NMOPeration

Function

GSM TA

 This command is not applicable to the GSM Test Application.

GPRA TA

This command is not applicable to the GPRS Test Application.

EGPRS TA

This command is not applicable to the EGPRS Test Application.

GSM/GPRS LA

Sets/queries the Network Operation Mode. See Configuring the Broadcast Channel (BCH) .

This can only be set when the Cell Operating Mode is set to Cell Off (see CALL:OPERating:MODE ).

  • 1 - Network operation mode I
  • 2 - Network operation mode II
  • 3 - Network operation mode III

See 3GPP TS 23.060 section 6.3.3.1 for more information about the network operation mode.

EGPRS LA

Setting

Range: 1 to 3

Resolution: 1

Query

Range: 1 to 3

Resolution: 1

*RST Setting

1
Requirements GSM/GPRS/EGPRS LA

Revision: F.00.27 and above

Programming Example

OUTPUT 714;"CALL:CELL:NMOPERATION 2"
! Set the Network Operation Mode to 2.


CALL:(PBCCH|PBCChannel)

CALL:(PBCCH|PBCChannel)

Last updated: December 3, 2008

GPIB Command Conventions

  • CALL[:CELL]:(PBCCH|PBCChannel)[:STATe]
  • CALL[:CELL]:(PBCCH|PBCChannel):BA:TABLe:NCELl<n>[:STATe]
  • CALL[:CELL]:(PBCCH|PBCChannel):BA:TABLe:NCELl<n>:ARFCn
  • CALL[:CELL]:(PBCCH|PBCChannel):BA:TABLe:NCELl<n>:BCCode
  • CALL[:CELL]:(PBCCH|PBCChannel):BA:TABLe:NCELl<n>:NCCode
  • CALL[:CELL]:(PBCCH|PBCChannel):BA:TABLe:NCELl<n>:RACode
  • CALL[:CELL]:(PBCCH|PBCChannel):BA:TABLe:NCELl<n>:RPRiority
  • CALL[:CELL]:(PBCCH|PBCChannel):MS:TXLevel[:SELected]
  • CALL[:CELL]:(PBCCH|PBCChannel):NCONtrol:NDRX:PERiod
  • CALL[:CELL]:(PBCCH|PBCChannel):PRACh:LENGth

CALL[:CELL]:(PBCCH|PBCChannel)[:STATe]

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

This command sets/queries the PBCCH channel state.

The PBCCH can only be enabled in the Cell Off operating mode. Attempting to change this setting while in any mode other than Cell Off results in the following error message: "GPRS operation rejected; Attempting to set BCH parameter while generating a BCH."

EGPRS LA

Setting

Range: 0 | OFF | 1 | ON

Query

Range: 0 | 1

*RST Setting

0|OFF
Requirements GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Revision E.00.08 adds the optional :CELL mnemonic.

Programming Example

OUTPUT 714;"CALL:PBCCH ON"
! Enables the PBCCH channel.

CALL[:CELL]:(PBCCH|PBCChannel):BA:TABLe:NCELl<n>[:STATe]

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

This command sets/queries the PBCCH channel state for Neighbour Cell <n>, where <n> is any integer 1 to 32.

The Packet Broadcast Control Channel (PBCCH) state must be enabled for this parameter to take effect.
EGPRS LA

Setting

Range: 0 | OFF | 1 | ON

Query

Range: 0 | 1

*RST Setting

0|OFF
Requirements GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Revision E.00.12 adds the optional :CELL mnemonic.

Revision F.00.37 adds neighbour cell 17 to 32.

Programming Example

OUTPUT 714;"CALL:PBCCH ON"
! Enables the PBCCH channel.

CALL[:CELL]:(PBCCH|PBCChannel):BA:TABLe:NCELl<n>:ARFCn

Function

 GSM TA This command is not applicable to the GSM test application.

GPRS TA

 This command is not applicable to the GPRS test application.

EGPRS TA

 This command is not applicable to the EGPRS test application.

GSM/GPRS LA

This command sets/queries the ARFCN for Neighbour Cell <n>, where <n> is any integer 1 to 32.

The Packet Broadcast Control Channel (PBCCH) state must be enabled for this parameter to take effect.

EGPRS LA

Setting

Range: 0-1024

Resolution: 1

Query

Range: 0-1024

Resolution: 1

*RST Setting

 See Default ARFCNs in PBCCH BA Table .
Requirements GSM/GPRS/ EGPRS LA

Revision: E.00.12 and above.

Revision F.00.37 adds neighbour cell 17 to 32.

Programming Example

OUTPUT 714;"CALL:PBCCH:BA:TABLe:NCELl1:ARFCN?"
! Queries the ARFCN setting for Neighbour Cell 1.

CALL[:CELL]:(PBCCH|PBCChannel):BA:TABLe:NCELl<n>:BCCode

Function GSM TA This command is not applicable to the GSM test application.

GPRS TA

 This command is not applicable to the GPRS test application.

EGPRS TA

 This command is not applicable to the GPRS test application.

GSM/GPRS LA

This command sets/queries the Base Station Color Code (BCC) for Neighbour Cell <n>, where <n> is any integer 1 to 32.

The Packet Broadcast Control Channel (PBCCH) state must be enabled for this parameter to take effect.

EGPRS LA

Setting

Range: 0 to 7

Resolution: 1

Query

Range: 0 to 7

Resolution: 1

*RST Setting

 5
Requirements GSM/GPRS/ EGPRS LA

Revision: E.00.12 and above.

Revision F.00.37 adds neighbour cell 17 to 32.

Programming Example

OUTPUT 714;"CALL:PBCCH:BA:TABLe:NCELl1:BCCode 1"
! Sets the BCC for Neighbour Cell 1 of the selected cell band to 1.

CALL[:CELL]:(PBCCH|PBCChannel):BA:TABLe:NCELl<n>:NCCode

Function GSM TA This command is not applicable to the GSM test application.

GPRS TA

 This command is not applicable to the GPRS test application.

GPRS TA

 This command is not applicable to the GPRS test application.

GSM/GPRS LA

This command sets/queries the Network Color Code (NCC) for Neighbour Cell <n>, where <n> is any integer 1 to 32.

The Packet Broadcast Control Channel (PBCCH) state must be enabled for this parameter to take effect.

EGPRS LA

Setting

Range: 0 to 7

Resolution: 1

Query

Range: 0 to 7

Resolution: 1

*RST Setting

 1
Requirements GSM/GPRS/ EGPRS LA

Revision: E.00.12 and above.

Revision F.00.37 adds neighbour cell 17 to 32.

Programming Example

OUTPUT 714;"CALL:PBCCH::BA:TABLe:NCELl1:NCCode 1"
! Sets the NCC for Neighbour Cell 1 of the selected cell band to 1.

CALL[:CELL]:(PBCCH|PBCChannel):BA:TABLe:NCELl<n>:RACode

Function GSM TA This command is not applicable to the GSM test application.

GPRS TA

 This command is not applicable to the GPRS test application.

GPRS TA

 This command is not applicable to the GPRS test application.

GSM/GPRS LA

This command sets/queries the Routing Area Code (RAC) for Neighbour Cell <n>, where <n> is any integer 1 to 32.

The Packet Broadcast Control Channel (PBCCH) state must be enabled for this parameter to take effect.

EGPRS LA

Setting

Range: 0 to 255

Resolution: 1

Query

Range: 0 to 255

Resolution: 1

*RST Setting

 1
Requirements GSM/GPRS/ EGPRS LA

Revision: E.00.12 and above.

Revision F.00.37 adds neighbour cell 17 to 32.

Programming Example

OUTPUT 714;"CALL:PBCCH:BA:TABLe:NCELl1:RACode 1"
! Sets the RAC for Neighbour Cell 1 of the selected cell band to 1.

CALL[:CELL]:(PBCCH|PBCChannel):BA:TABLe:NCELl<n>:RPRiority

Function

 GSM TA This command is not applicable to the GSM Test Application.

GPRS TA

 This command is not applicable to the GPRS Test Application.

EGPRS TA

 This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

This command sets/queries the Report Priority for Neighbour Cell <n>, where <n> is any integer 1 to 32.

The Packet Broadcast Control Channel (PBCCH) state must be enabled for this parameter to take effect.

EGPRS LA

Setting

Range: HIGH | LOW

Query

Range: HIGH | LOW

*RST Setting

0|LOW
Requirements GSM/GPRS/ EGPRS LA

Revision: E.00.12 and above.

Revision F.00.37 adds neighbour cell 17 to 32.

Programming Example

OUTPUT 714;"CALL:CELL:PBCCH:BA:TABLE:NCELL3:RPRIORITY HIGH"
! Sets Report Priority of Neighbour cell 3 to HIGH.

CALL[:CELL]:(PBCCH|PBCChannel):MS:TXLevel[:SELected]

CALL[:CELL]:(PBCCH|PBCChannel):MS:TXLevel:(DCS|EGSM|GSM450|GSM480|GSM750|GSM850|PCS|PGSM|RGSM|TGSM810)

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

This command sets/queries the maximum GPRS MS TX Power parameter. This parameter controls the maximum TX power level an MS may use when accessing the network via the PBCCH.
EGPRS LA

Setting

(Depends on the band.)

DCS:

  • Range: 0 to 28, Resolution: 1

PCS:

  • Range: 0 to 15, 30, and 31, Resolution: 1

All other bands:

  • Range: 0 to 15, 30, and 31, Resolution: 1

Query

(Depends on the band.)

DCS:

  • Range: 0 to 28, Resolution: 1

PCS:

  • Range: 0 to 15, 30, and 31, Resolution: 1

All other bands:

  • Range: 0 to 15, 30, and 31, Resolution: 1

*RST Setting

 0
Requirements GSM/GPRS/ EGPRS LA

Revision: E.00.08 and above

Programming Example

OUTPUT 714;"CALL:PBCCH:MS:TXLevel 0"
! Sets the MS TX level to 0.

CALL[:CELL]:(PBCCH|PBCChannel):NCONtrol:NDRX:PERiod

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

This command sets/queries the Network Control Non-DRX (discontinuous reception) Period. 3GPP TS 05.08 states, "In non-DRX mode, the MS shall only increment/decrement DSC (downlink signaling failure counter) for one block per DRX period according to its paging group."

EGPRS LA

Setting

Range: 0 to 7, which corresponds to 0.48, 0.96, 1.92, 3.84, 7.68, 15.36, 30.72, and 61.44 seconds.

3GPP TS 04.06 section 11.2.23 shows the values in the NC_REPORTING_PERIOD_T (3-bit field)

bit

3 2 1

0 0 0 0.48 sec

0 0 1 0.96 sec

0 1 0 1.92 sec

0 1 1 3.84 sec

1 0 0 7.68 sec

1 0 1 15.36 sec

1 1 0 30.72 sec

1 1 1 61.44 sec

Resolution: 1

Query

Range: 0 to 7

Resolution: 1

*RST Setting

 2
Requirements GSM/GPRS/ EGPRS LA

Revision: E.00.08 and above

Programming Example

OUTPUT 714;"CALL:PBCCH:NCONtrol:NDRX:Period 2"
! Sets the non-DRX period to 1.92 seconds.

CALL[:CELL]:(PBCCH|PBCChannel):PRACh:LENGth

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

This command sets/queries the number of bits used in the PRACH of the PBCCH.

This setting can only be changed while in the Cell Off operating mode. Attempting to change this setting while in any mode other than Cell Off results in the following error message: "GPRS operation rejected; Attempting to set BCH parameter while generating a BCH."
EGPRS LA

Setting

Range: 8 or 11

Query

Range: 8 or 11

*RST Setting

8
Requirements GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Revision E.00.08 adds the optional :CELL mnemonic.

Programming Example

OUTPUT 714;"CALL:PBCCH:PRACh:LENGth?"
! Queries the PRACH length.


CALL:PFContext

CALL:PFContext

GPIB Command Conventions

  • CALL[:CELL]:PFContext[:STATe]

CALL[:CELL]:PFContext[:STATe]

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

Sets/Queries the Packet Flow Context (PFC) State. When the Packet Flow Context state is set to ON, You can set the Packet Flow Identifier (PFI) for each QoS Profile using the GPIB command CALL:PPRocedure[:QOSProfile[1]|2|3|4]:PFI .

Note: The Operating Mode must be set to Cell Off before setting this parameter. See CALL:OPERating for more details.
EGPRS LA

Setting

 Range: 1|ON|0|OFF

Query

1|0

*RST Setting

 OFF

Requirements

 GSM/GPRS/ EGPRS LA

Revision: F.00.37 and above

Programming Example:

OUTPUT 714;"CALL:CELL:PFCONTEXT ON"
! Sets the Packet Flow Context State to ON.


CALL:PLOGging

CALL:PLOGging

GPIB Command Conventions

  • CALL:PLOGging:STARt
  • CALL:PLOGging:STOP
  • CALL:PLOGging:STATus? or CALL:PLOGging:STATe?
  • CALL:PLOGging:CONNected?
  • CALL:PLOGging:ACTive?
  • CALL:PLOGging:DONE?

CALL:PLOGging:STARt

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

This command starts protocol logging.
EGPRS LA
Requirements GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:PLOGGING:START"
! Starts protocol logging.

CALL:PLOGging:STOP

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

This command stops protocol logging.
EGPRS LA
Requirements GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:PLOGGING:STOP"

CALL:PLOGging:STATus? or CALL:PLOGging:STATe?

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

This command queries the protocol logging status (idle or active).
EGPRS LA

Query

Range: IDLE|ACT

*RST Setting

IDLE
Requirements GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:PLOGGING:STATE?"
ENTER 714;variable_name$

CALL:PLOGging:CONNected?

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

This query returns an integer value of 1 if the status of the test set's protocol logging data source is either:

  • IDLE - A real-time protocol logging session has been established between the test set and the protocol logging software, but protocol logging is not currently taking place.
  • ACT (Active) - Both a real-time session and a logging session have been established and data is being captured by the protocol logging software.

If the state of the test set's protocol logging data source is not one of the above, this query will "hang" until a transition to one of these states occurs, or a bus time-out or device clear terminates the query attempt.
EGPRS LA

Query

 Range: 1
Requirements GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:PLOGGING:CONN?"
! Queries the connected state.

CALL:PLOGging:ACTive?

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

This query returns an integer value of 1 if the status of the test set's protocol logging data source is:

  • ACT (Active) - Both a real-time session and a logging session have been established and data is being captured by the protocol logging software.

If the state of the test set's protocol logging data source is not Active, this query will "hang" until a transition to the Active state occurs, or a bus time-out or device clear terminates the query attempt.
EGPRS LA

Query

 Range: 1
Requirements GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:PLOGGING:ACT?"
! Queries the Active state.

CALL:PLOGging:DONE?

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

This query returns an integer value of 1 if the status of the test set's protocol logging data source is either:

  • DISC (Disconnected) - There is no real-time protocol logging session established between the test set and the protocol logging software.
  • IDLE - A real-time protocol logging session has been established between the test set and the protocol logging software, but protocol logging is not currently taking place.

If the state of the test set's protocol logging data source is not one of the above, this query will "hang" until a transition to one of these states occurs, or a bus time-out or device clear terminates the query attempt.
EGPRS LA

Query

 Range: 1
Requirements GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:PLOGGING:DONE?"
! Queries the done (logging) state.


CALL:PPRocedure

CALL:PPRocedure

Syntax Diagrams and Command Descriptions

CALL:PPRocedure:ATTach

CALL:PPRocedure:DETach

CALL:PPRocedure:IDENtity

CALL:PPRocedure:LAU|LAUPdate

CALL:PPRocedure:PDPContext

CALL:PPRocedure:PLMNetwork

CALL:PPRocedure:PMEasurement:ADATa

CALL:PPRocedure:PMEasurement:MPRequest

CALL:PPRocedure:PMEasurement:MS

CALL:PPRocedure:PMEasurement:MS:RESet

CALL:PPRocedure:PMEasurement:PERRor

CALL:PPRocedure:PMEasurement:PIPE

CALL:PPRocedure:PMEasurement:PRESponse:AVAilable?

CALL:PPRocedure:PMEasurement:PRESponse:LIERror

CALL:PPRocedure:PMEasurement:PRESponse:LINFormation

CALL:PPRocedure:PMEasurement:PRESponse:MINFormation

CALL:PPRocedure:PMEasurement:PRESponse:MSETs

CALL:PPRocedure:PMEasurement:PRESponse:RIDentity

CALL:PPRocedure:RAU|RAUPdate


CALL:PPRocedure:ATTach

CALL:PPRocedure:ATTach

GPIB Command Conventions

  • CALL:PPRocedure:ATTach:ACCept:IAReject:GMMCause
  • CALL:PPRocedure:ATTach:ACCept:IAReject:STATe
  • CALL:PPRocedure:ATTach:REJect:GMMCause
  • CALL:PPRocedure:ATTach:REJect:STATe

CALL:PPRocedure:ATTach:ACCept:IAReject:GMMCause

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

Sets the GMM Cause for Rejecting IMSI attach for non-GPRS services.

EGPRS LA
Setting

Range: 0 to 255 (decimal) See GMM Cause Information Element .

Query

Range: 0 to 255

*RST setting

 111

Requirements

 GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example:

OUTPUT 714;"CALL:PPROCEDURE:ATTACH:ACCEPT:IAREJECT:GMMCAUSE 3"
! The test set sends this GMM cause value to the MS as the reason for rejecting its attach attempt.

CALL:PPRocedure:ATTach:ACCept:IAReject:STATe

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

Sets/Queries IMSI attach accept state.

EGPRS LA
Setting

Range: 0| OFF | 1 | ON

Query

Range: 0 | 1

*RST setting

 0

Requirements

 GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example:

OUTPUT 714;"CALL:PPROCEDURE:ATTACH:ACCEPT:IAREJECT:STATE 1"
! The test set will now reject any attach attempt that is not for GPRS only.

CALL:PPRocedure:ATTach:REJect:GMMCause

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

Sets the GMM Cause for rejecting IMSI attach.

EGPRS LA
Setting

Range: 0 to 255 (decimal) See GMM Cause Information Element .

Query

Range: 0 to 255

*RST setting

 111

Requirements

 GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example:

OUTPUT 714;"CALL:PPROCEDURE:ATTACH:REJECT:GMMCAUSE 3"
! The test set sends this GMM cause value to the MS as the reason for rejecting its attach attempt.

CALL:PPRocedure:ATTach:REJect:STATe

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

Sets/Queries IMSI attach reject state.

EGPRS LA
Setting

Range: 0| OFF | 1 | ON

Query

Range: 0 | 1

*RST setting

 0

Requirements

 GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example:

OUTPUT 714;"CALL:PPROCEDURE:ATTACH:REJECT:STATE 1"
! Turns state on.  Now the test set will reject all attach attempts.


CALL:PPRocedure:DETach

CALL:PPRocedure:DETach

GPIB Command Conventions

  • CALL:PPRocedure:DETach:REQuest[:IMMediate]
  • CALL:PPRocedure:DETach:REQuest:GMMCause
  • CALL:PPRocedure:DETach:REQuest:TYPE

CALL:PPRocedure:DETach:REQuest[:IMMediate]

Function

GSM TA

 This command is not applicable to the GSM test applications.
GPRS TA

This command sends detach request.

For an explanation of the :DONE?, :OPComplete?, :SEQuential, and :WAIT commands, see Call Processing Event Synchronization .
EGPRS TA
GSM/GPRS LA
EGPRS LA

Requirements

GSM/GPRS/ EGPRS TA

Revision: A.04 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example:

OUTPUT 714;"CALL:PPRocedure:DETach:REQuest"
! Sends a network initiated Detach Request.

CALL:PPRocedure:DETach:REQuest:GMMCause

Function

GSM TA

 This command is not applicable to the GSM test applications.
GPRS TA

This command sets/queries the GMM Cause for the test set to send a detach request.

See GMM Cause Information Element for details on settings this parameter accepts as defined in 3GPP TS 24.008 Version 6.7.0.

EGPRS TA
GSM/GPRS LA
EGPRS LA
Setting

Range: 0 to 255 (decimal)

Query

Range: 0 to 255

*RST setting

 +111

Requirements

GSM/GPRS/ EGPRS TA

Revision A.04 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example:

OUTPUT 714;"CALL:PPRocedure:DETach:REQuest:GMMCause 96"
! The test set sends the MS this GMM Cause value as the reason for requesting a detach.

CALL:PPRocedure:DETach:REQuest:TYPE

Function

GSM TA

 This command is not applicable to the GSM test applications.
GPRS TA This command sets/queries the type of detach request.

See Detach Type Information Element for details on settings this parameter accepts.
EGPRS TA
GSM/GPRS LA
EGPRS LA
Setting

Range: REQ|NREQ|IMSI

Query

Range: REQ|NREQ|IMSI

*RST setting

 NREQ

Requirements

GSM/GPRS/ EGPRS TA

Revision A.04 and above
GSM/GPRS/ EGPRS LA

Revision: D.02 and above

Programming Example:

OUTPUT 714;"CALL:PPRocedure:DETach:REQuest:TYPE REQ"
! Sets the detach type to REQ.


CALL:PPRocedure:PLMNetwork

CALL:PPRocedure:PLMNetwork

GPIB Command Conventions

  • CALL:PPRocedure:PLMNetwork[:LIST]
  • CALL:PPRocedure:PLMNetwork[:LIST]:POINts?

CALL:PPRocedure:PLMNetwork[:LIST]

Function

GSM TA

 This command is not applicable to the GSM test applications.
GPRS TA | This command is not applicable to the GPRS test applications.
EGPRS TA | This command is not applicable to the EGPRS test applications.
GSM/GPRS LA

This command sets the list of equivalent PLMNs. See Equivalent PLMN List for more information.

EGPRS LA
Setting

Range:

  • MCC: 0 to 999
  • MNC: 0 to 999

Query

Range:

  • MCC: 0 to 999 and 9.91E+37(NAN)
  • MNC: 0 to 999 and 9.91E+37(NAN)

*RST setting
  • MCC MNC
  • PLMN1 0 0
  • PLMN2 1 1
  • PLMN3 2 2
  • PLMN4 3 3
  • PLMN5 4 4
  • PLMN6 5 5
  • PLMN7 6 6
  • PLMN8 7 7
  • PLMN9 8 8
  • PLMN10 9 9
  • PLMN11 10 10
  • PLMN12 11 11
  • PLMN13 12 12
  • PLMN14 13 13
  • PLMN15 14 14

Requirements

 GSM/GPRS/ EGPRS LA

Revision: F.00.37and above

Programming Example:

OUTPUT 714;"CALL:PPRocedure:PLMNetwork 1,3,7,9,55,32,55,87,654,525,5,54,88,56,26,4,8,56,25,42,22,666,545,222,88,56,5,9,5,2"
! The test set the list of equivalent PLMNs to {1,3,7,9,55,32,55,87,654,525,5,54,88,56,26,4,8,56,25,42,22,666,545,222,88,56,5,9,5,2}".

CALL:PPRocedure:PLMNetwork[:LIST]:POINts?

Function

GSM TA

 This command is not applicable to the GSM test applications.
GPRS TA | This command is not applicable to the GPRS test applications.
EGPRS TA | This command is not applicable to the EGPRS test applications.
GSM/GPRS LA | This query returns the the number of the comma-seperated items that are returned via the corresponding equivalent PLMNs list.
EGPRS LA

Query

Range: 0 to 15

*RST setting

0

Requirements

 GSM/GPRS/ EGPRS LA

Revision: F.00.37 and above

Programming Example:

OUTPUT 714;"CALL:PPRocedure:PLMNetwork:[LIST]:POINts?"
! Queries the the number of the comma-seperated items that are returned via the corresponding
! equivalent PLMNs list.


CALL:PPRocedure:IDENtity

CALL:PPRocedure:IDENtity

GPIB Command Conventions

  • CALL:PPRocedure:IDENtity:REQuest[:IMMediate]
  • CALL:PPRocedure:IDENtity:REQuest:RESults?
  • CALL:PPRocedure:IDENtity:REQuest:RESults:CLEar
  • CALL:PPRocedure:IDENtity:REQuest:TYPE

CALL:PPRocedure:IDENtity:REQuest[:IMMediate]

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

Sends an Identity Request .

EGPRS LA

Requirements

 GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example:

OUTPUT 714;"CALL:PPROCEDURE:IDENTITY:REQUEST"
! Sends an identity request to the MS.

CALL:PPRocedure:IDENtity:REQuest:RESults?

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

Queries identity results and returns four string values for IMSI, IMEI, IMEISV, TMSI in order.
EGPRS LA

Requirements

 GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example:

OUTPUT 714;"CALL:PPROCEDURE:IDENTITY:REQUEST:RESULTS"
! Queries identity results.

CALL:PPRocedure:IDENtity:REQuest:RESults:CLEar

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

Clears the Identity Request results.

EGPRS LA

Requirements

 GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example:

OUTPUT 714;"CALL:PPROCEDURE:IDENTITY:REQUEST:RESULTS:CLEAR"
! Queries identity results.

CALL:PPRocedure:IDENtity:REQuest:TYPE

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

Sets/Queries the type of Identity to Request. See Identity Request for more information.

NOTE
The test set always displays a zero for the 15th digit of the IMEI. This behavior conforms to 3GPP TS 03.03, which requires that the 15th digit (referred to as Spare digit or Check Digit) "shall be zero, when transmitted by the MS", and 3GPP TS 02.16 which states that the "check digit is not part of the digits transmitted at IMEI check equations".
EGPRS LA
Setting

IMSI|IMEI|EISV|TMSI

Query

 IMSI|IMEI|EISV|TMSI

*RST Setting

 IMSI

Requirements

 GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example:

OUTPUT 714;"CALL:PPROCEDURE:IDENTITY:REQUEST:TYPE IMEI"
! Sets IMEI as the identity type to request


CALL:PPRocedure:LAU|LAUPdate

CALL:PPRocedure:LAU|LAUPdate

GPIB Command Conventions

  • CALL:PPRocedure:LAU|LAUPdate:REJect[:STATe]
  • CALL:PPRocedure:LAU|LAUPdate:REJect:GMMCause
  • CALL:PPRocedure:LAU|LAUPdate:T3212

CALL:PPRocedure:LAU|LAUPdate:REJect[:STATe]

Function

GSM TA

 This command is not applicable to the GSM test applications.
GPRS TA | This command is not applicable to the GPRS test applications.
EGPRS TA | This command is not applicable to the EGPRS test applications.
GSM/GPRS LA

This command sets Location Area Update Reject State. When the parameter is set to ON, the test set will reject the LAU request from the mobile station.

EGPRS LA
Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST setting

 0|OFF

Requirements

 GSM/GPRS/ EGPRS LA

Revision: F.00.27 and above

Programming Example:

OUTPUT 714;"CALL:PPRocedure:LAUPdate:REJect:STATe ON"
! Sets the Location Area Update Reject State to ON.

CALL:PPRocedure:LAU|LAUPdate:REJect:GMMCause

Function

GSM TA

 This command is not applicable to the GSM test applications.
GPRS TA | This command is not applicable to the GPRS test applications.
EGPRS TA | This command is not applicable to the EGPRS test applications.
GSM/GPRS LA

This command sets the Location Area Update Reject cause.

See GMM Cause Information Element for details on settings this parameter accepts as defined in 3GPP TS 24.008 Version 6.7.0.

EGPRS LA
Setting

Range: 0 to 255 (decimal)

Query

Range: 0 to 255

*RST setting

+12

Requirements

 GSM/GPRS/ EGPRS LA

Revision: F.00.27 and above

Programming Example:

OUTPUT 714;"CALL:PPRocedure:LAUPdate:REJect:GMMCause 3"
! The test set sends the MS the RAU Reject cause value as "Illegal MS".

CALL:PPRocedure:LAU|LAUPdate:T3212

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

Sets the Periodic Location Update Timer value. See Configurable Timers .
EGPRS LA
Setting

Range: 0 to 255 (decihours)

Query

Range: 0 to 255 (decihours)

*RST setting

 0

Requirements

 GSM/GPRS/ EGPRS LA

Revision: F.00.27 and above

Programming Example:

OUTPUT 714;"CALL:PPROCEDURE:LAU:T3212 20"
! Set the expire time of T3212 to 2 decihours (12 minutes).


CALL:PPRocedure:PDPContext

CALL:PPRocedure:PDPContext

GPIB Command Conventions

  • CALL:PPRocedure[:QOSProfile[1]|2|3|4]:PDPContext:AACCept:QOService:RCLass:SUBScribed
  • CALL:PPRocedure[:QOSProfile[1]|2|3|4]:PDPContext:AACCept:QOService:RCLass:ENForce:[SVALue]
  • CALL:PPRocedure[:QOSProfile[1]|2|3|4]:PDPContext:AACCept:QOService:RCLass:ENForce:STATe
  • CALL:PPRocedure[:QOSProfile[1]|2|3|4]:PDPContext:AACCept:QOService:RCLass:ENForce:VALue
  • CALL:PPRocedure:PDPContext:AREJect:SMCause
  • CALL:PPRocedure:PDPContext:AREJect:STATe
  • CALL:PPRocedure[:QOSProfile]:PDPContext:NINitiated[:STATe]
  • CALL:PPRocedure[:QOSProfile[1]|2|3|4]:PFI
  • CALL:PPRocedure[:QOSProfile[1]|2|3|4]:TCLass
  • CALL:PPRocedure[:QOSProfile[1]|2|3|4]:THPRiority

CALL:PPRocedure[:QOSProfile[1]|2|3|4]:PDPContext:AACCept:QOService:RCLass:SUBScribed

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA Sets/Queries the Subscribed Reliability Class of QOS Profile 1, 2, 3 or 4 which represents Quality of Service Reliability Class that will be supplied to the MS if it requests its subscribed value. The subscribed reliability class is only applicable for pre R99 Context Request messages. See GSM 05.08 for specific values. Some values are listed below.
EGPRS LA

Setting

 Range: 0 to 7 (decimal)

0: (Undefined)
1: (Ack GTP, LLC, RLC;Protected Data)
2: (Unack GTP, ack LLC, RLC;Protected Data)
3: (Unack GTP, LLC, ack RLC;Protected Data)
4: (Unack GTP, LLC, RLC;Protected Data)
5: (Unack GTP, LLC, RLC;Unprotected Data)
6: (Undefined)
7: (Undefined)

Query

0 to 7

*RST Setting

3 for QOS Profile 1

4 for QOS Profile 2, 3, and 4.

Requirements

 GSM/GPRS/ EGPRS LA

Revision: C.01 and above for QOS Profile 1

E.00.12 and above for QOS Profile 2, 3 and 4.

Programming Example:

OUTPUT 714;"CALL:PPROCEDURE:QOSPROFILE2:PDPCONTEXT:AACCEPT:QOSERVICE:RCLASS:SUBSCRIBED 5"
! Sets the subscribed QoS Reliability Class of QOS Profile 2 to 5.

CALL:PPRocedure[:QOSProfile[1]|2|3|4]:PDPContext:AACCept:QOService:RCLass:ENForce:[SVALue]

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA Complex command to both set the PDP Context Accept Override Reliability Class state to On and set/query the PDP Context Accept Override Reliability Class Value for QOS Profile 1, 2, 3 or 4 respectively. See GSM 04.08 for specific values. The values are listed below.
EGPRS LA

Setting

 Range: 0 to 7 (decimal)

0: (Undefined)
1: (Ack GTP, LLC, RLC;Protected Data)
2: (Unack GTP, ack LLC, RLC;Protected Data)
3: (Unack GTP, LLC, ack RLC;Protected Data)
4: (Unack GTP, LLC, RLC;Protected Data)
5: (Unack GTP, LLC, RLC;Unprotected Data)
6: (Undefined)
7: (Undefined)

Query

0 to 7

*RST Setting

3 for QOS Profile 1

4 for QOS Profile 2, 3 and 4

Requirements

 GSM/GPRS/ EGPRS LA

Revision: C.01 and above for QOS Profile 1

E.00.12 and above for QOS Profile 2, 3 and 4

Programming Example:

OUTPUT 714;"CALL:PPROCEDURE:QOSPROFILE2:PDPCONTEXT:AACCEPT:QOSERVICE:RCLASS:ENFORCE:SVALUE 1"
! The test set will now override the QoS requested by the MS if QOSPROFILE2 is allocated.

CALL:PPRocedure[:QOSProfile[1]|2|3|4]:PDPContext:AACCept:QOService:RCLass:ENForce:STATe

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

Sets/Queries the Override Requested Reliability Class state of QOS Profile 1, 2, 3 or 4.

EGPRS LA
Setting

Range: 0|OFF|1|ON

Query

Range: 0|1

*RST setting

 0

Requirements

 GSM/GPRS/ EGPRS LA

Revision: C.01 and above for QOS Profile 1

E.00.12 and above for QOS Profile 2, 3 and 4

Programming Example:

OUTPUT 714;"CALL:PPROCEDURE:QOSPROFILE2:PDPCONTEXT:AACCEPT:QOSERVICE:RCLASS:ENFORCE:STATE 1"
! The test set will now override the QoS requested by the MS if QOSPROFILE2 is allocated.

CALL:PPRocedure[:QOSProfile[1]|2|3|4]:PDPContext:AACCept:QOService:RCLass:ENForce:VALue

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA Sets/Queries the Override Requested Reliability Class Value of QOS Profile 1, 2, 3 or 4 which represents Quality of Service Reliability Class that will be supplied to the DUT when the Override Requested Reliability Class State is set to ON. See GSM 04.08 for specific values. The values are listed below.
EGPRS LA

Setting

 Range: 0 to 7 (decimal)
0: (Undefined)
1: (Ack GTP, LLC, RLC;Protected Data)
2: (Unack GTP, ack LLC, RLC;Protected Data)
3: (Unack GTP, LLC, ack RLC;Protected Data)
4: (Unack GTP, LLC, RLC;Protected Data)
5: (Unack GTP, LLC, RLC;Unprotected Data)
6: (Undefined)
7: (Undefined)

Query

0 to 7

*RST Setting

3 for QOS Profile 1

4 for QOS Profile 2, 3 and 4

Requirements

 GSM/GPRS/ EGPRS LA

Revision: C.01 and above for QOS Profile 1

E.00.12 and above for QOS Profile 2, 3 and 4

Programming Example:

OUTPUT 714;"CALL:PPROCEDURE:QOSPROFILE2:PDPCONTEXT:AACCEPT:QOSERVICE:RCLASS:ENFORCE:Value 1"
! Set the Override Reliability Class value of QOS Profile 2 to 1.

CALL:PPRocedure:PDPContext:AREJect:SMCause

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA Sets/Queries the SM Cause for Rejecting PDP Context.
EGPRS LA
Setting

Range: 0 to 255 (decimal) See SM Cause Information Element .

Query

Range: 0 to 255

*RST setting

 111

Requirements

 GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example:

OUTPUT 714;"CALL:PPROCEDURE:PDPCONTEXT:AREJECT:SMCAUSE 37"
! The test set sends SM Cause value 37 to the MS when it rejects its PDP Context Request

CALL:PPRocedure:PDPContext:AREJect:STATe

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

Sets/Queries the PDP Context Reject state. See Activate PDP Context Reject

EGPRS LA
Setting

Range: 0|OFF|1|ON

Query

Range: 0|1

*RST setting

 0

Requirements

 GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example:

OUTPUT 714;"CALL:PPROCEDURE:PDPCONTEXT:AREJECT:STATE 1"
! Sets the test set to reject all PDP Context Requests

CALL:PPRocedure[:QOSProfile]:PDPContext:NINitiated[:STATe]

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

Sets/Queries the Network Initiated PDP Context state. See Network Initiated PDP Context

EGPRS LA
Setting

Range: 0|OFF|1|ON

Query

Range: 0|1

*RST setting

 1

Requirements

 GSM/GPRS/ EGPRS LA

Revision: F.00.27 and above

Programming Example:

OUTPUT 714;"CALL:PPR:PDPC:NIN 1"
! Sets the Network Initiated PDP Context State to ON

CALL:PPRocedure[:QOSProfile[1]|2|3|4]:PFI

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA Sets/Queries Packet Flow Identifier (PFI) of QOS Profile 1, 2, 3 or 4 respectively.
EGPRS LA
Setting

Range: 0, 2, 8 to 127

Query

Range: 0, 2, 8 to 127

*RST setting

 0

Requirements

 GSM/GPRS/ EGPRS LA

Revision: F.00.37 and above

Programming Example:

OUTPUT 714;"CALL:PPROCEDURE:QOSPROFILE2:PFI 2"
! Set the PFI of QOS Profile 2 to 2 (SMS).

CALL:PPRocedure[:QOSProfile[1]|2|3|4]:TCLass

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA Sets/Queries Traffic Class of QOS Profile 1, 2, 3 or 4 respectively.
EGPRS LA
Setting

Range: CONVersation | STReaming | INTeractive | BACKground

Query

Range: CONV |STR | INT |BACK

*RST setting

 INT

Requirements

 GSM/GPRS/ EGPRS LA

Revision: E.00.12 and above

Programming Example:

OUTPUT 714;"CALL:PPROCEDURE:QOSPROFILE2:TCLass STR"
! Set the Traffic class of QOS Profile 2 to Streaming.

CALL:PPRocedure[:QOSProfile[1]|2|3|4]:THPRiority

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

Sets/Queries the Traffic Handling Priority of QOS Profile 1, 2, 3 or 4 respectively.

EGPRS LA
Setting

Range: 1 to 3

Resolution: 1

Query

Range: 1 to 3

*RST setting

 2

Requirements

 GSM/GPRS/ EGPRS LA

Revision: E.00.12 and above

Programming Example:

OUTPUT 714;"CALL:PPROCEDURE:QOSPROFILE2:THPRIORITY 1"
! Sets Traffic Handling Priority of QOS Profile 2 to 1.


CALL:PPRocedure:PMEasurement:ADATa

CALL:PPRocedure:PMEasurement:ADATa

GPIB Command Conventions

  • CALL:PPRocedure:PMEasurement:ADATa:ACKNowledged?
  • CALL:PPRocedure:PMEasurement:ADATa:MAData
  • CALL:PPRocedure:PMEasurement:ADATa:MORE
  • CALL:PPRocedure:PMEasurement:ADATa:RAData
  • CALL:PPRocedure:PMEasurement:ADATa:REL98|RELEASE98
  • CALL:PPRocedure:PMEasurement:ADATa:SEND

CALL:PPRocedure:PMEasurement:ADATa:ACKNowledged?

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA Queries the status of the last Assistance Data message sent to the MS. This query returns a "0" when the a message has been sent but an acknowledgment has not been received from the MS. A "1" is returned after an acknowledgment has been received and before another Assistance Data message is sent.
EGPRS LA
Query

0 | 1

Requirements

 GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example:

OUTPUT 714;"CALL:PPRocedure:PMEasurement:ADATa:ACKNowledged?"

CALL:PPRocedure:PMEasurement:ADATa:MAData

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA Includes or excludes the optional E-OTD Measurement Assistance Data element from the Assistance Data component.
EGPRS LA

Setting

 INCLude|EXCLude

Query

 INCL|EXCL

*RST setting

 EXCL

Requirements

 GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example:

OUTPUT 714;"CALL:PPRocedure:PMEasurement:ADATa:MAData INCL"

CALL:PPRocedure:PMEasurement:ADATa:MORE

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA Sets the value of the More Assistance Data To Be Sent element of the Assistance Data component. This is used to indicate to the MS if more Assistance Data components will be sent in order to deliver the entire set of assistance data.
EGPRS LA

Setting

 0|1

Query

 0|1

*RST setting

 0

Requirements

 GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example:

OUTPUT 714;"CALL:PPRocedure:PMEasurement:ADATa:MORE 1"

CALL:PPRocedure:PMEasurement:ADATa:RAData

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA Includes or excludes the optional E-OTD Reference BTS for Assistance Data element from the Assistance Data component.
EGPRS LA

Setting

 INCLude|EXCLude

Query

 INCL|EXCL

*RST setting

 EXCL

Requirements

 GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example:

OUTPUT 714;"CALL:PPRocedure:PMEasurement:ADATa:RAData INCL"

CALL:PPRocedure:PMEasurement:ADATa:REL98|RELEASE98

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA Includes or excludes the optional Release 98 Extension element from the Assistance Data component. You can set the value of these fields using the following commands: CALL:PPRocedure:PMEasurement:MPRequest:REL98|RELEASE98:BTS[<n>]:EOTDiff CALL:PPRocedure:PMEasurement:MPRequest:REL98|RELEASE98:BTS[<n>]:EOTDiff:UNCertainty
EGPRS LA

Setting

 INCLude|EXCLude

Query

 INCL|EXCL

*RST setting

 EXCL

Requirements

 GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example:

OUTPUT 714;"CALL:PPRocedure:PMEasurement:ADATa:REL98 INCL"

CALL:PPRocedure:PMEasurement:ADATa:SEND

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA Sends the Assistance Data component in an RRLP message.
EGPRS LA

Requirements

 GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example:

OUTPUT 714;"CALL:PPRocedure:PMEasurement:ADATa:SEND"


CALL:PPRocedure:PMEasurement:MPRequest

CALL:PPRocedure:PMEasurement:MPRequest

GPIB Command Conventions

  • CALL:PPRocedure:PMEasurement:MPRequest:MAData
  • CALL:PPRocedure:PMEasurement:MPRequest:MAData:BTS[<n>]:BCHCarrier
  • CALL:PPRocedure:PMEasurement:MPRequest:MAData:BTS[<n>]:BSICode
  • CALL:PPRocedure:PMEasurement:MPRequest:MAData:BTS[<n>]:CASSistance
  • CALL:PPRocedure:PMEasurement:MPRequest:MAData:BTS[<n>]:CASSistance:FRTDiff
  • CALL:PPRocedure:PMEasurement:MPRequest:MAData:BTS[<n>]:CASSistance:RALTitude
  • CALL:PPRocedure:PMEasurement:MPRequest:MAData:BTS[<n>]:CASSistance:RALTitude:VALue
  • CALL:PPRocedure:PMEasurement:MPRequest:MAData:BTS[<n>]:CASSistance:REASt
  • CALL:PPRocedure:PMEasurement:MPRequest:MAData:BTS[<n>]:CASSistance:RNORth
  • CALL:PPRocedure:PMEasurement:MPRequest:MAData:BTS[<n>]:MOFFset
  • CALL:PPRocedure:PMEasurement:MPRequest:MAData:BTS:NUMBer
  • CALL:PPRocedure:PMEasurement:MPRequest:MAData:BTS[<n>]:RRTDiff

  • CALL:PPRocedure:PMEasurement:MPRequest:PINStruction:ACCuracy
  • CALL:PPRocedure:PMEasurement:MPRequest:PINStruction:ACCuracy
  • CALL:PPRocedure:PMEasurement:MPRequest:PINStruction:ACCuracy:VALue
  • CALL:PPRocedure:PMEasurement:MPRequest:PINStruction:ECHaracter
  • CALL:PPRocedure:PMEasurement:MPRequest:PINStruction:ECHaracter:VALue
  • CALL:PPRocedure:PMEasurement:MPRequest:PINStruction:MSETs
  • CALL:PPRocedure:PMEasurement:MPRequest:PINStruction:MTYPe
  • CALL:PPRocedure:PMEasurement:MPRequest:PINStruction:RTIMe

  • CALL:PPRocedure:PMEasurement:MPRequest:RAData
  • CALL:PPRocedure:PMEasurement:MPRequest:RAData:BTSPosition
  • CALL:PPRocedure:PMEasurement:MPRequest:RAData:BTSPosition:ALTitude
  • CALL:PPRocedure:PMEasurement:MPRequest:RAData:BTSPosition:ALTitude:DIRection
  • CALL:PPRocedure:PMEasurement:MPRequest:RAData:BTSPosition:LATitude:DEGRees
  • CALL:PPRocedure:PMEasurement:MPRequest:RAData:BTSPosition:LATitude:SIGN
  • CALL:PPRocedure:PMEasurement:MPRequest:RAData:BTSPosition:LONGitude:DEGRees
  • CALL:PPRocedure:PMEasurement:MPRequest:RAData:BTSPosition:TYPe

  • CALL:PPRocedure:PMEasurement:MPRequest:REL98|RELEASE98
  • CALL:PPRocedure:PMEasurement:MPRequest:REL98|RELEASE98:BTS[<n>]:EOTDiff
  • CALL:PPRocedure:PMEasurement:MPRequest:REL98|RELEASE98:BTS[<n>]:EOTDiff:UNCertainty

  • CALL:PPRocedure:PMEasurement:MPRequest:SEND

CALL:PPRocedure:PMEasurement:MPRequest:MAData

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA Includes or excludes the optional E-OTD Measurement Assistance Data element from the Measure Position Request component.
EGPRS LA

Setting

 INCLude|EXCLude

Query

 INCL|EXCL

*RST setting

 EXCL

Requirements

 GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example:

OUTPUT 714;"CALL:PPRocedure:PMEasurement:MPRequest:MAData INCL"

CALL:PPRocedure:PMEasurement:MPRequest:MAData:BTS[<n>]:BCHCarrier

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA Sets the value of the BCCH Carrier field in the E-OTD Measurement Assistance Data element. This field indicates the absolute RF channel number of the BTS indicated by the [<n>] mnemonic, where n can range from 1 to 8.
The E-OTD Measurement Assistance Data element is optional. Use the CALL:PPRocedure:PMEasurement:MPRequest:MAData command to have it included.
EGPRS LA

Setting

 Range: 0 to 1023
Resolution: 1

Query

 Range: 0 to 1023
Resolution: 1

*RST setting

 0

Requirements

 GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example:

OUTPUT 714;"CALL:PPRocedure:PMEasurement:MPRequest:MAData:BTS2:BCHCarrier 556"

CALL:PPRocedure:PMEasurement:MPRequest:MAData:BTS[<n>]:BSICode

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA Sets the value of the BSIC field in the E-OTD Measurement Assistance Data element. This field indicates the BSIC the BTS indicated by the [<n>] mnemonic, where n can range from 1 to 8.

The E-OTD Measurement Assistance Data element is optional. Use the CALL:PPRocedure:PMEasurement:MPRequest:MAData command to have it included.
EGPRS LA

Setting

 Range: 0 to 63
Resolution: 1

Query

 Range: 0 to 63
Resolution: 1

*RST setting

 0

Requirements

 GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example:

OUTPUT 714;"CALL:PPRocedure:PMEasurement:MPRequest:MAData:BTS2:BCICode 8"

CALL:PPRocedure:PMEasurement:MPRequest:MAData:BTS[<n>]:CASSistance

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA Includes or excludes the optional Calculation Assistance Data fields from the E-OTD Reference BTS for Assistance Data element for the BTS indicated by the [<n>} mnemonic, where n can range from 1 to 8. You can set the value of these fields using the following commands: CALL:PPRocedure:PMEasurement:MPRequest:MAData:BTS[<n>]:CASSistance:FRTDiff CALL:PPRocedure:PMEasurement:MPRequest:MAData:BTS[<n>]:CASSistance:RNORth CALL:PPRocedure:PMEasurement:MPRequest:MAData:BTS[<n>]:CASSistance:REASt
EGPRS LA

Setting

 INCLude|EXCLude

Query

 INCL|EXCL

*RST setting

 EXCL

Requirements

 GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example:

OUTPUT 714;"CALL:PPRocedure:PMEasurement:MPRequest:MAData:BTS2:CASSistance INCL"

CALL:PPRocedure:PMEasurement:MPRequest:MAData:BTS[<n>]:CASSistance:FRTDiff

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA Sets the value of the optional Fine RTD field in the E-OTD Measurement Assistance Data element. This field indicates the fine RTD value between the BTS indicated by the [<n>] mnemonic (where n can range from 1 to 8) and the reference BTS.

This field is optional. Use the CALL:PPRocedure:PMEasurement:MPRequest:MAData:BTS[<n>]:CASSistance command to have it included.
EGPRS LA

Setting

 Range: 0 to 255
Resolution: 1 bit

Query

 Range: 0 to 255
Resolution: 1 bit

*RST setting

 0

Requirements

 GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example:

OUTPUT 714;"CALL:PPRocedure:PMEasurement:MPRequest:MAData:BTS2:CASSistance:FRTDiff 220"

CALL:PPRocedure:PMEasurement:MPRequest:MAData:BTS[<n>]:CASSistance:RALTitude

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA Includes or excludes the optional Calculation Assistance Data Relative Altitude field from the E-OTD Reference BTS for Assistance Data element for the BTS indicated by the [<n>] mnemonic, where n can range from 1 to 8. You can set the value of this field using the CALL:PPRocedure:PMEasurement:MPRequest:MAData:BTS[<n>]:CASSistance:RALTitude:VALue command.
EGPRS LA

Setting

 INCLude|EXCLude

Query

 INCL|EXCL

*RST setting

 EXCL

Requirements

 GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example:

OUTPUT 714;"CALL:PPRocedure:PMEasurement:MPRequest:MAData:BTS2:CASSistance INCL"

CALL:PPRocedure:PMEasurement:MPRequest:MAData:BTS[<n>]:CASSistance:RALTitude:VALue

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA Sets the value of the Relative Altitude field in the E-OTD Measurement Assistance Data element. This field indicates the altitude of the BTS indicated by the [<n>] mnemonic (where n can range from 1 to 8) relative to the reference BTS in meters.

This field is optional. Use the CALL:PPRocedure:PMEasurement:MPRequest:MAData:BTS[<n>]:CASSistance:RALTitude command to have it included. or excludes the optional E-OTD Measurement Assistance Data element from the Measure Position Request component.
EGPRS LA

Setting

 Range: -4000 to 4000
Resolution: 1

Query

 Range: -4000 to 4000
Resolution: 1

*RST setting

 0

Requirements

 GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example:

OUTPUT 714;"CALL:PPRocedure:PMEasurement:MPRequest:MAData:BTS2:CASSistance:RALTitude:VALue 2000"

CALL:PPRocedure:PMEasurement:MPRequest:MAData:BTS[<n>]:CASSistance:REASt

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA Sets the value of the optional Relative East field in the E-OTD Measurement Assistance Data element. This field indicates the distance between the BTS indicated by the [<n>] mnemonic (where n can range from 1 to 8) and the reference BTS in the east-west direction.

This field is optional. Use the CALL:PPRocedure:PMEasurement:MPRequest:MAData:BTS[<n>]:CASSistance command to have it included.
EGPRS LA

Setting

 Range: -200000 to 200000
Resolution: 1

Query

 Range: -200000 to 200000
Resolution: 1

*RST setting

 0

Requirements

 GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example:

OUTPUT 714;"CALL:PPRocedure:PMEasurement:MPRequest:MAData:BTS2:CASSistance:REASt -200"

CALL:PPRocedure:PMEasurement:MPRequest:MAData:BTS[<n>]:CASSistance:RNORth

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA Sets the value of the optional Relative North field in the E-OTD Measurement Assistance Data element. This field indicates the distance between the BTS indicated by the [<n>] mnemonic (where n can range from 1 to 8) and the reference BTS in the north-south direction.

This field is optional. Use the CALL:PPRocedure:PMEasurement:MPRequest:MAData:BTS[<n>]:CASSistance command to have it included.
EGPRS LA

Setting

 Range: -200000 to 200000
Resolution: 1

Query

 Range: -200000 to 200000
Resolution: 1

*RST setting

 0

Requirements

 GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example:

OUTPUT 714;"CALL:PPRocedure:PMEasurement:MPRequest:MAData:BTS2:CASSistance:RNORth -22000"

CALL:PPRocedure:PMEasurement:MPRequest:MAData:BTS[<n>]:MOFFset

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA Sets the value of the Multiframe Offset field in the E-OTD Measurement Assistance Data element. This field indicates the frame offset between the BTS indicated by the [<n>] mnemonic (where n can range from 1 to 8) and the reference BTS.

The E-OTD Measurement Assistance Data element is optional. Use the CALL:PPRocedure:PMEasurement:MPRequest:MAData command to have it included.
EGPRS LA

Setting

 Range: 0 to 51
Resolution: 1

Query

 Range: 0 to 51
Resolution: 1

*RST setting

 0

Requirements

 GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example:

OUTPUT 714;"CALL:PPRocedure:PMEasurement:MPRequest:MAData:BTS2:MOFFset 30"

CALL:PPRocedure:PMEasurement:MPRequest:MAData:BTS:NUMBer

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA Sets the value of the Number of BTS field in the E-OTD Measurement Assistance Data element. This field indicates how many BTS are included in this information element.
The E-OTD Measurement Assistance Data element is optional. Use the CALL:PPRocedure:PMEasurement:MPRequest:MAData command to have it included.
EGPRS LA

Setting

 Range: 1 to 8
Resolution: 1

Query

 Range: 1 to 8
Resolution: 1

*RST setting

 1

Requirements

 GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example:

OUTPUT 714;"CALL:PPRocedure:PMEasurement:MPRequest:MAData:BTS:NUMBer 3"

CALL:PPRocedure:PMEasurement:MPRequest:MAData:BTS[<n>]:RRTDiff

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA Sets the value of the Rough RTD field in the E-OTD Measurement Assistance Data element. This field indicates the rough RTD value between the BTS indicated by the [<n>] mnemonic (where n can range from 1 to 8) and the reference BTS.

The E-OTD Measurement Assistance Data element is optional. Use the CALL:PPRocedure:PMEasurement:MPRequest:MAData command to have it included.
EGPRS LA

Setting

 Range: 0 to 1250
Resolution: 1 bit

Query

 Range: 0 to 1250
Resolution: 1 bit

*RST setting

 0

Requirements

 GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example:

OUTPUT 714;"CALL:PPRocedure:PMEasurement:MPRequest:MAData:BTS2:RRTDiff 120"

CALL:PPRocedure:PMEasurement:MPRequest:MAData:BTS[<n>]:TSSCheme

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA Sets the value of the Time Slot Scheme field in the E-OTD Measurement Assistance Data element. This field indicates the type of transmission scheme used by the BTS indicated by the [<n>] mnemonic, where n can range from 1 to 8.

The E-OTD Measurement Assistance Data element is optional. Use the CALL:PPRocedure:PMEasurement:MPRequest:MAData command to have it included.
EGPRS LA

Setting

 Range: 0 to 1
Resolution: 1

0: All timeslots are 156.25 bits long
1: Time slots 0 and 4 are 157 bits long, all other are 156 bits long

Query

 Range: 0 to 1
Resolution: 1

*RST setting

 1

Requirements

 GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example:

OUTPUT 714;"CALL:PPRocedure:PMEasurement:MPRequest:MAData:BTS2:TSSCheme 0"

CALL:PPRocedure:PMEasurement:MPRequest:PINStruction:ACCuracy

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA Includes or excludes the optional Accuracy field from the Positioning Instructions element. You can set the value of this field using the CALL:PPRocedure:PMEasurement:MPRequest:PINStruction:ACCuracy:VALue command.
EGPRS LA

Setting

 INCLude|EXCLude

Query

 INCL|EXCL

*RST setting

 EXCL

Requirements

 GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example:

OUTPUT 714;"CALL:PPRocedure:PMEasurement:MPRequest:PINStruction:ACCuracy INCL"

CALL:PPRocedure:PMEasurement:MPRequest:PINStruction:ACCuracy:VALue

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA Sets the value of the Accuracy field in the Positioning Instructions element. This indicates the required accuracy of the latitude and longitude for the location estimate.
This field is optional. Use the CALL:PPRocedure:PMEasurement:MPRequest:PINStruction:ACCuracy command to have it included.
EGPRS LA

Setting

 Range: 0 to 127
Resolution: 1

Query

 0 to 127

*RST setting

 127

Requirements

 GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example:

OUTPUT 714;"CALL:PPRocedure:PMEasurement:MPRequest:PINStruction:ACCuracy:VALue 55"

CALL:PPRocedure:PMEasurement:MPRequest:PINStruction:ECHaracter

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA Includes or excludes the optional Environment Characterization field from the Positioning Instructions element. You can set the value of this field using the CALL:PPRocedure:PMEasurement:MPRequest:PINStruction:ECHaracter:VALue command.
EGPRS LA

Setting

 INCLude|EXCLude

Query

 INCL|EXCL

*RST setting

 EXCL

Requirements

 GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example:

OUTPUT 714;"CALL:PPRocedure:PMEasurement:MPRequest:PINStruction:ECHaracter INCL"

CALL:PPRocedure:PMEasurement:MPRequest:PINStruction:ECHaracter:VALue

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA Sets the value of the Environment Characterization field in the Positioning Instructions element. This field provides the MS with information about expected multipath in the current area.
This field is optional. Use the CALL:PPRocedure:PMEasurement:MPRequest:PINStruction:ECHaracter command to have it included.
EGPRS LA

Setting

 Range: 0 to 3

0: Heavy multipath
1: Light multipath
2: Not Defined
3: Reserved

Query

 0 to 3

*RST setting

 0

Requirements

 GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example:

OUTPUT 714;"CALL:PPRocedure:PMEasurement:MPRequest:PINStruction:ECHaracter:VALue 0"

CALL:PPRocedure:PMEasurement:MPRequest:PINStruction:MSETs

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA Sets the Multiple Sets field in the Positioning Instructions element. This indicates if the MS should send multiple E-OTD Measurement Information Sets.
EGPRS LA

Setting

 0|1

0: Sending of multiple sets is allowed
1: Sending of multiple sets is not allowed

Query

 0|1

*RST setting

 0

Requirements

 GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example:

OUTPUT 714;"CALL:PPRocedure:PMEasurement:MPRequest:PINStruction:MSETs 1"

CALL:PPRocedure:PMEasurement:MPRequest:PINStruction:MTYPe

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA Sets the Method Type field in the Positioning Instructions element.
EGPRS LA

Setting

 Range: 0 to 3

0: MS assisted
1: MS based
2: MS based preferred, but MS assisted is allowed
3: MS assisted preferred, but MS based is allowed

Query

 0 to 3

*RST setting

 0

Requirements

 GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example:

OUTPUT 714;"CALL:PPRocedure:PMEasurement:MPRequest:PINStruction:MTYPe 1"

CALL:PPRocedure:PMEasurement:MPRequest:PINStruction:RTIMe

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA Sets the Response Time field in the Positioning Instructions element. This indicates the desired time for the MS to respond to the RRLP message.
EGPRS LA

Setting

 Range: 0 to 7

The response time is 2N seconds, where N is the value of the Response Time field. Therefore,
0: 1 second 4: 16 seconds
1: 2 seconds 5: 32 seconds
2: 4 seconds 6: 64 seconds
3: 8 seconds 7: 128 seconds

Query

 0 to 7

*RST setting

 2

Requirements

 GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example:

OUTPUT 714;"CALL:PPRocedure:PMEasurement:MPRequest:PINStruction:RTIMe 1"

CALL:PPRocedure:PMEasurement:MPRequest:RAData

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA Includes or excludes the optional E-OTD Reference BTS for Assistance Data element from the Measure Position Request component.
EGPRS LA

Setting

 INCLude|EXCLude

Query

 INCL|EXCL

*RST setting

 EXCL

Requirements

 GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example:

OUTPUT 714;"CALL:PPRocedure:PMEasurement:MPRequest:RAData INCL"

CALL:PPRocedure:PMEasurement:MPRequest:RAData:BTSPosition

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA Includes or excludes the optional BTS Position field from the E-OTD Reference BTS for Assistance Data element. You can set the value of this field using the CALL:PPRocedure:PMEasurement:MPRequest:PINStruction:ECHaracter:VALue command.
EGPRS LA

Setting

 INCLude|EXCLude

Query

 INCL|EXCL

*RST setting

 EXCL

Requirements

 GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example:

OUTPUT 714;"CALL:PPRocedure:PMEasurement:MPRequest:RAData:BTSPosition INCL"

CALL:PPRocedure:PMEasurement:MPRequest:RAData:BTSPosition:ALTitude

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA Sets the Degrees Altitude for the BTS Position field.
The BTS Position field is optional. Use the CALL:PPRocedure:PMEasurement:MPRequest:RAData:BTSPosition command to have it included.
EGPRS LA

Setting

 Range: 0 to 32767
Resolution: 1

Query

 Range: 0 to 32767
Resolution: 1

*RST setting

 0

Requirements

 GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example:

OUTPUT 714;"CALL:PPRocedure:PMEasurement:MPRequest:RAData:BTSPosition:ALTitude 456"

CALL:PPRocedure:PMEasurement:MPRequest:RAData:BTSPosition:ALTitude:DIRection

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA Sets the Direction of Altitude for the BTS Position field.
The BTS Position field is optional. Use the CALL:PPRocedure:PMEasurement:MPRequest:RAData:BTSPosition command to have it included.
EGPRS LA

Setting

 ABOVe|BELow

Query

 ABOV|BEL

*RST setting

 ABOV

Requirements

 GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example:

OUTPUT 714;"CALL:PPRocedure:PMEasurement:MPRequest:RAData:BTSPosition:ALTitude:DIRection BELow"

CALL:PPRocedure:PMEasurement:MPRequest:RAData:BTSPosition:LATitude:DEGRees

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA Sets the Degrees Latitude for the BTS Position field.
The BTS Position field is optional. Use the CALL:PPRocedure:PMEasurement:MPRequest:RAData:BTSPosition command to have it included.
EGPRS LA

Setting

 Range: 0 to 2147483647
Resolution: 1

Query

 Range: 0 to 2147483647
Resolution: 1

*RST setting

 0

Requirements

 GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example:

OUTPUT 714;"CALL:PPRocedure:PMEasurement:MPRequest:RAData:BTSPosition:LATitude:DEGRees 4567131"

CALL:PPRocedure:PMEasurement:MPRequest:RAData:BTSPosition:LATitude:SIGN

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA Includes Sets the Direction of Latitude for the BTS Position field.
The BTS Position field is optional. Use the CALL:PPRocedure:PMEasurement:MPRequest:RAData:BTSPosition command to have it included. excludes the optional E-OTD Measurement Assistance Data element from the Measure Position Request component.
EGPRS LA

Setting

 NORTh|SOUTh

Query

 NORT|SOUT

*RST setting

 NORT

Requirements

 GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example:

OUTPUT 714;"CALL:PPRocedure:PMEasurement:MPRequest:RAData:BTSPosition:LATitude:SIGN NORTh"

CALL:PPRocedure:PMEasurement:MPRequest:RAData:BTSPosition:LONGitude:DEGRees

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA Sets the Degrees Longitude for the BTS Position field.
The BTS Position field is optional. Use the CALL:PPRocedure:PMEasurement:MPRequest:RAData:BTSPosition command to have it included.
EGPRS LA

Setting

 Range: -2147483647 to 2147483647
Resolution: 1

Query

 Range: -2147483647 to 2147483647
Resolution: 1

*RST setting

 0

Requirements

 GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example:

OUTPUT 714;"CALL:PPRocedure:PMEasurement:MPRequest:RAData:BTSPosition:LONGitude:DEGRees 4567131"

CALL:PPRocedure:PMEasurement:MPRequest:RAData:BTSPosition:TYPe

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA Sets the Type of Description for the BTS Position field. The type of description is either "Ellipsoid Point" or "Ellipsoid Point with Altitude".
The BTS Position field is optional. Use the CALL:PPRocedure:PMEasurement:MPRequest:RAData:BTSPosition command to have it included.
EGPRS LA

Setting

 EPOint|EPALitude

EPOint: Ellipsoid Point
EPALitude: Ellipsoid Point with Altitude

Query

 EPO|EPAL

*RST setting

 EPO

Requirements

 GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example:

OUTPUT 714;"CALL:PPRocedure:PMEasurement:MPRequest:RAData:BTSPosition:TYPe EPAL"

CALL:PPRocedure:PMEasurement:MPRequest:REL98|RELEASE98

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA Includes or excludes the optional Release 98 Extension element from the Measure Position Request component. You can set the value of these fields using the following commands: CALL:PPRocedure:PMEasurement:MPRequest:REL98|RELEASE98:BTS[<n>]:EOTDiff CALL:PPRocedure:PMEasurement:MPRequest:REL98|RELEASE98:BTS[<n>]:EOTDiff:UNCertainty
EGPRS LA

Setting

 INCLude|EXCLude

Query

 INCL|EXCL

*RST setting

 EXCL

Requirements

 GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example:

OUTPUT 714;"CALL:PPRocedure:PMEasurement:MPRequest:REL98 INCL"

CALL:PPRocedure:PMEasurement:MPRequest:REL98|RELEASE98:BTS[<n>]:EOTDiff

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA Sets the value of the Expected OTD field in the Release 98 Extension element. This field indicates the OTD value that the MS is expected to measure between the BTS indicated by the [<n>] mnemonic and the reference BTS.

The Release 98 Extension element is optional. Use the CALL:PPRocedure:PMEasurement:MPRequest:REL98|RELEASE98 command to have it included.
EGPRS LA

Setting

 Range: 0 to 1250
Resolution: 1 bit

Query

 Range: 0 to 1250
Resolution: 1 bit

*RST setting

 0

Requirements

 GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example:

OUTPUT 714;"CALL:PPRocedure:PMEasurement:MPRequest:REL98:BTS2:EOTDiff 1010"

CALL:PPRocedure:PMEasurement:MPRequest:REL98|RELEASE98:BTS[<n>]:EOTDiff:UNCertainty

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA Sets the value of the Uncertainty of Expected OTD field in the Release 98 Extension element. This field indicates the uncertainty in the Expected OTD value.

The Release 98 Extension element is optional. Use the CALL:PPRocedure:PMEasurement:MPRequest:REL98|RELEASE98 command to have it included.
EGPRS LA

Setting

 Range: 0 to 7
Resolution: 1

Query

 Range: 0 to 7
Resolution: 1

*RST setting

 0

Requirements

 GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example:

OUTPUT 714;"CALL:PPRocedure:PMEasurement:MPRequest:REL98:BTS2:EOTDiff:UNCertainty 5"

CALL:PPRocedure:PMEasurement:MPRequest:SEND

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
GSM/GPRS LA Sends the Measure Position Request component in an RRLP message.
EGPRS LA

Requirements

 GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example:

OUTPUT 714;"CALL:PPRocedure:PMEasurement:MPRequest:SEND"


CALL:PPRocedure:PMEasurement:MS

CALL:PPRocedure:PMEasurement:MS

GPIB Command Conventions

  • CALL:PPRocedure:PMEasurement:MS:RESet

CALL:PPRocedure:PMEasurement:MS:RESet

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

Commands the MS to reset the MS positioning stored information by sending a special message (RESET MS POSITIONING STORED INFORMATION) on the DCCH.

When receives the message the MS will discard any stored GPS reference time, reference position, and any other aiding data obtained or derived previously.
EGPRS LA

Requirements

 GSM/GPRS/ EGPRS LA

Revision: G.00.00 and above

Programming Example:

OUTPUT 714;"CALL:PPRocedure:PMEasurement:MS:RESet"


CALL:PPRocedure:PMEasurement:PERRor

CALL:PPRocedure:PMEasurement:PERRor

GPIB Command Conventions

  • CALL:PPRocedure:PMEasurement:PERRor:CODE
  • CALL:PPRocedure:PMEasurement:PERRor:SEND

CALL:PPRocedure:PMEasurement:PERRor:CODE

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA Sets the value of the Protocol Error component.
EGPRS LA

Setting

 Range: 0 to 5
Resolution: 1

0: Undefined
1: Missing Component
2: Incorrect Data
3: Missing Information Element or Component Element
4: Message Too Short
5: Unknown Reference Number

Query

 0 to 5

*RST setting

 0

Requirements

 GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example:

OUTPUT 714;"CALL:PPRocedure:PMEasurement:PERRor:CODE 3"

CALL:PPRocedure:PMEasurement:PERRor:SEND

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA Sends the Protocol Error component in an RRLP message.
EGPRS LA

Requirements

 GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example:

OUTPUT 714;"CALL:PPRocedure:PMEasurement:PERRor:SEND"


CALL:PPRocedure:PMEasurement:PIPE

CALL:PPRocedure:PMEasurement:PIPE

GPIB Command Conventions

  • CALL:PPRocedure:PMEasurement:PIPE
  • CALL:PPRocedure:PMEasurement:PIPE:DATA:RX?
  • CALL:PPRocedure:PMEasurement:PIPE:DATA:RX:AVAilable?
  • CALL:PPRocedure:PMEasurement:PIPE:DATA:TX
  • CALL:PPRocedure:PMEasurement:PIPE:HEADer[:STATe]
  • CALL:PPRocedure:PMEasurement:PIPE:RTIMe
  • CALL:PPRocedure:PMEasurement:PIPE:SEND

CALL:PPRocedure:PMEasurement:PIPE

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA Sets or queries the state of the RRLP pipe. When the RRLP pipe mode is enabled, the test set's RRLP message based E-OTD testing is disabled. E-OTD RRLP messages can still be sent, but not encoding or decoding of messages is provided by the test set.
EGPRS LA

Setting

 0|OFF|1|ON
Query

0 | 1

*RST setting

 0

Requirements

 GSM/GPRS/ EGPRS LA

Revision: C.03 and above

Programming Example:

OUTPUT 714;"CALL:PPRocedure:PMEasurement:PIPE ON"

CALL:PPRocedure:PMEasurement:PIPE:DATA:RX?

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

Queries the raw data from the last RRLP message received from a mobile station.

The maximum length of the RRLP message is controlled by the RRLP Header State. See CALL:PPRocedure:PMEasurement:PIPE:HEADer[:STATe] .

EGPRS LA

Query

Range:

  • A string of 0 to 2000 hexadecimal characters when the RRLP Header state is set to ON.
  • A string of 0 to 251 hexadecimal characters when the RRLP Header state is set to OFF.

*RST setting

 ""

Requirements

 GSM/GPRS/ EGPRS LA

Revision: C.03 and above

Programming Example:

OUTPUT 714;"CALL:PPRocedure:PMEasurement:PIPE:DATA:RX?"

CALL:PPRocedure:PMEasurement:PIPE:DATA:RX:AVAilable?

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA Queries whether a response to the last message transmitted to the mobile station using the RRLP pipe has been received and if receiver results are available.
EGPRS LA

Query

 0|1

*RST setting

 0

Requirements

 GSM/GPRS/ EGPRS LA

Revision: C.03 and above

Programming Example:

OUTPUT 714;"CALL:PPRocedure:PMEasurement:PIPE:DATA:RX:AVA?"

CALL:PPRocedure:PMEasurement:PIPE:DATA:TX

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

Sets or queries the string of data to be sent using the RRLP pipe. The data should be formatted as hexadecimal characters and can be up to 2000 characters long.

The maximum length of the RRLP message is controlled by the RRLP Header State. See CALL:PPRocedure:PMEasurement:PIPE:HEADer[:STATe]

EGPRS LA

Setting

Range:

  • 0 to 2000 ASCII formatted hexadecimal characters when the RRLP Header state is set to ON.
  • 0 to 251 ASCII formatted hexadecimal characters when the RRLP Header state is set to OFF.

Query

 Range: 0 to 2000 ASCII formatted hexadecimal characters.

*RST setting

 ""

Requirements

 GSM/GPRS/ EGPRS LA

Revision: C.03 and above

Programming Example:

OUTPUT 714;"CALL:PPRocedure:PMEasurement:PIPE:DATA:TX `00000000000000000000000000'"

CALL:PPRocedure:PMEasurement:PIPE:HEADer[:STATe]

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA Sets or queries the RRLP Header State which controls the automatic header creation and segmentation of the RRLP pipe message.
EGPRS LA

Setting

 Range: 1|ON|0|OFF

Query

 Range: 0|1

*RST setting

 1|ON

Requirements

 GSM/GPRS/ EGPRS LA

Revision: F.00.37 and above

Programming Example:

OUTPUT 714;"CALL:PPRocedure:PMEasurement:PIPE:HEADer:STATe ON"
! Set the RRLP Header State to ON.

CALL:PPRocedure:PMEasurement:PIPE:RTIMe

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA Sets or queries the maximum amount of time to wait for a response from the mobile station when sending it information using the RRLP pipe.
EGPRS LA

Setting

 Range:0 to 140 seconds
Resolution: 1 second

Query

 Range:0 to 140 seconds
Resolution: 1 second

*RST setting

 10

Requirements

 GSM/GPRS/ EGPRS LA

Revision: C.03 and above

Programming Example:

OUTPUT 714;"CALL:PPRocedure:PMEasurement:PIPE:RTIMe 60"

CALL:PPRocedure:PMEasurement:PIPE:SEND

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA Sends the data setup using the CALL:PPRocedure:PMEasurement:PIPE:DATA:TX command to the mobile station using the RRLP pipe. This command also clears the results returned by the CALL:PPRocedure:PMEasurement:PIPE:DATA:RX:AVAilable? command.
EGPRS LA

Requirements

 GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example:

OUTPUT 714;"CALL:PPRocedure:PMEasurement:PIPE:SEND"


CALL:PPRocedure:PMEasurement:PRESponse:AVAilable?

CALL:PPRocedure:PMEasurement:PRESponse:AVAilable?

Last updated: December 3, 2008

GPIB Command Conventions

  • CALL:PPRocedure:PMEasurement:PRESponse:AVAilable?

CALL:PPRocedure:PMEasurement:PRESponse:AVAilable?

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA Queries the status of the Measurement Position Response from the mobile station. This query returns a "0" when the a request message has been sent but an acknowledgment has not been received from the mobile station. A "1" is returned after an acknowledgment has been received and before another Measurement Position Request message is sent.
EGPRS LA
Query

0 | 1

0: No results are available
1: Results are available

Requirements

 GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example:

OUTPUT 714;"CALL:PPRocedure:PMEasurement:PRESponse:AVAilable?"


CALL:PPRocedure:PMEasurement:PRESponse:LIERror

CALL:PPRocedure:PMEasurement:PRESponse:LIERror

GPIB Command Conventions

  • CALL:PPRocedure:PMEasurement:PRESponse:LIERror:INCLuded?
  • CALL:PPRocedure:PMEasurement:PRESponse:LIERror:REASon?

CALL:PPRocedure:PMEasurement:PRESponse:LIERror:INCLuded?

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA Queries to determine if the optional Location Information Error element is included in the Measurement Position Response component from the MS. If this element is not included, none of the values in this element will be available. The will instead all return NAN (Not a number).
EGPRS LA
Query

0 | 1

0: Not included
1: Included

Requirements

 GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example:

OUTPUT 714;"CALL:PPRocedure:PMEasurement:PRESponse:LIERror:INCLuded?"

CALL:PPRocedure:PMEasurement:PRESponse:LIERror:REASon?

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA Queries the Error Reason field of the optional Location Information Error element. If the Location Information Error element is not included, values for this field will not be available. See CALL:PPRocedure:PMEasurement:PRESponse:LIERror:INCLuded? to determine if the element is included.
EGPRS LA
Query

Range: 0 to 10 and 9.91E+37 (NAN)
Resolution: 1

Requirements

 GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example:

OUTPUT 714;"CALL:PPRocedure:PMEasurement:PRESponse:LINFormation:LIERror:REASon?"


CALL:PPRocedure:PMEasurement:PRESponse:LINFormation

CALL:PPRocedure:PMEasurement:PRESponse:LINFormation

GPIB Command Conventions

  • CALL:PPRocedure:PMEasurement:PRESponse:LINFormation:FTYPe?
  • CALL:PPRocedure:PMEasurement:PRESponse:LINFormation:INCLuded?
  • CALL:PPRocedure:PMEasurement:PRESponse:LINFormation:RFRame?
  • CALL:PPRocedure:PMEasurement:PRESponse:LINFormation:PESTimate:ALTitude?
  • CALL:PPRocedure:PMEasurement:PRESponse:LINFormation:PESTimate:ALTitude:DIRection?
  • CALL:PPRocedure:PMEasurement:PRESponse:LINFormation:PESTimate:ALTitude:UNCertainty?
  • CALL:PPRocedure:PMEasurement:PRESponse:LINFormation:PESTimate:CONFidence?
  • CALL:PPRocedure:PMEasurement:PRESponse:LINFormation:PESTimate:LATitude:DEGRees?
  • CALL:PPRocedure:PMEasurement:PRESponse:LINFormation:PESTimate:LATitude:SIGN?
  • CALL:PPRocedure:PMEasurement:PRESponse:LINFormation:PESTimate:LONGitude:DEGRees?
  • CALL:PPRocedure:PMEasurement:PRESponse:LINFormation:PESTimate:MAJor:ORIentation?
  • CALL:PPRocedure:PMEasurement:PRESponse:LINFormation:PESTimate:SMAJor:UNCertainty?
  • CALL:PPRocedure:PMEasurement:PRESponse:LINFormation:PESTimate:SMINor:UNCertainty?
  • CALL:PPRocedure:PMEasurement:PRESponse:LINFormation:PESTimate:TYPE?
  • CALL:PPRocedure:PMEasurement:PRESponse:LINFormation:PESTimate:UCODe?

CALL:PPRocedure:PMEasurement:PRESponse:LINFormation:FTYPe?

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA Queries the Fix Type field of the optional Location Information element. If the Location Information element is not included, values for this field will not be available. See CALL:PPRocedure:PMEasurement:PRESponse:LINFormation:INCLuded? to determine if the element is included.
EGPRS LA
Query

Range: 0 to 1 and 9.91E+37 (NAN)
Resolution: 1

Requirements

 GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example:

OUTPUT 714;"CALL:PPRocedure:PMEasurement:PRESponse:LINFormation:FTYPe?"

CALL:PPRocedure:PMEasurement:PRESponse:LINFormation:INCLuded?

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA Queries to determine if the optional Location Information element is included in the Measurement Position Response component from the MS. If this element is not included, none of the values in this element will be available. The will instead all return NAN (Not a number).
EGPRS LA
Query

0 | 1

0: Not included
1: Included

Requirements

 GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example:

OUTPUT 714;"CALL:PPRocedure:PMEasurement:PRESponse:LINFormation:INCLuded?"

CALL:PPRocedure:PMEasurement:PRESponse:LINFormation:RFRame?

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA Queries the Reference Frame field of the optional Location Information element. If the Location Information element is not included, values for this field will not be available. See CALL:PPRocedure:PMEasurement:PRESponse:LINFormation:INCLuded? to determine if the element is included.
EGPRS LA
Query

Range: 0 to 65535 and 9.91E+37 (NAN)
Resolution: 1

Requirements

 GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example:

OUTPUT 714;"CALL:PPRocedure:PMEasurement:PRESponse:LINFormation:RFRame?"

CALL:PPRocedure:PMEasurement:PRESponse:LINFormation:PESTimate:ALTitude?

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA Queries the Altitude element of the Shape Description information contained in the Position Estimate field of the optional Location Information element. If the Location Information element is not included, values for this field will not be available. See CALL:PPRocedure:PMEasurement:PRESponse:LINFormation:INCLuded? to determine if the element is included.
EGPRS LA
Query

Range: 0 to 32767 and 9.91E+37 (NAN)
Resolution: 1

Requirements

 GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example:

OUTPUT 714;"CALL:PPRocedure:PMEasurement:PRESponse:LINFormation:PESTimate:ALTitude?"

CALL:PPRocedure:PMEasurement:PRESponse:LINFormation:PESTimate:ALTitude:DIRection?

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA Queries the Direction of Altitude element of the Shape Description information contained in the Position Estimate field of the optional Location Information element. If the Location Information element is not included, values for this field will not be available. See CALL:PPRocedure:PMEasurement:PRESponse:LINFormation:INCLuded? to determine if the element is included.
EGPRS LA
Query

Range: 0 to 1 and 9.91E+37 (NAN)
Resolution: 1

0: Altitude expresses height
1: Altitude expresses depth

Requirements

 GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example:

OUTPUT 714;"CALL:PPRocedure:PMEasurement:PRESponse:LINFormation:PESTimate:ALTitude:DIRection?"

CALL:PPRocedure:PMEasurement:PRESponse:LINFormation:PESTimate:ALTitude:UNCertainty?

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA Queries the Uncertainty for the Altitude element of the Shape Description information contained in the Position Estimate field of the optional Location Information element. If the Location Information element is not included, values for this field will not be available. See CALL:PPRocedure:PMEasurement:PRESponse:LINFormation:INCLuded? to determine if the element is included.
EGPRS LA
Query

Range: 0 to 127 and 9.91E+37 (NAN)
Resolution: 1

Requirements

 GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example:

OUTPUT 714;"CALL:PPRocedure:PMEasurement:PRESponse:LINFormation:PESTimate:ALTitude:UNCertainty?"

CALL:PPRocedure:PMEasurement:PRESponse:LINFormation:PESTimate:CONFidence?

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA Queries the Confidence element of the Shape Description information contained in the Position Estimate field of the optional Location Information element. If the Location Information element is not included, values for this field will not be available. See CALL:PPRocedure:PMEasurement:PRESponse:LINFormation:INCLuded? to determine if the element is included.
EGPRS LA
Query

Range: 0 to 99 and 9.91E+37 (NAN)
Resolution: 1

Requirements

 GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example:

OUTPUT 714;"CALL:PPRocedure:PMEasurement:PRESponse:LINFormation:PESTimate:CONFidence?"

CALL:PPRocedure:PMEasurement:PRESponse:LINFormation:PESTimate:LATitude:DEGRees?

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA Queries the Degrees of Latitude element of the Shape Description information contained in the Position Estimate field of the optional Location Information element. If the Location Information element is not included, values for this field will not be available. See CALL:PPRocedure:PMEasurement:PRESponse:LINFormation:INCLuded? to determine if the element is included.
EGPRS LA
Query

Range: 0 to 2147483647 and 9.91E+37 (NAN)
Resolution: 1

Requirements

 GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example:

OUTPUT 714;"CALL:PPRocedure:PMEasurement:PRESponse:LINFormation:PESTimate:LATitude:DEGRees?"

CALL:PPRocedure:PMEasurement:PRESponse:LINFormation:PESTimate:LATitude:SIGN?

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA Queries the Sign of Latitude element of the Shape Description information contained in the Position Estimate field of the optional Location Information element. If the Location Information element is not included, values for this field will not be available. See CALL:PPRocedure:PMEasurement:PRESponse:LINFormation:INCLuded? to determine if the element is included.
EGPRS LA
Query

Range: 0 to 1 and 9.91E+37 (NAN)
Resolution: 1

Requirements

 GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example:

OUTPUT 714;"CALL:PPRocedure:PMEasurement:PRESponse:LINFormation:PESTimate:LATitude:SIGN?"

CALL:PPRocedure:PMEasurement:PRESponse:LINFormation:PESTimate:LONGitude:DEGRees?

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA Queries the Degrees of Longitude element of the Shape Description information contained in the Position Estimate field of the optional Location Information element. If the Location Information element is not included, values for this field will not be available. See CALL:PPRocedure:PMEasurement:PRESponse:LINFormation:INCLuded? to determine if the element is included.
EGPRS LA
Query

Range: -2147483647 to 2147483647 and 9.91E+37 (NAN)
Resolution: 1

Requirements

 GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example:

OUTPUT 714;"CALL:PPRocedure:PMEasurement:PRESponse:LINFormation:PESTimate:LONGitude:DEGRees?"

CALL:PPRocedure:PMEasurement:PRESponse:LINFormation:PESTimate:MAJor:ORIentation?

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA Queries the Orientation of the Major Axis element of the Shape Description information contained in the Position Estimate field of the optional Location Information element. If the Location Information element is not included, values for this field will not be available. See CALL:PPRocedure:PMEasurement:PRESponse:LINFormation:INCLuded? to determine if the element is included.
EGPRS LA
Query

Range: 0 to 127and 9.91E+37 (NAN)
Resolution: 1

Requirements

 GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example:

OUTPUT 714;"CALL:PPRocedure:PMEasurement:PRESponse:LINFormation:PESTimate:SMINor:UNCertainty?"

CALL:PPRocedure:PMEasurement:PRESponse:LINFormation:PESTimate:SMAJor:UNCertainty?

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA Queries the Uncertainty for the Semi Major element of the Shape Description information contained in the Position Estimate field of the optional Location Information element. If the Location Information element is not included, values for this field will not be available. See CALL:PPRocedure:PMEasurement:PRESponse:LINFormation:INCLuded? to determine if the element is included.
EGPRS LA
Query

Range: 0 to 127and 9.91E+37 (NAN)
Resolution: 1

Requirements

 GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example:

OUTPUT 714;"CALL:PPRocedure:PMEasurement:PRESponse:LINFormation:PESTimate:SMAJor:UNCertainty?"

CALL:PPRocedure:PMEasurement:PRESponse:LINFormation:PESTimate:SMINor:UNCertainty?

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA Queries the Uncertainty for the Semi Minor element of the Shape Description information contained in the Position Estimate field of the optional Location Information element. If the Location Information element is not included, values for this field will not be available. See CALL:PPRocedure:PMEasurement:PRESponse:LINFormation:INCLuded? to determine if the element is included.
EGPRS LA
Query

Range: 0 to 127and 9.91E+37 (NAN)
Resolution: 1

Requirements

 GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example:

OUTPUT 714;"CALL:PPRocedure:PMEasurement:PRESponse:LINFormation:PESTimate:SMINor:UNCertainty?"

CALL:PPRocedure:PMEasurement:PRESponse:LINFormation:PESTimate:TYPE?

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA Queries the Type of Shape information contained in the Position Estimate field of the optional Location Information element. If the Location Information element is not included, values for this field will not be available. See CALL:PPRocedure:PMEasurement:PRESponse:LINFormation:INCLuded? to determine if the element is included.
EGPRS LA
Query

Range: 0 to 10 and 9.91E+37 (NAN)
Resolution: 1

Requirements

 GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example:

OUTPUT 714;"CALL:PPRocedure:PMEasurement:PRESponse:LINFormation:PESTimate:TYPE?"

CALL:PPRocedure:PMEasurement:PRESponse:LINFormation:PESTimate:UCODe?

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA Queries the Uncertainty Code element of the Shape Description information contained in the Position Estimate field of the optional Location Information element. If the Location Information element is not included, values for this field will not be available. See CALL:PPRocedure:PMEasurement:PRESponse:LINFormation:INCLuded? to determine if the element is included.
EGPRS LA
Query

Range: 0 to 127and 9.91E+37 (NAN)
Resolution: 1

Requirements

 GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example:

OUTPUT 714;"CALL:PPRocedure:PMEasurement:PRESponse:LINFormation:PESTimate:UCODe?"


CALL:PPRocedure:PMEasurement:PRESponse:MINFormation

CALL:PPRocedure:PMEasurement:PRESponse:MINFormation

GPIB Command Conventions

  • CALL:PPRocedure:PMEasurement:PRESponse:MINFormation:LIERror:INCLuded?
  • CALL:PPRocedure:PMEasurement:PRESponse:MINFormation:SET[<n>]:BTS:BSICode?
  • CALL:PPRocedure:PMEasurement:PRESponse:MINFormation:SET[<n>]:BTS:CARRier?
  • CALL:PPRocedure:PMEasurement:PRESponse:MINFormation:SET[<n>]:BTS:CIDentity?
  • CALL:PPRocedure:PMEasurement:PRESponse:MINFormation:SET[<n>]:BTS:CITYpe?
  • CALL:PPRocedure:PMEasurement:PRESponse:MINFormation:SET[<n>]:BTS:LACode?
  • CALL:PPRocedure:PMEasurement:PRESponse:MINFormation:SET[<n>]:BTS:MEASurements:NUMBer?
  • CALL:PPRocedure:PMEasurement:PRESponse:MINFormation:SET[<n>]:BTS:MEASurements:SDEViation?
  • CALL:PPRocedure:PMEasurement:PRESponse:MINFormation:SET[<n>]:BTS:MOFFset?
  • CALL:PPRocedure:PMEasurement:PRESponse:MINFormation:SET[<n>]:BTS:NIPResent?
  • CALL:PPRocedure:PMEasurement:PRESponse:MINFormation:SET[<n>]:BTS:NUMBer?
  • CALL:PPRocedure:PMEasurement:PRESponse:MINFormation:SET[<n>]:BTS:OTDifference?
  • CALL:PPRocedure:PMEasurement:PRESponse:MINFormation:SET[<n>]:BTS:RINDex?
  • CALL:PPRocedure:PMEasurement:PRESponse:MINFormation:SET[<n>]:BTS:SIINdex?
  • CALL:PPRocedure:PMEasurement:PRESponse:MINFormation:SET[<n>]:BTS:TSLot?
  • CALL:PPRocedure:PMEasurement:PRESponse:MINFormation:SET[<n>]:FNUMber?
  • CALL:PPRocedure:PMEasurement:PRESponse:MINFormation:SET[<n>]:MREFerence:INCLuded?
  • CALL:PPRocedure:PMEasurement:PRESponse:MINFormation:SET[<n>]:MREFerence:NUMBer?
  • CALL:PPRocedure:PMEasurement:PRESponse:MINFormation:SET[<n>]:MREFerence:QUALity?
  • CALL:PPRocedure:PMEasurement:PRESponse:MINFormation:SET[<n>]:SRESolution?
  • CALL:PPRocedure:PMEasurement:PRESponse:MINFormation:SET[<n>]:TACorrection?
  • CALL:PPRocedure:PMEasurement:PRESponse:MINFormation:SET[<n>]:TACorrection:INCLuded?
  • CALL:PPRocedure:PMEasurement:PRESponse:MINFormation:SET[<n>]:TSLot?

CALL:PPRocedure:PMEasurement:PRESponse:MINFormation:LIERror:INCLuded?

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA Queries to determine if the optional E-OTD Measurement Information element is included in the Measurement Position Response component from the MS. If this element is not included, none of the values in this element will be available. Therefore, all the queries for the fields on this element will return NAN (Not a number).
EGPRS LA
Query

0 | 1

0: Not included
1: Included

Requirements

 GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example:

OUTPUT 714;"CALL:PPRocedure:PMEasurement:PRESponse:MINFormation:LIERror:INCLuded?"

CALL:PPRocedure:PMEasurement:PRESponse:MINFormation:SET[<n>]:BTS:BSICode?

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA Queries the Neighbour BSIC field of the optional E-OTD Measurement Information element for the measurement information set indicated by the [<n>] mnemonic, where n can range from 1 to 3. If the E-OTD Measurement Information element is not included, values for this field will not be available. See CALL:PPRocedure:PMEasurement:PRESponse:MINFormation:LIERror:INCLuded? to determine if the element is included.

This query returns a Neighbour BSIC value for each of the ten neighbouring BTS that can be included in the Measurement Information element. The values are returned the order BTS1, BTS2, BTS3, BTS4, BTS5, BTS6, BTS7, BTS8, BTS9, BTS10. NAN (9.91E+37) will be returned for any neighbour that was not specified in the Measurement Information element.
EGPRS LA
Query

Range: 0 to 63 and 9.91E+37 (NAN)
Resolution: 1

Requirements

 GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example:

OUTPUT 714;"CALL:PPRocedure:PMEasurement:PRESponse:MINFormation:SET2:BTS:BSICode?"

CALL:PPRocedure:PMEasurement:PRESponse:MINFormation:SET[<n>]:BTS:CARRier?

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA Queries the Neighbour BCCH Carrier field of the optional E-OTD Measurement Information element for the measurement information set indicated by the [<n>] mnemonic, where n can range from 1 to 3. If the E-OTD Measurement Information element is not included, values for this field will not be available. See CALL:PPRocedure:PMEasurement:PRESponse:MINFormation:LIERror:INCLuded? to determine if the element is included.

This query returns a Neighbour BCCH value for each of the ten neighbouring BTS that can be included in the Measurement Information element. The values are returned the order BTS1, BTS2, BTS3, BTS4, BTS5, BTS6, BTS7, BTS8, BTS9, BTS10. NAN (9.91E+37) will be returned for any neighbour that was not specified in the Measurement Information element.
EGPRS LA
Query

Range: 0 to 1023 and 9.91E+37 (NAN)
Resolution: 1

Requirements

 GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example:

OUTPUT 714;"CALL:PPRocedure:PMEasurement:PRESponse:MINFormation:SET2:BTS:CARRier?"

CALL:PPRocedure:PMEasurement:PRESponse:MINFormation:SET[<n>]:BTS:CIDentity?

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA Queries the Neighbour CI field of the optional E-OTD Measurement Information element for the measurement information set indicated by the [<n>] mnemonic, where n can range from 1 to 3. If the E-OTD Measurement Information element is not included, values for this field will not be available. See CALL:PPRocedure:PMEasurement:PRESponse:MINFormation:LIERror:INCLuded? to determine if the element is included.

This query returns a Neighbour CI value for each of the ten neighbouring BTS that can be included in the Measurement Information element. The values are returned the order BTS1, BTS2, BTS3, BTS4, BTS5, BTS6, BTS7, BTS8, BTS9, BTS10. NAN (9.91E+37) will be returned for any neighbour that was not specified in the Measurement Information element.
EGPRS LA
Query

Range: 0 to 65535 and 9.91E+37 (NAN)
Resolution: 1

Requirements

 GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example:

OUTPUT 714;"CALL:PPRocedure:PMEasurement:PRESponse:MINFormation:SET2:BTS:CIDentity?"

CALL:PPRocedure:PMEasurement:PRESponse:MINFormation:SET[<n>]:BTS:CITYpe?

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA Queries the Cell ID Type field of the optional E-OTD Measurement Information element for the measurement information set indicated by the [<n>] mnemonic, where n can range from 1 to 3. If the E-OTD Measurement Information element is not included, values for this field will not be available. See CALL:PPRocedure:PMEasurement:PRESponse:MINFormation:LIERror:INCLuded? to determine if the element is included.

This query returns a Cell ID Type value for each of the ten neighbouring BTS that can be included in the Measurement Information element. The values are returned the order BTS1, BTS2, BTS3, BTS4, BTS5, BTS6, BTS7, BTS8, BTS9, BTS10. NAN (9.91E+37) will be returned for any neighbour that was not specified in the Measurement Information element.
EGPRS LA
Query

Range: 0 to 5 and 9.91E+37 (NAN)
Resolution: 1

Requirements

 GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example:

OUTPUT 714;"CALL:PPRocedure:PMEasurement:PRESponse:MINFormation:SET2:BTS:CITYpe?"

CALL:PPRocedure:PMEasurement:PRESponse:MINFormation:SET[<n>]:BTS:LACode?

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA Queries the Neighbour LAC field of the optional E-OTD Measurement Information element for the measurement information set indicated by the [<n>] mnemonic, where n can range from 1 to 3. If the E-OTD Measurement Information element is not included, values for this field will not be available. See CALL:PPRocedure:PMEasurement:PRESponse:MINFormation:LIERror:INCLuded? to determine if the element is included.

This query returns a Neighbour LAC value for each of the ten neighbouring BTS that can be included in the Measurement Information element. The values are returned the order BTS1, BTS2, BTS3, BTS4, BTS5, BTS6, BTS7, BTS8, BTS9, BTS10. NAN (9.91E+37) will be returned for any neighbour that was not specified in the Measurement Information element.
EGPRS LA
Query

Range: 0 to 65535 and 9.91E+37 (NAN)
Resolution: 1

Requirements

 GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example:

OUTPUT 714;"CALL:PPRocedure:PMEasurement:PRESponse:MINFormation:SET2:BTS:LACode?"

CALL:PPRocedure:PMEasurement:PRESponse:MINFormation:SET[<n>]:BTS:MEASurements:NUMBer?

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA Queries the Number of EOTD Measurements field of the optional E-OTD Measurement Information element for the measurement information set indicated by the [<n>] mnemonic, where n can range from 1 to 3. If the E-OTD Measurement Information element is not included, values for this field will not be available. See CALL:PPRocedure:PMEasurement:PRESponse:MINFormation:LIERror:INCLuded? to determine if the element is included.

This query returns a Number of EOTD Measurements value for each of the ten neighbouring BTS that can be included in the Measurement Information element. The values are returned the order BTS1, BTS2, BTS3, BTS4, BTS5, BTS6, BTS7, BTS8, BTS9, BTS10. NAN (9.91E+37) will be returned for any neighbour that was not specified in the Measurement Information element.
EGPRS LA
Query

Range: 0 to 7 and 9.91E+37 (NAN)
Resolution: 1

Requirements

 GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example:

OUTPUT 714;"CALL:PPRocedure:PMEasurement:PRESponse:MINFormation:SET2:BTS:MEASurements:NUMBer?"

CALL:PPRocedure:PMEasurement:PRESponse:MINFormation:SET[<n>]:BTS:MEASurements:SDEViation?

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA Queries the Standard Deviation of EOTD Measurements field of the optional E-OTD Measurement Information element for the measurement information set indicated by the [<n>] mnemonic, where n can range from 1 to 3. If the E-OTD Measurement Information element is not included, values for this field will not be available. See CALL:PPRocedure:PMEasurement:PRESponse:MINFormation:LIERror:INCLuded? to determine if the element is included.

This query returns a Standard Deviation of EOTD Measurements value for each of the ten neighbouring BTS that can be included in the Measurement Information element. The values are returned the order BTS1, BTS2, BTS3, BTS4, BTS5, BTS6, BTS7, BTS8, BTS9, BTS10. NAN (9.91E+37) will be returned for any neighbour that was not specified in the Measurement Information element.
EGPRS LA
Query

Range: 0 to 31 and 9.91E+37 (NAN)
Resolution: 1

Requirements

 GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example:

OUTPUT 714;"CALL:PPRocedure:PMEasurement:PRESponse:MINFormation:SET2:BTS:MEASurements:SDEViation?"

CALL:PPRocedure:PMEasurement:PRESponse:MINFormation:SET[<n>]:BTS:MOFFset?

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA Queries the Neighbour Multiframe Offset field of the optional E-OTD Measurement Information element for the measurement information set indicated by the [<n>] mnemonic, where n can range from 1 to 3. If the E-OTD Measurement Information element is not included, values for this field will not be available. See CALL:PPRocedure:PMEasurement:PRESponse:MINFormation:LIERror:INCLuded? to determine if the element is included.

This query returns a Neighbour Multiframe Offset value for each of the ten neighbouring BTS that can be included in the Measurement Information element. The values are returned the order BTS1, BTS2, BTS3, BTS4, BTS5, BTS6, BTS7, BTS8, BTS9, BTS10. NAN (9.91E+37) will be returned for any neighbour that was not specified in the Measurement Information element.
EGPRS LA
Query

Range: 0 to 51 and 9.91E+37 (NAN)
Resolution: 1

Requirements

 GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example:

OUTPUT 714;"CALL:PPRocedure:PMEasurement:PRESponse:MINFormation:SET2:BTS:MOFFset?"

CALL:PPRocedure:PMEasurement:PRESponse:MINFormation:SET[<n>]:BTS:NIPResent?

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA Queries the Neighbour Identity Present field of the optional E-OTD Measurement Information element for the measurement information set indicated by the [<n>] mnemonic, where n can range from 2 to 3. If the E-OTD Measurement Information element is not included, values for this field will not be available. See CALL:PPRocedure:PMEasurement:PRESponse:MINFormation:LIERror:INCLuded? to determine if the element is included.

This query returns a Neighbour Identity Present value for each of the ten neighbouring BTS that can be included in the Measurement Information element. The values are returned the order BTS1, BTS2, BTS3, BTS4, BTS5, BTS6, BTS7, BTS8, BTS9, BTS10. NAN (9.91E+37) will be returned for any neighbour that was not specified in the Measurement Information element.
EGPRS LA
Query

Range: 0 to 1 and 9.91E+37 (NAN)
Resolution: 1

Requirements

 GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example:

OUTPUT 714;"CALL:PPRocedure:PMEasurement:PRESponse:MINFormation:SET2:BTS:NIPResent?"

CALL:PPRocedure:PMEasurement:PRESponse:MINFormation:SET[<n>]:BTS:NUMBer?

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA Queries the Number of Measured Neighbours field of the optional E-OTD Measurement Information element for the measurement information set indicated by the [<n>] mnemonic, where n can range from 1 to 3. If the E-OTD Measurement Information element is not included, values for this field will not be available. See CALL:PPRocedure:PMEasurement:PRESponse:MINFormation:LIERror:INCLuded? to determine if the element is included.
EGPRS LA
Query

Range: 0 to 10 and 9.91E+37 (NAN)
Resolution: 1

Requirements

 GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example:

OUTPUT 714;"CALL:PPRocedure:PMEasurement:PRESponse:MINFormation:SET2:BTS:NUMBer?"

CALL:PPRocedure:PMEasurement:PRESponse:MINFormation:SET[<n>]:BTS:OTDifference?

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA Queries the OTD field of the optional E-OTD Measurement Information element for the measurement information set indicated by the [<n>] mnemonic, where n can range from 1 to 3. If the E-OTD Measurement Information element is not included, values for this field will not be available. See CALL:PPRocedure:PMEasurement:PRESponse:MINFormation:LIERror:INCLuded? to determine if the element is included.

This query returns a OTD value for each of the ten neighbouring BTS that can be included in the Measurement Information element. The values are returned the order BTS1, BTS2, BTS3, BTS4, BTS5, BTS6, BTS7, BTS8, BTS9, BTS10. NAN (9.91E+37) will be returned for any neighbour that was not specified in the Measurement Information element.
EGPRS LA
Query

Range: 0 to 39999 and 9.91E+37 (NAN)
Resolution: 1

Requirements

 GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example:

OUTPUT 714;"CALL:PPRocedure:PMEasurement:PRESponse:MINFormation:SET2:BTS:OTDifference?"

CALL:PPRocedure:PMEasurement:PRESponse:MINFormation:SET[<n>]:BTS:RINDex?

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA Queries the Request Index field of the optional E-OTD Measurement Information element for the measurement information set indicated by the [<n>] mnemonic, where n can range from 1 to 3. If the E-OTD Measurement Information element is not included, values for this field will not be available. See CALL:PPRocedure:PMEasurement:PRESponse:MINFormation:LIERror:INCLuded? to determine if the element is included.

This query returns a Request Index value for each of the ten neighbouring BTS that can be included in the Measurement Information element. The values are returned the order BTS1, BTS2, BTS3, BTS4, BTS5, BTS6, BTS7, BTS8, BTS9, BTS10. NAN (9.91E+37) will be returned for any neighbour that was not specified in the Measurement Information element.
EGPRS LA
Query

Range: 0 to 16 and 9.91E+37 (NAN)
Resolution: 1

Requirements

 GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example:

OUTPUT 714;"CALL:PPRocedure:PMEasurement:PRESponse:MINFormation:SET2:BTS:RINDex?"

CALL:PPRocedure:PMEasurement:PRESponse:MINFormation:SET[<n>]:BTS:SIINdex?

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA Queries the System Info Index field of the optional E-OTD Measurement Information element for the measurement information set indicated by the [<n>] mnemonic, where n can range from 1 to 3. If the E-OTD Measurement Information element is not included, values for this field will not be available. See CALL:PPRocedure:PMEasurement:PRESponse:MINFormation:LIERror:INCLuded? to determine if the element is included.

This query returns a System Info Index value for each of the ten neighbouring BTS that can be included in the Measurement Information element. The values are returned the order BTS1, BTS2, BTS3, BTS4, BTS5, BTS6, BTS7, BTS8, BTS9, BTS10. NAN (9.91E+37) will be returned for any neighbour that was not specified in the Measurement Information element.
EGPRS LA
Query

Range: 0 to 32 and 9.91E+37 (NAN)
Resolution: 1

Requirements

 GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example:

OUTPUT 714;"CALL:PPRocedure:PMEasurement:PRESponse:MINFormation:SET2:BTS:SIINDex?"

CALL:PPRocedure:PMEasurement:PRESponse:MINFormation:SET[<n>]:BTS:TSLot?

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA Queries the Neighbour Time Slot field of the optional E-OTD Measurement Information element for the measurement information set indicated by the [<n>] mnemonic, where n can range from 1 to 3. If the E-OTD Measurement Information element is not included, values for this field will not be available. See CALL:PPRocedure:PMEasurement:PRESponse:MINFormation:LIERror:INCLuded? to determine if the element is included.

This query returns a Neighbour Time Slot value for each of the ten neighbouring BTS that can be included in the Measurement Information element. The values are returned the order BTS1, BTS2, BTS3, BTS4, BTS5, BTS6, BTS7, BTS8, BTS9, BTS10. NAN (9.91E+37) will be returned for any neighbour that was not specified in the Measurement Information element.
EGPRS LA
Query

Range: 0 to 3 and 9.91E+37 (NAN)
Resolution: 1

Requirements

 GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example:

OUTPUT 714;"CALL:PPRocedure:PMEasurement:PRESponse:MINFormation:SET2:BTS:TSLot?"

CALL:PPRocedure:PMEasurement:PRESponse:MINFormation:SET[<n>]:FNUMber?

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA Queries the Reference Frame Number field of the optional E-OTD Measurement Information element for the measurement information set indicated by the [<n>] mnemonic, where n can range from 1 to 3. If the E-OTD Measurement Information element is not included, values for this field will not be available. See CALL:PPRocedure:PMEasurement:PRESponse:MINFormation:LIERror:INCLuded? to determine if the element is included.
EGPRS LA
Query

Range: 0 to 42431and 9.91E+37 (NAN)
Resolution: 1

Requirements

 GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example:

OUTPUT 714;"CALL:PPRocedure:PMEasurement:PRESponse:MINFormation:SET2:FNUMBer?"

CALL:PPRocedure:PMEasurement:PRESponse:MINFormation:SET[<n>]:MREFerence:INCLuded?

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA Queries to determine if the Measurements of Reference BTS field is included in the E-OTD Measurement Information element of the Measurement Position Response component. If this field is not included, none of the values for this field will be available. Therefore, CALL:PPRocedure:PMEasurement:PRESponse:MINFormation:SET[<n>]:MREFerence:QUALity? and CALL:PPRocedure:PMEasurement:PRESponse:MINFormation:SET[<n>]:MREFerence:NUMBer? will all return NAN (Not a number).
EGPRS LA
Query

0 | 1

0: Not included
1: Included

Requirements

 GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example:

OUTPUT 714;"CALL:PPRocedure:PMEasurement:PRESponse:MINFormation:SET2:MREFerence:INCLuded?"

CALL:PPRocedure:PMEasurement:PRESponse:MINFormation:SET[<n>]:MREFerence:NUMBer?

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA Queries the Number of Measurements field of the optional Measurements of Reference BTS field for the measurement information set indicated by the [<n>] mnemonic, where n can range from 1 to 3. If the Measurements of Reference BTS field is not included, values for this field will not be available. See CALL:PPRocedure:PMEasurement:PRESponse:MINFormation:SET[<n>]:MREFerence:INCLuded? to determine if the element is included.
EGPRS LA
Query

Range: 0 to 7 and 9.91E+37 (NAN)
Resolution: 1

Requirements

 GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example:

OUTPUT 714;"CALL:PPRocedure:PMEasurement:PRESponse:MINFormation:SET2:MREFerence:NUMBer?"

CALL:PPRocedure:PMEasurement:PRESponse:MINFormation:SET[<n>]:MREFerence:QUALity?

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA Queries the Reference Quality field of the optional Measurements of Reference BTS field for the measurement information set indicated by the [<n>] mnemonic, where n can range from 1 to 3. If the Measurements of Reference BTS field is not included, values for this field will not be available. See CALL:PPRocedure:PMEasurement:PRESponse:MINFormation:SET[<n>]:MREFerence:INCLuded? to determine if the element is included.
EGPRS LA
Query

Range: 0 to 31and 9.91E+37 (NAN)
Resolution: 1

Requirements

 GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example:

OUTPUT 714;"CALL:PPRocedure:PMEasurement:PRESponse:MINFormation:SET2:MREFerence:QUALity?"

CALL:PPRocedure:PMEasurement:PRESponse:MINFormation:SET[<n>]:SRESolution?

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA Queries the Standard Resolution field of the optional E-OTD Measurement Information element for the measurement information set indicated by the [<n>] mnemonic, where n can range from 1 to 3. If the E-OTD Measurement Information element is not included, values for this field will not be available. See CALL:PPRocedure:PMEasurement:PRESponse:MINFormation:LIERror:INCLuded? to determine if the element is included.
EGPRS LA
Query

Range: 0 to 3and 9.91E+37 (NAN)
Resolution: 1

Requirements

 GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example:

OUTPUT 714;"CALL:PPRocedure:PMEasurement:PRESponse:MINFormation:SET2:SRESolution?"

CALL:PPRocedure:PMEasurement:PRESponse:MINFormation:SET[<n>]:TACorrection?

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA Queries the value of the optional TA Correction field for the measurement information set indicated by the [<n>] mnemonic, where n can range from 1 to 3. If the TA Correction field is not included, values for this field will not be available. See CALL:PPRocedure:PMEasurement:PRESponse:MINFormation:SET[<n>]:TACorrection:INCLuded? to determine if the element is included.
EGPRS LA
Query

Range: 0 to 960 and 9.91E+37 (NAN)
Resolution: 1

Requirements

 GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example:

OUTPUT 714;"CALL:PPRocedure:PMEasurement:PRESponse:MINFormation:SET2:TACorrection?"

CALL:PPRocedure:PMEasurement:PRESponse:MINFormation:SET[<n>]:TACorrection:INCLuded?

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA Queries to determine if the TA Correction field is included in the E-OTD Measurement Information element of the Measurement Position Response component. If this field is not included, the value for this field will not be available. Therefore, CALL:PPRocedure:PMEasurement:PRESponse:MINFormation:SET[<n>]:TACorrection? will return NAN (Not a number).
EGPRS LA
Query

0 | 1

0: Not included
1: Included

Requirements

 GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example:

OUTPUT 714;"CALL:PPRocedure:PMEasurement:PRESponse:MINFormation:SET2:TACorrection:INCLuded?"

CALL:PPRocedure:PMEasurement:PRESponse:MINFormation:SET[<n>]:TSLot?

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA Queries the Reference Time Slot field of the optional E-OTD Measurement Information element for the measurement information set indicated by the [<n>] mnemonic, where n can range from 1 to 3. If the E-OTD Measurement Information element is not included, values for this field will not be available. See CALL:PPRocedure:PMEasurement:PRESponse:MINFormation:LIERror:INCLuded? to determine if the element is included.
EGPRS LA
Query

Range: 0 to 3 and 9.91E+37 (NAN)
Resolution: 1

Requirements

 GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example:

OUTPUT 714;"CALL:PPRocedure:PMEasurement:PRESponse:MINFormation:SET2:TSLot?"


CALL:PPRocedure:PMEasurement:PRESponse:MSETs

CALL:PPRocedure:PMEasurement:PRESponse:MSETs

GPIB Command Conventions

  • CALL:PPRocedure:PMEasurement:PRESponse:MSETs:INCLuded?
  • CALL:PPRocedure:PMEasurement:PRESponse:MSETs:RBTS:NUMBer?
  • CALL:PPRocedure:PMEasurement:PRESponse:MSETs:RBTS:RELation?
  • CALL:PPRocedure:PMEasurement:PRESponse:MSETs:SETS:NUMBer?

CALL:PPRocedure:PMEasurement:PRESponse:MSETs:INCLuded?

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA Queries to determine if the optional Multiple Sets element is included in the Measurement Position Response component from the MS. If this element is not included, none of the values in this element will be available. Therefore, CALL:PPRocedure:PMEasurement:PRESponse:MSETs:SETS:NUMBer? , CALL:PPRocedure:PMEasurement:PRESponse:MSETs:RBTS:NUMBer? , and CALL:PPRocedure:PMEasurement:PRESponse:MSETs:RBTS:RELation? will all return NAN (Not a number).
EGPRS LA
Query

0 | 1

0: Not included
1: Included

Requirements

 GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example:

OUTPUT 714;"CALL:PPRocedure:PMEasurement:PRESponse:MSETS:INCLuded?"

CALL:PPRocedure:PMEasurement:PRESponse:MSETs:RBTS:NUMBer?

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA Queries the Number of Reference BTS field of the optional Multiple Sets element. If the Multiple Sets element is not included, values for this field will not be available. See CALL:PPRocedure:PMEasurement:PRESponse:MSETs:INCLuded? to determine if the element is included.
EGPRS LA
Query

Range: 1 to 3 and 9.91E+37 (NAN)
Resolution: 1

Requirements

 GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example:

OUTPUT 714;"CALL:PPRocedure:PMEasurement:PRESponse:MSETS:RBTS:NUMBer?"

CALL:PPRocedure:PMEasurement:PRESponse:MSETs:RBTS:RELation?

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA Queries the Reference BTS Relation to Measurement Elements field of the optional Multiple Sets element. If the Multiple Sets element is not included, values for this field will not be available. See CALL:PPRocedure:PMEasurement:PRESponse:MSETs:INCLuded? to determine if the element is included.
EGPRS LA
Query

Range: 0 to 2 and 9.91E+37 (NAN)
Resolution: 1

Requirements

 GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example:

OUTPUT 714;"CALL:PPRocedure:PMEasurement:PRESponse:MSETS:RBTS:RELation?"

CALL:PPRocedure:PMEasurement:PRESponse:MSETs:SETS:NUMBer?

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA Queries the Reference BTS Relation to Measurement Elements field of the optional Multiple Sets element. If the Multiple Sets element is not included, values for this field will not be available. See CALL:PPRocedure:PMEasurement:PRESponse:MSETs:INCLuded? to determine if the element is included.
EGPRS LA
Query

Range: 2 to 3 and 9.91E+37 (NAN)
Resolution: 1

Requirements

 GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example:

OUTPUT 714;"CALL:PPRocedure:PMEasurement:PRESponse:MSETS:SETS:NUMBer?"


CALL:PPRocedure:PMEasurement:PRESponse:RIDentity

CALL:PPRocedure:PMEasurement:PRESponse:RIDentity

GPIB Command Conventions

  • CALL:PPRocedure:PMEasurement:PRESponse:RIDentity:BSICode?
  • CALL:PPRocedure:PMEasurement:PRESponse:RIDentity:CARRier?
  • CALL:PPRocedure:PMEasurement:PRESponse:RIDentity:CIDentity?
  • CALL:PPRocedure:PMEasurement:PRESponse:RIDentity:CITYpe?
  • CALL:PPRocedure:PMEasurement:PRESponse:RIDentity:INCLuded?
  • CALL:PPRocedure:PMEasurement:PRESponse:RIDentity:LACode?
  • CALL:PPRocedure:PMEasurement:PRESponse:RIDentity:RINDex?
  • CALL:PPRocedure:PMEasurement:PRESponse:RIDentity:SIINdex?

CALL:PPRocedure:PMEasurement:PRESponse:RIDentity:BSICode?

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA Queries the Reference BSIC field of the optional Reference BTS Identity element. If the Reference BTS Identity element is not included, values for this field will not be available. See CALL:PPRocedure:PMEasurement:PRESponse:RIDentity:INCLuded? to determine if the element is included.

This query returns the BSIC for the three potential reference BTS that can be included in the Reference BTS Identity element. The values are returned the order BTS1, BTS2, BTS3.
EGPRS LA
Query

Range: 0 to 63 and 9.91E+37 (NAN)
Resolution: 1

Requirements

 GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example:

OUTPUT 714;"CALL:PPRocedure:PMEasurement:PRESponse:RIDentity:BSICode?"

CALL:PPRocedure:PMEasurement:PRESponse:RIDentity:CARRier?

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA Queries the Reference BCCH Carrier field of the optional Reference BTS Identity element. If the Reference BTS Identity element is not included, values for this field will not be available. See CALL:PPRocedure:PMEasurement:PRESponse:RIDentity:INCLuded? to determine if the element is included.

This query returns the BCCH Carrier for the three potential reference BTS that can be included in the Reference BTS Identity element. The values are returned the order BTS1, BTS2, BTS3.
EGPRS LA
Query

Range: 0 to 1023 and 9.91E+37 (NAN)
Resolution: 1

Requirements

 GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example:

OUTPUT 714;"CALL:PPRocedure:PMEasurement:PRESponse:RIDentity:CARRier?"

CALL:PPRocedure:PMEasurement:PRESponse:RIDentity:CIDentity?

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA Queries the Reference CI field of the optional Reference BTS Identity element. If the Reference BTS Identity element is not included, values for this field will not be available. See CALL:PPRocedure:PMEasurement:PRESponse:RIDentity:INCLuded? to determine if the element is included.

This query returns the CI for the three potential reference BTS that can be included in the Reference BTS Identity element. The values are returned the order BTS1, BTS2, BTS3.
EGPRS LA
Query

Range: 0 to 65535 and 9.91E+37 (NAN)
Resolution: 1

Requirements

 GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example:

OUTPUT 714;"CALL:PPRocedure:PMEasurement:PRESponse:RIDentity:CIDentity?"

CALL:PPRocedure:PMEasurement:PRESponse:RIDentity:CITYpe?

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA Queries the Cell ID Type field of the optional Reference BTS Identity element. If the Reference BTS Identity element is not included, values for this field will not be available. See CALL:PPRocedure:PMEasurement:PRESponse:RIDentity:INCLuded? to determine if the element is included.

This query returns the Cell ID Type for the three potential reference BTS that can be included in the Reference BTS Identity element. The values are returned the order BTS1, BTS2, BTS3.
EGPRS LA
Query

Range: 0 to 4 and 9.91E+37 (NAN)
Resolution: 1

Requirements

 GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example:

OUTPUT 714;"CALL:PPRocedure:PMEasurement:PRESponse:RIDentity:CITYpe?"

CALL:PPRocedure:PMEasurement:PRESponse:RIDentity:INCLuded?

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA Queries to determine if the optional Reference BTS Identity element is included in the Measurement Position Response component from the MS. If this element is not included, none of the values in this element will be available. Therefore, CALL:PPRocedure:PMEasurement:PRESponse:RIDentity:CITYpe? , CALL:PPRocedure:PMEasurement:PRESponse:RIDentity:LACode? , CALL:PPRocedure:PMEasurement:PRESponse:RIDentity:CIDentity? , CALL:PPRocedure:PMEasurement:PRESponse:RIDentity:CARRier? , CALL:PPRocedure:PMEasurement:PRESponse:RIDentity:BSICode? , CALL:PPRocedure:PMEasurement:PRESponse:RIDentity:RINDex? and CALL:PPRocedure:PMEasurement:PRESponse:RIDentity:SIINdex? will all return NAN (Not a number).
EGPRS LA
Query

0 | 1

0: Not included
1: Included

Requirements

 GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example:

OUTPUT 714;"CALL:PPRocedure:PMEasurement:PRESponse:RIDentity:INCLuded?"

CALL:PPRocedure:PMEasurement:PRESponse:RIDentity:LACode?

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA Queries the Reference LAC field of the optional Reference BTS Identity element. If the Reference BTS Identity element is not included, values for this field will not be available. See CALL:PPRocedure:PMEasurement:PRESponse:RIDentity:INCLuded? to determine if the element is included.

This query returns the LAC for the three potential reference BTS that can be included in the Reference BTS Identity element. The values are returned the order BTS1, BTS2, BTS3.
EGPRS LA
Query

Range: 0 to 65535 and 9.91E+37 (NAN)
Resolution: 1

Requirements

 GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example:

OUTPUT 714;"CALL:PPRocedure:PMEasurement:PRESponse:RIDentity:LACode?"

CALL:PPRocedure:PMEasurement:PRESponse:RIDentity:RINDex?

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA Queries the Request Index field of the optional Reference BTS Identity element. If the Reference BTS Identity element is not included, values for this field will not be available. See CALL:PPRocedure:PMEasurement:PRESponse:RIDentity:INCLuded? to determine if the element is included.

This query returns an index for each of the three potential reference BTS that can be included in the Reference BTS Identity element. The values are returned the order BTS1, BTS2, BTS3.
EGPRS LA
Query

Range: 0 to 16 and 9.91E+37 (NAN)
Resolution: 1

Requirements

 GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example:

OUTPUT 714;"CALL:PPRocedure:PMEasurement:PRESponse:RIDentity:RINDex?"

CALL:PPRocedure:PMEasurement:PRESponse:RIDentity:SIINdex?

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA Queries the System Info Index field of the optional Reference BTS Identity element. If the Reference BTS Identity element is not included, values for this field will not be available. See CALL:PPRocedure:PMEasurement:PRESponse:RIDentity:INCLuded? to determine if the element is included.

This query returns an index for each of the three potential reference BTS that can be included in the Reference BTS Identity element. The values are returned the order BTS1, BTS2, BTS3.
EGPRS LA
Query

Range: 0 to 32 and 9.91E+37 (NAN)
Resolution: 1

Requirements

 GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example:

OUTPUT 714;"CALL:PPRocedure:PMEasurement:PRESponse:RIDentity:SIINDex?"


CALL:PPRocedure:RAU|RAUPdate

CALL:PPRocedure:RAU|RAUPdate

GPIB Command Conventions

  • CALL:PPRocedure:RAU|RAUPdate:REJect[:STATe]
  • CALL:PPRocedure:RAU|RAUPdate:REJect:GMMCause
  • CALL:PPRocedure:RAU|RAUPdate:T3312

CALL:PPRocedure:RAU|RAUPdate:REJect[:STATe]

Function

GSM TA

 This command is not applicable to the GSM test applications.
GPRS TA | This command is not applicable to the GPRS test applications.
EGPRS TA | This command is not applicable to the EGPRS test applications.
GSM/GPRS LA

This command sets Routing Area Update Reject State. When the parameter is set to ON, the test set will reject the RAU request from the mobile station.

EGPRS LA
Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST setting

 0|OFF

Requirements

 GSM/GPRS/ EGPRS LA

Revision: F.00.27 and above

Programming Example:

OUTPUT 714;"CALL:PPRocedure:RAUPdate:REJect ON"
! Sets the Routing Area Update Reject State to ON.

CALL:PPRocedure:RAU|RAUPdate:REJect:GMMCause

Function

GSM TA

 This command is not applicable to the GSM test applications.
GPRS TA | This command is not applicable to the GPRS test applications.
EGPRS TA | This command is not applicable to the EGPRS test applications.
GSM/GPRS LA

This command sets the Routing Area Update Reject cause.

See GMM Cause Information Element for details on settings this parameter accepts as defined in 3GPP TS 24.008 Version 6.7.0.

EGPRS LA
Setting

Range: 0 to 255 (decimal)

Query

Range: 0 to 255

*RST setting

+12

Requirements

 GSM/GPRS/ EGPRS LA

Revision: F.00.27 and above

Programming Example:

OUTPUT 714;"CALL:PPRocedure:RAUPdate:REJect:GMMCause 7"
! The test set sends the MS the RAU Reject cause value as "GPRS Services Not Allowed".

CALL:PPRocedure:RAU|RAUPdate:T3312

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

Sets the Periodic Routing Update Timer value. See Configurable Timers .

The size of the layer 3 message field is limited and to provide large range of values the following rounding will be applied to the actual value sent to the MS.

  • Values of 1s to 60s will be rounded up to nearest even number of seconds.
  • Values of 61s to 1860s will be rounded up to the nearest minute.
  • Values of 1861s to 11160s will be rounded up to the nearest decihours (1 decihour = 6 minutes).
EGPRS LA
Setting

Range: 0 to 11160s

Query

Range: 0 to 11160s

*RST setting

 0

Requirements

 GSM/GPRS/ EGPRS LA

Revision: F.00.27 and above

Programming Example:

OUTPUT 714;"CALL:PPROCEDURE:RAU:T3312 10"
! Set the expire time of T3312 to 10 seconds.


CALL:PPRocedure:T3314

CALL:PPRocedure:T3314

GPIB Command Conventions

  • CALL:PPRocedure:T3314
  • CALL:PPRocedure:T3314:STATe

CALL:PPRocedure:T3314

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

Sets the GMM Ready Timer value. See Configurable Timers .

The size of the layer 3 message field is limited and to provide large range of values the following rounding will be applied to the actual value sent to the MS.

  • Values of 1s to 60s will be rounded up to nearest even number of seconds.
  • Values of 61s to 1860s will be rounded up to the nearest minute.
  • Values of 1861s to 11160s will be rounded up to the nearest decihours (1 decihour = 6 minutes).
EGPRS LA
Setting

Range: 0 to 11160s

Query

Range: 0 to 11160s

*RST setting

 0

Requirements

 GSM/GPRS/ EGPRS LA

Revision: F.00.27 and above

Programming Example:

OUTPUT 714;"CALL:PPROCEDURE:T3314 10"
! Set the expire time of T3314 to 10 seconds.

CALL:PPRocedure:T3314:STATe

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

This command Enables/Disables the GMM Ready Timer state. The GMM Ready Timer must be enabled for the timer value to be used. See Configurable Timers .
EGPRS LA
Setting

Range: 0 to 11160s

Query

Range: 0 to 11160s

*RST setting

 0

Requirements

 GSM/GPRS/ EGPRS LA

Revision: F.00.27 and above

Programming Example:

OUTPUT 714;"CALL:PPROCEDURE:T3314:STATE ON" ! Enable the GMM Ready Timer.


CALL:PSINdication

CALL:PSINdication

GPIB Command Conventions

  • CALL[:CELL]:PSINdication

CALL[:CELL]:PSINdication

Function GSM TA

This command is not applicable to the GSM Test Applications.

GPRS TA

This command is not applicable to the GPRS Test Applications.

EGPRS TA

This command is not applicable to the EGPRS Test Applications.

GSM/GPRS LA

This command sets/queries the Packet SI/PSI Status Indication State.

When this parameter is set to ON, the test set will indicate the supporting of the packet SI/PSI Status message in the SI13 message (on BCCH) or PSI1 message (on PBCCH). The mobile can request the specific SI/PSI messages to be transferred from the test set when working in the Packet Transfer state; Upon receiving the SI/PSI request messages the test set provides the requested broadcast information messages over the available PACCH associated with an active TBF between the mobile and the test set.

Note: The Operating Mode must be set to Cell Off before setting this parameter. See CALL:OPERating for more details.

EGPRS LA

Setting

Range: 1|ON|0|OFF

Query

Range: 0|1

*RST Setting

 0|OFF
Requirements GSM/GPRS/ EGPRS LA

Revision: F.00.37 and above

Programming Example

OUTPUT 714;"CALL:CELL:PSINdication ON"
! Set the Packet (P)SI status Indication State to ON.


CALL:SECurity

CALL:SECurity

  • CALL:SECurity:AUTHenticate:RANDom[:SELected]
  • CALL:SECurity:AUTHenticate:RANDom[:SELected]
  • CALL:SECurity:AUTHenticate:RANDom[:SELected]
  • CALL:SECurity:AUTHenticate:RESult[:MM][:SELected]?
  • CALL:SECurity:AUTHenticate:RESult:GMM[:SELected]?
  • CALL:SECurity:AUTHenticate:STATe
  • CALL:SECurity:AUTHenticate:XRESult[:SELected]
  • CALL:SECurity:CIPHering[:KEY]
  • CALL:SECurity:CIPHering:CKSNumber
  • CALL:SECurity:CIPHering:GPRS:ALGorithm
  • CALL:SECurity:CIPHering:GSM:ALGorithm

CALL:SECurity:AUTHenticate:RANDom[:SELected]

CALL:SECurity:AUTHenticate:RANDom:GSM

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

This parameter sets the 128 bit random number used as a challenge to MS in an authentication request. See Random(RAND) Value for more information.
EGPRS LA

Setting

 Range: 0 to FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF

Query

 Range: "00000000:00000000:00000000:00000000" to "FFFFFFFF:FFFFFFFF:FFFFFFFF:FFFFFFFF"

*RST setting

 "00000000:00000000:00000000:00000000"
Requirements GSM/GPRS/ EGPRS LA

Revision: F.00.37 and above

Programming Example

OUTPUT 714;"CALL:SECurity:AUTHenticate:RANDom 'B'"
! Sets the random value of the Authentication Parameter to 00000000:00000000:00000000:0000000B.

CALL:SECurity:AUTHenticate:RESult[:MM][:SELected]?

CALL:SECurity:AUTHenticate:RESult[:MM]:GSM?

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA This parameter queries the Authentication Result for MM authentication procedure. See Authentication Result: MM (CS domain) for more information.
EGPRS LA

Query

 Range: SUCCess|MSFAILUN|KNOWN|RESNOTMA|TCH|NULL
Requirements GSM/GPRS/ EGPRS LA

Revision: F.00.37 and above

Programming Example

OUTPUT 714;"CALL:SECurity:AUTHenticate:RESult?"
! Queries the MM authentication result.

CALL:SECurity:AUTHenticate:RESult:GMM[:SELected]?

CALL:SECurity:AUTHenticate:RESult:GMM:GSM?

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA Please refer to MM authentication result.
EGPRS LA

Query

 Range: SUCCess|MSFAILSYNC|MSFAILUN|KNOWN|NULL
Requirements GSM/GPRS/ EGPRS LA

Revision: F.00.37 and above

Programming Example

OUTPUT 714;"CALL:SECurity:AUTHenticate:RESult:GMM?"
! Queries the GMM authentication result.

CALL:SECurity:AUTHenticate:STATe

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA When this parameter is set to ON, the test set will perform an authentication challenge to the MS on every opportunity. This parameter sets Authentication State. See Authentication State for more information.
EGPRS LA

Setting

 Range: 1|ON|0|OFF

Query

 Range: 1|0

*RST setting

 0|OFF
Requirements GSM/GPRS/ EGPRS LA

Revision: F.00.37 and above

Programming Example

OUTPUT 714;"CALL:SECurity:AUTHenticate:STATe ON"
! Sets Authentication state to ON.

CALL:SECurity:AUTHenticate:XRESult[:SELected]

CALL:SECurity:AUTHenticate:XRESult:GSM

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA This parameter sets the 32 bit expected response used to compare with the actual SRES sent from the MS as a response to the RAND challenge. See XRES for more information.
EGPRS LA

Setting

 Range: 0 to FFFFFFFF

Query

 Range: "00000000" to "FFFFFFFF"

*RST setting

 "00000000"
Requirements GSM/GPRS/ EGPRS LA

Revision: F.00.37and above

Programming Example

OUTPUT 714;"CALL:SECurity:AUTHenticate:XRESult `E34B7AD8'"
! Sets the XRESult value of the Authentication Parameter to E34B7AD8.

CALL:SECurity:CIPHering[:KEY]

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA This parameter sets the 64 bit number used as an entry parameter to the selected encryption algorithm. See Ciphering Key(Kc) for more information.
EGPRS LA

Setting

 Range: 0 to FFFFFFFFFFFFFFFF

Query

 Range: "00000000:00000000" to "FFFFFFFF:FFFFFFFF"

*RST setting

 "0000000000000000"
Requirements GSM/GPRS/ EGPRS LA

Revision: F.00.37 and above

Programming Example

OUTPUT 714;"CALL:SECurity:Ciphering `7C'"
! Sets the ciphering key to 00000000:0000007C.

CALL:SECurity:CIPHering:CKSNumber

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA This parameter sets Cipher Key Sequence Number. See Cipher Key Sequence Number (CKSN) for more information.
EGPRS LA

Setting

 Range: 0 to 7

Query

 Range: 0 to 7

*RST setting

 1
Requirements GSM/GPRS/ EGPRS LA

Revision: F.00.37 and above

Programming Example

OUTPUT 714;"CALL:SECurity:Ciphering:CKSNumber 1"
! Sets the CKSN to 1.

CALL:SECurity:CIPHering:GPRS:ALGorithm

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA This parameter sets which ciphering algorithm will be used for GPRS packet switched data. See GPRS Ciphering Algorithm for more information.
EGPRS LA

Setting

 Range: OFF|GEA1|GEA2|GEA3

Query

 Range: OFF|GEA1|GEA2|GEA3

*RST setting

 0|OFF
Requirements GSM/GPRS/ EGPRS LA

Revision: F.00.37 and above

Programming Example

OUTPUT 714;"CALL:SECurity:Ciphering:GPRS:ALGorithm GEA3"
! Sets the ciphering GPRS algorithm to GEA3.

CALL:SECurity:CIPHering:GSM:ALGorithm

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

This parameter sets which ciphering algorithm will be used for GSM voice or circuit switched data.See GSM Ciphering Algorithm for more information
EGPRS LA

Setting

 Range: OFF|A51|A53

Query

 Range: OFF|A51|A53

*RST setting

 0|OFF
Requirements GSM/GPRS/ EGPRS LA

Revision: F.00.37 and above

Programming Example

OUTPUT 714;"CALL:SECurity:Ciphering:GSM:ALGorithm A53"
! Sets the ciphering GSM algorithm to A53.


CALL:SSERvice

CALL:SSERvice

GPIB Command Conventions

  • CALL:SSERvice:PIPE
  • CALL:SSERvice:PIPE:MMConnect
  • CALL:SSERvice:PIPE[:DATA]:RX?
  • CALL:SSERvice:PIPE[:DATA]:RX:AVAilable?
  • CALL:SSERvice:PIPE:TIMeout
  • CALL:SSERvice:PIPE[:DATA]:TX
  • CALL:SSERvice:PIPE[:DATA]:TX:SEND

CALL:SSERvice:PIPE

Function

 GSM TA This command is not applicable to the GSM Test Application.

GPRS TA

 This command is not applicable to the GPRS Test Application.

EGPRS TA

 This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

This command sets/queries the SS pipe mode.

  • 1 | ON - Enable the SS pipe mode
  • 0 | OFF - Disable the SS pipe mode

EGPRS LA

Setting

 Range: 1 | ON | 0 | OFF

Query

Range: 0 | 1

*RST Setting

0
Requirements GSM/GPRS/ EGPRS LA

Revision: F.00.27 and above

Programming Example

OUTPUT 714;"CALL:SSERvice:PIPE 1"
! Enable the SS pipe mode.

CALL:SSERvice:PIPE:MMConnect

Function

 GSM TA This command is not applicable to the GSM Test Application.

GPRS TA

 This command is not applicable to the GPRS Test Application.

EGPRS TA

 This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

This command sets/queries the MM (Mobile Management) connection.

  • 1 | ON - Enable the MM connection
  • 0 | OFF - Disable the MM connection

Disabling the SS pipe shall force the MM Connection Control to OFF and bring down any SS initiated MM connections. When the SS pipe is disabled, the test set report error message 232 on enabling MM connection.

Note, when querying the status of the MM connection, the result only indicates the status of the MM connection for SS pipe, not any other MM connections such as voice call, SMS etc.

EGPRS LA

Setting

 Range: 1 | ON | 0 | OFF

Query

Range: 0 | 1

*RST Setting

 0
Requirements GSM/GPRS/ EGPRS LA

Revision: F.00.27 and above

Programming Example

OUTPUT 714;"CALL:SSERvice:PIPE:MMConnect 1"
! Enable the MM Connection.

CALL:SSERvice:PIPE[:DATA]:RX?

Function

 GSM TA This command is not applicable to the GSM Test Application.

GPRS TA

 This command is not applicable to the GPRS Test Application.

EGPRS TA

 This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

This command queries the raw data from the last supplementary service message received from the mobile station.

Note that the raw data is sent as a character string with two hexadecimal characters required to define each binary byte.

EGPRS LA

Setting

 Range: 0 to 498 hexadecimal characters.

Query

Range: 0 to 498 hexadecimal characters.

*RST Setting

`' (Empty String)
Requirements GSM/GPRS/ EGPRS LA

Revision: F.00.27 and above

Programming Example

OUTPUT 714;"CALL:SSERvice:PIPE:RX?"
! Queries the last SS message received.

CALL:SSERvice:PIPE[:DATA]:RX:AVAilable?

Function

 GSM TA This command is not applicable to the GSM Test Application.

GPRS TA

 This command is not applicable to the GPRS Test Application.

EGPRS TA

 This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

This command queries if unread supplementary service Rx data are available.

  • The Rx data available flag is set to 1 when any data is received via the SS pipe and is available for reading via the GPIB command: CALL:SSERvice:PIPE[:DATA]:RX? .
  • The Rx data available flag is reset to 0 when the data is read via the GPIB command: CALL:SSERvice:PIPE[:DATA]:RX? .

EGPRS LA

Setting

 Range: 0 | 1

Query

Range: 0 | 1

*RST Setting

0
Requirements GSM/GPRS/ EGPRS LA

Revision: F.00.27 and above

Programming Example

OUTPUT 714;"CALL:SSERvice:PIPE:RX:AVAilable?"
! Queries if unread SS Rx data are available.

CALL:SSERvice:PIPE:TIMeout

Function

 GSM TA This command is not applicable to the GSM Test Application.

GPRS TA

 This command is not applicable to the GPRS Test Application.

EGPRS TA

 This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

This command sets/queries the maximum time to wait for any data sending/receiving from the mobile on the SS pipe or RRLP pipe. The MM connection will be closed when the timer is timeout.

Setting this parameter to zero disables the timeout timer. The MM connection started by the SS session will stay up indefinitely unless terminated explicitly by the user or mobile.

EGPRS LA

Setting

 Range: 0 to 140 seconds

Query

Range: 0 to 140 seconds

*RST Setting

10
Requirements GSM/GPRS/ EGPRS LA

Revision: F.00.27 and above

Programming Example

OUTPUT 714;"CALL:SSERvice:PIPE:TIMeout 30"
! Sets SS pipe inactivity timer to 30s.

CALL:SSERvice:PIPE[:DATA]:TX

Function

 GSM TA This command is not applicable to the GSM Test Application.

GPRS TA

 This command is not applicable to the GPRS Test Application.

EGPRS TA

 This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

This command sets/queries the raw data to be sent using the SS pipe. The Tx pipe data must be a valid L3 message, error message 232 will be reported if the main elements of the L3 message are not valid.

The Tx pipe data do not include the content of the FACILITY IE.

Note that the raw data is sent as a character string with two hexadecimal characters required to define each binary byte.

EGPRS LA

Setting

 Range: 0 to 498 hexadecimal characters.

Query

Range: 0 to 498 hexadecimal characters.

*RST Setting

`' (Empty String)
Requirements GSM/GPRS/ EGPRS LA

Revision: F.00.27 and above

Programming Example

OUTPUT 714;"CALL:SSERvice:PIPE:TX `a5fe'"
! Sets the Tx pipe data.

CALL:SSERvice:PIPE[:DATA]:TX:SEND

Function

 GSM TA This command is not applicable to the GSM Test Application.

GPRS TA

 This command is not applicable to the GPRS Test Application.

EGPRS TA

 This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

This command sends the currently set Tx data to the mobile station via the SS pipe.

EGPRS LA
Requirements GSM/GPRS/ EGPRS LA

Revision: F.00.27 and above

Programming Example

OUTPUT 714;"CALL:SSERvice:PIPE:TX:SEND"
! Sends the Tx data to the mobile station via the SS pipe.


CALL:T308

CALL:T308

GPIB Command Conventions

  • CALL[:CELL]:T308

CALL[:CELL]:T308

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

Sets the Call Release Timer value. See Configurable Timers .
EGPRS LA
Setting

Range: 1 to 60000 ms

Query

Range: 1 to 60000 ms

*RST setting

 1000

Requirements

 GSM/GPRS/ EGPRS LA

Revision: F.00.27 and above

Programming Example:

OUTPUT 714;"CALL:CELL:T308 500"
! Set the expire time of T308 to 500ms.


FETCh:SFERate

FETCh:SFERate

GPIB Command Conventions

  • FETCh:SFERate[:ALL]?
  • FETCh:SFERate:COUNt?
  • FETCh:SFERate:ICOunt?
  • FETCh:SFERate:INTegrity?
  • FETCh:SFERate:RATio?
  • FETCh:SFERate:SAMPles?

FETCh:SFERate[:ALL]?

Function

GSM/GPRS LA

This query returns the Repeated SACCH Frame Error Rate measurement results. The integrity indicator, number of samples counted, frame erasure ratio, and frame erasure count are returned.
EGPRS LA
GSM TA

This command is not applicable to the GSM Test Application.

GPRS TA

 This command is not applicable to the GPRS Test Application.

EGPRS TA

 This command is not applicable to the EGPRS Test Application.

Query

Integrity indicator:

  • Range: See Integrity Indicator .
  • Resolution: 1

Samples

  • Range: 0 to 999999 and 9.91E+37 (NAN)
  • Resolution: 1

Frame erasure ratio

  • Range: 0 to 100% and 9.91E+37 (NAN)
  • Resolution: 0.001

Frame erasure count

  • Range: 0 to 999999 and 9.91E+37 (NAN)
  • Resolution: 1
Requirements GSM/GPRS/ EGPRS LA

Revision: F.00.37 and above

FETCh:SFERate:COUNt?

Function | GSM/GPRS LA | This query returns the frame erasure count, or the number of retransmissions made.
 | EGPRS LA
 | GSM TA | This command is not applicable to the GSM Test Application.
 | GPRS TA | This command is not applicable to the GPRS Test Application.
 | EGPRS TA | This command is not applicable to the EGPRS Test Application.
Query |  | Range: 0 to 999999 and 9.91 E+37 (NAN) Resolution: 1
Requirements | GSM/GPRS/ EGPRS LA | Revision: F.00.37 and above

FETCh:SFERate:ICOunt?

Function | GSM/GPRS LA | Queries the intermediate count (measurement progress report) of samples tested.
 | EGPRS LA
 | GSM TA | This command is not applicable to the GSM Test Application.
 | GPRS TA | This command is not applicable to the GPRS Test Application.
 | EGPRS TA | This command is not applicable to the EGPRS Test Application.
Query |  | Range: 0 to 999999 and 9.91 E+37 (NAN)
Requirements | GSM/GPRS/ EGPRS LA | Revision: F.00.37 and above

FETCh:SFERate:INTegrity?

Function | GSM/GPRS LA | This query returns the integrity indicator value for the last Repeated SACCH Frame Error Rate measurement performed. Zero indicates a normal result. See Integrity Indicator for descriptions of non-zero integrity indicators.
 | EGPRS LA
 | GSM TA | This command is not applicable to the GSM Test Application.
 | GPRS TA | This command is not applicable to the GPRS Test Application.
 | EGPRS TA | This command is not applicable to the EGPRS Test Application.
Query |  | Range: See Integrity Indicator . Resolution: 1
Requirements | GSM/GPRS/ EGPRS LA | Revision: F.00.37 and above

FETCh:SFERate:RATio?

Function | GSM/GPRS LA | This query returns the frame erasure rate which is the ratio of frames erased to frames sampled.
 | EGPRS LA
 | GSM TA | This command is not applicable to the GSM Test Application.
 | GPRS TA | This command is not applicable to the GPRS Test Application.
 | EGPRS TA | This command is not applicable to the EGPRS Test Application.
Query |  | Range: 0 to 100% and 9.91 E+37 (NAN) Resolution: 0.001
Requirements | GSM/GPRS/ EGPRS LA | Revision: F.00.37 and above

FETCh:SFERate:SAMPles?

Function | GSM/GPRS LA | This query returns the number of samples counted.
 | EGPRS LA
 | GSM TA | This command is not applicable to the GSM Test Application.
 | GPRS TA | This command is not applicable to the GPRS Test Application.
 | EGPRS TA | This command is not applicable to the EGPRS Test Application.
Query |  | Range: 0 to 999999 and 9.91 E+37 (NAN) Resolution: 1
Requirements | GSM/GPRS/ EGPRS LA | Revision: F.00.37 and above


SETup:SFERate

SETup:SFERate

GPIB Command Conventions

  • SETup:SFERate:CONTinuous
  • SETup:SFERate:FRINterval
  • SETup:SFERate:SAMPles
  • SETup:SFERate:TIMeout[:STIMe]
  • SETup:SFERate:TIMeout:TIME
  • SETup:SFERate:TIMeout:STATe

SETup:SFERate:CONTinuous

Function

GSM/GPRS LA

This command sets/queries the trigger state to single trigger mode or continuous trigger mode for the Repeated SACCH Frame Erasure Rate (FER) measurement.
EGPRS LA
GSM TA

This command is not applicable to the GSM Test Application.

GPRS TA

 This command is not applicable to the GPRS Test Application.

EGPRS TA

 This command is not applicable to the EGPRS Test Application.
Setting

Range: 0 | OFF | 1 | ON

Query

Range: 0 | 1
*RST Setting

0 | OFF
Requirements GSM/GPRS/ EGPRS LA

Revision: F.00.37 and above

Programming Example

OUTPUT 714;"SETup:SFERate:CONTinuous OFF"
! Sets Repeated SACCH FER measurement to single trigger mode.

SETup:SFERate:FRINterval

Function

GSM/GPRS LA

This command sets/queries the minimum interval between testing SACCH frames being sent to the DUT.
EGPRS LA
GSM TA

This command is not applicable to the GSM Test Application.

GPRS TA

 This command is not applicable to the GPRS Test Application.

EGPRS TA

 This command is not applicable to the EGPRS Test Application.
Setting

Range: 1.0s to 10.0s

Query

Range: 1.0 to 10.0
*RST Setting

1.0s
Requirements GSM/GPRS/ EGPRS LA

Revision: F.00.37 and above

Programming Example

OUTPUT 714;"SETup:SFERate:FRINterval 1.1s"
! Sets the minimum interval between testing SACCH frames being sent to the DUT to 1.1s.

SETup:SFERate:SAMPles

Function

GSM/GPRS LA

This command sets/queries the number of samples to be taken by the Repeated SACCH Frame Erasure Error (FER) measurement. Each sample corresponds to a single SACCH block or a SACCH block and its requested repeat blocks.

EGPRS LA
GSM TA

This command is not applicable to the GSM Test Application.

GPRS TA

 This command is not applicable to the GPRS Test Application.

EGPRS TA

 This command is not applicable to the EGPRS Test Application.
Setting

Range: 1 to 999999

Resolution: 1

Query

Range: 1 to 999999

Resolution: 1
*RST Setting

1000
Requirements GSM/GPRS/ EGPRS LA

Revision: F.00.37 and above

Programming Example

OUTPUT 714;"SETup:SFERate:SAMPles 55000"
! Sets the number of samples to measure to 55000.

SETup:SFERate:TIMeout[:STIMe]

Function

GSM/GPRS LA

 This command sets/queries the timeout value in seconds for the Repeated SACCH Frame Erasure Rate (FER) measurements and turns the timeout state to On.
EGPRS LA
GSM TA

This command is not applicable to the GSM Test Application.

GPRS TA

 This command is not applicable to the GPRS Test Application.

EGPRS TA

 This command is not applicable to the EGPRS Test Application.
Setting

Range: 0.1 to 9999.9

Resolution: 0.1

Query

Range: 0.1 to 9999.9

Resolution: 0.1
*RST Setting

2000 seconds
Requirements GSM/GPRS/ EGPRS LA

Revision: F.00.37 and above

Programming Example

OUTPUT 714;"SETup:SFERate:TIMeout:STIMe 1500"
! Sets measurement timeout to 1500 seconds and the state to on.

SETup:SFERate:TIMeout:TIME

Function

GSM/GPRS LA

This command sets/queries the timeout value in seconds for the Repeated SACCH Frame Erasure Rate (FER) measurements.

EGPRS LA
GSM TA

This command is not applicable to the GSM Test Application.

GPRS TA

 This command is not applicable to the GPRS Test Application.

EGPRS TA

 This command is not applicable to the EGPRS Test Application.
Setting

Range: 0.1 to 9999.9

Resolution: 0.1

Query

Range: 0.1 to 9999.9Resolution: 0.1
*RST Setting

2000 seconds
Requirements GSM/GPRS/ EGPRS LA

Revision: F.00.37 and above

Programming Example

OUTPUT 714;"SETup:SFERate:TIMeout:TIME 1500"
! Sets measurement timeout to 1500 seconds.

SETup:SFERate:TIMeout:STATe

Function

GSM/GPRS LA

This command sets/queries the timeout state for the Repeated SACCH Frame Erasure Rate (FER) measurements.
EGPRS LA
GSM TA

This command is not applicable to the GSM Test Application.

GPRS TA

 This command is not applicable to the GPRS Test Application.

EGPRS TA

 This command is not applicable to the EGPRS Test Application.
Setting

Range: 0 | OFF | 1 | ON

Query

Range: 0 | 1
*RST Setting

0 | OFF
Requirements GSM/GPRS/ EGPRS LA

Revision: F.00.37 and above

Programming Example

OUTPUT 714;"SETup:SFERate:TIMeout:STATe ON"
! Sets the timeout state to on.


CALL:SMService

CALL:SMService

  • CALL:SMService:CBRoadcast:MESSage[<n>]:CDATa
  • CALL:SMService:CBRoadcast:MESSage[<n>]:CODE
  • CALL:SMService:CBRoadcast:MESSage[<n>]:CONTent
  • CALL:SMService:CBRoadcast:MESSage[<n>]:CTEXt
  • CALL:SMService:CBRoadcast:MESSage[<n>]:DCSCheme[:SPECify]
  • CALL:SMService:CBRoadcast:MESSage[<n>]:DCSCheme:LANGuage
  • CALL:SMService:CBRoadcast:MESSage[<n>]:DCSCheme:VALue
  • CALL:SMService:CBRoadcast:MESSage[<n>]:GSCope
  • CALL:SMService:CBRoadcast:MESSage[<n>]:IDENtifier
  • CALL:SMService:CBRoadcast:MESSage[<n>]:LANGuage
  • CALL:SMService:CBRoadcast:MESSage[<n>]:STATe
  • CALL:SMService:CBRoadcast:MESSage[<n>]:TEXT
  • CALL:SMService:CBRoadcast:MESSage[<n>]:UPDate
  • CALL:SMService:CBRoadcast:REPetition[:SEConds]
  • CALL:SMService:CBRoadcast:REPetition:UNITs
  • CALL:SMService:CBRoadcast:STARt
  • CALL:SMService:CBRoadcast:STOP
  • CALL:SMService:CBRoadcast:TEXT:CUSTom
  • CALL:SMService:CBRoadcast:TXT1?
  • CALL:SMService:CBRoadcast:TXT2?

  • CALL:SMService:HTTProtocol:INPut
  • CALL:SMService:HTTProtocol:OUTPut

  • CALL:SMService:PTPoint[:MTERminated]:CONTents
  • CALL:SMService:PTPoint[:MTERminated]:DATA:CUSTom
  • CALL:SMService:PTPoint[:MTERminated][:MESSage]:DCSCheme
  • CALL:SMService:PTPoint[:MTERminated][:MESSage]:FCAuse
  • CALL:SMService:PTPoint[:MTERminated][:MESSage]:MMTSend
  • CALL:SMService:PTPoint[:MTERminated][:MESSage]:MREFerence
  • CALL:SMService:PTPoint[:MTERminated][:MESSage]:OADDress
  • CALL:SMService:PTPoint[:MTERminated][:MESSage]:OADDress:HEXadecimal
  • CALL:SMService:PTPoint[:MTERminated][:MESSage]:OADDress:PLAN
  • CALL:SMService:PTPoint[:MTERminated][:MESSage]:OADDress:TYPE
  • CALL:SMService:PTPoint[:MTERminated][:MESSage]:PIDentifier
  • CALL:SMService:PTPoint[:MTERminated][:MESSage]:PINDicator
  • CALL:SMService:PTPoint[:MTERminated][:MESSage]:RADDress
  • CALL:SMService:PTPoint[:MTERminated][:MESSage]:RADDress:HEXadecimal
  • CALL:SMService:PTPoint[:MTERminated][:MESSage]:RADDress:PLAN
  • CALL:SMService:PTPoint[:MTERminated][:MESSage]:RADDress:TYPE
  • CALL:SMService:PTPoint[:MTERminated][:MESSage]:RPATh
  • CALL:SMService:PTPoint[:MTERminated][:MESSage]:SADDress
  • CALL:SMService:PTPoint[:MTERminated][:MESSage]:SADDress:HEXadecimal
  • CALL:SMService:PTPoint[:MTERminated][:MESSage]:SADDress:PLAN
  • CALL:SMService:PTPoint[:MTERminated][:MESSage]:SADDress:TYPE
  • CALL:SMService:PTPoint[:MTERminated][:MESSage]:SREPort
  • CALL:SMService:PTPoint[:MTERminated][:MESSage]:STATus
  • CALL:SMService:PTPoint[:MTERminated][:MESSage]:UDHind
  • CALL:SMService:PTPoint[:MTERminated]:RCAuse?
  • CALL:SMService:PTPoint[:MTERminated]:SEND[:IMMediate]
  • CALL:SMService:PTPoint[:MTERminated]:SEND:STATe?
  • CALL:SMService:PTPoint[:MTERminated]:TEXT
  • CALL:SMService:PTPoint[:MTERminated]:TEXT:CUSTom
  • CALL:SMService:PTPoint[:MTERminated]:TRANsport
  • CALL:SMService:PTPoint[:MTERminated][:MESSage]:TYPE
  • CALL:SMService:PTPoint[:MTERminated][:MESSage]:TYPE:SUBReport:RPTYpe
  • CALL:SMService:PTPoint[:MTERminated]:TXT1?
  • CALL:SMService:PTPoint[:MTERminated]:TXT2?
  • CALL:SMService:PTPoint:MORiginated:LOOPback
  • CALL:SMService:PTPoint:MORiginated[:MESSage]:CLEar[:ALL]
  • CALL:SMService:PTPoint:MORiginated[:MESSage]:CONTents?
  • CALL:SMService:PTPoint:MORiginated[:MESSage]:COUNt?
  • CALL:SMService:PTPoint:MORiginated[:MESSage]:DCSCheme?
  • CALL:SMService:PTPoint:MORiginated[:MESSage]:DESTination?
  • CALL:SMService:PTPoint:MORiginated[:MESSage]:FORMat?
  • CALL:SMService:PTPoint:MORiginated[:MESSage]:LENGth?
  • CALL:SMService:PTPoint:MORiginated[:MESSage]:MREFerence?
  • CALL:SMService:PTPoint:MORiginated[:MESSage]:PIDentifier?
  • CALL:SMService:PTPoint:MORiginated[:MESSage]:SRRequest?
  • CALL:SMService:PTPoint:MORiginated[:MESSage]:TEXT?
  • CALL:SMService:PTPoint:MORiginated[:MESSage]:UDHind?
  • CALL:SMService:PTPoint:MORiginated[:MESSage]:UDHLength?
  • CALL:SMService:PTPoint:MORiginated:QUEue[:STATe]
  • CALL:SMService:PTPoint:MORiginated:QUEue:COUNt?
  • CALL:SMService:PTPoint:MORiginated:QUEue:NEXT
  • CALL:SMService:PTPoint:MORiginated:REPort:MODE:STATus
  • CALL:SMService:PTPoint:MORiginated:REPort:MODE:SUBMit
  • CALL:SMService:PTPoint:MORiginated[:MESSage]:TRANsport?

GPIB Command Conventions

CALL:SMService:CBRoadcast:MESSage[<n>]:CDATa

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

This command sets/queries the User Defined Text Message (Custom Data) , which is a custom binary data string, for message n, where n can be 1,2,or 3, that can be included in the cell broadcast message content.

An even number of characters must be used when setting the custom data string with this command.
EGPRS LA

Setting

 Range: 0 to 2460 hexadecimal characters.

Query

 Range: 0 to 2460 hexadecimal character

*RST setting

`' (Empty String)
Requirements

GSM/GPRS/ EGPRS TA

 Revision: A.09
and above with required feature license.
GSM/GPRS/ EGPRS LA

Revision: E.00.05 and above

Programming Example

OUTPUT 714;"CALL:SMService:CBRoadcast:MESSage1:CDATa `a5fe'"
! Sets the custom binary data string.

CALL:SMService:CBRoadcast:MESSage[<n>]:CODE

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

This sets the message code for Cell Broadcast Message n, where n can be 1, 2, or 3. See Message Code for more information.
EGPRS LA

Setting

 Range: 0 to 1023

Query

 Range: 0 to 1023

*RST setting

0
Requirements

GSM/GPRS/ EGPRS TA

 Revision: A.09 and above with required feature license.
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:SMService:CBRoadcast:MESSage1:CODE 1000"
! Sets the Cell Broadcast Message 1 to have 1000 as the message code.

CALL:SMService:CBRoadcast:MESSage[<n>]:CONTent

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

This command sets/queries the type of content that is to be included in each message (see, Cell Broadcast Messages -Content ). The selected content can be one of two predefined text message strings, TXT1 or TXT2 (see CALL:SMService:CBRoadcast:TXT1? or CALL:SMService:CBRoadcast:TXT2? ), a custom text string (see CALL:SMService:CBRoadcast:MESSage[<n>]:CTEXt ), or a custom binary data (see CALL:SMService:CBRoadcast:MESSage[<n>]:CDATa ).

This parameter is automatically set to CTEXt if TEXT is included in the HTTP request URL. Similarly, this parameter is automatically set to CDATA if DATA is included in the HTTP request URL for message n, where n can be 1, 2, or 3. See Request URL Parameters .
EGPRS LA

Setting

 Range: TXT1|TXT2|CTEXt|CDATa

Query

 Range: TXT1|TXT2|CTEX|CDAT

*RST setting

 TXT1 (for message 1 and 3) , TXT2 (for message 2)
Requirements

GSM/GPRS/ EGPRS TA

 Revision: A.09 and above with required feature license.
GSM/GPRS/ EGPRS LA

Revision: E.00.05 and above

Programming Example

OUTPUT 714;"CALL:SMService:CBRoadcast:MESSage1:TXT1"
! Sets the Cell Broadcast Message 1 to use TXT1.

CALL:SMService:CBRoadcast:MESSage[<n>]:CTEXt

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

This command sets/queries the User Defined Text Message (Custom Text) string that can be included in the cell broadcast message n, where n can be 1, 2, or 3.
EGPRS LA

Setting

 Range: 0 to 1395 ASCII characters

Query

 Range: 0 to 1395 characters

*RST setting

 "Enter your text here"
Requirements

GSM/GPRS/ EGPRS TA

 Revision: A.09 and above with required feature license.
GSM/GPRS/ EGPRS LA

Revision: E.00.05 and above

Programming Example

OUTPUT 714;"CALL:SMService:CBRoadcast:MESSage1:CTEXt `Hello. How are you today?'"
! Sets the custom text string for message 1.

CALL:SMService:CBRoadcast:MESSage[<n>]:DCSCheme[:SPECify]

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

This command sets/queries the method used to set the 8-bit CBS Data Coding Scheme for message n, where n can be 1, 2, or 3. The two methods that can be used to specify the data coding scheme are:

  1. Language

    See CALL:SMService:CBRoadcast:MESSage[<n>]:DCSCheme:LANGuage .

  2. ValueSee CALL:SMService:CBRoadcast:MESSage[<n>]:DCSCheme:VALue .

This parameter is automatically set to Value if the following Request URL Parameters are included in the HTTP request URL: DCS or DCSHEX.
EGPRS LA

Setting

 Range: LANGuage|VALue

Query

 Range: LANG|VAL

*RST setting

 LANG
Requirements

GSM/GPRS/ EGPRS TA

 Revision: A.09 and above with required feature license.
GSM/GPRS/ EGPRS LA

Revision: E.00.05 and above

Programming Example

OUTPUT 714;"CALL:SMService:CBRoadcast:MESSage1:DCSCheme LANG"
! Allows the test set to configure the data coding scheme for message 1
! according to a specified language.

CALL:SMService:CBRoadcast:MESSage[<n>]:DCSCheme:LANGuage

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

This command sets/queries the language for the cell broadcast text message for message n, where n can be 1, 2, or 3. The specified language is used to set the 8-bit CBS Data Coding Scheme. This method is only appropriate for configuring text messages. See Data Coding Scheme Language for more information.

The 8-bit CBS Data Coding Scheme Specification must be set to LANGuage for this command to apply. The command to specify the method used to set the 8-bit CBS Data Coding Scheme is CALL:SMService:CBRoadcast:MESSage[<n>]:DCSCheme[:SPECify] .
EGPRS LA

Setting

 Range: See Language values .

Query

 Range: See Language values .

*RST setting

 ENGLish
Requirements

GSM/GPRS/ EGPRS TA

 Revision: A.09 and above with required feature license.
GSM/GPRS/ EGPRS LA

Revision: E.00.05 and above

Programming Example

OUTPUT 714;"CALL:SMService:CBRoadcast:MESSage1:DCSCheme:LANGuage ENGLish"
! Sets the language to English for the Cell Broadcast Message 1.

CALL:SMService:CBRoadcast:MESSage[<n>]:DCSCheme:VALue

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

This command sets/queries the value used to set the 8-bit CBS Data Coding Scheme. See Data Coding Scheme Value for more information.

The 8-bit CBS Data Coding Scheme Specification must be set to VALue for this command to apply. The command to specify the method used to set the 8-bit CBS Data Coding Scheme is CALL:SMService:CBRoadcast:MESSage[<n>]:DCSCheme[:SPECify] .
EGPRS LA

Setting

Range: 0 to 255

Resolution: 1

Query

Range: 0 to 255

Resolution: 1

*RST setting

 1
Requirements

GSM/GPRS/ EGPRS TA

 Revision: A.09 and above with required feature license.
GSM/GPRS/ EGPRS LA

Revision: E.00.05 and above

Programming Example

OUTPUT 714;"CALL:SMService:CBRoadcast:MESSage1:DCSCheme:VALue 1"
! Sets the value of the CBS Data Coding Scheme for the Cell Broadcast Message 1.

CALL:SMService:CBRoadcast:MESSage[<n>]:GSCope

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

This command sets/queries the 2-bit Geographical Scope (GS) for message n, where n can be 1, 2, or 3.
EGPRS LA

Setting

 Range: CIMMediate|PNORmal|LNORmal|CNORmal

Query

 Range: CIMM|PNOR|LNOR|CNOR

*RST setting

CNOR
Requirements

GSM/GPRS/ EGPRS TA

 Revision: A.09 and above with required feature license.
GSM/GPRS/ EGPRS LA

Revision: E.00.05 and above

Programming Example

OUTPUT 714;"CALL:SMService:CBRoadcast:MESSage1:GSCope CIMMediate"
! Sets the geographical scope for Cell Broadcast Message 1 regard similar messages
! in other cells as new and to continuously display the message.

CALL:SMService:CBRoadcast:MESSage[<n>]:IDENtifier

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

This sets the message identifier for Cell Broadcast Message n (where n can be 1,2, or 3). See Message Identifier for more information.
EGPRS LA

Setting

 Range: 0 to 65534

Query

 Range: 0 to 65534

*RST setting

0
Requirements

GSM/GPRS/ EGPRS TA

 Revision: A.09 and above with required feature license.
GSM/GPRS/ EGPRS LA

Revision: D.01 and above

Programming Example

OUTPUT 714;"CALL:SMService:CBRoadcast:MESSage1:IDENtifier 1500"
! Sets the message identifier for Cell Broadcast Message 1 to 1500.

CALL:SMService:CBRoadcast:MESSage[<n>]:LANGuage

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

This command is obsolete. Please use the command CALL:SMService:CBRoadcast:MESSage[<n>]:DCSCheme:LANGuage instead.

This sets the language for Cell Broadcast Message n, where n can be 1, 2, or 3.
EGPRS LA

Setting

 Fixed string (see table below)

Query

 Fixed string

*RST setting

 ENGLish
Requirements

GSM/GPRS/ EGPRS TA

 Revision: A.09 and above with required feature license.
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:SMService:CBRoadcast:MESSage1:LANGuage ENGLish"
! Sets the language to English for the Cell Broadcast Message 1.

Language values
Parameter Form | Query Value
GERMan | GERM
ENGLish | ENGL
ITALian | ITAL
FRENch | FREN
SPANish | SPAN
DUTCh | DUTC
SWEDish | SWED
DANish | DAN
PORTuguese | PORT
FINNish | FINN
NORWegian | NORW
GREek | GRE
TURKish | TURK
HUNGarian | HUNG
POLish | POL
UNSPecified | UNSP

CALL:SMService:CBRoadcast:MESSage[<n>]:STATe

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

Enables Cell Broadcast Message n, where n is 1, 2 or 3. Cell Broadcast service must be started for a message to be sent. See CALL:SMService:CBRoadcast:STARt .
EGPRS LA

Setting

 0|OFF|1|ON

Query

 0||1

*RST setting

Message 1 is ON; Messages 2 and 3 are OFF
Requirements

GSM/GPRS/ EGPRS TA

 Revision: A.09 and above with required feature license.
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:SMService:CBRoadcast:MESSage2:STATe ON"
! Sets the state for the Cell Broadcast Message 2 to ON, which is necessary
! to allow a message to be sent

CALL:SMService:CBRoadcast:MESSage[<n>]:TEXT

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

THIS COMMAND IS OBSOLETE. Please use the command CALL:SMService:CBRoadcast:MESSage[<n>]:CONTent instead.

This command selects the text to be transmitted for Cell Broadcast Message n, where n is 1, 2 or 3.
EGPRS LA

Setting

 TXT1|TXT2|CUSTom

Query

 TXT1|TXT2|CUST

*RST setting

Message 2 is TXT2; Messages 1and 3 are TXT1
Requirements

GSM/GPRS/ EGPRS TA

 Revision: A.09 and above with required feature license.
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:SMService:CBRoadcast:MESSage1:TEXT TXT2"
! Sets the Cell Broadcast Message 1 to contain the predefined TXT2 text.

CALL:SMService:CBRoadcast:MESSage[<n>]:UPDate

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

This sets the Update Number for Cell Broadcast Message n, where n can be 1, 2, or 3.
EGPRS LA

Setting

 Range: 0 to 15

Query

 Range: 0 to 15

*RST setting

0
Requirements

GSM/GPRS/ EGPRS TA

 Revision: A.09 and above with required feature license.
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:SMService:CBRoadcast:MESSage1:UPDate 10"
! Sets the Message Update number to 10 for the Cell Broadcast Message 1.

CALL:SMService:CBRoadcast:REPetition[:SEConds]

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

This command sets/queries the Repetition Period for sending the cell broadcast message.

The repetition period can also be set with the command CALL:SMService:CBRoadcast:REPetition:UNITs . Use this command if you wish to set a more precise repetition period.

EGPRS LA

Setting

 Range: 1 to 1800

Query

 Range: 1 to 1800

*RST setting

30
Requirements

GSM/GPRS/ EGPRS TA

 Revision: A.09 and above with required feature license.
GSM/GPRS/ EGPRS LA

Revision: E.00.05 and above

Programming Example

OUTPUT 714;"CALL:SMService:CBRoadcast:REPetition 30"
!Sets the Cell Broadcast Service repetiion period to 30 seconds.

CALL:SMService:CBRoadcast:REPetition:UNITs

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

This command sets/queries the Repetition Period for sending the cell broadcast message in terms to units of the minimum interval period.

You can also set the repetition period with the command CALL:SMService:CBRoadcast:REPetition[:SEConds] .
EGPRS LA

Setting

 Range: 1 to 1024

Query

 Range: 1 to 1024

*RST setting

16
Requirements

GSM/GPRS/ EGPRS TA

 Revision: A.09 and above with required feature license.
GSM/GPRS/ EGPRS LA

Revision: E.00.05 and above

Programming Example

OUTPUT 714;"CALL:SMService:CBRoadcast:REPetition:UNITS 3"
! Sets the Cell Broadcast Service repetiion period to 5.649 seconds (since 1.883 * 3 = 5.649).

CALL:SMService:CBRoadcast:STARt

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

This command initiates the Cell Broadcast Service, which causes the periodic transmission of all messages enabled through the command CALL:SMService:CBRoadcast:MESSage[<n>]:STATe .

This command is ignored if Cell Broadcast Service has already been started.
EGPRS LA
Requirements

GSM/GPRS/ EGPRS TA

 Revision: A.09 and above with required feature license.
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:SMService:CBRoadcast:STARt"
! Starts the Cell Broadcast Service.

CALL:SMService:CBRoadcast:STOP

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

Stops the Cell Broadcast Service.

This command is ignored if Cell Broadcast Service has already been ended.
EGPRS LA
Requirements

GSM/GPRS/ EGPRS TA

 Revision: A.09 and above with required feature license.
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714; "CALL:SMService:CBRoadcast:STOP"
! Stops the Cell Broadcast Service.

CALL:SMService:CBRoadcast:TEXT:CUSTom

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA THIS COMMAND IS OBSOLETE. Please use CALL:SMService:CBRoadcast:MESSage[<n>]:CTEXt instead.

This sets the string of the custom text which can be sent with any of the Cell Broadcast Messages.
EGPRS LA

Setting

 String: 7 bit ACSII characters up to 93 characters in length in quotes.

Query

 String: 7 bit ACSII characters up to 93 characters in length.

*RST Setting

 "Enter your text here"
Requirements

GSM/GPRS/ EGPRS TA

 Revision: A.09 and above with required feature license.
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714; "CALL:SMService:CBRoadcast:TEXT:CUSTom "Hello World" "
! Sets `Hello World' as a custom text which can be sent with any of the Cell Broadcast Messages.

CALL:SMService:CBRoadcast:TXT1?

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

This queries the Predefined text message 1 (Text1) .
EGPRS LA

Query

 Returns a string.
Requirements

GSM/GPRS/ EGPRS TA

 Revision: A.09 and above with required feature license.
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:SMService:CBRoadcast:TXT1?"
! Queries for the fixed Text Message 1.

CALL:SMService:CBRoadcast:TXT2?

Function | GSM TA | This command is not applicable to the GSM Test Application.
 | GPRS TA | This command is not applicable to the GPRS Test Application.
 | EGPRS TA | This command is not applicable to the EGPRS Test Application.
 | GSM/GPRS LA | This queries the Predefined text message 2 (Text2) .
 | EGPRS LA
Query |  | Returns a string.
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.09 and above with required feature license.
 | GSM/GPRS/ EGPRS LA | Revision: C.01 and above Revision E.00.05 modified the predefined text message 2.
Programming Example OUTPUT 714;"CALL:SMService:CBRoadcast:TXT2?" ! Queries for the fixed Text Message 2.

CALL:SMService:HTTProtocol:INPut

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

Enables or disables the HTTP input interface for mobile terminated SMS and Cell Broadcast SMS.
EGPRS LA

Setting

 0|OFF|1|ON

Query

 0||1

*RST setting

OFF
Requirements

GSM/GPRS/ EGPRS TA

 Revision: A.09 and above with required feature license.
GSM/GPRS/ EGPRS LA

Revision: D.01 and above

Programming Example

OUTPUT 714;"CALL:SMService:HTTProtocol:INPut ON"
! Enables the HTTP input interface for mobile terminated SMS

CALL:SMService:HTTProtocol:OUTPut

Function | GSM TA | This command is not applicable to the GSM Test Application.
 | GPRS TA | This command is not applicable to the GPRS Test Application.
 | EGPRS TA | This command is not applicable to the EGPRS Test Application.
 | GSM/GPRS LA | Enables or disables the HTTP output interface for mobile originated SMS.
 | EGPRS LA
Setting |  | 0|OFF|1|ON
Query |  | 0||1
*RST setting |  | OFF
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.09 and above with required feature license.
 | GSM/GPRS/ EGPRS LA | Revision: D.01 and above
Programming Example OUTPUT 714;"CALL:SMService:HTTProtocol:OUTPut 1" ! Enables the HTTP output interface for mobile originated SMS.

CALL:SMService:PTPoint[:MTERminated]:CONTents

Function | GSM TA | This command is not applicable to the GSM Test Application.
 | GPRS TA | This command is not applicable to the GPRS Test Application.
 | EGPRS TA | This command is not applicable to the EGPRS Test Application.
 | GSM/GPRS LA | This selects the content to be sent in mobile terminated SMS messages.
 | EGPRS LA
Setting |  | Range: TXT1 | TXT2 | CTEXt | CDATa
Query |  | Range: TXT1 | TXT2 | CTEX | CDAT
*RST Setting |  | TXT1
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.09 and above with required feature license.
 | GSM/GPRS/ EGPRS LA | Revision: D.01 and above
Programming Example OUTPUT 714;"CALL:SMService:PTPoint:CONTents TXT1" ! Selects TXT1 to be be sent in subsequent mobile terminated SMS messages.

CALL:SMService:PTPoint[:MTERminated]:DATA:CUSTom

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

Sets/queries the data to be sent in mobile terminated SMS messages. SMS data is formatted in octets, therefore there must be and even number of characters in the string.

This data is only sent to the mobile station if the CALL:SMService:PTPoint[:MTERminated]:CONTents is set to CDATA.
EGPRS LA

Setting

Range: 0 to 280 ASCII formatted hexadecimal characters

Query

Range: 0 to 280 ASCII formatted hexadecimal characters

*RST Setting

"00"
Requirements

GSM/GPRS/ EGPRS TA

 Revision: A.09 and above with required feature license.
GSM/GPRS/ EGPRS LA

Revision: D.01 and above

Programming Example

OUTPUT 714; "CALL:SMService:PTPoint:DATA:CUSTom `112A'"
! This sets the hex data 112A to be sent in subsequent mobile terminated SMS messages.

CALL:SMService:PTPoint[:MTERminated][:MESSage]:DCSCheme

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

Configures the TP-DCS (Data Coding Scheme) header element, used to identify the coding scheme used in the message contents.
EGPRS LA

Setting

 Range: 0 to 255

Query

 Range: 0 to 255

*RST Setting

0
Requirements

GSM/GPRS/ EGPRS TA

 Revision: A.09 and above with required feature license.
GSM/GPRS/ EGPRS LA

Revision: D.01 and above

Programming Example

OUTPUT 714; "CALL:SMService:PTPoint:DCSCheme 75"
! Configures the TP-DCS (Data Coding Scheme) header element, used to identify the coding scheme
! used in the message contents to 75.

CALL:SMService:PTPoint[:MTERminated][:MESSage]:FCAuse

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

Configures the TP-FCS (Failure Cause) header element, used to identify the reason for a previous SMS-SUBMIT failure. This setting is only relevant to the Submit Report message type. It is not relevant to either Deliver or Status Report message types.
EGPRS LA

Setting

 Range: 0 to 255

Query

 Range: 0 to 255

*RST Setting

255
Requirements

GSM/GPRS/ EGPRS TA

 Revision: A.09 and above with required feature license.
GSM/GPRS/ EGPRS LA

Revision: D.01 and above

Programming Example

OUTPUT 714; "CALL:SMService:PTPoint:FCAuse 20"
! Sets the TP-FCS (Failure Cause) header element, used to identify the reason
! for a previous SMS-SUBMIT failure.

CALL:SMService:PTPoint[:MTERminated][:MESSage]:MMTSend

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

Configures the TP-MMS (More Messages to Send) header element.
EGPRS LA

Setting

 0 | 1
0: More messages to send
1: No more messages

Query

 0 | 1

*RST Setting

1
Requirements

GSM/GPRS/ EGPRS TA

 Revision: A.09 and above with required feature license.
GSM/GPRS/ EGPRS LA

Revision: D.01 and above

Programming Example

OUTPUT 714; "CALL:SMService:PTPoint:MMTSend 1"
! Sets the TP-MMS (More Messages to Send) header element to indicate that there are
! no more messages.

CALL:SMService:PTPoint[:MTERminated][:MESSage]:MREFerence

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

Configures the TP-MR (Message Reference) header element. This element is only included in mobile terminated SMS messages if their message type is SMS-STATUS REPORT. It is used to identify the previously submitted mobile originated SMS to which the status report message relates.
EGPRS LA

Setting

 Range: 0 to 255

Query

 Range: 0 to 255

*RST Setting

0
Requirements

GSM/GPRS/ EGPRS TA

 Revision: A.09 and above with required feature license.
GSM/GPRS/ EGPRS LA

Revision: D.01 and above

Programming Example

OUTPUT 714; "CALL:SMService:PTPoint:MREFerence 100"
! Sets the TP-MR (Message Reference) header element for subsequent mobile terminated SMS messages.

CALL:SMService:PTPoint[:MTERminated][:MESSage]:OADDress

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

Configures the address value portion of the TP-OA (Originating Address) header element, used to identify the sender of the message.
EGPRS LA

Setting

 ASCII string of BCD digits 0-9, the symbols * and #, and the lower case characters a, b, c, and f.
Range: 2 to 20 characters

Query

 ASCII string

*RST Setting

"8960"
Requirements

GSM/GPRS/ EGPRS TA

 Revision: A.09 and above with required feature license.
GSM/GPRS/ EGPRS LA

Revision: D.01 and above.

Revision: G.00.00 adds the value `f'.

Programming Example

OUTPUT 714; "CALL:SMService:PTPoint:OADDress "abc" "
! Changes the address value portion of the TP-OA (Originating Address) header element to abc,
! which is used to identify the sender of the message.

CALL:SMService:PTPoint[:MTERminated][:MESSage]:OADDress:HEXadecimal

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

Configures the address value portion of the TP-OA (Originating Address) header element, used to identify the sender of the message.
EGPRS LA

Setting

 ASCII string of Hex digits 0-9, and the lower case characters a, b, c, d, e, and f.
Range: 2 to 20 characters

Query

 ASCII string

*RST Setting

"8960"
Requirements GSM/GPRS/ EGPRS LA

Revision: G.00.00 and above

Programming Example

OUTPUT 714; "CALL:SMService:PTPoint:OADDress:HEXadecimal "aaff" "
! Changes the address value portion of the TP-OA (Originating Address) header element to aaff,
! which is used to identify the sender of the message.

CALL:SMService:PTPoint[:MTERminated][:MESSage]:OADDress:PLAN

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

Configures the number plan identification bits of the Type of Address field of the TP-OA (Originating Address) header element, used to identify the sender of the message.
EGPRS LA

Setting

 Range: UNKNown | ISDN | DATA | TELex | SCS1 |SCS2 |PRIVate | NATional| ERMes | REServed

Query

 Range: UNKN | ISDN | DATA | TEL | SCS1 | SCS2 | PRIV | NAT | ERM | RES

*RST Setting

UNKN
Requirements

GSM/GPRS/ EGPRS TA

 Revision: A.09 and above with required feature license.
GSM/GPRS/ EGPRS LA

Revision: D.01 and above

Revision: G.00.00 adds the values `SCS1', `SCS2', `ERMes' and `REServed'.

Programming Example

OUTPUT 714; "CALL:SMService:PTPoint:OADDress:PLAN NATional"
! Sets the number plan identification bits of the Type of Address field of the
! TP-OA (Originating Address) header element to National, which is used to identify
! the sender of the message.

CALL:SMService:PTPoint[:MTERminated][:MESSage]:OADDress:TYPE

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

Configures the Type of Number bits of the Type of Address field of the TP-OA (Originating Address) header element, used to identify the sender of the message.
EGPRS LA

Setting

 Range: UNKNown | INATional | NATional | NETWork | SUBScriber | ALPHa | ABBReviated | REServed

Query

 Range: UNKN | INAT | NAT | NETW | SUBS | ALPH | ABBR | RES

*RST Setting

 UNKN
Requirements

GSM/GPRS/ EGPRS TA

 Revision: A.09 and above with required feature license.
GSM/GPRS/ EGPRS LA

Revision: D.01 and above.

Revision: G.00.00 adds the values `ALPHa', `ABBReviated' and `REServedS'.

Programming Example

OUTPUT 714; "CALL:SMService:PTPoint:OADDress:TYPE SUBScriber"
! Sets the Type of Number bits of the Type of Address field of the TP-OA (Originating Address)
! header element to `Suscriber', which is used to identify the sender of the message.

CALL:SMService:PTPoint[:MTERminated][:MESSage]:PIDentifier

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

Configures the TP-PID (Protocol Identifier) header element, used to identify the higher layer protocol used to send the SMS message.
EGPRS LA

Setting

 Range: 0 to 255

Query

 Range: 0 to 255

*RST Setting

0
Requirements

GSM/GPRS/ EGPRS TA

 Revision: A.09 and above with required feature license.
GSM/GPRS/ EGPRS LA

Revision: D.01 and above

Programming Example

OUTPUT 714; "CALL:SMService:PTPoint:MTERminated:MESSage:PIDentifier 100"
! Configures the TP-PID (Protocol Identifier) header element, used to identify the higher
! layer protocol used to send the SMS message.

CALL:SMService:PTPoint[:MTERminated][:MESSage]:PINDicator

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

Configures the TP-PI (Parameter Indicator) header element, used to identify the presence of optional elements within SMS-SUBMIT-REPORT and SMS-STATUS-REPORT messages.
EGPRS LA

Setting

 Range: 0 to 255

Query

 Range: 0 to 255

*RST Setting

7
Requirements

GSM/GPRS/ EGPRS TA

 Revision: A.09 and above with required feature license.
GSM/GPRS/ EGPRS LA

Revision: D.01 and above

Programming Example

OUTPUT 714; "CALL:SMService:PTPoint:PINDicator 5"
! Sets the TP-PI (Parameter Indicator) header element to `5', which is used to identify
! the presence of optional elements within SMS-SUBMIT-REPORT and SMS-STATUS-REPORT messages.

CALL:SMService:PTPoint[:MTERminated][:MESSage]:RADDress

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

Configures the TP-RA (Recipient Address) header element, used to identify the recipient of the previously submitted SMS message.
EGPRS LA

Setting

 ASCII string of BCD digits 0-9, the symbols *, #, and +, and the letters a, b, c, and f.
Range: 2 to 20 characters

Query

 ASCII string

*RST Setting

"8960"
Requirements

GSM/GPRS/ EGPRS TA

 Revision: A.09 and above with required feature license.
GSM/GPRS/ EGPRS LA

Revision: D.01 and above.

Revision: G.00.00 adds the value `f'.

Programming Example

OUTPUT 714; "CALL:SMService:PTPoint:RADDress "abc""
! Configures the TP-RA (Recipient Address) header element, used to identify the recipient of
! the previously submitted SMS messages.

CALL:SMService:PTPoint[:MTERminated][:MESSage]:RADDress:HEXadecimal

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

Configures the TP-RA (Recipient Address) header element, used to identify the recipient of the previously submitted SMS message.
EGPRS LA

Setting

 ASCII string of Hex digits 0-9, the symbols *, #, and +, and the letters a, b, c, and f.
Range: 2 to 20 characters

Query

 ASCII string

*RST Setting

"8960"
Requirements GSM/GPRS/ EGPRS LA

Revision: G.00.00 and above

Programming Example

OUTPUT 714; "CALL:SMService:PTPoint:RADDress:HEXadecimal "abc""
! Configures the TP-RA (Recipient Address) header element, used to identify the recipient of
! the previously submitted SMS messages.

CALL:SMService:PTPoint[:MTERminated][:MESSage]:RADDress:PLAN

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

Configures the number plan identification bits of the Type of Address field of the TP-RA (Recipient Address) header element, used to identify the sender of the message.
EGPRS LA

Setting

 Range: UNKNown | ISDN | DATA | TELex | SCS1 |SCS2 |PRIVate | NATional| ERMes | REServed

Query

 Range: UNKN | ISDN | DATA | TEL | SCS1 | SCS2 | PRIV | NAT | ERM | RES

*RST Setting

UNKN
Requirements GSM/GPRS/ EGPRS LA

Revision: G.00.00 and above

Programming Example

OUTPUT 714; "CALL:SMService:PTPoint:RADDress:PLAN NATional"
! Sets the number plan identification bits of the Type of Address field of the
! TP-RA (Recipient Address) header element to National, which is used to identify
! the sender of the message.

CALL:SMService:PTPoint[:MTERminated][:MESSage]:RADDress:TYPE

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

Configures the Type of Number bits of the Type of Address field of the TP-RA (Recipient Address) header element, used to identify the sender of the message.
EGPRS LA

Setting

 Range: UNKNown | INATional | NATional | NETWork | SUBScriber | ALPHa | ABBReviated | REServed

Query

 Range: UNKN | INAT | NAT | NETW | SUBS | ALPH | ABBR | RES

*RST Setting

 UNKN
Requirements GSM/GPRS/ EGPRS LA

Revision: G.00.00 and above

Programming Example

OUTPUT 714; "CALL:SMService:PTPoint:RADDress:TYPE SUBScriber"
! Sets the Type of Number bits of the Type of Address field of the TP-RA (Recipient Address)
! header element to `Suscriber', which is used to identify the sender of the message.

CALL:SMService:PTPoint[:MTERminated][:MESSage]:RPATh

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

Configures the TP-RP (Reply Path) header element.
EGPRS LA

Setting

 0 | 1
0: A reply path does not exist
1: A reply path exists

Query

 0 | 1

*RST Setting

0
Requirements

GSM/GPRS/ EGPRS TA

 Revision: A.09 and above with required feature license.
GSM/GPRS/ EGPRS LA

Revision: D.01 and above

Programming Example

OUTPUT 714; "CALL:SMService:PTPoint:RPATh 1"
! Configures the TP-RP (Rely Path) header element to indicate the existence of a reply path.

CALL:SMService:PTPoint[:MTERminated][:MESSage]:SADDress

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

Configures the RP Originating Address header element, used to identify the originating SMS Service Center address for MT transfer.
EGPRS LA

Setting

 ASCII string of BCD digits 0-9, the symbols * and #, and the lower case characters a, b, c, and f.
Range: 2 to 20 characters

Query

 ASCII string

*RST Setting

"8960"
Requirements

GSM/GPRS/ EGPRS TA

 Revision: A.09 and above with required feature license.
GSM/GPRS/ EGPRS LA

Revision: F.00.27 and above

Revision: G.00.00 adds the value `f'

Programming Example

OUTPUT 714; "CALL:SMService:PTPoint:SADDress "abc" "
! Changes the SMSC Address to abc.

CALL:SMService:PTPoint[:MTERminated][:MESSage]:SADDress:HEXadecimal

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

Configures the RP Originating Address header element, used to identify the originating SMS Service Center address for MT transfer.
EGPRS LA

Setting

 ASCII string of Hex digits 0-9, the symbols *, #, and +, and the letters a, b, c, and f.
Range: 2 to 20 characters

Query

 ASCII string

*RST Setting

"8960"
Requirements GSM/GPRS/ EGPRS LA

Revision: G.00.00 and above

Programming Example

OUTPUT 714; "CALL:SMService:PTPoint:SADDress:HEXadecimal "abc""
! Changes the SMSC Address to abc.

CALL:SMService:PTPoint[:MTERminated][:MESSage]:SADDress:PLAN

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

Configures the RP Originating Address plan header element, used to identify the plan associated with the SMSC Address.
EGPRS LA

Setting

 Range: UNKNown | ISDN | DATA | TELex | PRIVate | NATional

Query

 Range: UNKN | ISDN | DATA | TEL | PRIV | NAT

*RST Setting

UNKN
Requirements

GSM/GPRS/ EGPRS TA

 Revision: A.09 and above with required feature license.
GSM/GPRS/ EGPRS LA

Revision: F.00.27 and above

Programming Example

OUTPUT 714; "CALL:SMService:PTPoint:SADDress:PLAN NATional"
! Sets the SMSC Address plan to National.

CALL:SMService:PTPoint[:MTERminated][:MESSage]:SADDress:TYPE

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

Configures the RP Originating Address type header element, used to identify the type of the SMSC address setting.
EGPRS LA

Setting

 Range: UNKNown | INATional | NATional | NETWork | SUBScriber

Query

 Range: UNKN | INAT | NAT | NETW | SUBS

*RST Setting

 UNKN
Requirements

GSM/GPRS/ EGPRS TA

 Revision: A.09 and above with required feature license.
GSM/GPRS/ EGPRS LA

Revision: F.00.27 and above

Programming Example

OUTPUT 714; "CALL:SMService:PTPoint:SADDress:TYPE SUBScriber"
! Sets the SMSC Address type to Subscriber.

CALL:SMService:PTPoint[:MTERminated][:MESSage]:SREPort

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

Configures the TP-SRI (Status Report Indication) header element, used to indicate to the mobile station that a status report was requested for this message by the sender.
EGPRS LA

Setting

 0 | 1
0: Status report not requested
1: Status report requested

Query

 0 | 1

*RST Setting

0
Requirements

GSM/GPRS/ EGPRS TA

 Revision: A.09 and above with required feature license.
GSM/GPRS/ EGPRS LA

Revision: D.01 and above

Programming Example

OUTPUT 714; "CALL:SMService:PTPoint:SREPort 1"
! Sets the state of the TP-SRI (Status Report Indication) header element to 1, which is used to
! indicate that the mobile station should send a status report to the test set.

CALL:SMService:PTPoint[:MTERminated][:MESSage]:STATus

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

Configures the TP-ST (Status) header element, used to describe the status of the previously originated mobile SMS.
EGPRS LA

Setting

 Range: 0 to 255

Query

 Range: 0 to 255

*RST Setting

0
Requirements

GSM/GPRS/ EGPRS TA

 Revision: A.09 and above with required feature license.
GSM/GPRS/ EGPRS LA

Revision: D.01 and above

Programming Example

OUTPUT 714; "CALL:SMService:PTPoint:STATus 30"
! Sets the TP-ST (Status) header element to 30, which is used to describe the status of
! the previously originated mobile SMS.

CALL:SMService:PTPoint[:MTERminated][:MESSage]:UDHind

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

Configures the TP-UDHI (User Data Header Indication) header element. The TP-UDHI is used to indicate that the user data sent to the mobile station contains header information. This command is used when binary or concatenated messages are sent, but not with simple text messages.
EGPRS LA

Setting

 0 | 1
0: Content does not include header
1: Content includes header

Query

 0 | 1

*RST Setting

0
Requirements

GSM/GPRS/ EGPRS TA

 Revision: A.09 and above with required feature license.
GSM/GPRS/ EGPRS LA

Revision: D.01 and above

Programming Example

OUTPUT 714; "CALL:SMService:PTPoint:UDHind 1"
! Sets the TP-UDHI (User Data Header Indication) header element to 1, which is used to indicate
! that the user data sent to the mobile station does contain header information.

CALL:SMService:PTPoint[:MTERminated]:RCAuse?

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

Queries the reject cause value when a mobile terminated message is rejected by the mobile station. If the last message sent to the mobile station was not rejected, NAN is returned for the reject cause value. If the last message sent to the mobile station was rejected, this query returns the decimal value of the reject cause.

EGPRS LA

Query

 Range: 0 to 255 (decimal) See Reject Cause
and 9.91 E+37 (NAN)

*RST Setting

9.91 E+37 (NAN)
Requirements

GSM/GPRS/ EGPRS TA

 Revision: A.09 and above with required feature license.
GSM/GPRS/ EGPRS LA

Revision: D.01 and above

Programming Example

OUTPUT 714; "CALL:SMService:PTPoint:RCAuse?"
! Queries the reject cause decimal value when a mobile terminated message is rejected by the
! mobile station. If the last message sent to the mobile was not rejected, the query returns NAN.

CALL:SMService:PTPoint[:MTERminated]:SEND[:IMMediate]

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA Sends a Point to Point SMS message.
EGPRS LA
Requirements

GSM/GPRS/ EGPRS TA

 Revision: A.09 and above with required feature license.
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714; "CALL:SMService:PTPoint:SEND"
! Sends a Point to Point SMS message .

CALL:SMService:PTPoint[:MTERminated]:SEND:STATe?

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

Queries the state of the last message sent to the mobile station.
EGPRS LA

Query

Range: IDLE | SEND | ACK | NACK | REJ | FAIL
IDLE: No message has been sent
SEND: Message send in progress
ACK: Message acknowledged by mobile station
NACK: Message was not acknowledged by mobile station and send timed out
REJ: Message was rejected by the mobile station
FAIL: Message could not be sent

*RST Setting

IDLE
Requirements

GSM/GPRS/ EGPRS TA

 Revision: A.09 and above with required feature license.
GSM/GPRS/ EGPRS LA

Revision: D.01 and above

Programming Example

OUTPUT 714; "CALL:SMService:PTPoint:SEND:STATe?"
! Queries the state of the last message sent to the mobile station. .

CALL:SMService:PTPoint[:MTERminated]:TEXT

NOTE
This command has been replaced by CALL:SMService:PTPoint[:MTERminated]:CONTents .

Function | GSM TA | This command is not applicable to the GSM Test Application.
 | GPRS TA | This command is not applicable to the GPRS Test Application.
 | EGPRS TA | This command is not applicable to the EGPRS Test Application.
 | GSM/GPRS LA | This selects the message to be sent.
 | EGPRS LA
Setting |  | Range: TXT1|TXT2|CUSTom
Query |  | Range: TXT1|TXT2|CUST
*RST Setting |  | TXT1
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.09 and above with required feature license.
 | GSM/GPRS/ EGPRS LA | Revision: C.01 and above

CALL:SMService:PTPoint[:MTERminated]:TEXT:CUSTom

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

This sets the text of the custom message to be sent.
EGPRS LA

Setting

 String: 7 bit ACSII characters up to 160 characters in length in quotes.

Query

 String: 7 bit ACSII characters up to 160 characters in length.

*RST Setting

 "Enter your text here"
Requirements

GSM/GPRS/ EGPRS TA

 Revision: A.09 and above with required feature license.
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example:

OUTPUT 714;"CALL:SMService:PTPoint:TEXT:CUSTom `Hello World'"

CALL:SMService:PTPoint[:MTERminated]:TRANsport

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

Selects the transportation mechanism to be used.
EGPRS LA

Setting

Range: GPRS|GSM

Query

Range: GPRS|GSM

*RST Setting

GPRS
Requirements

GSM/GPRS/ EGPRS TA

 Revision: A.09 and above with required feature license.
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example:

OUTPUT 714;"CALL:SMService:PTPoint:TRANsport GSM"
! Selects GSM to be the transportation mechanism used.

CALL:SMService:PTPoint[:MTERminated][:MESSage]:TYPE

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

Sets the type of SMS message sent from the test set to the mobile station.
EGPRS LA

Setting

 DELiver | SUBReport | STATReport

Query

 DEL | SUBR |STATR

*RST Setting

 DELiver
Requirements

GSM/GPRS/ EGPRS TA

 Revision: A.09 and above with required feature license.
GSM/GPRS/ EGPRS LA

Revision: D.01 and above

Programming Example:

OUTPUT 714;"CALL:SMService:PTPoint:TYPE"
! Sets the type of SMS message sent from the test set to the mobile station to DELiver.

CALL:SMService:PTPoint[:MTERminated][:MESSage]:TYPE:SUBReport:RPTYpe

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

Sets the RP type to use when sending an SMS-SUBMIT-REPORT message from the test set to the mobile station.
EGPRS LA

Setting

 ERRor | ACK

Query

 ERR | ACK

*RST Setting

 ACK
Requirements

GSM/GPRS/ EGPRS TA

 Revision: A.09 and above with required feature license.
GSM/GPRS/ EGPRS LA

Revision: D.01 and above

Programming Example:

OUTPUT 714;"CALL:SMService:PTPoint:TYPE:SUBReport:RPTYpe ACK"
! Sets the RP type to `ACK' to use when sending an SMS-SUBMIT-REPORT message from the test set
! to the mobile station.

CALL:SMService:PTPoint[:MTERminated]:TXT1?

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

This queries the fixed Text Message 1.
EGPRS LA

Query

 Returns a string.

*RST Setting

 "0123456789ABCDEFGHIJKLMNOPQRSTUVWXYZabcdefghijklmnopqrstuvwxyz"
Requirements

GSM/GPRS/ EGPRS TA

 Revision: A.09 and above with required feature license.
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example:

OUTPUT 714;"CALL:SMService:PTPoint:TXT1"
! This queries the fixed Text Message 1.

CALL:SMService:PTPoint[:MTERminated]:TXT2?

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

This queries the fixed Text Message 2.
EGPRS LA

Query

 Returns a string.

*RST Setting

 "Agilent Technologies, your partner in wireless solutions"
Requirements

GSM/GPRS/ EGPRS TA

 Revision: A.09 and above with required feature license.
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example:

OUTPUT 714;"CALL:SMService:PTPoint:TXT2?"
! This queries the fixed Text Message 2.

CALL:SMService:PTPoint:MORiginated:LOOPback

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

Enables the loopback of a point-to-point message. The message is sent to the mobile station with the same parameters as the most recently received text message.
EGPRS LA

Setting

 0|OFF|1|ON

Query

 0|1

*RST setting

 0
Requirements

GSM/GPRS/ EGPRS TA

 Revision: A.09 and above with required feature license.
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714; "CALL:SMService:PTPoint:MORiginated:LOOPback ON"
! Enable loopback of a point to point message.

CALL:SMService:PTPoint:MORiginated[:MESSage]:CLEar[:ALL]

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

Clears all Received Message data. This includes Transport, Length, Format, Contents, Text, Destination Address, Message Count, More Messages to Send Indication, Data Coding Scheme, User Data Header Indication, User Data Header Length, Status Report Request, and Message Reference.

Empties the message queue if it is enabled.

Clears the mobile terminated send state (See CALL:SMService:PTPoint[:MTERminated]:SEND:STATe? ).
EGPRS LA
Requirements

GSM/GPRS/ EGPRS TA

 Revision: A.09 and above with required feature license.
GSM/GPRS/ EGPRS LA

Revision: C.01 and above; Revision D.01 extends this command to include emptying the message queue if it is enabled and also clearing the following message information: Contents, More Messages to Send Indication, Data Coding Scheme, User Data Header Indication, User Data Header Length, Status Report Request, and Message Reference.

Programming Example

OUTPUT 714; "CALL:SMService:PTPoint:MORiginated:CLEar"
! Clears all Received Message Data.

CALL:SMService:PTPoint:MORiginated[:MESSage]:CONTents?

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

Queries the contents of the last mobile originated message and returns the raw message content.
EGPRS LA
Query Returns an ASCII formatted string of hexadecimal characters.
Range: 0 to 280 characters

*RST setting

 Empty string.
Requirements

GSM/GPRS/ EGPRS TA

 Revision: A.09 and above with required feature license.
GSM/GPRS/ EGPRS LA

Revision: D.01 and above

Programming Example

OUTPUT 714; "CALL:SMService:PTPoint:MORiginated:CONTents?"
! Returns the raw content of the last mobile originates message.

CALL:SMService:PTPoint:MORiginated[:MESSage]:COUNt?

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

Queries the number of messages received by the test set.
EGPRS LA
Query Range: 0 to 255
Resolution: 1

*RST setting

 0
Requirements

GSM/GPRS/ EGPRS TA

 Revision: A.09 and above with required feature license.
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714; "CALL:SMService:PTPoint:MORiginated:COUNt?"
! Returns the number of messages received by the test set.

CALL:SMService:PTPoint:MORiginated[:MESSage]:DCSCheme?

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

Queries the Data Coding Scheme (TP-DCS) of the last message received by the test set or the current message available in the message queue.
EGPRS LA
Query Range: 0 to 255 or 9.91E+37 (NAN)
Resolution: 1

*RST setting

 9.91E+37
Requirements

GSM/GPRS/ EGPRS TA

 Revision: A.09 and above with required feature license.
GSM/GPRS/ EGPRS LA

Revision: D.01 and above

Programming Example

OUTPUT 714; "CALL:SMService:PTPoint:MORiginated:DCSCheme?"
! Queries the Data Coding Scheme of the last message received by the test set or the current
! message available in the message queue.

CALL:SMService:PTPoint:MORiginated[:MESSage]:DESTination?

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

Queries the destination address of the last SMS message received by the test set.
EGPRS LA
Query Returns a string.

*RST setting

 "" (null string)
Requirements

GSM/GPRS/ EGPRS TA

 Revision: A.09 and above with required feature license.
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714; "CALL:SMService:PTPoint:MORiginated:DESTination?"
! Queries the destination address of the last SMS message received by the test set.

CALL:SMService:PTPoint:MORiginated[:MESSage]:FORMat?

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

Queries the Last Received Message Format.
EGPRS LA

Query

 ASC|BIN|UCS2|INV|UNKN

ASC: 7 bit ASCII string
BIN: Binary data
UCS2: Unicode Character Set 2
INV: Invalid (returned when no messages have been received
UNKN: Unknown message format

*RST setting

 INV
Requirements

GSM/GPRS/ EGPRS TA

 Revision: A.09 and above with required feature license.
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714; "CALL:SMService:PTPoint:MORiginated:FORMat?"
! Queries the Last Received Message Format.

CALL:SMService:PTPoint:MORiginated[:MESSage]:LENGth?

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

Queries the Last Received Message Length.
EGPRS LA
Query Returns a number value or 9.91E+37 (NAN).

ASCII - the number of characters in the ASCII text message
Binary/UCS2 - the number of octets of data in the message
No message received - NAN

*RST setting

 9.91E37
Requirements

GSM/GPRS/ EGPRS TA

 Revision: A.09 and above with required feature license.
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714; "CALL:SMService:PTPoint:MORiginated:LENGth?"
! Queries the Last Received Message Length.

CALL:SMService:PTPoint:MORiginated[:MESSage]:MREFerence?

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

Queries the Message Reference (TP-MR) of the last message received by the test set or the current message available in the message queue.
EGPRS LA
Query Range: 0 to 255 or 9.91E+37 (NAN)

*RST setting

 9.91E+37
Requirements

GSM/GPRS/ EGPRS TA

 Revision: A.09 and above with required feature license.
GSM/GPRS/ EGPRS LA

Revision: D.01 and above

Programming Example

OUTPUT 714; "CALL:SMService:PTPoint:MORiginated:MREFerence?"
! Queries the Message Reference (TP-MR) of the last message received by the test set or
! the current message available in the message queue.

CALL:SMService:PTPoint:MORiginated[:MESSage]:PIDentifier?

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

Queries the Protocol Identifier (TP-PID) of the last message received by the test set or the current message available in the message queue.
EGPRS LA
Query Range: 0 to 255 or 9.91E+37 (NAN)

*RST setting

 9.91E+37
Requirements

GSM/GPRS/ EGPRS TA

 Revision: A.09 and above with required feature license.
GSM/GPRS/ EGPRS LA

Revision: D.01 and above

Programming Example

OUTPUT 714; "CALL:SMService:PTPoint:MORiginated:PIDentifier?"
! Queries the Protocol Identifier (TP-PID) of the last message received by the test set or
! the current message available in the message queue.

CALL:SMService:PTPoint:MORiginated[:MESSage]:SRRequest?

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

Queries the Status Report Request (TP-SRR) of the last message received by the test set or the current message available in the message queue.
EGPRS LA
Query 0 | 1 | 9.91E+37 (NAN)

*RST setting

 9.91E+37
Requirements

GSM/GPRS/ EGPRS TA

 Revision: A.09 and above with required feature license.
GSM/GPRS/ EGPRS LA

Revision: D.01 and above

Programming Example

OUTPUT 714; "CALL:SMService:PTPoint:MORiginated:SRRequest?"
! Queries the Status Report Request (TP-SRR) of the last message received by the test set
! or the current message available in the message queue.

CALL:SMService:PTPoint:MORiginated[:MESSage]:TEXT?

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

Queries the text from the last SMS message received by the test set.
EGPRS LA
Query Returns a string.

*RST setting

 "" (null string)
Requirements

GSM/GPRS/ EGPRS TA

 Revision: A.09 and above with required feature license.
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714; "CALL:SMService:PTPoint:MORiginated:TEXT?"
! Queries the text from the last SMS message received by the test set.

CALL:SMService:PTPoint:MORiginated[:MESSage]:UDHind?

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

Queries the User Data Header Indication (TP-UDHI) of the last message received by the test set or the current message available in the message queue.
EGPRS LA
Query 0 | 1 | 9.91E+37 (NAN)

*RST setting

 9.91E+37
Requirements

GSM/GPRS/ EGPRS TA

 Revision: A.09 and above with required feature license.
GSM/GPRS/ EGPRS LA

Revision: D.01 and above

Programming Example

OUTPUT 714; "CALL:SMService:PTPoint:MORiginated:UDHind?"
! Queries the User Data Header Indication (TP-UDHI) of the last message received by the test set
! or the current message available in the message queue.

CALL:SMService:PTPoint:MORiginated[:MESSage]:UDHLength?

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

Queries the User Data Header Length of the last message received by the test set or the current message available in the message queue.
EGPRS LA
Query Range: 0 to 140 bytes or 9.91E+37 (NAN)

*RST setting

 9.91E+37
Requirements

GSM/GPRS/ EGPRS TA

 Revision: A.09 and above with required feature license.
GSM/GPRS/ EGPRS LA

Revision: D.01 and above

Programming Example

OUTPUT 714; "CALL:SMService:PTPoint:MORiginated:UDHLength?"
! Queries the User Data Header Length of the last message received by the test set or
! the current message available in the message queue.

CALL:SMService:PTPoint:MORiginated:QUEue[:STATe]

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA | Enables SMS message queuing. This causes the test set to put received SMS-SUBMIT messages into a queue instead of overwriting existing messages.
EGPRS LA

Setting

 0|OFF|1|ON
Query | Range: 0|1
*RST Setting | 0
Requirements

GSM/GPRS/ EGPRS TA

 Revision: A.09 and above with required feature license.
GSM/GPRS/ EGPRS LA

Revision: D.01 and above

Programming Example

OUTPUT 714; "CALL:SMService:PTPoint:MORiginated:QUEue 1"
! Enables SMS message queuing. This causes the test set to put received SMS-SUBMIT
! messages into a queue instead of overwriting existing messages.

CALL:SMService:PTPoint:MORiginated:QUEue:COUNt?

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

Queries the current number of SMS messages held in the message queue.
EGPRS LA
Query Range: 0 to 255
Requirements

GSM/GPRS/ EGPRS TA

 Revision: A.09 and above with required feature license.
GSM/GPRS/ EGPRS LA

Revision: D.01 and above

Programming Example

OUTPUT 714; "CALL:SMService:PTPoint:MORiginated:QUEue:COUNt?"
! Enables SMS message queuing. This causes the test set to put received SMS-SUBMIT
! messages into a queue instead of overwriting existing messages.

CALL:SMService:PTPoint:MORiginated:QUEue:NEXT

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

Extracts the next message in the queue, making it available for query. Sending this command clears the previously available message results.
EGPRS LA
Requirements

GSM/GPRS/ EGPRS TA

 Revision: A.09 and above with required feature license.
GSM/GPRS/ EGPRS LA

Revision: D.01 and above

Programming Example

OUTPUT 714; "CALL:SMService:PTPoint:MORiginated:QUEue:NEXT"
! Enables SMS message queuing. This causes the test set to put received SMS-SUBMIT
! messages into a queue instead of overwriting existing messages.

CALL:SMService:PTPoint:MORiginated:REPort:MODE:STATus

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

Sets/queries the method used to send Status Reports.
EGPRS LA
Setting | AUTO | MANual
Query | AUTO | MAN
*RST Setting | AUTO
Requirements

GSM/GPRS/ EGPRS TA

 Revision: A.09 and above with required feature license.
GSM/GPRS/ EGPRS LA

Revision: D.01 and above

Programming Example

OUTPUT 714; "CALL:SMService:PTPoint:MORiginated:REPort:MODE:STATus MANual"
! Sets/queries the method used to send Status Reports to Manual.

CALL:SMService:PTPoint:MORiginated:REPort:MODE:SUBMit

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

Sets/queries the method used to send Submit Reports.
EGPRS LA
Setting | AUTO | MANual
Query | AUTO | MAN
*RST Setting | AUTO
Requirements

GSM/GPRS/ EGPRS TA

 Revision: A.09 and above with required feature license.
GSM/GPRS/ EGPRS LA

Revision: D.01 and above

Programming Example

OUTPUT 714; "CALL:SMService:PTPoint:MORiginated:REPort:MODE:SUBMit AUTO"
! Sets/queries the method used to send Submit Reports to Auto.

CALL:SMService:PTPoint:MORiginated[:MESSage]:TRANsport?

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

Queries the reported transportation mechanism used by the mobile station when it originates a point-to-point SMS message.
EGPRS LA
Query Range: INV|GSM|GPRS

INV: Invalid (returned when no messages have been received by the test set)
GSM: GSM protocol layers were used
GPRS: GPRS protocol layers were used
*RST Setting INV
Requirements

GSM/GPRS/ EGPRS TA

 Revision: A.09 and above with required feature license.
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714; "CALL:SMService:PTPoint:MORiginated:TRANsport?"
! Queries the reported transportation mechanism used by the mobile station when it
! originates a point-to-point SMS message.


Data Throughput Monitor

Data Throughput Monitor

This section is only applicable to the lab applications.

Description

What is Data Throughput?

The Data Throughput Monitor can analyze data transfer rates under various RF and call processing conditions. You can initiate the Data Throughput Monitor by pressing the Instrument selection key. It is displayed on the Measurement/Instrument screen (accessible using the MEASUREMENT key).

Data throughput is the rate of data transfer to and from a wireless device.

NOTE

This feature does not attempt to monitor application layer data throughput (FTP, HTTP, TELNET, etc.).

Two sets of statistics are available from the Data Throughput Monitor:

  • OTA Rx and OTA Tx

    OTA (Over the Air) throughput counts the data transmitted and received by the test set's protocol stack. The location of the measurement point in the protocol stack is dependent upon system type; this data could be a byte stream from RLP (Radio Link Protocol) or RLC (Radio Link Control) or PPP (point to point protocol). OTA throughput does not count physical layer overhead such a mid-amble, guard, or tail bits, or bits added by the encoding process.

  • IP Rx and IP Tx

    IP (Internet Protocol) throughput counts the data transmitted and received by the test set. It measures the IP data transferred between the external LAN connector and the protocol stack. It provides a measure of the IP data packets being transferred to/from the wireless device.

How is Data Throughput Displayed?

When the Data Throughput Monitor is selected and a data call is connected, the test set accumulates data throughput statistics. If a data call is disconnected, data accumulation is suspended until another connection is made and data accumulation continues. Data accumulation can be cleared by performing a measurement reset or clearing the graph.

The test set provides two tools to analyze data throughput:

  • Graphical trace
  • Summary table

Graphical trace

The graphical trace presents up to the most recent 600 seconds (10 minutes) of data throughput statistics. Each of the following color-coded traces can be turned on or off:

  • OTA Tx - (Over The Air Transmitted bits-per-second). This is the rate of link-layer bit transfer sent from the wireless device. In other words, OTA translates into RLP (Radio Link Protocol) in cdma2000 and 1xEV-DO, or RLC (Radio Link Control) protocol in W-CDMA and GPRS, or PPP in GSM. Tx refers to the reverse or uplink channel direction.
  • OTA Rx - (Over The Air Received bits-per-second). This is the rate of link-layer bit transfer received by the wireless device. In other words, OTA translates into RLP (Radio Link Protocol) in cdma2000 and 1xEV-DO, or RLC (Radio Link Control) protocol in W-CDMA and GPRS, or PPP in GSM. Rx refers to the forward or downlink channel direction.
  • IP Tx - Internet Protocol Transmitted. This is the rate of network-layer bit transfer sent by the wireless device. Tx refers to the reverse or uplink channel direction.
  • IP Rx - Internet Protocol Received. This is the rate of network-layer bit transfer received by the wireless device. Rx refers to the forward or downlink channel direction.
  • Context 1 Tx - Internet Protocol Context 1 Transmitted. This is the rate of context 1 network-layer bit transfer sent by the wireless device. Tx refers to the reverse or uplink channel direction.
  • Context 1 Rx - Internet Protocol Context 1 Received. This is the rate of context 1 network-layer bit transfer received by the wireless device. Rx refers to the forward or downlink channel direction.

Four sets of Context <n> traces can be set: Context 1 Tx/Rx, Context 2 Tx/Rx, Context 3 Tx/Rx and Context 4 Tx/Rx. Totally there are 12 traces results are available form the Data Throughput Monitor, but six of them can be display on the screen at one time. The users can choose which traces are to be displayed by pressing Trace Display softkey.

Note that for an application that dose not support counters for multiple Contexts, the "Context<n>" counts will always be zero (a trace will still be available but every point will be "0").

A marker can be assigned to each trace to display instantaneous numeric data throughput values. Markers can be used in conjunction with the Freeze Graph feature to analyze points of interest on traces.

Summary table

The summary table provides the latest statistics for the four monitored measurements. Each measurement is displayed with the following statistics:

  • Marker

    The data rate at the measurement's marker position in bits-per-second.

  • Current

    The measurement's instantaneous data in bits-per-second.

  • Average

    The measurement's average data rate in bits-per-second over the length of the data connection or since the last time the measurement was cleared.

  • Peak

    The measurement's peak data rate in bits-per-second over the length of the data connection or since the last time the measurement was cleared.

  • Data Transfer

    The measurement's total data throughput count, in bytes, over the length of the data connection or since the last time the measurement was cleared

Operating Considerations

The Data Throughput Monitor displays and stores the data throughput results for any Connection Type . The IP Tx and IP Rx data are only available when the Connection Type is set to Auto . The OTA results are available in any Connection Type .

The statistical results are reset and the graph is cleared if the Connection Type is changed.

For Multiple PDP Context application which allows the DUT to have multiple simultaneous services active, Data Throughput Monitor reports the summation of data transferred to or from the DUT. See DUT PDP Setup for more information.

Related Topics

How Do I Use the Data Throughput Monitor?


EDGE Dynamic Power (EDP) Measurement

EDGE Dynamic Power (EDP) Measurement

The EDP measurement is an enhancement to the Dynamic Power measurement. The EDP measurement tests GMSK and 8PSK bursts while in EGPRS test modes in addition to testing only GMSK modulated signals. Set up parameters and measurement results for this measurement are only accessible using the GPIB interface. This measurement is only available in test mode. See Operating Considerations for more details.

How is an EDGE Dynamic Power Measurement Made?

Mobile stations that support EDGE maintain GMSK, the modulation scheme used for GSM and GPRS, for low data rates. EDGE also supports 8PSK, a modulation scheme that extends the raw data rates of GMSK. The test set's EDP measurement provides a mechanism to quickly obtain power measurements of either 8PSK or GMSK modulated signals from a mobile station.

For GMSK modulated bursts generated from an EDGE mobile station, burst power is the only measurement method available in the test set. Burst power determines the power of the burst without any compensation for data content. For 8PSK modulated bursts generated from an EDGE mobile station, the test set offers the following measurement methods: burst power, variable Estimated Carrier Power (ECP), or fixed ECP. ECP is an approximation of the long-term average burst power. Variable ECP assumes a random data pattern is used for each burst and so determines an estimated carrier power compensation factor for each burst in the ramp segment individually. To use the fixed ECP to determine each burst power all bursts in the ramp segment must contain the same data pattern. This results in a faster measurement time because it is only necessary to determine the estimated carrier power compensation factor for the highest power burst in the ramp, which is then applied to each burst in the ramp segment. Variable ECP or Fixed ECP values for each burst in a ramp segment are determined by a single burst. For multi-segment ramps, the same measurement method is used for all segments. Multi-segment ramps are concatenations of single segment ramps, see Figure 1 .

The EDGE Dynamic Power (EDP) measurement must range the measurement receiver individually for each burst in a ramp segment. The receiver's expected power level for the first burst in a ramp segment can be either manually specified or can use the test set's expected power setting. The expected power level for subsequent group bursts are determined by adding the step size, or Expected Maximum Difference (EMD), to the measured power of the final burst in the previous burst group. Figure 1 illustrates how the EMD is used to find all subsequent group burst power levels after the first group. The EMD parameter may be a positive or negative value to facilitate increasing or decreasing power ramps, and can be set separately for each segment in a multi-segment ramp.

When the Initial Power State parameter is set to 1 or ON, the same expected power setting is used for the first burst in all ramp segments. The value used for the initial power depends on the state of the Expected Power Control. If the Expected Power Control parameter is set to Auto, the MS TX Level Burst 1 power level is used. If the Expected Power Control parameter is set to Manual, the expected power that is used is the power level setting for burst 1 that the test set's receiver is expecting to see. When the initial power state is set to OFF, the initial power values for each ramp segment can be set with the Initial Power Value parameter. For more information on the Initial Power State parameter see SETup:EDPower:INITial:POWer:AUTO .

Figure 1

Series of mobile station generated bursts at consecutive power levels.

The bursts drawn with solid lines of Figure 1 depicts what a typical single power ramp segment looks like. The dashed lines are portions of other segments of the multi-segment power ramp. Figure 1 is a single ramp segment with a burst count of 15 and a group count of 5. The number of segments measured in a multi-segment power ramp are configured with the Ramp Segment Count parameter. The test set measures the number of bursts in a ramp segment given by the Ramp Segment Burst Count parameter.The number of bursts at each expected power level is configured with the Ramp Segment Group Count parameter.

EDP measurement results are returned in blocks, or ranges, of 100 values. For example, if the burst count is 150, range 1 will return 100 power measurement results, range 2 will return 50 power measurement results, and ranges 3-10 will return a NaN because there are no result in the range. The same number of integrity values are returned as the burst power measurements. Range 1 will contain 100 integrity values and power measurements, range 2 will contain 50 integrity values and power measurements, and ranges 3-10 will contain the value 1, indicating no results are available for the specified range.

EDGE Dynamic Power Measurement Configurable Parameters

Parameter | GPIB Command
Trigger Arm | INITiate:<measurement mnemonic>[:ON] using EDPower as the <measurement mnemonic> READ:EDPower[:ALL][:RANGe1|RANGe2|RANGe3|RANGe4|RANGe5|RANGe6|RANGe7|RANGe8|RANGe9|RANGe10]? SETup:EDPower:CONTinuous
Timeout State and Time | SETup:EDPower:TIMeout[:STIMe] SETup:EDPower:TIMeout:TIME SETup:EDPower:TIMeout:STATe
Expected Maximum Time Interval State and Value | SETup:EDPower:EMTInterval[:STIMe] SETup:EDPower:EMTInterval:STATe SETup:EDPower:EMTInterval:TIME
Ramp Segment Burst Count | SETup:EDPower:COUNt:NUMBer
Ramp Segment Group Count | SETup:EDPower:COUNt:GROup:SIZE
Ramp Segment Expected Maximum Difference | SETup:EDPower:EMDifference
Ramp Segment Initial Power | SETup:EDPower:INITial:POWer
Ramp Segment Initial Power State | SETup:EDPower:INITial:POWer:AUTO
Ramp Segment Count | SETup:EDPower:COUNt:RSEGment
Measurement Method | SETup:EDPower:METHod

Input Signal Required

The input signal for the EDGE Dynamic Power measurement must be a normal burst.

The EDGE Dynamic Power measurement completes and meets its measurement accuracy specifications when the signal meets the following input signal conditions.

  • Input signal level is -15dBm to +37 dBm for GMSK, and -15dBm to +33dBm for 8PSK.
  • Input signal level is within +/- 3 dB of the expected input level for the first burs and +/-2 dB for all subsequent burst in the ramp segment.
  • The frequency setting tolerance is +/- 50 kHz for signals with an RMS EVM value of 7.5% or less.
  • The temperature range is 20º C to 50º C.
  • After transmitting each ramp or multi-segment ramp, the mobile station must wait a short period before transmitting the next ramp or multi-segment ramp. This period is calculated as 4.62 ms times the number of bursts in the ramp or multi-segment ramp when using the variable ECP method, or 2.31ms times the number of bursts when using the fixed ECP or burst power measurement methods.

EDGE Dynamic Power Measurement Results

  • Integrity Indicator for each burst measured
  • Power Level for each burst measured

The EDGE Dynamic Power measurement does not use the multi-measurement state parameter, and so does not return minimum, maximum, and standard deviation values. Instead, specify the number of bursts to measure using the Ramp Segment Burst Count parameter (see SETup:EDPower:COUNt:NUMBer ). A single measurement returns the integrity indicator and power level for every burst measured. For example, if you set the number of bursts to 15, the returned comma-separated list contains 15 integrity values followed by 15 corresponding measurement values.

Trigger Source

The trigger source that EDGE Dynamic Power measurement supports is RF Rise.

Operating Considerations

  • This measurement is a test mode only measurement, so it is not available when the operating mode is Active Cell. The EDGE Dynamic Power Measurement can measure both GMSK and 8PSK bursts in the EGPRS test modes, as well as GMSK bursts in the GSM and GPRS test modes. For more information on test modes, see Test Mode Operating Modes .

  • Only normal bursts in a single slot configuration are supported and all bursts in the ramp must be at the same frequency.

  • Initiating this measurement automatically aborts and closes any other measurement running at the time.

  • Set up parameters and measurement results for this measurement are only accessible using the GPIB interface.

Related Topics

Programming an EDGE Dynamic Power Measurement


Measurement Reports

Measurement Reports

Measurement reports are values reported from the MS that contain information about channel quality. Measurement reports assist the network in making handover and power control decisions.

There are six measurement report screens, SACCH and Network Control Measurement Reports have two screens (General and Enhanced Measurement Reports) each.

  • Summary Measurement Reports
  • SACCH Measurement Reports
  • PACCH Measurement Reports
  • Network Control Measurement Reports

Measurement reports are available for all data connection types. However, when using the ETSI Test Mode A data connection, results are available for the initial establishment of the connection only. The downlink TBF is released in ETSI Test Mode A. Therefore, there is no signal for the MS to measure and no updates to the report during the connection.

The SACCH Measurement Reports and the Network Control Measurement Reports allow you to query the NEW or LAST results for a specific parameter. See SACCH NEW? and [:LAST?] Queries and Network Control :NEW? and [:LAST]? Queries for more details.

You can configure measurement report parameters used to influence the type and rate of the measurement reports performed by the Mobile Station. See Configuring Measurement Report for more details.

The measurement reports are available only in Active Cell Operating Mode .

Summary Measurement Reports

The Summary Measurement Reports screen provides a summary of important results for all types of measurement reports on a single screen. This screen displays SACCH, PACCH, and Network Control measurement reports. This screen is particularly useful for DTM connections since this mode requires all three types of measurement reports. Additional information can be found in the separate measurement report screens. See the following sections for more information on each type of measurement report screen.

SACCH Measurement Reports

When the test set receives SACCH data from the mobile station, results are reported to you in the SACCH Measurement Reports screen.

SACCH data is reported any time there is a downlink TCH and the mobile station is synchronized to the test set transmitting a valid SACCH on the uplink. SACCH Reports are reported when the TBF not active.

There are two SACCH Measurement Report screens:

  • General SACCH Reports Screen , the screen displays reports for all types of SACCH reports except the neighbour cell information from Enhanced Reports. The neighbour cell reports part of this screen includes only "normal" reports but the Serving Cell part of the screen includes both normal and enhanced reports. The Mobile Station only returns measurement reports on up to 6 GSM and 3G FDD neighbour cells during the reporting period. The neighbour cell listed in the screen are listed decending order of the Report That is, the neighbour cell with the highest RX Level is reported as Neighbour Cell 1.
  • Enhanced SACCH Neighbour Reports Screen , the screen is only populated with results when the Report Type is set to Enhanced , the Mobile Station returns measurement reports on up to 16 GSM and 13 3G FDD neighbour cells during the reporting period. The neighbour cell information is displayed in the same order as specified in the neighbour cell lists of the test set, the Test set does not attempt to order the neighbour cell information the Mobile Station returns.

You can set the report type through configuration of the Report Type parameter. See Configuring Measurement Report . The type of report actually returned from the Mobile Station is displayed by the Report Type field on this screen.

NOTE
For Mobile Station limited by the protocol stack to support Enhanced SACCH Measurement Reports, General SACCH Measurement Reports are returned instead.

General SACCH Reports Screen

The following figure shows the General SACCH Measurement Reports screen. This screen displays Serving Cell Reports (such as Timing Advance, TX Level, RX Level, and RX Quality) and Neighbour Cell Reports (which contain the RAT, (U)ARFCN, NCC, BCC, SC(3G FDD), Report and Quantity of each neighbour cell). The Mobile Station returns information on up to 6 GSM or 3G FDD neighbour cells during the reporting period for General SACCH Measurement Reports.

Serving Cell Reports

  • Timing advance - The actual Timing advance value being used by the mobile station. This result should reflect the value set in the Call Parms, TCH Parms, Timing Advance field.
  • TX Level - The actual Tx Level being used by the mobile station. This result should reflect the value set in the Call Parms, TCH Parms, MS TX Level field.
  • RX Level (Full and Sub)- The power level corresponding to the average received signal level of the downlink TCH as measured by the mobile station during the preceding SACCH interval. See also Full and Sub Receiver Reports .
  • RX Qual (Full and Sub)- The level corresponding to the mobile station's perceived quality of the downlink signal during the preceding SACCH interval. See also Full and Sub Receiver Reports .

Neighbour Cell Reports

The mobile station determines what neighbour cells to measure from the BA tables and 3G FDD cell list. The test set reports the results returned for up to six neighbour cells.

  • Neighbour RAT results reflect the Radio Access Technology reported by the mobile station in the SACCH report.
  • Neighbour channel results reflect the GSM neighbour cell ARFCN or 3G FDD neighbour cell UARFCN reported by the mobile station in the SACCH report.
  • Neighbour NCC results reflect the network color code reported by the mobile station in the SACCH report. The NCC column always display "----" for 3G FDD neighbour cells as they are only relevant for GSM neighbour cells.
  • Neighbour BCC results reflect the base station color code reported by the mobile station in the SACCH report. The BCC column will always display "----" for 3G FDD neighbour cells as they are only relevant for GSM neighbour cells.
  • Neighbour SC (3G FDD) results reflect the 3G FDD neighbour cell scrambling code reported by the mobile station in the SACCH report. The SC column will always display "----" for GSM neighbour cells as they are only relevant for 3G FDD neighbour cells.
  • Neighbour Rx Lev results reflect the GSM neighbour cell power level reported by the mobile station in the SACCH report.
  • Neighbour Report results reflect the actual measurement result from measurements performed on the neighbour cell. The meaning of this result differs depending on the type of RAT being reported. The Quantity column used to further elaborate on the quantity of the report.
  • Neighbour Quantity results reflect the 3G FDD neighbour cell report quantity reported by the mobile station in the SACCH report. For GSM neighbour cell reports the quantity column always shows Rx Lev of the cell; For 3G FDD neighbour cell reports the quantity column shows either RCSP or Ec/No depending on the value of the FDD_REPORTING_QUANTITY parameter. See Configuring Measurement Report for more details.

    NOTE
    The Quantity results may also be "RSSI" if the DUT has been instructed to perform RSSI measurement reporting on a particular UARFCN, in such a case, the DUT perform a broadband power measurement rather than measuring a particular cell, no scrambling code is returned.

Enhanced SACCH Neighbour Reports Screen

The following figure shows the Enhanced SACCH Measurement Reports screen. This screen displays Reports for up to a maximum 29 valid neighbour cells (16 GSM and 13 3G FDD cells). The GSM neighbour cell report contains ARFCN, BCC, NCC, Rx Lev of each neighbour cell, the 3G FDD neighbour cell report contains UARFCN, SC, Report and Quantity of each neighbour cell.

Querying the SACCH Reports

You can retrieve the results remotely using the following queries. No mechanism is provided to turn off SACCH data reports.

Parameter | GPIB Query
SACCH GSM Neighbour Cell Information (Gerneral measurement reports only) | CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):NCELl<n>[:GSM][:LAST]? CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):NCELl<n>[:GSM]:NEW?
SACCH 3G FDD Neighbour Cell Information (General measurement reports only) | CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):NCELl<n>:FDD[:LAST]? CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):NCELl<n>:FDD:NEW?
SACCH GSM Neighbour Cell Data Points Number (Enhanced measurement reports only) | CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):ENHanced:NCELl[:GSM]:POINts[:LAST]? CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):ENHanced:NCELl[:GSM]:POINts:NEW?
SACCH 3G FDD Neighbour Cell Data Points Number (Enhanced measurement reports only) | CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):ENHanced:NCELl:FDD:POINts[:LAST]? CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):ENHanced:NCELl:FDD:POINts:NEW?
SACCH GSM Neighbour Cell Number (Enhanced measurement reports only) | CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):ENHanced:NCELl[:GSM]:POINts[:LAST]? CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):ENHanced:NCELl[:GSM]:POINts:NEW?
SACCH 3G FDD Neighbour Cell Number (Enhanced measurement reports only) | CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):ENHanced:NCELl:FDD:POINts[:LAST]? CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):ENHanced:NCELl:FDD:POINts:NEW?
SACCH Number of Neighbour Cells (General measurement reports only) | CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):NCELl:NUMBer[:LAST]? CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):NCELl:NUMBer:NEW?
SACCH RX Level (Full) | CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):RXLevel:FULL[:LAST]? CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):RXLevel:FULL:NEW?
SACCH RX Level (Sub) | CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):RXLevel:SUB[:LAST]? CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):RXLevel:SUB:NEW?
SACCH RX Quality (Full) | CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):RXQuality:FULL[:LAST]? CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):RXQuality:FULL:NEW?
SACCH RX Quality (Sub) | CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):RXQuality:SUB[:LAST]? CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):RXQuality:SUB:NEW?
SACCH Timing Advance | CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):TADVance[:LAST]? CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):TADVance:NEW?
SACCH TX Level | CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):TXLevel[:LAST]? CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):TXLevel:NEW?
SACCH Radio Access Technology (General measurement reports only) | CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):NCELl<n>:RATechnology[:LAST]? CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):NCELl<n>:RATechnology:NEW?
SACCH Report Type | CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):TYPE[:LAST]? CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):TYPE:NEW?

Full and Sub Receiver Reports

The SACCH Measurement Reports return both Full and Sub measurement reports for the RX Level and the RX Quality. Full and Sub indicate whether the returned measurement results are obtained from the full ( Full ) set of the TCH and SACCH TDMA frames or a subset ( Sub ) of four SACCH frames. See 3GPP TS 05.08 section 8.4.1 for more information.

SACCH NEW? and [:LAST?] Queries

:NEW? queries hang until a new message is received by the test set or until the SCPI control device timeout occurs. The mobile station issues data updates on the SACCH every 480 ms, (4 frames).

Measurements made during this four frame period are averaged and the result of these averaged measurements are reported by the mobile station during the next period. Measurements must be stable in order to give valid (stable) results for a :NEW? query. Therefore, it may take up to three reports before a reported value accurately reflects a change to any of its parameters. See SACCH Report Measurement Cycle.

After changing measurement parameters, you must send three consecutive :NEW? queries to obtain stable, accurate results. By querying :NEW? three times the value becomes stable for the second query, and meaningful stable results are then reported for the third query. The results from the first two queries should not be used.

SACCH Report Measurement Cycle

If several SACCH reported values are needed from the same report, the first value needed should be queried three times (to receive a stable new report). Then the additional values should be immediately queried using the :LAST? query before the next report arrives or the measurement parameters are changed again.

The :LAST? query is not a hanging query; values are returned from the last SACCH report. As shown in the following program example (line 60), the :LAST? command is optional. If :NEW? is not used in the MS:REPORTED command, the :LAST value is automatically reported.

Programming Example

10       OUTPUT 714;"CALL:CELL:POW -83"
20       OUTPUT 714;"CALL:MS:TADV 11"
30       OUTPUT 714;"CALL:MS:TXL 11"
40       OUTPUT 714;"CALL:MS:REP:MEAS:SACCH:TXL:NEW?;NEW?;NEW?"
41                ! Query 3 times
50       ENTER 714;Ignore_result,Ignore_result,Valid_result
51                ! Only use Valid_result
60       OUTPUT 714;"CALL:MS:REP:MEAS:SACCH:RXL?;TADV?"
61                ! The last RX Level and Timing advance reported by the MS.
70       ENTER 714;Rx_level,Timing_adv
80       END

PACCH Measurement Reports

PACCH measurements are only applicable to GPRS and EGPRS. The following figure shows the PACCH Measurement Reports screen when the system type is GPRS (left) and EGPRS (right).

You can query the values returned in the PACCH measurement reports using the following commands:

Parameter | GPIB Query
PACCH Variation Coefficient for GMSK or EPSK bursts (EGPRS only) | CALL:MS:REPorted:MEASurement:(PACCH|PACChannel):BEP:GMSK|EPSK:CVARiance[:AVERage]|MAXimum|MINimum?
PACCH Mean BEP for GMSK or EPSK bursts (EGPRS only) | CALL:MS:REPorted:MEASurement:(PACCH|PACChannel):BEP:GMSK|EPSK:MEAN[:AVERage]|MAXimum|MINimum?
PACCH BEP for each Timeslot for GMSK or EPSK bursts (EGPRS only) | CALL:MS:REPorted:MEASurement:(PACCH|PACChannel):BEP:GMSK|EPSK:TSLot<0|1|2|3|4|5|6|7>[:AVERage]|MAXimum|MINimum?
PACCH C Value | CALL:MS:REPorted:MEASurement:(PACCH|PACChannel):CVALue:AVERage?
PACCH Interference Level for each Timeslot | CALL:MS:REPorted:MEASurement:(PACCH|PACChannel):ILEVel:TSLot<n>:AVERage?
PACCH RX Quality | CALL:MS:REPorted:MEASurement:(PACCH|PACChannel):RXQuality:AVERage?
PACCH RX Level Signal Variance | CALL:MS:REPorted:MEASurement:(PACCH|PACChannel):SVARiance:AVERage?

Network Control Measurement Reports

Network Control Reports are reported when the mobile station is attached to the test set.

NOTE: The Network Control Measurement Reports are returned by the mobile station only when the Network Control Order is set to NC1 or NC2 . See CALL[:CELL]:BCHannel:NCORder for a description of the Network Control Order and the GPIB command used to configure the Network Control Order.

There are two Network Control Measurement Report screens:

  • General Network Control Measurement Reports Screen , the screen displays reports for all types of Network Contrl Measurement Reports except the neighbour cell information from Enhanced Reports. The neighbour cell reports part of this screen includes only "normal" reports but the Serving Cell part of the screen includes by both normal and enhanced reports. The Mobile Station only returns measurement reports on up to 9 GSM and 3G neighbour cells during the reporting period. The neighbour cell listed in the screen are listed decending order of the Report That is, the neighbour cell with the highest RX Level is reported as Neighbour Cell 1
  • Enhanced Network Control Neighbour Reports Screen , the screen is only populated with results when the Report Type is set to Enhanced , the Mobile Station returns measurement reports on up to 16 GSM and 13 3G FDD neighbour cells during the reporting period. The neighbour cell information is displayed in the same order as specified in the neighbour cell lists of the test set, the Test set does not attempt to order the neighbour cell information the Mobile Station returns.

You can set the report type through configuration of the Report Type parameter. See Configuring Measurement Report . The type of report actually returned from the Mobile Station is displayed by the Report Type field on this screen.

NOTE
For Mobile Station limited by the protocol stack to support Enhanced Network Control Measurement Reports, General Network Control Measurement Reports are returned instead.

General Network Control Measurement Reports Screen

The following figure shows the General Network Control Measurement Reports screen. This screen displays Serving Cell Reports (which contain Network Control Mode, Rx Level, and I Level) and Neighbour Cell Reports (which contain the RAT, (U)ARFCN, NCC, BCC, SC (3G FDD), Report and Quantity of each neighbour cell). For General Network Control Measurement Reports, the Mobile Station returns information on up to 6 GSM or 3G FDD neighbour cells during the reporting period.

Serving Cell Reports

  • Network Control Mode - The actual Network Control Mode value being used by the mobile station.
  • Rx Level - The actual Rx Level of the mobile station.
  • I Level (Full and Sub)- The interference level value reported by the mobile station .

Neighbour Cell Reports

See Neighbour Cell Reports .

Enhanced Network Control Neighbour Reports Screen

The following figure shows the Enhanced Network Control Measurement Reports screen. This screen displays Reports for up to a maximum 29 valid neighbour cells (16 GSM and 13 3G FDD cells). The GSM neighbour cell report contains ARFCN, BCC, NCC, Rx Lev of each neighbour cell, the 3G FDD neighbour cell report contains UARFCN, SC, Report and Quantity of each neighbour cell.

Querying the Network Control Measurement Reports

You can obtain the Network Control Measurement Reports using the following queries:

Parameter | GPIB Query
Network Control Interference Level | CALL:MS:REPorted:MEASurement:NCONtrol:ILEVel[:LAST]? CALL:MS:REPorted:MEASurement:NCONtrol:ILEVel:NEW?
Network Control GSM Neighbour Cell Information (General measurement reports only) | CALL:MS:REPorted:MEASurement:NCONtrol:NCELl<n>[:GSM][:LAST]? CALL:MS:REPorted:MEASurement:NCONtrol:NCELl<n>[:GSM]:NEW?
Network Control 3G FDD Neighbour Cell Information (General measurement reports only) | CALL:MS:REPorted:MEASurement:NCONtrol:NCELl<n>:FDD[:LAST]? CALL:MS:REPorted:MEASurement:NCONtrol:NCELl<n>:FDD:NEW?
Network Control GSM Neighbour Cell Information (Enhanced measurement reports only) | CALL:MS:REPorted:MEASurement:NCONtrol:ENHanced:NCELl[:GSM][:LAST]? CALL:MS:REPorted:MEASurement:NCONtrol:ENHanced:NCELl[:GSM]:NEW?
Network Control 3G FDD Neighbour Cell Information (Enhanced measurement reports only) | CALL:MS:REPorted:MEASurement:NCONtrol:ENHanced:NCELl:FDD[:LAST]? CALL:MS:REPorted:MEASurement:NCONtrol:ENHanced:NCELl:FDD:NEW?
Network Control GSM Neighbour Cell Data Points Number (Enhanced measurement reports only) | CALL:MS:REPorted:MEASurement:NCONtrol:ENHanced:NCELl[:GSM]:POINts[:LAST]? CALL:MS:REPorted:MEASurement:NCONtrol:ENHanced:NCELl[:GSM]:POINts:NEW?
Network Control 3G FDD Neighbour Cell Data Points Number (Enhanced measurement reports only) | CALL:MS:REPorted:MEASurement:NCONtrol:ENHanced:NCELl:FDD:POINts[:LAST]? CALL:MS:REPorted:MEASurement:NCONtrol:ENHanced:NCELl:FDD:POINts:NEW?
Network Control GSM Neighbour Cell Number (Enhanced measurement reports only) | CALL:MS:REPorted:MEASurement:NCONtrol:ENHanced:NCELl[:GSM]:POINts[:LAST]? CALL:MS:REPorted:MEASurement:NCONtrol:ENHanced:NCELl[:GSM]:POINts:NEW?
Network Control 3G FDD Neighbour Cell Number (Enhanced measurement reports only) | CALL:MS:REPorted:MEASurement:NCONtrol:ENHanced:NCELl:FDD:POINts[:LAST]? CALL:MS:REPorted:MEASurement:NCONtrol:ENHanced:NCELl:FDD:POINts:NEW?
Network Control Report for Number of Neighbour Cells (General measurement reports only) | CALL:MS:REPorted:MEASurement:NCONtrol:NCELl:NUMBer[:LAST]? CALL:MS:REPorted:MEASurement:NCONtrol:NCELl:NUMBer:NEW?
Network Control Mode | CALL:MS:REPorted:MEASurement:NCONtrol:NCMode[:LAST]? CALL:MS:REPorted:MEASurement:NCONtrol:NCMode:NEW?
Network Control Report for the RX Level | CALL:MS:REPorted:MEASurement:NCONtrol:RXLevel[:LAST]? CALL:MS:REPorted:MEASurement:NCONtrol:RXLevel:NEW?
Network Control Radio Access Technology (General measurement reports only) | CALL:MS:REPorted:MEASurement:NCONtrol:NCELl<n>:RATechnology[:LAST]? CALL:MS:REPorted:MEASurement:NCONtrol:NCELl<n>:RATechnology:NEW?
Network Control Report Type | CALL:MS:REPorted:MEASurement:NCONtrol:TYPE[:LAST]? CALL:MS:REPorted:MEASurement:NCONtrol:TYPE:NEW?

Network Control :NEW? and [:LAST]? Queries

:NEW? queries hang until a new message is received by the test set or until the SCPI control device timeout occurs.

Measurements made during this period are averaged and the result of these averaged measurements are reported by the mobile station during the next period. Measurements must be stable in order to give valid (stable) results for a :NEW? query. Therefore, it may take up to three reports before a reported value accurately reflects a change to any of its parameters.

After changing measurement parameters, you must send three consecutive :NEW? queries to obtain stable, accurate results. By querying :NEW? three times the value becomes stable for the second query, and meaningful stable results are then reported for the third query. The results from the first two queries should not be used.

The :LAST? query is not a hanging query; values are returned from the last Network Control report. The :LAST? mnemonic is optional. If :NEW? is not used in the CALL:MS:REPorted:MEASurement:NCONtrol command, the :LAST value is automatically reported.

The mobile station only sends network controlled measurement reports if it is GPRS attached to the 8960, and when the Network Control Mode is set to 1 or 2.

Configuring Measurement Report

There are two types of configurable measurement report parameters:

  • General Measurement Report Parameters, see Configuring General Measurement Reports Parameters for more details.
  • 3G Measurement Report Parameters, see Configuring 3G Measurement Reports Parameters for more details.

Related Topics

How to view Measurement Reports


Repeated SACCH Frame Erasure Rate (FER) Measurement Description

Repeated SACCH Frame Erasure Rate (FER) Measurement Description

Last updated: December 3, 2008

This section is only applicable to the lab applications.

You can use the Repeated SACCH Frame Erasure Rate (FER) measurement to measure the Frame Erasure Rate on SACCH of a mobile that supports the Repeated SACCH function. See Repeated SACCH .

How is the SACCH FER Measurement Made?

The test set measures the Repeated SACCH FER by sending a Layer 3 message that does not require a Layer 3 response from the mobile station on the SACCH. If the mobile station fails to decode a SACCH block then it may request that the block be repeated by setting the SRR (SACCH Repetition Request) bit in the Layer 1 SACCH header on the uplink SACCH. If the MS fails to decode the repeated SACCH block and again sets the SRR bit then the test set counts that as a single Frame Erasure event and will not repeat the downlink SACCH block a second time. The two downlink SACCH blocks, the original and the repeat, are counted as a single sample and the failure of the MS to decode both of them is counted as a single failure.

The test set uses an MM Information message with all the optional fields omitted for the Layer 3 message.

Operating Considerations

The Repeated SACCH FER measurement can only be performed in Active Cell Operating Mode.

The connection type must be Auto and a speech call must be active before performing a Repeated SACCH FER measurement.

The Downlink Repeated SACCH must be set to On Repeat Request before performing a Repeated SACCH FER measurement. See CALL:TCHannel:(SACCH|SACChannel):REPeat[:STATe] .

Repeated SACCH FER Measurement Parameters

  • Samples to Test - The number of samples to be taken by the measurement.
  • Trigger Arm - (See Trigger Arm (Single or Continuous) Description .)
  • Measurement Timeout - (See Measurement Timeouts .)

Repeated SACCH FER Measurement Results

  • Integrity Indicator - (see Integrity Indicator )
  • Frames Sampled - The count of samples tested.
  • Frames Erased - The count of frames requiring retransmission by the test set.
  • Frame Erasure Rate - The ratio of Frames Erased to Frames Sampled.

Related Topics

How Do I Make a Repeated SACCH Frame Erasure Rate (FER) Measurement?

Repeated SACCH

SETup:SFERate

FETCh:SFERate

Test Adherence to Standards


Uplink State Flag (USF)

Uplink State Flag (USF)

Last updated: December 3, 2008

The USF, or Uplink State Flag, allows the multiplexing of several MS onto a single uplink PDTCH. The USF value is sent to the mobile station in a Packet Immediate Assignment message. The USF is also sent in Packet Uplink Assignment and Packet Timeslot Reconfigure messages.

You can determine how well the mobile station reallocates its transmission to the appropriate uplink block by changing the USF value during a data transmission.

  1. Establish a GPRS data link and start transferring data.
  2. On the Control menu ( 1 of 3 ), press Handover Setup ( F5 ).
  3. Press GPRS Handover Setup (F2)
  4. Scroll to Uplink State Flag and enter a new value.
  5. Press Handover Execute ( F5 ).
  6. Verify that the MS transmits on the block corresponding to the new USF. Incorrect transmissions show up as USF BLER.

Related Topics

Uplink State Flag (USF) BLER


Protocol Logging Requirements

Protocol Logging Requirements

The Lab Application enables the test set to log protocol messages. Protocol messages are forwarded to the Wireless Protocol Advisor (WPA) software, which is required for message display and analysis. This software is included with the lab application and will run on PCs that meet the following system requirements:

Summary of Requirements for the Wireless Protocol Advisor

NOTE
These requirements are subject to change or addition without notice. Always refer to the product web page for the latest information.

  • PC Operating System:
    • Microsoft , Windows , 98
    • Microsoft , Windows , NT 4 SP3/4/5
    • Microsoft , Windows , 2000
  • 300 MHz Pentium or equivalent recommended
  • 128 MB RAM recommended
  • 250 MB available disk space required for installation
  • 100 MB available disk space recommended for storing logged information
  • Video resolution minimum 800 by 600 pixels with at least 256 colors
  • LAN or WAN connectivity required to connect to the test set


Activating Protocol Logging From the Test Set

Activating Protocol Logging From the Test Set

This section is only applicable to the lab applications.

Logging can be started or stopped using the test set's front panel or GPIB commands. If the Wireless Protocol Advisor (WPA) software is not attached to the test set an error message is generated.

NOTE
The WPA software performs the same start/stop functions when the REC (RECord) button is selected. Refer to the WPA on-line Help for details.

Related Topics

How to use Protocol Logging


Protocol Logging and Data Channel Troubleshooting

Protocol Logging and Data Channel Troubleshooting

Protocol Logging

  • Error message appears when you start Protocol Logging on the test set: The test set must be connected via a LAN or WAN to a PC running the Wireless Protocol Advisor (WPA). Check connections, installation of software, IP addresses and gateway addresses.
  • WPA is no longer connected to the test set: Anytime you preset the test set, the connection to the WPA is lost. Reestablish the connection from the configuration view of the WPA.

Data Channel

  • If your data channel application does not seem to be working, try pinging the device. The test set has a ping feature, and so do most computer operating systems. See Ping for more information.
  • Ping log has an unknown IP address: If you log a Ping that originated from the test set, the Ping Downlink Source Address and the Uplink Destination Address have a fixed address of 130.29.181.203. This is because the test set uses an internal address to originate IP data from the test set to the mobile station. See Protocol Logging During Ping for more information.
  • Ping does not work: Verify that your device supports ping. The device must have a PDP context established for GPRS or EGPRS or a PPP connection for GSM CSD in order for ping to work. This may require that you initiate a data transfer from the mobile station. Also, Ping and Data Channel are only available in when the connection type is set to Auto .
  • Can't find where to set the mobile station IP address: Switch the Connection Type to Auto first.
  • BER and FBER measurements are invalid when using the data channel: The BER and FBER measurements are not supported during data connections.
  • What is the APN (Access Point Name) that I need to include with the dial string when using dial-up? No APN is needed.
  • When using your mobile station as a modem, make sure the mobile station recognizes that the data cable is attached. You may need to allow the mobile station to camp or attach to the test set and then connect the data cable. The mobile station may also display a message indicating the cable has been connected.

Related Topics

Protocol Logging


Programming a Digital Audio Interface (DAI) Test

Programming a Digital Audio Interface (DAI) Test

This section is only applicable to lab applications and the test application with a required feature license.

  • Programming a Downlink DAI Test
  • Programming a Uplink DAI Test

Programming a Downlink DAI Test

The following example program demonstrates use of the Downlink DAI Test. See Digital Audio Interface (DAI) Downlink Test steps for procedure on how to set up a Downlink DAI Test.

11 Testset=714
12 CLEAR SCREEN
13 CLEAR 7
14 CLEAR Testset
15 PRINT "*** Digital Audio Interface (DAI) Downlink Test Program for GSM/GPRS/EGPRS***"
16 PRINT
17 PRINT
18     !
19     !****************************************************************
21     ! TS Uploads the COD/DEC reference file to the Test set via HTTP interface,
22     ! Indicate which codec the COD/DEC reference file applies to,
23     ! Press Enter when finished.
24     !****************************************************************
25 Codec_type$="AFS"     !Set the Type of the Codec file to "Adaptive Full Rate".
26     !
27 BEEP
28     !
30 PRINT "Upload the COD/DEC reference file to the Test set,"
31 PRINT "Indicate which codec the COD/DEC reference file applies to,"
32 PRINT "Press Enter when finished."
33 PRINT
34 PRINT
35 !
36 LINPUT "Press ENTER when finished",Keyboard$
37         !
38 !
39 OUTPUT 714;"CALL:CELL:OPERating:MODE CALL"     !Set the operating mode to Active Cell.
40 OUTPUT 714;"CALL:CELL:POWer -50dBm"     !Set the Cell Power.
41 !
42 !If necessary, configure the traffic channel parameters for the call assignment.
43 !See "CALL:TCHannel".
44 !If necessary, set the Paging Identity. See "CALL:PAGing:IDENtity[:TYPE]".
50 !If necessary, set the IMSI state. See "CALL:PAGing:IMSI".
60 !If necessary, set the repeat paging state. See "CALL:PAGing:REPeat[:STATe][:SELected".
61 !
70 OUTPUT 714;"CALL:ORIGINATE"     ! Begin the BS originated call.
80 OUTPUT 714;"CALL:CONNECTED:STATE?"     ! The connect/idle query.
90 ENTER 714;Call_connected     ! Program will hang here until state
100                              ! change or protocol timer expires.
110     !************************************************************
120     ! If mobile is not set to auto-answer, answer the call.
130     !************************************************************
140 IF NOT Call_connected THEN
150 DISP "CALL NOT CONNECTED."
160 ELSE
170 OUTPUT 714;"CALL:TCHannel:CMODe:LSPeech:CHANnel ";Codec_type$
171        !Set the Logical Speech Channel to be tested.
172 OUTPUT 714;"CALL:TCHannel:DAINterface:TINTerface SDECoder"
173        ! Enable the DAI Speech Decoder.
174 !
175         !*********************************************************************
176         ! Command the Customer Test Station (TS) to apply reset pulse to DUT.
177         ! Command the Customer Test Station (TS) to start recording the
178         ! COD file output from the Mobile Station via the DAI.
179         ! Press Enter when finished.
180         !*********************************************************************
181 !
182 BEEP
183 !
184 PRINT "Command the Customer Test Station (TS) to apply reset pulse to DUT."
185 PRINT "Command the Customer Test Station (TS) to start recording the"
186 PRINT "COD file output from the Mobile Station via the DAI."
187 PRINT "Press Enter when finished."
188 PRINT
189 PRINT
190         !
191 LINPUT "Press ENTER when finished",Keyboard$
192 !
193 OUTPUT 714;"CALL:DAINterface:PLAY:STATus?"         !Query the play status
194 ENTER 714;Play_status$
195 !
196 IF NOT (Play_status$="IDLE") THEN
197         !
198   OUTPUT 714;"CALL:DAINterface:PLAY:STARt"
199 !
200   LOOP
201   OUTPUT 714;"CALL:DAINterface:PLAY:STATus?"           !Query the play status.
202   ENTER 714;Play_status$
203   EXIT IF NOT (Play_status$="PLAY")
204   END LOOP
205 !
206   PRINT "DAI Downlink Test Finished."
207 !
208 ELSE
209   PRINT "Operation rejected; Digital audio file is not available."
210 END IF
211 !
212 OUTPUT 714;"CALL:TCHannel:DAINterface:TINTerface OFF"
213        !Set the DAI Test Interface to Off.
214 OUTPUT 714;"CALL:END"         !End the Call connection.
215 !
216 END IF
217 END

Programming a Uplink DAI Test

The following example program demonstrates use of the Uplink DAI Test. See Digital Audio Interface (DAI) Uplink Test steps for procedure on how to set up a Uplink DAI Test.

11 Testset=714
12 CLEAR SCREEN
13 CLEAR 7
14 CLEAR Testset
15 PRINT "*** Digital Audio Interface (DAI) Uplink Test Program for GSM/GPRS/EGPRS***"
16 PRINT
17 PRINT
35 !
36 Codec_type$="AFS"     !Set the Type of the Codec file to "Adaptive Full Rate".
37 OUTPUT 714;"CALL:CELL:OPERating:MODE CALL"     !Set the operating mode to Active Cell.
38 OUTPUT 714;"CALL:CELL:POWer -50dBm"     !Set the Cell Power.
39 !
40 !If necessary, configure the traffic channel parameters for the call assignment.
41 	 !See "CALL:TCHannel".
42 !If necessary, set the Paging Identity. See "CALL:PAGing:IDENtity[:TYPE]".
50 !If necessary, set the IMSI state. See "CALL:PAGing:IMSI".
60 !If necessary, set the repeat paging state. See "CALL:PAGing:REPeat[:STATe][:SELected]".
61 !
70 OUTPUT 714;"CALL:ORIGINATE"     ! Begin the BS originated call.
80 OUTPUT 714;"CALL:CONNECTED:STATE?"     ! The connect/idle query.
90 ENTER 714;Call_connected     ! Program will hang here until state
100                              ! change or protocol timer expires.
110     !************************************************************
120     ! If mobile is not set to auto-answer, answer the call.
130     !************************************************************
140 IF NOT Call_connected THEN
150 DISP "CALL NOT CONNECTED."
160 ELSE
170 OUTPUT 714;"CALL:TCHannel:CMODe:LSPeech:CHANnel ";Codec_type$
171        !Set the Logical Speech Channel to be tested.
172 OUTPUT 714;"CALL:TCHannel:DAINterface:TINTerface SENCoder"
173        ! Enable the DAI Speech Encoder.
174 !
175         !*********************************************************************
176         ! Command the Customer Test Station (TS) to apply reset pulse to DUT.
178         !*********************************************************************
179 !
180 BEEP
181 !
182 PRINT "Command the Customer Test Station (TS) to apply reset pulse to DUT."
185 PRINT "Press Enter when finished."
186 PRINT
188                 !
190 LINPUT "Press ENTER when finished",Keyboard$
191 !
193       !
194 OUTPUT 714;"CALL:DAINterface:RECord:STARt"
195 !
196         !*********************************************************************
197         ! Command the Customer Test Station (TS) to start transfering the
198         ! digital audio file to the Mobile Station.
201         !*********************************************************************
202 !
203 BEEP
204 !
205 PRINT "Command the Customer Test Station (TS) to start transfering the"
206 PRINT "digital audio file to the Mobile Station."
209 PRINT "Press Enter when finished."
210 PRINT
213         !
214 LINPUT "Press ENTER when finished",Keyboard$
215 !
216         !**********************************************************************
217         ! Command the Test Set to stop recording after the transmission of the
218         ! digital audio file is finished.
219         !**********************************************************************
220 !
221 BEEP
222 PRINT "Press ENTER When the Customer Test Station has finished the transmission of the digital audio file"
223 PRINT
224 !
225 LINPUT "Press ENTER when finished",Keyboard$
226 !
227 OUTPUT 714;"CALL:DAINterface:RECord:STOP"
228 !
229 PRINT "DAI Uplink Test Finished."
230 !
232 OUTPUT 714;"CALL:TCHannel:DAINterface:TINTerface OFF"
233        !Set the DAI Test Interface to Off.
234 OUTPUT 714;"CALL:END"
235        !End the Call connection.
236 !
237 END IF
238 END

Related Topics

Digital Audio Interface (DAI) Description

How to use the Digital Audio Interface Features

Logging Digital Audio Interface (DAI) Messages

CALL:DAINterface


Programming an EDGE Dynamic Power Measurement

Programming an EDGE Dynamic Power Measurement

This section provides an example of how to make an EDGE Dynamic Power measurement via the GPIB interface.

Procedure:

  1. Configure the mobile station to generate bursts.
  2. Setup the EDGE Dynamic Power measurement parameters to measure the bursts the mobile station is configured to generate.
  3. Obtain the measurement results using the FETCh subsystem.

Programming Example

The method used to synchronize the mobile station with the test set for the EDGE Dynamic Power measurement is proprietary to the mobile station manufacturer. The test set has no direct control of synchronization when the mobile station is operating in test mode. The EDGE Dynamic Power measurement requires the mobile station be put in a test mode in which it can generate a specified burst sequence.

The figure below models an example series of bursts that a mobile station has been programmed to generate.

As can be seen in the figure above there are three separate ramp segments defined, with a total burst count of thirty. The details of each ramp segment is shown in the following table.

 | Ramp Segment Burst Count | Group Burst Count | Initial Expected Power (dBm) | Expected Maximum Difference (dB)
Ramp Segment 1 | 12 | 4 | 6 | +3
Ramp Segment 2 | 6 | 1 | 14 | -2
Ramp Segment 3 | 12 | 2 | 5 | +1

The following programming example shows how to capture a series of bursts that a mobile station was commanded to generate.

10 Test_set=714
20 OUTPUT Test_set;"SETup:EDPower:CONTinuous OFF"     !sets  the  trigger  to  single
40 OUTPUT Test_set;"SETup:EDPower:TIMeout:STIMe 5"     !sets the  timeout  state  to  on  and  the                                                          !timeout time to 5 seconds
50 OUTPUT Test_set;"SETup:EDPower:COUNt:RSEGment 3"  !specifies  three  ramp  segments
60 OUTPUT Test_set;"SETup:EDPower:COUNt:NUMBer 12, 6, 12"    !specifies  the  number  of  bursts                                                                 !for  each  ramp  segment
70 OUTPUT Test_set;"SETup:EDPower:COUNt:GROup:SIZE 4, 1, 2"   !specifies  the  burst  group  size                                                                   !for  each  ramp  segment
80 OUTPUT Test_set;"SETup:EDPower:EMDifference 3,-2, 1"    !specifies  the  maximum  power                                                                        !difference  between  the  burst
90 OUTPUT Test_set;"SETup:EDPower:INITial:POWer 6, 14, 5"    !specifies  the  initial  expected                                                                     !power values
100 OUTPUT Test_set;"SETup:EDPower:INITial:POWer:AUTO OFF"    !tells  the  test set  to use  the                                                                 !specified  initial  power  values rather
110                                                         !than  deriving them
120 OUTPUT Test_set;"SETup:EDPower:COUNt:TOTal?"   !returns  the  total  number  of bursts                              !measure
130 !
131 OUTPUT Test_set;"INITiate:EDPower"   !Initiates the measurement
132 WAIT 1     !A one second wait is needed here to ensure the measurement
133             !is ready to start testing the generated bursts.
134             !
135 !* ************************************************************************
136 !
137 !* Trigger the mobile station to start generating the desired burst pattern.
138 !
139 !* ************************************************************************
140 OUTPUT Test_set;"FETCh:EDPower" !This obtains all the measurement results in range one,
150 !which is all that is needed for this example because the total number of bursts that are measured
160 !is less than 100.
170 !
180 ENTER 714;Integrity,Tx_power_levels
200 END

Returned Values

The result that is obtained from this program is a comma separated string of 60 values. The first 30 values in the string are Integrity Indicator values and the remaining thirty values are average transmitted power levels the mobile station generated.

Related Topics

EDGE Dynamic Power (EDP) Measurement


Programming an AMR In-Band Frame Error Rate Measurement

Programming an AMR In-Band Frame Error Rate Measurement

This section is only applicable to lab applications and the test application with a required feature license.

  1. Establish an AMR call between the mobile station and the test set.
  2. Configure the AMR In-Band Frame Error Rate (IFER) parameters using the SETup subsystem.
  3. Use the INITiate commands to begin an AMR IFER measurement.
  4. Use the FETCh? queries to obtain AMR IFER measurement results.

Programming Example

This programming example assumes that a call has been originated from the mobile station or the test set.

10  Test_set=714
20  OUTPUT Test_set;"CALL:TCHannel:CMODe:LSPeech:CHANnel AFS"
30    !Sets the Logical Speech Channel to AFS (Adaptive Full)
40    !-one of the two AMR Logical Speech Channels.
50  OUTPUT Test_set;"CALL:TCHannel:CMODe:AFSpeech:CODec AFS6700,AFS7400,AFS7950,AFS10200"
60      !These four codecs are now the Active Codec Set.
70  OUTPUT Test_set;"CALL:TCHannel:CMODe:AFSpeech:CODec:CURRent AFS6700"
80      !If a call does not exist, this codec will be the initial codec used when a call is made.
90      !If a call does exist, then the codec automatically switches to this codec.
100     !Note that the current codec must be a codec defined in the Active Codec Set.
110  OUTPUT Test_set;"CALL:TCHannel:CMODe:AFSpeech:CODec:THReshold 6,1.5,12,1.5,18.5,2"
120     !Sets the threshold and hysteresis values in the following order:threshold 1,
130     !hysteresis 1, threshold2, hysteresis2, threshold 3,hysteresis 3.
140  OUTPUT Test_set;"SETup:IFERror:TIMeout:STATe OFF"
150     !IFER measurement will not timeout.
160  OUTPUT Test_set;"SETup:IFERror:CONTinuous OFF"
170     !Configures the IFER measurement to Single Trigger.
180  OUTPUT Test_set;"SETup:IFERror:COUNt 150"
190     !Sets the number of speech frames to measure to 150000,
200     !the minimum recommended by the standard.
210  OUTPUT Test_set;"SETup:IFERror:LDControl:AUTO ON"
220     !Automatically determined the number of speech frames needed to wait
230     !for the complete loopback type I. IFER measurement will not start if
240     !loopback type I is not supported by the mobile station.
260  OUTPUT Test_set;"READ:IFERror?"    !Start and obtain all IFER measurement results.
270  ENTER Test_set;Integrity,Speech_frames,Fer,Fec
280  PRINT "Integrity",Integrity
290  PRINT "Speech Frames Tested",Speech_frames
300  PRINT "Frame Error Ratio",Fer
310  PRINT "Frame Error Count",Fec
450  END

Returned Values

The measurements returned by this program are:

  • Integrity - See Integrity Indicator . (Integrity Indicator Value)
  • Speech_Frames - The number of speech frames tested in the measurement. (Speech Frames)
  • FER - The ratio of speech frame errors to the total number of frames. (Frame Error Ratio)
  • FEC - The number of speech frame errors counted. (Frame Error Count)

Related Topics

SETup:IFERror

FETCh:IFERror

INITiate

In-Band Frame Error (IFER) Measurement Description .


Protocol Event Trigger Output (PETO)

Protocol Event Trigger Output (PETO)

Last updated: December 3, 2008

This feature provides a hardware trigger output from the rear panel of the test set to control external instruments and devices. It is an extension of the trigger provided in earlier applications. Frame triggers and protocol message-based triggers are available, based on various layers of the protocol stack.

The original trigger could be set to trigger on every TDMA frame with user-settable timeslot and symbol positions. PETO offers additionally:

  • Several more frame based triggers with varying degrees of frequency
  • Protocol message based triggers output when specific DL messages are sent by the test set
  • Triggers generated when the MS is expected to Transmit or Receive

Multiple Triggers

Any combination of frame and protocol triggers can be enabled at the same time. Triggers fire in the order in which they occur, but all triggers are output on the same Trig Out port. It is not possible to discern which trigger has fired based only on the output signal.

If triggers occur at the same time, only one signal will appear on the port. Choose triggers carefully to provide the most meaningful results.

Related Topics

Protocol Message Based Triggers


Frame Triggers

Frame Triggers

All of the frame based triggers can be enabled and will fire in all operating modes except Cell Off. In Cell Off mode, triggers can be enabled, but will not fire.

Frame Triggers Unique to the Lab Applications

The following frame triggers are available:

  • Every frame except the idle frame
  • Every GPRS radio block
  • Every 51 Frame BCH multiframe
  • Every 52 Frame PDTCH multiframe
  • Every hyperframe (designated by frame number)

All frame triggers (except "every frame except idle") allows for a frame offset within the hyperframe/multiframe/radio block, on which the trigger should fire. Timeslot or symbol position cannot be set.

Frame Trigger Common Between the Lab and Test Applications

There is an "every frame" trigger which can be configured for both timeslot and symbol position that is available. See Frame Trigger Parameters for details.

Related Topics

Protocol Event Trigger Output (PETO)


Protocol Message Based Triggers

Protocol Message Based Triggers

Messages that assign downlink resources have a trigger associated with them that can fire on the first frame the MS is expected to start receiving data as a result of the downlink resource assignment. The Expected MS RX Trigger could be used to analyze data sent to a MS by connecting the MS to a logic analyzer. This could be useful to track MS software defects or wireless application communication issues. This trigger indicates when the test set expects the MS to start receiving data.

Messages that assign uplink resources also have an associated trigger that can fire on the first frame the MS is expected to start transmitting as a result of the uplink assignment. The Expected MS Tx Trigger could be used to ensure that a MS responds correctly to resource assignments and starts its transmission period in the correct place. The trigger output could be connected to a spectrum analyzer to initiate measurements on the frame in which the MS starts to transmit.

Each protocol message to which triggers are related may have more than one trigger associated with it. At the very least each message has an associated trigger that can fire on the frame used to transmit the message from the test set to the MS (downlink).

The protocol messages handled and the triggers associated with them are shown in the following table.

Protocol Messages and their Associated Triggers
Protocol Message | Protocol Stack Layer | Test Set Tx Trigger | Expected MS Tx Trigger | Expected MS Rx Trigger
Packet Uplink Assignment | RLC/MAC | Yes | Yes |
Packet Downlink Assignment | RLC/MAC | Yes |  | Yes
Packet Timeslot Reconfigure | RLC/MAC | Yes | Yes |
Packet Power Control/Timing Advance | RLC/MAC | Yes |  |
Packet Immediate Assignment | RR | Yes | Yes | Yes
Identity Request | GMM | Yes |  |
Attach Accept | GMM | Yes |  |
Detach Request | GMM | Yes |  |
Request PDP Context Activation | SM | Yes |  |
PDP Context Activation Accept | SM | Yes |  |

NOTE
The Packet Timeslot Reconfigure and the Packet Immediate Assignment do not always assign uplink resources. The Expected MS TX Trigger will not be fired for occurrences where no uplink resource assignment is made.

All protocol message based triggers can only be used in the Active Cell operating mode. Any message based trigger will not fire in any other mode other than active cell.

Related Topics

Protocol Event Trigger Output (PETO)


Protocol Trigger Timing

Protocol Trigger Timing

Frame Trigger Timing

For any frame trigger that is enabled, a signal will be generated on the test set's trigger output on the first symbol period of the frame or frames on which the trigger is fired.

If a frame offset is set for any of the frame triggers, a signal will be generated that number of frames after the frame in which the trigger is fired.

Message Based Trigger Timing

All triggers associated with the sending of a message from the test set will generate a signal on the first symbol of the timeslot on which the first burst of the related message is sent.

All triggers associated with the MS starting to receive data will generate a signal on the first symbol of the timeslot on which the test set begins transmission of the data.

All triggers associated with the MS starting to transmit data will generate a signal on the first symbol of the timeslot on which the MS should start to transmit.

If a frame offset is set for any of the message based triggers, a signal will instead be generated that number of frames after the frame in which the event occurs.

Related Topics

Protocol Event Trigger Output (PETO)


Protocol Control

Protocol Control

Last updated: December 9, 2008

The protocol stack configuration options provide you with control over the content and execution of events in the protocol stack. These are organized by protocol layer. The parameters listed under the following protocol layers are accessed on the front panel by selecting the layer that contains the parameter in the Prot Control menu. For instructions on how to access the protocol layers, see How to access Protocol Control .

Layer 1

  • Downlink Corruption
  • EGPRS Demodulation Type
  • Test Mode Burst Timing Error Measurement

RLC/MAC

  • MAC Control
  • Handover Control
  • Block Polling Parameters
  • Temporary Block Flow (TBF) Parameters
  • Retransmission MCS Switching
  • Window Size
  • Control Channel Setup
  • Window Size

LLC

  • BLER Frame Check Sequence
  • Payload Patterns

MM/GMM

  • Attach Accept
  • Attach Reject
  • Detach Request
  • Equivalent PLMN List
  • Identity Request
  • Location Area Update Rejection
  • Routing Area Update Rejection
  • Security Information

SM

  • Activate PDP Context Reject
  • Network Initiated PDP Context

Call Control

  • Alerting Duration
  • Call Release State

Attach Accept

The parameters associated with the Attach Accept event allow you to configure the test set to simulate a network allowing only GPRS services. This means you can expect an IMSI attach for both GPRS and non-GPRS services to be rejected. You may also choose which cause value is sent to the MS in the GMM cause information element ( GMM Cause Information Element ) with the Attach Reject message. Use this function in parallel with protocol logging ( Protocol Logging ) to verify that the MS behaves in a manner conforming to the standards for this situation and for each associated GMM cause value.

The MS only sends an Attach Request in the "Idle" state. Therefore, the connection status must be "Idle" before the Attach Accept event can be used.

Attach Reject

You may configure the test set to simulate a network rejection of any Attach Attempt. You may choose from a variety of cause values to be sent in the GMM cause information element ( GMM Cause Information Element ) with the attach reject message. Use this function in parallel with protocol logging ( Protocol Logging ) to verify that the MS behaves in a manner conforming to the standards for this situation and for each associated GMM cause value.

The MS only sends an Attach Request in the "Idle" state. Therefore, the connection status must be "Idle" before the Attach Accept event can be used.

Detach Request

You can initiate the Detach Request event from the test set anytime the data connection state is "Attached". In addition, a Detach Request can also occur when the data connection state is either "Transferring" or "PDP Active". This allows you to observe how the mobile station responds to a detach request from a network and determines if it complies with mobile performance specifications of 3GPP TS 04.08 Version 7.9.1. The command to send a detach request is CALL:PPRocedure:DETach:REQuest[:IMMediate] .

There are two configurable parameters that you can set before sending a detach request.

  • GMM Cause Information Element

    You can choose which cause value is sent to the mobile station in the GMM Cause Information Element with the Detach Request.

    The command to set the GMM Cause Information Elements is CALL:PPRocedure:DETach:REQuest:GMMCause .

    Note: The front panel allows you to select Custom Value as the GMM Cause Information Element in addition to the GMM Cause Information Element settings defined in 3GPP TS 24.008 Version 6.7.0 Section 10.5.5.14. The Custom Value is set with the above command and is not configurable via the front panel.

  • Detach Type Information Element

    You can also choose which type of detach message the test set sends the mobile station in the Detach Type Information Element as defined in 3GPP TS 24.008 Version 6.7.0 Section 10.5.5.5.

    The command to set the Detach Type Information Element is CALL:PPRocedure:DETach:REQuest:TYPE .

Use these parameters in parallel with Protocol Logging to verify that the mobile station behaves in a manner conforming to the standards 3GPP TS 04.08 Version 7.9.1 Section 4.7.4.2 for this situation and for each associated GMM cause value.

Identity Request

A GPRS MS has four identity values (types). These values are displayed in the Identity Request Summary screen, in the following order:

  • IMSI - International Mobile Subscriber Identity
  • IMEI- International Mobile Station Equipment
  • IMEISV - IMEI and the Software Version number
  • TMSI - Temporary Mobile Subscriber Identity

The Identity Request Summary screen is accessed by pressing the GMM/MM ( F4 ) from the Prot Control menu (see How to access Protocol Control for instructions on how to get to the Prot Control menu), then pressing Identity Request ( F4 ) in the Identity Req menu. The test set displays the DUT Reported Identity that is in the indicated by the Identity Type parameter (which can be set to any of the identity types listed above. The default Identity Type is IMSI .

NOTE
The test set always displays a zero for the 15th digit of the IMEI. This behavior conforms to 3GPP TS 03.03, which requires that the 15th digit (referred to as Spare digit or Check Digit) "shall be zero, when transmitted by the MS", and 3GPP TS 02.16 which states that the "check digit is not part of the digits transmitted at IMEI check equations".

Lab application only:

You can send a request for any one of these four identities from the test set (by selecting the Identity Type ( F2 ), then pressing Send Identity Request ( F1 ) ) to verify that the MS supplies the appropriate value for the identity requested. Use this function in parallel with protocol logging ( Protocol Logging ) to verify that the MS behaves in a manner conforming to the standards for this situation.

Additionally, you can control whether the Identity Request messages get the IMEI during call setup by configuring the Get IMEI at Call Setup parameter. This parameter is located in the Identity Request Setup ( F3 ) menu, which is accessed from the Identity Req menu. The GPIB command for this parameter is CALL:IMEI:AUTO .

The data connection state can be either "Attached" or "PDP Active" when an Identity Request message is sent to the MS.

NOTE
The Get IMEI at Call Setup parameter is located in the Cell Parameters menu for the E6701D lab application and the E1968A test application.

The GPIB commands associated with Identity Request are located at CALL:PPRocedure:IDENtity .

Location Area Update Rejection

You can configure the test set to reject the Location Area Update (LAU) request from the mobile station. This allows you to observe how the mobile station responds to LAU Rejection from a network and determine if it complies with mobile performance specifications of 3GPP TS 24.008 Version 6.13.0.

There are two configurable parameters that you can set before sending a LAU Rejection.

  • Location Area Update Reject State

    When the Location Area Update Reject State is set to ON, the test set will reject the LAU request from the mobile station.

    The command to set the Location Area Update Reject State is CALL:PPRocedure:LAU|LAUPdate:REJect[:STATe] .

  • Location Area Update Reject Cause

    You can choose which cause value is sent to the mobile station in the Location Area Update Reject message. the reject cause can be either of the followings:

    • 00000010 (#2) - IMSI Unknown
    • 00000011 (#3) - Illegal MS
    • 00000110 (#6) - Illegal ME
    • 00001011 (#11) - PLMN not allowed
    • 00001100 (#12) - Location Area not allowed
    • 00001101 (#13) - Roaming not allowed in LA
    • 00001111 (#15) - No suitable cells in LA

    The front panel also allows you to select Custom Value as the Location Area Update Reject Cause in addition to the above values. The Custom Value is set with the GPIB command only and is not configurable via the front panel. See GMM Cause Information Element for more information about the cause values.

    The command to set the Location Area Update Reject Cause is CALL:PPRocedure:LAU|LAUPdate:REJect:GMMCause .

You can initiate a LAU Rejection procedure by doing the following:

  • Make sure the mobile station is Attached
  • Change the operating mode to Cell Off
  • Press Call Setup
  • Press Cell Info ( F6 )
  • Press Cell Identification ( F3 )
  • Change the actual Location Area Code (LAC) of the cell
  • Change the operating mode to Active Cell , then when the mobile station comes back in to register to the network. it will send the Location Area Update Request to the test set.

Use these parameters in parallel with Protocol Logging to verify that the mobile station behaves in a manner conforming to the standards 3GPP TS 24.008 Version 6.13.0 Section 4.4.4.7 for this situation and for each associated Location Area Update Reject Cause value.

Routing Area Update Rejection

You can configure the test set to reject the request for Routing Area Update (RAU) from the mobile station. This allows you to observe how the mobile station responds to RAU Rejection from a network and determines if it complies with mobile performance specifications of 3GPP TS 24.008 Version 6.13.0.

There are two configurable parameters that you can set before sending a RAU Rejection.

  • Routing Area Update Reject State

    When the Routing Area Update Reject State is set to ON, the test set will reject the RAU request from the mobile station.

    The command to set the Routing Area Update Reject State is CALL:PPRocedure:RAU|RAUPdate:REJect[:STATe] .

  • Routing Area Update Reject Cause

    You can choose which cause value is sent to the mobile station in the Routing Area Update Reject message. You can choose the following reject causes from the front panel:

    • 00000011 (#3) - Illegal MS
    • 00000110 (#6) - Illegal ME
    • 00000111 (#7) - GPRS Services Not Allowed
    • 00001000 (#8) - GPRS/Non-GPRS Services Not Allowed
    • 00001001 (#9) - MS Identity Cannot Be Derived
    • 00001010 (#10) - Implicitly Detached
    • 00001011 (#11) - PLMN not allowed
    • 00001100 (#12) - Location Area not allowed
    • 00001101 (#13) - Roaming not allowed in LA
    • 00001110 (#14) - GPRS Services Not Allowed In This PLMN
    • 00001111 (#15) - No suitable cells in LA

    The front panel also allows you to select Custom Value as the Routing Area Update Reject Cause in addition to the above values. The Custom Value is set with the GPIB command only and is not configurable via the front panel. See GMM Cause Information Element for more information about the cause values.

    The command to set the Routing Area Update Reject Cause is CALL:PPRocedure:RAU|RAUPdate:REJect:GMMCause .

You can initiate a RAU Rejection procedure by doing the following:

  • Make sure the mobile station is Attached
  • Change the operating mode to Cell Off
  • Press Call Setup
  • Press Cell Info ( F6 )
  • Press Cell Identification ( F3 )
  • Change the actual Routing Area Code (RAC) of the cell
  • Change the operating mode to Active Cell , then when the mobile station comes back in to register to the network. it will send the Routing Area Update Request to the test set.

Use these parameters in parallel with Protocol Logging to verify that the mobile station behaves in a manner conforming to the standards 3GPP TS 24.008 Version 6.13.0 Section 4.7.5.1.4 for this situation and for each associated Routing Area Update Reject cause value.

Activate PDP Context Reject

You may configure the test set to simulate a network rejection of an Activate PDP Context Request from an MS. You can select from a variety of SM cause values to be sent in the SM cause information element ( SM Cause Information Element ) with the Activate PDP Context Reject message. Use this function in parallel with protocol logging ( Protocol Logging ) to verify that the MS behaves in a manner conforming to the standards for this situation and for each associated SM cause value.

The data connection state must be "Attached" to use the Activate PDP Context Reject event.

Network Initiated PDP Context

If data requiring a PDP context is destined for an mobile staion which does not currently have an assigned PDP context, you can configure whether or not the test set will initiate a PDP context negotiation procedure by setting the Network Initiated PDP Context State.

The GPIB command to set the Network Initiated PDP Context State is CALL:PPRocedure[:QOSProfile]:PDPContext:NINitiated[:STATe] .

Alerting Duration

The Mobile Originated Alerting Duration is used to delay the connection of a Mobile Originated voice call. When the timer has a non-zero value, the call will remain in the Alerting state until the timer expires, at which point, the 8960 will complete (or release) the call.

This parameter is only applicable in the Active Cell operating mode.

The GPIB command to set the Alerting Duration is CALL:MORiginated:ALERting:DURation .

Call Release State

The Call Release State is used to determine whether an incoming Mobile Originated voice call is connected or released. When this parameter is set to ON , the Mobile Originated voice call will be released when the Alerting Duration expires.

This parameter is only applicable in the Active Cell operating mode.

The GPIB command to set the Call Release State is CALL:MORiginated:CALL:RELease[:STATe] .

Detach Type Information Element

Detach Type Value (decimal) | Detach Type (bits) | Programming Mnemonic | Detach Type
1 | 001 | REQ | Re-attach Required
2 | 010 | NREQ | Re-attach not Required
3 | 011 | IMSI | IMSI Detach (after VLR failure)

GMM Cause Information Element

GMM Cause Information Element
Cause Value (decimal) | Cause Value (bits) | Cause
2 | 00000010 | IMSI Unknown
3 | 00000011 | Illegal MS
6 | 00000110 | Illegal ME
7 | 00000111 | GPRS Services Not Allowed
8 | 00001000 | GPRS/Non-GPRS Services Not Allowed
9 | 00001001 | MS Identity Cannot Be Derived
10 | 00001010 | Implicitly Detached
11 | 00001011 | PLMN Not Allowed
12 | 00001100 | Location Area Not Allowed
13 | 00001101 | Roaming Not Allowed In This LA
16 | 00010000 | MSC Temporarily Not Reachable
17 | 00010001 | Network Failure
22 | 00010110 | Congestion
48 | 00110000 | Retry Upon Entry Into A New Cell
95 | 01011111 | Semantically Incorrect Message
96 | 01100000 | Invalid Mandatory Information
97 | 01100001 | Message Type Nonexistent
98 | 01100010 | Msg Type Incompatible With Prot State
99 | 01100011 | Information Element Nonexistent
100 | 01100100 | Conditional IE Error
101 | 01100101 | Msg Incompatible With Protocol State
111 | 01101111 | Protocol Error, Unspecified

SM Cause Information Element

SM Cause Information Element
Cause Value (decimal) | Cause Value (bits) | Cause
24 | 00011000 | MBMS Bearer Insufficient For Service
25 | 00011001 | LLC or SNDCP Failure
26 | 00011010 | Insufficient Resources
27 | 00011011 | Missing or Unknown APN
28 | 00011100 | Unknown PDP Address or PDP Type
29 | 00011101 | User Authentication Failed
30 | 00011110 | Activation Rejected By GGSN
31 | 00011111 | Activation Rejected, Unspecified
32 | 00100000 | Service Option Not Supported
33 | 00100001 | Requested Service Opt Not Subscribed
34 | 00100010 | Service Opt Temporarily Out of Order
35 | 00100011 | NSAPI Already Used
36 | 00100100 | Regular Deactivation
37 | 00100101 | QoS Not Accepted
38 | 00100110 | Network Failure
39 | 00100111 | Reactivation Required
40 | 00101000 | Feature Not Supported
41 | 00101001 | Semantic Error In the TFT Operation
42 | 00101010 | Syntactical Error In the TFT Operation
43 | 00101011 | Unknown PDP Context
44 | 00101100 | Semantic Errors in Packet Filter(s)
45 | 00101101 | Syntactical Errors in Packet Filter(s)
46 | 00101110 | PDP Context without TFT Already Activated
47 | 00101111 | Multicast Group Membership Timeout
81 | 01010001 | Invalid Transaction Identifier Value
95 | 01011111 | Semantically Incorrect Message
96 | 01100000 | Invalid Mandatory Information
97 | 01100001 | Msg Type Nonexistent/Not Implemented
98 | 01100010 | Msg Type Incompatible With Protocol State
99 | 01100011 | IE Non-existent or Not Implemented
100 | 01100100 | Conditional IE Error
101 | 01100101 | Msg Not Compatible With Protocol State
111 | 01101111 | Protocol Error, Unspecified
112 | 01110000 | APN Restric Value Incompatible without PDP Context

Related Topics

How to access Protocol Control


E6701A/B/C/D/E/F/T/U GSM/GPRS/EGPRS Lab Application Revision Information

E6701A/B/C/D/E/F/T/U GSM/GPRS/EGPRS Lab Application Revision Information

Last updated: December 9, 2008

This document describes features and functionality that are part of the Agilent Technologies GSM/GPRS/EGPRS Lab Application releases. This document contains the original features, as well as enhancements that have been added over time.

If you are interested in comparing the key feature differences between the latest releases of each of the GSM/GPRS/EGPRS Test and Lab Applications, see GSM/GPRS/EGPRS Application Feature Comparison.

CAUTION
You may need to upgrade the hardware in your test set before installing the application firmware described here. If you install application firmware on a test set with incompatible hardware, the following may occur:

  • Your test set may lock up (see Test Set Lockup During Power Up Sequence ).
  • The application may not run.
  • Some features in the application may be inaccessible, or may not perform to specifications.

To determine if a hardware upgrade is required for your testing needs, please review the hardware requirement information at:

http://wireless.agilent.com/rfcomms/upgrades/8960/

Select the appropriate link below to view the required release.

  • G.00.00 Subscription Release (E6701G) - Dec 2008
  • U.01.04 Special Release (E6701U) - October 2008
  • F.01.15 Release (E6701F) - October 2008
  • F.01.13 Release (E6701F) - September 2008
  • U.00.34 Special Release (E6701U) - May 2008
  • F.00.39 Subscription Release (E6701F) - May 2008
  • U.00.32 Special Release (E6701U) - May 2008
  • F.00.37 Subscription Release (E6701F) - May 2008
  • U.00.22 Special Release (E6701U) - November 2007
  • F.00.27 Subscription Release (E6701F) - November 2007
  • T.03.08 Special Release (E6701T) - July 2007
  • E.02.08 Release (E6701E) - July 2007
  • F.00.18 Subscription Release (E6701F) - May 2007
  • U.00.13 Special Release (E6701U) - April 2007
  • F.00.13 Subscription Release (E6701F) - April 2007
  • T.01.18 Special Release (E6701T) - March 2007
  • E.01.18 Release (E6701E) - March 2007
  • T.01.11 Special Release (E6701T) - December 2006
  • E.01.11 Release (E6701E) - December 2006
  • T.00.08 Special Release (E6701T) - August 2006
  • E.00.12 Subscription Release (E6701E) - August 2006
  • D.03.46 Release (E6701D) - July 2006
  • T.00.04 Special Release (E6701T) - May 2006
  • T.00.02 Special Release (E6701T) - April 2006
  • E.00.08 Subscription Release (E6701E) - March 2006
  • D.03.32 Release (E6701D) - January 2006
  • E.00.05 Subscription Release (E6701E) - August 2005
  • D.02.10 Release (E6701D) - May 2005
  • D.01.18 Release (E6701D) - January 2005
  • C.04.14 Release (E6701C) - January 2005
  • C.03.48 Release (E6701C) - April 2004
  • C.03.32 Release (E6701C) - January 2004
  • C.01.20 Release (E6701C) - February 2003
  • B.01.20 Release (E6701B) - May 2002
  • A.01.10 Release (E6701A) - November 2001

G.00.00 Subscription Release (E6701G) - Dec 2008

This is a subscription release of the E6701G application. In order to provide early access to new features, this subscription release has been partially qualified. The new features present in this release have been bench-tested to verify their performance. The previously existing features in this release have undergone a shortened software qualification cycle to verify that they have not been negatively affected by the new features.

You must have a current GSM/GPRS/EGPRS Lab Application Annual Contract to obtain this subscription release. Contact your Agilent Sales Representative for more information.

For information on how to use the other common features, see the GSM/GPRS/EGPRS online user's guide located at:

http://wireless.agilent.com/rfcomms/refdocs/gsmgprs/

Call Processing

  • Network Identity and Time Zone (NITZ) - allows you to set the Network Identity and Time Zone (NITZ) information in the MM and GMM Information messages for the mobile. See Network Identity and Time Zone for more information.
  • Global Position System (GPS) - allows you to generate GPS signals to calibrate the GPS receiver of the mobile. See Global Position System for more information.
  • Downlink Dual Carrier - allows you to assign EGPRS PDTCH resources to a mobile on two different carriers. See Downlink Dual Carrier for more information.
  • TTI Mode - allows you to reduce the data transfer latency of a EGPRS PDTCH block by setting the TTI Mode to RTTI (Reduced Transmission Time Interval). See TTI Mode Configuration for more information.
  • MO Call Control - allows you to set Alterting Duration and Call Release State of a Mobile Originated Call. See Call Control for more information.
  • Independent UL/DL Coding Scheme - allows you to set PDTCH coding scheme for GPRS uplink and downlink independetly. See Configuring the Packet Data Traffic Channel (PDTCH) for more information.
  • Settable BEP Period2 - allows you to configure the BEP (Bit Error Probability) Period 2 value for cell parameters. See Cell Parameters for more information.
  • Packet Paging - allows you to set the value of the GPRS Ready Timer (T3314) to initiate a packet paging in the test set. See Packet Paging for more information.
  • Flexible Timeslot - allows you to position timeslots within the TDMA frame as much flexibility as possible. See Flexible Timeslot for more information.
  • Frame Synchronization and Synchronized Handover - allows you to synchronize the frame structures between two boxes and to perform two-box handovers in the unsynchronized, synchronized, pre-synchronized and pseudosynchronized modes. See Synchronized Handovers and Handover Control Parameters for more information.

  • ARAC - allows the test set to request the Additional MS Radio Access Capability information when assigning an EGPRS TBF. See ARAC on receipt of PRR for more information.

  • SMS TP-OA, TP-RA, RP-OA extention - allows you to configure parameters of TP-OA, TP-RA, RP-OA flexibly. See Header Parameters for more information.
  • GSM Enhanced Power Control - allows the network to change the power level on the uplink more quickly than the Normal Power Control method. See Enhanced Power Control for more information.
  • Enhanced A-GPS - adds a new parameter to reset the MS positioning stored information. See A-GPS (Assisted-GPS) for more information.
  • FTAS - Provides the ability to preserve the NAS state of the test set when a Fast Switch between two RATs (GSM/GPRS/EGPRS and WCDMA) or a switch between GSM/GPRS/EGPRS and UMA/GAN occurs. See SYSTem:APPLication:FORMat:NAS|NASTratum .
  • FANR - Provides the capability to support sending short ACK/NACK information sequences within EGPRS data blocks.
  • Multislot Class 45 - Multislot Class support has been extended for mobile stations that are multislot class 45 capable. See Supported Multislot Classes .
  • Enhanced UMA/GAN - The Enhanced UMA/GAN test system adds the following functions:
    • Add PLMN List
    • Add GAN conformance test cases
    • Support Cell Broadcast SMS
    • Support Audio Routing

Measurements

  • Enhanced Phase and Amplitude versus Time Measurement - The Enhanced Phase and Amplitude versus Time Measurement allows you to select the Waveform Type for the calibration signal. See Phase and Amplitude versus Time Measurement Description for more information.
  • The following measurements have been enhanced to support measuring 6 continuous uplink timeslots
    • The Transmit Power measurement. See Transmit Power Measurement Description
    • The Power versus Time measurement. See Power versus Time Measurement Description
    • The Modulation Accuracy measurement. See Modulation Accuracy Measurement Description
    • The Phase and Frequency Error measurement. See Phase and Frequency Error Measurement Description
    • The Output RF Spectrum measurement. See Output RF Spectrum Measurement Description

Hardware Requirements

http://www.agilent.com/find/8960upgrades

_____________________________________________________________________________________________________

U.01.04 Special Release (E6701U) - October 2008

The E6701U can only be loaded onto an E5515C with Special High Data Rate Hardware (or a test set with the equivalent hardware upgrades). Loading the E6701U onto an E5515B or E5515C without the appropriate hardware upgrades will cause the test set to lock up.

You must have a current GSM/GPRS/EGPRS Lab Application Annual Contract to obtain this subscription release. Contact your Agilent Sales Representative for more information.

Note, the Special High Data Rate Hardware required to support the E6701U meets the E6701E measurement parametric specifications in a temperature range of 25 ° C +/- 5 ° C, and has an operating temperature range of 0 to 35 ° C.

The features and functionality offered in this release are identical to those offered in the F.01.15 Release (E6701F) - October 2008 , with the following exception:

  • You must use the new LAN 2 PORT for transferring data to the test set.

For information on how to uses these U-specific features, see the E6701U User Documentation .

F.01.15 Release (E6701F) - October 2008

This is a maintenance release to resolve the known issues detailed in the previous release. The features offered in this release are otherwise identical to those offered in the F.01.13 Release (E6701F) - September 2008 .

This release is available for download at the Lab Application Annual Contract site: www.agilent.com/find/wlcontract.

F.01.13 Release (E6701F) - September 2008

The most current documentation for the GSM/GPRS/EGPRS applications is the Online User's Guide located at:

http://wireless.agilent.com/rfcomms/refdocs/gsmgprs/

Call Processing

  • Enhanced UMA/GAN test system

    The Enhanced UMA/GAN test system adds the following functions:

    • Add GPRS packet paging.
    • Add Ciphering test capability between the Mobile Station and Core Network via GAN.
    • Add GAN conformance test cases.
    • Add new GANC configuration parameters including: CSR Classmark enquiry, CSR Paging Request, CSR Downlink Direct Transfer, PSR UnitData, Cell Broadcast SMS, PSR Activation, PSR Deactivation.
    • Add new GANC reported parameters including: UTRAN Cell ID, MS PSR MT Channel Activation Status, MS PSR UnitData Sequence Number, Cell Broadcast Service Required indication and Ciphering related reports parameters.
    • Modify definitions of the GA-RC Connection Status report behavior, Connected GANC Status report behavior and the AMR Codec Mode Set SCPI command.
    • Add support for query/interrupt of message based events occurring at GANC.
    • Add setting of local IP address to use for the test set connection.
    • Add default setting values of all IP address, FQDN, LAC (S-GANC) and RAC (S-GANC).

    See UMA/GAN Test System for more information.

Measurements

  • Mobile Calculate BER - Provides the ability that allows the mobile to calculate the BER when the test set transmits downlink clearcoded payload pattern to the Mobile Station. See Mobile Calculate BER Test for more information.
  • FM Broadcast - Allows you to use the test set coupled with the audio measurement features to test the Mobile Station with full range of FM Broadcast signals. See FM Broadcast for more information.
  • Enhanced GFDT Discontinuous Slot - Provides the ability of measurement timeout mechanism in GFDT transmit power measurement and adds GFDT trigger threshold. See Fast Device Tune Capable Measurement and Fast Device Tune for more information.
  • Enhanced Digital Output RF Spectrum Measurement - The digital Output RF Spectrum measurement is extended to support multi-slot class 12 configuration which has up to 4 uplink burst, time domain graphic and +/- 70 KHz frequency capture range. See Output RF Spectrum Measurement Description for more information.
  • Enhanced Phase and Frequency Error Measurement - The Phase and Frequency Error measurement is extended to support multi-slot class 12 configuration which has up to 4 uplink burst and +/- 500 KHz frequency setting accuracy. See Phase and Frequency Error Measurement Description for more information.
  • Enhanced Modulation Accuracy Measurement. The Modulation Accuracy Measurement is extended to support multi-slot class 12 configuration which has up to 4 uplink burst. See Modulation Accuracy Measurement Description for more information.
  • Enhanced Bit Error Measurement - Allows you to configure the mobile loopback type in test mode. See GSM Bit Error Measurement for more information.
  • Burst Timing Error Measurement - Allows you to measure the time difference between the expected and calculated synchronization code location within a burst in test mode.See Test Mode Burst Timing Error Measurement for more information.
  • Enhanced Transmit Power Measurement - Provides the ability to measure Class 34 Capable mobile phones. You can measure up to 5 uplink bursts with a single capture on one TDMA frame.See Transmit Power Measurement Description for more information.
  • Enhanced Power versus Time Measurement - Provides the ability to measure Class 34 capable mobile phones. You can measure up to 5 uplink bursts with a single capture on one TDMA frame.See Power versus Time Measurement Description for more information.
  • Enhanced EDGE Dynamic Power Measurement - Provides the ability to set the expected maximum time interval state and value. See EDGE Dynamic Power (EDP) Measurement for more information.
  • User Calibration Summary - Provides the summary of the calibration performed. See User Calibration Summary .

Known Issues

  • A protocol processor timeout occurs during repeated packet switched data handover procedures between two test sets.
  • The real time vocoder's Voice Activity Detection State parameter (CALL:RTVocoder:VADetection[:STATe]) is not functioning. It remains in the OFF state.
  • The SYStem:APPLication:CATalog:LICense:APPLication:ALL? command does not function.
  • Results are erroneously high for Unassigned USF BLER when three or more uplinks are in use (that is, when using extended dynamic allocation).
  • Web pages are sometimes not properly displayed on the mobile station when Web browsing.

Hardware Requirements

http://www.agilent.com/find/8960upgrades

_____________________________________________________________________________________________________

U.00.34 Special Release (E6701U) - May 2008

This is a maintenance release to resolve the known issue detailed in the previous release. The feature offered in this release are otherwise identical to those offered in the U.00.32 Special Release (E6701U) - May 2008 .

_____________________________________________________________________________________________________

F.00.39 Subscription Release (E6701F) - May 2008

This is a maintenance release to resolve the known issue detailed in the previous release. The feature offered in this release are otherwise identical to those offered in the F.00.37 Subscription Release (E6701F) - May 2008 .

_____________________________________________________________________________________________________

U.00.32 Special Release (E6701U) - May 2008

NOTE
This release is unavailable due to a critical defect related to test set IP address assignment. Please refer to the top of Known Issues for further details on this issue.

The E6701U can only be loaded onto an E5515C with Special High Data Rate Hardware (or a test set with the equivalent hardware upgrades). Loading the E6701U onto an E5515B or E5515C without the appropriate hardware upgrades will cause the test set to lock up.

You must have a current W-CDMA/HSPA Lab Application Annual Contract to obtain this Special Release. Contact your Agilent Sales Representative for more information.

Note, the Special High Data Rate Hardware required to support the E6701U meets the E6701E measurement parametric specifications in a temperature range of 25 ° C +/- 5 ° C, and has an operating temperature range of 0 to 35 ° C.

The features and functionality offered in this release are identical to those offered in the F.00.37 Subscription Release (E6701F) - May 2008 , with the following exception:

  • You must use the new LAN 2 PORT for transferring data to the test set.

For information on how to uses these U-specific features, see the E6701U User Documentation .

A downloadable version of the Online User's Guide (CHM Help File) that is specific to this release is available at:

http://www.home.agilent.com/upload/cmc_upload/All/E6701F_F0037_E6701U_U0032_E6704A_Ref_Guide.chm

To properly view the CHM Help File, you must save it to your desktop (rather than "Open" it from the Internet). For Windows XP, you must also then right-click on the file and select Properties>>Unblock.

_____________________________________________________________________________________________________

F.00.37 Subscription Release (E6701F) - May 2008

NOTE
This release is unavailable due to a critical defect related to test set IP address assignment. Please refer to the top of Known Issues for further details on this issue.

This is a subscription release of the E6701F application. In order to provide early access to new features, this subscription release has been partially qualified. The new features present in this release have been bench-tested to verify their performance. The previously existing features in this release have undergone a shortened software qualification cycle to verify that they have not been negatively affected by the new features.

You must have a current GSM/GPRS/EGPRS Lab Application Annual Contract to obtain this subscription release. Contact your Agilent Sales Representative for more information.

A downloadable version of the Online User's Guide (CHM Help File) that is specific to this release is available at:

http://www.home.agilent.com/upload/cmc_upload/All/E6701F_F0037_E6701U_U0032_E6704A_Ref_Guide.chm

To properly view the CHM Help File, you must save it to your desktop (rather than "Open" it from the Internet). For Windows XP, you must also then right-click on the file and select Properties>>Unblock.

Call Processing

  • Enhanced A-GPS - Allows you to enable/disable automatic header creation and segmentation of the RRLP binary message by setting the RRLP Header state. See A-GPS (Assisted-GPS) for more information.
  • MS Output Power - allows you to set the MS output power for a PS connection via two method:
    • MS TX Level
    • Alpha and Gamma

    See MS Output Power for more information.

  • Security Information - allows you to perform the security procedure which contains authentication and ciphering. See Security Information for more information.
  • Broadcast Allocation (BA) Tables - allows you to configure up to 32 (P)BCH GSM neighbor cells. You can set the ARFCN, BCC, NCC, Reporting Priority and State for each neighbor cell. See Broadcast Allocation (BA) Tables for more information.
  • DUT Routing State - allows you to use the test set as a router when exchanging IP datagrams between the mobile station and remote servers. See DUT Routing State for more information.
  • Equivalent PLMN List - allows you to set a list of equivalent PLMNs that is sent in the LOCATION UPDATING ACCEPT, ATTACH ACCEPT or ROUTING AREA UPDATE ACCEPT message. See Equivalent PLMN List for more information.
  • Multiple PDP Context - allows multiple simultaneous services active within the mobile stations. See QoS Profile for more information.
  • Enhanced External Handover

    The Enhanced External Handover adds the following procedure:

    • Network Assisted Cell Change (NACC)
    • Packet Switched (PS) Handover

    See Handover Control for more information.

  • Packet Flow Contexts (PFCs) - The test set supports Packet Flow Context negotiation procedure. See Packet Flow Identifier (PFI) for more information.
  • Packet (P)SI Status Indication - allows the mobile to request specific (P)SI message to be transferred from the test set over PACCH when working in the Packet Transfer state. See CALL[:CELL]:PSINdication and Cell Operation for more information.
  • (Packet) System Information Scheduling

    The enhanced (P)SI Scheduling adds the following functions:

    • Periodic PSI List
    • Packet (P)SI Status Indication Response
    • Send encapsulated SI on PACCH
    • Periodic (P)SI repetition time
    • Custom SI List
    • Custom PSI List

    See Control Channel Setup for more information.

  • Real-Time Vocoder - Real-Time Vocoder has been extended for additional functions which to contain AMR-WB/WFS, HalfRate/HS and Enhanced Full Rate/EFS codecs. See Real-Time Vocoder for more information.
  • Repeated SACCH Frame Erasure Rate (FER) Measurement - measures the SACCH Frame Erasure Rate of a mobile that supports Repeated SACCH function. See Repeated SACCH Frame Erasure Rate (FER) Measurement Description for more information.

Known Issues

The test set incorrectly assigns itself two IP addresses based on the "LAN IP Address" setting in the test set - the IP address specified by the "LAN IP Address" setting and "LAN IP Address" + 1. Thus, the test set will respond to IP traffic directed to "LAN IP Address" and "LAN IP Address + 1". This may result in unexpected network behavior if another device on the network is also assigned to "LAN IP Address" + 1.

Example:

If you set LAN IP Address = 192.168.1.22, the Test Set will also respond to LAN IP Address = 192.168.1.23. This will result in unexpected network behavior if there is another device on your network set to LAN IP Address = 192.168.1.23.

Workaround:

Reserve both "LAN IP Address" and "LAN IP Address" + 1 for use by your test set:

  • Ensure that no other device on the network is assigned "LAN IP Address" + 1, including other test sets.
  • Ensure that the test set's other IP addresses, such as "DUT IP Address" and "LAN IP Address 2" are not set to "LAN IP Address" + 1.

Hardware Requirements

http://www.agilent.com/find/8960upgrades

_____________________________________________________________________________________________________

U.00.22 Special Release (E6701U) - November 2007

The E6701U can only be loaded onto an E5515C with Special High Data Rate Hardware (or a test set with the equivalent hardware upgrades). Loading the E6701U onto an E5515B or E5515C without the appropriate hardware upgrades will cause the test set to lock up.

You must have the E6701T and a current GSM/GPRS/EGPRS Lab Application Annual Contract to obtain this subscription release. Contact your Agilent Sales Representative for more information.

Note, the Special High Data Rate Hardware required to support the E6701U meets the E6701E measurement parametric specifications in a temperature range of 25 ° C +/- 5 ° C, and has an operating temperature range of 0 to 35 ° C.

The features and functionality offered in this release are identical to those offered in the F.00.27 Subscription Release (E6701F) - November 2007 , with the following exception:

  • You must use the new LAN 2 PORT for transferring data to the test set.

For information on how to uses these U-specific features, see the E6701U User Documentation .

A downloadable version of the Online User's Guide (CHM Help File) that is specific to this release is available at:

http://www.home.agilent.com/upload/cmc_upload/All/E6701F_F0027_E6701U_U0022_E6704A_Ref_Guide.chm

To properly view the CHM Help File, you must save it to your desktop (rather than "Open" it from the Internet). For Windows XP, you must also then right-click on the file and select Properties>>Unblock.

For information on how to use the other common features, see the GSM/GPRS/EGPRS online user's guide located at:

http://wireless.agilent.com/rfcomms/refdocs/gsmgprs/

_____________________________________________________________________________________________________

F.00.27 Subscription Release (E6701F) - November 2007

This is a subscription release of the E6701F application. In order to provide early access to new features, this subscription release has been partially qualified. The new features present in this release have been bench-tested to verify their performance. The previously existing features in this release have undergone a shortened software qualification cycle to verify that they have not been negatively affected by the new features.

You must have a current GSM/GPRS/EGPRS Lab Application Annual Contract to obtain this subscription release. Contact your Agilent Sales Representative for more information.

A downloadable version of the Online User's Guide (CHM Help File) that is specific to this release is available at:

http://www.home.agilent.com/upload/cmc_upload/All/E6701F_F0027_E6701U_U0022_E6704A_Ref_Guide.chm

To properly view the CHM Help File, you must save it to your desktop (rather than "Open" it from the Internet). For Windows XP, you must also then right-click on the file and select Properties>>Unblock.

Call Processing

  • Real-Time Vocoder - allows you to perform real-time encoding of analogue audio frequency signals for transmission as a voice payload over a GSM downlink traffic channel, and the simultaneous real time decoding of a received GSM uplink signal to an analogue audio signal. The Real-Time Vocoder supports FR (Full Rate) and AMR (Adaptive Multi-Rate) codecs in this release. See Real-Time Vocoder for more information.
  • Enhanced UMA/GAN test system

    The Enhanced UMA/GAN test system adds the following functions:

    • Support for using an external media gateway for GAN speech calls rather than E6962A owns the embedded RTP server.
    • Support for independent configuration of embedded D-GANC and S-GANC entities in E6962A.
    • New user controls provided to initiate immediate redirection between the D-GANC and S-GANC in E6962A after initial MS registration has completed.
    • New option provided to ignore Discovery Requests arriving at the P-GANC.
    • New option provided to ignore Register Requests arriving at the D/S-GANC.
    • New options provided to ignore or reject CSR channel activation requests arriving at the D/S-GANC.
    • New options provided to ignore or reject PSR activation requests arriving at the D/S-GANC.
    • New option provided to ignore PSR deactivation requests arriving at the D/S-GANC.
    • Support for configuration of a number of new GANC cell configuration parameters including: Emergency Call Mode Preference, Early classmark sending allowed, Access control class.
    • Support for Periodic Location Update including independent configuration of T3212 for both GAN and GERAN operation
    • Support for configuration of Serving GANC Table Indicator IE and Location Status IE included in Register Accept/Update messages sent from the D/S-GANC
    • New option provided to specify the RR cause IE included in CSR release messages sent from the D/S-GANC
    • New option provided to ignore MS Handover-in attempts arriving at the D/S-GANC.
    • New "invalid" RTP sample size of 1ms.

    See UMA/GAN Test System for more information.

  • Supplementary Services Pipe - in addition to an RRLP pipe mode, the test set now includes a supplementary services pipe that allows encoding of supplementary service messages in external software and transmission of the messages to the mobile using the test set. The test set also passes any uplink supplementary service messages out for decoding. See Supplementary Services Pipe for more information.
  • Settable Timers - allows you to set the value of the following timers:
    • T3212 Periodic Location Update Timer
    • T3312 Periodic Routing Area UPdate Timer
    • T301 Call Originate Timer
    • T308 Call Release Timer
    • T3192 TBF Release Timer
    • T3314 GMM Ready Timer

    See Configurable Timers for more information.

  • BER Measurement Loopback Type D Option - allows you to measure BER on GSM signals with Frame Erasure and Unreliable Frame Rate Signaling. See TCH Parameters for information on how to set the mobile loopback type. See GSM Bit Error Measurement for information on how to make Loopback type D BER measurement.
  • Settable NMO - allows you to set the Network Mode of Operation between 1 and 3. See User Configurable Cell Parameters .
  • Enable/Disable Network Initiated PDP Contexts - allows you to disable Network Initiated PDP Contexts to reduce unnecessary messaging. See "Network Initiated PDP Context" on page 6 .
  • Settable USF Granularity - allows you to specify the number of RLC/MAC blocks to transmit per decoded USF. See Assigned USF Granularity .
  • Downlink DTx - allows you to test the mobile's ability to detect periodic downlink transmissions. See Discontinuous Transmission
  • Reduced RLC polling for improved uplink throughput - allows you to control the uplink data throughput by setting the Final Block Polling rate. See Final Block Polling .
  • BLER Algorithm Change - allows you to improve the accuracy of BLER measurement by setting the Early Re-Transmission Sate to OFF. See Early Re-Transmissions
  • Selectable LAU and RAU Reject causes - allows you to configure the test set to reject the Location Area Update (LAU) or Routing Area Update (RAU) request from the mobile station. See Location Area Update Rejection and Routing Area Update Rejection .
  • BFI measurement of AMR and HR signals - allows you to make BFI measurement when the speech channel mode is set to half-rate (HR), adaptive full-rate (AFS) or adaptive half-rate (AHS). See GSM Bad Frame Indication (BFI) Measurement Description .
  • FER measurement of HR signals - allows you to make FER measurement when the speech channel mode is set to half-rate (HR). See GSM Frame Erasure Rate (FER) Measurement Description ,
  • Multislot Class 34 - Multislot Class support has been extended for mobile stations that are multislot class 34 capable. Multislot Class 34 supports 1x5 (downlink x uplink) configuration. See Supported Multislot Classes .
  • Cell Selection Indicators - indicates on which frequency/cell the cell selection after channel release will be performed. See Cell Selection Indicator .
  • Settable SMSC Address - identifies the originating SMS Service Center address for Mobile Terminated transfer. See SMSC Address .
  • Unused Dummy Burst - allows you to set the power level for the unused bursts on the downlink traffic channel. See CALL:TCHannel:POWer[:AMPLitude]:UNUSed? and CALL:TCHannel:PREDuction:UNUSed .
  • Power Reduction Mode - allows you to set the transmission power used to transmit a current downlink RLC/MAC blocks in the GPRS/EGPRS network. See Power Reduction Mode .
  • RACH/PRACH Timing Error - measures the timing difference between the expected and the actual of the access burst for the RACH/PRACH. See CALL:STATus:PRAChannel:TERRor? and CALL:STATus:RACHannel:TERRor? .

Hardware Requirements

http://www.agilent.com/find/8960upgrades

_____________________________________________________________________________________________________

T.03.08 Special Release (E6701T) - July 2007

The E6701T can only be loaded onto an E5515C with Special High Data Rate Hardware (or a test set with the equivalent hardware upgrades). Loading the E6701T onto an E5515B or E5515C without the appropriate hardware upgrades will cause the test set to lock up.

Note, the Special High Data Rate Hardware required to support the E6701T meets the E6701E measurement parametric specifications in a temperature range of 25 °C +/- 5 °C, and has an operating temperature range of 0 to 35 °C.

The features and functionality offered in this release are identical to those offered in the E.02.08 Release (E6701E) - July 2007 , with the following exception:

  • You must use the LAN 2 PORT for transferring data to the test set.

For information on how to use these E6701T features, see E6701U User Documentation .

A downloadable version of the Online User's Guide (CHM Help File) that is specific to this release is available at:

http://www.home.agilent.com/upload/cmc_upload/All/E1968A_A08_E6701E_E02_E6701T_T03_E6704A_Ref_Guide.chm

To properly view the CHM Help File, you must save it to your desktop (rather than "Open" it from the Internet). For Windows XP, you must also then right-click on the file and select Properties>>Unblock.

E.02.08 Release (E6701E) - July 2007

The E6701E Release E.02 includes all of the features and functionality present in the E1968A GSM/GPRS/EGPRS Test Application Release A.08 (see "A.08.08 Release - July 2007" ).

A downloadable version of the Online User's Guide (CHM Help File) that is specific to this release is available at:

http://www.home.agilent.com/upload/cmc_upload/All/E1968A_A08_E6701E_E02_E6701T_T03_E6704A_Ref_Guide.chm

To properly view the CHM Help File, you must save it to your desktop (rather than "Open" it from the Internet). For Windows XP, you must also then right-click on the file and select Properties>>Unblock.

Note that this Online User's Guide includes documentation for the following features that are only available in the E6701F (which is available to GSM/GPRS/EGPRS Lab Application Annual Contract owners): Digital Audio Interface, Wideband Adaptive Multi-rate (AMR-WB), the UMA/GAN test system, and InterRAT Voice Handover.

Call Processing

The E6701E Release E.02 provides an new setting in the Dual Transfer Mode, which allows you to determine whether or not the half-rate subchannel is used for the CS connection while DTM is triggered. See DTM CS Half Rate Sub Channel for more information.

Hardware Requirements

http://www.agilent.com/find/8960upgrades

_____________________________________________________________________________________________________

F.00.18 Subscription Release (E6701F) - May 2007

This is a subscription release of the E6701F application. In order to provide early access to new features, this subscription release has been partially qualified. The new features present in this release have been bench-tested to verify their performance. The previously existing features in this release have undergone a shortened software qualification cycle to verify that they have not been negatively affected by the new features.

You must have a current GSM/GPRS/EGPRS Lab Application Annual Contract to obtain this subscription release. Contact your Agilent Sales Representative for more information.

This is a maintenance release to resolve known issues. The features offered in this release are identical to those offered in the F.00.13 Subscription Release (E6701F) - April 2007 Release.

_____________________________________________________________________________________________________

U.00.13 Special Release (E6701U) - April 2007

The E6701U can only be loaded onto an E5515C with Special High Data Rate Hardware (or a test set with the equivalent hardware upgrades). Loading the E6701U onto an E5515B or E5515C without the appropriate hardware upgrades will cause the test set to lock up.

You must have the E6701T and a current GSM/GPRS/EGPRS Lab Application Annual Contract to obtain this subscription release. Contact your Agilent Sales Representative for more information.

Note, the Special High Data Rate Hardware required to support the E6701U meets the E6701E measurement parametric specifications in a temperature range of 25 ° C +/- 5 ° C, and has an operating temperature range of 0 to 35 ° C.

The features and functionality offered in this release are identical to those offered in the F.00.13 Subscription Release (E6701F) - April 2007 , with the following exception:

  • You must use the new LAN 2 PORT for transferring data to the test set.

For information on how to uses these U-specific features, see the E6701U User Documentation .

A downloadable version of the Online User's Guide (CHM Help File) that is specific to this release is available at:

http://www.home.agilent.com/upload/cmc_upload/All/E6701_F0013_U0013_E6704A_Ref_Guide.chm

To properly view the CHM Help File, you must save it to your desktop (rather than "Open" it from the Internet). For Windows XP, you must also then right-click on the file and select Properties>>Unblock.

For information on how to use the other common features, see the GSM/GPRS/EGPRS online user's guide located at:

http://wireless.agilent.com/rfcomms/refdocs/gsmgprs/

_____________________________________________________________________________________________________

F.00.13 Subscription Release (E6701F) - April 2007

This is a subscription release of the E6701F application. In order to provide early access to new features, this subscription release has been partially qualified. The new features present in this release have been bench-tested to verify their performance. The previously existing features in this release have undergone a shortened software qualification cycle to verify that they have not been negatively affected by the new features.

You must have a current GSM/GPRS/EGPRS Lab Application Annual Contract to obtain this subscription release. Contact your Agilent Sales Representative for more information.

Note that the TXP measurement behaves the same as "E.01.11 Release (E6701E) - December 2006" , while the TXP measurement description in the online user's guide is for "E.01.18 Release (E6701E) - March 2007" . If you want to use the TXP measurement in this release, please refer to the CHM Help File of "E.01.11 Release (E6701E) - December 2006" to understand how the TXP measurement works. You can use the Online User's Guide for all other features in this release.

A downloadable version of the Online User's Guide (CHM Help File) that is specific to this release is available at:

http://www.home.agilent.com/upload/cmc_upload/All/E6701_F0013_U0013_E6704A_Ref_Guide.chm

To properly view the CHM Help File, you must save it to your desktop (rather than "Open" it from the Internet). For Windows XP, you must also then right-click on the file and select Properties>>Unblock.

Call Processing

  • Digital Audio Interface- Allows you to perform the bit exact test of the speech coder/decoder through Digital Audio Interface of the mobile station. See Digital Audio Interface (DAI) Description for more information
  • Wideband Adaptive Multi-Rate (AMR-WB) - AMR-WB provides excellent speech quality due to wider speech bandwidth. The mobile station can change AMR-WB parameters using the RATSCCH. The test set can support three bit rates (6.6, 8.85 and 12.65 kbit/s) of the AMR-WB on GMSK traffic channel currently. See Wideband Adaptive Multi-Rate (AMR-WB) Feature Descriptions for more information.
  • The UMA/GAN (Unlicensed Mobile Access / Generic Access Network) test system- Allows you to perform lab based functional, application, and pre-conformance testing of dual mode enabled UMA/GAN handsets. See UMA/GAN Test System for more information.

    The UMA/GAN test system is built around the test set's existing capabilities to provide GERAN cell and Core Network emulation. To aid in simulation of the GAN "cell" in the system, Agilent provide proprietary test focused GAN Controller (GANC) emulation software (with a product number of E6962A) for use with the system. This software is capable of communicating with a connected MS using the standardized GAN Up interface protocols, namely GA-RC, GA-CSR, and GA-PSR. The Agilent GANC also connects the test set in the UMA/GAN test system to make use of the test set's core network capabilities via modified BSSAP & BSSGP protocols. The combination of these interfaces (Up interface protocols and BSSAP & BSSGP protocols) at the GANC allows a connected MS to fully make use of the GANC for accessing the test set's core network to perform GAN based speech, data and signaling procedures.

    Note that you must have the E6962A GAN Controller to build the UMA/GAN test system. Contact your Agilent Sales Representative for more information.

    You can perform the following tests with the UMA/GAN test system.

    • GAN discovery and registration procedures
    • MO and MT voice calls via GAN
      • Support for configurable AMR FR/HR & GSM FR/HR/EFR channel modes.
      • Currently the only speech mode available is to have the uplink speech echoed back to the mobile.
      • There is currently no support for the Real-Time Control Protocol (RTCP).
    • MO and MT GSM SMS via GAN (including binary / concatenated messages)
    • MO and MT GPRS SMS via GAN (including binary / concatenated messages)
    • GPRS IP data connections via GAN
    • GAN Rove-in / Rove-out procedures
    • Network initiated handover from GERAN to GAN (Handover-in)
    • MS/GANC initiated handover from GAN to GERAN (Handover-out)
    • Network initiated handover from GAN to GERAN
    • View MS reports sent to GANC
    • View current MS GAN status
    • GAN protocol logging via Ethereal (a free third party software), cellular signaling and traffic logging via WPA.
  • InterRAT Voice Handover - provides the ability to test a mobile station's behavior during handover (CS Voice handover and DTM handover) from or to a WCDMA cell. See Two-Cell Test System for more information.

Hardware Requirements

http://www.agilent.com/find/8960upgrades

_____________________________________________________________________________________________________

T.01.18 Special Release (E6701T) - March 2007

This is a maintenance release to resolve known issues. The features offered in this release are identical to those offered in the T.01.11 Special Release (E6701T) - December 2006 .

A downloadable version of the Online User's Guide (CHM Help File) that is specific to this release is available at:

http://www.home.agilent.com/upload/cmc_upload/All/E1968A_A07_E6701E_E01_T01_Ref_Guide.chm

To properly view the CHM Help File, you must save it to your desktop (rather than "Open" it from the Internet). For Windows XP, you must also then right-click on the file and select Properties>>Unblock.

E.01.18 Release (E6701E) - March 2007

This is a maintenance release to resolve known issues. The features offered in this release are identical to those offered in the E.01.11 Release (E6701E) - December 2006 .

A downloadable version of the Online User's Guide (CHM Help File) that is specific to this release is available at:

http://www.home.agilent.com/upload/cmc_upload/All/E1968A_A07_E6701E_E01_T01_Ref_Guide.chm

To properly view the CHM Help File, you must save it to your desktop (rather than "Open" it from the Internet). For Windows XP, you must also then right-click on the file and select Properties>>Unblock.

T.01.11 Special Release (E6701T) - December 2006

The E6701T can only be loaded onto an E5515C with Special High Data Rate Hardware (or a test set with the equivalent hardware upgrades). Loading the E6701T onto an E5515B or E5515C without the appropriate hardware upgrades will cause the test set to lock up.

Note, the Special High Data Rate Hardware required to support the E6701T meets the E6701E measurement parametric specifications in a temperature range of 25 ° C +/- 5 ° C, and has an operating temperature range of 0 to 35 ° C.

The features and functionality offered in this release are identical to those offered in the E.01.11 Release (E6701E) - December 2006 , with the following exception:

  • You must use the new LAN 2 PORT for transferring data to the test set.

For information on how to uses these T-specific features, see the E6701U User Documentation .

A downloadable version of the Online User's Guide (CHM Help File) that is specific to this release is available at:

http://www.home.agilent.com/upload/cmc_upload/All/E1968A_A07_E6701E_E01_T01_Ref_Guide.chm

To properly view the CHM Help File, you must save it to your desktop (rather than "Open" it from the Internet). For Windows XP, you must also then right-click on the file and select Properties>>Unblock.

_____________________________________________________________________________________________________

E.01.11 Release (E6701E) - December 2006

The content of this guide includes all of the features and functionality present in the E1968A GSM/GPRS/EGPRS Test Application Release A.07 (see A.07.12 Release - December 2006 ) and the E6701E GSM/GPRS/EGPRS Lab Application pre-release E.00.12 (see E.00.12 Subscription Release (E6701E) - August 2006 ).

A downloadable version of the Online User's Guide (CHM Help File) that is specific to this release is available at:

http://www.home.agilent.com/upload/cmc_upload/All/E1968A_A07_E6701E_E01_T01_Ref_Guide.chm

To properly view the CHM Help File, you must save it to your desktop (rather than "Open" it from the Internet). For Windows XP, you must also then right-click on the file and select Properties>>Unblock.

Call Processing

  • SACCH LAPDm Format Selection - Allows you to select which LAPDm frame format is used for SACCH. The LAPDm Format specification changes since Release 1996(R96). LAPDm Format B is used before R96 while LAPDm Format B4 is used after R96. You can select either of them according to the LAPDm Format of your mobile station. See Cell Parameters for more information.
  • Measurement Channel Selection in BCH Only Mode - Allows you to choose which channel (RACH, TCH or PDTCH) is measured in BCH Only Mode (GSM BCH, GPRS BCH or EGPRS BCH). See Measurement Channel in BCH Only Mode for more information.
  • 3 Digit MNC for GSM850 - Allows you to choose if the BCCH should be configured using the standard 2-digit MNC (J-STD-007 coding) or the 3-digit MNC (J-STD-007A coding, section 2.10.5.1.3). See Cell Identification Parameters for more information.
  • Timeslot zero - Allows you to establish a voice call on timeslot 0 as well as the existing functionality of timeslots 1 through 7. Time slot 0 is available only when the ARFCN of BCH and TCH do not match, however, if BCH and TCH use different bands, Timeslot 0 can be used even if the ARFCN of BCH and TCH match. See Configuring the Traffic Channel (TCH) Parameters .

Measurements

  • Enhanced Phase and Amplitude versus Time Measurement - The Enhanced Phase and Amplitude versus Time Measurement allows you to select the Filter Type for the bandwidth filter. See Phase and Amplitude versus Time Measurement Description for more information.
  • Enhanced Transmit Power Measurement - The enhanced TXP measurement provides the Burst Power and Estimated Carrier Power measurements for 8PSK or GMSK modulated signals. You can measure up to 4 uplink bursts with a single capture on one TDMA frame. See Transmit Power Measurement Description for more information.

Hardware Requirements

http://www.agilent.com/find/8960upgrades

_____________________________________________________________________________________________________

T.00.08 Special Release (E6701T) - August 2006

The E6701T can only be loaded onto an E5515C with Special High Data Rate Hardware (or an instrument with the equivalent hardware upgrades). Loading the E6701T onto an E5515B or E5515C without the appropriate hardware upgrades will cause the test set to lock up.

Note, the Special High Data Rate Hardware required to support the E6701T meets the E6701D measurement parametric specifications in a temperature range of 25 ° C +/- 5 ° C, and has an operating temperature range of 0 to 35 ° C.

The features and functionality offered in this release are identical to those offered in the E.00.12 Subscription Release (E6701E) - August 2006 , with the following exception:

  • You must use the new LAN 2 PORT for transferring data to the test set.

For information on how to uses these T-specific features, see the E6701U User Documentation .

A downloadable version of the Online User's Guide (CHM Help Fiel) that is specific to this release is available at:

http://www.home.agilent.com/upload/cmc_upload/All/E1968A_A_06_E6701E_E_00_12_T_00_08_Ref_Guide.chm

NOTE: To properly view the CHM Help File, you must save it to your desktop (rather than "Open" it from the Internet). For Windows XP, you must also then right-click on the file and select Properties>>Unblock.

_____________________________________________________________________________________________________

E.00.12 Subscription Release (E6701E) - August 2006

You must have the E6720 Option 001 Lab Application Annual Upgrade Contract to obtain this release. Contact your Agilent Sales Representative for more information.

This is not the first pre-release of this product. See E.00.08 Subscription Release (E6701E) - March 2006 and E.00.05 Subscription Release (E6701E) - August 2005 for other pre-released features available in the E6701E lab application.

A downloadable version of the Online User's Guide (CHM Help File) that is specific to this release is available at:

http://www.home.agilent.com/upload/cmc_upload/All/E1968A_A_06_E6701E_E_00_12_T_00_08_Ref_Guide.chm

NOTE: To properly view the CHM Help File, you must save it to your desktop (rather than "Open" it from the Internet). For Windows XP, you must also then right-click on the file and select Properties>>Unblock.

This software release adds the following features:

Configuration

  • Added support for two-cell inter-RAT data cell reselection and Cell Change Order (WCDMA/HSDPA <--> GSM/GPRS/EGPRS). See Two-Cell Test System .

Call Processing

  • Enhanced Dual Transfer Mode - This allows a CS voice call to be established without aborting the PS session, the test set can also delay the release of the CS connection until sufficient Packet System Information messages have been received by the MS so that the PS can be maintained without the presence of the CS connection. See Dual Transfer Mode for more information.
  • Multiple PDP Context - This allows multiple simultaneous services active within the mobile station, each of these services is allocated a separated IP address and associated QoS. See QoS Profile for more information. Note, only the Primary PDP context is available in the test set for each DUT IP Address.
  • Repeated Downlink FACCH- Allows the Downlink FACCH signalling to be repeated to improve the robustness of the signalling link. See Repeated Downlink FACCH for more information.
  • Repeated SACCH- Allows the Uplink and Downlink SACCH block to be repeated to improve the robustness of the signalling link. See Repeated SACCH for more information.
  • Packet Uplink Ack/Nack Interval- Allows the ability to modify the rate at which the GPRS/EGPRS RLC/MAC Packet Uplink Ack/Nack messages are sent to the mobile station during an uplink TBF. See Packet Uplink Ack/Nack Interval for more information.
  • RLC/MAC Window Size- Allows the ability to set different RLC/MAC Window Size for Data Connection Types. See Window Size for more information.
  • Enhanced Measurement Reports
    • Add Enhanced Measurement Reports screen for SACCH Measurement Reports and Network Control Measurement Reports. See Enhanced SACCH Neighbour Reports Screen and Enhanced Network Control Neighbour Reports Screen .
    • Add Reporting Priority setting for all GPRS neighbour cells. See Configuring the PBCCH BA Table
    • Adds the ability to specify a BCC, NCC and Reporting Priority for GSM neighbour cells. See Configuring the BCH BA Table
    • Add new Cell Parameters for configuring the 3G neighbour Measurement Reports. See Cell Parameters

    See Measurement Reports for more information.

Hardware Requirements

http://www.agilent.com/find/8960upgrades

_____________________________________________________________________________________________________

D.03.46 Release (E6701D) - July 2006

The only change in this release of the E6701D is that the Phase and Amplitude versus Time Measurement now automatically calibrates the phase and amplitude results. The measurement speed is now much quicker with the new, on-the-fly calibration, which is performed automatically when you run this measurement for Discrete and Continuous waveforms. See Phase and Amplitude versus Time Measurement Description for more details.

The CHM Help File for the this release is located at:

http://www.home.agilent.com/upload/cmc_upload/All/E1968A_E6701D_A_06_D_03_Ref_Guide.chm

NOTE: The URL above does not include the Phase and Amplitude versus Time Measurement changes.

NOTE: To properly view the CHM Help File, you must save it to your desktop (rather than "Open" it from the Internet). For Windows XP, you must also then right-click on the file and select Properties>>Unblock.

_____________________________________________________________________________________________________

This software release adds the following features:

Configuration

  • Added support for Testing Push-to-talk Over Cellular function. The Application Note for this feature is located at:

    http://cp.literature.agilent.com/litweb/pdf/5989-5385EN.pdf

T.00.04 Special Release (E6701T) - May 2006

This is a maintenance release to resolve known issues. The features offered in this release are identical to those offered in the T.00.02 Special Release (E6701T) - April 2006 .

_____________________________________________________________________________________________________

T.00.02 Special Release (E6701T) - April 2006

The E6701T can only be loaded onto an E5515C with Special High Data Rate Hardware (or an instrument with the equivalent hardware upgrades). Loading the E6701T onto an E5515B or E5515C without the appropriate hardware upgrades will cause the test set to lock up.

Note, the Special High Data Rate Hardware required to support the E6701T meets the E6701D measurement parametric specifications in a temperature range of 25 ° C +/- 5 ° C, and has an operating temperature range of 0 to 35 ° C.

The features and functionality offered in this release are identical to those offered in the E.00.08 Subscription Release (E6701E) - March 2006 , with the following exception:

  • You must use the new LAN 2 PORT for transferring data to the test set.
For information on how to use these T-specific features, see the E6701U User Documentation .

For information on how to use the features that are common to the E6701E and E6701T, see the following CHM Help File:

http://www.home.agilent.com/upload/cmc_upload/All/E1968A_E6701E_A_06_E_00_08_Ref_Guide.chm

NOTE: To properly view the CHM Help File, you must save it to your desktop (rather than "Open" it from the Internet). For Windows XP, you must also then right-click on the file and select Properties>>Unblock.

_____________________________________________________________________________________________________

E.00.08 Subscription Release (E6701E) - March 2006

You must have the E6720 Option 001 Lab Application Annual Upgrade Contract to obtain this release. Contact your Agilent Sales Representative for more information.

A downloadable version of the Online User's Guide (CHM Help File) that is specific to this release is available at:

http://www.home.agilent.com/upload/cmc_upload/All/E1968A_E6701E_A_06_E_00_08_Ref_Guide.chm

NOTE: To properly view the CHM Help File, you must save it to your desktop (rather than "Open" it from the Internet). For Windows XP, you must also then right-click on the file and select Properties>>Unblock.

This is not the first pre-release of this product. See E.00.05 Subscription Release (E6701E) - August 2005 for other pre-released features available in the E6701E lab application.

This software release adds the following features:

Configuration

  • Enhancements to the Two Cell Test System feature (available in the E.00.05 pre-release)- Additional configurable parameters have been added. This includes the addition of the PBCCH BA Table that allows you to configure neighbour cells to be reported by the mobile station (see Configuring the PBCCH BA Table ). Many of the Control Parameters found in 3GPP TS 05.08 section 9 are now available.

Call Processing

  • Access Burst Type for Packet Control Acknowledgments - The test set allows you to configure the control acknowledgment type as an RLC/MAC control block or as a set of four Access Bursts.
  • Calls via the SDCCH - The test set now allows call setup signalling to take place on either the FACCH or the SDCCH.
  • Combined and Non-Combined BCH/SDCCH - The test set now supports the 3GPP TS 05.02 section 6.4 channel combination iv+vii to provide a combination where the BCH and the SDCCH exist on separate physical channels.
  • In addition to the Delayed Downlink TBF and Extended Uplink TBF enhancements offered in the E.00.05 pre-release- You can now configure whether the test set allows the re-establishment of an uplink TBF before the current TBF is released, see TBF Re-establishment . These features allow you to optimize the performance of the data link for real-time traffic uses such as Push-to-talk over Cellular (PoC).
  • You can now set the DNS Server IP Addresses (primary and secondary).
  • Additional Measurement Reports (from the mobile station) can now be viewed on the test set's front panel. There are now four separate Measurement Report screens, these include: Summary Measurement Reports, SACCH Measurement Reports (the Rx Level and RX Qual now report Full and Sub values; Neighbour Cell Reports are shown on this screen), PACCH Measurement Reports, and Network Control Measurement Reports (Neighbour Cell Reports are shown on this screen).
  • Multi-Page and Binary Cell Broadcast - Cell Broadcast functionality has been enhanced to allow messages up to 15 pages in length to be transmitted. Support has also been added for messages that contain binary data. For more information, see Cell Broadcast Service (CBS) .
  • Multislot Class support has been extended for mobile stations that are multislot class 30-33 capable (up to 5 timeslots on the downlink). New multislot configurations include (downlink x uplink): 2x4, 3x3, 4x2, and 5x1. See Supported Multislot Classes .

Data Channel

  • Continuous Ping - The number of pings the test set sends the mobile station before terminating has been extended from 1000 pings to 217483647 to allow much more time to pass before it needs to be restarted.

Manual User Interface Changes

This release contains changes to the manual user interface to improve usability. The Cell Info screen no longer contains the BCH Configuration, Last Location , and Neighbour Cell Report windows. Instead, this screen displays current cell configuration parameters categorized as Cell Operation, Cell Identification , and Cell Parameters . The Cell Info screen is now labeled Cell Information .

The Call Setup Screen has been combined DUT Information and DUT Class Information sections into one section called DUT Information . This new DUT Information section now reports Last LAC, Last MCC , and Last MNC in addition to the existing parameters reported by the DUT Information and DUT Class Information sections.

Certain parameters have been moved to the proper locations. The following table lists the previous and new locations of each parameter that was relocated as well as the location of new parameters introduced in this release.

Parameter Name | Previous Menu Location | New Menu Location
3 Digit MNC for PCS1900 | Cell Parameters | Cell Identification
Asymmetric Guard Period Length | Cell Parameters | Receiver Control
BA Table | Cell Info | Cell Lists
BCC (Base Station Colour Code) | Cell Parameters | Cell Identification
BCH Type | BCH Setup | Cell Operation
BEP Period | New Parameter | Cell Parameters
Block Sequence Countdown Value Max | New Parameter | Cell Parameters
C2 Penalty Time | New Parameter | Cell Parameters
C2 Temporary Offset | New Parameter | Cell Parameters
CA Table | Cell Info | Cell Lists
Call Originate Timeout | Cell Parameters | Paging Parameters
Cell Bar Access | New Parameter | Cell Parameters
Cell Bar Qualify | New Parameter | Cell Parameters
Cell Identity | New Parameter | Cell Identification
Cell Reselect Hysteresis | New Parameter | Cell Parameters
Cell Reselect Offset | New Parameter | Cell Parameters
DRX Timer Max | New Parameter | Cell Parameters
Dual Transfer Mode | BCH Setup | Cell Operation
EGPRS Link Qual Meas Mode | RLC/MAC | Control Channel Parameters
Extended Uplink TBF State | BCH Setup | Cell Operation
Get IMEI at Call Setup | Cell Parameters | Identity Request Setup
LAC (Location Area Code) | Cell Parameters | Cell Identification
MCC (Mobile Country Code) | Cell Parameters | Cell Identification
MCS/SGSN Revision | BCH Setup | Cell Operation
MNC (Mobile Network Code) | Cell Parameters | Cell Identification
Mobile DTX State | BCH Setup | Cell Operation
MS TX Power Max CCH (GPRS) | New Parameter | Cell Parameters
Multiband Reporting | New Parameter | Cell Parameters
N avg I | New Parameter | Cell Parameters
NCC (Network Colour Code) | Cell Parameters | Cell Identification
NCC Permitted | New Parameter | Cell Parameters
Network Control Non-DRX Period | New Parameter | Cell Parameters
Network Control Order | New Parameter | Cell Parameters
Network Control Reporting Period (Idle) | New Parameter | Cell Parameters
Network Control Reporting Period (Transfer) | New Parameter | Cell Parameters
Packet Control Ack Type | BCH Setup | Cell Operation
Paging IMSI | Control | Paging Parameters
Paging Identity Type | Cell Parameters | Paging Parameters
Paging Mode | Cell Parameters | Paging Parameters
Paging Multiframes | Cell Parameters | Paging Parameters
PBCCH | BCH Setup | Cell Operation
PC Measurement Channel | New Parameter | Cell Parameters
Persistent Attach State | BCH Setup | Cell Operation
PRACH Length | BCH Setup | Cell Operation
RAC (Routing Area Code) | Cell Parameters | Cell Identification
RX Lev Access Min | New Parameter | Cell Parameters
Serving Cell | BCH Setup | Cell Operation
T avg T | New Parameter | Cell Parameters
T avg W | New Parameter | Cell Parameters
TMSI Assignment | Cell Parameters | Paging Parameters
TMSI | Cell Parameters | Paging Parameters
TX Level FACCH Signaling | BCH Setup | Cell Operation
Uplink Frame Segmentation | Cell Parameters | Receiver Control

Also, there have been some minor changes to the names of some of the parameters. These changes are as follows and the location of these parameters are as follows:

Previous Parameter Name | New Parameter Name | Menu Location
CS Paging Identity Type | Paging Identity Type | Paging Parameters (previously located in the Cell Parameters menu)
DCS1800 Max CCH Power Offset | MS TX Power Max CCH DCS1800 Offset | Cell Parameters (No change)
MS TX Power Max CCH | MS TX Power Max CCH (GSM) | Cell Parameters (No Change)

Hardware Requirements

http://www.agilent.com/find/8960upgrades

_____________________________________________________________________________________________________

D.03.32 Release (E6701D) - January 2006

A downloadable version of the Online User's Guide (CHM Help File) that is specific to this release is available at:

http://www.home.agilent.com/upload/cmc_upload/All/E1968A_E6701D_A_06_D_03_Ref_Guide.chm

NOTE: To properly view the CHM Help File, you must save it to your desktop (rather than "Open" it from the Internet). For Windows XP, you must also then right-click on the file and select Properties>>Unblock.

This release inherits all the features offered in the E1968A A.06.09 Release - August 2005 as well as the A.06.31 Release - January 2006 . These features include the addition of the following:

Call Processing

  • TGSM810 Band (see Frequency Banded Parameters )
  • Coupling of the Band Indicator parameter to the BCH Cell Band setting. That is, if the BCH Cell Band is changed to DCS or PCS, the Band Indicator is updated to match the BCH Cell Band setting. For more information, see CALL:BINDicator .

Measurements

  • Phase and Amplitude vs. Time Measurement (see Phase and Amplitude versus Time Measurement Description )
  • ORFS Digital measurement filter type setting (see Output RF Spectrum Measurement Description )

    The ORFS measurement meets improved Agilent product specifications when using the digital measurement filter (Filter Type set to Digital or Auto), but only for E5515C test sets with serial number > GB46040000 and E5515B test sets with serial number > GB46050000. Upgraded E5515s may also meet specifications. Contact your Agilent Sales Representative for more information.

  • Tail Bit Demodulation parameter that allows you to control how the test set demodulates the tail bits during a Phase and Frequency Error measurement. The command to set this parameter is SETup:PFERror:TBDemod .

Hardware Requirements

http://www.agilent.com/find/8960upgrades

_____________________________________________________________________________________________________

E.00.05 Subscription Release (E6701E) - August 2005

You must have the E6720 Option 001 Lab Application Annual Upgrade Contract to obtain this release. Contact your Agilent Sales Representative for more information.

A downloadable version of the Online User's Guide (CHM Help File) that is specific to this release is available at:

http://www.home.agilent.com/upload/cmc_upload/All/E1968A_E6701E_A_06_E_00_05_Ref_Guide.chm

NOTE: To properly view the CHM Help File, you must save it to your desktop (rather than "Open" it from the Internet). For Windows XP, you must also then right-click on the file and select Properties>>Unblock.

This software release adds the following features:

Configuration

  • Two-Cell Test System - This provides the ability to test a mobile station's behavior during transition to a different cell via a handover or cell reselection process.

Call Processing

  • Dual Transfer Mode - This allows a simultaneous circuit switched voice connection and packet switched data connection on the same ARFCN.
  • TMSI Paging - The test set now allows the mobile station to be identified by a TMSI (Temporary Mobile Subscriber Identity) during circuit switched domain paging procedures. Previous revisions supported IMSI paging only. For more information, see the function description for the TMSI assignment parameter, CALL[:CELL]:TMSI:ASSignment .
  • Delayed Downlink TBF and Extended Uplink TBF - You can now configure the test set to delay the downlink TBF (Temporary Block Flow) following the transmission of a final data block, rather than instantly releasing it. You can also extend the duration of the uplink TBF. These parameters allow you to optimize procedures that are designed to reduce the number of times a TBF needs to be set up from scratch.

Hardware Requirements

http://www.agilent.com/find/8960upgrades

_____________________________________________________________________________________________________

D.02.10 Release (E6701D) - May 2005

A downloadable version of the Online User's Guide (CHM Help File) that is specific to this release is available at:

http://www.home.agilent.com/upload/cmc_upload/All/E1968A_E6701D_A.05_D.02_Ref_Guide.chm

NOTE: To properly view the CHM Help File, you must save it to your desktop (rather than "Open" it from the Internet). For Windows XP, you must also then right-click on the file and select Properties>>Unblock.

This firmware release provides support for a variety of new features such as: Speech Echo Loopback Delay, IMSI Attach, PACCH PSI, Network Detach Cause, UTRAN FDD neighbour cell reports, and CRC error reporting for the Bit Error and Block Error Measurements.

Hardware Requirements

There are no new hardware requirements for this release.

Call Processing

  • The Speech Echo Loopback Delay can now be varied from 0 to 1 second. See the description for the downlink speech parameter Echo for more details.
  • You can now control whether or not the test set will send Packet System Information (PSI) messages on the PACCH, and which type of PSI messages (SI1 or SI13) are sent depending on the BCH configuration. The command to configure this parameter is CALL:(PACCH|PACChannel):PSInfo .
  • You can choose which type of Detach Request the test set sends the mobile station in the Detach Type Information Element .
  • Additional parameters are added in this release to configure 3G FDD Neighbour Cells . Included in the added parameters are 3G Measurement Parameter Description and FDD Information Element.
  • You can control the state of the IMSI Attach flag with the command CALL[:CELL]:IATTach[:STATe]? .
  • The Block Polling Interval now has a separate setting for each applicable connection type. See Block Polling Parameters for more information.
  • The Restart on Fatal Error feature provides the ability to configure the test set to automatically restart if a fatal error occurs.

Measurements

  • The Bit Error Measurement and Block Error Measurement have been updated to now report CRC errors in addition to their existing reports. See the commands FETCh:BERRor:COUNt:CRC? and FETCh:BLERror:CRC? for more details.
  • The EDGE Dynamic Power (EDP) Measurement is now available in GSM and GPRS test modes as well as the EGPRS test mode. If you only have a GSM/GPRS license, the EDP measurement will only measure GMSK modulated busts.

D.01.18 Release (E6701D) - January 2005

A downloadable version of the Online User's Guide (CHM Help File) that is specific to this release is available at:

http://www.home.agilent.com/upload/cmc_upload/All/GSM_GPRS_EGPRS_Ref_Guide.chm

NOTE: To properly view the CHM Help File, you must save it to your desktop (rather than "Open" it from the Internet). For Windows XP, you must also then right-click on the file and select Properties>>Unblock.

This firmware release adds support for many new features. Some examples of the new call processing options include AMR, Frequency Hopping, Calling Party Number, support for binary SMS and MMS testing, and the ability to specify a UTRAN FDD Neighbour cell list. The new measurements include the In-Band Frame Error measurement to measure AMR, the Frequency Stability measurement, and enhancements to the BER measurement to support Circuit Switched Data.

Hardware Requirements

  • Previous hardware requirements still apply.

Call Processing

  • Additional header and message configuration has been added to the existing support for SMS message testing to accommodate the sending and receiving of binary SMS messages. Binary SMS messages are used in applications such as WAP Push, MMS, ringtones, and picture messaging. See the following links for additional information:
    • Short Message Service (SMS)
    • Point-to-Point SMS
    • Multimedia Service (MMS) Messages
  • An HTTP Interface has been added to facilitate testing Short Message Service (SMS) messages and Multimedia Service (MMS) messages. For more detailed information on the interface, see HTTP Interface for SMS - Introduction .
  • AMR has been added to ensure a mobile station changes to appropriate codecs as RF conditions change. The mobile station can change AMR parameters using the RATSCCH. There are different modes the test set allows such as MS control (where the mobile station can request which codec to change to) or Stress Mode (where the test set commands the mobile station to change codecs quickly). See Adaptive Multi-Rate (AMR) Feature Descriptions for more details.
  • The Calling Party Number (Caller ID) feature allows you to enter the originating caller identity in the test set and view the Calling Party Number on the mobile station when a mobile terminated call or mobile terminated SMS message is received. See CALL:CPNumber for the commands to set the Calling Party Number.
  • The Persistent Attach feature has been added that allows the mobile station to stay attached to the test set when you switch between the Active Cell (serving cell GPRS) and Active Cell (serving cell EGPRS) operating modes when Persistent Attach is enabled. You can change the state of Persistent attach with the command CALL:MS:PATTach[:STATe] .
  • A Custom option has been added to allow you to customize the payload pattern. For more information on the custom payload pattern to be sent on a speech frame, see Speech . For more information on the custom payload pattern to be sent on the RLC data block, see Payload Patterns . The payload pattern can only be configured via GPIB.
  • The ETSI Type A operating mode has been enhanced to allow you to set the Protocol Data Unit (PDU) count to transmit a finite or infinite number of PDUs. See ETSI Type A for more details. The PDU count can only be set via GPIB. The command to set the PDU count is CALL:FUNCtion:DATA:ETSIA:PDUNit|PDU:COUNt .
  • You can now specify a list of UTRAN FDD neighbour cells for the test set to transmit and the mobile station to decode and measure. See 3G FDD Neighbour Cells for more details. The command to create the UTRAN FDD neighbour cell list is CALL[:CELL]:UTRAN:FDDuplex:TABLe .
  • The test set now supports up to GPRS multislot class 12 and EGPRS multislot class 12. See Supported Multislot Classes .

  • Frequency Hopping has been added to improve the signal to noise ratio by adding frequency diversity. See Frequency Hopping for more details. The commands to change the frequency hopping parameters are outlined in Configuration of Frequency Hopping Parameters .

  • The ability to set the number of Unassigned USF BLER blocks has been added as an enhancement to the existing Assigned USF BLER feature. See Uplink State Flag (USF) BLER for more details and the commands used to configure this feature. Extended Dynamic Allocation and Auto Dynamic Allocation have been added to the Medium Access Mode options. See Medium Access Mode for more details.

  • The ability to configure the value of the Relative Reserved Block Period (RRBP) is available. This setting indicates the number of TDMA frames the mobile station waits before transmitting the uplink RLC/MAC block relative to the first TDMA frame of the downlink block containing the RRBP value. See Relative Reserved Block Period (RRBP) for more information. The command to change the RRBP value is CALL:(PDTCH|PDTChannel):RRBPeriod .

  • The ability to assign different Modulation Coding Scheme/Puncturing Scheme (MCS/PS) for each downlink timeslot of the multislot configuration is now available when the operating mode is set to EGPRS BCH+PDTCH.
  • Timer 301 (T301) now has a settable range from 1 to 999, inclusive. This timer determines how long the network alerts the mobile station during a mobile terminated call. (See CALL:ORIGinate:TIMeout for more information.)

Measurements

  • The AMR In-Band Frame Error (IFER) measurement has been added to test the Adaptive Muli-Rate (see Adaptive Multi-Rate (AMR) Feature Descriptions ) capability of the mobile station. For more details, refer to In-Band Frame Error (IFER) Measurement Description . The new commands added for this feature are:

    • SETup:IFERror
    • INITiate
    • FETCh:IFERror
    • READ

  • The Frequency Stability measurement has been added. See Frequency Stability Measurement Description for more details. The new commands added for this feature are:
    • SETup:FSTability
    • INITiate
    • FETCh:FSTability
    • READ
  • The Bit Error Rate measurement has been enhanced to support testing Circuit Switched Data (CSD). See Using the GSM Bit Error Measurement for Circuit Switched Data (CSD) Bit Error Testing for more information.

Instruments

  • Data Throughput Monitor (see Data Throughput Monitor ).

_____________________________________________________________________________________________________

C.04.14 Release (E6701C) - January 2005

A downloadable version of the Online User's Guide (CHM Help File) that is specific to this release is available at:

http://www.home.agilent.com/upload/cmc_upload/All/E1968_A03_48_E6701C_C03_48_E6704A_Ref_Guide.chm

NOTE: To properly view the CHM Help File, you must save it to your desktop (rather than "Open" it from the Internet). For Windows XP, you must also then right-click on the file and select Properties>>Unblock.

This firmware release is compatible with GPRS multislot class 12 and EGPRS multislot class 12 capable hardware, which was introduced for the D.01.18 Release (E6701D) - January 2005 . No new features have been added to this version of the firmware.

Support for GPRS multislot class 12 EGPRS multislot class 12 capable hardware

E6701C lab application release C.03.XX and earlier are not compatible with E5515B or E5515C chassis with EGPRS multislot class 12 capable hardware. Loading E6701C C.03.XX or earlier will make the mainframe inoperable and require Agilent service.

This firmware release provides the ability to run E6701C firmware on E5515B or E5515C chassis containing EGPRS multislot class 12 capable hardware. Chassis containing EGPRS multislot class 12 capable hardware include:

  • E5515C with serial numbers >= GB45070001 or E5515CU Option 185 Hardware Upgrade
  • E5515B with serial numbers >= GB45080001 or E5515BU Option 185 Hardware Upgrade

_____________________________________________________________________________________________________

C.03.48 Release (E6701C) - April 2004

A downloadable version of the Online User's Guide (CHM Help File) that is specific to this release is available at:

http://www.home.agilent.com/upload/cmc_upload/All/E1968_A03_48_E6701C_C03_48_E6704A_Ref_Guide.chm

NOTE: To properly view the CHM Help File, you must save it to your desktop (rather than "Open" it from the Internet). For Windows XP, you must also then right-click on the file and select Properties>>Unblock.

This firmware release enhances the BLER measurement. This release also includes fixes to known problems. See Known Problems Corrected in this Release below.

Hardware Requirements

  • Previous hardware requirements still apply.

Measurements

  • The BLER measurement has been enhanced to include the following:
    • user selectable measurement modes.For more details, refer to Block Error Measurement . The new command added for this feature is:
      • SETup:BLERror:ETSIB:MODE .
    • BLER measurement results by timeslot. For more details, refer to BLER Measurement Results by Timeslot . The new command added for this feature is:
      • FETCh:BLERror:BURSt<[1]|2|3|4|5>[:ALL]? .

Known Problems Corrected in this Release

For information on issues in specific firmware releases and for workarounds, see the 8960 Known Issue site at:

http://wireless.agilent.com/rfcomms/issues

Known problems that existed in early versions of firmware that no longer exist in the A.03.48 release are listed below.

  • A non-recoverable error occurs when the PBCCH is switched on and the power is reduced in one downlink on a connection using multiple downlinks.
  • A non-recoverable error occurs after staring the BFI measurement when the channel mode is set to HR speech.
  • The GSM Bad Frame Indication measurement incorrectly includes SID frames in the number of frames sampled when calculating the undetected bad frames ratio result.
  • The GSM Bad Frame Indication measurement incorrectly includes SID frames in the number of frames sampled measurement result.
  • Incorrect values are returned for the Neighbour Cell Report ARFCN.
  • Test set crashes when the INIT:BLER:ON or INIT:BLER:OFF commands are sent.
  • BLER measurement does not work with some phones in ETSI Type B (Ack) mode.

    When in ETSI B acknowledged mode there are two methods of BLER measurement available. These are loopback and ack/nack. Prior to the A.03.32 release only the loopback method was available in this test mode. (The ack/nack method uses the information returned from the phone to compute the BLER, the loopback method relies on the phone looping back the data and the test equipment making the measurement.)At A.03.32 the ack/nack method was added and the default changed to this method when in ETSI B acknowledged mode. (It offers advantages over the loopback method since the BLER associated with individual downlink timeslots can be observed in a single measurement.)This has been shown to cause problems with some phones that don't implement ETSI test mode B ack mode properly. To maintain backward compatibility the default measurement method has been changed to loopback for this and all later releases. The user may select the alternative measurement method if desired through the BLER measurement settings menu.

  • Test set indicates Connected status before a connection is fully established.

    When setting up a GSM voice call the instrument would indicate that the connection was established before it actually was. In this case attempting to make a BER measurement immediately could result in a measurement timeout.

  • Changing channel mode from HR to FR using Handover Setup causes the call to drop.
  • If the BER measurement is on during a change to another Operating Mode, the measurement stops working.
  • Downlink Power in Unused Bursts for GPRS data connections is affected by changes to the GSM PRL.
  • TCH and PDTCH PRL settings are coupled and should not be.
  • GPIB Command for the RLC/MAC Expected Header displayed on the front panel when in Help mode is incorrect.
  • Command SET:PVT:TXP:METHOD displayed on the front panel when in Help mode for setting the PVT measurement TX Power Method is not a valid command.
  • When the BLER measurement is restarted, the Sum of Burst Blocks Tested is not equal to the Total Number of Bursts Tested.
  • Performing a full preset does not clear the BLER Poll Rate value.
  • User's Guide incorrectly states that the BER measurement can be used with a GSM HR connection.
  • The test set is setting the change mark field in packet information messages on the PBCCH and PACCH to different values, causing mobile stations to repeatedly access the packet system information messages unnecessarily.

_____________________________________________________________________________________________________

C.03.32 Release (E6701C) - January 2004

A downloadable version of the Online User's Guide (CHM Help File) that is specific to this release is available at:

http://www.home.agilent.com/upload/cmc_upload/All/E1968A_A03_E6701C_C03_E6704A_Ref_Guide.chm

NOTE: To properly view the CHM Help File, you must save it to your desktop (rather than "Open" it from the Internet). For Windows XP, you must also then right-click on the file and select Properties>>Unblock.

This firmware release adds support for Assisted-GPS (A-GPS) testing. Additionally, two new GSM measurements, Bad Frame Indication and Frame Erasure Rate have also been added. Save and recall registers are also available to increase front panel usability.

Hardware Requirements

  • E5515C requires option H03/K03 to support the E6704A. Starting in February 2004, the E5515C ships with this option as standard hardware.

Call Processing

  • You can now use the test set to verify the Assisted-GPS (A-GPS) capability of your mobile station. See A-GPS (Assisted-GPS) for more details about this feature. The new commands to support this feature are:
    • CALL:PPRocedure:PMEasurement:PIPE
    • CALL:PPRocedure:PMEasurement:PIPE:DATA:RX?
    • CALL:PPRocedure:PMEasurement:PIPE:DATA:RX:AVAilable?
    • CALL:PPRocedure:PMEasurement:PIPE:DATA:TX
    • CALL:PPRocedure:PMEasurement:PIPE:RTIMe
    • CALL:PPRocedure:PMEasurement:PIPE:SEND
  • The front panel user interface has been enhanced to allow changes to the Serving Cell parameter without manually switching the cell off. To accommodate this, three new selections have been added to the Operating Mode menu. These are:
    • Active Cell (GSM) - GSM only BCH
    • Active Cell (GPRS) - GSM + GPRS BCH
    • Active Cell (EGPRS) - GSM + EGPRS BCH

    In addition, the selection Active Cell is no longer available. See Active Cell Operating Mode for more information.

  • The default for the serving cell parameter has changed from EGPRS to GPRS. See CALL[:CELL]:BCHannel:SCELl for more information.
  • The following broadcast channel configuration options have been added:
    • The ability to set the MSC/SGSN Revision to "Release 98 or older" or "Release 99 onwards". For more details, refer to CALL[:CELL]:BCHannel:MSCRevision .
    • The ability to indicate to the mobile station that the cell is DCS or PCS to account for the ARFCN numbers shared by the two bands. For more details, refer to CALL[:CELL]:BINDicator .

Measurements

  • New Measurements
    • GSM Bad Frame Indication has been added. See GSM Bad Frame Indication (BFI) Measurement Description for more information. Information on new commands added for this measurement can be found at:
      • SETup:<BFINdication|BFI>
      • INITiate
      • FETCh:<BFINdication|BFI>
      • READ
    • GSM Frame Erasure Rate has been added. See GSM Frame Erasure Rate (FER) Measurement Description for more information. Information on new commands added for this measurement can be found at:
      • SETup:FFERate
      • INITiate
      • FETCh:FFERate
      • READ

General

  • The ability to save and recall settings has been added. See Save and Recall Registers for more information.

_____________________________________________________________________________________________________

C.01.20 Release (E6701C) - February 2003

The reference guide for this release is available at the following web location. Note: This is a 24.4 MB .pdf file.

http://cp.literature.agilent.com/litweb/pdf/1000-1859.pdf

There is also a CHM format of the user's guide (3.61 MB) for this release available at:

http://www.home.agilent.com/upload/cmc_upload/All/E1968A_A01_E6701C_C01_E6704A_Ref_Guide.chm

NOTE: To properly view the CHM Help File, you must save it to your desktop (rather than "Open" it from the Internet). For Windows XP, you must also then right-click on the file and select Properties>>Unblock.

The E6701C replaces the E6701B.

This firmware release provides you with integrated GSM and GPRS network emulation capability. In addition, support for GSM Circuit Switched Data (CSD) Channels, GSM Short Message Service, GSM Logging and Enhanced-Observed Time Difference (E-OTD) testing have also been added to this release.

Hardware Requirements

  • E5515C requires option 002 to support the E6701C.

  • E5515A does not support E6701C.

  • E5515B will support the E6701C after April 1, 2003 without a hardware upgrade under the following conditions:

    • Option 002 installed AND serial number is >= US40350362 or >= GB40470454, or
    • the test set is already running E1985A Fast Switching with GSM and/or GPRS.

  • Instruments with Serial Numbers prior to US40350362 or GB40470454 (with option 002 installed) can be upgraded with upgrade product number E5515BU option 085 to be able to support the E6701C.

Protocol Logging

This release provides you with additional observation points for logging GSM protocol messages. The additional observation points include RLP, PPP, PPP HDLC, and RRLP. For more details, refer to Protocol Layers and Messages .

Data Channel

Support for GSM Circuit Switched Data (CSD) has been added to the GSM bits to complement the GPRS data channel in GSM. For more details, refer to GSM Circuit Switched Data (CSD)

Call Processing

  • GSM and GPRS network emulation have been integrated in this release. See A.01.20 Initial Release - January 2003 for more information about the effects of this integration.
  • Support for GSM Short Message Service has been added to the existing Short Message Service capability. For more details, refer to Point-to-Point SMS .
  • It is now possible to use the test set to verify the Enhanced-Observed Time Difference (E-OTD) capability of your mobile station. See E-OTD (Enhanced Observed Time Difference) for more details about this feature.

_____________________________________________________________________________________________________

B.01.20 Release (E6701B) - May 2002

The reference guide for this release is available at the following web location. Note: This is a 18.9 MB .pdf file.

http://cp.literature.agilent.com/litweb/pdf/1000-1842.pdf

The E6701B replaces the E6701A.

Summary of Features

  • Web-based Protocol Logging Replaced by Wireless Protocol Advisor Software
  • New: Short Message Service (SMS)
  • New: Protocol Event Trigger Output (PETO)
  • New: PBCCH capability
  • New: Continuous Timing Advance
  • New: Fixed Allocation
  • New: USF BLER
  • New: Mobile Station Measurement Reports
  • New: Enhanced Stack Configurations

Protocol Logging

The previous protocol logging system has been replaced by the Wireless Protocol Advisor software, E6581A. This software expands the features available in protocol logging.

Log GPRS protocol messages using the GPRS Wireless Protocol Advisor software (included with the protocol application). Allows real-time logging of inter-layer and peer-to-peer messages. Includes powerful triggering, filtering, and search capabilities of logs, and decode view for viewing individual bit fields with appropriate labeling for each message.

Short Message Service

Short messages can be sent to and from the DUT. This allows emulation of live GPRS point-to-point SMS (a short message is sent from one MS to another MS via the network), as well as cell broadcast SMS functionality. The cell broadcast SMS service allows short messages to be sent to every MS currently in a particular cell. Cell broadcast messages are repeated at intervals over a period of time, which allows an MS to receive the message even if entering the cell after the first transmission.

Protocol Event Trigger Output

This feature provides a hardware trigger output from the rear panel of the test to control external instruments and devices. It is an extension of the trigger provided in earlier applications. Various frame triggers and protocol message-based triggers are available, based on the downlink in multiple layers of the protocol stack.

The original trigger could be set to trigger on every TDMA frame with user-settable timeslot and symbol positions. PETO offers additionally:

  • Several more frame triggers with varying degrees of frequency
  • Protocol message based triggers on specific downlink messages sent by the test set

PBCCH

Packet Broadcast Control Channel (PBCCH) is a channel which is used when the test set is in Active Cell mode. When a PBCCH is present, the DUT will perform all requests for GPRS services via this channel.

Continuous Timing Advance

Continuous Timing Advance is an alternate method to the previously available Timing Advance assignment method. This is available in the RLC/MAC layer of the Protocol Control Menu. Now the DUT is given parameters to look in a given timeslot for its timing advance value.

Fixed Allocation

Fixed allocation provides more control over transferring data between the test set and the DUT. It provides the DUT with an allocation of uplink blocks which satisfies the number of octets that the DUT believes is necessary to transfer all of its data.

USF BLER

USF BLER is a measurement report viewed on the Call Setup screen. It is an indication of the number of PDTCH blocks incorrectly decoded (USF bits only) by the MS receive path.

GPRS Infrequent Network Events

- accept/reject options for key requests:

  • Attach Accept
  • Attach Reject (with cause)
  • Detach Request (Mobile Terminated)
  • Identity Request
  • Activate PDP Context Accept
  • Activate PDP Context Reject

Mobile Station Measurement Reports

Measurement Reports display measurements from the DUT regarding the quality of the downlink channel. The following channel parameters have data provided:

  • C Value
  • RX Quality
  • Signal Variance
  • Interference Levels

Enhanced Stack Configuration

Several elements of the protocol stack can now be controlled. See Protocol Control for instructions to use the menu.

Six controllable protocol events are listed below. These features are evaluated according to the GSM 04.08 standard.

  • Attach Accept
  • Attach Reject (with cause)
  • Detach Request (Mobile Terminated)
  • Identity Request
  • Activate PDP Context Accept
  • Activate PDP Context Reject

_____________________________________________________________________________________________________

A.01.10 Release (E6701A) - November 2001

The reference guide for this release is available at the following web location. Note This is a 15 MB .pdf file.

http://cp.literature.agilent.com/litweb/pdf/1000-1750.pdf

These are the original features of the E6701A.

The E6701A GPRS Lab Application is a firmware which enables the E5515C Agilent Technologies 8960 Series wireless communications test set to:

  • Log GPRS protocol
  • Use the test set as a data channel for transferring IP datagrams
  • Provide parameter enhancements compared to the E1964 Mobile Test Application

Features

Contains all functionality of the E1964 GPRS Mobile Test Application, A.02 release.

Protocol Logging Features

Logs GPRS Protocol at the following layers:

  • L1_Interface
  • RLC/MAC
  • LLC
  • GMM/SM
  • GSM/L3
  • SNDCP
  • IP

Provides Setup, Start and Stop of Protocol Logging from the front panel, Remote User Interface, and the test set's new Web User Interface. Multiple browser windows can be opened to one test set display, allowing users to share log data and control of logging at multiple locations.

Allows setup of logging to control any or all of seven observation points, corresponding to the logged layers listed above. Allows a user-defined log header. Allows choice between a cyclic or linear buffer, giving the opportunity to write over existing logged data or to stop when the buffer is full.

Displays log results in a web browser, currently supporting Internet Explorer 5.01.

Applicable Standards

Multiple standards apply to this Lab Application. The most relevant are listed here:

  • GPRS 04.60 v. 7.3.1
  • GSM 04.08 v. 7.6.1
  • GSM 04.64 v. 7.3.0

Data Channel

Data Channel allows the test set to be used as a router for transferring IP datagrams between the DUT and anywhere on the network that the test set is connected to.

Includes the ability to set an IP address for the DUT, ping the DUT or any alternate address, control ping setup, and log protocol while using the data channel. All test set measurements except BER are available while using the data channel.

Data Channel is available through the front panel and the Remote User Interface.

Parameter Enhancements

Parameter Enhancements offer extended capability over the E1964 GPRS Mobile Test Application.

Parameter enhancements are available through the front panel and the Remote User Interface.

Parameters that are now variable are:

  • MCC
  • MNC
  • LAC
  • NCC
  • BCC
  • RAC

Other controllable features are:

  • Timing Advance. Timing advance values can now be sent to the DUT, enabling simulation of propagation delays by telling the DUT how much it should offset its transmissions. Actual value is band-dependent.
  • Uplink State Flag. The USF value is sent to the DUT in an immediate assignment message. The DUT can be instructed to transmit on the block corresponding to the new USF.

_____________________________________________________________________________________________________


Uplink State Flag (USF) BLER

Uplink State Flag (USF) BLER

This measurement is not applicable to GSM.

The USF is only used by the mobile station when the test set's Medium Access Mode mode is set to Dynamic Allocation , Extended Dynamic Allocation , or Automatic Dynamic Allocation .

This section details the test set's operation for the following:

Assigned Uplink State Flag (USF) BLER

Unassigned USF Mode

Manual Unassigned USF

Operating Considerations

  • Assigned Uplink State Flag (USF) BLER

    Assigned Uplink State Flag (USF) BLER is a measurement report. It is displayed in the Error Reports section of the Call Setup screen.

    The Assigned USF BLER report is an indication of the number of PDTCH blocks incorrectly decoded (USF bits only) by the mobile station. This report is calculated by counting the number of blocks that the mobile station fails to transmit as a consequence of incorrectly decoding the USF of the block preceding the expected transmission period. This serves as an indication of the mobile station's receiver performance.

    The GPIB command to change this parameter is CALL:(PDTCH|PDTChannel):MACCess[:DYNamic]:USFLag[:ASSigned] .

  • Unassigned USF Mode

    Unassigned Uplink State Flag (USF) BLER is a measurement report. It is displayed in the Error Reports section of the Call Setup screen.

    The Unassigned USF BLER is the ratio of PDTCH blocks in which the USF bits were decoded incorrectly by the mobile station to the total number of PDTCH blocks transmitted from the test set. The Unassigned USF BLER measurement report allows you to verify if the mobile station is transmitting at inappropriate times as a result of the incorrectly decoded blocks.

    There are three modes available for the Unassigned USF to operate in:

    • Manual Unassigned USF

      See Manual Unassigned USF

    • Random Unassigned USF

      When the Random Unassigned USF mode is selected the test set pseudo-randomly assigns a value to the Unassigned USF. The test set never assigns the Unassigned USF the same value as the Assigned USF.

    • Random Burst

      When the Random Burst mode is selected the test set transmits a random GMSK modulated burst. This mode is only selectable when the connection type is ETSI Type A.

    The GPIB command to change this parameter is CALL:(PDTCH|PDTChannel):MACCess[:DYNamic]:USFLag:UNASsigned:MODE .

  • Manual Unassigned USF

    When the Unassigned USF Mode is set to Manual USF, the test set uses the value set for the Manual Unassigned USF parameter as the value for the USF value.

    The values for the Assigned USF and the Unassigned USF cannot be the same. If the value of the Assigned USF is changed to a value that is the same as what the Unassigned USF is currently set to, the Unassigned USF will change to the default value of 7 as long as 7 is not the value the Assigned USF is being changed to. If the Assigned USF value is changed to 7 when the Unassigned USF value is 7, the Unassigned USF value is changed to 0.

    The GPIB command to change this parameter is CALL:(PDTCH|PDTChannel):MACCess[:DYNamic]:USFLag:UNASsigned[:MANual] .

  • Operating Considerations

    The following table shows the valid connection types in which the Assigned and Unassigned USF BLER measurement can be performed.

    Connection Type

             Manual/Random USF

    Random Burst
    Auto | Not when on a voice or circuit switched data call.
    ETSI A | Yes | Yes
    ETSI B Yes

    No

    ETSI B

    Yes

    No
    BLER | No (uplink TBF is not present) | No (uplink TBF is not present)

    SRB Loopback

    Yes

    No

Related Topics

Medium Access Mode


Wideband Adaptive Multi-Rate (AMR-WB) Feature Descriptions

Wideband Adaptive Multi-Rate (AMR-WB) Feature Descriptions

This section is only applicable to the lab applications and the test application with a required feature license.

AMR-WB is a speech coding standard developed after the AMR using same technology like ACELP (Algebraic Code Excited Linear Prediction). AMR-WB ensures that speech quality is optimized in a mobile station by verifying its ability to determine when to request a change to another codec with either more or less error correction and protection as signal quality changes, like AMR.

The following topics are described in this section:

Wideband Adaptive Multi-Rate (AMR-WB) Overview

Wideband Adaptive Multi-Rate (AMR-WB) Channel Mode Configuration

Wideband Adaptive Multi-Rate (AMR-WB) Codec Setup

Robust AMR Traffic Synchronization Control Channel (RATSCCH)

Operating Considerations

Wideband Adaptive Multi-Rate (AMR-WB) Overview

The AMR-WB codec has nine basic bit rates, 23.85, 23.05, 19.85, 18.25, 15.85, 14.25, 12.65, 8.85 and 6.6 kbit/s. The test set can support three bit rates (6.6, 8.85 and 12.65 kbit/s) on GMSK traffic channel currently. The AMR-WB codec works on the principle of Algebraic Code Excited Linear Prediction (ACELP) for all bit rates.

The test set has one AMR-WB logical speech channel: Wideband Full-Rate Speech (WFS). During an AMR-WB speech call setup, the test set assigns the mobile station a set of up to three codecs for use during the call. These three codecs comprise what is called the Active Codec Set (ACS) that is defined for the AMR-WB logical speech channel.

An ACS of AMR-WB is a group of up to three codecs (codecs 1 through 3 on the front panel) the test set can command the mobile station to use. The test set uses one codec from the ACS at a time. The codec being used from the ACS is called the current codec. The current codec switches to other codecs in the ACS as the signal quality changes. If the signal quality decreases, then a more robust codec is used if one exists in the ACS. Likewise, if the signal quality increases, a less robust codec is used if one exists in the ACS. The point at which the current codec should change to another codec in the ACS is determined by the Threshold and Hysteresis values that can be specified in the test set. The test set allows parameters such as the codecs that define the ACS, current codec, Threshold and Hysteresis values to be changed whether a call exists or not. A protocol log captured with the Wireless Protocol Advisor (WPA) can be used to verify that the mobile station responded properly to changes in AMR-WB parameters. For more information see Protocol Logging .

Wideband Adaptive Multi-Rate (AMR-WB) Channel Mode Configuration

The AMR-WB specific logical speech channels that the channel mode can be configured to is Wideband Full Rate Speech (WFS). For instructions on setting the channel mode configuration on the front panel of the test set, see steps one through three of General AMR and AMR-WB Parameter Setup . The GPIB command to configure the Logical Speech Channel is CALL:TCHannel:CMODe:LSPeech:CHANnel .

Wideband Adaptive Multi-Rate (AMR-WB) Codec Setup

  • ACS

    The general guidelines for defining the ACS of AMR-WB are similar to that of AMR except that the number of codecs is 3 instead of 4. See Active Codec Set of Adaptive Multi-Rate (AMR) Feature Descriptions for more information.

    If WFS (Wideband Full) is chosen as the Logical Speech Channel, there are four options to choose from when defining the ACS: WFS 6.6, WFS 8.85, WFS 12.65 , and Unused .

    The units used for the codec options differ between the front panel and GPIB commands. The unit of measurement used on the front panel is kbps and is used in the Table 1: AMR-WB Configurable Parameters and Default Values , whereas the unit of measurement used for the GPIB commands is bps. The same codecs are available via the GPIB commands as on the front panel. The codecs available to choose from when WFS Logical Speech Channel is selected in the Channel Mode Configuration window must be specified in the GPIB commands in the following form: WFS6600, WFS8850, and WFS12650 .

    NOTE
    In order to activate the changes to the ACS on the front panel Apply Changes must be pressed, otherwise any changes will be discarded if the menu closes.

    Table 1: AMR-WB Configurable Parameters and Default Values below shows the configurable parameters in the codec set along with their corresponding GPIB commands.

Table 1: AMR-WB Configurable Parameters and Default Values

Wideband Full-Rate Speech (WFS)

GPIB Command

Current Codec

 WFS 6.6, WFS 8.85, WFS 12.65

CALL:TCHannel:CMODe:WFSPeech:CODec:CURRent

Default Current Codec

 WFS 6.6
Codec Options

WFS 6.6, WFS 8.85, WFS 12.65,
 Unused *

CALL:TCHannel:CMODe:WFSPeech:CODec

Default ACS Codec 1: WFS 6.6
Codec 2: WFS 8.85
Codec 3: WFS 12.65

Threshold Range

 0 - 31.5 dB (Step Size: .5 dB)

CALL:TCHannel:CMODe:WFSPeech:CODec:THReshold

Default Threshold Values

Codec 1 to 2 Threshold: 6.5 dB

Codec 2 to 3 Threshold: 12.5 dB

Hysteresis Range

0 - 7.5 dB (Step Size: .5 dB)

Default Hysteresis Values

Codec 1 to 2 Hysteresis: 2 dB

Codec 2 to 3 Hysteresis: 2 dB

*The Unused option eliminates a codec if less than three codecs are desired in the ACS. The option is not applicable to codec 1.

  • Current Codec

    The general guidelines for defining the Current Codec for AMR-WB are similar to that of AMR. See Current Codec of Adaptive Multi-Rate (AMR) Feature Descriptions for more information.

    There are five options for the Current Codec parameter of AMR-WB: WFS 6.6, WFS 8.85, WFS 12.65, Stress and MS Request . The current codec can only be changed to another codec within the codec set. you can select Stress or MS Request only in active cell operating mode.

  • Threshold and Hysteresis Values

    The general guidelines for defining the Threshold and Hysteresis Values for AMR-WB are similar to that of AMR except the number of Threshold and Hysteresis Value sets is 2 instead of 3. See Threshold and Hysteresis Values of Adaptive Multi-Rate (AMR) Feature Descriptions for more information.

    See Table 1: AMR-WB Configurable Parameters and Default Values for the range and default settings for the threshold and hysteresis values.

Robust AMR Traffic Synchronization Control Channel (RATSCCH)

The function of RATSCCH for AMR-WB is the same as that of AMR. See Robust AMR Traffic Synchronization Control Channel (RATSCCH) of Adaptive Multi-Rate (AMR) Feature Descriptions for more information.

Operating Considerations

AMR is available when the Operating Mode is set to Active Cell and serving cell the serving cell is GSM, GPRS, or EGPRS and when the Connection Type is Auto or when the Operating Mode is GSM BCH+TCH, GPRS BCH+PDTCH+TCH, or EGPRS BCH+PDTCH+TCH.

Related Topics

Adaptive Multi-Rate (AMR) Feature Descriptions


GSM (E1960A) Revision Information

GSM (E1960A) Revision Information

This document describes features and functionality that are part of the E1960A GSM Mobile Test Application releases. This document contains the original features, as well as enhancements that have been added over time.

CAUTION
You may need to upgrade the hardware in your test set before installing the application firmware described here. If you install application firmware on a test set with incompatible hardware, the following may occur:

  • Your test set may lock up (see Test Set Lockup During Power Up Sequence ).
  • The application may not run.
  • Some features in the application may be inaccessible, or may not perform to specifications.

To determine if a hardware upgrade is required for your testing needs, please review the hardware requirement information at:

http://www.agilent.com/find/8960upgrades

Select the appropriate link below to view the required release.

  • A.11.08 Release January 2005
  • A.11 Release February 2004
  • A.10 Release June 2002
  • A.09 Release March 2002
  • A.08 Release July 2001
  • A.07 Release May 2001
  • A.06 Release February 2001
  • A.05 Release May 2000
  • A.04 Release - March 2000
  • A.03 Release - December 1999
  • A.02 Release - July 1999
  • A.01 Release - March 1999
  • A.00 Initial Release - January 1999

A.11.08 Release January 2005

No new features or measurements have been added to this version of the firmware. The same hardware requirements apply as in the A.11 Release, see Support for EGPRS hardware .

A.11 Release February 2004

This firmware release is compatible with EGPRS capable hardware. No new features have been added to this version of the firmware.

Support for EGPRS hardware

E1960A test application release A.10.xx and earlier are not compatible with E5515B or E5515C chassis with EGPRS capable hardware. Loading E1960A A.10.xx or earlier will make the mainframe inoperable and require Agilent service. The following applications are not compatible with EGPRS capable chassis: E1960A (release A.10.xx and earlier), E1964A, E1985A, E6701A and E6701B.

This firmware release provides the ability to run E1960A firmware on E5515B or E5515C chassis containing EGPRS capable hardware. Chassis containing EGPRS capable hardware include:

  • E5515C with Option E5515C-H03 or E5515CU-H03, E5515CU-K03 or E5515CU-565 upgrades
  • E5515C serial number GB44050001 and later
  • E5515B with E5515CU-H03, E5515CU-K03 or E5515BU-565 upgrade
  • E5515B serial number GB44200001 and later

If you have previously been using any revision of the E1960A GSM test application on an E5515A, E5515B, or E5515C chassis then this revision will also run. The second RF source, Option 002, is required to run E1960A on E5515B and E5515C chassis.

A.10 Release June 2002

This firmware release adds new frequency bands, half rate speech mode and a spectrum monitor.

This firmware release will run on an E5515C chassis with Option 002. If you have previously been using any revision of the E1960A GSM test application on an E5515A or E5515B chassis then this revision will also run.

For access to the spectrum monitor feature requires your chassis be one of the following:

  • an E5515C.
  • an E5515B with serial number US40350362 or GB40470454 or higher.
  • an E5515B with E5515BU option 085.
  • an E5515A with E5515BU option 085.

Call Processing

  • This release provides you with the GSM450, GSM480, GSM750 and RGSM frequency bands.

  • Half rate speech channel mode has been added. For more details refer to Channel Mode Setup .

Measurements

A Spectrum Monitor measurement feature has been added. This allows you to find, identify and measure transmitted signals from your mobile phone. It can also be used for spur measurements in the transmit band. For more details refer to Spectrum Monitor Description .

Other

None

A.09 Release March 2002

This firmware release adds new features to the Output RF Spectrum and Power versus Time measurements.

This firmware release will run on an E5515C chassis with Option 002. If you have previously been using any revision of the E1960A GSM test application on an E5515A or E5515B chassis then this revision will also run. However, if you wish to run this test application on an E5515A or E5515B chassis for the first time, contact your local sales representative.

Call Processing

No new features in this release.

Measurements

  • The Power versus Time measurement has been enhanced to provide a relaxed mask specification for the PCS band, as defined in 3GPP 51.010-1 section 13.3.5(c). For more information refer to SETup:PVTime:LIMit:ETSI:PCS .
  • The Output RF Spectrum measurement has been enhanced to allow you to select to either test to the ETSI defined, or your own specified limits. The commands used to set up your own limits are:
    • SETup:ORFSpectrum:LIMit:SOURce
    • SETup:ORFSpectrum:SWITching:LIMit:MANual[:SELected]
    • SETup:ORFSpectrum:MODulation:LIMit:MANual<[1]|2>[:SELected]

A.08 Release July 2001

Call Processing

This release provides you with the GSM850 frequency band.

Measurements

  • The Phase and Frequency Error measurement has been enhanced to include a confidence level feature. Using confidence levels for your measurements can reduce your test time. Confidence levels simply end the measurement early, that is, before all the multi-measurements you specified are taken. It ends the measurement early only if it determines statistically that the rest of the measurements should pass. You can set the confidence level and the measurement limits. For more information on this feature refer to Confidence Levels .

Other

  • This release gives you the first revision of GSM which can be used for the E1985A GSM_AMPS/136_GPRS fast switching test application. The previous GSM release (A.07) only allowed you to switch quickly between GSM and AMPS/136, whereas this GSM revision also allows you to also switch quickly between GPRS.

  • Internal graphical measurements for: Power versus Time, Output RF Spectrum, Phase and Frequency Error and I/Q Tuning.

    For more details on these graphical measurements refer to one of the following step-by-step measurement procedures:

    • How Do I Make a Power Versus Time Measurement?
    • How Do I Make an Output RF Spectrum Measurement?
    • How Do I Make a Phase and Frequency Error Measurement?
    • How Do I Make a IQ Tuning Measurement?
  • Screen images can be captured and saved as .GIF files. This is useful when you want to save copies of measurement results or other screen images. See Printing and Saving Screen Images for a complete explanation of this procedure.

A.07 Release May 2001

Call Processing

No new features in this release.

Measurements

No new measurements in this release.

Other

This release gives you the first revision of GSM which can be used for the E1985A GSM_AMPS/136 fast switching test application. To allow the GSM test application to operate in the fast switching environment with AMPS/136 two existing GSM commands had to be changed. These commands were:

  • SETUP:IQTUNING:REFERENCE:FREQUENCY
  • CALL:MS:REPORTED:REVISION?

If you previously used either of these commands you must change them to the new commands to allow your code to run.

Command Changes in the A.07 Release
Previous Commands | New Commands
SETUP:IQTUNING:REFERENCE:FREQUENCY | SETup:IQTuning:REFerence[:MANual][:FREQuency]:CHARacter:GSM . This command allows you to use the same settings as with the previous command, that is NEG67KHZ, ZEROKHZ, POS67KHZ, and AUTO. You can use this command for the GSM I/Q Tuning measurement whether or not the GSM test application is the currently active format.
 | Alternatively you can use the following commands which are consistent with the format of the commands and settings in AMPS/136: SETup:IQTuning:REFerence[:MANual][:FREQuency]:GSM . This command allows you to use the settings -67000, 0, and + 67000. You can use this command for the GSM I/Q Tuning measurement whether or not the GSM test application is the currently active format. SETup:IQTuning:REFerence[:MANual][:FREQuency][:SELected] . This command allows you to use the settings -67000, 0, and + 67000. You can only use this command for the GSM I/Q Tuning measurement if GSM is the currently active format. SETup:IQTuning:REFerence:AUTO .
CALL:MS:REPORTED:REVISION? | "CALL:MS:REPorted:REVision:CHARacter:GSM?" on page 236. This command returns the same values as with the previous command, that is, UNKNown, PHASe1, and PHASe2. You can use this command for the mobile's revision whether or not the GSM test application is the currently active format.
 | Alternatively you can use the following commands which are consistent with the format of the command and setting in AMPS/136: CALL:MS:REPorted:REVision[:DIGital]:GSM? . This command returns the values; +1.00000000E+000 for phase 1, +2.00000000E+000 for phase 2, and NAN for unknown. You can use this command for the mobile's revision whether or not the GSM test application is the currently active format. CALL:MS:REPorted:REVision[:DIGital][:SELected]? . This command returns the values; +1.00000000E+000 for phase 1, +2.00000000E+000 for phase 2, and NAN for unknown. You can only use this command for the GSM revision if GSM is the currently active format.

A.06 Release February 2001

Call Processing

No new features in this release.

Measurements

  • Analog Audio measurement
    In the previous revisions of this test application it was possible to make Analog Audio Level measurements. In this release we have increased the number of Analog Audio measurements to include Audio Frequency and Distortion. Although not typically a GSM mobile measurement we have also included SINAD measurements. For more information refer to Analog Audio Measurement Description .

Other

  • RF Source Analyzer Level Compensation
    Amplitude offset is provided over a range of frequencies, in order to compensate for loss or gain of the external network between the test set and the DUT (device under test). For more information refer to Amplitude Offset .
  • Dynamic Power measurement enhanced
    The number of bursts over which you can make this measurements has increased from 100 to 999. For more information on this measurement refer to Dynamic Power Measurement Description .
  • Selectable AC or DC coupling between the Audio Generator and the front panel AUDIO OUT port.

A.05 Release May 2000

Call Processing

No new features in this release.

Measurements

No new measurements in this release.

Other

  • Test Application Security
    A licensed version of each test application is required in order for the test application to operate. If you switch test applications to an unlicensed test application, the test set will reboot to the SYSTEM CONFIG screen. You will be unable to switch to any other screen, or make any measurements.

A.04 Release - March 2000

Call Processing

No new features in this release.

Measurements

No new measurements in this release.

Other

  • Test Application selection for multi-format operation
    Menus have been added to the System Configuration screen which allow you to select between different Test Applications that are installed in the test set. This feature can also be accessed remotely within the SYSTem subsystem using the command SYSTem:APPLication:SELect[:NAME] .

    It is not recommended that you switch to a GSM Test Application that has a revision earlier than A.04. Earlier revisions did not have the capability to select Test Applications.

    There may be up to a three second delay between the time the Test Application is selected and it being implemented in the test set.

  • Options installed display is now active
    The Options Installed display on the System Configuration screen has been activated to allow for the optional second source. Although the second source has been optional since the A.03 release, the Options Installed display has remained blank until this current release.

  • Usability enhanced through gray fields
    Non-enabled menu items are now denoted as gray text, versus enabled menu items that are a standard black text. Currently there are no GSM Test Application menu items that use this feature.

  • Measurement time-out resolution increased
    The measurement time-out resolution has been increased from 1 second to 0.1 seconds. The minimum time-out has also been reduced from 1 second to 0.1 seconds.

  • Warning messages can be masked from the display
    A new command is available in the DISPlay subsystem which allows you to set whether or not the test set displays and beeps warning messages. For further information on this command refer to DISPlay:MESSage:MASKable:STATe . This feature is also available over the manual interface (the Maskable Messages Display State field is available in the Instrument Setup menu in the System Configuration screen).

A.03 Release - December 1999

Call Processing

  • EFS
    The Enhanced Full-rate Speech (EFS) feature provides the ability to set up a call in EFS mode.

  • SACCH Tx Level Signalling
    The mobile can now be commanded to use a different Tx level by signalling using the SACCH header alone. In previous releases a FACCH assignment as well as the updated SACCH header was used.

Measurements

  • I/Q Tuning
    A new measurement that can be used to determine the quality of an I/Q modulator by measuring the power of spurious signals at harmonics of 67.7 kHz.

  • Simultaneous BER results
    An enhancement to the BER measurement now allows all types of BER measurement results to be returned at the same time if required.

  • Dynamic Power
    A new feature that performs a series of rapid power measurements on a mobile station. This is only available via the test set's remote user interface.

Other

  • Remote clear of error messages on screen
    A new command can be sent over the GPIB to clear error messages from the screen to enhance use of the test set in a remote situation. Previously, error messages on the screen could only be cleared through manual intervention, by pressing a key on the front panel. For further information on this command refer to DISPlay:WINDow:ERRor:CLEar .

  • Status field indication of external or internal reference
    A status field has been implemented on the screen to indicate whether the test set has locked to an external or an internal reference.

  • Beeper ON/OFF setting is non-volatile
    The ON/OFF setting of the beeper is now maintained through power-off. Previously, a power cycle would reset the beeper to its default state of OFF.

  • Enhanced status subsystem for multi-format capability
    The status subsystem has been enhanced with radio system nodes where necessary for future multi-format capability. This will cause some status subsystem commands to be in error condition, unless they are replaced with the modified commands. The commands are:

    • STATus:QUEStionable:ERRors is now STATus:QUEStionable:ERRors:GSM
    • STATus:QUEStionable:CALL is now STATus:QUEStionable:CALL:GSM
    • STATus:OPERation:CALL is now STATus:OPERation:CALL:GSM
    • STATus:OPERation:NMRReady is now STATus:OPERation:NMRReady:GSM

  • Instrument configuration information available remotely
    Information on the instrument hardware can be obtained through a remote command over the GPIB, and through a remote command via the LAN and a web browser. For further information on the commands refer to Hardware Configuration Report .

  • Enhanced instrument information on the Configuration Screen
    The Instrument Information display on the Configuration Screen, now includes Subnet Mask and Gateway Default information in a new, improved information display.

  • *IDN? returns "Agilent Technologies" in the manufacturer's field where previously it returned "Hewlett-Packard".

  • RF Generator frequency range is now matched to the RF Receiver frequency range
    Previously the RF Generator had a low end limit of 45 MHz, while the RF Receiver has always had a low end limit of 292.5 MHz. The RF Generator is now limited to 292.5 MHz to enhance testability and supportability of the test set.

A.02 Release - July 1999

Call Processing

  • Paging Mode selectable between "Reorganization" or "Normal"

Measurements

  • Automatic closed loop settings as part of Normal BER and Fast BER measurements

  • 3 kHz speech selection for Downlink Speech Source

Other

  • LAN subnet mask and LAN Default Gateway settable

  • Status Subsystem for GPIB queries of instrument status

  • Display Brightness

  • Display Automatic Backlight Dimming

A.01 Release - March 1999

Call Processing

No new features in this release.

Measurements

  • Normal BER

  • Pulsed Audio Source (For uplink speech measurement)

Other

Measurement Integrity on Manual User Interface

A.00 Initial Release - January 1999

Call Processing

  • GSM 900 (Includes PGSM/EGSM), DCS1800, PCS1900

  • MS and BS Originated Calls

  • TCH, Timeslot, Timing Advance, MS Tx Level Assignments

  • Dual-Band Handover

  • Downlink Speech Source

  • Test Mode - CW, BCH Only, BCH + TCH

Measurements

  • Tx Power

  • Output RF Spectrum

  • Power versus Time

  • Phase / Frequency Error

  • Burst Timing

  • Analog Audio

  • Uplink Speech Measurement (requires pulsed audio source)

  • Burst by Burst BER (Fast BER)

Other

  • Audio Source

  • User settable amplitude offset


ABORt

ABORt

GPIB Command Conventions

  • ABORt[:ALL]
  • ABORt:<meas-mnemonic>

ABORt[:ALL]

Function

GSM TA

Stops any and all measurements that are active. See Measurement States

If the trigger arm is set to single, see Trigger Arm (Single or Continuous) Description the measurements will go to the idle state.

If the trigger arm is set to continuous the measurements will re-arm and initiate again.

GPRS TA

EGPRS TA
GSM/GPRS LA

EGPRS LA
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"ABORT:ALL"
! Aborts all active measurements in progress.

ABORt:<meas-mnemonic>

Function

GSM TA

Stops the selected measurement if it is active. See Measurement States

If the trigger arm is set to single, see Trigger Arm (Single or Continuous) Description the measurements will go to the idle state.

If the trigger arm is set to continuous the measurements will re-arm and initiate again.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
meas-
mnemonic 		GSM TA

Range:

AAUDio | BERRor | DAUDio | DPOWer | FBERror|FSTability | IQTuning | MTAudio | ORFSpectrum | PCALibration | PFERror | PVTime | SMONitor | TXPower
GPRS TA

Range:

BLERror | DPOWer |FSTability| GBERror | IQTuning | MTAudio | ORFSpectrum | PCALibration | PFERror | PVTime | SMONitor | TXPower
GSM/GPRS LA

Range:

AAUDio | BERRor | BLERror | DAUDio | DPOWer | FBERror|FSTability | GBERror | IQTuning | MTAudio | ORFSpectrum | PCALibration | PFERror | PVTime | SMONitor | TXPower|IFERror|BFI

EGPRS TA

Range:

AAUDio | BERRor | BLERror | DAUDio | DPOWer | EDPower|EMACcuracy | ETXPower | FBERror |FSTability| GBERror | IQTuning | MTAudio | ORFSpectrum | PCALibration | PFERror | PVTime | SBERror |SMONitor | TXPower

EGPRS LA

Range:

AAUDio | BERRor | BFINdication | BFI |BLERror | DAUDio | DPOWer | EDPower|EMACcuracy | ETXPower | FBERror | FFERate|FSTability| GBERror | IQTuning | MTAudio | ORFSpectrum | PCALibration | PFERror | PVTime | SBERror |SMONitor | TXPower|IFERror|BFI
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
Revision A.03 adds SBERror
Revision A.04 adds EDPower and FSTability
Revision A.06 adds PCALibration
GSM/GPRS/ EGPRS LA

Revision: C.01 and above
Revision C.03 adds BFINdication, BFI, FFERate, and SBERror
Revision D.01 adds EDPower, FSTability and IFER.
Revision D.03 adds PCALibration

Programming Example

OUTPUT 714;"ABORT:PVTIME"
! Aborts a PvT measurement.


ABORt Subsystem

ABORt Subsystem

Description

The ABORt command causes a measurement cycle in progress to stop. If the measurement is not being continuously armed (trigger arm set to single) , the measurement will remain in the idle state after this event. If the measurement is being continuously armed (trigger arm set to continuous), a new measurement cycle will begin after ABORt. If an ABORt command is issued from any measurement state other than measuring, the command is ignored.

Other Commands that Execute an ABORt Action

INITiate:<meas> will execute an ABORt:<meas> as part of the INITiate:<meas> command.

READ:<meas>? will execute an ABORt:<meas> action that aborts just one trigger sequence and then combines the INITiate and FETCh? commands.

Syntax Diagram and Command Descriptions

ABORt


AFGenerator

AFGenerator

GPIB Command Conventions

  • AFGenerator:COUPling
  • AFGenerator:FREQuency
  • AFGenerator:PULSe[:STATe]
  • AFGenerator:VOLTage[:SAMPlitude]
  • AFGenerator:VOLTage:AMPlitude
  • AFGenerator:VOLTage:STATe

AFGenerator:COUPling

Function

GSM TA

 Sets the output of the audio generator to be ac or dc coupled to the front-panel AUDIO OUT port.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

Range: AC or DC
Query

Range: AC or DC
*RST setting DC
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"AFGENERATOR:COUPling AC"
! Sets the audio generator coupling to AC.

AFGenerator:FREQuency

Function

GSM TA

 Sets/queries the frequency of the audio generator. Optional units (HZ|KHZ|MHZ|GHZ) can be specified when setting frequency but will default to Hz if units are not specified.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

Range: 1 Hz to 20 kHz

Resolution: .1 Hz
Query

Range: 1 Hz to 20 kHz

Resolution: .1 Hz
*RST setting 1 kHz
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"AFGENERATOR:FREQUENCY 1000"
! Sets the audio generator frequency to 1000 Hz.

AFGenerator:PULSe[:STATe]

Function

GSM TA

Sets/queries the audio generator pulse state.

The pulse state must be on when the test set's audio generator is used for audio stimulation during a decoded audio measurement.

When the state is on, the audio signal from the test set is pulsed at a 10 Hz rate with a 50% duty cycle.

The amplitude and frequency of the pulse is set with afgenerator commands. See AFGenerator .
GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting | Range: 0 | OFF | 1 | ON

Query

Range: 0 | 1
*RST setting | 0 | OFF
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"AFGENERATOR:PULSE ON"
! Sets the audio generator pulse to ON.

AFGenerator:VOLTage[:SAMPlitude]

Function

GSM TA

 Sets /queries the amplitude of the audio generator in volts and turns the state to on. Optional units (V|MV) can be specified when setting the amplitude but units will default to V if units are not specified.
GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

Range: 0 - 9 V pk.

Resolution:

  • .5 mV pk. <= 1 V pk. output
  • 5 mV pk. > 1 V pk. output
Query

Range: 0 - 9 V peak

Resolution:

  • .5 mV pk. <= 1 V pk. output
  • 5 mV pk. > 1 V pk. output
*RST setting zero volts
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"AFGENERATOR:VOLTAGE 2.1"
! Sets the state to on and the output voltage to 2.1 volts.

AFGenerator:VOLTage:AMPlitude

Function

 GSM TA Sets/queries the amplitude for the audio generator when the audio generator state is on. Optional units (V|MV) can be specified when setting amplitude but units will default to V if units are not specified.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

Range: 0 - 9 V pk.

Resolution:

  • .5 mV pk. <= 1 V pk. output
  • 5 mV pk. > 1 V pk. output
Query

Range: 0 - 9 V pk.

Resolution:

  • .5 mV pk. <= 1 V pk. output
  • 5 mV pk. > 1 V pk. output
*RST setting zero volts
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"AFGENERATOR:VOLTAGE:AMPLITUDE 1.414"
! Sets the audio generator output voltage to 1.414 volts peak.

AFGenerator:VOLTage:STATe

Function

 GSM TA Sets/queries the audio generator state
GPRS TA

EGPRS TA
GSM/GPRS LA

EGPRS LA
Setting | 0 | OFF | 1 | ON

Query

0 | 1
*RST setting | 0 | OFF
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"AFGENERATOR:VOLTAGE:STATE ON"
! Set the audio generator state to ON.


AFGenerator Subsystem

AFGenerator Subsystem

Description

The AFGenerator subsystem is used to control the audio source that is available at the Audio Output connector.

Syntax Diagram and Command Descriptions

AFGenerator


CALCulate Subsystem

CALCulate Subsystem

Description

The CALCulate subsystem is used to perform data processing on the measurement results. For example, the CALCulate subsystem uses the markers to find the peaks and to read back their values in the Spectrum Monitor.

Syntax Diagram and Command Descriptions

CALCulate:SMONitor


CALCulate:SMONitor

CALCulate:SMONitor

GPIB Command Conventions

  • CALCulate:SMONitor:MARKer:ALL:STATe
  • CALCulate:SMONitor:MARKer[<n>] :AMPLitude?
  • CALCulate:SMONitor:MARKer[<n>]:FREQuency
  • CALCulate:SMONitor:MARKer[<n>] :MODE
  • CALCulate:SMONitor:MARKer:PEAK:EXCursion[:LEVel]
  • CALCulate:SMONitor:MARKer[<n>] :PEAK:MAXimum
  • CALCulate:SMONitor:MARKer:PEAK:THReshold[:LEVel]
  • CALCulate:SMONitor:MARKer[<n>] [:SET]:EXPected:POWer
  • CALCulate:SMONitor:MARKer[<n>] [:SET]:EXPected:FREQuency
  • CALCulate:SMONitor:MARKer[<n>]:STATe
  • CALCulate:SMONitor:MARKer[<n>]:TIME

CALCulate:SMONitor:MARKer:ALL:STATe

Function

This command determines whether all markers are turned on or turned off.
Setting

Range: 1 | ON | 0 | OFF

Query

Range: 1 | ON | 0 | OFF
*RST Setting | 0 | OFF
Requirements | GSM/GPRS/EGPRS TA Revision: A.01 and above

GSM/GPRS/EGPRS LA Revision: C.01 and above

Programming Example

OUTPUT 714;"CALCulate:SMONitor:MARKer:ALL:STATe 1"
! Turns on all markers.

CALCulate:SMONitor:MARKer[<n>] :AMPLitude?

Function

This query returns the amplitude for marker <n>, where <n> is a number 1 through 3. When no marker number is specified, marker 1 is used.

If you are using delta marker mode, the result is the delta marker amplitude result. (See CALCulate:SMONitor:MARKer[<n>] :MODE .)

Query

Range

  • Position Mode: -180 dBm to +37 dBm

  • Delta Mode: -200 dB to +200 dB

Resolution: 0.01 dB
Requirements GSM/GPRS/EGPRS TA Revision: A.01 and above

GSM/GPRS/EGPRS LA Revision: C.01 and above

Programming Example

OUTPUT 714;"CALCulate:SMONitor:MARKer2:AMPLitude?"
! Returns the amplitude of marker 2.

CALCulate:SMONitor:MARKer[<n>]:FREQuency

Function

This command sets/queries the frequency of marker <n>. where <n> is a number 1 through 3. When no marker number is specified, marker 1 is used.

If you are using delta marker mode, this command sets/queries the offset frequency of the delta marker. (See CALCulate:SMONitor:MARKer[<n>] :MODE .)
Query

Range:

  • Position Mode

    Range: This is dependent on the settings of the center frequency and the frequency span. The markers frequency range is therefore equal to the center frequency +/- half the frequency span.

    Resolution: 0.001 MHz

  • Delta Mode:

    Range: The range is dependent on the center frequency, the frequency span and the position of the reference marker.

    Resolution: 0.001 MHz
Requirements GSM/GPRS/EGPRS TA Revision: A.01 and above

GSM/GPRS/EGPRS LA Revision: C.01 and above

Programming Example

OUTPUT 714;"CALCulate:SMONitor:MARKer:FREQuency?"
! Queries the frequency of marker 1.

CALCulate:SMONitor:MARKer[<n>] :MODE

Function

This command sets the mode of the marker.

Position mode activates a single frequency marker at the center frequency.

Delta mode freezes the marker at its current location and uses it as a reference marker. A second marker is created at the position of the reference marker and is used a delta marker.

Setting

Range: POSition | DELTa | OFF

Query

Range: POS | DELT | OFF
*RST Setting | OFF
Requirements | GSM/GPRS/EGPRS TA Revision: A.01 and above

GSM/GPRS/EGPRS LA Revision: C.01 and above

Programming Example

OUTPUT 714;"CALCulate:SMONitor:MARKer:MODE DELT"
! Sets a reference marker and creates a delta marker.

CALCulate:SMONitor:MARKer:PEAK:EXCursion[:LEVel]

Function

This command sets the peak excursion level. A peak is identified by using the peak threshold and peak excursion value. A point is only marked as a peak if it rises and falls more than the peak excursion value from the peak threshold value. Setting this command to DEFault sets it to 6 dB.
Setting

Range: 1 to 100 dB | DEFault

Resolution: 0.1 dB

Query

Range: 1 to 100 dBResolution: 0.1 dB
*RST Setting

6 dB
Requirements GSM/GPRS/EGPRS TA Revision: A.01 and above

GSM/GPRS/EGPRS LA Revision: C.01 and above

Programming Example

OUTPUT 714;"CALCulate:SMONitor:MARKer:PEAK:EXCursion 20DB"
! Sets the peak excursion level to 20 dB.

CALCulate:SMONitor:MARKer[<n>] :PEAK:MAXimum

Function

This command moves the specified marker <n> (1 to 3) to the highest peak value. If no marker <n> is specified, then marker 1 is moved.

An error message is returned if no peaks were found in the trace.
Requirements GSM/GPRS/EGPRS TA Revision: A.01 and above

GSM/GPRS/EGPRS LA Revision: C.01 and above

Programming Example

OUTPUT 714;"CALCulate:SMONitor:MARKer2:PEAK:MAXimum"
! Moves marker 2 to the highest peak value on the selected trace.

CALCulate:SMONitor:MARKer:PEAK:THReshold[:LEVel]

Function

This command sets peak threshold level. A peak is identified by using the peak threshold and peak excursion value. A point is only marked as a peak if it rises and falls more than the peak excursion value from the peak threshold value. Setting this command to DEFault sets it to -90 dBm.
Setting

Range: -120 to +37 dBm | DEFault

Resolution: 0.1

Query

Range: -120 to +37 dBmResolution: 0.1
*RST Setting

-90 dBm
Requirements GSM/GPRS/EGPRS TA Revision: A.01 and above

GSM/GPRS/EGPRS LA Revision: C.01 and above

Programming Example

OUTPUT 714;"CALCulate:SMONitor:MARKer:PEAK:THReshold:LEVel 10DBM"

CALCulate:SMONitor:MARKer[<n>] [:SET]:EXPected:POWer

Function

This command sets the base station emulator's expected power to the amplitude of the specified marker.

There are three markers <n> (1 to 3) that can be set. If no <n> is specified, marker 1 is used.
Requirements GSM/GPRS/EGPRS TA Revision: A.01 and above

GSM/GPRS/EGPRS LA Revision: C.01 and above

Programming Example

OUTPUT 714;"CALCulate:SMONitor:MARKer2:EXPected:POWer"

CALCulate:SMONitor:MARKer[<n>] [:SET]:EXPected:FREQuency

Function

This command sets the base station emulator's expected frequency to the frequency of the specified marker.

There are three markers <n> (1 to 3) that can be set. If no <n> is specified, marker 1 is used.
Requirements GSM/GPRS/EGPRS TA Revision: A.01 and above

GSM/GPRS/EGPRS LA Revision: C.01 and above

Programming Example

OUTPUT 714;"CALCulate:SMONitor:MARKer3:EXPected:FREQuency"

CALCulate:SMONitor:MARKer[<n>]:STATe

Function

This command sets which markers are turned on.

There are three markers <n> (1 to 3) that can be set. If no <n> is specified, marker 1 is used.
Setting

Range: 1 | ON | 0 | OFF

Query

Range: 1 | ON | 0 | OFF
*RST Setting | 0 | OFF
Requirements | GSM/GPRS/EGPRS TA Revision: A.01 and above

GSM/GPRS/EGPRS LA Revision: C.01 and above

Programming Example

OUTPUT 714;"CALCulate:SMONitor:MARKer2:STATE 1"
! Turns on marker 2.

CALCulate:SMONitor:MARKer[<n>]:TIME

Function

This command sets/queries the time at marker <n>. where <n> is a number 1 through 3. When no marker number is specified, marker 1 is used.

If you are using delta marker mode, this command sets/queries the delta offset time. (See CALCulate:SMONitor:MARKer[<n>] :MODE .)
Setting

Range: -50 ms to 10070 ms
Resolution: 0.25 us

Query

Range: -50 ms to 10070 ms
Resolution: 0.25 us
*RST Setting | 5 ms
Requirements | GSM/GPRS/EGPRS TA Revision: A.01 and above

GSM/GPRS/EGPRS LA Revision: C.01 and above

Programming Example

OUTPUT 714;"CALCulate:SMONitor:MARKer2:TIME 30"
! Places marker 2 at 30 ms.


CALibration

CALibration

GPIB Command Conventions

  • CALibration:BMOFfset:INFormation?
  • CALibration:DAPower:INFormation?
  • CALibration:DATE
  • CALibration:IQ[:1]?
  • CALibration:IQ1:INFormation?
  • CALibration:IQ2?
  • CALibration:IQ2:INFormation?
  • CALibration:SMONitor?
  • CALibration:SMONitor:INFormation?

CALibration:BMOFfset:INFormation?

Function

GSM TA

Queries the calibration information about Burst Modulation Offset 1.

The query returns 3 comma separated values: Data and Time, Temperature and Pass/Fail.

  • Date and Time indicates when the calibraiton is performed.
  • Temperature indicates the internal operating temperature when the calibration is performed.
  • Pass/Fail indicates whether the calibration is performed successfully.

GPRS TA

EGPRS TA
GSM/GPRS LA

EGPRS LA

Query

Range

  • Date and Time: "2000-01-01 00:00:00" to "2100-01-01 00:00:00"
  • Temperature: -60.0 to 100.0 (°C)
  • Pass/Fail: 1| 0
Requirements GSM/GPRS/
EGPRS TA

Revision: A.09 and above
GSM/GPRS/ EGPRS LA

Revision: F.01 and above

Programming Example

OUTPUT 714;"CALIBRATION:BMOFFSET:INFORMATION?"

CALibration:DAPower:INFormation?

Function

GSM TA

Queries the calibration information about Digital Average Power.

The query returns 3 comma separated values: Data and Time, Temperature and Pass/Fail.

  • Date and Time indicates when the calibraiton is performed.
  • Temperature indicates the internal operating temperature when the calibration is performed.
  • Pass/Fail indicates whether the calibration is performed successfully.

GPRS TA

EGPRS TA
GSM/GPRS LA

EGPRS LA

Query

Range

  • Date and Time: "2000-01-01 00:00:00" to "2100-01-01 00:00:00"
  • Temperature: -60.0 to 100.0 (°C)
  • Pass/Fail: 1| 0
Requirements GSM/GPRS/
EGPRS TA

Revision: A.09 and above
GSM/GPRS/ EGPRS LA

Revision: F.01 and above

Programming Example

OUTPUT 714;"CALIBRATION:DAPOWER:INFORMATION?"

CALibration:DATE

Function GSM TA

Sets/queries the date of the last system calibration done to the test set, not the IQ calibration date. Returns a comma separated list YYYY,MM,DD in that order.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

Sets the system calibration date.

Range

  • Year = 0000 to 9999

  • Month = 01 to 12

  • Day = 01 to 31

Query

Returns the date when system calibration was performed.

Range

  • Year = 0000 to 9999

  • Month = 1 to 12

  • Day = 1 to 31
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALIBRATION:DATE 1999,01,04"
! Sets the date of the last system calibration year, month and day.

CALibration:IQ[:1]?

Function

GSM TA

Sets/queries the calibration of the IQ modulator for RF generator 1. It takes some time to complete calibration and can't be aborted except by cycling the power switch.

  • Calibrates the IQ modulator for RF generator 1.
  • Returns a value indicating success or failure of calibration.

GPRS TA

EGPRS TA
GSM/GPRS LA

EGPRS LA

Query

Range

  • 0 = Pass
  • -340 = Fail
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALIBRATION:IQ1?"
! Performs a calibration of the IQ modulator for RF generator 1 and returns 0 or -340.

When the calibration is done the test set display will display:

IQ Calibration completed successfully for modulator 1.

CALibration:IQ1:INFormation?

Function

GSM TA

Queries the calibration information of the IQ modulator for RF generator 1. The command has a parameter string that indicates the name of the TA Partition. The parameter string is selected from "GSM/GPRS", "AMPS/136", "WCDMA", "IS-856" or "IS-2000/IS-95/AMPS".

The query returns 3 comma separated values: Data and Time, Temperature and Pass/Fail.

  • Date and Time indicates when the calibraiton is performed.
  • Temperature indicates the internal operating temperature when the calibration is performed.
  • Pass/Fail indicates whether the calibration is performed successfully.

GPRS TA

EGPRS TA
GSM/GPRS LA

EGPRS LA

Query

Range

  • Date and Time: "2000-01-01 00:00:00" to "2100-01-01 00:00:00"
  • Temperature: -60.0 to 100.0 (°C)
  • Pass/Fail: 1| 0
Requirements GSM/GPRS/
EGPRS TA

Revision: A.09 and above
GSM/GPRS/ EGPRS LA

Revision: F.01 and above

Programming Example

OUTPUT 714;"CALIBRATION:IQ1:INFORMATION GSM/GPRS?"

CALibration:IQ2?

Function

GSM TA

Sets/queries the calibration of the IQ modulator for RF generator 2. It takes some time to complete calibration and can't be aborted except by cycling the power switch.

  • Calibrates the IQ modulator for RF generator 2.
  • Returns a value indicating success or failure of calibration.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Range

  • 0 = Pass
  • -340 = Fail
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALIBRATION:IQ2?"
! Performs a calibration of the IQ modulator for RF generator 2 and returns 0 or -340.

When the calibration is done the test set display will display:

IQ Calibration completed successfully for modulator 2.

CALibration:IQ2:INFormation?

Function

GSM TA

Queries the calibration information of the IQ modulator for RF generator 2. The command has a parameter string that indicates the name of the TA Partition. The parameter string is selected from "GSM/GPRS", "AMPS/136", "WCDMA", "IS-856" or "IS-2000/IS-95/AMPS".

The query returns 3 comma separated values: Data and Time, Temperature and Pass/Fail.

  • Date and Time indicates when the calibraiton is performed.
  • Temperature indicates the internal operating temperature when the calibration is performed.
  • Pass/Fail indicates whether the calibration is performed successfully.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Range

  • Date and Time: "2000-01-01 00:00:00" to "2100-01-01 00:00:00"
  • Temperature: -60.0 to 100.0 (°C)
  • Pass/Fail: 1| 0
Requirements GSM/GPRS/
EGPRS TA

Revision: A.09 and above
GSM/GPRS/ EGPRS LA

Revision: F.01 and above

Programming Example

OUTPUT 714;"CALIBRATION:IQ2:INFORMATION GSM/GPRS?"

CALibration:SMONitor?

Function GSM TA

Starts the spectrum monitor calibration routine. It is important that no power is applied to the RF IN/OUT connector during calibration.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Range: 0 through 10, and -340

  • 0 (Spectrum Monitor calibration completed successfully)
  • 1 (Spectrum Monitor calibration failed due to temperature drift. Wait for temperature to stabilize)
  • 2 (Spectrum Monitor calibration failed due to oven out of range)
  • 3 (Spectrum Monitor calibration failed due to loopback switch problem)
  • 4 (Spectrum Monitor calibration failed due to under range condition)
  • 5 (Spectrum Monitor calibration failed due to over range condition)
  • 6 (Spectrum Monitor calibration failed due to correlation problem)
  • 7 (Spectrum Monitor calibration failed due to source level problem)
  • 8 (Spectrum Monitor calibration failed due to IF filter coefficient problem)
  • 9 (Spectrum Monitor calibration failed due to IF frequency response problem)
  • 10 (Spectrum Monitor calibration failed due to waveform quality problem)
  • -340 (Spectrum Monitor calibration failed)
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALIBRATION:SMONitor?"
! Performs a calibration of the Spectrum Monitor and returns a value 0-10 or -340.

CALibration:SMONitor:INFormation?

Function

GSM TA

Queries the calibration information about Spectrum Monitor. The command has a parameter string that indicates the name of the TA Partition. The parameter string is selected from "GSM/GPRS", "AMPS/136", "WCDMA", "IS-856" or "IS-2000/IS-95/AMPS".

The query returns 3 comma separated values: Data and Time, Temperature and Pass/Fail.

  • Date and Time indicates when the calibraiton is performed.
  • Temperature indicates the internal operating temperature when the calibration is performed.
  • Pass/Fail indicates whether the calibration is performed successfully.

GPRS TA

EGPRS TA
GSM/GPRS LA

EGPRS LA

Query

Range

  • Date and Time: "2000-01-01 00:00:00" to "2100-01-01 00:00:00"
  • Temperature: -60.0 to 100.0 (°C)
  • Pass/Fail: 1| 0
Requirements GSM/GPRS/
EGPRS TA

Revision: A.09 and above
GSM/GPRS/ EGPRS LA

Revision: F.01 and above

Programming Example

OUTPUT 714;"CALIBRATION:SMONITOR:INFORMATION GSM/GPRS?"


CALibration Subsystem

CALibration Subsystem

Description

The only user calibration that can be performed is for the IQ modulator. This calibration is required if the Baseband Generator or the Vector Output modules are serviced or swapped. The CALibration:IQ subsystem should not be used as part of frequent (i.e. daily, weekly or monthly) test set calibration.

Syntax Diagram and Command Descriptions

CALibration


CALL:ATTached

CALL:ATTached

Last updated:December 3, 2008

GPIB Command Conventions

  • CALL:ATTached[:STATe]?

CALL:ATTached[:STATe]?

Function

GSM TA

 This command is not applicable to GSM.

GPRS TA

Queries the data connection and determines if it is in the attached state. 1 is returned if the data connection is in the attached state. 0 is returned if the data connection is in any other non-transitory state. For more details on the Attached State query or the data connection states, see Data Connection Processing State Synchronization .

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Range: 0 | 1

*RST Setting

0 | OFF

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:ATTached:STATe?"


CALL:BA

CALL:BA

GPIB Command Conventions

  • CALL[:CELL]:BA:TABLe[:SELected]
  • CALL[:CELL]:BA:TABLe:NCELl<n>[:STATe]:<band>
  • CALL[:CELL]:BA:TABLe:NCELl<n>:ARFCn:<band>
  • CALL[:CELL]:BA:TABLe:NCELl<n>:BCCode:<band>
  • CALL[:CELL]:BA:TABLe:NCELl<n>:NCCode:<band>
  • CALL[:CELL]:BA:TABLe:NCELl<n>:RPRiority:<band>
  • CALL[:CELL]:BA:TABLe:POINts[:SELected]?

CALL[:CELL]:BA:TABLe[:SELected]

CALL[:CELL]:BA:TABLe:(DCS|EGSM|GSM450|GSM480|GSM750|GSM850|PCS|PGSM|RGSM|TGSM810)

Function

 GSM TA

This command sets/queries the BA Table ARFCN entries for the selected broadcast band in the active (that is the selected) format. Entries are set (value entered into table and state set to ON) using a comma separated list of 1 to 32 values for lab applications or 1 to 16 values for test applications. States of table entries not included in the setting list are set to OFF. Sending a null list (no values) sets states of all table entries to OFF. Query returns a comma separated list of the table entries that are in the ON state. If states of all table entries are set to OFF, query returns 9.91E+37 (NAN).

GPRS TA

EGPRS TA
GSM/GPRS LA

EGPRS LA

Setting

Range: (Depends on the selected broadcast band)

  • DCS broadcast band range: 512 to 885
  • EGSM broadcast band range: 0 to 124 | 975 to 1023
  • GSM450 broadcast band range: 259 to 293
  • GSM480 broadcast band range: 306 to 340
  • GSM750 broadcast band range: 438 to 511
  • GSM850 broadcast band range: 128 to 251
  • PCS broadcast band range: 512 to 810
  • PGSM broadcast band range: 1 to 124
  • RGSM broadcast band range: 0 to 124 | 955 to 1023
  • TGSM810 band, channels 350 to 425

Resolution: 1

Query

Range: (Depends on the selected broadcast band)

  • DCS broadcast band range: 512 to 885
  • EGSM broadcast band range: 0 to 124 | 975 to 1023
  • GSM450 broadcast band range: 259 to 293
  • GSM480 broadcast band range: 306 to 340
  • GSM750 broadcast band range: 438 to 511
  • GSM850 broadcast band range: 128 to 251
  • PCS broadcast band range: 512 to 810
  • PGSM broadcast band range: 1 to 124
  • RGSM broadcast band range: 0 to 124 | 955 to 1023
  • TGSM810 band, channels 350 to 425

Resolution: 1

*RST Setting

 See Default ARFCNs in BA Table
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above

Revision A.06 adds the TGSM810 band.
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Revision D.03 adds the TGSM810 band.

Revision F.00.37 adds neighbour cell 17 to 32.

Programming Example

OUTPUT 714;"CALL:CELL:BA:TABLE:SELECTED 512,689,885"
! Sets 3 table entries for the selected broadcast band.
! States of the remaining 13 entries are set to OFF.

OUTPUT 714;"CALL:CELL:BA:TABLE:SELECTED"
! Sets states of all table entries to OFF.

CALL[:CELL]:BA:TABLe:NCELl<n>[:STATe]:<band>

Function

 GSM TA This command is not applicable to the GSM Test Application.

GPRS TA

 This command is not applicable to the GPRS Test Application.

EGPRS TA

 This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

This command sets/queries the cell state for Neighbour Cell <n>, where <n> is any integer 1 to 32 for lab applications and 1 to 16 for test applications.

EGPRS LA

Setting

Range: 1 | ON | 0 | OFF

Query

Range: 1 |0

*RST Setting

The default setting is 1|ON for Neighbour cell 1 and 0|OFF for all the other Neighbour cells,

Requirements GSM/GPRS/ EGPRS TA

Revision: A.07 and above
GSM/GPRS/ EGPRS LA

Revision: E.00.12 and above

Revision F.00.37 adds neighbour cell 17 to 32.

Programming Example

OUTPUT 714;"CALL:CELL:BA:TABLE:NCELL3 ON"
! Sets Cell state of Neighbour cell 3 to ON.

CALL[:CELL]:BA:TABLe:NCELl<n>:ARFCn:<band>

Function

 GSM TA This command is not applicable to the GSM Test Application.

GPRS TA

 This command is not applicable to the GPRS Test Application.

EGPRS TA

 This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

This command sets/queries the ARFCn for Neighbour Cell <n>, where <n> is any integer 1 to 32 for lab applications and 1 to 16 for test applications.

EGPRS LA

Setting

Range: (Depends on the selected broadcast band)

  • DCS broadcast band range: 512 to 885
  • EGSM broadcast band range: 0 to 124 | 975 to 1023
  • GSM450 broadcast band range: 259 to 293
  • GSM480 broadcast band range: 306 to 340
  • GSM750 broadcast band range: 438 to 511
  • GSM850 broadcast band range: 128 to 251
  • PCS broadcast band range: 512 to 810
  • PGSM broadcast band range: 1 to 124
  • RGSM broadcast band range: 0 to 124 | 955 to 1023
  • TGSM810 band, channels 350 to 425

Resolution: 1

Query

Range: (Depends on the selected broadcast band)

  • DCS broadcast band range: 512 to 885
  • EGSM broadcast band range: 0 to 124 | 975 to 1023
  • GSM450 broadcast band range: 259 to 293
  • GSM480 broadcast band range: 306 to 340
  • GSM750 broadcast band range: 438 to 511
  • GSM850 broadcast band range: 128 to 251
  • PCS broadcast band range: 512 to 810
  • PGSM broadcast band range: 1 to 124
  • RGSM broadcast band range: 0 to 124 | 955 to 1023
  • TGSM810 band, channels 350 to 425

Resolution: 1

*RST Setting

Depends on the selected broadcast band. See Default ARFCNs in BA Table

Requirements GSM/GPRS/ EGPRS TA

Revision: A.07 and above
GSM/GPRS/ EGPRS LA

Revision: E.00.12 and above

Revision F.00.37 adds neighbour cell 17 to 32.

Programming Example

OUTPUT 714;"CALL:CELL:BA:TABLE:NCELL3:ARFCN 6"
! Sets ARFCN of Neighbour cell 3 to ON.

CALL[:CELL]:BA:TABLe:NCELl<n>:BCCode:<band>

Function

 GSM TA This command is not applicable to the GSM Test Application.

GPRS TA

 This command is not applicable to the GPRS Test Application.

EGPRS TA

 This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

This command sets/queries the Base station Color Code (BCC) for Neighbour Cell <n>, where <n> is any integer 1 to 32 for lab applications and 1 to 16 for test applications.

EGPRS LA

Setting

Range: 0 to 7

Resolution: 1

Query

Range: 0 to 7

*RST Setting

0
Requirements GSM/GPRS/ EGPRS TA

Revision: A.07 and above
GSM/GPRS/ EGPRS LA

Revision: E.00.12 and above

Revision F.00.37 adds neighbour cell 17 to 32.

Programming Example

OUTPUT 714;"CALL:CELL:BA:TABLE:NCELL3:BCCODE 6"
! Sets BCC of Neighbour cell 3 to ON.

CALL[:CELL]:BA:TABLe:NCELl<n>:NCCode:<band>

Function

 GSM TA This command is not applicable to the GSM Test Application.

GPRS TA

 This command is not applicable to the GPRS Test Application.

EGPRS TA

 This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

This command sets/queries the Network Color Code (NCC) for Neighbour Cell <n>, where <n> is any integer 1 to 32 for lab applications and 1 to 16 for test applications.

EGPRS LA

Setting

Range: 0 to 7

Resolution: 1

Query

Range: 0 to 7

*RST Setting

 0
Requirements GSM/GPRS/ EGPRS TA

Revision: A.07 and above
GSM/GPRS/ EGPRS LA

Revision: E.00.12 and above

Revision F.00.37 adds neighbour cell 17 to 32.

Programming Example

OUTPUT 714;"CALL:CELL:BA:TABLE:NCELL3:NCCODE 6"
! Sets NCC of Neighbour cell 3 to ON.

CALL[:CELL]:BA:TABLe:NCELl<n>:RPRiority:<band>

Function

 GSM TA This command is not applicable to the GSM Test Application.

GPRS TA

 This command is not applicable to the GPRS Test Application.

EGPRS TA

 This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

This command sets/queries the Reporting Priority for Neighbour Cell <n>, where <n> is any integer 1 to 32 for lab applications and 1 to 16 for test applications.

EGPRS LA

Setting

Range: HIGH |LOW

Query

Range: HIGH |LOW

*RST Setting

LOW
Requirements GSM/GPRS/ EGPRS TA

Revision: A.07 and above
GSM/GPRS/ EGPRS LA

Revision: E.00.12 and above

Revision F.00.37 adds neighbour cell 17 to 32.

Programming Example

OUTPUT 714;"CALL:CELL:BA:TABLE:NCELL3:RPRIORITY HIGH"
! Sets Reporting Priority of Neighbour cell 3 to HIGH.

CALL[:CELL]:BA:TABLe:POINts[:SELected]?

CALL[:CELL]:BA:TABLe:POINts:(DCS|EGSM|GSM450|GSM480|GSM750|GSM850|PCS|PGSM|RGSM|TGSM810)?

Funtion

 GSM TA

Queries the number of entries that are in the ON state in the selected broadcast band's BA Table. A return value of zero indicates that there are no table entries in the ON state.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Range: 0 to 32

Resolution: 1

*RST Setting

1
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above

Revision A.06 adds the TGSM810 band.
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Revision D.03 adds the TGSM810 band.

Revision F.00.37 adds neighbour cell 17 to 32

Programming Example

OUTPUT 714;"CALL:CELL:BA:TABLE:POINTS:SELECTED?"
! Queries the number of entries that are in the ON state in the selected broadcast band's BA Table.


CALL:BAND

CALL:BAND

GPIB Command Conventions

  • CALL[:CELL]:BAND<[:SELected]|:GSM>

CALL[:CELL]:BAND<[:SELected]|:GSM>

Function GSM TA

This command sets/queries the band in which the broadcast channel (BCH) is transmitted.

If this parameter is changed to PCS or DCS the Band Indicator changes to match this setting. The Band Indicator is not affected by other settings to the BCH Cell Band. The command to set the Band Indicator is CALL[:CELL]:BINDicator .

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Setting

Range: PGSM | DCS | EGSM | GSM450 | GSM480 | GSM750 | GSM850 | PCS | RGSM | TGSM810

Query

Range: PGSM | DCS | EGSM | GSM450 | GSM480 | GSM750 | GSM850 | PCS | RGSM | TGSM810

*RST Setting

The *RST value of this command depends on the format currently active. For example, if the GSM format is currently active, the *RST value for this command is the value equivalent to that generated by the command containing the :GSM format identifier.

Related Topics

 GSM

See Cell Band Parameter .

GPRS

See Cell Band Parameter

Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
A.06 adds TGSM810
GSM/GPRS/ EGPRS LA

Revision: C.01 and above
D.03 adds TGSM810

Programming Example

OUTPUT 714;"CALL:CELL:BAND PGSM"
! Sets the band for the BCH to PGSM.


CALL:BCCode

CALL:BCCode

GPIB Command Conventions

  • CALL[:CELL]:BCCode

CALL[:CELL]:BCCode

Function

 GSM TA

Sets/queries the value of the BCC (Base Station Colour Code) for the active format which is the selected format. This can only be set when the Cell Activated State parameter is set to Off (see CALL:OPERating:MODE ).

The Expected Burst parameter should be set in addition to the BCC parameter when the test set's operating mode will be set to one of the Test Mode Operating Modes .The Expected Burst parameter allows you to configure the test set to expect a certain uplink midamble pattern (TSC0 through TSC7). The command to configure the Expected burst parameter is CALL:BURSt:TYPE[:SELected] .

GPRS TA

EGPRS TA
GSM/GPRS LA

EGPRS LA

Setting

Range: 0 to 7

Resolution: 1

Query

Range: 0 to 7

Resolution: 1

*RST Setting

5
Related Topics

See Configuring the Broadcast Channel (BCH) .
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:CELL:BCCode 4"
! Sets the cell's base station color code to 4.


CALL:BCHannel

CALL:BCHannel

GPIB Command Conventions

  • CALL[:CELL]:BCHannel[:ARFCn][:SELected]
  • CALL[:CELL]:BCHannel:BEPPeriod
  • CALL[:CELL]:BCHannel:BEPPeriod2[:SVALue]
  • CALL[:CELL]:BCHannel:BEPPeriod2:STATe
  • CALL[:CELL]:BCHannel:BEPPeriod2:VALue
  • CALL[:CELL]:BCHannel:BSEQuence:CVALue:MAXimum
  • CALL[:CELL]:BCHannel:CBAR:ACCess
  • CALL[:CELL]:BCHannel:CBAR:QUALify
  • CALL[:CELL]:BCHannel:CIDentity
  • CALL[:CELL]:BCHannel:CRHYsteresis
  • CALL[:CELL]:BCHannel:CROFfset
  • CALL[:CELL]:BCHannel:DRXTimer:MAXimum
  • CALL[:CELL]:BCHannel:MREPorting
  • CALL[:CELL]:BCHannel:MSCRevision
  • CALL[:CELL]:BCHannel:MS:POWer:OFFSet:DCS
  • CALL[:CELL]:BCHannel:MS:TXLevel[:SELected]
  • CALL[:CELL]:BCHannel:N:AVGI
  • CALL[:CELL]:BCHannel:NCCPermitted
  • CALL[:CELL]:BCHannel:NCONtrol:RPERiod:IDLE
  • CALL[:CELL]:BCHannel:NCONtrol:RPERiod:TRANsferring
  • CALL[:CELL]:BCHannel:NCORder
  • CALL[:CELL]:BCHannel:PCMChannel
  • CALL[:CELL]:BCHannel:PTIMe
  • CALL[:CELL]:BCHannel:REPorting:RATE
  • CALL[:CELL]:BCHannel:REPorting:TYPE
  • CALL[:CELL]:BCHannel:RLAMinimum
  • CALL[:CELL]:BCHannel:SBReporting
  • CALL[:CELL]:BCHannel:SCELl
  • CALL[:CELL]:BCHannel:SORD
  • CALL[:CELL]:BCHannel:T:AVGT
  • CALL[:CELL]:BCHannel:T:AVGW
  • CALL[:CELL]:BCHannel:TOFFset
  • CALL[:CELL]:BCHannel:TYPE

CALL[:CELL]:BCHannel[:ARFCn][:SELected]

CALL[:CELL]:BCHannel[:ARFCn]:(DCS|EGSM|GSM450|GSM480|GSM750|GSM850|PCS|PGSM|RGSM|TGSM810)

Function

 GSM TA

This command sets/queries the broadcast channel ARFCN for the currently selected broadcast band.

The optional [:SELected] keyword in this command specifies that the BCH ARFCN being set or queried applies to the currently selected cell band.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Setting

Depends upon the selected broadcast band.

Range:

  • DCS broadcast band range: 512 to 885
  • EGSM broadcast band range: 0 to 124 | 975 to 1023
  • GSM450 broadcast band range: 259 to 293
  • GSM480 broadcast band range: 306 to 340
  • GSM750 broadcast band range: 438 to 511
  • GSM850 broadcast band range: 128 to 251
  • PCS broadcast band range: 512 to 810
  • PGSM broadcast band range: 1 to 124
  • RGSM broadcast band range: 0 to 124 | 955 to 1023
  • TGSM810 band, channels 350 to 425

Resolution: 1

Query

Depends upon the selected broadcast band.

Range:

  • DCS broadcast band range: 512 to 885
  • EGSM broadcast band range: 0 to 124 | 975 to 1023
  • GSM450 broadcast band range: 259 to 293
  • GSM480 broadcast band range: 306 to 340
  • GSM750 broadcast band range: 438 to 511
  • GSM850 broadcast band range: 128 to 251
  • PCS broadcast band range: 512 to 810
  • PGSM broadcast band range: 1 to 124
  • RGSM broadcast band range: 0 to 124 | 955 to 1023
  • TGSM810 band, channels 350 to 425

Resolution: 1

*RST Setting

Depends upon the selected broadcast band.

Range:

  • DCS *RST Setting: 512
  • EGSM *RST Setting: 20
  • GM450 *RST Setting: 270
  • GSM480 *RST Setting: 310
  • GSM750 *RST Setting: 450
  • GSM850 *RST Setting: 150
  • PCS *RST Setting: 512
  • PGSM *RST Setting: 20
  • RGSM *RST Setting: 20
  • TGSM810 *RST Setting: 380
Related Topics

Configuring the Broadcast Channel (BCH) .
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above

Revision A.06 adds the TGSM810 band.
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Revision D.03 adds the TGSM810 band.

Programming Example

OUTPUT 714;"CALL:BCHannel:ARFCN:PCS 512"
! Sets BCH ARFCN for the PCS broadcast band to channel 512.

CALL[:CELL]:BCHannel:BEPPeriod

Function

 GSM TA This command is not applicable to the GSM TA.

GPRS TA

 This command is not applicable to the GPRS TA.

EGPRS TA

 This command is not applicable to the EGPRS TA.

GSM/GPRS LA

 This command sets/queries the BEP (Bit Error Probability) Period parameter.

EGPRS LA

Setting

Range: 0 to 10

Resolution: 1

Query

Range: 0 to 10

Resolution: 1

*RST Setting

 0
Requirements GSM/GPRS/ EGPRS LA Revision: E.00.08 and above

Programming Example

OUTPUT 714;"CALL:BCHannel:BEPPeriod 0"
! Sets the BEP Probability to 0.

CALL[:CELL]:BCHannel:BEPPeriod2[:SVALue]

Function

 GSM TA This command is not applicable to the GSM TA.

GPRS TA

 This command is not applicable to the GPRS TA.

EGPRS TA

 This command is not applicable to the EGPRS TA.

GSM/GPRS LA

 This command is not applicable to the GSM/GPRS LA.

EGPRS LA

 This command sets/queries the BEP (Bit Error Probability) Period 2 value and the BEP Period 2 state. The BEP Period 2 directly maps to the BEP_PERIOD2 field in the Packet Downlink Asssignment, Packet Uplink Assignmnt or Packet CS Release Indication OTA message. The BEP_PERIOD2 field contains a constant which is used for filtering channel quality measurements in EGPRS.

Setting

Range: 0 to 15

Resolution: 1

Query

Range: 0 to 15

Resolution: 1

*RST Setting

 15
Requirements GSM/GPRS/ EGPRS LA Revision: G.00.00 and above

Programming Example

OUTPUT 714;"CALL:BCHannel:BEPPeriod2 15"
! Sets the BEP Period 2 state to ON the value to 15.

CALL[:CELL]:BCHannel:BEPPeriod2:STATe

Function

 GSM TA This command is not applicable to the GSM TA.

GPRS TA

 This command is not applicable to the GPRS TA.

EGPRS TA

 This command is not applicable to the EGPRS TA.

GSM/GPRS LA

 This command is not applicable to the GSM/GPRS LA.

EGPRS LA

 This command sets/queries the BEP (Bit Error Probability) Period 2 state. When the parameter is set to ON, the BEP_PERIOD2 field will be sent in the Packet Downlink Asssignment, Packet Uplink Assignment or Packet CS Release Indication OTA messages.

Setting

 Range: 1|ON|0|OFF

Query

Range: 0 | 1

*RST Setting

 OFF
Requirements GSM/GPRS/ EGPRS LA Revision: G.00.00 and above

Programming Example

OUTPUT 714;"CALL:BCHannel:BEPPeriod2:STATe OFF"
! Sets the BEP Period 2 state to OFF.

CALL[:CELL]:BCHannel:BEPPeriod2:VALue

Function

 GSM TA This command is not applicable to the GSM TA.

GPRS TA

 This command is not applicable to the GPRS TA.

EGPRS TA

 This command is not applicable to the EGPRS TA.

GSM/GPRS LA

 This command is not applicable to the GSM/GPRS LA.

EGPRS LA

 This command sets/queries the BEP (Bit Error Probability) Period 2 value. The BEP Period 2 directly maps to the BEP_PERIOD2 field in the Packet Downlink Asssignment, Packet Uplink Assignmnt or Packet CS Release Indication OTA message. The BEP_PERIOD2 field contains a constant which is used for filtering channel quality measurements in EGPRS.

Setting

Range: 0 to 15

Resolution: 1

Query

Range: 0 to 15

Resolution: 1

*RST Setting

 15
Requirements GSM/GPRS/ EGPRS LA Revision: G.00.xx and above

Programming Example

OUTPUT 714;"CALL:BCHannel:BEPPeriod2:VALue 15"
! Sets the BEP Period 2 value to 15.

CALL[:CELL]:BCHannel:BSEQuence:CVALue:MAXimum

Function

 GSM TA This command is not applicable to the GSM TA.

GPRS TA

 This command is not applicable to the GPRS TA.

EGPRS TA

 This command is not applicable to the EGPRS TA.

GSM/GPRS LA

 This command sets/queries the Block Sequence Countdown Value Max parameter.

EGPRS LA

Setting

Range: 0 to 15

Resolution: 1

Query

Range: 0 to 15

Resolution: 1

*RST Setting

 0
Requirements GSM/GPRS/ EGPRS LA Revision: E.00.08 and above

Programming Example

OUTPUT 714;"CALL:BCHannel:BSEQuence:CVALue:MAXimum 0"
! Sets the Block Sequence Countdown Value Max value to 0.

CALL[:CELL]:BCHannel:CBAR:ACCess

Function

 GSM TA This command is not applicable to the GSM TA.

GPRS TA

 This command is not applicable to the GPRS TA.

EGPRS TA

 This command is not applicable to the EGPRS TA.

GSM/GPRS LA

This command sets/queries the Cell Bar Access parameter. The Cell Bar Access parameter as well as the Cell Bar Qualify parameter affect the cell priority for cell selection parameters.

The command to set the Cell Bar Qualify parameter is CALL[:CELL]:BCHannel:CBAR:QUALify .

EGPRS LA

Setting

Range: 0|1

Query

Range: 0|1

*RST Setting

 0
Requirements GSM/GPRS/ EGPRS LA Revision: E.00.08 and above

Programming Example

OUTPUT 714;"CALL:BCHannel:CBACcess 0"
! Sets the Cell Bar Access parameter to 0.

CALL[:CELL]:BCHannel:CBAR:QUALify

Function

 GSM TA This command is not applicable to the GSM TA.

GPRS TA

 This command is not applicable to the GPRS TA.

EGPRS TA

 This command is not applicable to the EGPRS TA.

GSM/GPRS LA

This command sets/queries the Cell Bar Qualify parameter. The Cell Bar Qualify parameter as well as Cell Bar Access parameter affect the cell priority for cell selection parameters.

The command to set the Cell Bar Access Parameter is CALL[:CELL]:BCHannel:CBAR:ACCess .

EGPRS LA

Setting

Range: 0|1

Query

Range: 0|1

*RST Setting

 0
Requirements GSM/GPRS/ EGPRS LA Revision: E.00.08 and above

Programming Example

OUTPUT 714;"CALL:BCHannel:CBQualify 1"
! Sets the Cell Bar Qualify to 1.

CALL[:CELL]:BCHannel:CIDentity

Function

 GSM TA This command is not applicable to the GSM TA.

GPRS TA

 This command is not applicable to the GPRS TA.

EGPRS TA

 This command is not applicable to the EGPRS TA.

GSM/GPRS LA

 This command sets/queries the Cell Identity parameter. The Cell Identity uniquely identifies a cell within the location area.

EGPRS LA

Setting

Range: 0 to 65535

Resolution: 1

Query

Range: 0 to 65535

Resolution: 1

*RST Setting

 0
Requirements GSM/GPRS/ EGPRS LA Revision: E.00.05 and above

Programming Example

OUTPUT 714;"CALL:BCHannel:CIDentity 5"
! Sets the Cell Identity to 5.

CALL[:CELL]:BCHannel:CRHYsteresis

Function

 GSM TA This command is not applicable to the GSM TA.

GPRS TA

 This command is not applicable to the GPRS TA.

EGPRS TA

 This command is not applicable to the EGPRS TA.

GSM/GPRS LA

 This command sets/queries the Cell Reselect Hysteresis parameter. The Cell Reselect Hysteresis parameter sets the hysteresis level required for cell reselection.

EGPRS LA

Setting

Range: 0 to 7

Resolution: 1

Query

Range: 0 to 7

Resolution: 1

*RST Setting

 3
Requirements GSM/GPRS/ EGPRS LA Revision: E.00.08 and above

Programming Example

OUTPUT 714;"CALL:BCHannel:CRHYsteresis 1"
! Sets the Cell Reselect Hysteresis to 1.

CALL[:CELL]:BCHannel:CROFfset

Function

 GSM TA This command is not applicable to the GSM TA.

GPRS TA

 This command is not applicable to the GPRS TA.

EGPRS TA

 This command is not applicable to the EGPRS TA.

GSM/GPRS LA

 This command sets/queries the Cell Reselect Offset parameter. The Cell Reselect Offset parameter sets the offset that is applied to the second cell's (C2) reselection criteria.

EGPRS LA

Setting

Range: 0 to 63

Resolution: 1

Query

Range: 0 to 63

Resolution: 1

*RST Setting

 3
Requirements GSM/GPRS/ EGPRS LA Revision: E.00.08 and above

Programming Example

OUTPUT 714;"CALL:BCHannel:CROFfset 3"
! Sets the Cell Reselect Offset to 3.

CALL[:CELL]:BCHannel:DRXTimer:MAXimum

Function

 GSM TA This command is not applicable to the GSM TA.

GPRS TA

 This command is not applicable to the GPRS TA.

EGPRS TA

 This command is not applicable to the EGPRS TA.

GSM/GPRS LA

 This command sets/queries the maximum DRX (Discontinuous Receiver) Timer Max parameter.

EGPRS LA

Setting

Range: 0 to 7

Resolution: 1

Query

Range: 0 to 7

Resolution: 1

*RST Setting

 0
Requirements GSM/GPRS/ EGPRS LA Revision: E.00.08 and above

Programming Example

OUTPUT 714;"CALL:BCHannel:DRXTimer:MAXimum 0"
! Sets the maximum DRX Timer Max to 0.

CALL[:CELL]:BCHannel:MREPorting

Function

 GSM TA This command is not applicable to the GSM TA.

GPRS TA

 This command is not applicable to the GPRS TA.

EGPRS TA

 This command is not applicable to the EGPRS TA.

GSM/GPRS LA

 This parameter sets/queries the Multiband Reporting parameter. The Multiband Reporting parameter controls the number of carriers from each frequency band that are included in the measurement report.

EGPRS LA

Setting

Range: 0 to 3

Resolution: 1

Query

Range:

Resolution: 1

*RST Setting

 0
Requirements GSM/GPRS/ EGPRS LA Revision: E.00.08 and above

Programming Example

OUTPUT 714;"CALL:BCHannel:MREPorting 0"
! Sets the Multiband Reporting paramter to 0.

CALL[:CELL]:BCHannel:MSCRevision

Function

 GSM TA This command sets/queries the MSC/SGSN Revision Setting. This command sets the MSC revision field on the BCH System Information 3 Message. It also sets the SGSN field to "not present".

This parameter can only be set when the Operating Mode parameter is set to Off (see CALL:OPERating:MODE )

GPRS TA

EGPRS TA

GSM/GPRS LA
EGPRS LA
Setting Range: R99 | R98

Query

 Range: R99 | R98

*RST Setting

 R99
Related Topics

Serving Cell .
Requirements GSM/GPRS/
EGPRS TA

Revision: A.03 and above
GSM/GPRS/
EGPRS LA

Revision: C.03 and above

Programming Example

OUTPUT 714;"CALL:CELL:BCHannel:MSCRevision R98"
! Sets MSC Revision field in the broadcast channel System Information message to Revision 98.

CALL[:CELL]:BCHannel:MS:POWer:OFFSet:DCS

Function

GSM TA

This command defines an additional offset value that is used to set the MS TX Power Max CCH DCS1800 Offset, which increases the maximum control channel power for DCS band only. See Access Burst Power Control . NOTE: CALL:BCHannel:MS:TXLevel:DCS must be set to 0 or this power offset command has no effect. Each unit parameter equates to an additional 2 dB power increase. The offset settings are:
"0" = 0 dB,
"1" = 2 dB,
"2" = 4 dB,
"3" = 6 dB.

This can only be set when the Cell Operating Mode parameter is set to Off (see CALL:OPERating:MODE ).

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Setting

Range: 0 | 1 | 2 | 3

Query

Range: 0 | 1 | 2 | 3

*RST Setting

 0
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: E.00.08 and above

Programming Example

OUTPUT 714;"CALL:BCHannel:MS:TXLevel:DCS 0"
! Sets control channel transmit level to 0 to allow use of the following command.

OUTPUT 714;"CALL:BCHannel:MS:POWer:OFFSet:DCS 1"
! Adds 2 dB power increase to the control channel for the DCS band.

CALL[:CELL]:BCHannel:MS:TXLevel[:SELected]

CALL[:CELL]:BCHannel:MS:TXLevel:(DCS|EGSM|GSM450|GSM480|GSM750|GSM850|PCS|PGSM|RGSM|TGSM810)

Function

GSM TA

This command sets the MS TX Power Max CCH (GSM) parameter, which controls the maximum control channel power that the mobile station can use for access bursts for the specified band. See GSM Frequency Banded Parameters .

This setting is only accessible when the Cell Operating Mode parameter is set to Off (see CALL:OPERating:MODE ).

This parameter must be set to 0 if you want to use the DCS power offset command CALL[:CELL]:BCHannel:MS:POWer:OFFSet:DCS to set the control channel power level in 2 dB steps from 0 to 6 dB. Setting a value with CALL:BCHannel:MS:TXLevel:DCS will not allow use of the power offset command. See Access Burst Power Control .

GPRS TA

EGPRS TA
GSM/GPRS LA

EGPRS LA

Setting

(Depends on the band.)

DCS:

  • Range: 0 to 28, Resolution: 1

PCS:

  • Range: 0 to 15, 30, and 31, Resolution: 1

All other bands:

  • Range: 0 to 15, 30, and 31, Resolution: 1

Query

(Depends on the band.)

DCS:

  • Range: 0 to 28, Resolution: 1

PCS:

  • Range: 0 to 15, 30, and 31, Resolution: 1

All other bands:

  • Range: 0 to 15, 30, and 31, Resolution: 1

*RST Setting

 0
Requirements GSM/GPRS/ EGPRS LA

Revision: E.00.08 and above

Programming Example

OUTPUT 714;"CALL:BCHannel:MS:TXLevel 10"
! Sets the MS TX Power Max (GSM) to 10.

CALL[:CELL]:BCHannel:N:AVGI

Function

 GSM TA This command is not applicable to the GSM TA.

GPRS TA

 This command is not applicable to the GPRS TA.

EGPRS TA

 This command is not applicable to the EGPRS TA.

GSM/GPRS LA

 This command sets/queries the NAVG_I parameter. This parameter is the interference signal level filter constant for power control of 2(k/2), where k=0,1...15.

EGPRS LA

Setting

Range: 0 to 15

Resolution: 1

Query

Range: 0 to 15

Resolution: 1

*RST Setting

 11
Requirements GSM/GPRS/ EGPRS LA Revision: E.00.08 and above

Programming Example

OUTPUT 714;"CALL:BCHannel:N:AVGI 11"
! Sets the Navg_i parameter to 2^(11/2).

CALL[:CELL]:BCHannel:NCCPermitted

Function

 GSM TA This command is not applicable to the GSM TA.

GPRS TA

 This command is not applicable to the GPRS TA.

EGPRS TA

 This command is not applicable to the EGPRS TA.

GSM/GPRS LA

 This command sets/queries the NCC Permitted parameter. The NCC Permitted parameter sets the NCCs (Network Color Codes) that the mobile station is permitted to report.

EGPRS LA

Setting

Range: 0 to 255

Resolution: 1

Query

Range: 0 to 255

Resolution: 1

*RST Setting

 255
Requirements GSM/GPRS/ EGPRS LA Revision: E.00.08 and above

Programming Example

OUTPUT 714;"CALL:BCHannel:NCCPermitted 2"
! Sets the number of NCCs permitted to 2.

CALL[:CELL]:BCHannel:NCONtrol:RPERiod:IDLE

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

This command sets/queries the Network Control Reporting Period (Idle) parameter. This parameter controls the time period for measurement reporting during packet idle mode.
EGPRS LA

Setting

Range: 0 to 7, which corresponds to 0.48, 0.96, 1.92, 3.84, 7.68, 15.36, 30,72, and 61.44 seconds.

Resolution: 1

Query

Range: 0 to 7

Resolution: 1

*RST Setting

 7
Requirements GSM/GPRS/ EGPRS LA

Revision: E.00.12 and above

Programming Example

OUTPUT 714;"CALL:BCHannel:NCONtrol:RPERiod:IDLE 7"
! Sets the Network Control Reporting Period (Idle) to 61.44 seconds.

CALL[:CELL]:BCHannel:NCONtrol:RPERiod:TRANsferring

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

This command sets/queries the Network Control Reporting Period (Transfer) parameter. This parameter controls the time period for measurement reporting during packet transfer.
EGPRS LA

Setting

Range: 0 to 7, which corresponds to 0.48, 0.96, 1.92, 3.84, 7.68, 15.36, 30,72, and 61.44 seconds.

Resolution: 1

Query

Range: 0 to 7

Resolution: 1

*RST Setting

 3
Requirements GSM/GPRS/ EGPRS LA

Revision: E.00.12 and above

Programming Example

OUTPUT 714;"CALL:BCHannel:NCONtrol:RPERiod:TRANsferring 3"
! Sets the Network Control Reporting Period (Transfer) to 3.84 seconds.

CALL[:CELL]:BCHannel:NCORder

Function

 GSM TA This command is not applicable to the GSM TA.

GPRS TA

 This command is not applicable to the GPRS TA.

EGPRS TA

 This command is not applicable to the EGPRS TA.

GSM/GPRS LA

This command sets/queries the Network Control Order parameter.

The Network Control Order parameter sets the level of control the network has to control measurement reporting and cell reselection. There are three settings:

  • NC0 - allows the mobile station (MS) to perform autonomous cell reselections, which is normal mobile station control. NOTE: The MS does not send measurement reports to the network.
  • NC1 - The MS performs autonomous cell reselection and sends measurement reports to the network.
  • NC2 - The MS sends measurement reports to the network and does not perform autonomous cell reselection unless triggered downlink signaling failure or random access failure.

Network Control Order determines how the MS should perform cell reselections. If the Network Control Order has been set to NC0 or NC1 at the test set to which the MS is GPRS attached has the Network Control Order set to NC2, autonomous cell reselection may not be performed by the MS as a result of invalid BCH configuration.

EGPRS LA

Setting

Range: 0 to 2

Resolution: 1

Query

Range: 0 to 2

Resolution: 1

*RST Setting

 0
Requirements GSM/GPRS/ EGPRS LA Revision: E.00.05 and above

Programming Example

OUTPUT 714;"CALL:BCHannel:NCOrder 1"
! Sets the Netwprk Contol Order to 1.

CALL[:CELL]:BCHannel:PCMChannel

Function

 GSM TA This command is not applicable to the GSM TA.

GPRS TA

 This command is not applicable to the GPRS TA.

EGPRS TA

 This command is not applicable to the EGPRS TA.

GSM/GPRS LA

 This command sets/queries the PC (Power Control) Measurement Channel parameter. This parameter indicates whether the downlink measurements for power control shall be made on the BCCH or PDTCH.

EGPRS LA

Setting

Range: 0|1

Query

Range: 0|1

*RST Setting

 0
Requirements GSM/GPRS/ EGPRS LA Revision: E.00.12 and above

Programming Example

OUTPUT 714;"CALL:BCHannel:PCMChannel 0"
! Sets the PC Measurement Channel to BCCH.

CALL[:CELL]:BCHannel:PTIMe

Function

 GSM TA This command is not applicable to the GSM TA.

GPRS TA

 This command is not applicable to the GPRS TA.

EGPRS TA

 This command is not applicable to the EGPRS TA.

GSM/GPRS LA

This command sets/queries the C2 Penalty Time. This parameter sets the duration that the C2 Temporary Offset is applied.

The command to set the C2 Temporary Offset is CALL[:CELL]:BCHannel:TOFFset .

EGPRS LA

Setting

Range: 0 to 31

Resolution: 1

Query

Range: 0 to 31

Resolution: 1

*RST Setting

 0
Requirements GSM/GPRS/ EGPRS LA Revision: E.00.05 and above

Programming Example

OUTPUT 714;"CALL:BCHannel:PTIMe 10"
! Sets the Penalty Time to 10 seconds.

CALL[:CELL]:BCHannel:REPorting:RATE

Function

 GSM TA This command is not applicable to the GSM TA.

GPRS TA

 This command is not applicable to the GPRS TA.

EGPRS TA

 This command is not applicable to the EGPRS TA.

GSM/GPRS LA

This command sets/queries the reporting rate. This parameter sets the rate of measurement report performed by the Mobie Station.

EGPRS LA

Setting

Range: NORMal|REDuced

Query

Range: NORMal|REDuced

*RST Setting

 NORMal
Requirements GSM/GPRS/ EGPRS LA Revision: E.00.12 and above

Programming Example

OUTPUT 714;"CALL:BCHannel:REPorting:RATE REDuced"
! Sets the reporting rate to reduced.

CALL[:CELL]:BCHannel:REPorting:TYPE

Function

 GSM TA This command is not applicable to the GSM TA.

GPRS TA

 This command is not applicable to the GPRS TA.

EGPRS TA

 This command is not applicable to the EGPRS TA.

GSM/GPRS LA

This command sets/queries the reporting type. This parameter sets the type of measurement report performed by the Mobie Station.

EGPRS LA

Setting

Range: NORMal|ENHanced

Query

Range: NORMal|ENHanced

*RST Setting

 NORMal
Requirements GSM/GPRS/ EGPRS LA Revision: E.00.12 and above

Programming Example

OUTPUT 714;"CALL:BCHannel:REPorting:TYPE Enhanced"
! Sets the reporting type to ENHanced.

CALL[:CELL]:BCHannel:RLAMinimum

Function

 GSM TA This command is not applicable to the GSM TA.

GPRS TA

 This command is not applicable to the GPRS TA.

EGPRS TA

 This command is not applicable to the EGPRS TA.

GSM/GPRS LA

This command sets/queries the minimum RX Access Level. This parameter sets the minimum received signal level at the mobile station required for the mobile station to access the two cell test system.

The measured signal level shall be mapped to an RXLEV value between 0 and 63, as follows: RXLEV 0 = less than 110 dBm + SCALE. RXLEV 1 = 110 dBm + SCALE to 109 dBm + SCALE. RXLEV 2 = 109 dBm + SCALE to 108 dBm + SCALE. : : RXLEV 62 = 49 dBm + SCALE to 48 dBm + SCALE. RXLEV 63 = greater than 48 dBm + SCALE.where SCALE is an offset that is used in the ENHANCED MEASUREMENT REPORT and PACKET ENHANCED MEASUREMENT REPORT messages, otherwise it is set to 0.

The MS shall use the SCALE value as indicated by the parameter SCALE_ORD in the MEASUREMENT INFORMATION, PACKET CELL CHANGE ORDER and PACKET MEASUREMENT ORDER messages. If automatic scaling mode is indicated by SCALE_ORD, the MS shall choose the lowest SCALE value that is sufficient for reporting the strongest signal level within each ENHANCED MEASUREMENT REPORT or PACKET ENHANCED MEASUREMENT REPORT message. See CALL[:CELL]:BCHannel:SORD

EGPRS LA

Setting

Range: 0 to 63

Resolution: 1

Query

Range: 0 to 63

Resolution: 1

*RST Setting

 0
Requirements GSM/GPRS/ EGPRS LA Revision: E.00.08 and above

Programming Example

OUTPUT 714;"CALL:BCHannel:RLAMinimum 50"
! Sets the RX Level Access Minimum to RXLEV50.

CALL[:CELL]:BCHannel:SBReporting

Function

 GSM TA This command is not applicable to the GSM TA.

GPRS TA

 This command is not applicable to the GPRS TA.

EGPRS TA

 This command is not applicable to the EGPRS TA.

GSM/GPRS LA

 This command sets/queries the Serving Band Reporting. The parameter indicates the number of cells from the GSM serving frequency band that shall be included in the measurement report

EGPRS LA

Setting

Range: 0 to 3

Resolution: 1

Query

Range: 0 to 3

Resolution: 1

*RST Setting

 0
Requirements GSM/GPRS/ EGPRS LA Revision: E.00.12 and above

Programming Example

OUTPUT 714;"CALL:BCHannel:SBReporting 2"
! Sets the Servind Band Reporting to 2.

CALL[:CELL]:BCHannel:SCELl

Function

 GSM TA

The serving cell command sets what information is broadcast on the broadcast channel. It can be set to either GSM, GPRS, or EGPRS to provide GPRS capabilities.

NOTE: If only one TA is licensed, the serving cell will be fixed to the only valid setting. For example, if only the GSM TA is licensed, the only available serving cell is GSM.

Setting the serving cell to GSM will hide GPRS features and a GPRS mobile will not see the serving cell as GPRS capable and therefore, will not attempt to attach.

When the setting is GPRS, EGPRS features are hidden and an EGPRS mobile does not see the serving cell as being EGPRS capable. However, an EGPRS mobile should still be able to attach using GMSK modulation coding schemes (MCS1 through MCS4).

When the setting is EGPRS, GPRS features are hidden and a GRPS mobile will not be able to attach to the test set. Use the GPRS setting in this situation.

You can still send GPIB commands to the test set which control functions associated with the serving cell that is not active. However, these settings are not applied until the serving cell is changed.

The: SCELl query command returns the current serving cell setting.

This parameter can only be set when the Operating Mode parameter is set to Off (see CALL:OPERating:MODE )

GPRS TA

EGPRS TA

GSM/GPRS LA

The serving cell command sets what information is broadcast on the broadcast channel. It can be set to either GSM or to GPRS to provide GPRS capabilities.

Setting GSM will hide GPRS features and a GPRS mobile will not see the serving cell as GPRS capable and therefore, will not attempt to attach.

The: SCELl query command returns the current serving cell setting.

This parameter can only be set when the Operating Mode parameter is set to Off (see CALL:OPERating:MODE )
EGPRS LA

This command sets or returns the serving cell. The serving cell defines the type of information that is broadcast on the broadcast channel. It can be set to either GSM, GPRS or EGPRS.

When the setting is GPRS, EGPRS features are hidden and an EGPRS mobile does not see the serving cell as being EGPRS capable. However, an EGPRS mobile should still be able to attach using GMSK modulation coding schemes (MCS1 through MCS4).

If you set this command to a value other than EGPRS, you can still send GPIB commands to the test set which control EGPRS functions. However, these settings are not applied until the serving cell is set to EGPRS.

This parameter can only be set when the Operating Mode parameter is set to Off (see CALL:OPERating:MODE )
Setting

GSM/GPRS/
EGPRS TA

Range: GSM (if a GSM TA license is present)
| GPRS (if a GPRS TA license is present)
| EGPRS (if an EGPRS TA license is present)

GSM/GPRS LA

Range: GSM | GPRS
EGPRS LA

Range: GSM | GPRS | EGPRS

Query

GSM/GPRS/
EGPRS TA

Range: GSM | GPRS | EGPRS

GSM/GPRS LA

 Range: GSM | GPR

EGPRS LA

Range: GSM | GPRS | EGPRS

*RST Setting

 GPRS TA, GSM/GPRS LA, or EGPRS LA licenses: GPRS
GSM TA license only: GSM
EGPRS TA license only: EGPRS
GSM TA and EGPRS TA licenses: EGPRS
Related Topics

Serving Cell .
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/
EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:CELL:BCHANNEL:SCELL EGPRS"
! Sets broadcast channel SCELl to EGPRS (requires the E1968A EGPRS TA license or E6704A license).

CALL[:CELL]:BCHannel:SORD

Function

 GSM TA This command is not applicable to the GSM TA.

GPRS TA

 This command is not applicable to the GPRS TA.

EGPRS TA

 This command is not applicable to the EGPRS TA.

GSM/GPRS LA

This command sets/queries the Scale Order. This parameter indicates the offset (Scale) that is used for the reportecd RXLEV values.

Scale Order Scale
0 +0 dB
1 +10 dB
2 Automatic
The measured signal level shall be mapped to an RXLEV value between 0 and 63, as follows: RXLEV 0 = less than 110 dBm + SCALE.
RXLEV 1 = 110 dBm + SCALE to 109 dBm + SCALE.
RXLEV 2 = 109 dBm + SCALE to 108 dBm + SCALE.
:
RXLEV 62 = 49 dBm + SCALE to 48 dBm + SCALE.
RXLEV 63 = greater than 48 dBm + SCALE.

EGPRS LA

Setting

Range: 0 to 2

Resolution: 1

Query

Range: 0 to 2

Resolution: 1

*RST Setting

 0
Requirements GSM/GPRS/ EGPRS LA Revision: E.00.12 and above

Programming Example

OUTPUT 714;"CALL:BCHannel:SORD 1"
! Sets the Scale Order to 1.

CALL[:CELL]:BCHannel:T:AVGT

Function

 GSM TA This command is not applicable to the GSM TA.

GPRS TA

 This command is not applicable to the GPRS TA.

EGPRS TA

 This command is not applicable to the EGPRS TA.

GSM/GPRS LA

 This command sets/queries the T avg T parameter. This parameter sets the signal level filter period for power control in packet idle mode to [2^(k/2)]/6, where k=0,1...25.

EGPRS LA

Setting

Range: 0 to 25

Resolution: 1

Query

Range: 0 to 25

Resolution: 1

*RST Setting

 0
Requirements GSM/GPRS/ EGPRS LA Revision: E.00.08 and above

Programming Example

OUTPUT 714;"CALL:BCHannel:T:AVGT 1"
! Sets the Tavg_t paramter to .3333.

CALL[:CELL]:BCHannel:T:AVGW

Function

 GSM TA This command is not applicable to the GSM TA.

GPRS TA

 This command is not applicable to the GPRS TA.

EGPRS TA

 This command is not applicable to the EGPRS TA.

GSM/GPRS LA

 This command sets/queries the T avg W parameter. This parameter sets the signal level filter period for power control in packet transfer mode to [2^(k/2)]/6, where k=0,1,...25.

EGPRS LA

Setting

Range: 0 to 25

Resolution: 1

Query

Range: 0 to 25

Resolution: 1

*RST Setting

 0
Requirements GSM/GPRS/ EGPRS LA Revision: E.00.08 and above

Programming Example

OUTPUT 714;"CALL:BCHannel:T:AVGW 1"
! Sets the Tavg_w parameter to .3333.

CALL[:CELL]:BCHannel:TOFFset

Function

 GSM TA This command is not applicable to the GSM TA.

GPRS TA

 This command is not applicable to the GPRS TA.

EGPRS TA

 This command is not applicable to the EGPRS TA.

GSM/GPRS LA

This command sets/queries the C2 Temporary Offset parameter. The C2 Temporary Offset parameter sets the offset applied to cell 2 (C2) for the duration of C2 Penalty Time.

The command to set the C2 Penalty Time is CALL[:CELL]:BCHannel:PTIMe .

EGPRS LA

Setting

Range: 0 to 7

Resolution: 1

Query

Range: 0 to 7

Resolution: 1

*RST Setting

 0
Requirements GSM/GPRS/ EGPRS LA Revision: E.00.05 and above

Programming Example

OUTPUT 714;"CALL:BCHannel:TOFFset 5"
! Sets the temporary offset to 5.

CALL[:CELL]:BCHannel:TYPE

Function

 GSM TA This command is not applicable to the GSM TA.

GPRS TA

 This command is not applicable to the GPRS TA.

EGPRS TA

 This command is not applicable to the EGPRS TA.

GSM/GPRS LA

This command sets/queries BCH Type parameter.

EGPRS LA

Setting

Range: COMBined|NCOMbined

Query

Range: COMB|NCOM

*RST Setting

 COMB
Requirements GSM/GPRS/ EGPRS LA Revision: E.00.08 and above

Programming Example

OUTPUT 714;"CALL:BCHannel:TYPE COMBined"
! Sets the BCH Type to Combined.


CALL:BINDicator

CALL:BINDicator

GPIB Command Conventions

  • CALL[:CELL]:BINDicator

CALL[:CELL]:BINDicator

Function

 GSM TA

Sets/queries the value of the Band Indicator.
The band indicator is a bit carried in system information messages to distinguish between ARFCN numbers that overlap for the DCS and PCS bands. This parameter is part of System Information 1 and System Information 6 messages when a BCCH is used or the Packet System Information 1 message when a PBCCH is used. Setting this parameter to DCS sets the bit to 0 and a parameter setting of PCS sets the bit to 1.

If the BCH Cell Band is changed to DCS or PCS, the Band Indicator is updated to match the BCH Cell Band setting. Changes to the TCH or PDTCH traffic bands do not affect the Band Indicator setting. Also, presetting the test set reverts the Band Indicator setting to its default setting. The command to change the BCH Cell Band is CALL[:CELL]:BAND<[:SELected]|:GSM> .

GPRS TA

EGPRS TA
GSM/GPRS LA

EGPRS LA

Setting

Range: DCS | PCS

Query

Range: DCS | PCS

*RST Setting

DCS
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above

Revision A.06.20 adds the behavior to change the Band Indicator to match the BCH Cell Band.
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Revision D.03 adds the behavior to change the Band Indicator to match the BCH Cell Band.

Programming Example

OUTPUT 714;"CALL:BINDicator PCS" !Sets the band indicator to PCS.


CALL:BURSt

CALL:BURSt

GPIB Command Conventions

  • CALL:BURSt:TYPE[:SELected]

CALL:BURSt:TYPE[:SELected]

Function

 GSM TA

This command sets/queries the Expected Burst parameter in the active (that is the selected) format. This parameter is used for measurement synchronization when the test set's operating mode is set to one of the Test Mode Operating Modes . The command to set the operating mode is CALL:OPERating:MODE (If it is not set, the test set may not synchronize to the input signal's midamble).

Also, the BCC (Base Station Colour Code) parameter, which sets the downlink TSC, should be set prior to the Operating Mode. The command to set this parameter is CALL[:CELL]:BCCode .
GPRS TA

EGPRS TA
GSM/GPRS LA

EGPRS LA

Setting

 GSM

Range: RACH | TSC0 | TSC1 | TSC2 | TSC3 | TSC4 | TSC5 | TSC6 | TSC7
GPRS

Range: RACH | TSC0 | TSC1 | TSC2 | TSC3 | TSC4 | TSC5 | TSC6 | TSC7

Query

 GSM

Range: RACH | TSC0 | TSC1 | TSC2 | TSC3 | TSC4 | TSC5 | TSC6 | TSC7
GPRS

Range:RACH | TSC0 | TSC1 | TSC2 | TSC3 | TSC4 | TSC5 | TSC6 | TSC7

*RST Setting

The *RST value of this command depends on the format that is currently active. For example, if the GSM format is currently active, the *RST value for this command is the same value as the equivalent command containing the :GSM format identifier.
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:BURSt:TYPE TSC2"
! Sets the test set to expect Training Sequence Code 2 in the midamble burst.


CALL:CA

CALL:CA

GPIB Command Conventions

  • CALL:CA:TABLe
  • CALL:CA:TABLe:POINts?

CALL:CA:TABLe

Function

GSM TA

 This command is not applicable to the GSM Test Application.

GPRS TA

 This command is not applicable to the GPRS Test Application.

EGPRS TA

 This command is not applicable to the EGPRS Test Application.

GSM/GPRS LA

 This command sets/queries up to 16 channels in the Cell Allocated (CA) Table. The Operating Mode must be in Cell Off to configure the CA Table. The command to set the test set's Operating Mode is CALL:OPERating:MODE . See Frequency Hopping for more information.

EGPRS LA
Setting

Range: 0-124, 128-251, 259-293, 306-340, 350-425, 438-885, 955-1023

Resolution: 1
Query

Range: 0-124, 128-251, 259-293, 306-340, 350-425, 438-885, 955-1023

Resolution: 1
*RST setting

The default CA Table contains the following ARFCNs: 1, 124, 128, 251, 259, 293, 306, 340, 438, 511, 520, 661, 810, 885, 955, 975.

The following list shows which bands in the default CA Table are represented for each channel.

  • DCS band, channels 520, 661, 810, 885
  • EGSM band, channels 1, 124, 975
  • GSM450 band, channels 259, 293
  • GSM480 band, channels 306, 340
  • GSM750 band, channels 438, 511
  • GSM850 band, channels 128, 251
  • PCS band, channels 512 to 810
  • PGSM band, channels 1, 124
  • RGSM band, channels 1, 124, 955, 975
  • TGSM810 band, ' ' (empty)
Requirements GSM/GPRS/ EGPRS LA

Revision: D.01 and above

Revision D.03 adds the TGSM810 band.

Programming Example

OUTPUT 714;"CALL:OPERating:MODE OFF"
! Sets the test set's operating mode to Cell Off.

OUTPUT 714;"CALL:CA:TABLe 1,124,128,251,259,293,306,340,350,425,438,511,520,661,810,885,955"
! Sets the CA Table to the specified values.

CALL:CA:TABLe:POINts?

Function

GSM TA

 This command is not applicable to the GSM Test Application.

GPRS TA

 This command is not applicable to the GPRS Test Application.

EGPRS TA

 This command is not applicable to the EGPRS Test Application.

GSM/GPRS LA

 This command queries the number of channels in the Cell Allocated (CA) Table.

EGPRS LA
Query

Range: 1 through 16

Resolution: 1
*RST setting 16
Requirements GSM/GPRS/ EGPRS LA

Revision: D.01 and above

Programming Example

OUTPUT 714;"CALL:CA:TABLe:POINts?"
! Queries the number of channels listed in the Cell Allocated (CA) Table.


CALL:CCNactive

CALL:CCNactive

GPIB Command Conventions

  • CALL[:CELL]:CCNactive:GSM[:STATe]
  • CALL[:CELL]:CCNactive:UTRan[:STATe]

CALL[:CELL]:CCNactive:GSM[:STATe]

Function

GSM TA

 This command is not applicable to GSM Test Application

GPRS TA

 This command is not applicable to GPRS Test Application

EGPRS TA

 This command is not applicable to EGPRS Test Application
GSM/GPRS LA

This command allows specification of the current Cell Change Notification support in the current cell towards GSM neighbor cells.

Note: The Operating Mode must be set to Cell Off before setting this parameter.

EGPRS LA
Setting | Range: 1|ON|0|OFF
Query | Range: 1|0
*RST setting | 0|OFF
Requirements GSM/GPRS/ EGPRS LA

Revision: F.00.37 and above

Programming Example

OUTPUT 714;"CALL:CELL:CCNactive:GSM:STATe ON"

CALL[:CELL]:CCNactive:UTRan[:STATe]

Function

GSM TA

 This command is not applicable to GSM Test Application

GPRS TA

 This command is not applicable to GPRS Test Application

EGPRS TA

 This command is not applicable to EGPRS Test Application
GSM/GPRS LA

This command allows specification of the current Cell Change Notification support in the current cell towards 3G neighbor cells.

Note: The Operating Mode must be set to Cell Off before setting this parameter.

EGPRS LA
Setting | Range: 1|ON|0|OFF
Query | Range: 1|0
*RST setting | 0|OFF
Requirements GSM/GPRS/ EGPRS LA

Revision: F.00.37 and above

Programming Example

OUTPUT 714;"CALL:CELL:CCNactive:UTRan:STATe ON"


CALL:CONNected

CALL:CONNected

GPIB Command Conventions

  • CALL:CONNected[:STATe]?
  • CALL:CONNected:ARM[:IMMediate]
  • CALL:CONNected:ARM:STATe?
  • CALL:CONNected:TIMeout

CALL:CONNected[:STATe]?

Function

 GSM TA

Queries the connected/disconnected state of the call. 1 is returned if the call is in the connected state. 0 is returned if the call is in the idle (that is, disconnected) state. If the call is in any state other than connected or idle, the query will hang until the call state transitions to the connected or idle state. When used in conjunction with the CALL:CONNected:ARM and CALL:CONNected:TIMeout commands, the CALL:CONNected:STATe? command allows the control program to synchronize to call connection/disconnection. See Call Processing State Synchronization .
GSM/GPRS LA

EGPRS LA

GPRS TA
EGPRS TA

Query

Range: 0 | 1

*RST Setting

0

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:CONNECTED:STATE?"
! Returns 1 if call connected, 0 if call disconnected.

CALL:CONNected:ARM[:IMMediate]

Function

 GSM TA

Sets (arms) the call-state-change detector. Arming the call-state-change detector allows the control program to tell the test set that it is expecting a change to the state of a call prior to initiating the state change.

Once armed, the detector remains armed until there is a call state change to Idle or Connected from one of the transitory states. The call-state-change-detector is not disarmed by a call state change to one of the transitory states, nor is it disarmed by any transitions from Idle to Idle, or Connected to Connected.

When used in conjunction with the CALL:CONNected:STATe? and the CALL:CONNected:TIMeout commands, the CALL:CONNected:ARM command allows the control program to synchronize to call connection/disconnection. See Call State Change Detector

For an explanation of the :DONE?, :OPComplete?, :SEQuential, and :WAIT commands, see Call Processing Event Synchronization .
GSM/GPRS LA

EGPRS LA

GPRS TA
EGPRS TA

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:CONNECTED:ARM:IMMEDIATE"
! Arms the call-state-change detector.

CALL:CONNected:ARM:STATe?

Function

 GSM TA

Queries the arm state of the call-state-change detector. This command never hangs and immediately returns a 1 if the call-state-change detector is armed and a 0 if it is not armed. See Call Processing State Synchronization .
GSM/GPRS LA
EGPRS LA

GPRS TA
EGPRS TA

Query

Range: 0 | 1

*RST Setting

0

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:CONNECTED:ARM:STATE?"
! Returns arm state of call-state-change detector.

CALL:CONNected:TIMeout

Function

 GSM TA

Sets/queries the maximum time the test set will wait for a hanging CALL:CONNected:STATe? query to complete. Default setting units are seconds. To set timeout time in units other than seconds include optional unit specifier in command string.

A timeout timer is started whenever the call-state-change-detector becomes armed or gets rearmed when already armed. The duration of this timeout is a set using the CALL:CONNected:TIMeout command and should be greater than the maximum amount of time the control program needs/wants to wait between arming the call-state-change detector and the connect/disconnect operation starting. Once the process starts and the call state has moved into one of the transitory states the GSM defined protocol timers take over and prevent the call state from staying in a transitory state forever. See Call Processing State Synchronization .
GSM/GPRS LA
EGPRS LA

GPRS TA
EGPRS TA

Setting

Range: 0 to 100 seconds

Resolution: 0.1 seconds

Query

Range: 0 to 100 seconds

Resolution: 0.1 seconds

*RST Setting

10 seconds
Related Topics Call Processing State Synchronization
Call Processing State Synchronization

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:CONNECTED:TIMEOUT 3"
! Sets the CALL:CONNected:STATe? query timeout time to 3 seconds.

OUTPUT 714;"CALL:CONNECTED:TIMEOUT 500 MS"
! Sets the CALL:CONNected:STATe? query timeout time to 500 ms.


CALL:COUNt

CALL:COUNt

GPIB Command Conventions

  • CALL:COUNt:CBURst?

  • CALL:COUNt:CDERror?

  • CALL:COUNt:CLEar[:ALL]
  • CALL:COUNt:CLEar:BAERror
  • CALL:COUNt:CLEar:MS:IP
  • CALL:COUNt:CLEar:RAPage

  • CALL:COUNt:DTMonitor:CLEar
  • CALL:COUNt:DTMonitor[:ALL]:DISPlay:DRATe:(STARt | STOP)
  • CALL:COUNt:DTMonitor[:ALL]:DISPlay:SPAN:TIME
  • CALL:COUNt:DTMonitor[:ALL]:TRACe:HISTory:UNUMber?
  • CALL:COUNt:DTMonitor:(IPRX|IPTX|OTARx|OTATx):DISPlay:STATe
  • CALL:COUNt:DTMonitor:(IPRX|IPTX|OTARx|OTATx):DRATe?
  • CALL:COUNt:DTMonitor:(IPRX|IPTX|OTARx|OTATx):TRACe?
  • CALL:COUNt:DTMonitor:(IPRX|IPTX|OTARx|OTATx):TRACe:HISTory?

  • CALL:COUNt:MBURst?

  • CALL:COUNt:MS:IP[:ALL]?
  • CALL:COUNt:MS:IP:RX?
  • CALL:COUNt:MS:IP:TX?

  • CALL:COUNt:PAGE?

  • CALL:COUNt:PRACh?

  • CALL:COUNt:RACH?

  • CALL:COUNt:TDMA:FNUMber[:SELected]?
  • CALL:COUNt:TDMA:FRAMes?

CALL:COUNt:CBURst?

Function

GSM TA

Queries the corrupt burst counter. The corrupt burst counter keeps track of the number of uplink bursts where power was detected but the expected midamble could not be found.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Range: 0 to 99999

Resolution: 1

*RST Setting

0
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:COUNT:CBURST?"
! Queries the corrupt burst counter.

CALL:COUNt:CDERror?

Function

GSM TA

Queries the channel decode error counter. The channel decode error counter keeps track of how many channel decoder errors have occurred. Channel decode errors include convolutional, FIRE, and block errors, but not CRC errors.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Range: 0 to 99999

Resolution: 1

*RST Setting

0
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:COUNT:CDERROR?"
! Queries the channel decode error counter.

CALL:COUNt:CLEar[:ALL]

Function

GSM TA

This command resets the corrupt burst, channel decode error, missing burst, RACH, and page counters to zero.

GPRS TA

EGPRS TA

GSM/GPRS LA

This command resets the corrupt burst, channel decode error, missing burst, RACH, and page counters to zero. It also clears the PRACH counter and the reported results for the transmitted and received IP packets and bytes.

EGPRS LA
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:COUNt:CLEar"
! Clears all counters.

CALL:COUNt:CLEar:BAERror

Function

GSM TA

This command sets the corrupt burst, missing burst, and decode error counters' count to zero.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:COUNt:CLEar:BAERror"
! Clears the corrupt burst, missing burst, and decode error counters

CALL:COUNt:CLEar:MS:IP

Function

GSM TA

This command is not applicable to the GSM test application.

GPRS TA

 This command is not applicable to the GPRS test application.

EGPRS TA

This command is not applicable to the EGPRS test application.

GSM/GPRS LA

This command clears the reported results for the transmitted and received IP packets and bytes.

EGPRS LA
Requirements

GSM/GPRS/
EGPRS LA

 Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:COUNt:CLEar:MS:IP"
! Clears the TX and RX IP packet and byte counters.

CALL:COUNt:CLEar:RAPage

Function

GSM TA

This command sets the RACH and page counters' count to zero.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:COUNt:CLEar:RAPage"
! Clears the RACH and page counters.

CALL:COUNt:DTMonitor:CLEar

Function

 GSM TA

This command is not applicable to the GSM TA.
GPRS TA

This command is not applicable to the GPRS TA.
EGPRS TA

This command is not applicable to the EGPRS TA.

GSM/GPRS LA

 This command clears all traces from the data throughput monitor display and resets the numeric summary table values to zero.

EGPRS LA

Requirements

GSM/GPRS/ EGPRS LA

 Revision: D.01 and above

Programming Example

OUTPUT 714;"CALL:COUNt:DTMonitor:CLEar"
! Clears all Data Throughput Monitor results.

CALL:COUNt:DTMonitor[:ALL]:DISPlay:DRATe:(STARt | STOP)

Function

 GSM TA

This command is not applicable to the GSM TA.
GPRS TA

This command is not applicable to the GPRS TA.
EGPRS TA

This command is not applicable to the EGPRS TA.

GSM/GPRS LA

This command sets the data rate range (y-axis) for the data throughput monitor graphical display.

EGPRS LA
Setting

Start Range: 0 to 4999 kbps

Stop Range: 1 to 5000 kbps

Query

Start Range: 0 to 4999 kbps

Stop Range: 1 to 5000 kbps
*RST Setting

Start: 0 kbps
Stop: 100 kbps

Requirements

GSM/GPRS/ EGPRS LA

 Revision: D.01 and above

Programming Example

OUTPUT 714;"CALL:COUNt:DTMonitor:DISPlay:DRATe:STARt 10"
! Sets the data throughput monitor range to start at 10 kbps.

OUTPUT 714;"CALL:COUNt:DTMonitor:DISPlay:DRATe:STOP 50"
! Sets the data throughput monitor range to stop at 50 kbps.

CALL:COUNt:DTMonitor[:ALL]:DISPlay:SPAN:TIME

Function

 GSM TA

This command is not applicable to the GSM TA.
GPRS TA

This command is not applicable to the GPRS TA.
EGPRS TA

This command is not applicable to the EGPRS TA.

GSM/GPRS LA

This command sets the time span (x-axis) for the data throughput monitor graphical display.

EGPRS LA
Setting

Range: 5 to 600 seconds

Resolution:

Query

Range: 5 to 600 seconds
Resolution:
*RST Setting 600 seconds

Requirements

GSM/GPRS/ EGPRS LA

 Revision: D.01 and above

Programming Example

OUTPUT 714;"CALL:COUNt:DTMonitor:ALL:DISPlay:SPAN:TIME 100"
! Sets the data throughput monitor time span to 100 seconds.

CALL:COUNt:DTMonitor[:ALL]:TRACe:HISTory:UNUMber?

Function

 GSM TA

This command is not applicable to the GSM TA.
GPRS TA

This command is not applicable to the GPRS TA.
EGPRS TA

This command is not applicable to the EGPRS TA.

GSM/GPRS LA

This query returns the number of 10-minute trace data collection periods since the last time the monitor was enabled or cleared.

EGPRS LA

Query

Range: 0 to 2,147,483,647 10-minute periods, 9.91 E+37

Resolution: 1

Requirements

GSM/GPRS/ EGPRS LA

 Revision: D.01 and above

Programming Examples

OUTPUT 714;"CALL:COUNt:DTMonitor:TRACe:HISTory:UNUMber?"
! Queries the number of 10-minute collection periods.

CALL:COUNt:DTMonitor:(IPRX|IPTX|OTARx|OTATx):DISPlay:STATe

Function

 GSM TA

This command is not applicable to the GSM TA.
GPRS TA

This command is not applicable to the GPRS TA.
EGPRS TA

This command is not applicable to the EGPRS TA.

GSM/GPRS LA

This command sets which data throughput traces are displayed.

EGPRS LA
Setting

Range: 1|ON|0|OFF

Query

 Range: 1|0
*RST Setting

OTA Tx - ON

OTA Rx - ON

IP Tx - OFF

IP RX - OFF

Requirements

GSM/GPRS/ EGPRS LA

 Revision: D.01 and above

Programming Example

OUTPUT 714;"CALL:COUNt:DTMonitor:IPTX:DISPlay:STATe ON"
! Turns the IP TX display On.

OUTPUT 714;"CALL:COUNt:DTMonitor:IPRX:DISPlay:STATe ON"
! Turns the IP RX display On.

OUTPUT 714;"CALL:COUNt:DTMonitor:OTATx:DISPlay:STATe OFF"
! Turns the OTA TX display state Off.

OUTPUT 714;"CALL:COUNt:DTMonitor:OTARx:DISPlay:STATe ON"
! Turns the OTA RX display state Off.

CALL:COUNt:DTMonitor:(IPRX|IPTX|OTARx|OTATx):DRATe?

Function

 GSM TA

This command is not applicable to the GSM TA.
GPRS TA

This command is not applicable to the GPRS TA.
EGPRS TA

This command is not applicable to the EGPRS TA.

GSM/GPRS LA

Query results will be returned in a comma-separated string with values in the following order:

  • Average data throughput (bps)

  • Current data throughput (bps)

  • Peak data throughput (bps)

  • Total data transfer (bytes)

This query returns the summary table values (except for Marker) for any of the four traces:

  • OTA Tx

  • OTA Rx

  • IP Tx

  • IP Rx

EGPRS LA

Query

Range: 0 to 9999999999, 9.91 E+37

Resolution: 1

Requirements

GSM/GPRS/ EGPRS LA

 Revision: D.01 and above

Programming Examples

OUTPUT 714;"CALL:COUNt:DTMonitor:OTATx:DRATe?
!Queries OTA Tx summary

OUTPUT 714;"CALL:COUNt:DTMonitor:OTARx:DRATe?
!Queries OTA Rx summary

OUTPUT 714;"CALL:COUNt:DTMonitor:IPTX:DRATe?
!Queries IP Tx summary

OUTPUT 714;"CALL:COUNt:DTMonitor:IPRX:DRATe?
!Queries IP Rx summary

CALL:COUNt:DTMonitor:(IPRX|IPTX|OTARx|OTATx):TRACe?

Function

 GSM TA

This command is not applicable to the GSM TA.
GPRS TA

This command is not applicable to the GPRS TA.
EGPRS TA

This command is not applicable to the EGPRS TA.

GSM/GPRS LA

This query returns 600 comma-separated trace values for spreadsheet plotting. These values represent the most recent 10 minute trace data collection period.

If the graph is frozen (see How Do I Use the Data Throughput Monitor? ), this command will not return values representative of the graph. If you would like to see the graph this command will return values for, resume the graph then query the trace values.

Trace values can be obtained for any of the four traces:

  • OTA Tx

  • OTA Rx

  • IP Tx

  • IP Rx

EGPRS LA

Query

Range: 0 to 9999999999, 9.91 E+37

Resolution: 1

Requirements

GSM/GPRS/ EGPRS LA

 Revision: D.01 and above

Programming Examples

OUTPUT 714;"CALL:COUNt:DTMonitor:OTATx:TRACe?"
! Queries OTA Tx trace data values.

OUTPUT 714;"CALL:COUNt:DTMonitor:OTARx:TRACe?"
! Queries OTA Rx trace data values.

OUTPUT 714;"CALL:COUNt:DTMonitor:IPTX:TRACe?"
! Queries IP Tx trace data values.

OUTPUT 714;"CALL:COUNt:DTMonitor:IPRX:TRACe?"
! Queries IP Rx trace data values.

CALL:COUNt:DTMonitor:(IPRX|IPTX|OTARx|OTATx):TRACe:HISTory?

Function

 GSM TA

This command is not applicable to the GSM TA.
GPRS TA

This command is not applicable to the GPRS TA.
EGPRS TA

This command is not applicable to the EGPRS TA.

GSM/GPRS LA

This query returns 600 comma-separated trace values for the 10-minute trace data collection period captured prior to the most recent. To find out how many 10-minute periods have elapsed, see CALL:COUNt:DTMonitor[:ALL]:TRACe:HISTory:UNUMber? .

Trace values can be obtained for any of the four traces:

  • OTA Tx

  • OTA Rx

  • IP Tx

  • IP Rx

EGPRS LA

Query

Range: 0 to 9999999999, 9.91 E+37

Resolution: 1

Requirements

GSM/GPRS/ EGPRS LA

 Revision: D.01 and above

Programming Examples

OUTPUT 714;"CALL:COUNt:DTMonitor:OTATx:TRACe:HISTory?"
! Queries OTA Tx trace data values.

OUTPUT 714;"CALL:COUNt:DTMonitor:OTARx:TRACe:HISTory?"
! Queries OTA Rx trace data values.

OUTPUT 714;"CALL:COUNt:DTMonitor:IPTX:TRACe:HISTory?"
! Queries IP Tx trace data values.

OUTPUT 714;"CALL:COUNt:DTMonitor:IPRX:TRACe:HISTory?"
! Queries IP Rx trace data values.

CALL:COUNt:MBURst?

Function

GSM TA

This command queries the missing burst counter. The missing burst counter keeps track of how many uplink bursts, that should have been there, were missing. The missing burst counter does not count idle frames as missing.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Range: 0 to 99999

Resolution: 1

*RST Setting

0
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:COUNt:MBURst?"
! Returns the number of missing uplink bursts.

CALL:COUNt:MS:IP[:ALL]?

Function

GSM TA

This command is not applicable to the GSM test application.

GPRS TA

This command is not applicable to the GPRS test application.
EGPRS TA This command is not applicable to the EGPRS Test Application.

GSM/GPRS LA

Queries the data transmitted from and received by the device being tested. Data is returned in the following order: packets transmitted, bytes transmitted, packets received, bytes received.

The function connection type must be set to AUTO by CALL:FUNCtion:CONNection:TYPE . If the data type is not AUTO, this query will return 9.91 E+37.

EGPRS LA

Query

Range: 0 to 9999999999, 9.91 E+37

Resolution: 1
Requirements

GSM/GPRS/
EGPRS LA

 Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:COUNt:MS:IP:ALL?"

CALL:COUNt:MS:IP:RX?

Function

GSM TA

This command is not applicable to the GSM test application.

GPRS TA

This command is not applicable to the GPRS test application.
EGPRS TA This command is not applicable to the EGPRS Test Application.

GSM/GPRS LA

Queries the data received by the device being tested. Data is returned in the following order: packets received, bytes received.

The connection type must be set to AUTO. See CALL:FUNCtion:CONNection:TYPE . If the data type is not AUTO, this query will return 9.91 E+37.

EGPRS LA

Query

Range: 0 to 9999999999, 9.91 E+37

Resolution: 1
Requirements

GSM/GPRS/
EGPRS LA

 Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:COUNt:MS:IP:RX?"

CALL:COUNt:MS:IP:TX?

Function

GSM TA

This command is not applicable to the GSM test application.

GPRS TA

This command is not applicable to the GPRS test application.
EGPRS TA This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

Queries the data transmitted by the device being tested. Data is returned in the following order: packets transmitted, bytes transmitted.

The data connection type must be set to AUTO. See CALL:FUNCtion:CONNection:TYPE . If the data type is not AUTO, this query will return 9.91 E+37.

EGPRS LA

Query

Range: 0 to 9999999999, 9.91 E+37

Resolution: 1
Requirements

GSM/GPRS/
EGPRS LA

 Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:COUNt:MS:IP:TX?"

CALL:COUNt:PAGE?

Function

GSM TA

This command queries the page counter. The page counter keeps track of the number of pages sent by the base station (BS) emulator during a BS originated call setup.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Range: 0 to 9999

Resolution: 1

*RST Setting

0
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:COUNt:PAGE?"
! Returns the number of pages sent by the base station emulator.

CALL:COUNt:PRACh?

Function

GSM TA

This command is not applicable to the GSM test application.

GPRS TA

This command is not applicable to the GPRS test application.
EGPRS TA This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

Queries the number of PRACHs received. See PRACH Length for more information.

This query is used in conjunction with the PBCCH.

Valid in all data connection types.

EGPRS LA

Query

Range: 0 to 9999, 9.91 E+37

Resolution: 1
Requirements

GSM/GPRS/
EGPRS LA

 Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:COUNt:PRACh?"

CALL:COUNt:RACH?

Function

GSM TA

This command queries the RACH counter in the active (that is the selected) format. The RACH counter keeps track of the number of RACH bursts received by the base station emulator during call setup attempts.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Range: 0 to 9999

Resolution: 1

*RST Setting

The *RST value of this command depends on the format that is currently active. For example, if the GSM format is currently active, the *RST value for this command is the same value as the equivalent command containing the :GSM format identifier.
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:COUNt:RACH?"
! Returns the number of RACH bursts received by the base station emulator
! during call setup/data connection attempts.

CALL:COUNt:TDMA:FNUMber[:SELected]?

Function

GSM

 This command is not applicable to the GSM Test Application.
GPRS TA | This command is not applicable to the GPRS Test Application.
EGPRS TA | This command is not applicable to the EGPRS Test Application.

GSM/GPRS LA

Returns the number of the current TDMA frame within a hyperframe.
EGPRS LA

Query

Range: 0 to 2715647

Resolution: 1
Requirements

GSM/GPRS/
EGPRS LA

 Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:COUNt:TDMA:FNUMber?"

CALL:COUNt:TDMA:FRAMes?

Function

GSM

 This command is not applicable to the GSM Test Application.
GPRS TA | This command is not applicable to the GPRS Test Application.
EGPRS TA | This command is not applicable to the EGPRS Test Application.

GSM/GPRS LA

This command sets/quires the maximum number of TDMA frames the mobile station is allowed to take for a channel assignment. See Max Frames Allowed for Assignment Parameter for more information.
EGPRS LA

Setting

Range: 15 to 999

Resolution: 1

Query

Range: 15 to 999

Resolution: 1
RST setting | 28
Requirements

GSM/GPRS/
EGPRS LA

 Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:COUNt:TDMA:FRAMes?"


CALL:CPNumber

CALL:CPNumber

GPIB Command Conventions

  • CALL:CPNumber<[:SELected]>
  • CALL:CPNumber:INCLusion
  • CALL:CPNumber:PLAN
  • CALL:CPNumber:PRESentation[:INDicator]
  • CALL:CPNumber:SCReening[:INDicator]
  • CALL:CPNumber:TYPE

CALL:CPNumber<[:SELected]>

Function

GSM TA

This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.

EGPRS TA

This command is not applicable to the EGPRS Test Application.

GSM/GPRS LA

Sets/queries the ASCII representation of the calling party number.

The value is included in the SETUP message to the called mobile station when INCLude is selected by CALL:CPNumber:INCLusion .

It is displayed on the called mobile station's screen when "ALLowed" is selected by CALL:CPNumber:PRESentation[:INDicator] .
EGPRS LA

Setting

Range: 0 to 20 characters enclosed by quotes, each character from the set of 0123456789abc*#

Query

Range: 0 to 20 characters enclosed by quotes, each character from the set of 0123456789abc*#

*RST Setting

"5099214001"

Requirements

 GSM/GPRS/ EGPRS LA Revision: D.01 and above

Programming Example

OUTPUT 714;"CALL:CPNumber '#0123456789*'"
! Sets the calling party number to #0123456789*.

CALL:CPNumber:INCLusion

Function

GSM TA

This command is not applicable to the GSM Test Application.
GPRS TA This command is not applicable to the GPRS Test Application.

EGPRS TA

 This command is not applicable to the EGPRS Test Application.

GSM/GPRS LA

Sets/queries whether to include the calling party number information record.

The value is not included in the message to the called mobile station. When "INCLude" is selected, the calling party number parameters configured by CALL:CPNumber<[:SELected]> , CALL:CPNumber:PLAN , CALL:CPNumber:PRESentation[:INDicator] , CALL:CPNumber:SCReening[:INDicator] and CALL:CPNumber:TYPE is sent to the mobile station.
EGPRS LA

Setting

Range: INCLude|EXCLude

Query

Range: INCL|EXCL

*RST Setting

EXCL

Requirements

 GSM/GPRS/ EGPRS LA Revision: D.01 and above

Programming Example

OUTPUT 714;"CALL:CPNumber:INCLusion INCLude"
! Set to include the calling party number to the called mobile station.

CALL:CPNumber:PLAN

Function

GSM TA

 This command is not applicable to the GSM Test Application.

GPRS TA

 This command is not applicable to the GPRS Test Application.
EGPRS TA This command is not applicable to the EGPRS Test Application.

GSM/GPRS LA

Sets/queries the numbering plan used for the calling party number. See Parameter Descriptions for details.

The value is included in the SETUP message to the called mobile station when INCLude is selected by CALL:CPNumber:INCLusion .

EGPRS LA

Setting

Range: UNKNown|ISDN|NATional|PRIVate|TELex|DATA

Query

Range: UNKN|ISDN|NAT|PRIV|TEL|DATA

*RST Setting

UNKN

Requirements

 GSM/GPRS/ EGPRS LA

Revision: D.01 and above

Programming Example

OUTPUT 714;"CALL:CPNumber:PLAN PRIVate"
! Set the numbering plan for calling party number to private.

CALL:CPNumber:PRESentation[:INDicator]

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA This command is not applicable to the GPRS Test Application.

EGPRS TA

 This command is not applicable to the EGPRS Test Application.

GSM/GPRS LA

Sets/queries the presentation indicator (PI) used for the calling party number. See Parameter Descriptions for details.

The value is included in the SETUP message to the called mobile station when INCLude is selected by CALL:CPNumber:INCLusion .

EGPRS LA

Setting

Range: ALLowed|RESTricted|NNAVailable

Query

Range: ALL|REST|NNAV

*RST Setting

ALL

Requirements

 GSM/GPRS/ EGPRS LA

Revision: D.01 and above

Programming Example

OUTPUT 714;"CALL:CPNumber:PRESentation RESTricted"
! Set the presentation indicator of Calling Party Number to restricted.

CALL:CPNumber:SCReening[:INDicator]

Function

GSM TA

 This command is not applicable to the GSM Test Application.

GPRS TA

 This command is not applicable to the GPRS Test Application.
EGPRS TA This command is not applicable to the EGPRS Test Application.

GSM/GPRS LA

Sets/queries the screening indicator (SI) for the calling party number. See Parameter Descriptions for details.

The value is included in the SETUP message to the called mobile station when INCLude is selected by CALL:CPNumber:INCLusion .

EGPRS LA

Setting

Range: UNSCreened|UVPassed|UVFailed|NETWork

Query

Range: UNSC|UVP|UVF|NETW

*RST Setting

UNSC

Requirements

 GSM/GPRS/ EGPRS LA Revision: D.01 and above

Programming Example

OUTPUT 714;"CALL:CPNumber:SCReening NETWork"
! Set the screening indicator of calling party number to network.

CALL:CPNumber:TYPE

Function

GSM TA

This command is not applicable to the GSM Test Application.

GPRS TA

This command is not applicable to the GPRS Test Application.

EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

Sets/queries the number type of the calling party number. See Parameter Descriptions for details.

The value is included in the SETUP message to the called mobile station when INCLude is selected by CALL:CPNumber:INCLusion .

EGPRS LA

Setting

Range: UNKNown|INATional|NATional|NETWork|DEDicated

Query

Range: UNKN|INAT|NAT|NETW|DED

*RST Setting

UNKN

Requirements

 GSM/GPRS/ EGPRS LA

Revision: D.01 and above

Programming Example

OUTPUT 714;"CALL:CPNumber:TYPE NATional"
! Set the number type of calling party number to national.


CALL:DATA

CALL:DATA

GPIB Command Conventions

  • CALL:DATA:PING[:ALL]?

  • CALL:DATA:PING:ICOunt?

  • CALL:DATA:PING:PACKets:RX?
  • CALL:DATA:PING:PACKets:TX?

  • CALL:DATA:PING:PLOSs?

  • CALL:DATA:PING:SETup:ALTernate:IP:ADDRess
  • CALL:DATA:PING:SETup:COUNt
  • CALL:DATA:PING:SETup:DEVice
  • CALL:DATA:PING:SETup:PACKet[:SIZE]
  • CALL:DATA:PING:SETup:TIMeout

  • CALL:DATA:PING:STARt

  • CALL:DATA:PING:STOP

  • CALL:DATA:PING:TIME[:AVERage]?
  • CALL:DATA:PING:TIME:MAXimum?
  • CALL:DATA:PING:TIME:MINimum?

  • CALL:DATA:RATE:CONFig[:EGPRs]

CALL:DATA:PING[:ALL]?

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

This command returns the following results: packets transmitted, packets received, percentage of packets lost, minimum round trip time (in seconds), average round trip time (in seconds), maximum round trip time (in seconds).

This command will return 9.91 E+37 (NAN) if the Connection Type is not set to AUTO , or if ping results are not available. See CALL:FUNCtion:CONNection:TYPE for more information.
EGPRS LA
Requirements GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:DATA:PING:ALL?"
ENTER 714;Pxmit,Prcvd,Plost,Min_time,Avg_time,Max_time

CALL:DATA:PING:ICOunt?

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

This command queries the number of packets that have been transmitted at the moment this query is received by the test set.
EGPRS LA
Requirements GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:DATA:PING:ICOUNT?"
ENTER 714;variable_name

CALL:DATA:PING:PACKets:RX?

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

This command queries the number of packets received from the DUT or from the alternate device if CALL:DATA:PING:SETup:DEVice is set to ALTernate.

This command will return 9.91 E+37 (NAN) if the Connection Type is not set to AUTO , or if ping results are not available. See CALL:FUNCtion:CONNection:TYPE for more information.
EGPRS LA
Requirements GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:DATA:PING:PACKETS:RX?"
ENTER 714;variable_name
! Queries the number of packets received from the device being tested.

CALL:DATA:PING:PACKets:TX?

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

This queries the number of packets transmitted from the test set.

This command will return 9.91 E+37 (NAN) if the Connection Type is not set to AUTO , or if ping results are not available. See CALL:FUNCtion:CONNection:TYPE for more information.
EGPRS LA
Requirements GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:DATA:PING:PACKETS:TX?"
ENTER 714;variable_name
! Queries the number of packets transmitted from the test set.

CALL:DATA:PING:PLOSs?

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

This command queries the percentage of packets lost during the ping session.

This command will return 9.91 E+37 (NAN) if the Connection Type is not set to AUTO , or if ping results are not available. See CALL:FUNCtion:CONNection:TYPE for more information.
EGPRS LA
Requirements GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:DATA:PING:PLOSS?"
ENTER 714;variable_name
! Queries the percentage of lost packets.

CALL:DATA:PING:SETup:ALTernate:IP:ADDRess

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

This sets/queries the alternate internet protocol (IP) address. This address will be used as the address to ping instead of the device under test if the CALL:DATA:PING:SETup:DEVice command is set to ALT.
EGPRS LA

Setting

Range: IP v4 address in dotted decimal format.

Query

Range: IP v4 address in dotted decimal format.
Requirements GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:DATA:PING:SETUP:ALTERNATE:IP:ADDRESS `192.168.16.57'"

CALL:DATA:PING:SETup:COUNt

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

This command set/queries the number of ping IP messages sent for each uninterrupted invocation of the CALL:DATA:PING:STARt command. The MAXimum and MINimum mnemonics set this parameter to the maximum and minimum value of the numeric range, respectively.
EGPRS LA

Setting

Range: 1 to 2147483647 |MAXimum|MINimum

Query

Range: 1 to 2147483647

*RST Setting

 10
Requirements GSM/GPRS/ EGPRS LA

Revision: C.01 and above
Revision E.01 extends the range of this parameter from 1000 to 2147483647.

Programming Example

OUTPUT 714;"CALL:DATA:PING:SETUP:COUNT 20"

CALL:DATA:PING:SETup:DEVice

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

This command sets/queries which device address is used in the ping IP packets, the address of the device under test, or the address of an alternate device.
EGPRS LA

Setting

Range: DUT|ALTernate

Query

Range: DUT|ALT

*RST Setting

 DUT
Requirements GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:DATA:PING:SETUP:DEVice ALT"

CALL:DATA:PING:SETup:PACKet[:SIZE]

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

This command sets or queries the number of bytes to be sent by the test set in each ping packet.
EGPRS LA

Setting

Range: 8 to 4076 bytes

Resolution: 1

Query

Range: 8 to 4076 bytes

*RST Setting

 64 bytes
Requirements GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:DATA:PING:SETup:PACKet 10"

CALL:DATA:PING:SETup:TIMeout

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

This command sets or queries how long the test set will wait before ending a ping session.
EGPRS LA

Setting

Range: 1 to 100 seconds

Query

Range: 1 to 100 seconds

*RST Setting

 5 seconds
Requirements GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:DATA:PING:SETUP:TIMEOUT 10"

CALL:DATA:PING:STARt

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

This command starts a ping session.
EGPRS LA
Requirements GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:DATA:PING:START"

CALL:DATA:PING:STOP

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

This command immediately stops a ping session. The ping results will not include counts for any ping message that has not yet received a response.
EGPRS LA
Requirements GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:DATA:PING:STOP"

CALL:DATA:PING:TIME[:AVERage]?

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

This command queries the average round trip time (in seconds) for a series of pings.

This command will return 9.91 E+37 (NAN) if the Connection Type is not set to AUTO , or if ping results are not available. See CALL:FUNCtion:CONNection:TYPE for more information.
EGPRS LA
Requirements GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:DATA:PING:TIME:AVERAGE?"
ENTER 714;variable_name

CALL:DATA:PING:TIME:MAXimum?

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

This command queries the maximum round trip time (in seconds) for a series of pings.

This command will return 9.91 E+37 (NAN) if the Connection Type is not set to AUTO , or if ping results are not available. See CALL:FUNCtion:CONNection:TYPE for more information.
EGPRS LA
Requirements GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:DATA:PING:TIME:MAXIMUM?"
ENTER 714;variable_name

CALL:DATA:PING:TIME:MINimum?

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

This command queries the minimum round trip time (in seconds).

This command will return 9.91 E+37 (NAN) if the Connection Type is not set to AUTO , or if ping results are not available. See CALL:FUNCtion:CONNection:TYPE for more information.
EGPRS LA
Requirements GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:DATA:PING:TIME:MINIMUM?"
ENTER 714;variable_name

CALL:DATA:RATE:CONFig[:EGPRs]

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
GSM/GPRS LA | This command is not applicable to the GSM/GPRS Lab Application.
EGPRS TA | This command sets/queries whether the test set allows only multislot configurations which are known to work correctly for the current modulation and coding scheme setting or allows the selection of all multislot configurations regardless of whether they are supported by the test set for the current modulation and coding scheme setting.
EGPRS LA

Setting

Range: SUPPorted|ALL

Query

Range: SUPP|ALL

*RST Setting

 SUPP
Requirements GSM/GPRS/ EGPRS TA

Revision: A.03 and above
GSM/GPRS/ EGPRS LA

Revision: C.03 and above

Programming Example

OUTPUT 714;"CALL:DATA:RATE:CONF ALL"


CALL:DCONnected

CALL:DCONnected

GPIB Command Conventions

  • CALL:DCONnected[:STATe]?
  • CALL:DCONnected:ARM[:IMMediate]
  • CALL:DCONnected:ARM:STATe?
  • CALL:DCONnected:TIMeout

CALL:DCONnected[:STATe]?

Function

 GSM TA

This command is not applicable to GSM.

GPRS TA

 Queries the data connection state.

EGPRS TA

GSM/GPRS LA

EGPRS LA
Query

Range: 0 | 1

*RST Setting

0, disconnected
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:DCONnected?"
! Returns data connection state; 0=disconnected, 1=connected.

CALL:DCONnected:ARM[:IMMediate]

Function

 GSM TA

This command is not applicable to GSM.

GPRS TA

Sets (arms) the data connection state change detector. Arming the data connection state change detector allows the control program to tell the test set that it is expecting a change to the state of a data connection prior to initiating the state change.

Once armed, the detector remains armed until there is a data connection state change to Idle, Attached or Transferring, from one of the transitory states. The data connection state change detector is not disarmed by a connection state change to one of the transitory states, nor is it disarmed by any transitions from Idle to Idle, Attached to Attached or Transferring to Transferring.

When this command is used in conjunction with CALL:ATTached:STATe?, CALL:TRANsferring:STATe?, and CALL:DCONnected:TIMeout, it allows the control program to synchronize to data connection/disconnection. See Data Connection Processing State Synchronization .

Additional commands can be appended to aid in controller/Mobile Station synchronization. See Data Connection Processing Event Synchronization .

EGPRS TA

GSM/GPRS LA

EGPRS LA
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:DCONnected:ARM:IMMediate"
! Arms the data connection state change detector.

CALL:DCONnected:ARM:STATe?

Function

 GSM TA

This command is not applicable to GSM.

GPRS TA

Queries whether the data connection state change detector is armed or not. This command immediately returns a 1 if the data connection state change detector is armed and a 0 if it is not armed. See Data Connection Processing State Synchronization .

EGPRS TA

GSM/GPRS LA
EGPRS LA

Query

Range: 0 | 1

*RST Setting

0
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:DCONnected:ARM:STATe?"
! Returns arm state of data connection state change detector.

CALL:DCONnected:TIMeout

Function

 GSM TA

This command is not applicable to GSM.
GPRS TA

Sets/queries the maximum time the test set will wait for a hanging CALL:ATTached[:STATe]? and CALL:TRANsferring[:STATe]? query to complete. The default setting units are seconds.

A timeout timer is started whenever the data connection state change detector becomes armed. You can set the duration of the timeout using this command. The timeout should be greater than the maximum amount of time the control program needs to wait between arming the data connection state change detector and the connect/disconnect operation starting. Once the process starts and the data connection state has moved into one of the transitory states the pre-defined GPRS timers prevent the data connection state from staying in a transitory state forever. See Data Connection Processing State Synchronization .

EGPRS TA

GSM/GPRS LA

EGPRS LA

Setting

Range: 0 to 100 seconds

Resolution: 0.1 seconds

Query

Range: 0 to 100 seconds

Resolution: 0.1 seconds

*RST Setting

10 seconds
Related Topics Data Connection Processing State Synchronization
Data Connection Processing Event Synchronization
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:DCONnected:TIMeout 3"
! Sets the CALL:DCONected: STSTe? query timeout time to 3 seconds.


CALL Subsystem

CALL Subsystem

Description

The CALL subsystem handles all setup, control, and query functions for call processing. This includes mobile station (MS) and Base Station (cell) functions.

Syntax Diagrams and Command Descriptions

 | Applicable to:
 | GSM TA | GPRS TA | EGPRS TA | GSM/GPRS LA | EGPRS LA
CALL:ASTRatum? | No | No | No | Yes | Yes
CALL:ATTached | No | Yes | Yes | Yes | Yes
CALL:BA | Yes | Yes | Yes | Yes | Yes
CALL:BAND | Yes | Yes | Yes | Yes | Yes
CALL:BCCode | Yes | Yes | Yes | Yes | Yes
CALL:BCHannel | Yes | Yes | Yes | Yes | Yes
CALL:BINDicator | Yes | Yes | Yes | Yes | Yes
CALL:BURSt | Yes | Yes | Yes | Yes | Yes
CALL:CA | No | No | No | Yes | Yes
CALL:CCNactive | No | No | No | Yes | Yes
CALL:CONNected | Yes | Yes | Yes | Yes | Yes
CALL:COUNt | Yes | Yes | Yes | Yes | Yes
CALL:CPNumber | No | No | No | Yes | Yes
CALL:DAINterface | No | No | No | Yes | Yes
CALL:DATA | No | No | No | Yes | Yes
CALL:DCONnected | No | Yes | Yes | Yes | Yes
CALL:DEModulation | No | No | No | Yes | Yes
CALL:DTMode | No | No | No | Yes | Yes
CALL:END | Yes | Yes | Yes | Yes | Yes
CALL:FUNCtion | Yes | Yes | Yes | Yes | Yes
CALL:G850MNCode | Yes | Yes | Yes | Yes | Yes
CALL:HANDover|HANDoff | Ye s | Yes | Yes | Yes | Yes
CALL:IATTach | Yes | Yes | Yes | Yes | Yes
CALL:IMEI | Yes | Yes | Yes | Yes | Yes
CALL:LACode | Yes | Yes | Yes | Yes | Yes
CALL:MCCode | Yes | Yes | Yes | Yes | Yes
CALL:MNCode | Yes | Yes | Yes | Yes | Yes
CALL:MODulation | No | No | Yes | No | Yes
CALL:MORiginated | No | No | No | Yes | Yes
CALL:MS | Yes | Yes | Yes | Yes | Yes
CALL:NCCode | Yes | Yes | Yes | Yes | Yes
CALL:NITZone | No | No | No | Yes | Yes
CALL:NMOPeration | No | No | No | Yes | Yes
CALL:OPERating | Yes | Yes | Yes | Yes | Yes
CALL:ORIGinate | Yes | Yes | Yes | Yes | Yes
CALL:(PACCH|PACChannel) | Yes | Yes | Yes | Yes | Yes
CALL:PAGing | Yes | Yes | Yes | Yes | Yes
CALL:(PBCCH|PBCChannel) | No | No | No | Yes | Yes
CALL:PBPTest | No | Yes | Yes | Yes | Yes
CALL:PCAType | No | Yes | Yes | Yes | Yes
CALL:(PDTCH|PDTChannel) | No | Yes | Yes | Yes | Yes
CALL:(PDTC2|PDTCH2|PDTChannel) | No | No | No | No | Yes
CALL:PFContext | No | No | No | Yes | Yes
CALL:PLOGging | No | No | No | Yes | Yes
CALL:PMNCode | Yes | Yes | Yes | Yes | Yes
CALL:POWer | Yes | Yes | Yes | Yes | Yes
CALL:PPRocedure | No | No | No | Yes | Yes
CALL:PSINdication | No | No | No | Yes | Yes
CALL:RACode | Yes | Yes | Yes | Yes | Yes
CALL:RFGenerator | Yes | Yes | Yes | Yes | Yes
CALL:RTVocoder | No | No | No | Yes | Yes
CALL:(SACCH|SACChannel) | Yes | Yes | Yes | Yes | Yes
CALL:SECurity | No | No | No | Yes | Yes
CALL:SETup | Yes | Yes | Yes | Yes | Yes
CALL:SIGNaling | Yes | Yes | Yes | Yes | Yes
CALL:SMService | No | No | No | Yes | Yes
CALL:SSERvice | No | No | No | Yes | Yes
CALL:STATus | Yes | Yes | Yes | Yes | Yes
CALL:T308 | No | No | No | Yes | Yes
CALL:TBFLow | No | No | No | Yes | Yes
CALL:TCHannel | Yes | No | No | Yes | Yes
CALL:TMSI | No | No | No | Yes | Yes
CALL:TRANsferring | No | Yes | Yes | Yes | Yes
CALL:TRIGger | Yes | Yes | Yes | Yes | Yes
CALL:UTRan | No | No | No | Yes | Yes


CALL:DTMode

CALL:DTMode

GPIB Command Conventions

  • CALL[:CELL]:DTMode
  • CALL[:CELL]:DTMode:ENHanced

CALL[:CELL]:DTMode

Function GSM TA

This command is not applicable to the GSM Test Applications.

GPRS TA

This command is not applicable to the GPRS Test Applications.

EGPRS TA

This command is not applicable to the EGPRS Test Applications.

GSM/GPRS LA

This command sets/queries the state of the Dual Transfer Mode feature. See DTM Enable for more information.

Note: The Operating Mode must be set to Cell Off before setting this parameter. See CALL:OPERating for more details.

EGPRS LA

Setting

Range: 1|ON|0|OFF

Query

Range: 0|1

*RST Setting

 1|ON
Requirements GSM/GPRS/ EGPRS LA

Revision: E.00.12 and above

Programming Example

OUTPUT 714;"CALL:CELL:DTMode ON"
! Enables Dual Transfer Mode.

CALL[:CELL]:DTMode:ENHanced

Function GSM TA

This command is not applicable to the GSM Test Applications.

GPRS TA

This command is not applicable to the GPRS Test Applications.

EGPRS TA

This command is not applicable to the EGPRS Test Applications.

GSM/GPRS LA

This command sets/queries the state of the Enhanced Dual Transfer Mode feature. See Enhanced DTM Enable for more information.

Note: The Operating Mode must be set to Cell Off before setting this parameter. See CALL:OPERating for more details.

EGPRS LA

Setting

Range: 1|ON|0|OFF

Query

Range: 0|1

*RST Setting

 0|OFF
Requirements GSM/GPRS/ EGPRS LA

Revision: E.00.12 and above

Programming Example

OUTPUT 714;"CALL:CELL:DTMode:ENHanced ON"
! Enables Enhanced Dual Transfer Mode.


CALL:END

CALL:END

GPIB Command Conventions

  • CALL:END

CALL:END

Function

GSM TA

Terminates the active voice or CSD call.

GPRS TA

EGPRS TA
GSM/GPRS LA

EGPRS LA

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:END"
! Terminate the call.


CALL:FUNCtion

CALL:FUNCtion

GPIB Command Conventions

  • CALL:FUNCtion:CONNection:TYPE

  • CALL:FUNCtion:DATA:BLER:LLC:FCSequence
  • CALL:FUNCtion:DATA:BLER:POLLing:INTerval

  • CALL:FUNCtion:DATA:BLOCk:POLLing:INTerval[:SELected]
  • CALL:FUNCtion:DATA:BLOCk:POLLing:INTerval:ACKB
  • CALL:FUNCtion:DATA:BLOCk:POLLing:INTerval:AUTO
  • CALL:FUNCtion:DATA:BLOCk:POLLing:INTerva:BLER

  • CALL:FUNCtion:DATA:DETach

  • CALL:FUNCtion:DATA:ETSIA:PDUNit|PDU:COUNt

  • CALL:FUNCtion:DATA:FRAMe:STARt

  • CALL:FUNCtion:DATA:PAYLoad:PATTern[:OTHer]
  • CALL:FUNCtion:DATA:PAYLoad:PATTern[:OTHer]:MSOurce:BURSt<n>
  • CALL:FUNCtion:DATA:PAYLoad:PATTern:BLER
  • CALL:FUNCtion:DATA:PAYLoad:PATTern:ETSIB

  • CALL:FUNCtion:DATA:PUPLink:ACKNack:INTerval:EGPRs
  • CALL:FUNCtion:DATA:PUPLink:ACKNack:INTerval:GPRS

  • CALL:FUNCtion:DATA:START

  • CALL:FUNCtion:DATA:STOP

  • CALL:FUNCtion:EGPRs:DEMod

  • CALL:FUNCtion:TBTerror[:STATe]

CALL:FUNCtion:CONNection:TYPE

Function

GSM TA

This command sets/queries the type of connection. This is always set to AUTO for the GSM test application.

GPRS TA

This command sets/queries the type of connection that is used when you use the command CALL:FUNCtion:DATA:START to start a data connection.

If you set this parameter to ETSI Type A, no packet data traffic channel (PDTCH) bursts will be transmitted on the downlink.

Setting this parameter to ETSI Type B (unacknowledged) ensures that one or more downlink (PDTCH) bursts are present, which can be used to loopback data through the uplink. The number of downlink bursts is determined by the setting of the command CALL:(PDTCH|PDTChannel):MSLot:CONFig . The ETSI Type B Acknowledged connection type (ACKB) is almost identical to the ETSI Type B (Unacknowledged) connection type, except that it features an acknowledged downlink. The acknowledged downlink ensures maximum compatibility with different mobile station types.

ETSI Type B (Unacknowledged) or ETSI Type B (Acknowledged) is required if you want to perform BER measurements in active cell mode.

Setting this parameter to BLER ensures that an Agilent proprietary data connection type is used which allows the test set to obtain BLock Error Rate (BLER) measurement reports from the mobile station (see Block Error Rate (BLER) Reports Description ). In addition, the BLER data connection type allows you to perform other GPRS measurements at the same time (except BER and ORFS due to Modulation).

It is recommended you always end the data connection (using CALL:FUNCtion:DATA:STOP ) before changing the data connection type. If you change this parameter while the data connection status is transferring, the data connection will be dropped (changing the data connection status to attached), and an error message will be generated.

GSM/GPRS LA

In addition to the functions of the GPRS TA (above), the GSM/GPRS lab application has the following effects:

  • When the data connection type is AUTO (formerly known as IP Data), BER measurements will not be accurate due to synchronization problems. However, BLER measurements are not affected.

EGPRS TA

This command sets/queries the type of connection that is used when you use the command CALL:FUNCtion:DATA:START to start a data connection.

If you set this parameter to ETSI Type A, no packet data traffic channel (PDTCH) bursts will be transmitted on the downlink.

Setting this parameter to ETSI Type B (unacknowledged) ensures that one or more downlink (PDTCH) bursts are present, which can be used to loopback data through the uplink. The number of downlink bursts is determined by the setting of the command CALL:(PDTCH|PDTChannel):MSLot:CONFig . The ETSI Type B Acknowledged connection type (ACKB) is almost identical to the ETSI Type B (Unacknowledged) connection type, except that it features an acknowledged downlink. The acknowledged downlink ensures maximum compatibility with different mobile station types.ETSI Type B (unacknowledged) or ETSI Type B Acknowledged is required if you want to perform BER measurements in active cell mode.

Each of the ETSI test modes are extended with EGPRS header information.

Setting this parameter to BLER ensures that an Agilent proprietary data connection type is used which allows the test set to obtain BLock Error Rate (BLER) measurement reports from the mobile station (see Block Error Rate (BLER) Reports Description ). In addition, the BLER data connection type allows you to perform other GMSK modulated EGPRS measurements at the same time (except Bit Error Rate and ORFS due to Modulation).

Setting this parameter to SRBL ensures that the Switched Radio Block (SRB) Loopback mode is used for the data connection. This connection type is only available in Active Cell operating mode.

It is recommended you always end the data connection (using CALL:FUNCtion:DATA:STOP ) before changing the data connection type. If you change this parameter while the data connection status is transferring, the data connection will be dropped (changing the data connection status to attached), and an error message will be generated.

When the data connection type is AUTO (formerly known as IP Data), BER measurements will not be accurate due to synchronization problems. However, BLER measurements are not affected.

EGPRS LA

Setting

GSM TA

Range: AUTO

GPRS TA

Range: A | B | ACKB |BLER | AUTO

GSM/GPRS LA

EGPRS TA

Range: A | B | ACKB | BLER | AUTO | SRBL

EGPRS LA

Query

GSM TA

Range: AUTO

GPRS TA

Range: A | B | ACKB | BLER | AUTO

GSM/GPRS LA

EGPRS TA

Range: A | B | ACKB | BLER | AUTO | SRBL

EGPRS LA

*RST Setting

GPRS TA

BLER
GSM TA

AUTO

GSM/GPRS LA

EGPRS TA

EGPRS LA
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:FUNCTION:CONNECTION:TYPE B"
! Sets the connection type to ETSI Type B

CALL:FUNCtion:DATA:BLER:LLC:FCSequence

Function

GSM TA

This command is not applicable to GSM.

GPRS TA

This command sets/queries whether or not the Logical Link Control (LLC) Frame Check Sequence (FCS) is corrupted in order to establish a BLER mode data connection.

Setting this parameter to VALid ensures that the cyclic redundancy check code within the FCS is valid.

Setting this parameter to CORRupt causes the test set to transmit an invalid FCS to the mobile. This setting may enable some mobiles to establish a BLER mode data connection which would not otherwise be possible with a valid FCS.

This parameter is only applicable when the data connection type is set to BLER using CALL:FUNCtion:CONNection:TYPE BLER.

If you change this parameter while the data connection type is any type other than BLER, the setting has no effect until a new BLER mode data connection is established.

This command along with CALL:FUNCtion:DATA:BLER:POLLing:INTerval provides you with additional control over BLER data connection type settings. This may enable the test set to establish a BLER mode data connection with mobiles which cannot connect under normal conditions.

EGPRS TA

GSM/GPRS LA

EGPRS LA

Setting

Range: VALid | CORRupt

Query

Range: VAL | CORR

*RST Setting

 VALid
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:FUNCTION:DATA:BLER:LLC:FCSEQUENCE CORRUPT"
! Sets the test set to transmit an invalid FCS to the mobile.

CALL:FUNCtion:DATA:BLER:POLLing:INTerval

Function

GSM TA

 This command is not applicable to GSM.

GPRS TA

THIS COMMAND IS OBSOLETE.

Use the command CALL:FUNCtion:DATA:BLOCk:POLLing:INTerval[:SELected] instead.

This command sets/queries the Block Polling Parameters for the currently selected connection type. This command is only applicable when the currently selected connection type is Auto, BLER or ETSI Type B (Ack).

The command to configure the connection type is CALL:FUNCtion:CONNection:TYPE .

If you change this parameter while the connection type is not applicable to the block poll interval, the setting request is ignored, and the query will return zero.

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting Range: 1 to 256, or 0 if the connection type is not applicable to the block polling interval.
Resolution: 1
Query Range: 1 to 256
Resolution: 1
*RST setting 1
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:FUNCTION:DATA:BLER:POLLING:INTERVAL 8"
! Sets block polling interval to 8.

CALL:FUNCtion:DATA:BLOCk:POLLing:INTerval[:SELected]

Function

GSM TA

 This command is not applicable to GSM.

GPRS TA

This command sets/queries the Block Polling Parameters for the currently selected connection type. This command is only applicable when the currently selected connection type is Auto, BLER or ETSI Type B (Ack).

The command to configure the connection type is CALL:FUNCtion:CONNection:TYPE .

If you change this parameter while the connection type is not applicable to the block poll interval, the setting request is ignored, and the query will return zero.

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting Range: 1 to 256
Resolution: 1
Query Range: 1 to 256, or 0 if the connection type is not applicable to the block polling interval.
Resolution: 1
*RST setting

Depends on the test set application and licenses:

Test application with GPRS and/or EGPRS license: 1

Test application with GSM license in addition to a GPRS and/or EGPRS license: 0 (Not Applicable to when the Connection Type is Auto in the Test application)

Lab application: 32
Requirements GSM/GPRS/
EGPRS TA

Revision: A.05 and above
GSM/GPRS/ EGPRS LA

Revision: D.02 and above

Programming Example

OUTPUT 714;"CALL:FUNCtion:DATA:BLOCk:POLLing:INTerval 8"
! The block polling interval is 8 for the test set's currently selected connection.

CALL:FUNCtion:DATA:BLOCk:POLLing:INTerval:ACKB

Function

GSM TA

 This command is not applicable to GSM.

GPRS TA

This command sets/queries the Block Polling Interval for when the connection type is set to ETSI Type B (Ack). The command to configure the connection type is CALL:FUNCtion:CONNection:TYPE .

For more information see Block Polling Parameters .

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting Range: 1 to 256
Resolution: 1
Query Range: 1 to 256
Resolution: 1
*RST setting 32
Requirements GSM/GPRS/
EGPRS TA

Revision: A.05 and above
GSM/GPRS/ EGPRS LA

Revision: D.02 and above

Programming Example

OUTPUT 714;"CALL:FUNCtion:DATA:BLOCk:POLLing:INTerval:ACKB 64"
! The block polling interval is 64 when the test set's connection type is ETSI Type B.

CALL:FUNCtion:DATA:BLOCk:POLLing:INTerval:AUTO

Function

GSM TA

 This command is not applicable to the GSM test application.

GPRS TA

This command sets/queries the Block Polling Interval for when the connection type is set to Auto. The command to configure the connection type is CALL:FUNCtion:CONNection:TYPE .

For more information see Block Polling Parameters .

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting Range: 1 to 256
Resolution: 1
Query Range: 1 to 256
Resolution: 1
*RST setting 32
Requirements GSM/GPRS/
EGPRS TA

Revision: A.05 and above
GSM/GPRS/ EGPRS LA

Revision: D.02 and above

Programming Example

OUTPUT 714;"CALL:FUNCtion:DATA:BLOCk:POLLing:INTerval:AUTO 64"
! The block polling interval is 64 when the test set's connection type is Auto.

CALL:FUNCtion:DATA:BLOCk:POLLing:INTerva:BLER

Function

GSM TA

 This command is not applicable to GSM.

GPRS TA

This command sets/queries the Block Polling Interval for when the connection type is set to BLER. The command to configure the connection type is CALL:FUNCtion:CONNection:TYPE .

For more information see Block Polling Parameters .

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting Range: 1 to 256
Resolution: 1
Query Range: 1 to 256
Resolution: 1
*RST setting 1
Requirements GSM/GPRS/
EGPRS TA

Revision: A.05 and above
GSM/GPRS/ EGPRS LA

Revision:D.02 and above

Programming Example

OUTPUT 714;"CALL:FUNCtion:DATA:BLOCk:POLLing:INTerval:BLER 4"
! The block polling interval is 4 when the test set's connection type is BLER.

CALL:FUNCtion:DATA:DETach

Function

GSM TA

This command is not applicable to GSM.

GPRS TA

This command performs a test set initiated GPRS Detach.

EGPRS TA

GSM/GPRS LA

EGPRS LA
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:FUNCTION:DATA:DETACH"
! Detaches the mobile from the test set.

CALL:FUNCtion:DATA:ETSIA:PDUNit|PDU:COUNt

Function

GSM TA

This command sets/queries the number of Protocol Data Units (PDUs) sent from the test set to the mobile station.

When the PDU count is set to zero, the test set commands the mobile station to transmit continually as long as there is a connection between the mobile station. When the PDU count is set to 4095 the test set commands the mobile station to send 4095 PDUs on the uplink TBF before the mobile station terminates the connection between the mobile station and the test set.

See Protocol Data Unit Count for more information on which connection types are valid when setting the PDU count.

This setting only affects the ETSI Type A operating mode, see CALL:OPERating:MODE .

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Setting

 0|4095

Query

0|4095

*RST Setting

 4095
Requirements

GSM/GPRS/
EGPRS TA

Revision: A.04 and above

GSM/GPRS/
EGPRS LA

 Revision: D.01 an d above

Programming Example

OUTPUT 714;"CALL:FUNCtion:DATA:ETSIA:PDU:COUNt 0"
! The test set commands the mobile station to continuously transmit PDUs as long as
! there is a connection between the test set and the mobile station.

CALL:FUNCtion:DATA:FRAMe:STARt

Function

GSM TA

This command is not applicable to GSM.

GPRS TA

This command sets/queries the type of frame numbering scheme to be used when establishing a data connection.

Changing the frame numbering scheme may enable the test set to establish a data connection with mobiles which cannot connect under normal conditions.

When you set this command to:

  • RELative, the test set sends the starting frame number to the mobile as a relative offset from the current frame.
  • ABSolute, the test set sends the starting frame number to the mobile as an absolute frame number.
  • IMMediate, the test set sends the starting frame number as an immediate assignment.

It is recommended that you should not change this parameter while the data connection status is Starting, as there is no guarantee whether the new setting or the previous setting will be used for the current data connection.

If the type of data connection you want to establish is BLER, the commands CALL:FUNCtion:DATA:BLER:LLC:FCSequence and CALL:FUNCtion:DATA:BLER:POLLing:INTerval may also be helpful in enabling the test set to establish a data connection with mobiles which cannot establish a BLER data connection under normal conditions.

EGPRS TA

GSM/GPRS LA

EGPRS LA

Setting

Range: RELative | ABSolute | IMMediate

Query

Range: REL | ABS | IMM

*RST Setting

 REL
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:FUNCTION:DATA:FRAME:START ABSOLUTE"
! Sets the frame number type to Absolute.

CALL:FUNCtion:DATA:PAYLoad:PATTern[:OTHer]

Function

GSM TA

This command is not applicable to GSM.

GPRS TA

This command sets/queries the type of downlink payload pattern to be used when the test set's operating mode is set to a valid connection type. See CALL:FUNCtion:CONNection:TYPE for the GPIB command to set the connection type.

Changes to the payload pattern setting become effective immediately. See Payload Pattern (OTHER) for more information on the payload pattern parameters available and the valid connection types for this command.

EGPRS TA

GSM/GPRS LA
EGPRS LA

Setting

Range: ZERos | ONES | ABITs | APAirs | AQUads | PRBS15 | PRBS9 | FIXED2B |CUSTom

Query

Range: ZER | ONES | ABIT | APA | AQU | PRBS15 | PRBS9 | FIXED2B |CUST

*RST Setting

 PRBS15
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
Revision A.04 adds CUSTom
Revision A.09 adds PRBS9 with required feature license.
GSM/GPRS/ EGPRS LA

Revision: C.01 and above
Revision D.01 adds CUSTom
Revision F.01 adds PRBS9

Programming Example

OUTPUT 714;"CALL:FUNCTION:DATA:PAYLoad:PATTern:ETSIB AQUADS"
! Sets the payload pattern to be Alternate Quads.

CALL:FUNCtion:DATA:PAYLoad:PATTern[:OTHer]:MSOurce:BURSt<n>

Function

GSM TA

This command is not applicable to GSM Test Application.

GPRS TA

This command is not applicable to GPRS Test Application.

GSM/GPRS LA

This command is not applicable to GSM/GPRS Lab Application.
EGPRS TA

This command sets/queries the type of downlink payload pattern to be used when the test set's operating mode is set to a valid connection types. See Multi Source Payload Pattern (OTHER) for more information.
EGPRS LA

Setting

Range: ZERos | ONES | ABITs | APAirs | AQUads | PRBS9 | PRBS15 | FIXED2B |CUSTom

Query

Range: ZERO | ONES | ABIT | APA | AQU | PRBS9 | PRBS15 | FIXED2B |CUST

*RST Setting

 PRBS15
Requirements GSM/GPRS/
EGPRS TA

Revision: A.09 and above with required feature license.
GSM/GPRS/ EGPRS LA

Revision: F.01 and above

Programming Example

OUTPUT 714;"CALL:FUNCtion:DATA:PAYLoad:PATTern:MSOurce:BURSt2 AQUads"
! Sets the payload pattern to be Alternate Quads.

CALL:FUNCtion:DATA:PAYLoad:PATTern:BLER

Function

GSM TA

This command is not applicable to GSM.

GPRS TA

This command sets/queries the type of downlink payload pattern to be sent to the mobile when the connection type is set to BLER (see CALL:FUNCtion:CONNection:TYPE ) in Active Cell operating mode, and the LLC Frame Check Sequence parameter is set to CORRupt (see CALL:FUNCtion:DATA:BLER:LLC:FCSequence ).

Changes to the payload pattern setting become effective immediately. See Payload Pattern (BLER) for more information on the payload pattern parameters available for this command.

If this command is set to any value other than GMMinfo, and you want to change the setting of the LLC Frame Check Sequence parameter from CORRupt to VALid, it is strongly recommended that you end the data connection before making this change. After the LLC Frame Check Sequence parameter has been set to VALid, the data connection can be restarted using CALL:FUNCtion:DATA:START .

EGPRS TA

GSM/GPRS LA

EGPRS LA

Setting

Range: GMMinfo | ZEROs | ONES | ABITs | APAirs | AQUads | PRBS9 | PRBS15 | FIXED2B |CUSTom

Query

Range: GMM | ZERO | ONES | ABIT | APA | AQU | PRBS9 | PRBS15 | FIXED2B | CUST

*RST Setting

 GMM
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
Revision A.04 adds CUSTom
Revision A.09 adds PRBS9 with required feature license.
GSM/GPRS/ EGPRS LA

Revision: C.01 and above
Revision D.01 adds CUSTom
Revision F.01 adds PRBS9

Programming Example

OUTPUT 714;"CALL:FUNCTION:DATA:PAYLoad:PATTern:BLER ONES"
! Sets the payload pattern to be All Ones.

CALL:FUNCtion:DATA:PAYLoad:PATTern:ETSIB

Function

GSM TA

This command is not applicable to GSM.

GPRS TA

THIS COMMAND IS OBSOLETE. Please use the CALL:FUNCtion:DATA:PAYLoad:PATTern[:OTHer] command to perform the function of this command.

This command sets/queries the type of downlink payload pattern to be used when the test set's operating mode is set to either BCH+PDTCH Test Mode, or Active CALL operating mode with the data connection type set to ETSI Type B (see CALL:FUNCtion:CONNection:TYPE ).

Changes to the payload pattern setting become effective immediately. See Payload Pattern (BLER) for more information on the payload pattern parameters available for this command.

EGPRS TA

GSM/GPRS LA
EGPRS LA

Setting

Range: ZERos | ONES | ABITs | APAirs | AQUads | PRBS9 | PRBS15 | FIXED2B | CUSTom

Query

Range: ZER | ONES | ABIT | APA | AQU | PRBS9 | PRBS15 | FIXED2B | CUST

*RST Setting

 PRBS15
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above

Revision A.04 adds CUSTom

evision A.09 adds PRBS9 with required feature license.
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Revision D.01 adds CUSTom

Revision F.01 adds PRBS9

Programming Example

OUTPUT 714;"CALL:FUNCTION:DATA:PAYLoad:PATTern:ETSIB AQUADS"
! Sets the payload pattern to be Alternate Quads.

CALL:FUNCtion:DATA:PUPLink:ACKNack:INTerval:EGPRs

Function

GSM TA

This command is not applicable to GSM.

GPRS TA

 This command is not applicable to GPRS Test Application.

EGPRS TA

 This command is not applicable to EGPRS Test Application.

GSM/GPRS LA

 Sets/Queries the "Packet Uplink Ack/Nack Interval (EGPRS)". See Packet Uplink Ack/Nack Interval .
EGPRS LA

Setting

Range: 1 to 1023

Resolution: 1

Query

Range: 1 to 1023

*RST Setting

 9
GSM/GPRS/ EGPRS LA

Revision: E.00.12 and above

Programming Example

OUTPUT 714;"CALL:FUNCTION:DATA:PUPLink:ACKNack:INTerval:EGPRs 8"
! Set the Packet Uplink !Ack/Nack Interval(EGPRS) to 8.

CALL:FUNCtion:DATA:PUPLink:ACKNack:INTerval:GPRS

Function

GSM TA

This command is not applicable to GSM.

GPRS TA

 This command is not applicable to GPRS Test Application.

EGPRS TA

 This command is not applicable to EGPRS Test Application.

GSM/GPRS LA

 Sets/Queries the "Packet Uplink Ack/Nack Interval (GPRS)". See Packet Uplink Ack/Nack Interval .
EGPRS LA

Setting

Range: 1 to 63

Resolution: 1

Query

Range: 1 to 63

*RST Setting

 9
Requirements GSM/GPRS/ EGPRS LA

Revision: E.00.12 and above

Programming Example

OUTPUT 714;"CALL:FUNCTION:DATA:PUPLink:ACKNack:INTerval:GPRS 8"
! Set the Packet Uplink !Ack/Nack Interval(GPRS) to 8.

CALL:FUNCtion:DATA:START

Function

GSM TA

This command is not applicable to GSM.

GPRS TA

This command attempts to start the data connection. See Data Connection Processing Event Synchronization .

Additional commands can be appended to aid in controller/mobile station synchronization. See Call Processing Subsystem Overlapped Command Synchronization Commands for examples.

If you have trouble getting the data connection to start, see GPRS Data Connection Troubleshooting .

EGPRS TA

GSM/GPRS LA

EGPRS LA
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:FUNCTION:DATA:START"
! Starts data connection.

CALL:FUNCtion:DATA:STOP

Function

GSM TA

This command is not applicable to GSM.

GPRS TA

This command ends the data connection.

EGPRS TA

GSM/GPRS LA

EGPRS LA
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:FUNCTION:DATA:STOP"
! Ends data connection.

CALL:FUNCtion:EGPRs:DEMod

Function

GSM TA

This command is not applicable to GSM.

GPRS TA

 This command is not applicable to GPRS.

EGPRS TA

 This command sets/queries the layer 1 demodulation setting for EGPRS.

GSM/GPRS LA

 This command is not applicable to the GSM/GPRS lab application.

EGPRS LA

 This command is not applicable to the EGPRS lab application.

Setting

Range: NORMal | REDuced

Query

Range: NORM| RED

*RST Setting

 NORM
Requirements GSM/GPRS/
EGPRS TA

Revision: A.03 and above

Programming Example

OUTPUT 714;"CALL:FUNCtion:EGPRs:DEMod NORM"
! Sets the EGPRS Demod to normal.

CALL:FUNCtion:TBTerror[:STATe]

Function

GSM TA

This command sets/queries the availability of BTE measurement in test mode.

This setting controls the test set to determine whether real-time demodulation is needed and decide whether Demod Type is used. When the setting is ON, the Demod Type is changed to Normal.

In order to keep backward-compatibility, when the setting is set to OFF in operating modes other than EGPRS test modes, the Demod Type is always Normal. But the BTE report is still not available to reduce the message exchange between processors of the test set. When the setting becomes OFF in EGPRS test modes and BER, BLER or SRB BER measurement is not running, the EGPRS Demod Type Setting reverts to Reduced and EGPRS demodulation is applied only occasionally. See Test Mode Burst Timing Error Measurement for more information.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Setting

Range: OFF | 0 |ON| 1

Query

Range: 0| 1

*RST Setting

 OFF
Requirements GSM/GPRS/
EGPRS TA

Revision: A.09 and above

Programming Example

OUTPUT 714;"CALL:FUNCtion:TBTerror ON"
! Sets the BTE measurement in test mode.


CALL:G850MNCode

CALL:G850MNCode

GPIB Command Conventions

  • CALL[:CELL]:G850MNCode[:SVALue]
  • CALL[:CELL]:G850MNCode:VALue
  • CALL[:CELL]:G850MNCode:STATe

CALL[:CELL]:G850MNCode[:SVALue]

Function

 GSM TA

This command sets/queries the 3 digit mobile network code. This command is used for the GSM850 band only. Note, this command can only be used when the Cell Operating Mode is OFF and Cell Band is set to GSM850.

GPRS TA

EGPRS LA

GSM/GPRS LA

EGPRS LA

Setting

Range: 0 to 999

Resolution: 1

Query

Range: 0 to 999

Resolution: 1

*RST Setting

1
Requirements GSM/GPRS/
EGPRS TA

Revision: A.07 and above
GSM/GPRS/ EGPRS LA

Revision: E.01 and above

Programming Example

OUTPUT 714;"CALL:CELL:OPERATING:MODE OFF"
! Sets the operating mode to Cell Off.

OUTPUT 714;"CALL:CELL:BAND GSM850"
! Sets the Cell Band to GSM850.

OUTPUT 714;"CALL:CELL:G850MNCODE:SVALUE 798"
! Sets the value to 798 and the state
                                          !to ON. Only used for GSM850 band.

CALL[:CELL]:G850MNCode:VALue

Function

 GSM TA

This command sets/queries the 3 digit mobile network code value. This command is used for GSM850 band only. Note, this command can only be used when the Cell Operating Mode is OFF and Cell Band is set to GSM850.

GPRS TA

EGPRS LA
GSM/GPRS LA

EGPRS LA

Setting

Range: 0 to 999

Resolution: 1

Query

Range: 0 to 999

Resolution: 1

*RST Setting

1
Requirements GSM/GPRS/
EGPRS TA

Revision: A.07 and above
GSM/GPRS/ EGPRS LA

Revision: E.01 and above

Programming Example

OUTPUT 714;"CALL:CELL:G850MNCODE:VALUE 798"
! Sets the 3 digit MNCode for GSM 850 to 798.

CALL[:CELL]:G850MNCode:STATe

Function

 GSM TA

This command sets/queries the MNC state. This command is used for the GSM850 band only. Setting it to ON configures the BCCH to use the 3 digit MNC. Note, this command can only be used when the Cell Operating Mode is OFF and Cell Band is set to GSM850.

GPRS TA

EGPRS LA

GSM/GPRS LA

EGPRS LA

Setting

Range: 0 | OFF | 1 | ON

Query

Range: 0 | 1

*RST Setting

 0 | OFF
Requirements GSM/GPRS/
EGPRS TA

Revision: A.07 and above
GSM/GPRS/ EGPRS LA

Revision: E.01 and above

Programming Example

OUTPUT 714;"CALL:CELL:G850MNCode:STATe ON"
! Enables the 3 digit MNCode for GSM850.


CALL:HANDover|HANDoff

CALL:HANDover|HANDoff

GPIB Command Conventions

  • CALL:HANDover|HANDoff[:IMMediate]
  • CALL:HANDover|HANDoff:EXTernal[:IMMediate]
  • CALL:HANDover|HANDoff:EXTernal:INFormation:FSYNch:STATus?
  • CALL:HANDover|HANDoff:EXTernal:INFormation:OTDifference?
  • CALL:HANDover|HANDoff:EXTernal:PSWitched[:STATe]
  • CALL:HANDover|HANDoff:EXTernal:SYNChronize:INDication[:STATe]
  • CALL:HANDover|HANDoff:EXTernal:SYNChronize:NCI[:STATe]
  • CALL:HANDover|HANDoff:EXTernal:SYNChronize:ROT[:STATe]
  • CALL:HANDover|HANDoff:EXTernal:SYNChronize:TADVance[:STATe]
  • CALL:HANDover|HANDoff:EXTernal:SYNChronize:TYPE
  • CALL:HANDover|HANDoff:FSYNchronize[:IMMediate]
  • CALL:HANDover|HANDoff:FSYNchronize:OFFSet:BIT
  • CALL:HANDover|HANDoff:FSYNchronize:OFFSet:FNUMber
  • CALL:HANDover|HANDoff:FSYNchronize:POWer:CORRection:GAIN

CALL:HANDover|HANDoff[:IMMediate]

Function

GSM TA

This command applies to GSM as described in the GPRS description. This command applies the deferred TCHannel parameters to the active TCH. These parameters are:

  • Deferred TCH Timeslot
  • Deferred mobile station TCH TX level [band]
  • Deferred TCH ARFCN [band]
  • Deferred TCH band
  • Deferred TCH channel mode (full-rate, enhanced full-rate, or half-rate speech)
  • Deferred TCH channel mode half-rate speech sub channel
For more information on the use of deferred parameters see Using Deferred Parameters .

GPRS TA

This command applies the deferred PDTCH parameters to the active PDTCH. These parameters are:

  • Deferred PDTCH Band
  • Deferred PDTCH ARFCN [band]
  • Deferred mobile station TX Level [burst][band]
  • Deferred Multislot Configuration
  • Deferred Coding Scheme
  • Deferred P0

For more information on the use of deferred parameters see Using Deferred Parameters .

The action taken when this command is set depends on the setting of the cell operating mode and the data connection status:

  • When the cell operating mode is set to Active Cell (see CALL:OPERating:MODE ) and the data connection status is Transferring, this command causes any necessary over-the-air signaling to modify the PDTCH resources (frequency, power level, timeslot assignment and coding scheme). The immediate settings are updated with the deferred settings just applied and the current downlink PDTCH levels are updated.
  • When the cell operating mode is set to Active Cell (see CALL:OPERating:MODE ) and the data connection status is any state other than Transferring, the handover command is ignored and the following error is displayed "Call operation rejected; Protocol request ignored." The immediate settings are not updated.
  • When the cell operating mode is not set to Active Cell, this command replaces any active PDTCHs with new PDTCHs using the new parameters. If there are no active PDTCHs, the new values will be remembered until there is an active PDTCH. In either case, the immediate settings are updated with the deferred settings just applied and the current downlink PDTCH levels are updated.

EGPRS TA
GSM/GPRS LA

EGPRS LA
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:HANDover:IMMediate"

CALL:HANDover|HANDoff:EXTernal[:IMMediate]

Function

GSM TA

 This command is not applicable to GSM Test Application

GPRS TA

 This command is not applicable to GPRS Test Application

EGPRS TA

 This command is not applicable to EGPRS Test Application
GSM/GPRS LA

This command initiates the network initiated handovers and cell reselections in the two cell test system.

The type of cell transition performed by the test set upon receipt of this command depends on the current connection status of DUT. If a voice, CSD or DTM session is currently in progress. a "Handover command" message is sent to the DUT requesting it performs a Handover. If the DUT is in Idle mode (but at least GPRS attached) or a GPRS /EGPRS data connection is in progress, a Packet Cell Change Order message is sent to the DUT requesting it perform cell reselection.

see Two-Cell Test System for more information.

EGPRS LA
Requirements GSM/GPRS/ EGPRS LA

Revision: E.01 and above

Programming Example

OUTPUT 714;"CALL:HANDover:EXTernal:IMMediate"

CALL:HANDover|HANDoff:EXTernal:INFormation:FSYNch:STATus?

Function

GSM TA

 This command is not applicable to GSM Test Application

GPRS TA

 This command is not applicable to GPRS Test Application

EGPRS TA

 This command is not applicable to EGPRS Test Application
GSM/GPRS LA

This command quires the Synchronization Status. The parameter is 1 if the slave test set believes it is synchronized to the master test set.

See Handover Parameters for more information.

EGPRS LA
Query Range: 0|1
Requirements GSM/GPRS/ EGPRS LA

Revision: G.00.00 and above

Programming Example

OUTPUT 714;"CALL:HANDover:EXTernal:INFormation:FSYNch:STATus?"

CALL:HANDover|HANDoff:EXTernal:INFormation:OTDifference?

Function

GSM TA

 This command is not applicable to GSM Test Application

GPRS TA

 This command is not applicable to GPRS Test Application

EGPRS TA

 This command is not applicable to EGPRS Test Application
GSM/GPRS LA

This command quires the Mobile Observed Time Difference value reported in the HANDOVER_COMPLETE message.

See Handover Parameters for more information.

EGPRS LA
Query

Range: 0 to 2097151
Requirements GSM/GPRS/ EGPRS LA

Revision: G.00.00 and above

Programming Example

OUTPUT 714;"CALL:HANDover:EXTernal:INFormation:OTDifference?"

CALL:HANDover|HANDoff:EXTernal:PSWitched[:STATe]

Function

GSM TA

 This command is not applicable to GSM Test Application

GPRS TA

 This command is not applicable to GPRS Test Application

EGPRS TA

 This command is not applicable to EGPRS Test Application
GSM/GPRS LA

This command sets/quires the packet-switched handover state. When the PS handover state is set to ON, the handover of a DUT in packet transfer state will maintain packet resources during the handover procedure. otherwise, the DUT must abort the packet resources during the handover procedure.

see PS Handover Procedure for more information.

EGPRS LA
Setting | Range: 1|ON|0|OFF
Query | Range: 0|1
*RST setting | 0|OFF
Requirements GSM/GPRS/ EGPRS LA

Revision: F.00.37 and above

Programming Example

OUTPUT 714;"CALL:HANDover:EXTernal:PSWitched:STATe ON"
! Sets the PS handover state to ON.

CALL:HANDover|HANDoff:EXTernal:SYNChronize:INDication[:STATe]

Function

GSM TA

 This command is not applicable to GSM Test Application

GPRS TA

 This command is not applicable to GPRS Test Application

EGPRS TA

 This command is not applicable to EGPRS Test Application
GSM/GPRS LA

This command sets/quires the Sychronization Indication state. When the Sychronization Indication state is set to ON, the Sychronization Indication IE is present in the HANDOVER_COMMAND message.

See Synchronized Handovers for more information.

EGPRS LA
Setting | Range: 1|ON|0|OFF
Query | Range: 0|1
*RST setting | 0|OFF
Requirements GSM/GPRS/ EGPRS LA

Revision: G.00.00 and above

Programming Example

OUTPUT 714;"CALL:HANDover:EXTernal:SYNChronize:INDication OFF"

CALL:HANDover|HANDoff:EXTernal:SYNChronize:NCI[:STATe]

Function

GSM TA

 This command is not applicable to GSM Test Application

GPRS TA

 This command is not applicable to GPRS Test Application

EGPRS TA

 This command is not applicable to EGPRS Test Application
GSM/GPRS LA

This command sets/quires the Normal Cell Indication state. When the Normal Cell Indication state is set to ON, the Normal Cell Indication IE is present in the HANDOVER_COMMAND message.

See Synchronized Handovers for more information.

EGPRS LA
Setting | Range: 1|ON|0|OFF
Query | Range: 0|1
*RST setting | 0|OFF
Requirements GSM/GPRS/ EGPRS LA

Revision: G.00.00 and above

Programming Example

OUTPUT 714;"CALL:HANDover:EXTernal:SYNChronize:NCI OFF"

CALL:HANDover|HANDoff:EXTernal:SYNChronize:ROT[:STATe]

Function

GSM TA

 This command is not applicable to GSM Test Application

GPRS TA

 This command is not applicable to GPRS Test Application

EGPRS TA

 This command is not applicable to EGPRS Test Application
GSM/GPRS LA

This command sets/quires the Report Observed Time Difference (ROT) state. When the ROT state is set to ON, the Timing Difference IE is present in the HANDOVER_COMMAND message.

The Timing Difference value is controlled by the timing advance values in the two test sets of the two-cell test system:

TD = (2k+TA[A]-TA[B])mod 256

Where:
TD = Timing Difference
k = an arbitrary bit offset value by which the frames in the slave test set
lead the frames in the master test set.
TA[A] = Timing Advance on the slave test set.
TA[B] = Timing Advance on the master test set.

See Synchronized Handovers for more information.

EGPRS LA
Setting | Range: 1|ON|0|OFF
Query | Range: 0|1
*RST setting | 0|OFF
Requirements GSM/GPRS/ EGPRS LA

Revision: G.00.00 and above

Programming Example

OUTPUT 714;"CALL:HANDover:EXTernal:SYNChronize:ROT OFF"

CALL:HANDover|HANDoff:EXTernal:SYNChronize:TADVance[:STATe]

Function

GSM TA

 This command is not applicable to GSM Test Application

GPRS TA

 This command is not applicable to GPRS Test Application

EGPRS TA

 This command is not applicable to EGPRS Test Application
GSM/GPRS LA

This command sets/quires the Timing Advance state. When the Timing Advance state is set to ON, the Timing Advance IE is present in the HANDOVER_COMMAND message.

See Synchronized Handovers for more information.

EGPRS LA
Setting | Range: 1|ON|0|OFF
Query | Range: 0|1
*RST setting | 0|OFF
Requirements GSM/GPRS/ EGPRS LA

Revision: G.00.00 and above

Programming Example

OUTPUT 714;"CALL:HANDover:EXTernal:SYNChronize:TADVance OFF"

CALL:HANDover|HANDoff:EXTernal:SYNChronize:TYPE

Function

GSM TA

 This command is not applicable to GSM Test Application

GPRS TA

 This command is not applicable to GPRS Test Application

EGPRS TA

 This command is not applicable to EGPRS Test Application
GSM/GPRS LA

This command sets/quires the Synchronization Type.

See Synchronized Handovers for more information.

EGPRS LA
Setting | Range: NON | SYNChronized | PRE | PSEudo
Query | Range: NON | SYNC | PRE | PSE
*RST setting | NON
Requirements GSM/GPRS/ EGPRS LA

Revision: G.00.00 and above

Programming Example

OUTPUT 714;"CALL:HANDover:EXTernal:SYNChronize:TYPE NON"

CALL:HANDover|HANDoff:FSYNchronize[:IMMediate]

Function

GSM TA

 This command is not applicable to GSM Test Application

GPRS TA

 This command is not applicable to GPRS Test Application

EGPRS TA

 This command is not applicable to EGPRS Test Application
GSM/GPRS LA Commands the slave test set to align its BCH frame structure with the master's.

See Frame Synchronization for more information.

EGPRS LA
Requirements GSM/GPRS/ EGPRS LA

Revision: G.00.00 and above

Programming Example

OUTPUT 714;"CALL:HANDover:FSYNchronize"

CALL:HANDover|HANDoff:FSYNchronize:OFFSet:BIT

Function

GSM TA

 This command is not applicable to GSM Test Application

GPRS TA

 This command is not applicable to GPRS Test Application

EGPRS TA

 This command is not applicable to EGPRS Test Application
GSM/GPRS LA

This command configures the Bit Offset used during Frame Synchronization.

See Frame Synchronization for more information.

EGPRS LA
Setting

Range: -1249 to 1249

Resolution: 1
Query

Range: -1249 to 1249

Resolution: 1
*RST setting 0
Requirements GSM/GPRS/ EGPRS LA

Revision: G.00.00 and above

Programming Example

OUTPUT 714;"CALL:HANDover:FSYNchronize:OFFSET:BIT 0"

CALL:HANDover|HANDoff:FSYNchronize:OFFSet:FNUMber

Function

GSM TA

 This command is not applicable to GSM Test Application

GPRS TA

 This command is not applicable to GPRS Test Application

EGPRS TA

 This command is not applicable to EGPRS Test Application
GSM/GPRS LA

This command configures the Frame Number Offset used during Frame Synchronization.

See Frame Synchronization for more information.

EGPRS LA
Setting

Range: -2715647 to 2715647

Resolution: 1
Query

Range: -2715647 to 2715647

Resolution: 1
*RST setting 0
Requirements GSM/GPRS/ EGPRS LA

Revision: G.00.00 and above

Programming Example

OUTPUT 714;"CALL:HANDover:FSYNchronize:OFFSet:FNUMber 0"

CALL:HANDover|HANDoff:FSYNchronize:POWer:CORRection:GAIN

Function

GSM TA

 This command is not applicable to GSM Test Application

GPRS TA

 This command is not applicable to GPRS Test Application

EGPRS TA

 This command is not applicable to EGPRS Test Application
GSM/GPRS LA

This command configures the Power Correction Gain. The Power Correction Gain is a value by which the power level that the master is instructed to output is decreased to compensate for gains in the RF path between the master and slave.

See Frame Synchronization for more information.

EGPRS LA
Setting

Range: -100.0 to 100.0

Resolution: 0.1
Query

Range: -100.0 to 100.0

Resolution: 0.1
*RST setting 0
Requirements GSM/GPRS/ EGPRS LA

Revision: G.00.00 and above

Programming Example

OUTPUT 714;"CALL:HANDover:FSYNchronize:POWer:CORRection:GAIN 0"


CALL:IATTach

CALL:IATTach

Last updated:December 3, 2008

  • CALL[:CELL]:IATTach[:STATe]?

GPIB Command Conventions

CALL[:CELL]:IATTach[:STATe]?

Function

GSM TA

This command sets/queries the state of the IMSI (International Mobile Subscriber Identity) Attach flag. If the location area when the mobile station is powered on is the same as when it last detached from the network, then the IMSI Attach flag state is used by the mobile station to determine whether or not it should perform an IMSI Attach procedure when the mobile station is powered on. Otherwise, if the location area is different from the previous location area, a location area update procedure is performed regardless of the IMSI ATTach flag state.

The IMSI Attach flag state is also used to determine whether or not the mobile station is required perform the IMSI Detach procedure.

The state of the IMSI Attach flag is not operating mode specific, therefore if the state is changed in any operating mode, the change will be reflected in all other operating modes. Although the IMSI Attach state can be varied in any operating mode, it is only applicable in Active Cell (serving cell GSM, GPRS or EGPRS). See Active Cell Operating Mode for more details.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Range: 1|ON|0|OFF

*RST Setting

0 | OFF

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.05 and above
GSM/GPRS/ EGPRS LA

Revision: D.02 and above

Programming Example

OUTPUT 714;"CALL:IATTach 1"
! Sets the state of the IMSI Attach flag to 1."


CALL:IMEI

CALL:IMEI

GPIB Command Conventions

  • CALL:IMEI:AUTO

CALL:IMEI:AUTO

Function

 GSM TA

Sets/queries whether or not the base station emulator should request the international mobile equipment identity (IMEI) on call setup.

NOTE
The test set always displays a zero for the 15th digit of the IMEI. This behavior conforms to 3GPP TS 03.03, which requires that the 15th digit (referred to as Spare digit or Check Digit) "shall be zero, when transmitted by the MS", and 3GPP TS 02.16 which states that the "check digit is not part of the digits transmitted at IMEI check equations".
GSM/GPRS LA

EGPRS TA

GPRS TA

EGPRS LA

Setting

Range: 1 | ON | 0 | OFF

Query

Range: 1 | 0

*RST Setting

1

Related Topics

 Identity Request
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:IMEI:AUTO OFF"
! Sets automatically request IMEI state to OFF.


CALL:LACode

CALL:LACode

GPIB Command Conventions

  • CALL[:CELL]:LACode
  • CALL[:CELL]:LACode[:SELected]
  • CALL[:CELL]:LACode:GSM

CALL[:CELL]:LACode

Function

 GSM TA

Sets/queries the value of the cell's Location Area Code (LAC). This can only be set when the Cell Operating Mode parameter is set to Off (see CALL:OPERating:MODE ).
GPRS TA

EGPRS TA

GSM/GPRS LA
EGPRS LA

Setting

Range: 0 to 65535

Resolution: 1

Query

Range: 0 to 65535

Resolution: 1

*RST Setting

1

Related Topics

Configuring the Broadcast Channel (BCH)

Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:CELL:LACODE 456"
! Sets the cell's location area code 456.

CALL[:CELL]:LACode[:SELected]

Function

 GSM TA

Sets/queries the value of the cell's Location Area Code (LAC) for the active (that is the selected) format. This can only be set when the Cell Operating Mode parameter is set to Off (see CALL:OPERating:MODE ).
GPRS TA

EGPRS TA
GSM/GPRS LA

EGPRS LA

Setting

Range: 0 to 65535

Resolution: 1

Query

Range: 0 to 65535

Resolution: 1

*RST Setting

1

Related Topics

Configuring the Broadcast Channel (BCH)

Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:CELL:LACODE:SELECTED 456"
! Sets the cell's location area code 456.

CALL[:CELL]:LACode:GSM

Function

 GSM TA

Sets/queries the value of the cell's Location Area Code (LAC) for the GSM format. This can only be set when the Cell Operating Mode parameter is set to Off (see CALL:OPERating:MODE ).
GSM/GPRS LA

EGPRS TA
GPRS TA

EGPRS LA

Setting

Range: 0 to 65535

Resolution: 1

Query

Range: 0 to 65535

Resolution: 1

*RST Setting

1

Related Topics

Configuring the Broadcast Channel (BCH)

Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:CELL:LACODE:GSM 456"
! Sets the cell's location area code 456.


CALL:MCCode

CALL:MCCode

GPIB Command Conventions

  • CALL[:CELL]:MCCode[:SELected]
  • CALL[:CELL]:MCCode:GSM

CALL[:CELL]:MCCode[:SELected]

Function

 GSM TA

Sets/queries the value of the Mobile Country Code (MCC) for the active (that is the selected) format. This can only be set when the Cell Operating Mode parameter is set to Off (see CALL:OPERating:MODE ).
GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Setting

Range: 0 to 999

Resolution: 1

Query

Range: 0 to 999

Resolution: 1

*RST Setting

The *RST value of this command depends on the format that is currently active. For example, if the GSM format is currently active, the *RST value for this command is the same value as the equivalent command containing the :GSM format identifier.

Related Topics

 Configuring the Broadcast Channel (BCH)
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:CELL:MCCODE:SELECTED 4"
! Sets the cell's mobile country code to 4.

CALL[:CELL]:MCCode:GSM

Function

 GSM TA

Sets/queries the value of the Mobile Country Code (MCC) for the GSM format. This can only be set when the Cell Operating Mode parameter is set to Off (see CALL:OPERating:MODE ).
GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Setting

Range: 0 to 999

Resolution: 1

Query

Range: 0 to 999

Resolution: 1

*RST Setting

1

Related Topics

 Configuring the Broadcast Channel (BCH)
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:CELL:MCCODE:GSM 4"
! Sets the cell's mobile country code to 4.


CALL:MNCode

CALL:MNCode

GPIB Command Conventions

  • CALL[:CELL]:MNCode
  • CALL[:CELL]:MNCode[:SELected]
  • CALL[:CELL]:MNCode:GSM

CALL[:CELL]:MNCode

Function

 GSM TA

Sets/queries the value of the Mobile Network Code (MNC). This can only be set when the Cell Operating Mode parameter is set to Off (see CALL:OPERating:MODE ).
GPRS TA

EGPRS TA

GSM/GPRS LA
EGPRS LA

Setting

Range: 0 to 99

Resolution: 1

Query

Range: 0 to 99

Resolution: 1

*RST Setting

1

Related Topics

 Configuring the Broadcast Channel (BCH)
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:CELL:MNCODE 45"
! Sets the cell's mobile network code to 45.

CALL[:CELL]:MNCode[:SELected]

Function

 GSM TA

Sets/queries the value of the Mobile Network Code (MNC) for the active (that is the selected) format. This can only be set when the Cell Operating Mode parameter is set to Off (see CALL:OPERating:MODE ).
GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Setting

Range: 0 to 99

Resolution: 1

Query

Range: 0 to 99

Resolution: 1

*RST Setting

1

Related Topics

 Configuring the Broadcast Channel (BCH)
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:CELL:MNCODE:SELECTED 45"
! Sets the cell's mobile network code to 45.

CALL[:CELL]:MNCode:GSM

Function

 GSM TA

Sets/queries the value of the Mobile Network Code (MNC) for the GSM format. This can only be set when the Cell Operating Mode parameter is set to Off (see CALL:OPERating:MODE ).
GSM/GPRS LA

EGPRS TA

GPRS TA

EGPRS LA

Setting

Range: 0 to 99

Resolution: 1

Query

Range: 0 to 99

Resolution: 1

*RST Setting

1

Related Topics

 Configuring the Broadcast Channel (BCH)

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:CELL:MNCODE:GSM 45"
! Sets the cell's mobile network code to 45.


CALL:MODulation

CALL:MODulation

GPIB Command Conventions

  • CALL:MODulation[:FORMat]:CONTrol:AUTO
  • CALL:MODulation[:FORMat]:MANual:BURSt[1]|2|3|4|5|6|7

CALL:MODulation[:FORMat]:CONTrol:AUTO

Function

GSM TA

 This command is not applicable to GSM.

GPRS TA

 This command is not applicable to GPRS.

GSM/GPRS LA

 This command is not applicable to the GSM/GPRS LA.

EGPRS TA

This command sets/queries the modulation format control state.

If set to On, the test set determines which modulation type to expect based on a combination of the current Cell Operating Mode, the current System Type, and the current Modulation Coding Scheme on the uplink. Coding Schemes MCS1 through 4 use GMSK modulation; MCS5 through 9 use 8PSK modulation.

If set to Off, the modulation format control is set to manual, allowing you to set each burst individually to expect either GMSK modulation or 8PSK modulation.

EGPRS LA

Setting

0 | OFF | 1 | ON

Query

 0 | 1

*RST Setting

 1 | ON
Requirements

GSM/GPRS/
EGPRS TA

Revision: A.03 and above

GSM/GPRS/
EGPRS LA

Revision: C.03 and above

CALL:MODulation[:FORMat]:MANual:BURSt[1]|2|3|4|5|6|7

Function

GSM TA

 This command is not applicable to GSM.

GPRS TA

 This command is not applicable to GPRS.

GSM/GPRS LA

 This command is not applicable to the GSM/GPRS LA.

EGPRS TA

This command sets/queries the modulation format manually for the burst you specify in the multislot configuration.

If you expect your mobile to transmit a GMSK (Gaussian Minimum Shift Keying) signal, you should set this command to GMSK. EGPRS modulation coding schemes MCS1 through MCS4 use a GMSK modulated signal.

If you expect your mobile to transmit an 8PSK (Eight Phase Shift Keying) signal, you should set this command to EPSK. EGPRS modulation coding schemes MCS5 through MCS9 use an 8PSK modulated signal.

If the modulation format is set to GMSK, but an 8PSK signal is applied the measurement discards all bursts until it locates a GMSK burst. The measurement does not complete until it locates a burst of the type it expects.

You must set the modulation format control state to manual before using this command. See CALL:MODulation[:FORMat]:CONTrol:AUTO .

Bursts 5 through 8 only apply when the operating mode is set to FastTune .

EGPRS LA

Setting

Range: GMSK | EPSK

Query

Range: GMSK | EPSK

*RST Setting

 GMSK
Requirements

GSM/GPRS/
EGPRS TA

Revision: A.03 and above

Revision A.04 adds bursts 3 through 7.

GSM/GPRS/
EGPRS LA

Revision: C.03 and above

Revision E.00.08 adds bursts 3 through 7.

Programming Example

OUTPUT 714;"CALL:MODulation:MANual:BURSt2 EPSK"
! Sets the manual modulation format for the second uplink burst to 8PSK.


CALL:MORiginated

CALL:MORiginated

GPIB Command Conventions

  • CALL:MORiginated:ALERting:DURation
  • CALL:MORiginated:CALL:RELease[:STATe]

CALL:MORiginated:ALERting:DURation

Function GSM TA

This command is not applicable to the GSM Test Applications.

GPRS TA

This command is not applicable to the GPRS Test Applications.

EGPRS TA

This command is not applicable to the EGPRS Test Applications.

GSM/GPRS LA

This command sets/queries the length of time that the test set holds a Mobile Originated voice call in the Alerting state before completing (or ending) the call connection. See Alerting Duration for more information.

EGPRS LA

Setting

Range: 0 to 600 (s)

Resolutin: 1

Query

Range: 0|600

Resolution: 1

*RST Setting

 0
Requirements GSM/GPRS/ EGPRS LA

Revision: G.00.00 and above

Programming Example

OUTPUT 714;"CALL:MORiginated:ALERting:DURation 0"
! The incoming Mobile Originated voice call will be connected immediately.

CALL:MORiginated:CALL:RELease[:STATe]

Function GSM TA

This command is not applicable to the GSM Test Applications.

GPRS TA

This command is not applicable to the GPRS Test Applications.

EGPRS TA

This command is not applicable to the EGPRS Test Applications.

GSM/GPRS LA

This command sets/queries whether an incoming Mobile Originated voice call is connected or released. See Call Release State for more information.

EGPRS LA

Setting

Range: 1|ON|0|OFF

Query

Range: 0|1

*RST Setting

 0|OFF
Requirements GSM/GPRS/ EGPRS LA

Revision: G.00.00 and above

Programming Example

OUTPUT 714;"CALL:MORiginated:CALL:RELease OFF"
! The incoming Mobiel Originated voice call will be connected.


CALL:MS

CALL:MS

GPIB Command Conventions

  • CALL[:CELL]:MS:CCHannel:POWer:OFFSet:DCS

  • CALL:MS:DTX[:STATe]

  • CALL:MS:DNSServer:PRIMary:IP:ADDRess
  • CALL:MS:DNSServer:SECondary:IP:ADDRess

  • CALL:MS:IP:ADDRess[1]|2|3|4
  • CALL:MS:IP:ADDRess[1]|2|3|4:CONText:PRIMary:QOService
  • CALL:MS:IP:ADDRess[1]|2|3|4:CONText:SECondary1|2|3:QOService
  • CALL:MS:IP:ADDRess[1]|2|3|4:ROUTing:STATe

  • CALL:MS:LQMMode

  • CALL:MS:PATTach[:STATe]

  • CALL:MS:REPorted:BEP:GMSK|EPSK:CVARiance[:AVERage]|MAXimum|MINimum?
  • CALL:MS:REPorted:BEP:GMSK|EPSK:MEAN[:AVERage]|MAXimum|MINimum)?
  • CALL:MS:REPorted:BEP:GMSK|EPSK:TSLOT<0|1|2|3|4|5|6|7>[:AVERage]|MAXimum|MINimum?

  • CALL:MS:REPorted:CLEar

  • CALL:MS:REPorted:CVALue:AVERage?

  • CALL:MS:REPorted:ILEVel:TSLot<n>:AVERage?

  • CALL:MS:REPorted:DTMClass:EGPRs[:SELected]?
  • CALL:MS:REPorted:DTMClass:GPRS[:SELected]?

  • CALL:MS:REPorted:IMEI?

  • CALL:MS:REPorted:IMSI?

  • CALL:MS:REPorted:LACode?

  • CALL:MS:REPorted:MCCode?

  • CALL:MS:REPorted:MCLass:EGPRS[:SELected]?
  • CALL:MS:REPorted:MCLass:GPRS[:SELected]?

  • CALL:MS:REPorted:MEASurement:NCONtrol:ENHanced:NCELl[:GSM][:LAST]?
  • CALL:MS:REPorted:MEASurement:NCONtrol:ENHanced:NCELl[:GSM]:NEW?
  • CALL:MS:REPorted:MEASurement:NCONtrol:ENHanced:NCELl:FDD[:LAST]?
  • CALL:MS:REPorted:MEASurement:NCONtrol:ENHanced:NCELl:FDD:NEW?
  • CALL:MS:REPorted:MEASurement:NCONtrol:ENHanced:NCELl:FDD:POINts[:LAST]?
  • CALL:MS:REPorted:MEASurement:NCONtrol:ENHanced:NCELl:FDD:POINts:NEW?
  • CALL:MS:REPorted:MEASurement:NCONtrol:ENHanced:NCELl[:GSM]:POINts[:LAST]?
  • CALL:MS:REPorted:MEASurement:NCONtrol:ENHanced:NCELl[:GSM]:POINts:NEW?

  • CALL:MS:REPorted:MEASurement:NCONtrol:ILEVel[:LAST]?
  • CALL:MS:REPorted:MEASurement:NCONtrol:ILEVel:NEW?

  • CALL:MS:REPorted:MEASurement:NCONtrol:NCELl<n>:FDD[:LAST]?
  • CALL:MS:REPorted:MEASurement:NCONtrol:NCELl<n>:FDD:NEW?
  • CALL:MS:REPorted:MEASurement:NCONtrol:NCELl<n>[:GSM][:LAST]?
  • CALL:MS:REPorted:MEASurement:NCONtrol:NCELl<n>[:GSM]:NEW?
  • CALL:MS:REPorted:MEASurement:NCONtrol:NCELl:NUMBer[:LAST]?
  • CALL:MS:REPorted:MEASurement:NCONtrol:NCELl:NUMBer:NEW?
  • CALL:MS:REPorted:MEASurement:NCONtrol:NCELl<n>:RATechnology[:LAST]?
  • CALL:MS:REPorted:MEASurement:NCONtrol:NCELl<n>:RATechnology:NEW?

  • CALL:MS:REPorted:MEASurement:NCONtrol:NCMode[:LAST]?
  • CALL:MS:REPorted:MEASurement:NCONtrol:NCMode:NEW?

  • CALL:MS:REPorted:MEASurement:NCONtrol:RXLevel[:LAST]?
  • CALL:MS:REPorted:MEASurement:NCONtrol:RXLevel:NEW?

  • CALL:MS:REPorted:MEASurement:NCONtrol:TYPE[:LAST]?
  • CALL:MS:REPorted:MEASurement:NCONtrol:TYPE:NEW?

  • CALL:MS:REPorted:MEASurement:(PACCH|PACChannel):BEP:GMSK|EPSK:CVARiance[:AVERage]|MAXimum|MINimum?
  • CALL:MS:REPorted:MEASurement:(PACCH|PACChannel):BEP:GMSK|EPSK:MEAN[:AVERage]|MAXimum|MINimum?
  • CALL:MS:REPorted:MEASurement:(PACCH|PACChannel):BEP:GMSK|EPSK:TSLot<0|1|2|3|4|5|6|7>[:AVERage]|MAXimum|MINimum?

  • CALL:MS:REPorted:MEASurement:(PACCH|PACChannel):CVALue:AVERage?

  • CALL:MS:REPorted:MEASurement:(PACCH|PACChannel):ILEVel:TSLot<n>:AVERage?

  • CALL:MS:REPorted:MEASurement:(PACCH|PACChannel):RXQuality:AVERage?

  • CALL:MS:REPorted:MEASurement:(PACCH|PACChannel):SVARiance:AVERage?

  • CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):COUNt
  • CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):COUNt:CLEar

  • CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):ENHanced:NCELl[:GSM][:LAST]?
  • CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):ENHanced:NCELl[:GSM]:NEW?
  • CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):ENHanced:NCELl:FDD[:LAST]?
  • CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):ENHanced:NCELl:FDD:NEW?
  • CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):ENHanced:NCELl:FDD:POINts[:LAST]?
  • CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):ENHanced:NCELl:FDD:POINts:NEW?
  • CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):ENHanced:NCELl[:GSM]:POINts[:LAST]?
  • CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):ENHanced:NCELl[:GSM]:POINts:NEW?

  • CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):NCELl<n>:FDD[:LAST]?
  • CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):NCELl<n>:FDD:NEW?
  • CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):NCELl<n>[:GSM][:LAST]?
  • CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):NCELl<n>[:GSM]:NEW?
  • CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):NCELl:NUMBer[:LAST]?
  • CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):NCELl:NUMBer:NEW?
  • CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):NCELl<n>:RATechnology[:LAST]?
  • CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):NCELl<n>:RATechnology:NEW?

  • CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):RXLevel:FULL[:LAST]?
  • CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):RXLevel:FULL:NEW?
  • CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):RXLevel:SUB[:LAST]?
  • CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):RXLevel:SUB:NEW?

  • CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):RXQuality:FULL[:LAST]?
  • CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):RXQuality:FULL:NEW?
  • CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):RXQuality:SUB[:LAST]?
  • CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):RXQuality:SUB:NEW?

  • CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):TADVance[:LAST]?
  • CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):TADVance:NEW?

  • CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):TXLevel[:LAST]?
  • CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):TXLevel:NEW?

  • CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):TYPE[:LAST]?
  • CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):TYPE:NEW?

  • CALL:MS:REPorted:MNCode?

  • CALL:MS:REPorted:NEIGhbour[1]?

  • CALL:MS:REPorted:ONUMber[:SELected]?
  • CALL:MS:REPorted:ONUMber:GSM?

  • CALL:MS:REPorted:PCLass[:SELected]?
  • CALL:MS:REPorted:PCLass:EPSK[:SELected]?
  • CALL:MS:REPorted:PCLass:GMSK[:SELected]?
  • CALL:MS:REPorted:PCLass:GSM?

  • CALL:MS:REPorted:REVision[:DIGital][:SELected]?
  • CALL:MS:REPorted:REVision[:DIGital]:GSM?

  • CALL:MS:REPorted:RXLevel[:LAST]?
  • CALL:MS:REPorted:RXLevel:NEW?

  • CALL:MS:REPorted:RXQuality:AVERage?
  • CALL:MS:REPorted:RXQuality[:LAST]?
  • CALL:MS:REPorted:RXQuality:NEW?

  • CALL:MS:REPorted:SBANd[:GMSK]?
  • CALL:MS:REPorted:SBANd:EPSK?

  • CALL:MS:REPorted:SVARiance:AVERage?

  • CALL:MS:REPorted:TADVance[:LAST]?
  • CALL:MS:REPorted:TADVance:NEW?

  • CALL:MS:REPorted:TXLevel[:LAST]?
  • CALL:MS:REPorted:TXLevel:NEW?

  • CALL:MS:TADVance[:SELected]
  • CALL:MS:TADVance:DCS
  • CALL:MS:TADVance:EGSM
  • CALL:MS:TADVance:GSM450
  • CALL:MS:TADVance:GSM480
  • CALL:MS:TADVance:GSM750
  • CALL:MS:TADVance:GSM850
  • CALL:MS:TADVance:PCS
  • CALL:MS:TADVance:PGSM
  • CALL:MS:TADVance:RGSM
  • CALL:MS:TADVance:TGSM810

  • CALL:MS:TX:BURSt:GPLength

  • CALL:MS:TX:FRAMe:SEGMentation

  • CALL:MS:TXLevel[:SELected]
  • CALL[:CELL]:MS:TXLevel:CCHannel[:SELected]

CALL[:CELL]:MS:CCHannel:POWer:OFFSet:DCS

Function

GSM TA

IT IS RECOMMENDED to use CALL[:CELL]:BCHannel:MS:POWer:OFFSet:DCS instead in order to fit more consistently with the new commands. This command remains valid to facilitate backwards compatibility.

This command defines an additional offset value that is used to increase the Max CCHannel value for DCS band only. See Access Burst Power Control . NOTE: CALL:MS:TXLevel:CCHannel:DCS must be set to 0 or this power offset command has no effect. Each unit parameter equates to an additional 2 dB power increase. The offset settings are:
"0" = 0 dB,
"1" = 2 dB,
"2" = 4 dB,
"3" = 6 dB.

This can only be set when the Cell Operating Mode parameter is set to Off (see CALL:OPERating:MODE ).

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Setting

Range: 0 | 1 | 2 | 3

Query

Range: 0 | 1 | 2 | 3

*RST Setting

 0
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:MS:TXLevel:CCHannel:DCS 0"
! Sets control channel transmit level to 0 to allow use of the following command.

OUTPUT 714;"CALL:MS:CCHannel:POWer:OFFSet:DCS 1"
! Adds 2 dB power increase to the control channel for the DCS band.

CALL:MS:DTX[:STATe]

Function

GSM TA

This command turns the mobile station Discontinuous Transmission (DTX) on or off. The query form returns a 1 (state = on) or a 0 (state = off). See Configuring Mobile Station Operating Parameters .

GSM/GPRS LA

EGPRS TA

This command is not applicable to GPRS/EGPRS.

GPRS TA

EGPRS LA

Setting

Range: 1 | ON | 0 | OFF

Query

Range: 0 | 1

*RST Setting

0 | OFF
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:MS:DTX OFF"
! Turns mobile station discontinuous transmission OFF.

CALL:MS:DNSServer:PRIMary:IP:ADDRess

Function

GSM TA

 This command is not applicable to the GSM test application.

GPRS TA

This command is not applicable to GPRS test application.

EGPRS TA

This command is not applicable to EGPRS test application.

GSM/GPRS LA

 Sets/queries the DNS Server IP Addresses

EGPRS LA

Setting

Range: 0 to 15 characters formatted as A.B.C.D
The range of values for A = 0 to 126 and 128 to 223. The range of values for B, C, and D = 0 to 255.

Query

 Same as setting.

*RST Setting

Non-volatile

Requirements

GSM/GPRS/ EGPRS LA

Revision: E.00.08 and above

Programming Example

OUTPUT 714;"CALL:MS:DNSServer:PRIMary:IP:ADDRess '130.255.255.255'"
! Sets the DUT Primary DNS Server IP Address to 130.255.255.255.

CALL:MS:DNSServer:SECondary:IP:ADDRess

Function

GSM TA

 This command is not applicable to the GSM test application.

GPRS TA

This command is not applicable to GPRS test application.

EGPRS TA

This command is not applicable to EGPRS test application.

GSM/GPRS LA

Sets/queries the DNS Server IP Addresses .

EGPRS LA

Setting

Range: 0 to 15 characters formatted as A.B.C.D
The range of values for A = 0 to 126 and 128 to 223. The range of values for B, C, and D = 0 to 255.

Query

 Same as setting.

*RST Setting

Non-volatile

Requirements

GSM/GPRS/ EGPRS LA

Revision: E.00.08 and above

Programming Example

OUTPUT 714;"CALL:MS:DNSServer:SECondary:IP:ADDRess '130.254.255.255'"
! Sets the DUT Primary DNS Server IP Address to 130.254.255.255.

CALL:MS:IP:ADDRess[1]|2|3|4

Function

GSM TA

 This command is not applicable to the GSM test application.

GPRS TA

This command is not applicable to GPRS test application.

EGPRS TA

This command is not applicable to EGPRS test application.

GSM/GPRS LA

This command sets/queries the mobile station's internet protocol (IP) address 1, 2, 3 or 4 respectively. The address is the IP v4 address written in dotted decimal format, for example 147.123.159.15. The entered address must be on the same subnet as the test set (but it cannot have an identical address). The subnet is defined through the combination of the test set's LAN IP address ( SYSTem:COMMunicate:LAN[:SELF]:ADDRess ) and its subnet mask ( SYSTem:COMMunicate:LAN[:SELF]:SMASk ). The IP address can not be the same as any other IP.

Values entered for this command are stored in non-volatile memory and will persist after the instrument is reset or power-cycled.

Any part of this address with leading zeros (for example, 145.156.063.12) will have the leading zeros removed. Most operating systems treat parts of IP addresses entered with leading zeros as octal numbers, the test set does not.

EGPRS LA

*RST Setting

none

Requirements

GSM/GPRS/ EGPRS LA

Revision: C.01 and above for IP address 1

E.00.12 and above for IP address 2, 3 and 4

Programming Example

OUTPUT 714;"CALL:MS:IP:ADDRESS `147.123.159.15'"
! Set IP address 1.

OUTPUT 714;"CALL:MS:IP:ADDRESS2 `147.123.159.16'"
! Set IP address 2.

CALL:MS:IP:ADDRess[1]|2|3|4:CONText:PRIMary:QOService

Function

GSM TA

 This command is not applicable to the GSM test application.

GPRS TA

This command is not applicable to GPRS test application.

EGPRS TA

This command is not applicable to EGPRS test application.

GSM/GPRS LA

This command sets/queries the QOS Profile associated with the Primary PDP Context of IP address 1, 2, 3 or 4 respectively.

EGPRS LA

Setting

Range: QOSProfile1 | QOSProfile2 | QOSProfile3 | QOSProfile4

Query

Range: QOSP1 | QOSP2 | QOSP3 | QOSP4

*RST Setting

 QOSP1

Requirements

GSM/GPRS/
EGPRS LA

Revision: C.01 and above for IP address 1

E.00.12 and above for IP address 2, 3 and 4

Programming Example

OUTPUT 714;"CALL:MS:IP:ADDRESS2:CONTEXT:PRIMARY:QOSERVICE QOSP2"
! Set the QOS Profile associated with IP address 2 to QOSP2.

CALL:MS:IP:ADDRess[1]|2|3|4:CONText:SECondary1|2|3:QOService

Function

GSM TA

 This command is not applicable to the GSM test application.

GPRS TA

This command is not applicable to GPRS test application.

EGPRS TA

This command is not applicable to EGPRS test application.

GSM/GPRS LA

This command sets/queries the QOS Profile associated with the Secondary PDP Context 1,2 or 3 for IP address 1, 2, 3 or 4 respectively.

EGPRS LA

Setting

Range: QOSProfile1 | QOSProfile2 | QOSProfile3 | QOSProfile4

Query

Range: QOSP1 | QOSP2 | QOSP3 | QOSP4

*RST Setting

 QOSP1

Requirements

GSM/GPRS/
EGPRS LA

Revision: F.00.37 and above

Programming Example

OUTPUT 714;"CALL:MS:IP:ADDRESS2:CONTEXT:SECondary1:QOSERVICE QOSP2"
! Set the QOS Profile associated with Secondary PDP Context 1 of IP address 2 to QOSP2.

CALL:MS:IP:ADDRess[1]|2|3|4:ROUTing:STATe

Function

GSM TA

 This command is not applicable to the GSM test application.

GPRS TA

This command is not applicable to GPRS test application.

EGPRS TA

This command is not applicable to EGPRS test application.

GSM/GPRS LA

This command enable or disable forwarding of subnet traffic to the DUT IP Address. See DUT Routing State for more information.

If the DUT IP Address is NULL, network route traffic can not be routed to the DUT regardless of the DUT Routing State setting. If the DUT IP Address is subsequently set to a valid entry, the user can not change the DUT Routing State setting. And the DUT Routing State is applied automatically and the network route traffic is passed through to the DUT.

This command can not be set to ON if an external 8960 is connected. If you tries to do this, the Operation rejected error message is displayed. Conversely, an extend 8960 can not be connected if this command is already set to ON. If you tries to do this, the Operation rejected error message is displayed.

EGPRS LA

Setting

Range:1 | ON | 0 | OFF

Query

Range: 0 | 1

*RST Setting

0 | OFF

Requirements

GSM/GPRS/
EGPRS LA

Revision: F.00.37 and above

Programming Example

OUTPUT 714;"CALL:MS:IP:ADDRESS2:ROUTing:STATe OFF"
! Set route IP address 2 to the DUT 2's state OFF.

CALL:MS:LQMMode

Function

GSM TA

 This command is not applicable to the GSM test application.

GPRS TA

This command is not applicable to GPRS test application.

EGPRS TA

This command is not applicable to EGPRS test application.

GSM/GPRS LA

 This command is not applicable to GSM/GPRS lab application.

EGPRS LA

 This command sets/queries the EGPRS link quality measurement mode. This setting is in the Control Channel Parameters menu. See How Do I Configure the Control Channel Parameters? for more information.

Setting

Range: 0 | 1 | 2 | 3
0 - No measurement reports
1 - Interference measurement reports for timeslots 0 through 7
2 - Bit Error Probability (BEP) measurement reports for allocated timeslots
3 - Interference measurement reports alternating between timeslots 0 through 3 and 4 through 7 and BEP reports for allocated timeslots.

Query

Range: 0 | 1 | 2 | 3

*RST Setting

3

Requirements

GSM/GPRS/
EGPRS LA

 Revision: C.03 and above

Programming Example

OUTPUT 714;"CALL:MS:LQMM 0"
! Sets the EGPRS link quality measurement mode value to 0.

CALL:MS:PATTach[:STATe]

Function

GSM TA

 This command is not applicable to the GSM TA.

GPRS TA

This command sets/queries the state of Persistent Attach. See Persistent Attach for details. The operating mode must be set to OFF prior to changing the Serving Cell from GPRS to EGPRS.

NOTE
When the Persistent Attach state is ON, your existing test code may need to be modified if it waits for the connection status to be IDLE before proceeding to the next test when switching between the operating modes Active Cell (serving cell GPRS) and Active Cell (serving cell EGPRS).

The command to set the operating mode is CALL:OPERating:MODE .

The command to set the serving cell is CALL[:CELL]:BCHannel:SCELl .

EGPRS TA
GSM/GPRS LA

EGPRS LA

Setting

Range: 1 | ON | 0 | OFF

Query

Range: 0 | 1

*RST Setting

0 | OFF
Requirements GSM/GPRS/
EGPRS TA

Revision: A.04 and above
GSM/GPRS/ EGPRS LA

Revision: D.01 and above

Programming Example

OUTPUT 714;"CALL:MS:PATTach ON"
! Turns Persistent Attach on.

CALL:MS:REPorted:BEP:GMSK|EPSK:CVARiance[:AVERage]|MAXimum|MINimum?

Function

GSM TA

 This command is not applicable to the GSM test application.

GPRS TA

This command is not applicable to the GPRS test application.

GSM/GPRS LA

This command is not applicable to GSM/GPRS lab application.
EGPRS TA

IT IS RECOMMENDED to use CALL:MS:REPorted:MEASurement:(PACCH|PACChannel):BEP:GMSK|EPSK:CVARiance[:AVERage]|MAXimum|MINimum? instead in order to fit more consistently with the new commands. This command remains valid to facilitate backwards compatibility.

This command queries the Coefficient of Variation of the Bit Error Probability (BEP). The average, maximum, or minimum Coefficient of Variation of the Bit Error Probability (BEP) can be found for the data blocks tested.

If average, maximum, or minimum is not specified in this command, the average Coefficient of Variation of the BEP is returned.

Refer to 3GPP TS 05.08 section 8.2.5 for information for a mapping table for the coefficient of variation of the channel quality.
EGPRS LA
Query

Range: 0 to 7 and 9.91E+37

Resolution: 1
*RST Setting 9.91E+37 (NAN)

Requirements

 GSM/GPRS/EGPRS TA

Revision: A.06 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:MS:REPORTED:BER:GMSK:CVARIANCE?"

CALL:MS:REPorted:BEP:GMSK|EPSK:MEAN[:AVERage]|MAXimum|MINimum)?

Function

GSM TA

 This command is not applicable to the GSM test application.

GPRS TA

This command is not applicable to the GPRS test application.

GSM/GPRS LA

This command is not applicable to GSM/GPRS lab application.
EGPRS TA

IT IS RECOMMENDED to use CALL:MS:REPorted:MEASurement:(PACCH|PACChannel):BEP:GMSK|EPSK:MEAN[:AVERage]|MAXimum|MINimum? instead in order to fit more consistently with the new commands. This command remains valid to facilitate backwards compatibility.

This command queries the Bit Error Probability (BEP). The average, maximum, or minimum BEP can be found for the data blocks tested.

If average, maximum, or minimum is not specified in this command, the average BEP is returned.

Refer to 3GPP TS 05.08 section 8.2.5 for information on mean BEP mapping and accuracy for GMSK.
EGPRS LA
Query

Range: 0 to 31 and 9.91E+37

Resolution: 1
*RST Setting 9.91E+37 (NAN)

Requirements

 EGPRS TA

Revision: A.06 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:MS:REPORTED:BEP:EPSK:MEAN:MAXIMUM?"

CALL:MS:REPorted:BEP:GMSK|EPSK:TSLOT<0|1|2|3|4|5|6|7>[:AVERage]|MAXimum|MINimum?

Function

GSM TA

 This command is not applicable to the GSM test application.

GPRS TA

This command is not applicable to the GPRS test application.

GSM/GPRS LA

This command is not applicable to GSM/GPRS lab application.
EGPRS TA

IT IS RECOMMENDED to use CALL:MS:REPorted:MEASurement:(PACCH|PACChannel):BEP:GMSK|EPSK:TSLot<0|1|2|3|4|5|6|7>[:AVERage]|MAXimum|MINimum? instead in order to fit more consistently with the new commands. This command remains valid to facilitate backwards compatibility.

This command queries the Bit Error Probability (BEP) for the specified timeslot. The average, maximum, or minimum BEP can be found for the specified timeslot of the data blocks tested.

If average, maximum, or minimum is not specified in this command, the average BEP for the specified timeslot is returned.
EGPRS LA
Query Range: 0 to 63 and 9.91E+37

0: (< -110 dBm)
1: (-110 dBm to -109 dBm)
2: (-109 dBm to -108 dBm)
3: (-108 dBm to -107 dBm)
...
62: (-49 dBm to -48 dBm)
63: (>-48 dBm)

Resolution: 1
*RST Setting 9.91E+37 (NAN)

Requirements

 EGPRS TA

Revision: A.06 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:MS:REPORTED:BEP:GMSK:TSLOT?"

CALL:MS:REPorted:CLEar

Function

GSM TA

 This command clears the mobile station SAACH reported items. The values of the four mobile reported items - that is, Timing Adv, Tx Level, Rx Level and Rx Qual - are set to 9.91E+37 (NAN).

GSM/GPRS LA
EGPRS LA

GPRS TA

This command is not applicable to the GPRS test application.

EGPRS TA

This command is not applicable to EGPRS test application.

Requirements

 GSM/GPRS/ EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:MS:REPORTED:CLEAR"

CALL:MS:REPorted:CVALue:AVERage?

Function | GSM TA | This command is not applicable to the GSM Test Application.

GPRS TA

This command is not applicable to the GPRS Test Application.

EGPRS TA

This command is not applicable to EGPRS Test application.
GSM/GPRS LA

IT IS RECOMMENDED to use CALL:MS:REPorted:MEASurement:(PACCH|PACChannel):CVALue:AVERage? instead in order to fit more consistently with the new commands. This command remains valid to facilitate backwards compatibility.

Queries the C value reported by the MS.
EGPRS LA
Query Range: 0 to 63 and 9.91E+37

0: (< -110 dBm)
1: (-110 dBm to -109 dBm)
2: (-109 dBm to -108 dBm)
3: (-108 dBm to -107 dBm)
...
62: (-49 dBm to -48 dBm)
63: (>-48 dBm)

Resolution: 1
*RST Setting | 9.91E+37 (NAN)
Requirements

GSM/GPRS/
EGPRS LA

 Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:MS:REPorted:CVALue:AVERage?"

CALL:MS:REPorted:ILEVel:TSLot<n>:AVERage?

Function

GSM TA

 This command is not applicable to the GSM Test Application.

GPRS TA

This command is not applicable to the GPRS Test Application.

EGPRS TA

This command is not applicable to EGPRS Test application.
GSM/GPRS LA

IT IS RECOMMENDED to use CALL:MS:REPorted:MEASurement:(PACCH|PACChannel):ILEVel:TSLot<n>:AVERage? instead in order to fit more consistently with the new commands. This command remains valid to facilitate backwards compatibility.

Queries the interference level value reported by the MS for timeslot <n> (n can be 0 to 7).
EGPRS LA

Query

 Range: 0 to 15 and 9.91E37
Resolution: 1

0: (Interference level > C)
1: (C >= Interference level > C- 2 dB)
2: (C - 2 dB >= Interference level > C - 4 dB)
3: (C - 4 dB >= Interference level > C - 6 dB)
4: (C - 6 dB >= Interference level > C - 8 dB)
5: (C - 8 dB >= Interference level > C - 10 dB)
6: (C - 10 dB >= Interference level > C - 12 dB)
7: (C - 12 dB >= Interference level > C - 14 dB)
8: (C - 14 dB >= Interference level > C - 16 dB)
9: (C - 16 dB >= Interference level > C - 18 dB)
10: (C - 18 dB >= Interference level > C - 20 dB)
11: (C - 20 dB >= Interference level > C - 22 dB)
12: (C - 22 dB >= Interference level > C - 24 dB)
13: (C - 24 dB >= Interference level > C - 26 dB)
14: (C - 26 dB >= Interference level > C - 28 dB)
15: (Interference level <= C)
*RST Setting 9.91E+37 (NAN)
Requirements

GSM/GPRS/
EGPRS LA

 Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:MS:REPorted:ILEVel:TSLot5:AVERage?"
! Queries the interference level value reported by the MS for timeslot 5.

CALL:MS:REPorted:DTMClass:EGPRs[:SELected]?

CALL:MS:REPorted:DTMClass:EGPRS:(DCS |EGSM |GSM450 |GSM480 |GSM750 |GSM850 |PCS |PGSM |RGSM|TGSM810)?

Function

GSM

 This command is not applicable to the GSM Test Application.

GPRS TA

This command is not applicable to the GPRS Test Application.

EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

Refer to Supported DTM Multislot Classes for a table of all the supported GPRS/EGPRS DTM Multislot Classes.

This command queries two parameters previously reported from the mobile station.

  •
 The value that represents the supported EGPRS Dual Transfer Mode multislot class.
    •

  •

The values indicates if half rate operation is supported within the Dual Transfer Mode class. A returned value of 1 indicates that the mobile station supports half rate operation in Dual Transfer Mode. A returned value of 0 indicates the mobile station does not support half rate operation in Dual Transfer Mode.
    •

NAN indicates that no Dual Transfer Mode class information has been supplied by the mobile station. When no Dual Transfer Mode information has been supplied by the mobile station, this query returns a 0 for the half rate operation parameter.

If no cell band is specified, the results for this command are returned for the cell band that is currently selected on the test set. If a cell band is specified, the results for this command are the most recent values for the specified cell band.

EGPRS LA

Query

Range: 1-12 or 9.91E+37 (NAN), 0|1 or 9.91E+37 (NAN)

Resolution: 1

*RST Setting

9.91E+37 (NAN), 0

Requirements

GSM/GPRS/

EGPRS LA

Revision: E.00.05 and above

Programming Example 1

OUTPUT 714;"CALL:MS:REPorted:DTMClass:EGPRs?"
! Queries which EGPRS Multislot Class the mobile station supports for the currently selected
! cell band, as well as if it supports half rate operation.

Programming Example 2

OUTPUT 714;"CALL:MS:REPorted:DTMClass:EGPRs:PCS?"
! Queries which EGPRS Multislot Class the mobile station supports for the PCS cell band,
! as well as if it supports half rate operation.

CALL:MS:REPorted:DTMClass:GPRS[:SELected]?

CALL:MS:REPorted:DTMClass:GPRS:(DCS|EGSM|GSM450|GSM480|GSM750|GSM850|PCS|PGSM|RGSM|TGSM810)?

Function

GSM

This command is not applicable to the GSM Test Application.

GPRS TA

This command is not applicable to the GPRS Test Application.

EGPRS TA

This command is not applicable to the EGPRS Test Application.

GSM/GPRS LA

Refer to
Supported DTM Multislot Classes
 for a table of all the supported GPRS/EGPRS DTM Multislot Classes.

This command queries two parameters from the mobile station.

1) The value that represents the supported GPRS Dual Transfer Mode multislot class.

2) The value reported that indicates if half rate operation is supported within the Dual Transfer Mode class.

If no cell band is specified, the results for this command are returned for the cell band that is currently selected on the test set. If a cell band is specified, the results for this command are the most recent values for the specified cell band.

EGPRS LA

This command is not applicable to the EGPRS Lab Application.

Query

Range: 1-12 or NAN, 0|1

Resolution: 1

*RST Setting

9.91E+37 (NAN), 0

(NAN indicates that no Dual Transfer Mode class information has been supplied by the mobile station. When no Dual Transfer Mode information has been supplied by the mobile station, this query returns a 0 for the half rate operation parameter.)

Requirements

GSM/GPRS/

EGPRS LA

Revision: E.00.05 and above

Programming Example 1

OUTPUT 714;"CALL:MS:REPorted:DTMClass:GPRS?"
! Queries which GPRS Multislot Class the mobile station supports for the currently
! selected cell band,as well as if it supports half rate operation.

Programming Example 2

OUTPUT 714;"CALL:MS:REPorted:DTMClass:GPRS:PCS?"
! Queries which GPRS Multislot Class the mobile station supports for the PCS cell band,
! as well as if it supports half rate operation.

CALL:MS:REPorted:IMEI?

Function

GSM TA

This command queries the International Mobile Equipment Identity of the ME. An ME is a mobile station without a SIM.

This parameter is reported if the IMEI:AUTO state is ON, see
CALL:IMEI
 or the mobile station has no SIM.

NOTE

The test set always displays a zero for the 15th digit of the IMEI. This behavior conforms to 3GPP TS 03.03, which requires that the 15th digit (referred to as Spare digit or Check Digit) "shall be zero, when transmitted by the MS", and 3GPP TS 02.16 which states that the "check digit is not part of the digits transmitted at IMEI check equations".

GSM/GPRS LA

EGPRS LA

GPRS TA

This command is not applicable to the GPRS TA

EGPRS TA

This command is not applicable to EGPRS test application.

Query

Range: up to 15 decimal digits and ""

Resolution: 1

*RST Setting

"" (null string)

Requirements

GSM/GPRS/

EGPRS TA

Revision: A.01 and above

GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:MS:REPORTED:IMEI?"

CALL:MS:REPorted:IMSI?

Function

GSM TA

This command queries the International Mobile Subscriber Identity of the SIM in the mobile station.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Range: up to 15 decimal digits and ""

Resolution: 1

*RST Setting

"" (null string)

Requirements

GSM/GPRS/

EGPRS TA

Revision: A.01 and above

GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:MS:REPORTED:IMSI?"

CALL:MS:REPorted:LACode?

Function

GSM TA

This command queries the last Location Area Code the mobile station was camped on.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Setting

Range: `0' to `65535' and ""

Query

Range: 0 to 65535

Resolution: 1

*RST Setting

""(null string)

Requirements

GSM/GPRS/

EGPRS TA

Revision: A.01 and above

GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:MS:REPORTED:LACODE?"

CALL:MS:REPorted:MCCode?

Function

GSM TA

This command queries the last Mobile Country Code the mobile station was camped on.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Range: `0' to `999' and ""(null string)

*RST Setting

""(null string)

Requirements

GSM/GPRS/

EGPRS TA

Revision: A.01 and above

GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:MS:REPORTED:MCCODE?"

CALL:MS:REPorted:MCLass:EGPRS[:SELected]?

CALL:MS:REPorted:MCLass:EGPRS:(DCS|EGSM|GSM450|GSM480|GSM750|GSM850|PCS|PGSM|RGSM|TGSM810)?

Function

GSM TA

This command is not applicable to the GSM Test Application.

GPRS TA

This command queries the last EGPRS multislot class for the specified band as reported by the mobile during its attach procedure. The band used is the PDTCH traffic band as determined by CALL:PDTCH:BAND.

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Range: 1 to 29 and 9.91E+37 (means the multislot class is not applicable for the band)

Resolution: 1

*RST Setting

9.91E+37 (NAN)

Requirements

GSM/GPRS/

EGPRS TA

Revision: A.01 and above

A.06 adds the TGSM810 band.

GSM/GPRS/ EGPRS LA

Revision: C.01 and above

D.03 adds the TGSM810 band.

Programming Example

OUTPUT 714;"CALL:MS:REPORTED:MCLass:EGPRS?"

CALL:MS:REPorted:MCLass:GPRS[:SELected]?

CALL:MS:REPorted:MCLass:GPRS:(DCS|EGSM|GSM450|GSM480|GSM750|GSM850|PCS|PGSM|RGSM|TGSM810)?

Function

GSM TA

This command is not applicable to the GSM Test Application.

GPRS TA

This command queries the last GPRS multislot class for the specified band as reported by the mobile during its attach procedure. The band used is the PDTCH traffic band as determined by CALL:PDTCH:BAND.

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Range: 1 to 29 and 9.91E+37 (means the multislot class is not applicable for the band)

Resolution: 1

*RST Setting

9.91E+37 (NAN)

Requirements

GSM/GPRS/

EGPRS TA

Revision: A.01 and above

GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:MS:REPORTED:MCLass:GPRS?"

CALL:MS:REPorted:MEASurement:NCONtrol:ENHanced:NCELl[:GSM][:LAST]?

Function

GSM TA

This command is not applicable to the GSM test application.

GPRS TA
 |
This command is not applicable to the GPRS test application.

EGPRS TA
 |
This command is not applicable to the EGPRS test application.

GSM/GPRS LA

This command queries the last (most recent) MS reported measurements for all GSM cells in the Enhanced
Network Control Measurement Reports
. For more information, see
Network Control :NEW? and [:LAST]? Queries
.

The information is returned as groups of 4 numeric values separated by commas in the following order: RX LEVEL, ARFCN, BCC, NCC. The total number of comma separated values returned is determined by
CALL:MS:REPorted:MEASurement:NCONtrol:ENHanced:NCELl[:GSM]:POINts[:LAST]?
.

This command is used for enhanced measurement reports only. See
Enhanced Network Control Neighbour Reports Screen
.

EGPRS LA

Query

RX Level

  •
Range: 0 to 63
    •

  •

Resolution: 1
    •

ARFCN

  •
Range: 1 to 1023 and 9.91E+37
    •

  •

Resolution: 1
    •

BCC

  •
Range: 0 to 7
    •

  •

Resolution: 1
    •

NCC

  •
Range: 0 to 7
    •

  •

Resolution: 1
    •

*RST Setting

9.91E+37,9.91E+37,9.91E+37,9.91E+37

Requirements

GSM/GPRS/ EGPRS LA

Revision: E.00.12 and above

Programming Example

OUTPUT 714;"CALL:MS:REPorted:MEASurement:NCONtrol:ENHanced:NCELl?"
! Returns the last MS reported RX LEVEL,ARFCN,BCC,NCC for all GSM cells
! in the enhanced network control measurement report.

CALL:MS:REPorted:MEASurement:NCONtrol:ENHanced:NCELl[:GSM]:NEW?

Function

GSM TA

This command is not applicable to the GSM test application.

GPRS TA
 |
This command is not applicable to the GPRS test application.

EGPRS TA
 |
This command is not applicable to the EGPRS test application.

GSM/GPRS LA

This command queries the next MS reported measurements for all GSM cells in the Enhanced
Network Control Measurement Reports
. For more information, see
Network Control :NEW? and [:LAST]? Queries
.

The information is returned as groups of 4 numeric values separated by commas in the following order: RX LEVEL, ARFCN, BCC, NCC. The total number of comma separated values returned is determined by
CALL:MS:REPorted:MEASurement:NCONtrol:ENHanced:NCELl[:GSM]:POINts:NEW?
.

This command is used for enhanced measurement reports only. See
Enhanced Network Control Neighbour Reports Screen
.

EGPRS LA

Query

RX Level

  •
Range: 0 to 63
    •

  •

Resolution: 1
    •

ARFCN

  •
Range: 1 to 1023 and 9.91E+37
    •

  •

Resolution: 1
    •

BCC

  •
Range: 0 to 7
    •

  •

Resolution: 1
    •

NCC

  •
Range: 0 to 7
    •

  •

Resolution: 1
    •

*RST Setting

9.91E+37,9.91E+37,9.91E+37,9.91E+37

Requirements

GSM/GPRS/ EGPRS LA

Revision: E.00.12 and above

Programming Example

OUTPUT 714;"CALL:MS:REPorted:MEASurement:NCONtrol:ENHanced:NCELl:NEW?"
! Returns the next MS reported RX LEVEL,ARFCN,BCC,NCC for all GSM cells
! in the enhanced network control measurement report.

CALL:MS:REPorted:MEASurement:NCONtrol:ENHanced:NCELl:FDD[:LAST]?

Function

GSM TA

This command is not applicable to the GSM test application.

GPRS TA
 |
This command is not applicable to the GPRS test application.

EGPRS TA
 |
This command is not applicable to the EGPRS test application.

GSM/GPRS LA

This command queries the last (most recent) MS reported measurements for all FDD cells in the Enhanced
Network Control Measurement Reports
. For more information, see
Network Control :NEW? and [:LAST]? Queries
.

The information is returned as groups of 3 numeric values separated by commas in the following order: Reporting Quantity, UARFCN, Scrambling Code. The total number of comma separated values returned is determined by
CALL:MS:REPorted:MEASurement:NCONtrol:ENHanced:NCELl:FDD:POINts[:LAST]?
.

This command is used for enhanced measurement reports only. See
Enhanced Network Control Neighbour Reports Screen
.

EGPRS LA

Query

Reporting Quantity

  •
Range: 0 to 63
    •

  •

Resolution: 1
    •

UARFCN

  •
Range: 1 to 16383 and 9.91E+37
    •

  •

Resolution: 1
    •

Scrambling Code

  •
Range: 0 to 511
    •

  •

Resolution: 1
    •

*RST Setting

9.91E+37,9.91E+37,9.91E+37

Requirements

GSM/GPRS/ EGPRS LA

Revision: E.00.12 and above

Programming Example

OUTPUT 714;"CALL:MS:REPorted:MEASurement:NCONtrol:ENHanced:NCELl:FDD?"
! Returns the last MS reported Reporting Quantity, UARFCN, Scrambling Code for all FDD cells
! in the enhanced network control measurement report.

CALL:MS:REPorted:MEASurement:NCONtrol:ENHanced:NCELl:FDD:NEW?

Function

GSM TA

This command is not applicable to the GSM test application.

GPRS TA
 |
This command is not applicable to the GPRS test application.

EGPRS TA
 |
This command is not applicable to the EGPRS test application.

GSM/GPRS LA

This command queries the next MS reported measurements for all FDD cells in the Enhanced
Network Control Measurement Reports
. For more information, see
Network Control :NEW? and [:LAST]? Queries
.

The information is returned as groups of 3 numeric values separated by commas in the following order: Reporting Quantity, UARFCN, Scrambling Code. The total number of comma separated values returned is determined by
CALL:MS:REPorted:MEASurement:NCONtrol:ENHanced:NCELl:FDD:POINts:NEW?
.

This command is used for enhanced measurement reports only. See
Enhanced Network Control Neighbour Reports Screen
.

EGPRS LA

Query

Reporting Quantity

  •
Range: 0 to 63
    •

  •

Resolution: 1
    •

UARFCN

  •
Range: 1 to 16383 and 9.91E+37
    •

  •

Resolution: 1
    •

Scrambling Code

  •
Range: 0 to 511
    •

  •

Resolution: 1
    •

*RST Setting

9.91E+37,9.91E+37 ,9.91E+37

Requirements

GSM/GPRS/ EGPRS LA

Revision: E.00.12 and above

Programming Example

OUTPUT 714;"CALL:MS:REPorted:MEASurement:NCONtrol:ENHanced:NCELl:FDD:NEW?"
! Returns the next MS reported Reporting Quantity, UARFCN, Scrambling Code for all FDD cells
! in the enhanced network control measurement report.

CALL:MS:REPorted:MEASurement:NCONtrol:ENHanced:NCELl:FDD:POINts[:LAST]?

Function

GSM TA

This command is not applicable to the GSM test application.

GPRS TA
 |
This command is not applicable to the GPRS test application.

EGPRS TA
 |
This command is not applicable to the EGPRS test application.

GSM/GPRS LA

This command queries the number of comma seperated values returned by the related
CALL:MS:REPorted:MEASurement:NCONtrol:ENHanced:NCELl:FDD[:LAST]?
 command.

This command is used for enhanced measurement reports only. See
Enhanced Network Control Neighbour Reports Screen
.

EGPRS LA

Query

Range: 0 to 13

Resolution: 1

*RST Setting

0

Requirements

GSM/GPRS/ EGPRS LA

Revision: E.00.12 and above

Programming Example

OUTPUT 714;"CALL:MS:REPorted:MEASurement:NCONtrol:ENHanced:NCELl:FDD:POINts?"
! Returns the number of comma seperated values returned by the related
! CALL:MS:REPorted:MEASurement:NCONtrol:ENHanced:NCELl:FDD[:LAST]? query.

CALL:MS:REPorted:MEASurement:NCONtrol:ENHanced:NCELl:FDD:POINts:NEW?

Function

GSM TA

This command is not applicable to the GSM test application.

GPRS TA
 |
This command is not applicable to the GPRS test application.

EGPRS TA
 |
This command is not applicable to the EGPRS test application.

GSM/GPRS LA

This command queries the number of comma seperated values returned by the related
CALL:MS:REPorted:MEASurement:NCONtrol:ENHanced:NCELl:FDD:NEW?
 command.

This command is used for enhanced measurement reports only. See
Enhanced Network Control Neighbour Reports Screen
.

EGPRS LA

Query

Range: 0 to 13

Resolution: 1

*RST Setting

0

Requirements

GSM/GPRS/ EGPRS LA

Revision: E.00.12 and above

Programming Example

OUTPUT 714;"CALL:MS:REPorted:MEASurement:NCONtrol:ENHanced:NCELl:FDD:POINts:NEW?"
! Returns the number of comma seperated values returned by the related
! CALL:MS:REPorted:MEASurement:NCONtrol:ENHanced:NCELl:FDD:NEW? query.

CALL:MS:REPorted:MEASurement:NCONtrol:ENHanced:NCELl[:GSM]:POINts[:LAST]?

Function

GSM TA

This command is not applicable to the GSM test application.

GPRS TA
 |
This command is not applicable to the GPRS test application.

EGPRS TA
 |
This command is not applicable to the EGPRS test application.

GSM/GPRS LA

This command queries the number of comma seperated values returned by the related
CALL:MS:REPorted:MEASurement:NCONtrol:ENHanced:NCELl[:GSM][:LAST]?
 command.

This command is used for enhanced measurement reports only. See
Enhanced Network Control Neighbour Reports Screen
.

EGPRS LA

Query

Range: 0 to 16

Resolution: 1

*RST Setting

0

Requirements

GSM/GPRS/ EGPRS LA

Revision: E.00.12 and above

Programming Example

OUTPUT 714;"CALL:MS:REPorted:MEASurement:NCONtrol:ENHanced:NCELl:POINts?"
! Returns the number of comma seperated values returned by the related
! CALL:MS:REPorted:MEASurement:NCONtrol:ENHanced:NCELl[:GSM][:LAST]? query.

CALL:MS:REPorted:MEASurement:NCONtrol:ENHanced:NCELl[:GSM]:POINts:NEW?

Function

GSM TA

This command is not applicable to the GSM test application.

GPRS TA
 |
This command is not applicable to the GPRS test application.

EGPRS TA
 |
This command is not applicable to the EGPRS test application.

GSM/GPRS LA

This command queries the number of comma seperated values returned by the related
CALL:MS:REPorted:MEASurement:NCONtrol:ENHanced:NCELl[:GSM]:NEW?
 command.

This command is used for enhanced measurement reports only. See
Enhanced Network Control Neighbour Reports Screen
.

EGPRS LA

Query

Range: 0 to 16

Resolution: 1

*RST Setting

0

Requirements

GSM/GPRS/ EGPRS LA

Revision: E.00.12 and above

Programming Example

OUTPUT 714;"CALL:MS:REPorted:MEASurement:NCONtrol:ENHanced:NCELl:POINts:NEW?"
! Returns the number of comma seperated values returned by the related
! CALL:MS:REPorted:MEASurement:NCONtrol:ENHanced:NCELl[:GSM]:NEW? query.

CALL:MS:REPorted:MEASurement:NCONtrol:NCELl<n>:FDD[:LAST]?

Function

GSM TA

This command queries the last (most recent) MS reported measurements for FDD neighbour cell <n> in the normal
Network Control Measurement Reports
, where <n> is any integer 1 through 6. The information is returned as 3 numeric values separated by commas in the following order: Reporting Quantity, UARFCN, Scrambling Code.For more information, see
Network Control :NEW? and [:LAST]? Queries
.

This command is used for normal measurement reports only. See
General Network Control Measurement Reports Screen
.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Reporting Quantity

  •
Range: 0 to 63
    •

  •

Resolution: 1
    •

UARFCN

  •
Range: 1 to 16383 and 9.91E+37
    •

  •

Resolution: 1
    •

Scrambling Code

  •
Range: 0 to 511
    •

  •

Resolution: 1
    •

*RST Setting

9.91E+37,9.91E+37 ,9.91E+37

Requirements

GSM/GPRS/ EGPRS TA

Revision: A.07 and above

GSM/GPRS/ EGPRS LA

Revision: E.00.12 and above

Programming Example

OUTPUT 714;"CALL:MS:REPorted:MEASurement:NCONtrol:NCELl1:FDD?"
! Returns the last MS reported network control measurements of the Reporting Quantity,
! UARFCN, Scrambling Code for FDD neighbour cell 1.

CALL:MS:REPorted:MEASurement:NCONtrol:NCELl<n>:FDD:NEW?

Function

GSM TA

This command queries the next MS reported measurements for FDD neighbour cell <n> in the normal
Network Control Measurement Reports
, where <n> is any integer 1 through 6. The information is returned as 3 numeric values separated by commas in the following order: Reporting Quantity, UARFCN, Scrambling Code.For more information, see
Network Control :NEW? and [:LAST]? Queries
.

This command is used for normal measurement reports only. See
General Network Control Measurement Reports Screen
.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Reporting Quantity

  •
Range: 0 to 63
    •

  •

Resolution: 1
    •

UARFCN

  •
Range: 1 to 16383 and 9.91E+37
    •

  •

Resolution: 1
    •

Scrambling Code

  •
Range: 0 to 511
    •

  •

Resolution: 1
    •

*RST Setting

9.91E+37,9.91E+37 ,9.91E+37

Requirements

GSM/GPRS/ EGPRS TA

Revision: A.07 and above

GSM/GPRS/ EGPRS LA

Revision: E.00.12 and above

Programming Example

OUTPUT 714;"CALL:MS:REPorted:MEASurement:NCONtrol:NCELl1:NEW?"
! Returns the next MS reported network control measurements of the Reporting Quantity,
! UARFCN, Scrambling Code for FDD neighbour cell 1.

CALL:MS:REPorted:MEASurement:NCONtrol:ILEVel[:LAST]?

Function

GSM TA

Queries the interference level value last reported by the MS for the current timeslot.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Range: 0 to 15 and 9.91E37

Resolution: 1

0: (Interference level > C)

1: (C >= Interference level > C- 2 dB)

2: (C - 2 dB >= Interference level > C - 4 dB)

3: (C - 4 dB >= Interference level > C - 6 dB)

4: (C - 6 dB >= Interference level > C - 8 dB)

5: (C - 8 dB >= Interference level > C - 10 dB)

6: (C - 10 dB >= Interference level > C - 12 dB)

7: (C - 12 dB >= Interference level > C - 14 dB)

8: (C - 14 dB >= Interference level > C - 16 dB)

9: (C - 16 dB >= Interference level > C - 18 dB)

10: (C - 18 dB >= Interference level > C - 20 dB)

11: (C - 20 dB >= Interference level > C - 22 dB)

12: (C - 22 dB >= Interference level > C - 24 dB)

13: (C - 24 dB >= Interference level > C - 26 dB)

14: (C - 26 dB >= Interference level > C - 28 dB)

15: (Interference level <= C)

*RST Setting

9.91E+37 (NAN)

Requirements

GSM/GPRS/ EGPRS TA

Revision: A.07 and above

GSM/GPRS/ EGPRS LA

Revision: E.00.08 and above

Programming Example

OUTPUT 714;"CALL:MS:REPorted:MEASurement:NCONtrol:ILEVel?"
! Queries the interference level value last reported by the MS for the current timeslot.

CALL:MS:REPorted:MEASurement:NCONtrol:ILEVel:NEW?

Function

GSM TA

Queries the next interference level value reported by the MS for the current timeslot.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Range: 0 to 15 and 9.91E37

Resolution: 1

0: (Interference level > C)

1: (C >= Interference level > C- 2 dB)

2: (C - 2 dB >= Interference level > C - 4 dB)

3: (C - 4 dB >= Interference level > C - 6 dB)

4: (C - 6 dB >= Interference level > C - 8 dB)

5: (C - 8 dB >= Interference level > C - 10 dB)

6: (C - 10 dB >= Interference level > C - 12 dB)

7: (C - 12 dB >= Interference level > C - 14 dB)

8: (C - 14 dB >= Interference level > C - 16 dB)

9: (C - 16 dB >= Interference level > C - 18 dB)

10: (C - 18 dB >= Interference level > C - 20 dB)

11: (C - 20 dB >= Interference level > C - 22 dB)

12: (C - 22 dB >= Interference level > C - 24 dB)

13: (C - 24 dB >= Interference level > C - 26 dB)

14: (C - 26 dB >= Interference level > C - 28 dB)

15: (Interference level <= C)

*RST Setting

9.91E+37 (NAN)

Requirements

GSM/GPRS/ EGPRS TA

Revision: A.07 and above

GSM/GPRS/ EGPRS LA

Revision: E.00.08 and above

Programming Example

OUTPUT 714;"CALL:MS:REPorted:MEASurement:NCONtrol:ILEVel:NEW?"
! Queries the next interference level value reported by the MS for the current timeslot.

CALL:MS:REPorted:MEASurement:NCONtrol:NCELl<n>[:GSM][:LAST]?

Function

GSM TA

This command queries the last (most recent) MS reported measurements for GSM neighbour cell <n>, where <n> is any integer 1 through 9. The information is returned as 4 numeric values separated by commas in the following order: RX LEVEL, ARFCN, BCC, NCC. For more information, see
Network Control :NEW? and [:LAST]? Queries
. See also,
Network Control Measurement Reports
.

This command is used for normal measurement reports only. See
General Network Control Measurement Reports Screen
.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Range: 1 to 1023 and 9.91E+37

Resolution: 1

*RST Setting

9.91E+37 (NAN)

Requirements

GSM/GPRS/ EGPRS TA

Revision: A.07 and above

GSM/GPRS/ EGPRS LA

Revision: E.00.08 and above

Programming Example

OUTPUT 714;"CALL:MS:REPorted:MEASurement:NCONtrol:NCELl1?"
! Returns the last MS reported measurements of the RFLEVEL,ARFCN,BCC,NCC for GSM neighbour cell 1.

CALL:MS:REPorted:MEASurement:NCONtrol:NCELl<n>[:GSM]:NEW?

Function

GSM TA

This command queries the next MS reported measurements for GSM neighbour cell <n>, where <n> is any integer 1 through 9. The information is returned as 4 numeric values separated by commas for neighbour cell one in the following order: RFLEVEL, ARFCN, BCC, NCC. For more information, see
Network Control :NEW? and [:LAST]? Queries
. See also,
Network Control Measurement Reports
.

This command is used for normal measurement reports only. See
General Network Control Measurement Reports Screen
.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Range: 1 to 1023 and 9.91E+37

Resolution: 1

*RST Setting

9.91E+37 (NAN)

Requirements

GSM/GPRS/ EGPRS TA

Revision: A.07 and above

GSM/GPRS/ EGPRS LA

Revision: E.00.08 and above

Programming Example

OUTPUT 714;"CALL:MS:REPorted:MEASurement:NCONtrol:NCELl1:NEW?"
! Returns the next MS reported RFLEVEL,ARFCN,BCC,NCC for GSM neighbour cell 1.

CALL:MS:REPorted:MEASurement:NCONtrol:NCELl:NUMBer[:LAST]?

Function

GSM TA

This command queries the number of neighbour cells reported in the last
Network Control Measurement Reports
. See also,
Network Control :NEW? and [:LAST]? Queries
.

This command is used for normal measurement reports only. See
General Network Control Measurement Reports Screen
.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Range: 1 to 9

Resolution: 1

*RST Setting

NAN

Requirements

GSM/GPRS/ EGPRS TA

Revision: A.07 and above

GSM/GPRS/ EGPRS LA

Revision: E.00.08 and above

Programming Example

OUTPUT 714;"CALL:MS:REPorted:MEASurement:NCONtrol:NCELl:NUMBer?"
! Returns the last MS reported number neighbour cells.

CALL:MS:REPorted:MEASurement:NCONtrol:NCELl:NUMBer:NEW?

Function

GSM TA

This command queries the number of neighbour cells reported in the next
Network Control Measurement Reports
. See also,
Network Control :NEW? and [:LAST]? Queries
.

This command is used for normal measurement reports only. See
General Network Control Measurement Reports Screen
.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Range: 1 to 9

Resolution: 1

*RST Setting

NAN

Requirements

GSM/GPRS/ EGPRS TA

Revision: A.07 and above

GSM/GPRS/ EGPRS LA

Revision: E.00.08 and above

Programming Example

OUTPUT 714;"CALL:MS:REPorted:MEASurement:NCONtrol:NCELl:NUMBer:NEW?"
! Returns the number of the next MS reported neighbour cells.

CALL:MS:REPorted:MEASurement:NCONtrol:NCELl<n>:RATechnology[:LAST]?

Function

GSM TA

This command queries the Radio Access Technology of neighbour cell<n> reported in the last
Network Control Measurement Reports
, where <n> is any integer 1 through 6. See also,
Network Control :NEW? and [:LAST]? Queries
.

The query returns INV if the neighbour cell<n> is not included in the measurement report from the Mobile Station.

This command is used for normal measurement reports only. See
General Network Control Measurement Reports Screen
.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Range: GSM|FDD|TDD|CDMA|INV

*RST Setting

INV

Requirements

GSM/GPRS/ EGPRS TA

Revision: A.07 and above

GSM/GPRS/ EGPRS LA

Revision: E.00.12 and above

Programming Example

OUTPUT 714;"CALL:MS:REPorted:MEASurement:NCONtrol:NCELl:RATechnology?"
! Returns the last MS reported Radio Access Technology of neighbour cell 1.

CALL:MS:REPorted:MEASurement:NCONtrol:NCELl<n>:RATechnology:NEW?

Function

GSM TA

This command queries the Radio Access Technology of neighbour cell<n> reported in the next
Network Control Measurement Reports
, where <n> is any integer 1 through 6. See also,
Network Control :NEW? and [:LAST]? Queries
.

The query returns INV if the neighbour cell<n> is not included in the measurement report from the Mobile Station.

This command is used for normal measurement reports only. See
General Network Control Measurement Reports Screen
.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Range: GSM|FDD|TDD|CDMA|INV

*RST Setting

INV

Requirements

GSM/GPRS/ EGPRS TA

Revision: A.07 and above

GSM/GPRS/ EGPRS LA

Revision: E.00.12 and above

Programming Example

OUTPUT 714;"CALL:MS:REPorted:MEASurement:NCONtrol:NCELl:RATechnology:NEW?"
! Returns the next MS reported Radio Access Technology of neighbour cell 1.

CALL:MS:REPorted:MEASurement:NCONtrol:NCMode[:LAST]?

Function

GSM TA

Queries the last Network Control Mode reported by the MS. See
Network Control Measurement Reports
.

The command to set the Network Control Order parameter is
CALL[:CELL]:BCHannel:NCORder
. See the description in the table under this command for more information.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Range: 0 to 2

Resolution: 1

*RST Setting

NAN

Requirements

GSM/GPRS/ EGPRS TA

Revision: A.07 and above

GSM/GPRS/ EGPRS LA

Revision: E.00.08 and above

Programming Example

OUTPUT 714;"CALL:MS:REPorted:MEASurement:NCONtrol:NCMode?"
! Queries the network control mode last reported by the MS.

CALL:MS:REPorted:MEASurement:NCONtrol:NCMode:NEW?

Function

GSM TA

Queries the next Network Control Mode reported by the MS. See
Network Control Measurement Reports
.

The command to set the Network Control Order parameter is
CALL[:CELL]:BCHannel:NCORder
. See the description in the table under this command for more information.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Range: 0 to 2

Resolution: 1

*RST Setting

NAN

Requirements

GSM/GPRS/ EGPRS TA

Revision: A.07 and above

GSM/GPRS/ EGPRS LA

Revision: E.00.08 and above

Programming Example

OUTPUT 714;"CALL:MS:REPorted:MEASurement:NCONtrol:NCMode:NEW?"
! Queries the next network control mode reported by the MS.

CALL:MS:REPorted:MEASurement:NCONtrol:RXLevel[:LAST]?

Function

GSM/GPRS LA

This command queries the last MS reported measurement of the received level (full) of the TCH in dB (relative to -110 dBm) that is in the
Network Control Measurement Reports
. See also,
Network Control :NEW? and [:LAST]? Queries
.

EGPRS LA

GSM TA

GPRS TA

EGPRS TA

Query

Range: 0 to 63 and 9.91E+37

Resolution: 1

*RST Setting

9.91E+37 (NAN)

Requirements

GSM/GPRS/ EGPRS TA

Revision: A.07 and above

GSM/GPRS/ EGPRS LA

Revision: E.00.08 and above

Programming Example

OUTPUT 714;"CALL:MS:REPorted:MEASurement:NCONtrol:RXLevel?"
! Queries the last RX Level that was returned in the Network Control Measurement Reports.

CALL:MS:REPorted:MEASurement:NCONtrol:RXLevel:NEW?

Function

GSM/GPRS LA

This command queries the next MS reported measurement of the received level (full) of the TCH in dB (relative to -110 dBm) that is returned in the
Network Control Measurement Reports
. See also,
Network Control :NEW? and [:LAST]? Queries
.

EGPRS LA

GSM TA

GPRS TA

EGPRS TA

Query

Range: 0 to 63 and 9.91E+37

Resolution: 1

*RST Setting

9.91E+37 (NAN)

Requirements

GSM/GPRS/ EGPRS TA

Revision: A.07 and above

GSM/GPRS/ EGPRS LA

Revision: E.00.08 and above

Programming Example

OUTPUT 714;"CALL:MS:REPorted:MEASurement:NCONtrol:RXLevel:NEW?"
! Queries the next RX Level that is returned in the Network Control Measurement Reports.

CALL:MS:REPorted:MEASurement:NCONtrol:TYPE[:LAST]?

Function

GSM/GPRS LA

This command queries the report type of the last
Network Control Measurement Reports
. See
General Network Control Measurement Reports Screen
 and
Enhanced Network Control Neighbour Reports Screen
. See also
Network Control :NEW? and [:LAST]? Queries
.

EGPRS LA

GSM TA

GPRS TA

EGPRS TA

Query

Range: INV|NORM|ENH

*RST Setting

INV

Requirements

GSM/GPRS/ EGPRS TA

Revision: A.07 and above

GSM/GPRS/ EGPRS LA

Revision: E.00.12 and above

Programming Example

OUTPUT 714;"CALL:MS:REPorted:MEASurement:NCONtrol:TYPE?"
! Returns the report type of the last network control measurement report.

CALL:MS:REPorted:MEASurement:NCONtrol:TYPE:NEW?

Function

GSM/GPRS LA

This command queries the report type of the next
Network Control Measurement Reports
. See
General Network Control Measurement Reports Screen
 and
Enhanced Network Control Neighbour Reports Screen
. See also
Network Control :NEW? and [:LAST]? Queries
.

EGPRS LA

GSM TA

GPRS TA

EGPRS TA

Query

Range: INV|NORM|ENH

*RST Setting

INV

Requirements

GSM/GPRS/ EGPRS TA

Revision: A.07 and above

GSM/GPRS/ EGPRS LA

Revision: E.00.12 and above

Programming Example

OUTPUT 714;"CALL:MS:REPorted:MEASurement:NCONtrol:TYPE:NEW?"
! Returns the report type of the next network control measurement report.

CALL:MS:REPorted:MEASurement:(PACCH|PACChannel):BEP:GMSK|EPSK:CVARiance[:AVERage]|MAXimum|MINimum?

Function

GSM TA

This command queries the Coefficient of Variation of the Bit Error Probability (BEP). The average, maximum, or minimum Coefficient of Variation of the Bit Error Probability (BEP) can be found for the data blocks tested.

If average, maximum, or minimum is not specified in this command, the average Coefficient of Variation of the BEP is returned.

Refer to 3GPP TS 05.08 section 8.2.5 for information for a mapping table for the coefficient of variation of the channel quality.

GPRS TA

GSM/GPRS LA

EGPRS TA

EGPRS LA

Query

Range: 0 to 7 and 9.91E+37

Resolution: 1

*RST Setting

9.91E+37 (NAN)

Requirements

GSM/GPRS/ EGPRS TA

Revision: A.07 and above

GSM/GPRS/ EGPRS LA

Revision: E.00.08 and above

Programming Example

OUTPUT 714;"CALL:MS:REPorted:MEASurement:PACCH:BEP:GMSK:CVARiance?"

CALL:MS:REPorted:MEASurement:(PACCH|PACChannel):BEP:GMSK|EPSK:MEAN[:AVERage]|MAXimum|MINimum?

Function

GSM TA

This command queries the Bit Error Probability (BEP). The average, maximum, or minimum BEP can be found for the data blocks tested.

If average, maximum, or minimum is not specified in this command, the average BEP is returned.

Refer to 3GPP TS 05.08 section 8.2.5 for information on mean BEP mapping and accuracy for GMSK.

GPRS TA

GSM/GPRS LA

EGPRS TA

EGPRS LA

Query

Range: 0 to 31 and 9.91E+37

Resolution: 1

*RST Setting

9.91E+37 (NAN)

Requirements

GSM/GPRS/ EGPRS TA

Revision: A.07 and above

GSM/GPRS/ EGPRS LA

Revision: E.00.08 and above

Programming Example

OUTPUT 714;"CALL:MS:REPorted:MEASurement:PACCH:BEP:EPSK:MEAN:MAXimum?"

CALL:MS:REPorted:MEASurement:(PACCH|PACChannel):BEP:GMSK|EPSK:TSLot<0|1|2|3|4|5|6|7>[:AVERage]|MAXimum|MINimum?

Function

GSM TA

This command queries the Bit Error Probability (BEP) for the specified timeslot. The average, maximum, or minimum BEP can be found for the specified timeslot of the data blocks tested.

If average, maximum, or minimum is not specified in this command, the average BEP for the specified timeslot is returned.

GPRS TA

GSM/GPRS LA

EGPRS TA

EGPRS LA

Query

Range: 0 to 63 and 9.91E+37

0: (< -110 dBm)

1: (-110 dBm to -109 dBm)

2: (-109 dBm to -108 dBm)

3: (-108 dBm to -107 dBm)

...

62: (-49 dBm to -48 dBm)

63: (>-48 dBm)

Resolution: 1

*RST Setting

9.91E+37 (NAN)

Requirements

GSM/GPRS/ EGPRS TA

Revision: A.07 and above

GSM/GPRS/ EGPRS LA

Revision: E.00.08 and above

Programming Example

OUTPUT 714;"CALL:MS:REPorted:MEASurement:PACCH:BEP:GMSK:TSLOT1:AVERage?"

CALL:MS:REPorted:MEASurement:(PACCH|PACChannel):CVALue:AVERage?

Function
 |
GSM TA
 |
Queries the C value reported by the MS.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Range: 0 to 63 and 9.91E+37

0: (< -110 dBm)

1: (-110 dBm to -109 dBm)

2: (-109 dBm to -108 dBm)

3: (-108 dBm to -107 dBm)

...

62: (-49 dBm to -48 dBm)

63: (>-48 dBm)

Resolution: 1

*RST Setting
 |
9.91E+37 (NAN)

Requirements

GSM/GPRS/ EGPRS TA

Revision: A.07 and above

GSM/GPRS/ EGPRS LA

Revision: E.00.08 and above

Programming Example

OUTPUT 714;"CALL:MS:REPorted:MEASurement:PACCH:CVALue:AVERage?"

CALL:MS:REPorted:MEASurement:(PACCH|PACChannel):ILEVel:TSLot<n>:AVERage?

Function

GSM TA

Queries the interference level value reported by the MS for timeslot <n> (n can be 0 to 7).

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Range: 0 to 15 and 9.91E37

Resolution: 1

0: (Interference level > C)

1: (C >= Interference level > C- 2 dB)

2: (C - 2 dB >= Interference level > C - 4 dB)

3: (C - 4 dB >= Interference level > C - 6 dB)

4: (C - 6 dB >= Interference level > C - 8 dB)

5: (C - 8 dB >= Interference level > C - 10 dB)

6: (C - 10 dB >= Interference level > C - 12 dB)

7: (C - 12 dB >= Interference level > C - 14 dB)

8: (C - 14 dB >= Interference level > C - 16 dB)

9: (C - 16 dB >= Interference level > C - 18 dB)

10: (C - 18 dB >= Interference level > C - 20 dB)

11: (C - 20 dB >= Interference level > C - 22 dB)

12: (C - 22 dB >= Interference level > C - 24 dB)

13: (C - 24 dB >= Interference level > C - 26 dB)

14: (C - 26 dB >= Interference level > C - 28 dB)

15: (Interference level <= C)

*RST Setting

9.91E+37 (NAN)

Requirements

GSM/GPRS/ EGPRS TA

Revision: A.07 and above

GSM/GPRS/ EGPRS LA

Revision: E.00.08 and above

Programming Example

OUTPUT 714;"CALL:MS:REPorted:MEASurement:PACCH:ILEVel:TSLot5:AVERage?"
! Queries the !interference level value!reported by the MS for timeslot 5.

CALL:MS:REPorted:MEASurement:(PACCH|PACChannel):RXQuality:AVERage?

Function

GPRS TA

Queries the received signal quality value reported by the MS.

EGPRS TA

GSM TA

GSM/GPRS LA

EGPRS LA

Query

Range: 0 to 7 and 9.91E+37

0 (0% < BER < 0.2%)

1 (0.2% < BER < 0.4%)

2 (0.4% < BER < 0.8%)

3 (0.8% < BER < 1.6%)

4 (1.6% < BER < 3.2%)

5 (3.2% < BER < 6.4%)

6 (6.4% < BER < 12.8%)

7 (BER > 12.8%)

*RST Setting

9.91E+37 (NAN)

Requirements

GSM/GPRS/ EGPRS TA

Revision: A.07 and above

GSM/GPRS/ EGPRS LA

Revision: E.00.08 and above

Programming Example

OUTPUT 714;"CALL:MS:REPorted:MEASurement:PACCH:RXQuality:AVERage?"

CALL:MS:REPorted:MEASurement:(PACCH|PACChannel):SVARiance:AVERage?

Function

GSM TA

Queries the value reported by the MS representing the average received signal level variance.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Range: 0 to 63 and 9.91E+37

Resolution: 1

The formula: SVAR * 0.25 dB2 maps the MS reported value to the actual received signal level variance.

*RST Setting

9.91E+37 (NAN)

Requirements

GSM/GPRS/ EGPRS TA

Revision: A.07 and above

GSM/GPRS/ EGPRS LA

Revision: E.00.08 and above

Programming Example

OUTPUT 714;"CALL:MS:REPorted:MEASurement:PACCH:SVARiance:AVERage?"

CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):COUNt

Function

GSM TA

This command queries the number of SAACH reports received from the Mobile Station since the counter was last reset.

This counter is reset to zero when voice call is ended, or if explicitly reset by
CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):COUNt:CLEar
.

GPRS TA

EGPRS TA

GSM/GPRS LA

Query

Range: 0 to 4294967296

*RST Setting

0

Requirements

GSM/GPRS/ EGPRS LA

Revision: F.01 and above

GSM/GPRS/ EGPRS TA

Revision: A.09 and above

Programming Example

OUTPUT 714;"CALL:MS:REPorted:MEASurement:SACCH:COUNt"
! Returns the number of SACCH reports received from the Mobile Station.

CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):COUNt:CLEar

Function

GSM TA

This command is used to set the SACCH reports count to zero.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Requirements

GSM/GPRS/ EGPRS LA

Revision: F.01 and above

GSM/GPRS/ EGPRS TA

Revision: A.09 and above

Programming Example

OUTPUT 714;"CALL:MS:REPorted:MEASurement:SACCH:COUNt:CLEar"
! Clear the SACCH reports counters.

CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):ENHanced:NCELl[:GSM][:LAST]?

Function

GSM TA

This command is not applicable to the GSM test application.

GPRS TA
 |
This command is not applicable to the GPRS test application.

EGPRS TA
 |
This command is not applicable to the EGPRS test application.

GSM/GPRS LA

This command queries the last (most recent) MS reported measurements for all GSM cells in the Enhanced
SACCH Measurement Reports
. For more information, see
SACCH NEW? and [:LAST?] Queries
.

The information is returned as groups of 4 numeric values separated by commas in the following order: RX LEVEL, ARFCN, BCC, NCC. The total number of comma seperated values returned is determined by
CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):ENHanced:NCELl[:GSM]:POINts[:LAST]?
.

This command is used for enhanced measurement reports only. See
Enhanced SACCH Neighbour Reports Screen
.

EGPRS LA

Query

RX Level

  •
Range: 0 to 63
    •

  •

Resolution: 1
    •

ARFCN

  •
Range: 1 to 1023 and 9.91E+37
    •

  •

Resolution: 1
    •

BCC

  •
Range: 0 to 7
    •

  •

Resolution: 1
    •

NCC

  •
Range: 0 to 7
    •

  •

Resolution: 1
    •

*RST Setting

9.91E+37,9.91E+37 ,9.91E+37 ,9.91E+37

Requirements

GSM/GPRS/ EGPRS LA

Revision: E.00.12 and above

Programming Example

OUTPUT 714;"CALL:MS:REPorted:MEASurement:SACCH:ENHanced:NCELl?"
! Returns the last MS reported RX LEVEL,ARFCN,BCC,NCC for all GSM cells
! in the enhanced SACCH measurement report.

CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):ENHanced:NCELl[:GSM]:NEW?

Function

GSM TA

This command is not applicable to the GSM test application.

GPRS TA
 |
This command is not applicable to the GPRS test application.

EGPRS TA
 |
This command is not applicable to the EGPRS test application.

GSM/GPRS LA

This command queries the next MS reported measurements for all GSM cells in the Enhanced
SACCH Measurement Reports
. For more information, see
SACCH NEW? and [:LAST?] Queries
.

The information is returned as groups of 4 numeric values separated by commas in the following order: RX LEVEL, ARFCN, BCC, NCC. The total number of comma seperated values returned is determined by
CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):ENHanced:NCELl[:GSM]:POINts:NEW?
.

This command is used for enhanced measurement reports only. See
Enhanced SACCH Neighbour Reports Screen
.

EGPRS LA

Query

RX Level

  •
Range: 0 to 63
    •

  •

Resolution: 1
    •

ARFCN

  •
Range: 1 to 1023 and 9.91E+37
    •

  •

Resolution: 1
    •

BCC

  •
Range: 0 to 7
    •

  •

Resolution: 1
    •

NCC

  •
Range: 0 to 7
    •

  •

Resolution: 1
    •

*RST Setting

9.91E+37,9.91E+37 ,9.91E+37 ,9.91E+37

Requirements

GSM/GPRS/ EGPRS LA

Revision: E.00.12 and above

Programming Example

OUTPUT 714;"CALL:MS:REPorted:MEASurement:SACCH:ENHanced:NCELl:NEW?"
! Returns the next MS reported RX LEVEL,ARFCN,BCC,NCC for all GSM cells
! in the enhanced SACCH measurement report.

CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):ENHanced:NCELl:FDD[:LAST]?

Function

GSM TA

This command is not applicable to the GSM test application.

GPRS TA
 |
This command is not applicable to the GPRS test application.

EGPRS TA
 |
This command is not applicable to the EGPRS test application.

GSM/GPRS LA

This command queries the last (most recent) MS reported measurements for all FDD cells in the Enhanced
SACCH Measurement Reports
. For more information, see
SACCH NEW? and [:LAST?] Queries
.

The information is returned as groups of 3 numeric values separated by commas in the following order: Reporting Quantity, UARFCN, Scrambling Code. The total number of comma seperated values returned is determined by
CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):ENHanced:NCELl:FDD:POINts[:LAST]?
.

This command is used for enhanced measurement reports only. See
Enhanced SACCH Neighbour Reports Screen
.

EGPRS LA

Query

Reporting Quantity

  •
Range: 0 to 63
    •

  •

Resolution: 1
    •

UARFCN

  •
Range: 1 to 16383 and 9.91E+37
    •

  •

Resolution: 1
    •

Scrambling Code

  •
Range: 0 to 511
    •

  •

Resolution: 1
    •

*RST Setting

9.91E+37,9.91E+37 ,9.91E+37

Requirements

GSM/GPRS/ EGPRS LA

Revision: E.00.12 and above

Programming Example

OUTPUT 714;"CALL:MS:REPorted:MEASurement:SACCH:ENHanced:NCELl:FDD?"
! Returns the last MS reported Reporting Quantity, UARFCN, Scrambling Code for all FDD cells
! in the enhanced SACCH measurement report.

CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):ENHanced:NCELl:FDD:NEW?

Function

GSM TA

This command is not applicable to the GSM test application.

GPRS TA
 |
This command is not applicable to the GPRS test application.

EGPRS TA
 |
This command is not applicable to the EGPRS test application.

GSM/GPRS LA

This command queries the next MS reported measurements for all FDD cells in the Enhanced
SACCH Measurement Reports
. For more information, see
SACCH NEW? and [:LAST?] Queries
.

The information is returned as groups of 3 numeric values separated by commas in the following order: Reporting Quantity, UARFCN, Scrambling Code. The total number of comma seperated values returned is determined by
CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):ENHanced:NCELl:FDD:POINts:NEW?
.

This command is used for enhanced measurement reports only. See
Enhanced SACCH Neighbour Reports Screen
.

EGPRS LA

Query

Reporting Quantity

  •
Range: 0 to 63
    •

  •

Resolution: 1
    •

UARFCN

  •
Range: 1 to 16383 and 9.91E+37
    •

  •

Resolution: 1
    •

Scrambling Code

  •
Range: 0 to 511
    •

  •

Resolution: 1
    •

*RST Setting

9.91E+37,9.91E+37 ,9.91E+37

Requirements

GSM/GPRS/ EGPRS LA

Revision: E.00.12 and above

Programming Example

OUTPUT 714;"CALL:MS:REPorted:MEASurement:SACCH:ENHanced:NCELl:FDD:NEW?"
! Returns the next MS reported Reporting Quantity, UARFCN, Scrambling Code for all FDD cells
! in the enhanced SACCH measurement report.

CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):ENHanced:NCELl:FDD:POINts[:LAST]?

Function

GSM TA

This command is not applicable to the GSM test application.

GPRS TA
 |
This command is not applicable to the GPRS test application.

EGPRS TA
 |
This command is not applicable to the EGPRS test application.

GSM/GPRS LA

This command queries the number of comma seperated values returned by the related
CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):ENHanced:NCELl:FDD[:LAST]?
 command.

This command is used for enhanced measurement reports only. See
Enhanced SACCH Neighbour Reports Screen
.

EGPRS LA

Query

Range: 0 to 13

Resolution: 1

*RST Setting

0

Requirements

GSM/GPRS/ EGPRS LA

Revision: E.00.12 and above

Programming Example

OUTPUT 714;"CALL:MS:REPorted:MEASurement:SACCH:ENHanced:NCELl:FDD:POINts?"
! Returns the number of comma seperated values returned by the related
! CALL:MS:REPorted:MEASurement:SACCH:ENHanced:NCELl:FDD:LAST command.

CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):ENHanced:NCELl:FDD:POINts:NEW?

Function

GSM TA

This command is not applicable to the GSM test application.

GPRS TA
 |
This command is not applicable to the GPRS test application.

EGPRS TA
 |
This command is not applicable to the EGPRS test application.

GSM/GPRS LA

This command queries the number of comma seperated values returned by the related
CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):ENHanced:NCELl:FDD:NEW?
 command.

This command is used for enhanced measurement reports only. See
Enhanced SACCH Neighbour Reports Screen
.

EGPRS LA

Query

Range: 0 to 13

Resolution: 1

*RST Setting

0

Requirements

GSM/GPRS/ EGPRS LA

Revision: E.00.12 and above

Programming Example

OUTPUT 714;"CALL:MS:REPorted:MEASurement:SACCH:ENHanced:NCELl:FDD:POINts:NEW?"
! Returns the number of comma seperated values returned by the related
! CALL:MS:REPorted:MEASurement:SACCH:ENHanced:NCELl:FDD:NEW command.

CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):ENHanced:NCELl[:GSM]:POINts[:LAST]?

Function

GSM TA

This command is not applicable to the GSM test application.

GPRS TA
 |
This command is not applicable to the GPRS test application.

EGPRS TA
 |
This command is not applicable to the EGPRS test application.

GSM/GPRS LA

This command queries the number of comma seperated values returned by the related
CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):ENHanced:NCELl[:GSM][:LAST]?
 command.

This command is used for enhanced measurement reports only. See
Enhanced SACCH Neighbour Reports Screen
.

EGPRS LA

Query

Range: 0 to 16

Resolution: 1

*RST Setting

0

Requirements

GSM/GPRS/ EGPRS LA

Revision: E.00.12 and above

Programming Example

OUTPUT 714;"CALL:MS:REPorted:MEASurement:SACCH:ENHanced:NCELl:POINts?"
! Returns the number of comma seperated values returned by the related
! CALL:MS:REPorted:MEASurement:SACCH:ENHanced:NCELl:GSM:LAST command.

CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):ENHanced:NCELl[:GSM]:POINts:NEW?

Function

GSM TA

This command is not applicable to the GSM test application.

GPRS TA
 |
This command is not applicable to the GPRS test application.

EGPRS TA
 |
This command is not applicable to the EGPRS test application.

GSM/GPRS LA

This command queries the number of comma seperated values returned by the related
CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):ENHanced:NCELl[:GSM]:NEW?
 command.

This command is used for enhanced measurement reports only. See
Enhanced SACCH Neighbour Reports Screen
.

EGPRS LA

Query

Range: 0 to 16

Resolution: 1

*RST Setting

0

Requirements

GSM/GPRS/ EGPRS LA

Revision: E.00.12 and above

Programming Example

OUTPUT 714;"CALL:MS:REPorted:MEASurement:SACCH:ENHanced:NCELl:POINts:NEW?"
! Returns the number of comma seperated values returned by the related
! CALL:MS:REPorted:MEASurement:SACCH:ENHanced:NCELl:GSM:NEW command.

CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):NCELl<n>:FDD[:LAST]?

Function

GSM TA

This command queries the last (most recent) MS reported measurements for FDD neighbour cell <n> in the normal
SACCH Measurement Reports
, where <n> is any integer 1 through 6. The information is returned as 3 numeric values separated by commas in the following order: Reporting Quantity, UARFCN, Scrambling Code.For more information, see
SACCH NEW? and [:LAST?] Queries
.

This command is used for normal measurement reports only. See
General SACCH Reports Screen
.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Reporting Quantity

  •
Range: 0 to 63
    •

  •

Resolution: 1
    •

UARFCN

  •
Range: 1 to 16383 and 9.91E+37
    •

  •

Resolution: 1
    •

Scrambling Code

  •
Range: 0 to 511
    •

  •

Resolution: 1
    •

*RST Setting

9.91E+37,9.91E+37 ,9.91E+37

Requirements

GSM/GPRS/ EGPRS TA

Revision: A.07 and above

GSM/GPRS/ EGPRS LA

Revision: E.00.12 and above

Programming Example

OUTPUT 714;"CALL:MS:REPorted:MEASurement:SACCH:NCELl1:FDD?"
! Returns the last MS reported SACCH measurements of the Reporting Quantity,
! UARFCN, Scrambling Code for FDD neighbour cell 1.

CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):NCELl<n>:FDD:NEW?

Function

GSM TA

This command queries the next MS reported measurements for FDD neighbour cell <n> in the normal
SACCH Measurement Reports
, where <n> is any integer 1 through 6. The information is returned as 3 numeric values separated by commas in the following order: Reporting Quantity, UARFCN, Scrambling Code. For more information, see
SACCH NEW? and [:LAST?] Queries
.

This command is used for normal measurement reports only. See
General SACCH Reports Screen
.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Reporting Quantity

  •
Range: 0 to 63
    •

  •

Resolution: 1
    •

UARFCN

  •
Range: 1 to 16383 and 9.91E+37
    •

  •

Resolution: 1
    •

Scrambling Code

  •
Range: 0 to 511
    •

  •

Resolution: 1
    •

*RST Setting

9.91E+37,9.91E+37 ,9.91E+37

Requirements

GSM/GPRS/ EGPRS TA

Revision: A.07 and above

GSM/GPRS/ EGPRS LA

Revision: E.00.12 and above

Programming Example

OUTPUT 714;"CALL:MS:REPorted:MEASurement:SACCH:NCELl1:NEW?"
! Returns the next MS reported SACCH measurements of the Reporting Quantity,
! UARFCN, Scrambling Code for FDD neighbour cell 1.

CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):NCELl<n>[:GSM][:LAST]?

Function

GSM TA

This command queries the last (most recent) MS reported measurements for GSM neighbour cell <n>, where <n> is any integer 1 through 6. The information is returned as 4 numeric values separated by commas in the following order: RX LEVEL, ARFCN, BCC, NCC. For more information, see
SACCH NEW? and [:LAST?] Queries
. See also,
SACCH Measurement Reports
.

This command is used for normal measurement reports only. See
General SACCH Reports Screen
.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

RX Level

  •
Range: 0 to 63
    •

  •

Resolution: 1
    •

ARFCN

  •
Range: 1 to 1023 and 9.91E+37
    •

  •

Resolution: 1
    •

BCC

  •
Range: 0 to 7
    •

  •

Resolution: 1
    •

NCC

  •
Range: 0 to 7
    •

  •

Resolution: 1
    •

*RST Setting

9.91E+37,9.91E+37 ,9.91E+37 ,9.91E+37

Requirements

GSM/GPRS/ EGPRS TA

Revision: A.07 and above

GSM/GPRS/ EGPRS LA

Revision: E.00.08 and above

Programming Example

OUTPUT 714;"CALL:MS:REPorted:MEASurement:SACCH:NCELl1?"
! Returns the last MS reported measurements of the RX LEVEL,ARFCN,BCC,NCC
! for GSM neighbour cell 1.

CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):NCELl<n>[:GSM]:NEW?

Function

GSM TA

This command queries the next MS reported measurements for neighbour cell <n>, where <n> is any integer 1 through 6. The information is returned as 4 numeric values separated by commas for neighbour cell one in the following order: RX LEVEL, ARFCN, BCC, NCC. For more information, see
SACCH NEW? and [:LAST?] Queries
. See also,
SACCH Measurement Reports
.

This command is used for normal measurement reports only. See
General SACCH Reports Screen
.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

RX Level

  •
Range: 0 to 63
    •

  •

Resolution: 1
    •

ARFCN

  •
Range: 1 to 1023 and 9.91E+37
    •

  •

Resolution: 1
    •

BCC

  •
Range: 0 to 7
    •

  •

Resolution: 1
    •

NCC

  •
Range: 0 to 7
    •

  •

Resolution: 1
    •

*RST Setting

9.91E+37,9.91E+37 ,9.91E+37 ,9.91E+37

Requirements

GSM/GPRS/ EGPRS TA

Revision: A.07 and above

GSM/GPRS/ EGPRS LA

Revision: E.00.08 and above

Programming Example

OUTPUT 714;"CALL:MS:REPorted:MEASurement:SACCH:NCELl1:NEW?"
! Returns the next MS reported RX LEVEL,ARFCN,BCC,NCC for GSM neighbour cell 1.

CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):NCELl:NUMBer[:LAST]?

Function

GSM TA

This command queries the number of neighbour cells reported in the last
SACCH Measurement Reports
. See also,
SACCH NEW? and [:LAST?] Queries
.

This command is used for normal measurement reports only. See
General SACCH Reports Screen
.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Range: 1 to 6

Resolution: 1

*RST Setting

Range: 1 to 6

Resolution: 1

Requirements

GSM/GPRS/ EGPRS TA

Revision: A.07 and above

GSM/GPRS/ EGPRS LA

Revision: E.00.08 and above

Programming Example

OUTPUT 714;"CALL:MS:REPorted:MEASurement:SACCH:NCELl:NUMBer?"
! Returns the last MS reported number neighbour cells.

CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):NCELl:NUMBer:NEW?

Function

GSM TA

This command queries the number of neighbour cells reported in the next
SACCH Measurement Reports
. See also,
SACCH NEW? and [:LAST?] Queries
.

This command is used for normal measurement reports only. See
General SACCH Reports Screen
.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Range: 1 to 6

Resolution: 1

*RST Setting

Range: 1 to 6

Resolution: 1

Requirements

GSM/GPRS/ EGPRS TA

Revision: A.07 and above

GSM/GPRS/ EGPRS LA

Revision: E.00.08 and above

Programming Example

OUTPUT 714;"CALL:MS:REPorted:MEASurement:SACCH:NCELl:NUMBer:NEW?"
! Returns the number of the next MS reported neighbour cells.

CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):NCELl<n>:RATechnology[:LAST]?

Function

GSM TA

This command queries the Radio Access Technology of neighbour cell<n> reported in the last
SACCH Measurement Reports
, where <n> is any integer 1 through 6. See also,
SACCH NEW? and [:LAST?] Queries
.

The query returns INV if the neighbour cell<n> is not included in the measurement report from the Mobile Station.

This command is used for normal measurement reports only. See
General SACCH Reports Screen
.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Range: GSM|FDD|TDD|CDMA|INV

Note: The TDD and CDMA parameters are not currently supported.

*RST Setting

Range: GSM|FDD|TDD|CDMA|INV

Requirements

GSM/GPRS/ EGPRS TA

Revision: A.07 and above

GSM/GPRS/ EGPRS LA

Revision: E.00.12 and above

Programming Example

OUTPUT 714;"CALL:MS:REPorted:MEASurement:SACCH:NCELl:RATechnology?"
! Returns the last MS reported Radio Access Technology of neighbour cell 1.

CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):NCELl<n>:RATechnology:NEW?

Function

GSM TA

This command queries the Radio Access Technology of neighbour cell<n> reported in the next
SACCH Measurement Reports
, where <n> is any integer 1 through 6. See also,
SACCH NEW? and [:LAST?] Queries
.

The query returns INV if the neighbour cell<n> is not included in the measurement report from the Mobile Station.

This command is used for normal measurement reports only. See
General SACCH Reports Screen
.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Range: GSM|FDD|TDD|CDMA|INV

Note: The TDD and CDMA parameters are not currently supported.

*RST Setting

Range: GSM|FDD|TDD|CDMA|INV

Requirements

GSM/GPRS/ EGPRS TA

Revision: A.07 and above

GSM/GPRS/ EGPRS LA

Revision: E.00.12 and above

Programming Example

OUTPUT 714;"CALL:MS:REPorted:MEASurement:SACCH:NCELl:RATechnology:NEW?"
! Returns the next MS reported Radio Access Technology of neighbour cell 1.

CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):RXLevel:FULL[:LAST]?

Function

GSM/GPRS LA

This command queries the last MS reported measurement of the received level (full) of the TCH in dB (relative to -110 dBm) that is in the
SACCH Measurement Reports
. See also,
SACCH NEW? and [:LAST?] Queries
.

EGPRS LA

GSM TA

GPRS TA

EGPRS TA

Query

Range: 0 to 63 and 9.91E+37

Resolution: 1

*RST Setting

9.91E+37 (NAN)

Requirements

GSM/GPRS/ EGPRS TA

Revision: A.07 and above

GSM/GPRS/ EGPRS LA

Revision: E.00.08 and above

Programming Example

OUTPUT 714;"CALL:MS:REPorted:MEASurement:SACCH:RXLevel:FULL?"
! Queries the last (full) RX Level that was returned in the SACCH Measurement Report.

CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):RXLevel:FULL:NEW?

Function

GSM/GPRS LA

This command queries up to three of the next MS reported measurements of the received level (full) of the TCH in dB (relative to -110 dBm) that are returned in the
SACCH Measurement Reports
.

Each time the :NEW? query is sent, the test set hangs until report results from that measurement period are sent or until 10 seconds have elapsed at which point the test set times out.

This will return 3 variables; the first two are ignored while the value from the third new query is the valid variable. For more information, see
SACCH NEW? and [:LAST?] Queries
.

EGPRS LA

GSM TA

GPRS TA

EGPRS TA

Query

Range: 0 to 63 and 9.91E+37

Resolution: 1

*RST Setting

9.91E+37 (NAN)

Requirements

GSM/GPRS/ EGPRS TA

Revision: A.07 and above

GSM/GPRS/ EGPRS LA

Revision: E.00.08 and above

Programming Example

OUTPUT 714;"CALL:MS:REPorted:MEASurement:SACCH:RXLevel:FULL:NEW?;NEW?;NEW?"
! Queries the next three (full) RX Level that will be returned in the SACCH Measurement Reports.
! The third result is valid.

CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):RXLevel:SUB[:LAST]?

Function

GSM/GPRS LA

This command queries the received level (sub) of the TCH in dB (relative to -110 dBm) that was reported in the
SACCH Measurement Reports
. See also,
SACCH NEW? and [:LAST?] Queries
.

EGPRS LA

GSM TA

GPRS TA

EGPRS TA

Query

Range: 0 to 63 and 9.91E+37

Resolution: 1

*RST Setting

9.91E+37 (NAN)

Requirements

GSM/GPRS/ EGPRS TA

Revision: A.07 and above

GSM/GPRS/ EGPRS LA

Revision: E.00.08 and above

Programming Example

OUTPUT 714;"CALL:MS:REPorted:MEASurement:SACCH:RXLevel:SUB?"
! Queries the last (subset) RX Level returned in the SACCH Measurement Reports.

CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):RXLevel:SUB:NEW?

Function

GSM/GPRS LA

This command queries up to three of the next MS reported measurements of the received level (sub) of the TCH in dB (relative to -110 dBm). See
Full and Sub Receiver Reports
.

Each time the :NEW? query is sent, the test set hangs until report results from that measurement period are sent or until 10 seconds have elapsed at which point the test set times out.

This will return 3 variables; the first two are ignored while the value from the third new query is the valid variable. For more information, see
SACCH NEW? and [:LAST?] Queries
.

EGPRS LA

GSM TA

GPRS TA

EGPRS TA

Query

Range: 0 to 63 and 9.91E+37

Resolution: 1

*RST Setting

9.91E+37 (NAN)

Requirements

GSM/GPRS/ EGPRS TA

Revision: A.07 and above

GSM/GPRS/ EGPRS LA

Revision: E.00.08 and above

Programming Example

OUTPUT 714;"CALL:MS:REPorted:MEASurement:SACCH:RXLevel:SUB:NEW?;NEW?;NEW?"
! Queries the next three (subset) RX Level results that are returned in the SACCH Measurement Reports.
! The third result is valid.

CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):RXQuality:FULL[:LAST]?

Function

GSM/GPRS LA

This command queries the last (most recently) MS reported Full RX Quality result from the SACCH Measurement Reports. For more information, see
Full and Sub Receiver Reports
 and
SACCH NEW? and [:LAST?] Queries
.

EGPRS LA

GSM TA

GPRS TA

EGPRS TA

Query

Range: 0 to 7 and 9.91E+37

Resolution: 1

*RST Setting

9.91E+37 (NAN)

Requirements

GSM/GPRS/ EGPRS TA

Revision: A.07 and above

GSM/GPRS/ EGPRS LA

Revision: E.00.08 and above

Programming Example

OUTPUT 714;"CALL:MS:REPorted:MEASurement:SACCH:RXQuality:FULL?"
! Queries the last (full) RX Quality returned in the SACCH Measurement Reports.

CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):RXQuality:FULL:NEW?

Function

GSM/GPRS LA

This command queries up to three of the next MS reported measurements of the full received quality from the SACCH report. See
Full and Sub Receiver Reports
. Each time the :NEW? query is sent the test set hangs until report results from that measurement period are sent or until 10 seconds have elapsed at which point the test set times out.

This will return 3 variables; the first two are ignored while the value from the third new query is the valid variable. For more information, see
SACCH NEW? and [:LAST?] Queries
.

EGPRS LA

GSM TA

GPRS TA

EGPRS TA

Query

Range: 0 to 7 and 9.91E+37

Resolution: 1

*RST Setting

9.91E+37 (NAN)

Requirements

GSM/GPRS/ EGPRS TA

Revision: A.07 and above

GSM/GPRS/ EGPRS LA

Revision: E.00.08 and above

Programming Example

OUTPUT 714;"CALL:MS:REPorted:MEASurement:SACCH:RXQuality:FULL:NEW?;NEW?;NEW?"
! Queries the next three (full) RX Quality that will be returned in the SACCH Measurement Reports.
! The third result is valid.

CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):RXQuality:SUB[:LAST]?

Function

GSM/GPRS LA

This command queries the RX Level of the result reported by the mobile station for a subset of SACCH frames (see
Full and Sub Receiver Reports
). See also
SACCH NEW? and [:LAST?] Queries
.

EGPRS LA

GSM TA

GPRS TA

EGPRS TA

Query

Range: 0 to 7 and 9.91E+37

Resolution: 1

*RST Setting

9.91E+37 (NAN)

Requirements

GSM/GPRS/ EGPRS TA

Revision: A.07 and above

GSM/GPRS/ EGPRS LA

Revision: E.00.08 and above

Programming Example

OUTPUT 714;"CALL:MS:REPorted:MEASurement:SACCH:RXQuality:SUB?"
! Queries the last (subset) RX Quality returned in the SACCH Measurement Reports.

CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):RXQuality:SUB:NEW?

Function

GSM/GPRS LA

This command queries up to three of the next MS reported measurements of the received quality for a subset of SACCH frames. See
Full and Sub Receiver Reports
. Each time the :NEW? query is sent the test set hangs until report results from that measurement period are sent or until 10 seconds have elapsed at which point the test set times out.

This will return 3 variables; the first two are ignored while the value from the third new query is the valid variable. For more information, see
SACCH NEW? and [:LAST?] Queries
.

EGPRS LA

GSM TA

GPRS TA

EGPRS TA

Query

Range: 0 to 7 and 9.91E+37

Resolution: 1

*RST Setting

9.91E+37 (NAN)

Requirements

GSM/GPRS/ EGPRS TA

Revision: A.07 and above

GSM/GPRS/ EGPRS LA

Revision: E.00.08 and above

Programming Example

OUTPUT 714;"CALL:MS:REPorted:MEASurement:SACCH:RXQuality:SUB:NEW?;NEW?;NEW?"
! Queries the next three (subset) RX Level that will be returned in the SACCH Measurement Reports.
! The third result is valid.

CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):TADVance[:LAST]?

Function

GSM/GPRS LA

This command queries the mobile station for the last TCH Timing Advance actually used by the mobile station. See
CALL:(PDTCH|PDTChannel):MS:TADVance[:SELected]
. See also
SACCH NEW? and [:LAST?] Queries
.

EGPRS LA

GSM TA

GPRS TA

EGPRS TA

Query

Range: 0 to 63 and 9.91E+37

Resolution: 1

*RST Setting

0

Requirements

GSM/GPRS/ EGPRS TA

Revision: A.07 and above

GSM/GPRS/ EGPRS LA

Revision: E.00.08 and above

Programming Example

OUTPUT 714;"CALL:MS:REPorted:MEASurement:SACCH:TADVance:LAST?"

CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):TADVance:NEW?

Function

GSM/GPRS LA

This command queries the mobile station reported timing advance from the SACCH report. Each time the :NEW? query is sent the test set hangs until report results from that measurement period are sent or until 10 seconds have elapsed at which point the test set times out.

This will return 3 variables; the first two are ignored while the value from the third new query is the valid variable.

For more information, see
SACCH NEW? and [:LAST?] Queries
.

EGPRS LA

GSM TA

GPRS TA

EGPRS TA

Query

Range: 0 to 63 and 9.91E+37

Resolution: 1

*RST Setting

9.91E+37 (NAN)

Requirements

GSM/GPRS/ EGPRS TA

Revision: A.07 and above

GSM/GPRS/ EGPRS LA

Revision: E.00.08 and above

Programming Example

OUTPUT 714;"CALL:MS:REPorted:MEASurement:SACCH:TADVance:NEW?;NEW?;NEW?"
! The third result is valid.

CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):TXLevel[:LAST]?

Function

GSM/GPRS LA

This command queries the mobile station for the last reported transmit level. See
SACCH NEW? and [:LAST?] Queries
.

EGPRS LA

GSM TA

GPRS TA

EGPRS TA

Query

Range: 0 to 31 and 9.91E+37

Resolution: 1

*RST Setting

9.91E+37 (NAN)

Requirements

GSM/GPRS/ EGPRS TA

Revision: A.07 and above

GSM/GPRS/ EGPRS LA

Revision: E.00.08 and above

Programming Example

OUTPUT 714;"CALL:MS:REPorted:MEASurement:SACCH:TXLevel:LAST?"

CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):TXLevel:NEW?

Function

GSM/GPRS LA

This command queries the mobile station reported transmit level from the SACCH report. Each time the :NEW? query is sent the test set hangs until report results from that measurement period are sent or until 10 seconds have elapsed at which point the test set times out.

This will return 3 variables; the first two are ignored while the value from the third new query is the valid variable.

For more information, see
SACCH NEW? and [:LAST?] Queries
.

EGPRS LA

GSM TA

GPRS TA

EGPRS TA

Query

Range: 0 to 31 and 9.91E+37

Resolution: 1

*RST Setting

9.91E+37 (NAN)

Requirements

GSM/GPRS/ EGPRS TA

Revision: A.07 and above

GSM/GPRS/ EGPRS LA

Revision: E.00.08 and above

Programming Example

OUTPUT 714;"CALL:MS:REPorted:MEASurement:SACCH:TXLevel:NEW?;NEW?;NEW?"
! The third result is valid.

CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):TYPE[:LAST]?

Function

GSM/GPRS LA

This command queries the report type of the last
SACCH Measurement Reports
. See
General SACCH Reports Screen
 and
Enhanced SACCH Neighbour Reports Screen
. See also
SACCH NEW? and [:LAST?] Queries
.

EGPRS LA

GSM TA

GPRS TA

EGPRS TA

Query

Range: INV|NORM|ENH

*RST Setting

INV

Requirements

GSM/GPRS/ EGPRS TA

Revision: A.07 and above

GSM/GPRS/ EGPRS LA

Revision: E.00.12 and above

Programming Example

OUTPUT 714;"CALL:MS:REPorted:MEASurement:SACCH:TYPE?"
! Returns the report type of the last SACCH measurement report.

CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):TYPE:NEW?

Function

GSM/GPRS LA

This command queries the report type of the next
SACCH Measurement Reports
. See
General SACCH Reports Screen
 and
Enhanced SACCH Neighbour Reports Screen
. See also
SACCH NEW? and [:LAST?] Queries
.

EGPRS LA

GSM TA

GPRS TA

EGPRS TA

Query

Range: INV|NORM|ENH

*RST Setting

INV

Requirements

GSM/GPRS/ EGPRS TA

Revision: A.07 and above

GSM/GPRS/ EGPRS LA

Revision: E.00.12 and above

Programming Example

OUTPUT 714;"CALL:MS:REPorted:MEASurement:SACCH:TYPE:NEW?"
! Returns the report type of the next SACCH measurement report.

CALL:MS:REPorted:MNCode?

Function

GSM TA

This command queries the last Mobile Network Code the mobile station was camped on.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Range: `0' to `999' and ""

Resolution: 1

*RST Setting

""(blank string)

Requirements

GSM/GPRS/

EGPRS TA

Revision: A.01 and above

GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:MS:REPORTED:MNCODE?"

CALL:MS:REPorted:NEIGhbour[1]?

Function

GSM TA

IT IS RECOMMENDED to use
CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):NCELl:NUMBer[:LAST]?
 instead in order to fit more consistently with the new commands. This command remains valid to facilitate backwards compatibility.

This query will return 4 data items separated by commas for neighbour cell one.

RFLEVEL, ARFCN, BCC, NCC are returned in that order.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Range: 1 to 1023 and 9.91E+37

Resolution: 1

*RST Setting

9.91E+37 (NAN)

Requirements

GSM/GPRS/

EGPRS TA

Revision: A.01 and above

GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:MS:REPorted:NEIGhbour?"
! Returns RFLEVEL,ARFCN,BCC,NCC in that order.

CALL:MS:REPorted:ONUMber[:SELected]?

Function

GSM TA

Queries the number the mobile station reported when the last mobile originated call was attempted.

GSM/GPRS LA

EGPRS TA

This command is not applicable to the EGPRS TA.

GPRS TA

This command is not applicable to the GPRS TA.

EGPRS LA

This command is not applicable to the EGPRS LA.

Query

Range: up to 21 ASCII characters and ` `

*RST Setting

The *RST value of this command depends on the format that is currently active. For example, if the GSM format is currently active, the *RST value for this command is the same value as the equivalent command containing the: GSM format identifier.

Requirements

GSM/GPRS/

EGPRS TA

Revision: A.01 and above

GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:MS:REPORTED:ONUMBER:SELECTED?"
! Returns the number the mobile station reported when the last mobile originated call was attempted.

CALL:MS:REPorted:ONUMber:GSM?

Function

GSM TA

This command queries the mobile station for the originated number keyed in on the mobile station.

GSM/GPRS LA

EGPRS TA

This command is not applicable to the EGPRS TA.

GPRS LA

This command is not applicable to GPRS.

EGPRS LA

This command is not applicable to EGPRS.

Query

Range: up to 21 ASCII characters and ` `

*RST Setting

` `(null string)

Requirements

GSM/GPRS/

EGPRS TA

Revision: A.01 and above

GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:MS:REPORTED:ONUMBER:GSM?"
! Returns the phone number of the last MS that called the test set.

CALL:MS:REPorted:PCLass[:SELected]?

CALL:MS:REPorted:PCLass:(DCS|EGSM|GSM450|GSM480|GSM750|GSM850|PCS|PGSM|RGSM|TGSM810)?

Function

GSM TA

This command is not applicable to the GSM TA.

GPRS TA

This command queries the mobile station for its Power Class mark for the active (that is the selected) format.

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Range:

PGSM | EGSM | RGSM | GSM450 | GSM480 | GSM750 | GSM850 |TGSM810 = 1 to 5 and 9.91E+37

DCS | PCS = 1 to 3 and 9.91E+37

Resolution: 1

*RST Setting

The *RST value of this command depends on the format that is currently active. For example, if the GSM format is currently active, the *RST value for this command is the same value as the equivalent command containing the: GSM format identifier.

Requirements

GSM/GPRS/

EGPRS TA

Revision: A.01 and above

Revision A.06 adds the TGSM810 band.

GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Revision D.03 adds the TGSM810 band.

Programming Example

OUTPUT 714;"CALL:MS:REPORTED:PCLASS:PCS?"
! Returns the mobile's power class for the PCS band.

CALL:MS:REPorted:PCLass:EPSK[:SELected]?

CALL:MS:REPorted:PCLass:EPSK:(DCS|EGSM|GSM450|GSM480|GSM750|GSM850|PCS|PGSM|RGSM|TGSM810)?

Function

GSM TA

This command queries the last EPSK or 8PSK power class for each band as reported by the mobile during its attach procedure. The band used is the PDTCH traffic band as determined by CALL:PDTCH:BAND.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Range: 1 to 29 and 9.91E+37 (means the power class is not applicable for the band)

Resolution: 1

*RST Setting

9.91E+37 (NAN)

Requirements

GSM/GPRS/

EGPRS TA

Revision: A.01 and above

A.06 adds the TGSM810 band.

GSM/GPRS/ EGPRS LA

Revision: C.01 and above

D.03 adds the TGSM810 band.

Programming Example

OUTPUT 714;"CALL:MS:REPORTED:PCLass:EPSK?"

CALL:MS:REPorted:PCLass:GMSK[:SELected]?

CALL:MS:REPorted:PCLass:GMSK:(DCS|EGSM|GSM450|GSM480|GSM750|GSM850|PCS|PGSM|RGSM|TGSM810)?

Function

GSM TA

This command is not applicable to GSM.

GPRS TA

This command queries the last GMSK power class for the specified band as reported by the mobile during its attach procedure. The band used is the PDTCH traffic band as determined by CALL:PDTCH:BAND.

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Range: 1 to 29 and 9.91E+37 (means the power class is not applicable for the band)

Resolution: 1

*RST Setting

9.91E+37 (NAN)

Requirements

GSM/GPRS/

EGPRS TA

Revision: A.01 and above

A.06 adds the TGSM810 band.

GSM/GPRS/ EGPRS LA

Revision: C.01 and above

D.03 adds the TGSM810 band.

Programming Example

OUTPUT 714;"CALL:MS:REPORTED:PCLass:EGSM?"

CALL:MS:REPorted:PCLass:GSM?

Function

GSM TA

This command is not applicable to GSM.

GPRS TA

This command queries the GSM mobile station for its Power Class mark.

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Range:

PGSM | EGSM | GSM850 = 1 to 5 and 9.91E+37

DCS | PCS = 1 to 3 and 9.91E+37

Resolution: 1

*RST Setting

9.91E+37 (NAN)

Requirements

GSM/GPRS/

EGPRS TA

Revision: A.01 and above

GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:MS:REPORTED:PCLASS:GSM?"
! Returns the MS reported power class.

CALL:MS:REPorted:REVision[:DIGital][:SELected]?

Function

GSM TA

This command queries the MS on the active (that is the selected) format to determine which phase of the standard it complies with.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Range:

9.91E+37 (NAN) = Unknown revision level

+1.00000000E+000 = Phase 1

+2.00000000E+000 = Phase 2

+3.00000000E+000 = R99 (1999 release of GSM standards)

*RST Setting

The *RST value of this command depends on the format that is currently active. For example, if the GSM format is currently active, the *RST value for this command is the same value as the equivalent command containing the: GSM format identifier.

Requirements

GSM/GPRS/

EGPRS TA

Revision: A.01 and above

GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:MS:REPORTED:REVISION?"
! Returns the MS reported protocol version.

CALL:MS:REPorted:REVision[:DIGital]:GSM?

Function

GSM TA

This command queries the mobile station to determine which phase of GSM standards it complies with.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Range:

9.91E+37 (NAN) = Unknown revision level

+1.00000000E+000 = Phase 1

+2.00000000E+000 = Phase 2

+3.00000000E+000 = R99 (1999 release of GSM standards)

*RST Setting

9.91E+37 (NAN)

Requirements

GSM/GPRS/

EGPRS TA

Revision: A.01 and above

GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:MS:REPORTED:REVISION:DIGITAL:GSM?"
! Returns the MS reported protocol version.

CALL:MS:REPorted:RXLevel[:LAST]?

Function

GSM TA

IT IS RECOMMENDED to use
CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):RXLevel:FULL[:LAST]?
 instead in order to fit more consistently with the new commands. This command remains valid to facilitate backwards compatibility.

This command queries the received level of the TCH in dB (relative to -110 dBm) which the mobile station measured during the last SACCH multiframe.

GSM/GPRS LA

EGPRS LA

GPRS TA

This command is not applicable to GPRS.

EGPRS TA

This command is not applicable to EGPRS.

Query

Range: 0 to 63 and 9.91E+37

Resolution: 1

*RST Setting

9.91E+37 (NAN)

Requirements

GSM/GPRS/

EGPRS TA

Revision: A.01 and above

GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:MS:REPORTED:RXLEVEL:LAST?"

CALL:MS:REPorted:RXLevel:NEW?

Function

GSM TA

IT IS RECOMMENDED to use
CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):RXLevel:FULL:NEW?
 instead in order to fit more consistently with the new commands. This command remains valid to facilitate backwards compatibility.

This command queries the received level of the TCH in dB (relative to -110 dBm) which the mobile station measured.

Each time the :NEW? query is sent, the test set hangs until report results from that measurement period are sent or until 10 seconds have elapsed at which point the test set times out.

This will return 3 variables; the first two are ignored while the value from the third new query is the valid variable.

GSM/GPRS LA

EGPRS LA

GPRS TA

This command is not applicable to GPRS.

EGPRS TA

This command is not applicable to EGPRS.

Query

Range: 0 to 63 and 9.91E+37

Resolution: 1

*RST Setting

9.91E+37 (NAN)

Requirements

GSM/GPRS/

EGPRS TA

Revision: A.01 and above

GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:MS:REPORTED:RXLEVEL:NEW?;NEW?;NEW?"
! The third result is valid.

CALL:MS:REPorted:RXQuality:AVERage?

Function

GPRS TA

This command is not applicable to GPRS.

EGPRS TA

This command is not applicable to EGPRS.

GSM TA

IT IS RECOMMENDED to use
CALL:MS:REPorted:MEASurement:(PACCH|PACChannel):RXQuality:AVERage?
 instead in order to fit more consistently with the new commands. This command remains valid to facilitate backwards compatibility.

Queries the received signal quality value reported by the MS.

GSM/GPRS LA

EGPRS LA

Query

Range: 0 to 7 and 9.91E+37

0 (0% < BER < 0.2%)

1 (0.2% < BER < 0.4%)

2 (0.4% < BER < 0.8%)

3 (0.8% < BER < 1.6%)

4 (1.6% < BER < 3.2%)

5 (3.2% < BER < 6.4%)

6 (6.4% < BER < 12.8%)

7 (BER > 12.8%)

*RST Setting

9.91E+37 (NAN)

Requirements

GSM/GPRS/

EGPRS TA

Revision: A.01 and above

GSM/GPRS/

EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:MS:REPorted:RXQuality:AVERage?"

CALL:MS:REPorted:RXQuality[:LAST]?

Function

GSM TA

IT IS RECOMMENDED to use
CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):RXQuality:FULL[:LAST]?
 instead in order to fit more consistently with the new commands. This command remains valid to facilitate backwards compatibility.

This command queries the mobile station reported quality of the signal used for the RX Level during the last SACCH report.

GSM/GPRS LA

EGPRS LA

GPRS TA

This command is not applicable to GPRS.

EGPRS TA

This command is not applicable to EGPRS.

Query

Range: 0 to 7 and 9.91E+37

Resolution: 1

*RST Setting

9.91E+37 (NAN)

Requirements

GSM/GPRS/

EGPRS TA

Revision: A.01 and above

GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:MS:REPORTED:RXQUALITY:LAST?"

CALL:MS:REPorted:RXQuality:NEW?

Function

GSM TA

IT IS RECOMMENDED to use
CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):RXQuality:FULL:NEW?
 instead in order to fit more consistently with the new commands. This command remains valid to facilitate backwards compatibility.

This command queries the mobile station reported received quality from the SACCH report. Each time the :NEW? query is sent the test set hangs until report results from that measurement period are sent or until 10 seconds have elapsed at which point the test set times out.

This will return 3 variables; the first two are ignored while the value from the third new query is the valid variable.

GSM/GPRS LA

EGPRS LA

GPRS TA

This command is not applicable to GPRS.

EGPRS TA

This command is not applicable to EGPRS.

Query

Range: 0 to 7 and 9.91E+37

Resolution: 1

*RST Setting

9.91E+37 (NAN)

Requirements

GSM/GPRS/

EGPRS TA

Revision: A.01 and above

GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:MS:REPORTED:RXQUALITY:NEW?;NEW?;NEW?"
! The third result is valid.

CALL:MS:REPorted:SBANd[:GMSK]?

Function

GSM TA

This command queries for the frequency bands supported by the mobile station. A comma separated list of supported bands is listed following each location update. If you change bands and do a subsequent query, the new band will be appended to the list of bands if not already present in the list. It is recommended you perform a GPRS attach procedure which provides a more comprehensive band list (if the phone is capable and the TA or LA is GPRS licensed) to yield the best possible supported band information. It is also recommended that you clear this band information when you change phones using the CALL:MS:REPorted:CLEar command to prevent the return of band information from the previous phone.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Range: PGSM, DCS, EGSM, GSM450, GSM480, GSM750, GSM850, T-GSM810, PCS, RGSM, and ""

*RST Setting

"" (null string)

Requirements

GSM/GPRS/

EGPRS TA

Revision: A.01 and above

Revision A.06 adds the T-GSM810 band.

GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Revision D.03 adds the T-GSM810 band.

Programming Example

OUTPUT 714;"CALL:MS:REPORTED:SBAND?"

CALL:MS:REPorted:SBANd:EPSK?

Function

GSM TA

This command is not applicable to the GSM Test Application.

GPRS TA

This command queries for the frequency bands supported by the mobile station for the 8PSK (EDGE) modulation schemes. The 8PSK supported band information is acquired during the GPRS attach procedure only. The phone under test must be GPRS capable and the TA or LA must be licensed for GPRS or EGPRS or this query will return an empty string ("" null string).

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Range: PGSM, DCS, EGSM, GSM450, GSM480, GSM750, GSM850, T-GSM810, PCS, RGSM, and ""

*RST Setting

"" (null string)

Requirements

GSM/GPRS/

EGPRS TA

Revision: A.01 and above

Revision A.06 adds the T-GSM810 band.

GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Revision D.03 adds the T-GSM810 band.

Programming Example

OUTPUT 714;"CALL:MS:REPORTED:SBAND:EPSK?"

CALL:MS:REPorted:SVARiance:AVERage?

Function

GSM

This command is not applicable to the GSM Test Application.

GPRS TA

This command is not applicable to the GPRS Test Application.

EGPRS TA

This command is not applicable to the EGPRS Test Application.

GSM/GPRS LA

IT IS RECOMMENDED to use
CALL:MS:REPorted:MEASurement:(PACCH|PACChannel):SVARiance:AVERage?
 instead in order to fit more consistently with the new commands. This command remains valid to facilitate backwards compatibility.

Queries the value reported by the MS representing the average received signal level variance.

EGPRS LA

Query

Range: 0 to 63 and 9.91E+37

Resolution: 1

The formula: SVAR * 0.25 dB2 maps the MS reported value to the actual received signal level variance.

*RST Setting

9.91E+37 (NAN)

Requirements

GSM/GPRS/

EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:MS:REPorted:SVARiance:AVERage?"

CALL:MS:REPorted:TADVance[:LAST]?

Function

GSM TA

IT IS RECOMMENDED to use
CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):TADVance[:LAST]?
 instead in order to fit more consistently with the new commands. This command remains valid to facilitate backwards compatibility.

This command queries the mobile station for the last TCH Timing Advance actually used by the mobile station. See
CALL:(PDTCH|PDTChannel):MS:TADVance[:SELected]
.

GSM/GPRS LA

EGPRS LA

GPRS TA

This command is not applicable to GPRS.

EGPRS TA

This command is not applicable to EGPRS.

Query

Range: 0 to 63 and 9.91E+37

Resolution: 1

*RST Setting

0

Requirements

GSM/GPRS/

EGPRS TA

Revision: A.01 and above

GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:MS:REPORTED:TADVANCE:LAST?"

CALL:MS:REPorted:TADVance:NEW?

Function

GSM TA

IT IS RECOMMENDED to use
CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):TADVance:NEW?
 instead in order to fit more consistently with the new commands. This command remains valid to facilitate backwards compatibility.

This command queries the mobile station reported timing advance from the SACCH report. Each time the :NEW? query is sent the test set hangs until report results from that measurement period are sent or until 10 seconds have elapsed at which point the test set times out.

This will return 3 variables; the first two are ignored while the value from the third new query is the valid variable.

GSM/GPRS LA

EGPRS LA

GPRS TA

This command is not applicable to GPRS.

EGPRS TA

This command is not applicable to EGPRS.

Query

Range: 0 to 63 and 9.91E+37

Resolution: 1

*RST Setting

9.91E+37 (NAN)

Requirements

GSM/GPRS/

EGPRS TA

Revision: A.01 and above

GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:MS:REPORTED:TADVANCE:NEW?;NEW?;NEW?"
! The third result is valid.

CALL:MS:REPorted:TXLevel[:LAST]?

Function

GSM TA

IT IS RECOMMENDED to use
CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):TXLevel[:LAST]?
 instead in order to fit more consistently with the new commands. This command remains valid to facilitate backwards compatibility.

This command queries the mobile station for the last reported transmit level.

GSM/GPRS LA

EGPRS LA

GPRS TA

This command is not applicable to GPRS.

EGPRS TA

This command is not applicable to EGPRS.

Query

Range: 0 to 31 and 9.91E+37

Resolution: 1

*RST Setting

9.91E+37 (NAN)

Requirements

GSM/GPRS/

EGPRS TA

Revision: A.01 and above

GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:MS:REPORTED:TXLEVEL:LAST?"

CALL:MS:REPorted:TXLevel:NEW?

Function

GSM TA

IT IS RECOMMENDED to use
CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):TXLevel:NEW?
 instead in order to fit more consistently with the new commands. This command remains valid to facilitate backwards compatibility.

This command queries the mobile station reported transmit level from the SACCH report. Each time the :NEW? query is sent the test set hangs until report results from that measurement period are sent or until 10 seconds have elapsed at which point the test set times out.

This will return 3 variables; the first two are ignored while the value from the third new query is the valid variable.

GSM/GPRS LA

EGPRS LA

GPRS TA

This command is not applicable to GPRS.

EGPRS TA

This command is not applicable to EGPRS.

Query

Range: 0 to 31 and 9.91E+37

Resolution: 1

*RST Setting

9.91E+37 (NAN)

Requirements

GSM/GPRS/

EGPRS TA

Revision: A.01 and above

GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:MS:REPorted:TXLevel:NEW?"
! The third result is valid.

CALL:MS:TADVance[:SELected]

CALL:MS:TADVance:(DCS|EGSM|GSM450|GSM480|GSM750|GSM850|PCS|PGSM|RGSM|TGSM810)

Function

GSM TA

This command sets the mobile station's uplink TCH timing advance for the band already selected. See
GSM Frequency Banded Parameters
.

GSM/GPRS LA

EGPRS LA

GPRS TA

This command is not applicable to GPRS.

EGPRS TA

This command is not applicable to EGPRS.

Query

Range: 0 to 63

Resolution: 1

*RST Setting

0

Requirements

GSM/GPRS/

EGPRS TA

Revision: A.01 and above

A.06 adds the TGSM810 band.

GSM/GPRS/ EGPRS LA

Revision: C.01 and above

D.03 adds the TGSM810 band.

Programming Example

OUTPUT 714;"CALL:MS:TADVANCE 3"
! Sets the mobile station TCH Timing Advance to 3 on the uplink.

CALL:MS:TADVance:DCS

Function

GSM TA

This command sets the mobile station's uplink TCH timing advance for the DCS band. See
GSM Frequency Banded Parameters
.

GSM/GPRS LA

EGPRS LA

GPRS TA

This command is not applicable to GPRS.

EGPRS TA

This command is not applicable to EGPRS.

Setting

Range: 0 to 31 (default 10)

Resolution: 1

Query

Range: 0 to 31

Resolution: 1

*RST Setting

TADVance: 0

Requirements

GSM/GPRS/

EGPRS TA

Revision: A.01 and above

GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:MS:TADVANCE:DCS 8"

CALL:MS:TADVance:EGSM

Function

GSM TA

This command sets the mobile station's uplink TCH timing advance for the EGSM band. See
GSM Frequency Banded Parameters
.

GSM/GPRS LA

EGPRS LA

GPRS TA

This command is not applicable to GPRS.

EGPRS TA

This command is not applicable to EGPRS.

Setting

Range: 0 to 31 (default 15)

Resolution: 1

Query

Range: 0 to 31

Resolution: 1

*RST Setting

TADVance: 0

Requirements

GSM/GPRS/

EGPRS TA

Revision: A.01 and above

GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:MS:TADVANCE:EGSM 20"

CALL:MS:TADVance:GSM450

Function

GSM TA

This command sets the mobile station's uplink TCH timing advance for the GSM450 band. See
GSM Frequency Banded Parameters
.

GSM/GPRS LA

EGPRS LA

GPRS TA

This command is not applicable to GPRS.

EGPRS TA

This command is not applicable to EGPRS.

Setting

Range: 0 to 31 (default 15)

Resolution: 1

Query

Range: 0 to 31

Resolution: 1

*RST Setting

TADVance: 0

Requirements

GSM/GPRS/

EGPRS TA

Revision: A.01 and above

GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:MS:TADVANCE:GSM450 20"

CALL:MS:TADVance:GSM480

Function

GSM TA

This command sets the mobile station's uplink TCH timing advance for the GSM480 band. See
GSM Frequency Banded Parameters
.

GSM/GPRS LA

EGPRS LA

GPRS TA

This command is not applicable to GPRS.

EGPRS TA

This command is not applicable to EGPRS.

Setting

Range: 0 to 31 (default 15)

Resolution: 1

Query

Range: 0 to 31

Resolution: 1

*RST Setting

TADVance: 0

Requirements

GSM/GPRS/

EGPRS TA

Revision: A.01 and above

GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:MS:TADVANCE:GSM480 20"

CALL:MS:TADVance:GSM750

Function

GSM TA

This command sets the mobile station's uplink TCH timing advance for the GSM750 band. See
GSM Frequency Banded Parameters
.

GSM/GPRS LA

EGPRS LA

GPRS TA

This command is not applicable to GPRS.

EGPRS TA

This command is not applicable to EGPRS.

Setting

Range: 0 to 31 (default 15)

Resolution: 1

Query

Range: 0 to 31

Resolution: 1

*RST Setting

TADVance: 0

Requirements

GSM/GPRS/

EGPRS TA

Revision: A.01 and above

GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:MS:TADVANCE:GSM750 20"

CALL:MS:TADVance:GSM850

Function

GSM TA

This command sets the mobile station's uplink TCH timing advance for the GSM850 band. See
GSM Frequency Banded Parameters
.

GSM/GPRS LA

EGPRS LA

GPRS TA

This command is not applicable to GPRS.

EGPRS TA

This command is not applicable to EGPRS.

Setting

Range: 0 to 31 (default 15)

Resolution: 1

Query

Range: 0 to 31

Resolution: 1

*RST Setting

TADVance: 0

Requirements

GSM/GPRS/

EGPRS TA

Revision: A.01 and above

GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:MS:TADVANCE:GSM850 20"

CALL:MS:TADVance:PCS

Function

GSM TA

This command sets the mobile station's uplink TCH timing advance for the PCS band. See
GSM Frequency Banded Parameters
.

GSM/GPRS LA

EGPRS LA

GPRS TA

This command is not applicable to GPRS.

EGPRS TA

This command is not applicable to EGPRS.

Setting

Range: 0 to 31 (default 15)

Resolution: 1

Query

Range: 0 to 31

Resolution: 1

*RST Setting

TADVance: 0

Requirements

GSM/GPRS/

EGPRS TA

Revision: A.01 and above

GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:MS:TADVANCE:PCS 20"

CALL:MS:TADVance:PGSM

Function

GSM TA

This command sets the mobile station's uplink TCH timing advance for the PGSM band. See
GSM Frequency Banded Parameters
.

GSM/GPRS LA

EGPRS LA

GPRS TA

This command is not applicable to GPRS.

EGPRS LA

This command is not applicable to EGPRS.

Setting

Range: 0 to 31 (default 15)

Resolution: 1

Query

Range: 0 to 31

Resolution: 1

*RST Setting

TADVance: 0

Requirements

GSM/GPRS/

EGPRS TA

Revision: A.01 and above

GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:MS:TADVANCE:PGSM 22"

CALL:MS:TADVance:RGSM

Function

GSM TA

This command sets the mobile station's uplink TCH timing advance for the RGSM band. See
GSM Frequency Banded Parameters
.

GSM/GPRS LA

EGPRS LA

GPRS TA

This command is not applicable to GPRS.

EGPRS TA

This command is not applicable to EGPRS.

Setting

Range: 0 to 31 (default 15)

Resolution: 1

Query

Range: 0 to 31

Resolution: 1

*RST Setting

TADVance: 0

Requirements

GSM/GPRS/

EGPRS TA

Revision: A.01 and above

GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:MS:TADVANCE:RGSM 20"

CALL:MS:TADVance:TGSM810

Function

GSM TA

This command sets the mobile station's uplink TCH timing advance for the TGSM810 band. See
GSM Frequency Banded Parameters
.

GSM/GPRS LA

EGPRS LA

GPRS TA

This command is not applicable to GPRS.

EGPRS TA

This command is not applicable to EGPRS.

Setting

Range: 0 to 63 (default 0)

Resolution: 1

Query

Range: 0 to 63

Resolution: 1

*RST Setting

TADVance: 0

Requirements

GSM/GPRS/

EGPRS TA

Revision: A.06 and above

GSM/GPRS/ EGPRS LA

Revision: D.03 and above

Programming Example

OUTPUT 714;"CALL:MS:TADVANCE:TGSM810 31"

CALL:MS:TX:BURSt:GPLength

Function

GSM TA

This command is not applicable to GSM.

GPRS TA

This command defines the width of the guard period between the two uplink bursts. The command and parameters to use are determined by the mobile station segmentation of the TDMA frame and the particular bursts transmitted in the multislot configuration.

Whether or not you need to use this command depends on your mobile station.

If the mobile station segments the frame into six bursts of 156 bit duration and two bursts of 157 bit duration then this command should be set as follows:

  •
Use GPL10 if the first burst in the multislot configuration is timeslot 4 or 7.
    •

  •

Use GPL9 if the first burst in the multislot configuration is in any other timeslot.
    •

EGPRS TA

GSM/GPRS LA

EGPRS LA

Setting

Range: GPL9 | GPL10

Query

Range: GPL9 | GPL10

*RST Setting

GPL9

Requirements

GSM/GPRS/

EGPRS TA

Revision: A.01 and above

GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:MS:TX:BURSt:GPLength GPL9"
! Sets the Guard Period length to 9 bits.

CALL:MS:TX:FRAMe:SEGMentation

Function

GSM TA

This command sets/queries the TDMA frame structure being used by the mobile station. This user setting allows the Power versus Time measurement to accurately measure a multislot uplink. The possible settings are:

Symmetric: each timeslot occupies 156.25 symbols

Asymmetric: timeslots are 156 symbols expect for 0 and 4, which are 157

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Setting

Range: ASYMmetric | SYMMetric

Query

Range: ASYM | SYMM

*RST Setting

ASYM

Requirements

GSM/GPRS/

EGPRS TA

Revision: A.03 and above

GSM/GPRS/ EGPRS LA

Revision: C.03 and above

Programming Example

OUTPUT 714;"CALL:MS:TX:FRAMe:SEGMentation SYMM"
! Sets the TDMA frame structure to Symmetric.

CALL:MS:TXLevel[:SELected]

CALL:MS:TXLevel:(DCS|EGSM|GSM450|GSM480|GSM750|GSM850|PCS|PGSM|RGSM|TGSM810)

Function

GSM TA

This command selects the TCH mobile station uplink power control level for the specified band. See
GSM Frequency Banded Parameters
.

GSM/GPRS LA

EGPRS LA

GPRS TA

This command is not applicable to GPRS.

EGPRS TA

This command is not applicable to EGPRS.

Setting

Range: 0 to 31

Resolution: 1

Query

Range: 0 to 31

Resolution: 1

*RST Setting

Depends on the band (the default band is PGSM):

PGSM, EGSM RGSM, GSM450, GSM480, GSM750, GSM850, TGSM810 bands:15,

DCS and PCS bands: 10

Requirements

GSM/GPRS/

EGPRS TA

Revision: A.01 and above

Revision A.06 adds the TGSM810 band.

GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Revision D.03 adds the TGSM810 band.

Programming Example

OUTPUT 714;"CALL:MS:TXLEVEL:SELECTED 10"

CALL[:CELL]:MS:TXLevel:CCHannel[:SELected]

CALL[:CELL]:MS:TXLevel:CCHannel:(DCS|EGSM|GSM450|GSM480|GSM750|GSM850|PCS|PGSM|RGSM|TGSM810)

Function

GSM TA

IT IS RECOMMENDED to use
CALL[:CELL]:BCHannel:MS:TXLevel[:SELected]
 instead in order to fit more consistently with the new commands. This command remains valid to facilitate backwards compatibility.

This command sets the maximum Control Channel power that the mobile station can use for access bursts for the specified band. See
GSM Frequency Banded Parameters
.

This setting is only accessible when the Cell Operating Mode parameter is set to Off (see
CALL:OPERating:MODE
).

This must be set to 0 if you want to use the DCS power offset command
CALL[:CELL]:MS:CCHannel:POWer:OFFSet:DCS
 to set the control channel power level in 2 dB steps from 0 to 6 dB. Setting a value with CALL:MS:TXL:CCH:DCS will not allow use of the power offset command. See
Access Burst Power Control
.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Setting

(Depends on the band.)

DCS:

  •
Range: 0 to 28, Resolution: 1
    •

PCS:

  •
Range: 0 to 15, 30, and 31, Resolution: 1
    •

All other bands:

  •
Range: 0 to 15, 30, and 31, Resolution: 1
    •

Query

(Depends on the band.)

DCS:

  •
Range: 0 to 28, Resolution: 1
    •

PCS:

  •
Range: 0 to 15, 30, and 31, Resolution: 1
    •

All other bands:

  •
Range: 0 to 15, 30, and 31, Resolution: 1
    •

*RST Setting

0

Requirements

GSM/GPRS/

EGPRS TA

Revision: A.01 and above

Revision A.06 adds the TGSM810 band.

GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Revision D.03 adds the TGSM810 band.

Programming Example

OUTPUT 714;"CALL:MS:TXLEVEL:CCHannel:SELECTED 10"


CALL:NCCode

CALL:NCCode

GPIB Command Conventions

  • CALL[:CELL]:NCCode[:SELected]
  • CALL[:CELL]:NCCode:GSM

CALL[:CELL]:NCCode[:SELected]

Function

GSM TA

Sets/queries the Network Color Code for the active (that is the selected) format. See Configuring the Broadcast Channel (BCH) .

This can only be set when the Cell Operating Mode is set to Off (see CALL:OPERating:MODE ).

GPRA TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Setting

Range: 0 to 7

Resolution: 1

Query

Range: 0 to 7

Resolution: 1

*RST Setting

1
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:CELL:NCCODE:SELECTED 2"

CALL[:CELL]:NCCode:GSM

Function

GSM TA

Sets/queries the Network Color Code. See Configuring the Broadcast Channel (BCH) .

This can only be set when the Cell Operating Mode is set to Off (see CALL:OPERating:MODE ).

GSM/GPRS LA

EGPRS TA

GPRS TA

This command is not applicable to GPRS.

EGPRS LA

This command is not applicable to EGPRS.

Setting

Range: 0 to 7

Resolution: 1

Query

Range: 0 to 7

Resolution: 1

*RST Setting

1
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:CELL:NCCODE 2"


CALL:OPERating

CALL:OPERating

GPIB Command Conventions

  • CALL:OPERating:MODE

CALL:OPERating:MODE

Function

GSM TA

This command sets/queries the operating mode (behavior) of the test set:

  • CALL sets the operating mode to Active Cell (see Active Cell Operating Mode ).

  • GBTest sets the operating mode to GSM BCH Test Mode (see GSM Test Mode Operation ).

  • GBTTest sets the operating mode to GSM BCH+TCH Test Mode.

  • CW sets the operating mode to continuous wave.

  • OFF sets the operating mode to OFF (see Cell Off ).

GPRS TA

This command sets/queries the operating mode (behavior) of the test set:

  • CALL sets the operating mode to Active Cell (see Active Cell Operating Mode ). The query returns CALL.

  • PBTest sets the operating mode to GPRS BCH Test Mode (see GPRS BCH ).

  • PBPTest sets the operating mode to GPRS BCH+PDTCH Test Mode (see GPRS BCH+PDTCH ).

  • CW sets the operating mode to continuous wave.

  • OFF sets the operating mode to OFF (see Cell Off ).

EGPRS TA

This command sets/queries the operating mode (behavior) of the test set:

  • CALL sets the operating mode to Active Cell (see Active Cell Operating Mode ). The query returns CALL.

  • EBTest sets the operating mode to EGPRS BCH Test Mode (see EGPRS BCH ).

  • EBPTest sets the operating mode to EGPRS BCH+PDTCH Test Mode (see EGPRS BCH + PDTCH ).

  • CW sets the operating mode to continuous wave.

  • OFF sets the operating mode to OFF (see OFF Behavior ).

GSM/GPRS LA

This command sets/queries the operating mode (behavior) of the test set:

  • CALL sets the operating mode to Active Cell (see Active Cell Operating Mode ). The query returns CALL.

  • GBTest sets the operating mode to GSM BCH Test Mode (see GSM Test Mode Operation ).

  • GBTTest sets the operating mode to GSM BCH+TCH Test Mode (see GSM BCH+TCH ).

  • PBTest sets the operating mode to GPRS BCH Test Mode (see GPRS BCH ).

  • PBPTest sets the operating mode to GPRS BCH+PDTCH Test Mode (see GPRS BCH+PDTCH ).

  • PBPTTest sets the operating mode to GPRS BCH+PDTCH+TCH Test Mode (see GPRS BCH+PDTCH+TCH .

  • CW sets the operating mode to continuous wave.

  • OFF sets the operating mode to OFF (see Cell Off ).

EGPRS LA

This command sets/queries the operating mode (behavior) of the test set:

  • CALL sets the operating mode to Active Cell (see Active Cell Operating Mode ). The query returns CALL.

  • GBTest sets the operating mode to GSM BCH Test Mode (see GSM Test Mode Operation ).

  • GBTTest sets the operating mode to GSM BCH+TCH Test Mode.

  • PBTest sets the operating mode to GPRS BCH Test Mode (see GPRS BCH ).

  • PBPTest sets the operating mode to GPRS BCH+PDTCH Test Mode (see GPRS BCH+PDTCH ).

  • EBTest sets the operating mode to EGPRS BCH Test Mode (see EGPRS BCH ).

  • EBPTest sets the operating mode to EGPRS BCH+PDTCH Test Mode (see EGPRS BCH + PDTCH ).

  • PBPTTest sets the operating mode to GPRS BCH+PDTCH+TCH Test Mode (see GPRS BCH+PDTCH+TCH ).
  • EBPTTest sets the operating mode to EGPRS BCH+PDTCH+TCH Test Mode (see EGPRS BCH + PDTCH + TCH ).

  • CW sets the operating mode to continuous wave

  • OFF sets the operating mode to OFF (see OFF Behavior ).

Setting

(must have license for the application to access the setting)

GSM TA

Range: CALL | CW | GBTest | GBTTest | OFF

GPRS TA

Range: CALL | CW | PBTest | PBPTest | OFF

EGPRS TA

Range: CALL | CW | EBTest | EBPTest | OFF

GSM/GPRS LA Range: CALL | CW | GBTest | GBTTest | PBTest | PBPTest | PBPTTest | OFF

EGPRS LA

 Range: CALL | CW | EBTest | EBPTest | GBTest | GBTTest | PBTest | PBPTest | PBPTTest | EBPTTest | OFF

Query

 GSM TA

Range: CALL | CW | GBT | GBTT| OFF

GPRS TA

Range: CALL | CW | PBT| PBPT| OFF

EGPRS TA

Range: CALL | CW | EBT | EBPT | OFF

GSM/GPRS LA

 Range: CALL | CW | GBT| GBST |GBTT| PBT | PBPT | PBPTT | OFF

EGPRS LA

 Range: CALL | CW | EBT | EBPT | GBT | GBTT | PBT | PBPT| PBPTT| EBPTT | OFF

*RST Setting

CALL
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above

Revision A.06 adds PBPTTest and EBPTTest
GSM/GPRS/ EGPRS LA

Revision: C.01 and above
Revision E.01 adds PBPTTest and EBPTTest.

Programming Example (GSM)

OUTPUT 714;"CALL:OPERATING:MODE GBTest"
! Sets the operating mode to GSM Test Mode BCH.

Programming Example (GPRS)

OUTPUT 714;"CALL:OPERATING:MODE PBPTest"
! Sets the operating mode to GPRS Test Mode BCH + PDTCH.

Related Topics

Test Mode Operating Modes

Active Cell Operating Mode

Configuring the Serving Cell


CALL:ORIGinate

CALL:ORIGinate

GPIB Command Conventions

  • CALL:ORIGinate
  • CALL:ORIGinate:TIMeout

CALL:ORIGinate

Function

GSM TA

Performs a BS Originated call. See Call Processing Event Synchronization .

Additional commands can be appended to aid in controller/Mobile Station synchronization. See Call Processing Subsystem Overlapped Command Synchronization Commands for examples.

GSM/GPRS LA

EGPRS LA

GPRS TA

EGPRS TA

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:ORIGinate:SEQuential"
! Orignates a base station call.
! Appending SEQuential to this command
! causes the command to be performed sequentially.

CALL:ORIGinate:TIMeout

Function

GSM TA

This command sets/queries the Call Originate Timeout parameter. This parameter sets the Timer 301 (T301), which controls the time the test set alerts a mobile station when attempting a mobile terminated call.

The Call Originate Timeout parameter may be set in any operating mode, but is only used for mobile terminated calls when the operating mode is Active Cell ( Serving Cell GSM, GPRS or EGPRS). See How Do I Change Paging Parameters? for information on how to manually configure this the Call Originate Timeout Parameter.

GSM/GPRS LA

EGPRS LA

GPRS TA

This command is not applicable to GPRS.

EGPRS TA

This command is not applicable to EGPRS.

Setting

Range: 1-999 seconds

Resolution: 1 second

Query

Range: 1-999 seconds

Resolution: 1 second

*RST Setting

 10 seconds

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.04 and above
GSM/GPRS/ EGPRS LA

Revision: D.01 and above

Programming Example

OUTPUT 714;"CALL:ORIGinate:TIMeout"
! Sets the Call Originate Timeout parameter to 15 seconds.


CALL:(PACCH|PACChannel)

CALL:(PACCH|PACChannel)

Last updated: December 3, 2008

GPIB Command Conventions

  • CALL:(PACCH|PACChannel):PSI:PERiodic:LIST
  • CALL:(PACCH|PACChannel):PSI:PERiodic:TIME
  • CALL:(PACCH|PACChannel):PSINdication:RESPonse
  • CALL:(PACCH|PACChannel):PSInfo
  • CALL:(PACCH|PACChannel):PSInfo:CUSTom:PSI1|2|3|5|8|13|14[:STATe]
  • CALL:(PACCH|PACChannel):PSInfo:CUSTom:PSI3:BIS[:STATe]
  • CALL:(PACCH|PACChannel):PSInfo:CUSTom:PSI3:QUATer[:STATe]
  • CALL:(PACCH|PACChannel):SI
  • CALL:(PACCH|PACChannel):SI:CUSTom:SI1|2|3|4|13[:STATe]
  • CALL:(PACCH|PACChannel):SI:CUSTom:SI2:BIS[:STATe]
  • CALL:(PACCH|PACChannel):SI:CUSTom:SI2:TER[:STATe]
  • CALL:(PACCH|PACChannel):SI:CUSTom:SI2:QUATer[:STATe]

CALL:(PACCH|PACChannel):PSI:PERiodic:LIST

Function

GSM TA

 This command is not applicable to the GSM TA.

GPRS TA

 This command is not applicable to the GPRS TA.

EGPRS TA

 This command is not applicable to the EGPRS TA.

GSM/GPRS LA

This command sets/queries the manner that the PSI messages are sent. See Periodic PSI List for more information.

EGPRS LA

Setting

Range: STANdard|CUSTom

Query

Range: STAN|CUST

*RST Setting

 STANdard
Requirements GSM/GPRS/ EGPRS LA

Revision: F.00.37 and above

Programming Example

OUTPUT 714;"CALL:PACCH:PSI:PERiodic:LIST STANdard"
! The PSI messages are sent in the standard manner.

CALL:(PACCH|PACChannel):PSI:PERiodic:TIME

Function

GSM TA

 This command is not applicable to the GSM TA.

GPRS TA

 This command is not applicable to the GPRS TA.

EGPRS TA

 This command is not applicable to the EGPRS TA.

GSM/GPRS LA

This command sets/queries the repetition rate of periodic PSI and/or SI messages which are transmitted on the PACCH. See Periodic (P)SI repetition time for more information.

EGPRS LA

Setting

Range: 1 to 60

Resolution: 1

Query

Range: 1 to 60

*RST Setting

 10
Requirements GSM/GPRS/ EGPRS LA

Revision: F.00.37 and above

Programming Example

OUTPUT 714;"CALL:PACCH:PSI:PERiodic:TIME 10"
! The periodic PSI and/or SI message is transmitted every 10 seconds.

CALL:(PACCH|PACChannel):PSINdication:RESPonse

Function

GSM TA

 This command is not applicable to the GSM TA.

GPRS TA

 This command is not applicable to the GPRS TA.

EGPRS TA

 This command is not applicable to the EGPRS TA.

GSM/GPRS LA

This command sets/queries the behavior of the test set in response to a Packet SI Status Indication or Packet PSI Status Indication message received from the DUT. See Packet (P)SI Status Indication Response for more information.

EGPRS LA

Setting

Range: MSRequest|CUSTom

Query

Range: MSR|CUST

*RST Setting

 MSReqest
Requirements GSM/GPRS/ EGPRS LA

Revision: F.00.37 and above

Programming Example

OUTPUT 714;"CALL:PACCH:PSINdication:RESPonse CUSTom"
! The test set will transmit customized PSI messages on the PACCH.

CALL:(PACCH|PACChannel):PSInfo

Function

GSM TA

This command sets/queries whether or not the test set will send Packet System Information (PSI) messages on the PACCH. This setting is only applicable when the Operating Mode is set to Active Cell ( Serving Cell GSM, GPRS, or EGPRS). See Active Cell Operating Mode for more details.

This command has three settings:

  • Auto - PSI messages are transmitted on the PACCH except during SRB Loopback data connections.
  • ON - PSI messages are always transmitted on the PACCH.
  • OFF - PSI messages are never transmitted on the PACCH

See Send Packet System Information on PACCH for more information.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Range: AUTO|ON|OFF

*RST Setting

 AUTO

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.05 and above
GSM/GPRS/ EGPRS LA

Revision: D.02 and above

Programming Example

OUTPUT 714;"CALL:PACCH:PSInfo ON"
! Always transmit PSI messages on the PACCH.

CALL:(PACCH|PACChannel):PSInfo:CUSTom:PSI1|2|3|5|8|13|14[:STATe]

Function

GSM TA

 This command is not applicable to the GSM TA.

GPRS TA

 This command is not applicable to the GPRS TA.

EGPRS TA

 This command is not applicable to the EGPRS TA.

GSM/GPRS LA

This command sets/queries whether the PSI message (PSI 1, PSI 2, PSI 3, PSI 5,PSI 8, PSI 13 or PSI 14) can be selected for transmission. See Custom PSI List for more information.

EGPRS LA

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

 0|OFF
Requirements GSM/GPRS/ EGPRS LA

Revision: F.00.37 and above

Programming Example

OUTPUT 714;"CALL:PACCH:PSInfo:CUSTom:PSI1 ON"
! PSI 1 message is selected to be transmitted for both periodic transmission on an available PACCH
! channel or as a pre-defined response to a Packet SI Status Indication message received from the DUT.

CALL:(PACCH|PACChannel):PSInfo:CUSTom:PSI3:BIS[:STATe]

Function

GSM TA

 This command is not applicable to the GSM TA.

GPRS TA

 This command is not applicable to the GPRS TA.

EGPRS TA

 This command is not applicable to the EGPRS TA.

GSM/GPRS LA

This command sets/queries whether the PSI 3bis message can be selected for transmission. See Custom PSI List for more information.

EGPRS LA

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

 0|OFF
Requirements GSM/GPRS/ EGPRS LA

Revision: F.00.37 and above

Programming Example

OUTPUT 714;"CALL:PACCH:PSInfo:CUSTom:PSI3:BIS ON"
! PSI 3bis message is selected to be transmitted for both periodic transmission on an available PACCH
! channel or as a pre-defined response to a Packet SI Status Indication message received from the DUT.

CALL:(PACCH|PACChannel):PSInfo:CUSTom:PSI3:QUATer[:STATe]

Function

GSM TA

 This command is not applicable to the GSM TA.

GPRS TA

 This command is not applicable to the GPRS TA.

EGPRS TA

 This command is not applicable to the EGPRS TA.

GSM/GPRS LA

This command sets/queries whether the PSI 3quater message can be selected for transmission. See Custom PSI List for more information.

EGPRS LA

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

 0|OFF
Requirements GSM/GPRS/ EGPRS LA

Revision: F.00.37 and above

Programming Example

OUTPUT 714;"CALL:PACCH:PSInfo:CUSTom:PSI3:QUATer ON"
! PSI 3quater message is selected to be transmitted for both periodic transmission
! on an available PACCH channel or as a pre-defined response to a Packet SI Status Indication
! message received from the DUT.

CALL:(PACCH|PACChannel):SI

Function

GSM TA

 This command is not applicable to the GSM TA.

GPRS TA

 This command is not applicable to the GPRS TA.

EGPRS TA

 This command is not applicable to the EGPRS TA.

GSM/GPRS LA

This command sets/queries whether or not the test set will send SI messages encapsulated in Packet Serving Cell SI messages on the PACCH.

This command has three settings:

  • Auto - SI messages encapsulated in Packet Serving Cell SI messages are transmitted on the PACCH except during SRB Loopback data connections.
  • ON - SI messages encapsulated in Packet Serving Cell SI messages are always transmitted on the PACCH.
  • OFF - SI messages encapsulated in Packet Serving Cell SI messages are never transmitted on the PACCH

See Send encapsulated SI on PACCH for more information.

EGPRS LA

Query

Range: AUTO|ON|OFF

*RST Setting

 AUTO

Requirements

 GSM/GPRS/ EGPRS LA

Revision: F.00.37 and above

Programming Example

OUTPUT 714;"CALL:PACCH:SI ON"
! Always transmit SI messages encapsulated in Packet Serving Cell SI messages on the PACCH.

CALL:(PACCH|PACChannel):SI:CUSTom:SI1|2|3|4|13[:STATe]

Function

GSM TA

 This command is not applicable to the GSM TA.

GPRS TA

 This command is not applicable to the GPRS TA.

EGPRS TA

 This command is not applicable to the EGPRS TA.

GSM/GPRS LA

This command sets/queries whether the SI message (SI 1, SI 2, SI 3, SI 4 or SI 13) can be selected for transmission. See Custom SI List for more information.

EGPRS LA

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

 0|OFF
Requirements GSM/GPRS/ EGPRS LA

Revision: F.00.37 and above

Programming Example

OUTPUT 714;"CALL:PACCH:SI:CUSTom:SI1 ON"
! SI 1 message is selected to be transmitted for both periodic transmission on an available PACCH
! channel or as a pre-defined response to a Packet SI Status Indication message received from the DUT.

CALL:(PACCH|PACChannel):SI:CUSTom:SI2:BIS[:STATe]

Function

GSM TA

 This command is not applicable to the GSM TA.

GPRS TA

 This command is not applicable to the GPRS TA.

EGPRS TA

 This command is not applicable to the EGPRS TA.

GSM/GPRS LA

This command sets/queries whether the SI 2bis message can be selected for transmission. See Custom SI List for more information.

EGPRS LA

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

 0|OFF
Requirements GSM/GPRS/ EGPRS LA

Revision: F.00.37 and above

Programming Example

OUTPUT 714;"CALL:PACCH:SI:CUSTom:SI2:BIS ON"
! SI 2bis message is selected to be transmitted for both periodic transmission on an available PACCH
! channel or as a pre-defined response to a Packet SI Status Indication message received from the DUT.

CALL:(PACCH|PACChannel):SI:CUSTom:SI2:TER[:STATe]

Function

GSM TA

 This command is not applicable to the GSM TA.

GPRS TA

 This command is not applicable to the GPRS TA.

EGPRS TA

 This command is not applicable to the EGPRS TA.

GSM/GPRS LA

This command sets/queries whether the SI 2ter message can be selected for transmission. See Custom SI List for more information.

EGPRS LA

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

 0|OFF
Requirements GSM/GPRS/ EGPRS LA

Revision: F.00.37 and above

Programming Example

OUTPUT 714;"CALL:PACCH:SI:CUSTom:SI2:TER ON"
! SI 2ter message is selected to be transmitted for both periodic transmission on an available PACCH
! channel or as a pre-defined response to a Packet SI Status Indication message received from the DUT.

CALL:(PACCH|PACChannel):SI:CUSTom:SI2:QUATer[:STATe]

Function

GSM TA

 This command is not applicable to the GSM TA.

GPRS TA

 This command is not applicable to the GPRS TA.

EGPRS TA

 This command is not applicable to the EGPRS TA.

GSM/GPRS LA

This command sets/queries whether the SI 2quater message can be selected for transmission. See Custom SI List for more information.

EGPRS LA

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

 0|OFF
Requirements GSM/GPRS/ EGPRS LA

Revision: F.00.37 and above

Programming Example

OUTPUT 714;"CALL:PACCH:SI:CUSTom:SI2:QUATer ON"
! SI 2quater message is selected to be transmitted for both periodic transmission on an available PACCH
! channel or as a pre-defined response to a Packet SI Status Indication message received from the DUT.


CALL:PAGing

CALL:PAGing

GPIB Command Conventions

  • CALL:PAGing:IDENtity[:TYPE]
  • CALL:PAGing:IMSI
  • CALL:PAGing:MODE
  • CALL:PAGing:MFRames
  • CALL:PAGing:REPeat[:STATe][:SELected]
  • CALL:PAGing:REPeat[:STATe]:GSM

CALL:PAGing:IDENtity[:TYPE]

Function

 GSM TA This command is not applicable to GSM.

GPRS TA

This command is not applicable to GPRS.

EGPRS TA

This command is not applicable to EGPRS.

GSM/GPRS LA

This command sets/queries the Paging Identity Type parameter.

The Paging Identity Type setting determines whether the mobile station is paged using its IMSI or TMSI. This parameter can only be set while the Call Status is Idle and the Data Connection Status is Idle. When there is a service request for a MT Point-to-Point SMS (GPRS transport type), the identifier type used is P-TMSI (Packet TMSI), regardless of the setting for this parameter.

If you wish to page the mobile station using a TMSI, it is strongly recommended that the TMSI value be allocated to the mobile station when it registers with the test set to ensure that the mobile station recognizes the TMSI value used in the CS page request. The TMSI is allocated to the mobile station when it registers to the test set if TMSI Assignment is set to On . See Paging Parameters for more information.

The command to set the TMSI Assignment is CALL[:CELL]:TMSI:ASSignment .

The command to set the TMSI value is CALL[:CELL]:TMSI[:VALue] .
EGPRS LA

Setting

Range: IMSI|TMSI

Query

Range: IMSI|TMSI

*RST Setting

IMSI
Requirements GSM/GPRS/ EGPRS LA

Revision: E.00 and above

Programming Example

OUTPUT 714;"CALL:PAGing:IDENtity TMSI"
! Set paging identity to TMSI

CALL:PAGing:IMSI

Function

 GSM TA

Sets/queries the paging IMSI (International Mobile Subscriber Identity) field, used for paging the MS. The test set will stay in Active Cell Status (Setup Request), see Call Processing State Synchronization until the paging IMSI is returned if the state is on.

The paging IMSI is automatically updated by the test set during an MS originated call using the IMSI reported by the MS. If the MS has no SIM, the paging IMSI is left unchanged.

GSM/GPRS LA
EGPRS LA

GPRS TA

EGPRS TA

Setting

Range: a string of up to 15 decimal digits

Query

Range: a string of up to 15 decimal digits

*RST Setting

"001012345678901"

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:PAGing:IMSI `01012345678901'"
! Set paging IMSI to 01012345678901.

CALL:PAGing:MODE

Function

 GSM TA

Sets/queries the paging mode that the test set will use to page the MS. Some mobile stations can be set to a discontinuous reception mode (DRX), which configures the MS to look for a page in a pre-defined paging subchannel only.

When paging mode is set to Reorg (DRX off), the test set will page the MS on the paging channel in the next available paging subchannel without waiting for the defined paging group.

When paging mode is set to Normal (DRX on), the test set will page the MS on the correct paging subchannel defined by the mobile station's paging group.

GSM/GPRS LA
EGPRS LA

GPRS TA

EGPRS TA

Setting

Range: REORg | NORMal

Query

Range: REOR | NORM

*RST Setting

NORMal

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:PAGING:MODE REOR"
! MS will be sent a page on the next available paging subchannel

CALL:PAGing:MFRames

Function

 GSM TA

Sets/queries the number of multiframes between paging subchannels.

This parameter is used when the paging mode is normal. MFRames and IMSI are used to define the mobile station's paging group. The paging group determines when an MS can expect a page if paging mode is normal.

GSM/GPRS LA
EGPRS LA

GPRS TA

EGPRS TA

Setting

Range: 2 to 9

Resolution: 1

Query

Range: 2 to 9

Resolution: 1

*RST Setting

 2

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:PAGING:MFRAMES 5"
! Sets the number of multiframes between paging subchannels.

CALL:PAGing:REPeat[:STATe][:SELected]

Function

 GSM TA Sets/queries repeat paging state for the active (that is the selected) format. When the state is ON paging repeats until the test set receives a RACH. When the state is OFF the test set returns the No response to page timer T3113 expiry. See Fixed Timer Messages .

GSM/GPRS LA
EGPRS LA

GPRS TA

EGPRS TA

Setting

0 | OFF | 1 | ON

Query

0 | 1

*RST Setting

The *RST value of this command depends on the format that is currently active. For example, if the GSM format is currently active, the *RST value for this command is the same value as the equivalent command containing the :GSM format identifier.

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:PAGING:REPEAT:STATE:SELECTED ON"
! Turns paging repeat ON.

CALL:PAGing:REPeat[:STATe]:GSM

Function

 GSM TA Sets/queries repeat paging state for the GSM format. When the state is ON paging repeats until the test set receives a RACH. When the state is OFF the test set returns the No response to page timer T3113 expiry. See Fixed Timer Messages .

GSM/GPRS LA
EGPRS LA

GPRS TA

EGPRS TA

Setting

0 | OFF | 1 | ON

Query

0 | 1

*RST Setting

0 | OFF

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:PAGING:REPEAT:STATE:GSM ON"
! Turns paging repeat ON.


CALL:PBPTest

CALL:PBPTest

GPIB Command Conventions

  • CALL:PBPTest:RLCMac[:HEADer]:STATe

CALL:PBPTest:RLCMac[:HEADer]:STATe

Function

GSM TA

This command is not applicable to GSM.

GPRS TA

This command sets/queries the RLC/MAC header state. This setting is only applicable when the operating mode is set to GPRS Test Mode BCH+PDTCH (PBPTest).

If the RLC/MAC header state is changed when the operating mode is any mode other than GPRS BCH+PDTCH or EGPRS BCH+PDTCH, the setting is remembered until the next time you use GPRS BCH+PDTCH or EGPRS BCH+PDTCH.

EGPRS TA

GSM/GPRS LA

EGPRS LA

Setting

Range: 0 | OFF | 1 | ON

Query

Range: 0 | 1

*RST Setting

0|OFF
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:PBPTest:RLCMac:HEADer:STATe ON"
! Enables the RLC/MAC header.


CALL:PCAType

CALL:PCAType

GPIB Command Conventions

  • CALL[:CELL]:PCAType

CALL[:CELL]:PCAType

Function

GSM TA

 This command is not applicable to GSM.

GPRS TA

This command sets/queries the type of burst used to carry Packet Control Acknowledgments.

The settings for this command include:

  • ACCess

    When this setting is selected, the test set sends the Packet Control Acknowledgment message on four access bursts. You can also configure the format of the access bursts (8-bit or 11-bit) by using the command CALL[:CELL]:(PBCCH|PBCChannel):PRACh:LENGth .

  • NORMal

    When this setting is selected, the test set sends the Packet Control Acknowledgment message on a normal RLC/MAC block.
For more information, see Access Burst Type for Packet Control Acknowledgments .

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

Range: ACCess|NORMal

Query

Range: ACC|NORM

*RST Setting

 NORM
Requirements GSM/GPRS/ EGPRS LA

Revision: E.01 and above

Programming Example

OUTPUT 714;"CALL:PCAType ACCess"
! Configures the test set to send the Control Acknowledgment on four access bursts.


CALL:(PDTCH|PDTChannel)

CALL:(PDTCH|PDTChannel)

Last updated: December 3, 2008

GPIB Command Conventions

  • CALL:(PDTCH|PDTChannel)[:ARFCn][:SELected]

  • CALL:(PDTCH|PDTChannel):ARAC:PRRequest[:STATe]

  • CALL:(PDTCH|PDTChannel):BAND

  • CALL:(PDTCH|PDTChannel):CSCHeme
  • CALL:(PDTCH|PDTChannel):CSCHeme:DOWNink
  • CALL:(PDTCH|PDTChannel):CSCHeme:UPLink

  • CALL:(PDTCH|PDTChannel):CUSTom:DATA

  • CALL:(PDTChannel|PDTCH):DLDCarrier[:STATe]

  • CALL:(PDTCH|PDTChannel):DOWNlink:CORRuption[:STATe]
  • CALL:(PDTCH|PDTChannel):DOWNlink:CORRuption:BURSt<[1]|2|3|4>[:STATe]
  • CALL:(PDTCH|PDTChannel):DOWNlink:CORRuption:PATTern
  • CALL:(PDTCH|PDTChannel):DOWNlink:CORRuption:SEQuence:CBURsts
  • CALL:(PDTCH|PDTChannel):DOWNlink:CORRuption:SEQuence:LENGth
  • CALL:(PDTCH|PDTChannel):DOWNlink:CORRuption:SYMBol:LENGth
  • CALL:(PDTCH|PDTChannel):DOWNlink:CORRuption:SYMBol:STARt

  • CALL:(PDTCH|PDTChannel):DTMode:ARFCn[:SELected]
  • CALL:(PDTCH|PDTChannel):DTMode:BAND
  • CALL:(PDTCH|PDTChannel):DTMode:CSCHeme
  • CALL:(PDTCH|PDTChannel):DTMode:CSCHeme:DOWNlink
  • CALL:(PDTCH|PDTChannel):DTMode:CSCHeme:UPLink
  • CALL:(PDTCH|PDTChannel):DTMode:CSWitched:HRSPeech:SCHannel
  • CALL:(PDTCH|PDTChannel):DTMode:CSWitched:MS:TXLevel[:SELected]
  • CALL:(PDTCH|PDTChannel):DTMode:CSWitched:TSLot
  • CALL:(PDTCH|PDTChannel):DTMode:FHOPping[:STATe]
  • CALL:(PDTCH|PDTChannel):DTMode:MCSCheme
  • CALL:(PDTCH|PDTChannel):DTMode:MS:GAMMa:BURSt<[1]|2|3|4>[:SELected]
  • CALL:(PDTCH|PDTChannel):DTMode:MS:TXLevel[:SELected]:BURSt<[1]|2|3|4|5>
  • CALL:(PDTCH|PDTChannel):DTMode:MSLot:CONFig
  • CALL:(PDTCH|PDTChannel):DTMode:MSLot:CONFig:CUSTom:TSLots
  • CALL:(PDTCH|PDTChannel):DTMode:MSLot:MEASurement:BURSt
  • CALL:(PDTCH|PDTChannel):DTMode:PZERo:LEVel
  • CALL:(PDTCH|PDTChannel):DTMode:TTI[:MODE]
  • CALL:(PDTCH|PDTChannel):DTMode:USFLag[:ASSigned]
  • CALL:(PDTCH|PDTChannel):DTMode:USFLag:UNASsigned[:MANual]

  • CALL:(PDTCH|PDTChannel):EGPRS:MAPPing
  • CALL:(PDTCH|PDTChannel):ESPolling

  • CALL:(PDTCH|PDTChannel):FHOPping[:STATe]
  • CALL:(PDTCH|PDTChannel):FHOPping:HSNumber
  • CALL:(PDTCH|PDTChannel):FHOPping:MAIOffset[:SELected]

  • CALL:(PDTCH|PDTChannel):IREDundancy[:STATe]

  • CALL:(PDTCH|PDTChannel):MA:MEASurement:ARFCN[:SELected]
  • CALL:(PDTCH|PDTChannel):MA:TABLe[:AUTO][:SELected]?
  • CALL:(PDTCH|PDTChannel):MA:TABLe[:AUTO]:POINts[:SELected]?
  • CALL:(PDTCH|PDTChannel):MA:TABLe:CONFig:AUTO
  • CALL:(PDTCH|PDTChannel):MA:TABLe:MANual[:SELected]
  • CALL:(PDTCH|PDTChannel):MA:TABLe:MANual:POINts[:SELected]?

  • CALL:(PDTCH|PDTChannel):MACCess
  • CALL:(PDTCH|PDTChannel):MACCess:FIXed:MOALlocation:STATe
  • CALL:(PDTCH|PDTChannel):MACCess:FIXed:MOALlocation:NUMBer
  • CALL:(PDTCH|PDTChannel):MACCess[:DYNamic]:USFLag[:ASSigned]
  • CALL:(PDTCH|PDTChannel):MACCess[:DYNamic]:USFLag[:ASSigned]:GRANularity
  • CALL:(PDTCH|PDTChannel):MACCess[:DYNamic]:USFLag:PERCent
  • CALL:(PDTCH|PDTChannel):MACCess[:DYNamic]:USFLag:UNASsigned[:MANual]
  • CALL:(PDTCH|PDTChannel):MACCess[:DYNamic]:USFLag:UNASsigned:MODE

  • CALL:(PDTCH|PDTChannel):MCSCheme
  • CALL:(PDTCH|PDTChannel):MCSCheme:EBPTest[:BURSt1]
  • CALL:(PDTCH|PDTChannel):MCSCheme:EBPTest:BURSt<2|3|4|5>
  • CALL:(PDTCH|PDTChannel):MCSCheme:PSCHeme
  • CALL:(PDTCH|PDTChannel):MCSCheme:SWITch[:STATe]
  • CALL:(PDTCH|PDTChannel):MCSCheme:SWITch:RESegment[:STATe]
  • CALL:(PDTCH|PDTChannel):MCSCheme:SWITch:RETRansmit

  • CALL:(PDTCH|PDTChannel):MS:ALPHa
  • CALL:(PDTCH|PDTChannel):MS:GAMMa:BURSt<[1]|2|3|4|5>[:SELected]
  • CALL:(PDTCH|PDTChannel):MS:OPSMode
  • CALL:(PDTCH|PDTChannel):MS:TADVance[:SELected]
  • CALL:(PDTCH|PDTChannel):MS:TADVance:CONTinuous
  • CALL:(PDTCH|PDTChannel):MS:TXLevel[:SELected]:BURSt<[1]|2|3|4|5>

  • CALL:(PDTCH|PDTChannel):MSLot:CONFig
  • CALL:(PDTCH|PDTChannel):MSLot:CONFig:CUSTom:TSLots
  • CALL:(PDTCH|PDTChannel):MSLot[:FIRSt]:DOWNlink:LOOPback[:BURSt]
  • CALL:(PDTCH|PDTChannel):MSLot:MEASurement:BURSt

  • CALL:(PDTCH|PDTChannel):PMESsage:NACChange:COMPletion
  • CALL:(PDTCH|PDTChannel):PMESsage:(PMORder|PMO):NC2[:STATe]
  • CALL:(PDTCH|PDTChannel):PMESsage:PNCData[:STATe]
  • CALL:(PDTCH|PDTChannel):PMESsage:PPTadvance
  • CALL:(PDTCH|PDTChannel):PMESsage:PTReconfig

  • CALL:(PDTCH|PDTChannel):POWer[:AMPLitude]:BURSt<[1]|2|3|4|5>?
  • CALL:(PDTCH|PDTChannel):POWer[:AMPLitude]:UBURst?
  • CALL:(PDTCH|PDTChannel):POWer[:AMPLitude]:UNUSed?

  • CALL:(PDTCH|PDTChannel):PREDuction:ADJacent
  • CALL:(PDTCH|PDTChannel):PREDuction:BURSt<[1]|2|3|4|5>
  • CALL:(PDTCH|PDTChannel):PREDuction:LEVel<1|2>
  • CALL:(PDTCH|PDTChannel):PREDuction:MODE
  • CALL:(PDTCH|PDTChannel):PREDuction:UBURst
  • CALL:(PDTCH|PDTChannel):PREDuction:UNUSed

  • CALL:(PDTCH|PDTChannel):PZERo:LEVel

  • CALL:(PDTCH|PDTChannel):RRBPeriod

  • CALL:(PDTCH|PDTChannel):TBFLow:DOWNlink:DELayed[:SDURation]
  • CALL:(PDTCH|PDTChannel):TBFLow:DOWNlink:DELayed:DURation
  • CALL:(PDTCH|PDTChannel):TBFLow:DOWNlink:DELayed:STATe
  • CALL:(PDTCH|PDTChannel):TBFLow:DOWNlink:FBIndicator:POLLing
  • CALL:(PDTCH|PDTChannel):TBFLow:DOWNlink:RETRansmit[:STATe]
  • CALL:(PDTCH|PDTChannel):TBFLow:REEStablish[:STATe]
  • CALL:(PDTCH|PDTChannel):TBFLow:UPLink:DLOSt:TIMer[:SDURation]
  • CALL:(PDTCH|PDTChannel):TBFLow:UPLink:DLOSt:TIMer:DURation
  • CALL:(PDTCH|PDTChannel):TBFLow:UPLink:DLOSt:TIMer:STATe
  • CALL:(PDTCH|PDTChannel):TBFLow:UPLink:EXTended:DURation

  • CALL:(PDTCH|PDTChannel):TTI[:MODE]

  • CALL:(PDTCH|PDTChannel):UPLink:RETRansmit:FORCe:PROBability[:STATe]
  • CALL:(PDTCH|PDTChannel):UPLink:RETRansmit:FORCe:PROBability:PERCentage
  • CALL:(PDTCH|PDTChannel):UPLink:RETRansmit:FORCe:PROBability:SPERcentage

  • CALL:(PDTCH|PDTChannel):USFlag
  • CALL:(PDTCH|PDTChannel):USFlag:RTTI[:MODE]

  • CALL:(PDTCH|PDTChannel):WINDow:SIZE[:ALL]
  • CALL:(PDTCH|PDTChannel):WINDow:SIZE:AUTO
  • CALL:(PDTCH|PDTChannel):WINDow:SIZE:OTHer
  • CALL:(PDTCH|PDTChannel):WINDow:SIZE:SELected

NOTE
The CALL:PDTCH:MACCess[:DYNamic]:USFLag command replaces the

CALL:PDTCH:USFLag command.

CALL:(PDTCH|PDTChannel)[:ARFCn][:SELected]

CALL:(PDTCH|PDTChannel)[:ARFCN]:(DCS|EGSM|GSM450|GSM480|GSM750|GSM850|PCS|PGSM|RGSM|TGSM810)

Function

GSM TA

 This command is not applicable to the GSM Test Application.

GPRS TA

This command sets/queries the ARFCN of the downlink and uplink PDTCH for the band already selected.

The optional [SELected] keyword in this command specifies that the channel being set/queried applies to the current PDTCH band.

If this command is attempted while there is an active DTM connection or while the test set is in a DTM test operating mode, it is stored and applied when the test set is no longer in Dual Transfer Mode.

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

Range:

  • DCS band, channels 512 to 885
  • EGSM band, channels 0 to 124 and 975 to 1023
  • GSM450 band, channels 259 to 293
  • GSM480 band, channels 306 to 340
  • GSM750 band, channels 438 to 511
  • GSM850 band, channels 128 to 251
  • PCS band, channels 512 to 810
  • PGSM band, channels 1 to 124
  • RGSM band, channels 0 to 124 and 955 to 1023
  • TGSM810 band, channels 350 to 425

Resolution: 1
Query

Range:

  • DCS band, channels 512 to 885
  • EGSM band, channels 0 to 124 and 975 to 1023
  • GSM450 band, channels 259 to 293
  • GSM480 band, channels 306 to 340
  • GSM750 band, channels 438 to 511
  • GSM850 band, channels 128 to 251
  • PCS band, channels 512 to 810
  • PGSM band, channels 1 to 124
  • RGSM band, channels 0 to 124 and 955 to 1023
  • TGSM810 band, channels 350 to 425

Resolution: 1
*RST setting

PGSM, EGSM and RGSM bands: 30, DCS and PCS bands: 698, GSM450: 280, GSM480: 320, GSM750: 460, GSM850: 160, TGSM810: 400.
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above

A.06 adds the TGSM810 band.
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

D.03 adds the TGSM810 band.

Programming Example

OUTPUT 714;"CALL:PDTCH:ARFCn 512"
! Sets the ARFCN of the selected band to 512, if 512 is valid for the selected band.

CALL:(PDTCH|PDTChannel):ARAC:PRRequest[:STATe]

Function

GSM TA

 This command is not applicable to the GSM Test Application.

GPRS TA

 This command is not applicable to the GPRS Test Application.

EGPRS TA

 This command is not applicable to the EGPRS Test Application.

GSM/GPRS LA

 This command is not applicable to the GSM/GPRS Lab Application.

EGPRS LA

This command sets/queries the ARAC state.

When the ARAC state is set to ON, the test set will request ARAC in the following PACKET UPLINK ASSIGNMENT message every time upon receiving a PACKET RESOURCE REQUEST message. See ARAC on receipt of PRR for more information.
Setting | Range: 1|ON|0|OFF
Query | Range: 1|0
*RST setting | 0|OFF
Requirements GSM/GPRS/ EGPRS LA

Revision: G.00.00 and above

Programming Example

OUTPUT 714;"CALL:PDTCH:ARAC:PRRequest:STATe ON"
! Sets the ARAC state to ON.

CALL:(PDTCH|PDTChannel):BAND

Function

GSM TA

 This command is not applicable to the GSM Test Application.

GPRS TA

This command sets/queries the PDTCH band, therefore constraining the range of PDTCH ARFCNs.

If this command is attempted while there is an active DTM connection or while the test set is in a DTM test operating mode, it is stored and applied when the test set is no longer in Dual Transfer Mode.

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting | Range: PGSM | EGSM | GSM450 | GSM480 | GSM750 | GSM850 | DCS | PCS | RGSM| TGSM810
Query | Range: PGSM | EGSM | GSM450 | GSM480 | GSM750 | GSM850 | DCS | PCS | RGSM| TGSM810
*RST setting | PGSM
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above

A.06 adds the TGSM810 band.
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

D.03 adds the TGSM810 band.

Programming Example

OUTPUT 714;"CALL:PDTCH:BAND DCS"
! Sets the band to DCS.

CALL:(PDTCH|PDTChannel):CSCHeme

Function

GSM TA

 This command is not applicable to the GSM Test Application.

EGPRS TA

 This command is not applicable to the EGPRS Test Application.

GPRS TA

This command sets/queries the PDTCH coding scheme.

Note, in test application, the PDTCH coding scheme applies for both GPRS uplink and downlink; In lab application, the PDTCH coding scheme applies for only GPRS uplink. (equals to CALL:(PDTCH|PDTChannel):CSCHeme:UPLink .) Use the CALL:(PDTCH|PDTChannel):CSCHeme:DOWNink to set the PDTCH coding scheme for GPRS downlink in lab application.

When you make a coding scheme change, all the measurements and the Block Error Rate (BLER) reports are stopped before the change is made. They are then re-started after the change has taken effect.

If this command is attempted while there is an active DTM connection or while the test set is in a DTM test operating mode, it is stored and applied when the test set is no longer in Dual Transfer Mode

GSM/GPRS LA

EGPRS LA
Setting | Range: CS1 | CS2 | CS3 | CS4
Query | Range: CS1 | CS2 | CS3 | CS4
*RST setting | CS4
Requirements GSM/GPRS/EGPRS TA

Revision: A.01 and above
GSM/GPRS/EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:PDTCHannel:CSCHeme CS1"
! Sets the PDTCH coding scheme to CS1.

CALL:(PDTCH|PDTChannel):CSCHeme:DOWNink

Function

GSM TA

 This command is not applicable to the GSM Test Application.

EGPRS TA

 This command is not applicable to the EGPRS Test Application.

GPRS TA

 This command is not applicable to the GPRS Test Application.

EGPRS LA

 This command is not applicable to the EGPRS Lab Application.

GSM/GPRS LA

This command sets/queries the PDTCH coding scheme for GPRS downlink.

When you make a coding scheme change, all the measurements and the Block Error Rate (BLER) reports are stopped before the change is made. They are then re-started after the change has taken effect.

If this command is attempted while there is an active DTM connection or while the test set is in a DTM test operating mode, it is stored and applied when the test set is no longer in Dual Transfer Mode

When ETSI B connection is used, the coding scheme on the downlink must be the same as the uplink.
Setting | Range: CS1 | CS2 | CS3 | CS4
Query | Range: CS1 | CS2 | CS3 | CS4
*RST setting | CS4
Requirements GSM/GPRS LA

Revision: G.00.00 and above

Programming Example

OUTPUT 714;"CALL:PDTCHannel:CSCHeme:DOWNink CS1"
! Sets the downlink PDTCH coding scheme to CS1.

CALL:(PDTCH|PDTChannel):CSCHeme:UPLink

Function

GSM TA

 This command is not applicable to the GSM Test Application.

EGPRS TA

 This command is not applicable to the EGPRS Test Application.

GPRS TA

 This command is not applicable to the GPRS Test Application.

EGPRS LA

 This command is not applicable to the EGPRS Lab Application.

GSM/GPRS LA

This command sets/queries the PDTCH coding scheme for GPRS uplink.

When you make a coding scheme change, all the measurements and the Block Error Rate (BLER) reports are stopped before the change is made. They are then re-started after the change has taken effect.

If this command is attempted while there is an active DTM connection or while the test set is in a DTM test operating mode, it is stored and applied when the test set is no longer in Dual Transfer Mode
Setting | Range: CS1 | CS2 | CS3 | CS4
Query | Range: CS1 | CS2 | CS3 | CS4
*RST setting | CS4
Requirements GSM/GPRS LA

Revision: G.00.00 and above

Programming Example

OUTPUT 714;"CALL:PDTCHannel:CSCHeme:UPLink CS1"
! Sets the uplink PDTCH coding scheme to CS1.

CALL:(PDTCH|PDTChannel):CUSTom:DATA

Function

GSM TA

 This command is not applicable to the GSM test application.

GPRS TA

This command sets/queries the values used when the Custom option is selected for the Payload Patterns . The GPIB commands that allows you to set the payload pattern to custom are CALL:FUNCtion:DATA:PAYLoad:PATTern[:OTHer] CALL:FUNCtion:DATA:PAYLoad:PATTern:BLER .

Note: The same custom data is used for GPRS Payload Pattern (BLER) , GPRS Payload Pattern (OTHER) and GSM Speech .
EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

A comma separated list of 1 to 174 values:

Range: 0 to 255

Resolution: 1
Query

A comma separated list of 1 to 174 values:

Range: 0 to 255

Resolution: 1
*RST setting 0xff, 0xfe, 0x00, 0x04, 0x00, 0x18, 0x00, 0x50,0x01, 0xe0, 0x04, 0x40, 0x19, 0x80, 0x55, 0x01,0xfe, 0x04, 0x04, 0x18, 0x18, 0x50, 0x51, 0xe1,0xe4, 0x44, 0x59, 0x99, 0xd5, 0x54, 0xff, 0xfa,0x00, 0x1c, 0x00, 0x48, 0x01, 0xb0, 0x05, 0xa0,0x1d, 0xc0, 0x4c, 0x81, 0xab, 0x05, 0xfa, 0x1c,0x1c, 0x48, 0x49, 0xb1, 0xb5, 0xa5, 0xbd, 0xdd,0x8c, 0xcd, 0x2a, 0xae, 0xff, 0xe6, 0x00, 0x54,0x01, 0xf8, 0x04, 0x10, 0x18, 0x60, 0x51, 0x41,0xe7, 0x84, 0x51, 0x19, 0xe6, 0x54, 0x55, 0xf9,0xfc, 0x14, 0x08, 0x78, 0x31, 0x10, 0xa6, 0x63,0xd5, 0x48, 0xff, 0xb2, 0x01, 0xac, 0x05, 0xe8,0x1c, 0x70, 0x49, 0x21, 0xb6, 0xc5, 0xb6, 0x9d,0xb7, 0x4d, 0xb3, 0xad, 0xa9, 0xed, 0xf4, 0x6c,0x39, 0x68, 0x97, 0x73, 0x73, 0x2b, 0x2a, 0xfa,0xfe, 0x1e, 0x04, 0x44, 0x19, 0x98, 0x55, 0x51,0xff, 0xe4, 0x00, 0x58, 0x01, 0xd0, 0x04, 0xe0,0x1a, 0x40, 0x5d, 0x81, 0xcd, 0x04, 0xae, 0x1b,0xe4, 0x58, 0x59, 0xd1, 0xd4, 0xe4, 0xfa, 0x5a,0x1d, 0xdc, 0x4c, 0xc9, 0xaa, 0xb5, 0xff, 0xbc,0x01, 0x88, 0x05, 0x30, 0x1e, 0xa0, 0x47, 0xc1,0x90, 0x85, 0x63, 0x1f, 0x4a, 0x43

Requirements

 GPRS/EGPRS TA

Revision: A.04 and above
GSM/GPRS/ EGPRS LA

Revision: D.01 and above

Programming Example

OUTPUT 714;"CALL:PDTCH:CUSTom:DATA #ha5,#hfe,#h9b"
! Sets the values for the custom data pattern.
! Note: These values were entered in hexadecimal format. The format to enter hexadecimal
! values is #hXX where X can be any value 0-9 of letters a,b,c,d,e or f.

OUTPUT 714;"CALL:PDTCH:CUSTom:DATA?"
! This query of the previous command returns +165,+254,+155, which is the decimal
! form of the values defined in the custom data pattern.

CALL:(PDTChannel|PDTCH):DLDCarrier[:STATe]

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA | This command is not applicable to the GSM/GPRS Lab Application.
EGPRS LA | This command sets/queries the DLDC state for PS connections. See Downlink Dual Carrier for more information.

Setting

Range: 0 | OFF | 1 | ON

Query

Range: 0 | 1

*RST setting

0 | OFF
Requirements EGPRS LA

Revision: G.00.00 and above

Programming Example

OUTPUT 714;"CALL:PDTCH:DLDCarrier ON" ! Turns the DLDC On.

OUTPUT 714;"CALL:PDTCH:DLDCarrier?" ! Returns "On" if the DLDC has been turn on.

CALL:(PDTCH|PDTChannel):DOWNlink:CORRuption[:STATe]

Function

GSM TA

 This command is not applicable to the GSM Test Application.

GPRS TA

 This command is not applicable to the GPRS Test Application.

GSM/GPRS LA

 This command is not applicable to the GSM/GPRS Lab Application.

EGPRS TA

 This command is not applicable to the EGPRS Test Application.

EGPRS LA

 This command enables/queries the state of downlink block corruption for EGPRS. Note: The corruption sequence is restarted when the Corruption State changes to ON.
Setting | Range: 0 | OFF | 1 | ON
Query | Range: 0 | 1
*RST setting | 0 | OFF
Requirements GSM/GPRS/ EGPRS LA

Revision: C.03 and above

Programming Example

OUTPUT 714;"CALL:PDTCH:DOWN:CORR 1"
! Turns on downlink block corruption.

CALL:(PDTCH|PDTChannel):DOWNlink:CORRuption:BURSt<[1]|2|3|4>[:STATe]

Function

GSM TA

 This command is not applicable to the GSM Test Application.

GPRS TA

 This command is not applicable to the GPRS Test Application.

GSM/GPRS LA

 This command is not applicable to the GSM/GPRS Lab Application.

EGPRS TA

 This command is not applicable to the EGPRS Test Application.

EGPRS LA

 This command sets/queries the state of burst corruption for the individual downlink bursts.
Setting | Range: 0 | OFF |1 | ON
Query | Range: 0 | 1
*RST setting BURSt[1]: ON
BURSt2, BURSt3 and BURSt4: OFF
Requirements GSM/GPRS/EGPRS LA

Revision: C.03 and above

Programming Example

OUTPUT 714;"CALL:PDTCH:DOWN:CORR:BURS 0"
! Turns off burst corruption for downlink burst 1.

CALL:(PDTCH|PDTChannel):DOWNlink:CORRuption:PATTern

Function

GSM TA

 This command is not applicable to the GSM Test Application.

GPRS TA

 This command is not applicable to the GPRS Test Application.

GSM/GPRS LA

 This command is not applicable to the GSM/GPRS Lab Application.

EGPRS TA

 This command is not applicable to the EGPRS Test Application.

EGPRS LA

This command sets the symbol pattern parameter for Downlink Corruption. This specifies the symbol pattern that should be used to replace the symbols set to be corrupted. The different symbol patters available are:

ZERos: replaces symbols to be corrupted with all zeros
ONES: replaces the symbols to be corrupted with all ones
INVert: inverts the original value of each symbol that is to be corrupted
Setting | Range: ZERos, ONES, INVert
Query | Range: ZER | ONES | INV
*RST setting | ZER
Requirements GSM/GPRS/ EGPRS LA

Revision: C.03 and above

Programming Example

OUTPUT 714;"CALL:PDTCH:DOWN:CORR:PATT INV"
! Sets the symbol pattern to be used for burst corruption to the inverse of the correct symbol values.

CALL:(PDTCH|PDTChannel):DOWNlink:CORRuption:SEQuence:CBURsts

Function

GSM TA

 This command is not applicable to the GSM Test Application.

GPRS TA

 This command is not applicable to the GPRS Test Application.

GSM/GPRS LA

 This command is not applicable to the GSM/GPRS Lab Application.

EGPRS TA

 This command is not applicable to the EGPRS Test Application.

EGPRS LA

 This command sets the number of blocks to corrupt in the specified sequence The command to specify the length of the sequence is CALL:(PDTCH|PDTChannel):DOWNlink:CORRuption:SEQuence:LENGth . Note: If the number of blocks to corrupt in the sequence is greater than or equal to the Sequence Length, then all blocks are subject to corruption.
Setting Range: 1 to 2048
Resolution: 1
Query Range: 1 to 2048
Resolution: 1
*RST setting 1
Requirements GSM/GPRS/ EGPRS LA

Revision: C.03 and above

Programming Example

OUTPUT 714;"CALL:PDTCH:DOWN:CORR:SEQ:CBUR 300"
! Sets the number of blocks to be corrupted to 300.

CALL:(PDTCH|PDTChannel):DOWNlink:CORRuption:SEQuence:LENGth

Function

GSM TA

 This command is not applicable to the GSM Test Application.

GPRS TA

 This command is not applicable to the GPRS Test Application.

GSM/GPRS LA

 This command is not applicable to the GSM/GPRS Lab Application.

EGPRS TA

 This command is not applicable to the EGPRS Test Application.

EGPRS LA

 This command sets the number of the blocks in a sequence to which the other corruption parameters are to be applied. Note that the command CALL:(PDTCH|PDTChannel):DOWNlink:CORRuption:SEQuence:CBURsts defines the number of blocks in this sequence which are to be corrupted.
Setting Range: 1 to 2048
Resolution: 1
Query Range: 1 to 2048
Resolution: 1
*RST setting 100
Requirements GSM/GPRS/ EGPRS LA

Revision: C.03 and above

Programming Example

OUTPUT 714;"CALL:PDTCH:DOWN:CORR:SEQ:LENG 500"
! Sets the sequence of blocks affected by corruption to 500.

CALL:(PDTCH|PDTChannel):DOWNlink:CORRuption:SYMBol:LENGth

Function

GSM TA

 This command is not applicable to the GSM Test Application.

GPRS TA

 This command is not applicable to the GPRS Test Application.

GSM/GPRS LA

 This command is not applicable to the GSM/GPRS Lab Application.

EGPRS TA

 This command is not applicable to the EGPRS Test Application.

EGPRS LA

 This command sets the number of symbols to corrupt in each block that is corrupted.
Setting Range: 1 to 148
Resolution: 1
Query Range: 1 to 148
Resolution: 1
*RST setting 148
Requirements GSM/GPRS/ EGPRS LA

Revision: C.03 and above

Programming Example

OUTPUT 714;"CALL:PDTCH:DOWN:CORR:SYMB:LENG 74"
! Sets the number of symbols in a block to be corrupted to 74.

CALL:(PDTCH|PDTChannel):DOWNlink:CORRuption:SYMBol:STARt

Function

GSM TA

 This command is not applicable to the GSM Test Application.

GPRS TA

 This command is not applicable to the GPRS Test Application.

GSM/GPRS LA

 This command is not applicable to the GSM/GPRS Lab Application.

EGPRS TA

 This command is not applicable to the EGPRS Test Application.

EGPRS LA

 This command sets the symbol position at which block corruption begins for corrupted blocks.
Setting Range: 0 to 147
Resolution: 1
Query Range: 0 to 147
Resolution: 1
*RST setting 0
Requirements GSM/GPRS/ EGPRS LA

Revision: C.03 and above

Programming Example

OUTPUT 714;"CALL:PDTCH:DOWN:CORR:SYMB:STAR 148"
! Sets the first symbol to be corrupted to number 148.

CALL:(PDTCH|PDTChannel):DTMode:ARFCn[:SELected]

CALL:(PDTCH|PDTChannel):DTMode:ARFCn:(DCS|EGSM|GSM450|GSM480|GSM750|GSM850|PCS|PGSM|RGSM|TGSM810)

Function

GSM TA

 This command is not applicable to the GSM Test Application.

GPRS TA

 This command is not applicable to the GPRS Test Application.

EGPRS TA

 This command is not applicable to the EGPRS Test Application.

GSM/GPRS LA

This command sets/queries the DTM (Dual Transfer Mode) traffic channel for the band selected.

The deferred version of this command is CALL:SETup:DTMode:ARFCn[:SELected] .

The optional [SELected] keyword in this command specifies that the channel being set/queried applies to the current DTM band.

See DTM Traffic Channel for more information.

EGPRS LA
Setting

Range:

  • DCS band, channels 512 to 885
  • EGSM band, channels 0 to 124 and 975 to 1023
  • GSM450 band, channels 259 to 293
  • GSM480 band, channels 306 to 340
  • GSM750 band, channels 438 to 511
  • GSM850 band, channels 128 to 251
  • PCS band, channels 512 to 810
  • PGSM band, channels 1 to 124
  • RGSM band, channels 0 to 124 and 955 to 1023
  • TGSM810 band, channels 350 to 425

Resolution: 1
Query

Range:

  • DCS band, channels 512 to 885
  • EGSM band, channels 0 to 124 and 975 to 1023
  • GSM450 band, channels 259 to 293
  • GSM480 band, channels 306 to 340
  • GSM750 band, channels 438 to 511
  • GSM850 band, channels 128 to 251
  • PCS band, channels 512 to 810
  • PGSM band, channels 1 to 124
  • RGSM band, channels 0 to 124 and 955 to 1023
  • TGSM810 band, channels 350 to 425

Resolution: 1
*RST setting

PGSM, EGSM and RGSM bands: 30, DCS and PCS bands: 698, GSM450: 280, GSM480: 320, GSM750: 460, GSM850: 160, TGSM810: 400.
Requirements GSM/GPRS/ EGPRS LA

Revision: E.00.12 and above

Programming Example

OUTPUT 714;"CALL:PDTCH:DTMode:ARFCn 512"
! Sets the DTM ARFCN of the selected band to 512, if 512 is valid for the selected band.

CALL:(PDTCH|PDTChannel):DTMode:BAND

Function

GSM TA

 This command is not applicable to the GSM Test Application.

GPRS TA

 This command is not applicable to the GPRS Test Application.

EGPRS TA

 This command is not applicable to the EGPRS Test Application.

GSM/GPRS LA

This command sets/queries the DTM band, therefore constraining the range of DTM ARFCNs.

The deferred version of this command is CALL:SETup:DTMode:BAND .

See DTM Traffic Band for more information.

EGPRS LA
Setting | Range: PGSM | EGSM | GSM450 | GSM480 | GSM750 | GSM850 | DCS | PCS | RGSM| TGSM810
Query | Range: PGSM | EGSM | GSM450 | GSM480 | GSM750 | GSM850 | DCS | PCS | RGSM| TGSM810
*RST setting | PGSM
Requirements GSM/GPRS/ EGPRS LA

Revision: E.00.12 and above

Programming Example

OUTPUT 714;"CALL:PDTCH:DTMode:BAND DCS"
! Sets the DTM band to DCS.

CALL:(PDTCH|PDTChannel):DTMode:CSCHeme

Function

GSM TA

 This command is not applicable to the GSM Test Application.

GPRS TA

 This command is not applicable to the GPRS Test Application.

EGPRS TA

 This command is not applicable to the EGPRS Test Application.

GSM/GPRS LA

This command sets/queries the DTM coding scheme for both GPRS uplink and downlink.

The deferred version of this command is CALL:SETup:DTMode:CSCHeme .

See DTM Coding Schemes for more information.

EGPRS LA
Setting | Range: CS1 | CS2 | CS3 | CS4
Query | Range: CS1 | CS2 | CS3 | CS4
*RST setting | CS4
Requirements GSM/GPRS/ EGPRS LA

Revision: E.00.12 and above

Programming Example

OUTPUT 714;"CALL:PDTCHannel:DTMode:CSCHeme CS1"
! Sets the DTM coding scheme to CS1.

CALL:(PDTCH|PDTChannel):DTMode:CSCHeme:DOWNlink

Function

GSM TA

 This command is not applicable to the GSM Test Application.

GPRS TA

 This command is not applicable to the GPRS Test Application.

EGPRS TA

 This command is not applicable to the EGPRS Test Application.

EGPRS LA

 This command is not applicable to the EGPRS Lab Application.

GSM/GPRS LA

This command sets/queries the DTM downlink coding scheme for GPRS downlink.

When ETSI B connection is used, the coding scheme on the downlink must be the same as the uplink.

The deferred version of this command is CALL:SETup:DTMode:CSCHeme .

See DTM Coding Schemes for more information.
Setting | Range: CS1 | CS2 | CS3 | CS4
Query | Range: CS1 | CS2 | CS3 | CS4
*RST setting | CS4
Requirements GSM/GPRS LA

Revision: G.00.00 and above

Programming Example

OUTPUT 714;"CALL:PDTCHannel:DTMode:CSCHeme:DOWNlink CS1"
! Sets the downlink DTM coding scheme to CS1.

CALL:(PDTCH|PDTChannel):DTMode:CSCHeme:UPLink

Function

GSM TA

 This command is not applicable to the GSM Test Application.

GPRS TA

 This command is not applicable to the GPRS Test Application.

EGPRS TA

 This command is not applicable to the EGPRS Test Application.

EGPRS LA

 This command is not applicable to the EGPRS Lab Application.

GSM/GPRS LA

This command sets/queries the DTM coding scheme for GPRS uplink.

The deferred version of this command is CALL:SETup:DTMode:CSCHeme .

See DTM Coding Schemes for more information.
Setting | Range: CS1 | CS2 | CS3 | CS4
Query | Range: CS1 | CS2 | CS3 | CS4
*RST setting | CS4
Requirements GSM/GPRS LA

Revision: G.00.00 and above

Programming Example

OUTPUT 714;"CALL:PDTCHannel:DTMode:CSCHeme:UPLink CS1"
! Sets the uplink DTM coding scheme to CS1.

CALL:(PDTCH|PDTChannel):DTMode:CSWitched:HRSPeech:SCHannel

Function

GSM TA

 This command is not applicable to the GSM Test Application.

GPRS TA

 This command is not applicable to the GPRS Test Application.

EGPRS TA

 This command is not applicable to the EGPRS Test Application.

GSM/GPRS LA

This command sets/queries the DTM Circuit Switched Half Rate Sub-channel.

The deferred version of this command is CALL:SETup:DTMode:CSWitched:HRSPeech:SCHannel .

See DTM CS Half Rate Sub Channel for more information.

EGPRS LA
Setting | Range: 0 | 1
Query | Range: 0 | 1
*RST setting | 0
Requirements GSM/GPRS/ EGPRS LA

Revision: E.02 and above

Programming Example

OUTPUT 714;"CALL:PDTCHannel:DTMode:CSWitched:HRSPeech:SCHannel 1"
! Sets the CS Half Rate Sub-channel to ON.

CALL:(PDTCH|PDTChannel):DTMode:CSWitched:MS:TXLevel[:SELected]

CALL:(PDTCH|PDTChannel):DTMode:CSWitched:MS:TXLevel:(DCS|EGSM|GSM450|GSM480|GSM750|GSM850|PCS|PGSM|RGSM|TGSM810)

Function

GSM TA

 This command is not applicable to the GSM Test Application.

GPRS TA

 This command is not applicable to the GPRS Test Application.

EGPRS TA

 This command is not applicable to the EGPRS Test Application.

GSM/GPRS LA

This command sets/queries the DTM circuit switched MS Transmit Power Level for the band selected.

The deferred version of this command is CALL:SETup:DTMode:CSWitched:MS:TXLevel[:SELected] .

EGPRS LA
Setting

Range: 0 to 31

Resolution: 1
Query

Range: 0 to 31

Resolution: 1
*RST setting DCS and PCS bands: 10, PGSM, EGSM, RGSM, GSM450, GSM480, GSM750, GSM850 and TGSM810 bands: 15
Requirements GSM/GPRS/ EGPRS LA

Revision: E.00.12 and above

Programming Example

OUTPUT 714;"CALL:PDTCH:DTMode:CSWitched:MS:TXLevel 15"
! Sets the DTM circuit switched MS Transmit Power Level to 15.

CALL:(PDTCH|PDTChannel):DTMode:CSWitched:TSLot

Function

GSM TA

 This command is not applicable to the GSM Test Application.

GPRS TA

 This command is not applicable to the GPRS Test Application.

EGPRS TA

 This command is not applicable to the EGPRS Test Application.

GSM/GPRS LA

This command sets/queries the DTM circuit switched timeslot position within the selected multislot configuration.

The deferred version of this command is CALL:SETup:DTMode:CSWitched:TSLot .

See DTM CS Timeslot Position for more information.

EGPRS LA
Setting

Range: 2|3|4|5|6

Resolution: 1
Query

Range: 2|3|4|5|6

Resolution: 1
*RST setting Depends on the currently selected multislot configuration. See DTM CS Timeslot Position .
Requirements GSM/GPRS/ EGPRS LA

Revision: E.00.05

Revision: F.01extends the input range to include `2'.

Programming Example

OUTPUT 714;"CALL:PDTCH:DTMode:CSWitched:TSLot 3"
! Sets the circuit switched timeslot position to 3.

CALL:(PDTCH|PDTChannel):DTMode:FHOPping[:STATe]

Function

GSM TA

 This command is not applicable to the GSM Test Application.

GPRS TA

 This command is not applicable to the GPRS Test Application.

EGPRS TA

 This command is not applicable to the EGPRS Test Application.

GSM/GPRS LA

This command enables/queries the DTM Frequency Hopping state for GPRS or EGPRS.

The deferred version of this command is CALL:SETup:DTMode:FHOPping[:STATe] .

See DTM Frequency Hopping for more information.

EGPRS LA
Setting | Range: 0 | OFF | 1 | ON
Query | Range: 0 | 1
*RST setting | 0 |OFF
Requirements GSM/GPRS/ EGPRS LA

Revision: E.00.12 and above

Programming Example

OUTPUT 714;"CALL:PDTCH:DTMode:FHOPping ON"
! Enables DTM Frequency Hopping.

CALL:(PDTCH|PDTChannel):DTMode:MCSCheme

Function

GSM TA

 This command is not applicable to the GSM Test Application.

GPRS TA

 This command is not applicable to the GPRS Test Application.
EGPRS TA | This command is not applicable to the EGPRS Test Application.

GSM/GPRS LA

 This command is not applicable to the GSM/GPRS Lab Application.

EGPRS LA

This command sets/queries the DTM modulation coding scheme. Modulation coding schemes MCS1 through MCS4 use GMSK modulation, while MCS5 to MCS9 use 8PSK modulation.

The deferred version of this command is CALL:SETup:DTMode:MCSCheme .
Setting

Range: <downlink>, <uplink>

<downlink> can be set to one of the following values:

  • MCS1 | MCS2 | MCS3 | MCS4 | MCS5 | MCS6 | MCS7 | MCS8 | MCS9

<uplink> can be set to one of the following values:

  • MCS1 | MCS2 | MCS3 | MCS4 | MCS5 | MCS6 | MCS7 | MCS8 | MCS9
Query

Range: <downlink>, <uplink>

<downlink> returns one of the following values:

  • MCS1 | MCS2 | MCS3 | MCS4 | MCS5 | MCS6 | MCS7 | MCS8 | MCS9

<uplink> returns one of the following values:

  • MCS1 | MCS2 | MCS3 | MCS4 | MCS5 | MCS6 | MCS7 | MCS8 | MCS9
*RST setting | MCS4,MCS4
Requirements

GSM/GPRS/ EGPRS LA

 Revision: E.00.12 and above

Programming Example

OUTPUT 714;"CALL:PDTCH:DTMode:MCSCheme MCS1 MCS1"
! Sets the DTM modulation coding scheme for the downlink and uplink to MCS1.

CALL:(PDTCH|PDTChannel):DTMode:MS:GAMMa:BURSt<[1]|2|3|4>[:SELected]

CALL:(PDTCH|PDTChannel):DTMode:MS:GAMMa:BURSt<[1]|2|3|4>:(DCS|EGSM|GSM450|GSM480|GSM750|GSM850|PCS|PGSM|RGSM|TGSM810)

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA This command sets/queries the DTM gamma value for any uplink burst in the selected band. The range of gamma 0 to 31 represents 0 to 62 dB in 2 dB steps. See MS Output Power for more information.
EGPRS LA

Setting

Range: 0 to 31

Resolution: 1

Query

Range: 0 to 31

Resolution: 1

*RST setting

 13
Requirements GSM/GPRS/ EGPRS LA

Revision: F.00.37 and above

Programming Example

OUTPUT 714;CALL:PDTCH:DTMode:MS:GAMMa:BURSt4 17
! Sets the DTM gamma parameter of the 4th uplink burst in the selected band to 17.

CALL:(PDTCH|PDTChannel):DTMode:MS:TXLevel[:SELected]:BURSt<[1]|2|3|4|5>

CALL:(PDTCH|PDTChannel):DTMode:MS:TXLevel:(DCS|EGSM|GSM450|GSM480|GSM750|GSM850|PCS|PGSM|RGSM|TGSM810):BURSt<[1]|2|3|4|5>

Function

GSM TA

 This command is not applicable to the GSM Test Application.

GPRS TA

 This command is not applicable to the GPRS Test Application.

EGPRS TA

 This command is not applicable to the GPRS Test Application.

GSM/GPRS LA

This command sets/queries the DTM packet switched MS transmit power level for any burst in the selected band.

Burst one is assumed if no burst is specified.

The optional [SELected] keyword in this command specifies that the channel being set/queried applies to the current DTM band.

The deferred version of this command is CALL:SETup:DTMode:MS:TXLevel[:SELected]:BURSt<[1]|2|3|4|5> .

See DTM MS Tx Levels for more information.

EGPRS LA

Setting

Range (all bands): 0 to 31

Resolution (all bands): 1

Query

Range (all bands): 0 to 31

Resolution (all bands): 1

*RST Setting

PGSM, EGSM, RGSM, GSM450, GSM480, GSM750, GSM850, and TGSM810 bands: 15,
DCS and PCS bands: 10
Requirements GSM/GPRS/ EGPRS LA

Revision: E.00.12 and above.

Revision F.00.27 adds Burst 5.

Programming Example

OUTPUT 714;"CALL:PDTCH:DTMode:MS:TXLevel:BURSt 10"
! Sets the DTM MS Transmit power level of burst one in the selected band to 10.

CALL:(PDTCH|PDTChannel):DTMode:MSLot:CONFig

Function

GSM TA

 This command is not applicable to the GSM Test Application.

GPRS TA

 This command is not applicable to the GPRS Test Application.

EGPRS TA

 This command is not applicable to the EGPRS Test Application.

GSM/GPRS LA

This command sets/queries the DTM multislot configuration.

The deferred version of this command is CALL:SETup:DTMode:MSLot:CONFig .

See DTM Multislot Configuration for more information.

The actual timeslots used in each configuration are fixed as in the list below.

Multislot Configuration Downlink Timeslots Used Uplink Timeslots Used

D1U1 3 3
D1U2 3 3,4
D1U3 3 3,4,5
D1U4 3 3,4,5,6
D1U5 3 2,3,4,5,6
D1U6 2 1,2,3,4,5,6
D2U1 3,4 4
D2U2 3,4 3,4
D2U3 3,4 3,4,5
D2U4 3,4 3,4,5,6
D2U5 2,3 2,3,4,5,6
D3U1 3,4,5 4
D3U2 3,4,5 4,5
D3U3 3,4,5 4,5,6
D3U4 2,3,4 3,4,5,6
D4U1 3,4,5,6 5
D4U2 3,4,5,6 5,6
D4U3 2,3,4,5 4,5,6
D5U1 2,3,4,5,6 5
D5U2 2,3,4,5,6 5,6
D6U1 1,2,3,4,5,6 5
CUSTom You can position the timeslots flexibly. See Flexible Timeslot

EGPRS LA

Setting

 Range: D1U1 |D1U2 |D1U3 |D1U4 |D1U5 |D1U6|D2U1 | D2U2 |D2U3 |D2U4 |D2U5 |D3U1 | D3U2 |D3U3 |D3U4 |D4U1 |D4U2 |D4U3 |D5U1 |D5U2 |D6U1 |CUSTom

Query

 Range: D1U1 |D1U2 |D1U3 |D1U4 |D1U5 |D1U6|D2U1 | D2U2 |D2U3 |D2U4 |D2U5 |D3U1 | D3U2 |D3U3 |D3U4 |D4U1 |D4U2 |D4U3 |D5U1 |D5U2 |D6U1 |CUST

*RST Setting

 D2U2
Requirements GSM/GPRS/ EGPRS LA

Revision: E.00.12 and above

Revision: F.00.27 adds D1U5

Revision: G.00.00 adds D1U6, D2U5, D3U4, D4U3, D5U2, D6U1 and CUSTom

Programming Example

OUTPUT 714;"CALL:PDTCH:DTMode:MSLot:CONFig D2U2"
! Sets the DTMmultislot configuration to be 2 downlink and 2 uplink timeslots.

CALL:(PDTCH|PDTChannel):DTMode:MSLot:CONFig:CUSTom:TSLots

Function

GSM TA

 This command is not applicable to the GSM Test Application.

GPRS TA

 This command is not applicable to the GPRS Test Application.

EGPRS TA

 This command is not applicable to the EGPRS Test Application.

GSM/GPRS LA

This command sets/queries the customized DTM multislot configuration. See Flexible Timeslot for more information.

The command form accepts two string parameters with each contains a maximum of 8 characters. The first string represents the timeslot usage of TS0 to TS7 of the downlink timeslots and the second string represents the timeslot usage of TS0 to TS7 of the uplink timslots. Each timeslot of the uplink and downlink can be configured to one of the three values:

  • OFF: represented by `-'. ` `, `x', `X', or `0', `-' returned by query.
  • PDCH: represented by `p', `P', or `1', `P' returned by query.
  • TCH: represented by `t' or `T', `T' returned by query

If less than 8 characters in each string are specified in a parameter, the remaining higher numbered timeslots are assumed to be OFF.

See DTM Multislot Configuration for more information.

EGPRS LA

Setting

 Range: -, ,x,X,0 |p,P,1 |t,T

Query

 Range: - |P |T

*RST Setting

 --PT----,--PT----
Requirements GSM/GPRS/ EGPRS LA

Revision: G.00.00 and above

Programming Example

OUTPUT 714;"CALL:PDTCH:DTMode:MSLot:CONFig:CUST:TSLots --PT----, --PT----"
! Sets the DTM custom multislot configuration to be 2 downlink and 2 uplink timeslots. Timeslot 2 are
! configured as PDCH and Timeslot 3 are configured as TCH in both uplink and downlink.

CALL:(PDTCH|PDTChannel):DTMode:MSLot:MEASurement:BURSt

Function

GSM TA

 This command is not applicable to the GSM Test Application.

GPRS TA

 This command is not applicable to the GPRS Test Application.

EGPRS TA

 This command is not applicable to the EGPRS Test Application.

GSM/GPRS LA

This command sets/queries which uplink burst in the DTM multislot configuration will be measured for single slot measurements when the receiver measurement burst control is AUTO.

See DTM Measured Burst for more information.

EGPRS LA

Setting

Range: 1 to 7

Resolution: 1

Query

Range: 1 to 7

Resolution: 1

*RST Setting

 1
Requirements GSM/GPRS/ EGPRS LA

Revision: E.00.12 and above

Programming Example

OUTPUT 714;"CALL:PDTCH:MSLot:MEASurement:BURSt 2"
! Sets uplink burst 2 in the DTM multislot configuration to be measured for single slot measurements.

CALL:(PDTCH|PDTChannel):DTMode:PZERo:LEVel

Function

GSM TA

 This command is not applicable to the GSM Test Application.

GPRS TA

 This command is not applicable to the GPRS Test Application.

EGPRS TA

 This command is not applicable to the EGPRS Test Application.

GSM/GPRS LA

This command sets/queries the DTM power reduction reference level. (ETSI refers to this as P0)

The deferred version of this command is CALL:SETup:DTMode:PZERo:LEVel .

See DTM Power Reduction Reference for more information.
EGPRS LA
Setting Range: 0 to 30 dB
Resolution: 2 dB
Query Range: 0 to 30 dB
Resolution: 2 dB
*RST setting 0 dB
Requirements GSM/GPRS/ EGPRS LA

Revision: E.00.12 and above

Programming Example

OUTPUT 714;"CALL:PDTCH:DTMode:PZERo:LEVel 30"
! Sets the DTM power reduction reference level (p0) to 30 dB.

CALL:(PDTCH|PDTChannel):DTMode:TTI[:MODE]

Function

GSM TA

 This command is not applicable to the GSM Test Application.

GPRS TA

 This command is not applicable to the GPRS Test Application.

EGPRS TA

 This command is not applicable to the EGPRS Test Application

GSM/GPRS LA

 This command is not applicable to the GSM/GPRS Lab Application.

EGPRS LA

 Sets/Queries the TTI mode that the TBFs will be operated in the DTM operation. See TTI Mode Configuration
Setting

Range: BTTI | RTTI
Query | BTTI | RTTI
*RST setting | BTTI
Requirements GSM/GPRS/ EGPRS LA

Revision: G.00.00 and above

Programming Example

OUTPUT 714;"CALL:PDTCH:DTMode:TTI:MODE BTTI"
! Sets the TTI mode to BTTI in the DTM operation.

CALL:(PDTCH|PDTChannel):DTMode:USFLag[:ASSigned]

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA This command is not applicable to the GPRS Test Application.

EGPRS TA

 This command is not applicable to the EGPRS Test Application.

GSM/GPRS LA

This command sets/queries the DTM uplink state flag (USF). The USF allows multiple mobile stations to share over-the-air resources.

The deferred version of this command is CALL:SETup:DTMode:USFLag[:ASSigned] .

See DTM Uplink State Flag for more information.

EGPRS LA

Setting

Range: 0 to 7

Resolution: 1

Query

Range: 0 to 7

Resolution: 1

*RST setting

 0
Requirements GSM/GPRS/ EGPRS LA

Revision: E.00.12 and above

Programming Example:

OUTPUT 714;"CALL:PDTCH:DTMode:USFLag 2"
! Sets the DTM USF to 2.

CALL:(PDTCH|PDTChannel):DTMode:USFLag:UNASsigned[:MANual]

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA This command is not applicable to the GPRS Test Application.

EGPRS TA

 This command is not applicable to the EGPRS Test Application.

GSM/GPRS LA

This command sets/queries the DTM Manual Unassigned USF value.

See DTM Manual Unassigned USF for more information.

EGPRS LA

Setting

Range: 0-7

Resolution:1

Query

Range: 0-7

Resolution: 1

*RST setting

 7
Requirements GSM/GPRS/ EGPRS LA

Revision: E.00.12 and above

Programming Example:

OUTPUT 714;"CALL:PDTCH:DTMode:USFLag:UNASsigned 2"
! Sets the DTM Manual Unassigned USF to 2.

CALL:(PDTCH|PDTChannel):EGPRS:MAPPing

Function

GSM/GPRS TA

 This command is not applicable to the GSM Test Application.
GSM LA This command is not applicable to the GPRS Test Application.

GPRS LA

 This command is not applicable to the EGPRS Test Application.

EGPRS TA

This command enables/queries EGPRS ClearCoded payload and sets/queries the EGPRS payload mapping. The different payload mapping schemes available are:

SSNormal: ClearCoded payload is disabled and the payload from the same data source spreads over all the downlink PDTCH channels. The modulation and coding scheme is determined by MCS/PS setting.
SSCLearcoded: ClearCoded payload is enabled and the payload from the same data source spreads over all the downlink PDTCH channels. The payload is directly applied to the bursts of PDTCH channel without channel coding and interleaving. If "8PSK Clearcoded" is selected in MCS/PS setting, the payload spreads over the whole burst including the headers, SB and USF fields. Otherwise, they are coded an interleaved only when the payload is Clearcoded.
MSCLearcoded: ClearCoded payload is enabled and the payload for each of the downlink PDTCH channels is independently generated. The payload is directly applied to the bursts of PDTCH channel without channel coding and interleaving. If "8PSK Clearcoded" is selected in MCS/PS setting, the payload is filled into the whole burst including the headers, SB and USF fields. Otherwise, they are coded an interleaved only when the payload is Clearcoded.

See Mobile Calculate BER Test for more information.

EGPRS LA

Setting

Range: SSNormal | SSCLearcoded | MSCLearcoded

Query

Range: SSN | SSCL| MSCL

*RST setting

 SSNormal
Requirements

 GSM/GPRS/ EGPRS TA

Revision: A.09 and above with required feature license.
GSM/GPRS/ EGPRS LA

Revision: F.01 and above.

Programming Example:

OUTPUT 714;"CALL:PDTCH:EGPRS:MAPPing SSCLearcoded"
! Sets EGPRS data sources to Single Source, ClearCoded payload.

CALL:(PDTCH|PDTChannel):ESPolling

Function

GSM TA

 This command is not applicable to the GSM Test Application.

GPRS TA

 This command is not applicable to the GPRS Test Application.

GSM/GPRS LA

 This command is not applicable to the GSM/GPRS Lab Application.

EGPRS TA

 This command is not applicable to the EGPRS Test Application.

EGPRS LA

 This command sets/queries the setting of the EGPRS Supplementary Polling parameter.
Setting Range: 0 | 1 | 2 | 3
0 - RRBP field is invalid (no polling)
1 - RRBP field valid, extended Ack/Nack type FPB
2 - RRBP field valid, extended Ack/Nack type NPB
3 - RRBP field valid, extended Ack/Nack type NPB, with measurement reports
Query | Range: 0 | 1 | 2| 3
*RST setting | 1
Requirements GSM/GPRS/ EGPRS LA

Revision: C.03 and above

Programming Example

OUTPUT 714;"CALL:PDTCH:ESP 0"
! Sets the EGPRS Supplementary Polling value to 0.

CALL:(PDTCH|PDTChannel):FHOPping[:STATe]

Function

GSM TA

 This command is not applicable to the GSM Test Application.

GPRS TA

 This command is not applicable to the GPRS Test Application.

EGPRS TA

 This command is not applicable to the EGPRS Test Application.

GSM/GPRS LA

This command enables/queries the state of Frequency Hopping for GPRS or EGPRS Packet Data Traffic Channels.

If this command is attempted while there is an active DTM connection or while the test set is in a DTM test operating mode, it is stored and applied when the test set is no longer in Dual Transfer Mode.

EGPRS LA
Setting | Range: 0 | OFF | 1 | ON
Query | Range: 0 | 1
*RST setting | 0 |OFF
Requirements GSM/GPRS/ EGPRS LA

Revision: D.01 and above

Programming Example

OUTPUT 714;"CALL:PDTCH:FHOPping ON"
! Enables Frequency Hopping.

CALL:(PDTCH|PDTChannel):FHOPping:HSNumber

Function

GSM TA

 This command is not applicable to the GSM Test Application.

GPRS TA

 This command is not applicable to the GPRS Test Application.

EGPRS TA

 This command is not applicable to the EGPRS Test Application.

GSM/GPRS LA

 Sets/queries which hopping sequence the test set uses to switch between available frequencies for the GPRS or EGPRS Packet Data Traffic Channels. There are 64 different hopping sequences that are numbered from 0-63. When the Hopping Sequence Number (HSN) is zero, it corresponds to a cyclic hopping sequence. All other HSNs correspond to different pseudo random hopping sequences.

EGPRS LA
Setting Range: 0 to 63
Resolution: 1
Query Range: 0 to 63
Resolution: 1
*RST setting 0
Requirements GSM/GPRS/ EGPRS LA

Revision: D.01

Programming Example

OUTPUT 714;"CALL:PDTCH:FHOPping:HSNumber 55"
! Sets the Hopping Sequence Number (HSN) to 55.

C ALL:(PDTCH|PDTChannel):FHOPping:MAIOffset[:SELected]

CALL:(PDTCH|PDTChannel):FHOPping:MAIOffset:(DCS|EGSM|GSM450|GSM480|GSM750|GSM850|PCS|PGSM|RGSM|TGSM810)

Function

GSM TA

 This command is not applicable to the GSM Test Application.

GPRS TA

 This command is not applicable to the GPRS Test Application.

EGPRS TA

 This command is not applicable to the EGPRS Test Application.

GSM/GPRS LA

This command sets/queries the Mobile Allocation Index Offset (MAIO), which determines where in the Mobile Allocation (MA) Table the hopping sequence begins. If the MAIO is set to a value greater than the number of entries in a the Mobile Allocation (MA) Table, the MAIO shall be set to zero.

The optional [SELected] keyword in this command specifies that the channel being set/queried applies to the current cell band.

EGPRS LA
Setting

Range: 0 to15

Resolution: 1
Query

Range: 0 to15

Resolution: 1
*RST setting 0
Requirements GSM/GPRS/ EGPRS LA

Revision: D.01 and above

Revision D.03 adds the TGSM810 band.

Programming Example

OUTPUT 714;"CALL:PDTCH:FHOPping:MAIOffset 8"
! Sets MAIO so it starts in the middle Mobile Allocation (MA) table,
! which contains the available frequencies.

CALL:(PDTCH|PDTChannel):IREDundancy[:STATe]

Function

GSM TA

 This command is not applicable to the GSM Test Application.

GPRS TA

 This command is not applicable to the GPRS Test Application.

EGPRS TA

 This command is not applicable to the EGPRS Test Application.

GSM/GPRS LA

 This command is not applicable to the GSM/GPRS Lab Application.

EGPRS LA

 This command sets/queries the state of Incremental Redundancy for EGPRS.
Setting | Range: 0 | OFF | 1 | ON
Query | Range: 0 | 1
*RST setting | 0 | OFF
Requirements GSM/GPRS/ EGPRS LA

Revision: C.03 and above

Programming Example

OUTPUT 714;"CALL:PDTCH:IRED 1"
! Turns on Incremental Redundancy.

CALL:(PDTCH|PDTChannel):MA:MEASurement:ARFCN[:SELected]

CALL:(PDTCH|PDTChannel):MA:MEASurement:ARFCN :(DCS|EGSM|GSM450|GSM480|GSM750|GSM850|PCS|PGSM|RGSM|TGSM810)

Function

GSM TA

 This command is not applicable to the GSM Test Application.

GPRS TA

 This command is not applicable to the GPRS Test Application.

EGPRS TA

 This command is not applicable to the EGPRS Test Application.

GSM/GPRS LA

This command sets/queries the ARFCN the measurement down converter is set to in the MA Table for a particular cell band for GPRS or EGPRS packet data traffic channels.

The optional [SELected] keyword in this command specifies that the channel being set/queried applies to the current cell band.

EGPRS LA
Setting

Depends upon the selected broadcast band.

Range:

  • DCS broadcast band range: 512 to 885
  • EGSM broadcast band range: 0 to 124 | 975 to 1023
  • GSM450 broadcast band range: 259 to 293
  • GSM480 broadcast band range: 306 to 340
  • GSM750 broadcast band range: 438 to 511
  • GSM850 broadcast band range: 128 to 251
  • PCS broadcast band range: 512 to 810
  • PGSM broadcast band range: 1 to 124
  • RGSM broadcast band range: 0 to 124 | 955 to 1023
  • TGSM810 broadcast band range: 350 to 425

Resolution: 1
Query

Depends upon the selected broadcast band.

Range:

  • DCS broadcast band range: 512 to 885
  • EGSM broadcast band range: 0 to 124 | 975 to 1023
  • GSM450 broadcast band range: 259 to 293
  • GSM480 broadcast band range: 306 to 340
  • GSM750 broadcast band range: 438 to 511
  • GSM850 broadcast band range: 128 to 251
  • PCS broadcast band range: 512 to 810
  • PGSM broadcast band range: 1 to 124
  • RGSM broadcast band range: 0 to 124 | 955 to 1023
  • TGSM810 broadcast band range: 350 to 425

Resolution: 1
*RST setting +9.91E37 (NAN)
Requirements GSM/GPRS/ EGPRS LA

Revision: D.01 and above

Revision D.03 adds the TGSM810 band.

Programming Example

OUTPUT 714;"CALL:PDTCH:MA:MEASurement:PCS 661"
! Sets measurement ARFCN to 661.

CALL:(PDTCH|PDTChannel):MA:TABLe:CONFig:AUTO

Function

GSM TA

 This command is not applicable to the GSM Test Application.

GPRS TA

 This command is not applicable to the GPRS Test Application.

EGPRS TA

 This command is not applicable to the EGPRS Test Application.

GSM/GPRS LA

This command sets/queries the state of Mobile Allocation (MA) Table configuration for GPRS and EGPRS packet data traffic channels. If the configuration state is OFF you can update the MA Tables manually. If the configuration state is ON the test set automatically populates the MA Tables for each cell band with the applicable values in the CA Table. The command to set the CA Table entries is: CALL:CA:TABLe .

All values entered into the MA Tables, either manually or automatically, are in the ON state.

EGPRS LA
Setting | Range: 0 | OFF | 1 | ON
Query | Range: 0 | 1
*RST setting | 1|ON
Requirements GSM/GPRS/ EGPRS LA

Revision: D.01 and above

Programming Example

OUTPUT 714;"CALL:PDTCH:MA:TABLe:CONFig:AUTO ON"
! Enables automatic configuation of the Mobile Allocation (MA) Table.

CALL:(PDTCH|PDTChannel):MA:TABLe[:AUTO][:SELected]?

CALL:(PDTCH|PDTChannel):MA:TABLe[:AUTO]:(DCS|EGSM|GSM450|GSM480|GSM750|GSM850|PCS|PGSM|RGSM|TGSM810)?

Function

GSM TA

 This command is not applicable to the GSM Test Application.

GPRS TA

 This command is not applicable to the GPRS Test Application.

EGPRS TA

 This command is not applicable to the EGPRS Test Application.

GSM/GPRS LA

This command queries the channels in the Mobile Allocated (MA) Table for the selected band for a GPRS or EGPRS packet data traffic channel.

The optional [SELected] keyword in this command specifies that the channel being set/queried applies to the current cell band.

EGPRS LA
Query

Depends upon the selected broadcast band:

  • DCS broadcast band range: 512 to 885
  • EGSM broadcast band range: 0 to 124 | 975 to 1023
  • GSM450 broadcast band range: 259 to 293
  • GSM480 broadcast band range: 306 to 340
  • GSM750 broadcast band range: 438 to 511
  • GSM850 broadcast band range: 128 to 251
  • PCS broadcast band range: 512 to 810
  • PGSM broadcast band range: 1 to 124
  • RGSM broadcast band range: 0 to 124 | 955 to 1023
  • TGSM810 broadcast band range: 350 to 425

Resolution: 1
*RST setting

Depends on the selected band. (PGSM is the default band.)

  • DCS: 520, 661, 810, 885

  • EGSM: 1, 124, 975

  • GSM450: 259, 293

  • GSM480: 306, 340

  • GSM750: 438, 511

  • GSM850: 128, 251

  • PCS: 520, 661, 810

  • PGSM: 1, 124

  • RGSM: 1, 124, 955, 975

  • TGSM810: +9.91E37 (NAN)
Requirements GSM/GPRS/ EGPRS LA

Revision: D.01 and above

D.03 adds the TGSM810 band.

Programming Example

OUTPUT 714;"CALL:PDTCH:MA:TABLe:PGSM?"
! Queries the channels listed in the Mobile Allocated (MA) Table for the PGSM band.

CALL:(PDTCH|PDTChannel):MA:TABLe[:AUTO]:POINts[:SELected]?

CALL:(PDTCH|PDTChannel):MA:TABLe[:AUTO]:POINts:(DCS|EGSM|GSM450|GSM480|GSM750|GSM850|PCS|PGSM|RGSM|TGSM810)?

Function

GSM TA

 This command is not applicable to the GSM Test Application.

GPRS TA

 This command is not applicable to the GPRS Test Application.

EGPRS TA

 This command is not applicable to the EGPRS Test Application.

GSM/GPRS LA

This command queries the number of ARFCNs that were automatically entered from the Cell Allocation (CA) Table into the Mobile Allocated (MA) Table for the selected band (for a GPRS or EGPRS packet data traffic channel).

The optional [SELected] keyword in this command specifies that the channel being set/queried applies to the current cell band.

EGPRS LA
Query

Range: 1 through 16

Resolution: 1
*RST setting
  • DCS: 4

  • EGSM: 3

  • GSM450: 2

  • GSM480: 2

  • GSM750: 2

  • GSM850: 2

  • PCS: 3

  • PGSM: 2

  • RGSM: 4

  • TGSM810: 0
Requirements GSM/GPRS/ EGPRS LA

Revision: D.01 and above

D.03 adds the TGSM810 band.

Programming Example

OUTPUT 714;"CALL:PDTCH:MA:TABLe:POINts:PCS"
! Queries how many ARFCNs are in the Mobile Allocation (MA) Table for the PCS band.

CALL:(PDTCH|PDTChannel):MA:TABLe:MANual[:SELected]

CALL:(PDTCH|PDTChannel):MA:TABLe:MANual:(DCS|EGSM|GSM450|GSM480|GSM750|GSM850|PCS|PGSM|RGSM|TGSM810)

Function

GSM TA

 This command is not applicable to the GSM Test Application.

GPRS TA

 This command is not applicable to the GPRS Test Application.

EGPRS TA

 This command is not applicable to the EGPRS Test Application.

GSM/GPRS LA

This command sets/queries the ARFCNs that were manually assigned to the Mobile Allocated (MA) Table for a GPRS or EGPRS packet data traffic channel. ARFCNs are entered into the MA Table using a comma separated list of up to 16 values. Only values that are in the Cell Allocation (CA) Table are valid entries in the MA Table. The states of the MA Table entries that are not included in the list are set to OFF.

The optional [SELected] keyword in this command specifies that the channel being set/queried applies to the current cell band.

The command for configuring the CA Table is CALL:CA:TABLe .

EGPRS LA
Setting

Depends upon the selected broadcast band.

Range:

  • DCS broadcast band range: 512 to 885
  • EGSM broadcast band range: 0 to 124 | 975 to 1023
  • GSM450 broadcast band range: 259 to 293
  • GSM480 broadcast band range: 306 to 340
  • GSM750 broadcast band range: 438 to 511
  • GSM850 broadcast band range: 128 to 251
  • PCS broadcast band range: 512 to 810
  • PGSM broadcast band range: 1 to 124
  • RGSM broadcast band range: 0 to 124 | 955 to 1023
  • TGSM810 broadcast band range: 350 to 425

Resolution: 1
Query

Depends upon the selected broadcast band.

Range:

  • DCS broadcast band range: 512 to 885
  • EGSM broadcast band range: 0 to 124 | 975 to 1023
  • GSM450 broadcast band range: 259 to 293
  • GSM480 broadcast band range: 306 to 340
  • GSM750 broadcast band range: 438 to 511
  • GSM850 broadcast band range: 128 to 251
  • PCS broadcast band range: 512 to 810
  • PGSM broadcast band range: 1 to 124
  • RGSM broadcast band range: 0 to 124 | 955 to 1023
  • TGSM810 broadcast band range: 350 to 425

Resolution: 1
*RST setting

  • DCS: 520, 661, 810, 885

  • EGSM: 1, 124, 975

  • GSM450: 259, 293

  • GSM480: 306, 340

  • GSM750: 438, 511

  • GSM850: 128, 251

  • PCS: 520, 661, 810

  • PGSM: 1, 124

  • RGSM: 1, 124, 955, 975

  • TGSM810: +9.91E37 (NAN)
Requirements GSM/GPRS/ EGPRS LA

Revision: D.01 and above

D.03 adds the TGSM810 band.

Programming Example

OUTPUT 714;"CALL:PDTCH:MA:TABLe:MANual 512"
! Sets the ARFCN of the MA Table to 512, if 512 is valid for the selected band.

CALL:(PDTCH|PDTChannel):MA:TABLe:MANual:POINts[:SELected]?

CALL:(PDTCH|PDTChannel):MA:TABLe:MANual:POINts:(DCS|EGSM|GSM450|GSM480|GSM750|GSM850|PCS|PGSM|RGSM|TGSM810)?

Function

GSM TA

 This command is not applicable to the GSM Test Application.

GPRS TA

This command queries the number of ARFCNs that were manually assigned to the Mobile Allocated (MA) Table for a GPRS or EGPRS packet data traffic channel.

The optional [SELected] keyword in this command specifies that the channel being set/queried applies to the current cell band.

The command to set the values of the MA Table of a particular band is CALL:(PDTCH|PDTChannel):MA:TABLe:MANual[:SELected] .

EGPRS TA

GSM/GPRS LA

EGPRS LA
Query

Range: 1 through 16

Resolution: 1
*RST setting
  • DCS: 4

  • EGSM: 3

  • GSM450: 2

  • GSM480: 2

  • GSM750: 2

  • GSM850: 2

  • PCS: 3

  • PGSM: 2

  • RGSM: 4

  • TGSM810: 0
Requirements GSM/GPRS/ EGPRS LA

Revision: D.01 and above

D.03 adds the TGSM810 band.

Programming Example

OUTPUT 714;"CALL:PDTCH:MA:TABLe:MANual:POINts:PCS?"
! Queries the number of ARFCNs that were manually assigned to the Mobile Allocated (MA) Table.

CALL:(PDTCH|PDTChannel):MACCess

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA | This command is not applicable to the GPRS Test Application.
EGPRS TA | This command is not applicable to the EGPRS Test Application.

GSM/GPRS LA

This command sets/queries the Medium Access Mode. The Medium Access Modes the test set offers are:

Fixed Allocation

Automatic Dynamic Allocation

Dynamic Allocation

Extended Dynamic Allocation

For information on these modes see Medium Access Mode .

EGPRS LA

Setting

 FIXed | ADYNamic| DYNamic | EXTended

Query

 FIX | ADYN | DYN | EXT

*RST setting

 ADYN
Requirements GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Revision D.01 adds ADYNamic and EXTended

Programming Example

OUTPUT 714;"CALL:PDTCH:MACCess EXTended"
! Sets the Medium Access Mode to Extended Dynamic Allocation.

CALL:(PDTCH|PDTChannel):MACCess:FIXed:MOALlocation:STATe

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA This command is not applicable to the GPRS Test Application.

EGPRS TA

 This command is not applicable to the EGPRS Test Application.

GSM/GPRS LA

Enables the Maximum Octet Allocation.

EGPRS LA

Setting

 0 | OFF | 1 | ON

Query

 0 | 1

*RST setting

 0|OFF
Requirements GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example:

OUTPUT 714;"CALL:PDTCH:MACCess:FIXed:MOALlocation:STATe ON"
! Enables the maximum octed allocation.

CALL:(PDTCH|PDTChannel):MACCess:FIXed:MOALlocation:NUMBer

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA This command is not applicable to the GPRS Test Application.

EGPRS TA

 This command is not applicable to the EGPRS Test Application.

GSM/GPRS LA

Sets the maximum number of octets to be allocated.

EGPRS LA

Setting

 range 1-9999

Query

 range 1-9999

*RST setting

 1024
Requirements GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example:

OUTPUT 714;"CALL:PDTCH:MACCess:FIXed:MOALlocation:STATe ON"
! Enables the maximum octed allocation.

OUTPUT 714;"CALL:PDTCH:MACCess:FIXed:MOALlocation:NUMBer 200"
! Limits the number of octets to be allocated to 200.

CALL:(PDTCH|PDTChannel):MACCess[:DYNamic]:USFLag[:ASSigned]

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA This command is not applicable to the GPRS Test Application.

EGPRS TA

 This command is not applicable to the EGPRS Test Application.

GSM/GPRS LA

This command sets/queries the uplink state flag (USF). The USF allows multiple mobile stations to share over-the-air resources.

EGPRS LA

Setting

Range: 0 to 7

Resolution: 1

Query

Range: 0 to 7

Resolution: 1

*RST setting

 0
Requirements GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Revision D.01 adds the optional ASSigned mnemonic

Programming Example:

OUTPUT 714;"CALL:PDTCH:MACCess:USFLag 2"
! Sets the Assigned USF to 2.

CALL:(PDTCH|PDTChannel):MACCess[:DYNamic]:USFLag[:ASSigned]:GRANularity

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA This command is not applicable to the GPRS Test Application.

EGPRS TA

 This command is not applicable to the EGPRS Test Application.

GSM/GPRS LA

This command sets/queries the USF Granularity. See Assigned USF Granularity for more information.

EGPRS LA

Setting

Range: USFG1 | USFG4

Query

Range: USFG1 | USFG4

*RST setting

 USFG1
Requirements GSM/GPRS/ EGPRS LA

Revision: F.00.27 and above

Programming Example:

OUTPUT 714;"CALL:PDTCH:MACC:USFL:GRAN USFG1"
! Sets the USF Granularity to 1.

CALL:(PDTCH|PDTChannel):MACCess[:DYNamic]:USFLag:PERCent

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA This command is not applicable to the GPRS Test Application.

EGPRS TA

 This command is not applicable to the EGPRS Test Application.

GSM/GPRS LA

This command sets/queries the percentage of unassigned uplink state flag (USF) blocks to transmit.

EGPRS LA

Setting

Range: 0-100%

Resolution: 1%

Query

Range: 0-100%

Resolution: 1%

*RST setting

 100
Requirements GSM/GPRS/ EGPRS LA

Revision: D.01 and above

Programming Example:

OUTPUT 714;"CALL:PDTCH:MACCess:USFLag:PERCent 95"
! Sets the Assigned USF Allocation to 95%. Since the assigned allocation is less than 100%,
! the remaining 5% is Unassigned USF Allocation.

CALL:(PDTCH|PDTChannel):MACCess[:DYNamic]:USFLag:UNASsigned[:MANual]

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA This command is not applicable to the GPRS Test Application.

EGPRS TA

 This command is not applicable to the EGPRS Test Application.

GSM/GPRS LA

This command sets/queries the Unassigned USF value.

EGPRS LA

Setting

Range: 0-7

Resolution:1

Query

Range: 0-7

Resolution: 1

*RST setting

 7
Requirements GSM/GPRS/ EGPRS LA

Revision: D.01 and above

Programming Example:

OUTPUT 714;"CALL:PDTCH:MACCess:USFLag 2"
! Sets the Assigned USF to 2.

OUTPUT 714;"CALL:PDTCH:MACCess:USFLag:UNASsigned 2"
! Does not set the Unassigned USF to 2 because the Assigned USF and
! the Unssigned USF cannot be the same value.

OUTPUT 714;"CALL:PDTCH:MACCess:USFLag:UNASsigned?"
! The value of the Unassigned USF is +7.

CALL:(PDTCH|PDTChannel):MACCess[:DYNamic]:USFLag:UNASsigned:MODE

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA This command is not applicable to the GPRS Test Application.

EGPRS TA

 This command is not applicable to the EGPRS Test Application.

GSM/GPRS LA

This command sets/queries the uplink state flag (USF) mode. The USF allows multiple mobile stations to share over-the-air resources.

The available modes are: Manual Unassigned USF , Random Unassigned USF , and Random Burst .

EGPRS LA

Setting

Range: MUSF|RUSF|RBURst

Query

Range: MUSF|RUSF|RBUR

*RST setting

 RUSF
Requirements GSM/GPRS/ EGPRS LA

Revision: D.01 and above

Programming Example:

OUTPUT 714;"CALL:PDTCH:MACCess:USFLag:UNASsigned:MODE RUSF"
! Sets the Unassigned USF mode to Random Unassigned USF mode.

CALL:(PDTCH|PDTChannel):MCSCheme

Function

GSM TA

 This command is not applicable to the GSM TA.

GPRS TA

 This command is not applicable to the GPRS TA.

GSM/GPRS LA

 This command is not applicable to the GSM/GPRS LA.
EGPRS TA

This command sets/queries the modulation coding scheme used for transmission on the downlink and uplink in Active Cell operating mode. Modulation coding schemes MCS1 through MCS4 use GMSK modulation, while MCS5 to MCS9 use 8PSK modulation.

If this command is attempted while there is an active DTM connection or while the test set is in a DTM test operating mode, it is stored and applied when the test set is no longer in Dual Transfer Mode

EGPRS LA
Setting

Range: <downlink>, <uplink>

<downlink> can be set to one of the following values:

  • MCS1 | MCS2 | MCS3 | MCS4 | MCS5 | MCS6 | MCS7 | MCS8 | MCS9

<uplink> can be set to one of the following values:

  • MCS1 | MCS2 | MCS3 | MCS4 | MCS5 | MCS6 | MCS7 | MCS8 | MCS9
Query

Range: <downlink>, <uplink>

<downlink> returns one of the following values:

  • MCS1 | MCS2 | MCS3 | MCS4 | MCS5 | MCS6 | MCS7 | MCS8 | MCS9

<uplink> returns one of the following values:

  • MCS1 | MCS2 | MCS3 | MCS4 | MCS5 | MCS6 | MCS7 | MCS8 | MCS9
*RST setting MCS4,MCS4

Requirements

 GSM/GPRS/ EGPRS TA Revision: A.03 and above

GSM/GPRS/
EGPRS LA

 Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:PDTCH:MCSCheme MCS1, MCS1"
! Sets the PDTCH modulation coding scheme for the downlink and uplink to MCS1.

CALL:(PDTCH|PDTChannel):MCSCheme:EBPTest[:BURSt1]

Function

GSM TA

 This command is not applicable to the GSM TA.

GPRS TA

 This command is not applicable to the GPRS TA.

GSM/GPRS LA

 This command is not applicable to the GSM/GPRS LA.

EGPRS TA

This command allows you to set/query the modulation coding scheme and downlink puncturing scheme for the first downlink burst of a multislot transmission in EGPRS BCH+PDTCH test mode.

For information on the parameters this command accepts, see Modulation Coding Scheme / Puncturing Scheme Options .

You may set/query the other downlink bursts in the selected multislot configuration using the command: CALL:(PDTCH|PDTChannel):MCSCheme:EBPTest:BURSt<2|3|4|5> .

NOTE
MCS7-MCS9 allow two data blocks to be embedded in each radio block. These data blocks can have the same or different puncturing schemes. For example, MCS9P3-2 uses MCS 9, with puncturing scheme 3 on the first data block and puncturing scheme 2 on the second data block.

EGPRS LA
Setting

Range:

MCS1P1 | MCS1P2 | MCS2P1 | MCS2P2 | MCS3P1 | MCS3P2 | MCS3P3 | MCS4P1 | MCS4P2 | MCS4P3 | MCS5P1 | MCS5P2 | MCS6P1 | MCS6P2 | MCS7P1_1 | MCS7P1_2 | MCS7P1_3 | MCS7P2_1 | MCS7P2_2 | MCS7P2_3 | MCS7P3_1 | MCS7P3_2 | MCS7P3_3 | MCS8P1_1 | MCS8P1_2 | MCS8P1_3 | MCS8P2_1 | MCS8P2_2 | MCS8P2_3 | MCS8P3_1 | MCS8P3_2 | MCS8P3_3 | MCS9P1_1 | MCS9P1_2 | MCS9P1_3 | MCS9P2_1 | MCS9P2_2 | MCS9P2_3 | MCS9P3_1 | MCS9P3_2 | MCS9P3_3 | EPSKCLEAR
Query

Range:

MCS1P1 | MCS1P2 | MCS2P1 | MCS2P2 | MCS3P1 | MCS3P2 | MCS3P3 | MCS4P1 | MCS4P2 | MCS4P3 | MCS5P1 | MCS5P2 | MCS6P1 | MCS6P2 | MCS7P1_1 | MCS7P1_2 | MCS7P1_3 | MCS7P2_1 | MCS7P2_2 | MCS7P2_3 | MCS7P3_1 | MCS7P3_2 | MCS7P3_3 | MCS8P1_1 | MCS8P1_2 | MCS8P1_3 | MCS8P2_1 | MCS8P2_2 | MCS8P2_3 | MCS8P3_1 | MCS8P3_2 | MCS8P3_3 | MCS9P1_1 | MCS9P1_2 | MCS9P1_3 | MCS9P2_1 | MCS9P2_2 | MCS9P2_3 | MCS9P3_1 | MCS9P3_2 | MCS9P3_3 | EPSKCLEAR
*RST setting MCS4P1

Requirements

 GSM/GPRS/EGPRS TA

Revision: A.03 and above

Revision A.04 adds the Optional BURSt1 mnemonic

GSM/GPRS/
EGPRS LA

Revision: C.01 and above

Revision D.01 adds the Optional BURSt1 mnemonic

Programming Example

OUTPUT 714;"CALL:PDTCH:MCSCheme:EBPTest MCS1P2"
! Sets the PDTCH modulation coding scheme for the first downlink burst in the multislot
! configuration to MCS1, puncturing scheme P2 for EGPRS BCH+PDTCH test mode.

CALL:(PDTCH|PDTChannel):MCSCheme:EBPTest:BURSt<2|3|4|5>

Function

GSM TA

 This command is not applicable to the GSM TA.

GPRS TA

 This command is not applicable to the GPRS TA.

GSM/GPRS LA

 This command is not applicable to the GSM/GPRS LA.

EGPRS TA

This command allows you to set/query the modulation coding scheme and downlink puncturing scheme for each downlink burst of a multislot transmission in EGPRS BCH+PDTCH test mode. Modulation coding schemes MCS1 through MCS4 use GMSK modulation, while MCS5 to MCS9 use 8PSK modulation.

For information on the parameters this command accepts, see Modulation Coding Scheme / Puncturing Scheme Options .

You may set/query the first downlink burst in the selected multislot configuration using the command: CALL:(PDTCH|PDTChannel):MCSCheme:EBPTest[:BURSt1] .

NOTE
MCS7-MCS9 allow two data blocks to be embedded in each radio block. These data blocks can have the same or different puncturing schemes. For example, MCS9P3_2 uses MCS9, with puncturing scheme 3 on the first data block and puncturing scheme 2 on the second data block.

EGPRS LA
Setting

Range:

MCS1P1 | MCS1P2 | MCS2P1 | MCS2P2 | MCS3P1 | MCS3P2 | MCS3P3 | MCS4P1 | MCS4P2 | MCS4P3 | MCS5P1 | MCS5P2 | MCS6P1 | MCS6P2 | MCS7P1_1 | MCS7P1_2 | MCS7P1_3 | MCS7P2_1 | MCS7P2_2 | MCS7P2_3 | MCS7P3_1 | MCS7P3_2 | MCS7P3_3 | MCS8P1_1 | MCS8P1_2 | MCS8P1_3 | MCS8P2_1 | MCS8P2_2 | MCS8P2_3 | MCS8P3_1 | MCS8P3_2 | MCS8P3_3 | MCS9P1_1 | MCS9P1_2 | MCS9P1_3 | MCS9P2_1 | MCS9P2_2 | MCS9P2_3 | MCS9P3_1 | MCS9P3_2 | MCS9P3_3 | EPSKCLEAR | ASBURST1
Query

Range:

MCS1P1 | MCS1P2 | MCS2P1 | MCS2P2 | MCS3P1 | MCS3P2 | MCS3P3 | MCS4P1 | MCS4P2 | MCS4P3 | MCS5P1 | MCS5P2 | MCS6P1 | MCS6P2 | MCS7P1_1 | MCS7P1_2 | MCS7P1_3 | MCS7P2_1 | MCS7P2_2 | MCS7P2_3 | MCS7P3_1 | MCS7P3_2 | MCS7P3_3 | MCS8P1_1 | MCS8P1_2 | MCS8P1_3 | MCS8P2_1 | MCS8P2_2 | MCS8P2_3 | MCS8P3_1 | MCS8P3_2 | MCS8P3_3 | MCS9P1_1 | MCS9P1_2 | MCS9P1_3 | MCS9P2_1 | MCS9P2_2 | MCS9P2_3 | MCS9P3_1 | MCS9P3_2 | MCS9P3_3 | EPSKCLEAR | ASBURST1
*RST setting

Burst 2: ASBURST1
Burst 3: ASBURST1
Burst 4: ASBURST1
Burst 5: ASBURST1
Burst 6: ASBURST1

Note: MCS4P1 is the default modulation coding scheme/puncturing scheme for burst 1.

Requirements

 GSM/GPRS/ EGPRS TA Revision: A.04 and above
Revision A.09 adds Burst 5.

GSM/GPRS/
EGPRS LA

 Revision: D.01 and above
Revision E.00.08 adds Burst 5

Programming Example

OUTPUT 714;"CALL:PDTCH:MSLot:CONFig D4U1"
! Sets the multislot configuration to be 4 downlink PDTCHs and 1 uplink PDTCH.

OUTPUT 714;"CALL:PDTCH:MCSCheme:EBPTest MCS1P2"
! Sets the first burst's PDTCH Modulation Coding Scheme (MCS) to MCS 1 (an GMSK modulated signal)
! and puncturing scheme P2 for EGPRS BCH+PDTCH test mode.

OUTPUT 714;"CALL:PDTCH:MCSCheme:EBPTest:BURSt2 MCS9P2_1"
! Burst 2 uses MCS 9 (an 8PSK modulated signal) and puncuturing scheme 2_1

OUTPUT 714;"CALL:PDTCH:MCSCheme:EBPTest:BURSt3 MCS7P1_3"
! Burst 3 uses MCS 7 (8PSK modulated siganl)

OUTPUT 714;"CALL:PDTCH:MCSCheme:EBPTest:BURSt4 ASBURSt1"
! Burst 4 is set to the same MCS  as burst 1 which is MCS1P2.

CALL:(PDTCH|PDTChannel):MCSCheme:PSCHeme

Function

GSM TA

 This command is not applicable to the GSM Test Application.

GPRS TA

 This command is not applicable to the GPRS Test Application.

GSM/GPRS LA

 This command is not applicable to the GSM/GPRS Lab Application.

EGPRS TA

 This command is not applicable to the EGPRS Test Application.

EGPRS LA

 This command sets/queries the Puncturing Scheme for EGPRS used in Active Cell mode when Incremental Redundancy is turned off (See CALL:(PDTCH|PDTChannel):IREDundancy[:STATe] ).
Setting Range: PS1 | PS2 | PS3 for MCS 3,4,7,8,and 9
Range: PS1 | PS2 for MCS 1, 2, 5, and 6
Query | Range: PS1 | PS2 | PS3
*RST setting | PS1
Requirements GSM/GPRS/ EGPRS LA

Revision: C.03 and above

Programming Example

OUTPUT 714;"CALL:PDTCH:MCSC:PSCH PS2"
! Sets the Puncturing Scheme to 1/2 rate.

CALL:(PDTCH|PDTChannel):MCSCheme:SWITch[:STATe]

Function

GSM TA

 This command is not applicable to the GSM Test Application.

GPRS TA

 This command is not applicable to the GPRS Test Application.

GSM/GPRS LA

 This command is not applicable to the GSM/GPRS Lab Application.

EGPRS TA

 This command is not applicable to the EGPRS Test Application.

EGPRS LA

 This command sets/queries the state of Modulation Coding Scheme Switching for EGPRS.
Setting | Range: 0 | OFF | 1 | ON
Query | Range: 0 | 1
*RST setting | 0 | OFF
Requirements GSM/GPRS/ EGPRS LA

Revision: C.03 and above

Programming Example

OUTPUT 714;"CALL:PDTCH:MCSC:SWIT 1"
! Turns on Modulation Coding Scheme Switching.

CALL:(PDTCH|PDTChannel):MCSCheme:SWITch:RESegment[:STATe]

Function

GSM TA

 This command is not applicable to the GSM Test Application.

GPRS TA

 This command is not applicable to the GPRS Test Application.

GSM/GPRS LA

 This command is not applicable to the GSM/GPRS Lab Application.

EGPRS TA

 This command is not applicable to the EGPRS Test Application.

EGPRS LA

 This command enables downlink resegmentation. This allows MCS switching between all the families defined in 3GPP TS 04.60 Section 10.3a.
Setting | 0 | OFF | 1 | ON
Query | 0 | 1
*RST setting | 0 | Off
Requirements GSM/GPRS/ EGPRS LA

Revision: C.03 and above

Programming Example

OUTPUT 714;"CALL:PDTCH:MCSC:SWIT:RES ON"
! Enables downlink resegmentation.

CALL:(PDTCH|PDTChannel):MCSCheme:SWITch:RETRansmit

Function

GSM TA

 This command is not applicable to the GSM Test Application.

GPRS TA

 This command is not applicable to the GPRS Test Application.

GSM/GPRS LA

 This command is not applicable to the GSM/GPRS Lab Application.

EGPRS TA

 This command is not applicable to the EGPRS Test Application.

EGPRS LA

 This command sets/queries the number of times an RLC data block is retransmitted before a Modulation Coding Scheme Switch takes place.
Setting Range: 1 to 500
Resolution: 1
Query Range: 1 to 500
Resolution: 1
*RST setting 15
Requirements GSM/GPRS/ EGPRS LA

Revision: C.03 and above

Programming Example

OUTPUT 714;"CALL:PDTCH:MCSC:SWIT:RETR 40"
! Sets the test set to change the Modulation Coding Scheme after 40
! retransmissions of an RLC data block.

CALL:(PDTCH|PDTChannel):MS:ALPHa

Function

GSM TA

 This command is not applicable to the GSM Test Application.

GPRS TA

 This command is not applicable to the GPRS Test Application.
EGPRS TA This command is not applicable to the EGPRS Test Application.

GSM/GPRS LA

This command sets/queries the proportion value of measured broadcast channel. See MS Output Power for more information.

EGPRS LA

Setting

Range: 0.0 to 1.0

Resolution: 0.1

Query

Range: 0.0 to 1.0

Resolution: 0.1

*RST Setting

 0
Requirements

GSM/GPRS/
EGPRS LA

 Revision: F.00.37 and above

Programming Example

OUTPUT 714;"CALL:PDTCH:MS:ALPHa 0.5"
! Sets the Alpha Parameter to 0.5.

CALL:(PDTCH|PDTChannel):MS:GAMMa:BURSt<[1]|2|3|4|5>[:SELected]

CALL:(PDTCH|PDTChannel):MS:GAMMa:BURSt<[1]|2|3|4|5>:(DCS|EGSM|GSM450|GSM480|GSM750|GSM850|PCS|PGSM|RGSM|TGSM810)

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA This command sets/queries the gamma value for any uplink burst in the selected band. The range of gamma 0 to 31 represents 0 to 62dB in 2 dB steps. See MS Output Power for more information.
EGPRS LA

Setting

Range: 0 to 31

Resolution: 1

Query

Range: 0 to 31

Resolution: 1

*RST setting

 13
Requirements GSM/GPRS/ EGPRS LA

Revision: F.00.37 and above

Programming Example

OUTPUT 714;CALL:PDTCH:MS:GAMMa:BURSt2 14
! Sets the gamma parameter of the 2rd uplink burst in the selected band to 14.

CALL:(PDTCH|PDTChannel):MS:OPSMode

Function

GSM TA

 This command is not applicable to the GSM Test Application.

GPRS TA

 This command is not applicable to the GPRS Test Application.
EGPRS TA This command is not applicable to the EGPRS Test Application.

GSM/GPRS LA

This command sets/queries the mode by which the MS output power is determined for a PS connection. The mode used is either the original based around MS TX level or the more complete solution relation to power control parameters alpha and gamma. See MS Output Power for more information.

EGPRS LA

Setting

Range: TXLev | AGAMma

Query

 Range: TXL | AGAM

*RST Setting

 TXL
Requirements

GSM/GPRS/
EGPRS LA

 Revision: F.00.37 and above

Programming Example

OUTPUT 714;"CALL:PDTCH:MS:OPSMode TXLev"
! Sets the output power selection mode to TXLev.

CALL:(PDTCH|PDTChannel):MS:TADVance[:SELected]

CALL:(PDTCH|PDTChannel):MS:TADVance:(DCS|EGSM|GSM450|GSM480|GSM750|GSM850|PCS|PGSM|RGSM|TGSM810)

Function

GSM TA

 This command is not applicable to the GSM Test Application.

GPRS TA

 This command is not applicable to the GPRS Test Application.
EGPRS TA This command is not applicable to the EGPRS Test Application.

GSM/GPRS LA

This command sets/queries the timing advance that is sent to the device under test. This value tells the device how much to offset its transmission to simulate the effects of propagation delays.

The optional [SELected] keyword in this command specifies that the channel being set/queried applies to the current cell band.

If this command is attempted while there is an active DTM connection or while the test set is in a DTM test operating mode, it is stored and applied when the test set is no longer in Dual Transfer Mode.

Note, if the multislot configuration is D1U6, D2U5, D3U4, D4U3, D5U2 or D6U1 , the timing advance setting must be larger than 31, otherwise the mobile station may not work.

EGPRS LA

Setting

Range (all bands): 0 to 63

Resolution (all bands): 1

Query

Range (all bands): 0 to 63

Resolution (all bands): 1

*RST Setting

 0
Requirements

GSM/GPRS/
EGPRS LA

 Revision C.01 and above
D.03 adds the TGSM810 band.

Programming Example

OUTPUT 714;"CALL:PDTCH:MS:TADVance:PCS 10"
! Sets timing advance to 10 for the PCS band.

CALL:(PDTCH|PDTChannel):MS:TADVance:CONTinuous

Function

GSM TA

 This command is not applicable to the GSM Test Application.

GPRS TA

 This command is not applicable to the GPRS test application.
EGPRS TA This command is not applicable to the EGPRS Test Application.

GSM/GPRS LA

This command sets/queries the timing advance mode. If this is set to ON, a continuous timing advance procedure is used. If this is set to OFF, messages are used to assign timing advance values to the MS. See Timing Advance for more information.

If this command is attempted while there is an active DTM connection or while the test set is in a DTM test operating mode, it is stored and applied when the test set is no longer in Dual Transfer Mode.
EGPRS LA

Setting

Range: 0 | OFF | 1 | ON

Query

Range: 0 | 1

*RST Setting

 0|0FF
Requirements

GSM/GPRS/
EGPRS LA

 Revision C.01 and above

Programming Example

OUTPUT 714;"CALL:PDTCH:MS:TADVance:CONT 1"
! Sets continuous timing advance to ON.

CALL:(PDTCH|PDTChannel):MS:TXLevel[:SELected]:BURSt<[1]|2|3|4|5>

CALL:(PDTCH|PDTChannel):MS:TXLevel:(DCS|EGSM|GSM450|GSM480|GSM750|GSM850|PCS|PGSM|RGSM|TGSM810):BURSt<[1]|2|3|4|5>

Function

GSM TA

 This command is not applicable to the GSM Test Application.

GPRS TA

This command selects the mobile station's uplink power control level for any burst that is transmitted on the uplink in a multislot configuration in the selected band. See GPRS and EGPRS Frequency Banded Parameters .

Burst one is assumed if no burst is specified.

The optional [SELected] keyword in this command specifies that the channel being set/queried applies to the current cell band.

If this command is attempted while there is an active DTM connection or while the test set is in a DTM test operating mode, it is stored and applied when the test set is no longer in Dual Transfer Mode.

EGPRS TA

GSM/GPRS LA

EGPRS LA

Setting

Range (all bands): 0 to 31

Resolution (all bands): 1

Query

Range (all bands): 0 to 31

Resolution (all bands): 1

*RST Setting

PGSM, EGSM, RGSM, GSM450, GSM480, GSM750, GSM850, and TGSM810 bands: 15,
DCS and PCS bands: 10
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above.

Revision A.04 adds Burst 3 and Burst 4.

Revision A.06 adds the TGSM810 band.

Revision A.09 adds Burst 5.
GSM/GPRS/ EGPRS LA

Revision: C.01 and above.

Revision D.01 adds Burst 3 and Burst 4.

Revision D.03 adds the TGSM810 band.

Revision F.00.27 adds Burst 5.

Programming Example

OUTPUT 714;"CALL:PDTCH:MS:TXLevel:BURSt 10"
! Sets the uplink power level of burst one in the selected band to 10.

CALL:(PDTCH|PDTChannel):MSLot:CONFig

Function

GSM TA

 This command is not applicable to the GSM Test Application.

GPRS TA

This command sets/queries the multislot configuration. The deferred version of this command is CALL:SETup:(PDTCH|PDTChannel):MSLot:CONFig .

If this command is attempted while there is an active DTM connection or while the test set is in a DTM test operating mode, it is stored and applied when the test set is no longer in Dual Transfer Mode.

The effect this command has on the number of uplink and downlink timeslots depends on the Connection Type (see CALL:FUNCtion:CONNection:TYPE ):

  • Type A - The multislot configuration command only affects the number of uplink timeslots.
  • BLER - The multislot configuration command only affects the number of downlink timeslots.

The actual timeslots used in each configuration are fixed as in the list below.

Multislot Configuration Downlink Timeslots Used Uplink Timeslots Used

D1U1 3 3
D1U2 3 3,4
D1U3 3 3,4,5
D1U4 3 3,4,5,6
D1U5 3 2,3,4,5,6
D1U6 2 1,2,3,4,5,6
D2U1 3,4 4
D2U2 3,4 3,4
D2U3 3,4 3,4,5
D2U4 3,4 3,4,5,6
D2U5 2,3 2,3,4,5,6
D3U1 3,4,5 4
D3U2 3,4,5 4,5
D3U3 3,4,5 4,5,6
D3U4 2,3,4 3,4,5,6
D4U1 3,4,5,6 5
D4U2 3,4,5,6 5,6
D4U3 2,3,4,5 4,5,6
D5U1 2,3,4,5,6 5
D5U2 2,3,4,5,6 5,6
D6U1 1,2,3,4,5,6 5
CUSTom You can position the timeslots flexibly. See Flexible Timeslot

When a multislot configuration change is executed, all measurements will be stopped before the change is made, and re-started after the change has taken effect.

For more information see Supported Multislot Classes .

EGPRS TA

GSM/GPRS LA

EGPRS LA

Setting

 Range: D1U1 | D1U2 |D1U3 |D1U4 |D1U5 |D1U6|D2U1 | D2U2 |D2U3 | D2U4 |D2U5|D3U1 | D3U2 | D3U3 |D3U4| D4U1 | D4U2 |D4U3| D5U1|D5U2|D6U1

Query

 Range: D1U1 | D1U2 |D1U3 |D1U4 |D1U5 |D1U6|D2U1 | D2U2 |D2U3 | D2U4 |D2U5|D3U1 | D3U2 | D3U3 |D3U4| D4U1 | D4U2 |D4U3| D5U1|D5U2|D6U1

*RST Setting

 D2U1
Requirements GPRS/EGPRS TA

Revision: A.01 and above

Revision A.04 adds D1U2, D1U3, D1U4, and D2U3

Revision A.09 adds D1U5, D2U4, D3U3 D4U2, D5U1,

GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Revision D.01 adds D1U2, D1U3, D1U4, and D2U3

Revision E.00.08 adds D2U4, D3U3, D4U2, and D5U1

Revision F.00.27 adds D1U5

Revision G.00.00 adds D1U6, D2U5, D3U4, D4U3, D5U2, D6U1

Programming Example

OUTPUT 714;"CALL:PDTCH:MSLot:CONFig D2U1"
! Sets the multislot configuration to be 2 downlink PDTCHs and 1 uplink PDTCH.

CALL:(PDTCH|PDTChannel):MSLot:CONFig:CUSTom:TSLots

Function

GSM TA

 This command is not applicable to the GSM Test Application.

GPRS TA

 This command is not applicable to the GPRS Test Application.

EGPRS TA

 This command is not applicable to the EGPRS Test Application.

GSM/GPRS LA

This command sets/queries the customized multislot configuration. See Flexible Timeslot for more information.

The command form accepts two string parameters with each contains a maximum of 8 characters. The first string represents the timeslot usage of TS0 to TS7 of the downlink timeslots and the second string represents the timeslot usage of TS0 to TS7 of the uplink timslots. Each timeslot of the uplink and downlink can be configured to one of the three values:

  • OFF: represented by `-'. ` `, `x', `X', or `0', `-' returned by query.
  • PDCH: represented by `p', `P', or `1', `P' returned by query.
  • TCH: represented by `t' or `T', `T' returned by query

If less than 8 characters in each string are specified in a parameter, the remaining higher numbered timeslots are assumed to be OFF.

EGPRS LA

Setting

 Range: -, ,x,X,0 |p,P,1

Query

 Range: - |P

*RST Setting

 --PP----,--P-----
Requirements GSM/GPRS/ EGPRS LA

Revision: G.00.00 and above

Programming Example

OUTPUT 714;"CALL:PDTCH:MSLot:CONFig:CUSTom:TSLots --PP----,--P-----"
! Sets the custom multislot configuration to be 2 downlink PDTCHs and 1 uplink PDTCH. Timeslot 2 and 3
! are configured to PDCH in the downlink and Timeslot 2 is configured to PDCH in the uplink.

CALL:(PDTCH|PDTChannel):MSLot[:FIRSt]:DOWNlink:LOOPback[:BURSt]

Function

GSM TA

 This command is not applicable to the GSM Test Application.

GPRS TA

This command sets/queries the first downlink burst to be looped back in the first uplink burst. Subsequent downlink bursts are looped back in subsequent uplink bursts.

When the operating mode is set to Active Cell, any attempt to change this setting while the data connection state is Transferring and the data connection type is ETSI Type B or SRB Loopback will be rejected.

If the multislot configuration is set to a value that has a number of downlink bursts less than the current setting of this parameter, the downlink burst looped back will be determined by the calculation:

1 + ((First Downlink Burst to Loop -1) modulo (current number of downlink bursts) )

For example, if the setting of First Downlink Burst to Loop is 4, and the multislot configuration is set to D3U2, then the first downlink burst looped on the uplink will be 1.

(1+ ((4 - 1) modulo 3)) = 1

EGPRS TA

GSM/GPRS LA

EGPRS LA

Setting

 Range: 1 to 6

Query

 Range: 1 to 6

*RST Setting

 1
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Revision E.00.08 extends the range to accept 5.

Revision F.09 extends the range to accept 6

Programming Example

OUTPUT 714;"CALL:PDTCH:MSLot:DOWNlink:LOOPback 2"
! Sets downlink burst 2 as the first downlink burst to be looped back.

CALL:(PDTCH|PDTChannel):MSLot:MEASurement:BURSt

Function

GSM TA

 This command is not applicable to the GSM Test Application.

GPRS TA

This command sets/queries which uplink burst will be measured for single slot measurements on dual uplink PDTCHs when the receiver measurement burst control is AUTO.

This setting has no effect on GSM calls; the measurement burst will always be 1.

If this command is attempted while there is an active DTM connection or while the test set is in a DTM test operating mode, it is stored and applied when the test set is no longer in Dual Transfer Mode.

The maximum value this parameter allows depends on the Uplink Test Sequence Burst Count setting (when the operating mode is set to FastTune) and the Multislot Configuration setting (when the operating mode is not set to FastTune).

EGPRS TA

GSM/GPRS LA

EGPRS LA

Setting

Range: 1 to 7

Resolution: 1

Query

 Same as setting.

*RST Setting

 1
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above

Revision A.04 adds bursts 3 through 7.
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Revision E.00.12 adds bursts 3 through 7.

Programming Example

OUTPUT 714;"CALL:PDTCH:MSLot:MEASurement:BURSt 2"
! Sets uplink burst 2 will be measured for single slot measurements.

CALL:(PDTCH|PDTChannel):PMESsage:NACChange:COMPletion

Function

GSM TA

 This command is not applicable to the GSM Test Application.

GPRS TA

 This command is not applicable to the GPRS Test Application.

EGPRS TA

 This command is not applicable to the EGPRS Test Application.

GSM/GPRS LA

This parameter specifies the over-the-air (OTA) message to be sent to the DUT as part of the network-side completion of the NACC procedures. The possible values are outlined as follows:

  • OFF - no message is sent to complete the NACC procedure
  • PCCO - a packet Cell Change Order (PCCO) message is sent
  • PCCC - a Packet Cell Change Continue (PCCC) message is sent, which is used to signify the DUT to exit the Cell Change Notification (CCN) mode and to continue the reselection procedure.

See Network Assisted Cell Change (NACC) Handover Procedure for more information.

EGPRS LA

Setting

Range: OFF|PCCContinue|PCCOrder

Query

Range: OFF|PCCContinue|PCCOrder

*RST Setting

OFF
Requirements GSM/GPRS/ EGPRS LA

Revision: F.00.37 and above

Programming Example

OUTPUT 714;"CALL:PDTCH:PMESsage:NACChange:COMPletion OFF"
! Sets the NACC Completion Message to OFF.

CALL:(PDTCH|PDTChannel):PMESsage:(PMORder|PMO):NC2[:STATe]

Function

GSM TA

 This command is not applicable to the GSM Test Application.

GPRS TA

 This command is not applicable to the GPRS Test Application.

EGPRS TA

 This command is not applicable to the EGPRS Test Application.

GSM/GPRS LA

 This command enables/disables the transmission of a Packet Measurement Order message to the DUT during either the NACC or PS Handover procedures causing the DUT to be forced into Network Control mode 2.

See Handover Control for more information.

EGPRS LA

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0|OFF
Requirements GSM/GPRS/ EGPRS LA

Revision: F.00.37 and above

Programming Example

OUTPUT 714;"CALL:PDTCH:PMESsage:PMO:NC2:STATe OFF"
! Sets the PMO Forces NC2 State to OFF.

CALL:(PDTCH|PDTChannel):PMESsage:PNCData[:STATe]

Function

GSM TA

 This command is not applicable to the GSM Test Application.

GPRS TA

 This command is not applicable to the GPRS Test Application.

EGPRS TA

 This command is not applicable to the EGPRS Test Application.

GSM/GPRS LA

 This command enables/disables the transmission of the Packet Neighbor Cell Data message used for neighbor cell SI message exchange during both the NACC and PS Handover procedures.

See Handover Control for more information.

EGPRS LA

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

1|ON
Requirements GSM/GPRS/ EGPRS LA

Revision: F.00.37 and above

Programming Example

OUTPUT 714;"CALL:PDTCH:PMESsage:PNCData:STATe ON"
! Sets the Packet Neighbour Cell Data to ON.

CALL:(PDTCH|PDTChannel):PMESsage:PPTadvance

Function

GSM TA

 This command is not applicable to the GSM Test Application.

GPRS TA

This command sets/queries whether or not to send a Packet Power Timing Advance (PPTA) message to the mobile when applying deferred or immediate PDTCH parameters to an active data connection (that is, data connection status is Transferring).

Setting this command to On ensures that a PPTA message is sent.

If you set this command while the data connection status is Transferring, any changes you make will take effect immediately during the current data connection.

This command along with CALL:(PDTCH|PDTChannel):PMESsage:PTReconfig provides you with power control settings for mobiles that do not fully support the Packet Timeslot Reconfigure (PTR) message.

EGPRS TA

GSM/GPRS LA

EGPRS LA

Setting

Range: 0 | OFF | 1 | ON

Query

Range: 0 | 1

*RST Setting

1|ON
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:PDTCH:PMESsage:PPTadvance OFF"
! Sets the PPTA message state to ON.

CALL:(PDTCH|PDTChannel):PMESsage:PTReconfig

Function

GSM TA

 This command is not applicable to the GSM Test Application.

GPRS TA

This command sets/queries whether or not to send a Packet Timeslot Reconfigure (PTR) message to the mobile. Setting this command to:

  • On, sends a PTR message to the mobile when applying deferred or immediate PDTCH parameters to an active data connection (that is, data connection status is Transferring).
  • Off, sends an alternative message to the mobile instead of a PTR message. The alternative message that is sent to the mobile depends on the type of data connection (set using CALL:FUNCtion:CONNection:TYPE ):
    • If the data connection type is BLER, a Packet Downlink Assignment (PDA) message is sent.
    • If the data connection type is ETSI Type A, a Packet Uplink Assignment (PUA) message is sent.
    • If the data connection type is ETSI Type B, both PDA and PUA messages are sent.
    • If the data connection type is SRB Loopback, both PDA and PUA messages are sent.

If you set this command while the data connection status is Transferring, any changes you make will take effect immediately during the current data connection.

This command along with CALL:(PDTCH|PDTChannel):PMESsage:PPTadvance provides you with power control settings for mobiles that do not fully support the Packet Timeslot Reconfigure (PTR) message.

EGPRS TA

GSM/GPRS LA

EGPRS LA

Setting

Range: 0 | OFF | 1 | ON

Query

Range: 0 | 1

*RST Setting

 ON- Connection Types ETSI B and ETSI B ACK (See CALL:FUNCtion:CONNection:TYPE )
OFF - All other Connection Types
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:PDTCH:PMESsage:PTReconfig ON"
! Sets the PTR message state to ON.

CALL:(PDTCH|PDTChannel):POWer[:AMPLitude]:BURSt<[1]|2|3|4|5>?

Function

GSM TA

 This command is not applicable to the GSM Test Application.

GPRS TA

This query returns the current absolute power level of the downlink PDTCH burst. The level is calculated from the current BCH Level, current power reduction reference level P0 and the current power reduction level. For more detail on these power levels, refer to Testing a GPRS Mobile Station .

If you do not specify a burst then burst one is assumed.

EGPRS TA

GSM/GPRS LA
EGPRS LA
Query

Range: -182.0 to -10.0 dBm and 9.91 E+37 (NAN)

Resolution: 0.1 dBm
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
Revision: A.04 adds Burst 3 and Burst 4
Revision: A.09 adds Burst 5
GSM/GPRS/ EGPRS LA

Revision: C.01 and above
Revision E.00.08 adds Burst 5

Programming Example

OUTPUT 714;"CALL:PDTCH:POWer:BURSt?"
! Returns current power level of downlink PDTCH burst 1.

CALL:(PDTCH|PDTChannel):POWer[:AMPLitude]:UBURst?

Function

GSM TA

 This command is not applicable to the GSM Test Application.

GPRS TA

 THIS COMMAND IS OBSOLETE. Use CALL:(PDTCH|PDTChannel):POWer[:AMPLitude]:UNUSed? instead.

This query returns the current absolute power level of the unused bursts on the downlink PDTCH ARFCN. The level is calculated from the current BCH Level, current power reduction reference level P0 and the current power reduction level specified for unused bursts. NAN is returned if no power is present on the unused downlink PDTCH ARFCN. For more detail on these power levels, refer to Testing a GPRS Mobile Station .

EGPRS TA

GSM/GPRS LA
EGPRS LA
Query

Range: -182.0 to -10.0 dBm and 9.91 E+37 (NAN)

Resolution: 0.1 dBm
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:PDTCH:POWer:UBURst?"
! Queries the absolute power level of the unused bursts.

CALL:(PDTCH|PDTChannel):POWer[:AMPLitude]:UNUSed?

Function

GSM TA

 This command is not applicable to the GSM Test Application.

GPRS TA

 This command is not applicable to the GPRS Test Application.

EGPRS TA

 This command is not applicable to the EGPRS Test Application.

GSM/GPRS LA

This query returns the current absolute power level of the unused bursts on the downlink PDTCH ARFCN. The level is calculated from the current BCH Level, current power reduction reference level P0 and the current power reduction level specified for unused bursts. NAN is returned if no power is present on the unused downlink PDTCH ARFCN. For more detail on these power levels, refer to Testing a GPRS Mobile Station .
EGPRS LA
Query

Range: -182.0 to -10.0 dBm and 9.91 E+37 (NAN)

Resolution: 0.1 dBm
Requirements GSM/GPRS/ EGPRS LA

Revision: F.00.27 and above

Programming Example

OUTPUT 714;"CALL:PDTCH:POWer:UNUSed?"
! Queries the absolute power level of the unused bursts.

CALL:(PDTCH|PDTChannel):PREDuction:ADJacent

Function

GSM TA

 This command is not applicable to the GSM Test Application.

GPRS TA

This command sets/queries the power reduction level for the unused bursts on the downlink PDTCH ARFCN. In addition, it can also be used to turn power reduction off (no power transmitted) for the unused bursts.

When this command is set to PRL1 or PRL2, the power reduction level for unused bursts is the value specified using CALL:(PDTCH|PDTChannel):PREDuction:LEVel<1|2> .

Note: In order to make use of power reduction levels, you must set the downlink PDTCHs to be on a different ARFCN from the broadcast channel (BCH). This is because the power level across all timeslots on the BCH must remain constant. Therefore, power reduction levels are ignored if the BCH and PDTCH are on the same ARFCN.
EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting | Range: PRL1 | PRL2 | OFF
Query | Range: PRL1 | PRL2 | OFF
*RST setting | OFF
Requirements GSM/GPRS/
EGPRS TA

Revision: A.04 and above
GSM/GPRS/ EGPRS LA

Revision: D.01 and above

Programming Example

OUTPUT 714;"CALL:PDTCH:PRED:ADJ PRL2"
! Sets the power reduction level of the unused bursts to PRL2.

CALL:(PDTCH|PDTChannel):PREDuction:BURSt<[1]|2|3|4|5>

Function

GSM TA

 This command is not applicable to the GSM Test Application.

GPRS TA

This command sets/queries the power reduction level for any of the downlink bursts. You can define the levels of PRL1 and PRL2 using CALL:(PDTCH|PDTChannel):PREDuction:LEVel<1|2> .

For further information see Downlink PDTCH Power Control .

If you do not specify a burst then burst one is assumed.
EGPRS TA

GSM/GPRS LA
EGPRS LA
Setting | Range: PRL1 | PRL2
Query | Range: PRL1 | PRL2
*RST setting | PRL1
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
Revision A.04 adds Burst 3 and Burst 4
Revision A.09 adds Burst 5
GSM/GPRS/ EGPRS LA

Revision: C.01 and above
Revision E.00.08 adds Burst 5

Programming Example

OUTPUT 714;"CALL:PDTCH:PREDuction:BURSt3 PRL1"
! Sets the power reduction level of the first burst to PRL1.

CALL:(PDTCH|PDTChannel):PREDuction:LEVel<1|2>

Function

GSM TA

 This command is not applicable to the GSM Test Application.

GPRS TA

In GPRS, power levels are referred to as power reduction levels relative to the BCCH. This command sets/queries two power reduction levels. These levels can then be applied to up to four downlink PDTCH bursts using CALL:(PDTCH|PDTChannel):PREDuction:BURSt<[1]|2|3|4|5> . In addition, they can be applied to the unused downlink bursts using CALL:(PDTCH|PDTChannel):PREDuction:UBURst .

For further information see Downlink PDTCH Power Control .

If you do not specify a burst then burst one is assumed.

If the actual measured difference between two power reduction levels exceeds 20 dB, the test set's source specifications may no longer be valid.

When the Test Set's operating mode is set to GPRS BCH+PDTCH or EGPRS BCH+PDTCH and the RLC/MAC Header is turned ON, information is included in the PR field of the RLC/MAC Header to indicate a power reduction level to the mobile. When the Test Set's operating mode is set to GPRS BCH+PDTCH or EGPRS BCH+PDTCH and the RLC/MAC Header is turned Off, no information relating to power control is sent to the mobile. (When the operating mode is set to Active Cell the RLC/MAC header containing the PR field is always sent to the mobile.)

3GPP TS 04.60 section 10 Release 1999 defines that a maximum power reduction level of 10 dB can be indicated to the mobile in the PR field of the RLC/MAC header. If your mobile adheres strictly to the standards, and you set this command to a value greater than 10 dB, it is possible your mobile may not respond correctly to the power reduction level you set.

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting Range: 0 to 25 dB
Resolution: 0.1 dB
Query Range: 0 to 25 dB
Resolution: 0.1 dB
*RST setting 0 dB
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:PDTCH:PRED:LEV2 3"
! Sets the second power reduction level (PRL2) to 3 dB.

CALL:(PDTCH|PDTChannel):PREDuction:MODE

Function

GSM TA

 This command is not applicable to the GSM Test Application.

GPRS TA

 This command is not applicable to the GPRS Test Application.
EGPRS TA | This command is not applicable to the EGPRS Test Application.

GSM/GPRS LA

This command sets/queries the power reduction mode on the downlink PDTCH ARFCN.

The two values that the PR Mode can be set to is A or B.

  • When this parameter is set to A, the Power Reduction (PR) field in the Packet Downlink Assignment and Packet Uplink Assignment is intended only for the assigned mobile.
  • When this parameter is set to B, the test set assigns the same value of power reference level (P0) to every mobile in the cell.

EGPRS LA
Setting | Range: A | B
Query | Range: A | B
*RST setting | A
Requirements GSM/GPRS/ EGPRS LA

Revision: F.00.27 and above

Programming Example

OUTPUT 714;"CALL:PDTCH:PRED:MODE B"
! Sets the power reduction mode to B.

CALL:(PDTCH|PDTChannel):PREDuction:UBURst

Function

GSM TA

 This command is not applicable to the GSM Test Application.

GPRS TA

THIS COMMAND IS OBSOLETE. Use CALL:(PDTCH|PDTChannel):PREDuction:UNUSed instead.

This command sets/queries the power reduction level for the unused bursts on the downlink PDTCH ARFCN. In addition, it can also be used to turn power reduction off (no power transmitted) for the unused bursts.

When this command is set to PRL1 or PRL2, the power reduction level for unused bursts is the value specified using CALL:(PDTCH|PDTChannel):PREDuction:LEVel<1|2> .

Note: In order to make use of power reduction levels, you must set the downlink PDTCHs to be on a different ARFCN from the broadcast channel (BCH). This is because the power level across all timeslots on the BCH must remain constant. Therefore, power reduction levels are ignored if the BCH and PDTCH are on the same ARFCN.
EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting | Range: PRL1 | PRL2 | OFF
Query | Range: PRL1 | PRL2 | OFF
*RST setting | OFF
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:PDTCH:PRED:UBUR PRL2"
! Sets the power reduction level of the unused bursts to PRL2.

CALL:(PDTCH|PDTChannel):PREDuction:UNUSed

Function

GSM TA

 This command is not applicable to the GSM Test Application.

GPRS TA

 This command is not applicable to the GPRS Test Application.
EGPRS TA | This command is not applicable to the EGPRS Test Application.

GSM/GPRS LA

This command sets/queries the power reduction level for the unused bursts on the downlink PDTCH ARFCN. In addition, it can also be used to turn power reduction off (no power transmitted) for the unused bursts.

When this command is set to PRL1 or PRL2, the power reduction level for unused bursts is the value specified using CALL:(PDTCH|PDTChannel):PREDuction:LEVel<1|2> .

When Frequency Hopping is turned on, The timeslots needed for transient settling are the three consecutive ones preceding the active timeslot. Therefore, when frequency hopping is on and the power reduction level of the unused bursts are not set to OFF, all unused timeslots, excluding two timeslots which are reserved for transients settling, will be filled with dummy bursts. Note, although the adjacent timeslot to the left of the active timeslot is considered part of the timeslots needed for transient settling, however, it will be filled with dummy burst.

The power reduction level for the unused bursts are always set to OFF when performing simultaneous CS and PS transfer (DTM).

Note: In order to make use of power reduction levels, you must set the downlink PDTCHs to be on a different ARFCN from the broadcast channel (BCH). This is because the power level across all timeslots on the BCH must remain constant. Therefore, power reduction levels are ignored if the BCH and PDTCH are on the same ARFCN.

EGPRS LA
Setting | Range: PRL1 | PRL2 | OFF
Query | Range: PRL1 | PRL2 | OFF
*RST setting | OFF
Requirements GSM/GPRS/ EGPRS LA

Revision: F.00.27 and above

Programming Example

OUTPUT 714;"CALL:PDTCH:PRED:UNUS PRL2"
! Sets the power reduction level of the unused bursts to PRL2.

CALL:(PDTCH|PDTChannel):PZERo:LEVel

Function

GSM TA

 This command is not applicable to the GSM Test Application.

GPRS TA

This command sets/queries the power reduction reference level (ETSI refers to this as P0) for downlink PDTCH power control.

If this command is attempted while there is an active DTM connection or while the test set is in a DTM test operating mode, it is stored and applied when the test set is no longer in Dual Transfer Mode

For further information see Downlink PDTCH Power Control .

EGPRS TA

GSM/GPRS LA
EGPRS LA
Setting Range: 0 to 30 dB
Resolution: 2 dB
Query Range: 0 to 30 dB
Resolution: 2 dB
*RST setting 0 dB
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:PDTCH:PZERo:LEVel 30"
! Sets the power reduction reference level (P0) to 30 dB.

CALL:(PDTCH|PDTChannel):RRBPeriod

Function | GSM TA | This command is not applicable to the GSM Test Application.
 | GPRS TA | This command is not applicable to the GPRS Test Application.
 | EGPRS TA | This command is not applicable to the EGPRS Test Application.
 | GSM/GPRS LA | This command sets/queries the value of the Relative Reserved Block Period (RRBP) field of the Medium Access Control (MAC) header. N in the formulas below is the frame number of the block received by the mobile station with a valid S/P bit and the corresponding RRBP. See Relative Reserved Block Period (RRBP) for more information.
 | EGPRS LA
Setting |  | Range: 0 to 3, where: 0: (N+13) mod 2715648 1: (N+17 or N+18) mod 2715648 2: (N+21 or N+22) mod 2715648 3: (N+20) mod 2715648 Resolution: 1
Query |  | Range: 0 to 3 Resolution: 1
*RST setting |  | 0
Requirements | GSM/GPRS/ EGPRS LA | Revision: D.01 and above

CALL:(PDTCH|PDTChannel):TBFLow:DOWNlink:DELayed[:SDURation]

Function

GSM TA

 This command is not applicable to the GSM Test Application.

GPRS TA

 This command is not applicable to the GPRS Test Application.

EGPRS TA

 This command is not applicable to the EGPRS Test Application.

GSM/GPRS LA

This is a complex command. When the duration of the delayed downlink TBF is set, it automatically sets the state of the delayed downlink TBF to On.

The individual commands to set the delayed downlink TBF state and duration are: CALL:(PDTCH|PDTChannel):TBFLow:DOWNlink:DELayed:STATe and CALL:(PDTCH|PDTChannel):TBFLow:DOWNlink:DELayed:DURation , respectively.

EGPRS LA
Setting

Range: 0.1 to 30 seconds

Resolution: 0.1 seconds
Query

Range: 0.1 to 30 seconds

Resolution: 0.1 seconds
*RST setting 2.5 seconds
Requirements GSM/GPRS/ EGPRS LA

Revision: E.00.05 and above

Programming Example

OUTPUT 714;"CALL:PDTCH:TBFLow:DOWNlink:DELayed 5"
! Sets the duration of the delayed downlink TBF duration to 5 seconds.

CALL:(PDTCH|PDTChannel):TBFLow:DOWNlink:DELayed:DURation

Function

GSM TA

 This command is not applicable to the GSM Test Application.

GPRS TA

 This command is not applicable to the GPRS Test Application.

EGPRS TA

 This command is not applicable to the EGPRS Test Application.

GSM/GPRS LA

Sets/Queries the duration of the delayed downlink TBF. You must first enable the downlink delayed state for this command to apply. The command to set the downlink delayed state is CALL:(PDTCH|PDTChannel):TBFLow:DOWNlink:DELayed:STATe .

Alternatively, you can set the state and the duration of the delayed downlink using the complex command CALL:(PDTCH|PDTChannel):TBFLow:DOWNlink:DELayed[:SDURation] .

EGPRS LA
Setting

Range: 0.1 to 30 seconds

Resolution: 0.1 seconds
Query

Range: 0.1 to 30 seconds

Resolution: 0.1 seconds
*RST setting 2.5 seconds
Requirements GSM/GPRS/ EGPRS LA

Revision: E.00.05 and above

Programming Example

OUTPUT 714;"CALL:PDTCH:TBFLow:DOWNlink:DELayed:DURation 5"
! Sets the duration of the delayed downlink TBF duration to 5 seconds.

CALL:(PDTCH|PDTChannel):TBFLow:DOWNlink:DELayed:STATe

Function

GSM TA

 This command is not applicable to the GSM Test Application.

GPRS TA

 This command is not applicable to the GPRS Test Application.
EGPRS TA | This command is not applicable to the EGPRS Test Application.

GSM/GPRS LA

 Sets/Queries the state of the downlink delayed TBF. You can set the duration of the downlink delayed TBF using the command CALL:(PDTCH|PDTChannel):TBFLow:DOWNlink:DELayed:DURation .

EGPRS LA
Setting | Range: 0 | OFF | 1 | ON
Query | Range: 0 | 1
*RST setting | 0
Requirements GSM/GPRS/ EGPRS LA

Revision: E.00.05 and above

Programming Example

OUTPUT 714;"CALL:PDTCH:TBFLow:DOWNlink:DELayed:STATe ON"
! Sets the Downlink Delay state to ON.

CALL:(PDTCH|PDTChannel):TBFLow:DOWNlink:FBIndicator:POLLing

Function

GSM TA

 This command is not applicable to the GSM Test Application.

GPRS TA

 This command is not applicable to the GPRS Test Application.
EGPRS TA | This command is not applicable to the EGPRS Test Application.

GSM/GPRS LA

 Sets/Queries the Final Block polling method. See Final Block Polling for more information.

EGPRS LA
Setting | Range: NORMal | REDuced
Query | Range: NORMal
*RST setting | NORMal
Requirements GSM/GPRS/ EGPRS LA

Revision: F.00.27 and above

Programming Example

OUTPUT 714;"CALL:PDTCH:TBFLow:DOWNlink:FBIndicator:POLLing REDuced"
! Sets the Final Block Polling method to Reduced.

CALL:(PDTCH|PDTChannel):TBFLow:DOWNlink:RETRansmit[:STATe]

Function

GSM TA

 This command is not applicable to the GSM Test Application.

GPRS TA

 This command is not applicable to the GPRS Test Application.
EGPRS TA | This command is not applicable to the EGPRS Test Application.

GSM/GPRS LA

 Sets/Queries the Early Re-transmissions state. See Early Re-Transmissions for more information.

EGPRS LA
Setting | Range: 1|ON | 0|OFF
Query | Range: 1 | 0
*RST setting | 1
Requirements GSM/GPRS/ EGPRS LA

Revision: F.00.27 and above

Programming Example

OUTPUT 714;"CALL:PDTCH:TBFLow:DOWNlink:RETRansmit ON"
! Sets the Early Re-transmission State to ON.

CALL:(PDTCH|PDTChannel):TBFLow:REEStablish[:STATe]

Function

GSM TA

 This command is not applicable to the GSM Test Application.

GPRS TA

 This command is not applicable to the GPRS Test Application.
EGPRS TA | This command is not applicable to the EGPRS Test Application.

GSM/GPRS LA

 Sets/Queries the state of the TBF Re-establishment parameter.

EGPRS LA
Setting | Range: 0 | OFF | 1 | ON
Query | Range: 0 | 1
*RST setting | 0
Requirements GSM/GPRS/ EGPRS LA

Revision: E.00.08 and above

Programming Example

OUTPUT 714;"CALL:PDTCH:TBFLow:REEStablish ON"
! Sets the TBF Re-establishment state to ON.

CALL:(PDTCH|PDTChannel):TBFLow:UPLink:DLOSt:TIMer[:SDURation]

Function

GSM TA

 This command is not applicable to the GSM Test Application.

GPRS TA

This is a complex command. When the duration of the Uplink Data Timeout timer is set, it automatically sets the state of the Uplink Data Timeout timer to On.

The individual commands to set the delayed downlink TBF state and duration are: CALL:(PDTCH|PDTChannel):TBFLow:UPLink:DLOSt:TIMer:STATe and CALL:(PDTCH|PDTChannel):TBFLow:UPLink:DLOSt:TIMer:DURation , respectively.

See Uplink Data Timeout for more information.

GSM/GPRS LA

EGPRS TA

EGPRS LA
Setting

Range: 1.0 to 999.9 seconds

Resolution: 0.1 seconds
Query

Range: 1.0 to 999.9 seconds

Resolution: 0.1 seconds
*RST setting 2.0 seconds
Requirements GSM/GPRS/ EGPRS TA

Revision: A.08 and above
GSM/GPRS/ EGPRS LA

Revision: E.02 and above

Programming Example

OUTPUT 714;"CALL:PDTCH:TBFLow:UPLink:DLOSt:TIMer 3"
! Sets the duration of the Uplink Data Timeout timer to 3 seconds.

CALL:(PDTCH|PDTChannel):TBFLow:UPLink:DLOSt:TIMer:DURation

Function

GSM TA

 This command is not applicable to the GSM Test Application.

GPRS TA

Sets/Queries the duration of the Uplink Data Timeout timer. You must first enable the Uplink Data Timeout timer state for this command to apply. The command to set the Uplink Data Timeout timer state is CALL:(PDTCH|PDTChannel):TBFLow:UPLink:DLOSt:TIMer:STATe .

Alternatively, you can set the state and the duration of the Uplink Data Timeout timer using the complex command CALL:(PDTCH|PDTChannel):TBFLow:UPLink:DLOSt:TIMer[:SDURation] .

See Uplink Data Timeout for more information.

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

Range: 1.0 to 999.9 seconds

Resolution: 0.1 seconds
Query

Range: 1.0 to 999.9 seconds

Resolution: 0.1 seconds
*RST setting 2.0 seconds
Requirements GSM/GPRS/ EGPRS TA

Revision: A.08 and above
GSM/GPRS/ EGPRS LA

Revision: E.02 and above

Programming Example

OUTPUT 714;"CALL:PDTCH:TBFLow:UPLink:DLOSt:TIMer:DURation 3"
! Sets the duration of the Uplink Data Timeout timer to 3 seconds.

CALL:(PDTCH|PDTChannel):TBFLow:UPLink:DLOSt:TIMer:STATe

Function

GSM TA

 This command is not applicable to the GSM Test Application.

GPRS TA

Sets/Queries the state of the Uplink Data Timeout timer. You can set the duration of the Uplink Data Timeout timer using the command CALL:(PDTCH|PDTChannel):TBFLow:UPLink:DLOSt:TIMer:DURation .

See Uplink Data Timeout for more information.
EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting | Range: 0 | OFF | 1 | ON
Query | Range: 0 | 1
*RST setting | 1
Requirements GSM/GPRS/ EGPRS TA

Revision: A.08 and above
GSM/GPRS/ EGPRS LA

Revision: E.02 and above

Programming Example

OUTPUT 714;"CALL:PDTCH:TBFLow:UPLink:DLOSt:TIMer:STATe 0"
! Disable the Uplink Data Timeout timer.

CALL:(PDTCH|PDTChannel):TBFLow:UPLink:EXTended:DURation

Function

GSM TA

 This command is not applicable to the GSM Test Application.

GPRS TA

 This command is not applicable to the GPRS Test Application.

EGPRS TA

 This command is not applicable to the EGPRS Test Application.

GSM/GPRS LA

 Sets/Queries the duration of the extended uplink TBF. The extended uplink TBF must first be enabled for this setting to apply. See CALL[:CELL]:TBFLow:UPLink:EXTended[:STATe] .

EGPRS LA
Setting

Range: 0 to 30 seconds

Resolution: 0.1 seconds
Query

Range: 0 to 30 seconds

Resolution: 0.1 seconds
*RST setting 2.5 seconds
Requirements GSM/GPRS/ EGPRS LA

Revision: E.00.05 and above

Programming Example

OUTPUT 714;"CALL:PDTCH:TBFLow:UPLink:EXTended:DURation 3"
! Sets the duration of the extended uplink TBF to 3 seconds.

CALL:(PDTCH|PDTChannel):TTI[:MODE]

Function

GSM TA

 This command is not applicable to the GSM Test Application.

GPRS TA

 This command is not applicable to the GPRS Test Application.

EGPRS TA

 This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA | This command is not applicable to the GSM/GPRS Lan Application.

EGPRS LA

 Sets/Queries the TTI mode that the TBFs will be operated. See TTI Mode Configuration
Setting

Range: BTTI | RTTI
Query | BTTI | RTTI
*RST setting | BTTI
Requirements GSM/GPRS/ EGPRS LA

Revision: G.00.00 and above

Programming Example

OUTPUT 714;"CALL:PDTCH:TTI:MODE BTTI"
! Sets the TTI mode to BTTI.

CALL:(PDTCH|PDTChannel):UPLink:RETRansmit:FORCe:PROBability[:STATe]

Function

GSM TA

 This command is not applicable to the GSM Test Application.

GPRS TA

 This command is not applicable to the GPRS Test Application.

GSM/GPRS LA

 This command is not applicable to the GSM/GPRS Lab Application.

EGPRS TA

 This command is not applicable to the EGPRS Test Application.

EGPRS LA

 This command enables/queries the state of forced Not Acknowledging (NACKing) of correctly received uplink blocks for EGPRS. This forces uplink retransmissions.
Setting | Range: 0 | OFF | 1 | ON
Query | Range: 0 | 1
*RST setting | 0 | OFF
Requirements GSM/GPRS/ EGPRS LA

Revision: C.03 and above

Programming Example

OUTPUT 714;"CALL:PDTCH:UPL:RETR:FORC:PROB 1"
! Turns on NACKing of uplink blocks.

CALL:(PDTCH|PDTChannel):UPLink:RETRansmit:FORCe:PROBability:PERCentage

Function

GSM TA

 This command is not applicable to the GSM Test Application.

GPRS TA

 This command is not applicable to the GPRS Test Application.

GSM/GPRS LA

 This command is not applicable to the GSM/GPRS Lab Application.

EGPRS TA

 This command is not applicable to the EGPRS Test Application.

EGPRS LA

 This command enables/queries the percentage of correctly received uplink blocks to be Not Acknowledged (NACKed). This forces uplink retransmissions.
Setting Range: 0.00 to 100.00 percent
Resolution: 0.01 percent
Query Range: 0.00 to 100.00
Resolution: 0.01
*RST setting 1.00
Requirements GSM/GPRS/ EGPRS LA

Revision: C.03 and above

Programming Example

OUTPUT 714;"CALL:PDTCH:UPL:RETR:FORC:PROB:PERC 10.50"
! Sets the value to 10.5 percent.

CALL:(PDTCH|PDTChannel):UPLink:RETRansmit:FORCe:PROBability:SPERcentage

Function

GSM TA

 This command is not applicable to the GSM Test Application.

GPRS TA

 This command is not applicable to the GPRS Test Application.

GSM/GPRS LA

 This command is not applicable to the GSM/GPRS Lab Application.

EGPRS TA

 This command is not applicable to the EGPRS Test Application.

EGPRS LA

 This command enables/queries the percentage of correctly received uplink blocks to be Not Acknowledged (NACKed) and turns the state ON. This forces uplink retransmissions.
This is a complex command combining the forced NACKing of correctly received uplink blocks state and percentage commands. The state is automatically set to ON when this command is used.
Setting Range: 0.00 to 100.00 percent
Resolution: 0.01 percent
Query Range: 0.00 to 100.00
Resolution: 0.01
*RST setting 1.00
Requirements GSM/GPRS/ EGPRS LA

Revision: C.03 and above

Programming Example

OUTPUT 714;"CALL:PDTCH:UPL:RETR:FORC:PROB:SPER 10.50"
! Sets the value to 10.5 percent.

CALL:(PDTCH|PDTChannel):USFlag

Function

GSM TA

This command sets/queries the uplink state flag (USF) for handoffs. The USF allows multiple mobiles to share over-the-ari resources. The USF allows you to verify that your device under test only responds when required.

GPRS TA

GSM/GPRS LA

EGPRS TA

EGPRS LA
Setting

Range: 0 to 7

Resolution: 1
Query

Range: 0 to 7

Resolution: 1
*RST setting 0

Requirements

GSM/GPRS/
EGPRS LA

 Revision F.01 and above

GSM/GPRS/
EGPRS TA

 Revision A.09 and above

Programming Example

OUTPUT 714;"CALL:PDTCH:USFLAG 5"
! Sets the handoff uplink state flag to 5.

CALL:(PDTCH|PDTChannel):USFlag:RTTI[:MODE]

Function

GSM TA

 This command is not applicable to the GSM Test Application.

GPRS TA

 This command is not applicable to the GPRS Test Application.

EGPRS TA

 This command is not applicable to the EGPRS Test Application

GSM/GPRS LA

 This command is not applicable to the GSM/GPRS Lab Application.

EGPRS LA

 This command sets/quires the USF mode to be used for an RTTI configuration. See RTTI USF Mode .
Setting

Range: BTTI | RCS1 | RMCS0
Query | BTTI | RCS1 | RMCS0
*RST setting | BTTI
Requirements GSM/GPRS/ EGPRS LA

Revision: G.00.00 and above

Programming Example

OUTPUT 714;"CALL:PDTCH:USFlag:RTTI:MODE BTTI"
! Sets the RTTI USF mode to BTTI.

CALL:(PDTCH|PDTChannel):WINDow:SIZE[:ALL]

Function

GSM TA

 This command is not applicable to the GSM Test Application.

GPRS TA

 This command is not applicable to the GPRS Test Application.

GSM/GPRS LA

 This command is not applicable to the GSM/GPRS Lab Application.

EGPRS TA

 This command is not applicable to the EGPRS Test Application.

EGPRS LA

This command sets the RLC window size on the downlink for EGPRS for all Data Connection Types. The window size can be set to the maximum allowable value for the number of downlink slots or the minimum window size for all timeslots.

Additional commands have been added to allow you to set the window size for different Data Connection Type settings.
Setting | Range: WMINimum | WMAXimum
Query | Range: WMIN | WMAX
*RST setting | WMAX
Requirements GSM/GPRS/ EGPRS LA

Revision: C.03 and above

Revision E.00.12 adds the optional ALL mnemonic.

Programming Example

OUTPUT 714;"CALL:PDTCH:WIND:SIZE WMAX"
! Sets all RLC window size paramters to maximum.

CALL:(PDTCH|PDTChannel):WINDow:SIZE:AUTO

Function

GSM TA

 This command is not applicable to the GSM Test Application.

GPRS TA

 This command is not applicable to the GPRS Test Application.

GSM/GPRS LA

 This command is not applicable to the GSM/GPRS Lab Application.

EGPRS TA

 This command is not applicable to the EGPRS Test Application.

EGPRS LA

This command sets the RLC window size on the downlink for EGPRS when the Data Connection Type is set to Auto . The window size can be set to the maximum allowable value for the number of downlink slots or the minimum window size for all timeslots.

See Window Size for more information.
Setting | Range: WMINimum | WMAXimum
Query | Range: WMIN | WMAX
*RST setting | WMAX
Requirements GSM/GPRS/ EGPRS LA

Revision: E.00.12 and above

Programming Example

OUTPUT 714;"CALL:PDTCH:WINDow:SIZE:AUTO WMAX"
! Sets RLC window size to the maximum when the Data Connection Type is set to AUTO.

CALL:(PDTCH|PDTChannel):WINDow:SIZE:OTHer

Function

GSM TA

 This command is not applicable to the GSM Test Application.

GPRS TA

 This command is not applicable to the GPRS Test Application.

GSM/GPRS LA

 This command is not applicable to the GSM/GPRS Lab Application.

EGPRS TA

 This command is not applicable to the EGPRS Test Application.

EGPRS LA

This command sets the RLC window size on the downlink for EGPRS when the Data Connection Type is not set to Auto (that is, any "other" Data Connection Type). The window size can be set to the maximum allowable value for the number of downlink slots or the minimum window size for all timeslots.

See Window Size for more information.
Setting | Range: WMINimum | WMAXimum
Query | Range: WMIN | WMAX
*RST setting | WMIN
Requirements GSM/GPRS/ EGPRS LA

Revision: E.00.12 and above

Programming Example

OUTPUT 714;"CALL:PDTCH:WINDow:SIZE:OTHER WMAX"
! Sets RLC window size to maximum when the Data Connection Type is not set to AUTO.

CALL:(PDTCH|PDTChannel):WINDow:SIZE:SELected

Function

GSM TA

 This command is not applicable to the GSM Test Application.

GPRS TA

 This command is not applicable to the GPRS Test Application.

GSM/GPRS LA

 This command is not applicable to the GSM/GPRS Lab Application.

EGPRS TA

 This command is not applicable to the EGPRS Test Application.

EGPRS LA

This command sets the RLC window size on the downlink for EGPRS for the currently active Data Connection Type. The window size can be set to the maximum allowable value for the number of downlink slots or the minimum window size for all timeslots.

See Window Size for more information.
Setting | Range: WMINimum | WMAXimum
Query | Range: WMIN | WMAX
*RST setting | WMAX
Requirements GSM/GPRS/ EGPRS LA

Revision: E.00.12 and above

Programming Example

OUTPUT 714;"CALL:PDTCH:WINDow:SIZE:SELected WMAX"
! Sets RLC window size to maximum for the Data Connection Type that is currently active.


CALL:(PDTC2|PDTCH2|PDTChannel)

CALL:(PDTC2|PDTCH2|PDTChannel)

Last updated: December 3, 2008

GPIB Command Conventions

  • CALL:(PDTC2|PDTCH2|PDTChannel2):ARFCn[:SELected]

  • CALL:(PDTC2|PDTCH2|PDTChannel2):FHOPping[:STATe]
  • CALL:(PDTC2|PDTCH2|PDTChannel2):FHOPping:MAIOffset[:SELected]

  • CALL:(PDTC2|PDTCH2|PDTChannel2):MCSCheme:EBPTest[:BURSt1]
  • CALL:(PDTC2|PDTCH2|PDTChannel2):MCSCheme:EBPTest:BURSt<2|3|4|5>
  • CALL:(PDTC2|PDTCH2|PDTChannel2):MSLot:CONFig
  • CALL:(PDTC2|PDTCH2|PDTChannel2):MSLot:CONFig:CUSTom:TSLots

  • CALL:(PDTC2|PDTCH2|PDTChannel2):PZERo:LEVel
  • CALL:(PDTC2|PDTCH2|PDTChannel2):PREDuction:LEVel
  • CALL:(PDTC2|PDTCH2|PDTChannel2):PREDuction:BURSt<1|2|3|4|5>

CALL:(PDTC2|PDTCH2|PDTChannel2):ARFCn[:SELected]

CALL:(PDTC2|PDTCH2|PDTChannel2):ARFCN:(DCS|EGSM|GSM450|GSM480|GSM750|GSM850|PCS|PGSM|RGSM|TGSM810)

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA This command is not applicable to the GSM/GPRS Lab Application.
EGPRS LA

This command sets/queries the PDTCH carrier 2 for the band selected.

The optional [SELected] keyword in this command specifies that the channel being set/queried applies to the current PDTCH2 band.

See Downlink Dual Carrier for more informations.

Setting

Range:

  • DCS band, channels 512 to 885
  • EGSM band, channels 0 to 124 and 975 to 1023
  • GSM450 band, channels 259 to 293
  • GSM480 band, channels 306 to 340
  • GSM750 band, channels 438 to 511
  • GSM850 band, channels 128 to 251
  • PCS band, channels 512 to 810
  • PGSM band, channels 1 to 124
  • RGSM band, channels 0 to 124 and 955 to 1023
  • TGSM810 band, channels 350 to 425

Resolution: 1

Query

Range:

  • PGSM band, channels 1 to 124
  • EGSM band, channels 0 to 124 and 975 to 1023
  • DCS band, channels 512 to 885
  • PCS band, channels 512 to 810
  • RGSM band, channels 0 to 124 and 955 to 1023
  • GSM450 band, channels 259 to 293
  • GSM480 band, channels 306 to 340
  • GSM850 band, channels 128 to 251
  • GSM750 band, channels 438 to 511
  • TGSM810 band, channels 350 to 425

Resolution: 1

*RST setting

PGSM, EGSM and RGSM bands: 20, DCS and PCS bands: 512, GSM450: 270, GSM480: 310, GSM750: 450, GSM850: 150, TGSM810: 380.
Requirements EGPRS LA

Revision: G.00.00 and above

Programming Example

OUTPUT 714;"CALL:PDTC2:ARFCn 512"
! Sets the PDTCH2 ARFCN of the selected band to 512, if 512 is valid for the selected band.

CALL:(PDTC2|PDTCH2|PDTChannel2):FHOPping[:STATe]

Function

GSM TA

 This command is not applicable to the GSM Test Application.

GPRS TA

 This command is not applicable to the GPRS Test Application.

EGPRS TA

 This command is not applicable to the EGPRS Test Application.

GSM/GPRS LA

 This command is not applicable to the GSM/GPRS Lab Application.

EGPRS LA

This command enables/queries the state of Frequency Hopping for PDTCH2.
Setting | Range: 0 | OFF | 1 | ON
Query | Range: 0 | 1
*RST setting | 0 |OFF
Requirements EGPRS LA

Revision: G.00.00 and above

Programming Example

OUTPUT 714;"CALL:PDTC2:FHOPping ON"
! Enables Frequency Hopping.

CALL:(PDTC2|PDTCH2|PDTChannel2):FHOPping:MAIOffset[:SELected]

CALL:(PDTC2|PDTCH2|PDTChannel2):FHOPping:MAIOffset:(DCS|EGSM|GSM450|GSM480|GSM750|GSM850|PCS|PGSM|RGSM|TGSM810)

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA This command is not applicable to the GSM/GPRS Lab Application.
EGPRS LA

This command sets/queries the Mobile Allocation Index Offset (MAIO), which determines where in the Mobile Allocation (MA) Table the hopping sequence begins. If the MAIO is set to a value greater than the number of entries in a the Mobile Allocation (MA) Table, the MAIO shall be set to zero.The optional [SELected] keyword in this command specifies that the channel being set/queried applies to the current PDTCH2 band

See Downlink Dual Carrier for more informations.

Setting

Range: 0 to 15

Resolution: 1

Query

Range: 0 to 15

Resolution: 1

*RST setting

 0
Requirements EGPRS LA

Revision: G.00.00 and above

Programming Example

OUTPUT 714;"CALL:PDTC2:FHOPping:MAIoffset 8"
! Sets MAIO so it starts in the middle Mobile Allocation (MA) table,
! which contains the available frequencies.

CALL:(PDTC2|PDTCH2|PDTChannel2):MCSCheme:EBPTest[:BURSt1]

Function

GSM TA

 This command is not applicable to the GSM TA.

GPRS TA

 This command is not applicable to the GPRS TA.

GSM/GPRS LA

 This command is not applicable to the GSM/GPRS LA.

EGPRS TA

 This command is not applicable to the EGPRS TA.

EGPRS LA

This command allows you to set/query the modulation coding scheme and downlink puncturing scheme for the first downlink burst of a multislot transmission in EGPRS BCH+PDTCH test mode.

For information on the parameters this command accepts, see Modulation Coding Scheme / Puncturing Scheme Options .

You may set/query the other downlink bursts in the selected multislot configuration using the command: CALL:(PDTC2|PDTCH2|PDTChannel2):MCSCheme:EBPTest:BURSt<2|3|4|5> .

NOTE
MCS7-MCS9 allow two data blocks to be embedded in each radio block. These data blocks can have the same or different puncturing schemes. For example, MCS9P3-2 uses MCS 9, with puncturing scheme 3 on the first data block and puncturing scheme 2 on the second data block.
Setting

Range:

MCS1P1 | MCS1P2 | MCS2P1 | MCS2P2 | MCS3P1 | MCS3P2 | MCS3P3 | MCS4P1 | MCS4P2 | MCS4P3 | MCS5P1 | MCS5P2 | MCS6P1 | MCS6P2 | MCS7P1_1 | MCS7P1_2 | MCS7P1_3 | MCS7P2_1 | MCS7P2_2 | MCS7P2_3 | MCS7P3_1 | MCS7P3_2 | MCS7P3_3 | MCS8P1_1 | MCS8P1_2 | MCS8P1_3 | MCS8P2_1 | MCS8P2_2 | MCS8P2_3 | MCS8P3_1 | MCS8P3_2 | MCS8P3_3 | MCS9P1_1 | MCS9P1_2 | MCS9P1_3 | MCS9P2_1 | MCS9P2_2 | MCS9P2_3 | MCS9P3_1 | MCS9P3_2 | MCS9P3_3 | EPSKCLEAR
Query

Range:

MCS1P1 | MCS1P2 | MCS2P1 | MCS2P2 | MCS3P1 | MCS3P2 | MCS3P3 | MCS4P1 | MCS4P2 | MCS4P3 | MCS5P1 | MCS5P2 | MCS6P1 | MCS6P2 | MCS7P1_1 | MCS7P1_2 | MCS7P1_3 | MCS7P2_1 | MCS7P2_2 | MCS7P2_3 | MCS7P3_1 | MCS7P3_2 | MCS7P3_3 | MCS8P1_1 | MCS8P1_2 | MCS8P1_3 | MCS8P2_1 | MCS8P2_2 | MCS8P2_3 | MCS8P3_1 | MCS8P3_2 | MCS8P3_3 | MCS9P1_1 | MCS9P1_2 | MCS9P1_3 | MCS9P2_1 | MCS9P2_2 | MCS9P2_3 | MCS9P3_1 | MCS9P3_2 | MCS9P3_3 | EPSKCLEAR
*RST setting MCS4P1

Requirements

EGPRS LA

Revision: G.00.00 and above

Programming Example

OUTPUT 714;"CALL:PDTC2:MCSCheme:EBPTest MCS1P2"
! Sets the PDTCH modulation coding scheme for the first downlink burst in the multislot
! configuration to MCS1, puncturing scheme P2 for EGPRS BCH+PDTCH test mode.

CALL:(PDTC2|PDTCH2|PDTChannel2):MCSCheme:EBPTest:BURSt<2|3|4|5>

Function

GSM TA

 This command is not applicable to the GSM TA.

GPRS TA

 This command is not applicable to the GPRS TA.

GSM/GPRS LA

 This command is not applicable to the GSM/GPRS LA.

EGPRS TA

 This command is not applicable to the EGPRS TA.

EGPRS LA

This command allows you to set/query the modulation coding scheme and downlink puncturing scheme for each downlink burst of a multislot transmission in EGPRS BCH+PDTCH test mode. Modulation coding schemes MCS1 through MCS4 use GMSK modulation, while MCS5 to MCS9 use 8PSK modulation.

For information on the parameters this command accepts, see Modulation Coding Scheme / Puncturing Scheme Options .

You may set/query the first downlink burst in the selected multislot configuration using the command: CALL:(PDTC2|PDTCH2|PDTChannel2):MCSCheme:EBPTest[:BURSt1] .

NOTE
MCS7-MCS9 allow two data blocks to be embedded in each radio block. These data blocks can have the same or different puncturing schemes. For example, MCS9P3_2 uses MCS9, with puncturing scheme 3 on the first data block and puncturing scheme 2 on the second data block.
Setting

Range:

MCS1P1 | MCS1P2 | MCS2P1 | MCS2P2 | MCS3P1 | MCS3P2 | MCS3P3 | MCS4P1 | MCS4P2 | MCS4P3 | MCS5P1 | MCS5P2 | MCS6P1 | MCS6P2 | MCS7P1_1 | MCS7P1_2 | MCS7P1_3 | MCS7P2_1 | MCS7P2_2 | MCS7P2_3 | MCS7P3_1 | MCS7P3_2 | MCS7P3_3 | MCS8P1_1 | MCS8P1_2 | MCS8P1_3 | MCS8P2_1 | MCS8P2_2 | MCS8P2_3 | MCS8P3_1 | MCS8P3_2 | MCS8P3_3 | MCS9P1_1 | MCS9P1_2 | MCS9P1_3 | MCS9P2_1 | MCS9P2_2 | MCS9P2_3 | MCS9P3_1 | MCS9P3_2 | MCS9P3_3 | EPSKCLEAR | ASBURST1
Query

Range:

MCS1P1 | MCS1P2 | MCS2P1 | MCS2P2 | MCS3P1 | MCS3P2 | MCS3P3 | MCS4P1 | MCS4P2 | MCS4P3 | MCS5P1 | MCS5P2 | MCS6P1 | MCS6P2 | MCS7P1_1 | MCS7P1_2 | MCS7P1_3 | MCS7P2_1 | MCS7P2_2 | MCS7P2_3 | MCS7P3_1 | MCS7P3_2 | MCS7P3_3 | MCS8P1_1 | MCS8P1_2 | MCS8P1_3 | MCS8P2_1 | MCS8P2_2 | MCS8P2_3 | MCS8P3_1 | MCS8P3_2 | MCS8P3_3 | MCS9P1_1 | MCS9P1_2 | MCS9P1_3 | MCS9P2_1 | MCS9P2_2 | MCS9P2_3 | MCS9P3_1 | MCS9P3_2 | MCS9P3_3 | EPSKCLEAR | ASBURST1
*RST setting

Burst 2: ASBURST1
Burst 3: ASBURST1
Burst 4: ASBURST1
Burst 5: ASBURST1
Burst 6: ASBURST1

Note: MCS4P1 is the default modulation coding scheme/puncturing scheme for burst 1.

Requirements

EGPRS LA

 Revision: G.00.00 and above

Programming Example

OUTPUT 714;"CALL:PDTC2:MSLot:CONFig D4U1"
! Sets the multislot configuration to be 4 downlink PDTCHs and 1 uplink PDTCH.

OUTPUT 714;"CALL:PDTC2:MCSCheme:EBPTest MCS1P2"
! Sets the first burst's PDTCH Modulation Coding Scheme (MCS) to MCS 1 (an GMSK modulated signal)
! and puncturing scheme P2 for EGPRS BCH+PDTCH test mode.

OUTPUT 714;"CALL:PDTC2:MCSCheme:EBPTest:BURSt2 MCS9P2_1"
! Burst 2 uses MCS 9 (an 8PSK modulated signal) and puncuturing scheme 2_1

OUTPUT 714;"CALL:PDTC2:MCSCheme:EBPTest:BURSt3 MCS7P1_3"
! Burst 3 uses MCS 7 (8PSK modulated siganl)

OUTPUT 714;"CALL:PDTC2:MCSCheme:EBPTest:BURSt4 ASBURSt1"
! Burst 4 is set to the same MCS  as burst 1 which is MCS1P2.

CALL:(PDTC2|PDTCH2|PDTChannel2):MSLot:CONFig

Function

GSM TA

 This command is not applicable to the GSM Test Application.

GPRS TA

This command is not applicable to the GPRS Test Application.

EGPRS TA

This command is not applicable to the EGPRS Test Application.

GSM/GPRS LA

This command is not applicable to the GSM/ GPRS Lab Application.

EGPRS LA

This command sets/queries the multislot configuration. The deferred version of this command is CALL:SETup:(PDTCH|PDTChannel):MSLot:CONFig .

If this command is attempted while there is an active DTM connection or while the test set is in a DTM test operating mode, it is stored and applied when the test set is no longer in Dual Transfer Mode.

The effect this command has on the number of uplink and downlink timeslots depends on the Connection Type (see CALL:FUNCtion:CONNection:TYPE ):

  • Type A - The multislot configuration command only affects the number of uplink timeslots.
  • BLER - The multislot configuration command only affects the number of downlink timeslots.

The actual timeslots used in each configuration are fixed as in the list below.

Multislot Configuration Downlink Timeslots Used Uplink Timeslots Used

D1U1 3 3
D1U2 3 3,4
D1U3 3 3,4,5
D1U4 3 3,4,5,6
D1U5 3 2,3,4,5,6
D1U6 2 1,2,3,4,5,6
D2U1 3,4 4
D2U2 3,4 3,4
D2U3 3,4 3,4,5
D2U4 3,4 3,4,5,6
D2U5 2,3 2,3,4,5,6
D3U1 3,4,5 4
D3U2 3,4,5 4,5
D3U3 3,4,5 4,5,6
D3U4 2,3,4 3,4,5,6
D4U1 3,4,5,6 5
D4U2 3,4,5,6 5,6
D4U3 2,3,4,5 4,5,6
D5U1 2,3,4,5,6 5
D5U2 2,3,4,5,6 5,6
D6U1 1,2,3,4,5,6 5
CUSTom You can position the timeslots flexibly. See Flexible Timeslot

When a multislot configuration change is executed, all measurements will be stopped before the change is made, and re-started after the change has taken effect.

For more information see Supported Multislot Classes .

Setting

 Range: D1U1 | D1U2 |D1U3 |D1U4 |D1U5 |D1U6|D2U1 | D2U2 |D2U3 | D2U4 |D2U5|D3U1 | D3U2 | D3U3 |D3U4| D4U1 | D4U2 |D4U3| D5U1|D5U2|D6U1

Query

 Range: D1U1 | D1U2 |D1U3 |D1U4 |D1U5 |D1U6|D2U1 | D2U2 |D2U3 | D2U4 |D2U5|D3U1 | D3U2 | D3U3 |D3U4| D4U1 | D4U2 |D4U3| D5U1|D5U2|D6U1

*RST Setting

 D2U1
Requirements GSM/GPRS/ EGPRS LA

Revision G.00.00 and above.

Programming Example

OUTPUT 714;"CALL:PDTC2:MSLot:CONFig D2U1"
! Sets the multislot configuration to be 2 downlink PDTCHs and 1 uplink PDTCH.

CALL:(PDTC2|PDTCH2|PDTChannel2):MSLot:CONFig:CUSTom:TSLots

Function

GSM TA

 This command is not applicable to the GSM Test Application.

GPRS TA

 This command is not applicable to the GPRS Test Application.

EGPRS TA

 This command is not applicable to the EGPRS Test Application.

GSM/GPRS LA

 This command is not applicable to the GSM/EGPRS Lab Applicatio

EGPRS LA

This command sets/queries the customized multislot configuration. See Flexible Timeslot for more information.

The command form accepts two string parameters with each contains a maximum of 8 characters. The first string represents the timeslot usage of TS0 to TS7 of the downlink timeslots and the second string represents the timeslot usage of TS0 to TS7 of the uplink timslots. Each timeslot of the uplink and downlink can be configured to one of the three values:

  • OFF: represented by `-'. ` `, `x', `X', or `0', `-' returned by query.
  • PDCH: represented by `p', `P', or `1', `P' returned by query.
  • TCH: represented by `t' or `T', `T' returned by query

If less than 8 characters in each string are specified in a parameter, the remaining higher numbered timeslots are assumed to be OFF.

Setting

 Range: -, ,x,X,0 |p,P,1

Query

 Range: - |P

*RST Setting

 --PP----,--P-----
Requirements GSM/GPRS/ EGPRS LA

Revision: G.00.00 and above

Programming Example

OUTPUT 714;"CALL:PDTC2:MSLot:CONFig:CUSTom:TSLots --PP----,--P-----"
! Sets the custom multislot configuration to be 2 downlink PDTCHs and 1 uplink PDTCH. Timeslot 2 and 3
! are configured to PDCH in the downlink and Timeslot 2 is configured to PDCH in the uplink.

CALL:(PDTC2|PDTCH2|PDTChannel2):PZERo:LEVel

Function

GSM TA

 This command is not applicable to the GSM Test Application.

GPRS TA

This command is not applicable to the GPRS Test Application.

EGPRS TA

This command is not applicable to the EGPRS Test Application.

GSM/GPRS LA

This command is not applicable to the GSM/GPRS Lab Application.
EGPRS LA

This command sets/queries the power reduction reference level (ETSI refers to this as P0) for the downlink PDTCH carrier 2 power control.

For further information see Downlink Dual Carrier .
Setting Range: 0 to 30 dB
Resolution: 2 dB
Query Range: 0 to 30 dB
Resolution: 2 dB
*RST setting 0 dB
Requirements EGPRS LA

Revision: G.00.00 and above

Programming Example

OUTPUT 714;"CALL:PDTC2:PZERo:LEVel 30"
! Sets the power reduction reference level (P0) to 30 dB.

CALL:(PDTC2|PDTCH2|PDTChannel2):PREDuction:LEVel

Function

GSM TA

 This command is not applicable to the GSM Test Application.

GPRS TA

This command is not applicable to the GPRS Test Application.

EGPRS TA

This command is not applicable to the EGPRS Test Application.

GSM/GPRS LA

This command is not applicable to the GSM/GPRS Lab Application.
EGPRS LA

This command sets/queries the power reduction level for the downlink PDTCH carrier 2 power control of a mobile.

For further information see Downlink Dual Carrier .
Setting Range: 0 to 25 dB
Resolution: 0.1 dB
Query Range: 0 to 25 dB
Resolution: 0.1 dB
*RST setting 0 dB
Requirements EGPRS LA

Revision: G.00.00 and above

Programming Example

OUTPUT 714;"CALL:PDTC2:PRED:LEVel 3"
! Sets the power reduction level to 3 dB.

CALL:(PDTC2|PDTCH2|PDTChannel2):PREDuction:BURSt<1|2|3|4|5>

Function

GSM TA

 This command is not applicable to the GSM Test Application.

GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.

GSM/GPRS LA

This command is not applicable to the GSM/GPRS Lab Application.
EGPRS LA

This command sets/queries whether or not a 2nd downlink PDTCH burst can set its power reduction level. You can define the levels of reduction using CALL:(PDTC2|PDTCH2|PDTChannel2):PREDuction:LEVel .

For further information see Downlink Dual Carrier .
Setting | Range: 0 | OFF | 1 | ON
Query | Range: 0 | 1
*RST setting | 0 | OFF
Requirements EGPRS LA

Revision: G.00.00 and above

Programming Example

OUTPUT 714;"CALL:PDTC2:PRED:BURSt1 ON"
! Turns the power reduction level of the burst1 ON.


CALL:PMNCode

CALL:PMNCode

GPIB Command Conventions

  • CALL[:CELL]:PMNCode[:SVALue]
  • CALL[:CELL]:PMNCode:VALue
  • CALL[:CELL]:PMNCode:STATe

CALL[:CELL]:PMNCode[:SVALue]

Function

 GSM TA

This command sets/queries the 3 digit mobile network code. This command is used for the PCS band only. This command sets the PMNCode state to ON. This can only be set when the Call Operating Mode is set to Off (see CALL:OPERating:MODE ).

GPRS TA

EGPRS LA

GSM/GPRS LA

EGPRS LA

Setting

Range: 0 to 999

Resolution: 1

Query

Range: 0 to 999

Resolution: 1

*RST Setting

1
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:CELL:PMNCODE:SVALUE 798"
! Sets the value to 798 and the state to ON. Only used for PCS 1900 band.

CALL[:CELL]:PMNCode:VALue

Function

 GSM TA

This command sets/queries the 3 digit mobile network code value. This command is used for PCS band only.

GPRS TA

EGPRS LA
GSM/GPRS LA

EGPRS LA

Setting

Range: 0 to 999

Resolution: 1

Query

Range: 0 to 999

Resolution: 1

*RST Setting

1
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:CELL:PMNCODE:VALUE 798"
! Sets the 3 digit MNCode for PCS 1900 to 798.

CALL[:CELL]:PMNCode:STATe

Function

 GSM TA

This command sets/queries the MNC state in the active (that is the selected) format. This command is used for the PCS band only. Setting it to ON configures the BCCH to use the 3 digit MNC. Note, this command can only be used when the Cell Operating Mode is OFF.

If the test set is in active cell operating mode, this command cannot be set unless the Call Operating Mode is OFF.

GPRS TA

EGPRS LA

GSM/GPRS LA

EGPRS LA

Setting

Range: 0 | OFF | 1 | ON

Query

Range: 0 | 1

*RST Setting

 0 | OFF
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:CELL:PMNCode:STATe ON"
! Enables the 3 digit MNCode for PCS 1900.


CALL:POWer

CALL:POWer

  • CALL[:CELL]:POWer[:SAMPlitude][:SELected]
  • CALL[:CELL]:POWer[:SAMPlitude]:CW
  • CALL[:CELL]:POWer[:SAMPlitude]:GSM
  • CALL[:CELL]:POWer:AMPLitude[:SELected]
  • CALL[:CELL]:POWer:AMPLitude:CW
  • CALL[:CELL]:POWer:AMPLitude:GSM
  • CALL[:CELL]:POWer:STATe[:SELected]
  • CALL[:CELL]:POWer:STATe:CW
  • CALL[:CELL]:POWer:STATe:GSM

GPIB Command Conventions

CALL[:CELL]:POWer[:SAMPlitude][:SELected]

Function

GSM TA

This command sets/queries the Cell Power for the active (that is the selected) format and turns the state to ON.

This is a complex command combining the cell power state and amplitude commands. The cell power state is automatically set to ON when this command is used.

The suffix dBm is optional.

The Cell Power is affected when there is an amplitude offset (see Amplitude Offset ).

The power level of the TCH is also affected by the setting of this command.
However, the TCH level is also affected by other settings
(see CALL:(PDTCH|PDTChannel):PREDuction:LEVel<1|2> ). TCH burst power = BCH power - (PRL1 | PRL2).

GPRS TA

This command sets/queries the Cell Power for the active (that is the selected) format and turns the state to ON.

This is a complex command combining the cell power state and amplitude commands. The cell power state is automatically set to ON when this command is used.

The suffix dBm is optional.

The power level of the PDTCH is also affected by the setting of this command. However, the PDTCH level is also affected by other settings (see Configuring the Packet Data Traffic Channel (PDTCH) ).

The Cell Power is affected when there is an amplitude offset (see Amplitude Offset ).

EGPRS TA

GSM/GPRS LA

This command sets/queries the Cell Power for the active (that is the selected) format and turns the state to ON.

This is a complex command combining the cell power state and amplitude commands. The cell power state is automatically set to ON when this command is used.

The suffix dBm is optional.

The Cell Power is affected when there is an amplitude offset (see Amplitude Offset ).

The power level of the TCH is also affected by the setting of this command.
However, the TCH level is also affected by other settings
(see CALL:(PDTCH|PDTChannel):PREDuction:LEVel<1|2> ). TCH burst power = BCH power - (PRL1 | PRL2).

The power level of the PDTCH is also affected by the setting of this command. However, the PDTCH level is also affected by other settings (see Configuring the Packet Data Traffic Channel (PDTCH) ).

EGPRS LA

Setting

Range: -10 dBm to -127 dBm

Resolution: .01 dBm

Query

Range: -10 dBm to -127 dBm

Resolution: .01 dBm

*RST Setting

The *RST value of this command depends on the format that is currently active. For example, if the GSM format is currently active, the *RST value for this command is the same value as the equivalent command containing the :GSM format identifier.
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:CELL:POWer:SAMPlitude:SELected -50dBm"
! Sets the value to -50dBm and the state to ON.

CALL[:CELL]:POWer[:SAMPlitude]:CW

Function

GSM TA

This command sets/queries the Cell Power for a continuous wave format whether or not that format is active.

This is a complex command combining the cell power state and amplitude commands. The cell power state is automatically set to ON when this command is used.

The suffix dBm is optional.

The Cell Power is affected when there is an amplitude offset (see Amplitude Offset ).

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Setting

Range: +40 dBm to -177 dBm

Resolution: .01 dBm

Query

Range: +40 dBm to -177 dBm

Resolution: .01 dBm

*RST Setting

-50 dBm
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:CELL:POWer:SAMPlitude:CW -50dBm"
! Sets the value to -50dBm and the state to ON.

CALL[:CELL]:POWer[:SAMPlitude]:GSM

Function

GSM TA

This command sets/queries the Cell Power for the GSM format whether or not that format is active.

This is a complex command combining the cell power state and amplitude commands. The cell power state is automatically set to ON when this command is used.

The suffix dBm is optional.

The Cell Power is affected when there is an amplitude offset (see Amplitude Offset ).

The power level of the TCH is also affected by the setting of this command.
However, the TCH level is also affected by other settings
(see CALL:(PDTCH|PDTChannel):PREDuction:LEVel<1|2> ). TCH burst power = BCH power - (PRL1 | PRL2).

GSM/GPRS LA

EGPRS TA

GPRS TA

EGPRS LA

Setting

Range: -10 dBm to -127 dBm

Resolution: .01 dBm

Query

Range: -10 dBm to -127 dBm

Resolution: .01 dBm

*RST Setting

-85 dBm
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:CELL:POWer:SAMPlitude:GSM -50dBm"
! Sets the value to -50dBm and the state to ON.

CALL[:CELL]:POWer:AMPLitude[:SELected]

Function

GSM TA

This command sets/queries the Cell Power for the active (that is the selected) format.

The suffix dBm is optional.

The Cell Power is affected when there is an amplitude offset (see Amplitude Offset ).

The power level of the TCH is also affected by the setting of this command.
However, the TCH level is also affected by other settings
(see CALL:(PDTCH|PDTChannel):PREDuction:LEVel<1|2> ). TCH burst power = BCH power - (PRL1 | PRL2).

GPRS TA

This command sets/queries the Cell Power (BCH) for the active (that is the selected) format.

The suffix dBm is optional.

The power level of the PDTCH is also affected by the setting of this command. However, the PDTCH level is also affected by other settings (see Configuring the Packet Data Traffic Channel (PDTCH) ).

The Cell Power is affected when there is an amplitude offset (see Amplitude Offset ).

EGPRS TA

GSM/GPRS LA

This command sets/queries the Cell Power for the active (that is the selected) format and turns the state to ON.

This is a complex command combining the cell power state and amplitude commands. The cell power state is automatically set to ON when this command is used.

The suffix dBm is optional.

The Cell Power is affected when there is an amplitude offset (see Amplitude Offset ).

The power level of the TCH is also affected by the setting of this command.
However, the TCH level is also affected by other settings
(see CALL:(PDTCH|PDTChannel):PREDuction:LEVel<1|2> ). TCH burst power = BCH power - (PRL1 | PRL2).

The power level of the PDTCH is also affected by the setting of this command. However, the PDTCH level is also affected by other settings (see Configuring the Packet Data Traffic Channel (PDTCH) ).

EGPRS LA

Setting

Range: -10 dBm to -127 dBm

Resolution: .01 dBm

Query

Range: -10 dBm to -127 dBm

Resolution: .01dBm

*RST Setting

The *RST value of this command depends on the format that is currently active. For example, if the GSM format is currently active, the *RST value for this command is the same value as the equivalent command containing the :GSM format identifier.
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:CELL:POWer:AMPLitude:SELected -50dBm"
! Set the cell power from test set to -50dBm.

CALL[:CELL]:POWer:AMPLitude:CW

Function

GSM TA

This command sets/queries the Cell Power for a continuous wave format whether or not that format is active.

The suffix dBm is optional.

The Cell Power is affected when there is an amplitude offset (see Amplitude Offset ).

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Setting

Range: +40 dBm to -177 dBm

Resolution: .01 dBm

Query

Range: +40 dBm to -177 dBm

Resolution: .01 dBm

*RST Setting

-50 dBm
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:CELL:POWer:AMPLitude:CW -50dBm"
! Set the cell power from test set to -50dBm.

CALL[:CELL]:POWer:AMPLitude:GSM

Function

GSM TA

This command sets/queries the Cell Power for the GSM format whether or not that format is active.

The suffix dBm is optional.

The Cell Power is affected when there is an amplitude offset (see Amplitude Offset ).

The power level of the TCH is also affected by the setting of this command.
However, the TCH level is also affected by other settings
(see CALL:(PDTCH|PDTChannel):PREDuction:LEVel<1|2> ). TCH burst power = BCH power - (PRL1 | PRL2).

GSM/GPRS LA

EGPRS TA

GPRS TA

EGPRS LA

Setting

Range: -10 dBm to -127 dBm

Resolution: .01 dBm

Query

Range: -10 dBm to -127 dBm

Resolution: .01dBm

*RST Setting

-85 dBm
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:CELL:POWer:AMPLitude:GSM -50dBm"
! Set the cell power from test set to -50dBm.

CALL[:CELL]:POWer:STATe[:SELected]

Function

GSM TA

This command sets/queries the Cell Power state for the active (that is the selected) format.

When set to 1|ON, the RF power for the cell is turned on.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Setting

Range: 0 | OFF | 1 | ON

Query

Range: 0 | 1

*RST Setting

The *RST value of this command depends on the format that is currently active. For example, if the GSM format is currently active, the *RST value for this command is the same value as the equivalent command containing the :GSM format identifier.
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:CELL:POWer:STATe:SELected 1"
! Sets the cell power state to ON.

CALL[:CELL]:POWer:STATe:CW

Function

GSM TA

This command sets/queries the Cell Power state in a continuous wave format whether or not that format is active.

When set to 1 | 0, the RF power for the cell is turned on.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Setting

Range: 0 | OFF | 1 | ON

Query

Range: 0 | 1

*RST Setting

ON
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:CELL:POWer:STATe:CW 1"
! Sets the cell power state to ON.

CALL[:CELL]:POWer:STATe:GSM

Function

GSM TA

This command sets/queries the Cell Power state in the GSM format whether or not that format is active.

When set to 1 | 0, the RF power for the cell is turned on.

GSM/GPRS LA

EGPRS TA

GPRS TA

EGPRS LA

Setting

Range: 0 | OFF | 1 | ON

Query

Range: 0 | 1

*RST Setting

ON
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:CELL:POWer:STATe:GSM 1"
! Sets the cell power state to ON.


CALL:RACode

CALL:RACode

GPIB Command Conventions

  • CALL[:CELL]:RACode<[:SELected]|:GSM>

CALL[:CELL]:RACode<[:SELected]|:GSM>

Function

 GSM TA

Sets/queries the value of the Routing Area Code (RAC). This can only be set when the Call Operating Mode parameter is set to Off (see CALL:OPERating:MODE ).

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Setting

Range: 0 to 255

Resolution: 1

Query

Range: 0 to 255

Resolution: 1

*RST Setting

1
Related Topics

See Configuring the Broadcast Channel (BCH) .
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:CELL:RACODE 111"
! Sets the cell's routing area code to 111.


CALL:RFGenerator

CALL:RFGenerator

GPIB Command Conventions

  • CALL[:CELL]:RFGenerator:CONFigure
  • CALL[:CELL]:RFGenerator:FMBRoadcast:ADAPter:GAIN
  • CALL[:CELL]:RFGenerator:FMBRoadcast:CORRection:GAIN
  • CALL[:CELL]:RFGenerator:FMBRoadcast:CORRection:STATe
  • CALL[:CELL]:RFGenerator:FMBRoadcast:FREQuency
  • CALL[:CELL]:RFGenerator:FMBRoadcast:FM:INTernal:DEViation
  • CALL[:CELL]:RFGenerator:FMBRoadcast:FM:INTernal:FREQuency
  • CALL[:CELL]:RFGenerator:FMBRoadcast:FM:INTernal:STATe
  • CALL[:CELL]:RFGenerator:FMBRoadcast:POWer:AMPLitude
  • CALL[:CELL]:RFGenerator:FMBRoadcast:POWer:STATe
  • CALL[:CELL]:RFGenerator:FREQuency[:SELected]
  • CALL[:CELL]:RFGenerator:FREQuency:GSM

  • CALL[:CELL]:RFGenerator:GPS:BFILter
  • CALL[:CELL]:RFGenerator:GPS:FREQuency
  • CALL[:CELL]:RFGenerator:GPS:FREQuency2
  • CALL[:CELL]:RFGenerator:GPS:NMESsage
  • CALL[:CELL]:RFGenerator:GPS:POWer:AMPLitude
  • CALL[:CELL]:RFGenerator:GPS:POWer:STATe
  • CALL[:CELL]:RFGenerator:GPS:POWer[:SAMPLitude]
  • CALL[:CELL]:RFGenerator:GPS:RAW:PPATtern
  • CALL[:CELL]:RFGenerator:GPS:SVID

CALL[:CELL]:RFGenerator:CONFigure

Function

GSM TA

Sets/queries the RF Generator mode:

Normal: This mode is the normal CW operating mode is in which the test set generates a CW signal.
FM broadcast: In this mode, the test set generates the signals that are sent through the PF OUT ONLY port to the FM Adapter to produce an FM Broadcast signal.

Operating mode = Test Mode and Downlink Function = CW. See CW .

See FM Broadcast for more information.

GPS: In this mode, the test set generates the required GPS signal at specified frequency point and specified power level. See Global Position System for more information

GPRS TA
EGPRS TA

GSM/GPRS LA

EGPRS LA

Setting

Range: NORMal | FMBRoadcast |GPS

Query

 Range: NORM | FMBR |GPS

*RST Setting

 NORMal
Requirements GSM/GPRS/
EGPRS TA

Revision: A.09 and above
GSM/GPRS/
EGPRS LA

Revision: F.01 and above

Revision: G.00.00 adds GPS

Programming Example

OUTPUT 714;"CALL:RFGenerator:CONFigure FMBRoadcast"
! Sets RF Generator mode to FM Broadcast.

CALL[:CELL]:RFGenerator:FMBRoadcast:ADAPter:GAIN

Function

GSM TA

Sets/queries the loss of the FM Adapter. This parameter compensates the loss by increasing the signal strength at the RF OUT ONLY port.

Operating mode = Test Mode and Downlink Function = CW. See CW .

See FM Broadcast for more information.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Setting

Range: -30 to -10 dB

Resolution: 0.01 dB

Query

Range: -30 to -10 dB

Resolution: 0.01 dB

*RST Setting

 -19.75 dB
Requirements GSM/GPRS/
EGPRS TA

Revision: A.09 and above
GSM/GPRS/
EGPRS LA

Revision: F.01 and above

Programming Example

OUTPUT 714;"CALL:RFGenerator:FMBRoadcast:ADAPter:GAIN -19.75"
! Sets FM Broadcast Adapter Gain to -19.75 dB.

CALL[:CELL]:RFGenerator:FMBRoadcast:CORRection:GAIN

CALL[:CELL]:RFGenerator:FMBRoadcast:CORRection[:SGAIN]

Function

GSM TA

Sets/queries the FM Broadcast mode Amplitude Offset setting that is applied to the RF OUT ONLY port.

Operating mode = Test Mode and Downlink Function = CW. See CW .

See FM Broadcast for more information.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Setting

Range: -50 to 50 dB

Resolution: 0.01 dB

Query

Range: -50 to 50 dB

Resolution: 0.01 dB

*RST Setting

 0 dB
Requirements GSM/GPRS/
EGPRS TA

Revision: A.09 and above
GSM/GPRS/
EGPRS LA

Revision: F.01 and above

Programming Example

OUTPUT 714;"CALL:RFGenerator:FMBRoadcast:CORRection:GAIN 0"
! Sets FM Broadcast Correction Gain to 0 dB.

CALL[:CELL]:RFGenerator:FMBRoadcast:CORRection:STATe

Function

GSM TA

Sets/queries whether the FM Broadcast mode Amplitude Offset setting is applied.

Operating mode = Test Mode and Downlink Function = CW. See CW .

See FM Broadcast for more information.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Setting

Range: 1 | ON | 0 | OFF

Query

 Range: 1 | 0

*RST Setting

 OFF
Requirements GSM/GPRS/
EGPRS TA

Revision: A.09 and above
GSM/GPRS/
EGPRS LA

Revision: F.01 and above

Programming Example

OUTPUT 714;"CALL:RFGenerator:FMBRoadcast:CORRection:STATe 0"
! Sets FM Broadcast Correction State to OFF.

CALL[:CELL]:RFGenerator:FMBRoadcast:FREQuency

Function

GSM TA

Sets/queries the frequency at which the test set broadcasts the FM signal.

Operating mode = Test Mode and Downlink Function = CW. See CW .

The units (Hz|kHz|MHz|GHz) are optional, if no units are specified then units default to Hz.

See FM Broadcast for more information.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Setting

Range: 10MHz to 110 MHz

Resolution: 1 Hz

Query

Range: 10MHz to 110 MHz

Resolution: 1 Hz

*RST Setting

 98.1 MHz
Requirements GSM/GPRS/
EGPRS TA

Revision: A.09 and above
GSM/GPRS/
EGPRS LA

Revision: F.01 and above

Programming Example

OUTPUT 714;"CALL:RFGenerator:FMBRoadcast:FREQuency 100"
! Sets FM Broadcast Frequency to 100 Hz.

CALL[:CELL]:RFGenerator:FMBRoadcast:FM:INTernal:DEViation

CALL[:CELL]:RFGenerator:FMBRoadcast:FM:INTernal[:SDEViation]

Function

GSM TA

Sets/queries FM Deviation of the internal audio source. The internal audio source is the amount the modulated signal deviates from the carrier frequency.

Operating mode = Test Mode and Downlink Function = CW. See CW .

The units (Hz|kHz|MHz|GHz) are optional, if no units are specified then units default to Hz.

See FM Broadcast for more information.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Setting

Range: 0 to 75 kHz

Resolution: 100 Hz

Query

Range: 0 to 75 kHz

Resolution: 100 Hz

*RST Setting

 22.5 kHz
Requirements GSM/GPRS/
EGPRS TA

Revision: A.09 and above
GSM/GPRS/
EGPRS LA

Revision: F.01 and above

Programming Example

OUTPUT 714;"CALL:RFGenerator:FMBRoadcast:FM:INTernal 22.5 kHz"
! Sets Internal FM Deviation to 22.5 kHz.

CALL[:CELL]:RFGenerator:FMBRoadcast:FM:INTernal:FREQuency

Function

GSM TA

Sets/queries the test set's internal FM frequency.

Operating mode = Test Mode and Downlink Function = CW. See CW .

The units (Hz|kHz|MHz|GHz) are optional, if no units are specified then units default to Hz.

See FM Broadcast for more information.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Setting

Range: 50 to 20,000 Hz

Resolution: 1 Hz

Query

Range: 50 to 20,000 Hz

Resolution: 1 Hz

*RST Setting

 1 kHz
Requirements GSM/GPRS/
EGPRS TA

Revision: A.09 and above
GSM/GPRS/
EGPRS LA

Revision: F.01 and above

Programming Example

OUTPUT 714;"CALL:RFGenerator:FMBRoadcast:FM:INTernal:FREQuency 1 kHz"
! Sets the Internal FM Frequency to 1 kHz.

CALL[:CELL]:RFGenerator:FMBRoadcast:FM:INTernal:STATe

Function

GSM TA

Sets/queries whether the FM Broadcast mode Internal FM Deviation setting is applied.

Operating mode = Test Mode and Downlink Function = CW. See CW .

See FM Broadcast for more information.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Setting

Range: 1 | ON | 0 | OFF

Query

 Range: 1 | 0

*RST Setting

 1 (ON)
Requirements GSM/GPRS/
EGPRS TA

Revision: A.09 and above
GSM/GPRS/
EGPRS LA

Revision: F.01 and above

Programming Example

OUTPUT 714;"CALL:RFGenerator:FMBRoadcast:FM:INTernal:STATe ON"
! Sets Internal FM Deviation State to ON.

CALL[:CELL]:RFGenerator:FMBRoadcast:POWer:AMPLitude

CALL[:CELL]:RFGenerator:FMBRoadcast:POWer[:SAMPLitude]

Function

GSM TA

Sets/queries the power at which the test set broadcasts the FM signal.

Operating mode = Test Mode and Downlink Function = CW. See CW .

See FM Broadcast for more information.

NOTE
When this parameters is set to > -30 and < -120, "Over Range" and "Under Range" error message is displayed respectively.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Setting

Range: -140 to -20 dBm

Resolution: 0.01 dBm

Query

Range: -140 to -20 dBm

Resolution: 0.01 dBm

*RST Setting

 -50 dBm
Requirements GSM/GPRS/
EGPRS TA

Revision: A.09 and above
GSM/GPRS/
EGPRS LA

Revision: F.01 and above

Programming Example

OUTPUT 714;"CALL:RFGenerator:FMBRoadcast:POWer -50 dBm
! Sets FM Broadcast Power Amplitude to -50 dBm.

CALL[:CELL]:RFGenerator:FMBRoadcast:POWer:STATe

Function

GSM TA

Sets/queries whether the FM Broadcast Power setting is applied.

Operating mode = Test Mode and Downlink Function = CW. See CW .

See FM Broadcast for more information.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Setting

Range: 1 | ON | 0 | OFF

Query

 Range: 1 | 0

*RST Setting

 1 (ON)
Requirements GSM/GPRS/
EGPRS TA

Revision: A.09 and above
GSM/GPRS/
EGPRS LA

Revision: F.01 and above

Programming Example

OUTPUT 714;"CALL:RFGenerator:FMBRoadcast:POWer:STATe ON"
! Sets FM Broadcast Power State to ON.

CALL[:CELL]:RFGenerator:FREQuency[:SELected]

Function

GSM TA

Sets/queries the RF Generator Frequency for the active (that is the selected) format.

Operating mode = Test Mode and Downlink Function = CW. See CW .

The units (Hz|kHz|MHz|GHz) are optional, if no units are specified then units default to Hz.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Setting

Range: 292 MHz to 2700 MHz

Resolution: 1

Query

Range: 292 MHz to 2700 MHz

Resolution: 1

*RST Setting

The *RST value of this command depends on the format that is currently active. For example, if the GSM format is currently active, the *RST value for this command is the same value as the equivalent command containing the: GSM format identifier.
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:CELL:RFGenerator:FREQUENCY:SELECTED 896.2MHZ"
! Sets RF Gen frequency.

CALL[:CELL]:RFGenerator:FREQuency:GSM

Function

GSM TA

Sets/queries the RF Gen Frequency for the GSM format whether or not that format is active.

Operating mode = Test Mode and Downlink Function = CW. See CW .

The units (Hz|kHz|MHz|GHz) are optional, if no units are specified then units default to Hz.

GSM/GPRS LA

EGPRS LA

GPRS TA

EGPRS TA

Setting

Range: 292 MHz to 2700 MHz

Resolution: 1

Query

Range: 292 MHz to 2700 MHz

Resolution: 1

*RST Setting

939 MHz

Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:CELL:RFGenerator:FREQUENCY:GSM 896.2MHZ"
! Sets RF Gen frequency.

CALL[:CELL]:RFGenerator:GPS:BFILter

Function

GSM/GPRS TA

 This command is not applicable to GSM/GPRS TA
EGPRS TA This command is not applicable to EGPRS TA

GSM/GPRS LA

Sets/queries the filter that is used to filter the GPS baseband signal. A Gaussian or Rectangle filter with 10 MHz bandwidth is supported in this setting.

Operating mode = CW. See CW .

RF Gen Config = GPS. See Global Position System .

EGPRS LA

Setting

Range: GAUSsian | RECTangle

Query

Range: GAUSsian | RECTangle

*RST Setting

 GAUSsian
Requirements GSM/GPRS/
EGPRS LA

Revision: G.00.00 and above

Programming Example

OUTPUT 714;"CALL:RFGenerator:GPS:BFILter GAUSsian"
! Sets the type of filter to be GAUSsian

CALL[:CELL]:RFGenerator:GPS:FREQuency

Function

GSM/GPRS TA

 This command is not applicable to GSM/GPRS TA

EGPRS TA

 This command is not applicable to EGPRS TA

GSM/GPRS LA

Queries the frequency of RF source 1. This parameter is fixed at 1575.42MHz and displayed on the MUI.

Operating mode = CW. See CW .

RF Gen Config = GPS. See Global Position System .

EGPRS LA
Requirements GSM/GPRS/
EGPRS LA

Revision: G.00.00 and above

Programming Example

OUTPUT 714;"CALL:RFGenerator:GPS:FREQuency?"
! Queries the frequency of RF source 1. It will return the value:+1.57542000E+009

CALL[:CELL]:RFGenerator:GPS:FREQuency2

Function

GSM/GPRS TA

 This command is not applicable to GSM/GPRS TA

EGPRS TA

 This command is not applicable to EGPRS TA

GSM/GPRS LA

Queries the frequency of RF source 2. This parameter is fixed at 871MHz. RF source 2 is only available in those TA that use two RF Sources.

Operating mode = CW. See CW .

RF Gen Config = GPS. See Global Position System .

EGPRS LA
Requirements GSM/GPRS/
EGPRS LA

Revision: G.00.00 and above

Programming Example

OUTPUT 714;"CALL:RFGenerator:GPS:FREQuency2?"
! Queries the frequency of RF source 2. It will return the value:+8.71000000E+008

CALL[:CELL]:RFGenerator:GPS:NMESsage

Function

GSM/GPRS TA

 This command is not applicable to GSM/GPRS TA

EGPRS TA

 This command is not applicable to EGPRS TA

GSM/GPRS LA

Sets/queries the type of GPS navigation message that is transmitted on GPS frames.

Default Navigation (also called TLM): the GPS frames is filled according to the default navigation data (Alternating ones and zeros in word 3 through 10)

Raw: the GPS frames is filled with PN sequence.

Operating mode = CW. See CW .

RF Gen Config = GPS. See Global Position System .

EGPRS LA

Setting

Range: DEFault | RAW

Query

Range: DEFault | RAW

*RST Setting

 DEFault
Requirements GSM/GPRS/
EGPRS LA

Revision: G.00. 00 and above

Programming Example

OUTPUT 714;"CALL:RFGenerator:GPS:NMESsage RAW"
! Sets the type of GPS navigation message to be RAW

CALL[:CELL]:RFGenerator:GPS:POWer:AMPLitude

Function

GSM/GPRS TA

 This command is not applicable to GSM/GPRS TA

EGPRS TA

 This command is not applicable to EGPRS TA

GSM/GPRS LA

Sets/queries the power at which the test set generates the GPS signal.

Operating mode = CW. See CW .

The actual power range is -125dBm to -70dBm. However, it is affected when there is an amplitude offset.

See Global Position System for more information.

NOTE
When this parameters is set to > -70 or < -125 ( If Amplitude Offset = 0), a persistent error "Warning, Source under/over range due to requested setting" is displayed.

EGPRS LA

Setting

Range: -160dBm to -20dBm, after the Amplitude Offset (optional) has been included, see Amplitude Offset .

Resolution: 0.01 dBm

Query

Range: -160dBm to -20dBm, after the Amplitude Offset (optional) has been included, see Amplitude Offset )

Resolution: 0.01 dBm

*RST Setting

 -80 dBm
Requirements GSM/GPRS/
EGPRS LA

Revision: G.00.xx and above

Programming Example

OUTPUT 714;"CALL:RFGenerator:GPS:POWer:AMPLitude -80 dBm
! Sets GPS Power Amplitude to -80dBm.

CALL[:CELL]:RFGenerator:GPS:POWer:STATe

Function

GSM/GPRS TA

 This command is not applicable to GSM/GPRS TA

EGPRS TA

 This command is not applicable to EGPRS TA

GSM/GPRS LA

Sets/queries whether the GPS power setting is applied.

Operating mode = CW. See CW .

RF Gen Config = GPS. See Global Position System .

EGPRS LA

Setting

Range: 1 | ON | 0 | OFF

Query

 Range: 1 | 0

*RST Setting

 1 |ON
Requirements GSM/GPRS/
EGPRS LA

Revision: G.00.00 and above

Programming Example

OUTPUT 714;"CALL:RFGenerator:GPS:POWer:STATe ON"
! Sets GPS Power State to ON.

CALL[:CELL]:RFGenerator:GPS:POWer[:SAMPLitude]

Function

GSM/GPRS TA

 This command is not applicable to GSM/GPRS TA

EGPRS TA

 This command is not applicable to EGPRS TA

GSM/GPRS LA

Sets/queries the power at which the test set generates the GPS signal. Setting this parameter is also set the GPS State to ON.

Operating mode = CW. See CW .

RF Gen Config = GPS.

The actual power range is -125dBm to -70dBm. However, it is affected when there is an amplitude offset.

See Global Position System for more information.

NOTE
When this parameters is set to > -70 or < -125 ( If Amplitude Offset = 0), a persistent error "Warning, Source under/over range due to requested setting" is displayed.

EGPRS LA

Setting

Range: -160dBm to -20dBm, after the Amplitude Offset (optional) has been included, see Amplitude Offset .

Resolution: 0.01 dBm

Query

Range: -160dBm to -20dBm, after the Amplitude Offset (optional) has been included, see Amplitude Offset .

Resolution: 0.01 dBm

*RST Setting

 -80 dBm
Requirements GSM/GPRS/
EGPRS LA

Revision: G.00.xx and above

Programming Example

OUTPUT 714;"CALL:RFGenerator:GPS:POWer -80 dBm
!Sets GPS Power State to ON and Amplitude to -80dBm.

CALL[:CELL]:RFGenerator:GPS:RAW:PPATtern

Function

GSM/GPRS TA

 This command is not applicable to GSM/GPRS TA

EGPRS TA

 This command is not applicable to EGPRS TA

GSM/GPRS LA

Sets/queries the date type that is transmitted on GPS frames.

Operating mode = CW. See CW .

RF Gen Config = GPS. See Global Position System .

GPS Navigation Message Type = RAW.

EGPRS LA

Setting

Range: PN9| PN15

Query

Range: PN9| PN15

*RST Setting

 PN9
Requirements GSM/GPRS/
EGPRS LA

Revision: G.00.00 and above

Programming Example

OUTPUT 714;"CALL:RFGenerator:GPS:RAW:PPATtern PN15"
! Sets the date type to be PN15

CALL[:CELL]:RFGenerator:GPS:SVID

Function

GSM/GPRS TA

 This command is not applicable to GSM/GPRS TA

EGPRS TA

 This command is not applicable to EGPRS TA

GSM/GPRS LA

Sets/queries which satellite is generating the GPS signal.

Operating mode = CW. See CW .

RF Gen Config = GPS. See Global Position System

Note: The SV ID will affect the spreading code phase.

EGPRS LA

Setting

Range: 1 to 37

Resolution: 1

Query

Range: 1 to 37

Resolution: 1

*RST Setting

 1
Requirements GSM/GPRS/
EGPRS LA

Revision: G.00.xx and above

Programming Example

OUTPUT 714;"CALL:RFGenerator:GPS:SVID 2
!Sets GPS satellite ID to be 2.


CALL:RTVocoder

CALL:RTVocoder

GPIB Command Conventions

  • CALL:RTVocoder:DECoder:HEADroom[:SELected]?
  • CALL:RTVocoder:DECoder:HEADroom:GSM?
  • CALL:RTVocoder:ENCoder:HEADroom[:SELected]?
  • CALL:RTVocoder:ENCoder:HEADroom:GSM?
  • CALL:RTVocoder:INPut:VOLTage[:EXPected][:SELected]
  • CALL:RTVocoder:INPut:VOLTage[:EXPected]:GSM
  • CALL:RTVocoder:OUTPut:VOLTage[:MAXimum][:SELected]
  • CALL:RTVocoder:OUTPut:VOLTage[:MAXimum]:GSM
  • CALL:RTVocoder:VADetection[:STATe][:SELected]
  • CALL:RTVocoder:VADetection[:STATe]:GSM
  • CALL:RTVocoder:VADetection:AMRate:ALGorithm[:SELected]
  • CALL:RTVocoder:VADetection:AMRate:ALGorithm:GSM

CALL:RTVocoder:DECoder:HEADroom[:SELected]?

CALL:RTVocoder:DECoder:HEADroom:GSM?

Function

 GSM TA This command is not applicable to the GPRS test application.

GPRS TA

 This command is not applicable to the GPRS test application.

EGPRS TA

 This command is not applicable to the EGPRS test application.

GSM/GPRS LA

Queries the headroom of the decoded data samples to the full scale of the DAC (Digital to Analog Converter). See "Real-Time Vocoder Headroom Information" .

EGPRS LA

Query

Range: 0.0 to 100 dB, 9.91E+37 (NAN)

Resolution: 0.1 dB
*RST Setting | 9.91E+37 (NAN)

Requirements

GSM/GPRS/ EGPRS TA

Revision: A.09 and above with required feature license.
GSM/GPRS/ EGPRS LA | Lab Application Revision: F.00.27 and above

Programming Example

OUTPUT 714;"CALL:RTVocoder:DECoder:HEADroom?"
! Queries decoder headroom.

CALL:RTVocoder:ENCoder:HEADroom[:SELected]?

CALL:RTVocoder:ENCoder:HEADroom:GSM?

Function

 GSM TA This command is not applicable to the GPRS test application.

GPRS TA

 This command is not applicable to the GPRS test application.

EGPRS TA

 This command is not applicable to the EGPRS test application.

GSM/GPRS LA

Queries the headroom of the audio samples to the full scale of the ADC (Analog to Digital Converter). See "Real-Time Vocoder Headroom Information" .

EGPRS LA

Query

Range: 0.0 to 100 dB, 9.91E+37 (NAN)

Resolution: 0.1 dB
*RST Setting | 9.91E+37 (NAN)

Requirements

GSM/GPRS/ EGPRS TA

Revision: A.09 and above with required feature license.
GSM/GPRS/ EGPRS LA | Lab Application Revision: F.00.27 and above

Programming Example

OUTPUT 714;"CALL:RTVocoder:ENCoder:HEADroom?"
! Queries encoder headroom.

CALL:RTVocoder:INPut:VOLTage[:EXPected][:SELected]

CALL:RTVocoder:INPut:VOLTage[:EXPected]:GSM

Function

 GSM TA This command is not applicable to the GPRS test application.

GPRS TA

 This command is not applicable to the GPRS test application.

EGPRS TA

 This command is not applicable to the EGPRS test application.

GSM/GPRS LA

Sets/queries the peak voltage of the analog audio signal that is applied at the test set's AUDIO IN connector. The units (V|mV) are optional. If no units are specified, then units default to V. See "Setting Real-Time Vocoder Parameters" .

EGPRS LA

Setting

Range: 0.001 to 2.0 V

Resolution: 1 mV

Query

Range: 0.001 to 2.0 V

Resolution: 1 mV
*RST Setting | 2.0 V

Requirements

GSM/GPRS/ EGPRS TA

Revision: A.09 and above with required feature license.
GSM/GPRS/ EGPRS LA | Lab Application Revision: F.00.27 and above

Programming Example

OUTPUT 714;"CALL:RTVocoder:INPut:VOLTage 350mV"
! Sets the peak level of Audio In signal to 350 mV.

CALL:RTVocoder:OUTPut:VOLTage[:MAXimum][:SELected]

CALL:RTVocoder:OUTPut:VOLTage[:MAXimum]:GSM

Function

 GSM TA This command is not applicable to the GPRS test application.

GPRS TA

 This command is not applicable to the GPRS test application.

EGPRS TA

 This command is not applicable to the EGPRS test application.

GSM/GPRS LA

Sets/queries the maximum audio peak output level that is produced on the test set's AUDIO OUT connector according to the voice data received on the R-Traffic/R-FCH channel. The units (V|mV) are optional. If no units are specified, then units default to V. See "Setting Real-Time Vocoder Parameters" .

EGPRS LA

Setting

Range: 0.0 to 5.0 V

Resolution: 0.1 mV

Query

Range: 0.0 to 5.0 V

Resolution: 0.1 mV
*RST Setting

0.0 V

Requirements

GSM/GPRS/ EGPRS TA

Revision: A.09 and above with required feature license.
GSM/GPRS/ EGPRS LA Lab Application Revision: F.00.27 and above

Programming Example

OUTPUT 714;"CALL:RTVocoder:OUTPut:VOLTage 350MV"
! Sets the peak level of AUDIO OUT signal to 350 mV.

CALL:RTVocoder:VADetection[:STATe][:SELected]

CALL:RTVocoder:VADetection[:STATe]:GSM

Function

 GSM TA This command is not applicable to the GPRS test application.

GPRS TA

 This command is not applicable to the GPRS test application.

EGPRS TA

 This command is not applicable to the EGPRS test application.

GSM/GPRS LA

Sets/queries whether or not the voice activity detection algorithm is implemented in the speech codec. See "Setting Real-Time Vocoder Parameters" .

EGPRS LA

Setting

Range: 1|ON | 0|OFF

Query

Range: 1 | 0
*RST Setting | 0|OFF

Requirements

GSM/GPRS/ EGPRS TA

Revision: A.09 and above with required feature license.
GSM/GPRS/ EGPRS LA | Lab Application Revision: F.00.27 and above

Programming Example

OUTPUT 714;"CALL:RTVocoder:VADetection ON"
! Enable the voice activity detection algorithm.

CALL:RTVocoder:VADetection:AMRate:ALGorithm[:SELected]

CALL:RTVocoder:VADetection:AMRate:ALGorithm:GSM

Function

 GSM TA This command is not applicable to the GPRS test application.

GPRS TA

 This command is not applicable to the GPRS test application.

EGPRS TA

 This command is not applicable to the EGPRS test application.

GSM/GPRS LA

Sets/queries the voice activity detection algorithm. See "Setting Real-Time Vocoder Parameters" .

EGPRS LA

Setting

Range: OPTion1 | OPTion2

Query

Range: OPT1 | OPT2
*RST Setting

OPT1

Requirements

GSM/GPRS/ EGPRS TA

Revision: A.09 and above with required feature license.
GSM/GPRS/ EGPRS LA Lab Application Revision: F.00.27 and above

Programming Example

OUTPUT 714;"CALL:RTVocoder:VADetection:AMRate:ALGorithm OPT2"
! Select Option 2 VAD algorithm for AMR.


CALL:(SACCH|SACChannel)

CALL:(SACCH|SACChannel)

Last updated: December 3, 2008

GPIB Command Conventions

  • CALL:(SACCH|SACChannel):LAPDModified:FORMat

CALL:(SACCH|SACChannel):LAPDModified:FORMat

Function

GSM TA

This command sets/queries the LAPDm Format on SACCH channel. The LAPDm Format specification changes since Release 1996(R96). LAPDm Format B is used before R96 while LAPDm Format B4 is used after R96. You can select either of them according to the LAPDm Format of your mobile station.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Setting

Range: B4 | B

Query

Range: B4 | B

*RST Setting

 B4

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.07 and above
GSM/GPRS/ EGPRS LA

Revision: E.01 and above

Programming Example

OUTPUT 714;"CALL:CELL:OPERATING:MODE OFF" !Set the operating mode to OFF.

OUTPUT 714;"CALL:SACCH:LAPDM:FORM B" !Set the LAPDm Format to B.


CALL:SETup

CALL:SETup

GPIB Command Conventions

  • CALL:SETup:DTMode:ARFCn[:SELected]
  • CALL:SETup:DTMode:BAND
  • CALL:SETup:DTMode:CSCHeme
  • CALL:SETup:DTMode:CSCHeme:DOWNlink
  • CALL:SETup:DTMode:CSCHeme:UPLink
  • CALL:SETup:DTMode:CSWitched:HRSPeech:SCHannel
  • CALL:SETup:DTMode:CSWitched:MS:TXLevel[:SELected]
  • CALL:SETup:DTMode:CSWitched:TSLot
  • CALL:SETup:DTMode:FHOPping[:STATe]
  • CALL:SETup:DTMode:MCSCheme
  • CALL:SETup:DTMode:MS:GAMMa:BURSt<[1]|2|3|4>[:SELected]
  • CALL:SETup:DTMode:MS:TXLevel[:SELected]:BURSt<[1]|2|3|4|5>
  • CALL:SETup:DTMode:MSLot:CONFig
  • CALL:SETup:DTMode:MSLot:CONFig:CUSTom:TSLots
  • CALL:SETup:DTMode:PZERo:LEVel
  • CALL:SETup:DTMode:TTI:[MODE]
  • CALL:SETup:DTMode:USFLag[:ASSigned]

  • CALL:SETup:(PDTCH|PDTChannel)[:ARFCn][:SELected]
  • CALL:SETup:(PDTCH|PDTChannel):BAND
  • CALL:SETup:(PDTCH|PDTChannel):CSCHeme
  • CALL:SETup:(PDTCH|PDTChannel):CSCHeme:DOWNlink
  • CALL:SETup:(PDTCH|PDTChannel):CSCHeme:UPLink
  • CALL:SETup:(PDTChannel|PDTCH):DLDCarrier[:STATe]
  • CALL:SETup:(PDTCH|PDTChannel):MCSCheme
  • CALL:SETup:(PDTCH|PDTChannel):MS:GAMMa:BURSt<[1]|2|3|4|5>[:SELected]
  • CALL:SETup:(PDTCH|PDTChannel):MS:TXLevel[:SELected]:BURSt<[1]|2|3|4|5>
  • CALL:SETup:(PDTCH|PDTChannel):MSLot:CONFig
  • CALL:SETup:(PDTCH|PDTChannel):MSLot:CONFig:CUSTom:TSLots
  • CALL:SETup:(PDTCH|PDTChannel):PZERo:LEVel
  • CALL:SETup:(PDTCH|PDTChannel):TTI:[MODE]
  • CALL:SETup:(PDTCH|PDTChannel):USFLag

  • CALL:SETup:(PDTC2|PDTCH2|PDTChannel2):ARFCn[:SELected]
  • CALL:SETup:(PDTC2|PDTCH2|PDTChannel2):FHOPping[:STATe]
  • CALL:SETup:(PDTC2|PDTCH2|PDTChannel2):MSLot:CONFig
  • CALL:SETup:(PDTC2|PDTCH2|PDTChannel2):MSLot:CONFig:CUSTom:TSLots

  • CALL:SETup:TCHannel[:ARFCn][:SELected]
  • CALL:SETup:TCHannel:BAND
  • CALL:SETup:TCHannel:CMODe[:VALue]
  • CALL:SETup:TCHannel:CMODe:HRSPeech:SCHannel
  • CALL:SETup:TCHannel:CMODe:LSPeech:CHANnel
  • CALL:SETup:TCHannel:MS:TXLevel[:SELected]
  • CALL:SETup:TCHannel:TSLot

CALL:SETup:DTMode:ARFCn[:SELected]

CALL:SETup:DTMode:ARFCn:(DCS|EGSM|GSM450|GSM480|GSM750|GSM850|PCS|PGSM|RGSM|TGSM810)

Function

GSM TA

 This command is not applicable to the GSM Test Application.

GPRS TA

 This command is not applicable to the GPRS Test Application.

EGPRS TA

 This command is not applicable to the EGPRS Test Application.

GSM/GPRS LA

This command sets/queries the deferred DTM (Dual Transfer Mode) traffic channel for the band selected.

The optional [SELected] keyword in this command specifies that the channel being set/queried applies to the current DTM band.

See DTM Traffic Channel for more information.

EGPRS LA
Setting

Range:

  • DCS band, channels 512 to 885
  • EGSM band, channels 0 to 124 and 975 to 1023
  • GSM450 band, channels 259 to 293
  • GSM480 band, channels 306 to 340
  • GSM750 band, channels 438 to 511
  • GSM850 band, channels 128 to 251
  • PCS band, channels 512 to 810
  • PGSM band, channels 1 to 124
  • RGSM band, channels 0 to 124 and 955 to 1023
  • TGSM810 band, channels 350 to 425

Resolution: 1
Query

Range:

  • DCS band, channels 512 to 885
  • EGSM band, channels 0 to 124 and 975 to 1023
  • GSM450 band, channels 259 to 293
  • GSM480 band, channels 306 to 340
  • GSM750 band, channels 438 to 511
  • GSM850 band, channels 128 to 251
  • PCS band, channels 512 to 810
  • PGSM band, channels 1 to 124
  • RGSM band, channels 0 to 124 and 955 to 1023
  • TGSM810 band, channels 350 to 425

Resolution: 1
*RST setting

PGSM, EGSM and RGSM bands: 30, DCS and PCS bands: 698, GSM450: 280, GSM480: 320, GSM750: 460, GSM850: 160, TGSM810: 400.
Requirements GSM/GPRS/ EGPRS LA

Revision: E.00.12 and above

Programming Example

OUTPUT 714;"CALL:SETup:DTMode:ARFCn 512"
! Sets the deferred DTM ARFCN of the selected band to 512, if 512 is valid for the selected band.

CALL:SETup:DTMode:BAND

Function

GSM TA

 This command is not applicable to the GSM Test Application.

GPRS TA

 This command is not applicable to the GPRS Test Application.

EGPRS TA

 This command is not applicable to the EGPRS Test Application.

GSM/GPRS LA

This command sets/queries the deferred DTM band, therefore constraining the range of DTM ARFCNs.

See DTM Traffic Band for more information.

EGPRS LA
Setting | Range: PGSM | EGSM | GSM450 | GSM480 | GSM750 | GSM850 | DCS | PCS | RGSM| TGSM810
Query | Range: PGSM | EGSM | GSM450 | GSM480 | GSM750 | GSM850 | DCS | PCS | RGSM| TGSM810
*RST setting | PGSM
Requirements GSM/GPRS/ EGPRS LA

Revision: E.00.12 and above

Programming Example

OUTPUT 714;"CALL:SETup:DTMode:BAND DCS"
! Sets the deferred DTM band to DCS.

CALL:SETup:DTMode:CSCHeme

Function

GSM TA

 This command is not applicable to the GSM Test Application.

GPRS TA

 This command is not applicable to the GPRS Test Application.

EGPRS TA

 This command is not applicable to the EGPRS Test Application.

GSM/GPRS LA

This command sets/queries the deferred DTM coding scheme for both GPRS uplink and downlink.

See DTM Coding Schemes for more information.

EGPRS LA
Setting | Range: CS1 | CS2 | CS3 | CS4
Query | Range: CS1 | CS2 | CS3 | CS4
*RST setting | CS4
Requirements GSM/GPRS/ EGPRS LA

Revision: E.00.12 and above

Programming Example

OUTPUT 714;"CALL:SETup:DTMode:CSCHeme CS1"
! Sets the deferred DTM coding scheme to CS1.

CALL:SETup:DTMode:CSCHeme:DOWNlink

Function

GSM TA

 This command is not applicable to the GSM Test Application.

GPRS TA

 This command is not applicable to the GPRS Test Application.

EGPRS TA

 This command is not applicable to the EGPRS Test Application.

EGPRS LA

 This command is not applicable to the EGPRS Lab Application.
GSM/GPRS LA

This command sets/queries the deferred DTM coding scheme for GPRS downlink.

When ETSI B connection is used, the coding scheme on the downlink must be the same as the uplink.

See DTM Coding Schemes for more information.
Setting | Range: CS1 | CS2 | CS3 | CS4
Query | Range: CS1 | CS2 | CS3 | CS4
*RST setting | CS4
Requirements GSM/GPRS LA

Revision: G.00.00 and above

Programming Example

OUTPUT 714;"CALL:SETup:DTMode:CSCHeme:DOWNlink CS1"
! Sets the deferred downlink DTM coding scheme to CS1.

CALL:SETup:DTMode:CSCHeme:UPLink

Function

GSM TA

 This command is not applicable to the GSM Test Application.

GPRS TA

 This command is not applicable to the GPRS Test Application.

EGPRS TA

 This command is not applicable to the EGPRS Test Application.

EGPRS LA

 This command is not applicable to the EGPRS Lab Application.
GSM/GPRS LA

This command sets/queries the deferred DTM coding scheme for GPRS uplink.

See DTM Coding Schemes for more information.
Setting | Range: CS1 | CS2 | CS3 | CS4
Query | Range: CS1 | CS2 | CS3 | CS4
*RST setting | CS4
Requirements GSM/GPRS LA

Revision: G.00.00 and above

Programming Example

OUTPUT 714;"CALL:SETup:DTMode:CSCHeme:UPLink CS1"
! Sets the deferred uplink DTM coding scheme to CS1.

CALL:SETup:DTMode:CSWitched:HRSPeech:SCHannel

Function

GSM TA

 This command is not applicable to the GSM Test Application.

GPRS TA

 This command is not applicable to the GPRS Test Application.

EGPRS TA

 This command is not applicable to the EGPRS Test Application.

GSM/GPRS LA

This command sets/queries the deferred DTM Circuit Switched Half Rate Sub-channel.

See DTM CS Half Rate Sub Channel for more information.

EGPRS LA
Setting | Range: 0 | 1
Query | Range: 0 | 1
*RST setting | 0
Requirements GSM/GPRS/ EGPRS LA

Revision: E.02 and above

Programming Example

OUTPUT 714;"CALL:SETup:DTMode:CSWitched:HRSPeech:SCHannel 1"
! Sets the deferred DTM CS Half Rate Sub-channel to ON.

CALL:SETup:DTMode:CSWitched:MS:TXLevel[:SELected]

CALL:SETup:DTMode:CSWitched:MS:TXLevel:(DCS|EGSM|GSM450|GSM480|GSM750|GSM850|PCS|PGSM|RGSM|TGSM810)

Function

GSM TA

 This command is not applicable to the GSM Test Application.

GPRS TA

 This command is not applicable to the GPRS Test Application.

EGPRS TA

 This command is not applicable to the EGPRS Test Application.

GSM/GPRS LA

 This command sets/queries the deferred DTM circuit switched MS Transmit Power Level for the band selected.

EGPRS LA
Setting

Range: 0 to 31

Resolution: 1
Query

Range: 0 to 31

Resolution: 1
*RST setting DCS and PCS bands: 10, PGSM, EGSM, RGSM, GSM450, GSM480, GSM750, GSM850 and TGSM810 bands: 15
Requirements GSM/GPRS/ EGPRS LA

Revision: E.00.12 and above

Programming Example

OUTPUT 714;"CALL:SETup:DTMode:CSWitched:MS:TXLevel 15"
! Sets the deferred DTM circuit switched MS Transmit Power Level to 15.

CALL:SETup:DTMode:CSWitched:TSLot

Function

GSM TA

 This command is not applicable to the GSM Test Application.

GPRS TA

 This command is not applicable to the GPRS Test Application.

EGPRS TA

 This command is not applicable to the EGPRS Test Application.

GSM/GPRS LA

This command sets/queries the deferred DTM circuit switched timeslot position within the selected multislot configuration.

See DTM CS Timeslot Position for more information.

EGPRS LA
Setting

Depends on the currently selected multislot configuration.

Range: 2|3|4|5|6

Resolution: 1
Query

Range: 2|3|4|5|6

Resolution: 1
*RST setting Depends on the currently selected multislot configuration. See DTM CS Timeslot Position
Requirements GSM/GPRS/ EGPRS LA

Revision: E.00.05

Revision: F.01 extends the input range to include `2'.

Programming Example

OUTPUT 714;"CALL:SETup:DTMode:CSWitched:TSLot 3"
! Sets the deferred circuit switched timeslot position to 3.

CALL:SETup:DTMode:FHOPping[:STATe]

Function

GSM TA

 This command is not applicable to the GSM Test Application.

GPRS TA

 This command is not applicable to the GPRS Test Application.

EGPRS TA

 This command is not applicable to the EGPRS Test Application.

GSM/GPRS LA

This command enables/queries the deferred DTM Frequency Hopping state for GPRS or EGPRS.

See DTM Frequency Hopping for more information.

EGPRS LA
Setting | Range: 0 | OFF | 1 | ON
Query | Range: 0 | 1
*RST setting | 0 |OFF
Requirements GSM/GPRS/ EGPRS LA

Revision: E.00.12 and above

Programming Example

OUTPUT 714;"CALL:SETup:DTMode:FHOPping ON"
! Enables deferred DTM Frequency Hopping.

CALL:SETup:DTMode:MCSCheme

Function

GSM TA

 This command is not applicable to the GSM Test Application.

GPRS TA

 This command is not applicable to the GPRS Test Application.
EGPRS TA | This command is not applicable to the EGPRS Test Application.

GSM/GPRS LA

 This command is not applicable to the GSM/GPRS Lab Application.

EGPRS LA

This command sets/queries the deferred DTM modulation coding scheme. Modulation coding schemes MCS1 through MCS4 use GMSK modulation, while MCS5 to MCS9 use 8PSK modulation.
Setting

Range: <downlink>, <uplink>

<downlink> can be set to one of the following values:

  • MCS1 | MCS2 | MCS3 | MCS4 | MCS5 | MCS6 | MCS7 | MCS8 | MCS9

<uplink> can be set to one of the following values:

  • MCS1 | MCS2 | MCS3 | MCS4 | MCS5 | MCS6 | MCS7 | MCS8 | MCS9
Query

Range: <downlink>, <uplink>

<downlink> returns one of the following values:

  • MCS1 | MCS2 | MCS3 | MCS4 | MCS5 | MCS6 | MCS7 | MCS8 | MCS9

<uplink> returns one of the following values:

  • MCS1 | MCS2 | MCS3 | MCS4 | MCS5 | MCS6 | MCS7 | MCS8 | MCS9
*RST setting | MCS4,MCS4
Requirements

GSM/GPRS/ EGPRS LA

 Revision: E.00.12 and above

Programming Example

OUTPUT 714;"CALL:SETup:DTMode:MCSCheme MCS1, MCS1"
! Sets the deferred DTM modulation coding Scheme for the downlink and uplink to MCS1.

CALL:SETup:DTMode:MS:GAMMa:BURSt<[1]|2|3|4>[:SELected]

CALL:SETup:DTMode:MS:GAMMa:BURSt<[1]|2|3|4>:(DCS|EGSM|GSM450|GSM480|GSM750|GSM850|PCS|PGSM|RGSM|TGSM810)

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA This command sets/queries the deferred DTM gamma value for any uplink burst in the selected band. The range of gamma 0 to 31 represents 0 to 62 dB in 2 dB steps. See MS Output Power for more information.
EGPRS LA

Setting

Range: 0 to 31

Resolution: 1

Query

Range: 0 to 31

Resolution: 1

*RST setting

 13
Requirements GSM/GPRS/ EGPRS LA

Revision: F.00.37 and above

Programming Example

OUTPUT 714;CALL:SETup:DTMode:MS:GAMMa:BURSt2 7
! Sets the deferred DTM gamma parameter of the 2rd uplink burst in the selected band to 7.

CALL:SETup:DTMode:MS:TXLevel[:SELected]:BURSt<[1]|2|3|4|5>

CALL:SETup:DTMode:MS:TXLevel:(DCS|EGSM|GSM450|GSM480|GSM750|GSM850|PCS|PGSM|RGSM|TGSM810):BURSt<[1]|2|3|4|5>

Function

GSM TA

 This command is not applicable to the GSM Test Application.

GPRS TA

 This command is not applicable to the GPRS Test Application.

EGPRS TA

 This command is not applicable to the EGPRS Test Application.

GSM/GPRS LA

This command sets/queries the deferred DTM packet switched MS transmit power level for any burst in the selected band.

Burst one is assumed if no burst is specified.

The optional [SELected] keyword in this command specifies that the channel being set/queried applies to the current DTM band.

See DTM MS Tx Levels for more information.

EGPRS LA

Setting

Range (all bands): 0 to 31

Resolution (all bands): 1

Query

Range (all bands): 0 to 31

Resolution (all bands): 1

*RST Setting

PGSM, EGSM, RGSM, GSM450, GSM480, GSM750, GSM850, and TGSM810 bands: 15,
DCS and PCS bands: 10
Requirements GSM/GPRS/ EGPRS LA

Revision: E.00.12 and above
Revision: F.00.27 adds Burst 5

Programming Example

OUTPUT 714;"CALL:SETup:DTMode:MS:TXLevel:BURSt 10"
! Sets the deferred DTM MS Transmit power level of burst one in the selected band to 10.

CALL:SETup:DTMode:MSLot:CONFig

Function

GSM TA

 This command is not applicable to the GSM Test Application.

GPRS TA

 This command is not applicable to the GPRS Test Application.

EGPRS TA

 This command is not applicable to the EGPRS Test Application.

GSM/GPRS LA

This command sets/queries the deferred DTM multislot configuration. See DTM Multislot Configuration for more information.

The actual timeslots used in each configuration are fixed as in the list below.

Multislot Configuration Downlink Timeslots Used Uplink Timeslots Used

D1U1 3 3
D1U2 3 3,4
D1U3 3 3,4,5
D1U4 3 3,4,5,6
D1U5 3 2,3,4,5,6
D1U6 2 1,2,3,4,5,6
D2U1 3,4 4
D2U2 3,4 3,4
D2U3 3,4 3,4,5
D2U4 3,4 3,4,5,6
D2U5 2,3 2,3,4,5,6
D3U1 3,4,5 4
D3U2 3,4,5 4,5
D3U3 3,4,5 4,5,6
D3U4 2,3,4 3,4,5,6
D4U1 3,4,5,6 5
D4U2 3,4,5,6 5,6
D4U3 2,3,4,5 4,5,6
D5U1 2,3,4,5,6 5
D5U2 2,3,4,5,6 5,6
D6U1 1,2,3,4,5,6 5
CUSTom You can position the timeslots flexibly. See Flexible Timeslot

EGPRS LA

Setting

 Range: D1U1 |D1U2 |D1U3 |D1U4 |D1U5 |D1U6 |D2U1 | D2U2 |D2U3 |D2U4 |D2U5 |D3U1 | D3U2 |D3U3 |D3U4 |D4U1 |D4U2 |D4U3 |D5U1 |D5U2 |D6U1

Query

 Range: D1U1 |D1U2 |D1U3 |D1U4 |D1U5 |D1U6 |D2U1 | D2U2 |D2U3 |D2U4 |D2U5 |D3U1 | D3U2 |D3U3 |D3U4 |D4U1 |D4U2 |D4U3 |D5U1 |D5U2 |D6U1

*RST Setting

 D2U2
Requirements GSM/GPRS/ EGPRS LA

Revision: E.00.12 and above

Revision: F.00.27 adds D1U5

Revision G.00.00 adds D1U6, D2U5, D3U4, D4U3, D5U2, D6U1

Programming Example

OUTPUT 714;"CALL:SETup:DTMode:MSLot:CONFig D2U2"
! Sets the deferred DTM multislot configuration to be 2 downlink and 2 uplink timeslots.

CALL:SETup:DTMode:MSLot:CONFig:CUSTom:TSLots

Function

GSM TA

 This command is not applicable to the GSM Test Application.

GPRS TA

 This command is not applicable to the GPRS Test Application.

EGPRS TA

 This command is not applicable to the EGPRS Test Application.

GSM/GPRS LA

This command sets/queries the customized DTM multislot configuration. See Flexible Timeslot for more information.

The command form accepts two string parameters with each contains a maximum of 8 characters. The first string represents the timeslot usage of TS0 to TS7 of the downlink timeslots and the second string represents the timeslot usage of TS0 to TS7 of the uplink timslots. Each timeslot of the uplink and downlink can be configured to one of the three values:

  • OFF: represented by `-'. ` `, `x', `X', or `0', `-' returned by query.
  • PDCH: represented by `p', `P', or `1', `P' returned by query.
  • TCH: represented by `t' or `T', `T' returned by query

If less than 8 characters in each string are specified in a parameter, the remaining higher numbered timeslots are assumed to be OFF.

See DTM Multislot Configuration for more information.

EGPRS LA

Setting

 Range: -, ,x,X,0 |p,P,1 |t,T

Query

 Range: - |P |T

*RST Setting

 --PT----,--PT----
Requirements GSM/GPRS/ EGPRS LA

Revision: G.00.00 and above

Programming Example

OUTPUT 714;"CALL:SETup:DTMode:MSLot:CONFig:CUSTom:TSLots --PT----, --PT----"
! Sets the DTM custom multislot configuration to be 2 downlink and 2 uplink timeslots. Timeslot 2 are
! configured as PDCH and Timeslot 3 are configured as TCH in both uplink and downlink.

CALL:SETup:DTMode:PZERo:LEVel

Function

GSM TA

 This command is not applicable to the GSM Test Application.

GPRS TA

 This command is not applicable to the GPRS Test Application.

EGPRS TA

 This command is not applicable to the EGPRS Test Application.

GSM/GPRS LA

This command sets/queries the deferred DTM power reduction reference level. (ETSI refers to this as P0)

See DTM Power Reduction Reference for more information.
EGPRS LA
Setting Range: 0 to 30 dB
Resolution: 2 dB
Query Range: 0 to 30 dB
Resolution: 2 dB
*RST setting 0 dB
Requirements GSM/GPRS/ EGPRS LA

Revision: E.00.12 and above

Programming Example

OUTPUT 714;"CALL:SETup:DTMode:PZERo:LEVel 30"
! Sets the deferred DTM power reduction reference level (p0) to 30 dB.

CALL:SETup:DTMode:TTI:[MODE]

Function

GSM TA

 This command is not applicable to the GSM Test Application.

GPRS TA

 This command is not applicable to the GPRS Test Application.

EGPRS TA

 This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA | This command is not applicable to the GSM/GPRS Lan Application.

EGPRS LA

 Sets/Queries the deferred TTI mode that the TBFs will be operated in the DTM operation. See TTI Mode Configuration
Setting

Range: BTTI | RTTI
Query | BTTI | RTTI
*RST setting | BTTI
Requirements GSM/GPRS/ EGPRS LA

Revision: G.00.00 and above

Programming Example

OUTPUT 714;"CALL:SETup:DTMode:TTI:MODE BTTI"
! Sets the deferred TTI mode to BTTI in the DTM operation.

CALL:SETup:DTMode:USFLag[:ASSigned]

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA This command is not applicable to the GPRS Test Application.

EGPRS TA

 This command is not applicable to the EGPRS Test Application.

GSM/GPRS LA

This command sets/queries the deferred DTM uplink state flag (USF). The USF allows multiple mobile stations to share over-the-air resources.

See DTM Uplink State Flag for more information.

EGPRS LA

Setting

Range: 0 to 7

Resolution: 1

Query

Range: 0 to 7

Resolution: 1

*RST setting

 0
Requirements GSM/GPRS/ EGPRS LA

Revision: E.00.12 and above

Programming Example:

OUTPUT 714;"CALL:SETup:DTMode:USFLag 2"
! Sets the deferred DTM USF to 2.

CALL:SETup:(PDTCH|PDTChannel)[:ARFCn][:SELected]

CALL:SETup:(PDTCH|PDTChannel)[:ARFCn]:(DCS|EGSM|GSM450|GSM480|GSM750|GSM850|PCS|PGSM|RGSM|TGSM810)

Function

GSM TA

 This command is not applicable to GSM.

GPRS TA

This command sets/queries the deferred PDTCH ARFCN for the band specified using the command CALL:SETup:(PDTCH|PDTChannel):BAND . Deferred parameters are applied when a channel change is executed using the CALL:HANDover command (see CALL:HANDover|HANDoff[:IMMediate] ).

The ARFCN range varies with the selected PDTCH band. The correspondence between ARFCN and frequency differs for each band and that a single ARFCN specifies a separate frequency for uplink and downlink.

The PDTCH ARFCN selects the ARFCN for all the PDTCHs which you can configure.

The PDTCH ARFCN is a frequency banded parameter. Refer to Frequency Banded Parameters for a detailed description of the implications of being a banded parameter.

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

Range:

  • DCS band, channels 512 to 885
  • EGSM band, channels 0 to 124 and 975 to 1023
  • GSM450 band, channels 259 to 293
  • GSM480 band, channels 306 to 340
  • GSM750 band, channels 438 to 511
  • GSM850 band, channels 128 to 251
  • PCS band, channels 512 to 810
  • PGSM band, channels 1 to 124
  • RGSM band, channels 0 to 124 and 955 to 1023
  • TGSM810 band, channels 350 to 425

Resolution: 1
Query

Range:

  • DCS band, channels 512 to 885
  • EGSM band, channels 0 to 124 and 975 to 1023
  • GSM450 band, channels 259 to 293
  • GSM480 band, channels 306 to 340
  • GSM750 band, channels 438 to 511
  • GSM850 band, channels 128 to 251
  • PCS band, channels 512 to 810
  • PGSM band, channels 1 to 124
  • RGSM band, channels 0 to 124 and 955 to 1023
  • TGSM810 band, channels 350 to 425

Resolution: 1
*RST setting

PGSM, EGSM and RGSM bands: 30, DCS and PCS bands: 698, GSM450 band: 280, GSM480 band: 320, GSM750 band: 460, GSM850 band: 160, TGSM810 band: 400

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.01 and above

A.06 adds the TGSM810 band.
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

D.03 adds the TGSM810 band.

Programming Example

OUTPUT 714;"CALL:SETup:PDTCh 515"
! Sets the ARFCN to 515 if it is appropriate in the current band.

CALL:SETup:(PDTCH|PDTChannel):BAND

Function

GSM TA

 This command is not applicable to GSM.

GPRS TA

This command sets/queries the deferred GSM band. Deferred parameters are applied when a channel change is executed using the CALL:HANDover command (see CALL:HANDover|HANDoff[:IMMediate] ).

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

Range: DCS | EGSM | GSM450 | GSM480 | GSM750 | GSM850 |PCS |PGSM |RGSM | TGSM810
Query

Range: DCS | EGSM | GSM450 | GSM480 | GSM750 | GSM850 |PCS |PGSM |RGSM| TGSM810
*RST setting PGSM

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.01 and above

A.06 adds the TGSM810 band.
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

D.03 adds the TGSM810 band.

Programming Example

OUTPUT 714;"CALL:SETup:PDTCH:BAND DCS"
! Sets the deferred band to DCS

CALL:SETup:(PDTCH|PDTChannel):CSCHeme

Function

GSM TA

 This command is not applicable to GSM TA.

EGPRS TA

This command is not applicable to EGPRS TA.

GPRS TA

This command sets/queries the deferred PDTCH coding scheme for both GPRS uplink and downlink. Deferred parameters are applied when a channel change is executed using the CALL:HANDover command (see CALL:HANDover|HANDoff[:IMMediate] ).

When a Coding Scheme change is executed, all measurements and BLER reports are stopped before the change is made, and re-started after the change has taken effect.

GSM/GPRS LA

EGPRS LA
Setting | Range: CS1 | CS2| CS3 | CS4
Query | Range: CS1 | CS2 | CS3 | CS4
*RST setting | CS4

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:SETup:PDTCH:CSCHeme CS4"
! Sets the PDTCH deferred coding scheme to CS4

CALL:SETup:(PDTCH|PDTChannel):CSCHeme:DOWNlink

Function

GSM/GPRS TA

 This command is not applicable to GSM/GPRS Test Application.

EGPRS TA

This command is not applicable to GPRS Test Application.

EGPRS LA

This command is not applicable to EGPRS Lab Application.

GSM/GPRS LA

This command sets/queries the deferred downlink PDTCH coding scheme. Deferred parameters are applied when a channel change is executed using the CALL:HANDover command (see CALL:HANDover|HANDoff[:IMMediate] ).

When a Coding Scheme change is executed, all measurements and BLER reports are stopped before the change is made, and re-started after the change has taken effect.

When ETSI B connection is used, the coding scheme on the downlink must be the same as the uplink.
Setting | Range: CS1 | CS2| CS3 | CS4
Query | Range: CS1 | CS2 | CS3 | CS4
*RST setting | CS4

Requirements

 GSM/GPRS LA

Revision: G.00 .xx and above

Programming Example

OUTPUT 714;"CALL:SETup:PDTCH:CSCHeme:DOWNlink CS4"
! Sets the downlink PDTCH deferred coding scheme to CS4

CALL:SETup:(PDTCH|PDTChannel):CSCHeme:UPLink

Function

GSM/GPRS TA

 This command is not applicable to GSM/GPRS Test Application.

EGPRS TA

This command is not applicable to GPRS Test Application.

EGPRS LA

This command is not applicable to EGPRS Lab Application.

GSM/GPRS LA

This command sets/queries the deferred uplink PDTCH coding scheme. Deferred parameters are applied when a channel change is executed using the CALL:HANDover command (see CALL:HANDover|HANDoff[:IMMediate] ).

When a Coding Scheme change is executed, all measurements and BLER reports are stopped before the change is made, and re-started after the change has taken effect.
Setting | Range: CS1 | CS2| CS3 | CS4
Query | Range: CS1 | CS2 | CS3 | CS4
*RST setting | CS4

Requirements

 GSM/GPRS LA

Revision: G.00 .xx and above

Programming Example

OUTPUT 714;"CALL:SETup:PDTCH:CSCHeme:UPLink CS4"
! Sets the uplink PDTCH deferred coding scheme to CS4

CALL:SETup:(PDTChannel|PDTCH):DLDCarrier[:STATe]

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA | This command is not applicable to the GSM/GPRS Lab Application.
EGPRS LA | This command sets/queries the deferred DLDC state for PS connections. See Downlink Dual Carrier for more information.

Setting

Range: 0 | OFF | 1 | ON

Query

Range: 0 | 1

*RST setting

0 | OFF
Requirements EGPRS LA

Revision: G.00.00 and above

Programming Example

OUTPUT 714;"CALL:SETup:PDTCH:DLDCarrier ON" ! Turns the DLDC On.

OUTPUT 714;"CALL:SETup:PDTCH:DLDCarrier?" ! Returns "On" if the DLDC has been turn on.

CALL:SETup:(PDTCH|PDTChannel):MCSCheme

Function

GSM TA

 This command is not applicable to the GSM TA.

GPRS TA

 This command is not applicable to the GPRS TA.

GSM/GPRS LA

 This command is not applicable to the GSM/GPRS LA.

EGPRS TA

This command sets/queries the deferred modulation coding scheme used for transmission on the downlink and uplink in Active Cell operating mode. Deferred parameters are applied when a channel change is executed using the CALL:HANDover command (see CALL:HANDover|HANDoff[:IMMediate] ).

EGPRS LA
Setting

Range: <downlink>, <uplink>

<downlink> can be set to one of the following values:

  • MCS1 | MCS2 | MCS3 | MCS4 | MCS5 | MCS6 | MCS7 | MCS8 | MCS9

<uplink> can be set to one of the following values:

  • MCS1 | MCS2 | MCS3 | MCS4 | MCS5 | MCS6 | MCS7 | MCS8 | MCS9
Query

Range: <downlink>, <uplink>

<downlink> returns one of the following values:

  • MCS1 | MCS2 | MCS3 | MCS4 | MCS5 | MCS6 | MCS7 | MCS8 | MCS9

<uplink> returns one of the following values:

  • MCS1 | MCS2 | MCS3 | MCS4 | MCS5 | MCS6 | MCS7 | MCS8 | MCS9
*RST setting MCS4,MCS4

Requirements

GSM/GPRS/
EGPRS LA

 Revision C.01 and above

Programming Example

OUTPUT 714;"CALL:SETup:PDTCH:MCSCheme MCS2, MCS2"
! Sets the PDTCH deferred modulation coding scheme for the downlink and uplink to MCS2.

CALL:SETup:(PDTCH|PDTChannel):MS:GAMMa:BURSt<[1]|2|3|4|5>[:SELected]

CALL:SETup:(PDTCH|PDTChannel):MS:GAMMa:BURSt<[1]|2|3|4|5>:(DCS|EGSM|GSM450|GSM480|GSM750|GSM850|PCS|PGSM|RGSM|TGSM810)

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA This command sets/queries the deferred gamma value for any uplink burst in the selected band. The range of gamma 0 to 31 represents 0 to 62 dB in 2 dB steps. See MS Output Power for more information.
EGPRS LA

Setting

Range: 0 to 31

Resolution: 1

Query

Range: 0 to 31

Resolution: 1

*RST setting

 13
Requirements GSM/GPRS/ EGPRS LA

Revision: F.00.37 and above

Programming Example

OUTPUT 714;CALL:SETup:PDTCH:MS:GAMMa:BURSt3 11
! Sets the deferred gamma parameter of the 3rd uplink burst in the selected band to 11.

CALL:SETup:(PDTCH|PDTChannel):MS:TXLevel[:SELected]:BURSt<[1]|2|3|4|5>

CALL:SETup:(PDTCH|PDTChannel):MS:TXLevel:(DCS|EGSM|GSM450|GSM480|GSM750|GSM850|PCS|PGSM|RGSM|TGSM810) :BURSt[1]|2|3|4|5

Function

GSM TA

 This command is not applicable to GSM.

GPRS TA

This command sets/queries the deferred mobile station transmit power level for the deferred PDTCH band. The transmit power is set individually for each uplink burst. Depending on the "Multislot Configuration" setting, there is one to four uplink bursts (burst 1, burst 2, burst 3, burst 4) - burst 1 is in the first uplink slot specified, not timeslot 1, burst 2 is in the second slot specified, not timeslot 2, etc. Deferred parameters are applied when a channel change is executed using the CALL:HANDover command (see CALL:HANDover|HANDoff[:IMMediate] ).

The immediate setting for the mobile station transmit power level for a PDTCH band is CALL:(PDTCH|PDTChannel):MS:TXLevel[:SELected]:BURSt<[1]|2|3|4|5> .

The mobile station transmit power level is a frequency banded parameter. Refer to Frequency Banded Parameters for a detailed description of the implications of being a banded parameter.

The mobile station transmit power level is a bursted parameter. Refer to Bursted Parameters for a detailed description of being a bursted parameter.

EGPRS TA

GSM/GPRS LA
EGPRS LA
Setting

Range: 0 to 31

Resolution: 1
Query

Range: 0 to 31

Resolution: 1
*RST setting

PGSM, EGSM RGSM, GSM450, GSM480, GSM750, GSM850, TGSM810 bands:15,
DCS and PCS bands: 10

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.01 and above

Revision A.04 adds Burst 3 and Burst 4.

Revision A.05 adds the TGSM810 band.

Revision A.09 adds Burst 5.

GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Revision D.01 adds Burst 3 and Burst 4.

Revision D.03 adds the TGSM810 band.

Revision E.00.05 adds Burst 5.

Programming Example

OUTPUT 714;"CALL:SETup:PDTCH:MS:TXLevel:BURSt2 13"
! Sets the deferred mobile station TX level for the 2nd uplink burst in the currently selected band.

CALL:SETup:(PDTCH|PDTChannel):MSLot:CONFig

Function

GSM TA

This command is not applicable to GSM.

GPRS TA

This command sets/queries the deferred number of downlink and uplink PDTCHs. These deferred PDTCHs are only applied when the Execute Channel Change action is initiated using CALL:HANDover|HANDoff[:IMMediate] .

The effect this command has on the number of uplink and downlink timeslots depends on the Data Connection Type:

  • Type A - The multislot configuration command only affects the number of uplink timeslots, therefore configurations D1U1, D2U1, D3U1, D4U1, and D5U1 will appear similar.
  • Type B - The multislot configuration command constrains the number of uplink timeslots to be less than or equal to the number of downlink timeslots.
  • BLER - The multislot configuration command only affects the number of downlink timeslots, therefore D2U2 and D2U1 will appear similar. Multislot configurations with more uplinks than downlinks are not selectable.

The actual timeslots used in each configuration are fixed as follows:

Multislot Configuration Downlink Timeslots Used Uplink Timeslots Used

D1U1 3 3
D1U2 3 3,4
D1U3 3 3,4,5
D1U4 3 3,4,5,6
D1U5 3 2,3,4,5,6
D1U6 2 1,2,3,4,5,6
D2U1 3,4 4
D2U2 3,4 3,4
D2U3 3,4 3,4,5
D2U4 3,4 3,4,5,6
D2U5 2,3 2,3,4,5,6
D3U1 3,4,5 4
D3U2 3,4,5 4,5
D3U3 3,4,5 4,5,6
D3U4 2,3,4 3,4,5,6
D4U1 3,4,5,6 5
D4U2 3,4,5,6 5,6
D4U3 2,3,4,5 4,5,6
D5U1 2,3,4,5,6 5
D5U2 2,3,4,5,6 5,6
D6U1 1,2,3,4,5,6 5
CUSTom You can position the timeslots flexibly. See Flexible Timeslot

When the Multislot Configuration is set to D1U1, D2U1, D3U1, D4U1 or D5U1 the measurement burst is set to 1.

When a multislot configuration change is executed, all measurements are stopped before the change is made, and restarted after the change has taken effect.

NOTE
Some features may be inaccessible without a hardware upgrade to your test set. For more details, please see

http://www.agilent.com/find/8960upgrade

EGPRS TA

GSM/GPRS LA

EGPRS LA

Setting

Range: D1U1 |D1U2 |D1U3 |D1U4 |D1U5 |D1U6 |D2U1 | D2U2 |D2U3 |D2U4 |D2U5 |D3U1 | D3U2 |D3U3 |D3U4 |D4U1 |D4U2 |D4U3 |D5U1 |D5U2 |D6U1

"D<n>U<m>" corresponds to "Downlink<n>Uplink<m>", where <n> indicates the number of downlink timeslots and <m> represents the number of uplink timeslots.

Query

 Range: D1U1 |D1U2 |D1U3 |D1U4 |D1U5 |D1U6 |D2U1 | D2U2 |D2U3 |D2U4 |D2U5 |D3U1 | D3U2 |D3U3 |D3U4 |D4U1 |D4U2 |D4U3 |D5U1 |D5U2 |D6U1

*RST Setting

 D2U1

Requirements

 GPRS/EGPRS TA

Revision: A.01 and above

Revision A.04 adds D1U2, D1U3, D1U4, and D2U3

Revision A.09 adds D1U5, D2U4, D3U3, D4U2, D5U1
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Revision D01 adds D1U2, D1U3, D1U4, and D2U3

Revision E.00.08 adds D2U4, D3U3, D4U2, and D5U1

Revision F.00.27 adds D1U5

Revision G.00.00 adds D1U6, D2U5, D3U4, D4U3, D5U2, D6U1

Programming Example

OUTPUT 714;"CALL:SETup:PDTCH:MSLot:CONFig D2U2"
! Sets the number of downlink timeslots to 2 and uplink timeslots to 2.

CALL:SETup:(PDTCH|PDTChannel):MSLot:CONFig:CUSTom:TSLots

Function

GSM TA

 This command is not applicable to the GSM Test Application.

GPRS TA

 This command is not applicable to the GPRS Test Application.

EGPRS TA

 This command is not applicable to the EGPRS Test Application.

GSM/GPRS LA

This command sets/queries the customized DTM multislot configuration. See Flexible Timeslot for more information.

The command form accepts two string parameters with each contains a maximum of 8 characters. The first string represents the timeslot usage of TS0 to TS7 of the downlink timeslots and the second string represents the timeslot usage of TS0 to TS7 of the uplink timslots. Each timeslot of the uplink and downlink can be configured to one of the three values:

  • OFF: represented by `-'. ` `, `x', `X', or `0', `-' returned by query.
  • PDCH: represented by `p', `P', or `1', `P' returned by query.
  • TCH: represented by `t' or `T', `T' returned by query

If less than 8 characters in each string are specified in a parameter, the remaining higher numbered timeslots are assumed to be OFF.

See DTM Multislot Configuration for more information.

EGPRS LA

Setting

 Range: -, ,x,X,0 |p,P,1 |t,T

Query

 Range: - |P |T

*RST Setting

 --PT----,--PT----
Requirements GSM/GPRS/ EGPRS LA

Revision: G.00.00 and above

Programming Example

OUTPUT 714;"CALL:SETup:PDTCH:MSLot:CONFig:CUSTom:TSLots --PT----, --PT----"
! Sets the DTM custom multislot configuration to be 2 downlink and 2 uplink timeslots. Timeslot 2 are
! configured as PDCH and Timeslot 3 are configured as TCH in both uplink and downlink.

CALL:SETup:(PDTCH|PDTChannel):PZERo:LEVel

Function

GSM TA

 This command is not applicable to GSM.

GPRS TA

This command sets/queries the deferred Power Reduction reference level to be used for connections. Deferred parameters are applied when the Execute Channel Change action is initiated using CALL:HANDover|HANDoff[:IMMediate] .

When Data Connection Type "ETSI Type A" is used, there is no downlink PDTCH and therefore changing this parameter has no effect other than remembering the new value until the Data Connection Type "ETSI Type B" or "BLER" is used.

EGPRS TA
GSM/GPRS LA
EGPRS LA
Setting Range: 0 to 30 dB
Resolution: 2 dB
Query Range: 0 to 30 dB
Resolution: 2 dB
*RST setting 0 dB

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:SETup:PDTCH:PZERo:LEVel 15 dB"
! Sets the deferred Power Reduction reference level to 15 dB.

CALL:SETup:(PDTCH|PDTChannel):TTI:[MODE]

Function

GSM TA

 This command is not applicable to the GSM Test Application.

GPRS TA

 This command is not applicable to the GPRS Test Application.

EGPRS TA

 This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA | This command is not applicable to the GSM/GPRS Lan Application.

EGPRS LA

 Sets/Queries the deferred TTI mode that the TBFs will be operated. See TTI Mode Configuration
Setting

Range: BTTI | RTTI
Query | BTTI | RTTI
*RST setting | BTTI
Requirements GSM/GPRS/ EGPRS LA

Revision: G.00.00 and above

Programming Example

OUTPUT 714;"CALL:SETup:PDTCH:TTI:MODE BTTI"
! Sets the deferred TTI mode to BTTI.

CALL:SETup:(PDTCH|PDTChannel):USFLag

Function

GSM

This command sets/queries the uplink state flag (USF) value to be used upon performing a handover. The USF allows multiple mobiles to share over-the-ari resources. The USF allows you to verify that your device under test only responds when required.

GPRS TA

EGPRS TA

GSM/GPRS LA
EGPRS LA

Setting

Range: 0 to 7

Resolution: 1

Query

Range: 0 to 7

Resolution: 1

*RST Setting

 0

Requirements

GSM/GPRS/
EGPRS LA

 Revision C.01 and above

GSM/GPRS/
EGPRS TA

 Revision A.09 and above

Programming Example

OUTPUT 714;"CALL:SETup:PDTCH:USFLAG 5"
! Sets the handoff uplink state flag to 5.

CALL:SETup:(PDTC2|PDTCH2|PDTChannel2):ARFCn[:SELected]

CALL:SETup:(PDTC2|PDTCH2|PDTChannel2):ARFCn:(DCS|EGSM|GSM450|GSM480|GSM750|GSM850|PCS|PGSM|RGSM|TGSM810)

Function

GSM TA

 This command is not applicable to GSM TA.

GPRS TA

 This command is not applicable to GPRS TA.

EGPRS TA

 This command is not applicable to EGPRS TA.

GSM/GPRS LA

 This command is not applicable to GSM/GPRS LA.

EGPRS LA

This command sets/queries the deferred PDTCH2 ARFCN for the band specified using the command CALL:SETup:(PDTCH|PDTChannel):BAND . Deferred parameters are applied when a channel change is executed using the CALL:HANDover command (see CALL:HANDover|HANDoff[:IMMediate] ).

The ARFCN range varies with the selected PDTCH2 band. The correspondence between ARFCN and frequency differs for each band and that a single ARFCN2 specifies a separate frequency for uplink and downlink.

The PDTCH2 ARFCN and PDTCH1 ARFCN can NOT be the same, refer to Constrains on PDTCH Configuration for a detailed description.

The PDTCH2 ARFCN is a frequency banded parameter. Refer to Frequency Banded Parameters for a detailed description of the implications of being a banded parameter.
Setting

Range:

  • DCS band, channels 512 to 885
  • EGSM band, channels 0 to 124 and 975 to 1023
  • GSM450 band, channels 259 to 293
  • GSM480 band, channels 306 to 340
  • GSM750 band, channels 438 to 511
  • GSM850 band, channels 128 to 251
  • PCS band, channels 512 to 810
  • PGSM band, channels 1 to 124
  • RGSM band, channels 0 to 124 and 955 to 1023
  • TGSM810 band, channels 350 to 425

Resolution: 1
Query

Range:

  • DCS band, channels 512 to 885
  • EGSM band, channels 0 to 124 and 975 to 1023
  • GSM450 band, channels 259 to 293
  • GSM480 band, channels 306 to 340
  • GSM750 band, channels 438 to 511
  • GSM850 band, channels 128 to 251
  • PCS band, channels 512 to 810
  • PGSM band, channels 1 to 124
  • RGSM band, channels 0 to 124 and 955 to 1023
  • TGSM810 band, channels 350 to 425

Resolution: 1
*RST setting

PGSM, EGSM and RGSM bands: 20, DCS and PCS bands: 512, GSM450 band: 270, GSM480 band: 310, GSM750 band: 450, GSM850 band: 150, TGSM810 band: 380

Requirements

 GSM/GPRS/ EGPRS LA

Revision: G.00.00 and above.

Programming Example

OUTPUT 714;"CALL:SETup:PDTC2:ARFCN 515"
! Sets the ARFCN to 515 if it is appropriate in the current band.

CALL:SETup:(PDTC2|PDTCH2|PDTChannel2):FHOPping[:STATe]

Function

GSM TA

 This command is not applicable to the GSM Test Application.

GPRS TA

 This command is not applicable to the GPRS Test Application.

EGPRS TA

 This command is not applicable to the EGPRS Test Application.

GSM/GPRS LA

 This command is not applicable to the GSM/GPRS Lab Application.

EGPRS LA

This command enables/queries the state of Frequency Hopping for PDTCH2.
Setting | Range: 0 | OFF | 1 | ON
Query | Range: 0 | 1
*RST setting | 0 |OFF
Requirements EGPRS LA

Revision: G.00.00 and above

Programming Example

OUTPUT 714;"CALL:SET:PDTC2:FHOPping ON"
! Enables Frequency Hopping.

CALL:SETup:(PDTC2|PDTCH2|PDTChannel2):MSLot:CONFig

Function

GSM TA

 This command is not applicable to the GSM Test Application.

GPRS TA

This command is not applicable to the GPRS Test Application.

EGPRS TA

This command is not applicable to the EGPRS Test Application.

GSM/GPRS LA

This command is not applicable to theGSM/ GPRS Lab Application.

EGPRS LA

This command sets/queries the deferred number of downlink and uplink PDTCH2s. These deferred PDTCH2s are only applied when the Execute Channel Change action is initiated using CALL:HANDover|HANDoff[:IMMediate] .

The effect this command has on the number of uplink and downlink timeslots depends on the Data Connection Type:

  • Type A - The multislot configuration command only affects the number of uplink timeslots, therefore configurations D1U1, D2U1, D3U1, D4U1, and D5U1 will appear similar.
  • Type B - The multislot configuration command constrains the number of uplink timeslots to be less than or equal to the number of downlink timeslots.
  • BLER - The multislot configuration command only affects the number of downlink timeslots, therefore D2U2 and D2U1 will appear similar. Multislot configurations with more uplinks than downlinks are not selectable.

The actual timeslots used in each configuration are fixed as follows:

Multislot Configuration Downlink Timeslots Used Uplink Timeslots Used

D1U1 3 3
D1U2 3 3,4
D1U3 3 3,4,5
D1U4 3 3,4,5,6
D1U5 3 2,3,4,5,6
D1U6 2 1,2,3,4,5,6
D2U1 3,4 4
D2U2 3,4 3,4
D2U3 3,4 3,4,5
D2U4 3,4 3,4,5,6
D2U5 2,3 2,3,4,5,6
D3U1 3,4,5 4
D3U2 3,4,5 4,5
D3U3 3,4,5 4,5,6
D3U4 2,3,4 3,4,5,6
D4U1 3,4,5,6 5
D4U2 3,4,5,6 5,6
D4U3 2,3,4,5 4,5,6
D5U1 2,3,4,5,6 5
D5U2 2,3,4,5,6 5,6
D6U1 1,2,3,4,5,6 5
CUSTom You can position the timeslots flexibly. See Flexible Timeslot

When the Multislot Configuration is set to D1U1, D2U1, D3U1, D4U1 or D5U1 the measurement burst is set to 1.

When a multislot configuration change is executed, all measurements are stopped before the change is made, and restarted after the change has taken effect.

NOTE
Some features may be inaccessible without a hardware upgrade to your test set. For more details, please see

http://www.agilent.com/find/8960upgrade

Setting

Query

*RST Setting
Requirements GSM/GPRS/ EGPRS LA

Revision G.00.00 and above

Programming Example

OUTPUT 714;"CALL:SET:(PDTC2|PDTCH2|PDTChannel2):MSLot:CONFig D2U1"
! Sets the multislot configuration to be 2 downlink PDTCHs and 1 uplink PDTCH.

CALL:SETup:(PDTC2|PDTCH2|PDTChannel2):MSLot:CONFig:CUSTom:TSLots

Function

GSM TA

 This command is not applicable to the GSM Test Application.

GPRS TA

 This command is not applicable to the GPRS Test Application.

EGPRS TA

 This command is not applicable to the EGPRS Test Application.

GSM/GPRS LA

 This command is not applicable to the GSM/EGPRS Lab Applicatio

EGPRS LA

This command sets/queries the customized multislot configuration. See Flexible Timeslot for more information.

The command form accepts two string parameters with each contains a maximum of 8 characters. The first string represents the timeslot usage of TS0 to TS7 of the downlink timeslots and the second string represents the timeslot usage of TS0 to TS7 of the uplink timslots. Each timeslot of the uplink and downlink can be configured to one of the three values:

  • OFF: represented by `-'. ` `, `x', `X', or `0', `-' returned by query.
  • PDCH: represented by `p', `P', or `1', `P' returned by query.
  • TCH: represented by `t' or `T', `T' returned by query

If less than 8 characters in each string are specified in a parameter, the remaining higher numbered timeslots are assumed to be OFF.

Setting

 Range: -, ,x,X,0 |p,P,1

Query

 Range: - |P

*RST Setting

 --PP----,--P-----
Requirements GSM/GPRS/ EGPRS LA

Revision: G.00.00 and above

Programming Example

OUTPUT 714;"CALL:SET:(PDTC2|PDTCH2|PDTChannel2):MSLot:CONFig:CUSTom:TSLots --PP----,--P-----"
! Sets the custom multislot configuration to be 2 downlink PDTCHs and 1 uplink PDTCH. Timeslot 2 and 3
! are configured to PDCH in the downlink and Timeslot 2 is configured to PDCH in the uplink.

CALL:SETup:TCHannel[:ARFCn][:SELected]

CALL:SETup:TCHannel[:ARFCn]:(DCS|EGSM|GSM450|GSM480|GSM750|GSM850|PCS|PGSM|RGSM|TGSM810)

Function

GSM TA

Sets/queries the channel number of downlink and uplink TCH for the band already selected. See Configuring the Traffic Channel (TCH) Parameters .

TCH ARFCN may be set and queried when the CALL:STATUS:STATE is idle or connected, see CALL:STATus[:STATe][:VOICe]? .

GSM/GPRS LA

EGPRS LA

GPRS TA

 This command is not applicable to GPRS.

EGPRS TA

 This command is not applicable to the EGPRS test application.

Setting

Range:

  • DCS band, channels 512 to 885 (default: 698)
  • EGSM band, channels 0 to 124 and 975 to 1023 (default: 30)
  • GSM450 band, channels 259 to 293 (default: 280)
  • GSM480 band, channels 306 to 340 (default: 320)
  • GSM750 band, channels 438 to 511 (default: 460)
  • GSM850 band, channels 128 to 251 (default: 160)
  • PCS band, channels 512 to 810 (default: 698)
  • PGSM band, channels 1 to 124 (default: 30)
  • RGSM band, channels 0 to 124 and 955 to 1023 (default: 30)
  • TGSM810 band, channels 350 to 425

Resolution: 1

Query

Range:

  • DCS band, channels 512 to 885
  • EGSM band, channels 0 to 124 and 975 to 1023
  • GSM450 band, channels 259 to 293
  • GSM480 band, channels 306 to 340
  • GSM750 band, channels 438 to 511
  • GSM850 band, channels 128 to 251
  • PCS band, channels 512 to 810
  • PGSM band, channels 1 to 124
  • RGSM band, channels 0 to 124 and 955 to 1023
  • TGSM810 band, channels 350 to 425

Resolution: 1

*RST Setting

PGSM, EGSM and RGSM bands: 30, DCS and PCS bands: 698, GSM450: 280, GSM480: 320, GSM750: 460, GSM850: 160, TGSM810: 400.

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.01 and above

A.06 adds the TGSM810 band.
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

D.03 adds the TGSM810 band.

Programming Example

OUTPUT 714;"CALL:SETup:TCH 515"
! Sets the ARFCN to 515 if it is appropriate in the current band.

CALL:SETup:TCHannel:BAND

Function

GSM TA

Sets/queries which GSM band the BS Emulator should use for the TCH.

The test set may be queried for the current TCH band when the CALL:STATUS:STATE is idle or connected, see CALL:STATus[:STATe][:VOICe]? .

The test set uses this command to perform a channel assignment, see How the Test Set Performs a Dualband Handover when the MS will support the band and the CALL:STATUS:STATE is CONNected.

GSM/GPRS LA

EGPRS LA

GPRS TA

 This command is not applicable to GPRS.

EGPRS TA

 This command is not applicable to the EGPRS test application.

Setting

Range: DCS | EGSM | GSM450 | GSM480 | GSM750 | GSM850 |PCS |PGSM |RGSM| TGSM810

Query

Range: DCS | EGSM | GSM450 | GSM480 | GSM750 | GSM850 |PCS |PGSM |RGSM| TGSM810

*RST Setting

PGSM

Related Topic

See Traffic Band Parameter .

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.01 and above

A.06 adds the TGSM810 band.
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

D.03 adds the TGSM810 band.

Programming Example

OUTPUT 714;"CALL:SETup:TCH:BAND DCS"
! Sets the deferred band to DCS

CALL:SETup:TCHannel:CMODe[:VALue]

Function

GSM TA

THIS COMMAND IS OBSOLETE.

Please use CALL:SETup:TCHannel:CMODe:LSPeech:CHANnel instead.

This command sets/queries which channel mode the mobile station should use for speech data. This setting is either full rate speech (FRSPeech), enhanced full rate speech (EFRSpeech) or half rate speech (HRSPeech). See Programming a Channel Mode Change .

GSM/GPRS LA

EGPRS LA

GPRS TA

 This command is not applicable to GPRS.

EGPRS TA

 This command is not applicable to the EGPRS test application.

Setting

Range: FRSPeech | EFRSpeech | HRSPeech

Query

Range: FRSPeech | EFRSpeech | HRSPeech

*RST Setting

 FRSPeech

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:SETup:TCH:CMODe EFRSpeech"
! Sets the TCH coding mode to EFRSpeech

CALL:SETup:TCHannel:CMODe:HRSPeech:SCHannel

Function

GSM TA

 Sets/queries the half rate sub channel for half rate speech.

GSM/GPRS LA

EGPRS LA

GPRS TA

 This command is not applicable to GPRS.

EGPRS TA

 This command is not applicable to the EGPRS test application.

Setting

Range: 0 | 1

Query

Range: 0 | 1

*RST Setting

 0

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:SETup:TCH:CMODe:HRSPeech:SCH 1"
! Sets TCH half rate speech sub channel

CALL:SETup:TCHannel:CMODe:LSPeech:CHANnel

Function

GSM/GPRS LA

 Sets/queries the logical speech channel.

EGPRS LA

GSM TA

GPRS TA

EGPRS TA

 This command is not applicable the test applications.

Setting

Range: FS|EFS|HS|AFS|AHS|WFS

Query

Range: FS|EFS|HS|AFS|AHS|WFS

*RST Setting

 FS
Requirements GSM/GPRS/ EGPRS LA

Revision: D.01 and above

Revision: F.00.13 add WFS

Programming Example

OUTPUT 714;"CALL:SETup:TCH:CMODe:LSPeech:CHANnel EFS"
! Sets the logical speech channel to Enhanced Full-Rate Speech, EFS.

CALL:SETup:TCHannel:MS:TXLevel[:SELected]

CALL:SETup:TCHannel:MS:TXLevel:(DCS|EGSM|GSM450|GSM480|GSM750|GSM850|PCS|PGSM|RGSM|TGSM810)

Function

GSM TA

This command selects the mobile station uplink power control level for the band already selected. See Frequency Banded Parameters .

GSM/GPRS LA

EGPRS LA

GPRS TA

This command is not applicable to GPRS.

EGPRS TA

 This command is not applicable to the EGPRS test application.

Setting

Range: 0 to 31

Resolution: 1

Query

Range: 0 to 31

Resolution: 1

*RST Setting

The default TX Level depends on the band (the default band is PGSM):

  • DCS band, TX Level 10
  • EGSM band, TX Level 15
  • GSM450 band, TX Level 15
  • GSM480 band, TX Level 15
  • GSM750 band, TX Level 15
  • GSM850 band, TX Level 15
  • PCS band, TX Level 10
  • PGSM band, TX Level 15
  • RGSM band, TX Level 15
  • TGSM810 band, TX Level 15

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.01 and above

A.06 adds the TGSM810 band.
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

D.03 adds the TGSM810 band.

Programming Example

OUTPUT 714;"CALL:SETup:TCH:MS:TXLevel 19"
! Sets the deferred mobile station TX level for the currently selected band.

CALL:SETup:TCHannel:TSLot

Function

GSM TA

Sets the Timeslot number used for downlink and uplink Traffic Channel.

See Configuring the Traffic Channel (TCH) Parameters .

GSM/GPRS LA

EGPRS LA

GPRS TA

This command is not applicable to GPRS.

EGPRS TA

 This command is not applicable to the EGPRS test application.

Setting

Range: 0 | 1 | 2 | 3 | 4 | 5 | 6 | 7

Resolution: 1

Query

Range: 0 | 1 | 2 | 3 | 4 | 5 | 6 | 7

Resolution: 1

*RST Setting

4
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above

Revision A.06 adds timeslot 0
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Revision E.01 adds timeslot 0

Programming Example

OUTPUT 714;"CALL:SETup:TCH:TSLot 2"
! Sets the number of downlink timeslots to 2 and uplink timeslots to 2.


CALL:SIGNaling

CALL:SIGNaling

GPIB Command Conventions

  • CALL:SIGNaling:MS:EPControl:MODE[:STATe]
  • CALL:SIGNaling:MS:EPControl:CONTinuous[:STATe]
  • CALL:SIGNaling:MS:EPControl:STEP:MAXimum
  • CALL:SIGNaling:MS:TXLevel:FACCH

CALL:SIGNaling:MS:EPControl:MODE[:STATe]

Function

 GSM TA

This command is not applicable to the GSM Test Application.
GPRS TA This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

This parameter sets/quires the enhanced power control mode. See EPC Mode for more information.

EGPRS LA

Setting

Range: 1 | ON | 0 | OFF

Query

1 | 0

*RST Setting

 0 | OFF

Requirements

 GSM/GPRS/ EGPRS LA

Revision: G.00.00 and above

Programming Example

OUTPUT 714;"CALL:SIGNaling:MS:EPControl:MODE OFF"
! Turns the EPC Mode OFF.

CALL:SIGNaling:MS:EPControl:CONTinuous[:STATe]

Function

 GSM TA

This command is not applicable to the GSM Test Application.
GPRS TA This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

This parameter sets/quires whether EPC signalling is used continuously or only when a change is required. See EPC Continuous for more information.

EGPRS LA

Setting

Range: 1 | ON | 0 | OFF

Query

1 | 0

*RST Setting

 0 | OFF

Requirements

 GSM/GPRS/ EGPRS LA

Revision: G.00.00 and above

Programming Example

OUTPUT 714;"CALL:SIGNaling:MS:EPControl:CONTinuous OFF"
! Turns the EPC Continuous OFF.

CALL:SIGNaling:MS:EPControl:STEP:MAXimum

Function

 GSM TA

This command is not applicable to the GSM Test Application.
GPRS TA This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

This parameter sets/quires the maximum EPC step size that taken to reach the destination power. See EPC Maximum Step Size for more information.

EGPRS LA

Setting

Range: 1 |2 | 3 | 4

Query

1 | 2 | 3 | 4

*RST Setting

 4

Requirements

 GSM/GPRS/ EGPRS LA

Revision: G.00.00 and above

Programming Example

OUTPUT 714;"CALL:SIGNaling:MS:EPControl:STEP:MAXimum 4"
! Sets the EPC Maximum Step Size to 4.

CALL:SIGNaling:MS:TXLevel:FACCH

Function

 GSM TA

THIS COMMAND IS OBSOLETE. Please use the command CALL:TCHannel:(FACCH|FACChannel):MS:TXLevel instead.

Sets/queries the TX Level FACCH Signaling parameter.

When TX Level FACCH Signaling is set to on, the base station emulator uses both a FACCH (Fast Associated Control CHannel) channel assignment and an update to the SACCH (Slow Associated Control CHannel) header to signal the mobile to change to a new power level.

When TX Level FACCH Signaling is set to off, the base station emulator uses only an update to the SACCH header to signal the mobile to change to a new power level. A FACCH channel assignment message is not sent. This setting is useful if you want to update the SACCH header's TX Level field without performing a channel assignment.

The setting of TX Level FACCH Signaling can be changed in either of the test set's two operating modes, Active Cell or Test mode.
GSM/GPRS LA

EGPRS LA
GPRS TA

EGPRS TA

Setting

Range: 1 | ON | 0 | OFF

Query

1 | 0

*RST Setting

 1 | ON

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:SIGNaling:MS:TXLevel:FACCH 0"
! Turns the TX Level Signaling parameter OFF.

Related Topics

Configuring the Broadcast Channel (BCH)


CALL:STATus

CALL:STATus

GPIB Command Conventions

  • CALL:STATus[:STATe][:VOICe]?

  • CALL:STATus[:STATe]:DATA?

  • CALL:STATus:MS:IP:ADDRess[1|]2|3|4:CONText:PRIMary?
  • CALL:STATus:MS:IP:ADDRess[1]|2|3|4:CONText:PRIMary:LLCSapi?
  • CALL:STATus:MS:IP:ADDRess[1]|2|3|4:CONText:PRIMary:NSAPi?
  • CALL:STATus:MS:IP:ADDRess[1|]2|3|4:CONText:SECondary1|2|3?
  • CALL:STATus:MS:IP:ADDRess[1]|2|3|4:CONText:SECondary1|2|3:LLCSapi?
  • CALL:STATus:MS:IP:ADDRess[1]|2|3|4:CONText:SECondary1|2|3:NSAPi?

  • CALL:STATus:(PDTCH|PDTChannel):BLERror?
  • CALL:STATus:(PDTCH|PDTChannel):TERRor?
  • CALL:STATus:(PDTCH|PDTChannel):USFBler[:ASSigned]?
  • CALL:STATus:(PDTCH|PDTChannel):USFBler:ALL?
  • CALL:STATus:(PDTCH|PDTChannel):USFBler:UNASsigned?

  • CALL:STATus:PRAChannel:TERRor?

  • CALL:STATus:RACHannel:TERRor?

  • CALL:STATus:TCHannel:TERRor?

CALL:STATus[:STATe][:VOICe]?

Function

GSM TA

This query returns the status of the call. For details on the call states see Call Processing State Synchronization .

GSM/GPRS LA

EGPRS LA

GPRS TA

 This command is not applicable to GPRS.

EGPRS TA

 This command is not applicable to EGPRS.
Query

Range: IDLE | SREQ | ALER | CONN | DISC
*RST setting

IDLE

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:STATUS:STATE?"

CALL:STATus[:STATe]:DATA?

Function

GSM TA

This command is not applicable to GSM.

GPRS TA

This query returns the status of the data connection. For details on the data connection states see Data Connection Processing State Synchronization .

SUSP is only applicable to the lab applications.

EGPRS TA

GSM/GPRS LA

EGPRS LA
Query

Range:

  • GPRS Test Application: IDLE | ATTG | DET |ATT | STAR | END | TRAN
  • GSM/GPRS Lab Application: IDLE | ATTG | DET |ATT | STAR | END | TRAN | PDPAG | PDP | PDPD | DCON | SUSP
*RST setting

IDLE

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above
Revision E.00.12 adds SUSP

Programming Example

OUTPUT 714;"CALL:STATUS:DATA?"

CALL:STATus:MS:IP:ADDRess[1|]2|3|4:CONText:PRIMary?

Function

GSM TA

This command is not applicable to GSM Test Application.

GPRS TA

This command is not applicable to GPRS Test Application.

EGPRS TA

This command is not applicable to EGPRS Test Application.

GSM/GPRS LA

This query returns the Primary PDP context status of IP address 1, 2, 3, or 4 respectively. This command is not applicable to GSM.

EGPRS LA
Query

Range: ACTive | INACtive
*RST setting INAC
Requirements GSM/GPRS/ EGPRS LA

Revision: E.00.12 and above

Programming Example

OUTPUT 714;"CALL:STATUS:MS:IP:ADDRESS2:CONTEXT:PRIMARY?"

CALL:STATus:MS:IP:ADDRess[1]|2|3|4:CONText:PRIMary:LLCSapi?

Function

GSM TA

This command is not applicable to GSM Test Application.

GPRS TA

This command is not applicable to GPRS Test Application.

EGPRS TA

This command is not applicable to EGPRS Test Application.

GSM/GPRS LA

This query returns the LLC SAPI for the Primary PDP Context of IP address 1, 2, 3, or 4 respectively. This command is not applicable to GSM.

EGPRS LA
Query

Range: 3 | 5 | 7 | 9

*RST setting None
Requirements GSM/GPRS/ EGPRS LA

Revision: E.00.12 and above

Programming Example

OUTPUT 714;"CALL:STATUS:MS:IP:ADDRESS2:CONTEXT:PRIMARY:LLCSAPI?"

CALL:STATus:MS:IP:ADDRess[1]|2|3|4:CONText:PRIMary:NSAPi?

Function

GSM TA

This command is not applicable to GSM Test Application.

GPRS TA

This command is not applicable to GPRS Test Application.

EGPRS TA

This command is not applicable to EGPRS Test Application.

GSM/GPRS LA

This query returns the NSAPI for the Primary PDP Context of IP address 1, 2, 3, or 4 respectively. This command is not applicable to GSM.

EGPRS LA
Query

Range: 1 to 16
*RST setting None
Requirements GSM/GPRS/ EGPRS LA

Revision: E.00.12 and above

Programming Example

OUTPUT 714;"CALL:STATUS:MS:IP:ADDRESS2:CONTEXT:PRIMARY:NSAPI?"

CALL:STATus:MS:IP:ADDRess[1|]2|3|4:CONText:SECondary1|2|3?

Function

GSM TA

This command is not applicable to GSM Test Application.

GPRS TA

This command is not applicable to GPRS Test Application.

EGPRS TA

This command is not applicable to EGPRS Test Application.

GSM/GPRS LA

This query returns the Secondary PDP context (1, 2 or 3) status of IP address 1, 2, 3, or 4 respectively. This command is not applicable to GSM.

EGPRS LA
Query

Range: ACTive | INACtive
*RST setting INAC
Requirements GSM/GPRS/ EGPRS LA

Revision: F.00.37 and above

Programming Example

OUTPUT 714;"CALL:STATUS:MS:IP:ADDRESS2:CONTEXT:SECONDARY1?"

CALL:STATus:MS:IP:ADDRess[1]|2|3|4:CONText:SECondary1|2|3:LLCSapi?

Function

GSM TA

This command is not applicable to GSM Test Application.

GPRS TA

This command is not applicable to GPRS Test Application.

EGPRS TA

This command is not applicable to EGPRS Test Application.

GSM/GPRS LA

This query returns the LLC SAPI for the Secondary PDP Context (1, 2 or 3) of IP address 1, 2, 3, or 4 respectively. This command is not applicable to GSM.

EGPRS LA
Query

Range: 3 | 5 | 7 | 9

*RST setting None
Requirements GSM/GPRS/ EGPRS LA

Revision: F.00.37 and above

Programming Example

OUTPUT 714;"CALL:STATUS:MS:IP:ADDRESS2:CONTEXT:SECONDARY1:LLCSAPI?"

CALL:STATus:MS:IP:ADDRess[1]|2|3|4:CONText:SECondary1|2|3:NSAPi?

Function

GSM TA

This command is not applicable to GSM Test Application.

GPRS TA

This command is not applicable to GPRS Test Application.

EGPRS TA

This command is not applicable to EGPRS Test Application.

GSM/GPRS LA

This query returns the NSAPI for the Secondary PDP Context (1, 2 or 3) of IP address 1, 2, 3, or 4 respectively. This command is not applicable to GSM.

EGPRS LA
Query

Range: 1 to 16
*RST setting None
Requirements GSM/GPRS/ EGPRS LA

Revision: F.00.37 and above

Programming Example

OUTPUT 714;"CALL:STATUS:MS:IP:ADDRESS2:CONTEXT:SECONDARY1:NSAPI?"

CALL:STATus:(PDTCH|PDTChannel):BLERror?

Function

GSM TA

This command is not applicable to GSM.

GPRS TA

This query returns the block error rate (BLER) result and the number of blocks tested to calculate the BLER result.

The BLER result is only available when the data connection type is set to BLER (see CALL:FUNCtion:CONNection:TYPE ).

The BLER result is only updated when the data connection state is transferring (TRAN). See CALL:STATus[:STATe]:DATA? . To reset the BLER result you must use SYSTem:MEASurement:RESet . The BLER result does not reset automatically when you connect a different GPRS mobile station.

If you require more details on BLER, see Block Error Rate (BLER) Reports Description .

EGPRS TA

GSM/GPRS LA

EGPRS LA
Query

Block error rate

  • Range: 0 to 100 and 9.91E+37 (NAN)
  • Resolution: 1

Blocks tested

  • Range: 0 to 100000 and 9.91E+37 (NAN)
  • Resolution: 1
*RST setting

Block error rate: 9.91E+37 (NAN), Blocks tested: 9.91E+37 (NAN)

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:STATus:PDTCh:BLERror?"

CALL:STATus:(PDTCH|PDTChannel):TERRor?

Function

GSM TA

This command is not applicable to GSM.

GPRS TA

This query returns the burst timing error report which provides a course indication of the difference between the actual and expected burst reception times. The error is calculated on a burst by burst basis from the adaptive equalization filter coefficients. The reporting period for burst timing error is approximately 0.5 seconds, and the value returned is the peak timing error occurring during the period. Note that this report is not based on a demodulated midamble position.

When there are no active PDTCHs, Burst Timing Error results are not available

EGPRS TA

GSM/GPRS LA

EGPRS LA
Query

Range: -8 to +30 T and 9.91 E+37 (NAN)

Resolution: 0.25 T

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:STATus:PDTCh:TERRor?"

CALL:STATus:(PDTCH|PDTChannel):USFBler[:ASSigned]?

Function

GSM TA

This command is not applicable to the GSM test application.
GPRS TA This command is not applicable to the GPRS test application.

EGPRS TA

 This command is not applicable to EGPRS.

GSM/GPRS LA

This query returns the Assigned USF block error rate (USF BLER) percentage and the number of blocks tested to calculate the USF BLER result.

The USF BLER results are only updated when the data connection state is transferring (TRAN). See CALL:STATus[:STATe]:DATA? . To reset the USF BLER results you must use SYSTem:MEASurement:RESet . The USF BLER results do not reset automatically when you connect a different GPRS mobile station.

EGPRS LA
Query Assigned USF BLER
  • Range: 0 to 100 percent and 9.91E+37 (NAN)
  • Resolution: 1

Assigned blocks tested

  • Range: 0 to 100000 and 9.91E+37 (NAN)
  • Resolution: 1
*RST setting

Assigned USF BLER: 9.91E+37, assigned locks tested: 9.91E+37
Requirements GSM/GPRS/ EGPRS LA

Revision: D.01 and above

Programming Example

OUTPUT 714;"CALL:STATus:PDTCh:USFBler?"

CALL:STATus:(PDTCH|PDTChannel):USFBler:ALL?

Function

GSM TA

This command is not applicable to the GSM test application.
GPRS TA This command is not applicable to the GPRS test application.

EGPRS TA

 This command is not applicable to EGPRS.

GSM/GPRS LA

This query returns the Assigned USF Block Error Rate (USF BLER) percentage measured, total number of assigned USF BLER blocks measured, Unassigned USF BLER percentage measured, and number of total unassigned blocks measured.

The USF BLER results are only updated when the data connection state is transferring (TRAN). See CALL:STATus[:STATe]:DATA? . To reset the USF BLER results you must use SYSTem:MEASurement:RESet . The USF BLER results do not reset automatically when you connect a different GPRS mobile station.

EGPRS LA
Query

Assigned USF BLER

  • Range: 0 to 100 percent and 9.91E+37 (NAN)
  • Resolution: 1

Assigned blocks tested

  • Range: 0 to 100000 and 9.91E+37 (NAN)
  • Resolution: 1

Unassigned USF BLER

  • Range: 0 to 100 percent and 9.91E+37 (NAN)
  • Resolution: 1

Unassigned blocks tested

  • Range: 0 to 100000 and 9.91E+37 (NAN)
  • Resolution: 1
*RST setting

Assigned USF BLER: 9.91E+37 (NAN), assigned blocks tested: 9.91E+37 Unassigned USF BLER: 9.91E+37, unassigned blocks tested: 9.91E+37
Requirements GSM/GPRS/ EGPRS LA

Revision: D.01 and above

Programming Example

OUTPUT 714;"CALL:STATus:PDTCh:USFBler:ALL?"

CALL:STATus:(PDTCH|PDTChannel):USFBler:UNASsigned?

Function

GSM TA

This command is not applicable to the GSM test application.
GPRS TA This command is not applicable to the GPRS test application.

EGPRS TA

 This command is not applicable to EGPRS.

GSM/GPRS LA

This query returns the Unassigned USF Block Error Rate (USF BLER) percentage and the total number of blocks tested to calculate the USF BLER result.

The USF BLER results are only updated when the data connection state is transferring (TRAN). See CALL:STATus[:STATe]:DATA? . To reset the USF BLER result you must use SYSTem:MEASurement:RESet . The USF BLER results do not reset automatically when you connect a different GPRS mobile station.

EGPRS LA
Query

Block error rate

  • Range: 0 to 100 and 9.91E+37 (NAN)
  • Resolution: 1

Blocks tested

  • Range: 0 to 100000 and 9.91E+37 (NAN)
  • Resolution: 1
*RST setting

Unassigned USF BLER: 9.91E+37, Unassigned blocks tested: 9.91E+37
Requirements GSM/GPRS/ EGPRS LA

Revision: D.01 and above

Programming Example

OUTPUT 714;"CALL:STATus:PDTCh:USFBler:UNASsigned?"

CALL:STATus:PRAChannel:TERRor?

Function

GSM TA

 This command is not applicable to GSM TA

GPRS TA

 This command is not applicable to GPRS TA.

EGPRS TA

 This command is not applicable to EGPRS TA.

GSM/GPRS LA

This query returns the burst timing error report which provides a course indication of the difference between the expected and the actual of the access burst for the PRACH. The timing error is calculated on a burst by burst basis with accuracy of 0.124 symbol period and is only valid when call status is idle or setup.

This indicates the worst case timing error of all bursts received in a reporting period. If all of the bursts reporting in a period are missing, the query returns 9.91E+37 (NAN).

NOTE
For access burst timing error measurement, the result is always presented even if the error is 0. This behavior is different with the normal burst timing error which only present the peak timing error value.

The PRACH timing error is used in the uplink direction only by MS to perform the followings:

  • Initiating a call - when the MS originates a call, it transmits a Channel Request message in the PRACH.
  • Responding to a page request - when the MS receives a Paging Request message, it begins the immediate assignment procedure by sending the Channel Request Message in the PRACH.
  • Performing a location update - this is a mobile-initiated procedure which happens when the MS is switched on or the MS defects a new Location Area or the Periodic Timer expires. The MS performs the location update by sending the Channel Request message using the PRACH channel.

EGPRS LA
Query

Range: -8 to +30 T and 9.91E+37 (NAN)

Resolution: 0.25 T

*RST setting

9.91E+37 (NAN)

Requirements

 GSM/GPRS/ EGPRS LA

Revision: F.00.27 and above

Programming Example

OUTPUT 714;"CALL:STATus:PRAChannel:TERRor?"

CALL:STATus:RACHannel:TERRor?

Function

GSM TA

 This command is not applicable to GSM TA

GPRS TA

 This command is not applicable to GPRS TA.

EGPRS TA

 This command is not applicable to EGPRS TA.

GSM/GPRS LA

This query returns the burst timing error report which provides a course indication of the difference between the expected and the actual of the access burst for the RACH. The timing error is calculated on a burst by burst basis with accuracy of 0.124 symbol period and is only valid when call status is idle or setup.

This indicates the worst case timing error of all bursts received in a reporting period. If all of the bursts reporting in a period are missing, the query returns 9.91E+37 (NAN).

NOTE
For access burst timing error measurement, the result is always presented even if the error is 0. This behavior is different with the normal burst timing error which only present th peak timing error value.

The RACH timing error is used in the uplink direction only by MS to perform the followings:

  • Initiating a call - when the MS originates a call, it transmits a Channel Request messagein the RACH.
  • Responding to a page request - when the MS receives a Paging Request message, it begins the immediate assignment procedure by sending the Channel Request Message in the RACH.
  • Performing a location update - this is a mobile-initiated procedure which happens when the MS is switched on or the MS defects a new Location Area or the Periodic Timer expires. The MS performs the location update by sending the Channel Request message using the RACH channel.

EGPRS LA
Query

Range: -8 to +30 T and 9.91E+37 (NAN)

Resolution: 0.25 T

*RST setting

9.91E+37 (NAN)

Requirements

 GSM/GPRS/ EGPRS LA

Revision: F.00.27 and above

Programming Example

OUTPUT 714;"CALL:STATus:RACHannel:TERRor?"

CALL:STATus:TCHannel:TERRor?

Function

GSM TA

This query returns the last normal burst timing error measurement.

This indicates the worst case timing error of all bursts received in a reporting period. If all of the bursts reporting in a period are missing, the query returns 9.91E+37 (NAN).

The reference for burst timing error measurements is with respect to the (downlink TCH slot) + (3 slot TX/RX delay (468.75 bits)) - (TCH Timing Advance).

The CALL:STATUS:STATE must be connected, see CALL:STATus[:STATe][:VOICe]? .

Burst timing error is continuously updated every 480 ms . Burst timing error is displayed in the Call Setup window.

GSM/GPRS LA

EGPRS LA

GPRS TA

 This command is not applicable to GPRS.

EGPRS TA

 This command is not applicable to EGPRS.
Query

Range: -8 to +30 T and 9.91E+37 (NAN)

Resolution: 0.25 T

*RST setting

9.91E+37 (NAN)

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:STATus:TCHANnel:TERRor?"
! Returns Burst Timing Error.


CALL:TBFLow

CALL:TBFLow

GPIB Command Conventions

  • CALL[:CELL]:TBFLow:T3192
  • CALL[:CELL]:TBFLow:UPLink:EXTended[:STATe]

CALL[:CELL]:TBFLow:T3192

Function

GSM TA

 This command is not applicable to the GSM Test Application.
GPRS TA

This command is not applicable to the GPRS Test Application.
EGPRS TA

This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

Sets the TBF Release Timer value. See Configurable Timers .
EGPRS LA
Setting

Range: MS500 | MS1000 | MS1500 | MS0 | MS80 | MS120 | MS160 | MS200

Query

Range: MS500 | MS1000 | MS1500 | MS0 | MS80 | MS120 | MS160 | MS200

*RST setting

 MS500

Requirements

 GSM/GPRS/ EGPRS LA

Revision: F.00.27 and above

Programming Example:

OUTPUT 714;"CALL:CELL:TBFLOW:T3192 MS1000"
! Set the expire time of T3192 to 1000ms.

CALL[:CELL]:TBFLow:UPLink:EXTended[:STATe]

Function

GSM TA

 This command is not applicable to the GSM Test Application.

GPRS TA

 This command is not applicable to the GPRS Test Application.

EGPRS TA

 This command is not applicable to the EGPRS Test Application.

GSM/GPRS LA

Sets/Queries the Extended Uplink TBF State.

The command to set the duration of the extended uplink TBF is CALL:(PDTCH|PDTChannel):TBFLow:UPLink:EXTended:DURation .

EGPRS LA
Setting | Range: 0 | OFF | 1 | ON
Query | Range: 0 | 1
*RST setting | 0
Requirements GSM/GPRS/ EGPRS LA

Revision: E.01 and above

Programming Example

OUTPUT 714;"CALL:TBFLow:UPLink:EXTended ON"
! Enables the extended uplink TBF.


CALL:TCHannel

CALL:TCHannel

GPIB Command Conventions

  • CALL:TCHannel[:ARFCn][:SELected]

  • CALL:TCHannel:BAND

  • CALL:TCHannel:CLEarcoded:STATe

  • CALL:TCHannel:CMODe[:VALue]
  • CALL:TCHannel:CMODe:AFSPeech:CODec
  • CALL:TCHannel:CMODe:AFSPeech:CODec:CURRent
  • CALL:TCHannel:CMODe:AFSPeech:CODec:THReshold
  • CALL:TCHannel:CMODe:AHSPeech:CODec
  • CALL:TCHannel:CMODe:AHSPeech:CODec:CURRent
  • CALL:TCHannel:CMODe:AHSPeech:CODec:THReshold
  • CALL:TCHannel:CMODe:HRSPeech:SCHannel
  • CALL:TCHannel:CMODe:LSPeech:CHANnel
  • CALL:TCHannel:CMODe:WFSPeech:CODec
  • CALL:TCHannel:CMODe:WFSPeech:CODec:CURRent
  • CALL:TCHannel:CMODe:WFSPeech:CODec:THReshold

  • CALL:TCHannel:CUSTom:DATA

  • CALL:TCHannel:DAINterface:TINTerface

  • CALL:TCHannel:DOWNlink:DTX[:STATe]

  • CALL:TCHannel:DOWNlink:SPEech
  • CALL:TCHannel:DOWNlink:SPEech:LOOPback:DELay

  • CALL:TCHannel:(FACCH|FACChannel):MS:TXLevel
  • CALL:TCHannel:(FACCH|FACChannel):REPeat[:STATe]

  • CALL:TCHannel:FHOPping[:STATe]
  • CALL:TCHannel:FHOPping:HSNumber
  • CALL:TCHannel:FHOPping:MAIoffset:[SELected]

  • CALL:TCHannel:LOOPback

  • CALL:TCHannel:MA:MEASurement:ARFCn:(SELected]
  • CALL:TCHannel:MA:TABLe[:AUTO]:[SELected]?
  • CALL:TCHannel:MA:TABLe[:AUTO]:POINts:[SELected]?
  • CALL:TCHannel:MA:TABLe:CONFig:AUTO
  • CALL:TCHannel:MA:TABLe:MANual:[SELected]
  • CALL:TCHannel:MA:TABLe:MANual:POINts:[SELected]?

  • CALL:TCHannel:POWer[:AMPLitude]?
  • CALL:TCHannel:POWer[:AMPLitude]:ADJacent?
  • CALL:TCHannel:POWer[:AMPLitude]:UBURst?
  • CALL:TCHannel:POWer[:AMPLitude]:UNUSed?

  • CALL:TCHannel:PREDuction:ADJacent
  • CALL:TCHannel:PREDuction:BURSt
  • CALL:TCHannel:PREDuction:LEVel([1]|2)
  • CALL:TCHannel:PREDuction:UBURst
  • CALL:TCHannel:PREDuction:UNUSed

  • CALL:TCHannel:(SACCH|SACChannel):REPeat[:STATe]
  • CALL:TCHannel:(SACCH|SACChannel):REPeat:ORDer

  • CALL:TCHannel:SIGNaling:ASSignment:CHANnel
  • CALL:TCHannel:SIGNaling:DCCHannel:CSINdicator
  • CALL:TCHannel:SIGNaling:DESTination:CHANnel
  • CALL:TCHannel:SIGNaling:(SDCCH|SDCChannel):MS:TADVance[:SELected]
  • CALL:TCHannel:SIGNaling:(SDCCH|SDCChannel):MS:TXLevel[:SELected]
  • CALL:TCHannel:SIGNaling:(SDCCH|SDCChannel):SUBChannel

  • CALL:TCHannel:TSLot

CALL:TCHannel[:ARFCn][:SELected]

CALL:TCHannel[:ARFCn]:(DCS|EGSM|GSM450|GSM480|GSM750|GSM850|PCS|PGSM|RGSM|TGSM810)

Function

GSM TA

Sets/queries the channel number of downlink and uplink TCH for the specified traffic band. See Configuring the Traffic Channel (TCH) Parameters . The optional [:SELected] keyword in this command specifies that the cell band being set or queried applies to the currently selected traffic band.

The TCH ARFCN may be set and queried when the CALL:STATUS:STATE is idle or connected, see CALL:STATus[:STATe][:VOICe]? .

The setting, query, and *RST value depend on the which traffic band is used.

If this command is attempted while there is an active DTM connection or while the test set is in a DTM test operating mode, it is stored and applied when the test set is no longer in Dual Transfer Mode.

GSM/GPRS LA

EGPRS LA

GPRS TA

 This command is not applicable to GPRS.

EGPRS TA

 This command is not applicable to EGPRS.

Setting

Range:

  • DCS band, channels 512 to 885 (default: 698)
  • EGSM band, channels 0 to 124 and 975 to 1023 (default: 30)
  • GSM450 band, channels 259 to 293 (default: 280)
  • GSM480 band, channels 306 to 340 (default: 320)
  • GSM750 band, channels 438 to 511 (default: 460)
  • GSM850 band, channels 128 to 251 (default: 160)
  • PCS band, channels 512 to 810 (default: 698)
  • PGSM band, channels 1 to 124 (default: 30)
  • RGSM band, channels 0 to 124 and 955 to 1023 (default: 30)
  • TGSM810 band, channels 350 to 425 (default 400)

Resolution: 1

Query

Range:

  • DCS band, channels 512 to 885
  • EGSM band, channels 0 to 124 and 975 to 1023
  • GSM450 band, channels 259 to 293
  • GSM480 band, channels 306 to 340
  • GSM750 band, channels 438 to 511
  • GSM850 band, channels 128 to 251
  • PCS band, channels 512 to 810
  • PGSM band, channels 1 to 124
  • RGSM band, channels 0 to 124 and 955 to 1023
  • TGSM810 band, channels 350 to 425

Resolution: 1

*RST Setting

PGSM, EGSM and RGSM bands: 30, DCS and PCS bands: 698, GSM450: 280, GSM480: 320, GSM750: 460, GSM850: 160, TGSM810: 400.

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.01 and above

A.06 adds the TGSM810 band.
GSM/GPRS/ EGPRS LA

Revision: C.01 and above
D.03 adds the TGSM810 band.

Programming Example

OUTPUT 714;"CALL:TCHannel:PCS 512"
! Selects ARFCN of 512 on the test set.

CALL:TCHannel:BAND

Function

GSM TA

Sets/queries which GSM band the BS Emulator should use for the TCH.

The test set may be queried for the current TCH band when the CALL:STATUS:STATE is idle or connected, see CALL:STATus[:STATe][:VOICe]? .

The test set uses this command to perform a channel assignment, see How the Test Set Performs a Dualband Handover when the MS will support the band and the CALL:STATUS:STATE is CONNected.

If this command is attempted while there is an active DTM connection or while the test set is in a DTM test operating mode, it is stored and applied when the test set is no longer in Dual Transfer Mode.

GSM/GPRS LA

EGPRS LA

GPRS TA

 This command is not applicable to GPRS.

EGPRS TA

 This command is not applicable to EGPRS.

Setting

Range: PGSM | DCS | EGSM | GSM450 | GSM480 | GSM750 | GSM850 | PCS | RGSM| TGSM810

Resolution: 1

Query

Range: PGSM | DCS | EGSM | GSM450 | GSM480 | GSM750 | GSM850 | PCS | RGSM| TGSM810

Resolution: 1

*RST Setting

PGSM

Related Topic

See Traffic Band Parameter .

Requirement

 GSM/GPRS/
EGPRS TA

Revision: A.01 and above

A.06 adds the TGSM810 band.
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

D.03 adds the TGSM810 band.

Programming Example

OUTPUT 714;"CALL:TCHANNEL:BAND DCS"

CALL:TCHannel:CLEarcoded:STATe

Function

GSM TA

 This command enables/queries ClearCoded state on TCH. See Mobile Calculate BER Test for more information.

EGPRS TA

GSM LA

EGPRS LA

GPRS TA

 This command is not applicable to GPRS.

GPRS LA

 This command is not applicable to EGPRS.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0|OFF

Requirement

 GSM/GPRS/
EGPRS TA

Revision: A.09 and above with required feature license.
GSM/GPRS/ EGPRS LA

Revision: F.01 and above

Programming Example

OUTPUT 714;"CALL:TCHannel:CLEarcoded:STATe ON"

CALL:TCHannel:CMODe[:VALue]

Function

GSM TA

This channel sets/queries which channel mode the mobile station should use for speech data. This setting is either full rate speech (FRSPeech), enhanced full rate speech (EFRSpeech) or half rate speech (HRSPeech). See Programming a Channel Mode Change .

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Setting

Range: FRSPeech | EFRSpeech | HRSPeech

Query

Range: FRSP | EFRS | HRSP

*RST Setting

 FRSPeech

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:TCHANNEL:CMODE EFRSPEECH"

CALL:TCHannel:CMODe:AFSPeech:CODec

Function

GSM TA

 This command is not applicable to the GPRS test application.

GPRS TA

 This command is not applicable to the GPRS test application.

EGPRS TA

 This command is not applicable to the EGPRS test application.

GSM/GPRS LA

Sets/queries the AFS (Adaptive Full) codecs that are in the AFS Codec Set.

EGPRS LA

Setting

Range: AFS12200|AFS10200|AFS7950|AFS7400|AFS6700|AFS5900|AFS5150|AFS4750|UNUSed

NOTE: The Codec Set must be defined in order, with codec 1 being first and codec 4 being last. Also, the codec rates must be in ascending order such that the codec with lowest rate is first and the codec with the highest rate is last.

Query

Returns: AFS12200|AFS10200|AFS7950|AFS7400|AFS6700|AFS5900|AFS5150|AFS4750

*RST Setting

AFS12200|AFS10200|AFS7950|AFS7400
Requirements

 GSM/GPRS/ EGPRS LA

Revision: D.01 and above

GSM/GPRS/ EGPRS TA

Revision: A.09 and above with required feature license.

Programming Example 1

OUTPUT 714;"CALL:TCHannel:CMODe:LSPeech:CHANnel AFS"
! Sets the logical speech channel to AFS (Adaptive Full).

OUTPUT 714;"CALL:TCHannel:CMODe:AFSPeech:CODec AFS6700,AFS7400,AFS7950,AFS10200"
! Defines which codecs are in the AFS Codec Set.

OUTPUT 714;"CALL:TCHannel:CMODe:AFSPeech:CODec:CURRent AFS6700"
! Sets the codec that the mobile station will use to AFS6700.

OUTPUT 714;"CALL:TCHannel:CMODe:AFSPeech:CODec:THReshold 6.5,2,12.5,2,18.5,2"
! Sets the threshold and hysteresis values. These four commands are sufficient to
! completely define the AFS Codec Set.

Programming Example 2

OUTPUT 714;"CALL:TCHannel:CMODe:AFSPeech:CODec AFS6700,UNUSed,UNUSed,UNUSed"
! Defines only one codec in the AFS Codec Set. Note: There must be four parameters for this command.

CALL:TCHannel:CMODe:AFSPeech:CODec:CURRent

Function

GSM TA

 This command is not applicable to the GPRS test application.

GPRS TA

 This command is not applicable to the GPRS test application.

EGPRS TA

 This command is not applicable to the EGPRS test application.

GSM/GPRS LA

Sets/queries which codec from the AFS Codec Set that is being used.
EGPRS LA

Setting

Range: AFS12200|AFS10200|AFS7950|AFS7400|AFS6700|AFS5900|AFS5150|AFS4750|STR|MSR

NOTE: The current codec can only be changed to another codec within the set and, when the operating mode is Active, STRESS or MSReqest can be chosen.

Query

Returns: AFS12200|AFS10200|AFS7950|AFS7400|AFS6700|AFS5900|AFS5150|AFS4750|STR|MSR

*RST Setting

 AFS7400
Requirements

 GSM/GPRS/ EGPRS LA

Revision: D.01 and above

GSM/GPRS/ EGPRS TA

Revision: A.09 and above with required feature license.

Programming Example

OUTPUT 714;"CALL:TCHannel:CMODe:LSPeech:CHANnel AFS"
! Sets the logical speech channel to AFS (Adaptive Full).

OUTPUT 714;"CALL:TCHANNEL:CMODe:AFSPeech:CODec AFS6700,AFS7400,AFS7950,AFS10200"
! Defines which codecs are in the AFS Codec Set.

OUTPUT 714;"CALL:TCHANNEL:CMODe:AFSPeech:CODec:CURRent MSRequest"
! Allows the mobile to make requests to change the current codec that
! it is using based on the threshold and hysteresis values.

OUTPUT 714;"CALL:TCHANNEL:CMODe:AFSPeech:CODec:THReshold 6.5,2,12.5,2,18.5,2"
! Sets the threshold and hysteresis values.
! These four commands are sufficient to completely define the AFS Codec Set.

CALL:TCHannel:CMODe:AFSPeech:CODec:THReshold

Function

GSM TA

 This command is not applicable to the GPRS test application.

GPRS TA

 This command is not applicable to the GPRS test application.

EGPRS TA

 This command is not applicable to the EGPRS test application.

GSM/GPRS LA

Sets/queries the threshold and hysteresis values, which determine when the current codec needs to be changed in the AFS Codec Set.

EGPRS LA

Setting

Range: Threshold Values: 0 to 31.5 dB, Hysteresis Values: 0 to 7.5

Resolution: .5 dB

Query

Range: Threshold Values: 0 to 31.5 dB, Hysteresis Values: 0 to 7.5

Resolution: .5 dB

*RST Setting

 6.5,2,12.5,2,18.5,2
Requirements

 GSM/GPRS/ EGPRS LA

Revision: D.01 and above

GSM/GPRS/ EGPRS TA

Revision: A.09 and above with required feature license.

Programming Example

OUTPUT 714;"CALL:TCHannel:CMODe:LSPeech:CHANnel AFS"
! Sets the logical speech channel to AFS (Adaptive Full).

OUTPUT 714;"CALL:TCHANNEL:CMODe:AFSPeech:CODec AFS6700,AFS7400,AFS7950,AFS10200"
! Defines which codecs are in the AFS Codec Set.

OUTPUT 714;"CALL:TCHANNEL:CMODe:AFSPeech:CODec:CURRent AFS6700"
! Sets the codec that the mobile station will use to AFS6700.

OUTPUT 714;"CALL:TCHANNEL:CMODe:AFSPeech:CODec:THReshold 6,1.5,10.5,2,18,2.5"
! Sets the threshold and hysteresis values.
! These four commands are sufficient to completely define the AFS Codec Set.

CALL:TCHannel:CMODe:AHSPeech:CODec

Function

GSM TA

 This command is not applicable to the GPRS test application.

GPRS TA

 This command is not applicable to the GPRS test application.

EGPRS TA

 This command is not applicable to the EGPRS test application.

GSM/GPRS LA

Sets/queries the AHS (Adaptive Half) codecs that are in the AHS Codec Set

EGPRS LA

Setting

Range: AHS7950|AHS7400|AHS6700|AHS5900|AHS5150| AHS4750|UNUSed

NOTE: The Codec Set must be defined in order, with codec 1 being first and codec 4 being last. Also, the codec rates must be in ascending order such that the codec with lowest rate is first and the codec with the highest rate is last.

Query

Returns: AHS7950|AHS7400|AHS6700|AHS5900|AHS5150| AHS4750

*RST Setting

AHS7950|AHS7400|AHS6700|AHS5900
Requirements

 GSM/GPRS/ EGPRS LA

Revision: D.01 and above

GSM/GPRS/ EGPRS TA

Revision: A.09 and above with required feature license.

Programming Example 1

OUTPUT 714;"CALL:TCHannel:CMODe:LSPeech:CHANnel AHS"
! Sets the logical speech channel to AHS (Adaptive Half).

OUTPUT 714;"CALL:TCHANNEL:CMODe:AHSPeech:CODec:CURRent AHS6700"
! Sets the codec that the mobile station will use to AHS6700.

OUTPUT 714;"CALL:TCHANNEL:CMODe:AHSPeech:CODec AHS4750,AHS5150,AHS5900,AHS6700"
! Defines which codecs are in the AHS Codec Set.

OUTPUT 714;"CALL:TCHANNEL:CMODe:AHSPeech:CODec:THReshold 6.5,2,12.5,2,18.5,2"
! Sets the threshold and hysteresis values.
! These four commands are sufficient to completely define the AHS Codec Set.

Programming Example 2

OUTPUT 714;"CALL:TCHannel:CMODe:AHSPeech:CODec AHS6700,UNUSed,UNUSed,UNUSed"
! Defines only one codec in the AHS Codec Set. Note: There must be four parameters for this command.

CALL:TCHannel:CMODe:AHSPeech:CODec:CURRent

Function

GSM TA

 This command is not applicable to the GPRS test application.

GPRS TA

 This command is not applicable to the GPRS test application.

EGPRS TA

 This command is not applicable to the EGPRS test application.

GSM/GPRS LA

Sets/queries which codec from the AHS Codec Set that is being used.

EGPRS LA

Setting

Range: AHS7950|AHS7400|AHS6700|AHS5900|AHS5150| AHS4750|STRess|MS Request

NOTE: The current codec can only be changed to another codec within the set and, when the operating mode is Active, STRESS or MSRequest can be chosen.

Query

Returns: AHS7950|AHS7400|AHS6700|AHS5900|AHS5150| AHS4750|STRess|MS Request

*RST Setting

 AFS5900
Requirements

 GSM/GPRS/ EGPRS LA

Revision: D.01 and above

GSM/GPRS/ EGPRS TA

Revision: A.09 and above with required feature license.

Programming Example

OUTPUT 714;"CALL:TCHannel:CMODe:LSPeech:CHANnel AHS"
! Sets the logical speech channel to AHS (Adaptive Half).

OUTPUT 714;"CALL:TCHANNEL:CMODe:AHSPeech:CODec AHS4750,AHS5150,AHS5900,AHS6700"
! Defines which codecs are in the AHS Codec Set.

OUTPUT 714;"CALL:TCHANNEL:CMODe:AHSPeech:CODec:CURRent STRess"
! Sets the current codec in the AHS Codec Set to STRESS,
! which changes the sequentially between all the codecs in the AHS Codec Set.

OUTPUT 714;"CALL:TCHANNEL:CMODe:AHSPeech:CODec:THReshold 6,1.5,10.5,2,18,2.5"
! Sets the threshold and hysteresis values.
! These four commands are sufficient to completely define the AHS Codec Set.

CALL:TCHannel:CMODe:AHSPeech:CODec:THReshold

Function

GSM TA

 This command is not applicable to the GPRS test application.

GPRS TA

 This command is not applicable to the GPRS test application.

EGPRS TA

 This command is not applicable to the EGPRS test application.

GSM/GPRS LA

Sets/queries the threshold and hysteresis values, which determine when the current codec needs to be changed in the AHS Codec Set.

EGPRS LA

Setting

Range: Threshold Values: 0 to 31.5 dB, Hysteresis Values: 0 to 7.5

Resolution: .5 dB

Query

Range: Threshold Values: 0 to 31.5 dB, Hysteresis Values: 0 to 7.5

Resolution: .5 dB

*RST Setting

 8,2, 12,2, 16,2
Requirements

 GSM/GPRS/ EGPRS LA

Revision: D.01 and above

GSM/GPRS/ EGPRS TA

Revision: A.09 and above with required feature license.

Programming Example

OUTPUT 714;"CALL:TCHannel:CMODe:LSPeech:CHANnel AHS"
! Sets the logical speech channel to AHS (Adaptive Half).

OUTPUT 714;"CALL:TCHANNEL:CMODe:AHSPeech:CODec AHS4750,AHS5150,AHS5900,AHS6700"
! Defines which codecs are in the AHS Codec Set.

OUTPUT 714;"CALL:TCHANNEL:CMODe:AHSPeech:CODec:CURRent AHS4750"
! Sets the codec that the mobile station will use to AHS4750.

OUTPUT 714;"CALL:TCHANNEL:CMODe:AHSPeech:CODec:THReshold 6,1.5,10.5,2,18,2.5"
! Sets the threshold and hysteresis values.
! These four commands are sufficient to completely define the AHS Codec Set.

CALL:TCHannel:CMODe:HRSPeech:SCHannel

Function

GSM TA

 This command is not applicable to the GPRS test application.

GPRS TA

 This command is not applicable to the GPRS test application.

EGPRS TA

 This command is not applicable to the EGPRS test application.

GSM/GPRS LA

 Sets/queries the half rate sub channel for half rate speech.

EGPRS LA

Setting

Range: 0 | 1

Query

Returns: 0 | 1

*RST Setting

 0
Requirements GSM TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:TCHANNEL:CMODE:HRSPEECH:SCHANNEL 1"

CALL:TCHannel:CMODe:LSPeech:CHANnel

Function

GSM TA

 This command is not applicable to the GPRS test application.

GPRS TA

 This command is not applicable to the GPRS test application.

EGPRS TA

 This command is not applicable to the EGPRS test application.

GSM/GPRS LA

Sets/queries the logical speech channel.

EGPRS LA

Setting

Range: FS|EFS|HS|AFS|AHS|WFS

Query

Returns: FS|EFS|HS|AFS|AHS|WFS

*RST Setting

FS
Requirements GSM TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: D.01 and above

Revision: F.00.13 add WFS

Programming Example

OUTPUT 714;"CALL:TCHANNEL:CMODe:LSPeech:CHANnel AFS"
! Sets the logical speech channel type to AFS (Adaptive Full).

CALL:TCHannel:CMODe:WFSPeech:CODec

Function

GSM TA

 This command is not applicable to the GPRS test application.

GPRS TA

 This command is not applicable to the GPRS test application.

EGPRS TA

 This command is not applicable to the EGPRS test application.

GSM/GPRS LA

Sets/queries the WFS (Wideband Full) codecs that are in the WFS Codec Set.

EGPRS LA

Setting

Range: WFS6600|WFS8850|WFS12650|UNUSed

NOTE: The Codec Set must be defined in order, with codec 1 being first and codec 3 being last. Also, the codec rates must be in ascending order such that the codec with lowest rate is first and the codec with the highest rate is last.

Query

Returns: WFS6600|WFS8850|WFS12650|UNUSed

*RST Setting

WFS6600|WFS8850|WFS12650
Requirements

 GSM/GPRS/ EGPRS LA

Revision: F.00.13 and above

GSM/GPRS/ EGPRS TA

Revision: A.09 and above with required feature license.

Programming Example 1

OUTPUT 714;"CALL:TCHannel:CMODe:LSPeech:CHANnel WFS"
! Sets the logical speech channel to WFS (Wideband Full Rate).

OUTPUT 714;"CALL:TCHANNEL:CMODe:WFSPeech:CODec WFS6600,WFS8850,WFS12650"
! Defines which codecs are in the WFS Codec Set.

OUTPUT 714;"CALL:TCHANNEL:CMODe:WFSPeech:CODec:CURRent WFS6600"
! Sets the codec that the mobile station will use to WFS6600.

OUTPUT 714;"CALL:TCHANNEL:CMODe:WFSPeech:CODec:THReshold 6,1.5,10.5,2"
! Sets the threshold and hysteresis values.
! These four commands are sufficient to completely define the WFS Codec Set.

Programming Example 2

OUTPUT 714;"CALL:TCHannel:CMODe:WFSPeech:CODec WFS12650,UNUSed,UNUSed"
! Defines only one codec in the WFS Codec Set. Note: There must be three parameters for this command.

CALL:TCHannel:CMODe:WFSPeech:CODec:CURRent

Function

GSM TA

 This command is not applicable to the GPRS test application.

GPRS TA

 This command is not applicable to the GPRS test application.

EGPRS TA

 This command is not applicable to the EGPRS test application.

GSM/GPRS LA

Sets/queries which codec from the WFS Codec Set that is being used.
EGPRS LA

Setting

Range: WFS6600|WFS8850|WFS12650|STR|MSR

NOTE: The current codec can only be changed to another codec within the codec set and, when the operating mode is Active, STRESS or MSReqest can be chosen.

Query

Returns: WFS6600|WFS8850|WFS12650|STR|MSR

*RST Setting

 WFS6600
Requirements

 GSM/GPRS/ EGPRS LA

Revision: F.00.13 and above

GSM/GPRS/ EGPRS TA

Revision: A.09 and above with required feature license.

Programming Example

OUTPUT 714;"CALL:TCHannel:CMODe:LSPeech:CHANnel WFS"
! Sets the logical speech channel to WFS (Wideband Full Rate).

OUTPUT 714;"CALL:TCHANNEL:CMODe:WFSPeech:CODec WFS6600,WFS8850,WFS12650"
! Defines which codecs are in the WFS Codec Set.

OUTPUT 714;"CALL:TCHANNEL:CMODe:WFSPeech:CODec:CURRent WFS6600"
! Sets the codec that the mobile station will use to WFS6600.

OUTPUT 714;"CALL:TCHANNEL:CMODe:WFSPeech:CODec:THReshold 6,1.5,10.5,2"
! Sets the threshold and hysteresis values.
! These four commands are sufficient to completely define the WFS Codec Set.

CALL:TCHannel:CMODe:WFSPeech:CODec:THReshold

Function

GSM TA

 This command is not applicable to the GPRS test application.

GPRS TA

 This command is not applicable to the GPRS test application.

EGPRS TA

 This command is not applicable to the EGPRS test application.

GSM/GPRS LA

Sets/queries the threshold and hysteresis values, which determine when the current codec needs to be changed in the WFS Codec Set.

EGPRS LA

Setting

Range: Threshold Values: 0 to 31.5 dB, Hysteresis Values: 0 to 7.5

Resolution: .5 dB

Query

Range: Threshold Values: 0 to 31.5 dB, Hysteresis Values: 0 to 7.5

Resolution: .5 dB

*RST Setting

 6.5,2, 12.5,2
Requirements

 GSM/GPRS/ EGPRS LA

Revision: F.00.13 and above

GSM/GPRS/ EGPRS TA

Revision: A.09 and above with required feature license.

Programming Example

OUTPUT 714;"CALL:TCHannel:CMODe:LSPeech:CHANnel WFS"
! Sets the logical speech channel to WFS (Wideband Full Rate).

OUTPUT 714;"CALL:TCHANNEL:CMODe:WFSPeech:CODec WFS6600,WFS8850,WFS12650"
! Defines which codecs are in the WFS Codec Set.

OUTPUT 714;"CALL:TCHANNEL:CMODe:WFSPeech:CODec:CURRent WFS6600"
! Sets the codec that the mobile station will use to WFS6600.

OUTPUT 714;"CALL:TCHANNEL:CMODe:WFSPeech:CODec:THReshold 6,1.5,10.5,2"
! Sets the threshold and hysteresis values.
! These four commands are sufficient to completely define the WFS Codec Set.

CALL:TCHannel:CUSTom:DATA

Function

GSM TA

This command sets/queries the values used when the Custom option is selected. See CUSTom for more information. The GPIB command to set the downlink speech to Custom is CALL:TCHannel:DOWNlink:SPEech .

Note: The same custom data is used for GPRS Payload Pattern (BLER) , GPRS Payload Pattern (OTHER) and GSM Speech .

GPRS TA
EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

A comma separated list of 1 to 174 values:

Range: 0 to 255

Resolution: 1
Query

A comma separated list of decimal values:

Range: 0 to 255

Resolution: 1
*RST setting 0xff, 0xfe, 0x00, 0x04, 0x00, 0x18, 0x00, 0x50,0x01, 0xe0, 0x04, 0x40, 0x19, 0x80, 0x55, 0x01,0xfe, 0x04, 0x04, 0x18, 0x18, 0x50, 0x51, 0xe1,0xe4, 0x44, 0x59, 0x99, 0xd5, 0x54, 0xff, 0xfa,0x00, 0x1c, 0x00, 0x48, 0x01, 0xb0, 0x05, 0xa0,0x1d, 0xc0, 0x4c, 0x81, 0xab, 0x05, 0xfa, 0x1c,0x1c, 0x48, 0x49, 0xb1, 0xb5, 0xa5, 0xbd, 0xdd,0x8c, 0xcd, 0x2a, 0xae, 0xff, 0xe6, 0x00, 0x54,0x01, 0xf8, 0x04, 0x10, 0x18, 0x60, 0x51, 0x41,0xe7, 0x84, 0x51, 0x19, 0xe6, 0x54, 0x55, 0xf9,0xfc, 0x14, 0x08, 0x78, 0x31, 0x10, 0xa6, 0x63,0xd5, 0x48, 0xff, 0xb2, 0x01, 0xac, 0x05, 0xe8,0x1c, 0x70, 0x49, 0x21, 0xb6, 0xc5, 0xb6, 0x9d,0xb7, 0x4d, 0xb3, 0xad, 0xa9, 0xed, 0xf4, 0x6c,0x39, 0x68, 0x97, 0x73, 0x73, 0x2b, 0x2a, 0xfa,0xfe, 0x1e, 0x04, 0x44, 0x19, 0x98, 0x55, 0x51,0xff, 0xe4, 0x00, 0x58, 0x01, 0xd0, 0x04, 0xe0,0x1a, 0x40, 0x5d, 0x81, 0xcd, 0x04, 0xae, 0x1b,0xe4, 0x58, 0x59, 0xd1, 0xd4, 0xe4, 0xfa, 0x5a,0x1d, 0xdc, 0x4c, 0xc9, 0xaa, 0xb5, 0xff, 0xbc,0x01, 0x88, 0x05, 0x30, 0x1e, 0xa0, 0x47, 0xc1,0x90, 0x85, 0x63, 0x1f, 0x4a, 0x43

Requirements

 GSM/ GPRS/ EGPRS TA

Revision: A.04 and above
GSM/GPRS/ EGPRS LA

Revision: D.01 and above

Programming Example

OUTPUT 714;"CALL:TCHannel:CUSTom:DATA #ha5,#hfe,#h9b"
! Sets the values for the custom data pattern.
! Note: These values were entered in hexadecimal format. The format to enter
! hexadecimal values is #hXX where X can be any value 0-9 of letters a,b,c,d,e or f.

OUTPUT 714;"CALL:TCHannel:CUSTom:DATA?"
! This query of the previous command returns +165,+254,+155,
! which is the decimal form of the values defined in the custom data pattern.

CALL:TCHannel:DAINterface:TINTerface

Function

GSM TA

 This command is not applicable to the GPRS test application.

GPRS TA

 This command is not applicable to the GPRS test application.
EGPRS TA | This command is not applicable to the EGPRS test application.

GSM/GPRS LA

This command set the Test Interface for Digital Audio Interface (DAI). See Digital Audio Interface (DAI) Description for more information.

EGPRS LA
Setting

Range:

  • OFF: Set the DAI Test Interface to Off.
  • SDECoder: Set the DAI Test Interface to Speech Decoder.
  • SENCoder: Set the DAI Test Interface to Speech Encoder.
  • ACOustic: Set the DAI Test Interface to Acoustic.
*RST setting | OFF

Requirements

 GSM/GPRS/ EGPRS LA

Revision: F.00.13 and above

Programming Example

OUTPUT 714;"CALL:TCHannel:DAINterface:TINTerface SENCoder"
! Sets the DAI Test Interface to Speech Encoder.

CALL:TCHannel:DOWNlink:DTX[:STATe]

Function

GSM TA

 This command is not applicable to the GPRS test application.

GPRS TA

 This command is not applicable to the GPRS test application.
EGPRS TA | This command is not applicable to the EGPRS test application.

GSM/GPRS LA

This command sets the Downlink Discontinuous Transmission state. When the downlink DTX state is set to ON, the test set turns its transmit power off during a voice call when there is nothing to transmit.

EGPRS LA
Setting

Range: 1|ON|0|OFF
Query

1|0
*RST setting | 0|OFF

Requirements

 GSM/GPRS/ EGPRS LA

Revision: F.00.27 and above

Programming Example

OUTPUT 714;"CALL:TCHannel:DOWNlink:DTX ON"
! Sets the downlink DTX state to ON.

CALL:TCHannel:DOWNlink:SPEech

Function

GSM TA

This command sets/queries the Speech data configuration that is transmitted on the downlink TCH. For information on the downlink speech source parameters, see Speech .

The command to configure the Custom payload pattern is CALL:TCHannel:CUSTom:DATA .

The command to set the Speech Echo Loopback Delay is CALL:TCHannel:DOWNlink:SPEech:LOOPback:DELay .

See also Fast Bit Error Measurement Description , Test Mode Operating Modes , or Multi-tone Audio Measurement Description .

GSM/GPRS LA

EGPRS LA

GPRS TA

 This command is not applicable to GPRS.

EGPRS TA

 This command is not applicable to EGPRS.

Setting

 GSM TA

Range: ECHO | NONE | PRBS15 | PRBS9 | SIN300 | SIN1000 | SIN3000|MULTITONE| CUSTom

GSM/GPRS LA

Range: ECHO | NONE | PRBS15 | PRBS9 | SIN300 | SIN1000 | SIN3000|MULTITONE|SID| CUSTom

EGPRS LA

Query

 GSM TA

Range: ECHO | NONE | PRBS15 | PRBS9 | SIN300 | SIN1000 | SIN3000|MULTITONE|CUST

GSM/GPRS LA

Range: ECHO | NONE | PRBS15 | PRBS9 | SIN300 | SIN1000 | SIN3000|MULTITONE|SID |CUST

EGPRS LA

*RST Setting

ECHO

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.01 and above
Revision A.04 adds CUSTOM as a parameter value
Revision A.09 adds PRBS9 as a parameter value with required feature license.
GSM/GPRS/ EGPRS LA

Revision: C.01 and above;
Revision C.03 adds SID as a parameter value
Revision D.01 adds CUSTOM as a parameter value
Revision F.01 adds PRBS9 as a parameter value

Programming Example

OUTPUT 714;"CALL:TCHannel:DOWNlink:SPEech ECHO"

CALL:TCHannel:DOWNlink:SPEech:LOOPback:DELay

Function

GSM TA

This command sets/queries the Speech Echo Loopback Delay parameter. The Speech Echo Loopback Delay parameter determines the amount of time that speech frames received on the uplink are delayed before being retransmitted on the downlink.

The Speech Echo Loopback Delay can be set regardless of the Downlink Speech Source setting, however it is only applicable when the Speech Source is set to ECHO. The command to set the Speech Source is CALL:TCHannel:DOWNlink:SPEech .

For more information refer to Speech .

GSM/GPRS LA

EGPRS LA

GPRS TA

 This command is not applicable to GPRS.

EGPRS TA

 This command is not applicable to EGPRS.

Setting

Range: 0 to 4 seconds

Resolution: .02 seconds

Query

Range: 0 to 1 seconds

Resolution: .02 seconds

*RST Setting

 1 second

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.05

Revision: A.09 extends the range from 1 seconds to 4 seconds
GSM/GPRS/ EGPRS LA

Revision: D.02.

Revision: F.01 extends the range from 1 seconds to 4 seconds

Programming Example

OUTPUT 714;"CALL:TCHannel:DOWNlink:SPEech:LOOPback:DELay .5"
! Sets the speech echo loopback delay to .5 seconds.

CALL:TCHannel:(FACCH|FACChannel):MS:TXLevel

Function

GSM TA

 This command is not applicable to the GSM test applications.
GPRS TA

This command is not applicable to the GPRS test applications.

EGPRS TA

 This command is not applicable to the EGPRS test applications.
GSM/GPRS LA

Sets/queries the TX Level FACCH Signaling parameter.

When TX Level FACCH Signaling is set to on, the base station emulator uses both a FACCH (Fast Associated Control CHannel) channel assignment and an update to the SACCH (Slow Associated Control CHannel) header to signal the mobile to change to a new power level.

When TX Level FACCH Signaling is set to off, the base station emulator uses only an update to the SACCH header to signal the mobile to change to a new power level. A FACCH channel assignment message is not sent. This setting is useful if you want to update the SACCH header's TX Level field without performing a channel assignment.

The setting of TX Level FACCH Signaling can be changed in either of the test set's two operating modes, Active Cell or Test mode.

EGPRS LA

Setting

Range: 1 | ON | 0 | OFF

Query

1 | 0

*RST Setting

 1 | ON
Requirements GSM/GPRS/ EGPRS LA

Revision: E.00.12 and above

Programming Example

OUTPUT 714;"CALL:TCHannel:FACCH:MS:TXLevel 0"
! Turns the TX Level Signaling parameter OFF.

CALL:TCHannel:(FACCH|FACChannel):REPeat[:STATe]

Function

GSM TA

 This command is not applicable to the GSM Test Application.

GPRS TA

 This command is not applicable to the GPRS Test Application.

EGPRS TA

 This command is not applicable to the EGPRS Test Application.
GSM/GPRS LA

Sets/queries the state of the Repeated FACCH parameter.

Please see Repeated Downlink FACCH for more details.

EGPRS LA

Setting

Range: 1 | ON | 0 | OFF

Query

1 | 0

*RST Setting

 0 | OFF
Requirements GSM/GPRS/ EGPRS LA

Revision: E.00.12 and above

Programming Example

OUTPUT 714;"CALL:TCHannel:FACCH:REPeated ON"
! Turns on the Repeated FACCH parameter.

CALL:TCHannel:FHOPping[:STATe]

Function

GSM TA

 This command is not applicable to the GSM Test Application.

GPRS TA

 This command is not applicable to the GPRS Test Application.

EGPRS TA

 This command is not applicable to the EGPRS Test Application.

GSM/GPRS LA

 This command enables/queries the state of Frequency Hopping for GSM traffic channels.

EGPRS LA
Setting | Range: 0 | OFF | 1 | ON
Query | Range: 0 | 1
*RST setting | 0 |OFF
Requirements GSM/GPRS/ EGPRS LA

Revision: D.01 and above

Programming Example

OUTPUT 714;"CALL:TCHannel:FHOPping ON"
! Enables Frequency Hopping.

CALL:TCHannel:FHOPping:HSNumber

Function

GSM TA

 This command is not applicable to the GSM Test Application.

GPRS TA

 This command is not applicable to the GPRS Test Application.

EGPRS TA

 This command is not applicable to the EGPRS Test Application.

GSM/GPRS LA

Sets which hopping sequence the test set uses to switch between available frequencies for the GSM traffic channels. There are 64 different hopping sequences, numbered from 0-63. When the Hopping Sequence Number (HSN) is zero, it corresponds to a cyclic hopping sequence. All other HSNs correspond to different pseudo random hopping sequences.

If this command is attempted while there is an active DTM connection or while the test set is in a DTM test operating mode, it is stored and applied when the test set is no longer in Dual Transfer Mode.

EGPRS LA
Setting Range: 0 to 63
Resolution: 1
Query Range: 0 to 63
Resolution: 1
*RST setting 0
Requirements GSM/GPRS/ EGPRS LA

Revision: D.01 and above

Programming Example

OUTPUT 714;"CALL:TCHannel:FHOPping:HSNumber 55"
! Sets the Hopping Sequence Number (HSN) to 55.

CALL:TCHannel:FHOPping:MAIoffset:[SELected]

CALL:TCHannel:FHOPping:MAIoffset:(DCS|EGSM|GSM450|GSM480|GSM750|GSM850|PCS|PGSM|RGSM|TGSM810)

Function

GSM TA

 This command is not applicable to the GSM Test Application.

GPRS TA

 This command is not applicable to the GPRS Test Application.

EGPRS TA

 This command is not applicable to the EGPRS Test Application.

GSM/GPRS LA

This command sets/queries the Mobile Allocation Index Offset (MAIO) for the GSM traffic channels. The MAIO determines where in the Mobile Allocation (MA) Table the hopping sequence begins. If the MAIO is set to a value greater than the number of entries in the Mobile Allocation (MA) Table, the MAIO shall be set to zero.

The optional [SELected] keyword in this command specifies that the channel being set/queried applies to the current cell band.

If this command is attempted while there is an active DTM connection or while the test set is in a DTM test operating mode, it is stored and applied when the test set is no longer in Dual Transfer Mode.

EGPRS LA
Setting

Range: 0 to 15

Resolution: 1
Query

Range: 0 to 15

Resolution: 1
*RST setting 0
Requirements GSM/GPRS/ EGPRS LA

Revision: D.01 and above

Revision D.03 adds the TGSM810 band.

Programming Example

OUTPUT 714;"CALL:TCHannel:FHOPping:MAIOffset 8"
! Sets MAIO so it starts in the middle Mobile Allocation (MA) table,
! which contains the available frequencies.

CALL:TCHannel:LOOPback

Function

GSM TA

Sets traffic channel loopback state and type for the MS.

The loopback type must be set before a Fast Bit Error or a Bit Error measurement will function. See Mobile Loopback .

The test set will automatically set the correct loopback type if the signalling loopback control is set to on, after the measurement the test set will automatically set the loopback to off. See SETup:BERRor:SLControl[:STATe] or SETup:FBERror:SLControl[:STATe] .

See Fast Bit Error Measurement Description or GSM Bit Error Measurement .

GSM/GPRS LA

EGPRS LA

GPRS TA

 This command is not applicable to GPRS.

EGPRS TA

 This command is not applicable to EGPRS.

Setting

Range: OFF | A | B | C | D

  • OFF - Sets the TCH Loop state for the MS to OFF. The loop back is open.

  • A- Sets the TCH Loop state for the MS to type A. Full-rate speech TCH loopback with signaling of erased frames, (residual).

  • B- Sets the TCH Loop state for the MS to type B. Full-rate speech TCH loopback without signalling of erased frames, (non-residual).

  • C - Sets the TCH Loop state for the MS to type C. TCH burst by burst loopback.

  • D - Sets the TCH Loop state for the MS to type D. Full-rate speech TCH loopback with signaling of erased frames and unreliable frame rate. Note that loopback type D is only available in the E6701F lab applications.

*RST Setting

OFF

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Revision: F.00.27 adds loopback type D.

Programming Example

OUTPUT 714;"CALL:TCHANNEL:LOOPBACK C"
! Sets loopback type.

CALL:TCHannel:MA:MEASurement:ARFCn:(SELected]

CALL:TCHannel:MA:MEASurement:ARFCn:(DCS|EGSM|GSM450|GSM480|GSM750|GSM850|PCS|PGSM|RGSM|TGSM810)

Function

GSM TA

 This command is not applicable to the GSM Test Application.

GPRS TA

 This command is not applicable to the GPRS Test Application.

EGPRS TA

 This command is not applicable to the EGPRS Test Application.

GSM/GPRS LA

This command sets/queries the ARFCN the measurement down converter is set to in the MA Table for a particular cell band for GSM traffic channels.

The optional [SELected] keyword in this command specifies that the channel being set/queried applies to the current cell band.

If this command is attempted while there is an active DTM connection or while the test set is in a DTM test operating mode, it is stored and applied when the test set is no longer in Dual Transfer Mode.

EGPRS LA
Setting

Range:

  • DCS band, channels 512 to 885
  • EGSM band, channels 0 to 124 and 975 to 1023
  • GSM450 band, channels 259 to 293
  • GSM480 band, channels 306 to 340
  • GSM750 band, channels 438 to 511
  • GSM850 band, channels 128 to 251
  • PCS band, channels 512 to 810
  • PGSM band, channels 1 to 124
  • RGSM band, channels 0 to 124 and 955 to 1023
  • TGSM810 band, channels 350 to 425

Resolution: 1
Query

Range:

  • DCS band, channels 512 to 885
  • EGSM band, channels 0 to 124 and 975 to 1023
  • GSM450 band, channels 259 to 293
  • GSM480 band, channels 306 to 340
  • GSM750 band, channels 438 to 511
  • GSM850 band, channels 128 to 251
  • PCS band, channels 512 to 810
  • PGSM band, channels 1 to 124
  • RGSM band, channels 0 to 124 and 955 to 1023
  • TGSM810 band, channels 350 to 425

Resolution: 1
*RST setting +9.91E37 (NAN)
Requirements GSM/GPRS/ EGPRS LA

Revision: D.01 and above

D.03 adds the TGSM810 band.

Programming Example

OUTPUT 714;"CALL:TCHannel:MA:MEASurement:PCS 661"
! Sets measurement ARFCN to 661.

CALL:TCHannel:MA:TABLe[:AUTO]:[SELected]?

CALL:TCHannel:MA:TABLe[:AUTO]:(DCS|EGSM|GSM450|GSM480|GSM750|GSM850|PCS|PGSM|RGSM|TGSM810)?

Function

GSM TA

 This command is not applicable to the GSM Test Application.

GPRS TA

 This command is not applicable to the GPRS Test Application.

EGPRS TA

 This command is not applicable to the EGPRS Test Application.

GSM/GPRS LA

This command queries the channels in the Mobile Allocated (MA) Table for the selected band for a GSM traffic channel.

The optional [SELected] keyword in this command specifies that the channel being set/queried applies to the current cell band.

EGPRS LA
Query

Depends on the selected band.

Range:

  • DCS band, channels 512 to 885
  • EGSM band, channels 0 to 124 and 975 to 1023
  • GSM450 band, channels 259 to 293
  • GSM480 band, channels 306 to 340
  • GSM750 band, channels 438 to 511
  • GSM850 band, channels 128 to 251
  • PCS band, channels 512 to 810
  • PGSM band, channels 1 to 124
  • RGSM band, channels 0 to 124 and 955 to 1023
  • TGSM810 band, channels 350 to 425

Resolution: 1
*RST setting

Depends on the selected band. (PGSM is the default band.)

  • DCS: 520, 661, 810, 885

  • EGSM: 1, 124, 975

  • GSM450: 259, 293

  • GSM480: 306, 340

  • GSM750: 438, 511

  • GSM850: 128, 251

  • PCS: 520, 661, 810

  • PGSM: 1, 124

  • RGSM: 1, 124, 955, 975

  • TGSM810: +9.91E37 (NAN)
Requirements GSM/GPRS/ EGPRS LA

Revision: D.01 and above

D.03 adds the TGSM810 band.

Programming Example

OUTPUT 714;"CALL:TCHannel:MA:TABLe:PGSM?"
! Queries the channels listed in the Mobile Allocated (MA) Table for the PGSM band.

CALL:TCHannel:MA:TABLe[:AUTO]:POINts:[SELected]?

CALL:TCHannel:MA:TABLe[:AUTO]:POINts:(DCS|EGSM|GSM450|GSM480|GSM750|GSM850|PCS|PGSM|RGSM|TGSM810)?

Function

GSM TA

 This command is not applicable to the GSM Test Application.

GPRS TA

 This command is not applicable to the GPRS Test Application.

EGPRS TA

 This command is not applicable to the EGPRS Test Application.

GSM/GPRS LA

This command queries the number of channels in the Mobile Allocated (MA) Table for the selected band for a GSM traffic channel.

The optional [SELected] keyword in this command specifies that the channel being set/queried applies to the current cell band.

If this command is attempted while there is an active DTM connection or while the test set is in a DTM test operating mode, it is stored and applied when the test set is no longer in Dual Transfer Mode.

EGPRS LA
Query

Range: 1 to 16

Resolution: 1
*RST setting
  • DCS: 4

  • EGSM: 3

  • GSM450: 2

  • GSM480: 2

  • GSM750: 2

  • GSM850: 2

  • PCS: 3

  • PGSM: 2

  • RGSM: 4

  • TGSM810: 0
Requirements GSM/GPRS/ EGPRS LA

Revision: D.01 and above

D.03 adds the TGSM810 band.

Programming Example

OUTPUT 714;"CALL:TCHannel:MA:TABLe:POINts:PCS?"
! Queries how many ARFCNs are in the Mobile Allocation (MA) Table for the PCS band.

CALL:TCHannel:MA:TABLe:CONFig:AUTO

Function

GSM TA

 This command is not applicable to the GSM Test Application.

GPRS TA

 This command is not applicable to the GPRS Test Application.

EGPRS TA

 This command is not applicable to the EGPRS Test Application.

GSM/GPRS LA

This command sets/queries the state of Mobile Allocation (MA) Table configuration for GSM data traffic channels. If the configuration state is OFF you can update the MA Tables manually. If the configuration state is ON the test set automatically populates the MA Tables for each cell band with the applicable values in the CA Table. The command to set the CA Table entries is: CALL:CA:TABLe .

If this command is attempted while there is an active DTM connection or while the test set is in a DTM test operating mode, it is stored and applied when the test set is no longer in Dual Transfer Mode.

EGPRS LA
Setting | Range: 0 | OFF | 1 | ON
Query | Range: 0 | 1
*RST setting | 1|ON
Requirements GSM/GPRS/ EGPRS LA

Revision: D.01 and above

Programming Example

OUTPUT 714;"CALL:TCHannel:MA:TABLe:CONFig:AUTO ON"
! Enables automatic configuation of the Mobile Allocation (MA) Table.

CALL:TCHannel:MA:TABLe:MANual:[SELected]

CALL:TCHannel:MA:TABLe:MANual:(DCS|EGSM|GSM450|GSM480|GSM750|GSM850|PCS|PGSM|RGSM|TGSM810)

Function

GSM TA

 This command is not applicable to the GSM Test Application.

GPRS TA

 This command is not applicable to the GPRS Test Application.

EGPRS TA

 This command is not applicable to the EGPRS Test Application.

GSM/GPRS LA

This command sets/queries the ARFCNs that were manually assigned to the Mobile Allocated (MA) Table for a GSM traffic channel. ARFCNs are entered into the MA Table using a comma separated list of up to 16 values. Only values that are in the Cell Allocation (CA) Table are valid entries in the MA Table.

The optional [SELected] keyword in this command specifies that the channel being set/queried applies to the current cell band.

The command for configuring the CA Table is CALL:CA:TABLe .

If this command is attempted while there is an active DTM connection or while the test set is in a DTM test operating mode, it is stored and applied when the test set is no longer in Dual Transfer Mode.

EGPRS LA
Setting

Range:

  • DCS band, channels 512 to 885
  • EGSM band, channels 0 to 124 and 975 to 1023
  • GSM450 band, channels 259 to 293
  • GSM480 band, channels 306 to 340
  • GSM750 band, channels 438 to 511
  • GSM850 band, channels 128 to 251
  • PCS band, channels 512 to 810
  • PGSM band, channels 1 to 124
  • RGSM band, channels 0 to 124 and 955 to 1023
  • TGSM810 band, channels 350 to 425

Resolution: 1
Query

Range:

  • DCS band, channels 512 to 885
  • EGSM band, channels 0 to 124 and 975 to 1023
  • GSM450 band, channels 259 to 293
  • GSM480 band, channels 306 to 340
  • GSM750 band, channels 438 to 511
  • GSM850 band, channels 128 to 251
  • PCS band, channels 512 to 810
  • PGSM band, channels 1 to 124
  • RGSM band, channels 0 to 124 and 955 to 1023
  • TGSM810 band, channels 350 to 425

Resolution: 1
*RST setting

  • DCS: 520, 661, 810, 885

  • EGSM: 1, 124, 975

  • GSM450: 259, 293

  • GSM480: 306, 340

  • GSM750: 438, 511

  • GSM850: 128, 251

  • PCS: 520, 661, 810

  • PGSM: 1, 124

  • RGSM: 1, 124, 955, 975

  • TGSM810: +9.91E37 (NAN)
Requirements GSM/GPRS/ EGPRS LA

Revision: D.01 and above

D.03 adds the TGSM810 band.

Programming Example

OUTPUT 714;"CALL:TCHannel:ARFCn:SELected 512"
! Sets the ARFCN of the selected band to 512, if 512 is valid for the selected band.

CALL:TCHannel:MA:TABLe:MANual:POINts:[SELected]?

CALL:TCHannel:MA:TABLe:MANual:POINts:(DCS|EGSM|GSM450|GSM480|GSM750|GSM850|PCS|PGSM|RGSM|TGSM810)?

Function

GSM TA

 This command is not applicable to the GSM test application.

GPRS TA

 This command is not applicable to the GPRS test application.

EGPRS TA

 This command is not applicable to the EGPRS test application.

GSM/GPRS LA

This command queries the number of ARFCNs that were manually assigned to the Mobile Allocated (MA) Table for a GSM traffic channel. The command to set the values of the MA Table of a particular band is CALL:(PDTCH|PDTChannel):MA:TABLe:MANual[:SELected] .

The optional [SELected] keyword in this command specifies that the channel being set/queried applies to the current cell band.

If this command is attempted while there is an active DTM connection or while the test set is in a DTM test operating mode, it is stored and applied when the test set is no longer in Dual Transfer Mode.

EGPRS LA
Query

Range: 1 through 16

Resolution: 1
*RST setting
  • DCS: 4

  • EGSM: 3

  • GSM450: 2

  • GSM480: 2

  • GSM750: 2

  • GSM850: 2

  • PCS: 3

  • PGSM: 2

  • RGSM: 4

  • TGSM810: 0
Requirements GSM/GPRS/ EGPRS LA

Revision: D.01 and above

D.03 adds the TGSM810 band.

Programming Example

OUTPUT 714;"CALL:TCHannel:MA:TABLe:MANual:POINts:PCS?"
! Queries how many ARFCNs  the Mobile Allocated (MA) contains.

CALL:TCHannel:POWer[:AMPLitude]?

Function

GSM TA

 Queries the downlink traffic channel used burst power amplitude in dB.

GSM/GPRS LA

EGPRS LA

GPRS TA

This command is not applicable to GPRS.

EGPRS TA

 This command is not applicable to EGPRS.

Query

Range: -10 to -172 dBm
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:TCHANNEL:POWer?"
! Queries traffic channel power level of used bursts.

CALL:TCHannel:POWer[:AMPLitude]:ADJacent?

Function

GSM TA

Queries the downlink traffic channel adjacent burst power amplitude in dBm.

This command replaces CALL:TCHannel:POWer[:AMPLitude]? .

GSM/GPRS LA

EGPRS LA

GPRS TA

This command is not applicable to GPRS.

EGPRS TA

 This command is not applicable to EGPRS.
Requirements GSM/GPRS/
EGPRS TA

Revision: A.04 and above
GSM/GPRS/ EGPRS LA

Revision: D.01 and above

Programming Example

OUTPUT 714;"CALL:TCHANNEL:POWer:UBURst?"
! Queries traffic channel power level of Unused bursts.

CALL:TCHannel:POWer[:AMPLitude]:UBURst?

Function

GSM TA

THIS COMMAND IS OBSOLETE.

Please use CALL:TCHannel:POWer[:AMPLitude]:ADJacent? instead.

This command queries the downlink traffic channel unused burst power amplitude in dBm.

GSM/GPRS LA

EGPRS LA

GPRS TA

This command is not applicable to GPRS.

EGPRS TA

 This command is not applicable to EGPRS.
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:TCHANNEL:POWer:UBURst?"
! Queries traffic channel power level of Unused bursts.

CALL:TCHannel:POWer[:AMPLitude]:UNUSed?

Function

GSM TA

This command is not applicable to GSM Test Application.

GPRS TA

This command is not applicable to GPRS Test Application.

EGPRS TA

This command is not applicable to EGPRS Test Application.

GSM/GPRS LA

 This command queries the downlink traffic channel unused burst power amplitude in dBm.

EGPRS LA
Requirements GSM/GPRS/ EGPRS LA

Revision: F.00.27 and above

Programming Example

OUTPUT 714;"CALL:TCHANNEL:POWer:UNUSed?"
! Queries traffic channel power level of Unused bursts.

CALL:TCHannel:PREDuction:ADJacent

Function

GSM TA

This command queries/sets the power reduction level to use for the downlink traffic channel adjacent burst power. One of two power reduction levels can be selected; PRLevel1 or PRLevel2. When frequency hopping is enabled, the bursts before and after the downlink traffic channel are returned. Otherwise, the unused bursts in the downlink traffic channel power are returned. See Frequency Hopping for more information,

This command replaces CALL:TCHannel:PREDuction:UBURst .

GSM/GPRS LA

EGPRS LA

GPRS TA

This command is not applicable to GPRS.

EGPRS TA

 This command is not applicable to EGPRS.

Setting

Range: PRLevel1 | PRLevel2

Query

Range: PRL1 | PRL2

*RST Setting

PRL2

Related Commands

CALL:TCHannel:PREDuction
Requirements GSM/GPRS/
EGPRS TA

Revision: A.04 and above
GSM/GPRS/ EGPRS LA

Revision: D.01 and above

Programming Example

OUTPUT 714;"CALL:TCHannel:PREDuction:UBURst PRLevel1"
! Selects the traffic channel power reduction level 1 for unused bursts.

CALL:TCHannel:PREDuction:BURSt

Function

GSM TA

Specifies the power reduction level to use for the downlink traffic channel burst power. One of two power reduction levels can be selected; PRLevel1 or PRLevel2.

If this command is attempted while there is an active DTM connection or while the test set is in a DTM test operating mode, it is stored and applied when the test set is no longer in Dual Transfer Mode.

GSM/GPRS LA

EGPRS LA

GPRS TA

This command is not applicable to GPRS.

EGPRS TA

 This command is not applicable to EGPRS.

Setting

Range: PRLevel1 | PRLevel2

Query

Range: PRL1 | PRL2

*RST Setting

PRL1
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:TCHANNEL:PREDuction:BURSt PRLevel2"
! Selects traffic channel power reduction level 2 for used bursts

CALL:TCHannel:PREDuction:LEVel([1]|2)

Function

GSM TA

Sets the value in dB to the traffic channel power reduction levels PRL1 and PRL2.

If this command is attempted while there is an active DTM connection or while the test set is in a DTM test operating mode, it is stored and applied when the test set is no longer in Dual Transfer Mode.

GSM/GPRS LA

EGPRS LA

GPRS TA

This command is not applicable to GPRS.

EGPRS TA

 This command is not applicable to EGPRS.

Setting

Range: 0 to 25 dB

Resolution: 0.1 dB

Query

Range: 0 to 25 dB

*RST Setting

0 dB
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:TCHANNEL:PREDuction:LEVel2 5"
! Sets traffic channel power reduction level 2 to 5 dB.

CALL:TCHannel:PREDuction:UBURst

Function

GSM TA

THIS COMMAND IS OBSOLETE.

Please use CALL:TCHannel:PREDuction:ADJacent instead.

This command specifies the power reduction level to use for the downlink traffic channel unused burst power. One of two power reduction levels can be selected; PRLevel1 or PRLevel2.

GSM/GPRS LA

EGPRS LA

GPRS TA

This command is not applicable to GPRS.

EGPRS TA

 This command is not applicable to EGPRS.

Setting

Range: PRLevel1 | PRLevel2 | OFF

Query

Range: PRL1 | PRL2 | OFF

*RST Setting

OFF

Related Commands

CALL:TCHannel:PREDuction
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:TCHANNEL:PREDuction:UBURst PRLevel1"
! Selects the traffic channel power reduction level 1 for unused bursts.

CALL:TCHannel:PREDuction:UNUSed

Function

GSM TA

This command is not applicable to GSM Test Application.

GPRS TA

This command is not applicable to GPRS Test Application.

EGPRS TA

This command is not applicable to EGPRS Test Application.

GSM/GPRS LA

This command sets/queries the power reduction level for the unused bursts on the downlink traffic channel. In addition, it can also be used to turn power reduction off (no power transmitted) for the unused bursts.

When Frequency Hopping is turned on, The timeslots needed for transient settling are the three consecutive ones preceding the active timeslot. Therefore, when frequency hopping is on and the power reduction level of the unused bursts are not set to OFF, all unused timeslots, excluding two timeslots which are reserved for transients settling, will be filled with dummy bursts. Note, although the adjacent timeslot to the left of the active timeslot is considered part of the timeslots needed for transient settling, however, it will be filled with dummy burst.

The value of PRL1 and PRL2 can be set with the GPIB command CALL:TCHannel:PREDuction:LEVel([1]|2)

Note: In order to make use of power reduction levels, you must set the downlink traffic channel to be on a different ARFCN from the broadcast channel (BCH). This is because the power level across all timeslots on the BCH must remain constant. Therefore, power reduction levels are ignored if the BCH and TCH are on the same ARFCN.

EGPRS LA

Setting

Range: PRLevel1 | PRLevel2 | OFF

Query

Range: PRL1 | PRL2 | OFF

*RST Setting

 OFF
Requirements GSM/GPRS/ EGPRS LA

Revision: F.00.27 and above

Programming Example

OUTPUT 714;"CALL:TCHANNEL:PREDuction:UNUSed PRLevel1"
! Selects the traffic channel power reduction level 1 for unused bursts.

CALL:TCHannel:(SACCH|SACChannel):REPeat[:STATe]

Function

 GSM TA

This command is not applicable to GSM Test Application.
GPRS TA

This command is not applicable to GPRS Test Application.

EGPRS TA

This command is not applicable to EGPRS Test Application.
GSM/GPRS LA

Sets/queries the state of the Repeated SACCH parameter.

Please see Repeated SACCH for more details.

EGPRS LA

Setting

Range: OFF | CONTinuous | REQuest

Query

OFF | CONTinuous | REQuest

*RST Setting

 OFF
Requirements GSM/GPRS/ EGPRS LA

Revision: E.00.12 and above

Programming Example

OUTPUT 714;"CALL:TCHannel:SACCH:REPeat ON"
! Turns on the Repeated SACCH parameter.

CALL:TCHannel:(SACCH|SACChannel):REPeat:ORDer

Function

 GSM TA

This command is not applicable to GSM Test Application.
GPRS TA

This command is not applicable to GPRS Test Application.

EGPRS TA

This command is not applicable to EGPRS Test Application.
GSM/GPRS LA

Sets/queries the Uplink SACCH Repeat Order. When this parameter is set to ON,

Please see Repeated SACCH for more details.

EGPRS LA

Setting

Range: 1 | ON | 0 | OFF

Query

1 | 0

*RST Setting

 0 | OFF
Requirements GSM/GPRS/ EGPRS LA

Revision: E.00.12 and above

Programming Example

OUTPUT 714;"CALL:TCHannel:SACCH:REPeat:ORDer OFF"
! Set the SACCH Repeated Order to OFF.

CALL:TCHannel:SIGNaling:ASSignment:CHANnel

Function

GSM TA

This command sets the Assignment Channel parameter.

GSM/GPRS LA

EGPRS LA

GPRS TA

This command is not applicable to GPRS.

EGPRS TA

 This command is not applicable to EGPRS.

Setting

Range: TCH|SDCCH|SDCChannel

Query

Range: TCH|SDCC

*RST Setting

 TCH
Requirements GSM/GPRS/
EGPRS TA

Revision: A.07 and above
GSM/GPRS/ EGPRS LA

Revision: E.00.12 and above

Programming Example

OUTPUT 714;"CALL:TCHannel:SIGNaling:ASSignment:CHANnel SDCCH"
! Sets the Assignment Channel to use the SDCCH.

CALL:TCHannel:SIGNaling:DCCHannel:CSINdicator

Function

GSM TA

This command is not applicable to GSM Test Application.

GPRS TA

 This command is not applicable to GPRS Test Application.

EGPRS TA

 This command is not applicable to EGPRS Test Application

GSM/GPRS LA

This command sets/queries the type of cell(s) that the mobile station should select when the TCH or SDCCH is released. See Cell Selection Indicator for more information.

EGPRS LA

Setting

Range: OFF | GSM | FDD

Query

Range: OFF | GSM | FDD

*RST Setting

 OFF
Requirements GSM/GPRS/ EGPRS LA

Revision: F.00.27 and above

Programming Example

OUTPUT 714;"CALL:TCHannel:SIGNaling:DCCHannel:CSINdicator GSM"
! Sets the type of the cell to be selected after DCCH release to GSM.

CALL:TCHannel:SIGNaling:DESTination:CHANnel

Function

GSM TA

 This command is not applicable to GSM Test Application.

GPRS TA

This command is not applicable to GPRS Test Application.

EGPRS TA

 This command is not applicable to EGPRS Test Application.

GSM/GPRS LA

This command sets/queries the Destination Channel parameter.

This setting is applied only when CALL:TCHannel:SIGNaling:ASSignment:CHANnel is set to SDCCH.

EGPRS LA

Setting

Range: TCH|SDCCH|SDCChannel

Query

Range: TCH|SDCC

*RST Setting

 TCH
Requirements GSM/GPRS/ EGPRS LA

Revision: E.00.12 and above

Programming Example

OUTPUT 714;"CALL:TCHannel:SIGN:DESTination:CHANnel TCH"
! Sets the Destination Channel type to TCH.

CALL:TCHannel:SIGNaling:(SDCCH|SDCChannel):MS:TADVance[:SELected]

CALL:TCHannel:SIGNaling:(SDCCH|SDCChannel):MS:TADVance:DCS|EGSM|GSM450|GSM480|GSM750|GSM850|PCS|PGSM|RGSM|TGSM810)

Function

GSM TA

 This command is not applicable to the GSM TA.
GPRS TA This command is not applicable to the GPRS TA.

EGPRS TA

 This command is not applicable to the EGPRS TA.

GSM/GPRS LA

This command sets/queries the SDCCH MS Timing Advance value.

EGPRS LA

Setting

For all GSM bands:

  • Range: 0 to 63
  • Resolution: 1

Query

 Same as setting.

*RST Setting

 For all GSM bands: 0
Requirements GSM/GPRS/ EGPRS LA

Revision: E.00.12 and above

Programming Example

OUTPUT 714;"CALL:TCHannel:SIGNaling:SDCCH:TADVance 1"
! Sets the MS Timing Advance to 1 (while on an SDCCH).

CALL:TCHannel:SIGNaling:(SDCCH|SDCChannel):MS:TXLevel[:SELected]

CALL:TCHannel:SIGNaling:(SDCCH|SDCChannel):MS:TXLevel:DCS|EGSM|GSM450|GSM480|GSM750|GSM850|PCS|PGSM|RGSM|TGSM810)

Function

GSM TA

 This command is not applicable to the GSM TA.
GPRS TA This command is not applicable to the GPRS TA.

EGPRS TA

 This command is not applicable to the EGPRS TA.

GSM/GPRS LA

This command sets/queries the SDCCH MS TX Level value.

EGPRS LA

Setting

Depends on the band.

DCS:

  • Range: 0 to 31, Resolution: 1

PCS:

  • Range: 0 to 15, 30, and 31, Resolution: 1

All other bands:

  • Range: 0 to 15, 30, and 31, Resolution: 1

Query

 Same as setting.

*RST Setting

Depends on the band (the default band is PGSM):

PGSM, EGSM RGSM, GSM450, GSM480, GSM750, GSM850, TGSM810 bands: 15,
DCS and PCS bands: 10
Requirements GSM/GPRS/ EGPRS LA

Revision: E.00.12 and above

Programming Example

OUTPUT 714;"CALL:TCHannel:SIGNaling:SDCCH:MS:TXLevel 10"
! Sets the MS TX Level to 10 (while on an SDCCH).

CALL:TCHannel:SIGNaling:(SDCCH|SDCChannel):SUBChannel

Function

GSM TA

 This command is not applicable to the GSM TA.
GPRS TA This command is not applicable to the GPRS TA.

EGPRS TA

 This command is not applicable to the EGPRS TA.

GSM/GPRS LA

This command sets/queries the SDCCH Subchannel value.

The setting range for this parameter depends on the BCH Type. The command to set the BCH Type is CALL[:CELL]:BCHannel:TYPE . This setting is applied only when CALL:TCHannel:SIGNaling:ASSignment:CHANnel is set to SDCCH.

EGPRS LA

Setting

If the BCH Type is set to Combined:

  • Range: 0 to 3
  • Resolution: 1

If the BCH Type is set to Non-Combined:

  • Range: 0 to 7
  • Resolution: 1

Query

If the BCH Type is set to Combined:

  • Range: 0 to 3
  • Resolution: 1

If the BCH Type is set to Non-Combined:

  • Range: 0 to 7
  • Resolution: 1

*RST Setting

 0
Requirements GSM/GPRS/ EGPRS LA

Revision: E.00.12 and above

Programming Example

OUTPUT 714;"CALL:TCHannel:SIGNaling:SDCCH:SUBChannel 1"
! Sets the SDCCH subchannel to 1.

CALL:TCHannel:TSLot

Function

GSM TA

This command sets/queries the Timeslot number used for downlink and uplink Traffic Channel.

See Configuring the Traffic Channel (TCH) Parameters .

If this command is attempted while there is an active DTM connection or while the test set is in a DTM test operating mode, it is stored and applied when the test set is no longer in Dual Transfer Mode.

Timeslot 0 can be used for Traffic Channel only when the ARFCN of BCH and TCH do not match, otherwise the TCH timeslot setting will revert back to its previous value. Note, if BCH and TCH use different bands, Timeslot 0 is available even if the ARFCN of BCH and TCH match.

GSM/GPRS LA

EGPRS LA

GPRS TA

This command is not applicable to GPRS.

EGPRS TA

 This command is not applicable to EGPRS.

Setting

Range: 0 | 1 | 2 | 3 | 4 | 5 | 6 | 7

Resolution: 1

Query

Range: 0 | 1 | 2 | 3 | 4 | 5 | 6 | 7

Resolution: 1

*RST Setting

4
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above

Revision A.07 adds timeslot 0
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Revision E.01 adds timeslot 0

Programming Example

OUTPUT 714;"CALL:TCHANNEL:TSLOT 5"
! Sets timeslot number.


CALL:TMSI

CALL:TMSI

GPIB Command Conventions

  • CALL[:CELL]:TMSI[:VALue]
  • CALL[:CELL]:TMSI:ASSignment

CALL[:CELL]:TMSI[:VALue]

Function GSM TA This command is not applicable to the GSM test applications.

GPRS TA

 This command is not applicable to the GPRS test applications.

EGPRS TA

 This command is not applicable to the EGPRS test applications.

GSM/GPRS LA

This command sets/queries the TMSI (Temporary Mobile Subscriber Identity). TMSI is described in 3GPP TS 23.003 Section 2.4, which states that "The network shall not allocate a TMSI with all 32 bits equal to 1 (this is because the TMSI must be stored in the SIM, and the SIM uses 4 octets with all bits equal to 1 to indicate that no valid TMSI is available)."

This parameter can only be set while the Call Status is Idle and the Data Connection Status is Idle. (Manually setting the TMSI value requires the TMSI Assignment parameter to be On .)

When the TMSI Assignment is set to On , the TMSI value setting determines the TMSI that is assigned to the mobile station during the Location Area Update procedure, combined GPRS / IMSI Attach procedure, or Routing Area Update procedure (see Call Processing Ladder Diagrams ). The command to set the is TMSI Assignment is CALL[:CELL]:TMSI:ASSignment .

When the CS Paging Identity Type is set to TMSI , this setting determines the TMSI that is used to page the mobile station. The command to set the is Paging Identity Type is CALL:PAGing:IDENtity[:TYPE] .

The TMSI value used for both test sets in a Two-Cell Test System is the TMSI setting in the test set that initiates the External Device Connection.

EGPRS LA

Setting

Range: 0 to 4294967294 (Note: The value 4294967295 (or 232 - 1) is reserved by the mobile station to indicate that it does not have a valid TMSI stored.)

Resolution: 1

Query

Range: 0 to 4294967294

Resolution: 1

*RST Setting

 21430000 (This value is used in the 3GPP TS 51.010 section 27 conformance test.)
Requirements GSM/GPRS/ EGPRS LA

Revision: E.00 and above

Programming Example

OUTPUT 714;"CALL:TMSI 1234567890"
! Sets the TMSI value.

CALL[:CELL]:TMSI:ASSignment

Function GSM TA This command is not applicable to the GSM test applications.

GPRS TA

 This command is not applicable to the GPRS test applications.

EGPRS TA

 This command is not applicable to the EGPRS test applications.

GSM/GPRS LA

This command sets/queries whether the test set assigns a TMSI to the mobile station during the Location Area Update, Routing Area Update, and Combined GPRS/IMSI Attach procedures. If the TMSI Assignment is set to On , the mobile station is assigned the TMSI value when it registers with the test set.

This parameter can only be set while the Call Status is Idle and the Data Connection Status is Idle.

You must set TMSI Assignment to On before the mobile station registers in order for the TMSI to be assigned.

The command to set the Operating Mode is CALL:OPERating:MODE .

The command to set/query the TMSI value is CALL[:CELL]:TMSI[:VALue] .

EGPRS LA

Setting

Range: ON|OFF

Query

Range: ON|OFF

*RST Setting

 OFF
Requirements GSM/GPRS/ EGPRS LA

Revision: E.00 and above

Programming Example

OUTPUT 714;"CALL:TMSI:ASSignment ON"
! Turns on the TMSI procedure.


CALL:TRANsferring

CALL:TRANsferring

Last updated:December 3, 2008

GPIB Command Conventions

  • CALL:TRANsferring[:STATe]?

CALL:TRANsferring[:STATe]?

Function

GSM TA

 This command is not applicable to GSM.

GPRS TA

Queries whether or not the data connection is in the transferring state. 1 is returned if the data connection is in the transferring state. 0 is returned if the data connection is in any other non-transitory state. For more details on the Transferring State query or the data connection states, see Data Connection Processing State Synchronization .

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Range: 0 | 1

*RST Setting

0 | OFF
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:TRANsferring:STATe?"


CALL:UTRan

CALL:UTRan

GPIB Command Conventions

  • CALL[:CELL]:UTRAN:FDDuplex:TABLe
  • CALL[:CELL]:UTRAN:FDDuplex:TABLe:POINts?
  • CALL[:CELL]:UTRAN:FDDuplex:TABLe:EXTended
  • CALL[:CELL]:UTRAN:FDDuplex:TABLe:EXTended:POINts?

  • CALL[:CELL]:UTRAN[:ALL]:MPDescr

  • CALL[:CELL]:UTRAN[:ALL]:MPDescr:TGSPriority

  • CALL[:CELL]:UTRAN[:ALL]:MPDescr:FDDinfo
  • CALL[:CELL]:UTRAN[:ALL]:MPDescr:FDDinfo:MREPorting
  • CALL[:CELL]:UTRAN[:ALL]:MPDescr:FDDinfo:QMINimum
  • CALL[:CELL]:UTRAN[:ALL]:MPDescr:FDDinfo:QOFFset[:GSM]
  • CALL[:CELL]:UTRAN[:ALL]:MPDescr:FDDinfo:QOFFset:GPRS
  • CALL[:CELL]:UTRAN[:ALL]:MPDescr:FDDinfo:RQUantity
  • CALL[:CELL]:UTRAN[:ALL]:MPDescr:FDDinfo:RTHReshold
  • CALL[:CELL]:UTRAN[:ALL]:MPDescr:FDDinfo:ROFFset

  • CALL[:CELL]:UTRAN[:ALL]:MPDescr:QSC
  • CALL[:CELL]:UTRAN[:ALL]:MPDescr:QSC:INITial

  • CALL[:CELL]:UTRAN[:ALL]:MPDescr:QSI
  • CALL[:CELL]:UTRAN[:ALL]:MPDescr:QSP

CALL[:CELL]:UTRAN:FDDuplex:TABLe

Function

 GSM TA This command is not applicable to the GSM TA.

GPRS TA

 This command is not applicable to the GPRS TA.

EGPRS TA

 This command is not applicable to the EGPRS TA.
GSM/GPRS LA

This command sets/queries the list of entries in the UTRAN neighbour cell list. There are four parameters that are required for each entry, these include: UARFCN, Scrambling Code Indication (SCI), Scrambling Code (SC), and Diversity (Div) indicator. If no UTRAN FDD neighbour cells (null list) are sent the test set will not broadcast it. Multiple UTRAN FDD neighbour cells are concatenated into one comma separated list. For example, two UTRAN FDD neighbour cells would be entered in the form UARFCN, SCI, SC, Div, UARFCN, SCI, SC, Div.

See Table 1: Unique UARFCN and Scrambling Code Restrictions for details on the number of scrambling codes available for the number of unique UARFCNs.

NOTE
A Scrambling Code Indicator (SCI) set to 1 indicates a Scrambling Code (SC) is specified for the UTRAN FDD Neighbour Cell. An SCI set to 0 indicates no SC or Div should be used. Values must still be given for the SC and Div regardless of whether or not they are used.

EGPRS LA

Setting

A comma separated list of 0 to 5 different UTRAN FDD neighbour cells.

  • UARFCN

    Range:0-16383

    Resolution: 1

  • SCI

    Range: 0|1

  • SC

    Range: 0-511

    Resolution: 1

  • Div

    Range: 0|1

Query

A comma separated list of 0 to 6 different UTRAN FDD neighbour cells.

  • UARFCN

    Range:0-16383

    Resolution: 1

  • SCI

    Range: 0|1

  • SC

    Range: 0-511

    Resolution: 1

  • Div

    Range: 0|1

*RST Setting

 9.91E37 (NAN)
Requirements GSM/GPRS/ EGPRS LA

Revision: D.01 and above

Programming Example

OUTPUT 714;"CALL:UTRan:FDDuplex:TABLe"
! No FDD neighbour cell list is transmitted on the PBCCH or BCCH.

OUTPUT 714;"CALL:UTRan:FDDuplex:TABLe 10,1,4,1"
! A single FDD neighbour cell (UARFCN=10, SCI=1, SC=4, !Div=1).

OUTPUT 714;"CALL:UTRan:FDDuplex:TABLe 10,0,0,0,20,0,0,0,30,0,0,0,40,0,0,0,50,0,0,0"
! Five UARFCNs. Notice there are still values for the Scrambling Code and Diversity
! even though the Scrambling Code Indicator is zero.

CALL[:CELL]:UTRAN:FDDuplex:TABLe:POINts?

Function

 GSM TA This command is not applicable to the GSM TA.

GPRS TA

 This command is not applicable to the GPRS TA.

EGPRS TA

 This command is not applicable to the EGPRS TA.
GSM/GPRS LA This command queries the number of points in the UTRAN FDD neighbour cell list.

To determine the number of neighbour cells present in the list, the result of this command must be divided by four since there are four points, or parameters, for each UTRAN FDD neighbour cell.

The GPIB command used to configure the UTRAN FDD Neighbour Cell list is CALL[:CELL]:UTRAN:FDDuplex:TABLe .

EGPRS LA

Query

Range: 0 to 20

Resolution: 1

*RST Setting

 There are no initial points define in the table.
Requirements GSM/GPRS/ EGPRS LA

Revision: D.01 and above

Programming Example

OUTPUT 714;"CALL:UTRan:FDDuplex:TABLe:POINts?"
! Queries how many FDD neighbour cell points are set in the in the UTRAN Neighbour List.

CALL[:CELL]:UTRAN:FDDuplex:TABLe:EXTended

Function

 GSM TA This command is not applicable to the GSM TA.

GPRS TA

 This command is not applicable to the GPRS TA.

EGPRS TA

 This command is not applicable to the EGPRS TA.
GSM/GPRS LA

This command sets/queries the list of entries in the UTRAN neighbour cell list. There are five parameters that are required for each entry, these include: UARFCN, Scrambling Code Indication (SCI), Scrambling Code (SC), Diversity (DIV) indicator, and Reporting Priority (REP_PRIO). If no UTRAN FDD neighbour cells (null list) are sent the test set will not broadcast it. Multiple UTRAN FDD neighbour cells are concatenated into one comma separated list. For example, two UTRAN FDD neighbour cells would be entered in the form UARFCN, SCI, SC, DIV, REP_PRIO, UARFCN, SCI, SC, Div, REP_PRIO.

See Table 1: Unique UARFCN and Scrambling Code Restrictions for details on the number of scrambling codes available for the number of unique UARFCNs.

NOTE
A Scrambling Code Indicator (SCI) set to 1 indicates a Scrambling Code (SC) is specified for the UTRAN FDD Neighbour Cell. An SCI set to 0 indicates no SC or Div should be used. Values must still be given for the SC and Div regardless of whether or not they are used.

EGPRS LA

Setting

A comma separated list of 0 to 5 different UTRAN FDD neighbour cells.

  • UARFCN

    Range:0-16383

    Resolution: 1

  • SCI

    Range: 0|1

  • SC

    Range: 0-511

    Resolution: 1

  • DIV

    Range: 0|1

  • REP_PRIO

    Range: 1|0 (1: HIGH; 0: LOW)

Query

A comma separated list of 0 to 6 different UTRAN FDD neighbour cells.

  • UARFCN

    Range:0-16383

    Resolution: 1

  • SCI

    Range: 0|1

  • SC

    Range: 0-511

    Resolution: 1

  • Div

    Range: 0|1

  • REP_PRIO

    Range: 1|0

*RST Setting

 9.91E37 (NAN)
Requirements GSM/GPRS/ EGPRS LA

Revision: E.00.12 and above

Programming Example

OUTPUT 714;"CALL:UTRan:FDDuplex:TABLe:EXTended"
! No FDD neighbour cell list is transmitted on the PBCCH or BCCH.

OUTPUT 714;"CALL:UTRan:FDDuplex:TABLe:EXTended 10,1,4,1,HIGH"
! A single FDD neighbour cell (UARFCN=10, !SCI=1, SC=4, DIV=1, REP_PRIO=HIGH).

OUTPUT 714;"CALL:UTRan:FDDuplex:TABLe:EXTended 10,0,0,0,0,20,0,0,0,0,30,0,0,0,0,40,0,0,0,0,50,0,0,0,0"
! Five UARFCNs. Notice there are still values for the Scrambling Code and Diversity
! even though the Scrambling Code Indicator is zero.

CALL[:CELL]:UTRAN:FDDuplex:TABLe:EXTended:POINts?

Function

 GSM TA This command is not applicable to the GSM TA.

GPRS TA

 This command is not applicable to the GPRS TA.

EGPRS TA

 This command is not applicable to the EGPRS TA.
GSM/GPRS LA This command queries the number of points in the UTRAN FDD neighbour cell list.

To determine the number of neighbour cells present in the list, the result of this command must be divided by five since there are five points, or parameters, for each UTRAN FDD neighbour cell.

The GPIB command used to configure the UTRAN FDD Neighbour Cell list is CALL[:CELL]:UTRAN:FDDuplex:TABLe:EXTended .

EGPRS LA

Query

Range: 0 to 20

Resolution: 1

*RST Setting

 There are no initial points define in the table.
Requirements GSM/GPRS/ EGPRS LA

Revision: E.00.12 and above

Programming Example

OUTPUT 714;"CALL:UTRan:FDDuplex:TABLe:EXTended:POINts?"
! Queries how many FDD neighbour cell points are set in the in the UTRAN Neighbour List.

CALL[:CELL]:UTRAN[:ALL]:MPDescr

Function

 GSM TA This command is not applicable to the GSM TA.

GPRS TA

 This command is not applicable to the GPRS TA.

EGPRS TA

 This command is not applicable to the EGPRS TA.
GSM/GPRS LA

This command sets/queries whether or not the 3G measurement parameter description IE is transmitted.

Note: A valid neighbour cell list must be specified for the 3G measurement parameter description IE to be sent over the air interface.

EGPRS LA
Setting

Range: INCLude|EXCLude

Query

Range: INCLude|EXCLude

*RST Setting

 EXCLude
Requirements GSM/GPRS/ EGPRS LA

Revision: E.00.12 and above

Programming Example

OUTPUT 714;"CALL:UTRan:MPDescr INCLude"
! Sets the 3G measurement parameter description IE to be !included.

CALL[:CELL]:UTRAN[:ALL]:MPDescr:TGSPriority

Function

 GSM TA This command is not applicable to the GSM TA.

GPRS TA

 This command is not applicable to the GPRS TA.

EGPRS TA

 This command is not applicable to the EGPRS TA.
GSM/GPRS LA This command sets/queries whether 3G cells are searched by the Mobile Station when BSIC decoding is required.

EGPRS LA
Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

 0
Requirements GSM/GPRS/ EGPRS LA

Revision: E.00.12 and above

Programming Example

OUTPUT 714;"CALL:UTRan:MPDescr:TGSPriority ON"
! Sets 3G cells to be searched.

CALL[:CELL]:UTRAN[:ALL]:MPDescr:FDDinfo

Function

 GSM TA This command is not applicable to the GSM TA.

GPRS TA

 This command is not applicable to the GPRS TA.

EGPRS TA

 This command is not applicable to the EGPRS TA.
GSM/GPRS LA

This command sets/queries whether or not the FDD Information IE (part of the 3G measurement parameter description IE) is transmitted.

Note: A valid neighbour cell list must be specified for the 3G measurement parameter description IE to be sent over the air interface.

EGPRS LA
Setting

Range: INCLude|EXCLude

Query

Range: INCLude|EXCLude

*RST Setting

 EXCLude
Requirements GSM/GPRS/ EGPRS LA

Revision: E.00.12 and above

Programming Example

OUTPUT 714;"CALL:UTRan:MPDescr:FDDinfo INCLude"
! Sets the FDD Information IE to be transmitted.

CALL[:CELL]:UTRAN[:ALL]:MPDescr:FDDinfo:MREPorting

Function

 GSM TA This command is not applicable to the GSM TA.

GPRS TA

 This command is not applicable to the GPRS TA.

EGPRS TA

 This command is not applicable to the EGPRS TA.
GSM/GPRS LA

This command sets/queries the number cells the access technology/mode FDD that are reported in the list of strongest cells.

EGPRS LA
Setting

Range: 0 to 3

Resolution: 1

Query

Range: 0 to 3

Resolution: 1

*RST Setting

 1
Requirements GSM/GPRS/ EGPRS LA

Revision: D.02 and above

Programming Example

OUTPUT 714;"CALL:UTRan:MPDescr:FDDinfo:MREPorting 2"
! Sets the number of cells reported in the measurement report in the access
! technology/mode FDD to two.

CALL[:CELL]:UTRAN[:ALL]:MPDescr:FDDinfo:QMINimum

Function

 GSM TA This command is not applicable to the GSM TA.

GPRS TA

 This command is not applicable to the GPRS TA.

EGPRS TA

 This command is not applicable to the EGPRS TA.
GSM/GPRS LA

This command sets/queries the minimum threshold for Ec/No for UTRAN FDD cell re-selection.

These settings are mapped to threshold values as follows:

Setting Threshold
0 -20 dBm
1 -19 dBm
2 -18 dBm
3 -17 dBm
4 -16 dBm
5 -15 dBm
6 -14 dBm
7 -13 dBm

EGPRS LA
Setting

Range: 0 to 7

Resolution: 1

Query

Range: 0 to 7

Resolution: 1

*RST Setting

 0
Requirements GSM/GPRS/ EGPRS LA

Revision: D.02 and above

Programming Example

OUTPUT 714;"CALL:UTRan:MPDescr:FDDinfo:QMINimum 3"
! Sets the threshold for Ec/No for UTRAN FDD cell reselection to 3 (-17 dBm).

CALL[:CELL]:UTRAN[:ALL]:MPDescr:FDDinfo:QOFFset[:GSM]

Function

 GSM TA This command is not applicable to the GSM TA.

GPRS TA

 This command is not applicable to the GPRS TA.

EGPRS TA

 This command is not applicable to the EGPRS TA.
GSM/GPRS LA

This command set/queries the offset applied to RLA_C (received level averages) for cell re-section to access technology/mode FDD.

Changes to this parameter can only be made when the Operating Mode is set to Off. See CALL:OPERating:MODE .

The settings are mapped to values as follows:

Setting Offset
0 always
1 -28 dB
2 -24 dB
3 -20 dB
4 -16 dB
5 -12 dB
6 -8 dB
7 -4 dB
8 0 dB
9 4 dB
10 8 dB
11 12 dB
12 16 dB
13 20 dB
14 24 dB
15 28 dB

EGPRS LA
Setting

Range: 0-15

Resolution: 1

Query

Range: 0-15

Resolution: 1

*RST Setting

 0 (always)
Requirements GSM/GPRS/ EGPRS LA

Revision: D.02 and above

Programming Example

OUTPUT 714;"CALL:UTRan:MPDescr:FDDinfo:QOFFset 5"
! Sets FDD_Qoffset value to 5 (-12 dBm).

CALL[:CELL]:UTRAN[:ALL]:MPDescr:FDDinfo:QOFFset:GPRS

Function

 GSM TA This command is not applicable to the GSM TA.

GPRS TA

 This command is not applicable to the GPRS TA.

EGPRS TA

 This command is not applicable to the EGPRS TA.
GSM/GPRS LA

This command set/queries the offset applied to RLA_C (received level averages) for cell re-section to access technology/mode FDD. It is the GPRS variant of the FDD_Qoffset setting. See CALL[:CELL]:UTRAN[:ALL]:MPDescr:FDDinfo:QOFFset[:GSM] .

The settings are mapped to values as follows:

Setting Offset
0 always
1 -28 dB
2 -24 dB
3 -20 dB
4 -16 dB
5 -12 dB
6 -8 dB
7 -4 dB
8 0 dB
9 4 dB
10 8 dB
11 12 dB
12 16 dB
13 20 dB
14 24 dB
15 28 dB

EGPRS LA
Setting

Range: 0-15

Resolution: 1

Query

Range: 0-15

Resolution: 1

*RST Setting

 0 (always)
Requirements GSM/GPRS/ EGPRS LA

Revision: E.00.12 and above

Programming Example

OUTPUT 714;"CALL:UTRan:MPDescr:FDDinfo:QOFFset:GPRS 5"
! Sets FDD GPRS Qoffset value to 5 (-12 dBm).

CALL[:CELL]:UTRAN[:ALL]:MPDescr:FDDinfo:RQUantity

Function

 GSM TA This command is not applicable to the GSM TA.

GPRS TA

 This command is not applicable to the GPRS TA.

EGPRS TA

 This command is not applicable to the EGPRS TA.
GSM/GPRS LA

This command sets/queries the reporting quantity for UTRAN FDD cells.

When this command is set to 0, the reporting quantity is RSCP (used for cell re-selection ranking criteria). When this command is set to 1, the reporting quantity is Ec/No. Ec/No is used for a minimum quality requirement.

EGPRS LA
Setting

Range: 0|1

Query

Range: 0|1

*RST Setting

 0
Requirements GSM/GPRS/ EGPRS LA

Revision: D.02 and above

Programming Example

OUTPUT 714;"CALL:UTRan:MPDescr:FDDinfo:RQUantity 1"
! The quantity reported is Ec/No.

CALL[:CELL]:UTRAN[:ALL]:MPDescr:FDDinfo:RTHReshold

Function

 GSM TA This command is not applicable to the GSM TA.

GPRS TA

 This command is not applicable to the GPRS TA.

EGPRS TA

 This command is not applicable to the EGPRS TA.
GSM/GPRS LA

This command sets/queries whether to apply priority reporting if the reported value for an FDD neighbour cell is above the specified threshold. The settings are mapped to values as follows:

Setting Threshold
0 0 dB
1 6 dB
2 12 dB
3 18 dB
4 24 dB
5 30 dB
6 36 dB
7 42 dB

EGPRS LA
Setting

Range: 0 to 7

Resolution: 1

Query

Range: 0 to 7

Resolution: 1

*RST Setting

 0
Requirements GSM/GPRS/ EGPRS LA

Revision: E.00.12 and above

Programming Example

OUTPUT 714;"CALL:UTRan:MPDescr:FDDinfo:RTHReshold 5"
! Sets the report threshold to 5.

CALL[:CELL]:UTRAN[:ALL]:MPDescr:FDDinfo:ROFFset

Function

 GSM TA This command is not applicable to the GSM TA.

GPRS TA

 This command is not applicable to the GPRS TA.

EGPRS TA

 This command is not applicable to the EGPRS TA.
GSM/GPRS LA

This command sets/queries the offset to the reported value when prioritizing the FDD neighbour cells for reporting. The settings are mapped to values as follows:

Setting Offset
0 always
1 6 dB
2 12 dB
3 18 dB
4 24 dB
5 30 dB
6 36 dB
7 never

EGPRS LA
Setting

Range: 0 to 7

Resolution: 1

Query

Range: 0 to 7

Resolution: 1

*RST Setting
Requirements GSM/GPRS/ EGPRS LA

Revision: E.00.12 and above

Programming Example

OUTPUT 714;"CALL:UTRan:MPDescr:FDDinfo:ROFFset 5"
! Sets the offset to the reported value to 5.

CALL[:CELL]:UTRAN[:ALL]:MPDescr:QSC

Function

 GSM TA This command is not applicable to the GSM TA.

GPRS TA

 This command is not applicable to the GPRS TA.

EGPRS TA

 This command is not applicable to the EGPRS TA.
GSM/GPRS LA

This command sets/queries a threshold and indicates whether the Mobile Station search for 3G cells .

The Mobile Station will search for 3G cells if a signal level is below 0-7 or above 8-15. The settings are mapped to values as follows:

Setting Threshold
0 -98 dBm
1 -94 dBm
2 -90 dBm
3 -86 dBm
4 -82 dBm
5 -78 dBm
6 -74 dBm
7 always
8 -78 dBm
9 -74 dBm
10 -70 dBm
11 -66 dBm
12 -62 dBm
13 -58 dBm
14 -54 dBm
15 never

EGPRS LA
Setting

Range: 0 to 15

Resolution: 1

Query

Range: 0 to 15

Resolution: 1

*RST Setting

 7 (always)
Requirements GSM/GPRS/ EGPRS LA

Revision: E.00.12 and above

Programming Example

OUTPUT 714;"CALL:UTRan:MPDescr:QSC 7"
! Sets Qsearch_C threshold to 7 (always).

CALL[:CELL]:UTRAN[:ALL]:MPDescr:QSC:INITial

Function

 GSM TA This command is not applicable to the GSM TA.

GPRS TA

 This command is not applicable to the GPRS TA.

EGPRS TA

 This command is not applicable to the EGPRS TA.
GSM/GPRS LA

This command sets/queries the value to be used in connected mode before Qsearch_C (sent on the SACCH) is received. The Qsearch_C_initial is sent on the BCCH.

When this parameter is set to 0 the signal level for Qsearch_I is used. The command to set the Qsearch_I level is CALL[:CELL]:UTRAN[:ALL]:MPDescr:QSI .

EGPRS LA
Setting

Range: 0|1

Query

Range: 0|1

*RST Setting

 0
Requirements GSM/GPRS/ EGPRS LA

Revision: D.02 and above

Programming Example

OUTPUT 714;"CALL:UTRan:MPDescr:QSC:INITial 0"
! Qsearch_C_Initial is set to the Qsearch_I value.

CALL[:CELL]:UTRAN[:ALL]:MPDescr:QSI

Function

 GSM TA This command is not applicable to the GSM TA.

GPRS TA

 This command is not applicable to the GPRS TA.

EGPRS TA

 This command is not applicable to the EGPRS TA.
GSM/GPRS LA

This command sets/queries a threshold and indicates whether measurements on cells of other radio access technologies shall be performed.

The Qsearch_I parameter will search for 3G cells if a signal level is below 0-7 or above 8-15. The settings are mapped to values as follows:

Setting Threshold
0 -98 dBm
1 -94 dBm
2 -90 dBm
3 -86 dBm
4 -82 dBm
5 -78 dBm
6 -74 dBm
7 always
8 -78 dBm
9 -74 dBm
10 -70 dBm
11 -66 dBm
12 -62 dBm
13 -58 dBm
14 -54 dBm
15 never

EGPRS LA
Setting

Range: 0 to 15

Resolution: 1

Query

Range: 0 to 15

Resolution: 1

*RST Setting

 7 (always)
Requirements GSM/GPRS/ EGPRS LA

Revision: D.02 and above

Programming Example

OUTPUT 714;"CALL:UTRan:MPDescr:QSI 7"
! Sets Qsearch_I threshold to 7 (always).

CALL[:CELL]:UTRAN[:ALL]:MPDescr:QSP

Function

 GSM TA This command is not applicable to the GSM TA.

GPRS TA

 This command is not applicable to the GPRS TA.

EGPRS TA

 This command is not applicable to the EGPRS TA.
GSM/GPRS LA

This command sets/queries a threshold and indicates whether measurements on cells of other radio access technologies shall be performed. It is the GPRS variant of the Qsearch_C setting. see CALL[:CELL]:UTRAN[:ALL]:MPDescr:QSI .

The Qsearch_P parameter will search for 3G cells if a signal level is below 0-7 or above 8-15. The settings are mapped to values as follows:

Setting Threshold
0 -98 dBm
1 -94 dBm
2 -90 dBm
3 -86 dBm
4 -82 dBm
5 -78 dBm
6 -74 dBm
7 always
8 -78 dBm
9 -74 dBm
10 -70 dBm
11 -66 dBm
12 -62 dBm
13 -58 dBm
14 -54 dBm
15 never

EGPRS LA
Setting

Range: 0 to 15

Resolution: 1

Query

Range: 0 to 15

Resolution: 1

*RST Setting

 7 (always)
Requirements GSM/GPRS/ EGPRS LA

Revision: E.00.12 and above

Programming Example

OUTPUT 714;"CALL:UTRan:MPDescr:QSP 6"
! Sets Qsearch_P threshold to 6.


E1968A GSM/GPRS GPIB COMMAND CHANGES

E1968A GSM/GPRS GPIB COMMAND CHANGES

This section describes the GPIB command changes that occurred in the GSM commands and GPRS commands as the E1960A GSM Mobile Test Application functionality and the E1964A GPRS Mobile Test Application functionality moved to the E1968A GSM/GPRS Mobile Test Application.

Operating Mode Commands

The operating mode was determined by three separate GPIB commands in the E1960A GSM Mobile Test Application (TA):

CALL[:CELL]:OPERating:MODE CALL | CELL | TEST

CALL[:CELL]:FUNCtion:DOWNlink CW | BCH | BCHTCH

CALL[:CELL]:ACTivated 1 | ON | 0 | OFF

The operating mode command selected between active cell mode and test mode. When in active cell mode, the cell activated command determined the cell state. When in test mode, the downlink function command determined which test mode was used.

The above three commands have been replaced with a single combined operating mode command in the E1968A GSM/GPRS Mobile Test Application:

CALL[:CELL]:OPERating:MODE

with the following parameters:

CALL* | CELL | GBTest | GBTTest | PBTest | PBPTest | OFF | CW

*CALL and CELL are equivalent, CALL is always returned by the query form of the command.

All existing E1960A test code should be checked wherever the above three commands occur. In most cases, the new form of the operating mode command will be required. See CALL:OPERating:MODE .

CALL[:CELL]:FUNCtion:DOWNlink has been deleted and should be replaced by CALL[:CELL]:OPERating:MODE

CALL[:CELL]:ACTivated has been retained as an alias of CALL[:CELL]:OPERating:MODE

CALL[:CELL]:ACTivated 1 | ON is replaced by CALL[:CELL]:OPERating:MODE CALL

CALL[:CELL]:ACTivated 0 | OFF is replaced by CALL[:CELL]:OPERating:MODE OFF

Connection Type Commands

A new E1968A GSM/GPRS command CALL:FUNCtion:CONNection:TYPE has been added to control what type of connection can be made. This command replaces the E1964A GPRS Mobile Test Application command CALL:FUNCtion:DATA:TYPE which is also retained for backwards compatibility with existing E1964A test code. The new command accepts the following parameters:

A | B | ACKB | BLER | AUTO

The A, B, ACKB, BLER parameters are only applicable when licensed for GPRS. The AUTO parameter is only applicable when licensed for either GSM TA or the E6701C GSM/GPRS Lab Application (LA). When set to AUTO, either mobile originated or mobile terminated GSM voice calls can be made, or alternatively IP Data data connections can be made. Effectively, AUTO is equivalent to the GPRS LA IPData connection type for GPRS data connections, but adds capability for GSM voice calls.

When licensed for GSM (E1960A or E6701C license present), the default setting for connection type is AUTO meaning that existing GSM code will not need to be modified to take account of this new setting. If the GPRS TA only is licensed, this setting defaults to BLER.

The old GPRS TA/LA command CALL:FUNCtion:DATA:TYPE is maintained for backwards compatibility and is identical to the newer CALL:FUNCtion:CONNection:TYPE command except that IPData is used instead of AUTO.

GSM RF Generator Commands

The E1960A GSM Mobile Test Application CW test mode was specific to the E1960A Mobile TA only, it was accessed by the following commands:

CALL:OPERating:MODE TEST

CALL:FUNCtion:DOWNlink CW

The E1964A GPRS Mobile Test Application and the E6701B GPRS Lab Application Rev B did not have any form of CW mode. E1968A GSM/GPRS based applications use a CW operating mode which is common to all other TAs e.g. IS136 and WCDMA. The new CW operating mode is accessed as follows:

CALL:OPERating:MODE CW

Since the common CW operating mode is used for all formats, it does not support setting the CW frequency by specifying GSM band and ARFCN as these have no meaning in formats such as IS136. To maintain backwards compatibility with the E1960A GSM Mobile Test Application, the old CALL:RFG commands are supported but with some differences, these are explained below.

In the E1960A GSM Mobile Test Application there were no separate RFG settings, all RFG commands except frequency were actually aliases to other CELL commands, as shown below:

CALL[:CELL]:RFGenerator:BAND --> CALL[:CELL]:BAND

CALL[:CELL]:RFGenerator:CHANnel:[SELected] --> CALL[:CELL]:BCH:ARFCn:[SELected]

CALL[:CELL]:RFGenerator:CHANnel:EGSM --> CALL[:CELL]:BCH:ARFCn:EGSM

CALL[:CELL]:RFGenerator:CHANnel:RGSM --> CALL[:CELL]:BCH:ARFCn:RGSM

CALL[:CELL]:RFGenerator:CHANnel:DCS --> CALL[:CELL]:BCH:ARFCn:DCS

CALL[:CELL]:RFGenerator:CHANnel:PCS --> CALL[:CELL]:BCH:ARFCn:PCS

CALL[:CELL]:RFGenerator:CHANnel:GSM450 --> CALL[:CELL]:BCH:ARFCn:GSM450

CALL[:CELL]:RFGenerator:CHANnel:GSM480 --> CALL[:CELL]:BCH:ARFCn:GSM480

CALL[:CELL]:RFGenerator:CHANnel:GSM750 --> CALL[:CELL]:BCH:ARFCn:GSM750

CALL[:CELL]:RFGenerator:CHANnel:GSM850 --> CALL[:CELL]:BCH:ARFCn:GSM850

CALL[:CELL]:RFGenerator:POWer[:SAMPlitude] --> CALL[:CELL]:POWer:[SAMPlitude]

CALL[:CELL]:RFGenerator:POWer:AMPLitude --> CALL[:CELL]:POWer:AMPLitude

CALL[:CELL]:RFGenerator:POWer:STATe --> CALL[:CELL]:POWer:STATe

This meant that if you modified any RFG setting, it would reflect on its equivalant setting BCH setting. For example, if you modified CALL:RFG:BAND while in CW test mode, it would also change CALL:BAND, meaning that when you returned to Active Cell mode, the BCH BAND would have been changed.

In the E1968A GSM/GPRS Mobile Test Application there is no linkage between the CW mode parameters and BCH ARFCN, band and power parameters. CW mode maintains its own separate frequency, power and state parameters.

In the E1968A GSM/GPRS Mobile Test Application, the legacy GSM RFG commands are mapped onto common CW operating mode commands as shown below:

CALL[:CELL]:RFGenerator:POWer[:SAMPlitude] --> CALL[:CELL]:POWer:[SAMPlitude]:CW

CALL[:CELL]:RFGenerator:POWer:AMPLitude --> CALL[:CELL]:POWer:AMPLitude:CW

CALL[:CELL]:RFGenerator:POWer:STATe --> CALL[:CELL]:POWer:STATe:CW

The CALL[:CELL]:RFGenerator:FREQuency command exists unchanged from from the E1960A GSM Test Application.

The other GSM RFG band and channel commands do not have direct equivalent common CW operating mode commands. These commands have been implemented in the yuc code layer only, to provide a degree of backwards compatibility with E1960A code. This means that a *RST (or MUI full preset) will not reset these commands to their power on default values - their values do not change during a reset.

CALL[:CELL]:RFGenerator:BAND

CALL[:CELL]:RFGenerator:CHANnel:[SELected]

CALL[:CELL]:RFGenerator:CHANnel:PGSM

CALL[:CELL]:RFGenerator:CHANnel:EGSM

CALL[:CELL]:RFGenerator:CHANnel:RGSM

CALL[:CELL]:RFGenerator:CHANnel:DCS

CALL[:CELL]:RFGenerator:CHANnel:PCS

CALL[:CELL]:RFGenerator:CHANnel:GSM450

CALL[:CELL]:RFGenerator:CHANnel:GSM480

CALL[:CELL]:RFGenerator:CHANnel:GSM750

CALL[:CELL]:RFGenerator:CHANnel:GSM850

GSM RFAN Commands

The GSM RFAN commands are now obsolete and the GPRS RFAN commands should be used instead. To maintain backwards compatibility, the old GSM RFAN commands have been mapped onto the newer GPRS RFAN commands where possible. Where a direct mapping isn't possible, the setting has been created in the yuc code layer only to provide a degree of backwards compatibility. It is strongly recommended that previous code be changed over to the newer GPRS RFAN commands where ever possible.

One fundamental difference between GSM and GPRS RFAN commands is in GSM where there was only a single receiver expected power, therefore, when the receiver was under base station emulator control, changing MS TX Level would alter the single receiver expected power setting. This meant that if you switched from base station emulator (auto) control to RFAN (manual) control, the receiver expected power setting would remain the same as it was under base station emulator control until changed. There was a coupling between the base station emulator control MS TX Level and the manual expected power setting.

The E1968A GSM/GPRS Mobile Test Application does not retain this coupling between base station emulator (auto) and RFAN (manual) settings. The E1968A GSM/GPRS Mobile Test Application maintains separate settings for automatic and manual control, therefore, when you change to manual control in the E1968A, the receiver expected power and frequency settings will not necessarily remain the same, in fact it is likely that they will change. This means that receiver expected frequency and/or power must be explicitly set rather than assuming that it will be correct.

Another difference between the E1960A GSM and E1968A GSM/GPRS Mobile Test Application is in the expected power control and measurement and uplink (demod) receivers. E1960A GSM Mobile Test Application used a single auto/manual control that governed the expected power control and measurement and uplink (demod) receivers. The E1968A GSM/GPRS Mobile Test Application individually sets these settings.

The following shows how the GSM RFAN commands map onto the newer GPRS RFAN commands.

RFANalyzer:CONTrol:AUTO --> RFANalyzer:CONTrol:POWer:AUTO

--> RFANalyzer:CONTrol:MEASurement:FREQuency:AUTO

The single GSM auto/manual control command maps onto the GPRS expected power control and measurement control commands. Note however that the uplink (demod) frequency control is not altered.

RFANalyzer:EXPected:POWer[:SELected] --> RFANalyzer:MANual:POWer:BURS1

RFANalyzer:MANual:FREQuency --> RFANalyzer:MANual:MEASurement:FREQuency

The GPRS RFAN commands do not support banded settings for either power or frequency, and do not support setting frequency in terms of ARFCN, so the following GSM RFAN commands have had legacy settings added into the yuc code to ensure a degree of backwards compatibility:

RFANalyzer:MANual:BAND

RFANalyzer:EXPected:POWer:PGSM

RFANalyzer:EXPected:POWer:EGSM

RFANalyzer:EXPected:POWer:RGSM

RFANalyzer:EXPected:POWer:DCS

RFANalyzer:EXPected:POWer:PCS

RFANalyzer:EXPected:POWer:GSM450

RFANalyzer:EXPected:POWer:GSM480

RFANalyzer:EXPected:POWer:GSM750

RFANalyzer:EXPected:POWer:GSM850

RFANalyzer:MANual:CHANnel[:SELected]

RFANalyzer:MANual:CHANnel:PGSM

RFANalyzer:MANual:CHANnel:EGSM

RFANalyzer:MANual:CHANnel:RGSM

RFANalyzer:MANual:CHANnel:DCS

RFANalyzer:MANual:CHANnel:PCS

RFANalyzer:MANual:CHANnel:GSM450

RFANalyzer:MANual:CHANnel:GSM480

RFANalyzer:MANual:CHANnel:GSM750

RFANalyzer:MANual:CHANnel:GSM850

These legacy settings will retain their existing values through a *RST or full preset operation, they will not be reset to their power on default values.

RFANalyzer:MSLot:MEASurement:BURSt --> CALL:PDTCh:MSLot:MEASurement:BURSt

Note that none of the legacy GSM RFAN commands have any coupling to the new command CALL:PDTCh:MSLot:MEASurement:BURSt command which selects which burst is measured. This setting must be set to 1 for GSM TCH measurements. See CALL:(PDTCH|PDTChannel):MSLot:MEASurement:BURSt . This command replaces RFAN:MSLot:MEASurement:BURSt.

Overlapped Commands

The E1960A GSM Mobile Test Application supported overlapped command functionality for the following commands:

CALL[:CELL]:BCHannel[:ARFCn][:SELected]

CALL[:CELL]:BCHannel[:ARFCn]:PGSM

CALL[:CELL]:BCHannel[:ARFCn]:EGSM

CALL[:CELL]:BCHannel[:ARFCn]:DCS

CALL[:CELL]:BCHannel[:ARFCn]:PCS

CALL[:CELL]:BCHannel[:ARFCn]:RGSM

CALL[:CELL]:BCHannel[:ARFCn]:GSM450

CALL[:CELL]:BCHannel[:ARFCn]:GSM480

CALL[:CELL]:BCHannel[:ARFCn]:GSM850

CALL[:CELL]:BCHannel[:ARFCn]:GSM750

CALL:END

CALL:MS:TADVance[:SELected]

CALL:MS:TADVance:PGSM

CALL:MS:TADVance:EGSM

CALL:MS:TADVance:DCS

CALL:MS:TADVance:PCS

CALL:MS:TADVance:RGSM

CALL:MS:TADVance:GSM450

CALL:MS:TADVance:GSM480

CALL:MS:TADVance:GSM850

CALL:MS:TADVance:GSM750

CALL:MS:TXLevel[:SELected]

CALL:MS:TXLevel:PGSM

CALL:MS:TXLevel:EGSM

CALL:MS:TXLevel:DCS

CALL:MS:TXLevel:PCS

CALL:MS:TXLevel:RGSM

CALL:MS:TXLevel:GSM450

CALL:MS:TXLevel:GSM480

CALL:MS:TXLevel:GSM850

CALL:MS:TXLevel:GSM750

CALL:TCHannel[:ARFCn][:SELected]

CALL:TCHannel[:ARFCn]:PGSM

CALL:TCHannel[:ARFCn]:EGSM

CALL:TCHannel[:ARFCn]:DCS

CALL:TCHannel[:ARFCn]:PCS

CALL:TCHannel[:ARFCn]:RGSM

CALL:TCHannel[:ARFCn]:GSM450

CALL:TCHannel[:ARFCn]:GSM480

CALL:TCHannel[:ARFCn]:GSM850

CALL:TCHannel[:ARFCn]:GSM750

CALL:TCHannel:CMODe[:VALue]

CALL:TCHannel:CMODe:HRSPeech:SCHannel

CALL:TCHannel:TSLot

In the E1968A GSM/GPRS Mobile Test Application, this functionality has been removed. All other commands with overlapped functionality, such as CALL:ORIGinate, still have overlapped functionality as before. This means that sending one of the above commands in the E1968A Mobile TA is equivalent to appending :SEQ in the E1960A Mobile TA. All of the above commands execute sequentially in the E1968A GSM/GPRS Mobile Test Application.

:SEQ

All of the above commands operate sequentially by default, therefore appending :SEQ is uneccessary, but is still supported.

:WAIT

In the E1960A GSM Mobile Test Application, the :WAIT GPIB extension could be used to convert a previously issued overlapped command into a sequential command. In the E1968A GSM/GPRS Mobile Test Application, overlapped functionality is not available for the above commands, therefore, this GPIB extension has no purpose. To maximise backwards compatibility, the :WAIT GPIB extension will be accepted without error for the above commands, but will be ignored. Ideally, :WAIT GPIB extensions should be removed from test code.

:DONE? And OPC?

These GPIB extensions no longer have any meaning for the above commands and will always return 1. It is recommended the above commands with :OPC? or :DONE? extensions be removed from test code.

Deferred Commands

To compensate for the loss of overlapped functionality in the above E1960A GSM commands, deferred commands have been added for the following settings:

CALL:SETup:TCHannel:MS:TXLevel[:SELected]

CALL:SETup:TCHannel:MS:TXLevel:PGSM

CALL:SETup:TCHannel:MS:TXLevel:EGSM

CALL:SETup:TCHannel:MS:TXLevel:DCS

CALL:SETup:TCHannel:MS:TXLevel:PCS

CALL:SETup:TCHannel:MS:TXLevel:RGSM

CALL:SETup:TCHannel:MS:TXLevel:GSM450

CALL:SETup:TCHannel:MS:TXLevel:GSM480

CALL:SETup:TCHannel:MS:TXLevel:GSM850

CALL:SETup:TCHannel:MS:TXLevel:GSM750

CALL:SETup:TCHannel[:ARFCn][:SELected]

CALL:SETup:TCHannel[:ARFCn]:PGSM

CALL:SETup:TCHannel[:ARFCn]:EGSM

CALL:SETup:TCHannel[:ARFCn]:DCS

CALL:SETup:TCHannel[:ARFCn]:PCS

CALL:SETup:TCHannel[:ARFCn]:RGSM

CALL:SETup:TCHannel[:ARFCn]:GSM450

CALL:SETup:TCHannel[:ARFCn]:GSM480

CALL:SETup:TCHannel[:ARFCn]:GSM850

CALL:SETup:TCHannel[:ARFCn]:GSM750

CALL:SETup:TCHannel:BAND

CALL:SETup:TCHannel:CMODe[:VALue]

CALL:SETup:TCHannel:CMODe:HRSPeech:SCHannel

CALL:SETup:TCHannel:TSLot

As with the E1964A GPRS TA, a handover is initiated with the CALL:HAND GPIB command.

Since the above deferred commands are new commands, there is no direct impact on previous test code. However, it is recommended previous test code be optimised to take advantage of the faster handovers possible using the new deferred commands.

Other Commands and Changes

CALL:COUNt:TDMA:FRAMes

In the E1960A GSM Mobile Test Application, this command specified the timeout period (in frames) within which a mobile must respond to a TCH assignment command such as a TCH ARFCN change. If this time was exceeded, an error was logged.

In the E1968A GSM/GPRS Mobile Test Application architecture, this command is redundant. It is supported for backwards compatibility reasons, but the setting doesn't do anything. It is recommended that this command be removed from previously written test code.

CALL:TCHannel:TSLot

This command now accepts values in the range 1 to 7 whereas previously, it was limited to 3 to 5. There is no impact on previously written test code.

CALL:BURSt:TYPE

This command now accepts the parameter RACH for GPRS as well as GSM. No impact on previously written test code.

CALL:STATus:TCHannel[:ARFCn]?

This command is now redundant, it is now an alias for CALL:TCHannel:ARFCn? which should be used instead.

CALL:STATus:TCHannel:BAND?

This command is now redundant, it is now an alias for CALL:TCHannel:BAND? which should be used instead.

CALL:STATus:TCHannel:TSLot?

This command is now redundant, it is now an alias for CALL:TCHannel:TSLot? which should be used instead.

SYSTem:APPLication:FORMat[:NAME]

In the E1985A Fast Switching Test Application, this command would fast switch between formats. In the E1968A GSM/GPRS Mobile Test Application, there is no fast switch between GSM and GPRS because the GSM and GPRS formats are integrated. To switch from another format e.g. WCDMA to GSM/GPRS, you can use any of the following parameters:

"GSM/GPRS" (preferred) or "GSM" or "GPRS"

The query will always return "GSM/GPRS".

It is strongly recommended that all instances of the SYS:APPL:FORM:NAMe command be removed where there is a fast switch between GSM and GPRS or vice-versa to optimise test plan execution. In the E1968A.GSM/GPRS Mobile Test Application this command does not perform any function and will waste time because the E1968A now integrates these two technologies. It is also recommended, though not essential, that the new format name "GSM/GPRS" be used when switching from other formats to the E1968A. Any code using the query form of this command must be modified to expect "GSM/GPRS" as the response.

SYSTem:APPLication:SELect[:NAME]

The name used for the E1968A is "GSM/GPRS Mobile Test Application".

New Commands

The following commands are new to the E1968A GSM/GPRS Mobile Test Application, consequently there will be no impact on existing test code.

CALL:TCHannel:PREDuction:LEVel[1|2]

Assigns a value in dB to power reduction level 1 or 2 - accepts values in the range 0 to 25 dB. This command works in the same manner as the existing E1964A GPRS command CALL:PDTChannel:PREDuction:LEVel[1|2].

CALL:TCHannel:PREDuction:BURSt

Specifies a power reduction level to use for the downlink TCH burst power - accepts either PRL1 or PRL2 as a parameter. This command works in the same manner as the existing E1964A GPRS command CALL:PDTChannel:PREDuction:BURSt[1|2|3|4].

CALL:TCHannel:PREDuction:UBURst

Specifies a power reduction level to use for the downlink TCH unused burst power - accepts either PRL1 or PRL2 as a parameter. This command works in the same manner as the existing E1964A GPRS command CALL:PDTChannel:PREDuction:UBURst.

CALL:TCHannel:POWer[:AMPLitude]?

Query only. Returns the downlink TCH used burst power in dB.

CALL:TCHannel:POWer[:AMPLitude]:UBURst?

Query only. Returns the downlink TCH unused burst power in dB.

CALL:MS:TXLevel:CCHannel[:SELected]

CALL:MS:TXLevel:CCHannel:PGSM

CALL:MS:TXLevel:CCHannel:EGSM

CALL:MS:TXLevel:CCHannel:RGSM

CALL:MS:TXLevel:CCHannel:DCS

CALL:MS:TXLevel:CCHannel:PCS

CALL:MS:TXLevel:CCHannel:GSM450

CALL:MS:TXLevel:CCHannel:GSM480

CALL:MS:TXLevel:CCHannel:GSM750

CALL:MS:TXLevel:CCHannel:GSM850

These commands specify the maximum burst power a mobile may uses for access bursts. At present this is an LA only feature. The range of values accepted is dependant on the band.

DCS band 0 to 28

PCS band 0 to 15 and 30 to 31

Other bands 0 to 31

These settings can only be changed when the operating mode is OFF.

CALL[:CELL]:MS:CCHannel:POWer:OFFSet:DCS

This command specifies an additional offset for use with the Max CCH value in the DCS band only. It accepts values in the range 0 to 3. This command is an LA only command, and can only be changed when the operating mode is OFF.

CALL:TRIGger[:OUTPut]:FRAMe:NIDLe:STATe

This command which was previously only available in the LA, is now available in the GSM and GPRS TAs.

CALL[:CELL]:BCHannel:SCELl

This command sets the serving cell, that is it determines the capabilities of the cell BCH generated by the base station emulator.

Parameters are license dependent and can include GSM | GPRS | EGPRS.

The EGPRS parameter is only applicable when licensed for EDGE. The GPRS parameter is only applicable when licensed for GPRS. If the only application licensed is GSM, you will be unable to change this setting. If you are licensed for GPRS, setting this parameter to GSM will mean that GPRS BCH information (sysinfo 13 etc) is not broadcast, therefore GPRS mobiles won't attempt to attach.

CALL:MS:REPorted:PCLass:EPSK:DCS

CALL:MS:REPorted:PCLass:EPSK:EGSM

CALL:MS:REPorted:PCLass:EPSK:GSM450

CALL:MS:REPorted:PCLass:EPSK:GSM480

CALL:MS:REPorted:PCLass:EPSK:GSM750

CALL:MS:REPorted:PCLass:EPSK:GSM850

CALL:MS:REPorted:PCLass:EPSK:PCS

CALL:MS:REPorted:PCLass:EPSK:PGSM

CALL:MS:REPorted:PCLass:EPSK:RGSM

CALL:MS:REPorted:PCLass:EPSK[:SELected]

CALL:MS:REPorted:PCLass:GMSK:DCS

CALL:MS:REPorted:PCLass:GMSK:EGSM

CALL:MS:REPorted:PCLass:GMSK:GSM450

CALL:MS:REPorted:PCLass:GMSK:GSM480

CALL:MS:REPorted:PCLass:GMSK:GSM750

CALL:MS:REPorted:PCLass:GMSK:GSM850

CALL:MS:REPorted:PCLass:GMSK:PCS

CALL:MS:REPorted:PCLass:GMSK:PGSM

CALL:MS:REPorted:PCLass:GMSK:RGSM

CALL:MS:REPorted:PCLass:GMSK[:SELected]

The above commands return the power class for each band in either the GSMK or EPSK (8PSK - EDGE) modulation scheme. This information is only made available during the attach procedure and therefore, is not available to the GSM TA.

CALL:MS:REPorted:MCLass:EGPRS:DCS

CALL:MS:REPorted:MCLass:EGPRS:EGSM

CALL:MS:REPorted:MCLass:EGPRS:GSM450

CALL:MS:REPorted:MCLass:EGPRS:GSM480

CALL:MS:REPorted:MCLass:EGPRS:GSM750

CALL:MS:REPorted:MCLass:EGPRS:GSM850

CALL:MS:REPorted:MCLass:EGPRS:PCS

CALL:MS:REPorted:MCLass:EGPRS:PGSM

CALL:MS:REPorted:MCLass:EGPRS:RGSM

CALL:MS:REPorted:MCLass:EGPRS[:SELected]

CALL:MS:REPorted:MCLass:GPRS:DCS

CALL:MS:REPorted:MCLass:GPRS:EGSM

CALL:MS:REPorted:MCLass:GPRS:GSM450

CALL:MS:REPorted:MCLass:GPRS:GSM480

CALL:MS:REPorted:MCLass:GPRS:GSM750

CALL:MS:REPorted:MCLass:GPRS:GSM850

CALL:MS:REPorted:MCLass:GPRS:PCS

CALL:MS:REPorted:MCLass:GPRS:PGSM

CALL:MS:REPorted:MCLass:GPRS:RGSM

CALL:MS:REPorted:MCLass:GPRS[:SELected]

The above commands return the power class for each band in either the GSMK or EPSK (8PSK - EDGE) modulation scheme as reported by the mobile during its attach procedure. This information is only made available during the attach procedure and therefore, is not available to the GSM TA.

CALL:MS:REPorted:SBANd[:GMSK]?

Returns a comma-separated list of all supported bands.

RFANalyzer:CONTrol:MEASurement:BURSt:AUTO <0 | 1 | OFF | ON>

This command determines how the receiver decides which uplink burst to measure. If set to the default "ON" state, the measurement burst will be determined automatically. When set to the "OFF" or manual state, the measurement is made on either burst 1 or 2 set by the following new command

RFANalyzer:MANual:MEASurement:BURSt <1 | 2>

This manual measurement burst command is active only when the control measurement burst auto is off. In the manual mode, if you attempt to measure burst 2 while on a GSM call, the TXP measurement will report an integrity error of `Parameter Error'.

CALL:PCTCh:MSLot:MEASurement:BURSt <1 | 2>

This new command sets which uplink burst will be measured for single slot measurements on dual uplink PDTCH's when the receiver measurement burst control is AUTO. This command setting has no effect on GSM calls where the measurement burst will always be 1.


IEEE 488.2 Common Commands

IEEE 488.2 Common Commands

Description

*CLS

The *CLS, clear status command, is defined in "IEEE Std 488.2-1992", 10.3. If an error message is currently posted on the test set's display, this command also closes the error message.

*ESE

The *ESE, standard event status enable command, is defined in "IEEE Std 488.2-1992", 10.10.

*ESE?

The *ESE?, standard event status enable query, is defined in "IEEE Std 488.2-1992", 10.11.

*ESR?

The *ESR?, standard event status register query, is defined in "IEEE Std 488.2-1992 ",10.12.

*IDN?

The *IDN?, identification query, is defined in "IEEE Std 488.2-1992", 10.14.*IDN? is used to retrieve information about the test set in ASCII format.

*IDN?, returns ASCII codes 32 through 126 excluding comma and semicolon in four comma separated fields. Field 1 returns the manufacturer, field 2 returns the instrument model number, field 3 returns the serial number, field 4 returns 0.

*OPC

The *OPC, operation complete command, is defined in "IEEE 488.2-1992", 10.18. *OPC causes the test set to continuously sense the No Operation Pending flag. When the No Operation Pending flag becomes TRUE, the OPC event bit in the standard event status register (ESR) is set to indicate that the state of all pending operations is completed. The *OPC common command is not recommended for use as an overlapped command.

*OPC?

The *OPC?, operation complete query, is defined in "IEEE Std 488.2-1992", 10.19. The *OPC? query allows synchronization between the controller and the test set using either the message available (MAV) bit in the status byte, or a read of the output OPC?. The *OPC? query does not effect the OPC event bit in the Standard Event Status Register (ESR). The *OPC? common command is not recommended for use as an overlapped command.

*OPT?

The *OPT?, option identification query, is defined in "IEEE Std 488.2-1992", 10.20. Each option will have a unique name, that name will be retuned with the query.

*RST

The *RST, full preset command, is defined in "IEEE Std 488.2-1992", 10.32. *RST is the recommended command when performing a full preset on the test set. A *RST restores the majority of settings to their default values.

  • *RST sets trigger arm to single
  • PRESet2 sets trigger arm to continuous

*SRE

The *SRE, service request enable command, is defined in "IEEE Std 488.2-1992", 10.34. The parameter range for this command is 0 through 255.

*SRE?

The *SRE?, service request enable query, is defined in "IEEE Std 488.2-1992", 10.35. Values returned by this query range from 0 through 255.

*STB?

The *STB?, read status byte query, is defined in "IEEE Std 488.2-1992", 10.36. Values returned by this query range from 0 through 255.

*TST?

The test set's implementation of *TST? does not follow the "IEEE Std 488.2-1992" section 10.38 definition. Rather, the test set's implementation is as described in the "Verifying the Test Set" (Self Test) topic in the Related Topics below. Values returned by this query are 0 (pass) and -330 (fail).

*WAI

The *WAI, wait-to-continue command, is defined in "IEEE Std 488.2-1992", 10.39. The *WAI command prevents the test set from executing any further commands or queries until all pending operation flags are false. The *WAI common command is not recommended for use as an overlapped command.

Related Topics

Call Processing Event Synchronization


DISPlay

DISPlay

GPIB Command Conventions

  • DISPlay:BRIGhtness
  • DISPlay:MODE
  • DISPlay:MESSage:MASKable:STATe
  • DISPlay:WINDow:ERRor:CLEar

DISPlay:BRIGhtness

Function

GSM TA

Sets/queries the test set's display brightness.

A display backlight dimming feature lowers the display brightness after approximately 10 minutes without any manual user interaction with the test set. See Display Backlight Dimming .

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Setting

Range: MEDium | HIGH

Query

Range: MED | HIGH

Factory setting

HIGH (this parameter is not affected by any reset operation and can only be changed by direct user access)
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"DISPLAY:BRIGHTNESS MEDIUM"
! Sets display brightness to medium.

DISPlay:MODE

Function

GSM TA

Sets/queries the test set's display mode.

See Display Mode (Track/Fast) .

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting | Range: FAST | TRACK

Query

 Range: FAST | TRAC
*RST setting | TRACK
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"DISPLAY:MODE FAST"
! Sets display mode to fast.

DISPlay:MESSage:MASKable:STATe

Function

GSM TA

Blocks maskable messages from appearing on the test set display screen but not from the Message Log. Maskable messages are reported to the Message Log in either state.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Setting

Range: 1 | ON | 0 | OFF

Query

Range: 1 | ON | 0 | OFF

Factory setting

1 | ON
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"DISPLAY:MESSAGE:MASKABLE:STATE OFF"
! Prevents certain messages from appearing on the display.

DISPlay:WINDow:ERRor:CLEar

Function

GSM TA

Clears the error message from the display screen but not from the Message Log.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"DISPLAY:WINDOW:ERROR:CLEAR"
! Clears an error message from the display.


DISPlay Subsystem

DISPlay Subsystem

Description

The DISPlay subsystem is used to configure the test set's display mode or display brightness . Use of the DISPlay subsystem is not required to set or query any data or results.

Display Backlight Dimming

The test set's display brightness parameter has two settings at this time, high and medium. The life of the display's backlight will be maximized when brightness is set to medium. The test set has an auto dimming feature that will lower the display brightness automatically if approximately 10 minutes pass without a key being pressed on the test set's front panel. The display will return to the brightness level shown in the Display Brightness field when the test set is set to local and any front panel key is pressed. There is no other user control for this feature.

Syntax Diagram and Command Descriptions

DISPlay


FETCh:AAUDio

FETCh:AAUDio

GPIB Command Conventions

  • FETCh:AAUDio[:ALL]?
  • FETCh:AAUDio:DISTortion[:AVERage]?
  • FETCh:AAUDio:DISTortion:ALL?
  • FETCh:AAUDio:DISTortion:MAXimum?
  • FETCh:AAUDio:DISTortion:MINimum?
  • FETCh:AAUDio:DISTortion:SDEViation?
  • FETCh:AAUDio:FREQuency[:AVERage]?
  • FETCh:AAUDio:FREQuency:ALL?
  • FETCh:AAUDio:FREQuency:MAXimum?
  • FETCh:AAUDio:FREQuency:MINimum?
  • FETCh:AAUDio:FREQuency:SDEViation?
  • FETCh:AAUDio:ICOunt?
  • FETCh:AAUDio:INTegrity?
  • FETCh:AAUDio:SINad[:AVERage]?
  • FETCh:AAUDio:SINad:ALL?
  • FETCh:AAUDio:SINad:MAXimum?
  • FETCh:AAUDio:SINad:MINimum?
  • FETCh:AAUDio:SINad:SDEViation?
  • FETCh:AAUDio:VOLTage[:AVERage]?
  • FETCh:AAUDio:VOLTage:ALL?
  • FETCh:AAUDio:VOLTage:MAXimum?
  • FETCh:AAUDio:VOLTage:MINimum?
  • FETCh:AAUDio:VOLTage:SDEViation?

FETCh:AAUDio[:ALL]?

Function

GSM TA

This query returns the analog audio measurement results. This query returns an integrity indicator (see Integrity Indicator ), average analog audio level, average SINAD, average distortion and the average audio frequency. Values are returned in a comma-separated list.

If the analog audio Multi-Measurement Count field is off, the level returned by this command is displayed in the Analog Audio In Level field. If the analog audio multi-measurement count is on, the level returned by this command is displayed in the Analog Audio Average field.

GSM/GPRS LA

EGPRS LA

GPRS TA

This command is not applicable to GPRS.

EGPRS TA

This command is not applicable to EGPRS.

Query

Integrity indicator

  • Range: See Integrity Indicator .
  • Resolution: 1

Average analog audio level

  • Range: 5 mVrms to 14.1 Vrms
  • Resolution: 0.1 mVrms

Average SINAD

  • Range: -99 to 99 dB, 9.91 E+37
  • Resolution: 0.01 dB

Average distortion

  • Range: 0 to 99%
  • Resolution: 0.01%

Average audio frequency

  • Range: 0 to 99999 Hz
  • Resolution: 0.01 Hz

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

FETCh:AAUDio:DISTortion[:AVERage]?

Function

GSM TA

This query returns the average audio distortion measurement.
GSM/GPRS LA

EGPRS LA

GPRS TA

This command is not applicable to GPRS.

EGPRS TA

This command is not applicable to EGPRS.

Query

Average audio distortion

  • Range: 0 to 99%, 9.91 E+37

  • Resolution: 0.01%

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

FETCh:AAUDio:DISTortion:ALL?

Function

GSM TA

This query returns the audio distortion measurements.

The measurement results are returned in the following order: minimum distortion, maximum distortion, average distortion, and standard deviation distortion.

GSM/GPRS LA

EGPRS LA

GPRS TA

This command is not applicable to GPRS.

EGPRS TA

This command is not applicable to EGPRS.

Query

Minimum, maximum, and average audio distortion:

  • Range: 0 to 99%, 9.91 E+37

  • Resolution: 0.01%

Standard deviation audio distortion:

  • Range: 0 to 99%, 9.91 E+37

  • Resolution: 0.001%

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

FETCh:AAUDio:DISTortion:MAXimum?

Function | GSM TA | This query returns the maximum audio distortion.
 | GSM/GPRS LA
 | EGPRS LA
 | GPRS TA | This command is not applicable to GPRS.
 | EGPRS TA | This command is not applicable to EGPRS.
Query |  | Range: 0 to 99%, 9.91 E+37 Resolution: 0.01%
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.01 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.01 and above

FETCh:AAUDio:DISTortion:MINimum?

Function | GSM TA | This query returns the minimum audio distortion.
 | GSM/GPRS LA
 | EGPRS LA
 | GPRS TA | This command is not applicable to GPRS.
 | EGPRS TA | This command is not applicable to EGPRS.
Query |  | Range: 0 to 99%, 9.91 E+37 Resolution: 0.01%
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.01 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.01 and above

FETCh:AAUDio:DISTortion:SDEViation?

Function | GSM TA | This query returns the standard deviation audio distortion.
 | GSM/GPRS LA
 | EGPRS LA
 | GPRS TA | This command is not applicable to GPRS.
 | EGPRS TA | This command is not applicable to EGPRS.
Query |  | Range: 0 to 99%, 9.91 E+37 Resolution: 0.001%
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.01 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.01 and above

FETCh:AAUDio:FREQuency[:AVERage]?

Function

GSM TA

This query returns the average audio frequency measurement.

GSM/GPRS LA

EGPRS LA
GPRS TA

This command is not applicable to GPRS.

EGPRS TA

This command is not applicable to EGPRS.

Query

Average audio frequency

  • Range: 0 to 99999 Hz, 9.91 E+37

  • Resolution: 0.01 Hz

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

FETCh:AAUDio:FREQuency:ALL?

Function

GSM TA

This query returns the audio frequency measurements.

The measurement results are returned in the following order: minimum frequency, maximum frequency, average frequency, standard deviation frequency.

GSM/GPRS LA

EGPRS LA
GPRS TA

This command is not applicable to GPRS.

EGPRS TA

This command is not applicable to EGPRS.

Query

Minimum, maximum, and average audio frequency:

  • Range: 0 to 99999 Hz, 9.91 E+37

  • Resolution: 0.01 Hz

Standard deviation audio frequency:

  • Range: 0 to 99999 Hz, 9.91 E+37

  • Resolution: 0.001 Hz

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

FETCh:AAUDio:FREQuency:MAXimum?

Function | GSM TA | This query returns the maximum audio frequency.
 | GSM/GPRS LA
 | EGPRS LA
 | GPRS TA | This command is not applicable to GPRS.
 | EGPRS TA | This command is not applicable to EGPRS.
Query |  | Range: 0 to 99999 Hz, 9.91 E+37 Resolution: 0.01 Hz
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.01 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.01 and above

FETCh:AAUDio:FREQuency:MINimum?

Function | GSM TA | This query returns the minimum audio frequency.
 | GSM/GPRS LA
 | EGPRS LA
 | GPRS TA | This command is not applicable to GPRS.
 | EGPRS TA | This command is not applicable to EGPRS.
Query |  | Range: 0 to 99999 Hz, 9.91 E+37 Resolution: 0.01 Hz
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.01 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.01 and above

FETCh:AAUDio:FREQuency:SDEViation?

Function | GSM TA | This query returns the standard deviation audio frequency.
 | GSM/GPRS LA
 | EGPRS LA
 | GPRS TA | This command is not applicable to GPRS.
 | EGPRS TA | This command is not applicable to EGPRS.
Query |  | Range: 0 to 99999 Hz, 9.91 E+37 Resolution: 0.01 Hz
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.01 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.01 and above

FETCh:AAUDio:ICOunt?

Function | GSM TA | This query returns the intermediate count of analog audio multi-measurements completed. This value is not available over the manual interface.
 | GSM/GPRS LA
 | EGPRS LA
 | GPRS TA | This command is not applicable to GPRS.
 | EGPRS TA | This command is not applicable to EGPRS.
Query |  | Range: 1 to 999 Resolution: 1
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.01 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.01 and above

FETCh:AAUDio:INTegrity?

Function | GSM TA | This query returns the integrity indicator for the last analog audio measurement completed. Zero indicates a normal measurement. See Integrity Indicator for descriptions of non-zero integrity indicators.
 | GSM/GPRS LA
 | EGPRS LA
 | GPRS TA | This command is not applicable to GPRS.
 | EGPRS TA | This command is not applicable to EGPRS.
Query |  | Range: See Integrity Indicator . Resolution: 1
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.01 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.01 and above

FETCh:AAUDio:SINad[:AVERage]?

Function

GSM TA

This query returns the average SINAD measurement.

GSM/GPRS LA

EGPRS LA

GPRS TA

This command is not applicable to GPRS.

EGPRS TA

This command is not applicable to EGPRS.

Query

Average SINAD

  • Range:-99 to 99 dB, 9.91 E+37

  • Resolution: 0.01 dB

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

FETCh:AAUDio:SINad:ALL?

Function

GSM TA

Queries the SINAD measurements.

Measurement results are returned in the following order: minimum SINAD, maximum SINAD, average SINAD, and standard deviation SINAD.

GSM/GPRS LA

EGPRS LA

GPRS TA

This command is not applicable to GPRS.

EGPRS TA

This command is not applicable to EGPRS.

Query

Minimum, maximum, average SINAD:

  • Range: -99 to 99 dB, 9.91 E+37

  • Resolution: 0.01 dB

Standard deviation SINAD

  • Range: -99 to 99 dB, 9.91 E+37

  • Resolution: 0.001 dB

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

FETCh:AAUDio:SINad:MAXimum?

Function | GSM TA | This query returns the maximum SINAD measurement.
 | GSM/GPRS LA
 | EGPRS LA
 | GPRS TA | This command is not applicable to GPRS.
 | EGPRS TA | This command is not applicable to EGPRS.
Query |  | Range: -99 to 99 dB, 9.91 E+37 Resolution: 0.01 dB
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.01 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.01 and above

FETCh:AAUDio:SINad:MINimum?

Function | GSM TA | This query returns the minimum SINAD measurement.
 | GSM/GPRS LA
 | EGPRS LA
 | GPRS TA | This command is not applicable to GPRS.
 | EGPRS TA | This command is not applicable to EGPRS.
Query |  | Range: -99 to 99 dB, 9.91 E+37 Resolution: 0.01 dB
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.01 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.01 and above

FETCh:AAUDio:SINad:SDEViation?

Function | GSM TA | This query returns the standard deviation SINAD measurements.
 | GSM/GPRS LA
 | EGPRS LA
 | GPRS TA | This command is not applicable to GPRS.
 | EGPRS TA | This command is not applicable to EGPRS.
Query |  | Range: 0 to 99 dB, 9.91 E+37 Resolution: 0.001 dB
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.01 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.01 and above

FETCh:AAUDio:VOLTage[:AVERage]?

Function | GSM TA | This query returns the average analog audio level. Value is returned in units of Vrms.
 | GSM/GPRS LA
 | EGPRS LA
 | GPRS TA | This command is not applicable to GPRS.
 | EGPRS TA | This command is not applicable to EGPRS.
Query |  | Range: 5 mVrms to 14.1 Vrms Resolution: 0.1 mVrms
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.01 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.01 and above

FETCh:AAUDio:VOLTage:ALL?

Function

GSM TA

This query returns the analog audio multi-measurement minimum, maximum, average and standard deviation. Values are returned in a comma-separated list.

GSM/GPRS LA

EGPRS LA

GPRS TA

This command is not applicable to GPRS.

EGPRS TA

This command is not applicable to EGPRS.

Query

Minimum

  • Range: 10 mVrms to 20 Vrms
  • Resolution: 0.1 mVrms

Maximum

  • Range: 10 mVrms to 20 Vrms
  • Resolution: 0.1 mVrms

Average

  • Range: 10 mVrms to 20 Vrms
  • Resolution: 0.1 mVrms

Standard deviation

  • Range: 0 V to 14.14214 V
  • Resolution: 0.01 mV

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

FETCh:AAUDio:VOLTage:MAXimum?

Function | GSM TA | This query returns the analog audio multi-measurement maximum analog audio voltage.
 | GSM/GPRS LA
 | EGPRS LA
 | GPRS TA | This command is not applicable to GPRS.
 | EGPRS TA | This command is not applicable to EGPRS.
Query |  | Range: 10 mVrms to 20 Vrms Resolution: 0.1 mVrms
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.01 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.01 and above

FETCh:AAUDio:VOLTage:MINimum?

Function | GSM TA | This query returns the analog audio multi-measurement minimum analog audio voltage.
 | GSM/GPRS LA
 | EGPRS LA
 | GPRS TA | This command is not applicable to GPRS.
 | EGPRS TA | This command is not applicable to EGPRS.
Query |  | Range: 10 mVrms to 20 Vrms Resolution: 0.1 mVrms
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.01 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.01 and above

FETCh:AAUDio:VOLTage:SDEViation?

Function | GSM TA | This query returns the analog audio multi-measurement standard deviation.
 | GSM/GPRS LA
 | EGPRS LA
 | GPRS TA | This command is not applicable to GPRS.
 | EGPRS TA | This command is not applicable to EGPRS.
Query |  | Range: 0 V to 14.14214 V Resolution: 0.01 mV
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.01 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.01 and above


FETCh:BERRor

FETCh:BERRor

GPIB Command Conventions

  • FETCh:BERRor[:ALL]?
  • FETCh:BERRor:BITS?
  • FETCh:BERRor:BITS:TYPEIA|TYPEIB|TYPEII?
  • FETCh:BERRor:COUNt[:BITS]?
  • FETCh:BERRor:COUNt:CRC?
  • FETCh:BERRor:COUNt:FE?
  • FETCh:BERRor:COUNt:TYPEIA|TYPEIB|TYPEII?
  • FETCh:BERRor:DELay?
  • FETCh:BERRor:FULL?
  • FETCh:BERRor:ICOunt?
  • FETCh:BERRor:INTegrity?
  • FETCh:BERRor:RATio[:BITS]?
  • FETCh:BERRor:RATio:CRC?
  • FETCh:BERRor:RATio:FE?
  • FETCh:BERRor:RATio:TYPEIA|TYPEIB|TYPEII?

FETCh:BERRor[:ALL]?

Function

 GSM TA

Queries the bit error measurement. Query returns integrity indicator, bits tested, bit error ratio, and bit error count. (A similar query, FETCh:BERRor:FULL? , returns the same results but for all bit types simultaneously.) See Bit Error Measurement .

GSM/GPRS LA

EGPRS LA

GPRS TA

 This command is not applicable to GPRS.

EGPRS TA

This command is not applicable to EGPRS.

Query

Integrity indicator

  • Range: See Integrity Indicator .
  • Resolution: 1

Bits tested

  • Range: 0 to 999,131 and 9.91 E+37 (NAN)
  • Resolution: 1

Bit error ratio

  • Range: 0 to 100 and 9.91 E+37 (NAN)
  • Resolution: 0.01

Bit error count

  • Range: 1 to 999,131 and 9.91 E+37 (NAN)
  • Resolution: 1
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

FETCh:BERRor:BITS?

Function

 GSM TA

Queries the number of bits actually tested. This query only returns the result of the bit type set using the SETup:BERRor[:TYPE] command.

The number of bits actually tested will exceed the number requested because the test set rounds up the number requested to the nearest number that results in an integral number of speech frames. One speech frame is 132 bits. The test set measures complete a speech frame and it is queried for bits. See Bit Error Measurement

GSM/GPRS LA

EGPRS LA
GPRS TA

This command is not applicable to GPRS.

EGPRS TA

This command is not applicable to EGPRS.

Query

Bits tested

  • Range: 0 to 999,131 and 9.91 E+37 (NAN)

  • Resolution: 1

*RST Setting

10,000
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

FETCh:BERRor:BITS:TYPEIA|TYPEIB|TYPEII?

Function | GSM TA | Queries the number of bits which have been tested. This query allows you to select the bit type you want to query; either Type Ia, Type Ib or Type II. See Bit Error Measurement
 | GSM/GPRS LA
 | EGPRS LA
 | GPRS TA | This command is not applicable to GPRS.
 | EGPRS TA | This command is not applicable to EGPRS.
Query |  | Range for Type Ia: 0 to 999,000 and 9.91 E+37 (NAN) Range for Type Ib: 0 to 2,637,369 and 9.91 E+37 (NAN) Range for Type II: 0 to 1,558,440 and 9.91 E+37 (NAN) Resolution: 1
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.01 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.01 and above

FETCh:BERRor:COUNt[:BITS]?

Function | GSM TA | Queries the number of bits that were in error during the last bit error test. See Bit Error Measurement The manual user must set the measurement unit to count.
 | GSM/GPRS LA
 | EGPRS LA
 | GPRS TA | This command is not applicable to GPRS.
 | EGPRS TA | This command is not applicable to EGPRS.
Query |  | Range: 1 to 999,131 and 9.91 E+37 (NAN) Resolution: 1
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.01 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.01 and above

FETCh:BERRor:COUNt:CRC?

Function

GSM TA

Queries the number of bad cyclic redundancy checks (CRCs) for a non-residual measurement type, loopback type B test. See Bit Error Measurement

The mobile station re-transmits the CRC it received from the test set on the uplink.

A bad CRC occurs when the CRC transmitted by the test set does not match what is received back from the mobile station.

The manual user must set the measurement unit to count.

GSM/GPRS LA

EGPRS LA

GPRS TA

This command is not applicable to GPRS.

EGPRS TA

This command is not applicable to EGPRS.

Query

Range: 0 to 19,980 and 9.91 E+37 (NAN)

Resolution: 1
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

FETCh:BERRor:COUNt:FE?

Function | GSM TA | Queries the number of frames erased during a residual measurement type, looback type A test. The manual user must set the measurement's unit to count.
 | GSM/GPRS LA
 | EGPRS LA
 | GPRS TA | This command is not applicable to GPRS.
 | EGPRS TA | This command is not applicable to EGPRS.
Query |  | Range: 0 to 19,980 and 9.91 E+37 (NAN) Resolution: 1
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.01 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.01 and above

FETCh:BERRor:COUNt:TYPEIA|TYPEIB|TYPEII?

Function | GSM TA | Queries the number of bits in error. This query allows you to select the bit type you want to query; either Type Ia, Type Ib or Type II. See Bit Error Measurement
 | GSM/GPRS LA
 | EGPRS LA
 | GPRS TA | This command is not applicable to GPRS.
 | EGPRS TA | This command is not applicable to EGPRS.
Query |  | Range for Type Ia: 0 to 999,000 and 9.91 E+37 (NAN) Range for Type Ib: 0 to 2,637,369 and 9.91 E+37 (NAN) Range for Type II: 0 to 1,558,440 and 9.91 E+37 (NAN) Resolution: 1
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.01 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.01 and above

FETCh:BERRor:DELay?

Function

GSM TA

Queries the delay (in speech frames) that the test set used during the last bit error measurement to correlate uplink information bits with downlink information bits.

This value is displayed in the Loopback Delay field.

This value can be determined automatically, or manually set by the user. See SETup:BERRor:MANual:DELay and SETup:BERRor:LDControl:AUTO .

Refer also to the Bit Error Measurement for a description of loopback delay and how it is used in the bit error measurement.

GSM/GPRS LA

EGPRS LA

GPRS TA

This command is not applicable to GPRS.
EGPRS TA

This command is not applicable to EGPRS.

Query

Range: 0 to 15 and 9.91 E+37 (NAN)

Resolution: 1

*RST Setting

Auto

Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

FETCh:BERRor:FULL?

Function

GSM TA

Queries the bit error measurement.

Returns Integrity Indicator see Integrity Indicator , Bits Tested, Bit Error Ratio and Bit Error Count for Type Ia, Type Ib and Type II bits. (A similar query, FETCh:BERRor[:ALL]? , returns the same results but only for the bit type previously set using the SETup:BERRor[:TYPE] command.) See Bit Error Measurement

GSM/GPRS LA

EGPRS LA

GPRS TA

This command is not applicable to GPRS.
EGPRS TA

This command is not applicable to EGPRS.

Query

Integrity indicator

  • Range: See Integrity Indicator .
  • Resolution: 1

Type Ia Bits tested

  • Range: 0 to 999,000 and 9.91E+37 (NAN)
  • Resolution: 1

Type Ia Bit error ratio

  • Range: 0 to 100 and 9.91E+37 (NAN)
  • Resolution: 0.01

Type Ia Bit error count

  • Range: 0 to 999,000 and 9.91E+37 (NAN)
  • Resolution: 1

Type Ib Bits tested

  • Range: 0 to 2,637,369 and 9.91E+37 (NAN)
  • Resolution: 1

Type Ib Bit error ratio

  • Range: 0 to 100 and 9.91E+37 (NAN)
  • Resolution: 0.01

Type Ib Bit error count

  • Range: 0 to 2,637,369 and 9.91E+37 (NAN)
  • Resolution: 1

Type II Bits tested

  • Range: 0 to 15,584,400 and 9.91E+37 (NAN)
  • Resolution: 1

Type II Bit error ratio

  • Range: 0 to 100 and 9.91E+37 (NAN)
  • Resolution: 0.01

Type II Bit error count

  • Range: 0 to 1,558,440 and 9.91E+37 (NAN)
  • Resolution: 1
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

FETCh:BERRor:ICOunt?

Function | GSM TA | Queries the intermediate count of bits tested (measurement progress report). See Measurement Progress Report
 | GSM/GPRS LA
 | EGPRS LA
 | GPRS TA | This command is not applicable to GPRS.
 | EGPRS TA | This command is not applicable to EGPRS.
Query |  | Range: 0 to 999 Resolution: 1
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.01 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.01 and above

FETCh:BERRor:INTegrity?

Function | GSM TA | Returns the integrity indicator value for the last bit error measurement performed. Zero indicates a normal result. See Integrity Indicator for descriptions of non-zero integrity indicators.
 | GSM/GPRS LA
 | EGPRS LA
 | GPRS TA | This command is not applicable to GPRS.
 | EGPRS TA | This command is not applicable to EGPRS.
Query |  | Range: See Integrity Indicator . Resolution: 1
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.01 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.01 and above

FETCh:BERRor:RATio[:BITS]?

Function | GSM TA | Queries the ratio of bits in error to the number of bits tested during the last bit error test and returns it as a percentage. See Bit Error Measurement The manual user must set the measurement unit to %.
 | GSM/GPRS LA
 | EGPRS LA
 | GPRS TA | This command is not applicable to GPRS.
 | EGPRS TA | This command is not applicable to EGPRS.
Query |  | Range: 1 to 100 and 9.91 E+37 (NAN) Resolution: 0.01
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.01 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.01 and above

FETCh:BERRor:RATio:CRC?

Function

 GSM TA

Queries the ratio of bad cyclic redundancy checks (CRCs) to the total number of CRCs received for a non-residual measurement type, looback type B test and returns it as a percentage. See Bit Error Measurement

The mobile station re-transmits the CRC it received from the test set on the uplink.

A bad CRC occurs when the CRC transmitted by the test set does not match what is received back from the mobile station.

The manual user must set the measurement's unit to %.

GSM/GPRS LA

EGPRS LA

GPRS TA

This command is not applicable to GPRS.
EGPRS TA

This command is not applicable to EGPRS.

Query

Range: 0 to 100 and 9.91 E+37 (NAN)

Resolution: 0.01
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

FETCh:BERRor:RATio:FE?

Function | GSM TA | Queries the ratio of erased frames to the total number of frames received for a residual measurement type, looback type A test and returns them as a percentage. See Bit Error Measurement The manual user must set the measurement's unit to %.
 | GSM/GPRS LA
 | EGPRS LA
 | GPRS TA | This command is not applicable to GPRS.
 | EGPRS TA | This command is not applicable to EGPRS.
Query |  | Range: 0 to 100 and 9.91 E+37 (NAN) Resolution: 0.01
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.01 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.01 and above

FETCh:BERRor:RATio:TYPEIA|TYPEIB|TYPEII?

Function | GSM TA | Queries the number of bits in error to the number of bits tested. This query allows you to select the bit type you want to query; either Type Ia, Type Ib or Type II. The result is returned as a percentage. See Bit Error Measurement
 | GSM/GPRS LA
 | EGPRS LA
 | GPRS TA | This command is not applicable to GPRS.
 | EGPRS TA | This command is not applicable to EGPRS.
Query |  | Range: 0 to 100 and 9.91 E+37 (NAN) Resolution: 0.01
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.01 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.01 and above


FETCh:BLERror

FETCh:BLERror

GPIB Command Conventions

  • FETCh:BLERror[:ALL]?
  • FETCh:BLERror:BLOCks?
  • FETCh:BLERror:BURSt<[1]|2|3|4|5>[:ALL]?
  • FETCh:BLERror:BURSt:ALL?
  • FETCh:BLERror:COUNt?
  • FETCh:BLERror:CRC?
  • FETCh:BLERror:DELay?
  • FETCh:BLERror:ICOunt?
  • FETCh:BLERror:INTegrity?
  • FETCh:BLERror:RATio?
  • FETCh:BLERror:RATio:BURSt[1]|2|3|4|5?
  • FETCh:BLERror:RATio:DOWNlink[:ALL]?

FETCh:BLERror[:ALL]?

Function

 GSM TA

This command is not applicable to GSM.

GPRS TA

This query returns the block error measurement results. The integrity indicator, blocks tested, block error ratio, and block error count are returned.

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Integrity indicator:

  • Range: See Integrity Indicator .
  • Resolution: 1

Blocks tested:

  • Range: 0 to 99127 and 9.91 E+37 (NAN)
  • Resolution: 1

Block error ratio:

  • Range: 0 to 100 and 9.91 E+37 (NAN)
  • Resolution: 0.01

Block error count:

  • Range: 0 to 99127 and 9.91 E+37 (NAN)
  • Resolution: 1
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

FETCh:BLERror:BLOCks?

Function | GSM TA | This command is not applicable to GSM.
 | GPRS TA | This query returns the total number of information blocks tested during the last block error measurement. See FETCh:BLERror:COUNt? .
 | EGPRS TA
 | GSM/GPRS LA
 | EGPRS LA
Query |  | Range: 0 to 99127 and 9.91 E+37 (NAN) Resolution: 1
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.01 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.01 and above

FETCh:BLERror:BURSt<[1]|2|3|4|5>[:ALL]?

Function

 GSM TA

This command is not applicable to GSM.

GPRS TA

This query returns the block error measurement results by time slot. The integrity indicator, blocks tested, block error ratio, and block error count are returned.

This query can only be used when the BLER measurement method is Polling. See Block Error Measurement for more information about the BLER measurement methods.

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Integrity indicator:

  • Range: See Integrity Indicator .
  • Resolution: 1

Blocks tested:

  • Range: 0 to 99127 and 9.91 E+37 (NAN)
  • Resolution: 1

Block error ratio:

  • Range: 0 to 100 and 9.91 E+37 (NAN)
  • Resolution: 0.01

Block error count:

  • Range: 0 to 99127 and 9.91 E+37 (NAN)
  • Resolution: 1
Requirements GSM/GPRS/
EGPRS TA

Revision: A.03 and above

Revision A.04 adds Burst 3 and Burst 4

Revision A.09 adds Burst 5

GSM/GPRS/ EGPRS LA

Revision: C.03 and above

Revision E.00.08 adds Burst 5.
Programming Example
OUTPUT 714;"FETC:BLER:BURS?" ! Query results for the first burst.
OUTPUT 714;"FETC:BLER:BURS2?" ! Query results for the second burst.
OUTPUT 714;"FETC:BLER:BURS3?" ! Query results for the third burst.
OUTPUT 714;"FETC:BLER:BURS4?" ! Query results for the fourth burst.

FETCh:BLERror:BURSt:ALL?

Function

 GSM TA

This command is not applicable to GSM.

GPRS TA

This query returns the block error measurement results for all the bursts. The total integrity indicator and the block error ratio for burst 1 to 8 are returned. Note, the block error ratio for burst 7 and 8 are always NAN. .

This query can only be used when the BLER measurement method is Polling. See Block Error Measurement for more information about the BLER measurement methods.

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Integrity indicator:

  • Range: See Integrity Indicator .
  • Resolution: 1

Block error ratio:

  • Range: 0 to 100 and 9.91 E+37 (NAN)
  • Resolution: 0.01
Requirements GSM/GPRS/
EGPRS TA

Revision: A.09 and above
GSM/GPRS/ EGPRS LA

Revision: F.01 and above
Programming Example
OUTPUT 714;"FETC:BLER:BURS:ALL?"

FETCh:BLERror:COUNt?

Function | GSM TA | This command is not applicable to GSM.
 | GPRS TA | This query returns the count of erroneous blocks found during the last block error measurement.
 | EGPRS TA
 | GSM/GPRS LA
 | EGPRS LA
Query |  | Range: 0 to 99127 and 9.91 E+37 (NAN) Resolution: 1
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.01 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.01 and above

FETCh:BLERror:CRC?

Function

 GSM TA

This command is not applicable to GSM.

GPRS TA

This query returns the CRC (Frame Check Sequence) Error Count found during the last BLER measurement. Each block that fails its CRC will cause the CRC Error Count result to increment.

The CRC Error Count is only applicable to loopback BLER measurements. NAN will always be returned for polling BLER measurements. (Refer to BLER measurement method usage .)

The CRC Error Count affects the BLER measurement results differently depending on the BLER Bad Block Handling setting. For more information on the BLER Bad Block Handling setting see SETup:BLERror:BBLocks .

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Range: 0 to 99999 and 9.91 E+37 (NAN)

Resolution: 1
Requirements GSM/GPRS/
EGPRS TA

Revision: A.05 and above
GSM/GPRS/ EGPRS LA

Revision: D.02 and above

FETCh:BLERror:DELay?

Function | GSM TA | This command is not applicable to GSM.
 | GPRS TA | This query returns the block delay the test set used during the last block error measurement. This value can be determined automatically by the test set, or you can set it manually. See SETup:BLERror:MANual:DELay and SETup:BLERror:LDControl:AUTO for setting this value manually. This query is not applicable when the data connection type is set to BLER.
 | EGPRS TA
 | GSM/GPRS LA
 | EGPRS LA
Query |  | Range: 1 to 12 and 9.91 E+37 (NAN) Resolution: 1
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.01 and above Revision A.03: Upper limit on range changed from 6 to 12
 | GSM/GPRS/ EGPRS LA | Revision: C.01 and above Revision C.03: Upper limit on range changed from 6 to 12

FETCh:BLERror:ICOunt?

Function | GSM TA | This command is not applicable to GSM.
 | GPRS TA | Queries the intermediate count (measurement progress report) of blocks tested.
 | EGPRS TA
 | GSM/GPRS LA
 | EGPRS LA
Query |  | Range: 0 to 99127 and 9.91 E+37 (NAN)
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.01 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.01 and above

FETCh:BLERror:INTegrity?

Function | GSM TA | This command is not applicable to GSM.
 | GPRS TA | This query returns the integrity indicator value for the last block error measurement performed. Zero indicates a normal result. See Integrity Indicator for descriptions of non-zero integrity indicators.
 | EGPRS TA
 | GSM/GPRS LA
 | EGPRS LA
Query |  | Range: See Integrity Indicator . Resolution: 1
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.01 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.01 and above

FETCh:BLERror:RATio?

Function | GSM TA | This command is not applicable to GSM.
 | GPRS TA | This query returns the ratio of erroneous blocks found during the last block error measurement.
 | EGPRS TA
 | GSM/GPRS LA
 | EGPRS LA
Query |  | Range: 0 to 100 and 9.91 E+37 (NAN) Resolution: 0.01
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.01 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.01 and above

FETCh:BLERror:RATio:BURSt[1]|2|3|4|5?

Function | GSM TA | This command is not applicable to GSM.
 | GPRS TA | This query returns the ratio of erroneous blocks found for each burst.
 | EGPRS TA
 | GSM/GPRS LA
 | EGPRS LA
Query |  | Range: 0 to 100 and 9.91 E+37 (NAN) Resolution: 0.01
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.04 and above Revision: A.09 ands Burst 5
 | GSM/GPRS/ EGPRS LA | Revision: C.03 and above Revision: E.00.08 adds Burst 5

FETCh:BLERror:RATio:DOWNlink[:ALL]?

Function

 GSM TA

This command is not applicable to GSM.

GPRS TA

THIS COMMAND IS OBSOLETE. Please use instead.

This query returns an integrity indicator and the block error ratio for each of the four downlink bursts.

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Integrity indicator:

  • Range: See Integrity Indicator .
  • Resolution: 1

Block error ratio for Burst 1:

  • Range: 0 to 100 and 9.91 E+37 (NAN)
  • Resolution: 0.01

Block error ratio for Burst 2:

  • Range: 0 to 100 and 9.91 E+37 (NAN)
  • Resolution: 0.01

Block error ratio for Burst 3:

  • Range: 0 to 100 and 9.91 E+37 (NAN)
  • Resolution: 0.01

Block error ratio for Burst 4:

  • Range: 0 to 100 and 9.91 E+37 (NAN)
  • Resolution: 0.01
Requirements GSM/GPRS/
EGPRS TA

Revision: A.03 and above
GSM/GPRS/ EGPRS LA

Revision: C.03 and above


FETCh:DAUDio

FETCh:DAUDio

GPIB Command Conventions

  • FETCh:DAUDio[:ALL]?
  • FETCh:DAUDio:ICOunt?
  • FETCh:DAUDio:INTegrity?
  • FETCh:DAUDio:AMPLitude[:AVERage]?
  • FETCh:DAUDio:AMPLitude:ALL?
  • FETCh:DAUDio:AMPLitude:MAXimum?
  • FETCh:DAUDio:AMPLitude:MINimum?
  • FETCh:DAUDio:AMPLitude:SDEViation?

FETCh:DAUDio[:ALL]?

Function

 GSM TA

Queries integrity indicator and average decoded audio results. Values are returned in a comma-separated list.

GSM/GPRS LA

EGPRS LA

GPRS TA

This command is not applicable to GPRS.

EGPRS TA

This command is not applicable to EGPRS.

Query

Integrity indicator:

  • Range: See Integrity Indicator .
  • Resolution: 1

Decoded audio:

  • Range: 0 to 100%
  • Resolution: 0.01% FS

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

FETCh:DAUDio:ICOunt?

Function | GSM TA | Queries the intermediate count of decoded audio multi-measurements completed. This value is not displayed on the test set.
 | GSM/GPRS LA
 | EGPRS LA
 | GPRS TA | This command is not applicable to GPRS.
 | EGPRS TA | This command is not applicable to EGPRS.
Query |  | Range: 1 to 999 Resolution: 1
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.01 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.01 and above

FETCh:DAUDio:INTegrity?

Function | GSM TA | Queries the integrity indicator for the last decoded audio measurement completed. Zero indicates a normal measurement. See Integrity Indicator for descriptions of non-zero integrity indicators.
 | GSM/GPRS LA
 | EGPRS LA
 | GPRS TA | This command is not applicable to GPRS.
 | EGPRS TA | This command is not applicable to EGPRS.
Query |  | Range: See Integrity Indicator . Resolution: 1
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.01 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.01 and above

FETCh:DAUDio:AMPLitude[:AVERage]?

Function

 GSM TA

Queries the average decoded audio result from an uplink speech level measurement in percent full scale.

If the decoded audio multi-measurement count field is off, the level returned by this command is displayed in the Decoded Audio Level field. If the decoded audio multi-measurement count is on, the level returned by this query is displayed in the Average field.

GSM/GPRS LA

EGPRS LA

GPRS TA

This command is not applicable to GPRS.

EGPRS TA

This command is not applicable to EGPRS.

Query

Range: 0 to 100%

Resolution: 0.01% FS

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

FETCh:DAUDio:AMPLitude:ALL?

Function

 GSM TA

Queries the decoded audio multi-measurement minimum, maximum, average and standard deviation. Values are returned in a comma-separated list.

The values returned are displayed in the Minimum, Maximum, Average, and Std. Dev. fields, which are displayed when the decoded audio multi-measurement count is not off.

GSM/GPRS LA

EGPRS LA

GPRS TA

This command is not applicable to GPRS.

EGPRS TA

This command is not applicable to EGPRS.

Query

Minimum:

  • Range: 0 to 100%
  • Resolution: 0.01% FS

Maximum:

  • Range: 0 to 100%
  • Resolution: 0.01% FS

Average:

  • Range: 0 to 100%
  • Resolution: 0.01% FS

Standard deviation:

  • Range: 0 to 71%
  • Resolution: 0.001% FS

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

FETCh:DAUDio:AMPLitude:MAXimum?

Function | GSM TA | Queries the decoded audio multi-measurement maximum decoded audio voltage. The value returned is displayed in the Decoded Audio Maximum field, which is displayed when the decoded audio multi-measurement count is not off.
 | GSM/GPRS LA
 | EGPRS LA
 | GPRS TA | This command is not applicable to GPRS.
 | EGPRS TA | This command is not applicable to EGPRS.
Query |  | Range: 0 to 100% Resolution: 0.01% FS
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.01 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.01 and above

FETCh:DAUDio:AMPLitude:MINimum?

Function | GSM TA | Queries the decoded audio multi-measurement minimum decoded audio voltage The value returned is displayed in the Decoded Audio Minimum field, which is displayed when the decoded audio multi-measurement count is not off.
 | GSM/GPRS LA
 | EGPRS LA
 | GPRS TA | This command is not applicable to GPRS.
 | EGPRS TA | This command is not applicable to EGPRS.
Query |  | Range: 0 to 100% Resolution: 0.01% FS
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.01 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.01 and above

FETCh:DAUDio:AMPLitude:SDEViation?

Function | GSM TA | Queries the decoded audio multi-measurement standard deviation. The value returned is displayed in the Decoded Audio Std Dev. field, which is displayed when the Decoded Audio multi-measurement count is not off.
 | GSM/GPRS LA
 | EGPRS LA
 | GPRS TA | This command is not applicable to GPRS.
 | EGPRS TA | This command is not applicable to EGPRS.
Query |  | Range: 0 to 71% Resolution: 0.001% FS
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.01 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.01 and above


FETCh? Subsystem

FETCh? Subsystem

Description

The FETCh? query is a function that allows users to query results from a measurement that was previously INITiated or READ. It does NOT begin a measurement. If no measurement is in progress it will return the integrity and measurement values from the last measurement made, or return an integrity of No Result Available and results of NAN. If a measurement is in process, the query will hang until the results are available, or the measurement fails or times out. The exact results returned with a FETCh? will depend on the specific measurement. A measurement may have a number of different results or combination of results for a FETCh?. The FETCh? queries are intended to be used to provide overlapped operation access to measurement results from the test set. When used along with SETup and INITiate commands , FETCh? is the primary way for the user to retrieve measurement results. In order to use the test set's concurrent test capabilities the overlapped commands of INITiate and FETCh? must be used. Overlapped commands allow the user to send commands and not wait for completion.

Syntax Diagrams and Command Descriptions

 | Applicable to:
 | GSM TA | GPRS TA | EGPRS TA | GSM/GPRS LA | EGPRS LA
FETCh:AAUDio | Yes | No | Yes | Yes | Yes
FETCh:BERRor | Yes | No | Yes | Yes | Yes
FETCh:<BFINdication|BFI> | No | No | No | No | Yes
FETCh:BLERror | No | Yes | Yes (includes support for 8PSK modulation coding schemes) | Yes | Yes (includes support for 8PSK modulation coding schemes)
FETCh:DAUDio | Yes | No | Yes | Yes | Yes
FETCh:DPOWer | Yes | Yes | Yes | Yes | Yes
FETCh:EDPower | No | No | Yes | No | Yes
FETCh:EMACcuracy | No | No | Yes | No | Yes
FETCh:ETXPower | No | No | Yes (includes support for 8PSK modulation coding schemes) | No | Yes (includes support for 8PSK modulation coding schemes)
FETCh:FBERror | Yes | No | Yes | Yes | Yes
FETCh:FFERate | No | No | No | Yes | Yes
FETCh:FSTability | Yes | Yes | Yes | Yes | Yes
FETCh:GBERror | No | Yes | Yes (includes support for 8PSK modulation coding schemes) | Yes | Yes (includes support for 8PSK modulation coding schemes)
FETCh:IFERror | No | No | No | Yes | Yes
FETCh:IQTuning | Yes | Yes | Yes | Yes | Yes
FETCh:MTAudio | Yes | No | No | Yes | Yes
FETCh:ORFSpectrum | Yes | Yes | Yes | Yes | Yes
FETCh:PCALibration | Yes | Yes | Yes | Yes | Yes
FETCh:PFERror | Yes | Yes | Yes | Yes | Yes
FETCh:PVTime | Yes | Yes | Yes | Yes | Yes
FETCh:SBERror | No | No | Yes | No | Yes
FETCh:SFERate | No | No | No | Yes | Yes
FETCh:SMONitor | Yes | Yes | Yes | Yes | Yes
FETCh:TXPower | Yes | Yes | Yes | Yes | Yes


FETCh:DPOWer

FETCh:DPOWer

GPIB Command Conventions

  • FETCh:DPOWer[:ALL][:RANGe1]? FETCh:DPOWer[:ALL]:RANGe2|3|4|5|6|7|8|9|10?
  • FETCh:DPOWer:ICOunt?
  • FETCh:DPOWer:NUMBer[:RANGe1]? FETCh:DPOWer:POWer:NUMBer:RANGe2|3|4|5|6|7|8|9|10?
  • FETCh:DPOWer:POWer[:RANGe1]? FETCh:DPOWer:POWer:RANGe2|3|4|5|6|7|8|9|10?
  • FETCh:DPOWer:RANGe:OFFSet?

FETCh:DPOWer[:ALL][:RANGe1]?
FETCh:DPOWer[:ALL]:RANGe2|3|4|5|6|7|8|9|10?

Function

GSM TA

Queries the Dynamic Power measurement results. Query returns N integrity indicators and N average TX power levels (where N is the number of bursts measured). To set the number of bursts you want to measure, use SETup:DPOWer:COUNt:NUMBer[:SELected] .

Each of the ranges can query up to 100 bursts. Therefore if you have set up to measure 250 bursts you must use range 1, range 2 and range 3 to obtain all your results.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Integrity indicators for each individual burst

  • Range: See Integrity Indicator .
  • Resolution: 1

Average TX power levels for each individual burst

  • Range: -100 to +100 dBm and 9.91 E+37 (NAN)
  • Resolution: 0.01 dBm
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"FETCh:DPOWer?"
! Queries the Dynamic Power measurement results for the first 100 bursts.

FETCh:DPOWer:ICOunt?

Function

GSM TA

Queries the intermediate count of measurements completed in a multi-measurement.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Range: 0 to 999
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"FETCH:DPOWER:ICOUNT?"

FETCh:DPOWer:INTegrity[:RANGe1]?
FETCh:DPOWer:INTegrity:RANGe2|3|4|5|6|7|8|9|10?

Function

GSM TA

Returns N integrity indicators (where N is the number of bursts measured). To set the number of bursts you want to measure, use SETup:DPOWer:COUNt:NUMBer[:SELected] .

Each of the ranges can query up to 100 bursts. Therefore if you have set up to measure 160 bursts you must use range 1 and range 2 to obtain all the integrity indicators.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Range: See Integrity Indicator .

Resolution: 1
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"FETCh:DPOWer:INTegrity:RANGe3?"
! Queries the integrity results for bursts 201 through 300.

FETCh:DPOWer:NUMBer[:RANGe1]?
FETCh:DPOWer:POWer:NUMBer:RANGe2|3|4|5|6|7|8|9|10?

Function

GSM TA

Queries the number of measurements made in the specified range.

Each of the ranges can query up to 100 bursts. Therefore if you have set up to measure 400 bursts you must use range 1, range 2, range 3 and range 4 to obtain all your TX power level results.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Range: 1 to 100 (per range)
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"FETCh:DPOWer:NUMBer:RANGe2?"
! Queries the number of measurements made in range 2.

FETCh:DPOWer:POWer[:RANGe1]?
FETCh:DPOWer:POWer:RANGe2|3|4|5|6|7|8|9|10?

Function

GSM TA

Queries the average TX power levels for the Dynamic Power measurement. Returns N average power levels (where N is the number of bursts measured. To set the number of bursts you want to measure, see SETup:DPOWer:COUNt:NUMBer[:SELected] .

Each of the ranges can query up to 100 bursts. Therefore if you have set up to measure 400 bursts you must use range 1, range 2, range 3 and range 4 to obtain all your TX power level results.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Range: -100 to +100 dB and 9.91 E+37 (NAN)

Resolution: 0.01 dB
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"FETCh:DPOWer:POWer:RANGe2?"
! Queries the average TX power for bursts 101 through 200.

FETCh:DPOWer:RANGe:OFFSet?

Function

GSM TA

Queries the average offset range for the Dynamic Power measurement.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Range: -4 dB to +4 dB

Resolution: 0.01 dB
Requirements GSM/GPRS/
EGPRS TA

Revision: A.05 and above
GSM/GPRS/ EGPRS LA

Revision: D.02 and above

Programming Example

OUTPUT 714;"FETCh:DPOWer:RANGe:OFFSet?"
! Queries offset value.


FETCh:EDPower

FETCh:EDPower

GPIB Command Conventions

  • FETCh:EDPower[:ALL]:<[RANGe1]|2|3|4|5|6|7|8|9|10>?
  • FETCh:EDPower:INTegrity:<[RANGe1]|2|3|4|5|6|7|8|9|10>?
  • FETCh:EDPower:NUMBer:<[RANGe1]|2|3|4|5|6|7|8|9|10>?
  • FETCh:EDPower:POWer:<[RANGe1]|2|3|4|5|6|7|8|9|10>?

FETCh:EDPower[:ALL]:<[RANGe1]|2|3|4|5|6|7|8|9|10>?

Function

GSM TA

Queries the EDGE Dynamic Power measurement results. Query returns N integrity indicators and N average TX power levels (where N is the number measurement results present in the specified range).

Each of the ranges can return measurement results, that is, integrity and power measurements, for up to 100 burst. Therefore if you have set up to measure 250 bursts you must query range 1, range 2 and range 3 to obtain all your results.

If a range contains no measurement results, a single integrity value of `1' and a single power value of NAN are returned.

GPRS TA
GSM/GPRS LA

EGPRS TA

EGPRS LA

Query

Integrity indicators for each individual burst

  • Range: See Integrity Indicator .
  • Resolution: 1

Average TX power levels for each individual burst

  • Range: -100 to +100 dBm and 9.91 E+37 (NAN)
  • Resolution: 0.01 dB
Requirements GSM/GPRS/
EGPRS TA

Revision: A.04 and above

Revision A.05 makes the EDP Measurement available in all TAs.
GSM/GPRS/ EGPRS LA

Revision: D.01 and above

Revision D.02 makes the EDP Measurement available in all LAs.

Programming Example

OUTPUT 714;"FETCh:EDPower?"
! Queries the Dynamic Power measurement results for the first 100 bursts.

FETCh:EDPower:INTegrity:<[RANGe1]|2|3|4|5|6|7|8|9|10>?

Function

GSM TA

Returns N integrity indicators (where N is the number of measurement results present in the specified range).

Each of the ranges can query up to 100 bursts. For example, if you want to obtain the measurements for 160 bursts you must query range 1 and range 2 to obtain all the integrity indicators. Range 1 will contain the maximum of 100 measurement results and Range 2 contains the remaining 60 measurement results.

If a range contains no measurement results, a single value of `1' is returned.

GPRS TA

GSM/GPRS LA

EGPRS TA

EGPRS LA

Query

Range: See Integrity Indicator .

Resolution: 1
Requirements GSM/GPRS/
EGPRS TA

Revision: A.04 and above

Revision A.05 makes the EDP Measurement available in all TAs.
GSM/GPRS/ EGPRS LA

Revision: D.01 and above

Revision D.02 makes the EDP Measurement available in all LAs.

Programming Example

OUTPUT 714;"FETCh:EDPower:INTegrity:RANGe3?"
! Queries the integrity results for bursts 201 through 300.

FETCh:EDPower:NUMBer:<[RANGe1]|2|3|4|5|6|7|8|9|10>?

Function

GSM TA

Queries the number of measurements results available specified range.

Each of the ranges contains results for up to 100 bursts. For example, if you want to measure 350 bursts, you must use range 1, range 2, range 3 and range 4 to obtain all your TX power level results. Ranges 1, 2, and 3 contains the maximum of 100 measurement results and Range 4 contains the remaining 50 measurements results.

GPRS TA

GSM/GPRS LA

EGPRS TA

EGPRS LA

Query

Range: 0 to 100 (per range)

Resolution: 1
Requirements GSM/GPRS/
EGPRS TA

Revision: A.04 and above

Revision A.05 makes the EDP Measurement available in all TAs.
GSM/GPRS/ EGPRS LA

Revision: D.01 and above

Revision D.02 makes the EDP Measurement available in all LAs.

Programming Example

OUTPUT 714;"FETCh:EDPower:NUMBer:RANGe2?"
! Queries the number of measurements made in range 2.

FETCh:EDPower:POWer:<[RANGe1]|2|3|4|5|6|7|8|9|10>?

Function

GSM TA

Queries the average TX power levels for the EDGE Dynamic Power measurement. Returns N average power levels (where N is the number of measurement results present in the specified range). To set the number of bursts you want to measure, see SETup:EDPower:COUNt:NUMBer .

Each of the ranges can query up to 100 bursts. Therefore if you have set up to measure 400 bursts you must use range 1, range 2, range 3 and range 4 to obtain all your TX power level results.

If a range contains no measurement results, a single NAN value is returned.

GPRS TA
GSM/GPRS LA

EGPRS TA

EGPRS LA

Query

Range: -100 to +100 dBm and 9.91 E+37 (NAN)

Resolution: 0.01 dB
Requirements GSM/GPRS/
EGPRS TA

Revision: A.04 and above

Revision A.05 makes the EDP Measurement available in all TAs.
GSM/GPRS/ EGPRS LA

Revision: D.01 and above

Revision D.02 makes the EDP Measurement available in all LAs.

Programming Example

OUTPUT 714;"FETCh:EDPower:POWer:RANGe2?"
! Queries the average TX power for bursts 101 through 200.


FETCh:EMACcuracy

FETCh:EMACcuracy

GPIB Command Conventions

  • FETCh:EMACcuracy[:ALL]?
  • FETCh:EMACcuracy[:ALL]:ETSI?
  • FETCh:EMACcuracy:DROop[:AVERage]?
  • FETCh:EMACcuracy:DROop: MAXimum?
  • FETCh:EMACcuracy:DROop:MINimum?
  • FETCh:EMACcuracy:DROop:SDEViation?
  • FETCh:EMACcuracy:EVM:PEAK[:AVERage]?
  • FETCh:EMACcuracy:EVM:PEAK:MAXimum?
  • FETCh:EMACcuracy:EVM:PEAK:MINimum?
  • FETCh:EMACcuracy:EVM:PEAK:SDEViation?
  • FETCh:EMACcuracy:EVM:PERCentile?
  • FETCh:EMACcuracy:EVM:RMS[:MAXimum]?
  • FETCh:EMACcuracy:EVM:RMS:AVERage?
  • FETCh:EMACcuracy:EVM:RMS:MINimum?
  • FETCh:EMACcuracy:EVM:RMS:SDEViation?
  • FETCh:EMACcuracy:EVM:TRACe:DATA?
  • FETCh:EMACcuracy:FERRor:AVERage?
  • FETCh:EMACcuracy:FERRor: MAXimum?
  • FETCh:EMACcuracy:FERRor:MINimum?
  • FETCh:EMACcuracy:FERRor:SDEViation?
  • FETCh:EMACcuracy:FERRor[:WORSt]?
  • FETCh:EMACcuracy:HISTogram:DATA?
  • FETCh:EMACcuracy:ICOunt?
  • FETCh:EMACcuracy:IQIMbalance:MAXimum?
  • FETCh:EMACcuracy:IQIMbalance:MINimum?
  • FETCh:EMACcuracy:IQIMbalance[:AVERage]?
  • FETCh:EMACcuracy:IQIMbalance:SDEViation?
  • FETCh:EMACcuracy:INTegrity?
  • FETCh:EMACcuracy:MERRor:PEAK:AVERage?
  • FETCh:EMACcuracy:MERRor:PEAK:MAXimum?
  • FETCh:EMACcuracy:MERRor:PEAK:MINimum?
  • FETCh:EMACcuracy:MERRor:PEAK:SDEViation?
  • FETCh:EMACcuracy:MERRor:PEAK[:WORSt]?
  • FETCh:EMACcuracy:MERRor:RMS[:AVERage]?
  • FETCh:EMACcuracy:MERRor:RMS:MAXimum?
  • FETCh:EMACcuracy:MERRor:RMS:MINimum?
  • FETCh:EMACcuracy:MERRor:RMS:SDEViation?
  • FETCh:EMACcuracy:MERRor:TRACe:DATA?
  • FETCh:EMACcuracy:OOFFset[:AVERage]?
  • FETCh:EMACcuracy:OOFFset: MAXimum?
  • FETCh:EMACcuracy:OOFFset:MINimum?
  • FETCh:EMACcuracy:OOFFset:SDEViation?
  • FETCh:EMACcuracy:PERRor:PEAK:AVERage?
  • FETCh:EMACcuracy:PERRor:PEAK:MAXimum?
  • FETCh:EMACcuracy:PERRor:PEAK:MINimum?
  • FETCh:EMACcuracy:PERRor:PEAK:SDEViation?
  • FETCh:EMACcuracy:PERRor:PEAK[:WORSt]?
  • FETCh:EMACcuracy:PERRor:RMS[:AVERage]?
  • FETCh:EMACcuracy:PERRor:RMS:MAXimum?
  • FETCh:EMACcuracy:PERRor:RMS:MINimum?
  • FETCh:EMACcuracy:PERRor:RMS:SDEViation?
  • FETCh:EMACcuracy:PERRor:TRACe:DATA?
  • FETCh:EMACcuracy:SYMBol:DATA?

FETCh:EMACcuracy[:ALL]?

Function

 GSM TA This command is not applicable to GSM.

GPRS TA

 This command is not applicable to GPRS.

GSM/GPRS LA

 This command is not applicable to the GSM/GPRS LA.

EGPRS TA

Queries integrity indicator, RMS error vector magnitude (EVM), peak EVM, 95th percentile EVM, frequency error, origin offset suppression, RMS phase error, RMS magnitude error, amplitude droop, IQ imbalance.

EGPRS LA

Query

Integrity indicator

  • Range: See Integrity Indicator .
  • Resolution: 1

RMS Error Vector Magnitude

  • Range: 0 % to 100 % and 9.91 E+37 (NAN)
  • Resolution: 0.01 %

Peak Error Vector Magnitude

  • Range: 0 % to 100 % and 9.91 E+37 (NAN)
  • Resolution: 0.01 %

95th Percentile Error Vector Magnitude

  • Range: 0 % to 100 % and 9.91 E+37 (NAN)
  • Resolution: 0.01 %

Frequency Error

  • Range: -9999 Hz to +9999 Hz and 9.91 E+37 (NAN)
  • Resolution: 0.01 Hz

Origin Offset Suppression

  • Range: -70 dB to 0 dB and 9.91 E+37 (NAN)
  • Resolution: 0.01 dB

RMS Phase Error

  • Range: 0 to 180 degrees and 9.91 E+37 (NAN)
  • Resolution: 0.01 degrees

Peak Phase Error

  • Range: 0 to 180 degrees and 9.91 E+37 (NAN)
  • Resolution: 0.01 degrees

RMS Magnitude Error

  • Range: 0 to 100 % and 9.91 E+37 (NAN)
  • Resolution: 0.01 %

Peak Magnitude Error

  • Range: 0 to 100 % and 9.91 E+37 (NAN)
  • Resolution: 0.01 %

Amplitude Droop

  • Range: -20 dB to +20 dB and 9.91 E+37 (NAN)
  • Resolution: 0.01 dB

IQ Imbalance

  • Range: -100 dB to 0 dB and 9.91 E+37 (NAN)
  • Resolution: 0.01 dB
Requirements GSM/GPRS/
EGPRS TA

Revision: A.03 and above
GSM/GPRS/ EGPRS LA

Revision: C.03 and above

Programming Example

OUTPUT 714;"FETCh:EMACcuracy:ALL?"
! Returns all of the 8PSK Modulation Accuracy results.

FETCh:EMACcuracy[:ALL]:ETSI?

Function

 GSM TA This command is not applicable to GSM.

GPRS TA

 This command is not applicable to GPRS.

GSM/GPRS LA

 This command is not applicable to the GSM/GPRS LA.

EGPRS TA

Queries the ETSI specified 8PSK multislot modulation accuracy results; integrity indicator, RMS error vector magnitude, peak error vector magnitude, 95th percentile, frequency error, and origin offset suppression.

EGPRS LA

Query

Integrity indicator

  • Range: See Integrity Indicator .
  • Resolution: 1

RMS Error Vector Magnitude

  • Range: 0 % to 100 % and 9.91 E+37 (NAN)
  • Resolution: 0.01 %

Peak Error Vector Magnitude

  • Range: 0 % to 100 % and 9.91 E+37 (NAN)
  • Resolution: 0.01 %

95th Percentile Error Vector Magnitude

  • Range: 0 % to 100 % and 9.91 E+37 (NAN)
  • Resolution: 0.01 %

Frequency Error

  • Range: -9999 Hz to +9999 Hz and 9.91 E+37 (NAN)
  • Resolution: 0.01 Hz

Origin Offset Suppression

  • Range: -70 dB to 0 dB and 9.91 E+37 (NAN)
  • Resolution: 0.01 dB
Requirements GSM/GPRS/
EGPRS TA

Revision: A.03 and above
GSM/GPRS/ EGPRS LA

Revision: C.03 and above

Programming Example

OUTPUT 714;"FETCH:PFERROR:ALL:ETSI?"
! Returns the ETSI-specified 8PSK modulation accuracy results.

FETCh:EMACcuracy:DROop[:AVERage]?

Function | GSM TA | This command is not applicable to GSM.
 | GPRS TA | This command is not applicable to GPRS.
 | GSM/GPRS LA | This command is not applicable to the GSM/GPRS LA.
 | EGPRS TA | Queries the average amplitude droop result from a multi-measurement.
 | EGPRS LA
Query |  | Range: Range: -20 dB to +20 dB and 9.91 E+37 (NAN) Resolution: 0.01 dB
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.03 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.03 and above

FETCh:EMACcuracy:DROop: MAXimum?

Function | GSM TA | This command is not applicable to GSM.
 | GPRS TA | This command is not applicable to GPRS.
 | GSM/GPRS LA | This command is not applicable to the GSM/GPRS LA.
 | EGPRS TA | Queries the maximum amplitude droop results from a multi-measurement.
 | EGPRS LA
Query |  | Range: -20 dB to +20 dB and 9.91 E+37 (NAN) Resolution: 0.01 dB
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.03 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.03 and above

FETCh:EMACcuracy:DROop:MINimum?

Function | GSM TA | This command is not applicable to GSM.
 | GPRS TA | This command is not applicable to GPRS.
 | GSM/GPRS LA | This command is not applicable to the GSM/GPRS LA.
 | EGPRS TA | Queries the minimum amplitude droop results from a multi-measurement.
 | EGPRS LA
Query |  | Range: -20 dB to +20 dB and 9.91 E+37 (NAN) Resolution: 0.01 dB
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.03 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.03 and above

FETCh:EMACcuracy:DROop:SDEViation?

Function | GSM TA | This command is not applicable to GSM.
 | GPRS TA | This command is not applicable to GPRS.
 | GSM/GPRS LA | This command is not applicable to the GSM/GPRS LA.
 | EGPRS TA | Queries the standard deviation result from an amplitude droop multi-measurement.
 | EGPRS LA
Query |  | Range: -20 dB to +20 dB and 9.91 E+37 (NAN) Resolution: 0.01 dB
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.03 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.03 and above

FETCh:EMACcuracy:EVM:PEAK[:AVERage]?

Function | GSM TA | This command is not applicable to GSM.
 | GPRS TA | This command is not applicable to GPRS.
 | GSM/GPRS LA | This command is not applicable to the GSM/GPRS LA.
 | EGPRS TA | Queries the average peak error vector magnitude result from a multi-measurement.
 | EGPRS LA
Query |  | Range: 0 % to 100 % and 9.91 E+37 (NAN) Resolution: 0.01 %
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.03 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.03 and above

FETCh:EMACcuracy:EVM:PEAK:MAXimum?

Function | GSM TA | This command is not applicable to GSM.
 | GPRS TA | This command is not applicable to GPRS.
 | GSM/GPRS LA | This command is not applicable to the GSM/GPRS LA.
 | EGPRS TA | Queries the maximum peak error vector magnitude result from a multi-measurement.
 | EGPRS LA
Query |  | Range: 0 % to 100 % and 9.91 E+37 (NAN) Resolution: 0.01 %
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.03 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.03 and above

FETCh:EMACcuracy:EVM:PEAK:MINimum?

Function | GSM TA | This command is not applicable to GSM.
 | GPRS TA | This command is not applicable to GPRS.
 | GSM/GPRS LA | This command is not applicable to the GSM/GPRS LA.
 | EGPRS TA | Queries the minimum peak error vector magnitude result from a multi-measurement.
 | EGPRS LA
Query |  | Range: 0 % to 100 % and 9.91 E+37 (NAN) Resolution: 0.01 %
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.03 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.03 and above

FETCh:EMACcuracy:EVM:PEAK:SDEViation?

Function | GSM TA | This command is not applicable to GSM.
 | GPRS TA | This command is not applicable to GPRS.
 | GSM/GPRS LA | This command is not applicable to the GSM/GPRS LA.
 | EGPRS TA | Queries the standard deviation result from a peak error vector magnitude measurement.
 | EGPRS LA
Query |  | Range: 0 % to 100 % and 9.91 E+37 (NAN) Resolution: 0.01 %
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.03 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.03 and above

FETCh:EMACcuracy:EVM:PERCentile?

Function | GSM TA | This command is not applicable to GSM.
 | GPRS TA | This command is not applicable to GPRS.
 | GSM/GPRS LA | This command is not applicable to the GSM/GPRS LA.
 | EGPRS TA | Queries the 95th percentile error vector magnitude result.
 | EGPRS LA
Query |  | Range: 0 % to 100 % and 9.91 E+37 (NAN) Resolution: 0.01 %
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.03 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.03 and above

FETCh:EMACcuracy:EVM:RMS[:MAXimum]?

Function | GSM TA | This command is not applicable to GSM.
 | GPRS TA | This command is not applicable to GPRS.
 | GSM/GPRS LA | This command is not applicable to the GSM/GPRS LA.
 | EGPRS TA | Queries the maximum RMS error vector magnitude result from a multi-measurement.
 | EGPRS LA
Query |  | Range: 0 % to 100 % and 9.91 E+37 (NAN) Resolution: 0.01 %
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.03 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.03 and above

FETCh:EMACcuracy:EVM:RMS:AVERage?

Function | GSM TA | This command is not applicable to GSM.
 | GPRS TA | This command is not applicable to GPRS.
 | GSM/GPRS LA | This command is not applicable to the GSM/GPRS LA.
 | EGPRS TA | Queries the average RMS error vector magnitude result from a multi-measurement.
 | EGPRS LA
Query |  | Range: 0 % to 100 % and 9.91 E+37 (NAN) Resolution: 0.01 %
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.03 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.03 and above

FETCh:EMACcuracy:EVM:RMS:MINimum?

Function | GSM TA | This command is not applicable to GSM.
 | GPRS TA | This command is not applicable to GPRS.
 | GSM/GPRS LA | This command is not applicable to the GSM/GPRS LA.
 | EGPRS TA | Queries the minimum RMS error vector magnitude result from a multi-measurement.
 | EGPRS LA
Query |  | Range: 0 % to 100 % and 9.91 E+37 (NAN) Resolution: 0.01 %
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.03 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.03 and above

FETCh:EMACcuracy:EVM:RMS:SDEViation?

Function | GSM TA | This command is not applicable to GSM.
 | GPRS TA | This command is not applicable to GPRS.
 | GSM/GPRS LA | This command is not applicable to the GSM/GPRS LA.
 | EGPRS TA | Queries the standard deviation result from an RMS error vector magnitude multi-measurement.
 | EGPRS LA
Query |  | Range: 0 % to 100 % and 9.91 E+37 (NAN) Resolution: 0.01 %
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.03 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.03 and above

FETCh:EMACcuracy:EVM:TRACe:DATA?

Function | GSM TA | This command is not applicable to GSM.
 | GPRS TA | This command is not applicable to GPRS.
 | GSM/GPRS LA | This command is not applicable to the GSM/GPRS LA.
 | EGPRS TA | Queries the EGPRS Modulation Accuracy EVM measurement and returns 142 points representing the EVM results (in %) of the trace data. If the graph state is OFF, this query returns NAN. See SETup:EMACcuracy:GRAPh:STATe . When multi-measurements are turned on, this is the trace data for the last burst measured
 | EGPRS LA
Query |  | Range: 0 % to 100 % and 9.91 E+37 (NAN) Resolution: 0.01 %
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.03 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.03 and above

FETCh:EMACcuracy:FERRor:AVERage?

Function | GSM TA | This command is not applicable to GSM.
 | GPRS TA | This command is not applicable to GPRS.
 | GSM/GPRS LA | This command is not applicable to the GSM/GPRS LA.
 | EGPRS TA | Queries the average frequency error result from a multi-measurement.
 | EGPRS LA
Query |  | Range: -9999 Hz to +9999 Hz and 9.91 E+37 (NAN) Resolution: 0.01 Hz
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.03 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.03 and above

FETCh:EMACcuracy:FERRor: MAXimum?

Function | GSM TA | This command is not applicable to GSM.
 | GPRS TA | This command is not applicable to GPRS.
 | GSM/GPRS LA | This command is not applicable to the GSM/GPRS LA.
 | EGPRS TA | Queries the maximum frequency error result from a multi-measurement.
 | EGPRS LA
Query |  | Range: -9999 Hz to +9999 Hz and 9.91 E+37 (NAN) Resolution: 0.01 Hz
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.03 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.03 and above

FETCh:EMACcuracy:FERRor:MINimum?

Function | GSM TA | This command is not applicable to GSM.
 | GPRS TA | This command is not applicable to GPRS.
 | GSM/GPRS LA | This command is not applicable to the GSM/GPRS LA.
 | EGPRS TA | Queries the minimum frequency error result from a multi-measurement.
 | EGPRS LA
Query |  | Range: -9999 Hz to +9999 Hz and 9.91 E+37 (NAN) Resolution: 0.01 Hz
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.03 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.03 and above

FETCh:EMACcuracy:FERRor:SDEViation?

Function | GSM TA | This command is not applicable to GSM.
 | GPRS TA | This command is not applicable to GPRS.
 | GSM/GPRS LA | This command is not applicable to the GSM/GPRS LA.
 | EGPRS TA | Queries the standard deviation result from a frequency error multi-measurement.
 | EGPRS LA
Query |  | Range: -500 kHz to +500 kHz and 9.91 E+37 (NAN) Resolution: 0.01 Hz
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.03 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.03 and above

FETCh:EMACcuracy:FERRor[:WORSt]?

Function | GSM TA | This command is not applicable to GSM.
 | GPRS TA | This command is not applicable to GPRS.
 | GSM/GPRS LA | This command is not applicable to the GSM/GPRS LA.
 | EGPRS TA | Queries the worst case frequency error result from a multi-measurement. This is a signed quantity which returns the frequency error out of all the individual sub-measurements taken, which is furthest from 0 Hz. In the case where the most Positive and most negative frequency errors are the same, the positive one will be returned.
 | EGPRS LA
Query |  | Range: -500 kHz to +500 kHz and 9.91 E+37 (NAN) Resolution: 0.01 Hz
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.03 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.03 and above

FETCh:EMACcuracy:HISTogram:DATA?

Function

 GSM TA This command is not applicable to GSM.

GPRS TA

 This command is not applicable to GPRS.

GSM/GPRS LA

 This command is not applicable to the GSM/GPRS LA.

EGPRS TA

Queries the EGPRS Modulation Accuracy Sample EVM Histogram measurement and returns 201 points representing a histogram of the EVM results for the measured burst or bursts. The last point returned is the number of samples whose EVM value exceeded the maximum value allowed by the histogram at its current resolution setting. (See SETup:EMACcuracy:HISTogram:MAXimum:EVM for more information.)

If the graph state is OFF, this query returns NAN. See SETup:EMACcuracy:GRAPh:STATe .

EGPRS LA

Query

Range:

  • 0 to 142 when the multi-measurement count is OFF or 0
  • 0 to 141858 when multi-measurements are used
  • -1 when there is no valid data to return

Resolution: 1
Requirements GSM/GPRS/
EGPRS TA

Revision: A.03 and above
GSM/GPRS/ EGPRS LA

Revision: C.03 and above

FETCh:EMACcuracy:ICOunt?

Function | GSM TA | This command is not applicable to GSM.
 | GPRS TA | This command is not applicable to GPRS.
 | GSM/GPRS LA | This command is not applicable to the GSM/GPRS LA.
 | EGPRS TA | Queries the intermediate count of 8PSK modulation accuracy multi-measurements completed. This number will increase to the value returned by SETup:EMACcuracy:COUNt:NUMBer .
 | EGPRS LA
Query |  | Range: 0 to 999 Resolution: 1
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.03 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.03 and above

FETCh:EMACcuracy:IQIMbalance:MAXimum?

Function | GSM TA | This command is not applicable to GSM.
 | GPRS TA | This command is not applicable to GPRS.
 | GSM/GPRS LA | This command is not applicable to the GSM/GPRS LA.
 | EGPRS TA | Queries the maximum IQ amplitude imbalance result from a multi-measurement. The IQ Imbalance State must be turned on for this query to return a result other than NAN. See SETup:EMACcuracy:IQIMbalance[:CALCulate]:STATe .
 | EGPRS LA
Query |  | Range: -100 dB to 0 dB and 9.91 E+37 (NAN) Resolution: 0.01 dB
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.03 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.03 and above

FETCh:EMACcuracy:IQIMbalance:MINimum?

Function | GSM TA | This command is not applicable to GSM.
 | GPRS TA | This command is not applicable to GPRS.
 | GSM/GPRS LA | This command is not applicable to the GSM/GPRS LA.
 | EGPRS TA | Queries the minimum IQ amplitude imbalance result from a multi-measurement. The IQ Imbalance State must be turned on for this query to return a result other than NAN. See SETup:EMACcuracy:IQIMbalance[:CALCulate]:STATe .
 | EGPRS LA
Query |  | Range: -100 dB to 0 dB and 9.91 E+37 (NAN) Resolution: 0.01 dB
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.03 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.03 and above

FETCh:EMACcuracy:IQIMbalance[:AVERage]?

Function | GSM TA | This command is not applicable to GSM.
 | GPRS TA | This command is not applicable to GPRS.
 | GSM/GPRS LA | This command is not applicable to the GSM/GPRS LA.
 | EGPRS TA | Queries the average IQ imbalance result from a multi-measurement. The IQ Imbalance State must be turned on for this query to return a result other than NAN. See SETup:EMACcuracy:IQIMbalance[:CALCulate]:STATe .
 | EGPRS LA
Query |  | Range: -100 dB to 0 dB and 9.91 E+37 (NAN) Resolution: 0.01 dB
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.03 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.03 and above

FETCh:EMACcuracy:IQIMbalance:SDEViation?

Function | GSM TA | This command is not applicable to GSM.
 | GPRS TA | This command is not applicable to GPRS.
 | GSM/GPRS LA | This command is not applicable to the GSM/GPRS LA.
 | EGPRS TA | Queries the standard deviation result from an IQ amplitude imbalance multi-measurement.The IQ Imbalance State must be turned on for this query to return a result other than NAN. See SETup:EMACcuracy:IQIMbalance[:CALCulate]:STATe .
 | EGPRS LA
Query |  | Range: -20 dB to +20 dB and 9.91 E+37 (NAN) Resolution: 0.01 dB
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.03 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.03 and above

FETCh:EMACcuracy:INTegrity?

Function | GSM TA | This command is not applicable to GSM.
 | GPRS TA | This command is not applicable to GPRS.
 | GSM/GPRS LA | This command is not applicable to the GSM/GPRS LA.
 | EGPRS TA | Queries the integrity indicator for the 8PSK multislot modulation accuracy measurement. Zero indicates a normal result. See Integrity Indicator for descriptions of non-zero integrity indicators.
 | EGPRS LA
Query |  | Range: See Integrity Indicator . Resolution: 1
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.03 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.03 and above

FETCh:EMACcuracy:MERRor:PEAK:AVERage?

Function | GSM TA | This command is not applicable to GSM.
 | GPRS TA | This command is not applicable to GPRS.
 | GSM/GPRS LA | This command is not applicable to the GSM/GPRS LA.
 | EGPRS TA | Queries the average peak magnitude error result from a multi-measurement.
 | EGPRS LA
Query |  | Range: -100% to 100 % and 9.91 E+37 (NAN) Resolution: 0.01 %
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.03 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.03 and above

FETCh:EMACcuracy:MERRor:PEAK:MAXimum?

Function | GSM TA | This command is not applicable to GSM.
 | GPRS TA | This command is not applicable to GPRS.
 | GSM/GPRS LA | This command is not applicable to the GSM/GPRS LA.
 | EGPRS TA | Queries the maximum peak magnitude error result from a multi-measurement.
 | EGPRS LA
Query |  | Range: -100 % to 100 % and 9.91 E+37 (NAN) Resolution: 0.01 %
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.03 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.03 and above

FETCh:EMACcuracy:MERRor:PEAK:MINimum?

Function | GSM TA | This command is not applicable to GSM.
 | GPRS TA | This command is not applicable to GPRS.
 | GSM/GPRS LA | This command is not applicable to the GSM/GPRS LA.
 | EGPRS TA | Queries the minimum peak magnitude error result from a multi-measurement.
 | EGPRS LA
Query |  | Range: -100 % to 100 % and 9.91 E+37 (NAN) Resolution: 0.01 %
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.03 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.03 and above

FETCh:EMACcuracy:MERRor:PEAK:SDEViation?

Function | GSM TA | This command is not applicable to GSM.
 | GPRS TA | This command is not applicable to GPRS.
 | GSM/GPRS LA | This command is not applicable to the GSM/GPRS LA.
 | EGPRS TA | Queries the standard deviation result from a peak magnitude error multi-measurement.
 | EGPRS LA
Query |  | Range: -100 % to 100 % and 9.91 E+37 (NAN) Resolution: 0.01 %
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.03 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.03 and above

FETCh:EMACcuracy:MERRor:PEAK[:WORSt]?

Function | GSM TA | This command is not applicable to GSM.
 | GPRS TA | This command is not applicable to GPRS.
 | GSM/GPRS LA | This command is not applicable to the GSM/GPRS LA.
 | EGPRS TA | Queries the peak magnitude error result from a peak magnitude error multi-measurement.
 | EGPRS LA
Query |  | Range: -100 % to 100 % and 9.91 E+37 (NAN) Resolution: 0.01 %
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.03 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.03 and above

FETCh:EMACcuracy:MERRor:RMS[:AVERage]?

Function | GSM TA | This command is not applicable to GSM.
 | GPRS TA | This command is not applicable to GPRS.
 | GSM/GPRS LA | This command is not applicable to the GSM/GPRS LA.
 | EGPRS TA | Queries the average RMS magnitude error result from a multi-measurement.
 | EGPRS LA
Query |  | Range: 0 % to 100 % and 9.91 E+37 (NAN) Resolution: 0.01 %
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.03 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.03 and above

FETCh:EMACcuracy:MERRor:RMS:MAXimum?

Function | GSM TA | This command is not applicable to GSM.
 | GPRS TA | This command is not applicable to GPRS.
 | GSM/GPRS LA | This command is not applicable to the GSM/GPRS LA.
 | EGPRS TA | Queries the maximum RMS magnitude error result from a multi-measurement.
 | EGPRS LA
Query |  | Range: 0 % to 100 % and 9.91 E+37 (NAN) Resolution: 0.01 %
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.03 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.03 and above

FETCh:EMACcuracy:MERRor:RMS:MINimum?

Function | GSM TA | This command is not applicable to GSM.
 | GPRS TA | This command is not applicable to GPRS.
 | GSM/GPRS LA | This command is not applicable to the GSM/GPRS LA.
 | EGPRS TA | Queries the minimum RMS magnitude error result from a multi-measurement.
 | EGPRS LA
Query |  | Range: 0 % to 100 % and 9.91 E+37 (NAN) Resolution: 0.01 %
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.03 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.03 and above

FETCh:EMACcuracy:MERRor:RMS:SDEViation?

Function | GSM TA | This command is not applicable to GSM.
 | GPRS TA | This command is not applicable to GPRS.
 | GSM/GPRS LA | This command is not applicable to the GSM/GPRS LA.
 | EGPRS TA | Queries the standard deviation result from an RMS magnitude error measurement.
 | EGPRS LA
Query |  | Range: 0 % to 100 % and 9.91 E+37 (NAN) Resolution: 0.01 %
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.03 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.03 and above

FETCh:EMACcuracy:MERRor:TRACe:DATA?

Function | GSM TA | This command is not applicable to GSM.
 | GPRS TA | This command is not applicable to GPRS.
 | GSM/GPRS LA | This command is not applicable to the GSM/GPRS LA.
 | EGPRS TA | Queries the EGPRS Modulation Accuracy Magnitude Error measurement and returns 142 points representing the magnitude error (in percent) for the measured burst. When multi-measurements are turned on, this is the trace data for the last burst measured.
 | EGPRS LA
Query |  | Range: -100 % to 100 % and 9.91 E+37 (NAN) Resolution: 0.01 %
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.03 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.03 and above

FETCh:EMACcuracy:OOFFset[:AVERage]?

Function | GSM TA | This command is not applicable to GSM.
 | GPRS TA | This command is not applicable to GPRS.
 | GSM/GPRS LA | This command is not applicable to the GSM/GPRS LA.
 | EGPRS TA | Queries the average origin offset result from a multi-measurement.
 | EGPRS LA
Query |  | Range: 0 dB to +70 dB and 9.91 E+37 (NAN) Resolution: 0.01 dB
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.03 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.03 and above

FETCh:EMACcuracy:OOFFset: MAXimum?

Function | GSM TA | This command is not applicable to GSM.
 | GPRS TA | This command is not applicable to GPRS.
 | GSM/GPRS LA | This command is not applicable to the GSM/GPRS LA.
 | EGPRS TA | Queries the maximum origin offset result from a multi-measurement.
 | EGPRS LA
Query |  | Range: 0 dB to +70 dB and 9.91 E+37 (NAN) Resolution: 0.01 dB
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.03 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.03 and above

FETCh:EMACcuracy:OOFFset:MINimum?

Function | GSM TA | This command is not applicable to GSM.
 | GPRS TA | This command is not applicable to GPRS.
 | GSM/GPRS LA | This command is not applicable to the GSM/GPRS LA.
 | EGPRS TA | Queries the minimum origin offset result from a multi-measurement.
 | EGPRS LA
Query |  | Range: 0 dB to +70 dB and 9.91 E+37 (NAN) Resolution: 0.01 dB
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.03 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.03 and above

FETCh:EMACcuracy:OOFFset:SDEViation?

Function | GSM TA | This command is not applicable to GSM.
 | GPRS TA | This command is not applicable to GPRS.
 | GSM/GPRS LA | This command is not applicable to the GSM/GPRS LA.
 | EGPRS TA | Queries the standard deviation result from an origin offset multi-measurement.
 | EGPRS LA
Query |  | Range: 0 dB to +70 dB and 9.91 E+37 (NAN) Resolution: 0.01 dB
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.03 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.03 and above

FETCh:EMACcuracy:PERRor:PEAK:AVERage?

Function | GSM TA | This command is not applicable to GSM.
 | GPRS TA | This command is not applicable to GPRS.
 | GSM/GPRS LA | This command is not applicable to the GSM/GPRS LA.
 | EGPRS TA | Queries the average peak phase error result from a multi-measurement.
 | EGPRS LA
Query |  | Range: -180 to 180 degrees and 9.91 E+37 (NAN) Resolution: 0.01 degrees
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.03 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.03 and above

FETCh:EMACcuracy:PERRor:PEAK:MAXimum?

Function | GSM TA | This command is not applicable to GSM.
 | GPRS TA | This command is not applicable to GPRS.
 | GSM/GPRS LA | This command is not applicable to the GSM/GPRS LA.
 | EGPRS TA | Queries the maximum peak phase error result from a multi-measurement.
 | EGPRS LA
Query |  | Range: -180 to 180 degrees and 9.91 E+37 (NAN) Resolution: 0.01 degrees
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.03 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.03 and above

FETCh:EMACcuracy:PERRor:PEAK:MINimum?

Function | GSM TA | This command is not applicable to GSM.
 | GPRS TA | This command is not applicable to GPRS.
 | GSM/GPRS LA | This command is not applicable to the GSM/GPRS LA.
 | EGPRS TA | Queries the minimum peak phase error result from a multi-measurement.
 | EGPRS LA
Query |  | Range: -180 to 180 degrees and 9.91 E+37 (NAN) Resolution: 0.01 degrees
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.03 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.03 and above

FETCh:EMACcuracy:PERRor:PEAK:SDEViation?

Function | GSM TA | This command is not applicable to GSM.
 | GPRS TA | This command is not applicable to GPRS.
 | GSM/GPRS LA | This command is not applicable to the GSM/GPRS LA.
 | EGPRS TA | Queries the standard deviation result from an peak phase error multi-measurement.
 | EGPRS LA
Query |  | Range: -180 to 180 degrees and 9.91 E+37 (NAN) Resolution: 0.01 degrees
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.03 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.03 and above

FETCh:EMACcuracy:PERRor:PEAK[:WORSt]?

Function | GSM TA | This command is not applicable to GSM.
 | GPRS TA | This command is not applicable to GPRS.
 | GSM/GPRS LA | This command is not applicable to the GSM/GPRS LA.
 | EGPRS TA | Queries the peak phase error result from a peak phase error multi-measurement.
 | EGPRS LA
Query |  | Range: -180 to 180 degrees and 9.91 E+37 (NAN) Resolution: 0.01 degrees
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.03 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.03 and above

FETCh:EMACcuracy:PERRor:RMS[:AVERage]?

Function | GSM TA | This command is not applicable to GSM.
 | GPRS TA | This command is not applicable to GPRS.
 | GSM/GPRS LA | This command is not applicable to the GSM/GPRS LA.
 | EGPRS TA | Queries the average RMS phase error result from a multi-measurement.
 | EGPRS LA
Query |  | Range: 0 to 180 degrees and 9.91 E+37 (NAN) Resolution: 0.01 degrees
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.03 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.03 and above

FETCh:EMACcuracy:PERRor:RMS:MAXimum?

Function | GSM TA | This command is not applicable to GSM.
 | GPRS TA | This command is not applicable to GPRS.
 | GSM/GPRS LA | This command is not applicable to the GSM/GPRS LA.
 | EGPRS TA | Queries the maximum RMS phase error result from a multi-measurement.
 | EGPRS LA
Query |  | Range: 0 to 180 degrees and 9.91 E+37 (NAN) Resolution: 0.01 degrees
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.03 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.03 and above

FETCh:EMACcuracy:PERRor:RMS:MINimum?

Function | GSM TA | This command is not applicable to GSM.
 | GPRS TA | This command is not applicable to GPRS.
 | GSM/GPRS LA | This command is not applicable to the GSM/GPRS LA.
 | EGPRS TA | Queries the minimum RMS phase error result from a multi-measurement.
 | EGPRS LA
Query |  | Range: 0 to 180 degrees and 9.91 E+37 (NAN) Resolution: 0.01 degrees
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.03 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.03 and above

FETCh:EMACcuracy:PERRor:RMS:SDEViation?

Function | GSM TA | This command is not applicable to GSM.
 | GPRS TA | This command is not applicable to GPRS.
 | GSM/GPRS LA | This command is not applicable to the GSM/GPRS LA.
 | EGPRS TA | Queries the standard deviation result from an RMS phase error multi-measurement.
 | EGPRS LA
Query |  | Range: 0 to 180 degrees and 9.91 E+37 (NAN) Resolution: 0.01 degrees
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.03 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.03 and above

FETCh:EMACcuracy:PERRor:TRACe:DATA?

Function | GSM TA | This command is not applicable to GSM.
 | GPRS TA | This command is not applicable to GPRS.
 | GSM/GPRS LA | This command is not applicable to the GSM/GPRS LA.
 | EGPRS TA | Queries the EGPRS Modulation Accuracy Phase Error measurement and returns 142 points representing the phase error (in percent) for the measured burst. When multi-measurements are turned on, this is the trace data for the last burst measured
 | EGPRS LA
Query |  | Range: -180 to +180 degrees and 9.91 E+37 (NAN) Resolution: 0.01 degrees
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.03 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.03 and above

FETCh:EMACcuracy:SYMBol:DATA?

Function | GSM TA | This command is not applicable to GSM.
 | GPRS TA | This command is not applicable to GPRS.
 | GSM/GPRS LA | This command is not applicable to the GSM/GPRS LA.
 | EGPRS TA | Queries the EGPRS Modulation Accuracy EVM measurement and returns 148 points representing the demodulated symbols for the burst measured. The first three and last three results in the array correspond to the burst's tail bits.
 | EGPRS LA
Query |  | Range: 0 | 1 | 2 | 3 | 4 | 5 | 6 | 7 | -1 where -1 indicates a symbol that could not be demodulated.
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.03 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.03 and above


FETCh:ETXPower

FETCh:ETXPower

GPIB Command Conventions

  • FETCh:ETXPower[:ALL]?
  • FETCh:ETXPower:ICOunt?
  • FETCh:ETXPower:INTegrity?
  • FETCh:ETXPower:POWer:ALL?
  • FETCh:ETXPower:POWer:BURSt[:AVERage]?
  • FETCh:ETXPower:POWer:BURSt:MAXimum?
  • FETCh:ETXPower:POWer:BURSt:MINimum?
  • FETCh:ETXPower:POWer:BURSt:SDEViation?
  • FETCh:ETXPower:POWer:CARRier[:AVERage]?
  • FETCh:ETXPower:POWer:CARRier:MAXimum?
  • FETCh:ETXPower:POWer:CARRier:MINimum?
  • FETCh:ETXPower:POWer:CARRier:SDEViation?

FETCh:ETXPower[:ALL]?

Function

GSM TA

 This command is not applicable to GSM.

GPRS TA

 This command is not applicable to GPRS.
GSM/GPRS LA This command is not applicable to the GSM/GPRS LA.

EGPRS LA

Queries integrity indicator and average EGPRS transmit power measurement.

A value of zero for the integrity indicator is normal. See Integrity Indicator for non-zero integrity indicators.

EGPRS TA

Query

Integrity indicator

  • Range: See Integrity Indicator .
  • Resolution: 1

Burst power (average)

  • Range: -100 to +100 dBm and 9.91E+37 (NAN)
  • Resolution: 0.01 dB

Estimated carrier power (average)

  • Range: -100 to +100 dBm and 9.91E+37 (NAN)
  • Resolution: 0.01 dB
Requirements GSM/GPRS/ EGPRS TA

Revision: A.03 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

FETCh:ETXPower:ICOunt?

Function | GSM TA | This command is not applicable to GSM.
 | GPRS TA | This command is not applicable to GPRS.
 | GSM/GPRS LA | This command is not applicable to the GSM/GPRS LA.
 | EGPRS LA | Queries the intermediate count of EGPRS transmit power measurements completed.
 | EGPRS TA
Query |  | Range: 1 to 999 Resolution: 1
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.03 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.01 and above

FETCh:ETXPower:INTegrity?

Function | GSM TA | This command is not applicable to GSM.
 | GPRS TA | This command is not applicable to GPRS.
 | GSM/GPRS LA | This command is not applicable to the GSM/GPRS LA.
 | EGPRS LA | Queries the integrity indicator. Zero indicates normal. For non-zero integrity indicators, refer to Integrity Indicator .
 | EGPRS TA
Query |  | Range: See Integrity Indicator . Resolution: 1
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.03 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.01 and above

FETCh:ETXPower:POWer:ALL?

Function

 GSM TA

GSM TA

GPRS TA

GPRS TA

GSM/GPRS LA

 GSM/GPRS LA

EGPRS LA

Queries average, minimum, maximum and standard deviation of burst power multi-measurement results.

EGPRS TA

Query

Average:

  • Range: -100 dBm to 100 dBm and 9.91 E+37 (NAN)
  • Resolution: 0.01 dB

Minimum:

  • Range: -100 dBm to 100 dBm and 9.91 E+37 (NAN)
  • Resolution: 0.01 dB

Maximum:

  • Range: -100 dBm to 100 dBm and 9.91 E+37 (NAN)
  • Resolution: 0.01 dB

Standard deviation:

  • Range: 0 dB to 100 dB and 9.91 E+37 (NAN)
  • Resolution: 0.001 dB
Requirements GSM/GPRS/ EGPRS TA

Revision: A.03 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

FETCh:ETXPower:POWer:BURSt[:AVERage]?

Function | GSM TA | This command is not applicable to GSM.
 | GPRS TA | This command is not applicable to GPRS.
 | GSM/GPRS LA | This command is not applicable to the GSM/GPRS LA.
 | EGPRS LA | Queries average burst power.
 | EGPRS TA
Query |  | Range: -100 dBm to 100 dBm and 9.91 E+37 (NAN) Resolution: 0.01 dB
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.03 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.01 and above

FETCh:ETXPower:POWer:BURSt:MAXimum?

Function | GSM TA | This command is not applicable to GSM.
 | GPRS TA | This command is not applicable to GPRS.
 | GSM/GPRS LA | This command is not applicable to the GSM/GPRS LA.
 | EGPRS LA | Queries maximum burst power results from a multi-measurement.
 | EGPRS TA
Query |  | Range: -100 dBm to 100 dBm and 9.91 E+37 (NAN) Resolution: 0.01 dB
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.03 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.01 and above

FETCh:ETXPower:POWer:BURSt:MINimum?

Function | GSM TA | This command is not applicable to GSM.
 | GPRS TA | This command is not applicable to GPRS.
 | GSM/GPRS LA | This command is not applicable to the GSM/GPRS LA.
 | EGPRS LA | Queries minimum burst power results from a multi-measurement.
 | EGPRS TA
Query |  | Range: -100 dBm to 100 dBm and 9.91 E+37 (NAN) Resolution: 0.01 dB
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.03 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.01 and above

FETCh:ETXPower:POWer:BURSt:SDEViation?

Function | GSM TA | This command is not applicable to GSM.
 | GPRS TA | This command is not applicable to GPRS.
 | GSM/GPRS LA | This command is not applicable to the GSM/GPRS LA.
 | EGPRS LA | Queries the standard deviation from a burst power multi-measurement.
 | EGPRS TA
Query |  | Range: 0 dB to 100 dB and 9.91 E+37 (NAN) Resolution: 0.001 dB
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.03 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.01 and above

FETCh:ETXPower:POWer:CARRier[:AVERage]?

Function | GSM TA | This command is not applicable to GSM.
 | GPRS TA | This command is not applicable to GPRS.
 | GSM/GPRS LA | This command is not applicable to the GSM/GPRS LA.
 | EGPRS LA | Queries average carrier power.
 | EGPRS TA
Query |  | Range: -100 dBm to 100 dBm and 9.91 E+37 (NAN) Resolution: 0.01 dB
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.03 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.01 and above

FETCh:ETXPower:POWer:CARRier:MAXimum?

Function | GSM TA | This command is not applicable to GSM.
 | GPRS TA | This command is not applicable to GPRS.
 | GSM/GPRS LA | This command is not applicable to the GSM/GPRS LA.
 | EGPRS LA | Queries maximum carrier power results from a multi-measurement.
 | EGPRS TA
Query |  | Range: -100 dBm to 100 dBm and 9.91 E+37 (NAN) Resolution: 0.01 dB
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.03 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.01 and above

FETCh:ETXPower:POWer:CARRier:MINimum?

Function | GSM TA | This command is not applicable to GSM.
 | GPRS TA | This command is not applicable to GPRS.
 | GSM/GPRS LA | This command is not applicable to the GSM/GPRS LA.
 | EGPRS LA | Queries minimum carrier power results from a multi-measurement.
 | EGPRS TA
Query |  | Range: -100 dBm to 100 dBm and 9.91 E+37 (NAN) Resolution: 0.01 dB
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.03 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.01 and above

FETCh:ETXPower:POWer:CARRier:SDEViation?

Function | GSM TA | This command is not applicable to GSM.
 | GPRS TA | This command is not applicable to GPRS.
 | GSM/GPRS LA | This command is not applicable to the GSM/GPRS LA.
 | EGPRS LA | Queries the standard deviation from a carrier power multi-measurement.
 | EGPRS TA
Query |  | Range: 0 dB to 100 dB and 9.91 E+37 (NAN) Resolution: 0.001 dB
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.03 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.01 and above


FETCh:FBERror

FETCh:FBERror

GPIB Command Conventions

  • FETCh:FBERror[:ALL]?
  • FETCh:FBERror:BITS?
  • FETCh:FBERror:COUNt?
  • FETCh:FBERror:DELay?
  • FETCh:FBERror:ICOunt?
  • FETCh:FBERror:INTegrity?
  • FETCh:FBERror:RATio?

FETCh:FBERror[:ALL]?

Function

 GSM TA

Queries the fast bit error measurement. Query returns integrity indicator, bits tested, bit error ratio, and bit error count.

Bit error ratio is displayed in the Fast Bit Error field. The other values returned by this query are not available on the front panel display.

GSM/GPRS LA

EGPRS LA

GPRS TA

This command is not applicable to GPRS.

EGPRS TA

This command is not applicable to EGPRS.

Query

Integrity indicator:

  • See Integrity Indicator .
  • Resolution: 1

Bits tested:

  • Range: 1 to 999,455 and 9.91 E+37 (NAN)
  • Resolution: 1

Bit error ratio:

  • Range: 0 to 100 and 9.91 E+37 (NAN)
  • Resolution: 0.01

Fast bit error count:

  • Range: 1 to 999,455 and 9.91 E+37 (NAN)
  • Resolution: 1

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

FETCh:FBERror:BITS?

Function | GSM TA | Queries the total number of information bits tested during the last fast bit error measurement. See SETup:FBERror:COUNt This value is not available on the front panel display.
 | GSM/GPRS LA
 | EGPRS LA
 | GPRS TA | This command is not applicable to GPRS.
 | EGPRS TA | This command is not applicable to EGPRS.
Query |  | Range: 1 to 999,455 and 9.91 E+37 (NAN) Resolution: 1
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.01 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.01 and above

FETCh:FBERror:COUNt?

Function | GSM TA | Queries the number of information bits that were deemed errors during the last fast bit error test. This value is not available on the front panel display.
 | GSM/GPRS LA
 | EGPRS LA
 | GPRS TA | This command is not applicable to GPRS.
 | EGPRS TA | This command is not applicable to EGPRS.
Query |  | Range: 1 to 999,455 and 9.91 E+37 (NAN) Resolution: 1
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.01 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.01 and above

FETCh:FBERror:DELay?

Function

GSM TA

Queries the delay (in TDMA frames) the test set used during the last fast bit error measurement to correlate uplink information bits with downlink information bits.

This value is displayed in the TDMA Frame Delay field.

This value can be determined automatically, or set by the user. See SETup:FBERror:MANual:DELay and SETup:FBERror:LDControl:AUTO for setting this value manually.

Refer also to the Fast Bit Error Measurement Description for a description of frame delay and how it is used in the fast bit error measurement.

GSM/GPRS LA

EGPRS LA

GPRS TA

This command is not applicable to GPRS.

EGPRS TA

This command is not applicable to EGPRS.

Query

Range: 0 to 26 and 9.91 E+37 (NAN)

Resolution: 1

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

FETCh:FBERror:ICOunt?

Function | GSM TA | Queries the intermediate count (measurement progress report) of bits tested
 | GSM/GPRS LA
 | EGPRS LA
 | GPRS TA | This command is not applicable to GPRS.
 | EGPRS TA | This command is not applicable to EGPRS.
Query |  | Range: 0 to 999,455 and 9.91 E+37 (NAN)
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.01 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.01 and above

FETCh:FBERror:INTegrity?

Function | GSM | Returns the integrity indicator value for the last fast bit error measurement performed. Zero indicates a normal result. See Integrity Indicator for descriptions of non-zero integrity indicators.
 | GSM/GPRS LA
 | EGPRS LA
 | GPRS TA | This command is not applicable to GPRS.
 | EGPRS TA | This command is not applicable to EGPRS.
Query |  | Range: See Integrity Indicator . Resolution: 1
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.01 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.01 and above

FETCh:FBERror:RATio?

Function | GSM TA | Queries the ratio of bits deemed bad to total bits tested during the last fast bit error measurement performed.
 | GSM/GPRS LA
 | EGPRS LA
 | GPRS TA | This command is not applicable to GPRS.
 | EGPRS TA | This command is not applicable to EGPRS.
Query |  | Range: 0 to 100 and 9.91 E+37 (NAN) Resolution: 0.01
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.01 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.01 and above


FETCh:FSTability

FETCh:FSTability

GPIB Command Conventions

  • FETCh:FSTability[:ALL]?
  • FETCh:FSTability:FERRor[:WORSt]?
  • FETCh:FSTability:FERRor:ALL?
  • FETCh:FSTability:FERRor:AVERage?
  • FETCh:FSTability:FERRor:MAXimum?
  • FETCh:FSTability:FERRor:MINimum?
  • FETCh:FSTability:FREQuency[:AVERage]?
  • FETCh:FSTability:FREQuency:ALL?
  • FETCh:FSTability:FREQuency:MAXimum?
  • FETCh:FSTability:FREQuency:MINimum?
  • FETCh:FSTability:FREQuency:SDEViation?
  • FETCh:FSTability:ICOunt?
  • FETCh:FSTability:INTegrity?

FETCh:FSTability[:ALL]?

Function

GSM TA

Queries the frequency stability measurement. Returns integrity, worst-case frequency error, and average frequency.
GPRS TA
EGPRS TA
GSM LA
GPRS/EGPRS LA

Query

Worst-case frequency error:

  • Range: -500 to 500 parts per million (ppm)

  • Resolution: 0.01 ppm

Average frequency:

  • Range: 100 E+6 to 3 E+9 Hz

  • Resolution: 0.01 ppm
Requirements GSM/GPRS/ EGPRS TA

Revision: A.04 and above
GSM/GPRS/ EGPRS LA Revision: D.01 and above

Programming Example

OUTPUT 714;"FETCH:FSTABILITY:ALL?"
! Returns integrity, worst-case frequency error, and average frequency.

FETCh:FSTability:FERRor[:WORSt]?

Function

GSM TA

Queries the frequency stability frequency error measurement.
GPRS TA
EGPRS TA
GSM LA
GPRS/EGPRS LA

Query

Range: -500 to 500 parts per million (ppm)

Resolution: 0.01 ppm
Requirements GSM/GPRS/ EGPRS TA

Revision: A.04 and above
GSM/GPRS/ EGPRS LA Revision: D.01 and above

Programming Example

OUTPUT 714;"FETCH:FSTABILITY:FERROR:WORST?"

FETCh:FSTability:FERRor:ALL?

Function

GSM TA

Queries the frequency stability frequency error measurements.

Measurement results are returned in the following order: minimum frequency error, maximum frequency error, average frequency error, worst-case frequency error.
GPRS TA
EGPRS TA
GSM LA
GPRS/EGPRS LA

Query

Maximum, minimum frequency error:

  • Range: -500 E+3 to 500 E+3 Hz

  • Resolution: 1 Hz

Average frequency error:

  • Range: -500 E+3 to 500 E+3 Hz

  • Resolution: 1 Hz

Worst-case frequency error:

  • Range: -500 to 500 parts per million (ppm)

  • Resolution: 0.01
Requirements GSM/GPRS/ EGPRS TA

Revision: A.04 and above
GSM/GPRS/ EGPRS LA Revision: D.01 and above

Programming Example

OUTPUT 714;"FETCH:FSTABILITY:FERROR:ALL?"
! Returns minimum, maximum, average, and worst-case frequency error.

FETCh:FSTability:FERRor:AVERage?

Function

GSM TA

Queries the average frequency error measurement.
GPRS TA
EGPRS TA
GSM LA
GPRS/EGPRS LA

Query

Range: -500 E+3 to 500 E+3 Hz

Resolution: 1 Hz
Requirements GSM/GPRS/ EGPRS TA

Revision: A.04 and above
GSM/GPRS/ EGPRS LA Revision: D.01 and above

Programming Example

OUTPUT 714;"FETCH:FSTABILITY:FERROR:AVERAGE?"

FETCh:FSTability:FERRor:MAXimum?

Function

GSM TA

Queries the maximum frequency error measurement.
GPRS TA
EGPRS TA
GSM LA
GPRS/EGPRS LA

Query

Range: -500 E+3 to 500 E+3 Hz

Resolution: 1 Hz
Requirements GSM/GPRS/ EGPRS TA

Revision: A.04 and above
GSM/GPRS/ EGPRS LA Revision: D.01 and above

Programming Example

OUTPUT 714;"FETCH:FSTABILITY:FERROR:MAXIMUM?"

FETCh:FSTability:FERRor:MINimum?

Function

GSM TA

Queries the minimum frequency error measurement.
GPRS TA
EGPRS TA
GSM LA
GPRS/EGPRS LA

Query

Range: -500 E+3 to 500 E+3 Hz

Resolution: 1 Hz
Requirements GSM/GPRS/ EGPRS TA

Revision: A.04 and above
GSM/GPRS/ EGPRS LA Revision: D.01 and above

Programming Example

OUTPUT 714;"FETCH:FSTABILITY:FERROR:MINIMUM?"

FETCh:FSTability:FREQuency[:AVERage]?

Function

GSM TA

Queries the frequency stability average frequency measurement.
GPRS TA
EGPRS TA
GSM LA
GPRS/EGPRS LA

Query

Range: 100 E+6 to 3 E+9 Hz

Resolution: 1 Hz
Requirements GSM/GPRS/ EGPRS TA

Revision: A.04 and above
GSM/GPRS/ EGPRS LA Revision: D.01 and above

Programming Example

OUTPUT 714;"FETCH:FSTABILITY:FREQUENCY:AVERAGE?"

FETCh:FSTability:FREQuency:ALL?

Function

GSM TA

Queries the frequency stability frequency measurement.

Measurement results are returned in the following order: minimum frequency, maximum frequency, average frequency, and standard deviation frequency.
GPRS TA
EGPRS TA
GSM LA
GPRS/EGPRS LA

Query

Minimum, maximum, average frequency:

  • Range: 100 E+6 to 3 E+9

  • Resolution: 1 Hz

Standard deviation frequency:

  • Range: 0 to 500 E+3 Hz

  • Resolution: 0.1 Hz
Requirements GSM/GPRS/ EGPRS TA

Revision: A.04 and above
GSM/GPRS/ EGPRS LA Revision: D.01 and above

Programming Example

OUTPUT 714;"FETCH:FSTABILITY:FREQUENCY:ALL?"
! Returns minimum, maximum, average, and standard deviation frequency.

FETCh:FSTability:FREQuency:MAXimum?

Function

GSM TA

Queries the maximum frequency stability frequency.
GPRS TA
EGPRS TA
GSM LA
GPRS/EGPRS LA

Query

Range: 100 E+6 to 3 E+9

Resolution: 1 Hz
Requirements GSM/GPRS/ EGPRS TA

Revision: A.04 and above
GSM/GPRS/ EGPRS LA Revision: D.01 and above

Programming Example

OUTPUT 714;"FETCH:FSTABILITY:FREQUENCY:MAXIMUM?"

FETCh:FSTability:FREQuency:MINimum?

Function

GSM TA

Queries the minimum frequency stability frequency.
GPRS TA
EGPRS TA
GSM LA
GPRS/EGPRS LA

Query

Range: 100 E+6 to 3 E+9

Resolution: 1 Hz
Requirements GSM/GPRS/ EGPRS TA

Revision: A.04 and above
GSM/GPRS/ EGPRS LA Revision: D.01 and above

Programming Example

OUTPUT 714;"FETCH:FSTABILITY:FREQUENCY:MINIMUM?"

FETCh:FSTability:FREQuency:SDEViation?

Function

GSM TA

Queries the standard deviation frequency stability frequency.
GPRS TA
EGPRS TA
GSM LA
GPRS/EGPRS LA

Query

Range: 0 to 500 E+3 Hz

Resolution: 0.1 Hz
Requirements GSM/GPRS/ EGPRS TA

Revision: A.04 and above
GSM/GPRS/ EGPRS LA Revision: D.01 and above

Programming Example

OUTPUT 714;"FETCH:FSTABILITY:FREQUENCY:SDEVIATION?"

FETCh:FSTability:ICOunt?

Function

GSM TA

Queries the intermediate count of measurements completed in a multi-measurement.
GPRS TA
EGPRS TA
GSM LA
GPRS/EGPRS LA

Query

Range: 0 to 999
Requirements GSM/GPRS/ EGPRS TA

Revision: A.04 and above
GSM/GPRS/ EGPRS LA Revision: D.01 and above

Programming Example

OUTPUT 714;"FETCH:FSTABILITY:ICOUNT?"

FETCh:FSTability:INTegrity?

Function

GSM TA

Queries the measurement integrity indicator for the last frequency stability measurement completed.

Zero indicates a normal measurement. See Integrity Indicator for information about non-zero integrity results.
GPRS TA
EGPRS TA
GSM LA
GPRS/EGPRS LA

Query

Range: 1 through 16
Requirements GSM/GPRS/ EGPRS TA

Revision: A.04 and above
GSM/GPRS/ EGPRS LA Revision: D.01 and above

Programming Example

OUTPUT 714;"FETCH:FSTABILITY:INTEGRITY"
! Returns the integrity indicator for the frequency stability measurement.


FETCh:GBERror

FETCh:GBERror

GPIB Command Conventions

  • FETCh:GBERror[:ALL]?
  • FETCh:GBERror:BITS?
  • FETCh:GBERror:CRC?
  • FETCh:GBERror:COUNt?
  • FETCh:GBERror:DELay?
  • FETCh:GBERror:ICOunt?
  • FETCh:GBERror:INTegrity?
  • FETCh:GBERror:RATio?

FETCh:GBERror[:ALL]?

Function

 GSM TA

This command is not applicable to GSM.

GPRS TA

This query returns the bit error measurement results. The integrity indicator, bits tested, bit error ratio, and bit error count are returned.

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Integrity indicator:

  • Range: See Integrity Indicator .
  • Resolution: 1

Bits tested:

  • Range: 0 to 999,427 and 9.91 E+37 (NAN)
  • Resolution: 1

Bit error ratio:

  • Range: 0 to 100 and 9.91 E+37 (NAN)
  • Resolution: 0.01

Bit error count:

  • Range: 0 to 999,427 and 9.91 E+37 (NAN)
  • Resolution: 1
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

FETCh:GBERror:BITS?

Function | GSM TA | This command is not applicable to GSM.
 | GPRS TA | This query returns the total number of information bits tested during the last bit error measurement. See FETCh:GBERror:COUNt? .
 | EGPRS TA
 | GSM/GPRS LA
 | EGPRS LA
Query |  | Range: 0 to 999,427 and 9.91 E+37 (NAN) Resolution: 1
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.01 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.01 and above

FETCh:GBERror:CRC?

Function

 GSM TA

This command is not applicable to GSM.

GPRS TA

This query returns the CRC (Frame Check Sequence) Error Count found during the last GBER measurement. Each block that fails its CRC will cause the CRC Error Count result to increment.

The CRC Error Count affects the BLER measurement results differently depending on the GBER Bad Block Handling setting. For more information on the GBER Bad Block Handling setting see SETup:GBERror:BBLocks .

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Range: 0 to 99999 and 9.91 E+37 (NAN)

Resolution: 1
Requirements GSM/GPRS/
EGPRS TA

Revision: A.05 and above
GSM/GPRS/ EGPRS LA

Revision: D.02 and above

FETCh:GBERror:COUNt?

Function | GSM TA | This command is not applicable to GSM.
 | GPRS TA | This query returns the count of erroneous bits found during the last bit error measurement.
 | EGPRS TA
 | GSM/GPRS LA
 | EGPRS LA
Query |  | Range: 0 to 999,427 and 9.91 E+37 (NAN) Resolution: 1
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.01 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.01 and above

FETCh:GBERror:DELay?

Function

 GSM TA

This command is not applicable to GSM.

GPRS TA

This query returns the block delay the test set used during the last bit error measurement.

This value can be determined automatically by the test set, or you can set it manually. See SETup:GBERror:MANual:DELay and SETup:GBERror:LDControl:AUTO for setting this value manually.

Refer also to the GPRS Bit Error Measurement for a description of block delay and how it is used in the bit error measurement.

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Range: 1 to 12 and 9.91 E+37 (NAN)

Resolution: 1
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above

Revision A.03: Upper limit on range changed from 6 to 12
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Revision C.03: Upper limit on range changed from 6 to 12

FETCh:GBERror:ICOunt?

Function | GSM TA | This command is not applicable to GSM.
 | GPRS TA | Queries the intermediate count (measurement progress report) of bits tested.
 | EGPRS TA
 | GSM/GPRS LA
 | EGPRS LA
Query |  | Range: 0 to 999,455 and 9.91 E+37 (NAN)
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.01 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.01 and above

FETCh:GBERror:INTegrity?

Function | GSM TA | This command is not applicable to GSM.
 | GPRS TA | This query returns the integrity indicator value for the last bit error measurement performed. Zero indicates a normal result. See Integrity Indicator for descriptions of non-zero integrity indicators.
 | EGPRS TA
 | GSM/GPRS LA
 | EGPRS LA
Query |  | Range: See Integrity Indicator . Resolution: 1
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.01 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.01 and above

FETCh:GBERror:RATio?

Function | GSM TA | This command is not applicable to GSM.
 | GPRS TA | This query returns the ratio of erroneous bits found during the last bit error measurement.
 | EGPRS TA
 | GSM/GPRS LA
 | EGPRS LA
Query |  | Range: 0 to 100 and 9.91 E+37 (NAN) Resolution: 0.01
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.01 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.01 and above


FETCh:IFERror

FETCh:IFERror

GPIB Command Conventions

  • FETCh:IFERror[:ALL]?
  • FETCh:IFERror:COUNt?
  • FETCh:IFERror:DELay?
  • FETCh:IFERror:ICOunt?
  • FETCh:IFERror:INTegrity?
  • FETCh:IFERror:RATio?
  • FETCh:IFERror:SFRames?

FETCh:IFERror[:ALL]?

Function

 GSM TA

This command is not applicable to the GSM TA.
GPRS TA

This command is not applicable to the GPRS TA.
EGPRS TA

This command is not applicable to the EGPRS TA.

GSM/GPRS LA

Queries, in the following order: integrity, speech frames measured, frame error ratio, and frame error count.

EGPRS LA

Query

Integrity indicator

  • Range: See Integrity Indicator .
  • Resolution: 1

Number of speech frames tested

  • Range: 1 to 900000 or 9.91e+37 (NAN)
  • Resolution: 1

Frame Error Ratio

  • Range: 0 to 100 or 9.91e+37 (NAN)
  • Resolution: .001

Frame Error Count

  • Range: 0 to 900000 or 9.91e+37 (NAN)
  • Resolution: 1
Requirements

 GSM/GPRS/ EGPRS LA

Revision: D.01 and above

GSM/GPRS/ EGPRS TA

Revision: A.09 and above with required feature license.

Programming Example

OUTPUT 714;"FETCh:IFERror?"
! Queries for values in the following order: integrity, speech frames tested, frame error ratio,
! frame error count.

FETCh:IFERror:COUNt?

Function

 GSM TA

This command is not applicable to the GSM TA.
GPRS TA

This command is not applicable to the GPRS TA.
EGPRS TA

This command is not applicable to the EGPRS TA.

GSM/GPRS LA

Queries the frame error count.

EGPRS LA

Query

Range: 1 to 900000 or 9.91e+37 (NAN)

Resolution: 1
Requirements

 GSM/GPRS/ EGPRS LA

Revision: D.01 and above

GSM/GPRS/ EGPRS TA

Revision: A.09 and above with required feature license.

Programming Example

OUTPUT 714;"FETCh:IFERror:COUNt?"
! Queries the frame error count.

FETCh:IFERror:DELay?

Function

 GSM TA

This command is not applicable to the GSM TA.
GPRS TA

This command is not applicable to the GPRS TA.
EGPRS TA

This command is not applicable to the EGPRS TA.

GSM/GPRS LA

Queries the number of speech frames that were necessary for the test set to synchronize the uplink with the downlink.

EGPRS LA
Requirements

 GSM/GPRS/ EGPRS LA

Revision: D.01 and above

GSM/GPRS/ EGPRS TA

Revision: A.09 and above with required feature license.

Programming Example

OUTPUT 714;"FETCh:IFERror:DELay?"
! Queries the number of speech frames that were necessary for the test set to synchronize
! the uplink with the downlink.

FETCh:IFERror:ICOunt?

Function

 GSM TA

This command is not applicable to the GSM TA.
GPRS TA

This command is not applicable to the GPRS TA.
EGPRS TA

This command is not applicable to the EGPRS TA.

GSM/GPRS LA

Queries the measurement progress by returning the number of frames measured of the total to be measured.

EGPRS LA

Query

Range: 1 to 900000 or 9.91e+37 (NAN)

Resolution: 1
Requirements

 GSM/GPRS/ EGPRS LA

Revision: D.01 and above

GSM/GPRS/ EGPRS TA

Revision: A.09 and above with required feature license.

Programming Example

OUTPUT 714;"FETCh:IFERror:ICOunt?"
! Queries the measurement progress.

FETCh:IFERror:INTegrity?

Function

 GSM TA

This command is not applicable to the GSM TA.
GPRS TA

This command is not applicable to the GPRS TA.
EGPRS TA

This command is not applicable to the EGPRS TA.

GSM/GPRS LA

Queries the integrity indicator value for each burst.

EGPRS LA

Query

Range: See Integrity Indicator .

Resolution: 1
Requirements

 GSM/GPRS/ EGPRS LA

Revision: D.01 and above

GSM/GPRS/ EGPRS TA

Revision: A.09 and above with required feature license.

Programming Example

OUTPUT 714;"FETCh:IFERror:INTegrity?"
! Queries the measurement integrity indicator value.

FETCh:IFERror:RATio?

Function

 GSM TA

This command is not applicable to the GSM TA.
GPRS TA

This command is not applicable to the GPRS TA.
EGPRS TA

This command is not applicable to the EGPRS TA.
GSM/GPRS LA Queries the frame error ratio.

EGPRS LA

Query

Range: 0 to 100 or 9.91e+37 (NAN)

Resolution: .001
Requirements

 GSM/GPRS/ EGPRS LA

Revision: D.01 and above

GSM/GPRS/ EGPRS TA

Revision: A.09 and above with required feature license.

Programming Example

OUTPUT 714;"FETCh:IFERror:RATio?"
! Queries for the frame error ratio.

FETCh:IFERror:SFRames?

Function

 GSM TA

This command is not applicable to the GSM TA.
GPRS TA

This command is not applicable to the GPRS TA.
EGPRS TA

This command is not applicable to the EGPRS TA.

GSM/GPRS LA

Queries the number of speech frames measured.

EGPRS LA

Query

Range: 1 to 900000 or 9.91e+37 (NAN)

Resolution: 1
Requirements

 GSM/GPRS/ EGPRS LA

Revision: D.01 and above

GSM/GPRS/ EGPRS TA

Revision: A.09 and above with required feature license.

Programming Example

OUTPUT 714;"FETCh:IFERror:SFRames?"
! Queries for the number of frames measured.


FETCh:IQTuning

FETCh:IQTuning

GPIB Command Conventions

  • FETCh:IQTuning[:ALL]?
  • FETCh:IQTuning:ICOunt?
  • FETCh:IQTuning:INTegrity?
  • FETCh:IQTuning:POWer[:ALL]?
  • FETCh:IQTuning:REFerence:FREQuency?
  • FETCh:IQTuning:SPUR:POWer?

FETCh:IQTuning[:ALL]?

Function

 GSM TA Queries the I/Q Tuning measurement results. Query returns the integrity indicator and the relative power level at the following offset frequencies: carrier frequency, +/-67.7083 kHz, +/-135.417 kHz, +/-203.125 kHz, +/-270.833 kHz. The spur measurement result is also returned.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Integrity indicator

  • Range: See Integrity Indicator .
  • Resolution: 1

Signal level relative to the desired signal at 9 different frequencies

  • Range: -100 to +100 dB and 9.91 E+37 (NAN)
  • Resolution: 0.01 dB

The order of the signal level results are:

  • -270.833 kHz
  • -203.125 kHz
  • -135.417 kHz
  • -67.7083 kHz
  • carrier frequency
  • +67.7083 kHz
  • +135.417 kHz
  • +203.125 kHz
  • +270.833 kHz

Relative power of the spur frequency:

  • Range: -100 to +100 dB and 9.91E+37 (NAN)
  • Resolution: 0.01 dB
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

FETCh:IQTuning:ICOunt?

Function | GSM TA | Queries the intermediate number of I/Q Tuning multi-measurements completed.
 | GPRS TA
 | EGPRS TA
 | GSM/GPRS LA
 | EGPRS LA
Query |  | Range: 0 to 999 Resolution: 1
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.01 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.01 and above

FETCh:IQTuning:INTegrity?

Function | GSM TA | Returns the integrity indicator value for the last I/Q Tuning measurement performed. Zero indicates a normal result.
 | GPRS TA
 | EGPRS TA
 | GSM/GPRS LA
 | EGPRS LA
Query |  | Range: See Integrity Indicator . Resolution: 1
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.01 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.01 and above

FETCh:IQTuning:POWer[:ALL]?

Function

 GSM TA Queries the I/Q Tuning measurement results. Query returns the relative power level at the following offset frequencies: carrier frequency, 䕧.7083 kHz, 𫏯.417 kHz, 𫐳.125 kHz, 𫑶.833 kHz. The spur measurement result is also returned.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Signal level relative to the desired signal at 9 different frequencies

  • Range: -100 to +100 dB and 9.91 E+37 (NAN)
  • Resolution: 0.01 dB

The order of the signal level results are:

  • -270.833 kHz
  • -203.125 kHz
  • -135.417 kHz
  • -67.7083 kHz
  • carrier frequency
  • +67.7083 kHz
  • +135.417 kHz
  • +203.125 kHz

  • +270.833 kHz

Relative power of the spur frequency:

  • Range: -100 to +100 dB and 9.91E+37 (NAN)
  • Resolution: 0.01 dB
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

FETCh:IQTuning:REFerence:FREQuency?

Function | GSM TA | Queries the offset frequency being used as the reference for the measurement.
 | GPRS TA
 | EGPRS TA
 | GSM/GPRS LA
 | EGPRS LA
Query |  | NEG67KHZ | ZEROKHZ | POS67KHZ | UNKNOWN
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.01 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.01 and above

FETCh:IQTuning:SPUR:POWer?

Function | GSM TA | Queries the relative power level of the spur frequency.
 | GPRS TA
 | EGPRS TA
 | GSM/GPRS LA
 | EGPRS LA
Query |  | Range: -100 to +100 dB and 9.91 E+37 (NAN) Resolution: 0.01 dB
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.01 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.01 and above


FETCh:MTAudio

FETCh:MTAudio

GPIB Command Conventions

  • FETCh:MTAudio[:ALL]?
  • FETCh:MTAudio:DISTortion[:AVERage]?
  • FETCh:MTAudio:FREQuency[:AVERage]?
  • FETCh:MTAudio:ICOunt?
  • FETCh:MTAudio:INTegrity?
  • FETCh:MTAudio:LEVel?
  • FETCh:MTAudio:LEVel:LIMit:FAIL?
  • FETCh:MTAudio:SINad|SNDRatio[:AVERage]?
  • FETCh:MTAudio:VOLTage[:AVERage]?

FETCh:MTAudio[:ALL]?

Function | GSM TA | This query returns the integrity indicator and a comma separated list containing the measured average audio levels for each of the 20 audio tones that are turned on. The query returns NAN (9.91E+37) for any audio tone that is turned off. See SETup:MTAudio:GENerator:LEVel:DOWNlink:ALL[:SAMPlitude] for more information on turning audio tones off and on
 | GSM/GPRS LA
 | EGPRS LA
 | GPRS TA
 | EGPRS TA
Query |  | Range: -100 to +100 dB or 9.91E+37 (NAN) Resolution: 0.1 dB
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.01 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.01 and above

FETCh:MTAudio:DISTortion[:AVERage]?

Function

GSM TA

This query returns the average multi-tone audio distortion measurement result for audio tone 1. The SINAD/Distortion state must be on for this result to be returned. See SETup:MTAudio:SDIStortion:STATe .

GSM/GPRS LA

EGPRS LA

GPRS TA
EGPRS TA

Query

Average audio distortion

  • Range: 0 to 99%, 9.91 E+37

  • Resolution: 0.01%

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

FETCh:MTAudio:FREQuency[:AVERage]?

Function

GSM TA

This query returns the average frequency measurement result for audio tone 1. The SINAD/Distortion state must be on for this result to be returned. See SETup:MTAudio:SDIStortion:STATe .

GSM/GPRS LA

EGPRS LA

GPRS TA
EGPRS TA

Query

Average frequency

  • Range: 0 to 99999 Hz, 9.91 E+37

  • Resolution: 0.01 Hz

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

FETCh:MTAudio:ICOunt?

Function | GSM TA | This query returns the intermediate count of multi-tone audio multi-measurements completed. This value is not available over the manual interface.
 | GSM/GPRS LA
 | EGPRS LA
 | GPRS TA
 | EGPRS TA
Query |  | Range: 1 to 999 Resolution: 1
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.01 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.01 and above

FETCh:MTAudio:INTegrity?

Function | GSM TA | This query returns the integrity indicator for the last multi-tone audio measurement completed. Zero indicates a normal measurement. See Integrity Indicator for descriptions of non-zero integrity indicators.
 | GSM/GPRS LA
 | EGPRS LA
 | GPRS TA
 | EGPRS TA
Query |  | Range: See Integrity Indicator . Resolution: 1
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.01 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.01 and above

FETCh:MTAudio:LEVel?

Function | GSM TA | This query returns a comma separated list containing the measured average audio levels for each of the 20 audio tones that are turned on. The query returns NAN (9.91E+37) for any audio tone that is turned off. See SETup:MTAudio:GENerator:LEVel:DOWNlink:ALL[:SAMPlitude] for more information on turning audio tones off and on.
 | GSM/GPRS LA
 | EGPRS LA
 | GPRS TA
 | EGPRS TA
Query |  | Range: -100 to +100 dB or 9.91E+37 (NAN) Resolution: 0.1 dB
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.01 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.01 and above

FETCh:MTAudio:LEVel:LIMit:FAIL?

Function | GSM TA | This query returns information about whether the multi-tone audio level measurement results exceeded the mask limits.
 | GSM/GPRS LA
 | EGPRS LA
 | GPRS TA
 | EGPRS TA
Query |  | 0: Passed 1: Failed 9.91E+37 (NAN): results can not be determined
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.01 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.01 and above

FETCh:MTAudio:SINad|SNDRatio[:AVERage]?

Function

GSM TA

This query returns the average SINAD measurement for audio tone 1. The SINAD/Distortion state must be on for this result to be returned. See SETup:MTAudio:SDIStortion:STATe .

GSM/GPRS LA

EGPRS LA

GPRS TA
EGPRS TA

Query

Average SINAD

  • Range:-99 to 99 dB, 9.91 E+37

  • Resolution: 0.01 dB

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

FETCh:MTAudio:VOLTage[:AVERage]?

Function

GSM TA

This query returns the total average measured audio level. The value is returned in units of Vrms when the measurement mode is downlink and in percentage (%) when the measurement mode is uplink. (See SETup:MTAudio:MEASurement:MODE .) When the SINAD/Distortion state is on, this result is the average audio level of audio tone 1. See SETup:MTAudio:SDIStortion:STATe .

GSM/GPRS LA

EGPRS LA

GPRS TA
EGPRS TA

Query

Downlink

  • Range: 5 mVrms to 14.1 Vrms
  • Resolution: 0.1 mVrms

Uplink

  • Range: 0 to 70 %
  • Resolution: 0.1%

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above


FETCh:ORFSpectrum

FETCh:ORFSpectrum

GPIB Command Conventions

  • FETCh:ORFSpectrum[:ALL]?
  • FETCh:ORFSpectrum:ICOunt?
  • FETCh:ORFSpectrum:INTegrity?
  • FETCh:ORFSpectrum:LIMit?
  • FETCh:ORFSpectrum:LIMit:ALL?
  • FETCh:ORFSpectrum:MODulation[:ALL][:AVERage]?
  • FETCh:ORFSpectrum:MODulation[:ALL]:SDEViation?
  • FETCh:ORFSpectrum:MODulation:FREQuency[:OFFSet][:AVERage]?
  • FETCh:ORFSpectrum:MODulation:FREQuency[:OFFSet]:SDEViation?
  • FETCh:ORFSpectrum:MODulation:LIMit?
  • FETCh:ORFSpectrum:MODulation:LIMit:ALL?
  • FETCh:ORFSpectrum:POWer?
  • FETCh:ORFSpectrum:POWer:BWIDth[:AVERage]?
  • FETCh:ORFSpectrum:POWer:BWIDth:SDEViation?
  • FETCh:ORFSpectrum:SWITChing[:ALL][:MAXimum]?
  • FETCh:ORFSpectrum:SWITChing[:ALL]:AVERage?
  • FETCh:ORFSpectrum:SWITChing[:ALL]:SDEViation?
  • FETCh:ORFSpectrum:SWITChing:FREQuency[:OFFSet][:MAXimum]?
  • FETCh:ORFSpectrum:SWITChing:FREQuency[:OFFSet]:AVERage?
  • FETCh:ORFSpectrum:SWITChing:FREQuency[:OFFSet]:SDEViation?
  • FETCh:ORFSpectrum:SWITching:LIMit?
  • FETCh:ORFSpectrum:SWITching:LIMit:ALL?

FETCh:ORFSpectrum[:ALL]?

Function

GSM TA

Queries integrity indicator, TX carrier power, up to eight comma-separated output RF spectrum due to switching (max) results, 30 kHz bandwidth power, and up to 22 output RF spectrum due to modulation (average) results.

The SETup:ORFSpectrum:SWITching:FREQuency[:OFFSet] command sets up the number of output RF spectrum due to switching offsets that are turned on and their frequency values. The SETup:ORFSpectrum:SWITching:FREQuency:POINts? queries the number of output RF spectrum due to switching points that are turned on, indicating the number of output RF spectrum due to switching (max) values to expect when you FETCh results.

The SETup:ORFSpectrum:MODulation:FREQuency[:OFFSet] command sets up the number of output RF spectrum due to modulation offsets that are turned on and their frequency values. The SETup:ORFSpectrum:MODulation:FREQuency:POINts? command queries the number of output RF spectrum due to modulation points that are turned on, indicating the number of output RF spectrum due to modulation (average) values to expect when you FETCh results.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Integrity indicator

  • Range: See Integrity Indicator .
  • Resolution: 1

TX Carrier Power

  • Range: -100 dBm to +100 dBm and 9.91 E+37
  • Resolution: 0.01 dB

Output RF Spectrum Due to Switching (Max)

  • Range: -100 dBm to +100 dBm and 9.91 E+37
  • Resolution: 0.01 dB

30 kHz Bandwidth Power

  • Range: -100 dBm to +100 dBm and 9.91 E+37
  • Resolution: 0.01 dB

Output RF Spectrum due to Modulation (Average)

  • Range: -200 dB to +100 dB and 9.91 E+37
  • Resolution: 0.01 dB
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

FETCh:ORFSpectrum:ICOunt?

Function | GSM TA | Queries the intermediate count of ORFS multi-measurements completed. This number will climb to the number returned by SETup:ORFSpectrum:ICOunt:MAXimum? .
 | GPRS TA
 | EGPRS TA
 | GSM/GPRS LA
 | EGPRS LA
Query |  | Range: 0 to 30970 Resolution: 1
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.01 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.01 and above

FETCh:ORFSpectrum:INTegrity?

Function | GSM TA | Queries the integrity indicator for the output RF spectrum analyzer measurement. Zero indicates a normal result. See Integrity Indicator for descriptions of non-zero integrity indicators.
 | GPRS TA
 | EGPRS TA
 | GSM/GPRS LA
 | EGPRS LA
Query |  | Range: See Integrity Indicator . Resolution: 1
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.01 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.01 and above

FETCh:ORFSpectrum:LIMit?

Function | GSM TA | Queries both the ORFS switching and modulation offset results for an overall pass/fail result.
 | GPRS TA
 | EGPRS TA
 | GSM/GPRS LA
 | EGPRS LA
Query |  | Range: 0 (pass), 1 (fail), and 9.91 E+37 (NAN)
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.01 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.01 and above

FETCh:ORFSpectrum:LIMit:ALL?

Function

 GSM TA Queries the results for all enabled ORFS due to switching offsets and enabled ORFS due to modulation offsets.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

For each switching enabled result the following is returned in a comma-separated:

  • 0 (pass), 1 (fail), and 9.91 E+37 (NAN)
  • limit used

For each modulation enabled result the following is returned in a comma-separated:

  • 0 (pass), 1 (failed due to relative limit), -1 (failed due to absolute limit) and 9.91 E+37 (NAN)
  • relative limit used (in dB)
  • absolute limit used (in dBm)
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

FETCh:ORFSpectrum:MODulation[:ALL][:AVERage]?

Function

GSM TA

Queries 30 kHz BW Power, and up to 22 comma-separated output RF spectrum due to modulation (average) results.

The SETup:ORFSpectrum:MODulation:FREQuency[:OFFSet] command sets up the number of output RF spectrum due to modulation offsets that are turned on and their frequency values. The SETup:ORFSpectrum:MODulation:FREQuency:POINts? command queries the number of output RF spectrum due to modulation points that are turned on, indicating the number of output RF spectrum due to modulation (average) values to expect when you FETCh output RF spectrum due to modulation results.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

TX Carrier Power

  • Range: -100 dBm to +100 dBm and 9.91 E+37
  • Resolution: 0.01 dB

30 kHz Bandwidth Power

  • Range: -100 dBm to +100 dBm and 9.91 E+37
  • Resolution: 0.01 dB

Output RF Spectrum due to Modulation (Average)

  • Range: -200 dB to +100 dB and 9.91 E+37
  • Resolution: 0.01 dB
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

FETCh:ORFSpectrum:MODulation[:ALL]:SDEViation?

Function

GSM TA

Queries 30 kHz BW Power, and the standard deviation of the power level of up to 22 frequency offsets.

The SETup:ORFSpectrum:MODulation:FREQuency[:OFFSet] command sets up the number of output RF spectrum due to modulation offsets that are turned on and their frequency values. The SETup:ORFSpectrum:MODulation:FREQuency:POINts? command queries the number of output RF spectrum due to modulation points that are turned on, indicating the number of output RF spectrum due to modulation (average) values to expect when you FETCh output RF spectrum due to modulation results.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Range: 0 to 150 and 9.91E+37 (NAN)

Resolution: 0.001

Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above

Programming Example:

OUTPUT 714;"FETCh:ORFSpectrum:MODulation[:ALL]:SDEViation?
! Queries the 30 kHz bandwidth power and the standard deviation of up to 22 offsets.

FETCh:ORFSpectrum:MODulation:FREQuency[:OFFSet][:AVERage]?

Function

GSM TA

Queries the ORFS due to modulation measurement, allowing frequency offset values to be appended to the command. Returns ORFS due to modulation (average) measurements at the frequencies listed, in the order they are listed.

Frequencies must have a one-to-one correspondence to ORFS due to modulation frequency offsets that are currently turned on. Frequencies must be separated by commas. (See SETup:ORFSpectrum:MODulation:FREQuency[:OFFSet] for the command that turns on frequency offsets.)

Each frequency value is (optionally) followed by: HZ|KHZ|MHZ|GHZ . The default unit is HZ (hertz).

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Range: -200 dB to +100 dB and 9.91E+37 (NAN)

Resolution: 0.001 dB
Requirements

GSM/GPRS/
EGPRS TA

Revision: A.06 and above

GSM/GPRS/ EGPRS LA

 Revision: D.03 and above

Programming Example

OUTPUT 714;"FETCh:ORFSpectrum:MODulation:FREQuency? 200 KHZ, 400 KHZ"
! Returns the ORFS due to modulation (average) measurement results at the
! 200 kHz and 400 kHz offsets only, assuming these offsets are turned on.

FETCh:ORFSpectrum:MODulation:FREQuency[:OFFSet]:SDEViation?

Function

GSM TA

Queries the ORFS due to modulation measurement, allowing frequency offset values to be appended to the command. Returns ORFS due to modulation standard deviation of measurements at the frequencies listed, in the order they are listed.

Frequencies must have a one-to-one correspondence to ORFS due to modulation frequency offsets that are currently turned on. Frequencies must be separated by commas. (See SETup:ORFSpectrum:MODulation:FREQuency[:OFFSet] for the command that turns on frequency offsets.)

Each frequency value is (optionally) followed by: HZ|KHZ|MHZ|GHZ. The default unit is HZ (hertz).

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Range: 0 dB to +150 and 9.91 E+37 (NAN)

Resolution: 0.001

Requirements GSM/GPRS/
EGPRS TA

Revision: A.06 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"FETCH:ORFSectrum:MODulation:FREQuency:SDEV? 200 KHZ, 400 KHZ"
! Returns the ORFS due to modulation standard deviation of the measurement results
! at the 200 kHz and 400 kHz offsets only, assuming these offsets are turned on.

FETCh:ORFSpectrum:MODulation:LIMit?

Function | GSM TA | Queries the ORFS modulation offset results for an overall pass/fail result.
 | GPRS TA
 | EGPRS TA
 | GSM/GPRS LA
 | EGPRS LA
Query |  | Range: 0 (pass), 1 (fail), and 9.91 E+37 (NAN)
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.01 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.01 and above

FETCh:ORFSpectrum:MODulation:LIMit:ALL?

Function

 GSM TA Queries the results for all enabled ORFS due to modulation offsets.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

For each modulation enabled result the following is returned in a comma-separated:

  • 0 (pass), 1 (failed due to relative limit), -1 (failed due to absolute limit), and 9.91E+37 (NAN)
  • relative limit used (in dB)
  • absolute limit used (in dBm)
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

FETCh:ORFSpectrum:POWer?

Function

 GSM TA

Returns the TX carrier power measurement result from the last ORFS measurement. This measurement is made using the method described in the Transmit Power Measurement Description .

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Range: -100 dBm to +100 dBm and 9.91 E+37 (NAN)

Resolution: 0.01 dB
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"FETCH:ORFSPECTRUM:POWER:TXPOWER?"
! Returns TX carrier power.

FETCh:ORFSpectrum:POWer:BWIDth[:AVERage]?

Function | GSM TA | Queries the average ORFS 30 kHz bandwidth power measurement. See Output RF Spectrum Measurement Description .
 | GPRS TA
 | EGPRS TA
 | GSM/GPRS LA
 | EGPRS LA
Query |  | Range: -100 dBm to +100 dBm and 9.91 E+37 (NAN) Resolution: 0.01 dB
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.01 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.01 and above

FETCh:ORFSpectrum:POWer:BWIDth:SDEViation?

Function | GSM TA | Queries the standard deviation of the ORFS 30 kHz bandwidth power measurement. See Output RF Spectrum Measurement Description .
 | GPRS TA
 | EGPRS TA
 | GSM/GPRS LA
 | EGPRS LA
Query |  | Range: 0 dB to +150 and 9.91E+37 (NAN) Resolution: 0.001
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.06 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.01 and above

FETCh:ORFSpectrum:SWITChing[:ALL][:MAXimum]?

Function

 GSM TA

Queries output RF spectrum due to switching (maximum) measurement results at all frequency offsets currently turned on (there can be up to eight).

The SETup:ORFSpectrum:SWITching:FREQuency[:OFFSet] command sets up the number of output RF spectrum due to switching offsets that are turned on and their frequency values. The SETup:ORFSpectrum:SWITching:FREQuency:POINts? queries the number of output RF spectrum due to switching points that are turned on, indicating the number of output RF spectrum due to switching (max) values to expect when you FETCh results.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Range: -100 dBm to +100 dBm and 9.91 E+37 (NAN)

Resolution: 0.01 dB
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"FETCH:ORFSPECTRUM:SWITCHING:ALL:MAXIMUM?"
! Returns the ORFS due to switching (maximum) measurement results at
! all frequency offsets currently turned on.

FETCh:ORFSpectrum:SWITChing[:ALL]:AVERage?

Function

 GSM TA

Queries output RF spectrum due to switching (average) measurement results at all frequency offsets currently turned on (there can be up to eight).

The SETup:ORFSpectrum:SWITching:FREQuency[:OFFSet] command sets up the number of output RF spectrum due to switching offsets that are turned on and their frequency values. The SETup:ORFSpectrum:SWITching:FREQuency:POINts? queries the number of output RF spectrum due to switching points that are turned on, indicating the number of output RF spectrum due to switching values to expect when you FETCh results.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Range: -100 dBm to +100 dBm and 9.91 E+37 (NAN)

Resolution: 0.01 dB
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"FETCH:ORFSPECTRUM:SWITCHING:ALL:AVERAGE?"
! Returns the ORFS due to switching (average) measurement results at all
! frequency offsets currently turned on.

FETCh:ORFSpectrum:SWITChing[:ALL]:SDEViation?

Function

 GSM TA

Queries output RF spectrum due to switching (standard deviation) measurement results at all frequency offsets currently turned on (there can be up to eight).

The SETup:ORFSpectrum:SWITching:FREQuency[:OFFSet] command sets up the number of output RF spectrum due to switching offsets that are turned on and their frequency values. The SETup:ORFSpectrum:SWITching:FREQuency:POINts? queries the number of output RF spectrum due to switching points that are turned on, indicating the number of output RF spectrum due to switching values to expect when you FETCh results.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Range: -100 dBm to +100 dBm and 9.91 E+37 (NAN)

Resolution: 0.01 dB
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"FETCH:ORFSPECTRUM:SWITCHING:ALL:SDEVIATION?"
! Returns the ORFS due to switching (standard deviation) measurement results
! at all frequency offsets currently turned on.

FETCh:ORFSpectrum:SWITChing:FREQuency[:OFFSet][:MAXimum]?

Function

 GSM TA

Queries the ORFS due to switching measurement, allowing frequency offset values to be appended to the command. Returns ORFS due to switching (maximum) measurements at the frequencies listed, in the order they are listed.

Frequencies must have a one-to-one correspondence to ORFS due to switching frequency offsets that are currently turned on. Frequencies must be separated by commas. (See SETup:ORFSpectrum:SWITching:FREQuency[:OFFSet] for the command that turns on frequency offsets.)

Each value is (optionally) followed by: HZ|KHZ|MHZ|GHZ. The default unit is HZ (hertz).

GPRS TA

GSM/GPRS LA

EGPRS LA

Query

Range: -100 dB to +100 dB and 9.91 E+37 (NAN)

Resolution: 0.01 dB
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"FETCH:ORFSPECTRUM:SWITCHING:FREQUENCY:OFFSET:MAXIMUM? 200 KHZ,400 KHZ"
! Returns the ORFS due to switching (maximum) measurement results at the 200 kHz
! and 400 kHz offsets only, assuming these offsets are turned on.

FETCh:ORFSpectrum:SWITChing:FREQuency[:OFFSet]:AVERage?

Function

 GSM TA

Queries the ORFS due to switching measurement, allowing frequency offset values to be appended to the command. Returns ORFS due to switching (average) measurements at the frequencies listed, in the order they are listed.

Frequencies must have a one-to-one correspondence to ORFS due to switching frequency offsets that are currently turned on. Frequencies must be separated by commas. (See SETup:ORFSpectrum:SWITching:FREQuency[:OFFSet] for the command that turns on frequency offsets.)

Each value is (optionally) followed by: HZ|KHZ|MHZ|GHZ. The default unit is HZ (hertz).

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Range: -100 dB to +100 dB and 9.91 E+37 (NAN)

Resolution: 0.01 dB
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"FETCH:ORFSPECTRUM:SWITCHING:FREQUENCY:OFFSET:AVERAGE? 200 KHZ,400 KHZ"
! Returns the ORFS due to switching (average) measurement results at the 200 kHz
! and 400 kHz offsets only, assuming these offsets are turned on.

FETCh:ORFSpectrum:SWITChing:FREQuency[:OFFSet]:SDEViation?

Function

 GSM TA

Queries the ORFS due to switching measurement, allowing frequency offset values to be appended to the command. Returns ORFS due to switching (standard deviation) measurements at the frequencies listed, in the order they are listed.

Frequencies must have a one-to-one correspondence to ORFS due to switching frequency offsets that are currently turned on. Frequencies must be separated by commas. (See SETup:ORFSpectrum:SWITching:FREQuency[:OFFSet] for the command that turns on frequency offsets.)

Each value is (optionally) followed by: HZ|KHZ|MHZ|GHZ. The default unit is HZ (hertz).

GPRS TA
EGPRS TA
GSM/GPRS LA

EGPRS LA

Query

Range: 0 dB to +150 dB and 9.91 E+37 (NAN)

Resolution: 0.001 dB
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"FETCH:ORFSPECTRUM:SWITCHING:FREQUENCY:OFFSET:STDEVIATION? 200 KHZ,400 KHZ"
! Returns the ORFS due to switching (standard deviation) measurement results at
! the 200 kHz and 400 kHz offsets only, assuming these offsets are turned on.

FETCh:ORFSpectrum:SWITching:LIMit?

Function | GSM TA | Queries the ORFS switching offset results for an overall pass/fail result.
 | GPRS TA
 | EGPRS TA
 | GSM/GPRS LA
 | EGPRS LA
Query |  | Range: 0 (pass), 1 (fail), and 9.91 E+37 (NAN)
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.01 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.01 and above

FETCh:ORFSpectrum:SWITching:LIMit:ALL?

Function

 GSM TA Queries the results for all enabled ORFS due to switching offsets.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

For each switching enabled result the following is returned in a comma-separated:

  • 0 (pass), 1 (fail), and 9.91 E+37 (NAN)
  • limit used
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above


FETCh:PCALibration

FETCh:PCALibration

GPIB Command Conventions

  • FETCh:PCALibration[:ALL]?
  • FETCh:PCALibration:FERRor?
  • FETCh:PCALibration:INTegrity?
  • FETCh:PCALibration:PHASe?
  • FETCh:PCALibration:POWer?
  • FETCh:PCALibration:REFerence:POWer?
  • FETCh:PCALibration:SAMPle:AMPLitude? <range>
  • FETCh:PCALibration:SAMPle:AMPLitude:BINary?
  • FETCh:PCALibration:SAMPle:AMPLitude:DBM? <range>
  • FETCh:PCALibration:SAMPle:AMPLitude:DBM:BINary?
  • FETCh:PCALibration:SAMPle:AMPLitude:MAXimum?
  • FETCh:PCALibration:SAMPle:AMPLitude:MAXimum:DBM?
  • FETCh:PCALibration:SAMPle:AMPLitude:MINimum?
  • FETCh:PCALibration:SAMPle:AMPLitude:MINimum:DBM?
  • FETCh:PCALibration:SAMPle[:ALL]:BINary?
  • FETCh:PCALibration:SAMPle:COUNt?
  • FETCh:PCALibration:SAMPle[:ALL]:DBM:BINary?
  • FETCh:PCALibration:SAMPle:PHASe? <range>
  • FETCh:PCALibration:SAMPle:PHASe:BINary?

FETCh:PCALibration[:ALL]?

Function

 GSM TA

This query is only applicable when the Waveform Type is set to DISCrete , and the Result Type is set to PCAL .

See Phase and Amplitude Measurement Results for a Discrete Waveform for more information.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Requirements

GSM/GPRS/
EGPRS TA

Revision: A.06 and above with the required feature license

GSM/GPRS/
EGPRS LA

Revision: D.03.32 and above

Programming Example

OUTPUT 714;"FETCh:PCALibration?"
! If the Waveform Type is DISCrete and the Result Type is PCAL: This query returns
! Integrity Indicator, Power, Phase Error and Frequency Error.

FETCh:PCALibration:FERRor?

Function

 GSM TA

This query is only applicable when the Waveform Type measured was a DISCrete waveform and the result type setting is PCAL or BOTH . The command to set the waveform type is SETup:PCALibration:WAVeform:TYPE , and the command to set the result type is SETup:PCALibration:RESult:TYPE .

This command queries the Frequency measurement result array. This array is identical to the Frequency array returned by the command FETCh:PCALibration[:ALL]? . The first value returned in the frequency array is the frequency (Hz) offset relative to the expected input frequency and all subsequent values in the array are frequency values relative to the first value returned (from the first measurement interval).

You can set/query the number of results that are returned in this array using the command SETup:PCALibration:MEASurement:COUNt .

For more information, see Phase and Amplitude Measurement Results for a Discrete Waveform .

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Requirements

GSM/GPRS/
EGPRS TA

Revision: A.06 and above with the required feature license

GSM/GPRS/
EGPRS LA

Revision: D.03.32 and above

Programming Example

OUTPUT 714;"FETCh:PCALibration:FREQuency?"
! Queries the Frequency measurement result array for the Discrete waveform.

FETCh:PCALibration:INTegrity?

Function

 GSM TA

This command queries the Integrity Indicator for the Phase and Amplitude versus Time measurement.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Requirements

GSM/GPRS/
EGPRS TA

Revision: A.06 and above with the required feature license

Programming Example

OUTPUT 714;"FETCh:PCALibration:INTegrity?"
! Queries the Integrity Indicator value for the Phase and Amplitude versus Time measurement.

FETCh:PCALibration:PHASe?

Function

 GSM TA

This command queries the Phase measurement result array. This array is identical to the Phase array returned by the command FETCh:PCALibration[:ALL]? . The initial phase value in the phase array is 0° and all subsequent phase measurements are the phase relative to 0°. The unit of measurement for the phase results is degrees.

This query is only applicable when the Waveform Type measured was a DISCrete waveform and the result type setting is PCAL . The command to set the waveform type is SETup:PCALibration:WAVeform:TYPE , and the command to set the result type is SETup:PCALibration:RESult:TYPE

You can set/query the number of results that are returned in this array using the command SETup:PCALibration:MEASurement:COUNt .

For more information, see Phase and Amplitude Measurement Results for a Discrete Waveform .

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Requirements

GSM/GPRS/
EGPRS TA

Revision: A.06 and above with the required feature license

GSM/GPRS/
EGPRS LA

Revision: D.03.32 and above

Programming Example

OUTPUT 714;"FETCh:PCALibration:PHASe?"
! Queries the Phase measurement result array for the Discrete waveform.

FETCh:PCALibration:POWer?

Function

 GSM TA

This query is only applicable when the Waveform Type measured was a DISCrete waveform and the result type setting is PCAL . The command to set the waveform type is SETup:PCALibration:WAVeform:TYPE , and the command to set the result type is SETup:PCALibration:RESult:TYPE .

This command queries the Power measurement result array. This array is identical to the Power array returned by the command FETCh:PCALibration[:ALL]? . The first value returned in the power array is the absolute power measurement (in dBm), and all subsequent results in the array are relative power measurements (in dB) to the initial absolute power value.

You can set/query the number of results that are returned in this array using the command SETup:PCALibration:MEASurement:COUNt .

For more information, see Phase and Amplitude Measurement Results for a Discrete Waveform .

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Requirements

GSM/GPRS/
EGPRS TA

Revision: A.06 and above with the required feature license

GSM/GPRS/
EGPRS LA

Revision: D.03.32 and above

Programming Example

OUTPUT 714;"FETCh:PCALibration:Power?"
! Queries the Power measurement results for the Discrete waveform.

FETCh:PCALibration:REFerence:POWer?

Function

 GSM TA

This command is only applicable when the Waveform Type parameter is set to CONTinuous or CONT2.

This command queries the average power measurement (dBm) of the initial reference burst.

The command to set the waveform type parameter is SETup:PCALibration:WAVeform:TYPE .

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Requirements

GSM/GPRS/
EGPRS TA

Revision: A.06 and above with the required feature license

GSM/GPRS/
EGPRS LA

Revision: D.03.32 and above

Programming Example

OUTPUT 714;"FETCh:PCALibration:REFerence:Power?"
! Queries the Power results for the refernce burst on which the measurement is triggered.

FETCh:PCALibration:SAMPle:AMPLitude? <range>

Function

 GSM TA

This command queries the Amplitude (normalized*) results in blocks of 1000. The amplitude results are normalized voltages.

If you wish to have the results returned in dBm, use the command FETCh:PCALibration:SAMPle:AMPLitude:DBM? <range> .

The total number of amplitude measurement results can be determined by using the FETCh:PCALibration:SAMPle:COUNt? query.

If the Waveform Type is DIScrete , the result type must be SAMPle or BOTH to obtain these results. The command to set the waveform type parameter is SETup:PCALibration:WAVeform:TYPE .

The range of <range> is 1 to N, where N is the Sample Count/1000 rounded up to the nearest integer. For example, if the Sample Count is 15,366 samples, then N is 16.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Requirements

GSM/GPRS/
EGPRS TA

Revision: A.06 and above with the required feature license

GSM/GPRS/
EGPRS LA

Revision: D.03.32 and above

Programming Example

OUTPUT 714;"FETCh:PCALibration:SAMPle:AMPLitude? 2"
! Queries the Power measurement results for samples 1001 through 2000.

FETCh:PCALibration:SAMPle:AMPLitude:BINary?

Function

 GSM TA

This query returns amplitude (sqrt(mW)) results as an IEEE 488 definite length arbitrary block. Each amplitude result in the payload of the arbitrary block is a 32 bit floating point (IEEE 754 format) number expressing the sample amplitude in Volts.

The number of amplitude results in the block can be determined by querying FETCh:PCALibration:SAMPle:COUNt? .

This command is only applicable when the Waveform Type is set to CONTinuous or if the waveform type is set to DISCrete and the result type is SAMPle or BOTH . The command to set the waveform type parameter is SETup:PCALibration:WAVeform:TYPE .

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Requirements

GSM/GPRS/
EGPRS TA

Revision: A.06 and above with the required feature license

GSM/GPRS/
EGPRS LA

Revision: D.03.32 and above

Programming Example

OUTPUT 714;"FETCh:PCALibration:SAMPle:AMPLitude:BINary?"
! Queries the all Power measurement results (in Volts) and returns them in binary format.

FETCh:PCALibration:SAMPle:AMPLitude:DBM? <range>

Function

 GSM TA

This command queries the amplitude (in dBm) results in blocks of 1000. The amplitude results are normalized voltages.

The total number of amplitude measurement results can be determined by using the FETCh:PCALibration:SAMPle:COUNt? query.

If the Waveform Type is DIScrete , the result type must be SAMPle or BOTH to obtain these results. The command to set the waveform type parameter is SETup:PCALibration:WAVeform:TYPE .

The range of <range> is 1 to N, where N is (0.5 plus Sample Count)/1000 rounded up to the nearest integer. For example, if the Sample Count is 15,366 samples, then N is 16.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Requirements

GSM/GPRS/
EGPRS TA

Revision: A.06 and above with the required feature license

GSM/GPRS/
EGPRS LA

Revision: D.03.32 and above

Programming Example

OUTPUT 714;"FETCh:PCALibration:SAMPle:AMPLitude:dBm? 2"
! Queries the Power measurement results(in dBm) for samples 1001 through 2000.

FETCh:PCALibration:SAMPle:AMPLitude:DBM:BINary?

Function

 GSM TA

This query returns amplitude (dBm) results as an IEEE 488 definite length arbitrary block. Each amplitude result in the payload of the arbitrary block is a 32 bit floating point (IEEE 754 format) number expressing the sample amplitude in dBm.

The number of amplitude results in the block can be determined by querying FETCh:PCALibration:SAMPle:COUNt? .

If the Waveform Type is DIScrete , the result type must be SAMPle or BOTH to obtain these results. The command to set the waveform type parameter is SETup:PCALibration:WAVeform:TYPE .

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Requirements

GSM/GPRS/
EGPRS TA

Revision: A.06 and above with the required feature license

GSM/GPRS/
EGPRS LA

Revision: D.03.32 and above

Programming Example

OUTPUT 714;"FETCh:PCALibration:SAMPle:AMPLitude:DBM:BINary?"
! Queries the all Power measurement results (in dBm) and returns them in binary format.

FETCh:PCALibration:SAMPle:AMPLitude:MAXimum?

Function

 GSM TA

This query returns the Amplitude (normalized*) of the sample with the largest amplitude.

If the Waveform Type is DIScrete , the result type must be SAMPle or BOTH to obtain these results. The command to set the waveform type parameter is SETup:PCALibration:WAVeform:TYPE .

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Requirements

GSM/GPRS/
EGPRS TA

Revision: A.06 and above with the required feature license

GSM/GPRS/
EGPRS LA

Revision: D.03.32 and above

Programming Example

OUTPUT 714;"FETCh:PCALibration:SAMPle:AMPLitude:MAXimum?"
! Queries the sample with the largest amplitude (units are sqrt(mW)).

FETCh:PCALibration:SAMPle:AMPLitude:MAXimum:DBM?

Function

 GSM TA

This query returns the amplitude (in dBm) of the sample with the largest amplitude.

If the Waveform Type is DIScrete , the result type must be SAMPle or BOTH to obtain these results. The command to set the waveform type parameter is SETup:PCALibration:WAVeform:TYPE .

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Requirements

GSM/GPRS/
EGPRS TA

Revision: A.06 and above with the required feature license

GSM/GPRS/
EGPRS LA

Revision: D.03.32 and above

Programming Example

OUTPUT 714;"FETCh:PCALibration:SAMPle:AMPLitude:MAXimum:DBM?"
! Queries the sample with the largest amplitude (returns result in dBm).

FETCh:PCALibration:SAMPle:AMPLitude:MINimum?

Function

 GSM TA

This query returns the Amplitude (normalized*) of the sample with the smallest amplitude.

If the Waveform Type DIScrete , the result type must be SAMPle or BOTH to obtain these results. The command to set the waveform type parameter is SETup:PCALibration:WAVeform:TYPE .

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Requirements

GSM/GPRS/
EGPRS TA

Revision: A.06 and above with the required feature license

GSM/GPRS/
EGPRS LA

Revision: D.03.32 and above

Programming Example

OUTPUT 714;"FETCh:PCALibration:SAMPle:AMPLitude:MINimum?"
! Queries the sample with the smallest amplitude (units are sqrt(mW)).

FETCh:PCALibration:SAMPle:AMPLitude:MINimum:DBM?

Function

 GSM TA

This query returns the amplitude (in dBm) of the sample with the smallest amplitude.

If the Waveform Type DIScrete , the result type must be SAMPle or BOTH to obtain these results. The command to set the waveform type parameter is SETup:PCALibration:WAVeform:TYPE .

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Requirements

GSM/GPRS/
EGPRS TA

Revision: A.06 and above with the required feature license

GSM/GPRS/
EGPRS LA

Revision: D.03.32 and above

Programming Example

OUTPUT 714;"FETCh:PCALibration:SAMPle:AMPLitude:MINimum:DBM?"
! Queries the sample with the smallest amplitude (returns the result in dBm).

FETCh:PCALibration:SAMPle[:ALL]:BINary?

Function

 GSM TA

This query returns sample amplitude (sqrt(mW)) and phase (Degrees) results as an IEEE 488 definite length arbitrary block. The payload of the arbitrary block contains amplitude/phase pairs, each pair comprising an amplitude result (Volts) followed by a phase result (Hz). Each result is a 32 bit floating point number (IEEE 754 format).

The number of amplitude/phase pairs in the block can be determined by using the query FETCh:PCALibration:SAMPle:COUNt? .

If the Waveform Type is DIScrete , the result type must be SAMPle or BOTH to obtain these results. The command to set the waveform type parameter is SETup:PCALibration:WAVeform:TYPE .

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Requirements

GSM/GPRS/
EGPRS TA

Revision: A.06 and above with the required feature license

GSM/GPRS/
EGPRS LA

Revision: D.03.32 and above

Programming Example

OUTPUT 714;"FETCh:PCALibration:SAMPle[:ALL]:BINary"
! Queries all the Power (Volts) and Phase measurement results and returns them in binary format.

FETCh:PCALibration:SAMPle:COUNt?

Function

 GSM TA

This command queries the number of results available.

If the Waveform Type parameter is set to DISCrete, this command is only applicable when the Result type parameter is set to SAMPle. The command to set the waveform type parameter is SETup:PCALibration:WAVeform:TYPE .

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Requirements

GSM/GPRS/
EGPRS TA

Revision: A.06 and above with the required feature license

GSM/GPRS/
EGPRS LA

Revision: D.03.32 and above

Programming Example

OUTPUT 714;"FETCh:PCALibration:SAMPle:COUNt?"
! Queries the number of samples the measurement tested.

FETCh:PCALibration:SAMPle[:ALL]:DBM:BINary?

Function

 GSM TA

This query returns amplitude (dBm) and phase (Degrees) results as an IEEE 488 definite length arbitrary block. The payload of the arbitrary block contains amplitude/phase pairs, each pair comprising an amplitude result (dBm) followed by a phase result (Hz). Each result is a 32 bit floating point number (IEEE 754 format). The number of amplitude/phase pairs in the block can be determined by querying FETCh:PCALibration:SAMPle:COUNt? .

If the Waveform Type is DIScrete , the result type must be SAMPle or BOTH to obtain these results. The command to set the waveform type parameter is SETup:PCALibration:WAVeform:TYPE .

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Requirements

GSM/GPRS/
EGPRS TA

Revision: A.06 and above with the required feature license

GSM/GPRS/
EGPRS LA

Revision: D.03.32 and above

Programming Example

OUTPUT 714;"FETCh:PCALibration:SAMPle[:ALL]:DBM:BINary?"
! Queries the all the Power measurement and Phase results (dBm) and returns the results
! in binary format.

FETCh:PCALibration:SAMPle:PHASe? <range>

Function

 GSM TA

This command queries the phase measurement results (Degrees) in blocks of 1000. The total number of phase measurement results can be determined by using the FETCh:PCALibration:SAMPle:COUNt? query.

If the Waveform Type is DIScrete , the result type must be SAMPle or BOTH to obtain these results. The command to set the waveform type parameter is SETup:PCALibration:WAVeform:TYPE and the command to set the result type parameter is SETup:PCALibration:RESult:TYPE .

The range of <range> is 1 to N, where N is the Sample Count/1000 rounded up to the nearest integer. For example, if the Sample Count is 15,366 samples, then N is 16.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Requirements

GSM/GPRS/
EGPRS TA

Revision: A.06 and above with the required feature license

GSM/GPRS/
EGPRS LA

Revision: D.03.32 and above

Programming Example

OUTPUT 714;"FETCh:PCALibration:SAMPle:PHASe? 8"
! Queries the Phase measurement results for samples 8001 through 9000.

FETCh:PCALibration:SAMPle:PHASe:BINary?

Function

 GSM TA

This query returns phase (Degrees) results as an IEEE 488 definite length arbitrary block. Each phase result in the payload of the arbitrary block is a 32 bit floating point (IEEE 754 format) number expressing the sample phase in Degrees.

The number of phase results in the block can be determined by querying FETCh:PCALibration:SAMPle:COUNt? query.

If the Waveform Type is DIScrete , the result type must be SAMPle or BOTH to obtain these results. The command to set the waveform type parameter is SETup:PCALibration:WAVeform:TYPE and the command to set the result type parameter is SETup:PCALibration:RESult:TYPE .

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Requirements

GSM/GPRS/
EGPRS TA

Revision: A.06 and above with the required feature license

GSM/GPRS/
EGPRS LA

Revision: D.03.32 and above

Programming Example

OUTPUT 714;"FETCh:PCALibration:SAMPle:PHASe:BINary?"
! Queries all the sampled Phase measurement results and returns them in binary format.


FETCh:PFERror

FETCh:PFERror

GPIB Command Conventions

  • FETCh:PFERor[:ALL]?
  • FETCh:PFERor:FAIL?
  • FETCh:PFERror:COUNt:TESTed?
  • FETCh:PFERror:FERRor:ALL?
  • FETCh:PFERror:FERRor:AVERage?
  • FETCh:PFERror:FERRor:FAIL?
  • FETCh:PFERror:FERRor: MAXimum?
  • FETCh:PFERror:FERRor:MINimum?
  • FETCh:PFERror:FERRor[:WORSt]?
  • FETCh:PFERror:ICOunt?
  • FETCh:PFERror:INTegrity?
  • FETCh:PFERror:PEAK:ALL?
  • FETCh:PFERror:PEAK:AVERage?
  • FETCh:PFERror:PEAK:FAIL?
  • FETCh:PFERror:PEAK[:MAXimum]?
  • FETCh:PFERror:PEAK:MINimum?
  • FETCh:PFERror:RMS:ALL?
  • FETCh:PFERror:RMS:AVERage?
  • FETCh:PFERror:RMS:FAIL?
  • FETCh:PFERror:RMS[:MAXimum]?
  • FETCh:PFERror:RMS:MINimum?

FETCh:PFERor[:ALL]?

Function

 GSM TA

Queries integrity indicator, maximum RMS phase error, maximum peak phase error and worst frequency error.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Integrity indicator

  • Range: See Integrity Indicator .
  • Resolution: 1

Maximum RMS Phase Error

  • Range: 0 degrees to 180 degrees and 9.91 E+37 (NAN)
  • Resolution: 0.01 degrees

Maximum Peak Phase Error

  • Range: 0 degrees to 180 degrees and 9.91 E+37 (NAN)
  • Resolution: 0.01 degrees

Worst Frequency Error

  • Range: -750 kHz to +750 kHz and 9.91 E+37 (NAN)
  • Resolution: 0.1 kHz
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"FETCH:PFERROR:ALL?"
! Returns integrity, maximum RMS phase error, maximum peak phase error and
! worst frequency error.

FETCh:PFERor:FAIL?

Function

 GSM TA

Queries integrity indicator, RMS phase error pass/fail indicator, peak phase error pass/fail indicator, frequency error pass/fail indicator and the number of measurements taken.

The number of measurements taken may be of interest to you if you are using the confidence level feature. For more information on using confidence levels refer to Confidence Levels .

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Integrity indicator

  • Range: See Integrity Indicator .
  • Resolution: 1

RMS Phase Error pass/fail indicator

  • Range: 0|1

Peak Phase Error pass/fail indicator

  • Range: 0|1

Frequency Error pass/fail indicator

  • Range: 0|1

Number of measurements taken

  • Range: 0 to 999 and 9.91 E+37 (NAN)
  • Resolution: 1
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"FETCH:PFERROR:FAIL?"
! Returns integrity, RMS phase error pass/fail result, peak phase error pass/fail
! result, frequency error pass/fail result and the number of measurements made.

FETCh:PFERror:COUNt:TESTed?

Function | GSM TA | Queries the number of measurements taken. If you are not using the confidence level feature then the value returned, after a successful measurement completes, is the same as that returned by the query of SETup:PFERror:COUNt:NUMBer . However if you are using the confidence level feature then this value may be lower than that set for multi-measurements.
 | GPRS TA
 | EGPRS TA
 | GSM/GPRS LA
 | EGPRS LA
Query |  | Range: 0 to 999 and 9.91 E+37 (NAN) Resolution: 1
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.01 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.01 and above

FETCh:PFERror:FERRor:ALL?

Function

 GSM TA

Queries minimum, maximum, average, and worst frequency error, in Hz.

The minimum frequency error is the value closest to negative infinity from the last multi-measurement cycle. The maximum frequency error is the value closest to positive infinity from the last multi-measurement cycle.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Minimum Frequency Error

  • Range: -750 kHz to +750 kHz and 9.91 E+37 (NAN)
  • Resolution: 0.1 kHz

Maximum Frequency Error

  • Range: -750 kHz to +750 kHz and 9.91 E+37 (NAN)
  • Resolution: 0.1 kHz

Average Frequency Error

  • Range: -750 kHz to +750 kHz and 9.91 E+37 (NAN)
  • Resolution: 0.1 kHz

Worst Frequency Error

  • Range: -750 kHz to +750 kHz and 9.91 E+37 (NAN)
  • Resolution: 0.1 kHz
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"FETCH:PFERROR:FERROR:ALL?"
! Returns minimum, maximum, average and worst frequency error results.

FETCh:PFERror:FERRor:AVERage?

Function | GSM TA | Queries the single or average (from a multi-measurement) frequency error measurement result, in Hz.
 | GPRS TA
 | EGPRS TA
 | GSM/GPRS LA
 | EGPRS LA
Query |  | Range: -750 kHz to +750 kHz and 9.91 E+37 (NAN) Resolution: 0.1 kHz
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.01 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.01 and above

FETCh:PFERror:FERRor:FAIL?

Function

 GSM TA

Queries whether the frequency error passed or failed the value set using either of the following commands:

  • SETup:PFERror:FERRor[:LIMit]:GSM , or

  • SETup:PFERror:FERRor[:LIMit][:SELected]

GSM/GPRS LA

GPRS TA

 This command is not applicable to GPRS.

EGPRS LA

This command is not applicable to EGPRS.

Query

Range: 0 (pass), 1 (fail), and 9.91 E+37 (NAN)
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

FETCh:PFERror:FERRor: MAXimum?

Function | GSM TA | Queries the maximum (from a multi-measurement) frequency error measurement result, in Hz.
 | GPRS TA
 | EGPRS TA
 | GSM/GPRS LA
 | EGPRS LA
Query |  | Range: -750 kHz to +750 kHz and 9.91 E+37 (NAN) Resolution: 0.1 kHz
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.01 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.01 and above

FETCh:PFERror:FERRor:MINimum?

Function | GSM TA | Queries the minimum (from a multi-measurement) frequency error measurement result, in Hz.
 | GPRS TA
 | EGPRS TA
 | GSM/GPRS LA
 | EGPRS LA
Query |  | Range: -750 kHz to +750 kHz and 9.91 E+37 (NAN) Resolution: 0.1 kHz
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.01 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.01 and above

FETCh:PFERror:FERRor[:WORSt]?

Function | GSM TA | Queries the frequency error from the individual multi-measurements that is furthest from 0 Hz. If the most positive and the most negative frequency errors are the same, the positive value will be returned.
 | GPRS TA
 | EGPRS TA
 | GSM/GPRS LA
 | EGPRS LA
Query |  | Range: -750 kHz to +750 kHz and 9.91 E+37 (NAN) Resolution: 0.1 kHz
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.01 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.01 and above

FETCh:PFERror:ICOunt?

Function | GSM TA | Queries the intermediate count of phase and frequency multi-measurements completed. This number will increase to the value returned by SETup:PFERror:COUNt:NUMBer .
 | GPRS TA
 | EGPRS TA
 | GSM/GPRS LA
 | EGPRS LA
Query |  | Range: 0 to 999 Resolution: 1
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.01 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.01 and above

FETCh:PFERror:INTegrity?

Function | GSM TA | Queries the integrity indicator for the phase and frequency error measurement. Zero indicates a normal result. See Integrity Indicator for descriptions of non-zero integrity indicators.
 | GPRS TA
 | EGPRS TA
 | GSM/GPRS LA
 | EGPRS LA
Query |  | Range: See Integrity Indicator . Resolution: 1
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.01 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.01 and above

FETCh:PFERror:PEAK:ALL?

Function

 GSM TA

Queries the minimum, maximum, and average peak phase error measurement result, in degrees.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Minimum Peak Phase Error

  • Range: 0 degrees to 180 degrees and 9.91 E+37 (NAN)
  • Resolution: 0.01 degrees

Maximum Peak Phase Error

  • Range: 0 degrees to 180 degrees and 9.91 E+37 (NAN)
  • Resolution: 0.01 degrees

Average Peak Phase Error

  • Range: 0 degrees to 180 degrees and 9.91 E+37 (NAN)
  • Resolution: 0.01 degrees
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"FETCH:PFERROR:PEAK:ALL?"
! Returns minimum, maximum, and average peak phase error results.

FETCh:PFERror:PEAK:AVERage?

Function | GSM TA | Queries the single or average (from a multi-measurement) peak phase error measurement result, in degrees.
 | GPRS TA
 | EGPRS TA
 | GSM/GPRS LA
 | EGPRS LA
Query |  | Range: 0 degrees to 180 degrees and 9.91 E+37 (NAN) Resolution: 0.01 degrees
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.01 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.01 and above

FETCh:PFERror:PEAK:FAIL?

Function

 GSM TA

Queries whether the peak phase error passed or failed the value set using either of the following commands:

  • SETup:PFERror:PEAK[:LIMit]:GSM , or
  • SETup:PFERror:PEAK[:LIMit][:SELected]

GSM/GPRS LA

EGPRS TA

GPRS TA

This command is not applicable to GPRS.

EGPRS LA

This command is not applicable to EGPRS.

Query

Range: 0 (pass), 1 (fail), and 9.91 E+37 (NAN)
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

FETCh:PFERror:PEAK[:MAXimum]?

Function | GSM TA | Queries the maximum (from a multi-measurement) peak phase error result, in degrees.
 | GPRS TA
 | EGPRS TA
 | GSM/GPRS LA
 | EGPRS LA
Query |  | Range: 0 degrees to 180 degrees and 9.91 E+37 (NAN) Resolution: 0.01 degrees
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.01 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.01 and above

FETCh:PFERror:PEAK:MINimum?

Function | GSM TA | Queries the minimum (from a multi-measurement) peak phase error measurement result, in degrees.
 | GPRS TA
 | EGPRS TA
 | GSM/GPRS LA
 | EGPRS LA
Query |  | Range: 0 degrees to 180 degrees and 9.91 E+37 (NAN) Resolution: 0.01 degrees
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.01 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.01 and above

FETCh:PFERror:RMS:ALL?

Function

 GSM TA

Queries the minimum, maximum, and average RMS phase error measurement result, in degrees.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Minimum RMS Phase Error

  • Range: 0 degrees to 180 degrees and 9.91 E+37 (NAN)
  • Resolution: 0.01 degrees

Maximum RMS Phase Error

  • Range: 0 degrees to 180 degrees and 9.91 E+37 (NAN)
  • Resolution: 0.01 degrees

Average RMS Phase Error

  • Range: 0 degrees to 180 degrees and 9.91 E+37 (NAN)
  • Resolution: 0.01 degrees
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"FETCH:PFERROR:RMS:ALL?"
! Returns minimum, maximum, and average RMS phase error.

FETCh:PFERror:RMS:AVERage?

Function | GSM TA | Queries the single or average (from a multi-measurement) RMS phase error measurement result, in degrees.
 | GPRS TA
 | EGPRS TA
 | GSM/GPRS LA
 | EGPRS LA
Query |  | Range: 0 degrees to 180 degrees and 9.91 E+37 (NAN) Resolution: 0.01 degrees
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.01 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.01 and above

FETCh:PFERror:RMS:FAIL?

Function

 GSM TA

Queries whether the RMS phase error passed or failed the value set using either of the following commands:

  • SETup:PFERror:RMS[:LIMit]:GSM , or

  • SETup:PFERror:RMS[:LIMit][:SELected]

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Range: 0 (pass), 1 (fail), and 9.91 E+37 (NAN)
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

FETCh:PFERror:RMS[:MAXimum]?

Function

 GSM TA

Queries the Maximum (from a multi-measurement) RMS phase error measurement result, in degrees.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Range: 0 degrees to 180 degrees and 9.91 E+37 (NAN)

Resolution: 0.01 degrees
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"FETCH:PFERROR:RMS:MAXIMUM?"
! Returns the maximum RMS phase error.

FETCh:PFERror:RMS:MINimum?

Function | GSM TA | Queries the minimum (from a multi-measurement) RMS phase error measurement result, in degrees.
 | GPRS TA
 | EGPRS TA
 | GSM/GPRS LA
 | EGPRS LA
Query |  | Range: 0 degrees to 180 degrees and 9.91 E+37 (NAN) Resolution: 0.01 degrees
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.01 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.01 and above


FETCh:PVTime

FETCh:PVTime

GPIB Command Conventions

  • FETCh:PVTime[:BURSt[1]][:ALL]?
  • FETCh:PVTime:BURSt2|3|4|5|6[:ALL]?
  • FETCh:PVTime[:BURSt[1]]:INTegrity?
  • FETCh:PVTime:BURSt2|3|4|5|6:INTegrity?
  • FETCh:PVTime[:BURSt[1]]:MASK[:FAIL]?
  • FETCh:PVTime:BURSt2|3|4|5|6:MASK[:FAIL]?
  • FETCh:PVTime[:BURSt[1]]:MASK:ALL?
  • FETCh:PVTime:BURSt2|3|4|5|6:MASK:ALL?
  • FETCh:PVTime[:BURSt[1]]:MASK:LOWer[:MARGin]?
  • FETCh:PVTime:BURSt2|3|4|5|6:MASK:LOWer[:MARGin]?
  • FETCh:PVTime[:BURSt[1]]:MASK:LOWer:TIME?
  • FETCh:PVTime:BURSt2|3|4|5|6:MASK:LOWer:TIME?
  • FETCh:PVTime[:BURSt[1]]:MASK:UPPer[:MARGin]?
  • FETCh:PVTime:BURSt2|3|4|5|6:MASK:UPPer[:MARGin]?
  • FETCh:PVTime[:BURSt[1]]:MASK:UPPer:TIME?
  • FETCh:PVTime:BURSt2|3|4|5|6:MASK:UPPer:TIME?
  • FETCh:PVTime[:BURSt[1]]:POWer[:ALL]:AVERage?
  • FETCh:PVTime:BURSt2|3|4|5|6:POWer[:ALL]:AVERage?
  • FETCh:PVTime[:BURSt[1]]:POWer[:ALL][:MAXimum]?
  • FETCh:PVTime:BURSt2|3|4|5|6:POWer[:ALL][:MAXimum]?
  • FETCh:PVTime[:BURSt[1]]:POWer[:ALL]:MINimum?
  • FETCh:PVTime:BURSt2|3|4|5|6:POWer[:ALL]:MINimum?
  • FETCh:PVTime[:BURSt[1]]:POWer[:ALL]:SDEViation?
  • FETCh:PVTime:BURSt2|3|4|5|6:POWer[:ALL]:SDEViation?
  • FETCh:PVTime[:BURSt[1]]:POWer:TIME[:OFFSet][:MAXimum]?
  • FETCh:PVTime:BURSt2|3|4|5|6:POWer:TIME[:OFFSet][:MAXimum]?
  • FETCh:PVTime[:BURSt[1]]:POWer:TIME[:OFFSet]:AVERage?
  • FETCh:PVTime:BURSt2|3|4|5|6:POWer:TIME[:OFFSet]:AVERage?
  • FETCh:PVTime[:BURSt[1]]:POWer:TIME[OFFSet]:MINimum?
  • FETCh:PVTime:BURSt2|3|4|5|6:POWer:TIME[OFFSet]:MINimum?
  • FETCh:PVTime[:BURSt[1]]:POWer:TIME[:OFFSet]:SDEViation?
  • FETCh:PVTime:BURSt2|3|4|5|6:POWer:TIME[:OFFSet]:SDEViation?
  • FETCh:PVTime[:BURSt[1]]:TRACe?
  • FETCh:PVTime:BURSt2|3|4|5|6:TRACe?
  • FETCh:PVTime[:BURSt[1]]:TXPower[:CARRier][:AVERage]?
  • FETCh:PVTime:BURSt2|3|4|5|6:TXPower[:CARRier][:AVERage]?
  • FETCh:PVTime[:BURSt[1]]:TXPower[:CARRier]:ALL?
  • FETCh:PVTime:BURSt2|3|4|5|6:TXPower[:CARRier]:ALL?
  • FETCh:PVTime[:BURSt[1]]:TXPower[:CARRier]:MAXimum?
  • FETCh:PVTime:BURSt2|3|4|5|6:TXPower[:CARRier]:MAXimum?
  • FETCh:PVTime[:BURSt[1]]:TXPower[:CARRier]:MINimum?
  • FETCh:PVTime:BURSt2|3|4|5|6:TXPower[:CARRier]:MINimum?
  • FETCh:PVTime[:BURSt[1]]:TXPower[:CARRier]:SDEViation?
  • FETCh:PVTime:BURSt2|3|4|5|6:TXPower[:CARRier]:SDEViation?
  • FETCh:PVTime:ICOunt?
  • FETCh:PVTime:MASK[:FAIL]?
  • FETCh:PVTime:MASK[:FAIL]:SECTion?
  • FETCh:PVTime:MASK[:FAIL]:SEGment?
  • FETCh:PVTime:SECTion[:ALL]?
  • FETCh:PVTime:SECTion:AVERage?
  • FETCh:PVTime:SECTion:MAXimum?
  • FETCh:PVTime:SECTion:MINimum?

FETCh:PVTime[:BURSt[1]][:ALL]?

FETCh:PVTime:BURSt2|3|4|5|6[:ALL]?

Function

 GSM

Queries integrity indicator, mask pass/fail indicator, power versus time (PvT) transmit power (average), and PvT power (maximum) at up to 12 time offsets for the burst of the multislot configuration that you specify.

The number of PvT measurement offsets that will be returned can be queried using the SETup:PVTime[:BURSt[1]]:TIME:POINts[:SELected]? . The time offsets are set up using the command SETup:PVTime[:BURSt[1]]:TIME[:OFFSet][:SELected] .

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Integrity indicator

  • Range: See Integrity Indicator .
  • Resolution: 1

Power versus time mask pass/fail

  • Range: 0 (pass) or 1 (fail) and 9.91 E+37 (NAN)

Power versus time TX carrier power

  • Range: -100 dBm to 100 dBm and 9.91 E+37 (NAN)
  • Resolution: 0.01 dB

Power versus time power (maximum) - up to 12 individual results depending on the number of time offsets

  • Range: -100 dBc to 100 dBc and 9.91 E+37 (NAN)
  • Resolution: 0.01 dB
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above

Revision: A.08 adds Burst 3 and 4

Revision: A.09 adds Burst 5

GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Revision: E.02 adds Burst 3 and 4

Revision: F.01 adds Burst 5

Revision: G.00.00 adds Burst 6

FETCh:PVTime[:BURSt[1]]:INTegrity?

FETCh:PVTime:BURSt2|3|4|5|6:INTegrity?

Function | GSM TA | Queries the integrity indicator for the power versus time measurement. This query returns the integrity indicator for the burst that you specify. Zero indicates a normal result. See Integrity Indicator for descriptions of non-zero integrity indicators.
 | GPRS TA
 | EGPRS TA
 | GSM/GPRS LA
 | EGPRS LA
Query |  | Range: See Integrity Indicator . Resolution: 1
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.01 and above Revision: A.08 adds Burst 3 and 4 Revision: A.09 adds Burst 5
 | GSM/GPRS/ EGPRS LA | Revision: C.01 and above Revision: E.02 adds Burst 3 and 4 Revision: F.01 adds Burst 5 Revision: G.00.00 adds Burst 6

FETCh:PVTime[:BURSt[1]]:MASK[:FAIL]?

FETCh:PVTime:BURSt2|3|4|5|6:MASK[:FAIL]?

Function | GSM TA | Queries the overall mask pass/fail indicator for the power versus time measurement .
 | GPRS TA
 | EGPRS TA
 | GSM/GPRS LA
 | EGPRS LA
Query |  | Range: 0 (pass) or 1 (fail) and 9.91 E+37 (NAN)
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.01 and above Revision: A.08 adds Burst 3 and 4 Revision: A.09 adds Burst 5
 | GSM/GPRS/ EGPRS LA | Revision: C.01 and above Revision: E.02 adds Burst 3 and 4 Revision: F.01 adds Burst 5 Revision: G.00.00 adds Burst 6

FETCh:PVTime[:BURSt[1]]:MASK:ALL?

FETCh:PVTime:BURSt2|3|4|5|6:MASK:ALL?

Function

 GSM TA

Queries the mask pass/fail indicator and the following worst case margins for the specified burst of the multislot configuration:

  • Upper limit margin result
  • Upper limit margin time
  • Lower limit margin result
  • Lower limit margin time

Margin time is the point in time, relative to burst bit 0, that corresponds with the worst case measurement result (the measurement with the least difference between measured power and the power level boundary specified by the power versus time mask). See the Typical PvT Mask for a Two Burst Multislot Configuration .

Margin result is the difference between the measured power and the power level boundary specified by the power versus time mask. See the Typical PvT Mask for a Two Burst Multislot Configuration .

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Power versus time mask pass/fail

  • Range: 0 (pass) or 1 (fail) and 9.91 E+37 (NAN)

Power versus time upper limit margin time worst case result

  • Range: -50 µs to 593 µs and 9.91 E+37 (NAN)
  • Resolution: 1 ns

Power versus time upper limit margin worst case result:

  • Range: -100 dB to 0 dB and 9.91 E+37 (NAN)
  • Resolution: 0.01 dB

Power versus time lower limit margin time worst case result

  • Range: -50 µs to 593 µs and 9.91 E+37 (NAN)
  • Resolution: 1 ns

Power versus time lower limit margin worst case result

  • Range: -100 dB to 0 dB and 9.91 E+37 (NAN)
  • Resolution: 0.01 dB
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above

Revision: A.08 adds Burst 3 and 4

Revision: A.09 adds Burst 5

GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Revision: E.02 adds Burst 3 and 4

Revision: F.01 adds Burst 5

Revision: G.00.00 adds Burst 6

FETCh:PVTime[:BURSt[1]]:MASK:LOWer[:MARGin]?

FETCh:PVTime:BURSt2|3|4|5|6:MASK:LOWer[:MARGin]?

Function

 GSM TA

Queries the power versus time measurement's lower limit margin, worst case result for the burst of the multislot configuration that you specify.

The lower limit margin, worst case result is the power versus time measurement with the least difference between measured power and the lower power level boundary specified by the power versus time mask. See the Typical PvT Mask for a Two Burst Multislot Configuration .

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Range: -100 dB to 0 dB and 9.91 E+37 (NAN)

Resolution: 0.01 dB
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above

Revision: A.08 adds Burst 3 and 4

Revision: A.09 adds Burst 5

GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Revision: E.02 adds Burst 3 and 4

Revision: F.01 adds Burst 5

Revision: G.00.00 adds Burst 6

FETCh:PVTime[:BURSt[1]]:MASK:LOWer:TIME?

FETCh:PVTime:BURSt2|3|4|5|6:MASK:LOWer:TIME?

Function

 GSM TA

Queries the power versus time measurement's lower limit margin time, worst case result for the burst of the multislot configuration that you specify.

The lower limit margin time result is the point in time, relative to bit 0 in the GSM burst, that corresponds with the worst case measurement (the measurement with the least difference between measured power and the lower power level boundary specified by the power versus time mask). See the Typical PvT Mask for a Two Burst Multislot Configuration .

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Range: -50 µs to 593 µs and 9.91 E+37 (NAN)

Resolution: 1 ns
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above

Revision: A.08 adds Burst 3 and 4

Revision: A.09 adds Burst 5
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Revision: E.02 adds Burst 3 and 4

Revision: F.01 adds Burst 5

Revision: G.00.00 adds Burst 6

FETCh:PVTime[:BURSt[1]]:MASK:UPPer[:MARGin]?

FETCh:PVTime:BURSt2|3|4|5|6:MASK:UPPer[:MARGin]?

Function

 GSM TA

Queries the power versus time measurement upper limit margin worst case result for the burst of the multislot configuration that you specify.

The upper limit margin, worst case result is the power versus time measurement with the least difference between measured power and the power level boundary specified by the power versus time mask. See the Typical PvT Mask for a Two Burst Multislot Configuration .

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Range: -100 dB to 0 dB and 9.91 E+37 (NAN)

Resolution: 0.01 dB
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above

Revision: A.08 adds Burst 3 and 4

Revision: A.09 adds Burst 5

GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Revision: E.02 adds Burst 3 and 4

Revision: F.01 adds Burst 5

Revision: G.00.00 adds Burst 6

FETCh:PVTime[:BURSt[1]]:MASK:UPPer:TIME?

FETCh:PVTime:BURSt2|3|4|5|6:MASK:UPPer:TIME?

Function

 GSM TA

Queries the power versus time measurement's upper limit margin time, worst case result for the burst of the multislot configuration that you specify.

The upper limit margin time result is the point in time, relative to bit 0 in the burst, that corresponds with the worst case measurement result (the measurement with the least difference between measured power and the upper power level boundary specified by the power versus time mask). See the Typical PvT Mask for a Two Burst Multislot Configuration .

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Range: -50 µs to 593 µs and 9.91 E+37 (NAN)

Resolution: 1 ns
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above

Revision: A.08 adds Burst 3 and 4

Revision: A.09 adds Burst 5

GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Revision: E.02 adds Burst 3 and 4

Revision: F.01 adds Burst 5

Revision: G.00.00 adds Burst 6

FETCh:PVTime[:BURSt[1]]:POWer[:ALL]:AVERage?

FETCh:PVTime:BURSt2|3|4|5|6:POWer[:ALL]:AVERage?

Function

 GSM TA

Queries the average power levels, from a number of multi-measurements, at each user-settable time offset that is currently turned on for the burst of the multislot configuration that you specify. Results are relative to the power versus time carrier power measurement.

The SETup:PVTime[:BURSt[1]]:TIME[:OFFSet][:SELected] command sets up the number of offsets that are turned on and their time values. The SETup:PVTime[:BURSt[1]]:TIME:POINts[:SELected]? queries the number of offset points that are turned on, indicating the number of values to expect when you send this command.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Range: -100 dBc to +10 dBc and 9.91 E+37 (NAN)

Resolution: 0.01 dB
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above

Revision: A.08 adds Burst 3 and 4

Revision: A.09 adds Burst 5

GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Revision: E.02 adds Burst 3 and 4

Revision: F.01 adds Burst 5

Revision: G.00.00 adds Burst 6

FETCh:PVTime[:BURSt[1]]:POWer[:ALL][:MAXimum]?

FETCh:PVTime:BURSt2|3|4|5|6:POWer[:ALL][:MAXimum]?

Function

 GSM TA

Queries the maximum power levels, from a number of multi-measurements, at each user-settable time offset that is currently turned on for the burst of the multislot configuration that you specify. Power levels are relative to the power versus time carrier power measurement.

The SETup:PVTime[:BURSt[1]]:TIME[:OFFSet][:SELected] command sets up the number of offsets that are turned on and their time values. The SETup:PVTime[:BURSt[1]]:TIME:POINts[:SELected]? queries the number of offset points that are turned on, indicating the number of values to expect when you send this command.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Range: -100 dBc to +10 dBc and 9.91 E+37 (NAN)

Resolution: 0.01 dB
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above

Revision: A.08 adds Burst 3 and 4

Revision: A.09 adds Burst 5
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Revision: E.02 adds Burst 3 and 4

Revision: F.01 adds Burst 5

Revision: G.00.00 adds Burst 6

FETCh:PVTime[:BURSt[1]]:POWer[:ALL]:MINimum?

FETCh:PVTime:BURSt2|3|4|5|6:POWer[:ALL]:MINimum?

Function

 GSM TA

Queries the minimum power levels, from a number of multi-measurements, at each user-settable time offset that is currently turned on for the burst of the multislot configuration that you specify. Power levels are relative to the power versus time carrier power measurement.

The SETup:PVTime[:BURSt[1]]:TIME[:OFFSet][:SELected] command sets up the number of offsets that are turned on and their time values. The SETup:PVTime[:BURSt[1]]:TIME:POINts[:SELected]? queries the number of offset points that are turned on, indicating the number of values to expect when you send this command.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Range: -100 dBc to +10 dBc and 9.91 E+37 (NAN)

Resolution: 0.01 dB
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above

Revision: A.08 adds Burst 3 and 4

Revision: A.09 adds Burst 5

GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Revision: E.02 adds Burst 3 and 4

Revision: F.01 adds Burst 5

Revision: G.00.00 adds Burst 6

FETCh:PVTime[:BURSt[1]]:POWer[:ALL]:SDEViation?

FETCh:PVTime:BURSt2|3|4|5|6:POWer[:ALL]:SDEViation?

Function

 GSM TA

Queries the standard deviation, from a number of multi-measurements, at each user-settable time offset that is currently turned on for the burst of the multislot configuration that you specify.

The SETup:PVTime[:BURSt[1]]:TIME[:OFFSet][:SELected] command sets up the number of offsets that are turned on and their time values. The SETup:PVTime[:BURSt[1]]:TIME:POINts[:SELected]? queries the number of offset points that are turned on, indicating the number of values to expect when you send this command.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Range: 0 dBc to +100 dBc and 9.91 E+37 (NAN)

Resolution: 0.001 dB
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above

Revision: A.08 adds Burst 3 and 4

Revision: A.09 adds Burst 5

GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Revision: E.02 adds Burst 3 and 4

Revision: F.01 adds Burst 5

Revision: G.00.00 adds Burst 6

FETCh:PVTime[:BURSt[1]]:POWer:TIME[:OFFSet][:MAXimum]?

FETCh:PVTime:BURSt2|3|4|5|6:POWer:TIME[:OFFSet][:MAXimum]?

Function

 GSM TA

Queries the maximum power levels, from a number of multi-measurements, at each user-settable time offset appended to this command. The query returns the results for the burst that you specify. Specified time values must correspond to user-settable time offsets that are currently turned on, and must be rounded to the same values. (9.91 E+37 (NAN) is returned for specified offsets that do not correspond to offsets currently turned on).

Power levels are relative to the power versus time carrier power measurement.

The SETup:PVTime[:BURSt[1]]:TIME[:OFFSet][:SELected] command sets up the number of offsets that are turned on and their time values. Measurements are returned by this query in the same order they are listed in the command.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Power levels:

  • Range: -100 dBc to +10 dBc and 9.91 E+37 (NAN)

  • Resolution: 0.01 dB

Time offsets:

  • Range: Up to 12 time offset values, corresponding to entries in the Power vs Time table of user-defined time offsets currently turned on. The default units are s (seconds).

  • Resolution: Rounded to the same value as displayed in the Power vs Time table and returned by the SETup:PVTime[:BURSt[1]]:TIME[:OFFSet][:SELected] query.
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above

Revision: A.08 adds Burst 3 and 4

Revision: A.09 adds Burst 5

GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Revision: E.02 adds Burst 3 and 4

Revision: F.01 adds Burst 5

Revision: G.00.00 adds Burst 6

Programming Example

OUTPUT 714;"FETCH:PVTIME:POWER:TIME:OFFSET:MAXIMUM? 0US, 570.8US"
! Returns the maximum of power versus time measurements for Burst 1 at the 0.0 us
! and 570.8 us offsets.

FETCh:PVTime[:BURSt[1]]:POWer:TIME[:OFFSet]:AVERage?

FETCh:PVTime:BURSt2|3|4|5|6:POWer:TIME[:OFFSet]:AVERage?

Function

 GSM TA

Queries the average power levels, from a number of multi-measurements, at each user-settable time offset appended to this command. The query returns the results for the burst that you specify. Specified time values must correspond to user-settable time offsets that are currently turned on, and must be rounded to the same values. (9.91 E+37 (NAN) is returned for specified offsets that do not correspond to offsets currently turned on).

Power levels are relative to the power versus time carrier power measurement.

The SETup:PVTime[:BURSt[1]]:TIME[:OFFSet][:SELected] command sets up the number of offsets that are turned on and their time values. Measurements are returned by this query in the same order they are listed in the command.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Power levels:

  • Range: -100 dBc to +10 dBc and 9.91 E+37 (NAN)

    Resolution: 0.01 dB

Time offsets:

  • Range: Up to 12 time offset values, corresponding to entries in the Power vs Time table of user-defined time offsets currently turned on. The default units are s (seconds).

  • Resolution: Rounded to the same value as displayed in the Power vs Time table and returned by the SETup:PVTime[:BURSt[1]]:TIME[:OFFSet][:SELected] query.
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above

Revision: A.08 adds Burst 3 and 4

Revision: A.09 adds Burst 5

GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Revision: E.02 adds Burst 3 and 4

Revision: F.01 adds Burst 5

Revision: G.00.00 adds Burst 6

Programming Example

OUTPUT 714;"FETCH:PVTIME:BURSt2:POWER:TIME:OFFSET:AVERAGE? 0US, 570.8US"
! Returns the average of power versus time measurements for Burst 1 at the
! 0.0 us and 570.8 us offsets.

FETCh:PVTime[:BURSt[1]]:POWer:TIME[OFFSet]:MINimum?

FETCh:PVTime:BURSt2|3|4|5|6:POWer:TIME[OFFSet]:MINimum?

Function

 GSM TA

Queries the minimum power levels, from a number of multi-measurements, at each user-settable time offset appended to this command. The query returns the results for the burst that you specify. Specified time values must correspond to user-settable time offsets that are currently turned on, and must be rounded to the same values. (9.91 E+37 (NAN) is returned for specified offsets that do not correspond to offsets currently turned on).

Power levels are relative to the power versus time carrier power measurement.

The SETup:PVTime[:BURSt[1]]:TIME[:OFFSet][:SELected] command sets up the number of offsets that are turned on and their time values. Measurements will be returned by this query in the same order they are listed in the command.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Power levels:

  • Range: -100 dBc to +10 dBc and 9.91 E+37 (NAN)
  • Resolution: 0.01 dB

Time offsets:

  • Range: Up to 12 time offset values, corresponding to entries in the Power vs Time table of user-defined time offsets currently turned on. The default units are s (seconds).

  • Resolution: Rounded to the same value as displayed in the Power vs Time table and returned by the SETup:PVTime[:BURSt[1]]:TIME[:OFFSet][:SELected] query.
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above

Revision: A.08 adds Burst 3 and 4

Revision: A.09 adds Burst 5

GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Revision: E.02 adds Burst 3 and 4

Revision: F.01 adds Burst 5

Revision: G.00.00 adds Burst 6

Programming Example

OUTPUT 714;"FETCH:PVTIME:POWER:TIME:OFFSET:MINIMUM? 0US, 570.8US"
! Returns the minimum of power versus time measurements for Burst 1 at the 0.0 us and
! 570.8 us offsets.

FETCh:PVTime[:BURSt[1]]:POWer:TIME[:OFFSet]:SDEViation?

FETCh:PVTime:BURSt2|3|4|5|6:POWer:TIME[:OFFSet]:SDEViation?

Function

 GSM TA

Queries the standard deviation, from a number of multi-measurements, at each user-settable time offset appended to this command. The query returns the results for the burst that you specify. Specified time values must correspond to user-settable time offsets that are currently turned on, and must be rounded to the same values. (9.91 E+37 (NAN) is returned for specified offsets that do not correspond to offsets currently turned on).

Power levels are relative to the power versus time carrier power measurement.

The SETup:PVTime[:BURSt[1]]:TIME[:OFFSet][:SELected] command sets up the number of offsets that are turned on and their time values. Measurements are returned by this query in the same order they are listed in the command.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Power levels:

  • Range: 0 dBc to +100 dBc and 9.91 E+37 (NAN)

  • Resolution: 0.001 dB

Time offsets:

  • Range: Up to 12 time offset values, corresponding to entries in the Power vs Time table of user-defined time offsets currently turned on. The default units are s (seconds).

  • Resolution: Rounded to the same value as displayed in the Power vs Time table and returned by the SETup:PVTime[:BURSt[1]]:TIME[:OFFSet][:SELected] query.
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above

Revision: A.08 adds Burst 3 and 4

Revision: A.09 adds Burst 5

GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Revision: E.02 adds Burst 3 and 4

Revision: F.01 adds Burst 5

Revision: G.00.00 adds Burst 6

Programming Example

OUTPUT 714;"FETCH:PVTIME:POWER:TIME:OFFSET:SDEVIATION? 0US, 570.8US"
! Returns the standard deviation of power versus time measurements for Burst 1
! at the 0.0 us and 570.8 us offsets.

FETCh:PVTime[:BURSt[1]]:TRACe?

FETCh:PVTime:BURSt2|3|4|5|6:TRACe?

Function

 GSM TA

Queries the power versus time trace results for the burst of the multislot configuration that you specify. It returns the integrity of the measurement, the start time of the trace, the time increment between data points, and a data block containing the trace data. The start time is the time of the first sample in the trace, relative to bit 0 of the burst being queried. The time increment is the time between samples.

NOTE
This command only returns valid data when the power versus time graphics state is ON. See SETup:PVTime:GRAPh:STATe for more information.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Power versus time measurement integrity

  • Range: See Integrity Indicator .
  • Resolution: 1

Start time

  • Range: -200 µs to +800 µs and 9.91 E+37 (NAN)
  • Resolution: 1 ns

Time increment

  • Range: 0 to 100 µs and 9.91 E+37 (NAN)
  • Resolution: 1 ns

Data block

  • Power values relative to the current setting of the Tx Power Reference. These values are returned as a comma separated list.
  • Range: -100 dB to 100 dB and 9.91 E+37 (NAN)
  • Resolution: 0.01 dB
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above

Revision: A.03 and above changed the start time value to be relative to bit 0 of the burst being queried. Previously, the start time value was relative to bit 0 of Burst 1.

Revision: A.08 adds Burst 3 and 4

Revision: A.09 adds Burst 5

GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Revision: C.03 and above changed the start time value to be relative to bit 0 of the burst being queried. Previously, the start time value was relative to bit 0 of Burst 1.

Revision: E.02 adds Burst 3 and 4

Revision: F.01 adds Burst 5

Revision: G.00.00 adds Burst 6

Programming Example

OUTPUT 714;"FETC:PVT:TRAC?"
! Returns the trace results for Burst 1 of a multislot configuration.

FETCh:PVTime[:BURSt[1]]:TXPower[:CARRier][:AVERage]?

FETCh:PVTime:BURSt2|3|4|5|6:TXPower[:CARRier][:AVERage]?

Function | GSM TA | Queries power versus time average carrier power for the burst of the multislot configuration that you specify.
 | GPRS TA
 | EGPRS TA
 | GSM/GPRS LA
 | EGPRS LA
Query |  | Range: -100 dBm to 100 dBm and 9.91 E+37 (NAN) Resolution: 0.01 dB
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.01 and above Revision: A.08 adds Burst 3 and 4 Revision: A.09 adds Burst 5
 | GSM/GPRS/ EGPRS LA | Revision: C.01 and above Revision: E.02 adds Burst 3 and 4 Revision: F.01 adds Burst 5 Revision: G.00.00 adds Burst 6

FETCh:PVTime[:BURSt[1]]:TXPower[:CARRier]:ALL?

FETCh:PVTime:BURSt2|3|4|5|6:TXPower[:CARRier]:ALL?

Function

 GSM TA

Queries the power versus time carrier power results for the burst of the multislot configuration that you specify. It returns the minimum, maximum, average, and standard deviation.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Power versus time carrier power (average)

  • Range: -100 dBm to 100 dBm and 9.91 E+37 (NAN)
  • Resolution: 0.01 dB

Power versus time carrier power (minimum)

  • Range: -100 dBm to 100 dBm and 9.91 E+37 (NAN)
  • Resolution: 0.01 dB

Power versus time carrier power (maximum)

  • Range: -100 dBm to 100 dBm and 9.91 E+37 (NAN)
  • Resolution: 0.01 dB

Power versus time carrier power (standard deviation)

  • Range: 0 dB to 100 dB and 9.91 E+37 (NAN)
  • Resolution: 0.001 dB
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above

Revision: A.08 adds Burst 3 and 4

Revision: A.09 adds Burst 5

GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Revision: E.02 adds Burst 3 and 4

Revision: F.01 adds Burst 5

Revision: G.00.00 adds Burst 6

FETCh:PVTime[:BURSt[1]]:TXPower[:CARRier]:MAXimum?

FETCh:PVTime:BURSt2|3|4|5|6:TXPower[:CARRier]:MAXimum?

Function | GSM TA | Queries power versus time maximum carrier power for the burst of the multislot configuration that you specify.
 | GPRS TA
 | EGPRS TA
 | GSM/GPRS LA
 | EGPRS LA
Query |  | Range: -100 dBm to 100 dBm and 9.91 E+37 (NAN) Resolution: 0.01 dB
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.01 and above Revision: A.08 adds Burst 3 and 4 Revision: A.09 adds Burst 5
 | GSM/GPRS/ EGPRS LA | Revision: C.01 and above Revision: E.02 adds Burst 3 and 4 Revision: F.01 adds Burst 5 Revision: G.00.00 adds Burst 6

FETCh:PVTime[:BURSt[1]]:TXPower[:CARRier]:MINimum?

FETCh:PVTime:BURSt2|3|4|5|6:TXPower[:CARRier]:MINimum?

Function | GSM TA | Queries power versus time minimum carrier power for the burst of the multislot configuration that you specify.
 | GPRS TA
 | EGPRS TA
 | GSM/GPRS LA
 | EGPRS LA
Query |  | Range: -100 dBm to 100 dBm and 9.91 E+37 (NAN) Resolution: 0.01 dB
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.01 and above Revision: A.08 adds Burst 3 and 4 Revision: A.09 adds Burst 5
 | GSM/GPRS/ EGPRS LA | Revision: C.01 and above Revision: E.02 adds Burst 3 and 4 Revision: F.01 adds Burst 5 Revision: G.00.00 adds Burst 6

FETCh:PVTime[:BURSt[1]]:TXPower[:CARRier]:SDEViation?

FETCh:PVTime:BURSt2|3|4|5|6:TXPower[:CARRier]:SDEViation?

Function | GSM TA | Queries power versus time standard deviation for the burst of the multislot configuration that you specify.
 | GPRS TA
 | EGPRS TA
 | GSM/GPRS LA
 | EGPRS LA
Query |  | Range: 0 dB to 100 dB and 9.91 E+37 (NAN) Resolution: 0.001 dB
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.01 and above Revision: A.08 adds Burst 3 and 4 Revision: A.09 adds Burst 5
 | GSM/GPRS/ EGPRS LA | Revision: C.01 and above Revision: E.02 adds Burst 3 and 4 Revision: F.01 adds Burst 5 Revision: G.00.00 adds Burst 6

FETCh:PVTime:ICOunt?

Function | GSM TA | Queries the intermediate count of power versus time multi-measurements completed.
 | GPRS TA
 | EGPRS TA
 | GSM/GPRS LA
 | EGPRS LA
Query |  | Range: 0 to 999 Resolution: 1
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.01 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.01 and above

FETCh:PVTime:MASK[:FAIL]?

Function | GSM TA | Queries power versus time measurement mask pass/fail indicator.
 | GPRS TA
 | EGPRS TA
 | GSM/GPRS LA
 | EGPRS LA
Query |  | Range: 0 (pass) or 1 (fail) and 9.91 E+37 (NAN)
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.01 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.01 and above

FETCh:PVTime:MASK[:FAIL]:SECTion?

Function

 GSM TA

This query returns a pair of mask error codes for the upper and lower mask sections.

The number of pairs returned depends upon the number of bursts within the measurement. The error code represents a bit field with one bit for each section of the mask.

The error codes are:

  • 0 = No Mask Failures
  • 1 (bit 1) = First section of the mask failed
  • 2 (bit 2) = Second section of the mask failed
  • 4 (bit 3) = Third section of the mask failed

    ...

  • -1 (bit 32)= Thirty-second section of the mask failed

The above list shows values which can be returned if any single error occurs. Note that the value returned could indicate a combination of errors. For example, if 5 is returned, this indicates that the first and third sections have caused the failure.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Range: -2147483648 to 2147483648
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

FETCh:PVTime:MASK[:FAIL]:SEGment?

Function

 GSM TA

This query returns the mask error code for the entire multislot configuration. This error code indicates which parts, if any are causing the multislot configuration to fail the power versus time mask.

The error codes are:

  • 0 = No Mask Failures
  • 1 (bit 1) = Rising Edge Failure
  • 2 (bit 2) = Falling Edge Failure
  • 4 (bit 3) = Active Part of First Burst
  • 8 (bit 4) = First Guard Period
  • 16 (bit 5) = Active Part of Second Burst
  • 32 (bit 6) = Second Guard Period
  • 64 (bit 7) = Active Part of Third Burst
  • 128 (bit 8) = Third Guard Period
  • 256 (bit 9) = Active Part of Fourth Burst

The above list shows values which can be returned if any single error causes the multislot configuration to fail the mask. (For example, if 4 is returned the failure is due to the active part of the first burst. Note that the value returned could indicate a combination of errors which is causing the multislot configuration to fail. For example, if 9 is returned, this indicates that a rising edge failure and the first guard period has caused the failure.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Range: 0 to 31
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

FETCh:PVTime:SECTion[:ALL]?

Function

 GSM TA

Queries the average, minimum, and maximum power, relative to the carrier power, for a section of the power versus time trace. This query requires the start and stop time values be appended to the command.

NOTE
This command only returns valid data when the power versus time graphics state is ON. See SETup:PVTime:GRAPh:TIME:REFerence for more information.

GPRS TA

GSM/GPRS LA

EGPRS LA

Query

Power versus Time trace section Average Relative Power:

  • Range: -100 dBc to +100 dBc and 9.91 E+37 (NAN)

  • Resolution: 0.01 dB

Power versus Time trace section Minimum Relative Power:

  • Range: -100 dBc to +100 dBc and 9.91 E+37 (NAN)

  • Resolution: 0.01 dB

Power versus Time trace section Maximum Relative Power level:

  • Range: -100 dBc to +100 dBc and 9.91 E+37 (NAN)

  • Resolution: 0.01 dB
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"FETC:PVT:SECT? -50US, 300US"
! Returns statistical values for the specified time range.

FETCh:PVTime:SECTion:AVERage?

Function

 GSM TA

Queries the average power, relative to the carrier power, for a section of the power versus time trace. This query requires the start and stop time values be appended to the command.

NOTE
This command only returns valid data when the power versus time graphics state is ON. See SETup:PVTime:GRAPh:TIME:REFerence for more information.

GPRS TA

GSM/GPRS LA

EGPRS LA

Query

Range: -100 dBc to +100 dBc and 9.91 E+37 (NAN)

Resolution: 0.01 dB
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"FETC:PVT:SECT:AVER? -50US, 300US"
! Returns the average power, relative to the carrier power,
! for the specified time range.

FETCh:PVTime:SECTion:MAXimum?

Function

 GSM TA

Queries the maximum power, relative to the carrier power, for a section of the power versus time trace. This query requires the start and stop time values be appended to the command.

NOTE
This command only returns valid data when the power versus time graphics state is ON. See SETup:PVTime:GRAPh:TIME:REFerence for more information.

GPRS TA

GSM/GPRS LA

EGPRS LA

Query

Range: -100 dBc to +100 dBc and 9.91 E+37 (NAN)

Resolution: 0.01 dB
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"FETC:PVT:SECT:MAX? -50US, 300US"
! Returns the maximum power, relative to the carrier power,
! for the specified time range.

FETCh:PVTime:SECTion:MINimum?

Function

 GSM TA

Queries the minimum power, relative to the carrier power, for a section of the power versus time trace. This query requires the start and stop time values be appended to the command.

NOTE
This command only returns valid data when the power versus time graphics state is ON. See SETup:PVTime:GRAPh:TIME:REFerence for more information.

GPRS TA

GSM/GPRS LA

EGPRS LA

Query

Range: -100 dBc to +100 dBc and 9.91 E+37 (NAN)

Resolution: 0.01 dB
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"FETC:PVT:SECT:MIN? -50US, 300US"
! Returns the minimum power, relative to the carrier power,
! for the specified time range.


FETCh:SMONitor

FETCh:SMONitor

GPIB Command Conventions

  • FETCh:SMONitor[:ALL]?
  • FETCh:SMONitor:INTegrity?
  • FETCh:SMONitor:TRACe?

FETCh:SMONitor[:ALL]?

Function

GSM TA

Returns one integrity indicator value followed by 401 points representing the amplitude results (in dBm) of the trace data for the last spectrum monitor measurement performed.

See Integrity Indicator for descriptions of non-zero integrity indicators.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Integrity Indicator:

  • Range: See Integrity Indicator
  • Resolution: 1

Trace Data:

  • Range:

    • For spans of 125 kHz and 500 kHz

      • frequency of point: within the current span (relative to the center frequency)
      • amplitude of point: -50 to +55 dB

    • For all other spans

      • frequency of point: within the current span (relative to the center frequency)
      • amplitude of point: (reference level - 60 dB) to +55 dB
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

FETCh:SMONitor:INTegrity?

Function | GSM TA | Returns the integrity indicator value for the last spectrum monitor measurement performed. Zero indicates a normal result. See Integrity Indicator for descriptions of non-zero integrity indicators.
 | GPRS TA
 | EGPRS TA
 | GSM/GPRS LA
 | EGPRS LA
Query |  | Range: See Integrity Indicator . Resolution: 1
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.01 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.01 and above

FETCh:SMONitor:TRACe?

Function

GSM TA

 Queries the spectrum monitor and returns one Integrity Indicator followed by 401 points representing the amplitude results (in dBm) of the trace data.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Range:

  • For spans of 125 kHz and 500 kHz

    • frequency of point: within the current span (relative to the center frequency)
    • amplitude of point: -50 to +55 dB

  • For all other spans

    • frequency of point: within the current span (relative to the center frequency)
    • amplitude of point: (reference level - 60 dB) to +55 dB
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above


FETCh:TXPower

FETCh:TXPower

GPIB Command Conventions

  • FETCh:TXPower[:ALL]?<sp>[<Burst>]
  • FETCh:TXPower:ICOunt?
  • FETCh:TXPower:INTegrity?
  • FETCh:TXPower:GFDTune:TRIGger:COUNt?
  • FETCh:TXPower:MODulation:FORMat[:BURSt]?<sp>[<Burst>]
  • FETCh:TXPower:MODulation:FORMat:FRAMe?
  • FETCh:TXPower:POWer:ALL?<sp>[<Burst>]
  • FETCh:TXPower:POWer:BURSt[:AVERage]?<sp>[<Burst>]
  • FETCh:TXPower:POWer:BURSt:MAXimum?<sp>[<Burst>]
  • FETCh:TXPower:POWer:BURSt:MINimum?<sp>[<Burst>]
  • FETCh:TXPower:POWer:BURSt:SDEViation?<sp>[<Burst>]
  • FETCh:TXPower:POWer:BURSt:FRAMe:[:AVERage]?
  • FETCh:TXPower:POWer:BURSt:FRAMe:MAXimum?
  • FETCh:TXPower:POWer:BURSt:FRAMe:MINimum?
  • FETCh:TXPower:POWer:BURSt:FRAMe:SDEViation?
  • FETCh:TXPower:POWer[:CARRier][:AVERage]?<sp>[<Burst>]
  • FETCh:TXPower:POWer[:CARRier]:MAXimum?<sp>[<Burst>]
  • FETCh:TXPower:POWer[:CARRier]:MINimum?<sp>[<Burst>]
  • FETCh:TXPower:POWer[:CARRier]:SDEViation?<sp>[<Burst>]
  • FETCh:TXPower:POWer[:CARRier]:FRAMe[:AVERage]?]
  • FETCh:TXPower:POWer[:CARRier]:FRAMe:MAXimum?
  • FETCh:TXPower:POWer[:CARRier]:FRAMe:MINimum?
  • FETCh:TXPower:POWer[:CARRier]:FRAMe:SDEViation?
  • FETCh:TXPower:SSTep:BPOWer:FRAMe[:AVERage]?<sp><Step>
  • FETCh:TXPower:SSTep:BPOWer:FRAMe:MAXimum?<sp><Step>
  • FETCh:TXPower:SSTep:BPOWer:FRAMe:MINimum?<sp><Step>
  • FETCh:TXPower:SSTep:BPOWer:FRAMe:SDEViation?<sp><Step>
  • FETCh:TXPower:SSTep:CPOWer:FRAMe[:AVERage]?<sp><Step>
  • FETCh:TXPower:SSTep:CPOWer:FRAMe:MAXimum?<sp><Step>
  • FETCh:TXPower:SSTep:CPOWer:FRAMe:MINimum?<sp><Step>
  • FETCh:TXPower:SSTep:CPOWer:FRAMe:SDEViation?<sp><Step>
  • FETCh:TXPower:SSTep:BPOWer[:BURSt][:AVERage]?<sp><Step>[,<Burst>]
  • FETCh:TXPower:SSTep:BPOWer[:BURSt]:MAXimum?<sp><Step>[,<Burst>]
  • FETCh:TXPower:SSTep:BPOWer[:BURSt]:MINimum?<sp><Step>[,<Burst>]
  • FETCh:TXPower:SSTep:BPOWer[:BURSt]:SDEViation?<sp><Step>[,<Burst>]
  • FETCh:TXPower:SSTep:CPOWer[:BURSt][:AVERage]?<sp><Step>[,<Burst>]
  • FETCh:TXPower:SSTep:CPOWer[:BURSt]:MAXimum?<sp><Step>[,<Burst>]
  • FETCh:TXPower:SSTep:CPOWer[:BURSt]:MINimum?<sp><Step>[,<Burst>]
  • FETCh:TXPower:SSTep:CPOWer[:BURSt]:SDEViation?<sp><Step>[,<Burst>]
  • FETCh:TXPower:SSTep:INTegrity?<sp><Step>
  • FETCh:TXPower:SSTep:MODulation:FORMat[:BURSt]?<sp><Step>[,<Burst>]
  • FETCh:TXPower:SSTep:MODulation:FORMat:FRAMe?<sp><Step>
  • FETCh:TXPower:TSEQuence:BPOWer[:AVERage]?<sp>[<Burst>]
  • FETCh:TXPower:TSEQuence:BPOWer:MAXimum?<sp>[<Burst>]
  • FETCh:TXPower:TSEQuence:BPOWer:MINimum?<sp>[<Burst>]
  • FETCh:TXPower:TSEQuence:BPOWer:SDEViation?<sp>[<Burst>]
  • FETCh:TXPower:TSEQuence:CPOWer[:AVERage]?<sp>[<Burst>]
  • FETCh:TXPower:TSEQuence:CPOWer:MAXimum?<sp>[<Burst>]
  • FETCh:TXPower:TSEQuence:CPOWer:MINimum?<sp>[<Burst>]
  • FETCh:TXPower:TSEQuence:CPOWer:SDEViation?<sp>[<Burst>]
  • FETCh:TXPower:TSEQuence:INTegrity?
  • FETCh:TXPower:TSEQuence:MODulation:FORMat?<sp>[<Burst>]

FETCh:TXPower[:ALL]?<sp>[<Burst>]

Function

 GSM TA

Queries integrity indicator and burst power measurement result for the burst specified by Measurement Burst . This query returns the results in the following order: <Integrity>, <TX Burst Power>. If the Multi-measurement Count parameter is set to ON, the burst power multi-measurement average result is returned instead of the TX Burst Power result.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Integrity indicator

  • Range: See Integrity Indicator .
  • Resolution: 1

Burst power (average)

  • Range: -100 to +100 dBm and 9.91E+37 (NAN)
  • Resolution: 0.01 dB
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"FETCh:TXPower:ALL?"
! Query the integrity indicator and burst power measurement for the burst
! specified by "Measurement Burst".

FETCh:TXPower:ICOunt?

Function

 GSM TA Queries the intermediate count of transmit power measurements completed.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Range: 1 to 999

Resolution: 1
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"FETCh:TXPower:ICOunt?"
! Query the intermediate count of transmit power measurements completed.

FETCh:TXPower:INTegrity?

Function

 GSM TA

Queries the overall integrity indicator for all bursts under measurement. Zero indicates normal.

For non-zero integrity indicators, refer to Integrity Indicator .

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Range: See Integrity Indicator .

Resolution: 1
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"FETCh:TXPower:INTegrity?"
! Query the integrity indicator for all the burst under measurement.

FETCh:TXPower:GFDTune:TRIGger:COUNt?

Function

 GSM TA Queries the good protocol trigger number in Fast Device Tune mode.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Range: 1 to 100000.

Resolution: 1
Requirements GSM/GPRS/
EGPRS TA

Revision: A.08 and above
GSM/GPRS/ EGPRS LA

Revision: E.02 and above

Programming Example

OUTPUT 714;"FETCh:TXPower:GFDTune:TRIGger:COUNt?"
! Query the good protocol trigger number.

FETCh:TXPower:MODulation:FORMat[:BURSt]?<sp>[<Burst>]

Function

 GSM TA

This command is only applicable when the Burst Capture Range is set to All.

Queries the modulation format for the specified burst.

See Query the measurement results for a specified burst for more information.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Range: GMSK | EPSK | MIXed |UNKNown.
Requirements GSM/GPRS/
EGPRS TA

Revision: A.07 and above
GSM/GPRS/ EGPRS LA

Revision: E.01 and above

Programming Example

OUTPUT 714;"FETCh:TXPower:MODulation:FORMat? 2"
! Query the modulation format for burst 2.

FETCh:TXPower:MODulation:FORMat:FRAMe?

Function

 GSM TA

This command is only applicable when the Burst Capture Range is set to All.

Queries the modulation format for the whole TDMA frame.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Range: GMSK | EPSK | MIXed | UNKNown.

Resolution: Not Applicable
Requirements GSM/GPRS/
EGPRS TA

Revision: A.07 and above
GSM/GPRS/ EGPRS LA

Revision: E.01 and above

Programming Example

OUTPUT 714;"FETCh:TXPower:MODulation:FORMat:FRAMe?
! Query the modulation format for the whole frame.

FETCh:TXPower:POWer:ALL?<sp>[<Burst>]

Function

 GSM TA

Queries the average, minimum, maximum and standard deviation of transmit power multi-measurement results for the specified burst. The query returns the power results in the following order: <Burst Power minimum>, <Burst Power maximum>, <Burst Power average>, <Burst Power standard deviation>.

See Query the measurement results for a specified burst for more information.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Average:

  • Range: -100 dBm to 100 dBm and 9.91 E+37 (NAN)
  • Resolution: 0.01 dB

Minimum:

  • Range: -100 dBm to 100 dBm and 9.91 E+37 (NAN)
  • Resolution: 0.01 dB

Maximum:

  • Range: -100 dBm to 100 dBm and 9.91 E+37 (NAN)
  • Resolution: 0.01 dB

Standard deviation:

  • Range: 0 dB to 100 dB and 9.91 E+37 (NAN)
  • Resolution: 0.001 dB
Requirements GSM/GPRS/
EGPRS TA

Revision: A.07 and above
GSM/GPRS/ EGPRS LA

Revision: E.01 and above

Programming Example

OUTPUT 714;"FETCh:TXPower:POWer:ALL? 2"
! Query the average, minimum, maximum and standard deviation of the transmit power
! multi-measurement results for burst 2.

FETCh:TXPower:POWer:BURSt[:AVERage]?<sp>[<Burst>]

Function

 GSM TA

Queries the average burst power for the specified burst.

See Query the measurement results for a specified burst for more information.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Range: -100 dBm to 100 dBm and 9.91 E+37 (NAN)

Resolution: 0.01 dB
Requirements GSM/GPRS/
EGPRS TA

Revision: A.07 and above
GSM/GPRS/ EGPRS LA

Revision: E.01 and above

Programming Example

OUTPUT 714;"FETCh:TXPower:POWer:BURSt? 2"
! Query the average burst power for burst 2.

FETCh:TXPower:POWer:BURSt:MAXimum?<sp>[<Burst>]

Function

 GSM TA

Queries the maximum burst power for the specified burst.

See Query the measurement results for a specified burst for more information.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Range: -100 dBm to 100 dBm and 9.91 E+37 (NAN)

Resolution: 0.01 dB
Requirements GSM/GPRS/
EGPRS TA

Revision: A.07 and above
GSM/GPRS/ EGPRS LA

Revision: E.01 and above

Programming Example

OUTPUT 714;"FETCh:TXPower:POWer:BURSt:MAXimum? 2"
! Query the maximum burst power for burst 2.

FETCh:TXPower:POWer:BURSt:MINimum?<sp>[<Burst>]

Function

 GSM TA

Queries the minimum burst power for the specified burst.

See Query the measurement results for a specified burst for more information.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Range: -100 dBm to 100 dBm and 9.91 E+37 (NAN)

Resolution: 0.01 dB
Requirements GSM/GPRS/
EGPRS TA

Revision: A.07 and above
GSM/GPRS/ EGPRS LA

Revision: E.01 and above

Programming Example

OUTPUT 714;"FETCh:TXPower:POWer:BURSt:MINimum? 2"
! Query the minimum burst power for burst 2.

FETCh:TXPower:POWer:BURSt:SDEViation?<sp>[<Burst>]

Function

 GSM TA

Queries the standard deviation of burst power for the specified burst.

See Query the measurement results for a specified burst for more information.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Range: 0 dB to 100 dB and 9.91 E+37 (NAN)

Resolution: 0.001 dB
Requirements GSM/GPRS/
EGPRS TA

Revision: A.07 and above
GSM/GPRS/ EGPRS LA

Revision: E.01 and above

Programming Example

OUTPUT 714;"FETCh:TXPower:POWer:BURSt:SDEViation? 2"
! Query the standard deviation of the burst power for burst 2.

FETCh:TXPower:POWer:BURSt:FRAMe:[:AVERage]?

Function

 GSM TA

This command is only applicable when the Burst Capture Range is set to All.

See Query the measurement results for all bursts for more information.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Range: -100 dBm to 100 dBm and 9.91 E+37 (NAN)

Resolution: 0.01 dB
Requirements GSM/GPRS/
EGPRS TA

Revision: A.07 and above
GSM/GPRS/ EGPRS LA

Revision: E.01 and above

Programming Example

OUTPUT 714;"FETCh:TXPower:POWer:BURSt:FRAMe?
! Query the average burst power for the whole frame.

FETCh:TXPower:POWer:BURSt:FRAMe:MAXimum?

Function

 GSM TA

This command is only applicable when the Burst Capture Range is set to All.

See Query the measurement results for all bursts for more information.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Range: -100 dBm to 100 dBm and 9.91 E+37 (NAN)

Resolution: 0.01 dB
Requirements GSM/GPRS/
EGPRS TA

Revision: A.07 and above
GSM/GPRS/ EGPRS LA

Revision: E.01 and above

Programming Example

OUTPUT 714;"FETCh:TXPower:POWer:BURSt:FRAMe:MAXimum?
! Query the maximum burst power for the whole frame .

FETCh:TXPower:POWer:BURSt:FRAMe:MINimum?

Function

 GSM TA

This command is only applicable when the Burst Capture Range is set to All.

See Query the measurement results for all bursts for more information.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Range: -100 dBm to 100 dBm and 9.91 E+37 (NAN)

Resolution: 0.01 dB
Requirements GSM/GPRS/
EGPRS TA

Revision: A.07 and above
GSM/GPRS/ EGPRS LA

Revision: E.01 and above

Programming Example

OUTPUT 714;"FETCh:TXPower:POWer:BURSt:FRAMe:MINimum?
! Query the minimum burst power for the whole frame .

FETCh:TXPower:POWer:BURSt:FRAMe:SDEViation?

Function

 GSM TA

This command is only applicable when the Burst Capture Range is set to All.

See Query the measurement results for all bursts for more information.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Range: 0 dB to 100 dB and 9.91 E+37 (NAN)

Resolution: 0.001 dB
Requirements GSM/GPRS/
EGPRS TA

Revision: A.07 and above
GSM/GPRS/ EGPRS LA

Revision: E.01 and above

Programming Example

OUTPUT 714;"FETCh:TXPower:POWer:BURSt:FRAMe:SDEViation?
! Query the standard deviation of the burst power for the whole frame.

FETCh:TXPower:POWer[:CARRier][:AVERage]?<sp>[<Burst>]

Function

 GSM TA

When the Burst Capture Range is set to All, this command queries the average Estimated Carrier Power for the specified burst.

When the Burst Capture Range is set to Single, this command queries the average Burst Power for the specified burst.

See Query the measurement results for a specified burst for more information.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Range: -100 dBm to 100 dBm and 9.91 E+37 (NAN)

Resolution: 0.01 dB
Requirements GSM/GPRS/
EGPRS TA

Revision: A.07 and above
GSM/GPRS/ EGPRS LA

Revision: E.01 and above

Programming Example

OUTPUT 714;"FETCh:TXPower:POWer:CARRier? 2
! Query the average Estimated Carrier Power for burst 2.

FETCh:TXPower:POWer[:CARRier]:MAXimum?<sp>[<Burst>]

Function

 GSM TA

When the Burst Capture Range is set to All, this command queries the maximum Estimated Carrier Power for the specified burst.

When the Burst Capture Range is set to Single, this command queries the maximum Burst Power for the specified burst.

See Query the measurement results for a specified burst for more information.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Range: -100 dBm to 100 dBm and 9.91 E+37 (NAN)

Resolution: 0.01 dB
Requirements GSM/GPRS/
EGPRS TA

Revision: A.07 and above
GSM/GPRS/ EGPRS LA

Revision: E.01 and above

Programming Example

OUTPUT 714;"FETCh:TXPower:POWer:CARRier:MAXimum? 2
! Query the maximum Estimated Carrier Power for burst 2.

FETCh:TXPower:POWer[:CARRier]:MINimum?<sp>[<Burst>]

Function

 GSM TA

When the Burst Capture Range is set to All, this command queries the minimum Estimated Carrier Power for the specified burst.

When the Burst Capture Range is set to Single, this command queries the minimum Burst Power for the specified burst.

See Query the measurement results for a specified burst for more information.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Range: -100 dBm to 100 dBm and 9.91 E+37 (NAN)

Resolution: 0.01 dB
Requirements GSM/GPRS/
EGPRS TA

Revision: A.07 and above
GSM/GPRS/ EGPRS LA

Revision: E.01 and above

Programming Example

OUTPUT 714;"FETCh:TXPower:POWer:CARRier:MINimum? 2
! Query the minimum Estimated Carrier Power for burst 2.

FETCh:TXPower:POWer[:CARRier]:SDEViation?<sp>[<Burst>]

Function

 GSM TA

When the Burst Capture Range is set to All, this command queries the standard deviation of the Estimated Carrier Power for the specified burst.

When the Burst Capture Range is set to Single, this command queries the standard deviation of the Burst Power for the specified burst.

See Query the measurement results for a specified burst for more information.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Range: 0 dB to 100 dB and 9.91 E+37 (NAN)

Resolution: 0.001 dB
Requirements GSM/GPRS/
EGPRS TA

Revision: A.07 and above
GSM/GPRS/ EGPRS LA

Revision: E.01 and above

Programming Example

OUTPUT 714;"FETCh:TXPower:POWer:CARRier:SDEViation? 2
! Query the standard deviation of the Estimated Carrier Power for burst 2.

FETCh:TXPower:POWer[:CARRier]:FRAMe[:AVERage]?]

Function

 GSM TA

This command is only applicable when the Burst Capture Range is set to All.

Queries the average Estimated Carrier Power for all bursts in one frame.

See Query the measurement results for all bursts for more information.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Range: -100 dBm to 100 dBm and 9.91 E+37 (NAN)

Resolution: 0.01 dB
Requirements GSM/GPRS/
EGPRS TA

Revision: A.07 and above
GSM/GPRS/ EGPRS LA

Revision: E.01 and above

Programming Example

OUTPUT 714;"FETCh:TXPower:POWer:CARRier:FRAMe?
! Query the average Estimated Carrier Power for the whole frame.

FETCh:TXPower:POWer[:CARRier]:FRAMe:MAXimum?

Function

 GSM TA

This command is only applicable when the Burst Capture Range is set to All.

Queries the maximum Estimated Carrier Power for all bursts in one frame from a multi-measurement.

See Query the measurement results for all bursts for more information.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Range: -100 dBm to 100 dBm and 9.91 E+37 (NAN)

Resolution: 0.01 dB
Requirements GSM/GPRS/
EGPRS TA

Revision: A.07 and above
GSM/GPRS/ EGPRS LA

Revision: E.01 and above

Programming Example

OUTPUT 714;"FETCh:TXPower:POWer:CARRier:FRAMe:MAXimum?
! Query the maximum Estimated Carrier Power for the whole frame.

FETCh:TXPower:POWer[:CARRier]:FRAMe:MINimum?

Function

 GSM TA

This command is only applicable when the Burst Capture Range is set to All.

Queries the minimum Estimated Carrier Power for all bursts in one frame from a multi-measurement.

See Query the measurement results for all bursts for more information.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Range: -100 dBm to 100 dBm and 9.91 E+37 (NAN)

Resolution: 0.01 dB
Requirements GSM/GPRS/
EGPRS TA

Revision: A.07 and above
GSM/GPRS/ EGPRS LA

Revision: E.01 and above

Programming Example

OUTPUT 714;"FETCh:TXPower:POWer:CARRier:FRAMe:MINimum?
! Query the minimum Estimated Carrier Power for the whole frame.

FETCh:TXPower:POWer[:CARRier]:FRAMe:SDEViation?

Function

 GSM TA

This command is only applicable when the Burst Capture Range is set to All.

Queries the standard deviation of Estimated Carrier Power for all bursts in one frame from a multi-measurement.

See Query the measurement results for all bursts for more information.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Range: 0 dB to 100 dB and 9.91 E+37 (NAN)

Resolution: 0.001 dB
Requirements GSM/GPRS/
EGPRS TA

Revision: A.07 and above
GSM/GPRS/ EGPRS LA

Revision: E.01 and above

Programming Example

OUTPUT 714;"FETCh:TXPower:POWer:CARRier:FRAMe:SDEViation?"
! Query the standard deviation of the Estimated Carrier Power for the whole frame.

FETCh:TXPower:SSTep:BPOWer:FRAMe[:AVERage]?<sp><Step>

Function

 GSM TA

Queries the average transmit power for all bursts of the specified test sequence step.

See Note 2 for more information on how to use the command.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Range: -100 dBm to 100 dBm and 9.91 E+37 (NAN)

Resolution: 0.01 dB
Requirements GSM/GPRS/
EGPRS TA

Revision: A.08 and above, with the required feature license.
GSM/GPRS/ EGPRS LA

Revision: E.02 and above.

Programming Example

OUTPUT 714;"FETCh:TXPower:SSTep:BPOWer:FRAMe? 2"
! Query the average transmit power for all bursts of step 2.

FETCh:TXPower:SSTep:BPOWer:FRAMe:MAXimum?<sp><Step>

Function

 GSM TA

Queries the maximum transmit power for all bursts of the specified test sequence.

See Note 2 for more information on how to use the command.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Range: -100 dBm to 100 dBm and 9.91 E+37 (NAN)

Resolution: 0.01 dB
Requirements GSM/GPRS/
EGPRS TA

Revision: A.08 and above, with the required feature license.
GSM/GPRS/ EGPRS LA

Revision: E.02 and above.

Programming Example

OUTPUT 714;"FETCh:TXPower:SSTep:BPOWer:FRAMe:MAXimum? 2
! Query the maximum transmit power for all bursts of step 2.

FETCh:TXPower:SSTep:BPOWer:FRAMe:MINimum?<sp><Step>

Function

 GSM TA

Queries the minimum transmit power for all bursts of the specified test sequence.

See Note 2 for more information on how to use the command.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Range: -100 dBm to 100 dBm and 9.91 E+37 (NAN)

Resolution: 0.01 dBm
Requirements GSM/GPRS/
EGPRS TA

Revision: A.08 and above, with the required feature license.
GSM/GPRS/ EGPRS LA

Revision: E.02 and above.

Programming Example

OUTPUT 714;"FETCh:TXPower:SSTep:BPOWer:FRAMe:MINimum? 2
! Query the minimum transmit power for all bursts of step 2.

FETCh:TXPower:SSTep:BPOWer:FRAMe:SDEViation?<sp><Step>

Function

 GSM TA

Queries the standard deviation of the transmit power for all bursts of the specified test sequence.

See Note 2 for more information on how to use the command.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Range: 0 dB to 100 dB and 9.91 E+37 (NAN)

Resolution: 0.001 dB
Requirements GSM/GPRS/
EGPRS TA

Revision: A.08 and above, with the required feature license.
GSM/GPRS/ EGPRS LA

Revision: E.02 and above.

Programming Example

OUTPUT 714;"FETCh:TXPower:SSTep:BPOWer:FRAMe:SDEViation? 2
! Query the standard deviation of the transmit power for all bursts of step 2.

FETCh:TXPower:SSTep:CPOWer:FRAMe[:AVERage]?<sp><Step>

Function

 GSM TA

Queries the average estimated carrier power for all bursts of the specified test sequence.

See Note 2 for more information on how to use the command.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Range: -100 dBm to 100 dBm and 9.91 E+37 (NAN)

Resolution: 0.01 dB
Requirements GSM/GPRS/
EGPRS TA

Revision: A.08 and above, with the required feature license.
GSM/GPRS/ EGPRS LA

Revision: E.02 and above.

Programming Example

OUTPUT 714;"FETCh:TXPower:SSTep:CPOWer:FRAMe? 2
! Query the average estimated carrier power for all bursts of step 2.

FETCh:TXPower:SSTep:CPOWer:FRAMe:MAXimum?<sp><Step>

Function

 GSM TA

Queries the maximum estimated carrier power for all bursts of the specified test sequence.

See Note 2 for more information on how to use the command.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Range: -100 dBm to 100 dBm and 9.91 E+37 (NAN)

Resolution: 0.01 dB
Requirements GSM/GPRS/
EGPRS TA

Revision: A.08 and above, with the required feature license.
GSM/GPRS/ EGPRS LA

Revision: E.02 and above.

Programming Example

OUTPUT 714;"FETCh:TXPower:SSTep:CPOWer:FRAMe:MAXimum? 2
! Query the maximum estimated carrier power for all bursts of step 2.

FETCh:TXPower:SSTep:CPOWer:FRAMe:MINimum?<sp><Step>

Function

 GSM TA

Queries the minimum estimated carrier power for all bursts of the specified test sequence.

See Note 2 for more information on how to use the command.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Range: -100 dBm to 100 dBm and 9.91 E+37 (NAN)

Resolution: 0.01 dB
Requirements GSM/GPRS/
EGPRS TA

Revision: A.08 and above, with the required feature license.
GSM/GPRS/ EGPRS LA

Revision: E.02 and above.

Programming Example

OUTPUT 714;"FETCh:TXPower:SSTep:CPOWer:FRAMe:MINimum? 2
! Query the minimum estimated carrier power for all bursts of step 2.

FETCh:TXPower:SSTep:CPOWer:FRAMe:SDEViation?<sp><Step>

Function

 GSM TA

Queries the standard deviation of estimated carrier power for all bursts of the specified test sequence.

See Note 2 for more information on how to use the command.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Range: 0 dB to 100 dB and 9.91 E+37 (NAN)

Resolution: 0.001 dB
Requirements GSM/GPRS/
EGPRS TA

Revision: A.08 and above, with the required feature license.
GSM/GPRS/ EGPRS LA

Revision: E.02 and above.

Programming Example

OUTPUT 714;"FETCh:TXPower:SSTep:CPOWer:FRAMe:SDEViation? 2
! Query the standard deviation of the estimated carrier power for all bursts of step 2.

FETCh:TXPower:SSTep:BPOWer[:BURSt][:AVERage]?<sp><Step>[,<Burst>]

Function

 GSM TA

Queries the average transmit power for a specified burst of the specified test sequence step.

See Note 3 for more information on how to use the command.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Range: -100 dBm to 100 dBm and 9.91 E+37 (NAN)

Resolution: 0.01 dB
Requirements GSM/GPRS/
EGPRS TA

Revision: A.08 and above, with the required feature license.
GSM/GPRS/ EGPRS LA

Revision: E.02 and above.

Programming Example

OUTPUT 714;"FETCh:TXPower:SSTep:BPOWer? 2,3
! Query the average transmit power for burst 3 of step 2.

FETCh:TXPower:SSTep:BPOWer[:BURSt]:MAXimum?<sp><Step>[,<Burst>]

Function

 GSM TA

Queries the maximum transmit power for a specified burst of the specified test sequence step.

See Note 3 for more information on how to use the command.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Range: -100 dBm to 100 dBm and 9.91 E+37 (NAN)

Resolution: 0.01 dB
Requirements GSM/GPRS/
EGPRS TA

Revision: A.08 and above, with the required feature license.
GSM/GPRS/ EGPRS LA

Revision: E.02 and above.

Programming Example

OUTPUT 714;"FETCh:TXPower:SSTep:BPOWer:MAXimum? 2,3
! Query the maximum transmit power for burst 3 of step 2.

FETCh:TXPower:SSTep:BPOWer[:BURSt]:MINimum?<sp><Step>[,<Burst>]

Function

 GSM TA

Queries the minimum transmit power for a specified burst of the specified test sequence step.

See Note 3 for more information on how to use the command.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Range: -100 dBm to 100 dBm and 9.91 E+37 (NAN)

Resolution: 0.01 dB
Requirements GSM/GPRS/
EGPRS TA

Revision: A.08 and above, with the required feature license.
GSM/GPRS/ EGPRS LA

Revision: E.02 and above.

Programming Example

OUTPUT 714;"FETCh:TXPower:SSTep:BPOWer:MINimum? 2,3
! Query the minimum transmit power for burst 3 of step 2.

FETCh:TXPower:SSTep:BPOWer[:BURSt]:SDEViation?<sp><Step>[,<Burst>]

Function

 GSM TA

Queries the standard deviation of transmit power for a specified burst of the specified test sequence step.

See Note 3 for more information on how to use the command.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Range: 0 dB to 100 dB and 9.91 E+37 (NAN)

Resolution: 0.001 dB
Requirements GSM/GPRS/
EGPRS TA

Revision: A.08 and above, with the required feature license.
GSM/GPRS/ EGPRS LA

Revision: E.02 and above.

Programming Example

OUTPUT 714;"FETCh:TXPower:SSTep:BPOWer:SDEViation? 2,3
! Query the standard deviation of the transmit power for burst 3 of step 2.

FETCh:TXPower:SSTep:CPOWer[:BURSt][:AVERage]?<sp><Step>[,<Burst>]

Function

 GSM TA

Queries the average estimated carrier power for a specified burst of the specified test sequence step.

See Note 3 for more information on how to use the command.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Range: -100 dBm to 100 dBm and 9.91 E+37 (NAN)

Resolution: 0.01 dB
Requirements GSM/GPRS/
EGPRS TA

Revision: A.08 and above, with the required feature license.
GSM/GPRS/ EGPRS LA

Revision: E.02 and above.

Programming Example

OUTPUT 714;"FETCh:TXPower:SSTep:CPOWer? 2,3
! Query the average estimated carrier power for burst 3 of step 2.

FETCh:TXPower:SSTep:CPOWer[:BURSt]:MAXimum?<sp><Step>[,<Burst>]

Function

 GSM TA

Queries the maximum estimated carrier power for a specified burst of the specified test sequence step.

See Note 3 for more information on how to use the command.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Range: -100 dBm to 100 dBm and 9.91 E+37 (NAN)

Resolution: 0.01 dB
Requirements GSM/GPRS/
EGPRS TA

Revision: A.08 and above, with the required feature license.
GSM/GPRS/ EGPRS LA

Revision: E.02 and above.

Programming Example

OUTPUT 714;"FETCh:TXPower:SSTep:CPOWer:MAXimum? 2,3
! Query the maximum estimated carrier power for burst 3 of step 2.

FETCh:TXPower:SSTep:CPOWer[:BURSt]:MINimum?<sp><Step>[,<Burst>]

Function

 GSM TA

Queries the minimum estimated carrier power for a specified burst of the specified test sequence step.

See Note 3 for more information on how to use the command.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Range: -100 dBm to 100 dBm and 9.91 E+37 (NAN)

Resolution: 0.01 dB
Requirements GSM/GPRS/
EGPRS TA

Revision: A.08 and above, with the required feature license.
GSM/GPRS/ EGPRS LA

Revision: E.02 and above.

Programming Example

OUTPUT 714;"FETCh:TXPower:SSTep:CPOWer:MINimum? 2,3
! Query the minimum estimated carrier power for burst 3 of step 2.

FETCh:TXPower:SSTep:CPOWer[:BURSt]:SDEViation?<sp><Step>[,<Burst>]

Function

 GSM TA

Queries the standard deviation of estimated carrier power for a specified burst of the specified test sequence step.

See Note 3 for more information on how to use the command.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Range: 0 dB to 100 dB and 9.91 E+37 (NAN)

Resolution: 0.001 dB
Requirements GSM/GPRS/
EGPRS TA

Revision: A.08 and above, with the required feature license.
GSM/GPRS/ EGPRS LA

Revision: E.02 and above.

Programming Example

OUTPUT 714;"FETCh:TXPower:SSTep:CPOWer:SDEViation? 2,3
! Query the standard deviation of the estimated carrier power for burst 3 of step 2.

FETCh:TXPower:SSTep:INTegrity?<sp><Step>

Function

 GSM TA

Queries the integrity indicator for all bursts of the specified test sequence step. Zero indicates normal.

For non-zero integrity indicators, refer to Integrity Indicator .

The command contains a mandatory parameter which defines which step's results are to be queried. If the step number exceeds the range defined by Uplink Sequence Step Count, NANs are returned.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Range: See Integrity Indicator .

Resolution: 1
Requirements GSM/GPRS/
EGPRS TA

Revision: A.08 and above, with the required feature license.
GSM/GPRS/ EGPRS LA

Revision: E.02 and above.

Programming Example

OUTPUT 714;"FETCh:TXPower:SSTep:INTegrity? 2
! Query the integrity indicator for all bursts of step 2.

FETCh:TXPower:SSTep:MODulation:FORMat[:BURSt]?<sp><Step>[,<Burst>]

Function

 GSM TA

Queries the modulation format for a specified burst of the specified test sequence step.

See Note 3 for more information on how to use the command.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Range: GMSK | EPSK | MIXed | UNKNown
Requirements GSM/GPRS/
EGPRS TA

Revision: A.08 and above, with the required feature license.
GSM/GPRS/ EGPRS LA

Revision: E.02 and above.

Programming Example

OUTPUT 714;"FETCh:TXPower:SSTep:MODulation:FORMat? 2,3
! Query the modulation format for burst 3 of step 2.

FETCh:TXPower:SSTep:MODulation:FORMat:FRAMe?<sp><Step>

Function

 GSM TA

Queries the modulation format for all bursts of the specified test sequence step.

The command contains a mandatory parameter which defines which step's results are to be queried.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Range: GMSK | EPSK | MIXed | UNKNown.
Requirements GSM/GPRS/
EGPRS TA

Revision: A.08 and above, with the required feature license.
GSM/GPRS/ EGPRS LA

Revision: E.02 and above.

Programming Example

OUTPUT 714;"FETCh:TXPower:SSTep:CPOWer? 2
! Query the modulation format for all bursts of step 2.

FETCh:TXPower:TSEQuence:BPOWer[:AVERage]?<sp>[<Burst>]

Function

 GSM TA

Queries the average transmit power for all the test sequence steps of the specified burst.

See Note 1 for more information about how to use the command.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Range: -100 dBm to 100 dBm and 9.91 E+37 (NAN)

Resolution: 0.01 dB
Requirements GSM/GPRS/
EGPRS TA

Revision: A.08 and above, with the required feature license.
GSM/GPRS/ EGPRS LA

Revision: E.02 and above.

Programming Example

OUTPUT 714;"FETCh:TXPower:TSEQuence:BPOWer? 3
! Query the average transmit power for all the test sequence steps of burst 3.

FETCh:TXPower:TSEQuence:BPOWer:MAXimum?<sp>[<Burst>]

Function

 GSM TA

Queries the maximum transmit power for all the test sequence steps of the specified burst.

See Note 1 for more information about how to use the command.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Range: -100 dBm to 100 dBm and 9.91 E+37 (NAN)

Resolution: 0.01 dB
Requirements GSM/GPRS/
EGPRS TA

Revision: A.08 and above, with the required feature license.
GSM/GPRS/ EGPRS LA

Revision: E.02 and above.

Programming Example

OUTPUT 714;"FETCh:TXPower:TSEQuence:BPOWer:MAXimum? 3
! Query the maximum transmit power for all the test sequence steps of burst 3.

FETCh:TXPower:TSEQuence:BPOWer:MINimum?<sp>[<Burst>]

Function

 GSM TA

Queries the minimum transmit power for all the test sequence steps of the specified burst.

See Note 1 for more information about how to use the command.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Range: -100 dBm to 100 dBm and 9.91 E+37 (NAN)

Resolution: 0.01 dB
Requirements GSM/GPRS/
EGPRS TA

Revision: A.08 and above, with the required feature license.
GSM/GPRS/ EGPRS LA

Revision: E.02 and above.

Programming Example

OUTPUT 714;"FETCh:TXPower:TSEQuence:BPOWer:MINimum? 3
! Query the minimum transmit power for all the test sequence steps of burst 3.

FETCh:TXPower:TSEQuence:BPOWer:SDEViation?<sp>[<Burst>]

Function

 GSM TA

Queries the standard deviation of transmit power for all the test sequence steps of the specified burst.

See Note 1 for more information about how to use the command.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Range: 0 dB to 100 dB and 9.91 E+37 (NAN)

Resolution: 0.001 dB
Requirements GSM/GPRS/
EGPRS TA

Revision: A.08 and above, with the required feature license.
GSM/GPRS/ EGPRS LA

Revision: E.02 and above.

Programming Example

OUTPUT 714;"FETCh:TXPower:TSEQuence:BPOWer:SDEViation? 3
! Query the standard deviation of the transmit power for all the test sequence steps of burst 3.

FETCh:TXPower:TSEQuence:CPOWer[:AVERage]?<sp>[<Burst>]

Function

 GSM TA

Queries the average estimated carrier power for all the test sequence steps of the specified burst.

See Note 1 for more information about how to use the command.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Range: -100 dBm to 100 dBm and 9.91 E+37 (NAN)

Resolution: 0.01 dB
Requirements GSM/GPRS/
EGPRS TA

Revision: A.08 and above, with the required feature license.
GSM/GPRS/ EGPRS LA

Revision: E.02 and above.

Programming Example

OUTPUT 714;"FETCh:TXPower:TSEQuence:CPOWer? 3
! Query the average estimated carrier power for all the test sequence steps of burst 3.

FETCh:TXPower:TSEQuence:CPOWer:MAXimum?<sp>[<Burst>]

Function

 GSM TA

Queries the maximum estimated carrier power for all the test sequence steps of the specified burst.

See Note 1 for more information about how to use the command.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Range: -100 dBm to 100 dBm and 9.91 E+37 (NAN)

Resolution: 0.01 dB
Requirements GSM/GPRS/
EGPRS TA

Revision: A.08 and above, with the required feature license.
GSM/GPRS/ EGPRS LA

Revision: E.02 and above.

Programming Example

OUTPUT 714;"FETCh:TXPower:TSEQuence:CPOWer:MAXimum? 3
! Query the maximum estimated carrier power for all the test sequence steps of burst 3.

FETCh:TXPower:TSEQuence:CPOWer:MINimum?<sp>[<Burst>]

Function

 GSM TA

Queries the minimum estimated carrier power for all the test sequence steps of the specified burst.

See Note 1 for more information about how to use the command.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Range: -100 dBm to 100 dBm and 9.91 E+37 (NAN)

Resolution: 0.01 dB
Requirements GSM/GPRS/
EGPRS TA

Revision: A.08 and above, with the required feature license.
GSM/GPRS/ EGPRS LA

Revision: E.02 and above.

Programming Example

OUTPUT 714;"FETCh:TXPower:TSEQuence:CPOWer:MINimum? 3
! Query the minimum estimated carrier power for all the test sequence steps of burst 3.

FETCh:TXPower:TSEQuence:CPOWer:SDEViation?<sp>[<Burst>]

Function

 GSM TA

Queries the standard deviation of estimated carrier power for all the test sequence steps of the specified burst.

See Note 1 for more information about how to use the command.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Range: 0 dB to 100 dB and 9.91 E+37 (NAN)

Resolution: 0.001 dB
Requirements GSM/GPRS/
EGPRS TA

Revision: A.08 and above, with the required feature license.
GSM/GPRS/ EGPRS LA

Revision: E.02 and above.

Programming Example

OUTPUT 714;"FETCh:TXPower:TSEQuence:CPOWer:SDEViation? 3
! Query the standard deviation of the estimated carrier power for all the test sequence
! steps of burst 3.

FETCh:TXPower:TSEQuence:INTegrity?

Function

 GSM TA

Queries the overall integrity indicator for all bursts of each test sequence steps. Zero indicates normal.

For non-zero integrity indicators, refer to Integrity Indicator .

The query returns measurement results in the following order: <Result for Step 1>, <Result for Step 2>,..., <Result for Step 50>.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Range: See Integrity Indicator .

Resolution: 1
Requirements GSM/GPRS/
EGPRS TA

Revision: A.08 and above, with the required feature license.

GSM/GPRS/ EGPRS LA

Revision: E.02 and above.

Programming Example

OUTPUT 714;"FETCh:TXPower:TSEQuence:INTegrity?
! Query the integrity indicator for all the test sequence steps.

FETCh:TXPower:TSEQuence:MODulation:FORMat?<sp>[<Burst>]

Function

 GSM TA

Queries the modulation format for the specified burst across all test sequence steps.

See Note 1 for more information about how to use the command.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Range: GMSK | EPSK | MIXed | UNKNown.
Requirements GSM/GPRS/
EGPRS TA

Revision: A.08 and above, with the required feature license.
GSM/GPRS/ EGPRS LA

Revision: E.02 and above.

Programming Example

OUTPUT 714;"FETCh:TXPower:TSEQuence:MODulation:FORMat? 3
! Query the modulation format for all the test sequence steps of burst 3.

Note 1

The query returns measurement results of a specified burst for all uplink sequence steps in the following order: <Result for Step 1>, <Result for Step 2>,..., <Result for Step 50>. The commands contain an optional parameter that defines which burst in the TDMA frame is queried. If the optional parameter is omitted, then the results of the burst specified by "Measurement Burst" are returned.

Note 2

The query returns measurement results of all bursts for a specified uplink sequence step. The commands contain a mandatory parameter that defines which step is queried. The commands return the measurement results in the following order: <Result for Burst 1>, <Result for Burst 2>, <Result for Burst 3>, <Result for Burst 4>, <Result for Burst 5>, <Result for Burst 6>, <Result for Burst 7>, <Result for Burst 8>. only the results for the burst within the uplink burst numbers are valid. The Result of Burst 8 is always invalid.

Note 3

The query returns measurement results of one burst for a specified uplink sequence step. The commands contain a mandatory parameter that defines which step is queried and a optional parameter that defines which burst in the TDMA frame is queried. If the optional parameter is omitted, then the results of the burst specified by Measurement Burst are returned.


GFDTune:DOWNlink

GFDTune:DOWNlink

The following commands are only applicable to lab applications or the feature-licensed test applications.

GPIB Command Conventions

  • GFDTune:DOWNlink:SSTep:[:ALL]
  • GFDTune:DOWNlink:SSTep:ARFCn
  • GFDTune:DOWNlink:SSTep:BURSt:TYPE:TSLot<0|1|2|3|4|5>
  • GFDTune:DOWNlink:SSTep:FREQuency
  • GFDTune:DOWNlink:SSTep:PLEVel:FRAMe
  • GFDTune:DOWNlink:SSTep:REPeat
  • GFDTune:DOWNlink:SSTep:TRIGger:FRAMe
  • GFDTune:DOWNlink:SSTep:TRIGger:STATe
  • GFDTune:DOWNlink:SSTep:TRIGger:TSLot
  • GFDTune:DOWNlink:TSEQuence:ARFCn
  • GFDTune:DOWNlink:TSEQuence:BURSt:TYPE:TSLot<0|1|2|3|4|5>
  • GFDTune:DOWNlink:TSEQuence:CONTinuous
  • GFDTune:DOWNlink:TSEQuence:FREQuency
  • GFDTune:DOWNlink:TSEQuence:PLEVel:FRAMe
  • GFDTune:DOWNlink:TSEQuence:PLEVel:TSLot<0|1|2|3|4|5>
  • GFDTune:DOWNlink:TSEQuence:PLEVel<1|2|3|4>
  • GFDTune:DOWNlink:TSEQuence:REPeat
  • GFDTune:DOWNlink:TSEQuence:SSTep[:COUNt]
  • GFDTune:DOWNlink:TSEQuence:STARt
  • GFDTune:DOWNlink:TSEQuence:STOP
  • GFDTune:DOWNlink:TSEQuence:TRIGger:FRAMe
  • GFDTune:DOWNlink:TSEQuence:TRIGger:STATe
  • GFDTune:DOWNlink:TSEQuence:TRIGger:TSLot

GFDTune:DOWNlink:SSTep:[:ALL]

Function

 GSM TA

This command sets/queries all the DTS parameters for a specified range of DSSs. The command has a comma separated list of parameters in the following order: <The first DSS>, <The last DSS>, <Frequency>, <Repeat Count>, <Frame Power Level Allocation>, <Burst Type 1>, <Burst Type 2>, <Burst Type 3>, <Burst Type 4>, <Burst Type 5>, <Burst Type 6>.

See Note1 for more information on how to use this command.

See DTS Parameters for additional information.

GPRS TA

EGPRS TA
GSM/GPRS LA

EGPRS LA

Setting

Frequency

  • Range: 400 to 630 MHz (Band 1), 630 to 1000 MHz (Band 2), 1550 to 2400 MHz (Band 3)
  • Resolution: 1Hz

Repeat Count

  • Range: 1 to 1000
  • Resolution: 1

Frame Power Level Allocation

  • Range: PL1|PL2|PL3|PL4|MIXed

Burst Type

  • Range: OFF|FCB|FSB|DSB|DUMMY|PRBS

Query

 Same as setting.

*RST Setting

 939MHz, 1, MIXed, DUMMY, DUMMY, DUMMY, DUMMY, DUMMY, DUMMY
Requirements GSM/GPRS/
EGPRS TA

Revision: A.08 and above, with the required feature license.

GSM/GPRS EGPRS LA

Revision: E.02 and above.

Programming Example

OUTPUT 714;"GFDTune:DOWNlink:SSTep:ALL 1,2,9e+8,2,PL1,FCB,FSB,DUMMY,DUMMY,DUMMY,DUMMY"
! Sets the frequency, repeat count, frame power level allocation and burst type for both DSS 1 and 2.
OUTPUT 714;"GFDTune:DOWNlink:SSTep:ALL 1?
! Queries all the DTS parameters for DSS 1.

GFDTune:DOWNlink:SSTep:ARFCn

Function

 GSM TA

The command has no query form.

This command sets ARFCN for a specified range of DSSs in the following order: <Band Parameter>, <ARFCN>.

The <Band Parameter> is optional and specifies whether ARFCNs common to both the DCS and PCS bands should be treated as DCS or PCS, DCS or PCS has no meaning for ARFCNs corresponding to other bands. If the band parameter is not specified, DCS is assumed.

See Note1 for more information on how to use this command.

See DTS Parameters for additional information.

GPRS TA

EGPRS TA
GSM/GPRS LA

EGPRS LA
Setting

Range:

  • DCS band, channels 512 to 885
  • EGSM band, channels 0 to 124 and 975 to 1023
  • GSM450 band, channels 259 to 293
  • GSM480 band, channels 306 to 340
  • GSM750 band, channels 438 to 511
  • GSM850 band, channels 128 to 251
  • PCS band, channels 512 to 810
  • PGSM band, channels 1 to 124
  • RGSM band, channels 0 to 124 and 955 to 1023
  • TGSM810 band, channels 350 to 425

Resolution: 1
*RST setting

30
Requirements GSM/GPRS/
EGPRS TA

Revision: A.08 and above, with the required feature license.

GSM/GPRS EGPRS LA

Revision: E.02 and above.

Programming Example

OUTPUT 714;"GFDTune:DOWNlink:SSTep:ARFCn 1,3,PCS,512,PCS,513,PCS,514"
! Sets the ARFCN of DSS 1-3 to 512, 513 and 514 respectively in the PCS band.

GFDTune:DOWNlink:SSTep:BURSt:TYPE:TSLot<0|1|2|3|4|5>

Function

 GSM TA

This command sets/queries the Burst Type (per timeslot) of the timeslot 0 to 5 for a specified range of DSSs.

See Note1 for more information on how to use this command.

See DTS Parameters for additional information.

GPRS TA

EGPRS TA
GSM/GPRS LA

EGPRS LA

Setting

 Range: OFF|FCB|FSB|DSB|DUMMY|PRBS|EPSK_PRBS

Query

 Same as setting.

*RST Setting

DUMMY
Requirements GSM/GPRS/
EGPRS TA

Revision: A.08 and above, with the required feature license.

GSM/GPRS EGPRS LA

Revision: E.02 and above

Programming Example

OUTPUT 714;"GFDTune:DOWNlink:SSTep:BURSt:TYPE:TSLot0 1,2,FCB,FSB"
! Sets the burst type of timeslot 0 for DSS 1-2 to FCB and FSB respectively.

GFDTune:DOWNlink:SSTep:FREQuency

Function

 GSM TA

This command sets/queries the DTS Frequency for a specified range of DSSs.

See Note1 for more information on how to use this command.

See DTS Parameters for additional information.

GPRS TA

EGPRS TA
GSM/GPRS LA

EGPRS LA

Setting

Range: 400 to 630 MHz (Band 1), 630 to 1000 MHz (Band 2), 1550 to 2400 MHz (Band 3)

Resolution: 1 Hz

Query

 Same as setting.

*RST Setting

939 MHz
Requirements GSM/GPRS/
EGPRS TA

Revision: A.08 and above, with the required feature license.

GSM/GPRS EGPRS LA

Revision: E.02 and above.

Programming Example

OUTPUT 714;"GFDTune:DOWNlink:SSTep:FREQuency 1,4,850,900,950,1000,1000"
! Sets the frequency for DSS 1-4 to 850, 900, 950, 1000, and 1000MHz respectively.

GFDTune:DOWNlink:SSTep:PLEVel:FRAMe

Function

 GSM TA

This command sets/queries the Frame Power Level Allocation for a specified range of DSSs.

See Note1 for more information on how to use this command.

See DTS Parameters for additional information.

GPRS TA

EGPRS TA
GSM/GPRS LA

EGPRS LA

Setting

Range: PL1 | PL2 | PL3 | PL4 | MIXed

Query

 Same as setting.

*RST Setting

 MIXed
Requirements GSM/GPRS/
EGPRS TA

Revision: A.08 and above, with the required feature license.

GSM/GPRS EGPRS LA

Revision: E.02 and above.

Programming Example

OUTPUT 714;"GFDTune:DOWNlink:SSTep:PLEVel:FRAMe 1,10,MIXed"
! Sets the frame power level allocation for DSS 1-10 to MIXed.

GFDTune:DOWNlink:SSTep:REPeat

Function

 GSM TA

This command sets/queries the Repeat Count parameter for a specified range of DSSs.

See Note1 for more information on how to use this command.

See DTS Parameters for additional information.

GPRS TA

EGPRS TA
GSM/GPRS LA

EGPRS LA

Setting

Range: 1 to 1000

Resolution: 1

Query

 Same as setting.

*RST Setting

 1
Requirements GSM/GPRS/
EGPRS TA

Revision: A.08 and above, with the required feature license.

GSM/GPRS EGPRS LA

Revision: E.02 and above.

Programming Example

OUTPUT 714;"GFDTune:DOWNlink:SSTep:REPeat 1,1,10"
! Sets the repeat count to 10 for DSS 1.

GFDTune:DOWNlink:SSTep:TRIGger:FRAMe

Function

 GSM TA

This command sets/queries the Trigger Frame parameter for a specified range of DSSs.

See Note1 for more information on how to use this command.

See DTS Parameters for additional information.

GPRS TA

EGPRS TA
GSM/GPRS LA

EGPRS LA

Setting

Range: 1 to 1000

Resolution: 1

Query

 Same as setting.

*RST Setting

1
Requirements GSM/GPRS/
EGPRS TA

Revision: A.08 and above, with the required feature license.

GSM/GPRS EGPRS LA

Revision: E.02 and above.

Programming Example

OUTPUT 714;"GFDTune:DOWNlink:SSTep:TRIGger:FRAMe 1,10,1"
! The trigger event occurs at the first frame in DSS 1-10.

GFDTune:DOWNlink:SSTep:TRIGger:STATe

Function

 GSM TA

This command sets/queries the Trigger State parameter for a specified range of DSSs.

See Note1 for more information on how to use this command.

See DTS Parameters for additional information.

GPRS TA

EGPRS TA
GSM/GPRS LA

EGPRS LA

Setting

Range: 0|1|ON|OFF

Query

 0|1.

*RST Setting

0
Requirements GSM/GPRS/
EGPRS TA

Revision: A.08 and above, with the required feature license.

GSM/GPRS EGPRS LA

Revision: E.02 and above.

Programming Example

OUTPUT 714;"GFDTune:DOWNlink:SSTep:TRIGger:STATe 1,4,ON"
! Enables the trigger event for DSS 1-4.

GFDTune:DOWNlink:SSTep:TRIGger:TSLot

Function

 GSM TA

This command sets/queries the Trigger Timeslot parameter for a specified range of DSSs.

See Note1 for more information on how to use this command.

See DTS Parameters for additional information.

GPRS TA

EGPRS TA
GSM/GPRS LA

EGPRS LA

Setting

Range: 0 to 5

Resolution: 1

Query

 Same as setting.

*RST Setting

0
Requirements GSM/GPRS/
EGPRS TA

Revision: A.08 and above, with the required feature license.

GSM/GPRS EGPRS LA

Revision: E.02 and above.

Programming Example

OUTPUT 714;"GFDTune:DOWNlink:SSTep:TRIGger:TSLot 1,4,0"
! The trigger event occurs at timeslot 0 for DSS 1-4.

GFDTune:DOWNlink:TSEQuence:ARFCn

Function

 GSM TA

The command has no query form.

This command sets ARFCN for all the DSSs in a DTS in the following order: <Band Parameter>, <ARFCN>. The number of element pairs in the command is given by the DTS Step Count . For example, if the DTS Step Count is 4, then the command should follow with four Band and ARFCN pairs.

Note that the <Band Parameter> is optional and specifies whether ARFCNs common to both the DCS and PCS bands should be treated as DCS or PCS, DCS or PCS has no meaning for ARFCNs corresponding to other bands. If this parameter is not specified, DCS is assumed.

See Note2 for more information on how to use this command.

See DTS Parameters for additional information.

GPRS TA

EGPRS TA
GSM/GPRS LA

EGPRS LA
Setting

Range:

  • DCS band, channels 512 to 885
  • EGSM band, channels 0 to 124 and 975 to 1023
  • GSM450 band, channels 259 to 293
  • GSM480 band, channels 306 to 340
  • GSM750 band, channels 438 to 511
  • GSM850 band, channels 128 to 251
  • PCS band, channels 512 to 810
  • PGSM band, channels 1 to 124
  • RGSM band, channels 0 to 124 and 955 to 1023
  • TGSM810 band, channels 350 to 425

Resolution: 1
*RST setting

30.
Requirements GSM/GPRS/
EGPRS TA

Revision: A.08 and above, with the required feature license.

GSM/GPRS EGPRS LA

Revision: E.02 and above.

Programming Example

OUTPUT 714;"GFDTune:DOWNlink:TSEQuence:SSTep 5" !Sets the DTS Step Count to 5.
OUTPUT 714;"GFDTune:DOWNlink:TSEQuence:ARFCn 975,8,66,124"
! Sets the ARFCN for the five DSSs to 975, 8, 66, 124 and 124 respectively.
! (The ARFCN of Step 5 is equal to Step 4 as there are only four parameters in the command.)

GFDTune:DOWNlink:TSEQuence:BURSt:TYPE:TSLot<0|1|2|3|4|5>

Function

 GSM TA

This command sets/queries the Burst Type (per timeslot) parameter for timeslot <n>, where <n> can be any integer from 0 to 5, for all the DSSs in a DTS.

See Note2 for more information on how to use this command.

GPRS TA

EGPRS TA
GSM/GPRS LA

EGPRS LA

Setting

 Range: OFF|FCB|FSB|DSB|DUMMY|PRBS

Query

 Same as setting.

*RST Setting

DUMMY
Requirements GSM/GPRS/
EGPRS TA

Revision: A.08 and above, with the required feature license.

GSM/GPRS EGPRS LA

Revision: E.02 and above.

Programming Example

OUTPUT 714;"GFDTune:DOWNlink:TSEQuence:SSTep 5" !Sets the DTS Step Count to 5.
OUTPUT 714;"GFDTune:DOWNlink:TSEQuence:BURSt:TYPE:TSLot0 FCB,DUMMY"
! Sets the burst type of timeslot 0 to FCB for the 1st DSS and DUMMY to DSS 2-5.
! (The burst type of DSS 3-5 are all equal to DSS 2 as there are only two parameters in the command.)

GFDTune:DOWNlink:TSEQuence:CONTinuous

Function

 GSM TA This command sets/queries the DTS Continuous parameter.

GPRS TA

EGPRS TA
GSM/GPRS LA

EGPRS LA

Setting

Range: 0|1|ON|OFF

Query

Range: 0|1

*RST Setting

0
Requirements GSM/GPRS/
EGPRS TA

Revision: A.08 and above, with the required feature license.

GSM/GPRS EGPRS LA

Revision: E.02 and above.

Programming Example

OUTPUT 714;"GFDTune:DOWNlink:TSEQuence:CONTinuous 0"
! Sets the DTS to be generated once.

GFDTune:DOWNlink:TSEQuence:FREQuency

Function

 GSM TA

This command sets/queries the DTS Frequency parameter for all the DSSs in a DTS.

See Note2 for more information on how to use this command.

GPRS TA

EGPRS TA
GSM/GPRS LA

EGPRS LA

Setting

Range: 400 to 630 MHz (Band 1), 630 to 1000 MHz (Band 2), 1550 to 2400 MHz (Band 3)

Resolution: 1 Hz

Query

 Same as setting.

*RST Setting

939 MHz
Requirements GSM/GPRS/
EGPRS TA

Revision: A.08 and above, with the required feature license.

GSM/GPRS EGPRS LA

Revision: E.02 and above.

Programming Example

OUTPUT 714;"GFDTune:DOWNlink:TSEQuence:SSTep 5" !Sets the DTS Step Count to 5.
OUTPUT 714;"GFDTune:DOWNlink:TSEQuence:FREQuency 8.5e+8, 9e+8, 9.5e+8, 1e+9"
! Sets the frequency for the five DSSs to 850, 900, 950, 1000 and 1000 MHz, respectively.
! (The frequency of Step 5 is equal to Step 4 as there are only four parameters in the command.)

GFDTune:DOWNlink:TSEQuence:PLEVel:FRAMe

Function

 GSM TA

This command sets/queries the Frame Power Level Allocation parameter for all the DSSs in a DTS.

See Note2 for more information on how to use this command.

GPRS TA

EGPRS TA
GSM/GPRS LA

EGPRS LA

Setting

Range: PL1 | PL2 | PL3 | PL4 |MIXed

Query

 Same as setting.

*RST Setting

 MIXed
Requirements GSM/GPRS/
EGPRS TA

Revision: A.08 and above, with the required feature license.

GSM/GPRS EGPRS LA

Revision: E.02 and above.

Programming Example

OUTPUT 714;"GFDTune:DOWNlink:TSEQuence:SSTep 5" !Sets the DTS Step Count to 5.
OUTPUT 714;"GFDTune:DOWNlink:TSEQuence:PLEVel:FRAMe PL1,MIXed"
! The power level of all the timeslots in DSS 1 must be PL1.
! The power level of all the timeslots in DSS 2-5 can be assigned power levels PL1 through PL4.

GFDTune:DOWNlink:TSEQuence:PLEVel:TSLot<0|1|2|3|4|5>

Function

 GSM TA

This command sets/queries the Power Levels per Timeslot parameter for timeslot <n>, where <n> can be any integer from 0 to 5.

GPRS TA

EGPRS TA
GSM/GPRS LA

EGPRS LA

Setting

Range: PL1|PL2|PL3|PL4

Query

 Same as setting.

*RST Setting

 PL1
Requirements GSM/GPRS/
EGPRS TA

Revision: A.08 and above, with the required feature license.

GSM/GPRS EGPRS LA

Revision: E.02 and above.

Programming Example

OUTPUT 714;"GFDTune:DOWNlink:TSEQuence:PLEVel:TSLot1 PL2"
! Sets the power levels of timeslot 1 for all the DSSs to PL2.

GFDTune:DOWNlink:TSEQuence:PLEVel<1|2|3|4>

Function

 GSM TA

This command set/queries the DTS Power Level .

GPRS TA

EGPRS TA
GSM/GPRS LA

EGPRS LA

Setting

Range: -160 to +40 dBm

Resolution: 0.01dB

Query

 Same as setting.

*RST Setting

 PL1
Requirements GSM/GPRS/
EGPRS TA

Revision: A.08 and above, with the required feature license.

GSM/GPRS EGPRS LA

Revision: E.02 and above.

Programming Example

OUTPUT 714;"GFDTune:DOWNlink:TSEQuence:PLEVel1 -50"
! Sets the power level 1 (PL1) to -50 dBm.

GFDTune:DOWNlink:TSEQuence:REPeat

Function

 GSM TA

This command sets/queries the Repeat Count parameter for all the DSSs in a DTS.

See Note2 for more information on how to use this command.

GPRS TA

EGPRS TA
GSM/GPRS LA

EGPRS LA

Setting

Range: 1 to 1000

Resolution: 1

Query

 Same as setting.

*RST Setting

1
Requirements GSM/GPRS/
EGPRS TA

Revision: A.08 and above, with the required feature license.

GSM/GPRS EGPRS LA

Revision: E.02 and above.

Programming Example

OUTPUT 714;"GFDTune:DOWNlink:TSEQuence:SSTep 5" !Sets the DTS Step Count to 5.
OUTPUT 714;"GFDTune:DOWNlink:TSEQuence:REPeat 10,1,1,2"
! Sets the repeat count for the DSS 1-5 to 10, 1, 1, 2 and 2 respectively.
! (The repeat count of Step 5 is equal to Step 4 as there are only four parameters in the command.)

GFDTune:DOWNlink:TSEQuence:SSTep[:COUNt]

Function

 GSM TA This command sets/queries the DTS Step Count parameter.

GPRS TA

EGPRS TA
GSM/GPRS LA

EGPRS LA

Setting

Range: 1 to 50

Resolution: 1

Query

 Same as setting.

*RST Setting

1
Requirements GSM/GPRS/
EGPRS TA

Revision: A.08 and above, with the required feature license.

GSM/GPRS EGPRS LA

Revision: E.02 and above.

Programming Example

OUTPUT 714;"GFDTune:DOWNlink:TSEQuence:SSTep 10"
! Sets the number of DSSs in the DTS to 10.

GFDTune:DOWNlink:TSEQuence:STARt

Function

 GSM TA This command starts the Downlink Test Sequence. See DTS Start for more information.

GPRS TA

EGPRS TA
GSM/GPRS LA

EGPRS LA
Requirements GSM/GPRS/
EGPRS TA

Revision: A.08 and above, with the required feature license.

GSM/GPRS EGPRS LA

Revision: E.02 and above.

Programming Example

OUTPUT 714;"GFDTune:DOWNlink:TSEQuence:STARt"
! Starts the transmission of DTS.

GFDTune:DOWNlink:TSEQuence:STOP

Function

 GSM TA This command stops the Downlink Test Sequence. See DTS Stop for more information.

GPRS TA

EGPRS TA
GSM/GPRS LA

EGPRS LA
Requirements GSM/GPRS/
EGPRS TA

Revision: A.08 and above, with the required feature license.

GSM/GPRS EGPRS LA

Revision: E.02 and above.

Programming Example

OUTPUT 714;"GFDTune:DOWNlink:TSEQuence:STOP"
! Stops the transmission of DTS.

GFDTune:DOWNlink:TSEQuence:TRIGger:FRAMe

Function

 GSM TA

This command sets/queries the Trigger Frame parameter at which the external trigger event occurs for all the DSSs in a DTS.

See Note2 for more information on how to use this command.

GPRS TA

EGPRS TA
GSM/GPRS LA

EGPRS LA

Setting

Range: 1 to 1000

Resolution: 1

Query

 Same as setting.

*RST Setting

1
Requirements GSM/GPRS/
EGPRS TA

Revision: A.08 and above, with the required feature license.

GSM/GPRS EGPRS LA

Revision: E.02 and above.

Programming Example

OUTPUT 714;"GFDTune:DOWNlink:TSEQuence:SSTep 5" !Sets the DTS Step Count to 5.
OUTPUT 714;"GFDTune:DOWNlink:TSEQuence:TRIGger:FRAMe 1,10,1"
! The external trigger event of DSS 1-5 occurs at 1st, 10th , 1st, 1st, and 1st frame respectively.

GFDTune:DOWNlink:TSEQuence:TRIGger:STATe

Function

 GSM TA

This command sets/queries the Trigger State parameter that controls the external trigger output for all the DSSs in a DTS.

See Note2 for more information on how to use this command.

GPRS TA

EGPRS TA
GSM/GPRS LA

EGPRS LA

Setting

Range: 0|1|ON|OFF

Query

 0|1

*RST Setting

0
Requirements GSM/GPRS/
EGPRS TA

Revision: A.08 and above, with the required feature license.

GSM/GPRS EGPRS LA

Revision: E.02 and above.

Programming Example

OUTPUT 714;"GFDTune:DOWNlink:TSEQuence:SSTep 5" !Sets the DTS Step Count to 5.
OUTPUT 714;"GFDTune:DOWNlink:TSEQuence:TRIGger:STATe 1,1,1,1,0"
! Enables the external trigger output for DSS 1-4 and diables the external trigger output for DSS 5.

GFDTune:DOWNlink:TSEQuence:TRIGger:TSLot

Function

 GSM TA

This command sets/queries the Trigger Timeslot on which the external trigger event occurs for all the DSSs in a DTS.

See Note2 for more information on how to use this command.

GPRS TA

EGPRS TA
GSM/GPRS LA

EGPRS LA

Setting

Range: 0 to 5

Resolution: 1

Query

 Same as setting.

*RST Setting

0
Requirements GSM/GPRS/
EGPRS TA

Revision: A.08 and above, with the required feature license.

GSM/GPRS EGPRS LA

Revision: E.02 and above.

Programming Example

OUTPUT 714;"GFDTune:DOWNlink:TSEQuence:SSTep 5" !Sets the DTS Step Count to 5.
OUTPUT 714;"GFDTune:DOWNlink:TSEQuence:TRIGger:TSLot 3,3, 2"
! The external trigger event occurs to timeslot 3 on DSS1, timeslot 3 on DSS2 and timeslot 2 on DSS 3-5.

Note1

This command sets/queries the DTS parameters for one or several DSSs. In the setting form, the first two parameters in the command indicate the first and last sequence step to which the following parameters apply. The subsequent parameters are specified as an array of values, where each element of the array correspond to a DSS. The test set compensates by using the value of the last element in the array when there are too few elements and by ignoring settings if there are too many elements in the array. In the querying form, the first parameter indicates the result of which sequence step is returned and the second parameter is omitted. You can only query the DTS parameters for one DSS at a time.

Note2

This command sets/queries the DTS parameters on a per DTS basis. The parameters in the command are specified as an array of values, where each element of the array corresponds to a DSS. The number of elements that should be specified in the array is given by the DTS Step Count . If these numbers contradict (that is, the DTS Step Count does not equal the number of array elements specified for the array), the test set compensates by using the value of the last element in the array when there are too few elements and by ignoring settings if there are too many elements in the array.


GFDTune:UPLink

GFDTune:UPLink

The following commands are only applicable to the lab applications or the feature-licensed test applications.

GPIB Command Conventions

  • GFDTune:UPLink:SSTep:ARFCn
  • GFDTune:UPLink:SSTep:FREQuency
  • GFDTune:UPLink:TSEQuence:ARFCn
  • GFDTune:UPLink:TSEQuence:BURSt:COUNt
  • GFDTune:UPLink:TSEQuence:BURSt1|2|3|4|5|6|7:STATe
  • GFDTune:UPLink:TSEQuence:FREQuency
  • GFDTune:UPLink:TSEQuence:SSTep[:COUNt]

GFDTune:UPLink:SSTep:ARFCn

Function

 GSM TA

The command has no query form.

This command sets ARFCN for a specified range of USSs in the following order: <Band Parameter>, <ARFCN>.

The <Band Parameter> is optional and specifies whether ARFCNs common to both the DCS and PCS bands should be treated as DCS or PCS, DCS or PCS has no meaning for ARFCNs corresponding to other bands. If the band parameter is not specified, DCS is assumed.

See Note1 for more information on how to use this command.

See UTS Parameters for additional information.

GPRS TA

EGPRS TA
GSM/GPRS LA

EGPRS LA
Setting

Range:

  • DCS band, channels 512 to 885
  • EGSM band, channels 0 to 124 and 975 to 1023
  • GSM450 band, channels 259 to 293
  • GSM480 band, channels 306 to 340
  • GSM750 band, channels 438 to 511
  • GSM850 band, channels 128 to 251
  • PCS band, channels 512 to 810
  • PGSM band, channels 1 to 124
  • RGSM band, channels 0 to 124 and 955 to 1023
  • TGSM810 band, channels 350 to 425

Resolution: 1
*RST setting

30.
Requirements GSM/GPRS/
EGPRS TA

Revision: A.08 and above, with the required feature license.

GSM/GPRS EGPRS LA

Revision: E.02 and above.

Programming Example

OUTPUT 714;"GFDTune:UPLink:SSTep:ARFCn 1,3,PCS,512"
! Sets the ARFCN of USS 1-3 to 512 in the PCS band.

GFDTune:UPLink:SSTep:FREQuency

Function

 GSM TA

This command sets/queries the frequency for a specified range of USSs.

See Note1 for more information on how to use this command.

See UTS Parameters for additional information.

GPRS TA

EGPRS TA
GSM/GPRS LA

EGPRS LA

Setting

Range: 292.2 to 645.5 MHz (Band 1), 645.5 to 1395.5 MHz (Band 2), and 1395.5 to 2700 MHz (Band 3)

Resolution: 1 Hz

Query

 Same as setting.

*RST Setting

896 MHz
Requirements GSM/GPRS/
EGPRS TA

Revision: A.08 and above, with the required feature license.

GSM/GPRS EGPRS LA

Revision: E.02 and above.

Programming Example

OUTPUT 714;"GFDTune:UPLink:SSTep:FREQuency 1,1,9e+8,"
! Sets the frequency of USS 1 to 900 MHz.

GFDTune:UPLink:TSEQuence:ARFCn

Function

 GSM TA

The command has no query form.

This command sets ARFCN for all the USSs in a UTS in the following order: <Band Parameter>, <ARFCN>. The number of element pairs in the command is given by the UTS Step Count . For example, if the UTS Step Count is 4, then the command should follow with four Band and ARFCN pairs.

Note that the <Band Parameter> is optional and specifies whether ARFCNs common to both the DCS and PCS bands should be treated as DCS or PCS, DCS or PCS has no meaning for ARFCNs corresponding to other bands. If this parameter is not specified, DCS is assumed.

See Note2 for more information on how to use this command.

See UTS Parameters for additional information.

GPRS TA

EGPRS TA
GSM/GPRS LA

EGPRS LA
Setting

Range:

  • DCS band, channels 512 to 885
  • EGSM band, channels 0 to 124 and 975 to 1023
  • GSM450 band, channels 259 to 293
  • GSM480 band, channels 306 to 340
  • GSM750 band, channels 438 to 511
  • GSM850 band, channels 128 to 251
  • PCS band, channels 512 to 810
  • PGSM band, channels 1 to 124
  • RGSM band, channels 0 to 124 and 955 to 1023
  • TGSM810 band, channels 350 to 425

Resolution: 1
*RST setting

30.
Requirements GSM/GPRS/
EGPRS TA

Revision: A.08 and above, with the required feature license.

GSM/GPRS EGPRS LA

Revision: E.02 and above.

Programming Example

OUTPUT 714;"GFDTune:UPLink:TSEQuence:SSTep 5" !Sets the UTS Step Count to 5
OUTPUT 714;"GFDTune:UPLink:TSEQuence:ARFCn 975, 8, 66 ,124"
! Sets the ARFCN for USS 1-5 to 975, 8, 66, 124 and 124 respectively.
! (The ARFCN of USS 5 is equal to USS 4 as there are only four parameters in the command.)

GFDTune:UPLink:TSEQuence:BURSt:COUNt

Function

 GSM TA

This command sets/queries the number of uplink bursts present in the TDMA frame for all the USSs in a UTS.

See Note2 for more information on how to use this command.

See UTS Parameters for additional information.

GPRS TA

EGPRS TA
GSM/GPRS LA

EGPRS LA

Setting

Range: 1 to 7

Resolution: 1

Query

 Same as setting.

*RST Setting

 1
Requirements GSM/GPRS/
EGPRS TA

Revision: A.08 and above, with the required feature license.

GSM/GPRS EGPRS LA

Revision: E.02 and above.

Programming Example

OUTPUT 714;"GFDTune:UPLink:TSEQuence:BURSt:COUNt 4"
! Sets the number of uplink bursts present to 4

GFDTune:UPLink:TSEQuence:BURSt1|2|3|4|5|6|7:STATe

Function

 GSM TA

This command sets/queries the transmission state of Burst N for all the USSs in a UTS. See UTS Burst State .

Note the burst transmission state of all the USSs are the same so the command only have one parameter.

See UTS Parameters for additional information.

GPRS TA

EGPRS TA
GSM/GPRS LA

EGPRS LA

Setting

Range: 1|ON|0|OFF
(Note, the state of Burst 1 can only be set to ON)

Query

 Range: 1|0

*RST Setting

 1|ON
Requirements GSM/GPRS/
EGPRS TA

Revision: A.09 and above, with the required feature license.

GSM/GPRS EGPRS LA

Revision: F.01 and above.

Programming Example

OUTPUT 714;"GFDTune:UPLink:TSEQuence:SSTep 5" !Sets the UTS Step Count to 5
OUTPUT 714;"GFDTune:UPLink:TSEQuence:BURSt2:STATe ON"
! Sets the transmission state of Burst 2 for USS 1-5 to ON.

GFDTune:UPLink:TSEQuence:FREQuency

Function

 GSM TA

This command sets/queries the frequency of all the USSs in a UTS.

See Note2 for more information on how to use this command.

See UTS Parameters for additional information.

GPRS TA

EGPRS TA
GSM/GPRS LA

EGPRS LA

Setting

Range: 292.2-645.5 MHz (Band 1), 645.5 to 1395.5 MHz (Band 2), and 1395.5 to 2700 MHz (Band 3)

Resolution: 1 Hz

Query

 Same as setting.

*RST Setting

896 MHz
Requirements GSM/GPRS/
EGPRS TA

Revision: A.08 and above, with the required feature license.

GSM/GPRS EGPRS LA

Revision: E.02 and above.

Programming Example

OUTPUT 714;"GFDTune:UPLink:TSEQuence:SSTep 5" !Sets the UTS Step Count to 5
OUTPUT 714;"GFDTune:UPLink:TSEQuence:FREQuency 8.5e+8, 9e+8, 9.5e+8, 1e+9"
! Sets the frequency for USS 1-5 to 850,900, 950, 1000 and 1000MHz respectively
! (The frequency of USS 5 is the same as USS 4 as there are only four parameters in the command.)

GFDTune:UPLink:TSEQuence:SSTep[:COUNt]

Function

 GSM TA

This command sets/queries the UTS Step Count parameter.

See UTS Parameters for additional information.

GPRS TA

EGPRS TA
GSM/GPRS LA

EGPRS LA

Setting

Range: 1 to 50

Resolution: 1

Query

Range: 1 to 50

Resolution: 1

*RST Setting

1
Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.08 and above, with the required feature license.

GSM/GPRS EGPRS LA

Revision: E.02 and above.

Programming Example

OUTPUT 714;"GFDTune:UPLink:TSEQuence:SSTep 10"
! Sets the number of Uplink Sequence Steps to 10.

Note1

This command sets/queries the UTS parameters for one or several USSs. In the setting form, the first two parameters in the command indicate the first and last sequence step to which the following parameters apply. The subsequent parameters are specified as an array of values, where each element of the array correspond to a USS. The test set compensates by using the value of the last element in the array when there are too few elements and by ignoring settings if there are too many elements in the array. In the querying form, the first parameter indicates the result of which sequence step is returned and the second parameter is omitted. You can only query the UTS parameters for one USS at a time.

Note2

This command sets/queries the UTS parameters on a per UTS basis. The parameters in the command are specified as an array of values, where each element of the array corresponds to a USS. The number of elements that should be specified in the array is given by the UTS Step Count . If these numbers contradict (that is, the UTS Step Count does not equal the number of array elements specified for the array), the test set compensates by using the value of the last element in the array when there are too few elements and by ignoring settings if there are too many elements in the array.


INITiate

INITiate

GPIB Command Conventions

  • INITiate:<measurement mnemonic>[:ON]
  • INITiate:<measurement mnemonic>:OFF
  • INITiate:COUNt?
  • INITiate:DONE?
  • INITiate:DONE:CLEar
  • INITiate:DONE:FLAG[:ALL]
  • INITiate:DONE:FLAG:<measurement mnemonic>
  • INITiate:ON?
  • INITiate:PCALibration:ARMed?
  • INITiate:TXPower:GFDTune:ARMed?

INITiate:<measurement mnemonic>[:ON]

Function

 GSM TA

Starts measurements with the test set.

The INITiate command is associated with the SETup command, and the FETCh? command, see SETup Subsystem and FETCh? Subsystem .

One or more measurements may be initiated on the same program line. See Concurrent Measurements .

This command is also used to activate a measurement. See INITiate Programming Examples (how INIT commands are used) .
GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"INITIATE:TXPOWER:ON" !Initiates a TX Power measurement.

OUTPUT 714;"INITIATE:TXPOWER;PFERROR:ON"
! Initiates TX Power and phase and frequency error measurements.

OUTPUT 714;"INITIATE:PVTIME;ORFSPECTRUM;FBERROR:ON"
! Initiates power versus time output RF spectrum, and fast bit error rate measurements.

INITiate:<measurement mnemonic>:OFF

Function

 GSM TA

Deactivates the selected measurement. See Measurement States .

Only one measurement can be deactivated at a time. To stop one or more measurements and leave them in the active state, see ABORt .
GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"INITIATE:TXPOWER:OFF"
! Deactivates TX power measurement.

INITiate:COUNt?

Function | GSM TA | Queries the number of measurements that have been initiated (that are active). See Measurement States .
 | GPRS TA
 | EGPRS TA
 | GSM/GPRS LA
 | EGPRS LA
Query |  | Range: 0 to 10 Resolution: 1 Note: Some measurements are mutually exclusive, and so cannot be run at the same time as others, and some measurement close all other measurements. See Concurrent Measurements .
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.01 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.01 and above

INITiate:DONE?

Function | GSM TA | Queries (one at a time) which measurements if any are available or have timed out. See Measurement Event Synchronization for details on how to use this command. See Measurement States to understand the test set's measurement states. See INITiate:DONE:FLAG:<measurement mnemonic> for include or exclude commands. Note that WAIT is returned when no measurements are done. NONE is returned when all measurements are done.
 | GPRS TA
 | EGPRS TA
 | GSM/GPRS LA
 | EGPRS LA
Query | GSM TA | Range: NONE|AAUD|BERR|DAUD|DPOW|FBER|FST|IQT|MTA|ORFS|PCAL |PFER|PVT| SMON| TXP|WAIT
 | GPRS TA | Range: NONE|BLER|DPOW|FST|GBER|IQT|ORFS|PCAL |PFER|PVT| SMON| TXP|WAIT
 | EGPRS TA | Range: NONE|BLER|DPOW|EDP|EMAC|ETXP|FST|GBER|IQT|ORFS|PCAL| PFER|PVT| SBER|SMON| TXP|WAIT
 | GSM/GPRS LA | Range: NONE|AAUD|BERR|BFI|BLER|DAUD|DPOW|FBER|FFER|FST|GBER| IQT|MTA|ORFS|PCAL| PFER|PVT|SFER|SMON| TXP|WAIT|IFER
 | EGPRS LA | Range: NONE|AAUD|BERR|BFI|BLER|DAUD|DPOW|EDP|EMAC|ETXP|FBER|FFER|FST|GBER|IQT|MTA|ORFS|PCAL| PFER|PVT|SBER|SFER| SMON| TXP|WAIT|IFER
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.01 and above Revision A.03 adds SBER Revision A.04 adds EDP and FST Revision A.06 with the required feature license adds PCAL
 | GSM/GPRS/ EGPRS LA | Revision: C.01 and above Revision C.03 adds BFI, FFER, and SBER Revision D.01 adds EDP, FST and IFER Revision D.03 adds PCAL Revision F.00.37 adds SFER

INITiate:DONE:CLEar

Function

 GSM TA

Clears the done flag from all measurements. See INITiate:DONE? .
GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"INITIATE:DONE:CLEAR"
! Clears done flag.

INITiate:DONE:FLAG[:ALL]

Function

 GSM TA

Specifies that all measurements are considered, (included or excluded) when the DONE? query is sent.

If a measurements trigger arm, see Trigger Arm (Single or Continuous) Description , has been left in continuous mode, the done flag for that measurement will toggle between DONE and WAIT, see INITiate:DONE? . The INITiate:DONE? query will probably not be able to catch the measurement at the instant it is done, therefore the measurement will never appear to be done. If a measurement trigger arm must be left in continuous mode the user should (exclude) it, using this command, from the INITiate:DONE? query results.

Once the INITiate:DONE:FLAG has been set to EXCLude for a measurement, you must send the INCLude command for that measurement in order to query that measurement with, the INITiate:DONE? query. The test set will reset an (excluded measurement) to be an (included measurement) at power on or with any form of preset, see Preset Descriptions .
GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Setting

Range

  • INCLude: include all measurements

  • EXCLude: exclude all measurements
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"INITIATE:DONE:FLAG:ALL EXCLUDE"
! Excludes all measurements from contributing the INITIATE:DONE? query,
! see "INITiate:DONE?" on page 6.

INITiate:DONE:FLAG:<measurement mnemonic>

Function

 GSM TA

Specifies which measurements are considered, (included or excluded) when the DONE? query is sent.

If a measurements trigger arm, see Trigger Arm (Single or Continuous) Description , has been left in continuous mode, the done flag for that measurement will toggle between DONE and WAIT, see INITiate:DONE? . The INITiate:DONE? query will not be able to catch the measurement at the instant it is done, therefore the measurement will never appear to be done. If a measurement trigger arm must be left in continuous mode the user should (exclude) it, using this command, from the INITiate:DONE? query results.

Once the INITiate:DONE:FLAG has been set to EXCLude for a measurement, the user must send the INCLude command for that measurement in order to query that measurement with, the INITiate:DONE? query. The test set will reset any (excluded measurement) to be an (included measurement) at power on or with any form of preset, see Preset Descriptions .
GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Setting

GSM TA

Range

  • INCLude

    • :AAUDio | :BERRor | :DAUDio | :DPOWer | :FBERror | :IQTuning | :MTAudio|:ORFSpectrum | :PCALibration |:PFERror | :PVTime | :SMONitor | :TXPower

  • EXCLude

    • :AAUDio | :BERRor |:DAUDio | :DPOWer | :FBERror | :IQTuning | :MTAudio|:ORFSpectrum | :PCALibration |:PFERror | :PVTime | :SMONitor | :TXPower

GPRS TA

Range

  • INCLude

    • :BLERror | :DPOWer | :GBERror | :IQTuning | :ORFSpectrum | :PCALibration |:PFERror | :PVTime | :SMONitor | :TXPower

  • EXCLude

    • :BLERror | :DPOWer | :GBERror | :IQTuning | :ORFSpectrum | :PCALibration |:PFERror | :PVTime | :SMONitor | :TXPower

EGPRS TA

Range

  • INCLude

    • :BLERror | :DPOWer |:EDPower| :EMACcuracy | :ETXPower | :GBERror | :IQTuning | :ORFSpectrum |:PCALibration | :PFERror | :PVTime |:SBERror |:SMONitor | :TXPower

  • EXCLude

    • :BLERror | :DPOWer |:EDPower| :EMACcuracy | :ETXPower | :GBERror | :IQTuning | :ORFSpectrum | :PCALibration |:PFERror | :PVTime |:SBERror |:SMONitor | :TXPower

GSM/GPRS LA

Range

  • INCLude

    • :AAUDio | :BERRor | :BFINdication | :BFI | :BLERror | :DAUDio | :DPOWer | :FBERror | :FFERate | :GBERror | :IQTuning | :MTAudio | :ORFSpectrum | :PCALibration |:PFERror | :PVTime | :SFERate | :SMONitor | :TXPower

  • EXCLude

    • :AAUDio | :BERRor | :BFINdication | :BFI | :BLERror | :DAUDio | :DPOWer | :FBERror | :FFERate | :GBERror | :IQTuning | :MTAudio | :ORFSpectrum | :PCALibration | :PFERror | :PVTime | :SFERate | :SMONitor | :TXPower

EGPRS LA

Range

  • INCLude

    • :AAUDio | :BERRor | :BFINdication | :BFI | :BLERror | :DAUDio | :DPOWer |:EDPower| :EMACcuracy | :ETXPower | :FBERror | :FFERate | :GBERror | :IQTuning | :MTAudio | :ORFSpectrum |:PCALibration | :PFERror | :PVTime | :SBERror | :SFERate | :SMONitor | :TXPower

  • EXCLude

    • :AAUDio | :BERRor | :BFINdication | :BFI | :BLERror | :DAUDio | :DPOWer |:EDPower| :EMACcuracy | :ETXPower | :FBERror | :FFERate | :GBERror | :IQTuning | :MTAudio | :ORFSpectrum |:PCALibration | :PFERror | :PVTime | :SBERror | :SFERate | :SMONitor | :TXPower
Related Topics

INITiate:DONE?

Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
Revision A.03 adds SBERror
Revision A.04 adds EDPower
Revision A.06 with the required feature license adds PCALibration
GSM/GPRS/ EGPRS LA

Revision: C.01 and above
Revision C.03 adds BFINdication|BFI, FFERate, and SBERror
Revision D.01 adds EDPower and IFERror
Revision D.03 adds PCALibration
Revision F.00.37 adds SFERate

Programming Example

OUTPUT 714;"INITIATE:DONE:FLAG:PFERROR EXCLUDE"
! Excludes PFERROR measurements from contributing to the INITIATE:DONE? query.

INITiate:ON?

Function | GSM TA | Queries the names of the measurements (none, one, or more than one) that are ON in a comma separated list of measurement mnemonics. See INITiate:<measurement mnemonic>[:ON] .
 | GPRS TA
 | EGPRS TA
 | GSM/GPRS LA
 | EGPRS LA
Query | GSM TA | Range: AAUD|BERR|DAUD|DPOW|FBER|FFER|IQT|MTA|NONE|ORFS| PCAL |PFER|PVT|SMON|TXP
 | GPRS TA | Range: BLER|DPOW|GBER|NONE|IQT|ORFS|PCAL|PFER |PVT|SMON|TXP
 | EGPRS TA | Range: BLER|DPOW|EDP|EMAC|ETXP|GBER|NONE|IQT|ORFS|PCAL|PFER |PVT|SBER|SMON|TXP
 | GSM/GPRS LA | Range: AAUD|BERR|BFI|BLER|DAUD|DPOW|FBER|FFER|GBER|IQT|MTA| NONE| ORFS|PCAL|PFER|PVT|SMON|TXP
 | EGPRS LA | Range: AAUD|BERR|BFI|BLER|DAUD|DPOW|EDP|EMAC|ETXP|FBER|FFER|GBER| IQT| MTA|NONE|ORFS|PCAL|PFER|PVT|SBER|SMON|TXP
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.01 and above Revision A.03 adds SBER Revision A.04 adds EDP Revision A.06 with the required feature license adds PCAL
 | GSM/GPRS/ EGPRS LA | Revision: C.01 and above Revision C.03 adds BFI, FFER, and SBER Revision D.01 adds EDP and IFER Revision D.03 adds PCALibration

INITiate:PCALibration:ARMed?

Function | GSM/GPRS TA | This command is not applicable to GSM TA.
 | EGPRS TA | This command is not applicable to GPRS TA.
 | GSM/GPRS LA | This command queries whether the hardware of the test set has been armed to accept PAvT Measurement. The GPIB bus will be hung untill the results is returned.
 | EGPRS TA
Query |  | Range: 0 | 1
*RST Setting |  | 0|OFF
Requirements | GSM/GPRS/ EGPRS LA | Revision: G.00.00 and above

INITiate:TXPower:GFDTune:ARMed?

Function | GSM TA | This command queries whether the hardware of the test set has been armed to accept input RF signal. The GPIB bus will be hung untill the results is returned.
 | GPRS TA
 | GSM/GPRS LA
 | EGPRS LA
 | EGPRS TA
Query |  | Range: 0 | 1
*RST Setting |  | 0|OFF
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.04 and above
 | GSM/GPRS/ EGPRS LA | Revision: E.01 and above


INITiate Subsystem

INITiate Subsystem

Syntax Diagrams and Command Descriptions

INITiate

Description

INITiate Command Functions

The INITiate subsystem is used to:

  • Start (activate) individual or multiple (concurrent) measurements.

  • Turn individual measurements off.

  • Determine the number of measurements currently active (INIT:COUNT?).

  • Determine the names of the measurements currently active (INIT:ON?).

  • Determine which measurements are finished (INIT:DONE?).

What Happens When a Measurement is INITiated?

When a measurement is started using INITiate commands, a new measurement cycle is started. If the selected measurement is currently in a measurement cycle, it is aborted. If a timeout is specified, the timeout period begins when a measurement is initiated.

NOTE
The INITiate subsystem is derived from SCPI, but has some modifications to make it more compatible with the manual operation of the test set. Most notably, the choice of single or continuous measurement triggering is made using the SETup subsystem.

INITiate Programming Examples (how INIT commands are used)

The INITiate command is used to start measurements. INITiate commands allow multiple measurements to be started without waiting for other measurement processes to complete. For example, the following code starts the Transmit Power and PFER measurements, and then uses the INITiate:DONE? command in a loop to query the status of these measurements, see Measurement Event Synchronization .

When the measurements are done, the FETCh command is used to acquire the results, and the results are entered into variables in the controlling application. The program ends when the INITiate:DONE? command returns the string "NONE" indicating that all initiated measurements have gone through the measuring state see Measurement States .

Trigger arming for each measurement is controlled in the SETup subsystem. The choices are single or continuous. The best practice (during remote operation) is to use single measurement mode. This simplifies the tasks of starting concurrent measurements, then using the INIT subsystem commands to determine which measurements are ready to be FETChed.

10 OUTPUT 714;"SETup:ALL:CONTinuous:OFF" ! selects single measurement mode
20 OUTPUT 714;"INITiate:TXPower;PFERror" ! starts TX power/phase frequency error measurement
30 LOOP
40 OUTPUT 714;"INITiate:DONE?" !query to find out if any measurements are done
50 ENTER 714;Meas_complete
60 SELECT Meas_complete$$
70 CASE "TXP" !tests for the string "TXP" which would indicate TX power measurement is done
80 OUTPUT 714;"FETCh:TXPower:POWer?" !Queries average TX power measurement
90 ENTER 714;Avg_tx_power
100 CASE "PFER"!tests for the string "PFER" which would indicate phase/frequency error measurement is done
110 OUTPUT 714;"FETCh:PFERror:RMS?" !Queries PFER maximum phase error measurement
120 ENTER 714;Max_phs_error
130 END SELECT
140 EXIT IF Meas_complete$ = "NONE"
150 END LOOP
160 END

INITiate commands should be sent only when the test set has finished performing any operations, such as handovers, that require settling. For example, the following code performs a handover to a new traffic channel using the :SEQ (sequential) appendage, then initiates a TX power measurement.

OUTPUT 714;"CALL:TCH:SEQ 65" !Hands over traffic channel to channel 65, waits for process
                             !to complete before accepting next command.
OUTPUT 714;"INITiate:TXPower" !Initiates TX power measurement


GSM/GPRS/EGPRS Listing of Commands

GSM/GPRS/EGPRS Listing of Commands

This section lists all of the available GPIB commands for the W-CDMA/HSDPA applications.

It is recommended that you print this topic because it provides a useful syntax reference for all of the available GSM/GPRS/EGPRS commands.

The GPIB commands in this topic are categorized by subsystem:

  • ABORt Subsystem
  • AFGenerator Subsystem
  • CALCulate Subsystem
  • CALibration Subsystem
  • CALL Subsystem
  • DISPlay Subsystem
  • FETCh Subsystem
  • INITiate Subsystem
  • READ Subsystem
  • RFANalyzer Subsystem
  • RFGenerator Subsystem
  • SETup Subsystem
  • STATus Subsystem
  • SYSTem Subsystem

ABORt Subsystem

  • ABORt[:ALL]
  • ABORt:<meas-mnemonic>

AFGenerator Subsystem

  • AFGenerator:COUPling
  • AFGenerator:FREQuency
  • AFGenerator:PULSe[:STATe]
  • AFGenerator:VOLTage[:SAMPlitude]
  • AFGenerator:VOLTage:AMPlitude
  • AFGenerator:VOLTage:STATe

CALCulate Subsystem

  • CALCulate:SMONitor:MARKer:ALL:STATe
  • CALCulate:SMONitor:MARKer[<n>] :AMPLitude?
  • CALCulate:SMONitor:MARKer[<n>]:FREQuency
  • CALCulate:SMONitor:MARKer[<n>] :MODE
  • CALCulate:SMONitor:MARKer:PEAK:EXCursion[:LEVel]
  • CALCulate:SMONitor:MARKer[<n>] :PEAK:MAXimum
  • CALCulate:SMONitor:MARKer:PEAK:THReshold[:LEVel]
  • CALCulate:SMONitor:MARKer[<n>] [:SET]:EXPected:POWer
  • CALCulate:SMONitor:MARKer[<n>] [:SET]:EXPected:FREQuency
  • CALCulate:SMONitor:MARKer[<n>]:STATe
  • CALCulate:SMONitor:MARKer[<n>]:TIME

CALibration Subsystem

  • CALibration:BMOFfset:INFormation?
  • CALibration:DAPower:INFormation?
  • CALibration:DATE
  • CALibration:IQ[:1]?
  • CALibration:IQ1:INFormation?
  • CALibration:IQ2?
  • CALibration:IQ2:INFormation?
  • CALibration:SMONitor?
  • CALibration:SMONitor:INFormation?

CALL Subsystem

  • CALL:ASTRatum?

  • CALL:ATTached[:STATe]?

  • CALL[:CELL]:BA:TABLe[:SELected]
  • CALL[:CELL]:BA:TABLe:NCELl<n>[:STATe]:<band>
  • CALL[:CELL]:BA:TABLe:NCELl<n>:ARFCn:<band>
  • CALL[:CELL]:BA:TABLe:NCELl<n>:BCCode:<band>
  • CALL[:CELL]:BA:TABLe:NCELl<n>:NCCode:<band>
  • CALL[:CELL]:BA:TABLe:NCELl<n>:RPRiority:<band>
  • CALL[:CELL]:BA:TABLe:POINts[:SELected]?

  • CALL[:CELL]:BAND<[:SELected]|:GSM>

  • CALL[:CELL]:BCCode

  • CALL[:CELL]:BCHannel[:ARFCn][:SELected]
  • CALL[:CELL]:BCHannel:BEPPeriod
  • CALL[:CELL]:BCHannel:BEPPeriod2[:SVALue]
  • CALL[:CELL]:BCHannel:BEPPeriod2:STATe
  • CALL[:CELL]:BCHannel:BEPPeriod2:VALue
  • CALL[:CELL]:BCHannel:BSEQuence:CVALue:MAXimum
  • CALL[:CELL]:BCHannel:CBAR:ACCess
  • CALL[:CELL]:BCHannel:CBAR:QUALify
  • CALL[:CELL]:BCHannel:CIDentity
  • CALL[:CELL]:BCHannel:CRHYsteresis
  • CALL[:CELL]:BCHannel:CROFfset
  • CALL[:CELL]:BCHannel:DRXTimer:MAXimum
  • CALL[:CELL]:BCHannel:MREPorting
  • CALL[:CELL]:BCHannel:MSCRevision
  • CALL[:CELL]:BCHannel:MS:POWer:OFFSet:DCS
  • CALL[:CELL]:BCHannel:MS:TXLevel[:SELected]
  • CALL[:CELL]:BCHannel:N:AVGI
  • CALL[:CELL]:BCHannel:NCCPermitted
  • CALL[:CELL]:BCHannel:NCONtrol:RPERiod:IDLE
  • CALL[:CELL]:BCHannel:NCONtrol:RPERiod:TRANsferring
  • CALL[:CELL]:BCHannel:NCORder
  • CALL[:CELL]:BCHannel:PCMChannel
  • CALL[:CELL]:BCHannel:PTIMe
  • CALL[:CELL]:BCHannel:REPorting:RATE
  • CALL[:CELL]:BCHannel:REPorting:TYPE
  • CALL[:CELL]:BCHannel:RLAMinimum
  • CALL[:CELL]:BCHannel:SBReporting
  • CALL[:CELL]:BCHannel:SCELl
  • CALL[:CELL]:BCHannel:SORD
  • CALL[:CELL]:BCHannel:T:AVGT
  • CALL[:CELL]:BCHannel:T:AVGW
  • CALL[:CELL]:BCHannel:TOFFset
  • CALL[:CELL]:BCHannel:TYPE

  • CALL[:CELL]:BINDicator

  • CALL:BURSt:TYPE[:SELected]

  • CALL:CA:TABLe
  • CALL:CA:TABLe:POINts?

  • CALL[:CELL]:CCNactive:GSM[:STATe]
  • CALL[:CELL]:CCNactive:UTRan[:STATe]

  • CALL:CONNected[:STATe]?
  • CALL:CONNected:ARM[:IMMediate]
  • CALL:CONNected:ARM:STATe?
  • CALL:CONNected:TIMeout

  • CALL:COUNt:CBURst?

  • CALL:COUNt:CDERror?

  • CALL:COUNt:CLEar[:ALL]
  • CALL:COUNt:CLEar:BAERror
  • CALL:COUNt:CLEar:MS:IP
  • CALL:COUNt:CLEar:RAPage

  • CALL:COUNt:DTMonitor:CLEar
  • CALL:COUNt:DTMonitor[:ALL]:DISPlay:DRATe:(STARt | STOP)
  • CALL:COUNt:DTMonitor[:ALL]:DISPlay:SPAN:TIME
  • CALL:COUNt:DTMonitor[:ALL]:TRACe:HISTory:UNUMber?
  • CALL:COUNt:DTMonitor:(IPRX|IPTX|OTARx|OTATx):DISPlay:STATe
  • CALL:COUNt:DTMonitor:(IPRX|IPTX|OTARx|OTATx):DRATe?
  • CALL:COUNt:DTMonitor:(IPRX|IPTX|OTARx|OTATx):TRACe?
  • CALL:COUNt:DTMonitor:(IPRX|IPTX|OTARx|OTATx):TRACe:HISTory?

  • CALL:COUNt:MBURst?

  • CALL:COUNt:MS:IP[:ALL]?
  • CALL:COUNt:MS:IP:RX?
  • CALL:COUNt:MS:IP:TX?

  • CALL:COUNt:PAGE?

  • CALL:COUNt:PRACh?

  • CALL:COUNt:RACH?

  • CALL:COUNt:TDMA:FNUMber[:SELected]?
  • CALL:COUNt:TDMA:FRAMes?

  • CALL:CPNumber<[:SELected]>
  • CALL:CPNumber:INCLusion
  • CALL:CPNumber:PLAN
  • CALL:CPNumber:PRESentation[:INDicator]
  • CALL:CPNumber:SCReening[:INDicator]
  • CALL:CPNumber:TYPE

  • CALL:DAINterface:PLAY:STARt
  • CALL:DAINterface:PLAY:STATus
  • CALL:DAINterface:PLAY:STOP
  • CALL:DAINterface:RECord:FORMat:AMR
  • CALL:DAINterface:RECord:STARt
  • CALL:DAINterface:RECord:STATus
  • CALL:DAINterface:RECord:STOP

  • CALL:DATA:PING[:ALL]?

  • CALL:DATA:PING:ICOunt?

  • CALL:DATA:PING:PACKets:RX?
  • CALL:DATA:PING:PACKets:TX?

  • CALL:DATA:PING:PLOSs?

  • CALL:DATA:PING:SETup:ALTernate:IP:ADDRess
  • CALL:DATA:PING:SETup:COUNt
  • CALL:DATA:PING:SETup:DEVice
  • CALL:DATA:PING:SETup:PACKet[:SIZE]
  • CALL:DATA:PING:SETup:TIMeout

  • CALL:DATA:PING:STARt

  • CALL:DATA:PING:STOP

  • CALL:DATA:PING:TIME[:AVERage]?
  • CALL:DATA:PING:TIME:MAXimum?
  • CALL:DATA:PING:TIME:MINimum?

  • CALL:DATA:RATE:CONFig[:EGPRs]

  • CALL:DCONnected[:STATe]?
  • CALL:DCONnected:ARM[:IMMediate]
  • CALL:DCONnected:ARM:STATe?
  • CALL:DCONnected:TIMeout

  • CALL:DEModulation:DELay

  • CALL[:CELL]:DTMode
  • CALL[:CELL]:DTMode:ENHanced

  • CALL:END

  • CALL:FUNCtion:CONNection:TYPE

  • CALL:FUNCtion:DATA:BLER:LLC:FCSequence
  • CALL:FUNCtion:DATA:BLER:POLLing:INTerval

  • CALL:FUNCtion:DATA:BLOCk:POLLing:INTerval[:SELected]
  • CALL:FUNCtion:DATA:BLOCk:POLLing:INTerval:ACKB
  • CALL:FUNCtion:DATA:BLOCk:POLLing:INTerval:AUTO

  • CALL:FUNCtion:DATA:BLOCk:POLLing:INTerva:BLER

  • CALL:FUNCtion:DATA:DETach

  • CALL:FUNCtion:DATA:ETSIA:PDUNit|PDU:COUNt

  • CALL:FUNCtion:DATA:FRAMe:STARt

  • CALL:FUNCtion:DATA:PAYLoad:PATTern[:OTHer]
  • CALL:FUNCtion:DATA:PAYLoad:PATTern[:OTHer]:MSOurce:BURSt<n>
  • CALL:FUNCtion:DATA:PAYLoad:PATTern:BLER
  • CALL:FUNCtion:DATA:PAYLoad:PATTern:ETSIB

  • CALL:FUNCtion:DATA:PUPLink:ACKNack:INTerval:EGPRs
  • CALL:FUNCtion:DATA:PUPLink:ACKNack:INTerval:GPRS

  • CALL:FUNCtion:DATA:START

  • CALL:FUNCtion:DATA:STOP

  • CALL:FUNCtion:EGPRs:DEMod

  • CALL:FUNCtion:TBTerror[:STATe]

  • CALL[:CELL]:G850MNCode[:SVALue]
  • CALL[:CELL]:G850MNCode:VALue
  • CALL[:CELL]:G850MNCode:STATe

  • CALL:HANDover|HANDoff[:IMMediate]
  • CALL:HANDover|HANDoff:EXTernal[:IMMediate]
  • CALL:HANDover|HANDoff:EXTernal:INFormation:FSYNch:STATus?
  • CALL:HANDover|HANDoff:EXTernal:INFormation:OTDifference?
  • CALL:HANDover|HANDoff:EXTernal:PSWitched[:STATe]
  • CALL:HANDover|HANDoff:EXTernal:SYNChronize:INDication[:STATe]
  • CALL:HANDover|HANDoff:EXTernal:SYNChronize:NCI[:STATe]
  • CALL:HANDover|HANDoff:EXTernal:SYNChronize:ROT[:STATe]
  • CALL:HANDover|HANDoff:EXTernal:SYNChronize:TADVance[:STATe]
  • CALL:HANDover|HANDoff:EXTernal:SYNChronize:TYPE
  • CALL:HANDover|HANDoff:FSYNchronize[:IMMediate]
  • CALL:HANDover|HANDoff:FSYNchronize:OFFSet:BIT
  • CALL:HANDover|HANDoff:FSYNchronize:OFFSet:FNUMber
  • CALL:HANDover|HANDoff:FSYNchronize:POWer:CORRection:GAIN

  • CALL[:CELL]:IATTach[:STATe]?

  • CALL:IMEI:AUTO

  • CALL[:CELL]:LACode
  • CALL[:CELL]:LACode[:SELected]
  • CALL[:CELL]:LACode:GSM

  • CALL[:CELL]:MCCode[:SELected]
  • CALL[:CELL]:MCCode:GSM

  • CALL[:CELL]:MNCode
  • CALL[:CELL]:MNCode[:SELected]
  • CALL[:CELL]:MNCode:GSM

  • CALL:MODulation[:FORMat]:CONTrol:AUTO
  • CALL:MODulation[:FORMat]:MANual:BURSt[1]|2|3|4|5|6|7

  • CALL:MORiginated:ALERting:DURation
  • CALL:MORiginated:CALL:RELease[:STATe]

  • CALL[:CELL]:MS:CCHannel:POWer:OFFSet:DCS

  • CALL:MS:DTX[:STATe]

  • CALL:MS:DNSServer:PRIMary:IP:ADDRess
  • CALL:MS:DNSServer:SECondary:IP:ADDRess

  • CALL:MS:IP:ADDRess[1]|2|3|4
  • CALL:MS:IP:ADDRess[1]|2|3|4:CONText:PRIMary:QOService
  • CALL:MS:IP:ADDRess[1]|2|3|4:CONText:SECondary1|2|3:QOService
  • CALL:MS:IP:ADDRess[1]|2|3|4:ROUTing:STATe

  • CALL:MS:LQMMode

  • CALL:MS:PATTach[:STATe]

  • CALL:MS:REPorted:BEP:GMSK|EPSK:CVARiance[:AVERage]|MAXimum|MINimum?
  • CALL:MS:REPorted:BEP:GMSK|EPSK:MEAN[:AVERage]|MAXimum|MINimum)?
  • CALL:MS:REPorted:BEP:GMSK|EPSK:TSLOT<0|1|2|3|4|5|6|7>[:AVERage]|MAXimum|MINimum?

  • CALL:MS:REPorted:CLEar

  • CALL:MS:REPorted:CVALue:AVERage?

  • CALL:MS:REPorted:ILEVel:TSLot<n>:AVERage?

  • CALL:MS:REPorted:DTMClass:EGPRs[:SELected]?
  • CALL:MS:REPorted:DTMClass:GPRS[:SELected]?

  • CALL:MS:REPorted:IMEI?

  • CALL:MS:REPorted:IMSI?

  • CALL:MS:REPorted:LACode?

  • CALL:MS:REPorted:MCCode?

  • CALL:MS:REPorted:MCLass:EGPRS[:SELected]?
  • CALL:MS:REPorted:MCLass:GPRS[:SELected]?

  • CALL:MS:REPorted:MEASurement:NCONtrol:ENHanced:NCELl[:GSM][:LAST]?
  • CALL:MS:REPorted:MEASurement:NCONtrol:ENHanced:NCELl[:GSM]:NEW?
  • CALL:MS:REPorted:MEASurement:NCONtrol:ENHanced:NCELl:FDD[:LAST]?
  • CALL:MS:REPorted:MEASurement:NCONtrol:ENHanced:NCELl:FDD:NEW?
  • CALL:MS:REPorted:MEASurement:NCONtrol:ENHanced:NCELl:FDD:POINts[:LAST]?
  • CALL:MS:REPorted:MEASurement:NCONtrol:ENHanced:NCELl:FDD:POINts:NEW?
  • CALL:MS:REPorted:MEASurement:NCONtrol:ENHanced:NCELl[:GSM]:POINts[:LAST]?
  • CALL:MS:REPorted:MEASurement:NCONtrol:ENHanced:NCELl[:GSM]:POINts:NEW?

  • CALL:MS:REPorted:MEASurement:NCONtrol:ILEVel[:LAST]?
  • CALL:MS:REPorted:MEASurement:NCONtrol:ILEVel:NEW?

  • CALL:MS:REPorted:MEASurement:NCONtrol:NCELl<n>:FDD[:LAST]?
  • CALL:MS:REPorted:MEASurement:NCONtrol:NCELl<n>:FDD:NEW?
  • CALL:MS:REPorted:MEASurement:NCONtrol:NCELl<n>[:GSM][:LAST]?
  • CALL:MS:REPorted:MEASurement:NCONtrol:NCELl<n>[:GSM]:NEW?
  • CALL:MS:REPorted:MEASurement:NCONtrol:NCELl:NUMBer[:LAST]?
  • CALL:MS:REPorted:MEASurement:NCONtrol:NCELl:NUMBer:NEW?
  • CALL:MS:REPorted:MEASurement:NCONtrol:NCELl<n>:RATechnology[:LAST]?
  • CALL:MS:REPorted:MEASurement:NCONtrol:NCELl<n>:RATechnology:NEW?

  • CALL:MS:REPorted:MEASurement:NCONtrol:NCMode[:LAST]?
  • CALL:MS:REPorted:MEASurement:NCONtrol:NCMode:NEW?

  • CALL:MS:REPorted:MEASurement:NCONtrol:RXLevel[:LAST]?
  • CALL:MS:REPorted:MEASurement:NCONtrol:RXLevel:NEW?

  • CALL:MS:REPorted:MEASurement:NCONtrol:TYPE[:LAST]?
  • CALL:MS:REPorted:MEASurement:NCONtrol:TYPE:NEW?

  • CALL:MS:REPorted:MEASurement:(PACCH|PACChannel):BEP:GMSK|EPSK:CVARiance[:AVERage]|MAXimum|MINimum?
  • CALL:MS:REPorted:MEASurement:(PACCH|PACChannel):BEP:GMSK|EPSK:MEAN[:AVERage]|MAXimum|MINimum?
  • CALL:MS:REPorted:MEASurement:(PACCH|PACChannel):BEP:GMSK|EPSK:TSLot<0|1|2|3|4|5|6|7>[:AVERage]|MAXimum|MINimum?

  • CALL:MS:REPorted:MEASurement:(PACCH|PACChannel):CVALue:AVERage?

  • CALL:MS:REPorted:MEASurement:(PACCH|PACChannel):ILEVel:TSLot<n>:AVERage?

  • CALL:MS:REPorted:MEASurement:(PACCH|PACChannel):RXQuality:AVERage?

  • CALL:MS:REPorted:MEASurement:(PACCH|PACChannel):SVARiance:AVERage?

  • CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):COUNt
  • CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):COUNt:CLEar

  • CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):ENHanced:NCELl[:GSM][:LAST]?
  • CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):ENHanced:NCELl[:GSM]:NEW?
  • CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):ENHanced:NCELl:FDD[:LAST]?
  • CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):ENHanced:NCELl:FDD:NEW?
  • CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):ENHanced:NCELl:FDD:POINts[:LAST]?
  • CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):ENHanced:NCELl:FDD:POINts:NEW?
  • CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):ENHanced:NCELl[:GSM]:POINts[:LAST]?
  • CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):ENHanced:NCELl[:GSM]:POINts:NEW?

  • CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):NCELl<n>:FDD[:LAST]?
  • CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):NCELl<n>:FDD:NEW?
  • CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):NCELl<n>[:GSM][:LAST]?
  • CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):NCELl<n>[:GSM]:NEW?
  • CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):NCELl:NUMBer[:LAST]?
  • CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):NCELl:NUMBer:NEW?
  • CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):NCELl<n>:RATechnology[:LAST]?
  • CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):NCELl<n>:RATechnology:NEW?

  • CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):RXLevel:FULL[:LAST]?
  • CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):RXLevel:FULL:NEW?
  • CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):RXLevel:SUB[:LAST]?
  • CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):RXLevel:SUB:NEW?

  • CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):RXQuality:FULL[:LAST]?
  • CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):RXQuality:FULL:NEW?
  • CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):RXQuality:SUB[:LAST]?
  • CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):RXQuality:SUB:NEW?

  • CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):TADVance[:LAST]?
  • CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):TADVance:NEW?

  • CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):TXLevel[:LAST]?
  • CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):TXLevel:NEW?

  • CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):TYPE[:LAST]?
  • CALL:MS:REPorted:MEASurement:(SACCH|SACChannel):TYPE:NEW?

  • CALL:MS:REPorted:MNCode?

  • CALL:MS:REPorted:NEIGhbour[1]?

  • CALL:MS:REPorted:ONUMber[:SELected]?
  • CALL:MS:REPorted:ONUMber:GSM?

  • CALL:MS:REPorted:PCLass[:SELected]?
  • CALL:MS:REPorted:PCLass:EPSK[:SELected]?
  • CALL:MS:REPorted:PCLass:GMSK[:SELected]?
  • CALL:MS:REPorted:PCLass:GSM?

  • CALL:MS:REPorted:REVision[:DIGital][:SELected]?
  • CALL:MS:REPorted:REVision[:DIGital]:GSM?

  • CALL:MS:REPorted:RXLevel[:LAST]?
  • CALL:MS:REPorted:RXLevel:NEW?

  • CALL:MS:REPorted:RXQuality:AVERage?
  • CALL:MS:REPorted:RXQuality[:LAST]?
  • CALL:MS:REPorted:RXQuality:NEW?

  • CALL:MS:REPorted:SBANd[:GMSK]?
  • CALL:MS:REPorted:SBANd:EPSK?

  • CALL:MS:REPorted:SVARiance:AVERage?

  • CALL:MS:REPorted:TADVance[:LAST]?
  • CALL:MS:REPorted:TADVance:NEW?

  • CALL:MS:REPorted:TXLevel[:LAST]?
  • CALL:MS:REPorted:TXLevel:NEW?

  • CALL:MS:TADVance[:SELected]
  • CALL:MS:TADVance:DCS
  • CALL:MS:TADVance:EGSM
  • CALL:MS:TADVance:GSM450
  • CALL:MS:TADVance:GSM480
  • CALL:MS:TADVance:GSM750
  • CALL:MS:TADVance:GSM850
  • CALL:MS:TADVance:PCS
  • CALL:MS:TADVance:PGSM
  • CALL:MS:TADVance:RGSM
  • CALL:MS:TADVance:TGSM810

  • CALL:MS:TX:BURSt:GPLength

  • CALL:MS:TX:FRAMe:SEGMentation

  • CALL:MS:TXLevel[:SELected]
  • CALL[:CELL]:MS:TXLevel:CCHannel[:SELected]

  • CALL[:CELL]:NCCode[:SELected]
  • CALL[:CELL]:NCCode:GSM

  • CALL[:CELL]:NITZone:UTIMe:DATE[:SELected]
  • CALL[:CELL]:NITZone:UTIMe:TIME[:SELected]
  • CALL[:CELL]:NITZone:TZONe[:LOCal][:SELected]
  • CALL[:CELL]:NITZone:DSTime[:HOURs][:SVALue][:SELected]
  • CALL[:CELL]:NITZone:DSTime[:HOURs]:VALue[:SELected]
  • CALL[:CELL]:NITZone:DSTime[:HOURs]:STATe[:SELected]
  • CALL[:CELL]:NITZone:SEND:GMM:REGistration[:STATe][:SELected]
  • CALL[:CELL]:NITZone:SEND:DATA:ORIGination[:STATe][:SELected]
  • CALL[:CELL]:NITZone:SEND:MM:REGistration[:STATe][:SELected]
  • CALL[:CELL]:NITZone:SEND:VOICe:ORIGination[:STATe][:SELected]
  • CALL[:CELL]:NITZone:SEND:TRANsport[:SELected]
  • CALL[:CELL]:NITZone:SEND[:IMMediate]
  • CALL[:CELL]:NITZone:UTIMe:UTC[:IMMediate]

  • CALL[:CELL]:NMOPeration

  • CALL:OPERating:MODE

  • CALL:ORIGinate
  • CALL:ORIGinate:TIMeout

  • CALL:(PACCH|PACChannel):PSI:PERiodic:LIST
  • CALL:(PACCH|PACChannel):PSI:PERiodic:TIME
  • CALL:(PACCH|PACChannel):PSINdication:RESPonse
  • CALL:(PACCH|PACChannel):PSInfo
  • CALL:(PACCH|PACChannel):PSInfo:CUSTom:PSI1|2|3|5|8|13|14[:STATe]
  • CALL:(PACCH|PACChannel):PSInfo:CUSTom:PSI3:BIS[:STATe]
  • CALL:(PACCH|PACChannel):PSInfo:CUSTom:PSI3:QUATer[:STATe]
  • CALL:(PACCH|PACChannel):SI
  • CALL:(PACCH|PACChannel):SI:CUSTom:SI1|2|3|4|13[:STATe]
  • CALL:(PACCH|PACChannel):SI:CUSTom:SI2:BIS[:STATe]
  • CALL:(PACCH|PACChannel):SI:CUSTom:SI2:TER[:STATe]
  • CALL:(PACCH|PACChannel):SI:CUSTom:SI2:QUATer[:STATe]

  • CALL:PAGing:IDENtity[:TYPE]
  • CALL:PAGing:IMSI
  • CALL:PAGing:MODE
  • CALL:PAGing:MFRames
  • CALL:PAGing:REPeat[:STATe][:SELected]
  • CALL:PAGing:REPeat[:STATe]:GSM

  • CALL[:CELL]:(PBCCH|PBCChannel)[:STATe]
  • CALL[:CELL]:(PBCCH|PBCChannel):BA:TABLe:NCELl<n>[:STATe]
  • CALL[:CELL]:(PBCCH|PBCChannel):BA:TABLe:NCELl<n>:ARFCn
  • CALL[:CELL]:(PBCCH|PBCChannel):BA:TABLe:NCELl<n>:BCCode
  • CALL[:CELL]:(PBCCH|PBCChannel):BA:TABLe:NCELl<n>:NCCode
  • CALL[:CELL]:(PBCCH|PBCChannel):BA:TABLe:NCELl<n>:RACode
  • CALL[:CELL]:(PBCCH|PBCChannel):BA:TABLe:NCELl<n>:RPRiority
  • CALL[:CELL]:(PBCCH|PBCChannel):MS:TXLevel[:SELected]
  • CALL[:CELL]:(PBCCH|PBCChannel):NCONtrol:NDRX:PERiod
  • CALL[:CELL]:(PBCCH|PBCChannel):PRACh:LENGth

  • CALL:PBPTest:RLCMac[:HEADer]:STATe

  • CALL[:CELL]:PCAType

  • CALL:(PDTCH|PDTChannel)[:ARFCn][:SELected]

  • CALL:(PDTCH|PDTChannel):ARAC:PRRequest[:STATe]

  • CALL:(PDTCH|PDTChannel):BAND

  • CALL:(PDTCH|PDTChannel):CSCHeme
  • CALL:(PDTCH|PDTChannel):CSCHeme:UPLink
  • CALL:(PDTCH|PDTChannel):CSCHeme:DOWNink

  • CALL:(PDTCH|PDTChannel):CUSTom:DATA

  • CALL:(PDTChannel|PDTCH):DLDCarrier[:STATe]

  • CALL:(PDTCH|PDTChannel):DOWNlink:CORRuption[:STATe]
  • CALL:(PDTCH|PDTChannel):DOWNlink:CORRuption:BURSt<[1]|2|3|4>[:STATe]
  • CALL:(PDTCH|PDTChannel):DOWNlink:CORRuption:PATTern
  • CALL:(PDTCH|PDTChannel):DOWNlink:CORRuption:SEQuence:CBURsts
  • CALL:(PDTCH|PDTChannel):DOWNlink:CORRuption:SEQuence:LENGth
  • CALL:(PDTCH|PDTChannel):DOWNlink:CORRuption:SYMBol:LENGth
  • CALL:(PDTCH|PDTChannel):DOWNlink:CORRuption:SYMBol:STARt

  • CALL:(PDTCH|PDTChannel):DTMode:ARFCn[:SELected]
  • CALL:(PDTCH|PDTChannel):DTMode:BAND
  • CALL:(PDTCH|PDTChannel):DTMode:CSCHeme:UPLink
  • CALL:(PDTCH|PDTChannel):DTMode:CSCHeme:DOWNlink
  • CALL:(PDTCH|PDTChannel):DTMode:CSWitched:HRSPeech:SCHannel
  • CALL:(PDTCH|PDTChannel):DTMode:CSWitched:MS:TXLevel[:SELected]
  • CALL:(PDTCH|PDTChannel):DTMode:CSWitched:TSLot
  • CALL:(PDTCH|PDTChannel):DTMode:FHOPping[:STATe]
  • CALL:(PDTCH|PDTChannel):DTMode:MCSCheme
  • CALL:(PDTCH|PDTChannel):DTMode:MS:GAMMa:BURSt<[1]|2|3|4>[:SELected]
  • CALL:(PDTCH|PDTChannel):DTMode:MS:TXLevel[:SELected]:BURSt<[1]|2|3|4|5>
  • CALL:(PDTCH|PDTChannel):DTMode:MSLot:CONFig
  • CALL:(PDTCH|PDTChannel):DTMode:MSLot:CONFig:CUSTom:TSLots
  • CALL:(PDTCH|PDTChannel):DTMode:MSLot:MEASurement:BURSt
  • CALL:(PDTCH|PDTChannel):DTMode:PZERo:LEVel
  • CALL:(PDTCH|PDTChannel):DTMode:TTI[:MODE]
  • CALL:(PDTCH|PDTChannel):DTMode:USFLag[:ASSigned]
  • CALL:(PDTCH|PDTChannel):DTMode:USFLag:UNASsigned[:MANual]

  • CALL:(PDTCH|PDTChannel):EGPRS:MAPPing

  • CALL:(PDTCH|PDTChannel):ESPolling

  • CALL:(PDTCH|PDTChannel):FHOPping[:STATe]
  • CALL:(PDTCH|PDTChannel):FHOPping:HSNumber
  • CALL:(PDTCH|PDTChannel):FHOPping:MAIOffset[:SELected]

  • CALL:(PDTCH|PDTChannel):IREDundancy[:STATe]

  • CALL:(PDTCH|PDTChannel):MA:MEASurement:ARFCN[:SELected]
  • CALL:(PDTCH|PDTChannel):MA:TABLe:CONFig:AUTO
  • CALL:(PDTCH|PDTChannel):MA:TABLe[:AUTO][:SELected]?
  • CALL:(PDTCH|PDTChannel):MA:TABLe[:AUTO]:POINts[:SELected]?
  • CALL:(PDTCH|PDTChannel):MA:TABLe:MANual[:SELected]
  • CALL:(PDTCH|PDTChannel):MA:TABLe:MANual:POINts[:SELected]?

  • CALL:(PDTCH|PDTChannel):MACCess
  • CALL:(PDTCH|PDTChannel):MACCess:FIXed:MOALlocation:STATe
  • CALL:(PDTCH|PDTChannel):MACCess:FIXed:MOALlocation:NUMBer
  • CALL:(PDTCH|PDTChannel):MACCess[:DYNamic]:USFLag[:ASSigned]
  • CALL:(PDTCH|PDTChannel):MACCess[:DYNamic]:USFLag[:ASSigned]:GRANularity
  • CALL:(PDTCH|PDTChannel):MACCess[:DYNamic]:USFLag:PERCent
  • CALL:(PDTCH|PDTChannel):MACCess[:DYNamic]:USFLag:UNASsigned[:MANual]
  • CALL:(PDTCH|PDTChannel):MACCess[:DYNamic]:USFLag:UNASsigned:MODE

  • CALL:(PDTCH|PDTChannel):MCSCheme
  • CALL:(PDTCH|PDTChannel):MCSCheme:EBPTest[:BURSt1]
  • CALL:(PDTCH|PDTChannel):MCSCheme:EBPTest:BURSt<2|3|4|5>
  • CALL:(PDTCH|PDTChannel):MCSCheme:PSCHeme
  • CALL:(PDTCH|PDTChannel):MCSCheme:SWITch[:STATe]
  • CALL:(PDTCH|PDTChannel):MCSCheme:SWITch:RESegment[:STATe]
  • CALL:(PDTCH|PDTChannel):MCSCheme:SWITch:RETRansmit

  • CALL:(PDTCH|PDTChannel):MS:ALPHa
  • CALL:(PDTCH|PDTChannel):MS:GAMMa:BURSt<[1]|2|3|4|5>[:SELected]
  • CALL:(PDTCH|PDTChannel):MS:OPSMode
  • CALL:(PDTCH|PDTChannel):MS:TADVance[:SELected]
  • CALL:(PDTCH|PDTChannel):MS:TADVance:CONTinuous
  • CALL:(PDTCH|PDTChannel):MS:TXLevel[:SELected]:BURSt<[1]|2|3|4|5>

  • CALL:(PDTCH|PDTChannel):MSLot:CONFig
  • CALL:(PDTCH|PDTChannel):MSLot:CONFig:CUSTom:TSLots
  • CALL:(PDTCH|PDTChannel):MSLot[:FIRSt]:DOWNlink:LOOPback[:BURSt]
  • CALL:(PDTCH|PDTChannel):MSLot:MEASurement:BURSt

  • CALL:(PDTCH|PDTChannel):PMESsage:NACChange:COMPletion
  • CALL:(PDTCH|PDTChannel):PMESsage:(PMORder|PMO):NC2[:STATe]
  • CALL:(PDTCH|PDTChannel):PMESsage:PNCData[:STATe]
  • CALL:(PDTCH|PDTChannel):PMESsage:PPTadvance
  • CALL:(PDTCH|PDTChannel):PMESsage:PTReconfig

  • CALL:(PDTCH|PDTChannel):POWer[:AMPLitude]:BURSt<[1]|2|3|4|5>?
  • CALL:(PDTCH|PDTChannel):POWer[:AMPLitude]:UBURst?
  • CALL:(PDTCH|PDTChannel):POWer[:AMPLitude]:UNUSed?

  • CALL:(PDTCH|PDTChannel):PREDuction:ADJacent
  • CALL:(PDTCH|PDTChannel):PREDuction:BURSt<[1]|2|3|4|5>
  • CALL:(PDTCH|PDTChannel):PREDuction:LEVel<1|2>
  • CALL:(PDTCH|PDTChannel):PREDuction:MODE
  • CALL:(PDTCH|PDTChannel):PREDuction:UBURst
  • CALL:(PDTCH|PDTChannel):PREDuction:UNUSed

  • CALL:(PDTCH|PDTChannel):PZERo:LEVel

  • CALL:(PDTCH|PDTChannel):RRBPeriod

  • CALL:(PDTCH|PDTChannel):TBFLow:DOWNlink:DELayed[:SDURation]
  • CALL:(PDTCH|PDTChannel):TBFLow:DOWNlink:DELayed:DURation
  • CALL:(PDTCH|PDTChannel):TBFLow:DOWNlink:DELayed:STATe
  • CALL:(PDTCH|PDTChannel):TBFLow:DOWNlink:FBIndicator:POLLing
  • CALL:(PDTCH|PDTChannel):TBFLow:DOWNlink:RETRansmit[:STATe]
  • CALL:(PDTCH|PDTChannel):TBFLow:REEStablish[:STATe]
  • CALL:(PDTCH|PDTChannel):TBFLow:UPLink:DLOSt:TIMer[:SDURation]
  • CALL:(PDTCH|PDTChannel):TBFLow:UPLink:DLOSt:TIMer:DURation
  • CALL:(PDTCH|PDTChannel):TBFLow:UPLink:DLOSt:TIMer:STATe
  • CALL:(PDTCH|PDTChannel):TBFLow:UPLink:EXTended:DURation

  • CALL:(PDTCH|PDTChannel):TTI[:MODE]

  • CALL:(PDTCH|PDTChannel):UPLink:RETRansmit:FORCe:PROBability[:STATe]
  • CALL:(PDTCH|PDTChannel):UPLink:RETRansmit:FORCe:PROBability:PERCentage
  • CALL:(PDTCH|PDTChannel):UPLink:RETRansmit:FORCe:PROBability:SPERcentage

  • CALL:(PDTCH|PDTChannel):USFlag
  • CALL:(PDTCH|PDTChannel):USFlag:RTTI[:MODE]

  • CALL:(PDTCH|PDTChannel):WINDow:SIZE[:ALL]
  • CALL:(PDTCH|PDTChannel):WINDow:SIZE:AUTO
  • CALL:(PDTCH|PDTChannel):WINDow:SIZE:OTHer
  • CALL:(PDTCH|PDTChannel):WINDow:SIZE:SELected

  • CALL:(PDTC2|PDTCH2|PDTChannel2):ARFCn[:SELected]

  • CALL:(PDTC2|PDTCH2|PDTChannel2):FHOPping[:STATe]
  • CALL:(PDTC2|PDTCH2|PDTChannel2):FHOPping:MAIOffset[:SELected]

  • CALL:(PDTC2|PDTCH2|PDTChannel2):MCSCheme:EBPTest[:BURSt1]
  • CALL:(PDTC2|PDTCH2|PDTChannel2):MCSCheme:EBPTest:BURSt<2|3|4|5>
  • CALL:(PDTC2|PDTCH2|PDTChannel2):MSLot:CONFig
  • CALL:(PDTC2|PDTCH2|PDTChannel2):MSLot:CONFig:CUSTom:TSLots

  • CALL:(PDTC2|PDTCH2|PDTChannel2):PZERo:LEVel
  • CALL:(PDTC2|PDTCH2|PDTChannel2):PREDuction:LEVel
  • CALL:(PDTC2|PDTCH2|PDTChannel2):PREDuction:BURSt<1|2|3|4|5>

  • CALL[:CELL]:PFContext[:STATe]

  • CALL:PLOGging:STARt
  • CALL:PLOGging:STOP
  • CALL:PLOGging:STATus? or CALL:PLOGging:STATe?
  • CALL:PLOGging:CONNected?
  • CALL:PLOGging:ACTive?

  • CALL[:CELL]:PMNCode[:SVALue]
  • CALL[:CELL]:PMNCode:VALue
  • CALL[:CELL]:PMNCode:STATe

  • CALL[:CELL]:POWer[:SAMPlitude][:SELected]
  • CALL[:CELL]:POWer[:SAMPlitude]:CW
  • CALL[:CELL]:POWer[:SAMPlitude]:GSM
  • CALL[:CELL]:POWer:AMPLitude[:SELected]
  • CALL[:CELL]:POWer:AMPLitude:CW
  • CALL[:CELL]:POWer:AMPLitude:GSM
  • CALL[:CELL]:POWer:STATe[:SELected]
  • CALL[:CELL]:POWer:STATe:CW
  • CALL[:CELL]:POWer:STATe:GSM

  • CALL:PPRocedure:ATTach:ACCept:IAReject:GMMCause
  • CALL:PPRocedure:ATTach:ACCept:IAReject:STATe
  • CALL:PPRocedure:ATTach:REJect:GMMCause
  • CALL:PPRocedure:ATTach:REJect:STATe

  • CALL:PPRocedure:DETach:REQuest[:IMMediate]
  • CALL:PPRocedure:DETach:REQuest:GMMCause
  • CALL:PPRocedure:DETach:REQuest:TYPE

  • CALL:PPRocedure:IDENtity:REQuest[:IMMediate]
  • CALL:PPRocedure:IDENtity:REQuest:RESults?
  • CALL:PPRocedure:IDENtity:REQuest:RESults:CLEar
  • CALL:PPRocedure:IDENtity:REQuest:TYPE

  • CALL:PPRocedure:LAU|LAUPdate:REJect[:STATe]
  • CALL:PPRocedure:LAU|LAUPdate:REJect:GMMCause
  • CALL:PPRocedure:LAU|LAUPdate:T3212

  • CALL:PPRocedure[:QOSProfile[1]|2|3|4]:PDPContext:AACCept:QOService:RCLass:SUBScribed
  • CALL:PPRocedure[:QOSProfile[1]|2|3|4]:PDPContext:AACCept:QOService:RCLass:ENForce:[SVALue]
  • CALL:PPRocedure[:QOSProfile[1]|2|3|4]:PDPContext:AACCept:QOService:RCLass:ENForce:STATe
  • CALL:PPRocedure[:QOSProfile[1]|2|3|4]:PDPContext:AACCept:QOService:RCLass:ENForce:VALue
  • CALL:PPRocedure:PDPContext:AREJect:SMCause
  • CALL:PPRocedure:PDPContext:AREJect:STATe
  • CALL:PPRocedure[:QOSProfile]:PDPContext:NINitiated[:STATe]
  • CALL:PPRocedure[:QOSProfile[1]|2|3|4]:PFI
  • CALL:PPRocedure[:QOSProfile[1]|2|3|4]:TCLass
  • CALL:PPRocedure[:QOSProfile[1]|2|3|4]:THPRiority

  • CALL:PPRocedure:PLMNetwork[:LIST]
  • CALL:PPRocedure:PLMNetwork[:LIST]:POINts?

  • CALL:PPRocedure:PMEasurement:ADATa:ACKNowledged?
  • CALL:PPRocedure:PMEasurement:ADATa:MAData
  • CALL:PPRocedure:PMEasurement:ADATa:MORE
  • CALL:PPRocedure:PMEasurement:ADATa:RAData
  • CALL:PPRocedure:PMEasurement:ADATa:REL98|RELEASE98
  • CALL:PPRocedure:PMEasurement:ADATa:SEND

  • CALL:PPRocedure:PMEasurement:MPRequest:MAData
  • CALL:PPRocedure:PMEasurement:MPRequest:MAData:BTS[<n>]:BCHCarrier
  • CALL:PPRocedure:PMEasurement:MPRequest:MAData:BTS[<n>]:BSICode
  • CALL:PPRocedure:PMEasurement:MPRequest:MAData:BTS[<n>]:CASSistance
  • CALL:PPRocedure:PMEasurement:MPRequest:MAData:BTS[<n>]:CASSistance:FRTDiff
  • CALL:PPRocedure:PMEasurement:MPRequest:MAData:BTS[<n>]:CASSistance:RALTitude
  • CALL:PPRocedure:PMEasurement:MPRequest:MAData:BTS[<n>]:CASSistance:RALTitude:VALue
  • CALL:PPRocedure:PMEasurement:MPRequest:MAData:BTS[<n>]:CASSistance:REASt
  • CALL:PPRocedure:PMEasurement:MPRequest:MAData:BTS[<n>]:CASSistance:RNORth
  • CALL:PPRocedure:PMEasurement:MPRequest:MAData:BTS[<n>]:MOFFset
  • CALL:PPRocedure:PMEasurement:MPRequest:MAData:BTS:NUMBer
  • CALL:PPRocedure:PMEasurement:MPRequest:MAData:BTS[<n>]:RRTDiff

  • CALL:PPRocedure:PMEasurement:MPRequest:PINStruction:ACCuracy
  • CALL:PPRocedure:PMEasurement:MPRequest:PINStruction:ACCuracy
  • CALL:PPRocedure:PMEasurement:MPRequest:PINStruction:ACCuracy:VALue
  • CALL:PPRocedure:PMEasurement:MPRequest:PINStruction:ECHaracter
  • CALL:PPRocedure:PMEasurement:MPRequest:PINStruction:ECHaracter:VALue
  • CALL:PPRocedure:PMEasurement:MPRequest:PINStruction:MSETs
  • CALL:PPRocedure:PMEasurement:MPRequest:PINStruction:MTYPe
  • CALL:PPRocedure:PMEasurement:MPRequest:PINStruction:RTIMe

  • CALL:PPRocedure:PMEasurement:MPRequest:RAData
  • CALL:PPRocedure:PMEasurement:MPRequest:RAData:BTSPosition
  • CALL:PPRocedure:PMEasurement:MPRequest:RAData:BTSPosition:ALTitude
  • CALL:PPRocedure:PMEasurement:MPRequest:RAData:BTSPosition:ALTitude:DIRection
  • CALL:PPRocedure:PMEasurement:MPRequest:RAData:BTSPosition:LATitude:DEGRees
  • CALL:PPRocedure:PMEasurement:MPRequest:RAData:BTSPosition:LATitude:SIGN
  • CALL:PPRocedure:PMEasurement:MPRequest:RAData:BTSPosition:LONGitude:DEGRees
  • CALL:PPRocedure:PMEasurement:MPRequest:RAData:BTSPosition:TYPe

  • CALL:PPRocedure:PMEasurement:MPRequest:REL98|RELEASE98
  • CALL:PPRocedure:PMEasurement:MPRequest:REL98|RELEASE98:BTS[<n>]:EOTDiff
  • CALL:PPRocedure:PMEasurement:MPRequest:REL98|RELEASE98:BTS[<n>]:EOTDiff:UNCertainty

  • CALL:PPRocedure:PMEasurement:MPRequest:SEND

  • CALL:PPRocedure:PMEasurement:MS:RESet

  • CALL:PPRocedure:PMEasurement:PERRor:CODE
  • CALL:PPRocedure:PMEasurement:PERRor:SEND

  • CALL:PPRocedure:PMEasurement:PIPE
  • CALL:PPRocedure:PMEasurement:PIPE:DATA:RX?
  • CALL:PPRocedure:PMEasurement:PIPE:DATA:RX:AVAilable?
  • CALL:PPRocedure:PMEasurement:PIPE:DATA:TX
  • CALL:PPRocedure:PMEasurement:PIPE:HEADer[:STATe]
  • CALL:PPRocedure:PMEasurement:PIPE:RTIMe
  • CALL:PPRocedure:PMEasurement:PIPE:SEND

  • CALL:PPRocedure:PMEasurement:PRESponse:AVAilable?

  • CALL:PPRocedure:PMEasurement:PRESponse:LIERror:INCLuded?
  • CALL:PPRocedure:PMEasurement:PRESponse:LIERror:REASon?

  • CALL:PPRocedure:PMEasurement:PRESponse:LINFormation:FTYPe?
  • CALL:PPRocedure:PMEasurement:PRESponse:LINFormation:INCLuded?
  • CALL:PPRocedure:PMEasurement:PRESponse:LINFormation:RFRame?
  • CALL:PPRocedure:PMEasurement:PRESponse:LINFormation:PESTimate:ALTitude?
  • CALL:PPRocedure:PMEasurement:PRESponse:LINFormation:PESTimate:ALTitude:DIRection?
  • CALL:PPRocedure:PMEasurement:PRESponse:LINFormation:PESTimate:ALTitude:UNCertainty?
  • CALL:PPRocedure:PMEasurement:PRESponse:LINFormation:PESTimate:CONFidence?
  • CALL:PPRocedure:PMEasurement:PRESponse:LINFormation:PESTimate:LATitude:DEGRees?
  • CALL:PPRocedure:PMEasurement:PRESponse:LINFormation:PESTimate:LATitude:SIGN?
  • CALL:PPRocedure:PMEasurement:PRESponse:LINFormation:PESTimate:LONGitude:DEGRees?
  • CALL:PPRocedure:PMEasurement:PRESponse:LINFormation:PESTimate:MAJor:ORIentation?
  • CALL:PPRocedure:PMEasurement:PRESponse:LINFormation:PESTimate:SMAJor:UNCertainty?
  • CALL:PPRocedure:PMEasurement:PRESponse:LINFormation:PESTimate:SMINor:UNCertainty?
  • CALL:PPRocedure:PMEasurement:PRESponse:LINFormation:PESTimate:TYPE?
  • CALL:PPRocedure:PMEasurement:PRESponse:LINFormation:PESTimate:UCODe?

  • CALL:PPRocedure:PMEasurement:PRESponse:MINFormation:LIERror:INCLuded?
  • CALL:PPRocedure:PMEasurement:PRESponse:MINFormation:SET[<n>]:BTS:BSICode?
  • CALL:PPRocedure:PMEasurement:PRESponse:MINFormation:SET[<n>]:BTS:CARRier?
  • CALL:PPRocedure:PMEasurement:PRESponse:MINFormation:SET[<n>]:BTS:CIDentity?
  • CALL:PPRocedure:PMEasurement:PRESponse:MINFormation:SET[<n>]:BTS:CITYpe?
  • CALL:PPRocedure:PMEasurement:PRESponse:MINFormation:SET[<n>]:BTS:LACode?
  • CALL:PPRocedure:PMEasurement:PRESponse:MINFormation:SET[<n>]:BTS:MEASurements:NUMBer?
  • CALL:PPRocedure:PMEasurement:PRESponse:MINFormation:SET[<n>]:BTS:MEASurements:SDEViation?
  • CALL:PPRocedure:PMEasurement:PRESponse:MINFormation:SET[<n>]:BTS:MOFFset?
  • CALL:PPRocedure:PMEasurement:PRESponse:MINFormation:SET[<n>]:BTS:NIPResent?
  • CALL:PPRocedure:PMEasurement:PRESponse:MINFormation:SET[<n>]:BTS:NUMBer?
  • CALL:PPRocedure:PMEasurement:PRESponse:MINFormation:SET[<n>]:BTS:OTDifference?
  • CALL:PPRocedure:PMEasurement:PRESponse:MINFormation:SET[<n>]:BTS:RINDex?
  • CALL:PPRocedure:PMEasurement:PRESponse:MINFormation:SET[<n>]:BTS:SIINdex?
  • CALL:PPRocedure:PMEasurement:PRESponse:MINFormation:SET[<n>]:BTS:TSLot?
  • CALL:PPRocedure:PMEasurement:PRESponse:MINFormation:SET[<n>]:FNUMber?
  • CALL:PPRocedure:PMEasurement:PRESponse:MINFormation:SET[<n>]:MREFerence:INCLuded?
  • CALL:PPRocedure:PMEasurement:PRESponse:MINFormation:SET[<n>]:MREFerence:NUMBer?
  • CALL:PPRocedure:PMEasurement:PRESponse:MINFormation:SET[<n>]:MREFerence:QUALity?
  • CALL:PPRocedure:PMEasurement:PRESponse:MINFormation:SET[<n>]:SRESolution?
  • CALL:PPRocedure:PMEasurement:PRESponse:MINFormation:SET[<n>]:TACorrection?
  • CALL:PPRocedure:PMEasurement:PRESponse:MINFormation:SET[<n>]:TACorrection:INCLuded?
  • CALL:PPRocedure:PMEasurement:PRESponse:MINFormation:SET[<n>]:TSLot?

  • CALL:PPRocedure:PMEasurement:PRESponse:MSETs:INCLuded?
  • CALL:PPRocedure:PMEasurement:PRESponse:MSETs:RBTS:NUMBer?
  • CALL:PPRocedure:PMEasurement:PRESponse:MSETs:RBTS:RELation?
  • CALL:PPRocedure:PMEasurement:PRESponse:MSETs:SETS:NUMBer?

  • CALL:PPRocedure:PMEasurement:PRESponse:RIDentity:BSICode?
  • CALL:PPRocedure:PMEasurement:PRESponse:RIDentity:CARRier?
  • CALL:PPRocedure:PMEasurement:PRESponse:RIDentity:CIDentity?
  • CALL:PPRocedure:PMEasurement:PRESponse:RIDentity:CITYpe?
  • CALL:PPRocedure:PMEasurement:PRESponse:RIDentity:INCLuded?
  • CALL:PPRocedure:PMEasurement:PRESponse:RIDentity:LACode?
  • CALL:PPRocedure:PMEasurement:PRESponse:RIDentity:RINDex?
  • CALL:PPRocedure:PMEasurement:PRESponse:RIDentity:SIINdex?

  • CALL:PPRocedure:RAU|RAUPdate:REJect[:STATe]
  • CALL:PPRocedure:RAU|RAUPdate:REJect:GMMCause
  • CALL:PPRocedure:RAU|RAUPdate:T3312

  • CALL:PPRocedure:T3314
  • CALL:PPRocedure:T3314:STATe

  • CALL[:CELL]:PSINdication

  • CALL[:CELL]:RACode<[:SELected]|:GSM>

  • CALL[:CELL]:RFGenerator:CONFigure
  • CALL[:CELL]:RFGenerator:FMBRoadcast:ADAPter:GAIN
  • CALL[:CELL]:RFGenerator:FMBRoadcast:CORRection:GAIN
  • CALL[:CELL]:RFGenerator:FMBRoadcast:CORRection:STATe
  • CALL[:CELL]:RFGenerator:FMBRoadcast:FREQuency
  • CALL[:CELL]:RFGenerator:FMBRoadcast:FM:INTernal:DEViation
  • CALL[:CELL]:RFGenerator:FMBRoadcast:FM:INTernal:FREQuency
  • CALL[:CELL]:RFGenerator:FMBRoadcast:FM:INTernal:STATe
  • CALL[:CELL]:RFGenerator:FMBRoadcast:POWer:AMPLitude
  • CALL[:CELL]:RFGenerator:FMBRoadcast:POWer:STATe
  • CALL[:CELL]:RFGenerator:FREQuency[:SELected]
  • CALL[:CELL]:RFGenerator:FREQuency:GSM

  • CALL[:CELL]:RFGenerator:GPS:BFILter
  • CALL[:CELL]:RFGenerator:GPS:FREQuency
  • CALL[:CELL]:RFGenerator:GPS:FREQuency2
  • CALL[:CELL]:RFGenerator:GPS:NMESsage
  • CALL[:CELL]:RFGenerator:GPS:POWer:AMPLitude
  • CALL[:CELL]:RFGenerator:GPS:POWer:STATe
  • CALL[:CELL]:RFGenerator:GPS:POWer[:SAMPLitude]
  • CALL[:CELL]:RFGenerator:GPS:RAW:PPATtern
  • CALL[:CELL]:RFGenerator:GPS:SVID

  • CALL:RTVocoder:DECoder:HEADroom[:SELected]?
  • CALL:RTVocoder:DECoder:HEADroom:GSM?
  • CALL:RTVocoder:ENCoder:HEADroom[:SELected]?
  • CALL:RTVocoder:ENCoder:HEADroom:GSM?
  • CALL:RTVocoder:INPut:VOLTage[:EXPected][:SELected]
  • CALL:RTVocoder:INPut:VOLTage[:EXPected]:GSM
  • CALL:RTVocoder:OUTPut:VOLTage[:MAXimum][:SELected]
  • CALL:RTVocoder:OUTPut:VOLTage[:MAXimum]:GSM
  • CALL:RTVocoder:VADetection[:STATe][:SELected]
  • CALL:RTVocoder:VADetection[:STATe]:GSM
  • CALL:RTVocoder:VADetection:AMRate:ALGorithm[:SELected]
  • CALL:RTVocoder:VADetection:AMRate:ALGorithm:GSM

  • CALL:(SACCH|SACChannel):LAPDModified:FORMat

  • CALL:SECurity:AUTHenticate:RANDom[:SELected]
  • CALL:SECurity:AUTHenticate:RESult[:MM][:SELected]?
  • CALL:SECurity:AUTHenticate:RESult:GMM[:SELected]?
  • CALL:SECurity:AUTHenticate:STATe
  • CALL:SECurity:AUTHenticate:XRESult[:SELected]
  • CALL:SECurity:CIPHering[:KEY]
  • CALL:SECurity:CIPHering:CKSNumber
  • CALL:SECurity:CIPHering:GPRS:ALGorithm
  • CALL:SECurity:CIPHering:GSM:ALGorithm

  • CALL:SETup:DTMode:ARFCn[:SELected]
  • CALL:SETup:DTMode:BAND
  • CALL:SETup:DTMode:CSCHeme
  • CALL:SETup:DTMode:CSCHeme:UPLink
  • CALL:SETup:DTMode:CSCHeme:DOWNlink
  • CALL:SETup:DTMode:CSWitched:HRSPeech:SCHannel
  • CALL:SETup:DTMode:CSWitched:MS:TXLevel[:SELected]
  • CALL:SETup:DTMode:CSWitched:TSLot
  • CALL:SETup:DTMode:FHOPping[:STATe]
  • CALL:SETup:DTMode:MCSCheme
  • CALL:SETup:DTMode:MS:TXLevel[:SELected]:BURSt<[1]|2|3|4|5>
  • CALL:SETup:DTMode:MSLot:CONFig
  • CALL:SETup:DTMode:MSLot:CONFig:CUSTom:TSLots
  • CALL:SETup:DTMode:PZERo:LEVel
  • CALL:SETup:DTMode:TTI:[MODE]
  • CALL:SETup:DTMode:USFLag[:ASSigned]

  • CALL:SETup:(PDTCH|PDTChannel)[:ARFCn][:SELected]
  • CALL:SETup:(PDTCH|PDTChannel):BAND
  • CALL:SETup:(PDTCH|PDTChannel):CSCHeme
  • CALL:SETup:(PDTCH|PDTChannel):CSCHeme:UPLink
  • CALL:SETup:(PDTCH|PDTChannel):CSCHeme:DOWNlink
  • CALL:SETup:(PDTChannel|PDTCH):DLDCarrier[:STATe]
  • CALL:SETup:(PDTCH|PDTChannel):MCSCheme
  • CALL:SETup:(PDTCH|PDTChannel):MS:GAMMa:BURSt<[1]|2|3|4|5>[:SELected]
  • CALL:SETup:(PDTCH|PDTChannel):MS:TXLevel[:SELected]:BURSt<[1]|2|3|4|5>
  • CALL:SETup:(PDTCH|PDTChannel):MSLot:CONFig
  • CALL:SETup:(PDTCH|PDTChannel):MSLot:CONFig:CUSTom:TSLots
  • CALL:SETup:(PDTCH|PDTChannel):PZERo:LEVel
  • CALL:SETup:(PDTCH|PDTChannel):TTI:[MODE]
  • CALL:SETup:(PDTCH|PDTChannel):USFLag

  • CALL:SETup:(PDTC2|PDTCH2|PDTChannel2):ARFCn[:SELected]
  • CALL:SETup:(PDTC2|PDTCH2|PDTChannel2):FHOPping[:STATe]
  • CALL:SETup:(PDTC2|PDTCH2|PDTChannel2):MSLot:CONFig
  • CALL:SETup:(PDTC2|PDTCH2|PDTChannel2):MSLot:CONFig:CUSTom:TSLots

  • CALL:SETup:TCHannel[:ARFCn][:SELected]
  • CALL:SETup:TCHannel:BAND
  • CALL:SETup:TCHannel:CMODe[:VALue]
  • CALL:SETup:TCHannel:CMODe:HRSPeech:SCHannel
  • CALL:SETup:TCHannel:CMODe:LSPeech:CHANnel
  • CALL:SETup:TCHannel:MS:TXLevel[:SELected]
  • CALL:SETup:TCHannel:TSLot

  • CALL:SIGNaling:MS:EPControl:MODE[:STATe]
  • CALL:SIGNaling:MS:EPControl:CONTinuous[:STATe]
  • CALL:SIGNaling:MS:EPControl:STEP:MAXimum
  • CALL:SIGNaling:MS:TXLevel:FACCH

  • CALL:SMService:CBRoadcast:MESSage[<n>]:CDATa
  • CALL:SMService:CBRoadcast:MESSage[<n>]:CODE
  • CALL:SMService:CBRoadcast:MESSage[<n>]:CONTent
  • CALL:SMService:CBRoadcast:MESSage[<n>]:CTEXt
  • CALL:SMService:CBRoadcast:MESSage[<n>]:DCSCheme[:SPECify]
  • CALL:SMService:CBRoadcast:MESSage[<n>]:DCSCheme:LANGuage
  • CALL:SMService:CBRoadcast:MESSage[<n>]:DCSCheme:VALue
  • CALL:SMService:CBRoadcast:MESSage[<n>]:GSCope
  • CALL:SMService:CBRoadcast:MESSage[<n>]:IDENtifier
  • CALL:SMService:CBRoadcast:MESSage[<n>]:LANGuage
  • CALL:SMService:CBRoadcast:MESSage[<n>]:STATe
  • CALL:SMService:CBRoadcast:MESSage[<n>]:TEXT
  • CALL:SMService:CBRoadcast:MESSage[<n>]:UPDate
  • CALL:SMService:CBRoadcast:REPetition[:SEConds]
  • CALL:SMService:CBRoadcast:REPetition:UNITs
  • CALL:SMService:CBRoadcast:STARt
  • CALL:SMService:CBRoadcast:STOP
  • CALL:SMService:CBRoadcast:TEXT:CUSTom
  • CALL:SMService:CBRoadcast:TXT1?
  • CALL:SMService:CBRoadcast:TXT2?

  • CALL:SMService:HTTProtocol:INPut
  • CALL:SMService:HTTProtocol:OUTPut

  • CALL:SMService:PTPoint[:MTERminated]:CONTents
  • CALL:SMService:PTPoint[:MTERminated]:DATA:CUSTom
  • CALL:SMService:PTPoint[:MTERminated][:MESSage]:DCSCheme
  • CALL:SMService:PTPoint[:MTERminated][:MESSage]:FCAuse
  • CALL:SMService:PTPoint[:MTERminated][:MESSage]:MMTSend
  • CALL:SMService:PTPoint[:MTERminated][:MESSage]:MREFerence
  • CALL:SMService:PTPoint[:MTERminated][:MESSage]:OADDress
  • CALL:SMService:PTPoint[:MTERminated][:MESSage]:OADDress:HEXadecimal
  • CALL:SMService:PTPoint[:MTERminated][:MESSage]:OADDress:PLAN
  • CALL:SMService:PTPoint[:MTERminated][:MESSage]:OADDress:TYPE
  • CALL:SMService:PTPoint[:MTERminated][:MESSage]:PIDentifier
  • CALL:SMService:PTPoint[:MTERminated][:MESSage]:PINDicator
  • CALL:SMService:PTPoint[:MTERminated][:MESSage]:RADDress
  • CALL:SMService:PTPoint[:MTERminated][:MESSage]:RADDress:HEXadecimal
  • CALL:SMService:PTPoint[:MTERminated][:MESSage]:RADDress:PLAN
  • CALL:SMService:PTPoint[:MTERminated][:MESSage]:RADDress:TYPE
  • CALL:SMService:PTPoint[:MTERminated][:MESSage]:RPATh
  • CALL:SMService:PTPoint[:MTERminated][:MESSage]:SADDress
  • CALL:SMService:PTPoint[:MTERminated][:MESSage]:SADDress:HEXadecimal
  • CALL:SMService:PTPoint[:MTERminated][:MESSage]:SADDress:PLAN
  • CALL:SMService:PTPoint[:MTERminated][:MESSage]:SADDress:TYPE
  • CALL:SMService:PTPoint[:MTERminated][:MESSage]:SREPort
  • CALL:SMService:PTPoint[:MTERminated][:MESSage]:STATus
  • CALL:SMService:PTPoint[:MTERminated][:MESSage]:UDHind
  • CALL:SMService:PTPoint[:MTERminated]:RCAuse?
  • CALL:SMService:PTPoint[:MTERminated]:SEND[:IMMediate]
  • CALL:SMService:PTPoint[:MTERminated]:SEND:STATe?
  • CALL:SMService:PTPoint[:MTERminated]:TEXT
  • CALL:SMService:PTPoint[:MTERminated]:TEXT:CUSTom
  • CALL:SMService:PTPoint[:MTERminated]:TRANsport
  • CALL:SMService:PTPoint[:MTERminated][:MESSage]:TYPE
  • CALL:SMService:PTPoint[:MTERminated][:MESSage]:TYPE:SUBReport:RPTYpe
  • CALL:SMService:PTPoint[:MTERminated]:TXT1?
  • CALL:SMService:PTPoint[:MTERminated]:TXT2?
  • CALL:SMService:PTPoint:MORiginated:LOOPback
  • CALL:SMService:PTPoint:MORiginated[:MESSage]:CLEar[:ALL]
  • CALL:SMService:PTPoint:MORiginated[:MESSage]:CONTents?
  • CALL:SMService:PTPoint:MORiginated[:MESSage]:COUNt?
  • CALL:SMService:PTPoint:MORiginated[:MESSage]:DCSCheme?
  • CALL:SMService:PTPoint:MORiginated[:MESSage]:DESTination?
  • CALL:SMService:PTPoint:MORiginated[:MESSage]:FORMat?
  • CALL:SMService:PTPoint:MORiginated[:MESSage]:LENGth?
  • CALL:SMService:PTPoint:MORiginated[:MESSage]:MREFerence?
  • CALL:SMService:PTPoint:MORiginated[:MESSage]:PIDentifier?
  • CALL:SMService:PTPoint:MORiginated[:MESSage]:SRRequest?
  • CALL:SMService:PTPoint:MORiginated[:MESSage]:TEXT?
  • CALL:SMService:PTPoint:MORiginated[:MESSage]:UDHind?
  • CALL:SMService:PTPoint:MORiginated[:MESSage]:UDHLength?
  • CALL:SMService:PTPoint:MORiginated:QUEue[:STATe]
  • CALL:SMService:PTPoint:MORiginated:QUEue:COUNt?
  • CALL:SMService:PTPoint:MORiginated:QUEue:NEXT
  • CALL:SMService:PTPoint:MORiginated:REPort:MODE:STATus
  • CALL:SMService:PTPoint:MORiginated:REPort:MODE:SUBMit
  • CALL:SMService:PTPoint:MORiginated[:MESSage]:TRANsport?

  • CALL:SSERvice:PIPE
  • CALL:SSERvice:PIPE:MMConnect
  • CALL:SSERvice:PIPE[:DATA]:RX?
  • CALL:SSERvice:PIPE[:DATA]:RX:AVAilable?
  • CALL:SSERvice:PIPE:TIMeout
  • CALL:SSERvice:PIPE[:DATA]:TX
  • CALL:SSERvice:PIPE[:DATA]:TX:SEND

  • CALL:STATus[:STATe][:VOICe]?

  • CALL:STATus[:STATe]:DATA?

  • CALL:STATus:MS:IP:ADDRess[1|]2|3|4:CONText:PRIMary?
  • CALL:STATus:MS:IP:ADDRess[1]|2|3|4:CONText:PRIMary:LLCSapi?
  • CALL:STATus:MS:IP:ADDRess[1]|2|3|4:CONText:PRIMary:NSAPi?
  • CALL:STATus:MS:IP:ADDRess[1|]2|3|4:CONText:SECondary1|2|3?
  • CALL:STATus:MS:IP:ADDRess[1]|2|3|4:CONText:SECondary1|2|3:LLCSapi?
  • CALL:STATus:MS:IP:ADDRess[1]|2|3|4:CONText:SECondary1|2|3:NSAPi?

  • CALL:STATus:(PDTCH|PDTChannel):BLERror?
  • CALL:STATus:(PDTCH|PDTChannel):TERRor?
  • CALL:STATus:(PDTCH|PDTChannel):USFBler[:ASSigned]?
  • CALL:STATus:(PDTCH|PDTChannel):USFBler:ALL?
  • CALL:STATus:(PDTCH|PDTChannel):USFBler:UNASsigned?

  • CALL:STATus:PRAChannel:TERRor?

  • CALL:STATus:RACHannel:TERRor?

  • CALL:STATus:TCHannel:TERRor?

  • CALL[:CELL]:T308

  • CALL[:CELL]:TBFLow:T3192
  • CALL[:CELL]:TBFLow:UPLink:EXTended[:STATe]

  • CALL:TCHannel[:ARFCn][:SELected]

  • CALL:TCHannel:BAND

  • CALL:TCHannel:CLEarcoded:STATe

  • CALL:TCHannel:CMODe[:VALue]
  • CALL:TCHannel:CMODe:AFSPeech:CODec
  • CALL:TCHannel:CMODe:AFSPeech:CODec:CURRent
  • CALL:TCHannel:CMODe:AFSPeech:CODec:THReshold
  • CALL:TCHannel:CMODe:AHSPeech:CODec
  • CALL:TCHannel:CMODe:AHSPeech:CODec:CURRent
  • CALL:TCHannel:CMODe:AHSPeech:CODec:THReshold
  • CALL:TCHannel:CMODe:HRSPeech:SCHannel
  • CALL:TCHannel:CMODe:LSPeech:CHANnel
  • CALL:TCHannel:CMODe:WFSPeech:CODec
  • CALL:TCHannel:CMODe:WFSPeech:CODec:CURRent
  • CALL:TCHannel:CMODe:WFSPeech:CODec:THReshold

  • CALL:TCHannel:CUSTom:DATA

  • CALL:TCHannel:DAINterface:TINTerface

  • CALL:TCHannel:DOWNlink:DTX[:STATe]

  • CALL:TCHannel:DOWNlink:SPEech
  • CALL:TCHannel:DOWNlink:SPEech:LOOPback:DELay

  • CALL:TCHannel:(FACCH|FACChannel):MS:TXLevel
  • CALL:TCHannel:(FACCH|FACChannel):REPeat[:STATe]

  • CALL:TCHannel:FHOPping[:STATe]
  • CALL:TCHannel:FHOPping:HSNumber
  • CALL:TCHannel:FHOPping:MAIoffset:[SELected]

  • CALL:TCHannel:LOOPback

  • CALL:TCHannel:MA:MEASurement:ARFCn:(SELected]
  • CALL:TCHannel:MA:TABLe[:AUTO]:[SELected]?
  • CALL:TCHannel:MA:TABLe[:AUTO]:POINts:[SELected]?
  • CALL:TCHannel:MA:TABLe:CONFig:AUTO
  • CALL:TCHannel:MA:TABLe:MANual:[SELected]
  • CALL:TCHannel:MA:TABLe:MANual:POINts:[SELected]?

  • CALL:TCHannel:POWer[:AMPLitude]?
  • CALL:TCHannel:POWer[:AMPLitude]:ADJacent?
  • CALL:TCHannel:POWer[:AMPLitude]:UBURst?
  • CALL:TCHannel:POWer[:AMPLitude]:UNUSed?

  • CALL:TCHannel:PREDuction:ADJacent
  • CALL:TCHannel:PREDuction:BURSt
  • CALL:TCHannel:PREDuction:LEVel([1]|2)
  • CALL:TCHannel:PREDuction:UBURst
  • CALL:TCHannel:PREDuction:UNUSed

  • CALL:TCHannel:(SACCH|SACChannel):REPeat[:STATe]
  • CALL:TCHannel:(SACCH|SACChannel):REPeat:ORDer

  • CALL:TCHannel:SIGNaling:ASSignment:CHANnel
  • CALL:TCHannel:SIGNaling:DCCHannel:CSINdicator
  • CALL:TCHannel:SIGNaling:DESTination:CHANnel
  • CALL:TCHannel:SIGNaling:(SDCCH|SDCChannel):MS:TADVance[:SELected]
  • CALL:TCHannel:SIGNaling:(SDCCH|SDCChannel):MS:TXLevel[:SELected]
  • CALL:TCHannel:SIGNaling:(SDCCH|SDCChannel):SUBChannel

  • CALL:TCHannel:TSLot

  • CALL[:CELL]:TMSI[:VALue]
  • CALL[:CELL]:TMSI:ASSignment

  • CALL:TRANsferring[:STATe]?

  • CALL:TRIGger[:OUTPut][:ALL]:STATe:OFF

  • CALL:TRIGger[:OUTPut]:FRAMe:NIDLe:STATe
  • CALL:TRIGger[:OUTPut]:FRAMe:STATe
  • CALL:TRIGger[:OUTPut]:FRAMe:SYMBol
  • CALL:TRIGger[:OUTPut]:FRAMe:SYNChronize
  • CALL:TRIGger[:OUTPut]:FRAMe:SYNChronize:OFFSet
  • CALL:TRIGger[:OUTPut]:FRAMe:TSLot

  • CALL:TRIGger[:OUTPut]:HFRame:STATe
  • CALL:TRIGger[:OUTPut]:HFRame:FOFFset

  • CALL:TRIGger[:OUTPut]:MFRame:(PDTCH|PDTChannel):STATe
  • CALL:TRIGger[:OUTPut]:MFRame:(PDTCH|PDTChannel):FOFFset
  • CALL:TRIGger[:OUTPut]:MFRame:BCHannel:STATe
  • CALL:TRIGger[:OUTPut]:MFRame:BCHannel:FOFFset

  • CALL:TRIGger[:OUTPut]:RBLock:(PDTCH|PDTChannel):STATe
  • CALL:TRIGger[:OUTPut]:RBLock:(PDTCH|PDTChannel):FOFFset

  • CALL:TRIGger[:OUTPut]:PMESsage[:TSET][:TX]:PUASsignment:STATe
  • CALL:TRIGger[:OUTPut]:PMESsage[:TSET][:TX]:PUASsignment:FOFFset
  • CALL:TRIGger[:OUTPut]:PMESsage:DUT:TX:PUASsignment:STATe
  • CALL:TRIGger[:OUTPut]:PMESsage:DUT:TX:PUASsignment:FOFFset
  • CALL:TRIGger[:OUTPut]:PMESsage[:TSET][:TX]:PDASsignment:STATe
  • CALL:TRIGger[:OUTPut]:PMESsage[:TSET][:TX]:PDASsignment:FOFFset
  • CALL:TRIGger[:OUTPut]:PMESsage:DUT:RX:PDASsignment:STATe
  • CALL:TRIGger[:OUTPut]:PMESsage:DUT:RX:PDASsignment:FOFFset
  • CALL:TRIGger[:OUTPut]:PMESsage[:TSET][:TX]:PTReconfig:STATe
  • CALL:TRIGger[:OUTPut]:PMESsage[:TSET][:TX]:PTReconfig:FOFFset
  • CALL:TRIGger[:OUTPut]:PMESsage:DUT:TX:PTReconfig:STATe
  • CALL:TRIGger[:OUTPut]:PMESsage:DUT:TX:PTReconfig:FOFFset
  • CALL:TRIGger[:OUTPut]:PMESsage[:TSET][:TX]:PPCTadvance:STATe
  • CALL:TRIGger[:OUTPut]:PMESsage[:TSET][:TX]:PPCTadvance:FOFFset
  • CALL:TRIGger[:OUTPut]:PMESsage[:TSET][:TX]:PIASsignment:STATe
  • CALL:TRIGger[:OUTPut]:PMESsage[:TSET][:TX]:PIASsignment:FOFFset
  • CALL:TRIGger[:OUTPut]:PMESsage:DUT:TX:PIASsignment:STATe
  • CALL:TRIGger[:OUTPut]:PMESsage:DUT:TX:PIASsignment:FOFFset
  • CALL:TRIGger[:OUTPut]:PMESsage:DUT:RX:PIASsignment:STATe
  • CALL:TRIGger[:OUTPut]:PMESsage:DUT:RX:PIASsignment:FOFFset
  • CALL:TRIGger[:OUTPut]:PMESsage[:TSET][:TX]:IREQuest:STATe
  • CALL:TRIGger[:OUTPut]:PMESsage[:TSET][:TX]:IREQuest:FOFFset
  • CALL:TRIGger[:OUTPut]:PMESsage[:TSET][:TX]:AACCept:STATe
  • CALL:TRIGger[:OUTPut]:PMESsage[:TSET][:TX]:AACCept:FOFFset
  • CALL:TRIGger[:OUTPut]:PMESsage[:TSET][:TX]:DREQuest:STATe
  • CALL:TRIGger[:OUTPut]:PMESsage[:TSET][:TX]:DREQuest:FOFFset
  • CALL:TRIGger[:OUTPut]:PMESsage[:TSET][:TX]:PDPAccept:STATe
  • CALL:TRIGger[:OUTPut]:PMESsage[:TSET][:TX]:PDPAccept:FOFFset
  • CALL:TRIGger[:OUTPut]:PMESsage[:TSET][:TX]:PDPRequest:STATe
  • CALL:TRIGger[:OUTPut]:PMESsage[:TSET][:TX]:PDPRequest:FOFFset

  • CALL[:CELL]:UTRAN:FDDuplex:TABLe
  • CALL[:CELL]:UTRAN:FDDuplex:TABLe:POINts?
  • CALL[:CELL]:UTRAN:FDDuplex:TABLe:EXTended
  • CALL[:CELL]:UTRAN:FDDuplex:TABLe:EXTended:POINts?

  • CALL[:CELL]:UTRAN[:ALL]:MPDescr

  • CALL[:CELL]:UTRAN[:ALL]:MPDescr:TGSPriority

  • CALL[:CELL]:UTRAN[:ALL]:MPDescr:FDDinfo
  • CALL[:CELL]:UTRAN[:ALL]:MPDescr:FDDinfo:MREPorting
  • CALL[:CELL]:UTRAN[:ALL]:MPDescr:FDDinfo:QMINimum
  • CALL[:CELL]:UTRAN[:ALL]:MPDescr:FDDinfo:QOFFset[:GSM]
  • CALL[:CELL]:UTRAN[:ALL]:MPDescr:FDDinfo:QOFFset:GPRS
  • CALL[:CELL]:UTRAN[:ALL]:MPDescr:FDDinfo:RQUantity
  • CALL[:CELL]:UTRAN[:ALL]:MPDescr:FDDinfo:RTHReshold
  • CALL[:CELL]:UTRAN[:ALL]:MPDescr:FDDinfo:ROFFset

  • CALL[:CELL]:UTRAN[:ALL]:MPDescr:QSC
  • CALL[:CELL]:UTRAN[:ALL]:MPDescr:QSC:INITial

  • CALL[:CELL]:UTRAN[:ALL]:MPDescr:QSI
  • CALL[:CELL]:UTRAN[:ALL]:MPDescr:QSP

DISPlay Subsystem

  • DISPlay:BRIGhtness
  • DISPlay:MODE
  • DISPlay:MESSage:MASKable:STATe
  • DISPlay:WINDow:ERRor:CLEar

FETCh Subsystem

  • FETCh:AAUDio[:ALL]?
  • FETCh:AAUDio:DISTortion[:AVERage]?
  • FETCh:AAUDio:DISTortion:ALL?
  • FETCh:AAUDio:DISTortion:MAXimum?
  • FETCh:AAUDio:DISTortion:MINimum?
  • FETCh:AAUDio:DISTortion:SDEViation?
  • FETCh:AAUDio:FREQuency[:AVERage]?
  • FETCh:AAUDio:FREQuency:ALL?
  • FETCh:AAUDio:FREQuency:MAXimum?
  • FETCh:AAUDio:FREQuency:MINimum?
  • FETCh:AAUDio:FREQuency:SDEViation?
  • FETCh:AAUDio:ICOunt?
  • FETCh:AAUDio:INTegrity?
  • FETCh:AAUDio:SINad[:AVERage]?
  • FETCh:AAUDio:SINad:ALL?
  • FETCh:AAUDio:SINad:MAXimum?
  • FETCh:AAUDio:SINad:MINimum?
  • FETCh:AAUDio:SINad:SDEViation?
  • FETCh:AAUDio:VOLTage[:AVERage]?
  • FETCh:AAUDio:VOLTage:ALL?
  • FETCh:AAUDio:VOLTage:MAXimum?
  • FETCh:AAUDio:VOLTage:MINimum?
  • FETCh:AAUDio:VOLTage:SDEViation?

  • FETCh:BERRor[:ALL]?
  • FETCh:BERRor:BITS?
  • FETCh:BERRor:BITS:TYPEIA|TYPEIB|TYPEII?
  • FETCh:BERRor:COUNt[:BITS]?
  • FETCh:BERRor:COUNt:CRC?
  • FETCh:BERRor:COUNt:FE?
  • FETCh:BERRor:COUNt:TYPEIA|TYPEIB|TYPEII?
  • FETCh:BERRor:DELay?
  • FETCh:BERRor:FULL?
  • FETCh:BERRor:ICOunt?
  • FETCh:BERRor:INTegrity?
  • FETCh:BERRor:RATio[:BITS]?
  • FETCh:BERRor:RATio:CRC?
  • FETCh:BERRor:RATio:FE?
  • FETCh:BERRor:RATio:TYPEIA|TYPEIB|TYPEII?

  • FETCh:<BFINdication|BFI>[:ALL]?
  • FETCh:<BFINdication|BFI>:COUNt[:UBFRames]?
  • FETCh:<BFINdication|BFI>:COUNt:BSID?
  • FETCh:<BFINdication|BFI>:ICOunt?
  • FETCh:<BFINdication|BFI>:INTegrity?
  • FETCh:<BFINdication|BFI>:NSID?
  • FETCh:<BFINdication|BFI>:RATio[:UBFRames]?
  • FETCh:<BFINdication|BFI>:RATio:BSID?
  • FETCh:<BFINdication|BFI>:SAMPles?

  • FETCh:BLERror[:ALL]?
  • FETCh:BLERror:BLOCks?
  • FETCh:BLERror:BURSt<[1]|2|3|4|5>[:ALL]?
  • FETCh:BLERror:BURSt:ALL?
  • FETCh:BLERror:COUNt?
  • FETCh:BLERror:CRC?
  • FETCh:BLERror:DELay?
  • FETCh:BLERror:ICOunt?
  • FETCh:BLERror:INTegrity?
  • FETCh:BLERror:RATio?
  • FETCh:BLERror:RATio:DOWNlink[:ALL]?

  • FETCh:DAUDio[:ALL]?
  • FETCh:DAUDio:ICOunt?
  • FETCh:DAUDio:INTegrity?
  • FETCh:DAUDio:AMPLitude[:AVERage]?
  • FETCh:DAUDio:AMPLitude:ALL?
  • FETCh:DAUDio:AMPLitude:MAXimum?
  • FETCh:DAUDio:AMPLitude:MINimum?
  • FETCh:DAUDio:AMPLitude:SDEViation?

  • FETCh:DPOWer[:ALL][:RANGe1]? FETCh:DPOWer[:ALL]:RANGe2|3|4|5|6|7|8|9|10?
  • FETCh:DPOWer:ICOunt?
  • FETCh:DPOWer:NUMBer[:RANGe1]? FETCh:DPOWer:POWer:NUMBer:RANGe2|3|4|5|6|7|8|9|10?
  • FETCh:DPOWer:POWer[:RANGe1]? FETCh:DPOWer:POWer:RANGe2|3|4|5|6|7|8|9|10?
  • FETCh:DPOWer:RANGe:OFFSet?

  • FETCh:EDPower[:ALL]:<[RANGe1]|2|3|4|5|6|7|8|9|10>?
  • FETCh:EDPower:INTegrity:<[RANGe1]|2|3|4|5|6|7|8|9|10>?
  • FETCh:EDPower:NUMBer:<[RANGe1]|2|3|4|5|6|7|8|9|10>?
  • FETCh:EDPower:POWer:<[RANGe1]|2|3|4|5|6|7|8|9|10>?

  • FETCh:EMACcuracy[:ALL]?
  • FETCh:EMACcuracy[:ALL]:ETSI?
  • FETCh:EMACcuracy:DROop[:AVERage]?
  • FETCh:EMACcuracy:DROop: MAXimum?
  • FETCh:EMACcuracy:DROop:MINimum?
  • FETCh:EMACcuracy:DROop:SDEViation?
  • FETCh:EMACcuracy:EVM:PEAK[:AVERage]?
  • FETCh:EMACcuracy:EVM:PEAK:MAXimum?
  • FETCh:EMACcuracy:EVM:PEAK:MINimum?
  • FETCh:EMACcuracy:EVM:PEAK:SDEViation?
  • FETCh:EMACcuracy:EVM:PERCentile?
  • FETCh:EMACcuracy:EVM:RMS[:MAXimum]?
  • FETCh:EMACcuracy:EVM:RMS:AVERage?
  • FETCh:EMACcuracy:EVM:RMS:MINimum?
  • FETCh:EMACcuracy:EVM:RMS:SDEViation?
  • FETCh:EMACcuracy:EVM:TRACe:DATA?
  • FETCh:EMACcuracy:FERRor:AVERage?
  • FETCh:EMACcuracy:FERRor: MAXimum?
  • FETCh:EMACcuracy:FERRor:MINimum?
  • FETCh:EMACcuracy:FERRor:SDEViation?
  • FETCh:EMACcuracy:FERRor[:WORSt]?
  • FETCh:EMACcuracy:HISTogram:DATA?
  • FETCh:EMACcuracy:ICOunt?
  • FETCh:EMACcuracy:IQIMbalance:MAXimum?
  • FETCh:EMACcuracy:IQIMbalance:MINimum?
  • FETCh:EMACcuracy:IQIMbalance[:AVERage]?
  • FETCh:EMACcuracy:IQIMbalance:SDEViation?
  • FETCh:EMACcuracy:INTegrity?
  • FETCh:EMACcuracy:MERRor:PEAK:AVERage?
  • FETCh:EMACcuracy:MERRor:PEAK:MAXimum?
  • FETCh:EMACcuracy:MERRor:PEAK:MINimum?
  • FETCh:EMACcuracy:MERRor:PEAK:SDEViation?
  • FETCh:EMACcuracy:MERRor:PEAK[:WORSt]?
  • FETCh:EMACcuracy:MERRor:RMS[:AVERage]?
  • FETCh:EMACcuracy:MERRor:RMS:MAXimum?
  • FETCh:EMACcuracy:MERRor:RMS:MINimum?
  • FETCh:EMACcuracy:MERRor:RMS:SDEViation?
  • FETCh:EMACcuracy:MERRor:TRACe:DATA?
  • FETCh:EMACcuracy:OOFFset[:AVERage]?
  • FETCh:EMACcuracy:OOFFset: MAXimum?
  • FETCh:EMACcuracy:OOFFset:MINimum?
  • FETCh:EMACcuracy:OOFFset:SDEViation?
  • FETCh:EMACcuracy:PERRor:PEAK:AVERage?
  • FETCh:EMACcuracy:PERRor:PEAK:MAXimum?
  • FETCh:EMACcuracy:PERRor:PEAK:MINimum?
  • FETCh:EMACcuracy:PERRor:PEAK:SDEViation?
  • FETCh:EMACcuracy:PERRor:PEAK[:WORSt]?
  • FETCh:EMACcuracy:PERRor:RMS[:AVERage]?
  • FETCh:EMACcuracy:PERRor:RMS:MAXimum?
  • FETCh:EMACcuracy:PERRor:RMS:MINimum?
  • FETCh:EMACcuracy:PERRor:RMS:SDEViation?
  • FETCh:EMACcuracy:PERRor:TRACe:DATA?
  • FETCh:EMACcuracy:SYMBol:DATA?

  • FETCh:ETXPower[:ALL]?
  • FETCh:ETXPower:ICOunt?
  • FETCh:ETXPower:INTegrity?
  • FETCh:ETXPower:POWer:ALL?
  • FETCh:ETXPower:POWer:BURSt[:AVERage]?
  • FETCh:ETXPower:POWer:BURSt:MAXimum?
  • FETCh:ETXPower:POWer:BURSt:MINimum?
  • FETCh:ETXPower:POWer:BURSt:SDEViation?
  • FETCh:ETXPower:POWer:CARRier[:AVERage]?
  • FETCh:ETXPower:POWer:CARRier:MAXimum?
  • FETCh:ETXPower:POWer:CARRier:MINimum?
  • FETCh:ETXPower:POWer:CARRier:SDEViation?

  • FETCh:FBERror[:ALL]?
  • FETCh:FBERror:BITS?
  • FETCh:FBERror:COUNt?
  • FETCh:FBERror:DELay?
  • FETCh:FBERror:ICOunt?
  • FETCh:FBERror:INTegrity?
  • FETCh:FBERror:RATio?

  • FETCh:FFERate[:ALL]?
  • FETCh:FFERate:COUNt?
  • FETCh:FFERate:ICOunt?
  • FETCh:FFERate:INTegrity?
  • FETCh:FFERate:RATio?
  • FETCh:FFERate:SAMPles?

  • FETCh:FSTability[:ALL]?
  • FETCh:FSTability:FERRor[:WORSt]?
  • FETCh:FSTability:FERRor:ALL?
  • FETCh:FSTability:FERRor:AVERage?
  • FETCh:FSTability:FERRor:MAXimum?
  • FETCh:FSTability:FERRor:MINimum?
  • FETCh:FSTability:FREQuency[:AVERage]?
  • FETCh:FSTability:FREQuency:ALL?
  • FETCh:FSTability:FREQuency:MAXimum?
  • FETCh:FSTability:FREQuency:MINimum?
  • FETCh:FSTability:FREQuency:SDEViation?
  • FETCh:FSTability:ICOunt?
  • FETCh:FSTability:INTegrity?

  • FETCh:GBERror[:ALL]?
  • FETCh:GBERror:BITS?
  • FETCh:GBERror:CRC?
  • FETCh:GBERror:COUNt?
  • FETCh:GBERror:DELay?
  • FETCh:GBERror:ICOunt?
  • FETCh:GBERror:INTegrity?
  • FETCh:GBERror:RATio?

  • FETCh:IFERror[:ALL]?
  • FETCh:IFERror:COUNt?
  • FETCh:IFERror:DELay?
  • FETCh:IFERror:ICOunt?
  • FETCh:IFERror:INTegrity?
  • FETCh:IFERror:RATio?
  • FETCh:IFERror:SFRames?

  • FETCh:IQTuning[:ALL]?
  • FETCh:IQTuning:ICOunt?
  • FETCh:IQTuning:INTegrity?
  • FETCh:IQTuning:POWer[:ALL]?
  • FETCh:IQTuning:REFerence:FREQuency?
  • FETCh:IQTuning:SPUR:POWer?

  • FETCh:MTAudio[:ALL]?
  • FETCh:MTAudio:DISTortion[:AVERage]?
  • FETCh:MTAudio:FREQuency[:AVERage]?
  • FETCh:MTAudio:ICOunt?
  • FETCh:MTAudio:INTegrity?
  • FETCh:MTAudio:LEVel?
  • FETCh:MTAudio:LEVel:LIMit:FAIL?
  • FETCh:MTAudio:SINad|SNDRatio[:AVERage]?
  • FETCh:MTAudio:VOLTage[:AVERage]?

  • FETCh:ORFSpectrum[:ALL]?
  • FETCh:ORFSpectrum:ICOunt?
  • FETCh:ORFSpectrum:INTegrity?
  • FETCh:ORFSpectrum:LIMit?
  • FETCh:ORFSpectrum:LIMit:ALL?
  • FETCh:ORFSpectrum:MODulation[:ALL][:AVERage]?
  • FETCh:ORFSpectrum:MODulation[:ALL]:SDEViation?
  • FETCh:ORFSpectrum:MODulation:FREQuency[:OFFSet][:AVERage]?
  • FETCh:ORFSpectrum:MODulation:FREQuency[:OFFSet]:SDEViation?
  • FETCh:ORFSpectrum:MODulation:LIMit?
  • FETCh:ORFSpectrum:MODulation:LIMit:ALL?
  • FETCh:ORFSpectrum:POWer?
  • FETCh:ORFSpectrum:POWer:BWIDth[:AVERage]?
  • FETCh:ORFSpectrum:POWer:BWIDth:SDEViation?
  • FETCh:ORFSpectrum:SWITChing[:ALL][:MAXimum]?
  • FETCh:ORFSpectrum:SWITChing[:ALL]:AVERage?
  • FETCh:ORFSpectrum:SWITChing[:ALL]:SDEViation?
  • FETCh:ORFSpectrum:SWITChing:FREQuency[:OFFSet][:MAXimum]?
  • FETCh:ORFSpectrum:SWITChing:FREQuency[:OFFSet]:AVERage?
  • FETCh:ORFSpectrum:SWITChing:FREQuency[:OFFSet]:SDEViation?
  • FETCh:ORFSpectrum:SWITching:LIMit?
  • FETCh:ORFSpectrum:SWITching:LIMit:ALL?

  • FETCh:PCALibration[:ALL]?
  • FETCh:PCALibration:FERRor?
  • FETCh:PCALibration:INTegrity?
  • FETCh:PCALibration:PHASe?
  • FETCh:PCALibration:POWer?
  • FETCh:PCALibration:REFerence:POWer?
  • FETCh:PCALibration:SAMPle:AMPLitude? <range>
  • FETCh:PCALibration:SAMPle:AMPLitude:BINary?
  • FETCh:PCALibration:SAMPle:AMPLitude:DBM? <range>
  • FETCh:PCALibration:SAMPle:AMPLitude:DBM:BINary?
  • FETCh:PCALibration:SAMPle:AMPLitude:MAXimum?
  • FETCh:PCALibration:SAMPle:AMPLitude:MAXimum:DBM?
  • FETCh:PCALibration:SAMPle:AMPLitude:MINimum?
  • FETCh:PCALibration:SAMPle:AMPLitude:MINimum:DBM?
  • FETCh:PCALibration:SAMPle[:ALL]:BINary?
  • FETCh:PCALibration:SAMPle:COUNt?
  • FETCh:PCALibration:SAMPle[:ALL]:DBM:BINary?
  • FETCh:PCALibration:SAMPle:PHASe? <range>
  • FETCh:PCALibration:SAMPle:PHASe:BINary?

  • FETCh:PFERor[:ALL]?
  • FETCh:PFERor:FAIL?
  • FETCh:PFERror:COUNt:TESTed?
  • FETCh:PFERror:FERRor:ALL?
  • FETCh:PFERror:FERRor:AVERage?
  • FETCh:PFERror:FERRor:FAIL?
  • FETCh:PFERror:FERRor: MAXimum?
  • FETCh:PFERror:FERRor:MINimum?
  • FETCh:PFERror:FERRor[:WORSt]?
  • FETCh:PFERror:ICOunt?
  • FETCh:PFERror:INTegrity?
  • FETCh:PFERror:PEAK:ALL?
  • FETCh:PFERror:PEAK:AVERage?
  • FETCh:PFERror:PEAK:FAIL?
  • FETCh:PFERror:PEAK[:MAXimum]?
  • FETCh:PFERror:PEAK:MINimum?
  • FETCh:PFERror:RMS:ALL?
  • FETCh:PFERror:RMS:AVERage?
  • FETCh:PFERror:RMS:FAIL?
  • FETCh:PFERror:RMS[:MAXimum]?
  • FETCh:PFERror:RMS:MINimum?

  • FETCh:PVTime[:BURSt[1]][:ALL]?
  • FETCh:PVTime:BURSt2|3|4|5|6[:ALL]?
  • FETCh:PVTime[:BURSt[1]]:INTegrity?
  • FETCh:PVTime:BURSt2|3|4|5|6:INTegrity?
  • FETCh:PVTime[:BURSt[1]]:MASK[:FAIL]?
  • FETCh:PVTime:BURSt2|3|4|5|6:MASK[:FAIL]?
  • FETCh:PVTime[:BURSt[1]]:MASK:ALL?
  • FETCh:PVTime:BURSt2|3|4|5|6:MASK:ALL?
  • FETCh:PVTime[:BURSt[1]]:MASK:LOWer[:MARGin]?
  • FETCh:PVTime:BURSt2|3|4|5|6:MASK:LOWer[:MARGin]?
  • FETCh:PVTime[:BURSt[1]]:MASK:LOWer:TIME?
  • FETCh:PVTime[:BURSt[1]]:MASK:UPPer[:MARGin]?
  • FETCh:PVTime:BURSt2|3|4|5|6:MASK:UPPer[:MARGin]?
  • FETCh:PVTime[:BURSt[1]]:MASK:UPPer:TIME?
  • FETCh:PVTime:BURSt2|3|4|5|6:MASK:UPPer:TIME?
  • FETCh:PVTime[:BURSt[1]]:POWer[:ALL]:AVERage?
  • FETCh:PVTime:BURSt2|3|4|5|6:POWer[:ALL]:AVERage?
  • FETCh:PVTime[:BURSt[1]]:POWer[:ALL][:MAXimum]?
  • FETCh:PVTime:BURSt2|3|4|5|6:POWer[:ALL][:MAXimum]?
  • FETCh:PVTime[:BURSt[1]]:POWer[:ALL]:MINimum?
  • FETCh:PVTime:BURSt2|3|4|5|6:POWer[:ALL]:MINimum?
  • FETCh:PVTime[:BURSt[1]]:POWer[:ALL]:SDEViation?
  • FETCh:PVTime:BURSt2|3|4|5|6:POWer[:ALL]:SDEViation?
  • FETCh:PVTime[:BURSt[1]]:POWer:TIME[:OFFSet][:MAXimum]?
  • FETCh:PVTime:BURSt2|3|4|5|6:POWer:TIME[:OFFSet][:MAXimum]?
  • FETCh:PVTime[:BURSt[1]]:POWer:TIME[:OFFSet]:AVERage?
  • FETCh:PVTime:BURSt2|3|4|5|6:POWer:TIME[:OFFSet]:AVERage?
  • FETCh:PVTime[:BURSt[1]]:POWer:TIME[OFFSet]:MINimum?
  • FETCh:PVTime:BURSt2|3|4|5|6:POWer:TIME[OFFSet]:MINimum?
  • FETCh:PVTime[:BURSt[1]]:POWer:TIME[:OFFSet]:SDEViation?
  • FETCh:PVTime:BURSt2|3|4|5|6:POWer:TIME[:OFFSet]:SDEViation?
  • FETCh:PVTime[:BURSt[1]]:TRACe?
  • FETCh:PVTime:BURSt2|3|4|5|6:TRACe?
  • FETCh:PVTime[:BURSt[1]]:TXPower[:CARRier][:AVERage]?
  • FETCh:PVTime:BURSt2|3|4|5|6:TXPower[:CARRier][:AVERage]?
  • FETCh:PVTime[:BURSt[1]]:TXPower[:CARRier]:ALL?
  • FETCh:PVTime:BURSt2|3|4|5|6:TXPower[:CARRier]:ALL?
  • FETCh:PVTime[:BURSt[1]]:TXPower[:CARRier]:MAXimum?
  • FETCh:PVTime:BURSt2|3|4|5|6:TXPower[:CARRier]:MAXimum?
  • FETCh:PVTime[:BURSt[1]]:TXPower[:CARRier]:MINimum?
  • FETCh:PVTime:BURSt2|3|4|5|6:TXPower[:CARRier]:MINimum?
  • FETCh:PVTime[:BURSt[1]]:TXPower[:CARRier]:SDEViation?
  • FETCh:PVTime:BURSt2|3|4|5|6:TXPower[:CARRier]:SDEViation?
  • FETCh:PVTime:ICOunt?
  • FETCh:PVTime:MASK[:FAIL]?
  • FETCh:PVTime:MASK[:FAIL]:SECTion?
  • FETCh:PVTime:MASK[:FAIL]:SEGment?
  • FETCh:PVTime:SECTion[:ALL]?
  • FETCh:PVTime:SECTion:AVERage?
  • FETCh:PVTime:SECTion:MAXimum?
  • FETCh:PVTime:SECTion:MINimum?

  • FETCh:SBERror[:ALL]?
  • FETCh:SBERror:BITS?
  • FETCh:SBERror:COUNt?
  • FETCh:SBERror:DELay?
  • FETCh:SBERror:ICOunt?
  • FETCh:SBERror:INTegrity?
  • FETCh:SBERror:RATio?

  • FETCh:SFERate[:ALL]?
  • FETCh:SFERate:COUNt?
  • FETCh:SFERate:ICOunt?
  • FETCh:SFERate:INTegrity?
  • FETCh:SFERate:RATio?
  • FETCh:SFERate:SAMPles?

  • FETCh:SMONitor[:ALL]?
  • FETCh:SMONitor:INTegrity?
  • FETCh:SMONitor:TRACe?

  • FETCh:TXPower[:ALL]?<sp>[<Burst>]
  • FETCh:TXPower:ICOunt?
  • FETCh:TXPower:INTegrity?
  • FETCh:TXPower:GFDTune:TRIGger:COUNt?
  • FETCh:TXPower:MODulation:FORMat[:BURSt]?<sp>[<Burst>]
  • FETCh:TXPower:MODulation:FORMat:FRAMe?
  • FETCh:TXPower:POWer:ALL?<sp>[<Burst>]
  • FETCh:TXPower:POWer:BURSt[:AVERage]?<sp>[<Burst>]
  • FETCh:TXPower:POWer:BURSt:MAXimum?<sp>[<Burst>]
  • FETCh:TXPower:POWer:BURSt:MINimum?<sp>[<Burst>]
  • FETCh:TXPower:POWer:BURSt:SDEViation?<sp>[<Burst>]
  • FETCh:TXPower:POWer:BURSt:FRAMe:[:AVERage]?
  • FETCh:TXPower:POWer:BURSt:FRAMe:MAXimum?
  • FETCh:TXPower:POWer:BURSt:FRAMe:MINimum?
  • FETCh:TXPower:POWer:BURSt:FRAMe:SDEViation?
  • FETCh:TXPower:POWer[:CARRier][:AVERage]?<sp>[<Burst>]
  • FETCh:TXPower:POWer[:CARRier]:MAXimum?<sp>[<Burst>]
  • FETCh:TXPower:POWer[:CARRier]:MINimum?<sp>[<Burst>]
  • FETCh:TXPower:POWer[:CARRier]:SDEViation?<sp>[<Burst>]
  • FETCh:TXPower:POWer[:CARRier]:FRAMe[:AVERage]?]
  • FETCh:TXPower:POWer[:CARRier]:FRAMe:MAXimum?
  • FETCh:TXPower:POWer[:CARRier]:FRAMe:MINimum?
  • FETCh:TXPower:POWer[:CARRier]:FRAMe:SDEViation?
  • FETCh:TXPower:SSTep:BPOWer:FRAMe[:AVERage]?<sp><Step>
  • FETCh:TXPower:SSTep:BPOWer:FRAMe:MAXimum?<sp><Step>
  • FETCh:TXPower:SSTep:BPOWer:FRAMe:MINimum?<sp><Step>
  • FETCh:TXPower:SSTep:BPOWer:FRAMe:SDEViation?<sp><Step>
  • FETCh:TXPower:SSTep:CPOWer:FRAMe[:AVERage]?<sp><Step>
  • FETCh:TXPower:SSTep:CPOWer:FRAMe:MAXimum?<sp><Step>
  • FETCh:TXPower:SSTep:CPOWer:FRAMe:MINimum?<sp><Step>
  • FETCh:TXPower:SSTep:CPOWer:FRAMe:SDEViation?<sp><Step>
  • FETCh:TXPower:SSTep:BPOWer[:BURSt][:AVERage]?<sp><Step>[,<Burst>]
  • FETCh:TXPower:SSTep:BPOWer[:BURSt]:MAXimum?<sp><Step>[,<Burst>]
  • FETCh:TXPower:SSTep:BPOWer[:BURSt]:MINimum?<sp><Step>[,<Burst>]
  • FETCh:TXPower:SSTep:BPOWer[:BURSt]:SDEViation?<sp><Step>[,<Burst>]
  • FETCh:TXPower:SSTep:CPOWer[:BURSt][:AVERage]?<sp><Step>[,<Burst>]
  • FETCh:TXPower:SSTep:CPOWer[:BURSt]:MAXimum?<sp><Step>[,<Burst>]
  • FETCh:TXPower:SSTep:CPOWer[:BURSt]:MINimum?<sp><Step>[,<Burst>]
  • FETCh:TXPower:SSTep:CPOWer[:BURSt]:SDEViation?<sp><Step>[,<Burst>]
  • FETCh:TXPower:SSTep:INTegrity?<sp><Step>
  • FETCh:TXPower:SSTep:MODulation:FORMat[:BURSt]?<sp><Step>[,<Burst>]
  • FETCh:TXPower:SSTep:MODulation:FORMat:FRAMe?<sp><Step>
  • FETCh:TXPower:TSEQuence:BPOWer[:AVERage]?<sp>[<Burst>]
  • FETCh:TXPower:TSEQuence:BPOWer:MAXimum?<sp>[<Burst>]
  • FETCh:TXPower:TSEQuence:BPOWer:MINimum?<sp>[<Burst>]
  • FETCh:TXPower:TSEQuence:BPOWer:SDEViation?<sp>[<Burst>]
  • FETCh:TXPower:TSEQuence:CPOWer[:AVERage]?<sp>[<Burst>]
  • FETCh:TXPower:TSEQuence:CPOWer:MAXimum?<sp>[<Burst>]
  • FETCh:TXPower:TSEQuence:CPOWer:MINimum?<sp>[<Burst>]
  • FETCh:TXPower:TSEQuence:CPOWer:SDEViation?<sp>[<Burst>]
  • FETCh:TXPower:TSEQuence:INTegrity?
  • FETCh:TXPower:TSEQuence:MODulation:FORMat?<sp>[<Burst>]

INITiate Subsystem

  • INITiate:<measurement mnemonic>[:ON]
  • INITiate:<measurement mnemonic>:OFF
  • INITiate:COUNt?
  • INITiate:DONE?
  • INITiate:DONE:CLEar
  • INITiate:DONE:FLAG[:ALL]
  • INITiate:DONE:FLAG:<measurement mnemonic>
  • INITiate:ON?
  • INITiate:TXPower:GFDTune:ARMed?

READ Subsystem

  • READ:AAUDio[:ALL]?
  • READ:BERRor[:ALL]?
  • READ:BERRor:FULL?
  • READ:BLERror[:ALL]?
  • READ:BLERror:BURSt[:ALL]?
  • READ:BFINdication|BFI[:ALL]?
  • READ:DAUDio[:ALL]?
  • READ:DPOWer[:ALL]?
  • READ:EDPower[:ALL][:RANGe1|RANGe2|RANGe3|RANGe4|RANGe5|RANGe6|RANGe7|RANGe8|RANGe9|RANGe10]?
  • READ:EMACcuracy[:ALL]?
  • READ:EMACcuracy[:ALL]:ETSI?
  • READ:ETXPower[:ALL]?
  • READ:FBERror[:ALL]?
  • READ:FFERate[:ALL]?
  • READ:FSTability[:ALL]?
  • READ:GBERror[:ALL]?
  • READ:IFERror[:ALL]?
  • READ:IQTuning[:ALL]?
  • READ:MTAudio[:ALL]?
  • READ:ORFSpectrum[:ALL]?
  • READ:PCALibration[:ALL]?
  • READ:PFERror[:ALL]?
  • READ:PFERror[:ALL]:FAIL?
  • READ:PVTime[:ALL]?
  • READ[:BURSt[1]]:PVTime[:ALL]?
  • READ:BURSt2|3|4|5:PVTime[:ALL]?
  • READ:SBERror[:ALL]?
  • READ:SMONitor:TRACe?
  • READ:TXPower[:ALL]?

RFANalyzer Subsystem

  • RFANalyzer:CONTrol:BTESt:CHANnel
  • RFANalyzer:CONTrol:MEASurement:FREQuency:AUTO
  • RFANalyzer:CONTrol:POWer:AUTO
  • RFANalyzer:CONTrol:UPLink:FREQuency:AUTO
  • RFANalyzer:CW:EXPected:POWer
  • RFANalyzer:MANual:MEASurement[:MFRequency]
  • RFANalyzer:MANual:MEASurement:FREQuency
  • RFANalyzer:MANual:POWer:BURSt<[1]|2|3|4|5|6|7>
  • RFANalyzer:MANual:UPLink[:MFRequency]
  • RFANalyzer:MANual:UPLink:FREQuency

RFGenerator Subsystem

  • RFGenerator:OUTPut[:DESTination]

SETup Subsystem

  • GFDTune:UPLink:SSTep:ARFCn
  • GFDTune:UPLink:SSTep:FREQuency
  • GFDTune:UPLink:TSEQuence:ARFCn
  • GFDTune:UPLink:TSEQuence:BURSt:COUNt
  • GFDTune:UPLink:TSEQuence:BURSt1|2|3|4|5|6|7:STATe
  • GFDTune:UPLink:TSEQuence:FREQuency
  • GFDTune:UPLink:TSEQuence:SSTep[:COUNt]

  • GFDTune:DOWNlink:SSTep:[:ALL]
  • GFDTune:DOWNlink:SSTep:ARFCn
  • GFDTune:DOWNlink:SSTep:BURSt:TYPE:TSLot<0|1|2|3|4|5>
  • GFDTune:DOWNlink:SSTep:FREQuency
  • GFDTune:DOWNlink:SSTep:PLEVel:FRAMe
  • GFDTune:DOWNlink:SSTep:REPeat
  • GFDTune:DOWNlink:SSTep:TRIGger:FRAMe
  • GFDTune:DOWNlink:SSTep:TRIGger:STATe
  • GFDTune:DOWNlink:SSTep:TRIGger:TSLot
  • GFDTune:DOWNlink:TSEQuence:ARFCn
  • GFDTune:DOWNlink:TSEQuence:BURSt:TYPE:TSLot<0|1|2|3|4|5>
  • GFDTune:DOWNlink:TSEQuence:CONTinuous
  • GFDTune:DOWNlink:TSEQuence:FREQuency
  • GFDTune:DOWNlink:TSEQuence:PLEVel:FRAMe
  • GFDTune:DOWNlink:TSEQuence:PLEVel:TSLot<0|1|2|3|4|5>
  • GFDTune:DOWNlink:TSEQuence:PLEVel<1|2|3|4>
  • GFDTune:DOWNlink:TSEQuence:REPeat
  • GFDTune:DOWNlink:TSEQuence:SSTep[:COUNt]
  • GFDTune:DOWNlink:TSEQuence:STARt
  • GFDTune:DOWNlink:TSEQuence:STOP
  • GFDTune:DOWNlink:TSEQuence:TRIGger:FRAMe
  • GFDTune:DOWNlink:TSEQuence:TRIGger:STATe
  • GFDTune:DOWNlink:TSEQuence:TRIGger:TSLot

  • SETup:AAUDio:CONTinuous
  • SETup:AAUDio:COUNt[:SNUMber]
  • SETup:AAUDio:COUNt:NUMBer
  • SETup:AAUDio:COUNt:STATe
  • SETup:AAUDIO:DEMPhasis:STATe
  • SETup:AAUDio:DETector[:TYPE]
  • SETup:AAUDio:EXPANDOR[:SRLevel]
  • SETup:AAUDio:EXPANDOR:RLEVel
  • SETup:AAUDio:EXPANDOR:STATe
  • SETup:AAUDio:EXPected:VOLTage[:PEAK]
  • SETup:AAUDio:FILTer[:SFRequency]
  • SETup:AAUDio:FILTer:FREQuency
  • SETup:AAUDio:FILTer:STATe
  • SETup:AAUDio:FILTer:TYPE
  • SETup:AAUDio:FREQuency:STATe
  • SETup:AAUDio:SDIStortion:FREQuency
  • SETup:AAUDio:SDIStortion:STATe
  • SETup:AAUDio:TIMEout[:STIME]
  • SETup:AAUDio:TIMEout:STATe
  • SETup:AAUDio:TIMEout:TIME

  • SETup:BERRor[:TYPE]
  • SETup:BERRor:CLSDelay[:STIMe]
  • SETup:BERRor:CLSDelay:TIME
  • SETup:BERRor:CLSDelay:STATe
  • SETup:BERRor:CONTinuous
  • SETup:BERRor:COUNt
  • SETup:BERRor:LDControl:AUTO
  • SETup:BERRor:MANual:DELay
  • SETup:BERRor:SLControl[:STATe]
  • SETup:BERRor:TIMeout[:STIMe]
  • SETup:BERRor:TIMeout:TIME
  • SETup:BERRor:TIMeout:STATe

  • SETup:<BFINdication|BFI>:CONTinuous
  • SETup:<BFINdication|BFI>:SAMPles
  • SETup:<BFINdication|BFI>:SFDelay
  • SETup:<BFINdication|BFI>:TIMeout[:STIMe]
  • SETup:<BFINdication|BFI>:TIMeout:TIME
  • SETup:<BFINdication|BFI>:TIMeout:STATe

  • SETup:BLERror:BBLocks
  • SETup:BLERror:CONTinuous
  • SETup:BLERror:COUNt
  • SETup:BLERror:ETSIB:MODE
  • SETup:BLERror:LDControl:AUTO
  • SETup:BLERror:MANual:DELay
  • SETup:BLERror:TIMeout[:STIMe]
  • SETup:BLERror:TIMeout:TIME
  • SETup:BLERror:TIMeout:STATe

  • SETup[:ALL]:CONTinuous

  • SETup:DAUDio:CONTinuous
  • SETup:DAUDio:COUNt[:SNUMber]
  • SETup:DAUDio:COUNt:NUMBer
  • SETup:DAUDio:COUNt:STATe
  • SETup:DAUDio:FILTer [:SFREquency]
  • SETup:DAUDio:FILTer:FREQuency
  • SETup:DAUDio:FILTer:STATe
  • SETup:DAUDio:TIMeout[:STIMe]
  • SETup:DAUDio:TIMeout:TIME
  • SETup:DAUDio:TIMeout:STATe

  • SETup:DPOWer:CONTinuous[:SELected]
  • SETup:DPOWer:CONTinuous:GSM
  • SETup:DPOWer:COUNt:NUMBer[:SELected]
  • SETup:DPOWer:COUNt:NUMBer:GSM
  • SETup:DPOWer:EMDifference[:SELected]
  • SETup:DPOWer:EMDifference:GSM
  • SETup:DPOWer:EMTInterval[:STIMe]
  • SETup:DPOWer:EMTInterval:STATe
  • SETup:DPOWer:EMTInterval:TIME
  • SETup:DPOWer:RANGe:OFFSet
  • SETup:DPOWer:TIMeout[:STIMe][:SELected]
  • SETup:DPOWer:TIMeout[:STIMe]:GSM
  • SETup:DPOWer:TIMeout:STATe[:SELected]
  • SETup:DPOWer:TIMeout:STATe:GSM
  • SETup:DPOWer:TIMeout:TIMe[:SELected]
  • SETup:DPOWer:TIMeout:TIMe:GSM

  • SETup:EDPower:CONTinuous
  • SETup:EDPower:COUNt:GROup:SIZE
  • SETup:EDPower:COUNt:NUMBer
  • SETup:EDPower:COUNt:RSEGment
  • SETup:EDPower:COUNt:TOTal?
  • SETup:EDPower:EMDifference
  • SETup:EDPower:EMTInterval[:STIMe]
  • SETup:EDPower:EMTInterval:STATe
  • SETup:EDPower:EMTInterval:TIME
  • SETup:EDPower:INITial:POWer:AUTO
  • SETup:EDPower:INITial:POWer
  • SETup:EDPower:METHod
  • SETup:EDPower:TIMeout[:STIMe]
  • SETup:EDPower:TIMeout:STATe
  • SETup:EDPower:TIMeout:TIME

  • SETup:EMACcuracy:CONTinuous
  • SETup:EMACcuracy:COUNt[:SNUMber]
  • SETup:EMACcuracy:COUNt:NUMBer
  • SETup:EMACcuracy:COUNt:STATe
  • SETup:EMACcuracy:DROop[:CALCulate]:STATe
  • SETup:EMACcuracy:GRAPh:STATe
  • SETup:EMACcuracy:HISTogram:MAXimum:EVM
  • SETup:EMACcuracy:IQIMbalance[:CALCulate]:STATe
  • SETup:EMACcuracy:PERRor:FILTer
  • SETup:EMACcuracy:TIMeout[:STIMe]
  • SETup:EMACcuracy:TIMeout:STATe
  • SETup:EMACcuracy:TIMeout:TIME
  • SETup:EMACcuracy:TRIGger:DELay
  • SETup:EMACcuracy:TRIGger:SOURce

  • SETup:ETXPower:CONTinuous
  • SETup:ETXPower:COUNt[:SNUMber]
  • SETup:ETXPower:COUNt:NUMBer
  • SETup:ETXPower:COUNt:STATe
  • SETup:ETXPower:ECPower:STATe
  • SETup:ETXPower:TIMeout[:STIMe]
  • SETup:ETXPower:TIMeout:TIME
  • SETup:ETXPower:TIMeout:STATe
  • SETup:ETXPower:TRIGger:DELay
  • SETup:ETXPower:TRIGger:SOURce

  • SETup:FBERror:CLSDelay[:STIMe]
  • SETup:FBERror:CLSDelay:TIME
  • SETup:FBERror:CLSDelay:STATe
  • SETup:FBERror:CONTinous
  • SETup:FBERror:COUNt
  • SETup:FBERror:LDControl:AUTO
  • SETup:FBERror:MANual:DELay
  • SETup:FBERror:SLControl[:STATe]
  • SETup:FBERror:TIMeout[:STIMe]
  • SETup:FBERror:TIMeout:TIME
  • SETup:FBERror:TIMeout:STATe

  • SETup:FFERate:CONTinuous
  • SETup:FFERate:FRINterval[:FS]
  • SETup:FFERate:FRINterval:HS
  • SETup:FFERate:SAMPles[:SELected]
  • SETup:FFERate:TIMeout[:STIMe]
  • SETup:FFERate:TIMeout:TIME
  • SETup:FFERate:TIMeout:STATe

  • SETup:FSTability:CONTinuous
  • SETup:FSTability:COUNt[:SNUMber]
  • SETup:FSTability:COUNt:NUMBer
  • SETup:FSTability:COUNt:STATe
  • SETup:FSTability:TIMeout[:STIMe]
  • SETup:FSTability:TIMeout:STATe
  • SETup:FSTability:TIMeout:TIME

  • SETup:GBERror:BBLocks
  • SETup:GBERror:CONTinuous
  • SETup:GBERror:COUNt
  • SETup:GBERror:LDControl:AUTO
  • SETup:GBERror:MANual:DELay
  • SETup:GBERror:TIMeout[:STIMe]
  • SETup:GBERror:TIMeout:TIME
  • SETup:GBERror:TIMeout:STATe
  • SETup:GBERror:ZBBLocks
  • SETup:IFERror:CONTinuous
  • SETup:IFERror:COUNt
  • SETup:IFERror:CPERiod
  • SETup:IFERror:LDControl:AUTO
  • SETup:IFERror:MANual:DELay
  • SETup:IFERror:TIMeout:STATe
  • SETup:IFERror:TIMeout[:STIME]
  • SETup:IFERror:TIMeout:TIME

  • SETup:IQTuning:CONTinuous[:SELected]
  • SETup:IQTuning:CONTinuous:GSM
  • SETup:IQTuning:COUNt:STATe[:SELected]
  • SETup:IQTuning:COUNt:STATe:GSM
  • SETup:IQTuning:COUNt:NUMBer[:SELected]
  • SETup:IQTuning:COUNt:NUMBer:GSM
  • SETup:IQTuning:COUNt[:SNUMBer][:SELected]
  • SETup:IQTuning:COUNt[:SNUMBer]:GSM
  • SETup:IQTuning:REFerence:AUTO
  • SETup:IQTuning:REFerence[:MANual][:FREQuency][:SELected]
  • SETup:IQTuning:REFerence[:MANual][:FREQuency]:GSM
  • SETup:IQTuning:REFerence[:MANual][:FREQuency]:CHARacter:GSM
  • SETup:IQTuning:SPUR:FREQuency[:SELected]
  • SETup:IQTuning:SPUR:FREQuency:GSM
  • SETup:IQTuning:SPUR:STATe[:SELected]
  • SETup:IQTuning:SPUR:STATe:GSM
  • SETup:IQTuning:SPUR[:SFRequency][:SELected]
  • SETup:IQTuning:SPUR[:SFRequency]:GSM
  • SETup:IQTuning:TIMeout:STATe[:SELected]
  • SETup:IQTuning:TIMeout:STATe:GSM
  • SETup:IQTuning:TIMeout[:STIMe][:SELected]
  • SETup:IQTuning:TIMeout[:STIMe]:GSM
  • SETup:IQTuning:TIMeout:TIMe[:SELected]
  • SETup:IQTuning:TIMeout:TIMe:GSM
  • SETup:IQTuning:TRIGger:DELay[:SELected]
  • SETup:IQTuning:TRIGger:DELay:GSM
  • SETup:IQTuning:TRIGger:SOURce[:SELected]
  • SETup:IQTuning:TRIGger:SOURce:GSM

  • SETup:MTAudio:ANALyzer:FREQuency:ALL[:SVALue]
  • SETup:MTAudio:ANALyzer:FREQuency:ALL:GENerator
  • SETup:MTAUDio:COUNt[:SNUMber]
  • SETup:MTAUDio:COUNt:NUMBer
  • SETup:MTAUDio:COUNt:STATe
  • SETup:MTAudio:CONTinuous
  • SETup:MTAudio:GENerator:FREQuency:ALL[:SVALue]
  • SETup:MTAudio:GENerator:FREQuency:PRESet
  • SETup:MTAudio:GENerator:LEVel:DOWNlink:ALL[:SAMPlitude]
  • SETup:MTAudio:GENerator:LEVel:DOWNlink:ALL:TOTal[:SAMPlitude]
  • SETup:MTAudio:GENerator:LEVel:DOWNlink:ALL:TOTal:STATe
  • SETup:MTAudio:GENerator:LEVel:UPLink:ALL[:SAMPlitude]
  • SETup:MTAudio:GENerator:LEVel:UPLink:ALL:TOTal[:SAMPlitude]
  • SETup:MTAudio:GENerator:LEVel:UPLink:ALL:TOTal:STATe
  • SETup:MTAudio:LEVel:ALL:LIMit:UPPer
  • SETup:MTAudio:LEVel:ALL:LIMit:LOWer
  • SETup:MTAudio:MEASurement:MODE
  • SETup:MTAudio:PEAK:VOLTage
  • SETup:MTAudio:REFerence:ABSolute:LEVel:DOWNlink
  • SETup:MTAudio:REFerence:ABSolute:LEVel:UPLink
  • SETup:MTAudio:REFerence:MODE
  • SETup:MTAudio:REFerence:RELative:TONE
  • SETup:MTAudio:SDIStortion:STATe
  • SETup:MTAudio:SETTling[:TIME]
  • SETup:MTAudio:TIMeout:STATe
  • SETup:MTAudio:TIMeout[:STIMe]
  • SETup:MTAudio:TIMeout:TIME

  • SETup:ORFSpectrum:AUTO:FILTer:TYPE?
  • SETup:ORFSpecturm:CONTinuous
  • SETup:ORFSpectrum:COUNt:STATe
  • SETup:ORFSpectrum:FAST
  • SETup:ORFSpectrum:FILTer:TYPE
  • SETup:ORFSpectrum:ICOunt:MAXimum?
  • SETup:ORFSpectrum:LIMit:SOURce
  • SETup:ORFSpectrum:MODulation:ABSolute:LIMit:CUSTom<[1]|2>
  • SETup:ORFSpectrum:MODulation:ABSolute:LIMit:CUSTom<[1] |2>:POINts?
  • SETup:ORFSpectrum:MODulation:COUNt[:SNUMber]
  • SETup:ORFSpectrum:MODulation:COUNt:NUMBer
  • SETup:ORFSpectrum:MODulation:FREQuency[:OFFSet]
  • SETup:ORFSpectrum:MODulation:FREQuency:OFFSet:ALL
  • SETup:ORFSpectrum:MODulation:FREQuency:POINts?
  • SETup:ORFSpectrum:MODulation:LIMit:MANual<[1]|2>[:SELected]
  • SETup:ORFSpectrum:MODulation:RELative:LIMit:CUSTom<[1]|2>
  • SETup:ORFSpectrum:MODulation:RELative:LIMit:CUSTOM<[1]|2>:POINts?
  • SETup:ORFSpectrum:SWITching:COUNt[:SNUMber]
  • SETup:ORFSpectrum:SWITching:COUNt:NUMBer
  • SETup:ORFSpectrum:SWITching:FREQuency[:OFFSet]
  • SETup:ORFSpectrum:SWITching:FREQuency:OFFSet:ALL
  • SETup:ORFSpectrum:SWITching:FREQuency:POINts?
  • SETup:ORFSpectrum:SWITching:LIMit:CUSTom
  • SETup:ORFSpectrum:SWITching:LIMit:CUSTom:POINts?
  • SETup:ORFSpectrum:SWITching:LIMit:MANual[:SELected]
  • SETup:ORFSpectrum:SWITching:TIME:DOMain:STATe
  • SETup:ORFSpectrum:SWITching:TIME:DOMain:FREQuency:OFFSet:INDex
  • SETup:ORFSpectrum:TIMeout:TIME
  • SETup:ORFSpectrum:TIMeout[:STIMe]
  • SETup:ORFSpectrum:TIMeout:STATe
  • SETup:ORFSpectrum:TRIGer:DELay
  • SETup:ORFSpectrum:TRIGger:SOURce

  • SETup:PCALibration:FILTer
  • SETup:PCALibration:MEASurement:COUNt
  • SETup:PCALibration:MEASurement:DELay
  • SETup:PCALibration:RESult:TYPE
  • SETup:PCALibration:STEP:CENTer
  • SETup:PCALibration:STEP:COUNt
  • SETup:PCALibration:STEP:WIDth
  • SETup:PCALibration:TIMeout:STATe
  • SETup:PCALibration:TIMeout:STIMe
  • SETup:PCALibration:TIMeout:TIME
  • SETup:PCALibration:TRIGger:DELay
  • SETup:PCALibration:TRIGger:SOURce
  • SETup:PCALibration:TRIGger:THReshold
  • SETup:PCALibration:WAVeform:TYPE

  • SETup:PFERror:CONFidence:LEVel[:SELected]
  • SETup:PFERror:CONFidence:LEVel:GSM
  • SETup:PFERror:CONFidence[:SLEVel][:SELected]
  • SETup:PFERror:CONFidence[:SLEVel]:GSM
  • SETup:PFERror:CONFidence:STATe[:SELected]
  • SETup:PFERror:CONFidence:STATe:GSM
  • SETup:PFERror:CONTinuous
  • SETup:PFERror:COUNt[:SNUMber]
  • SETup:PFERror:COUNt:NUMBer
  • SETup:PFERror:COUNt:STATe
  • SETup:PFERror:FERRor[:LIMit]:GSM
  • SETup:PFERror:FERRor[:LIMit][:SELected]
  • SETup:PFERror:PEAK[:LIMit]:GSM
  • SETup:PFERror:PEAK[:LIMit][:SELected]
  • SETup:PFERror:RMS[:LIMit]:GSM
  • SETup:PFERror:RMS[:LIMit][:SELected]
  • SETup:PFERror:SYNC
  • SETup:PFERror:TBDemod
  • SETup:PFERror:TIMeout[:STIMe]
  • SETup:PFERror:TIMeout:TIME
  • SETup:PFERror:TIMeout:STATe
  • SETup:PFERror:TRIGger:DELay
  • SETup:PFERror:TRIGer:SOURce
  • SETup:PFERror:TRIGger:QUALifier[:SELected]
  • SETup:PFERror:TRIGger:QUALifier:GSM

  • SETup:PVTime:BURSt:CAPTure
  • SETup:PVTime[:BURSt[1]]:MASK[:SELected]
  • SETup:PVTime:BURSt2|3|4|5|6:MASK[:SELected]
  • SETup:PVTime[:BURSt[1]]:MASK:GPERiod
  • SETup:PVTime:BURSt2|3|4|5:MASK:GPERiod
  • SETup:PVTime[:BURSt[1]]:MASK:GPERiod:CUSTom:HIGH
  • SETup:PVTime[:BURSt[1]]:MASK:GPERiod:CUSTom:LOW
  • SETup:PVTime[:BURSt[1]]:MASK[:SELected]:LOWer?
  • SETup:PVTime:BURSt2|3|4|5|6:MASK[:SELected]:LOWer?
  • SETup:PVTime[:BURSt[1]]:MASK[:SELected]:LOWer?
  • SETup:PVTime:BURSt2|3|4|5|6:MASK[:SELected]:LOWer?
  • SETup:PVTime[:BURSt[1]]:MASK[:SELected]:LOWer:POINts?
  • SETup:PVTime:BURSt2|3|4|5|6:MASK[:SELected]:LOWer:POINts?
  • SETup:PVTime[:BURSt[1]]:MASK[:SELected]:UPPer?
  • SETup:PVTime:BURSt2|3|4|5|6:MASK[:SELected]:UPPer?
  • SETup:PVTime[:BURSt[1]]:MASK[:SELected]:UPPer:POINts?
  • SETup:PVTime:BURSt2|3|4|5|6:MASK[:SELected]:UPPer:POINts?
  • SETup:PVTime[:BURSt[1]]:TIME[:OFFSet][:SELected]
  • SETup:PVTime:BURSt2|3|4|5|6:TIME[:OFFSet][:SELected]
  • SETup:PVTime[:BURSt[1]]:TIME:POINts[:SELected]?
  • SETup:PVTime:BURSt2|3|4|5|6:TIME:POINts[:SELected]?
  • SETup:PVTime:CONTinuous[:SELected]
  • SETup:PVTime:COUNt[:SNUMber]
  • SETup:PVTime:COUNt:NUMBer
  • SETup:PVTime:COUNt:STATe
  • SETup:PVTime:CUSTom1:MASK:LOWer?
  • SETup:PVTime:CUSTom2:MASK:LOWer?
  • SETup:PVTime:CUSTom1:MASK:LOWer:POINts?
  • SETup:PVTime:CUSTom2:MASK:LOWer:POINts?
  • SETup:PVTime:CUSTom1:MASK:UPPer?
  • SETup:PVTime:CUSTom2:MASK:UPPer?
  • SETup:PVTime:CUSTom1:MASK:UPPer:POINts?
  • SETup:PVTime:CUSTom2:MASK:UPPer:POINts?
  • SETup:PVTime:ETXPower[:METHod]
  • SETup:PVTime:GRAPh:POWer:REFerence
  • SETup:PVTime:GRAPh:STATe
  • SETup:PVTime:GRAPh:TIME:REFerence
  • SETup:PVTime:LIMit:ETSI:PCS
  • SETup:PVTime:RANGing[:MODE]
  • SETup:PVTime:BSYNc
  • SETup:PVTime:SYNC
  • SETup:PVTime:TIMeout[:STIMe]
  • SETup:PVTime:TIMeout:TIME
  • SETup:PVTime:TIMeout:STATe
  • SETup:PVTime:TRIGger:DELay
  • SETup:PVTime:TRIGger:SOURce
  • SETup:PVTime:VIDeo:FILTer:BWIDth

  • SETup:SBERror:CLSDelay[:STIMe]
  • SETup:SBERror:CLSDelay:TIME
  • SETup:SBERror:CLSDelay:STATe
  • SETup:SBERror:CONTinuous
  • SETup:SBERror:COUNt
  • SETup:SBERror:LDControl:AUTO
  • SETup:SBERror:MANual:DELay
  • SETup:SBERror:TIMeout[:STIMe]
  • SETup:SBERror:TIMeout:TIME
  • SETup:SBERror:TIMeout:STATe

  • SETup:SFERate:CONTinuous
  • SETup:SFERate:SAMPles
  • SETup:SFERate:TIMeout[:STIMe]
  • SETup:SFERate:TIMeout:TIME
  • SETup:SFERate:TIMeout:STATe

  • SETup:SMONitor:AMPLitude:PDIVision
  • SETup:SMONitor:AMPLitude:RLEVel:AUTO
  • SETup:SMONitor:AMPLitude:RLEVel:MANual
  • SETup:SMONitor:BANDwidth|BWIDth[:RESolution]?
  • SETup:SMONitor:BANDwidth|BWIDth:AUTO
  • SETup:SMONitor:BANDwidth|BWIDth:MANual
  • SETup:SMONitor:BANDwidth|BWIDth:ZSPan[:RESolution]
  • SETup:SMONitor:COUNt[:SNUMber]
  • SETup:SMONitor:COUNt:NUMber
  • SETup:SMONitor:COUNt:STATe
  • SETup:SMONitor:CONTinous
  • SETup:SMONitor:DETector[:TYPE]
  • SETup:SMONitor:FREQuency:SPAN
  • SETup:SMONitor:TIME:OFFSet
  • SETup:SMONitor:TIME:SPAN
  • SETup:SMONitor:TIMeout[:STIMe]
  • SETup:SMONitor:TIMeout:STATe
  • SETup:SMONitor:TIMeout:TIME
  • SETup:SMONitor:TRACe:MODE
  • SETup:SMONitor:TRiGger:DELay
  • SETup:SMONitor:TRiGger:SOURce

  • SETup:TXPower:BURSt:CAPTure
  • SETup:TXPower:CONTinuous
  • SETup:TXPower:COUNt[:SNUMber]
  • SETup:TXPower:COUNt:NUMBer
  • SETup:TXPower:COUNt:STATe
  • SETup:TXPower:ECPower:STATe
  • SETup:TXPower:FRAMe:QUALifier
  • SETup:TXPower:GFDTune:RSET
  • SETup:TXPower:GFDTune:THReshold
  • SETup:TXPower:RANGe:AUTO
  • SETup:TXPower:SSTep:FRAMes?
  • SETup:TXPower:TIMeout[:STIMe]
  • SETup:TXPower:TIMeout:TIME
  • SETup:TXPower:TIMeout:STATe
  • SETup:TXPower:TRIGger:DELay
  • SETup:TXPower:TRIGger:QUALifier
  • SETup:TXPower:TRIGger:SOURce

STATus Subsystem

  • *ESR?
  • *ESE?
  • *ESE

  • STATus:OPERation Condition Register Bit Assignment
  • STATus:OPERation:CALL Condition Register Bit Assignment
  • STATus:OPERation:CALL:COMMon Condition Register Bit Assignment
  • STATus:OPERation:CALL:COMMon:DAINterface Condition Register Bit Assignment
  • STATus:OPERation:CALL:COMMon:DATA Condition Register Bit Assignment
  • STATus:OPERation:CALL:GSM Condition Register Bit Assignment
  • STATus:OPERation:FEATures Register Bit Assignments
  • STATus:OPERation:FEATures:COMMon Register Bit Assignments
  • STATus:OPERation:FEATures:COMMon:SMService Register Bit Assignments
  • STATus:OPERation:HARDware Register Bit Assignments
  • STATus:OPERation:KEYPressed Register Bit Assignments
  • STATus:OPERation:NMRReady Condition Register Bit Assignment
  • STATus:OPERation:NMRReady:AMPS Condition Register Bit Assignment
  • STATus:OPERation:NMRReady:COMMon Condition Register Bit Assignment
  • STATus:OPERation:NMRReady:GPRS Condition Register Bit Assignment
  • STATus:OPERation:NMRReady:GSM Condition Register Bit Assignment

  • STATus:PRESet

  • STATus:QUEStionable Condition Register Bit Assignment
  • STATus:QUEStionable:CALL Condition Register Bit Assignment
  • STATus:QUEStionable:CALL:COMMon Condition Register Bit Assignment
  • STATus:QUEStionable:CALL:GPRS Condition Register Bit Assignment
  • STATus:QUEStionable:CALL:GSM Condition Register Bit Assignment
  • STATus:QUEStionable:ERRors Condition Register Bit Assignment
  • STATus:QUEStionable:ERRors:COMMon Condition Register Bit Assignment
  • STATus:QUEStionable:ERRors:GPRS Condition Register Bit Assignment
  • STATus:QUEStionable:ERRors:GSM Condition Register Bit Assignment
  • STATus:QUEStionable:HARDware Condition Register Bit Assignment

  • *STB?

SYSTem Subsystem

  • SYSTem:APPLication[:CURRent][:NAME]?
  • SYSTem:APPLication[:CURRent]:REVision?
  • SYSTem:APPLication:CATalog[:NAME]?
  • SYSTem:APPLication:CATalog[:NAME]:COUNt?
  • SYSTem:APPLication:CATalog:FORMat?
  • SYSTem:APPLication:CATalog:FORMat:COUNt?
  • SYSTem:APPLication:CATalog:LICense?<sp>'<application name>','<revision>'
  • SYSTem:APPLication:CATalog:LICense:APPLication:ALL?
  • SYSTem:APPLication:CATalog:LICense:APPLication:COUNt?
  • SYSTem:APPLication:CATalog:REVision?<sp>'<application name>'
  • SYSTem:APPLication:CATalog:REVision:COUNt?<sp>'<application name>'
  • SYSTem:APPLication:FORMat[:NAME]
  • SYSTem:APPLication:FORMat:LICense?<sp>'<format name>'
  • SYSTem:APPLication:FORMat:NAS|NASTratum
  • SYSTem:APPLication:SELect[:NAME]
  • SYSTem:APPLication:SELect:REVision
  • SYSTem:APPLication:SELect:REVision?<sp>'<application name>'

  • SYSTem:AUDio:OUTPut:SOURce
  • SYSTem:AUDio:OUTPut:FMDemod:BPFilter:STATe
  • SYSTem:AUDio:OUTPut:FMDemod:EXPandor:STATe
  • SYSTem:AUDio:OUTPut:FMDemod:DEEMphasis:STAT

  • SYSTem:BEEPer:STATe

  • SYSTem:COMMunicate:GPIB:[:SELF]:ADDRess
  • SYSTem:COMMunicate:GPIB:DEBug[:STATe]
  • SYSTem:COMMunicate:LAN[:SELF]:ADDRess
  • SYSTem:COMMunicate:LAN[:SELF]:ADDRess2
  • SYSTem:COMMunicate:LAN[:SELF]:DGATeway
  • SYSTem:COMMunicate:LAN[:SELF]:SMASk

  • SYSTem:CONFigure:INFormation:HARDware:VERBose?

  • SYSTem:CORRection:[:SGAin]
  • SYSTem:CORRection:FREQuency
  • SYSTem:CORRection:GAIN
  • SYSTem:CORRection:POINts
  • SYSTem:CORRection:SFRequency
  • SYSTem:CORRection:STATe

  • SYSTem:CURRent:TA:MODel?
  • SYSTem:CURRent:TA:NAME?
  • SYSTem:CURRent:TA:REVision?

  • SYSTem:DATE

  • SYSTem:ERRor?

  • SYSTem:FATal:ERRor:RESTart

  • SYSTem:FTRigger:BIT[:SELected]
  • SYSTem:FTRigger:BIT:GSM
  • SYSTem:FTRigger:STATe[:SELected]
  • SYSTem:FTRigger:STATe:GSM
  • SYSTem:FTRigger:TSLot[:SELected]
  • SYSTem:FTRigger:TSLot:GSM

  • SYSTem:INSTrument:TEMPerature?
  • SYSTem:INSTrument:THERmal:POWer:NULL:ADJust:INFormation?

  • SYSTem:LOG:UI:CLEAR
  • SYSTem:LOG:UI:GPIB[:STATe]
  • SYSTem:LOG:UI:COUNt?
  • SYSTem:LOG:UI:REPort?

  • SYSTem:MEASurement:RESet

  • SYSTem:PRESet[1] (not recommended for use)
  • SYSTem:PRESet2
  • SYSTem:PRESet3

  • SYSTem:REGister:SAVE
  • SYSTem:REGister:RECall
  • SYSTem:REGister:DELete

  • SYSTem:ROSCillator[:TIMebase]?
  • SYSTem:ROSCillator:LOCKed?

  • SYSTem:STATus:COMMunicate:LAN:EXTernal[:CONNected][:STATe]
  • SYSTem:STATus:COMMunicate:LAN:EXTernal[:CONNected]:ADDRess
  • SYSTem:STATus:COMMunicate:LAN:EXTernal:SYNChronize[:STATe]?

  • SYSTem:SYNChronized

  • SYSTem:TIME

  • SYSTem:TZONe

  • SYSTem:UTC[:TIME]
  • SYSTem:UTC:DATE


READ

READ

GPIB Command Conventions

  • READ:AAUDio[:ALL]?
  • READ:BERRor[:ALL]?
  • READ:BERRor:FULL?
  • READ:BLERror[:ALL]?
  • READ:BLERror:BURSt[:ALL]?
  • READ:BFINdication|BFI[:ALL]?
  • READ:DAUDio[:ALL]?
  • READ:DPOWer[:ALL]?
  • READ:EDPower[:ALL][:RANGe1|RANGe2|RANGe3|RANGe4|RANGe5|RANGe6|RANGe7|RANGe8|RANGe9|RANGe10]?
  • READ:EMACcuracy[:ALL]?
  • READ:EMACcuracy[:ALL]:ETSI?
  • READ:ETXPower[:ALL]?
  • READ:FBERror[:ALL]?
  • READ:FFERate[:ALL]?
  • READ:FSTability[:ALL]?
  • READ:GBERror[:ALL]?
  • READ:IFERror[:ALL]?
  • READ:IQTuning[:ALL]?
  • READ:MTAudio[:ALL]?
  • READ:ORFSpectrum[:ALL]?
  • READ:PCALibration[:ALL]?
  • READ:PFERror[:ALL]?
  • READ:PFERror[:ALL]:FAIL?
  • READ:PVTime[:ALL]?
  • READ[:BURSt[1]]:PVTime[:ALL]?
  • READ:BURSt2|3|4|5:PVTime[:ALL]?
  • READ:SBERror[:ALL]?
  • READ:SFERate[:ALL]?
  • READ:SMONitor:TRACe?
  • READ:TXPower[:ALL]?

READ:AAUDio[:ALL]?

Function

 GSM TA

Queries (initiates and fetches) one analog audio measurement as a sequential operation.

Returns an integrity indicator (see Integrity Indicator ), average analog audio level, average SINAD, average distortion and the average audio frequency. Values are returned in a comma-separated list.

Returns Integrity Indicator, see Integrity Indicator and analog audio (average). The FETCh command should be used to obtain other measurement results. See FETCh:AAUDio .

GSM/GPRS LA

EGPRS LA

GPRS TA

This command is not applicable to GPRS.

EGPRS TA

This command is not applicable to EGPRS.
Query

Integrity indicator

  • Range: See Integrity Indicator .
  • Resolution: 1

Analog audio (average)

  • Range: 0 to 20 volts
  • Resolution: 0.1mv

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

READ:BERRor[:ALL]?

Function

 GSM TA

Queries (initiates and fetches) one RX bit error measurement as a sequential operation.

Returns Integrity Indicator see Integrity Indicator , Bits Tested, Bit Error Ratio and Bit Error Count, for the bit type set using SETup:BERRor[:TYPE] . (A similar query, READ:BERRor:FULL? , returns the same results but for all residual, or all non-residual bit types simultaneously.) The FETCh command should be used to obtain other measurement results. See FETCh:BERRor .

GSM/GPRS LA

EGPRS LA

GPRS TA

This command is not applicable to GPRS.

EGPRS TA

This command is not applicable to EGPRS.
Query

Integrity indicator

  • Range: See Integrity Indicator .
  • Resolution: 1

Bits tested

  • Range: 0 to (<RX bits to test +131) and 9.91E+37 (NAN)
  • Resolution: 1

Bit error ratio

  • Range: 0 to 100 and 9.91E+37 (NAN)
  • Resolution: 1

Bit error count

  • Range: 0 to (<RX bits to test +131) and 9.91E+37 (NAN)
  • Resolution: 1

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

READ:BERRor:FULL?

Function

 GSM TA

Queries (initiates and fetches) one RX bit error measurement as a sequential operation. Either all of the residual or non-residual results are returned, depending on the type of bit error measurement set using SETup:BERRor[:TYPE] .

Returns Integrity Indicator (see Integrity Indicator ), Bits Tested, Bit Error Ratio and Bit Error Count for Type Ia, Type Ib and Type II.

(A similar query, READ:BERRor[:ALL]? , returns the same results but only for the bit type previously set using SETup:BERRor[:TYPE] .)

The FETCh command should be used to obtain other measurement results. See FETCh:BERRor .

GSM/GPRS LA

EGPRS LA

GPRS TA

This command is not applicable to GPRS.

EGPRS TA

This command is not applicable to EGPRS.

Query

Integrity indicator

  • Range: See Integrity Indicator .
  • Resolution: 1

Type Ia Bits tested

  • Range: 0 to 999000 and 9.91E+37 (NAN)
  • Resolution: 1

Type Ia Bit error ratio

  • Range: 0 to 100 and 9.91E+37 (NAN)
  • Resolution: 0.01

Type Ia Bit error count

  • Range: 0 to 999000 and 9.91E+37 (NAN)
  • Resolution: 1

Type Ib Bits tested

  • Range: 0 to 2637369 and 9.91E+37 (NAN)
  • Resolution: 1

Type Ib Bit error ratio

  • Range: 0 to 100 and 9.91E+37 (NAN)
  • Resolution: 0.01

Type Ib Bit error count

  • Range: 0 to 2637369 and 9.91E+37 (NAN)
  • Resolution: 1

Type II Bits tested

  • Range: 0 to 15584400 and 9.91E+37 (NAN)
  • Resolution: 1

Type II Bit error ratio

  • Range: 0 to 100 and 9.91E+37 (NAN)
  • Resolution: 0.01

Type II Bit error count

  • Range: 0 to 1558440 and 9.91E+37 (NAN)
  • Resolution: 1

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

READ:BLERror[:ALL]?

Function

 GSM TA

This command is not applicable to GSM.

GPRS TA

Queries (initiates and fetches) one block error measurement as a sequential operation.

Returns Integrity Indicator (see Integrity Indicator ), Blocks Tested, Block Error Ratio, and Block Error Count. The FETCh command should be used to obtain other measurement results. See FETCh:BLERror .

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Integrity indicator

  • Range: See Integrity Indicator .
  • Resolution: 1

Blocks tested

  • Range: 0 to 99127 and 9.91E+37 (NAN)
  • Resolution: 1

Block error ratio

  • Range: 0 to 100 and 9.91E+37 (NAN)
  • Resolution: 1

Block error count

  • Range: 0 to 99127 and 9.91E+37 (NAN)
  • Resolution: 1
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

READ:BLERror:BURSt[:ALL]?

Function

 GSM TA

This command is not applicable to GSM.

GPRS TA

Queries the block error measurement results for all the bursts. The total integrity indicator and the block error ratio for burst 1 to 8 are returned. Note, the block error ratio for burst 6, 7 and 8 are always NAN. .

This query can only be used when the BLER measurement method is Polling. See Block Error Measurement for more information about the BLER measurement methods.

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Integrity indicator:

  • Range: See Integrity Indicator .
  • Resolution: 1

Block error ratio:

  • Range: 0 to 100 and 9.91 E+37 (NAN)
  • Resolution: 0.01
Requirements GSM/GPRS/
EGPRS TA

Revision: A.09 and above
GSM/GPRS/ EGPRS LA

Revision F.01 and above
Programming Example
OUTPUT 714;"READ:BLER:BURS:ALL?"

READ:BFINdication|BFI[:ALL]?

Function

GSM/GPRS LA

Queries (initiates and fetches) one bad frame indication measurement as a sequential operation.

Returns Integrity Indicator see Integrity Indicator , Number of Samples Counted, Number of Undetected Bad Frames, Number of SIDs Reported as Bad Frames, and the Number of SIDs Sent. The FETCh command should be used to obtain other measurement results. See FETCh:<BFINdication|BFI> .

EGPRS LA
GSM TA This command is not applicable to the GSM Test Application.

GPRS TA

This command is not applicable to GPRS.
EGPRS TA

This command is not applicable to EGPRS.
Query

Integrity indicator

  • Range: See Integrity Indicator .
  • Resolution: 1

Samples

  • Range: 0 to 999999 and 9.91E+37 (NAN)
  • Resolution: 1

Undetected Bad Frames

  • Range: 0 to 999999 and 9.91E+37 (NAN)
  • Resolution: 1

SIDs marked as BFI

  • Range: 0 to 999999 and 9.91E+37 (NAN)
  • Resolution: 1

SIDs sent

  • Range: 0 to 999999 and 9.91E+37 (NAN)
  • Resolution: 1
Requirements GSM/GPRS/ EGPRS LA

Revision: C.03 and above

READ:DAUDio[:ALL]?

Function

 GSM TA

Queries (initiates and fetches) one decoded audio (uplink speech level) measurement as a sequential operation.

Returns Integrity Indicator see Integrity Indicator and decoded audio (average). The FETCh command should be used to obtain other measurement results. See FETCh:DAUDio .

GSM/GPRS LA

EGPRS LA

GPRS TA

This command is not applicable to GPRS.

EGPRS TA

This command is not applicable to EGPRS.

Query

Integrity indicator

  • Range: See Integrity Indicator .
  • Resolution: 1

Decoded audio (average)

  • Range: 0 to 100% FS (full scale)
  • Resolution: 0.01% FS

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

READ:DPOWer[:ALL]?

Function

 GSM TA Queries the Dynamic Power measurement results. Query returns N integrity indicators and N average TX power levels (where N is the number of bursts measured). To set the number of bursts you want to measure, use SETup:DPOWer:COUNt:NUMBer[:SELected] . The maximum number of results that can be returned is 99. Measurement result 100 and above must be retrieved using the FETCh command.

GSM/GPRS LA

GPRS TA

EGPRS TA

EGPRS LA

Query

Integrity indicators for each individual burst

  • Range: See Integrity Indicator .
  • Resolution: 1

Average TX power levels for each individual burst

  • Range: -100 to +100 dBm and 9.91 E+37 (NAN)
  • Resolution: 0.01 dBm

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

READ:EDPower[:ALL][:RANGe1|RANGe2|RANGe3|RANGe4|RANGe5|RANGe6|RANGe7|RANGe8|RANGe9|RANGe10]?

Function

 GSM TA Queries the EDGE Dynamic Power measurement results. Query returns N integrity indicators and N average TX power levels (where N is the number of measurement results present in the specified range). To set the number of bursts you want to measure, use SETup:EDPower:COUNt:NUMBer .

GSM/GPRS LA

GPRS TA

EGPRS TA

EGPRS LA

Query

Integrity indicators for each individual burst

  • Range: See Integrity Indicator .
  • Resolution: 1

Average TX power levels for each individual burst

  • Range: -100 to +100 dBm and 9.91 E+37 (NAN)
  • Resolution: 0.01 dB

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.04 and above

Revision A.05 makes the EDP Measurement available in all TAs.
GSM/GPRS/ EGPRS LA

Revision: D.01 and above

Revision D.02 makes the EDP Measurement available in all LAs.

READ:EMACcuracy[:ALL]?

Function

 GSM TA

This command is not applicable to the GSM TA.

GPRS TA

This command is not applicable to the GPRS TA.

GSM/GPRS LA

This command is not applicable to the GSM/GPRS LA.

EGPRS TA

Queries (initiates and fetches) the 8PSK multislot modulation accuracy measurement results as a sequential operation.

Queries integrity indicator, RMS error vector magnitude (EVM), peak EVM, 95th percentile EVM, frequency error, origin offset suppression, RMS phase error, peak phase error, RMS magnitude error, peak magnitude error, amplitude droop, IQ imbalance.

EGPRS LA

Query

Integrity indicator

  • Range: See Integrity Indicator .
  • Resolution: 1

RMS Error Vector Magnitude

  • Range: 0 % to 100 % and 9.91 E+37 (NAN)
  • Resolution: 0.01 %

Peak Error Vector Magnitude

  • Range: 0 % to 100 % and 9.91 E+37 (NAN)
  • Resolution: 0.01 %

95th Percentile Error Vector Magnitude

  • Range: 0 % to 100 % and 9.91 E+37 (NAN)
  • Resolution: 0.01 %

Frequency Error

  • Range: -9999 Hz to +9999 Hz and 9.91 E+37 (NAN)
  • Resolution: 0.01 Hz

Origin Offset Suppression

  • Range: -70 dB to 0 dB and 9.91 E+37 (NAN)
  • Resolution: 0.01 dB

RMS Phase Error

  • Range: 0 to 180 degrees and 9.91 E+37 (NAN)
  • Resolution: 0.01 degrees

Peak Phase Error

  • Range: 0 to 180 degrees and 9.91 E+37 (NAN)
  • Resolution: 0.01 degrees

RMS Magnitude Error

  • Range: 0 to 100 % and 9.91 E+37 (NAN)
  • Resolution: 0.01 %

Peak Magnitude Error

  • Range: 0 to 100 % and 9.91 E+37 (NAN)
  • Resolution: 0.01 %

Amplitude Droop

  • Range: -20 dB to +20 dB and 9.91 E+37 (NAN)
  • Resolution: 0.01 dB

IQ Imbalance

  • Range: 0 dB to +100 dB and 9.91 E+37 (NAN)
  • Resolution: 0.01 dB
Requirements GSM/GPRS/
EGPRS TA

Revision: A.03 and above
GSM/GPRS/ EGPRS LA

Revision: C.03 and above

READ:EMACcuracy[:ALL]:ETSI?

Function

 GSM TA

This command is not applicable to the GSM TA.

GPRS TA

This command is not applicable to the GPRS TA.

GSM/GPRS LA

This command is not applicable to the GSM/GPRS LA.

EGPRS TA

Queries (initiates and fetches) the ETSI specified 8PSK multislot modulation accuracy results. The query returns integrity indicator, RMS error vector magnitude (EVM), peak EVM, 95th percentile EVM, frequency error, and origin offset suppression.

EGPRS LA

Query

Integrity indicator

  • Range: See Integrity Indicator .
  • Resolution: 1

RMS Error Vector Magnitude

  • Range: 0 % to 100 % and 9.91 E+37 (NAN)
  • Resolution: 0.01 %

Peak Error Vector Magnitude

  • Range: 0 % to 100 % and 9.91 E+37 (NAN)
  • Resolution: 0.01 %

95th Percentile Error Vector Magnitude

  • Range: 0 % to 100 % and 9.91 E+37 (NAN)
  • Resolution: 0.01 %

Frequency Error

  • Range: -9999 Hz to +9999 Hz and 9.91 E+37 (NAN)
  • Resolution: 0.01 Hz

Origin Offset Suppression

  • Range: -70 dB to 0 dB and 9.91 E+37 (NAN)
  • Resolution: 0.01 dB
Requirements GSM/GPRS/
EGPRS TA

Revision: A.03 and above
GSM/GPRS/ EGPRS LA

Revision: C.03 and above

READ:ETXPower[:ALL]?

Function

 GSM TA

This command is not applicable to the GSM TA.

GPRS TA

This command is not applicable to the GPRS TA.

GSM/GPRS LA

This command is not applicable to the GSM/GPRS LA.

EGPRS TA

Queries (initiates and fetches) one EGPRS TX power measurement as a sequential operation.

Returns Integrity Indicator (see Integrity Indicator ), average burst power, and average estimated carrier power.

When the selected modulation format is set to GMSK, Burst Power and Carrier Power measurements are equivalent so both results return the same value.

EGPRS LA

Query

Integrity indicator

  • Range: See Integrity Indicator .
  • Resolution: 1

Burst power (average)

  • Range: -100 to +100 dBm and 9.91E+37 (NAN)
  • Resolution: 0.01 dB

Estimated carrier power (average)

  • Range: -100 to +100 dBm and 9.91E+37 (NAN)
  • Resolution: 0.01 dB
Requirements GSM/GPRS/
EGPRS TA

Revision: A.03 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

READ:FBERror[:ALL]?

Function

 GSM

Queries (initiates and fetches) one fast bit error measurement as a sequential operation.

Returns Integrity Indicator see Integrity Indicator , Bits Tested, Bit Error Ratio, and Fast Bit Error Count using mobile station burst-by-burst looback (type C loopback). The FETCh command should be used to obtain other measurement results. See FETCh:BERRor .
GSM/GPRS LA

EGPRS LA

GPRS TA

This command is not applicable to GPRS.

EGPRS TA

This command is not applicable to EGPRS.

Query

Integrity indicator

  • Range: See Integrity Indicator .
  • Resolution: 1

Bits tested

  • Range: 0 to (RX Fast BER bits to test + 455) and 9.91E+37 (NAN)
  • Resolution: 1

Bit error ratio

  • Range: 0 to 100 and 9.91E+37 (NAN)
  • Resolution: 1

Fast bit error count

  • Range: 0 to (RX Fast BER bits to test + 455) and 9.91E+37 (NAN)
  • Resolution: 1

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

READ:FFERate[:ALL]?

Function

 GSM/GPRS LA

Queries (initiates and fetches) one frame erasure rate on FACCH full rate speech measurement as a sequential operation.

Returns Integrity Indicator see Integrity Indicator , Samples, Frame Erasure Ratio, and Count of Retransmissions. The FETCh command should be used to obtain other measurement results. See FETCh:FFERate .

EGPRS LA

GSM TA

This command is not applicable to the GSM Test Application.

GPRS TA

This command is not applicable to the GPRS Test Application.

EGPRS TA

This command is not applicable to the EGPRS Test Application.

Query

Integrity indicator

  • Range: See Integrity Indicator .
  • Resolution: 1

Samples

  • Range: 0 to 999999 and 9.91E+37 (NAN)
  • Resolution: 1

Frame erasure ratio

  • Range: 0 to 100% and 9.91E+37 (NAN)
  • Resolution: 0.001

Frame erasure count

  • Range: 0 to 999999 and 9.91E+37 (NAN)
  • Resolution: 1

Requirements

 GSM/GPRS/ EGPRS LA

Revision: C.03 and above

READ:FSTability[:ALL]?

Function

 GSM TA

Initiates and fetches a frequency stability measurement as a sequential operation.

Measurement results are returned in the following order: integrity, worst-case frequency error, average frequency.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Function

Initiates and fetches a frequency stability measurement as a sequential operation.

Measurement results are returned in the following order: integrity, worst-case frequency error, average frequency.
Query

Integrity

  • Range: 0 to 23 see Integrity Indicator
  • Resolution: 1

Worst-case frequency error

  • Range: -500 to 500 parts per million (ppm), 9.91 E+37
  • Resolution: 0.01

Average frequency

  • Range: 100 E+6 to 3 E+9 Hz, 9.91 E+37
  • Resolution: 1 Hz
Requirements GSM/GPRS/
EGPRS TA

Revision: A.04 and above
GSM/GPRS/ EGPRS LA

Revision: D.01 and above

READ:GBERror[:ALL]?

Function

 GSM TA

This command is not applicable to GSM.

GPRS TA

Queries (initiates and fetches) one bit error measurement as a sequential operation.

Returns Integrity Indicator see Integrity Indicator , Bits Tested, Bit Error Ratio, and Bit Error Count. The FETCh command should be used to obtain other measurement results. See FETCh:GBERror .

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Integrity indicator

  • Range: See Integrity Indicator .
  • Resolution: 1

Bits tested

  • Range: 0 to 999,427 and 9.91E+37 (NAN)
  • Resolution: 1

Bit error ratio

  • Range: 0 to 100 and 9.91E+37 (NAN)
  • Resolution: 1

Bit error count

  • Range: 0 to 999,427 and 9.91E+37 (NAN)
  • Resolution: 1
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

READ:IFERror[:ALL]?

Function

 GSM TA

This command is not applicable to the GSM TA.
GPRS TA

This command is not applicable to the GPRS TA.
EGPRS TA

This command is not applicable to the EGPRS TA.

GSM/GPRS LA

Queries (initiates and fetches) one bit error measurement as a sequential operation.

Returns the results in the following order: integrity, speech frames measured, frame error ratio, and frame error count.

EGPRS LA

Query

Integrity indicator

  • Range: See Integrity Indicator .
  • Resolution: 1

Number of speech frames tested

  • Range: 1 to 900000 or 9.91e+37 (NAN)
  • Resolution: 1

Frame Error Ratio

  • Range: 0 to 100 or 9.91e+37 (NAN)
  • Resolution: .001

Frame Error Count

  • Range: 0 to 900000 or 9.91e+37 (NAN)
  • Resolution: 1
Requirements GSM/GPRS/ EGPRS LA

Revision: D.01 and above

READ:IQTuning[:ALL]?

Function

 GSM TA

Queries (initiates and fetches) the I/Q Tuning measurement results. Query returns the integrity indicator and the relative power level at the following offset frequencies: carrier frequency, 䕧.7083 kHz, 𫏯.417 kHz, 𫐳.125 kHz, 𫑶.833 kHz. The spur measurement result is also returned.

The FETCh command should be used to return other measurement results. See FETCh:IQTuning .

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Integrity indicator

  • Range: See Integrity Indicator .
  • Resolution: 1

Signal level relative to the desired signal at 9 different frequencies

  • Range: -100 to +100 dB and 9.91 E+37 (NAN)
  • Resolution: 0.01 dB

The order of the signal level results are:

  • -270.833 kHz
  • -203.125 kHz
  • -135.417 kHz
  • -67.7083 kHz
  • carrier frequency
  • +67.7083 kHz
  • +135.417 kHz
  • +203.125 kHz
  • +270.833 kHz

Relative power of the spur frequency:

  • Range: -100 to +100 dB and 9.91E+37 (NAN)
  • Resolution: 0.01 dB

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

READ:MTAudio[:ALL]?

Function

 GSM TA

Queries (initiates and fetches) the Multi-Tone Audio measurement results. Query returns the integrity indicator and a comma separated list of RMS audio levels for the 20 audio tones.

The FETCh command should be used to return other measurement results. See FETCh:MTAudio[:ALL]? .

GSM/GPRS LA

EGPRS LA

GPRS TA

 This command is not applicable to GPRS.

EGPRS TA

This command is not applicable to EGPRS.

Query

Integrity indicator

  • Range: See Integrity Indicator .
  • Resolution: 1

Audio level

  • Range: -100 to +100 dB and 9.91 E+37 (NAN)
  • Resolution: 0.1 dB

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

READ:ORFSpectrum[:ALL]?

Function

 GSM TA

Queries (initiates and fetches) one output RF spectrum measurement as a sequential operation.

Returns Integrity Indicator see Integrity Indicator , TX Power, Output RF Spectrum due to Switching (Max), 30 kHz Bandwidth Power, and Output RF Spectrum due to Modulation (Average). The FETCh command should be used to obtain other measurement results. See FETCh:ORFSpectrum .

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Integrity indicator

  • Range: See Integrity Indicator .
  • Resolution: 1

TX power

  • Range: -100 to +100 dBm and 9.91E+37 (NAN)
  • Resolution: 0.01 dB

Output RFspectrum due to switching (Max)

  • Range: 0 to 8 comma separated values -100 to +100 dBm and 9.91E+37 (NAN)
  • Resolution: 0.01 dB

30 kHz bandwidth power

  • Range: -100 to +100 dBm and 9.91E+37 (NAN)
  • Resolution: 0.01 dB

Output RF spectrum due to modulation (average)

  • Range: 0 to 22 comma separated values -200 to +100 dBm and 9.91E+37 (NAN)
  • Resolution: 0.01 dB
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

READ:PCALibration[:ALL]?

Function

 GSM TA

This command initiates the Phase and Amplitude versus Time measurement and fetches the results when the measurement is complete.

This query is only applicable when the waveform type is DISCrete and the result type is PCAL or BOTH . The command to set the waveform type is SETup:PCALibration:WAVeform:TYPE , and the command to set the result type is SETup:PCALibration:RESult:TYPE .

If the waveform type is CONTinuous or the waveform type is DIScrete and the result type is SAMPle , only the measurement integrity result is valid .When the result type is set to PCAL or BOTH other results are reported as single NaN results.

The values returned by this query are a single integrity result for the measurement followed by a comma separated list of up to 512 measured power values, followed by a comma separated list of up to 512 measured phase values, followed by a comma separated list of up to 512 frequency error results.

The first measured power value is the absolute power level and all subsequent power values are relative to the absolute power. The first phase value is 0° and all subsequent values are phase values relative to the 0° reference. The first frequency value is the absolute frequency, and all subsequent values are relative to the absolute frequency.

GPRS TA

EGPRS TA
GSM/GPRS LA

EGPRS LA
Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.06 and above with the required feature license

GSM/GPRS/
EGPRS LA

Revision: D.03 and above

READ:PFERror[:ALL]?

Function

 GSM TA

Queries (initiates and fetches) one Phase and Frequency Error measurement as a sequential operation.

Returns Integrity Indicator see Integrity Indicator , RMS Phase Error (Max), Peak Phase Error (Max), Frequency Error (Worst). The FETCh command should be used to obtain other measurement results. See FETCh:PFERror .

Worst frequency error (negative or positive) is the value furthest from zero.

GPRS TA

EGPRS TA
GSM/GPRS LA

EGPRS LA

Query

Integrity indicator

  • Range: See Integrity Indicator .
  • Resolution: 1

rms phase error (max)

  • Range: 0 to 180 degrees and 9.91E+37 (NAN)
  • Resolution: 0.01 dB

Peak phase error (max)

  • Range: 0 to 180 degrees and 9.91E+37 (NAN)
  • Resolution: 0.01 degrees

Frequency error (worst)

  • Range: -750 kHz to +750 kHz and 9.91E+37 (NAN)
  • Resolution: 0.01 Hz
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

READ:PFERror[:ALL]:FAIL?

Function

 GSM

Queries (initiates and fetches) one Phase and Frequency Error measurement as a sequential operation.

Returns Integrity Indicator see Integrity Indicator , RMS Phase Error pass/fail indicator, Peak Phase Error pass/fail indicator, Frequency Error pass/fail indicator, and the number of measurements taken. The number of measurements taken may be of interest to you if you are using the confidence level feature. For more information on using confidence levels refer to Confidence Levels .

The FETCh command should be used to obtain other measurement results. See FETCh:PFERror .

Worst frequency error (negative or positive) is the value furthest from zero.

GSM/GPRS LA

EGPRS LA

GPRS TA

EGPRS TA

Query

Integrity indicator

  • Range: See Integrity Indicator .
  • Resolution: 1

RMS phase error pass/fail indicator

  • Range: 0|1

Peak phase error pass/fail indicator

  • Range: 0|1

Frequency error pass/fail indicator

  • Range: 0|1

Number of measurements taken

  • Range: 0 to 999 and 9.91 E+37 (NAN)
  • Resolution: 1

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

READ:PVTime[:ALL]?

Function

 GSM TA

Queries (initiates and fetches) one power versus time measurement as a sequential operation.

Returns Integrity Indicator see Integrity Indicator , Mask pass/fail, power versus time transmit power and up to 12 power versus time offset (max) results. The FETCh command should be used to obtain other measurement results. See FETCh:PVTime .

GSM/GPRS LA

EGPRS LA

GPRS TA

 This command is not applicable to the GPRS Test Application.

EGPRS TA

 This command is not applicable to the GPRS Test Application.

Query

Integrity indicator

  • Range: See Integrity Indicator .
  • Resolution: 1

Mask pass/fail

  • Range: 0|1 and 9.91E+37 (NAN)

Power versus time transmit power

  • Range: -100 to +100 dBm and 9.91E+37 (NAN)
  • Resolution: 0.01 dB

Power versus time offset (max)

  • Range: Up to 12 comma-separated power versus time values returned with max power = -100 dBc to +100 dBc (relative to power versus time carrier power) and 9.91E+37 (NAN)
  • Resolution: 0.01 dB
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

READ[:BURSt[1]]:PVTime[:ALL]?

READ:BURSt2|3|4|5:PVTime[:ALL]?

Function

 GSM TA This command is not applicable for GSM.

GPRS TA

Queries (initiates and fetches) one power versus time measurement as a sequential operation for the burst in the multislot configuration that you specify.

Returns Integrity Indicator see Integrity Indicator , Mask pass/fail, power versus time transmit power and up to 12 power versus time offset (max) results. The FETCh command should be used to obtain other measurement results. See FETCh:PVTime .

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Integrity indicator

  • Range: See Integrity Indicator .
  • Resolution: 1

Mask pass/fail

  • Range: 0|1 and 9.91E+37 (NAN)

Power versus time transmit power

  • Range: -100 to +100 dBm and 9.91E+37 (NAN)
  • Resolution: 0.01 dB

Power versus time offset (max)

  • Range: Up to 12 comma-separated power versus time values returned with max power = -100 dBc to +100 dBc (relative to power versus time carrier power) and 9.91E+37 (NAN)
  • Resolution: 0.01 dB
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above

Revision: A.08 adds Burst 3 and 4

Revision: A.09 adds Burst 5
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Revision: E.02 adds Burst 3 and 4

Revision: F.01 adds Burst 5

READ:SBERror[:ALL]?

Function

 GSM TA

This command is not applicable to GSM TA.

GPRS TA

 This command is not applicable to GPRS TA.

GSM/GPRS LA

 This command is not applicable to the GSM/GPRS LA.

EGPRS TA

Queries (initiates and fetches) one bit error measurement as a sequential operation.

Returns Integrity Indicator see Integrity Indicator , Bits Tested, Bit Error Ratio, and Bit Error Count. The FETCh command should be used to obtain other measurement results. See FETCh:SBERror .

EGPRS LA

Query

Integrity indicator

  • Range: See Integrity Indicator .
  • Resolution: 1

Bits tested

  • Range: 0 to 999,427 and 9.91E+37 (NAN)
  • Resolution: 1

Bit error ratio

  • Range: 0 to 100 and 9.91E+37 (NAN)
  • Resolution: 1

Bit error count

  • Range: 0 to 999,427 and 9.91E+37 (NAN)
  • Resolution: 1
Requirements GSM/GPRS/
EGPRS TA

Revision: A.03 and above
GSM/GPRS/ EGPRS LA

Revision: C.03 and above

READ:SFERate[:ALL]?

Function

 GSM/GPRS LA

Queries (initiates and fetches) one Repeated SACCH Frame Erasure Rate (FER) measurement as a sequential operation.

Returns Integrity Indicator see Integrity Indicator , Samples, Frame Erasure Ratio, and Frame Erasure Count. The FETCh command should be used to obtain other measurement results. See FETCh:SFERate[:ALL]? .

EGPRS LA

GSM TA

This command is not applicable to the GSM Test Application.

GPRS TA

This command is not applicable to the GPRS Test Application.

EGPRS TA

This command is not applicable to the EGPRS Test Application.

Query

Integrity indicator

  • Range: See Integrity Indicator .
  • Resolution: 1

Samples

  • Range: 0 to 999999 and 9.91E+37 (NAN)
  • Resolution: 1

Frame erasure ratio

  • Range: 0 to 100% and 9.91E+37 (NAN)
  • Resolution: 0.001

Frame erasure count

  • Range: 0 to 999999 and 9.91E+37 (NAN)
  • Resolution: 1

Requirements

 GSM/GPRS/ EGPRS LA

Revision: F.00.37 and above

READ:SMONitor:TRACe?

Function

 GSM TA

Queries (initiates and fetches) one spectrum monitor measurement as a sequential operation.

Returns a comma separated list of 401 points representing the amplitude results of the trace data.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Range:

  • For spans of 125 kHz and 500 kHz

    • frequency of point: within the current span (relative to the center frequency)
    • amplitude of point: -50 to +55 dB

  • For all other spans

    • frequency of point: within the current span (relative to the center frequency)
    • amplitude of point: (reference level - 60 dB) to +55 dB
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

READ:TXPower[:ALL]?

Function

 GSM TA

Queries (initiates and fetches) one TX power measurement as a sequential operation.

Returns Integrity Indicator see Integrity Indicator and transmit power (average). The FETCh command should be used to obtain other measurement results. See FETCh:TXPower .

GPRS TA

GSM/GPRS LA

EGPRS LA

EGPRS TA

This command is not applicable to the EGPRS Test Application.

Query

Integrity indicator

  • Range: See Integrity Indicator .
  • Resolution: 1

Transmit power (average)

  • Range: -100 to +100 dBm and 9.91E+37 (NAN)
  • Resolution: 0.01 dB
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above


READ? Subsystem

READ? Subsystem

Syntax Diagram and Command Descriptions

READ

Description

The READ? command provides a sequential method to make measurements and retrieve the results. READ? will hang the GPIB bus until the measurement is completed, or until the timeout value has been exceeded. Associated SETup commands (for each measurement) are used with the READ? command to retrieve desired measurement results in a sequential manner.

Sending a READ? command is equivalent to an INITiate/FETCh cycle for a measurement. A READ? command executes an abort action on that measurement followed by an INITiate and a FETCH?.

READ? commands can be mixed with FETCH? queries in order to make combinations of sequential and overlapped operations. One measurement can be issued a READ? command (sequential), and the next measurement can be issued INITiate/FETCh? commands (overlapped), if necessary.

The advantage of using the READ? commands to obtain measurement results, as opposed to the INITiate/FETCh method is:

  • It is simpler. Fewer commands are required to obtain measurement results.

Some disadvantages of using READ? over INITiate and FETCh are:

  • The test set does not process any additional GPIB commands until the requested measurement results are available.
  • The sequential nature of the READ? command does not allow the user to make concurrent measurements. Concurrent measurements require the overlapped commands INITiate, DONE? and FETCh? .
  • The READ? command does not provide measurement results such as statistics that are available using the INITiate/FETCh method.
  • The READ? commands have pre-defined measurement results. If additional results are needed from a measurement they may be obtained with a FETCh? query.

NOTE
Trigger arming for each measurement is controlled in the SETup subsystem. Best practice during remote operation is to set trigger arm to single (Continuous Off).

Programming Example

OUTPUT 714;"READ:TXPower?" !Starts TX power measurement. As soon as the
                           !measurement cycle has completed, the test set
                           !provides the TX power measurement results to the
                           !controlling application.
ENTER 714;integrity, tx_carrier_power !Enters the integity indicator and
                                      !TX carrier power measurement into
                                      !controlling application.


RFANalyzer

RFANalyzer

GPIB Command Conventions

  • RFANalyzer:CONTrol:BTESt:CHANnel
  • RFANalyzer:CONTrol:MEASurement:FREQuency:AUTO
  • RFANalyzer:CONTrol:POWer:AUTO
  • RFANalyzer:CONTrol:UPLink:FREQuency:AUTO
  • RFANalyzer:CW:EXPected:POWer
  • RFANalyzer:MANual:MEASurement[:MFRequency]
  • RFANalyzer:MANual:MEASurement:FREQuency
  • RFANalyzer:MANual:POWer:BURSt<[1]|2|3|4|5|6|7>
  • RFANalyzer:MANual:UPLink[:MFRequency]
  • RFANalyzer:MANual:UPLink:FREQuency

RFANalyzer:CONTrol:BTESt:CHANnel

Function

GSM TA

Sets/queries which channel (RACH, TCH or PDTCH) is measured when the operating mode is GSM BCH, GPRS BCH or EGPRS BCH. See Measurement Channel in BCH Only Mode .
GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Setting

 Range: RACH | TCH | PDTCh

Query

Range: RACH | TCH | PDTCh
*RST setting RACH
Requirements GSM/GPRS/
EGPRS TA

Revision: A.07 and above
GSM/GPRS/ EGPRS LA

Revision: E.01 and above

Programming Example

OUTPUT 714;"RFANalyzer:CONTrol:BTESt:CHANnel TCH"
! Sets the Measurement Channel in BCH Only Mode to TCH.

RFANalyzer:CONTrol:MEASurement:FREQuency:AUTO

Function

GSM TA

Sets/queries whether the test set's receiver is set to automatic (AUTO ON) or manual (AUTO OFF) measurement frequency control. See Receiver Control .
GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Setting

 Range: 1 | ON | 0 | OFF

Query

Range: 1 | 0
*RST setting 1 | ON
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"RFANalyzer:CONTrol:MEASurement:FREQuency:AUTO OFF"
! Enables manual control of the measurement receiver's frequency.

RFANalyzer:CONTrol:POWer:AUTO

Function

GSM TA

Sets/queries whether the test set receiver's expected power setting is set to automatic (AUTO ON) or manual (AUTO OFF) power control. See Receiver Control .

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Setting

Range: 1 | ON | 0 | OFF

Query

Range: 1 | 0
*RST setting 1 | ON
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"RFANalyzer:CONTrol:POWer:AUTO OFF"

RFANalyzer:CONTrol:UPLink:FREQuency:AUTO

Function

GSM TA

Sets/queries whether the test set's demodulation receiver is set to automatic (AUTO ON) or manual (AUTO OFF) uplink frequency control. See Receiver Control .

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Setting

Range: 1 | ON | 0 | OFF

Query

Range: 1 | 0
*RST setting 1 | ON
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"RFANalyzer:CONTrol:UPLink:FREQuency:AUTO OFF"
! The test set's demodulation receiver is set to manual uplink frequency control.

RFANalyzer:CW:EXPected:POWer

Function

GSM TA

Sets/queries the power level in DBM that the mobile station is expected to transmit in CW mode. The units DBM are optional. The test set will set up its input signal path to measure this power level. See Expected Power Control .

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Setting

Range: -60 to +53 dBm, after the Amplitude Offset (optional) has been factored in. see Amplitude Offset .

Resolution: 0.01 dBm

Query

Range: -60 to +53 dBm, after the Amplitude Offset (optional) has been factored in. see Amplitude Offset .

Resolution: 0.01 dBm
*RST setting

Expected Power: +13 dBm
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"RFANalyzer:CW:EXPected:POWer -20 DBM"
! Sets the expected power transmit level to -20 dBm.

RFANalyzer:MANual:MEASurement[:MFRequency]

Function

GSM TA

This command automatically sets the receiver to manual mode and changes the measurement frequency, which is used to tune the test set's measuring receiver.

GPRS TA

EGPRS TA

GSM/GPRS LA
EGPRS LA

Setting

Range: 292.5 MHz to 2700 MHz

Resolution: 1 Hz

Query

Range: 292.5 MHz to 2700 MHz

Resolution: 1 Hz
*RST setting 896.000 MHz
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"RFANalyzer:MANual:MEASurement:MFRequency 942.6 MHZ"
! Enables manual receiver control and sets the test set's receiver frequency to 942.6 MHz.

RFANalyzer:MANual:MEASurement:FREQuency

Function

GSM TA

Sets/queries the frequency used to tune the test set's measuring receiver, when manual mode is selected (RFANalyzer:CONTrol:MEASurement:FREQuency:AUTO OFF).

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Setting

Range: 292.5 MHz to 2700 MHz

Resolution: 1 Hz

Query

Range: 292.5 MHz to 2700 MHz

Resolution: 1 Hz
*RST setting 896.000 MHz
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"RFANalyzer:MANual:MEASurement:FREQuency 942.6 MHZ"
! Sets the test set's receiver frequency to 942.6 MHz when manual control is used.

RFANalyzer:MANual:POWer:BURSt<[1]|2|3|4|5|6|7>

Function

GSM TA

This command sets/queries the power level in dBm that the test set's receiver is expecting the mobile station uplink burst to transmit at for the active (that is the selected) format.

This setting applies when the Multislot Configuration setting allows the number of uplink bursts that you wish to set, or Uplink Test Sequence Burst Count (while in FastTune operating mode) is at least as high as the burst power you wish to set.

Bursts 5 through 8 only apply when the operating mode is set to FastTune .

Note: Only burst 1 is applicable to GSM TCH measurements.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Setting

Range: -60 dBm to +53 dBm, after the Amplitude Offset (optional) has been included, see Amplitude Offset .

Resolution: 0.01 dBm

Query

Range: -60 dBm to +53 dBm, after the Amplitude Offset (optional) has been included, see Amplitude Offset .

Resolution: 0.01 dBm
*RST setting

13 dBm
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above

Revision A.03 adds Burst3 and Burst4

Revision A.04 adds Burst 5 through 8.
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Revision D.01 adds Burst3 and Burst4

Revision E.01 adds Burst 5 through 7.

Programming Example

OUTPUT 714;"RFANalyzer:MANual:POWer:BURSt 7"
! Sets the test set expected burst power of the first burst level to 7 dBm.

RFANalyzer:MANual:UPLink[:MFRequency]

Function

GSM TA

Sets/queries the test set's demodulation receiver frequency, used to demodulate information from the mobile's reverse channel transmission.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Setting

Range: 292.5 MHz to 2700 MHz

Resolution: 1 Hz

Query

 Range: 292.5 MHz to 2700 MHz
*RST setting 896.000 MHz
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"RFANalyzer:MANual:UPLink:MFRequency 1955.030 MHz"
! Enables manual demodulation receiver control and sets the test set's
! demodulation receiver frequency to 1955.030 MHz.

RFANalyzer:MANual:UPLink:FREQuency

Function

GSM TA

Sets/queries the test set's demodulation receiver frequency used to demodulate information from the mobile's reverse channel transmission when manual mode is selected (RFANalyzer:CONTrol:MEASurement:FREQuency:AUTO OFF).

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Setting

Range: 292.5 MHz to 2700 MHz

Resolution: 1 Hz

Query

Range: 292.5 MHz to 2700 MHz

Resolution: 1 Hz
*RST setting 896.000 MHz
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"RFANalyzer:MANual:UPLink:FREQuency 942.6 MHZ"
! Sets the test set's demodulation receiver frequency to 942.6 MHz.


RFANalyzer Subsystem

RFANalyzer Subsystem

Description

The RFANalyzer command subsystem performs "lower-level" functions that control the Test Set's measuring receiver. Most of these functions are normally controlled indirectly by commands in other subsystems. One exception would be when operating in Test Mode. For example, the command CALL:TCHannel:<channel number> would set the RFANalyzer:EXPected:FREQuency parameter to the frequency that maps to the uplink traffic channel specified.

Syntax Diagrams and Command Descriptions

RFANalyzer


RFGenerator:OUTPut

RFGenerator:OUTPut

GPIB Command Conventions

  • RFGenerator:OUTPut[:DESTination]

RFGenerator:OUTPut[:DESTination]

Function

GSM TA

Sets/queries the RF output port destination: RF IN/OUT (IO) or RF OUT ONLY (OUT).

The correct hardware for a requested setting must be present or an error is generated. For example, trying to change to the RF OUT ONLY port when this port is not installed causes the test set to display the following error: Hardware error; RFIO version does not support RF out only selection.

The query form of this command will always return a result, regardless of the hardware version.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Setting

Range: IO | OUT

Query

Range: IO | OUT

*RST Setting

 IO
Requirements GSM/GPRS/
EGPRS TA

Revision A.01 and above

Hardware: RF Input/Output module with second RF output connector, modified front panel.

GSM/GPRS/
EGPRS LA

 Revision C.01 and above
Hardware: RF Input/Output module with second RF output connector, modified front panel.

Programming Example

OUTPUT 714;"RFGENERATOR:OUTPUT:DESTINATION OUT"
! Sets the RF generator's output destination to the RF Out Only port.
! Will return an error if the RF Out Only port is not present.


RFGenerator Subsystem

RFGenerator Subsystem

This subsystem is not applicable to GSM.

Description

The RFGenerator subsystem selects the RF generator output port on test sets equipped with both the RF IN/OUT port and the RF OUT ONLY port. If the test set does not have the RF OUT ONLY port, an error message is generated when attempting to switch output ports.

The RF OUT ONLY port may not be used with some test applications or lab applications. In that case, a message is displayed that tells you that the port could not be switched.

Syntax Diagrams and Command Descriptions

RFGenerator:OUTPut


SETup:AAUDio

SETup:AAUDio

GPIB Command Conventions

  • SETup:AAUDio:CONTinuous
  • SETup:AAUDio:COUNt[:SNUMber]
  • SETup:AAUDio:COUNt:NUMBer
  • SETup:AAUDio:COUNt:STATe
  • SETup:AAUDIO:DEMPhasis:STATe
  • SETup:AAUDio:DETector[:TYPE]
  • SETup:AAUDio:EXPANDOR[:SRLevel]
  • SETup:AAUDio:EXPANDOR:RLEVel
  • SETup:AAUDio:EXPANDOR:STATe
  • SETup:AAUDio:EXPected:VOLTage[:PEAK]
  • SETup:AAUDio:FILTer[:SFRequency]
  • SETup:AAUDio:FILTer:FREQuency
  • SETup:AAUDio:FILTer:STATe
  • SETup:AAUDio:FILTer:TYPE
  • SETup:AAUDio:FREQuency:STATe
  • SETup:AAUDio:SDIStortion:FREQuency
  • SETup:AAUDio:SDIStortion:STATe
  • SETup:AAUDio:TIMEout[:STIME]
  • SETup:AAUDio:TIMEout:STATe
  • SETup:AAUDio:TIMEout:TIME

SETup:AAUDio:CONTinuous

Function

GSM TA

 Selects/queries the trigger arm state for Analog Audio measurements.

GSM/GPRS LA

EGPRS LA
GPRS TA

This command is not applicable to GPRS.
EGPRS TA

This command is not applicable to EGPRS.
Setting

Range:

  • Continuous trigger arm mode = 1 | ON
  • Single trigger arm mode = 0 | OFF

Query

 Range: 0 | 1

*RST setting

 Single | 0 | OFF

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETUP:AAUDIO:CONTINUOUS OFF"
! Selects single trigger mode.

SETup:AAUDio:COUNt[:SNUMber]

Function

GSM TA

 Selects the number of Analog Audio multi-measurements the test set will make and sets the count state to ON.

GSM/GPRS LA

EGPRS LA

GPRS TA

This command is not applicable to GPRS.
EGPRS TA

This command is not applicable to EGPRS.
Setting

Range: 1 to 999
Resolution: 1

Query

Range: 1 to 999
Resolution: 1
*RST setting 10

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETUP:AAUDIO:COUNT:SNUMBER 5"
! Sets the value to 5 and the state to on.

SETup:AAUDio:COUNt:NUMBer

Function

GSM TA

 Selects/queries the number of Analog Audio measurements the test set will make when the SETup:AAUDio:COUNt:STATe is ON.

GSM/GPRS LA

EGPRS LA

GPRS TA

This command is not applicable to GPRS.
EGPRS TA

This command is not applicable to EGPRS.
Setting

Range: 1 to 999
Resolution: 1

Query

Range: 1 to 999
Resolution: 1

*RST setting

 10

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"ABORT:ALL" !Aborts all active measurements in progress.

OUTPUT 714;"SETUP:AAUDIO:COUNT:NUMBER 10"
! Sets the audio multi-measurement count number to 10.

SETup:AAUDio:COUNt:STATe

Function

GSM TA

 Selects/queries the Analog Audio multi-measurement count state.

GSM/GPRS LA

EGPRS LA

GPRS TA

This command is not applicable to GPRS.
EGPRS TA

This command is not applicable to EGPRS.
Setting Range: 1 | ON | 0 | OFF

Query

 Range: 1 | 0

*RST setting

 0 | OFF

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETUP:AAUDIO:COUNT:STATE ON"
! Turns the analog audio measurement multi-measurement count state on.

SETup:AAUDIO:DEMPhasis:STATe

Function

GSM TA

Sets/queries whether 750 us de-emphasis is enabled.

GSM/GPRS LA

EGPRS LA

GPRS TA

This command is not applicable to GPRS.
EGPRS TA

This command is not applicable to EGPRS.
Setting

Range: 1 | ON | 0 | OFF

Query

Range: 1 | 0

*RST setting

0 | OFF

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETUP:AAUDIO:DEMPhasis:STATE ON"
! Turns the de-emphasis on.

SETup:AAUDio:DETector[:TYPE]

Function

GSM TA

Sets/queries the detector type for audio level measurements.

GSM/GPRS LA

EGPRS LA

GPRS TA

This command is not applicable to GPRS.
EGPRS TA

This command is not applicable to EGPRS.
Setting

Range: RMS | PEAK

Query

Range: RMS | PEAK

*RST setting

RMS

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETUP:AAUDIO:DETECTOR:TYPE PEAK"

SETup:AAUDio:EXPANDOR[:SRLevel]

Function

GSM TA

Sets/queries the expandor's reference level and automatically sets the expandor's state to ON. The units (V|MV|UV) are optional, if no units are specified then units default to V.

GSM/GPRS LA

EGPRS LA

GPRS TA

This command is not applicable to GPRS.
EGPRS TA

This command is not applicable to EGPRS.
Setting

Range: 10 mV to 10 V
Resolution: 1 mV

Query

Range: 10 mV to 10 V
Resolution: 1 mV

*RST setting

1 V

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETUP:AAUDIO:EXPANDOR:SRLEVEL 5V"
! Sets expandor state to on and level to 5 V.

SETup:AAUDio:EXPANDOR:RLEVel

Function

GSM TA

Sets/queries the expandor's reference level to be used when the expandor's state is set to ON. The units (V|MV|UV) are optional, if no units are specified then units default to V.

GSM/GPRS LA

EGPRS LA

GPRS TA

This command is not applicable to GPRS.
EGPRS TA

This command is not applicable to EGPRS.
Setting

Range: 10 mV to 10 V
Resolution: 1 mV

Query

Range: 10 mV to 10 V
Resolution: 1 mV

*RST setting

1 V

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETUP:AAUDIO:EXPANDOR:RLEVEL 5V"
! Sets expandor reference level to 5 V.

SETup:AAUDio:EXPANDOR:STATe

Function

GSM TA

Sets/queries whether the expandor is enabled.

GSM/GPRS LA

EGPRS LA

GPRS TA

This command is not applicable to GPRS.
EGPRS TA

This command is not applicable to EGPRS.
Setting

Range: 1 | ON | 0 | OFF

Query

Range: 1 | 0

*RST setting

0 | OFF

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETUP:AAUDIO:EXPANDOR:STATE ON"

SETup:AAUDio:EXPected:VOLTage[:PEAK]

Function

GSM TA

 Sets/queries the maximum expected peak voltage (clipping level) of the Analog Audio signal to be measured. The units (V|MV|UV) are optional, if no units are specified then units default to V. See SETup:AAUDio .

GSM/GPRS LA

EGPRS LA

GPRS TA

This command is not applicable to GPRS.
EGPRS TA

This command is not applicable to EGPRS.
Setting

Range: 10 mV to 20 V peak
Resolution: 0.1 mV

Query

Range: 10 mV to 20 V peak
Resolution: 0.1 mV

*RST setting

 20 V

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETUP:AAUDIO:EXPECTED:VOLTAGE 5V"
! Sets the clipping level of Analog Audio measurements to 5 volts.

SETup:AAUDio:FILTer[:SFRequency]

Function

GSM TA

Sets/queries the center frequency for the 100 Hz bandpass filter applied to Analog Audio measurements and sets the state to on. Units (KHZ|HZ) are optional, if no units are specified then units default to Hz.

GSM/GPRS LA

EGPRS LA

GPRS TA

This command is not applicable to GPRS.
EGPRS TA

This command is not applicable to EGPRS.
Setting

Range: 200 Hz to 20.0 kHz
Resolution: 0.1 Hz

Query

Range: 200 Hz to 20.0 kHz
Resolution: 0.1 Hz

*RST setting

1000 Hz

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETUP:AAUDIO:FILTER:SFREQUENCY 1000"
! This sets the aaudio filter state to on and sets the bandpass filter frequency to 1 kHz.

SETup:AAUDio:FILTer:FREQuency

Function

GSM TA

 Sets/queries the center frequency for the 100 Hz bandpass filter applied to Analog Audio measurements. Units (KHZ|HZ) are optional, if no units are specified then units default to Hz. See SETup:AAUDio .

GSM/GPRS LA

EGPRS LA

GPRS TA

This command is not applicable to GPRS.
EGPRS TA

This command is not applicable to EGPRS.
Setting

Range: 200 Hz to 20.0 kHz
Resolution: 0.1 Hz

Query

Range: 200 Hz to 20.0 kHz
Resolution: 0.1 Hz

*RST setting

 1000 Hz

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETUP:AAUDIO:FILTER:FREQUENCY 217HZ"
! Set aaudio bandpass filter to 217 hz.

SETup:AAUDio:FILTer:STATe

Function

GSM TA

 Selects/queries the state of the Analog Audio bandpass filter. see SETup:AAUDio

GSM/GPRS LA

EGPRS LA

GPRS TA

This command is not applicable to GPRS.
EGPRS TA

This command is not applicable to EGPRS.
Setting Range: 1 | ON | 0 | OFF

Query

 Range: 1 | 0

*RST setting

0 (off)

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETUP:AAUDIO:FILTER:STATE ON"
! Sets filter state on.

SETup:AAUDio:FILTer:TYPE

Function

GSM TA

Sets/queries the filter type for audio measurements.

GSM/GPRS LA

EGPRS LA

GPRS TA

This command is not applicable to GPRS.
EGPRS TA

This command is not applicable to EGPRS.
Setting

Range: NONE | TBPass | CMESsage | BPASs50 | BPASs300

Query

Range: NONE | TBP | CMES | BPAS50 | BPAS300

*RST setting

NONE

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETUP:AAUDIO:FILTER:TYPE BPASS50"
! Selects the 50 Hz to 15 kHz bandpass filter.

SETup:AAUDio:FREQuency:STATe

Function

GSM TA

Sets/queries whether the audio frequency measurement is enabled.

GSM/GPRS LA

EGPRS LA

GPRS TA

This command is not applicable to GPRS.
EGPRS TA

This command is not applicable to EGPRS.
Setting

Range: 1 | ON | 0 | OFF

Query

Range: 1 | 0

*RST setting

0 | OFF

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETUP:AAUDIO:FREQUENCY:STATE ON"

SETup:AAUDio:SDIStortion:FREQuency

Function

GSM TA

Sets/queries the fundamental frequency setting for the SINAD/distortion measurement. Units (KHZ|HZ) are optional, if no units are specified then units default to Hz.

GSM/GPRS LA

EGPRS LA

GPRS TA

This command is not applicable to GPRS.
EGPRS TA

This command is not applicable to EGPRS.
Setting

Range: 100.0 to 10000 Hz
Resolution: 0.1 Hz

Query

Range: 100.0 to 10000 Hz
Resolution: 0.1 Hz

*RST setting

1000 Hz

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;SETUP:AAUDIO:SDISTORTION:FREQUENCY 300HZ"

SETup:AAUDio:SDIStortion:STATe

Function

GSM TA

Sets/queries whether the SINAD/distortion measurement is enabled.

GSM/GPRS LA

EGPRS LA

GPRS TA

This command is not applicable to GPRS.
EGPRS TA

This command is not applicable to EGPRS.
Setting

Range: 1 | ON | 0 | OFF

Query

Range: 1 | 0

*RST setting

0 | OFF

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

10 OUTPUT 714;SETUP:AAUDIO:SDISTORTION:STATE ON"

SETup:AAUDio:TIMEout[:STIME]

Function

GSM TA

 Selects/queries the timeout value in seconds that will be used for Analog Audio measurements and sets the timeout state to ON. Units (S|MS) are optional, if no units are specified then units default to S.

GSM/GPRS LA

EGPRS LA
GPRS TA

This command is not applicable to GPRS.
EGPRS TA

This command is not applicable to EGPRS.
Setting

Range: 0.1 to 999 seconds
Resolution: 0.1 seconds

Query

Range: 0.1 to 999 seconds
Resolution: 0.1 seconds

*RST setting

10 seconds

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETUP:AAUDIO:TIMEOUT:STIME 3"
! Sets the timeout state to on and sets the timeout value.

SETup:AAUDio:TIMEout:STATe

Function

GSM TA

 Selects/queries the Analog Audio measurement timeout state.

GSM/GPRS LA

EGPRS LA

GPRS TA

This command is not applicable to GPRS.
EGPRS TA

This command is not applicable to EGPRS.
Setting Range: 1 | ON | 0 | OFF

Query

 Range: 1 | 0

*RST setting

0 | OFF

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETUP:AAUDIO:TIMEOUT:STATE ON"
! Sets timeout state to on.

SETup:AAUDio:TIMEout:TIME

Function

GSM TA

 Selects/queries the timeout value in seconds that will be used for Analog Audio measurements when the timeout state is ON. Unit (S|MS) are optional, if no units are specified then units default to S.

GSM/GPRS LA

EGPRS LA
GPRS TA

This command is not applicable to GPRS.
EGPRS TA

This command is not applicable to EGPRS.
Setting

Range: 0.1 to 999 seconds
Resolution: 0.1 seconds

Query

Range: 0.1 to 999 seconds
Resolution: 0.1 seconds

*RST setting

10 seconds

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETUP:AAUDIO:TIMEOUT:TIME 5"
! Sets timeout value to 5 seconds.


SETup:BERRor

SETup:BERRor

GPIB Command Conventions

  • SETup:BERRor[:TYPE]
  • SETup:BERRor:CLSDelay[:STIMe]
  • SETup:BERRor:CLSDelay:TIME
  • SETup:BERRor:CLSDelay:STATe
  • SETup:BERRor:CONTinuous
  • SETup:BERRor:COUNt
  • SETup:BERRor:LDControl:AUTO
  • SETup:BERRor:MANual:DELay
  • SETup:BERRor:SLControl[:STATe]
  • SETup:BERRor:TIMeout[:STIMe]
  • SETup:BERRor:TIMeout:TIME
  • SETup:BERRor:TIMeout:STATe

SETup:BERRor[:TYPE]

Function

GSM TA

Sets the measurement type for BER measurements including Type A (residual), Type B (non-residual) and Type D (residual (D) )

GSM/GPRS LA

EGPRS LA

GPRS TA

This command is not applicable to GPRS.
EGPRS TA

This command is not applicable to EGPRS.
Setting GSM TA

Range:

TYPEIA | TYPEII |TYPEIB | RESTYPEIA | RESTYPEII | RESTYPEIB

GSM/GPRS LA

Range:

TYPEIA | TYPEII |TYPEIB | DATA |RESTYPEIA | RESTYPEII |

RESTYPEIB | RESDATA |RESTYPEIAD | RESTYPEIBD | RESTYPEIID |RESDATAD

Query

 GSM TA

Range:

TYPEIA | TYPEII |TYPEIB | RESTYPEIA | RESTYPEII | RESTYPEIB

GSM/GPRS LA

Range:

TYPEIA | TYPEII |TYPEIB | DATA |RESTYPEIA | RESTYPEII |

RESTYPEIB | RESDATA |RESTYPEIAD | RESTYPEIBD | RESTYPEIID |RESDATAD

*RST Setting

RESTYPEII

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Revision D.01 adds DATA and RESDATA to support CSD BER testing.

Revision F.00.27 adds RESTYPEIAD, RESTYPEIBD, RESTYPEIID and RESDATAD.

Programming Example

OUTPUT 714;"SETUP:BERROR:TYPE TYPEIA"
! Sets type of BER measurement.

SETup:BERRor:CLSDelay[:STIMe]

Function

GSM TA

Selects/queries the closed loop signalling delay time in seconds for Bit Error measurements and sets the delay state to ON. The units (S|MS) are optional, if no units are specified than units default to S.

The delay time defines how long the test set should wait before starting a BERR measurement. The downlink signalling operation must be completed and the test set must send a close loop command to the MS before the measurement can begin. The delay time allows time for the loop to close.

When a close loop message is set to the MS the closed loop signalling delay time will hold off the BERR measurement from starting for the specified time period.

GSM/GPRS TA

EGPRS LA

GPRS TA

This command is not applicable to GPRS.
EGPRS TA

This command is not applicable to EGPRS.
Setting

Range: 0 to 5 seconds

Resolution: 100 ms

Query

Range: 0 to 5 seconds

Resolution: 100 ms
*RST Setting 500 ms

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETUP:BERROR:CLSDELAY:STIME 400 MS"
! Set state to on and delay time

SETup:BERRor:CLSDelay:TIME

Function

GSM TA

Selects/queries the closed loop signalling delay time in seconds for Bit Error measurements. The units (S|MS) are optional, if no units are specified than units default to S.

The delay time defines how long the test set should wait before starting a BERR measurement. The downlink signalling operation must be completed and the test set must send a close loop command to the MS before the measurement can begin. The delay time allows time for the loop to close.

When a close loop message is set to the MS the closed loop signalling delay time will hold off the BERR measurement from starting for the specified time period.

GSM/GPRS LA

EGPRS LA
GPRS TA

This command is not applicable to GPRS.
EGPRS TA

This command is not applicable to EGPRS.
Setting

Range: 0 to 5 seconds

Resolution: 100 ms

Query

Range: 0 to 5 seconds

Resolution: 100 ms
*RST Setting 500 ms

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETUP:BERROR:CLSDELAY:TIME 600MS"
! Set delay time

SETup:BERRor:CLSDelay:STATe

Function

GSM TA

Selects/queries the closed loop signalling delay state for Bit Error measurements. If the state is off the test set will not wait to start a BERR measurement after a downlink signalling operation has completed.

The delay time defines how long the test set should wait before starting and BERR measurement after a downlink signalling operation has completed and after the test set has sent a close loop command to the MS.

When a close loop message is set to the MS the closed loop signalling delay time will hold off the BERR measurement from starting for the specified time period.

GSM/GPRS LA

EGPRS LA
GPRS TA

This command is not applicable to GPRS.
EGPRS TA

This command is not applicable to EGPRS.
Setting Range: 1 | ON

 |
0 | OFF

Query

Range: 1 | 0
*RST Setting 1 | ON

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETUP:BERROR:CLSDELAY:STATE ON"

SETup:BERRor:CONTinuous

Function

GSM TA

Sets/queries the trigger state to single trigger mode or continuous trigger mode for BER measurement.

GSM/GPRS LA

EGPRS LA

GPRS TA

This command is not applicable to GPRS.
EGPRS TA

This command is not applicable to EGPRS.
Setting

Range: 0 | OFF | 1 | ON

Query

Range: 0 | 1
*RST Setting

0 | OFF

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETup:BERROR:CONTINUOUS OFF"
! Sets BER measurement to single trigger mode.

SETup:BERRor:COUNt

Function

GSM TA

Sets/queries the number of BER measurements the test set will make when the count state is on

GSM/GPRS LA

EGPRS LA

GPRS TA

This command is not applicable to GPRS.
EGPRS TA

This command is not applicable to EGPRS.
Setting

Range: 1 to 999,000

Resolution: 1

Query

Range: 1 to 999,000

Resolution: 1
*RST Setting

10,000

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETUP:BERROR:COUNT 880"
! Set BER multi-measurement count to 880.

SETup:BERRor:LDControl:AUTO

Function

GSM TA

Sets/queries loopback delay control mode. If loopback delay control mode is automatic (Auto), the test set determines the loopback delay value that will allow correlation between uplink information bits with downlink information bits.

If loopback delay control mode is manual (not Auto), the test set will use the loopback delay value entered in the Loopback Delay field. Refer to. see SETup:BERRor:MANual:DELay

Refer also to the Bit Error Measurement for a description of loopback delay and its use in the BER measurement.

GSM/GPRS LA

EGPRS LA

GPRS TA

This command is not applicable to GPRS.
EGPRS TA

This command is not applicable to EGPRS.
Setting

Range: 0 | OFF | 1 | ON

Query

0 | 1
*RST Setting

1 (automatic)

Related Topics

SETup:BERRor:MANual:DELay

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETUP:BERROR:LDCONTROL:AUTO OFF"
! sets BER delay to manual the user must select the manual frame delay number.

SETup:BERRor:MANual:DELay

Function

GSM TA

Sets/queries the number of frames the test set uses to correlate uplink information bits with downlink information bits when loopback delay control mode is manual (AUTO OFF). To set the loopback delay mode to manual, refer to SETup:BERRor:LDControl:AUTO .

This value is displayed in the Loopback Delay field when Auto is not displayed. (If you want to display this value and Auto is currently displayed, press the front-panel key labeled OFF ).

Refer to Bit Error Measurement for a description of loopback delay and how it is used in this measurement.

GSM/GPRS LA

EGPRS LA

GPRS TA

This command is not applicable to GPRS.
EGPRS TA

This command is not applicable to EGPRS.
Setting

Range: 1 to 15

Resolution : 1

Query

Range: 1 to 15

Resolution : 1
*RST Setting

5

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETUP:BERROR:MANUAL:DELAY 4"
! Set delay of 4 speech frames.

SETup:BERRor:SLControl[:STATe]

Function

GSM TA

Selects/queries the Signalling loopback control state for an BER measurement.

When signalling loopback control is set to on, the test set will automatically send the loopback for Type A (residual) or Type B (non-residual) loopback to the MS, based on the measurement type selected, and then set loopback to off when the measurement is complete.

The loopback type is controlled manually using Mobile Loopback ( F12 ) on Call Parms menu 1 of 4 . See CALL:TCHannel:LOOPback for a programming example and details about the command.

GSM/GPRS LA

EGPRS LA

GPRS TA

This command is not applicable to GPRS.
EGPRS TA

This command is not applicable to EGPRS.
Setting

Range: 1 | ON | 0 | OFF

Query

Range: 1 | 0
*RST Setting 1 | ON

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETUP:BERROR:SLCONTROL ON"
! Test set will send loopback type automatically

SETup:BERRor:TIMeout[:STIMe]

Function

GSM TA

Sets/queries the timeout value in seconds for the trigger state during BER measurements and turns the timeout state on. The units (S|MS) are optional, if no units are specified than units default to S.

GSM/GPRS LA

EGPRS LA

GPRS TA

This command is not applicable to GPRS.
EGPRS TA

This command is not applicable to EGPRS.
Setting

Range: 0.1 to 999

Resolution: 0.1

Query

Range: 0.1 to 999Resolution: 0.1
*RST Setting

10 seconds

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETUP:BERR:TIMEOUT:STIME 8"
! Sets BER measurement timeout to 8 seconds and the state to on.

SETup:BERRor:TIMeout:TIME

Function

GSM TA

Sets/queries the timeout value in seconds for the trigger state during BER measurements. The units (S|MS) are optional, if no units are specified than units default to S (seconds).

GSM/GPRS LA

EGPRS LA

GPRS TA

This command is not applicable to GPRS.
EGPRS TA

This command is not applicable to EGPRS.
Setting

Range: 0.1 to 999

Resolution: 0.1

Query

Range: 0.1 to 999Resolution: 0.1
*RST Setting

10 seconds

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETUP:BERR:TIMEOUT:TIME 8"
! Sets BER measurement timeout to 8 seconds.

SETup:BERRor:TIMeout:STATe

Function

GSM TA

Sets/queries the timeout state for BER measurements.

GSM/GPRS LA

EGPRS LA

GPRS TA

This command is not applicable to GPRS.
EGPRS TA

This command is not applicable to EGPRS.
Setting

Range: 0 | OFF | 1 | ON

Query

Range: 0 | 1
*RST Setting

0 | OFF

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETUP:BERR0R:TIMEOUT:STATE ON"
! Sets the timeout state to on.


SETup:BLERror

SETup:BLERror

GPIB Command Conventions

  • SETup:BLERror:BBLocks
  • SETup:BLERror:CONTinuous
  • SETup:BLERror:COUNt
  • SETup:BLERror:ETSIB:MODE
  • SETup:BLERror:LDControl:AUTO
  • SETup:BLERror:MANual:DELay
  • SETup:BLERror:TIMeout[:STIMe]
  • SETup:BLERror:TIMeout:TIME
  • SETup:BLERror:TIMeout:STATe

SETup:BLERror:BBLocks

Function

GSM TA

This command is not applicable to GSM.

GPRS TA

This command sets/queries the BLER Bad Block Handling parameter. The BLER Bad Block Handling parameter setting determines how the bad blocks are handled by the BLER measurement.

This command is only applicable to loopback BLER measurements. (Refer to BLER measurement method usage .)

There are two settings:

  1. Include -The blocks that fail the CRCs (frame check sequence) are included in the BLER calculation.
  2. Exclude- The blocks that fail the CRCs are excluded from the BLER calculation.

NOTE
A block is defined as bad if :
  • At least one of the four expected bursts has not been received by the test set.
  • The demodulation quality of at least one of the bursts was questionable.
  • The block has failed the frame check sequence (CRC). (Each block that fails its CRC will cause the CRC error count result to increment, regardless of the BLER Bad Block Handling setting.) The CRC count result can be obtained using the command FETCh:BLERror:CRC? .

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

Range: INClude|EXClude

Query

Range: INC|EXC
*RST Setting

INC
Requirements GSM/GPRS/
EGPRS TA

Revision: A.05 and above
GSM/GPRS/ EGPRS LA

Revision: D.02 and above

Programming Example

OUTPUT 714;"SETup:BLERror:BBLocks EXClude"
! Sets BLER measurement calculation to exclude all blocks that fail the CRCs
! while calculating the BLER.

SETup:BLERror:CONTinuous

Function

GSM TA

This command is not applicable to GSM.

GPRS TA

 This command sets/queries the trigger state to single trigger mode or continuous trigger mode for the BLER measurement.

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

Range: 0 | OFF | 1 | ON

Query

Range: 0 | 1
*RST Setting

0 | OFF
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETup:BLERror:CONTinuous OFF"
! Sets BLER measurement to single trigger mode.

SETup:BLERror:COUNt

Function

GSM TA

This command is not applicable to GSM.

GPRS TA

This command sets/queries the number of blocks to measure.

When the Data Connection Type is set to BLER, and depending on the block polling interval setting (see CALL:FUNCtion:DATA:BLOCk:POLLing:INTerval[:SELected] ), the number of blocks actually tested may be larger than the number you specify using this command. The actual number of blocks tested is returned by FETCh:BLERror:BLOCks? .

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

Range: 1 to 99000

Resolution: 1

Query

Range: 1 to 99000

Resolution: 1
*RST Setting

500
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETup:BLERror:COUNt 880"
! Sets the number of blocks to measure to 880.

SETup:BLERror:ETSIB:MODE

Function

GSM TA

This command is not applicable to GSM.

GPRS TA

Sets/queries the ETSI B Acknowledged Measurement Mode. This command is only applicable when the connection type is ETSI B Ack. See CALL:FUNCtion:CONNection:TYPE .

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting | LOOPback|POLLing

Query

 LOOP|POLL
*RST Setting | LOOPback
Requirements GSM/GPRS/
EGPRS TA

Revision: A.03 and above
GSM/GPRS/ EGPRS LA

Revision: C.03 and above

Programming Example

OUTPUT 714;"SETup:BLERror:ETSIB:MODE POLL"
! Sets the number of blocks to measure to 880.

SETup:BLERror:LDControl:AUTO

Function

GSM TA

This command is not applicable to GSM.

GPRS TA

This command sets/queries the loopback delay control mode.

If loopback delay control mode is automatic (ON), the test set determines the block delay value that allows the correlation between uplink and downlink data.

If loopback delay control mode is manual (OFF), the test set uses the block delay you specify using SETup:BLERror:MANual:DELay .

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

Range: 0 | OFF | 1 | ON

Query

Range: 0 | 1
*RST Setting

1 | ON
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETup:BLERror:LDControl:AUTO OFF"
! Sets the loopback delay control mode to manual.

SETup:BLERror:MANual:DELay

Function

GSM TA

This command is not applicable to GSM.

GPRS TA

This command sets/queries the block delay when loopback delay control mode is manual. To set the delay mode to manual, refer to SETup:BLERror:LDControl:AUTO .

This command is not applicable when the data connection type is set to BLER.

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

Range: 1 to 12

Resolution : 1

Query

Range: 1 to 12

Resolution : 1
*RST Setting

2
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above

Range increased from 6 to 12 at Revision A.03
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Range increased from 6 to 12 at Revision C.03

Programming Example

OUTPUT 714;"SETup:BLERror:MANual:DELay 6"
! Sets the number of blocks to 6.

SETup:BLERror:TIMeout[:STIMe]

Function

GSM TA

This command is not applicable to GSM.

GPRS TA

This command sets/queries the timeout value in seconds for the trigger state during BLER measurements and turns the timeout state to On. The units (S|MS) are optional. If no units are specified then units default to S (seconds).

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

Range: 0.1 to 999

Resolution: 0.1

Query

Range: 0.1 to 999Resolution: 0.1
*RST Setting

10 seconds
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETup:BLERror:TIMeout:STIMe 12"
! Sets BLER measurement timeout to 12 seconds and the state to on.

SETup:BLERror:TIMeout:TIME

Function

GSM TA

This command is not applicable to GSM.

GPRS TA

This command sets/queries the timeout value in seconds for the trigger state during BLER measurements. The units (S|MS) are optional. If no units are specified then units default to S (seconds).

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

Range: 0.1 to 999

Resolution: 0.1

Query

Range: 0.1 to 999Resolution: 0.1
*RST Setting

10 seconds
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETup:BLERror:TIMeout:TIME 8"
! Sets BLER measurement timeout to 8 seconds.

SETup:BLERror:TIMeout:STATe

Function

GSM TA

This command is not applicable to GSM.

GPRS TA

This command sets/queries the timeout state for BLER measurements.

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

Range: 0 | OFF | 1 | ON

Query

Range: 0 | 1
*RST Setting

0 | OFF
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETup:BLERror:TIMEout:STATe ON"
! Sets the timeout state to on.


SETup:CONTinuous

SETup:CONTinuous

GPIB Command Conventions

  • SETup[:ALL]:CONTinuous

SETup[:ALL]:CONTinuous

Function

GSM TA

This command sets trigger arm to OFF (single trigger) or ON (continuous trigger) for all measurements. See Trigger Arm (Single or Continuous) Description .

At power-on and a (manual user) full preset the trigger arm is set to continuous. Partial preset has no effect on the trigger arm state. See Preset Descriptions .

Remote full preset sets the trigger arm to single, this is the recommended trigger arm for any remote measurements.

Trigger arm may be set and queried for each individual measurement. For GPIB command syntax, see the measurement's SETup<meas-mnemonic>:CONTinuous command description. (For example, SETup:PVTime:CONTinuous[:SELected] allows you to set the trigger arm for the Power versus Time measurement.)

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

Range:

  • Continuous trigger = ON

  • Single trigger = OFF

*RST Setting

Single

Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETUP:ALL:CONTINUOUS:OFF"
! Sets trigger arm for all measurements to single.


SETup:DAUDio

SETup:DAUDio

GPIB Command Conventions

  • SETup:DAUDio:CONTinuous
  • SETup:DAUDio:COUNt[:SNUMber]
  • SETup:DAUDio:COUNt:NUMBer
  • SETup:DAUDio:COUNt:STATe
  • SETup:DAUDio:FILTer [:SFREquency]
  • SETup:DAUDio:FILTer:FREQuency
  • SETup:DAUDio:FILTer:STATe
  • SETup:DAUDio:TIMeout[:STIMe]
  • SETup:DAUDio:TIMeout:TIME
  • SETup:DAUDio:TIMeout:STATe

SETup:DAUDio:CONTinuous

Function

GSM TA

 This command selects/queries the trigger state for Decoded Audio measurements.

GSM/GPRS LA

EGPRS LA

GPRS TA

 This command is not applicable to GPRS.

EGPRS TA

 This command is not applicable to EGPRS.
Setting

Range:

  • Continuous = 1|ON
  • Single = 0|OFF

Query

 Range: 1|0
*RST Setting

0 (single)

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETUP:DAUDIO:CONTINUOUS OFF"
! Set DAUDIO measurement to single trigger mode.

SETup:DAUDio:COUNt[:SNUMber]

Function

GSM TA

 This command selects/queries the number of Decoded Audio multi-measurements the Test Set will make. This command sets the count state to ON.

GSM/GPRS LA

EGPRS LA

GPRS TA

 This command is not applicable to GPRS.

EGPRS TA

 This command is not applicable to EGPRS.
Setting

Range: 1 to 999

Resolution: 1

Query

Range: 1 to 999

Resolution: 1
*RST Setting 10

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETUP:DAUDIO:COUNT:SNUMBER 10"
! Sets the value to 10 and the state to on.

SETup:DAUDio:COUNt:NUMBer

Function

GSM TA

This command selects/queries the number of Decoded Audio measurements the test set will make when the multi-measurement count state is on.

GSM/GPRS LA

EGPRS LA

GPRS TA

 This command is not applicable to GPRS.

EGPRS TA

 This command is not applicable to EGPRS.
Setting

Range: 1 to 999

Resolution: 1

Query

Range: 1 to 999

Resolution: 1
*RST Setting

10

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETUP:DAUDIO:COUNT:NUMBER 25"
! Sets the number of DAUDIO measurements that will be made.

SETup:DAUDio:COUNt:STATe

Function

GSM TA

 This command selects/queries the Decoded Audio multi-measurement count state.

GSM/GPRS LA

EGPRS LA

GPRS TA

 This command is not applicable to GPRS.

EGPRS TA

 This command is not applicable to EGPRS.
Setting Range: 1|ON | 0|OFF

Query

 Range: 1|0
*RST Setting

0 (off)

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETUP:DAUDIO:COUNT:STATE OFF"
! Sets trigger state for DAUDIO measurement.

SETup:DAUDio:FILTer [:SFREquency]

Function

GSM TA

 This command sets/queries the center frequency for the 100 Hz bandpass filter applied to Decoded Audio measurements. This command sets the count state to ON. The units (HZ|KHZ) are optional, if no units are specified then units default to KHZ. see Decoded Audio Measurement Description

GSM/GPRS LA

EGPRS LA

GPRS TA

 This command is not applicable to GPRS.

EGPRS TA

 This command is not applicable to EGPRS.
Setting

Range: 200 Hz to 3.6 kHz

Resolution: 1 Hz

Query

Range: 200 Hz to 3.6 kHz

Resolution: 1 Hz
*RST Setting

1000 Hz

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETUP:DAUDIO:FILTER:SFREQUENCY 2.2KHZ"
! This is a complex command that sets the value and the state to on.

SETup:DAUDio:FILTer:FREQuency

Function

GSM TA

 This command sets/queries the center frequency for the 100 Hz bandpass filter applied to Decoded Audio measurements. The units (HZ|KHZ) are optional, if no units are specified then units default to KHZ. see Decoded Audio Measurement Description

GSM/GPRS LA

EGPRS LA

GPRS TA

 This command is not applicable to GPRS.

EGPRS TA

 This command is not applicable to EGPRS.
Setting

Range: 200 Hz to 3.6 kHz

Resolution: 1 Hz

Query

Range: 200 Hz to 3.6 kHz

Resolution: 1 Hz
*RST Setting

1000 Hz

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"DAUDIO:FILTER:FREQUENCY 217HZ"
! Sets bandpass filter frequency.

SETup:DAUDio:FILTer:STATe

Function

GSM TA

 This command selects/queries the Decoded Audio bandpass filter state. see Decoded Audio Measurement Description

GSM/GPRS LA

EGPRS LA

GPRS TA

 This command is not applicable to GPRS.

EGPRS TA

 This command is not applicable to EGPRS.
Setting Range: 1|ON |0|OFF

Query

 Range: 1|0

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"ABORT:ALL"
! Aborts all active measurements in progress.

Programming Example

OUTPUT 714;"SETUP:DAUDIO:FILTER:STATE OFF"
! Sets bandpass filter state to off.

SETup:DAUDio:TIMeout[:STIMe]

Function

GSM TA

 This command selects/queries the timeout value in seconds that will be used for Decoded Audio measurements. This command sets the timeout state to ON. The units (S|MS) are optional, if no units are specified then units default to S.

GSM/GPRS LA

EGPRS LA

GPRS TA

 This command is not applicable to GPRS.

EGPRS TA

 This command is not applicable to EGPRS.
Setting

Range: 0.1 to 999

Resolution: 0.1

Query

Range: 0.1 to 999

Resolution: 0.1
*RST Setting

10 seconds

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETUP:DAUDIO:TIMEOUT:STIME 6"
! Sets the value to 6 seconds and the state to on.

SETup:DAUDio:TIMeout:TIME

Function

GSM TA

 This command selects/queries the timeout value used for Decoded Audio measurements when the timeout state is ON. The units (S|MS) are optional, if no units are specified then units default to S.

GSM/GPRS LA

EGPRS LA

GPRS TA

 This command is not applicable to GPRS.

EGPRS TA

 This command is not applicable to EGPRS.
Setting

Range: 0.1 to 999 seconds

Resolution: 0.1 seconds

Query

Range: 0.1 to 999 seconds

Resolution: 0.1 seconds
*RST Setting

10 seconds

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETUP:DAUDIO:TIMEOUT:TIME 15"
! Sets timeout value to 15 seconds.

SETup:DAUDio:TIMeout:STATe

Function

GSM TA

 This command selects/queries the Decoded Audio measurement timeout state.

GSM/GPRS LA

EGPRS LA

GPRS TA

 This command is not applicable to GPRS.

EGPRS TA

 This command is not applicable to EGPRS.
Setting Range: 1|ON | 0|Off

Query

 Range: 1|0
*RST Setting

0 (off)

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETUP:DAUDIO:TIMEOUT:STATE ON"
! Sets timeout state to on.


SETup Subsystem

SETup Subsystem

Description

The SETup subsystem is used to configure the test set for each measurement. Typical settings include:

  • Multi-Measurement Count, how many measurements will be made each time a measurement is initiated.
  • Trigger Arm, determines if a measurement will make one measurement then return to idle (single), or automatically rearm on completion of a measurement and repeat the process (continuous).
  • Trigger Source, how a measurement is triggered.
  • Trigger Delay, controls the delay time between the trigger and the start of sampling.
  • Measurement Timeout, length of time before a measurement times out.

NOTE
Trigger arming for each measurement is controlled in the SETup subsystem. The choices are single or continuous. In most cases, it is a best practice (during remote operation) to use "single" measurement mode. This simplifies the tasks of starting concurrent measurements, using the INIT subsystem commands to determine which measurements are ready to be fetched, then using the FETCh subsystem to obtain results. The command "SETup:CONTinuous:OFF sets all measurements to "single" trigger mode.

Syntax Diagrams and Command Descriptions

 | Applicable to:
 | GSM TA | GPRS TA | EGPRS TA | GSM/GPRS LA | EGPRS LA
SETup:AAUDio | Yes | No | No | Yes | Yes
SETup:BERRor | Yes | No | No | Yes | Yes
SETup:<BFINdication|BFI> | No | No | No | No | Yes
SETup:BLERror | No | Yes | Yes (includes support for 8PSK modulation coding schemes | Yes | Yes (includes support for 8PSK modulation coding schemes)
SETup:CONTinuous | Yes | Yes | Yes | Yes | Yes
SETup:DAUDio | Yes | No | No | Yes | Yes
SETup:DPOWer | Yes | Yes | No | Yes | Yes
SETup:EDPower | No | No | Yes | No | Yes
SETup:EMACcuracy | No | No | Yes | No | Yes
SETup:ETXPower | No | No | Yes (includes support for 8PSK modulation coding schemes | No | Yes (includes support for 8PSK modulation coding schemes)
SETup:FBERror | Yes | No | No | Yes | Yes
SETup:FFERate | No | No | No | Yes | Yes
SETup:FSTability | Yes | Yes | Yes | Yes | Yes
SETup:GBERror | No | Yes | Yes(includes support for 8PSK modulation coding schemes) | Yes | Yes(includes support for 8PSK modulation coding schemes)
SETup:IFERror | No | No | No | Yes | Yes
SETup:IQTuning | Yes | Yes | Yes | Yes | Yes
SETup:MTAudio | Yes | Yes | Yes | Yes | Yes
SETup:ORFSpectrum | Yes | Yes | Yes (includes support for 8PSK modulation coding schemes | Yes | Yes (includes support for 8PSK modulation coding schemes
SETup:PCALibration | Yes | Yes | Yes | Yes | Yes
SETup:PFERror | Yes | Yes | Yes (includes support for 8PSK modulation coding schemes | Yes | Yes (includes support for 8PSK modulation coding schemes
SETup:PVTime | Yes | Yes | Yes (includes support for 8PSK modulation coding schemes | Yes | Yes (includes support for 8PSK modulation coding schemes
SETup:SBERror | No | No | Yes | No | Yes
SETup:SFERate | No | No | No | Yes | Yes
SETup:SMONitor | Yes | Yes | Yes | Yes | Yes
SETup:TXPower | Yes | Yes | No | Yes | Yes


SETup:DPOWer

SETup:DPOWer

GPIB Command Conventions

  • SETup:DPOWer:CONTinuous[:SELected]
  • SETup:DPOWer:CONTinuous:GSM
  • SETup:DPOWer:COUNt:NUMBer[:SELected]
  • SETup:DPOWer:COUNt:NUMBer:GSM
  • SETup:DPOWer:EMDifference[:SELected]
  • SETup:DPOWer:EMDifference:GSM
  • SETup:DPOWer:EMTInterval[:STIMe]
  • SETup:DPOWer:EMTInterval:STATe
  • SETup:DPOWer:EMTInterval:TIME
  • SETup:DPOWer:RANGe:OFFSet
  • SETup:DPOWer:TIMeout[:STIMe][:SELected]
  • SETup:DPOWer:TIMeout[:STIMe]:GSM
  • SETup:DPOWer:TIMeout:STATe[:SELected]
  • SETup:DPOWer:TIMeout:STATe:GSM
  • SETup:DPOWer:TIMeout:TIMe[:SELected]
  • SETup:DPOWer:TIMeout:TIMe:GSM

SETup:DPOWer:CONTinuous[:SELected]

Function

GSM TA

 This command selects/queries the trigger state for Dynamic Power measurements in the active (that is the selected) format.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

Range:

  • Continuous trigger mode: 1 | ON
  • Single trigger mode: 0 | OFF

Query

Range: 1 | 0
*RST Setting

The *RST value of this command depends on the format that is currently active. For example, if the GSM format is currently active, the *RST value for this command is the same value as the equivalent command containing the :GSM format identifier.

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETUP:DPOWER:CONTINUOUS:SELECTED ON"
! Sets trigger mode to Continuous.

SETup:DPOWer:CONTinuous:GSM

Function

GSM TA

 This command selects/queries the trigger state for Dynamic Power measurement in the GSM format whether or not that format is active.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

Range:

  • Continuous trigger mode: 1 | ON
  • Single trigger mode: 0 | OFF

Query

Range: 1 | 0
*RST Setting 0 (off)

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETUP:DPOWER:CONTINUOUS:GSM ON"
! Sets trigger mode to Continuous.

SETup:DPOWer:COUNt:NUMBer[:SELected]

Function

GSM TA

This command sets/queries the number of bursts for the Dynamic Power measurement in the active (that is the selected) format.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

Range: 1 to 999

Resolution: 1

Query

Range: 1 to 999

Resolution: 1
*RST Setting

The *RST value of this command depends on the format that is currently active. For example, if the GSM format is currently active, the *RST value for this command is the same value as the equivalent command containing the :GSM format identifier.

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETUP:DPOWER:COUNT:NUMBER:SELECTED 25"
! Sets the number of measurement bursts.

SETup:DPOWer:COUNt:NUMBer:GSM

Function

GSM TA

This command sets/queries the number of bursts for the Dynamic Power measurement in the GSM format whether or not that format is active.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

Range: 1 to 999

Resolution: 1

Query

Range: 1 to 999

Resolution: 1
*RST Setting 10

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETUP:DPOWER:COUNT:NUMBER:GSM 50"
! Sets the number of measurement bursts.

SETup:DPOWer:EMDifference[:SELected]

Function

GSM TA

This command sets/queries the Expected Maximum Difference from Previous Measurement parameter for the Dynamic Power measurement in the active (that is the selected) format. The units dB are optional.

The Expected Maximum Difference from Previous Measurement parameter is used with the measured transmit power from the previous burst to set the maximum RF power that the base station emulator is expecting the mobile to transmit in the next burst.

The setting of this parameter does not affect the receiver Expected Power parameter. See RFANalyzer:CW:EXPected:POWer .

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

Range: -30 dB to +30 dB

Resolution: 0.01 dB

Query

Range: -30 dB to +30 dB

Resolution: 0.01 dB

*RST

3 dB

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETUP:DPOWER:EMDIFFERENCE:SELECTED 20"
! Sets the Expected Maximum Difference in measurement value.

SETup:DPOWer:EMDifference:GSM

Function

GSM TA

This command sets/queries the Expected Maximum Difference from Previous Measurement parameter for the Dynamic Power measurement in the GSM format whether or not that format is active. The units dB are optional.

The Expected Maximum Difference from Previous Measurement parameter is used with the measured transmit power from the previous burst to set the maximum RF power that the base station emulator is expecting the mobile to transmit in the next burst.

The setting of this parameter does not affect the receiver Expected Power parameter. See RFANalyzer:CW:EXPected:POWer .

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

Range: -30 dB to +30 dB

Resolution: 0.01 dB

Query

Range: -30 dB to +30 dB

Resolution: 0.01 dB

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETUP:DPOWER:EMDIFFERENCE:GSM 10"
! Sets the Expected Maximum Difference in measurement value.

SETup:DPOWer:EMTInterval[:STIMe]

Function

GSM TA

 This command sets/queries the Dynamic Power Measurement Expected Maximum Time Interval value in seconds and sets the Expected Maximum Time Interval State to ON for the active format. This combines the commands SETup:DPOWer:EMTInterval:STATe and SETup:DPOWer:EMTInterval:TIME .

GPRS TA

GSM/GPRS LA

EGPRS TA

EGPRS LA
Setting

Range: 0.01s to 10s

Resolution: 0.01s

Query

Range: 0.01s to 10s

Resolution: 0.01s
*RST Setting

0.02s

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.09 and above
GSM/GPRS/ EGPRS LA

Revision: F.01 and above

Programming Example

OUTPUT 714;"SETup:DPOWer:EMTInterval:STIMe 0.1"
! Sets the DPOW Expected Maximum Time Interval State to ON and sets the value to 0.1s.

SETup:DPOWer:EMTInterval:STATe

Function

GSM TA

 This command sets/queries the Dynamic Power Measurement Expected Maximum Time Interval State. When this parameter is set to ON, the DPOW Measurement will stop waiting and return measurement results if the time between the input bursts is over the value specified by the Expected Maximum Time Interval Value parameter.
See SETup:DPOWer:EMTInterval:TIME for information on how to set the Expected Maximum Time Interval Value.

GPRS TA

GSM/GPRS LA

EGPRS TA

EGPRS LA
Setting

Range: 1|ON|0|OFF

Query

Range: 1|0
*RST Setting 0|OFF

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.09 and above
GSM/GPRS/ EGPRS LA

Revision: F.01 and above

Programming Example

OUTPUT 714;"SETup:DPOWer:EMTInterval:STATe ON"
! Sets the DPOW Expected Maximum Time Interval State to ON.

SETup:DPOWer:EMTInterval:TIME

Function | GSM TA | This command sets/queries the Dynamic Power Measurement Expected Maximum Time Interval value between the measured bursts when the DPOW Expected Maximum Time Interval State is set to ON. See SETup:DPOWer:EMTInterval:STATe for information on how to set the Expected Maximum Time Interval State.
 | GPRS TA
 | GSM/GPRS LA
 | EGPRS TA
 | EGPRS LA
Setting |  | Range: 0.01s to 10s Resolution: 0.01s
Query |  | Range: 0.01s to 10s Resolution: 0.01s
*RST Setting |  | 0.02s
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.09 and above
 | GSM/GPRS/ EGPRS LA | Revision: F.01 and above
Programming Example OUTPUT 714;"SETup:DPOWer:EMTInterval:TIME 0.1" ! Sets the DPOW Expected Maximum Time Interval Value to 0.1s.

SETup:DPOWer:RANGe:OFFSet

Function

GSM TA

This command sets/queries the range offset for the Dynamic Power measurement.

Note: The recommended range offset for the Dynamic Power measurement is 0 dB unless otherwise specified.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

Range: -4 dB to +4 dB

Resolution: 0.01 dB

Query

Range: -4 dB to +4 dB

Resolution: 0.01 dB
*RST

-3 dB

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.05 and above
GSM/GPRS/ EGPRS LA

Revision: D.02 and above

Programming Example

OUTPUT 714;"SETup:DPOWer:RANGe:OFFSet 0"
! Sets the Dynamic Power Measurement range offset to 0.

SETup:DPOWer:TIMeout[:STIMe][:SELected]

Function

GSM TA

 This command sets/queries the Dynamic Power measurement timeout value in seconds and sets the time-out state to on for the active (that is the selected) format. The units (S |MS) are optional, if no units are specified then the default is S.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

Range: 0.1 to 999 seconds

Resolution: 0.1 seconds

Query

Range: 0.1 to 999 seconds

Resolution: 0.1 seconds
*RST Setting

The *RST value of this command depends on the format that is currently active. For example, if the GSM format is currently active, the *RST value for this command is the same value as the equivalent command containing the :GSM format identifier.

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETUP:DPOWER:TIMEOUT:STIME:SELECTED 12S"
! Sets the timeout state and value.

SETup:DPOWer:TIMeout[:STIMe]:GSM

Function

GSM TA

 This command sets/queries the Dynamic Power measurement timeout value in seconds and sets the time-out state to on for the GSM format whether or not that format is active. The units (S |MS) are optional, if no units are specified then the default is S.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

Range: 0.1 to 999 seconds

Resolution: 0.1 seconds

Query

Range: 0.1 to 999 seconds

Resolution: 0.1 seconds
*RST Setting 10 seconds

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETUP:DPOWER:TIMEOUT:STIME:GSM 20"
! Sets the timeout state and value.

SETup:DPOWer:TIMeout:STATe[:SELected]

Function

GSM TA

 This command sets/queries the time-out state for the Dynamic Power measurement in the active (that is the selected) format.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting Range: 0 | OFF | 1 | ON

Query

 Range: 0 | 1
*RST Setting

The *RST value of this command depends on the format that is currently active. For example, if the GSM format is currently active, the *RST value for this command is the same value as the equivalent command containing the :GSM format identifier.

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETUP:DPOWER:TIMEOUT:STATE:SELECTED ON"
! Sets the timeout state.

SETup:DPOWer:TIMeout:STATe:GSM

Function

GSM TA

 This command sets/queries the time-out state for the Dynamic Power measurement in the GSM format whether or not that format is active.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting | Range: 0 | OFF | 1 | ON

Query

 Range: 0 | 1
*RST Setting | 0 (off)

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETUP:DPOWER:TIMEOUT:STATE:GSM ON"
! Sets the timeout state.

SETup:DPOWer:TIMeout:TIMe[:SELected]

Function

GSM TA

 This command sets/queries the time-out value in seconds that is used for the Dynamic Power measurement for the active (that is the selected) format. The time-out state must be ON. The units (S|MS) are optional, if no units are specified then the default is S.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

Range: 0.1 to 999 seconds

Resolution: 0.1 seconds

Query

Range: 0.1 to 999 seconds

Resolution: 0.1 seconds
*RST Setting

The *RST value of this command depends on the format that is currently active. For example, if the GSM format is currently active, the *RST value for this command is the same value as the equivalent command containing the :GSM format identifier.

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETUP:DPOWER:TIMEOUT:TIME:SELECTED 15"
! Sets the timeout value.

SETup:DPOWer:TIMeout:TIMe:GSM

Function

GSM TA

 This command sets/queries the time-out value in seconds that is used for the Dynamic Power measurements when the time-out state is ON for the GSM format whether or not that format is active. The units (S|MS) are optional, if no units are specified then the default is S.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

Range: 0.1 to 999 seconds

Resolution: 0.1 seconds

Query

Range: 0.1 to 999 seconds

Resolution: 0.1 seconds
*RST Setting 10 seconds

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETUP:DPOWER:TIMEOUT:TIME:GSM 10S"
! Sets the timeout value.


SETup:EDPower

SETup:EDPower

GPIB Command Conventions

  • SETup:EDPower:CONTinuous
  • SETup:EDPower:COUNt:GROup:SIZE
  • SETup:EDPower:COUNt:NUMBer
  • SETup:EDPower:COUNt:RSEGment
  • SETup:EDPower:COUNt:TOTal?
  • SETup:EDPower:EMDifference
  • SETup:EDPower:EMTInterval[:STIMe]
  • SETup:EDPower:EMTInterval:STATe
  • SETup:EDPower:EMTInterval:TIME
  • SETup:EDPower:INITial:POWer:AUTO
  • SETup:EDPower:INITial:POWer
  • SETup:EDPower:METHod
  • SETup:EDPower:TIMeout[:STIMe]
  • SETup:EDPower:TIMeout:STATe
  • SETup:EDPower:TIMeout:TIME

SETup:EDPower:CONTinuous

Function

GSM TA

 This command is not applicable to GSM TA.

GPRS TA

 This command is not applicable to GPRS TA.
GSM/GPRS LA | This command is not applicable to GSM/GPRS LA.

EGPRS TA

 This command selects/queries the trigger mode for the EDGE Dynamic Power measurement.

EGPRS LA
Setting

Range:

  • Continuous trigger mode: 1 | ON
  • Single trigger mode: 0 | OFF

Query

Range: 1 | 0
*RST Setting | OFF

Requirements

 GSM/GPRS/ EGPRS TA

Revision: A.04 and above

Revision A.05 makes the EDP Measurement available in all TAs.
GSM/GPRS/ EGPRS LA

Revision: D.01 and above

Revision D.02 makes the EDP Measurement available in all LAs.

Programming Example

OUTPUT 714;"SETup:EDPower:CONTinuous ON"
! Sets trigger mode to Continuous.

SETup:EDPower:COUNt:GROup:SIZE

Function

GSM TA

 This command is not applicable to GSM TA.

GPRS TA

 This command is not applicable to GPRS TA.

GSM/GPRS LA

 This command is not applicable to GSM/GPRS LA.
EGPRS TA

This command sets/queries the group count, that is the number of bursts at each power level, for each ramp segment. For the command form, if the number of parameters sent exceeds the current number of ramp segments, the additional values are stored but are only used in a measurement if the number of ramp segments is increased.

If the group size is set to a value greater than the number of bursts in a ramp segment, the group size will truncate the group size to the number of bursts in the ramp segment.

The query form of this command returns one value per ramp segment. The number of ramp segments is specified by the command SETup:EDPower:COUNt:RSEGment .

The total number of bursts to be measured over all ramp segments can be obtained with the query SETup:EDPower:COUNt:TOTal? .

EGPRS LA
Setting

Length: 1 to 100 comma separated values

Range: 1 to 999

Resolution: 1

Query

Range: 1 to 999

Resolution: 1
*RST Setting 1

Requirements

 GSM/GPRS/EGPRS TA

Revision: A.04 and above

Revision A.05 makes the EDP Measurement available in all TAs.
GSM/GPRS/EGPRS LA

Revision: D.01 and above

Revision D.02 makes the EDP Measurement available in all LAs.

Programming Example

OUTPUT 714;"SETup:EDPower:COUNt:RSEGment 4"
! Sets number of ramp segments to 4OUTPUT 714;"SETup:EDPower:COUNt:GROup:SIZE 5,10,5,10,5,10"
! Specifies the burst group size for 6 ramp segments, only the first 4 will be usedOUTPUT 714;"SETup:EDPower:COUNt:GROup:SIZE?"
! Query returns one value per ramp segment (5, 10, 5, 10).OUTPUT 714;"SETup:EDPower:COUNt:RSEGment 6"
! Increase number of ramp segments to 6.OUTPUT 714;"SETup:EDPower:COUNt:GROup:SIZE?"
! Query now returns all six values (5, 10, 5, 10, 5, 10 ).END

SETup:EDPower:COUNt:NUMBer

Function

GSM TA

 This command is not applicable to GSM TA.

GPRS TA

 This command is not applicable to GPRS TA.

GSM/GPRS LA

 This command is not applicable to GSM/GPRS LA.
EGPRS TA

This command sets/queries the number of bursts to be measured for each ramp segment. For the command syntax, if the number of parameters sent exceeds the current number of ramp segments, the additional values are stored but are only used in a measurement if the number of ramp segments is increased

The total number of bursts to be measured over all ramp segments can be obtained with the query SETup:EDPower:COUNt:TOTal? .

EGPRS LA
Setting

Length: 1 to 100 comma separated values

Range: 1 to 999

Resolution: 1

Note: The sum of the values in the list cannot exceed 999.

Query

Range: 1 to 999

Resolution: 1
*RST Setting 25

Requirements

 GSM/GPRS/EGPRS TA

Revision: A.04 and above

Revision A.05 makes the EDP Measurement available in all TAs.
GSM/GPRS/EGPRS LA

Revision: D.01 and above

Revision D.02 makes the EDP Measurement available in all LAs.

Programming Example

OUTPUT 714; "SETup:EDPower:COUNt:RSEGment 4"
! Sets number of ramp segments to 4.

OUTPUT 714; "SETup:EDPower:COUNt:NUMBer 25, 50, 75, 100, 125, 150"
! Specifies the burst count for 6 ramp segments, only the first 4 will be used.

OUTPUT 714; "SETup:EDPower:COUNt:NUMBer?"
! Query returns one value per ramp segment (25, 50, 75, 100).

OUTPUT 714; "SETup:EDPower:COUNt:TOTal?"
! Query returns the total number of bursts for the whole measurement (250).

OUTPUT 714; "SETup:EDPower:COUNt:RSEGment 6"
! Increases number of ramp segments to 6.

OUTPUT 714; "SETup:EDPower:COUNt:NUMBer?"
! Query now returns all six values (25, 50, 75, 100, 125, 150).

OUTPUT 714; "SETup:EDPower:COUNt:TOTal?"
! Query returns the total number of bursts for the whole measurement (525).

SETup:EDPower:COUNt:RSEGment

Function

GSM TA

 This command is not applicable to GSM TA.

GPRS TA

 This command is not applicable to GPRS TA.

GSM/GPRS LA

 This command is not applicable to GSM/GPRS LA.
EGPRS TA

This command sets/queries the number of ramp segments within the EDGE Dynamic Power measurement.

EGPRS LA
Setting

Range: 1 to 100

Resolution: 1

Query

Range: 1 to 100

Resolution: 1
*RST Setting 1

Requirements

 GSM/GPRS/EGPRS TA

Revision: A.04 and above

Revision A.05 makes the EDP Measurement available in all TAs.
GSM/GPRS/EGPRS LA

Revision: D.01 and above

Revision D.02 makes the EDP Measurement available in all LAs.

Programming Example

OUTPUT 714;"SETup:EDPower:COUNt:RSEGment 6"
! Sets the number of measurement segments within the EDGE Dynamic Power measurement.

SETup:EDPower:COUNt:TOTal?

Function

GSM TA

 This command is not applicable to GSM TA.

GPRS TA

 This command is not applicable to GPRS TA.

GSM/GPRS LA

 This command is not applicable to GSM/GPRS LA.
EGPRS TA

This command queries the total number of bursts to be measured by the EDGE Dynamic Power measurement. The value returned will be the sum of the burst counts specified for each ramp segment. For more information see SETup:EDPower:COUNt:NUMBer .

EGPRS LA

Query

Range: 1 to 999

Resolution: 1
*RST Setting 25

Requirements

 GSM/GPRS/EGPRS TA

Revision: A.04 and above

Revision A.05 makes the EDP Measurement available in all TAs.
GSM/GPRS/EGPRS LA

Revision: D.01 and above

Revision D.02 makes the EDP Measurement available in all LAs.

Programming Example

OUTPUT 714;"SETup:EDPower:COUNt:TOTal?"
! Queries the total number of bursts to be measured for the whole measurement. This value
! is the sum of values returned by SET:EDP:COUN:NUMB?

SETup:EDPower:EMDifference

Function

GSM TA

 This command is not applicable to GSM TA.

GPRS TA

 This command is not applicable to GPRS TA.

GSM/GPRS LA

 This command is not applicable to GSM/GPRS LA.

EGPRS TA

 This command sets/queries the maximum expected power difference between successive bursts in a ramp segment. For the command form, if the number of parameters sent exceeds the current number of ramp segments, the additional values are stored but are only used in a measurement if the number of ramp segments is increased. The query form of this command returns one value per ramp segment. The number of ramp segments is specified by the command SETup:EDPower:COUNt:RSEGment.

EGPRS LA
Setting

Length: 1 to 100 comma separated values

Range: -30 dB to +30 dB

Resolution: 0.01 dB

Query

Range: -30 dB to +30 dB

Resolution: 0.01 dB
*RST Setting

3 dB

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.04 and above

Revision A.05 makes the EDP Measurement available in all TAs.
GSM/GPRS/ EGPRS LA

Revision: D.01 and above

Revision D.02 makes the EDP Measurement available in all LAs.

Programming Example

OUTPUT 714;"SETup:EDPower:EMDifference 1.5,1.5,-2,-2,1.5,1.5"
! Specifies the expected max difference for 6 ramp segments, only the first 4 will be used.

OUTPUT 714;"SETup:EDPower:EMDifference?"
! Query returns one value per ramp segment (1.5, 1.5, -2.0, -2.0).

OUTPUT 714;"SETup:EDPower:COUNt:RSEGment 6"
! Increase number of ramp segments to 6.

OUTPUT 714;"SETup:EDPower:EMDifference?"
! Query now returns all six values (1.5, 1.5, -2.0, -2.0, 1.5, 1.5).

END

SETup:EDPower:EMTInterval[:STIMe]

Function

GSM TA

 This command sets/queries the EDGE Dynamic Power Measurement Expected Maximum Time Interval value in seconds and sets the Expected Maximum Time Interval State to ON for the active format. This combines the commands SETup:EDPower:EMTInterval:STATe and SETup:EDPower:EMTInterval:TIME .

GPRS TA

GSM/GPRS LA

EGPRS TA

EGPRS LA
Setting

Range: 0.01s to 10s

Resolution: 0.01s

Query

Range: 0.01s to 10s

Resolution: 0.01s
*RST Setting

0.02s

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.09 and above
GSM/GPRS/ EGPRS LA

Revision: F.01 and above

Programming Example

OUTPUT 714;"SETup:EDPower:EMTInterval:STIMe 0.1"
! Sets the EDPOW Expected Maximum Time Interval State to ON and sets the value to 0.1s.

SETup:EDPower:EMTInterval:STATe

Function

GSM TA

 This command sets/queries the EDGE Dynamic Power Measurement Expected Maximum Time Interval State. When this parameter is set to ON, the EDPOW Measurement will stop waiting and return measurement results if the time between the input bursts is over the value specified by the Expected Maximum Time Interval Value parameter.
See SETup:EDPower:EMTInterval:TIME for information on how to set the Expected Maximum Time Interval Value.

GPRS TA

GSM/GPRS LA

EGPRS TA

EGPRS LA
Setting

Range: 1|ON|0|OFF

Query

Range: 1|0
*RST Setting 0|OFF

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.09 and above
GSM/GPRS/ EGPRS LA

Revision: F.01 and above

Programming Example

OUTPUT 714;"SETup:EDPower:EMTInterval:STATe ON"
! Sets the EDPOW Expected Maximum Time Interval State to ON.

SETup:EDPower:EMTInterval:TIME

Function | GSM TA | This command sets/queries the EDGE Dynamic Power Measurement Expected Maximum Time Interval value between the measured bursts when the EDPOW Expected Maximum Time Interval State is set to ON. See SETup:EDPower:EMTInterval:STATe for information on how to set the Expected Maximum Time Interval State.
 | GPRS TA
 | GSM/GPRS LA
 | EGPRS TA
 | EGPRS LA
Setting |  | Range: 0.01s to 10s Resolution: 0.01s
Query |  | Range: 0.01s to 10s Resolution: 0.01s
*RST Setting |  | 0.02s
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.09 and above
 | GSM/GPRS/ EGPRS LA | Revision: F.01 and above
Programming Example OUTPUT 714;"SETup:EDPower:EMTInterval:TIME 0.1" ! Sets the EDPOW Expected Maximum Time Interval Value to 0.1s.

SETup:EDPower:INITial:POWer:AUTO

Function

GSM TA

 This command is not applicable to GSM TA.

GPRS TA

 This command is not applicable to GPRS TA.

GSM/GPRS LA

 This command is not applicable to GSM/GPRS LA.
EGPRS TA

This command sets/queries whether or not the expected power for the first burst in each ramp segment should be derived automatically by the test set.

When this command is set to 1 or ON, the same expected power setting is used for the first burst in all ramp segments. The value used for the expected power depends on the state of the Expected Power Control. To set the state of the test set's expected power see RFANalyzer:CONTrol:POWer:AUTO . If the Expected Power Control parameter is set to Auto, the MS TX Level Burst 1 setting is used, see CALL:(PDTCH|PDTChannel):MS:TXLevel[:SELected]:BURSt<[1]|2|3|4|5> . If the Expected Power Control parameter is set to Manual, the expected power that is used is the power level setting for burst 1 that the test set's receiver is expecting to see. To set the power level that the test set's receiver is expecting see RFANalyzer:MANual:POWer:BURSt<[1]|2|3|4|5|6|7> .

When the initial power state is set to OFF, the initial power values set by the Initial Power Values parameter, SETup:EDPower:INITial:POWer , are used for the expected value in each ramp segment.

EGPRS LA
Setting | Range: 0 | OFF | 1 | ON

Query

 Range: 0 | 1
*RST Setting | 1 (ON)

Requirements

 GSM/GPRS/ EGPRS TA

Revision: A.04 and above

Revision A.05 makes the EDP Measurement available in all TAs.
GSM/GPRS/ EGPRS LA

Revision: D.01 and above

Revision D.02 makes the EDP Measurement available in all LAs.

Programming Example

OUTPUT 714;"SETup:EDPower:INITial:POWer:AUTO ON"
! Specifies that the expected power for the first burst in each ramp segment should be derived
! automatically from the base station emulator.

SETup:EDPower:INITial:POWer

Function

GSM TA

 This command is not applicable to GSM TA.

GPRS TA

 This command is not applicable to GPRS TA.

GSM/GPRS LA

 This command is not applicable to GSM/GPRS LA.
EGPRS TA | This command sets/queries the expected power for the first burst in a ramp segment. For the command form, if the number of parameters sent exceeds the current number of ramp segments, the additional values are stored but are only used in a measurement if the number of ramp segments is increased. The query form of this command returns one value per ramp segment. The number of ramp segments is specified by the command SETup:EDPower:COUNt:RSEGment.

EGPRS LA
Setting

Length: 1 to 100 comma separated values

Range: -60.0 dB to +53 dB

Resolution: 1

Query

Range: 1 to 999

Resolution: 1
*RST Setting | 25

Requirements

 GSM/GPRS/ EGPRS TA

Revision: A.04 and above

Revision A.05 makes the EDP Measurement available in all TAs.
GSM/GPRS/ EGPRS LA

Revision: D.01 and above

Revision D.02 makes the EDP Measurement available in all LAs.

Programming Example

OUTPUT 714;"SETup:EDPower:COUNt:RSEGment 4"
! Sets number of ramp segments to 4.

OUTPUT 714;"SETup:EDPower:INITial:POWer 10, 12, 14, 3, 5, 7"
! Specifies the initial expected power for 6 ramp segments, only the first 4 will be used.

OUTPUT 714;"SETup:EDPower:INITial:POWer?"
! Query returns one value per ramp segment (10, 12, 14, 3).

OUTPUT 714;"SETup:EDPower:COUNt:RSEGment 6"
! Increase number of ramp segments to 6.

OUTPUT 714;"SETup:EDPower:INITial:POWer?"
! Query now returns all six values (10, 12, 14, 3, 5, 7).

END

SETup:EDPower:METHod

Function

GSM TA

 This command is not applicable to GSM TA.

GPRS TA

 This command is not applicable to GPRS TA.
GSM/GPRS LA | This command is not applicable to GSM/GPRS LA.
EGPRS TA This command sets/queries the measurement methods. There are three measurement methods: Burst Power, Variable Estimated Carrier Power(ECP) and Fixed Estimated Carrier Power. When the expected modulation format is 8PSK, the power of a burst is determined using one of three methods above. If the expected modulation format is GMSK, the measurement method is always Burst Power.

Burst Power ( BURSt ) determines the power of burst of the burst without any compensation for data content. Variable Estimated Carrier Power ( CARRier ) determines the ECP on an individual burst basis. This allows random data patterns to be used. Fixed Estimated Carrier Power ( FCARrier ) determines the data compensation factor for the burst with the highest power and assumes the same data pattern is used for all bursts.

EGPRS LA
Setting

Range: BURSt|CARRier|FCARrier

Query

Range: BURSt|CARRier|FCARrier
*RST Setting | CARRier

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.04 and above

Revision A.05 makes the EDP Measurement available in all TAs.
GSM/GPRS/ EGPRS LA

Revision: D.01 and above

Revision D.02 makes the EDP Measurement available in all LAs.

Programming Example

OUTPUT 714;"SETup:EDPower:METHod BURSt"
! Sets the measurement method to be Burst Power.

SETup:EDPower:TIMeout[:STIMe]

Function

GSM TA

 This command is not applicable to GSM TA.

GPRS TA

 This command is not applicable to GPRS TA.

GSM/GPRS LA

 This command is not applicable to GSM/GPRS LA.
EGPRS TA | This command sets/queries the EDGE Dynamic Power measurement timeout value in seconds and sets the time-out state to on for the active format. This combines the commands SETup:EDP:TIMeout:STATe and SETup:EDP:TIMeout:TIME.

EGPRS LA
Setting

Range: 0.1 to 999 seconds

Resolution: 0.1 seconds

Query

Range: 0.1 to 999 seconds

Resolution: 0.1 seconds
*RST Setting | 10 seconds

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.04 and above

Revision A.05 makes the EDP Measurement available in all TAs.
GSM/GPRS/ EGPRS LA

Revision: D.01 and above

Revision D.02 makes the EDP Measurement available in all LAs.

Programming Example

OUTPUT 714;"SETup:EDPower:TIMeout 12S"
! Sets the timeout state and value such that the measurement will timeout after 12 seconds.

SETup:EDPower:TIMeout:STATe

Function

GSM TA

 This command is not applicable to GSM TA.

GPRS TA

 This command is not applicable to GPRS TA.
GSM/GPRS LA | This command is not applicable to GSM/GPRS LA.
EGPRS TA | This command sets/queries the timeout state for the EDGE Dynamic Power measurement.

EGPRS LA
Setting | Range: 0 | OFF | 1 | ON

Query

 Range: 0 | 1
*RST Setting

0 (OFF)

Requirements

 GSM/GPRS/ EGPRS TA

Revision: A.04 and above

Revision A.05 makes the EDP Measurement available in all TAs.
GSM/GPRS/ EGPRS LA

Revision: D.01 and above

Revision D.02 makes the EDP Measurement available in all LAs.

Programming Example

OUTPUT 714;"SETup:EDPower:TIMeout:STATe ON"
! Sets the timeout state to ON.

SETup:EDPower:TIMeout:TIME

Function

GSM TA

 This command is not applicable to GSM TA.

GPRS TA

 This command is not applicable to GPRS TA.

GSM/GPRS LA

 This command is not applicable to GSM/GPRS LA.
EGPRS TA | This command sets/queries the time-out value in seconds that is used for the EDGE Dynamic Power measurement for the active format. The time-out state must be ON.

EGPRS LA
Setting

Range: 0.1 to 999 seconds

Resolution: 0.1 seconds

Query

Range: 0.1 to 999 seconds

Resolution: 0.1 seconds
*RST Setting | 10 seconds

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.04 and above

Revision A.05 makes the EDP Measurement available in all TAs.
GSM/GPRS/ EGPRS LA

Revision: D.01 and above

Revision D.02 makes the EDP Measurement available in all LAs.

Programming Example

OUTPUT 714;"SETup:EDPower:TIMeout:TIME 15"
! Sets the time it takes for the measurement to timeout.


SETup:EMACcuracy

SETup:EMACcuracy

GPIB Command Conventions

  • SETup:EMACcuracy:CONTinuous
  • SETup:EMACcuracy:COUNt[:SNUMber]
  • SETup:EMACcuracy:COUNt:NUMBer
  • SETup:EMACcuracy:COUNt:STATe
  • SETup:EMACcuracy:DROop[:CALCulate]:STATe
  • SETup:EMACcuracy:GRAPh:STATe
  • SETup:EMACcuracy:HISTogram:MAXimum:EVM
  • SETup:EMACcuracy:IQIMbalance[:CALCulate]:STATe
  • SETup:EMACcuracy:PERRor:FILTer
  • SETup:EMACcuracy:TIMeout[:STIMe]
  • SETup:EMACcuracy:TIMeout:STATe
  • SETup:EMACcuracy:TIMeout:TIME
  • SETup:EMACcuracy:TRIGger:DELay
  • SETup:EMACcuracy:TRIGger:SOURce

SETup:EMACcuracy:CONTinuous

Function

GSM TA

 This command is not applicable to GSM.

GPRS TA

 This command is not applicable to GPRS.

GSM/GPRS LA

 This command is not applicable to the GSM/GPRS LA.

EGPRS TA

This command sets/queries the trigger state for EGPRS modulation accuracy measurements.

EGPRS LA
Setting

Range:

  • Single trigger mode = 0 | OFF
  • Continuous trigger mode = 1 | ON

Query

Range: 0 | 1
*RST Setting

0 | OFF
Requirements GSM/GPRS/
EGPRS TA

Revision: A.03 and above
GSM/GPRS/ EGPRS LA

Revision: C.03 and above

Programming Example

OUTPUT 714;"SETup:EMACcuracy:CONTinuous ON"
! Specifies continuous trigger mode for EGPRS modulation accuracy measurements.

SETup:EMACcuracy:COUNt[:SNUMber]

Function

GSM TA

 This command is not applicable to GSM.

GPRS TA

 This command is not applicable to GPRS.

GSM/GPRS LA

 This command is not applicable to the GSM/GPRS LA.

EGPRS TA

This command sets/queries the number of EGPRS modulation accuracy measurements made by the test set. This command sets the count state to ON.

EGPRS LA
Setting

Range: 1 to 999

Resolution: 1

Query

Range: 1 to 999

Resolution: 1
*RST Setting 10
Requirements GSM/GPRS/
EGPRS TA

Revision: A.03 and above
GSM/GPRS/ EGPRS LA

Revision: C.03 and above

Programming Example

OUTPUT 714;"SETup:EMACcuracy:COUNt:SNUMber 99"
! Sets the state to on and the multi-measurement count value to 99.

SETup:EMACcuracy:COUNt:NUMBer

Function

GSM TA

 This command is not applicable to GSM.

GPRS TA

 This command is not applicable to GPRS.

GSM/GPRS LA

 This command is not applicable to the GSM/GPRS LA.

EGPRS TA

This command sets/queries the number of EGPRS modulation accuracy measurements the test set makes. The multi-measurement count state must be on before this to be applied to the measurement.

EGPRS LA
Setting

Range: 1 to 999

Resolution: 1

Query

Range: 1 to 999

Resolution: 1
*RST Setting 10
Requirements GSM/GPRS/
EGPRS TA

Revision: A.03 and above
GSM/GPRS/ EGPRS LA

Revision: C.03 and above

Programming Example

OUTPUT 714;"SETup:EMACcuracy:COUNt:NUMBer 5"
! Sets the EGPRS modulation accuracy multi-measurement count number to 5.

SETup:EMACcuracy:COUNt:STATe

Function

GSM TA

 This command is not applicable to GSM.

GPRS TA

 This command is not applicable to GPRS.

GSM/GPRS LA

 This command is not applicable to the GSM/GPRS LA.

EGPRS TA

This command sets/queries the EGPRS modulation accuracy multi-measurement count state.

EGPRS LA
Setting

Range: 0 | OFF | 1 | ON

Query

Range: 0 | 1
*RST Setting

0 | OFF
Requirements GSM/GPRS/
EGPRS TA

Revision: A.03 and above
GSM/GPRS/ EGPRS LA

Revision: C.03 and above

Programming Example

OUTPUT 714;"SETup:EMACcuracy:COUNt:STATe ON"
! Sets the multi-measurement count state to on.

SETup:EMACcuracy:DROop[:CALCulate]:STATe

Function

GSM TA

 This command is not applicable to GSM.

GPRS TA

 This command is not applicable to GPRS.

GSM/GPRS LA

 This command is not applicable to the GSM/GPRS LA.

EGPRS TA

This command sets/queries the amplitude droop calculate state for EGPRS modulation accuracy measurements.

When set to ON, amplitude droop is determined (as an estimated parameter) and removed from the signal in the measurement of RMS EVM and other parameters. This is the method of EVM measurement defined in GSM release 1999. The amplitude droop measurement results are made available, even though amplitude droop is not currently specified.

When set to OFF, amplitude droop is neither determined (as an estimated parameter) nor removed from the signal in the measurement of RMS EVM and other parameters. NaN is returned for all amplitude droop measurement results.

EGPRS LA
Setting

Range: 0 | OFF | 1 | ON

Query

Range: 0 | 1
*RST Setting

1 | ON
Requirements GSM/GPRS/
EGPRS TA

Revision: A.03 and above
GSM/GPRS/ EGPRS LA

Revision: C.03 and above

Programming Example

OUTPUT 714;"SETup:EMACcuracy:COUNt:STATe 1"
! Turns the EGPRS modulation accuracy timeout state on.

SETup:EMACcuracy:GRAPh:STATe

Function

GSM TA

 This command is not applicable to GSM.

GPRS TA

 This command is not applicable to GPRS.

GSM/GPRS LA

 This command is not applicable to the GSM/GPRS LA.

EGPRS TA

This command sets/queries the graphics state for EGPRS modulation accuracy measurements.

EGPRS LA
Setting

Range: 0 | OFF | 1 | ON

Query

Range: 0 | 1
*RST Setting

0 | OFF
Requirements GSM/GPRS/
EGPRS TA

Revision: A.03 and above
GSM/GPRS/ EGPRS LA

Revision: C.03 and above

Programming Example

OUTPUT 714;"SETup:EMACcuracy:GRAPh:STATe ON"
! Turns graphics state ON for EGPRS modulation accuracy measurements.

SETup:EMACcuracy:HISTogram:MAXimum:EVM

Function

GSM TA

 This command is not applicable to GSM.

GPRS TA

 This command is not applicable to GPRS.

GSM/GPRS LA

 This command is not applicable to the GSM/GPRS LA.

EGPRS TA

This command selects/queries the maximum sample EVM value to be displayed by the Sample EVM Histogram graph.

The number of histogram bins is fixed at 200, therefore reducing the Maximum Sample EVM value increases the resolution of the histogram.

EGPRS LA
Setting

PCT2 | PCT10| PCT100

Query

PCT2 | PCT10| PCT100
*RST Setting

PCT100
Requirements GSM/GPRS/
EGPRS TA

Revision: A.03 and above
GSM/GPRS/ EGPRS LA

Revision: C.03 and above

Programming Example

OUTPUT 714;"SETup:EMACcuracy:HISTogram:MAXimum:EVM PCT10"

SETup:EMACcuracy:IQIMbalance[:CALCulate]:STATe

Function

GSM TA

 This command is not applicable to GSM.

GPRS TA

 This command is not applicable to GPRS.

GSM/GPRS LA

 This command is not applicable to the GSM/GPRS LA.

EGPRS TA

This command sets/queries the IQ imbalance calculate state for EGPRS modulation accuracy measurements.

When set to OFF, IQ amplitude and phase imbalances are neither determined (as estimated parameters) nor removed from the signal in the measurement of RMS EVM and other parameters. This is the method of EVM measurement defined by the standards. NaN is returned for all IQ Imbalance measurement results.

When set to ON, IQ amplitude and phase imbalances are determined (as estimated parameters) and removed from the signal in the measurement of RMS EVM and other parameters. IQ Imbalance measurement results are made available. This feature provides you with a way to perform IQ modulator tuning.

EGPRS LA
Setting

Range: 0 | OFF | 1 | ON

Query

Range: 0 | 1
*RST Setting

0 | OFF
Requirements GSM/GPRS/
EGPRS TA

Revision: A.03 and above
GSM/GPRS/ EGPRS LA

Revision: C.03 and above

Programming Example

OUTPUT 714;"SETup:EMACcuracy:IQIMbalance:STATe 1"
! Turns the EGPRS modulation accuracy IQ Imbalance Calculate state on.

SETup:EMACcuracy:PERRor:FILTer

Function

GSM TA

 This command is not applicable to GSM.

GPRS TA

 This command is not applicable to GPRS.

GSM/GPRS LA

 This command is not applicable to the GSM/GPRS LA.

EGPRS TA

This command sets/queries the filter type to be applied before the phase error is estimated. The two filters are:

  • MEASurement: default measurement filter
  • LPFilter: normal low pass filter

Note that the filter only affect phase error result in the EMAC measurement, the LPFilter can provide more stable phase error.

EGPRS LA
Setting

Range: MEASurement|LPFilter

Query

Range: MEAS|LPF
*RST Setting

MEAS
Requirements GSM/GPRS/
EGPRS TA

Revision: A.09 and above
GSM/GPRS/ EGPRS LA

Revision: F.01 and above

Programming Example

OUTPUT 714;"SETup:EMACcuracy:PERRor:FILTer LPF"
! Sets the filter type to LPF.

SETup:EMACcuracy:TIMeout[:STIMe]

Function

GSM TA

 This command is not applicable to GSM.

GPRS TA

 This command is not applicable to GPRS.
GSM/GPRS LA This command is not applicable to the GSM/GPRS LA.

EGPRS TA

This command sets/queries the EGPRS modulation accuracy measurement timeout value. This command also sets the count state to on. The units (S|MS) are optional, if no units are specified then units default to S.

EGPRS LA
Setting

Range: 0.1 to 999 seconds

Resolution: 0.1 seconds

Query

Range: 0.1 to 999 seconds

Resolution: 0.1 seconds
*RST Setting

10 seconds
Requirements GSM/GPRS/
EGPRS TA

Revision: A.03 and above
GSM/GPRS/ EGPRS LA

Revision: C.03 and above

Programming Example

OUTPUT 714;"SETup:EMACcuracy:TIMeout:STIMe 20"
! Sets the state to on and the timeout value to 20 seconds.

SETup:EMACcuracy:TIMeout:STATe

Function

GSM TA

 This command is not applicable to GSM.

GPRS TA

 This command is not applicable to GPRS.

GSM/GPRS LA

 This command is not applicable to the GSM/GPRS LA.

EGPRS TA

This command selects/queries the EGPRS modulation accuracy measurement timeout state.

EGPRS LA
Setting

Range: 0 | OFF | 1 | ON

Query

Range: 0 | 1
*RST Setting

0 | OFF
Requirements GSM/GPRS/
EGPRS TA

Revision: A.03 and above
GSM/GPRS/ EGPRS LA

Revision: C.03 and above

Programming Example

OUTPUT 714;"SETup:EMACcuracy:TIMeout:STATe 1"
! Turns the EGPRS modulation accuracy timeout state on.

SETup:EMACcuracy:TIMeout:TIME

Function

GSM TA

 This command is not applicable to GSM.

GPRS TA

 This command is not applicable to GPRS.

GSM/GPRS LA

 This command is not applicable to the GSM/GPRS LA.

EGPRS TA

This command sets/queries the timeout value in seconds that will be used for EGPRS modulation accuracy measurements. The units (S|MS) are optional, if no units are specified then units default to S.

EGPRS LA
Setting

Range: 0.1 to 999 seconds

Resolution: 0.1 seconds

Query

Range: 0.1 to 999 seconds

Resolution: 0.1 seconds
*RST Setting

10 seconds
Requirements GSM/GPRS/
EGPRS TA

Revision: A.03 and above
GSM/GPRS/ EGPRS LA

Revision: C.03 and above

Programming Example

OUTPUT 714;"SETup:EMACcuracy:TIMeout:TIME 20"
! Sets the EGPRS modulation accuracy measurement timeout to 20 seconds.

SETup:EMACcuracy:TRIGger:DELay

Function

GSM TA

 This command is not applicable to GSM.

GPRS TA

 This command is not applicable to GPRS.

GSM/GPRS LA

 This command is not applicable to the GSM/GPRS LA.

EGPRS TA

This command sets/queries the trigger delay in seconds for EGPRS modulation accuracy measurements. The units (S|MS|US|NS) are optional, if no units are specified then units default to S.
EGPRS LA
Setting

Range: -2.31 ms to +2.31 ms

Resolution: 5 significant digits or 100 ns, whichever is greater

Query

Range: -2.31 ms to +2.31 ms

Resolution: 5 significant digits or 100 ns, whichever is greater
*RST Setting 0 seconds
Requirements GSM/GPRS/
EGPRS TA

Revision: A.03 and above
GSM/GPRS/ EGPRS LA

Revision: C.03 and above

Programming Example

OUTPUT 714;"SETup:EMACcuracy:TRIGger:DELay 1.5MS"
! Set trigger delay time to 1.5 milliseconds

SETup:EMACcuracy:TRIGger:SOURce

Function

GSM TA

 This command is not applicable to GSM.

GPRS TA

 This command is not applicable to GPRS.

GSM/GPRS LA

 This command is not applicable to the GSM/GPRS LA.

EGPRS TA

This command selects/queries the trigger source for EGPRS modulation accuracy measurements. See Triggering of Measurements .

EGPRS LA
Setting

AUTO | EXTernal | PROTocol | RISE | IMMediate

Query

AUTO | EXT | PROT | RISE | IMM
*RST Setting

AUTO
Requirements GSM/GPRS/
EGPRS TA

Revision: A.03 and above
GSM/GPRS/ EGPRS LA

Revision: C.03 and above

Programming Example

OUTPUT 714;"SETup:EMACcuracy:TRIGger:SOURce AUTO"
! Sets trigger source to automatic.


SETup:ETXPower

SETup:ETXPower

GPIB Command Conventions

  • SETup:ETXPower:CONTinuous
  • SETup:ETXPower:COUNt[:SNUMber]
  • SETup:ETXPower:COUNt:NUMBer
  • SETup:ETXPower:COUNt:STATe
  • SETup:ETXPower:ECPower:STATe
  • SETup:ETXPower:TIMeout[:STIMe]
  • SETup:ETXPower:TIMeout:TIME
  • SETup:ETXPower:TIMeout:STATe
  • SETup:ETXPower:TRIGger:DELay
  • SETup:ETXPower:TRIGger:SOURce

SETup:ETXPower:CONTinuous

Function

GSM TA

 This command is not applicable to the GSM Test Application

GPRS TA

 This command is not applicable to the GPRS Test Application.

GSM/GPRS LA

 This command is not applicable to the GSM/GPRS Lab Application.

EGPRS TA

This command sets/queries the trigger state for EGPRS TX carrier power measurements.

EGPRS LA
Setting

Range:

  • Single trigger mode = 0 | OFF
  • Continuous trigger mode = 1 | ON

Query

Range: 0 | 1
*RST Setting

0 | OFF
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETup:ETXPower:CONTinuous ON"
! Specifies continuous trigger mode for EGPRS TX carrier power measurements.

SETup:ETXPower:COUNt[:SNUMber]

Function

GSM TA

 This command is not applicable to the GSM.Test Application

GPRS TA

 This command is not applicable to the GPRS Test Application.

GSM/GPRS LA

 This command is not applicable to the GSM/GPRS Lab Application.

EGPRS TA

This command sets/queries the number of EGPRS TX carrier power measurements made by the test set. This command sets the count state to ON.

EGPRS LA
Setting

Range: 1 to 999

Resolution: 1

Query

Range: 1 to 999

Resolution: 1
*RST Setting 10
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETup:ETXPower:COUNt:SNUMber 99"
! Sets the state to on and the multi-measurement count value to 99.

SETup:ETXPower:COUNt:NUMBer

Function

GSM TA

 This command is not applicable to the GSM.Test Application

GPRS TA

 This command is not applicable to the GPRS Test Application.

GSM/GPRS LA

 This command is not applicable to the GSM/GPRS Lab Application.

EGPRS TA

This command sets/queries the number of EGPRS TX power measurements the test set makes in the active (that is the selected) format. The multi-measurement count state must be on.

EGPRS LA
Setting

Range: 1 to 999

Resolution: 1

Query

Range: 1 to 999

Resolution: 1
*RST Setting 10
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETup:ETXPower:COUNt:NUMBer 5"
! Sets the EGPRS TX Power multi-measurementcount number to 5.

SETup:ETXPower:COUNt:STATe

Function

GSM TA

 This command is not applicable to the GSM.Test Application

GPRS TA

 This command is not applicable to the GPRS Test Application.

GSM/GPRS LA

 This command is not applicable to the GSM/GPRS Lab Application.

EGPRS TA

This command sets/queries the EGPRS TX power multi-measurement count state.

EGPRS LA
Setting

Range: 0 | OFF | 1 | ON

Query

Range: 0 | 1
*RST Setting

0 | OFF
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETup:ETXPower:COUNt:STATe ON"
! Sets the multi-measurement count state to on.

SETup:ETXPower:ECPower:STATe

Function

GSM TA

 This command is not applicable to the GSM.Test Application

GPRS TA

 This command is not applicable to the GPRS Test Application.

GSM/GPRS LA

 This command is not applicable to the GSM/GPRS Lab Application.

EGPRS TA

This command sets/queries the EGPRS TX power estimated carrier power state.

When set to ON (1) and the modulation format is set to 8PSK, the estimated carrier power measurement is calculated and the result is available via GPIB and on the test set's front panel.

When set to OFF (0) and the modulation format is set to 8PSK, the estimated carrier power measurement is not calculated. The power measurement completes in a shorter time when this command is set to OFF.

If the modulation format is set to GMSK, only the transmit power value is displayed on the test set's front panel, and the transmit power is returned via GPIB when the estimated carrier power result is queried.

EGPRS LA
Setting

Range: 0 | OFF | 1 | ON

Query

Range: 0 | 1
*RST Setting

0 | OFF
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETup:ETXPower:COUNt:STATe ON"
! Sets the multi-measurement count state to on.

SETup:ETXPower:TIMeout[:STIMe]

Function

GSM TA

 This command is not applicable to the GSM.Test Application

GPRS TA

 This command is not applicable to the GPRS Test Application.
GSM/GPRS LA This command is not applicable to the GSM/GPRS Lab Application.

EGPRS TA

This command sets/queries the EGPRS TX carrier power measurement timeout value. This command also sets the count state to on. The units (S|MS) are optional, if no units are specified then units default to S.

EGPRS LA
Setting

Range: 0.1 to 999 seconds

Resolution: 0.1 seconds

Query

Range: 0.1 to 999 seconds

Resolution: 0.1 seconds
*RST Setting

10 seconds
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETup:ETXPower:TIMeout:STIMe 20"
! Sets the state to on and the timeout value to 20 seconds.

SETup:ETXPower:TIMeout:TIME

Function

GSM TA

 This command is not applicable to the GSM.Test Application

GPRS TA

 This command is not applicable to the GPRS Test Application.

GSM/GPRS LA

 This command is not applicable to the GSM/GPRS Lab Application.

EGPRS TA

This command sets/queries the timeout value in seconds that will be used for EGPRS TX power measurements in the active (that is the selected) format. The units (S|MS) are optional, if no units are specified then units default to S.

EGPRS LA
Setting

Range: 0.1 to 999 seconds

Resolution: 0.1 seconds

Query

Range: 0.1 to 999 seconds

Resolution: 0.1 seconds
*RST Setting

10 seconds
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETup:ETXPower:TIMeout:TIME 20"
! Sets the EGPRS TX power measurement timeout to 20 seconds.

SETup:ETXPower:TIMeout:STATe

Function

GSM TA

 This command is not applicable to the GSM.Test Application

GPRS TA

 This command is not applicable to the GPRS Test Application.

GSM/GPRS LA

 This command is not applicable to the GSM/GPRS Lab Application.

EGPRS TA

This command selects/queries EGPRS TX carrier power measurement timeout state in the active (that is the selected) format.

EGPRS LA
Setting

Range: 0 | OFF | 1 | ON

Query

Range: 0 | 1
*RST Setting

0 | OFF
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETup:ETXPower:COUNt:STATe 1"
! Turns the EGPRS TX carrier power timeout state on.

SETup:ETXPower:TRIGger:DELay

Function

GSM TA

 This command is not applicable to the GSM.Test Application

GPRS TA

 This command is not applicable to the GPRS Test Application.

GSM/GPRS LA

 This command is not applicable to the GSM/GPRS Lab Application.

EGPRS TA

This command sets/queries the trigger delay in seconds for EGPRS TX carrier power measurements in the active (that is the selected) format. The units (S|MS|US|NS) are optional, if no units are specified then units default to S.
EGPRS LA
Setting

Range: -2.31 ms to +2.31 ms

Resolution: 5 significant digits or 100 ns, whichever is greater

Query

Range: -2.31 ms to +2.31 ms

Resolution: 5 significant digits or 100 ns, whichever is greater
*RST Setting 0 seconds
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETup:ETXPower:TRIGger:DELay 1.5MS"
! Set trigger delay time to 1.5 milliseconds

SETup:ETXPower:TRIGger:SOURce

Function

GSM TA

 This command is not applicable to the GSM.Test Applicaton

GPRS TA

 This command is not applicable to the GPRS Test Application.

GSM/GPRS LA

 This command is not applicable to the GSM/GPRS Lab Application.

EGPRS TA

This command selects/queries the trigger source for EGPRS TX carrier power measurements in the active (that is the selected) format. See Triggering of Measurements .

EGPRS LA
Setting

AUTO | PROTocol | RISE | IMMediate

Query

AUTO | PROT | RISE | IMM
*RST Setting

AUTO
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETup:ETXPower:TRIGger:SOURce AUTO"
! Sets trigger source to automatic.


SETup:FBERror

SETup:FBERror

GPIB Command Conventions

  • SETup:FBERror:CLSDelay[:STIMe]
  • SETup:FBERror:CLSDelay:TIME
  • SETup:FBERror:CLSDelay:STATe
  • SETup:FBERror:CONTinous
  • SETup:FBERror:COUNt
  • SETup:FBERror:LDControl:AUTO
  • SETup:FBERror:MANual:DELay
  • SETup:FBERror:SLControl[:STATe]
  • SETup:FBERror:TIMeout[:STIMe]
  • SETup:FBERror:TIMeout:TIME
  • SETup:FBERror:TIMeout:STATe

SETup:FBERror:CLSDelay[:STIMe]

Function

GSM TA

This command selects/queries the closed loop signalling delay time in seconds for Fast Bit Error measurements and sets the delay state to ON. The units (S|MS) are optional, if no units are specified than units default to S.

The delay time defines how long the test set should wait before starting a FBER measurement. The downlink signalling operation must be completed and the test set must send a close loop command to the MS before the measurement can begin. The delay time allows time for the loop to close.

When a close loop message is set to the MS the closed loop signalling delay time will hold off the FBER measurement from starting for the specified time period.

GSM/GPRS LA

EGPRS LA

GPRS TA

This command is not applicable to GPRS.

EGPRS TA

This command is not applicable to EGPRS.
Setting

Range: 0 to 5 seconds

Resolution: 100 ms

Query

Range: 0 to 5 seconds

Resolution: 100 ms
*RST Setting 500 ms
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

 OUTPUT 714;"SETUP:FBERROR:CLSDELAY:STIME 500 MS"
! Sets the Close Loop Delay to 500 ms.

SETup:FBERror:CLSDelay:TIME

Function

GSM TA

This command selects/queries the closed loop signalling delay time in seconds for Fast Bit Error measurements. The units (S|MS) are optional, if no units are specified than units default to S.

The delay time defines how long the test set should wait before starting a FBER measurement. The downlink signalling operation must be completed and the test set must send a close loop command to the MS before the measurement can begin. The delay time allows time for the loop to close.

When a close loop message is set to the MS the closed loop signalling delay time will hold off the FBER measurement from starting for the specified time period.

GSM/GPRS LA

EGPRS LA

GPRS TA

This command is not applicable to GPRS.

EGPRS TA

This command is not applicable to EGPRS.
Setting

Range: 0 to 5 seconds

Resolution: 100 ms

Query

Range: 0 to 5 seconds

Resolution: 100ms
*RST Setting 500 ms

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

 OUTPUT 714;"SETUP:FBERROR:CLSDELAY:TIME 500 MS"
! Sets the Close Loop Delay to 500 ms.

SETup:FBERror:CLSDelay:STATe

Function

GSM TA

This command selects/queries the closed loop signalling delay state for Fast Bit Error measurements. If the state is off the test set will not wait to start a FBER measurement after a downlink signalling operation has completed.

The delay time defines how long the test set should wait before starting a FBER measurement after a downlink signalling operation has completed and after the test set has sent a close loop command to the MS.

When a close loop message is set to the MS the closed loop signalling delay time will hold off the FBER measurement from starting for the specified time period.

GSM/GPRS LA

EGPRS LA

GPRS TA

 This command is not applicable to GPRS.

EGPRS TA

This command is not applicable to EGPRS.
Setting Range: 1 | ON

 |
0 | OFF

Query

Range: 1 | 0
*RST Setting 1 (on)

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

 OUTPUT 714;"SETUP:FBERROR:CLSDELAY:STATE ON"
! Sets the Close Loop Delay state to on.

SETup:FBERror:CONTinous

Function

GSM TA

This command selects/queries the trigger state for Fast Bit Error Rate tests.

GSM/GPRS LA

EGPRS LA

GPRS TA

This command is not applicable to GPRS.

EGPRS TA

This command is not applicable to EGPRS.
Setting

Range:

  • Continuous trigger mode = 1 | ON
  • Single trigger mode = 0 | OFF

Query

Range: 1 | 0
*RST Setting 0 (single)

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETUP:FBERROR:CONTINUOUS 0"
! Specifies single trigger mode for Fast BER measurements.

SETup:FBERror:COUNt

Function

GSM TA

 This command sets/queries the number of bits to test during each Fast Bit Error Rate test.

GSM/GPRS LA

EGPRS LA

GPRS TA

 This command is not applicable to GPRS.

EGPRS TA

This command is not applicable to EGPRS.
Setting

Range: 1 to 999,000

Resolution: 1

Query

Range: 1 to 999,000

Resolution: 1
*RST Setting 10,000

Comments

 The actual number of bits that are tested will be determined by the number of frames tested, and will be at least as great as this count

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;``SETUP:FBERROR:COUNT 10000"
! Specifies the number of Fast BER bits to test at 10,000 bits.

SETup:FBERror:LDControl:AUTO

Function

GSM TA

This command sets/queries loopback delay control mode. If loopback control mode is automatic (auto on), the test set will determine the frame delay value that will allow correlation between uplink information bits with downlink information bits. .

If loopback delay control mode is manual (auto off) , the test set will use the frame delay value entered in the TDMA Frames Delay field. Refer to SETup:FBERror:MANual:DELay .

Refer also to the Fast Bit Error Measurement Description for a description of frame delay and its use in the fast bit error rate measurement.

GSM/GPRS LA

EGPRS LA

GPRS TA

This command is not applicable to GPRS.

EGPRS TA

This command is not applicable to EGPRS.
Setting

Range: 1 | ON | 0 | OFF

Query

Range: 1 | 0
*RST Setting | 1 (automatic)
Related Topics | see SETup:FBERror:MANual:DELay

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETUP:FBERROR:LDCONTROL OFF"
! Set delay control to manual the user must select the manual frame delay number.

SETup:FBERror:MANual:DELay

Function

GSM TA

This command sets/queries the number of frames the test set will use to correlate uplink information bits with downlink information bits when loopback delay control mode is manual (auto off). To set the loopback delay mode to manual, refer to SETup:FBERror:LDControl:AUTO .

This value is displayed in the TDMA Frames Delay field when Auto is not displayed. (If you want to display this value and Auto is currently displayed, press the front panel key labeled MANUAL).

Refer to Fast Bit Error Measurement Description for a description of frame delay and how it is used in this measurement.

GSM/GPRS LA

EGPRS LA

GPRS TA

 This command is not applicable to GPRS.

EGPRS TA

This command is not applicable to EGPRS.
Setting

Range: 0 to 26

Resolution: 1

Query

Range: 0 to 26

Resolution: 1
*RST Setting 5 (loopback delay control is reset to automatic (auto on)).

Related Topics

 See SETup:FBERror:LDControl:AUTO .

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETUP:FBERROR:MANUAL:DELAY 6"
! Set frame delay to 6 frames.

SETup:FBERror:SLControl[:STATe]

Function

GSM TA

This command selects/queries the Signalling loopback control state for an FBER measurement.

When the state is set to on, the test set will automatically send the command for Type C (burst-by-burst) loopback to the MS when a FBER measurement is activated, and then set loopback to off when the measurement is complete.

The loopback type is controlled manually from the Mobile Loopback F12 key, see CALL:TCHannel:LOOPback for a program example and details about the command.

GSM/GPRS LA

EGPRS LA

GPRS TA

This command is not applicable to GPRS.

EGPRS TA

This command is not applicable to EGPRS.
Setting

Range: 1 | ON | 0 | OFF

Query

Range: 1 | 0
*RST Setting 1 (on)

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETUP:FBERROR:SLCONTROL ON"
! Sets the Signal Loop Control state to on.

SETup:FBERror:TIMeout[:STIMe]

Function

GSM TA

 This command selects/queries the timeout value in seconds for the trigger state during Fast Bit Error measurements and sets the timeout state to ON. The units (S|MS) are optional, if no units are specified than units default to S.

GSM/GPRS LA

EGPRS LA

GPRS TA

This command is not applicable to GPRS.

EGPRS TA

This command is not applicable to EGPRS.
Setting

Range: 0.1 to 999 seconds

Resolution: 0.1 seconds

Query

Range: 0.1 to 999 seconds

Resolution: 0.1 seconds
*RST Setting 10 seconds

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETUP:FBERROR:TIMEOUT:STIME 20"
! Sets the timeout value to 20 seconds and the state to on.

SETup:FBERror:TIMeout:TIME

Function

GSM TA

 This command selects/queries the timeout value in seconds for the trigger state during Fast Bit Error measurements. The units (S|MS) are optional, if no units are specified than units default to S.

GSM/GPRS LA

EGPRS LA

GPRS TA

This command is not applicable to GPRS.

EGPRS TA

This command is not applicable to EGPRS.
Setting

Range: 0.1 to 999 seconds

Resolution: 0.1 seconds

Query

Range: 0.1 to 999 seconds

Resolution: 0.1 seconds
*RST Setting 10 seconds

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETUP:FBERROR:TIMEOUT:TIME 20"
! Sets the timeout value to 20 seconds.

SETup:FBERror:TIMeout:STATe

Function

GSM TA

 This command sets/queries the timeout state for Fast BER measurements.

GSM/GPRS LA

EGPRS LA

GPRS TA

 This command is not applicable to GPRS.

EGPRS TA

This command is not applicable to EGPRS.
Setting

Range: 0|OFF | 1|ON

Query

Range: 0|1
*RST Setting 0 (off)

Requirements

 GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETUP:FBERROR:TIMEOUT:STATE ON"
! Sets the timeout state to on.


SETup:FSTability

SETup:FSTability

GPIB Command Conventions

  • SETup:FSTability:CONTinuous
  • SETup:FSTability:COUNt[:SNUMber]
  • SETup:FSTability:COUNt:NUMBer
  • SETup:FSTability:COUNt:STATe
  • SETup:FSTability:TIMeout[:STIMe]
  • SETup:FSTability:TIMeout:STATe
  • SETup:FSTability:TIMeout:TIME

SETup:FSTability:CONTinuous

Function

GSM TA

Sets/queries the trigger arm state for the frequency stability measurement. Determines whether measurement will make one measurement then stop (0|OFF (single)), or automatically rearm upon completion of one measurement and repeat the process (1|ON (continuous)).
GPRS TA
EGPRS TA
GSM LA
GPRS/EGPRS LA

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)
Requirements GSM/GPRS/ EGPRS TA

Revision: A.04 and above
GSM/GPRS/ EGPRS LA Revision: D.01 and above

Programming Example

OUTPUT 714;"SETUP:FSTABILITY:CONTINUOUS ON"
! Sets measurement to continuous trigger mode.

SETup:FSTability:COUNt[:SNUMber]

Function

GSM TA

Sets/queries the number of frequency stability measurements to be made in a mulit-measurement setup. This command sets the count, and automatically sets the multi-measurement STATe command to 1 (on).
GPRS TA
EGPRS TA
GSM LA
GPRS/EGPRS LA

Setting

Range: 1 to 999

Query

Range: 1 to 999

*RST Setting

10, on
Requirements GSM/GPRS/ EGPRS TA

Revision: A.04 and above
GSM/GPRS/ EGPRS LA Revision: D.01 and above

Programming Example

OUTPUT 714;"SETUP:FSTABILITY:COUNT:SNUMBER 5"
! Turns on multi-measurements and sets the number of measurements to 5.

SETup:FSTability:COUNt:NUMBer

Function

GSM TA

Sets/queries the number of frequency stability measurements to be made when mulit-measurement state is ON.

GPRS TA
EGPRS TA
GSM LA
GPRS/EGPRS LA

Setting

Range: 1 to 999

Query

Range: 1 to 999

*RST Setting

 10
Requirements GSM/GPRS/ EGPRS TA

Revision: A.04 and above
GSM/GPRS/ EGPRS LA Revision: D.01 and above

Programming Example

OUTPUT 714;"SETUP:FSTABILITY:COUNT:NUMBER 5"
! Sets the number of measurements to 5 when the multi-measurement state is set to ON.

SETup:FSTability:COUNt:STATe

Function

GSM TA

Sets/queries the multi-measurement state of the frequency stability measurement.
GPRS TA
EGPRS TA
GSM LA
GPRS/EGPRS LA

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)
Requirements GSM/GPRS/ EGPRS TA

Revision: A.04 and above
GSM/GPRS/ EGPRS LA Revision: D.01 and above

Programming Example

OUTPUT 714;"SETUP:FSTABILITY:COUNT:STATE ON"
! Turns on multi-measurements.

SETup:FSTability:TIMeout[:STIMe]

Function

GSM TA

Sets/queries the frequency stability measurement's timeout setting and automatically sets the timeout state to ON.
GPRS TA
EGPRS TA
GSM LA
GPRS/EGPRS LA

Setting

Range: 0.1 to 999 seconds

Resolution: 0.1 second

Query

Range: 0.1 to 999

*RST Setting

10 seconds, on
Requirements GSM/GPRS/ EGPRS TA

Revision: A.04 and above
GSM/GPRS/ EGPRS LA Revision: D.01 and above

Programming Example

OUTPUT 714;"SETUP:FSTABILITY:TIMEOUT:STIME 5S"
! Sets timeout state to ON and sets the timeout time to 5 seconds.

SETup:FSTability:TIMeout:STATe

Function

GSM TA

Sets/queries the frequency stability measurement's timeout state.
GPRS TA
EGPRS TA
GSM LA
GPRS/EGPRS LA

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)
Requirements GSM/GPRS/ EGPRS TA

Revision: A.04 and above
GSM/GPRS/ EGPRS LA Revision: D.01 and above

Programming Example

OUTPUT 714;"SETUP:FSTABILITY:TIMEOUT:STATE ON"

SETup:FSTability:TIMeout:TIME

Function

GSM TA

Sets/queries the frequency stability measurement's timeout setting.
GPRS TA
EGPRS TA
GSM LA
GPRS/EGPRS LA

Setting

Range: 0.1 to 999 seconds

Resolution: 0.1 second

Query

Range: 0.1 to 999 seconds

Resolution: 0.1 second

*RST Setting

10 seconds, on
Requirements GSM/GPRS/ EGPRS TA

Revision: A.04 and above
GSM/GPRS/ EGPRS LA Revision: D.01 and above

Programming Example

OUTPUT 714;"SETUP:FSTABILITY:TIMEOUT:TIME 5S"


SETup:GBERror

SETup:GBERror

Last updated: December 4, 2008

GPIB Command Conventions

  • SETup:GBERror:BBLocks
  • SETup:GBERror:CONTinuous
  • SETup:GBERror:COUNt
  • SETup:GBERror:LDControl:AUTO
  • SETup:GBERror:MANual:DELay
  • SETup:GBERror:TIMeout[:STIMe]
  • SETup:GBERror:TIMeout:TIME
  • SETup:GBERror:TIMeout:STATe
  • SETup:GBERror:ZBBLocks

SETup:GBERror:BBLocks

Function

GSM TA

 This command is not applicable to the GSM TA.

GPRS TA

This command sets/queries the setting for the GBER Bad Block Handling parameter. The GBER Bad Block Handling parameter controls how the bad blocks are used while calculating the BER. This command as three options:

  1. Zero -Sets all bits within a bad block to zero before calculating the BER. This results in an average error rate of 50%.
  2. Include -The bad bits are not altered before calculating the BER.
  3. Exclude- All bits within a bad block are excluded from the BER calculation.

NOTE
A block is defined as bad if :
  • At least one of the four expected bursts has not been received by the test set.
  • The demodulation quality of at least one of the bursts was questionable.
  • The block has failed the frame check sequence (CRC). (Each block that fails its CRC will cause the CRC error count result to increment, regardless of the GBER Bad Block Handling setting.) The CRC count result can be obtained using the command FETCh:GBERror:CRC?

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

Range: ZERO|INCLude|EXCLude

Query

Range: ZERO|INCL|EXCL
*RST Setting

ZERO
Requirements GSM/GPRS/
EGPRS TA

Revision: A.05 and above
GSM/GPRS/ EGPRS LA

Revision: D.02 and above

Programming Example

OUTPUT 714;"SETup:GBERor:BBLocks EXClude"
! Sets GBER measurement to exclude all bits within a bad block while calculating the BER.

SETup:GBERror:CONTinuous

Function

GSM TA

This command is not applicable to GSM.

GPRS TA

This command sets/queries the trigger state to single trigger mode or continuous trigger mode for the BER measurement.

EGPRS TA

GSM/GPRS LA
EGPRS LA
Setting

Range: 0|OFF | 1|ON

Query

Range: 0|1
*RST Setting

0 (off)
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETup:GBERror:CONTinous OFF"
! Sets BER measurement to single trigger mode.

SETup:GBERror:COUNt

Function

GSM TA

This command is not applicable to GSM.

GPRS TA

This command sets/queries the number of bits to measure when the count state is ON.

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

Range: 1 to 999,000

Resolution: 1

Query

Range: 1 to 999,000

Resolution: 1
*RST Setting

10,000
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETup:GBERror:COUNt 880"
! Sets the number of bits to measure to 880.

SETup:GBERror:LDControl:AUTO

Function

GSM TA

This command is not applicable to GSM.

GPRS TA

This command sets/queries the loopback delay control mode.

If loopback delay control mode is automatic (ON), the test set determines the block delay value that allows the correlation between uplink and downlink data. While the loopback delay control is automatic, the test set attempts to determine the loopback delay in the following cases:

  • If the Operating Mode is GPRS BCH+PDTCH, the test set determines the loopback delay in the following cases.
  • If the Operating Mode is Active Cell (serving cell GPRS), the test set determines the loopback delay the first time a measurement is made after the GBER measurement has been initiated. (If the connection is terminated or the loopback delay control changes, the test set will redetermine the loopback delay.)
  • The first time a measurement is made after the GBER measurement has been initiated after a change in the Operating Mode.

If loopback delay control mode is manual (OFF), the test set uses the block delay you specify using SETup:GBERror:MANual:DELay .

Refer to How is a GPRS Bit Error (GBER) Measurement Made? for a description of block delay and its use in the BER measurement.

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

Range: 0 | OFF | 1 | ON

Query

Range: 0 | 1
*RST Setting

1 (on)
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETup:GBERror:LDControl:AUTO OFF"
! Sets the loopback delay control mode to manual.

SETup:GBERror:MANual:DELay

Function

GSM TA

This command is not applicable to GSM.

GPRS TA

This command sets/queries the block delay when loopback delay control mode is manual. To set the delay mode to manual, refer to SETup:GBERror:LDControl:AUTO .

Refer to GPRS Bit Error Measurement for a description of block delay and how it is used in this measurement.

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

Range: 1 to 12

Resolution : 1

Query

Range: 1 to 12

Resolution : 1
*RST Setting

2
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above

Range increased from 6 to 12 at Revision A.03
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Range increased from 6 to 12 at Revision C.03

Programming Example

OUTPUT 714;"SETup:GBERror:MANual:DELay 6"
! Sets the number of blocks to 6.

SETup:GBERror:TIMeout[:STIMe]

Function

GSM TA

This command is not applicable to GSM.

GPRS TA

This command sets/queries the timeout value in seconds for the trigger state during BER measurements and turns the timeout state on. The units (S|MS) are optional, if no units are specified than units default to S.

EGPRS TA

GSM/GPRS LA
EGPRS LA
Setting

Range: 0.1 to 999

Resolution: 0.1

Query

Range: 0.1 to 999Resolution: 0.1
*RST Setting

10 seconds
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETup:GBERror:TIMeout:STIMe 12"
! Sets BER measurement timeout to 12 seconds and the state to on.

SETup:GBERror:TIMeout:TIME

Function

GSM TA

This command is not applicable to GSM.

GPRS TA

This command sets/queries the timeout value in seconds for the trigger state during BER measurements. The units (S|MS) are optional, if no units are specified than units default to S (seconds).

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

Range: 0.1 to 999

Resolution: 0.1

Query

Range: 0.1 to 999Resolution: 0.1
*RST Setting

10 seconds
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETup:GBERror:TIMeout:TIME 8"
! Sets BER measurement timeout to 8 seconds.

SETup:GBERror:TIMeout:STATe

Function

GSM TA

This command is not applicable to GSM.

GPRS TA

This command sets/queries the timeout state for BER measurements.

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

Range: 0 | OFF | 1 | ON

Query

Range: 0 | 1
*RST Setting

0 (off)
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETup:GBERror:TIMEout:STATe ON"
! Sets the timeout state to on.

SETup:GBERror:ZBBLocks

Function

GSM TA

This command is not applicable to GSM.

GPRS TA

 THIS COMMAND IS OBSOLETE. Please use SETup:GBERror:BBLocks instead.

This command sets/queries the zero bad blocks state for BER measurements. The zero bad blocks state determines how a bad block is interpreted.

A block is defined as bad if either:

  • At least one of the four expected bursts has not been received by the test set, or
  • The demodulation quality of at least one of the bursts was questionable.

When set to On, all bits within a bad block are set to zero. This results in an average error rate of 50%. Setting this command to On is equivalent to setting the SETup:GBERror:BBLocks to Zero.

When set to Off, the value of bits within a bad block are not altered before being measured. This lowers the overall BER value measured. Setting this command to Off is equivalent to setting SETup:GBERror:BBLocks to INClude.

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

Range: 0 | OFF | 1 | ON

Query

Range: 0 | 1
*RST Setting

1 (on)
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETup:GBERror:ZBBLocks:STATe OFF"
! Sets the zero bad blocks state to off.


SETup:IFERror

SETup:IFERror

GPIB Command Conventions

  • SETup:IFERror:CONTinuous
  • SETup:IFERror:COUNt
  • SETup:IFERror:CPERiod
  • SETup:IFERror:LDControl:AUTO
  • SETup:IFERror:MANual:DELay
  • SETup:IFERror:TIMeout:STATe
  • SETup:IFERror:TIMeout[:STIME]
  • SETup:IFERror:TIMeout:TIME

SETup:IFERror:CONTinuous

Function

 GSM TA

This command is not applicable to the GSM TA.
GPRS TA

This command is not applicable to the GPRS TA.
EGPRS TA

This command is not applicable to the EGPRS TA.

GSM/GPRS LA

Sets/queries the state of the In-Band Frame Error (IFER) measurement trigger.

EGPRS LA

Setting

1|ON|0|OFF

Query

 0|1

*RST Setting

 0
Requirements

 GSM/GPRS/ EGPRS LA

Revision: D.01 and above

GSM/GPRS/ EGPRS TA

Revision: A.09 and above with required feature license.

Programming Example

OUTPUT 714;"SETup:IFERror:CONTinuous ON"
! Makes the IFER measurement trigger continuously.

SETup:IFERror:COUNt

Function

 GSM TA

This command is not applicable to the GSM TA.
GPRS TA

This command is not applicable to the GPRS TA.
EGPRS TA

This command is not applicable to the EGPRS TA.

GSM/GPRS LA

Sets/queries the number of speech frames to measure.

EGPRS LA

Setting

Range: 1000-900000

Resolution: 1

Query

Range: 1000-900000 or 9.91e+37 (NAN)

Resolution: 1

*RST Setting

 5000
Requirements

 GSM/GPRS/ EGPRS LA

Revision: D.01 and above

GSM/GPRS/ EGPRS TA

Revision: A.09 and above with required feature license.

Programming Example

OUTPUT 714;"SETup:IFERror:COUNt 150000"
! Sets the number of Speech Frames for the test set to measure to 150000.

SETup:IFERror:CPERiod

Function

 GSM TA

This command is not applicable to the GSM TA.
GPRS TA

This command is not applicable to the GPRS TA.
EGPRS TA

This command is not applicable to the EGPRS TA.

GSM/GPRS LA

Sets/queries the number of frames the change period is assigned in the In-Band Frame Error (IFER) measurement.

EGPRS LA

Setting

Range: 1 to 100

Resolution: 1

Query

Range: 1 to 100

Resolution: 1

*RST Setting

 22
Requirements

 GSM/GPRS/ EGPRS LA

Revision: D.01 and above

GSM/GPRS/ EGPRS TA

Revision: A.09 and above with required feature license.

Programming Example

OUTPUT 714;"SETup:IFERror:CPERiod 25"
! Sets the change period to 25.

SETup:IFERror:LDControl:AUTO

Function

 GSM TA

This command is not applicable to the GSM TA.
GPRS TA

This command is not applicable to the GPRS TA.
EGPRS TA

This command is not applicable to the EGPRS TA.

GSM/GPRS LA

Sets/queries the state of the Loopback Delay Control. The Loopback Delay Control can automatically determine the delay needed to complete the loopback, or it can be set manually.

EGPRS LA

Setting

1|ON|0|OFF

Query

1|0
*RST Setting 1
Requirements

 GSM/GPRS/ EGPRS LA

Revision: D.01 and above

GSM/GPRS/ EGPRS TA

Revision: A.09 and above with required feature license.

Programming Example

OUTPUT 714;"SETup:IFERror:LDControl:AUTO 0"
! Sets the loopback delay control to the manual state. It also allows the user to set the
! Speech Frame Delay time.

SETup:IFERror:MANual:DELay

Function

 GSM TA

This command is not applicable to the GSM TA.
GPRS TA

This command is not applicable to the GPRS TA.
EGPRS TA

This command is not applicable to the EGPRS TA.

GSM LA

Sets/queries the number of Speech Frames to wait to correlate the uplink with the downlink.

If the speech frame loopback delay parameter is set to AUTO, and the Operating Mode is not in Active Cell, the test set will a try to determine the speech frame delay every time the measurement begins. If the Operating Mode is in Active Cell, the test set tries to determine the speech frame delay the first time the measurement is made, unless the call drops or the speech frame delay control changes. If the speech frame loopback delay control is set to Manual, the test set uses the specified speech frame delay.

EGPRS LA

Setting

Range: 0 to 10

Resolution: 1

Query

Range: 0 to 10

Resolution: 1

*RST Setting

 2
Requirements

 GSM/GPRS/ EGPRS LA

Revision: D.01 and above

GSM/GPRS/ EGPRS TA

Revision: A.09 and above with required feature license.

Programming Example

OUTPUT 714;"SETup:IFERror:LDControl:AUTO 0"
! Enables the user to set the Speech Frame Delay.

OUTPUT 714;"SETup:IFERror:MANual:DELay 5"
! Changes the number of Speech Frames to wait to 5 frames.

SETup:IFERror:TIMeout:STATe

Function

 GSM TA

This command is not applicable to the GSM TA.
GPRS TA

This command is not applicable to the GPRS TA.
EGPRS TA

This command is not applicable to the EGPRS TA.

GSM/GPRS LA

Sets/queries the state of the timeout for the In-Band Frame Error Rate (IFER) measurement.

EGPRS LA

Setting

1|ON|0|OFF

Query

 0|1

*RST Setting

 0
Requirements

 GSM/GPRS/ EGPRS LA

Revision: D.01 and above

GSM/GPRS/ EGPRS TA

Revision: A.09 and above with required feature license.

Programming Example

OUTPUT 714;"SETup:IFERror:TIMeout:STATe 1"
! Turns on the measurement timeout.

SETup:IFERror:TIMeout[:STIME]

Function

 GSM TA

This command is not applicable to the GSM TA.
GPRS TA

This command is not applicable to the GPRS TA.
EGPRS TA

This command is not applicable to the EGPRS TA.

GSM/GPRS LA

This command combines SETup:IFERror:TIMeout:TIME and SETup:IFERror:TIMeout:STATe . This command sets both the state of the In-Band Frame Error (IFER) measurement timeout to ON and the time for the measurement to time out. The units (S|MS|US|NS) are optional, if none are specified, the the default is S. Only the timeout time is queried with this command.

EGPRS LA

Setting

Range: 1 to 999.9 seconds

Resolution: .1 seconds

Query

Range: 1 to 999.9 seconds

Resolution: .1 seconds

*RST Setting

10 seconds
Requirements

 GSM/GPRS/ EGPRS LA

Revision: D.01 and above

GSM/GPRS/ EGPRS TA

Revision: A.09 and above with required feature license.

Programming Example

OUTPUT 714;"SETup:IFERror:TIMeout 5"
! Sets the state of the timeout to ON and the measurement timeout time to 5 seconds.

SETup:IFERror:TIMeout:TIME

Function

 GSM TA

This command is not applicable to the GSM TA.
GPRS TA

This command is not applicable to the GPRS TA.
EGPRS TA

This command is not applicable to the EGPRS TA.

GSM/GPRS LA

Sets/queries the amount of time it takes for the In-Band Frame Error measurement to timeout.

EGPRS LA

Setting

Range: 1 to 999.9 seconds

Resolution: .1 seconds

Query

Range: 1 to 999.9 seconds

Resolution: .1 seconds

*RST Setting

10
Requirements

 GSM/GPRS/ EGPRS LA

Revision: D.01 and above

GSM/GPRS/ EGPRS TA

Revision: A.09 and above with required feature license.

Programming Example

OUTPUT 714;"SETup:IFERror:TIMeout:TIME 10"
! Sets the measurement timeout to 10 seconds.


SETup:IQTuning

SETup:IQTuning

GPIB Command Conventions

  • SETup:IQTuning:CONTinuous[:SELected]
  • SETup:IQTuning:CONTinuous:GSM
  • SETup:IQTuning:COUNt:STATe[:SELected]
  • SETup:IQTuning:COUNt:STATe:GSM
  • SETup:IQTuning:COUNt:NUMBer[:SELected]
  • SETup:IQTuning:COUNt:NUMBer:GSM
  • SETup:IQTuning:COUNt[:SNUMBer][:SELected]
  • SETup:IQTuning:COUNt[:SNUMBer]:GSM
  • SETup:IQTuning:REFerence:AUTO
  • SETup:IQTuning:REFerence[:MANual][:FREQuency][:SELected]
  • SETup:IQTuning:REFerence[:MANual][:FREQuency]:GSM
  • SETup:IQTuning:REFerence[:MANual][:FREQuency]:CHARacter:GSM
  • SETup:IQTuning:SPUR:FREQuency[:SELected]
  • SETup:IQTuning:SPUR:FREQuency:GSM
  • SETup:IQTuning:SPUR:STATe[:SELected]
  • SETup:IQTuning:SPUR:STATe:GSM
  • SETup:IQTuning:SPUR[:SFRequency][:SELected]
  • SETup:IQTuning:SPUR[:SFRequency]:GSM
  • SETup:IQTuning:TIMeout:STATe[:SELected]
  • SETup:IQTuning:TIMeout:STATe:GSM
  • SETup:IQTuning:TIMeout[:STIMe][:SELected]
  • SETup:IQTuning:TIMeout[:STIMe]:GSM
  • SETup:IQTuning:TIMeout:TIMe[:SELected]
  • SETup:IQTuning:TIMeout:TIMe:GSM
  • SETup:IQTuning:TRIGger:DELay[:SELected]
  • SETup:IQTuning:TRIGger:DELay:GSM
  • SETup:IQTuning:TRIGger:SOURce[:SELected]
  • SETup:IQTuning:TRIGger:SOURce:GSM

SETup:IQTuning:CONTinuous[:SELected]

Function

GSM TA

Sets/queries the trigger arm state for the IQ tuning measurement in the active (that is the selected) format. Determines whether measurement will make one measurement then stop (0|OFF (single)), or automatically rearm upon completion of one measurement and repeat the process (1|ON (continuous)).

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

Range:

  • Continuous trigger mode = 1 | ON
  • Single trigger mode = 0 | OFF

Query

Range: 1 | 0
*RST Setting

The *RST value of this command depends on the format that is currently active. For example, if the GSM format is currently active, the *RST value for this command is the same value as the equivalent command containing the :GSM format identifier.
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETUP:IQTUNING:CONTINUOUS:SELECTED ON"
! Sets measurement to continuous trigger mode.

SETup:IQTuning:CONTinuous:GSM

Function

GSM TA

Sets/queries the trigger arm state for the IQ tuning measurement in the GSM format whether or not that format is active. Determines whether measurement will make one measurement then stop (0|OFF (single)), or automatically rearm upon completion of one measurement and repeat the process (1|ON (continuous)).

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

Range:

  • Continuous trigger mode = 1 | ON
  • Single trigger mode = 0 | OFF

Query

Range: 1 | 0
*RST Setting 1 (on)
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETUP:IQTUNING:CONTINUOUS:GSM ON"
! Sets measurement to continuous trigger mode.

SETup:IQTuning:COUNt:STATe[:SELected]

Function

GSM TA

Sets/queries the multi-measurement state for the IQ tuning measurement in the active (that is the selected) format.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting Range: 0 | OFF | 1 | ON

Query

 0 | 1
*RST Setting

The *RST value of this command depends on the format that is currently active. For example, if the GSM format is currently active, the *RST value for this command is the same value as the equivalent command containing the :GSM format identifier.
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETUP:IQTUNING:COUNT:STATE:SELECTED ON"
! Turns on multi-measurements.

SETup:IQTuning:COUNt:STATe:GSM

Function

GSM TA

Sets/queries the multi-measurement state for the IQ tuning measurement in the GSM format whether or not that format is active.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting | Range: 0 | OFF | 1 | ON

Query

 0 | 1
*RST Setting | 0 (off)
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETUP:IQTUNING:COUNT:STATE:GSM ON"
! Turns on multi-measurements.

SETup:IQTuning:COUNt:NUMBer[:SELected]

Function

GSM TA

 This command sets/queries the number of I/Q Tuning multi-measurements the test set makes in the active (that is the selected) format. The multi-measurement count state must be on. See I/Q Tuning Measurement Description .

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

Range: 1 to 999

Resolution: 1

Query

Range: 1 to 999

Resolution: 1
*RST Setting

The *RST value of this command depends on the format that is currently active. For example, if the GSM format is currently active, the *RST value for this command is the same value as the equivalent command containing the :GSM format identifier.
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETUP:IQTUNING:COUNT:NUMBER:SELECTED 30"
! Sets the number of multi-measurements.

SETup:IQTuning:COUNt:NUMBer:GSM

Function

GSM TA

 This command sets/queries the number of I/Q Tuning multi-measurements the test set makes in the GSM format whether or not that format is active. The multi-measurement count state must be on. See I/Q Tuning Measurement Description .

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

Range: 1 to 999

Resolution: 1

Query

Range: 1 to 999

Resolution: 1
*RST Setting 10
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETUP:IQTUNING:COUNT:NUMBER:GSM 30"
! Sets the number of multi-measurements.

SETup:IQTuning:COUNt[:SNUMBer][:SELected]

Function

GSM TA

 This command sets/queries the number of I/Q Tuning multi-measurements the test set makes in the active (that is the selected) format. This command sets the count state to ON.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

Range: 1 to 999

Resolution: 1

Query

Range: 1 to 999

Resolution: 1
*RST Setting

The *RST value of this command depends on the format that is currently active. For example, if the GSM format is currently active, the *RST value for this command is the same value as the equivalent command containing the :GSM format identifier.
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETUP:IQTUNING:COUNT:SNUMBER:SELECTED 30"
! Turns on multi-measurement and sets the number of multi-measurements to 30.

SETup:IQTuning:COUNt[:SNUMBer]:GSM

Function

GSM TA

 This command sets/queries the number of I/Q Tuning multi-measurements the test set makes in the GSM format whether or not that format is active. This command sets the count state to ON.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

Range: 1 to 999

Resolution: 1

Query

Range: 1 to 999

Resolution: 1
*RST Setting 10
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETUP:IQTUNING:COUNT:SNUMBER:GSM 30"
! Turns on multi-measurement and sets the number of multi-measurements to 30.

SETup:IQTuning:REFerence:AUTO

Function

GSM TA

This command allows you to specify whether or not the test set selects the most appropriate offset to be used for the measurement.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting | Range: 0 | OFF | 1 | ON

Query

 0 | 1
*RST Setting | 1 | ON
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETUP:IQTUNING:REFERENCE:AUTO 1"
! Sets the test set to select the reference offset.

SETup:IQTuning:REFerence[:MANual][:FREQuency][:SELected]

Function

GSM TA

This command sets/queries the reference offset frequency to be used for the measurement in the active (that is the selected) format.

If your mobile is transmitting all ones you should set this command to -67000, and if your mobile is transmitting all zeros it should be set to +67000.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting | -67000 | +67000 | 0

Query

 -67000 | +67000 | 0
*RST Setting | This command is not affected by *RST.
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETUP:IQTUNING:REFERENCE:MANUAL:FREQUENCY:SELECTED -67000"
! Sets reference frequency for IQ Tuning measurement.

SETup:IQTuning:REFerence[:MANual][:FREQuency]:GSM

Function

GSM TA

This command sets/queries the reference offset frequency to be used for the measurement in the GSM format whether or not that format is active.

This means that if your mobile is transmitting all ones you should set this command to -67000, and if your mobile is transmitting all zeros it should be set to +67000.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting | -67000|+67000|0

Query

 -67000|+67000|0
*RST Setting | This command is not affected by *RST.
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETUP:IQTUNING:REFERENCE:MANUAL:FREQUENCY:GSM +67000"
! Sets reference frequency for IQ Tuning measurement.

SETup:IQTuning:REFerence[:MANual][:FREQuency]:CHARacter:GSM

Function

GSM TA

This command sets/queries the reference offset frequency to be used for the measurement in the GSM format whether or not that format is active.

This means that if your mobile is transmitting all ones, you should set this command to NEG67KHZ, and if your mobile is transmitting all zeros, it should be set to POS67KHZ. Alternatively, you could select AUTO which allows the test set to select the most appropriate offset.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting | NEG67KHZ | ZEROKHZ | POS67KHZ | AUTO

Query

 NEG67KHZ | ZEROKHZ | POS67KHZ | AUTO
*RST Setting | AUTO
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETUP:IQTUNING:REFERENCE:MANUAL:FREQUENCY:CHARACTER:GSM AUTO"
! Sets reference frequency for IQ Tuning measurement (old command).

SETup:IQTuning:SPUR:FREQuency[:SELected]

Function

GSM TA

 This command sets/queries the spur frequency for the I/Q Tuning measurement in the active (that is the selected) format. The units (HZ|KHZ|MHZ) are optional, if no units are specified then the default is HZ.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

Range: -13.0 MHz to -1.0 MHz and +1.0 MHz to +13 MHz

Resolution: 100 Hz

Query

Range: -19 MHz to +19 MHz

Resolution: 100 Hz
*RST Setting

The *RST value of this command depends on the format that is currently active. For example, if the GSM format is currently active, the *RST value for this command is the same value as the equivalent command containing the :GSM format identifier.
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETUP:IQTUNING:SPUR:FREQUENCY:SELECTED 10MHZ"
! Sets spur measurement frequency.

SETup:IQTuning:SPUR:FREQuency:GSM

Function

GSM TA

 This command sets/queries the spur frequency for the I/Q Tuning measurement in the GSM format whether or not that format is active. The units (HZ|KHZ|MHZ) are optional, if no units are specified then the default is HZ.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

Range: -13.0 MHz to -1.0 MHz and +1.0 MHz to +13 MHz

Resolution: 100 Hz

Query

Range: -19 MHz to +19 MHz

Resolution: 100 Hz
*RST Setting 0 MHz
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETUP:IQTUNING:SPUR:FREQUENCY:GSM 10MHZ"
! Sets spur measurement frequency.

SETup:IQTuning:SPUR:STATe[:SELected]

Function

GSM TA

 This command sets/queries the spur state for the I/Q Tuning measurement in the active (that is the selected) format.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting Range: 0 | OFF | 1 | ON

Query

 Range: 0 | 1
*RST Setting

The *RST value of this command depends on the format that is currently active. For example, if the GSM format is currently active, the *RST value for this command is the same value as the equivalent command containing the :GSM format identifier.
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETUP:IQTUNING:SPUR:STATE:SELECTED ON"
! Sets state for spur measurement.

SETup:IQTuning:SPUR:STATe:GSM

Function

GSM TA

 This command sets/queries the spur state for the I/Q Tuning measurement in the GSM format whether or not that format is active.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting | Range: 0 | OFF | 1 | ON

Query

 Range: 0 | 1
*RST Setting | 0 (off)
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETUP:IQTUNING:SPUR:STATE:GSM ON"
! Sets state for spur measurement.

SETup:IQTuning:SPUR[:SFRequency][:SELected]

Function

GSM TA

 This command sets/queries the spur frequency for the I/Q Tuning measurement in the active (that is the selected) format. The units (HZ|KHZ|MHZ) are optional, if no units are specified then the default is HZ. This command sets the spur state to ON.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

Range: -13.0 MHz to -1.0 MHz and +1.0 MHz to +13 MHz

Resolution: 100 Hz

Query

Range: -13.0 MHz to -1.0 MHz and +1.0 MHz to +13 MHz

Resolution: 100 Hz
*RST Setting

The *RST value of this command depends on the format that is currently active. For example, if the GSM format is currently active, the *RST value for this command is the same value as the equivalent command containing the :GSM format identifier.
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETUP:IQTUNING:SPUR:SFREQUENCY:SELECTED 10MHZ"
! Sets frequency value and state for spur measurement.

SETup:IQTuning:SPUR[:SFRequency]:GSM

Function

GSM TA

 This command sets/queries the spur frequency for the I/Q Tuning measurement in the GSM format whether or not that format is active. The units (HZ|KHZ|MHZ) are optional, if no units are specified then the default is HZ. This command sets the spur state to ON.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

Range: -13.0 MHz to -1.0 MHz and +1.0 MHz to +13 MHz

Resolution: 100 Hz

Query

Range: -13.0 MHz to -1.0 MHz and +1.0 MHz to +13 MHz

Resolution: 100 Hz
*RST Setting 0 (off)
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETUP:IQTUNING:SPUR:SFREQUENCY:GSM 10MHZ"
! Sets frequency value and state for spur measurement.

SETup:IQTuning:TIMeout:STATe[:SELected]

Function

GSM TA

 This command sets/queries the timeout state for the I/Q Tuning measurement in the active (that is the selected) format.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting Range: 0 | OFF | 1 | ON

Query

 Range: 0 | 1
*RST Setting

The *RST value of this command depends on the format that is currently active. For example, if the GSM format is currently active, the *RST value for this command is the same value as the equivalent command containing the :GSM format identifier.
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETUP:IQTUNING:TIMEOUT:STATE:SELECTED 25"
! Sets timeout state.

SETup:IQTuning:TIMeout:STATe:GSM

Function

GSM TA

 This command sets/queries the timeout state for the I/Q Tuning measurement in the GSM format whether or not that format is active.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting | Range: 0 | OFF | 1 | ON

Query

 Range: 0 | 1
*RST Setting | 0 (off)
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETUP:IQTUNING:TIMEOUT:STATE:GSM 25"
! Sets timeout state.

SETup:IQTuning:TIMeout[:STIMe][:SELected]

Function

GSM TA

This command sets/queries the I/Q Tuning measurement time-out value in seconds in the active (that is the selected) format. This command sets the time-out state to on.

The units (S|MS) are optional, if no units are specified then the default is S.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

Range: 0.1 to 999 seconds

Resolution: 0.1 seconds

Query

Range: 0.1 to 999 seconds

Resolution: 0.1 seconds
*RST Setting

The *RST value of this command depends on the format that is currently active. For example, if the GSM format is currently active, the *RST value for this command is the same value as the equivalent command containing the :GSM format identifier.
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETUP:IQTUNING:TIMEOUT:STIME:SELECTED 25"
! Sets timeout value and state.

SETup:IQTuning:TIMeout[:STIMe]:GSM

Function

GSM TA

This command sets/queries the I/Q Tuning measurement time-out value in seconds for the GSM format whether or not that format is active. This command sets the timeout state to on.

The units (S|MS) are optional, if no units are specified then the default is S.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

Range: 0.1 to 999 seconds

Resolution: 0.1 seconds

Query

Range: 0.1 to 999 seconds

Resolution: 0.1 seconds
*RST Setting 10 seconds
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETUP:IQTUNING:TIMEOUT:STIME:GSM 25"
! Sets timeout value and state.

SETup:IQTuning:TIMeout:TIMe[:SELected]

Function

GSM TA

This command sets/queries the time-out value in seconds that is used for the I/Q Tuning measurements in the active (that is the selected) format. The timeout state must be on.

The units (S|MS) are optional, if no units are specified then the default is S.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

Range: 0.1 to 999 seconds

Resolution: 0.1 seconds

Query

Range: .1 to 999 seconds

Resolution: .1 seconds
*RST Setting

The *RST value of this command depends on the format that is currently active. For example, if the GSM format is currently active, the *RST value for this command is the same value as the equivalent command containing the :GSM format identifier.
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETUP:IQTUNING:TIMEOUT:TIME:SELECTED 25"
! Sets timeout time value.

SETup:IQTuning:TIMeout:TIMe:GSM

Function

GSM TA

This command sets/queries the time-out value in seconds that is used for the I/Q Tuning measurements in the GSM format whether or not that format is active. The time-out state must be on.

The units (S |MS) are optional, if no units are specified then the default is S.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

Range: 0.1 to 999 seconds

Resolution: 0.1 seconds

Query

Range: .1 to 999 seconds

Resolution: .1 seconds
*RST Setting 10 seconds
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETUP:IQTUNING:TIMEOUT:TIME:GSM 25"
! Sets timeout time value.

SETup:IQTuning:TRIGger:DELay[:SELected]

Function

GSM TA

This command sets/queries the trigger delay time in seconds for an I/Q Tuning measurement in the active (that is the selected) format.

The units (S|MS|US|NS) are optional, if no units are specified then the default is S.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

Range: -2.31 ms to +2.31 ms

Resolution: 5 significant digits or 100 ns, whichever is greater

Query

Range: -2.31 ms to +2.31 ms

Resolution: 5 significant digits or 100 ns, whichever is greater
*RST Setting

The *RST value of this command depends on the format that is currently active. For example, if the GSM format is currently active, the *RST value for this command is the same value as the equivalent command containing the :GSM format identifier.
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETUP:IQTUNING:TRIGGER:DELAY:SELECTED 1.1MS"
! Sets trigger delay time.

SETup:IQTuning:TRIGger:DELay:GSM

Function

GSM TA

This command sets/queries the trigger delay time in seconds for an I/Q Tuning measurement in the GSM format whether or not that format is active.

The units (S | MS | US | NS) are optional, if no units are specified then the default is S.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

Range: -2.31 ms to +2.31 ms

Resolution: 5 significant digits or 100 ns, whichever is greater

Query

Range: -2.31 ms to +2.31 ms

Resolution: 5 significant digits or 100 ns, whichever is greater
*RST Setting zero seconds
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETUP:IQTUNING:TRIGGER:DELAY:GSM 1.1MS"
! Sets trigger delay time.

SETup:IQTuning:TRIGger:SOURce[:SELected]

Function

GSM TA

 This command sets/queries the trigger source for an I/Q Tuning measurement in the active (that is the selected) format.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

RISE | IMMediate

See Triggering of Measurements .

Query

 RISE | IMM
*RST Setting

The *RST value of this command depends on the format that is currently active. For example, if the GSM format is currently active, the *RST value for this command is the same value as the equivalent command containing the :GSM format identifier.
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETUP:IQTUNING:TRIGGER:SOURCE:SELECTED IMMEDIATE"
! Sets trigger delay source.

SETup:IQTuning:TRIGger:SOURce:GSM

Function

GSM TA

 This command sets/queries the trigger source for an I/Q Tuning measurement in the GSM format whether or not that format is active.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

RISE | IMMediate

See Triggering of Measurements .

Query

 RISE | IMM
*RST Setting RISE
Requirements GSM/GPRS/
EGPRS TA

Revision: A.01 and above
GSM/GPRS/ EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETUP:IQTUNING:TRIGGER:SOURCE:GSM IMMEDIATE"
! Sets trigger delay source.


SETup:MTAudio

SETup:MTAudio

GPIB Command Conventions

  • SETup:MTAudio:ANALyzer:FREQuency:ALL[:SVALue]
  • SETup:MTAudio:ANALyzer:FREQuency:ALL:GENerator
  • SETup:MTAUDio:COUNt[:SNUMber]
  • SETup:MTAUDio:COUNt:NUMBer
  • SETup:MTAUDio:COUNt:STATe
  • SETup:MTAudio:CONTinuous
  • SETup:MTAudio:GENerator:FREQuency:ALL[:SVALue]
  • SETup:MTAudio:GENerator:FREQuency:PRESet
  • SETup:MTAudio:GENerator:LEVel:DOWNlink:ALL[:SAMPlitude]
  • SETup:MTAudio:GENerator:LEVel:DOWNlink:ALL:TOTal[:SAMPlitude]
  • SETup:MTAudio:GENerator:LEVel:DOWNlink:ALL:TOTal:STATe
  • SETup:MTAudio:GENerator:LEVel:UPLink:ALL[:SAMPlitude]
  • SETup:MTAudio:GENerator:LEVel:UPLink:ALL:TOTal[:SAMPlitude]
  • SETup:MTAudio:GENerator:LEVel:UPLink:ALL:TOTal:STATe
  • SETup:MTAudio:LEVel:ALL:LIMit:UPPer
  • SETup:MTAudio:LEVel:ALL:LIMit:LOWer
  • SETup:MTAudio:MEASurement:MODE
  • SETup:MTAudio:PEAK:VOLTage
  • SETup:MTAudio:REFerence:ABSolute:LEVel:DOWNlink
  • SETup:MTAudio:REFerence:ABSolute:LEVel:UPLink
  • SETup:MTAudio:REFerence:MODE
  • SETup:MTAudio:REFerence:RELative:TONE
  • SETup:MTAudio:SDIStortion:STATe
  • SETup:MTAudio:SETTling[:TIME]
  • SETup:MTAudio:TIMeout:STATe
  • SETup:MTAudio:TIMeout[:STIMe]
  • SETup:MTAudio:TIMeout:TIME

SETup:MTAudio:ANALyzer:FREQuency:ALL[:SVALue]

Function

GSM TA

 Selects/queries the audio analyzer frequency for all 20 tones. Also turns the state to ON for all 20 tones. A value must be entered for each of the 20 tones to avoid receiving an error from the test set.
GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

Range: 10 to 4000 Hz and -1 (turns a tone off)
Resolution: 10 Hz

Query

Range: 10 to 4000 Hz and -1 (tone is turned off)
Resolution: 10 Hz

*RST setting

 140 Hz increments starting at 300 Hz for the first tone

Requirements

GSM/GPRS/
EGPRS TA

Revision: A.02 and above

GSM/GPRS/
EGPRS LA

Revision: C.02 and above

Programming Example

OUTPUT 714;"SETup:MTAudio:ANALyzer:FREQuency:ALL 350, 400, 450, 500, 550, 600,
650, 700, 750, 800, 850, 900, 950, 1000, 1050, 1100, 1150, 1200, 1250, 1300"
! Specifies a frequency value for each of the 20 available audio tones and turns
! their states to ON.

SETup:MTAudio:ANALyzer:FREQuency:ALL:GENerator

Function

GSM TA

 Links the frequency and state of each analyzer tone to the corresponding value specified for the generator.
GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

Range:

  • Link frequency values and states = 1 | ON
  • Unlink frequency values and states = 0 | OFF

Query

 Range: 0 | 1

*RST setting

 1 | ON

Requirements

GSM/GPRS/
EGPRS TA

Revision: A.02 and above

GSM/GPRS/
EGPRS LA

Revision: C.02 and above

Programming Example

OUTPUT 714;"SETup:MTAudio:ANALyzer:FREQuency:ALL:GENerator OFF"
! Removes coupling between generator and analyzer frequency values and states.

SETup:MTAUDio:COUNt[:SNUMber]

Function

GSM TA

 Selects the number of Multi-tone Audio multi-measurements the test set will make and sets the count state to ON.
GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

Range: 1 to 999
Resolution: 1

Query

Range: 1 to 999
Resolution: 1
*RST setting 10

Requirements

GSM/GPRS/
EGPRS TA

Revision: A.02 and above

GSM/GPRS/
EGPRS LA

Revision: C.02 and above

Programming Example

OUTPUT 714;"SETUP:MTAUDIO:COUNT 5"
! Sets the value to 5 and the state to on.

SETup:MTAUDio:COUNt:NUMBer

Function

GSM TA

 Selects/queries the number of Multi-tone Audio measurements the test set will make when the SETup:MTAUDio:COUNt:STATe is ON.
GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

Range: 1 to 999
Resolution: 1

Query

Range: 1 to 999
Resolution: 1

*RST setting

 10

Requirements

GSM/GPRS/
EGPRS TA

Revision: A.02 and above

GSM/GPRS/
EGPRS LA

Revision: C.02 and above

Programming Example

OUTPUT 714;"SETUP:MTAUDIO:COUNT:NUMBER 10"
! Sets the audio multi-measurement count number to 10.

SETup:MTAUDio:COUNt:STATe

Function

GSM TA

 Selects/queries the Multi-tone Audio multi-measurement count state.
GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting Range: 1 | ON | 0 | OFF

Query

 Range: 1 | 0

*RST setting

 0 | OFF

Requirements

GSM/GPRS/
EGPRS TA

Revision: A.02 and above

GSM/GPRS/
EGPRS LA

Revision: C.02 and above

Programming Example

OUTPUT 714;"SETUP:MTAUDIO:COUNT:STATE ON"
! Turns the multi-tone audio measurement multi-measurement count state on.

SETup:MTAudio:CONTinuous

Function

GSM TA

 Selects/queries the trigger arm state for Multi-Tone Audio measurements.
GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

Range:

  • Continuous trigger arm mode = 1 | ON
  • Single trigger arm mode = 0 | OFF

Query

 Range: 0 | 1

*RST setting

 Single | 0 | OFF

Requirements

GSM/GPRS/
EGPRS TA

Revision: A.02 and above

GSM/GPRS/
EGPRS LA

Revision: C.02 and above

Programming Example

OUTPUT 714;"SETup:MTAudio:CONTinuous OFF"
! Selects single trigger mode.

SETup:MTAudio:GENerator:FREQuency:ALL[:SVALue]

Function

GSM TA

 Selects/queries the audio generator frequency for all 20 tones. Also turns the state to ON for all 20 tones. A value must be entered for each of the 20 tones to avoid receiving an error from the test set.
GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

Range: 10 to 4000 Hz and -1 (turns a tone off)
Resolution: 10 Hz

Query

Range: 10 to 4000 Hz and -1 (tone is turned off)
Resolution: 10 Hz

*RST setting

 140 Hz increments starting at 300 Hz for the first tone

Requirements

GSM/GPRS/
EGPRS TA

Revision: A.02 and above

GSM/GPRS/
EGPRS LA

Revision: C.02 and above

Programming Example

OUTPUT 714;"SETup:MTAudio:GENerator:FREQuency:ALL 350, 400, 450, 500, 550, 600,
650, 700, 750, 800, 850, 900, 950, 1000, 1050, 1100, 1150, 1200, 1250, 1300"
! Specifies a frequency value for each of the 20 available audio tones and turns
! their states to ON.

SETup:MTAudio:GENerator:FREQuency:PRESet

Function

GSM TA

 Selects/queries all the audio tone generator frequencies for the preset selected.
GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

NONE: no preset state or generator freqency settings do not match one of the preset states
MTA140: sets the first tone to 300 Hz and all others at increments of 140 Hz
MTA100: sets the first tone to 300 Hz and all others at increments of 100 Hz
SIN300: sets the first tone to 300 Hz and turns all others off
SIN1000: sets the first tone to 1 kHz and turns all others off
SIN3000: sets the first tone to 3 kHz and turns all others off
AOFF: turns all tones off

Query

 NONE | MTA140 | MTA100 | SIN300 | SIN1000 | SIN3000 | AOFF

*RST setting

 NONE

Requirements

GSM/GPRS/
EGPRS TA

Revision: A.02 and above

GSM/GPRS/
EGPRS LA

Revision: C.02 and above

Programming Example

OUTPUT 714;"SETup:MTAudio:GENerator:FREQuency:PRESet MTA140"

SETup:MTAudio:GENerator:LEVel:DOWNlink:ALL[:SAMPlitude]

Function

GSM TA

 Selects/queries the audio generator downlink level for all 20 tones. Also turns the state to ON for all 20 tones. A value must be entered for each of the 20 tones to avoid receiving an error from the test set.
NOTE: The total % for all 20 tones can not exceed 70%.
GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

Range: 0 to 70 % and -1 (turns a tone off)
Resolution: 0.1%

Query

Range: 0 to 70 % and -1 (tone is turned off)
Resolution: 0.1%

*RST setting

 2.2%

Requirements

GSM/GPRS/
EGPRS TA

Revision: A.02 and above

GSM/GPRS/
EGPRS LA

Revision: C.02 and above

Programming Example

OUTPUT 714;"SETup:MTAudio:GENerator:LEVel:DOWNlink:ALL 2.2, 2.2, 2.2, 2.2, 3.5,
4, 2, 4.5, 3.2, 3.3, 2.2, 5, 2.1, 2.1, 1.5, 1, 1, 1, 1, 1"
! Specifies a audio generator downlink level value for each of the 20
! available audio tones and turns their states to ON.

SETup:MTAudio:GENerator:LEVel:DOWNlink:ALL:TOTal[:SAMPlitude]

Function

GSM TA

 Sets/queries the multi-tone audio total level for the downlink generator and sets the state to ON. The level you specify for the total is distributed between all tones whose state is on. For example, if you specify the total to be 15% and all 20 tones are active, 3.4% is assigned to each tone.
GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

Range: 0 to 70 %
Resolution: 1%

Query

Range: 0 to 70 %
Resolution: 1%

*RST setting

 10%

Requirements

GSM/GPRS/
EGPRS TA

Revision: A.02 and above

GSM/GPRS/
EGPRS LA

Revision: C.02 and above

Programming Example

OUTPUT 714;"SETup:MTAudio:GENerator:LEVel:DOWNlink:ALL:TOTal 55"
! Specifies a audio generator downlink level total to be distributed among
! all levels whose state is on.

SETup:MTAudio:GENerator:LEVel:DOWNlink:ALL:TOTal:STATe

Function

GSM TA

 Sets/queries the multitone audio total level state for the generator downlink.
GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

0|OFF|1|ON

Query

 0|1

*RST setting

 1|ON

Requirements

GSM/GPRS/
EGPRS TA

Revision: A.02 and above

GSM/GPRS/
EGPRS LA

Revision: C.02 and above

Programming Example

OUTPUT 714;"SETup:MTAudio:GENerator:LEVel:DOWNlink:ALL:TOTal:STATe OFF"
! Turns the multitone audio total level for the generator downlink off.

SETup:MTAudio:GENerator:LEVel:UPLink:ALL[:SAMPlitude]

Function

GSM TA

 Selects/queries the audio generator uplink level for all 20 tones. Also turns the state to ON for all 20 tones. A value must be entered for each of the 20 tones to avoid receiving an error from the test set.
NOTE: The total value for all 20 tones can not exceed 5 V RMS.
GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

Range: 0 to 5 V RMS and -1 (turns a tone off)
Resolution: 0.1 mV

Query

Range: 0 to 5 V RMS and -1 (turns a tone off)
Resolution: 0.1 mV

*RST setting

 80 mV

Requirements

GSM/GPRS/
EGPRS TA

Revision: A.02 and above

GSM/GPRS/
EGPRS LA

Revision: C.02 and above

Programming Example

OUTPUT 714;"SETup:MTAudio:GENerator:LEVel:UPLink:ALL 50, 60, 70, 80, 80, 80,
80, 80, 70, 70, 70, 60, 60, 50, 50, 50, 50, 50, 50, 50"
! Specifies a audio generator uplink level value for each of the 20 available
! audio tones and turns their states to ON.

SETup:MTAudio:GENerator:LEVel:UPLink:ALL:TOTal[:SAMPlitude]

Function

GSM TA

 Sets/queries the multi-tone audio total level for the uplink generator and sets the state to ON. The level you specify for the total is distributed between all tones whose state is on. For example, if you specify the total to be 1 V and all 20 tones are active, 224 mV is assigned to each tone.
GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

Range: 0 to 5 V RMS
Resolution: 0.1 mV

Query

Range: 0 to 5 V RMS
Resolution: 0.1 mV

*RST setting

 360 mV

Requirements

GSM/GPRS/
EGPRS TA

Revision: A.02 and above

GSM/GPRS/
EGPRS LA

Revision: C.02 and above

Programming Example

OUTPUT 714;"SETup:MTAudio:GENerator:LEVel:UPLink:ALL:TOTal 55"
! Specifies a audio generator uplink level total to be distributed among
! all levels whose state is on.

SETup:MTAudio:GENerator:LEVel:UPLink:ALL:TOTal:STATe

Function

GSM TA

 Sets/queries the multitone audio total level state for the generator uplink.
GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

0|OFF|1|ON

Query

 0|1

*RST setting

 1|ON

Requirements

GSM/GPRS/
EGPRS TA

Revision: A.02 and above

GSM/GPRS/
EGPRS LA

Revision: C.02 and above

Programming Example

OUTPUT 714;"SETup:MTAudio:GENerator:LEVel:UPLink:ALL:TOTal:STATe OFF"
! Turns the multitone audio total level for the generator uplink off.

SETup:MTAudio:LEVel:ALL:LIMit:UPPer

Function

GSM TA

 Sets/queries the audio tone mask level upper limits for all 20 tones. A value must be entered for each of the 20 tones to avoid receiving an error from the test set.
GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

Range: 100 to -100 dB
Resolution: 1 dB

Query

Range: 100 to -100 dB
Resolution: 1 dB

*RST setting

 100 dB

Requirements

GSM/GPRS/
EGPRS TA

Revision: A.02 and above

GSM/GPRS/
EGPRS LA

Revision: C.02 and above

Programming Example

OUTPUT 714;"SETup:MTAudio:LEVel:ALL:LIMit:UPPer
25,25,25,50,50,50,75,75,75,100,100,100,100,100,75,75,75,50,50,50"
! Sets the audio tone mask level upper limits for all 20 tones.

SETup:MTAudio:LEVel:ALL:LIMit:LOWer

Function

GSM TA

 Sets/queries the audio tone mask level lower limits for all 20 tones. A value must be entered for each of the 20 tones to avoid receiving an error from the test set.
GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

Range: 100 to -100 dB
Resolution: 1 dB

Query

Range: 100 to -100 dB
Resolution: 1 dB

*RST setting

 -100 dB

Requirements

GSM/GPRS/
EGPRS TA

Revision: A.02 and above

GSM/GPRS/
EGPRS LA

Revision: C.02 and above

Programming Example

OUTPUT 714;"SETup:MTAudio:LEVel:ALL:LIMit:LOWer -25,-25,-25,-50,-50,-50,-75,-75,-75,-100,-100,-100,-100,-100,-75,-75,-75,-50,-50,-50"
! Sets the audio tone mask level lower limits for all 20 tones.

SETup:MTAudio:MEASurement:MODE

Function

GSM TA

 Sets/queries the mode to be used for the multi-tone audio measurement.
GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting UPLink | DOWNlink | ECHO

Query

 UPL | DOWN | ECHO

*RST setting

 DOWNlink

Requirements

GSM/GPRS/
EGPRS TA

Revision: A.02 and above

GSM/GPRS/
EGPRS LA

Revision: C.02 and above

Programming Example

OUTPUT 714;"SETup:MTAudio:MEASurement:MODE UPL"
! Sets the measurement mode to uplink audio.

SETup:MTAudio:PEAK:VOLTage

Function

GSM TA

 Sets/queries the expected peak voltage (clipping level) of the multi-tone audio signal to be measured. The units (V|MV|UV) are optional, if no units are specified then units default to V.
GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting Range: 1 mV to 20 V
Resolution: 1 mV

Query

 Range: 1 mV to 20 V
Resolution: 1 mV

*RST setting

 1 V

Requirements

GSM/GPRS/
EGPRS TA

Revision: A.02 and above

GSM/GPRS/
EGPRS LA

Revision: C.02 and above

Programming Example

OUTPUT 714;"SETup:MTAudio:PEAK:VOLTage 5V"
! Sets the expected peak voltage to 5 volts.

SETup:MTAudio:REFerence:ABSolute:LEVel:DOWNlink

Function

GSM TA

 Sets/queries the Analyzer Downlink Reference Level parameter, which is used when making absolute measurements on the downlink. The reference must be set to absolute (see SETup:MTAudio:REFerence:MODE ) and the measurement mode must be downlink (see SETup:MTAudio:MEASurement:MODE ) for this setting to be used.
GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting Range: 1 mV to 5 V RMS
Resolution: 0.1 mV

Query

 Range: 1 mV to 5 V RMS
Resolution: 0.1 mV
Setting Range: 0 to 100 %
Resolution: 0.1 %

Query

 Range: 0 to 100 %
Resolution: 0.1 %

*RST setting

 1V

Requirements

GSM/GPRS/
EGPRS TA

Revision: A.02 and above

GSM/GPRS/
EGPRS LA

Revision: C.02 and above

Programming Example

OUTPUT 714;"SETup:MTAudio:REFerence:ABSolute:LEVel:DOWNlink 3.5"
! Sets the reference level for downlink absolute measurements to 3.5 volts RMS.

SETup:MTAudio:REFerence:ABSolute:LEVel:UPLink

Function

GSM TA

 Sets/queries the Analyzer Uplink Reference Level parameter, which is used when making absolute measurements on the uplink. The reference must be set to absolute (see SETup:MTAudio:REFerence:MODE ) and the measurement mode must be uplink (see SETup:MTAudio:MEASurement:MODE ) for this setting to be used.
GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting Range: 0 to 100 %
Resolution: 0.1 %

Query

 Range: 0 to 100 %
Resolution: 0.1 %

*RST setting

 10 %

Requirements

GSM/GPRS/
EGPRS TA

Revision: A.02 and above

GSM/GPRS/
EGPRS LA

Revision: C.02 and above

Programming Example

OUTPUT 714;"SETup:MTAudio:REFerence:ABSolute:LEVel:UPLink 5"
! Sets the reference level for uplink absolute measurements to 5 percent.

SETup:MTAudio:REFerence:MODE

Function

GSM TA

 Sets/queries the Analyzer 0dB Reference Mode used for multi-tone audio level measurements to relative or absolute.
GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting ABSolute | RELative

Query

 ABS | REL

*RST setting

 ABSolute

Requirements

GSM/GPRS/
EGPRS TA

Revision: A.02 and above

GSM/GPRS/
EGPRS LA

Revision: C.02 and above

Programming Example

OUTPUT 714;"SETup:MTAudio:REFerence:MODE RELative"
! Sets the reference mode to relative.

SETup:MTAudio:REFerence:RELative:TONE

Function

GSM TA

 Sets/queries the audio tone to be used as the reference when making multi-tone audio level measurements in relative reference mode. The reference must be set to relative (see SETup:MTAudio:REFerence:MODE ) for this setting to be used.
GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting Range: 1 to 20
Resolution: 1

Query

 Range: 1 to 20
Resolution: 1

*RST setting

 6

Requirements

GSM/GPRS/
EGPRS TA

Revision: A.02 and above

GSM/GPRS/
EGPRS LA

Revision: C.02 and above

Programming Example

OUTPUT 714;"SETup:MTAudio:REFerence:RELative:TONE 3"
! Sets the reference audio tone for relative measurements to the third tone.

SETup:MTAudio:SDIStortion:STATe

Function

GSM TA

 Sets/queries the state of the SINAD/Distortion measurement. Audio level, SINAD, and distortion results are available when the state is ON. These measurement results are not available or displayed when the state is OFF.
GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting 0 | OFF | 1 | ON

Query

 0 | 1

*RST setting

 0 (OFF)

Requirements

GSM/GPRS/
EGPRS TA

Revision: A.02 and above

GSM/GPRS/
EGPRS LA

Revision: C.02 and above

Programming Example

OUTPUT 714;"SETup:MTAudio:SDIStortion 1"
! Turns audio level, SINAD, and distortion measurements on.

SETup:MTAudio:SETTling[:TIME]

Function

GSM TA

 Sets/queries the amount of time the multi-tone audio measurement waits before starting the measurement after setting the level and frequency.
GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting Range: 0 to 1 s
Resolution: 10 ms

Query

 Range: 0 to 1 s
Resolution: 10 ms

*RST setting

 0 ms

Requirements

GSM/GPRS/
EGPRS TA

Revision: A.02 and above

GSM/GPRS/
EGPRS LA

Revision: C.02 and above

Programming Example

OUTPUT 714;"SETup:MTAudio:SETTling 60ms"
! Sets the settling time to 60 milliseconds

SETup:MTAudio:TIMeout:STATe

Function

GSM TA

 Sets/queries the multi-tone audio measurement timeout state.
GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting 0 | OFF | 1 | ON

Query

 0 | 1

*RST setting

 0 (OFF)

Requirements

GSM/GPRS/
EGPRS TA

Revision: A.02 and above

GSM/GPRS/
EGPRS LA

Revision: C.02 and above

Programming Example

OUTPUT 714;"SETup:MTAudio:TIMeout:STATe 1"
! Turns measurment timeout on for the multi-tone audio measurement.

SETup:MTAudio:TIMeout[:STIMe]

Function

GSM TA

 Sets/queries the multi-tone audio measurement timeout value in seconds and sets the timeout state to ON.
GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting Range: 0.1 to 999 seconds
Resolution: 0.1 seconds

Query

 Range: 0.1 to 999 seconds
Resolution: 0.1 seconds

*RST setting

 10 seconds

Requirements

GSM/GPRS/
EGPRS TA

Revision: A.02 and above

GSM/GPRS/
EGPRS LA

Revision: C.02 and above

Programming Example

OUTPUT 714;"SETup:MTAudio:TIMeout 2"
! Sets the measurement timeout to 2 seconds and turns measurment timeout on
! for the multi-tone audio measurement.

SETup:MTAudio:TIMeout:TIME

Function

GSM TA

 Sets/queries the multi-tone audio measurement timeout value in seconds.
GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting Range: 0.1 to 999 seconds
Resolution: 0.1 seconds

Query

 Range: 0.1 to 999 seconds
Resolution: 0.1 seconds

*RST setting

 10 seconds

Requirements

GSM/GPRS/
EGPRS TA

Revision: A.02 and above

GSM/GPRS/
EGPRS LA

Revision: C.02 and above

Programming Example

OUTPUT 714;"SETup:MTAudio:TIMeout:TIME 2"
! Sets the measurement timeout to 2 seconds for the multi-tone audio measurement.


SETup:ORFSpectrum

SETup:ORFSpectrum

GPIB Command Conventions

  • SETup:ORFSpectrum:AUTO:FILTer:TYPE?
  • SETup:ORFSpecturm:CONTinuous
  • SETup:ORFSpectrum:COUNt:STATe
  • SETup:ORFSpectrum:FAST
  • SETup:ORFSpectrum:FILTer:TYPE
  • SETup:ORFSpectrum:ICOunt:MAXimum?
  • SETup:ORFSpectrum:LIMit:SOURce
  • SETup:ORFSpectrum:MODulation:ABSolute:LIMit:CUSTom<[1]|2>
  • SETup:ORFSpectrum:MODulation:ABSolute:LIMit:CUSTom<[1] |2>:POINts?
  • SETup:ORFSpectrum:MODulation:COUNt[:SNUMber]
  • SETup:ORFSpectrum:MODulation:COUNt:NUMBer
  • SETup:ORFSpectrum:MODulation:FREQuency[:OFFSet]
  • SETup:ORFSpectrum:MODulation:FREQuency:OFFSet:ALL
  • SETup:ORFSpectrum:MODulation:FREQuency:POINts?
  • SETup:ORFSpectrum:MODulation:LIMit:MANual<[1]|2>[:SELected]
  • SETup:ORFSpectrum:MODulation:RELative:LIMit:CUSTom<[1]|2>
  • SETup:ORFSpectrum:MODulation:RELative:LIMit:CUSTOM<[1]|2>:POINts?
  • SETup:ORFSpectrum:SWITching:COUNt[:SNUMber]
  • SETup:ORFSpectrum:SWITching:COUNt:NUMBer
  • SETup:ORFSpectrum:SWITching:FREQuency[:OFFSet]
  • SETup:ORFSpectrum:SWITching:FREQuency:OFFSet:ALL
  • SETup:ORFSpectrum:SWITching:FREQuency:POINts?
  • SETup:ORFSpectrum:SWITching:LIMit:CUSTom
  • SETup:ORFSpectrum:SWITching:LIMit:CUSTom:POINts?
  • SETup:ORFSpectrum:SWITching:LIMit:MANual[:SELected]
  • SETup:ORFSpectrum:SWITching:TIME:DOMain:STATe
  • SETup:ORFSpectrum:SWITching:TIME:DOMain:FREQuency:OFFSet:INDex
  • SETup:ORFSpectrum:TIMeout:TIME
  • SETup:ORFSpectrum:TIMeout[:STIMe]
  • SETup:ORFSpectrum:TIMeout:STATe
  • SETup:ORFSpectrum:TRIGer:DELay
  • SETup:ORFSpectrum:TRIGger:SOURce

SETup:ORFSpectrum:AUTO:FILTer:TYPE?

Function

GSM TA

Queries the test set to determine the fastest measurement filter type based on the currently installed hardware and test set configuration. The possible measurement filter types are ANALog and DIGital . See Output RF Spectrum Measurement Description for more information regarding the measurement filter type and other information on the ORFS measurement.The result of this query is the type of measurement filter the test set uses if the measurement filter type is set to AUTO .

The command to set the measurement filter type is SETup:ORFSpectrum:FILTer:TYPE .

For more information on how the hardware affects the measurement filter type, see:

http://www.agilent.com/find/8960upgrades

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

Range: ANALog|DIGital

Query

Range: ANALog|DIGital
*RST Setting ANAL
Requirements

GSM/GPRS/
EGPRS TA

Revision: A.06 and above

GSM/GPRS/ EGPRS LA

 Revision: D.03 and above

Programming Example

OUTPUT 714;"SETup:ORFSpectrum:AUTO:FILTer:TYPe?"
! Queries the ORFS modulation measurement filter type that would give the fastest measurement results.

SETup:ORFSpecturm:CONTinuous

Function

GSM TA

This command selects/queries the trigger state for output RF spectrum measurements.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

Range:

  • Continuous trigger mode = 1 | ON
  • Single trigger mode = 0 | OFF

Query

Range: 1 | 0
*RST Setting 1 | ON
Requirements

GSM/GPRS/
EGPRS TA

Revision: A.02 and above

GSM/GPRS/
EGPRS LA

Revision: C.02 and above

Programming Example

OUTPUT 714;"ABORT:ALL"
! Aborts all active measurements in progress.

OUTPUT 714;"SETUP:CONTINUOUS OFF"
! Sets trigger mode to single for an ORFS measurement.

SETup:ORFSpectrum:COUNt:STATe

Function

GSM TA

This command selects/queries the ORFS due to switching and modulation multi-measurement count state.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

Range: 0 | OFF | 1 | ON

Query

Range: 0 | 1
*RST Setting 1 | ON
Requirements

GSM/GPRS/
EGPRS TA

Revision: A.02 and above

GSM/GPRS/
EGPRS LA

Revision: C.02 and above

Programming Example

OUTPUT 714;"SETUP:ORFSPECTRUM:COUNT:STATE ON"
! Sets count state for both ORFS due to switching and modulation measurements.

SETup:ORFSpectrum:FAST

Function

GSM TA

This command sets/queries the fast measurement state, which determines whether or not the ORFS due to modulation measurement is performed exactly as defined in the ETSI standards.

When set to On, the measurement is performed on both the front and back sections of the burst. With this setting, the test set can provide two modulation measurements per burst, effectively doubling measurement throughput.

When set to Off, the measurement is only performed on the latter section of the burst as defined in the ETSI GSM standards.

When the ORFS measurement filter type ( SETup:ORFSpectrum:FILTer:TYPE ) is set to DIGital the measurement ignores the fast measurement state if the expected power for the selected burst is lower than the expected power of the burst that is immediately before it.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

Range: 0 | OFF | 1 | ON

Query

Range: 0 | 1
*RST Setting 1 | ON
Requirements

GSM/GPRS/
EGPRS TA

Revision: A.03 and above

GSM/GPRS/
EGPRS LA

Revision: C.03 and above

Programming Example

OUTPUT 714;"SETUP:ORFSPECTRUM:FAST OFF"
! Sets the ORFS modulation measurement to be performed exactly as defined in the ETSI standards.

SETup:ORFSpectrum:FILTer:TYPE

Function

GSM TA

Sets/Queries the filter type. The possible measurement filter options are Analog, Digital, and AUTO.

The analog and digital measurement filter types each include ORFS due to modulation and ORFS due to switching. When set to AUTO, the test set automatically selects the filter type that will result in the fastest measurement speed based on the test set's hardware specification and the current test set configuration. The filter type chosen by the test set can be queried using the command SETup:ORFSpectrum:AUTO:FILTer:TYPE? . See also Output RF Spectrum Measurement Description for more information regarding the measurement filter type and other information on the ORFS measurement.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

Range: ANALog|AUTO|DIGital

Query

Range: ANALog|AUTO|DIGital
*RST Setting ANAL
Requirements

GSM/GPRS/
EGPRS TA

Revision: A.06 and above

GSM/GPRS/ EGPRS LA

 Revision: D.03 and above

Programming Example

OUTPUT 714;"SETup:ORFSpectrum:FILTer:TYPe AUTO"
! Allows the test set to determine which measurement type was the fastest.
! The measurement filter type that is used is what the test set returns from the query
! SETup:ORFSpectrum:AUTO:FILTer:TYPE?

SETup:ORFSpectrum:ICOunt:MAXimum?

Function

GSM TA

This command queries the total number of measurements made each time an ORFS measurement is initiated. This number will vary depending on the number of offsets and number of multi-measurements that you choose.

The total number of measurements is calculated using the following formula:

ICO MAX = 1 + M + S

  • Where:

    • M= ( the number of modulation offsets ) ¥ ( the number of multi-measurements for ORFS due to modulation ).

    • S= ( the number of switching offsets ) ¥ ( the number of multi-measurements for ORFS due to switching ).

See Output RF Spectrum Measurement Description for a description of modulation and switching offsets.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Range: 1 to 30970

Resolution: 1
Requirements

GSM/GPRS/
EGPRS TA

Revision: A.01 and above

GSM/GPRS/
EGPRS LA

Revision: C.01 and above

SETup:ORFSpectrum:LIMit:SOURce

Function

GSM TA

This command selects whether the ORFS measurement uses the ETSI defined limits, or user-defined limits you have specified using the MANual or CUSTom commands.

This command is implemented in the active (that is the selected) format.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

Range: ETSI | MANual[1] | MANual2|CUSTom[1]| CUSTom2|NOMask

Query

Range: ETSI | MAN | MAN2|CUST| CUST2|NOMask
*RST Setting ETSI
Requirements

GSM/GPRS/
EGPRS TA

Revision: A.01 and above

GSM/GPRS/
EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714"SETUP:ORFSPECTRUM:LIMIT:SOURCE MAN"
! Allows you to manually set the limits.

SETup:ORFSpectrum:MODulation:ABSolute:LIMit:CUSTom<[1]|2>

Function

GSM TA

This command sets/queries the absolute limits for the specified custom mask to be used with the ORFS Modulation measurement. Custom limit testing differs from Manual limit testing because a limit mask is defined separately from the frequency offset. When a frequency offset is changed, the limit value is recalculated for the new frequency offset by interpolating the Custom Mask.

A total of 32 reference points (frequency point / limit value mask point pairs) are available to you when defining a custom mask. Frequency Offsets that fall outside the Custom Mask will always return a PASS result. The custom mask is turned off when no points are specified in this command.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

Range:
0 to 32 comma-separated value pairs containing frequency point and limit value within the following ranges:

  • Frequency: -1800Hz to -10Hz and +10Hz to +1800kHz
  • Limit Value: -200dBm to +100dBm

Resolution:

  • Frequency: 10 Hz
  • Limit Value: 0.1 dB

Query

Range:
0 to 32 comma-separated value pairs containing frequency point and limit value within the following ranges:

  • Frequency: -1800Hz to -10Hz, +10Hz to +1800kHz, and 9.91E+37 (NAN) if no offsets are specified.
  • Limit Value: -200dBm to +100dBm

Resolution:

  • Frequency: 10 Hz
  • Limit Value: 0.1 dB
*RST Setting No Mask
Requirements

GSM/GPRS/
EGPRS TA

Revision: A.03 and above

GSM/GPRS/
EGPRS LA

Revision: C.03 and above

SETup:ORFSpectrum:MODulation:ABSolute:LIMit:CUSTom<[1] |2>:POINts?

Function | GSM TA | This query returns the number of enabled reference points for the ORFS Modulation Absolute custom mask you specify.
 | GPRS TA
 | EGPRS TA
 | GSM/GPRS LA
 | EGPRS LA
Query |  | Range: 0 to 32 Resolution: 1
*RST Setting |  | 0
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.03 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.03 and above

SETup:ORFSpectrum:MODulation:COUNt[:SNUMber]

Function

GSM TA

This command sets/queries the number of ORFS due to modulation multi-measurements the test set will make. This command sets the count state to ON.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

Range: 1 to 999

Resolution: 1

Query

Range: 1 to 999

Resolution: 1
*RST Setting

20
Requirements

GSM/GPRS/
EGPRS TA

Revision: A.01 and above

GSM/GPRS/
EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714"SETUP:ORFSPECTRUM:MODULATION:COUNT:SNUMBER 99"
! Sets the value to 99 multi-measurements and the state to on.

SETup:ORFSpectrum:MODulation:COUNt:NUMBer

Function

GSM TA

 This command sets/queries the number of ORFS due to modulation multi-measurements the test set will make when the multi-measurement count state is on. See Output RF Spectrum Measurement Description .

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

Range: 1 to 999

Resolution: 1

Query

Range: 1 to 999

Resolution: 1
*RST Setting 20
Requirements

GSM/GPRS/
EGPRS TA

Revision: A.01 and above

GSM/GPRS/
EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETUP:ORFSPECTRUM:MODULATION:COUNT:NUMBER 75"
! Sets the multi-measurement count number for ORFS due to modulation measurements to 75.

SETup:ORFSpectrum:MODulation:FREQuency[:OFFSet]

Function

GSM TA

 This command sets/queries the list of ORFS due to modulation frequency offsets. Each offset listed in the command is turned on by default. If no frequency offsets (null list) are sent, the output RF spectrum due to modulation measurement will not be made. The units (GHZ|MHZ|KHZ|HZ) are optional, if no units are specified than units default to HZ. see Output RF Spectrum Measurement Description .

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

Range: 0 to 22 comma-separated values ranging from -1.8 MHz to -10 Hz, and +10 Hz to +1.8 MHz

Resolution: 10 Hz

Query

Range: 0 to 22 comma-separated values ranging from -1.8 MHz to -10 Hz, and +10 Hz to +1.8 MHz

Resolution: 10 Hz
*RST Setting

Offset 1: 400.0 kHz

Offset 2: 600.0 kHz

Offsets 3 to 22: off
Requirements

GSM/GPRS/
EGPRS TA

Revision: A.01 and above

GSM/GPRS/
EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETUP:ORFSPECTRUM:MODULATION:FREQUENCY:OFFSET 400 KHZ, 700 KHZ"
! Turns on the first two ORFS due to modulation measurement offsets and sets
! them to 400 kHz and 700 kHz offsets. All other offsets are in the off state.

OUTPUT 714;"SETUP:ORFSPECTRUM:MODULATION:FREQUENCY:OFFSET 700 KHZ"
! Turns on the first ORFS due to modulation measurement offset and sets it to  A 700 kHz
! offset. All other offsets are in the off state.

OUTPUT 714;"SETUP:ORFSPECTRUM:MODULATION:FREQUENCY:OFFSET"
! Turns all offsets for ORFS due to modulation measurement to the off state.

SETup:ORFSpectrum:MODulation:FREQuency:OFFSet:ALL

Function

GSM TA

This command turns on or off all of the frequency offsets for the ORFS Modulation measurement.

NOTE

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

Range: 0 | OFF | 1 | ON
*RST Setting

Offset 1: On

Offset 2: On

Offsets 3 to 22: Off
Requirements

GSM/GPRS/
EGPRS TA

Revision: A.01 and above

GSM/GPRS/
EGPRS LA

Revision: C.01 and above

SETup:ORFSpectrum:MODulation:FREQuency:POINts?

Function | GSM TA | This command queries the number of frequency offsets currently on during an ORFS due to modulation measurement in the active (that is the selected) format. See Output RF Spectrum Measurement Description .
 | GPRS TA
 | EGPRS TA
 | GSM/GPRS LA
 | EGPRS LA
Query |  | Range: 0 to 22 Resolution: 1
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.01 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.01 and above

SETup:ORFSpectrum:MODulation:LIMit:MANual<[1]|2>[:SELected]

SETup:ORFSpectrum:MODulation:LIMit:MANual<[1]|2>:(DCS|EGSM|GSM450|GSM480|GSM750|GSM850|PCS|PGSM|RGSM|TGSM810)

Function

GSM TA

This command allows you to set the specified manual limits for the ORFS due to modulation measurement. You can enter up to 22 limit values, one for each of the ORFS due to modulation offset frequencies. The n th limit value is the value for the n th offset frequency, regardless of whether the offset frequency is switched on or off. Changing the offset value has no effect on the limit value. If you supply fewer than 22 limit values, the remainder of the limit values remain unchanged.

The optional [:SELected] node allows you to select which traffic channel band the setting is implemented in. The default band is the currently selected band, otherwise you can specify PGSM, EGSM, DCS, PCS, RGSM, GSM450, GSM480, GSM750, GSM850, or TGSM810.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

Range: 1 to 22 comma-separated values ranging from -200 dB to +100 dB

Resolution: 0.1

Query

Range: 22 comma-separated values ranging from -200 dB to +100 dB

Resolution: 0.1
*RST Setting

Offset 1: -60 dB
Offset 2: -60 dB
Offset 3: +0.5 dB
Offset 4: +0.5 dB
Offset 5: -30 dB
Offset 6: -30 dB
Offset 7: -33 dB
Offset 8: -33 dB
Offset 9: -60 dB
Offset 10: -60 dB
Offset 11: -60 dB
Offset 12: -60 dB
Offset 13: -60 dB
Offset 14: -60 dB
Offset 15: -60 dB
Offset 16: -60 dB
Offset 17: -60 dB
Offset 18: -60 dB
Offset 19: -60 dB
Offset 20: -60 dB
Offset 21: -60 dB
Offset 22: -60 dB
Requirements

GSM/GPRS/
EGPRS TA

Revision: A.01 and above

Revision A.06 adds the TGSM810 band.

GSM/GPRS/
EGPRS LA

Revision: C.01 and above

Revision D.03 adds the TGSM810 band.

Programming Example

OUTPUT 714;"SETUP:ORFSPECTRUM:MODULATION:LIMIT:MANUAL -58DB,-58DB"
! Sets the first two offsets to -58 dB and -58 dB respectively.

SETup:ORFSpectrum:MODulation:RELative:LIMit:CUSTom<[1]|2>

Function

GSM TA

This command sets/queries the relative limits for the specified custom mask to be used with the ORFS Modulation measurement. Custom limit testing differs from Manual limit testing because a limit mask is defined separately from the frequency offset. When a frequency offset is changed, the limit value is recalculated for the new frequency offset by interpolating the Custom Mask.

A total of 32 reference points (frequency point / limit value mask point pairs) are available to you when defining a custom mask. Frequency Offsets that fall outside the Custom Mask will always return a PASS result.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

Range:
0 to 32 comma-separated value pairs containing frequency point and limit value within the following ranges:

  • Frequency: -1800 Hz to -10 Hz and +10 Hz to +1800 kHz
  • Limit Value: -200 dB to +100 dB

Resolution:

  • Frequency: 10 Hz
  • Limit Value: 0.1 dB

Query

Range:
0 to 32 comma-separated value pairs containing frequency point and limit value within the following ranges:

  • Frequency: -1800 Hz to -10 Hz, +10 Hz to +1800 kHz, and 9.91E+37 (NAN) if no offsets are specified.
  • Limit Value: -200 dB to +100 dB

Resolution:

  • Frequency: 10 Hz
  • Limit Value: 0.1 dB
*RST Setting No Mask
Requirements

GSM/GPRS/
EGPRS TA

Revision: A.03 and above

GSM/GPRS/
EGPRS LA

Revision: C.03 and above

SETup:ORFSpectrum:MODulation:RELative:LIMit:CUSTOM<[1]|2>:POINts?

Function | GSM TA | This query returns the number of enabled reference points for the ORFS Modulation Relative custom mask you specify.
 | GPRS TA
 | EGPRS TA
 | GSM/GPRS LA
 | EGPRS LA
Query |  | Range: 0 to 32 Resolution: 1
*RST Setting |  | 0
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.03 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.03 and above

SETup:ORFSpectrum:SWITching:COUNt[:SNUMber]

Function

GSM TA

This command sets/queries the ORFS due to switching multi-measurement count value and turns the state on.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

Range: 1 to 999

Resolution: 1

Query

Range: 1 to 999

Resolution: 1
*RST Setting 10
Requirements

GSM/GPRS/
EGPRS TA

Revision: A.01 and above

GSM/GPRS/
EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETUP:ORFSPECTRUM:SWITCHING:COUNT:SNUMBER 55"
! Sets the multi-measurment value to 10 and the state to on.

SETup:ORFSpectrum:SWITching:COUNt:NUMBer

Function

GSM TA

 This command sets/queries the ORFS due to switching multi-measurement count value. See Output RF Spectrum Measurement Description .

GPRS TA

EGPRS TA

GSM/GPRS LA
EGPRS LA
Setting

Range: 1 to 999

Resolution: 1

Query

Range: 1 to 999

Resolution: 1
*RST Setting 10
Requirements

GSM/GPRS/
EGPRS TA

Revision: A.01 and above

GSM/GPRS/
EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETUP:ORFSPECTRUM:SWITCHING:COUNT:NUMBER 15"
! Sets the multi-measurement count number for ORFS due to switching to 15.

SETup:ORFSpectrum:SWITching:FREQuency[:OFFSet]

Function

GSM TA

 This command sets/queries the list of ORFS due to switching frequency offsets in the active (that is the selected) format. Each offset listed in the command is turned on by default. If no frequency offsets (null list) are sent, the output RF spectrum due to switching measurement will not be made. The units (GHZ|MHZ|KHZ|HZ) are optional, if no units are specified than units default to HZ. See Output RF Spectrum Measurement Description .

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

Range: 0 to 8 comma-separated values ranging from -1.8 MHz to -10 Hz, and +10 Hz to +1.8 MHz

Resolution: 10 Hz

Query

Range: 0 to 8 comma-separated values ranging from -1.8 MHz to -10 Hz, and +10 Hz to +1.8 MHz

Resolution: 10 Hz
*RST Setting

Offset 1 = 400.0 kHz

Offset 2 = 600.0 kHz

Offsets 3 to 8 off
Requirements

GSM/GPRS/
EGPRS TA

Revision: A.01 and above

GSM/GPRS/
EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETUP:ORFSPECTRUM:SWITCHING:FREQUENCY:OFFSET 400 KHZ, 700 KHZ"
! Turns on the first two ORFS due to switching measurement offsets and sets them
! to 400 kHz and 700 kHz offsets. All other offsets are in the off state.

OUTPUT 714;"SETUP:ORFSPECTRUM:SWITCHING:FREQUENCY:OFFSET 700 KHZ"
! Turns on the first ORFS due to switching measurement offset and sets it to 700 kHz
! offsets. All other offsets are in the off state.

OUTPUT 714;"SETUP:ORFSPECTRUM:SWITCHING:FREQUENCY:OFFSET"
! Turns all of the ORFS due to switching measurements offsets to off.

SETup:ORFSpectrum:SWITching:FREQuency:OFFSet:ALL

Function

GSM TA

This command turns on or off all of the frequency offsets for the ORFS Switching measurement.

NOTE

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

Range: 0 | OFF | 1 | ON
*RST Setting

Offset 1: On

Offset 2: On

Offsets 3 to 8: Off
Requirements

GSM/GPRS/
EGPRS TA

Revision: A.01 and above

GSM/GPRS/
EGPRS LA

Revision: C.01 and above

SETup:ORFSpectrum:SWITching:FREQuency:POINts?

Function | GSM TA | This command queries the number of frequency offsets currently on during an ORFS due to switching measurement. See Output RF Spectrum Measurement Description .
 | GPRS TA
 | EGPRS TA
 | GSM/GPRS LA
 | EGPRS LA
Query |  | Range: 0 to 8 Resolution: 1
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.01 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.01 and above

SETup:ORFSpectrum:SWITching:LIMit:CUSTom

Function

GSM TA

This command sets/queries the absolute limits for the custom mask to be used with the ORFS Switching measurement. Custom limit testing differs from Manual limit testing because a limit mask is defined separately from the frequency offset. When a frequency offset is changed, the limit value is recalculated for the new frequency offset by interpolating the Custom Mask.

A total of 32 reference points (frequency point / limit value mask point pairs) are available to you when defining a custom mask. Frequency Offsets that fall outside the Custom Mask will always return a PASS result.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

Range:
0 to 32 comma-separated value pairs containing frequency point and limit value within the following ranges:

  • Frequency: -1800 Hz to -10H z and +10 Hz to +1800 kHz
  • Limit Value: -200 dBm to +100 dBm

Resolution:

  • Frequency: 10 Hz
  • Limit Value: 0.1 dB

Query

Range:
0 to 32 comma-separated value pairs containing frequency point and limit value within the following ranges:

  • Frequency: -1800 Hz to -10 Hz, +10 Hz to +1800 kHz, and 9.91E+37 (NAN) if no offsets are specified.
  • Limit Value: -200 dBm to +100 dBm

Resolution:

  • Frequency: 10 Hz
  • Limit Value: 0.1 dB
*RST Setting No Mask
Requirements

GSM/GPRS/
EGPRS TA

Revision: A.03 and above

GSM/GPRS/
EGPRS LA

Revision: C.03 and above

SETup:ORFSpectrum:SWITching:LIMit:CUSTom:POINts?

Function | GSM TA | This query returns the number of enabled reference points for the ORFS Switching Absolute custom mask.
 | GPRS TA
 | EGPRS TA
 | GSM/GPRS LA
 | EGPRS LA
Query |  | Range: 0 to 32 Resolution: 1
*RST Setting |  | 0
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.03 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.03 and above

SETup:ORFSpectrum:SWITching:LIMit:MANual[:SELected]

SETup:ORFSpectrum:SWITching:LIMit:MANual:(DCS|EGSM|GSM450|GSM480|GSM750|GSM850|PCS|PGSM|RGSM|TGSM810)

Function

GSM TA

This command allows you to set the limits for the ORFS due to switching measurement. You can enter up to eight limit values, one for each of the ORFS due to switching offset frequencies. The n th limit value is the value for the n th offset frequency, regardless of whether the offset frequency is switched on or off. Changing the offset value has no effect on the limit value. If you supply fewer than eight limit values, the remainder of the limit values remain unchanged.

The optional [:SELected] node allows you to select which traffic channel band the setting is implemented in. The default band is the currently selected band, otherwise you can specify PGSM, EGSM, DCS, PCS, RGSM, GSM450, GSM480, GSM750, GSM850, or TGSM810.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

Range: 1 to 8 comma-separated values ranging from -200 dBm to +100 dBm

Resolution: 0.1

Query

Range:8 comma-separated values ranging from -200 dBm to +100 dBm

Resolution: 0.1
*RST Setting

Offset 1: -23 dBm
Offset 2: -26 dBm
Offset 3: -23 dBm
Offset 4: -26 dBm
Offset 5: -32 dBm
Offset 6: -32 dBm
Offset 7: -36 dBm
Offset 8: -36 dBm
Requirements

GSM/GPRS/
EGPRS TA

Revision: A.01 and above

Revision A.06 adds the TGSM810 band.

GSM/GPRS/
EGPRS LA

Revision: C.01 and above

Revision D.03 adds the TGSM810 band.

Programming Example

OUTPUT 714;"SETUP:ORFSPECTRUM:SWITCHING:LIMIT:MANUAL -30DBM,-32DBM"
! Sets the first two offsets to -30 dBm and -32 dBm respectively.

SETup:ORFSpectrum:SWITching:TIME:DOMain:STATe

Function

GSM TA

 This command sets/queries the Time Domain Trace state for ORFS due to Switching measurement. You can turn on/off the Time Domain Trace by setting this parameter. However, turn on the Time Domain Trace will significantly slow down the measurement speed.
GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

Range: 1|ON|0|OFF

Query

Range: 1|0
*RST Setting 0|OFF
Requirements

GSM/GPRS/
EGPRS TA

Revision: A.09 and above

GSM/GPRS/
EGPRS LA

Revision: F.01 and above

Programming Example

OUTPUT 714;"SET:ORFS:SWIT:TIME:DOM:STAT ON"
! Turn on the Time Domain Trace.

SETup:ORFSpectrum:SWITching:TIME:DOMain:FREQuency:OFFSet:INDex

Function

GSM TA

 This command sets/queries the frequency that the time domain trace is made on. the frequency is either equal to that of the carrier or an offset towards the carrier. You can use SETup:ORFSpectrum:SWITching:FREQuency[:OFFSet] to set the offset value.
GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

Range: CARRier|OFFSet1|OFFSet2|OFFSet3|OFFSet4|OFFSet5|OFFSet6| OFFSet7|OFFSet8|CARRier

Query

 Range: CARR|OFFS1|OFFS2|OFFS3|OFFS4|OFFS5|OFFS6| OFFS7|OFFS8
*RST Setting CARRier
Requirements

GSM/GPRS/
EGPRS TA

Revision: A.09 and above

GSM/GPRS/
EGPRS LA

Revision: F.01 and above

Programming Example

OUTPUT 714;"SETup:ORFSpectrum:SWITching:TIME:DOMain:FREQuency:OFFSet:INDex OFFSet1"
! Sets the Frequency Offset Index to OFFSet1.

SETup:ORFSpectrum:TIMeout:TIME

Function

GSM TA

 This command selects/queries the timeout value in seconds that will be used for ORFS measurements when the SETup:ORFSpectrum:TIMeout:STATe is ON. The units (S | MS) are optional. Units default to S if units are not specified.
GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

Range: 0.1 to 999 seconds

Resolution: 0.1 seconds

Query

Range: 0.1 to 999 seconds

Resolution: 0.1 seconds
*RST Setting

10 seconds
Requirements

GSM/GPRS/
EGPRS TA

Revision: A.01 and above

GSM/GPRS/
EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETUP:ORFSPECTRUM:TIMEOUT:TIME 15"
! Sets the timeout value to 15 seconds.

SETup:ORFSpectrum:TIMeout[:STIMe]

Function

GSM TA

This command sets/queries the timeout value in seconds that will be used for ORFS measurements and turns the timeout state on. The units (S|MS) are optional. If no units are specified than units default to S.

GPRS TA

EGPRS TA

GSM/GPRS LA
EGPRS LA
Setting

Range: 0.1 to 999 seconds

Resolution: 0.1 seconds

Query

Range: 0.1 to 999 seconds

Resolution: 0.1 seconds
*RST Setting

10 seconds
Requirements

GSM/GPRS/
EGPRS TA

Revision: A.01 and above

GSM/GPRS/
EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETUP:ORFSPECTRUM:TIMEOUT:STIME 12"
! Sets the timeout value to 12 seconds and the state to on.

SETup:ORFSpectrum:TIMeout:STATe

Function

GSM TA

This command selects/queries the ORFS measurement timeout state.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

Range: 0 | OFF | 1 | ON

Query

Range: 0 | 1
*RST Setting 0 | OFF
Requirements

GSM/GPRS/
EGPRS TA

Revision: A.01 and above

GSM/GPRS/
EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETUP:ORFSPECTRUM:TIMEOUT:STATE ON"
! Sets timeout state to on.

SETup:ORFSpectrum:TRIGer:DELay

Function

GSM TA

This command sets/queries the trigger delay for ORFS measurements. The units (S | MS | US | NS) are optional, units default to S if units are not specified.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

Range: -2.31 ms to +2.31 ms

Resolution: 5 significant digits or 100 nanoseconds whichever is greater

Query

Range: -2.31 ms to +2.31 ms

Resolution: 5 significant digits or 100 nanoseconds whichever is greater
*RST Setting 0 seconds
Requirements

GSM/GPRS/
EGPRS TA

Revision: A.01 and above

GSM/GPRS/
EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETUP:ORFSPECTRUM:TRIGGER:DELAY 1MS"
! Sets the trigger delay value to 1 millisecond.

SETup:ORFSpectrum:TRIGger:SOURce

Function

GSM TA

 This command selects/queries the trigger source for ORFS measurements. See Output RF Spectrum Measurement Description .

GPRS TA

EGPRS TA

GSM/GPRS LA
EGPRS LA
Setting

Range: AUTO | IMMediate | PROTocol | RISE | EXTernal

See Triggering of Measurements .

Query

Range: AUTO | IMM | PROT | RISE | EXT
*RST Setting

AUTO
Requirements

GSM/GPRS/
EGPRS TA

Revision: A.01 and above

GSM/GPRS/
EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETUP:ORFSPECTRUM:TRIGGER:SOURCE AUTO"
! Sets the trigger source to automatic.


SETup:PCALibration

SETup:PCALibration

GPIB Command Conventions

  • SETup:PCALibration:FILTer
  • SETup:PCALibration:MEASurement:COUNt
  • SETup:PCALibration:MEASurement:DELay
  • SETup:PCALibration:RESult:TYPE
  • SETup:PCALibration:STEP:CENTer
  • SETup:PCALibration:STEP:COUNt
  • SETup:PCALibration:STEP:WIDth
  • SETup:PCALibration:TIMeout:STATe
  • SETup:PCALibration:TIMeout:STIMe
  • SETup:PCALibration:TIMeout:TIME
  • SETup:PCALibration:TRIGger:DELay
  • SETup:PCALibration:TRIGger:SOURce
  • SETup:PCALibration:TRIGger:THReshold
  • SETup:PCALibration:WAVeform:TYPE

SETup:PCALibration:FILTer

Function

 GSM TA

This command sets/queries the type of filter used in the Phase and Amplitude versus Time measurement.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

Range: WIDE|NARRow|ENARrow

Query

Range: WIDE|NARR|ENARrow
*RST Setting

WIDE

Requirements

GSM/GPRS/
EGPRS TA

Revision: A.07 and above with the required feature license

GSM/GPRS/
EGPRS LA

Revision: E.01 and above.

Programming Example

OUTPUT 714;"SETup:PCALibration:FILTer ENARrow"
! Sets the filter type to ENARrow.

SETup:PCALibration:MEASurement:COUNt

Function

 GSM TA

This parameter only applies when the command SETup:PCALibration:WAVeform:TYPE is set to CONTinuous , CONT2 , or CONT3 .

This command sets/queries the Measurement Sample Count for the Phase and Amplitude versus Time measurement.

  • When this count value is set to > 5000 or < 1 ( For CONTinuous and CONT2 ), > 50000 or < 1 ( For CONT3 ), "Data out of Range" error message is displayed.
  • If you change a CONT3 Measurement to CONTinuous or CONT2 , the count value will be automatically set to 1 if it is originately over 5000. A warning message is popped up to notify the change.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

Range: 1 to 5000 (For CONTinuous and CONT2 ). 1 to 50000 (For CONT3 )

Resolution: 1

Query

Range: 1 to 5000 (For CONTinuous and CONT2 ). 1 to 50000 (For CONT3 )

Resolution: 1

*RST Setting 1

Requirements

GSM/GPRS/
EGPRS TA

Revision: A.06 and above with the required feature license

GSM/GPRS/
EGPRS LA

Revision: D.03.32 and above.

Revision: G.00.00 adds the value for CONT3 (1 to 50000).

Programming Example

OUTPUT 714;"SETup:PCALibration:MEASurement:COUNt 500"
! Sets the number of continuous waveform type samples for the test set to return.

SETup:PCALibration:MEASurement:DELay

Function

 GSM TA

This setting is only applicable when the command SETup:PCALibration:WAVeform:TYPE is set to CONTinuous .

This command sets/queries the Measurement Delay for the Phase and Amplitude versus Time measurement.

If none of the optional units (S|MS|US|NS) are specified, the default unit is S (seconds).

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

Range: -576.875 µs to +25 ms

Resolution: 1ns

Query

Range: -576.875 µs to +25 ms

Resolution: 1 ns
*RST Setting

0

Requirements

GSM/GPRS/
EGPRS TA

Revision: A.06 and above with the required feature license

GSM/GPRS/
EGPRS LA

Revision: D.03.32 and above.

Programming Example

OUTPUT 714;"SETup:PCALibration:MEASurement:DELay .001"
! Sets the delay the Phase and Amplitude versus Time measurement waits to initiate once
! it has been triggered to 1 second.

SETup:PCALibration:RESult:TYPE

Function

 GSM TA

This parameter only applies when the command SETup:PCALibration:WAVeform:TYPE is set to DISCrete .

This command sets/queries the type of results the Phase and Amplitude versus Time measurement returns. The valid settings for this command depend on what the command SETup:PCALibration:WAVeform:TYPE is set to. If the waveform is DISCrete all the options for this command are available. If the waveform is CONTinuous then the only valid setting is SAMPle . The options for this command are described below:

  • PCAL - returns the measurement results of each step in the following order: measured power, measured phase error, measured frequency error.
  • SAMPle - returns the amplitude and phase of the samples taken from the calibration signal generated from the mobile station.
  • BOTH - this setting makes both PCAL and SAMPle result formats available.

The setting for this command affects the results the test set returns for the command READ:PCALibration[:ALL]? and the FETCh:PCALibration commands.

See also Phase and Amplitude Measurement Results for a Discrete Waveform .

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

Range: PCAL|SAMPle|BOTH

Query

Range: PCAL|SAMP|BOTH
*RST Setting

PCAL

Requirements

GSM/GPRS/
EGPRS TA

Revision: A.06 and above with the required feature license

GSM/GPRS/
EGPRS LA

Revision: D.03.32 and above.

Programming Example

OUTPUT 714;"SETup:PCALibration:RESult:TYPE PCAL"
! Sets the result type to PCAL.

SETup:PCALibration:STEP:CENTer

Function

 GSM TA

This command is only applicable when the command SETup:PCALibration:WAVeform:TYPE is set to DISCrete .

This command sets/queries the expected center location of the measurable portion of each step in a calibration signal generated by the mobile station relative to the RF Rise trigger threshold (see SETup:PCALibration:TRIGger:THReshold ).

Make sure the step count, the number of centers, and the number of widths specified for the discrete wavetype are consistent. The number of returned results depends on the step count. If the number of centers and/or widths is less than the step count, invalid data is returned.

The command to set the step count is SETup:PCALibration:STEP:COUNt .

The command to set the step centers is SETup:PCALibration:STEP:CENTer .

The command to set the step widths is SETup:PCALibration:STEP:WIDth .

The range of this parameter depends on the Step Width parameter. You must ensure that the Step Center subtract half of the Step Width is greater than or equal to zero and the Step Center plus half of the Step Width parameter is less than or equal to 400 ms.

If none of the optional units (S|MS|US|NS) are specified, the default unit is S (seconds).

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

Range: 50 µs to 399.95 ms

Resolution: 10 µs

Query

Range: 50 µs to 399.95 ms

Resolution: 10 µs
*RST Setting 1 ms

Requirements

GSM/GPRS/
EGPRS TA

Revision: A.06 and above with the required feature license

GSM/GPRS/
EGPRS LA

Revision: D.03.32 and above.

Programming Example

OUTPUT 714;"SETup:PCALibration:STEP:CENTer 0.0025,0.004608,0.005632,0.006656"
! Sets the step centers to be at 0.0025,0.004608,0.005632,0.006656 seconds after the
! mobile station reaches the trigger threshold.

SETup:PCALibration:STEP:COUNt

Function

 GSM TA

This command is only applicable when the command SETup:PCALibration:WAVeform:TYPE is set to DISCrete .

This command sets/queries the total number of intervals for which in the mobile station's discrete calibration signal is to be measured.

Make sure the step count, the number of centers, and the number of widths specified for the discrete wavetype are consistent. The number of returned results depends on the step count. If the number of centers and/or widths is less than the step count, invalid data is returned.

The command to set the step centers is SETup:PCALibration:STEP:CENTer .

The command to set the step widths is SETup:PCALibration:STEP:WIDth .

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

Range: 1 to 512

Resolution: 1

Query

Range: 1 to 512

Resolution: 1
*RST Setting 1

Requirements

GSM/GPRS/
EGPRS TA

Revision: A.06 and above with the required feature license

GSM/GPRS/
EGPRS LA

Revision: D.03.32 and above.

Programming Example

OUTPUT 714;"SETup:PCALibration:STEP:COUNT 10"
! Sets the step count to 10.

SETup:PCALibration:STEP:WIDth

Function

 GSM TA

This command is only applicable when the command SETup:PCALibration:WAVeform:TYPE is set to DISCrete .

This command sets/queries the Interval Widths of each interval of a Discrete Waveform Calibration Signal.

Make sure the step count, the number of centers, and the number of widths specified for the discrete wavetype are consistent. The number of returned results depends on the step count. If the number of centers and/or widths is less than the step count, invalid data is returned.

The command to set the step count is SETup:PCALibration:STEP:COUNt .

The command to set the step centers is SETup:PCALibration:STEP:CENTer .

The command to set the step widths is SETup:PCALibration:STEP:WIDth .

The range of this parameter depends on the Step Center parameter. You must ensure that the Step Center minus half of the Step Width is greater than or equal to zero and the Step Center plus half of the Step Width parameter is less than or equal to 400 ms.

If none of the optional units (S|MS|US|NS) are specified, the default unit is S (seconds).

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Setting

Range: 100 µs to 400 ms

Resolution: 10 µs

Query

Range: 100 µs to 400 ms

Resolution: 10 µs

*RST Setting

1 ms

Requirements

GSM/GPRS/

EGPRS TA

Revision: A.06 and above with the required feature license

GSM/GPRS/

EGPRS LA

Revision: D.03.32 and above.

Programming Example

OUTPUT 714;"SETup:PCALibration:STEP:WIDth .008,.008,.008,.008"
! Sets width of each power step measured.

SETup:PCALibration:TIMeout:STATe

Function

GSM TA

This command sets/queries the state of the Phase and Amplitude versus Time measurement timeout.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Setting

Range: ON|1|OFF|0

Query

Range: ON|OFF

*RST Setting

0 (OFF)

Requirements

GSM/GPRS/

EGPRS TA

Revision: A.06 and above with the required feature license

GSM/GPRS/

EGPRS LA

Revision: D.03.32 and above.

Programming Example

OUTPUT 714;"SETup:PCALibration:TIMeout:STATe ON"
! Enables the timeout the Phase and Amplitude versus Time measurement.

SETup:PCALibration:TIMeout:STIMe

Function

GSM TA

This command sets/queries the state time of the Phase and Amplitude vs. Time measurement timeout and state. Using this command sets the command
SETup:PCALibration:TIMeout:STATe
 to
ON
and sets the timeout time parameter.

If none of the optional units (S|MS|US|NS) are specified, the default unit is S (seconds).

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Setting

Range: 0.1 to 999.9 seconds

Resolution: 0.1 seconds

Query

Range: 0.1 to 999.9 seconds

Resolution: 0.1 seconds

*RST Setting

10 seconds

Requirements

GSM/GPRS/

EGPRS TA

Revision: A.06 and above with the required feature license

GSM/GPRS/

EGPRS LA

Revision: D.03.32 and above.

Programming Example

OUTPUT 714;"SETup:PCALibration:STIMe 10"
! Enables the Phase and Amplitude versus Time measurement timeout and sets it to 10 seconds.

SETup:PCALibration:TIMeout:TIME

Function

GSM TA

This command sets/queries the length of the Phase and Amplitude vs. Time measurement
Timeout
.

If none of the optional units (S|MS|US|NS) are specified, the default unit is S (seconds).

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Setting

Range: 0.1 to 999.9 seconds

Resolution: 0.1 seconds

Query

Range: 0.1 to 999.9 seconds

Resolution: 0.1 seconds

*RST Setting

10 seconds

Requirements

GSM/GPRS/

EGPRS TA

Revision: A.06 and above with the required feature license

GSM/GPRS/

EGPRS LA

Revision: D.03.32 and above.

Programming Example

OUTPUT 714;"SETup:PCALibration:TIMeout:TIME 10"
! Sets the Phase and Amplitude versus Time measurement timeout to 10 seconds.

SETup:PCALibration:TRIGger:DELay

Function

GSM TA

This command sets/queries the for the
Trigger Delay
 Phase and Amplitude versus Time measurement.

If none of the optional units (S|MS|US|NS) are specified, the default unit is S (seconds).

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Setting

Range:

  •
0 ms to 10 ms when the
Waveform Type
 is set to DISCrete or CONTinuous
    •

  •

-2.31001 to 10 ms when the
Waveform Type
 is set to CONT2 or CONT3
    •

Resolution: 50 µs

Query

Range:

  •
0 ms to 10 ms when the
Waveform Type
 is set to DISCrete or CONTinuous
    •

  •

-2.31001 to 10 ms when the
Waveform Type
 is set to CONT2 or CONT3
    •

Resolution: 50 µs

*RST Setting

0

Requirements

GSM/GPRS/

EGPRS TA

Revision: A.06 and above with the required feature license

GSM/GPRS/

EGPRS LA

Revision: D.03.32 and above.

Revision: G.00.00 adds CONT3.

Programming Example

OUTPUT 714;"SETup:PCALibration:TRIGger:DELay .005"
! Sets the trigger delay for the Phase and Amplitude versus Time measurement to .005 seconds.

SETup:PCALibration:TRIGger:SOURce

Function

GSM TA

This command sets/queries the trigger source. There are three settings for this command:

  •
RF Rise
    •

  •

Immediate
    •

  •

External
    •

For more information, see
Triggering of Measurements
.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Setting

Range: RISE|IMMediate|EXTernal

Query

Range: RISE|IMM|EXT

*RST Setting

RISE

Requirements

GSM/GPRS/

EGPRS TA

Revision: A.06 and above with the required feature license

GSM/GPRS/

EGPRS LA

Revision: D.03.32 and above.

Programming Example

OUTPUT 714;"SETup:PCALibration:TRIGger:SOURce RISE"
! Sets the trigger source for the Phase and Amplitude versus Time measurement to RF Rise.

SETup:PCALibration:TRIGger:THReshold

Function

GSM TA

This command sets/queries the
Trigger Threshold
 for the Phase and Amplitude versus Time measurement.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Setting

Range: 0 to 30 dB

Resolution: 0.1 dB

Query

Range: 0 to 30 dB

Resolution: 0.1 dB

*RST Setting

10 dB

Requirements

GSM/GPRS/

EGPRS TA

Revision: A.06 and above with the required feature license

GSM/GPRS/

EGPRS LA

Revision: D.03.32 and above.

Programming Example

OUTPUT 714;"SETup:PCALibration:TRIGger:THReshold 0"
! Sets the trigger threshold for the Phase and Amplitude versus Time measurement to 0 dBm.

SETup:PCALibration:WAVeform:TYPE

Function

GSM TA

This command sets/queries the
Waveform Type
 for the Phase and Amplitude versus Time measurement.

  •

DISCrete
 - This setting configures the test set to expect a calibration signal generated by the mobile station that consists of a sequence of finite length power bursts with no burst in the sequence having a higher maximum power level than the first burst, which transitions through the trigger level threshold (see
SETup:PCALibration:TRIGger:THReshold
).
    •

  •

CONTinuous
 -This setting configures the test set to expect a waveform consisting of an initial power burst 577 µs wide to trigger the measurement, followed by a piecewise continuous power waveform.
    •

  •

CONT2
 - This setting is similar to the
CONTinuous
 setting except that it uses different type of filtering and a different sample rate.
    •

  •

CONT3
 - This setting is similar to the
CONTinuous
 setting except that it uses different type of filtering and a different sample rate. It supports measureing a wideband signal.
    •

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Setting

Range: DISCrete|CONTinuous|CONT2|CONT3

Query

Range: DISC|CONT|CONT2|CONT3

*RST Setting

DISC

Requirements

GSM/GPRS/

EGPRS TA

Revision: A.06 and above with the required feature license

GSM/GPRS/

EGPRS LA

Revision: D.03.32 and above.

Revision: G.00.00 adds CONT3.

Programming Example

OUTPUT 714;"SETup:PCALibration:WAVeform:TYPE DISCrete"
! Sets the waveform type to discrete.


SETup:PFERror

SETup:PFERror

GPIB Command Conventions

  • SETup:PFERror:CONFidence:LEVel[:SELected]
  • SETup:PFERror:CONFidence:LEVel:GSM
  • SETup:PFERror:CONFidence[:SLEVel][:SELected]
  • SETup:PFERror:CONFidence[:SLEVel]:GSM
  • SETup:PFERror:CONFidence:STATe[:SELected]
  • SETup:PFERror:CONFidence:STATe:GSM
  • SETup:PFERror:CONTinuous
  • SETup:PFERror:COUNt[:SNUMber]
  • SETup:PFERror:COUNt:NUMBer
  • SETup:PFERror:COUNt:STATe
  • SETup:PFERror:FERRor[:LIMit]:GSM
  • SETup:PFERror:FERRor[:LIMit][:SELected]
  • SETup:PFERror:PEAK[:LIMit]:GSM
  • SETup:PFERror:PEAK[:LIMit][:SELected]
  • SETup:PFERror:RMS[:LIMit]:GSM
  • SETup:PFERror:RMS[:LIMit][:SELected]
  • SETup:PFERror:SYNC
  • SETup:PFERror:TBDemod
  • SETup:PFERror:TIMeout[:STIMe]
  • SETup:PFERror:TIMeout:TIME
  • SETup:PFERror:TIMeout:STATe
  • SETup:PFERror:TRIGger:DELay
  • SETup:PFERror:TRIGer:SOURce
  • SETup:PFERror:TRIGger:QUALifier[:SELected]
  • SETup:PFERror:TRIGger:QUALifier:GSM

SETup:PFERror:CONFidence:LEVel[:SELected]

Function

GSM TA

This command sets/queries the active (that is the selected) format's confidence level (in %) with which to end the measurement early. This level applies to the RMS Phase Error, the Peak Phase Error, and the Frequency Error.

For more information on using confidence levels refer to Confidence Levels .

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

Range: 80.00 to 99.99

Resolution: 0.01

Query

Range: 80.00 to 99.99

Resolution: 0.01

*RST Setting 99.00

Requirements

GSM/GPRS/
EGPRS TA

Revision: A.01 and above

GSM/GPRS/
EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETUP:PFERROR:CONFIDENCE:LEVel 90"
! Sets the confidence level to 90%.

SETup:PFERror:CONFidence:LEVel:GSM

Function

GSM TA

This command sets/queries the GSM format's confidence level (in %) with which to end the measurement early, whether or not the GSM format is active. This level applies to the RMS Phase Error, the Peak Phase Error, and the Frequency Error.

For more information on using confidence levels refer to Confidence Levels .

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

Range: 80.00 to 99.99

Resolution: 0.01

Query

Range: 80.00 to 99.99

Resolution: 0.01

*RST Setting 99.00

Requirements

GSM/GPRS/
EGPRS TA

Revision: A.01 and above

GSM/GPRS/
EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETUP:PFERROR:CONFIDENCE:LEVEL:GSM 90"
! Sets the confidence level to 90%.

SETup:PFERror:CONFidence[:SLEVel][:SELected]

Function

GSM TA

This command sets/queries the active (that is the selected) format's confidence level with which to end the measurement early and turns the confidence state on. This level applies to the RMS Phase Error, the Peak Phase Error, and the Frequency Error.

This command also turns the multi-measurement state on.

For more information on using confidence levels refer to Confidence Levels .

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

Range: 80.00 to 99.99

Resolution: 0.01

Query

Range: 80.00 to 99.99

Resolution: 0.01

*RST Setting 99.00

Requirements

GSM/GPRS/
EGPRS TA

Revision: A.01 and above

GSM/GPRS/
EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETUP:PFERROR:CONFIDENCE 95"
! Sets the confidence level to 95% and the state to on.

SETup:PFERror:CONFidence[:SLEVel]:GSM

Function

GSM TA

This command sets/queries the GSM format's confidence level with which to end the measurement early and turns the confidence state on. It does this in the GSM format whether or not that format is active. This level applies to the RMS Phase Error, the Peak Phase Error, and the Frequency Error.

This command also turns the multi-measurement state on.

For more information on using confidence levels refer to Confidence Levels .

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

Range: 80.00 to 99.99

Resolution: 0.01

Query

Range: 80.00 to 99.99

Resolution: 0.01

*RST Setting 99.00

Requirements

GSM/GPRS/
EGPRS TA

Revision: A.01 and above

GSM/GPRS/
EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETUP:PFERROR:CONFIDENCE:GSM 90"
! Sets the confidence level to 90% and the state to on.

SETup:PFERror:CONFidence:STATe[:SELected]

Function

GSM TA

This command sets/queries whether the active (that is the selected) format's confidence level feature for the phase and frequency error measurement is on or off.

This command also turns the multi-measurement state on.

For more information on using confidence levels refer to Confidence Levels .

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

Range: 0 | OFF | 1 | ON

Query

Range: 0 | 1
*RST Setting 0 | OFF

Requirements

GSM/GPRS/
EGPRS TA

Revision: A.01 and above

GSM/GPRS/
EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETUP:PFERROR:CONFIDENCE:STATE 1"
! Sets the confidence state on.

SETup:PFERror:CONFidence:STATe:GSM

Function

GSM TA

This command sets/queries whether the GSM format's confidence level feature for the phase and frequency error measurement is on or off, whether or not that format is active.

This command also turns the multi-measurement state on.

For more information on using confidence levels refer to Confidence Levels .

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

Range: 0 | OFF | 1 | ON

Query

Range: 0 | 1
*RST Setting 0 | OFF

Requirements

GSM/GPRS/
EGPRS TA

Revision: A.01 and above

GSM/GPRS/
EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETUP:PFERROR:CONFIDENCE:STATE:GSM OFF"
! Sets the confidence state off.

SETup:PFERror:CONTinuous

Function

GSM TA

This command sets/queries the trigger state for phase and frequency error measurements.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

Range:

  • Single trigger mode = 0 | OFF
  • Continuous trigger mode = 1 | ON

Query

Range: 0 | 1
*RST Setting

0 | OFF
Requirements

GSM/GPRS/
EGPRS TA

Revision: A.01 and above

GSM/GPRS/
EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETUP:PFERROR:CONTINUOUS OFF"
! Specifies single trigger mode for phase/frequency measurements.

SETup:PFERror:COUNt[:SNUMber]

Function

GSM TA

This command sets/queries the number of phase and frequency error measurements the test set will make and turns the multi-measurement count state on.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

Range: 1 to 999

Resolution: 1

Query

Range: 1 to 999

Resolution: 1
*RST Setting 0 | OFF
Requirements

GSM/GPRS/
EGPRS TA

Revision: A.01 and above

GSM/GPRS/
EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETUP:PFERROR:COUNT:SNUMBER 100"
! Sets the value to 100 and the state to on.

SETup:PFERror:COUNt:NUMBer

Function

GSM TA

This command sets/queries the number of phase and frequency error measurements the Test Set will make when the multi-measurement count state is on.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

Range: 1 to 999

Resolution: 1

Query

Range: 1 to 999

Resolution: 1
*RST Setting

10
Requirements

GSM/GPRS/
EGPRS TA

Revision: A.01 and above

GSM/GPRS/
EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETUP:PFERROR:COUNT:NUMBER 55"
! Sets the multi-measurement count value to 55.

SETup:PFERror:COUNt:STATe

Function

GSM TA

This command sets/queries the phase and frequency error multi-measurement count state.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

Range: 0 | OFF | 1 | ON

Query

0 | 1
*RST Setting

0 | OFF
Requirements

GSM/GPRS/
EGPRS TA

Revision: A.01 and above

GSM/GPRS/
EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETUP:PFERROR:COUNT:STATE ON"
! Turns on multi-measurement mode for the phase/frequency measurement.

SETup:PFERror:FERRor[:LIMit]:GSM

Function

GSM TA

This command sets/queries the frequency error limit (in ppm) in the GSM format whether or not that format is active.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

Range: 0.01 to 0.1

Resolution: 0.01

Query

Range: 0.01 to 0.1

Resolution: 0.01
*RST Setting

0.1

Requirements

GSM/GPRS/
EGPRS TA

Revision: A.01 and above

GSM/GPRS/
EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETUP:PFERROR:FERROR:GSM 0.05"
! Sets the frequency error limit to 0.05 ppm.

SETup:PFERror:FERRor[:LIMit][:SELected]

Function

GSM TA

This command sets/queries the frequency error limit (in ppm) in the active (that is currently selected) format.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

Range: 0.01 to 0.1

Resolution: 0.01

Query

Range: 0.01 to 0.1

Resolution: 0.01
*RST Setting

0.1

Requirements

GSM/GPRS/
EGPRS TA

Revision: A.01 and above

GSM/GPRS/
EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETUP:PFERROR:FERROR 0.1"
! Sets the frequency error limit to 0.1 ppm.

SETup:PFERror:PEAK[:LIMit]:GSM

Function

GSM TA

This command sets/queries the peak phase error limit (in degrees) in the GSM format whether or not that format is active.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

Range: 0.00 to 20.00

Resolution: 0.01

Query

Range: 0.00 to 20.00

Resolution: 0.01
*RST Setting

20.00

Requirements

GSM/GPRS/
EGPRS TA

Revision: A.01 and above

GSM/GPRS/
EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETUP:PFERROR:PEAK:GSM 15"
! Sets the peak phase error to 15 degrees.

SETup:PFERror:PEAK[:LIMit][:SELected]

Function

GSM TA

This command sets/queries the peak phase error limit (in degrees) in the active (that is currently selected) format.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

Range: 0.00 to 20.00

Resolution: 0.01

Query

Range: 0.00 to 20.00

Resolution: 0.01
*RST Setting

20.00

Requirements

GSM/GPRS/
EGPRS TA

Revision: A.01 and above

GSM/GPRS/
EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETUP:PFERROR:PEAK 18"
! Sets the peak phase error to 18 degrees.

SETup:PFERror:RMS[:LIMit]:GSM

Function

GSM TA

This command sets/queries the RMS phase error limit (in degrees) in the GSM format whether or not that format is active.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

Range: 0.00 to 5.00

Resolution: 0.01

Query

Range: 0.00 to 5.00

Resolution: 0.01
*RST Setting

5.00

Requirements

GSM/GPRS/
EGPRS TA

Revision: A.01 and above

GSM/GPRS/
EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETUP:PFERROR:RMS:GSM 3"
! Sets the RMS phase error to 3 degrees.

SETup:PFERror:RMS[:LIMit][:SELected]

Function

GSM TA

This command sets/queries the RMS phase error limit (in degrees) in the active (that is currently selected) format.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

Range: 0.00 to 5.00

Resolution: 0.01

Query

Range: 0.00 to 5.00

Resolution: 0.01
*RST Setting

5.00

Requirements

GSM/GPRS/
EGPRS TA

Revision: A.01 and above

GSM/GPRS/
EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETUP:PFERROR:RMS 3.5"
! Sets the RMS phase error to 3.5 degrees.

SETup:PFERror:SYNC

Function

GSM TA

This command sets/queries the burst synchronization mode for phase and frequency error measurements in the active (that is the selected) format. See Burst Synchronization of Measurements .

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

MIDamble | AMPLitude | NONE

Query

MID | AMPL | NONE
*RST Setting MID
Requirements

GSM/GPRS/
EGPRS TA

Revision: A.01 and above

GSM/GPRS/
EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETUP:PFERROR:SYNC MIDAMBLE"
! Selects burst synchronization to midamble for power versus time measurements.

SETup:PFERror:TBDemod

Function

GSM TA

This command sets/queries the Tail Bit Demodulation parameter. This parameter determines how the measurement performs demodulation of the tail bits.

  • OPTimal

    The guard bits are adjusted to values that minimize the phase error on the tail bits.

  • SIMPle

    The guard bits are demodulated as they are received. The values are not adjusted.

  • ETSI

    The tail bits are forced to be ETSI compliant. That is, all the tail bits are set to zero, rather than using the demodulated values.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting | OPTimal|SIMPle|ETSI

Query

OPT|SIMP|ETSI
*RST Setting | OPT

Requirements

GSM/GPRS/
EGPRS TA

Revision: A.06.20 and above

GSM/GPRS/
EGPRS LA

Revision: D.03 and above

Programming Example

OUTPUT 714;"SETUP:PFERROR:TBDemod OPTimal"
! Sets the Tail Bit Demodulation parameter to OPTimal.

SETup:PFERror:TIMeout[:STIMe]

Function

GSM TA

This command sets/queries the phase and frequency error measurement timeout value in seconds and sets the timeout state to on in the active (that is the selected) format. The units (S|MS) are optional, if no units are specified then unit default to S (seconds).

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

Range: 0.1 to 999 seconds
Resolution: 0.1 seconds

Query

Range: 0.1 to 999 seconds
Resolution: 0.1 seconds
*RST Setting

10 seconds
Requirements

GSM/GPRS/
EGPRS TA

Revision: A.01 and above

GSM/GPRS/
EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETUP:PFERROR:TIMEOUT:STIME 3"
! Sets the timeout state to on and the timeout value to 3 seconds.

SETup:PFERror:TIMeout:TIME

Function

GSM TA

This command sets/queries the timeout value in seconds that will be used for phase and frequency error measurements when the timeout state is ON in the active (that is the selected) format. The units (S|MS) are optional, if no units are specified then unit default to S (seconds).

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

Range: 0.1 to 999 seconds
Resolution: 0.1 seconds

Query

Range: 0.1 to 999 seconds
Resolution: 0.1 seconds
*RST Setting 10 seconds
Requirements

GSM/GPRS/
EGPRS TA

Revision: A.01 and above

GSM/GPRS/
EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETUP:PFERROR:TIMEOUT:TIME 4"
! Sets the timeout value to 4 seconds.

SETup:PFERror:TIMeout:STATe

Function

GSM TA

This command selects/queries the timeout state for a phase and frequency error measurement in the active (that is the selected) format.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

0 | OFF | 1 | ON

Query

0 | 1
*RST Setting 0 | OFF
Requirements

GSM/GPRS/
EGPRS TA

Revision: A.01 and above

GSM/GPRS/
EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETUP:PFERROR:TIMEOUT:STATE ON"
! Sets the timeout state to on for a Phase/Frequency measurement.

SETup:PFERror:TRIGger:DELay

Function

GSM TA

This command sets/queries the trigger delay time in seconds for a phase and frequency error measurement in the active (that is the selected) format. The units (S|MS|US|NS) are optional, if no units are specified then units default to S (seconds).

See Phase and Frequency Error Measurement Description .

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

Range: -2.31 ms to +2.31 ms

Resolution: 5 significant digits or 100 ns, whichever is greater

Query

Range: -2.31 ms to +2.31 ms

Resolution: 5 significant digits or 100 ns, whichever is greater
*RST Setting

0 seconds
Requirements

GSM/GPRS/
EGPRS TA

Revision: A.01 and above

GSM/GPRS/
EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETUP:PFERROR:TRIGGER:DELAY 1.2MS"
! Sets trigger delay time to 1.2 milliseconds

SETup:PFERror:TRIGer:SOURce

Function

GSM TA

This command sets/queries the trigger source for phase and frequency error measurements in the active (that is the selected) format. See Phase and Frequency Error Measurement Description .

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

AUTO | PROTocol | RISE | IMMediate

See Triggering of Measurements .

Query

AUTO | PROT | RISE | IMM
*RST Setting

AUTO
Requirements

GSM/GPRS/
EGPRS TA

Revision: A.01 and above

GSM/GPRS/
EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETUP:PFERROR:TRIGGER:SOURCE AUTO"
! Sets trigger source to automatic.

SETup:PFERror:TRIGger:QUALifier[:SELected]

Function

GSM TA

This command selects/queries the trigger qualifier for phase and frequency error measurements. See Trigger Qualification Description .

GPRS TA

EGPRS TA
GSM/GPRS LA

EGPRS LA
Setting

Range: 0 | OFF | 1 | ON

Query

Range: 0 | 1
*RST Setting

The *RST value of this command depends on the format that is currently active. For example, if the GSM format is currently active, the *RST value for this command is the same value as the equivalent command containing the :GSM format identifier.
Requirements

GSM/GPRS/
EGPRS TA

Revision: A.01 and above

GSM/GPRS/
EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETUP:PFERROR:TRIGGER:QUALIFIER OFF"
! Sets trigger qualifier state to off.

SETup:PFERror:TRIGger:QUALifier:GSM

Function

GSM TA

This command selects/queries the trigger qualifier for phase and frequency error measurements in the GSM format whether or not that format is active. See Trigger Qualification Description .

GSM/GPRS LA

EGPRS LA
GPRS TA | This command is not applicable to GPRS.
EGPRS TA | This command is not applicable to EGPRS.
Setting

Range: 0 | OFF | 1 | ON

Query

Range: 0 | 1
*RST Setting

1 | ON

Requirements

GSM/GPRS/
EGPRS TA

Revision: A.01 and above

GSM/GPRS/
EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETUP:PFERROR:TRIGGER:QUALIFIER:GSM OFF"
! Sets trigger qualifier state to off.


SETup:PVTime

SETup:PVTime

GPIB Command Conventions

  • SETup:PVTime:BURSt:CAPTure
  • SETup:PVTime[:BURSt[1]]:MASK[:SELected]
  • SETup:PVTime:BURSt2|3|4|5|6:MASK[:SELected]
  • SETup:PVTime[:BURSt[1]]:MASK:GPERiod
  • SETup:PVTime:BURSt2|3|4|5:MASK:GPERiod
  • SETup:PVTime[:BURSt[1]]:MASK:GPERiod:CUSTom:HIGH
  • SETup:PVTime[:BURSt[1]]:MASK:GPERiod:CUSTom:LOW
  • SETup:PVTime[:BURSt[1]]:MASK[:SELected]:LOWer?
  • SETup:PVTime:BURSt2|3|4|5|6:MASK[:SELected]:LOWer?
  • SETup:PVTime[:BURSt[1]]:MASK[:SELected]:LOWer:POINts?
  • SETup:PVTime:BURSt2|3|4|5|6:MASK[:SELected]:LOWer:POINts?
  • SETup:PVTime[:BURSt[1]]:MASK[:SELected]:UPPer?
  • SETup:PVTime:BURSt2|3|4|5|6:MASK[:SELected]:UPPer?
  • SETup:PVTime[:BURSt[1]]:MASK[:SELected]:UPPer:POINts?
  • SETup:PVTime:BURSt2|3|4|5|6:MASK[:SELected]:UPPer:POINts?
  • SETup:PVTime[:BURSt[1]]:TIME[:OFFSet][:SELected]
  • SETup:PVTime:BURSt2|3|4|5|6:TIME[:OFFSet][:SELected]
  • SETup:PVTime[:BURSt[1]]:TIME:POINts[:SELected]?
  • SETup:PVTime:BURSt2|3|4|5|6:TIME:POINts[:SELected]?
  • SETup:PVTime:CONTinuous[:SELected]
  • SETup:PVTime:COUNt[:SNUMber]
  • SETup:PVTime:COUNt:NUMBer
  • SETup:PVTime:COUNt:STATe
  • SETup:PVTime:CUSTom1:MASK:LOWer?
  • SETup:PVTime:CUSTom2:MASK:LOWer?
  • SETup:PVTime:CUSTom1:MASK:LOWer:POINts?
  • SETup:PVTime:CUSTom2:MASK:LOWer:POINts?
  • SETup:PVTime:CUSTom1:MASK:UPPer?
  • SETup:PVTime:CUSTom2:MASK:UPPer?
  • SETup:PVTime:CUSTom1:MASK:UPPer:POINts?
  • SETup:PVTime:CUSTom2:MASK:UPPer:POINts?
  • SETup:PVTime:ETXPower[:METHod]
  • SETup:PVTime:GRAPh:POWer:REFerence
  • SETup:PVTime:GRAPh:STATe
  • SETup:PVTime:GRAPh:TIME:REFerence
  • SETup:PVTime:LIMit:ETSI:PCS
  • SETup:PVTime:RANGing[:MODE]
  • SETup:PVTime:BSYNc
  • SETup:PVTime:SYNC
  • SETup:PVTime:TIMeout[:STIMe]
  • SETup:PVTime:TIMeout:TIME
  • SETup:PVTime:TIMeout:STATe
  • SETup:PVTime:TRIGger:DELay
  • SETup:PVTime:TRIGger:SOURce
  • SETup:PVTime:VIDeo:FILTer:BWIDth

SETup:PVTime:BURSt:CAPTure

Function

GSM TA

 This command sets/queries the Burst Capture Range for TX power measurement. See Burst Capture Range

GPRS TA

GSM/GPRS LA

EGPRS LA

EGPRS TA
Setting

SINGle | ALL

Query

 SING | ALL
*RST Setting SINGle
Requirements

GSM/GPRS/
EGPRS TA

Revision: A.08 and above

GSM/GPRS/
EGPRS LA

Revision: E.02 and above

Programming Example

OUTPUT 714;"SETup:TXPower:BURSt:CAPTure SINGle"
! Sets Burst Capture Range to SINGle.

SETup:PVTime[:BURSt[1]]:MASK[:SELected]

SETup:PVTime:BURSt2|3|4|5|6:MASK[:SELected]

Function

GSM TA

This command sets/queries the type of mask to be used for the specified burst in the single slot or multislot configuration.

Setting this command to ETSI selects the appropriate ETSI compliant mask for the specified burst.

Setting this command to CUSTom1 selects the user-defined CUSTOM 1 mask for the specified burst.

Setting this command to CUSTom2 selects the user-defined CUSTOM 2 mask for the specified burst.

Setting this command to NOMask disables mask checking for the specified burst.

Note that if you want to select a custom mask (CUSTOM 1 or CUSTOM 2), you need to configure the mask settings before use.

EGPRS LA

GSM/GPRS LA

GPRS TA

EGPRS TA
Setting

ETSI | CUSTom1|CUSTom2|NOMask

Query

ETSI | CUST1|CUST2|NOM
*RST Setting

ETSI
Requirements

GSM/GPRS/
EGPRS TA

Revision: A.01 and above

Revision: A.08 adds Burst 3 and 4

Revision: A.09 adds Burst 5

GSM/GPRS/
EGPRS LA

Revision: C.01 and above

Revision: E.02 adds Burst 3 and 4

Revision: F.01 adds Burst 5

Revision: G.00.00 adds Burst 6

Programming Example

OUTPUT 714;"SETUP:PVTIME:BURST:MASK CUSTOM1"
! Sets burst 1 to use the custom1 mask for the pass/fail comparison

SETup:PVTime[:BURSt[1]]:MASK:GPERiod

SETup:PVTime:BURSt2|3|4|5:MASK:GPERiod

Function

GSM TA

This command sets/queries the guard period mask type for Power versus Time measurements.

Setting this command to ETSI selects the ETSI compliant mask for the guard period.

Setting this command to CUSTom selects the user-defined CUSTOM mask for the guard period.

Setting this command to NOMask disables mask checking for the guard period.

EGPRS LA

GSM/GPRS LA

GPRS TA

EGPRS TA
Setting

ETSI | CUSTom|NOMask

Query

ETSI | CUST||NOM
*RST Setting

ETSI
Requirements

GSM/GPRS/
EGPRS TA

Revision: A.01 and above

Revision: A.08 adds Burst 2 and 3

Revision: A.09 adds Burst 4

GSM/GPRS/
EGPRS LA

Revision: C.01 and above

Revision: E.02 adds Burst 2 and 3

Revision: F.01 adds Burst 4

Revision: G.00.00 adds Burst 5

Programming Example

OUTPUT 714;"SETUP:PVT:BURST1:MASK:GPERIOD CUSTOM
! Sets the measurement to use the custom guard period settings.

SETup:PVTime[:BURSt[1]]:MASK:GPERiod:CUSTom:HIGH

Function

GSM TA

This command sets/queries the custom guard period high level offset. This is the guard period level in dBc relative to the first burst's carrier power level.

EGPRS LA

GSM/GPRS LA

GPRS TA

EGPRS TA
Setting

Range: -200 dB to +200 dB

Resolution: 0.01 dB

Query

Range: -200 dB to +200 dB

Resolution: 0.01 dB
*RST Setting

+1 dBc (relative to the previous burst)
Requirements

GSM/GPRS/
EGPRS TA

Revision: A.01 and above

GSM/GPRS/
EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETUP:PVTIME:BURST1:MASK:GPERIOD:CUSTOM:HIGH 2"
! Sets the custom guard period high value to be 2 dBc

SETup:PVTime[:BURSt[1]]:MASK:GPERiod:CUSTom:LOW

Function

GSM TA

This command sets/queries the custom guard period low level offset. This is the guard period level in dBc relative to the second burst's carrier power level.

EGPRS LA

GSM/GPRS LA

GPRS TA

EGPRS TA
Setting

Range: -200 dB to +200 dB

Resolution: 0.01 dB

Query

Range: -200 dB to +200 dB

Resolution: 0.01 dB
*RST Setting

+4 dBc (relative to the next burst)
Requirements

GSM/GPRS/
EGPRS TA

Revision: A.01 and above

GSM/GPRS/
EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETUP:PVTIME:BURST1:MASK:GPERIOD:CUSTOM:LOW 5"
! Sets the custom guard period low value to be 5dBc

SETup:PVTime[:BURSt[1]]:MASK[:SELected]:LOWer?

SETup:PVTime:BURSt2|3|4|5|6:MASK[:SELected]:LOWer?

Function

GSM TA

This query returns the lower limits for the actual mask being used by the specified burst.

EGPRS LA

GSM/GPRS LA

GPRS TA

EGPRS TA

Query

Range:
0 to 32 comma-separated triple values containing Time, Relative Power, and Absolute Power within the following ranges:

  • Time: -50 us to 593 us
  • Relative Power and Absolute Power: -200 to +200 dBc and 9.91E+37 (NAN) for Absolute Power values.

Resolution:

  • Time: 1 ns
  • Relative Power and Absolute Power: 0.1 dB
Requirements

GSM/GPRS/
EGPRS TA

Revision: A.01 and above

Revision: A.08 adds Burst 3 and 4

Revision: A.09 adds Burst 5

GSM/GPRS/
EGPRS LA

Revision: C.01 and above

Revision: E.02 adds Burst 3 and 4

Revision: F.01 adds Burst 5

Revision: G.00.00 adds Burst 6

SETup:PVTime[:BURSt[1]]:MASK[:SELected]:LOWer:POINts?

SETup:PVTime:BURSt2|3|4|5|6:MASK[:SELected]:LOWer:POINts?

Function | GSM TA | This query returns the number of reference points for the lower mask being used by the specified burst.
 | EGPRS LA
 | GSM/GPRS LA
 | GPRS TA
 | EGPRS TA
Query |  | Range: 0 to 32 Resolution: 1
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.01 and above Revision: A.08 adds Burst 3 and 4 Revision: A.09 adds Burst 5
 | GSM/GPRS/ EGPRS LA | Revision: C.01 and above Revision: E.02 adds Burst 3 and 4 Revision: F.01 adds Burst 5 Revision: G.00.00 adds Burst 6

SETup:PVTime[:BURSt[1]]:MASK[:SELected]:UPPer?

SETup:PVTime:BURSt2|3|4|5|6:MASK[:SELected]:UPPer?

Function

GSM TA

This query returns the upper limits for the actual mask being used by the specified burst.

EGPRS LA

GSM/GPRS LA

GPRS TA

EGPRS TA

Query

Range:
0 to 32 comma-separated triple values containing Time, Relative Power, and Absolute Power within the following ranges:

  • Time: -50 us to 593 us
  • Relative Power and Absolute Power: -200 to +200 dBc and 9.91E+37 (NAN) for Absolute Power values.

Resolution:

  • Time: 1 ns
  • Relative Power and Absolute Power: 0.1 dB
Requirements

GSM/GPRS/
EGPRS TA

Revision: A.01 and above

Revision: A.08 adds Burst 3 and 4

Revision: A.09 adds Burst 5

GSM/GPRS/
EGPRS LA

Revision: C.01 and above

Revision: E.02 adds Burst 3 and 4

Revision: F.01 adds Burst 5

Revision: G.00.00 adds Burst 6

SETup:PVTime[:BURSt[1]]:MASK[:SELected]:UPPer:POINts?

SETup:PVTime:BURSt2|3|4|5|6:MASK[:SELected]:UPPer:POINts?

Function | GSM TA | This query returns the number of reference points for the lower mask being used by the specified burst.
 | EGPRS LA
 | GSM/GPRS LA
 | GPRS TA
 | EGPRS TA
Query |  | Range: 0 to 32 Resolution: 1
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.01 and above Revision: A.08 adds Burst 3 and 4 Revision: A.09 adds Burst 5
 | GSM/GPRS/ EGPRS LA | Revision: C.01 and above Revision: E.02 adds Burst 3 and 4 Revision: F.01 adds Burst 5 Revision: G.00.00 adds Burst 6

SETup:PVTime[:BURSt[1]]:TIME[:OFFSet][:SELected]

SETup:PVTime:BURSt2|3|4|5|6:TIME[:OFFSet][:SELected]

Function

GSM TA

This command sets/queries the time offsets (for the specified burst of the multislot configuration) for the power vs time power measurement, (not the mask measurement) in the active (that is the selected) format.

All 12 time offsets are set to on by default. If less than 12 values are sent with this command, the remaining offsets are turned off, see Power versus Time Measurement Description . These values are referenced to the occurrence of bit 0 in a normal burst.

The units (S|MS|US|NS) are optional, if no units are specified then units default to S.

EGPRS LA

GSM/GPRS LA

GPRS TA

EGPRS TA
Setting

Range: 0 to 12 comma-separated values ranging from: -50 us to 590 us

Note that there is a further restriction on this range to ensure that a valid result is returned when testing a GPRS mobile which supports a multislot configuration with two uplink timeslots. For more details, see Time Offset Range Restrictions for GPRS and EGPRS Mobiles .

Resolution: 1 ns

Query

Range: 1 to 12 comma-separated values ranging from: -50 us to 590 us and 9.91E+37 (NAN) if no offsets are specified

Resolution: 1 ns

*RST Setting

Time offsets 1 through 12 are on and set to these values:

Burst 1

  • time offset 1 = -28 us

  • time offset 2 = -18 us

  • time offset 3 = -10 us

  • time offset 4 = 0 us

  • time offset 5 = 321.2 us

  • time offset 6 = 331.2 us

  • time offset 7 = 339.2 us

  • time offset 8 = 349.2 ms

  • time offset 9 = 542.8 us

  • time offset 10 = 552.8 us

  • time offset 11 = 560.8 us

    time offset 12 = 570.8 us

Burst 2

  • time offset 1 = 0 us

  • time offset 2 = 0 us

  • time offset 3 = 0 us

  • time offset 4 = 0 us

  • time offset 5 = 321.2 us

  • time offset 6 = 331.2 us

  • time offset 7 = 339.2 us

  • time offset 8 = 349.2 us

  • time offset 9 = 542.8 us

  • time offset 10 = 552.8 us

  • time offset 11 = 560.8 us

  • time offset 12 = 570.8 us
Requirements

GSM/GPRS/
EGPRS TA

Revision: A.01 and above

Revision: A.08 adds Burst 3 and 4

Revision: A.09 adds Burst 5

GSM/GPRS/
EGPRS LA

Revision: C.01 and above

Revision: E.02 adds Burst 3 and 4

Revision: F.01 adds Burst 5

Revision: G.00.00 adds Burst 6

Programming Example

OUTPUT 714;"SETUP:PVTIME:BURSt2:TIME:OFFSET 0US, 0US, 0US, 0US, 321.2.0US, 331.2US"
! Configures the first six time offset points and turns the remaining six off for burst 2.
! Using the query form of this command would return six time offset values.

SETup:PVTime[:BURSt[1]]:TIME:POINts[:SELected]?

SETup:PVTime:BURSt2|3|4|5|6:TIME:POINts[:SELected]?

Function

GSM TA

This command queries the number of the specified burst's Measurement Offset points that are turned on during a power versus time measurement in the active (that is the selected) format.

This command is useful for determining how many time values are returned in a comma-separated list when the SETup:PVTime[:BURSt[1]]:TIME[:OFFSet][:SELected] query is sent, and how many power values are returned when the FETCh:PVTime[:BURSt[1]]:POWer[:ALL][:MAXimum]? command is sent.

EGPRS LA

GSM/GPRS LA

GPRS TA

EGPRS TA

Query

Range: 0 to 12

Resolution: 1
*RST Setting 12
Requirements

GSM/GPRS/
EGPRS TA

Revision: A.01 and above

Revision: A.08 adds Burst 3 and 4

Revision: A.09 adds Burst 5

GSM/GPRS/
EGPRS LA

Revision: C.01 and above

Revision: E.02 adds Burst 3 and 4

Revision: F.01 adds Burst 5

Revision: G.00.00 adds Burst 6

SETup:PVTime:CONTinuous[:SELected]

Function

GSM TA

This command sets/queries the trigger state for power versus time measurements in the active (that is the selected) format. See Measurement States .

GPRS TA
EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

Range:

  • Single trigger mode = 0 | OFF
  • Continuous trigger mode = 1 | ON

Query

Range: 0 | 1
*RST Setting 1
Requirements

GSM/GPRS/
EGPRS TA

Revision: A.01 and above

GSM/GPRS/
EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETUP:PVTIME:CONTINUOUS OFF"
! Specifies single trigger mode for power versus time measurements.

SETup:PVTime:COUNt[:SNUMber]

Function

GSM TA

This command sets/queries the number of power versus time measurements made by the test set. This command sets the count state to ON for this value to take effect.

EGPRS LA

GSM/GPRS LA

GPRS TA

EGPRS TA
Setting

Range: 1 to 999

Resolution: 1

Query

Range: 1 to 999

Resolution: 1
*RST Setting 10
Requirements

GSM/GPRS/
EGPRS TA

Revision: A.01 and above

GSM/GPRS/
EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETUP:PVTIME:COUNT:SNUMBER 25"
! Sets the state to on and the multi-measurement count value to 25.

SETup:PVTime:COUNt:NUMBer

Function

GSM TA

This command sets/queries the number of Power vs Time measurements made by the test set. The multi-measurement count state must be on.

EGPRS LA

GSM/GPRS LA

GPRS TA

EGPRS TA
Setting

Range: 1 to 999

Resolution: 1

Query

Range: 1 to 999

Resolution: 1
*RST Setting 10
Requirements

GSM/GPRS/
EGPRS TA

Revision: A.01 and above

GSM/GPRS/
EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETUP:PVTIME:COUNT:NUMBER 20"
! Sets multi-measurement count value to 20.

SETup:PVTime:COUNt:STATe

Function

GSM TA

This command sets/queries the power versus time multi-measurement count state in the active (that is the selected) format.

EGPRS LA

GSM/GPRS LA

GPRS TA

EGPRS TA
Setting

Range: 0 | OFF | 1 | ON

Query

Range: 0 | 1
*RST Setting

0 | OFF
Requirements

GSM/GPRS/
EGPRS TA

Revision: A.01 and above

GSM/GPRS/
EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETUP:PVTIME:COUNT:STATE ON"
! Sets multi-measurement count state to on.

SETup:PVTime:CUSTom1:MASK:LOWer?

SETup:PVTime:CUSTom2:MASK:LOWer?

Function

GSM TA

This command sets/queries the lower limits for the specified custom mask to be used with the Power versus Time measurement.

A total of 32 reference points are available to you when defining a custom mask. All custom masks have a step profile rather than a linearly interpolated profile. Each custom mask has a fixed starting point which is located -50 us relative to the middle of the zero-th symbol (that is, T0). All mask reference points that you specify are end points of one section of the custom mask.

If you use this command without specifying any parameters, the previously defined mask is cleared.

EGPRS LA

GSM/GPRS LA

GPRS TA

EGPRS TA
Setting

Range:
0 to 32 comma-separated value pairs containing Time and Relative Power within the following ranges:

  • Time: -50 us to 593 us
  • Relative Power and Absolute Power: -200 to +200 dBc

Resolution:

  • Time: 1 ns
  • Relative Power: 0.1 dB

Query

Range:
0 to 32 comma-separated value pairs containing Time and Relative Power within the following ranges:

  • Time: -50 us to 593 us and 9.91E+37 (NAN) if no offsets are specified
  • Relative Power and Absolute Power: -200 to +200 dBc

Resolution:

  • Time: 1 ns
  • Relative Power: 0.1 dB
*RST Setting ETSI GMSK Mask
Requirements

GSM/GPRS/
EGPRS TA

Revision: A.01 and above

GSM/GPRS/
EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETUP:PVTIME:CUSTOM1:MASK:LOWER 0us, -2, 300us, 3
! Sets the first 2 points of the lower custom mask.  All other points are blanked.

SETup:PVTime:CUSTom1:MASK:LOWer:POINts?

SETup:PVTime:CUSTom2:MASK:LOWer:POINts?

Function | GSM TA | This query returns the number of reference points for the specified user settable lower mask.
 | EGPRS LA
 | GSM/GPRS LA
 | GPRS TA
 | EGPRS TA
Query |  | Range: 0 to 32 Resolution: 1
*RST Setting |  | 0
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.01 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.01 and above

SETup:PVTime:CUSTom1:MASK:UPPer?

SETup:PVTime:CUSTom2:MASK:UPPer?

Function

GSM TA

This command sets/queries the upper limits for the specified custom mask to be used with the Power versus Time measurement.

A total of 32 reference points are available to you when defining a custom mask. All custom masks have a step profile rather than a linearly interpolated profile. Each custom mask has a fixed starting point which is located -50 us relative to the middle of the zero-th symbol (that is, T0). All mask reference points that you specify are end points of one section of the custom mask.

If you use this command without specifying any parameters, the previously defined mask is cleared.

EGPRS LA

GSM/GPRS LA

GPRS TA

EGPRS TA
Setting

Range:
0 to 32 comma-separated value pairs containing Time and Relative Power within the following ranges:

  • Time: -50 us to 593 us
  • Relative Power and Absolute Power: -200 to +200 dBc

Resolution:

  • Time: 1 ns
  • Relative Power: 0.1 dB

Query

Range:
0 to 32 comma-separated value pairs containing Time and Relative Power within the following ranges:

  • Time: -50 us to 593 us and 9.91E+37 (NAN) if no offsets are specified
  • Relative Power and Absolute Power: -200 to +200 dBc

Resolution:

  • Time: 1 ns
  • Relative Power: 0.1 dB
*RST Setting ETSI GMSK Mask
Requirements

GSM/GPRS/
EGPRS TA

Revision: A.01 and above

GSM/GPRS/
EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETUP:PVTIME:CUSTOM1:MASK:UPPER -40us, 50, -20us, 10, 0us, 1, 300us, 2"
! Sets the first 4 points of the upper custom mask.  All other points are blanked.

SETup:PVTime:CUSTom1:MASK:UPPer:POINts?

SETup:PVTime:CUSTom2:MASK:UPPer:POINts?

Function | GSM TA | This query returns the number of reference points for the specified user settable upper mask.
 | EGPRS LA
 | GSM/GPRS LA
 | GPRS TA
 | EGPRS TA
Query |  | Range: 0 to 32 Resolution: 1
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.01 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.01 and above

SETup:PVTime:ETXPower[:METHod]

Function | GSM TA | This command is not applicable to GSM.
 | GPRS TA | This command is not applicable to GPRS.
 | GSM/GPRS LA | This command is not applicable to the GSM/GPRS LA.
 | EGPRS TA | This command allows you to specify how to calculate the Transmit Power (which constitutes the 0dB level in the mask). This command is only available in the 8PSK version of the Power versus Time measurement.
 | EGPRS LA
Setting |  | CARRier | BURSt
Query |  | CARR | BURS
*RST Setting |  | CARRier
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.03 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.03 and above

SETup:PVTime:GRAPh:POWer:REFerence

Function | GSM TA | This command sets/queries the reference value for the graph. See Graph Power Reference for more information
 | EGPRS LA
 | GSM/GPRS LA
 | GPRS TA
 | EGPRS TA
Setting |  | Range: STRongest | BURSt1 | BURSt2 | BURSt3 | BURSt4 | BURSt5
Query |  | Range: STRongest | BURS1 | BURS2 | BURS3 | BURS4 | BURS5
*RST Setting |  | STRongest
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.01 and above Revision: A.08 adds Burst 3 and 4 Revision: A.09 adds Burst 5
 | GSM/GPRS/ EGPRS LA | Revision: C.01 and above Revision: E.02 adds Burst 3 and 4 Revision: F.01 adds Burst 5 a

SETup:PVTime:GRAPh:STATe

Function

GSM TA

This command sets/queries the power versus time graphics state.

NOTE
Turning the graphics state ON causes the measurement time to increase significantly.

EGPRS LA

GSM/GPRS LA

GPRS TA

EGPRS TA
Setting

Range: 0 | OFF | 1 | ON

Query

Range: 0 | 1
*RST Setting

0 | OFF
Requirements

GSM/GPRS/
EGPRS TA

Revision: A.01 and above

GSM/GPRS/
EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SET:PVT:GRAP:STAT ON"
! Sets PvT graphic state to on.

SETup:PVTime:GRAPh:TIME:REFerence

Function | GSM TA | This command sets/queries the time reference for the graph. See Graph Power Reference for more information.
 | EGPRS LA
 | GSM/GPRS LA
 | GPRS TA
 | EGPRS TA
Setting |  | Range: BURSt1 | BURSt2 | BURSt3 | BURSt4 | BURSt5
Query |  | Range: BURS1 | BURS2 | BURS3 | BURS4 | BURS5
*RST Setting |  | BURSt1
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.01 and above Revision: A.08 adds Burst 3 and 4 Revision: A.09 adds Burst 5
 | GSM/GPRS/ EGPRS LA | Revision: C.01 and above Revision: E.02 adds Burst 3 and 4 Revision: F.01 adds Burst 5

SETup:PVTime:LIMit:ETSI:PCS

Function

GSM TA

This command sets/queries the mask specification used for the PCS band in the active (that is the selected) format. ETSI define a relaxed mask specification for the PCS band in 3GPP 51.010-1 section 13.3.5(c).

EGPRS LA

GSM/GPRS LA

GPRS TA

EGPRS TA
Setting

NARRow | RELaxed

Query

NARR | REL

*RST Setting NARRow
Requirements

GSM/GPRS/
EGPRS TA

Revision: A.01 and above

GSM/GPRS/
EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETUP:PVTIME:LIMIT:ETSI:PCS REL"
! Selects the relaxed mask specification for power versus time measurements in the PCS band.

SETup:PVTime:RANGing[:MODE]

Function

GSM TA

This command sets/queries the ranging mode for the power versus time measurement.

When set to High Linearity Mode (HLINearity), the hardware ranges for measuring the second burst such that the first burst never overranges the hardware by more than 20 dB. This will prevent overshoot sufficiently but it also reduces the dynamic range (since this solution lifts the noise floor). This High Linearity Mode results in less dynamic range.When set to High Dynamic Range Mode (HDynamic), the hardware is ranged when measuring the second burst based on its expected power level. Consequently the burst is optimal with regards to dynamic range but a large overrange (due to the first burst) will effect the amplitude accuracy at the beginning of the useful part of the second burst (This may result in an Overshoot condition).

EGPRS LA

GSM/GPRS LA

GPRS TA

EGPRS TA
Setting

HLINearity | HDYNamic

Query

HLIN | HDYN
*RST Setting

HLIN
Requirements

GSM/GPRS/
EGPRS TA

Revision: A.01 and above

GSM/GPRS/
EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETup:PVTime:RANGing:MODE HDYN"
! Selects high dynamic range mode.

SETup:PVTime:BSYNc

SETup:PVTime:SYNC

Function

GSM TA

This command sets/queries the burst synchronization mode for power versus time measurements in the active (that is the selected) format. See Burst Synchronization for more information.

EGPRS LA

GSM/GPRS LA

GPRS TA

EGPRS TA
Setting

MIDamble | AMPLitude | NONE

Query

MID | AMPL | NONE
*RST Setting

MID
Requirements

GSM/GPRS/
EGPRS TA

Revision: A.01 and above

GSM/GPRS/
EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETUP:PVTIME:SYNC MIDAMBLE"
! Selects burst synchronization to midamble for GPRS power versus time measurements.

SETup:PVTime:TIMeout[:STIMe]

Function

GSM TA

This command sets/queries the timeout value in seconds that is used for power versus time measurements in the active (that is the selected) format. This command also sets the timeout state to on. The units (S|MS) are optional, if no units are specified then units default to S.

EGPRS LA

GSM/GPRS LA

GPRS TA

EGPRS TA
Setting

Range: 0.1 to 999 seconds

Resolution: 0.1 seconds

Query

Range: 0.1 to 999 seconds

Resolution: 0.1 seconds
*RST Setting 10 seconds
Requirements

GSM/GPRS/
EGPRS TA

Revision: A.01 and above

GSM/GPRS/
EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETUP:PVTIME:TIMEOUT:STIME 4"
! Sets the state to on and the timeout value to 4 seconds.

SETup:PVTime:TIMeout:TIME

Function

GSM TA

This command sets/queries the timeout value in seconds that will be used for power versus time measurements in the active (that is the selected) format. The units (S|MS) are optional, if no units are specified then units default to S.

EGPRS LA

GSM/GPRS LA

GPRS TA

EGPRS TA
Setting

Range: 0.1 to 999 seconds

Resolution: 0.1 seconds

Query

Range: 0.1 to 999 seconds

Resolution: 0.1 seconds
*RST Setting

10 seconds
Requirements

GSM/GPRS/
EGPRS TA

Revision: A.01 and above

GSM/GPRS/
EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETUP:PVTIME:TIMEOUT:TIME 6"
! Sets the timeout value to 6 seconds.

SETup:PVTime:TIMeout:STATe

Function

GSM TA

This command sets/queries power versus time timeout state in the active (that is the selected) format.

EGPRS LA

GSM/GPRS LA

GPRS TA

EGPRS TA
Setting

Range: 0 | OFF | 1 | ON

Query

Range: 0 | 1
*RST Setting

0 | OFF
Requirements

GSM/GPRS/
EGPRS TA

Revision: A.01 and above

GSM/GPRS/
EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETUP:PVTIME:TIMEOUT:STATE ON"
! Sets timeout state to on.

SETup:PVTime:TRIGger:DELay

Function

GSM TA

This command selects/queries the trigger delay in seconds for power versus time measurements in the active (that is the selected) format. The units (S|MS|US|NS) are optional, if no units are specified then units default to S.

EGPRS LA

GSM/GPRS LA

GPRS TA

EGPRS TA
Setting

Range: -2.31 ms to +2.31 ms

Resolution: 5 significant digits or 100 ns, whichever is greater

Query

Range: -2.31 ms to +2.31 ms

Resolution: 5 significant digits or 100 ns, whichever is greater
*RST Setting 0 seconds
Requirements

GSM/GPRS/
EGPRS TA

Revision: A.01 and above

GSM/GPRS/
EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETUP:PVTIME:TRIGGER:DELAY 1.1MS"
! Sets trigger delay value to 1.1 milli-seconds.

SETup:PVTime:TRIGger:SOURce

Function

GSM TA

This command selects/queries the trigger source for power versus time measurements in the active (that is the selected) format. See Triggering of Measurements .

EGPRS LA

GSM/GPRS LA

GPRS TA

EGPRS TA
Setting

AUTO | PROTocol | RISE | IMMediate | EXTernal

Query

AUTO | PROT | RISE | IMM | EXT
*RST Setting

AUTO
Requirements

GSM/GPRS/
EGPRS TA

Revision: A.01 and above

GSM/GPRS/
EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETUP:PVTIME:TRIGGER:SOURCE AUTO"
! Sets trigger source to automatic.

SETup:PVTime:VIDeo:FILTer:BWIDth

Function

GSM TA

This command selects/queries the bandwidth of the video log filter.

EGPRS LA

GSM/GPRS LA

GPRS TA

EGPRS TA
Setting | VBW_WIDE | VBW_300K | VBW_100K | VBW_30K

Query

VBW_WIDE | VBW_300K | VBW_100K | VBW_30K
*RST Setting | VBW_WIDE
Requirements

GSM/GPRS/
EGPRS TA

Revision: A.05 and above

GSM/GPRS/
EGPRS LA

Revision: D.02 and above

Programming Example

OUTPUT 714;"SETup:PVTime:VIDeo:FILTer:BWIDth VBW_WIDE"
! Do not use video filtering.


SETup:SMONitor

SETup:SMONitor

GPIB Command Conventions

  • SETup:SMONitor:AMPLitude:PDIVision
  • SETup:SMONitor:AMPLitude:RLEVel:AUTO
  • SETup:SMONitor:AMPLitude:RLEVel:MANual
  • SETup:SMONitor:BANDwidth|BWIDth[:RESolution]?
  • SETup:SMONitor:BANDwidth|BWIDth:AUTO
  • SETup:SMONitor:BANDwidth|BWIDth:MANual
  • SETup:SMONitor:BANDwidth|BWIDth:ZSPan[:RESolution]
  • SETup:SMONitor:COUNt[:SNUMber]
  • SETup:SMONitor:COUNt:NUMber
  • SETup:SMONitor:COUNt:STATe
  • SETup:SMONitor:CONTinous
  • SETup:SMONitor:DETector[:TYPE]
  • SETup:SMONitor:FREQuency:SPAN
  • SETup:SMONitor:TIME:OFFSet
  • SETup:SMONitor:TIME:SPAN
  • SETup:SMONitor:TIMeout[:STIMe]
  • SETup:SMONitor:TIMeout:STATe
  • SETup:SMONitor:TIMeout:TIME
  • SETup:SMONitor:TRACe:MODE
  • SETup:SMONitor:TRiGger:DELay
  • SETup:SMONitor:TRiGger:SOURce

SETup:SMONitor:AMPLitude:PDIVision

Function

 GSM TA

This command sets the scale of the spectrum monitor's display in dB per division (dB/div).

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

Range: 0.1 to 20 dB

Resolution: 0.1

Query

Range: 0.1 to 20 dBResolution: 0.1
*RST Setting

10 dB

Requirements

GSM/GPRS/
EGPRS TA

Revision: A.01 and above

GSM/GPRS/
EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETup:SMONitor:AMPLitude:PDIVision 1DB"
! Sets scale of the spectrum monitor's display to 1 dB per division.

SETup:SMONitor:AMPLitude:RLEVel:AUTO

Function

 GSM TA

This command allows you to set whether or not the spectrum monitor's reference level is selected automatically by the test set. This parameter must be set to OFF before the test set uses the manual setting for the reference level.

The command to manually set the reference level is SETup:SMONitor:AMPLitude:RLEVel:MANual .

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

Range: 1 | ON | 0 | OFF

Query

Range: 1 | 0
*RST Setting

ON

Requirements

GSM/GPRS/
EGPRS TA

Revision: A.01 and above

GSM/GPRS/
EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETup:SMONitor:AMPLitude:RLEVel:AUTO ON"
! Sets spectrum monitor's reference level to set automatically.

SETup:SMONitor:AMPLitude:RLEVel:MANual

Function

 GSM TA

This command allows you to set the spectrum monitors actual reference level in dBm. The range settings are coupled to the amplitude offset value for the current value of the expected frequency (set using SYSTem:CORRection:[:SGAin] ). Changing the amplitude offset value does not change the reference value, unless the new value for the amplitude offset forces the current value of the reference level to exceed the range limits. If this happens the reference level is set to its limit.

The test set does not apply the manual setting until the command SETup:SMONitor:AMPLitude:RLEVel:AUTO is set to OFF.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

Range: (-50 dBm + Amplitude Offset) to +(37 dBm - Amplitude)

Resolution: 0.1 dB

Query

Range: (-50 dBm + Amplitude Offset) to +(37 dBm - Amplitude)Resolution: 0.1 dB
*RST Setting

+37 dB

Requirements

GSM/GPRS/
EGPRS TA

Revision: A.01 and above

GSM/GPRS/
EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETup:SMONitor:AMPLitude:RLEVel:MANual -20DBM"
! Sets spectrum monitor's manual reference level setting to -20 dBm.

SETup:SMONitor:BANDwidth|BWIDth[:RESolution]?

Function

 GSM TA

This command queries the resolution bandwidth being used by the spectrum monitor measurement. This command returns the resolution bandwidth regardless of whether the bandwidth was set manually or automatically.

The command that configures the test set to automatically determine the resolution bandwidth based on the Frequency Span setting is SETup:SMONitor:BANDwidth|BWIDth:AUTO . When the resolution bandwidth is not set to Auto, you can manually configure the resolution bandwidth with the command SETup:SMONitor:BANDwidth|BWIDth:MANual .

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Range: 300 kHz to 5 MHz
*RST Setting 30000 Hz

Requirements

GSM/GPRS/
EGPRS TA

Revision: A.01 and above

GSM/GPRS/
EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETup:SMONitor:BANDwidth?"
! Returns the spectrum monitor's resolution bandwidth.

SETup:SMONitor:BANDwidth|BWIDth:AUTO

Function

 GSM TA

This command sets/queries the Spectrum Monitor Resolution Bandwidth Coupling State. When the state of this parameter is ON the Resolution Bandwidth is determined by the Frequency Span setting ( SETup:SMONitor:FREQuency:SPAN ). When this parameter is set to OFF the Frequency Span and the Resolution Bandwidth parameters are decoupled and can be set separately to any valid Frequency Span and Resolution Bandwidth. See Table 1: Frequency Span, Resolution Bandwidth and Dynamic Range for the complete list of valid settings for Frequency Span and Resolution Bandwidth.

The command to set the resolution bandwidth is SETup:SMONitor:BANDwidth|BWIDth:MANual .

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0
*RST Setting 1

Requirements

GSM/GPRS/
EGPRS TA

Revision: A.05 and above

GSM/GPRS/
EGPRS LA

Revision: D.02 and above

Programming Example

OUTPUT 714;"SETup:SMONitor:BAND:AUTO 0"
! Turns Spectrum Monitor Resolution Bandwidth Coupling parameter OFF.

SETup:SMONitor:BANDwidth|BWIDth:MANual

Function

 GSM TA

This command sets/queries the value of the resolution bandwidth when SETup:SMONitor:BANDwidth|BWIDth:AUTO is set to OFF. When the state of this parameter is ON the Resolution Bandwidth is determined by the Frequency Span setting ( SETup:SMONitor:FREQuency:SPAN ).

When using this command the values in the Frequency Span and Resolution Bandwidth columns of Table 1: Frequency Span, Resolution Bandwidth and Dynamic Range are no longer coupled. Therefore, the Frequency Span and the Resolution Bandwidth parameters can be set to any value in the Frequency Span and Resolution Bandwidth columns, respectively.

The units (HZ|KHZ|MHZ) are optional, if no units are specified then the default is HZ.

Another command to query the resolution bandwidth is SETup:SMONitor:BANDwidth|BWIDth[:RESolution]? .

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA

Setting

Range: A value in the range 300 Hz to 5 MHz can be entered, however the value is rounded to a valid entry. The decision point for rounding up or down is the halfway point between the first valid entry below the setting and the first valid entry above the setting. The valid entries include:

Resolution Bandwidth: 300 Hz, 1 kHz, 3 kHz, 10 kHz, 30 kHz, 100 kHz, 300 kHz, 1 MHz, 5 MHz.

Query

 300 Hz, 1 kHz, 3 kHz, 10 kHz, 30 kHz, 100 kHz, 300 kHz, 1 MHz, 5 MHz.
*RST Setting 30 kHz

Requirements

GSM/GPRS/
EGPRS TA

Revision: A.05 and above

GSM/GPRS/
EGPRS LA

Revision: D.02 and above

Programming Example

OUTPUT 714;"SETup:SMONitor:BANDwidth:MANual 600 khz"
! Sets the Resolution Bandwidth to 300 kHz because the first valid entry below the setting is
! 300 kHz and the first valid entry above the setting is 1 MHz. The middle point between the two
! valid values is !650 kHz and since 600 kHz is below 650 kHz, the test set rounds 600 kHz to 300 kHz.

SETup:SMONitor:BANDwidth|BWIDth:ZSPan[:RESolution]

Function

 GSM TA

This command sets/queries the resolution bandwidth when the spectrum monitor is operating in zero span mode. To measure the total power of a signal you must select a resolution bandwidth greater than or equal to the signal bandwidth. To resolve two spectral components the resolution bandwidth must be less than the difference between them. The units (HZ|KHZ|MHZ) are optional, if no units are specified then the default is HZ.
To change the spectrum monitor to zero span mode, us the command SETup:SMONitor:FREQuency:SPAN , to set the frequency span to 0 Hz.

Any setting you enter is rounded to the nearest of the three settings.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

Range: 100 kHz | 300 kHz | 1 MHz

Query

Range: 100 kHz | 300 kHz | 1 MHz

*RST Setting 300 kHz

Requirements

GSM/GPRS/
EGPRS TA

Revision: A.01 and above

GSM/GPRS/
EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETup:SMONitor:BAND:ZSPan 100 KHZ"
! Sets spectrum monitor's zero span resolution bandwidth to 100 kHz.

SETup:SMONitor:COUNt[:SNUMber]

Function

 GSM TA

This command sets/queries the averaging count and turns on averaging.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

Range: 1 to 999

Query

Range: 1 to 999
*RST Setting

10

Requirements

GSM/GPRS/
EGPRS TA

Revision: A.01 and above

GSM/GPRS/
EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETup:SMONitor:COUNt 200"
! Sets the averaging count to 200 and sets the averaging the state to on.

SETup:SMONitor:COUNt:NUMber

Function

 GSM TA

This command sets/queries the averaging count used when the averaging is turned on.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

Range: 1 to 999

Query

Range: 1 to 999
*RST Setting

100

Requirements

GSM/GPRS/
EGPRS TA

Revision: A.01 and above

GSM/GPRS/
EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETup:SMONitor:COUNt:NUMBer 200"
! Sets the averaging count to 200.

SETup:SMONitor:COUNt:STATe

Function

 GSM TA

This command sets/queries the averaging state.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

Range: 1 | ON | 0 | OFF

Query

Range: 1 | 0
*RST Setting

OFF

Requirements

GSM/GPRS/
EGPRS TA

Revision: A.01 and above

GSM/GPRS/
EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETup:SMONitor:COUNt:STATe 1"
! Turns on averaging.

SETup:SMONitor:CONTinous

Function

 GSM TA

This command arms triggering for a measurement sweep. Trigger arming can be single (OFF) or continuous (ON). With single triggering, the measurement sweep starts when an INITiate or READ command is received. With continuous triggering, measurement sweeps initiate immediately and continuously.

The *RST (remote full preset) default setting is single triggering. At power-on or after a front-panel preset, the default setting is continuous triggering.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

Range: ON | 1 | OFF | 0

Query

Range: 1 | 0
*RST Setting OFF

Requirements

GSM/GPRS/
EGPRS TA

Revision: A.01 and above

GSM/GPRS/
EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETup:SMONitor:CONTinuous ON"
! Sets the trigger mode to continuous.

SETup:SMONitor:DETector[:TYPE]

Function

 GSM TA This command sets/queries the Spectrum Monitor Detection Method. There are three detection methods available in the test set's Spectrum Monitor: Peak Detection, Sample Detection, and RMS Detection. See Detection Method for more information.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

Range: PEAK|SAMPle|RMS

Query

Range: PEAK|SAMP|RMS
*RST Setting PEAK

Requirements

GSM/GPRS/
EGPRS TA

Revision: A.01 and above

Revision A.05 adds RMS

GSM/GPRS/
EGPRS LA

Revision: C.01 and above

Revision D.02 adds RMS

Programming Example

OUTPUT 714;"SETup:SMONitor:DETector RMS"
! Sets Detection Method to RMS.

SETup:SMONitor:FREQuency:SPAN

Function

 GSM TA

This command sets/queries the spectrum monitor's frequency span. If the Spectrum Monitor Resolution Bandwidth Coupling State is ON(see SETup:SMONitor:AMPLitude:RLEVel:AUTO ) the Frequency Span setting will automatically determine the resolution bandwidth. The couplings between the frequency span and the resolution bandwidth are shown in Table 1: Frequency Span, Resolution Bandwidth and Dynamic Range .

The units (HZ|KHZ|MHZ) are optional, if no units are specified then the default is HZ.

The command to set the resolution bandwidth is SETup:SMONitor:BANDwidth|BWIDth:MANual .

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

Range: A value in the range 125 kHz to 100 MHz can be entered, however the value is rounded to a valid entry. The decision point for rounding up or down is the halfway point between the first valid entry below the setting and the first valid entry above the setting.

  • 0 Hz, 125 kHz, 500 kHz, 1.25 MHz, 2.5 MHz, 4 MHz, 5 MHz, 10 MHz, 12 MHz, 20 MHz, 40 MHz, 80 MHz, 100 MHz
Query

Range: 0 Hz, 125 kHz, 500 kHz, 1.25 MHz, 2.5 MHz, 4 MHz, 5 MHz, 10 MHz, 12 MHz, 20 MHz, 40 MHz, 80 MHz, 100 MHz
*RST Setting 5 MHz

Requirements

GSM/GPRS/
EGPRS TA

Revision: A.01 and above

GSM/GPRS/
EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETup:SMONitor:FREQuency:SPAN 10MHZ"
! Sets the frequency span to 10 MHz.

SETup:SMONitor:TIME:OFFSet

Function

 GSM TA This command sets/queries the time offset. You can specify the time window for viewing the signal using this command and the SETup:SMONitor:TIME:SPAN . The measurement is made for the duration of the time span, beginning at the time defined by the trigger event plus the trigger delay plus the time offset. The units (S|MS|US|NS) are optional, if no units are specified then the default is S.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

Range: 0 us to 10 s

Resolution: 0.1 us
Query

Range: 0 us to 10 s

Resolution: 0.1 us
*RST Setting 0 us

Requirements

GSM/GPRS/
EGPRS TA

Revision: A.01 and above

GSM/GPRS/
EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETup:SMONitor:TIME:OFFSet 25 MS"
! Sets the spectrum monitor's time offset to 25 millisecond.

SETup:SMONitor:TIME:SPAN

Function

 GSM TA This command sets/queries the span of the time display. The units (S|MS|US) are optional, if no units are specified then the default is S.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

Range: 50 us to 70 ms

Resolution: 0.250 us
Query

Range: 50 us to 70 ms

Resolution: 0.250 us
*RST Setting 10 ms

Requirements

GSM/GPRS/
EGPRS TA

Revision: A.01 and above

GSM/GPRS/
EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETup:SMONitor:TIME:SPAN 30MS"
! Sets the spectrum monitor's time span to 30 millisecond.

SETup:SMONitor:TIMeout[:STIMe]

Function

 GSM TA

This command sets/queries the spectrum monitor's timeout interval and turns on the timeout state. The units (S|MS|US) are optional, if no units are specified then the default is S.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

Range: 1 to 999 seconds

Resolution: 0.1 second
Query

Range: 1 to 999 seconds

Resolution: 0.1 second
*RST Setting 10 s

Requirements

GSM/GPRS/
EGPRS TA

Revision: A.01 and above

GSM/GPRS/
EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETup:SMONitor:TIMeout:STIMe 12S"
! Turns on the timeout timer and sets the timer to expire in 12 seconds.

SETup:SMONitor:TIMeout:STATe

Function

 GSM TA

This command sets/queries the state of the spectrum monitor's timeout timer.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

Range: 1 | ON | 0 | OFF
Query

Range: 1 | 0
*RST Setting OFF

Requirements

GSM/GPRS/
EGPRS TA

Revision: A.01 and above

GSM/GPRS/
EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETup:SMONitor:TIMeout:STATe 1"
! Turns on the timeout timer.

SETup:SMONitor:TIMeout:TIME

Function

 GSM TA

This command sets/queries the spectrum monitor's timeout interval. The units (S|MS|US) are optional, if no units are specified then the default is S.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

Range: 1 to 999 seconds

Resolution: 0.1 seconds
Query

Range: 1 to 999 seconds

Resolution: 0.1 seconds
*RST Setting 10 seconds

Requirements

GSM/GPRS/
EGPRS TA

Revision: A.01 and above

GSM/GPRS/
EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETup:SMONitor:TIMeout:TIME 20S"
! Generates a timeout error if no results are reported within 20 seconds.

SETup:SMONitor:TRACe:MODE

Function

 GSM TA

This command sets/queries the trace update parameter.

  • WRITe (Clear-write) erases any data previously stored in the selected trace.
  • MAXHold (maximum hold) maintains the maximum level for each trace point of the selected trace and updates each trace point if a new maximum level is detected in successive sweeps.
  • MINHold (minimum hold) maintains the minimum level for each trace point of the selected trace and updates each trace point if a new minimum level is detected in successive sweeps.

If you change the center, start, or the frequency span, or the resolution bandwidth, the MAXHold and MINHold traces are restarted. These traces are not restarted if you change only the reference level or the scale.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

Range: WRITe | MAXHold | MINHold
Query

Range: WRIT | MAXH | MINH
*RST Setting WRITe

Requirements

GSM/GPRS/
EGPRS TA

Revision: A.01 and above

GSM/GPRS/
EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETup:SMONitor:TRACe:MODE MAXH"
! Sets the update method to maximim hold.

SETup:SMONitor:TRiGger:DELay

Function

 GSM TA

This command sets/queries the trigger delay. This command allows you to add a time delay following the trigger event before samples are taken. The delay can be positive or negative. The units (S|MS|US) are optional, if no units are specified then the default is S.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

Range: -50 ms to +50 ms

Resolution: 5 significant digits or 100 ns, whichever is greater
Query

Range: -50 ms to +50 ms

Resolution: 5 significant digits or 100 ns, whichever is greater
*RST Setting 350 us

Requirements

GSM/GPRS/
EGPRS TA

Revision: A.01 and above

GSM/GPRS/
EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETup:SMONitor:TRIGger:DELay 1MS"
! Sets the trigger delay to 1 millisecond.

SETup:SMONitor:TRiGger:SOURce

Function

 GSM TA

This command sets the trigger source. Immediate triggering happens as soon as the measurement is armed. RF rise triggering is initiated by the rising edge of an RF burst. With protocol triggering, sampling is initiated by a signaling event such as the start of a burst. An external trigger is used when set to external.

GPRS TA

EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting

Range: IMMediate | PROTocol | RISE | EXTernal
Query

Range: IMM | PROT | RISE | EXT
*RST Setting IMMediate

Requirements

GSM/GPRS/
EGPRS TA

Revision: A.01 and above

GSM/GPRS/
EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETup:SMONitor:TRIGger:SOURce RISE"
! Sets the measurement to trigger on the rising edge of an RF burst.


SETup:TXPower

SETup:TXPower

GPIB Command Conventions

  • SETup:TXPower:BURSt:CAPTure
  • SETup:TXPower:CONTinuous
  • SETup:TXPower:COUNt[:SNUMber]
  • SETup:TXPower:COUNt:NUMBer
  • SETup:TXPower:COUNt:STATe
  • SETup:TXPower:ECPower:STATe
  • SETup:TXPower:FRAMe:QUALifier
  • SETup:TXPower:GFDTune:RSET
  • SETup:TXPower:GFDTune:THReshold
  • SETup:TXPower:RANGe:AUTO
  • SETup:TXPower:SSTep:FRAMes?
  • SETup:TXPower:TIMeout[:STIMe]
  • SETup:TXPower:TIMeout:TIME
  • SETup:TXPower:TIMeout:STATe
  • SETup:TXPower:TRIGger:DELay
  • SETup:TXPower:TRIGger:QUALifier
  • SETup:TXPower:TRIGger:SOURce

SETup:TXPower:BURSt:CAPTure

Function

GSM TA

 This command sets/queries the Burst Capture Range for TX power measurement. See Burst Capture Range

GPRS TA

GSM/GPRS LA

EGPRS LA

EGPRS TA
Setting

SINGle | ALL

Query

 SING | ALL
*RST Setting SINGle
Requirements

GSM/GPRS/
EGPRS TA

Revision: A.07 and above

GSM/GPRS/
EGPRS LA

Revision: E.01 and above

Programming Example

OUTPUT 714;"SETup:TXPower:BURSt:CAPTure SINGle"
! Sets Burst Capture Range to SINGle.

SETup:TXPower:CONTinuous

Function

GSM TA

This command sets/queries the trigger state for TX power measurements.

GPRS TA

GSM/GPRS LA

EGPRS LA

EGPRS TA
Setting

Range:

  • Single trigger mode = 0 | OFF
  • Continuous trigger mode = 1 | ON

Query

Range: 0 | 1
*RST Setting

0
Requirements

GSM/GPRS/
EGPRS TA

Revision: A.01 and above

GSM/GPRS/
EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETup:TXPower:CONTInuous OFF"
! Specifies single trigger mode for TX power measurements.

SETup:TXPower:COUNt[:SNUMber]

Function

GSM TA

This command sets/queries the number of TX power measurements made by the test set. This command sets the count state to ON. See Multi-measurement Count

GPRS TA

GSM/GPRS LA

EGPRS LA

EGPRS TA
Setting

Range: 1 to 999

Resolution: 1

Query

Range: 1 to 999

Resolution: 1
*RST Setting 10
Requirements

GSM/GPRS/
EGPRS TA

Revision: A.01 and above

GSM/GPRS/
EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETup:TXPower:COUNt:SNUMber 99"
! Sets the state to on and the multi-measurement count value to 99.

SETup:TXPower:COUNt:NUMBer

Function

GSM TA

This command sets/queries the number of TX power measurements the test set makes in the active (that is the selected) format. The multi-measurement count state must be on.

GPRS TA

GSM/GPRS LA

EGPRS LA

EGPRS TA
Setting

Range: 1 to 999

Resolution: 1

Query

Range: 1 to 999

Resolution: 1
*RST Setting 10
Requirements

GSM/GPRS/
EGPRS TA

Revision: A.01 and above

GSM/GPRS/
EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETup:TXPower:COUNt:NUMBer 5"
! Sets the TX Power multi-measurementcount number to 5.

SETup:TXPower:COUNt:STATe

Function

GSM TA

This command sets/queries the TX power multi-measurement count state.

GPRS TA

GSM/GPRS LA

EGPRS LA

EGPRS TA
Setting

Range: 0 | OFF | 1 | ON

Query

Range: 0 | 1
*RST Setting

0
Requirements

GSM/GPRS/
EGPRS TA

Revision: A.01 and above

GSM/GPRS/
EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETup:TXPower:COUNt:STATe ON"
! Sets the multi-measurement count state to on.

SETup:TXPower:ECPower:STATe

Function

GSM TA

This command is only applicable when the Burst Capture Range is set to All.

This command sets/queries the Estimated Carrier Power State. See Estimated Carrier Power

GPRS TA

GSM/GPRS LA

EGPRS LA

EGPRS TA
Setting Range: 0 | OFF | 1 | ON

Query

Range: 0 | 1
*RST Setting

1
Requirements

GSM/GPRS/
EGPRS TA

Revision: A.07 and above

GSM/GPRS/
EGPRS LA

Revision: E.01 and above

Programming Example

OUTPUT 714;"SETup:TXPower:ECPower:STATe ON"
! Sets the Estimated Carrier Power state to on.

SETup:TXPower:FRAMe:QUALifier

Function

GSM TA

This command sets/queries the frame qualification for TX power measurements when the operating mode is not Fast Device Tune. See Frame Qualification .

GPRS TA
GSM/GPRS LA

EGPRS LA

EGPRS TA
Setting

Range: 0 | OFF | 1 | ON

Query

Range: 0 | 1
*RST Setting 0
Requirements

GSM/GPRS/
EGPRS TA

Revision: A.07 and above

GSM/GPRS/
EGPRS LA

Revision: E.01 and above

Programming Example

OUTPUT 714;"SETup:TXPower:FRAMe:QUALifier ON"
! Sets TX Power meas Frame Qualification state to on.

SETup:TXPower:GFDTune:RSET

Function

GSM TA

 This command sets/queries the measurement results of which Uplink Sequence Step are returned when the FETCH GPIB commands other than FETCh:TXPower:TSEQuence and FETCh:TXP:SSTep are used. This parameter is only applicable when the operating mode is set to Fast Device Tune. See Fast Device Tune Result Set

GPRS TA

GSM/GPRS LA

EGPRS LA

EGPRS TA
Setting Range: 1 to 50
Resolution: 1

Query

 Range: 1 to 50
Resolution: 1
*RST Setting 1
Requirements

GSM/GPRS/
EGPRS TA

Revision: A.08 and above, with the required feature license.

GSM/GPRS/
EGPRS LA

Revision: E.02 and above.

Programming Example

OUTPUT 714;"SETup:TXPower:GFDTune:RSET 10"
! The results of USS 10 will be returned.

SETup:TXPower:GFDTune:THReshold

Function

GSM TA

 This command sets/queries the threshold for the first RF trigger in the Fast Device Tune operating mode. See Fast Device Tune Trigger Threshold

GPRS TA

GSM/GPRS LA

EGPRS LA

EGPRS TA
Setting Range: 10 dB to 35 dB
Resolution: 1 dB

Query

 Range: 10 dB to 35 dB
Resolution: 1 dB
*RST Setting 35 dB
Requirements

GSM/GPRS/
EGPRS TA

Revision: A.09 and above, with the required feature license.

GSM/GPRS/
EGPRS LA

Revision: F.01 and above.

Programming Example

OUTPUT 714;"SETup:TXPower:GFDTune:THReshold 10"
! Sets the Trigger Threshold to 10dB in the Fast Device Tune operating mode.

SETup:TXPower:RANGe:AUTO

Function

GSM TA

This command is only applicable when the Burst Capture Range is set to All.

This command set/queries whether the instrument ranges the hardware to the highest burst or not. See Auto Range to Highest Burst

GPRS TA
GSM/GPRS LA

EGPRS LA

EGPRS TA
Setting

Range: 0 | OFF | 1 | ON

Query

Range: 0 | 1
*RST Setting

0
Requirements

GSM/GPRS/
EGPRS TA

Revision: A.07 and above

GSM/GPRS/
EGPRS LA

Revision: E.01 and above

Programming Example

OUTPUT 714;"SETup:TXPower:RANGe:AUTO ON"
! Sets Auto-Ranging state to on.

SETup:TXPower:SSTep:FRAMes?

Function

GSM TA

 This command queries the number of uplink TDMA frames required in an uplink sequence step. This parameter is only applicable when the operating mode is set to Fast Device Tune. See Uplink Frames per Step .

GPRS TA
GSM/GPRS LA

EGPRS LA

EGPRS TA

Query

Range: 1 to 100000

Resolution: 1
*RST Setting -1
Requirements

GSM/GPRS/
EGPRS TA

Revision: A.08 and above, with the required feature license.

GSM/GPRS/
EGPRS LA

Revision: E.02 and above.

Programming Example

OUTPUT 714;"SETup:TXPower:SSTep FRAMes?
! Queries the uplink frames per sequence step in FDT mode.

SETup:TXPower:TIMeout[:STIMe]

Function

GSM TA

This command sets/queries the TX power measurement timeout value. This command also sets the count state to on. The units (S|MS) are optional, if no units are specified then units default to S. See Measurement Timeout .

GPRS TA
GSM/GPRS LA

EGPRS LA

EGPRS TA
Setting

Range: 0.1 to 999 seconds

Resolution: 0.1 seconds

Query

Range: 0.1 to 999 seconds

Resolution: 0.1 seconds
*RST Setting

10 seconds
Requirements

GSM/GPRS/
EGPRS TA

Revision: A.01 and above

GSM/GPRS/
EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETup:TXPower:TIMeout:STIMe 20"
! Sets the state to on and the timeout value to 20 seconds.

SETup:TXPower:TIMeout:TIME

Function

GSM TA

This command sets/queries the timeout value in seconds that will be used for TX power measurements in the active (that is the selected) format. The units (S|MS) are optional, if no units are specified then units default to S. See Measurement Timeout .

GPRS TA

GSM/GPRS LA

EGPRS LA

EGPRS TA
Setting

Range: 0.1 to 999 seconds

Resolution: 0.1 seconds

Query

Range: 0.1 to 999 seconds

Resolution: 0.1 seconds
*RST Setting

10 seconds
Requirements

GSM/GPRS/
EGPRS TA

Revision: A.01 and above

GSM/GPRS/
EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETup:TXPower:TIMeout:TIME 20"
! Sets the TX power measurement timeout to 20 seconds.

SETup:TXPower:TIMeout:STATe

Function

GSM TA

This command selects/queries TX power measurement timeout state in the active (that is the selected) format. See Measurement Timeout .

GPRS TA

GSM/GPRS LA

EGPRS LA

EGPRS TA
Setting

Range: 0 | OFF | 1 | ON

Query

Range: 0 | 1
*RST Setting

0
Requirements

GSM/GPRS/
EGPRS TA

Revision: A.01 and above

GSM/GPRS/
EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETup:TXPower:TIMeout:STATe 1"
! Turns the TX power timeout state on.

SETup:TXPower:TRIGger:DELay

Function

GSM TA

This command sets/queries the trigger delay in seconds for TX power measurements in the active (that is the selected) format. The units (S|MS|US|NS) are optional, if no units are specified then units default to S.

GPRS TA

GSM/GPRS LA
EGPRS LA

EGPRS TA
Setting

Range: -2.31 ms to +2.31 ms

Resolution: 5 significant digits or 100 ns, whichever is greater

Query

Range: -2.31 ms to +2.31 ms

Resolution: 5 significant digits or 100 ns, whichever is greater
*RST Setting 0 seconds
Requirements

GSM/GPRS/
EGPRS TA

Revision: A.01 and above

GSM/GPRS/
EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETup:TXPower:TRIGger:DELay 1.5MS"
! Set trigger delay time to 1.5 milliseconds

SETup:TXPower:TRIGger:QUALifier

Function

GSM TA

This command is only applicable when the Burst Capture Range is set to All.

This command sets/queries the trigger qualification for TX power measurements in the active (that is the selected) format. When ON, an automatic trigger re-arm occurs if a measurement is triggered when no valid signal (burst) is present. See Trigger Qualification Description .

GPRS TA
GSM/GPRS LA

EGPRS LA

EGPRS TA
Setting

Range: 0 | OFF | 1 | ON

Query

Range: 0 | 1
*RST Setting

1
Requirements

GSM/GPRS/
EGPRS TA

Revision: A.01 and above

GSM/GPRS/
EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETup:TXPower:TRIGger:QUALifier ON"
! Sets trigger qualifier state to on.

SETup:TXPower:TRIGger:SOURce

Function

GSM TA

This command selects/queries the trigger source for TX power measurements in the active (that is the selected) format. See Triggering of Measurements .

GPRS TA

GSM/GPRS LA

EGPRS LA

EGPRS TA
Setting

AUTO | PROTocol | RISE | IMMediate | EXTernal

Query

AUTO | PROT | RISE | IMM | EXT
*RST Setting

AUTO
Requirements

GSM/GPRS/
EGPRS TA

Revision: A.01 and above

GSM/GPRS/
EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SETup:TXPower:TRIGger:SOURce AUTO"
! Sets trigger source to automatic.


STATus Subsystem Description

STATus Subsystem Description

Description

The STATus subsystem is used to communicate current test set status information to the controlling application program.

Syntax Diagrams and Command Descriptions

STATus:OPERation

STATus:PRESet

STATus:QUEStionable

Standard Event Status Register
Status Byte Register

Status Register Bit Definitions

Status Byte Register Bit Assignments

Standard Event Status Register Bit Assignment

STATus:QUEStionable Condition Register Bit Assignment

STATus:QUEStionable:CALL Condition Register Bit Assignment

STATus:QUEStionable:CALL:GSM Condition Register Bit Assignment

STATus:QUEStionable:ERRors Condition Register Bit Assignment

STATus:QUEStionable:ERRors:GSM Condition Register Bit Assignment

STATus:QUEStionable:HARDware Condition Register Bit Assignment

STATus:OPERation Condition Register Bit Assignment

STATus:OPERation:CALL Condition Register Bit Assignment

STATus:OPERation:CALL:COMMon Condition Register Bit Assignment

STATus:OPERation:CALL:COMMon:DATA Condition Register Bit Assignment

STATus:OPERation:CALL:GSM Condition Register Bit Assignment

STATus:OPERation:FEATures Register Bit Assignments

STATus:OPERation:FEATures:COMMon Register Bit Assignments

STATus:OPERation:FEATures:COMMon:SMService Register Bit Assignments

STATus:OPERation:NMRReady Condition Register Bit Assignment

STATus:OPERation:NMRReady:GPRS Condition Register Bit Assignment

STATus:OPERation:NMRReady:GSM Condition Register Bit Assignment


STATus:OPERation

STATus:OPERation

GPIB Command Conventions

  • STATus:OPERation Condition Register Bit Assignment
  • STATus:OPERation:CALL Condition Register Bit Assignment
  • STATus:OPERation:CALL:COMMon Condition Register Bit Assignment
  • STATus:OPERation:CALL:COMMon:DAINterface Condition Register Bit Assignment
  • STATus:OPERation:CALL:COMMon:DATA Condition Register Bit Assignment
  • STATus:OPERation:CALL:GSM Condition Register Bit Assignment
  • STATus:OPERation:FEATures Register Bit Assignments
  • STATus:OPERation:FEATures:COMMon Register Bit Assignments
  • STATus:OPERation:FEATures:COMMon:SMService Register Bit Assignments
  • STATus:OPERation:HARDware Register Bit Assignments
  • STATus:OPERation:KEYPressed Register Bit Assignments
  • STATus:OPERation:NMRReady Condition Register Bit Assignment
  • STATus:OPERation:NMRReady:AMPS Condition Register Bit Assignment
  • STATus:OPERation:NMRReady:COMMon Condition Register Bit Assignment
  • STATus:OPERation:NMRReady:GPRS Condition Register Bit Assignment
  • STATus:OPERation:NMRReady:GSM Condition Register Bit Assignment

STATus:OPERation Condition Register Bit Assignment

The OPERation status register set contains bits which give an indication of conditions that are part of the test set's normal operation.

Bit Number | Binary Weighting | Condition | Description
15 | 32768 | Not Used. Defined by SCPI. | This bit is always 0.
14 | 16384 | Reserved for future use. | This bit is always 0.
13 | 8192 | Reserved for future use. | This bit is always 0.
12 | 4096 | Processing SYSTem:SYNChronized Command | This condition bit is "pulsed" by the SYSTem:SYNChronized command. This allows the status system to indicate that the input buffer is synchronized to the point where this command is parsed and that all prior sequential commands are completed and all prior overlapped commands have started.
11 | 2048 | Reserved for future use | This bit is always 0.
10 | 1024 | CALL Summary | This bit is the summary bit for the STATus:OPERation:CALL register.
9 | 512 | NMRReady (New Measurement Result Ready) Summary | This bit is the summary bit for the STATus:OPERation:NMRReady register.
8 | 256 | Reserved for future use. | This bit is always 0.
7 | 128 | Reserved for future use. | This bit is always 0.
6 | 64 | Reserved for future use. | This bit is always 0.
5 | 32 | Reserved for future use. | This bit is always 0.
4 | 16 | Reserved for future use. | This bit is always 0.
3 | 8 | Reserved for future use. | This bit is always 0.
2 | 4 | Reserved for future use. | This bit is always 0.
1 | 2 | Reserved for future use. | This bit is always 0.
0 | 1 | Extension Bit | This bit is always 0.

Program Examples - STATus:OPERation

OUTPUT 714;"STATUS:OPERATION:EVENT?" !Queries and clears the Operation
                                     !Event Register
OUTPUT 714;"STATUS:OPERATION:CONDITION?" !Queries and clears the Operation
                                         !Condition Register
OUTPUT 714;"STATUS:OPERATION:ENABLE 1024" !Sets the Operation
                                          !Enable
                                          !Register for bit 10
OUTPUT 714;"STATUS:OPERATION:NTRANSITION 2" !Sets the Operation
                                            !Negative Transition
                                            !Filter Register for bit 1
OUTPUT 714;"STATUS:OPERATION:PTRANSITION 2" !Sets the Operation
                                            !Positive Tranasition
                                            !Filter Register for bit 1

STATus:OPERation:CALL Condition Register Bit Assignment

The STATus:OPERation:CALL register bits are used to indicate status of processes that occur during normal call processing operations.

Bit Number | Binary Weighting | Condition | Description
15 | 32768 | Not Used. Defined by SCPI. | This bit is always 0.
14 | 16384 | Reserved for future use. | This bit is always 0.
13 | 8192 | Reserved for future use. | This bit is always 0.
12 | 4096 | GPRS Summary bit | This bit is the summary bit for the STATus:OPERation:CALL:GPRS register.
11 | 2048 | WCDMa Summary bit | This bit is the summary bit for the STATus:OPERation:CALL:WCDMa register.
10 | 1024 | FDD Summary bit | This bit is the summary bit for the STATus:OPERation:CALL:FDD register.
9 | 512 | TA2000 Summary bit | This bit is the summary bit for the STATus:OPERation:CALL:TA2000 register.
8 | 256 | CDMA Summary bit | This bit is the summary bit for the STATus:OPERation:CALL:CDMA register.
7 | 128 | DIGital2000 Summary bit. | This bit is the summary bit for the STATus:OPERation:CALL:DIGital2000 register.
6 | 64 | DIGital95 Summary bit | This bit is the summary bit for the STATus:OPERation:CALL:DIGital95 register.
5 | 32 | TA136 Summary bit | This bit is the summary bit for the STATus:OPERation:CALL:TA136 register.
4 | 16 | DIGital136 Summary bit | This bit is the summary bit for the STATus:OPERation:CALL:DIGital136 register.
3 | 8 | AMPS Summary bit | This bit is the summary bit for the STATus:OPERation:CALL:AMPS register.
2 | 4 | GSM Summary bit | This bit is the summary bit for the STATus:OPERation:CALL:GSM register.
1 | 2 | COMMon Summary bit | This bit is the summary bit for the STATus:OPERation:CALL:COMMon register.
0 | 1 | Extension Bit | This bit is always 0.

Program Examples - STATus:OPERation:CALL

OUTPUT 714;"STATUS:OPERATION:CALL:EVENT?" !Queries and clears the Operation Call Event
                                          !Register
OUTPUT 714;"STATUS:OPERATION:CALL:CONDITION?" !Queries and clears the Operation Call
                                              !Condition Register
OUTPUT 714;"STATUS:OPERATION:CALL:ENABLE 4" !Sets the Operation Call Enable
                                            !Register for bit 2
OUTPUT 714;"STATUS:OPERATION:CALL:NTR 4" !Sets the Negative Transition Filter
                                         !Register for bit 2
OUTPUT 714;"STATUS:OPERATION:CALL:PTR 256" !Sets the Positive Transition Filter
                                           !Register for bit 8

STATus:OPERation:CALL:COMMon Condition Register Bit Assignment

The STATus:OPERation:CALL:COMMon register bits are used to indicate status of processes that occur during normal call processing operations.

Bit Number

Binary Weighting

Condition

Description

15

32768

Not Used. Defined by SCPI.

This bit is always 0.

14

16384

Data Summary

 This bit is the summary bit for the STATus:QUEStionable:CALL:GSM:DATA register.

13

8192

 Call Control Status Access Probe

This bit is a 1 when the test set is in the call control status access probe state.

12

4096

Call Control Status Set Up Request

This bit is a 1 when the test set is in the call control status set up request state.

11

2048

Call Control Status Releasing

This bit is a 1 when the test set is in the call control status releasing state.

10

1024

Call Control Status Paging

This bit is a 1 when the test set is in the call control status paging state.

9

512

Registering (BS initiated)

This bit is set to a 1 when the Base Station initiates registration.

8

256

Reserved for future use.

This bit is always 0.

7

128

BS Originating

This bit is a 1 when:

  • Active Cell mode - the call processing state leaves the idle state

  • Test mode - the test set has noted a base station origination.

6

64

Call Control Status Changing

This bit is set to a 1 when the call control status change detector has been armed.

5

32

Reserved for future use.

This bit is always 0.

4

16

Reserved for future use.

This bit is always 0.

3

8

Call Control Status Alerting

This bit is a 1 when the test set is in the call alerting state (ringing).

2

4

Call Control Status Connected

This bit is a 1 when the test set is in the call connected state.

1

2

Call Control Status Idle

This bit is a 1 when the test set is in the call idle state.

0

1

Extension Bit

This bit is always 0.

Program Examples STATus:OPERation:CALL:COMMon

OUTPUT 714;"STATUS:OPERATION:CALL:COMMON:EVENT?" !Queries and clears the Operation
                                                 !Call
                                                 !Common Event Register
OUTPUT 714;"STATUS:OPERATION:CALL:COMMON:CONDITION?" !Queries and clears the Operation
                                                     !Call
                                                     !Common Condition Register
OUTPUT 714;"STATUS:OPERATION:CALL:COMMON:ENABLE 1024" !Sets the Operation
                                                      !Call
                                                      !Common Enable
                                                      !Register for bit 10
OUTPUT 714;"STATUS:OPERATION:CALL:COMMON:NTRANSITION 2" !Sets the Operation
                                                        !Call
                                                        !Common Negative Transition
                                                        !Filter Register for bit 1
OUTPUT 714;"STATUS:OPERATION:CALL:COMMON:PTRANSITION 2" !Set the Operation
                                                        !Call
                                                        !Common Positive Transition
                                                        !Filter Register for bit 1

STATus:OPERation:CALL:COMMon:DAINterface Condition Register Bit Assignment

The STATus:OPERation:CALL:COMMon:DAINterface register bits are used to indicate status of processes that occur during digital audio interface test processing operations.

Bit Number | Bit Name | Description
15 | Not Used. | This bit is always 0.
14-5 | Reserved for future use. | These bits are always 0.
4 | Ready to play | This bit is set to 1 then cleared to 0 when a file has been successfully uploaded.
3 | Playing state | This bit is set to 1 while playing a digital audio file.
2 | Record buffer filled | This bit is set to 1 then cleared to 0 when recording was terminated by the record buffer being filled.
1 | Recording state | This bit is set to 1 while recording a digital audio file.
0 | Extension Bit | Reserved for future use.

Program Examples STATus:OPERation:CALL:COMMon:DAINterface

OUTPUT 714;"STATUS:OPERATION:CALL:COMMON:DAIN:EVENT?" !Queries and clears the Operation
                                                      !Call Common DAI Interface
                                                      !Event Register
OUTPUT 714;"STATUS:OPERATION:CALL:COMMON:DAIN:CONDITION?" !Queries and clears the Operation
                                                          !Call Common DAI Interface
                                                          !Condition Register
OUTPUT 714;"STATUS:OPERATION:CALL:COMMON:DAIN:ENABLE 8" !Sets the Operation Call Common
                                                          !DAI Interface Enable Register
                                                          !for bit 3
OUTPUT 714;"STATUS:OPERATION:CALL:COMMON:DAIN:NTRANSITION 2" !Sets the Operation Call Common
                                                        !DAI Interface Negative Transition
                                                        !Filter Register for bit 1
OUTPUT 714;"STATUS:OPERATION:CALL:COMMON:DAIN:PTRANSITION 2" !Set the Operation Call Common
                                                        !DAI Interface Positive Transition
                                                        !Filter Register for bit 1

STATus:OPERation:CALL:COMMon:DATA Condition Register Bit Assignment

The STATus:OPERation:CALL:COMMon:DATA register bits are used to indicate status of processes that occur during normal data connection processing operations.

Bit Number

Binary Weighting

Condition

Description

15

32768

Not Used. Defined by SCPI.

This bit is always 0.

14

16384

 Ping active.

This bit is a 1 when a Ping session is active.

13

8192

Reserved for future use.

This bit is always 0.

12

4096

Reserved for future use.

This bit is always 0.

11

2048

Data Connection Status Suspended

 This bit is a 1 when the status is Suspended, zero when not Suspended.

10

1024

Data Connection Status Dormant

 This bit is a 1 when the Status is Dormant, zero when not Dormant.

9

512

Data Connection Status Session Open

This bit is a 1 when the Status Session is Open, zero when Closed.

8

256

PDP Active state

This bit is a 1 when the PDP is active, zero when inactive.

7

128

Starting Data Connection

This bit is a 1 when:

  • Active Cell mode - the data connection status leaves the idle state

  • Test mode - the test set has noted a base station origination.

6

64

Data Connection Status Changing

This bit is set to a 1 when the data connection status change detector has been armed.

5

32

 Data Connection Status Off This bit is set to 1 when the test set is in the call control status handover/handoff state.

4

16

 Data Connection Status Data Connected

This bit is set to 1 when:

  • data connection status data is in the connected state.
  • a circuit switched data (CSD) connection is active.

3

8

Data Connection Status Transferring

This bit is a 1 when the data connection status is Transferring.

2

4

Data Connection Status Attached

This bit is a 1 when the data connection status is Attached.

1

2

Data Connection Status Idle

This bit is a 1 when the data connection status is Idle.

0

1

Extension Bit

This bit is always 0.

Program Examples STATus:OPERation:CALL:COMMon:DATA

OUTPUT 714;"STATUS:OPERATION:CALL:COMMON:DATA:EVENT?" !Queries and clears the Operation
                                                      !Call Common Data Event Register
OUTPUT 714;"STATUS:OPERATION:CALL:COMMON:DATA:CONDITION?" !Queries and clears the Operation
                                                          !Call Common Data Condition
                                                          !Register
OUTPUT 714;"STATUS:OPERATION:CALL:COMMON:DATA:ENABLE 128" !Sets the Operation Call Common
                                                          !Data Enable Register for bit 7
OUTPUT 714;"STATUS:OPERATION:CALL:COMMON:DATA:NTRANSITION 2" !Sets the Operation Call Common
                                                        !Data Negative Transition Filter
                                                        !Register for bit 1
OUTPUT 714;"STATUS:OPERATION:CALL:COMMON:DATA:PTRANSITION 2" !Set the Operation Call Common
                                                        !Data Positive Transition Filter
                                                        !Register for bit 1

STATus:OPERation:CALL:GSM Condition Register Bit Assignment

The STATus:OPERation:CALL:GSM register bits are used to indicate status of processes that occur during normal GSM call processing operations. These register bits are not applicable to GPRS.

Bit Number

Binary Weighting

Condition

Description

15

32768

Not Used. Defined by SCPI.

This bit is always 0.

14

16384

RRLP Measurement Position Request Received.

 If message queuing is "OFF", the CONDition bit moves from 0 to 1 and back to 0 when the event takes place. If message queuing is "ON", the CONDition bit is set to 1 and remains there until the test set is informed by the controller that all received messages have been read.

13

8192

RRLP Assistance Data Ack Received.

 If message queuing is "OFF", the CONDition bit moves from 0 to 1 and back to 0 when the event takes place. If message queuing is "ON", the CONDition bit is set to 1 and remains there until the test set is informed by the controller that all received messages have been read.

12

4096

RRLP Pipe Data Received.

If message queuing is "OFF", the CONDition bit moves from 0 to 1 and back to 0 when the event takes place. If message queuing is "ON", the CONDition bit is set to 1 and remains there until the test set is informed by the controller that all received messages have been read.

11

2048

Reserved for future use.

This bit is always 0.

10

1024

Reserved for future use.

This bit is always 0.

9

512

Reserved for future use.

This bit is always 0.

8

256

BS Disconnecting

This bit is a 1 when:

  • Active Cell mode - the call processing state reaches (or is in) the idle state

  • Test mode - the test set has noted a base station termination.

7

128

BS Originating

This bit is a 1 when:

  • Active Cell mode - the call processing state leaves the idle state

  • Test mode - the test set has noted a base station origination.

6

64

Call Control Status Changing

This bit is set to a 1 when the call control status change detector has been armed.

5

32

TCH Assignment in Progress

This bit is a 1 when:

  • The channel assignment is successfully completed (when a call is established).

  • The test set notes a change in the TCH ARFCN, cell band, TCH timeslot, or mobile station timing advance.

  • An error message is generated.

4

16

BCH Changing

This bit is a 1 when:

  • The downlink signal is transmitting on the new broadcast channel.

  • The test set has noted a change in cell band.

3

8

Call Control Status Alerting

This bit is a 1 when the test set is in the call alerting state (ringing).

2

4

Call Control Status Connected

This bit is a 1 when:

  • the test set is in the call connected state.
  • a circuit switched data (CSD) connection is active.

1

2

Call Control Status Idle

This bit is a 1 when the test set is in the call idle state.

0

1

Extension Bit

This bit is always 0.

Program Examples - STATus:OPERation:CALL:GSM

OUTPUT 714;"STATUS:OPERATION:CALL:GSM:EVENT?" !Queries and clears the Operation
                                              !Call GSM Event Register
OUTPUT 714;"STATUS:OPERATION:CALL:GSM:CONDITION?" !Queries and clears the Operation
                                                  !Call GSM Condition Register
OUTPUT 714;"STATUS:OPERATION:CALL:GSM:ENABLE 1024" !Sets the Operation
                                                   !Call GSM Enable
                                                   !Register for bit 10
OUTPUT 714;"STATUS:OPERATION:CALL:GSM:NTRANSITION 2" !Sets the Operation
                                                     !Call GSM Negative Transition
                                                     !Filter Register for bit 1
OUTPUT 714;"STATUS:OPERATION:CALL:GSM:PTRANSITION 2" !Sets the Operation
                                                     !Call GSM Positive Tranasition
                                                     !Filter Register for bit 1

STATus:OPERation:FEATures Register Bit Assignments

The STATus:OPERation:FEATures register bits are used to access miscellaneous Features Registers.

Bit Number | Binary Weighting | Condition | Description
15 | 32768 | Not Used. Defined by SCPI. | This bit is always 0.
14 | 16384 | Reserved for future use. | This bit is always 0.
13 | 8192 | Reserved for future use. | This bit is always 0.
12 | 4096 | Reserved for future use. | This bit is always 0.
11 | 2048 | Reserved for future use. | This bit is always 0.
10 | 1024 | Reserved for future use. | This bit is always 0.
9 | 512 | Reserved for future use. | This bit is always 0.
8 | 256 | Reserved for future use. | This bit is always 0.
7 | 128 | Reserved for future use. | This bit is always 0.
6 | 64 | Reserved for future use. | This bit is always 0.
5 | 32 | Reserved for future use. | This bit is always 0.
4 | 16 | Reserved for future use. | This bit is always 0.
3 | 8 | Reserved for future use. | This bit is always 0.
2 | 4 | Reserved for future use. | This bit is always 0.
1 | 2 | COMMon Summary Bit | This bit is the summary bit for the STATus:OPERation:FEATures:COMMon register. (see STATus:OPERation:FEATures:COMMon Register Bit Assignments )
0 | 1 | Extension Bit | This bit is always 0.

Program Examples - STATus:OPERation:FEATures

OUTPUT 714;"STATUS:OPERATION:FEATures:EVENT?"
    !Queries the Operation FEATures Event Register.
OUTPUT 714;"STATUS:OPERATION:FEATures:CONDITION?"
    !Queries the Operation FEATures Condition Register.
OUTPUT 714;"STATUS:OPERATION:FEATures:ENABLE 2"
    !Sets Operation FEATures Enable register for bit 1.
OUTPUT 714;"STATUS:OPERATION:FEATures:NTR 2"
    !Sets the Operation FEATures Negative Transition Register for bit 1.
OUTPUT 714;"STATUS:OPERATION:FEATures:PTR 4"
    !Sets the Operation FEATures Positive Transition Register for bit 2

STATus:OPERation:FEATures:COMMon Register Bit Assignments

The STATus:OPERation:FEATures:COMMon register bits indicate the status of processes that occur during the operations.

Bit Number | Binary Weighting | Condition | Description
15 | 32768 | Not Used. Defined by SCPI. | This bit is always 0.
14 | 16384 | Reserved for future use. | This bit is always 0.
13 | 8192 | Reserved for future use. | This bit is always 0.
12 | 4096 | Reserved for future use. | This bit is always 0.
11 | 2048 | Reserved for future use. | This bit is always 0.
10 | 1024 | Reserved for future use. | This bit is always 0.
9 | 512 | Reserved for future use. | This bit is always 0.
8 | 256 | Reserved for future use. | This bit is always 0.
7 | 128 | Reserved for future use. | This bit is always 0.
6 | 64 | Reserved for future use. | This bit is always 0.
5 | 32 | Reserved for future use. | This bit is always 0.
4 | 16 | Reserved for future use. | This bit is always 0.
3 | 8 | Reserved for future use. | This bit is always 0.
2 | 4 | Common Supplementary Services Summary bit. | This bit is the summary message bit for the STATus:OPERation:FEATures:COMMon:SSERvice register. (see STATus:OPERation:FEATures:COMMon:SSERvice Register Bit Assignments )
1 | 2 | SMService Summary bit | This bit is the summary message bit for the STATus:OPERation:FEATures:COMMon:SMService register. (see STATus:OPERation:FEATures:COMMon:SMService Register Bit Assignments )
0 | 1 | Extension Bit | This bit is always 0.

STATus:OPERation:FEATures:COMMon:SSERvice Register Bit Assignments

The STATus:OPERation:FEATures:COMMon:SService register bits indicate the status of processes that occur during SS operations.

Bit Number | Binary Weighting | Condition | Description
15 | 32768 | Not Used. Defined by SCPI. | This bit is always 0.
14 | 16384 | Reserved for future use. | This bit is always 0.
13 | 8192 | Reserved for future use. | This bit is always 0.
12 | 4096 | Reserved for future use. | This bit is always 0.
11 | 2048 | Reserved for future use. | This bit is always 0.
10 | 1024 | Reserved for future use. | This bit is always 0.
9 | 512 | Reserved for future use. | This bit is always 0.
8 | 256 | Reserved for future use. | This bit is always 0.
7 | 128 | Reserved for future use. | This bit is always 0.
6 | 64 | Reserved for future use. | This bit is always 0.
5 | 32 | Reserved for future use. | This bit is always 0.
4 | 16 | Reserved for future use. | This bit is always 0.
3 | 8 | Reserved for future use. | This bit is always 0.
2 | 4 | Reserved for future use. | This bit is always 0.
1 | 2 | SS Pipe data received. | If message queuing is "OFF", the CONDition bit moves from 0 to 1 and back to 0 when the event takes place. If message queuing is "ON", the CONDition bit is set to 1 and remains there until the test set is informed by the controller that all received messages have been read.
0 | 1 | Extension Bit | This bit is always 0.

Program Examples - STATus:OPERation:FEATures:COMMon:SSERvice

OUTPUT 714;"STATUS:OPERATION:FEATURES:COMMON:SSERVICE:EVENT?"
            !Queries the Operation FEATures Event Register.
OUTPUT 714;"STATUS:OPERATION:FEATURES:COMMON:SSERVICE:CONDITION?"
            !Queries the Operation FEATures Condition Register.
OUTPUT 714;"STATUS:OPERATION:FEATURES:COMMON:SSERVICE:ENABLE 2"
            !Sets Operation FEATures Enable register for bit 1.
OUTPUT 714;"STATUS:OPERATION:FEATURES:COMMON:SSERVICE:NTRANSITION 2"
            !Sets the Operation FEATures Negative Transition Register for bit 1.
OUTPUT 714;"STATUS:OPERATION:FEATURES:COMMON:SSERVICE:PTRANSITION 4"
            !Sets the Operation FEATures Positive Transition Register for bit

STATus:OPERation:FEATures:COMMon:SMService Register Bit Assignments

The STATus:OPERation:FEATures:COMMon:SMService register bits indicate the status of processes that occur during SMS operations.

Bit Number | Binary Weighting | Condition | Description
15 | 32768 | Not Used. Defined by SCPI. | This bit is always 0.
14 | 16384 | Mobile-Originated SMS Message Queue Overflow | The CONDition bit moves from 0 to 1 and back to 0 when the event takes place.
13 | 8192 | Reserved for future use. | This bit is always 0.
12 | 4096 | Reserved for future use. | This bit is always 0.
11 | 2048 | Reserved for future use. | This bit is always 0.
10 | 1024 | Reserved for future use. | This bit is always 0.
9 | 512 | Reserved for future use. | This bit is always 0.
8 | 256 | Reserved for future use. | This bit is always 0.
7 | 128 | Mobile-Originated Message Received/Ready to be Returned | If message queuing is "OFF", the CONDition bit moves from 0 to 1 and back to 0 when the event takes place. If message queuing is "ON", the CONDition bit is set to 1 and remains there until the test set is informed by the controller that all received messages have been read.
6 | 64 | Reserved for future use. | This bit is always 0.
5 | 32 | Reserved for future use. | This bit is always 0.
4 | 16 | Reserved for future use. | This bit is always 0.
3 | 8 | Reserved for future use. | This bit is always 0.
2 | 4 | Reserved for future use. | This bit is always 0.
1 | 2 | Reserved for future use. | This bit is always 0.
0 | 1 | Extension Bit | This bit is always 0.

Program Examples - STATus:OPERation:FEATures:COMMon:SMService

OUTPUT 714;"STATUS:OPERATION:FEATURES:COMMON:SMSERVICE:EVENT?"
            !Queries the Operation FEATures Event Register.
OUTPUT 714;"STATUS:OPERATION:FEATURES:COMMON:SMSERVICE:CONDITION?"
            !Queries the Operation FEATures Condition Register.
OUTPUT 714;"STATUS:OPERATION:FEATURES:COMMON:SMSERVICE:ENABLE 2"
            !Sets Operation FEATures Enable register for bit 1.
OUTPUT 714;"STATUS:OPERATION:FEATURES:COMMON:SMSERVICE:NTRANSITION 2"
            !Sets the Operation FEATures Negative Transition Register for bit 1.
OUTPUT 714;"STATUS:OPERATION:FEATURES:COMMON:SMSERVICE:PTRANSITION 4"
            !Sets the Operation FEATures Positive Transition Register for bit

STATus:OPERation:HARDware Register Bit Assignments

The STATus:OPERation:HARDware register bits indicate information about the test set's hardware during normal operation.

Bit Number | Binary Weighting | Condition | Description
15 | 32768 | Not Used. Defined by SCPI. | This bit is always 0.
14 | 16384 | Reserved for future use. | This bit is always 0.
13 | 8192 | Reserved for future use. | This bit is always 0.
12 | 4096 | Reserved for future use. | This bit is always 0.
11 | 2048 | Reserved for future use. | This bit is always 0.
10 | 1024 | Reserved for future use. | This bit is always 0.
9 | 512 | Reserved for future use. | This bit is always 0.
8 | 256 | Reserved for future use. | This bit is always 0.
7 | 128 | Reserved for future use. | This bit is always 0.
6 | 64 | Reserved for future use. | This bit is always 0.
5 | 32 | Reserved for future use. | This bit is always 0.
4 | 16 | Reserved for future use. | This bit is always 0.
3 | 8 | Reserved for future use. | This bit is always 0.
2 | 4 | Reserved for future use. | This bit is always 0.
1 | 2 | External Timebase in use | This bit is a 1 if a suitable external timebase is connected to the test set's 10 MHz REF IN connector on the rear panel of the test set.
0 | 1 | Extension Bit | This bit is always 0.

Program Examples - STATus:OPERation:HARDware

OUTPUT 714;"STATUS:OPERATION:HARDWARE:EVENT?" !Queries the Hardware Event Register.
OUTPUT 714;"STATUS:OPERATION:HARDWARE:CONDITION?" !Queries the Hardware Condition Register.
OUTPUT 714;"STATUS:OPERATION:HARDWARE:ENABLE 16" !Sets New Measurement Results Hardware for
bit 16.
OUTPUT 714;"STATUS:OPERATION:HARDWARE:NTR 2" !Sets the Hardware Negative Transition
                                             !Register for bit 4.
OUTPUT 714;"STATUS:OPERATION:HARDWARE:PTR 4" !Sets the Hardware Positive Transition
                                             !Register for bit 4.

STATus:OPERation:KEYPressed Register Bit Assignments

The STATus:OPERation:KEYpressed register bits indicate when a softkey on the test set's front panel has been pressed while the test set is in remote operating mode.

Bit Number | Binary Weighting | Condition | Description
15 | 32768 | Not Used. Defined by SCPI. | This bit is always 0.
14 | 16384 | Reserved for future use. | This bit is always 0.
13 | 8192 | Reserved for future use. | This bit is always 0.
12 | 4096 | Reserved for future use. | This bit is always 0.
11 | 2048 | F12 softkey | This bit is a 1 when the F12 softkey has been pressed.
10 | 1024 | F11 softkey | This bit is a 1 when the F11 softkey has been pressed.
9 | 512 | F10 softkey | This bit is a 1 when the F10 softkey has been pressed.
8 | 256 | F9 softkey | This bit is a 1 when the F9 softkey has been pressed.
7 | 128 | F8 softkey | This bit is a 1 when the F8 softkey has been pressed.
6 | 64 | F7 softkey | This bit is a 1 when the F7 softkey has been pressed.
5 | 32 | F6 softkey | This bit is a 1 when the F6 softkey has been pressed.
4 | 16 | F5 softkey | This bit is a 1 when the F5 softkey has been pressed.
3 | 8 | F4 softkey | This bit is a 1 when the F4 softkey has been pressed.
2 | 4 | F3 softkey | This bit is a 1 when the F3 softkey has been pressed.
1 | 2 | F2 softkey | This bit is a 1 when the F2 softkey has been pressed.
0 | 1 | F1 softkey | This bit is a 1 when the F1 softkey has been pressed.

Program Examples - STATus:OPERation:KEYPressed

OUTPUT 714;"STATUS:OPERATION:KEYPRESSED:EVENT?" !Queries the Keypressed Event Register.

STATus:OPERation:NMRReady Condition Register Bit Assignment

The STATus:OPERation:NMRReady register bits indicate when a measurement has been completed and new measurement results are available.

Bit Number | Binary Weighting | Condition | Description
15 | 32768 | Not Used. Defined by SCPI. | This bit is always 0.
14 | 16384 | Reserved for future use. | This bit is always 0.
13 | 8192 | Reserved for future use. | This bit is always 0.
12 | 4096 | GPRS Summary bit | This bit is the summary bit for the STATus:OPERation:NMRReady:GPRS register.
11 | 2048 | WCDMa Summary bit | This bit is the summary bit for the STATus:OPERation:NMRReady:WCDMa register.
10 | 1024 | FDD Summary bit | This bit is the summary bit for the STATus:OPERation:NMRReady:FDD register.
9 | 512 | TA2000 Summary bit | This bit is the summary bit for the STATus:OPERation:NMRReady:TA2000 register.
8 | 256 | CDMA Summary bit | This bit is the summary bit for the STATus:OPERation:NMRReady:CDMA register.
7 | 128 | DIGital2000 Summary bit | This bit is the summary bit for the STATus:OPERation:NMRReady:DIGital2000 register.
6 | 64 | DIGital95 Summary bit | This bit is the summary bit for the STATus:OPERation:NMRReady:DIGital95 register.
5 | 32 | TA136 Summary bit | This bit is the summary bit for the STATus:OPERation:NMRReady:TA136 register.
4 | 16 | DIGital136 Summary bit | This bit is the summary bit for the STATus:OPERation:NMRReady:DIGital136 register.
3 | 8 | AMPS Summary bit | This bit is the summary bit for the STATus:OPERation:NMRReady:AMPS register.
2 | 4 | GSM Summary bit | This bit is the summary bit for the STATus:OPERation:NMRReady:GSM register.
1 | 2 | COMMon Summary bit | This bit is the summary bit for the STATus:OPERation:NMRReady:COMMon register.
0 | 1 | Extension Bit | This bit is always 0.

Program Examples - STATus:OPERation:NMRReady

OUTPUT 714;"STATUS:OPERATION:NMRREADY:EVENT?" !Queries and clears the New Measurement
                                              !Results Ready Event Register
OUTPUT 714;"STATUS:OPERATION:NMRREADY:CONDITION?" !Queries and clears the New Measurement
                                                  !Results Ready
                                                  !Condition Register
OUTPUT 714;"STATUS:OPERATION:NMRREADY:ENABLE 16" !Sets New Measurement Results
                                                 !Ready Enable Regigter
                                                 !for bit 4
OUTPUT 714;"STATUS:OPERATION:NMRREADY:NTR 2" !Sets the New Measurement Results
                                             !Ready Negative Transition Filter
                                             !Register for bit 1
OUTPUT 714;"STATUS:OPERATION:NMRREADY:PTR 4" !Sets the New Measurement
                                             !Results Ready Positive
                                             !Transition Filter Register
                                             !for bit 2

STATus:OPERation:NMRReady:AMPS Condition Register Bit Assignment

The STATus:OPERation:NMRReady:AMPS register bits indicate when a measurement has been completed and new measurement results are available.

Bit Number | Binary Weighting | Condition | Description
15 | 32768 | Not Used. Defined by SCPI. | This bit is always 0.
14 | 16384 | Reserved for future use. | This bit is always 0.
13 | 8192 | Reserved for future use. | This bit is always 0.
12 | 4096 | Reserved for future use. | This bit is always 0.
11 | 2048 | Reserved for future use. | This bit is always 0.
10 | 1024 | Reserved for future use. | This bit is always 0.
9 | 512 | Reserved for future use. | This bit is always 0.
8 | 256 | Reserved for future use. | This bit is always 0.
7 | 128 | Reserved for future use. | This bit is always 0.
6 | 64 | Reserved for future use. | This bit is always 0.
5 | 32 | Reserved for future use. | This bit is always 0.
4 | 16 | Reserved for future use. | This bit is always 0.
3 | 8 | Frequency Modulation New Measurement Result Ready | This bit is a 1 if the measurement has been completed and has produced new results. This bit is a zero at power on, after a preset and while a measurement is in Measuring States.
2 | 4 | Frequency Stability New Measurement Result Ready | This is a 1 if the measurement has been completed and has produced new results. This bit is a zero at power on, after a preset and while a measurement is in Measuring States.
1 | 2 | Analog Transmit Power New Measurement Result Ready | This bit is a 1 if the measurement has been completed and has produced new results. This bit is a zero at power on, after a preset and while a measurement is in Measuring States.
0 | 1 | Extension Bit | This bit is always 0.

Program Examples - STATus:OPERation:NMRReady:AMPS

OUTPUT 714;"STATUS:OPERATION:NMRREADY:AMPS:EVENT?" !Queries the New Measurement
                                              !Results Ready AMPS Event Register.
OUTPUT 714;"STATUS:OPERATION:NMRREADY:AMPS:CONDITION?" !Queries the New Measurement
                                                  !Results Ready AMPS
                                                  !Condition Register.
OUTPUT 714;"STATUS:OPERATION:NMRREADY:AMPS:ENABLE 8" !Sets New Measurement Results
                                                 !Ready AMPS Enable Register
                                                 !for bit 3.
OUTPUT 714;"STATUS:OPERATION:NMRREADY:AMPS:NTR 2" !Sets the New Measurement Results
                                             !Ready AMPS Negative Transition
                                             !Register for bit 1.
OUTPUT 714;"STATUS:OPERATION:NMRREADY:AMPS:PTR 4" !Sets the New Measurement
                                             !Results Ready AMPS Positive
                                             !Transition Register
                                             !for bit 2.

STATus:OPERation:NMRReady:COMMon Condition Register Bit Assignment

The STATus:OPERation:NMRReady:COMMon register bits indicate when a measurement has been completed and new measurement results are available.

Bit Number | Binary Weighting | Condition | Description
15 | 32768 | Not Used. Defined by SCPI. | This bit is always 0.
14 | 16384 | Reserved for future use. | This bit is always 0.
13 | 8192 | Reserved for future use. | This bit is always 0.
12 | 4096 | Reserved for future use. | This bit is always 0.
11 | 2048 | Reserved for future use. | This bit is always 0.
10 | 1024 | Reserved for future use. | This bit is always 0.
9 | 512 | Reserved for future use. | This bit is always 0.
8 | 256 | Reserved for future use. | This bit is always 0.
7 | 128 | Reserved for future use. | This bit is always 0.
6 | 64 | Phase and Amplitude vs. Time | This is the summary bit for the STATus:OPERation:NMRReady:COMMon Phase and Amplitude vs. Time register.
5 | 32 | Frequency Stability | This is the summary bit for the STATus:OPERation:NMRReady:COMMon Frequency Stability register.
4 | 16 | Multi-Tone Audio | This is the summary bit for the STATus:OPERation:NMRReady:COMMon Multi-Tone Audio register.
3 | 8 | Spectrum Monitor | This is the summary bit for the STATus:OPERation:NMRReady:COMMon Spectrum Monitor register.
2 | 4 | Swept Audio | This is the summary bit for the STATus:OPERation:NMRReady:COMMon Swept Audio register.
1 | 2 | Audio Analyzer | This is the summary bit for the STATus:OPERation:NMRReady:COMMon Audio Analyzer register.
0 | 1 | Extension Bit | This bit is always 0.

Program Examples - STATus:OPERation:NMRReady:COMMon

OUTPUT 714;"STATUS:OPERATION:NMRREADY:COMMON:EVENT?" !Queries and clears the Operation
                                                     !New Measurement Results Ready
                                                     !Common Event Register
OUTPUT 714;"STATUS:OPERATION:NMRREADY:COMMON:CONDITION?" !Queries and clears the Operation
                                                         !New Measurement Results Ready
                                                         !Common Condition Register
OUTPUT 714;"STATUS:OPERATION:NMRREADY:COMMON:ENABLE 1024" !Sets the Operation
                                                          !New Measurement Results Ready
                                                          !Common Enable
                                                          !Register for bit 10
OUTPUT 714;"STATUS:OPERATION:NMRREADY:COMMON:NTRANSITION 2" !Sets the Operation
                                                            !New Measurement Results Ready
                                                            !Common Negative Transition
                                                            !Filter Register for bit 1
OUTPUT 714;"STATUS:OPERATION:NMRREADY:COMMON:PTRANSITION 2" !Set the Operation
                                                            !New Measurement Results Ready
                                                            !Common Positive Tranasition
                                                            !Filter Register for bit 1

STATus:OPERation:NMRReady:GPRS Condition Register Bit Assignment

The STATus:OPERation:NMRReady:GPRS register bits indicate when a GPRS measurement has been completed and new measurement results are available.

Bit Number | Binary Weighting | Condition | Description
15 | 32768 | Not Used. Defined by SCPI. | This bit is always 0.
14 | 16384 | EMACcuracy New Measurement Result Ready. |
13 | 8192 | ETXPower New Measurement Result Ready. | This bit is a 1 if the measurement has been completed and has produced new results. This bit is a zero at power on, after a preset and while a measurement is in Measuring States. See Triggering of Measurements .
12 | 4096 | BLERror New Measurement Result Ready. | This bit is a 1 if the measurement has been completed and has produced new results. This bit is a zero at power on, after a preset and while a measurement is in Measuring States. See Triggering of Measurements .
11 | 2048 | GBERror New Measurement Result Ready | This bit is a 1 if the measurement has been completed and has produced new results. This bit is a zero at power on, after a preset and while a measurement is in Measuring States. See Triggering of Measurements .
10 | 1024 | DPOWer New Measurement Result Ready |
9 | 512 | I/Q Tuning New Measurement Result Ready |
8 | 256 | Reserved for future use. | This bit is always 0.
7 | 128 | SBERror New Measurement Result Ready. | This bit is a 1 if the measurement has been completed and has produced new results. This bit is a zero at power on, after a preset and while a measurement is in Measuring States. See Triggering of Measurements .
6 | 64 | Reserved for future use. | This bit is always 0.
5 | 32 | Reserved for future use. | This bit is always 0.
4 | 16 | ORFSpectrum New Measurement Result Ready | This bit is a 1 if the measurement has been completed and has produced new results. This bit is a zero at power on, after a preset and while a measurement is in Measuring States. See Triggering of Measurements .
3 | 8 | PFERror New Measurement Result Ready | This bit is a 1 if the measurement has been completed and has produced new results. This bit is a zero at power on, after a preset and while a measurement is in Measuring States. See Triggering of Measurements .
2 | 4 | PVTime New Measurement Result Ready | This bit is a 1 if the measurement has been completed and has produced new results. This bit is a zero at power on, after a preset and while a measurement is in Measuring States. See Triggering of Measurements .
1 | 2 | TXPower New Measurement Result Ready | This bit is a 1 if the measurement has been completed and has produced new results. This bit is a zero at power on, after a preset and while a measurement is in Measuring States. See Triggering of Measurements .
0 | 1 | Extension Bit | This bit is always 0.

Program Examples - STATus:OPERation:NMRReady:GPRS

OUTPUT 714;"STATUS:OPERATION:NMRREADY:GPRS:EVENT?" !Queries and clears the Operation
                                                   !New Measurement Results Ready
                                                   !GPRS Event Register
OUTPUT 714;"STATUS:OPERATION:NMRREADY:GPRS:CONDITION?" !Queries and clears the Operation
                                                       !New Measurement Results Ready
                                                       !GPRS Condition Register
OUTPUT 714;"STATUS:OPERATION:NMRREADY:GPRS:ENABLE 1024" !Sets the Operation
                                                        !New Measurement Results Ready
                                                        !GPRS Enable
                                                        !Register for bit 10
OUTPUT 714;"STATUS:OPERATION:NMRREADY:GPRS:NTRANSITION 2" !Sets the Operation
                                                          !New Measurement Results Ready
                                                          !GPRS Negative Transition
                                                          !Filter Register for bit 1
OUTPUT 714;"STATUS:OPERATION:NMRREADY:GPRS:PTRANSITION 2" !Sets the Operation
                                                          !New Measurement Results Ready
                                                          !GPRS Positive Tranasition
                                                            !Filter Register for bit 1

STATus:OPERation:NMRReady:GSM Condition Register Bit Assignment

The STATus:OPERation:NMRReady:GSM register bits indicate when a GSM measurement has been completed and new measurement results are available.

Bit Number | Binary Weighting | Condition | Description
15 | 32768 | Not Used. Defined by SCPI. | This bit is always 0.
14 | 16384 | Reserved for future use. | This bit is always 0.
13 | 8192 | Reserved for future use. | This bit is always 0.
12 | 4096 | FACCH Frame Erasure Rate (FER) New Measurement Result Ready. | This bit is a 1 if the measurement has been completed and has produced new results. This bit is a zero at power on, after a preset and while a measurement is in Measuring States. See Triggering of Measurements .
11 | 2048 | Bad Frame Indication (BFI) New Measurement Result Ready. | This bit is a 1 if the measurement has been completed and has produced new results. This bit is a zero at power on, after a preset and while a measurement is in Measuring States. See Triggering of Measurements .
10 | 1024 | DPOWer New Measurement Result Ready | This bit is a 1 if the measurement has been completed and has produced new results. This bit is a zero at power on, after a preset and while a measurement is in Measuring States. See Triggering of Measurements .
9 | 512 | I/Q Tuning New Measurement Result Ready | This bit is a 1 if the measurement has been completed and has produced new results. This bit is a zero at power on, after a preset and while a measurement is in Measuring States. See Triggering of Measurements .
8 | 256 | BERRor New Measurement Result Ready | This bit is a 1 if the measurement has been completed and has produced new results. This bit is a zero at power on, after a preset and while a measurement is in Measuring States. See Triggering of Measurements .
7 | 128 | FBERror New Measurement Result Ready | This bit is a 1 if the measurement has been completed and has produced new results. This bit is a zero at power on, after a preset and while a measurement is in Measuring States. See Triggering of Measurements .
6 | 64 | DAUDio New Measurement Result Ready | This bit is a 1 if the measurement has been completed and has produced new results. This bit is a zero at power on, after a preset and while a measurement is in Measuring States. See Triggering of Measurements .
5 | 32 | AAUDio New Measurement Result Ready | This bit is a 1 if the measurement has been completed and has produced new results. This bit is a zero at power on, after a preset and while a measurement is in Measuring States. See Triggering of Measurements .
4 | 16 | ORFSpectrum New Measurement Result Ready | This bit is a 1 if the measurement has been completed and has produced new results. This bit is a zero at power on, after a preset and while a measurement is in Measuring States. See Triggering of Measurements .
3 | 8 | PFERror New Measurement Result Ready | This bit is a 1 if the measurement has been completed and has produced new results. This bit is a zero at power on, after a preset and while a measurement is in Measuring States. See Triggering of Measurements .
2 | 4 | PVTime New Measurement Result Ready | This bit is a 1 if the measurement has been completed and has produced new results. This bit is a zero at power on, after a preset and while a measurement is in Measuring States. See Triggering of Measurements .
1 | 2 | TXPower New Measurement Result Ready | This bit is a 1 if the measurement has been completed and has produced new results. This bit is a zero at power on, after a preset and while a measurement is in Measuring States. See Triggering of Measurements .
0 | 1 | Extension Bit | This bit is always 0.

Program Examples - STATus:OPERation:NMRReady:GSM

OUTPUT 714;"STATUS:OPERATION:NMRREADY:GSM:EVENT?" !Queries and clears the Operation
                                                  !New Measurement Results Ready
                                                  !GSM Event Register
OUTPUT 714;"STATUS:OPERATION:NMRREADY:GSM:CONDITION?" !Queries and clears the Operation
                                                      !New Measurement Results Ready
                                                      !GSM Condition Register
OUTPUT 714;"STATUS:OPERATION:NMRREADY:GSM:ENABLE 1024" !Sets the Operation
                                                       !New Measurement Results Ready
                                                       !GSM Enable
                                                       !Register for bit 10
OUTPUT 714;"STATUS:OPERATION:NMRREADY:GSM:NTRANSITION 2" !Sets the Operation
                                                         !New Measurement Results Ready
                                                         !GSM Negative Transition
                                                         !Filter Register for bit 1
OUTPUT 714;"STATUS:OPERATION:NMRREADY:GSM:PTRANSITION 2" !Sets the Operation
                                                         !New Measurement Results Ready
                                                         !GSM Positive Tranasition
                                                         !Filter Register for bit 1

Related Topics

Triggering of Measurements


STATus:PRESet

STATus:PRESet

GPIB Command Conventions

  • STATus:PRESet

STATus:PRESet

Function

GSM TA

Presets the Status Subsystem

Sets all Enable Registers to 0 (not enabled).

Sets all Positive Transition Registers (PTR) to 1 (positive transitions enabled).

Sets all Negative Transition Registers (NTR) to 0 (negative transitions disabled).

GPRS TA
EGPRS TA

GSM/GPRS LA

EGPRS LA


STATus:QUEStionable

STATus:QUEStionable

GPIB Command Conventions

  • STATus:QUEStionable Condition Register Bit Assignment
  • STATus:QUEStionable:CALL Condition Register Bit Assignment
  • STATus:QUEStionable:CALL:COMMon Condition Register Bit Assignment
  • STATus:QUEStionable:CALL:GPRS Condition Register Bit Assignment
  • STATus:QUEStionable:CALL:GSM Condition Register Bit Assignment
  • STATus:QUEStionable:ERRors Condition Register Bit Assignment
  • STATus:QUEStionable:ERRors:COMMon Condition Register Bit Assignment
  • STATus:QUEStionable:ERRors:GPRS Condition Register Bit Assignment
  • STATus:QUEStionable:ERRors:GSM Condition Register Bit Assignment
  • STATus:QUEStionable:HARDware Condition Register Bit Assignment

STATus:QUEStionable Condition Register Bit Assignment

The STATus:QUEStionable register contains bits which give an indication that the data currently being acquired or generated is of questionable quality due to some condition affecting the functionality associated with that bit.

Bit Number | Binary Weighting | Condition | Description
15 | 32768 | Not Used. Defined by SCPI. | This bit is always 0.
14 | 16384 | Reserved for future use. | This bit is always 0.
13 | 8192 | Reserved for future use. | This bit is always 0.
12 | 4096 | Reserved for future use. | This bit is always 0.
11 | 2048 | QUEStionable:HARDware summary | This bit is the summary bit for the STATus:QUEStionable:HARDware register.
10 | 1024 | QUEStionable:CALL summary | This bit is the summary bit for the STATus:QUEStionable:CALL register.
9 | 512 | Reserved for future use. | This bit is always 0.
8 | 256 | Reserved for future use. | This bit is always 0.
7 | 128 | Reserved for future use. | This bit is always 0.
6 | 64 | Reserved for future use. | This bit is always 0.
5 | 32 | Reserved for future use. | This bit is always 0.
4 | 16 | Reserved for future use. | This bit is always 0.
3 | 8 | Reserved for future use. | This bit is always 0.
2 | 4 | Reserved for future use. | This bit is always 0.
1 | 2 | QUEStionable:ERRors summary | This bit is the summary bit for the STATus:QUEStionable:ERRors register.
0 | 1 | Reserved for future use. | This bit is always 0.

Program Example - STATus:QUEStionable Condition Register Bit Assignment

OUTPUT 714;"STATUS:QUESTIONABLE:EVENT?" !Queries and clears the Questionable Event
                                        !Register
OUTPUT 714;"STATUS:QUESTIONABLE:CONDITION?" !Queries and clears the Questionable Condition
                                            !Register
OUTPUT 714;"STATUS:QUESTIONABLE:ENABLE 1024" !Sets the Questionable Enable Register
                                             !for bit 10
OUTPUT 714;"STATUS:QUESTIONABLE:NTRANSITION 2" !Sets the Questionable Negative
                                               !Transition Filter Register for bit 1
OUTPUT 714;"STATUS:QUESTIONABLE:PTRANSITION 2" !Sets the Questionable Positive
                                               !Transition Filter Register for bit 1

STATus:QUEStionable:CALL Condition Register Bit Assignment

The STATus:QUEStionable:CALL registers contain information about which event(s) occurred during call processing that indicate what call processing procedure failed.

Bit Number | Binary Weighting | Condition | Description
15 | 32768 | Not Used. Defined by SCPI. | This bit is always 0.
14 | 16384 | Reserved for future use. | This bit is always 0.
13 | 8192 | Reserved for future use. | This bit is always 0.
12 | 4096 | GPRS Summary bit | This bit is the summary bit for the STATus:QUEStionable:CALL:GPRS register.
11 | 2048 | WCDMa Summary bit | This bit is the summary bit for the STATus:QUEStionable:CALL:WCDMa register.
10 | 1024 | FDD Summary bit | This bit is the summary bit for the STATus:QUEStionable:CALL:FDD register.
9 | 512 | TA2000 Summary bit | This bit is the summary bit for the STATus:QUEStionable:CALL:TA2000 register.
8 | 256 | CDMA Summary bit | This bit is the summary bit for the STATus:QUEStionable:CALL:CDMA register.
7 | 128 | DIGital2000 Summary bit | This bit is the summary bit for the STATus:QUEStionable:CALL:DIGital2000 register.
6 | 64 | DIGital95 Summary bit | This bit is the summary bit for the STATus:QUEStionable:CALL:DIGital95 register.
5 | 32 | TA136 Summary bit | This bit is the summary bit for the STATus:QUEStionable:CALL:TA136 register.
4 | 16 | DIGital136 Summary bit | This bit is the summary bit for the STATus:QUEStionable:CALL:DIGital136 register.
3 | 8 | AMPS Summary bit | This bit is the summary bit for the STATus:QUEStionable:CALL:AMPS register.
2 | 4 | GSM Summary bit | This bit is the summary bit for the STATus:QUEStionable:CALL:GSM register.
1 | 2 | COMMon Summary bit | This bit is the summary bit for the STATus:QUEStionable:CALL:COMMon register.
0 | 1 | Extension Bit | This bit is always 0.

Program Example - STATus:QUEStionable:CALL Condition Register Bit Assignment

OUTPUT 714;"STATUS:QUESTIONABLE:CALL:EVENT?"
  !Queries and clears the Questionable Call Event Register
OUTPUT 714;"STATUS:QUESTIONABLE:CALL:CONDITION?"
  !Queries and clears the Questionable Call Condition Register
OUTPUT 714;"STATUS:QUESTIONABLE:CALL:ENABLE 1024"
  !Sets the Questionable Call Enable Register for bit 10
OUTPUT 714;"STATUS:QUESTIONABLE:CALL:NTRANSITION 2"
  !Sets the Questionable Call Negative Transition Filter Registerfor bit 1
OUTPUT 714;"STATUS:QUESTIONABLE:CALL:PTRANSITION 2"
  !Sets the Questionable Call Positive Transition Filter Register for bit 1

STATus:QUEStionable:CALL:COMMon Condition Register Bit Assignment

The STATus:QUEStionable:CALL:COMMon registers contain information about which event(s) occurred during normal call processing that indicate why the call processing procedure failed.

Bit Number | Binary Weighting | Condition | Description
15 | 32768 | Not Used. Defined by SCPI. | This bit is always 0.
14 | 16384 | Reserved for future use. | This bit is always 0.
13 | 8192 | Reserved for future use. | This bit is always 0.
12 | 4096 | Reserved for future use. | This bit is always 0.
11 | 2048 | Reserved for future use. | This bit is always 0.
10 | 1024 | Reserved for future use. | This bit is always 0.
9 | 512 | Reserved for future use. | This bit is always 0.
8 | 256 | Reserved for future use. | This bit is always 0.
7 | 128 | Reserved for future use. | This bit is always 0.
6 | 64 | Reserved for future use. | This bit is always 0.
5 | 32 | Reserved for future use. | This bit is always 0.
4 | 16 | Reserved for future use. | This bit is always 0.
3 | 8 | Reserved for future use. | This bit is always 0.
2 | 4 | Reserved for future use. | This bit is always 0.
1 | 2 | Reserved for future use. | This bit is always 0.
0 | 1 | Extension Bit | This bit is always 0.

Program Example - STATus:QUEStionable:CALL:COMMon Condition Register Bit Assignment

OUTPUT 714;"STATUS:QUESTIONABLE:CALL:COMMON:EVENT?" !Queries and clears the Questionable
                                                    !Call Common Event Register
OUTPUT 714;"STATUS:QUESTIONABLE:CALL:COMMON:CONDITION?" !Queries and clears the Questionable
                                                        !Call Common Condition Register
OUTPUT 714;"STATUS:QUESTIONABLE:CALL:COMMON:ENABLE 1024" !Sets the Questionable Call Common
                                                         !Enable Register for bit 10
OUTPUT 714;"STATUS:QUESTIONABLE:CALL:COMMON:NTRANSITION 2" !Sets the Questionable Call
                                                           !Common Negative Transition
                                                           !Filter Register for bit 1
OUTPUT 714;"STATUS:QUESTIONABLE:CALL:GSM:PTRANSITION 2" !Sets the Questionable Call
                                                        !Common Positive Transition
                                                        !Filter Register for bit 1

STATus:QUEStionable:CALL:GPRS Condition Register Bit Assignment

The STATus:QUEStionable:CALL:GPRS registers contain information about which event(s) occurred during GSM call processing, relating to a data connection, that indicate why the call processing procedure failed. These register bits are not applicable to GSM.

Bit Number | Binary Weighting | Condition | Description
15 | 32768 | Not Used. Defined by SCPI. | This bit is always 0.
14 | 16384 | Reserved for future use. | This bit is always 0.
13 | 8192 | Reserved for future use. | This bit is always 0.
12 | 4096 | Reserved for future use. | This bit is always 0.
11 | 2048 | Reserved for future use. | This bit is always 0.
10 | 1024 | End Data Connection Failure | This bit is a 1 if the test set timed out waiting for the data connection to end.
9 | 512 | MS Unexpectedly Ended TBF | This bit is a 1 if the mobile station unexpectedly ended the TBF (temporary block flow).
8 | 256 | Downlink Immediate Assignment Failure | This bit is a 1 if the mobile station did not respond to the downlink immediate assignment.
7 | 128 | Uplink Immediate Assignment Failure | This bit is a 1 if the mobile station did not respond to the uplink immediate assignment.
6 | 64 | Downlink Timed Out | This bit is a 1 if the mobile station timed out ACK (Acknowledged) or NACK (Not Acknowledged) exchanges and released the TBF (temporary block flow).
5 | 32 | No Data Received Recently | This bit is a 1 if no data was received from the mobile station in the allowed time.
4 | 16 | Start Data Connection Failure | This bit is a 1 if the GPRS test application was unable to start the data connection with the DUT (Device Under Test).
3 | 8 | Routing Area Update Failure | This bit is a 1 if the Routing Area Update procedure failed after five attempts. The Data Connection Status will not be changed.
2 | 4 | Detach Failure | This bit is a 1 if the Detach procedure failed after five attempts. The Data Connection Status is set to Idle.
1 | 2 | Attach Failure | This bit is a 1 if the Attach procedure failed after five attempts. The Data Connection Status is set to Idle.
0 | 1 | Extension Bit | This bit is always 0.

Program Example - STATus:QUEStionable:CALL:GPRS Condition Register Bit Assignment

OUTPUT 714;"STATUS:QUESTIONABLE:CALL:GPRS:EVENT?" !Queries and clears the Questionable
                                                  !Call GPRS Event Register
OUTPUT 714;"STATUS:QUESTIONABLE:CALL:GPRS:CONDITION?" !Queries and clears the
                                                      !Questionable Call GPRS
                                                      !Condition Register
OUTPUT 714;"STATUS:QUESTIONABLE:CALL:GPRS:ENABLE 1024" !Sets the Questionable Call GPRS
                                                       !Enable Register for bit 10
OUTPUT 714;"STATUS:QUESTIONABLE:CALL:GPRS:NTRANSITION 2" !Sets the Questionable Call
                                                         !GPRS Negative Transition Filter
                                                         !Register for bit 1
OUTPUT 714;"STATUS:QUESTIONABLE:CALL:GPRS:PTRANSITION 2" !Sets the  Questionable Call GPRS
                                                           !Positive Transition Filter
                                                             !Register for bit 1

STATus:QUEStionable:CALL:GSM Condition Register Bit Assignment

The STATus:QUEStionable:CALL:GSM registers contain information about which event(s) occurred during GSM call processing that indicate why the call processing procedure failed.

Bit Number

Binary Weighting

Condition

Description

15

32768

Not Used. Defined by SCPI.

This bit is always 0.

14

16384

Reserved for future use.

This bit is always 0.

13

8192

Reserved for future use.

This bit is always 0.

12

4096

Reserved for future use.

This bit is always 0.

11

2048

Reserved for future use.

This bit is always 0.

10

1024

Reserved for future use.

This bit is always 0.

9

512

Call disconnected: Channel Mode not supported

This bit is a 1 if the mobile station is not capable of supporting the selected channel mode.

8

256

Identification failure

This bit is a 1 if the identity request timer (T3270) has expired. The timer expires if the mobile does not respond to identity request message, within 5 seconds.

7

128

Channel Assignment exceeded specified number of frames

This bit is a 1 if the channel assignment exceeded the specified number of frames.

6

64

Call disconnected: No Response to Page

This bit is a 1 if the paging timer (T3113) has expired. The timer expires if the mobile does not respond to a paging request message, within 5 seconds.

5

32

Call disconnected: Handover Failure

This bit is a 1 if the physical information timer (T3105) has expired. The timer expires if the mobile does not respond to a physical information message, within 50 ms.

If the timer has expired and correctly decoded data or a TCH frame has not been received, newly allocated channels are released.

4

16

Call disconnected: Channel Assignment Failure

This bit is a 1 if the channel assignment timer (T3107) has expired. The timer expires if the mobile does not respond to an assignment command message within 3 seconds.

3

8

Call disconnected: Immediate Assignment Failure

This bit is a 1 if the immediate assignment timer (T3101) has expired. The timer expires after 1 second if a signaling link is not established when an immediate assignment or immediate assignment extended message is sent.

If the timer expires, newly allocated channels are released.

2

4

Call disconnected: Radio Link Failure

This bit is a 1 if the radio link time out (T100) has expired. The timer expires if a radio link is not detected within four SACCH mulitframes (1.92 seconds if no SACCH is present).

1

2

Call disconnected: Data Link Failure

This bit is a 1 if the data link timer (T200) has expired. This timer is used for retransmission on the data link. The expiration period of the timer depends on the message type (for FACCH, 155 ms).

0

1

Extension Bit

This bit is always 0.

Program Example - STATus:QUEStionable:CALL:GSM Condition Register Bit Assignment

OUTPUT 714;"STATUS:QUESTIONABLE:CALL:GSM:EVENT?" !Queries and clears the Questionable
                                                 !Call GSM Event Register
OUTPUT 714;"STATUS:QUESTIONABLE:CALL:GSM:CONDITION?" !Queries and clears the Questionable
                                                     !Call GSM Condition Register
OUTPUT 714;"STATUS:QUESTIONABLE:CALL:GSM:ENABLE 1024" !Sets the Questionable
                                                      !Call GSM Enable Register for bit 10
OUTPUT 714;"STATUS:QUESTIONABLE:CALL:GSM:NTRANSITION 2" !Sets the Questionable Call
                                                        !GSM Negative Transition Filter Register
                                                        !for bit 1
OUTPUT 714;"STATUS:QUESTIONABLE:CALL:GSM:PTRANSITION 2" !Sets the Questionable Call
                                                        !GSM Positive Transition Filter Register
                                                        !for bit 1

STATus:QUEStionable:ERRors Condition Register Bit Assignment

The STATus:QUEStionable:ERRors register bits are used to indicate information about test set device-specific errors (positive error numbers).

Bit Number | Binary Weighting | Condition | Description
15 | 32768 | Not Used. Defined by SCPI. | This bit is always 0.
14 | 16384 | Reserved for future use. | This bit is always 0.
13 | 8192 | Reserved for future use. | This bit is always 0.
12 | 4096 | GPRS Summary bit | This bit is the summary bit for the QUEStionable:ERRors:GPRS register.
11 | 2048 | WCDMa Summary bit | This bit is the summary bit for the QUEStionable:ERRors:WCDMa register.
10 | 1024 | FDD Summary bit | This bit is the summary bit for the QUEStionable:ERRors:FDD register.
9 | 512 | TA2000 Summary bit | This bit is the summary bit for the QUEStionable:ERRors:TA2000 register.
8 | 256 | CDMA Summary bit | This bit is the summary bit for the QUEStionable:ERRors:CDMA register.
7 | 128 | DIGital2000 Summary bit | This bit is the summary bit for the QUEStionable:ERRors:DIGital2000 register.
6 | 64 | DIGital95 Summary bit | This bit is the summary bit for the QUEStionable:ERRors:DIGital95 register.
5 | 32 | TA136 Summary bit | This bit is the summary bit for the QUEStionable:ERRors:TA136 register.
4 | 16 | DIGital136 Summary bit | This bit is the summary bit for the QUEStionable:ERRors:DIGital136 register.
3 | 8 | AMPS Summary bit | This bit is the summary bit for the QUEStionable:ERRors:AMPS register.
2 | 4 | GSM Summary bit | This bit is the summary bit for the QUEStionable:ERRors:GSM register.
1 | 2 | COMMon Summary bit | This bit is the summary bit for the QUEStionable:ERRors:COMMon register.
0 | 1 | Extension Bit | This bit is always 0.

Program Example - STATus:QUEStionable:ERRors Condition Register Bit Assignment

OUTPUT 714;"STATUS:QUESTIONABLE:ERRORS:EVENT?"
  !Queries and clears the Questionable Errors Event Register
OUTPUT 714;"STATUS:QUESTIONABLE:ERRORS:CONDITION?"
  !Queries and clears the Questionable Errors Condition Register
OUTPUT 714;"STATUS:QUESTIONABLE:ERRORS:ENABLE 1024"
  !Sets the Questionable Errors Enable Register for bit 10
OUTPUT 714;"STATUS:QUESTIONABLE:ERRORS:NTRANSITION 2"
  !Sets the Questionable Errors Negative Transition Filter Register for bit 1
OUTPUT 714;"STATUS:QUESTIONABLE:ERRORS:PTRANSITION 2"
  !Sets the Questionable Errors Positive Transition Filter Register for bit 1

STATus:QUEStionable:ERRors:COMMon Condition Register Bit Assignment

The STATus:QUEStionable:ERRors:COMMon register bits are used to indicate information about the COMMon test set device-specific errors (positive error numbers).

Bit Number | Binary Weighting | Condition | Description
15 | 32768 | Not Used. Defined by SCPI. | This bit is always 0.
14 | 16384 | RUI Maskable Messages. | This bit is a 1 when a Maskable Message occurs.
13 | 8192 | Reserved for future use. | This bit is always 0.
12 | 4096 | Reserved for future use. | This bit is always 0.
11 | 2048 | Reserved for future use. | This bit is always 0.
10 | 1024 | Reserved for future use. | This bit is always 0.
9 | 512 | +900 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +900 to +999 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
8 | 256 | +800 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +800 to +899 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
7 | 128 | +700 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +700 to +799 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
6 | 64 | +600 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +600 to +699 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
5 | 32 | +500 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +500 to +599 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
4 | 16 | +400 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +400 to +499 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
3 | 8 | +300 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +300 to +399 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
2 | 4 | +200 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +200 to +299 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
1 | 2 | +100 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +100 to +199 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
0 | 1 | Extension Bit | This bit is always 0.

Program Example - STATus:QUEStionable:ERRors:COMMon Condition Register Bit Assignment

OUTPUT 714;"STATUS:QUESTIONABLE:ERRORS:COMMON:EVENT?" !Queries and clears the Questionable
                                                      !Errors Common Event Register
OUTPUT 714;"STATUS:QUESTIONABLE:ERRORS:COMMON:CONDITION?" !Queries the and clears the
                                                          !Questionable Errors
                                                          !Common Condition Register
OUTPUT 714;"STATUS:QUESTIONABLE:ERRORS:COMMON:ENABLE 1024" !Sets the Questionable
                                                           !Errors Common Enable
                                                           !Register for bit 10
OUTPUT 714;"STATUS:QUESTIONABLE:ERRORS:COMMON:NTRANSITION 2" !Sets the Questionable Errors
                                                             !Common Negative Transition
                                                             !Register for bit 1
OUTPUT 714;"STATUS:QUESTIONABLE:ERRORS:COMMON:PTRANSITION 2" !Sets the Questionable Errors
                                                             !Common Positive Tranasition
                                                             !Register for bit 1

STATus:QUEStionable:ERRors:GPRS Condition Register Bit Assignment

The STATus:QUEStionable:ERRors:GPRS register bits are used to indicate information about GPRS test set device-specific errors (positive error numbers).

Bit Number | Binary Weighting | Condition | Description
15 | 32768 | Not Used. Defined by SCPI. | This bit is always 0.
14 | 16384 | Reserved for future use. | This bit is always 0.
13 | 8192 | Reserved for future use. | This bit is always 0.
12 | 4096 | Reserved for future use. | This bit is always 0.
11 | 2048 | Reserved for future use. | This bit is always 0.
10 | 1024 | Reserved for future use. | This bit is always 0.
9 | 512 | +900 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +900 to +999 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you may query the Event Register to find out which of these errors occurred.
8 | 256 | +800 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +800 to +899 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you may query the Event Register to find out which of these errors occurred.
7 | 128 | +700 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +700 to +799 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you may query the Event Register to find out which of these errors occurred.
6 | 64 | +600 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +600 to +699 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you may query the Event Register to find out which of these errors occurred.
5 | 32 | +500 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +500 to +599 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you may query the Event Register to find out which of these errors occurred.
4 | 16 | +400 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +400 to +499 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you may query the Event Register to find out which of these errors occurred.
3 | 8 | +300 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +300 to +399 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you may query the Event Register to find out which of these errors occurred.
2 | 4 | +200 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +200 to +299 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you may query the Event Register to find out which of these errors occurred.
1 | 2 | +100 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +100 to +199 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you may query the Event Register to find out which of these errors occurred.
0 | 1 | Extension Bit | This bit is always 0.

Program Example - STATus:QUEStionable:ERRors:GPRS Condition Register Bit Assignment

OUTPUT 714;"STATUS:QUESTIONABLE:ERRORS:GPRS:EVENT?" !Queries and clears the Questionable
                                                    !Errors GPRS Event Register
OUTPUT 714;"STATUS:QUESTIONABLE:ERRORS:GPRS:CONDITION?" !Queries and clears the Questionable
                                                        !Errors Condition Register
OUTPUT 714;"STATUS:QUESTIONABLE:ERRORS:GPRS:ENABLE 1024" !Sets the Questionable
                                                         !Errors Enable Register for bit 10
OUTPUT 714;"STATUS:QUESTIONABLE:ERRORS:GPRS:NTRANSITION 2" !Sets the Questionable Errors
                                                          !GPRS Negative Transition Filter Register
                                                     !for bit 1
OUTPUT 714;"STATUS:QUESTIONABLE:ERRORS:GPRS:PTRANSITION 2" !Sets the Questionable Errors
                                                          !GPRS Positive Transition Filter Register
                                                          !for bit 1

STATus:QUEStionable:ERRors:GSM Condition Register Bit Assignment

The STATus:QUEStionable:ERRors:GSM register bits are used to indicate information about GSM test set device-specific errors (positive error numbers).

Bit Number | Binary Weighting | Condition | Description
15 | 32768 | Not Used. Defined by SCPI. | This bit is always 0.
14 | 16384 | Reserved for future use. | This bit is always 0.
13 | 8192 | Reserved for future use. | This bit is always 0.
12 | 4096 | Reserved for future use. | This bit is always 0.
11 | 2048 | Reserved for future use. | This bit is always 0.
10 | 1024 | Reserved for future use. | This bit is always 0.
9 | 512 | +900 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +900 to +999 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you may query the Event Register to find out which of these errors occurred.
8 | 256 | +800 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +800 to +899 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you may query the Event Register to find out which of these errors occurred.
7 | 128 | +700 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +700 to +799 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you may query the Event Register to find out which of these errors occurred.
6 | 64 | +600 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +600 to +699 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you may query the Event Register to find out which of these errors occurred.
5 | 32 | +500 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +500 to +599 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you may query the Event Register to find out which of these errors occurred.
4 | 16 | +400 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +400 to +499 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you may query the Event Register to find out which of these errors occurred.
3 | 8 | +300 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +300 to +399 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you may query the Event Register to find out which of these errors occurred.
2 | 4 | +200 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +200 to +299 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you may query the Event Register to find out which of these errors occurred.
1 | 2 | +100 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +100 to +199 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you may query the Event Register to find out which of these errors occurred.
0 | 1 | Extension Bit | This bit is always 0.

Program Example - STATus:QUEStionable:ERRors:GSM Condition Register Bit Assignment

OUTPUT 714;"STATUS:QUESTIONABLE:ERRORS:GSM:EVENT?" !Queries and clears the Questionable
                                                   !Errors GSM Event Register
OUTPUT 714;"STATUS:QUESTIONABLE:ERRORS:GSM:CONDITION?" !Queries and clears the Questionable
                                                       !Errors Condition Register
OUTPUT 714;"STATUS:QUESTIONABLE:ERRORS:GSM:ENABLE 1024" !Sets the Questionable
                                                        !Errors Enable Register for bit 10
OUTPUT 714;"STATUS:QUESTIONABLE:ERRORS:GSM:NTRANSITION 2" !Sets the Questionable Errors
                                                          !GSM Negative Transition Filter Register
                                                          !for bit 1
OUTPUT 714;"STATUS:QUESTIONABLE:ERRORS:GSM:PTRANSITION 2" !Sets the Questionable Errors
                                                          !GSM Positive Transition Filter Register
                                                          !for bit 1

STATus:QUEStionable:HARDware Condition Register Bit Assignment

The STATus:QUEStionable:HARDware register bits give an indication that the data/signals currently being acquired or generated are of questionable quality.

Bit Number | Binary Weighting | Condition | Description
15 | 32768 | Not Used. Defined by SCPI. | This bit is always 0.
14 | 16384 | Reserved for future use. | This bit is always 0.
13 | 8192 | Reserved for future use. | This bit is always 0.
12 | 4096 | Reserved for future use. | This bit is always 0.
11 | 2048 | Reserved for future use. | This bit is always 0.
10 | 1024 | Reserved for future use. | This bit is always 0.
9 | 512 | Reserved for future use. | This bit is always 0.
8 | 256 | Reserved for future use. | This bit is always 0.
7 | 128 | Reserved for future use. | This bit is always 0.
6 | 64 | Reserved for future use. | This bit is always 0.
5 | 32 | Reserved for future use. | This bit is always 0.
4 | 16 | Power-up Self Test(s) Failed | This bit is a 1 if the power-up self tests failed.
3 | 8 | Reserved for future use. | This bit is always 0.
2 | 4 | Reserved for future use. | This bit is always 0.
1 | 2 | Reserved for future use. | This bit is always 0.
0 | 1 | Extension Bit. | This bit is always 0.

Program Example - STATus:QUEStionable:HARDware Condition Register Bit Assignment

OUTPUT 714;"STATUS:QUESTIONABLE:HARDWARE:EVENT?" !Queries and clears the Questionable
                                                 !Hardware Event Register
OUTPUT 714;"STATUS:QUESTIONABLE:HARDWARE:CONDITION?" !Queries and clears the Questionable
                                                     !Hardware Condition Register
OUTPUT 714;"STATUS:QUESTIONABLE:HARDWARE:ENABLE 1024" !Sets the Questionable
                                                      !Hardware Enable
                                                      !Register for bit 10
OUTPUT 714;"STATUS:QUESTIONABLE:HARDWARE:NTRANSITION 2" !Sets the Questionable
                                                        !Hardware Negative Transition Filter
                                                        !Register for bit 1
OUTPUT 714;"STATUS:QUESTIONABLE:HARDWARE:PTRANSITION 2" !Sets the Questionable
                                                        !Hardware Positive Transition Filter
                                                        !Register for bit 1


Status Byte Register

Status Byte Register

  • *STB?

*STB?

The Status Byte Register can also be read with a serial poll. For example, the command "Status_byte = SPOLL(714)" would perform a serial poll of the Status Byte Register, returning and releasing RQS (bit 6).

Status Byte Register Bit Assignments

Note that only certain bit numbers in the Status Byte Register are applicable to GPRS as indicated in the "Description" column in the table below.

Bit Number | Binary Weighting | Label | Description
7 | 128 | STATus: OPERation | Summarizes the STATus: OPERation Status Register, which fans out to the NMRReady and CALL Status Registers.
6 | 64 | RQS (SRQ TRUE?)/Master Summary Status | RQS is read by a serial poll (SPOLL). Master Summary Status is read by a *STB? query - defined by IEEE 488.2
5 | 32 | Standard Event Status Register | Summarizes the Standard Event Status Register
4 | 16 | Message Available | SCPI - Defined
3 | 8 | STATus: QUEStionableStatus Register | Summary Message comes from the STATus: QUEStionable Status Register, which fans out to the CALL and HARDware Status Registers.
2 | 4 | Error/ Event Queue | SCPI - Defined
1 | 2 | Reserved |
0 | 1 | Reserved |

Program Example - Status Byte Register Bit Assignments

OUTPUT 714;"*STB?" !Queries the Status Byte.


Standard Event Status Register

Standard Event Status Register

GPIB Command Conventions

  • *ESR?
  • *ESE?
  • *ESE

*ESR?

*ESE?

*ESE

Standard Event Status Register Bit Assignment

Bit Number

Binary Weighting

Condition

Description

15

32768

Reserved by IEEE.

This bit will always be 0.

14

16384

Reserved by IEEE.

This bit will always be 0.

13

8192

Reserved by IEEE.

This bit will always be 0.

12

4096

Reserved by IEEE.

This bit will always be 0.

11

2048

Reserved by IEEE.

This bit will always be 0.

10

1024

Reserved by IEEE.

This bit will always be 0.

9

512

Reserved by IEEE.

This bit will always be 0.

8

256

Reserved by IEEE.

This bit will always be 0.

7

128

Power On

This bit is set to 1 if the power supply has been turned off and on since the last time this register was read or otherwise cleared. Defined in "IEEE Std. 488.2-1992",11.5.1.1.2

6

64

Reserved for future use.

This bit will always be 0.

5

32

Command Error

This bit is set to 1 if the test set detects an error while trying to process a command. The following events cause a command error:

  • An IEEE 488.2 syntax error. The test set received a message that did not follow the syntax defined by the standard.

  • A semantic error. For example the test set received an incorrectly spelled command.

  • The test set received a group execution trigger (GET) inside a program message

4

16

Execution Error

This bit is set to 1 if the test set detects an error while trying to execute a command. The following events cause a execution error:

  • A <PROGRAM DATA> element received in a command is outside the legal range for the test set, or it is inconsistent with the operation of the test set.

  • The test set could not execute a valid command due to some test set hardware/firmware condition.

3

8

Device Dependent Error

This bit is set to 1 if a test set operation does not execute properly due to an internal condition (such as, overrange). This bit indicates that the error was not a command, query, or execution error.

2

4

Query Error

This bit is set to 1 if an error has occurred while trying to read the test set's output queue. The following events cause a query error:

  • An attempt is made to read data from the output queue when no data is present or is pending.

  • Data in the output queue has been lost. An example of this would be an output queue overflow.

1

2

Reserved for future use.

This bit will always be 0.

0

1

Operation Complete

This bit is set to 1 when the test set has completed all pending operations and is ready to accept new commands. This bit is only generated in response to the *OPC IEEE 488.2 common command.

Program Example - Standard Event Status Register

OUTPUT 714;"*ESR?" !Queries (reads) the Standard Event Status Register.


GPIB Command Conventions

GPIB Command Conventions

Description

Command Description

The uppercase letters of a mnemonic represent the short form of the mnemonic, whereas the long form of a mnemonic is the short form followed by the lowercase letters. The test set accepts either the long form or the short form of the mnemonic.

The mnemonics that are inside square brackets are optional. That is, a command operates the same whether or not the mnemonic in square brackets is used in the command.

A vertical bar, |, implies choices. When mnemonics are listed in parentheses separated by vertical bars ( | ), you must choose one of the mnemonics inside the parentheses.

Complex Command Description

Complex commands are valuable because they set the state of the parameter and a value for that parameter. For example, a command that contains the mnemonic [:SAMPlitude] is a complex command that sets the state to ON as well as the amplitude. You can use parameters such as amplitude, frequency, gain, number, time, and value as a complex command. Refer to the specific command for the parameter that applies.

Data Type Description

num value

Integer, float or scientific values.

For example,

CALL:POWer -55.5

CALL:POWer -5.55E+001

CALL:CHANnel 525

string

Characters. The string will often need to be enclosed in single or double quotes, depending upon your programming environment.

For example,

CALL:CIDentity "#0123456789*"

CALL:UPLink:PRAChannel:ASUBchannels '111111111111'

The string returned by the test set is enclosed by double quotes.
choice1|choice2|choice3

Specific character choices.

For example,

CALL:OPERating:MODE D2KTest

SYSTem:COMMunicate:GPIB:DEBug ON

Unit Type Description

Some commands have optional units of measurement. These are displayed in square brackets. If no units are specified in the command then the default unit in bold font below is used. The test set accepts the specified unit either with or without a space inserted between the <num value> and the unit (for example, both 10S and 10 S are valid). The following table summarizes the units available.

Description

Optional Units

Example

Amplitude (linear)

V |MV

To set the spectrum monitor's timeout interval to 20 seconds, use any of the following formats:

SETup:SMONitor:TIMeout:TIME 20
SETup:SMONitor:TIMeout:TIME 20S
SETup:SMONitor:TIMeout:TIME 20 S

Power (logarithmic)

DBM |DBW

Level (relative)

DB

Frequency

HZ |KHZ|MHZ|GHZ

Time

S |MS|US|NS

Percentage

PCT

[:SELected] Mnemonic

The [:SELected] Mnemonic is an optional mnemonic that implies a current selection on the test set. Often there are other mnemonics that can be used in place of the [:SELected] mnemonic to configure a setting that is not the currently selected configuration on the test set. The mnemonics that can replace the [:SELected] mnemonic are listed in parentheses separated by vertical bars ( | ) in the description table title. An example of a command that contains the [:SELected] mnemonic is shown in the following table.

Using quotes around strings

When the setting and query values of a GPIB command are strings, a single quote is needed around the strings when setting the command, while the test set returns the result in double quoted strings when querying.

For example:

OUTPUT 714;"SYSTem:APPLication:FORMat '1xEV-DO'"

OUTPUT 714;"SYSTem:APPLication:FORMat?"
!The test set returns "1xEV-DO". Note here the strings are enclosed in double quote.

An example of a command that contains strings in the setting and query values is shown in the following table.


SYSTem:APPLication

SYSTem:APPLication

Last updated: December 9, 2008

GPIB Command Conventions

  • SYSTem:APPLication[:CURRent][:NAME]?
  • SYSTem:APPLication[:CURRent]:REVision?
  • SYSTem:APPLication:CATalog[:NAME]?
  • SYSTem:APPLication:CATalog[:NAME]:COUNt?
  • SYSTem:APPLication:CATalog:FORMat?
  • SYSTem:APPLication:CATalog:FORMat:COUNt?
  • SYSTem:APPLication:CATalog:LICense?<sp>'<application name>','<revision>'
  • SYSTem:APPLication:CATalog:LICense:APPLication:ALL?
  • SYSTem:APPLication:CATalog:LICense:APPLication:COUNt?
  • SYSTem:APPLication:CATalog:REVision?<sp>'<application name>'
  • SYSTem:APPLication:CATalog:REVision:COUNt?<sp>'<application name>'
  • SYSTem:APPLication:FORMat[:NAME]
  • SYSTem:APPLication:FORMat:LICense?<sp>'<format name>'
  • SYSTem:APPLication:FORMat:NAS|NASTratum
  • SYSTem:APPLication:SELect[:NAME]
  • SYSTem:APPLication:SELect:REVision
  • SYSTem:APPLication:SELect:REVision?<sp>'<application name>'

SYSTem:APPLication[:CURRent][:NAME]?

Function

Queries the name of the currently running application.

To query the revision of the currently running application, see SYSTem:APPLication[:CURRent]:REVision? .

To switch applications, see SYSTem:APPLication:SELect[:NAME] and SYSTem:APPLication:SELect:REVision .

Query

Range: See SYSTem:APPLication:CATalog[:NAME]? .

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SYSTem:APPLication?"

SYSTem:APPLication[:CURRent]:REVision?

Function

Queries the revision of the currently running application.

To query the name of the currently running application, see SYSTem:APPLication[:CURRent][:NAME]? .

To switch to a different revision of an application, see SYSTem:APPLication:SELect[:NAME] and SYSTem:APPLication:SELect:REVision .

Query

Range: 0 to 20 characters from the set .0123456789aAbBcCdDeEfF, enclosed by double quotes. For example, "A.01.01"

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SYSTem:APPLication:REVision?"

SYSTem:APPLication:CATalog[:NAME]?

Function

Queries the names of the applications stored on the test set.

This query returns a comma-separated list of double-quoted strings (one for each application stored on the test set).

To query the number of applications stored on the test set, see SYSTem:APPLication:CATalog[:NAME]:COUNt? .

To switch applications, see SYSTem:APPLication:SELect[:NAME] and SYSTem:APPLication:SELect:REVision .

Query

Range: One or more of the following strings, separated by commas -

  • "1xEV-DO FTM Terminal Test"
  • "1xEV-DO Lab App"
  • "1xEV-DO Lab App B"
  • "1xEV-DO Lab App T"
  • "1xEV-DO Lab App U'
  • "1xEV-DO Terminal Test"
  • "AMPS/136 Mobile Test"
  • "CDMA 2000 Lab App"
  • "CDMA 2000 Lab App B"
  • "CDMA 2000 Lab App T"
  • "CDMA 2000 Mobile Test"
  • "CDMA 2000_1xEV-DO"
  • "EGPRS Lab App"
  • "Fast Switch Test App"
  • "GPRS Lab Application"
  • "GPRS Lab App B"
  • "GPRS Mobile Test"
  • "GSM Mobile Test"
  • "GSM/GPRS Lab App C"
  • "GSM/GPRS Lab App D"
  • "GSM/GPRS Lab App E"
  • "GSM/GPRS Lab App F"
  • "GSM/GPRS Lab App T"
  • "GSM/GPRS Lab App U"
  • "GSM/GPRS Mobile Test"
  • "GSM/GPRS RF Modem"
  • "GSM/GPRS_AMPS/136"
  • "GSM/GPRS_AMPS/136_WCDMA"
  • "GSM/GPRS_CDMA 2000"
  • "GSM/GPRS_WCDMA Lab App"
  • "GSM/GPRS_WCDMA Lab App B"
  • "GSM/GPRS_WCDMA Lab App C"
  • "GSM/GPRS_WCDMA Lab App D"
Query (continued)
  • "GSM/GPRS_WCDMA Lab App E"
  • "GSM/GPRS_WCDMA Lab App T"
  • "GSM/GPRS_WCDMA Lab App U"
  • "WCDMA Lab App"
  • "WCDMA Lab App B"
  • "WCDMA Lab App C"
  • "WCDMA Lab App D"
  • "WCDMA Lab App E"
  • "WCDMA Lab App T"
  • "WCDMA Lab App U"
  • "WCDMA Mobile Test"

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SYSTem:APPLication:CATalog?"

SYSTem:APPLication:CATalog[:NAME]:COUNt?

Function

Queries the total number of applications stored on the test set.

To query the names of the applications stored on the test set, see SYSTem:APPLication:CATalog[:NAME]? .

Query

Range: 0 through 30

Resolution: 1

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SYSTem:APPLication:CATalog:COUNt?"

SYSTem:APPLication:CATalog:FORMat?

Function

Queries the names of the formats in the current application.

This query returns a comma-separated list of double-quoted strings (one for each format in the application).

To query the number of formats in the current application, see SYSTem:APPLication:CATalog:FORMat:COUNt? .

To switch formats in a fast switching application, see SYSTem:APPLication:FORMat[:NAME] .

Query

Range: One or more of the following strings separated by commas -

  • "1xEV-DO"
  • "AMPS/136"
  • "GSM/GPRS" (Note: this query return represents GSM, GPRS and EGPRS formats)
  • "IS-2000/IS-95/AMPS"
  • "IS-856"
  • "WCDMA"

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SYSTem:APPLication:CATalog:FORMat?"

SYSTem:APPLication:CATalog:FORMat:COUNt?

Function

Queries the number of formats in the current application.

To query the names of the formats in the current application, see SYSTem:APPLication:CATalog:FORMat? .

Query

Range: 0 to 30

Resolution: 1

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SYSTem:APPLication:CATalog:FORMat:COUNt?"

SYSTem:APPLication:CATalog:LICense?<sp>'<application name>','<revision>'

Function

Queries the license status for the specified application/revision. The application/revision does not have to be installed in the test set.

The query must include a parameter for the application name and revision, enclosed by single quotes and separated by a comma. For application names and revisions, see SYSTem:APPLication:CATalog[:NAME]? and SYSTem:APPLication:CATalog:REVision?<sp>'<application name>' . Note that the application name and revision parameters are not case-sensitive.

Query

Range: LIC|NLIC|PART|UNKN

  • "LIC" indicates this is a licensed application/revision.
  • "NLIC" indicates this is not a licensed application/revision.
  • "PART" indicates that not all of the formats in this application/revision are licensed. (To determine the license status of each format, see SYSTem:APPLication:FORMat:LICense?<sp>'<format name>' .)
  • "UNKN" indicates that license status is unknown.

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SYSTem:APPLication:CATalog:LICense? 'CDMA 2000 Mobile Test','B.07.00'"

SYSTem:APPLication:CATalog:LICense:APPLication:ALL?

Function

Queries the names of the applications, formats and features that are licensed for the test set. The applications, formats and features do not have to be installed in the test set to be returned by this query.

This query returns a comma-separated list of double-quoted strings (two for each application, one for each format or feature).

To query the number of licensed applications, formats and features for the test set, see SYSTem:APPLication:CATalog:LICense:APPLication:COUNt? .

Query

Range: One or more of the following strings, separated by commas.

Applications -

  • "E1960A","GSM Mobile Test"
  • "E1961A","AMPS/136 TA"
  • "E1962B","CDMA2000 TA"
  • "E1963A","WCDMA TA"
  • "E1964A","GPRS Mobile Test"
  • "E1966A","1xEV-DO TA"
  • "E1968A","GSM/GPRS Mobile Test"
  • "E1976A","1xEV-DO FTM TA"
  • "E1985A","GSM/GPRS_AMPS/136"
  • "E1985B","GSM/GPRS_AMPS/136_WCDMA"
  • "E1985C","GSM/GPRS_CDMA 2000"
  • "E1985E","CDMA 2000_1xEV-DO"
  • "E1987A","Fast Switch Test App"
  • "E6590A","GSM/GPRS RF Modem"
  • "E6701A","GPRS LA"
  • "E6701B","GPRS LA rev B"
  • "E6701C","GSM/GPRS LA rev C"
  • "E6701D","GSM/GPRS LA rev D"
  • "E6701E","GSM/GPRS LA rev E"
  • "E6701F","GSM/GPRS LA rev F"
  • "E6701T","GSM/GPRS LA rev T"
  • "E6701U","GSM/GPRS LA rev U"
  • "E6702A","CDMA2000 LA"
  • "E6702B","CDMA2000 LA rev B"
  • "E6702T","CDMA2000 LA rev T"
  • "E6703A","WCDMA LA"
  • "E6703B","WCDMA LA rev B"
  • "E6703C","WCDMA LA rev C"
  • "E6703D","WCDMA LA rev D"
  • "E6703E","WCDMA LA rev E"
  • "E6703T","WCDMA LA rev T"
  • "E6703U","WCDMA LA rev U"
Query (continued)
  • "E6704A","EGPRS LA"
  • "E6706A","1xEV-DO Lab App"
  • "E6706B","1xEV-DO LA rev B"
  • "E6706T","1xEV-DO LA rev T"
  • "E6706U","1xEV-DO LA rev U"
  • "E6785A","GSM/GPRS_WCDMA Lab App"
  • "E6785B","GSM/GPRS_WCDMA LA rev B"
  • "E6785C","GSM/GPRS_WCDMA LA rev C"
  • "E6785D","GSM/GPRS_WCDMA LA rev D"
  • "E6785T","GSM/GPRS_WCDMA LA rev T"

Formats -

  • "E1968A-101","GSM TA"
  • "E1968A-102","GPRS TA"
  • "E1968A-103","EGPRS TA"
  • "E1968A-201","GSM/GPRS TA"
  • "E1968A-202","GSM/GPRS/EGPRS TA"
  • "E6590A-101","GSM/GPRS"
  • "E6590A-102","EGPRS"
  • "E6590A-103","RF Modem"

Features -

  • "E1962B-401","CDMA2000 RelA"
  • "E1962B-402","AMPS Enhancement"
  • "E1962B-403","CDMA2000 Authenticat"
  • "E1963A-401","WCDMA Video Call"
  • "E1963A-403","HSDPA Test Modes"
  • "E1966A-102","1xEV-DO RelA"
  • "E1968A-410","Phase & Ampl vs Time"
  • "E1976A-102","1xEV-DO RelA FTM"
  • "E1999A-201","Fast Device Tune"
  • "E6706A-102","1xEV-DO Rel A ETAP"
  • "E6706T-102","1xEV-DO Rel A ETAP"

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SYSTem:APPLication:CATalog:LICense:APPLication:ALL?"

SYSTem:APPLication:CATalog:LICense:APPLication:COUNt?

Function

Queries the number of applications, formats and features that are licensed for the test set. The applications, formats and features do not have to be installed in the test set to be included in the query result.

To query the names of the licensed applications, formats and features for the test set, see SYSTem:APPLication:CATalog:LICense:APPLication:ALL? .

Query

Range: 0 to 300

Resolution: 1

Requirements

Test Application Revision: B.08 and above

Lab Application Revision: B.02 and above

Programming Example

OUTPUT 714;"SYSTem:APPLication:CATalog:LICense:APPLication:COUNt?"

SYSTem:APPLication:CATalog:REVision?<sp>'<application name>'

Function

Queries the revisions stored on the test set for the specified application.

The query must include a parameter for the application name enclosed by single quotes. For application names, see SYSTem:APPLication:CATalog[:NAME]? . Note that the application name parameter is not case-sensitive.

This query returns a comma-separated list of double-quoted strings (one for each revision of the application).

Note, if you have several revisions of the application stored on the test set, you may need to increase your GPIB controller's timeout time to avoid a timeout condition.

To query the number of revisions stored on the test set for the specified application, see SYSTem:APPLication:CATalog:REVision:COUNt?<sp>'<application name>' .

To switch to a different revision of an application, see SYSTem:APPLication:SELect[:NAME] and SYSTem:APPLication:SELect:REVision .

Query

 Range: Comma-separated list of 0 to 20 characters from the set .0123456789aAbBcCdDeEfF, enclosed by double quotes. For example, "A.01.01","A.02.01"

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SYSTem:APPLication:CATalog:REVision? 'CDMA 2000 MOBILE TEST'"

SYSTem:APPLication:CATalog:REVision:COUNt?<sp>'<application name>'

Function

Queries the number of revisions stored on the test set for the specified application.

The query must include a parameter for the application name enclosed by single quotes. For application names, see SYSTem:APPLication:CATalog[:NAME]? . Note that the application name parameter is not case-sensitive.

To query the revision numbers stored on the test set for the specified application, see SYSTem:APPLication:CATalog:REVision?<sp>'<application name>' .

Query

Range: 0 to 30

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SYSTem:APPLication:CATalog:REVision:COUNt? 'CDMA 2000 MOBILE TEST'"

SYSTem:APPLication:FORMat[:NAME]

Function

Switches to the specified format (in the current application). Only fast switching applications include more than one format. To determine what formats are available in the current application, see SYSTem:APPLication:CATalog:FORMat? . To determine the license status of a format, see SYSTem:APPLication:FORMat:LICense?<sp>'<format name>' .

Queries the name of the currently active format in the current application.

Setting

Range:

  • 1xEV-DO
  • AMPS/136
  • GSM/GPRS (Note: this query return represents GSM, GPRS and EGPRS formats)
  • IS-2000/IS-95/AMPS
  • IS-856
  • WCDMA

Query

Same as setting.

Note: The query result is returned within a pair of double quotation marks. For example, if the current application is GSM/GPRS, the test set returns "GSM/GPRS" .

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SYSTem:APPLication:FORMat 'IS-2000/IS-95/AMPS'"

OUTPUT 714;"SYSTem:APPLication:FORMat?"

SYSTem:APPLication:FORMat:LICense?<sp>'<format name>'

Function

Queries the license status of the specified format in the current application.

The query must include a parameter for the format name enclosed by single quotes. For format names, see SYSTem:APPLication:CATalog:FORMat? . Note that the format name parameter is not case-sensitive.

Query

Range: LIC|NLIC|UNKN

  • "LIC" indicates this is a licensed format.
  • "NLIC" indicates this is not a licensed format.
  • "UNKN" indicates that the license status is unknown.

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SYSTem:APPLication:FORMat:LICense? 'IS-2000/IS-95/AMPS'"

SYSTem:APPLication:FORMat:NAS|NASTratum

Function

 Sets/Queries whether or not the Non-Access Stratum (NAS) state of the test set will be preserved when a Fast Switch between two RATs (GSM/GPRS/EGPRS and WCDMA) or a switch between GSM/GPRS/EGPRS and UMA/GAN occurs. When this parameter is set to PREServe, the state of the session management (SM), GPRS Mobility Management (GMM), Mobility Management (MM), Call Control (CC) and Logical Link Layer (LLC) are preserved.

Setting

Range: PREServe | CLEar

Query

Range: PRES | CLE

*RST Setting

CLEar

Requirements

Lab Application Revision: G.00.00 and above

Programming Example

OUTPUT 714;"SYSTem:APPLication:FORMat:NAS CLEar"
! The NAS State will not be preserved after a switch.

SYSTem:APPLication:SELect[:NAME]

Function

Switches to the specified application (this includes a reboot of the test set). To determine what applications are stored on the test set, see SYSTem:APPLication:CATalog[:NAME]? . The revision that is switched to is determined by SYSTem:APPLication:SELect:REVision . To determine the license status of the application/revision, see SYSTem:APPLication:CATalog:LICense?<sp>'<application name>','<revision>' .

Queries the name of the application that will be loaded after the next reboot of the test set.

Setting

Range: See SYSTem:APPLication:CATalog[:NAME]? .

Query

Range: See SYSTem:APPLication:CATalog[:NAME]? .

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SYSTem:APPLication:SELect 'CDMA 2000 MOBILE TEST'"

OUTPUT 714;"SYSTem:APPLication:SELect?"

SYSTem:APPLication:SELect:REVision

Function

Sets the revision that will be loaded when the application is switched to using the SYSTem:APPLication:SELect[:NAME] command.

To determine what application is to be switched to, see SYSTem:APPLication:SELect[:NAME] . To determine what revisions are stored on the test set for the specified application, see SYSTem:APPLication:CATalog:REVision?<sp>'<application name>' . To determine the license status of a revision, see SYSTem:APPLication:CATalog:LICense?<sp>'<application name>','<revision>' .

To query the revision that will be loaded when an application is switched to, see SYSTem:APPLication:SELect:REVision?<sp>'<application name>' .

NOTE
GSM Mobile Test revisions prior to A.04.00 did not have application switching and provide no way to return to revisions that have switching. If you switch to a GSM Mobile Test application revision prior to A.04.00, the only way to return to a newer revision is by downloading it using the process for upgrading firmware.

Setting

Range: see SYSTem:APPLication:CATalog[:NAME]? and SYSTem:APPLication:CATalog:REVision?<sp>'<application name>' .

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SYSTem:APPLication:SELect:REVision 'CDMA 2000 Mobile Test','B.06.30'"

SYSTem:APPLication:SELect:REVision?<sp>'<application name>'

Function

Queries the revision that will be loaded when the specified application is switched to using the SYSTem:APPLication:SELect[:NAME] command.

The query must include a parameter for the application name enclosed by single quotes. For application names, see SYSTem:APPLication:CATalog[:NAME]? . Note that the application name parameter is not case-sensitive.

To set the revision that will be loaded when the specified application is switched to, see SYSTem:APPLication:SELect:REVision .

NOTE
GSM Mobile Test revisions prior to A.04.00 did not have application switching and provide no way to return to revisions that have switching. If you switch to a GSM Mobile Test application revision prior to A.04.00, the only way to return to a newer revision is by downloading it using the process for upgrading firmware.

Query

 Range: 0 to 20 characters from the set .0123456789aAbBcCdDeEfF, enclosed by double quotes. For example, "A.01.01"

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SYSTem:APPLication:SELect:REVision? `CDMA 2000 MOBILE TEST'"

Related Topics

Application Switching


SYSTem:AUDio

SYSTem:AUDio

GPIB Command Conventions

  • SYSTem:AUDio:OUTPut:SOURce
  • SYSTem:AUDio:OUTPut:FMDemod:BPFilter:STATe
  • SYSTem:AUDio:OUTPut:FMDemod:EXPandor:STATe
  • SYSTem:AUDio:OUTPut:FMDemod:DEEMphasis:STAT

SYSTem:AUDio:OUTPut:SOURce

Function

GSM TA

Set/queries whether the audio generator signal or the FM demodulation signal is selected to be routed to the AUDIO OUT port of the test set's front panel.

When audio generator is selected for output at the front-panel AUDIO OUT port, use AFGenerator Subsystem to control the audio generator.

NOTE
The selection of FM Demod signal is useful only in AMPS system. A bandpass filter, expander circuit, and deemphasis circuit can be individually inserted or bypassed in the FM Demod signal path. Use the command SYSTem:AUDio:OUTPut:FMDemod:BPFilter:STATe to insert the bandpass filter. Use the command SYSTem:AUDio:OUTPut:FMDemod:EXPandor:STATe to insert the expandor circuit. Use the command SYSTem:AUDio:OUTPut:FMDemod:DEEMphasis:STAT to insert the deemphasis filter.

NOTE
There will be no guaranteed performance for the signal present at the Audio Out port when FM Demod is selected for output.
GPRS TA
EGPRS TA

GSM/GPRS LA

EGPRS LA

Setting

AFGenerator|FMDemod

Query

AFG|FMD

*RST Setting

AFG

Requirements

GSM/GPRS/
EGPRS TA

Revision: A.01 and above

GSM/GPRS/
EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SYSTem:AUDio:OUTPut:SOURce FMDemod"
! Selects FM Demod signal for output at the front panel AUDIO OUT port.

SYSTem:AUDio:OUTPut:FMDemod:BPFilter:STATe

Function

GSM TA

Sets/queries whether the fixed bandpass filter is inserted or bypassed in the FM Demod signal path. It is useful only when FM Demod signal is selected for output at the front-panel AUDIO OUT port (see SYSTem:AUDio:OUTPut:SOURce ).

When the state is ON, a 300 Hz to 3 KHz bandpass filter is inserted in the audio signal path. When the state is OFF, the bandpass filter is bypassed in the audio signal path
GPRS TA
EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting | Range: 0|OFF|1|ON

Query

Range: 0|1
*RST setting | 0 (OFF)

Requirements

GSM/GPRS/
EGPRS TA

Revision: A.01 and above

GSM/GPRS/
EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SYSTem:AUDio:OUTPut:FMDemod:BPFilter:STATe ON"
! Sets the bandpass filter state to ON.

SYSTem:AUDio:OUTPut:FMDemod:EXPandor:STATe

Function

GSM TA

Sets/queries whether the expandor filter is inserted or bypassed in the FM Demod signal path. It is useful only when FM Demod signal is selected for output at the front-panel AUDIO OUT port (see SYSTem:AUDio:OUTPut:SOURce ).

When the state is ON, the expandor filter is inserted in the audio signal path. When the state is OFF, the expandor filter is bypassed in the audio signal path.
GPRS TA
EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting | Range: 0|OFF|1|ON

Query

Range: 0|1
*RST setting | 0 (OFF)

Requirements

GSM/GPRS/
EGPRS TA

Revision: A.01 and above

GSM/GPRS/
EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SYSTem:AUDio:OUTPut:FMDemod:EXPandor:STATe ON"
! Sets the expandor filter state to ON.

SYSTem:AUDio:OUTPut:FMDemod:DEEMphasis:STAT

Function

GSM TA

Sets/queries whether the deemphasis filter is inserted or bypassed in the FM Demod signal path. It is useful only when FM Demod signal is selected for output at the front-panel AUDIO OUT port (see SYSTem:AUDio:OUTPut:SOURce ).

When the state is ON, the deemphasis filter is inserted in the audio signal path. When the state is OFF, the deemphasis filter is bypassed in the audio signal path.
GPRS TA
EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting | Range: 0|OFF|1|ON

Query

Range: 0|1
*RST setting | 0 (OFF)

Requirements

GSM/GPRS/
EGPRS TA

Revision: A.01 and above

GSM/GPRS/
EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SYSTem:AUDio:OUTPut:FMDemod:DEEMphasis:STATe ON"
! Sets the deemphasis filter state to ON.


SYSTem:BEEPer

SYSTem:BEEPer

GPIB Command Conventions

  • SYSTem:BEEPer:STATe

SYSTem:BEEPer:STATe

Function

GSM TA

Sets/queries the beeper state of the test set.
GPRS TA
EGPRS TA

GSM/GPRS LA

EGPRS LA

Setting

Range: 0 | OFF | 1 | ON

Query

Range: 0 | 1

*RST Setting

1 | ON
Requirements

GSM/GPRS/
EGPRS TA

Revision: A.01 and above

GSM/GPRS/
EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SYSTEM:BEEPER:STATE OFF"
! Sets beeper state to off.


SYSTem:COMMunicate

SYSTem:COMMunicate

Last updated: December 4, 2008

GPIB Command Conventions

  • SYSTem:COMMunicate:GPIB:[:SELF]:ADDRess
  • SYSTem:COMMunicate:GPIB:DEBug[:STATe]
  • SYSTem:COMMunicate:LAN[:SELF]:ADDRess
  • SYSTem:COMMunicate:LAN[:SELF]:ADDRess2
  • SYSTem:COMMunicate:LAN[:SELF]:DGATeway
  • SYSTem:COMMunicate:LAN[:SELF]:SMASk

SYSTem:COMMunicate:GPIB:[:SELF]:ADDRess

Function

GSM TA

 Sets/queries the test set's GPIB address.
GPRS TA
EGPRS TA

GSM/GPRS LA

EGPRS LA

Setting

Range: 0 to 30

Resolution: 1

Query

Range: 0 to 30

Resolution: 1

Factory setting

14 (this parameter is not affected by any reset operation and can only be changed by direct user access)
Related Topics Configuring the Test Set's GPIB Address
Requirements

GSM/GPRS/
EGPRS TA

Revision: A.01 and above

GSM/GPRS/
EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SYSTEM:COMMUNICATE:GPIB:SELF:ADDRESS 14"
! Sets the GPIB address to 14.

SYSTem:COMMunicate:GPIB:DEBug[:STATe]

Function

GSM TA

Sets/queries the test set's SCPI debugger state.

When the state is on, enhanced error messages (generated from GPIB commands with syntax errors) are shown on the test set display.

The error message is printed along with the syntax. <ERR> is displayed at the end of the incorrect node. Non-printable characters will be replaced with the $ symbol. See Error Messages for a list of the errors.

The debugger state should be set to on only during GPIB code development. Test times will increase if the debugger state is left on.
GPRS TA
EGPRS TA

GSM/GPRS LA

EGPRS LA

Setting

 Range: 0 | OFF | 1 | ON
Query Range: 0 | 1

*RST setting

0 | OFF
Requirements

GSM/GPRS/
EGPRS TA

Revision: A.01 and above

GSM/GPRS/
EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SYSTEM:COMMUNICATE:GPIB:DEBUG:STATE ON"
! Sets debugger to on.

SYSTem:COMMunicate:LAN[:SELF]:ADDRess

Function

GSM TA

Sets/queries the test set's LAN IP address. The value of A is used to determine the subnet mask, see SYSTem:COMMunicate:LAN[:SELF]:SMASk .

If the LAN address is changed the subnet mask should be checked to insure that it is set to the proper class for that LAN address.

If the LAN IP address is changed the subnet mask should be checked to insure that it is set to the proper class for that LAN address. (See Configuring the Test Set's LAN )The LAN IP address cannot be changed when CALL:OPERating:MODE is set to CALL.
GPRS TA
EGPRS TA

GSM/GPRS LA

EGPRS LA

Setting

Range: 15 characters formatted as follows: A.B.C.D. The range of values for A= 0 to 126 and 128 to 223. The range of values for B.C. D = 0 to 255 (no embedded spaces).

Query

Range: 15 characters formatted as follows: A.B.C.D. The range of values for A= 0 to 126 and 128 to 223. The range of values for B.C.D = 0 to 255 (no embedded spaces).

Factory setting

0.0.0.0 (this parameter is not affected by any reset operation and can only be changed by direct user access)
Related Topics LAN IP Address
Requirements

GSM/GPRS/
EGPRS TA

Revision: A.01 and above

GSM/GPRS/
EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SYSTEM:COMMUNICATE:LAN:SELF:ADDRESS '130.015.156.255'"
! Sets the LAN IP address.

SYSTem:COMMunicate:LAN[:SELF]:ADDRess2

Function

GSM TA

Sets/queries the test set's LAN 2 PORT IP address.

GPRS TA
EGPRS TA

GSM/GPRS LA

EGPRS LA

Setting

Range: 15 characters formatted as follows: A.B.C.D. The range of values for A= 0 to 126 and 128 to 223. The range of values for B.C. D = 0 to 255 (no embedded spaces).

Query

Range: 15 characters formatted as follows: A.B.C.D. The range of values for A= 0 to 126 and 128 to 223. The range of values for B.C.D = 0 to 255 (no embedded spaces).

Factory setting

0.0.0.0 (this parameter is not affected by any reset operation and can only be changed by direct user access)
Related Topics LAN 2 PORT
Requirements

GSM/GPRS/
EGPRS TA

Revision: A.09 and above

GSM/GPRS/
EGPRS LA

Revision: F.01 and above

Programming Example

OUTPUT 714;"SYSTEM:COMMUNICATE:LAN:SELF:ADDRESS2 '130.015.156.255'"
! Sets the LAN 2 IP address.

SYSTem:COMMunicate:LAN[:SELF]:DGATeway

Function

GSM TA

Sets/queries the LAN IP router/gateway address for the test set.

GPRS TA
EGPRS TA

GSM/GPRS LA

EGPRS LA

Setting

Range: 15 characters formatted as follows: A.B.C.D where A= 0 to 223 B,C,D = 0 to 255 (no embedded spaces), blank field

Query

Range: 15 characters formatted as follows: A.B.C.D where A,B,C,D = 0 to 255 (no embedded spaces). blank field

Factory setting

blank field, (this parameter is not affected by any reset operation)
Requirements

GSM/GPRS/
EGPRS TA

Revision: A.01 and above

GSM/GPRS/
EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SYSTEM:COMMUNICATE:LAN:SELF:DGATEWAY '130.2.6.200'"

SYSTem:COMMunicate:LAN[:SELF]:SMASk

Function

GSM TA

Sets/queries the subnet mask of the test set based on the LAN IP address selected. The subnet mask changes according to the value of A used for the LAN IP address.

If A is less than 127, the default subnet mask is 255.0.0.0.

If A is greater than 127 and less or equal to 191, the default subnet mask is 222.255.0.0.

If A is greater than 191, the default subnet mask is 255.255.255.0.

If the LAN address is changed the subnet mask should be checked to insure that it is set to the proper class for that LAN address.
GPRS TA
EGPRS TA

GSM/GPRS LA

EGPRS LA

Setting

Range: 15 characters formatted as follows: A.B.C.D where A,B,C,D are between = 0 to 255 (no embedded spaces)

Query

Range: 15 characters formatted as follows: A.B.C.D where A,B,C,D are between = 0 to 255 (no embedded spaces)

Factory setting

0.0.0.0 (this parameter is not affected by any reset operation and can only be changed by direct user access)
Requirements

GSM/GPRS/
EGPRS TA

Revision: A.01 and above

GSM/GPRS/
EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SYSTEM:COMMUNICATE:LAN:SELF:SMASK '255.2.6.200'"


SYSTem:CONFigure

SYSTem:CONFigure

GPIB Command Conventions

  • SYSTem:CONFigure:INFormation:HARDware:VERBose?

SYSTem:CONFigure:INFormation:HARDware:VERBose?

Function | GSM TA | Queries the manufacturer, model number, model number of the test application running, serial number, revision, board ID, and cal file information. The information provided by the query represents the configuration that existed when the test set was powered up. For an example of how to use this command, see Hardware Configuration Report .
 | GPRS TA
 | EGPRS TA
 | GSM/GPRS LA
 | EGPRS LA
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.01 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.01 and above
*RST Setting |  | Resets have no effect on this information. The information is gathered during the power up cycle.

Related Topics

Hardware Configuration Report


SYSTem:CORRection

SYSTem:CORRection

GPIB Command Conventions

  • SYSTem:CORRection:[:SGAin]
  • SYSTem:CORRection:FREQuency
  • SYSTem:CORRection:GAIN
  • SYSTem:CORRection:POINts
  • SYSTem:CORRection:SFRequency
  • SYSTem:CORRection:STATe

SYSTem:CORRection:[:SGAin]

Function

GSM TA

Sets/queries the up to 20 comma separated offset values in dB. This command sets the state to On.

See Amplitude Offset .

The units, dB, are optional. If no units are specified then units default to dB.

Sending a null list (no values) sets the state of all offsets to Off.
GPRS TA
EGPRS TA

GSM/GPRS LA

EGPRS LA

Setting

Range: 0 to 20 values between -100 to +100

Resolution: 0.01

Query

Range: 1 to 20 values between -100 to +100, and NAN (9.91E+37)

Resolution: 0.01

Factory Setting

Offsets 1 through 20, are set to 0.00 dB, state is set to Off
Requirements

GSM/GPRS/
EGPRS TA

Revision: A.01 and above

GSM/GPRS/
EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SYSTEM:CORRECTION:SGAIN -2.55,-3.12,-3.68,-4.23,-4.74,-5.3"
!A complex command that sets up to 20 comma separated offsets and sets the state to On
! for the frequencies, offsets and RF IN/OUT Amplitude Offset State

OUTPUT 714;"SYSTEM:CORRECTION:SGAIN"
! Sets the state for all frequencies and offsets to Off

SYSTem:CORRection:FREQuency

Function

GSM TA

Sets/queries up to 20 comma separated frequency values in MHz.

The units, (GHz, MHz, kHz, Hz) are optional. If no units are specified, units default to Hz.

See Amplitude Offset .

Sending a null list (no values) sets the state of all frequencies to Off.
GPRS TA
EGPRS TA

GSM/GPRS LA

EGPRS LA

Setting

Range: 0 to 20 comma separated values ranging from 292.5 MHz to 2700 MHz

Resolution: 1 Hz

Query

Range: 1 to 20 comma separated values ranging from 292.5 MHz to 2700 MHz, and NAN (9.91E+37)

Resolution: 1 HZ

Factory Setting
  1. 800.00 MHz Off
  2. 810.00 MHz Off
  3. 820.00 MHz Off
  4. 830.00 MHz Off
  5. 840.00 MHz Off
  6. 850.00 MHz Off
  7. 860.00 MHz Off
  8. 870.00 MHz Off
  9. 880.00 MHz Off
  10. 890.00 MHz Off
  11. 900.00 MHz Off
  12. 910.00 MHz Off
  13. 920.00 MHz Off
  14. 930.00 MHz Off
  15. 940.00 MHz Off
  16. 950.00 MHz Off
  17. 960.00 MHz Off
  18. 970.00 MHz Off
  19. 980.00 MHz Off
  20. 990.00 MHz Off
Requirements

GSM/GPRS/
EGPRS TA

Revision: A.01 and above

GSM/GPRS/
EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SYSTEM:CORRECTION:FREQUENCY 1784.8 MHZ,1879.8 MHZ"
! Sets up to 20 comma separated frequencies

OUTPUT 714;"SYSTEM:CORRECTION:FREQUENCY"
! Sets the state for all frequencies and offsets to Off

SYSTem:CORRection:GAIN

Function

GSM TA

Sets/queries the up to 20 comma separated offset values in dB.

See Amplitude Offset .

The units, dB, are optional. If no units are specified, units default to dB.

Sending a null list (no values) sets the state of all offsets to Off.
GPRS TA
EGPRS TA

GSM/GPRS LA

EGPRS LA

Setting

Range: 0 to 20 values between -100 to +100

Resolution: 0.01

Query

Range: 1 to 20 values between -100 to +100, and NAN (9.91E+37)

Resolution: 0.01

Factory Setting

Offsets 1 through 20, are set to 0.00 dB, state is set to off
Requirements

GSM/GPRS/
EGPRS TA

Revision: A.01 and above

GSM/GPRS/
EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SYSTEM:CORRECTION:GAIN -3.12,-3.68,-4.23"
! Sets up to 20 comma separated offset values

OUTPUT 714;"SYSTEM:CORRECTION:GAIN"
! Sets the state for all frequencies and offsets to Off

SYSTem:CORRection:POINts

Function

GSM TA

Queries the number of offsets that are in their On state when the RF IN/OUT Amplitude Offset State is also set to On.

See Amplitude Offset .
GPRS TA
EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Range: 1 to 20, and NAN (9.91E+37)

Resolution: 1
Requirements

GSM/GPRS/
EGPRS TA

Revision: A.01 and above

GSM/GPRS/
EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SYSTEM:CORRECTION:POINTS?"
! Returns the number of frequencies and offsets
! with their state set to On

SYSTem:CORRection:SFRequency

Function

GSM TA

Sets/queries up to 20 comma separated frequency values in MHz. This command sets the state to On.

The units (GHz, MHz, kHz, Hz) are optional. If no units are specified, units default to MHz.

See Amplitude Offset .

Sending a null list (no values) sets the state of all frequencies to Off.
GPRS TA
EGPRS TA

GSM/GPRS LA

EGPRS LA

Setting

Range: 0 to 20 comma separated values from 292.5 MHz to 2700 MHz

Resolution: 1 Hz

Query

Range: 1 to 20 comma separated values from 292.5 MHz to 2700 MHz, and NAN (9.91E+37)

Resolution: 1 HZ

Factory Setting
  1. 800.00 MHz Off
  2. 810.00 MHz Off
  3. 820.00 MHz Off
  4. 830.00 MHz Off
  5. 840.00 MHz Off
  6. 850.00 MHz Off
  7. 860.00 MHz Off
  8. 870.00 MHz Off
  9. 880.00 MHz Off
  10. 890.00 MHz Off
  11. 900.00 MHz Off
  12. 910.00 MHz Off
  13. 920.00 MHz Off
  14. 930.00 MHz Off
  15. 940.00 MHz Off
  16. 950.00 MHz Off
  17. 960.00 MHz Off
  18. 970.00 MHz Off
  19. 980.00 MHz Off
  20. 990.00 MHz Off
Requirements

GSM/GPRS/
EGPRS TA

Revision: A.01 and above

GSM/GPRS/
EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SYSTEM:CORRECTION:SFREQUENCY 1710.2 MHZ,1805.2 MHZ,1784.8 MHZ,1879.8 MHZ"
! Sets up to 20 comma separated frequencies and sets the state to On for the frequency,
! offset, and RF IN/OUT Amplitude Offset State

OUTPUT 714;"SYSTEM:CORRECTION:SFREQUENCY"
! Sets the state for all frequencies and offsets to Off

SYSTem:CORRection:STATe

Function

GSM TA

Sets/queries the RF IN/OUT Amplitude Offset State. The state must be On before any of the offsets are active regardless of the state for any of the frequencies or offsets.

When the RF IN/OUT Amplitude Offset State is On, the Instrument Status Area will indicate "Offset" regardless of the state for any of the frequencies or offsets.

Setting any of the frequency or offset states to On will set the RF IN/OUT Amplitude Offset State to On.

See Amplitude Offset .
GPRS TA
EGPRS TA

GSM/GPRS LA

EGPRS LA

Setting

Range: 0 | OFF | 1 | ON

Query

Range: 0 | 1

Factory Setting

0 | OFF
Requirements

GSM/GPRS/
EGPRS TA

Revision: A.01 and above

GSM/GPRS/
EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SYSTEM:CORRECTION:STATE ON"
! Sets the RF IN/OUT Amplitude Offset State to On.


SYSTem:CURRent:TA

SYSTem:CURRent:TA

GPIB Command Conventions

  • SYSTem:CURRent:TA:MODel?
  • SYSTem:CURRent:TA:NAME?
  • SYSTem:CURRent:TA:REVision?

SYSTem:CURRent:TA:MODel?

Function | GSM TA | Queries the model number of the test application running. Printable ASCII characters up to a 15 character string.
 | GPRS TA
 | EGPRS TA
 | GSM/GPRS LA
 | EGPRS LA
Query |  | Range: ASCII codes 32 - 126 decimal excluding comma and semicolon
*RST Setting |  | non volatile, read from the test set's hard disk
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.01 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.01 and above

SYSTem:CURRent:TA:NAME?

Function | GSM TA | Queries the name of the test application running. Printable ASCII characters up to a 25 character string. This is not the recommended command, see SYSTem:APPLication for the recommended command.
 | GPRS TA
 | EGPRS TA
 | GSM/GPRS LA
 | EGPRS LA
Query |  | Range: ASCII codes 32 - 126 decimal excluding comma and semicolon
*RST Setting |  | non volatile, read from the test set's hard disk
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.01 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.01 and above

SYSTem:CURRent:TA:REVision?

Function | GSM TA | Queries the coordinated codeware revision for the test application running. Printable ASCII characters up to a 20 character string. This is not the recommended command, see SYSTem:APPLication for the recommended command.
 | GPRS TA
 | EGPRS TA
 | GSM/GPRS LA
 | EGPRS LA
Query |  | Range: ASCII codes 32 - 126 decimal excluding comma and semicolon
*RST Setting |  | non volatile, read from the test set's hard disk.
Requirements | GSM/GPRS/ EGPRS TA | Revision: A.01 and above
 | GSM/GPRS/ EGPRS LA | Revision: C.01 and above


SYSTem:DATE

SYSTem:DATE

December 3, 2008

GPIB Command Conventions

  • SYSTem:DATE

SYSTem:DATE

Function

Sets/queries the date.

Setting

Range:

  • <year> 2000 to 2099
  • <month> 1 to 12 (the number 1 corresponds to January)
  • <day> 1 to the number of days in the month specified by the <month> parameter

Query

Range:

  • <year> 2000 to 2099
  • <month> 1 to 12 (the number 1 corresponds to January)
  • <day> 1 to the number of days in the month specified by the <month> parameter

*RST Setting

 This feature is not affected by instrument preset

Requirements

GSM/GPRS/EGPRS TA Revision: A.01 and above

GSM/GPRS/EGPRS LA Revision: C.01 and above

Programming Example

OUTPUT 714;"SYSTEM:DATE 2001,9,27" !Sets the date to September 27,2001.

OUTPUT 714;"SYSTEM:DATE?
! Returns "+2001,+9,+27" if the date has been set to September 27,2001.

Related Topics

SYSTem:UTC:DATE


SYSTem Subsystem

SYSTem Subsystem

Description

The SYSTem subsystem collects the functions that are not related to test set performance. Examples include functions for performing general housekeeping and functions related to setting global configurations, such as TIME or CORRection (amplitude offset).

Syntax Diagrams and Command Descriptions

SYSTem:APPLication

SYSTem:AUDio

SYSTem:BEEPer
SYSTem:COMMunicate
SYSTem:CONFigure
SYSTem:CORRection
SYSTem:CURRent:TA
SYSTem:DATE
SYSTem:ERRor?

SYSTem:FATal

SYSTem:FTRigger

SYSTem:INSTrument

SYSTem:LOG
SYSTem:MEASurement
SYSTem:PRESet

SYSTem:REGister

SYSTem:ROSCillator

SYSTem:STATus

SYSTem:SYNChronized
SYSTem:TIME
SYSTem:TZONe
SYSTem:UTC


SYSTem:ERRor?

SYSTem:ERRor?

Last updated: December 3, 2008

GPIB Command Conventions

  • SYSTem:ERRor?

SYSTem:ERRor?

Function

GSM TA

Queries the contents of the Error/Event Queue. The Error/Event Queue may contain one or more messages with an error or event description. See Error Messages .

Manual users may view the Message Log from the SYSTEM CONFIG screen. See Error Message Log .

The contents of the Error/Event Queue and the Message log may not match. Example, manual user errors are not displayed with SYSTem:ERRor? they are viewed from the Message Log. See Manual User Error Messages .
GPRS TA
EGPRS TA

GSM/GPRS LA

EGPRS LA
Query

Error/Event Queue

  • Range: 0 to 100 messages up to 255 characters in length

Programming Example

OUTPUT 714;"SYSTem:ERRor?"
! Queries the contents of the Error/Event Queue


SYSTem:FATal

SYSTem:FATal

December 3, 2008

GPIB Command Conventions

  • SYSTem:FATal:ERRor:RESTart

SYSTem:FATal:ERRor:RESTart

Function

This command sets/queries the state of the Restart on Fatal Error parameter. See Restart on Fatal Error for more information.

Error messages that are created when a fatal error occurs are entered in the error/event queue that can be queried with the command SYSTem:ERRor? .

This is a nonvolatile setting, that is the instrument does not require a power supply to retain the setting its memory.

Setting

Range: ON|1|OFF|0

Query

Range: 1|0

*RST Setting

 0

Requirements

GSM/GPRS/EGPRS TA Revision: A.05 and above

GSM/GPRS/EGPRS LA Revision: D.02 and above

Programming Example

OUTPUT 714;"SYSTem:FATal:ERRor:RESTart ON"
! Commands the instrument to restart if a fatal error occurs.


SYSTem:FTRigger

SYSTem:FTRigger

This command has been replaced by the command CALL:TRIGger[:OUTPut].

GPIB Command Conventions

  • SYSTem:FTRigger:BIT[:SELected]
  • SYSTem:FTRigger:BIT:GSM
  • SYSTem:FTRigger:STATe[:SELected]
  • SYSTem:FTRigger:STATe:GSM
  • SYSTem:FTRigger:TSLot[:SELected]
  • SYSTem:FTRigger:TSLot:GSM

SYSTem:FTRigger:BIT[:SELected]

Function

GSM TA

This command selects/queries which bit, after zero, will be used for frame trigger pulse positioning in the active (that is the selected) radio format. See Frame Trigger Parameters

GPRS TA
EGPRS TA

GSM/GPRS LA

EGPRS LA

Setting

Range: 0 to 1250

Resolution: 1

Query

Range: 0 to 1250

Resolution: 1

*RST Setting

zero
Requirements

GSM/GPRS/
EGPRS TA

Revision: A.01 and above

GSM/GPRS/
EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SYSTEM:FRTIGGER:BIT 14"
! Would cause external frame trigger pulses to occur 14 bits after bit 0 of
! the selected timeslot.

SYSTem:FTRigger:BIT:GSM

Function

GSM TA

This command selects/queries which bit, after zero, will be used for frame trigger pulse positioning in the GSM radio format whether or not that format is active. See Frame Trigger Parameters .
GPRS TA
EGPRS TA

GSM/GPRS LA

EGPRS LA

Setting

Range: 0 to 1250

Resolution: 1

Query

Range: 0 to 1250

Resolution: 1

*RST Setting

zero

Requirements

GSM/GPRS/
EGPRS TA

Revision: A.01 and above

GSM/GPRS/
EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SYSTEM:FRTIGGER:BIT:GSM 12"
! Would cause external frame trigger pulses to occur 12 bits after bit 0 of
! the selected timeslot.

SYSTem:FTRigger:STATe[:SELected]

Function

GSM TA

This command sets/queries the frame trigger state in the active (that is the selected) radio format. See Frame Trigger Parameters .
GPRS TA
EGPRS TA

GSM/GPRS LA

EGPRS LA

Setting

Range: 0 | OFF | 1 | ON

Query

Range: 0 | 1

*RST Setting

0 | OFF
Requirements

GSM/GPRS/
EGPRS TA

Revision: A.01 and above

GSM/GPRS/
EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SYSTEM:FRTIGGER:STATE ON"
! Set frame trigger state to on.

SYSTem:FTRigger:STATe:GSM

Function

GSM TA

This command sets/queries the frame trigger state in the GSM radio format whether or not that format is active. See Frame Trigger Parameters .
GPRS TA
EGPRS TA

GSM/GPRS LA

EGPRS LA

Setting

Range: 0 | OFF | 1 | ON

Query

Range: 0 | 1

*RST Setting

0 | OFF

Requirements

GSM/GPRS/
EGPRS TA

Revision: A.01 and above

GSM/GPRS/
EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SYSTEM:FRTIGGER:STATE:GSM ON"
! Set frame trigger state to on.

SYSTem:FTRigger:TSLot[:SELected]

Function

GSM TA

This command selects/queries the timeslot for frame trigger pulse positioning in the active (that is the selected) radio format. See Frame Trigger Parameters .
GPRS TA
EGPRS TA

GSM/GPRS LA

EGPRS LA

Setting

Range: 0 to 7

Resolution: 1

Query

Range: 0 to 7

Resolution: 1

*RST Setting

zero
Requirements

GSM/GPRS/
EGPRS TA

Revision: A.01 and above

GSM/GPRS/
EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SYSTEM:FRTIGGER:TSLOT 5"
! Sets the frame trigger timeslot to 5.

SYSTem:FTRigger:TSLot:GSM

Function

GSM TA

This command selects/queries the timeslot for frame trigger pulse positioning in the GSM radio format whether or not that format is active. See Frame Trigger Parameters .
GPRS TA
EGPRS TA

GSM/GPRS LA

EGPRS LA

Setting

Range: 0 to 7

Resolution: 1

Query

Range: 0 to 7

Resolution: 1

*RST Setting

zero

Requirements

GSM/GPRS/
EGPRS TA

Revision: A.01 and above

GSM/GPRS/
EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SYSTEM:FRTIGGER:TSLOT:GSM 6"
! Sets the frame trigger timeslot to 6.


SYSTem:INSTrument

SYSTem:INSTrument

GPIB Command Conventions

  • SYSTem:INSTrument:TEMPerature?
  • SYSTem:INSTrument:THERmal:POWer:NULL:ADJust:INFormation?

SYSTem:INSTrument:TEMPerature?

Function

GSM TA

Queries the current internal operating temperature.

GPRS TA

EGPRS TA
GSM/GPRS LA

EGPRS LA

Query

Range: -60.0 to 100.0 (°C)
Requirements GSM/GPRS/
EGPRS TA

Revision: A.09 and above
GSM/GPRS/ EGPRS LA

Revision: F.01 and above

Programming Example

OUTPUT 714;"SYSTEM:INSTRUMENT:TEMPERATURE?"

SYSTem:INSTrument:THERmal:POWer:NULL:ADJust:INFormation?

Function

GSM TA

Queries the information about Thermal Power Null Adjustment.

The query returns 3 comma separated values for the Thermal Power Null Adjustment: Data and Time, Temperature and Pass/Fail.

  • Date and Time indicates when the Thermal Power Null Adjustment is performed.
  • Temperature indicates the internal operating temperature when the Thermal Power Null Adjustment is performed.
  • Pass/Fail indicates whether the Thermal Power Null Adjustment is performed successfully.

GPRS TA

EGPRS TA
GSM/GPRS LA

EGPRS LA

Query

Range

  • Date and Time: "2000-01-01 00:00:00" to "2100-01-01 00:00:00"
  • Temperature: -60.0 to 100.0 (°C)
  • Pass/Fail: 1| 0
Requirements GSM/GPRS/
EGPRS TA

Revision: A.09 and above
GSM/GPRS/ EGPRS LA

Revision: F.01 and above

Programming Example

OUTPUT 714;"SYSTEM:INSTRUMENT:THERMAL:POWER:NULL:ADJUST:INFORMATION?"


SYSTem:LOG

SYSTem:LOG

GPIB Command Conventions

  • SYSTem:LOG:UI:CLEAR


SYSTem:MEASurement

SYSTem:MEASurement

GPIB Command Conventions

  • SYSTem:MEASurement:RESet

SYSTem:MEASurement:RESet

Function

GSM TA

Sets all measurements to abort, if the trigger arm is set to continuous the measurements will begin a new measurement cycle. See Trigger Arm (Single or Continuous) Description .

Any measurement results are cleared and the Integrity Indicator is set to 1 (No_Result_Available). See Integrity Indicator .
GPRS TA
EGPRS TA

GSM/GPRS LA

EGPRS LA
Setting GSM TA

These results are set to their default values:

  • RACH Count
  • Page Count
  • Missing Burst Count
  • Corrupted Burst Count
  • Channel Decoder Error Count
  • MS TX Level Reported
  • TCH Timing Advance Reported
  • RX Level
  • RX Qual

GSM/GPRS LA

GPRS TA

These results are set to their default values:

  • Block Error Rate (BLER)
  • Blocks Tested

EGPRS LA
Requirements

GSM/GPRS/
EGPRS TA

Revision: A.01 and above

GSM/GPRS/
EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SYSTEM:MEASUREMENT:RESET"
! Resets current measurements.


SYSTem:PRESet

SYSTem:PRESet

GPIB Command Conventions

  • SYSTem:PRESet[1] (not recommended for use)
  • SYSTem:PRESet2
  • SYSTem:PRESet3

SYSTem:PRESet[1] (not recommended for use)

Function

GSM TA

Not recommended for use at this time, use the SYSTEM:PRESET3 command for partial preset.

Performs a partial preset. This is the recommended command when you want to change from remote operation to manual operation and a partial preset is needed.

Any call in process is disconnected and all measurements are aborted and inactivated. Measurement parameters are not changed.

A partial preset will not modify any measurement settings including trigger arm. See Trigger Arm (Single or Continuous) Description .
GPRS TA
EGPRS TA

GSM/GPRS LA

EGPRS LA
Related Topics

See Partial Preset for more details
Requirements

GSM/GPRS/
EGPRS TA

Revision: A.01 and above

GSM/GPRS/
EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SYSTEM:PRESET"
! Partial preset when changing from remote to manual operation.

SYSTem:PRESet2

Function

GSM TA

Performs a full preset of the test set. This is the remote equivalent of pressing the SHIFT Preset keys on the front panel of the test set.

All parameters are set to their default values. All measurements are aborted the trigger arm is set to continuous. See Trigger Arm (Single or Continuous) Description .

The *RST command will set the trigger arm to single.
GPRS TA
EGPRS TA

GSM/GPRS LA

EGPRS LA
Related Topics See Full Preset for more details.
Requirements

GSM/GPRS/
EGPRS TA

Revision: A.01 and above

GSM/GPRS/
EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SYSTEM:PRESET2"
! Full preset.

SYSTem:PRESet3

Function

GSM TA

Performs a partial preset. This is the recommended command when a partial preset is needed during remote operation of the test set.

Any call in process is disconnected and all measurements are aborted and inactivated. Measurement parameters are not changed.

A partial preset will not modify any measurement settings including trigger arm. See Trigger Arm (Single or Continuous) Description .
GPRS TA
EGPRS TA

GSM/GPRS LA

EGPRS LA
Related Topics

See Partial Preset for more details.
Requirements

GSM/GPRS/
EGPRS TA

Revision: A.01 and above

GSM/GPRS/
EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SYSTEM:PRESET3"
! Partial preset when in remote operation.


SYSTem:REGister

SYSTem:REGister

GPIB Command Conventions

  • SYSTem:REGister:SAVE
  • SYSTem:REGister:RECall
  • SYSTem:REGister:DELete

SYSTem:REGister:SAVE

Function

GSM TA

Saves the current test set settings to one of five available registers.

If this command is used to save to a register that is already full, the old contents of the register will be overwritten.
GPRS TA
EGPRS TA

GSM/GPRS LA

EGPRS LA

Setting

1|2|3|4|5

Query

No query

*RST Setting

 Not applicable

Requirements

GSM/GPRS/
EGPRS TA

Revision: A.01 and above

GSM/GPRS/
EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SYSTem:REGister:SAVE 1"
! Saves the current test set configuration to save register 1.

SYSTem:REGister:RECall

Function

GSM TA

Recalls a saved register from one of five registers.

If this command is used to recall a register that is empty, an error message will be displayed.
GPRS TA
EGPRS TA

GSM/GPRS LA

EGPRS LA

Setting

1|2|3|4|5

Query

No query

*RST Setting

 Not applicable

Requirements

GSM/GPRS/
EGPRS TA

Revision: A.01 and above

GSM/GPRS/
EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SYSTem:REGister:RECall 1"
! Recalls register 1.

SYSTem:REGister:DELete

Function

GSM TA

Deletes any contents saved in the selected register.
GPRS TA
EGPRS TA

GSM/GPRS LA

EGPRS LA

Setting

1|2|3|4|5

Query

No query

*RST Setting

 Not applicable

Requirements

GSM/GPRS/
EGPRS TA

Revision: A.01 and above

GSM/GPRS/
EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SYSTem:REGister:DELete 1"
! Deletes register 1.

Related Topics

Save and Recall Registers


SYSTem:ROSCillator

SYSTem:ROSCillator

GPIB Command Conventions

  • SYSTem:ROSCillator[:TIMebase]?
  • SYSTem:ROSCillator:LOCKed?

SYSTem:ROSCillator[:TIMebase]?

Function

GSM TA

Query to indicate if the test set's internal source or a suitable external source has been chosen to drive the test set's time base.

A suitable external source must have:

  • an output level of 0 to +13DBM
  • frequency of 10 MHZ
GPRS TA
EGPRS TA

GSM/GPRS LA

EGPRS LA
Query

Range:

  • INT = internal source
  • EXT = external source
Requirements

GSM/GPRS/
EGPRS TA

Revision: A.01 and above

GSM/GPRS/
EGPRS LA

Revision: C.01 and above

SYSTem:ROSCillator:LOCKed?

Function

GSM TA

 Query the status of the reference oscillator and indicate if it is locked or unlocked.
GPRS TA
EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Range:

  • 0 = unlocked
  • 1 = locked
Requirements

GSM/GPRS/
EGPRS TA

Revision: A.01 and above

GSM/GPRS/
EGPRS LA

Revision: C.01 and above


SYSTem:STATus

SYSTem:STATus

GPIB Command Conventions

  • SYSTem:STATus:COMMunicate:LAN:EXTernal[:CONNected][:STATe]
  • SYSTem:STATus:COMMunicate:LAN:EXTernal[:CONNected]:ADDRess
  • SYSTem:STATus:COMMunicate:LAN:EXTernal:SYNChronize[:STATe]?

SYSTem:STATus:COMMunicate:LAN:EXTernal[:CONNected][:STATe]

Function

GSM TA

 Queries External Device Connection Status .
GPRS TA
EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Range:

  • CONG - Connecting
  • CONN - Connected
  • DISC - Disconnecting
  • NCON - Not Connected
Requirements

GSM/GPRS/
EGPRS LA

Revision: E.00.05 and above

Programming Example

OUTPUT 714;"SYSTem:STATus:COMMunicate:LAN:EXTernal?"

SYSTem:STATus:COMMunicate:LAN:EXTernal[:CONNected]:ADDRess

Function

GSM TA

 Queries the IP Address of the External Device.
GPRS TA
EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Range: 15 characters formatted as follows: "A.B.C.D" where A= 0 to 126 and 128 to 223, B.C.D = 0 to 255 (no embedded spaces), "".
Requirements

GSM/GPRS/
EGPRS LA

Revision: E.00.05 and above

Programming Example

OUTPUT 714;"SYSTem:STATus:COMMunicate:LAN:EXTernal:ADDRess?"

SYSTem:STATus:COMMunicate:LAN:EXTernal:SYNChronize[:STATe]?

Function

GSM TA

Queries the external device synchronization status. This command returns the following:

  • NCON

    The test sets are not connected.

  • NSYN

    The test sets are not yet synchonized.

  • SYNG

    The test sets are in the process of synchronizing. This process takes only a couple of seconds before the test sets are synchronized.

  • SYNCThe test sets are synchronized.
GPRS TA
EGPRS TA

GSM/GPRS LA

EGPRS LA

Query

Range: NCON|NSYN|SYNG|SYNC
Requirements

GSM/GPRS/
EGPRS LA

 Revision: E.00.05 and above

Programming Example

OUTPUT 714;"SYSTem:STATus:COMMunicate:LAN:EXTernal:SYNChronize?"


SYSTem:SYNChronized

SYSTem:SYNChronized

GPIB Command Conventions

  • SYSTem:SYNChronized

SYSTem:SYNChronized

Function

GSM TA

Sets/queries the test set that all prior sequential commands have completed and all prior overlapped commands have started indicating that the input buffer is synchronized. (See Call Processing Event Synchronization or Data Connection Processing Event Synchronization .)
GPRS TA
EGPRS TA

GSM/GPRS LA

EGPRS LA

Setting

Bit 12 of the status operation condition register is pulsed. See STATus:OPERation:CALL Condition Register Bit Assignment .

Query

1

Related Topics

See Status Subsystem Overview .

See Call Processing Event Synchronization or Data Connection Processing Event Synchronization .
Requirements

GSM/GPRS/
EGPRS TA

Revision: A.01 and above

GSM/GPRS/
EGPRS LA

Revision: C.01 and above

Programming Example

OUTPUT 714;"SYSTEM:SYNCHRONIZED"
! Pulses bit 12 of the status operation condition register.

OUTPUT 714;"SYSTEM:SYNCHRONIZED?"
! Returns a 1 indicating all prior sequential commands have completed and all overlapped
! commands have started.


SYSTem:TIME

SYSTem:TIME

December 3, 2008

GPIB Command Conventions

  • SYSTem:TIME

SYSTem:TIME

Function

Sets/queries the local time of day.

UTC time will track changes made directly to local time settings. Also, if new settings are made to UTC time, local time will track UCT time.

Changes to time zone will cause changes to local time, but will not directly affect UTC time.

Setting

Range:

  • <hour> 0 to 23
  • <minute> 0 to 59
  • <second> 0 to 59

The resolution of local time setting is minutes. A number within the parameter range must be entered for <second> but it will not affect the minute setting.

Query

Range:

  • <hour> 0 to 23
  • <minute> 0 to 59
  • <second> 0 to 59

The resolution of the local time setting is minutes. The value returned for <second> will not provide useful information.

*RST Setting

 This feature is not affected by instrument preset

Requirements

 GSM/GPRS Lab Application: Revision: C.01 and above

Programming Example

OUTPUT 714;"SYSTEM:TIME 7,30,0"
! Sets local time to 7:30

OUTPUT 714;"SYSTEM:TIME?"
! Returns "+7,+30,+0" if local time has been set to 7:30.

Related Topics

SYSTem:UTC[:TIME]


SYSTem:TZONe

SYSTem:TZONe

December 3, 2008

GPIB Command Conventions

  • SYSTem:TZONe

SYSTem:TZONe

Function

Sets/queries the time zone.

Changes to time zone will cause changes to local time, but will not directly affect UTC time.

Setting

Range:

  • <hour> -12 to +15
  • <minute> 0 to 59

Query

Range:

  • <hour> -12 to +15
  • <minute> 0 to 59

*RST Setting

 This feature is not affected by instrument preset

Requirements

 GSM/GPRS Lab Application: Revision C.01 and above

Programming Example

OUTPUT 714;"SYSTEM:TZONe 8,0"
! Sets time zone to 8 hours and 0 minutes.

OUTPUT 714;"SYSTEM:TZONe?"
! Returns "+8,+0" if time zone has been set to 8 hours.

Related Topics

SYSTem:TIME


SYSTem:UTC

SYSTem:UTC

December 3, 2008

GPIB Command Conventions

  • SYSTem:UTC[:TIME]
  • SYSTem:UTC:DATE

SYSTem:UTC[:TIME]

Function

Sets/queries the Universal Coordinated Time (UTC) time of day. (UTC is also known as UCT, Zulu, and Greenwich Mean Time.)

Local time will track UTC time settings. Also, if new settings are made to local time, UTC time will track local time.

Setting

Range:

  • <hour> 0 to 23
  • <minute> 0 to 59
  • <second> 0 to 59

The resolution of the UTC time setting is minutes. A number within the parameter range must be entered for <second> but it will not affect the minute setting.

Query

Range:

  • <hour> 0 to 23
  • <minute> 0 to 59
  • <second> 0 to 59

The resolution of the UTC time setting is minutes. The value returned for <second> will not provide useful information.

*RST Setting

 This feature is not affected by instrument preset

Requirements

GSM/GPRS/EGPRS TA Revision: A.01 and above

GSM/GPRS/EGPRS LA Revision: C.01 and above

Programming Example

OUTPUT 714;"SYSTEM:UTC:TIME 7,30,0"
! Sets UCT time to 7:30

OUTPUT 714;"SYSTEM:UTC:TIME?"
! Returns "+7,+30,+0" if UTC time has been set to 7:30.

SYSTem:UTC:DATE

Function

Sets/queries the Universal Coordinated Time (UTC) date. (UTC is also known as UCT, Zulu, and Greenwich Mean Time.)

Setting

Range:

  • <year> 2000 to 2099
  • <month> 1 to 12 (the number 1 corresponds to January)
  • <day> 1 to the number of days in the month specified by the <month> parameter

Query

Range:

  • <year> 2000 to 2099
  • <month> 1 to 12 (the number 1 corresponds to January)
  • <day> 1 to the number of days in the month specified by the <month> parameter

*RST Setting

 This feature is not affected by instrument preset

Requirements

 GSM/GPRS/EGPRS LA Revision: C.01 and above

Programming Example

OUTPUT 714;"SYSTEM:UTC:DATE 2001,9,27"
! Sets the UTC date to September 27,2001.

OUTPUT 714;"SYSTEM:UTC:DATE?
! Returns "+2001,+9,+27" if the UTC date has been set to September 27,2001.

Related Topics

SYSTem:DATE


Performing Individual Measurements and 3GPP TS 51.010 Tests

Performing Individual Measurements and 3GPP TS 51.010 Tests

NOTE
You can also download and print a pdf of this information at:

Manual Operation Guide: Making 3GPP TS 51.010 Tests Manually

(http://cp.literature.agilent.com/litweb/pdf/1000-1903.pdf)

Measurement Procedures
Measurement | General Measurement Procedure | 3GPP TS 51.010 Test Procedure
AMR In-Band Frame Error (LA Only) | How to Make an AMR In-Band Frame Error Measurement | 3GPP 51.010 section 14.2.19 and 14.2.20 3GPP 44.010 section 5.1.7.a
Bit Error | How Do I Make a Bit Error Measurement? | 3GPP TS 51.010 version 5.9, section 14.2
Block Error | How Do I Make a Block Error Measurement? | 3GPP 51.010, section 14.16 (GPRS) 3GPP 51.010, section 14.18.1 (EGPRS)
EGPRS SRB Bit Error Measurement | How do I make EGPRS SRB Bit Error Measurements? | 3GPP 51.010, section 14.18.1 (EGPRS)
Fast Bit Error | How Do I Make a Fast Bit Error Measurement? | Not a 3GPP specified measurement
Frequency Stability | Frequency Stability Measurement Description | Not a 3GPP specified measurement
GSM Bad Frame Indication (LA Only) | How do I make a GSM Bad Frame Indication (BFI) Measurement? | 3GPP 51.010 section 14.1.1.1
GSM Frame Erasure Rate (LA Only) | How Do I Make a Repeated SACCH Frame Erasure Rate (FER) Measurement? | 3GPP 51.010 section 14.2.3
IQ Tuning | How Do I Make a IQ Tuning Measurement? | Not a 3GPP specified measurement
Modulation Accuracy | How do I make Modulation Accuracy Measurements? | 3GPP TS 51.010 Section 13.17.1
Output RF Spectrum | How Do I Make an Output RF Spectrum Measurement? | 3GPP TS 13.16.3 / 13.16.4
Phase and Frequency Error | How Do I Make a Phase and Frequency Error Measurement? | 3GPP TS 51.010 Section 13.1
Power versus Time | How Do I Make a Power Versus Time Measurement? | 3GPP TS 51.010 Section 13.3
Spectrum Monitor Measurements | How Do I Use the Spectrum Monitor? | Not a 3GPP specified measurement
Transmit Power | How Do I Make a Transmit Power Measurement? | 3GPP TS 51.010 13.16.2

Related Topics

Test Adherence to Standards


Analog Audio Measurement Block Diagram

Analog Audio Measurement Block Diagram

Related Topics

Analog Audio Measurement Description


Audio Frequency Measurement Description

Audio Frequency Measurement Description

This measurement is not applicable to GPRS.

How is an Audio Frequency measurement made?

Audio Frequency measures the frequency of the signal applied to the front-panel AUDIO IN connectors, and is one of the Analog Audio measurements. Audio Frequency can be measured for signals in the frequency range of 100 Hz to 15 kHz, at levels from 7.1 mV peak to 20 V peak, and with a signal-to-noise ratio of 30 dB or greater.

The analog audio frequency measurement is made after any filtering and processing are applied for the audio measurements.

Related Topics

Programming an Audio Frequency Measurement


Audio Level Measurement Description

Audio Level Measurement Description

This measurement is not applicable to GPRS.

How is an Audio Level measurement made?

Audio Level measures the AC voltage of the signal applied to the front-panel AUDIO IN connectors, and is one of the Analog Audio measurements. Audio Level can be measured for signals in the frequency range of
100 Hz to 20 kHz, at levels from 7.1 mV peak to 20V peak . The measurement is made after any filtering is applied, and can be made using an RMS or Peak detector. The type of detector being used for the measurement is displayed next to the measurement value.

When measuring very low voltages, it may be helpful to use the adjustable bandpass filter and the rms detector to reduce noise components.

Related Topics

Programming an Audio Level Measurement


Analog Audio Measurement Description

Analog Audio Measurement Description

This measurement is not applicable to GPRS or EGPRS.

How is an analog audio measurement made?

The analog audio measurement can measure Audio Level (V), SINAD (dB), Distortion (%), and Audio Frequency. Measurements are made through the test set's front panel AUDIO IN connectors. When measuring a mobile's audio output, the audio signal may come from either an acoustic coupler or from a test interface connection to the mobile's audio circuitry.

SINAD is one of four measurements available from the Analog Audio measurement. However, SINAD measurements are not typically made when testing GSM mobiles but are more common when testing AMPS or analog mobiles.

See Analog Audio Measurement Block Diagram .

The AUDIO IN connectors feed the inputs to a floating-input differential amplifier, with each input having an impedance of about 100,000 ohms to chassis ground. For best noise immunity, connect the audio signal and its ground reference to the two input ports through shielded coaxial cables, or input the signal to the AUDIO IN HI connector and ground the AUDIO IN LO connector's center contact.

SINAD/Distortion State

Select On or Off to enable or disable the SINAD and Distortion measurements. This can be done remotely using the SETup:AAUDio:SDIStortion:STATe . When On, these measurement results are displayed on the screen below the Audio Level measurement. The SINAD/Distortion Fundamental Frequency must be entered to specify the audio frequency for the measurement (range: 100 Hz to 10 kHz).

Audio Frequency State

Select On or Off to enable or disable the analog audio frequency measurement.

Filter Type

  • None - no filtering is provided (default).
  • 100 Hz BW BPF - The 100 Hz BW Band Pass Filter (Tunable) setting is available when this filter is selected, and can be set in the range of 200 Hz to 20 kHz.
  • C-Message - This type of filter is typically used when testing AMPS or other analog mobiles, and not GSM mobiles.
  • 50 Hz to 15 kHz
  • 300 Hz to 15 kHz

Detector Type

Select either Peak or RMS (default) for making and displaying an analog audio level measurement (does not affect other measurements). The type of detector selected is displayed next to the Audio Level measurement results. A 1-volt rms sinewave input signal would measure 1.414 V Peak when the Peak detector is used. A 1-volt peak input signal would measure 0.707 V RMS when the RMS detector is used.

Expected Peak Voltage

The Expected Peak Voltage sets the analog audio clipping level and must be set. This voltage is always the absolute peak audio input signal voltage expected at the AUDIO IN connectors, and must be in the range of 7.07 mV peak (5 mVrms) to 20 V peak . Remember, measuring a 1-volt rms sinewave input signal would require a 1.414 V peak expected voltage value to avoid clipping (over-driving) the input.

De-Emphasis State

Set to On or Off (default) to enable or disable 750 microsecond de-emphasis.

Expandor Reference Level

Set value from 10 mV/kHz to 10 V/kHz, or Off (default). Entering a numeric value automatically turns the state to On. Entering Off disables the expandor (state = Off).

Trigger Source

Analog audio measurements use immediate triggering and are continuously re-triggered each time the Trigger Arm parameter is set to Continuous. Trigger timing is independent of any mobile protocol signaling.

Related Topics

Analog Audio Measurement Block Diagram

Analog Audio Troubleshooting

Audio Level Measurement Description

Audio Frequency Measurement Description

SINAD Measurement Description

Distortion Measurement Description

Programming an Audio Frequency Measurement

Programming an Audio Level Measurement

Programming a SINAD Measurement

Programming a Distortion Measurement

Statistical Measurement Results (Multi-measurements)


Test Adherence to Standards

Test Adherence to Standards

The 8960 Series 10 is compliant with 3GPP 51.010 (formerly ETSI GSM 11.10).

Frequency Error and Phase Error

Standards Reference: 3GPP 51.010 (formerly ETSI GSM 11.10) sections 13.1 and 13.16.1

The method of test implemented by the test set's Phase and Frequency Error measurement conforms to the measurement method defined in 3GPP 51.010, section 13.1. For GPRS mobiles which support a single uplink timeslot or two adjacent uplink timeslots, the Phase and Frequency Error measurement conforms to 3GPP 51.010, section 13.16.1. For EGPRS mobiles which support a single uplink timeslot or two adjacent uplink timeslots, the Phase and Frequency Error measurement conforms to 3GPP 51.010, section 13.16.1.

Related Topics

Phase and Frequency Error Measurement Description

Programming a Phase and Frequency Error Measurement for GSM

Programming a Phase and Frequency Error Measurement for GPRS and EGPRS

Transmitter Output Power and Burst Timing Error

Standards Reference: 3GPP 51.010 (formerly ETSI GSM 11.10) sections 13.3, 13.16.2, and 13.17.3

To make a transmitter output power measurement that conforms to 3GPP 51.010 standards, perform a Power versus Time measurement. An ETSI compliant, transmitter output power (TXPower) result is available as a result of this measurement. Pass/fail checking of the Power versus Time mask is also available by using the Power versus Time measurement. The Burst Timing Error result is available for GSM, GPRS and EGPRS on the Call Setup screen and by sending a query to the CALL subsystem ( CALL:STATus:TCHannel:TERRor? for GSM, CALL:STATus:(PDTCH|PDTChannel):TERRor? for GPRS and EGPRS).

For GPRS mobiles which support a single uplink timeslot or two adjacent uplink timeslots, the transmitter output power result conforms to 3GPP 51.010, section 13.16.2. When measuring two adjacent uplinks, each of these can have different power levels.

For EGPRS mobiles which support a single uplink timeslot or two adjacent uplink timeslots, the 8PSK burst power measurement (with averaging turned on) conforms to 3GPP 51.010, section 13.17.3. The 8PSK Estimated Carrier Power measurement meets the accuracy requirements for an estimation technique of long term average power as defined in 3GPP 51.010, annex 5.

Making a faster transmitter output power measurement for GMSK modulated signals

An alternative method for testing the transmitter output power is using the Transmit Power measurement in the test set.

When the Burst Capture Range is set to single , the Transmit Power measurement implemented in the test set varies from the ETSI recommended method for measuring carrier power in terms of synchronization. This measurement synchronizes using RF amplitude synchronization instead of midamble synchronization. This was intentionally done to speed up the measurement, as this is one of the most common measurements performed in manufacturing. This alternative measurement technique is approximately four times faster than the synchronized method with the same accuracy. If the input signal meets the GSM Power versus Time characteristics, the TX Power measurement provides the same results as the Power versus Time - TX Power result (which is midamble synchronized and ETSI compliant).

NOTE
When the Burst Capture Range is set to single , the serving cell must be either GSM or GPRS for the GSM/GPRS TX Power measurement to be used. When the serving cell is EGPRS, this measurement is not available. See Serving Cell for information about setting the serving cell.

When the Burst Capture Range is set to All ,

  • For GSM/GPRS mobiles which support a single uplink timeslot or up to four adjacent uplink timeslots, the transmitter output power result conforms to 3GPP 51.010, section 13.16.2. When measuring two or more adjacent uplinks, each of these can have different power levels.
  • For the EGPRS mobiles which support a single uplink timeslot or up to four adjacent uplink timeslots, the GMSK transmitter output power result conforms to 3GPP 51.010, section 13.16.2; the 8PSK burst power result conforms to 3GPP 51.010, section 13.17.3; the 8PSK Estimated Carrier Power result meets the accuracy requirements for an estimation technique of long term average power as defined in 3GPP 51.010, annex 5.

Note that the output RF spectrum measurement makes the TX Power measurement as part of its measurement process.

Related Topics

Transmit Power Measurement Description

Programming a Transmit Power Measurement for GSM

Programming a Transmit Power Measurement for GPRS/EGPRS

Programming a EGPRS Transmit Power Measurement

Power versus Time Measurement Description

Programming a Power versus Time Measurement for GSM

Programming a Power versus Time Measurement for GPRS and EGPRS

EDGE Dynamic Power (EDP) Measurement

Programming an EDGE Dynamic Power Measurement

Output RF Spectrum

Standards Reference: 3GPP 51.010 (formerly ETSI GSM 11.10) sections 13.4 and 13.16.3

The Output RF Spectrum due to Switching method of test conforms to ETSI GSM 11.10, section 13.4 at offsets < 1800 kHz. For GPRS mobiles which support a single uplink timeslot or two adjacent uplink timeslots, the measurement conforms to ETSI GSM 11.10, section 13.16.3 at offsets < 1800 kHz.

The Output RF Spectrum due to Modulation method of test conforms to 3GPP 51.010, section 13.4 at offsets < 1800 kHz.

For GPRS or EGPRS mobiles which support a single uplink timeslot or two adjacent uplink timeslots, the measurement conforms to 3GPP 51.010, section 13.16.3 at offsets < 1800 kHz (when the Multi-Measurement Count - Modulation parameter is set to Off using SETup:ORFSpectrum:COUNt:STATe ).

Making a faster ORFS measurement

When Multi-Measurement Count (Modulation) is greater than 1, the measurement is performed over 40 or more bits in each of the regions from bit 15 to 60 and bit 87 to 132 of the burst. In 3GPP 51.010, the measurement is only specified on the latter section of the burst.

Measuring on both the front and back of the burst has two advantages. First, this method provides two modulation measurements per burst, effectively doubling measurement speed. Secondly, it provides additional information regarding the spurious performance of the mobile.

The method of test in 3GPP 51.010 is based upon time-gated spectrum analysis; this technique only allows one measurement per burst. Modern DSP techniques employed in the test set makes it possible to measure more of the burst while still excluding the unwanted effects of the midamble and switching transients generated by burst modulation.

Measuring ORFS on GPRS and EGPRS mobiles using the BLER data connection type

The result of the Output RF Spectrum measurement relies on pseudo random data being present in the data field of the RF burst. When using the BLER data connection type, these data fields do not contain pseudo random data, therefore the results may not be representative.

Related Topics

GSM Output RF Spectrum Measurement

GPRS and EGPRS Output RF Spectrum Measurement

Programming an Output RF Spectrum Measurement for GSM

Programming an Output RF Spectrum Measurement for GPRS and EGPRS

Reference Sensitivity

Standards Reference: 3GPP 51.010 (formerly ETSI GSM 11.10) section 14.2

The method of test implemented by the test set's Bit Error measurement conforms to the measurement method defined in 3GPP 51.010, section 14.2. The Bit Error measurement is available for GSM, GPRS, and EGPRS.

Making a faster reference sensitivity measurement

An alternative method of test for making a Reference Sensitivity measurement is to use the Fast Bit Error (FBER) measurement in the test set. The FBER measurement is five times faster than the normal BER measurement.

The Fast Bit Error measurement is not applicable to GPRS or EGPRS.

Block Error Measurement

The Block Error (BLER) measurement which the test set provides is based on GPRS receiver tests defined in 3GPP 51.010, section 14.16 (GPRS) and section 14.18.1 (EGPRS).

The Block Error measurement is not applicable to GSM.

GSM Frame Erasure Rate

Standards Reference: 3GPP 51.010 (formerly ETSI GSM 11.10) section 14.2.3 and 14.2.4

The method of test implemented by the test set's Frame Erasure Rate measurement conforms to steps b) - d) of the measurement procedure defined in 3GPP 51.010 section 14.2.3.4.2 and 14.2.4.4.2 The test set does not provide a fading function as required in step a).

AMR In-Band Frame Error Measurement

Standards Reference: 3GPP 51.010 (formerly ETSI GSM 11.10) sections 14.2.19 and 14.2.20, and 3GPP 44.010, section 5.1.7a

The In-Band Frame Error Rate (IFER) measurement provides the reference sensitivity of the speech traffic channel. IFER is defined in 3GPP 51.010, section 14.2.19 (Reference sensitivity - TCH/AFS-INB), section 14.2.20 (Reference sensitivity - TCH/AHS-INB), and 3GPP 44.010, section 5.1.7a (TCH loop without signalling of erased frames for in-band channel rate error).

Related Topics

GSM Bit Error Measurement

GPRS Bit Error Measurement

Programming a Bit Error Measurement for GSM

Programming a Bit Error Measurement for GPRS

Fast Bit Error Measurement Description

Programming a Fast Bit Error Measurement

Block Error Measurement

Programming a Block Error Measurement

GSM Frame Erasure Rate (FER) Measurement Description

Programming a Frame Erasure Rate (FER) Measurement

In-Band Frame Error (IFER) Measurement Description

Frequency Stability

Frequency Stability measures the absolute frequency and frequency error of an analog RF signal. The signal may be modulated by SAT and/or additional FM. Refer to IS-137A section 3.1.1.2, Analog Frequency Stability, for more information on making this measurement. Measurement resolution is 1.0 Hz, meeting the requirements in IS-137A section 6.6.1.1, Analog General Equipment, Radio frequency.

I/Q Tuning Measurement

The I/Q Tuning measurement is not an ETSI specified measurement.

Related Topics

I/Q Tuning Measurement Description

Programming an I/Q Tuning Measurement

Dynamic Power Measurement

The Dynamic Power measurement is not an ETSI specified measurement.

Related Topics

Dynamic Power Measurement Description

Programming a Dynamic Power Measurement

EDGE Dynamic Power Measurement

The EDGE Dynamic Power (EDP) measurement is not an ETSI specified measurement.

Related Topics

EDGE Dynamic Power (EDP) Measurement

Programming an EDGE Dynamic Power Measurement

Analog Audio Measurements

The Analog Audio measurements are not ETSI specified measurements.

The Analog Audio measurements are not applicable to GPRS.

Related Topics

Analog Audio Measurement Description

Spectrum Monitor Measurements

The Spectrum Monitor measurement is not an ETSI specified measurement.

Related Topics

Spectrum Monitor Description

Programming the Spectrum Monitor

Modulation Accuracy

Standards Reference: 3GPP 51.010 section 13.17.1

The method of test implemented for the Modulation Accuracy measurement conforms to the measurement method defined in 3GPP 51.010 section 13.17.1. This measurement is only applicable to EGPRS.

Related Topics

Modulation Accuracy Measurement Description

How do I make Modulation Accuracy Measurements?

Programming a Modulation Accuracy Measurement

GSM Bad Frame Indication

Standards Reference: 3GPP 51.010 (formerly ETSI GSM 11.10) section 14.1.1, 14.1.2, 14.1.5 and 14.1.6

With proper test set configuration, the method of test implemented for the GSM Bad Frame Indication conforms to the measurement method defined in 3GPP 51.010 section 14.1.1, 14.1.2, 14.1.5 and 14.1.6. This measurement is only applicable to GSM.

Related Topics

GSM Bad Frame Indication (BFI) Measurement Description


Bit Error Measurement

Bit Error Measurement

There are three bit error measurements available in the test set:

  • GSM Bit Error Measurement for GSM speech data and Circuit Switched Data (CSD) bit error testing,
  • GPRS Bit Error Measurement for GPRS and EGPRS bit error testing, and
  • EGPRS SRB Bit Error Measurement for BER testing in SRB Loopback.

GSM Bit Error Measurement

  • Bit Error Measurements versus Fast Bit Error Measurements
  • How is a Bit Error (BER) Measurement Made?
  • BER Measurement Types
  • BER Measurement Results
  • Using the GSM Bit Error Measurement for Circuit Switched Data (CSD) Bit Error Testing

Bit Error Measurements versus Fast Bit Error Measurements

There are four commonly used types of bit error measurements in GSM:

  • ``BER with Frame Erasure" or ``Residual BER" when the mobile station has been configured to loopback A.
  • ``BER without Frame Erasure" or ``Non-residual BER" when the mobile station has been configured to loopback B.
  • BER using burst-by-burst loopback when the mobile station has been configured to loopback C.
  • "BER with Frame Erasure and Unreliable Frame Rate Signaling" or "Residual (D) BER" when mobile station has been configured to loopback D.

The test set allows you to select between loopback A, B or D for Bit Error Measurement. Loopback C can only be used in the fast bit error measurement. Refer also to Fast Bit Error Measurement Description .

NOTE
If the test set has codeware version A.02.00 or above, unnecessary loopback commands and delays can be eliminated by taking advantage of enhancements available.

Previous versions of the test set required you to set the loopback type, and did not have a feature that allowed time for the loop to close.

How is a Bit Error (BER) Measurement Made?

During BER measurements, the test set generates a downlink TCH with pseudo-random binary sequence, PRBS-15, data at a known power level. The mobile station receives the data, loops it back to its transmitter, and returns the data to the test set. The test set compares data sent to data received, and BER is calculated.

SETup subsystem commands are sent to the test set to specify the time taken to close its loopback path, whether to open or close a loop during downlink signaling operations (for example, channel assignment), the number of bits to test, measurement type, loopback delay, measurement units, trigger arm, and measurement timeout values.

When a call is established on a TCH, the loopback type, corresponding to one of the BER measurement types, must be sent to the mobile station. The test set closes the loopback automatically and re-opens it when the measurement is closed (that is, when INITiate:BERRor is OFF).

You must set the measurement type from one of the available measurement types, (see SETup:BERRor[:TYPE] ). If you query a residual result when a non-residual measurement is initiated, the test set returns 9.91 E+37 (NAN). The Measurement type must be set before initiating a BER measurement. See BER Measurement Types

The loop must be closed before a BER test can start. Using the close loop signalling delay time feature allows time for the loop to close. See SETup:BERRor:CLSDelay[:STIMe] for more details.

Each mobile station may have a different time delay between receiving a frame and re-sending it on the uplink. By default, the test set is configured to automatically determine the amount of delay needed. This is determined automatically when the test set has, for two frames, correctly received 80% of the downlink bits back on the uplink. The test set can be queried for the loopback delay value.

If necessary, you can manually set the loopback delay (see SETup:BERRor:LDControl:AUTO ).

NOTE
In case the test set is not able to correlate the data it transmits on the downlink with the data it receives on the uplink, a Measurement Timeout value should be set. If a timeout is not set and the test set is unable to correlate, the measurement appears to "hang".

The BER measurement trigger source is always set to immediate. The BER measurement does not offer multi-measurement results. See Statistical Measurement Results

BER, FBER, and DAUDIO (uplink speech level) measurements are mutually exclusive measurements. Whichever of these measurements is activated last forces the others to stop.

BER Measurement Types

Type IA, Type IB, and Type II for both residual and non-residual refer to the different class types describing GSM speech coding bits.

Residual:

  • Residual Type IA (50 bits per speech frame)
  • Residual Type IB (132 bits per speech frame)
  • Residual Type II (78 bits per speech frame)
  • Residual Data

When one of these residual measurement types is selected, the test set sends the mobile station a message instructing it to close loopback A. When the mobile station is in loopback A, it erases frames received with CRC (cyclic redundancy check) errors and replaces all the bits in those frames with zeros. The BER measurement is then able to return the frame erasure count or ratio results as well as the results of the bitwise comparison of the un-erased frames looped back from the mobile station.

Non-residual:

  • Type IA (50 bits per speech frame)
  • Type IB (132 bits per speech frame)
  • Type II (78 bits per speech frame)
  • Data

When you select one of these non-residual measurement types, the test set sends the mobile station a message instructing it to close loopback B. A BER measurement with CRC's (cyclic redundancy check) returns the CRC count or ratio results. The mobile station does not indicate if any frames in the downlink were erased.

Residual (D):

  • Residual Type IA (D) (50 bits per speech frame)
  • Residual Type IB (D) (132 bits per speech frame)
  • Residual Type II (D) (78 bits per speech frame)
  • Residual Data (D)

When one of these residual (D) measurement types is selected, the test set sends the mobile station a message instructing it to close loopback D. The test set works almost the same as the correspondent Residual measurement type with one exception: the FER display during the measurement is actually Frame Error Rate plus Unreliable Frames Rate.

BER Measurement Results

The results of a BER measurement can be displayed in two ways, (number of errors counted) or (the ratio bad bits (errors) to total bits counted). If you are using the test set manually, select either Count or % from the Measurement Units field. If you are using the test set remotely, these results are available using the FETCh command, see FETCh:BERRor:COUNt[:BITS]? or FETCh:BERRor:RATio[:BITS]? . Alternatively the FETCh:BERRor[:ALL]? or FETCh:BERRor:FULL? can also be used to return the results.

Type A Residual Measurement Results

  • Integrity Indicator
  • Bit Error Ratio
  • Bits Tested
  • Bit Error Count
  • Frame Error Rate
  • Frame Erasure Count

Type B Non-Residual Measurement Results

  • Integrity Indicator
  • Bit Error Ratio
  • Bits Tested
  • Bit Error Count
  • CRC Ratio
  • CRC Count

Type D Residual Measurement Results

  • Integrity Indicator
  • Bit Error Ratio
  • Bits Tested
  • Bit Error Count
  • Frame Error Rate (which is actually Frame Error Rate plus Unreliable Frames Rate)
  • Frame Erasure Count

Using the GSM Bit Error Measurement for Circuit Switched Data (CSD) Bit Error Testing

The GSM bit error measurement is also useful for CSD bit error testing. For more information on GSM CSD, see GSM Circuit Switched Data (CSD) .

You must start a CSD call before initiating the GSM BER measurement.

Measurement Types for CSD Bit Error

Since all the data in the CSD data payload is equally important and convolutionally encoded with same protection, the test set allows you to choose two new measurement types to ensure appropriate results are returned: Residual Data and Data.

In addition, the frame-by-frame Fast Bit Error measurement is also applicable to CSD bit error testing.

Operating Considerations

GSM Bit Error Measurement is available when the operating mode is set to Active Cell, GSM BCH+TCH, GPRS BCH+PDTCH+TCH and EGPRS BCH+TCH+PDTCH.

Related Topics for GSM

Programming a Bit Error Measurement

Test Adherence to Standards

Fast Bit Error Measurement Description

Programming a Fast Bit Error Measurement

CALL:TCHannel:LOOPback

Bit Error Troubleshooting

GPRS Bit Error Measurement

How is a GPRS Bit Error (GBER) Measurement Made?

During GBER measurements, the test set generates one or more downlink PDTCHs at a known level with data using the payload pattern you specify. (See Payload Patterns .) The default payload pattern is a pseudo-random binary sequence, PRBS-15, which is the most appropriate for this measurement. The mobile station receives the data, loops it back to its transmitter, and returns the data to the test set. The test set compares data sent to data received, and BER is calculated.

If the test set's operating mode is set to Active Cell, the connection type must be set to ETSI Type B (Unacknowledged) or ETSI Type B (Acknowledged) in order to make BER measurements. This can be done using CALL:FUNCtion:CONNection:TYPE . The measurement does not return any results if the connection type is set to SRB Loopback.

Alternatively, you can make BER measurements when the test set's operating mode is set to GPRS BCH+PDTCH or EGPRS BCH+PDTCH test modes (see CALL:OPERating:MODE ).

SETup subsystem commands are sent to the test set to specify the loopback delay control mode, number of bits to test, block delay, measurements units, trigger arm, measurement timeout values, and bad block handling setting.

The bad block handling parameter determines how bad blocks are interpreted by the GBER measurement. If you want more details on this parameter, see SETup:GBERror:BBLocks .

Each mobile station may have a different time delay between receiving a block of data and re-sending it on the uplink. By default, the loopback delay control mode is set to automatic, and the amount of delay needed is determined when the test set has, for four consecutive blocks, correctly received 80% of the downlink bits back on the uplink. The test set can be queried for the block delay value using FETCh:GBERror:DELay? .

You can specify the first downlink burst to be looped back in the first uplink burst using the command CALL:(PDTCH|PDTChannel):MSLot[:FIRSt]:DOWNlink:LOOPback[:BURSt] .

If necessary, you can manually set the delay using SETup:GBERror:LDControl:AUTO .

NOTE
In case the test set is not able to correlate the data it transmits on the downlink with the data it receives on the uplink, a Measurement Timeout value should be set. If a timeout is not set and the test set is unable to correlate, the measurement will appear to "hang".

The GBER measurement trigger source is always set to immediate. The GBER measurement does not offer multi-measurement results. If you require more details on multi-measurement results, see Statistical Measurement Results .

Operating Considerations

The GBER measurement aborts and restarts if the Operating Mode, Multislot Configuration, or Coding Scheme is changed while the GBER measurement is running.

Any change to the Multislot Configuration or the Coding Scheme affects the rate at which bits are tested. More uplink timeslots per frame will increase the number of bits tested per second as well as coding scheme used. For example, if the coding scheme CS-4 is selected on the test set, the GBER measurement can test more bits per second than if the coding scheme CS-1 is selected. Therefore, the recommended channel coding scheme for GPRS BER measurements is CS-4. Use the command CALL:(PDTCH|PDTChannel):CSCHeme:UPLink to set the GPRS coding scheme.

The GBER and the BLER measurements are mutually exclusive, that is which ever of these measurements is activated last forces the other to become inactive.

GSM Bit Error Measurement is available when the operating mode is set to Active Cell, GSM BCH+TCH, GPRS BCH+PDTCH+TCH and EGPRS BCH+TCH+PDTCH.

Types of Signal GBER can Measure

GBER measurements can be made on these types of input signals:

  • One or more uplink and downlink PDTCH pairs with the mobile station in active cell mode and the data connection type set to ETSI Type B Unacknowledged or ETSI Type B Acknowledged. If you want to optimize measurement speed, it is important that the mobile station is set up for the same number of uplink and downlink PDTCHs.
  • One or more uplink and downlink PDTCH pairs with the mobile station in GPRS BCH+PDTCH or EGPRS BCH+PDTCH test modes (see CALL:OPERating:MODE for details on setting the cell operating mode). Note that you have to manually set your mobile station to synchronize its internal frequency and timing reference with the test set. You also have to command the mobile station to loop back the PDTCH data.

GBER Measurement Results

The results of a GBER measurement can be displayed in two ways; the number of errors counted or the ratio of bad bits (errors) to total bits counted. If you are using the test set manually, both Count and Bit Error Ratio are displayed on the Bit Error measurement screen. If you are using the test set remotely, these results are available using the FETCh command, see FETCh:GBERror:COUNt? or FETCh:GBERror:RATio? . Alternatively the command FETCh:GBERror[:ALL]? can be used to return all of the following results:

  • Integrity Indicator
  • Bit Error Ratio
  • Bits Tested
  • Bit Error Count

In addition, the Intermediate Count of Bits Tested result can be queried using FETCh:GBERror:ICOunt? , the Block Delay can be queried using FETCh:GBERror:DELay? , and the CRC error count can be queried using FETCh:GBERror:CRC? .

Related Topics for GPRS

Programming a Bit Error Measurement

Test Adherence to Standards

Bit Error Troubleshooting

Receiver Sensitivity Testing in GPRS and EGPRS

EGPRS SRB Bit Error Measurement

How is a EGPRS SRB Bit Error (SBER) Measurement Made?

During the SBER measurement, the test set generates one or more downlink PDTCHs at a known level with data using the payload pattern you specify. (See Payload Patterns .) The default payload pattern is a pseudo-random binary sequence, PRBS-15, with is the most appropriate for this measurement. To accurately measure bit error, the measurement must reflect the bit error rate before error correction is applied. For EGPRS, this is provided by implementing the ETSI defined SRB Loopback test mode in the mobile station. In this test mode, the mobile station loops back the received downlink PDTCH after demodulation but before decoding, thus bypassing the error correction stage. The mobile station receives the data, loops it back to its transmitter, and returns the data to the test set. The test set compares data sent to data received, and BER is calculated.

The SBER measurement is made on the raw data after coding and before decoding. This means not all the bits returned by the mobile station are included in the comparison. Only the encrypted bits which are not "stealing bits" are included in the calculation. Therefore only the following bits are used in the SBER measurement:

  • GMSK Normal Burst - bit numbers 3-59 and 88-144
  • 8PSK Normal Burst - bit numbers 9-182 and 263-434.

Operating Considerations

If the test set's operating mode is set to Active Cell, the serving cell must be set to EGPRS and the data connection type must be set to SRB Loopback in order to make SBER measurements. This can be done using CALL:FUNCtion:CONNection:TYPE .

Alternatively, you can make SBER measurements when the test set's operating mode is set to EGPRS BCH+PDTCH test mode (see CALL:OPERating:MODE ).The SBER measurement will work correctly in this mode if the modulation format used on a downlink slot has the same modulation format as the corresponding uplink slot. If the SRB Loopback mode is supported, the SBER measurement will also function when an 8PSK downlink modulation format is looped into a GMSK uplink modulation format.

Measurement Setup Parameters

SETup subsystem commands are sent to the test set to specify the loopback delay control mode, number of bits to test, block delay, measurements units, trigger arm, and measurement timeout values. See SETup:SBERror .

Each mobile station may have a different time delay between receiving a block of data and re-sending it on the uplink. By default, the loopback delay control mode is set to automatic, and the amount of delay needed is determined when the test set has, for four consecutive blocks, correctly received 80% of the downlink bits back on the uplink. The test set can be queried for the block delay value using FETCh:SBERror:DELay? .

You can specify the first downlink burst to be looped back in the first uplink burst using the command CALL:(PDTCH|PDTChannel):MSLot[:FIRSt]:DOWNlink:LOOPback[:BURSt] .

If necessary, you can manually set the delay using SETup:SBERror:MANual:DELay .

NOTE
In case the test set is not able to correlate the data it transmits on the downlink with the data it receives on the uplink, a Measurement Timeout value should be set. If a timeout is not set and the test set is unable to correlate, the measurement will appear to "hang".

The SBER measurement trigger source is always set to immediate. The SBER measurement does not offer multi-measurement results. If you require more details on multi-measurement results, see Statistical Measurement Results .

Types of Signal SBER can Measure

SBER measurements can be made on these types of input signals:

  • One uplink and downlink PDTCH pair with the mobile station in active cell mode, serving cell EGPRS, and the data connection type set to SRB Loopback.
    • The Modulation Coding Scheme for the downlink and uplink must both use the same modulation format (GMSK or 8PSK).

      NOTE
      The test set does not currently support asymmetric SRB Loopback. In asymmetric SRB Loopback, the uplink and downlink are allowed to use different modulation formats.

      If the data looped back on the uplink uses a different modulation format than that used by the downlink, the number of bits in the data blocks will be different. In this situation, the SRB BER measurement treats each bit as if it were in error.

  • One uplink and downlink PDTCH pair with the mobile station in EGPRS BCH+PDTCH test mode (see CALL:OPERating:MODE for details on setting the cell operating mode).

    NOTE
    When operating the test set in EGPRS BCH+PDTCH operating mode, you must
    • manually set your mobile station to synchronize its internal frequency and timing reference with the test set, and
    • configure the mobile station for SRB Loopback test mode.

SBER Measurement Results

The results of an SBER measurement can be displayed in two ways; the number of errors counted or the ratio of bad bits (errors) to total bits counted. If you are using the test set manually, both Count and Bit Error Ratio are displayed on the EGPRS SRB Bit Error measurement screen. If you are using the test set remotely, these results are available using the FETCh command, see FETCh:SBERror:COUNt? or FETCh:SBERror:RATio? . Alternatively the command FETCh:SBERror[:ALL]? can be used to return all of the following results:

  • Integrity Indicator
  • Bits Tested
  • Bit Error Ratio
  • Bit Error Count

In addition, the Intermediate Count of Bits Tested result can be queried using FETCh:SBERror:ICOunt? and the Block Delay can be queried using FETCh:SBERror:DELay? .

Related Topics for EGPRS

Programming a Bit Error Measurement

Test Adherence to Standards

How do I make EGPRS SRB Bit Error Measurements?

EGPRS SRB Bit Error Troubleshooting

Receiver Sensitivity Testing in GPRS and EGPRS


Block Error Measurement

Block Error Measurement

This measurement is not applicable to GSM.

How is a Block Error (BLER) Measurement Made?

Block Error (BLER) measurements can be used in the production process to test the performance of a GPRS or EGPRS mobile station's receiver.

The BLER measurement which the test set provides is based on GPRS receiver tests defined in 3GPP 51.010 (formerly ETSI GSM 11.10), section 14.16 (GPRS) and section 14.18.1 (EGPRS).

Two measurement methods, Loopback and Polling, are used by the BLER measurement, depending on how the test set is configured. The possible scenarios are illustrated in the following table.

BLER measurement method usage
 |  | Connection Type
Operating Mode |  | ETSI B Unack | ETSI B Ack | BLER | Auto1 | SRB Loopback
Active Cell | GPRS | Loopback | Loopback or Polling | Polling | Polling | This connection type is not applicable to the BLER Measurement
 | EGPRS
GPRS BCH+PDTCH |  | Loopback
EGPRS BCH+PDTCH

1: The Auto connection type is not recommended for BLER measurements. During data transfers, TBFs are brought up and down causing the measurement to abort and restart frequently.

The BLER measurement is made using one of the following two methods, depending on the test set's configuration:

Loopback Measurement Method

The test set generates one or more downlink PDTCHs at a known level with data using the payload pattern you specify. (See Payload Patterns .) The default payload pattern is a pseudo-random binary sequence, PRBS-15, which is the most appropriate for this measurement. The mobile station receives the data, loops it back to its transmitter, and returns the data to the test set in the available uplink PDTCHs. You can specify the first downlink burst to be looped back in the first uplink burst using the command CALL:(PDTCH|PDTChannel):MSLot[:FIRSt]:DOWNlink:LOOPback[:BURSt] . The test set compares data sent to data received. A block that is received which has one or more bit errors within it is marked as having a block error.

Each mobile station may have a different time delay between receiving a block of data and re-sending it on the uplink. By default, the loopback delay control mode is set to automatic, and the amount of delay needed is determined when the test set has, for four consecutive blocks, correctly received 80% of the downlink bits back on the uplink. The test set can be queried for the block delay value using FETCh:BLERror:DELay? .

If necessary, you can manually set the delay. First, change loopback delay control to Manual using the command SETup:BLERror:LDControl:AUTO , and then set the delay using SETup:BLERror:LDControl:AUTO .

The BLER measurement result is calculated irrespective of the Layer 1 reported demodulation status. The BLER measurement result a will vary depending on the setting for the BLER Bad Block Handling setting (see SETup:BLERror:BBLocks for more information on the BLER Bad Block Handling parameter).

  • If a corrupted burst error, missing burst error or radio block frame check sequence error is received, the burst is still included in the BLER measurement result and contributes to the Block Error count if the BLER Bad Block Handling parameter is set to Include .
  • Only valid radio blocks contribute to the BLER measurment result if the BLER Bad Block Handling parameter is set to Exclude . Radio blocks that fail the CRC (cyclic redundancy check or frame check sequence) are considered invalid an are excluded. See FETCh:BLERror:CRC? for more information on the CRC Error Count parameter.

Polling Measurement Method

The test set periodically polls the mobile station, deriving the BLER measurement result from the Radio Link Control (RLC) layer's Packet ACK/NACK (Acknowledged/Not Acknowledged) message. Polling the mobile station for this message provides an indication of which blocks have been successfully received, and which blocks have been received with an error.

The number of blocks indicated to be in error and the total number of blocks received are counted. The polling interval can be set using CALL:FUNCtion:DATA:BLER:POLLing:INTerval .

ETSI B Acknowledged Measurement Method Mode

For the ETSI B Ack connection type, the BLER measurement can be performed in using either the Loopback or Polling measurement method. You can select the method to be used by the measurement with the following command: SETup:BLERror:ETSIB:MODE .

Operating Considerations

The BLER and the GBER measurements are mutually exclusive, that is which ever of these measurements is activated last forces the other to become inactive.

BLER measurements cannot be made when the data connection type is set to ETSI Type A in Active Cell operating mode, nor in BCH test mode. The test set's operating mode can be set using CALL:OPERating:MODE . The data connection type can be set using CALL:FUNCtion:CONNection:TYPE .

You may want to collect BLER results for different GPRS coding schemes. Use the command CALL:(PDTCH|PDTChannel):CSCHeme:UPLink to change the GPRS coding scheme.

You may want to collect BLER results with different modulation and coding schemes for EGPRS. Use the command CALL:(PDTCH|PDTChannel):MCSCheme to set the EGPRS modulation coding scheme.

If you make a change to any of the following parameters while the BLER measurement is on, it will abort and restart.

  • Operating Mode
  • Connection Type
  • Amplitude Offset
  • Multislot Configuration
  • Coding Scheme
  • Modulation Coding Scheme

The multislot configuration used affects the speed of the BLER measurement. Using multiple uplink timeslots increases the rate at which blocks are tested.

You can send SETup subsystem commands to the test set which specify the number of blocks to test, block delay, trigger arm, and measurement timeout values.

In case the test set is not able to correlate the data it transmits on the downlink with the data it receives on the uplink, a Measurement Timeout value should be set. If a timeout is not set and the test set is unable to correlate, the measurement will appear to "hang".

Types of Signal BLER can Measure

BLER measurements can be made on these types of input signals:

  • One or more uplink and downlink PDTCH pairs with the mobile station in active cell mode and the data connection type set to ETSI Type B, ETSI Type B Acknowledged, or BLER. If you want to optimize measurement speed, it is important that the mobile station is set up for the same number of uplink and downlink PDTCHs.
  • One or more uplink and downlink PDTCH pairs with the mobile station in either GPRS BCH+PDTCH test mode or EGPRS BCH+PDTCH test mode (see CALL:OPERating:MODE for details on setting the cell operating mode). Note that you have to manually set your mobile station to synchronize its internal frequency and timing reference with the test set. You also have to command the mobile station to loop back the PDTCH data.

BLER Measurement Results

The results of a BLER measurement can be displayed in two ways; the number of block errors counted or the ratio of bad blocks (errors) to total blocks counted. If you are using the test set manually, both Count and Block Error Ratio are displayed on the Block Error measurement screen. If you are using the test set remotely, these results are available using the FETCh command, see FETCh:BLERror:COUNt? or FETCh:BLERror:RATio? . Alternatively the command FETCh:BLERror[:ALL]? can be used to return all of the following results:

  • Integrity Indicator
  • Blocks Tested
  • Block Error Ratio
  • Block Error Count

In addition, the Intermediate Count of Blocks Tested result can be queried using FETCh:BLERror:ICOunt? , Block Delay can be queried using FETCh:BLERror:DELay? , and the CRC count can be queried using FETCh:BLERror:CRC? .

BLER Measurement Results by Timeslot

When using the Polling measurement method, you can also retrieve the following measurement results for individual timeslots using FETCh:BLERror:BURSt<[1]|2|3|4|5>[:ALL]? .

  • Integrity Indicator for the burst
  • Blocks Tested
  • Block Error Ratio
  • Block Error Count

Related Topics

Programming a Block Error Measurement

Test Adherence to Standards

Block Error Troubleshooting

Receiver Sensitivity Testing in GPRS and EGPRS

Block Error Rate (BLER) Reports Description


Block Error Rate (BLER) Reports Description

Block Error Rate ( BLER) Reports Description

These reports are not applicable to GSM.

Block Error Rate (BLER) reports can be used in the production process to test the performance of a GPRS mobile station's receiver. The BLER result is derived from the Radio Link Control (RLC) layer's Packet ACK/NACK (Acknowledged/Not Acknowledged) message. BLER is simply the ratio of the number of negatively acknowledged blocks to the total number of blocks acknowledged by the mobile station.

The test set uses an Agilent proprietary data connection to enable BLER reports to be retrieved from the mobile station (For details on how to set the data connection type to BLER, see CALL:FUNCtion:CONNection:TYPE ).

The BLER reports which the test set provides are based on GPRS receiver tests defined in 3GPP 51.010 (formerly ETSI GSM 11.10), section 14.16 (GPRS) and section 14.18.1 (EGPRS).

As well as BLER reports, the test set also provides a Block Error measurement (see Block Error Measurement ). Starting or aborting a Block Error measurement does not affect the BLER reports. In addition, resetting the BLER reports does not affect the BLER measurement.

When are BLER Reports Made?

You obtain BLER results using the GPIB query CALL:STATus:(PDTCH|PDTChannel):BLERror? . This query returns the percentage of blocks tested that were in error and the total number of blocks used to generate the BLER result. To reset the BLER result you must use SYSTem:MEASurement:RESet . The BLER result does not reset automatically when you connect a different mobile station.

The BLER results are only available when the data connection status is transferring (TRAN). If you require details on data connection states, see Data Connection Processing State Synchronization .

Using Different Power Levels on Downlink Timeslots

The BLER results are calculated across all active downlink timeslots, not on any individual downlink timeslot.

When using the multislot configurations which provide two downlinks (D2U1 and D2U2), the test set requests Packet ACK/NACK (Acknowledged/Not Acknowledged) messages from the mobile station on timeslot 4. ETSI specifies that the mobile station must respond to these requests on the same timeslot. If the downlink on timeslot 4 degrades severely (and thus has a large number of block errors), the mobile station may be unaware of a request for Packet ACK/NACK messages. If this happens, the BLER reports may hang for long periods or stop completely. This may cause the data connection to stop after a few seconds.

Programming BLER Reports

This section provides an example of how to use BLER reports to test a GPRS mobile station's receiver via GPIB.

The following procedure assumes that a data connection has been established between the test set and the mobile station (connection status is Transferring). See Step 4: Make a Connection .

  1. Configure the BCH and PDTCH parameters using the CALL subsystem.
  2. Reset the BLER results using the SYSTem:MEASurement:RESet command.
  3. Use the CALL:STATus:PDTCH:BLERror? query to obtain the first BLER results.
  4. Re-configure the downlink PDTCH power level of one of the bursts using the CALL subsystem.
  5. Reset the BLER results again using the SYSTem:MEASurement:RESet command.
  6. Use the CALL:STATus:PDTCH:BLERror? query to obtain the second BLER results.

Programming Example

10    ! This code assumes that the current data connection state is Transferring.
20    !
30    ! Configure BCH and PDTCH parameters
40    OUTPUT 714;"CALL:PDTCH:BAND PGSM" ! Set the PDTCH band.
50    OUTPUT 714;"CALL:POW -60" ! Set the BCH level to -60 dBm
60    OUTPUT 714;"CALL:PDTCH:MSL:CONF D2U1" ! Set the multislot configuration to
70                                         ! two downlinks, one uplink.
80    OUTPUT 714;"CALL:PDTCH:PZER:LEV 30" ! Set the P0 reference level to 30 dB.
90    OUTPUT 714;"CALL:PDTCH:CSCH CS4" ! Set the channel coding scheme to CS4.
100   !
110   ! Perform a measurement reset to ensure a stable data connection.
120   OUTPUT 714;"SYST:MEAS:RES"
130   ! Read initial BLER ensuring that result is over 2000 blocks at least
140   REPEAT
150     OUTPUT 714;"CALL:STAT:PDTCH:BLER?"
160     ENTER 714;Bler_initial,Blocks_initial
170   UNTIL (Blocks_initial>=2000 AND Blocks_initial<=2300) ! <= required for
180                                                         ! NAN (9.91E+37) case.
190   !
200   ! Print results at initial downlink PDTCH power level
210   ! of -90 dBm(-60 dBm BCH level - 30 dB P0 level)
220   PRINT "Blocks tested at -90 dBm = ";Blocks_initial
230   PRINT "BLER Result at downlink PDTCH power of -90 dBm = ";Bler_initial
240   !
250   ! Set up and select the downlink PDTCH power reduction levels.
260   OUTPUT 714;"CALL:PDTCH:PRED:LEV1 11db"
270   OUTPUT 714;"CALL:PDTCH:PRED:LEV2 0dB"
280   OUTPUT 714;"CALL:PDTCH:PRED:BURS1 PRL1"
290   OUTPUT 714;"CALL:PDTCH:PRED:BURS2 PRL2"
300   OUTPUT 714;"SYST:MEAS:RES" ! Reset the BLER results
310   !
320   ! Now obtain the second set of BLER results when burst 1 has a lower
330   ! power level which introduces more block errors.
340   REPEAT
350     OUTPUT 714;"CALL:STAT:PDTCH:BLER?"
360     ENTER 714;Bler_second,Blocks_second
370   UNTIL (Blocks_second>=2000 AND Blocks_second<=2300)
380   !
390   ! Print results when downlink burst 1 is at lower downlink PDTCH
400   ! power level of -101 dBm(-60 dBm BCH level - 30 dB P0 level - 11 dB power
410   ! reduction level).
420   PRINT
430   PRINT "Blocks tested at -101 dBm = ";Blocks_second
440   PRINT "BLER Result at downlink PDTCH power of -101 dBm = ";Bler_second
450   END

Returned Values

The BLER reports returned by this program are:

  • Blocks_initial returns the number of blocks tested to calculate the first BLER result.
  • Bler_initial returns the BLER result, in percent (%) when the downlink PDTCH power levels of both bursts are at -90 dBm.
  • Blocks_second returns the number of blocks tested to calculate the second BLER result.
  • Bler_second returns the second BLER result, in percent (%). This result has been obtained when the downlink PDTCH power level of the first burst has been reduced by 11 dB to -101 dBm.

Related Topics

Testing a GPRS Mobile Station

Receiver Sensitivity Testing in GPRS and EGPRS

CALL:STATus:(PDTCH|PDTChannel):BLERror?

Programming: Getting Started Guide for E1968A GSM/GPRS Mobile Test Application Revision A.02 and E6701C GSM/GPRS Lab Application Revision C.02

GPRS Data Connection Troubleshooting


Calibrating the Test Set

Calibrating the Test Set

Description

  • Calibration Process Requirements
  • Recommended Calibration Intervals
  • Calibration Descriptions
    • IQ Calibrations
    • Burst Mod Offset 1 Calibration
    • Thermal Power Null Adjustment
    • Digital Average Power Calibration
    • Spectrum Monitor Calibration
    • Channel Power Calibration
    • Calibrate Measurements

Various calibration routines must be run periodically to ensure measurement accuracy, source accuracy and allow the most robust demodulation of the device-under-test's signal. This document describes the various calibrations available in the test set and when they should be performed.

Calibration Process Requirements

IMPORTANT
Before performing any calibrations on your test set:

  • Ensure that the calibration is necessary - running calibrations more often than necessary wastes your time and effort, and if the calibration is performed incorrectly, could actually result in degraded test set performance.
  • Ensure that the test set is in its ambient operating environment - in other words, ensure that the test set has warmed up (at least 30 minutes) and is in a location similar to the one it will be used in. For example, if you are going to be using the test set in a racked test system, then you must calibrate the test set while it is in that test system, and all of the equipment has reached a stable operating temperature.
  • Ensure that no power is present at the front panel RF connectors - remove any cables or connectors from the RF IN/OUT and RF OUT ONLY connectors. If you are operating in a high RF environment, it is recommended that you also terminate the RF connectors with a 50 Ohm load.

Recommended Calibration Intervals

This section indicates when the test set calibrations should be performed. Procedures are given for test sets that include Option 003: Flexible Radio Link and test sets that do not. Refer to Calibration Descriptions for details about the calibrations and how to perform them.

  • Once every year you must perform a full calibration by following steps 1-7 of the Calibration Procedure for Test Sets with Option 003 (or steps 1-2 of the Calibration Procedure for Test Sets without Option 003 if your test set does not include option 003).
  • You must also perform steps 1-7 of the Calibration Procedure for Test Sets with Option 003 (or steps 1-2 of the Calibration Procedure for Test Sets without Option 003 if your test set does not include option 003) if any of the following events occur:
    • When you receive the test set, before using it for the first time (regardless of whether the test set is new, being returned from service, or on loan from a colleague).
    • After adding a new application or format to the test set.
      Note: Upgrading firmware already present in the test set does not typically require running the calibration procedures. However, when upgrading firmware, it is advisable to check the release notes for any major feature changes that require re-calibration of the test set.
    • After you perform any kind of repair or service on your test set.
  • It is recommended that once every month you perform steps 4-7 of the Calibration Procedure for Test Sets with Option 003 (or step 2 of the Calibration Procedure for Test Sets without Option 003 if your test set does not include option 003).
  • You must also perform steps 4-7 of the Calibration Procedure for Test Sets with Option 003 (or step 2 of the Calibration Procedure for Test Sets without Option 003 if your test set does not include option 003) if any of the following events occur:
    • The operating environment for your test set changes significantly (for example, the temperature changes by more than 10 degrees C or the test set is moved from a racked test system to a bench top).
    • A measurement returns integrity indicator 19 ( Uncalibrated Due to Temperature ).

IMPORTANT
Ensure that your test set has warmed up at least 30 minutes and that no power is present at the front panel RF connectors before performing any calibrations.

Calibration Procedure for Test Sets with Option 003

Calibration Procedure for Test Sets without Option 003

Calibration Descriptions

If any of the following calibrations fail, ensure that you have followed the Calibration Process Requirements and have performed the calibrations in the order prescribed by Recommended Calibration Intervals . If the calibration still fails, contact your local Agilent Sales Representative for assistance.

IQ Calibrations

When performed from a GSM/GPRS/EGPRS or AMPS/136 application or format, the First IQ Modulator calibration sends a signal from the Baseband Generator 1 module to the RF Source 1 module to optimize the phase accuracy of RF Source 1 as a function of frequency. The optimization data is then stored in the test set and accessed whenever the RF Source frequency is set. The Second IQ Modulator calibration performs a similar procedure for RF Source 2 (RF Source 2 is only present if the test set includes option 002: RF Source 2).

When performed from a W-CDMA/HSPA, cdma2000/IS-95/AMPS or 1xEV-DO application or format (which require option 003: Flexible Radio Link), the IQ calibrations perform the same phase optimizations explained above. Additionally, a signal is sent from the Flexible Radio Link Subsystem to the RF sources to calibrate phase accuracy for those alternative paths as well. This additional calibration data is written to the same calibration data file as above, but in a different area of the calibration table.

The IQ calibrations ensure that the test set accurately generates IQ-modulated signals. If the test set's IQ modulators have not been properly calibrated, the test set's output power (when producing an IQ-modulated signal) will be inaccurate, which may result in degraded receiver test results.

If you perform the IQ calibrations from a W-CDMA/HSPA, cdma2000/IS-95/AMPS or 1xEV-DO application or format, you do not need to perform them from any other application or format. However, note that if you perform the IQ calibrations from a GSM/GPRS/EGPRS or AMPS/136 application/format, you must still perform them once from a W-CDMA/HSPA, cdma2000/IS-95/AMPS or 1xEV-DO application or format.

The IQ calibrations do not need to be run frequently. See Recommended Calibration Intervals .

To initiate the IQ calibrations from the front panel, press SYSTEM CONFIG , press the right More ( 1 of 2 ) key, select Service ( F7 ), then select Cal. first IQ Modulator or Cal. second IQ Modulator . To initiate the IQ calibrations from a remote program, use the CALibration:IQ[1]|2? queries.

Each IQ calibration takes 5-6 minutes to execute.

Burst Mod Offset 1 Calibration

This calibration is only applicable to W-CDMA/HSPA, cdma2000/IS-95/AMPS, and 1xEV-DO applications and formats. This calibration is only required when using the test set to generate an AM or DSB-SC test signal (select ( F9 ) Test Signal when in CW Operating Mode ). These test signals are used for calibrating Zero Intermediate Frequency (Zero IF) devices which utilize Qualcomm's radioOne™ architecture.

You do not have to perform the Burst Mod Offset 1 calibration for each application/format in your test set; performing it from one application/format provides calibration data to all relevant applications and formats.

The Burst Mod Offset 1 calibration does not need to be run frequently. See Recommended Calibration Intervals .

The Burst Mod Offset 1 calibration calibrates the noise and signal level of RF Source 1 (as a function of frequency) to most accurately produce the AM and DSB-SC test signals required for Zero IF device calibration. The calibration is performed by generating the modulated test signals and adjusting RF Source 1 to optimize gain and minimize the noise floor. The optimization data is then stored in the test set and accessed whenever the RF Source frequency is set.

To initiate the Burst Mod Offset 1 calibration from the front panel, press SYSTEM CONFIG , press the right More ( 1 of 2 ) key, select Service ( F7 ), then select Cal. Burst Mod Offset 1 . To initiate the Burst Mod Offset 1 calibration from a remote program, use the CALibration:BMOFfset? query.

The Burst Mod Offset 1 calibration takes less than 1 minute to execute.

Thermal Power Null Adjustment

The Thermal Power Null Adjustment is only applicable to the cdma2000/IS-95/AMPS, 1xEV-DO and W-CDMA/HSPA applications/formats.

The Thermal Power Detector is calibrated at the factory and temperature controlled for stability. However, it is still possible for the auto-null circuit within the detector to drift over time. The Thermal Power Null Adjustment re-centers the auto-null circuit to provide optimum accuracy for the affected measurements.

You only need to perform the Thermal Power Null Adjustment once to re-center the auto-null circuit (you do not have to perform it from each application/format in your test set).

NOTE
Older application releases loaded on your test set may not include the Thermal Power Null Adjustment feature. Any applications that do not include the Thermal Power Null Adjustment feature (in the Utilities menu of the System Config screen) do not use the re-centering data and thus do not achieve the accuracy optimization that results from re-centering the auto-null circuit. You must upgrade those applications if you wish to achieve the accuracy optimization that results from running the Thermal Power Null Adjustment .

The Thermal Power Null Adjustment does not need to be run frequently. See Recommended Calibration Intervals .

This adjustment affects the Thermal Power (W-CDMA/HSPA) measurement, as well as all measurements that are calibrated by the Digital Average Power Calibration (cdma2000/IS-95/AMPS, 1xEV-DO) and Calibrate Measurements (W-CDMA/HSPA) routine.

To initiate the Thermal Power Null Adjustment from the front panel, press SYSTEM CONFIG , press the right More ( 1 of 2 ) key, and select Thermal Power Null Adjust ( F9 ). To initiate the Thermal Power Null Adjustment from a remote program, use the SYSTem:INSTrument:THERmal:POWer:NULL:ADJust? query.

The Thermal Power Null Adjustment takes between 30 seconds and 3 minutes.

The Thermal Power Null Adjustment can also be used to help verify your test set. See "Verifying the Test Set" in the Related Topics below.

Digital Average Power Calibration

The Digital Average Power calibration is only applicable to the cdma2000/IS-95/AMPS and 1xEV-DO applications/formats.

You do not have to perform the Digital Average Power calibration for each application/format in your test set; performing it from one application/format provides calibration data to all relevant applications and formats.

The Digital Average Power calibration does not need to be run frequently. See Recommended Calibration Intervals .

IMPORTANT
You must cycle the test set's power after the Digital Average Power calibration is complete in order to complete the calibration (the calibration data is not available to the test set until it has been restarted).

The Digital Average Power calibration generates calibration data for the Fast Power Detector for use by cdma2000/IS-95/AMPS and 1xEV-DO applications and formats. This calibration improves the accuracy of the Fast Power Detector when used to measure IS-95 and reverse RC-1 and RC-2 signals.

The calibration generates a CW signal at a given power level, measures it using the Fast Power Detector, generates a CDMA-modulated signal at the same power level, measures it using the Fast Power Detector and notes the difference. The calibration then generates a CW signal at a given power level, measures it using the Thermal Power Detector, generates a CDMA-modulated signal at the same power level, measures it using the Thermal Power Detector and notes the difference. Calibration data is then created by comparing these results. This is repeated for several power levels.

The Digital Average Power calibration provides calibration data for the following measurements:

  • Digital Average Power
  • Maximum/Minimum Power

To initiate the Digital Average Power calibration from the front panel, press Measurement selection , select Digital Average Power , then select Calibrate Digital Avg Pwr (F4) . To initiate the Digital Average Power calibration from a remote program, use the CALibration:DAPower? query.

The Digital Average Power calibration takes approximately 9 minutes to execute.

Spectrum Monitor Calibration

Performing the Spectrum Monitor calibration from one application/format does not provide calibration data to all relevant applications and formats. The calibration data files are shared as follows:

  • cdma2000/IS-95/AMPS and 1xEV-DO share the same Spectrum Monitor calibration data file.
  • W-CDMA/HSPA has its own Spectrum Monitor calibration data file.
  • GSM/GPRS/EGPRS and AMPS/136 share the same Spectrum Monitor calibration data file.

Thus, if you perform the Spectrum Monitor calibration from a 1xEV-DO application/format, you do not need to perform it from a cdma2000/IS-95/AMPS application/format. However you do still need to perform it from a W-CDMA/HSPA application/format and then again from either a GSM/GPRS/EGPRS or AMPS/136 application/format.

The Spectrum Monitor calibration should be run monthly, or whenever the test set's operating environment changes. See Recommended Calibration Intervals .

Performing the Spectrum Monitor calibration from a cdma2000/IS-95/AMPS or 1xEV-DO application/format executes the same routine as performing the Channel Power Calibration .

Performing the Spectrum Monitor calibration from a W-CDMA/HSPA application/format executes the same routine as performing the Calibrate Measurements routine.

Performing the Spectrum Monitor calibration from a GSM/GPRS/EGPRS or AMPS/136 application/format calibrates the IF signal path in the Measurement Downconverter, using a CW signal.

To initiate the Spectrum Monitor calibration from the front panel, press Instrument selection , select Spectrum Monitor , select Trigger Setup ( F4 ), then select Calibrate Measurement ( F11 ). To initiate the Spectrum Monitor calibration from a remote program, use the CALibration:SMONitor? query.

The Spectrum Monitor calibration takes between 45 seconds and 3 minutes to execute, depending upon which application/format it is executed from.

Channel Power Calibration

The Channel Power calibration is applicable to the cdma2000/IS-95/AMPS and 1xEV-DO applications/formats.

You do not have to perform the Channel Power calibration for each application/format in your test set; performing it from one application/format provides calibration data to all relevant applications and formats.

The Channel Power calibration should be run monthly, or whenever the test set's operating environment changes. See Recommended Calibration Intervals .

The Channel Power calibration calibrates the signal paths through the Measurement Downconverter and Demod Downconverter using both a CW signal and a modulated signal. The calibration is performed by comparing measured signals through the MDC and DDC to measurements made using the Fast Power Detector (which is calibrated at the factory and temperature controlled for stability). During the Calibrate Measurements calibration, the internal temperature of the test set is measured and stored with the calibration data. If the internal temperature of the test set drifts by more than +/- 10 C since the last calibration, measurements utilizing this calibration will return integrity indicator 19 ( Uncalibrated Due to Temperature ).

The Channel Power calibration provides calibration data for the following measurements:

  • Access Probe Power
  • Channel Power
  • Code Channel Time/Phase Error
  • Fast Device Tune ( lab application or feature-licensed test application only )
  • Gated Power
  • Graphical Access Probe Power ( lab application only )
  • Handoff Waveform Quality
  • Maximum/Minimum Power
  • Time Response of Open Loop Power Control
  • TX Dynamic Power
  • TX Spurious Emissions
  • Waveform Quality + Code Domain
  • Spectrum Monitor

Performing the Channel Power calibration executes the same routine as performing the Spectrum Monitor Calibration from a cdma2000/IS-95/AMPS or 1xEV-DO application/format.

To initiate the Channel Power calibration from the front panel, initiate any of the measurements listed above and select Calibrate Channel Power (F4) . To initiate the Channel Power calibration from a remote program, use the CALibration:CPOWer? query.

The Channel Power calibration takes approximately 2 minutes to execute.

Calibrate Measurements

The Calibrate Measurements routine is only applicable to W-CDMA/HSPA applications/formats.

The Calibrate Measurements routine should be run monthly, or whenever the test set's operating environment changes. See Recommended Calibration Intervals .

The Calibrate Measurements routine calibrates the signal paths through the Measurement Downconverter and Demod Downconverter using both a CW signal and a modulated signal. The calibration is performed by comparing measured signals through the MDC and DDC to measurements made using the Fast Power Detector (for CW signals) and the Thermal Power Detector (for modulated signals). Both of these detectors are calibrated at the factory and temperature controlled for stability. During the Calibrate Measurements calibration, the internal temperature of the test set is measured and stored with the calibration data. If the internal temperature of the test set drifts by more than +/- 10 C since the last calibration, measurements utilizing this calibration will return integrity indicator 19 ( Uncalibrated Due to Temperature ).

The Calibrate Measurements routine provides calibration data for the following measurements:

  • Adjacent Channel Leakage Ratio
  • Channel Power
  • Change of TFC ( lab application only )
  • Code Domain
  • Dynamic Power Analysis
  • Extended Range Dynamic Power
  • Fast Device Tune ( lab application or feature-licensed test application only )
  • Inner Loop Power
  • IQ Tuning
  • Occupied Bandwidth
  • Phase Discontinuity
  • PRACH Preamble Analysis ( lab application only )
  • PRACH Transmit On/Off Power
  • Spectrum Emission Mask
  • Spectrum Monitor
  • TX Dynamic Power
  • Waveform Quality

Performing the Calibrate Measurements routine executes the same routine as performing the Spectrum Monitor Calibration from a W-CDMA/HSPA application/format.

To initiate the Calibrate Measurements routine from the front panel, initiate any of the measurements listed above and select Calibrate Measurements (F4) . To initiate the Calibrate Measurements routine from a remote program, use the CALibration:MEASurements? query.

The Calibrate Measurements routine takes approximately 3 minutes to execute.

Related Topics

CALibration Subsystem


Decoded Audio Measurement Description

Decoded Audio Measurement Description

This measurement is not applicable to GPRS or EGPRS.

How is a decoded audio (DAUDIO) measurement made?

This measurement is also known as decoded audio or uplink speech level measurement. The DAUDIO measurement tests the ability of the mobile station to encode an audio signal onto the uplink traffic channel.

  1. The audio signal originates from the test set's AUDIO OUT connector. The audio signal is connected to the mobile station by means of an audio frequency input connector, or acoustically through a speaker placed near the microphone of the mobile station. See AFGenerator for set up commands for the test set's audio generator.
  2. The mobile station digitizes and encodes the audio signal that is transmitted on the uplink TCH.
  3. The uplink TCH is decoded with a bit accurate GSM RPE-LTP decoder to yield a block of 13-bit PCM samples within the DSP. As described in ETSI GSM 06.10.

The MS needs to be stimulated with a pulsed audio signal during a DAUDIO measurement. The audio signal must be pulsed at a 10 Hz rate with 50% duty cycle. See AFGenerator:PULSe[:STATe] .

The decoded audio measurement returns the rms value, in percent of full scale, of the speech signal present on the uplink (encoded) audio signal over a 100 ms (10 Hz) period of time.

The DAUDIO measurement performs an rms level measurement of a speech signal on the uplink TCH with optional bandpass filtering. Speech data can be filtered using a tunable 100 Hz bandpass filter prior to analysis. The center frequency of the 100 Hz bandpass filter may be tuned from 200 Hz to 3.6 kHz. Setting the frequency will activate the filter.

The trigger source for a DAUDIO measurement is always set to Immediate.

The DAUDIO measurement, BER and Fast BER measurements are mutually exclusive. Whichever of these measurements is activated last forces the other to become inactive.

Single or Multi-Measurements

The DAUDIO measurement can return single or averaged measurements defined by the multi-measurement count. A single measurement (multi-measurement count off) returns an estimate of the rms value of the decoded speech signal after removal of any dc component. The measurement units are in percent of full scale (%FS), ranging from 0 to 100%. Values greater than 70.70% may only result from non-sinusoidal signals. Multiple measurements (multi-measurement count >1) provide average, minimum, maximum, and standard deviation results. An integrity indicator is returned for both multi-measurement states. None of the results are affected by amplitude offset.

Trigger Source

DAUDIO measurement does not support any trigger source other than immediate.

Related Topics

Programming a Decoded Audio Measurement


Distortion Measurement Description

Distortion Measurement Description

This measurement is not applicable to GPRS.

How is a Distortion measurement made?

Distortion is an audio quality measurement that compares the audio signal level from the mobile at a specified (desired) frequency to the level of signals present at other frequencies. The audio signals from the mobile are typically measured after digital demodulation of the traffic channel.

The test set makes two measurements to determine distortion. First, the test set measures the total audio signal level. Next, a precise notch filter is then used to remove the signal at the specified frequency. The remaining signal level indicates the level of unwanted signals (distortion). Distortion is expressed as a percentage of the total audio signal.

Distortion can be measured in the range of 100 Hz to 10 kHz.

The distortion measurement can be used to perform the audio harmonic distortion test. For example in an analog system like AMPS, two audio signals are used: a 1004 Hz tone and the 6000 Hz Supervisory Audio Tone (SAT). The 1004 Hz tone is notched out to make the measurement.

Related Topics

Analog Audio Measurement Description


Dynamic Power Measurement Description

Dynamic Power Measurement Description

The Dynamic Power measurement is similar the EDGE Dynamic Power (EDP) Measurement . The difference being that the Dynamic Power measurement is limited to GMSK bursts in GSM and GPRS test modes, whereas the EDP measurement can measure GMSK bursts in GSM and GPRS test modes, as well as GMSK and 8PSK bursts EGPRS test mode.

How is a Dynamic Power Measurement Made?

The Dynamic Power measurement performs a series of consecutive power measurements on a mobile station returning a power measurement and an integrity value for each burst measured. Dynamic Power is only available via the test set's remote user interface.

NOTE
When using the Dynamic Power measurement with an EGPRS mobile, you must select a modulation coding scheme which uses GMSK modulation (MCS1 through MCS4). The Dynamic Power measurement does not support 8PSK modulation coding schemes (MCS5 through MCS9).

Dynamic Power is not an ETSI specified measurement.

The signal is measured at the RF IN/OUT port.

Single or Multi-Measurements

The Dynamic Power measurement does not use the multi-measurement state parameter, and so does not return minimum, maximum, and standard deviation values. Instead, you specify the number of bursts that you want to measure using the Number of Bursts parameter (see SETup:DPOWer:COUNt:NUMBer[:SELected] ). A single measurement returns the integrity indicator and power level for every burst measured. For example, if you set the number of bursts to 15, the returned comma-separated list contains 15 integrity values followed by 15 corresponding measurement values.

Types of Signals Dynamic Power can Measure

Dynamic Power measurements can be made on these types of input signals:

  • Normal TCH or PDTCH burst with mobile station in active cell mode.
  • Normal TCH or PDTCH burst with mobile station in test mode (no protocol).

Input Signal Requirements

The Dynamic Power measurement will complete and meet its measurement accuracy specifications when the signal meets the following input signal conditions.

  • Input signal level is between -20 dBm and +43 dBm.
  • Input signal level is within +3 dB and -3 dB of the expected input level. For all subsequent burst the input signal level is within 0 to -6 dB plus the Expected Maximum Difference of the previous burst.
  • Input signal is within 100 kHz of the measurement frequency.
  • The measurement frequency is within the currently selected band.

Trigger Source

The only trigger source that the Dynamic Power measurement supports is RF Rise.

Related Topics

Programming a Dynamic Power Measurement

SETup:DPOWer

FETCh:DPOWer

Test Adherence to Standards

EDGE Dynamic Power (EDP) Measurement


Modulation Accuracy Measurement Description

Modulation Accuracy Measurement Description

This measurement is only applicable to EGPRS.

How is a Modulation Accuracy (EMAC) measurement made?

Modulation accuracy is a measure of how much a real 8PSK modulated signal differs from an ideal 8PSK signal carrying the same information.This measurement is used to measure the modulation accuracy of an 8PSK modulated signal in a single timeslot. For multiple uplink multislot configurations, bursts are measured from a single timeslot that you specify.

The measurement assumes that the specified burst in the multislot configuration is 8PSK modulated, but it is tolerant of occasional GMSK bursts present in the signal. In real mobile calls, GMSK bursts carrying control information occur during an 8PSK data transmission. If the specified burst is found to be GMSK modulated, it is discarded and the measurement is re-armed. This will result in an apparent increase in measurement time.

This measurement is made on normal bursts only. Access bursts are not supported as they never use 8PSK modulation.

You can measure one of the six adjacent uplink bursts of the multislot configuration at any one time. You can specify the burst to measure using CALL:(PDTCH|PDTChannel):MSLot:MEASurement:BURSt . The relative power level is within 30dB according the data sheet.

The most important measurements returned are Error Vector Magnitude (Peak and RMS), Frequency Error, Origin Offset Suppression, and 95th Percentile EVM.

Operating Considerations

As the uplink burst number increases, the measurement speed is expected to decrease.

The measurement must know the training sequence code (TSC) to be able to synchronize to the burst's midamble. In an active cell mode, this information is received from the protocol processor. When using a test mode, you must manually specify the TSC using the CALL:BURSt:TYPE command (see CALL:BURSt:TYPE[:SELected] for more information) or from the front panel by accessing the Receiver Control screen and selecting the Expected Burst parameter.

The modulation accuracy measurement does not trigger unless an uplink burst using 8PSK modulation is present. You can control the modulation and coding scheme (either 8PSK or GMSK modulation) used by the data connection to be measured using CALL:(PDTCH|PDTChannel):MCSCheme . Additionally, you can manually control what modulation should be expected for individual bursts using CALL:MODulation[:FORMat]:CONTrol:AUTO . See Modulation Format Control (EGPRS only) for more information. If the test set is not configured properly, the measurement returns an "Unsupported Configuration" integrity indicator.The affected test set configuration parameters are:

  • Operating Mode - The modulation accuracy measurement is only valid for the Active Cell operating mode and EGPRS BCH+PDTCH test mode.
  • Serving Cell must be set to EGPRS. This can be done in one step from the front panel using the Active Cell (EGPRS) operating mode.
  • Modulation and Coding Scheme must be set to use an 8PSK MCS (MCS-5 through MCS-9) for the measurement to return results. The modulation accuracy measurement is only valid for 8PSK modulation.
  • Connection Type - This measurement is valid for all connection types except BLER. In a BLER connection, the mobile station sends PACCH control channels on the uplink. Since control channels only use GMSK modulation, this connection type cannot be used to perform modulation accuracy measurements.

Related Topics

How do I make Modulation Accuracy Measurements?

Programming a Modulation Accuracy Measurement

Modulation Accuracy Troubleshooting

Test Adherence to Standards

SETup:EMACcuracy

FETCh:EMACcuracy


Fast Bit Error Measurement Description

Fast Bit Error Measurement Description

This measurement is not applicable to GPRS or EGPRS.

Bit Error Measurements vs. Fast Bit Error Measurements

There are three commonly used types of bit error measurements in GSM:

  • ``BER with Frame Erasure" or ``Residual BER" when the mobile station has been configured to loopback Type A.
  • ``BER without Frame Erasure" or ``Non-residual BER" when the mobile station has been configured to loopback Type B.
  • BER using burst-by-burst loopback when the mobile station has been configured to loopback Type C.

The test set allows you to select between Loopback Type A or B, and the Fast Bit Error Measurement, which uses Loopback Type C. Refer also to Bit Error Measurement .

NOTE
If the test set has codeware version A.02.00 or above, unnecessary loopback commands and delays can be eliminated by taking advantage of enhancements available.

Previous versions of the test set required you to set the loopback type, and did not have a feature that allowed time for the loop to close.

How is a fast bit error (FBER) measurement made?

During FBER measurements, the test set generates a downlink TCH with (Pseudo Random Binary Sequence) PRBS-15 data at a known low level. The mobile station receives the data, loops it back to its transmitter, and returns the data to the test set. The test set compares data sent to data received, and FBER is calculated. see CALL:TCHannel

SETup subsystem commands are sent to the test set to specify close loop delay, signal loopback control, the number of bits to test, TDMA frames delay, measurement unit, trigger arm, and measurement timeout values.

When a call is established on the TCH, the loopback type is sent to the mobile station if the signal loopback control is on, see SETup:FBERror:SLControl[:STATe] . If you set signal loopback control to off, the loopback type is controlled using CALL:TCHannel:LOOPback .

FBER measurements use mobile station burst-by-burst loopback, referred to as loopback type C. In loopback type C the comparison is made between the 114 bits of data sent from the test set to the mobile station, then looped back and received by the test set.

The loop must be closed before a FBER test can start, using the close loop signaling delay time feature allows time for the loop to close. See SETup:FBERror:CLSDelay[:STIMe] for more details.

Each mobile station may have a different delay between receiving a TDMA frame and re-sending it on the uplink. By default, the test set is configured to LDControl:AUTO:ON, and the amount of delay needed is determined automatically when the test set has, for two frames, correctly received 80% of the downlink bits back on the uplink. The test set can be queried for the TDMA frames delay value.

If necessary, you can manually set the delay. See SETup:FBERror:LDControl:AUTO or SETup:FBERror:MANual:DELay

In case the test set is not able to correlate the data it transmits on the downlink with the data it receives on the uplink, a Measurement Timeout value should be set. If a timeout is not set and the test set is unable to correlate, the measurement will appear to "hang".

The FBER, BERR and the DAUDIO (uplink speech level) measurements are mutually exclusive, that is which ever of these measurements is activated last forces the other to become inactive. see Decoded Audio Measurement Description

FBER measurement trigger source is always set to immediate. The FBER measurement does not offer multi-measurement results. see Statistical Measurement Results

FBER measurement results

These the measurement results available from an FBER measurement.

The results of a FBER measurement can be displayed in two ways, (number of errors counted) or (the ratio bad bits (errors) to total bits counted). If you are using the test set remotely these results are available by using the FETCh command, see FETCh:FBERror:COUNt? or FETCh:FBERror:RATio? . If you are using the test set manually select either Count or % from the Measurement Units field.

Manual user interface results:

  • Fast BER Ratio (bad bits to total bits tested)
  • Fast BER Count (bad bits found during a measurement)
  • TDMA frame Delay (if TDMA Frame Loopback Delay Control = Manual)
  • RX Level
  • RX Quality

Remote user interface results:

  • Fast BER Ratio (bad bits to total bits tested)
  • Fast BER Count (bad bits found during a measurement)
  • TDMA Frame Delay (if TDMA Frame Loopback Delay Control = Manual)
  • Integrity Indicator
  • Intermediate Count

Related Topics

Programming a Fast Bit Error Measurement

Test Adherence to Standards

Bit Error Measurement

Programming a Bit Error Measurement

CALL:TCHannel:LOOPback


Frequency Stability Measurement Description

Frequency Stability Measurement Description

Description

How is a Frequency Stability measurement made?

The Frequency Stability measurement displays the frequency of an RF signal applied to the test set's front panel RF IN/OUT input port. After each measurement the input signal's absolute RF freqency is displayed with 1000 Hz resolution on the test set's front panel and 1 Hz resolution when queried over the GPIB.

The absolute RF signal frequency obtained during each Frequency Stability measurement is compared to the expected (measurement downconverter) frequency of the test set's measuring receiver. The difference between the expected frequency and the measured frequency is displayed as frequency error with 1 Hz resolution.

Frequency Stability Measurement

If the device under test is a mobile station on a call, the expected frequency can be automatically set by the base station emulator (using the RF Channel setting).

If the device under test is not on a call, the expected frequency must be set by manually controlling the receiver (manual measurement frequency).

Operating Considerations

Front Panel Access

Frequency Stability measurements are accessed manually by pressing the front-panel Measurement selection key.

NOTE
In some test set applications it is necessary to select an analog System Type (for example, AMPS) or an analog Operating Mode (for example, AVC Test or CW) to access the Frequency Stability measurement.

Input Signal Requirements

The Frequency Stability measurement is designed to measure non-bursted analog signals. For example, this measurement can be made on an AMPS cellular mobile station while it is on an active AVC (analog voice channel) with or without SAT or other frequency modulation. It is not desiged to measure AM (amplitude modulated) signals.

When a mobile station is on a call, the test set has the ability to predict the power level and frequency that is present on the RF input and automatically adjust attenuator and measurement downconverter settings. However, for test operating modes or CW (continuous wave) the test set is not functioning as a base station emulator. In the absence of call control, it is likely that the test set's receiver will need to be manually tuned to the input signal.

To meet Frequency Stability measurement performance specifications, the input signal must be:

  • Within the frequency interval 293 MHz to 2.7 GHz.
  • Within 200 kHz of the expected frequency.
  • Greater than -30 dBm.
  • Within 3 dB of the expected power.
  • Within an FM index of three (if FM is applied).
  • Within 100 Hz and 15 kHz modulating frequency (if FM is applied).

Multi-measurement Use

When multi-measurement count is turned on during a Frequency Stability measurement, the test set returns statistical data acquired over a number of measurements, including the worst case frequency error, in ppm (parts per million).

Frequency Stability Measurement With Multi-measurements

Related Topics

Programming a Frequency Stability Measurement

Frequency Stability Measurement Troubleshooting

Statistical Measurement Results

Measurement Timeouts

Test Adherence to Standards


Fast Device Tune Capable Measurement

Fast Device Tune Capable Measurement

The measurements made on the Uplink Test Sequence (UTS) by the test set in Fast Device Tune operating mode are called Fast Device Tune capable measurements. The Transmit Power Measurement is currently the only Fast Device Tune capable Measurement.

  • How is a TXP measurement made in Fast Device Tune operating mode?
  • TXP Measurement Parameters in Fast Device Tune operating mode
  • TXP Measurement Results in Fast Device Tune operating mode
  • TXP Measurement Input Signal Requirements in Fast Device Tune operating mode

How is a TXP measurement made in Fast Device Tune operating mode?

In the Fast Device Tune operating mode, you can configure the mobile station to send up to 7 uplink bursts in one TDMA frame. The TXP measurement is able to simultaneously measure the 7 uplink bursts with a single capture on a TDMA frame.

The actual uplink bursts sent by the mobile station in one TDMA frame is specified using GFDTune:UPLink:TSEQuence:BURSt:COUNt . See Fast Device Tune .

For other informations about the TXP measurement, See How is a TXP measurement made?

Operating Considerations

In Fast Device Tune operating mode, you should not change any measurement related settings when the Fast Device Tune capable measurement is running.

The first burst in the TDMA frame should have the highest power level and should be higher than -14dBm.

In Fast Device Tune operating mode, the TXP measurement can not be concurrent with any other measurements.

TXP Measurement Parameters in Fast Device Tune operating mode

All the previous Transmit Power measurement parameters are available in Fast Device Tune operating mode. Additionally three new parameters: Arm State, Fast Device Tune Result Set and Uplink Frames per Step are newly added in order to fulfill the requirement in Fast Device Tune operating mode.

  • Arm State

    This parameter is only applicable in Fast Device Tune operating mode. The parameter indicates whether the hardware of the test set has been armed to accept input RF signal.

    The GPIB command to query this parameter is INITiate:TXPower:GFDTune:ARMed? .

  • Auto Range to Highest Burst

    See Auto Range to Highest Burst in Transmit Power Measurement Description .

    Note, in Fast Device Tune operating mode, the highest input burst is the first input burst. You only need to set the expected power for the first burst. see Expected Power Control for information on how to set the expected power.

  • Expected Power Control

    To make accurate measurements, the test set needs to know how much power to expect at the test set's RF IN/OUT port, which is referred to as the expected power. In Fast Device Tune operating mode, the Expected Power Control must be set to Manual . You can specify the expected power for up to 7 uplink bursts; each burst is set individually.

    To set the test set receiver's expected power setting to manual use RFANalyzer:CONTrol:POWer:AUTO .

    To set the power level that the test set's receiver is expecting the mobile station uplink burst to transmit at, use RFANalyzer:MANual:POWer:BURSt<[1]|2|3|4|5|6|7> .

    See Receiver Control for more information.

  • Fast Device Tune Trigger Threshold

    This parameter is only applicable in Fast Device Tune operating mode. This parameter defines the threshold for the first RF trigger. The threshold is an offset value below the highest expected power.

    The GPIB command to set this parameter is SETup:TXPower:GFDTune:THReshold . The parameter can only be set using GPIB command.

  • Fast Device Tune Result Set

    This parameter is only applicable in Fast Device Tune operating mode. This parameter defines the results of which uplink sequence step are returned with any FETCh command that is not assigned an step parameter. This parameter is only applicable when the operating mode is set to GFDTune.

    The GPIB command to set this parameter is SETup:TXPower:GFDTune:RSET . The parameter can be set using GPIB command only.

  • Measurement Burst

    In Fast Device Tune operating mode, This parameter indicates the measurement results of which burst is returned if the optional parameter in an FETCh command is omitted.

    The GPIB command to set this parameter is CALL:(PDTCH|PDTChannel):MSLot:MEASurement:BURSt .

  • Measurement Timeout

    Ensure that you set the Measurement Timeout to a value great enough to either allow the test set to output the entire UTS, or to a value great enough to both allow you to command the mobile station to transmit the UTS and allow the mobile station enough time to completely transmit the UTS. See Measurement Timeouts for more information.

  • Measurement Frequency

    In Fast Device Tune operating mode, you must specify the Measurement Frequency manually. You can specify the Measurement Frequency for the whole uplink test sequence using GFDTune:UPLink:TSEQuence:FREQuency , or specify the Measurement Frequency for a specified uplink test step, using GFDTune:UPLink:SSTep:FREQuency

  • Multi-Measurement Count

    In Fast Device Tune operating mode, Multi-Measurement count specifies how many loops are measured on every sequence step before the measurement moves to the next sequence step. See Multi-measurement Count in Transmit Power Measurement Description for more information.

    To set Multi-Measurement state and count separately, use SETup:TXPower:COUNt:STATe to set the Multi-Measurement state, SETup:TXPower:COUNt:NUMBer to set the Multi-Measurement count; use SETup:TXPower:COUNt[:SNUMber] to set the state and count simultaneously.

  • Trigger Arm

    In Fast Device Tune operating mode, the trigger arm is set to Single and can not be changed, Continuous trigger arm is not supported. see Trigger Arm (Single or Continuous) Description for more information.

    The GPIB command to set this parameter is SETup:TXPower:CONTinuous .

  • Trigger Delay

    See Trigger Delay in Transmit Power Measurement Description .

  • Trigger Qualification

    In Fast Device Tune operating mode, the trigger qualification is set to OFF and can not be changed.

  • Trigger Source

    In Fast Device Tune operating mode, the trigger source is set to protocol and can not be changed, a fixed triggering arrangement is used, RF Rise trigger is used to capture the first Uplink Sequence Step from the mobile station and GSM frame timing is used for the subsequent Uplink Sequence Steps. Trigger Source retrieve its original setting when leaving Fast Device Tune operating mode.

    The GPIB command to set this parameter is SETup:TXPower:TRIGger:SOURce .

  • Uplink Frames per Step

    This parameter is only applicable in Fast Device Tune operating mode, The parameter indicates how many TDMA frames will be transmitted by the mobile station for a Uplink Sequence Step.

    The GPIB command to query this parameter is SETup:TXPower:SSTep:FRAMes? . The query result is determined by the test set according to actual configuration. The mobile station then generates the number of TDMA frames according to the query result to complete the measurement for one step and move to the next sequence step.

TXP Measurement Results in Fast Device Tune operating mode

In Fast Device Tune operating mode, The results returned by the TXP measurement are Burst Power and Integrity Indicator, Additionally, average, maximum, minimum and standard deviation of Burst Power are returned when the Multi-Measurement state is On .

Note that in the Fast Device Tune operating mode, the Estimated Carrier Power measurement is not supported, the Estimated Carrier Power is the same as Burst Power in the measurement result returned.

You can query the measurement result in Fast Device Tune operating mode by the following ways:

  • Power results for all steps of a single burst using FETCh:TXPower:TSEQuence commands:

    The query returns measurement results of a specified burst for all uplink sequence steps in the following order: <Result for Step 1>, <Result for Step 2>,..., <Result for Step 50>. The commands contain an optional parameter that defines which burst in the TDMA frame is queried. If the optional parameter is omitted, then the results of the burst specified by Measurement Burst are returned.

  • Power results for all bursts of a single Uplink Sequence Step (USS) using FETCh:TXPower:SSTep:BPOWer:FRAMe or FETCh:TXPower:SSTep:CPOWer:FRAMe commands:

    The query returns measurement results of all bursts for a specified uplink sequence step. The commands contain a mandatory parameter that defines which step is queried. The commands return the measurement results in the following order: <Result for Burst 1>, <Result for Burst 2>, <Result for Burst 3>, <Result for Burst 4>, <Result for Burst 5>, <Result for Burst 6>, <Result for Burst 7>, <Result for Burst 8>. only the results for the burst within the uplink burst numbers are valid. The Result of Burst 8 is always invalid.

    NOTE
    In Fast Device Tune operating mode, if the GPIB commands other than FETCh:TXPower:TSEQuence and FETCh:TXP:SSTep are used to query the measurement results, then only the results for the uplink sequence step specified by Fast Device Tune Result Set are returned for each query. See TXP Measurement Results in Transmit Power Measurement Description for more information.

  • Power results for one burst of a single USS using other FETCh:TXPower:SSTep commands:

    The query returns measurement results of one burst for a specified uplink sequence step. The commands contain a mandatory parameter that defines which step is queried and a optional parameter that defines which burst in the TDMA frame is queried. If the optional parameter is omitted, then the results of the burst specified by Measurement Burst are returned.

TXP Measurement Input Signal Requirements in Fast Device Tune operating mode

The TXP measurement requires the following signal attributes:

  • Level of the first input burst is between -14dBm and +37dBm, level of the other bursts are between -25dBm and +37dBm.
  • When the Auto Range to Highest Burst parameter is set to Off :
    • The level of the highest input burst (or the first burst) is within +/-3 dB of the Highest Expected Power.
    • The level of all the other input bursts are within +3dB/-30dB of the Highest Expected Power.
  • when the Auto Range to Highest Burst parameter is set to On :
    • The level of the highest input burst (or the first burst) is within +3dB/-30dB dB of the Highest Expected Power.
    • The level of the all other input bursts are within +3dB/-30dB of the Highest Expected Power.

Related Topics

Fast Device Tune

Programming in Fast Device Tune Operating Mode

INITiate

GFDTune:UPLink

GFDTune:DOWNlink

SETup:TXPower

FETCh:TXPower

Receiver Control


Fast Device Tune

Fast Device Tune

This measurement is applicable to the lab applications and a feature-licensed test application.

  • Fast Device Tune Description
  • Configurable Fast Device Tune Parameters
    • DTS Parameters
    • UTS Parameters
  • How to configure the Fast Device Tune Calibration?
    • Receiver Calibration
    • Transmitter Calibration

Fast Device Tune Description

Mobile phone calibration during manufacturing typically involves making a set of transmitter and receiver measurements at a number of different frequencies and power levels.

Traditionally making such measurements has entailed stepping through a number of test points (each point consisting of a specific frequency and power level), configuring the mobile station and the test set, making the measurement and then returning the result. This traditional method has a high overhead in the time taken to do the configuration and return the results.

Fast Device Tune is a Fast Calibration solution that allows the customer to perform rapid calibration of mobile phones during manufacturing test. Fast Device Tune encompasses independent Downlink and Uplink Test Sequences which can be used separately or in combination to calibrate a mobile phone's receiver and transmitter respectively.

Downlink Test Sequence (DTS)

A DTS is comprised of a series of Downlink Sequence Steps (DSS) where each sequence step corresponds to one or more identical downlink TDMA frames. A DSS is defined using the following parameters on a per sequence step basis: the frequency at which a DSS is transmitted, the number of active bursts in a TDMA frame, the power level and type of each burst and the number of TDMA frames in a DSS. See DTS Parameters for more information.

Uplink Test Sequence (UTS)

An UTS is comprised of one or more Uplink Sequence Steps (USS) where each sequence step corresponds to one or more uplink TDMA frames. The test set need to know the frequency at which the USS is transmitted, the number of active bursts in a TDMA frame and the state of each burst (On or OFF) before making a measurement on UTS. See UTS Parameters for more information.

The number of TDMA frames in an USS is determined by the measurement settings in the test set. The number of TDMA frames in all the USSs are the same. The mobile should query the number of TDMA frames in an USS before transmitting a UTS.

Actually there is no new measurement introduced for the fast transmitter calibration but only leverage the existing measurement. The measurement that can be performed in the Fast Device Tune mode is called Fast Device Tune capable measurement. The transmit power measurement is currently the only Fast Device Tune capable Measurement. See Fast Device Tune Capable Measurement for more information.

See UTS Parameters for more information.

Configurable Fast Device Tune Parameters

The operating mode must be set to Fast Device Tune before configuring the DTS and UTS parameters. Most of the Fast Device Tune parameters are configured via GPIB only. However, you can Start/Stop DTS and select single/continuous operation of DTS from the front panel.

DTS Parameters

DTS parameters are used to define the DSSs and the transmission behavior of a DTS.

  • DTS Continuous

    This parameter determines whether the test set outputs the DTS continuously or only one time (single mode).

    The GPIB command to set/query this parameter is GFDTune:DOWNlink:TSEQuence:CONTinuous .

  • DTS Step Count

    This parameter sets the number of DSSs in a DTS. The count does not include the number of times a DSS repeats (to set the repeat count, see Repeat Count ).

    The GPIB command to set/query this parameter is GFDTune:DOWNlink:TSEQuence:SSTep[:COUNt] .

  • DTS Start

    This parameter initiates the DTS. If the DTS Continuous is configured for continuous operation the test set continuously outputs the DTS until it is stopped (see DTS Stop ), otherwise the test set outputs the DTS one time. The test set applies any changes of the DTS parameters before it outputs the DTS.

    The GPIB command to start the DTS is GFDTune:DOWNlink:TSEQuence:STARt .

  • DTS Stop

    This parameter stops the transmission of the DTS. This parameter is applied only if the test set is transmitting a DTS.

    The GPIB command to stop the DTS is GFDTune:DOWNlink:TSEQuence:STOP .

  • Burst Type (per timeslot)

    This parameter sets the burst type of the DSSs in a per timeslot manner.

    The available bust type settings are listed below.

    1. Off ( OFF ) - No burst transmitted.
    2. Frequency Correction Burst ( FCB ) - This is used by the mobile station for frequency synchronization. See 3GPP TS 45.002 version 7.4.0, subclause 5.2.4 for more information.
    3. Fixed Synchronization Burst ( FSB ) - This is used by the mobile station for time synchronization. The reduced frame number field is fixed to zero, the BCC and NCC fields use the normal Active Cell operating mode values. See 3GPP TS 45.002 version 7.4.0, subclause 5.2.5 for more information.
    4. Dynamic Synchronization Burst ( DSB ) -This is used by the mobile station for time synchronization. The reduced frame number field increments with each transmitted TDMA frame. If more than one DSB is specified in a TDMA frame, the TDMA frame number is the same for all DSBs. See 3GPP TS 45.002 version 7.4.0, subclause 5.2.5 for more information.
    5. Dummy ( DUMMY ) - This is used to pad timeslots on the BCH to ensure that the BCH has a constant power level. Note that the test set will measure a report results on these "dummy" bursts, and you must simply discard or ignore these data points. See 3GPP TS 45.002 version 7.4.0, subclause 5.2.6 for more information.
    6. GMSK PRBS ( PRBS ) - This is a GMSK burst containing a valid midamble and PRBS data.

    The GPIB command to set/query this parameter on a per DTS basis is GFDTune:DOWNlink:TSEQuence:BURSt:TYPE:TSLot<0|1|2|3|4|5> .

    The GPIB command to set/query this parameter for a specified range of DSSs is GFDTune:DOWNlink:SSTep:BURSt:TYPE:TSLot<0|1|2|3|4|5> .

  • Configure the Power Level for a DTS

    The DTS can not output more than four different power levels due to hardware limitation. The four available power levels are referred to as PL1 to PL4. You can set the power level of PL1 to PL4 with the DTS Power Level parameter.

    Each DSS can be configured to allocate the available power levels across a TDMA frame in two ways - either use the same power level (PL1 to PL4) for all timeslots in the frame or MIXED where each timeslot is allocated a power level that is fixed for the duration of the test sequence. This is done by setting the Frame Power Level Allocation parameter.

  • DTS Power Level

    This parameter specifies the power levels that can be used in the DSSs of a DTS. The test set can generate four different power levels, (PL1, PL2, PL3, and PL4), in a DTS. The power levels of the active bursts in the DSSs can vary between these four power level settings. Each power level setting must be in the range of -160 dBm to +40 dBm.

    The command to set/query this parameter is GFDTune:DOWNlink:TSEQuence:PLEVel<1|2|3|4> .

  • Frame Power Level Allocation

    This parameter specifies the method used to allocate the available power levels across a TDMA frame. The two methods are:

    • PLX(PL1, PL2, PL3, PL4) - all timeslots in the frame are fixed to Power Level X (PL1, PL2, PL3, PL4). This mode allows for additional flexibility in defining sequence steps that output synchronization pulses used for synchronizing a receiver test.
    • MIXed - the timeslots can be set to any of the four specified Power Levels ( PL1, PL2, PL3 , or PL4 ).

    The command to set/query this parameter on a per DTS basis is GFDTune:DOWNlink:TSEQuence:PLEVel:FRAMe .

    The GPIB command to set/query this parameter for a specified range of DSSs is GFDTune:DOWNlink:SSTep:PLEVel:FRAMe .

  • Power Levels per Timeslot

    This parameter specifies the power level for timeslot<n> for all the DSSs. These settings are only applied if the Frame Power Level Allocation is set to MIXed .

    The GPIB command to set/query this parameter is GFDTune:DOWNlink:TSEQuence:PLEVel:TSLot<0|1|2|3|4|5> .

    The following table gives an example of DTS power level allocation.

    Step

    Power Level Allocation

    TS0

    TS1

    TS2

    TS3

    TS4

    TS5

    TS6

    TS7

    1

    PL1

    PL1

    PL1

    PL1

    PL1

    PL1

    PL1

    2

    MIXED

    PL1

    PL2

    PL3

    PL4

    PL3

    PL2

    3

    MIXED

    PL1

    4

    MIXED

    PL1

    PL2

    5

    MIXED

    PL1

    PL2

    PL3

    6

    MIXED

    PL1

    PL2

    PL3

    PL4

    7

    PL3

    PL3

    PL3

    PL3

    PL3

    8

    MIXED

    PL1

    PL2

    PL3

    PL4

    PL3

    9

    MIXED

    PL1

    PL2

    PL3

    PL4

    PL3

    PL2

    10

    MIXED

    PL1

    PL2

    PL3

    PL4

    PL3

    PL2

    The programming for the above power level allocation is:

    "*** Set DTS power level Allocation ***"
    OUTPUT Testset;"GFDT:DOWN:TSEQ:PLEV:FRAM PL1,MIX,MIX,MIX,MIX,MIX,PL3,MIX,MIX,MIX"
    "*** Set DTS power level ***"
    OUTPUT Testset;"GFDT:DOWN:TSEQ:PLEV1 -50"
    OUTPUT Testset;"GFDT:DOWN:TSEQ:PLEV2 -60"
    OUTPUT Testset;"GFDT:DOWN:TSEQ:PLEV3 -70"
    OUTPUT Testset;"GFDT:DOWN:TSEQ:PLEV4 -80"
    "*** Set DTS Power Levels for TS1 through TS5 ***"
    OUTPUT Testset;"GFDT:DOWN:TSEQ:PLEV:TSL0 PL1"
    OUTPUT Testset;"GFDT:DOWN:TSEQ:PLEV:TSL1 PL2"
    OUTPUT Testset;"GFDT:DOWN:TSEQ:PLEV:TSL2 PL3"
    OUTPUT Testset;"GFDT:DOWN:TSEQ:PLEV:TSL3 PL4"
    OUTPUT Testset;"GFDT:DOWN:TSEQ:PLEV:TSL4 PL3"
    OUTPUT Testset;"GFDT:DOWN:TSEQ:PLEV:TSL5 PL2"

  • DTS Frequency

    This parameter sets the frequency of the DSSs in a DTS. The frequency settings in a DTS must be in the same band. The frequency bands are divided as follows:

    Downlink Frequency Bands
    Downlink Frequency Band | Frequency Range (MHz) | GSM Band Coverage
    Band 1 | 400 to 630 | GSM450, GSM480
    Band 2 | 630 to 1000 | GSM750, GSM850, GSM900, TGSM810
    Band 3 | 1550 to 2400 | DCS1800, PCS1900

    The GPIB command to set/query this parameter on a per DTS basis is GFDTune:DOWNlink:TSEQuence:FREQuency .

    The GPIB command to set/query this parameter for a specified range of DSSs is GFDTune:DOWNlink:SSTep:FREQuency .

  • Repeat Count

    This parameter specifies the number of times a specific DSS is repeated in the DTS before proceeding to the next DSS.

    The GPIB command to set/query this parameter on a per DTS basis is GFDTune:DOWNlink:TSEQuence:REPeat .

    The GPIB command to set/query this parameter for a specified range of DSSs is GFDTune:DOWNlink:SSTep:REPeat .

  • Trigger Frame

    This parameter sets the frame of each DTS Step in a DTS in which the DTS will generate a trigger output. This parameter only applies to a DSS if the Trigger State is enabled for that DSS. Also, this setting must be less than or equal to the corresponding Repeat Count value in order for the trigger event to occur. This setting, along with the Trigger Timeslot setting determines the time at which the trigger event occurs for a particular DSS.

    The command to set/query this parameter on a per DTS basis is GFDTune:DOWNlink:TSEQuence:TRIGger:FRAMe .

    The GPIB command to set/query this parameter for a specified range of DSSs is GFDTune:DOWNlink:SSTep:TRIGger:FRAMe .

  • Trigger StateThis parameter set/query the state to the trigger for each DTS Step in a DTS. If this parameter is enabled for a particular DSS, the trigger event occurs at a time specified by the Trigger Frame and Trigger Timeslot .

    The command to set/query this parameter on a per DTS is GFDTune:DOWNlink:TSEQuence:TRIGger:STATe .

    The GPIB command to set/query this parameter for a specified range of DSSs is GFDTune:DOWNlink:SSTep:TRIGger:STATe .

  • Trigger Timeslot

    This parameter sets the timeslot in which the trigger event should occur for each DTS Step of a DTS. This parameter is only applied if the Trigger State is enabled for that DSS. This setting, along with the Trigger Frame setting determines the time at which the trigger event occurs for a particular DSS.

    The command to set/query this parameter on a per DTS is GFDTune:DOWNlink:TSEQuence:TRIGger:TSLot .

    The GPIB command to set/query this parameter for a specified range of DSSs is GFDTune:DOWNlink:SSTep:TRIGger:TSLot .

UTS Parameters

UTS parameters are used to define the USSs and the transmission behavior of a UTS.

  • UTS Step Count

    This parameter specifies the number of USSs that are in the UTS.

    The GPIB command to set this parameter is GFDTune:UPLink:TSEQuence:SSTep[:COUNt] .

  • UTS Burst Count

    This parameter specifies the number of active burst that are in each USS. (This number is the same for all USSs.) This setting is only applicable when the operating mode is Fast Device Tune . Also, the maximum number of uplinks depends on the number of uplinks supported by a particular measurement. If a measurement does not support the number of uplinks specified by this parameter, the test set returns integrity indicator 13.

    The GPIB command to set this parameter is GFDTune:UPLink:TSEQuence:BURSt:COUNt .

  • UTS Burst State

    This parameter specifies whether an uplink burst is transmitted in the uplink sequence step. You can get discontinuously uplink burst transmission by setting this parameter. When the state for an uplink burst is set to ON , the burst will be transmitted, otherwise it will not be transmitted. you can specifies the state of Burst 1 to 7 for each uplink sequence step. Note, the state of Burst 1 can only be set to ON .

    The GPIB command to set this parameter on a per UTS basis is GFDTune:UPLink:TSEQuence:BURSt1|2|3|4|5|6|7:STATe .

  • UTS Frequency

    This parameter sets the frequency of each USS. All frequency settings in an UTS must be in the same band. These frequency bands are divided as follows:

    Uplink Frequency Bands
    Uplink Frequency Band | Frequency Range (MHz) | GSM Band Coverage
    Band 1 | 292.5 to 645.5 | GSM450, GSM480
    Band 2 | 645.5 to 1395.5 | GSM750, GSM850, GSM900, TGSM810
    Band 3 | 1395.5 to 2700 | DCS1800, PCS1900

    The GPIB command to set this parameter on a per UTS basis is GFDTune:UPLink:TSEQuence:FREQuency .

    The GPIB command to set/query this parameter for a specified range of USSs is GFDTune:UPLink:SSTep:FREQuency .

How to configure the Fast Device Tune Calibration?

You can configure the transmitter and receiver calibration separately.

Receiver Calibration

The receiver calibration can be done by commanding the test set to transmit the DTS and let the mobile to measure on. The following constrains apply when configuring a DTS.

  • All the TDMA frames within a DSS must be at the same frequency. Further, all the DSSs in a DTS must be in the same frequency band. See DTS Frequency for information about frequency band.
  • The maximum number of DSSs in a DTS is 50.
  • The maximum number of active bursts allowed per downlink TDMA frame is 6.
  • The test set can not output more than four power levels in each DSS.
  • The repeat count for a DSS can not exceed 1000.

DTS Example: Five DSSs with a total of 15 TDMA Frames

The figure above shows an example DTS. In this example, the setting for the DSS Repeat Count outputs the first DSS 10 times before moving on to the next DSS. The 2nd, 3rd, and 4th DSSs are sent once, and the 5th DSS is sent twice. The total number of frames transmitted in the DTS is 15.

To configure the test set to transmit the above waveform, set the following:

  1. Set the operating mode to Fast Device Tune
    OUTPUT Testset;"CALL:OPER:MODE FDT"
  2. DTS Step Count = 5
    OUTPUT Testset;"GFDT:DOWN:TSEQ:SST 5"
  3. DTS Power Level Allocation = "PL1, MIXed, MIXed, MIXed, MIXed"
    OUTPUT Testset;"GFDT:DOWN:TSEQ:PLEV:FRAM PL1,MIX,MIX,MIX,MIX"
  4. DTS Power Levels (PLs) in dBm.
    DTS PL1 = -50
    DTS PL2 = -60
    DTS PL3 = -70
    DTS PL4 = -80
    OUTPUT Testset;"GFDT:DOWN:TSEQ:PLEV1 -50
    OUTPUT Testset;"GFDT:DOWN:TSEQ:PLEV2 -60
    OUTPUT Testset;"GFDT:DOWN:TSEQ:PLEV3 -70
    OUTPUT Testset;"GFDT:DOWN:TSEQ:PLEV4 -80
  5. DTS Power Levels for Timeslot 1 (TS1) through Timeslot 5 (TS5). (Note: The Power Levels for all the timeslots in DSS1 are fixed at PL1.)
    DTS Power Levels for TS0 = PL1
    DTS Power Levels for TS1 = PL2
    DTS Power Levels for TS2 = PL3
    DTS Power Levels for TS3 = PL4
    DTS Power Levels for TS4 = PL3
    DTS Power Levels for TS5 = PL2
    OUTPUT Testset;"GFDT:DOWN:TSEQ:PLEV:TSL0 PL1
    OUTPUT Testset;"GFDT:DOWN:TSEQ:PLEV:TSL1 PL2
    OUTPUT Testset;"GFDT:DOWN:TSEQ:PLEV:TSL2 PL3
    OUTPUT Testset;"GFDT:DOWN:TSEQ:PLEV:TSL3 PL4
    OUTPUT Testset;"GFDT:DOWN:TSEQ:PLEV:TSL4 PL3
    OUTPUT Testset;"GFDT:DOWN:TSEQ:PLEV:TSL5 PL2
  6. DTS Frequency (in MHz) for each step.
    DTS Frequency = "800MHz, 850MHz, 900MHz, 950MHz, 1000MHz"
    OUTPUT Testset;"GFDT:DOWN:TSEQ:FREQ 800Mhz,850MHz,900MHz,950MHz,1000MHz"
  7. DTS Repeat Count for each step.
    DTS Repeat Count = "10, 1, 1, 1, 2"
    OUTPUT Testset;"GFDT:DOWN:TSEQ:REP 10,1,1,1,2"
  8. DTS Burst Type for Timeslot 1 (TS1) through Timeslot 5 (TS5).
    DTS Burst Type for TS0 ="FCB, FSB, FSB, FSB, PRBS"
    DTS Burst Type for TS1 ="DUMMY, PRBS, PRBS, PRBS, PRBS"
    DTS Burst Type for TS2 ="DUMMY, PRBS, PRBS, PRBS, PRBS"
    DTS Burst Type for TS3 ="DUMMY, PRBS, PRBS, PRBS, PRBS"
    DTS Burst Type for TS4 ="DUMMY. OFF, OFF, OFF, PRBS"
    DTS Burst Type for TS5 ="DUMMY. OFF, OFF, OFF,PRBS"
    OUTPUT Testset;"GFDT:DOWN:TSEQ:BURS:TYPE:TSL0 FCB,FSB,FSB,FSB,PRBS"
    OUTPUT Testset;"GFDT:DOWN:TSEQ:BURS:TYPE:TSL1 DUMMY,PRBS,PRBS,PRBS,PRBS"
    OUTPUT Testset;"GFDT:DOWN:TSEQ:BURS:TYPE:TSL2 DUMMY,PRBS,PRBS,PRBS,PRBS"
    OUTPUT Testset;"GFDT:DOWN:TSEQ:BURS:TYPE:TSL3 DUMMY,PRBS,PRBS,PRBS,PRBS"
    OUTPUT Testset;"GFDT:DOWN:TSEQ:BURS:TYPE:TSL4 DUMMY,OFF,OFF,OFF,PRBS"
    OUTPUT Testset;"GFDT:DOWN:TSEQ:BURS:TYPE:TSL5 DUMMY,OFF,OFF,OFF,PRBS"
  9. Start the transmission of DTS is the mobile is ready.
    OUTPUT Testset;"GFDT:DOWN:TSEQ:STAR"
  10. Stop the transmission of DTS if needed when transmitting.
    OUTPUT Testset;"GFDT:DOWN:TSEQ:STOP"
The MUI screen displays the DTS configuration after sending the above GPIB commands. You can start/stop the DTS transmission by pressing the start/stop downlink button in the front panel instead.

Transmitter Calibration

The transmitter calibration can be done by commanding the mobile to transmit the UTS and let the test set to measure on. Currently, the transmit power measurement is the only measurement that can be made on UTS. Before making the transmitter calibration, you should set the UTS parameters and transmit power parameters. See Fast Device Tune Capable Measurement for information about how to set the transmit power parameters in Fast Device Tune operating mode.

The following constrains apply when configuring an UTS.

  • All the TDMA frames within a USS must be at the same frequency. Further, all the USSs in a UTS must be in the same frequency band. See UTS Frequency for information about frequency band.
  • The maximum number of USSs in an UTS is 50
  • The repeat count for a USS can not exceed 1000.

  • Before transmitting the UTS, the mobile station needs to make sure that the test set's hardware has been ready to receive the input RF signal. An Arm State is specified in each GFDT capable measurement for this purpose. You can query the Arm State of the test set using the query only GPIB command of each specific GFDT capable measurement.

  • The number of TDMA frames in a USS should be know by the mobile before transmitting the UTS. For this reason, all the Fast Device Tune capable measurements have a query only parameter called Uplink Frames per Step . The parameter reports the number of TDMA frames required in an USS. The value of this parameter depends on the measurement settings. In the transmit power measurement, the number of TDMA frames in an USS depends on the parameter Auto Range to Highest Burst and Multi-Measurement Count . See the following table for more details.

    Multi-Measurement State | Auto Range To Highest Burst | The number of TDMA frames in an USS
    OFF ON

    4
    OFF OFF

    2
    ON | ON | Multi-Meas Count × 2 + 2 *
    ON | OFF | Multi-Meas Count × 2 **

    * The mobile transmits 4 TDMA frames in the first USS, then transmits 2 TDMA frames in the following repeated USSs.
    ** The mobile transmits 2 TDMA frames in each repeated USS.

  • The maximum number of active bursts allowed per uplink TDMA frame in the transmit power measurement is 7.
  • For the transmit power measurement, the first burst in each TDMA frame must have the highest power and should be higher than -14dBm.

UTS Example: Five USSs with a total of 10 TDMA Frames

The figure above shows an example UTS.

To configure a GFDT capable measurement using the above waveform, set the following:

  1. Set the operating mode to Fast Device Tune
    OUTPUT Testset;"CALL:OPER:MODE FDT"
  2. UTS Step Count = 5
    OUTPUT Testset;"GFDT:UPL:TSEQ:SST 5"
  3. UTS Burst Count = 7
    OUTPUT Testset;"GFDT:UPL:TSEQ:BURS:COUN 7"
  4. Set Expected Power Control to Manual , set the expected power for the highest burst.
    OUTPUT Testset;"RFAN:MAN:POW:BURST1 30"
  5. Set Modulation Format Control to Manual , set the expected modulation format (GMSK or 8PSK) for each uplink burst individually.
    OUTPUT Testset;"CALL:MOD:MAN:BURST1 GMSK"
    OUTPUT Testset;"CALL:MOD:MAN:BURST2 GMSK"
    OUTPUT Testset;"CALL:MOD:MAN:BURST3 GMSK"
    OUTPUT Testset;"CALL:MOD:MAN:BURST4 GMSK"
    OUTPUT Testset;"CALL:MOD:MAN:BURST5 GMSK"
    OUTPUT Testset;"CALL:MOD:MAN:BURST6 GMSK"
    OUTPUT Testset;"CALL:MOD:MAN:BURST7 GMSK"
  6. UTS Frequency (in MHz) for each USS.
    UTS Frequency = "800MHz, 850MHz, 900MHz, 950MHz, 1000MHz"
    OUTPUT Testset;"GFDT:UPL:TSEQ:FREQ 800MHz,850MHz,900MHz,950MHz,1000MHz"
  7. Configure the Fast Device Tune capable measurement as you need.
    OUTPUT Testset;"SET:TXP:COUN:STAT OFF" !Sets the multi measurement to OFF
    OUTPUT Testset;"SET:TXP:RANG:AUTO OFF" !Sets the Auto Range to OFF
    OUTPUT Testset;"SET:TXP:TIM:STIM 10" !Sets timeout value
    OUTPUT Testset;"SET:TXP:TRIG:DEL 0ms" !Sets the trigger delay
  8. Query uplink frames per USS.

    OUTPUT Test_set;"SETup:TXPower:SSTep:FRAMes?"

  9. Configure mobile station for correctly transmitting UTS
  10. Initiate the GFDT capable measurement. This example uses the Transmit Power Measurement.

    OUTPUT Test_set;"INITiate:TXPower"

  11. Query the Arm State of Test set. The test set needs about 2 second to arm.

    OUTPUT Test_set;"INITiate:TXPower:GFDTUNe:ARMed?"

  12. If the test set is ready to receive input RF signals, trigger mobile station to transmit UTS.

Related Topics

Fast Device Tune Capable Measurement

Programming in Fast Device Tune Operating Mode

INITiate

GFDTune:UPLink

GFDTune:DOWNlink

SETup:TXPower

FETCh:TXPower

Receiver Control


In-Band Frame Error (IFER) Measurement Description

In-Band Frame Error (IFER) Measurement Description

This section is only applicable to the lab applications and the test application with a required feature license.

The IFER measurement is used to verify the reference sensitivity of an AMR logical speech channel.

How is an IFER Measurement Made?

The test set requires that four codecs be defined in the Active Codec Set (ACS) before an IFER measurement can initiate. If the IFER measurement is initiated but the ACS does not contain four codecs, the measurement does not start and the following integrity indicator is displayed on the front panel: Unsupported Configuration . The codec that is used on the downlink (or the uplink) can change at a minimum of every two speech frames. To inform the receiver of the codec that has been used for a group of two speech frames, a control message is transmitted in-band (with the speech data) every two speech frames, on specific multiframe positions. This is known as the Codec Mode Indication (CMI). The message sent by the test set to the mobile station to change the codec used on the uplink is called the Codec Mode Command (CMC). The message sent by the mobile station to request the use of a new codec on the downlink is called the Codec Mode Request (CMR).

The test set requires that the mobile station supports loopback type I in order for the downlink CMI and CMC bits to be returned on the uplink. If the mobile is not capable of performing a loopback type I, synchronization between the uplink and the downlink will not occur and meaningful results will not be generated. When loopback type I is activated, no changes to the RATSCCH parameters are permitted. The RATSCCH parameters include Current Codec, Active Codec Set, Threshold and Hysteresis values. The test set allows the mobile station enough time to close loopback type I with the speech frame loopback delay control parameter. If the speech frame loopback delay parameter is set to AUTO, and the Operating Mode is not Active Cell, the test set tries to determine the speech frame delay every time the measurement begins. If the Operating Mode is in Active Cell, the test set only determines the speech frame delay the first time the measurement is made, unless the call drops or the speech frame delay control changes. If the speech frame loopback delay control is set to Manual, the test set uses the specified speech frame delay.

The IFER measurement measures the reference sensitivity of an AMR logical speech channel by forcing the CMI and CMC bits to cycle through the codec selection pattern 1,2,3,4,4,3,2,1 at a rate specified in the test set. When the IFER measurement is activated, it overrides the settings for the current codec. When IFER is deactivated, the setting for the current codec is set on the downlink back to what is was before the IFER measurement was activated. Changes to the current codec, codec set and/or thresholds that are made during the IFER measurement are ignored until the next call is initiated.

The 3GPP TS 51.010 recommends a minimum of 150000 speech frames to be tested to have accurate measurement results. This measurement can take over 50 minutes to complete.

The results of an AMR IFER measurement can be displayed in two ways; the number of errors counted or the ratio of bad bits to the total number of bits. If you are using the test set's front panel, select either % or Count from the Measurement Units field. If you are using the test set via the GPIB commands, the results are available using the fetch command, see FETCh:IFERror:RATio? or FETCh:IFERror:COUNt? . Alternatively, the command FETCh:IFERror[:ALL]? can also be used to obtain these results.

IFER Measurement Parameters

  • Speech Frames to Test - The number of speech frames to be tested by the measurement.
  • Speech Frame Delay -The time needed for the loopback type I to complete.
  • Change Period - The number of frames to wait between changing codec mode.
  • Measurement Unit - Option to display the measurement results in a ratio or actual count.
  • Trigger Arm- See Trigger Arm (Single or Continuous) Description
  • Measurement Timeout- See Measurement Timeouts

IFER Measurement Results

  • IFER Integrity Indicator - See Integrity Indicator
  • IFER Speech Frames - The number of speech frames tested.
  • IFER Ratio - The ratio of speech frame bit errors to the total number of bits.
  • IFER Count - The number of speech frame errors counted.
  • IFER Speech Frame Delay - The delay used to ensure that loopback type I has completed.

Operating Considerations

An IFER measurement can be made when the Operating Mode is set to Active Cell and the Serving Cell is GSM , GPRS , and EGPRS and when the Connection Type is Auto or when the Operating Mode is GSM BCH+TCH.

Impact on other Measurement

Only one of the following measurements can be made at a time: GSM Bit Error, GSM Fast Bit Error or AMR In-Band Frame Error. If one of these measurements is initiated while another of the remaining two are running, the measurement that is initiated last continues to run and the other is closed.

Related Topics

How to Make an AMR In-Band Frame Error Measurement

Programming an AMR In-Band Frame Error Rate Measurement

AMR In-Band Frame Error (IFER) Measurement Troubleshooting

Adaptive Multi-Rate (AMR) Feature Descriptions

Test Adherence to Standards


I/Q Tuning Measurement Description

I/Q Tuning Measurement Description

How is an I/Q Tuning Measurement Made?

The I/Q Tuning measurement is used in the production process (normally at mobile pre-test) where the I/Q modulator of the mobile is being calibrated. The measurement is normally performed with the mobile station in test mode and transmitting a GMSK modulated sequence of all 0s or all 1s. The mobile can be transmitting either a bursted signal or a continuous wave signal. I/Q Tuning is not an ETSI specified measurement.

NOTE
When using the I/Q Tuning measurement with an EGPRS mobile, you must select a modulation coding scheme which uses GMSK modulation (MCS1 through MCS4). The I/Q Tuning measurement does not support 8PSK modulation coding schemes (MCS5 through MCS9).

The carrier frequency is shifted up or down 67.7083 kHz by transmitting a sequence of all 0s (+67.7083 kHz) or all 1s (-67.7083 kHz). The accuracy of the mobile's I/Q modulator is determined by measuring the level of spurious signals relative to the desired signal (the desired signal being the carrier frequency +/-67.7083 kHz). The signals the test set measures are: the carrier frequency (Fc); Fc+/-67.7083 kHz; Fc+/-135.417 kHz; Fc+/-203.125 kHz and Fc+/-270.833 kHz. These signals are measured at the RF IN/OUT port.

The figure below shows a typical spectrum generated by a mobile transmitting a sequence of all 0s. The peak at the +67.7083 kHz offset is the one used as the reference.

The I/Q Tuning measurement also allows you to make an additional relative power measurement at any frequency you want between -13.0 MHz to -1.0 MHz and +1.0 MHz to +13.0 MHz relative to the carrier frequency.

Spectrum of a mobile transmitting a sequence of all 0s

Single or Multi-Measurements

The I/Q Tuning measurement can return either single or averaged measurement results.

  • If you set the multi-measurement state OFF then only a single measurement is made at each offset.

  • If you set the multi-measurement state ON, and the multi-measurement count number to a value greater than one, then multiple measurements are made at each offset. The returned results are an average of these measurements.

Types of Signals I/Q Tuning can Measure

I/Q Tuning measurements can be made on these types of input signals.

  • Normal TCH or PDTCH burst without a midamble.
  • CW signal.

I/Q Tuning Input Signal Requirements

The I/Q Tuning measurement will complete and meet its measurement accuracy specifications under the following input signal conditions.

  • Input signal level is between -15 dBm and +43 dBm.
  • Input signal level is within +3 dB and -10 dB of the expected input level.
  • Signal must be within 500 kHz of expected frequency for RF Rise triggering to function.

Trigger Source

The trigger source depends on the type of input signal.

Recommended Trigger Source Settings
Input Signal Type | Recommended Trigger Source
Normal TCH or PDTCH burst without a midamble | RF Rise
CW signal | Immediate

Related Topics

Programming an I/Q Tuning Measurement


Multi-tone Audio Measurement Description

Multi-tone Audio Measurement Description

This measurement is not applicable to GPRS or EGPRS.

You can use the multi-tone audio measurement to verify the performance of a mobile station's speaker and microphone. This is made possible by the two measurement modes available: downlink and uplink. Audio level, frequency response, and distortion results are available for both modes.

In both modes, there is an audio stimulus, referred to as the "Generator", and an audio analysis, referred to as the "Analyzer". The Generator is a 20 tone source. Presets are provided, which contain frequency and level setting for all 20 tones, or you can specify the frequency and level for each tone. You can choose to have the Analyzer tuned to the same frequencies as the Generator, or you can configure the Analyzer separately.

How is a multi-tone audio measurement made?

The multi-tone audio measurement measures Audio Level (V), SINAD (dB), Distortion (%), and Audio Frequency. When measuring a mobile's audio output, the audio signal may come from either an acoustic coupler or from a test interface connection to the mobile's audio circuitry.

Downlink Measurement Mode

The downlink measurement mode is used to test the mobile station's speaker quality. The tones from the Generator are encoded and sent to the mobile station over the RF link. The mobile station decodes the audio and sends it to the speaker. The audio signal travels through an acoustic coupler to the test set's AUDIO IN port and then to the Analyzer. Measurement results are available for each tone either graphically from the test set's front panel or programmatically using a GPIB query.

Considerations when making a downlink multi-tone audio measurement

The Speech TCH parameter must be set to Multi-Tone for downlink measurements. Setting the speech type to Multi-Tone connects the multi-tone generator to the encoder and ensures the audio signal gets placed on the RF link.

The Expected Audio In Peak Voltage should be set appropriately to avoid over or under range errors.

The AUDIO IN connectors feed the inputs to a floating-input differential amplifier, with each input having an impedance of about 100,000 ohms to chassis ground. For best noise immunity, connect the audio signal and its ground reference to the two input ports through shielded coaxial cables, or input the signal to the AUDIO IN HI connector and ground the AUDIO IN LO connector's center contact.

Uplink Measurement Mode

The uplink measurement mode is used to test the mobile station's microphone quality. The Generator sends the audio tones to the test set's AUDIO OUT port. An acoustic coupler is used to connect the AUDIO OUT port to the mobile station's microphone. The mobile station encodes the audio signal and transmits it back to the test set using the RF link. The test set decodes the audio signal and sends it to the Analyzer. Measurement results are available for each tone either graphically from the test set's front panel or programmatically using a GPIB query.

Considerations when making an uplink multi-tone audio measurement

The Speech TCH parameter must be set to None for uplink measurements. This ensures there is no downlink signal, which would cause bad measurement results.

You should adjust the downlink Generator levels as high as possible to achieve a strong signal on the uplink. This will help prevent the low level portions of the signal from being buried in the noise floor. The downlink Generator level upper limits are dynamic, depending on the generator frequency configuration. You can see this difference when a call is connected and audio is being supplied to the mobile station's microphone. For example, the preset Multi-tone 100 has a lower crest factor and therefore allows the total downlink generator to be set to a higher level than the Multi-tone 140, whose crest factor is larger and therefore would cause signal level peaks which exceed the hardware limitations if it's total limit is set too high.

SINAD/Distortion Measurements

When the SINAD/Distortion State is ON, the test set returns SINAD, Distortion, Audio Level, and Audio Frequency results for audio tone one. In this mode, it is also possible for you to make a distortion level when no tone is being generated. This allows you to detect spurs from the mobile station.

Difference between Multi-tone Audio and Audio Analyzer SINAD/Distortion measurement.

The SINAD/Distortion measurements used by the Multi-tone Audio instrument and the Audio Analyzer use the same algorithms. The primary difference is the Multi-tone Audio instrument allows you to make these measurements on audio that has been sent to the test set over RF instead of only through the AUDIO IN BNC connectors.

Measurement Parameters

Measurement Setup Parameters

  • Multi-Measurement Count - (See Statistical Measurement Results .)
  • Measurement Mode - Controls whether measurements are made on the downlink or uplink.
  • Analyzer 0 dB Reference Mode - Controls the reference to be used when making audio level measurements. The Analyzer Reference Tone is used to specify a reference other than 0 dB if this parameter is set to Relative .
  • Analyzer Reference Tone - The number of the audio tone to be used as the reference when making relative measurements. The Analyzer 0 dB Reference Mode must be set to Relative for this parameter to be active.
  • Analyzer Downlink Reference Level - The reference level used when making absolute measurements on the downlink. The Analyzer 0 dB Reference Mode must be set to Absolute and the Measurement Mode must be set to Downlink for this parameter to be active.
  • Analyzer Uplink Reference Level - The reference level used when making absolute measurements on the uplink. The Analyzer 0 dB Reference Mode must be set to Absolute and the Measurement Mode must be set to Uplink for this parameter to be active.
  • Expected Peak Voltage - The Expected Peak Voltage sets the audio clipping level and must be set. This voltage is always the absolute peak audio input signal voltage expected at the AUDIO IN connectors, and must be in the range of 7.07 mV peak (5 mVrms) to 20 V peak . Remember, measuring a 1-volt rms sinewave input signal would require a 1.414 V peak expected voltage value to avoid clipping (over-driving) the input.
  • Device Settling Time - The amount of time allowed to lapse after setting the level and frequency before triggering a measurement.
  • SINAD/Distortion State - Select On or Off to enable or disable the SINAD and Distortion measurements. This can be done remotely using the SETup:MTAudio:SDIStortion:STATe . When On, these measurement results are displayed on the screen instead of the frequency response graph. Only tone one should be active when making the SINAD/Distortion measurement. All other tones should be turned off.
  • Trigger Arm - (See Trigger Arm (Single or Continuous) Description ) Multi-tone audio measurements use immediate triggering and are continuously re-triggered each time the Trigger Arm parameter is set to Continuous. Trigger timing is independent of any mobile protocol signaling.
  • Measurement Timeout - (See Measurement Timeouts .)

Multi-Tone Audio Generator Parameters

Multi-Tone Audio Generator Frequencies

  • Preset Frequencies To - Allows you to select a preset frequency configuration for the 20 available audio tones.
  • Audio Tone <n> Frequency - Allows you to turn on each audio tone individually and specify the frequency associated with it.

Multi-Tone Generator Uplink Levels

  • Multi-Tone Audio Total Level - Sets the total RMS audio output level, to be distributed evenly among all active frequencies. This setting is dynamic, depending on the active frequencies. See Considerations when making an uplink multi-tone audio measurement for more explanation.
  • Audio Tone <n> Level - Allows you to turn on each audio tone individually and specify the level associated with it.

Multi-Tone Generator Downlink Levels

  • Multi-Tone Audio Total Level - Sets the total percentage audio output level, to be distributed evenly among all active frequencies. This setting is dynamic, depending on the active frequencies. See Considerations when making a downlink multi-tone audio measurement for more explanation
  • Audio Tone <n> Level - Allows you to turn on each audio tone individually and specify the level associated with it.

Multi-Tone Audio Analyzer Parameters

Multi-Tone Analyzer Frequencies

  • Use Multi-Tone Generator Frequencies - Controls the coupling between the generator frequencies and the analyzer frequencies. If the setting is off, you must specify the frequencies for the analyzer to use.
  • Audio Tone <n> Frequency - Allows you to turn on each analyzer tone individually and specify the frequency associated with it.

Multi-Tone Audio Level Limits

  • Controls the upper and lower limits for each audio tone. These settings are used to determine if the measured audio levels for each tone pass or fail.

Measurement Results

  • Integrity Indicator - (See Integrity Indicator .)
  • Multi-Tone Audio Level - This is the frequency response. The measurement reports the average RMS level for each of the 20 audio tones that are turned on. The results are displayed in a bar graph on the test set's front panel screen.
  • Multi-Tone Audio Frequency Response Mask - Indicates a pass or fail for each of the 20 audio tones that are turned on. On the test set's screen, the bar graph for audio tones which fail the mask are displayed in red.
  • Distortion - The measured distortion of audio tone one. The SINAD/Distortion state must be turned on for this measurement result to be available.
  • SINAD - The measured SINAD for audio tone one. The SINAD/Distortion state must be turned on for this measurement result to be available.
  • Audio Level - The measured audio level for audio tone one. The SINAD/Distortion state must be turned on for this measurement result to be available.
  • Frequency - The measured frequency for audio tone one. The SINAD/Distortion state must be turned on for this measurement result to be available.

Related Topics

Multi-Tone Audio Troubleshooting

Programming a Downlink Multi-Tone Audio Measurement

Programming an Uplink Multi-Tone Audio Measurement

Statistical Measurement Results (Multi-measurements)


Output RF Spectrum Measurement Description

Output RF Spectrum Measurement Description

The Output RF Spectrum Measurement is applicable to GSM, GPRS, and EGPRS. This measurement description contains two sections:

  • GSM Output RF Spectrum Measurement
  • GPRS and EGPRS Output RF Spectrum Measurement

GSM Output RF Spectrum Measurement

How is an output RF spectrum (ORFS) measurement made?

The ORFS measurement is a narrow-band measurement that provides information about the distribution of the mobile station transmitter's out-of-channel spectral energy due to modulation and switching as defined in ETSI GSM 05.05, section 4.2, 3GPP 51.010 (formerly ETSI GSM 11.10), section 13.4 at offsets < 1800 kHz.

The test set provides two forms of the ORFS measurement filter types: analog and digital. The Digital ORFS measurement is optimized for speed. It allows all ORFS offset frequencies to be computed from a single acquisition rather than obtaining them individually, which is the process for the Analog ORFS measurement. For power levels greater than 2 dBm, the dynamic range of the Digital ORFS measurement is about 3 dB to 7 dB less than the dynamic range for the Analog ORFS measurement. However, at lower values of expected power, the dynamic range of the ORFS measurement is actually greater than the Analog ORFS measurement.

The measurement filter type can be configured either manually or remotely. The available settings for the measurement filter type are Analog , Digital , and Auto . The Auto setting allows the test set to determine which filter type to use based on the current hardware. The test set always chooses the filter type that returns the fastest measurement results. The command to set the filter type is SETup:ORFSpectrum:FILTer:TYPE . The manual setting for the filter type is in the Measurement Setup window of the ORFS Setup screen.

The analog and digital measurement filter types each include ORFS due to modulation and ORFS due to switching. Switching and modulation measurements may be performed from the same burst. If you request both modulation and switching results at the same frequency offsets, measurement throughput is improved.

ORFS due to modulation measures out of channel interference due to the GMSK modulating signal. The measurement returns relative results in (dB) using the power in a 30 kHz bandwidth centered on the carrier frequency as the reference. You can set 0 to 22 modulation offset frequencies.

ORFS due to switching measures out of channel interference due to the TDMA switching transients. The measurement returns absolute power results (dBm) for each offset frequency indicating the peak power value over the entire burst plus 10 additional bits on either side of the 147 bit wide normal burst. You can set 0 to 8 ORFS due to switching offset frequencies.

The number of measurements to be averaged for each offset may be different. The test set internally controls all other aspects of the measurement, including calibration.

TX power (average power), 30 kHz bandwidth power at zero offset, ORFS due to modulation average power, and ORFS due to switching maximum power are included in an ORFS measurement, when both modulation and switching measurements are made. (TX power is performed using the same method as described in the Transmit Power Measurement Description , which synchronizes the measurement with the burst amplitude).

ORFS due to modulation

When multiple offset frequencies for the ORFS due to modulation measurement are set, the DSP averages the power across the appropriate time segments (40 bits) of the burst with a 30 kHz resolution bandwidth, 5-pole, synchronously tuned filter placed at the center frequency of the burst and compares it to a time segment of the response of the same filter placed at some frequency offset. The result is a relative power measurement using the 30 kHz bandwidth power at zero offset as a reference. When the ORFS measurement filter type is ANALog , for each offset you specify, the DSP retunes the filter and measures the 30 kHz bandwidth power and compares it to the reference, the relative power measurement of signal power over the entire burst. The DSP processes the data and makes these results available to you.When the ORFS measurement filter type is DIGital , the test set captures the signal in the full 3.6 MHz ORFS bandwidth in a single acquisition, and does not need to retune the receiver for each offset which reduces the measurement time.

For offsets up to 1.799999 MHz, an ORFS due to modulation measurement uses the 30 kHz resolution bandwidth filter required in GSM 05.05. At the 1800 kHz offset frequency the ORFS due to modulation measurement is made using the 30 kHz resolution bandwidth filter, not the 100 kHz resolution bandwidth filter required by ETSI.

The ORFS due to modulation measurement measures both the front and back data portions of the burst. Measurements occur from bit 15 to 60 and from bit 87 to 132. GSM 11.10 recommends that this measurement is performed on only the back section of the burst. Measuring both the front and back of the burst has the speed advantage of providing two modulation measurements per burst.

ORFS due to switching

When multiple offset frequencies for the ORFS due to switching measurement are set, the DSP looks at the signal through the 30 kHz resolution bandwidth, 5-pole, synchronously tuned to each offset frequency in turn. The result for the measurement is the maximum of these sampled values over the entire burst and is reported as an absolute power measurement. When the measurement filter type is set to ANALog, the DSP then retunes the filter, samples the signal, and processes the data for each requested offset. When the measurement filter type is set to the DSP computes the result for all requested offset frequencies from the same sample acquisition.

Single or Multi-Measurements

To obtain statistical measurement results, the multi-measurement count must be set for both switching and modulation measurements. (See Statistical Measurement Results for more information.)

Changing the multi-measurement modulation or switching count number or setting multi-measurement to ON allows the test set to make multiple measurements at each frequency offset. If you set Multi-measurement count state to OFF only one ORFS measurement is completed at each offset frequency (that is, one ORFS due to modulation, and one ORFS due to switching measurement).

  • If you want to make multiple ORFS due to modulation measurements and no ORFS due to switching measurements, a number must be entered in the multi-measurement modulation count, and all the switching offset frequencies must be off.

  • In order to make multiple ORFS due to switching measurements and no ORFS due to modulation measurements, a number must be entered in the multi-measurement switching count, and all modulation offset frequencies must be off.

For modulation measurements, the average and standard deviation of the relative power values at each offset frequency are returned.

For switching measurements, the maximum, average and standard deviation of the absolute power values at each offset frequency are returned.

Types of Signals ORFS can Measure

ORFS measurements can be made on these types of input signals:

  • Normal GSM TCH burst with mobile station in active cell mode.
  • Normal GSM TCH burst with mobile station in test mode.

  • Non-bursted signal including GMSK modulation with mobile station in test mode.

    For a non-bursted signal, an ORFS due to switching measurement result is not useful.

Input Signal Requirements

The ORFS measurement will complete and meet its accuracy specification under the following conditions:

  • Input signal level is between -10 dBm and +37 dBm.
  • Input signal level within +/-3 dB of the expected input level.
  • Frequency is within +/-200 Hz of expected input frequency.

Trigger Source

Auto triggering is the recommended trigger source for each measurement, allowing the test set to choose the preferred trigger source. However, you may want to select the trigger source.

Recommended Trigger Source Settings
Input Signal Type | Recommended Trigger Source
Normal GSM TCH burst with mobile station in active cell mode | Protocol
Normal GSM TCH burst with mobile station in test mode | RF Rise
CW signal | Immediate

Related Topics

How Do I Make an Output RF Spectrum Measurement?

SETup:ORFSpectrum

FETCh:ORFSpectrum

Programming an Output RF Spectrum Measurement

Test Adherence to Standards

ORFS Troubleshooting

GPRS and EGPRS Output RF Spectrum Measurement

How is an output RF spectrum (ORFS) measurement made?

The ORFS measurement is a narrow-band measurement that provides information about the distribution of the mobile station transmitter's out-of-channel spectral energy due to modulation and switching as defined in ETSI GSM 05.05, section 4.2, 3GPP 51.010 (formerly ETSI GSM 11.10), section 13.4 at offsets < 1800 kHz.

The test set provides two forms of the ORFS measurements: analog and digital. The Digital ORFS measurement is optimized for speed. It allows all ORFS offset frequencies to be computed from a single acquisition rather than obtaining them individually, which is the process for the Analog ORFS measurement. For power levels greater than 2 dBm, the dynamic range of the Digital ORFS measurement is about 3 dB to 7 dB less than the dynamic range for the Analog ORFS measurement. However, at lower values of expected power, the dynamic range of the ORFS measurement is actually greater than the Analog ORFS measurement.

The measurement filter type can be configured either manually or remotely. The available settings for the measurement filter type are Analog , Digital , and Auto . The Auto setting allows the test set to determine which filter type to use based on the current hardware. The test set always chooses the filter type that returns the fastest measurement results. The command to set the filter type is SETup:ORFSpectrum:FILTer:TYPE . The manual setting for the filter type is in the Measurement Setup window of the ORFS Setup screen.

For analog ORFS measurement, You can measure one of the two adjacent uplink bursts of the multislot configuration at one time. You can specify the burst to measure using CALL:(PDTCH|PDTChannel):MSLot:MEASurement:BURSt . The relative power level is within 30dB according to the data sheet. Initiating analog ORFS with more than 2 uplink bursts will result in Unsupported Configuration error.

For digital ORFS measurement, You can measure one of the six adjacent uplink bursts of the multislot configuration at one time. You can specify the burst to measure using CALL:(PDTCH|PDTChannel):MSLot:MEASurement:BURSt . The relative power level is within 30dB according to the data sheet of the four uplink bursts in the multislot configuration.

For GPRS and EGPRS mobiles, the measurement conforms to 3GPP 51.010 (formerly ETSI GSM 11.10), section 13.16.3 at offsets < 1800 kHz (when the Multi-Measurement Count - Modulation parameter is set to Off using SETup:ORFSpectrum:COUNt:STATe ).

The analog and digital measurement each include ORFS due to modulation and ORFS due to switching.

ORFS due to modulation measures out of channel interference due to the GMSK or 8PSK modulating signal. The measurement returns relative results in (dB) using the power in a 30 kHz bandwidth centered on the carrier frequency as the reference. You can set 0 to 22 modulation offset frequencies.

ORFS due to switching measures out of channel interference due to the TDMA switching transients. The measurement returns absolute power results (dBm) for each offset frequency indicating the peak power value over the entire burst plus 10 additional bits on either side of the 147 bit wide normal burst (or 147 symbol wide normal burst for 8PSK modulation). You can set 0 to 8 ORFS due to switching offset frequencies.

When measuring a single uplink timeslot, switching and modulation measurements can be performed from the same burst (provided that the overshoot in the burst is less than 1 dB). If you request both modulation and switching results at the same frequency offsets, measurement throughput is improved. Measurements are made using a 30 kHz IF bandwidth, 5-pole synchronously tuned filter.

When measuring more than one uplink timeslots, the modulation measurement is performed for only one burst at a time in the multislot configuration, which you specify using CALL:(PDTCH|PDTChannel):MSLot:MEASurement:BURSt . The switching measurement is performed over all consecutive bursts irrespective of which burst you have currently selected to measure.

NOTE
In order for the test set to return a valid switching measurement result when measuring more than one consecutive uplink bursts, you should ensure that the burst you have selected to measure has the highest expected power level in the multislot configuration. If the selected burst does not have the highest expected power level, the test set returns NAN for the switching measurement. The expected power can be set manually using RFANalyzer:MANual:POWer:BURSt<[1]|2|3|4|5|6|7> .

The number of measurements to be averaged for each offset may be different. The test set internally controls all other aspects of the measurement, including calibration.

TX power (average power), 30 kHz bandwidth power at zero offset, ORFS due to modulation average power, and ORFS due to switching maximum power are included in an ORFS measurement, when both modulation and switching measurements are made. (TX power is performed using the same method as described in the Transmit Power Measurement Description , which synchronizes the measurement with the burst amplitude).

ORFS due to modulation

When multiple offset frequencies for the ORFS due to modulation measurement are set, the DSP averages the power across the appropriate time segments (40 bits) of the burst with a 30 kHz resolution bandwidth, 5-pole, synchronously tuned filter placed at the center frequency of the burst and compares it to a time segment of the response of the same filter placed at some frequency offset. The result is a relative power measurement using the 30 kHz bandwidth power at zero offset as a reference. When the ORFS measurement filter type is ANALog , for each offset you specify, the DSP retunes the filter and measures the 30 kHz bandwidth power and compares it to the reference, the relative power measurement of signal power over the entire burst. The DSP processes the data and makes these results available to you.When the ORFS measurement filter type is DIGital , the test set captures the signal in the full 3.6 MHz ORFS bandwidth in a single acquisition, and does not need to retune the receiver for each offset which reduces the measurement time.

For offsets up to 1.799999 MHz, an ORFS due to modulation measurement uses the 30 kHz resolution bandwidth filter required in GSM 05.05. At the 1800 kHz offset frequency the ORFS due to modulation measurement is made using the 30 kHz resolution bandwidth filter, not the 100 kHz resolution bandwidth filter required by ETSI.

The ORFS due to modulation measurement measures both the front and back data portions of the burst. Measurements occur from bit 15 to 60 and from bit 87 to 132. GSM 11.10 recommends that this measurement is performed on only the back section of the burst. Measuring both the front and back of the burst has the speed advantage of providing two modulation measurements per burst.

ORFS due to switching

When multiple offset frequencies for the ORFS due to switching measurement are set, the DSP looks at the signal through the 30 kHz resolution bandwidth, 5-pole, synchronously tuned to each offset frequency in turn. The result for the measurement is the maximum of these sampled values over the entire burst and is reported as an absolute power measurement. When the measurement filter type is set to ANALog, the DSP then retunes the filter, samples the signal, and processes the data for each requested offset. When the measurement filter type is set to DIGital the DSP computes the result for all requested offset frequencies from the same sample acquisition.

Single or Multi-Measurements

To obtain statistical measurement results, the multi-measurement count must be set for both switching and modulation measurements. (See Statistical Measurement Results for more information.)

Changing the multi-measurement modulation or switching count number or setting multi-measurement to ON allows the test set to make multiple measurements at each frequency offset. For modulation measurements the offset values returned are the average power at each offset. For switching measurements the offset values returned are the maximum power at each offset. If you set Multi-measurement count state to OFF only one ORFS measurement is completed at each offset (that is, one ORFS due to modulation, and one ORFS due to switching measurement).

  • If you want to make multiple ORFS due to modulation measurements and no ORFS due to switching measurements, a number must be entered in the multi-measurement modulation count, and all the switching offset frequencies must be off.

  • In order to make multiple ORFS due to switching measurements and no ORFS due to modulation measurements, a number must be entered in the multi-measurement switching count, and all modulation offset frequencies must be off.

    For modulation measurements, the average and standard deviation of the relative power values at each offset frequency are returned.

    For switching measurements, the maximum, average and standard deviation of the absolute power values at each offset frequency are returned.

Measuring ORFS on GPRS and EGPRS mobiles using the BLER data connection type

The result of the Output RF Spectrum measurement relies on pseudo random data being present in the data field of the RF burst. When using the BLER data connection type, these data fields do not contain pseudo random data, therefore the results may not be representative.

Types of Signals ORFS can Measure

The following list summarizes the input signal attributes and mobile station operating modes for making PvT measurements.

  • Class 1 to 12 GPRS PDTCH multislot configurations with the mobile station in active cell mode.

  • Class 1 to 12 GPRS PDTCH multislot configurations with the mobile station in GPRS BCH or GPRS BCH+PDTCH test mode (no protocol).

  • Class 1 to 12 EGPRS PDTCH multislot configurations when the operating mode is active cell and the serving cell is EGPRS.

  • Class 1 to 12 EGPRS PDTCH multislot configurations with the mobile station in EGPRS BCH or EGPRS BCH+PDTCH test mode (no protocol).

  • Non-bursted signal including GMSK modulation with mobile station in test mode.

    For a non-bursted signal, an ORFS due to switching measurement result is not useful.

Input Signal Requirements

The ORFS measurement will complete and meet its accuracy specification under the following conditions:

  • Input signal level is between -10 dBm and +37 dBm (GPRS) / +33 dBm (EGPRS).
  • Input signal level within +/-3 dB of the expected input level.
  • Frequency is within +/-200 Hz of expected input frequency.

Trigger Source

Auto triggering is the recommended trigger source for each measurement, allowing the test set to choose the preferred trigger source. However, you may want to select the trigger source.

Recommended Trigger Source Settings
Input Signal Type | Recommended Trigger Source
GPRS PDTCH multislot configuration with mobile station in active cell mode | Protocol
Normal GPRS PDTCH multislot configuration with mobile station in GPRS BCH or GPRS BCH+PDTCH test mode | RF Rise
EGPRS PDTCH multislot configuration with mobile station in active cell mode and modulation coding scheme set to MCS1, MCS2, MCS3, or MCS4 | Protocol
EGPRS PDTCH multislot configuration with the test set in EGPRS BCH or EGPRS BCH+PDTCH test mode and modulation coding scheme set to MCS1, MCS2, MCS3, or MCS4 | RF Rise
CW signal | Immediate

For more information on measurement triggering, refer to Triggering of Measurements .

Operating Considerations

As the uplink burst number increases, the measurement speed is expected to decrease.

The test set also provides the result of ORFS due to Switching in time domain. However, Turning on the Time Domain Trace will slow down the measurement speed significantly. You can use SETup:ORFSpectrum:SWITching:TIME:DOMain:STATe to turn on/off the Time Domain Trace.

Related Topics

How Do I Make an Output RF Spectrum Measurement?

SETup:ORFSpectrum

FETCh:ORFSpectrum

Programming an Output RF Spectrum Measurement

ORFS Troubleshooting

Test Adherence to Standards


Phase and Amplitude versus Time Measurement Description

Phase and Amplitude versus Time Measurement Description

This measurement is only applicable to the GSM/GPRS/EGPRS lab applications and a test application with the required feature license.

Set up parameters and measurement results for this measurement are only accessible using the GPIB interface.

  • How is a Phase and Amplitude versus Time Measurement Made?
  • Phase and Amplitude versus Time Measurement Parameters
    • Configuring a Discrete Waveform Calibration Signal
    • Configuring a Continuous Waveform Calibration Signal
  • Phase and Amplitude versus Time Measurement Results
    • Phase and Amplitude Measurement Results for a Discrete Waveform
    • Phase and Amplitude versus Time Measurement Results for a Continuous Waveform
    • Interpreting Integrity Indicators
  • Phase and Amplitude versus Time Input Signal Requirements
  • Calibrating the Phase and Amplitude versus Time Measurement

How is a Phase and Amplitude versus Time Measurement Made?

The Phase and Amplitude versus Time measurement provides a way to characterize the magnitude and phase errors introduced by the non-linear effects of power amplifiers operating over a wide dynamic range. Measuring the amplitude, phase and frequency as a function of output level makes it possible to create a more accurate output signal by pre-distorting the input signal to the power amplifier.

The Phase and Amplitude versus Time measurement is performed on a continuous wave signal with either a discrete amplitude step waveform (Discrete Waveform Calibration Signal) or continuous ramp waveform (Continuous Waveform Calibration Signal). This measurement requires you to put your mobile station into a test mode that can command the mobile station to generate a waveform, which can be either discrete or continuous.

The Discrete Waveform Calibration Signal may include up to 512 measurement intervals (steps), which can be of varying widths (100 us to 400 ms) and amplitudes (-20 dBm to +35 dBm). For this waveform, you can configure the test set to return different types of results, these are: power, phase, and frequency results ( PCAL ), amplitude and phase pairs ( SAMPle ), or both ( BOTH ). The test set samples the discrete waveform at an effective rate of 156.25 kHz. The results returned by the test set depend on the Result Type parameter setting.

The Continuous Waveform Calibration Signal can be classified as three different waveform types: CONTinuous, CONT2 and CONT3. When the Waveform Type is CONTinuous, the signal required by the test set is a 577us GMSK initial reference burst, followed by a CW signal. The initial reference burst is used to range the expected input power and can be used to trigger the Phase and Amplitude versus Time measurement. The CONT2/CONT3 waveform measures a modulated burst signal (and does not require an initial reference burst). The differences in the way the test set performs measurements on these three waveform types are the effective sampling rate at which the test set returns results and the measurement sample count. For the CONTinuous waveform types, the sampling rate is 1.083 MHz and the maximum count is 5000; for the CONT2 waveform types the sampling rate is 4.333 MHz and the maximum count is 5000; for the CONT3 waveform types the sampling rate is 10 MHz and the maximum count is 50000. The results returned by the test set are amplitude and phase pairs.

This measurement can be armed as a single measurement only. Once triggered, the test set performs a measurement on the mobile generated waveform. The type of measurement and the format of the measurement results depend on the type of waveform (DISCrete, CONTinuous, CONT2, or CONT3) your mobile station generates and, for the DISCrete waveform, the Result Type parameter setting.

Before starting the Phase and Amplitude versus Time measurement, you should first specify the mobile station's Measurement Frequency and the Expected Power Control on the test set. The Expected Power Level should be set to the maximum power level in the mobile generated waveform, and the RF Generator's cell power should be set to OFF . Also before starting, you should specify any waveform specific parameters. See Configuring a Discrete Waveform Calibration Signal and Configuring a Continuous Waveform Calibration Signal .

The accuracy of this measurement relies heavily on the Spectrum Monitor calibration.

Operating Considerations

The Phase and Amplitude versus Time measurement is available in all operating modes. However, it is recommended that the operating mode be set to CW mode. CW mode provides the most basic setup for the RF Analyzer (see RFANalyzer ).

It is assumed that the call status is idle since the mobile station must be operating in a test mode to generate the appropriate waveform.

Setup and data output for this measurement is only available via the GPIB commands.

See Calibrating the Phase and Amplitude versus Time Measurement for information on how this measurement is calibrated to ensure accuracy.

For Discrete Waveform Calibration Signals, you must make sure the Interval Count, the number of Interval Centers, and the number of Interval Widths are consistent. The number of returned results depends on the step count. If the number of Interval Centers and/or Interval Widths is less than the step count, invalid data is returned.

This measurement can be armed as a single measurement only.

Impact on Other Measurements

This measurement is not concurrent with any other measurements. That is, initiating this measurement automatically aborts any measurement that is currently in progress. Likewise, if any other measurement is initiated, the Phase and Amplitude versus Time measurement is aborted.

Phase and Amplitude versus Time Measurement Parameters

  • Filter Type

    This parameter allows you to select the bandwidth filter used for the measurement. The test set provides three types of filter: WIDE, NARRow and ENARrow. You can select the filter type according to the following table. For example, if you want to measure the Power results of a signal with interference out of band, and do not concern much on the test speed, you can select Filter Type ENARrow .

    Anti-interference ability | Test Speed | Returned Results
    WIDE | Weak | Fast | Power, phase and frequency
    NARRow | Strong | Slow(*) | Power, phase and frequency
    ENARrow | Strong | Slow(*) | Only Power results are valid. The phase and frequency results are always Nan.

    *When the Filter Type is set to NARRow or ENARrow, the Interval Widths is recommended to be larger than 1ms, which will influence the test speed.

    The GPIB command to set this parameter is SETup:PCALibration:FILTer .

  • Interval Count

    This parameter is only applicable when the Waveform Type is DISCrete . This is the total number of steps the test set is to measure.

    You must make sure the Interval Count, the number of Interval Centers , and the number of Interval Widths are consistent. The number of returned results depends on the step count. If the number of Interval Centers and/or Interval Widths is less than the Interval Count, invalid data is returned.

    The GPIB command to set this parameter is SETup:PCALibration:STEP:COUNt .

  • Interval Centers

    This parameter is only applicable when the Waveform Type is DISCrete .This is the time location of the center of each step relative to the time when the trigger event occurs.

    The GPIB command to set this parameter is SETup:PCALibration:STEP:CENTer .

  • Interval Widths

    This parameter is only applicable when the Waveform Type is DISCrete .This is the stable portion, or portion you wish to measure, of each power step.

    The GPIB command to set this parameter is SETup:PCALibration:STEP:WIDth .

  • Measurement Sample Count

    This parameter is only applicable when the Waveform Type is CONTinuous , CONT2, or CONT3 . This parameter sets the total number of amplitude and phase samples to be reported by the test set in the Phase and Amplitude versus Time measurement results.

    The range of the sample count is:

    • 1 to 5000 when the Waveform Type is set to CONTinuous or CONT2;
    • 1 to 50000 when the Waveform Type is set to CONT3 .

    If you change a CONT3 Measurement to CONTinuous or CONT2 , the count value will be automatically set to 1 if it is originately over 5000. A warning message is popped up to notify the change.

    The GPIB command to set this parameter is SETup:PCALibration:MEASurement:COUNt .

  • Measurement Delay

    This parameter is only applicable when the Waveform Type is CONTinuous . This parameter is the time the test set waits after the initial reference burst before is starts sampling data to and processing the data into amplitude and phase results.

    The GPIB command to set this parameter is SETup:PCALibration:MEASurement:DELay .

  • Result Type

    This parameter only applicable when the Waveform Type is DISCrete . This parameter can be set to one of three options: PCAL , SAMPle , or BOTH . The setting for this parameter determines what type of measurement results the test set returns after measuring the Discrete Waveform Calibration Signal. For information on the type of results the test set returns base on the setting of this parameter, see Phase and Amplitude Measurement Results for a Discrete Waveform .

    The GPIB command to set this parameter is SETup:PCALibration:RESult:TYPE .

  • Timeout

    You can set the timeout state and time for this measurement. To set them separately, use SETup:PCALibration:TIMeout:STATe to set the timeout state, SETup:PCALibration:TIMeout:TIME to set the timeout time, or SETup:PCALibration:TIMeout:STIMe to set the state and time using the complex command.

  • Trigger Delay

    This is the specified time between the trigger event and when the test set begins sampling data.

    The range of the trigger delay is:

    • 0 to 10 ms when the Waveform Type is set to DISCrete or CONTinuous;
    • -2.31001 to 10 ms when the Waveform Type is set to CONT2 or CONT3.

    If you change a CONT2 /CONT3 Measurement to DISCrete or CONTinuous, the trigger delay will be automatically set to zero if it is originately negative. A warning message is popped up to notify the change.

    The GPIB command to set this parameter is SETup:PCALibration:TRIGger:DELay .

  • Trigger Source

    You can set the Trigger Source to IMMediate , RISE (RF Rise), or EXTernal . See Triggering of Measurements .

    The GPIB command to set this parameter is SETup:PCALibration:TRIGger:SOURce .

  • Trigger Threshold

    This is the level below the maximum power level (the power level of the initial reference burst) at which the measurement triggers. That is, the trigger threshold is the offset below the Expected Input Power plus the RF Amplitude Offset value. This parameter only applies if the Trigger Source is set to RISE.

    The GPIB command to set this parameter is SETup:PCALibration:TRIGger:THReshold .

  • Waveform Type

    This parameter classifies the characteristics of the calibration signal generated by the mobile station. The settings available for this parameter are DISCrete, CONTinuous, CONT2, or CONT3. See Configuring a Discrete Waveform Calibration Signal and Configuring a Continuous Waveform Calibration Signal for more information.

    Note, for certain feature licenses the waveform type must be set to CONT2 or CONT3 to initiate the measurement.

    • DISCrete - This setting configures the test set to expect a calibration signal generated by the mobile station that consists of a sequence of finite length power bursts with no burst in the sequence having a higher maximum power level than the first burst, which transitions through the trigger level threshold.
    • CONTinuous -This setting configures the test set to expect a waveform consisting of a GMSK initial power burst (577 µs wide) to trigger the measurement, followed by a continuous waveform.
    • CONT2 - This setting is similar to the CONTinuous setting except that it uses different type of filtering and a different sample rate.
    • CONT3 - This setting is similar to the CONTinuous setting except that it uses different type of filtering and a different sample rate. It supports measureing a wideband signal.

    The GPIB command to set this parameter is SETup:PCALibration:WAVeform:TYPE .

Configuring a Discrete Waveform Calibration Signal

A discrete waveform consists of a sequence of up to 512 measurement intervals (steps), which be of varying widths (between 100 us and 400 ms) and amplitude levels (-20 dBM to +35 dBM). All steps in a discrete waveform must be at the same carrier frequency.

The total sampling time is the largest Interval Center plus half of the corresponding Interval Width. The maximum sampling time is 400 ms. Therefore if the largest Interval Center plus half of the corresponding Interval Width exceeds 400 ms, the test set returns integrity indicator 21 (Parameter Error).

The maximum power setting is used to range the measurement and can be used as the reference for the trigger level, which is set by configuring the Trigger Threshold parameter. The Trigger Delay should also be configured prior to measuring the waveform. A wait is needed after the measurement initiates and before the waveform's RF Rise trigger event occurs.

If the Result Type is set to PCAL , there are parameters specific to the discrete waveform that you should set prior to measuring the discrete waveform. These parameters are necessary to completely define where the test set makes measurements on the discrete waveform, these are: Interval Count , Interval Centers , and Interval Widths .

The figure below is an example of a Discrete Waveform calibration signal when the Result Type parameter is set to PCAL .

Example Discrete Waveform (Waveform Type = Discrete, Result Type = PCAL)

The test set samples the discrete waveform at an effective rate of 156.25 kHz. These format of the results returned by depend on the Result Type parameter. See Phase and Amplitude Measurement Results for a Discrete Waveform for details on what the test set returns after performing the Phase and Amplitude versus Time measurement on a discrete waveform calibration signal generated from a mobile station.

Configuring a Continuous Waveform Calibration Signal

If you wish to measure a continuous signal, the Waveform Type should be set to CONTinuous , CONT2, or CONT3 . The CONTinuous waveform must consist of a GSM burst followed by the waveform to be measured. For the test set to trigger properly, the Initial Reference Burst (GSM burst) should be at the maximum power level of the waveform. The CONT2 and CONT3 waveforms both do not require the Initial Reference Burst.

NOTE: When measuring a CONT2 or CONT3 waveform, and the Trigger Source is set to RISE , the waveform must begin with a sharp rise toward the maximum power setting in order for the test set to trigger. The measurement will not trigger until the power level rises above the Trigger Threshold .

The Expected Power Control parameter in the test set should be set to the maximum power level. This setting is used to range the measurement and can be used as the reference for the trigger threshold, which is set by configuring the Trigger Threshold parameter. A wait is needed after the measurement initiates and before the waveform's trigger event occurs.

The figure below shows an example of a CONTinuous waveform (including the required Initial Reference Burst). The Waveform Type parameter determines the effective sampling rate used for the continuous waveform. For the CONTinuous waveform types, the sampling rate is 1.083 MHz, and for CONT2 waveform types the sampling rate is 4.333 MHz, while the sampling rate for the CONT3 waveform types is 10 MHz. You should specify the Measurement Sample Count , Trigger Delay , and Measurement Delay parameters before you measure the continuous waveform.

.

Example Continuous Waveform (Waveform Type = CONTinuous)

See Phase and Amplitude versus Time Measurement Results for a Continuous Waveform to learn what values the test set returns after performing the Phase and Amplitude measurement on a continuous waveform calibration signal generated from a mobile station.

Phase and Amplitude versus Time Measurement Results

The test set returns the Phase and Amplitude versus Time measurement results via the GPIB interface only. The Phase and Amplitude versus Time measurement results depend on the mobile generated waveform type.

If the waveform you are measuring is a discrete waveform, see Phase and Amplitude Measurement Results for a Discrete Waveform .

If the waveform you are measuring is a continuous waveform, see Phase and Amplitude versus Time Measurement Results for a Continuous Waveform .

Phase and Amplitude Measurement Results for a Discrete Waveform

This section only applies when the Waveform Type parameter is set to DISCrete .

You can configure the test set to return Phase and Amplitude versus Time measurement results in three different formats (result types):

  • PCAL Measurement Results
  • Sample Measurement Results
  • Both Measurement Results

PCAL Measurement Results

This section only applies when the Result Type parameter is set to PCAL, and when the Waveform Type is Discrete.

The results that the test set returns are an integrity indicator for the entire measurement, followed by power, phase, and frequency measurement results for specified intervals. The power, phase, and frequency results for the first measurement interval are slightly different than the rest. The first measured power result is an absolute power measurement, the first phase result is set to 0×, and the first frequency result is the offset relative the expected input frequency (which is set using the GPIB command RFANalyzer:MANual:MEASurement[:MFRequency] ). A negative frequency result indicates the first measurement interval is below the expected input frequency, and a positive result indicates the first measurement interval is above the expected input frequency.)

The results from the first measurement interval are returned as the first element in the returned power, phase and frequency arrays, respectively. All subsequent measurement results are relative to the results of the first measurement interval. Therefore, the results of the measured power level, phase, and frequency of the second measurement interval are given relative to the power level, phase, and frequency of the first measurement interval.

The Phase and Amplitude versus Time measurement completes without returning a 5 (Over Range) or 6 (Under Range) integrity indicator as long as the measured power is within +/-6 dB of the expected power for that burst. However, measurement accuracy is warranted only if the measured power is within 3 dB of the expected power.

All results returned from the test set in the power, phase, and frequency arrays are measured relative to the measurement results of the initial measurement interval. If you send a GPIB query for all the results, the results are returned in the following order: integrity indicator, power measurement results array, phase measurement results array, and frequency measurement results array. Alternatively, you can independently query the test set for the integrity indicator, or any of the individual result arrays. The maximum power, phase, and frequency array size the test set returns is 512.

The GPIB query to retrieve the results from the test set a listed in the following table.

Results | GPIB Query
Measurement Integrity Indicator | FETCh:PCALibration:INTegrity?
Power Array | FETCh:PCALibration:POWer?
Phase Array | FETCh:PCALibration:PHASe?
Frequency Array | FETCh:PCALibration:FERRor?
All (Integrity Indicator, Power Array, Phase Array, Frequency Array) | READ:PCALibration[:ALL]? or FETCh:PCALibration[:ALL]?

Sample Measurement Results

This section only applies when the Result Type parameter is set to SAMPle , and the Waveform Type is DISCrete ., or when the Waveform Type is CONTinuous or CONT2 .

There is one integrity indicator for the entire measurement. The Phase and Amplitude versus Time measurement completes without returning a 5 (Over Range) or 6 (Under Range) integrity indicator as long as the measured power is within +/-6 dB of the expected power for that burst. However, measurement accuracy is warranted only if the measured power is within 3 dB of the expected power. You can obtain this result using the FETCh:PCALibration:INTegrity? command.

The following values are returned by the test set for each sample point.

  • Amplitude (normalized*)

    You can obtain these results using the FETCh:PCALibration:SAMPle:AMPLitude? <range> command.

    *If you wish to convert the data results to have units of mW, you must square the data results. For example, if the test set returns an amplitude value of 10 this corresponds to 100 mW (since 10^2=100). Alternatively, if you wish to convert the data results to have the units of dBm, you must use the formula 20*log10(normalized voltage). For example if the test set returns an amplitude value of 10 this corresponds to 20 dBm (since 20*log10(10)=20).

  • Phase (degrees)

    You can obtain these results using the FETCh:PCALibration:SAMPle:PHASe? <range> command.

    The Amplitude and Phase results are returned in groups of 1000 amplitude and phase pairs. The Measurement Sample Count (total number of amplitude and phase pairs) can be queried using the command FETCh:PCALibration:SAMPle:COUNt? . Therefore, the total number of groups that the results are divided among is the (Measurement Sample Count plus 0.5)/1000 rounded up to the nearest integer value. (Where the 0.5, or half a pair, is due to the integrity indicator.) The maximum Measurement Sample Count is 5000.

Both Measurement Results

This section only applies when the Result Type parameter is set to BOTH , and the Waveform Type is DISCrete.

This result type is a combination of the PCAL and Sample result types. The following values are returned by the test set:

  • Integrity Indicator, Power (dB), Phase (degrees), and Frequency (Hz) -See PCAL Measurement Results
  • Integrity Indicator, Amplitude (normalized*), and Phase (degrees) of each sample point -See Sample Measurement Results .

Phase and Amplitude versus Time Measurement Results for a Continuous Waveform

This section is only applicable when the Waveform Type is CONTinuous , CONT2 . or CONT3

The Phase and Amplitude versus Time measurement results for a Continuous Waveform Calibration Signal are returned in the same format as the results for a Discrete Waveform Calibration Signal when the Result Type is set to SAMPle.

See Sample Measurement Results for more information on what measurement results the test set returns for a Continuous Waveform Calibration Signal.

Interpreting Integrity Indicators

Common integrity indicators:

  • 0: Normal measurement completion.
  • +2: Measurement timeout.
  • +5: Over range.
  • +6: Under range.
  • +13 Unidentified Error. (Some or all of the results are not available. The measurement algorithm was not able to converge; this usually occurs because a portion of the input signal is too low.)
  • +21 Parameter Error.

For more information see Integrity Indicator .

Phase and Amplitude versus Time Input Signal Requirements

The Phase and Amplitude versus Time measurement has the following input signal requirements:

  • Frequency: 292.5 MHz to 2700 MHz
  • Input Signal Level: -20 dBm to +35 dBm

Calibrating the Phase and Amplitude versus Time Measurement

This measurement automatically calibrates the phase and amplitude results when the waveform type is DISCrete or CONTinuous. However, to ensure triggering accuracy when the trigger source is set to RF Rise, you must run the Spectrum Monitor Calibration at least once a month.

This measurement is not automatically calibrated when the waveform type is CONT2 or CONT3; it relies on the Spectrum Monitor calibration factors.

See Recommended Calibration Intervals for more information on when the Spectrum Monitor calibration should be performed.

Related Topics

Spectrum Monitor Calibration

Programming a Phase and Amplitude vs. Time Measurement (Discrete Waveform)

Programming a Phase and Amplitude vs. Time Measurement (CONTinuous Waveform)

Programming a Phase and Amplitude vs. Time Measurement (CONT2 Waveform)

SETup:PCALibration

FETCh:PCALibration

Phase and Amplitude versus Time Troubleshooting


Phase and Frequency Error Measurement Description

Phase and Frequency Error Measurement Description

How is a phase and frequency error (PFER) measurement made?

The PFER measurement performs a narrow-band (<200 kHz) measurement of the modulation quality and frequency accuracy of the mobile station's transmitter. The test set measures frequency error, rms phase error and peak phase error over the useful part of the burst.

The PFER measurement demodulates the data and compares the measured wave form with the "ideal" waveform that was expected for the data received. The frequency error is the difference in frequency, after adjustment for the effect of the modulation and phase error, between the RF transmission from the mobile station and the test set. The phase error is the difference in phase, after adjustment for the effect of the frequency error, between the mobile station and the theoretical "ideal" transmission. This measurement conforms to ETSI GSM 05.05; and ETSI GSM 11.10, section 13.1.

The PFER measurement demodulates the guard bits according to the Tail Bit Demodulation parameter setting. This parameter determines how the PFER measurement performs demodulation on the guard bits, which in turn impacts the demodulation of the tail bits. For details on the settings available for this parameter, see SETup:PFERror:TBDemod .

You can measure one of the six adjacent uplink bursts of the multislot configuration at any one time. You can specify the burst to measure using CALL:(PDTCH|PDTChannel):MSLot:MEASurement:BURSt . The relative power level is within 30dB according the data sheet.

For GPRS mobiles, this measurement conforms to ETSI GSM 05.05 (Ver 8.2.0, 7.2.0, 6.6.0), section 4.6.1. It also conforms with 3GPP 51.010 (formerly ETSI GSM 11.10) if used as part of a type approval system.

For EGPRS mobiles, the Phase and Frequency Error measurement conforms to 3GPP 51.010 (formerly ETSI GSM 11.10), section 13.16.1. You can control the modulation and coding scheme (either 8PSK or GMSK modulation) used by the data connection to be measured using CALL:(PDTCH|PDTChannel):MCSCheme . Additionally, you can manually control what modulation should be expected for individual bursts using CALL:MODulation[:FORMat]:CONTrol:AUTO . See Modulation Format Control (EGPRS only) for more information.

The PFER measurement is controlled by the DSP in the test set. No calibration is required by the user, the DSP gets calibration information during test set power up. PFER measurements can be initiated with any measurement made by the test set.

Single or Multi-Measurements

The DSP demodulates the data and compares the measured waveform with the "ideal" waveform created by the DSP.

A single burst for a PFER measurement calculates the following:

  • peak phase error
  • rms phase error
  • frequency error

A multiple burst PFER measurement is made when the multi-measurement state is on and calculates the maximum, minimum and average values for the following:

  • peak phase error
  • rms phase error
  • frequency error
  • worst frequency error (worst frequency error is the frequency furthest from zero.)

All of these results are available using the FETCh command. If the most positive and the most negative frequency error are the same value, the most positive frequency will be returned. Worst frequency error is only accessible through GPIB. The test set always has an integrity indicator available regardless of whether it is a single or multiple burst measurement.

Types of Signals PFER can Measure

PFER measurements can be made on these types of input signals.

  • Normal GSM TCH or GPRS PDTCH burst with mobile station in active cell mode.
  • Normal EGPRS PDTCH burst when the operating mode is set to active cell mode and the serving cell is set to EGPRS.
  • Access (RACH) burst with mobile station in active cell mode.
  • Normal GSM TCH or GPRS PDTCH burst with mobile station in test mode.
  • Normal EGPRS PDTCH burst when the operating mode is set to EGPRS BCH+PDTCH.
  • Access (RACH) burst with mobile station in test mode.
  • Bursted signal with GMSK modulation without a valid midamble.

Input Signal Requirements

The PFER measurement will complete and meet its accuracy specification of:

  • Frequency error measurement accuracy of +/-12 Hz + timebase reference (+/-18 Hz for RACH bursts).
  • rms phase error measurement accuracy of less than +/-1 degree.
  • Peak phase error measurement accuracy of less than +/-4 degrees.

under these conditions:

  • Level is between -15 dBm and +43 dBm.
  • Level within +/-3 dB of the expected input level.
  • Frequency is within +/-100 kHz of expected input frequency when serving cell is set to GSM or GPRS. The capture range is +/-1 kHz when the serving cell is set to EGPRS. See Serving Cell for more information about the different serving cells.

Trigger Source

Auto triggering is the recommended trigger source for each measurement allowing the test set to choose the preferred trigger source. However, you may want to select the trigger source. Immediate trigger source is not recommended for PFER measurements.

Recommended Trigger Source settings
Input Signal Type | Recommended Trigger Source
Normal GSM TCH or GPRS PDTCH burst with mobile station in active cell mode | Protocol or RF Rise
Normal EGPRS PDTCH burst with mobile station in active cell mode and modulation coding scheme set to MCS1, MCS2, MCS3, or MCS4 | Protocol or RF Rise
RACH burst with mobile station in active cell mode (GSM only) | Protocol or RF Rise
Normal GSM TCH or GPRS PDTCH burst with mobile station in test mode | RF Rise
Normal EGPRS PDTCH burst with mobile station in test mode and modulation coding scheme set to MCS1, MCS2, MCS3, or MCS4 | RF Rise
RACH burst with mobile station in test mode (GSM only) | RF Rise
Bursted signal with GMSK modulation but no valid midamble | RF Rise
Non-bursted (CW) signal with a manual frequency offset of +/- 67.7083 kHz | Immediate

Burst Synchronization

The PFER measurement provides you with a choice for the time reference (burst synchronization). (See Burst Synchronization of Measurements ). For GPRS and EGPRS mobiles, you should note that only the Midamble synchronization method is available when you set the multislot configuration to D2U2 (2 downlink timeslots, 2 uplink timeslots). For more details on setting the multislot configuration, see CALL:(PDTCH|PDTChannel):MSLot:CONFig .

Burst Synchronization | Description
Midamble | References measurement timing to the midamble transmitted within a timeslot.
RF Amplitude | The amplitude rise and fall of a transmitted burst determines the measurement time reference.
None | No edge of the burst is detected, the measurement is made using the first 87 or 147 bits of data found centered around the middle of the expected burst position. Can be used when measuring non-bursted signals

Operating Considerations

As the uplink burst number increases, the measurement speed is expected to decrease.

Related Topics

Programming a Phase and Frequency Error Measurement


Power versus Time Measurement Description

Power versus Time Measurement Description

The Power versus Time Measurement is applicable to GSM/GPRS/EGPRS lab application and a test application with the required license.

  • How is a Power versus Time (PvT) measurement made?
  • Power vs. Time Parameters
  • Power versus Time Measurement Results
  • Power vs. Time Input Signal Requirements

How is a Power versus Time (PvT) measurement made?

PvT measurements determine if the mobile station's transmitter power stays within specified power and timing ranges. Refer to the Typical GSM PvT Measurement and Typical PvT Mask for a Two Burst Multislot Configuration .

During a PvT measurement, the test set makes a narrowband point-by-point measurement of the instantaneous power received during the signal burst as it varies across a single burst or up to six adjacent modulated TDMA bursts. The Burst Capture Range parameter determines the maximum number of TDMA bursts that the PvT measurement can measure. When the Burst Capture Range is set to Single , the PvT measurement can measure up to 2 adjacent modulated TDMA bursts. When the Burst Capture Range is set to All , the PvT measurement can measure up to 6 adjacent modulated TDMA bursts. A single pass or fail result is returned for the entire multislot configuration. This means that if any part of the multislot configuration fails the multislot mask, the result is a Fail. Additional information is provided to indicate which segments of the multislot configuration have failed.

Included with the narrowband measurement are broad-band carrier power measurements, labeled as Transmit Power on the Burst Numeric Results screen. The PvT Transmit Power measurement is synchronized to the burst midamble as recommended in 3GPP 51.010 (formerly ETSI GSM 11.10). (The test set also provides a faster transmit power measurement that is synchronized to the burst's amplitude. See Transmit Power Measurement Description ).

You can also control the modulation and coding scheme (either 8PSK or GMSK modulation) used by the data connection to be measured using CALL:(PDTCH|PDTChannel):MCSCheme . Additionally, you can manually control what modulation should be expected for individual bursts using CALL:MODulation[:FORMat]:CONTrol:AUTO . See Modulation Format Control (EGPRS only) for more information.

This measurement conforms to ETSI GSM 05.05 (Ver 8.2.0, 7.2.0, 6.6.0), section 4.5 and Annex B. It will also conform with 3GPP 51.010 (formerly ETSI GSM 11.10) if used as part of a type approval system.

Types of Signals Power vs. Time Can Measure

The following list summarizes the input signal attributes for making PvT measurements.

  1. A Single normal burst, or up to 2 normal bursts when Burst Capture Range is set to Single.

  2. A Single normal burst, or up to 6 normal bursts when Burst Capture Range is set to All.

  3. GSM RACH burst when Burst Capture Range is set to Single.

  4. CW signals.

For details on the multislot configurations which the test set supports, see CALL:(PDTCH|PDTChannel):MSLot:CONFig .

Typical GSM PvT Measurement

Typical PvT Mask for a Two Burst Multislot Configuration

Operating Consideration

You can perform the PvT measurement in all operating modes except Cell Off and Fast Device Tune . However, you must set the modulation format and the expected power correctly in order to get the accurate power result of the measured bursts. See "Expected Power Control" on page 6 and "Modulation Format Control (EGPRS only)" on page 10 to find how to set the modulation format and the expected power.

In the Active Cell mode, the test set automatically passes the Training Sequence Code (TSC) to the measurement with no action required by you. However, you must specify the TSC manually in the test mode.

The dynamic range of the PvT measurement is approximately 70 dB.

Power vs. Time Parameters

  • Burst Capture Range

    This parameter determines whether the uplink burst are captured individually or simultaneously during the PvT measurement. The default value for this parameter is Single . When Burst Capture Range is set to Single , the PvT measurement can measure up to two bursts, which are captured in two TDMA frames. When Burst Capture Range is set to ALL , the PvT measurement can measure up to six bursts, which are captured in one TDMA frame.

    The GPIB command to set this parameter is SETup:PVTime:BURSt:CAPTure .

  • Burst Synchronization

    The PvT measurement provides you with a choice for the time reference setting (burst synchronization) for a single uplink burst. In the case of measuring multiple uplink bursts the burst synchronization is fixed to Midamble. If a valid midamble cannot be found, the measurement will complete on a best effort basis using RF Amplitude synchronization. See Burst Synchronization of Measurements .

    Burst Synchronization

            Description

    Midamble

             References measurement timing to the midamble transmitted within a timeslot.

    RF Amplitude

             The amplitude rise and fall of a transmitted burst determines the measurement time reference.

    None

             No edge of the burst will be detected, the measurement will be made using the first 87 or 147 bits of data found centered around the middle of the expected burst position. None may be used when measuring non-bursted (CW) signals.

    Note, the Burst Synchronization is set to Midamble and can not be changed in the following scenarios:

    • When measuring multi-bursts.
    • The Burst Capture Range is set to All.
    • The operating mode is Active cell (EGPRS), EGPRS BCH, EGPRS BCH+TCH, or EGPRS BCH+PDTCH+TCH.

    The GPIB command to set this parameter is SETup:PVTime:BSYNc or SETup:PVTime:SYNC .

  • Graph Power Reference

    This parameter determines which burst's Transmit Power is used as the reference value for the PvT graph. This value will effect the results from the FETCh:PVTime:SECTion and FETCh:PVTime:TRACe commands.

    Note, when Burst Capture Range is set to SINGle , setting Power Reference to Burst 3 to 6 will cause "Illegal parameter value" error.

    The GPIB command to set this parameter is: SETup:PVTime:GRAPh:POWer:REFerence

  • Graph State

    This command is used to turn on or off the PvT Measurement graphics state. Setting the Graph State to ON does not automatically force the graphical view to be displayed. You should manually change the view to Graph. Noted that turning the graph state to ON will slow the measurement.

    The GPIB command to set this parameter is: SETup:PVTime:GRAPh:STATe

  • Graph Time Reference

    This command is used to determine which burst is used as the time reference for the graph.

    Note, when Burst Capture Range is set to SINGle , setting Power Reference to Burst 3 to 6 will cause "Illegal parameter value" error.

    The GPIB command to set this parameter is: SETup:PVTime:GRAPh:TIME:REFerence

  • Log Detector Video Filter

    This parameter allows you to choose a filter to apply to the log-detector (LD) trace output. You can select a 1MHz Video Bandwidth Filter or a 300kHz filter. The default setting is 1MHz Video Bandwidth Filter. 300KHz Filter can helps you to filter out more noise. However the 300KHz filter is only applicable to GMSK modulated signals.

    This parameter can only be set via GPIB command.

    The GPIB command to set this parameter is: SETup:PVTime:VIDeo:FILTer:BWIDth

  • Mask Type

    This parameter allows you to select the type of mask to be used for a specified burst.

    There will be four independent mask definitions available:

    • One fixed GMSK Mask according to ETSI GSM 05.05 v8
    • One fixed 8-PSK Mask according to ETSI GSM 05.05 v8
    • Two custom Masks configurable by the user

    The first two masks are configured according the ETSI GSM 05.05 v8. These two fixed masks are selectable through the Mask Type ETSI, have a fixed length and can not be modified by the user. The two custom masks are of variable size and user settable, you can specify up to a maximum of 32 upper points and 32 lower points to define a custom mask.

    The GPIB command to set the Mask type is: SETup:PVTime[:BURSt[1]]:MASK[:SELected] or SETup:PVTime:BURSt2|3|4|5|6:MASK[:SELected] .

    The GPIB commands to set the lower limits for the specified custom mask are SETup:PVTime:CUSTom1:MASK:LOWer? and SETup:PVTime:CUSTom2:MASK:LOWer? . Use SETup:PVTime:CUSTom1:MASK:LOWer:POINts? and SETup:PVTime:CUSTom2:MASK:LOWer:POINts? to query the number of reference points for the specified user settable lower mask.

    The GPIB commands to set the upper limits for the specified custom mask are SETup:PVTime:CUSTom1:MASK:UPPer? and SETup:PVTime:CUSTom2:MASK:UPPer? . Use SETup:PVTime:CUSTom1:MASK:UPPer:POINts? and SETup:PVTime:CUSTom2:MASK:UPPer:POINts? to query the number of reference points for the specified user settable upper mask.

  • Measurement Offsets

    The PvT measurement has a fixed number of twelve offset settings for every active burst of the TDMA frame, up to 6 uplink time slots (only when capture mode is set to ALL ). Each burst's offset times are referenced to the centre of symbol 0 for that burst (the start of the useful part of the burst). A single reference point for a multislot configuration is not used because the measurement may be made in two separate passes and the guard period between bursts can vary in length.

    The GPIB command to set this parameter is: SETup:PVTime[:BURSt[1]]:TIME[:OFFSet][:SELected] or SETup:PVTime:BURSt2|3|4|5|6:TIME[:OFFSet][:SELected]

  • Measurement Timeout

    You can set the timeout state and time for this measurement. To set them separately, use SETup:PVTime:TIMeout:STATe to set the timeout state, SETup:PVTime:TIMeout:TIME to set the timeout time; use SETup:PVTime:TIMeout[:STIMe] to set the state and time simultaneously.

  • Multi Measurement

    You can set Multi-Measurement state and count for the PvT measurement. If Multi-Measurement State is On , Multi-Measurement Count determines how many measurements are to be performed for a measurement request. If Multi-Measurement State is Off , no Multi-Measurement are performed.

    The PvT measurement use the standard Multi-Measurement implementation. Each Multi-Measurement returns the average value, maximum value, minimum value and standard deviation for the number of counts selected. No intermediate results are returned during a Multi-Measurement.

    Multi-Measurement count specifies how many loops are measured for a measurement request.

    To set Multi-Measurement state and count separately, use SETup:PVTime:COUNt:STATe to set the Multi-Measurement state, SETup:PVTime:COUNt:NUMBer to set the Multi-Measurement count; use SETup:PVTime:COUNt[:SNUMber] to set the state and count simultaneously.

  • Ranging Mode

    This parameter is only applicable when measuring two bursts and the Burst Capture Range is set to Single.

    The Ranging Mode parameter helps you to strike a balance between dynamic range and Linearity. There are two Ranging Modes available:

    • High Linearity Mode (HLINear)

      The High Linearity Mode ensures the accuracy of the PvT trace during the active part of the burst at the expense of some loss in dynamic range.

    • High Dynamic Range Mode (HDynamic) The High Dynamic Range Mode gives you the full dynamic range but the power result slightly higher at the front and the end of the burst.

    The GPIB command to set this parameter is SETup:PVTime:RANGing[:MODE]

  • Trigger Arm

    Trigger arm can be set to Single or Continuous , See Trigger Arm (Single or Continuous) Description for more information.

    The GPIB command to set this parameter is SETup:PVTime:CONTinuous[:SELected] .

  • Trigger Delay

    This is the specified time between the trigger event and when the test set begins sampling data. See Trigger Delay Description for more information.

    The GPIB command to set this parameter is SETup:PVTime:TRIGger:DELay .

  • Trigger Source

    The triggering choices available for the PvT measurement are RF rise, protocol, immediate, and auto. In most cases, auto triggering provides the optimum measurement triggering condition for the PvT measurement.

    When auto triggering is selected, the test set chooses a trigger source based on the optimum trigger source available. For example, PvT measurements are automatically triggered by a protocol trigger if a data connection is established or data connection processing events provide the protocol trigger source.

    In situations where no protocol trigger is available, the test set chooses RF rise triggering for the PvT measurement. An example of this situation is when the test set is in one of the test mode operating modes.

    Recommended Trigger Source
    Operating mode

    Recommended Trigger Source
    Active Cell

    RF Rise or Protocol

    Note: RF Rise should be selected when measuring bursted signal with no valid midamble.

    Test mode

    RF Rise
    CW signal

    Immediate

    For more information on measurement triggering, refer to Triggering of Measurements .

    The GPIB command to set this parameter is SETup:PVTime:TRIGger:SOURce

  • TX Power Method

    This parameter allows you to select the transmit power measurement method for an 8PSK modulated signal.

    In EGPRS operating mode, there are two methods to determine the transmit power of an 8PSK modulated signal: Burst Power and Estimated Carrier Power.

    • Burst Power

      This is the average power measured across a single timeslot. This value varies as a function of the modulating data.

    • Estimated Carrier Power

      This is an estimate of the power of the unmodulated carrier. The Estimated Carrier Power is equivalent to the Long Term Average Power which is the primary definition of 8PSK power in the ETSI standards. Long Term Average Power is the average power of many individual bursts when the individual bursts are modulated with PRBS data. The Estimated Carrier Power measurement uses knowledge of the modulating data to determine the carrier power from the power measurement.

    The GPIB command to set this parameter is: SETup:PVTime:ETXPower[:METHod]

Power versus Time Measurement Results

The primary result of a PvT measurement is the pass/fail result. The pass/fail result that the test set returns indicates whether the entire multislot configuration falls within power and timing ranges determined by a point-by-point comparison of the power versus time measurement mask.

The PvT measurement examines the multislot configuration to determine the points which have failed the most, or the points which are closest to failing the upper and lower limits. These worst case points provide the upper and lower limit margin results. A negative value, along with the offset time, is returned for the result if the multislot configuration fails the mask. A positive value indicates the multislot configuration is within the mask. The command FETCh:PVTime[:BURSt[1]]:MASK:ALL? and FETCh:PVTime:BURSt2|3|4|5|6:MASK:ALL? are used to return these values for the burst you specify.

For statistical analysis, the test set allows you to set up to 12 time markers per burst. These markers do not define the mask, but are merely used to get results from specified points on the mask. To set these markers you can use SETup:PVTime[:BURSt[1]]:TIME[:OFFSet][:SELected] and SETup:PVTime:BURSt2|3|4|5|6:TIME[:OFFSet][:SELected] . Note that these points are a subset of those used in the point-by-point comparison which determines the pass/fail result.

The Power versus Time measurement allows you to use the ETSI mask specification or define up to two custom masks of your own. For more information refer to Mask Type .

The following lists show the results available for single measurements, multi-measurements and statistical measurements:

  • Results for a single PvT measurement are listed below. Results 1 through 6 can be obtained using the query FETCh:PVTime[:BURSt[1]][:ALL]? and FETCh:PVTime:BURSt2|3|4|5|6[:ALL]? . Results 6 through 9 can be obtained using the query FETCh:PVTime[:BURSt[1]]:MASK:ALL? and FETCh:PVTime:BURSt2|3|4|5|6:MASK:ALL? .

    1. PvT measurement integrity indicator for each burst in the multislot configuration

    2. PvT multislot mask pass/fail result (0 = Pass, 1 & NaN = Fail)

    3. Transmit power with midamble synchronization (average power during the burst) for each burst in the multislot configuration

    4. PvT maximum power at up to 12 time offsets

    5. PvT mask error code (this indicates which parts of the multislot configuration are causing failure). For more details on the mask error code result see FETCh:PVTime:MASK[:FAIL]:SEGment? .

    6. Upper limit power margin worst case for each burst in the multislot configuration (how close to or where the signal exceeded upper power limit)

    7. Upper limit timing margin worst case for each burst in the multislot configuration (the time offset where the signal came close to or exceeded upper timing limit)

    8. Lower limit power margin worst case for each burst in the multislot configuration (how close or where the signal exceeded lower power limit)

    9. Lower limit timing margin worst case for each burst in the multislot configuration (the time offset where the signal came close to or exceeded lower timing limit)

  • In addition to the results you can obtain for a single measurement the following results are also available for multi-measurements . These results can be obtained using the query FETCh:PVTime[:BURSt[1]]:TXPower[:CARRier]:ALL? and FETCh:PVTime:BURSt2|3|4|5|6:TXPower[:CARRier]:ALL? .

    1. Minimum transmit carrier power measured across each burst

    2. Maximum transmit carrier power measured across each burst

    3. Average of transmit carrier power measurements (average of averages) for each burst in the multislot configuration

    4. Standard deviation of transmit carrier power measured across each burst

  • Statistical PvT measurement results, calculated from measurements taken at each of the active time offset markers or across a subset of the markers and available only through programming commands are listed below. These results can be obtained using the FETCH:PVTime[:BURSt[1]]|BURSt2|BURSt3|BURSt4|BURSt5|BURSt6:POWer queries.

    1. Average Power (in dBc) measured at the marker(s) relative to transmit power (carrier power)

    2. Maximum power (in dBc) measured at the marker(s) relative to transmit power (carrier power)

    3. Minimum power (in dBc) measured at the marker(s) relative to transmit power (carrier power)

    4. Standard deviation of power (in dBc) measured at the marker(s) relative to transmit power (carrier power)

  • The measurement integrity indicator is another result available for any completed PvT measurement. This result provides information about error conditions which occurred and may have affected the accuracy of the most recently completed measurement. For more information about measurement integrity, refer to Integrity Indicator .

  • The measurement progress report is a feature that allows you to periodically see how far a multi-measurement cycle has progressed. When the multi-measurement count is greater than 1, the progress report indicates the number of individual sub-measurements that have been completed, n , out of the total number to be completed, m . "n" is referred to as ICOunt remotely. "m," the total number of measurements to be made, is based on the PvT settings you make and the input signal attributes.

    The progress report is displayed on the test set's screen in an "n of m" format. The number of measurements completed, n , increases from zero to the total number of measurements which need to be made, m .

Power vs. Time Input Signal Requirements

The PvT measurement will complete and meet the PvT measurement accuracy specifications when the signal meets the following input signal conditions.

  1. Input signal level is between -15 dBm and +37 dBm for GPRS or between -15dBm and +33dBm for EGPRS.

  2. Input signal level is within +/-3 dB of expected input level.

Related Topics

How Do I Make a Power Versus Time Measurement?


RACH Measurement Description

RACH Measurement Description

What is a RACH?

The RACH (Random Access Channel) is used by the mobile station to request a dedicated channel from the base station. The RACH is sent on the random access burst which is the first burst sent to the base station by the mobile station when a call origination or data connection is attempted. The random access burst is only 312.2 us as opposed to the normal GSM burst of 542.8 us.

Measurements that can be performed on a RACH

The test set can perform the following three measurements on a RACH in Active Cell or a test mode:

  • Power versus Time
  • GSM/GPRS Transmit Power
  • Phase and Frequency Error

NOTE
Only one measurement at a time can be made on the RACH even if two measurements are initiated.

Triggering

The type of triggering used is dependent on whether you are in Active Cell or Test mode:

Active Cell mode:
The default triggering of Auto is acceptable for most signals. (In Active Cell mode Auto is equivalent to Protocol.) However, if the mobile's RACH timing is outside the specified limits you may need to use RF Rise triggering.

Test mode:
The default triggering of Auto should be used. (Trigger Auto is equivalent to RF Rise in a test mode.)

Related Topics

How do I Make Rach Measurements?


SINAD Measurement Description

SINAD Measurement Description

This measurement is not applicable to GPRS.

How is a SINAD measurement made?

SINAD is one of four measurements available from the Analog Audio measurement. However, SINAD measurements are not typically made when testing GSM mobiles but are more common when testing AMPS or other analog mobiles.

SINAD is a receiver audio quality measurement for mobiles. It is the ratio of Signal+Noise+Distortion divided by Noise+Distortion, expressed in dB. SINAD can be measured in the range of 100 Hz to 10 kHz.

The SINAD measurement is used to determine receiver RF sensitivity. SINAD is usually measured in either of two ways:

  • Reduce the Cell Power from the test set until 12 dB SINAD is displayed (re-triggering for each measurement), or
  • Set the Cell Power from the test set to a specified low level and verify a >=12 dB SINAD reading.

Difference in Agilent 8960 Series 10 and 8920B Test Set SINAD Measurements

If you have previously used the Agilent 8920B RF Communications Test Set to measure SINAD, you may notice that the Agilent 8960 Series 10 test set's SINAD value may be higher by up to 0.8 dB when measuring 12 dB SINAD. This is due to the more precise digital notch filter used by the Agilent 8960, allowing a more accurate noise measurement to be made. The Agilent 8920B uses an analog filter that does not have as precise a filter notch as the Agilent 8960.

Related Topics

Programming a SINAD Measurement


Spectrum Monitor Description

Spectrum Monitor Description

How is the spectrum monitor (SMON) used?

The Spectrum Monitor (SMON) can be used to locate, identify and measure transmitted signals from a device under test. The Spectrum Monitor can be used while a call is in progress.

The Spectrum Monitor is intended to be used for indication only. The Spectrum Monitor does not have the same level accuracy specifications as other measurements provided by the test set, and should therefore not be used when parametric accuracy is required (for example, calibration of a mobile). It is recommended that you use the other wireless format-specific measurements when you require accurate parametric measurements.

From the test set's front panel, the Spectrum Monitor can be accessed by pressing the Instrument Selection key, then selecting Spectrum Monitor . If you require more details on manual operation of the Spectrum Monitor, see How Do I Use the Spectrum Monitor? .

The Spectrum Monitor has the following two modes of operation:

  • Swept mode, in which the X axis represents frequency , and the Y axis represents absolute amplitude.
  • Zero span mode, in which the X axis represents time and the Y axis represents absolute amplitude.

You can use the markers on the Spectrum Monitor's graphical display to set the expected frequency and power levels that are used by the test or lab application for parametric measurements.

The center frequency used by the Spectrum Monitor is initially set at the expected frequency maintained by the test set's base station emulator. The expected frequency range is 292.5 MHz to 2700 MHz.

The range of frequencies which the spectrum monitor is calibrated to measure is determined by the range of traffic band frequencies supported by the specific test or lab application that is currently running. For example, if you are using the GSM Test Application, any of the frequencies used by the GSM traffic bands are available for you to monitor accurately. You can view signals which fall outside of any of the frequencies used by GSM, but the Spectrum Monitor will not be calibrated.

Detection Method

Frequency binning is used when the Spectrum Monitor divides the frequency span by the number of display points such that each bin contains a segment of the frequency span. Within each frequency bin, a single value representing each frequency bin is displayed on the test set's screen. The algorithm used to find the value that represents each frequency bin is determined by the detection method. There are three detection methods available in the test set's Spectrum Monitor:

  • Peak Detection

    The largest spectral component in the frequency bin is used to represent each bin.

  • Sample Detection

    The last spectral component in the frequency bin is used to represent each bin.

  • RMS Detection

    The sum of the power across the frequency bin is used to represent each bin.

The command to change the detection method is SETup:SMONitor:DETector[:TYPE] .

Resolution Bandwidth and Frequency Span

The resolution bandwidth can be used to resolve two or more closely spaced signals as long as the resolution bandwidth is less than the difference between the spectral components. A resolution bandwidth greater than or equal to the signal bandwidth can be used to measure the total power of a signal.

Refer to Table 1: Frequency Span, Resolution Bandwidth and Dynamic Range below. When the Resolution Bandwidth Coupling State is OFF, the Frequency Span and the Resolution Bandwidth can be set to any value in their respective columns, and Resolution Bandwidth setting determines the Displayed Dynamic Range. When the Resolution Bandwidth Coupling State is On, the Resolution Bandwidth and Displayed Dynamic Range settings are coupled with the Frequency Span setting. For example, if the Frequency Span is 100 MHz, the test set automatically sets the Resolution Bandwidth to 5 MHz and the Displayed Dynamic Range to 55 dB.

Table 1: Frequency Span, Resolution Bandwidth and Dynamic Range
Frequency Span | Resolution Bandwidth | Displayed Dynamic Range
100 MHz | 5 MHz | 50 dB
80 MHz | 1 MHz | 55 dB
40 MHz | 300 kHz | 60 dB
20 MHz | 100 kHz | 65 dB
12 MHz | 100 kHz | 65 dB
10 MHz | 100 kHz | 65 dB
5 MHz | 30 kHz | 70 dB
4 MHz | 30 kHz | 70 dB
2.5 MHz | 10 kHz | 75 dB
1.25 MHz | 3 kHz | 80 dB
500 kHz | 1 kHz | 80 dB
125 kHz | 300 Hz | 80 dB
0 Hz (zero span mode) | 100 kHz | 65 dB
 | 300 kHz | 60 dB
 | 1 MHz | 55 dB

The command to set the Resolution Bandwidth Coupling State is SETup:SMONitor:BANDwidth|BWIDth:AUTO .

The command to set the Resolution Bandwidth is SETup:SMONitor:BANDwidth|BWIDth:MANual , and the command to set the Frequency Span is SETup:SMONitor:FREQuency:SPAN .

Single or Multi-Measurements

The Spectrum Monitor can return either single or averaged results.

  • If you set the averaging state OFF then the trace represents a single measurement sweep.

  • If you set the averaging state ON, and the averaging count number to a value greater than one, then the trace represents the rolling average of the specified number of sweeps.

Input Signal Requirements

The Spectrum Monitor will complete and meet its accuracy specifications under the following input signal conditions.

  • The signal is within 40 dB of the reference level.
  • The measurement frequency is within the traffic band frequencies supported by the specific lab or test application that is currently running, and the expected frequency is tuned to the carrier.

Trigger Source

Triggering choices available for the Spectrum Monitor are Immediate, Protocol, RF Rise, and External.

For more information on measurement triggering, refer to Triggering of Measurements .

Calibrating the Spectrum Monitor

See Spectrum Monitor Calibration .

Related Topics

How Do I Use the Spectrum Monitor?

Programming the Spectrum Monitor

Test Adherence to Standards

Spectrum Monitor Troubleshooting

SETup:SMONitor


What 3GPP TS 05.05 Requirements are supported?

What 3GPP TS 05.05 Requirements are supported?

Last updated: December 3, 2008

This table shows the standard GSM, GPRS, and EGPRS requirements as given in 3GPP TS 05.05 version 8. Shown are test set's measurement capabilities.

X* - Also use an E4438C ESG Vector Signal Generator

X** - Also use an E4445A PSA Spectrum Analyzer

X* - Also use an E4438C ESG Vector Signal Generator

X** - Also use an E4445A PSA Spectrum Analyzer

X* - Also use an E4438C ESG Vector Signal Generator

X** - Also use an E4445A PSA Spectrum Analyzer

Related Topics

Test Adherence to Standards

Power versus Time Measurement Description

Output RF Spectrum Measurement Description

Phase and Frequency Error Measurement Description

Bit Error Measurement

Block Error Measurement


Transmit Power Measurement Description

Transmit Power Measurement Description

The Transmit Power Measurement is applicable to GSM/GPRS/EGPRS lab application and a test application with the required feature license. The EGRS Transmit Power Measurement is applicable to the EGPRS lab application and test application

  • Transmit Power (TXP) Measurement
    • How is a TXP measurement made?
      • TXP Measurement with "Burst Capture Range" set to Single
      • TXP Measurement with "Burst Capture Range" set to All
    • TXP Measurement Parameters
    • TXP Measurement Results
    • TXP Measurement Input Signal Requirements
  • EGPRS Transmit Power (ETXP) Measurement

Transmit Power (TXP) Measurement

How is a TXP measurement made?

TXP measurement provides the Burst Power and Estimated Carrier Power measurements for 8PSK or GMSK modulated signals. You can use Burst Capture Range to configure whether a single uplink burst or all uplink bursts in one TDMA frame are measured during the TXP measurement.

  • TXP Measurement with Burst Capture Range set to Single

    When Burst Capture Range is set to Single , the TXP measurement measures the Burst Power of a single burst (GMSK modulated) at one capture of the TDMA frame, the TXP measurement supports the multislot configuration of up to 2 uplink bursts, but only the burst specified by the Measurement Burst parameter is measured each time.

    In EGPRS Active Cell and Test modes, An `Unsupported Configuration' message is displayed when using the TXP Measurement with Burst Capture Range set to Single . You should use the EGPRS Transmit Power (ETXP) Measurement instead.

    In order to provide you with a very fast TXP measurement the test set measures the power without synchronizing it to the midamble. The measurement is made with RF amplitude synchronization; therefore, the signal does not need to be demodulated to determine the midamble. This technique is different from the TXP measurement defined in 3GPP 51.010 (formerly ETSI GSM 11.10). (See Burst Synchronization of Measurements ). The power versus time measurement provides a carrier power measurement that is synchronized to the burst's midamble, and conforms to 3GPP 51.010 (formerly ETSI GSM 11.10), section 13.3 and 3GPP 51.010 (formerly ETSI GSM 11.10), section 13.16.2. (See Power versus Time Measurement Description for more details.)

    When Burst Capture Range is set to Single , the TXP measurement can be made on the following types of input signals:

    • A multislot configuration with 1 to 2 uplink normal bursts (GMSK modulated).
    • An access (RACH) burst.
    • A CW signal.

  • TXP Measurement with Burst Capture Range set to All

    When Burst Capture Range is set to All , the TXP measurement measures the Burst Power and Estimated Carrier Power of all uplink bursts (either 8PSK or GMSK modulated) at one capture of the TDMA frame. The TXP measurement supports the multislot configuration of up to 6 uplink bursts. You can get the results of up to 6 uplink bursts simultaneously.

    The Burst Power and Estimated Carrier Power results are not specified when using the TXP Measurement with Burst Capture Range set to All . Specified measurement results are only available for single bursts. You should use the "TXP Measurement with "Burst Capture Range" set to Single" for GSM/GPRS, and the EGPRS Transmit Power (ETXP) Measurement for EGPRS in case of measuring a single burst

    When Burst Capture Range is set to All , the Burst Power measurement results (with averaging turned on) conform to ETSI GSM 05.05 (Ver 8), section 4. It also conforms with 3GPP 51.010 (formerly ETSI GSM 11.10) if used as part of a type approval system. The Estimated Carrier Power measurement results meet the accuracy requirements for an estimation technique of long term average power as defined in 3GPP 51.010, annex 5.

    When Burst Capture Range is set to All , the TXP measurement can be made on these types of input signals.

    • A multislot configuration with 1 to 6 uplink normal bursts (GMSK or 8PSK modulated).
    • An access (RACH) burst.

See the following table for instructions on how to properly set the Burst Capture Range and how to select the correct measurement.

 | GSM/GPRS Active Cell and Test Modes | EGPRS Active Cell and Test Modes | CW Operating Mode
Single burst | "TXP Measurement with "Burst Capture Range" set to Single" . | EGPRS Transmit Power (ETXP) Measurement . | "TXP Measurement with "Burst Capture Range" set to Single" .
Multiple bursts | "TXP Measurement with "Burst Capture Range" set to All" . |  | Not applicable.

The TXP measurement is completely controlled by the test set. The power meter used for this measurement is zeroed automatically by the DSP as needed. No temperature dependent calibration is required because temperature compensation in the power detector circuits provide temperature stability.

Operating Consideration

When Burst Capture Range is set to All :

  • You can perform the TXP measurement in all operating modes. However, you must set the modulation format and the expected power correctly in order to get the accurate power result of the measured burst. See "Expected Power Control" on page 6 and "Modulation Format Control (EGPRS only)" on page 10 to find how to set the modulation format and the expected power.
  • In the Active Cell mode, the test set automatically passes the Training Sequence Code (TSC) to the measurement with no action required by you. However, you must specify the TSC manually in the test mode.

The following table lists the behavior differences for different Burst Capture Range settings.

 | TXP Measurement with Burst Capture Range set to Single | TXP Measurement with Burst Capture Range set to All
Supported multislot classes | D1U1,D2U1,D3U1,D4U1,D5U1,D1U2,D2U2,D3U2,D4U2. | D1U1,D2U1,D3U1,D4U1,D5U1,D6U1,D1U2,D2U2,D3U2,D4U2,D5U2,D1U3,D2U3,D3U3,D4U3,D1U4,D2U4,D3U4,D1U5,D2U5,D1U6.
Supported operating modes | All operating modes except Active Cell (EGPRS), EGPRS BCH+PDTCH and EGPRS BCH+TCH+PDTCH . | All operating modes.
Supported modulation formats | GMSK | GMSK, 8PSK
Uplink burst number checking | No | Yes
Modulation format checking | No | Yes
Synchronization method | RF Amplitude | Midamble Sync
Specification | The power measurement results are specified. | The power measurement results are not specified.
CW signal supported | Yes | No

Impact on Other Measurements

The TXP measurement can operate concurrently with other measurements.

TXP Measurement Parameters

  • Auto Range to Highest Burst

    This parameter is only applicable when Burst Capture Range is set to All .

    Note, when Burst Capture Range is set to All , you only need to set the expected power for the highest burst, which is called `highest expected power' in the following descriptions. see Expected Power Control for information on how to set the expected power.

    This parameter determines whether the test set ranges its hardware to the highest power of the input bursts or not. If this parameter set to On , the test set ranges its hardware to the highest input burst before the measurement is performed. The specified accuracy can be achieved when the highest input burst is within the range of -30 dB to +3 dB relative to the highest expected power. If this parameter is set to Off , the test set ranges its hardware according to the highest expected power, but the highest input burst must be within the range of -3 dB to +3 dB relative to the highest expected power to achieve the specified accuracy. The figure below illustrates the ranges of the input burst which can achieve the specified accuracy based on the Auto-Ranging to Highest Burst setting.

    Note that the measurement speed will slow down when the Auto Range to Highest Burst parameter is set to ON .

    The GPIB command to set this parameter is SETup:TXPower:RANGe:AUTO .

    The Ranges of the Highest Input Burst
  • Burst Capture Range

    This parameter determines whether a single uplink burst or all uplink bursts in a multi-slot configuration are measured during the TXP measurement. The default value for this parameter is Single . When Burst Capture Range is set to Single , the TXP measurement measures one burst which is specified by Measurement Burst . When Burst Capture Range is set to ALL , the TXP measurement measures all bursts in one TDMA frame.

    The GPIB command to set this parameter is SETup:TXPower:BURSt:CAPTure .

  • Estimated Carrier Power

    This parameter is only applicable when Burst Capture Range is set to All and the operating mode is Active Cell (EGPRS), EGPRS BCH, EGPRS BCH+PDTCH or EGPRS BCH+TCH+PDTCH ..

    This parameter specifies whether the Carrier Power is calculated. The default value for this parameter is On . This parameter is available only in the EGPRS Active cell and the EGPRS Test mode.

    The table below lists the relationship between Estimated Carrier Power State and the Estimated Carrier Power result displayed on front panel or retrieved by GPIB command.

    Estimated Carrier Power State

    Modulation Format

    Estimated Carrier Power displayed on front panel

    Estimated Carrier Power Retrieved by GPIB command
    On

    8PSK

             Display the Estimated Carrier Power result.

    returned Estimated Carrier Power result.

    On

    GMSK

             Display the Estimated Carrier Power while the result is equal to the Burst Power The returned result is equal to Burst Power.
    OFF

    8PSK

             Display ----

    Not Available (NAN's are returned)
    OFF

    GMSK

             Display the Estimated Carrier Power while the result is equal to the Burst Power

    The returned result is equal to Burst Power.

    The GPIB command to set this parameter is SETup:TXPower:ECPower:STATe .

  • Frame Qualification

    This parameter is only applicable when Burst Capture Range is set to All .

    This parameter is used to determine whether the number of the measured bursts and their modulation formats are correct. When Measurement Frame Qualification is set to On , the measurement checks the number of the measured bursts in a TDMA frame and the modulation format of the input signal. If they don't match the expected value, the samples are discarded and the samplers are re-armed.

    The GPIB command to set this parameter is SETup:TXPower:FRAMe:QUALifier .

  • Measurement Burst

    This parameter indicates which burst in the multislot configuration is measured if the user chooses to measure an individual burst by setting Burst Capture Range to SINGle . Measurement Burst is fixed to 1 when only a single uplink timeslot is present. See How Do I Configure the PDTCH Parameters? .

    The GPIB command to set this parameter is CALL:(PDTCH|PDTChannel):MSLot:MEASurement:BURSt .

  • Measurement Timeout

    You can set the timeout state and time for this measurement. To set them separately, use SETup:TXPower:TIMeout:STATe to set the timeout state, SETup:TXPower:TIMeout:TIME to set the timeout time; use SETup:TXPower:TIMeout[:STIMe] to set the state and time simultaneously.

  • Multi-measurement Count

    You can set Multi-Measurement state and count for the TXP measurement. If Multi-Measurement State is On , Multi-Measurement Count determines how many measurements are to be performed for a measurement request. If Multi-Measurement State is Off , no Multi-Measurement are performed.

    The TXP measurement use the standard Multi-Measurement implementation. Each Multi-Measurement returns the average value, maximum value, minimum value and standard deviation for the number of counts selected. No intermediate results are returned during a Multi-Measurement.

    Multi-Measurement count specifies how many loops are measured for a measurement request.

    To set Multi-Measurement state and count separately, use SETup:TXPower:COUNt:STATe to set the Multi-Measurement state, SETup:TXPower:COUNt:NUMBer to set the Multi-Measurement count; use SETup:TXPower:COUNt[:SNUMber] to set the state and count simultaneously.

  • Multi-measurement Count Progress Indicator

    There is a progress indicator displayed on the front panel that shows how many measurements of the total Multi-Measurement count have been made. You can retrieve it using FETCh:TXPower:ICOunt? .

  • Trigger Arm

    Trigger arm can be set to Single or Continuous , See Trigger Arm (Single or Continuous) Description for more information.

    The GPIB command to set this parameter is SETup:TXPower:CONTinuous .

  • Trigger Delay

    This is the specified time between the trigger event and when the test set begins sampling data. See Trigger Delay Description for more information.

    The GPIB command to set this parameter is SETup:TXPower:TRIGger:DELay .

  • Trigger Qualification

    This parameter defines whether the measurement will discard the samples on detection of an idle frame. If this parameter is set to ON , the samples is discarded; If the parameter is set to OFF , the measurement continues to be completed.

    The GPIB command to set this parameter is SETup:TXPower:TRIGger:QUALifier .

  • Trigger Source

    Auto triggering is the recommended trigger source for each measurement. This allows the test set to choose the preferred trigger source. See Trigger Source Description . The following table shows the recommended trigger source for the TXP measurement.

    Recommended Trigger Source
    Operating mode

    Recommended Trigger Source
    Active Cell

    RF Rise or Protocol for GMSK signals

    Protocol for 8PSK signals

    Test mode

    RF Rise
    CW signal

    Immediate

    The GPIB command to set this parameter is SETup:TXPower:TRIGger:SOURce .

TXP Measurement Results

The results returned by the TXP measurement are Burst Power, Estimated Carrier Power and Integrity Indicator. Additionally, average, maximum, minimum and standard deviation of Burst Power and Estimated Carrier Power are returned when the Multi-Measurement state is On .

Burst Power and Estimated Carrier Power measurement results

The TXP measurement returns two types of power results:

  • Burst Power

    This is the average power measured across a single timeslot. This value varies as a function of the modulating data.

  • Estimated Carrier Power

    This is an estimate of the power of the unmodulated carrier. The Estimated Carrier Power is equivalent to the Long Term Average Power which is the primary definition of 8PSK power in the ETSI standards. Long Term Average Power is the average power of many individual bursts when the individual bursts are modulated with PRBS data. The Estimated Carrier Power measurement uses knowledge of the modulating data to determine the carrier power from the power measurement.

When the modulation format of the measured burst is GMSK, Burst Power and Estimated Carrier Power results are equivalent.

When Burst Capture Range is set to Single , you can query the Burst Power and the Estimated Carrier Power for the burst specified by Measurement Burst . The Burst Power and Estimated Carrier Power are equivalent.

When Burst Capture Range is set to All , you can query the Burst Power and the Estimated Carrier Power for a specified burst or all bursts in one TDMA frame:

  • Query the measurement results for a specified burst

    The FETCh commands may contain an optional parameter that is used to specify the burst. Measurement results of the burst specified by the optional parameter are returned. If you omit the optional parameter, measurement results of the burst specified by Measurement Burst are returned.

  • Query the measurement results for all bursts

    The FETCh commands return the measurement results in the following order: <Result for Burst 1>, <Result for Burst 2>, <Result for Burst 3>, <Result for Burst 4>, <Result for Burst 5>, <Result for Burst 6>, <Result for Burst 7>, <Result for Burst 8>. Note that the results for the inactive bursts in the multislot configuration are not valid.

TXP Measurement Integrity Value

Integrity values provide information that allows you to judge how useful the result is. See Integrity Indicator .

Common integrity indicators:

  • 0: Normal measurement completion
  • +2: Measurement timeout
  • +5: Over range
  • +6: Under range
  • +13 Unidentified Error. (Results are unavailable. A likely cause of this error can be due to invalid calibration data.)
  • +21 Parameter Error

TXP Measurement Input Signal Requirements

  • Single Burst Capture TXP Measurement

    When Burst Capture Range is set to Single , the TXP measurement will complete and be accurate when:

    • The input signal is within +/- 100 kHz of the expected frequency.
    • The level of the input burst is between -30 dBm and +43 dBm.
    • The level of the input burst is within +/-3 dB of the Expected Power.
  • Multiple Burst Capture TXP Measurement

    When Burst Capture Range is set to All , the TXP measurement will complete and be accurate when:

    • The input signal is within +/- 100 kHz of the expected frequency.
    • The level of the input burst is between -25 dBm and +33 dBm when measureing the Burst Power of 8PSK modulated bursts.
    • The level of the input burst is between -25 dBm and +37 dBm when measuring the Burst Power of GMSK modulated bursts.
    • The level of the input burst is between -20 dBm and +33 dBm when measuring Estimated Carrier Power.
    • When the Auto Range to Highest Burst parameter is set to OFF :
      • The level of the highest input burst is within +/-3 dB of the Highest Expected Power.
      • The level of all the other input bursts are within +3dB/-30dB of the Highest Expected Power.
    • when the Auto Range to Highest Burst parameter is set to ON :
      • The level of the highest input burst is within +3dB/-30dB dB of the Highest Expected Power.
      • The level of the all other input bursts are within +3dB/-30dB of the Highest Expected Power.

EGPRS Transmit Power (ETXP) Measurement

The EGPRS Transmit Power (ETXP) Measurement is used when you want to measure a single 8PSK burst. otherwise you are suggested to use the GSM/GPRS/EGPRS Transmit Power (TXP) Measurement.

ETXP is applicable only when the operating mode parameter is set to Active Cell (EGPRS), EGPRS BCH, EGPRS BCH+PDTCH or EGPRS BCH+TCH+PDTCH.

How is an EGPRS transmit power (ETXP) measurement made?

For EGPRS mobiles, ETXP provides a broadband measurement of the average transmitted burst and carrier power of an 8PSK or GMSK modulated signal for a specified burst in a multislot configuration. Multislot configurations with different power levels on each burst are supported. Only one burst which you specify using CALL:(PDTCH|PDTChannel):MSLot:MEASurement:BURSt is measured at a time. You can also control the modulation and coding scheme (either 8PSK or GMSK modulation) used by the data connection to be measured using CALL:(PDTCH|PDTChannel):MCSCheme . Additionally, you can manually control what modulation should be expected for individual bursts using CALL:MODulation[:FORMat]:CONTrol:AUTO . See "Modulation Format Control (EGPRS only)" on page 10 for more information.

The EGPRS radio format allows for all GMSK, all 8PSK or a mixture of GMSK and 8PSK bursts in a multislot configuration. Additionally, when a timeslot supports an 8PSK packet data traffic channel (PDTCH), GMSK modulated control blocks can be inserted. When you specify a burst to measure, the measurement takes samples only from that burst in the multislot configuration. If the modulation is the same as the modulation and coding scheme you have selected or the modulation format you manually specified, the measurement proceeds normally. If the modulation is not the same, the samples are discarded and the measurement is re-armed. The measurement completes when a burst using the same modulation is detected.

Single or Multi-Measurements

The 8PSK Transmit Power measurement supports single Burst Power and Estimated Carrier Power measurements. For multi-burst measurements, the average value of Burst Power is equivalent to the Long Term Average Power defined in the ETSI standards. You can choose either a more accurate but slower measurement with the multi-measurement Burst Power result, or a less accurate but faster measurement with the Estimated Carrier Power result.

This measurement calculates average, minimum, maximum, and standard deviation values for the burst power and estimated carrier power results. When the measured signal's modulation format is GMSK, Burst Power and Carrier Power measurements are equivalent so both results return the same value. All of these results are available using the FETCh commands (see FETCh:ETXPower ). The test set always has an integrity indicator available regardless of whether single or multiple burst measurements are selected.

Types of Signals ETXP can Measure

The following list summarizes the input signal attributes and mobile station operating modes for making ETXP measurements.Normal GSM TCH burst with the operating mode set to active cell and the serving cell set to EGPRS.

  • Two burst multislot configuration comprising two normal PDTCH bursts with the operating mode set to active cell and the serving cell set to EGPRS.
  • Single normal PDTCH burst with the mobile station in active cell mode.
  • Access (RACH) burst with the mobile station in active cell mode.
  • Two burst multislot configuration comprising two normal PDTCH bursts with the mobile station in EGPRS BCH, EGPRS BCH+PDTCH or EGPRS BCH+TCH+PDTCH test mode (no protocol).
  • Single normal PDTCH burst with the mobile station in EGPRS BCH, EGPRS BCH+PDTCH or EGPRS BCH+TCH+PDTCH test mode (no protocol).
  • Access (RACH) burst with mobile station in EGPRS BCH, EGPRS BCH+PDTCH or EGPRS BCH+TCH+PDTCH test mode (no protocol).

Input Signal Requirements

The ETXP measurement requires the following signal attributes:

  • Level is between -30 dBm and +37 dBm (Peak).
  • Level within +/-3 dB of the expected input level.
  • Input signal is within +/- 100 kHz for GMSK signals and +/- 1 kHz for 8PSK signals of the expected frequency.

Trigger Source

Auto triggering is the recommended trigger source for each measurement. This allows the test set to choose the preferred trigger source. However you may want to select the trigger source. See Recommended Trigger Source Settings

Recommended Trigger Source Settings
Input Signal Type | Recommended Trigger Source
Normal GSM TCH burst with mobile station in active cell mode | Protocol
Two burst multislot configuration comprising two normal PDTCH bursts with the mobile station in active cell mode. | Protocol
Single normal PDTCH burst with the mobile station in active cell mode. | Protocol
Access (RACH) burst with the mobile station in active cell mode, and the modulation format set to GMSK. | Protocol
Two burst multislot configuration comprising two normal PDTCH bursts with the mobile station in EGPRS BCH, EGPRS BCH+PDTCH or EGPRS BCH+TCH+PDTCH test mode (no protocol). | RF Rise
Single normal PDTCH burst with the mobile station in EGPRS BCH, EGPRS BCH+PDTCH or EGPRS BCH+TCH+PDTCH test mode (no protocol). | RF Rise
Access (RACH) burst with mobile station in EGPRS BCH, EGPRS BCH+PDTCH or EGPRS BCH+TCH+PDTCH test mode (no protocol), and the modulation format set to GMSK. | RF Rise

Related Topics

Programming a Transmit Power Measurement

Test Adherence to Standards

Transmit Power Troubleshooting

SETup:TXPower

SETup:ETXPower

FETCh:TXPower

FETCh:ETXPower


Introduction

Introduction

The intent of this guide is to help you quickly learn how to use the GSM/GPRS/EGPRS E1968A Test Application and the GSM/GPRS/EGPRS E6701D Lab Application to manually make mobile station receiver and transmitter tests as specified in the 3GPP TS Standard.

The Appendix includes additional information to help you perform the 3GPP tests such as:

  • Test Adherence to Standards table that shows which tests are supported by the test set
  • General procedures that are required to setup the measurement
  • Calibration procedures that must be performed periodically when testing mobile stations with the test set

The scope of this guide does not cover the numerous features and capabilities of the test set. For details, refer to the E1968A On-line User's Guide which is available at:

  • http://www.agilent.com/find/e1968a, or
  • User Documentation CD-ROM shipped with your application.


Programming an Audio Frequency Measurement

Programming an Audio Frequency Measurement

This measurement is not applicable to GPRS or EGPRS.

This section provides an example of how to make an Audio Frequency measurement via the GPIB.

The following procedure assumes that an audio source is connected to the AUDIO IN connectors. See Analog Audio Measurement Description .

  1. Configure the analog audio measurement parameters using the SETup subsystem. When more than one audio frequency signal may be present, use the 100 Hz bandpass filter to isolate the desired signal to measure (see the Programming Example below).
  2. Start the audio frequency measurement using the INITiate subsystem.
  3. Use the FETCh? subsystem to obtain analog audio measurement results.

Programming Example

10  OUTPUT 714;"SETup:AAUDio:CONTinuous OFF" !Set the audio
20                                           !measurements to single trigger mode.
30 OUTPUT 714;"SETup:AAUDio:EXPected:VOLTage 3V" !Set the Expected peak voltage
40                                                !for the audio input level in Vpeak.
50  OUTPUT 714;"SETup:AAUDio:FREQuency:STATe ON" !Enable audio frequency measurement.
60  OUTPUT 714;"SETup:AAUDio:FILTer:STATe ON" !Enable the bandpass filter.
70  OUTPUT 714;"SETup:AAUDio:FILTer:FREQuency 8000 Hz" !Set the filter's center
80     !frequency to 8 kHz.
90  OUTPUT 714;"SETup:AAUDio:TIMeout 3S" !Set a timeout value of 3 seconds
100                                      !in case the measurement cannot be made.
110 OUTPUT 714;"INITiate:AAUDio" !Start the Analog Audio measurement.
120 OUTPUT 714;"FETCh:AAUDio:INTegrity?" !Query the integrity indicator to
130                           !verify that a reliable measurement was made.
140 ENTER 714;Integrity  !Enter the returned value into a variable for comparison
150                      !with possible integrity indicator values (not shown here).
160 IF Integrity=0 THEN  !Only fetch measurement result if integrity indicator is 0.
170  OUTPUT 714;"FETCh:AAUDio:FREQuency?" !Fetch the analog audio frequency result.
180  ENTER 714;Audio_frequency !Enter the result into a variable.
190 END IF
200 END

Returned Values

The results returned by this program are:

  • Integrity returns the measurement integrity indicator (0 means a successful measurement with no errors). See Integrity Indicator .
  • Audio_frequency returns the average audio frequency in hertz.

Related Topics

Audio Frequency Measurement Description

Analog Audio Troubleshooting

Analog Audio Measurement Description

INITiate

SETup:AAUDio

FETCh:AAUDio


Programming an Audio Level Measurement

Programming an Audio Level Measurement

This measurement is not applicable to GPRS or EGPRS.

This section provides an example of how to make an audio level measurement via the GPIB.

The following procedure assumes that an audio source is connected to the AUDIO IN connectors. See Analog Audio Measurement Description .

  1. Configure analog audio measurement parameters using the SETup subsystem. Even though default settings exist for each parameter, it is preferable to deliberately set each parameter to make sure the setting is correct for the specific audio analyzer measurement you are making.
  2. Start the analog audio measurement using the INITiate subsystem.
  3. Use the FETCh? subsystem to obtain analog audio measurement results.

Programming Example

10  OUTPUT 714;"SETup:AAUDio:CONTinuous OFF" !Set the analog audio
20                                           !measurements to single trigger mode.
30  OUTPUT 714;"SETup:AAUDio:EXPECTED:VOLTage 3V" !Set the Expected Amplitude level for
40                                                !audio input voltage in Vpeak.
50  OUTPUT 714;"SETup:AAUDio:SDIStortion:STATe OFF" !Turn off the SINAD and
60                                                  !distortion measurements since
70                                                  !they are not being used.
80  OUTPUT 714;"SETup:AAUDio:FILTer:TYPE NONE" !Bypass all audio filters.
90  OUTPUT 714;"SETup:AAUDio:DEMPhasis:STATe OFF" !Turn off de-emphasis.
100 OUTPUT 714;"SETup:AAUDio:EXPANDOR:STATe OFF" !Turn off the expandor.
110 OUTPUT 714;"SETup:AAUDio:DETector RMS" !Specify the RMS detector for the
120                                            !audio measurement.
130 OUTPUT 714;"SETup:AAUDio:TIMeout 3S" !Set a timeout value of 3 seconds
140                                      !in case the measurement cannot be made.
150 OUTPUT 714;"INITiate:AAUDio" !Start the Analog Audio measurement.
120 OUTPUT 714;"FETCh:AAUDio:INTegrity?" !Query the integrity indicator to
130                           !verify that a reliable measurement was made.
140 ENTER 714;Integrity  !Enter the returned value into a variable for comparison
150                      !with possible integrity indicator values (not shown here).
160 IF Integrity=0 THEN  !Only fetch measurement result if integrity indicator is 0.
170  OUTPUT 714;"FETCh:AAUDio:VOLTage?" !Fetch the Audio Level result.
180  ENTER 714;Audio_level  !Enter the result into a variable.
190 END IF
200 END

Returned Values

The results returned by this program are:

  • Integrity returns the measurement integrity indicator (0 means a successful measurement with no errors). See Integrity Indicator .
  • Audio_level returns the audio level in volts rms.

Related Topics

Analog Audio Measurement Description

Analog Audio Troubleshooting

INITiate

SETup:AAUDio

FETCh:AAUDio


Programming a Bit Error Measurement

Programming a Bit Error Measurement

This section contains three programming examples:

  • Programming a Bit Error Measurement for GSM
  • Programming a Bit Error Measurement for GPRS
  • Programming an EGPRS SRB Bit Error Measurement

Programming a Bit Error Measurement for GSM

This section provides an example of how to make the bit error (BER) measurement via GPIB.

The following procedure assumes that an active link is established between the test set and the mobile station. See Establishing an Active GSM Link with the Mobile Station .

  1. Set the cell power to a low operating level.
  2. Configure BER measurement parameters using the SETup subsystem.
  3. Set the measurement type (either residual Type IA, Type IB, Type II, or non-residual Type IA, Type IB, Type II).
  4. Set the cell power to a low level for BER measurement.
  5. Use the READ:BERROR? command to initiate and fetch the BER measurement results.
  6. Set the cell power to a normal operating level.

Programming Example

10       OUTPUT 714;"SETUP:BERROR:TIMEOUT:TIME 5"! BER measurement times out after
20                                              ! 5 seconds.
30       OUTPUT 714;"CALL:CELL:POWER:AMPLITUDE -102 DBM"! Sets the cell power level
40                                                      ! to a "low" level for the
50                                                      ! BER measurement.
60       OUTPUT 714;"SETUP:BERROR:CONTINUOUS OFF" ! Configures a BER measurement to
70                                                ! Single Trigger.
80       OUTPUT 714;"SETUP:BERROR:COUNT 10000" ! Sets the number of bits to measure
90                                             ! at 10,000.
100       OUTPUT 714;"SETUP:BERROR:CLSDELAY:STIME 500 MS"  ! Sets the Close Loop Delay
110                                                       ! to 500 ms.
120       OUTPUT 714;"SETUP:BERROR:SLCONTROL ON" ! Sets the Signal Loop Control state to on.
130       OUTPUT 714;"SETUP:BERROR:TYPE TYPEIA" ! Sets the Measurement Type to IA.
140       OUTPUT 714;"SETUP:BERROR:LDCONTROL:AUTO OFF" ! Configure loopback delay
150                                                  ! control to manual.
160       OUTPUT 714;"SETUP:BERROR:MANUAL:DELAY 1" ! Set frame delay to 6 frames in order
170                                              ! to correlate uplink and downlink bits.
180       OUTPUT 714;"READ:BERROR?"  ! Initiate and fetch  BER measurement results.
201       ENTER 714;Integrity,Bits_tested,Bit_err_ratio,Bit_err_count
202       PRINT "Integrity";TAB(20);Integrity
203       PRINT "Bits Tested";TAB(20);Bits_tested
204       PRINT "Bit Error Ratio";TAB(20);Bit_err_ratio
205       PRINT "Bit Error Count";TAB(20);Bit_err_count
206       OUTPUT 714;"FETCH:BERROR:COUNT:CRC?" ! Query CRC Count results.
220       ENTER 714;Crc_count
221       PRINT "CRC Count";TAB(20);Crc_count
230       OUTPUT 714;"CALL:CELL:POWER:AMPLITUDE -85 DBM" ! Returns the cell power level
240                                                      ! to a good level.
250       END

Returned values

The measurements returned by this program are:

  • Integrity returns the Integrity Indicator (0 means a successful measurement with no errors).
  • Bits_tested returns the number of bits tested.
  • Bit_err_ratio returns the ratio of bit errors to total bits tested.
  • Bit_err_count returns the number of bit errors.
  • Crc_count returns the CRC count (cyclic redundancy check).

Related Topics

Bit Error Measurement

SETup:BERRor

INITiate

FETCh:BERRor

Programming: Getting Started Guide for E1968A GSM/GPRS Mobile Test Application Revision A.02 and E6701C GSM/GPRS Lab Application Revision C.02

Bit Error Troubleshooting

Programming a Bit Error Measurement for GPRS

This section provides an example of how to make the GPRS bit error (BER) measurement via GPIB.

The following procedure assumes that the Operating Mode has been set to Active Cell (using CALL:OPERating:MODE ) and the data connection type has been set to ETSI Type B (using CALL:FUNCtion:CONNection:TYPE ). In addition, it is assumed that a data connection has been established between the test set and the mobile station (that is, the connection status is Transferring). See Step 4: Make a Connection . Note that you can also make BER measurements when the test set's operating mode is set to GPRS BCH+PDTCH test mode (see CALL:OPERating:MODE ).

  1. Configure the BCH and PDTCH parameters using the CALL subsystem.
  2. Configure the Bit Error measurement parameters using the SETup subsystem.
  3. Configure the downlink PDTCH parameters using the CALL subsystem.
  4. Start the Bit Error measurement using the INITiate subsystem.
  5. Use the FETCh? command to obtain Bit Error measurement results.

Programming Example

10   ! This code assumes that the current data connection state is Transferring.
20   !
30   ! Configure BCH and PDTCH parameters.
40   OUTPUT 714;"CALL:POW -60 DBM" ! Set the BCH power.
50   OUTPUT 714;"CALL:PDTCH:PZER:LEV 30" ! Set the P0 reference level to 30 dB.
60   OUTPUT 714;"CALL:PDTCH:CSCH CS4" ! Set the channel coding scheme to CS4.
70   ! Configure the measurement parameters
80   OUTPUT 714;"SET:GBER:TIM:TIME 5" ! BER measurement times out after
90                                    ! 5 seconds.
100  OUTPUT 714;"SET:GBER:CONT OFF" ! Configures a BER measurement to
110                                 ! Single Trigger.
120  OUTPUT 714;"SET:GBER:COUN 10000" ! Sets the number of bits to measure
130                                   ! at 10,000.
140  OUTPUT 714;"SET:GBER:LDC:AUTO ON" ! Sets the Loopback Delay
150                                    ! Control mode to ON. This
160                                    ! commands the test set to
170                                    ! determine the Block Delay.
180  ! Set up and select the downlink PDTCH power reduction levels.
190  OUTPUT 714;"CALL:PDTCH:PRED:LEV1 12db"
200  OUTPUT 714;"CALL:PDTCH:PRED:LEV2 0dB"
210  OUTPUT 714;"CALL:PDTCH:PRED:BURS1 PRL1"
220  OUTPUT 714;"CALL:PDTCH:PRED:BURS2 PRL1"
230  OUTPUT 714;"INIT:GBER"  ! Start a BER measurement.
240  OUTPUT 714;"FETC:GBER?"
250  ENTER 714;Integrity,Bits_tested,Bit_ratio,Bit_err_cnt
260  END

Returned values

The measurements returned by this program are:

  • Integrity returns the Integrity Indicator (0 means a successful measurement with no errors).
  • Bits_tested returns the number of bits tested.
  • Bit_ratio returns the ratio of bit errors to total bits tested.
  • Bit_err_cnt returns the number of bit errors.

Related Topics

Bit Error Measurement

SETup:GBERror

INITiate

FETCh:GBERror

Bit Error Troubleshooting

Programming an EGPRS SRB Bit Error Measurement

This section provides an example of how to make the EGPRS SRB bit error (SBER) measurement via GPIB.

The following procedure assumes that the Operating Mode has been set to Active Cell (using CALL:OPERating:MODE ) and the data connection type has been set to SRB Loopback (using CALL:FUNCtion:CONNection:TYPE ). In addition, it is assumed that a data connection has been established between the test set and the mobile station (that is, the connection status is Transferring). See Step 4: Make a Connection . Note that you can also make SBER measurements when the test set's operating mode is set to EGPRS BCH+PDTCH test mode (see CALL:OPERating:MODE ).

  1. Configure the BCH and PDTCH parameters using the CALL subsystem.
  2. Configure the EGPRS SRB Bit Error measurement parameters using the SETup subsystem.
  3. Configure the downlink PDTCH parameters using the CALL subsystem.
  4. Start the EGPRS SRB Bit Error measurement using the INITiate subsystem.
  5. Use the FETCh? command to obtain EGPRS SRB Bit Error measurement results.

Programming Example

10   ! This code assumes that the current data connection state is Transferring.
20   !
30   ! Configure BCH and PDTCH parameters.
40   OUTPUT 714;"CALL:POW -60 DBM" ! Set the BCH power.
50   OUTPUT 714;"CALL:PDTCH:PZER:LEV 30" ! Set the P0 reference level to 30 dB.
60   OUTPUT 714;"CALL:PDTCH:MCSC MCS3,MCS3" ! Set the modulation coding scheme to MCS3.
70   ! Configure the measurement parameters
80   OUTPUT 714;"SET:SBER:TIM:TIME 5" ! BER measurement times out after
90                                    ! 5 seconds.
100  OUTPUT 714;"SET:SBER:CONT OFF" ! Configures a BER measurement to
110                                 ! Single Trigger.
120  OUTPUT 714;"SET:SBER:COUN 80000" ! Sets the number of bits to measure
130                                   ! at 80,000.
140  OUTPUT 714;"SET:SBER:LDC:AUTO ON" ! Sets the Loopback Delay
150                                    ! Control mode to ON. This
160                                    ! commands the test set to
170                                    ! determine the Block Delay.
180  ! Set up and select the downlink PDTCH power reduction levels.
190  OUTPUT 714;"CALL:PDTCH:PRED:LEV1 12db"
200  OUTPUT 714;"CALL:PDTCH:PRED:LEV2 0dB"
210  OUTPUT 714;"CALL:PDTCH:PRED:BURS1 PRL1"
220  OUTPUT 714;"CALL:PDTCH:PRED:BURS2 PRL1"
230  OUTPUT 714;"INIT:SBER"  ! Start a BER measurement.
240  OUTPUT 714;"FETC:SBER?"
250  ENTER 714;Integrity,Bits_tested,Bit_ratio,Bit_err_cnt
260  END

Returned values

The measurements returned by this program are:

  • Integrity returns the Integrity Indicator (0 means a successful measurement with no errors).
  • Bits_tested returns the number of bits tested.
  • Bit_ratio returns the ratio of bit errors to total bits tested.
  • Bit_err_cnt returns the number of bit errors.

Related Topics

EGPRS SRB Bit Error Measurement

SETup:SBERror

INITiate

FETCh:SBERror

EGPRS SRB Bit Error Troubleshooting


Programming a Block Error Measurement

Programming a Block Error Measurement

This measurement is not applicable to GSM.

This section provides an example of how to make the block error (BLER) measurement via GPIB.

The following procedure assumes that the Operating Mode has been set to Active Cell (using CALL:OPERating:MODE ) and the data connection type has been set to ETSI Type B or BLER (using CALL:FUNCtion:CONNection:TYPE ). In addition, it is assumed that a data connection has been established between the test set and the mobile station (that is, the connection status is Transferring). See Step 4: Make a Connection . Note that you can also make BLER measurements when the test set's operating mode is set to GPRS BCH+PDTCH test mode (see CALL:OPERating:MODE ).

  1. Configure the BCH and PDTCH parameters using the CALL subsystem.
  2. Configure the Block Error measurement parameters using the SETup subsystem.
  3. Configure the downlink PDTCH parameters using the CALL subsystem.
  4. Start the Block Error measurement using the INITiate subsystem.
  5. Use the FETCh? command to obtain Block Error measurement results.

Programming Example

10   ! This code assumes that the current data connection state is Transferring.
20   !
30   ! Configure BCH and PDTCH parameters.
40   OUTPUT 714;"CALL:POW -50 DBM" ! Set the BCH power.
50   OUTPUT 714;"CALL:PDTCH:PZER:LEV 30" ! Set the P0 reference level to 30 dB.
60   OUTPUT 714;"CALL:PDTCH:MCSC MCS3" ! Set the modulation coding scheme to MCS3.
70   ! Configure the measurement parameters
80   OUTPUT 714;"SET:BLER:TIM:TIME 5" ! BLER measurement times out after
90                                    ! 5 seconds.
100  OUTPUT 714;"SET:BLER:CONT OFF" ! Configures a BLER measurement to
110                                 ! Single Trigger.
120  OUTPUT 714;"SET:BLER:COUN 2000"  ! Sets the number of blocks to measure
130                                   ! at 2,000.
140  OUTPUT 714;"SET:BLER:LDC:AUTO ON" ! Sets the Loopback Delay
150                                    ! Control mode to ON. This
160                                    ! commands the test set to
170                                    ! determine the Block Delay.
180  ! Set up and select the downlink PDTCH power reduction levels.
190  OUTPUT 714;"CALL:PDTCH:PRED:LEV1 12db"
200  OUTPUT 714;"CALL:PDTCH:PRED:LEV2 0dB"
210  OUTPUT 714;"CALL:PDTCH:PRED:BURS1 PRL1"
220  OUTPUT 714;"CALL:PDTCH:PRED:BURS2 PRL1"
230  OUTPUT 714;"INIT:BLER"  ! Start a BLER measurement.
240  REPEAT
250    OUTPUT 714;"INIT:DONE?"
260    ENTER 714;Meas_complete$
270  UNTIL Meas_complete$="BLER"
280  ! Fetch results.
290  OUTPUT 714;"FETC:BLER?"
300  ENTER 714;Integrity,Blocks_tested,Block_ratio,Block_err_cnt
310  END

Returned values

The measurements returned by this program are:

  • Integrity returns the Integrity Indicator (0 means a successful measurement with no errors).
  • Blocks_tested returns the number of blocks tested.
  • Block_ratio returns the ratio of block errors to total blocks tested.
  • Block_err_cnt returns the number of block errors.

Related Topics

Block Error Measurement

SETup:BLERror

INITiate

FETCh:BLERror

Block Error Troubleshooting


Burst Synchronization of Measurements

Burst Synchronization of Measurements

Measurement Synchronization

Measurement Synchronization Description

Measurement synchronization determines how a measurement's time reference is determined from the measurement data (a sampled time record). Measurement synchronization occurs after the measurement data is captured.

For the transmit power and ORFS (switching and modulation) measurements, the RF amplitude of the input signal is used for measurement synchronization. For Phase and Frequency Error Measurement and the Power versus Time Measurement (see Phase and Frequency Error Measurement Description and Power versus Time Measurement Description .) there are three possible settings for measurement synchronization:

  • Midamble
  • RF Amplitude
  • None

Selecting midamble causes the test set to use the input signal's midamble data to determine the measurement's time reference. A measurement is capable of midamble synchronization if the test set is able to determine transmitted data from measurement samples (i.e. perform demodulation). Midamble synchronization is not available for Transmit Power measurements. However, the Power vs. Time measurement can perform an average power measurement using midamble synchronization.

When the test set's operating mode is "test mode" or when the cell activated state is "off", the burst type may need to be specified before the test set can synchronize to the input signal's midamble. See Expected Burst .

Selecting RF amplitude causes the test set to use the input signal's rising and falling edges (if edges are detected within the sampled time record) to determine the measurement's time reference. If a non-bursted signal was sampled, the measurement's time reference will be developed using the beginning and end of the sampled time record, and the samples used for making the measurement will be taken from the middle of the time record.

Selecting None causes the test set to perform measurements exactly as if RF amplitude was chosen.

An integrity indicator is returned for each completed measurement. Integrity errors are prioritized so that when multiple errors occur, the highest priority error is returned first, as the root error. The integrity indicator returns a number from 0 to 16, where 0 indicates normal. The following integrity indicators reveal problems with measurement synchronization:

  • (7) Burst Short
  • (8) Trigger Early
  • (8) Fall Early
  • (9) Trigger Late
  • (9) Rise Late
  • (11) Sync Not Found

Refer to Integrity Indicator for descriptions of integrity indicators.

Programming Example:

OUTPUT 714;"SETUP:PVTIME:SYNC MIDAMBLE"!selects midamble synchronization for PVT measurements

Related Topics

Integrity Indicator


Establishing an Active GSM Link with the Mobile Station

Establishing an Active GSM Link with the Mobile Station

Making a Base Station Originated Call

The process for making a base station originated call is to:

  1. If necessary, configure the traffic channel parameters for the call assignment. See CALL:TCHannel .

  2. Set the Paging Identity. See CALL:PAGing:IDENtity[:TYPE] .

  3. If necessary, set the IMSI state. See CALL:PAGing:IMSI .

OUTPUT 714;"CALL:PAGING:IMSI ""01012345678901"""

    would set the paging IMSI to 01012345678901.

  4. If necessary, set the repeat paging state. See CALL:PAGing:REPeat[:STATe][:SELected] .

OUTPUT 714;"CALL:PAGING:REPEAT ON"

    would turn on repeat paging.

  5. Configure the necessary call processing connect/disconnect synchronization conditions.
    See Call Processing State Synchronization .

  6. Page the mobile station by sending the call originate command to the test set.

OUTPUT 714;"CALL:ORIGINATE"

    would start the process of making a base station originated call.

IMPORTANT
To verify that the origination is successfully completed, see Call Processing State Synchronization .

Making a Mobile Station Originated Call

The process for making a mobile station originated call is to:

  1. If necessary, configure the traffic channel parameters for the call assignment. See CALL:TCHannel for more information about the traffic channel parameters.

  2. Configure the necessary call processing connect/disconnect synchronization conditions.
    See Call Processing State Synchronization .

  3. Initiate a call from the mobile station.

NOTE
There is no facility in the test set to initiate a call from the mobile station. This must be accomplished manually or through a test bus built-in to the mobile station.

IMPORTANT
To verify that the origination is successfully completed, see Call Processing State Synchronization .

Operating Considerations

The test set must be in active cell operating mode and the connection type must be Auto. The correct frequency band must be selected.

Related Links

Active Cell Operating Mode


Establishing a Data Connection with the Mobile Station

Establishing a Data Connection with the Mobile Station

This section is not applicable to GSM.

For instructions and a programming example on how to make a GPRS or EGPRS data connection, see Step 4: Make a Connection .

Related Topics

CALL:(PDTCH|PDTChannel)


Programming a Channel Mode Change

Programming a Channel Mode Change

Channel Mode Change is not applicable to GPRS or EGPRS.

This section provides an example of how to change a mobile station's channel mode to enhanced full rate speech via GPIB while a call is connected and a measurement is running.

The following procedure assumes that an active link is established between the test set and the mobile station. See Establishing an Active GSM Link with the Mobile Station .

  1. Ensure the mobile is initially in full rate speech channel mode.
  2. Configure the parameters for the measurement(s) you want to run using the SETup subsystem.
  3. Start the measurement(s) using the INITiate subsystem.
  4. Change the mobile's channel mode to enhanced full rate speech.
  5. Use the INITiate:DONE? command to find out if the measurement results are available.
  6. Use the FETCh? command to obtain the measurement results.

Programming Example

The following program uses the TX Power measurement to show how to change the channel mode to enhanced full rate speech while a measurement is running. The TX Power measurement is chosen because it is one of the measurements that is supported in enhanced full rate speech mode.

10    OUTPUT 714;"CALL:TCHANNEL:CMODE FRSPEECH" !Ensure mobile is in
20                        !full rate speech channel mode initially.
30    OUTPUT 714;"SETUP:TXPOWER:CONTINUOUS OFF" !Configures trigger
40                        !mode to single for a TX Power measurement.
50    OUTPUT 714;"SETUP:TXPOWER:COUNT:NUMBER 100" !Configures a
60                        !multi measurement of 100.
70    OUTPUT 714;"SETUP:TXPOWER:TRIGGER:SOURCE AUTO" !Configures the
80                        !trigger source to auto.
90    OUTPUT 714;"INITIATE:TXPOWER" !Start TX Power measurement.
100   OUTPUT 714;"CALL:TCHANNEL:CMODE EFRSPEECH" !Sets the channel
110                       !mode to enhanced full rate speech while
120                       !the TX Power measurement is running.
130   REPEAT
140   OUTPUT 714;"INITIATE:DONE?" !Check to see if TX Power
150                       !measurement is complete.
160   ENTER 714;Meas_complete$
170   UNTIL Meas_complete$="TXP"
180   OUTPUT 714;"FETCH:TXPOWER:ALL?" !Fetch TX Power results.
190   ENTER 714;Integrity,Avg_tx_pwr
200   PRINT "TX Power Measurement Results"
210   PRINT "Integrity=";Integrity
220   PRINT "TX Power=";Avg_tx_pwr
230   END

Returned Values

The measurements returned by this program are:

  • Integrity returns the measurement Integrity Indicator (0 means a successful measurement with no errors).
  • Avg_tx_pwr returns the average transmit power in dBm.

Related Topics

Channel Mode Setup


Programming a Decoded Audio Measurement

Programming a Decoded Audio Measurement

This measurement is not applicable to GPRS or EGPRS.

This section provides an example of how to make a Decoded Audio (DAUDio) measurement. The following procedure assumes that an active link is established between the test set and the mobile station. See Establishing an Active GSM Link with the Mobile Station .

  1. Configure decoded audio measurement parameters using the SETup subsystem.
  2. Setup the audio source to stimulate the mobile station with a pulsed audio signal.
  3. Start the decoded audio measurement using the INITiate subsystem.
  4. Use the FETCh? command to obtain decoded audio measurement results.

Programming Example

10    OUTPUT 714;"SETUP:DAUDIO:CONTINUOUS OFF"         ! Configures the decoded audio
20                                                     ! measurement to single trigger mode.
30    OUTPUT 714;"AFGENERATOR:PULSE:STATE ON"          ! Audio signal must be pulsed.
40    OUTPUT 714;"AFGENERATOR:VOLTAGE:SAMPLITUDE 100MV"
50    OUTPUT 714;"AFGENERATOR:FREQUENCY 2.1KHZ"
60    OUTPUT 714;"SETUP:DAUDIO:FILTER:SFREQUENCY 2.1KHZ"! Specifies the tunable
70                                                      ! bandpass filter frequency
80                                                      ! and set the filter state to on.
90    OUTPUT 714;"INITIATE:DAUDIO"
100   OUTPUT 714;"FETCH:DAUDIO?"                        ! Fetch the decoded audio results.
110   ENTER 714;Ingerity,Decoded_audio
120   END

Returned Values

The measurements returned by this program are:

  • Integrity returns the measurement Integrity Indicator (0 means a successful measurement with no errors).
  • Decoded_audio returns the decoded audio measurement results in percent (%).

Related Topics

Decoded Audio Measurement Description


Programming a Distortion Measurement

Programming a Distortion Measurement

This measurement is not applicable to GPRS or EGPRS.

This section provides an example of how to make a distortion measurement via the GPIB. Distortion measurements are not typically made when testing GSM mobiles but are more common when testing AMPS or other analog mobiles. The programming example below is typical for a 136 mobile.

SINAD and Distortion measurements are affected by the same STATe and INITiate commands, so both measurements are enabled and triggered at the same time. However, measurement results are queried separately. See Analog Audio Measurement Description .

The following procedure assumes that the mobile's audio output is connected to the AUDIO IN connectors and the mobile is on an analog voice channel (AVC). The AVC is being modulated with a 1004 Hz tone at +/-8 kHz peak deviation, and a 6000 Hz supervisory audio tone (SAT) at +/-2 kHz peak deviation. It is also assumed that the Cell Power from the test set is set to -50 dBm.

  1. Configure analog audio measurement parameters using the SETup subsystem.
  2. Start the analog audio measurement using the INITiate subsystem.
  3. Use the FETCh? subsystem to obtain analog audio measurement results.

Programming Example

10  OUTPUT 714;"SETup:AAUDio:CONTinuous OFF" !Set the analog audio
20                                           !measurements to single trigger mode.
30  OUTPUT 714;"SETup:AAUDio:EXPected:VOLTage 3V" !Set the Expected Amplitude level for
40                                                !audio input voltage in Vpeak.
50  OUTPUT 714;"SETup:AAUDio:SDIStortion:STATe ON" !Turn on the SINAD and
60                                                  !distortion measurements.
70  OUTPUT 714;"SETup:AAUDio:SDIStortion:FREQuency 1004 HZ" !Specify the audio
80                                      !frequency to use for the measurements.
90  OUTPUT 714;"SETup:AAUDio:FILTer:TYPE CMESsage" !Select the c-message filter.
100 OUTPUT 714;"SETup:AAUDio:DEMPhasis:STATe OFF" !Turn off de-emphasis.
110 OUTPUT 714;"SETup:AAUDio:EXPANDOR:STATe OFF" !Turn off the expandor.
120 OUTPUT 714;"SETup:AAUDio:TIMeout 3S" !Set a timeout value of 3 seconds
130                                      !in case the measurement cannot be made.
140 OUTPUT 714;"INITiate:AAUDio" !Start the Analog Audio measurement.
150 OUTPUT 714;"FETCh:AAUDio:INTegrity?" !Query the integrity indicator to
160                           !verify that a reliable measurement was made.
170 ENTER 714;Integrity  !Enter the returned value into a variable for comparison
180                      !with possible integrity indicator values (not shown here).
190 IF Integrity=0 THEN  !Only fetch measurement result if integrity indicator is 0.
200  OUTPUT 714;"FETCh:AAUDio:DISTortion?" ! Fetch the Distortion result.
210  ENTER 714;Distortion !Enter the returned value into a variable.
220 END IF
230 END

Returned Values

The results returned by this program are:

  • Integrity returns the measurement integrity indicator; 0 means a successful measurement with no errors. See Integrity Indicator .
  • Distortion returns the Distortion measurement value in percent (%).

Related Topics

Analog Audio Measurement Description

Analog Audio Troubleshooting

Distortion Measurement Description

INITiate

SETup:AAUDio

FETCh:AAUDio


Program to Establish Dual Transfer Mode Operation

Program to Establish Dual Transfer Mode Operation

Procedure

The following is a programming example of establishing Dual Transfer Mode connection between the mobile station and the test set. This procedure assumes that:

  • the correct Cell Band is selected for your mobile station,
  • appropriate RF IN/OUT Amplitude Offsets have been set to offset loss between the mobile station and the test set,
  • there is an active link between the mobile station and the test set.

Programming Example

10    Test_set=714
20    DIM Call_status$[10] !declare the connection status string
30    !
40 !Set up parameters.
50    OUTPUT Test_set;"CALL:FUNCtion:CONNection:TYPE BLER"!Set the data connection type
60    OUTPUT Test_set;"CALL:PDTCH:MSLot:CONFig D2U2"!Set the multislot configuration.
70    OUTPUT Test_set;"CALL:PDTCH:DTMode:CSWitched:TSLot 4"!Set the CS timeslot.
80   !
90 !Establish a Circuit Switched (CS) voice call.
100    OUTPUT Test_set;"CALL:PAG:IMSI `001012345678901'"
110    OUTPUT Test_set;"CALL:PAG:REP OFF"  ! Set the paging repeat state.
120       !
130    Tries=1
140    LOOP
150        OUTPUT Test_set;"CALL:ORIG"   ! Originate a call.
160        OUTPUT Test_set;"CALL:CONN:STAT?"! CALL:CONN hanging query.
170        ENTER Test_set;Call_connected
180       ! Program will hang here until origination process completes.  If
190       ! successful and the call is connected the query will return a 1
200       ! and the program will next start a data connection.
210       ! If unsuccessful and the call is not connected, the query
220       ! returns 0.
230       !
240    EXIT IF Call_connected
260        IF Tries=50 THEN
270            BEEP
280            DISP ""
290            PRINT "Call did not connect after";Tries;"."
300            PRINT "Program terminated."
310            STOP
320        END IF
330        DISP "Call has not connected after";Tries;"attempts."
340        Tries=Tries+1
350    END LOOP
360 !
370    OUTPUT Test_set;"CALL:FUNCtion:DATA:STARt"!Establishes a PS data connection.
380    END

Related Topics

Dual Transfer Mode


How the Test Set Performs a Dualband Handover

How the Test Set Performs a Dualband Handover

The dualband handover function has been implemented as an interband channel assignment for GSM and a packet timeslot reconfigure for GPRS and EGPRS, rather than an interband handover, since the test set currently has one BCH (cell).

The test set has the ability to switch traffic channels from:

  • EGSM/PGSM/RGSM to DCS/PCS/GSM450/GSM480/GSM750/GSM850/TGSM810
  • GSM450 to EGSM/PGSM/RGSM/DCS/PCS/GSM480/GSM750/GSM850/TGSM810
  • GSM480 to EGSM/PGSM/RGSM/DCS/PCS/GSM450/GSM750/GSM850/TGSM810
  • GSM750 to EGSM/PGSM/RGSM/DCS/PCS/GSM450/GSM480/GSM850/TGSM810
  • GSM850 to EGSM/PGSM/RGSM/DCS/PCS/GSM450/GSM480/GSM750/TGSM810
  • DCS/PCS to EGSM/PGSM/RGSM/GSM450/GSM480/GSM750/GSM850/TGSM810
  • TGSM810 to EGSM/PGSM/RGSM/DCS/PCS/GSM450/GSM480/GSM750/GSM850

No other combinations of traffic channel band handovers are supported. Also, the traffic channel band can only be changed when an active link exists between the test set and a mobile station. See Establishing an Active GSM Link with the Mobile Station or for GPRS and EGPRS see, Step 4: Make a Connection .

There are parameters that can be set up to take on different values depending on the broadcast band currently selected. These are called Frequency Banded Parameters . After a handover, the frequency banded parameters for the new band are active. Only one set of frequency banded parameters is active at any one time. However, you can set up any of the traffic channel parameters for bands involved in the handover because the test set remembers the settings and switches to them when the handover occurs.

Related Topics

  • Step 6: Reconfigure Test Set and Mobile Station Connection Parameters


Programming a Dynamic Power Measurement

Programming a Dynamic Power Measurement

This section provides an example of how to make a Dynamic Power measurement via the GPIB.

The following procedure assumes that an active link is established between the test set and the mobile station. See Establishing an Active GSM Link with the Mobile Station .

  1. Configure the Dynamic Power measurement parameters using the SETup subsystem.
  2. Initiate and fetch the Dynamic Power measurement using the READ? subsystem.

Programming Example

The following program shows how to use the Dynamic Power measurement to measure a GSM mobile station's power control level capability when using SACCH (Slow Associated Control Channel) TX Level Signaling. This technique is based upon the RF power control characteristics specified in GSM 05.08 section 6.3.0 Release 1997.

10 !
20     !
30       ! INITIALIZE VARIABLES IN THE TEST
40       !
50    Sacch_time=TIMEDATE     ! Set up a variable to capture test time
60    OPTION BASE 1     ! Set default lower bound of array subscripts to 1
70    REAL Integ1(100),Txp1(100),Power(300)
80    REAL Integ2(100),Txp2(100),Integ3(100),Txp3(100)
90    REAL Start_power,Stop_power,P_sum,Pave
100    INTEGER Test_set,I,Start_level,Stop_level,Count
110    Test_set=714
120    Start_level=5
130    Start_power=33.0
140    Stop_level=15
150    Stop_power=13.0
160    Count=0
170       !
180    OUTPUT Test_set;"RFAN:MAN:POW:BURS1 33"     ! Set expected power
190    OUTPUT Test_set;"SYST:CORR -1.2"      ! Set value to compensate for cable loss
200       !
210       ! SETUP DPOW PARAMETERS
220    OUTPUT Test_set;"SET:DPOW:CONT OFF;EMD 2"
230    OUTPUT Test_set;"SET:DPOW:COUN:NUMBER 300"     ! Set the number of bursts high enough
240                                                   ! to capture all 10 power level changes
250    OUTPUT Test_set;"CALL:SIGN:MS:TXL:FACCH 1"    ! Switch on FACCH mode
260    OUTPUT Test_set;"SETup:DPOW:RANGe:OFFset 0"    ! Set the range offset to zero.
270       !
280       ! CHANGE POWER LEVEL FROM 5 TO 15
290    OUTPUT Test_set;"CALL:MS:TXL:SEQ ";Start_level
300    OUTPUT Test_set;"CALL:SIGN:MS:TXL:FACCH 0"     ! Switch off FACCH signaling - only
310                                                   ! SACCH header is used
320    OUTPUT Test_set;"CALL:MS:TXL:SEQ ";Stop_level
330       !
340     ! A SHORT WAIT MIGHT BE NEEDED HERE TO ENSURE 100 PERCENT RELIABILITY OF MEASUREMENT
350     ! THIS MAY BE DEPENDENT ON THE PHONE AND IS TO ENSURE THAT VERY LAST POWER STEP IS
360     ! ALWAYS CAPTURED
370     ! WAIT .1
380       !
390       ! INITIATE DPOW MEASUREMENT AND FETCH RESULTS
400 !
410    OUTPUT Test_set;"READ:DPOW?"
420    ENTER Test_set;Integ1(*),Txp1(*)
430    OUTPUT Test_set;"FETC:DPOW:RANG2?"
440    ENTER Test_set;Integ2(*),Txp2(*)
450    OUTPUT Test_set;"FETC:DPOW:RANG3?"
460    ENTER Test_set;Integ3(*),Txp3(*)
470       !
480       ! LOAD TXP RESULTS WHICH HAVE VALID INTEGRITY INTO ARRAY
490       !
500       ! PROCESS BURSTS 1 TO 100
510    K=1
520    FOR J=1 TO 100
530        IF Integ1(J)=0 THEN
540            Power(K)=Txp1(J)
550            K=K+1
560        END IF
570    NEXT J
580       ! PROCESS BURSTS 101 TO 200
590    FOR J=1 TO 100
600        IF Integ2(J)=0 THEN
610            Power(K)=Txp2(J)
620            K=K+1
630        END IF
640    NEXT J
650       ! PROCESS BURSTS 201 TO 300
660    FOR J=1 TO 100
670        IF Integ3(J)=0 THEN
680            Power(K)=Txp3(J)
690            K=K+1
700        END IF
710    NEXT J
720       !
730    PRINT
740 !
750 ! PRINT MEASUREMENT RESULTS
760       PRINT "Measured TX Levels from 5 to 15 using SACCH Method"
770       I=1
780       FOR J=Start_level TO Stop_level
790         LOOP
800           IF I=(K-1) THEN
810           !If this is the last burst measured, then...
820               P_sum=P_sum+Power(I)  !Add to the existing sum.
830               Count=Count+1         !Increment counter.
840               Pave=P_sum/Count      !Find the average Power for the current MS TX Level.
850               PRINT "MS TX LEVEL=";J,"MEASURED POWER=";PROUND(Pave,-4)
860               GOTO 1000
870           END IF
880         !
890         EXIT IF (PROUND(Power(I),-2)-PROUND(Power(I+1),-2))>=.8
900         !A difference >=.8 corresponds to a change in the MS TX Level.
910         !
920         P_sum=P_sum+Power(I)
930         !Sum the burst power for the particular MS TX Level.
940         Count=Count+1
950         !counter for the number of bursts measured at the current MS TX Level
960         I=I+1
970         END LOOP
980         Pave=P_sum/Count
990         PRINT "MS TX LEVEL=";J,"MEASURED POWER=";PROUND(Pave,-4)
1000         P_sum=0
1010         Count=1
1020         I=I+1
1030       NEXT J
1040 ! PRINT TOTAL TIME FOR PROGRAM TO COMPLETE
1050    PRINT "Total Test Time=";PROUND(TIMEDATE-Sacch_time,-2);"Seconds"
1060    END

Returned Values

The measurements returned by this program are:

  • Integ1 , Integ2 , and Integ3 return the measurement integrity indicators for each of the ranges used when the Dynamic Power measurement is made over 300 bursts (0 means a successful measurement with no errors). If you require more details, see Integrity Indicator .
  • Txp1() , Txp2() , and Txp3() return the average TX power results for each of the ranges used over 300 bursts. For example, Txp1() returns average TX power results for bursts 1 to 100.
  • Power() returns average TX power results for all bursts which have been successfully measured with no errors. That is, only results with an integrity indicator of 0 are contained in Power() . This program does not display the entire contents of the Power() array. It only displays the results which correlate with power level changes 5 to 15.
  • Sacch_time returns the total test time.

Related Topics

Dynamic Power Measurement Description


Programming a Modulation Accuracy Measurement

Programming a Modulation Accuracy Measurement

This section is only applicable to EGPRS.

The following procedure assumes that the mobile station is connected to the test set's RF IN/OUT connector.

  1. Change the serving cell to EGPRS. To do this via GPIB, you must first turn the cell off. See the following procedure.
    1. Turn the cell off using the CALL:OPER:MODE OFF command.
    2. Change the serving cell to EGPRS using the CALL:BCH:SCEL EGPRS command.
    3. Turn the cell back on using the CALL:OPER:MODE CALL command.
  2. Set the connection type to ETSI A using the CALL:FUNC:CONN:TYPE A command.
  3. Set the modulation and coding scheme to one which uses 8PSK modulation.
  4. Set up the modulation accuracy measurement parameters using the SETup:EMACcuracy parameters (See SETup:EMACcuracy for more information.)
  5. Turn on the mobile station and allow it to attach.
  6. Start the data connection.
  7. Use a hanging query to determine when the connection has started and to provide synchronization between your program and the test set.
  8. Initiate the modulation accuracy measurement.
  9. Fetch the measurement results using a FETCh:EMACcuracy? query. (See FETCh:EMACcuracy for more information.)

Programming Example:

10    ! Turn the cell off to access the serving cell parameter
20    OUTPUT 714;"CALL:OPER:MODE OFF"
30    ! Change the serving cell to EGPRS
40    OUTPUT 714;"CALL:BCH:SCEL EGPRS"
50    ! Turn the cell back on
60    OUTPUT 714;"CALL:OPER:MODE CALL"
70    ! Set the connection type to ETSI Type A
80    OUTPUT 714;"CALL:FUNC:CONN:TYPE A"
90    ! Select a Modulation and Coding Scheme using 8PSK
100   OUTPUT 714;"CALL:PDTCH:MCSC MCS9,MCS9"
110   OUTPUT 714;"SET:EMAC:CONT OFF"!Set trigger mode to single
120   OUTPUT 714;"SET:EMAC:COUN 5"! Turn statisical results on
130   ! Turn measurement timeout on and set to 5 seconds
140   OUTPUT 714;"SET:EMAC:TIM 5"
150   !
160   !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
170   ! Turn on the mobile station and allow it to attach
180   !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
190   !
200   ! Start the data connection
210   OUTPUT 714;"CALL:FUNC:DATA:START"
220   ! Hanging query to determine when the data connection
230   !  has been established.
240   OUTPUT 714;"CALL:TRAN?"
250   ENTER 714;Tran_state
260   IF NOT Tran_state THEN
270     PRINT "DATA CONNECTION FAILED"
280     STOP
290   END IF
300   OUTPUT 714;"INIT:EMAC" ! Initiate measurement
310   ! The query below fetches the measurement results required
320   !  by the conformance specification for modulation accuracy.
330   OUTPUT 714;"FETC:EMAC:ETSI?"! Fetch measurement results
340   ENTER 714;Integrity,Rms_evm,Peak_evm,Percentile,Ferr,Origin_offset
350   END

Returned Values

The measurements returned by the FETCh? query in the programming example above are:

  • Integrity returns the measurement Integrity Indicator (0 means a successful measurement with no errors).
  • Rms_evm returns the RMS Error Vector Magnitude in percent.
  • Peak_evm returns the Peak Error Vector Magnitude in percent.
  • Percentile returns the 95th Percentile Error Vector Magnitude in percent.
  • Ferr returns the frequency error in hertz.
  • Origin_offset returns the origin offset suppression in dB.

Related Topics

Modulation Accuracy Measurement Description

How do I make Modulation Accuracy Measurements?

Modulation Accuracy Troubleshooting

SETup:EMACcuracy

FETCh:EMACcuracy


Programming a Fast Bit Error Measurement

Programming a Fast Bit Error Measurement

This measurement is not applicable to GPRS or EGPRS.

This section provides an example of how to make the fast bit error (FBER) measurement via GPIB.

The following procedure assumes that an active link is established between the test set and the mobile station. See Establishing an Active GSM Link with the Mobile Station .

  1. Set the cell power to a good level.
  2. Configure FBER measurement parameters using the SETup subsystem.
  3. Set the cell power to a low level for a FBER measurement.
  4. Start the FBER measurement using the INITiate subsystem.
  5. Use the FETCh? command to obtain FBER measurement results.
  6. Set the cell power to a good level.

Programming Example

10    OUTPUT 714;"SETUP:FBERROR:TIMEOUT:TIME 5" ! BER measurement times out after
20                                              ! 5 seconds.
30    OUTPUT 714;"CALL:CELL:POWER:AMPLITUDE -85 DBM" ! Sets the cell power level to
40                                                   ! a good level.
50    OUTPUT 714;"SETUP:FBERROR:CONTINUOUS OFF" ! Configures a BER measurement to
60                                              ! Single Trigger.
70    OUTPUT 714;"SETUP:FBERROR:COUNT 10000" ! Sets the number of bits to measure
80                                           ! at 10,000.
90    OUTPUT 714;"SETUP:FBERROR:CLSDELAY:STIME 500 MS" ! Sets the Close Loop Delay
100                                                    ! to 500 ms.
110   OUTPUT 714;"SETUP:FBERROR:SLCONTROL ON" ! Sets the Signal Loop Control state to on.
120   OUTPUT 714;"SETUP:FBERROR:LDCONTROL:AUTO OFF" ! Configure loopback delay
130                                                 ! control to manual.
140   OUTPUT 714;"SETUP:FBERROR:MANUAL:DELAY 6" ! Set frame delay to 6 frames in order
150                                             ! to correlate uplink and downlink bits.
160   OUTPUT 714;"CALL:CELL:POWER:AMPLITUDE -102 DBM" ! Sets the cell power level
170                                                   ! to a "low" level for the
180                                                   ! BER measurement.
190   OUTPUT 714;"INITIATE:FBERROR"  ! Start a FBER measurement.
200   OUTPUT 714;"FETCH:FBERROR?"
210   ENTER 714;Integrity,Bits_tested,Fas_bit_ratio,Fas_bit_err_cnt
220   OUTPUT 714;"CALL:CELL:POWER:AMPLITUDE -85 DBM" ! Sets the cell power level
230                                                  ! to a good level.
240   END

Returned values

The measurements returned by this program are:

  • Integrity returns the measurement Integrity Indicator (0 means a successful measurement with no errors).
  • Bits_tested returns the number of bits tested.
  • Bit_error_ratio retuns the ratio of bit errors to total bits tested, in percent (%).
  • Bit_error_count returns the number of bit errors.

Related Topics

Fast Bit Error Measurement Description

SETup:FBERror

INITiate

FETCh:FBERror

GSM/GPRS Control Program Example


Programming a Frequency Stability Measurement

Programming a Frequency Stability Measurement

December 3, 2008

This section provides an example of how to make analog Frequency Stability measurements via GPIB.

The following program example assumes that the mobile's antenna output is connected to the RF IN/OUT connector, and the mobile is on an analog voice channel (AVC). For information on configuring the test set to get the mobile on an active call, see Establishing an Active GSM Link with the Mobile Station .

The test set uses the AVC Channel (CALL:SET:AVC) and MS TX Level (CALL:SET:MS:ANALog:TXLevel) settings of the base station emulator for the expected frequency and power level. To manually set the expected frequency and power, see Receiver Control .

The basic procedure to test Frequency Stability is as follows:

  1. Enter the expected frequency and power.
  2. Define the Frequency Stability Setup parameters as desired for measurement timeout and multi-measurements.
  3. Use the READ:FSTability command to initiate and fetch the measurement results.

Programming Example

10       !Set the expected frequency and power.
20       OUTPUT 714;"SETup:FSTability:CONTinuous OFF"!Set the frequency stability
30                                              !measurement to single trigger mode.
40       OUTPUT 714;"SETup:FSTability:TIMeout 1 S"!Set a timeout value of 1 second
50                                          !in case the measurement cannot be made.
60       OUTPUT 714;"SETup:FSTability:COUNt 5"!Set multi-measurements to 5.
70       OUTPUT 714;"READ:FSTability?"!Query the returned integrity indicator and the
80            !Worst Case Frequency Error and average Frequency measurements.
90       ENTER 714;Integrity,Freq_error,Frequency !Enter the returned values into variables.
100      IF Integrity=0 THEN !See if the integrity value = 0 (valid measurement).
110      ELSE
120           PRINT "Measurement problem; check for signal level over/under range condition."
130      END IF
140      PRINT "Integrity = ";Integrity !Prints the Integrity Indicator
150      PRINT "Frequency = ";Frequency !Prints the Frequency
190      END

Returned Values

The measurements returned by this program are:

  • Integrity returns the measurement integrity indicator (see Integrity Indicator ); 0 means a successful measurement with no errors.
  • Freq_error returns the worst case frequency error in parts per million (PPM). Frequency returns the average frequency.

Related Topics

Frequency Stability Measurement Description

Frequency Stability Measurement Troubleshooting

INITiate

SETup:FSTability

FETCh:FSTability

GSM/GPRS Control Program Example

Receiver Control


Programming in Fast Device Tune Operating Mode

Programming in Fast Device Tune Operating Mode

December 3, 2008

This section provides examples of how to perform transmitter and receiver calibrations in Fast Device Tune operating mode.

Receiver Calibration

The following program example assumes that the mobile's antenna output is connected to the RF IN/OUT connector.

The basic procedure to calibrate the mobile's receiver in Fast Device Tune operating mode is as follows:

  1. Enter Fast Device Tune operating mode.
  2. Configure Downlink Test Sequence parameters.
  3. Command the test set to start the transmission of Downlink Test Sequence,

Programming Example

80        ! ====================================================================
90        ! This program is intended to calibrate the receiver of a mobile
100       ! ====================================================================
110       !
120       ! *** Initialize Program Variables ***
130       !
140         OPTION BASE 0
150         Testset=714
160         CLEAR SCREEN
170         CLEAR 7
180         CLEAR Testset
190         PRINT "*** Fast Device Tune transmitter calibration Program ***"
200         PRINT
210         !
220         !***Set up GPIB timeout***
230         ON TIMEOUT 7,32 CALL Timeout
240         ! Call "Timeout" routine after 32 seconds of GP-IB hang-up
250         !
260         !*** Variable declarations for the FDT measurements ***
270         !
280         Op_mode$="FDT"   !Operation mode.
290         Num_dts_steps=5  !Number of Downlink Sequence Steps
300         !
310         !Uncomment the pass loss varables and set the value as needed.
320         !Loss_frequency$=" 8.3652E+8,8.60E+8" !Set frequencies for path loss.
330         !Expected_loss$=" -1.5,-1.5" !Set path loss at frequencies specified
340         !
350         !************************************
360         !***Simple Test Executive
370         !************************************
380         !
390         GOSUB Preset_test_set
400             !End any current connection and preset test set
410         !GOSUB Set_path_loss
420             !If needed, uncomment this line and set the pass loss required for your test.
430         GOSUB Set_init_cond
440             !Set initial conditions required for the FDT test
450         GOSUB Set_dts_series
460             !Set up and transmit the DTS
470         GOTO End_program
480             !End the program
490         !
500         !**************************************************************************
510         ! BEGINNING OF SUBROUTINES
520         !**************************************************************************
530         !
540  Preset_test_set:             !
550         !*******************************************************************
560         ! Subroutine: Preset the test set
570         !*******************************************************************
580         !
590         OUTPUT Testset;"*Rst"
600             ! Full preset test set
610         OUTPUT Testset;"*OPC?"
620         ENTER Testset;Opc$
630         RETURN
640         !
650  Set_path_loss:         !
660         !*******************************************************************
670         ! Subroutine: Set path loss values
680         !*******************************************************************
690         !
700         OUTPUT Testset;"SYST:CORR:FREQ";Loss_frequency$
710             ! Set the frequencies for amplitude offset
720         OUTPUT Testset;"SYST:CORR";Expected_loss$
730             ! Set the amplitude offsets for above frequencies
740         RETURN
750         !
760  Set_init_cond:         !
770         !*******************************************************************
780         ! Subroutine: Set initial conditions required for the FDT Test
790         !*******************************************************************
800         !
810         OUTPUT Testset;"CALL:OPER:MODE ";Op_mode$
820             !Set Operating Mode to Fast Device Tune Mode
830         RETURN
840         !
850  Set_dts_series:           !
860         !*******************************************************************
870         ! Subroutine: Set up the downlink test sequence for MS Receiver test
880         !*******************************************************************
890         !
900         !
910         PRINT "*** Set DTS Continuous to OFF***"
920         OUTPUT Testset;"GFDT:DOWN:TSEQ:CONT 0"
930         PRINT
940         PRINT "*** Set the number of DSSs in the DTS to 5***"
950         OUTPUT Testset;"GFDT:DOWN:TSEQ:SST ";Num_dts_steps
960         PRINT "Number of DSS in the DTS =";Num_dts_steps
970         PRINT
980         PRINT "*** Set DTS power level Allocation ***"
990         OUTPUT Testset;"GFDT:DOWN:TSEQ:PLEV:FRAM PL1,MIX"
1000        PRINT
1010        PRINT "*** Set DTS power level ***"
1020        OUTPUT Testset;"GFDT:DOWN:TSEQ:PLEV1 -50"
1030        OUTPUT Testset;"GFDT:DOWN:TSEQ:PLEV2 -60"
1040        OUTPUT Testset;"GFDT:DOWN:TSEQ:PLEV3 -70"
1050        OUTPUT Testset;"GFDT:DOWN:TSEQ:PLEV4 -80"
1060        PRINT
1070        PRINT "*** Set DTS Power Levels for TS1 through TS5 ***"
1080        OUTPUT Testset;"GFDT:DOWN:TSEQ:PLEV:TSL0 PL1"
1090        OUTPUT Testset;"GFDT:DOWN:TSEQ:PLEV:TSL1 PL2"
1100        OUTPUT Testset;"GFDT:DOWN:TSEQ:PLEV:TSL2 PL3"
1110        OUTPUT Testset;"GFDT:DOWN:TSEQ:PLEV:TSL3 PL4"
1120        OUTPUT Testset;"GFDT:DOWN:TSEQ:PLEV:TSL4 PL3"
1130        OUTPUT Testset;"GFDT:DOWN:TSEQ:PLEV:TSL5 PL2"
1140        PRINT
1150        PRINT "*** Set DTS frequency for each DSS ***"
1160        OUTPUT Testset;"GFDT:DOWN:TSEQ:FREQ 9e+8,8.5e+8,9e+8,9.5e+8,1e+9"
1170        PRINT
1180        PRINT "*** Set DTS Repeat Count for each step ***"
1190        OUTPUT Testset;"GFDT:DOWN:TSEQ:REP 10,1,1,1,2"
1200        PRINT
1210        PRINT "*** Set DTS Burst Type for TS1 through TS5 ***"
1220        OUTPUT Testset;"GFDT:DOWN:TSEQ:BURS:TYPE:TSL0 FCB,FSB,FSB,DUMMY,PRBS"
1230        OUTPUT Testset;"GFDT:DOWN:TSEQ:BURS:TYPE:TSL1 DUMMY,PRBS,FSB,DUMMY,PRBS"
1240        OUTPUT Testset;"GFDT:DOWN:TSEQ:BURS:TYPE:TSL2 DUMMY,PRBS,DUMMY,DUMMY,PRBS"
1250        OUTPUT Testset;"GFDT:DOWN:TSEQ:BURS:TYPE:TSL3 DUMMY,PRBS,DUMMY,DUMMY,PRBS"
1260        OUTPUT Testset;"GFDT:DOWN:TSEQ:BURS:TYPE:TSL4 DUMMY,OFF,OFF,OFF,PRBS"
1270        OUTPUT Testset;"GFDT:DOWN:TSEQ:BURS:TYPE:TSL5 DUMMY,OFF,OFF,OFF,PRBS"
1280        PRINT
1290        !
1380        PRINT "Start the transmission of DTS"
1390        OUTPUT Testset;"GFDT:DOWN:TSEQ:STAR"
1400        PRINT
1410        !
1420        RETURN
1430         !
1440  End_program:          !
1450        !*******************************************************************
1460        ! Subroutine: End of all testing clean up
1470        !*******************************************************************
1480        !
1490        OUTPUT Testset;"*Rst"
1500            ! Full preset test set
1510        OUTPUT Testset;"*OPC?"
1520        ENTER Testset;Opc$
1530        PRINT
1540        PRINT "End of Program"
1550        END
1560        !
1570        !**************************************************************************
1580        ! SUB-PROGRAM SECTION: Global timeout handler
1590        !**************************************************************************
1610  Timeout: SUB Timeout
1620             PRINT
1630             PRINT "Program timed out, check setup"
1640             CLEAR 7
1650             CLEAR Testset
1660             STOP
1670        SUBEND
1680         !

Transmitter Calibration

The following program example assumes that the mobile's antenna output is connected to the RF IN/OUT connector.

The basic procedure to calibrate the transmitter in Fast Device Tune operating mode is as follows:

  1. Enter Fast Device Tune operating mode.
  2. Configure Uplink Test Sequence parameters.
  3. Configure the transmit power measurement related parameters.
  4. Query the number of TDMA frames in an USS.
  5. Command the MS to transmit the Uplink Test Sequence when the transmit power measurement is ARMed.
  6. Use FETCh:TXPower command to fetch the measurement results

Programming Example

10       ! ====================================================================
20       ! This program is intended to calibrate the transmitter of a mobile.
30       ! ====================================================================
40       !
50       ! *** Initialize Program Variables ***
60       !
70           OPTION BASE 0
80           Testset=714
90           CLEAR SCREEN
100          CLEAR 7
110          CLEAR Testset
120          PRINT "*** Fast Device Tune (GFDT) Measurement Program for GSM/GPRS/EGPRS***"
130          PRINT
140          !
150          !***Set up GPIB timeout***
160          ON TIMEOUT 7,32 CALL Timeout
170          ! Call "Timeout" routine after 32 seconds of GP-IB hang-up
180          !
190          ! *** Variable declarations for the FDT measurements ***
200          !
210          DIM Meas_bpow$[500],Meas_cpow$[500]
220          ALLOCATE REAL Meas_bpow_res(0:49),Meas_cpow_res(0:49)
230          !
240          Burst_measured=5 !Set the burst to be measured to 5
250          Op_mode$="FDT"   !Operation mode.
260          Meas_timeout=50  !Measurement timeout.
270          Num_uts_steps=5  !Number of Uplink Sequence Steps
280          Uts_burst_cnts=7 !Number of bursts per Uplink Sequence Steps
290          Arm_state=0      !The arm state of the transmit power measurement.
300          !
310          !Uncomment the pass loss varables and set the value as needed.
320          !Loss_frequency$=" 8.3652E+8,8.60E+8" !Set frequencies for path loss.
330          !Expected_loss$=" -1.5,-1.5" !Set path loss at frequencies specified
340          !
350          !************************************
360          !***Simple Test Executive
370          !************************************
380          !
390          GOSUB Preset_test_set
400          !End any current connection and preset test set
410          !GOSUB Set_path_loss
420          !If needed, uncomment this line and set the pass loss required for your test.
430          GOSUB Set_init_cond
440          !Set initial conditions required for the FDT test
450          GOSUB Check_ms_config
460          !Check MS configuration state
470          GOSUB Set_uts_series
480          !Set up the MS Tx Freq/Power Series
490          GOSUB Fetch_txp_res
500          !Query TXP measurement results
510          GOTO End_program
520          !
530          !
540          !**************************************************************************
550          ! BEGINNING OF SUBROUTINES
560          !**************************************************************************
570          !
580          !
590   Preset_test_set:             !
600          !*******************************************************************
610          ! Subroutine: Preset the test set
620          !*******************************************************************
630          !
640          OUTPUT Testset;"*Rst"
650              ! Full preset test set
660          OUTPUT Testset;"*OPC?"
670          ENTER Testset;Opc$
680          RETURN
690          !
700   Set_path_loss:         !
710          !*******************************************************************
720          ! Subroutine: Set path loss values
730          !*******************************************************************
740          !
750          OUTPUT Testset;"SYST:CORR:FREQ ";Loss_frequency$
760              ! Set the frequencies for amplitude offset
770          OUTPUT Testset;"SYST:CORR ";Expected_loss$
780              ! Set the amplitude offsets for above frequencies
790          RETURN
800          !
810   Set_init_cond:         !
820          !*******************************************************************
830          ! Subroutine: Set initial conditions required for the FDT Test
840          !*******************************************************************
850          !
860          OUTPUT Testset;"CALL:OPER:MODE ";Op_mode$
870              !Set Operating Mode to Fast Device Tune Mode
880          RETURN
890          !
900   Set_uts_series:            !
910          !*******************************************************************
920          ! Subroutine: Set up the uplink test sequence for MS transmitter test
930          !*******************************************************************
940          !
950          PRINT "*** Set the number of uplink sequence steps in the UTS to 5***"
960          OUTPUT Testset;"GFDT:UPL:TSEQ:SST ";Num_uts_steps
970          PRINT "Number of USS in the UTS =";Num_uts_steps
980          PRINT
990          PRINT "*** Set UTS Burst Count to 7 ***"
1000         OUTPUT Testset;"GFDT:UPL:TSEQ:BURS:COUN ";Uts_burst_cnts
1010         PRINT
1020         PRINT "*** Set UTS frequency for each USS ***"
1030         OUTPUT Testset;"GFDT:UPL:TSEQ:FREQ 9e+8,8.5e+8,9e+8,9.5e+8,1e+9"
1040         PRINT
1050         !
1060         PRINT "*** Set the TXP measurement related parameters***"
1070         OUTPUT Testset;"CALL:MOD:MAN:BURS1 GMSK"
1080         OUTPUT Testset;"CALL:MOD:MAN:BURS2 GMSK"
1090         OUTPUT Testset;"CALL:MOD:MAN:BURS3 GMSK"
1100         OUTPUT Testset;"CALL:MOD:MAN:BURS4 GMSK"
1110         OUTPUT Testset;"CALL:MOD:MAN:BURS5 GMSK"
1120         OUTPUT Testset;"CALL:MOD:MAN:BURS6 GMSK"
1130         OUTPUT Testset;"CALL:MOD:MAN:BURS7 GMSK"
1140             !Set the expected modulation format for each uplink burst.
1150         OUTPUT Testset;"RFAN:CONT:POW:AUTO OFF"
1160             !Set receiver power control to manual mode.
1170         OUTPUT Testset;"RFAN:MAN:POW:BURS1 13"
1180         OUTPUT Testset;"RFAN:MAN:POW:BURS2 13"
1190         OUTPUT Testset;"RFAN:MAN:POW:BURS3 13"
1200         OUTPUT Testset;"RFAN:MAN:POW:BURS4 13"
1210         OUTPUT Testset;"RFAN:MAN:POW:BURS5 13"
1220         OUTPUT Testset;"RFAN:MAN:POW:BURS6 13"
1230         OUTPUT Testset;"RFAN:MAN:POW:BURS7 13"
1240             !Set the power level that the test set's receiver is expecting
1250             !the mobile station uplink burst to transmit at to 13dBm.
1260         !
1270         OUTPUT Testset;"SET:TXP:TIM:STIME "&VAL$(Meas_timeout)
1280             !Set measurement timeout.
1290         !
1300         OUTPUT Testset;"SET:TXP:COUN:STAT OFF"
1310             !Set TXP multi measurement state.
1320         !
1330         OUTPUT Testset;"SET:TXP:TRIG:DEL 0"
1340             !Set TXP measurement trigger delay to zero.
1350             !
1390         OUTPUT Testset;"SET:TXP:RANG:AUTO OFF"
1400             !Set auto range to highest burst state to OFF.
1410             !
1450         OUTPUT Testset;"SET:TXP:SST:FRAMES?"
1460             !Query how many frames are required for each uplink sequence step
1470         !
1480         RETURN
1490         !
1500  Check_ms_config:               !
1510         !*******************************************************************
1520         ! Subroutine: Check MS Configuration Matching Test Set's
1530         !*******************************************************************
1540         PRINT "************** NOTE *****************************************"
1550         PRINT "Make sure that your MS is placed into a test mode, and is properly"
1560         PRINT "configured to transmit the UTS to the right number USSs and TDMA frames"
1570         PRINT "in each USS."
1580         PRINT "*************************************************************"
1590         PRINT
1600         LINPUT "Press ENTER when finished",Keyboard$
1610         RETURN
1620         !
1630  Fetch_txp_res:                    !
1640         !*******************************************************************
1650         ! Subroutine: Perform FDT Measurement
1660         !*******************************************************************
1670         !
1680         !
1690         PRINT "*** Initiate the transmit power measurement"
1710         OUTPUT Testset;"INIT:TXP"
1740         !
1750         PRINT "*** Check the Arm State of the transmit power measurement"
1760         LOOP
1761             OUTPUT Testset;"INIT:TXP:GFDT:ARM?";Arm_state
1762             EXIT IF Arm_state=1
1763             PRINT "The Transmit Power measurement is not armed"
1764         END LOOP
1770         !
1780         BEEP
1790         PRINT "Command the MS to start sending Uplink Test Sequence ..."
1800         LINPUT "Press ENTER when finished",Keyboard$
1810         !
1811         !
1820         !*********Fetch and display the measurement result for Burst 5*********
1821         OUTPUT Testset;"FETC:TXP:TSEQ:BPOW? ";Burst_measured
1830         ENTER Testset;Meas_bpow$
1840         OUTPUT Testset;"FETC:TXP:TSEQ:CPOW? ";Burst_measured
1850         ENTER Testset;Meas_cpow$
1860         !
1870         FOR N=0 TO Num_uts_steps-1
1880             Dynamic_mkr=(N*17)
1890             !Set up a marker that will jump to each comma in the ascii string
1900             Meas_bpow_res(N)=VAL(Meas_bpow$[Dynamic_mkr+1,Dynamic_mkr+16])
1910             Meas_cpow_res(N)=VAL(Meas_cpow$[Dynamic_mkr+1,Dynamic_mkr+16])
1920             !Convert ascii to a numeric value
1930         NEXT N
1940         !
1950         OUTPUT Testset;"FETC:TXP:INT?"
1960         ENTER Testset;Integrity
1970         !
1980         PRINT "*** Print MS Tx Measurement Results ***"
1990         PRINT
2000         PRINT "integrity=";Integrity
2010         PRINT "Number of UTS Steps = ";Num_uts_steps
2020         PRINT "Total Number of Meas Results = ";Num_uts_steps
2030         PRINT
2040         !
2050         PRINT "Burst Number #   Sequence Step #   Burst Power #   Carrier Power"
2060         PRINT
2070             FOR N=0 TO Num_uts_steps-1
2080                 PRINT Burst_measured," ",N+1," ",Meas_bpow_res(N)," ",Meas_cpow_res(N)
2090             NEXT N
2100         RETURN
2110         !
2120  End_program:          !
2130         !*******************************************************************
2140         ! Subroutine: End of all testing clean up
2150         !*******************************************************************
2160         !
2170         OUTPUT Testset;"*Rst"
2180             ! Full preset test set
2190         OUTPUT Testset;"*OPC?"
2200         ENTER Testset;Opc$
2210         PRINT
2220         PRINT "End of Program"
2230         DEALLOCATE Meas_bpow_res(*),Meas_cpow_res(*)
2240         END
2250         !
2260         !**************************************************************************
2270         ! SUB-PROGRAM SECTION
2280         !**************************************************************************
2290                 !
2300  Timeout: SUB Timeout                 ! Global timeout handler
2310              PRINT
2320              PRINT "Program timed out, check setup"
2330              CLEAR 7
2340              CLEAR Testset
2350              STOP
2360         SUBEND
2370         !

Returned Values

The measurements returned by this program are:

  • Integrity returns the measurement integrity indicator (see Integrity Indicator ). 0 means a successful measurement with no errors.
  • Burst Power returns the average carrier power in dBm of Burst 5 for all USSs.
  • Carrier Power returns the average carrier power in dBm of Burst for all USSs5.

The MUI screen of the transmit power measurement displays the measurement results for the USS specified by the parameter Fast Device Tune Result Set only.

Related Topics

Fast Device Tune

Fast Device Tune Capable Measurement

INITiate

GFDTune:UPLink

GFDTune:DOWNlink

SETup:TXPower

FETCh:TXPower

Receiver Control


Dealing With Semicolon Separated Response Data Lists

Dealing With Semicolon Separated Response Data Lists

Description

In accordance with IEEE 488.2-1992 Section 8.4.1 the test set uses the semicolon (;) as the response message unit separator (RMUS). The RMUS separates sequential response message unit elements from one another when multiple response message unit elements are sent in a response message. This condition would occur when combining multiple queries into a single GPIB transaction.

Query Response Data Types Used By Test Set

The test set can return the following data types in response to queries:

  • character data (char): ASCII characters A-Z (65-90 decimal), underscore (95 decimal), digits (48-57 decimal).

  • string data: ASCII characters enclosed in quotes (for example, "5551212" or "PGSM")

  • numeric response data (nr1): numeric data in the form +/- dddddddd

  • numeric response data (nr3): numeric data in the form +/- ddd.ddd E +/- dddd

Semicolon Separated Response Data Lists Containing Mixed Data Types

Problems can occur when trying to enter semicolon separated response data lists containing mixed data types.

For example: If the following command string is sent to the test set, the test set will respond by constructing a response message which contains multiple response message unit elements (that is, one response message unit element for each query item contained in the command string). Some response message unit elements are string data type, some are character data type and some are nr3 data type.

OUTPUT 714;"CALL:MS:REP:IMSI?;PCL?;REV?;SBAN?;ONUM?;MCC?;MNC?;LAC?"

An example response message generated by the test set in response to the above OUTPUT statement would be:

"001012345678901";+4.00000000E+000;PHAS1;"PGSM";"5551212";9.91E37;9.91E37;9.91E37

Constructing the following data entry statement will account for multiple responses from the query:

ENTER 714;Imsi$,Pcl,Rev$,Sban$,Onum$,Mcc,Mnc,Lac

In the Basic programming environment the above ENTER statement will fail with an `Insufficient data for ENTER' error. Some programming languages, Basic for example, cannot use the semicolon character as a data item terminator for string variables. In this example Basic will attempt to enter data into Imsi$ until it sees a LF (line feed) data item terminator. The test set does not send the LF until all the data has been sent. Consequently when Basic sees the LF it terminates entry of data into Imsi$ and starts to look for data to enter into Pcl. Since the test set is no longer sending any data the error message `Insufficient data for ENTER' is generated.

One possible workaround is to enter all the data into a single string variable, replace all semicolons with line feeds and then enter the data from the string into the individual data items. For example:

DIM Response$[500]
!
!
OUTPUT 714;"CALL:MS:REP:IMSI?;PCL?;REV?;SBAN?;ONUM?;MCC?;MNC?;LAC?"
ENTER 714;Response$
Semicolon=POS(Response$,";")
WHILE Semicolon
Response$[Semicolon,Semicolon]=CHR$(10)
Semicolon=POS(Response$,";")
END WHILE
ENTER Response$;Imsi$,Pcl,Rev$,Sban$,Onum$,Mcc,Mnc,La

Semicolon Separated Response Data Lists Containing Only Numeric Data Types

Semicolon separated response data lists containing only numeric data types do not present the types of problem associated with semicolon separated response data lists containing mixed data types. The number building routines in most languages will use any non-numeric character (that is, anything other than +/- 0123456789 E .) as the data item terminator. Consequently when the number building routines encounter the semicolon the data item is terminated. The following example illustrates this:

OUTPUT 714;"FETCH:TXP:INT?;POW:MIN?;MAX?"
ENTER 714;Integrity,Min_power,Max_power


Concurrent Measurements

Concurrent Measurements

Description

A number of measurements can be initiated (with the INITiate command) while other measurements are being made, and the test set will perform as many operations simultaneously as its architecture allows. This technique is referred to as concurrency. Performing measurements concurrently can greatly improve test throughput.

Operating Considerations

The test set has three parallel signal paths to improve measurement throughput.

  • Demodulation downconverter path.
  • Measurement downconverter path.
  • Power detector path.

Since measurements are DSP (digital signal processor) based, and there are four A/D converters available to digitize or "sample" the input signal for analysis by the DSP, the test set will always have the capability to perform one transmitter measurement, one receiver measurement, and maintain the radio link concurrently. The test set's ability to perform multiple transmitter, or multiple receiver tests concurrently will depend on the availability of resources within the test set and availability of the signal to be tested.

Concurrent Measurements for the GSM, GPRS and EGPRS Applications

This table shows the concurrency considerations for the GSM Mobile Test Application. Refer to the Table Key if you require an explanation of the codes used in the table.

Table Key

Empty cell: These measurements can operate concurrently with no conflicts.

A: Cannot operate concurrently. The measurement which is initiated most recently will cause all other conflicting measurements to be closed.

B: These measurements share a sampler path. If multiple measurements are initiated at the same time, they will execute sequentially. However, if multiple measurements are configured to operate off the same trigger event and only a single occurrence of that event happens, only the first initiated measurement will complete .

C: The traffic channel ARFCN or transmit power level can be changed while the measurement is in progress. However, this causes the measurement to re-start, obviously increasing test time.

D: When this measurement is initiated, all other measurements are closed.

E: The Block Error Rate (BLER) measurement cannot operate concurrently with the GPRS Bit Error Rate (GBER) measurement or the SRB Loopback BER measurement.

This note is applicable to GSM only.

The downlink speech source cannot be used when the FBER or BER measurements are running. These measurements take absolute control of the downlink speech source and use it to generate the pseudo-random data.

Related Topics

Measurement Event Synchronization


Integrity Indicator

Integrity Indicator

Description

The test set can evaluate its own performance and make a determination as to the validity of a measurement result. The test set evaluates the conditions surrounding a measurement and reports to the user its evaluation of these conditions in a parameter called the measurement integrity indicator. A measurement integrity indicator value is returned for every completed measurement. It is recommended that the user take advantage of this feature in every measurement.

The returned value defines whether or not a problem was encountered by the measurement process. It is not, however, guaranteed to be the only or root cause of the measurement problem. This is because some of the conditions surrounding a measurement may interact, and the test set may have insufficient information to determine the root cause of the measurement problem. However, in most cases, the value returned is the most likely cause of the problem.

Not all of the integrity indicator values are available for each measurement or test application, if a value doesn't apply it will not be available.

Integrity Indicator Values

NOTE
GSM, GPRS and EGPRS measurements return integrity indicators (8, 9, 11) when the measurement synchronization is set to midamble.

Integrity Indicator Number

Integrity Indicator Message

0

Normal: Indicates the measurement completed successfully without error and the result is accurate.

1

No Result Available: Indicates that there is no measurement result and returns NAN (not a number).

2

Measurement Timeout: Indicates that a measurement has timed out. The measurement timeout state must be set to ON.

3

Hardware Not Installed: Indicates that a piece of hardware is not installed in the test set, or the hardware has failed in a way which leads the instrument controller to believe it isn't installed.

4

Hardware Error: Indicates that a hardware failure has occurred. These include failures such as a phase lock loop out-of-lock, defective DSP samplers, or power detectors that can not be calibrated.

5

Over Range: Indicates that the input signal is over range. This can occur because your device's power is above the maximum input level for the measurement, or because your device's power is too far above the expected power. Refer to the measurement's `Input Signal Requirements' to determine if your device's power is higher than the maximum input level for the measurement. Otherwise, verify that your device's power is less than 3dB above the expected power level for GSM/GPRS/EGPRS, or less than 9dB above the expected power level for W-CDMA, cdma2000 and 1xEV-DO.

6

Under Range: Indicates that the input signal is under range. This can occur because your device's power is below the minimum input level for the measurement, or because your device's power is too far below the expected power. Refer to the measurement's `Input Signal Requirements' to determine if your device's power is lower than the minimum input level for the measurement. Otherwise, verify that your device's power is less than 10dB below the expected power level for GSM/GPRS/EGPRS, or less than 9dB below the expected power level for W-CDMA, cdma2000 and 1xEV-DO.

Note, in some circumstances, the input signal is under range when your device's power is more than 6dB below the expected power level for GSM/GPRS/EGPRS.

7

Burst Short: Indicates that the burst duration is too short, or part of the burst was not sampled due to improper triggering.

8

Trigger Early or Fall Early: Indicates that the DUT's burst amplitude fell prematurely or, due to an early trigger (early relative to a transmitted burst) the measurement sampling operation terminated before the falling edge of the burst.

9

Trigger Late or Rise Late: Indicates that either the rising edge of the DUT's burst was late or, due to a late trigger (late relative to a transmitted burst) the measurement sampling operation didn't start until after the rising edge of the transmitted burst.

10

Signal Too Noisy: Indicates that the measurement algorithm has found the signal measured to be too noisy to provide accurate results.

11

Sync Not Found: For the GSM/GPRS/EGPRS power versus time measurement, indicates that the midamble was not found therefore the measurement was not synchronized. For the W-CDMA BER and BLER measurements, indicates that the test set has lost synchronization with the UE.

12

Oven Out of Range: Indicates that a temperature controlled oven (other than the internal timebase oven) is outside of its operating range. The power meter's oven is checked and its condition reported with this value. (The internal timebase generates a temporary error message (out of lock) that is sent to the system error queue and the display. This is not an integrity indicator value, it is an error message.)

13

Unidentified Error: Indicates errors which are not covered by the other integrity values. Examples include: parameter errors, algorithm memory errors (too many measurements), measurements unavailable (unable to control), autorange unable to converge, default calibration data used.
14

PCM Full Scale Warning: Indicates that the PCM signal has reached plus or minus full scale. The measurement made will be accurate on the PCM signal but would typically indicate an overdriven or oscillating element in the DUT.
15

Questionable Result for Phase 1 Mobile: Indicates that the user attempted to make an FBER measurement in a phase 1 system. FBER is only possible in a phase 2 GSM system. This indicator is available only when the selected broadcast band is PGSM.

16

Questionable Result:
1. Indicates that the channel mode was NOT set to Full Rate Speech while a Decoded Audio measurement was active. Decoded Audio is only supported for FS Speech.
2. For the cdma2000 lab application, this integrity indicator is used to indicate that the Digital Average Power measurement result is questionable if the reverse channel is in 1/8 rate gated transmission in radio configuration 3 and above or the test set can not determine whether the reverse channel is in gated transmission (for example, while in a voice call).
3. For the GPRS Bit Error and GPRS Block Error measurements, this integrity indicator is returned when the Connection Type is set to an invalid parameter, i.e. SRB Loopback.

17

Can not Correlate: Indicates that the test sets internally generated reference signal does not correlate with the received signal.

Some conditions that could cause this integrity indicator result include the following:

  • an input signal that is corrupted
  • the input signal is extremely distorted
  • the input signal is off by more than 10 ms.
  • the frequency of the input signal deviates more than allowed
  • something is wrong with the long-code mask coming from the mobile ID

18

Frequency Out Of Range: Indicates that a Channel Power Measurement was attempted at a frequency for which there is no calibration data. The test set display will indicate 4 dashes.

19

Uncalibrated Due To Temperature: Indicates that the ambient temperature changes more than 10 degrees C since latest calibration, when attempting a Channel Power Measurement.

20

 Potential Receiver Saturation: Indicates that an input signal immediately prior to the measured input was high enough to potentially saturate the receiver hardware.

21

Parameter Error: Indicates that a measurement setup parameter has been set in a way that gives invalid measurement results.

22

Unsupported Configuration: Indicates that some parameter, other than a measurement setup parameter has been set so that it causes an invalid measurement result. Typically this would be a base station emulator parameter.

23

Call Processing Operation Failed: Indicates that a call processing operation, (base station emulator) needed in the course of making the measurement could not complete.

24

Calibration Error

25

 Burst Not Found
26 | Missing Loopback Packets or AT Buffer Overflow: Indicates that Loopback Packets are missing, or the Access Terminal had an overflow. This integrity indicator was added for the 1xEV-DO Packet Error Rate measurement.

27

No AT Loopback Packets: Indicates that no Loopback Packets from the Access Terminal were detected for a period of several seconds. This integrity indicator was added to provide an early termination criteria for the 1xEV-DO Packet Error Rate measurement.

28

 Questionable MS-to-Cell Data: Indicates that a condition exists on the uplink or reverse channel that has caused the measurement results to be in question. In the case of the WCDMA Loopback BER measurement, an example condition that could cause this integrity indicator would be detection of a CRC error in an uplink transport block.
30 | Trigger Missed: Indicates one or more triggers were missed during the measurement. In the case of the CDMA TX dynamic power measurement, an example condition that may cause this integrity indicator would be GPIB or LAN activities occur during the measurement. This integrity indicator was added to prevent the CDMA TX dynamic power measurement from hanging forever and provide an early termination criteria for the measurement.

31

Dual Measurement Request: Indicates that a request has been received for a measurement type that is already running.

32

Measurement Not Licensed: Indicates that the required feature license for the measurement is not present. See

http://www.agilent.com/find/8960upgrades

for details on hardware and software requirements to run a specific feature.

Programming Example

10  OUTPUT 714;"INITIATE:TXPOWER" !Start TXP measurement
20  OUTPUT 714;"FETCH:TXPOWER?" !Request measurement results.
30  ENTER 714;Integrity,Tx_power !Read measurement results.
40  IF Integrity = 0 THEN !Permits measurement to be printed if integrity
50                        !indicator indicates a successful measurement
60  PRINT "TX Power =";Tx_power!if 0 then measurement was successful
70  ELSE
80  PRINT "Measurement integrity questionable, integrity value = ";Integrity
90                                        !If integrity not zero then print
100                                       !integrity value.
110 END IF
120 END

Related Topics

Classes of Errors


Measurement Timeouts

Measurement Timeouts

Description

The primary use of measurement timeouts is to regain control of the test set's GPIB in cases where the bus could potentially "hang."

The time normally required for a measurement to complete may vary greatly depending on the individual measurement, its settings, it's multiple measurement count value, and so forth. Because of this, you may need to set the timeout longer than the default for measurements where a large number of multiple measurements are requested or where measurement triggers may be infrequent.

Be careful when setting a timeout that is shorter than the default. It is possible to specify a timeout that is so short the measurement does not even have a chance to begin. Measurement timeouts should always be at least several seconds long.

Timeout units default to S (seconds). The seconds suffix is an optional part of the command. If you want MS (milliseconds), US (microseconds) or NS (nanoseconds), you must specify these units in the suffix.

Timeout Default Values

List of Timeouts and Default Values
Measurement Function | Default Timeout Time | Default Timeout State | Integrity Indicator Value
Analog Audio Measurements* | 10 seconds | OFF | 2
Bit Error Rate | 10 seconds | OFF | 2
Block Error Rate | 10 seconds | OFF | 2
Decoded Audio * also know as Uplink Speech Level | 10 seconds | OFF | 2
Dynamic Power | 10 seconds | OFF | 2
Fast Bit Error Rate * | 10 seconds | OFF | 2
I/Q Tuning | 10 seconds | OFF | 2
Output RF Spectrum | 10 seconds | OFF | 2
Phase and Frequency Error | 10 seconds | OFF | 2
Power versus Time | 10 seconds | OFF | 2
Transmit Power | 10 seconds | OFF | 2
AMR In-Band Frame Error Rate* | 10 seconds | OFF | 2

The measurements in the table marked with an * apply to GSM only.

Programming Example

The following program causes a timeout to occur on an attempted transmit power measurement. The integrity indicator should return a 2 (the measurement timeout indicator).

10  !Existing conditions: A call is not connected.
20  OUTPUT 714;"SETUP:TXPOWER:TIMEOUT:TIME 5;STATE ON" !Sets a timeout value
30                                                     !of 5 seconds
40  OUTPUT 714;"INITIATE:TXPOWER" !Initiates a single TX power measurement.
50  OUTPUT 714;"FETCH:TXPOWER?" !Queries the TX Power measurement result.
60  ENTER 714;Integrity,Tx_pwr_result
70  PRINT "Integrity indicator was ";Integrity
80  IF Integrity=2 THEN   !Integrity Indicator 2 indicates TX power timed-out.
90  PRINT "Measurement timed out"
100 ELSE
110 PRINT "Measurement did not time out, TX power measurement result was ";Tx_pwr_result
120 END IF
130 END

In this example, if the transmit power measurement takes longer than 5 seconds to complete, the FETCh command retrieves an integrity value of 2. The test set's GPIB is then available to accept more commands.

Related Topics

Integrity Indicator


Step 1: Set Up the Test Set

Step 1: Set Up the Test Set

The following information provides additional details on Step 1 of the Programming Flowchart. This information is applicable to all test applications.

Description

In this step you initialize the test set and set up the general operating conditions.

Contents

  • Initialize the Test Set
  • Set Up General Operating Conditions

Initialize the Test Set

  • Fully Preset the Test Set

    It is important to get the test set to a known state before each production session.

    Sending the *RST command fully presets the test set, which ends all call processing and measurement processes and restores all values to defaults.

  • Clear the Error Queue

    Before each production session, it is useful to clear the error queue of any old messages. That way, you know that any messages logged are relevant to the current production session.

    Sending the *CLS command clears the error queue.

Set Up General Operating Conditions

  • Turn Debugger On

    While developing your code, it is very useful to enable the GPIB debugger using the
    SYST:COMM:GPIB:DEB ON command. When the debugger is on, the test set alerts you when you send an incorrect command, and it also tells you which symbol or letter in the command is incorrect.

NOTE
You should turn the debugger off once you have finished development and your code is stable.

  • Set Operating Mode

    The test set contains a base station emulator (BSE), whose primary purpose is to provide enough call processing to allow parametric measurements of a mobile station's RF signal.

    An important characteristic of the test set's base station emulator is its operating mode. The operating mode sets the way in which the base station emulator interacts with the mobile station.

    Active cell mode is used when emulating a normal cell. Active cell mode allows active signaling between the mobile station and BSE. The mobile station camps to the BSE signal, and an actual call is established.

    The BSE provides necessary forward channel stimulus and makes reverse channel measurements. It does not provide over-the-air signaling for call processing. In test mode, the mobile station synchronizes to the BSE signal and transmits an appropriate signal which the test set analyzes.

    The test set's operating mode is set using the following command:

    Command to Set the Test Set's Operating Mode

    Command

             Example

    CALL:OPER:MODE <operating mode>

    CALL:OPER:MODE CALL

  • Set Amplitude Offsets

    To achieve accurate measurement results, it is important to account for losses in the cabling and fixturing between the mobile station and test set. You must determine what the losses are for your test setup and then specify the appropriate frequency-dependent amplitude offset values.

    You can specify amplitude offsets for up to 20 frequencies using the following commands:

    Commands to Set Amplitude Offsets

    Command

             Example

    SYST:CORR:FREQ <freq1>, <freq2>, <freq3>

    SYST:CORR:FREQ 800MHz, 1800MHz,
    1900MHz

    SYST:CORR[:SGAin] <offset1>,
    <offset2>, <offset3>

             SYST:CORR -0.7, -1.0, -1.2

  • Set Display Mode

    To achieve a slightly faster test execution speed, you can disable the front panel display on the test set using the DISP:MODE FAST command.


Step 2: Configure Test Set and Mobile Station Parameters

Step 2: Configure Test Set and Mobile Station Parameters

The following information provides additional details on Step 2 of the Programming Flowchart. This information is applicable to all test applications.

Description

In this step you configure the parameters that allow a connection to be made between the test set and mobile station. This mainly involves setting up channels and power levels.

Contents

  • Set Up Channels
  • Set Cell Power
  • Set Mobile Station Transmit Power
  • Set Up Additional Connection Parameters

Set Up Channels

Setting up channels involves specifying the channel associated with every band and channel type (for example, analog or digital), and then setting the active band and channel type.

  • Specify Channel Numbers

    All of the test set's test applications can test in more than one frequency band (for example, US Cellular, US PCS, or Korean PCS). To produce the most efficient code, you should configure the channel information for each band in advance. Then, to move to a new band during testing, you only need to send the command to change bands. You do not need to also specify the channel of the new band. This reduces test time.

    To set up the channel number for the various bands, use one of the following commands (depending upon which test application you are using):

    Commands to Set the Channel for a Band

    Command

             Example

    CALL:<channel mnemonic>:<band mnemonic>
    <num value>

    CALL:TCH:EGSM 124

    CALL:SET:<channel type mnemonic>:<band
    mnemonic> <num value>

    CALL:SET:DTC:PCS 777

    CALL:CHAN:<channel type mnemonic>:<band
    mnemonic> <num value>

    CALL:CHAN:DIG2000:K
    PCS 384

    This practice also applies to test applications which test both analog and digital channel types. In this case you should specify the channel for the analog and digital channel types in advance. Then, switching between them requires only one command to initiate the change, and not an additional change to specify the channel of the new channel type.

    If you specify channels in advance as described, the only time you need to specify a channel during testing is if you move to a new channel within the same band and channel type.

  • Set Active Band and Mode

    Once you have specified the channel information for each band and channel type, you must set the active band using one of the following commands (depending upon which test application you are using):

    Commands to Set the Active Band

    Command

             Example

    CALL:<channel mnemonic>:BAND <band mnemonic>

    CALL:TCH:BAND
    EGSM

    CALL:SET:<channel type mnemonic>:BAND <band
    mnemonic>

             CALL:SET:DTC:BAND
    PCS
    CALL:BAND:<channel mnemonic> <band mnemonic>

    CALL:BAND:DIG2000
    KPCS

    If the test application you are using supports testing of both analog and digital channel types, then you must also set the channel type using the following command:

    Command to Set the Active Channel Type

    Command

             Example

    CALL:<channel mnemonic>:TYPE <channel type
    mnemonic>

    CALL:TCH:TYPE
    DTC

  • Active Cell and Test Mode Considerations

    The function of the CALL commands differ depending upon whether you are in active cell or test mode.

    In active cell mode, when you use the CALL commands to set the channel numbers, the test set's output frequency and receiver frequency are set. A message is also sent to the mobile station to set its frequency.

    However, in test mode, since the BSE does not send call processing information to the mobile station, the CALL commands only configure the test set's output frequency and receiver frequency. You need to also send the appropriate test mode commands to the mobile station to set it to the correct frequency.

    In test mode, instead of using the CALL commands to configure the test set's frequencies, you may prefer to manually control the RF generator and RF analyzer using the CALL:RFG and RFAN commands, respectively. In either case, you must still send the appropriate test mode commands to the mobile station to move it to the proper frequency.

Set Cell Power

To set the output power of the test set, use the following command:

Command to Set Cell Power
Command | Example
CALL:POW <num value> | CALL:POW -75

  • Active Cell and Test Mode Considerations

    You can use the CALL:POW command to set the cell power in both active cell and test mode. However, in test mode you may prefer to manually control the output power of the test set using the CALL:RFG commands.

Set Mobile Station Transmit Power

In active cell mode, use one of the following commands to set the mobile station transmit power level (depending upon which test application you are using):

Commands to Set Mobile Station Transmit Power
Command | Example
CALL:MS:TXL:<band mnemonic> <num value> | CALL:MS:TXL:DCS <num value>
CALL:SET:MS:<channel type mnemonic>:TXL:<band mnemonic> <num value> | CALL:SET:MS:DIG:TXL:PCS <num value>
CALL:<channel mnemonic>:MS:TXL:<band mnemonic>:BURS <num value> | CALL:PDTCH:MS:TXL:DCS: BURS <num value>

In addition to setting the mobile station transmit level, these commands also automatically configure the test set's receiver at the expected input level, whether in active cell or test mode. However, in test mode, you must also send the appropriate test mode commands to the mobile station to command it to output at the correct level. This is due to the fact that the BSE is not transmitting call processing commands to the mobile station.

  • Manually Setting Expected Power

    Sending the CALL commands in Commands to Set Mobile Station Transmit Power automatically sets the expected input level of the test set's receiver. However, there is another option for setting the receiver's input level in both active cell and test mode. It is often beneficial to manually set the expected input power level using the RFAN commands, rather than using the CALL commands.

    When you set the expected power manually, you tell the test set exactly what power level to expect. Whereas the CALL commands simply tell the test set the range of input level to expect, based on the definition of the mobile station power level (for example, an AMPS/136 mobile station transmitting at power level 3 has an output level in the range of +20 dBm to +26 dBm).

Set Up Additional Connection Parameters

Depending upon the test application you are using, there may be other connection parameters to specify, such as timeslot, timing advance, vocoder, or data rates and types.

In active cell mode, you may also choose to set up network parameters, such as base station identifier numbers (for example, SID) and color codes.

All of these parameters are configured using the CALL subsystem.


Step 3: Set Measurement Parameters

Step 3: Set Measurement Parameters

The following information provides additional details on Step 3 of the Programming Flowchart. This information is applicable to all test applications.

Description

In this step you set up the conditions under which the measurements operate. You do this by configuring measurement parameters.

Contents

  • Measurement Parameters Overview
  • Generic Measurement Parameters
  • Measurement-Specific Measurement Parameters

Measurement Parameters Overview

There are two different types of measurement parameters:

  • Generic Measurement Parameters
  • Measurement-Specific Measurement Parameters

The SETup subsystem is used to configure measurement parameters. Each individual measurement parameter can be set and queried using the associated SETup subsystem command. The general hierarchy of the SETup subsystem command structure is as follows:

SETup:<measurement mnemonic>:<measurement parameter> <parameter setting/value>

Not all measurements use all measurement parameters. Refer to the GPIB syntax listing for the detailed list of measurement parameters for individual measurements.

Generic Measurement Parameters

There are three types of generic measurement parameters:

  • Measurement Count (used by most measurements)
    Measurement Count State
    Measurement Count Number

  • Measurement Timeout (used by all measurements)
    Measurement Timeout State
    Measurement Timeout Time

  • Measurement Trigger (used by most measurements)
    Trigger Arm (used by all measurements)
    Trigger Source (not applicable to analog measurements)
    Trigger Delay (not applicable to analog measurements)

Measurement Count Parameters

The measurement count parameters control measurement averaging. The STATe command turns averaging on or off, and the NUMBer command determines the number of averages. The SNUMber command is a complex command which allows you to turn averaging on and set the number of averages in one command.

Statistical Measurement Results Parameters
Parameter | Command Syntax
Measurement Count State | SETup:<meas-mnemonic>:COUNt:STATe <ON|1|OFF|0>
Measurement Count Number | SETup:<meas-mnemonic>:COUNt:NUMBer <numeric value>
Measurement Count Number and State | SETup:<meas-mnemonic>:COUNt[:SNUMber] <numeric value>
Programming Example:

OUTPUT Test_set;"SET:DTXP:COUN 10"

sets the multi-measurement count state to ON and set the number of averages to 10 for the digital transmit power measurement.

Measurement Timeout Parameters

Measurement timeout parameters control the maximum time that a measurement executes. TIMe sets the amount of time and STATe determines if the timeout is in use. The STIMe command is a complex command which enables you to set both parameters in one command.

Measurement Timeout Parameters
Parameters | Command Syntax
Measurement Timeout Time and State | SETup:<meas-mnemonic>:TIMeout[:STIMe] <numeric value>[<suffix>]
Measurement Timeout State | SETup:<meas-mnemonic>:TIMeout:STATe <ON|1|OFF|0>
Measurement Timeout Time | SETup:<meas-mnemonic>:TIMeout:TIME <numeric value>[<suffix>]
Programming Example:

OUTPUT Test_set;"SET:DTXP:TIM 10"

sets the measurement timeout state to ON and set the measurement timeout time to 10 seconds for the digital transmit power measurement.

Measurement Trigger Parameters

There are three measurement trigger parameters. They control the arming of a measurement, the source of the trigger, and the trigger's delay.

  • The trigger arm parameter determines whether the test set makes one measurement and then stops (single), or automatically re-arms upon completion of one measurement and repeats the process (continuous). The recommended setting when writing a control program is single (CONTinuous OFF).

  • The trigger source parameter selects the source of the measurement trigger signal. The recommended Trigger Source setting when writing a control program is AUTO.

Trigger source is always IMMediate for analog measurements and cannot be changed by the user.

  • The trigger delay parameter controls the delay between the trigger event (the point in time at which the trigger signal is received) and the start of sampling. Negative values indicate that the sampling should occur prior to the trigger event.

Trigger delay is not applicable to analog measurements.

Measurement Trigger Parameters
Parameter | Command Syntax
Trigger Arm | SETup:<meas-mnemonic>:CONTinuous <ON|1|OFF|0>
Trigger Source | SETup:<meas-mnemonic>:TRIGger:SOURce <AUTO|IMMediate|PROTocol|RISE>
Trigger Delay | SETup:<meas-mnemonic>:TRIGger:DELay <numeric value>[<suffix>]

You can set the Trigger Arm for all measurements to single (CONTinuous OFF) using the following command syntax:

SETup[:ALL]:CONTinuous:OFF

Programming Example:

OUTPUT Test_set;"SET:CONT:OFF"

sets the trigger arm to single for all measurements.

Programming Example:

OUTPUT Test_set;"SET:DTXP:TRIG:SOUR AUTO"

sets the trigger source to AUTO for the digital transmit power measurement.

Programming Example:

OUTPUT Test_set;"SET:DTXP:TRIG:DEL 10 US"

sets the trigger delay to 10 microseconds for the digital transmit power measurement.

Measurement-Specific Measurement Parameters

Measurement-specific measurement parameters set up operating conditions for a specific measurement. For example:

  • Setting the channel power measurement speed in IS-2000
  • Setting ORFS frequency offsets in GPRS
  • Setting number of bits for the FBER measurement in GSM

Refer to the GPIB syntax listing for the detailed list of measurement parameters for individual measurements.

Programming Example:

OUTPUT Test_set;"SET:CPOW:MSP FAST"

sets the IS-2000 channel power measurement speed to fast.

Programming Example:

OUTPUT Test_set;"SET:ORFS:SWIT:FREQ 400 KHZ"

sets the first ORFS offset to 400 kHz.

Programming Example:

OUTPUT Test_set;"SET:FBER:COUN 10000"

sets the number of fast BER bits to test to 10,000 bits.

Program Example Setting Both Generic and Measurement-Specific Measurement Parameters

! Set trigger arm to single for all measurements:
!
OUTPUT Test_set;"SET:CONT:OFF"
!
! *****************************************************
! Configure Modulation Accuracy Measurement:
!
OUTPUT Test_set;"SET:MACC:COUN 5"
! Example of using a complex command to set both the
! measurement count state and number at the same time.
!
OUTPUT Test_set;"SET:MACC:TRIG:SOUR AUTO"
! Sets trigger source to auto.
!
OUTPUT Test_set;"SET:MACC:TIM 15"
! Sets timeout state to ON and time to 15 sec.
!
OUTPUT Test_set;"SET:MACC:EVM10:STAT ON"
! Turns the EVM10 State ON
!
! ******************************************************
! Configure Digital TX Power Measurement:
!
OUTPUT Test_set;"SET:DTXP:COUN 5"
OUTPUT Test_set;"SET:DTXP:TRIG:SOUR AUTO"
OUTPUT Test_set;"SET:DTXP:TIM 5"
!
! ******************************************************
! Configure Frequency Stability Measurement:
!
OUTPUT Test_set;"SET:FST:COUN 3"
OUTPUT Test_set;"SET:FST:TIM 10"
!
! ******************************************************
! Configure Analog TX Power Measurement:
!
OUTPUT Test_set;"SET:ATXP:COUN 5"
OUTPUT Test_set;"SET:ATXP:TRIG:SOUR AUTO"
OUTPUT Test_set;"SET:ATXP:TIM 15"


Step 4: Make Connection

Step 4: Make Connection

The following information provides additional details on Step 4 of the Programming Flowchart. This information is applicable to all test applications.

Description

In this step you make a connection between the mobile station and test set. How you do this depends upon whether you are in active cell or test mode. In active cell mode you establish a phone call between the test set and mobile station. In test mode, you command the mobile station to synchronize to the test set's signal and begin transmitting back an appropriate signal.

Contents

  • Establish a Call in Active Cell Mode
  • Make a Test Mode Connection

Establish a Call in Active Cell Mode

To test a mobile station in active cell mode, you must first establish a call between the test set and mobile station. Your control program must issue the commands necessary to initiate the call connection process, either to the test set (for a base station originated call) or to the mobile station (for a mobile station originated call). Your control program must then determine when the call has successfully connected so that it can proceed to testing. The control program must also determine if the call has not been successfully connected so that it can take appropriate action.

Call States

At any instant in time a call can be in a stable state such as the idle or the connected state, or in one of many transitory states such as alerting, handoff, registering, releasing or paging. These are referred to as transitory states because the amount of time which the call can spend in any of these states is limited by the mobile station's protocol. The call is not allowed to stay in a transitory state indefinitely.

If repeat paging or repeat registration are on, it is possible for the call process to stay in one of the transitory states beyond the time specified by the mobile station's protocol timers.

Call Connection Synchronization Commands

The test set has a set of commands designed specifically for call connection and release synchronization.

Call Connection Synchronization Commands
Synchronization Command | Command Syntax
Call-Connected-State Query | CALL:CONNected[:STATe]?
Call-State-Change Detector Arm | CALL:CONNected:ARM[:IMMediate]
Call-State-Change Detector Timeout | CALL:CONNected:TIMeout

  • Call-Connected-State Query

    The CALL:CONN? query allows the control program to determine if a call is in the connected state or in the idle state.

    Responses Returned by the CALL:CONN? Query
    Response | Meaning
    1 | The call is in the connected state.
    0 | The call is in the idle state.

    If the call is in one of the transitory states, the query waits until the call reaches the idle state or connected state before returning a value.

  • Call-State-Change Detector Arm Command

    The test set has a call-state-change detector which can be used to temporarily hold the response to a CALL:CONN? query until the call state has moved from idle to connected or vice versa.

    Without the call-state-change detector, the CALL:CONN? query only hangs if the call is in a transitory state. Otherwise, it immediately returns a 1 or 0. Therefore, if a call connection process is started and the CALL:CONN? query is sent before the call state has transitioned from idle to one of the transitory states, the query immediately returns a 0. This indicates that the call is in the idle state (and therefore that the connection attempt failed). In reality, the call likely connected, but not until after the CALL:CONN? query immediately returned a 0.

    When the call-state-change detector is armed during a connection attempt, if the CALL:CONN? query is sent while the call state is still idle, the query waits until the state changes to connected, and then returns a 1.

    The CALL:CONNected:ARM[:IMMediate] command is used to arm this call-state-change detector.

  • Call-State-Change Detector Timeout Command

    If the call-state-change detector is armed and a call connection is attempted but the call state never changes from the idle state, the CALL:CONN? query hangs the bus. This easily happens if the mobile is badly broken, the mobile is not connected to the test set, or no one pushes the send button on the mobile.

    The CALL:CONNected:TIMeout command is used to set the timeout value for the call-state-change detector.

    The timeout timer is started whenever the call-state-change detector is armed, and should be set to the maximum amount of time the control program should wait between arming the detector and the beginning of the connection process (when the call state moves from the idle state). If the timer expires before the call state has moved from the idle or connected state, the call-state-change detector is disarmed, which releases the CALL:CONN? query if it is currently hanging.

Process for Making a Base Station Originated Call

Process for Making a Base Station Originated Call

It is not necessary for you to send the CALL:CONN:TIM and CALL:CONN:ARM commands as they are automatically sent by the test set during a base station originated call or base station release.

Programming Example

OUTPUT Test_set;"CALL:PAG:PNUM `0000574016'"! Set paging number
OUTPUT Test_set;"CALL:PAG:REP ON" ! Set paging repeat state
OUTPUT Test_set;"CALL:ORIG" ! Start a base station originated call
OUTPUT Test_set;"CALL:CONN?"  ! Hanging GPIB query
ENTER Test_set;Call_connected      ! Program hangs here until
                                   ! origination passes or fails
IF NOT Call_connected THEN
   OUTPUT Test_set;"CALL:END"
! <put error handler here>
END IF
! Call is connected so proceed with control program

Process for Making a Mobile Station Originated Call

Process for Making a Mobile Station Originated Call

The test set cannot originate a call from the mobile station. You must physically dial a number on the mobile station and press send, or send commands to a test bus built into the mobile station. For mobile station originated calls where the call is originated by physically dialing a number (as opposed to using a test bus) ensure that the call-state-change detector timeout time is long enough to allow the number to be dialed.

Programming Example

OUTPUT Test_set;"CALL:CONN:TIM 10"         ! Set timeout time to 10 seconds
OUTPUT Test_set;"CALL:CONN:ARM"            ! Arm the change detector
DISP "Initiate a call from the mobile"
OUTPUT Test_set;"CALL:CONN?"          ! Initiate a call connected state query
ENTER Test_set;Call_connected              ! Program hangs here until
                                           ! origination passes or fails
IF NOT Call_connected THEN
   OUTPUT Test_set;"CALL:END"
! <put error handler here>
END IF
! Call is connected.  Proceed with the control program.

Make a Test Mode Connection

To make a connection between the test set and mobile station in test mode, you must send the appropriate test mode commands to the mobile station to command it to synchronize to the test set's signal and begin transmitting.

You may also want to make a quick power measurement to ensure that the connection has been made.


Step 5: INITiate and FETCh Measurements

Step 5: INITiate and FETCh Measurements

The following information provides additional details on Step 5 of the Programming Flowchart. This information is applicable to all test applications.

Description

This step involves making measurements on the mobile station.

The test set has multiple signal paths and processors, which means you can make measurements concurrently and reduce test time. Making concurrent measurements involves starting a group of measurements, fetching the results of the measurements as they complete, and then verifying that the results are valid.

In this step you may also choose to make measurements in a more sequential way.

Contents

  • Concurrent Measurement Process
  • Alternative Measurement Process

Concurrent Measurement Process

Process for Making Concurrent Measurements

Start a Set of Concurrent Measurements

The INITiate command is used to start measurements. Each individual measurement can be started using the INITiate command. For starting measurements, the syntax of the INITiate command is as follows:

INITiate:<measurement mnemonic>[:ON]

More than one measurement can be started using a single INITiate command. For example:

OUTPUT Test_set;"INIT:TXP;PFER"

starts the transmit power measurement and the phase and frequency error measurement. These measurements then run concurrently.

Determine if a Measurement Is Done

Use the INITiate:DONE? query command to determine which measurement has completed.

This command is a query only and returns only one response per query. The responses returned and their meanings are shown in the following table:

Responses Returned from INITiate:DONE? Query
Response String | Meaning
<MEASUREMENT1 mnemonic> | MEASUREMENT1 is done.
<MEASUREMENT2 mnemonic> | MEASUREMENT2 is done.
WAIT | There are one or more measurements that are in progress, but none of those measurements are done yet.
NONE | No measurements are in progress.
Responses Returned from INITiate:DONE? Query
Response String | Meaning
<MEASUREMENT1 mnemonic> | MEASUREMENT1 is done.
<MEASUREMENT2 mnemonic> | MEASUREMENT2 is done.
WAIT | There are one or more measurements that are in progress, but none of those measurements are done yet.
NONE | No measurements are in progress.

Once a measurement is reported as being complete via the INITiate:DONE? query it is removed from the done list (it is not reported again). To use the INITiate:DONE? query properly, your control program should immediately fetch a measurement's results once it is reported as being complete.

Obtain a Set of Measurement Results

In order to minimize bus traffic and reduce test time, the test set's measurements are designed to return multiple measured values in response to a single measurement request.

For example, if a transmit power measurement with averaging is initiated there are five measurement results available. These are:

  1. Measurement integrity value
  2. Average value
  3. Minimum value
  4. Maximum value
  5. Standard deviation value

The test set can return the measurement results in a variety of formats to suit your needs using the FETCh? subsystem. The general structure of the FETCh? command is as follows:

FETCh:<measurement mnemonic>:<result format>?

For example, the transmitter power measurement results can be returned as:

Example FETCh? Result Formats
Command | Results Returned
FETC:TXP? | Measurement integrity and average value
FETC:TXP:POW:ALL? | Minimum, maximum, average and standard deviation values
FETC:TXP:POW:AVER? | Average value only
FETC:TXP:POW:MIN? | Minimum value only
FETC:TXP:POW:MAX? | Maximum value only
FETC:TXP:POW:SDEV? | Standard deviation value only
FETC:TXP:INT? | Measurement integrity value only
Concurrent Measurement Process Programming Example

! Start a Set of Concurrent Measurements:
!
OUTPUT Test_set;"INIT:TXP;PFER"
!
! Determine if a Measurement Is Done:
!
LOOP
  OUTPUT Test_set;"INIT:DONE?"
  ENTER Test_set;Meas_done$
!
! Obtain a Set of Measurement Results:
!
  SELECT Meas_done$
    CASE "TXP"
      OUTPUT Test_set;"FETC:TXP:POW?"
      ENTER Test_set;Avg_tx_power
    CASE "PFER"
      OUTPUT Test_set;"FETC:PFER:RMS?"
      ENTER Test_set;Max_rms_phas_er
  END SELECT
EXIT IF Meas_done$="NONE"
END LOOP

Validate Measurement Results

Validating measurement results is extremely important. The test set returns a result if it is capable of making a measurement, even if this result is obtained under adverse conditions.

The measurement integrity indicator is a measurement result and therefore is queried using the FETCh subsystem. A value of 0 indicates that the measurement is valid. A value other than 0 indicates that an error occurred during the measurement process.

Example Integrity Indicators
Value Returned | Description (message also appears on test set)
0 | Normal
1 | No Result Available
2 | Measurement Timeout
5 | Over Range
6 | Under Range
Programming Example

OUTPUT Test_set;"FETC:DTXP?"
ENTER Test_set;Integrity,Avg_dig_pow
IF Integrity=0 THEN
   PRINT "AVG DIG POW= ";Avg_dig_pow
ELSE
   PRINT "DTXP Measurement Error"
   PRINT "DTXP Measurement Integrity is ";Integrity
END IF

Alternative Measurement Process

You may choose to test in a sequential way rather than use the concurrent measurement process.

For instance, instead of using the INIT:DONE? query to determine when a measurement is complete, you may choose to initiate a set of measurements and then simply fetch them sequentially.

Programming Example

OUTPUT Test_set; "INIT:DTXP;MACC"
OUTPUT Test_set; "FETC:DTXP:POW?"
ENTER Test_set;Avg_dig_pow
OUTPUT Test_set; "FETC:MACC:EVM[1]?"
ENTER Test_set;Max_EVM1

In this example, the test set starts both measurements at the same time. However, if the MACC measurement finishes first, the results are not fetched until the DTXP measurement finishes. Therefore, this process requires that you understand the order in which measurements will complete in order to optimize your testing speed.


Step 6: Reconfigure Test Set and Mobile Station Connection Parameters

Step 6: Reconfigure Test Set and Mobile Station Connection Parameters

Last updated: December 3, 2008

The following information provides additional details on Step 6 of the Programming Flowchart. This information is applicable to all test applications.

Description

After performing a set of measurements on the mobile station using the configuration established in step 2, you may want to change this configuration and test the mobile station again. This step involves changing testing conditions such as channel, mobile station transmit power level, or cell power.

Contents

  • Change Channels
  • Change Other Connection Parameters

Change Channels

In a manufacturing environment it is common to test a mobile station on more than one channel. Some or all of the tests may be performed on multiple channels, to verify the mobile station's performance in a range of operating frequencies.

Perform a Handoff (Handover) in Active Cell Mode

If you are operating in active cell mode, to change channels you perform a handoff (handover) to the new channel. The control program sends the commands to initiate the handoff (handover), and then determines whether the transition was successfully completed. This is accomplished using the CALL:STATus? query.

The CALL:STATus? query immediately returns the state of the call at the time the query is received.

Example Responses Returned from the CALL:STAT? Query
Response | Meaning
IDLE | The call is in the Idle state
ALER | The call is in the Alerting transitory state.
HAND | The call is in the Handoff transitory state.
PAG | The call is in the Paging transitory state.
CONN | The call is in the Connected state.

After issuing the commands to perform a handoff (handover), you should send the CALL:STAT? query to verify that the call is still connected before resuming testing.

Process for Performing a Handoff (Handover)

Test Mode Considerations

In test mode, you can either change the test set's frequencies by using the handoff (handover) commands, or directly control the RF generator and RF analyzer.

In either case, you must also send the appropriate test mode commands to the mobile station to move it to the new channel.

Change Other Connection Parameters

You may also choose to change the mobile station transmit power level or cell power, or other connection parameters such as timeslot or timing advance.


Step 7: End Connection

Step 7: End Connection

The following information provides additional details on Step 7 of the Programming Flowchart. This information is applicable to all test applications.

Description

In this step you release the call (in active cell mode) or end the mobile station transmission (in test mode).

Contents

  • Release the Call in Active Cell Mode
  • End the Mobile Station Test Mode Transmission
  • Partially Preset the Test Set

Release the Call in Active Cell Mode

In active cell mode, you can release the call with the mobile station in one of two ways:

  • Release from the Base Station

  • Release from the Mobile Station

Releasing an Active Call from the Base Station

Process for Releasing an Active Call from the Base Station
Programming Example

OUTPUT Test_set;"CALL:END"        ! Initiate a base station release.
OUTPUT Test_set;"CALL:CONN?" 	 	! Send call connected state query.
ENTER Test_set;Call_connected     ! Program hangs here until state
                                  ! change or timer expires.
IF Call_connected THEN            ! Check if disconnection successful
! <put error handler here>
END IF
! Call is disconnected so proceed with control program

Releasing an Active Call from the Mobile Station

Process for Terminating an Active Call from the Mobile Station

The test set cannot initiate a call disconnection from the mobile station. You must manually push the end button on the mobile station or send commands to a test bus built into the mobile station. For a mobile station release where the call is terminated by physically pushing a button on the phone (as opposed to using a test bus) ensure that the call-state-change-detector timeout time is long enough to allow the end button to be pushed.

Programming Example

OUTPUT Test_set;"CALL:CONN:TIM 5" !Set timeout time to 5 seconds.
OUTPUT Test_set;"CALL:CONN:ARM"   !Arm the change detector.
DISP "Terminate the call from the mobile station."
OUTPUT Test_set;"CALL:CONN?" !Initiate call connected state query.
ENTER Test_set;Call_connected     !Program hangs here until state
                                  !change or timer expires.
IF Call_connected THEN            !Check if disconnection successful.
! <put error handler here>
END IF
! Call is disconnected so proceed with control program

End the Mobile Station Test Mode Transmission

In test mode, you must send the necessary test mode commands to end the mobile station transmission.

Partially Preset the Test Set

At this point, it is good practice to partially preset the test set by sending the SYST:PRES3 command. This command stops all measurement and call processing processes, but does not reset all values to default.


Programming: Getting Started Guide for E1968A GSM/GPRS Mobile Test Application Revision A.02 and E6701C GSM/GPRS Lab Application Revision C.02

Programming: Getting Started Guide for E1968A GSM/GPRS Mobile Test Application Revision A.02 and E6701C GSM/GPRS Lab Application Revision C.02

Last updated: December 3, 2008

Introduction

The Getting Started Guide is organized around the basic set of tasks a control program normally performs when testing a mobile station in a manufacturing environment.

Click on any step in the flowchart below to learn more about how to program the Agilent Technologies 8960 to perform these tasks.

Programming Flowchart

  • Step 1: Set up the Test Set
  • Step 2: Configure Test Set and Mobile Station Parameters
  • Step 3: Set the Measurement Parameters
  • Step 4: Make a Connection
  • Step 5: INITiate and FETCh Measurements
  • Step 6: Reconfigure Test Set and Mobile Station Connection Parameters
  • Step 7: End the Connection

You can also use the buttons on each page to navigate between steps, return to the flowchart, or to find more detailed information about each step.

How to use the programming flowchart for testing GSM and GPRS

It is important for you to understand how to utilize the programming flowchart when designing a control program that tests both GSM and GPRS mobile station capability. In steps 1,2, and 3 of the programming flowchart, you set up the test set and configure parameters for GSM and GPRS all at once. In contrast, you implement steps 4-7 for only one connection type at a time. Flowchart for performing GSM and GPRS testing illustrates in greater detail how to perform these steps for each format. Example code for both GSM and GPRS is contained in steps 4-7 of this guide.

Flowchart for performing GSM and GPRS testing

Conventions used in this Getting Started Guide

Throughout this Getting Started Guide the term "test set" refers to an Agilent Technologies 8960 Series 10 wireless communications test set with either the E1968A GSM/GPRS mobile test application or the E6701C GSM/GPRS Lab Application installed.

The variable Test_set used in the steps of the Getting Started Guide refers to the test set's GPIB address.

About the Programming Examples Presented in this Guide

Programming Language:

Programming examples presented in this guide are written in the HP BASIC programming language, also known as RMB or Rocky Mountain BASIC. The use of HP BASIC is not an endorsement of the HP BASIC product.

Line Numbers

All of the programming examples in the guide with line numbers are sections from a control program example available on-line for you to download.

Code that is not part of the download control program example does not have line numbers. This code may represent an alternate method of performing the task or may illustrate a feature not used by the control program example.

Syntax used in Programming Examples:

  • The programming examples use the shortened form of the command syntax to minimize GPIB bus transactions. The shortened form of a command is defined by use of capital letters in the command syntax. For the command syntax:

 RFANalyzer:CONTrol:MEASurement:FREQuency:AUTO?

    the shortened form would be:

 RFAN:CONT:MEAS:FREQ:AUTO?
  • The programming examples do not include optional nodes. Optional nodes in the command syntax are defined by enclosing the node inside the [ ] brackets. For example, the command syntax:

 CALL[:CELL]:POWer[:SAMPlitude] -80dBm

    appears in the programming examples as:

 CALL:POW -80dBm

  • Programming examples make extensive use of compound commands using the ; and the ;: separators. Refer to the on-line information for the definition and use of these command separators.

Complex Commands

Complex commands are used to configure the state and assign values to parameters simultaneously. Complex commands can be used to save programming steps and minimize GPIB bus transactions.

  • The syntax below turns the state of the parameter on.

    OUTPUT Test_set;"SET:DTXP:TIM:STAT ON"

  • The syntax below is used to assign a value to the parameter.

    OUTPUT Test_set;"SET:DTXP:TIM:TIME 10 S"

  • Both of the above actions can be accomplished with one syntax command:

    OUTPUT Test_set;"SET:DTXP:TIM:STIM 10 S"

    The command above sets the parameter state to ON and the value of the parameter to 10 seconds. Note that in this example the optional command mnemonic :STIMe has been included to clarify that this complex command was used to set both the state and the value.

  • This command can be shortened further by removing the optional command mnemonic :STIMe, as shown below.

    OUTPUT Test_set;"SET:DTXP:TIM 10 S"

    This is the format that will be used throughout this guide.


Step 1: Set up the Test Set

Step 1: Set up the Test Set

Last updated: December 4, 2008

This step explains how to:

  • Fully Preset the Test Set
  • Turn on the GPIB Debugger
  • Set the Amplitude Offsets

Fully Preset the Test Set

To set up the test set, you begin by sending the *RST command. The *RST is used to perform a full preset of the test set, returning it to a known state. *RST also sets all measurements to single trigger.

Turn on the GPIB Debugger

Another useful tool that you may want to turn on at this time is the GPIB command debugger. While turned on, error messages appear on the test set's screen when the test set receives an unknown GPIB command. The message contains information about what type of error was caused and indicates where in the syntax the error occurred. Troubleshooting, like locating and fixing typing errors for example, becomes easier using the GPIB command debugger.

NOTE
The SYST:COMM:GPIB:DEB:STAT ON command assists you when debugging code. This command should be taken out of your code once development is completed.

Set the Amplitude Offsets

The SYST:CORR and SYST:CORR:FREQ commands in the diagram are used to set amplitude offsets to account for loss in your fixture and cabling.


Step 2: Configure Test Set and Mobile Station Parameters

Step 2: Configure Test Set and Mobile Station Parameters

Last updated: December 4, 2008

This step explains how to:

  • Configure the Broadcast Channel Parameters
  • Configure GSM Parameters
  • Configure GPRS Parameters

NOTE
Many of the parameters configured below are being configured to their default values. In a manufacturing environment it may be desirable to explicitly configure these parameters to ensure that the required settings have not been changed by someone setting a parameter's value through the test set's front panel. However, greater code efficiency can be achieved by not configuring them.

Many of the parameters configured below are being configured to their default values. In a manufacturing environment it may be desirable to explicitly configure these parameters to ensure that the required settings have not been changed by someone setting a parameter's value through the test set's front panel. However, greater code efficiency can be achieved by not configuring them.

Configure the Broadcast Channel Parameters

The example below illustrates how to set up the broadcast channel parameters.

You must deactivate the cell, as shown in line 520 below, before setting the network parameters in line 540. If you do not deactivate the cell, the test set generates the following error:

GSM/GPRS operation rejected; Attempting to set <MCC|MNC|LAC|NCC|BCC|RAC> while generating a BCH.

480   ! Configure BCH parameters
490   OUTPUT Test_set;"CALL:BAND PGSM"! Set active broadcast band.
500   ! Deactivate cell to set network parameters by setting the
510   ! operating mode to Cell Off.
520   OUTPUT Test_set;"CALL:OPER:MODE OFF"!
530   ! Set BCH parameters
540   OUTPUT Test_set;"CALL:MCC 1;LAC 1;MNC 1;NCC 1;BCC 5"
550   !
560   OUTPUT Test_set;"CALL:OPER:MODE CELL"! Reactivate the cell.
570   OUTPUT Test_set;"CALL:FUNC:CONN:TYPE AUTO"! Set connection type
580   OUTPUT Test_set;"CALL:BCH 32"
590   OUTPUT Test_set;"CALL:POW -70"! Set cell power to -70 dBm and
600                                 ! cell power state to ON with
610                                 ! a complex command.

Configure GSM Parameters

The following example illustrates setting GSM traffic channel parameters. Refer to Configuring the Traffic Channel (TCH) Parameters and Configuring Mobile Station Operating Parameters for other traffic channel and mobile station operating parameters you can configure.

630   ! Configure GSM parameters
640   OUTPUT Test_set;"CALL:TCH 5;:CALL:MS:TXL 0;TADV 0"

Configure GPRS Parameters

In the next example, several packet data traffic channel parameters are specified. Note that the PDTCH ARFCN is set to 45. This is on a different ARFCN than the broadcast channel (20 is the default broadcast channel ARFCN for PGSM), allowing the use of the power reduction levels specified and assigned to the downlink bursts.

670   OUTPUT Test_set;"CALL:PDTCH:BAND PGSM"! Set broadcast band
680   OUTPUT Test_set;"CALL:PDTCH 45"! Set packet data traffic channel
690   !
700   !  The following commands are helpful in enabling the test set to
710   !  establish a data connection with mobiles which cannot establish
720   !  a BLER data connection under default conditions.
730   !
740   !  Set the test set to send an invalid FCS to the mobile
750   OUTPUT Test_set;"CALL:FUNC:DATA:BLER:LLC:FCS CORR"!
760   !  Set the block polling interval used during BLER connection
770   OUTPUT Test_set;"CALL:FUNC:DATA:BLER:POLL:INT 4"
780!  Set the type of frame numbering scheme used during attach.
790   OUTPUT Test_set;"CALL:FUNC:DATA:FRAM:STAR ABS"
800   !
810   ! Set Multi-slot Configuration to two downlinks and one uplink.
820   OUTPUT Test_set;"CALL:PDTCH:MSL:CONF D2U1"
830   OUTPUT Test_set;"CALL:PDTCH:CSCH CS4"! Set Coding Scheme to CS4
840   !
850   ! Assign values to the power reduction levels
860   OUTPUT Test_set;"CALL:PDTCH:PZER:LEV 25" ! Assign a value to P0
870   OUTPUT Test_set;"CALL:PDTCH:PRED:LEV1 5"! Set PRL1 to 5 dB
880   OUTPUT Test_set;"CALL:PDTCH:PRED:LEV2 11" ! Set PRL2 to 11 dB
890   !
900   ! Assign power levels to the downlink bursts
910   ! Assign Burst 1 a PRL of 5 dB
920   OUTPUT Test_set;"CALL:PDTCH:PRED:BURS1 PRL1"
930   ! Assign Burst 2 a PRL of 11 dB
940   OUTPUT Test_set;"CALL:PDTCH:PRED:BURS2 PRL2"
950   !
960   ! Assign a power level to the uplink burst
970   OUTPUT Test_set;"CALL:PDTCH:MS:TXL:BURS 5"

Configuring the message type used for GPRS handovers

If your phone supports the Packet Timeslot Reconfigure message type, you may want to configure the test set to use this message instead of the Packet Power Control/Timing Advance message for GPRS handovers. If the Packet Timeslot Reconfigure message is used, only one message is necessary to reconfigure both the channel and the power level. Otherwise, two messages must be sent, a Packet Assignment message and a Packet Power Control/Timing Advance message, requiring more test time.

990   ! Configure the test set to use the Packet Timeslot Reconfigure
1000  !  message for GPRS handovers instead of the Packet Power Timing
1010  !  Advance message.
1020  OUTPUT Test_set;"CALL:PDTCH:PMES:PPT OFF"
1030  OUTPUT Test_set;"CALL:PDTCH:PMES:PTR ON"


Step 3: Set the Measurement Parameters

Step 3: Set the Measurement Parameters

This step gives an example of how you can configure measurement parameters. For more information about measurement parameters, refer to Step 3: Set Measurement Parameters .

1080  ! Configure ORFS Measurement for both GSM and GPRS:
1090  !
1100  OUTPUT Test_set;"SET:ORFS:TIM 20"! Set timeout time.
1110  ! Put switching and modulation offsets to be tested into string
1120  ! variables.  Swit$ contains switching offsets.  Mod$ contains
1130  ! modulation offsets.
1140  Swit$=".4MHZ,-.4MHZ,.6MHZ,-.6MHZ,1.2MHZ,-1.2MHZ,1.8MHZ,-1.8MHZ"
1150  Mod$=".4MHZ,-.4MHZ,.6MHZ,-.6MHZ,1.2MHZ,-1.2MHZ,1.8MHZ,-1.8MHZ"
1160  OUTPUT Test_set;"SET:ORFS:SWIT:COUN 20"
1170  OUTPUT Test_set;"SET:ORFS:SWIT:FREQ "&Swit$
1180  OUTPUT Test_set;"SET:ORFS:MOD:COUN 10;FREQ "&Mod$
1190  OUTPUT Test_set;"SET:ORFS:MOD:FREQ "&Mod$
1200  !
1210  ! Configure Power vs. Time Measurement for GSM and GPRS:
1220  !
1230  OUTPUT Test_set;"SET:PVT:TIM 10;COUN 5"
1240  Pvt$="-28us,-10us,321.2us,552.8us,570.8us"
1250  OUTPUT Test_set;"SET:PVT:TIME "&Pvt$
1260  !
1270  ! Configure Phase & Frequency Error Measurement for GSM and GPRS:
1280  !
1290  OUTPUT Test_set;"SET:PFER:COUN 10;TIM 5"
1300  OUTPUT Test_set;"SET:PFER:SYNC MID"
1310  !
1320  ! Configure Block Error Rate Measurement for GPRS
1330  OUTPUT Test_set;"SET:BLER:TIM 200;COUN 2000"


Step 4: Make a Connection

Step 4: Make a Connection

This control program example is written to test a mobile station with both GSM and GPRS capability. The GSM capability of the mobile station is tested first, then the voice call is ended in Step 7: End the Connection . The test set is then reconfigured and a GPRS data connection is established. See the following for code examples:

  • GSM Call Connection
  • GPRS Data Connection

GSM Call Connection

There are two possible ways to make a GSM call connection with the mobile station.

  • Originating a Call from the Test Set
  • Originating a Call from the Mobile Station

Originating a Call from the Test Set

The code below illustrates how to make a connection by originating a call from the test set.

Synchronization for a test set origination is very similar to that for a mobile station originated call. However, as a programming convenience the test set automatically arms the state change detector with a fixed timeout value of 60 seconds for test set initiated events. Therefore, there is no need for you to specify a timeout value or arm the change detector when originating a call from the test set.

1430  OUTPUT Test_set;"CALL:PAG:IMSI `001012345678901'"
1440  OUTPUT Test_set;"CALL:PAG:REP OFF"! Set the paging repeat state.
1570  !
1580  Tries=1
1590  LOOP
1600    OUTPUT Test_set;"CALL:ORIG"   ! Originate a call.
1610    OUTPUT Test_set;"CALL:CONN:STAT?"! CALL:CONN hanging query.
1620    ENTER Test_set;Call_connected
1630  ! Program will hang here until origination process completes.  If
1640  ! successful and the call is connected the query will return a 1.
1650  ! If unsuccessful and the call is not connected, the query
1660  ! returns 0.
1670  !
1680  EXIT IF Call_connected
1690    OUTPUT Test_set;"CALL:END"
1700    IF Tries=50 THEN
1710      BEEP
1720      DISP ""
1730      PRINT "Call did not connect after";Tries;"."
1740      PRINT "Program terminated."
1750      STOP
1760    END IF
1770    DISP "Call has not connected after";Tries;"attempts."
1780    Tries=Tries+1
1790  END LOOP

Originating a Call from the Mobile Station

The code below illustrates how to make a connection by originating a call with the mobile station. This code is not included in the control program available on-line for you to download. That example originates the connection from the test set.

Synchronization between the control program and the test set is maintained by querying the test set for the state of the connection between it and the mobile station. When a Mobile Station origination occurs, the CALL:CONN? hanging query is used. It will return a "1" when the call is connected and a "0" otherwise. A state change detector is also armed to ensure the query does not stop hanging before the state transition from "IDLE" to "CONNected" is able to begin. Finally, to prevent the query from hanging indefinitely, which could occur if the mobile station is not turned on, badly broken, or no one pushes the "send" button on the mobile, a timeout is set for this query. In this example, 15 seconds is the value assigned to the timeout. After 15 seconds, the change detector is disarmed and the query returns either a "1" or "0". For more information about call synchronization, refer to the Internet.

OUTPUT Test_set;"CALL:CONN:TIM 15"   ! Set timeout time to 15 seconds
OUTPUT Test_set;"CALL:CONN:ARM"      ! Arm the change detector
OUTPUT Test_set;"CALL:CONN:STAT?"    ! Initiate call connect state query
DISP "Originate call from mobile station."
ENTER Test_set;Call_connected        ! Program will hang here until
                                     ! origination passes or fails
IF NOT Call_connected THEN           ! Check if connection successful
  OUTPUT Test_set;"CALL:END"
  PRINT "Origination failed.  Program terminated."
  STOP
END IF

GPRS Data Connection

The code example below illustrates the steps necessary to establish a GPRS data connection. In this example, the test set is configured to use the BLER connection type for testing. Refer to Connection Types for information about the different connection types that can be used.

Before establishing the data connection, it is necessary to confirm that the mobile station is GPRS attached. A GPRS attache must be initiated by the mobile station. In this control program, the mobile station should return to the attached state after the GSM voice call ends. In this example, the CALL:STAT:DATA? query is used to confirm the state. This query returns the current connection state. If the state is " ATT " the mobile station is attached to the test set and a data connection can be started.

The CALL:FUNC:DATA:STAR command on line 2590 is used to start the data connection. The CALL:FUNC:DATA:STAR command is a overlapped command, meaning the test set accepts other commands before completely processing this command. Because this is an overlapped command, synchronization is maintained by using the CALL:TRAN? hanging query. It allows the test set to initiate the data connection and then returns a "1" if the data connection starts successfully and a "0" if the state of the connection returns to either "IDLE" or "ATTached". Because the test set originated the data connection, it is not necessary to assign a timeout value or arm the change detector for this query. Instead, there is a default timer associated with this query and the change detector is armed automatically

2430  ! The BLER connection type will be used for GPRS testing.
2440  !
2450  OUTPUT Test_set;"CALL:FUNC:CONN:TYPE BLER"
2460  !
2470  ! The MS should still be GPRS attached.
2480  ! The following code will query the test set for the connection
2490  ! status and then stop the program if the MS is not attached
2500  !
2510  OUTPUT Test_set;"CALL:STAT:DATA?"
2520  ENTER Test_set;Data_state$
2530  IF Data_state$<>"ATT" THEN
2540    PRINT "NO LONGER GPRS ATTACHED.  PROGRAM TERINATED."
2550    STOP
2560  END IF
2570  PRINT "ATTACHED SUCCESSFULLY"
2580  !  Start the data connection
2590  OUTPUT Test_set;"CALL:FUNC:DATA:STAR"
2600  !  Verify that the data connection started.  If not, end the
2610  !   program.
2620  OUTPUT Test_set;"CALL:TRAN?"
2630  ENTER Test_set;Tran_state
2640  IF NOT Tran_state THEN
2650    BEEP
2660    DISP ""
2670    PRINT "Data connection failed.  Program terminated."
2680    STOP
2690  END IF


Step 5: INITiate and FETCh Measurements

Step 5: INITiate and FETCh Measurements

This step explains how to:

  • INITiate a set of measurements
  • FETCh measurement results using a subroutine

INITiate a set of measurements

The example below illustrates how to start three measurements running concurrently.

1860  ! Start a set of concurrent measurements:
1870  !
1880  OUTPUT Test_set;"INIT:PVT;PFER;ORFS"

FETCh measurement results using a subroutine

In a typical control program, measurements are repeated on various frequencies and power levels. Therefore, it is desirable to have a subroutine capable of fetching multiple measurement results. The example code below demonstrates how you might create a subroutine for fetching the measurement results. Refer to Step 5: INITiate and FETCh Measurements for more information about the different measurement results that are available and how to fetch them.

3630  SUB Global_fetch
3640    OPTION BASE 1
3650    COM /Address/Test_set
3660    REAL Pvt(5)
3670  !
3680  !  Determine if a measurement is done:
3690  !
3700      LOOP
3710        OUTPUT Test_set;"INIT:DONE?"
3720        ENTER Test_set;Meas_done$
3730  !
3740  ! Obtain measurement results: Each measurement illustrates a
3750  ! different way of reading in results. There is no one right way.
3760  ! The method used is application dependent. Note that the examples
3770  ! do not show all possible ways.
3780  !
3790        SELECT Meas_done$
3800  !
3810        CASE "PVT"
3820          OUTPUT Test_set;"FETC:PVT?"
3830          ENTER Test_set;Integrity,Mask,Txp,Pvt1,Pvt2,Pvt3,Pvt4,Pvt5
3840          IF (Integrity=0) THEN
3850              Print_pvt(Mask,Txp,Pvt1,Pvt2,Pvt3,Pvt4,Pvt5)
3860          ELSE
3870            GOSUB Bad_measurement
3880          END IF
3890  !
3900        CASE "PFER"! Phase & Frequency Error measurement done.
3910          OUTPUT Test_set;"FETC:PFER?"
3920          ENTER Test_set;Integrity,Rms_ph_er,Peak_ph_er,Worst_frq_er
3930          IF (Integrity=0) THEN
3940            PRINT "RMS Phase Error: ";Rms_ph_er;" deg"
3950            PRINT "Peak Phase Error: ";Peak_ph_er;" deg"
3960            PRINT "Worst Freq Error: ";Worst_frq_er;" Hz"
3970          ELSE
3980            GOSUB Bad_measurement
3990          END IF
4000  !
4010        CASE "ORFS"! ORFS measurement done.
4020  !
4030  ! This code illustrates a more `generic' approach to reading
4040  ! measurement results. By using the capabilities designed into
4050  ! high-level measurements, routines that access measurement
4060  ! results do not have to explicitly know what the measurement
4070  ! execution conditions were.  That information can be determined
4080  ! at the time the measurement results are queried.
4090  !
4100          OUTPUT Test_set;"FETC:ORFS:INT?"! Check integrity.
4110          ENTER Test_set;Integrity
4120          IF (Integrity=0) THEN
4130  ! Get the number of offsets tested.
4140            OUTPUT Test_set;"SET:ORFS:SWIT:FREQ:POIN?"
4150            ENTER Test_set;Points
4160            IF Points THEN ! Only query if one or more offsets tested.
4170              ALLOCATE Swit_res(Points),Swit_offs(Points)
4180  ! Get measurement offsets.
4190              OUTPUT Test_set;"SET:ORFS:SWIT:FREQ?"
4200              ENTER Test_set;Swit_offs(*)
4210  ! Get results
4220              OUTPUT Test_set;"FETC:ORFS:POW?"
4230              ENTER Test_set;Tx_power
4240              OUTPUT Test_set;"FETC:ORFS:SWIT:MAX?"
4250              ENTER Test_set;Swit_res(*)
4260              PRINT USING "19X,""TX Power ="",M2D.2D,"" dBm""";Tx_power
4270              PRINT "     Offset(kHz)          Level(dBm)"
4280              PRINT "     -----------          ----------"
4290 Orfs_image:  IMAGE 6X,M4D.2D,12X,M4D.2D
4300              FOR J=1 TO Points
4310                PRINT USING Orfs_image;(Swit_offs(J)/1.E+3),Swit_res(J)
4320              NEXT J
4330              DEALLOCATE Swit_res(*),Swit_offs(*)
4340            END IF
4350  ! Get the number of offsets tested.
4360              OUTPUT Test_set;"SET:ORFS:MOD:FREQ:POIN?"
4370              ENTER Test_set;Points
4380              IF Points THEN ! Only query if one or more offsets tested.
4390                ALLOCATE Mod_res(Points),Mod_offs(Points)
4400  ! Get measurement offsets
4410                OUTPUT Test_set;"SET:ORFS:MOD:FREQ?"
4420                ENTER Test_set;Mod_offs(*)
4430  ! Get results
4440                OUTPUT Test_set;"FETC:ORFS:POW?;MOD?"
4450                ENTER Test_set;Tx_power,Pwr_30khz,Mod_res(*)
4460                PRINT "ORFS Mod Results: TCH=";Tch;"and TXL=";Ms_pwr_lvl
4470                PRINT "30 KHz BW Power =";Pwr_30khz;" dBm"
4480                PRINT "     Offset(kHz)          Level(dB)"
4490                PRINT "     -----------          ---------"
4500                FOR J=1 TO Points
4510                  PRINT USING Orfs_image;(Mod_offs(J)/1.E+3),Mod_res(J)
4520                NEXT J
4530                DEALLOCATE Mod_res(*),Mod_offs(*)
4540              END IF
4550          ELSE
4560            GOSUB Bad_measurement
4570          END IF
4580        END SELECT
4590      EXIT IF Meas_done$="NONE"
4600      END LOOP ! If `WAIT' is returned from `INIT:DONE?' query, it
4610               ! just falls through the loop.
4620      SUBEXIT


Step 6: Reconfigure Test Set and Mobile Station Connection Parameters

Step 6: Reconfigure Test Set and Mobile Station Connection Parameters

Last updated: December 3, 2008

You can reconfigure both GSM voice connections and GPRS data connections.

  • Reconfiguring the GSM Voice Connection
  • Reconfiguring the GPRS Data Connection

Reconfiguring the GSM Voice Connection

There are several ways you may want to reconfigure the connection parameters. Some examples are:

  • Reconfigure the Mobile Station Parameters
  • Reconfigure the GSM Connection to a New ARFCN in a Different Band

Reconfigure the Mobile Station Parameters

The example below illustrates how to change the mobile station's transmit level. The test set does not accept any other commands until this command has completed. This is important because the mobile station must have received the command to go to a new power level before transmitter measurements can be made accurately.

OUTPUT 714;"CALL:MS:TXL 12"

Reconfigure the GSM Connection to a New ARFCN in a Different Band

When reconfiguring the connection to a new ARFCN, you may also want to change other parameters at the same time. In this case, using deferred parameter commands would create the most efficient code. The code below shows how to set a new mobile station TX level, ARFCN, and band with deferred parameter commands, and then use the CALL:HAND command to apply the new parameters. The order in which these are set is not important. The code also shows you how to use the CALL:STAT:STAT? synchronization command to make sure the connection was maintained. The CALL:STAT:STAT? query returns the current state of the connection. In this case, "CONN" should be returned, indicating the connection is still in the transferring state and the handover was successful.

2010  OUTPUT Test_set;"CALL:SET:TCH:BAND DCS"
2020  OUTPUT Test_set;"CALL:SET:TCH 600"
2030  OUTPUT Test_set;"CALL:SET:TCH:MS:TXL 5"
2040  OUTPUT Test_set;"CALL:HAND"
2050  !
2060  OUTPUT Test_set;"CALL:STAT:STAT?"! Verify that the call is still
2070  ENTER Test_set;Call_status$      ! in the connected state after
2080                                   ! the handover.
2090  IF Call_status$<>"CONN" THEN
2100    PRINT "Call handover failed."
2110    PRINT "Program terminated."
2120    STOP
2130  END IF

Reconfiguring the GPRS Data Connection

There are several ways you may want to reconfigure the connection parameters. Some examples are:

  • Reconfigure GPRS Uplink Burst Parameters
  • Reconfigure the connection to a new PDTCH ARFCN
  • Reconfigure the connection to a new PDTCH ARFCN in a different band

Reconfigure GPRS Uplink Burst Parameters

The example below illustrates how to change the transmit levels of the uplink bursts. The test set does not accept any other commands until these commands have completed. This is important because the mobile station must have received the command to go to new power levels before transmitter measurements can be made accurately.

OUTPUT 714;"CALL:PDTCH:MS:TXL:BURS 12"
OUTPUT 714;"CALL:PDTCH:MS:TXL:BURS2 10"

Reconfigure the connection to a new PDTCH ARFCN

When reconfiguring the connection to a new packet data traffic channel ARFCN, you may also want to change other parameters at the same time. In this case, using deferred parameter commands would create the most efficient code. The code below shows how to set a new mobile station TX level, PDTCH ARFCN, and coding scheme with deferred parameter commands, and then use the CALL:HAND command to apply the new parameters. The code also shows you how to use the CALL:STAT:DATA? synchronization command to make sure the connection was maintained. The CALL:STAT:DATA? query returns the current state of the connection. In this case, "TRAN" should be returned, indicating the connection is still in the transferring state and the handover was successful. This query can be used because the CALL:HAND command is sequential, meaning its operation completes before the test set accepts a new command.

OUTPUT Test_set;"CALL:SET:PDTCH:MS:TXL:BURS 5"
OUTPUT Test_set;"CALL:SET:PDTCH 120"
OUTPUT Test_set;"CALL:SET:PDTCH:CSCH CS2"
OUTPUT Test_set;"CALL:HAND"
! Use a call synchronization command to ensure the
! reconfiguration succeeded.
OUTPUT Test_set;"CALL:STAT:DATA?"
ENTER Test_set;Conn_status$
IF Conn_status$<>"TRAN" THEN
   PRINT "Data connection failed to reconfigure properly."
   PRINT "Program terminated."
   STOP
END IF

Reconfigure the connection to a new PDTCH ARFCN in a different band

Configuring the connection to a new band is exactly the same as configuing the connection to a new PDTCH. In the following example, we use deferred commands to reconfigure the mobile station transmit levels for both bursts and specify a new band and channel number. Again, the CALL:HAND command is used to indicate these new parameters should be sent to the mobile station.

2870  OUTPUT Test_set;"CALL:SET:PDTCH:MS:TXL:DCS:BURS 15"
2880  OUTPUT Test_set;"CALL:SET:PDTCH:MS:TXL:DCS:BURS2 15"
2890  OUTPUT Test_set;"CALL:SET:PDTCH:BAND DCS"
2900  OUTPUT Test_set;"CALL:SET:PDTCH 665"
2910  OUTPUT Test_set;"CALL:HAND"
2920  ! Use a call syncrhonization command to ensure the
2930  ! reconfiguration succeeded.
2940  OUTPUT Test_set;"CALL:STAT:DATA?"
2950  ENTER Test_set;Conn_status$
2960  IF Conn_status$<>"TRAN" THEN
2970    PRINT "Data connection failed to reconfigure properly."
2980    PRINT "Program terminated."
2990    STOP
3000  END IF


Step 7: End the Connection

Step 7: End the Connection

This control program example is written to test a mobile station with both GSM and GPRS capability. The GSM capability of the mobile station is tested first, then the voice call is ended before a data connection is established. After GPRS testing, the GPRS data connection must be stopped. See the following for code examples:

  • Ending a GSM Call Connection
  • Ending a GPRS Data Connection

Ending a GSM Call Connection

You can end the connection in one of two ways:

  • Ending the Connection from the Test Set
  • Ending the Connection from the Mobile Station

Ending the Connection from the Test Set

When you are ending the connection from the test set use the CALL:END command. The example below illustrates how you use the CALL:CONN:STAT? query for call synchronization. This query returns a "0" if the call ended successfully and a "1" if the call is not ended. It is not necessary for you to arm the change detector or set a change detector timeout when using the test set to terminate a call. The test set automatically arms the change detector and uses a default timeout in this situation.

2280  !  End the GSM call so a GPRS connection can be established.
2290  !
2300  OUTPUT Test_set;"CALL:END"
2310  OUTPUT Test_set;"CALL:CONN:STAT?"
2320  ENTER Test_set;Call_connected
2330  IF Call_connected THEN
2340    BEEP
2350    PRINT "Unable to complete BS termination. Program terminated."
2360    STOP
2370  END IF

Ending the Connection from the Mobile Station

When the connection is being ended from the mobile station, it is important to set a timeout value and arm the change detector. More information about using these commands to achieve call synchronization is available in Step 7: End Connection .

This code is not included in the control program available on-line for you to download. In that example, the connection is ended from the test set.

OUTPUT Test_set;"CALL:CONN:TIM 5" !Set timeout time to 5 seconds.
OUTPUT Test_set;"CALL:CONN:ARM"   !Arm the change detector.
OUTPUT Test_set;"CALL:CONN:STAT?" !Initiate call connect state query.
DISP "Terminate the call from the mobile station."
ENTER Test_set;Call_connected     !Program will hang here until state
                                  !change or timer expires.
IF Call_connected THEN            !Check if disconnect successful.
  OUTPUT Test_set;"CALL:END"
  PRINT "Call failed to end correctly.  Program terminated."
  STOP
END IF

Ending a GPRS Data Connection

Stopping the data connection

The CALL:FUNC:DATA:STOP command ends the data connection. Use the CALL:STAT:DATA? query to ensure the data connection has ended and the connection is in the "ATTached" state.

3160  OUTPUT Test_set;"CALL:FUNC:DATA:STOP"
3170  OUTPUT Test_set;"CALL:STAT:DATA?"
3180  ENTER Test_set;Conn_status$
3190  IF Conn_status$<>"ATT" THEN
3200    PRINT "Unable to terminate data connection correctly."
3210    PRINT "PROGRAM TERMINATED."
3220    STOP
3230  END IF

Initiating a GPRS Detach

The test set does not require you to perform a GPRS detach. No errors are generated if a GPRS detach is not performed. Therefore, you may choose to remove the tested phone after the data connection has ended.

There are two ways to initiate a GPRS Detach.

  • Initiating the GPRS Detach from the Test Set
  • Mobile Station initiated GPRS Detach

Initiating the GPRS Detach from the Test Set

The example below illustrates initiating a GPRS Detach from the Test Set.

3280  ! Initiate a GPRS detach from the test set.
3290  OUTPUT Test_set;"CALL:FUNC:DATA:DET"
3300  !
3310  Start_time=TIMEDATE
3320  LOOP
3330    OUTPUT Test_set;"CALL:DCON:ARM"
3340    OUTPUT Test_set;"CALL:ATT?"
3350    ENTER Test_set;Att_state
3360  EXIT IF NOT Att_state
3370    Current_time=TIMEDATE-Start_time
3380    IF Current_time>=Timer THEN
3390      DISP ""
3400      PRINT "GPRS detach did not occur.  Program terminated"
3410      STOP
3420    END IF
3430    IF Conn_state$="DET" THEN
3440      DISP "GPRS detach is in process."
3450    END IF
3460  END LOOP

Mobile Station initiated GPRS Detach

The example below illustrates initiating a GPRS Detach from the mobile station.

DISP "Initiate a GPRS Detach"
Start_time=TIMEDATE
LOOP
  OUTPUT Test_set;"CALL:STAT:DATA?"
  ENTER Test_set;Conn_state$
 EXIT IF Conn_state$="IDLE"
  Current_time=TIMEDATE-Start_time
  IF Current_time>=Timer THEN
    DISP ""
    PRINT "GPRS detach did not occur.  Program terminated"
    STOP
  END IF
  IF Conn_state$="DET" THEN
    DISP "GPRS detach is in process."
  END IF
END LOOP


Invalid Measurement Results

Invalid Measurement Results

Description

Invalid measurement results are returned by the test set when conditions such as signal level are not within the present measurement range. Three different invalid measurement results are provided in order to help you understand the condition that caused the invalid result.

  • 9.9E+37 = INFinity (Infinity)
  • -9.9E+37 = NINF (Negative Infinity)
  • 9.91E+37 = NAN (Not A Number)

9.9E+37 (INFinity)

9.9E+37 is returned by the test set when the measurement is out of range and results are far above the present measurement range.

-9.9E+37 (NINFinity)

-9.91E+37 is returned by the test set when the measurement is out of range and results are far below the present measurement range.

9.91E+37 (NAN)

9.91E+37 is returned by the test set when the measurement is out of range but it can not be determined if measurement results are far above, or far below the measurement range.

If a measurement exceeds its measurement timeout value before a valid result is determined, 9.91E+37 is returned.

FETCH? and READ? Invalid Results

When a FETCH? or READ? query is performed on a measurement with invalid results, the integrity indicator returns a value of 1, indicating No Result Available.

Manual Users Invalid Results

Manual users will generally see four dashes , "----" on the test set display. When the measurement timeout value has been exceeded, "Measurement Timeout" is displayed as well as the four dashes.


Programming an I/Q Tuning Measurement

Programming an I/Q Tuning Measurement

This section provides an example of how to make an I/Q Tuning measurement via the GPIB.

  1. Ensure that the mobile is in test mode and is transmitting all 1s or all 0s.
  2. Ensure that the expected frequency, expected power level and trigger are appropriately set.
  3. Configure the I/Q Tuning measurement parameters using the SETup subsystem.
  4. Start the I/Q Tuning measurement using the INITiate subsystem.
  5. Use the FETCh? command to obtain I/Q Tuning measurement results.

Programming Example

The following program shows how to make an I/Q Tuning measurement on a normal GSM TCH burst. If you want to test a CW signal all you need to change in this program is the trigger type, which should be set to Immediate, rather than RF Rise.

10    PRINT "Ensure your mobile is transmitting:" !On-screen prompts.
20    PRINT "-all 1s or all 0s."
30    PRINT "-on ARFCN 30."
40    PRINT "-a power level of 10 dBm."
50    PRINT "                         "
60    PRINT "Press any key to continue."
70    LOOP
80      ON KBD GOTO Key_exit
90    END LOOP
100 Key_exit: !
110   OUTPUT 714;"RFANALYZER:MANUAL:CHANNEL:SELECTED 30" !Configures the
120                      !test set to expect a transmission on ARFCN 30.
130   OUTPUT 714;"RFANALYZER:EXPECTED:POWER:SELECTED 10 DBM" !Configures
140                     !the test set to expect a power level of 10 dBm.
150   OUTPUT 714;"SETUP:IQTUNING:CONTINUOUS OFF"  !Configures trigger
160                       !mode to single for an I/Q Tuning measurement.
170   OUTPUT 714;"SETUP:IQTUNING:COUNT:SNUMBER 50"  !Configures the
180   OUTPUT 714;"SETUP:IQTUNING:SPUR:STATE ON"  !Configures spur on.
190   OUTPUT 714;"SETUP:IQTUNING:SPUR:FREQUENCY 10MHZ" !Configures a
200   !power measurement at 10MHz from the carrier.
210   !multi_measurement state to ON with a measurement count value
220   !of 50.
230   OUTPUT 714;"SETUP:IQTUNING:TRIGGER:SOURCE RISE" !Configures the
240                                        !trigger source to RF RISE.
250   OUTPUT 714;"SETUP:IQTUNING:REFERENCE:FREQUENCY AUTO" !Sets the
260   !set to choose which offset frequency is to be used as the ref.
270   OUTPUT 714;"INITIATE:IQTUNING" !Start I/Q Tuning measurement.
280   OUTPUT 714;"FETCH:IQTUNING:ALL?"!Fetches the measurement integrity
290   !value and the relative power levels at the offset frequencies.
300   ENTER 714;Integrity,N270,N203,N135,N67,Carrier,P67,P135,P203,P270,Sr
310   PRINT "I/Q Tuning Measurement Results"
320   PRINT "Integrity = ";Integrity
330   PRINT "Spur Power = ";Sr
340   PRINT "Offset (kHz)       Level (dB)"
350   PRINT "------------       ----------"
360   PRINT "-270.334          ";N270
370   PRINT "-203.125          ";N203
380   PRINT "-135.417          ";N135
390   PRINT "-67.708           ";N67
400   PRINT "0.000             ";Carrier
410   PRINT "+67.708           ";P67
420   PRINT "+135.417          ";P135
430   PRINT "+203.125          ";P203
440   PRINT "+270.334          ";P270
450   END

Returned Values

The measurements returned by this program are:

  • Integrity returns the measurement Integrity Indicator (0 means a successful measurement with no errors).
  • The signal level of the following offsets are measured relative to the signal level at the reference offset (either Fc + 67.7083 kHz for all 0s or Fc -67.7083 kHz for all 1s). Note, if the TX I/Q Tuning measurement multi-measurement command is set to ON the average of all the individual results at each offset are returned.
    • -270.833 kHz
    • -203.125 kHz
    • -135.417 kHz
    • -67.7083 kHz
    • Carrier Frequency
    • +67.7083 kHz
    • +135.417 kHz
    • +203.125 kHz
    • +270.833 kHz

Related Topics

I/Q Tuning Measurement Description


Measurement Progress Report

Measurement Progress Report

Description

The measurement progress report is a query of how far along a multi-measurement cycle has progressed. When the multi-measurement count is greater than one, the measurement progress report will indicate the number of measurements that have completed. The returned value will be the last update and not the actual number, because the value is updated periodically and not for each multi-measurement cycle. Every measurement has the measurement progress report available.

Programming Example

OUTPUT 714;"FETCH:PVTIME:ICOUNT?" !Returns the approximate number of
                                  !multi-measurement cycles completed during a
                                  !multi-measurement count cycle

Related Topics

Statistical Measurement Results


Measurement Event Synchronization

Measurement Event Synchronization

Description

Measurement event synchronization saves time by controlling the communication between the controller, the test set, and the mobile station, so that no device does something before it is supposed to (which can cause errors or do something well after it could have). Because some measurements can run concurrently, it is necessary that the control program know when individual measurement results are available.

Measurement event synchronization is accomplished using the INITiate subsystem's command INITiate:DONE? or the STATus:OPERation:NMRReady status registers.

INITiate:DONE?

The INITiate:DONE? query returns a string that indicates what, if any, measurements are ready to be fetched. This query should be used inside a loop, checking each measurement that was initiated. See INITiate:DONE? for more details about this query.

The INITiate:DONE? query returns at least one of the following indicators for each pass through the loop:

  • "AAUD*" - The analog audio measurement results are available.*
  • "BERR" - The GSM bit error measurement results are available.*
  • "BFI+" - The GSM bad frame indication measurement results are available.*
  • "BLERo" - The block error measurement results are available.o
  • "DAUD" - The decoded audio measurement results are available.*
  • "DPOW" - The dynamic power measurement results are available.
  • "EMACo*" - The EGPRS modulation accuracy measurement results are available.
  • "ETXPo*" - The EGPRS transmit power measurement results are available.*o
  • "FBER*" - The fast bit error measurement results are available.
  • "FFER+" - The frame erasure rate measurement results are available.
  • "GBERo" - The GPRS/EGPRS bit error measurement results are available.o
  • "IQT" - The I/Q Tuning measurement results are available.
  • "MTA*" - The multi-tone audio measurement results are available.
  • "ORFS" - The output RF spectrum measurement results are available.
  • "PFER" - The phase and frequency error measurement results are available.
  • "PVT" - The power versus time measurement results are available.
  • "SMON" - The spectrum monitor measurement results are available.
  • "TXP" - The GSM/GPRS transmit power measurement results are available.
  • "WAIT" - There are one or more measurements which are in the measuring state which are not excluded from the query. See INITiate:DONE:FLAG:<measurement mnemonic> . When WAIT is returned at least one measurement is not ready to be fetched yet.
  • "NONE" - There are no measurements currently in the measuring state. This assumes no measurements have been excluded. See INITiate:DONE:FLAG:<measurement mnemonic> . This indicates that all measurements results are available or none have been initiated.

The indicators marked with a o are not returned for GSM as those measurements are not available in that test application.

The indicators marked with a * are not returned for GPRS as those measurements are not available in that test application.

The indicators marked with a + are only returned for the GSM/GPRS and EGPRS lab applications.

Programming Example

The following example assumes that a call is currently connected and that no measurements other than TX power (TXP) and phase and frequency error (PFER) are currently being triggered. See Establishing an Active GSM Link with the Mobile Station and Triggering Process Description .

10  OUTPUT 714;"SETUP:TXPOWER:CONTINUOUS OFF" !Sets TX power trigger mode
20                                            !to single.
30  OUTPUT 714;"SETUP:PFERROR:CONTINUOUS OFF" !Sets PFER trigger mode
40                                            !to single.
50  OUTPUT 714;"INITiate:TXPower;PFERror" !Begins a TX power and
60                                        !PFER measurement.
70  REPEAT
80  OUTPUT 714;"INITIATE:DONE?" !Queries the test set for measurements
90                              !that are done
100 ENTER 714;Meas_done$ !String value representing DONE measurements,
110                      ! NONE if no measurements are done.
120 SELECT Meas_done$ !This variable will be set to WAIT until measurements
130                   !are DONE.
140 CASE "TXP" !Characters must be upper case.
150 OUTPUT 714;"FETCH:TXPOWER:POWER?" !If this case is selected, Tx power
160                                   !(no integrity indicator) is FETCHed.
170 ENTER 714;Tx_power
180 PRINT "TX_Power is ";Tx_power
190 CASE "PFER" !Characters must be uppercase.
200 OUTPUT 714;"FETCH:PFERROR:RMS?" !If this case is selected, rms phase error
210                                 !measurement is FETCHed.
220 ENTER 714;Phs_error
230 PRINT "Max RMS Phase Error is ";Phs_error
240 END SELECT
250 UNTIL Meas_done$ = "NONE" !When all triggered measurements have completed,
260                           !the INITiate:DONE? query returns NONE.
270 END

STATUS:OPERATION:NMRREADY:GSM

The STATus:OPERation:NMRReady:GSM command allows the program to immediately branch to the next operation or command without continuing through a loop as in INITiate:DONE? See STATus:OPERation:NMRReady:GSM Condition Register Bit Assignment for more details about this command.

You must enable the following so that as soon as the enabled NMRReady bit is true the program moves on.

  • Positive or negative transition filter. See Transition Filters .
  • STATus:OPERation:NMRReady:GSM bit for the measurement desired.
  • STATus:OPERation:NMRReady bit (4 for GSM) for the required system. See STATus Subsystem Description or Status Subsystem Overview .
  • STATus:OPERation bit (512 for NMRReady).
  • Service Request Enabling (*SRE 128 for NMRReady).

The STATus:OPERation:NMRReady:GSM Condition Register Bit Assignment status register provides status reporting on the following measurement completions:

  • GSM Frame Erasure Rate on the FACCH
  • GSM Bad Frame Indication
  • TX Power
  • Power vs. Time
  • Phase/Frequency Error
  • Output RF Spectrum
  • Analog Audio
  • Decoded Audio
  • Fast Bit Error Rate
  • Bit Error Rate
  • I/Q Tuning
  • Dynamic Power

Generating a Service Request (SRQ) Interrupt - Bit Error Rate NMRR

The following example illustrates the use of the STATus subsystem to generate a service request when a BERR measurement completes. This example assumes a call is already connected and the BERR measurement is setup (mobile station must be in loopback type A or B).

10  OUTPUT 714;"STATUS:OPERATION:NMRREADY:GSM:PTR 256" !Enable positive transition
20                                                 !filter on fast BER bit.
30  OUTPUT 714;"STATUS:OPERATION:NMRREADY:GSM:ENABLE 256" !Enable the fast BER Bit to
40                                                    !generate a summary message.
45  OUTPUT 714;"STATUS:OPERATION:NMRREADY:ENABLE 4" !Enable the GSM summary bit.
50  OUTPUT 714;"STATUS:OPERATION:ENABLE 512" !Enable the Operation summary bit to
60                                           !generate a summary message.
70  OUTPUT 714;"*SRE 128" !Enable the service request enable register to generate SRQ.
80  OUTPUT 714;"*CLS" !Clear all status data structures.
90  ON INTR 7,15 CALL Meas_complete !Define interrupt-initiated branch with a priority
100                                 !of 15 (highest)
110 ENABLE INTR 7;2 !Enable interrupt on interface card 7 with a bit mask
120                 !(for interface's interrupt-enable register) of 2.
130 OUTPUT 714;"SETUP:FBER:CONTINUOUS OFF;:INITIATE:FBERROR" !Initiate a single
140                                                          !fast BER test.
150 LOOP
160 DISP "Waiting for BERR test to complete"
170 WAIT .1 !"Dummy" loop
180 END LOOP
190 !Instead of a "dummy" loop, controlling application could be performing setups,
200 !making measurements, etc.
210 END
220 SUB Meas_complete
230 DISP "BER test complete, OK to FETCh results now"
240 Clear_interrupt=SPOLL(714) !Clear the RQS message in the status byte register.
250 STOP
260 SUBEND

Operating Considerations

Only one indicator is returned per query.

All active measurements must be set to single trigger mode. This ensures that when a measurement completes it remains in the "DONE" state rather than restarting. Sending the "*RST" command at the beginning of the test code or using the "SETup:CONTinous:OFF" command during measurement setups are ways to set the trigger to single for all measurements.

Related Topics

INITiate Subsystem

What Happens When a Measurement is INITiated?

Concurrent Measurements

STATus:OPERation:NMRReady:GSM Condition Register Bit Assignment

STATus:OPERation:NMRReady:GPRS Condition Register Bit Assignment


Programming a Downlink Multi-Tone Audio Measurement

Programming a Downlink Multi-Tone Audio Measurement

This measurement is not applicable to GPRS or EGPRS.

This section provides an example of how to use the Multi-tone Audio instrument via the GPIB for performing measurements on a mobile station's speaker.

The following procedure assumes that a mobile station is connected to the test set's RF IN/OUT and that the mobile station's speaker is connected to the AUDIO IN BNC connectors. See Multi-tone Audio Measurement Description .

  1. Set the traffic channel speech type to Multi-tone.
  2. Configure the multi-tone audio measurement for measuring the frequency response and absolute audio level of the mobile station's speaker. The SETup subsystemes used for configuring parameters. Parameters that must be configured include:
    • Measurement Mode - must be set to Downlink
    • SINAD/Distortion State - must be turned off to capture frequency response results.
    • Expected Audio In Peak Voltage - must be set to avoid over or under range errors.
    • Generator's Total Audio Level - should be set as high as possible. This setting is dynamic and varies depending on the generator frequencies selected.

    Other parameters can also be configured as illustrated in the following programming example. See Measurement Parameters for more information.

  3. Start the multi-tone measurement using the INITiate subsystem.
  4. Use the FETCh? subsystem to obtain multi-tone audio measurement results.
  5. Reconfigure the multi-tone audio measurement for performing a SINAD/Distortion measurement.
    • SINAD/Distortion State - turn the state on so SINAD and Distortion measurement results will be available.
    • Generator Preset Frequencies - a preset with audio tone one turned on and all other tones turned off must be used for SINAD/Distortion measurements.
  6. Start the multi-tone measurement again using the INITiate subsystem.
  7. Use the FETCh? subsystem to obtain multi-tone audio SINAD/Distortion measurement results.

Programming Example

1 DIM UL$[100]   ! String to hold data for MTA downlink upper Limits
2 DIM LL$[100]   ! String to hold data for MTA downlink lower Limits
3 !
4 DIM Mta_levels(20)   ! Arry to hold MTA measurement results
5 ! including integrity indicator
6 !
7 !*** Define Pass Fail Limits for all 20 tones ***
8 !
9 UL$ = "-11,-12,-12,-12,-12,-8,-10,-12,-12,-10,-13,-11,-14,-13,-12,-8,-5,-2,0,-1"
10 LL$ = "-15,-16,-16,-16,-16,-12,-14,-16,-16,-14,-17,-15,-18,-17,-16,-12,-9,-6,-4,-5"
11 !
12 OUTPUT Testset;"SETUP:MTA:LEVEL:ALL:LIMIT:UPPER "&Mta_dnlink_ul$
13 OUTPUT Testset;"SETUP:MTA:LEVEL:ALL:LIMIT:LOWER "&Mta_dnlink_ll$
14 !
15 !*** multi-tone audio measurement setup ***
16 !
17 !  Turn Off Uplink Generator
18 OUTPUT Testset;"SETUP:MTAUDIO:GEN:LEVEL:UPLINK:ALL:TOTAL 0"
19 OUTPUT Testset;"CALL:TCH:DOWNLINK:SPEECH MTA"
20 ! DOWNLINK MEASUREMENT MODE
21 OUTPUT Testset;"SETUP:MTAUDIO:MEAS:MODE DOWNLINK"
22 !  SET SINAD DISTORTION STATE TO OFF
23 OUTPUT Testset;"SETUP:MTAUDIO:SDIS:STATE 0"
24 !  PRESET 100 HZ SPACING
25 OUTPUT Testset;"SETUP:MTAUDIO:GEN:FREQ:PRESET MTA100"
26 OUTPUT Testset;"SETUP:MTAUDIO:COUNT 5"   !averaging of 5
27 !  Set absolute reference level
28 OUTPUT Testset;"SETUP:MTAUDIO:REF:ABS:LEVEL:DOWNLINK .3"
29 !  EXPECTED VOLTAGE OF 1 VOLT
30 OUTPUT Testset;"SETUP:MTAUDIO:PEAK:VOLT 1"
31 OUTPUT Testset;"SETUP:MTAUDIO:SETT .1"   !  SETTLING TIME OF .1 SECONDS
32 !  TOTAL GENERATOR LEVEL
33 OUTPUT Testset;"SETUP:MTAUDIO:GEN:LEVEL:DOWNLINK:ALL:TOTAL 25"
34 !
35 !*** Multi-tone audio individual 20 tone level measurements
36 !
37 OUTPUT Testset;"INIT:MTA"
38 !
39 OUTPUT Testset;"FETCH:MTA:LEVEL?"
40 ENTER Testset;Mta_levels(*)
41 !
42 OUTPUT Testset;"FETCH:MTA:INTEGRITY?"
43 ENTER Testset;Integrity
44 !
45 OUTPUT Testset;"FETCH:MTA:VOLTAGE?"
46 ENTER Testset;Dnlink_volts
47 !
48 !
49 OUTPUT Testset;"FETCH:MTA:LEVEL:LIMIT:FAIL?"
50 ENTER Testset;Pass_fail
51 !
52 SELECT Pass_fail
53 !
54   Case 0
55     Pass_fail$ = "Passed"
56   Case 1
57     Pass_fail$ = "Failed"
58   Case Else
59     Pass_fail$ = "Unknown"
60   End Select
61 !
62 !*** DownLink Distortion Test
63 !
64 OUTPUT Testset;"SETUP:MTAUDIO:COUNT 3"   !averaging of 3
65 !  SET SINAD DISTORTION STATE TO ON
66 OUTPUT Testset;"SETUP:MTAUDIO:SDIS:STATE 1"
67 !  PRESET SINE 1000 HZ SINGLE TONE
68 OUTPUT Testset;"SETUP:MTAUDIO:GEN:FREQ:PRESET SIN1000"
69 OUTPUT Testset;"SETUP:MTAUDIO:REF:ABS:LEVEL:DOWNLINK .5"
70 !
71 OUTPUT Testset;"INIT:MTA"
72 !
73 OUTPUT Testset;"FETCH:MTA:DISTORTION?;SINAD?;VOLTAGE?"
74 ENTER Testset;Dnlink_dist,Dnlink_sinad,Dist_volts
75 !
76 !*** Print Results ***
77 !
78 Print
79 Print_title ("MultiTone Audio Downlink Test")
80 Print_results("Channel= ",Current_chan,"")
81 Print
82 !
83 Print_results("Integrity indicator = ",Integrity,"")
84 Print
85 Print_results("Downlink Audio Level =",Dnlink_volts," V")
86 Print
87 !
88 For I = 1 To 20
89   Print_results("Tone "&VAL$(I),Mta_levels(I)," dB")
90 Next I
91 !
92 Print_res_str("Test Result: ",Pass_fail$)
93 Print
94 !
95 Print_results("Downlink Distortion 1000 Hz =",Dnlink_dist," %")
96 Print_results("Downlink SINAD 1000 Hz =",Dnlink_sinad," dB")
97 Print_results("Downlink Level 1000 Hz =",Dist_volts," V")

Related Topics

Multi-tone Audio Measurement Description

Multi-Tone Audio Troubleshooting

INITiate

SETup:MTAudio

FETCh:MTAudio


Programming an Uplink Multi-Tone Audio Measurement

Programming an Uplink Multi-Tone Audio Measurement

This measurement is not applicable to GPRS or EGPRS.

This section provides an example of how to use the Multi-tone Audio instrument via the GPIB to perform measurements on a mobile station's microphone.

The following procedure assumes that a mobile station is connected to the test set's RF IN/OUT and that the mobile station's microphone is connected to the AUDIO OUT BNC connector. See Multi-tone Audio Measurement Description .

  1. Set the traffic channel speech type to None.
  2. Configure the multi-tone audio measurement for measuring the frequency response and absolute audio level of the mobile station's speaker. The SETup subsystemis used for configuring parameters. Parameters that must be configured include:
    • Measurement Mode - must be set to Uplink.
    • SINAD/Distortion State - must be turned off to capture frequency response results.
    • Generator's Total Audio Level - should be set as high as possible. This setting is dynamic and varies depending on the generator frequencies selected.

    Other parameters can also be configured as illustrated in the following programming example. See Measurement Parameters for more information.

  3. Start the multi-tone measurement using the INITiate subsystem.
  4. Use the FETCh? subsystem to obtain multi-tone audio measurement results.
  5. Reconfigure the multi-tone audio measurement for performing a SINAD/Distortion measurement.
    • SINAD/Distortion State - turn the state on so SINAD and Distortion measurement results will be available.
    • Generator Preset Frequencies - a preset with audio tone one turned on and all other tones turned off must be used for SINAD/Distortion measurements.
  6. Start the multi-tone measurement again using the INITiate subsystem.
  7. Use the FETCh? subsystem to obtain multi-tone audio SINAD/Distortion measurement results.

Programming Example

1 ! String to hold data for MTA uplink upper Limits
2 DIM UL$[100]
3 ! String to hold data for MTA uplink lower Limits
4 DIM LL$[100
5 ! Arry to hold MTA measurement results
6 !   including integrity indicator
7 DIM Mta_levels(20)
8 !
9 !*** Define Pass Fail Limits for all 20 tones ***
10 !
11 UL$="-8,-8,-8,-7,-7,-6,-6,-6,-6,-6,-6,-6,-6,-6,-6,-6,-6,-6,-6,-6"
12 LL$="-12,-12,-12,-11,-11,-10,-10,-10,-10,-10,-10,-11,-11,-11,-13,-13,-13,-16,-16,-18"
13 !
14 !
15 OUTPUT 714;"SETUP:MTA:LEVEL:ALL:LIMIT:UPPER "&Mta_uplink_ul$
16 OUTPUT 714;"SETUP:MTA:LEVEL:ALL:LIMIT:LOWER "&Mta_uplink_ll$
17 !
18 !
19 !*** multi-tone audio measurement setup ***
20 !
21 !UPLINK MEASUREMENT MODE
22 OUTPUT 714;"SETUP:MTAUDIO:MEAS:MODE UPLINK'
23 OUTPUT 714;"CALL:TCH:DOWNLINK:SPEECH NONE"
24 !SET SINAD DISTORTION STATE TO OFF
25 OUTPUT 714;"SETUP:MTAUDIO:SDIS:STATE 0'
26 OUTPUT 714;"SETUP:MTAUDIO:COUNT 20"   !averaging of 20
27 OUTPUT 714;"SETUP:MTAUDIO:SETT .1"   !SETTLING TIME OF .1 SECONDS
28 !PRESET 100 HZ SPACING
29 OUTPUT 714;"SETUP:MTAUDIO:GEN:FREQ:PRESET MTA100"
30 !TOTAL GENERATOR LEVEL in V
31 OUTPUT 714;"SETUP:MTAUDIO:GEN:LEVEL:UPLINK:ALL:TOTAL 1.2"
32 !
33 OUTPUT 714;"SETUP:MTAUDIO:REF:ABS:LEVEL:UPLINK 7"
34 !
35 !*** Multi-tone audio individual 20 tone level measurements
36 !
37 OUTPUT 714;"INIT:MTA"
38 !
39 OUTPUT 714;"FETCH:MTA:LEVEL?"
40 ENTER 714;Mta_levels(*)
41 !
42 OUTPUT 714;"FETCH:MTA:INTEGRITY?"
43 ENTER 714;Integrity
44 !
45 OUTPUT 714;"FETCH:MTA:VOLTAGE?"
46 ENTER 714;Uplink_volts
47 !
48 OUTPUT 714;"FETCH:MTA:LEVEL:LIMIT:FAIL?"
49 ENTER 714;Pass_fail
50 !
51 SELECT Pass_fail
52 !
53  Case 0
54    Pass_fail$ = "Passed"
55  Case 1
56    Pass_fail$ = "Failed"
57  Case Else
58    Pass_fail$ = "Unknown"
59 End Select
60 !
61 !*** UpLink Distortion Test
62 !
63 OUTPUT 714;"SETUP:MTAUDIO:COUNT 1"   !averaging of 3
64 !SET SINAD DISTORTION STATE TO ON
65 OUTPUT 714;"SETUP:MTAUDIO:SDIS:STATE 1"
66 !PRESET SINE 1000 HZ SINGLE TONE
67 OUTPUT 714;"SETUP:MTAUDIO:GEN:FREQ:PRESET SIN1000"
68 !TOTAL GENERATOR LEVEL
69 OUTPUT 714;"SETUP:MTAUDIO:GEN:LEVEL:UPLINK:ALL:TOTAL 1"
70 OUTPUT 714;"SETUP:MTAUDIO:REF:ABS:LEVEL:UPLINK 15"
71 !
72 OUTPUT 714;"INIT:MTA"
73 !
74 OUTPUT 714;"FETCH:MTA:DISTORTION?;SINAD?;VOLTAGE?"
75 ENTER 714;Uplink_dist,Uplink_sinad,Dist_volts
76 !
77 !*** Print Results ***
78 !
79 Print
80 Print_title ("MultiTone Audio Uplink Test")
81 Print_results("Channel= ",Current_chan,"")
82 Print
83 !
84 Print_results("Integrity indicator = ",Integrity,"")
85 Print
86 Print_results("Uplink Audio Level =",Uplink_volts," %")
87 Print
88 !
89 For I = 1 To 20
90   Print_results("Tone "&VAL$(I),Mta_levels(I)," dB")
91 Next I
92 !
93 !
94 Print_res_str("Test Result: ",Pass_fail$)
95 Print
96 !
97 Print_results("Uplink Distortion 1000 Hz =",Uplink_dist," %")
98 Print_results("Uplink SINAD 1000 Hz =",Uplink_sinad," dB")
99 Print_results("Uplink Level 1000 Hz =",Dist_volts," %")

Related Topics

Multi-tone Audio Measurement Description

Multi-Tone Audio Troubleshooting

INITiate

SETup:MTAudio

FETCh:MTAudio


GSM/GPRS Control Program Example

GSM/GPRS Control Program Example

HP BASIC

For your convenience we have combined the programming examples shown in the Getting Started Guide into one program. This program, written using HP Basic, is a fully functional GSM/GPRS control program. You can use this as a starting point for developing your own program. Click on the link below to view this program.

  • Getting Started Guide Control Program Example


Test System Synchronization

Test System Synchronization

GSM

  • Test System Synchronization Overview
  • Measurement Event Synchronization
  • Call Processing Event Synchronization
  • Call Processing State Synchronization
  • Mobile Terminated SMS Delivery Status

GPRS and EGPRS

  • Test System Synchronization Overview
  • Measurement Event Synchronization
  • Data Connection Processing Event Synchronization
  • Data Connection Processing State Synchronization
  • Mobile Terminated SMS Delivery Status


Obtaining Measurement Results

Obtaining Measurement Results

  • Concurrent Measurements
  • Measurement Timeouts
  • Measurement Progress Report
  • Triggering of Measurements
  • Burst Synchronization of Measurements
  • Statistical Measurement Results
  • Integrity Indicator
  • Invalid Measurement Results
  • Frame Trigger Parameters
  • Dealing With Semicolon Separated Response Data Lists


Programming an Output RF Spectrum Measurement

Programming an Output RF Spectrum Measurement

This section contains two programming examples:

  • Programming an Output RF Spectrum Measurement for GSM
  • Programming an Output RF Spectrum Measurement for GPRS and EGPRS

Programming an Output RF Spectrum Measurement for GSM

This section provides an example of how to make the output RF spectrum (ORFS) measurement via GPIB.

The following procedure assumes that an active link is established between the test set and the mobile station. See Establishing an Active GSM Link with the Mobile Station .

  1. Configure the ORFS measurement parameters using the SETup subsystem.
  2. Start the ORFS measurement using the INITiate subsystem.
  3. Use the FETCh? command to obtain ORFS Power measurement results.

Programming Example

10 Test_set=714
20 OUTPUT Test_set;"SETup:ORFSpectrum:CONTinuous OFF"
30 !Configures a ORFS measurement to single trigger mode.
40 OUTPUT Test_set;"SETup:ORFSpectrum:FILTer:TYPE AUTO"
50 !Configures the measurement to choose the fastest measurement filter.
60 OUTPUT Test_set;"SETup:ORFSpectrum:COUNt:STATe ON"
70 !Configures a multi-measurement state to on.
80 OUTPUT Test_set;"SETup:ORFSpectrum:TRIGger:SOURce AUTO"
90 !Configures trigger source to auto.
100 OUTPUT Test_set;"SETup:ORFSpectrum:FILTer:TYPE DIGital"
110 !Configures the measurement filter type to Digital ORFS.
120 OUTPUT Test_set;"SETup:ORFSpectrum:SWITching:COUNt:NUMBer 50"
130 !Configures ORFS due to switching multi-measurement count.
140 OUTPUT Test_set;"SETup:ORFSpectrum:SWITching:FREQuency 200KHZ,400KHZ"
150 !Configure switching offsets.
160 OUTPUT Test_set;"SETup:ORFSpectrum:MODulation:COUNt:NUMBer 100"
170 !Configure ORFS due to modulation multi-measurement count.
180 OUTPUT Test_set;"SETup:ORFSpectrum:MODulation:FREQuency 200KHZ"
190 !Configure modulation offset.
200 OUTPUT Test_set;"READ:ORFSpectrum?"
210 !Start and fetch ORFS measurement.
220 !
230 ENTER Test_set;Integrity,Tx_pwr,Max_swit_200,Max_swit_400,Bw_pwr,Avg_mod_200
240 PRINT "Integrity: ";Integrity
250 PRINT "TX Power: ";Tx_pwr
260 PRINT "200 KHz offset frequency power: ";Max_swit_200
270 PRINT "400 KHz offset frequency power: ";Max_swit_400
280 PRINT "30 KHz Bandwidth Power: ";Bw_pwr
290 PRINT "Average Modulation Power at 200 KHz: ";Avg_mod_200
300 !
310 END

Returned values

The measurements returned by this program are:

  • Integrity returns the measurement Integrity Indicator (0 means a successful measurement with no errors).
  • Tx_pwr returns the transmit power in dBm.
  • Max_swit_200,Max_swit_400 returns maximum ORFS power due to switching in dBm (one maximum power level at a 200 kHz offset and one maximum power level at a 400 kHz offset).
  • Bw_pwr returns the power level in a 30 kHz bandwidth at zero offset in dBm (this is the reference level for ORFS power due to switching and ORFS power due to modulation).
  • Avg_mod_200 returns the average ORFS power due to modulation in dBm (one average power level at a 200 kHz offset).

Related Topics

Output RF Spectrum Measurement Description

SETup:ORFSpectrum

INITiate

FETCh:ORFSpectrum

GSM/GPRS Control Program Example

Programming an Output RF Spectrum Measurement for GPRS and EGPRS

This section provides an example of how to make the output RF spectrum (ORFS) measurement via GPIB.

When using the ORFS measurement with an EGPRS mobile, you can select a modulation coding scheme which uses either GMSK or 8PSK modulation. For more details on setting the modulation coding scheme, see

CALL:(PDTCH|PDTChannel):MCSCheme .

The following procedure assumes that a data connection has been established between the test set and the mobile station (connection status is Transferring). See Step 4: Make a Connection .

  1. Set the multislot configuration to two downlinks, two uplinks (D2U2) and set the uplink power control level for each of the two bursts using the CALL subsystem.
  2. Configure the ORFS measurement parameters using the SETup subsystem.
  3. Start the ORFS measurement using the INITiate subsystem.
  4. Use the FETCh? command to obtain ORFS Power measurement results.

Programming Example

10  OUTPUT 714;"CALL:PDTCH:MSLOT:CONFIG D2U2" ! Configures the multislot
20                                            ! configuration to be
30                                            ! 2 downlink, 2 uplink.
40  OUTPUT 714;"CALL:PDTCH:MS:TXLEVEL:BURST1 5" ! Sets the uplink power for
50                                              ! the first burst.
60  OUTPUT 714;"CALL:PDTCH:MS:TXLEVEL:BURST2 5" ! Sets the uplink power for
70                                              ! the second burst.
80  OUTPUT 714;"CALL:PDTCH:MSLOT:MEASUREMENT:BURST 2" ! Select to measure the
90                                                    ! second uplink burst in the
100                                                   ! multislot configuration.
110 OUTPUT 714;"SETUP:ORFSPECTRUM:CONTINUOUS OFF" !Configures a ORFS measurement
120                                                !to single trigger mode.
130 OUTPUT 714;"SETUP:ORFSPECTRUM:COUNT:STATE ON" !Configures a multi-measurement
140                                               !state to on.
150 OUTPUT 714;"SETUP:ORFSPECTRUM:TRIGGER:SOURCE AUTO" !Configure trigger source
160                                                    !to auto.
170 OUTPUT 714;"SETUP:ORFSPECTRUM:SWITCHING:COUNT:NUMBER 50" !Configures ORFS due
180                                                          !to switching
190                                                          !multi-measurement
200                                                          !count.
210 OUTPUT 714;"SETUP:ORFSPECTRUM:SWITCHING:FREQUENCY 200KHZ,400KHZ" !Configure
220                                                                  !switching
230                                                                  !offsets.
240 OUTPUT 714;"SETUP:ORFSPECTRUM:MODULATION:COUNT:NUMBER 100" !Configure ORFS
250                                                            !due to modulation
260                                                            !multi-measurement
270                                                            !count.
280 OUTPUT 714;"SETUP:ORFSPECTRUM:MODULATION:FREQUENCY 200KHZ" !Configure
290                                                            !modulation offset.
300 OUTPUT 714;"INITIATE:ORFSPECTRUM" !Start ORFS measurement.
310 OUTPUT 714;"FETCH:ORFSPECTRUM?" !Fetch ORFS results.
320 ENTER 714;Integrity,Tx_pwr,Max_swit_200,Max_swit_400,Bw_pwr,Avg_mod_200
330 END

Returned values

The measurements returned by this program are:

  • Integrity returns the measurement Integrity Indicator (0 means a successful measurement with no errors).
  • Tx_pwr returns the transmit power in dBm.
  • Max_swit_200,Max_swit_400 returns maximum ORFS power due to switching in dBm (one maximum power level at a 200 kHz offset and one maximum power level at a 400 kHz offset). This result relates to the whole multislot configuration.
  • Bw_pwr returns the power level in a 30 kHz bandwidth at zero offset in dBm (this is the reference level for ORFS power due to switching and ORFS power due to modulation).
  • Avg_mod_200 returns the average ORFS power due to modulation for the specified burst of the multislot configuration in dBm (one average power level at a 200 kHz offset).

Related Topics

Output RF Spectrum Measurement Description

SETup:ORFSpectrum

INITiate

FETCh:ORFSpectrum

GSM/GPRS Control Program Example


Programming a Phase and Amplitude vs. Time Measurement (Discrete Waveform)

Programming a Phase and Amplitude vs. Time Measurement (Discrete Waveform)

Last updated: December 3, 2008

This measurement is only applicable to the GSM/GPRS/EGPRS lab applications and test applications with the required feature license.

Procedure

This procedure assumes that the BCH parameter for the Cell Band is set up correctly for your mobile station and that the appropriate RF IN/OUT Amplitude Offsets have been set to offset the loss between the mobile station and the test set.

  1. If necessary, run the Spectrum Monitor Calibration. An example program is provided to demonstrate this step, see Programming the Spectrum Monitor Calibration It is recommended that you calibrate the Spectrum Monitor monthly.Refer to Calibrating the Test Set for more information on calibrating the test set.
  2. Set the Operating Mode to CW.
  3. Set the RF Generator cell power to OFF.
  4. Set the test set's RF Analyzer expected input frequency to the carrier frequency of the mobile station generated waveform.
  5. Set the test set's RF Analyzer expected input power level to the maximum power expected to be transmitted in the mobile station generated waveform.
  6. Configure the Phase and Amplitude vs. Time measurement specific parameters using SETup:PCALibration commands. For example, set the:
    • Phase and Amplitude versus Time measurement timeout.
    • Phase and Amplitude versus Time measurement trigger source.
    • Phase and Amplitude versus Time measurement waveform type.
  7. Initiate and Fetch the Phase and Amplitude vs. Time measurement with the READ? Subsystem.
  8. Command the mobile station to transmit the signal to be measured.

Discrete Phase and Amplitude vs. Time Measurement Program Example

The following example program does not apply for a continuous input waveform. This program demonstrates use of the Phase & Amplitude versus Time Measurement for a discrete waveform, but does not calibrate the Spectrum Monitor as recommended in step 1 in the procedure above. See Programming the Spectrum Monitor Calibration for an example of how to program the test set to calibrate the Spectrum Monitor.

Note: A 250 ms wait is needed after the measurement is initiated and before the measurement starts. Values for measurement interval center times and measurement interval widths are data values loaded into the Test Set. These data values are in the Time_specs subroutine at the end of this program.

10  Test_set=714
20      !Sets program variable "Test_set" equal to the Test Set's default GPIB address
30     !
40     ON TIMEOUT 7,15 CALL Timeout
50                     !Timeout protection subroutine; after 15 seconds of inactivity,
60                     ! the program stops and clears the GPIB bus (so the GPIB bus
70                     ! doesn't hang)
80                     !
90                             !****Test Set Setup****!
100                             !----------------------!
110     OUTPUT Test_set;"*RST"
120      !Resets all Test Set values to their default settings.
130     OUTPUT Test_set;"SYST:SYNC?"
140        ENTER Test_set;Sync_result
150                ! Ensures previous commands are complete before executing following
160                !  commands
170                !
180     !OUTPUT Test_set;"SYST:LOG:UI:GPIB:STAT ON"
190                !Turns on UI logging for GPIB troubleshooting; use web browser to
200                ! retrieve log; remove the command line after your program works
210                ! correctly
220                !
230     OUTPUT Test_set;"CALL:CELL:OPERating:MODE CW"
240      !Sets the operating mode to continuous wave.
250     !
260     OUTPUT Test_set;"RFAnalyzer:MANual:MEASurement:MFRequency 890.2 MHz"
270      !Sets the expected input frequency.
280     !
290     OUTPUT Test_set;"RFAnalyzer:CW:EXPected:POWer 10 dbm"
300      !Adjusts the Test Set to the expected power level (the maximum input level
310      ! in the TX waveform).
320      !
330     OUTPUT Test_set;"CALL:POWer:STATe OFF"
340      !Turns off the RF generator cell power, to remove any interference which
350      ! may affect the phone
360      !
370                             !**** Setup for PAvT Measurement ****!
380                             !------------------------------------!
390     OUTPUT Test_set;"SETup:PCALibration:TIMeout:STIMe 10"
400      !Sets the measurement timeout period to 10 seconds, and the state to on.
410     !
420     OUTPUT Test_set;"SETup:PCAL:TRIGger:SOURce RISE"
430      !Sets the trigger source as desired (RISE, IMMediate, or EXTernal).
440     !
450     OUTPUT Test_set;"SETup:PCAL:TRIGger:THReshold 20"
460      !Adjusts the trigger level in dB below the expected input power level.
470     !
480     OUTPUT Test_set;"SETup:PCAL:WAVeform:TYPe DISCRETE"
490      !Chooses the discrete version of the measurement
500      !
510     OUTPUT Test_set;"SETup:PCAL:TRIGger:DELay 0"
520      !Adjusts the trigger delay; default value is 0; default unit is seconds;
530      ! adjusts the time the test set waits after a physical trigger event, before
540      ! the Analog to Digital Converter acquires waveform samples
550     !
560       ! The following section sets up data arrays for this measurement for the
570       !   HT BASIC programming language
580         RESTORE Time_specs
590          !Points to the first data item on or after the beginning of the
600          ! Time_specs subroutine.
610     !
620         READ Step_count
630           !Assigns Step_count to the first data item on or after the beginning
640           ! of the Time_specs subroutine.
650     !
660         ALLOCATE Center(1:Step_count),Width(1:Step_count)
670           !Dimensions the `Center' and `Width' arrays to contain the same number of
680           ! elements as the number of measurement intervals (Step_count); also
690           ! reserves computer memory for the arrays.
700     !
710         OUTPUT Test_set;"SETup:PCAL:STEP:COUNt ";Step_count
720           !Tells the Test Set how many measurement intervals it will perform
730           ! (Step_count).
740     !
750         FOR I=1 TO Step_count
760           !Creates separate `Center' and `Width' arrays from the data items.
770           READ Time_cent,Time_width
780           Center(I)=Time_cent
790           Width(I)=Time_width
800         NEXT I
810     !
820         OUTPUT Test_set;"SETup:PCAL:STEP:CENTer ";Center(*)
830           !Enters the center location of each measurement interval (from the
840           ! `Center' array) into the Test Set
850     !
860          OUTPUT Test_set;"SETup:PCAL:STEP:WIDth  ";Width(*)
870            !Enters the center location of each measurement interval (from the
880            ! "Width" array) into the Test Set
890      !
900                              !****Initialize the measurement & get results.****!
910                              !-------------------------------------------------!
920      ALLOCATE Power_results(1:Step_count),Phase_results(1:Step_count),Freq_results(1:Step_count)
930       !Dimensions results arrays to contain the same number of elements as the
940       ! `Center' array and `Width' array; reserves computer memory for the arrays.
950        !
960      OUTPUT Test_set;"READ:PCAL?"
970       !Initiates the Phase & Amplitude vs. Time measurement and waits until
980       ! results are returned (or until the measurement timeout interval elapses).
990      !
1000      PRINT "*** Agilent E1968A Phase & Amplitude vs. Time Measurement ***"
1010      PRINT ""
1020      !
1030      PRINT "-->   INSTRUCTIONS TO USER:"
1040      PRINT "--> Command the wireless device to transmit the test waveform"
1050      PRINT "--> (before the end of the measurement timeout interval)."
1060      PRINT ""
1070       ! If your program controls when your device begins transmitting, you must
1080       !  include at least a 250 millisecond wait time between: initializing the
1090       !  PAvT measurement (READ:PCAL? above); and when the DUT transmits the
1100       !  test waveform
1110       !
1120      ENTER 714;Integrity,Power_results(*),Phase_results(*),Freq_results(*)
1130       ! Read and sort the measurement results from the Test Set.
1140      !
1150            IF Integrity<>0 THEN ! If measurement integrity value does not equal
1160                                 !  zero, there is an error
1170            PRINT "Measurement Error; Integrity Value = ";Integrity
1180            PRINT ""
1190         ELSE
1200         END IF
1210      !
1220      PRINT "Reference Measurement Data:"
1230      PRINT "    Absolute Power Reference = ";Power_results(1);" dBm"
1240      PRINT "    Phase error = 0 degrees by definition."
1250      PRINT "    Frequency Error (vs. meas. frequency) = ";Freq_results(1);" Hz"
1260      PRINT ""
1270       ! First measurement results are reference values; see documentation.
1280       !
1290      PRINT "Results below are compared to the Reference Measurement Data above."
1300      PRINT ""
1310      !
1320      PRINT "Power           Phase             Frequency"
1330      PRINT "Difference      Difference        Difference"
1340      PRINT "in dB           in degrees        in Hz"
1350      PRINT "------------------------------------------------"
1360      !
1370      FOR I=2 TO Step_count! Reads and prints the results arrays (not including
1380                           !  the first measurement results).
1390       PRINT Power_results(I);"      ";Phase_results(I);"        ";Freq_results(I)
1400      NEXT I
1410            !
1420      DEALLOCATE Power_results(*),Phase_results(*),Freq_results(*)
1430       ! Releases computer memory allocated for arrays
1440      !
1450      STOP
1460      ! Program stops here; subroutines continue below
1470      !
1480      !
1490  Time_specs:     !
1500       !
1510      DATA 20  ! The first data item is equal to the number of measurement
1520               ! intervals being specified (Step_count).
1530          !
1540      ! The following data values are used by this program to set the measurement
1550      ! interval center time (in seconds) and the measurement interval width (in
1560      ! seconds) for each step of a discrete input waveform.
1570      ! (These values do not apply to a continuous waveform measurement).
1580      !
1590      ! center (sec), width (sec)
1600      DATA .0005,.0008
1610      DATA .0015,.0008
1620      DATA .0025,.0008
1630      DATA .0035,.0008
1640      DATA .0045,.0008
1650      DATA .0055,.0008
1660      DATA .0065,.0008
1670      DATA .0075,.0008
1680      DATA .0085,.0008
1690      DATA .0095,.0008
1700      DATA .0105,.0008
1710      DATA .0115,.0008
1720      DATA .0125,.0008
1730      DATA .0135,.0008
1740      DATA .0145,.0008
1750      DATA .0155,.0008
1760      DATA .0165,.0008
1770      DATA .0175,.0008
1780      DATA .0185,.0008
1790      DATA .0195,.0008
1800      !
1810      DEALLOCATE Center(*),Width(*)
1820       ! Releases computer memory allocated for arrays
1830      !
1840      END
1850      !*****End of main program.****!
1860      !
1870      !
1880  Timeout: SUB Timeout
1890                 PRINT "Program timeout!!"
1900                 CLEAR 7
1910                 CLEAR 714
1920                 SUBEND
1930 !

Returned Values

This program sorts the measurement results into three arrays: Power_results, Phase_results and Freq_result. This program returns the arrays in three comma separated columns. The first column displays the Power results, the second displays the Phase results and the third displays the Frequency results.

Note: The first row of values returned by this program are absolute measurements and all subsequent rows are measured results relative to the absolute values. See Phase and Amplitude Measurement Results for a Discrete Waveform for more information.

Related Topics

Phase and Amplitude versus Time Measurement Description


Programming a Phase and Amplitude vs. Time Measurement (CONT2 Waveform)

Programming a Phase and Amplitude vs. Time Measurement (CONT2 Waveform)

Last updated: December 3, 2008

This measurement is only applicable to the GSM/GPRS/EGPRS lab applications or test applications with the required feature license.

This section is only applicable if the Waveform Type you wish to measure is a CONT2 waveform. If the Waveform Type you wish to measure is CONTinuous or CONT3 , see Programming a Phase and Amplitude vs. Time Measurement (CONTinuous Waveform) or Programming a Phase and Amplitude vs. Time Measurement (CONT3 Waveform) .

Procedure

This procedure assumes that the BCH parameter for the Cell Band is set up correctly for your mobile station and that the appropriate RF IN/OUT Amplitude Offsets have been set to offset the loss between the mobile station and the test set.

  1. Set the Operating Mode to Cell Off.

  2. Set the RF Generator cell power to OFF.
  3. Set the test set's RF Analyzer expected input frequency to the carrier frequency of the mobile station generated waveform.
  4. Set the test set's RF Analyzer expected input power level to the maximum power expected to be transmitted in the mobile station generated waveform.
  5. Configure the Phase and Amplitude vs. Time measurement specific parameters using SETup:PCALibration commands. For example, set the:
    • Phase and Amplitude versus Time measurement trigger source.
    • Phase and Amplitude versus Time measurement waveform type.
    • Phase and Amplitude versus Time measurement count.
  6. Initiate the Phase and Amplitude vs. Time measurement with the INITiate Subsystem .
  7. Command the mobile station to transmit the signal to be measured.
  8. Fetch the Phase and Amplitude vs. Time measurement with the FETCh? Subsystem .

Programming Example

This program demonstrates use of the Phase & Amplitude versus Time PAvT measurement for a continuous waveform that returns measurement results in binary format. It assumes that the RF Analyzer's expected input frequency and the expected input power have already been set (see RFANalyzer ).

IMPORTANT
This program assumes that you are using Agilent IO Libraries. If not, you must find and use other VISA libraries that allow the conversion from a binary value to a real number. You must also have a reference to the VISA COM driver. To create a Visual Basic® program that uses VISA COM, create your project in your normal manner then click on the Project menu and select References . Scroll down the list and select VISA COM 1.0 Type Library and Agilent VISA COM Resource Manager 1.0 , then click OK . If they don't appear in the list, select Browse... and navigate to the file c:\program files\visa\visacom\visacom.tlb. (Note: A single quote (`) marks the beginning of a comment in the following program. This program declares the test_set variable to be linked to the VISA COM library.

The binary transfer queries return an IEEE 488 definite length arbitrary header block, followed by an arbitrary data block that contains single-precision floating point numbers in IEEE 754 format that represent the amplitude and phase data results. This program was built using Visual Basic®, and uses ReadIEEEBlock to convert the binary data returned by the test set into ASCII data.

This algorithm that returns binary values, sampled at 13/3 million samples per second (4.333 MHz, or 4.333 samples per microsecond).This example sets the number of samples to measure to 2500. Therefore, this measurement takes approximately 0.577 ms to take 2500 samples at the sample rate of 4.333 samples per microsecond.

10           Test_set=714   !Sets variable "Test_set" = 8960's default GPIB address
20              !
30           DIM Ident$[200]! Sets a variable to store the *IDN result
40     !
50           Count=2500     ! Sets a variable for the number of samples to measure
60                          !
70           ON TIMEOUT 7,15 CALL Timeout
80           !Timeout protection subroutine; after 15 seconds of inactivity, the
90           ! program stops and clears the GPIB bus (so the GPIB bus doesn't hang)
100                         !
110                             !****Test Set Setup****!
120                             !----------------------!
130           OUTPUT Test_set;"*idn?"   ! Extra commands to identify specific 8960 used
140           ENTER Test_set;Ident$
150           PRINT "Test Set ID = ";Ident$
160     !
170           OUTPUT Test_set;"*RST"
180           ! Resets all Test Set values to their default settings; only necessary at
190           !  beginning of program (not at beginning of each PAvT measurement)
200                         !
210           OUTPUT Test_set;"SYST:SYNC?"
220           ENTER Test_set;Sync_result
230           ! Ensures previous commands are complete before executing other commands
240           !  so that elapsed time measurements are valid for each sub-section
250                         !
260     !OUTPUT Test_set;"SYST:LOG:UI:GPIB:STAT ON"
270           !Turns on UI logging for GPIB troubleshooting; use web browser to retrieve
280           ! log --->>> Remove this line after your program works correctly <<<---
290     !
300     !
310           Tsetup_start=TIMEDATE
320     !OUTPUT Test_set;"SYSTem:CORRection:SFRequency 890.2 MHz"
330     !OUTPUT Test_set;"SYST:CORR:GAIN -7"
340           ! Turn on RF offset for attenuation between phone & test set
350                         !
360           OUTPUT Test_set;"CALL:OPERating:MODE EBPT"
370           ! Sets operating mode to EGPRS BCH+PDTCH (test mode; no call processing)
380     !
390           OUTPUT Test_set;"RFANalyzer:MANual:MEASurement:MFRequency 890.2 MHz"
400           ! Sets the expected input frequency manually.
410     !
420           OUTPUT Test_set;"RFAN:CONTrol:POWer:AUTO OFF"
430           ! Sets the input level to manual control.
440                         !
450           OUTPUT Test_set;"RFAN:MAN:POWer:BURSt 10 dbm"
460           ! Adjusts the Test Set to the expected power level (typically the maximum
470           !  expected input level in the TX waveform).
480                         !
490           OUTPUT Test_set;"CALL:POW:STATe OFF"
500           ! Turns off the RF generator cell power, if desired.
510                        !
520           OUTPUT Test_set;"SYST:SYNC?"
530           ENTER Test_set;Sync_result
540           !Ensures previous commands are complete before executing other commands
550           !  so that elapsed time measurements are valid for each sub-section
560           Tsetup_time=TIMEDATE-Tsetup_start
570           PRINT "  Elapsed Test Set SETUP time = ";Tsetup_time;" seconds"
580                         !
590                         !
600                             !**** Setup for PAvT Measurement ****!
610                             !------------------------------------!
620           Pcalset_start=TIMEDATE
630           OUTPUT Test_set;"SETup:PCALibration:TIMeout:STIMe 10"
640            !Sets the measurement timeout period to 10 seconds, and the state to on.
650     !
660            OUTPUT Test_set;"SETup:PCAL:TRIGger:SOURce rise"
670             !Sets the trigger source as desired (RISE, IMMediate, or EXTernal).
680      !
690            OUTPUT Test_set;"SETup:PCAL:TRIG:THReshold 5"
700             !Adjusts the trigger level in dB below the expected input power level.
710      !
720            OUTPUT Test_set;"SETup:PCAL:WAVeform:TYPe CONT2"
730             !Chooses the continuous (sampled) version of the PAvT measurement
740                            !
750            OUTPUT Test_set;"SETup:PCAL:TRIG:DELay 0us"
760             ! Adjusts the trigger delay; default value=0; default unit is seconds.
770             !  Adjusts the time the test set waits after a physical trigger event,
780             !  before the Analog to Digital Converter acquires waveform samples.
790      !
800      ! OUTPUT Test_set;"SETup:PCAL:MEASurement:DELay 0us"
810             ! USE ONLY FOR CONTINUOUS ALGORITHMS!
820             ! Adjusts the measurement delay; default value is 0; default units is
830             !  seconds.  Adjusts time the test set waits after a physical trigger
840             !  event, before the "measurement" begins (this means, where in time the
850             !  filtering & vector analysis into amplitude/phase pairs begins). This
860             !  allows you to ignore initial waveform samples if desired.
870                            !
880            OUTPUT Test_set;"SETup:PCAL:MEAS:COUNt";Count
890             ! Sets the number of continuous samples
900                           !
910            OUTPUT Test_set;"SYST:SYNC?"
920            ENTER Test_set;Sync_result
930             !Ensures previous commands are complete before executing other commands
940             !  so that elapsed time measurements are valid for each sub-section
950            Pcalset_time=TIMEDATE-Pcalset_start
960            PRINT "  Elapsed PAvT     SETUP time = ";Pcalset_time;" seconds"
970      !
980      !
990             !***********************************************************************
1000             !                 DECIMAL MEASUREMENT SECTION
1010             ! The first portion of the program uses decimal fetches of the results.
1020             !***********************************************************************
1030      !
1040      !
1050                      !****Setup phase & amplitude arrays for DECIMAL results.****!
1060                      !-----------------------------------------------------------!
1070            ALLOCATE Phase1$[18000],Phase2$[18000],Phase3$[9000]
1080            ALLOCATE Amplit1$[18000],Amplit2$[18000],Amplit3$[9000]
1090             !Dimension results arrays (of type=string) to contain the measurement
1100             ! data; reserves computer memory for the arrays; string size set to
1110             ! 18000 based on (1000 values max. x 18 characters per value)
1120             ! [9000 = 500 values x 18 char/value]
1130      !
1140      !
1150                      !****Initialize the measurement & get DECIMAL results.****!
1160                      !---------------------------------------------------------!
1170            Meas_start=TIMEDATE
1180            OUTPUT Test_set;"INITiate:PCALibration"
1190      !Initiates the PAvT measurement and waits until
1200      ! results are returned (or until the measurement timeout interval elapses).
1210                           !
1220            OUTPUT Test_set;"SYST:SYNC?"
1230            ENTER Test_set;Sync_result
1240      !Ensures previous commands are complete before executing other commands
1250      !  so that elapsed time measurements are valid for each sub-section
1260      !
1270      !PRINT "*** Agilent E1968A Phase & Amplitude vs. Time Measurement ***"
1280      !PRINT ""
1290      !PRINT "-->   INSTRUCTIONS TO USER:"
1300      !PRINT "--> Command the wireless device to transmit the test waveform"
1310      !PRINT "--> (before the end of the measurement timeout interval)."
1320      !PRINT ""
1330                   !
1340            Meas_time=TIMEDATE-Meas_start
1350            PRINT "    Elapsed MEASUREMENT  time = ";Meas_time;" seconds"
1360      !
1370                               !
1380            !****Fetch DECIMAL phase & ampl. data; store results in arrays.****!
1390            !------------------------------------------------------------------!
1400      ! Each DECIMAL fetch returns up to 1000 comma-separated values; see PAvT
1410      !  documentation for more details for Fetch:Pcal:Sample description
1420            Decdata_st=TIMEDATE
1430            OUTPUT Test_set;"FETCh:PCAL:SAMPle:AMPLitude:dbm? 1"
1440            ENTER Test_set;Amplit1$
1450            OUTPUT Test_set;"FETCh:PCAL:SAMPle:AMPLitude:dbm? 2"
1460            ENTER Test_set;Amplit2$
1470            OUTPUT Test_set;"FETCh:PCAL:SAMPle:AMPLitude:dbm? 3"
1480            ENTER Test_set;Amplit3$
1490            OUTPUT Test_set;"FETCh:PCAL:SAMPle:PHASe? 1"
1500            ENTER Test_set;Phase1$
1510            OUTPUT Test_set;"FETCh:PCAL:SAMPle:PHASe? 2"
1520            ENTER Test_set;Phase2$
1530            OUTPUT Test_set;"FETCh:PCAL:SAMPle:PHASe? 3"
1540            ENTER Test_set;Phase3$
1550            Decdata_tm=TIMEDATE-Decdata_st
1560            PRINT "      Elapsed DECIMAL data retrieve time = ";Decdata_tm;" seconds"
1570                    !
1580             !
1590      !
1600           !*************************************************************************
1610           !                     BINARY MEASUREMENT SECTION
1620           ! It's much faster to retrieve the data in BINARY, so the second portion
1630           ! of the program repeats the measurement process, but uses binary fetches.
1640           !*************************************************************************
1650      !
1660      !
1670                    !****Setup phase & amplitude arrays for BINARY results.****!
1680                    !----------------------------------------------------------!
1690            ALLOCATE Phasbin$[10000],Amplbin$[10000]
1700             !Dimension results arrays (of type=string) to contain the binary
1710             ! measurement data; should be 2500 results x 4 bytes each = 10000 values
1720             ! for a full 577us burst.
1730      !
1740      !
1750              !****Fetch BINARY phase & ampl. data; store results in arrays.****!
1760              !-----------------------------------------------------------------!
1770            Bindata_st=TIMEDATE
1780            OUTPUT Test_set;"FETCh:PCALibration:SAMPle:AMPLitude:BINary?"
1790            ENTER Test_set;Amplbin$
1800            OUTPUT Test_set;"FETCh:PCALibration:SAMPle:PHASe:BINary?"
1810            ENTER Test_set;Phasbin$
1820            Bindata_tm=TIMEDATE-Bindata_st
1830            PRINT "      Elapsed BINARY  data retrieve time = ";Bindata_tm;" seconds"
1840            PRINT ""
1850                            !
1860                    !****Fetch DECIMAL PAvT integrity indicator and sample count****!
1870                    !**** (same for both the DECIMAL and BINARY methods)
1880                    !   [note that these data cannot be retrieved in binary format]
1890                    !---------------------------------------------------------------!
1900            OUTPUT Test_set;"FETCh:PCAL:SAMPle:COUNt?"
1910            ENTER Test_set;Result_count
1920               ! Number of results for amplitude and phase pairs (integer value)
1930            PRINT "Number of measured amplitude and phase pairs = ";Result_count
1940            OUTPUT Test_set;"FETCh:PCAL:INTegrity?"
1950            ENTER Test_set;Integrity
1960               ! Read PAvT measurement integrity from the Test Set.
1970            PRINT "Integrity value =";Integrity
1980            PRINT ""
1990            PRINT ""
2000            IF Integrity<>0 THEN
2010                 ! If measurement integrity does not equal zero, there is an error.
2020                PRINT "Measurement Error; Integrity Value = ";Integrity
2030                PRINT ""
2040            ELSE
2050            END IF
2060      !
2070      !
2080            !****For illustration: prints 1st values from DECIMAL ampl. array.****!
2090            !---------------------------------------------------------------------!
2100            PRINT "----------------- DECIMAL Amplitude Data #1 --------------------"
2110            PRINT Amplit1$
2120            PRINT "----------------------------------------------------------------"
2130      !
2140            DEALLOCATE Phase1$,Amplit1$,Phase2$,Amplit2$,Phase3$,Amplit3$
2150      ! Releases computer memory allocated for decimal arrays
2160      !
2170      !
2180             !****For illustration: prints values from BINARY amplitude array.****!
2190             !--------------------------------------------------------------------!
2200             !PRINT "----------------- BINARY Amplitude Data ---------------------"
2210             !PRINT Amplbin$
2220             !PRINT "-------------------------------------------------------------"
2230      !
2240            DEALLOCATE Phasbin$,Amplbin$
2250                 ! Releases PC memory allocated for binary arrays
2260      !
2270      !
2280                 !****End of program****!
2290                 !----------------------!
2300            OUTPUT Test_set;"INIT:PCAL:OFF"
2310             ! Turns off the PAvT measurement at the end of the program
2320            END
2330      !
2340  Timeout: SUB Timeout
2350                PRINT "Program timeout!!"
2360                CLEAR 7       ! Clears the PC's GPIB interface (at select code 7)
2370                CLEAR 714       ! Clears the Test Set GPIB interface
2380            SUBEND

Returned Values

Once you have clicked the Click to run PAvT button on the GUI, this program displays following values:

  • Amplitude Results -This field displays two columns: the sample number in square brackets (starting at zero), followed by the corresponding Amplitude result for that sample. The length of these columns is determined by the measurement count.
  • Phase Results -This field also displays two columns: the sample number in square brackets (starting at zero), followed by the corresponding Phase result for that sample. The length of these columns is determined by the measurement count.

Related Topics

Phase and Amplitude versus Time Measurement Description

Programming a Phase and Amplitude vs. Time Measurement (CONTinuous Waveform)

Programming a Phase and Amplitude vs. Time Measurement (CONT3 Waveform)

SETup:PCALibration

FETCh:PCALibration


Programming a Phase and Amplitude vs. Time Measurement (CONTinuous Waveform)

Programming a Phase and Amplitude vs. Time Measurement (CONTinuous Waveform)

Last updated: December 3, 2008

This measurement is only applicable to the GSM/GPRS/EGPRS lab applications and test applications with the required feature license.

This section is only applicable if the Waveform Type you wish to measure is a CONTinuous waveform. If the Waveform Type you wish to measure is CONT2 or CONT3 , see Programming a Phase and Amplitude vs. Time Measurement (CONT2 Waveform) or Programming a Phase and Amplitude vs. Time Measurement (CONT3 Waveform) .

Procedure

This procedure assumes that the BCH parameter for the Cell Band is set up correctly for your mobile station and that the appropriate RF IN/OUT Amplitude Offsets have been set to offset the loss between the mobile station and the test set.

  1. If necessary, run the Spectrum Monitor Calibration. An example program is provided to demonstrate this step, see Programming the Spectrum Monitor Calibration It is recommended that you calibrate the Spectrum Monitor monthly. Refer to Calibrating the Test Set for more information on calibrating the test set.

  2. Set the Operating Mode to CW.

  3. Set the RF Generator cell power to OFF.
  4. Set the test set's RF Analyzer expected input frequency to the carrier frequency of the mobile station generated waveform.
  5. Set the test set's RF Analyzer expected input power level to the maximum power expected to be transmitted in the mobile station generated waveform.
  6. Configure the Phase and Amplitude vs. Time measurement specific parameters using SETup:PCALibration commands. For example, set the:
    • Phase and Amplitude versus Time measurement timeout.
    • Phase and Amplitude versus Time measurement trigger source.
    • Phase and Amplitude versus Time measurement waveform type.
  7. Initiate and Fetch the Phase and Amplitude vs. Time measurement with the READ? Subsystem.
  8. Command the mobile station to transmit the signal to be measured.

Programming Example

This program demonstrates use of the Phase & Amplitude versus Time Measurement for a continuous waveform. This program does not calibrate the Spectrum Monitor, however it is important to do so at regular intervals. If you have not performed the recommend monthly calibration of your test set, an example program is provided, see Example Spectrum Monitor Program .

This example does not apply to a discrete waveform.

The continuous algorithm samples at 13/12 million samples per second (1.083 MHz, or 1.083 samples per microsecond).

The variable Count in line 30 sets the number of samples to be measured. This measurement takes approximately 2.31 ms to take 2500 samples at the sample rate of 1.083 samples per microsecond. Since this measurement returns data in blocks of up to 1000 values, this program separates the 2500 results into two string arrays containing 1000 values each and a third string array with 500 values. This is done for both the amplitude and phase results, giving a total of six arrays. (Note: The exclamation mark (!) symbol causes the compiler to ignore any text that follows it until the end of the line.)

10 !* 180 Test_set=714
20       !Sets program variable "Test_set" equal to the 8960's default GPIB address
30     !
40     Count=867
50       ! Sets a variable for the number of samples to measure
60                     !
70     ON TIMEOUT 7,15 CALL Timeout
80       !Timeout protection subroutine; after 15 seconds of inactivity, the
90       ! program stops and clears the GPIB bus (so the GPIB bus doesn't hang)
100                    !
110                        !****Test Set Setup****!
120                        !----------------------!
130     OUTPUT Test_set;"*RST"
140       !Resets all Test Set values to their default settings.
150                    !
160     OUTPUT Test_set;"SYST:SYNC?"
170     ENTER Test_set;Sync_result
180       !Ensures previous commands are complete before executing following commands.
190                    !
200     !OUTPUT Test_set;"SYST:LOG:UI:GPIB:STAT ON"
210       !Turns on UI logging for GPIB troubleshooting;
220       ! --->>> COMMENT this line out of your program after it works <<<---
230                    !
240     OUTPUT Test_set;"CALL:OPERating:MODE CW"
250        !Sets the operating mode to CW (test mode; no call processing).
260     !
270     OUTPUT Test_set;"RFANalyzer:MANual:MEASurement:MFRequency 890.2 MHz"
280        !Sets the expected input frequency manually.
290     !
330     OUTPUT Test_set;"RFAN:CW:EXP:POW 10 dbm"
340        !Adjusts the Test Set to the expected power level (the maximum
350        ! expected input level in the TX waveform).
360                    !
370     OUTPUT Test_set;"CALL:POW:STATe OFF"
380        !Turns off the RF generator cell power, if desired.
390                    !
400                        !**** Setup for PAvT Measurement ****!
410                        !------------------------------------!
420     OUTPUT Test_set;"SETup:PCALibration:TIMeout:STIMe 10"
430        !Sets the measurement timeout period to 10 s, and state to on.
440     !
450     OUTPUT Test_set;"SETup:PCAL:TRIGger:SOURce RISE"
460        !Sets the trigger source (RISE, IMMediate, or EXTernal).
470     !
480     OUTPUT Test_set;"SETup:PCAL:TRIG:THReshold 10"
490        !Adjusts trigger level in dB below the expected input power level.
500     !
510     OUTPUT Test_set;"SETup:PCAL:WAVeform:TYPe CONTinuous"
520        !Chooses the continuous (sampled) version of the PAvT measurement
530                    !
540     OUTPUT Test_set;"SETup:PCAL:TRIG:DELay 0"
550        ! Adjusts the trigger delay; default value is 0; default unit is seconds.
560        !  Adjusts the time the test set waits after the rising edge of the initial
570        !  GSM reference burst, before the Analog to Digital Converter acquires
580        !  waveform samples.
590     !
600     ! OUTPUT Test_set;"SETup:PCAL:MEASurement:DELay 0"
610        ! Adjusts the measurement delay; default value is 0; default units is
620        !  seconds.  Adjusts the time the test set waits after the falling edge of
630        !  the initial GSM reference burst, before the "measurement" begins (this
640        !  means, where in time the filtering and vector analysis into amplitude &
650        !  phase pairs begins).  This allows you to ignore initial waveform
660        !  information if desired.
670                    !
680     OUTPUT Test_set;"SETup:PCAL:MEAS:COUNt";Count
690        ! Sets the number of continuous samples
700                   !
710     OUTPUT Test_set;"SYST:SYNC?"
720     ENTER Test_set;Sync_result
730        !Ensures previous commands are complete before executing following commands.
740     !
750                        !****Initialize the measurement & get results.****!
760                        !-------------------------------------------------!
770     OUTPUT Test_set;"INITiate:PCALibration"
780        !Initiates the PAvT measurement and waits until
790        ! results are returned (or until the measurement timeout interval elapses).
800     !
810     PRINT "*** Agilent E1968A Phase & Amplitude vs. Time Measurement ***"
820     PRINT ""
830      PRINT "-->   INSTRUCTIONS TO USER:"
840      PRINT "--> Command the wireless device to transmit the test waveform"
850      PRINT "--> (before the end of the measurement timeout interval)."
860      PRINT ""
870      !
880      OUTPUT Test_set;"FETCh:PCAL:SAMPle:COUNt?"
890      ENTER Test_set;Result_count
900         ! Number of results available for amplitude and phase pairs (integer value)
910      PRINT "Number of measured amplitude and phase pairs = ";Result_count
920      !
930      OUTPUT Test_set;"FETCh:PCAL:INTegrity?"
940      ENTER Test_set;Integrity
950         ! Read PAvT measurement integrity from the Test Set.
960      PRINT "Integrity value =";Integrity
970      PRINT ""
980         IF Integrity<>0 THEN ! If measurement integrity value does not equal zero,
990                              !  there is an error.
1000            PRINT "Measurement Error; Integrity Value = ";Integrity
1010            PRINT ""
1020         ELSE
1030         END IF
1040      !
1050                             !****Fetch absolute power****!
1060                             !----------------------------!
1070      OUTPUT Test_set;"FETCh:PCAL:REFerence:POWer?"
1080      ENTER Test_set;Ref_power
1090         ! Returns absolute power in dBm of initial GSM reference burst for
1100         !  continuous PAvT algorithm
1110      PRINT "    Absolute Power Measurement = ";Ref_power;" dBm"
1120      PRINT ""
1130      !
1140                             !****Setup phase & amplitude arrays for results.****!
1150                             !---------------------------------------------------!
1160      ALLOCATE Phase1$[15606],Amplit1$[15606]
1170        !Dimension results arrays for strings to contain the measurement
1180        ! data (because fetches for lots of decimal data into PC's are often faster
1190        ! using strings); reserves computer memory for the arrays; string size of
1200        ! 15606 based on 867 values x 18 (18 characters per string value in HT BASIC)
1210                        !
1220                 !****Fetch phase & amplitude data; store results in arrays.****!
1230                 !--------------------------------------------------------------!
1240      OUTPUT Test_set;"FETCh:PCAL:SAMPle:AMPLitude? 1"
1250       ENTER Test_set;Amplit1$
1260      OUTPUT Test_set;"FETCh:PCAL:SAMPle:PHASe? 1"
1270       ENTER Test_set;Phase1$
1280               ! Each Fetch returns up to 1000 comma-separated values; see PAvT
1290               !  documentation for more details for Fetch:Pcal:Sample description
1300      !
1310                !****For illustration: prints values from one array.****!
1320                !-------------------------------------------------------!
1330      PRINT "Amplitude1 Data (867 comma-separated values)"
1340      PRINT "---------------------------------------------"
1350      PRINT Amplit1$
1360      !
1370               !****Convert amplitude data to dBm if desired****!
1380               !------------------------------------------------!
1390        ! Amplitude value in dbm = 20 * log10 (amplitude sample)
1400      !
1410      DEALLOCATE Phase1$,Amplit1$
1420        ! Releases computer memory allocated for arrays
1430                               !
1440      OUTPUT Test_set;"INIT:PCAL:OFF"
1450        ! Turns off the PAvT measurement at the end of the program
1460      !
1470      END
1480      !*****Ends the program.****!
1490      !
1500  Timeout: SUB Timeout
1510                  PRINT "Program timeout!!"
1520                  CLEAR 7   ! Clear PC GPIB Interface device (at select code 7)
1530                  CLEAR 714 ! Clear Test Set GPIB interface
1540                  SUBEND
1550 !

Returned Values

This program prints the values for the following:

  • total number of amplitude and phase pair results ( Result_count )
  • integrity value for the measurement ( Integrity )
  • absolute power (in dBm) of the first burst for the continuous algorithm only ( Ref_power )
  • the first 1000 phase values (There are a total of 6 arrays returned - 3 amplitude arrays that contain up to 1000 each and 3 phase arrays that contain up to 1000 each. Only the first phase array is printed by this program.)

Related Topics

Phase and Amplitude versus Time Measurement Description

Programming the Spectrum Monitor Calibration

Programming a Phase and Amplitude vs. Time Measurement (CONT2 Waveform)

Programming a Phase and Amplitude vs. Time Measurement (CONT3 Waveform)

SETup:PCALibration

FETCh:PCALibration


Programming a Phase and Amplitude vs. Time Measurement (CONT3 Waveform)

Programming a Phase and Amplitude vs. Time Measurement (CONT3 Waveform)

Last updated: December 3, 2008

This measurement is only applicable to the GSM/GPRS/EGPRS lab applications or test applications with the required feature license.

This section is only applicable if the Waveform Type you wish to measure is a CONT3 waveform. If the Waveform Type you wish to measure is CONTinuous , or CONT2 see Programming a Phase and Amplitude vs. Time Measurement (CONTinuous Waveform) ,or Programming a Phase and Amplitude vs. Time Measurement (CONT2 Waveform) .

Procedure

This procedure assumes that the BCH parameter for the Cell Band is set up correctly for your mobile station and that the appropriate RF IN/OUT Amplitude Offsets have been set to offset the loss between the mobile station and the test set.

  1. Set the Operating Mode to Cell Off.

  2. Set the RF Generator cell power to OFF.
  3. Set the test set's RF Analyzer expected input frequency to the carrier frequency of the mobile station generated waveform.
  4. Set the test set's RF Analyzer expected input power level to the maximum power expected to be transmitted in the mobile station generated waveform.
  5. Configure the Phase and Amplitude vs. Time measurement specific parameters using SETup:PCALibration commands. For example, set the:
    • Phase and Amplitude versus Time measurement trigger source.
    • Phase and Amplitude versus Time measurement waveform type.
    • Phase and Amplitude versus Time measurement count.
  6. Initiate the Phase and Amplitude vs. Time measurement with the INITiate Subsystem .
  7. Command the mobile station to transmit the signal to be measured.
  8. Fetch the Phase and Amplitude vs. Time measurement with the FETCh? Subsystem .

Programming Example

This program demonstrates use of the Phase & Amplitude versus Time PAvT measurement for a continuous waveform that returns measurement results in binary format. It assumes that the RF Analyzer's expected input frequency and the expected input power have already been set (see RFANalyzer ).

IMPORTANT
This program assumes that you are using Agilent IO Libraries. If not, you must find and use other VISA libraries that allow the conversion from a binary value to a real number. You must also have a reference to the VISA COM driver. To create a Visual Basic® program that uses VISA COM, create your project in your normal manner then click on the Project menu and select References . Scroll down the list and select VISA COM 1.0 Type Library and Agilent VISA COM Resource Manager 1.0 , then click OK . If they don't appear in the list, select Browse... and navigate to the file c:\program files\visa\visacom\visacom.tlb. (Note: A single quote (`) marks the beginning of a comment in the following program. This program declares the test_set variable to be linked to the VISA COM library.

The binary transfer queries return an IEEE 488 definite length arbitrary header block, followed by an arbitrary data block that contains single-precision floating point numbers in IEEE 754 format that represent the amplitude and phase data results. This program was built using Visual Basic®, and uses ReadIEEEBlock to convert the binary data returned by the test set into ASCII data.

This algorithm that returns binary values, sampled at 20/2 million samples per second (10 MHz, or 10 samples per microsecond).This example sets the number of samples to measure to 2500. Therefore, this measurement takes approximately 0.25 ms to take 2500 samples at the sample rate of 10 samples per microsecond.

10          Test_set=714   !Sets variable "Test_set" = 8960's default GPIB address
20              !
30          DIM Ident$[200]! Sets a variable to store the *IDN result
40        !
50          Count=2500    ! Sets a variable for the number of samples to measure
60                             !
70          ON TIMEOUT 7,15 CALL Timeout
80          !Timeout protection subroutine; after 15 seconds of inactivity, the
90          ! program stops and clears the GPIB bus (so the GPIB bus doesn't hang)
100                             !
110                            !****Test Set Setup****!
120                            !----------------------!
130          OUTPUT Test_set;"*idn?"   ! Extra commands to identify specific 8960 used
140          ENTER Test_set;Ident$
150          PRINT "Test Set ID = ";Ident$
160         !
170          OUTPUT Test_set;"*RST"
180          ! Resets all Test Set values to their default settings; only necessary at
190          !  beginning of program (not at beginning of each PAvT measurement)
200                             !
210          OUTPUT Test_set;"SYST:SYNC?"
220          ENTER Test_set;Sync_result
230          ! Ensures previous commands are complete before executing other commands
240          !  so that elapsed time measurements are valid for each sub-section
250                             !
260          !OUTPUT Test_set;"SYST:LOG:UI:GPIB:STAT ON"
270          !Turns on UI logging for GPIB troubleshooting; use web browser to retrieve
280          ! log --->>> Remove this line after your program works correctly <<<---
290         !
300         !
310          Tsetup_start=TIMEDATE
320          !OUTPUT Test_set;"SYSTem:CORRection:SFRequency 890.2 MHz"
330          !OUTPUT Test_set;"SYST:CORR:GAIN -7"
340          ! Turn on RF offset for attenuation between phone & test set
350                             !
360          OUTPUT Test_set;"CALL:OPERating:MODE EBPT"
370          ! Sets operating mode to EGPRS BCH+PDTCH (test mode; no call processing)
380         !
390          OUTPUT Test_set;"RFANalyzer:MANual:MEASurement:MFRequency 890.2 MHz"
400          ! Sets the expected input frequency manually.
410         !
420          OUTPUT Test_set;"RFAN:CONTrol:POWer:AUTO OFF"
430          ! Sets the input level to manual control.
440                           !
450          OUTPUT Test_set;"RFAN:MAN:POWer:BURSt 10 dbm"
460          ! Adjusts the Test Set to the expected power level (typically the maximum
470          !  expected input level in the TX waveform).
480                             !
490          OUTPUT Test_set;"CALL:POW:STATe OFF"
500          ! Turns off the RF generator cell power, if desired.
510                            !
520          OUTPUT Test_set;"SYST:SYNC?"
530          ENTER Test_set;Sync_result
540          !Ensures previous commands are complete before executing other commands
550          !  so that elapsed time measurements are valid for each sub-section
560          Tsetup_time=TIMEDATE-Tsetup_start
570          PRINT "  Elapsed Test Set SETUP time = ";Tsetup_time;" seconds"
580                             !
590                          !
600                           !**** Setup for PAvT Measurement ****!
610                           !------------------------------------!
621          Pcalset_start=TIMEDATE
630          OUTPUT Test_set;"SETup:PCALibration:TIMeout:STIMe 10"
640          !Sets the measurement timeout period to 10 seconds, and the state to on.
650         !
660          OUTPUT Test_set;"SETup:PCAL:TRIGger:SOURce rise"
670          !Sets the trigger source as desired (RISE, IMMediate, or EXTernal).
680        !
690          OUTPUT Test_set;"SETup:PCAL:TRIG:THReshold 5"
700          !Adjusts the trigger level in dB below the expected input power level.
710          !
720          OUTPUT Test_set;"SETup:PCAL:WAVeform:TYPe CONT3"
730          !Chooses the continuous (sampled) version of the PAvT measurement
740                                !
750          OUTPUT Test_set;"SETup:PCAL:TRIG:DELay 0us"
760            ! Adjusts the trigger delay; default value=0; default unit is seconds.
770            !  Adjusts the time the test set waits after a physical trigger event,
780            !  before the Analog to Digital Converter acquires waveform samples.
790       !
800            ! OUTPUT Test_set;"SETup:PCAL:MEASurement:DELay 0us"
810            ! USE ONLY FOR CONTINUOUS ALGORITHMS!
820            ! Adjusts the measurement delay; default value is 0; default units is
830            !  seconds.  Adjusts time the test set waits after a physical trigger
840            !  event, before the "measurement" begins (this means, where in time the
850            !  filtering & vector analysis into amplitude/phase pairs begins). This
860            !  allows you to ignore initial waveform samples if desired.
870                                !
880          OUTPUT Test_set;"SETup:PCAL:MEAS:COUNt";Count
890            ! Sets the number of continuous samples
900                              !
910          OUTPUT Test_set;"SYST:SYNC?"
920          ENTER Test_set;Sync_result
930            !Ensures previous commands are complete before executing other commands
940            !  so that elapsed time measurements are valid for each sub-section
950          Pcalset_time=TIMEDATE-Pcalset_start
960          PRINT "  Elapsed PAvT     SETUP time = ";Pcalset_time;" seconds"
970          !
980          !
990           !***********************************************************************
1000           !                 DECIMAL MEASUREMENT SECTION
1010           ! The first portion of the program uses decimal fetches of the results.
1020           !***********************************************************************
1030           !
1040           !
1050                   !****Setup phase & amplitude arrays for DECIMAL results.****!
1060                   !-----------------------------------------------------------!
1070            !
1071                 !
1072          ALLOCATE Phase1$[18000],Phase2$[18000],Phase3$[9000]
1080          ALLOCATE Amplit1$[18000],Amplit2$[18000],Amplit3$[18000]
1081          ALLOCATE REAL Amplit1(0:999),Phase1(0:999)
1082                !
1083 !
1090           !Dimension results arrays (of type=string) to contain the measurement
1100           ! data; reserves computer memory for the arrays; string size set to
1110           ! 18000 based on (1000 values max. x 18 characters per value)
1120           ! [9000 = 500 values x 18 char/value]
1130           !
1140           !
1150                   !****Initialize the measurement & get DECIMAL results.****!
1160                   !---------------------------------------------------------!
1170          Meas_start=TIMEDATE
1180          OUTPUT Test_set;"INITiate:PCALibration"
1190            !Initiates the PAvT measurement and waits until
1200            ! results are returned (or until the measurement timeout interval elapses).
1210                                !
1220            !OUTPUT Test_set;"SYST:SYNC?"
1230            !ENTER Test_set;Sync_result
1240            !Ensures previous commands are complete before executing other commands
1250            !  so that elapsed time measurements are valid for each sub-section
1260           !
1270          PRINT "*** Agilent E1968A Phase & Amplitude vs. Time Measurement ***"
1280          PRINT ""
1290          PRINT "-->   INSTRUCTIONS TO USER:"
1300          PRINT "--> Command the wireless device to transmit the test waveform"
1310          PRINT "--> (before the end of the measurement timeout interval)."
1320          PRINT ""
1330                        !
1340          Meas_time=TIMEDATE-Meas_start
1350          PRINT "    Elapsed MEASUREMENT  time = ";Meas_time;" seconds"
1360           !
1370                                         !
1380            !****Fetch DECIMAL phase & ampl. data; store results in arrays.****!
1390            !------------------------------------------------------------------!
1400            ! Each DECIMAL fetch returns up to 1000 comma-separated values; see PAvT
1410               !  documentation for more details for Fetch:Pcal:Sample description
1420          Decdata_st=TIMEDATE
1430          OUTPUT Test_set;"FETCh:PCAL:SAMPle:AMPLitude:dbm? 1"
1440          ENTER Test_set;Amplit1$
1450          OUTPUT Test_set;"FETCh:PCAL:SAMPle:AMPLitude:dbm? 2"
1460          ENTER Test_set;Amplit2$
1470          OUTPUT Test_set;"FETCh:PCAL:SAMPle:AMPLitude:dbm? 3"
1480          ENTER Test_set;Amplit3$
1490          OUTPUT Test_set;"FETCh:PCAL:SAMPle:PHASe? 1"
1500          ENTER Test_set;Phase1$
1510          OUTPUT Test_set;"FETCh:PCAL:SAMPle:PHASe? 2"
1520          ENTER Test_set;Phase2$
1530          OUTPUT Test_set;"FETCh:PCAL:SAMPle:PHASe? 3"
1540          ENTER Test_set;Phase3$
1550          Decdata_tm=TIMEDATE-Decdata_st
1560          PRINT "      Elapsed DECIMAL data retrieve time = ";Decdata_tm;" seconds"
1570                         !
1580                  !
1590           !
1600            !*************************************************************************
1610            !                     BINARY MEASUREMENT SECTION
1620            ! It's much faster to retrieve the data in BINARY, so the second portion
1630            ! of the program repeats the measurement process, but uses binary fetches.
1640            !*************************************************************************
1650           !
1660           !
1670                  !****Setup phase & amplitude arrays for BINARY results.****!
1680                  !----------------------------------------------------------!
1690           ALLOCATE Phasbin$[10000],Amplbin$[10000]
1701           !Dimension results arrays (of type=string) to contain the binary
1710           ! measurement data; should be 2500 results x 4 bytes each = 10000 values
1720           ! for a full 250us burst.
1730        !
1740           !
1750           !****Fetch BINARY phase & ampl. data; store results in arrays.****!
1760           !-----------------------------------------------------------------!
1770           Bindata_st=TIMEDATE
1780           OUTPUT Test_set;"FETCh:PCALibration:SAMPle:AMPLitude:BINary?"
1790           ENTER Test_set;Amplbin$
1800           OUTPUT Test_set;"FETCh:PCALibration:SAMPle:PHASe:BINary?"
1810           ENTER Test_set;Phasbin$
1820           Bindata_tm=TIMEDATE-Bindata_st
1830           PRINT "      Elapsed BINARY  data retrieve time = ";Bindata_tm;" seconds"
1840           PRINT ""
1850                                 !
1860                 !****Fetch DECIMAL PAvT integrity indicator and sample count****!
1870                 !**** (same for both the DECIMAL and BINARY methods)
1880                 !   [note that these data cannot be retrieved in binary format]
1890                 !---------------------------------------------------------------!
1900           OUTPUT Test_set;"FETCh:PCAL:SAMPle:COUNt?"
1910           ENTER Test_set;Result_count
1920               ! Number of results for amplitude and phase pairs (integer value)
1930           PRINT "Number of measured amplitude and phase pairs = ";Result_count
1940           OUTPUT Test_set;"FETCh:PCAL:INTegrity?"
1950           ENTER Test_set;Integrity
1960            ! Read PAvT measurement integrity from the Test Set.
1970           PRINT "Integrity value =";Integrity
1980           PRINT ""
1990           PRINT ""
2000             IF Integrity<>0 THEN
2010               ! If measurement integrity does not equal zero, there is an error.
2020              PRINT "Measurement Error; Integrity Value = ";Integrity
2030              PRINT ""
2040             ELSE
2050              END IF
2060           !
2070         !****For illustration: prints the first 100 samples
2071         !values from DECIMAL ampl&phase. array.****!
2072         !-------------------------------------------------------------------------!
2073          !
2074           FOR N=0 TO 999
2075             Dynamic_mkr=(N*17)
2076             !Set up a marker that will jump to each comma in the ascii string
2077             Amplit1(N)=VAL(Amplit1$[Dynamic_mkr+1,Dynamic_mkr+16])
2078             Phase1(N)=VAL(Phase1$[Dynamic_mkr+1,Dynamic_mkr+16])
2079             !Convert ascii to a numeric value
2080           NEXT N
2081 !
2082 !
2083          PRINT "Results below are compared to the Reference Measurement Data above."
2084          PRINT
2085           !
2086          PRINT "Sample Number          Power                   Phase        "
2087          PRINT "                       in dBm                  Difference   "
2088          PRINT "                                               in degrees   "
2089          PRINT "------------------------------------------------------------"
2090           !
2091          FOR I=0 TO 99    ! Reads and prints the results arrays, for illustrate,
2092                           ! we have chooese the first 100 pairs.
2093                              !
2094            PRINT I+1,"            ",Amplit1(I),"        ",Phase1(I)
2095             NEXT I
2096            !
2097            !
2140           DEALLOCATE Phase1$,Amplit1$,Phase2$,Amplit2$,Phase3$,Amplit3$
2141           DEALLOCATE Amplit1(*),Phase1(*)
2150           ! Releases computer memory allocated for decimal arrays
2151               !
2240           DEALLOCATE Phasbin$,Amplbin$
2250                ! Releases PC memory allocated for binary arrays
2260           !
2270               !****End of program****!
2290               !----------------------!
2300          OUTPUT Test_set;"INIT:PCAL:OFF"
2310          ! Turns off the PAvT measurement at the end of the program
2320          END
2330           !
2340  Timeout: SUB Timeout
2350                     PRINT "Program timeout!!"
2360                     CLEAR 7       ! Clears the PC's GPIB interface (at select code 7)
2370                     CLEAR 714       ! Clears the Test Set GPIB interface
2380                 SUBEND

Returned Values

Once you have clicked the Click to run PAvT button on the GUI, this program displays following values:

  • Amplitude Results -This field displays two columns: the sample number in square brackets (starting at zero), followed by the corresponding Amplitude result for that sample. The length of these columns is determined by the measurement count.
  • Phase Results -This field also displays two columns: the sample number in square brackets (starting at zero), followed by the corresponding Phase result for that sample. The length of these columns is determined by the measurement count.

Related Topics

Phase and Amplitude versus Time Measurement Description

Programming a Phase and Amplitude vs. Time Measurement (CONTinuous Waveform)

Programming a Phase and Amplitude vs. Time Measurement (CONT2 Waveform)

SETup:PCALibration

FETCh:PCALibration


Programming a Phase and Frequency Error Measurement

Programming a Phase and Frequency Error Measurement

This section contains two programming examples:

  • Programming a Phase and Frequency Error Measurement for GSM
  • Programming a Phase and Frequency Error Measurement for GPRS and EGPRS

Programming a Phase and Frequency Error Measurement for GSM

This section provides an example of how to make the phase and frequency error (PFER) measurement via GPIB.

The following procedure assumes that an active link is established between the test set and the mobile station. See Establishing an Active GSM Link with the Mobile Station .

  1. Configure PFER measurement parameters using the SETup subsystem.
  2. Start the PFER measurement using the INITiate subsystem.
  3. Use the FETCh? command to obtain PFER measurement results.

Programming Example

10  OUTPUT 714;"SETUP:PFERROR:CONTINUOUS OFF" !Configures a PFER measurement to
20                                            !single trigger mode.
30  OUTPUT 714;"SETUP:PFERROR:COUNT:NUMBER 100" !Configures a multi-measurement
40                                             !of 100.
50  OUTPUT 714;"SETUP:PFERROR:TRIGGER:SOURCE AUTO"!Configure trigger source
60                                                !to auto.
70  OUTPUT 714;"SETUP:PFERROR:SYNC MIDAMBLE" !Configures a PFER measurement so
80                                           !that burst synchronization, which
90                                           !will synchronize the timing of the
100                                          !measurement algorithm relative to
110                                          !the data sample, will be set
120                                          !to midamble.
130 OUTPUT 714;"INITIATE:PFERROR" !Starts the PFER measurement.
140 OUTPUT 714;"FETCH:PFERROR:ALL?"
150 ENTER 714;Integrity, Max_phase_err, Max_peak_error, Worst_freq_err
160 END

Returned values

The measurements returned by this program are:

  • Integrity returns the measurement Integrity Indicator (0 means a successful measurement with no errors).

  • Max_phase_err returns the maximum rms phase error in degrees

  • Max_peak_phase_error returns the maximum peak phase error in degrees

  • Worst_freq_err returns the frequency, in Hz, that is the furthest from zero, if the most positive and the most negative frequency error are the same value, the most positive will be returned.

Related Topics

Phase and Frequency Error Measurement Description

SETup:PFERror

INITiate

FETCh:PFERror

GSM/GPRS Control Program Example

Programming a Phase and Frequency Error Measurement for GPRS and EGPRS

This section provides an example of how to make the phase and frequency error (PFER) measurement via GPIB.

When using the PFER measurement with an EGPRS mobile, you can select a modulation coding scheme which uses either GMSK or 8PSK modulation. For more details on setting the modulation coding scheme, see

CALL:(PDTCH|PDTChannel):MCSCheme .

The following procedure assumes that a GPRS data connection has been established between the test set and the mobile station (connection status is Transferring). See Step 4: Make a Connection .

  1. Set the multislot configuration to two downlinks, two uplinks (D2U2) and set the uplink power control level for each of the two bursts using the CALL subsystem.
  2. Configure PFER measurement parameters using the SETup subsystem.
  3. Use the CALL:(PDTCH|PDTChannel):MSLot:MEASurement:BURSt command to select burst 1 for the first PFER measurement.
  4. Start the PFER measurement using the INITiate subsystem.
  5. Use the FETCh? command to obtain PFER measurement results.
  6. Use the CALL:(PDTCH|PDTChannel):MSLot:MEASurement:BURSt command to select burst 2 for the second PFER measurement.
  7. Repeat steps 4 to 6 above to perform a PFER measurement on burst 2 of the multislot configuration.

Programming Example

10  OUTPUT 714;"CALL:PDTCH:MSLOT:CONFIG D2U2" ! Configures the multi-
20                                            ! slot configuration to be
30                                            ! 2 downlink, 2 uplink.
40  OUTPUT 714;"CALL:PDTCH:MS:TXLEVEL:BURST 9" ! Sets the uplink power for
50                                             ! burst 1 to 25 dBm.
60  OUTPUT 714;"CALL:PDTCH:MS:TXLEVEL:BURST2 6" ! Sets the uplink power for
70                                              ! burst 2 to 31 dBm.
80  OUTPUT 714;"SETUP:PFERROR:CONTINUOUS OFF" !Configures a PFER measurement to
90                                            !single trigger mode.
100 OUTPUT 714;"SETUP:PFERROR:COUNT:NUMBER 100" !Configures a multi-measurement
110                                             !of 100.
120 OUTPUT 714;"SETUP:PFERROR:TRIGGER:SOURCE AUTO" !Configure trigger source
130                                                !to auto.
140 OUTPUT 714;"SETUP:PFERROR:SYNC MIDAMBLE" !Configures a PFER measurement so
150                                          !that burst synchronization, which
160                                          !will synchronize the timing of the
170                                          !measurement algorithm relative to
180                                          !the data sample, will be set
190                                          !to midamble.
200 OUTPUT 714;"CALL:PDTCH:MSLOT:MEASUREMENT:BURST 1" ! Perform first PFER
210                                                   ! measurement on burst 1.
220 OUTPUT 714;"INITIATE:PFERROR" !Starts the first PFER measurement.
230 OUTPUT 714;"FETCH:PFERROR:ALL?"
240 ENTER 714;Integrity1,Max_phase_err1,Max_peak_err1,Worst_freq_err1
250 OUTPUT 714;"CALL:PDTCH:MSLOT:MEASUREMENT:BURST 2" ! Perform next PFER
260                                                   ! measurement on burst 2.
270 OUTPUT 714;"INITIATE:PFERROR" !Starts the next PFER measurement.
280 REPEAT
290    OUTPUT 714;"INITIATE:DONE?"
300    ENTER 714;Meas_complete$
310 UNTIL Meas_complete$="PFER"
320 OUTPUT 714;"FETCH:PFERROR:ALL?"
330 ENTER 714;Integrity2,Max_phase_err2,Max_peak_err2,Worst_freq_err2
340 END

Returned values

This program instructs the test set to make two sets of PFER measurements, the first on burst 1 in the multislot configuration and the second on burst 2. The results returned by this program are:

  • Integrity1 returns the measurement Integrity Indicator (0 means a successful measurement with no errors) for burst 1.

  • Max_phase_err1 returns the maximum rms phase error in degrees for burst 1.

  • Max_peak_err1 returns the maximum peak phase error in degrees for burst 1.

  • Worst_freq_err1 returns the frequency, in Hz, that is the furthest from zero for burst 1. If the most positive and the most negative frequency error are the same value, the most positive is returned.

  • A similar set of results are returned for burst 2 ( Integrity2 , Max_phase_err2 , Max_peak_err2 and Worst_freq_err2 ).

Related Topics

Phase and Frequency Error Measurement Description

SETup:PFERror

INITiate

FETCh:PFERror

GSM/GPRS Control Program Example

Confidence Levels


Programming a Power versus Time Measurement

Programming a Power versus Time Measurement

This section contains two programming examples:

  • Programming a Power versus Time Measurement for GSM
  • Programming a Power versus Time Measurement for GPRS and EGPRS

Programming a Power versus Time Measurement for GSM

This section provides an example of how to make the power versus time (PvT) measurement via GPIB.

The following procedure assumes that an active link is established between the test set and the mobile station. See Establishing an Active GSM Link with the Mobile Station .

  1. Configure PvT measurement parameters using the SETup subsystem.
  2. Start the PvT measurement using the INITiate subsystem.
  3. Use the FETCh? command to obtain PvT measurement results.

Programming Example

10  OUTPUT 714;"SETUP:PVTIME:CONTINUOUS OFF" !Configures a PvT measurement to
20                                           !single trigger mode.
30  OUTPUT 714;"SETUP:PVTIME:COUNT:NUMBER 100 !Configures a multi-measurment
40                                            !of 100.
50  OUTPUT 714;"SETUP:PVTIME:TRIGGER:SOURCE AUTO" !Configure trigger source
60                                                !to auto.
65 OUTPUT 714;"SETUP:PVTIME:BURST:CAPTURE SINGLE" !Configure Burst Capture Range
70  OUTPUT 714;"SETUP:PVTIME:SYNC MIDAMBLE" !Configures a PvT measurement so
80                                           !that burst synchronization, which
90                                           !will synchronize the time of the
100                                          !measurement algorithm relative to
110                                          !the data sample, will be set
120                                          !to midamble.
130 OUTPUT 714;"SETUP:PVTIME:TIME:OFFSET -28US,-18US" !Turns on time markers
140                                                  !-28 and -18 microseconds.
150 OUTPUT 714;"INITIATE:PVTIME" !Start PvT measurement.
160 OUTPUT 714;"FETCH:PVTIME:ALL?" !PvT results for time measurements.
170 	ENTER 714;Integrity,Pvt_mask, Pvt_power, Max_offset1, Max_offset2
180 END

Returned values

The measurements returned by this program are:

  • Integrity returns the measurement Integrity Indicator (0 means a successful measurement with no errors).

  • Pvt_mask returns the mask pass/fail indicator. When the multi-measurement count is greater than 1, the PvT mask pass/fail result will return Fail (1) if any single measurement fails.

  • Pvt_power returns the PvT carrier power in dBm.
  • Max_offset1 and Max_offset2 return the maximum offset levels in dB, relative to the PvT carrier power at the two offsets.

Related Topics for GSM

Power versus Time Measurement Description

SETup:PVTime

INITiate

FETCh:PVTime

GSM/GPRS Control Program Example

Programming a Power versus Time Measurement for GPRS and EGPRS

This section provides an example of how to make the power versus time (PvT) measurement via GPIB.

When using the Power versus Time measurement with an EGPRS mobile, you can select a modulation coding scheme which uses either GMSK or 8PSK modulation. For more details on setting the modulation coding scheme, see

CALL:(PDTCH|PDTChannel):MCSCheme .

The following procedure assumes that the Operating Mode has been set to Active Cell (using CALL:OPERating:MODE ) and the data connection type has been set to ETSI Type B (using CALL:FUNCtion:CONNection:TYPE ). In addition, it is assumed that a data connection has been established between the test set and the mobile station (connection status is Transferring). See Step 4: Make a Connection .

  1. Set the multislot configuration to two downlinks, two uplinks (D2U2) and set the uplink power control level for each of the two bursts using the CALL subsystem.
  2. Configure PvT measurement parameters using the SETup subsystem.
  3. Set the trigger type to single using the SETup subsystem.
  4. Set the Burst Capture Range to single using SETup subsystem.

    Note that if you want to measure more than 2 uplink bursts simultaneously, you should set the Burst Capture Range to ALL .

  5. Start the PvT measurement using the INITiate subsystem.
  6. Use the FETCh? commands to obtain PvT measurement results.

Programming Example

10  OUTPUT 714;"CALL:PDTCH:MSLOT:CONFIG D2U2" ! Configures the multislot
20                                            ! configuration to be
30                                            ! 2 downlink, 2 uplink.
40  OUTPUT 714;"CALL:PDTCH:MS:TXLEVEL:BURST1 10" ! Sets the uplink power for
50                                               ! the first burst to 23 dBm.
60  OUTPUT 714;"CALL:PDTCH:MS:TXLEVEL:BURST2 5" ! Sets the uplink power for
70                                              ! the second burst to 33 dBm.
80  OUTPUT 714;"SETUP:PVTIME:CONTINUOUS OFF" !Configures a PvT measurement to
90                                           !single trigger mode.
100 OUTPUT 714;"SETUP:PVTIME:COUNT:NUMBER 100" !Configures a multi-measurement
110                                            !of 100.
120 OUTPUT 714;"SETUP:PVTIME:TRIGGER:SOURCE AUTO" !Configure trigger source

130                                               !to auto.
135 OUTPUT 714;"SETUP:PVTIME:BURST:CAPTURE SINGLE" !Configure Burst Capture Range.
140 OUTPUT 714;"SETUP:PVTIME:SYNC MIDAMBLE" !Configures a PvT measurement so
150                                         !that burst synchronization, which
160                                         !will synchronize the time of the
170                                         !measurement algorithm relative to
180                                         !the data sample, will be set
190                                         !to midamble.
200 OUTPUT 714;"INITIATE:PVTIME" !Start PvT measurement.
210 ! Fetch all the required PvT results.
220 OUTPUT 714;"FETCH:PVTIME:BURST1:INTEGRITY?" ! Always check integrity values.
230 ENTER 714;Integ_burst1
240 OUTPUT 714;"FETCH:PVTIME:BURST2:INTEGRITY?"
250 ENTER 714;Integ_burst2
260 IF (Integ_burst1=0) AND (Integ_burst2=0) THEN
270    OUTPUT 714;"FETCH:PVTIME:MASK?" !PvT pass/fail result for entire mask
280    ENTER 714;Mask_result
290    OUTPUT 714;"FETCH:PVTIME:MASK:SEGMENT?" ! PvT mask error code. This will
300                                            ! tell us which parts of the
310                                            ! uplink has failed the mask.
320    ENTER 714;Mask_error_code
330    OUTPUT 714;"FETCH:PVTIME:BURST1:POWER:AVERAGE?" ! PvT Carrier Power result
340                                                    ! for the first burst.
350    ENTER 714;Pvt_pwr_burst1
360    OUTPUT 714;"FETCH:PVTIME:BURST2:POWER:AVERAGE?" ! PvT Carrier Power result
370                                                    ! for the second burst.
380    ENTER 714;Pvt_pwr_burst2
390  ELSE
400    PRINT "Measurement error: "&Meas_complete$
410    PRINT "Measurement Integrity value for burst 1 = ";Integ_burst1
420    PRINT "Measurement Integrity value for burst 2 = ";Integ_burst2
430  END IF
440 END

Returned values

The measurements returned by this program are:

  • Integ_burst1 and Integ_burst2 return the measurement integrity values for each of the two adjacent uplink bursts in the multislot configuration (0 means a successful measurement with no errors). See Integrity Indicator .

  • Mask_result returns the mask pass/fail indicator for the entire mask, not an individual burst. When the multi-measurement count is greater than 1, the PvT mask pass/fail result will return Fail (1) if any single measurement fails.

  • Mask_error_code returns the mask error code for the entire multislot configuration. For more details on how to interpret the value returned by this result, see FETCh:PVTime:MASK[:FAIL]:SEGment? .

  • Pvt_pwr_burst1 and Pvt_pwr_burst2 return the PvT carrier power results in dBm for each of the bursts in the multislot configuration.

Related Topics for GPRS and EGPRS

Power versus Time Measurement Description

SETup:PVTime

INITiate

FETCh:PVTime

GSM/GPRS Control Program Example


Programming a RACH Measurement

Programming a RACH Measurement

This section provides an example of how to make a power versus time measurement on a RACH. The same principles as used in this example can also be used for transmit power and phase and frequency error measurements.

Overview of Measurement Procedure

  1. Ensure that the mobile is switched off.
  2. Set the test set's measurement receiver to the frequency the RACH will arrive on. The simplest way to do this is to set the manual channel (that is, the expected ARFCN) to the ARFCN of the BCH. Alternatively you could set the expected frequency to the uplink frequency of the BCH ARFCN.
  3. Set triggering to single.
  4. Set trigger mode to Auto.

Once the RACH measurement is completed, in order to make further measurements on the TCH, ensure you reset the receiver control to Auto.

Only one measurement at a time can be made on the RACH even if two measurements are initiated.

Programming Example

The following example details how to make a power versus time RACH measurement on a mobile originated call in Active Cell mode.

Alternatively, the same measurement could be made on a base station originated call by replacing lines 160 and 170 with the CALL:ORIGinate command.

10    INTEGER Int
20    DIM Results(11)
30    REAL Mask,Power
40    OUTPUT 714;"*RST"
50    OUTPUT 714;"RFANALYZER:MANUAL:CHANNEL:SELECTED 20" !Configures the
60                       !test set to expect a transmission on ARFCN 20.
70    OUTPUT 714;"RFANALYZER:EXPECTED:POWER:SELECTED 10 DBM" !Configures
80                      !the test set to expect a power level of 10 dBm.
90    OUTPUT 714;"SETUP:PVTIME:CONTINUOUS OFF"  !Configures trigger
100                       !mode to single for a pvt measurement.
110   OUTPUT 714;"SETUP:PVTIME:COUNT:STATE OFF"  !Configures the
120   !multi_measurement state to OFF.
130   OUTPUT 714;"SETUP:PVTIME:TRIGGER:SOURCE AUTO" !Configures the
140                                             !trigger source to AUTO.
150   OUTPUT 714;"INITIATE:PVTIME" !Start a pvt measurement.
160   PRINT "Connect your mobile to the Test Set and initiate a call"
170   PRINT "from the mobile."
180   OUTPUT 714;"FETCH:PVTIME:ALL?"!Fetches the measurement integrity
190   !value, mask indicator, tx power, and pvt offsets.
200   ENTER 714;Int,Mask,Power,Results(*)
210   PRINT "****************************************"
220   PRINT "*Power vs Time RACH Measurement Results*"
230   PRINT "****************************************"
240   PRINT "Integrity = ";Integrity
250   PRINT "Mask = ";Mask
260   PRINT "Carrier Power =";Power
270   PRINT "Offset        Level (dB)"
280   PRINT "(micro sec)   (dB)"
290   PRINT "-------       ----------"
300   PRINT "-28            ";Results(0)
310   PRINT "-18            ";Results(1)
320   PRINT "-10            ";Results(2)
330   PRINT "0              ";Results(3)
340   PRINT "321.2          ";Results(4)
350   PRINT "331.2          ";Results(5)
360   PRINT "339.2          ";Results(6)
370   PRINT "349.2          ";Results(7)
380   PRINT "542.8          ";Results(8)
390   PRINT "552.8          ";Results(9)
400   PRINT "560.8          ";Results(10)
410   PRINT "570.8          ";Results(11)
420   EN

Related Topics

RACH Measurement Description

RACH Troubleshooting


Programming a SINAD Measurement

Programming a SINAD Measurement

This measurement is not applicable to GPRS or EGPRS.

This section provides an example of how to make a SINAD measurement via the GPIB. SINAD measurements are not typically made when testing GSM mobiles but are more common when testing AMPS or other analog mobiles. The programming example below is typical for a 136 mobile.

SINAD and Distortion measurements are affected by the same STATe and INITiate commands, so both measurements are enabled and triggered at the same time. However, measurement results are queried separately. See Analog Audio Measurement Description .

The following procedure assumes that the mobile's audio output is connected to the AUDIO IN connectors and the mobile is on an analog voice channel (AVC) that is being modulated with a 1004 Hz tone at +/-8 kHz peak deviation. It is also assumed that the Cell Power from the test set is set to a minimum usable level (typically about -116 dBm).

  1. Configure analog audio measurement parameters using the SETup subsystem.
  2. Start the analog audio measurement using the INITiate subsystem.
  3. Use the FETCh? subsystem to obtain analog audio measurement results.

Programming Example

10  OUTPUT 714;"SETup:AAUDio:CONTinuous OFF" !Set the analog audio
20                                           !measurements to single trigger mode.
30  OUTPUT 714;"SETup:AAUDio:EXPected:VOLTage 3V" !Set the Expected Amplitude level for
40                                                !audio input voltage in Vpeak.
50  OUTPUT 714;"SETup:AAUDio:SDIStortion:STATe ON" !Turn on the SINAD and
60                                                  !distortion measurements.
70  OUTPUT 714;"SETup:AAUDio:SDIStortion:FREQuency 1004 HZ" !Specify the audio
80                                      !frequency to use for the measurements.
90  OUTPUT 714;"SETup:AAUDio:FILTer:TYPE CMESsage" !Select the c-message filter.
100 OUTPUT 714;"SETup:AAUDio:DEMPhasis:STATe OFF" !Turn off de-emphasis.
110 OUTPUT 714;"SETup:AAUDio:EXPANDOR:STATe OFF" !Turn off the expandor.
120 OUTPUT 714;"SETup:AAUDio:TIMeout 3S" !Set a timeout value of 3 seconds
130                                      !in case the measurement cannot be made.
140 OUTPUT 714;"INITiate:AAUDio" !Start the Analog Audio measurement.
150 OUTPUT 714;"FETCh:AAUDio:INTegrity?" !Query the integrity indicator to
160                           !verify that a reliable measurement was made.
170 ENTER 714;Integrity  !Enter the returned value into a variable for comparison
180                      !with possible integrity indicator values (not shown here).
190 IF Integrity=0 THEN !Only fetch measurement result if integrity indicator is 0.
200  OUTPUT 714;"FETCh:AAUDio:SINad?" !Fetch the SINAD result.
210  ENTER 714;Sinad  !Enter the returned value into a variable.
220 END IF
230 END

Returned Values

The results returned by this program are:

  • Integrity returns the integrity indicator (0 means a successful measurement with no errors). See Integrity Indicator .
  • SINAD returns the SINAD value in dB.

Related Topics

Analog Audio Measurement Description

Analog Audio Troubleshooting

INITiate

SETup:AAUDio

FETCh:AAUDio


Programming the Spectrum Monitor Calibration

Programming the Spectrum Monitor Calibration

This section provides an example of how to run the Spectrum Monitor Calibration via the GPIB.

The following procedure assumes the PC running this program is connected to the test set via the GPIB port.

  1. Remove any RF power source from the RF IN/OUT connector of the test set.
  2. Initiate the Spectrum Monitor Calibration.
  3. Wait for the Spectrum Monitor Calibration to complete (50-60 seconds).
  4. Retrieve the Spectrum Monitor Calibration status. (The calibration completed successfully if the status is 0.)

Example Spectrum Monitor Program

10     COM Name1$[30],Rev1$[30]! Set string variable lengths
20     ON TIMEOUT 7,15 CALL Timeout
30                       !Timeout protection subroutine; after 15 seconds of inactivity, the
40                       ! program stops and clears the GPIB bus (so the GPIB bus doesn't hang)
50                       !
60     OUTPUT 714;"syst:appl?"! Query which TA or LA firmware is active on the E5515
70     ENTER 714;Name1$
80     PRINT "Active Test or Lab Application = ";Name1$
90     PRINT "  The TA or LA listed above should be `GSM/GPRS Mobile Test' or similar."
100     OUTPUT 714;"syst:appl:rev?"! Query which revision of TA or LA is active
110     ENTER 714;Rev1$
120     PRINT ""
130     PRINT "TA or LA Revision = ";Rev1$
140     PRINT ""
150     PRINT " Remove any RF power source from the RF IN/OUT connector of the Test Set;"
160     PRINT "  then press the CONTINUE key on this PC"
170     PAUSE
180     OUTPUT 714;"cal:smon?"
190     WAIT 60       ! Wait about 50 to 60 seconds to ensure calibration is finished
200                    ! before retrieving cal status; this wait time should be checked with
210                    ! your program/PC/test system to verify sufficient wait time is allowed
220     ENTER 714;Smonstat       ! Retrieve the Spectrum Monitor Calibration Status
230     PRINT ""
240     PRINT "Spectrum analyzer calib. successful if result is zero.  Result = ";Smonstat
250     PRINT ""
260     PRINT " "
270     !
280     !
290     END
300  Timeout: SUB Timeout
310                PRINT "Program timeout!!"
320                CLEAR 7
330                CLEAR 714
340                SUBEND

Returned Values

The program example above returns:

  • Active Test Application
  • TA or LA Revision of your application.
  • Result (0 is successful)

Related Topics

Programming the Spectrum Monitor


Programming the Spectrum Monitor

Programming the Spectrum Monitor

This section provides an example of how to use the Spectrum Monitor via the GPIB.

The following procedure assumes that the mobile station's antenna output is connected to the RF IN/OUT connector, and that the mobile station is transmitting an uplink signal.

  1. Configure the Spectrum Monitor parameters using the SETup subsystem.
  2. Start the Spectrum Monitor using the INITiate subsystem.
  3. Use the INITiate:DONE? command to determine if Spectrum Monitor results are available.
  4. Use the FETCh? commands to obtain Spectrum Monitor results.
  5. Use the CALCulate commands to set and query the Spectrum Monitor markers.

Programming Example

10       REAL Amplitudes(400)
20       ! Set up array to hold 401 amplitude results (trace data)
30       OUTPUT 714;"SETUP:SMONITOR:CONTINUOUS OFF"!Configures the Spectrum Monitor to
40                                                !single trigger mode.
50       OUTPUT 714;"SETUP:SMONITOR:COUNT:NUMBER 20"!Configures a multi-measurement
60                                                  !of 20.
70       OUTPUT 714;"SETUP:SMONITOR:TRIGGER:SOURCE IMMEDIATE"!Configure trigger source
80                                                     !to immediate.
90       OUTPUT 714;"SETUP:SMONITOR:FREQUENCY:SPAN 20 MHz"!Set frequency span
100       OUTPUT 714;"SETUP:SMONITOR:BWIDth:MANUAL 300 KHZ"!Decouples the frequency span
110                     ! and the resolution bandwidth, and sets the resolution bandwidth.
120       OUTPUT 714;"INITIATE:SMONITOR"!Start the Spectrum Monitor
130     !
140       OUTPUT 714;"FETCH:SMONITOR:INTEGRITY?"!Fetch SMON Integrity
150       ENTER 714;Integrity
160       PRINT "Spectrum Monitor Integrity: ";Integrity
170       IF Integrity=0 THEN                  !Fetch results if SMON
180           OUTPUT 714;"FETCH:SMONITOR:TRACE?"!has valid integrity.
190           ENTER 714;Integrity,Amplitudes(*)!Load valid results into array
200           PRINT "Trace Data Amplitude Results (dB):"
210           PRINT "--------------------------------------------------"
220           PRINT Amplitudes(*) !Prints the 401 stored data points.
230           PRINT "--------------------------------------------------"
240       ELSE
250           PRINT "Bad Integrity value =";Integrity
260           STOP
270       END IF
280     ! Move the marker to the signal peak and query the frequency and level
290       OUTPUT 714;"CALCULATE:SMONITOR:MARKER1:PEAK:MAXIMUM"
300       OUTPUT 714;"CALCULATE:SMONITOR:MARKER1:FREQUENCY?"
310       ENTER 714;Peak_frequency
320       PRINT "Maximum Peak Frequency (MHz): ";Peak_frequency
330       OUTPUT 714;"CALCULATE:SMONITOR:MARKER1:AMPLITUDE?"
340       ENTER 714;Peak_amplitude
350       PRINT "Maximum Peak Amplitude (dBm): ";Peak_amplitude
360       END

Returned Values

The results returned by this program are:

  • Integrity returns the Spectrum Monitor Integrity Indicator (0 means that the Spectrum Monitor completed with no errors).
  • Amplitudes() returns 401 points representing the amplitude results (in dBm) of the trace data.
  • Peak_frequency returns the frequency in MHz at marker 1. In this case, marker 1 is positioned at the highest peak value.
  • Peak_amplitude returns the amplitude in dBm at marker 1. In this case, marker 1 is positioned at the highest peak value.

Related Topics

Spectrum Monitor Description

SETup:SMONitor

INITiate

FETCh:SMONitor

CALCulate:SMONitor


Statistical Measurement Results

Statistical Measurement Results

Description

Most measurements have a setup window that provides for the entry of a multi-measurement count value. This specifies how many measurements the test set will perform to obtain a set of values from which to calculate the following statistical measurement results:

  • Average (arithmetic mean) of measurement set
  • Minimum value from measurement set
  • Maximum value from measurement set
  • Standard Deviation of measurement set

Operating Considerations

The advantages of using the multi-measurement feature to obtain statistical measurement data include: reduced time associated with GPIB bus traffic, and reduced time configuring hardware. This is because the number of measurements specified in the multi-measurement count value are performed during one measurement cycle.

Programming Example

OUTPUT 714;"SETup:TXPower:COUNt:SNUMber 10" !Enters a TX Power multi-measurement count
                                      !value of 10, and turns the TX Power
                                      !multi-measurement state on.

Related Topics

Measurement Progress Report


Status Subsystem Overview

Status Subsystem Overview

The following pages present an overview of the entire status subsystem, including applications which may or may not be loaded in your test set.

Description

Overview of STATus Reporting Structure

Status Reporting Structure For STATus QUEStionable Registers

Status Reporting Structure For STATus OPERation Registers

Status Reporting Structures for the COMMon Registers

Status Reporting Structure for the SMService Register

Status Reporting Structure for the GSM Registers

Status Reporting Structure For the GPRS Registers

Status Reporting Structure for the AMPS Registers

Status Reporting Structure for the DIGital136 Registers

Status Reporting Structures for the TA136 Registers

Status Reporting Structure for the DIGital95 Registers

Status Reporting Structure for the DIGital 2000 Registers

Status Reporting Structure for the CDMA Registers

Status Reporting Structure for the TA 2000 Registers

Status Reporting Structure for the FDD Registers

Status Reporting Structure for the WCDMA Registers

Status Reporting Structure For the TA856 Registers

Status Reporting Structure for the DIGital856 Registers

Status Data Structure - Register Model

The generalized status register model consists of a Condition Register, Transition Filters, an Event Register, an Enable Register, and a Summary Message Bit.

Condition Register

A condition is a test set state that is either TRUE or FALSE (a GPIB command error has occurred or a GPIB command error has not occurred). Each bit in a Condition Register is assigned to a particular test set state. A Condition Register continuously monitors the hardware and firmware states assigned to it. There is no latching or buffering of any bits in a Condition Register; it is updated in real time. Condition Registers are read-only. Condition Registers in the test set are 16 bits long and may contain unused bits. All unused bits return a zero value when read.

Transition Filters

In the test set, the Transition Filters are implemented as two registers: a 16-bit positive transition (PTR) register and a 16-bit negative transition (NTR) register.

For each bit in the Condition Register, a Transition Filter bit determines the state transitions which will set a corresponding bit in the Event Register. Transition Filters may be set to pass positive transitions (PTR), negative transitions (NTR) or either (PTR or NTR). A positive transition refers to a condition bit which has changed from 0 to 1. A negative transition refers to a condition bit which has changed from 1 to 0.

A positive transition of a bit in the Condition register will be latched in the Event Register if the corresponding bit in the positive transition filter is set to 1. A positive transition of a bit in the Condition register will not be latched in the Event Register if the corresponding bit in the positive transition filter is set to 0.

A negative transition of a bit in the Condition register will be latched in the Event Register if the corresponding bit in the negative transition filter is set to 1. A negative transition of a bit in the Condition register will not be latched in the Event Register if the corresponding bit in the negative transition filter is set to 0. Either transition (PTR or NTR) of a bit in the Condition Register will be latched in the Event Register if the corresponding bit in both transition filters is set to 1. No transitions (PTR or NTR) of a bit in the Condition Register will be latched in the Event Register if the corresponding bit in both transition filters is set to 0.

Transition Filters are read-write.

Transition Filters are unaffected by a *CLS (clear status) command.

Transitions Filters are set to pass positive transitions (all 16 bits of the PTR register are set to 1 and all 16 bits of the NTR register are set to 0) at power on or after receiving the *RST (reset) command.

Event Register

The Event Register captures bit-state transitions in the Condition Register as defined by the Transition Filters. Each bit in the Event Register corresponds to a bit in the Condition Register. Bits in the Event Register are latched, and, once set, they remain set until cleared by a query of the Event Register or a *CLS (clear status) command. This guarantees that the application can't miss a bit-state transition in the Condition Register. There is no buffering; so while an event bit is set, subsequent transitions in the Condition Register corresponding to that bit are ignored. Event Registers are read-only. Event Registers in the test set are 16 bits long and may contain unused bits. All unused bits return a zero value when read.

Event Enable Register

The Event Enable Register defines which bits in the Event Register will be used to generate the Summary Message. Each bit in the Enable Register has a corresponding bit in the Event Register. The test set logically ANDs corresponding bits in the Event and Enable registers and then performs an inclusive OR on all the resulting bits to generate the Summary Message. By using the enable bits the application program can direct the test set to set the Summary Message to the 1 or TRUE state for a single event or an inclusive OR of any group of events. Enable Registers are read-write. Enable Registers in the test set are 16 bits long and may contain unused bits which correspond to unused bits in the associated Event Register. All unused bits return a zero value when read and are ignored when written to. Enable Registers are unaffected by a *CLS (clear status) command or queries.

Standard Event Status Register Model

Summary Message Bit

The Summary Message is a single-bit message which indicates whether or not one or more of the enabled events have occurred since the last reading or clearing of the Event Register. The test set logically ANDs corresponding bits in the Event and Enable registers and then performs an inclusive OR on all the resulting bits to generate the Summary Message. By use of the enable bits, the application program can direct the test set to set the Summary Message to the 1, or TRUE, state for a single event or an inclusive OR of any group of events.

The Summary Message is TRUE, logic 1, if the register contains some information and an enabled event in the Event Register is set TRUE.

The Summary Message is FALSE, logic 0, if the queue is empty and no enabled events are TRUE. Registers can be cleared by reading all the information from the queue. Registers can also be cleared using the *CLS (clear status) command.

Service Request Enabling Register Model

Status Byte Register

The Status Byte Register is an 8 bit register that provides single bit summary messages, each summary message summarizes and overlaying status data structure. Summary messages always track the current status of the associated status data structure. Service request enabling determines if one or more of the summary messages will generate a message. Device status reporting is defined in IEEE 488.2-1992, 11.1.

The Status Byte Register contains the STB and RQS (or MSS) messages from the test set. The Status Byte Register can be read with either a serial poll or the *STB? common query. The value for bit 6 is dependent on which method used.

When reading with a serial poll the status byte and the RQS message are returned as a single data byte. The RQS message indicates if the SRQ is TRUE. The Status Byte Register is not affected by a serial poll, the RQS is set to FALSE when polled.

The *STB? query allows you to read the status byte and the MSS. The response represents the sum of the binary weighted values of the Status Byte Register from bit 0-5 and 7.

The Master Summary Status (MSS) message from bit 6 indicates when there is at least one reason for requesting service.

The Message Available (MAV) summary message from bit 4 is TRUE when there is a message is in the output queue.

The Status Byte Register is cleared with the *CLS common command. The output queue and the MAV are not affected by the *CLS command.

Service Request Enable Register

The Service Request Enable Register is an 8 bit register that enables corresponding summary messages in the Status Byte Register. Enabling the service request with the *SRE command allows you to choose which bits in the Status Byte Register will trigger a service request.

The Service Request Enable Register is read with the *SRE? query. The returned value is the sum of the binary weighted values of the Service Request Enable Register, with a range of 0 through 63 or 128 through 191.

The value of the unused bit 6 will always be zero.

System Synchronization Bit

Bit 12 of the status operation condition register is "pulsed" when the SYSTem:SYNChronized command is sent. This allows the status system to indicate that:

  • the input buffer is synchronized to the point where this command is parsed
  • all prior sequential commands are completed
  • all prior overlapped commands have started

Related Topics

STATus Subsystem Description


Call Processing Event Synchronization

Call Processing Event Synchronization

Description

Using the call processing subsystem overlapped command synchronization commands, you can query the test set to find out when an overlapped command operation is done (:DONE?, :OPC?), force the test set to not execute any more commands until an overlapped command operation has completed (:WAIT), or simply force an overlapped command to behave as a sequential command (:SEQ).

Pending Operation Flags

Associated with each overlapped command, the test set maintains a binary indicator known as a pending operation flag. A pending operation flag is set true when the operation started by the overlapped command is executing, and is set false when the operation is no longer executing.

NOTE
In addition to the call processing subsystem overlapped commands, the test set also provides the measurement-related INITiate <measurement> overlapped commands.

Call Processing Subsystem Overlapped Command Synchronization Commands

Overlapped Commands
Command Purpose Of Command

Example

:DONE?

Returns a 0 if the associated command's pending operation flag is true, or a 1 if it is false.

10 OUTPUT 714;"CALL:TCH 65"
20 OUTPUT 714;"SETUP:TXP:CONT OFF"
30 OUTPUT 714;"SETUP:PFER:CONT OFF"
40 REPEAT
50 OUTPUT 714;"CALL:TCH:DONE?"
60 ENTER 714;Process_done
70 UNTIL Process_done
80 OUTPUT 714;INIT:TXP;PFER"
90 END

The example shown is from the E1960A GSM test application. Commands the test set to perform a traffic channel handover and execute two setup commands. After the two setup commands have finished, the :DONE? command is used to find out if the handover is finished

:SEQuential

Forces an overlapped command to execute in a sequential manner. No subsequent commands will be executed until the pending operation flag for this operation is false.

OUTPUT 714;"CALL:TCH:SEQ 65"

The example shown is from the E1960A GSM test application. Commands the test set to perform a traffic channel handover and to not execute any more commands until the pending operation flag associated with the CALL:TCH command is false.

:WAIT

Forces the test set to wait until the associated command's pending operation flag is false before executing any more commands.

10 OUTPUT 714;"CALL:TCH 65"
20 OUTPUT 714;"SETUP:TXP:CONT OFF"
30 OUTPUT 714;"SETUP:PFER:CONT OFF"
40 OUTPUT 714;"CALL:TCH:WAIT"
50 OUTPUT 714;"INIT:TXP;PFER"
60 END

The example shown is from the E1960A GSM test application. Commands the test set to perform a traffic channel handover and execute two setup commands. After the two setup commands have finished, the :WAIT command is sent to prevent the test set from executing the INITiate command until the handover is finished.

:OPComplete?

Places a 1 in the test set's output queue when the associated command's pending operation flag goes false. Controlling program hangs on this query until the 1 is retrieved.

10 OUTPUT 714;"CALL:TCH 65"
20 OUTPUT 714;"SETUP:TXP:CONT OFF"
30 OUTPUT 714;"SETUP:PFER:CONT OFF"
40 OUTPUT 714;"CALL:TCH:OPC?"
50 ENTER 714;Op_complete
60 OUTPUT 714;"INIT:TXP;PFER"
70 END

The example shown is from the E1960A GSM test application. Commands the test set to perform a traffic channel handover and execute two setup commands. After the two setup commands have finished, the :OPC? command is sent to hang program execution until a 1 is put in the test set's output queue, satisfying the ENTER statement and allowing program execution to continue with the INITiate command.

Operating Considerations

When using the call processing subsystem overlapped command synchronization commands, check the conditions that set the operation's pending operation flag (POF) false to avoid unexpected results.

Call Processing Subsystem Overlapped Commands

Call Processing Command | Purpose Of Command | Pending Operation Flag (POF) is false when
CALL:ORIGinate See CALL:ORIGinate . | Performs a base station call origination. | The call processing state leaves the Idle state (when the operating mode is active cell), or The test set has noted this parameter change (when the operating mode is test mode).
CALL:END See CALL:END . | Performs a base station call termination. | The call processing state reaches the Idle state (when the operating mode is active cell), or The test set has noted this parameter change (when the operating mode is test mode).
CALL:CONNected:ARM[:IMMediate] See CALL:CONNected:ARM[:IMMediate] . | Arms the call control status change detector. | The call control status change detector has been disarmed. See Connected/Idle Query .

Related Topics

Call Processing State Synchronization


Data Connection Processing Event Synchronization

Data Connection Processing Event Synchronization

Description

Using the call processing subsystem overlapped command synchronization commands, you can query the test set to find out when an overlapped command operation is done (:DONE?, :OPC?), force the test set to not execute any more commands until an overlapped command operation has completed (:WAIT), or simply force an overlapped command to behave as a sequential command (:SEQ).

Pending Operation Flags

Associated with each overlapped command, the test set maintains a binary indicator known as a pending operation flag. A pending operation flag is set true when the operation started by the overlapped command is executing, and is set false when the operation is no longer executing.

In addition to the call processing subsystem overlapped commands, the test set also provides the measurement-related INITiate overlapped commands. For more details on these commands see INITiate .

Call Processing Subsystem Overlapped Command Synchronization Commands

Overlapped Commands
Command Purpose Of Command

Example

:DONE?

Returns a 0 if the associated command's pending operation flag is true, or a 1 if it is false.

OUTPUT 714;"CALL:DCON:ARM:DONE?"

This example queries whether the data connection state change detector has been successfully armed.

:SEQuential

Forces an overlapped command to execute in a sequential manner. No subsequent commands are executed until the pending operation flag for this operation is false.

OUTPUT 714;"CALL:FUNC:DATA:STAR:SEQ"

This example commands the test set to start a data connection. A data connection must be established before any GPRS or EGPRS measurements can be made. :SEQ ensures that no other commands are executed until the pending operation flag associated with the CALL:FUNCtion:DATA:STARt command is false.

:WAIT

Forces the test set to wait until the associated command's pending operation flag is false before executing any more commands.

OUTPUT 714;"CALL:DCON:ARM:WAIT?"

This example prevents the test set from executing the next command until the data connection state change detector has been armed.

:OPComplete?

Places a 1 in the test set's output queue when the associated command's pending operation flag goes false. Controlling program hangs on this query until the 1 is retrieved.

OUTPUT 714;"CALL:FUNC:DATA:STAR:OPC?"

This example hangs program execution until the :OPC query's until a 1 is placed in the test set's output queue.

Data Connection Processing Subsystem Overlapped Commands

Data Connection Processing Command | Purpose Of Command | Pending Operation Flag (POF) is false when
CALL:FUNCtion:DATA:STARt See CALL:FUNCtion:DATA:START . | Attempts to start the data connection. | The connection status is any non-transitory state (that is Idle, Attached or Transferring).
CALL:DCONnected:ARM[:IMMediate] See CALL:DCONnected:ARM[:IMMediate] . | Arms the data connection state change detector. | The data connection state change detector has been disarmed.

Related Topics

Data Connection Processing State Synchronization


Call Processing State Synchronization

Call Processing State Synchronization

Call Processing State Query

The CALL:STATus[:STATe]? query returns a string indicating the current call processing state.

There are five possible call processing states for GSM.

The query returns one of the following strings:

  • "IDLE"

    Idle is returned when the test set is not on a call, involved with any termination, page, origination, or registration call processing procedures with the mobile station.

  • "SREQ"

    Set Up Request is returned when the test set is in the process of assigning a channel to a mobile station as part of a Page or a mobile station originated call setup.

  • "ALER"

    Alerting is returned when the mobile station is about to receive an Alert message as part of a call setup due to a page.

  • "CONN"

    Connected is returned when the test set and the mobile station are connected on a call.

  • "DISC"

    Disconnected is returned when the test set is in the process of ending a call.

The following command returns the current state of a data connection:

OUTPUT 714;"CALL:STATus:STATe:DATA?"

Description

Connected/Idle Query

This query will determine if a call is connected or disconnected by returning an integer value. The value indicates if the call state is idle or connected, not if any call state change has occurred.

Query returns one of the following:

  • 0 = idle
  • 1 = connected

If the call is in the setup request, proceeding, alerting, or disconnecting state, this command will not return a value until the call status proceeds to either connected or idle.

OUTPUT 714;"CALL:CONNECTED:STATE?"

Base Station Originated Call - Using the Connected/Idle Query

The following example illustrates the use of the connected/idle query for a base station originated call. This code originates a call, then waits for the connected/idle query to return a result.

Note that this code does not include the CALL:CONNECTED:TIME (timeout timer) or the CALL:CONNECTED:ARM (change detector arm) commands. These commands are unnecessary since the change detector is armed automatically by the CALL:ORIGINATE command, and the timeout timer value is never applicable since a base station originated call guarantees a state change.

10    OUTPUT 714;"CALL:ORIGINATE" ! Begin the BS originated call.
20    OUTPUT 714;"CALL:CONNECTED:STATE?" ! The connect/idle query.
30    ENTER 714;Call_connected ! Program will hang here until state
40                             ! change or protocol timer expires.
50    !************************************************************
60    ! If mobile is not set to auto-answer, answer the call.
70    !************************************************************
80    IF NOT Call_connected THEN
90      DISP "CALL NOT CONNECTED."
100   ELSE
110     DISP "CALL IS CONNECTED."
120   END IF
130   END

Call State Change Detector

This feature provides a method for holding off the Connected/Idle Query results until a change in call processing states is detected. Arming the call state change detector is useful only for mobile station originated calls or disconnects only. It is armed automatically when call processing functions originating from the test set are requested.

The call state change detector becomes disarmed when any of the following conditions have been met:

  • the call processing state has changed to either connected or idle

    or...

  • the attempt to connect or disconnect a call has failed, and one of the test set's Fixed Timers has timed out

    or...

  • no call processing state changes occurred within the time period specified by the Call State Change Detector Timeout .

The following command arms the call state change detector:

OUTPUT 714;"CALL:CONNECTED:ARM[:IMMEDIATE]"

Mobile Station Originated Call - Arming the Change Detector

The following example illustrates the use of the call state change detector along with the connected/idle query to synchronize a controlling application with a call processing state change during a mobile station originated call.

When the CALL:CONNECTED:ARM command is received by the test set, the detector becomes armed and configures the test set to hold off on returning a result for the CALL:CONNECTED:STATE? query until the detector is disarmed by one of the three events described above.

10    OUTPUT 714;"CALL:CONNECTED:TIMEOUT 10S" ! Sets the time out
20                                            ! time to 10 seconds.
30    OUTPUT 714;"CALL:CONNECTED:ARM" ! Arm the change detector.
40    DISP "Make a mobile station orginated call. Continue when done."
50    PAUSE
60    OUTPUT 714;"CALL:CONNECTED:STATE?" ! The connected/idle query.
70    ENTER 714;Call_connected
80    IF Call_connected=1 THEN
90      DISP "Call is connected."
100     WAIT 2
110   ELSE
120     DISP "Call is not connected."
130     WAIT 2
140   END IF
150   END

Call State Change Detector Timeout

If a state change does not occur, the user needs a way to control how long to wait for the change detector. The change detector is disarmed by the timeout timer. After a timeout, the connected/idle query will return a 1 for connected or a 0 for idle. The timeout timer is user settable, but the user setting is only applied during mobile station originated call processing operations. For base station originated call processing operations, the timeout timer is automatically set to 60 seconds by the test set.

STATus:OPERation:CALL:GSM Status Register

The STATus subsystem provides a status register group that allows the user to query call processing states. Call processing state synchronization can be performed using the bit transitions of STATUS:OPERATION:CALL:GSM to generate interrupts to the external controller. Refer to STATus:OPERation:CALL:GSM Condition Register Bit Assignment for status bit definitions and GPIB command syntax. See Call State STATus:OPERation:CALL:GSM Program Example .

Call State STATus:OPERation:CALL:GSM Program Example

Generating a Service Request (SRQ) Interrupt - Dropped Call

The following example illustrates the use of the status subsystem to generate a service request when a call has been dropped.

10    OUTPUT 714;"*CLS"
20    OUTPUT 714;"STATUS:OPERATION:CALL:ENABLE 4" !Enable the
30                                                !connected bit
40                                                ! to generate a
50                                                !summary message.
60    OUTPUT 714;"STATUS:OPERATION:CALL:PTR 0;NTR 4" !Enable the
70                                                  !negative
80                                                  !transition
90                                                  !filter for the
100                                                 !GSM Summary bit.
110   OUTPUT 714;"STATUS:OPERATION:CALL:GSM:PTR 0;NTR 4" !Enable the
120                                                      !negative
130                                                      !transition
140                                                      !filter for the
150                                                      !GSM connected bit.
160   OUTPUT 714;"STATUS:OPERATION:CALL:GSM:ENABLE 4" !Enable the
170                                                   !connected bit for
180                                                   !GSM to generate a
190                                                   !summary message.
200   OUTPUT 714;"STATUS:OPERATION:ENABLE 1024" !Enable the call sumary
210                                             !bit to generate a summary
220                                             !message.
230   OUTPUT 714;"*SRE 128" !Enable the service request enable register to
240                         !generate an SRQ.
250   ON INTR 7,15 CALL Err !Define the interrupt-initiated branch wiht a
260                         !priority of 15, the highest.
270   ENABLE INTR 7;2 !Enable interrupt on interface card 7 with a bit mask
280                   !(for the interface's interrupt-enable register) of 2.
290   PRINT "Make a call, type CONT when connected." !Make a Mobile Station
300                                                  !originated call.
310   PAUSE
320   PRINT "End the call from the mobile station and then type CONT."
330   PAUSE
340   LOOP
350     OUTPUT 714;"STATUS:OPERATION:CALL:GSM:EVENT?" !Query the event register.
360     ENTER 714;Eve
370     IF Eve=0 THEN
380       PRINT "The call is still connected, press the end key."
390     END IF
400   END LOOP
410   END
420   SUB Err
430     DISP "The call has ended."
440     Clear_interrupt=SPOLL(714)
450     OUTPUT 714;"*CLS"
460     STOP
470   SUBEND

Related Topics

Call Processing Event Synchronization

CALL:STATus[:STATe][:VOICe]?

CALL:CONNected:ARM[:IMMediate]

CALL:CONNected:TIMeout

Instrument Status Area


Data Connection Processing State Synchronization

Data Connection Processing State Synchronization

Description

Data Connection Processing State Query

The CALL:STATus[:STATe]:DATA? query returns a string indicating the current data connection processing state.

There are seven possible data connection processing states.

The query returns one of the following strings:

  • "IDLE"

    Idle is returned when the mobile station is not GPRS attached or EGPRS attached.

  • "ATTG"

    Attaching is returned when the mobile station has sent an attach request. This is a transitory state (which means that the mobile station can only remain in this state until the protocol timer expires). At the end of the signalling exchange, the new state will either be Attached or Idle, depending on whether or not the attach procedure completes without error.

  • "DET"

    Detaching is returned when the attached mobile station has sent a detach request. This is a transitory state (which means that the mobile station can only remain in this state until it successfully moves to another state, or the protocol timer expires). At the end of the signalling exchange, the new state will be Idle, even if the procedure encounters an error.

  • "ATT"

    Attached is returned when the mobile station has performed a successful GPRS attach or EGPRS attach.

  • "STAR"

    Starting is returned when you have performed the "Start Data Connection" action (using CALL:FUNCtion:DATA:START ). This is a transitory state (which means that the mobile station can only remain in this state until it successfully moves to another state, or the protocol timer expires). At the end of the signalling exchange, the new state will be either Transferring, Attached or Idle, depending on whether or not the data connection is successfully established.

  • "END"

    Ending is returned when you have performed the "End Data Connection" action (using CALL:FUNCtion:DATA:STOP ). This is a transitory state (which means that the mobile station can only remain in this state until it successfully moves to another state, or the protocol timer expires). At the end of the signalling exchange, the new state will be Attached, even if the procedure encounters an error.

  • "TRAN"

    Transferring is returned when a data connection has been established.

  • "PDPAG"

    PDP Activating is returned when an activate PDP context request procedure has been initiated.

  • "PDP"

    PDP Active is returned when a PDP context has been established. The PDP Active data connection type is required for transferring IP datagrams between the MS and the test set.

  • "PDPD"

    PDP Deactivating is returned when a deactivate PDP context request procedure has been initiated.

  • "DCON"

    DCON is returned when a circuit switched data connection is active.

  • "SUSP"

    This setting is only applicable to the lab applications. SUSP is returned when the mobile station suspends GPRS operation in order to carry out circuit switched voice services rather than establishing a Dual Transfer Mode session.

The following command returns the current state of a data connection:

OUTPUT 714;"CALL:STATus:STATe:DATA?"
ENTER 714;Inst_state$

Attached State Query

This query determines if a data connection is in the Attached state by returning an integer value. The value indicates if the data connection state is Attached or any other non-transitory state, not if any data connection state change has occurred.

The query returns one of the following:

  • 0 = Any non-transitory state other than Attached (that is, Idle or Transferring)
  • 1 = Attached

If the data connection is in the Attaching, Detaching, Starting, or Ending state, this command does not return a value until the data connection state proceeds to Idle, Attached, or Transferring.

OUTPUT 714;"CALL:ATTached:STATe?"

Transferring State Query

This query determines if a data connection is in the Transferring state by returning an integer value. The value indicates if the data connection state is Transferring or any other non-transitory state, not if any data connection state change has occurred.

The query returns one of the following:

  • 0 = Any non-transitory state other than Transferring (that is, Idle or Attached)
  • 1 = Transferring

If the data connection is in the Attaching, Detaching, Starting, or Ending state, this command will not return a value until the data connection state proceeds to Idle, Attached, or Transferring.

OUTPUT 714;"CALL:TRANsferring:STATe?"

Data Connection State Change Detector

This method provides the advantage of indicating that a data connection state change has occurred. The change detector works in conjunction with the Attached State and Transferring State queries. Arming the CALL:DCONnected? query provides a way for the external controller to know when the data connection state change process is done.

The data connection state change detector becomes disarmed when any of the following conditions have been met:

  • the data connection processing state has changed to either Idle, Attached or Transferring from one of the transitory states

    or,

  • the attempt to establish a data connection failed and one of the test set's Fixed Timers has timed out

    or,

  • no data connection processing state changes occurred within the time period specified by the timeout timer.

The following command arms the data connection state change detector, but does not cause any data connection processing function to start:

OUTPUT 714;"CALL:DCONnected:ARM[:IMMEDIATE]"
Data Connection State Change Detector Timeout

If a state change does not occur, you need a way to control how long to wait for the change detector. The change detector is disarmed by the timeout timer. After a timeout, the state query that you have initiated (Attached state query or Transferring state query will return a 1 for connected or a 0 for idle. You can set the timeout value using CALL:DCONnected:TIMeout .

Related Topics

Test System Synchronization Overview


Test System Synchronization Overview

Test System Synchronization Overview

Description

Typical test systems include an external controller with a GPIB connection to the test set, an RF (and possible AF) connection between the test set and a mobile station under test, and a serial connection between the mobile station and the external controller.

Synchronizing an external controller with the test set and a mobile station under test ensures that no device does something before it is supposed to, which can cause errors, or does something well after it could have, which wastes time.

Test System

Sequential versus overlapped commands

The test set uses both sequential and overlapped commands:

  • Sequential commands must finish executing before the next command starts to execute.
  • Overlapped commands do not finish executing before the next command starts to execute.

Overlapped commands are more difficult to synchronize because an overlapped operation that started several commands earlier may still be executing as subsequent commands are being parsed out from the input buffer and executed. This can present a problem unless the external controller is properly synchronized to the test set's execution of commands. Overlapped commands allow the test set to use its internal resources as efficiently as possible.

Methods for synchronization

The test set's GPIB command set supports the following methods to achieve synchronization for overlapped commands. In some cases, combinations of these methods will provide the best results:

Methods one and two do not require the external controller to query the test set, nor to perform any branching or decision-making associated with information acquired from the test set.

Methods three through six rely on responses from the test set to an external controller, indicating that some event has occurred. The external controller can then make decisions based on these responses to control the flow of commands to the test set and other devices in the test system.

  1. Force the test set to execute overlapped commands sequentially.
  2. Force the test set to wait until an overlapped command is done executing before executing any more commands.
  3. Query the test set to determine when a command has finished executing.
  4. Query the test set to determine when all commands sent to it have at least begun executing.
  5. Query the test set to determine the current call or data connection processing state.
  6. Program the test set to generate a service request when an operation has completed or the test set is in a certain state.

Commands used for synchronization:

  • CALL:STATus[:STATe][:VOICe]?

    This command queries the test set's current call processing state. This command supports synchronization method five. (See Call Processing State Query ).

  • CALL:CONNected[:STATe]?

    This command determines the connected/idle state of a call. A feature called the change detector provides the user with a way to hold off the response to this query until a call processing state transition has taken place. (See Connected/Idle Query ). This command supports synchronization method five.

  • :DONE? and :OPC?
    These specialized commands can be appended to call processing overlapped commands to support synchronization method three. (See Call Processing Subsystem Overlapped Command Synchronization Commands .)

  • :WAIT
    This specialized command can be appended to call processing overlapped commands to support synchronization method two.
    (See Call Processing Subsystem Overlapped Command Synchronization Commands .)

  • :SEQ
    This specialized command can be appended to call processing overlapped commands to support synchronization method one.
    (See Call Processing Subsystem Overlapped Command Synchronization Commands .)

  • INITiate:DONE?
    This specialized command causes the test set to return a mnemonic indicating if a measurement is done. If not, the returned mnemonic will indicate if the measurement is still executing. This command supports synchronization method three.
    (See INITiate:DONE? .)

  • STATUS:<register>
    Status bits in the STATus:OPERation:CALL:GSM Condition Register Bit Assignment register are provided to indicate the test set's call processing state. These bits support synchronization methods five and six.

    Status bits in the STATus:OPERation:NMRReady:GSM Condition Register Bit Assignment register are provided to indicate when a measurement is ready to be fetched. These bits support synchronization method three and six.
    Many other status bits are provided in the GPIB status subsystem that are useful for synchronization. See STATus Subsystem Description .

  • SYSTem:SYNChronized
    This specialized command causes a condition bit to be set then cleared when all prior sequential commands have completed and all prior overlapped commands have started indicating that the input buffer is synchronized. (See STATus:OPERation Condition Register Bit Assignment ). This command supports synchronization method four and six.

  • *OPC , *OPC? , and *WAI (not recommended)

    Note: These commands look at all of the test set's operations collectively. Because multiple processes are likely to be executing at the same time, it is recommended that the other commands above be used instead.

Related Topics

Call Processing State Synchronization


Test System Synchronization Overview

Test System Synchronization Overview

Description

Typical test systems include an external controller with a GPIB connection to the test set, an RF (and possible AF) connection between the test set and a mobile station under test, and a serial connection between the mobile station and the external controller.

Synchronizing an external controller with the test set and a mobile station under test ensures that no device does something before it is supposed to, which can cause errors, or does something well after it could have, which wastes time.

Test System

Sequential versus overlapped commands

The test set uses both sequential and overlapped commands:

  • Sequential commands must finish executing before the next command starts to execute.
  • Overlapped commands do not finish executing before the next command starts to execute.

Overlapped commands are more difficult to synchronize because an overlapped operation that started several commands earlier may still be executing as subsequent commands are being parsed out from the input buffer and executed. This can present a problem unless the external controller is properly synchronized to the test set's execution of commands. Overlapped commands allow the test set to use its internal resources as efficiently as possible.

Methods for synchronization

The test set's GPIB command set supports the following methods to achieve synchronization for overlapped commands. In some cases, combinations of these methods will provide the best results:

Methods one and two do not require the external controller to query the test set, nor to perform any branching or decision-making associated with information acquired from the test set.

Methods three through six rely on responses from the test set to an external controller, indicating that some event has occurred. The external controller can then make decisions based on these responses to control the flow of commands to the test set and other devices in the test system.

  1. Force the test set to execute overlapped commands sequentially.
  2. Force the test set to wait until an overlapped command is done executing before executing any more commands.
  3. Query the test set to determine when a command has finished executing.
  4. Query the test set to determine when all commands sent to it have at least begun executing.
  5. Query the test set to determine the current call or data connection processing state.
  6. Program the test set to generate a service request when an operation has completed or the test set is in a certain state.

Commands used for synchronization:

  • CALL:STATus[:STATe]:DATA?
    This command queries the test set's current data connection processing state. This command supports synchronization method five. See Data Connection Processing State Query .

  • CALL:ATTached[:STATe]?
    This command determines if the current data connection is in the attached state. This command supports synchronization method 5.
  • CALL:TRANsferring[:STATe]?
    This command determines if the current data connection is in the transferring state. This command supports synchronization method 5.

  • :DONE? and :OPC?
    These specialized commands can be appended to data connection processing overlapped commands to support synchronization method three. See Call Processing Subsystem Overlapped Command Synchronization Commands .

  • :WAIT
    This specialized command can be appended to data connection processing overlapped commands to support synchronization method two.
    See Call Processing Subsystem Overlapped Command Synchronization Commands .

  • :SEQ
    This specialized command can be appended to data connection processing overlapped commands to support synchronization method one.
    See Call Processing Subsystem Overlapped Command Synchronization Commands .

  • INITiate:DONE?
    This specialized command causes the test set to return a mnemonic indicating if a measurement is done. If not, the returned mnemonic will indicate if the measurement is still executing. This command supports synchronization method three.
    See INITiate:DONE? .

  • SYSTem:SYNChronized
    This specialized command causes a condition bit to be set then cleared when all prior sequential commands have completed and all prior overlapped commands have started indicating that the input buffer is synchronized. (See STATus:OPERation Condition Register Bit Assignment ). This command supports synchronization method four and six.

  • *OPC , *OPC? , and *WAI (not recommended)

    Note: These commands look at all of the test set's operations collectively. Because multiple processes are likely to be executing at the same time, it is recommended that you use the other commands above instead.

Related Topics

Data Connection Processing State Synchronization


Triggering of Measurements

Triggering of Measurements

Operating Considerations

When the operating mode is active cell mode, Auto triggering sets the trigger source to Protocol. In any other operating mode, auto triggering sets the trigger source to RF Rise.

Description

  • Trigger Source Description
  • Triggering Process Description
  • Trigger Arm (Single or Continuous) Description
  • Trigger Delay Description
  • Trigger Qualification Description

Trigger Source Description

A measurement trigger causes hardware (for example, a sampler) to capture data which is used by a measurement algorithm to produce a measurement result. Not all of the trigger source choices are available in every measurement, or every test application.

RF Rise Trigger Source:

When RF rise triggering is selected, a measurement dependent threshold is used to define the trigger point on the envelope of the signal being measured. The envelope amplitude must fall below this threshold and remain there for a measurement-dependent period of time before the trigger is armed. After the trigger is armed, a trigger will occur as the envelope amplitude increases and passes through the threshold.

Protocol Trigger Source:

When protocol triggering is selected, a data capture is triggered by a protocol generated signal. The test set's protocol engine knows when the DUT's signal should be present and generates a trigger signal for use by the measurement to trigger the data capture.

External Trigger Source:

When external triggering is selected, the user supplies an external trigger signal via the rear panel TRIG IN connector in order to trigger data capture. The trigger will occur on the rising edge of this signal.

Immediate Trigger Source:

When immediate triggering selected, the trigger occurs as soon as any pre-trigger samples required by the measurement algorithm are taken. Data capture is triggered when the measurement is initiated.

HS-DPCCH Trigger Source:

When Trigger Source is set to HS-DPCCH and HS-DPCCH Trigger Subframe Alignment is set to subframe 0 , the trigger occurs at the start of every uplink HARQ0 subframe for which the downlink HARQ0 subframe was aligned with the 10 ms system frame clock. For an FRC, the trigger thus occurs every 60 ms. The HS-DPCCH Trigger Subframe Alignment setting can be used to move the trigger (in subframe increments) relative to the uplink HARQ0 subframe.

Auto Trigger Source:

When auto triggering is selected, the test set automatically chooses the best trigger source for that measurement. This trigger source setting is convenient because the measurement trigger doesn't need to be changed when switching parameters. Auto trigger source is the best choice for most users.

Triggering Process Description

The triggering process controls the present and future states of the test set during the measurement cycle. Triggers are set up using the SETup commands and can be set up when a measurement is in the inactive state. A measurement is activated (selected) with an INITiate command. If a measurement is initiated while in its measurement cycle, it will terminate that measurement and restart it. The active state is not a single state but a collection of any state other than the inactive state. Deactivating (de-selecting) the measurement is accomplished through an INITiate:<MEAS>:OFF command.

Manually, a measurement is activated by selecting it from the Measurement Selection menu. A measurement is deactivated by pressing the Measurement Selection key, scrolling to measurement in the Measurement Selection menu, and then pressing F4 (Close Measurement) .

The Test Set's Measurement States

Measurement States

The following examples describe states of the test set under various conditions. Refer to The Test Set's Measurement States .

Inactive State

If the test set has just been powered on, or any form of preset has been performed, then the measurement state is inactive.

Wait for Trigger State

If a measurement has been initiated with the INITiate command but has not been triggered, or a measurement has been selected from the Measurement Selection menu but has not been triggered, then the measurement state is wait for trigger.

Measuring and Idle States (Trigger Arm Single)

If the trigger arm is set to single, the trigger source is available, and the trigger qualifier (optional) is satisfied, the measurement state transitions to measuring and measurement results are now available to the user. The state then transitions to idle (awaiting another INITiate).

Measuring State (Trigger Arm Continuous)

If the trigger arm is set to continuous, the trigger source is available, and the trigger qualifier (optional) is satisfied, the measurement state transitions to measuring and measurement results are now available to the user. The measurement is continually triggered until the measurement is deactivated. Measurement results are only available after the measurement completes and before it rearms. The measurement is deactivated using the INITiate:<MEAS>:OFF. or Close Measurement .

Trigger Arm (Single or Continuous) Description

Trigger arm determines if a measurement will make one measurement then return to idle (single), or automatically rearm on completion of a measurement and repeat the process (continuous).

NOTE
When operating the test set remotely, the recommended setting for the trigger arm parameter is single. This ensures proper operation of the INIT:DONE? query which is used to control the retrieval of measurement results when measurements are initiated concurrently.

When a continuously armed measurement gets a result, it is available to any currently pending (waiting, hanging) FETCh? query. Then another measurement cycle is started immediately. At this point the results are no longer valid. The INIT:DONE? query is used to determine when there is a completed measurement with valid results that can be fetched. If you look for a continuously armed measurement with valid results that can be fetched using INIT:DONE? then you are unlikely to get anything but WAIT. Each time the Test Set is queried, it is 99% likely to be making another measurement. Even if it did return a measurement name, by the time the control program determines which FETCh? query to send, it is too late to fetch the results and the FETCh? query just hangs until the next measurement cycle is done, nullifying the efficiency provided by the INIT:DONE? query.

Pressing the Start Single key on the front panel will cause all currently active measurements with trigger arm set to single to arm and make the measurement.

Pressing Shift, Start Single (Stop) causes all measurements with trigger arm set to single to abort the measurement.

It is unnecessary for you to arm a measurement if the trigger arm is set to continuous. When in continuous mode, the measurement is automatically rearmed after completing a measurement.

Trigger Arm Default Settings
Action | Trigger Arm Default Setting
Power up of test set | Continuous
Manual Full Preset | Continuous
*RST (Remote) Full Preset | Single
Partial Preset | No change

Trigger Delay Description

Trigger delay controls the delay time between the trigger and the start of sampling. Resolution is 1 nanosecond per measurement and the units are in seconds. A negative value indicates the sampling should occur prior to the trigger. The default is zero seconds which is preferred for most measurements.

Trigger Qualification Description

When Trigger Qualification is on, the test set samples the input signal when a trigger is received. It then determines if the input signal was valid by looking at its power level. If the power level during sampling did not meet the requirements of a valid signal, the state returns to wait for trigger without processing the samples. If a valid signal is present, then it is qualified, and the samples are processed.

Related Topics

Integrity Indicator

SETup:ORFSpectrum:TRIGger:SOURce

SETup:PFERror:TRIGer:SOURce

SETup:PVTime:TRIGger:SOURce

SETup:IQTuning:TRIGger:SOURce[:SELected]

SETup:TXPower:TRIGger:SOURce


Programming a Transmit Power Measurement

Programming a Transmit Power Measurement

This section contains two programming examples:

  • Programming a Transmit Power Measurement for GSM
  • Programming a Transmit Power Measurement for GPRS/EGPRS
  • Programming a EGPRS Transmit Power Measurement

Programming a Transmit Power Measurement for GSM

This section provides an example of how to make the transmit power (TXP) measurement via GPIB.

The following procedure assumes that an active link is established between the test set and the mobile station. See Establishing an Active GSM Link with the Mobile Station .

  1. Configure the TXP measurement parameters using the SETup subsystem.
  2. Start the TXP measurement using the INITiate subsystem.
  3. Use the FETCh? command to obtain TXP measurement results.

Programming Example

10  OUTPUT 714;"SETUP:TXPOWER:CONTINUOUS OFF" !Configures a TXP measurement to
20                                            !single trigger mode.
30  OUTPUT 714;"SETUP:TXPOWER:COUNT:NUMBER 100" !Configures a multi-measurement
40                                             !of 100.
50  OUTPUT 714;"SETUP:TXPOWER:TRIGGER:SOURCE AUTO" !Configure trigger source
60                                                 !to auto.
70  OUTPUT 714;"INITIATE:TXPOWER" !Start TXP measurement.
80  OUTPUT 714;"FETCH:TXPOWER:ALL?" !Fetch TXP results.
90  	ENTER 714;Integrity, Avg_tx_power
100 END

Returned Values

The measurements returned by this program are:

  • Integrity returns the measurement Integrity Indicator (0 means a successful measurement with no errors).
  • Avg_tx_power returns the average burst power in dBm.

Programming a Transmit Power Measurement for GPRS/EGPRS

This section provides examples of how to make the transmit power (TXP) measurement via GPIB.

Programming a Single Burst Measurement

The following procedure assumes that a data connection has been established between the test set and the mobile station (connection status is Transferring). See Step 4: Make a Connection .

  1. Set the multislot configuration to two downlinks, two uplinks (D2U2) using the CALL subsystem.
  2. Configure the TXP measurement parameters using the SETup subsystem.
  3. Select burst 2 of the multislot configuration for the TXP measurement.
  4. Start the TXP measurement using the INITiate subsystem.
  5. Use the FETCh? command to obtain TXP measurement results for burst 2.

Programming Example (Single burst measurement)

10  OUTPUT 714;"CALL:PDTCH:MSLOT:CONFIG D2U2" ! Configures the multi-
20                                            ! slot configuration to be
30                                            ! 2 downlink, 2 uplink.
40  OUTPUT 714;"SETUP:TXPOWER:CONTINUOUS OFF" !Configures a TXP measurement to
50                                            !single trigger mode.
60  OUTPUT 714;"SETUP:TXPOWER:COUNT:NUMBER 100" !Configures a multi-measurement
70                                             !of 100.
80  OUTPUT 714;"SETUP:TXPOWER:TRIGGER:SOURCE AUTO" !Configure trigger source
90                                                 !to auto.
100 OUTPUT 714;"CALL:PDTCH:MSLOT:MEASUREMENT:BURST 2" ! Perform the TXP
110                                                   ! measurement on burst 2.
120 OUTPUT 714;"INITIATE:TXPOWER" !Start TXP measurement.
130 OUTPUT 714;"FETCH:TXPOWER:ALL?" !Fetch TXP results.
140 ENTER 714;Integrity, Avg_tx_power
150 END

Returned Values

The measurements returned by this program are:

  • Integrity returns the measurement Integrity Indicator (0 means a successful measurement with no errors).
  • Avg_tx_power returns the average transmit power in dBm for burst 2 of the multislot configuration.

Programming a Multiple Bursts Measurement

The following procedure assumes that the test set works in GPRS BCH+PDTCH test mode.

  1. Set the multislot configuration to two downlinks, two uplinks (D2U2) using the CALL subsystem.
  2. Configure the TXP measurement parameters using the SETup subsystem.
  3. Set the measurement frequency to 850MHz.
  4. Set the burst capture range to ALL .
  5. Start the TXP measurement using the INITiate subsystem.
  6. Use the FETCh? command to obtain Burst Power and Carrier Power for burst 1 and 2.

Programming Example (Multislot measurement)

10 !
20     DIM Frame_bpow$[150],Frame_cpow$[150]
30 !
40 !
50     OUTPUT 714;"CALL:PDTCH:MSLOT:CONFIG D2U2" ! Configures the multi-
60                                               ! slot configuration to be
70                                               ! 2 downlink, 2 uplink.
80     OUTPUT 714;"SETUP:TXPOWER:CONTINUOUS OFF" !Configures a TXP measurement to
90                                               !single trigger mode.
100     OUTPUT 714;"SETUP:TXPOWER:COUNT:NUMBER 100"!Configures a multi-measurement
110                                                !of 100.
120     OUTPUT 714;"SETUP:TXPOWER:TRIGGER:SOURCE AUTO" !Configure trigger source
130                                                    !to auto.
160     OUTPUT 714;"RFANALYZER:MANUAL:MEASUREMENT:MFREQUENCY 8.5E+8" !Set Mesurement
170                                                                  !Frequency to 850MHz
180     OUTPUT 714;"SET:TXP:RANG:AUTO ON"  !Set auto range to highest burst state to ON.
190             !
200     OUTPUT 714;"SET:TXP:BURS:CAPT ALL"  !Set Burst Capture Range to ALL
210 !
220     OUTPUT 714;"INITIATE:TXPOWER" !Start TXP measurement.
230 !
240     OUTPUT 714;"FETCH:TXPOWER:POWER:FRAME?" !Fetch Carrier Power for the whole TDMA Frame.
250     ENTER 714;Frame_cpow$
260 !
270     OUTPUT 714;"FETCH:TXPOWER:POWER:BURST:FRAME?" !Fetch Burst Power
280                                                   !for the whole TDMA Frame.
290     ENTER 714;Frame_bpow$
300 !
310     PRINT "*** Print Multislot Tx Measurement Results ***"
320     PRINT
330     PRINT "***************Burst Power Reslt****************"
340     PRINT "Burst1, Burst2, Burst3, Burst4, Burst5, Burst6, Burst7, Burst8"
350     PRINT Frame_bpow$
360     PRINT
370     PRINT "***************Carrier Power Results****************"
380     PRINT "Burst1, Burst2, Burst3, Burst4, Burst5, Burst6, Burst7, Burst8"
390     PRINT Frame_cpow$
400     PRINT "END of Program"
410 !
420     END

Returned Values

The measurements returned by this program are:

  • Burst Power returns the Average Burst Power in dBm of burst 1 and 2.
  • Carrier Power returns Average Estimated Carrier power in dBm for burst 1 and 2.

Programming a EGPRS Transmit Power Measurement

Programming a Single Burst Measurement

This section provides examples of how to make a single burst EGPRS transmit power (ETXP) measurement via GPIB.

The following procedure assumes that the mobile station is connected to the test set's RF IN/OUT connector.

  1. Change the serving cell to EGPRS. To do this via GPIB, you must first turn the cell off. See the following procedure.
    1. Turn the cell off using the CALL:OPER:MODE OFF command.
    2. Change the serving cell to EGPRS using the CALL:BCH:SCEL EGPRS command.
    3. Turn the cell back on using the CALL:OPER:MODE CALL command.
  2. Set the connection type to ETSI A using the CALL:FUNC:CONN:TYPE A command.
  3. Set the modulation and coding scheme to one which uses 8PSK modulation.
  4. Set the multislot configuration to two downlinks, one uplink (D2U1) using the CALL subsystem.
  5. Use the CALL:PDTCH:MSLot:MEASurement:BURSt command to select burst 1 of the multislot configuration for the ETXP measurement.
  6. Configure the ETXP measurement parameters using the SETup subsystem.
  7. Turn on the mobile station and allow it to attach.
  8. Start the data connection.
  9. Use a hanging query to determine when the connection has started and to provide synchronization between your program and the test set.
  10. Start the ETXP measurement using the INITiate subsystem.
  11. Use the FETCh? command to obtain ETXP measurement results.

Programming Example

10    ! Turn the cell off to access the serving cell parameter
20    OUTPUT 714;"CALL:OPER:MODE OFF"
30    ! Change the serving cell to EGPRS
40    OUTPUT 714;"CALL:BCH:SCEL EGPRS"
50    ! Turn the cell back on
60    OUTPUT 714;"CALL:OPER:MODE CALL"
70    ! Set the connection type to ETSI Type A
80    OUTPUT 714;"CALL:FUNC:CONN:TYPE A"
90    ! Select a Modulation and Coding Scheme using 8PSK
100   OUTPUT 714;"CALL:PDTCH:MCSC MCS9,MCS9"
110   ! Configures the multi-slot configuration to be
120   !   2 downlink, 1 uplink
130   OUTPUT 714;"CALL:PDTCH:MSL:CONF D2U1"
140   ! Perform the ETXP measurement on burst 1
150   OUTPUT 714;"CALL:PDTCH:MSL:MEAS:BURS 1"
160   OUTPUT 714;"SET:ETXP:CONT OFF"!Set trigger mode to single
170   OUTPUT 714;"SET:ETXP:COUN 5"! Turn statisical results on
180   !  Configure the trigger source to auto
190   OUTPUT 714;"SET:ETXP:TRIG:SOUR AUTO"
200   ! Turn measurement timeout on and set to 5 seconds
210   OUTPUT 714;"SET:ETXP:TIM 5"
220   !
230   !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
240   ! Turn on the mobile station and allow it to attach
250   !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
260   !
270   ! Start the data connection
280   OUTPUT 714;"CALL:FUNC:DATA:START"
290   ! Hanging query to determine when the data connection
300   !  has been established.
310   OUTPUT 714;"CALL:TRAN?"
320   ENTER 714;Tran_state
330   IF NOT Tran_state THEN
340     PRINT "DATA CONNECTION FAILED"
350     STOP
360   END IF
370   OUTPUT 714;"INIT:ETXP" ! Initiate measurement
380   OUTPUT 714;"FETC:ETXP?"! Fetch measurement results
390   ENTER 714;Integrity,Avg_burst_power,Avg_carr_power
400   END

Returned Values

The measurements returned by this program are:

  • Integrity returns the measurement Integrity Indicator (0 means a successful measurement with no errors).
  • Avg_burst_power returns the average burst power in dBm for burst 1 of the multislot configuration.
  • Avg_carrier_power returns the average estimated carrier power in dBm for burst 1 of the multislot configuration

Programming a Multiple Bursts Measurement

This section provides examples of how to make multiple bursts transmit power (TXP) measurement via GPIB

The following procedure assumes that the test set works in EGPRS BCH+PDTCH test mode.

  1. Set the multislot configuration to two downlinks, two uplinks (D2U2) using the CALL subsystem.
  2. Set the modulation format to 8PSK using the CALL subsystem.
  3. Configure the TXP measurement parameters using the SETup subsystem.
  4. Set the measurement frequency to 850MHz.
  5. Set the burst capture range to ALL .
  6. Start the TXP measurement using the INITiate subsystem.
  7. Use the FETCh? command to obtain Burst Power and Carrier Power for burst 1 and 2.

Programming Example (Multislot measurement)

10 !
20     DIM Frame_bpow$[150],Frame_cpow$[150]
30 !
40 !
50     OUTPUT 714;"CALL:PDTCH:MSLOT:CONFIG D2U2" ! Configures the multi-
60                                               ! slot configuration to be
70                                               ! 2 downlink, 2 uplink.
75      OUTPUT 714;"CALL:PDTCH:MCSCheme MCS5" !Configures the modulation format
80                                               !to 8PSK.
85      OUTPUT 714;"SETUP:TXPOWER:CONTINUOUS OFF" !Configures a TXP measurement to
90                                               !single trigger mode.
100     OUTPUT 714;"SETUP:TXPOWER:COUNT:NUMBER 100"!Configures a multi-measurement
110                                                !of 100.
120     OUTPUT 714;"SETUP:TXPOWER:TRIGGER:SOURCE AUTO" !Configure trigger source
130                                                    !to auto.
160     OUTPUT 714;"RFANALYZER:MANUAL:MEASUREMENT:MFREQUENCY 8.5E+8" !Set Mesurement
170                                                                  !Frequency to 850MHz
180     OUTPUT 714;"SET:TXP:RANG:AUTO ON"  !Set auto range to highest burst state to ON.
190             !
200     OUTPUT 714;"SET:TXP:BURS:CAPT ALL"  !Set Burst Capture Range to ALL
210 !
220     OUTPUT 714;"INITIATE:TXPOWER" !Start TXP measurement.
230 !
240     OUTPUT 714;"FETCH:TXPOWER:POWER:FRAME?" !Fetch Carrier Power for the whole TDMA Frame.
250     ENTER 714;Frame_cpow$
260 !
270     OUTPUT 714;"FETCH:TXPOWER:POWER:BURST:FRAME?" !Fetch Burst Power
280                                                   !for the whole TDMA Frame.
290     ENTER 714;Frame_bpow$
300 !
310     PRINT "*** Print Multislot Tx Measurement Results ***"
320     PRINT
330     PRINT "***************Burst Power Reslt****************"
340     PRINT "Burst1, Burst2, Burst3, Burst4, Burst5, Burst6, Burst7, Burst8"
350     PRINT Frame_bpow$
360     PRINT
370     PRINT "***************Carrier Power Results****************"
380     PRINT "Burst1, Burst2, Burst3, Burst4, Burst5, Burst6, Burst7, Burst8"
390     PRINT Frame_cpow$
400     PRINT "END of Program"
410 !
420     END

Returned Values

The measurements returned by this program are:

  • Burst Power returns the Average Burst Power in dBm of burst 1 and 2.
  • Carrier Power returns Average Estimated Carrier power in dBm for burst 1 and 2.

Related Topics

Transmit Power Measurement Description


GSM/GPRS/EGPRS (E1968A) Test Application Revision Information

GSM/GPRS/EGPRS (E1968A) Test Application Revision Information

Last updated: December 9, 2008

This document describes features and functionality that are part of the Agilent Technologies GSM/GPRS/EGPRS Test Application releases. This document contains the original features, as well as enhancements that have been added over time.

If you are interested in comparing the key feature differences between the latest releases of each of the GSM/GPRS/EGPRS Test and Lab Applications, see GSM/GPRS/EGPRS Application Feature Comparison.

CAUTION
You may need to upgrade the hardware in your test set before installing the application firmware described here. If you install application firmware on a test set with incompatible hardware, the following may occur:

  • Your test set may lock up (see Test Set Lockup During Power Up Sequence ).
  • The application may not run.
  • Some features in the application may be inaccessible, or may not perform to specifications.

To determine if a hardware upgrade is required for your testing needs, please review the hardware requirement information at:

http://wireless.agilent.com/rfcomms/upgrades/8960/

Select the appropriate link below to view the required release.

  • A.09.15 Release - October 2008
  • A.09.13 Release - September 2008
  • A.08.08 Release - July 2007
  • A.07.21 Release - April 2007
  • A.07.19 Release - March 2007
  • A.07.12 Release - December 2006
  • A.06.56 Release - July 2006
  • A.06.31 Release - January 2006
  • A.06.09 Release - August 2005
  • A.05.11 Release -May 2005
  • A.04.18 Release - January 2005
  • A.03.48 Release - April 2004
  • A.03.32 Release - January 2004
  • A.02.10 Release - July 2003
  • A.01.20 Initial Release - January 2003

A.09.15 Release - October 2008

This is a maintenance release to resolve the known issues detailed in the previous release. The features offered in this release are otherwise identical to those offered in the A.09.13 Release - September 2008 .

A.09.13 Release - September 2008

The most current documentation for the GSM/GPRS/EGPRS applications is the Online User's Guide located at:

http://wireless.agilent.com/rfcomms/refdocs/gsmgprs/

Measurements

  • Short Message Service - Allows you to test both the cell broadcast and point-to-point SMS capability of your mobile station with a required feature license. See Short Message Service (SMS) for more information.
  • Enhanced Audio Feature license - Allows you to use the enhanced audio features with a required feature license. The Enhanced Audio features including AMR, AMR-WB, IFER measurement, Digital Audio Interface and Real Time Vocoder.
  • Mobile Calculate BER - Provides the ability that allows the mobile to calculate the BER when the test set transmits downlink clearcoded payload pattern to the Mobile Station. See Mobile Calculate BER Test for more information.
  • FM Broadcast - Allows you to use the test set coupled with the audio measurement features to test the Mobile Station with full range of FM Broadcast signals. See FM Broadcast for more information.
  • Enhanced GFDT Discontinuous Slot - Provides the ability of measurement timeout mechanism in GFDT transmit power measurement and adds GFDT trigger threshold. See Fast Device Tune Capable Measurement and Fast Device Tune for more information.
  • Enhanced Digital Output RF Spectrum Measurement - The digital Output RF Spectrum measurement is extended to support multi-slot class 12 configuration which has up to 4 uplink burst, time domain graphic and +/- 70 KHz frequency capture range. See Output RF Spectrum Measurement Description for more information.
  • Enhanced Phase and Frequency Error Measurement - The Phase and Frequency Error measurement is extended to support multi-slot class 12 configuration which has up to 4 uplink burst and +/- 500 KHz frequency setting accuracy. See Phase and Frequency Error Measurement Description for more information.
  • Enhanced Modulation Accuracy Measurement. The Modulation Accuracy Measurement is extended to support multi-slot class 12 configuration which has up to 4 uplink burst. See Modulation Accuracy Measurement Description for more information.
  • Enhanced Bit Error Measurement - Allows you to configure the mobile loopback type in test mode. See GSM Bit Error Measurement for more information.
  • Burst Timing Error Measurement - Allows you to measure the time difference between the expected and calculated synchronization code location within a burst in test mode.See Test Mode Burst Timing Error Measurement for more information.
  • Enhanced Transmit Power Measurement - Provides the ability to measure Class 34 Capable mobile phones. You can measure up to 5 uplink bursts with a single capture on one TDMA frame.See Transmit Power Measurement Description for more information.
  • Enhanced Power versus Time Measurement - Provides the ability to measure Class 34 capable mobile phones. You can measure up to 5 uplink bursts with a single capture on one TDMA frame.See Power versus Time Measurement Description for more information.
  • Enhanced EDGE Dynamic Power Measurement - Provides the ability to set the expected maximum time interval state and value. See EDGE Dynamic Power (EDP) Measurement for more information.
  • User Calibration Summary - Provides the summary of the calibration performed. See User Calibration Summary .

Known Issues

  • The real time vocoder's Voice Activity Detection State parameter (CALL:RTVocoder:VADetection[:STATe]) is not functioning. It remains in the OFF state.
  • The SYStem:APPLication:CATalog:LICense:APPLication:ALL? command does not function.

Hardware Requirements

http://www.agilent.com/find/8960upgrades

_____________________________________________________________________________________________________

A.08.08 Release - July 2007

A downloadable version of the Online User's Guide (CHM Help File) that is specific to this release is available at:

http://www.home.agilent.com/upload/cmc_upload/All/E1968A_A08_E6701E_E02_E6701T_T03_E6704A_Ref_Guide.chm

To properly view the CHM Help File, you must save it to your desktop (rather than "Open" it from the Internet). For Windows XP, you must also then right-click on the file and select Properties>>Unblock.

Call Processing

  • Uplink Data Timeout - Allows you to determine whether the radio link has failed and whether the uplink flow of data messages has been interrupted for an extended period of time. You can get an uninterrupted TBF by setting the Uplink Data Timeout parameter to OFF. See Uplink Data Timeout for more information.

Measurements

  • Power versus Time Measurement - The enhanced Power versus Time measurement provides the ability to measure Class 12 Capable mobile phones. You can measure up to 4 uplink bursts with a single capture on one TDMA frame. See Power versus Time Measurement Description for more information.
  • Fast Device Tune - Fast Device Tune can significantly reduce the time taken to perform transmitter and receiver test. See Fast Device Tune for more information. The Transmit Power Measurement is the only Fast Device Capable Measurement at present. See Fast Device Tune Capable Measurement for more information.

Hardware Requirements

http://www.agilent.com/find/8960upgrades

_____________________________________________________________________________________________________

A.07.21 Release - April 2007

This is a maintenance release to resolve known issues. The features offered in this release are identical to those offered in the A.07.19 Release - March 2007 .

A.07.19 Release - March 2007

This firmware release provides support for a variety of new features including: LAPDm Format Selection, Measurement Channel Selection in BCH Only Mode, 3 Digit MNC for GSM850, Enhanced Phase and Amplitude versus Time Measurement, and Enhanced Transmit Power Measurement.

A downloadable version of the Online User's Guide (CHM Help File) that is specific to this release is available at:

http://www.home.agilent.com/upload/cmc_upload/All/E1968A_A0717_E6701E_D03_E01_T01_E6704A_Ref_Guide.chm

To properly view the CHM Help File, you must save it to your desktop (rather than "Open" it from the Internet). For Windows XP, you must also then right-click on the file and select Properties>>Unblock.

Call Processing

  • SACCH LAPDm Format Selection - Allows you to select which LAPDm frame format is used for SACCH. The LAPDm Format specification changes since Release 1996(R96). LAPDm Format B is used before R96 while LAPDm Format B4 is used after R96. You can select either of them according to the LAPDm Format of your mobile station. See Cell Parameters for more information.
  • Measurement Channel Selection in BCH Only Mode - Allows you to choose which channel (RACH, TCH or PDTCH) is measured in BCH Only Mode (GSM BCH, GPRS BCH or EGPRS BCH). See Measurement Channel in BCH Only Mode for more information.
  • 3 Digit MNC for GSM850 - Allows you to choose if the BCCH should be configured using the standard 2-digit MNC (J-STD-007 coding) or the 3-digit MNC (J-STD-007A coding, section 2.10.5.1.3). See Cell Identification Parameters for more information.

Measurements

  • Enhanced Phase and Amplitude versus Time Measurement - The enhanced Phase and Amplitude versus Time Measurement allows you to select the Filter Type for the bandwidth filter. See Phase and Amplitude versus Time Measurement Description for more information.
  • Enhanced Transmit Power Measurement - The enhanced TXP measurement provides the Burst Power and Estimated Carrier Power measurements for 8PSK or GMSK modulated signals. You can measure up to 4 uplink bursts with a single capture on one TDMA frame. See Transmit Power Measurement Description for more information.

Hardware Requirements

http://www.agilent.com/find/8960upgrades

_____________________________________________________________________________________________________

A.07.12 Release - December 2006

Release delayed, please use previous releases.

A.06.56 Release - July 2006

The only change in this release of the E1968A is that the Phase and Amplitude versus Time Measurement now automatically calibrates the phase and amplitude results. The measurement speed is now much quicker with the new, on-the-fly calibration, which is performed automatically when you run this measurement for Discrete and Continuous waveforms. See Phase and Amplitude versus Time Measurement Description for more details.

The content of this guide includes information for the E.00.08 Subscription Release (E6701E) - March 2006 . The E6701E contains new features and parameters. Some parameters that exist in the E1968A have changed locations in the E6701E and therefore it is recommended that you use the CHM Help File that is specific to your application for front panel access information.

A downloadable version of the Online User's Guide (CHM Help File) that is specific to this release is available at:

http://www.home.agilent.com/upload/cmc_upload/All/E1968A_E6701D_A_06_D_03_Ref_Guide.chm

NOTE: The URL above does not include the Phase and Amplitude versus Time Measurement changes.

To properly view the CHM Help File, you must save it to your desktop (rather than "Open" it from the Internet). For Windows XP, you must also then right-click on the file and select Properties>>Unblock.

A.06.31 Release - January 2006

A downloadable version of the Online User's Guide (CHM Help File) that is specific to this release is available at:

http://www.home.agilent.com/upload/cmc_upload/All/E1968A_E6701D_A_06_D_03_Ref_Guide.chm

NOTE: To properly view the CHM Help File, you must save it to your desktop (rather than "Open" it from the Internet). For Windows XP, you must also then right-click on the file and select Properties>>Unblock.

Call Processing

This release also couples the Band Indicator parameter to the BCH Cell Band setting. That is, if the BCH Cell Band is changed to DCS or PCS, the Band Indicator is updated to match the BCH Cell Band setting. For more information, see CALL:BINDicator .

Measurements

This release adds the Tail Bit Demodulation parameter that allows you to control how the test set demodulates the tail bits during a Phase and Frequency Error measurement. The command to set this parameter is SETup:PFERror:TBDemod .

The ORFS measurement meets improved Agilent product specifications when using the digital measurement filter (Filter Type set to Digital or Auto), but only for E5515C test sets with serial number > GB46040000 and E5515B test sets with serial number > GB46050000. Upgraded E5515s may also meet specifications. Contact your Agilent Sales Representative for more information.

Hardware Requirements

http://www.agilent.com/find/8960upgrades

_____________________________________________________________________________________________________

A.06.09 Release - August 2005

A downloadable version of the Online User's Guide (CHM Help File) that is specific to this release is available at:

http://www.home.agilent.com/upload/cmc_upload/All/E1968A_E6701D_A.06_D.02_Ref_Guide.chm

NOTE: To properly view the CHM Help File, you must save it to your desktop (rather than "Open" it from the Internet). For Windows XP, you must also then right-click on the file and select Properties>>Unblock.

This firmware release adds the T-GSM810 frequency band as well as provides support for the Phase and Amplitude versus Time measurement and the digital measurement filter type setting for the ORFS measurement.

Call Processing

All frequency banded test set parameters now support the T-GSM810 frequency band. You can now select the T-GSM810 frequency band on the test set's front panel in any menu that contains the frequency bands. The GPIB commands are also updated to include the T-GSM810 frequency band in all of the Frequency Banded Parameters . The GPIB command mnemonic for the T-GSM810 band is TGSM810 . The ARFCN range of the T-GSM810 band is 350 to 425.

Measurements

The Phase and Amplitude measurement provides a way to characterize the phase and magnitude error introduced by the non-linearity of power amplifiers operating over a wide dynamic range. For more information see the Phase and Amplitude versus Time Measurement Description .

The ORFS measurement now gives you the option to choose between an analog or digital measurement filter type. You can set Filter Type to Analog , Digital , or Auto. When filter type is set to Auto mode, the measurement uses the digital measurement filter if your test setís hardware supports it. However, the ORFS measurement is not specified when using the digital measurement filter. See Output RF Spectrum Measurement Description .

Hardware Requirements

http://www.agilent.com/find/8960upgrades

_____________________________________________________________________________________________________

A.05.11 Release -May 2005

A downloadable version of the Online User's Guide (CHM Help File) that is specific to this release is available at:

http://www.home.agilent.com/upload/cmc_upload/All/E1968A_E6701D_A.05_D.02_Ref_Guide.chm

NOTE: To properly view the CHM Help File, you must save it to your desktop (rather than "Open" it from the Internet). For Windows XP, you must also then right-click on the file and select Properties>>Unblock.

This firmware release provides support for a variety of new features such as: Speech Echo Loopback Delay, IMSI Attach, PACCH PSI, Network Detach Cause, and CRC error reporting for the Bit Error and Block Error Measurements.

Hardware Requirements

This release has no new hardware requirements.

Call Processing

  • The Speech Echo Loopback Delay can now be varied from 0 to 1 second. See the description for the downlink speech parameter Echo for more details.
  • You can now control whether or not the test set will send Packet System Information (PSI) messages on the PACCH, and which type of PSI messages (SI1 or SI13) are sent depending on the BCH configuration. The command to configure this parameter is CALL:(PACCH|PACChannel):PSInfo .
  • You can choose which type of Detach Request the test set sends the mobile station in the Detach Type Information Element .
  • You can control the state of the IMSI Attach flag with the command CALL[:CELL]:IATTach[:STATe]? .
  • The Block Polling Interval now has a separate setting for each applicable connection type. See Block Polling Parameters for more information.
  • The Restart on Fatal Error feature provides the ability to configure the test set to automatically restart if a fatal error occurs.
  • The EGPRS Demodulation Type is only configurable when the operating mode is set to Active Cell with an EGPRS Serving Cell . See How do I change the EGPRS Demodulation Type to Normal? for the procedure to configure the EGPRS Demodulation Type.

Measurements

  • The Bit Error Measurement and Block Error Measurement have been updated to now report CRC errors in addition to their existing reports. See the commands FETCh:BERRor:COUNt:CRC? and FETCh:BLERror:CRC? for more details.
  • The EDGE Dynamic Power (EDP) Measurement is now available in GSM and GPRS test modes as well as the EGPRS test mode. If you only have a GSM/GPRS license, the EDP measurement will only measure GMSK modulated busts.

_____________________________________________________________________________________________________

A.04.18 Release - January 2005

A downloadable version of the Online User's Guide (CHM Help File) that is specific to this release is available at:

http://www.home.agilent.com/upload/cmc_upload/All/GSM_GPRS_EGPRS_Ref_Guide.chm

NOTE: To properly view the CHM Help File, you must save it to your desktop (rather than "Open" it from the Internet). For Windows XP, you must also then right-click on the file and select Properties>>Unblock.

This firmware release adds the new call processing features you can set such as: custom payload pattern, PDU count, and call originate timeout. The new measurement this release adds is the EDGE Dynamic Power measurement.

Hardware Requirements

  • New hardware requirements apply. For details please see:

    http://www.agilent.com/find/8960upgrades

Call Processing

  • A Custom option has been added to allow you to customize the payload pattern. For more information on the custom payload pattern to be sent on a speech frame, see Speech . For more information on the custom payload pattern to be sent on the RLC data block, see Payload Patterns . The payload pattern can only be sent via GPIB.
  • The ETSI Type A operating mode has been enhanced to allow you to set the PDU count. See ETSI Type A for more details. The PDU count can only be set via GPIB. The command to set the PDU count is CALL:FUNCtion:DATA:ETSIA:PDUNit|PDU:COUNt .
  • Network Detach is now available in the test application. See Detach Request for more details.
  • The Call Originate Timeout feature has been added as an adjustable setting to provide the ability to extend the period the mobile station is alerted during a mobile terminated call. The command to set this parameter is CALL:ORIGinate:TIMeout .
  • More EGPRS data rate configurations are available in this release. See EGPRS Data Rate Configurations for more information. The GPIB command for this feature is:
    • CALL:DATA:RATE:CONFig[:EGPRs] .

Measurements

  • The EDGE Dynamic Power measurement has been added. For more details, refer to EDGE Dynamic Power (EDP) Measurement . The new commands added for this feature include:
    • SETup:EDPower
    • INITiate
    • FETCh:EDPower
    • READ
  • The Frequency Stability measurement has been added. See Frequency Stability Measurement Description for more details. The new commands added for this feature are:
    • SETup:FSTability
    • INITiate
    • FETCh:FSTability
    • READ

_____________________________________________________________________________________________________

A.03.48 Release - April 2004

A downloadable version of the Online User's Guide (CHM Help File) that is specific to this release is available at:

http://www.home.agilent.com/upload/cmc_upload/All/E1968A_A03_48_E6701C_C03_48_E6704A_Ref_Guide.chm

NOTE: To properly view the CHM Help File, you must save it to your desktop (rather than "Open" it from the Internet). For Windows XP, you must also then right-click on the file and select Properties>>Unblock.

This firmware release adds the new EGPRS SRB Bit Error measurement as well as the ability to select the demodulation type used when the system type is EGPRS. This release also includes fixes to known problems. See Known Problems Corrected in this Release below.

Hardware Requirements

  • Previous hardware requirements still apply.

Call Processing

  • EGPRS Demodulation Type has been added as a parameter. See EGPRS Demodulation Type for more information. The new GPIB command added for this feature is:
    • CALL:FUNCtion:EGPRs:DEMod .

Measurements

  • The EGPRS SRB Bit Error measurement has been added. For more details, refer to EGPRS SRB Bit Error Measurement . The new commands added for this feature include:
    • SETup:SBERror
    • INITiate
    • FETCh:SBERror
    • READ
  • The BLER measurement has been enhanced to include user selectable measurement modes.For more details, refer to Block Error Measurement . The new command added for this feature is:
    • SETup:BLERror:ETSIB:MODE .

Known Problems Corrected in this Release

See Known Issues for information on issues in specific firmware releases and for workarounds. Known problems that existed in early versions of firmware that no longer exist in the A.03.48 release are listed below.

  • Incorrect values are returned for the Neighbor Cell Report ARFCN.
  • SRB Loopback Connection does not work properly.
  • Test set crashes when the INIT:BLER:ON or INIT:BLER:OFF commands are sent.
  • BLER measurement does not work with some phones in ETSI Type B (Ack) mode.
    • When in ETSI B acknowledged mode there are two methods of BLER measurement available. These are loopback and ack/nack. Prior to the A.03.32 release only the loopback method was available in this test mode. (The ack/nack method uses the information returned from the phone to compute the BLER, the loopback method relies on the phone looping back the data and the test equipment making the measurement.)At A.03.32 the ack/nack method was added and the default changed to this method when in ETSI B acknowledged mode. (It offers advantages over the loopback method since the BLER associated with individual downlink timeslots can be observed in a single measurement.)This has been shown to cause problems with some phones that don't implement ETSI test mode B ack mode properly. To maintain backward compatibility the default measurement method has been changed to loopback for this and all later releases. The user may select the alternative measurement method if desired through the BLER measurement settings menu.
  • Test set indicates Connected status before a connection is fully established.
    • When setting up a GSM voice call the instrument would indicate that the connection was established before it actually was. In this case attempting to make a BER measurement immediately could result in a measurement timeout.
  • Connections made using the ETSI Type A and ETSI Type B (Ack) connection type are unreliable.
    • The previous release only demodulated signaling bursts known to contain useful information for both GPRS and EGPRS connections. Some phones have problems when using this technique for ETSI Type A and ETSI Type B (Ack) connection types.The following changes:
      • When using the GPRS system type, all bursts are now demodulated.
      • When using the EGPRS system type, for the ETSI Type B (Ack) connection type, all bursts are demodulated.
      • For ETSI Type A and ETSI Type B (Unack), the default is still reduced demod. You can change the demodulation used to normal demod by changing the EGPRS Demod setting. You may see a decrease in measurement throughput using normal demodulation.
  • Changing channel mode from HR to FR using Handover Setup causes the call to drop.
  • If the BER measurement is on during a change to another Operating Mode, the measurement stops working.
  • Downlink Power in Unused Bursts for GPRS data connections is affected by changes to the GSM PRL.
  • TCH and PDTCH PRL settings are coupled and should not be.
  • GPIB Command for the RLC/MAC Expected Header displayed on the front panel when in Help mode is incorrect.
  • Command SET:PVT:TXP:METHOD displayed on the front panel when in Help mode for setting the PVT measurement TX Power Method is not a valid command.
  • When the BLER measurement is restarted, the Sum of Burst Blocks Tested is not equal to the Total Number of Bursts Tested.
  • Performing a full preset does not clear the BLER Poll Rate value.
  • User's Guide incorrectly states that the BER measurement can be used with a GSM HR connection.
  • Unexpected BLER measurement results when using ETSI Type B Connection Type and Modulation Coding Scheme settings of MCS-7, MCS-8, and MCS-9.
  • The ETXP measurement incorrectly returns a Parameter Error measurement integrity when measuring RACH signals.
  • During multislot uplink EGPRS transfers, the second burst of signaling information is corrupt.
  • If the FBER measurement is setup and started while the operating mode is EGPRS Test Mode, changing the operating mode to Active Cell (EGPRS) causes a measurement timeout failure to occur.
  • In EGPRS MCS5-9, the test set transmits incorrect USF values for USF values other than 0.

_____________________________________________________________________________________________________

A.03.32 Release - January 2004

A downloadable version of the Online User's Guide (CHM Help File) that is specific to this release is available at:

http://www.home.agilent.com/upload/cmc_upload/All/E1968A_A03_E6701C_C03_E6704A_Ref_Guide.chm

NOTE: To properly view the CHM Help File, you must save it to your desktop (rather than "Open" it from the Internet). For Windows XP, you must also then right-click on the file and select Properties>>Unblock.

This firmware release adds optional EGPRS capability to the E1968A. This includes EGPRS specific call processing, new EGPRS measurements (EGPRS Transmit Power and EGPRS Modulation Accuracy), as well as the enhancement of existing measurements to support GMSK and 8PSK EGPRS modulation and coding schemes.

Hardware Requirements

  • E5515C requires option H03/K03 to support the E1968A with an EGPRS TA license. Starting in February 2004, the E5515C ships with this option as standard hardware.
  • Previous hardware requirements still apply.

Call Processing

  • EGPRS has been added as a selection for the serving cell parameter. See CALL[:CELL]:BCHannel:SCELl for more information.

    NOTE
    There is currently no combined GPRS + EGPRS mode available. Therefore, a mobile station that supports GPRS but not EGPRS will not be able to attach when the serving cell is set to EGPRS. The GPRS serving cell setting should be used instead. See CALL[:CELL]:BCHannel:SCELl for more information.

  • The operating modes EGPRS BCH and EGPRS BCH+PDTCH have been added. See EGPRS Test Mode Operation for more information.
  • The front panel user interface has been enhanced to allow changes to the Serving Cell parameter without manually switching the cell off. To accomodate this, three new selections have been added to the Operating Mode menu. These are:
    • Active Cell (GSM) - GSM only BCH
    • Active Cell (GPRS) - GSM + GPRS BCH
    • Active Cell (EGPRS) - GSM + EGPRS BCH

    In addition, the selection Active Cell is no longer available. See Active Cell Operating Mode for more information.

  • The following call processing commands have been added which are specific to EGPRS:
    • Modulation Coding and Puncturing Schemes
      For more details refer to CALL:(PDTCH|PDTChannel):MCSCheme , CALL:(PDTCH|PDTChannel):MCSCheme:EBPTest[:BURSt1] , and CALL:(PDTCH|PDTChannel):MCSCheme:EBPTest:BURSt<2|3|4|5> .
    • Switched Radio Block (SRB) Loopback Connection Type
      For more details refer to CALL:FUNCtion:CONNection:TYPE .
    • Uplink Frame Segmentation
      For more details refer to CALL:MS:TX:FRAMe:SEGMentation .
  • The following broadcast channel configuration options have been added:
    • The ability to set the MSC/SGSN Revision to "Release 98 or older" or "Release 99 onwards". For more details, refer to CALL[:CELL]:BCHannel:MSCRevision .
    • The ability to indicate to the mobile station that the cell is DCS or PCS to account for the ARFCN numbers shared by the two bands. For more details, refer to CALL[:CELL]:BINDicator .

Measurements

  • The following measurements provide support for both GMSK and 8PSK EGPRS modulation coding schemes (MCS1 through MCS9):
    • EGPRS Transmit Power
      For more details refer to EGPRS Transmit Power (ETXP) Measurement .
    • Block Error
      For more details refer to Block Error Measurement .
    • Output RF Spectrum
      For more details refer to Output RF Spectrum Measurement Description .
    • Power versus Time
      For more details refer to Power versus Time Measurement Description .
    • Phase and Frequency Error
      For more details refer to Phase and Frequency Error Measurement Description .
  • The following measurements provide support for GMSK EGPRS modulation coding schemes (MCS1 through MCS4):
    • Dynamic Power
      For more details refer to Dynamic Power Measurement Description .
    • I/Q Tuning
      For more details refer to I/Q Tuning Measurement Description .
  • The following measurements provide support for 8PSK EGPRS modulation coding schemes (MCS5 through MCS9):
    • EGPRS Modulation Accuracy
      For more details refer to Modulation Accuracy Measurement Description .
  • Modulation Format Control has been added to specify which modulation format is to be measured. See Modulation Format Control (EGPRS only) for more information.
  • The BLER measurement has been enhanced to include BLER measurement results by timeslot. For more details, refer to BLER Measurement Results by Timeslot . The new command added for this feature is:
    • FETCh:BLERror:BURSt<[1]|2|3|4|5>[:ALL]? .

General

  • The ability to save and recall settings has been added. See Save and Recall Registers for more information.

_____________________________________________________________________________________________________

A.02.10 Release - July 2003

A downloadable version of the Online User's Guide (CHM Help File) that is specific to this release is available at:

http://www.home.agilent.com/upload/cmc_upload/All/E1968A_A02_E6701C_C01_E6704A_Ref_Guide.chm

NOTE: To properly view the CHM Help File, you must save it to your desktop (rather than "Open" it from the Internet). For Windows XP, you must also then right-click on the file and select Properties>>Unblock.

This release adds the multi-tone audio instrument for testing GSM mobile stations' speakers and microphones. See Multi-tone Audio Measurement Description for more information.

_____________________________________________________________________________________________________

A.01.20 Initial Release - January 2003

The reference guide for this release is available at the following web location. Note This is a 24.4 MB .pdf file.

http://cp.literature.agilent.com/litweb/pdf/1000-1859.pdf

There is also a .chm format of the user's guide for this release available at:

http://www.home.agilent.com/upload/cmc_upload/All/E1968A_A01_E6701C_C01_E6704A_Ref_Guide.chm

NOTE: To properly view the CHM Help File, you must save it to your desktop (rather than "Open" it from the Internet). For Windows XP, you must also then right-click on the file and select Properties>>Unblock.

This initial release combines the existing E1960A GSM Mobile Test Application version A.10.20 and the E1964A GPRS Mobile Test Application version A.04.20 into one GSM/GPRS Mobile Test Application (E1968A).

Hardware Requirements

  • E5515A does not support E1968A.

  • E5515B will support E1968A without a hardware upgrade under the following conditions:

    • Option 002 installed AND serial number is >= US40350362 or >= GB40470454, or
    • the test set is already running E1985A Fast Switching with GSM and/or GPRS.

  • Instruments with Serial Numbers prior to US40350362 or GB40470454 (with option 002 installed) can be upgraded with upgrade product number E5515BU option 085 to be able to support the E1968A.

  • E5515C requires option 002 to support the E1968A.

E1968A Functionality/License Summary

The E1968A is an integrated GSM/GPRS TA which replaces the E1960A GSM TA and the E1964A GPRS TA. There is no need for the E1985A/B to enable fast switching between GSM and GPRS as was required with the old E1960A and E1964A test applications. The E1968A contains both GSM and GPRS components and allows access to both components without the need to perform an explicit format switch (providing each component is licensed). If the E1968A has a GSM license, GSM calls are supported; if a GPRS license is present, GPRS data connections are supported; if both licenses are present, there is access to all capabilities. An added benefit of the integrated GSM and GPRS in the E1968A GSM/GPRS Mobile Test Application is there is no loss of BCH when going from GSM to GPRS testing or vice-versa; this allows the mobile to stay camped/attached.

Product Number/License summary:

  • E1968A, GSM/GPRS Mobile Test Application, shell product, no technologies enabled

  • E1968A-101 GSM Functionality, enables GSM

  • E1968A-102 GPRS Functionality, enables GPRS

  • E1968A-201 GSM and GPRS Functionality, enables both GSM and GPRS

Issues that can affect compatibility and test times changing from E1960A and/or E1964A to the E1968A

  • Hardware compatibility - see Hardware Requirements above

  • Prior single-partition (E1960A and E1964A) and fast switching (E1985A/B) will not run on future test sets

  • Technologies must be licensed within the E1968A to gain their functionality

  • Compatibility of GPIB commands from E1960A/E1964A to E1968A is maintained where possible however, some GPIB changes were required as well as the added improvements to test features in the E1968A

  • Overlapped commands in the E1968A are not equivalent to those in the E1960A/E1964A. In many E1968A commands they are no longer needed and will only slow the test run when running old overlapped GPIB command code on the E1968A. This has been improved in the E1968A by new commands/methods for channel reconfiguration which possibly produce a reduction in test times.

Advantages to integrating, qualifying and moving to the E1968A

  • All future GSM, GPRS and EGPRS (EDGE) test applications and lab applications will be based on this format. Follow-on versions of the E1968A will incorporate new features but the E1960A GSM and E1964A GPRS Mobile Test Applications will not be updated.

  • The new GSM, GPRS and EGPRS (EDGE) format applications have a new firmware architecture that improves application performance.

  • The new E1968A combined format provides the potential for a reduction in test times.

  • The new E1968A combined format provides improvements to measurements and measurement features.

  • Using the E1968A will not require a format switch for GSM, GPRS, and EGPRS (EDGE) testing because all of these formats are integrated in the E1968A.

GSM Functionality Now Available in GPRS

  • IQ Tuning and Dynamic Power measurements are now available in GPRS. See SETup:IQTuning and SETup:DPOWer .

  • PFER CIFT functionality

  • Expected Burst Type RACH supported in test mode.

    CALL:BURSt:TYPE[:SELected]

  • The following network parameters may now be configured in the GPRS TA (previously available only in the
    GSM TA and GPRS LA): MCC, MNC, LAC, RAC, NCC, BCC. See the following respective commands:

    CALL:MCCode

    CALL:MNCode

    CALL:LACode

    CALL:RACode

    CALL:NCCode

    CALL:BCCode

  • Repeat Paging may be enabled or disabled

    CALL:PAGing:REPeat[:STATe][:SELected]

  • Display IMSI and IMEI (previously available only in the GPRS LA)
    Note: IMEI is not currently displayed in the GPRS TA.

    CALL:MS:REPorted:IMSI?

    CALL:MS:REPorted:IMEI?

  • Report supported bands information (RUI only)

    CALL:MS:REPorted:SBANd[:GMSK]?

    CALL:MS:REPorted:SBANd:EPSK?

  • Display power class reported by the class mark message

    CALL:MS:REPorted:PCLass:GSM?

    CALL:MS:REPorted:PCLass[:SELected]?

  • Display power class reported for each band by both GSMK and EPSK (8PSK - EDGE) modulation schemes.

    CALL:MS:REPorted:PCLass:EPSK[:SELected]?

    CALL:MS:REPorted:PCLass:(DCS|EGSM|GSM450|GSM480|GSM750|GSM850|PCS|PGSM|RGSM|TGSM810)?

    CALL:MS:REPorted:PCLass[:SELected]?

    CALL:MS:REPorted:PCLass:GMSK:(DCS|EGSM|GSM450|GSM480|GSM750|GSM850|PCS|PGSM|RGSM|TGSM810)?

  • Display corrupt burst, page count, decode error, missing burst information

    Note: Page counter is not relevant for GPRS data connections.

  • Audio Generator instrument

    AFGenerator

GPRS Functionality Now Available in GSM

  • Auxiliary RF Output port

  • Power in unused bursts

    CALL:TCHannel:PREDuction:UBURst

Additional Functionality Changes

  • The GPRS Data Connection Type setting has been renamed to Connection Type and has been extended by adding an Auto option (GSM TA and GSM/GPRS LA only)

    CALL:FUNCtion

  • Over-lapped command functionality no longer available in GSM for some commands and is replaced by deferred parameter handover scheme as in GPRS

  • Operating Mode command extended to add GSM BCH, GSM BCH+TCH, and CW modes. GSM banded RFGenerator commands removed.

    CALL:OPERating

  • Display mobile multi-slot class if available. Multislot class is obtained during the attach procedure so isn't available to the GSM TA.

    CALL:MS:REPorted:MCLass:EGPRS[:SELected]?

    CALL:MS:REPorted:MCLass:EGPRS:(DCS|EGSM|GSM450|GSM480|GSM750|GSM850|PCS|PGSM|RGSM|TGSM810)?

    CALL:MS:REPorted:MCLass:GPRS[:SELected]?

    CALL:MS:REPorted:MCLass:GPRS:(DCS|EGSM|GSM450|GSM480|GSM750|GSM850|PCS|PGSM|RGSM|TGSM810)?

GPIB Command Changes Resulting From Combining the E1960A and the E1964A into the E1968A GSM/GPRS Mobile Test Application

  • E1968A GSM/GPRS GPIB COMMAND CHANGES

Other

Control over the power used by the mobile station for access bursts has been added to this release. For more details, refer to Access Burst Power Control


Analog Audio Troubleshooting

Analog Audio Troubleshooting

Possible Setup Issues

During remote operation of the analog audio measurements, you should always set the Trigger Arm to Single. The length of time required to return a measurement over GPIB using continuous triggering varies, but is always longer than when using single triggering. Continuous triggering can also cause problems when the INITiate:DONE? is used.

If any other measurements are active, turn them off or set their trigger source to Immediate.

The Detector Type selected (Peak or RMS) also sets how analog audio level measurements are displayed; as a peak value or an rms value. When comparing returned values over GPIB to your specifications, be sure to take into account the type of detector being used.

The Expected Peak Voltage is always set in V peak , regardless of the Detector Type selected, and cannot exceed 20 V peak (14.1 V rms ).

For accurate measurements, always set all the analog audio measurement setup parameters to their proper settings for the measurement being made. The SINAD and Distortion measurements typically use different settings than the analog audio level measurement. See Analog Audio Measurement Description and Analog Audio Measurement Block Diagram .

For very low level audio signals, use the 100 Hz BW BPF filter to reduce the effects of noise (see Audio Level Measurement Description ).

For accurate analog audio frequency measurements where more than one signal may be present, use the 100 Hz BW BPF filter to isolate the desired signal (see Audio Level Measurement Description ).

Interpreting Integrity Indicator Values

See Integrity Indicator .

If over range (5) is returned, the input level is greater than 4.9 dB above the Expected Peak Amplitude value or the maximum input level of 20 volts peak.

If under range (6) is returned, the input level is lower than 8 dB below the Expected Peak Amplitude value.

If the signal has both over range and under range conditions, only the over range condition (5) is indicated.


Error Message Log

Error Message Log

December 3, 2008

Description

When an error message is displayed, it is also logged in the error message log. This log is only accessible manually; it is not available through GPIB. The error message log can be displayed by pressing the F7 menu key from the SYSTEM CONFIG screen. Next Page and Previous Page controls are provided.

All errors and events that are generated are displayed in the error message log. When the log is full a new message is sent to the log and the oldest message is removed from the log. The log is cleared when the test set powers up or when you press F10 (Clear Error Message Log).

Related Topics

Error Messages


Bit Error Troubleshooting

Bit Error Troubleshooting

GSM Bit Error Troubleshooting

During remote operation of the bit error measurement you should configure the trigger arm to single, see SETup:BERRor:CONTinuous .

If the trigger arm is not set to single, the measurement may not return a result. When trigger arm is continuous the measurement rearms itself and starts another measurement cycle, during remote operation the fetch query may not be synchronized to the measurement cycle, see
Measurement States .

If you have a BER measurement active and your mobile drops the call it may be that you have the SETup:BERRor:SLControl[:STATe] command set to OFF. This is likely to occur with mobiles that do not respond to downlink signalling when loopback is closed. To solve this problem set the command to ON.

If a GSM voice call is active and the Measurement Type is set to Data or Residual Data, no results are returned by the measurement because it can not sync to the signal being looped back from the mobile station. Change the Measurement Type to an appropriate value.

If a GSM circuit switched data (CSD) call is active and the Measurement Type is not set to Data or Residual Data, no results are returned by the measurement because it can not sync to the signal being looped back from the mobile station. Change the Measurement Type to an appropriate value.

GPRS Bit Error Troubleshooting

The error correction which is a feature of channel coding scheme CS-1 will mask low to medium bit error rates if used during GBER measurements. This will result in measurement results which are not ideal. Therefore, CS-4 is the recommended coding scheme for GBER measurements. You use the command CALL:(PDTCH|PDTChannel):CSCHeme:UPLink to set the channel coding scheme.

During remote operation of the GPRS bit error measurement you should configure the trigger arm to single, see SETup:GBERror:CONTinuous .

The GBER measurement only provides results when the test set's operating mode is:

  • GPRS BCH+PDTCH test mode, or
  • Active Cell, and the Data Connection Type is set to ETSI Type B or ETSI Type B Acknowledged. For details on setting the Connection Type see CALL:FUNCtion:CONNection:TYPE . For details on setting the cell operating mode, see CALL:OPERating:MODE .

GBER measurements cannot be run concurrently with SRB Loopback BER or BLER measurements. The test set closes the GBER measurement if you start either the SRB Loopback BER or BLER measurement while it is running.

EGPRS SRB Bit Error Troubleshooting

Possible Setup Issues

During remote operation of the bit error measurement you should configure the trigger arm to single, see SETup:SBERror:CONTinuous .

If the trigger arm is not set to single, the measurement may not return a result. When trigger arm is continuous the measurement rearms itself and starts another measurement cycle, during remote operation the fetch query may not be synchronized to the measurement cycle, see
Measurement States .

SBER measurements cannot be run concurrently with GBER or BLER measurements. The test set closes the SBER measurement if you start either the GBER or BLER measurement while it is running.

When the operating mode is EGPRS BCH+ PDTCH and the each burst in the downlink is assigned an MCS/PS, the GBER and the SBER measurements may not give accurate results. This is because they are not able to synchronize and calculate a BER if the downlink and the uplink slot being compared do not have the same length of data bytes. For example, if the downlink has MCS5/P1 on burst 1 and MCS3/P2 on burst 2, and the uplink has MCS5 on burst 1 and MCS4 on burst 2, then only burst 1 can be used to calculate the BER. An attempt to calculate the BER on burst 2 makes the measurement either not synchronize or have a large BER.

Unexpected BER results

The EGPRS SRB Bit Error rate measurement does not currently support Asymmetric SRB Loopback. If you have the uplink configured to use a different modulation format than the downlink, you may see very large BER results that you did not expect. When the number of bits in the received data blocks is different from the number transmitted on the downlink, the test set treats each bit that was originally transmitted on the downlink as an error.

To correct this problem, configure the Downlink Modulation Coding Scheme parameter in the test set to use the same modulation format as either the Uplink Modulation Coding Scheme parameter in the test set or, if you are using EGPRS BCH+PDTCH test mode, the modulation format you have configured your mobile station to use for the uplink.

MCS-1 through MCS-4 use GMSK modulation. MCS-5 through MCS-9 use 8PSK modulation.

See Test Set Configuration for instructions on manually configuring the test set's parameters.

For information on programmatically changing the modulation coding scheme parameters, see CALL:(PDTCH|PDTChannel):MCSCheme or, if you are using EGPRS BCH+PDTCH test mode, see CALL:(PDTCH|PDTChannel):MCSCheme:EBPTest:BURSt<2|3|4|5> .

Interpreting Integrity Indicator values

See Integrity Indicator .


Block Error Troubleshooting

Block Error Troubleshooting

Possible Setup Issues

This measurement is not applicable to GSM.

To run this measurement ensure the test set is configured for GPRS or EGPRS measurements.

GPRS

The error correction which is a feature of channel coding scheme CS-1 will mask low to medium block error rates if used during BLER measurements. This will result in measurement results which are not ideal. Therefore, CS-4 is the recommended coding scheme for BLER measurements. You use the command CALL:(PDTCH|PDTChannel):CSCHeme:UPLink to set the channel coding scheme.

During remote operation of the block error measurement you should configure the trigger arm to single, see SETup:BLERror:CONTinuous .

The BLER measurement only provides results when the test set's operating mode is:

  • GPRS BCH+PDTCH test mode, or
  • Active Cell, and the Data Connection Type is set to ETSI Type B, ETSI Type B Acknowledged, or BLER. For details on setting the Connection Type see CALL:FUNCtion:CONNection:TYPE . For details on setting the cell operating mode, see CALL:OPERating:MODE .

Changing the test set's operating mode while a block error measurement is running causes the measurement to abort and restart.

Any change to the multislot configuration or the channel coding scheme affects the rate at which bits are tested. Increasing the number of uplink timeslots per frame enables more blocks to be tested per second, whereas decreasing the number of uplink timeslots per frame reduces the number of blocks that can be tested per second. Changing the coding scheme does not affect the rate at which blocks can be tested, but does alter the performance of the link. In order to correctly handle these changes, the BLER measurement aborts and restarts whenever a multislot configuration or channel coding scheme change occurs.

BLER measurements cannot be run concurrently with BER measurements. Starting a BLER measurement while a BER measurement is currently running, closes the BER measurement.

EGPRS

During remote operation of the block error measurement you should configure the trigger arm to single, see SETup:BLERror:CONTinuous .

The BLER measurement only provides results when the test set's operating mode is:

  • EGPRS BCH+PDTCH test mode, or
  • Active Cell, and the Data Connection Type is set to ETSI Type B (unacknowledged), ETSI Type B Acknowledged, or BLER. For details on setting the Connection Type see CALL:FUNCtion:CONNection:TYPE . For details on setting the cell operating mode, see CALL:OPERating:MODE .

Changing the test set's operating mode while a block error measurement is running causes the measurement to abort and restart.

Any change to the multislot configuration or the modulation coding scheme affects the rate at which bits are tested. Increasing the number of uplink timeslots per frame enables more blocks to be tested per second, whereas decreasing the number of uplink timeslots per frame reduces the number of blocks that can be tested per second. Changing the modulation coding scheme does not affect the rate at which blocks can be tested, but does alter the performance of the link. In order to correctly handle these changes, the BLER measurement aborts and restarts whenever a multislot configuration or channel coding scheme change occurs.

BLER measurements cannot be run concurrently with BER measurements. Starting a BLER measurement while a BER measurement is currently running, closes the BER measurement.

Interpreting Integrity Indicator values

See Integrity Indicator .


Cell Broadcast Service (CBS) Troubleshooting

Cell Broadcast Service (CBS) Troubleshooting

Description

The Wireless Protocol Advisor (WPA) attempts to decode any messages as text when the Data Coding Scheme value is set to a value that corresponds to text. If the content of the CBS message being transmitted is data (not text), the WPA still attempts to decode the message as text which will not be accurate. You must ensure that Data Coding Scheme is set to an appropriate value.

Related Topics

Cell Broadcast Service (CBS)


Troubleshooting External Device Connection

Troubleshooting External Device Connection

Description

  • When connecting two 8960s, it is recommended that you connect them via a hub, rather than through a gateway or WAN link, or connect them directly using a LAN crossover cable. This helps minimize the risk of lost data due to delayed packets.
  • Before initiating an external device connection between two 8960s, you can verify that the two test sets are able to communicate by pinging one test set from the other. To do so, on 8960 #1:
    • Press the Call Setup key, then the left More key until the Ping menu is available.
    • Select Ping , then Ping Setup ( F1 ).
    • Set Device to Ping to Alternate ( CALL:DATA:PING:SETup:DEVice ).
    • Set the Alternate Ping Address to the IP address of 8960 #2 ( CALL:DATA:PING:SETup:ALTernate:IP:ADDRess ).
    • Select Start Ping ( F3 ) ( CALL:DATA:PING:STARt ).
  • When you select Connect to External 8960 , if the External Device Conn Status moves from Not Connected through several other states ( Connecting/ Connected /Disconnecting ) and then immediately back to Not Connected , check both 8960s for an error condition. The 8960 to which you are attempting to connect may not have the hardware or license required for the External Device Connection feature, or may have incompatible firmware. (The underlying architecture of the External Device Connection feature has changed over time. The implementations are not compatible. To establish an External Device Connection between two test sets, the test sets must have compatible firmware (see www.agilent.com/find/8960upgrades for more information)).
  • Ensure that Ext 8960 IP Addr on the 8960 originating the connection is equal to the LAN IP Address of the 8960 you wish to connect to (the LAN IP Address of each 8960 is shown in the LAN Connection Information window of the External Device Connection Setup screen as LAN (Self) IP Address , and also viewable/settable from the Instrument Setup ( F1 ) menu of the System Config screen).
  • Ensure that Subnet Mask and Default Gateway are configured properly for each test set.
  • Ext 8960 IP Addr and Connected Device IP Address will always be equal on the display of the test set that initiated the external device connection. However, Ext 8960 IP Addr and Connected Device IP Address can be different on the test set that was connected to, as Ext 8960 IP Addr is only used when initiating an external device connection.
  • Ext 8960 IP Addr can not be set to the same value as LAN IP Address or DUT IP Address . If LAN IP Address is set to the value of Ext 8960 IP Addr , Ext 8960 IP Addr is reset to a blank field.
  • The external device connection is not affected by a partial preset. However, the external device connection is disconnected as a result of a full preset.

Related Topics

How Do I Make an External Device Connection?


GPRS Data Connection Troubleshooting

GPRS Data Connection Troubleshooting

This section is not applicable to GSM or EGPRS.

Problems Getting the Mobile to Perform a GPRS Attach

If you have problems getting the mobile to perform a GPRS Attach, try working through some or all of the following troubleshooting hints:

  • Ensure that a GSM Test SIM card, or a standard GSM SIM card is installed correctly and is working properly.
  • Some mobiles may not perform a GPRS attach automatically. You may have to instruct the mobile to go into a data mode. The method for doing this varies from one mobile to another. For example, you may have to press a key on the mobile's keypad, or make a selection from the mobile's on-screen menu system.
  • Ensure that any cable loss or gain between the test set's RF IN/OUT front panel connector and the mobile's RF connector is correctly specified in the RF IN/OUT Amplitude Offset table (see Amplitude Offset or How Do I Configure the Test Set for My Test System? ).
  • Check that the cell power is set to a level that is sufficient to overcome any interference (for example,
    -35 dBm), especially if an indirect RF connection is being used between the test set and the mobile (see CALL:POWer ).
  • Try using coding scheme CS-1 which has the highest degree of error correction (see CALL:(PDTCH|PDTChannel):CSCHeme:UPLink ). To set the coding scheme manually, press the More key to access the Call Parms menu ( 2 of 3 ), then press the Coding Scheme ( F11 ) key.
  • Ensure that you have selected a multislot configuration that your GPRS mobile supports (see CALL:(PDTCH|PDTChannel):MSLot:CONFig ). Try starting with a multislot configuration of 1 down, 1 up (D1U1) because all GPRS mobiles support this configuration. Initially, you should avoid using a multislot configuration with two uplinks because fewer mobiles support more than one uplink. To set the multislot configuration manually, press the More key to access the Call Parms menu ( 3 of 3 ), then press the Multislot Config ( F7 ) key.
  • Verify that your mobile supports the test set's default frame numbering scheme (starting position) setting. The default is RELative which your mobile may not support. Try the ABSolute or IMMediate settings (see CALL:FUNCtion:DATA:FRAMe:STARt ). To set the frame numbering scheme manually, press the More key to access the Control menu ( 2 of 2 ), press Protocol Control ( F4 ), RLC/MAC ( F1 ), then press the Frame Start Pos ( F5 ) key.

Problems Establishing a BLER Data Connection

If you have problems establishing a data connection using the BLER Data Connection Type specifically, you may want to change the setting of the LLC Frame Check Sequence (see CALL:FUNCtion:DATA:BLER:LLC:FCSequence ) or the BLER Block Polling Interval (see CALL:FUNCtion:DATA:BLER:POLLing:INTerval ).

For example, if your mobile is not capable of a high level of GMM_INFORMATION messaging (the type of messaging used to stimulate the mobile to send ACK/NACK responses to the test set), then the data connection will timeout. One possible solution to this is to set the LLC Frame Check Sequence to CORRupt preventing the messaging while still forcing the mobile to send ACK/NACK responses. The BLER Block Polling Interval is the rate at which the RLC/MAC blocks have the MAC header poll bit set, forcing a response (Packet Downlink ACK/NACK) from the mobile.

To change the LLC Frame Check Sequence or BLER Block Polling Interval settings manually, press the More key to access the Control menu ( 2 of 2 ), then press the Protocol Control ( F4 ) key. Block Poll Rate is available under the RLC/MAC ( F1 ) key and BLER FCS is available under the LLC ( F2 ) key. Select a parameter and change its setting.

Problems with Measurements in ETSI Test Mode A or B

In order to perform measurements in Active Cell operating mode with the Data Connection Type set to ETSI Type A or ETSI Type B test modes, your mobile must fully support these connection types as defined in the standards. ETSI Type B is required if you want to perform BER measurements in active cell mode.

You can specify the first downlink burst to be looped back in the first uplink burst using the command CALL:(PDTCH|PDTChannel):MSLot[:FIRSt]:DOWNlink:LOOPback[:BURSt] .

In ETSI Type B test mode, the BLER measurement is performed using a different method from that used when the test set's data connection type is set to BLER. For more details on the BLER measurement see Block Error Measurement .


Decoded Audio Troubleshooting

Decoded Audio Troubleshooting

Possible Setup Issues

This measurement is not applicable to GPRS. To run this measurement ensure the test set is configured for GSM measurements.

During remote operation of the analog audio measurement you should configure the trigger arm to single, see SETup:DAUDio:CONTinuous .

If the trigger arm is not set to single, the measurement may not return a result. When trigger arm is continuous the measurement rearms itself and starts another measurement cycle, during remote operation the fetch query may not be synchronized to the measurement cycle, see Measurement States .

The audio signal expected by the DAUDio measurement is, pulsed at a 10 Hz rate and has a 50% duty cycle. The device under test should have echo cancellation disabled.

The signal measured is whatever is coming back in the speech frames, this includes any electrical or acoustical coupling from the downlink signal, earpiece or any noise coupled from the microphone of the MS.

Interpreting Integrity Indicator values

See Integrity Indicator .

If PCM Full Scale Warning (14) is returned the measurement is accurate, however you may want to reduce the signal level applied to the test set to achieve an integrity indicator of zero.

If the DAUDio measurement is active when the channel mode is set to EFRSpeech (see CALL:TCHannel:CMODe[:VALue] ), Questionable Result Due To Channel Mode (16) is returned. This is because the DAUDio measurement is not supported in this channel mode.


Troubleshooting Dual Transfer Mode

Troubleshooting Dual Transfer Mode

According to 3GPP TS 03.55 Version 8.4.0, any TCH Assignment message received on the FACCH by a mobile station during a DTM session will result in the mobile station aborting the current packet data connection. The default setting is for the test set to send TCH Tx Level assignments to the mobile station on a TCH assignment message sent on the FACCH.

However, when the DTM is triggered, the TCH MS Tx Level parameter has no effect on the DUT. DTM CS MS Tx Level parameter is used in the circumstance. When FACCH level signaling is enabled (default), changing the TCH MS Tx Level parameter will cause a DTM Assignment to be sent to the DUT. When FACCH level signaling is disabled, the change to the TCH MS Tx Level parameter via SACCH signaling will be stored but not applied until the DTM session ends. The DTM CS MS Tx Level parameter has no effect when DTM is not triggered.

The GPIB command to set FACCH level signaling is CALL:TCHannel:(FACCH|FACChannel):MS:TXLevel .

Related Topics

Dual Transfer Mode

Dual Transfer Mode Concepts


Dynamic Power Troubleshooting

Dynamic Power Troubleshooting

Possible Setup Issues

The Dynamic Power measurement closes all other currently active measurements when it is initiated. When this happens, the test set beeps and a measurement specific closure warning is reported via GPIB for each measurement that has been closed (see +700 to +799 Test Application Measurement Device-Specific Error ).

Interpreting Integrity Indicator Values

See Integrity Indicator .


EDGE Dynamic Power Troubleshooting

EDGE Dynamic Power Troubleshooting

Possible Setup Issues

The EDGE Dynamic Power (EDP) measurement parameter set up parameters and results are only accessible via the GPIB interface.

When the EDP measurement is initiated it aborts and closes all other measurements that are currently running.

The EDP measurement only supports measurement on normal bursts in a single slot configuration. Measurement of RACH bursts is not supported.

All bursts in the ramp segment must be generated at the same frequency.

The Expected Maximum Difference (EMD) between power levels of successive bursts is given in dB. This value must be accurate for meaningful measurement results.

If the Expected Modulation Format is GMSK, the measurement method will always be Burst Power. For information on changing the Expected Modulation Format see Modulation Format Control (EGPRS only) .

Although no integrity values indicating a burst was over or under range are returned as long as the measured power for a particular burst is within 6 dB of the expected power, the measurement accuracy is only guaranteed if the measured power is within 3 dB of the expected power.

The EDP measurement employs midamble synchronization for both GMSK and 8PSK modulation formats, however it will complete with out the presence of a midamble. When a midamble is not found, integrity indicator 11 is returned.

Interpreting Integrity Indicators

See Integrity Indicator

Related Topics

EDGE Dynamic Power (EDP) Measurement


EGPRS Connection Troubleshooting

EGPRS Connection Troubleshooting

Problems using ETSI Type A Connection Type

If you are seeing your EGPRS connections "timeout" when using the ETSI Type A connection type, you may need to change the EGPRS Demodulation Type to Normal. See EGPRS Demodulation Type .

When the EGPRS Demodulation Type is Reduced, the test set only demodulates the uplink periodically. The mobile station sends a Countdown Value (CV) on the uplink which indicates how many more blocks the mobile station is sending on the existing TBF. As specified in GSM 04.60 Sec. 9.3.1 "Countdown procedure", once the number of untransmitted blocks is less than 15, the mobile station should begin to send the specific number of blocks left. When the CV is a value other than 15, the test set recognizes that the mobile station is about to release the TBF. At this point the test set uses only normal demodulation and restarts the TBF when it is released. If the test set does not receive a value other than 15 for the CV on the uplink, it returns to using reduced demodulation and the TBF is not restarted after the mobile station releases it, resulting in the connection timing out.


Modulation Accuracy Troubleshooting

Modulation Accuracy Troubleshooting

This section is applicable only to EGPRS

Possible Setup Issues

The serving cell must be set to EGPRS and an EGPRS data connection must be active. The test set's default serving cell is GPRS. See Serving Cell for more information.

The modulation accuracy measurement can only be used on signals using 8PSK modulation. Therefore, the modulation and coding scheme used must be MCS-5, MCS-6, MCS-7, MCS-8, or MCS-9, which all use 8PSK modulation. (See CALL:(PDTCH|PDTChannel):MCSCheme . The other MCS use GMSK modulation.

If you are using a connection type other than Auto, you must have the mobile station configured to perform a GPRS attach automatically or you must force one before you can start a data connection from the test set. The mobile station may have a connectivity setting for GPRS that allows you to configure it to always be on-line rather than use GPRS as needed.

During remote operation of the modulation accuracy measurement you should configure the trigger arm to single, see SETup:EMACcuracy:CONTinuous .

If the trigger arm is not set to single, the measurement may not return a result. When trigger arm is continuous the measurement rearms itself and starts another measurement cycle, during remote operation the FETCh query may not be synchronized to the measurement cycle, see Measurement States .

If the Trigger Source is set to RF Rise and the signal measured is not burst modulated the measurement will wait until aborted or timed out.

If the input signal does not rise above the threshold set at 20 to 30 dB below the Expected Power, see Expected Power Control there is not enough power to generate an RF Rise trigger so the measurement may hang.

Interpreting Integrity Indicator values

See Integrity Indicator .

If over range (5) is returned; the input power has exceeded the test set's internal sampler maximum value during some part of the sampling or the input power has exceeded the calibrated range of the test set's power detector for the RF Range setting. RF Range is automatically set based on the input power setting. Input power is a combination of amplitude offset and expected power settings. See Mobile Station Receiver Example .

If the signal has both over range and under range conditions only the over range (5) will be indicated.

If under range (6) is returned; the input power is more than 2 dB below the calibrated range of the test set's power detector for the RF Range setting. RF Range is automatically set based on the input power setting. Input power is a combination of amplitude offset and expected power settings. See Mobile Station Receiver Example .

Sync Not Found (11) is returned if a valid midamble cannot be found. In test mode, you must set the midamble to be used with the burst type parameter. See CALL:BURSt:TYPE[:SELected] . You may also see this error if you do not have the amplitude offsets configured correctly. See Amplitude Offset for more information.

If the burst is not continuous in a flexible timeslot configuration, for example, if the total number of uplink bursts is 6 and the bursts are transmited in TS0, TS1, TS2, TS4, TS5 and TS6 respectively, then valid results will be returned for burst 1, 2, and 3, Sync Not Found (11) will be returned for burst 4, 5, 6 and 7.

Unsupported Configuration (22) is returned if a base station emulator parameter is set incorrectly for this measurement. This error is returned if the modulation and coding scheme parameter is set to an MCS which does not use 8PSK modulation. Additionally, this error is returned if the connection type is set to BLER, as the PACCH is used for all signaling and control channels all use GMSK modulation.

Related Topics

Modulation Accuracy Measurement Description


Error Messages

Error Messages

Error Message Descriptions

Fixed Timer Messages

Manual User Error Messages

-400 to -499 Query Errors

-300 to -399 SCPI Specified Device-Specific Errors

-200 to -299 Execution Errors

-100 to -199 Command Errors

+100 to +199 Core Device-Specific Error

+200 to +299 Call Processing Device-Specific Error

+300 to +399 Link Control Device-Specific Error

+400 to +499 Core Hardware Device-Specific Error

+500 to +599 Test Application Hardware Device-Specific Error

+600 to +699 Instrument Device-Specific Error

+700 to +799 Test Application Measurement Device-Specific Error

+800 to +899 Core Measurement Device-Specific Error

Description

Reading Error Messages

When an error occurs, an error message is shown in a message window at the center of the test set's display. When an error message is displayed, an audio beep occurs; the beeper state of the test set can be set to on or off. Error messages can be cleared from the test set's display using the DISPlay:WINDow:ERRor:CLEar command, or *CLS. Pressing any functional front panel key, i.e. the LOCAL key, will also clear an error message from the test set's display.

Each error message that is generated is recorded in either the error/event queue or the message log or both.

The error/event queue is read remotely using the SYSTem:ERRor? query. The error/event queue is able to hold 100 messages. The SYSTem:ERRor? query returns one error message at a time. As an error message is queried, it is removed from the error queue. To read the entire error/event queue (and thus also clear the error queue) use the following program.

10 DIM Err_msg$[255]
20 REPEAT
30 OUTPUT 714;"SYSTEM:ERROR?"
40 ENTER 714; Err_num,Err_msg$
50 PRINT Err_num,Err_msg$
60 UNTIL Err_num = 0

You can also clear the error queue by sending *CLS or *RST or by cycling the test set's power.

The message log may be viewed on the test set's display by pressing the SYSTEM CONFIG screen's Message Log key. The message log can display up to 24 entries over two pages. To clear the message log, select Clear Message Log ( F10 ), or cycle the test set's power.

Because the error queue and Message Log can be cleared independently, their contents may differ.

Classes of Errors

Error messages are divided into classes, each class of error is handled differently by the test set. The message log is cleared when the test set is power cycled.

Measurement Integrity Indicators

These messages occur as a result of a measurement, they indicate the validity of the measurement. Measurement integrity indicators are read with the FETCh command.

Non-Persistent Errors

These messages are generated when a condition occurs that is incorrect, but has no serious or long lasting effect on the test set's operation. Examples could include an out of range value to a parameter, or an invalid GPIB mnemonic. The message window is cleared when any front panel key is pressed.

Persistent Errors

These errors are generated when a non-transitory error condition exists. Persistent errors occur when a hardware failure is found, or when damage or injury to a person or the test set may occur.

The test set displays these errors in the error message window and as a prompt at the bottom of the display screen where it remains until the error condition no longer exists.

Fatal Errors

When these errors occur no further operation of the test set is possible without cycling the power switch. Fatal errors are not saved in the error message log. The test set display will provide the user with information about what to do next and some details about what the test set was doing when the fatal error occurred.

Maskable Messages

These messages are intended to inform the user of a condition within the test set. They are generally meant to provide information to the user. The user will need to decide if this condition is undesirable and if they want the message to appear.

Maskable Message Display State

The Maskable Messages Display State found in the Instrument Setup menu gives users a way to block these messages and the associated beep from ever happening. When the state is Off these messages and their associated beep will be blocked. The Maskable Message Display State can be set manually or with the following GPIB command:

OUTPUT 714;"DISPLAY:MESSAGE:MASKABLE:STATE OFF"
! Prevents certain messages from appearing on the display.

Instrument Maskable Messages

  • Instrument warning: Audio Generator instrument has been closed.
  • Instrument warning: Audio Analyzer instrument has been closed.
  • Instrument warning: Analog Audio instrument has been closed.

GSM Mobile Test Maskable Messages

  • GSM measurement warning; TX Power measurement has been closed.
  • GSM measurement warning; Power vs Time measurement has been closed.
  • GSM measurement warning; Phase Frequency Error measurement has been closed.
  • GSM measurement warning; Output RF Spectrum measurement has been closed.
  • GSM measurement warning; Fast Bit Error measurement has been closed.
  • GSM measurement warning; Decoded Audio measurement has been closed.
  • GSM measurement warning; IQ Tuning measurement has been closed.

GPRS Mobile Test Maskable Messages

  • GPRS measurement warning; TX Power measurement has been closed.
  • GPRS measurement warning; Power vs Time measurement has been closed.
  • GPRS measurement warning; Phase Frequency Error measurement has been closed.
  • GPRS measurement warning; Output RF Spectrum measurement has been closed.
  • GPRS measurement warning; Bit Error measurement has been closed.

Related Topics

SYSTem:COMMunicate:GPIB:DEBug[:STATe]

Test Set Beeper

SYSTem:ERRor?

DISPlay:WINDow:ERRor:CLEar

DISPlay:MESSage:MASKable:STATe

Integrity Indicator

FETCh? Subsystem


Fixed Timer Messages

Fixed Timer Messages

This is the list of fixed timers with a brief explanation and their values. A timer expiry message appears in its own window, on the test set display. The user has no access to these values and can not change them. None of the fixed timers are active when operating mode is Test Mode.

Timer Name | Description | Value
T100 RADIO-LINK-TIMEOUT | Detects the presence of the radio link by detecting SACCH frames every 480 ms. | 4 SACCH multiframes. That is 1.92 seconds if the SACCH is completely absent.
T200 Data link timer | Used for re-transmission on the data link. The value varies depending on the message type. | 155 ms for FACCH
T303 Mobility Management connection timer | Time the network waits after sending a CM SERVICE REQUEST until receiving a response. This occurs before initiating call clearing procedures towards the MS. | 10 seconds
T305 Release timer | Time the network waits after transmitting a DISCONNECT message until receiving a RELEASE message. | 1 seconds
T306 In-band tones release timer | Time the network waits after transmitting a DISCONNECT message while in-band tones/announcements are provided, until receiving a RELEASE message. | 1 seconds
T310 Call proceeding timer | Time the network waits after receiving a CALL CONFIRMED message until receiving a ALERTING, CONNECT, or DISCONNECT message before initiating clearing procedures towards the MS. | 10 seconds
T313 Connect acknowledge timer | Time the network waits after transmitting a CONNECT message until receiving the CONNECT ACKNOWLEDGE message before performing clearing procedures with the MS. | 10 seconds
T323 Modify complete timer | Time the network waits after sending a MODIFY message during call mode changes, until receiving a MODIFY COMPLETE or MODIFY REJECT message before initiating call clearing procedures. | 10 seconds
T3101 Immediate assignment timer | Time the network waits after sending the IMMEDIATE ASSIGNMENT or IMMEDIATE ASSIGNMENT EXTENDED message until the main signalling link is established before releasing the newly allocated channels. | 1 second
T3103 Handover timer | Time the network waits after transmitting a HANDOVER COMMAND message until receiving HANDOVER COMPLETE or HANDOVER FAILURE or the MS re-establishes the call before the old channels are released. If the timer expires and the network has not received a correctly decoded L2 (format A or B) or TCH frame, then the newly allocated channels are released. | 2 seconds
T3105 Physical information repetition timer | Time the network waits after sending the PHYSICAL INFORMATION message until receiving a correctly decoded L2 (format A or B) or TCH frame. This occur before re-transmitting the PHYSICAL INFORMATION message or releasing the newly allocated channels. | 50 ms
T3107 Channel assignment timer | Time the network waits after transmitting an ASSIGNMENT COMMAND message until receiving the ASSESSMENT FAILURE message or the MS re-establishes the call before releasing the old and the new channels. | 3 seconds
T3109 Signalling disconnection timer | Time the network waits after sending the CHANNEL RELEASE message before disconnecting the signalling link. | 5 seconds
T3111 Channel deactivation after disconnection timer | Time the network waits after disconnecting the signalling link before deactivating the channel. | 500 ms
T3113 Paging timer | Time the network waits after transmitting the PAGING REQUEST message until receiving the PAGING RESPONSE message. This occurs before re-transmitting the PAGING REQUEST (if the maximum number of re-transmissions have not been exceeded). | 5 seconds
T3250 TMSI reallocation timer | Time the network waits after sending the TMSI REALLOCATION COMMAND until receiving TMSI REALLOCATION COMPLETE. This occurs before aborting the procedure and releasing the Radio Resource connection. | 5 seconds
T3260 Authentication response timer | Time the network waits after an AUTHENTICATION REQUEST until receiving AUTHENTICATION RESPONSE. This occurs before aborting the procedure and releasing the Radio Resource connection. | 5 seconds
T3313 Packet Paging timer | Time the network waits after transmitting the PACKET PAGING REQUEST message until receiving the PACKET PAGING RESPONSE message. This occurs before re-transmitting the PACKET PAGING REQUEST (if the maximum number of re-transmissions have not been exceeded). | 20 seconds
T3360 Authentication response timer | Time the network waits after an AUTHENTICATION AND CIPHERING REQUEST until receiving AUTHENTICATION AND CIPHERING RESPONSE. | 6 seconds

Related Topics

Configurable Timers


Manual User Error Messages

Manual User Error Messages

Description

These messages are intended to be displayed on the manual user interface only, and are not entered into the Error/Event Queue.

Error Message | Description
The function you requested is not yet available. | The test set does not have this capability.
IQ Calibration completed successfully for modulator <N> | <N> is the IQ modulator number that you are attempting to calibrate, <N> is 1 or 2.
IQ Calibration failed for modulator <N> | <N> is the IQ modulator number that you are attempting to calibrate, <N> is 1 or 2.
The function you requested is not available in this TA. | This function is used in another Test Application.
IQ Calibration for modulator 1 in progress (10 minutes). Call processing disabled. | This error is cleared by either the; IQ Calibration completed successfully for modulator <N>, or IQ Calibration failed for modulator <N>.
IQ Calibration for modulator 2 in progress (6 minutes). Call processing disabled. | This error is cleared by either the; IQ Calibration completed successfully for modulator <N>, or IQ Calibration failed for modulator <N>.
Instrument warning: Audio generator instrument has been closed. | The audio generator instrument was closed automatically by the test set.
Measurement warning: Audio Analyzer instrument has been closed. | The audio analyzer instrument was closed automatically by the test set.
Measurement warning: Analog audio measurement has been closed. | Analog audio measurements have been closed by the test set.
Protocol warning: Setting change has terminated the link with the DUT | Some setting change has caused the call to disconnect.
Warning; Call processing disabled | The call processing functions are not active because the test set is performing calibration operations.
IQ first modulator calibration X% | IQ modulator calibration in progress, X represents the percent complete.
IQ second modulator calibration X% | IQ modulator calibration in progress, X represents the percent complete.

GSM and GPRS Mobile Test Manual User Messages

These messages are maskable so that they can be blocked from appearing on the display. See Error Messages .

Message | Description
GSM measurement warning; TX power measurement has been closed GPRS measurement warning; TX power measurement has been closed | Indicates that a measurement has been inactivated because of a resource conflict.
GSM measurement warning; Power vs time measurement has been closed GPRS measurement warning; Power vs time measurement has been closed | Indicates that a measurement has been inactivated because of a resource conflict.
GSM measurement warning; Phase frequency error measurement has been closed GPRS measurement warning; Phase frequency error measurement has been closed | Indicates that a measurement has been inactivated because of a resource conflict.
GSM measurement warning; Output RF spectrum measurement has been closed GPRS measurement warning; Output RF spectrum measurement has been closed | Indicates that a measurement has been inactivated because of a resource conflict.
GSM measurement warning; Fast bit error measurement has been closed | Indicates that a measurement has been inactivated because of a resource conflict.
GSM measurement warning; Bit error measurement has been closed | Indicates that a measurement has been inactivated because of a resource conflict.
GSM measurement warning; Decoded audio measurement has been closed | Indicates that a measurement has been inactivated because of a resource conflict.
GSM measurement warning; IQ tuning measurement has been closed | Indicates that a measurement has been inactivated because of a resource conflict.
GSM measurement warning; AMR in-band frame error measurement has been closed. | Indicates that a measurement has been inactivated because of a resource conflict.
Protocol warning; Setting change has terminated the link with the DUT | Indicates that a user setting has caused the link with the device under test (DUT) to be dropped. (For example, this may occur if you change the ETSI Test Mode Type parameter while the data connection status is Transferring.)


-100 to -199 Command Errors

-100 to -199 Command Errors

Description

A command error indicates that the test set's GPIB parser has detected an IEEE 488.2 syntax error.

When one of these errors is generated, the command error bit in the event status register is set.

Error Message

Description

-100 Command error

This event bit (Bit 5) indicates a syntax error, or a semantic error, or a GET command was entered, see IEEE 488.2, 11.5.1.1.4.

-101 Invalid character

Indicates a syntactic elements contains a character which is invalid for that type.

-102 Syntax error

Indicates that an unrecognized command or data type was encountered. For example, a string was received when the device does not accept strings.

-103 Invalid separator

The parser was expecting a separator and encountered an illegal character. For example, the semicolon was omitted after a program message unit.

-104 Data type error

The parser recognized a data element different than one allowed. For example, numeric or string data was expected but block data was encountered.

-105 Get not allowed

Indicates a Group Execute Trigger was received within a program message. Correct the program so that the GET does not occur within the program code.

-108 Parameter not allowed

Indicates that more parameters were received than expected for the header. For example, *ESE common command only accepts one parameter, so *ESE 0,1 is not allowed.

-109 Missing parameter

Indicates that less parameters were received than required for the header. For example, *ESE requires one parameter, *ESE is not allowed.

-110 Command header error

Indicates an error was detected in the header. This error is used when the device cannot detect the more specific errors -111 through -119.

-111 Header separator error

Indicates that a character that is not a legal header separator was encountered while parsing the header.

-112 Program mnemonic too long

Indicates that the header contains more that twelve characters, see IEEE 488.2, 7.6.1.4.1.

  • - 113 Undefined header
  • - 113 Undefined header

  • Indicates the header is syntactically correct, but it is undefined for this specific device. For example, `XYZ' is not defined for any device.
  • Attempt to set value of the GPS RF Generator Frequency or Frequency 2 will result in this error

-114 Header suffix out of range

Indicates the value of a header suffix attached to a program mnemonic makes the header invalid.

-120 Numeric data error

This error, as well as errors -121 through -129, are generated when parsing a data element which appears to be numeric, including non-decimal numeric types. This particular error is used if the device cannot detect a more specific error.

-121 Invalid character in number

Indicates an invalid character for the data type being parsed was encountered. For example, an alpha in a decimal numeric or a "9" in octal data.

-123 Exponent too large

Indicates the magnitude of an exponent was greater than 32000, see IEEE 488.2, 7.7.2.4.1.

-124 Too many digits

Indicates the mantissa of a decimal numeric data element contained more than 255 digits excluding leading zeros, see IEEE 488.2, 7.7.2.4.1.

-128 Numeric data not allowed

Indicates that a legal numeric data element was received, but the device does not accept one in this position for the header.

-130 Suffix error

This error, as well as errors -131 through -139, are generated when parsing a suffix. This particular error message is used if the device cannot detect a more specific error.

-131 Invalid suffix

Indicates the suffix does not follow the syntax described in IEEE 488.2, 7.7.3.2, or the suffix is inappropriate for this device.

-134 Suffix too long

Indicates the suffix contain more than 12 characters, see IEEE 488.2, 7.7.3.4.

-138 Suffix not allowed

Indicates that a suffix was encountered after a numeric element that does not allow suffixes.

-140 Character data error

This error, as well as errors -141 through -149, are generated when parsing a character data element. This particular error message is used if the device cannot detect a more specific error.

-141 Invalid character data

Indicates that the character data element contains an invalid character or the particular element received is not valid for the header.

-144 Character data too long

Indicates the character data element contains more than twelve characters, see IEEE 488.2, 7.7.1.4.

-148 Character not allowed

Indicates a legal character data element was encountered where prohibited by the device.

-150 String data error

This error, as well as errors -151 through -159, are generated when parsing a string data element. This particular error message is used if the device cannot detect a more specific error.

-151 Invalid string data

Indicates that a string data element was expected, but was invalid, see IEEE 488.2, 7.7.5.2. For example, an END message was received before the terminal quote character.

-158 String data not allowed

Indicates that a string data element was encountered but was not allowed by the device at this point in parsing.

-160 Block data error

This error, as well as errors -161 through -169, are generated when parsing a block data element. This particular error message is used if the device cannot detect a more specific error.

-161 Invalid block data

Indicates a block data element was expected, but was invalid, see IEEE 488.2, 7.7.6.2. For example, and END message was received before the end length was satisfied.

-168 Block data not allowed

Indicates a legal block data element was encountered, but not allowed by the device at this point in parsing.

-170 Expression error

This error, as well as errors -171 through -179, are generated when parsing an expression data element. This particular error message is used if the device cannot detect a more specific error.

-171 Invalid expression

Indicates the expression data element was invalid, see IEEE 488.2, 7.7.7.2. For example, unmatched parentheses or an illegal character.

-178 Expression data not allowed

Indicates a legal expression data was encountered, but was not allowed by the device at this point in parsing.

-180 Macro error

This error, as well as error -181 through -189, are generated when defining a macro or execution a macro. This particular error message is used if the device cannot detect a more specific error.

-181 Invalid output macro definition

Indicates that a macro parameter place holder was encountered outside of a macro definition.

-183 Invalid inside macro definition

Indicates that the program message unit sequence, sent with a *DDT or a *DMC command, is syntactically invalid, see IEEE 488.2, 10.7.6.3.

-184 Macro parameter error

Indicates that a command inside the macro definition had the wrong number or type of parameters.

Related Topics

Standard Event Status Register


-200 to -299 Execution Errors

-200 to -299 Execution Errors

Description

These errors are generated when something occurs that is incorrect in the current state of the instrument. These errors may be generated by a user action from either the remote or the manual user interface.

Error Message | Description
-200 Execution error | This event bit (Bit 4) indicates a PROGRAM DATA element following a header was outside the legal input range or otherwise inconsistent with the device's capabilities, see IEEE 488.2, 11.5.1.1.5.
-203 Command protected | Indicates that a legal password-protected program command or query could not be executed because the command was disabled.
-220 Parameter error | Indicates that a program data element related error occurred.
-221 Setting conflict | Indicates that a legal program data element was parsed but could not be executed due to the current device state.
-222 Data out of range | Indicates that a legal program data element was parsed but could not be executed because the interpreted value was outside the legal range defined by the devices
-223 Too much data | Indicates that a legal program data element of block, expression, or string type was received that contained more data than the device could handle due to memory or related device-specific requirements.
-224 Illegal parameter value | Indicates that the value selected was not part of the list of values given.
-225 Out of memory | The device has insufficient memory to perform the requested operation.
-226 Lists not the same length | Attempted to use LIST structure having individual LIST's of unequal lengths.
-230 Data corrupt or stale | Indicates invalid data, a new reading started but not completed since the last access.
-231 Data questionable | Indicates that measurement accuracy is suspect.
-233 Invalid version | Indicates that a legal program data element was parsed but could not be executed because the version of the data is incorrect to the device. For example, a not supported file version, a not supported instrument version.
-240 Hardware error | Indicates that a legal program command or query could not be executed because of a hardware problem in the device.
-241 Hardware missing | Indicates that a legal program command or query could not be executed because of missing device hardware. For example, an option was not installed.
-250 Mass storage error | Indicates that a mass storage error occurred. The device cannot detect the more specific errors described for errors -251 through -259.
-251 Missing mass storage | Indicates that a legal program command or query could not be executed because of missing mass storage.
-252 Missing media | Indicates that a legal program command or query could not be executed because of missing media. For example, no disk.
-253 Corrupt media | Indicates that a legal program command or query could not be executed because of corrupt media. For example, bad disk or wrong format.
-254 Media full | Indicates that a legal program command or query could not be executed because the media is full. For example, there is no room left on the disk.
-255 Directory full | Indicates that a legal program command or query could not be executed because the media directory was full.
-256 File name not found | Indicates that a legal program command or query could not be executed because the file name was not found on the media.
-257 File name error | Indicates that a legal program command or query could not be executed because the file name on the device media was in error. For example, an attempt was made to read or copy a nonexistent file.
-258 Media protected | Indicates that a legal program command or query could not be executed because the media was protected. For example, the write-protect switch on a memory card was set.
-270 Macro error | Indicates that a macro related execution error occurred.
-271 Macro syntax error | Indicates that a syntactically legal macro program data sequence, according to IEEE 488.2, 10.7.2, could not be executed due to a syntax error within the macro definition.
-272 Macro execution error | Indicates that a syntactically legal macro program data sequence could not be executed due to some error in the macro definition, see IEEE 488.2, 10.7.6.3.
-273 Illegal macro label | Indicates that the macro label was not accepted, it did not agree with the definition in IEEE 488.2, 10.7.3
-274 Macro parameter error | Indicates that the macro definition improperly used a macro parameter placeholder, see IEEE 4882, 10.7.3.
-275 Macro definition too long | Indicates that a syntactically legal macro program data sequence could not be executed because the string of block contents were too long for the device to handle, IEEE 488.2, 10.7.6.1.
-276 Macro recursion error | Indicates that a syntactically legal macro program data sequence count not be executed because it would be recursive, see IEEE 488.2, 10.7.6.6.
-277 Macro redefinition not allowed | Indicates that redefining an existing macro label, see IEEE 488.2, 10.7.6.4.
-278 Macro header not found | Indicates that a legal macro label in the *GMS?, see IEEE 488.2, 10.13, could not be executed because the header was not previously defined.


-300 to -399 SCPI Specified Device-Specific Errors

-300 to -399 SCPI Specified Device-Specific Errors

Description

A device-specific error indicates that the instrument has detected an error that occurred because some operations did not properly complete, possibly due to an abnormal hardware or firmware condition. For example, an attempt by the user to set an out of range value will generate a device specific error. When one of these errors is generated, the device specific error bit in the event status register is set.

Error Message | Description
-300 Device specific error | This event bit (Bit 3) indicates that a device operation did not properly complete due to some condition, such as overrange see IEEE 488.2, 11.5.1.1.6.
-311 Memory error | Indicates some physical fault in the devices memory, such as a parity error.
-312 PUD memory lost | Indicates protected user data saved by the *PUD command has been lost, see IEEE 488.2, 10.27.
-313 Calibration memory lost | Indicates that nonvolatile calibration data used by the *CAL? command has been lost, see IEEE 488.2, 10.2.
-314 Save/recall memory lost | Indicates that the nonvolatile data saved by the *SAV command has been lost, see IEEE 488.2, 10.33.
-315 Configuration memory lost | Indicates that nonvolatile configuration data saved by the device has been lost.
-320 Storage fault | Indicates that the firmware detected a fault when using data storage. This is not an indication of physical damage or failure of any mass storage element.
-321 Out of memory | An internal operation needed more memory than was available
-330 Self test failed | Indicates a problem with the device that is not covered by a specific error message. The device may require service.
-340 Calibration failed | Indicates a problem during calibration of the device that is not covered by a specific error.
-350 Queue overflow | Indicates that there is no room in the queue and an error occurred but was not recorded. This code is entered into the queue in lieu of the code that caused the error.
-360 Communication error | This is the generic communication error for devices that cannot detect the more specific errors described for error -361 through -363.
-361 Parity error in program message | Parity bit not correct when data received for example, on a serial port.
-362 Framing error in program message | A stop bit was not detected when data was received for example, on a serial port (for example, a baud rate mismatch).
-363 Input buffer overrun | Software or hardware input buffer on serial port overflows with data caused by improper or nonexistent pacing.

Related Topics

Standard Event Status Register


-400 to -499 Query Errors

-400 to -499 Query Errors

Description

A Query error is generated either when data in the instrument's GPIB output queue has been lost, or when an attempt is being made to read data from the output queue when no output is present or pending.

Error Message | Description
-400 Query error | This event bit (Bit 2) indicates that an attempt to read data from the Output Queues when no output is present or pending, to data in the Output Queue has been lost see IEEE488.2, 11.5.1.1.7.
-410 Query INTERRUPTED | Indicates the test set has been interrupted by a new program message before it finishes sending a RESPONSE MESSAGE see IEEE 488.2, 6.3.2.3.
-420 Query UNTERMINATED | Indicates an incomplete Query in the program see IEEE 488.2, 6.3.2.2.
-430 Query DEADLOCKED | Indicates that the Input Buffer and Output Queue are full see IEEE 488.2, 6.3.1.7.
-440 Query UNTERMINATED after indefinite response | Indicates that a query was received in the same program message after a query requesting an indefinite response was executed see IEEE 488.2, 6.5.7.5.


+100 to +199 Core Device-Specific Error

+100 to +199 Core Device-Specific Error

Description

A device-specific error indicates that the instrument has detected an error that occurred because some operations did not properly complete, possibly due to an abnormal hardware or firmware condition. For example, an attempt by the user to set an out of range value will generate a device specific error.

These are general errors generated by the core instrument. When one of these errors is generated, the `+100 errors' bit in the questionable error status register is set.

Error Message

Description

+101 Assert; Cycle power. Assert message<message1>

<message1> will appear as:

;P:DSP T:<task ID> E:<error code> C:<error classif.> F1:<flag 1> F2:<flag 2> if the DSP generated the assert.

;P:Protocol T:<task ID> L:<line number> F:<file name> if the Protocol processor generated the assert.

;P:Host T:<task ID> L:<line number> F:<file name> if the Host processor generated the assert.

+102 Exception; Cycle power. Exception message<message2>

<message2> will appear as: T:<task ID> or V:<vector number> or PC:<program counter> or DA:<data adrs reg value>.

Vector number, program counter and data address register values are hexadecimal format.

+103 Failure; No measurements or settings can be made

Indicates none of the VI's are operational because a serious problem exists.

+104 Failure; No settling operations will take place

Indicates none of the VI's are operational because a serious problem exists.

+105 Failure; No measurements or setting can be made for the function selected

Indicates none of the VI's are operational because a serious problem exists.

+110 Input pacing; Internal communication queue overflow likely

Indicates that GPIB commands are too fast for the device input queue and should be slowed.

+111 Input pacing; Internal communication queue overflow imminent. Pacing increased

Indicates that GPIB commands were too fast and the device input queue has not kept pace.

+112 Internal error; Protocol error <message3>

<message3> is an eight digit hexadecimal number that is the error code reported by protocol.

+113 Internal error; <VI NAME> forced inactive

Indicates that a VI is inactivated when not executed.

<VI NAME> includes: "IntVmVI","GprsBsEmulVI", "GsmComBsEmulVI","GSMFixedVI", "MiscVI", "GSMSacchMriVI", "IQSelfCalVI1", "IQSelfCalVI2", "TA RevisionVI", "TdmaTaBsEmulVI".

+114 Internal error; <VI NAME> not responding

Indicates that a VI has not been instantiated or the state is not available.

<VI NAME> includes: "IntVmVI","GprsBsEmulVI", "GsmComBsEmulVI", "GSMFixedVI", "MiscVI", "GSMSacchMriVI", "IQSelfCalVI1", "IQSelfCalVI2", "TA RevisionVI", "TdmaTaBsEmulVI", "RfHwAccessVI".

+115 Internal error; <VI NAME> inactive

Indicates that a VI has been made inactive.

<VI NAME> includes: "IntVmVI", "GSMFixedVI", "MiscVI", "GSMSacchMriVI", "IQSelfCalVI1", "IQSelfCalVI2", "TA RevisionVI".

+120 Warning; Receiver over range due to requested settings

Indicates the total received power (a combination of received power and amplitude offset) is above the range of the test set.

+121 Warning; Receiver under range due to requested settings

Indicates the total received power (a combination of received power and amplitude offset) is below the range of the test set.
+122 Warning; Reference out of lock

Indicates the test set's internal reference is out of lock.

+123 Warning; Duplicate RF IN/OUT Amplitude Offset Frequency entry. First frequency entry in RF IN/OUT Amplitude Offset table will be used.

Indicates that an amplitude offset value for that frequency has already been entered. The test set will use the amplitude offset value entered first.

+124 Warning; Source over range due to requested settings

The setting selected for total transmit power (a combination of cell power, AWGN power, amplitude offset) is above the test set's range.

+125 Warning; Source under range due to requested settings

The setting selected for total transmit power (a combination of cell power, AWGN power, amplitude offset) is below the test set's range.

+126 Warning; Data out of range error for system time, system date, time zone, UTC time or UTC date due to user input error or couplings between these settings

  • +236 Call operation rejected; Called MS is not responding
  • +236 GSM/GPRS operation rejected, Attempting to set NMO while generating a BCH

+127 Warning; Impairments backoff (IBO) over range due to settings made under external software control

+129 Configuration warning: License will expire soon

The temporary license is about to expire. This message will give the license number and the number of days before it is scheduled to expire.

+130 Configuration error; Unable to switch to indicated Test Application

The test application selected is not available for this test set.

+131 Configuration error; Current Test Application is not licensed (License = N). Select another Test Application

The test application selected is not licensed. Select another revision or test application that is licensed (License = L).

+132 Configuration error; Selected Test Application Format is not available.

Indicates that the fast switching operation will not activate a particular radio format. Check the revision number of the test application associated with the radio format, does the revision correspond with what the fast switching test application needs?
+133 Configuration error; Selected Test Application Format is not licensed, (License = N).

The radio format selected is not licensed. Select another revision or obtain a licensed revision of the test application test application that is licensed (License = L).

+134 Configuration error; Unable to switch to selected Test Application Format

The Test Application Format name used is correct but for some reason the test set can not switch to that format.

+137 Configuration error; The license has expired for the selected format

When a license expires you must switch applications by pressing the SYSTEM CONFIG key and then selecting Format Switch (F2) or Application Selection (F3).

+138 Configuration error; Selected format is not licensed due to unexpected system time change

 This message is displayed when a temporary license expires due to a change occurring to system time.

+139 Configuration error; Functionality is not available

+140 Operation rejected; Command is not supported in this operating mode

+141 Operation Rejected; A Measurement Is Currently Controlling This Setting. | An attempt has been made to access a setting that is being controlled by a measurement.

  • +142 Configuration error; Functionality not available
  • +142 Operation rejected; Functionality is not available in the selected partition; GPS

  • An attempt has been made to access lab application functions from a test application.
  • Selecting `GPS' when in format other than GGE, C2K, 1xev-DO and WCDMA, e.g. AMPS/IS136, shall result in this error message.

+143 Operation Rejected; Selected measurement is not available in the current measurement selection list

An attempt has been made to access a measurement that is not available in the current application.

+144 Operation rejected; PC connection not established

+145 Operation rejected; Feature is not licensed. See www.agilent.com/find/8960upgrades for additional information

The feature you are attempting to access is not licensed in your test set. Visit www.agilent.com/find/8960upgrades to find out how to acquire the required license.

+146 Operation rejected; External 8960 connection feature is not licensed. See www.agilent.com/find/8960upgrades for additional information

The external 8960 connection feature requires a license in a test application. Visit www.agilent.com/find/8960upgrades to find out how to acquire the required license.
+146 FDD operation rejected; HSDPA is not licensed. See www.agilent.com/find/8960upgrades for additional information | The HSDPA feature requires a license in a test application. Visit www.agilent.com/find/8960upgrades to find out how to acquire the required license.
+147 Help is enabled. Select a field to display the GPIB syntax. For additional help refer to www.agilent.com/find/8960 and select "8960 Online User's Guides".

+147 FDD operation rejected; HSPA feature is not licensed. See www.agilent.com/find/8960upgrades for additional information

+148 Operation rejected; Setting is currently under external control

+149 Warning; Running a partially qualified version of the application

+150 Operation rejected; LAN IP address 2 cannot be the same as the instrument LAN address

+151 Operation rejected; LAN IP address 2 must be on the same subnet as the instrument

+152 Warning; LAN IP address 2 cleared to 0.0.0.0 due to an instrument LAN address or subnet mask change

+153 Operation rejected; Even number of hexadecimal digits is required

+ 154 Operation rejected; An application is currently controlling this setting; <application>

 <application> could be <1xEV-DO Multicarrier>

+160 Save/Recall error; File operation error

 Occurs if there is any disk read or write problems when trying to save, recall or delete a register.

+161 Save/Recall error; Recalling available (empty) register

 Occurs if an attempt is made to recall any register that has not been saved.
+162 Save/Recall error; Functionality is not yet available for current application. | Occurs when an attempt to save a save/recall register while using an application that has not implemented this feature.

+163 Save/Recall error; Functionality is not yet available for current application

+170 Warning; RF source 1 ALC mode set to closed due to requested setting

+171 Warning; 8960 has been restarted after a non-recoverable error occurred.

Occurs when the instrument has completed its power up sequence after restarting due to a fatal error.


+200 to +299 Call Processing Device-Specific Error

+200 to +299 Call Processing Device-Specific Error

These errors are generated when a problem occurs maintaining the link between the test set and the DUT. These errors generally occur as a result of a problem on the link such as if the DUT did not respond to a message, or the user attempted to perform an invalid operation in the current instrument state.

Errors with a description beginning with "GSM call disconnected" mean that the call is dropped when the error occurs. Errors beginning with "GSM protocol failure" mean that the call is not necessarily dropped, these are informational messages.

Error Message

Description

+201 GSM call disconnected; Radio link failure (Timer T100 expiry)

Fixed Timer Messages

+202 GSM call disconnected; Immediate assignment failure (Timer T3101 expiry)

Fixed Timer Messages

+203 GSM call disconnected; Handover failure (Timer T3103 expiry)

Fixed Timer Messages

+204 GSM call disconnected; Channel assignment failure (Timer T3107 expiry)

Fixed Timer Messages

+205 GSM call disconnected; No response to page (Timer T3113 expiry)

Fixed Timer Messages

+206 GSM call disconnected; No answer (Timer T301 expiry)

Fixed Timer Messages

+207 GSM call disconnected; No response to setup (Timer T303 expiry)

Fixed Timer Messages

+210 GSM call disconnected; No response to release 2 times (Timer T308 expiry)

Fixed Timer Messages

+211 GSM call disconnected; No alert from mobile (Timer T310 expiry)

Fixed Timer Messages

+212 GSM call disconnected; No response to connect (Timer T313 expiry)

Fixed Timer Messages

+213 GSM call disconnected; Data link failure (Timer T200 expiry)

Fixed Timer Messages

+214 GSM call disconnected; Physical information repetition failed (Timer T3105 expiry)

Fixed Timer Messages

+217 GSM Call disconnected; TMSI (Temporary Mobile Subscriber Identity) reallocation failed (Timer T3250 expiry)

Fixed Timer Messages

+218 GSM call disconnected; Authentication failed (Timer T3260 expiry)

Fixed Timer Messages

+219 GSM Call disconnected; Mobile not capable of supporting the selected Channel Mode

Indicates that the mobile station cannot support the requested channel mode.

+220 GSM/GPRS operation rejected; Attempting to set BCH parameter while generating a BCH

 Indicates the BS Emulator VI cannot be instantiated.

+221 GSM/GPRS operation rejected; SDCCH subchannel required is currently unavailable

This error is generated if an attempt to initiate Cell Broadcast is made and the SDCCH Subchannel is set to 2, or if Cell Broadcast is activated and an attempt is made to set the SDDCH Subchannel to 2.

+226 GSM operation rejected; Only one call can be supported at a time

Indicates an attempt at a second call being activated.

+227 GSM/GPRS operation rejected; Attempting to set MNC while generating a BCH

Indicates that the cell is turned on. The Operating Mode must be Cell Off before setting the MNC.

+228 GSM/GPRS operation rejected; Attempting to set LAC while generating a BCH

Indicates that the cell is turned on. The Operating Mode must be Cell Off before setting the LAC.

+229 GSM/GPRS operation rejected; Attempting to set MCC while generating a BCH

Indicates that the cell is turned on. The Operating Mode must be Cell Off before setting the MCC.

+230 Call operation rejected; Action not possible

Indicates an attempt to perform a BS Emulator action when the BS emulator VI is inactive.

+231 Call operation rejected; Call processing in progress

+232 Call operation rejected; Protocol request ignored

+233 GSM/GPRS operation rejected; Attempting to set BCC while generating a BCH

Indicates that the cell is turned on. The Operating Mode must be Cell Off before setting the BCC.

+234 GSM/GPRS operation rejected; Attempting to set NCC while generating a BCH

Indicates that the cell is turned on. The Operating Mode must be Cell Off before setting the NCC.

+235 Call operation rejected; The external device has an invalid configuration for the requested service

  • +236 Call operation rejected; Called MS is not responding
  • +236 GSM/GPRS operation rejected, Attempting to set NMO while generating a BCH

  • Indicates that the cell is turned on. The Operating Mode must be Cell Off before setting the Network Operation Mode.

+237 GSM operation rejected; Attempting to start SMS Cell Broadcast Service while not generating a BCH

+238 GPRS operation rejected; Attempting to set RAC while generating a BCH

Indicates that the cell is turned on. The Operating Mode must be Cell Off before setting the RAC.

+239 Operation rejected; Starting ping not allowed with current configuration

Indicates the CALL:DATA:PING:STARt command was received when the data connection type was not Auto.

+240

  • GSM/GPRS operation rejected; Data connection request rejected due to invalid DUT IP address
  • Operation rejected; Attempting to send SMS submit report after TR2N expired.

  • Indicates DUT IP address is invalid. May be address setting, subnet mask, or incorrect LAN IP address.
  • There are network (TR2N) and mobile station (TR2M) timers associated with the return of a SMS-SUBMIT-REPORT message. You should ensure that the time taken to respond to a SMS-SUBMIT message when using MANUAL mode is well within the limits of these timers (by at least a couple of seconds). If a request to send and SMS-SUBMIT-REPORT is received at the test set outside these time constraints, the message will not be sent to the mobile station.

+241

  • GPRS operation rejected; DUT PDP context request rejected due to data connection type not being Auto
  • Operation rejected; Attempting to send SMS submit report while mode set to Auto

  • Indicates PDP context request occurred when the connection type was not Auto.

+242

  • GPRS operation rejected; DUT and instrument are in incompatible states
  • Operation rejected; Attempting to send SMS status report while mode set to Auto

  • Indicates that the instrument and the DUT were not able to meet the other's requests.

+243

  • GPRS operation rejected; Activate PDP context request procedure failed (Timer T3385 expired 5 times)
  • Operation rejected; Too many outstanding requests, could not send SMS message

  • Context request timed out.

+244 GPRS operation rejected; Modify PDP context request procedure failed (Timer T3386 expired 5 times)

Change request for PDP context timed out.

+245 GPRS operation rejected; Deactivate PDP context request procedure failed (Timer T3395 expired 5 times)

Deactivation request timed out.

+246 GPRS operation rejected; Request PDP context activation rejected by DUT

Request to send PDP activation request rejected by DUT.

+247 DUT IP address has been cleared; PDP Context will be rejected until valid DUT address is entered

+248 GSM/GPRS operation rejected; Attempting to set MS TX Power Max CCH while generating a BCH

Indicates that the cell is turned on. The Operating Mode must be Cell Off before setting the MS TX Power Max CCH parameter.

+249 GPRS protocol failure; Cell Change procedure failed

+250 Protocol failure; Unknown error

+251

  • GSM protocol failure; No response to release (Timer T308 expiry)
  • Warning; DUT's request for the primary DNS server address has been ignored because the setting does not currently contain a valid IP address

  • Fixed Timer Messages
  • DNS Server IP Addresses

+252

  • GSM protocol failure; Channel release failed (Timer T3109 expiry)
  • Warning; DUT's request for the secondary DNS server address has been ignored because the setting does not currently contain a valid IP address

  • Fixed Timer Messages
  • DNS Server IP Addresses

+253

  • GSM protocol failure; (Timer T3270 expiry)
  • Warning; DUT's request for primary and secondary DNS server addresses has been ignored because both of the settings do not contain valid IP addresses

  • Fixed Timer Messages
  • DNS Server IP Addresses

+254 GSM protocol failure; Unknown identity type received from mobile

Indicates that an identity type other than 1, 2, 3 or 4 was received from the MS.

+255 GSM protocol failure; Unexpected identity type received from mobile

Indicates that the MS has responded with an unexpected identity type. Example MS returned IMSI when IMEI was queried.
See CALL:MS:REPorted:IMEI? .

+256 GSM protocol failure; No response to disconnect (Timer T305 expiry)

Fixed Timer Messages

+257 GSM call disconnected; Invalid TMSI received from MS

Indicates that some of the bits received were not set to their normal or expected value for a TMSI (Temporary Mobile Subscriber Identity).

+258 GSM protocol failure; Out-of-range for timing advance

Indicates that there is a likely issue with the mobile's protocol board which is causing its timing advance to be out of the expected range.

+259 GPRS protocol failure; Received ACK/NACK for a block that has not been sent to the MS

 Indicates that there is a likely issue with the mobile's protocol board as it is responding to messages that haven't been sent.

+260 GSM RR Cause; <cause identifier>

The <cause identifier> is a 4 digit hexadecimal number

+261 GSM MM Cause; <cause identifier>

The <cause identifier> is a 4 digit hexadecimal number

+262 GSM CC Cause; <cause identifier>

The <cause identifier> is a 4 digit hexadecimal number

+263 Protocol Error; RRLP Protocol Error Received from MS. Error Code 0

 This error is generated if a `Protocol Error' RRLP message is received from the mobile station containing error code 0 (Undefined).

+264 Protocol Error; RRLP Protocol Error Received from MS. Error Code 1

 This error is generated if a `Protocol Error' RRLP message is received from the mobile station containing error code 1(Missing Component).

+265 Protocol Error; RRLP Protocol Error Received from MS. Error Code 2

 This error is generated if a `Protocol Error' RRLP message is received from the mobile station containing error code 2(Incorrect Data).

+266 Protocol Error; RRLP Protocol Error Received from MS. Error Code 3

 This error is generated if a `Protocol Error' RRLP message is received from the mobile station containing error code 3(Missing IE or component element).

+267 Protocol Error; RRLP Protocol Error Received from MS. Error Code 4

 This error is generated if a `Protocol Error' RRLP message is received from the mobile station containing error code 4(Message Too Short).

+268 Protocol Error; RRLP Protocol Error Received from MS. Error Code 5

 This error is generated if a `Protocol Error' RRLP message is received from the mobile station containing error code 5(Unknown Reference Number).

+269 Configuration Error; Attempting to send RRLP pipe message while pipe mode is Off

+270 Configuration Error; Attempting to send specific RRLP message while pipe mode is On

Indicates that the BCH ARFCN or Cell Band was changed while the mobile station was attached (thus initiating a cell change. The mobile station had not completed the cell change procedure after 5 seconds.

+271 GPRS data connection terminated; Data connection failed to start

Indicates that the GPRS test application was unable to start the data connection with the DUT (Device Under Test).

+272 GPRS data connection terminated; Detach failure (Timer T3322 expired 5 times)

Indicates that the Detach procedure failed after five attempts. The Data Connection Status will be set to Idle.

+273 GPRS data connection terminated; Attach failure (Timer T3350 expired 5 times)

Indicates that the Attach procedure failed after five attempts. The Data Connection Status will be set to Idle.

+274 GPRS data connection terminated; Routing Area Update failure (Timer T3350 expired 5 times)

Indicates that the Routing Area Update procedure failed after five attempts. The Data Connection Status will not be changed.

+275 GPRS data connection terminated; MS unexpectedly ended TBF

Indicates that the mobile station unexpectedly ended the TBF (temporary block flow).

+276 GPRS data connection terminated; Test set timed out waiting for data from the MS

Indicates that no data was received from the mobile station in the allowed time.

+277 GPRS data connection terminated; MS timed out ACK/NACK exchanges and released the TBF

Indicates that the mobile station timed out ACK (Acknowledged) or NACK (Not Acknowledged) exchanges and released the TBF (temporary block flow). For more details about the cause of this error and suggestions on how to resolve it, see GPRS Data Connection Troubleshooting .

+278 GPRS data connection terminated; MS did not respond to uplink immediate assignment

Indicates that the mobile station did not respond to the uplink immediate assignment.

+279 GPRS data connection terminated; MS did not respond to downlink immediate assignment

Indicates that the mobile station did not respond to the downlink immediate assignment.

+280

  • GPRS data connection terminated; Test set timed out waiting for data from the MS
  • Operation rejected; Digital audio file parsing error in frame

  • Indicates that the mobile station did not respond to the test set within the allowed time
  • Indicates that the Digital audio file uploaded to the test set has parse error in frame. see Digital Audio Interface (DAI) Description

+281

  • GPRS data connection terminated; MS did not respond to packet timeslot reconfigure
  • Operation rejected; Digital audio file is not suitable for selected logical speech channel

  • Indicates that the mobile station did not respond to a packet timeslot reconfiguration request from the test set.
  • Indicates that the type of the Digital audio file is not match with the logical speech channel you have selected in the TCH Parameters. See Digital Audio Interface (DAI) Description

+282

  • The Identity Request procedure has been aborted (Timer T3370 expired 5 times)
  • Operation rejected; Digital audio file contains references to AMR codec rates not specified in the codec set

  • Indicates that the AMR codec rates contained in the Digital audio file is not match with the codec set you have selected in the TCH Parameters. See Digital Audio Interface (DAI) Description

+283

  • GPRS data connection terminated; No response to network initiated detach procedure (Timer 3193 expired 5 times)
  • Operation rejected; Digital audio file is too long

  • Indicates that the length of Digital audio file exceeds the maximum capacity of the test set (2MB). See Digital Audio Interface (DAI) Description

+284 The Authentication procedure has been aborted (Timer T3360 expired 5 times)

  • The Authentication procedure has been aborted (Timer T3360 expired 5 times)
  • Operation rejected; Digital audio file is not available

  • Indicates that the Digital audio file has not been uploaded to the test set or there is no recorded Digital audio file for download. See Digital Audio Interface (DAI) Description

+285

  • The PTMSI Allocation procedure has been aborted (Timer T3350 expired 5 times)
  • Operation rejected; Digital audio file playing/recording can not take place while operating mode is not active cell

  • Indicates that the operating mode is not suitable for the digital audio test. See Digital Audio Interface (DAI) Description

+286

  • GPRS data connection terminated; MS did not respond to packet downlink assignment
  • Operation rejected; Digital audio file playing/recording can not take place while there is no active call

  • Indicates that the mobile station did not respond to a packet downlink assignment.
  • Indicates that a voice call should be set up between the MS and the test set before playing/recording the Digital audio file. See Digital Audio Interface (DAI) Description

+287

  • GPRS data connection terminated; MS did not respond to packet uplink
  • Operation rejected; Digital audio file not implemented for selected logical speech mode

  • Indicates that the mobile station did not respond to a packet uplink assignment.
  • Indicates that the type of the Digital audio file is not match with the logical speech channel you have selected in the TCH Parameters. Digital Audio Interface (DAI) Description

+288

  • GPRS operation rejected; Attempting to send GPRS SMS message while DUT is not GPRS attached
  • Operation rejected; Digital audio file can not be played as CODEC rate changes occur on both odd and even frames

+289

  • GSM/GPRS operation rejected; Attempting to send SMS message while connection type is not Auto
  • Operation rejected; Digital audio file upload/download in progress

  • See Digital Audio Interface (DAI) Description

+290

  • GPRS protocol warning; No IMSI received from MS (using default IMSI)
  • Warning; Digital audio file recording has reached maximum capacity and recording has stopped

  • This warning message occurs with some GPRS mobiles and not with others. It is an advisory message only and does not indicate failure of the test set or the mobile.
  • Indicates the test set has reached its maximum record capacity (2MB). See Digital Audio Interface (DAI) Description

+291

  • GPRS operation rejected; Attempting to select fixed allocation mode
  • Warning; Digital audio file recording has stopped due to user setting change

  • This warning message occurs when you attempt to change resource allocation to fixed allocation and the connection type is not Auto.

+292

  • GPRS protocol failure; Data arrived on unknown SAPI and has been ignored
  • Warning; Digital audio file playing has stopped due to user setting change

+293

  • GSM/GPRS Operation Rejected; The PBCCH must be disabled before sending a RRLP message
  • Warning; Digital audio file playing/recording has stopped because the call ended.

  • This error is generated if an attempt is made to send an RRLP message from the test set while the PBCCH is turned on and the mobile station could be monitoring it.
  • See Digital Audio Interface (DAI) Description

+294 GSM/GPRS Operation Rejected; Attempt to send RRLP Message outside of Active Cell operating mode

 This error is generated if an attempt is made to send any RRLP message when not in Active Cell operating mode.

+295 Protocol Error; Test set could not decode RRLP message

+296 Protocol Error; Received RRLP message contains unsupported extensions, message not decoded

+297 GPRS operation rejected; Attempting to send SMS message while operating mode is not active cell

+298 Protocol Warning; User operation caused disconnect

+299 GPRS protocol warning; No PTCCH/U access burst received


+300 to +399 Link Control Device-Specific Error

+300 to +399 Link Control Device-Specific Error

Last updated: December 9, 2008

These errors generally occur when a message is received from the DUT that is unexpected.

When one of these errors is generated, the `+300 errors' bit in the questionable error status register is set. Refer to Standard Event Status Register for information on this register.

Error Message

Description

+303 GSM data link failure; Unsolicited DM response, multiple frame established state

+309 GSM data link failure; N(R) sequence error

+315 External Handover failure: Handover rejected by MS

This error is generated if the mobile explicitly rejects the Handover Command message sent to it when you initiate the Execute External 8960 Handover immediate action. See "Two-Cell Test System".

+316 GSM operation rejected: External 8960 Configuration Error

This error is generated if the destination test set is not capable of accepting an incoming handover (for example if its operating mode is not active cell). See "Two-Cell Test System".

+317 GSM operation rejected: Invalid MA table specified at external 8960

This error is generated if an invalid TCH MA table is specified at the destination test set and Frequency hopping is also enabled at the destination test set when you initiate the Execute External 8960 Handover immediate action. The Handover Command message is not sent to the mobile. See "Two-Cell Test System".

+318 GSM operation rejected: Cannot perform external Handover for CS data

This error is generated if you attempt to initiate the Execute External 8960 Handover immediate action while the mobile has an active CS Data connection. See "Two-Cell Test System".

+325 GPRS operation rejected; Cannot perform GPRS services while DUT is GPRS suspended

+326 Warning: TMSI assignment failed. Timer T3250 expired

See Paging Parameters .

+353 GSM/GPRS operation rejected; Command is not permitted for use with Dual Transfer Mode

See Dual Transfer Mode .

+354

  • GPRS operation rejected; Invalid multislot configuration for Dual Transfer Mode operation
  • GPRS Packet Cell Change Failure; No response from MS

  • See Dual Transfer Mode .

  • This error is generated if the mobile does not respond to the Packet Cell Change Order sent to it when you initiate the Execute External 8960 Handover immediate action. See "Two-Cell Test System".

+355

  • Reject Dual Transfer Mode while on CS Data call
  • GPRS Packet Cell Change Failure; MS rejected Packet Cell Change Order request

  • See Dual Transfer Mode .
  • This error is generated if the mobile explicitly rejects the Packet Cell Change Order sent to it when you initiate the Execute External 8960 Handover immediate action. See "Two-Cell Test System".

+357 GPRS DTM operation failed; DTM unavailable while destination channel is SDCCH

See Stand Alone Dedicated Control Channel (SDCCH) .

+360 GPRS operation rejected; Invalid custom multislot configuration specified;<GPRS reason>

See Flexible Timeslot .

+361 DTM operation rejected; Invalid custom multislot configuration specified;<DTM reason>

See Flexible Timeslot .
+362 GPRS setting conflict; Multislot configurations with a total of seven or more timeslots require TADV >= 32

This error is generated when an attempt to set timing advance less than 32 while the sum of the downlink and uplink timeslots exceed seven.
+363 DTM setting conflict; Multislot configurations with a total of seven or more timeslots require TADV >= 32

This error is generated when an attempt to set timing advance less than 32 while the sum of the downlink and uplink timeslots exceed seven.

+364 EGPRS operation rejected; Invalid RTTI configuration.

This error is generated when an attempt is made to change the TTI mode to RTTI while an invalid multislot configuration is configured.

+365 EGPRS operation rejected; Invalid DLDC configuration.

See Downlink Dual Carrier

+383 Warning; CC/MM NAS state not preserved during format switch.

 This error is generated if the NAS state cannot be preserved over an FTAS while there is an active voice call on the local test set Access Stratum.

+390 GSM/GPRS operation rejected; Unable to initiate frame synchronization.

See Frame Synchronization

+391 GSM/GPRS warning; Frame synchronization timed out

See Frame Synchronization

+392 GSM/GPRS warning; Synchronized handover attempted with questionable frame synchronization

 This error is generated when an attempt is made to synchronized handover while an invalid frame synchronization is configured

See Synchronized Handovers


+400 to +499 Core Hardware Device-Specific Error

+400 to +499 Core Hardware Device-Specific Error

Description

These errors are generated when a problem occurs in one of the test set's hardware modules that is part of the test set's core instrument.

When one of these errors is generated, the `+400 errors' bit in the questionable error status register is set.

Error Message | Description
+400 Hardware failure; Hardware is not available |
+401 Hardware failure; Protocol processor hardware is not responding |
+402 Hardware failure; Demod receiver hardware is not responding |
+403 Hardware failure; Measurement receiver hardware is not responding |
+404 Hardware failure; RF source 1 hardware is not responding |
+405 Hardware failure; RF source 1 digital modulation hardware is not responding |
+406 Hardware failure; RF source 1 level hardware is not responding |
+407 Hardware failure; DSP demod control hardware is not responding |
+408 Hardware failure; 2nd demod receiver hardware is not responding |
+409 Hardware failure; Base station emulator trigger hardware is not responding |
+410 Hardware failure; Audio source hardware is not responding |
+411 Hardware failure; RF source 2 hardware is not responding |
+412 Hardware failure; Internal voltmeter hardware is not responding |
+413 Hardware failure; Fixed timebase input is not responding |
+414 Hardware failure; Fixed external reference output is not responding |
+415 Hardware failure; Instrument reference is not responding |
+416 Hardware failure; Bit clock A is not responding |
+417 Hardware failure; RF source 2 frequency hardware is not responding |
+418 Hardware failure; RF source 2 digital modulation hardware is not responding |
+419 Hardware failure; RF source 2 level hardware is not responding |
+420 Hardware failure; RF source hopping hardware is not responding |
+421 Hardware failure; Digital demod hopping hardware is not responding |
+422 Hardware failure; Misc VI hardware is not responding |
+423 Hardware failure; Unable to access networking information |
+424 Hardware failure; Bit clock B is not responding |
+425 Hardware failure; Invalid EEPROM checksum <EEPROM board ID> | See the list of EEPROM board ID names below.
+426 Hardware failure; Unable to write to EEPROM <EEPROM board ID> | See the list of EEPROM board ID names below.
+427 Hardware failure; Unable to read from EEPROM <EEPROM board ID> | See the list of EEPROM board ID names below.
+428 Hardware failure; Board not identified <board ID> | See the list of board ID names below.
+429 Hardware failure; Could not create board identification <board ID> | See the list of board ID names below.
+430 Hardware failure; Control version not compatible with FW <board ID> | See the list of board ID names below.
+431 Hardware failure; RF IO DAC cannot be calibrated due to present temperature |
+432 Hardware failure; RF hardware is not responding |
+433 Hardware failure; RF source FM hardware is not responding |
+434 Hardware failure; Audio source FM hardware is not responding |
+435 Hardware failure; Miscellaneous state hardware is not responding |
+436 Hardware failure; BSP access error |
+437 Hardware failure; LSS hardware is not responding |
+438 Hardware failure; RFIO hardware is not responding |
+460 Hardware failure; Hardware doesn't support requested operation. See www.agilent.com/find/8960upgrades for additional information | This error occurs when an action is attempted that is not possible with the test set's hardware. Visit www.agilent.com/find/8960upgrades to find out how to acquire the necessary hardware.
+461 Hardware failure; Link subsystem hardware is not responding. Call processing functionality not operational. | This error occurs any time the link subsystem is not operating correctly. The message is persistent to warn the user that any call processing operations will not work.
+462 Hardware error; Hardware not supported; <board ID><part_number> | This error appears when an operation was attempted that requires hardware that is not installed in the test set.
+463 Hardware error: RFIO version does not support loopback switching. |
+464 Hardware error: RFIO version does not support RF out only selection. | This error occurs when trying to select the RF OUT ONLY port when the test set has the RF I/O module that only has the RF IN/OUT port.
+465 Hardware error; RfSplitters version does not support RF out only selection |
+466 Hardware error; Missing or unsupported hardware. Module |
+467 Optional hardware error; Missing or unsupported optional hardware. Option |
+469 Hardware failure; Bbio VI hardware is not responding |
+470 Hardware error; Hardware doesn't support requested operation. Feature is not licensed. See www.agilent.com/find/8960upgrades for additional information | This error occurs you attempt to access a feature which is not licensed in the test set and is not possible with the test set's hardware. Visit www.agilent.com/find/8960upgrades to find out how to acquire the necessary hardware and license.

<board ID> names

3 GHZ ATTENUATOR 1| ;3GHZ ATTENUATOR 2| ;AUDIO BD| ;ROM BASEBAND GENERATOR 1| ;ROM BASEBAND GENERATOR 2| ;DEMOD DOWNCONVERTER| ;VECTOR OUTPUT BOARD 1| ;VECTOR OUTPUT BOARD 2| ;IVF MEASUREMENT| ;MEASUREMENT DOWCONVERTER| ;RF POWER DETECTORS| ;REFERENCE MODULE| ;SYNTH DOUBLER 1| ;SYNTH DOUBLER 2| ;TIMING REF| ;MOMENTUM INSTRUMENT| ;RF MOTHER BOARD| ;JUMPER BOARD| ;DIGITAL MOTHER BOARD| ;FLAT PANEL ADAPTER| ;REAR PANEL BOARD

<EEPROM board ID> names

Instrument Eeprom ID State| ;Atten 1 Eeprom ID State| ;Atten 2 Eeprom ID State| ;Audio Eeprom ID State| ;BaseBandGen 1 Eeprom ID State| ;BaseBandGen 2 Eeprom ID State| ;Demod DC Eeprom ID State| ;Digital Mother Board Eeprom ID State| ;IQ Output 1 Eeprom ID State| ;IQ Output 2 Eeprom ID State| ;IVF Meas Eeprom ID State| ; Jumper Board Eeprom ID State| ; Meas DC Eeprom ID State| ;RF Mother Board Eeprom ID State| ;RF Interface Eeprom ID State| ; Ref Mod Eeprom ID State| ;Sig Gen 1 Eeprom ID State| ; Sig Gen 2 Eeprom ID State| ;Time Ref Eeprom ID State| ;Display Interface Eeprom ID State| ;Rear Panel Eeprom ID State

Related Topics

Standard Event Status Register


+500 to +599 Test Application Hardware Device-Specific Error

+500 to +599 Test Application Hardware Device-Specific Error

Description

These errors are generated when a problem occurs with a hardware module that is required for a particular application.When one of these errors is generated, the `+500 errors' bit in the questionable error status register is set.

+500 through +599 Error Messages
Error Message | Description
+501 Protocol logging failure; No observation points enabled | This error message is displayed for information purposes only.
+519 Configuration error; DUT IP addresses must be unique |
+520 Configuration error; DUT IP address must be on same subnet as instrument | This error message is generated if the DUT IP address is not on the same subnet as the instrument. This situation may arise because the instrument IP address was set after the DUT IP address, or the instrument subnet mask changed.
+521 Configuration error; DUT IP address cannot be the same as the instrument LAN address | This error message is generated if the DUT IP address and the instrument IP address are the same. This situation may arise because the instrument IP address was set after the DUT IP address.
+522 Configuration Error; Operation Rejected Due To Invalid IP Address | This error is returned when attempting to Connect to External 8960 if the Ext 8960 IP Addr is invalid.
+524 Operation rejected; External PDSN state can not be changed while data connection is dormant | This error message is displayed for information purposes only.
+525 Configuration error; External PDSN IP address must be on same subnet as instrument |
+526 Configuration error; External PDSN IP address cannot be the same as instrument LAN address | This error message is generated if the External PDSN IP address and the instrument IP address are the same.
+527 Operation rejected; External PDSN state change to on not allowed if external PDSN IP address is undefined | This error message is displayed for information purposes only.
+528 Operation rejected; External PDSN service not available; external PDSN state set to off | This error message is displayed for information purposes only
+529 Warning; External PDSN control connection dropped; external PDSN state set to off. | This error message is associated with a lost control connection between test set and MOB-IP-SIM.
+530 Operation rejected; External PDSN settings cannot be changed when external PDSN state is on. | This error message is displayed for information purposes only.
+531 Operation rejected; External PDSN state cannot be changed while a data connection is established. | This error message is displayed for information purposes only.
+532 Warning; External PDSN data connection dropped | This error message is associated with a lost data connection between MOB-IP-SIM and MS.
+533 Operation rejected; ping DUT functionality is not available while external PDSN state is on. | This error message is displayed for information purposes only.
+534 Operation Rejected; No Response From The External Device | This error is returned when attempting to Connect to External 8960 if the external 8960 does not respond to the connection request.
+535 External 8960 LAN connection request rejected[; Because <reason>] | <reason> could be one of these two strings: a. external 8960 connection is not allowed; b. call processing is in progress.
+536 Warning; Connection Is Already Established With The External Device | This error is returned when attempting to Connect to External 8960 if your test set is already connected to the external 8960.
+537 Operation Rejected; Change Allowed Only When A Connection To An External Device Does Not Exist | This error is returned when attempting to set the Ext 8960 IP Addr while External Device Conn Status is not Disconnected .
+538 Operation Rejected; External 8960 Test Set IP Address Cannot Be The Same As Instrument LAN IP Address | This error is returned when attempting to set the Ext 8960 IP Addr to the same value as LAN IP Address .
+539 Warning; Connection To The External Device Has Been Lost; check call status to determine if any active calls have been disconnected | This error occurs if the External Device Connection is broken (for example, if you disconnect the LAN cable from the test set).
+540 Operation Rejected; Cannot Process Request While Attempting To Connect To Or Disconnect From The External Device | This error is returned when attempting to Connect to External 8960 or Disconnect from External 8960 if the External Device Conn Status is Connecting or Disconnecting .
+541 Operation Rejected; External 8960 Test Set IP Address Cannot Be The Same As The DUT IP Address | This error is returned when attempting to set the Ext 8960 IP Addr to the same value as DUT IP Address .
+542 Operation Rejected; Service Not Available Without A Connection To An External Device | This error is returned when attempting to originate an end-to-end service without an External Device Connection in place.
+543 HTTP Client Error; failed to create socket |
+544 HTTP Client Error; failed to connect to the socket |
+545 HTTP Client Error; invalid IP address specified |
+546 HTTP Client Error; timeout |
+547 HTTP Client Error; could not access socket |
+548 HTTP Client Error; bad request URL |
+549 Operation rejected; External 8960 test set IP address cannot be the same as the other external 8960 IP address | This error message is displayed for information purposes only.
+550 HTTP SMS request ignored; Request parameter out of range | This error is generated in response to a request URL for a mobile terminated SMS arriving at the test set's HTTP interface containing a parameter value out of the supported range.
+551 HTTP SMS request ignored; Incompatible parameters in request | This error is generated in response to a request URL for a mobile terminated SMS arriving at the test set's HTTP interface containing parameters that can not be used together in the same request URL.
+552 HTTP SMS request ignored; Missing mandatory parameter in request | This error is generated in response to a request URL for a mobile terminated SMS arriving at the test set's HTTP interface that does not contain parameters required by the test set.
+553 HTTP SMS warning; Output message URL exceeded maximum length and has been truncated | This error is generated when the constructed URL received by the test set's HTTP interface for a mobile originated SMS message exceeds the maximum size of 1500 characters. This generally occurs if one or more tags have been duplicated in the output URL format string, causing the length restriction to be exceeded.
+560 Data out of range; Total Baseband Studio multi-path relative levels' sum invalid; no change |
+561 Operation failed; The external device connection request failed likely because there is a firmware incompatibility between the two connecting devices. See www.agilent.com/find/8960upgrades for additional information | The underlying architecture of the External Device Connection feature has changed over time. The two implementations are not compatible. To establish an External Device Connection between two test sets, the test sets must have compatible firmware (see www.agilent.com/find/8960upgrades for more information)
+562 Operation failed; The incoming request for an external device connection request failed likely because there is a firmware incompatibility between the two connecting devices. See www.agilent.com/find/8960upgrades for additional information | The underlying architecture of the External Device Connection feature has changed over time. The two implementations are not compatible. To establish an External Device Connection between two test sets, the test sets must have compatible firmware (see www.agilent.com/find/8960upgrades for more information)
+563 Operation rejected; Calling party number 1 and calling party number 2 can not be set to the same number. | This error is generated when calling party1 number is set to the same value as calling party 2 number.
+564 Operation rejected; Requested DUT IP address is currently in use | This error is generated if the DUT address is currently assigned to a mobile device for an active data session. The device may be directly connected to the local 8960, or may be connected to a remote 8960, with an external connection to the local 8960. Specifically this can occur if the data connection was first established on the local 8960, but a cell transition occurred (handover) while the two 8960s were externally connected.
+565 Operation aborted; Signal was lost between 8960s | This error is generated if, after the Execute Ext 8960 Handover immediate action is initiated, a signaling problem occurs with the external 8960 before the appropriate handover message is sent to the UE.
+566 Warning; Signal was lost between 8960s but the operation will still try to continue | This error is generated if, after the Execute Ext 8960 Handover immediate action is initiated, a signaling problem occurs with the external 8960 after the appropriate handover message is sent to the UE.
+567 Operation rejected; Instrument LAN address can not be on same subnet as any DUT routing subnets (192.168.104.0/22) when DUT routing state is on. | This error is generated if any of the IP address or LAN subnet mask are set to an address that brings out any conflict with any of the fixed network routes the operation is rejected when turn on DUT routing.
+568 Operation failed; The external device connection request failed; <<reason> on <unit>> | <reason> could be: 1.CDMA system time synchronization failed 2. Call processing in progress 3. Incorrect state <unit>; Refer to your document CD or go to www.agilent.com/find/8960 for correct configuration 4. External connection not allowed 5. LAN communication error 6. IP address conflict 7. Due to data connection status 8. Due to external device connection status 9. Unkown error 10. Missing feature license 11. Missing hardware 12. Missing feature license and hardware 13. Incompatible firmware revisions14. CDMA system time not synchronized; <unit> could be: 1. on Aux 1 Unit 2. on Aux 2 Unit
+569 Operation rejected; External device connection is not allowed due to External Device Connection Allowed off | This error message is displayed for information purposes only.
+570 Warning; Disconnecting from the external device due to unexpected LAN message received | This error message is displayed for information purposes only.


+600 to +699 Instrument Device-Specific Error

+600 to +699 Instrument Device-Specific Error

Description

These errors are generated when a problem occurs that is specific to one of the test set's instruments. These errors are part of the test set's core. Note that these measurements may not be present in every test application and therefore, these errors may not be present in every test application. There is no plan at present to support test application specific instruments.

An instrument in this context refers to the measurement-like functionality such as the audio generator and not to the test set as a whole.

When one of these errors is generated, the `+600 errors' bit in the questionable error status register is set.

Error Message | Description
+601 Instrument failure; Audio generator hardware is not responding | Indicates a problem occurs when attempting to control the test set's audio generator.
+602 Data out of range; Spectrum Monitor; No peaks left |
+603 Data out of range; Spectrum Monitor; No peaks right |
+604 Data out of range; Spectrum Monitor; No peaks found |
+605 Operation rejected; Spectrum Monitor; Receiver power currently set to Auto |
+606 Operation rejected; Spectrum Monitor; Meas frequency currently set to Auto |
+607 Operation rejected; Spectrum Monitor; Marker Frequency out of Meas Frequency tune range |
+608 Operation rejected; Spectrum Monitor instrument is inactive |
+620 Data out of range; Total multi-tone audio downlink level upper limit exceeded; no change |
+621 Data out of range; Total multi-tone audio uplink level upper limit exceeded; no change |
+622 Warning; Multi-tone audio downlink level over range due to requested setting |
+623 Operation rejected; Multi-tone audio downlink levels cannot be set when total level state is on |
+624 Operation rejected; Multi-tone audio uplink levels cannot be set when total level state is on |
+625 Operation rejected; Multi-tone audio analyzer frequencies cannot be set when use generator frequencies state is on |

Related Topics

Standard Event Status Register


+700 to +799 Test Application Measurement Device-Specific Error

+700 to +799 Test Application Measurement Device-Specific Error

Last updated: December 3, 2008

These errors are generated when a problem occurs that is specific to one of the test set's measurements (such as BERR, or TX power). These are test application specific.

When one of these errors is generated, the `+700 errors' bit in the questionable error status register is set. Refer to Standard Event Status Register for information on this register.

Error Message | Description
+701 GSM measurement failure; TX power hardware is not responding +701 GPRS measurement failure; TX power hardware is not responding | This indicates a problem with your test set's hardware. Please call your local Agilent Service Center.
+702 GSM measurement failure; Power vs time hardware is not responding +702 GPRS measurement failure; Power vs time hardware is not responding | This indicates a problem with your test set's hardware. Please call your local Agilent Service Center.
+703 GSM measurement failure; Phase frequency error hardware is not responding +703 GPRS measurement failure; Phase frequency error hardware is not responding | This indicates a problem with your test set's hardware. Please call your local Agilent Service Center.
+704 GSM measurement failure; Output RF spectrum hardware is not responding +704 GPRS measurement failure; Output RF spectrum hardware is not responding | This indicates a problem with your test set's hardware. Please call your local Agilent Service Center.
+705 GSM measurement failure; Fast bit error hardware is not responding | This indicates a problem with your test set's hardware. Please call your local Agilent Service Center.
+706 GSM measurement failure; Bit error hardware is not responding | This indicates a problem with your test set's hardware. Please call your local Agilent Service Center.
+707 GSM measurement failure; Decoded audio hardware is not responding | This indicates a problem with your test set's hardware. Please call your local Agilent Service Center.
+708 GSM measurement failure; IQ tuning hardware is not responding | This indicates a problem with your test set's hardware. Please call your local Agilent Service Center.
+709 GSM measurement failure; Dynamic power hardware is not responding | This indicates a problem with your test set's hardware. Please call your local Agilent Service Center.
+729 GSM measurement warning; Dynamic Power measurement has been closed | Indicates that a measurement has been inactivated because of a resource conflict.


+800 to +899 Core Measurement Device-Specific Error

+800 to +899 Core Measurement Device-Specific Error

Description

These errors are generated when a problem occurs that is specific to one of the test set's core measurements (such as analog audio).

When one of these errors is generated, the `+800 errors' bit in the questionable error status register is set.

Error Message | Description
+801 Measurement failure; Analog audio hardware is not responding | Indicates that a problem occurs when attempting to control the measurement's hardware.
+802 Measurement failure; Audio analyzer hardware is not responding | Indicates that a problem occurs when attempting to control the measurement's hardware.
+803 Measurement failure; Signal Finder hardware is not responding |
+805 Measurement failure; Multi-tone audio hardware is not responding |

Related Topics

Standard Event Status Register


Fast Bit Error Troubleshooting

Fast Bit Error Troubleshooting

Possible Setup Issues

This measurement is not applicable to GPRS or EGPRS. To run this measurement ensure the test set is configured for GSM measurements.

During remote operation of the Fast BER measurement you should configure the trigger arm to single, see SETup:FBERror .

If the trigger arm is not set to single, the measurement may not return a result. When trigger arm is continuous the measurement rearms itself and starts another measurement cycle, during remote operation the fetch query may not be synchronized to the measurement cycle, see Measurement States .

Set signalling loopback control to on; if signalling loopback control is off, set loopback to Type C, see CALL:TCHannel:LOOPback .

The test set may never correlate the uplink and downlink, see SETup:FBERror:LDControl:AUTO so that the measurement appears to hang. The mobile station may not have closed its loop after the loopback type was set. You must allow sufficient time for the mobile station to close its loop and set time out mechanisms see SETup:FBERror:TIMeout[:STIMe] .

Interpreting Integrity Indicator values

See Integrity Indicator .

Questionable Result for PGSM (15) Fast BER measurement appears to work but it is only possible on a Phase 2 GSM system.


Frequency Stability Measurement Troubleshooting

Frequency Stability Measurement Troubleshooting

Possible Setup Issues

The Trigger Arm should always be set to Single for GPIB operation (not Continuous ).

If Trigger Arm is set to single, you must press START SINGLE to start the measurement from the front panel.

This measurement can only be used for analog signals.

The expected signal frequency and input level must be specified for accurate measurements (see Receiver Control ).

Ensure that the input signal meets the Input Signal Requirements .

Related Topics

Frequency Stability Measurement Description


Using GPIB Command Debug Mode

Using GPIB Command Debug Mode

Description

It is recommended that you set the test set's operating environment to debug during GPIB code development. Test times may be longer than necessary if the debugger state is left on. When debug mode is on, the error message displayed on the test set's front panel when incorrect GPIB syntax is sent to the test set is enhanced with additional information to help you correct the syntax error.

To set the test set debug mode to "ON" use the following syntax:

SYSTem:COMMunicate:GPIB:DEBug ON

Related Topics

SYSTem:COMMunicate:GPIB:DEBug[:STATe] .


AMR In-Band Frame Error (IFER) Measurement Troubleshooting

AMR In-Band Frame Error (IFER) Measurement Troubleshooting

Possible Setup Issues

If a GSM BER measurement or GSM FBER measurement is started while the IFER measurement is in progress, the IFER measurement will close.

A GSM voice call must be originated from the mobile station or the test set before an IFER measurement can begin.

In order to run the AMR IFER measurement, the Logical Speech Channel must be set to on of the AMR related speech channels, wither AFS (Adaptive Full) or AHS (Adaptive Half).

An IFER measurement can only be made when the Operating Mode is set to Active Cel l and the Serving Cell is GSM , GPRS , or EGPRS and when the Connection Type is Auto or when the Operating Mode is GSM BCH+TCH. If the connection type is not Auto, any origination from the test set will be a data connection. AMR does not work for data connections.

The mobile station must be capable of performing a Loopback Type I, otherwise the measurement results cannot be guaranteed to be accurate. The measurement is always available regardless of the capabilities of the mobile station.

When the IFER measurement activates, it overrides the setting for the current codec. When the IFER measurement is deactivated, the current codec is set on the downlink traffic channel. Any changes to the current codec set and/or thresholds that are made during the IFER measurement are ignored until the next call is initiated.

When configuring AMR parameters through the front panel under the Codec Setup menu, Apply Changes ( F5 ) must be pressed to save the new configuration.

GSM Phase 1 mobiles are not required to support enhanced full rate or half rate speech vocoders. Therefore, the behavior of a GSM Phase 1 mobile which does support this may be manufacturer dependent when used with the channel mode function.

Interpreting Integrity Indicators

There must be four codecs defined in the Active Codec Set (ACS) before the IFER measurement will start. If an attempt is made to initiate the IFER measurement when there are not four codecs in the ACS the following message is displayed on the front panel: Unsupported Configuration . The integrity indicator returned via the GPIB commands is +22. For more information on integrity indicators see Integrity Indicator .

Related Topics

In-Band Frame Error (IFER) Measurement Description


I/Q Tuning Troubleshooting

I/Q Tuning Troubleshooting

Possible Setup Issues

On most occasions the test set will be able to select the correct reference frequency when SETup:IQTuning:REFerence[:MANual][:FREQuency][:SELected] is set to AUTO. However, if the I/Q Modulator is very badly calibrated, it is possible that the test set selects the wrong offset. This could be confirmed by using the SETup:IQTuning:REFerence[:MANual][:FREQuency][:SELected] query.

If your measurement results are invalid or look as if they are centered around the wrong frequency, it may be that the carrier frequency is not correctly specified. You must input the carrier frequency into the test set. Invalid measurements may also be caused by modulation data other than all 1s or all 0s, for example, it may be that a midamble is being transmitted.

Interpreting Integrity Indicator Values

See Integrity Indicator .


Multi-Tone Audio Troubleshooting

Multi-Tone Audio Troubleshooting

Possible Setup Issues

During remote operation of the multi-tone audio measurements, you should always set the Trigger Arm to Single. The length of time required to return a measurement over GPIB using continuous triggering varies, but is always longer than when using single triggering. Continuous triggering can also cause problems when the INITiate:DONE? is used.

The Expected Peak Voltage is always set in V peak and cannot exceed 20 V peak (14.1 V rms ).

For accurate measurements, always set all the multi-tone audio measurement setup parameters to their proper settings for the measurement being made. Uplink, Downlink, and SINAD and Distortion measurements typically use different settings depending on the combination used. See Uplink Measurement Mode and Downlink Measurement Mode .

When using an audio breakout on the mobile station, do not connect both the microphone input and the speaker out to the test set at the same time. This will impact measurement accuracy.

The mobile station's echo canceller implementation can impact measurement results. If possilbe, turn this off while making multi-tone audio measurements.

Interpreting Integrity Indicator Values

See Integrity Indicator .

If over range (5) is returned, the input level is greater than 4.9 dB above the Expected Peak Amplitude value or the maximum input level of 20 volts peak.

If under range (6) is returned, the input level is lower than 8 dB below the Expected Peak Amplitude value.

If the signal has both over range and under range conditions, only the over range condition (5) is indicated.


ORFS Troubleshooting

ORFS Troubleshooting

Last updated: December 4, 2008

Possible Setup Issues

During remote operation of the Output RF Spectrum measurement you should configure the trigger arm to single, see SETup:ORFSpectrum .

If the trigger arm is not set to single, the measurement may not return a result. When trigger arm is continuous the measurement rearms itself and starts another measurement cycle, during remote operation the fetch query may not be synchronized to the measurement cycle, see Measurement States .

ORFS due to modulation measurements: Averaging for each measurement, including the zero offset measurement, is performed over 40 or more bits on the front and back of the burst, from bit 15 to 60 and bit 87 to 132. ETSI standards only require measuring the back bits 87 to 132. By making measurements on the front and back of the burst, two measurements per burst are achieved.

When fetching (frequency offsets) for ORFS due to modulation or switching remotely, the values for the offsets are entered after the " ? ", see FETCh:ORFSpectrum:MODulation:FREQuency[:OFFSet][:AVERage]? or FETCh:ORFSpectrum:SWITChing:FREQuency[:OFFSet][:MAXimum]? for GPIB commands.

GPRS and EGPRS Only

In order for the test set to return a valid switching measurement result when measuring two adjacent uplink bursts, you should ensure that the burst you have selected to measure has a higher expected power level than the other uplink burst in the multislot configuration. If the selected burst has a lower expected power level, the same hardware range settings cannot be used for both the modulation and switching measurements and the test set returns NAN for the switching measurement. The expected power can be set manually using RFANalyzer:MANual:POWer:BURSt<[1]|2|3|4|5|6|7> .

Interpreting Integrity Indicator values

See Integrity Indicator .

If over range (5) is returned the input signal is likely to clip during the useful part of the burst or the ORFS TX Power measurement has detected an over range.

If signal too noisy (10) is returned, the actual power at certain offsets is > 8 dB off from the expected level.

If under range (6) is returned; the measured power result is more than 10 dB below the expected input power level. Under range is also indicated if, the input power is more than 2 dB below the calibrated range of the test set's power detector for the RF Range setting. RF Range is automatically set based on the input power setting. Input power is a combination of amplitude offset and expected power settings. See Mobile Station Receiver Example .


Phase and Amplitude versus Time Troubleshooting

Phase and Amplitude versus Time Troubleshooting

Last updated: December 4, 2008

This measurement is only applicable to the GSM/GPRS/EGPRS lab applications and test applications with the required feature licenses.

Setup and data output for this measurement is only available via the GPIB commands.

The interval count and the number of interval centers and interval widths must be consistent. The number of returned results depends on the interval count. If the number of centers and/or widths is less than the step count, invalid data is returned.

Many of the SETup and FETCh commands for the Phase and Amplitude versus Time measurement only apply to one of the waveform types. See Phase and Amplitude versus Time Measurement Parameters for information.

Certain restrictions apply to the ranges of the step widths and step centers. For details, see the description for SETup:PCALibration:STEP:WIDth (step width) and SETup:PCALibration:STEP:CENTer (step center).

Initiating this measurement automatically aborts any measurement that is currently in progress.

Using a Spectrum Analyzer is a good way to troubleshoot the calibration signal the mobile is sending to the test set. You can do this by connecting the mobile station to the test set and the Spectrum Analyzer via an RF splitter.

You must run the Spectrum Monitor calibration at least once a month, more frequently if the temperature changes by +/- 10 °C.

If you got an error message saying "Operation rejected; Feature is not licensed. See www.agilent.com/find/8960upgrades for additional information". The possible reason could be because you do not have the correct license, or that for the license you have you need to set the waveform type to CONT2.

Related Topics

Phase and Amplitude versus Time Measurement Description


Phase and Frequency Error Troubleshooting

Phase and Frequency Error Troubleshooting

Last updated: June 29, 1999

Possible Setup Issues

During remote operation of the Phase and Frequency Error measurement you should configure the trigger arm to single, see SETup:PFERror:CONTinuous .

If the trigger arm is not set to single, the measurement may not return a result. When trigger arm is continuous the measurement rearms itself and starts another measurement cycle, during remote operation the FETCh query may not be synchronized to the measurement cycle, see Measurement States .

The Manual Frequency must be offset by +/- 67.7083 kHz in order to measure non-bursted or non-GMSK modulated signals.

If the Trigger Source is set to RF Rise and the signal measured is not burst modulated the measurement will wait until aborted or timed out.

If the input signal is more than 10 dB below the Expected Power, see Expected Power Control or if the input signal is below -30 dBm there is not enough power to generate an RF Rise trigger so the measurement will hang.

Interpreting Integrity Indicator values

See Integrity Indicator .

If the signal has both over range (5) and under range (6) conditions only the over range (5) is indicated.

Syn Not Found (11) will be returned if the measurement Burst Synchronization is set to Midamble synchronized and Expected Burst pattern is not set to TSC0 through TSC7, or RACH. see CALL:BURSt .

If the burst is not continuous in a flexible timeslot configuration, for example, if the total number of uplink bursts is 6 and the bursts are transmited in TS0, TS1, TS2, TS4, TS5 and TS6 respectively, then valid results will be returned for burst 1, 2, and 3, Sync Not Found (11) will be returned for burst 4, 5, 6 and 7.


Power versus Time Troubleshooting

Power versus Time Troubleshooting

Last updated: December 4, 2008

Possible Setup Issues

During remote operation of the Power versus Time measurement you should configure the trigger arm to single, see SETup:PVTime:CONTinuous[:SELected] .

If the trigger arm is not set to single, the measurement may not return a result. When trigger arm is continuous the measurement rearms itself and starts another measurement cycle, during remote operation the FETCh query may not be synchronized to the measurement cycle, see Measurement States .

If the Trigger Source is set to RF Rise and the signal measured is not burst modulated the measurement will wait until aborted or timed out.

If the input signal does not rise above the threshold set at 20 to 30 dB below the Expected Power, see Expected Power Control there is not enough power to generate an RF Rise trigger so the measurement may hang.

Time Offset Range Restrictions for GPRS and EGPRS Mobiles

When you want to perform a Power versus Time measurement on a GPRS or EGPRS mobile which supports a two uplink multislot configuration, there are restricted ranges for the power offset times to ensure that a valid result is returned. This restriction is a function of the expected power for each burst and the guard period as shown in the table below.

Restricted Ranges for GMSK Multislot Power Offset Times
 | Expected Power of Burst 1 is less than or equal to Burst 2
Guard Period | Burst 1 | Burst 2
9 bits | -50 us to 542.8 us | -33.2 us to 593 us
10 bits | -50 us to 542.8 us | -36.9 us to 593 us

Interpreting Integrity Indicator values

See Integrity Indicator .

If over range (5) is returned; the PvT input power has exceeded the test set's internal sampler maximum value during some part of the sampling or the input power has exceeded the calibrated range of the test set's power detector for the RF Range setting. RF Range is automatically set based on the input power setting. Input power is a combination of amplitude offset and expected power settings. See Mobile Station Receiver Example .

If the signal has both over range and under range conditions only the over range (5) will be indicated.

If under range (6) is returned; the PvT Transmit Power result is more than 10 dB below the expected input power level. Under range is also indicated if, the input power is more than 2 dB below the calibrated range of the test set's power detector for the RF Range setting. RF Range is automatically set based on the input power setting. Input power is a combination of amplitude offset and expected power settings. See Mobile Station Receiver Example .

Sync Not Found (11) will be returned if the measurement Burst Synchronization is set to Midamble synchronized and the Expected Burst pattern is not set to TSC0 through TSC7, or RACH. Note that the Expected Burst parameter is only used when the test set's operating mode is set to Test Mode or when the Cell Activated state is set to Off. See CALL:BURSt:TYPE[:SELected] .

Sync Not Found (11) is returned if a valid midamble cannot be found when measuring two adjacent uplink bursts. The measurement still completes on a best effort basis using RF Amplitude synchronization. See Burst Synchronization of Measurements .

Parameter Error (21) is returned if you measure more than 2 uplink bursts when Burst Capture Range is set to Single.

Parameter Error (21) is returned if you set a value outside the restricted range of offset times when testing a GPRS or EGPRS mobile station with a two uplink multislot configuration. For more details, see Time Offset Range Restrictions for GPRS and EGPRS Mobiles .

Unsupported Configuration (22) is returned if the multislot configuration of more than 2 uplink bursts is selected and the Burst Capture Range is set to Single.

Unsupported Configuration (22) is returned if you measure GSM RACH burst when Burst Capture Range is set to All.


RACH Troubleshooting

RACH Troubleshooting

Last updated: December 4, 2008

Possible Setup Issues

Ensure that the multi-measurement count is set to Off for a RACH measurement in either manual or remote operation. The measurement will not complete if multi-measurement count is set to On.

For more information, refer to one of the commands listed below if necessary:

  • SETup:PVTime:COUNt:STATe
  • SETup:TXPower:COUNt:STATe
  • SETup:PFERror:COUNt:STATe

Interpreting Integrity Indicator values

See Integrity Indicator .


Spectrum Monitor Troubleshooting

Spectrum Monitor Troubleshooting

Last updated: December 4, 2008

Possible Setup Issues

During remote operation of the Spectrum Monitor you should configure the trigger arm to single, see SETup:SMONitor .

The Spectrum Monitor may not return a result when the trigger arm is set to a setting other than single. When trigger arm is continuous, the Spectrum Monitor rearms itself and starts another measurement cycle. The fetch query may not be synchronized to the measurement cycle during remote operation (see Measurement States ).

The results returned will be unreliable if Trigger Source Immediate is used for burst modulated signals. Burst modulated signals should be measured with Trigger Source set to RF Rise or Auto. For RF Rise triggering to work correctly, the signal should be no less than 20 dB below the reference and greater than -20 dBm.

Interpreting Integrity Indicator values

See Integrity Indicator .


Test Set Lockup During Power Up Sequence

Test Set Lockup During Power Up Sequence

Last updated: December 4, 2008

Description

Loading application firmware onto your test set that is not compatible with your test set's hardware configuration will cause your test set to lock up when restarted.

For information on application firmware and test set hardware compatibility, see:

http://www.agilent.com/find/E5515

(select either E5515B or E5515C Release Notes).

Test sets shipped after February, 2004 include a lockup recovery utility in the event that a test set lockup occurs. If your test set has locked up during its power up sequence, turn the test set off. Turn the test set back on, and when the following text is displayed:

"Press `SYSTEM CONFIG' key to enter application selection utility."

press the SYSTEM CONFIG key.

If you press the SYSTEM CONFIG key within five seconds from the time this message is first displayed, a menu of installed applications is displayed that allows you to select an application to load.

Select an application that is compatible with your test set's hardware by entering the appropriate number listed on the display using the DATA ENTRY keys.


Troubleshooting Training Sequence Code

Troubleshooting Training Sequence Code

Last updated: December 4, 2008

This section provides troubleshooting tips on setting the Training Sequence Code (TSC) in the test set.

The test set's BCC and Expected Burst parameters must be set to the TSC used by the mobile station in order for the test set to synchronize with the mobile station.

When the Operating Mode is set to one of the Test Mode Operating Modes , both the BCC (Base Station Color Code) and the Expected Burst TSC must be set to the same TSC value on the test set that your mobile station uses.

When the Operating Mode is set to an Active Cell operating mode, the mobile station automatically sets the uplink TSC to match the downlink TSC (configured with the BCC parameter) in the test set when a voice or data call is made.

The default value for the BCC is 5. This setting for the BCC (or downlink TSC) must match the downlink TSC used by your mobile station.

Related Topics

Training Sequence Code (TSC) .


Troubleshooting the Two-Cell Test System

Troubleshooting the Two-Cell Test System

Last updated: December 4, 2008

Description

Possible Setup Issues

  • Important : DUT IP Address must be set to a different value in each test set in the two-cell test system.
  • The operating mode in both test sets must be set to Active Cell in order to perform cell transitions, as this is the only operating mode that provides signaling to the mobile.
  • While operating in the GSM/GPRS/EGPRS application/format, the connection type must be set to Auto in both test sets of the two-cell test system in order to maintain IP-based data connections during cell reselection. Any other connection type setting terminates the active data connection during cell reselection and does not restart the data connection once cell reselection is complete.
  • It is recommended that you configure the neighbor cell list in each test set to contain the other test set's information (using the SIB 11 Cell Info List in W-CDMA/HSPA or the Cell Lists in GSM/GPRS/EGPRS). This enables the mobile to measure the other test set before transitioning to it (some mobiles will not perform a "blind" handover) and allows you to view the mobile's measurement reports for the test set. Ensure that you have properly configured the mobile measurement reports for measuring the destination test set's current configuration by using the Compressed Mode settings in W-CDMA/HSPA (the HSUPA packet data service in the test set does not currently support compressed mode) or the Measurement Reports settings in GSM/GPRS/EGPRS.
  • Network Control Order in the GSM/GPRS/EGPRS application determines how the mobile should perform cell reselections. If Network Control Order is set to NC0 or NC1 in the test set to which the mobile is currently attached, it may not respond to network-initiated attempts at cell reselection. Also, if the test set to which the mobile is attached has Network Control Order set to NC2 , the mobile may not perform autonomous cell reselection.

Operating Considerations

  • Mobile initiated cell reselections made during GSM/GPRS/EGPRS PS data transfer mode may result in a TBF aborted by the mobile with no indication provided to the test set as to why the abort is occurring. In this circumstance, a warning appears at the test set from which the mobile is moving.
  • When performing a cell reselection from GSM/GPRS/EGPRS while actively transferring data, data may arrive for the mobile at the originating test set after the mobile has moved from the originating test set, but before it has arrived at the destination test set. In this case, the originating test set posts an error, but the reselection is not impacted. Once the mobile is established at the destination test set, all subsequent data is tunneled to the mobile at the destination test set.
  • Since the two-cell test system allows you to control when handovers and cell reselections occur, the measurement reports that are returned periodically by the mobile are not used by the test sets. you must order network-initiated cell transitions; it is not possible for the test sets to automatically order the transitions based on measurement reports from the mobile
  • The DUT IP Address setting is inaccessible if the mobile is connected to the current test set but using an IP address originally assigned by the other test set. When a mobile has an active PDP context with one test set and transitions to another, a tunnel is created to route data to and from the mobile via the originating test set. During tunneling, the mobile uses the DUT IP Address provided by the originating test set, not the DUT IP Address of the serving test set. In this case, the IP data trace is shown on the Data Throughput Monitor of the originating test set; only the OTA data trace is shown on the destination test set's Data Throughput Monitor. Refer to the External Device Connection documentation for additional information.
  • The External Device Connection is disconnected as a result of a full preset. You must re-establish the External Device Connection before continuing two-cell testing.

Related Topics

Two-Cell Test System

How Do I Set Up and Test Cell Selection and Transitions?

How Do I Make an External Device Connection?

External Device Connection

Configuring the Test Set's LAN


Transmit Power Troubleshooting

Transmit Power Troubleshooting

Last updated: December 4, 2008

Possible Setup Issues

Configure the trigger arm to single during remote operation of the Transmit Power measurement, see SETup:TXPower .

The measurement may not return a result if the trigger arm is not set to single. When trigger arm is continuous, the measurement rearms itself and starts another measurement cycle. The fetch query may not be synchronized to the measurement cycle during remote operation, see Measurement States .

The results returned will be unreliable if Trigger Source Immediate is used for burst modulated signals. Burst modulated signals should be measured with Trigger Source set to RF Rise or Auto.

Interpreting Integrity Indicator values

See Integrity Indicator .

If over range (5) is returned; the input power has exceeded the test set's internal sampler maximum value during some part of the sampling or the input power has exceeded the calibrated range of the test set's power detector for the RF Range setting. RF Range is automatically set based on the input power setting. Input power is a combination of amplitude offset and expected power settings. See Mobile Station Receiver Example .

If the signal has both over range and under range conditions, only the over range (5) will be indicated.

If under range (6) is returned; the Transmit Power result is more than 10 dB below the expected input power level. Under range is also indicated if, the input power is more than 2 dB below the calibrated range of the test set's power detector for the RF Range setting. RF Range is automatically set based on the input power setting. Input power is a combination of amplitude offset and expected power settings. See Mobile Station Receiver Example .


UI Log

UI Log

Last updated: December 4, 2008

Description

To help you troubleshoot or optimize your GPIB control programs, you can configure the test set to capture GPIB interface traffic and store it in the UI (User Interface) Log. To enable GPIB logging, see Step 2: Turn On UI Log GPIB State .

The UI log buffer can store up to 153600 bytes of information with 255 bytes displayed in a row. If the buffer is full, the oldest entry is removed from the top of the log and the newest entry is added to the end.

You can reset and access the UI Log through either the GPIB interface or a Web Browser.

The following procedures demonstrate how to reset and access the UI Log.

  • Step 1: Clear UI Log Data
  • Step 2: Turn On UI Log GPIB State
  • Step 3-1: Get UI Log Data
  • Step 3 - 2: Get Other UI Log Information (Optional)
  • Step 4: Save UI Log Data

Step 1: Clear UI Log Data

Before capturing new GPIB traffic, you can clear the residual information in UI Log storage. Two methods are valid to clear UI Log data storage in the test set:

  • Clear the UI Log via Local Area Network (LAN)

    • Connect your computer to the test set via LAN or directly via a LAN crossover cable.
    • Go to the URL of the test set using a web browser such as Internet Explorer.
      URL in Web Browser to Clear UI Log Data
      Command | Example
      http:// <test_set_ip_address> /uilogclear | http://111.222.333.444/uilogclear

    Clear UI Log Data

  • Clear the UI log via GPIB

    • Connect your computer to the test set via a GPIB interface.
    • Send the GPIB command in the following table to the test set and the log is cleared.

    SYSTem:LOG:UI:CLEAR

    GPIB Command to Clear the UI Log
    Command | Example
    SYSTem:LOG:UI:CLEAR | SYST:LOG:UI:CLEAR

Step 2: Turn On UI Log GPIB State

  • Send the GPIB command in the following table to the test set before you run your test program or send it from the point in your program where it is desired to start GPIB logging.

    NOTE
    The Log GPIB state is reset to OFF after cycling power. It is not reset by a full preset.

    SYSTem:LOG:UI:GPIB[:STATe]

    UI Log GPIB State Command
    Command Example

    SYSTem:LOG:UI:GPIB[:STATe] ON|OFF

    SYST:LOG:UI:GPIB:STAT ON

Step 3-1: Get UI Log Data

  • Go to the URL of the test set using your web browser to retrieve the GPIB log. The GPIB log is displayed in the browser window.

    NOTE
    You must ensure the computer is connected to the test set either via Ethernet LAN or a direct connection using a LAN crossover cable.

    URL in Web Browser to get the UI Log Data
    Command | Example
    http:// <test_set_LAN_IP_Address> /uilog | http://111.222.333.444/uilog
    Display UI Log Data in Web Browser

    NOTE
    In addition to GPIB traffic information, the UI Log also includes data regarding the key presses, knob turns and error messages that occur as you operate your test set from the front panel. Only the lines with the prefix "rem:" indicate the GPIB commands.

The UI Log display is not real time, therefore the latest UI log does not display automatically in the web browser. To capture multiple logs, click Refresh in the View menu.

Step 3 - 2: Get Other UI Log Information (Optional)

You can get more information about UI log data by sending the GPIB queries.

  • Query the number of lines containing GPIB commands in the UI Log

    The GPIB query in the following table returns the number of lines in the log since the last time the log was cleared.

    SYSTem:LOG:UI:COUNt?

    Query the number of lines in the UI Log
    Command Example

    SYSTem:LOG:UI:COUNt?

    SYST:LOG:UI:COUN?
  • Query the string at the specified line in the UI Log

    The GPIB query in the following table returns the string located at the line in the log that you specify. Note that issuing this command turns off GPIB logging. You must turn it back on using the SYSTem:LOG:UI:GPIB[:STATe] command to continue GPIB logging.

    SYSTem:LOG:UI:REPort?

    Query the string in the UI Log
    Command Example

    SYSTem:LOG:UI:REPort? <sp><number value>

    SYST:LOG:UI:REP? 11

Step 4: Save UI Log Data

To save the log in the Web Browser to a file:

  1. In the File menu, click Save As....
  2. In the Save as type: box, select Text File (*.txt).
  3. In the File name: box, type the file name.
  4. Click the Save button.