Here’s the page we think you wanted. See search results instead:

 

Contact an Expert

34980A Instrument Drivers

Updated revisions of the IVI driver (revision 1.3.7.0) and LabView driver (revision 1.3) for the 34980A have been released. These new revisions add support for the 34945A/EXT and now support all 34980A modules. These supersede the driver revision currently shipping on the 34980A Product Reference CD. Your 34980A mainframe must also be running instrument firmware revision 2.05 or later to use these capabilities. The firmware revision is displayed at power on, or can be viewed under the front panel menu. If necessary, you can download the latest firmware from 34980A Firmware Update Revision 2.11.

The drivers can be downloaded by following the link at the bottom of this page. Please be sure to review the release notes under the “More Information” link on the drivers page for additional information on this release.

If you are using National Instruments VISA:

The 34980A IVI drivers may not be able to initialize properly on newer revisions of National Instrument's VISA (known to be an issue with revision 3.2). This causes the IVI-C calls "ag34980a_init" and "ag34980a_InitWithOptions" to fail, as well as the IVI-COM method "Initialize". This is due to a defect with the registration of BasFrmIO.dll in recent revisions of NI's VISA. NI is aware of the problem and will be correcting this in a later revision of NI VISA. The work around for this is as follows:

  1. Open a DOS command prompt.
  2. Navigate to the NI VISA install directory, which is typically something like C:\vxipnp\visacom.
  3. In this directory, you should find the file "BasFrmIO.dll". This is the NI-VISA version of the Formatted I/O component.
  4. Run the following command in that directory: "regsvr32 BasFrmIO.dll".

If you are using older versions of the Keysight I/O Libraries (M.01.01.04 or older):

The Keysight 34980A instrument software drivers currently included on the Product Reference CD do not work properly with older versions of the Keysight I/O Libraries (M.01.01.04 or older). There are two possible solutions to fix this problem. The recommended solution is to download the latest 34980A instrument drivers from the link below.

The second option is a temporary work around and is only needed if you wish to run Revision 1.00 of the 34980A driver with Keysight IO Libraries M.01.01.04 or older. You do not need to perform the steps below if you have already installed the latest 34980A instrument drivers:

  1. Download the file "GlobMgr.dll" on this page into the directory containing VisaCom. This is usually the "C:\Program Files\Visa\VisaCom" directory.
  2. Run the following command:
    regsvr32.exe "C:\Program Files\Visa\VisaCom\GlobMgr.dll"

No previous versions available.