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Introduction
Welcome to the Agilent VEE family! Agilent Visual Engineering 
Environment (VEE) is a powerful visual language environment that 
dramatically reduces your development time. To get you started 
quickly on Agilent VEE, we have prepared this guide to show you how 
to install and use your new software. This guide also contains two 
tutorials that show you how to communicate with an instrument via 
the USB interface, and how to generate and display a waveform from 
a virtual source.

Installing Agilent IO Libraries
The Agilent IO Libraries Suite software is included when you 
purchase Agilent VEE. This software enables you to communicate 
with instruments via serial, USB, GPIB or LAN interfaces. 

You are required to install the Agilent IO Libraries Suite 15.0 before 
installing Agilent VEE if you need to communicate with instruments 
using Agilent VEE. However, you can choose not to install the Agilent 
IO Libraries Suite if you do not use instruments. 

Follow these simple installation steps:

1 Insert Agilent IO Libraries Suite CD into the CD- ROM drive. Click 
Click Here to Install Now in the Agilent IO Libraries Suite 15.0 window 
to begin installation.
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2 The InstallShield® Wizard will guide you through the installation 
process. Click Next to accept the default settings and complete the 
installation.

3 The Agilent Connection Expert Welcome Screen window will 
appear. This application configures the instruments that are 
connected to your PC. You may close this window before 
proceeding to the next step.
Agilent VEE Pro 8.5 & Agilent VEE Express 8.5 Quick Start Guide 3



Installing Agilent VEE Pro or Agilent VEE Express
1 Insert the Agilent VEE installation CD and click Agilent VEE Pro or 

Agilent VEE Express. The InstallShield® Wizard will guide you through 
the installation process. 

In regard to the differences of these products, refer to Page 16.

2 The InstallShield® Wizard will check if Agilent IO Libraries Suite 
15.0 is installed. If it is not, the following message box will appear. 

Click OK, the InstallShield® Wizard will guide you through the 
installation for your Agilent VEE selection in Step 1.

Please note that Agilent IO Libraries Suite 15.0 is a prerequisite if 
you communicate with instruments using Agilent VEE. So, please 
install Agilent IO Libraries Suite 15.0 or greater after finishing this 
installation.
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3 Accept the license agreement, then click Next.

4 Type your name, company name and product key when the 
Customer Information dialog box appears. The product key is 
contained in the Agilent VEE Pro or Agilent VEE Express Product 
Key Certificate. Click Next to accept the default settings. Select 
Typical Setup when prompted to complete the installation.
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Launching Agilent VEE Pro or Agilent VEE Express
Go to All Programs > Agilent VEE Pro 8.5> VEE Pro 8.5 or All Programs > Agilent 
VEE Express 8.5> VEE Express 8.5 to launch Agilent VEE Pro or Agilent 
VEE Express.

You can access the demos, MATLAB examples (only available in 
Agilent VEE Pro) as well as sample programs via the Agilent VEE Pro 
or Agilent VEE Express welcome window. You can close the window 
after exploring it.

You can also open sample programs from the menu bar. To open a 
sample program, go to File > Open Example or Help > Open Example.

Output 
Window

Workspace

Program 
Explorer

Properties
Window

ToolBar

Status Bar

Menu Bar

Welcome 
Window
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Instrument Communication Tutorial
In this tutorial, we will connect to an instrument via the USB 
interface. Ensure that the Agilent IO Libraries Suite 15.0 is installed before 
proceeding. 

If you do not have a USB instrument, the tutorial for a GPIB 
instrument is similar from Step 3 onwards. 

The following screenshots are sourced from Agilent VEE Pro. Agilent 
VEE Express has similar screenshots.

1 Connect to the instrument via any USB port on your PC. Then, 
turn on the instrument, a Found New Hardware Wizard dialog box 
may appear. Just step through the vizard clicking Next.

2 When the Assign USB device alias dialog box appears, you must 
click OK to register the interface to your system. 
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3 Launch Agilent VEE Pro or Agilent VEE Express, if you have not. 
Click the Instrument Manager button on the toolbar. 

4 The Instrument Manager tool window will appear. Click the Find 
Instruments button to automatically detect all instruments

connected to your PC. Click Yes if the Identify Instrument pop- up 
dialog box appears. This automatically identifies the instrument on 
the USB interface. In this example, an Agilent 34410A Digit 
Multimeter is present.

5 Right click newInstrument in the Instrument List panel. Then, 
choose Create Direct I/O Object in the opened context menu to place a 
Direct I/O object for the selected newinstrument on the workspace. 
This object allows you to send/receive commands to/from your 
instrument.
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6 Double- click the Direct I/O object's blue transaction bar to add a 
transaction to the Direct I/O object.

7 Type "*IDN?" (include the quotation marks) in the I/O Transaction 
dialog box as shown below. Click OK to proceed.

*IDN? is one of standard commands for programmable instruments 
(SCPI) command that queries the instrument for its identification 
string.

8 After sending the "*IDN?" query to the instrument, you need to 
read back its response. Double- click the text box of the 
newInstrument object to add a new transaction. This time, select 
the transaction to READ a STRING FORAT text to an output terminal
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named x. The output terminal x will be automatically created when 
you click OK.

9 Select Display > AlphaNumeric and place an AlphaNumeric object on 
the workspace to the right of the Direct I/O object.

10 You will now connect the Direct I/O object to the AlphaNumeric 
object. Place the mouse cursor beside the Direct I/O output 
terminal and a square icon will appear. Left- click and drag a line 
to the input terminal of the AlphaNumeric object. Left- click again 
to complete the connection.

11 Run the program by clicking the Run button on the toolbar.

12 The AlphaNumeric object will display the identification string 
output by the instrument as shown below.

13 To save your VEE code, select File > Save As and name the file as 
Tutorial 1.vee.
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Virtual Source Tutorial
In this tutorial, you will generate and display a waveform from a 
virtual source. No instrument is needed.

1 If you have an existing program in your Agilent VEE Pro or Agilent 
VEE Express workspace, select File > New. Then, select Device > 
Virtual Source > Function Generator and place a function generator 
object on the workspace.

2 By default, the function generator will generate a virtual cosine 
waveform at a frequency of 200 Hz, and an amplitude of 1. 
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3 Select Display > XY Trace and place an XY Trace object to the right of 
the function generator. 

4 Connect the function generator output terminal to the input 
terminal of the XY trace. Place the mouse cursor beside the 
function generator output terminal and a square icon will appear. 
Left- click and drag a line to the input terminal of the XY Trace 
object. Left- click again to complete the connection.

5 Click the Run button on the toolbar and you can see the 
cosine waveform displayed on the XY Trace object. 
12 Agilent VEE Pro 8.5 & Agilent VEE Express 8.5 Quick Start Guide



6 Select Display > Spectrum (Freq) > Magnitude Spectrum and place a 
Magnitude Spectrum object on the workspace below the XY Trace 
object.

7 Connect a second line from the output of the function generator to 
the input of the Magnitude Spectrum object using the same 
left- click and drag method as described in Step 4.

8 Click the Run button and observe the magnitude spectrum 
display. As the waveform is a 200 Hz cosine, the magnitude 
spectrum displayed will be a vertical line at the frequency of 200 
Hz.
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9 Change the waveform function on the virtual function generator to 
a square waveform. 
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10 Click the Run button and observe the difference. Agilent VEE 
gives you the flexibility to analyze your signal source in multiple 
graph displays simultaneously. 

11 To save your VEE code, select File > Save As and name the file as 
Tutorial 2.vee
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Differences Between Agilent VEE Pro and Agilent VEE 
Express

The following table shows the differences between Agilent VEE Pro 
and Agilent VEE Express.

From version 8.5, Agilent also provides Agilent VEE Student for 
academic users.

Features Agilent VEE Pro Agilent VEE 
Express

Interfaces GPIB, LAN, 
RS- 232, VXI, PXI, 

SCXI

USB
(Agilent USB 

devices in 
LiveMode Only)

MatlabScript objects & MatlabScript 
engine

Creating RunTime version of Agilent 
VEE programs and secured version of 
Agilent VEE objects

Programmatic changing of instrument 
address

The Callable Server feature, i.e. calling 
Agilent VEE as an ActiveX Automation 
server

The Remote Function feature, i.e. 
importing a UserFunction that runs in 
another Agilent VEE process on a 
remote host computer

Other features
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Agilent VEE 8.5 New Features
Modern Integrated Development Environment 
(IDE)-- The Integrated Development Environment in 
version 8.5 gives the user a more modern and 
streamlined programming experience. This feature 
provides the user with additional functionalities and 
flexibilities including the ability to customize the 
development environment to better meet their needs. 
With version 8.5, you can dock, float, hide, move all 
your tool windows, such as Instrument Manager, 
Function & Object Browser, Program Explorer, 
Properties window, Watch window, Output Window, Call Stack, Profiler, etc.

Microsoft Windows Vista Support-- With Agilent VEE 8.5, you can take advantage of the latest 
Microsoft Operating System that is more secure and easier to use. The Windows Aero 
interface, the Windows Instant Search, and the Windows Sidebar bring you a new Microsoft 
Windows experience. The User Account Control (UAC) as well as other security related 
features will help maintain the health and security of your PC. 

All Agilent VEE configuration files are saved with a per user and per version style.

Microsoft Office 2007 Support -- Agilent VEE 8.5 supports Microsoft Office 2007 including the 
updated built-in Excel menu.

MATLAB 2007a Support -- Agilent VEE Pro 8.5 upgrades the MATLAB support to MATLAB 
2007a.

Color Coding -- This feature makes Agilent VEE programs easier to read by coloring different 
types of objects with different colors automatically. Users can also color objects as they need 
and export/import the color theme to share with others.

Uncertain Data Flow Complier Warning --Agilent VEE 8.5 will give a warning when potential 
compiler problem is found in an Agilent VEE program. Tips on how to avoid such compiler 
problems are also provided in Agilent VEE online help.

Graphical Display Objects Enhancement -- In Agilent VEE 8.5, all graphical display objects, 
such as XY trace, Strip Chart, etc., can display up to 255 traces.
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Instrument Manager -- The Instrument Manager in 
version 8.5 is not only a tool window with 
brand-new UI which can dock, auto hide, or float, 
but it also provides more convenient features, 
including context menu and toolbar, to find, add, 
remove, and configure instruments and to create IO 
objects quickly.

Using Agilent IO Monitor to Monitor Instant Communications-- Agilent VEE8.5 replaces the 
old Bus I/O Monitor object with the Agilent IO Monitor, which is more powerful and easier to 
use.

Function & Object Browser (FOB) -- The newly designed Function & Object Browser allows 
you to easily browse and select functions and objects available for use in your program. 

Output Window --This feature helps you to debug your programs by logging Warning and Error 
messages during both run time and design time.

Dynamically change VISA interface and Address -- With version 8.5, by changing the VISA 
interface and address programmatically, you can communicate with the same instrument via 
different interfaces and addresses without extra configuration or coding. 

Exposing Main from Callable Server -- Users can now call the Main UserObject in programs 
written in other languages such as C#, Visual Basic, C++, Excel Macro, and etc. through the 
Callable Server interface.

Microsoft Standard File Open Dialog -- In Agilent VEE 8.5, the old file open dialog box, which 
appears when you use the To/From File, To/From Dataset, or Import Library objects, is replaced 
by the standard Windows file open dialog box.

New Execution Mode and New Data Type -- Beginning with version 8.5, Agilent VEE supports 
a new data type - UInt16 and a new Execution Mode - VEE 8.5.

VISA Change for ViReal32 -- Agilent VEE 8.5 supports ViReal32, ViReal32 [] and pViReal32 
according to the latest VISA specification.
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Agilent Connectivity Products

Agilent provides a complete range of high performance and highly 
reliable products to connect from your PC to your instruments. These 
include networked USB hub, LAN/GPIB gateway, PCI GPIB, USB/GPIB 
and USB/RS232 interfaces. For more information on Agilent 
connectivity products, visit www.agilent.com/find/io.

Agilent Support, Services and Assistance
With Agilent VEE Pro & Agilent VEE Express, you have access to 
Agilent’s worldwide resources for start- up assistance, training classes, 
and update services. As part of the purchase of any Agilent VEE 
product you are entitled to receive technical support free of charge. 
There is no need to register. 

Additional consulting services are available from Agilent. There are 
currently over 30 companies available in North America, Europe, 
Middle East and Asia to help you develop your Agilent VEE solution.

Sign up for the Agilent VEE electronic users group at 
http://www.agilent.com/find/vrf, and get help on using Agilent VEE 
from experts around the world.
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Appendix
Agilent VEE Pro Help is now available in other languages. Please 
rename vee.chm in your installation directory to veeEnglish.chm, then 
rename your preferred localized version to vee.chm. For example, 
rename veeJapanese.chm to vee.chm.
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Einführung
Willkommen im Kreis der Agilent VEE- Nutzer! Agilent Visual Enginee-
ring Environment (VEE) ist eine leistungsfähige visuelle Entwicklungs-
umgebung, mit der Sie Ihre Programme erheblich schneller erstellen 
können. Damit Sie möglichst schnell mit Agilent VEE starten können, 
wird in dieser Anleitung gezeigt, wie die neue Software installiert und 
verwendet wird. Außerdem beinhaltet diese Anleitung zwei Übungs-
einheiten, in denen erläutert wird, wie über die USB- Schnittstelle auf 
ein Instrument zugegriffen und wie eine Wellenform von einer virtuel-
len Quelle generiert und angezeigt werden kann.

Installieren von Agilent IO Libraries
Die Agilent IO Libraries Suite erhalten Sie beim Kauf von Agilent 
VEE. Mit dieser Software können Sie über serielle, USB- , GPIB-  oder 
LAN- Schnittstellen auf Instrumente zugreifen. 

Die Agilent IO Libraries Suite 15.0 muss installiert sein, bevor Agilent 
VEE installiert wird, wenn Sie über Agilent VEE auf ein Instrument 
zugreifen müssen. Wenn Sie keine Instrumente verwenden, können Sie 
sich jedoch gegen die Installation der Agilent IO Libraries Suite 
entscheiden. 

Führen Sie folgende einfache Installationsschritte aus:

1 Legen Sie die Agilent IO Libraries Suite- CD in das 
CD- ROM- Laufwerk ein. Klicken Sie im Fenster von Agilent IO 
Libraries Suite 15.0 auf Click Here to Install Now, damit die 
Installation gestartet wird.
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2 Der InstallShield® Wizard führt Sie durch die Installationsvorgänge. 
Klicken Sie auf Next, um die Standardeinstellungen zu übernehmen 
und die Installation abzuschließen.

3 Das Fenster Agilent Connection Expert Welcome Screen wird 
angezeigt. Mit dieser Anwendung werden die Instrumente 
konfiguriert, die an den PC angeschlossen sind. Sie können dieses 
Fenster schließen, bevor Sie den nächsten Schritt ausführen.
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Installieren von Agilent VEE Pro oder Agilent VEE Express
1 Legen Sie die Agilent VEE- Installations- CD ein, und klicken Sie auf 

Agilent VEE Pro oder Agilent VEE Express. Der InstallShield® Wizard 
führt Sie durch die Installationsvorgänge. 

Informationen zu den Produktunterschieden finden Sie auf Seite 16.

2 Der InstallShield® Wizard prüft nun, ob Agilent IO Libraries Suite 
15.0 installiert ist. Ist dies nicht der Fall, wird das folgende 
Meldungsfenster angezeigt. 

Klicken Sie auf OK, und der InstallShield® Wizard führt Sie durch die 
Installation für Ihre Agilent VEE- Auswahl in Schritt 1.

Beachten Sie, dass Agilent IO Libraries Suite 15.0 eine Voraussetzung 
für den Zugriff auf Instrumente über Agilent VEE ist. Installieren Sie 
also bitte nach Abschluss dieser Installation Agilent IO Libraries Suite 
15.0 oder höher.
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3 Akzeptieren Sie die Bestimmungen der Lizenzvereinbarung und 
klicken Sie dann auf Next.

4 Geben Sie Ihren Benutzernamen (User Name), den Firmennamen 
(Company Name) und den Produktschlüssel (Product Key) ein, 
wenn das Dialogfenster „Customer Information“ angezeigt wird. Den 
Produktschlüssel finden Sie im Agilent VEE Pro oder Agilent VEE 
Express Product Key Certificate. Klicken Sie auf Next, um die 
Standardeinstellungen zu akzeptieren. Wählen Sie Typical Setup aus, 
wenn Sie aufgefordert werden, die Installation abzuschließen.
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Starten von Agilent VEE Pro oder Agilent VEE Express
Klicken Sie auf Programme > Agilent VEE Pro 8.5> VEE Pro 8.5 oder auf 
Programme > Agilent VEE Express 8.5> VEE Express 8.5, um Agilent VEE Pro 
oder Agilent VEE Express zu starten.

Über die Begrüßungsseite von Agilent VEE Pro oder Agilent VEE 
Express können Sie auf die Demos, die MATLAB- Beispiele (nur 
verfügbar in Agilent VEE Pro) sowie die Beispielprogramme zugreifen. 
Nachdem Sie sich die Begrüßungsseite angesehen haben, können Sie 
diese schließen.

Beispielprogramme können Sie auch über die Menüleiste öffnen. Wenn 
Sie ein Beispielprogramm öffnen möchten, wählen Sie File > Open 
Example oder Help > Open Example aus.

Ausgabe-
fenster 

Arbeits-
bereich

Program 
Explorer

Eigenschaf-
tenfenster 
(Properties)

Symbol-
leiste

Status-
leiste

Menüleiste

Begrü-
ßungsseite
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Zugreifen auf ein Instrument – Übungseinheit
In dieser Übungseinheit wird über die USB- Schnittstelle eine 
Verbindung zu einem Instrument hergestellt. Führen Sie die weiteren 
Schritte erst aus, nachdem Sie sich vergewissert haben, dass die 
Agilent IO Libraries Suite 15.0 installiert ist. 

Wenn Sie kein USB- Instrument haben, können Sie zu Schritt 3 
springen. Die Übungseinheit ist ab diesem Schritt für ein 
GPIB- Instrument gleich. 

Die folgenden Screenshots sind von Agilent VEE Pro erstellt worden. 
Screenshots für Agilent VEE Express sehen ähnlich aus.

1 Stellen Sie über einen USB- Anschluss des PCs eine Verbindung 
zum Instrument her. Schalten Sie anschließend das Instrument ein. 
Das Dialogfenster „Found New Hardware Wizard“ (Assistent für das 
Suchen neuer Hardware) wird angezeigt. Folgen Sie dem 
Assistenten, indem Sie auf Next klicken.

2 Wenn das Dialogfenster „Assign USB device alias“ angezeigt wird, 
müssen Sie auf OK klicken, damit die Schnittstelle auf dem System 
registriert wird. 
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3 Starten Sie Agilent VEE Pro oder Agilent VEE Express. Klicken Sie 
in der Symbolleiste auf das Symbol Instrument Manager . 

4 Das Toolfenster Instrument Manager wird angezeigt. Klicken Sie auf 
die Schaltfläche Find Instruments , um automatisch alle 
Instrumente 

zu ermitteln, die mit Ihrem PC verbunden sind. Klicken Sie auf Yes, 
wenn das Popup- Dialogfenster Identify Instrument angezeigt wird. 
Dadurch wird das Instrument an der USB- Schnittstelle automatisch 
erkannt (identifiziert). In diesem Beispiel ist ein digitales Agilent 
34410A Multimeter vorhanden.

5 Klicken Sie mit der rechten Maustaste im Bereich „Instrument List“ 
auf den Eintrag für das neue Instrument (newInstrument). Wählen 
Sie anschließend Create Direct I/O Object im geöffneten Kontextmenü, 
um das Direct I/O- Objekt für das ausgewählte  neue Instrument 
(newinstrument) auf dem Arbeitsbereich zu platzieren. Über dieses 
Objekt können Sie Befehle an das/vom Instrument 
senden/empfangen.
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6 Doppelklicken Sie auf die blaue Transaktionsleiste des Direct 
I/O- Objekts, damit Sie ihm eine Transaktion hinzufügen können.

7 Geben Sie im Dialogfenster I/O Transaction die Zeichenfolge "*IDN?"  
ein. Geben Sie auch die Anführungszeichen ein (siehe Abbildung). 
Klicken Sie zum Fortsetzen auf OK.

*IDN? ist einer der SCPI- Befehle (Standard Commands for 
Programmable Instruments). Dieser Befehl fragt die 
Identifikationsszeichenfolge eines Instrumentes ab.

8 Nach dem Senden der Abfrage "*IDN?" an das Instrument muss 
dessen Antwort gelesen werden. Doppelklicken Sie auf das Textfeld 
des newInstrument- Objekts, damit Sie eine neue Transaktion hin-
zufügen können. Wählen Sie für diese Transaktion aus, dass sie mit 
einem READ-Befehl Text im STRING FORMAT lesen und an einen 
Ausgabeanschluss mit dem Namen x senden soll 
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Der Ausgang x wird automatisch erstellt, sobald Sie auf OK geklickt 
haben.

9 Wählen Sie Display > AlphaNumeric aus und ordnen Sie ein 
AlphaNumeric- Objekt im Arbeitsbereich rechts neben dem Direct 
I/O- Objekt an.

10 Das Direct I/O - Objekt soll nun mit dem AlphaNumeric- Objekt 
verbunden werden. Platzieren Sie den Cursor neben dem Ausgang 
des Direct I/O- Objekts. Es wird ein quadratisches Symbol angezeigt. 
Klicken Sie mit der linken Maustaste und ziehen Sie eine Linie zum 
Eingabeanschluss (input terminal, Eingang) des AlphaNumeric-
Objekts. Klicken Sie erneut mit der linken Maustaste, um die 
Verbindung abzuschließen.

11 Führen Sie das Programm aus, indem Sie in der Symbolleiste auf 
das Symbol Run klicken.

12 Das AlphaNumeric- Objekt zeigt die Identifikationszeichenfolge an, 
die das Instrument ausgegeben hat (siehe folgende Abbildung).

13 Zum Speichern des VEE- Codes wählen Sie File > Save As aus. Geben 
Sie der Datei den Namen Uebungseinheit 1.vee.
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Virtuelle Quelle (Virtual Source) – Übungseinheit
In dieser Übungseinheit generieren Sie eine Wellenform aus einer 
virtuellen Quelle und zeigen diese Wellenform an. Es ist kein 
Instrument erforderlich.

1 Wenn im Arbeitsbereich von Agilent VEE Pro oder Agilent VEE 
Express ein Programm vorhanden ist, wählen Sie File > New aus. 
Wählen Sie dann Device > Virtual Source > Function Generator aus, und 
ordnen Sie im Arbeitsbereich ein Function Generator- Objekt an.

2 Der Funktionsgenerator erzeugt standardmäßig eine virtuelle 
Kosinus- Wellenform (Cosine) mit der Frequenz (Frequency) 200 Hz 
und der Amplitude 1. 
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3 Wählen Sie Display > XY Trace aus, und legen Sie ein XY 
Trace- Objekt rechts neben dem Function Generator- Objekt ab. 

4 Verbinden Sie den Ausgang des Function Generator- Objekts mit 
dem Eingang des XY Trace- Objekts. Platzieren Sie den Mauscursor 
neben dem Ausgang des Function Generator- Objekts. Es wird ein 
quadratisches Symbol angezeigt. Klicken Sie mit der linken 
Maustaste und ziehen Sie eine Linie zum Eingang des XY 
Trace- Objekts. Klicken Sie erneut mit der linken Maustaste, um die 
Verbindung abzuschließen.

5 Klicken Sie in der Symbolleiste auf das Symbol Run . Danach 
wird die Kosinuswellenform im XY Trace- Objekt angezeigt. 
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6 Wählen Sie Display > Spectrum (Freq) > Magnitude Spectrum aus und 
legen Sie im Arbeitsbereich ein Magnitude Spectrum- Objekt unter 
dem XY Trace- Objekt ab.

7 Ziehen Sie gemäß der in Schritt 4 beschriebenen Methode des 
Linksklickens und Ablegens eine zweite Linie vom Ausgang des 
Function Generator- Objekts zum Eingang des Magnitude 
Spectrum- Objekts.

8 Klicken Sie auf das Symbol Run , und sehen Sie sich die 
Anzeige des Magnitude Spectrum- Objekts an. Da die Wellenform 
einer 200- Hz- Kosinuswelle entspricht, zeigt das Magnitude 
Spectrum- Objekt eine vertikale Linie bei der Frequenz 200 Hz an.
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9 Ändern Sie die Funktion im Generator für virtuelle Funktionen in 
eine rechteckige (Square) Wellenform. 
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10 Klicken Sie auf das Symbol Run  und sehen Sie sich den 
Unterschied an. Agilent VEE bietet Ihnen die Möglichkeit, eine 
Signalquelle gleichzeitig in mehreren Grafikdarstellungen zu 
analysieren. 

11 Zum Speichern des VEE- Codes wählen Sie File > Save As aus. Geben 
Sie der Datei den Namen Uebungseinheit 2.vee
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Unterschiede zwischen Agilent VEE Pro und Agilent VEE 
Express

In der folgenden Tabelle sind die Unterschiede zusammengestellt, die 
es zwischen Agilent VEE Pro und Agilent VEE Express gibt.

Ab Version 8.5 bietet Agilent zusätzlich Agilent VEE Student für 
akademische Benutzer an.

Funktionen Agilent VEE 
Pro

Agilent VEE 
Express

Schnittstellen GPIB, LAN, 
RS- 232, VXI, PXI, 

SCXI

USB
(Agilent USB- Geräte 

nur in LiveMode)

MatlabScript- Objekte und 
MatlabScript- Modul

Erstellen von Laufzeitversionen von 
Agilent VEE- Programmen und geschützten 
(secured) Versionen von Agilent 
VEE- Objekten

Programmgesteuertes Ändern von 
Instrumentenadressen

Funktion Callable Server („Aufrufbarer 
Server“), d. h., Agilent VEE kann als 
ActiveX- Automatisierungsserver 
aufgerufen werden

Verwenden von fernen Funktionen, d. h., 
es können Benutzerfunktionen importiert 
werden, die in einem anderen Agilent 
VEE- Prozess auf einem fernen 
Hostcomputer ausgeführt werden

Weitere Funktionen
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Agilent VEE 8.5 – neue Eigenschaften
Modern Integrated Development Environment (IDE) 
– Die Integrated Development Environment in 
Version 8.5 ermöglicht dem Benutzer eine modernere 
und optimierte Pogrammiererfahrung. Diese Eigen-
schaft stellt dem Benutzer zusätzliche Funktionen und 
Möglichkeiten zur Verfügung, einschließlich der 
Möglichkeit zur Anpassung der Entwicklungs-
umgebung zur besseren Erfüllung der Anforderungen. 
Mit Version 8.5 können Sie alle Toolfenster, wie z. B. 
Instrument Manager, Function & Object Browser, Pro-
gram Explorer, Eigenschaftenfenster (Properties), Anzeigefenster (Watch), Ausgabefenster 
(Output), Call Stack, Profiler usw. ab- und andocken, ausblenden oder verschieben.

Microsoft Windows Vista-Unterstützung – Mit Agilent VEE 8.5 können die Vorteile des 
sichereren und freundlicheren neuen  Microsoft Betriebssystems nutzen. Die Windows Aero 
Schnittstelle, die Windows Sofortsuche und die Windows Sidebar sorgen für eine neue 
Microsoft Windows-Erfahrung. Das Feature User Account Control (UAC) sowie andere 
sicherheitsbezogene Funktionen unterstützen  dabei, die Stabilität und Sicherheit Ihres PCs zu 
erhalten. 

Alle Agilent VEE Konfigurationsdateien werden benutzer- und versionsbezogen gesichert.

Microsoft Office 2007-Unterstützung –  Agilent VEE 8.5 unterstützt Microsoft Office 2007 
einschließlich das aktualisierte, integrierte Excel-Menü.

MATLAB 2007a-Unterstützung  –  Agilent VEE Pro 8.5 aktualisiert die MATLAB-Unterstützung 
auf MATLAB 2007a.

Farbkodierung (Color Coding)  – Diese Funktion sorgt für eine übersichtlichere Darstellung der 
Agilent VEE Programme, da unterschiedliche Objekttypen automatisch mit unterschiedlichen 
Farben dargestellt werden. Benutzer können Objekte ebenfalls nach Bedarf farbig gestalten 
und Farbthemen zur gemeinsamen Nutzung exportieren/importieren.

Warnung zu Compiler-Problemen wegen ungültigen Daten – Agilent VEE 8.5 gibt eine 
Warnung aus, wenn ein potenzielles Compiler-Problem in einem Agilent VEE Programm 
erkannt wird. Tipps zur Vermeidung solcher Compiler-Probleme finden Sie ebenfalls in der 
Agilent VEE Online-Hilfe.

Verbesserung der grafischen Anzeigeobjekte – In Agilent VEE 8.5 können alle grafischen 
Anzeigeobjekte wie z. B . XY Trace, Strip Chart usw. bis zu  255 Kurven anzeigen.
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Instrument Manager – Der Instrument Manager in 
Version 8.5 ist nicht nur ein Toolfenster mit 
brandneuer Benutzeroberfläche, die angedockt, 
automatisch ausgeblendet und abgedockt werden 
kann, sondern bietet zusätzlich benutzerfreundliche 
Funktionen einschließlich Kontextmenü und 
Symbolleiste, um Instrumente zu finden, 
hinzuzufügen und zu entfernen und schnell neue 
IO-Objekte zu erstellen.

Verwendung von Agilent IO Monitor zur Überwachung von direkter Kommunikation – Agilent 
VEE8.5 ersetzt das alte Bus I/O Monitor-Objekt mit dem leistungsfähigeren und 
benutzerfreundlicheren Agilent IO Monitor.

Function & Object Browser (FOB) – Der neu gestaltete Function & Object Browser ermöglicht 
es, problemlos nach etwas zu suchen und Funktionen und Objekte auszuwählen, die für den 
Einsatz in Ihrem Programm zur Verfügung stehen. 

Ausgabefenster (Output) – Diese Funktion unterstützt Sie dabei, in Ihren Programmen nach 
Fehlern zu suchen und diese zu beseitigen, indem Warn- und Fehlermeldungen sowohl 
während der Lauf- als auch der Konzeptionszeit protokolliert werden.

Dynamische Änderung der VISA-Schnittstelle und -Adresse –  Mit Version 8.5 können Sie 
durch programmatische Änderung der VISA-Schnittstelle und -Adresse mit demselben 
Instrument über verschiedene Schnittstellen und Adressen kommunizieren, ohne extra 
Konfiguration oder Kodierungen vornehmen zu müssen. 

Aufrufen von Main über Callable Server („Aufrufbarer Server“) – Benutzer können das Main 
UserObject in Programmen, die in anderen Sprachen wie C#, Visual Basic, C++,  Excel Macro 
usw. geschrieben sind, über die Callable Server-Schnittstelle aufrufen.

Microsoft Standard -Dialogfenster zum Öffnen von Dateien – In Agilent VEE 8.5 wird das alte 
Dialogfenster zum Öffnen von Dateien, das angezeigt wird, wenn Sie die To/From File-, 
To/From Dataset- oder Import Library-Objekte verwenden, durch das standardmäßige Windows 
Dialogfenster zum Öffnen von Dateien ersetzt.

Neuer Ausführungsmodus und neuer Datentyp – Ab Version 8.5 unterstützt Agilent VEE einen 
neuen Datentyp – UInt16 und einen neuen Ausführungsmodus – VEE 8.5.

VISA Änderung für ViReal32 – Agilent VEE 8.5 unterstützt ViReal32, ViReal32 [] und pViReal32 
gemäß der aktuellen VISA-Spezifikation.
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Agilent-Konnektivitätsprodukte

Agilent bietet eine umfassende Palette von sehr leistungsfähigen und 
zuverlässigen Produkten an, über die PCs mit Instrumenten verbun-
den werden können. Dazu gehören ein netzwerkbasierter USB- Hub, 
ein LAN/GPIB- Gateway sowie PCI/GPIB- , USB/GPIB-  und 
USB/RS232-
Schnittstellen. Weitere Informationen zu den Konnektivitätsprodukten 
von Agilent finden Sie hier: www.agilent.com/find/io.

Agilent-Unterstützung, -Dienstleistungen und 
-Aktualisierung

Mit Agilent VEE Pro und Agilent VEE Express haben Sie Zugriff auf 
die weltweiten Agilent- Ressourcen für die Erstunterstützung, für 
Schulungen und für Aktualisierungen. Mit dem Kauf eines beliebigen 
Agilent VEE- Produkts erwerben Sie das Recht, kostenfreie technische 
Unterstützung zu erhalten. Eine Registrierung ist nicht erforderlich. 

Agilent bietet weitere Beratungsdienstleistungen an. In den USA, in 
Europa und im Nahen Osten gibt es momentan mehr als 30 
Unternehmen, von denen Sie beim Entwickeln von Agilent 
VEE- Lösungen unterstützt werden können.

Melden Sie sich für die elektronische Agilent VEE- Benutzergruppe 
unter http://www.agilent.com/find/vrf an. Hier erhalten Sie von 
Experten auf der ganzen Welt Hilfe zum Arbeiten mit Agilent VEE.
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Anhang
Agilent VEE Pro Help steht jetzt auch in anderen Sprachen zur 
Verfügung. Bitte nennen Sie vee.chm in Ihrem Installationsverzeichnis 
in veeEnglish.chm und anschließend Ihre bevorzugte lokalisierte 
Version in vee.chm um. Nennen Sie z. B. veeJapanese.chm in vee.chm.
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はじめに

VEE Proファミリにようこそ！ Agilent VEE（Visual Engineering Environment）
は、開発時間の大幅な短縮を可能にするパワフルなビジュアル言語環境です。本

書は、Agilent VEEの入門ガイドです。Agilent VEEのインストールの仕方と使用

方法について説明します。本書には、USBインタフェース経由での測定器との通

信方法と波形の作成／表示方法を示した2つのチュートリアルが含まれています。

Agilent IO Librariesのインストール

Agilent IO Libraries Suite softwareは、Agilent VEEを購入した際に付属してい

ます。このソフトウェアにより、測定器とシリアル、USB、GPIB、またはLANイ

ンタフェース経由で通信が行えるようになります。 

Agilent VEEを使用して測定器と通信を行う必要がある場合には、Agilent VEEを
インストールする前にAgilent IO Libraries Suite 15.0をインストールする必要が

あります。ただし測定器を使用しない場合は、Agilent IO Libraries Suiteのイン

ストールを行わないよう選択できます。 

以下のインストール手順に従ってください。

1 Agilent IO Libraries Suite CDをCD- ROMドライブに挿入します。Agilent IO
Libraries Suite 15.0ウィンドウのClick Here to Install Nowをクリックしてイン

ストールを開始します。
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2 InstallShield® Wizardの指示に従ってインストール処理を進めます。Nextをク

リックしてデフォルト設定を受け入れ、インストールを完了します。

3 Agilent Connection Expert Welcome Screenウィンドウが表示されます。この

アプリケーションで、PCに接続されている測定器の設定を行います。ウィンド

ウを閉じて、次のステップに進みます。
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Agilent VEE ProまたはAgilent VEE Expressのインストール

1 Agilent VEEインストールCDを挿入し、Agilent VEE Pro、またはAgilent VEE
Expressを選択します。InstallShield® Wizardの指示に従ってインストール処理

を進めます。 

これらの製品の違いに関して、16ページを参照してください。

2 InstallShield® Wizardが、Agilent IO Libraries Suite 15.0がインストールされ

ているかチェックします。インストールされていない場合、以下のメッセージ・

ボックスが表示されます。

OKをクリックし、InstallShield® Wizardの指示に従ってステップ1で選択した

Agilent VEEのインストールを進めます。

Agilent IO Libraries Suite 15.0は、Agilent VEEを使用して測定器と通信を行う

場合の前提条件です。したがって、このインストールの終了後に、Agilent IO
Libraries Suite 15.0またはそれ以上をインストールしてください。
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3 ライセンス契約を承諾し、Nextをクリックします。

4 Customer Informationダイアログ・ボックスが表示されたら、名前、会社名、

製品キーを入力します。製品キーは、Agilent VEE ProまたはAgilent VEE
Express Product Key Certificateに記載されています。Nextをクリックしてデ

フォルト設定を受け入れます。Typical Setupが表示されたらそれを選択し、イン

ストールを完了します。
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Agilent VEE ProまたはAgilent VEE Expressの起動

All Programs > Agilent VEE Pro 8.5> VEE Pro 8.5またはAll Programs > Agilent VEE Express
8.5> VEE Express 8.5に進んでAgilent VEE ProまたはAgilent VEE Expressを起動

します。

Agilent VEE ProまたはAgilent VEE Expressのようこそウィンドウからデモ、

MATLABサンプル（Agilent VEE Proでのみ使用可能）、サンプル・プログラムに

アクセスできます。メニューを確認してからウィンドウを閉じます。

サンプル・プログラムは、メニュー・バーからもオープンできますサンプル・プ

ログラムを開くには、File > Open ExampleまたはHelp > Open Exampleに進みます。

Output　
ウィンドウ

ワークスペース

Program 
Explorer

Properties　
ウィンドウ

ツールバー

ステータス・

バー

メニュー・バー

ようこそ

ウィンドウ
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測定器通信チュートリアル

このチュートリアルでは、USBインタフェース経由で測定器に接続します。作業

を進める前にAgilent IO Libraries Suite 15.0がインストールされていることを確認し

てください。 

USB測定器がない場合、GPIB測定器のチュートリアルはステップ3からほぼ同じです。 

次に示すのは、Agilent VEE Proのインストールの場合のスクリーン・ショットで

す。Agilent VEE Expressでも同様のスクリーン・ショットが得られます。

1 PCのUSBポート経由で測定器に接続します。測定器の電源を入れると、Found
New Hardware Wizardダイアログ・ボックスが表示されます。Nextをクリック

してウィザードの次の画面に移動します。

2 Assign USB device aliasダイアログ・ボックスが表示されたら、OKをクリック

してインタフェースをシステムに登録する必要があります。 
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3 Agilent VEE ProまたはAgilent VEE Expressを起動します（起動していない場

合）。ツールバーのInstrument Managerボタン をクリックします。 

4 Instrument Managerツール・ウィンドウが表示されます。Find Instrumentsボタ

ン

をクリックすると、PCに接続されたすべての測定器が

自動的に検出されます。Identify Instrumentポップアップ・ダイアログ・ボッ

クスが表示されたら、Yesをクリックします。これにより、USBインタフェース

上の測定器が自動的に識別されます。この例では、Agilent 34410Aディジタル

マルチメーターが存在します。

5  Instrument ListパネルでnewInstrumentを右クリックします。次に、開いた

コンテキスト・メニューでC r e a t e  D i r e c t  I / O  O b j e c t を選択し、選択した

newinstrumentのDirect I/Oオブジェクトをワークスペースに配置します。こ

のオブジェクトにより、測定器とのコマンドの送受信が可能になります。

6 Direct I/Oオブジェクトの青のトランザクション・バーをダブルクリックして、

Direct I/Oオブジェクトにトランザクションを追加します。

7 下の図に示すように、I/O Transactionダイアログ・ボックスに"*IDN?"（引用

符を含む）を入力します。OKをクリックして先に進みます。
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*IDN?は、測定器に識別文字列を問い合わせるStandard Commands for 
Programmable Instruments（SCPI）コマンドの1つです。

8 "*IDN?"クエリを測定器に送信したら、その応答をリードバックする必要があり

ます。newInstrumentオブジェクトのテキスト・ボックスをダブルクリックし
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て、新しいトランザクションを追加します。今回は、xという名前の出力端子へ

のSTRING FORMATテキストをREADするためのトランザクションを選択します。

OKをクリックすると、出力端子xが自動的に作成されます。

9 Display > AlphaNumericを選択し、AlphaNumericオブジェクトをワークスペース

のDirect I/Oオブジェクトの右に配置します。

10 Direct I/OオブジェクトをAlphaNumericオブジェクトに接続します。マウスの

カーソルをDirect I/Oの出力端子の横に置くと、正方形のアイコンが現れます。

左マウス・ボタンをクリックし、AlphaNumericオブジェクトの入力端子まで線

を引きます。左マウス・ボタンをもう一度クリックして、接続を完了します。

11 ツールバーのRunボタン をクリックして、プログラムを実行します。

12 下の図に示すように、AlphaNumericオブジェクトが、測定器によって出力され

た識別文字列を表示します。

13 VEEコードを保存するため、File > Save Asを選択してファイルにTutorial 1.vee
という名前を付けます。
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仮想信号源チュートリアル

このチュートリアルでは、仮想信号源から波形を作成して表示します。測定器は

不要です。

1 Agilent VEE ProまたはAgilent VEE Expressのワークスペースに既存プログラ

ムが存在する場合、File > Newを選択します。次にDevice > Virtual Source >
Function Generatorを選択して、ファンクション・ジェネレータ・オブジェクト

をワークスペースに配置します。

2 デフォルトで、ファンクション・ジェネレータは、周波数200 Hz、振幅1の仮想

Cosine波形を作成します。 
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3 Display > XY Traceを選択し、XY Traceオブジェクトをファンクション・ジェネ

レータの右に配置します。 

4 ファンクション・ジェネレータの出力端子をXY Traceの入力端子に接続しま

す。マウスのカーソルをファンクション・ジェネレータの出力端子の横に置く

と、正方形のアイコンが現れます。左マウス・ボタンをクリックし、XY Trace
オブジェクトの入力端子まで線を引きます。左マウス・ボタンをもう一度クリッ

クして、接続を完了します。

5 ツールバーのRunボタン をクリックすると、XY Traceオブジェクトにコ

サイン波形が表示されます。
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6 Display > Spectrum (Freq) > Magnitude Spectrumを選択し、Magnitude Spectrum
オブジェクトをワークスペースのXY Traceオブジェクトの下に配置します。

7 ファンクション・ジェネレータの出力からMagnitude Spectrumオブジェクト

の入力に、ステップ 4で説明した左マウス・ボタンのクリックおよびドラッグ

と同じ方法で2番目のラインを接続します。

8 Runボタン をクリックし、振幅スペクトラム表示を観察します。波形は

200 Hzコサインであるため、振幅スペクトラムとして周波数200 Hzに縦線が表

示されます。
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9 仮想ファンクション・ジェネレータの波形機能を方形波に変更します。 
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10 Runボタン をクリックし、違いを観察します。Agilent VEEを使用する

と、信号源を同時に複数のグラフに表示してさまざまな解析が行えます。 

11 VEEコードを保存するため、File > Save Asを選択してファイルにTutorial 2.vee
という名前を付けます。
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Agilent VEE ProとAgilent VEE Expressの違い

以下の表に、Agilent VEE ProとAgilent VEE Expressの相違点を示します。

Agilentでは、バージョン8.5から、大学向けのAgilent VEE Studentも提供して

います。

特長 Agilent VEE Pro Agilent VEE Express

インタフェース GPIB、LAN、

RS- 232、VXI、PXI、
SCXI

USB

（LiveModeのAgilent 
USBデバイスのみ）

MatlabScriptオブジェクトおよびMatlabScript
エンジン

Agilent VEEプログラムのランタイム・バージョ

ンとAgilent VEEオブジェクトのセキュア・バー

ジョンの作成

測定器アドレスのプログラムによる変更

Agilent VEEをActiveXオートメーション・サー

バとして呼び出すなどの呼び出し可能サーバ機

能

リモート・ホスト・コンピュータの別のAgilent
VEEプロセスで実行するUserFunctionをイン

ポートするなどのリモート関数機能

その他の機能
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Agilent VEE 8.5の新機能

最新の統合開発環境（IDE）-- バージョン8.5の統合開

発環境で、最新の、能率の良いプログラミングを体

験できます。この機能により、さらにニーズに適合

した開発環境のカスタマイズなど、機能性と柔軟性

が一段と高まります。バージョン8.5では、Instrument

Manager、Function & Object Browser、Program Explorer、

Propertiesウィンドウ、Watchウィンドウ、Outputウィ

ンドウ、Call Stack、Profilerなどのすべてのツール・

ウィンドウのドック、フロート、非表示、移動が可

能です。

Microsoft Windows Vistaのサポート -- Agilent VEE 8.5を使用すると、セキュリティが強化され、

操作性が向上した最新Microsoftオペレーティング・システムの機能を活用できます。Windows

Aeroインタフェース、Windows Instant Search、WindowsサイドバーといったMicrosoft Windows

の新しい機能が利用可能です。User Account Control（UAC）およびその他のセキュリティ関連

機能を使用すると、PCのヘルスとセキュリティをより簡単に保持できます。 

すべてのAgilent VEE構成ファイルが、ユーザ別／バージョン別の形式で保存されます。

Microsoft Office 2007のサポート -- Agilent VEE 8.5は、アップデートされた内蔵Excelメニューを

含むMicrosoft Office 2007をサポートします。

MATLAB 2007aのサポート -- Agilent VEE Pro 8.5は、MATLABのサポートをMATLAB 2007aまでアッ

プグレードします。

色分け -- この機能によりオブジェクトがタイプごとに自動的に色分けされるので、Agilent

VEEのプログラムが一層読みやすくなります。必要に応じてオブジェクトに色を付けたり、カ

ラー・テーマをエクスポート／インポートして他のユーザと共有したりすることもできます。

不確かなデータ・フロー・コンパイラの警告 -- Agilent VEE 8.5は、Agilent VEEプログラムにコ

ンパイラ問題が見つかると警告を表示します。Agilent VEEオンライン・ヘルプで、こうした

コンパイラ問題の回避策のヒントを表示することもできます。

グラフィック表示オブジェクトの機能拡張 -- Agilent VEE 8.5では、XYトレース、ストリップ・

チャートなどのすべてのグラフィック表示オブジェクトを最大255トレース表示できます。
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Instrument Manager -- バージョン8.5 のInstrument

Managerは、一新されたUIを備えた、ドック、自動

非表示、フロートが可能なツール・ウィンドウと

いうだけではありません。コンテキスト・メニュー

とツールバーを含め、測定器の検出、追加、削除、

構成やIOオブジェクトのすばやい作成のためのさ

らに便利な機能が装備されています。

Agilent IO Monitorを使用した即時通信のモニタ -- Agilent VEE8.5では、旧いBus I/O Monitorオブ

ジェクトが、よりパワフルで使いやすいAgilent IO Monitorと置き換わっています。

Function & Object Browser (FOB) -- この新たにデザインされたFunction & Object Browserを使用す

ると、プログラムで使用できる機能とオブジェクトを簡単に参照し、選択できます。 

Outputウィンドウ -- この機能を使用すると、ランタイムとデザイン時間中の警告メッセージ

とエラー・メッセージを記録して、プログラムのデバッグに利用できます。

VISAインタフェースとアドレスの動的変更 -- バージョン8.5を使用すると、VISAインタフェー

スとアドレスをプログラムによって変更することにより、同じ測定器との通信を別のインタ

フェースとアドレス経由で、余分の構成またはコーディングなしに行えます。 

Callable ServerからのMainの呼び出し -- C#、Visual Basic、C++、Excel Macroなどの別の言語で

作成されたプログラム内のMain UserObjectを、Callable Serverインタフェース経由で呼び出すこ

とができるようになりました。

Microsoft標準ファイル・オープン・ダイアログ -- Agilent VEE 8.5では、To/From File、To/From

Dataset、またはImport Libraryオブジェクトを使用するときに表示される旧いファイル・オープ

ン・ダイアログ・ボックスが、標準のWindowsファイル・オープン・ダイアログ・ボックス

に置き換わっています。

新しい実行モードと新しいデータ・タイプ -- Agilent VEEのバージョン 8.5から、新しいデータ・

タイプUInt16と新しい実行モードVEE 85をサポートします。

ViReal32に対するVISAの変更 -- Agilent VEE 8.5は、最新のVISA仕様に従ってViReal32, ViReal32 []、

pViReal32をサポートします。
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Agilentコネクティビティ製品

Agilentでは、PCと測定器を接続するための高性能で信頼性の高い製品を多数揃えて

います。ネットワークUSBハブ、LAN/GPIBゲートウェイ、PCI GPIBインタフェー

ス、USB/GPIBインタフェース、USB/RS232インタフェースなどの製品がありま

す。Agilentコネクティビティ製品の詳細については、www.agilent.com/find/ioを
ご覧ください。

Agilentのサポート、サービス、アシスタンス

Agilent VEE Pro/Agilent VEE Expressの使用中、Agilentの世界規模のリソース

にアクセスして、スタートアップ・アシスタンス、トレーニング・クラス、アッ

プデート・サービスを利用することができます。Agilent VEE製品の購入の一部と

して、テクニカル・サポートが無料でご利用いただけます。登録の必要はありま

せん。 

Agilentではその他のコンサルティング・サービスも行っています。現在、北米、

ヨーロッパ、中東、アジアの30を超える国でAgilent VEEソリューションの開発に

対するサポートを提供しています。

Agilent VEE電子ユーザ・グループ（http://www.agilent.com/find/vrf）に登録す

ると、世界各国のエキスパートからAgilent VEEの使用に関するサポートが得られ

ます。
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付録

Agilent VEE Pro Help は、他の言語でも提供されています。インストール・ディ

レクトリにあるvee.chmの名前をveeEnglish.chmに変更し、使用したいローカライ

ズ・バージョンの名前をvee.chmに変更してください。例えば、veeJapanese.chm
をvee.chmに変更します。
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简介

欢迎使用 Agilent VEE! 安捷伦可视化工程环境 (VEE) 是一个功能强大的开
发环境，它可以有效且显著的缩短你的开发时间。本手册将通过介绍如何安
装和使用 Agilent VEE 使你能更快地开始使用 Agilent VEE，并且通过两个
范例向你介绍如何通过 USB 接口与仪器进行通信以及如何使用虚拟信号源
产生和显示一个波形。

安装 Agilent IO Libraries Suite
在你购买 Agilent VEE 时， 将同时免费获得 Agilent IO Libraries Suite。 
该软件可以查找、识别和配置通过串行接口、 USB 接口、 GPIB 接口或
LAN 连接到你计算机上的所有仪器。

如果需要通过 Agilent VEE 与仪器通信 ,你必须安装 Agilent IO Libraries 
Suite 15.0. 如果不与仪器通信 , 则可以选择不安装 Agilent IO Libraries 
15.0. 请按下列步骤安装 Agilent IO Libraries Suite。

1 将 Agilent IO Libraries Suite 光盘插入光盘驱动器。 当 Agilent IO 
Libraries Suite 15.0 窗口出现后，单击 Install Software 按钮开始安
装。
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2 InstallShield® Wizard 将指导你完成整个安装过程。单击 Next 按钮，并
使用全部缺省设置直到安装完成。

3 安装完成后，你将看到如下所示欢迎窗口。浏览过该窗口后，你可以将
它关闭。 
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安装 Agilent VEE Pro 或 Agilent VEE Express
1 将 Agilent VEE installation CD 插入光盘驱动器。安装文件将自动打

开。单击 Agilent VEE Pro 或 Agilent VEE Express 图标。
InstallShield® Wizard 将指导你完成整个安装过程。 

有关上述产品间的区别，请参阅第 16 页。

2 首先， InstallShield® Wizard 会检查你是否已安装了 Agilent IO 
Libraries Suite 15.0。如果没有安装，你将看到下面的对话框。

单击 OK， InstallShield® Wizard 会继续指导你完成你在第一步中所选择的
Agilent VEE 产品的安装。

请注意，只有安装了 Agilent IO Libraries Suite 15.0, 才能通过 Agilent 
VEE 与仪器通信。所以,如果您尚未安装Agilent IO Libraries Suite 15.0, 
而又需与仪器通信，请在安装完 Agilent VEE 之后，安装 Agilent IO 
Libraries Suite 15.0 或更高版本。
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3 当 License Agreement 对话框出现后，选择接受版权协议，并单击 Next
按钮。

4 当 Customer Information 对话框出现后，请输入你的姓名、公司名称以
及产品序列号（可以在 Agilent VEE Pro 或 Agilent VEE Express 的产
品序列号证书中找到产品序列号）。接受缺省设置并单击 Next 按钮。当
提示出现时，选择 Typical Setup。继续单击 Next 按钮直到安装完成。
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运行 Agilent VEE Pro 或 Agilent VEE Express
从 All Programs > Agilent VEE Pro 8.5> VEE Pro 8.5 或 All 
Programs > Agilent VEE Express 8.5> VEE Express 8.5 可以打开
Agilent VEE Pro 或 Agilent VEE Express。下图为打开 Agielnt VEE Pro 
时的主界面。

在欢迎画面中，你可以选择查看 VEE 的介绍、 VEE 新功能的介绍、范例程
序、辅导教程或 MATLAB 演示程序。浏览过该窗口后，你可以将它关闭。

你可以从菜单栏 Help > Contents and Index 查看帮助文件，也可以从菜
单栏 File > Open Example 打开范例程序。

欢迎
画面

程序
浏览区

属性窗口

工具栏

状态栏

菜单栏

工作区

输出窗口
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仪器通信范例
在本范例中 , 我们将介绍如何通过 USB 接口与仪器进行通信。开始前，请确
认 Agilent IO Libraries Suite 15.0 已经安装。 

如果你没有 USB 仪器，那么从第三步开始本范例也适用于 GPIB 仪器。 

下面的截图都来自 Agilent VEE Pro。 Agilent VEE Express 的截图与此
类似。

1 将仪器通过 USB 接口连接到你的计算机上。 然后打开电源。当 Found 
New Hardware Wizard 对话框出现后，单击 Next 按钮继续安装。

2 当 Assign USB device alias 对话框出现后，单击 OK 按钮将该 USB 接口
注册到你的系统中。
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3 如果你还没有打开 Agilent VEE Pro 或 Agilent VEE Express，请将它打
开。然后，单击工具栏上的 Instrument Manager 按钮 。 

4 当Instrument Manager窗口出现后，单击Find Instrument 工具栏按钮 
。

Instrument Manager 将自动检测连接在你计算机上的所有仪器。当
Identify Instrument 弹出框出现后，单击 Yes 按钮。 Instrument 
Manager 将自动识别连接在 USB 接口上的仪器。本例中，我们检测到一台
Agilent 34410A 数字万用表。

5 在 Instrument List 框中右击 newInstrument。然后，在打开的上下文菜
单中选择 Create Direct I/O Object，这将为这个已经选择好的仪器
（newInstrument）产生一个 Direct I/O 对象。将该对象放置在工作区
中。 使用该对象你可以向仪器发送命令并接收来自仪器的数据。
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6 双击该 Direct I/O 对象的蓝色事务条 <Double- Click to Add 
Transaction> 打开 I/O 事务对话框以增加一个事务到该对象。

7 在 I/O事务对话框中按下图所示输入 "*IDN?" (包括引号 ) 。然后单击OK 
按钮继续。 *IDN? 是一个用于可编程仪器的标准命令 (SCPI)。 用它可查
询仪器的识别码。

8 发出 "*IDN?" 查询后，你还需把查询结果读回来。双击 newInstrument 
的 Direct I/O 对象的事务条 <Double- Click to Add Transaction> 再增
加一个新事务。 这次，如下所示，选择 READ 一个 STRING FORMAT 
到输出端 x。 单击 OK 按钮后，输出端 x 将自动产生。
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9 从菜单栏选择 Display > AlphaNumeric，并将 AlphaNumeric 对象放在
工作区中 Direct I/O 对象的右边。

10 下面我们将把 Direct I/O 对象和 AlphaNumeric 对象连接起来。将鼠标
光标放在 Direct I/O 对象数据输出端的附近。当出现一个小方块时，单
击鼠标左键。移动鼠标会出现一条线，将这条线拖到 AlphaNumeric 对
象的数据输入端。再次单击鼠标左键完成该连接。

11 单击工具栏的 Run 按钮 运行该程序。

12 如下所示， AlphaNumeric 对象将显示由仪器输出的识别串。

13 如要保存你的VEE 代码，请选择File > Save As 并将其命名为Tutorial 
1.vee。
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虚拟信号源范例

在本范例中，你将学习使用虚拟信号源来产生并显示一个波形。本范例不需
要使用仪器。

1 打开Agilent VEE Pro或Agilent VEE Express后，选择File > New开始
一个新的 VEE 程序。然后，选择 Device > Virtual Source > Function 
Generator 生成一个波形发生器对象。将该对象放置在工作区中。

2 缺省状态下，该波形发生器将产生一个虚拟的余弦波，它的频率是 200 
Hz, 幅度是 1。 
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3 选择 Display > XY Trace 生成一个 XY Trace 对象，将该对象放置在波
形发生器的右边。 

4 将波形发生器对象的数据输出端连接到 XY trace 对象的数据输入端。将
鼠标光标放在 Direct I/O 对象数据输出端的附近。当出现一个小方块
时，单击鼠标左键。移动鼠标会出现一条线，将这条线拖到 XY trace 对
象的数据输入端。 再次单击鼠标左键完成该连接。

5 单击工具栏上的Run按钮 ， 你将会看到在XY Trace 对象中显示的
余弦波。 
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6 选择 Display > Spectrum (Freq) > Magnitude Spectrum 生成一个
Magnitude Spectrum 对象，将该对象放置在工作区中 XY Trace 对象的
下面。

7 从 Function Generator 对象的数据输出端拉出第二条线连到 Magnitude 
Spectrum 对象的数据输入端。请参阅第 4 步中所描述的单击和拖拽的方
法。

8 单击 Run  按钮并观察 Magnitude Spectrum 中的显示情况。 因为
这是一个200 Hz 的余弦波形，Magnitude Spectrum 将在频率为 200 Hz 
处显示一条垂线。
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9 如下图所示，将虚拟波形发生器变为方波。
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10 单击 Run 按钮  并观察 Magnitude Spectrum 中显示的变化。
Agilent VEE 可以同时显示多个图形以便于进行信号源分析。

11 如要保存你的VEE 代码。请选择File > Save As 并将其命名为Tutorial 
2.vee。
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Agilent VEE Pro 和 & Agilent VEE Express 的区别

下表列出了 Agilent VEE Pro 和 Agilent VEE Express 的区别。

从 Agilent VEE 8.5 开始， 安捷伦将专门为学术界用户提供 Agilent VEE 
Student。

功能 Agilent  
VEE Pro

Agilent 
VEE Express

接口 GPIB、 LAN、
RS- 232、 VXI、

PXI、 SCXI

USB
( 只支持已通过 USB
接口连接且已加电的

安捷伦设备 )

MatlabScript 对象和 MatlabScript 引擎

创建 Agilent VEE 程序的运行版本和
Agilent VEE 对象的安全版本

运行时动态修改仪器地址

可调用服务器功能，即将按捷伦 VEE 作为
一个 ActiveX Automation 服务器来调用

远程函数调用功能 ,即调用一个运行在远程
主机上的 Agilent VEE 进程中的
UserFunction

其他功能
16 Agilent VEE Pro 8.5 和 Agilent VEE Express 8.5 快速入门手册



Agilent  VEE 8.5 的新功能

全新的集成开发环境 -- 该开发环境将带给用户
一种全新的编程体验。它在提供新的功能的同
时，也为用户提供了极大的灵活性。用户可以
订制开发环境以更好地满足开发的需求，比如
用户可以停靠， 自动隐藏， 漂浮和移动所有的
工具窗口。 在 Agilent VEE 8.5 中， Instrument 
Manager， Function & Object 浏览器， Program
浏览器， Properties 窗口， Watch Window，
Output 窗口 ,Call Stack, 和 Profiler 等都是工具窗口。

对 Microsoft Windows Vista 的支持 -- 对 Microsoft Windows Vista 的支持，使你能尽
情体验最新的 Microsoft Windows 操作系统所带来的高安全性和高易用性。 
Windows Aero 接口， Windows 即时搜索， 和 Windows SideBar 会带给你全新的
Windows 体验。 用户帐号控制（UAC）和其它新安全特性将会更好地帮助你维护
计算机的安全。

Agilent VEE8.5 会为每个用户单独保存一份配置文件；如果一个用户同时使用多个
Agilent VEE 的版本，则 Agilent VEE 8.5 也会为每个所用的版本保存一份配置文件。

对 Microsoft Office 2007 的支持 -- Agilent VEE 8.5 不仅支持 Microsoft Office 2007，而
且还更新了内置的 Excel 菜单。

对 MATLAB 2007a 的支持 -- Agilent VEE Pro 8.5 将对 MATLAB 的支持升级到了
MATLAB 2007a。

Color Coding -- 这一新功能将会使 Agilent VEE 的程序更加易读。不同的对象将拥有
不同的颜色，所以通过颜色很容易就能区分开不同的对象。另外，用户还可以自
己设置对象的颜色，并将自己的设置保存起来与其它用户共享。

无法确定的数据流编译警告 --Agilent VEE 8.5 会对程序中存在的一些潜在的编译问
题给出警告。另外， Agilent VEE 的在线帮助中也会对这类编译问题给出一些帮助
信息。

增强的图形显示对象 -- 在 Agilent VEE 8.5 中，所有图形显示对象，比如 XY trace, 
Strip Chart, 等等，都可以显示多达 255 条线。
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Instrument Manager - -  Agilent VEE 8.5 中的
Instrument Manager 是一个拥有全新界面的工
具窗口，它可以被停靠，自动隐藏以及漂浮。
而且它新提供的上下文菜单更使查找，添加，
移动，和配置仪器及创建 IO 对象变得方便和
快捷。

用 Agilent IO Monitor 来监测即时通信 -- Agilent 
VEE8.5 使用 Agilent IO Monitor 代替原来的 Bus I/O Monitor 对象进行即时通信的监
测。

Function & Object浏览器 (FOB) -- 这个重新设计的 Function & Object浏览器使用户可
以方便地浏览和选择程序中所有可用的函数和对象。

Output Window -- Output Window 记录在运行时和设计时产生的警告和错误信息， 
对用户的调试及跟踪提供及时有效的信息。

动态改变 VISA 接口和地址 - -  在 Agilent VEE 8.5 中，用户可以通过编程动态地改
变仪器的 VISA 接口和地址。 这样，用户就可以很方便地通过多个接口与一台仪
器通信而无需进行额外的配置操作和编程。 

通过 Callable Server 调用 Main -- 用户可以通过 Callable Server 接口从用其它语
言编写的程序中调用 Main 。 这些语言包括 C#, Visual Basic, C++, Excel Macro, 
等。

标准的打开文件对话框 -- Agilent VEE 8.5 将用标准的 Windows 打开文件对话框取
代原来那个在使用 To/From File, To/From Dataset, 或 Import Library 对象时会出现的
旧的对话框。

新执行模式和数据类型-- 从8.5版开始， Agilent VEE 将支持一种新的数据类型 - 
UInt16 和一个新的执行模式 - VEE 8.5。

对 ViReal32 的支持 -- 为了与最新的 VISA 规范一致， Agilent VEE 8.5 提供了对 
ViReal32, ViReal32 [] 和 pViReal32 的支持。
18 Agilent VEE Pro 8.5 和 Agilent VEE Express 8.5 快速入门手册



安捷伦连接转换类产品

安捷伦提供了一整套高性能、高可靠性的产品用于连接你的计算机和仪器。
这些产品包括网络 USB 集线器、 LAN/GPIB 网关、 PCI GPIB、
USB/GPIB和USB/RS232转换接口。了解更多有关安捷伦连接转换类产品的
信息，请访问 www.agilent.com/find/io。

安捷伦的技术支持和服务
购买了 Agilent VEE Pro 或 Agilent VEE Express，您就拥有了包括启动
协助，培训课程和升级服务在内的安捷伦全球范围内的服务资源。 作为购
买安捷伦产品的一部分 ,您也将无需注册就获得免费的技术支持。

此外，您还将获得安捷伦提供的咨询服务。目前，分布在北美、欧洲、中东
及亚洲的 30 多家公司将协助您完成 Agilent VEE 解决方案的开发。

立即访问 http://www.agilent.com/find/vrf 并注册成为 Agilent VEE 电子
用户组成员，您就可以随时与世界各地的 Agilent VEE 专家探讨有关
Agilent VEE 的各种问题。
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附录

除了英文帮助文件外， Agilent VEE Pro 8.0 还提供其他语言的帮助文件。 您只
需将 Agilent VEE 安装路径下的 vee.chm 重命名为 veeEnglish.chm，再将您所
选的帮助文件命名为 vee.chm 就可以了。例如，将 veeChinese.chm 命名为
vee.chm。
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簡介

歡迎使用 Agilent VEE! 安捷倫可視化工程環境 (VEE) 是一個功能強大的開
發環境，它可以有效且顯著的縮短你的開發時間。本手冊將通過介紹如何安
裝和使用 Agilent VEE 使你能更快地開始使用 Agilent VEE，並且通過兩個
範例向你介紹如何通過 USB 接口與儀器進行通信以及如何使用虛擬信號源
产生和顯示一個波形。

安裝 Agilent IO 庫

在你購買 Agilent VEE 時， 將同時免費獲得 Agilent IO 庫軟件。 該軟件可
以查找、識別和配置通過串行接口、USB 接口、GPIB 接口或 LAN 連接到
你計算機上的所有儀器。

如果需要通過 Agilent VEE 與儀器通信 , 你必須安裝 Agilent IO Libraries 
Suite 15.0. 如果不與儀器通信, 則可以選擇不安裝 Agilent IO Libraries 15.0. 
請按下列步驟安裝 Agilent IO Libraries Suite。

1 將 Agilent IO Libraries Suite 光盤插入光盤驅動器。 當 Agilent IO 
Libraries Suite 15.0 窗口出現後，單擊 Click Here to Install Now 按鈕
開始安裝。
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2 InstallShield Wizard 將指導你完成整個安裝過程。單擊 Next 按鈕，並使
用全部缺省設置直到安裝完成。

3 安裝完成後，你將看到如下所示歡迎窗口。浏覽過該窗口後，你可以將
它關閉。 
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安裝 Agilent VEE Pro 或 Agilent VEE Express
1 將 Agilent VEE installation CD 插入光盤驅動器。安裝文件將自動打開。

單擊 Agilent VEE Pro 或 Agilent VEE Express 。 InstallShield Wizard
將指導你完成整個安裝過程。 

有關上述产品間的區別，請參閱第 16 頁。

2 首先 InstallShield Wizard 會檢查你是否已安裝了 Agilent IO Libraries 
Suite 15.0。如果沒有安裝，你將看到下面的對話框。

單擊 Yes， InstallShield. Wizard 會繼續指導你完成你在第一步中所選擇的
Agilent VEE 產品的安裝。

請注意，祇有安裝了 Agilent IO Libraries Suite 15.0, 才能通過 Agilent 
VEE 與儀器通信。
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3 當 License Agreement 對話框出現後，選擇接受版權協議，並單擊 Next 按
鈕。

4 當 Customer Information 對話框出現後，請輸入你的姓名、公司名稱以及
产品序列號 （可以在 Agilent VEE Pro 或 Agilent VEE Express 的产品
序列號證書中找到产品序列號）。接受缺省設置並單擊 Next 按鈕。當提
示出現時，選擇 Typical Setup。繼續單擊 Next 按鈕直到安裝完成。
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運行 Agilent VEE Pro 或 Agilent VEE Express
從 All Programs > Agilent VEE Pro 8.5> VEE Pro 8.5 或 All Programs > 
Agilent VEE Express 8.5> VEE Express 8.5 可以打開 Agilent VEE Pro 或
Agilent VEE Express。下圖為打開 Agielnt VEE Pro 時的主界面。

在歡迎畫面中，你可以選擇查看 VEE 的介紹、VEE 新功能的介紹、範例程
序、輔導教程或 MATLAB 演示程序。浏覽過該窗口後，你可以將它關閉。

你可以從菜單欄 Help > Contents and Index 查看幫助文件，也可以從菜單欄
File > Open Example 打開範例程序。

歡迎
畫面

程序
浏覽區

屬性窗口

工具欄

狀態欄

菜單欄

工作區

輸出窗口
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儀器通信範例

在本範例中 , 我們將介紹如何通過 USB 接口與儀器進行通信。開始前，請
確認 Agilent IO Libraries Suite 15.0 已經安裝。 

如果你沒有 USB 儀器，那從第三步開始本範例也適用于 GPIB 儀器。 

下面的截圖都來自 Agilent VEE Pro。Agilent VEE Express 的截圖與此類
似。

1 將儀器通過 USB 接口連接到你的計算機上。 然後，打開電源。當 Found 
New Hardware Wizard 對話框出現後，單擊 Next 按鈕繼續安裝。

2 當 Assign USB device alias 對話框出現後，單擊 OK 按鈕將該 USB 接口注
冊到你的系統中。
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3 如果你還沒有打開 Agilent VEE Pro 或 Agilent VEE Express，請將它打
開。然後，單擊工具欄上的 Instrument Manager 按鈕      。

4 當Instrument Manager視窗出現后，按一下Find Instrument 工具列按鈕   
  .  。

5 Instrument Manager 將自動偵測連線在你計算機上的所有儀器。當
Identify Instrument 跳出框出現后，按一下 Yes 按鈕。Instrument 
Manager 將自動識別連線在 USB 接口上的儀器。本例中，我們偵測到一
台 Agilent 34410A 數字萬用表。

6 在 Instrument List 框中選擇 newInstrument。然後，在 Create I/O Object
框中單擊 Direct I/O 按鈕，這將為這個已經選擇好的儀器
（newInstrument）产生一個 Direct I/O 對象。將該對象放置在工作區中。 
使用該對象你可以向儀器發送命令並接收來自儀器的數據。
8 Agilent VEE Pro 8.5 和 Agilent VEE Express 8.5 快速入門手冊



7 雙擊該 Direct I/O 對象的藍色事務條 <Double-Click to Add Transaction>
打開 I/O 事務對話框以增加一個事務到該對象。

8 在I/O事務對話框中按下圖所示輸入 "*IDN?" (包括引號) 。然後單擊OK 按
鈕繼續。*IDN? 是一個用于可編程儀器的標准命令 (SCPI)。 用它可查詢
儀器的識別碼。

9 發出 "*IDN?" 查詢後，你還需把查詢結果讀回來。雙擊 newInstrument 的
Direct I/O 對象的事務條 <Double-Click to Add Transaction> 再增加一個
新事務。 這次，如下所示，選擇 READ 一個 STRING FORMAT 到輸出
端 x。 單擊 OK 按鈕後，輸出端 x 將自動产生。
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10 從菜單欄選擇 Display > AlphaNumeric，並將 AlphaNumeric 對象放在工
作區中 Direct I/O 對象的右邊。

11 下面我們將把 Direct I/O 對象和 AlphaNumeric 對象連接起來。將鼠標光
標放在 Direct I/O 對象數據輸出端的附近。當出現一個小方塊時，單擊鼠
標左鍵。移動鼠標會出現一條線，將這條線拖到 AlphaNumeric 對象的數
據輸入端。再次單擊鼠標左鍵完成該連接。

12 單擊工具欄的 Run 按鈕      運行該程序。

13 如下所示，AlphaNumeric 對象將顯示由儀器輸出的識別串。

14 如要保存你的 VEE 代碼，請選擇 File > Save As 並將其命名為 Tutorial 
1.vee。
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虛擬信號源範例

在本範例中，你將學習使用虛擬信號源來产生並顯示一個波形。本範例不需
要使用儀器。

1 打開Agilent VEE Pro或Agilent VEE Express後，選擇File > New開始一
個新的 VEE 程序。然後，選擇 Device > Virtual Source > Function 
Generator 生成一個波形發生器對象。將該對象放置在工作區中。

2 缺省狀態下，該波形發生器將产生一個虛擬的余弦波，它的頻率是 200 
Hz, 幅度是 1。 
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3 選擇 Display > XY Trace 生成一個 XY Trace 對象，將該對象放置在波形
發生器的右邊。 

4 將波形發生器對象的數據輸出端連接到 XY trace 對象的數據輸入端。將鼠
標光標放在 Direct I/O 對象數據輸出端的附近。當出現一個小方塊時，單
擊鼠標左鍵。移動鼠標會出現一條線，將這條線拖到 XY trace 對象的數
據輸入端。 再次單擊鼠標左鍵完成該連接。

5 單擊工具欄上的 Run 按鈕      ， 你將會看到在 XY Trace 對象中顯示的
余弦波。 
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6 選擇 Display > Spectrum (Freq) > Magnitude Spectrum 生成一個
Magnitude Spectrum 對象，將該對象放置在工作區中 XY Trace 對象的
下面。

7 從 Function Generator 對象的數據輸出端拉出第二條線連到 Magnitude 
Spectrum 對象的數據輸入端。請參閱第 4 步中所描述的單擊和拖拽的方
法。

8 單擊 Run     按鈕並觀察 Magnitude Spectrum 中的顯示情況。 因為這
是一個 200 Hz 的余弦波形，Magnitude Spectrum 將在頻率為 200 Hz 處
顯示一條垂線。
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9 如下圖所示，將虛擬波形發生器變為方波。
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10 單擊 Run 按鈕     並觀察 Magnitude Spectrum 中顯示的變化。Agilent 
VEE 可以同時顯示多個圖形以便于進行信號源分析。

11 如要保存你的 VEE 代碼。請選擇 File > Save As 並將其命名為 Tutorial 
2.vee。
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Agilent  VEE Pro 和 MAgilent  VEE Express 的區別

下表列出了 Agilent VEE Pro 和 Agilent VEE Express 的區別。

從 Agilent VEE 8.5 開始， 安捷倫將專門為學術界使用者提供 Agilent VEE

Student。

功能 Agilent  
VEE Pro

Agilent 
VEE Express

接口 GPIB、 LAN、
RS- 232、 VXI、

PXI、 SCXI

USB
( 只支持通過 USB 接
口連接且已加電的安

捷倫設備 )

MatlabScript 對象和 MatlabScript 引擎

創建 Agilent VEE 程序的運行版本和
Agilent VEE 對象的安全版本

運行時動態修改儀器地址

可調用服務器功能，即將按捷倫 VEE 作為
一個 ActiveX Automation 服務器來調用

遠程函數調用功能 , 即調用一個運行在遠程
主機上的 Agilent VEE 進程中的
UserFunction

其他功能
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Agilent  VEE Pro 8.5 的新功能
全新的整合開發環境 -- 該開發環境將帶給使用者一種
全新的程式化體驗。它在提供新的功能的同時，也為
使用者提供了極大的靈活性。使用者可以訂製開發環
境以更好地滿足開發的需求，比如用戶可以停靠， 自
動隱藏， 漂浮和移動所有的工具視窗。在 Agilent 
VEE 8.5 中， Instrument Manager， Function & 
Object 瀏覽器， Program 瀏覽器， Properties 視窗， 
Watch Window， Output 視窗 ,Call Stack, 和 Profiler 等都是工具視窗。

對 Microsoft Windows Vista 的支持 -- 對 Microsoft Windows Vista 的支持，使
你能盡情體驗最新的 Microsoft Windows 作業系統所帶來的高安全性和高易用
性。 Windows Aero 接口， Windows 即時搜尋， 和 Windows SideBar 會帶給你全
新的 Windows 體驗。 使用者帳號控制 （UAC）和其它新安全特性將會更好地為
你維護計算機的安全。

Agilent VEE8.5 會為每個使用者單獨儲存一份組態檔案；如果一個使用者同時
使用多個 Agilent VEE 的版本，則 Agilent VEE 8.5 也會為每個所用的版本儲存
一份組態檔案。

對 Microsoft Office 2007 的支持 -- Agilent VEE 8.5 不只有支持 Microsoft 
Office 2007，而且還更新了內置的 Excel 選單。

對 MATLAB 2007a 的支持 -- Agilent VEE Pro 8.5 將對 MATLAB 的支持升級
到了 MATLAB 2007a。

Color Coding -- 這一新功能將會使 Agilent VEE 的程式更加易讀。不同的對象將
擁有不同的色彩，所以通過色彩很容易就能區分開不同的對象。另外，使用者還
可以自己設定對象的色彩，並將自己的設定儲存起來與其它使用者共享。

無法確定數據流的編譯警告 --Agilent VEE 8.5 會對程式中存在的一些潛在的編
譯問題給出警告。另外， Agilent VEE 的線上說明中也會對這類編譯問題給出一
些說明訊息。

.
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Instrument Manager - - Agilent VEE 8.5 中的
Instrument Manager 是一個擁有全新界面的工
具視窗，它可以被停靠，自動隱藏以及漂浮。
而且它新提供的上下文選單更使尋找，加入，
移動，和組態儀器及建立 IO 對象變得方便和
快捷。

用 Agilent IO Monitor 來監測即時通信 -- Agilent VEE8.5 使用 Agilent IO 
Monitor 代替原來的 Bus I/O Monitor 對象進行即時通信的監測。

增強的圖形顯示對象 -- 在 Agilent VEE 8.5 中，所有圖形顯示對象，比如 XY 
trace,Strip Chart, 等等，都可以顯示多達 255 條線。

Function & Object 瀏覽器 (FOB) -- 這個重新設計的 Function & Object 瀏覽器
使使用者可以方便地瀏覽和選擇程式中所有可用的函式和對象。

Output Window -- Output Window 記錄在執行時和設計時產生的警告和錯誤訊
息，對使用者的除錯及追蹤提供及時有效的訊息。

動態改變 VISA 接口和位址 - - 在 Agilent VEE 8.5 中，使用者可以通過程式化動
態地改變儀器的 VISA 接口和位址。 這樣，使用者就可以很方便地通過多個接口
與一台儀器通信而無需進行額外的組態作業和程式化。

通過 Callable Server 呼叫 Main -- 使用者可以通過 Callable Server 接口從用其
它語言編寫的程式中呼叫 Main 。 這些語言有 C#, Visual Basic, C++, Excel 
Macro, 等。

標準的開啟檔案對話視窗 -- Agilent VEE 8.5 將用標準的 Windows 開啟檔案對話
視窗取代原來那個在使用 To/From File, To/From Dataset, 或 Import Library 對
象時會出現的舊的對話視窗。

新執行模式和數據類型 -- 從 8.5 版開始， Agilent VEE 將支援一種新的數據類型 
-UInt16 和一個新的執行模式 - VEE 85。

對 ViReal32 的支援 -- 為了與最新的 VISA 規範一致， Agilent VEE 8.5 提供了對

ViReal32, ViReal32 [] 和 pViReal32 的支援。
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安捷倫連接轉換類产品

安捷倫提供了一整套高性能、高可靠性的产品用于連接你的計算機和儀器。
這些产品包括網絡 USB 集線器、LAN/GPIB 網關、PCI GPIB、USB/GPIB
和 USB/RS232 轉換接口。了解更多有關安捷倫連接轉換類产品的信息，請
訪問 www.agilent.com/find/io。

安捷倫的技術支持和服務

購買了 Agilent VEE Pro 或 Agilent VEE Express，您就擁有了包括启動協
助，培訓課程和升級服務在內的安捷倫全球範圍內的服務資源。 作為購買安
捷倫产品的一部分 , 您也將無需注冊就獲得免費的技術支持。

此外，您還將獲得安捷倫提供的咨詢服務。目前，分布在北美、歐洲、中東
及亞洲的 30 多家公司將協助您完成 Agilent VEE 解決方案的開發。

立即訪問 http://www.agilent.com/find/vrf 並注冊成為 Agilent VEE 電子用
戶組成員，您就可以隨時與世界各地的 Agilent VEE 專家探討有關 Agilent 
VEE 的各種問題。
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附錄

除了英文幫助文件外， Agilent VEE Pro 8.0 還提供其他語言的幫助文件。 
您只需將 Agilent VEE 安裝路徑下的 vee.chm 重命名為 veeEnglish.chm，
再將您所選的幫助文件命名為 vee.chm 就可以了。例如，將 veeTCN.chm 
命名為 vee.chm。
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시작하기

VEE Pro 제품군에 오신 것을 환영합니다 ! Agilent VEE (Visual 
Engineering Environment) 는 개발시간을 획기적으로 단축할 수 있는 
강력한 시각적인 프로그래밍 환경을 제공합니다 . 본 안내서에서는 
Agilent VEE 를 빠르고 쉽게 배울 수 있도록 , VEE 를 설치하는 방법과 
간단한 사용법을 설명합니다 . 'USB 인터페이스를 이용한 계측기와의 
통신을 설정하는 방법 ' 과 ' 파형을 생성하고 디스플레이 하는 방법 ' 에 
대한 2 개의 실습을 제공하고 있습니다 .

Agilent IO 라이브러리 설치

Agilent IO Libraries Suite 는 Agilent VEE Pro 또는 Agilent VEE 
Express 를 구매시 함께 제공됩니다 . 이 Agilent IO 라이브러리는 계측
기와 Serial, USB, GPIB 및 LAN 을 통해서 통신할 수 있는 인터페이스를 
제공합니다 . 

Agilent VEE 를 이용하여 계측기와 통신하기 위해서는 Agilent VEE 를 설
치하기 전에 Agilent IO Libraries Suite 15.0 을 먼저 설치해야 합니다 . 
그러나 계측기를 사용하지 않는 경우에는 Agilent IO Libraries Suite 를 
설치하지 않도록 설정할 수 있습니다 . 

아래의 절차에 따라서 Agilent IO Libraries Suite 를 간단히 설치할 수 있
습니다 :

1 Agilent IO Library Suites CD 를 PC 의 CD-ROM 드라이브에 삽입하
면 자동으로 설치가 시작되며 , Agilent IO Libraries Suite 15.0 의 설
치시작 화면에서 Click Here to Install Now 버튼을 클릭하십시오 .
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2 설치 마법사에 따라서 설치가 진행됩니다 . 디폴트 상태에서 Next 버
튼을 클릭하여 설치를 진행하십시오 .

3 Agilent Connection Expert 환영 화면이 나타납니다 . Agilent 
Connection Expert 는 PC 와 연결된 계측기를 설정합니다 . 다음 단
계를 진행하기 전에 Close Welcome Screen 버튼을 클릭하여 아래 
그림의 화면을 닫을 수도 있습니다 .
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Agilent VEE Pro 또는 Agilent VEE Express 설치
1 VEE Pro installation CD 를 삽입하고 Agilent VEE Pro 또는 Agilent 

VEE Express 를 선택하십시오 . 설치마법사가 설치를 안내합니다 .

이들 제품에 대한 차이점은 16 페이지를 참조하십시오 .

2 InstallShield 마법사가 Agilent IO Libraries Suite 15.0 이 설치되어 있
는지 체크합니다 . 설치되어 있지 않으면 , 다음과 같은 메시지 박스가 
나타납니다 . 

여기서 " 확인 " 버튼을 클릭하면 위 단계 1 에서 선택한 Agilent VEE 를 
설치마법사가 자동으로 설치합니다 .

Agilent VEE에서 계측기와 통신해야 하기 위해서는 Agilent IO Libraries 
Suite 15.0이 설치되어 있어야 합니다. 따라서 이 과정을 마친 다음에는 
Agilent IO Libraries Suite 15.0 이상의 버젼을 설치하시기 바랍니다 .
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3 라이센스 계약 안내에 동의하고 , Next 를 클릭하십시오 .

4 Customer Information 대화상자에서는 Name, Company Name 과 
Product Key 를 입력하십시오 . Product Key 는 Agilent VEE Pro 또
는 Agilent VEE Express Product Key Certificate 에 있습니다 . 평가
용 또는 데모용으로 VEE 를 설치하는 경우에는 Product Key 필드에 
Eval 을 입력하십시오 . 현 상태에서 Next 를 클릭하십시오 . 다음 화
면에서 Typical setup 을 선택하여 설치를 완료하십시오 .
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Agilent VEE Pro 또는 Agilent VEE Express 실행
시작 > 모든 프로그램 > Agilent VEE Pro 8.5> VEE Pro 8.5 또는 Agilent 
VEE Express 8.5> VEE Express 8.5 를 차례로 클릭하여 Agilent VEE 
Pro 또는 Agilent VEE Express 를 실행하십시오 .

Agilent VEE Pro 및 Agilent VEE Express Welcome 화면에서는 VEE 예
제 프로그램 및 MATLAB 데모 (Agilent VEE Pro 에서만 제공 ) 등의 링크
가 제공됩니다 . Welcome 화면에서 제공하는 여러 기능을 검토하고 화
면을 닫으십시오 .

또한 메뉴바에서도 예제 프로그램을 열 수 있습니다 . 예제 프로그램을 
열기 위해서는 File > Open Example 이나 Help > Open Example 을 실
행하십시오 .

Output 
Window

Workspace

Program 
Explorer

Properties
Window

ToolBar

Status Bar

Menu Bar

Welcome 
Window
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계측기 통신 안내서

본 안내서에서는 , USB 인터페이스를 이용하여 계측기를 연결할 것입니
다 . 먼저 Agilent IO Libraries Suite 15.0 이 반드시 설치되어 있어야 합
니다 . 

아래 3 단계 이후부터는 USB 계측기와 GPIB 계측기에서 사용하는 방법
이 거의 동일하므로 , 아래의 내용을 GPIB 계측기에도 적용할 수 있습니
다 . 

다음 그림은 Agilent VEE Pro 에서 캡쳐한 화면으로 , Agilent VEE 
Express 의 화면도 이와 유사합니다 .

1 계측기를 PC 의 USB 포트에 연결하고 계측기의 전원을 켜면 , 새 하드
웨어 검색 마법사 화면이 나타납니다 . Windows Update 를 통한 소프
트웨어 설치화면에서 " 아니오 , 지금 연결 안함 " 을 선택하고 다음을 
클릭합니다 . “소프트웨어 자동으로 설치 ( 권장 )” 를 선택하고 
“다음”  버튼을 클릭하면 설치가 계속 진행됩니다 .

2 Assign USB device alias 대화상자가 나타나면 OK 버튼을 클릭하여 
시스템에 이 연결을 등록하십시오 . 
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3 프로그램이 실행되어 있지 않다면, Agilent VEE Pro 또는 Agilent VEE 
Express 를 실행하십시오 . 툴바에 있는 Instrument Manager 버튼     

을 클릭하십시오 . 

4 Instrument Manager 화면이 나타납니다. Find Instrument 버튼  
을 클릭하면 PC 에 연결된 계측기를 자동으로 감지하고 설정합니다

Identify Instrument 화면이 나타나면 Yes 를 클릭하십시오 . 이 과정
에서 USB 인터페이스에 연결된 계측기가 자동으로 인식됩니다 . 아래
의 예제에서는 Agilent 34410A 디지털멀티미터가 검색되었습니다 .

5 대화상자의 Instrument List 에서 newInstrument 를 선택하고 이 상태
에서 마우스 오른쪽 버튼을 클릭하여 컨텍스트 메뉴가 열리면 Create 
Direct I/O Object 메뉴를 클릭하여 선택된 newInstrument 에 대한 
Direct I/O 오브젝트를 VEE 작업영역에 생성합니다 . 이 오브젝트를 
통해서 계측기에 명령을 전송하고 계측기의 응답을 수신할 수 있습니
다 .
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6 Direct I/O 오브젝트에 트랜잭션을 추가하기 위하여 Direct I/O 오브
젝트의 청색 트랜잭션바를 더블 클릭합니다 .

7 I/O Transaction 대화상자에서 그림과 같이 “*IDN?” ( 인용부호 
“ ”  포함 ) 이라고 입력하고 OK 버튼을 클릭하십시오 .

*IDN? 은 SCPI (Standard Commands for Programmable 
Instruments) 호환 명령어로써 이 명령어를 받은 계측기는 자신의 정
보를 응답하게 되어있습니다 .

8 계측기로 “*IDN?” 쿼리를 전송한 다음에는 계측기의 응답을 받아
서 읽어야 합니다 . 맨 아래의 트랜잭션바를 더블 클릭하여 , 새 트랜
잭션을 추가합니다 . 이번에는 그림과 같이 트랜잭션을 READ 로 , 포
맷은 STRING FORMAT 으로 변경하여 x 출력터미날로 전송하도록 선
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택합니다 . OK 버튼을 클릭하면 오브젝트에 출력터미날 x 가 자동생성
됩니다 .

9 메뉴바에서  Display > AlphaNumeric 을 선택하여 AlphaNumeric 오
브젝트를 Direct I/O 오브젝트의 오른쪽에 배치합니다 .

10 이번에는 Direct I/O 오브젝트를 AlphaNumeric 오브젝트에 연결해야 
합니다 . 마우스 커서를 Direct I/O 오브젝트의 출력터미날 가까이 가
져가면 정사각형의 박스아이콘으로 바뀝니다 . 그 상태에서 마우스의 
왼쪽 버튼을 클릭하고 라인을 드래그하여 AlphaNumeric 오브젝트의 
입력터미날 근처로 이동합니다 . 다시 한번 마우스의 왼쪽 버튼을 클
릭하면 연결선이 생성되고 연결이 마무리됩니다 .

11 툴바의 Run 버튼 아이을 클릭하여 프로그램을 실행합니다 .

12 AlphaNumeric 오브젝트에 계측기로부터 출력된 계측기 정보가 디스
플레이됩니다 .

13 현재의 프로그램을 File > Save As 를 선택하여 Tutorial 1.vee 로 저
장합니다 .
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Virtual Source 안내서

이 안내서에서는 가상소스를 이용하여 파형을 생성하고 디스플레이 합
니다 . 이 프로그램은 계측기 없이도 실행할 수 있습니다 .

1 Agilent VEE Pro 또는 Agilent VEE Express 에서 , 메뉴바의 File > 
New 를 선택하여 새로운 VEE 프로그램을 시작합니다 . 다시 메뉴바
에서 Device > Virtual Source > Function Generator 를 선택하여 작
업영역에 Function Generator 오브젝트를 생성합니다 .

2 디폴트 상태에서는 이 Function Generator 의 Function 필드는 
Cosine, Frequency 필드는 200Hz, Amplitude 필드는 1V 로 설정되
어 있습니다 . 
Agilent VEE Pro 8.5 & Agilent VEE Express 8.5 퀵 스타트 가이드 11



3 메뉴바에서 Display > XY Trace 를 선택하여 XY Trace 오브젝트를 
Function Generator 의 오른쪽에 배치합니다 . 

4 Function Generator 의 출력터미날을 XY Trace 의 입력터미날에 연결
하십시오 . 마우스 커서를 Function Generator 오브젝트 출력터미날 
가까이 가져가면 정사각형의 박스 아이콘으로 바뀝니다. 이 상태에서 
마우스의 왼쪽 버튼을 클릭하고 라인을 드래그하여 XY Trace 오브젝
트의 입력터미날 근처로 이동합니다 . 다시 한번 마우스의 왼쪽 버튼
을 클릭하면 연결선이 생성되고 연결이 마무리됩니다 .

5 툴바에서 Run 버튼 ( 지 ) 을 클릭하면 XY Trace 오브젝트에 코사인 파
형이 생성됩니다 . 
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6 Display > Spectrum (Freq) > Magnitude Spectrum 을 선택하여 오브
젝트를 생성하고 작업영역에서 XY Trace 아래에 배치하십시오 .

7 4단계에서 설명한 연결선 생성 방법을 사용하여 Function Generator 
의 출력터미날에서 두 번째 라인을 생성하여 Magnitude Spectrum 오
브젝트의 입력터미날에 연결합니다 .

8 Run 버튼 ( 지 ) 을 클릭하여 Magnitude Spectrum 오브젝트의 디스플
레이를 확인하십시오 . 코사인파형의 주파수가 200Hz 이므로 , 
Magnitude Spectrum 오브젝트의 창에 200Hz 에서 피크가 생성됩니
다 .
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9 Function Generator 오브젝트에서 Function 필드를 Square 파형으
로 변경하십시오 . 
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10 Run 버튼 (지)을 클릭하고 차이점을 비교하십시오. Agilent VEE는 여
러 개의 그래프를 동시에 디스플레이 할 수 있습니다 . 

11 지금까지 작성한 프로그램을 메뉴바에서 File > Save As 를 선택하여 
Tutorial 2.vee 로 저장하십시오 .
Agilent VEE Pro 8.5 & Agilent VEE Express 8.5 퀵 스타트 가이드 15



Agilent VEE Pro 와 Agilent VEE Express 의 차이점
Agilent VEE Pro 와 Agilent VEE Express 의 차이점은 아래 표와 같습니
다 .

또한 8.5 버젼부터는 학생사용자용 Agilent VEE Student 도 제공됩니다
.

항목 Agilent VEE Pro Agilent VEE Express

인터페이스 GPIB, LAN, 
RS-232, VXI, PXI, 

SCXI

USB

(LiveMode 로 설정된 
Agilent USB 계측기만 

사용 가능 )

MatlabScript 오브젝트 & MatlabScript 엔진

Agilent VEE 프로그램의 런타임 버전 생성 및 
Agilent VEE 오브젝트의 보안처리

계측기주소를 프로그램 실행시 변경

Callable Server 기능 ( 예 , Agilent VEE 를 
ActiveX Automation server 로 호출하는 것 )

Remote Function 기능 ( 예 , 리모트 호스트 컴
퓨터에서 실행되는 다른 Agilent VEE 프로그램
을 UserFunction 으로 임포팅 하는 것 )

다른 기능
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Agilent VEE Pro 8.5 의 새로운 기능

새로운 통합개발환경(IDE) -- 8.5 버전의 통
합개발환경에서는, 더욱 향상되고 합리적인 
프로그래밍을 할 수 있습니다 . 이 통합개발
환경은 사용자의 요구를 더욱 충족시키기 위
해서 개발환경을 커스터마이징하는 기능을 
포함하여 다양한 기능과 유연성을 제공합니
다 . 8.5 버전에서는 Instrument Manager, 
Function & Object Browser, Program 
Explorer, Properties 윈도우 , Watch 윈도우
, Output 윈도우 , Call Stack, Profiler 등 모
든 툴 윈도우를 고정 , 이동하거나 , 감추어 사용할 수 있습니다 .

마이크로소프트 윈도우 비스타 지원 -- 사용이 편리하고 보안이 강화된 마이크
로 소프트의 최신의 운영시스템의 장점을 Agilent VEE 8.5 에서 활용할 수 있습
니다 . 윈도우 에어로 (Aero) 인터페이스 , 윈도우 인스턴스 검색 및 윈도우 사이
드바 등의 기능을 활용할 수 있습니다 . 사용자 계정제어 (UAC) 와 기타 보안관련 
기능으로 고객의 PC 를 더욱 안전하게 사용할 수 있습니다 . 

모든 Agilent VEE 설정파일은 사용자 단위 및 버전에 따라서 저장되어 관리됩니
다 .

마이크로소프트 오피스 2007 지원 -- Agilent VEE 8.5 는 마이크로소프트 오피
스 2007 을 지원합니다 . VEE 의 내장 Excle 메뉴도 더욱 향상되었습니다 .

MATLAB 2007a 지원 -- VEE 에서 지원하는 MATLAB 버전이 Agilent VEE 8.5
에서는 MATLAB 2007a 로 향상되었습니다 .

컬러 코딩 -- 오브젝트의 타입에 따라서 다른 색깔을 자동으로 사용하여 더욱 
읽기 쉽도록 하는 기능입니다 . 사용자 필요에 따라서 오브젝트에 다른 색깔을 
사용할 수 있으며 , 이러한 색깔 설정을 임포트 / 익스포트하여 다른 오브젝트에
도 적용할 수 있습니다 .

명확하지 않은 DataFlow 컴파일러 경고 -- Agilent VEE 8.5 에서는 사용자가 작
성한 VEE 프로그램에 잠재적인 에러가 발견되면 경고를 발생합니다 . 이러한 컴
파일러 문제를 피하는 방법은 온라인 도움말에서 제공됩니다 . 

그래피컬 디스플레이 오브젝트 기능 향상 -- Agilent VEE 8.5 에서는 XY Trace, 
Strip Chart 를 포함한 모든 그래피컬 디스플레이 오브젝트에서 최대 256 개의 
트레이스를 표시할 수 있습니다 .
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Instrument Manager -- 버전 8.5 의 
Instrument Manager 는 도킹 , 자동 감추
기 , 프로팅 등의  새로운 UI 기능뿐만 아니
라 계측기 찾기 , 추가하기 , 제거하기 , 설
정하기 및 입출력 오브젝트를 생성하는 컨
텍스트 메뉴 및 툴바를 포함하여 , 더욱 편
리한 여러 가지 기능을 제공합니다 .

Agilent IO Monitor 로 순간적인 통신을 모니터링 -- 기존 Bus I/O Monitor 오브
젝트가 Agilent VEE 8.5 에서는 Agilent I/O Monitor 오브젝트로 변경되었습니다
. 이 오브젝트를 기존 Bus I/O Monitor 오브젝트 보다 더욱 강력하고 사용하기 
쉽습니다 . 

Function & Object Browser(FOB) -- 더욱 쉽게 브라우징하고 함수 및 오브젝트
를 선택할 수 있도록 Function & Object Browser 가 새로운 모습으로 개선되었
습니다 .

Output 윈도우 -- 이 기능은 프로그램 런타임시 또는 개발시 발생하는 경고와 
에러 메시지를 로깅하여 프로그램을 쉽게 디버깅할 수 있는 기능입니다 .

VISA 인터페이스 및 주소를 동적으로 변경 --버전 8.5에서는, 프로그램 상에서 
VISA 인터페이스 및 주소를 동적으로 변경할 수 있어서 , 설정이나 프로그램을 
변경하지 않고 , 동일한 계측기와의 통신에 다른 인터페이스 또는 주소를 이용할 
수 있습니다 .

콜러블 서버를 통해서 Main 사용자 오브젝트 호출 -- Callable Server 인터페이
스를 통해서 C#, Visual Basic, C++, Excel Macro 및 기타 언어로 작성된 프로
그램에서 VEE 의 Main UserObject 를 호출할 수 있습니다 .

마이크로소프트 표준 파일열기 대화상자 -- To/From File, To/From Dataset 
또는 Import Library 오브젝트에서 사용하던 기존의 파일열기 대화상자 , VEE 
8.5 버전에서는 마이크로소프트의 표준 파일열기 대화상자로 변경되었습니다 .

새로운 실행모드 및 새로운 데이터 타입 -- VEE 8.5 버전에서는 UInt16 데이터 
타입과 VEE 85 실행모드가 추가되었습니다 .

ViReal32 용 VISA 변경 -- Agilent VEE 8.5 에서는 최신 VISA 규격을 반영하여 
ViReal32, ViReal32[] 및 pViReal32 를 지원합니다 .
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Agilent Connectivity 제품

Agilent 는 PC 와 계측기를 연결하는 신뢰도가 높은 고성능 제품을 제공
합니다 . 이 제품군에는 USB 허브 , LAN/GPIB 게이트웨이 , PCI GPIB, 
USB/GPIB 및 USB/RS232 인터페이스 등이 있습니다 . 웹페이지 
www.agilent.com/find/io 에서 이와 관련된 더 많은 정보를 제공합니다 .

Agilent 지원과 서비스

Agilent VEE Pro & Agilent VEE Express 와 함께 , Agilent 는 프로그램
을 시작 지원 , 교육 및 업데이트에 대해 전세계 고객에게 동일한 서비스
를 제공합니다 . Agilent VEE 제품을 구매한 고객은 등록 절차 없이 무료
로 기술지원을 받을 수 있습니다 . 

Agilent 에서는 컨설팅 서비스도 제공합니다 . Agilent VEE 프로그램을 
개발하는데 있어 북미 , 유럽 , 중동 및 아시아의 30 여 회사에서 도움을 
제공할 수 있습니다 .

웹페이지 http://www.agilent.com/find/vrf 는 애질런트가 운영하는 
VEE 사용자 모임 (VEE electronic users group) 입니다 . 이 사이트에 등
록하여 전세계의 VEE 전문가들로부터 Agilent VEE 를 사용하는데 필요
한 도움을 받으십시오 .
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부록

Agilent VEE Pro 도움말을 영어 이외의 다른 언어로 사용할 수 있습니다
. 이미 설치된 vee.chm 파일의 이름을 veeEnglish.chm 으로 변경하고 , 
사용할 도움말 파일을 vee.chm 으로 변경하면 됩니다 . 예를 들어 , 
veeKorean.chm 을 vee.chm 으로 변경하면 한글 도움말을 사용할 수 
있습니다 .
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