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Overview
For seamless transmission of data, it is imperative to measure (and if possible, eradicate) 
errors, if any. With version 1.2, the Open RAN Studio software has been enhanced to 
provide a functionality to measure the Bit Error Ratio and the Block Error Ratio by 
measuring the ratio of incorrectly received bits / blocks to the total bits / blocks received 
from the O-RU.
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Defining BER and BLER
The Bit Error Ratio (BER) is defined as the ratio of the bits wrongly received to all data bits 
sent. Current measurement type compares the transmitted bits with PN9 sequence and 
calculates error rate (that is, how many bits did not match PN9).

A Block Error Ratio (BLER) is defined as the ratio of the number of erroneous blocks 
received to the total number of blocks sent. Current measurement type compares the 
transmitted demodulated data sequence and may correct some error bits. For example, if 
we transmit data sequence “00000000”, but the demodulated bits are “01000000” due to 
noise (1-bit error / total 8 bits). After decoding this bit sequence, the original bit 
sequence “00000000” can be obtained, as the decoder correct error bits.

NOTE
You must install the license option U5040MULA to use the BER 
/ BLER measurement application in the U5040A Open RAN 
Studio software.

https://ksm.software.keysight.com/ASM/External/TrialLicense.aspx?ProdNum=U5040MULA-TRL
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Before we proceed to understand how to measure the BER / BLER, let us 
understand the prerequisites for the O-RAN Studio software to identify the 
data correctly to perform proper measurements.
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Section 1.1: Prerequisites to BER/BLER measurements

Following is the list of Hardware and Software components along with the 
license options.

 1.1.1: Hardware components

Table 1 HW components for BER/BLER measurements

* Connection of the HW devices is shown further using the Cables listed in the table. 

HW component Product description

O-DU • BittWare TeraBox 1000S FPGA server with the FPGA Ethernet 
Acquisition Module

O-RU • Any Device Under Test

(Optional) Triggering 
Hardware

• N5182B MXG X-Series RF Vector Signal Generator
OR
• M9019A PXIe 18-Slot Chassis
• M9037A PXIe Embedded Controller
• M9410A VXT PXI Vector Transceiver
• M9300A PXIe Reference Module

Automation • BittWare Terabox server or a PC with Win 10 operating system

Cables*

Optics • QSFP28 (Qty. 2)
• Fiber Optic Single Mode (Qty. 1)

RF Cabling • N Type to SMA Female adapters (Qty. 2)
• SMA Male to SMA Male cable (Qty. 2)

Comms • USB to USB cable (Qty. 1)

Reference clock • SMB Female (plug) to MMPX Male cable (Qty. 1)
• SMB Female (plug) to SMB Female (plug) cable (Qty. 1)

Networking • Ethernet Cat 6 cable (Qty. 3)

Triggering • SMB Female (plug) to MMPX Male cable (Qty. 1)

https://www.keysight.com/en/pdx-x201912-pn-N5182B/mxg-x-series-rf-vector-signal-generator-9-khz-to-6-ghz?cc=US&lc=eng&jmpid=zzfindn5182b
https://www.keysight.com/en/pd-2685872-pn-M9019A/pxie-chassis-18-slot-3u-24-gb-s-gen-3?nid=-32038.1175294&cc=IN&lc=eng
https://www.keysight.com/en/pd-2375624-pn-M9037A/pxie-high-performance-embedded-controller?cc=US&lc=eng
https://www.keysight.com/en/pdx-2952244-pn-M9410A/vxt-pxi-vector-transceiver-300-600-1200-mhz-bandwidth?nid=-55429.5107464&cc=CA&lc=fre
https://www.keysight.com/en/pd-2193468-pn-M9300A/pxie-frequency-reference-10-mhz-and-100-mhz?cc=US&lc=eng&jmpid=zzfindm9300a
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 1.1.2: Software components

Table 2 SW components for BER/BLER measurements

After the HW and SW components have been installed, let us understand 
how to generate the following files, which are required as inputs for the 
calculation of BER / BLER. Note that you may perform the steps to 
generate each of these files on a Win 10 PC. Thereafter, you may use those 
files as inputs to a system that has the BittWare server along with a 
triggering mechanism and automation enabled via TAP or your own 
automation system.

• Using the N7631C Signal Studio software

• SCP file

• Waveform file

• Using the U5040A Open RAN Studio software

• ORSTX file

• PCAP UL file

• BER XML / BLER XML files

SW component Product description

Open RAN Studio
• U5040A Open RAN Studio Software v1.2.10720.0 or higher

• License options: U5040BSCA, U5040IQEA and U5040MULA

Signal Studio

• Keysight PathWave Signal Studio Pro 5G NR v6.1.2.3 or higher

• License options: N7631ORNC and N7631EMBC (reqd. if using VXT / 
MXG)

VSA

• Keysight PathWave 89601C - 89600 Vector Signal Analysis 2020 or 
higher

• License option: 89601BHNC

Automation
• (Optional) Keysight PathWave Test Automation

• License option: KS8400A

Triggering

• (Optional) Keysight M938xA Vector Signal Generator Drivers 
v2.1.150.4
• License option: Not required

• (Optional) Keysight Launch Modular TRX SW revision M.25.63
• License options: N9060EM3E, Y9085EM0E, V9060EM0E and 

V9065EM1E

https://www.keysight.com/us/en/lib/software-detail/computer-software/u5040a-open-ran-studio-software-3108894.html
https://ksm.software.keysight.com/ASM/External/TrialLicense.aspx?ProdNum=U5040BSCA-TRL&id=3108931
https://ksm.software.keysight.com/ASM/External/TrialLicense.aspx?ProdNum=U5040IQEA-TRL&id=3108945
https://ksm.software.keysight.com/ASM/External/TrialLicense.aspx?ProdNum=U5040MULA-TRL&id=3139001
https://www.keysight.com/main/software.jspx?ckey=2950773&lc=eng&cc=US&nid=-11143.0.00&id=2950773
https://ksm.software.keysight.com/ASM/External/TrialLicense.aspx?ProdNum=N7631ORNC-TRL&id=3108938
https://ksm.software.keysight.com/ASM/External/TrialLicense.aspx?ProdNum=N7631EMBC-TRL
https://www.keysight.com/main/software.jspx?cc=IN&lc=eng&ckey=2013472&nid=-32806.0.02&id=2013472
https://ksm.software.keysight.com/ASM/External/TrialLicense.aspx?ProdNum=89601TRLC-TRL&id=3108949
https://www.keysight.com/main/software.jspx?ckey=2796935&lc=eng&cc=IN&nid=-31809.1191510&id=2796935
https://ksm.software.keysight.com/ASM/External/TrialLicense.aspx?ProdNum=KS8400A-TRL
https://www.keysight.com/main/software.jspx?ckey=2235963&lc=eng&cc=IN&nid=-33111.1032567&id=2235963
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NOTE
While the configuration of the generated SCP file is the same for BER and 
BLER measurements, the ‘Channel Coding’ setting in the Signal Studio 
software determines whether the SCP file is configured for measuring 
BER or BLER.
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Section 1.2: Generating SCP & Waveform files with Signal Studio

The N7631C Signal Studio Pro for 5G NR interface allows for test 
waveforms to be downloaded into and played from Keysight 
instrumentation. This software runs in the BittWare server and is used to 
create the test waveforms for Open RAN Studio and for the signal source 
hardware of the M9410A.
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 1.2.1: Generating SCP files

1 For the Open RAN Studio software to gather data for BER / BLER 
measurements, you must configure the Carrier with the characteristics, 
which are shown in Figure 1.

Figure 1 SCP file settings in Signal Studio
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Carrier settings common for BER / BLER measurement:

• Carrier Type: Uplink (other carrier types are currently not supported for 
BER / BLER measurements)

• Data taken from SCP file for measurements

• Bandwidth

• Numerology

• Max RB

• Channel Setup: UL-SCH

• Payload Data: PN9

2 Configure the ‘Channel Coding’ for BER / BLER measurements as 
shown in Figure 2 and Figure 3.

• BLER — Channel Coding set to ‘On’

Figure 2 Channel Setup settings for BLER

• BER — Channel Coding set to ‘Off’

Figure 3 Channel Setup settings for BER

3 Click File > Save As… to generate an SCP file (*.scp) each for BER and 
BLER, with their respective characteristics described above.

Note that for the purpose and ease of illustration, the SCP files generated 
in the Signal Studio software for BER and BLER have been saved in two 
separate folders named ‘BER’ and ‘BLER’ respectively, which were 
manually created, in the local disk (C:) of the PC. The entire folder path is 
required to define the file names during the BER/BLER measurements 
using the manual process, as is explained further.
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Figure 4 Manually created folders to save files for BER/BLER measurements

 1.2.2: Generating Waveform Files

1 Click File > Export Waveform Data to generate a Waveform file (*.wfm) 
each for BER and BLER, with their respective characteristics described 
in the previous section.

2 Save the waveform files for BER and BLER in their respective folders, 
where the corresponding SCP files are located.
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Figure 5 Waveform file generation in Signal Studio

NOTE
Waveform files (*.wfm) are not required when measuring BER / BLER 
using the manual process, which has been explained further.
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Section 1.3: Generating files with Open RAN Studio

The following example displays the steps to generate the ORSTX and 
PCAP files, followed by generating the XML file using the U5040A Open 
RAN Studio software. These files are required to measure BLER. The flow 
to generate files for BER measurement is the same with some differences, 
which are explained along.

1 Load the SCP file into the Open RAN Studio software.

Figure 6 SCP file loaded in O-RAN Studio
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2 Assign a Flow/eAxC ID to the selected carrier.

3 Launch the C/U-Plane Builder Configuration Tool window.

4 In the Options tab, select the Create Uplink U-Plane check box in the 
U-Plane Package area.

Figure 7 Modifying configuration of the loaded file

5 Close the C/U-Plane Builder Configuration Tool window.

6 From the main menu, click File > Export > Generate Stimulus file to 
generate the corresponding PCAP file, with the ‘_UL’ suffix (which shall 
contain the U-Plane messages in the Uplink data). Note that the 
ORSTX file is also generated in this step.
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7 From the main menu, click File > Export > Generate BLER XML File.

Figure 8 Generating XML file for BER/BLER measurement

8 Click Ok on the Progress Dialog, after the Activity Progress reaches 
‘100%’, which indicates that the XML file required for BLER 
measurement has been generated.

Figure 9 Activity progress for XML file generation for BLER

The folders, where the SCP and the corresponding uplink U-Plane 
message PCAP (with the UL suffix) and ORSTX files are located, shows 
an XML file with the same name as the SCP file.



Measuring BER / BLER using ORAN Studio Solution (v1.2) Reference Guide 19

Measuring BER/BLER in Keysight Open RAN Studio Solution 1

 

The folder in Figure 10 shows the files required for BLER measurement. 

Figure 10 Folder for BLER containing all files reqd. for measurement
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If measuring BER, the file set will be similar, as shown in Figure 11.

Figure 11 Folder for BER containing all files reqd. for measurement

The set of files generated previously (SCP and WFM) and the stimulus 
file generated in this section (PCAP_UL) are used as inputs to a 
BittWare system, with triggering and automation enabled.
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Section 1.4: Generating Recording PCAP files

Consider a BittWare system, as depicted in Figure 12, where the following 
devices are connected:

Figure 12 Block diagram illustration of a BittWare system

• an O-DU (BittWare server)

• the U5040A Open RAN Studio software and the U5040MULA license 
must be installed on the server

• an O-RU (Device under test)

• a triggering mechanism, with one of the following instrument set:

• N5182B MXG, or

• M9019A PXIe 18-Slot Chassis, M9037A PXIe Embedded Controller, 
M9410A VXT PXI Vector Transceiver, and M9300A PXIe Reference 
Module

• a PC for automation using either TAP or your own automation system. 
This step is optional as you may manually perform BER / BLER 
measurements, as explained further.

NOTE
You must install the N7631EMBC license per-chassis for the M9410A 
VXT instrument or on each N5182B MXG.
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Figure 13 illustrates how the instruments are connected to each other 
using one or more cables listed in Table 1. This setup uses the VXT 
instrument set for the purpose of triggering and to aid the BittWare server 
in generating the required PCAP file. The SCP and WFM files are input to 
the VXT whereas the PCAP_UL file is loaded into the Open RAN Studio 
software on the BittWare server to capture the Recording PCAP file, which 
is required for the BER/BLER measurements.

Figure 13 BittWare system setup for BER/BLER measurement



Measuring BER / BLER using ORAN Studio Solution (v1.2) Reference Guide 23

Measuring BER/BLER in Keysight Open RAN Studio Solution 1

 

Figure 14 illustrates the flow of data in the system using various software 
components:

Figure 14 Data flow (for Uplink signal) in the BittWare system

 1.4.1: Delay in triggering mechanism for Uplink signal

Let us consider the scenario, where the Trigger comes out of the Trigger 
Out from the O-RU with the Delay set to 0s on the Open RAN Studio 
software, as the stimulus file starts.

If no trigger is applied, the Uplink signal/waveform/radio frame will arrive 
at the Radio's antenna port after a few milliseconds (say, 30µs) after 
triggering.

This causes misalignment between the arrival of the waveform and the 
expected radio frame boundaries at the Radio and makes the extracted IQ 
data to be invalid. If loaded in the 89600 VSA, it is unable to sync and 
demodulate such IQ data.

If you connect an Oscilloscope, you shall find that the time passed 
between triggering of the M9410A to the moment the RF signal is received 
is about 30µs
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This means that, if we want the signal to be received about 10ms after we 
trigger (so it will be aligned with the 10ms radio frame boundaries), we 
must add about 9.97ms of delay in the Signal Source (MXG or VXT). This 
scenario is illustrated in Figure 15.

Figure 15 Trigger with 9.97ms delay applied
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Section 1.5: BER / BLER Measurement Options

After the files required for BER/BLER measurement are generated, you 
may perform either “Option 1”, which involves an OpenTAP automated 
process to generate the PCAP file for measurement of BER/BLER on the 
BittWare server or “Option 2”, which involves a manual process or using 
your own automation application to generate the JSON files that contain 
the measurement data.

 1.5.1: Using Keysight OpenTAP application’s automation

1 Prepare the PCAP file for the BER / BLER measurement on the O-DU 
(BittWare server).

2 Make sure that the U5040MULA license is installed.

3 Install the KS8400A PathWave Test Automation application, if not 
installed already.

4 Make sure that the Test Automation application is not running. Run the 
installer for the BLER/BER application. To download the BER/BLER 
installer package for TAP, click BER_BLER.1.0.0.TapPackage.

5 Launch the PathWave Test Automation application and create a new 
Test Plan.

6 Add the BLER/BER measurement to the test by clicking on the '+' 
button at the top left corner.

Figure 16 Adding a test plan to TAP Automation

7 On the “Test Steps” dialog that appears, navigate to the ‘BER and 
BLER’ option and click “Add”.

https://www.keysight.com/us/en/lib/software-detail/instrument-firmware-software/ber-bler-tap-package-for-open-ran-studio-solution.html
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Figure 17 Adding automation steps for BER and BLER to TAP

8 Populate the required fields and run the test.

• The JSON file is generated, which can be used for analysis.

 1.5.2: Using manual process or custom automation

Note that before proceeding with either the manual or your own 
automation process for BER/BLER measurements, you must automate the 
captured O-RU response using the setup illustrated in Figure 12 and 
Figure 13. This requires coordination of the O-DU and the signal generator 
to make sure that it sends the signal when the O-RU expects it. Once the 
captured file has been created, save it in the same folder where the other 
files (SCP, ORSTX and XML) are placed for BER or BLER measurements. 
Proceed with the measurements either manually or through your own 
automation system.

1 From the Start menu on your machine, launch the Command Prompt 
window.

2 Set the root folder as “C:\Program Files\Keysight\Open RAN Studio”.
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Figure 18 Setting default installation folder as root

3 Type the following syntax and press Enter.

ErrorRatioAnalyzer BER|BLER <scpFilename> <xmlFilename> 
<pcapFilename> <orstxFilename>

Here:

• ErrorRatioAnalyzer is the executable file that is installed in the folder 
“C:\Program Files\Keysight\Open RAN Studio” along with Open 
RAN Studio software ver. 1.2 or higher.

• BER or BLER must be entered to indicate the measurement you are 
performing

• <scpFilename>: enter full path for the SCP file

• <xmlFilename>: enter full path for the XML file

• <orstxFilename>: enter full path for the ORSTX file

• <pcapFilename>: enter full path for the PCAP file captured in 
Generating Recording PCAP files on page 21.

For BLER:

Figure 19 Entering command for BLER measurement
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For BER:

Figure 20 Entering command for BER measurement

where,

1 — ErrorRatioAnalyzer

2 — BER or BLER, depending on what you are measuring

3 — Full paths to the SCP, PCAP, XML and ORSTX files (in any order) 
separated by a single space. Note that in the examples above, the 
complete folder location for each file is shown, such as C:\BLER\
UL_BLER.scp and so on.

If successful, the command prompt window displays the message 
Outputing results to <JSON file name>.

In both cases, the measurement result is written to a file in JSON format. 
File name of this JSON is of the format (name of PCAP file + date + time).

The folder, where the SCP, PCAP, XML and ORSTX files are located, now 
shows the JSON file generated.
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JSON file in the BLER folder

Figure 21 Generated JSON file containing BLER measurement data
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JSON file in the BER folder

Figure 22 Generated JSON file containing BER measurement data
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Section 1.6: Structure of the JSON file

To analyze the measured BER / BLER data, let us understand the JSON file 
structure.

JSON file for BER measured with 4 Frames in the recording

Figure 23 Structure of the JSON file for BER

The JSON file structure contains:

• Measurement type

• File name of recording

• Date and time when the measurement was finished

• Error ratio in percentage and frame number for each frame

Each frame has PN9 sequence with 11 bits altered. The Bit Error Ratio 
(BER) is calculated as 11/511 ~ 2.15%.
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Section 1.7: Contact us

For more information on Keysight Technologies’ products, applications or 
services, contact your local Keysight office. The complete list is available 
at: www.keysight.com/find/contactus.

https://www.keysight.com/find/contactus/
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