Welcome to the Agilent Technologies Wireless Protocol Advisor Help

Help Revision Date: April 14, 2008

This online help describes how to use the Wireless Protocol Advisor for revision A.07.50.

The help is organized into the following sections:

Getting Help: Use this section if you want to learn how to get the most from this online help.

Getting Started: Use this section if you are a new user.

How To ...: Use this section if you want step-by-step procedures for performing the most common tasks with the Wireless Protocol Advisor.

Learn About ...: Use this section if you want to learn about features of the Wireless Protocol Advisor.

Application Programming Interface: Use this section if you want information on how to use the Wireless Protocol Advisor's Application Programming Interface.

Loading the Wireless Protocol Advisor: Use this section if you want information on reinstalling and upgrading the Wireless Protocol Advisor.

Troubleshooting: Use this section if you have questions relating to installation, setup or use.

For other information such as pricing and availability, brochures and datasheets for WPA, visit the product page:

www.agilent.com/find/E6584A

Copyright © Agilent Technologies, Inc. 2008


Legal Information

Acknowledgements

Microsoft ® is a U.S. registered trademark of Microsoft Corporation

Windows ® and MS Windows ® are U.S. registered trademarks of Microsoft Corporation.

Notice

The hardware and/or software described in this document may be used or copied only with permission from Agilent Technologies, Inc..

If software is for use in the performance of a U.S. Government prime contract or subcontract, Software is delivered as "Commercial computer software" as defined in DFAR 252.227-7014 (June 1995), or as a "commercial item" as defined in FAR 2.101(a) or as "Restricted computer software" as defined in FAR 52.227-19 (June 1987) or any equivalent agency regulation or contract clause. Use, duplication or disclosure of Software is subject to Agilent Technologies’ standard commercial terms, and non-DOD Departments and Agencies of the U.S. Government will receive no greater than Restricted Rights as defined in FAR 52.227-19(c)(1-2) (June 1987). U.S. Government users will receive no greater than Limited Rights as defined in FAR 52.227-14 (June 1987) or DFAR 252.227-7015 (b)(2) (November 1995), as applicable in any technical data.

© Agilent Technologies, Inc. 2002-2005


Getting Help

This section provides details on how to use this online help and how to get additional information on the Internet.

For more information, choose a topic below:

Learning about Using Help

How to Get More Help


Learning about Using Help

The Wireless Protocol Advisor's On-line Help is based on Microsoft Windows On-line Help.

General Help

Click on [image] or select Contents and Index from the Help menu to display the On-line Help's Contents, Index and Search tabs

  • The Contents tab contains an expandable list of step-by-step instructions and basic information about each aspect of the Wireless Protocol Advisor.

  • The Index tab contains an alphabetical list of common words and phrases.

  • The Search tab lets you search for a word or phrase. The first time you select the Search tab you will be prompted to create the list of words used within the help system. The system builds the list for you in a few seconds.

On Views

  • Press F1 to display detailed information about the current view. You will find out what the view does and how it should be used.

  • Press Shift+F1 or select What's This? from the Help menu and point on the item you want more information on.

In Dialog Boxes

  • Press F1 to display detailed information about the selected object.

  • Click on the [image] in a dialog box and point to the object you want information about.

Tips

  • Move the pointer over an item to display a ToolTip. ToolTips provide additional information about the item. ToolTips are available on toolbar buttons and on many views.

  • In many areas right-clicking displays a menu. This menu lists all the functionality for the item on which the right-mouse button was clicked.


How to Get More Help

You can get up-to-date information about all aspects of the Wireless Protocol Advisor at the following Agilent Technologies web site.

http://www.agilent.com/find/e6584a

This web site contains the most recent CHM Help file, Release Notes, and the latest available WPA software download.


Getting Started

The topics in this section provide important introductory information if you are a new user.

For more information, choose a topic below:

Introduction

The Basic Steps

System Configuration

Set up the Wireless Protocol Advisor

Troubleshooting Connections


Introduction

This topic details the following:

  • Product Description

  • WPA features

Product Description

The Agilent Technologies WPA (Wireless Protocol Advisor) allows you to simultaneously log protocol messages between up to two test sets and a device under test. It can also be used to store, retrieve, and analyze previously captured message logs.

The WPA is designed for use with certain applications of the following test set:

  • E5515C Wireless Communications Test Set (also referred to as the 8960)

E5515C Wireless Communications Test Set
Application | Wireless Protocol Advisor
E6701C/D/E/F/T/U GSM/GPRS Lab Application | GSM-GPRS-EGPRS decodes
E6702A/B cdma2000 Lab Application | cdma2000 decodes
E6703A/B/C/D/E/T/U W-CDMA Lab Application | W-CDMA-HSDPA-HSUPA* decodes
E6704A EGPRS Lab Application | GSM-GPRS-EGPRS decodes
E6706A/B/T/U 1xEV-DO Lab Application | 1xEV-DO decodes

* While the WPA supports HSDPA/HSUPA protocol logging, it is not supported at full data rates. It is not guaranteed that all protocol messages between the DUT and the test set will be captured for high data throughput rates and therefore recommended that you do not use the WPA for CQI values greater than 5. The CQI Value setting can be accessed on the test set by pressing HSDPA Parameters (F10) from the Call Setup screen, then HSDPA PS Data Setup (F7).

WPA features

  • Operating Modes:

    • Real Time mode allows you to capture and analyze and save protocol messages between the test set and Device Under Test. The protocol messages are displayed real time as they are captured.

    • Post Capture allows you to analyze and save any .tol file captured in Real Time operating mode. You cannot capture protocol messages in Post Capture mode.

  • Views

  • Traffic Overview

  • Single-line display of the individual protocol messages in sequential order as they are received

  • You can customize the display by selecting the column fields that you find the most useful. General column fields include message number, size, message direction (text), message direction (arrow) system time, timestamp (based on PC's real-time clock), message name, repeat count, and selected fields from the logged messages. There are also many protocol field specific columns to choose from.

  • Decode View

  • Displays a very detailed decode of the selected message.

  • Display either the individual octets of the message or a separate line for each field of each parameter in the message.

  • Configurable display columns include octet number, octet data, decimal value, binary value, hexadecimal value, and field description.

  • Summary View (of the messages in the Traffic Overview)

  • Displays a summary of the messages currently in the traffic overview.

  • The contents of the summary view includes information such as the Date, Start and End Time (of the PC), Duration, Totall number of messages generated by the 8960, Number of messages logged by WPA, and the Number and Percentage of messages dropped.

  • User configurable filters, some of which can be saved for use later. The filter types include:

  • Test Set filters limit the amount of information sent over the LAN by passing only the messages for selected protocol layers.

  • Logging filters limit the amount of information contained in the log. The extremely flexible configuration can be based on individual field parameters of messages for any protocol layer. A time based filter can also be established. Filters can be combined using AND and OR operations. Logging filters can be exported to an external file for use with other captures or logs.

  • View filters limit the amount of information displayed, but have no effect on the amount of information actually logged. These also have extremely flexible user configurations based on individual field parameters of messages for any protocol layer or on timestamps which can be combined using AND and OR operations. Logging filters can be exported to an external file for use with other captures or logs.

  • Find filters locate messages in the captured log matching user defined parameters. These filters can be exported for use with other captures or logs.

  • Triggers to define when to start and stop logging. These are conditions that can be configured to pre-capture or post-capture a specific number of messages. Configurations can be saved for later use. The types of trigger configurations includes:

  • Message match triggers start or stop logging when a received message matches or does not match the user-selected message or message parameters.

  • Time triggers start or stop logging on a specific timestamp and day based on your PC's real-time clock.

  • Trigger counts can also be used to start logging. Log capture starts after a user-defined number of start triggers have occurred.

  • Event triggers start or stop logging when a message dropped, message received, or received message overflow event occurs.

  • Synchronization of Messages from Multiple Test Sets. You can connect and simultaneously capture protocol logs from two test sets.

  • Captured logs can be saved to useful file types. These include *.tol for use with the WPA and *.csv for use with a spreadsheet program. Additionally, message decodes can be saved to a text file or copied to other applications.

Microsoft ® and Windows ® are U.S. registered trademarks of Microsoft Corp.


The Basic Steps

There are three main steps to using your Wireless Protocol Advisor (WPA).

  1. Step 1 - Connecting and Configuring

  2. Step 2 - Capturing

  3. Step 3 - Analyzing Data

Step 1 - Connecting and Configuring

  1. The test set and the PC running the WPA software must be connected to a LAN. Note: The PC running WPA must have its internet browser configured to work online. WPA cannot retrieve the test set's configuration when the browser is setup to work offline. See the test set's documentation for information on setting the necessary IP and gateway addresses. See System Configuration for details on how to set up your test system.

  2. Once the test system is set up, start WPA.

  3. At the Start Up screen select Config to configure the WPA to monitor one or two test sets, or, if WPA has already been configured in a previous session, choose Real Time . (Alternatively, click Post Capture to open an existing *.tol file)

Step 2 - Capturing

You must be in Real Time mode to capture data. Once one or both of the test sets are configured, you must click Start/Stop Messages ( [image]) in the Monitor ( [image]) to start capturing. Clicking the Start/Stop Messages icon either starts or stops all test sets that are connected. That is, you cannot start/stop test sets independently.

Protocol logs are only taken from a test set if it is connected to WPA. The Start/Stop Messages icon ( [image]) indicates that a test set is connected to WPA by changing the background of one or both of the circles in the Start/Stop Messages icon from grey to red. For example, if the background of both circles are grey ( [image]), this indicates that WPA is not connected to either test set, and therefore cannot capture a protocol log.

Step 3 - Analyzing Data

To analyze the data and investigate problems:

  • Use Filters to capture or isolate only the messages you want. There are various filter types available.

  • Analyze the captured information.

  • Save log files (*.tol) for analysis later. The configuration and measurement setup information is also saved in the log file.

For more details, see Set up the Wireless Protocol Advisor. or System Configuration.


System Configuration

The Wireless Protocol Advisor (WPA) is connected to your network via the LAN connection on your PC.

Typically the PC is already connected to the LAN. Connecting your PC to the LAN is not covered in these instructions.

The test set must also be connected to the LAN via its LAN port on the test set's back panel. The Device Under Test (DUT) must be connected to the test set via the RF IN/OUT port on the test set's front panel.

WPA is capable of logging protocol messages from up to two test sets (dual source logging). The protocol messages can then be filtered to show messages from the either or both test sets by creating a view filter. The figure below shows the proper system configuration.

Two test sets are not required in the system configuration for WPA to operate. Also the PC running WPA must have its internet browser configured to work online, otherwise the PC cannot connect to the test set.


Set Up the Wireless Protocol Advisor

This section only applies to you if you are using the Wireless Protocol Advisor in Real Time operating mode. There are several steps involved in setting up your Wireless Protocol Advisor (WPA) to communicate with your test set.

Set Up the Test Set

You may need to request a valid IP address and subnet mask for the test set from your IT department. You may also need an IP address for your wireless device. If you arbitrarily create your own addresses, you may cause problems on your network.

Set up the Test Set for LAN Connection

  1. Connect the test set(s) to the LAN.

  2. Power up the test set(s).

  3. Press the System Config key to go to the System Config screen of the test set(s).

  4. Verify that the currently running application will work with the WPA product you are running.

  5. Look at the LAN IP address and the Subnet Mask on the System Config screen. If they are not correct,use the Instrument Setup (F1) key on the test set to change these values.

Set up the RF In/Out Amplitude on the Test Set

Set the amplitude offset to compensate for the device’s RF test cable if necessary.

  1. Press the System Config key.

  2. Press the RF IN/OUT Amptd Offset (F5) softkey.

  3. Press the RF IN/OUT Amptd Offset Setup (F2) softkey

  4. It is OK to leave the RF In/Out Amplitude Offset State value as Off if your RF cable between the test set and the DUT is low loss. If it is On, check that reasonable values are entered in the table for the device’s RF test cable.

  5. Press the Close Menu (F6) key.

Set Up the WPA to Communicate with the Test Set

The PC running WPA must have its internet browser configured to work online. If the internet browser is configured to work offline, the following message is displayed: "Cannot connect while browser is in offline mode".

  1. Start the WPA. Click Real Time to capture protocol logs or Post Capture to analyze protocol logs.

  2. Once the WPA is started, select Config if WPA is not already configured to communicate with the test set. This displays the Instrument Configuration screen as shown in the figure below. If WPA is configured to communicate with the test set, select Real Time to bypass the Instrument Configuration screen (shown below).

    Note:     There are separate Instrument Configuration screens for each test set in the system. Click on Test Set 1 or Test Set 2 tabs to access the Instrument Configuration screens for the corresponding test set.

  3. Enter the test set's IP Address (found on the Instrument Setup menu on the test set)

  4. Optional: Click on the Bypass default LAN settings checkbox. This step is recommended if it is not necessary to connect from the PC to the test set through a proxy server or network gateway. Contact your system administrator if necessary.

  5. Optional: Click the Disable automatic connection on transition to Real Time. The step prevents WPA from automatically connecting to the test set(s) that are currently configured when you transition to the Real Time. This step is recommended if you frequently connect to different test sets, or if you have two test sets configured and you prefer to only capture protocol logs from one test set at a time.

  6. Click on the Connect button.

  7. The Configuration screen will display while the WPA is trying to connect to the test set. If connection is successful, the WPA Traffic Overview window will be displayed. If unsuccessful, an error window will be displayed. See Troubleshooting Connections.

  8. Stacks/Streams - All available Stacks/Streams in the test set are automatically loaded when WPA connects to the test set. Streams are configured to route data correctly between the test set an the decode stack. Only formats with configured streams will be logged properly as the configured streams also determine the available stack selections on the trigger and filter screens. The connection time depends on the number of protocol decode stacks that must be loaded.

    A checkmark in the box next to the list of Stacks/Streams indicates that the protocol decode stack for that format is loaded and that a stream is configured for that format. Alternatively, no checkmark indicates that no stream is configured for the particular format and there may or may not be a protocol decode stack loaded.

    To load the appropriate protocol decode stack and configure the corresponding streams, check the empty box next to the appropriate protocol decode stack. (Un-checking a checked box un-configures the stream.)

Verify Connections

  1. Verify that a WPA is connected to the test set by looking at the Logging annunciator in the Instrument Status Area on the test set's front panel display. If the WPA is connected to the test set, the Logging status indicates "Logging:Idle". If a connection does not exist, the status indicates "No Conn."

  2. Verify that the WPA is communicating with the test set by observing the Status field in the bottom right corner of the Monitor window. It displays "Connected to <IP Address of your test set> - Idle" if a connection has been established.

  3. You can also check the status of the connection from the Configuration window.

    1. Observe the Status field in the Configuration screen. It should read Idle. Test set information is displayed in the information box below the Connect/Disconnect button in the screen.

    2. Verify that you have the correct application loaded on the test set by reading the test set information in the information box.


Troubleshooting Connections

If WPA does not Connect with the Test Set

Before contacting Agilent Technologies, verify the following checkpoints:

  1. The PC running WPA must have its internet browser configured to work online. If the internet browser is configured to work offline, the following message is displayed: "Cannot connect while browser is in offline mode".

  2. The PC (Personal Computer) is connected to the LAN.

  3. The test set is connected to the LAN.

  4. The test set is running the correct application.

  5. The WPA software on the PC is trying to connect to the correct test set IP address. (Compare IP addresses on the test set's System Config screen and the WPA's Configuration screen.)

If the IP address has been verified but WPA still won't connect, click on the checkbox labeled "Bypass default LAN settings" located below the Status field on the Instrument Configuration screen. Clicking on this checkbox will cause WPA to attempt a direct TCP/IP connection to the test set. Proxy server settings or Automatic configurations will be bypassed.

If your problem cannot be resolved using this information, see How to Get More Help.


How To ...

The topics in this section provide step-by-step procedures for performing the most common tasks with the Wireless Protocol Advisor.

For more information, choose a topic below:

Capture Traffic

Use the Measurement Setup view

Use Triggers and Filters

Analyze Captured Data

Use Connection Trace


Capture Traffic

You can quickly capture all the messages between the test set and the Device Under Test by following the Message Capture instructions. You can add and save Filters in Post Capture mode.

To restrict which messages are captured, go to Monitor's Measurement Setup view ( [image]) where you can define Test Set Filters, Triggers, and Logging Filters.


Message Capture

This topic discusses how:

  • T o capture protocol messages:

  • To recapture protocol messages without saving the previous capture:

To capture protocol messages:

  1. After you have set up and configured the Wireless Protocol Advisor with your test set(s) click [image] to go to Monitor.

  2. Click [image] to start capturing using the default settings. The Stop/Start button operates on all test sets that are connected. (The appearance of the Stop/Start button changes slightly depending on the number of test sets connected.)

  3. Click [image] when you want to stop capturing from your network. The Stop/Start button operates on all test sets that are connected. Then click [image] to save.

To pause traffic press [image] or [Spacebar]. Messages will continue to be recorded, only the views are paused.
To resume processing captured messages after pausing press [image]. The Pause and Resume buttons operates on all test sets that are connected.

Do not pause for too long while capturing at high data rates as you may lose data. The green area of the Free Buffers indicator at the bottom right of the windows ( [image]) will reduce as the buffer space is used. When buffer space is almost full the green band will change to red ( [image]). You must resume the capture to avoid loosing data. The band will indicate if data has been lost.

Considerations

  • The Start/Stop Messages option is disabled when the Wireless Protocol Advisor is in Post Capture mode ( [image]).

To recapture protocol messages without saving the previous capture:

1. Click the Recapture button, [image].

Considerations

  • When using recapture, WPA immediately starts capturing messages regardless of whether the previous message capture is saved or not.

  • The recapture feature is available only after a message capture has been performed.

  • You can perform the same functions when using the Recapture button (such as pause, resume, and save) as are available using the Stop/Start button.

  • It is important to remember that using recapture does not prompting you to save and automatically overwrites the messages that are in the traffic overview. You must manually save any message capture you wish to keep when using recapture.


Use the Measurement Setup View

Measurement setups contain information used to control the capture and viewing of messages exchanged between the test set and the device under test. You can export measurement setups to *.msf files. Once exported, you can import the file and reuse, or edit, the settings (filters and triggers) in a new Real Time measurement. Measurement setups can also be imported from a log file (*.tol).

When you import measurement setups the triggers and filter (logging, view, and so on) are imported into the current Real Time setup. You then choose whether to use your current Real Time hardware configuration setting or use the settings from an existing configuration file.

  • Click F1 to display this help topic for Measurement Setup view. In any Wireless Protocol Advisor (WPA) view, click F1 to display the current view's help topic.

  • Only ONE Real Time session can run at a time, however, multiple log files can be analyzed in Post Capture mode.


Export a Measurement

  1. Select Export Setup from the File menu.

  2. Enter the filename you want to use and click OK.

You can use this measurement in another Real Time capture by importing it.


Import a Measurement

  1. If the Wireless Protocol Advisor is not in Real Time mode, click Monitor's ( [image]) Real Time button ( [image]).

  2. Select Import Setup from the File menu to display the Select Setup to Import dialog box.

  3. Select the measurement setup file (*.msf) you want to use for the current Real Time capture and click Open. The Setup Import dialog box will be displayed.

  4. You must choose whether to use the existing Real Time configuration or to use an existing configuration file. Select Yes to use the current Real Time configuration,
    OR
    No     to select another configuration. The Select configuration for… dialog will be displayed. Select the configuration file from the list and click Open.

The current Measurement Setup and Configuration, where applicable, will be replaced.

You cannot import measurement setups in Post Capture mode.


Import a Measurement From a Log File

  1. If the Wireless Protocol Advisor is not in Real Time mode, click Monitor's ( [image]) Real Time button ( [image]).

  2. Select File menu [image] Import Setup to display the Select Setup to Import dialog box.

  3. Click [image] to display the higher level directories and double-click the Capture Data directory.

  4. Change the File type to Tol Files (*.tol) to display the log files.

  5. Select the file you want to import the measurement setup from and click Open. The Setup Import dialog box will be displayed.

  6. You must choose whether to use the existing Real Time configuration or to use an existing configuration file. Select Yes to use the current Real Time configuration,
    OR
    No     to select another configuration. The Select configuration for… dialog will be displayed. Select the configuration file from the list and click Open.

The current Measurement Setup and Configuration, where applicable, will be replaced.

You cannot import measurement setups in Post Capture mode.


Use Triggers and Filters

You can use triggers and filters to define which events and messages are processed. Start and stop triggers restrict the messages processed and the filters act as pass filters; items selected to filter are passed and all others are discarded.

The following filters and triggers are available in the Wireless Protocol Advisor (WPA):

  • Test set filters - instruct the test set which messages to send to the WPA

  • Start and Stop Triggers - Triggers control when to start or stop logging within the WPA

  • Log filters - control what is stored in the WPA log file

  • View filters - control what is viewed in the Traffic Overview screen

  • Find filters - locate information in the Traffic Overview screen

Trigger and Filter Setup

Triggers and filters are set independently for each connected test set. Triggers and filters are set up in the Monitor's Measurement Setup, which displays all the trigger and filter setup icons.

In Monitor's Measurement Setup view:

  • Set up Triggers to automatically start and stop capturing Real Time events and messages between the Device Under Test (DUT) and the test set.

  • Set up Logging Filters to restrict which events and messages are captured.

  • Set up View Filters to restrict which events and messages are displayed in the Traffic Overview.

In Monitor's Traffic Overview:

  • Set up or edit existing View Filters to restrict which events and messages are displayed in the current Traffic Overview.

  • Set up Find Filters to highlight defined events and messages.


Set Up a Test Set Filter

Test set filters can be created to control which messages are actually sent from the test set to the Wireless Protocol Advisor (WPA). They are essentially a pre-filter to the WPA and its other filters and triggers. Test set filters limit the amount of information sent over the LAN by passing only the messages for selected protocol layers. The filter setup dialog boxes identify which test set the settings apply to in the title of the dialog box.

Test set filters can be configured fore each test set that is connected. The filter setup dialog boxes identify which test set the settings apply to in the title of the dialog box. A Protocol Stack and TAP Points diagram is available in the test set message filter configuration screen. This diagram is provided to help you determine which messages you want to filter. You can hide the diagram by un-checking the Display Protocol Stack and TAP Points checkbox.

The test set message filter settings can only be modified if there is a connection to the test set. If there is no connection and you open the Test Set Filter configuration screen, a dialog box appears that states, "The Test Set connection has been lost, the settings cannot be modified". All filter setting are disabled in this circumstance.

If the connection to the test set is lost while the corresponding Test Set Message Filter configuration screen is open, no changes are applied to the Test Set Filter. A dialog box appears when you press OK stating: "The Test Set connection has been lost, the settings cannot be made". However, if the connection is reestablished while the Test Set Message Filter dialog box is open, click Reset/Refresh before changing the settings.

  1. If the WPA is not in Real Time mode, click Monitor's ( [image]) Real Time button ( [image]). Remember that the WPA must be successfully connected to a test set before Real Time mode can be used.

  2. Click [image] to open Monitor's Measurement Setup view.

  3. Double-click the Test Set filter icon corresponding to the test set you wish to configure to display the Test Set Message Filter editor, which is a list of the available protocol layers. If you are not connected to the test set, the available settings are unknown to WPA and a warning message is displayed . The figure below shows the Test Set Message Filter for the GSM/GPRS format. The Protocol Stack and Tap Points diagram can be hidden by unchecking Display Protocol Stack and Tap Points.

  4. Select the check boxes for the protocol layers whose messages you want to send to the WPA. The selected protocol layer's messages pass through the filter.

    At least one Test Set Filter must be enable for each format.

  5. Click OK to apply the filter.


Message Match Filter Setup

The Message Match pane of the trigger and filter editors contain a drop-down list of the protocol stacks available in the test set. The protocol layers displayed in the Message Match pane correspond to the selected Protocol Stack.

  1. Click New to create a new filter. Or edit an existing filter by adding 'AND' criteria to it.

  2. Click the Message Match tab.

  3. Double-click the Protocol. The list will update to show the fields in the selected protocol.

  4. Click on the Field. The Value criteria will be displayed opposite the field list.

  5. Select the value from the list. Or, click Add Value to display a dialog box, enter the new value in the dialog box and click OK.

  6. Either click another tab to add 'AND' criteria to the filter or click OK to apply the filter.

Within a single Trigger, Filter or Find the Conditions are 'AND'ed. Create another trigger (or filter) to add 'OR' conditions (and repeat to create further 'OR' conditions.) The filter setup dialog boxes identify which test set the settings apply to in the title of the dialog box.


Create a Start or Stop Trigger

This is only applicable to Real Time mode.

Triggers automatically start or stop the capture of messages between the test set and the Device Under Test (DUT) when an event that meets the trigger is detected. You can have no triggers, a start trigger, a stop trigger or both start and stop triggers for each test set that is connected to WPA. The trigger setup dialog boxes identify which test set the settings apply to in the title of the dialog box.

It is not possible to apply different triggers events on different test sets. That is, when a trigger is reached on one test set, that trigger event is applied to all the test sets. However, it is possible for each test set to trigger at the same time. This results in two trigger messages next to each other in the protocol log sequence.

Within a single trigger description the Trigger Conditions are 'AND'ed. To set up 'OR' conditions you must create a new trigger (repeat from Step 3 for the 'OR' conditions.)

Trigger Criteria

  1. If the Wireless Protocol Advisor is not in Real Time mode, click Monitor's ( [image]) Real Time button ( [image]). Click [image] to open Monitor's Measurement Setup view.

  2. Double-click [image] to display the Trigger Editor for the test set you wish to configure the triggers on.

  3. Click either the Start or Stop Trigger panel to select it and then click New button to create a new trigger.

  4. (OPTIONAL) Set up options in the Criteria panel. If you do not set criteria the capture session will start and /or stop at the message that activates the trigger(s). (The setting to capture a specific number of messages before the start trigger or after the stop trigger applies to the total number of messages logged by both test sets -not the number logged only by the test set that initiated the trigger.)

    • (OPTIONAL) Start Criteria
      You can capture for a specified time, or specific number of total messages before the event from each connected test set or message that activates the Start Trigger. You can also set the maximum capture duration if there is no Stop Trigger or its conditions have not been met by the defined duration.

    • (OPTIONAL) Stop Criteria
      You can capture for a specified time or specific number of total messages after the event from each connected test set or message that activates the Stop Trigger.

  5. Set up the Trigger Conditions in the tabs in the lower half of the Trigger Editor.

  6. Click OK to apply the trigger(s).

  • You can disable a trigger, without losing the settings, by clearing the trigger's check box. Only triggers which are selected are used during the capture.

  • Message conditions (in the lower half of the Trigger and Filter Editors) are set up the same way in Start Triggers, Stop Triggers, Logging Filters, View Filters and Find Message.


Time Filter Setup

The filter setup dialog boxes identify which test set the settings apply to in the title of the dialog box.

  1. Click New to create a new filter. Or edit an existing filter by adding 'AND' criteria to it.

  2. Click the Time tab.

  3. Click on the time filter type you want to apply.

  4. Enter the date and time details required.

  5. Either click another tab to add 'AND' criteria to the filter or click OK to apply the filter.

Within a single Trigger, Filter or Find the Conditions are 'AND'ed. Create another trigger (or filter) to add 'OR' conditions (and repeat to create further 'OR' conditions.)

The Time Filter set up options change depending on the timestamp format being used in Monitor.


Text search

Text Search Filter Setup

The WPA provides a text search feature for finding text strings within decoded protocol messages.

Including a Text Search as part of a filter or trigger setup may slow protocol logging significantly. (Performance will vary depending on the PC system WPA is running on. )

If filter or trigger settings force WPA to fully decode an excessive number of messages, processing time could cause messages to be lost. An example of this would be entering a text string with no Message Match filtering employed to allow internal algorithms to reduce decoding.

See How to Use Text Search for information about limiting the scope of Text Search.

To access the Text Search feature, select the Measurement Setup view, then double-click on one of the following icons:

  • Triggers

  • Log Filter

  • View Filter

From the editor, select New or Import, then select the Text Search tab. The following window will be displayed:

How Text Search Works

WPA combines the Text Search string with any Events, Message Match or Time settings into a Summary expression that describes protocol message attributes WPA will attempt to resolve as logging takes place (or after logging is stopped or when operating in post capture mode). Only those messages containing the target text string will be displayed.

The Summary of filtering or triggering settings is displayed in a window in the upper right portion of the Filter Editor or Trigger Editor.

How to Use Text Search

Simply enter a text string into the Text Search text box.

WPA decodes protocol messages only to the level that is necessary to resolve filter and trigger expressions using internal algorithms for determining the most efficient way to evaluate the expressions that result from trigger and filter settings. The algorithms are designed to allow WPA to move through messages as quickly as possible to minimize message processing.

Performance problems, such as slow protocol message processing, can result when a text search causes too much additional message decoding. To avoid these problems, limit the scope of the text search as much as possible. Do this by adding other filter terms, such as Message Match, Event, Time filters and Trigger settings.

If you would like to use regular expressions, a programming tool that is found in many text editors, click on the right arrow next to the text entry field to display a list of conditions that, when selected, will automatically insert regular expression syntax into the string. Make sure the Regular expression checkbox is checked if you want the search to treat the text box string as a regular expression.


Create a Logging Filter

This is only applicable to Real Time mode.

Logging Filters restrict which events and messages are captured. Only events and messages which pass through the logging filter are captured. Event and Messages on emulation links will not be filtered. The trigger setup dialog boxes identify which test set the settings apply to in the title of the dialog box.

Within a single Trigger, Filter or Find the Conditions are 'AND'ed. Create another trigger (or filter) to add 'OR' conditions (and repeat to create further 'OR' conditions.)

  1. If the Wireless Protocol Advisor is not in Real Time mode, click Monitor's ( [image]) Real Time button ( [image]). Click [image] to open Monitor's Measurement Setup view.

  2. Double-click [image] to display the Filter Editor for the test set log filter you wish to set up.

  3. Click New to create a new filter.

  4. Set up the Filter Conditions in the tabs in the lower half of the Filter Editor.

  5. Click OK to apply the filter.

  • Logging Filter criteria cannot be changed in Post Capture mode.

  • You can disable a filter, without losing the settings, by clearing the trigger's check box. Only triggers which are selected are used during the capture.


Bit Mask Filter Setup

Description

The bit mask filter allows you to filter by the existence of a value in a range of bits specified by a bit mask. A bit mask filter can only be specified for certain messages. The bit mask filter requires you to enter two values: the bit value and the bit mask. The bit value is the decimal value you want the remaining bits to match after the bit mask has been applied. The bit mask is the decimal value of the bit mask you want applied.

For example, if you enter a bit value of 5 and a bit mask of 7 to a 6 bit field, in binary the bit mask would be

000111

and the bit value you are looking for is

100.

Therefore, if the field contained the bits XXX100 (where X could be either a 1 or 0), the message would pass through the filter.

How to Set Up the Filter

  1. Click New to create a new filter. Or edit an existing filter by adding 'AND' criteria to it.

  2. Click the Message Match tab.

  3. Double-click the Protocol. The list will update to show the fields in the selected protocol.

  4. Click the Field. The Value criteria will be displayed opposite the field list. Click Add Value.

  5. Enter the Bit Value (5), '&' and the Bit Mask (7) in decimal, for example, 5&7.

  6. Either click another tab to add 'AND' criteria to the filter or click OK to apply the filter.

Within a single Trigger, Filter or Find the Conditions are 'AND'ed. Create another trigger (or filter) to add 'OR' conditions (and repeat to create further 'OR' conditions.) The filter setup dialog boxes identify which test set the settings apply to in the title of the dialog box.


Copy a Filter or Trigger

This is not applicable to the test set filter.

  1. From Monitor click [image] to open Measurement Setup view.

  2. Right-click the icon for the trigger or filter you want to copy and select Copy.

  3. Right-click the trigger or filter you want to overwrite and select Paste.

Triggers can be copied only to triggers and filters can be copied only to filters. The filter and trigger setup dialog boxes identify which test set the settings apply to in the title of the dialog box.


Disable a Trigger or Filter

From either the Trigger or Filter Editor click to clear the check box next to the trigger or filter you want to disable. The filter setup dialog boxes identify which test set the settings apply to in the title of the dialog box.


Export a Trigger or Filter

This is not applicable to the test set filter.

Exporting triggers or filters from a measurement setup allows you to use them in other measurement setups or in future measurement setups.

  1. From either the Trigger Editor or Filter Editor click Export. If more than one filter or trigger is defined, the Export Filters dialog box opens. Otherwise, the Export dialog box opens and you should go to Step 3.

  2. Select the check box for the filters or triggers to be exported. Click OK.

  3. Type a filename. Click Save.

Exported triggers and filters are saved to an external file whose name you specify. The filter setup dialog boxes identify which test set the settings apply to in the title of the dialog box.


Field Presence Filter Setup

  1. Click New to create a new filter. Or edit an existing filter by adding 'AND' criteria to it.

  2. Click the Message Match tab.

  3. Double-click the Protocol to display the Fields. This will filter for any message containing the selected Field.

  4. Right-click the Field to display the pop-up menu and select the Select Presence of Field option. Or, select Any Value on the opposite panel.

  5. Either click another tab to add 'AND' criteria to the filter or click OK to apply the filter.

Within a single Trigger, Filter or Find the Conditions are 'AND'ed. Create another trigger (or filter) to add 'OR' conditions (and repeat to create further 'OR' conditions.) The filter setup dialog boxes identify which test set the settings apply to in the title of the dialog box.


Import a Trigger or Filter

This is not applicable to the test set filter.

  1. From either the Trigger or Filter Editor click Import to open the Import dialog box.

  2. Select the file you want to import and click OK.

Triggers and filters are imported from an external file. Only Filter files can be imported to the Filter Editor. Similarly, only Trigger files can only be imported into the Trigger Editor. The filter setup dialog boxes identify which test set the settings apply to in the title of the dialog box.


Invalid Value Filter Setup

  1. Click New to create a new filter, or edit an existing filter by adding 'AND' criteria to it.

  2. Click the Message Match tab.

  3. Double-click the Protocol. The list will update to show the fields in the selected protocol.

  4. Click the field you want to filter on. The Value criteria will be displayed opposite the field list. Click Select All and the Not Match option. This will filter for messages containing this field with any value other than a valid one.

  5. Either click another tab to add 'AND' criteria to the filter or click OK to apply the filter.

Within a single Trigger, Filter or Find the Conditions are 'AND'ed. Create another trigger (or filter) to add 'OR' conditions (and repeat to create further 'OR' conditions.) The filter setup dialog boxes identify which test set the settings apply to in the title of the dialog box.


Not Match Filter Setup

  1. Click New to create a new filter. Or edit an existing filter by adding 'AND' criteria to it.

  2. Click the Message Match tab.

  3. Double-click the Protocol. The list will update to show the fields in the selected protocol.

  4. Click the Field. The Value criteria will be displayed opposite the field list.

  5. Select the value from the list. Or, click Add Value to display a dialog box, enter the new value in the dialog box and click OK.

  6. Click Not Match. This will filter for any value other than those entered.

  7. Either click another tab to add 'AND' criteria to the filter or click OK to apply the filter.

Within a single Trigger, Filter or Find the Conditions are 'AND'ed. Create another trigger (or filter) to add 'OR' conditions (and repeat to create further 'OR' conditions.) The filter setup dialog boxes identify which test set the settings apply to in the title of the dialog box.


Protocol Presence Filter Setup

  1. Click New to create a new filter. Or edit an existing filter by adding 'AND' criteria to it.

  2. Click the Message Match tab.

  3. Right-click the Protocol to display the pop-up menu and select the Select Presence of Protocol option. This will filter for any message using the selected Protocol.

  4. Either click another tab to add 'AND' criteria to the filter or click OK to apply the filter.

Within a single Trigger, Filter or Find the Conditions are 'AND'ed. Create another trigger (or filter) to add 'OR' conditions (and repeat to create further 'OR' conditions.)


Remove a Protocol's Filter Settings from the Filter

Right-click on the Protocol and select Deselect Presence of Protocol from the pop-up menu.


Remove a Trigger or Filter

  1. Click the trigger or filter to be deleted. The filter and trigger setup dialog boxes identify which test set the settings apply to in the title of the dialog box.

  2. Click Remove.

  • Disable triggers or filters if you want to remove them temporarily.

  • Export a trigger or filter if you want to save it.


Rename a Trigger or Filter

  1. Double-click the trigger or filter to display the dialog box. The filter and trigger setup dialog boxes identify which test set the settings apply to in the title of the dialog box.

  2. Type the new name. Click OK.


Trigger Counts Setup

This is only applicable to Real Time mode.

You can set up the trigger to be ignored until the conditions have been met a defined number of times. Set the occurrence you want to activate the trigger. The default is to activate the trigger on the first occurrence. The trigger setup dialog boxes identify which test set the settings apply to in the title of the dialog box.

It is not possible to apply different triggers events on different test sets. That is, when a trigger is reached on one test set, that trigger event is applied to all the test sets. Furthermore, the setting to capture a specific number of messages before the start trigger or after the stop trigger applies to the total number of messages logged by both test sets -not the number logged only by the test set that initiated the trigger.

  1. Click New to create a new trigger. Or edit an existing trigger by adding 'AND' criteria to it.

  2. Click the Trigger Counts tab.

  3. Enter the number of the start trigger occurrence that you want to actually start capturing messages.

  4. Either click another tab to add 'AND' criteria to the trigger or click OK to apply the trigger.

Within a single Trigger, Filter or Find the Conditions are 'AND'ed. Create another trigger (or filter) to add 'OR' conditions (and repeat to create further 'OR' conditions.)


Analyze Captured Data

From Monitor you can define what and how messages are displayed. You can also:

  • Apply view filters to display only the desired messages.

From setting filters to changing the layout and level of details displayed, you have a variety of display tools.


Change Traffic Overview Color Display

You can change the background and text color in the Traffic Overview message rows, as well as the background and the text color for up to six layers in the message Decode view. To access the color display configuration screen (shown below), click the Tool menu, then Options... in the Traffic Overview screen.

The changes you make are saved in WPA when you press OK.

To revert to the default color settings in WPA, there are two Defaults buttons. One button is for the default Traffic Overview message row colors and the other is reverts the message Decode settings back the default colors.


Change Decode Display Format

The fields in the Decode view can be displayed either as one Field Per Line or one Octet Per Line.

  1. Right-click on the Decode view to display the pop-up menu.

  2. Select Field Per Line.

A tick ( [image]) indicates that the display is using the Field Per Line format. No tick indicates that the Octet Per Line format is being used.


Decode Messages

There are three ways to decode a message:

  • Clicking the Decode View icon, [image], displays the message decode view. Clicking the icon again will hide the Decode view.

  • Select Decode view from the Traffic menu.

  • Double-click the message you want to decode. The decode will appear in the lower half of the Traffic Overview window.

To decode another message simply select it in the Traffic Overview. The Decode view always shows the decode for the highlighted message.


Create a View Filter

View Filters restrict which events and messages are displayed. Only captured events and messages which pass through a view filter will be displayed.

Although log filters and triggers are set independently for each test set connected, the view filter operates on the contents of the traffic overview, so there is only one view filter. The view filter contains an additional pane labeled Source that allows you to view messages logged by Test Set 1 or Test Set 2.

  1. In Monitor ( [image]) select View Filter from the Traffic menu.

  2. Click New to create a new filter.

  3. Set up the Filter Conditions in the tabs in the lower half dialog.

  4. Click OK to apply the filter.


Synchronization of Multiple Traffic Overviews

Multiple Traffic Overviews of the same file can be synchronized so that a message highlighted in one Traffic Overview is automatically highlighted in additional Traffic Overviews (see Traffic Overview). You can chose to switch on synchronization by selecting Synchronize Views from the Traffic menu.

If a highlighted message does not appear in an additional Traffic Overview (because it has different filter settings), the nearest message will be highlighted instead.


System Time

System Time represents the cellular system clock at the time messages were relayed from the test set to the WPA software.

The System Time is not equivalent to the GSM Frame Number.


Find an Event or Message

Find Filters highlight particular events or messages.

  1. In Monitor select Find... from the Traffic menu.

  2. Click New to create a new filter.

  3. Set up the Filter Conditions in the tabs in the lower half dialog.

  4. Click OK to apply the find filter and locate the first message.

  5. Select Find Next from the Traffic menu or F3 to select the next event or message that meets the conditions. Or, select Find Previous from the Traffic menu or Shift+F3 to select the previous event or message that meets the conditions.


Opening Log Files

From the Start Up Screen

  1. Click Post Capture to display the Open dialog box.

  2. Select the file you want to open. Click OK.

From Monitor

  1. From Monitor (click [image] if Monitor view is not displayed) click [image] to display the Open dialog box.

  2. Select the file you want to open. Click OK.

In Real Time mode ( [image]), only a single Real Time file is available. In Post Capture mode ( [image]), multiple log files can be open simultaneously.


Display Settings

You can use a variety of display settings to customize the way events and messages are displayed. Detail settings and columns can all be used to customize the way information is displayed. A user's custom settings do not affect the custom settings of another user.

Customized settings are retained when WPA is installed using the Repair option. However, if WPA is installed using the Remove option, all customized settings will be lost. (Customized settings cannot be retained when installing a version of WPA that is earlier than the version currently installed.)


Change Timestamp Format

  1. Right-click the Traffic overview to display the pop-up menu.

  2. Select Timestamp Format.

  3. Select the format you require from the list shown.

A tick ( [image]) to the left of a timestamp format indicates the format that is in use.


Compare Two Different Messages in the Same File

  1. From the Traffic menu on the Traffic Overview screen check that there is no tick ( [image]) to the left of the Synchronize Views option. If there is a tick ( [image]), indicating that synchronization is on, click the option to turn it off.

  2. Click [image] to open a second Traffic Overview.

You can now decode a message from each window.


Display the Same Message in Different Views

  1. From the Traffic Overview screen, click the Traffic menu, select the Synchronize Views option.

  2. Click [image] to open a second Traffic Overview.

  3. Click a message in one view and the same message will be highlighted in the other Traffic Overview.

If the message has been filtered out of the other Traffic Overview the nearest message will be highlighted.


Summary View

The Summary View of the messages logged in the traffic overview contains the following information:

  • Date

  • PC Start Time

  • PC End Time

  • Duration - When the duration is greater than 1000 seconds, the duration is displayed in minutes and seconds. Otherwise, the duration is displayed in seconds.

  • Total number of messages - the number of messages generated by the 8960

  • Number of messages logged - the number of messages captured by the WPA

  • Number of messages dropped - the number of messages generated by the 8960 that were not captured by WPA

  • Percentage of messages dropped

To Display Summary View:

You can display Summary View by clicking on the Summary View button ( [image]). The Summary View will be displayed to the right of the messages in the traffic overview.

Considerations:

    • If you display the Summary View in Real Time mode before completing a message capture, the Summary View displays "No Summary Data Available".

Traffic Overview indicates there are dropped messages

If there are dropped messages for any reason, the WPA will indicate this in a line within the traffic overview message log (this single line can represent multiple dropped messages). The number of dropped messages is listed in the Summary View.


Rearrange Windows

Select Tile Horizontally from the Window menu to display the windows so that they do not overlap on the screen.

Alternatively you can select Cascade to display the windows in an overlapped fashion.

In the Monitor view, windows are tiled automatically when a new view or window is created.


Displaying Columns

Display Columns

You can customize which columns are displayed, the order in which they are displayed, and the width of the column. Click the links below for more information.

Move Columns

Resize Columns

Show/Hide Columns

Traffic Overview Columns

Protocol Field Columns

Decode View Columns

Related Topic: Display Settings


Move Columns

You can move the columns in Traffic Overview or Decode view.

  1. Select the column heading of the column you want to move.

  2. Hold the mouse button down on the heading and drag the heading to its new location.

Protocol field columns can not be positioned before any of the general columns, which are detailed in Traffic Overview Columns.


Resize Columns

You can change the columns in Traffic Overview or Decode view.

  1. Select the column whose width you want to adjust.

  2. Drag the border at the right of the column heading until the column is the width you want.

Double-click the border to the right of the column heading to make the width fit the contents of the column.


Show/Hide Columns

You can change the columns in Traffic Overview or Decode view.

  1. Right-click on the view to display the pop-up menu.

  2. Select Columns from the pop-up menu.

  3. Select the columns you want to show. Clear the checks from the columns you want to hide.


Protocol Field Columns

Selecting the Column Setup feature in the Traffic Overview allows you to display many of the fields and parameters belonging to certain protocol stacks as columns. Otherwise, this data is only available in the decode view. You can use this to quickly identify messages with particular parameters or field values and can be very useful for troubleshooting.

  • Configuring Traffic Overview Protocol Field Columns

  • Add New Protocol Field Columns

  • Remove a Protocol Field Column

  • Save the Current Protocol Field Columns Settings

  • Load Protocol Field Columns Settings

Configuring Traffic Overview Protocol Field Columns

  1. Right-click on the Traffic Overview view to display a shortcut menu, or select Traffic Overview Settings from the Traffic menu.

  2. Select Column Setup... from the menu.

  3. The Traffic Overview Protocol Field Columns dialog box appears.

  4. In the list on the left, select the protocol fields that should appear as columns. Clear the check boxes for the protocol fields you do not want as columns. You can also select all of the protocol fields in the list or clear the check boxes for all the protocol fields in the list by clicking Select All or Select None respectively.

Add New Protocol Field Columns

You can add protocol fields to the list on the left of the Traffic Overview Protocol Field Columns dialog box.

  1. Select the field from the Available Protocol Field Columns area on the right.

  2. Click Add.

The protocol field appears in the list on the left and is selected as a column to be shown.

indicates a protocol field that is always listed. The field appears in the Traffic Overview under the column name indicated in parenthesis.

Remove a Protocol Field Column

You can remove protocol fields from the list on the left of the Traffic Overview Protocol Field Columns dialog box.

  1. Click on the protocol field in the list that you want to remove.

  2. Click Remove.

The protocol field is removed from the list.

Save the Current Protocol Field Columns Settings

You can save your current protocol field columns settings to a file. You may want to import these settings into the Traffic Overview Protocol Field Columns dialog box at a later time.

  1. Click Save. The Select file to save columns to dialog box appears.

  2. Select the directory where you want to save your file.

  3. Type a file name and click on Save or press Enter.

Load Protocol Field Columns Settings

You can load protocol field columns settings into the Traffic Overview Protocol Field Columns dialog box from a saved file.

  1. Click Load. The Select file to load columns from dialog box appears.

  2. Select the directory where your file is located.

  3. Select the Column Settings (.kcs) file you want to use as your columns settings.

  4. Click on Open or press Enter.


Copying

You can copy messages and decodes and paste them into other applications.

The copying methods available from Traffic Overview and Decode views are:

Copy Messages

Copy Decodes


Printing

You can print messages and decodes. Printing methods available from Traffic Overview and Decode view are:

Print a Range of Messages

Print Decodes

Print Messages


Print a Range of Messages

  1. Click the Traffic Overview containing the messages you want to print.

  2. Select the messages.

    All Messages

    Click on any message and press CTRL+A.

    Range of Adjacent Messages

    Click the first message in the range (as in Step 2 above), and then hold down SHIFT and click the last message in the range. You can scroll to make the last message visible.

    Range of Non-Adjacent Messages

    Click the first message in the range (as in Step 2 above), and then hold down CTRL and click each message in the range. You can scroll to make the last message visible.

  3. Select Print from the File menu to display the Print dialog box.

  4. (OPTIONAL) Change the print settings.

  5. Click OK to print.


Print Decodes

  1. Click [image] to display the Decode view.

  2. Click the message in Traffic Overview for the message decode you want to copy. This selects it.

  3. (OPTIONAL) Select multiple messages.

    All Message Decodes

    Click on any message and press CTRL+A.

    Range of Adjacent Message Decodes

    Click the first message in the range (as in Step 2 above), and then hold down SHIFT and click the last message in the range. You can scroll to make the last message visible.

    Range of Non-Adjacent Message Decodes

    Click the first message in the range (as in Step 2 above), and then hold down CTRL and click each message in the range. You can scroll to make the last message visible.

  4. Right-click the Decode view and select Print from the pop-up menu.


Print Messages

  1. Click the Traffic Overview you want to print.

  2. Select Print from the File menu to display the Print dialog box.

  3. (OPTIONAL) Change the print settings.

  4. Click OK to print.


Saving

Logged data can be saved in a variety of ways:

  • Saving Data

  • Save Decodes to a Text File

  • Save a Range of Messages

  • Save Decodes to a CSV File


Saving data

The changes to log files can be saved either by:

  • Clicking [image] to overwrite the existing file.

  • Saving the data displayed in Traffic Overview to a different file.

Saving to a Different File

  1. Select Save data to new log file from the File menu to display the dialog box.

  2. There will be a tab for each Traffic Overview window. Select the settings for the data you want to save from each view.

  3. Click Save to save data.


Save Decodes to a Text File

  1. Click [image] to display the Decode view.

  2. Click the message in Traffic Overview to select it.

  3. (OPTIONAL) Select multiple messages.

    All Messages

    Click on any message and press CTRL+A.

    Range of Adjacent Messages

    Click the first message in the range (as in Step 2 above), and then hold down SHIFT and click the last message in the range. You can scroll to make the last message visible.

    Range of Non-Adjacent Messages

    Click the first message in the range (as in Step 2 above), and then hold down CTRL and click each message in the range. You can scroll to make the last message visible.

  4. Right-click in the Decode view and select Save to Text File... from the pop-up menu.

  5. The Select file for saving the X message(s) to (where X is the number of selected messages) dialog box appears. Choose a location and enter a filename for the text

Example Text File Output

The following is an example of a text file output after using the above procedure to save the decodes in a W-CDMA .tol file to a text file. In this example, the Decode View Binary column is shown and Decimal is hidden (see Show/Hide Columns).

Octet Binary Hex Description

Message 1 of 329 on WCDMALink (Test Set 1) at Thursday, June 29, 2006 11:49:28.000000; Size 38 Octets

1 10100001 a1 System Time=3745(dec)

2 00001110 0e

3 00000000 00

4 00000000 00

5 ---01010 0a Protocol=MAC

6 00------ 00 System Type=FDD

--00---- Multiplex Used=FALSE

----00-- SHCCH Only=FALSE

------00 DTCH/DCCH on DSCH/USCH only=FALSE

7 0000---- 00 Transport Channel=BCH

----0000 Logical Channel=BCCH

8 11101010 ea data=ea

9 01001110 4e data=4e

10 00100011 23 data=23

11 01101100 6c data=6c

12 00000000 00 data=0

13 00000000 00 data=0

14 00000000 00 data=0

15 00000100 04 data=4

16 01000000 40 data=40

17 11101000 e8 data=e8

18 01000000 40 data=40

19 00111000 38 data=38

20 00000000 00 data=0

21 00000000 00 data=0

22 00101001 29 data=29

23 11111111 ff data=ff

24 11111111 ff data=ff

25 11111001 f9 data=f9

26 11000100 c4 data=c4

27 00000000 00 data=0

28 00000000 00 data=0

29 00000000 00 data=0

30 00000000 00 data=0

31 00000000 00 data=0

32 00000000 00 data=0

33 00000000 00 data=0

34 00000000 00 data=0

35 00000000 00 data=0

36 00000000 00 data=0

37 00000000 00 data=0

38 00000000 00 data=0


Save a Range of Messages

  1. Click the Traffic Overview containing the messages you want to save.

  2. Select the messages.

    All Messages

    Click on any message and press CTRL+A.

    Range of Adjacent Messages

    Click the first message in the range (as in Step 2 above), and then hold down SHIFT and click the last message in the range. You can scroll to make the last message visible.

    Range of Non-Adjacent Messages

    Click the first message in the range (as in Step 2 above), and then hold down CTRL and click each message in the range. You can scroll to make the last message visible.

  3. Select Save from the File menu to display the Save dialog box.

  4. Click OK to save.


Save Decodes to a CSV File

Logged data can be saved in a file as a comma-separated string of values for spreadsheet applications. There are two options for saving to a CSV file:

  • Real time CSV Logging

  • Save to CSV Log File

To save decodes to a CSV file:

  1. Stop logging.

  2. Right-click in the Traffic Overview window.

  3. Select Save to CSV Log File.

  4. Enter the file name and path.

To enable real time CSV logging:

  1. Stop logging.

  2. Right-click in the Traffic Overview window.

  3. Select the Enable CSV Logging check box.

  4. Enter the file name and path.

  5. Start logging


Copy Decodes

You can copy message decodes into other applications. However, you can not copy portions of the decode for a message. Only the entire decode for a message or the complete decodes for multiple messages can be copied from the Wireless Protocol Advisor (WPA).

The following procedure details how to copy message decodes.

  1. Click [image] to display the Decode view.

  2. Click the message in Traffic Overview for the message decode you want to copy. This selects it.

  3. (OPTIONAL) You can also select to copy the decodes for more than one message using the appropriate procedure below.

    All Message Decodes

    Click on any message and press CTRL+A.

    Range of Adjacent Message Decodes

    Click the first message in the range (as in Step 2 above), and then hold down SHIFT and click the last message in the range. You can scroll to make the last message visible.

    Range of Non-Adjacent Message Decodes

    Click the first message in the range (as in Step 2 above), and then hold down CTRL and click each message in the range. You can scroll to make the last message visible.

  4. Right-click in the Decode view and select Copy from the pop-up menu.

  5. Follow the Paste instructions for the application you want to paste into.

You can paste decodes into other applications, such as MS Notepad.


Copy Messages

  1. Click the message to select it.

  2. (OPTIONAL) Select multiple messages.

    All Messages

    Click on any message and press [CTRL]+[A].

    Range of Adjacent Messages

    Click the first message in the range (as in Step 2 above), and then hold down [SHIFT] and click the last message in the range. You can scroll to make the last message visible.

    Range of Non-Adjacent Messages

    Click the first message in the range (as in Step 2 above), and then hold down [CTRL] and click each message in the range. You can scroll to make the last message visible.

  3. Right-click the selection and select Copy from the pop-up menu.

  4. Follow the Paste instructions for the application you want to paste into.

You can paste messages into other applications, such as MS Notepad.


Use Connection Trace

You can use Connection Trace to group messages by connection.

  • Purpose of Connection Trace

  • How Connection Trace Works


Connection Phase Colors

The Connection Phase Colors tab is used to assign colors to connection trace (see Purpose of Connection Trace) phase indicators .

To assign a connection trace phase color:

  1. Open a Connection Trace view.

  2. Right click in the Connection Trace window and select Configuration.

  3. Click the Conn. Phase Colors tab.

  4. Click any of the Phase buttons.

  5. Select a color.

  6. Click OK.


Opening a Connection Trace View

Select the Add a Connection Trace View icon ( [image] or [image] ) for the test set you wish to add a connection trace to. A Connection Trace Configuration window will appear.

To configure the Connection Trace view, see Configuring Connection Trace.

The Connection Trace view is similar to the Traffic Overview, with the information arranged in a table with each row representing a connection and each column selected from a list of choices. Right clicking within the Connection Trace view will bring up a dialog box that includes a Columns and Column Setup menu.

A Summary View of the Connection Trace view can also be displayed by right clicking in the Connection Trace view. The Summary View displays a running count of:

  • Total Calls

  • Active Calls

  • Terminated Calls

Connection Trace Summary View


Configuring Connection Trace

Configuring a Connection Trace

You can configure a connection trace for each test set that is connected to WPA. When the either Connection Trace View icon, [image] or [image], is selected the corresponding Connection Trace Configuration window appears. The following figure shows the connection trace configuration window for test set 1.

This window has two main elements:

  1. Profile - A drop down menu displays the current protocol specification. The profile defines the model that WPA will use to track a connection's state and phase transitions.

The current choice(s) are:

    • TCP. This profile is based on the protocol specification RFC793.

  2. Tabs - Four tabs are also displayed:

  • Connection Selection - used to configure the connection

  • Connection Warnings - used to configure connection status and duration warnings

  • Connection Phase Colors - used to select colors for the graphic phase indicators.

  • Logging - used to select the connection trace information saved to CSV (comma-separated value) files.


Grouping Messages by Connection

The Connection Trace feature provides the capability to isolate messages in the Traffic Overview window that pertain to a given connection (see Purpose of Connection Trace).

To Group Messages:

With the WPA in Post Capture mode, or in Real Time mode with the logging status idle:

  1. Open the Connection Trace View (see Opening a Connection Trace View)

  2. Double-click one of the connections in the Connection Trace view. If there are no connections displayed, check the Traffic Overview window to make sure that filter and trigger settings allowed messages that fit the current Connection Trace Profile (see Configuring Connection Trace) to be logged.

  3. If you want to select a message from the Traffic Overview window and group all messages associated with its connection, click on the message and click on the Group icon [image], or, right-click on the message and select Connection from the menu.

To Ungroup Messages

  1. Click on the Group icon [image].

See also: Configuring a Connection Trace.


Connection Selection

The Connection Selection tab is used to restrict the number of connections (see Purpose of Connection Trace) by specifying only those addresses or ports that are of interest.

To specify a DUT or Network address:

  1. Open a Connection Trace view.

  2. Right click in the Connection Trace window and select Configuration.

  3. Click the Conn. Selection tab.

  4. Select network or DUT address.

  5. Click Add Value.

  6. Enter an IP address and click OK.

To specify a DUT or Network port:

  1. Open a Connection Trace view.

  2. Right click in the Connection Trace window and select Configuration.

  3. Click the Conn. Selection tab.

  4. Select network or DUT port.

  5. Click the check boxes for ports that are of interest.

  6. Click OK.


Connection Warnings

The Connection Warnings tab is used to assign colors to connection trace (see Purpose of Connection Trace) warning indicators .

To assign an Under Duration or Over Duration time limit and color (duration is the time between the first event of a connection and the last event):

  1. Open a Connection Trace view.

  2. Right click in the Connection Trace window and select Configuration.

  3. Click the Conn. Warnings tab.

  4. Select the Under Duration or Over Duration check box.

  5. Use the up/down arrows to select a time value.

  6. Click the Over Duration or Under Duration button.

  7. Select a color

  8. Click OK


Externally Connect Two Test Sets

To support synchronized dual source logging, the test sets must be externally connected via a LAN network. Once you've established this connection, you can test supported end-to-end services between two wireless devices (such as W-CDMA end-to-end video calls when you've connected two 8960s). Also when you've connected two 8960s you can test cell transitions, such as handovers and cell selections/re-selections, by expanding this configuration to mimic a two-cell test system.

You can establish an External Device Connection while your 8960 is in any operating mode. However, most end-to-end services utilizing the External Device Connection feature require active cell mode operation.

When connecting two 8960s, it is recommended that you connect them via a hub, rather than through a gateway or WAN link, or connect them directly using a LAN crossover cable. This helps minimize the risk of lost data due to delayed packets.

External Device Connection Setup for Two 8960s

External 8960 Connection Setup

  • External 8960 IP Address

Before establishing a connection with another 8960, you must first specify its IP address.

Ext 8960 IP Addr can not be set to the same value as LAN IP Address or DUT IP Address . If LAN IP Address is set to the value of Ext 8960 IP Addr , Ext 8960 IP Addr is reset to a blank field.

GPIB command: SYSTem:COMMunicate:LAN:EXTernal:ADDRess

  • Connect to External 8960

This action establishes a TCP/IP connection with the 8960 at the address specified by External 8960 IP Address .

If the External Device Connection Status is Connected , then this action is ignored by the test set.

GPIB command: SYSTem:COMMunicate:LAN:EXTernal:CONNect

  • Disconnect from External 8960

This action disconnects the TCP/IP connection with the connected external 8960.

If the External Device Connection Status is Disconnected , then this action is ignored by the test set.

GPIB command: SYSTem:COMMunicate:LAN:EXTernal:DCONnect

  • External Device Connection Status

The External Device Connection Status is displayed in the LAN Connection Information window of both 8960 tests sets, regardless of which 8960 initiated the connection. The possible states of the external device connection are: Not Connected , Connecting , Connected and Disconnecting .

GPIB command: SYSTem:STATus:COMMunicate:LAN:EXTernal[:CONNected][:STATe]

  • Connected Device IP Address

Once a connection has been established between the two 8960s, the IP address of each 8960 is displayed in the other 8960's LAN Connection Information window.

GPIB command: SYSTem:STATus:COMMunicate:LAN:EXTernal[:CONNected]:ADDRess

  • LAN (Self) IP Address

For your convenience, the IP address of the 8960 is shown in its LAN Connection Information window. This is a duplicate display of its LAN IP Address setting, which you set from the Instrument Setup ( F1 ) menu on its System Config screen, or using the SYSTem:COMMunicate:LAN[:SELF]:ADDRess command.

Other Considerations

The external device connection is not affected by a partial preset. However, the external device connection is disconnected as a result of a full preset.

Before initiating an external device connection between two 8960s, you can verify that the two test sets are able to communicate by pinging one test set from the other. To do so, on 8960 #1:

  • Press the Call Setup key, then the left More key until the Ping menu is available.

  • Select Ping , then Ping Setup ( F1 ).

  • Set Device to Ping to Alternate ( CALL:DATA:PING:SETup:DEVice ).

  • Set the Alternate Ping Address to the IP address of 8960 #2 ( CALL:DATA:PING:SETup:ALTernate:IP:ADDRess ).

  • Select Start Ping ( F3 ) ( CALL:DATA:PING:STARt ).

Please refer to the reference guide for your specific application for more information. The 8960 online user's guides are located at http://wireless.agilent.com/rfcomms/refdocs/.


Learn About ...

The topics in this section provide information about the features of the Wireless Protocol Advisor (WPA).

For more information, choose a topic below:

Learn about Capturing

Learn about Triggers and Filters

Learn about the Measurement Setup View

Learn about Analyzing Messages

Learn about Connection Trace

Synchronization of Messages from Multiple Test Sets

Post Capture Mode


Learn about Triggers and Filters

Triggers and Filters are used to control which events and messages are captured and displayed. You can have any mixture of triggers and filters. The filter and trigger setup dialog boxes identify which test set the settings apply to in the title of the dialog box. Log filters and triggers are set independently for each test set connected. However, since the view filter operates on the contents of the traffic overview, there is only one view filter. The default trigger and filter settings capture and display every message received from the test set when [image] is clicked. (These are the messages passed through the test set filter.)

There are two parts to triggers and filters:

  • Criteria - define what happens when the conditions are met. Criteria are set in the upper half of the dialog box. Multiple triggers or filters are 'OR'ed, that is, ALL CONDITIONS in ALL TABS for ANY ONE (trigger or filter) will activate the trigger or pass through the filter.

  • Conditions - define the event or message that will activate the trigger or pass through the filter. Conditions are set up in the lower half of the dialog box. In a single trigger or filter the conditions are 'AND'ed, that is, ALL CONDITIONS in ALL TABS must be met to activate the trigger or pass through the filter.

It is not possible to apply different triggers events on different test sets. That is, when a trigger is reached on one test set, that trigger event is applied to all the test sets. Furthermore, the setting to capture a specific number of messages before the start trigger or after the stop trigger applies to the total number of messages logged by both sources -not the number logged only by the test set that initiated the trigger.


Conditions

Trigger and Filter Conditions are defined in the lower half of Trigger and Filter Editors under tabs. They define the messages that will activate the Trigger or Filter.

There are several types of Trigger and Filter Conditions:

  • Event - reserved for future use.

  • Message Match - defines messages based on Protocol Stacks and Protocols, for example, Message Types, Calling Party Number, Destination Point Codes, and so on.

  • Time - defines messages based on the Time they were received.

  • Text Search - searches decoded text for a string value. You can restrict the search by using whole word, matching case, and/or regular expression. The arrow button to the right of the entry field contains common expressions that you can use to build regular expression strings in the entry field. The Text Search in the trigger editor allows you to set the trigger based on a test string found in the message decode.

  • Trigger Counts - (Real Time Triggers only) defines the occurrence of the trigger conditions that will activate the trigger, for example, if you set the trigger to be activated on the fourth occurrence, the first three times will be ignored.

  • Source - (View Filter only) determines which test set messages are displayed in the traffic view.


Critieria

Criteria

Trigger and Filter Criteria are defined in the top half of Trigger and Filter Editors. They define what action is to be taken when the Trigger or Filter Conditions are met.

  • Start Triggers - automatically starts capturing when the Wireless Protocol Advisor detects an event or message that meets the conditions. Using Criteria you can capture before the event or message that activates the trigger. You can capture a number of messages or for a period of time before the Start Trigger.

  • Stop Triggers - automatically stops capturing when the Wireless Protocol Advisor detects an event or message that meets the conditions. Using Criteria you can capture after the event or message that activates the trigger. You can capture a number of messages or for a period of time after the Stop Trigger.

  • Logging Filters - restricts which links, events and messages are captured.

  • View Filters - restricts which captured events and messages are displayed in Traffic Overview.

  • Find - finds events and messages in Traffic Overview. Once the filter conditions are defined you can Find Next and Find Previous to highlight the next event or message that meets the conditions.


Learn About Connection Trace

This chapter includes:

  • How Connection Trace Works

  • Purpose of Connection Trace


Connection Trace

Connection Trace is a feature of the WPA (Wireless Protocol Advisor) that mirrors the behavior of a network connection within the WPA for the purpose of tracking and performing measurements on connections.

You can set up a connection trace for each connected test set. You can add a connection trace by clicking on the Add a Connection Trace view for Test Set 1 or Add a Connection Trace view for Test Set 2 icon. You can also add a new Connection Trace by clicking View>>New Connection Trace View (1) or New Connection Trace View (2). The tool bar icon(s) and menu options to create a connection trace view are grayed out and not accessible unless the test set is connected.

When you add a connection trace, a configuration window for the corresponding test set is displayed. The profile supported is TCP (no other profile is supported at this time), also known as RFC 793 - Transmission Control Protocol.

When a Connection Trace view is selected, the WPA will display a text box for the corresponding test set for entering connection information (see Configuring Connection Trace). By specifying end point ports and addresses, Connection Trace can be restricted to display only those messages that pertain to the select criterion. If end point ports and addresses are not furnished to WPA, Connection Trace will display all connections.

During a logging session, the WPA displays the phases of each TCP connection using one FSM (Finite State Machine) per connection. The modeling performed by each FSM is based on specifications from RFC 793.

There are six phases possible during a connection:

  • Establishing - One side (DUT or network) has attempted to set up a connection.

  • Established - A TCP connection has been established.

  • Reset - Either party has reset the connection

  • Closing - One of the parties has closed their transmit part of the connection.

  • Time Wait - Both sides waiting for any remaining messages.

  • Closed - The connection has been terminated.

These phases are displayed as colored bars in the Phase Graphics column (see Connection Phase Colors).

Data throughput counters are also maintained during each connection. These counters display the total bytes transferred and the throughput rate in bps (bits per second) at both the TCP and IP protocol layers.

Double-clicking a connection groups the messages from that connection in the Traffic Overview window (see Purpose of Connection Trace).


Purpose of Connection Trace

The Purpose of Connection Trace

During a logging session, the DUT (Device Under Test) may communicate with one or more machines using one or more protocol ports per machine. Each of these communication links represent a connection, and the number of connections that can appear during a logging session depends on the nature of the network traffic.

Without a Connection Trace view selected the Traffic Overview window will display all logged messages for all connections within the scope of filter settings. Isolating only those messages that pertain to a single connection would require a filter setup for each connection.

Connection Trace solves this problem by providing the Connection Trace view. This view lists each connection that is part of a connection profile and is within the scope of endpoint addresses and protocol ports, if specified. When a connection is selected in the Connection Trace view, messages associated with that connection will be grouped together in the Traffic Overview window.

In the Connection Trace view, each connection is assigned a Connection Identity number. Along with the Connection Identity number the Connection Trace view displays selected information such as:

  • Duration - the elapsed time of the connection.

  • Status - has the connection been terminated?

  • Phase Graphics - a graphic representation of each connection's phase progression.

  • Data throughput - IP data and bps (bits per second)

A Summary View of the Connection Trace view can also be displayed. The Summary View displays a running count of:

  • Total Connections

  • Active Connections

  • Terminated Connections


Learn about the Measurement Setup View

Measurement Setup view graphically represents all the applications and views being used in Real Time mode ( [image]), or by the selected log file in Post Capture mode ( [image]).

The Measurement Setup view is displayed from Monitor by clicking [image] or by selecting Measurement Setup View from the View menu.

Measurement Setup view shows the flow of messages.


Real Time Measurement Setup

In Real Time mode, the Measurement Setup view shows the elements that have been set up for capturing messages exchanged between the test set and the device under test. To put the Wireless Protocol Advisor (WPA) into Real Time mode click [image] in Monitor. To add additional Traffic Overviews and set up any associated filters, click the button and select the relevant options.

In Real Time Measurement Setup you can:

  • Go to Configuration and edit the settings.

  • Define which messages and events should be captured.

  • Define how the data should be analyzed and viewed.

  • Copy and paste Trigger and Filter settings.

  • Import an existing measurement setup (containing configuration and measurement settings).

Measurement Setup view is the only view where you can define which messages and events should be captured. Triggers and all the filters to the left of the Log File icon define which messages are captured.

To improve capture performance close unnecessary views, especially Traffic Overviews. These can be added later during Post Capture analysis. The decode view should also be closed to improve performance.


Post Capture Measurement Setup

In Post Capture mode, the settings used during the file's capture are shown in the Capture Details box. These settings cannot be changed in Post Capture. To put the Wireless Protocol Advisor into Post Capture mode click [image] in Monitor.

In Post Capture Measurement Setup you can:

  • View the Configuration settings used during the capture.

  • Edit part of the Configuration.

  • View any triggers and logging filters.

  • Add view filters to the Traffic Overviews.

  • Use find filters in the Traffic Overviews.

The test set filter settings used during the capture are not available in Post Capture mode.


Learn About Analyzing Messages

The basic view used to display signaling is the Traffic Overview window. The Traffic Overview window can be split into two. The upper pane displays the Traffic Overview and the lower pane displays the detailed Decode view.

Traffic Overview

For each message, the Traffic Overview displays the link, direction, timestamp and description. As messages are captured they scroll up the Traffic Overview.

You have the option to Display invalid messages in Traffic Overview using error color or Display gridlines in Traffic Overview and Connection Trace View.

The status bar indicates the connection status of both test sets, as well if there were any dropped messages.

Traffic Overviews are added by clicking [image] or by selecting New Traffic Overview from the View menu.

Decode View

The Decode view is displayed in the bottom half of the Traffic Overview. It shows the decoded information for the message highlighted in the Traffic Overview. The decodes are automatically determined from the protocol associated with that link.

The Decode view shows MTAL messages in blue, message contents in green, and decode errors in red.

The current message is decoded by clicking [image], by selecting Decode View from the Traffic menu, or by double-clicking the message.

Capturing from many links and analyzing the data through many views may affect the performance. Here are some tips:

  • Use the Test Set Filter to minimize the number of messages sent over the LAN connection.

  • Minimize Traffic Overviews.

  • Use Logging Filters to restrict the data captured.


Changing the Level of Detail Displayed

The amount of detail displayed on the Traffic Overview can be changed by creating and applying a View Filter.


Decode View Columns

Columns can be hidden by right-clicking on the view and selecting the columns you want.

  • Octet View - the octet number of this part of the message.

  • D ecimal - the decimal format of the binary data for that octet.

  • Octet Data - a horizontal display of all raw binary message bits separated into octets and includes the ASCII data for each octet.

  • Type - Mandatory (M), Optional (O), Fixed (F) or Variable (V).

  • Binary - the binary data which makes up the octet. Most Significant Bit (MSB) is to the left and Least Significant Bit (LSB) is to the right.

  • Hex - the hexadecimal format of the binary data for that octet.

  • Description - the information contained in the octet.

You can also change the width and order of columns.

Information

Field per Line detailed decodes may sometimes show octets in repeated order. This is may be due to:

  • Fields not using consecutive bits across an octet boundary.

  • An octet going across a layer boundary. In this case new layer will repeat bits on previous layer and mark as 'Spare'.

Related Topic: Decode Messages


Filtering Messages

View Filters restrict the messages displayed in the Traffic Overview. Only messages which meet the specified filter criteria are shown in Traffic Overview. You set up View Filters by selecting the Traffic Overview and defining the filter criteria by selecting View Filter from the Traffic menu.


Finding Messages

If you select Find from the Traffic menu you can use the Filter Editor dialog box to set up the messages you want to find. You can jump to the next (or previous) message that meets the Find criteria.


Timestamps

The Wireless Protocol Advisor displays a timestamp for each message.

This information originates from the test set and indicates the time of day that a message was relayed to the WPA software. Timestamps do not account for time delays that occur between the DUT (Device Under Test) actually sending/receiving messages and the test set relaying these messages to the WPA software.

You can change the displayed timestamp format from Traffic menu by selecting Traffic Overview Settings and then Timestamp Format.

There are three timestamp formats:

  • Relative - shows the time difference between each message and the selected message when the Relative Timestamp format was chosen.

  • Absolute (Date) - shows the date and time the message was captured.

  • Absolute (No Date) - shows the time the message was captured.


Traffic Overview Columns

Traffic Overview General Columns

There are several columns in the traffic overview that provide general information about a particular message. These general columns are listed below. Not all of these columns are displayed using the default settings, but they can be easily added and moved according to your needs. Protocol field columns, which are useful for troubleshooting purposes, are also very easy to include in the traffic overview.

  • Num - the sequential number of the message within the file.

  • Size - indicates the size of the message in Octets.

  • Direction (text) - text indicates the direction the message was sent.

  • Direction (arrow) - arrow indicates the direction the message was sent.

  • Timestamp - the time the message was recorded or the time period relative to another message.

  • Repeat Count - the number of concurrent short messages.

  • Event Type - indicates type of event that generated the protocol message. The type of events this column indicate include: Rx, Start Trigger, and Stop Trigger.

  • Data Source - indicates which test set (Test Set 1 or Test Set 2) sent the protocol message.


Post Capture Mode

The Post Capture mode provided in the Wireless Protocol Advisor (WPA) allows you to view any existing protocol log file (that is, any *.tol or *.dtl file), configure the traffic and decode views for your preferences, configure and save view filters and search, as well as save and print the protocol logs. You may also view any of the measurement setup settings that were used for the log at the time it was captured.

How to open the Wireless Protocol Advisor in Post Capture mode

To activate Post Capture mode:

    1. Click on the Windows© Start menu and locate Wireless Protocol Advisor in the Programs menu.

    2. Select Wireless Protocol Advisor.

    3. Click Post Capture on the WPA startup screen to open the WPA in demonstration mode.

    4. Select any log file from the Select Log File window.

    5. Click Open.

Restrictions while operating in Post Capture mode

  • In Post Capture mode, the Wireless Protocol Advisor is not able to connect to the test set(s). Therefore, real time logs can not be captured.


Learn about Capturing

Learn about Capturing Messages

Once the Wireless Protocol Advisor is connected to your test set and configured you only have to click the Start/Stop messages button in the Traffic Overview screen to capture messages between the test set and the Device Under Test.

When Monitoring

The Wireless Protocol Advisor captures everything from the test set unless you set up restrictions. The Wireless Protocol Advisor can start and stop capturing automatically based on the Trigger settings you set. You can also restrict which events and messages are captured by setting logging filters.

Triggers and Logging Filters are set up in Measurement Setup view. Each setup is stored in the log file (*.tol) along with the captured network traffic. The Measurement Setup information can also be exported and used again for future captures.


Synchronization of Messages from Multiple Test Sets

WPA is capable of simultaneously capturing protocol messages from up to two 8960s (dual source logging). Synchronized dual source logging allows WPA to capture messages from two Test Sets and display the messages in the Traffic Overview in the order in which they were generated by the test set, with their message timestamps synchronized to each other.

Synchronization functionality may have a performance impact on logging and may cause a delay in the appearance of messages in the Traffic Overview.

Messages that cannot be synchronized are red. Messages that cannot be synchronized are caused when synchronization of messages is in progress, but a message arrives whose timestamp is out of synch enough that the WPA cannot insert the message into the correct location in the Traffic Overview.

How to Synchronize Messages from Multiple Test Sets

Synchronization of the messages simultaneously logged by two test sets only occurs when all of the following conditions are met:

  1. WPA must be connected to both test sets (as shown in System Configuration).

  2. The active application on each test set must support the synchronized dual source functionality.

    A warning is displayed in the WPA for each test set running an application that does not support synchronized dual source logging. (This warning can be disabled in the same location as you can enable the synchronization of test set message logging.)

  3. The two test sets must be externally connected (see Externally Connect Two Test Sets).

  4. The 'Enable Synchronization of Test Set Message Logging' must be selected in the WPA.

    You can enable synchronized dual source logging from the Configuration screen (click the Configuration icon or select Tools >> Configuration). From the Configuration screen, selece Tools>>Options. This displays the 'Configuration Options' dialog box where you can click the box to 'Enable Synchronization of Test Set Message Logging' as shown in the figure below.

    The low end of the Synchronization Threshold setting (toward Optimize Logging) minimizes the maximum number of logged messages that are sorted to accommodate LAN Latency and other causes of unsynchronized messages (i.e. when messages arriving from synchronized Test Sets are many seconds off). The upper limit of the slider (toward Optimize Synchronization) shall sort the maximum number of logged messages required to achieve synchronization (1500 messages) at the expense of logging efficiency.

The higher the synchronization threshold the larger the message buffer size that must be sorted. This buffer is filled before messages are displayed in the traffic overview screen. The following message is displayed when protocol messages are being captured, but messages are not yet displayed.

This message dissapears once messages start appearing in the log or logging has stopped.


Remote Operation with the API (Application Programming Interface)

The WPA (Wireless Protocol Analyzer) contains an Application Programming Interface (API), which allows programmatic control of WPA's protocol logging capability. A typical application of this API would be a program that exercises the device you are testing while controlling the WPA to log and save the protocol messages.

You can use the API when the WPA software is running and the WPA splash screen is displayed (before the operation mode has been selected).

You can use the API to control the WPA with a user program. This program could be written in many different programming languages such as C/C++, Visual Basic, Perl, or Python. Click here for a WPA Sample API Program in Perl.

The functions available in the API are described in WPA API Function Descriptions.

Note: Many of the WPA API functions are Non-Blocking Functions. When using non-blocking functions, it is suggested that the calling program enter a wait state for several seconds after making the function call, then request confirmation that the function has completed.

API information in this topic includes:

  • Non-Blocking Functions

  • Error Codes

  • Required Files

Non-Blocking Functions

Many of the WPA API functions are non-blocking. When a function is non-blocking, the WPA Application may continue to process the API function after returning the API function result to the calling program. For the non-blocking API functions, the return status simply indicates whether WPA was able to begin processing the requested functionality. If a WPA API function is non-blocking, it is indicated in function description (see WPA API Function Descriptions). Otherwise, if it is not indicated, the function is a blocking function. When using non-blocking functions, it is suggested that the calling program enter a wait state for several seconds after making the function call, then request confirmation that the function has completed.

Example Program:

#define MAX_ITERATIONS 100

int status = WPA_StartLogging(); // ‘status’ will indicate whether WPA was able to

// begin processing the Start Logging request

int i = 0;

// If WPA was able to begin processing the Start Logging request, wait until

// WPA has completed that request and put WPA into the Active Logging state

if (status == WPA_SUCCESS)

{

Sleep(2);

status = WPA_QueryLoggingState();

while ( (status != WPA_STATE_ACTIVE)

&& (status > 0) // Less than 0 indicates an error

&& (i++ < MAX_ITERATIONS))

{

// WPA is not yet in the Active Logging state, wait two seconds then

// check the state again

Sleep(2);

status = WPA_QueryLoggingState();

}

}

Error Codes

The following are the WPA Error Codes:

Function | Value | Description
WPA_SUCCESS | 0 | API function call successfully received (may not have completed yet)
WPA_TIMEOUT | -1 | Timeout occurred during operation
WPA_ERR_UNKNOWN | -2 | Unknown error occurred during operation
WPA_ERR_NOT_FOUND | -3 | Filter file or trigger file not found
WPA_ERR_WRONG_STATE | -4 | WPA is in the wrong state for the operation being requested. Example, attempting to load filters when logging has already started
WPA_ERR_LOST_CONNECTION | -5 | Connection to test set has been terminated
WPA_ERR_TEST_SET_NOT_CONNECTED | -6 |
WPA_ERR_CONN_REJ | -7 | Connection attempt rejected for unknown reason
WPA_ERR_INVALID_ADDRESS | -9 | Invalid IP Address, cannot connect to test set
WPA_ERR_BROWSER_OFFLINE | -10 | Internet Browser is offline, cannot connect to test set
Depricated Error: WPA_NOT_FOUND SA_NOT_FOUND | -14 -14 | WPA program not running WPA program not running
TEST_NOT_STARTED | -15 | Cannot stop logging, logging not started
TEST_ALREADY_STARTED | -16 | Cannot start logging, logging already started
WPA_ERR_FILE_UNKNOWN_ERROR | -17 | Unknown WPA error during file save operation
WPA_ERR_FILE_INTERNAL_ERROR | -18 | Internal WPA error during file save operation
WPA_ERR_FILE_ALREADY_SAVED | -19 | File already saved, cannot be written
WPA_ERR_FILE_WRITE | -20 | File cannot be written
WPA_ERR_FILE_RENAME | -21 | File cannot be renamed to requested filename
WPA_ERR_FILE_NO_DATA | -22 | No data captured to save to file
WPA_ERR_NOT_INITIALIZED | -24 | Data not yet requested
WPA_ERR_NO_LICENSED_OPTIONS | -25 |
WPA_ERR_INVALID_TAP | -30 | Invalid Test Application ID Specified
WPA_ERR_INVALID_SOURCE | -31 | Invalid Source number specified (valid are 1,2)
WPA_ERR_INVALID_ARGS | -32 | Invalid arguments past to function

Required Files

The DLL file for the API is located at:

<Your WPA Installation Path>\Wireless Protocol Advisor\bin\wpa_api.dll

In addition you need the following files which describe the API function calls:

  • wpa_api.lib

  • WPA_API.h

  • api_defines.h

These files are located at:

<Your WPA Installation Path>\Wireless Protocol Advisor\API\

Note: the default WPA Installation Path is C:\Program Files


WPA API Function Descriptions

Last Updated: April 14, 2008

The definitions used in the following functions for buffer sizes, return values, and parameter types are specified in the APIDefines.h file.

The WPA API contains the following functions. If a WPA API function is non-blocking, it is indicated in function description. Otherwise, if it is not indicated, the function is a blocking function. A blocking function does not return control to the calling program until the function is complete.

WPA API Connectivity

  • WPA_OpenWPAConnection

  • WPA_CloseWPAConnection

  • WPA_ConnectTestSet

  • WPA_DisconnectTestSet

WPA API Settings/Queries

  • WPA_LoadTestSetLoggingFilter

  • WPA_LoadTestSetTrigger

  • WPA_QueryBypassDefaultLANSetting

  • WPA_QueryLicenseStatus

  • WPA_QueryLogDuration

  • WPA_QueryLoggingState

  • WPA_QueryLogNumMessages

  • WPA_QueryNumDroppedMessages

  • WPA_QueryNumMessages

  • WPA_QueryProduct

  • WPA_QueryStacksLoaded

  • WPA_QuerySynchronization

  • WPA_QuerySynchronizationState

  • WPA_QuerySynchThreshold

  • WPA_QueryTestSetApplication

  • WPA_QueryTestSetFiltersNumSettings

  • WPA_QueryTestSetFiltersSettings

  • WPA_QueryTestSetFiltersStrings

  • WPA_QueryTestSetIP

  • WPA_QueryTestSetModel

  • WPA_QueryTestSetSerialNumber

  • WPA_QueryVersion

  • WPA_SetBypassDefaultLANSetting

  • WPA_SetLogDuration

  • WPA_SetLogNumMessages

  • WPA_SetSynchronization

  • WPA_SetSynchThreshold

  • WPA_SetTestSetFiltersSettings

WPA Logging Operation

  • WPA_LogAPIEvent

  • WPA_ParseTolFile

  • WPA_PeekMessage

  • WPA_SaveLog

  • WPA_StartLogging

  • WPA_StopLogging

WPA Deprecated Functions

The following are depricated functions still supported for backwards compatibility. It is recommended to NOT use these functions for new API development.

  • WPA_ConnectTester

  • WPA_DisconnectTester

  • WPA_LoadLoggingFilter

  • WPA_LoadTrigger

WPA_CloseWPAConnection

This function shall close the API Connection with WPA. This function is Non-Blocking.

Required Initial Conditions: WPA API connection must already be established.

Input Parameters: None

Return Value: API Function status, return values are specified in APIDefines.h

Syntax:

wpa_res_t __stdcall WPA_CloseWPAConnection(void);

WPA_ConnectTestSet

This function shall connect to the Test Set specified. This function is Non-Blocking.

Required Initial Conditions:

  • WPA API connection must already be established.

  • Connection to that Test Set must not already exist.

Input Parameters:

  • wpa_whichsource_t: "1" = Test Set 1, "2" = Test Set 2

  • wpa_net_t: IP Address of Test Set

Return Value: API Function status, return values are specified in APIDefines.h

Syntax:

wpa_res_t __stdcall WPA_ConnectTestSet(wpa_whichsource_t, wpa_net_t);

WPA_DisconnectTestSet

This function shall disconnect from the Test Set specified. This function is Non-Blocking.

Required Initial Conditions:

  • WPA API connection must already be established.

  • Connection to that Test Set must already exist.

Input Parameters: wpa_whichsource_t: "1" = Test Set 1, "2" = Test Set 2

Return Value: API Function status, return values specified in APIDefines.h

Syntax:

wpa_res_t __stdcall WPA_DisconnectTestSet(wpa_whichsource_t);

WPA_LoadTestSetLoggingFilter

This function shall load the Test Set Filter file previously saved via the WPA Filters dialog box.

Required Initial Conditions:

  • WPA API connection must already be established.

  • Logging Filter file must exist, unless the filename "" is being used to clear the settings.

Input Parameters:

  • wpa_whichsource_t: "1" = Test Set 1, "2" = Test Set 2

  • wpa_filename_t: Filename of Logging Filter file to load. (To clear log filters use a filename of "".)

Return Value: API Function status, return values are specified in APIDefines.h

Syntax:

wpa_res_t __stdcall WPA_LoadTestSetLoggingFilter(wpa_whichsource_t, wpa_filename_t);

WPA_LoadTestSetTrigger

This function shall load the Test Set Trigger file previously saved via the WPA Triggers dialog box. This function shall override any settings made via the WPA_SetLogNumMessages() or WPA_SetLogDuration() functions.

Required Initial Conditions:

  • WPA API connection must already be established.

  • Logging Filter file must exist, unless the filename "" is being used to clear the settings.

Input Parameters:

  • wpa_whichsource_t: "1" = Test Set 1, "2" = Test Set 2

  • wpa_filename_t: Filename of Logging Filter file to load. (To clear log filters use a filename of "".)

Return Value: API Function status, return values are specified in APIDefines.h

Syntax:

wpa_res_t __stdcall WPA_LoadTestSetTrigger(wpa_whichsource_t, wpa_filename_t);

WPA_LogAPIEvent

This function shall log a text event into the WPA log file (“.tol”) during a log session. This is useful to track external events while performing automated testing. This function is Non-Blocking.

Required Initial Conditions: WPA API connection must already be established and WPA must be in the "WPA_STATE_ACTIVE" state (log session active).

Input Parameters: wpa_stringBuffer_t: A pointer to a character buffer containing the text string to be inserted in the "Event" column of the log file. The string must not exceed MAX_API_EVENT_STRING_BUF characters. The character buffer may be deleted once the function call returns.

Return Values: API Function status, return values specified in APIDefines.h

Syntax:

wpa_res_t __stdcall WPA_LogAPIEvent(wpa_stringBuffer_t);

WPA_OpenWPAConnection

This function shall establish the API connection with WPA. This function must be called before any other WPA API functions. This function is Non-Blocking.

Required Initial Conditions: The WPA program must be running before this function is called, with the WPA Splash screen displayed.

Input Parameters: None

Return Values: WPA_SUCCESS or WPA_NOT_FOUND

Syntax:

wpa_res_t __stdcall WPA_OpenWPAConnection(void);

WPA_ParseTolFile

This function shall invoke the WPA ParseTol Utility to parse the .tol file captured by WPA. This function shall invoke the ParseTol utility in a DOS cmd window. The DOS window shall close upon termination of the ParseTol utility. In the event that the command arguments passed to the ParseTol utility are invalid, it may be difficult to read the status message returned by the ParseTol utility in the DOS window before the DOS window is closed. To capture the error status returned by the ParseTol utility, use redirection to redirect the output of ParseTol to a file. (For Example: "c:\test.tol >> test.out")

Required Initial Conditions: This function may not be used while WPA is actively logging. If it is, it shall return an error status. The status returned from this function shall only be returned once the ParseTol utility has completed parsing the ".tol" file specified.

Input Parameters:

A String containing command Line arguments specified for ParseTol Utility (see WPA ParseTol Utility Commands).

Return Value: API Function status, return values are specified in APIDefines.h

Syntax:

wpa_res_t __stdcall WPA_ParseTolFile(wpa_stringBuffer_t);

WPA_PeekMessage

This function shall "peek" at a message already logged.

Required Initial Conditions: This function is only valid after a log session has begun. The logging state must be "logging" (not stopped). The "WPA_PeekMessage()" function shall pause WPA logging, retrieve the data for the message number requested, then resume logging. Because of the "Pause/Resume" overhead required during the Peek Message operation, it is advisable to peek messages occasionally, not frequently. If the need is to continuously seek for a specific message, it is preferred to use a Logging Trigger rather than the "WPA_PeekMessage()" function. It is also suggested to use the "WPA_QueryNumMessages()" prior to calling the "WPA_PeekMessage()" function to verify that the message number requested has already been logged. This function shall return an error if it has not.

Input Parameters:

  • int: The message number to peek

  • wpa_stringBuffer_t:

Char * to buffer to hold resulting message data. Buffer to be allocated by calling program. Buffer size should be large enough to hold decoded message contents. Data returned by function shall not exceed MAX_PEEK_BUFFER_LEN characters. The format of the data shall the following: "Message Number: <number of message in log>, Message Size: <size of logged messsage>, Message: <comma delimited list of decoded data>"

For example: "Message
 number: 3, Message size: 38, Message: System Time=2945(dec),Protocol=MAC,System
 Type=FDD,Multiplex Used=FALSE,SHCCH Only-FLASE,Transport Channel=BCH,Logical
 Channel=BCCH,data=b8,data=4e,data=23,data=6c, data=0,data=0,data=0,data=4,data=40,data=e8,
 data=40,data=38,data=0,data=0,data=29, data=ff,data=ff,data=f9,data=c4,data=0,
 data=0,data=0,data=0,data=0,data=0"

The character buffer may be deleted once the function call returns.

Return Value: API Function status, return values are specified in APIDefines.h

Syntax:

wpa_res_t __stdcall WPA_PeekMessage(int messageNumber, wpa_stringBuffer_t);

WPA_QueryBypassDefaultLANSetting

This function shall query the Configuration "Bypass Default LAN Setting" for the source specified.

Required Initial Conditions: WPA API connection must already be established.

Input Parameters: wpa_whichsource_t: "1" = Test Set 1, "2" = Test Set 2

Return Value: 1 = setting on, 0 = setting off

In the event of error, the return value shall be the API Function status, return values specified in APIDefines.h

Syntax:

wpa_res_t __stdcall WPA_QueryBypassDefaultLANSetting(wpa_whichsource_t);

WPA_QueryLicenseStatus

This command is obsolete since, as of revision A.06.75, WPA no longer requires a license. This function shall query the license status of WPA.

Required Initial Conditions: WPA API connection must already be established.

Input Parameters:

wpa_stringBuffer_t: Char * to buffer to hold resulting license data. Buffer to be allocated by calling program. Buffer size should be large enough to hold license data contents. Data returned by function shall not exceed MAX_LICENSE_BUFFER_LEN. If there are no licensed options, the return string shall specify "There are no licensed options" and the returncode shall be WPA_ERR_NO_LICENSED_OPTIONS. The format of the data returned in the licensed>space<expiration date>[,]

For Example: "1xEV-DO 33.33 1-jan-0, GSM/GPRS/EGPRS 33.33 1-jan-0"

The character buffer may be deleted once the function call returns.

Return Value: API Function status, return values are specified in APIDefines.h.

Syntax:

wpa_res_t __stdcall WPA_QueryLicenseStatus(wpa_stringBuffer_t);

WPA_QueryLogDuration

This function shall query the duration set to log.

Required Initial Conditions: WPA API connection must already be established.

Input Parameters: None.

Return Value:

Duration of logging in seconds. If the duration is 0 the logging duration trigger is not being used. This setting is mutually exclusive with that set with a Logging Trigger File. In the event of error, the return value shall be the API Function status, return values specified in APIDefines.h.

Syntax:

wpa_res_t __stdcall WPA_QueryLogDuration(void);

WPA_QueryLoggingState

This function shall query the state of WPA.

Required Initial Conditions: WPA API connection must already be established.

Input Parameters: None.

Return Value: The state of logging as defined in APIDefines.h or an API error code as defined in APIDefines.h

Syntax:

wpa_res_t __stdcall WPA_QueryLoggingState(void);

WPA_QueryNumDroppedMessages

This function queries the number of messages dropped from the test set during logging. This is a blocking function.

Required Initial Conditions: WPA API connection must already be established.

Input Parameters: None

Return Value: Number of messages dropped by the test set. Note: In the event of and error, the return value shall be the API function status. Return values are specified in APIDefines.h.

Syntax:

wpa_res_t __sdtcall WPA_QueryNumDroppedMessages(void);

WPA_QueryLogNumMessages

This function shall query the number of messages set to log.

Required Initial Conditions: WPA API connection must already be established.

Input Parameters: None.

Return Value:

Number of messages to log. If the number of messages is 0 the logging trigger is not being used. This setting is mutually exclusive with that set with a Logging Trigger File. In the event of error, the return value shall be the API Function status, return values specified in APIDefines.h

Syntax:

wpa_res_t __stdcall WPA_QueryLogNumMessages(void);

WPA_QueryNumMessages

This function shall query the number of messages currently logged.

Required Initial Conditions: WPA API connection must already be established.

Input Parameters: None.

Return Value:

Number of messages captured in log. In the event of error, the return value shall be the API Function status, return values specified in APIDefines.h

Syntax:

wpa_res_t __stdcall WPA_QueryNumMessages(void);

WPA_QueryProduct

This function shall query the Product ID of the WPA application that is running.

Required Initial Conditions: WPA API connection must already be established.

Input Parameters:

wpa_stringBuffer_t:

Char * to buffer to hold WPA Product Number, for example: "E6584A". Buffer to be allocated by calling program. Buffer size should be large enough to hold Product Number. Data returned by function shall not exceed MAX_PRODUCT_ID_BUFFER_LEN characters. The character buffer may be deleted once the function call returns.

Return Value: API Function status, return values are specified in APIDefines.h

Syntax:

wpa_res_t __stdcall WPA_QueryProduct(wpa_stringBuffer_t);

WPA_QueryStacksLoaded

This function shall return a list of the stacks currently loaded in WPA.

Required Initial Conditions: WPA API connection must already be established and connection to Test Set exist.

Input Parameters:

wpa_stringBuffer_t:

Char * to buffer to hold list of stacks loaded. Buffer to be allocated by calling program. Buffer size should be large enough to hold list of stacks contents. Data returned by function shall not exceed MAX_STACKS_BUFFER_LEN characters. The format of the data returned shall be a comma delimited list of the stacks currently loaded, ex: "WCDMA,GSM-GPRS-EGPRS". The character buffer may be deleted once the function call returns.

Return Value: API Function status, return values are specified in APIDefines.h

Syntax:

wpa_res_t __stdcall WPA_QueryStacksLoaded(wpa_stringBuffer_t);

WPA_QuerySynchronization

This function shall query the synchronization state of WPA. The synchronization state is only applicable when connected to two Test Sets that support synchronization of log messages.

Note that the synchronization state does not necessarily determine whether messages will be synchronized. Other factors, such as the Test Sets connected to WPA and the synchronization states of those Test Sets shall determine whether synchronization actually occurs. To determine whether messages are being synchronized, use the "WPA_QuerySynchronizationState()" function.

Required Initial Conditions: WPA API connection must already be established.

Input Parameters: None.

Return Value: 1 = synchronization on, 0 = synchronization off

In the event of an error, the function shall return the API Function status, return values specified in APIDefines.h

Syntax:

wpa_res_t __stdcall WPA_QuerySynchronization(void);

WPA_QuerySynchronizationState

This function shall determine whether WPA messages are being synchronized. Messages will only be synchronized when the Synchronization setting in WPA is "on" and when WPA is connected to two Test Sets supporting message synchronization, and those test sets are synchronized to each other.

Required Initial Conditions: WPA API connection must already be established. This function is only valid after a logging session has begun.

Input Parameters: None.

Return Value: 1 = synchronization on, 0 = synchronization off

In the event of an error, the function shall return the API Function status, return values specified in APIDefines.h

Syntax:

wpa_res_t __stdcall WPA_QuerySynchronizationState(void);

WPA_QuerySynchThreshold

This function shall query the synchronization threshold setting in WPA.

Required Initial Conditions: WPA API connection must already be established.

Input Parameters: None.

Return Value: Synchronization threshold setting (value range 1-10).

In the event of an error, the function shall return the API Function status, return values specified in APIDefines.h

Return Value: API Function status, return values are specified in APIDefines.h

Syntax:

wpa_res_t __stdcall WPA_QuerySynchThreshold(void);

WPA_QueryTestSetApplication

This function shall query the description of one of the Test Set's to which WPA is connected.

Required Initial Conditions: WPA API connection must already be established.

Input Parameters:

wpa_whichsource_t: "1" = Test Set 1, "2" = Test Set 2

wpa_stringBuffer_t:

Char * to buffer to the string representing the Test Set application retrieved from the Test Set. Buffer to be allocated by calling program. Buffer size should be large enough to hold the Application description contents. Data returned by function shall not exceed MAX_APPLICATION_BUFFER_LEN characters. For Example: "E6703D WCDMA Lab App D D.00.07". The character buffer may be deleted once the function call returns.

Return Value: API Function status, return values are specified in APIDefines.h

Syntax:

wpa_res_t __stdcall WPA_QueryTestSetApplication(wpa_whichsource_t, wpa_stringBuffer_t);

WPA_QueryTestSetFiltersNumSettings

This function shall query the number of Test Set Filter settings in a specific Test Application (TAP) of the Test Set to which WPA is connected.

Required Initial Conditions: WPA API connection must already be established.

Input Parameters:

  • wpa_whichsource_t: "1" = Test Set 1, "2" = Test Set 2

  • wpa_whichTap_t:

0 = C2K

1 = Reserved

2 = Reserved

3 = WCDMA

4 = GSM/GPRS/EGPRS

5 = Reserved

6 = 1xEV-DO

Return Value:

The number of Test Set Filters in the Test Application.

In the event of an error, the function shall return the API Function status, return values specified in APIDefines.h.

Syntax:

wpa_res_t __stdcall WPA_QueryTestSetFiltersNumSettings(wpa_whichsource_t, wpa_whichTap_t);

WPA_QueryTestSetFiltersSettings

This function shall query the Test Set Filter settings in a specific Test Application (TAP) of the Test Set to which WPA is connected. This function is Non-Blocking.

Required Initial Conditions: WPA API connection must already be established.

Input Parameters:

  • wpa_whichsource_t: "1" = Test Set 1, "2" = Test Set 2

  • wpa_whichTap_t:

0 = C2K

1 = Reserved

2 = Reserved

3 = WCDMA

4 = GSM/GPRS/EGPRS

5 = Reserved

6 = 1xEV-DO

  • wpa_pSettingsFlags_t: pointer to integer result

A 32 bit integer representing the state of the Test Set Filter settings for the Test Application, where each bit in the value indicates on (1) or off (0). Bit 0 is associated with the first Test Set Filter setting. For example, a value of 0x0047 indicates that settings 1, 2, 3, and 7 are "on" and all other settings are "off". The order of the settings (1..n) is the same as that retrieved from the WPA_QueryTestSetFiltersStrings() functionand that which is displayed in the WPA Test Set Filters dialog box.

Return Value:

In the event of an error, the function shall return the API Function status, return values specified in APIDefines.h.

Syntax:

wpa_res_t __stdcall WPA_QueryTestSetFiltersSettings(wpa_whichsource_t, wpa_whichTap_t, wpa_pSettingsFlags_t);

WPA_QueryTestSetFiltersStrings

This function shall query the strings associated with the Test Set Filters for the Test Application of the specified Test Set.

Required Initial Conditions: WPA API connection must already be established.

Input Parameters:

  • wpa_whichsource_t: "1" = Test Set 1, "2" = Test Set 2

  • wpa_whichTap_t:

0 = C2K

1 = Reserved

2 = Reserved

3 = WCDMA

4 = GSM/GPRS/EGPRS

5 = Reserved

6 = 1xEV-DO

  • wpa_stringBuffer_t: Char * to buffer to the comma delimited string representing the names of the Test Set Filters for the Test Application specified. Buffer to be allocated by calling program. Buffer size should be large enough to hold the Test Set Filter Strings description contents. Data returned by function shall not exceed M MAX_FILTER_STRINGS_BUFFER_LEN characters. The character buffer may be deleted once the function call returns.

Return Value: API Function status, return values are specified in APIDefines.h

Syntax:

wpa_res_t __stdcall WPA_QueryTestSetFiltersStrings(wpa_whichsource_t, wpa_whichTap_t, wpa_stringBuffer_t);

WPA_QueryTestSetIP

This function shall query the IP Address of the Test Set specified.

Required Initial Conditions: WPA API connection must already be established.

Input Parameters:

  • wpa_whichsource_t: "1" = Test Set 1, "2" = Test Set 2

  • wpa_stringBuffer_t: Char * to buffer to the string representing the IP Address of the test set. Buffer to be allocated by calling program. Buffer size should be large enough to hold the IP Address description contents. Data returned by function shall not exceed MAX_IP_BUFFER_LEN characters.

Return Value: API Function status, return values are specified in APIDefines.h

Syntax:

wpa_res_t __stdcall WPA_QueryTestSetIP(wpa_whichsource_t, wpa_stringBuffer_t);

WPA_QueryTestSetModel

This function shall query the Model of the Test Set specified.

Required Initial Conditions: WPA API connection must already be established.

Input Parameters:

wpa_whichsource_t: "1" = Test Set 1, "2" = Test Set 2

wpa_stringBuffer_t: Char * to buffer to the string representing the Model number of the test set. Buffer to be allocated by calling program. Buffer size should be large enough to hold the Model description contents. Data returned by function shall not exceed MAX_MODEL_BUFFER_LEN characters. For Example: "Agilent Technologies 8960 Series 10 E5515C". The character buffer may be deleted once the function call returns.

Return Value: API Function status, return values are specified in APIDefines.h

Syntax:

wpa_res_t __stdcall WPA_QueryTestSetModel(wpa_whichsource_t, wpa_stringBuffer_t);

WPA_QueryTestSetSerialNumber

This function shall query the serial number of the Test Set specified

Required Initial Conditions: WPA API connection must already be established.

Input Parameters:

  • wpa_whichsource_t: "1" = Test Set 1, "2" = Test Set 2

  • wpa_stringBuffer_t: Char * to buffer to the string representing the serial number of the test set. Buffer to be allocated by calling program. Buffer size should be large enough to hold the Serial Number description contents. Data returned by function shall not exceed MAX_SERIAL_BUFFER_LEN characters. The character buffer may be deleted once the function call returns.

Return Value: API Function status, return values are specified in APIDefines.h

Syntax:

wpa_res_t __stdcall WPA_QueryTestSetSerialNumber(wpa_whichsource_t, wpa_stringBuffer_t);

WPA_QueryVersion

This function shall query the version number of the Wireless Protocol Advisor.

Required Initial Conditions: WPA API connection must already be established.

Input Parameters:

wpa_stringBuffer_t: Char * to buffer to the string representing the version number of the WPA. Ex: "A.05.00" Buffer to be allocated by calling program. Buffer size should be large enough to hold the Version Number description contents. Data returned by function shall not exceed MAX_VERSION_BUFFER_LEN characters. The character buffer may be deleted once the function call returns.

Return Value: API Function status, return values are specified in APIDefines.h

Syntax:

wpa_res_t __stdcall WPA_QueryVersion(char *sVersionNumber);

WPA_SaveLog

This function shall save the logged data to the ".tol" file specified.

Required Initial Conditions: Logging session must have already captured data to save. Logging must be in the "stopped" state.

Input Parameters:

  • wpa_filetype_t: Reserved, not used

  • wpa_filename_t: Filename of file to save the ".tol" file to.

Return Value: API Function status, return values are specified in APIDefines.h

Syntax:

wpa_res_t __stdcall WPA_SaveLog(wpa_filetype_t, wpa_filename_t);

WPA_SetBypassDefaultLANSetting

This function shall set the "Bypass Default LAN Setting".

Required Initial Conditions: WPA API connection must already be established.

Input Parameters:

  • wpa_whichsource_t: "1" = Test Set 1, "2" = Test Set 2

  • int: "1" = on, "0" = off

Return Value: API Function status, return values are specified in APIDefines.h

Syntax:

wpa_res_t __stdcall WPA_SetBypassDefaultLANSetting(wpa_whichsource_t, int);

WPA_SetLogDuration

This function shall set the duration for which to log, in seconds. This function shall override the setting made by any of the Load Triggers functions or the WPA_SetLogNumMessages() function.

Required Initial Conditions: WPA API connection must already be established.

Input Parameters: int: Duration in seconds. A value of "0" clears the trigger.

Return Value: API Function status, return values are specified in APIDefines.h

Syntax:

wpa_res_t __stdcall WPA_SetLogDuration(int duration);

WPA_SetLogNumMessages

This function shall set the number of messages to log. NOTE: The number of messages logged will be 1 greater than the number of messages set to log, in order to record the Stop Event in the message log. This function shall override the setting made by any of the Load Triggers functions or the WPA_SetLogDuration() function.

Required Initial Conditions: WPA API connection must already be established.

Input Parameters: int: Number of messages to capture. A value of "0" clears the trigger.

Return Value: API Function status, return values are specified in APIDefines.h

Syntax:

wpa_res_t __stdcall WPA_SetLogNumMessages(int number);

WPA_SetSynchronization

This function shall set the message synchronization mode. Note that this setting only applies to Test Set's that support message synchronization. The setting will be ignored for all other Test Sets.

Required Initial Conditions: WPA API connection must already be established.

Input Parameters: int: Synchronization mode where 1 = "on" and 0 = "off"

Return Value: API Function status, return values are specified in APIDefines.h

Syntax:

wpa_res_t __stdcall WPA_SetSynchronization(int synch_mode);

WPA_SetSynchThreshold

This function shall set the message synchronization threshold. Note that this setting only applies to Test Set's that support message synchronization. The setting will be ignored for all other Test Sets.

Required Initial Conditions: WPA API connection must already be established.

Input Parameters: int: Threshold setting, values 1-10.

Return Value: API Function status, return values are specified in APIDefines.h

Syntax:

wpa_res_t __stdcall WPA_SetSynchThreshold(int threshold);

WPA_SetTestSetFiltersSettings

This function shall set the Test Set Filter settings for the Test Application specified. Note: This is a non blocking operation which may take a second or so to complete in WPA. It should be followed by a "WPA_QueryTestSetFiltersSettings()" request to verify the settings have been completed. This function is Non-Blocking.

Required Initial Conditions:

  • WPA API connection must already be established.

  • Connection to Test Set must already be established.

Input Parameters:

  • wpa_whichsource_t: "1" = Test Set 1, "2" = Test Set 2

  • wpa_whichTap_t:

0 = C2K

1 = Reserved

2 = Reserved

3 = WCDMA

4 = GSM/GPRS/EGPRS

5 = Reserved

6 = 1xEV-DO

  • wpa_settingsFlags_t: A 32 bit integer representing the state of the Test Set Filter settings for the Test Application, where each bit in the value indicates on (1) or off (0). Bit 0 is associated with the first Test Set Filter setting. For example, a value of 0x0047 would turn settings 1, 2, 3, and 7 "on" and all other settings "off". The order of the settings (1..n) is the same as that retrieved from the WPA_QueryTestSetFiltersStrings() function and that which is displayed in the WPA Test Set Filters dialog box.

Return Value: API Function status, return values are specified in APIDefines.h

Syntax:

wpa_res_t __stdcall WPA_SetTestSetFiltersSettings(wpa_whichsource_t, wpa_whichTap_t, wpa_settingsFlags_t);

WPA_StartLogging

This function shall begin logging from all connected Test Sets. This function is Non-Blocking.

Required Initial Conditions:

  • WPA API connection must already be established.

  • Connection to Test Set must already be established.

Input Parameters: None.

Return Value: API Function status, return values are specified in APIDefines.h

Syntax:

wpa_res_t __stdcall WPA_StartLogging(void);

WPA_StopLogging

This function shall stop logging on all connected Test Sets. This function is Non-Blocking.

Required Initial Conditions:

  • WPA API connection must already be established.

  • Connection to Test Set must already be established and

  • log session already started.

Input Parameters: None.

Return Value: API Function status, return values are specified in APIDefines.h

Syntax:

wpa_res_t __stdcall WPA_StopLogging(void);

WPA_ConnectTester(wpa_net_t)

Use WPA_ConnectTestSet instead.

This function shall connect to Test Set 1. This function is Non-Blocking.

Required Initial Conditions:

  • WPA API connection must already be established.

  • Connection to that Test Set must not already exist.

Input Parameters: wpa_net_t: The IP Address of the Test Set to connect to

Return Value: API Function status, return values specified in APIDefines.h

Syntax:

wpa_res_t __stdcall WPA_ConnectTester(wpa_net_t);

WPA_DisconnectTester

Use WPA_DisconnectTestSet instead.

This function shall disconnect from Test Set 1. This function is Non-Blocking.

Required Initial Conditions:

  • WPA API connection must already be established.

  • Connection to that Test Set must already exist.

Input Parameters: None.

Return Value: API Function status, return values specified in APIDefines.h

Syntax:

wpa_res_t __stdcall WPA_DisconnectTester(void);

WPA_LoadLoggingFilter

Use WPA_LoadTestSetLoggingFilter instead.

This function shall load the Test Set Filter file previously saved via the WPA Triggers dialog box to Test Set 1.

Required Initial Conditions:

  • WPA API connection must already be established.

  • Filter File must already exist.

Input Parameters: wpa_filename_t: Filename of Logging Trigger file to load. To clear log triggers use a filename of "".

Return Value: API Function status, return values specified in APIDefines.h

Syntax:

wpa_res_t __stdcall WPA_LoadLoggingFilter(wpa_filename_t);

WPA_LoadTrigger

Use WPA_LoadTestSetTrigger instead.

This function shall load the Test Set Trigger file previously saved via the WPA Filters dialog box to Test Set 1.

Required Initial Conditions:

  • WPA API connection must already be established.

  • Trigger File must already exist.

Input Parameters: wpa_filename_t: Filename of Logging Filter file to load. To clear log filters use a filename of "".

Return Value: API Function status, return values specified in APIDefines.h

Syntax:

wpa_res_t __stdcall WPA_LoadTrigger(wpa_filename_t);


WPA Sample API Program in Perl

Last Updated: April 14, 2008

A sample Perl program to use the WPA API is located at :

  • <WPA Installation directory>\Wireless Protocol Advisor\bin\WPAExampleAPITest.pl

Note: the default WPA Installation directory is C:\Program Files


Troubleshooting

The topics in this section provide troubleshooting information relating to installation, set up or use.

For more information, choose a book or topic below:

Troubleshooting

  • Channel column directions are reversed

  • WPA does not connect with the test set

  • Logging has stopped because the disk is full

  • Traffic Overview indicates there are dropped messages

Contact Us


Contact Us

To find information about technical support, equipment service and repair, and training, visit the following Agilent Technologies Web site:

http://we.home.agilent.com/cgi-bin/bvpub/agilent/ContactPages/cp_ContactInformation.jsp?LANGUAGE_CODE=eng&COUNTRY_CODE=ZZ&NAV_ID=-11145.0.00

Service and Support

Contact your customer engineer through your local Agilent Technologies Service Center.

If you do not have access to the Internet, one of these centers can direct you to your nearest representative:

United States Test and Measurement Call Center

(Toll free in US)

(800) 452-4844

Europe

(31 20) 547 9900

Canada

(905) 206-4725

Japan Measurement Assistance Center

(81) 426 56 7832

(81) 426 56 7840 (FAX)

Latin America

(305) 267 4288 (FAX)

Australia/New Zealand

1 800 629 485 (Australia)

0800 738 378 (New Zealand)

Asia-Pacific

(852) 2599 7777

(852) 2506 9285 (FAX)

Regional Sales Offices

United States of America:

Agilent Technologies

Test and Measurement Call Center

P.O. Box 4026

Englewood, CO 80155-4026

(tel) 1 800 452 4844

Canada:

Agilent Technologies Canada Inc.

2660 Matheson Blvd. E

Mississauga, Ontario

L4W 5M2

(tel) 1 877 894 4414

Europe:

Agilent Technologies

European Marketing Organization

P.O. Box 999

1180 AZ Amstelveen

The Netherlands

(tel) (3120) 547 9999

Japan:

Agilent Technologies Japan Ltd.

Measurement Assistance Center

9-1 Takakura-Cho, Hachioji-Shi,

Tokyo 192-8510, Japan

(tel) (81) 456-56-7832

(fax) (81) 426-56-7840

Latin America:

Agilent Technologies

Latin America Region Headquarters

5200 Blue Lagoon Drive,

Suite #950

Miami, Florida 33126

U.S. A.

(tel) (305) 267 4245

(fax) (305) 267 4286

Australia/New Zealand:

Agilent Technologies Australia Pty Ltd.

347 Burwood Highway

Forest Hill, Victoria 3131

Australia

Australia

(tel) 1 800 629 485

(fax) (61 3) 9272 0749

New Zealand

(tel) 0 800 738 378

(fax) (64 4) 802 6881

Asia Pacific:

Agilent Technologies

24/F, Cityplaza One,

111 Kings Road,

Taikoo Shing, Hong Kong

(tel) (852) 3197 7777

(fax) (852) 2506 9233


Channel Column Directions are Reversed

If you have upgraded the Wireless Protocol Advisor from the E6582A (cdma2000) to E6584A (multi-format) and you attempt to view log (.tol) files saved using the E6582A, the Direction column in the Traffic Overview will have message directions reversed.

To correct this problem a program was created to reverse all Direction column readings:

  1. Save a backup copy of the .tol files that have the Direction column readings reversed.

  2. Run the StreamSwap executable (this file is located in the Program Files/Wireless Protocol Advisor/Bin folder).

  3. Click on the Select Files button and select the .tol files that you backed up.

  4. Click on the Exit button to exit the StreamSwap program.

  5. Re-open the .tol file.

The Direction column in the Traffic Overview window should now display the correct Forward/Reverse or Up(link)/Down(link) indicators.


Dropped Messages

As data throughput rates climb, the test set prioritizes the maintenance of these high data rates. This can cause situations where the test set does not send all protocol messages to Wireless Protocol Advisor (WPA). WPA can represent either one or a group of contiguous dropped messages by displaying a "Dropped Message(s)" in a single row of the traffic overview.

The following are ways to reduce the effects of losing messages (for any technology):

If you are experiencing dropped messages, it is recommended that you take an iterative approach to steps below to reduce dropped messages as well as follow the additional tips below for specific technologies.

  1. Use the test set filters to reduce the number of messages that are logged.

    1. Log the layers individually.

  2. Use a lower data rate. (Reduce the CQI value or AT Directed Packets settings in the test set)

  3. Use a smaller file size.

  4. Use the Summary View on the WPA to see how many messages have been dropped. Remember that one line in the WPA traffic overview window that displays "Dropped Message(s)" can represent one or many dropped messages.

Note: To achieve certain data throughput rates, you are required to have a Special High Data Rate Lab Application which also requires Special High Data Rate Hardware.

More details by technology to reduce the number of dropped messages:

1xEV-DO (for Release 0 and Release A)

Without the E6706U Special High Data Rate 1xEV-DO Lab Application, you need to lower the AT Directed to 10%. The data rate will be very low at this setting. It is recommended that you use E6706U Special High Data Rate 1xEV-DO Lab Application to reduce the number of dropped messages at higher data rates.

If you are experiencing dropped messages with the E6706U Special High Data Rate 1xEV-DO Lab Application and Special High Data Rate Hardware, try lowering the AT Directed Packets setting until no messages are dropped. For example, lower the AT Directed Packets setting to 70%, then 50% and so on.

HSDPA

To lower the number of dropped messages:

  • It is recommended that you only attempt to analyze protocol messages with WPA if you are using an 8960 with E6703U Special High Data Rate W-CDMA/HSDPA Lab Application on an E5515C with Special High Data Rate Hardware.

  • Lower the CQI value in the test set. The lower the CQI value, the lowere the number of dropped messages.


Logging stopped because the disk is full.

The wireless protocol advisor will not capture data if your local hard drive is full. Alternatively, if your hard drive is almost full, wireless protocol advisor may start capturing data, but terminate before you stop capturing data and display the following message:

Solution

Before any further data capturing can take place, you must create some space on your local hard drive. Wireless protocol advisor will then be able to capture data once your computer has been restarted.


WPA Causes 100% CPU Usage when Logging

When you start capturing data with WPA the Windows Task Manager will report that CPU memory usage is at 100%.

Although WPA reports 100% CPU usage while logging, it will only use 100% of the CPU for logging only if it is available. While it is logging, WPA continually checks whether there are other Windows programs/tasks that are requesting CPU time and gives it up to them


Re-installing/Upgrading the Wireless Protocol Advisor

Re-install/Upgrade the Wireless Protocol Advisor

The E6584A installation process will only detect previous versions of the E6584A. If you have an older version of WPA (E6581A, E6582A, E6583A) you will need to un-install it manually. If you are prompted to uninstall WPA from your PC, first go to the Control Panel and click Add/Remove Programs. Then select Wireless Protocol Advisor and click remove.

WPA cannot be open during the installation procedure. Installation of WPA requires administrative privileges.

The revision number format used by the WPA is XX.YY.ZZ, where X, Y, and Z can be any number 0-9. The XX portion of the revision number can also be any letter A-Z, which is mapped to numbers 0-25. For example, WPA software version A.03.00 is identical to WPA software version 00.03.00. The installation process only displays the numeric form of the revision number.

Installation from CD-ROM

  1. Insert the CD in your CD-ROM drive.

If your PC is setup to run when a CD is inserted you should accept the default options shown during the installation process.

If your PC does not auto-run when it detects a CD you should run the Setup.exe file on the CD from Windows Explorer. Accept the default options suggested by the installation process.

  1. Once installed the Wireless Protocol Advisor icon will appear on your desktop.

  2. Double-click the icon to start the Wireless Protocol Advisor.

Installation from the Agilent Technologies Website

You can download the latest version of WPA from the Agilent Technologies web site at:

http://www.agilent.com/find/e6584a

Installation Procedure:

  1. Click on the Technical Support >> Drivers & Software tab on the E6584A Wireless Protocol Advisor Product Page (http://www.agilent.com/find/e6584a).

  2. Select the E6584A Software Download link. This takes you to the 8960 Series 10 Wireless Software Downloads page.

  3. On the 8960 Series 10 Wireless Software Downloads page, scroll down to the Wireless Protocol Advisor and select the appropriate link under the Download column.

  4. Download the software to your PC.

  5. Run the executable that you've downloaded. This will start the installation software.

  6. Once installed the Wireless Protocol Advisor icon will appear on your desktop.

  7. Double-click the icon to launch the Wireless Protocol Advisor.


WPA ParseTol Utility

This section contains the following:

  • WPA ParseTol Utility Overview

  • Where to Access the WPA ParseTol Utilty

  • WPA ParseTol Utility Commands

  • WPA ParseTol Utility Text File Output Formats

WPA ParseTol Utility Overview

The WPA ParseTol command line utility program is a utility to parse a binary .tol file captured by the Wireless Protocol Advisor during a logging session into a text file that contains the .tol file content in a human readable format. The output of the parsed data is similar to that which is produced by WPA during the Save Decodes to a Text File operation, however there are differences between the two.

The text file output by the WPA ParseTol utility provides the Hex representation of the message data only, and therefore does not include the Octet, Binary, or Decimal representation of the message data. (See Decode View Columns for more information on the columns displayed in the message decode view.) The WPA ParseTol utility also provides the Message Direction, the number of times the message was transmitted or received, and the option to provide the Test Set Filter settings used when the .tol file was captured (none of which are provided by the Save Decodes to a Text File operation).

Note:

The ParseTol utility may not be used while WPA is logging. Doing so is likely to corrupt the message log captured by WPA. If WPA is running when the ParseTol utility is invoked the ParseTol utility shall return an error and terminate. To use the ParseTol utility while WPA is running (and while WPA is not actively logging), use the ParseTol utility via the WPA API WPA_ParseTolFile function.

Where to Access the WPA ParseTol Utilty

This program is located in the \Wireless Protocol Advisor\bin directory on your PC that has the WPA installed on it. (The default path is C:\Program Files\Wireless Protocol Advisor\bin.)

WPA ParseTol Utility Commands

ParseTol <filename>.tol

This command determines which .tol file is to be parsed into a text file. If no range of message decodes within the .tol file is specified, the ParseTol Utility parses all the message decodes in the specified file. If no output filename is specified, the output data is sent to the stdout function so that is can be easily piped to other functions.

Note: The length of the filename (including the ".tol" extension) must no greater than 200 characters.

To use this command, type it (along with any options you choose) into the command line of the your command line interface.

You can customize the text file output by using the following options:

  • -o <outputfile> - This option allows you to specify the name of the output file.

  • -r nn - This option allows you to specify a single message decode to be parsed, where 'nn' is the number of the message decode to be parsed.

  • -r nn,mm - This option allows you to specify a range of message decodes to be parsed, where 'nn' is the number of the first message decode to be parsed and 'mm' is the number of the last message decode to be parsed.

  • -r -nn - This option allows you to specify the number of message decodes from the end of the .tol file to be parsed, where 'nn' is the number of the first message decode to be parsed.

  • -v - This option is the verbose option. When you use this option the ParseTol Utility converts all the data in the .tol file to a text format. When this option is not used, only the message decode data is converted to text format.

  • It is recommended that you use the ParseTol utility via the WPA API WPA_ParseTolFile function if you wish to use the ParseTol utility while WPA is running (and while WPA is not actively logging).
    Users who are cautious not to invoke the ParseTol utility while WPA is logging may do so without having to use the WPA_ParseTolFile WPA API function by including -API as an argument to the ParseTol command.
    Example: C:\Program Files\Wireless Protocol Advisor\bin\ParseTol “c:\test.tol” –o “c:\test.txt” -API

Examples

  1. To parse the last 100 messages contained in the file sample.tol into a file named sample_parsed.txt, you would use the following command:
    ParseTol sample.tol –o sample_parsed.txt –r –100

  2. To parse all of the messages in the file sample.tol to the stdout function, you would use the following command:
    ParseTol sample.tol

  3. To parse all of the messages in sample.tol and redirect the output to another function such as findstr, you would use the following command:
    ParseTol sample.tol > findstr

  4. To parse messages 2 through 57 of the demo file location_update.tol that is located in C:\Program Files\Wireless Protocol Advisor\User Files\Capture Data into a file named location_update_parsed.txt that is located in C:\tmp, you would use the following command:
    ParseTol "C:\Program Files\Wireless Protocol Advisor\User Files\Capture Data\location_update.tol" -o C:\tmp\location_update_parsed.txt" -r 2,57

    As shown in the figure below, the command line interface displays the message number that it is currently being decoded, and then shows Parsing Complete as well as the parsed file's name.

WPA ParseTol Utility Text File Output Formats

This section contains two example text file output formats from the ParseTol Untility:

  • Text File Output Format (without the verbose option)

  • Text File Output Format (with the verbose option)

Text File Output Format (without the verbose option)

The following is an example of the output format of a text file generated from the ParseTol utility without the verbose option. The indentation of the columns is done by the Tab character, which in this example below is shown as equivalent to two character spaces.

test.tol parsed on Thu, Aug 17 06 at 09:19:11 AM

Number of Messages = 329

Message number of first msg = 1

Message number of last msg = 329

Message Block:

Message Number = 1

Message Size = 38

Message type = 0x10001

Status Word = 0x0000

Timestamp: Microseconds = 0x0000

Timestamp: ClockTime = 0x44a420b8

Formatted Timestamp = 11:49:28.000000

Number of times Msg rxed/txed = 1

Test Set Number = 1

Direction = For/Down ->

Message Data = 0xa1 0x0e 0x00 0x00 0x0a 0x00 0x00 0xea

0x4e 0x23 0x6c 0x00 0x00 0x00 0x04 0x40

0xe8 0x40 0x38 0x00 0x00 0x29 0xff 0xff

0xf9 0xc4 0x00 0x00 0x00 0x00 0x00 0x00

0x00 0x00 0x00 0x00 0x00 0x00

Decoded:

System Time=3745(dec)

Protocol=MAC

System Type=FDD

Multiplex Used=FALSE

SHCCH Only=FALSE

DTCH/DCCH on DSCH/USCH only=FALSE

Transport Channel=BCH

Logical Channel=BCCH

data=ea

data=4e

data=23

data=6c

data=0

data=0

data=0

data=4

data=40

data=e8

data=40

data=38

data=0

data=0

data=29

data=ff

data=ff

data=f9

data=c4

data=0

data=0

data=0

data=0

data=0

data=0

data=0

data=0

data=0

data=0

data=0

data=0

Message Block:

Message Number = 2

Message Size = 38

Message type = 0x10001

Status Word = 0x0000

Timestamp: Microseconds = 0x4e20

Timestamp: ClockTime = 0x44a420b8

Formatted Timestamp = 11:49:28.020000

Number of times Msg rxed/txed = 1

Test Set Number = 1

Direction = For/Down ->

Message Data = 0xa3 0x0e 0x00 0x00 0x0a 0x00 0x00 0xea

0x6e 0x0b 0xa5 0x03 0xf0 0x0c 0x18 0x02

0x00 0x10 0x84 0x7f 0x3c 0x0c 0x05 0x3d

0x41 0x00 0x0c 0x08 0x01 0x91 0xa0 0x50

0x00 0x00 0x00 0x00 0x00 0x00

Decoded:

System Time=3747(dec)

Protocol=MAC

System Type=FDD

Multiplex Used=FALSE

SHCCH Only=FALSE

DTCH/DCCH on DSCH/USCH only=FALSE

Transport Channel=BCH

Logical Channel=BCCH

data=ea

data=6e

data=b

data=a5

data=3

data=f0

data=c

data=18

data=2

data=0

data=10

data=84

data=7f

data=3c

data=c

data=5

data=3d

data=41

data=0

data=c

data=8

data=1

data=91

data=a0

data=50

data=0

data=0

data=0

data=0

data=0

data=0

Text File Output Format (with the verbose option)

The following is an example of the output -v (verbose) format. When using the verbose format all of the data in the .tol file is converted to text format, rather than just the decoded message data.

test.tol parsed on Thu, Aug 17 06 at 09:44:29 AM

LogFileStructID = 4

LogFileIdentifier = 2031801012

DiskFileFormat = Linear

Number of Message Buffers = 329

Number of Messages = 329

Buffer Size = 288

First Buffer Record Number = 0x0014

Last Buffer Record Number = 0xa9bf

Offset to Buffer Data = 0x0058

Offset to Monitor Setup Info = 0xd4ca

Offset to Configuration Info = 0xc86c

Offset to Workspace = 0x0000

Offset to Second Monitor Setup Info = 0xe7d9

Offset to Second Configuration Info = 0xdb7b

Offset to Extra Events = 0x12f55c

Message number of first msg = 1

Message number of last msg = 329

Record number of first extra event = 0x7c145454

Record number of last extra event = 0x573fd80

Size of blocks in file = 51200

Number of blocks in file = 1

Address of first byte after last msg in file = 0xaa98

Block Header:

Block Number = 1

First Message Number = 1

Last Message Number = 329

Record Number of First Block = 0x0014

Record Number of Last Block = 0xa9bf

Message Block:

Session Id = 0

Next Message Address 0x009e

Previous Message Address = 0x0000

Addresses of Next Message in Protocol at this layer = 0x0000, 0x0000, 0x0000, 0x0000, 0x0000

Addresses of Prev Message in Protocol at this layer = 0x0000, 0x0000, 0x0000, 0x0000, 0x0000

Select codes for the 1st 5 layers = 0xcdcd, 0xcdcd, 0xcdcd, 0xcdcd, 0xcdcd

2 Pad bytes = 0xcdcd

Pointer to KFE Buffer = 0x0000

Message Number = 1

Message Size = 38

2 Pad bytes = 0x0000

Message type = 0x10001

Status Word = 0x0000

Timestamp: Microseconds = 0x0000

Timestamp: ClockTime = 0x44a420b8

Formatted Timestamp = 11:49:28.000000

Record/Buffer Number = 20

Number of times Msg rxed/txed = 1

Test Set Number = 1

Direction = For/Down ->

Message Data = 0xa1 0x0e 0x00 0x00 0x0a 0x00 0x00 0xea

0x4e 0x23 0x6c 0x00 0x00 0x00 0x04 0x40

0xe8 0x40 0x38 0x00 0x00 0x29 0xff 0xff

0xf9 0xc4 0x00 0x00 0x00 0x00 0x00 0x00

0x00 0x00 0x00 0x00 0x00 0x00

Decoded:

System Time=3745(dec)

Protocol=MAC

System Type=FDD

Multiplex Used=FALSE

SHCCH Only=FALSE

DTCH/DCCH on DSCH/USCH only=FALSE

Transport Channel=BCH

Logical Channel=BCCH

data=ea

data=4e

data=23

data=6c

data=0

data=0

data=0

data=4

data=40

data=e8

data=40

data=38

data=0

data=0

data=29

data=ff

data=ff

data=f9

data=c4

data=0

data=0

data=0

data=0

data=0

data=0

data=0

data=0

data=0

data=0

data=0

data=0

Message Block:

Session Id = 0

Next Message Address 0x0128

Previous Message Address = 0x0014

Addresses of Next Message in Protocol at this layer = 0x0000, 0x0000, 0x0000, 0x0000, 0x0000

Addresses of Prev Message in Protocol at this layer = 0x0000, 0x0000, 0x0000, 0x0000, 0x0000

Select codes for the 1st 5 layers = 0xcdcd, 0xcdcd, 0xcdcd, 0xcdcd, 0xcdcd

2 Pad bytes = 0xcdcd

Pointer to KFE Buffer = 0x0000

Message Number = 2

Message Size = 38

2 Pad bytes = 0x0000

Message type = 0x10001

Status Word = 0x0000

Timestamp: Microseconds = 0x4e20

Timestamp: ClockTime = 0x44a420b8

Formatted Timestamp = 11:49:28.020000

Record/Buffer Number = 158

Number of times Msg rxed/txed = 1

Test Set Number = 1

Direction = For/Down ->

Message Data = 0xa3 0x0e 0x00 0x00 0x0a 0x00 0x00 0xea

0x6e 0x0b 0xa5 0x03 0xf0 0x0c 0x18 0x02

0x00 0x10 0x84 0x7f 0x3c 0x0c 0x05 0x3d

0x41 0x00 0x0c 0x08 0x01 0x91 0xa0 0x50

0x00 0x00 0x00 0x00 0x00 0x00

Decoded:

System Time=3747(dec)

Protocol=MAC

System Type=FDD

Multiplex Used=FALSE

SHCCH Only=FALSE

DTCH/DCCH on DSCH/USCH only=FALSE

Transport Channel=BCH

Logical Channel=BCCH

data=ea

data=6e

data=b

data=a5

data=3

data=f0

data=c

data=18

data=2

data=0

data=10

data=84

data=7f

data=3c

data=c

data=5

data=3d

data=41

data=0

data=c

data=8

data=1

data=91

data=a0

data=50

data=0

data=0

data=0

data=0

data=0

data=0

Configuration:

[Point Code Formats]

Version=1

Point Code=24 bit ANSI,24,3,321,"-",N,Member,8,Cluster,8,Network,8

Point Code=16 bit Japanese,16,1,1,"-",N,Network,16

Point Code=14 bit Korean,14,3,321,"-",N,MNA,3,SNA,4,SEP,7

Point Code=14 bit German,14,3,321,"-",N,Bereiche,3,HSVt,8,VStn,3

Point Code=14 bit CCITT (Q.708 SANC),14,2,21,"-",N,Point,3,Area,11

Point Code=14 bit CCITT (Q.708 Int),14,3,321,"-",N,Point,3,Area,8,Zone,3

Point Code=14 bit CCITT,14,1,1,"-",N,Network,14

[Point Code Mappings]

Version=1

Name=Protocol Stack1

Default Format=24 bit ANSI

[Point Code Mappings]

Version=1

Name=Protocol Stack1-1

Default Format=24 bit ANSI

[Point Code Mappings]

Version=1

Name=Protocol Stack1-1-2

Default Format=24 bit ANSI

[Protocol Stack]

Version=3

Protocol Stack=WCDMA,3G,,,,,,,,

Protocol=MTAL,2,2,wcdma_mtal, , ,Y

Protocol=PPP_HDLC,3,3,ppp_1662,18,-1,N

Protocol=PPP,3,3,ppp_1661,17,-1,N

Protocol=RLP,3,3,3gpp_r99_rlp,16.19,-1,N

Protocol=GSM_L3,3,3,3gpp_r99_gsml3,6,-1,N

Protocol=LAPDm,3,3,3gpp_r99_gsmlapdm,1,-1,N

Protocol=RLC,3,3,3gpp_r99_rlc,11,-1,N

Protocol=PDCP,3,3,3gpp_r99_pdcp,14,-1,N

Protocol=NAS,3,3,3gpp_r99_nas,13,-1,N

Protocol=RRC,3,3,3gpp_r99_rrc,12,-1,N

Protocol=MAC,3,3,3gpp_r99_mac,10,-1,N

Protocol=TCP/IP,3,3,tcp_ip,8,-1,N

Protocol=SMS,3,3,3gpp_r99_sms,5,-1,N

Protocol=GMM/SM,3,3,3gpp_r99_gmm_sm,4,-1,N

Protocol=SMS_CBS,3,3,3gpp_r99_sms_cbs,22,-1,N

[Protocol Stack]

Version=3

Protocol Stack=cdma2000,cdma2000,,,,,,,,

Protocol=MTAL,2,2,cdma_mtal,,-1,Y

Protocol=RLP TYPE 3,3,3,cdma_rlp3,04,-1,N

Protocol=PPP,3,3,ppp_1661,02,-1,N

Protocol=CDMA2000 Rev 0-2,3,3,cdma_is2000_0_2,00,-1,N

Protocol=CDMA2000 Rev A,3,3,cdma_is2000_a_2,08,-1,N

Protocol=IP,3,3,tcp_ip,06,-1,N

[Instrument]

Version=1

Instrument=Instrument1,1,0

[DASS]

Version=6

DASS=DASS1,1,1,10000,1,128,5,1,0,0,,,0000000000000000,-1

Stream Table=125,1,126

Stream Table=126,1,125

Stream Table=127,1,128

Stream Table=128,1,127

Stream Table=-1,0,0

[LIM]

Version=3

LIM=Interface1,1.1,1,7,2,0,1,0

[Momentum LAN Link]

Version=3

Link=Test Set 1,1.1.1,1,1,ppc166,Agilent Technologies 8960 Series 10 E5515C,US40480260,E6703D WCDMA Lab App D 06061550,3,0

[Stream]

Version=9

Stream=WCDMALink,1.1.1.1,WCDMA,N,1,0,128,127,0,0,0,0,0

Level2=0,,,,,,,,,,,,,,,,

Timeslots=0x00000000,0x00000000,0x00000000,0x00000000,0x00000000,0x00000000,0x00000000,0x00000000

[Stream]

Version=9

Stream=WCDMALink,1.1.1.1,WCDMA,N,1,1,127,128,0,0,0,0,0

Level2=0,,,,,,,,,,,,,,,,

Timeslots=0x00000000,0x00000000,0x00000000,0x00000000,0x00000000,0x00000000,0x00000000,0x00000000

[Momentum LAN Link]

Version=3

Link=Test Set 2,1.1.1,2,1,ppc168,Agilent Technologies 8960 Series 10 E5515C,US41070155,E6702B CDMA 2000 Lab App B B.04.14,3,0

[Stream]

Version=9

Stream=CDMA2000Link,1.1.1.2,cdma2000,N,1,0,126,125,0,0,0,0,0

Level2=0,,,,,,,,,,,,,,,,

Timeslots=0x00000000,0x00000000,0x00000000,0x00000000,0x00000000,0x00000000,0x00000000,0x00000000

[Stream]

Version=9

Stream=CDMA2000Link,1.1.1.2,cdma2000,N,1,1,125,126,0,0,0,0,0

Level2=0,,,,,,,,,,,,,,,,

Timeslots=0x00000000,0x00000000,0x00000000,0x00000000,0x00000000,0x00000000,0x00000000,0x00000000

[End Of File]

Monitor:

SetupVersion: 3

15

{20,14,0,0,0,0

T "IS-2000/IS-95/AMPS"

P+ "Sync Channel Messages"

P+ "Overhead Messages"

P+ "Mobile Station Directed Messages"

P+ "Access Channel Messages"

P+ "Forward Traffic Channel Messages"

P+ "Reverse Traffic Channel Messages"

P+ "Forward Fundamental Chan Frames"

P+ "Reverse Fundamental Chan Frames"

P+ "Forward Supplemental Chan Frames"

P+ "Quick Paging Channel Slots"

P+ "Forward RLP Frames"

P+ "Reverse RLP Frames"

P+ "Forward PPP Frames"

P+ "Reverse PPP Frames"

P+ "Forward IP Datagrams"

P+ "Reverse IP Datagrams"

P+ "Access Channel Frames"

RECEnd}

{15,13,0,0,0,0

T "WCDMA"

P+ "MAC_Broadcast"

P+ "MAC_Traffic"

P+ "MAC_Signalling"

P+ "RLC_Traffic"

P+ "RLC_Signalling"

P+ "RRC"

P+ "GMM/SM"

P+ "RR/CC/MM/TC"

P+ "PDCP"

P+ "SMS"

P+ "MTAL"

P+ "RLP"

P+ "PPP"

P+ "PPP_HDLC"

P+ "IP"

RECEnd}

{21,12,0,0,0,0

START 0 0

STOP 0 0 0 0

NO_FILTER

NO_FILTER

RECEnd}

{19,11,0,0,0,0

NO_FILTER

RECEnd}

{18,10,0,0,0,0

RECEnd}

{14,9,0,0,0,0

NO_FILTER

RECEnd}

{12,8,0,0,0,0

START 0 0

STOP 0 0 0 0

NO_FILTER

NO_FILTER

RECEnd}

{11,7,0,0,0,0

@@<LogFileData>

@@<PCM On>

@@<EndLogFileData>

RECEnd}

{7,6,0,0,5,0

0,0

@@<Columns>

kcs Version: 2

System Time,,1,93,1

Protocol,,1,61,1

MTAL Event,,0,0,1

Message,,1,68,1

Frame Type,,0,0,1

CtrlMsg,,0,0,1

ORDER,,0,0,1

Channel Type,,0,0,1

Sequence,,0,0,1

Protocol[UpperProtocol],,0,0,1

@@<EndColumns>

@@<CSV>

CSV Enabled=0

CSV Filename=C:\Program Files\Wireless Protocol Advisor\User Files\Capture Data\CaptureData.csv

@@<EndCSV>

RECEnd}

{3,5,6,0,4,0

NO_FILTER

RECEnd}

{5,4,5,0,3,0

RECEnd}

{1,3,4,0,2,0

NO_FILTER

RECEnd}

{0,2,3,0,1,0

RECEnd}

{10,1,2,0,0,0

RECEnd}

End

Second Configuration:

[Point Code Formats]

Version=1

Point Code=24 bit ANSI,24,3,321,"-",N,Member,8,Cluster,8,Network,8

Point Code=16 bit Japanese,16,1,1,"-",N,Network,16

Point Code=14 bit Korean,14,3,321,"-",N,MNA,3,SNA,4,SEP,7

Point Code=14 bit German,14,3,321,"-",N,Bereiche,3,HSVt,8,VStn,3

Point Code=14 bit CCITT (Q.708 SANC),14,2,21,"-",N,Point,3,Area,11

Point Code=14 bit CCITT (Q.708 Int),14,3,321,"-",N,Point,3,Area,8,Zone,3

Point Code=14 bit CCITT,14,1,1,"-",N,Network,14

[Point Code Mappings]

Version=1

Name=Protocol Stack1

Default Format=24 bit ANSI

[Point Code Mappings]

Version=1

Name=Protocol Stack1-1

Default Format=24 bit ANSI

[Point Code Mappings]

Version=1

Name=Protocol Stack1-1-2

Default Format=24 bit ANSI

[Protocol Stack]

Version=3

Protocol Stack=WCDMA,3G,,,,,,,,

Protocol=MTAL,2,2,wcdma_mtal, , ,Y

Protocol=PPP_HDLC,3,3,ppp_1662,18,-1,N

Protocol=PPP,3,3,ppp_1661,17,-1,N

Protocol=RLP,3,3,3gpp_r99_rlp,16.19,-1,N

Protocol=GSM_L3,3,3,3gpp_r99_gsml3,6,-1,N

Protocol=LAPDm,3,3,3gpp_r99_gsmlapdm,1,-1,N

Protocol=RLC,3,3,3gpp_r99_rlc,11,-1,N

Protocol=PDCP,3,3,3gpp_r99_pdcp,14,-1,N

Protocol=NAS,3,3,3gpp_r99_nas,13,-1,N

Protocol=RRC,3,3,3gpp_r99_rrc,12,-1,N

Protocol=MAC,3,3,3gpp_r99_mac,10,-1,N

Protocol=TCP/IP,3,3,tcp_ip,8,-1,N

Protocol=SMS,3,3,3gpp_r99_sms,5,-1,N

Protocol=GMM/SM,3,3,3gpp_r99_gmm_sm,4,-1,N

Protocol=SMS_CBS,3,3,3gpp_r99_sms_cbs,22,-1,N

[Protocol Stack]

Version=3

Protocol Stack=cdma2000,cdma2000,,,,,,,,

Protocol=MTAL,2,2,cdma_mtal,,-1,Y

Protocol=RLP TYPE 3,3,3,cdma_rlp3,04,-1,N

Protocol=PPP,3,3,ppp_1661,02,-1,N

Protocol=CDMA2000 Rev 0-2,3,3,cdma_is2000_0_2,00,-1,N

Protocol=CDMA2000 Rev A,3,3,cdma_is2000_a_2,08,-1,N

Protocol=IP,3,3,tcp_ip,06,-1,N

[Instrument]

Version=1

Instrument=Instrument1,1,0

[DASS]

Version=6

DASS=DASS1,1,1,10000,1,128,5,1,0,0,,,0000000000000000,-1

Stream Table=125,1,126

Stream Table=126,1,125

Stream Table=127,1,128

Stream Table=128,1,127

Stream Table=-1,0,0

[LIM]

Version=3

LIM=Interface1,1.1,1,7,2,0,1,0

[Momentum LAN Link]

Version=3

Link=Test Set 1,1.1.1,1,1,ppc166,Agilent Technologies 8960 Series 10 E5515C,US40480260,E6703D WCDMA Lab App D 06061550,3,0

[Stream]

Version=9

Stream=WCDMALink,1.1.1.1,WCDMA,N,1,0,128,127,0,0,0,0,0

Level2=0,,,,,,,,,,,,,,,,

Timeslots=0x00000000,0x00000000,0x00000000,0x00000000,0x00000000,0x00000000,0x00000000,0x00000000

[Stream]

Version=9

Stream=WCDMALink,1.1.1.1,WCDMA,N,1,1,127,128,0,0,0,0,0

Level2=0,,,,,,,,,,,,,,,,

Timeslots=0x00000000,0x00000000,0x00000000,0x00000000,0x00000000,0x00000000,0x00000000,0x00000000

[Momentum LAN Link]

Version=3

Link=Test Set 2,1.1.1,2,1,ppc168,Agilent Technologies 8960 Series 10 E5515C,US41070155,E6702B CDMA 2000 Lab App B B.04.14,3,0

[Stream]

Version=9

Stream=CDMA2000Link,1.1.1.2,cdma2000,N,1,0,126,125,0,0,0,0,0

Level2=0,,,,,,,,,,,,,,,,

Timeslots=0x00000000,0x00000000,0x00000000,0x00000000,0x00000000,0x00000000,0x00000000,0x00000000

[Stream]

Version=9

Stream=CDMA2000Link,1.1.1.2,cdma2000,N,1,1,125,126,0,0,0,0,0

Level2=0,,,,,,,,,,,,,,,,

Timeslots=0x00000000,0x00000000,0x00000000,0x00000000,0x00000000,0x00000000,0x00000000,0x00000000

[End Of File]

Second Monitor:

SetupVersion: 3

15

{20,14,0,0,0,0

T "IS-2000/IS-95/AMPS"

P+ "Sync Channel Messages"

P+ "Overhead Messages"

P+ "Mobile Station Directed Messages"

P+ "Access Channel Messages"

P+ "Forward Traffic Channel Messages"

P+ "Reverse Traffic Channel Messages"

P+ "Forward Fundamental Chan Frames"

P+ "Reverse Fundamental Chan Frames"

P+ "Forward Supplemental Chan Frames"

P+ "Quick Paging Channel Slots"

P+ "Forward RLP Frames"

P+ "Reverse RLP Frames"

P+ "Forward PPP Frames"

P+ "Reverse PPP Frames"

P+ "Forward IP Datagrams"

P+ "Reverse IP Datagrams"

P+ "Access Channel Frames"

RECEnd}

{15,13,0,0,0,0

T "WCDMA"

P+ "MAC_Broadcast"

P+ "MAC_Traffic"

P+ "MAC_Signalling"

P+ "RLC_Traffic"

P+ "RLC_Signalling"

P+ "RRC"

P+ "GMM/SM"

P+ "RR/CC/MM/TC"

P+ "PDCP"

P+ "SMS"

P+ "MTAL"

P+ "RLP"

P+ "PPP"

P+ "PPP_HDLC"

P+ "IP"

RECEnd}

{21,12,0,0,0,0

START 0 0

STOP 0 0 0 0

NO_FILTER

NO_FILTER

RECEnd}

{19,11,0,0,0,0

NO_FILTER

RECEnd}

{18,10,0,0,0,0

RECEnd}

{14,9,0,0,0,0

NO_FILTER

RECEnd}

{12,8,0,0,0,0

START 0 0

STOP 0 0 0 0

NO_FILTER

NO_FILTER

RECEnd}

{11,7,0,0,0,0

@@<LogFileData>

@@<PCM On>

@@<EndLogFileData>

RECEnd}

{7,6,0,0,5,0

0,0

@@<Columns>

kcs Version: 2

System Time,,1,93,1

Protocol,,1,61,1

MTAL Event,,0,0,1

Message,,1,68,1

Frame Type,,0,0,1

CtrlMsg,,0,0,1

ORDER,,0,0,1

Channel Type,,0,0,1

Sequence,,0,0,1

Protocol[UpperProtocol],,0,0,1

@@<EndColumns>

@@<CSV>

CSV Enabled=0

@@<EndCSV>

RECEnd}

{3,5,6,0,4,0

NO_FILTER

RECEnd}

{5,4,5,0,3,0

RECEnd}

{1,3,4,0,2,0

NO_FILTER

RECEnd}

{0,2,3,0,1,0

RECEnd}

{10,1,2,0,0,0

RECEnd}

End

Parsing completed at 09:44:29 AM


Logging

The Logging tab is used to specify the information to be used when saving a connection trace (see Purpose of Connection Trace) log to CSV files. CSV files produce a comma-separated list of values for use in a spreadsheet display format.

To specify CSV connection trace logging:

  1. Open a Connection Trace view.

  2. Right click in the Connection Trace window and select Configuration.

  3. Click on the Logging tab.

  4. Place a check mark in the Enable Connection Trace CSV Logging box.

  5. Enter a Filename.

  6. If you want the connection trace summary information included, select the Output Summary Information check box. (The summary information is displayed when the Summary View command is selected as shown below.)

  7. If you want the connection trace columns included, click the Export headings check box. Click the Export all columns or Export visible columns option. (All columns are displayed when the Columns command is selected as shown below.)

  8. If you want the connection trace phase information included, click the Export phase graphics check box. Click on the two options you want for phase descriptions.

  9. Click OK.