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Keysight 10 2t0l22f2| & X|

Keysight 10 Libraries Suite = HISJIE AsS22 M6t LAN, USB, GPIB,

RS-232 L JIEt EHII0AM HFIIE HIH%#—%&E% KN&ste 25 HSII M

01 ATENH Z2HEYLICH. XMlet HES AHEZHU 10 Libraries € T2 2
S35t ™ www.keysight.com/find/iosuite & Ol S3tAAIL .

Keysight VEE £ 0| E0ot0{ HZJ|12t S4I6tJ| 210 M= Keysight VEE € &£ X

at
J| &0l Keysight 10 Libraries Suite 18 € H A & XIoHOF & LICH. DLt ﬁlé £

MEGIHAl 2= &0 = Keysight 10 Libraries Suite € & XIotXl X8 &F &
2= USLICEH.

Keysight VEE Pro 9.33 2 AEH E Jt0I1& 5


www.keysight.com/find/iosuite

Keysight VEE Pro & X|

1

www.keysight.com/find/vee_download I 2 ZENHE 22 ETHNAIL.
ez d3E 2ot &X T2 02 NEoMAIL . O2es 4X
T2 )32 AHSINAIRL . InstallShield Wizard Ot & X Z2AHIAE CHLHAH &
SLICH.

The InstallShield OH& AFJt Keysight 10 Libraries Suite 18 0l &XI & A}= X
MIASLICH EXEH UK ZF2EH OIS0t 22 ALK 8 A LIEFELICH.

Keysight VEE Pro - InstallShield Wizard x

Keysight |0 Libraries Suite 2018 Update 1 or greater is not

! found.
Keysight VEE requires Keysight IO Libraries Suite 2018 Update
1 or greater for communicating with instruments.
Please install Keysight 1O Libraries Suite 2018 Update 1 or
greater after finishing this setup.

Keysight VEE Ol M HIZ D12t S &IHO0F 3t 18 M= Keysight 10 Libraries
Suite 18 0] A XTI 0f AO{OF SLICH. [H2tA 0l UHHE O TS 0l=
Keysight 10 Libraries Suite 18 Ol & 2| HH& S & XISHAIJ| HHELICY.
OKHES Z22otAJAIL . D01 A2 AT E NET ZH 213 3.5SP1 It &XI
SHU=XE X 0HHAHDE EISHLICH.
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ZE NETZHARAI35SP1 It SA EXELICH. 0122 EXl =0l=
Keysight VEE & XI 0t Ats 2 2 THIHE LICH. No tHE S 2= o™ Keysight VEE
X0t s=HELICH.

OIOIAZ2ATE NETZYAFAAILSPT I EXEN JA2H 2 SH 1 0l
M & 45 Keysight VEE & X2 XIS 8HLICH.
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Keysight VEE Pro - InstallShield Wizard X

Microsoft .MET Framewaork 3.5 5P1 is not found, please install
\MET Framewaork 3.5 5P1 first,

5 Next HE= S=6tH Ot LRt X ZAIELICH.

Keysight VEE Pro 9.33 Setup K

Welcome to the InstallShield Wizard for
Keyszight YEE Pro

The InstallShigld® WwWizard will install Kepsight YEE Pro on
your computer. To conltinue, click Mexst.

KEYSIGHT

TECHNOLOGIES

< Back Cancel
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6 IS OHLHOI S2I6tL]) , Next HES SEoHAAIL .

Keysight VEE Pro 9.33 Setup X
License Agreement
Please read the following license agreement carefully. 'I(”E:'LSIGHI

KEYSIGHT SOFTWARE END-USER
LICENSE AGREEMENT

ATTENTION: THIS SOFTWARE IS SUBJECT TO THE END-USER
LICENSE AGREEMENT ("EULA™) SET FORTH BELOW.

TO INSTALL OR USE THE SOFTWARE, YOU MUST FIRST AGREE
TO THE EULA BELOW. IF THE EULA IS PRESENTED TO YOU ¥

® agree Print
(O Do Not Agree

< Back Cancel

7 Customer Information CH 3t &k X+0ll M= Name, Company Name 3t Product Key
£ 2205t0 Next HES S5 AR . Product Key & Keysight VEE Pro

= =0

Product Key Certificate 0l A M3& LICtH.

Keysight VEE Pro 9.33 Setup

Customer Information
Flease enter your information.

User Mame:

|W’ind0ws User |

Company Mame:
Product Key [Enter E¥AL for a 30-day evaluation install)

Install this application far;

(®) Anyone who uses this computer (all users)

() Only for me [wfindows Lser)

< Back Mext Cancel
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8 [i= tHatat XtJt AT 2 Next

N2 .

Keysight VEE Pro 9.33 Setup

Choose Destination Location
Select folder where setup will install files.

Setup will install Keysight VEE Proin the following folder,

X
KEYSIGHT
TECHNOLO GIES

To install to this folder, dick Next. To install to a different folder, dick Browse and select

another folder.

Destination Folder

C:\Program Files (x86)\Keysight\VEE Pro 9.3

Browse...

< Back Cancel
9 4AXIE 2Z0t2™ Finish & 2HoIAAIL .

Keysight VEE Pro 8.33 Setup

InstallShield Wizard Complete

The InstallShield ‘Wizard has successfully installed Keypsight
WEE Pro. Click Finish to exit the wizard.

‘ez, | want to view the Readie file.

KEYSIGHT

TECHNOLOGIES

< Back Cancel
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Keysight VEE Pro & &4

AZE > DE T2 )8 > Keysight VEE Pro 9.3 > VEE Pro 9.3 € Xl 226t
Keysight VEE Pro & = Keysight VEE Express £ Ego”érél A2 .

D’“-;‘Trt”' # Untitled - Keysight VEE Pro = o %

I—He Edit View Debug Flow Device System IO Data Display Tools Database Excel MWindow Help

TS —=EH3 s B9 b1 ek F S MM @awERE BS s A Tan  @ODE,
=] | (B 6l P G| (T sy by | G B Oy

Program Explarer + 2 x|[“zMain NETE|f:]
=1 Untitled 5
o "I z
DTz -
]
Ct =
Keysight LA
13
XtAH 0 ey
He s VEE Pro 9.33
g
=
o
5
= H
%|— %4 KEYSIGHT 3
TECHNOLOGIES El
§|_ [aZ] Properties - B X ]
o g
Main (Main) - M = 3 5 ]
e I Tip of the Day
@ 2 =
s What's New We have a lot of great fips for getting the most out of
Appearance . — Web Keysight VEE Pro, so leave the Welcome window
XH Ab EF The Main Demos turned on for a while. If you turn offthe Welcome
—E-Bebadian window, itis available from the Help menu
= o Convert Infintyt False MATLAB Examples ; R
TigMode  Degrees S R—
& Design EExEmpe Togishe Tl
Declared Name Main
Declared Scope Global
Objectindex M
& Popup Panel
PopupMoveable True e F# Show tis screen at startup [NextTip | [ Close |
R PopupPanelTile Uinitled =
= = —_—
=" o Title
Tile string of the obiect
= Output
A
AHIOIH y ExecMode: VEED || PROF |[MOD [[WEB |
A Ht

Keysight VEE Pro Welcome St H0IM= VEE GIH 22088 & MATLABUHIZ2 S<
23t AISELICH. Welcome SHHA UM MZBot= 0 JlsS d&Eot] stHE
HOMAIL.

StHSHIHAME O H Z2 082 & 4 UASLICH. Ol =22 )&
-I = File > Open Example... Ol L} Help > Open Example... 2 & 35

g1 <lof

A2

0z o

pedl
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2 MU=, USBIEHHIOIAE 01 E6t0 HSIIE HZE 4Lt HA
Keysight IO Libraries Suite 18 O Bt=Al £ XI =l 0 QL0 0F & LICE.

Otch 3 EHHl OI= R H = USB HIEJ12 GPIB HIEJI0A ALEdt= 28 0l H2
Sot22 , 0tcHe HES GPIB HAFIINE B8 == JASLICH.

1 H=JIEPCUSBEEN AZot) H=II2 3= HE, M ot=30 S
OFE AL BHEHOI LIEFELITH. Next HHE S 221010 £ XIS A= S deLICH

2 T2 0| A UK L2 | Keysight VEE Pro E Al EHGHA AL . S bt
Ol Al Instrument Manager HHES B 22/518AIL .

3 Instrument Manager 3t21 0| LIEHE LICH . Find Instrument B & @ = 2ol
BPCOl HZE HA=IIE NS22 2ot &FeLICH.

Instrument Manager A X
EFL Smpl kEI LH = .;-."‘J L7]
gs wa @6 | G0 S | e
Find Instruments..

4 Identify Instrument & CH3F & XD LIEHLIH &0l 22/8HLICH. USB 21H
HOIAS JD|E s 2 AYSHLICH. 0] 0l0l A=, Keysight 34450A 57
Digit Multimeter Ot ZIH&HLICEH.
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b

Identify Instrument @

4 1 Send "*IDN?" to 'newlnstrument [ @USBInstrumentl)'?

The response to "*IDN?" provides an
accurate identification of this instrument.

Mote: Older, non 488.2 compliant instruments do not
understand this command. If this command causes an
error in the instrument, cycle the power on the
instrument to reset it.

QK Cancel

5

CH3AHXEQ] Instrument List Bl M newlinstrument & & 4610 O AEHOIA OFR

AQLEEHES SEOIH HEAE =t E2IH Create Direct 1/0 Object

H=E 2260 8 & newlnstrument Ol CHSF Direct I/0 LB R EE VEE &

AAN MHESLICH. O] LEMEES SoHA HSII0 Y S ME0HD A=
e SE2 =488 £+ ASLICH.

= USBD

B g 344500 e

'ﬁ_ﬁ Create Direct /0 Object

Add Instruments ...

=

Configure Drivers

Load Sample

EN

Open Web Interface

Delete Instrurnent Del

' Instrument Properties ...

Direct I/0 QERMEO| MM EHMMHAYIE HEZ22! 60 Direct I/0 LEHE
Ol EfMAZS =IIELICEH.

I/0 Transaction CHEHAF XA D& 0 20| "*IDN?" (1885 “” L&) 0|2t
DG D OKHES 2ol AIL B8 =S = SMENNA AIS
& 2= QeESCPIEENII SO BAELL . 8 HHHE LGN &
D s HAlE = BSEHE S8g = ASLIO OKHES 220t TS &

Keysight VEE Pro 9.33 2 AEH E Jt01&



*IDN? 2 SCPI (Standard Commands for Programmable Instruments) S & &
HEZMN 0l HEUHE E2 HS)l= M2 EEE SO D HUSLICH.

{ag34450A @USBInstrum

= Double-Click to Add Transaction =

|write | |TEXT | |r~1DN2"

IDEFAULT FORMAT j EOL ON |

ok | mnNop | cancel

8 JHI=J|IZ “*IDN?” H 22 MES US0les HSII2 S€2 Aot &LICH.
newinstrument LEMEQ HIAEAMTIE HE2E0IH MEZ2 EHMAEZ
=IIEHLICH. O|H0ll= EcH S =2 READ £ , 2 STRING FORMAT 2 2 |
Ed2xz SHELICH. OKI:H§%Eé!8FDJ PEXEN EHHOIL x HG
SMHELICH.

= | newlnstrument (ag34450A @USBInstrument1)
WRITE TEXT "™IDN?" EOL

= Double-Click to Add Transaction =

el UOTransacon |
Rew =] [ = F

ISTRING FORMAT j DEFAULT NUM CHARSl

ISCALAR vI

ok | nNop | cancel

Keysight VEE Pro 9.33 2 AEH E Jt0I1& 13
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9 0OI5Ut0ll M Display > AlphaNumeric = & &5t AlphaNumeric LEMEE

Direct I/0 QLE X E 9

Display | Teols Database

|[:J AlphaMumeric
[=2 Logging AlphaNumeric

Indicator

10 Ol H 0ll = Direct I/0 2

0t A H A E Direct 170

NIt EAE HAZ

QEZO0 BHXIELICH.
Exc
b
SR EE AlphaNumeric 2 EBRE Ol AZ5HO0F & LICEH.
QEMES ZAE0Y 2HE KIS 0122 I

HIELICH. O 4 0A OteA2 215 HHES 226t

—o s

0 etelg =2l 6H0 AlphaNumeric @B ES| HHOIL W SS&LICH.

CIAl St DR AC 2 ZE HES

S UCH.

SEotH A2 M0l 44 =0 AZ0| 0tFLl

Eﬂo

— | newinstrument (ag34450A @USBInstrument1) | 4|

READ TEXT x STR

WRITE TEXT ™IDN?" EOL

= Double-Click to Add Transaction =

11 EHIS RuntHE F

12 H=II2RH £ H=DI

— | newlnstrument (ke34450a @USBInstrument1)

<]

WRITE TEXT ™IDM?" EQL

READ TEXT x STR
= Double-Click to Add Transaction =

Keysight Technologies,34450A MY00000000,01.02-01.

x|

«| [ »

13 E 2 =184 Z File » Save As E MBS Tutorial 1.vee & M & & LICH.
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Virtual Source QHLH A

Ol SHLHM O Al = Db et 4

EEaS
T2 A=) 801 &«

1 Keysight VEE Pro Ol M , Bl =B}t 2| File > New & M &6l ME&& VEE Z2 ) &
= AMZEEHLICH. CHAl Bl =Bl Al Device > Virtual Source > Function Generator
£ MES & A A0 Function Generator LEME S MAEHLICH.

%6%04 nes ddotd LIAZd 0l ELICH. Of
E Ct.

Device | System /O Data Display Teols Database Excel Windc

Formula k'ﬁﬁ I A EEE

MATLAE Script

M

Function & Object Browser Ctrl+H

UserObject
ThreadObject

el B w

UszerFunction
Call
Import Library

! (&

Delete Library

Sequencer

Virtual Source r | E‘
Regression [
L]

Counter

unction Generator

E
P

ulse Generator

MNoise Generator

=

Keysight VEE Pro 9.33 2 AEH E Jt0I1& 15



2 CIZE MEI0ME 0l Function Generator 2| Function 2 == Cosine,
Frequency 2 &&= 200Hz, Amplitude 2= 1V 2 &850 USLICH.

= Function Generator =
Function Cosine -
Frequency 200

Amplitude | 1
DcOffset | 0 Func
Phase Deg =« IT

Time Span 20m
Mum Points 25R

3 [isUtoll A Display > XY Trace & & &SI XY Trace 2 E & E & Function
Generator 2| 220l BHXI&LICH.

Display | Tools Database Exc

] AlphaNumeric

|3 Logging AlphaNumeric

Indicator 3

|13'<x KY Trace
E‘g Strip Chart

LComplex Plane

4 Function Generator 2] ESE0IE2 XY Trace 2 Y EHOIL W HZSHAAIL .
0FR2A HAME Function Generator LB R E S HOIY 2K Z JFHIFHE OF
SAHAMII BARLE Ot01222 HAELICH. Ol MEH0IA OtRAS 2F H
E=2 220l 2lolS S8k XY Trace LB EQ| EHOIY 2K 2 0l
SELICH. CIAl 8t O1RACQ A B HES 220tH A2 H0| Mg D AA

Ol Ot=RelELIth.

Ais

ron

16 Keysight VEE Pro 9.33 2 A&t E JH0I1E



= Function Generator =
Function Cosine hd

Frequency 200
I

Amplitude
DcOffset
Phase
Time Span

Mum Points

0 Func ——&1 1

DegvlT

20m
256

5 SHIAH RuntHE F =
SELICH.

=2
=

XY Trace

¥ name

Trace1

Xname

25t XY Trace LE X E 0| 2 AR T}

6 Display > Spectrum (Freq) > Magnitude Spectrum S &
MASHD HEAAU M XY Trace Ot Ol BIXIGHA AL .

Keysight VEE Pro 9.33 &

o

=

BE

Display | Toels Database

Excel Window Help

AlphaMumeric
Legging AlphaMumeric

Indicator

2R = I =

T

XY Trace
Strip Chart

Complex Plane

Kws¥ Plot
Polar Plot

Waveform (Time)

Spectrum (Freq)

|1:.__.: Magnitude Spectrum

A

Picture

Phase Spectrum

17
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7 4SHUIN 2YE AN M
EOIZ0IA & BT 2102 445

BHOIL0 &2 2Z2 °‘LI Ct.

8 Run HHE

olat
SRl

=2 A= SH0 Function Generator 2| &
tOd Magnitude Spectrum @EXME Q| i &

4 % 22/5t0 Magnitude Spectrum LEXEQ| CIAZH0IEE

SAIL . DARITIAE O =1k 200Hz 0l 22 , Magnitude Spectrum 2
EQ "*Oil 200Hz Ol T 3A0F M ELICEH.

= Function Generator =

Function m

Frequency 200

Amplitude [ 1

DcOfset | 0 | Funcf———1
Phase m [ 0

Time Span 20m

Mum Points 25R

= XY Trace =
¥ name
Trace1
- L
1 |
1] 4m am 12m 16m 20m
Xname
= Magnitude-Spectmm =]
140
Mag  4ap
100
80
60
Trace1 40
20

4 »]

a 2000 4000 B000T000

Freq

Keysight VEE Pro 9.33 2 AEH E Jt01&



9 Function Generator 2 B & E 0| M Function

A2 .

Function
Freguency
Amplitude
DcOffset

Phase

Time Span

Mum Points

10Run HE F#
ol JefEZE SA

Sguare "I

Sine
Cosine
Tri
+Ramp
-Ramp
DcOnly

256

£ 2¢&iotd X0l
=

ol A2

Keysight VEE Pro 9.33 2 AEH E Jt0I1&

ZCE Square g oz #

A2 . Keysight VEE = 0421 i
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20

— XY Trace =

-
Function Generator = Y name

Function m

Frequency | 200

Amplitude | 1

DcOffset | 0 | Funcf————
Phase Deg - |T Trace1

Time Span 20m

Mum Points 25h 4 b
- 0 Am Bm 12m  16m 20m
Xname
- Magnitude Spectrum =
180
Mag 160
140
120
100
80
— &0
Trace1l 4, U.
20 .
0 U |JiIJHthl_Iﬁn_llln_lll._lll._ll'._ll'._l"._l‘._l"._l‘._
4 |
0 2000 4000 60007000
Freqg

11 X2S20A H-st T2 )= W00l A File > Save As £ & &G Tutorial
2vee & MEIEAIL.
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Keysight VEE 9.33

ANAE R ALE

Keysight VEE 9.33 2 CI=2

Sl ME2 Jls

o
T'__%:‘

HHME X2 ELICH.

S of 77 Windows 7 SP1 Windows 8 & Windows Windows 10(32 HIE & Windows 11
=< (B2HIE X 64HIE) 813N HIELGLHIE)B4HIE) (64HI E)
1GHz 32 H| E (x86)
=5 ’ =
Z2 MM 1GHz 32 H| E (x86), 1GHz 64 HI € (x64). 1GHz 32 HI E (x86), 1GHz 6481 € (x64),
= 1GHz 64 H1 £ (x64), i 1GHz 64 B1 £ (x64), . i
=T taniumB4 X 2 oF st ltaniumb4 &£ = taniumB4 X2 OF &t [tanium64 0| X &
= =% Windows8RT X ©F & -
ME IS8 022 = 2 1GB 24 1GB =4 1GB | A 4GB
_ A2 Jts 8t A2 Jts 8t _
2 Jl=5F DI} st 2ot
fg‘g;;‘%r;‘o' 22401 2568 ¢! B2+0] 2.5GB 2! 2*5680*"’6}‘:‘310'3
'~ s SECAIENSE GE02IEU8 Lo Do
A3s=uss o o= Cles ZasLc
— ZeEgut S ZEELICH.
seeLn - Microsoft.NET - Microsoft NET - MicrosoftNET
AME IS8t 8tE - Microsoft.NET Framewo'rk35 246 Framewo.rk35 246 Framework 3.5 &
cAa3 el Framework 46 2168 oo™ o ; o o AmE 4o LOSWBEASE
ArSE > AsUT. T =T = =T ausuch
Cevsiaht 10 Lib =5 SLICH. et 10 Lbar
B Eey(sjlg;t O Libraries Suite. _ Keysight 10 Libraries - Keysight 10 Libraries ey3|g]EtoO;| ranes
= 9laH 100mB Ol Aol ~ LI S Suite= <15 100MB
ZQsrL|Ch Suite £ <I0H 100MB  Suite £ </ 100MB 040 = QEHLICH
= ' O|AOl 2ERELICH. Ol&0l 2RELIC. < '
[a] EXIEXZ ool 29 e X HECH A2 HIZ2DIEE 4= UASLICH.

Microsoft Office Excel XI & JtsH

KeysightVEE 9.33( &

2016 ¥ Office 365 E NI & &fLICH.
LICEH.

2 NJAX A5

0l4) JI&E W& Excel O

%= Microsoft Office Excel 2013,
ot Xl 8+ Microsoft Office Excel 2] M2 Jls

Lt Keysight = St2 & AtE XIS 218 Keysight VEE Student & Keysight
Education H& = M Z&LICEH.

Keysight VEE Pro 9.33 2 AEH E Jt0I1&
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Keysight Connectivity Xl &
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