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Technology Licenses 

The hardware and/or software described 
in this document are furnished under a 
license and may be used or copied only in 
accordance with the terms of such 
license.

Declaration of Conformity

Declarations of Conformity for this prod-
uct and for other Keysight products may 
be downloaded from the Web. Go to 
http://keysight.com/go/conformity.
 You can then search by product number 
to find the latest Declaration of Confor-
mity. 

U.S. Government Rights

The Software is “commercial computer 
software,” as defined by Federal Acquisi-
tion Regulation (“FAR”) 2.101. Pursuant 
to FAR 12.212 and 27.405-3 and Depart-
ment of Defense FAR Supplement 
(“DFARS”) 227.7202, the U.S. govern-
ment acquires commercial computer 
software under the same terms by which 
the software is customarily provided to 
the public. Accordingly, Keysight pro-
vides the Software to U.S. government 
customers under its standard commercial 
license, which is embodied in its End 
User License Agreement (EULA), a copy 
of which can be found at http://
www.keysight.com/find/sweula. The 
license set forth in the EULA represents 
the exclusive authority by which the U.S. 
government may use, modify, distribute, 
or disclose the Software. The EULA and 
the license set forth therein, does not 
require or permit, among other things, 
that Keysight: (1) Furnish technical infor-
mation related to commercial computer 
software or commercial computer soft-
ware documentation that is not custom-
arily provided to the public; or (2) 
Relinquish to, or otherwise provide, the  
government rights in excess of these 
rights customarily provided to the public 
to use, modify, reproduce, release, per-
form, display, or disclose commercial 
computer software or commercial com-
puter software documentation. No addi-
tional government requirements beyond 
those set forth in the EULA shall apply, 
except to the extent that those terms, 
rights, or licenses are explicitly required 
from all providers of commercial com-
puter software pursuant to the FAR and 
the DFARS and are set forth specifically 
in writing elsewhere in the EULA. Key-
sight shall be under no obligation to 
update, revise or otherwise modify the 
Software.  With respect to any technical 
data as defined by FAR 2.101, pursuant 
to FAR 12.211 and 27.404.2 and DFARS 
227.7102, the U.S. government acquires 
no greater than Limited Rights as defined 
in FAR 27.401 or DFAR 227.7103-5 (c), as 
applicable in any technical data.

Warranty

THE MATERIAL CONTAINED IN THIS 
DOCUMENT IS PROVIDED “AS IS,” AND 
IS SUBJECT TO BEING CHANGED, 
WITHOUT NOTICE, IN FUTURE EDI-
TIONS. FURTHER, TO THE MAXIMUM 
EXTENT PERMITTED BY APPLICABLE 
LAW, KEYSIGHT DISCLAIMS ALL WAR-
RANTIES, EITHER EXPRESS OR IMPLIED, 
WITH REGARD TO THIS MANUAL AND 
ANY INFORMATION CONTAINED 
HEREIN, INCLUDING BUT NOT LIMITED 
TO THE IMPLIED WARRANTIES OF MER-
CHANTABILITY AND FITNESS FOR A 
PARTICULAR PURPOSE. KEYSIGHT 
SHALL NOT BE LIABLE FOR ERRORS OR 
FOR INCIDENTAL OR CONSEQUENTIAL 
DAMAGES IN CONNECTION WITH THE 
FURNISHING, USE, OR PERFORMANCE 
OF THIS DOCUMENT OR OF ANY INFOR-
MATION CONTAINED HEREIN. SHOULD 
KEYSIGHT AND THE USER HAVE A SEP-
ARATE WRITTEN AGREEMENT WITH 
WARRANTY TERMS COVERING THE 
MATERIAL IN THIS DOCUMENT THAT 
CONFLICT WITH THESE TERMS, THE 
WARRANTY TERMS IN THE SEPARATE 
AGREEMENT SHALL CONTROL.

Keysight Technologies does not warrant 
third-party system-level (combination of 
chassis, controllers, modules, etc.) per-
formance, safety, or regulatory compli-
ance unless specifically stated.

Safety Information

A CAUTION denotes a hazard. It calls 
attention to an operating procedure 
or practice that, if not correctly per-
formed or adhered to, could result in 
damage to the product or loss of 
important data. Do not proceed 
beyond a CAUTION notice until the 
indicated conditions are fully under-
stood and met. 

A WARNING denotes a hazard. It 
calls attention to an operating pro-
cedure or practice, that, if not cor-
rectly performed or adhered to, 
could result in personal injury or 
death. Do not proceed beyond a 
WARNING notice until the ind icated 
cond itions are fully understood and 
met. 
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M9192A/M9193A DSR Pattern Editor
Startup Guide
Introduction

This manual covers installation, startup and basic use of the: 

- M9192A Digital Stimulus/Response Pattern Editor software (Pattern Editor 
Software in this guide). The Pattern Editor Software is an integrated logic 
analyzer graphical editor for development and analysis of digital tests. 

- M9193A DSR Pattern Editor with Data Converters software that provides 
conversion utilities for WGL, EVCD, and other waveform file formats. The 
M9192A Pattern Editor Software is required to use the M9193A DSR Pattern 
Editor with Data Converters software.

This Startup Guide does not provide a detailed description for using the software 
nor describes all of its features; for detailed user information, refer to the 
software help file (start the software, then click Help > Manual). 

The software, sourced from TSSI SolsticeTM, provides software waveform pattern 
editing for the Keysight M9195A/B PXIe Digital Stimulus/Response (DSR) 
module.

Key features of the software include:

- Edit test patterns in a self-documented, executable flow-diagram

- Debug failing patterns by identifying precise failure location and details

- Reproduce problems in the same simulation environment

- Correlate patterns across various formats and platforms

- Integration with leading logic simulators enables a prompt view of differences 
between expected ATE pattern states and that of the DUT. 

- The graphical user interface (GUI) shows strobe placement, the nature of 
failure, and the correlation of the design timestamps vs. tester cycle.

- Failure information is available in text logs for post-processing use in any of 
the custom simulation environments. View failures by dragging and dropping 
the error log file into the software's waveform editor.  Both EDA's error format 
(from simulators or ATPG tools) and STDF (ATE standard data failure format) 
are supported.

The M9192A software editor requires additional licensing. See 
“Licensing the DSR Pattern Editor Software” on page 9.
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Introduction System Requirements
System Requirements

Software Installation

The software can be downloaded at: www.keysight.com/find/M9192A

1 Select the Trials & Licenses tab.

2 Click the Details & Download button.

3 Read the instructions and click the red Download button. Follow all on-screen 
instructions.

Running the Software

1 From the Windows Start button, select All Programs.

2 Scroll down to Keysight then select DSR Pattern Ed itor.

Windows Requirements

Operating System Windows 7 SP1 32-bit and 64-bit
Windows 8 and 8.1 (32-bit and 64-bit)

Processor Speed 2 GHz 64-bit (x64)

Available Memory 4 GB minimum (8 GB recommended for 64-bit OS)

Available Disk Space 
necessary for installation

300 Mb

S

A free trial version of the software is available. This trial version 
may be used for 30 days with no obligation. After 30 days, you 
must purchase a software license to continue using the software. 
Each PC requires a separate license. For purchasing information, 
go to:
www.keysight.com/find/M9192A
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Licensing the DSR Pattern Editor Software Introduction
Licensing the DSR Pattern Editor Software

The DSR Pattern Editor Software can be installed and used for 30 days with a 
temporary license. After 30 days a permanent software license is required to 
continue to use the software. Each PC requires a separate software license. For 
software and licensing information, go to: www.keysight/com/find/M9192A

1 Once you purchase the Pattern Editor Software, you will receive an 
Entitlement Certificate email describing how to redeem your license. Note 
that when purchasing the software, you will be given the choice to receive a 
printed copy of the Entitlement Certificate, an email with the certificate, or 
both.

2 On the PC where you have installed and plan to run the Pattern Editor 
Software (you must be logged on with Administrator privileges), log onto 
Keysight’s Licensing website at: www.keysight.com/find/softwaremanager. 
Note, you will need to register if you don’t have an account.

3 Follow the instructions in the Entitlement Certificate to redeem the license. 
You will need to enter the Entitlement Certificate number and the host ID of 
the PC (see page 10 of this guide for host ID information). 

4 Once you have entered the information, a license file is emailed (as an 
attachment) to the PC. The licesnse file has a .lic file extension; for example: 
10000996212_829728.lic.

5 In this email, save the attached license file to a temporary location on the C: 
drive of the computer where you have installed the Pattern Editor Software.

6 Start the Keysight License Manager on your computer. Click Windows Start > 
All Programs > Keysight License Manager > Keysight License Manager.

7 Use File > Install to browse and open the license file that was attached to this 
message and then minimize Keysight License Manager.

8 An Install License File(s) window appears. In this window, browse to the location 
where you saved the license file. Select the license file, and then click the 
Open button.

The license is automatically installed and now appears in the Tree View of the 
Keysight License Manager as an installed license under the host system. The 
Pattern Editor Software is now licensed and ready for use.

For the 30 day temporary license, you will receive installation 
instructions and a license valid for 30 days.

Installing the DSR Pattern Editor software installs the Keysight 
License Manager software on your PC (if it was not previously 
installed by other Keysight software).
Keysight M9192A / M9193A DSR Pattern Editor Startup Guide 9
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Introduction Licensing the DSR Pattern Editor Software
Transporting a license to another host PC

To easily transport a license, Keysight recommends that you configure your 
system so that the host system running Keysight License Manager (KLM) 
connects both to the Internet and to the LAN connecting the source and target 
systems.

- The system running KLM can be the source system, the target system, or a 
separate Windows-based computer. 

- When the source system and the target system both have LAN connectivity, 
you can use a simple drag-and-drop action to transport a license using KLM. 

KLM automatically removes a transported license from the source system. The 
license is then re-issued by the Keysight Software Manager Transport License 
Web Service, and then installed onto a target system

For additional information and procedures to transport a license, refer to the 
Keysight License Manager Help:

1 Open the About Keysight License Service dialog box:

a Double-click the Keysight License Manager icon  in the Windows 
toolbar. (If the icon is hidden, click the “Show hidden icons” button on the 
right side of the toolbar.

b Click Help > Keysight License Manager Help.

Your PC Host ID

A Host ID is a permanent, unique identifier to a computer or a Keysight 
instrument or application that locks licenses to that particular computer, 
instrument or application. If the host information provided at the time the license 
is generated is wrong, then the license will not enable the features purchased.

Where can I find the Host ID?

The Keysight License Manager Application is included with your Keysight 
software product. It is installed on your computer when you install your Keysight 
software product.

To transport a license, KLM must connect to the services available 
on the Keysight Software Manager Transport License Web site. 
This connection takes up to 90 seconds to complete a license 
transport operation.

It is important that you enter the correct host ID information. Your 
license will not enable the software if the host information does not 
exactly match your instrument or application.
10 Keysight M9192A / M9193A DSR Pattern Editor Startup Guide



Licensing the DSR Pattern Editor Software Introduction
To obtain a Host ID from the Keysight License Manager (KLM) application, follow 
these steps:

1 Open the About Keysight License Service dialog box:

a Right-click the Keysight License Manager icon  in the Windows 
toolbar. (If the icon is hidden, click the “Show hidden icons” button on the 
right side of the toolbar.

b Select the About Keysight License Service.

2 Click the Copy Host ID link to copy the host ID to the Windows clipboard.

3 You can request a license file from: www.keysight.com/find/softwaremanager. 
A Keysight order number, Entitlement Certificate numbers and Host ID, from 
Step 2 above, are required.

Figure 1 Keysight License Service Dialog Box

Host PC ID
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Using the M9192A Pattern Editor Software with the M9195A/B DSR

Because the M9192A Pattern Editor Software is an editing tool (not a tool for 
creating waveform patterns and vectors), you must first create an initial pattern 
file to import into the Pattern Editor Software. This initial file is most commonly a 
STIL file. Other file formats supported include an ASCII file or WGL file.

Starting the Pattern Editor Software

To start the software: 

- On Windows 7:

– Select Start > All Programs > Keysight > MDsr > M9192A Pattern Ed itor.

- On Windows 10:

– Select Start > All Apps > Keysight > M9192A Pattern Ed itor

Figure 2 shows the basic layout of the M9192A software screen.

Example Programs. The Pattern Editor Software help file provides 
complete scenarios (an initial standard STIL file, a STIL file that was 
exported from the M9195A/B Soft Front Panel, and ASCII Signal 
and Pattern files) to help you understand how to use the software. 
The help file also includes a detailed example of importing a file 
into the M9195A/B Soft Front Panel. Refer to the Pattern Editor 
Software help file for detailed information demonstrating how to 
use the software (start the Pattern Editor Software, then click Help 
> Manual). 
12 Keysight M9192A / M9193A DSR Pattern Editor Startup Guide



Using the M9192A Pattern Editor Software with the M9195A/B DSR Introduction
Figure 2 Basic Layout of the M9192A Display
Keysight M9192A / M9193A DSR Pattern Editor Startup Guide 13



Introduction Additional Information
Additional Information

Pattern Editor Software Documentation

The Pattern Editor Software help file is installed when you install the software 
and is available by clicking:

Start > All Programs > Keysight > DSR Pattern Ed itor Help

Complete Pattern Editor Software and documentation is available at:

www.keysight.com/find/M9192A

As long as you subscribe to the M9192A Support, you will be notified by email 
when software updates are available and how to obtain them.

M9195A/B documentation

Documentation for the M9195A/B PXIe Digital Stimulus/Response module is 
available by clicking:

Start > All Programs > Keysight > MDsr

The latest documentation and any firmware upgrades are available at:

www.keysight.com/find/M9195B
14 Keysight M9192A / M9193A DSR Pattern Editor Startup Guide

http://www.keysight.com/find/M9192A
http://www.keysight.com/find/M9195A




This information is subject to change 
without notice.
© Keysight Technologies, 2016
Edition 1 May 2016
Printed in Malaysia

*M9192-90001*

M9192-90001
www.keysight.com

http://www.keysight.com

	Keysight M9192A DSR Pattern Editor and M9193A DSR Pattern Editor with Converters
	Software waveform pattern editing for the M9195A/B PXI DSR module
	Startup Guide

	Contents
	Introduction
	System Requirements
	Software Installation
	Running the Software

	Licensing the DSR Pattern Editor Software
	Your PC Host ID

	Using the M9192A Pattern Editor Software with the M9195A/B DSR
	Starting the Pattern Editor Software

	Additional Information
	Pattern Editor Software Documentation
	M9195A/B documentation



