Welcome to the Agilent TD-SCDMA GGE Fast Switch Help

Welcome to the

Agilent E1969A

TD-SCDMA_GSM Fast Switch

Test Application Help

Updated E1969A Revision: A.05.14

Last Updated: April 19, 2012

Legal Information

This help describes how to use the Agilent E1969A TD-SCDMA_GSM Fast Switch Test Application on your E5515C Wireless Communication Test Set. The E1969A Fast Switch Test Application combines the TD-SCDMA and GSM/GPRS/EGPRS test applications together and allows you to switch between them very quickly.

This is only used as the TD-SCDMA test application user manual. The online version of this manual is available at http://wireless.agilent.com/rfcomms/refdocs/tdscdma/. If you want to know more on how to use the GSM/GPRS/EGPRS test application, click here for the latest E1968A GSM/GPRS/EGPRS user manual.

The Contents tab on the left provides access to all of the information contained within this help:

  • Configuration: Includes the system configuration information of the test set. Manual operations can be accessed by the left and right menus after pressing the SYSTEM CONFIG hardkey. Register and utility functionalities are also included.

  • Call Processing: Includes base station emulation and call processing functionalities of the test set. Manual operations can be accessed by the left and right menus after pressing the CALL SETUP hardkey.

  • Measurements: Includes all the measurements supported by the test set. Manual operations can be accessed by pressing the MEASUREMENT SELECTION hardkey.

  • How Do I...: Includes information on how to use the important features of the test set.

  • GPIB commands: Includes details on all of the GPIB syntax available to control the test set by remote program. This is mainly organized by the GPIB command subsystem.

  • Troubleshooting: Includes all the error message that may be shown on the test set. This is mainly organized by the error number.

  • Release Notes: Lists the features and functionality of the applications for each release of the firmware.

If you have trouble finding the information you need, use the search tab on the left to search the contents.

Copyright © Agilent Technologies, Inc. 2012


Fast Switch Between TD-SCDMA and GSM

Last updated: March 10, 2010

Description

The E1969A TD-SCDMA_GSM Fast Switch test application allows you to switch between GSM/GPRS/EGPRS and TD-SCDMA test applications very quickly if the required license is available.

If the required license and calibration file is available, the default boot-up format for the E1969A application is TD-SCDMA. If not, and you have the required license, you can do the following to make TD-SCDMA as the default boot-up format: 1), fast switch to TD-SCDMA (see How Do I Switch Formats?); 2), perform a full calibration of the test set (see Calibrating the Test Set).

Select SYSTEM CONFIG and then the Format Switch for viewing and switching formats. See How Do I Switch Formats?

For how to switch between formats using GPIB command, see Format Switch Example Using GPIB.

How Do I Switch Formats?

A. Choose a format.

  1. Press the SYSTEM CONFIG key.

  2. Press the Format Switch ( F2 ) key.

B. Switch formats.

  1. Turn the knob to highlight the desired format.

  2. Press the knob to switch formats.

Format Switch Example Using GPIB

Here are two examples on how to switch format using GPIB command. For more information, refer to SYST:APPL:FORM[:NAME].

OUTPUT 714;"SYST:APPL:FORM 'TD-SCDMA'" !Switch the current format to TD-SCDMA.

OUTPUT 714;"SYST:APPL:FORM?" ! Query the current format in the current application.


Configuration

This page provides links to configuration information including: Control (items in the Control menu, such as GPIB and LAN configuration, amplitude offsets and application/format switching), Utilities (items in the Utilities menu, such as message log, calibrations and self test) and Other Configuration Information (test set identification, hardware configuration etc.).

If you have trouble finding the information you need, use the search tab on the left to search the contents of this help.

Control

  • Instrument Setup

  • Format Switch

  • Application Selection

  • Amplitude Offset

  • RF Output Port

  • AUDIO OUT port and FM Demodulation

  • Instrument IP Info/Instrument IP Setup

Utilities

  • Message Log

  • License Status

  • Calibration Service

  • Self Test

  • Thermal Power Null Adjustment

Other Configuration Information

  • Front Panel Connectors

  • Rear Panel Connectors

  • Remote/Local Mode

  • Help Mode

  • IP Address Requirements

  • Save and Recall Registers

  • User Interface (UI) Log

  • Verifying the Test Set

  • Calibrating the Test Set


Instrument Setup

Last updated: April 19, 2012

  • Configuring the Test Set's GPIB

  • Configuring the Test Set's LAN

  • LAN IP Address

  • LAN Default Gateway

  • LAN Subnet Mask

  • Display Mode (Track/Fast)

  • Display Brightness

  • Test Set Beeper

  • System Time and Date

  • Restart on Fatal Error

Configuring the Test Set's GPIB

The GPIB address is an integer between 0 and 30. The test set comes with a default address of 14 and may be set/queried using the SYSTem subsystem or manually through the system configuration screen by selecting the parameter and changing the number with the knob or the keypad.

The GPIB address is a non-volatile parameter. The GPIB address is not affected by any reset operation and can only be changed by direct access to the parameter itself.

Configuring the Test Set's LAN

LAN IP Address

The LAN address is a character string with a maximum of 15 characters and a format of A.B.C. D where A is between 0 and 223 (excluding 127, which is assigned for use as the Internet host loopback address), and B, C, and D are between 0 and 255. No embedded spaces are allowed. The address may be manually set/viewed in the system configuration screen. The LAN address can be set/queried using the SYSTem subsystem.

The LAN address is a non-volatile parameter. The LAN address is not affected by any reset operation and can only be changed by direct access to the parameter itself.

  • Please always verify that the test set is responding to a new LAN IP Address by pinging the test set.

  • If the LAN address is set to a different network class, the subnet mask will change to the default net mask for the new network class.

For convenience the DATA port on the front panel may be configured as a LAN port. When an RJ45 jumper cable, (part number E5515-61160) is connected from the LAN PORT on the rear panel, to the ETHERNET TO FRONT PANEL port also on the rear panel, the user has LAN access from the front panel of the test set. Without the RJ45 jumper cable, the test set connection to a LAN is the rear-panel, LAN PORT connector.

The LAN address cannot be changed when the Operating Mode is set to Active Cell .

LAN Default Gateway

The LAN router, (default gateway), is a character string with a maximum of 15 characters and a format of A, B, C, D, where A is between 0 and 223 , and B, C, and D are between 0 and 255, no embedded spaces are allowed. If the default gateway is set to a format not allowed with the LAN address or the subnet mask that have been selected, the default gateway will be set to a null string, indicated by a blank field on the test set display. The address may be manually set/viewed in the system configuration screen. The LAN default gateway can be set/queried using the SYSTem subsystem.

The LAN default gateway is the address of a router that routes messages between networks and or subnets. If this value is not specified, LAN communications will be limited to the network and subnet specified by the LAN IP address and the subnet mask. Your network administrator will know if a default gateway is needed and if so, the address of the router. If the default gateway address is not needed by your network, it may be disabled by entering any of the following values: "0" (zero), "" (null string), "0.0.0.0"

The LAN default gateway is a non-volatile parameter. The LAN default gateway is not affected by any reset operation and can only be changed by direct access to the parameter itself.

LAN Subnet Mask

The LAN subnet mask address is a character string with a maximum of 15 characters and a format of A, B, C, D, where A , B, C, and D are between 0 and 255. No embedded spaces are allowed. The address may be manually set/viewed in the system configuration screen. The LAN subnet mask address can be set/queried using the SYSTem subsystem.

The subnet mask number combined with the IP address identifies which network and subnet your computer is on. Contact your system administrator for the correct subnet mask for your network.

The subnet mask determines the boundaries between the subnet ID and the host ID.

The LAN subnet mask is a non-volatile parameter. The LAN subnet mask is not affected by any reset operation and can only be changed by direct access to the parameter itself or by changes to the LAN IP Address.

The subnet mask number is obtained from your network administrator.

If the LAN address is set to a different network class, the subnet mask will change to the default net mask for the new network class.

Display Mode (Track/Fast)

There are two display modes to select from when operating the test set remotely.

  • Display mode fast

When operating remotely, there is often no need for the display to be updated as measurements are made. Using the fast display mode will increase the speed of the test set when it is operated remotely.

Fast mode is designed for remote use only. The test set returns to track mode if you change to manual operation.

No screen or menu items are visible (except error messages).

Error messages will be displayed in their normal location.

"This instrument is being operated remotely" will be displayed at the bottom of the screen.

  • Display mode track

The track display mode is used to allow users to see what the test set is doing while it is being controlled remotely. Track mode is the default mode of the test set.

Any changes made remotely will be updated on the screen if that screen is displayed.

The error message window will be displayed as required when an error occurs.

Display Brightness

This parameter allows you to adjust the brightness of the test set's display. The test set's display screen has two brightness settings:

  • medium brightness

  • high brightness

Test Set Beeper

This parameter allows you to change the beeper state to on or off. A beep will indicate error conditions caused during manual or remote operation of the test set.

A 100 ms, 1.24 kHz audible tone (beep) is generated when an error message is logged and the beeper state is set to on. If two errors are generated in quick succession, two beeps are generated to indicate that more than one error has been logged.

System Time and Date

  • The test set provides the following time and date settings:

  • Time - This field provides entry of the local time in hours and minutes. The Universal Coordinated Time field will track changes made to the Time field.

  • Date - This field provides entry of the local date.

  • Universal Coordinated Time (UTC) - Also known as Zulu, Greenwich Mean Time, or UCT, this field provides entry of universal time in hours and minutes.

The Time field will track changes made to the Universal Coordinated Time (UTC) field.

  • Universal Coordinated Time (UTC) Date

  • Time Zone

The Time Zone field provides entry of a time offset to the universal coordinated time (UTC). Based on each new time zone setting and the current UTC, a new local time value is calculated and automatically entered into the Time field.

Restart on Fatal Error

The Restart on Fatal Error feature provides the ability to configure the test set to automatically restart when a fatal error occurs. Restart on Fatal Error does not apply when a fatal error occurs during the test set's power up sequence.

The Restart on Fatal Error State is retained regardless of whether the test set is restarted manually or through the Restart on Fatal Error feature. The test set's default setting for the Restart on Fatal Error State is Off. If the Restart on Fatal Error State is set to On and a fatal error occurs, the test set prints the fatal error condition on the test set's front panel. The test set then waits 25 seconds before restarting.

The following error message is then displayed on the test set's front panel once the test set completes its power up sequence: " Warning; 8960 has been restarted after a non-recoverable error occurred. "

Related Topics

GPIB Commands: SYSTem, DISPlay


Format Switch

Description

Some radio formats are combined as fast switching applications. For example, the E1969A TD-SCDMA_GSM fast switch test application allows you to switch between GSM/GPRS/EGPRS and TD-SCDMA formats very quickly (in less than 2 seconds) if the required license is available.

To fast switch between TD-SCDMA and GSM/GPRS/EGPRS test applications, refer to Fast Switch Between TD-SCDMA and GSM.

Related Topics

GPIB Commands: SYSTem:APPLication:FORMat[:NAME]


Application Selection

Last updated: March 31, 2010

Description

Different radio formats (such as TD-SCDMA, GSM, CDMA 2000 or TIA/EIA 136) can be tested when applications are purchased from Agilent Technologies. Different revisions of the applications in your test set provide different capabilities. The test set allows you to switch between different applications, and once you select a revision the revision does not change unless you select another revision. Switching to another application takes about one minute.

To perform Application Selection, press the SYSTEM CONFIG key, followed by the Application Selection key.

License Status

Revisions are shown with their license status. After the revision number is a letter. That letter indicates the revision license status; Licensed "L", Not Licensed "N", or Unknown "U".

"L"- This revision of application appears to have a License. The application may have been developed before licensing and therefore needs no license.

"N" - This application does not appear to have a license.

"P" - Some Part of the application does not appear to have a license.

"U" - This application has Unknown license status.

Related Topics

GPIB Commands: SYSTem:APPLication


Amplitude Offset

Last updated: March 31, 2010

  • Description

  • Setting Up Amplitude Offsets and Frequency Points

  • Examples of Amplitude Offset Behavior

  • Amplitude Offsets Between Frequency Settings

Description

Amplitude offsets compensate for loss or gain between the test set's RF IN/OUT front panel connector and the mobile station's RF connector.

To access the amplitude offset feature, press the SYSTEM CONFIG key, followed by the RF IN/OUT Amptd Offset ( F5) key.

Amplitude offset settings are preserved during power cycles or instrument preset.

Setting Up Amplitude Offsets and Frequency Points

Up to 60 frequency points can be assigned an amplitude offset. Negative amplitude offset values should be entered when there is a loss through the RF cabling and test fixtures and positive values should be entered when there is a gain.

The RF IN/OUT Amplitude Offset table displays the current (on/off) state of the amplitude offset feature. There are also 60 rows for entering frequencies and 60 rows for entering corresponding offset values. To enter values in the table use the RF IN/OUT Amplitude Offset Setup menu.

Turning amplitude offsets on/off

When the RF IN/OUT Amplitude Offset State is on, all offsets that are not individually turned off are applied and the word "Offset" appears in the Instrument Status Area of the test set's display.

If the RF IN/OUT Amplitude Offset State is off, none of the amplitude offsets are applied.

If the RF IN/OUT Amplitude Offset State is turned off , none of the amplitude offsets are on, even if values are entered for the individual offsets.

Examples of Amplitude Offset Behavior

When the amplitude offset table entries accurately represent the loss in all components (cabling, connectors, and test fixturing) in the signal path between the test set and the mobile station, the test set will make the necessary adjustments in both receiver and transmitter measurements.

Mobile Station Receiver Example

When you set a transmit power level, the test set uses the amplitude offset value to adjust the power so that the test set's transmit power level refers to the power level received at the mobile station.

As shown in the picture below , with the test set's transmit power set to -85 dBm and a -3 dB amplitude offset the actual power level transmitted from the test set will be automatically offset to -82 dBm. With a 3 dB loss in the signal path the mobile station will receive -85 dBm, the actual setting.

Amplitude Offset Mobile Station Receiver Example

Mobile Station Transmitter Example

When you measure power from the mobile station, the displayed and queried values are offset to show the level at the mobile station.

As shown in Amplitude Offset Mobile Station Transmitter Example , with the mobile station transmitting 12 dBm and a -3 dB amplitude offset is entered, the measured power at the test set would be 9 dBm. The displayed power level is automatically adjusted to 12 dBm to show the level at the mobile station.

If the expected power, which can be set manually or automatically is 12 dBm, the test set's internal hardware adjusts itself to receive 9 dBm which is the actual power from the mobile station after 3 dB loss in the network.

Amplitude Offset Mobile Station Transmitter Example

Amplitude Offsets Between Frequency Settings

If mobile station testing is performed at frequencies that do not have amplitude offsets assigned to them, the test set will estimate an amplitude offset based on the nearest settings. For example, the following screen shows five amplitude offsets for frequencies ranging from 890.2 MHz to 1710.2 MHz.

RF IN/OUT Amplitude Offset Setup

For test frequencies between the lowest (890.2 MHz) and highest (1710.2 MHz) frequency points that are not entered in the table, the test set will calculate offsets using piece-wise linear interpolation.

The graph shown in Amplitude Offset Interpolation is a conceptual representation of the test set's amplitude offset configuration using the settings from the RF IN/OUT Amplitude Offset table in RF IN/OUT Amplitude Offset Setup . Each of the five points are shown on a non-scaled frequency versus amplitude offset graph. At a test frequency of 890.4 MHz, which is midway between point number one (-1 dB) and point number two (-2 dB) the test set applies an offset of -1.5 dB. Be aware that since amplitude offsets are in units of dB, this piece-wise linear interpolation does not produce a linear transition from point to point.

Amplitude Offset Interpolation

If testing is done outside the range of frequencies bounded by the lowest and highest frequency entries, the test set simply uses the amplitude offset that is paired with the nearest frequency point.

It is highly recommended that amplitude offsets are set up for each test frequency. This eliminates inaccuracies due to the mismatch between the test set's linear interpolation and the actual frequency response of the RF path between the test set and mobile station.

Related Topics

GPIB Commands: SYSTem:CORRection


RF Output Port

Description

  • RF IN/OUT

This Type-N connector is the default path for all RF signals out of the test set, and is always used as the RF input. Refer to the Technical Specifications in the Application Datasheet for more information.

  • RF OUT ONLY

This Type-N connector is an optional path for all RF signals out of the test set. It is intended to be used for duplexed testing. Front panel selection of this port is provided by the RF Output Port ( F6 ) control on the System Config screen, and by the RFGenerator:OUTPut[:DESTination] IO/OUT command. The same amplitude offsets and output power settings are used for either selected port (RF IN/OUT or RF OUT ONLY). Refer to the Technical Specifications in the Application Datasheet for more information.

Related Topics

GPIB Commands: RFGenerator


AUDIO OUT port and FM Demodulation

Last updated: March 31, 2010

  • Description

  • Configure the AUDIO OUT Port

Description

The AUDIO OUT connector on the test set's front panel can be configured to carry one of two signals:

  • Audio Generator

  • FM Demod

By default, the AUDIO OUT connector is configured to carry the output from the built in audio generator. This signal is typically used to stimulate a system to measure its audio performance.

It may be useful to configure the AUDIO OUT connector to carry the analog FM Demod signal. This provides the demodulated FM signal for external analysis and baseband processing. Fixed bandwidth bandpass, expandor, and de-emphasis filters can be selected to control the FM Demod signal.

Configure the AUDIO OUT Port

A. Select a signal to output to the AUDIO OUT port.

  1. Press the SYSTEM CONFIG key.

  2. Press the More key on the left side of the display for additional system parameters.

  3. Press the Audio Out Port ( F1 ) key.

  4. Turn the knob to highlight a selection and then press the knob.

Selection of FM Demod signal routed to the front-panel AUDIO OUT port is useful only in AMPS system. There will be no guaranteed performance for the signal present at the Audio Out Port when FM Demod is selected for output.

B. Set FM Demod signal.

When FM Demod signal is selected for output to the front-panel AUDIO OUT port, a bandpass filter, expander circuit, and de-emphasis circuit can be individually inserted or bypassed in the FM Demod signal path.

  1. Press the SYSTEM CONFIG key.

  2. Press the More key.

  3. Press the FM Demod Setup ( F2 ) key.

  4. Turn the knob to highlight a selection and then press the knob.

  5. Enter a value or selection and press the knob.

  6. Press the Close Menu ( F6 ) key.

Related Topics

GPIB Commands: SYSTem:AUDio, AFGenerator


Instrument IP Info/Instrument IP Setup

Description

The test set supports both IPv4 and IPv6 address setup. This page describes how to set up the IP parameters and get the IP information of the test set.

For the IP address requirements, see IP Address Requirements

A typical display for the Instrument Setup menu and the Instrument IP Addressing screen is shown as below:

Instrument Setup Parameters

  • LAN IP Address: sets the IPv4 address of the test set' LAN Port. GPIB example:

OUTPUT 714;"SYSTem:COMMunicate:LAN:SELF:ADDRess '130.015.156.255'"

  • LAN IP Address 2 (Data+): sets the IPv4 address of the test set's LAN 2 Port. Note that this setting is grayed out if your hardware does not support LAN 2 Port. GPIB example:

OUTPUT 714;"SYSTem:COMMunicate:LAN:SELF:ADDRess2 '130.015.156.255'"

  • Subnet Mask: sets the Subnet Mask of the test set. GPIB example:

OUTPUT 714;"SYSTem:COMMunicate:LAN:SELF:SMASK '255.2.6.200'"

  • Default Gateway: sets the default gateway of the subnet. GPIB example:

OUTPUT 714;"SYSTem:COMMunicate:LAN:SELF:DGATEWAY '130.2.6.200'"

  • IPv6 Prefix, Upper/Lower (Hex)

This parameter is an 8-digit number in hexadecimal which sets the upper or the lower part of the IPv6 prefix. The full-length IPv6 prefix is shown on the Instrument IP Addressing screen.

If you leave this parameter blank, the test set will assign an all-zero IPv6 address prefix and an error will be displayed. You can only change the IPv6 prefix when the data connection status is Idle.

This parameter is stored in the test set's non-volatile RAM and is not affected by power cycle, full preset or save/recall operations. GPIB example:

OUTPUT 714;"SYSTem:COMMunicate:LAN:ADDRess:IP6:PREFix '2009:8960:8960:8960'"

  • IPv6 Default Router Interface ID, Upper/Lower (Hex)The IPv6 Default Router Interface ID identifies the IPv6 default Router to which the test set sends packets. This is similar to the Default Gateway in IPv4. This parameter is an 8-digit number in hexadecimal which sets the upper or the lower part of the IPv6 Default Router Interface ID. The full-length IPv6 Default Router Interface ID is shown on the Instrument IP Addressing screen. GPIB example:

OUTPUT 714;" SYSTem:COMMunicate:LAN:DGATeway:IP6:IID '0000:0000:821D:B001'"

Related Topics

GPIB Commands: SYSTem:COMMunicate


Message Log

Description

When an error message is displayed, it is also logged in the error message log. This log is only accessible manually; it is not available through GPIB.

All errors and events that are generated are displayed in the error message log. When the log is full a new message is sent to the log and the oldest message is removed from the log. The log is cleared when the test set powers up or when you press F10 (Clear Error Message Log).

For all the possible error messages with the error number, see Troubleshooting.

Manual Operation: The error message log can be displayed by pressing the F7 menu key from the SYSTEM CONFIG screen. Next Page and Previous Page controls are provided.


Calibrating the Test Set

Last updated: March 31, 2010

  • Description

  • IQ Calibrations

  • Burst Mod Offset 1 Calibration

  • Calibrate Measurements

Description

Various calibration routines must be run periodically to ensure measurement accuracy, source accuracy and allow the most robust demodulation of the device-under-test's signal. This document describes the various calibrations available in the test set and when they should be performed.

IQ Calibrations

The First IQ Modulator calibration sends a signal from the Baseband Generator 1 module to the RF Source 1 module to optimize the phase accuracy of RF Source 1 as a function of frequency. The optimization data is then stored in the test set and accessed whenever the RF Source frequency is set. The Second IQ Modulator calibration performs a similar procedure for RF Source 2 (RF Source 2 is only present if the test set includes option 002: RF Source 2).

The IQ calibrations ensure that the test set accurately generates IQ-modulated signals. If the test set's IQ modulators have not been properly calibrated, the test set's output power (when producing an IQ-modulated signal) will be inaccurate, which may result in degraded receiver test results.

The IQ calibrations do not need to be run frequently.

To initiate the IQ calibrations from the front panel, press SYSTEM CONFIG, press the right More ( 1 of 2 ) key, select Service ( F7 ), then select Cal. first IQ Modulator or Cal. second IQ Modulator .

Each IQ calibration takes 5~6 minutes to execute.

Burst Mod Offset 1 Calibration

This calibration is only required when using the test set to generate an AM or DSB-SC test signal. These test signals are used for calibrating Zero Intermediate Frequency (Zero IF) devices which utilize Qualcomm's radioOne™ architecture.

You do not have to perform the Burst Mod Offset 1 calibration for each application/format in your test set; performing it from one application/format provides calibration data to all relevant applications and formats.

The Burst Mod Offset 1 calibration does not need to be run frequently.

The Burst Mod Offset 1 calibration calibrates the noise and signal level of RF Source 1 (as a function of frequency) to most accurately produce the AM and DSB-SC test signals required for Zero IF device calibration. The calibration is performed by generating the modulated test signals and adjusting RF Source 1 to optimize gain and minimize the noise floor. The optimization data is then stored in the test set and accessed whenever the RF Source frequency is set.

To initiate the Burst Mod Offset 1 calibration from the front panel, press SYSTEM CONFIG, press the right More ( 1 of 2 ) key, select Service ( F7 ), then select Cal. Burst Mod Offset 1.

The Burst Mod Offset 1 calibration takes less than 1 minute to execute.

Calibrate Measurements

The Calibrate Measurements routine should be run monthly, or whenever the test set's operating environment changes. See Recommended Calibration Intervals .

The Calibrate Measurements routine calibrates the signal paths through the Measurement Downconverter and Demod Downconverter using both a CW signal and a modulated signal. The calibration is performed by comparing measured signals through the MDC and DDC to measurements made using the Fast Power Detector (for CW signals) and the Thermal Power Detector (for modulated signals). Both of these detectors are calibrated at the factory and temperature controlled for stability. During the Calibrate Measurements calibration, the internal temperature of the test set is measured and stored with the calibration data. If the internal temperature of the test set drifts by more than +/- 10 C since the last calibration, measurements utilizing this calibration will return integrity indicator 19 ( Uncalibrated Due to Temperature ).

The Calibrate Measurements routine provides calibration data for the following measurements:

  • Channel Power

  • Waveform Quality

  • Adjacent Channel Leakage Ratio

  • Spectrum Emission Mask

  • Closed Loop Power Control

  • Spectrum Monitor

To initiate the Calibrate Measurements routine from the front panel, initiate any of the measurements listed above and select Calibrate Measurements (F4) .

The Calibrate Measurements routine takes approximately 3 minutes to execute.

Related Topics

GPIB Commands: CALibration


Verifying the Test Set

Description

If you are experiencing problems with your test set, first ensure that you have performed the recommended calibrations (see the Calibrating the Test Set). If you are still experiencing problems, run the following verifications to determine if a hardware failure has occurred in your test set.

Self Test

The Self Test verification checks the integrity of the test set's RF Interface module.

You do not have to perform the Self Test verification from each application/format in your test set; perform it from one application/format verifies the test set's RF Interface module.

To initiate the Self Test verification from the front panel, press the SYSTEM CONFIG key, press the right More ( 1 of 2 ) key, and select Self Test ( F8 ). The Self Test verification takes approximately 15 seconds to execute, and returns pass or fail.

Thermal Power Null Adjustment

The Thermal Power Null Adjustment is a periodic calibration that you must perform on your test set. However, if you are experiencing problems with your test set, you can also use the Thermal Power Null Adjustment to ensure that your test set's Thermal Power Detector auto-null circuit has not drifted such that it is no longer able to null the power detector. If this occurs, the Thermal Power Null Adjustment returns a fail.

Related Topics

GPIB Commands: SYSTem:INSTrument:THERmal:POWer:NULL:ADJust?


Front Panel Connectors

Last updated: March 10, 2010

Description

Click on the blue circle for the detailed descriptions of this interface.

AUDIO IN

The input to the audio analyzer is a floating input differential amplifier. Both the AUDIO IN High and AUDIO IN Low BNC connectors should be connected to provide noise immunity. Refer to the Technical Specifications in the Application Datasheet for more information.

AUDIO OUT

This BNC connector accesses the test set's Audio Generator and FM Demod signals. The Audio Generator is used to stimulate a system to measure audio performance characteristics. The FM Demod allows the user to access the demodulated FM signal for external analysis and baseband processing. Refer to the Technical Specifications in the Application Datasheet for more information.

There will be no guaranteed performance for the signal present at the AUDIO OUT connector when FM Demod signal is selected for output.

DVM

Not functional for this release.

RF IN/OUT

This Type-N connector is the default path for all RF signals out of the test set, and is always used as the RF input. Refer to the Technical Specifications in the Application Datasheet for more information. See also RF OUT ONLY .

RF OUT ONLY

This port cannot be used with the E1960A GSM test application or with the GSM personality in a test application suite (such as the E1985A GSM_AMPS/136_GPRS suite).

This Type-N connector is an optional path for all RF signals out of the test set. It is intended to be used for duplexed testing. Front panel selection of this port is provided by the RF Output Port ( F6 ) control on the System Config screen, and by the RFGenerator:OUTPut[:DESTination] IO/OUT command. The same amplitude offsets and output power settings are used for either selected port (RF IN/OUT or RF OUT ONLY). Refer to the Technical Specifications in the Application Datasheet for more information.

Related Topics

Rear Panel Connectors


Rear Panel Connectors

Last updated: March 10, 2010

Description

Click on the blue circle for the detailed descriptions of this interface.

BASEBAND I/O

Four pins are functional on this connector:

  • I channel (pin 9)

  • Q channel (pin 26)

  • Ground

  • Ground

CLK IN

Not functional for this release.

COUNTER IN

Not functional for this release.

DATA IN

Not functional for this release.

DATA VALID IN

Not functional for this release.

EXT INTERFACE CONTROL

Not functional for this release.

EXT SIG GEN/FRAME SYNCH

Not functional for this release.

FM MOD IN

This BNC connector allows you to use an external signal to frequency modulate the test set's RF generator. It has a fixed sensitivity of 20 KHz/volt, and a frequency range of 100Hz to 20 KHz.

GPIB

This GPIB connector allows test set control with compatible devices.

LAN PORT

This RJ-45 connector provides a connection for downloading firmware upgrades, new applications and for acquiring screen captures. In the lab application only, the LAN PORT is also used for protocol logging.

LAN 2 PORT

This RJ-45 connector provides a connection for transferring data to the test set and for establishing an external device connection between two test sets.

LAN 3 PORT

For future use.

PRINTER

Not functional for this release.

SERIAL 1

Not functional for this release.

SERIAL 2

Not functional for this release.

SERIAL 3

Not functional for this release.

TEST SET SYNCH IN

Not functional for this release.

TEST SET SYNCH OUT

Not functional for this release.

TIMEBASE ADJUST

This is the timebase adjust cover. Removing this screw allows access for timebase adjustment.

TRIG IN

This BNC connector provides the capability for you to trigger measurements or instruments from an external source. Setting the Trigger Source setting to External for measurements or instruments which support this feature causes the measurement or instrument to trigger when a positive-going TTL compatible pulse is applied to this connector. Currently, the only measurement or instrument which supports this feature is the Spectrum Monitor.

TRIG OUT

This BNC connector allows you to synchronize the test set to other equipment via a trigger signal.

VGA OUT

This DB-15 connector allows you to simultaneously route the test set's display to another monitor.

10 MHZ REF IN

This BNC connector accepts an external 10 MHz timebase signal. The nominal input impedance is 50 ohm. This version of test set can only accept a 10 MHz timebase signal.

10 MHZ REF OUT

This BNC connector provides a 10 MHz timebase signal to external test equipment. The accuracy of this signal is determined by the timebase used. The nominal output impedance is 50 ohm with a typical level of 0.5 V rms.

Related Topics

Front Panel Connectors


Remote/Local Mode

Last updated: March 10, 2010

Description

Remote Mode

When the test set is operated remotely, all of the keys on the front panel of the test set are disabled (except the LOCAL key and the power switch). During remote operation the test set is controlled by the Remote User Interface, (RUI).

Any open menus are be closed, and any manual entries are be aborted when the test set transitions from local mode to remote mode.

The remote annunciator (R) will appear in the Instrument Status Area of the test set's display indicating that the test set is in remote mode.

When the test set is in remote mode press the LOCAL key on the front panel in order to gain manual control.

Local Mode

During local mode all front panel keys and the knob are enabled. During local operation the test set is controlled by the Manual User Interface, (MUI).

The remote annunciator (R) is turned off when the test set is operated in local mode.


Help Mode

Last updated: April 21, 2010

Description

The help mode implemented in your test set provides context sensitive GPIB command syntax assistance. When you put the test set into help mode, the test set displays the GPIB command syntax necessary to perform an action remotely for each action you perform from the front panel.

For example, if you put the test set into help mode and then select the test set's GPIB address, the GPIB command syntax for changing it remotely appears in the bottom left hand corner of the test set's screen.

How do I use the help mode?

1. Put the test set into help mode by pressing the HELP key on the front panel.

The Help annunciator should now be displayed in the bottom of the screen.

2. Navigate to the screen and perform the action for which you would like to know the GPIB command syntax. For example, you could navigate to the Audio Generator instrument, and select Frequency ( F3 ). The GPIB command syntax to perform this action remotely appears in the bottom left of the screen.

Refer to GPIB commands on each command for more information.


IP Address Requirements

IPv4 Address Requirements

IPv6 Address Requirements

IPv4 Address Requirements

An IP Address (the IP address defaults for IPv4 address if there is no specified statements) consists of a 4-byte (32 bit) number. Each byte is in a decimal form separated from other bytes by a dot. This is referred to as a "dotted decimal" format.

The network portion of the LAN IP Address depends on the address classification as shown below:

LAN IP Address Classification

Class A = 1.0.0.0 to 127.255.255.255

Class B = 128.0.0.0 to 191.255.255.255

Class C = 192.0.0.0 to 223.255.255.255

Class D = 224.0.0.0 to 247.255.255.255

The test set does not allow LAN IP Addresses in the range of 127.0.0.0 to 127.255.255.255 because these addresses are assigned for use as the Internet host loopback address.

The IP address class defines which bytes contain the network portion of the address. For Class A addresses, the first byte from the left identifies the network. For class B it is the first two bytes from the left, and for class C it is the first three bytes. Class D addresses are multicast, which are used when a datagram is directed to multiple hosts. See the following table.

Class | Byte 1 | Byte 2 | Byte 3 | Byte 4
A | Network | Host
B | Network |  | Host
C | Network |  |  | Host
D | Multicast

If the test set's LAN IP Address is set to 130.29.183.121, as shown below, the first two bytes represent the network portion since this is a Class B address.

If the test set is on a subnet, the Subnet Mask must be applied to determine the subnet address. This is done by performing bit-wise AND logic between the binary values of the LAN IP Address and Subnet Mask.

The Subnet Mask splits the 16 bit host portion of the class B address into an 8-bit subnet ID and an 8-bit host ID.

This setting is non-volatile (it persists across partial and full presets and power-cycling the test set).

IPv6 Address Requirements

IP version 4 (known as IPv4) has been widely used for decades of years and it is proven to be robust, easily implemented and interoperable. However, as the increasingly growth of the internet, IPv4 faces many problems: the impending exhaustion address space, large routing tables etc. IP version 6 (known as IPv6) is developed by Internet Engineering Task Force (IETF) to solve these problems.

IPv6 Address Representation

IPv6 addresses are 128-bit identifiers for interfaces and sets of interfaces. These 128 bit is divided to eight 16-bit blocks with each block is represented by a 4-digital hexadecimal number and separated by colons. For example: 2001:0DB8:0000:2F3B:02AA:00FF:FE28:9C5A. Uppercase or lower case is not sensitive for IPv6 addresses.

Zero compression

For the IPv6 addresses with long sequences of `0', double-colon "::" is used to compress the `0's in the contiguous sequence of 16-bit block to further simplify the representation. "::" indicates one or more groups of 16 bits of `0's and can also be used at the leading or trailing part of an address. For example: FE80:0:0:0:2AA:FF:FE9A:4CA2 can be further simplified by `0' compressing and turns to: FE80::2AA:FF:FE9A:4CA2.

The following formula can be used if you want to determine how many `0's are represented by the "::" :

the number of bits expressed by "::" = (8-number of blocks in the address)*16.

For example: in the address FE80::2AA:FF:FE9A:4CA2, there are 5 blocks. The number of bits expressed by the "::" is 48 (i.e. (8-5)*16=48).

Note that this compression can only appear once in a given IPv6 address, or you could not determine how many `0's are represented by each instance of "::".

IPv4-compatible IPv6 addresses

When dealing with a mixed environment of IPv4 and IPv6 nodes, x:x:x:x:x:x:d.d.d.d can be used as a more convenient form, where the 'x's are the hexadecimal values of the six high-order 16-bit pieces of the address, and the 'd's are the decimal values of the four low-order 8-bit pieces of the address (standard IPv4 representation). For example: "0:0:0:0:0:FFFF:129.144.52.38" and the compressed form "::FFFF:129.144.52.38" are all valid addresses.

IPv6 Address Structure

  • An IPv6 address is comprised of two portion: IPv6 Prefix and IPv6 interface ID.

An IPv6 prefix indicates the block of address space or a network. The IPv6 prefix follows the general IPv6 addressing rules and is represented as: IPv6 address/prefix length.

Where IPv6 address represents the hexadecimal 128-bit address, and prefix length is a decimal value that indicates the number of contiguous, higher-order bits of the address that make up the network portion of the address. For example, "21DA:D3::/48" and "21DA:D3:0:2F3B::/64" are IPv6 address prefixes.

  • IPv6 Interface ID indicates the specific interface which is unique to the IPv6 prefix of the IPv6 address.

Types of IPv6 Addresses

In general, there are three types of IPv6 address: Unicast IPv6 Addresses, Multicast IPv6 Addresses and Anycast IPv6 Addresses.

  • An unicast address identifies a single interface within the scope of the type of unicast address. A packet sent to a unicast address is delivered to the interface identified by that address.

For the Unicast IPv6 Addresses, there are many types: Global unicast addresses, Link local addresses etc. Global unicast addresses are globally routable and reachable on the IPv6 portion of the Internet.

A prefix for link local addresses is always FE80::/64 with the interface ID be 64-bit length.

  • A multicast address identifies multiple interfaces (typically belonging to different nodes). A packet sent to a multicast address is delivered to all interfaces identified by that address.

  • An anycast address identifies a set of interfaces (typically belonging to different nodes). A packet sent to an anycast address is delivered to one of the interfaces identified by that address.


Partial/Full Preset

Last updated: March 10, 2010

Description

The test set is capable of accepting several different preset commands.

At no time during a preset operation, does transmit power exceed the last user setting of the transmit power. The input power is not set to any value lower than the last user setting of the input power. This is to avoid power spikes on the output and possible receiver damage on the input during transitions associated with preset operations.

Partial Preset

Partial preset saves setup time because measurement setup parameters remain unchanged. This is the recommended way to place the test set in a known condition.

When you fast switch between formats in a fast switching test application the test set behaves as if a partial preset has occurred. The table below lists some key partial preset results.

Example

OUTPUT 714;"SYSTEM:PRESET3" !Command for a partial preset when user in remote operation.

SYSTEM:PRESET3 is the recommended command for a partial preset operation. The SYSTEM:PRESET[1] command is not recommended for use at this time.

Press the green Preset key on the front panel to perform a partial preset.

Partial Preset Behavior

Function | Partial Preset Result
Trigger Arm | no change
Measurement parameters | no change
Calibration data | no change
Operating Mode | Active Cell
Measurements | aborted and inactivated
Measurement results | NAN
Measurement integrity indicator | 1 = no result available
Transmit Power State | ON
Cell Activated State | ON
Call in progress | aborted
Call Control Status | Idle
Call Counters | cleared
Call Error Counters | cleared
Pending Service request | not cleared

Full Preset

A full preset requires you to select new measurements and configure their parameters. If measurement parameters do not need to be changed, use a partial preset to save time.

Example

OUTPUT 714;"*RST" !Recommended command for a full preset, sets trigger arm to single.

OUTPUT 714;"SYSTEM:PRESET2" !Command for a full preset, sets trigger arm to continuous.

The *RST common command is the recommended command for a full preset operation.

Full Preset Behavior

Function | Full Preset Result
Trigger Arm | Continuous (manual operation full preset or SYSTEM:PRESET2 command)
Trigger Arm | Single (remote operation full preset, *RST command)
Measurement Parameters | all set to defaults
Maskable Message Display State | On (manual operation full preset)
Maskable Message Display State | Off (remote operation full preset)

Related Topics

GPIB Commands: SYSTem Preset


Save and Recall Registers

Description

The test set provides up to ten save/recall registers . Each register is identified by a number (1-10).

Note that either registers 6 to 10 or Setting register names is only applicable to a test application with the required Revision To Current (R2C) license.

  • Recalling Saved Registers

  • Deleting Saved Registers

  • Settings that are Saved

  • Settings that are not Saved

  • Saving Current Settings to a Register

  • Setting register names

Recalling Saved Registers

Press the Register recall hardkey.

Use the knob to scroll to a register that is labeled Full and press the knob.

When a register is recalled, the test set will clear all active measurements and display the Call Setup Screen. Registers can only be recalled in the format they were saved in. For example, in a fast switching application, a register that is saved in a specific format must also be recalled in that same format. If a register is attempted to be recalled in a format other than the one it was saved in, the following error will occur:

If the test set has had hardware options installed since the last time a registers were saved, delete the registers and re-save them. Failure to perform this step could result in a non-recoverable firmware "assert" when performing a register recall.

Deleting Saved Registers

Pressing the DELETE hardkey will display a menu indicating which registers have been saved (they are labeled "Full").

Use the knob to scroll to a register and press the knob. Select Yes to confirm the selection.

Settings that are Saved

All functions and parameters that have an associated static state or settable value will be saved. For example:

  • Cell parameters (System ID, Network ID, etc.)

  • Call control parameters (System Type, Operating Mode, etc.)

  • Measurement setup parameters (Trigger Arm state, Measurement Timeout, etc.)

  • Call Parms (Cell Power, Cell Band, etc.)

Settings that are not Saved

  • Functions that trigger immediate actions, such as originating a call or calibrating a measurement are not saved.

  • Settings saved in non-volatile memory (settings that are unchanged when power is cycled or the test set is preset) are not saved. For example:

  • LAN IP Address and GPIB address

  • Date/Time

  • RF IN/OUT Amplitude Offset

  • All other settings on the Instrument Setup menu on the System Config screen.

  • Measurement results

  • Active measurements

  • Read-only call processing results such as Mobile Station Information tables are not saved.

  • Navigational information, such as keys pressed, screens displayed are not saved

  • Most information from screens is not saved unless there happens to be an associated setting that is redisplayed on a screen.

Saving Current Settings to a Register

To save the current state of the test set, press the SAVE hardkey.

A menu will be displayed that shows the status of all five registers. If the register status is "Full", the register has had instrument settings saved to it. If the register status is "Empty", it does not currently contain any instrument settings.

Use the knob to scroll to a register and press the knob. If the selected register is currently Full, select Yes in the Overwrite Save Reg? window and it will be overwritten.

When a test set application is upgraded using the 8960 File Utility Program, the new revision of the application will not automatically retain save/recall registers from the old revision. Prior to the application upgrade, it is recommended that you record the critical settings (such as call setup information) from registers that you will want to re-save after the test application upgrade.

Setting register names

When the Save hardkey is pressed, you can also set a name for each register to easily identify your saved configuration.

To set a name for a specific register, press the Save hardkey. The Save Registers menu is displayed for you to operate on each register. Highlight the register you want to allocate a name, press the Set Register Name softkey on the left, a middle menu is displayed for you to edit the register name.

  • Done: the assignment of the register name is done, select this option will get the middle menu to be closed.

  • Clear: delete the name associated with the register.

  • Backspace: delete the last letter of the name.

  • A to Z, Space and 0 to 9: the register name can be comprised of any of these characters, until the maximum length of 20 characters is reached.

You can set the register name with a maximum length of 20 characters.

Once you have assigned a name to the register, the name will be in parentheses after the register number.

Related Topics

GPIB Commands: SYSTem:REGister


User Interface (UI) Log

Description

To help you troubleshoot or optimize your GPIB control programs, you can configure the test set to capture GPIB interface traffic and store it in the UI (User Interface) Log. To enable GPIB logging, see Step 2: Turn On UI Log GPIB State .

The UI log buffer can store up to 153600 bytes of information with 255 bytes displayed in a row. If the buffer is full, the oldest entry is removed from the top of the log and the newest entry is added to the end.

You can reset and access the UI Log through either the GPIB interface or a Web Browser.

The following procedures demonstrate how to reset and access the UI Log.

  • Step 1: Clear UI Log Data

  • Step 2: Turn On UI Log GPIB State

  • Step 3-1: Get UI Log Data

  • Step 3-2: Get Other UI Log Information (Optional)

  • Step 4: Save UI Log Data

Step 1: Clear UI Log Data

Before capturing new GPIB traffic, you can clear the residual information in UI Log storage. Two methods are valid to clear UI Log data storage in the test set:

  • Clear the UI Log via Local Area Network (LAN)

  • Connect your computer to the test set via LAN or directly via a LAN crossover cable.

  • Go to the URL of the test set using a web browser such as Internet Explorer.

URL in Web Browser to Clear UI Log Data

Command: http:// <test_set_ip_address> /uilogclear

Example: http://111.222.333.444/uilogclear

Figure 1: Clear UI Log Data

  • Clear the UI log via GPIB

  • Connect your computer to the test set via a GPIB interface.

  • Send the GPIB command SYSTem:LOG:UI:CLEAR to the test set and the log is cleared.

Step 2: Turn On UI Log GPIB State

  • Send the GPIB command SYSTem:LOG:UI:GPIB[:STATe] to the test set before you run your test program or send it from the point in your program where it is desired to start GPIB logging.

The Log GPIB state is reset to OFF after cycling power. It is not reset by a full preset.

Step 3-1: Get UI Log Data

  • Go to the URL of the test set using your web browser to retrieve the GPIB log. The GPIB log is displayed in the browser window.

You must ensure the computer is connected to the test set either via Ethernet LAN or a direct connection using a LAN crossover cable.

URL in Web Browser to get the UI Log Data:

Command: http:// <test_set_LAN_IP_Address> /uilog

Example: http://111.222.333.444/uilog

Figure 2: Display UI Log Data in Web Browser

In addition to GPIB traffic information, the UI Log also includes data regarding the key presses, knob turns and error messages that occur as you operate your test set from the front panel. Only the lines with the prefix "rem:" indicate the GPIB commands.

The UI Log display is not real time, therefore the latest UI log does not display automatically in the web browser. To capture multiple logs, click Refresh in the View menu.

Step 3 - 2: Get Other UI Log Information (Optional)

You can get more information about UI log data by sending the GPIB queries.

  • Query the number of lines containing GPIB commands in the UI Log

The GPIB query SYSTem:LOG:UI:COUNt? returns the number of lines in the log since the last time the log was cleared.

  • Query the string at the specified line in the UI Log

The GPIB query SYSTem:LOG:UI:REPort? returns the string located at the line in the log that you specify. Note that issuing this command turns off GPIB logging. You must turn it back on using the SYSTem:LOG:UI:GPIB[:STATe] command to continue GPIB logging.

Step 4: Save UI Log Data

To save the log in the Web Browser to a file:

  1. In the File menu, click Save As....

  2. In the Save as type: box, select Text File (*.txt).

  3. In the File name: box, type the file name.

  4. Click the Save button.

Related Topics

GPIB Commands: SYSTem:LOG


Call Processing

This page provides links to descriptions of the numerous settings and operations available in the test set for base station emulation and call processing including: Call Control, Call Parms and Call Processing Information and Operations.

If you have trouble finding the information you need, use the search tab on the left to search the contents of this help.

Call Control

  • Operating Mode

  • Originate/End Call

  • Paging Parameters

  • Handovers

  • Clear UE Info

  • Downlink Channel Level (only applicable to TD-SCDMA Test operating mode)

  • AWGN Power

  • DL TFCI Pattern (only applicable to TD-SCDMA Test operating mode)

  • Scrambling Code

  • Cell Parameters

  • Generator Info

  • UE Timer and Constant Parms

  • Channel Config Information

  • Trig Output Setup

  • Security Information

  • UE Measurement Control

  • Voice Call

  • RB Test Mode Setup

Call Parms

  • Cell Power

  • Channel Type

  • Paging Service Type

  • Channel

  • HSDPA Parameters (only applicable to the feature-licensed test application)

  • UE Transmit Power Control

  • RF Gen Freq Ctrl

  • DL DTCH Data

  • Call Limit State

  • Call Drop Timer

  • DL PICH Data (only applicable to TD-SCDMA Test operating mode)

  • UL DPCH TFCI Control (only applicable to TD-SCDMA Test operating mode)

  • UL DPCH TFCI (only applicable to TD-SCDMA Test operating mode)

  • MS DPCH Tgt Pwr

  • UL CL Power Control

  • Receiver Control

Call Processing Information and Operations

  • Call Setup Screen

  • Call Processing Ladder Diagrams

  • Cell Power, AWGN Power and Total RF Power

  • FM Broadcast

  • Single channel GPS source


Operating Mode

The test set supports the following operating modes:

Active Cell Operating Mode

TD-SCDMA Test Operating Mode

CW Operating Mode

Cell Off Operating Mode

Active Cell Operating Mode

The Active Cell Operating Mode allows you to make a signalling connection between the test set (emulating a base station (BS) in a network) and a UE (mobile station). When connected (and during the connection process for some measurements), the UE's performance can be measured using the suite of measurements shown when the Measurement Selection key or Instrument Selection key is pressed.

You can configure the test set's base station emulator using the parameters described in Call Processing. While operating in Active Cell mode the test set is capable of performing many call processing operations.

Many of the settings used in active cell mode cannot be changed during active cell mode operation. A message is displayed to alert you to this situation if you try to change them. These are settings that must be set before attempting to get the UE connected on a call, or settings that are not normally changed during base station operation in a network. Use the Cell Off Operating Mode to change these settings.

Supported Downlink Channel in Active Cell Mode

The test set supports the following WCDMA downlink physical channels when operating in Active Cell operating mode:

  • DwPCH - Downlink Pilot Channel

  • P-CCPCH - Primary Common Control Physical Channel

  • DPCH - Dedicated Physical Channel

  • PICH - Paging Indicator Channel

  • DPCHo - Orthogonal Channel Noise Source

  • AWGN - Additive White Gaussian Noise

  • S-CCPCH - Secondary Common Control Physical Channel

  • FPACH – Fast Physical Access Channel

In addition, for HSDPA, the test set support the following HSDPA downlink channels:

  • HS-SCCH1 – High Speed Shared Control Channel

  • HS-PDSCH – High Speed Physical Downlink Share Channel

Expected Uplink Channel in Active Cell Mode

The test set supports the following uplink physical channels when operating in Active Cell operating mode:

  • DPCH - Dedicated Physical Channel

  • UpPCH - Uplink Pilot Channel

  • PRACH – Physical Random Access Channel

In addition, for HSDPA, the test set support the following HSDPA uplink channels:

  • HS-SICH – High Speed Shared Information Channel

TD-SCDMA Test Operating Mode

When in TD-SCDMA Test Mode, the test set emulates a subset of the layer 1 functionalities of a TD-SCDMA Node B without sending any signalling information on the downlink channel. Changes to the UE configuration must be accomplished by directly sending commands to the UE from a system controller (usually a personal computer) through a proprietary digital interface.

Upon entry into the TD-SCDMA Test Mode, the test set begins continuously transmitting a downlink signal consisting of the DwPCH, P-CCPCH, PICH and DPCH, along with DPCHo and AWGN sources if desired. The downlink DPCH configured for the bearer service is determined by Channel Type. The UE is expected to synchronize to the downlink channels and begin the transmission of an uplink DPCH configured to the same channel type as the downlink DPCH. The test set does not send any signaling message, except BCH messages, in TD-SCDMA Test mode.

Supported Downlink Channel in TD-SCDMA Test Mode

The test set supports the following downlink physical channels in TD-SCDMA Test mode. See Figure 1: Downlink Channels in TD-SCDMA Test Mode.

  • DwPCH - Downlink Pilot Channel

  • P-CCPCH - Primary Common Control Physical Channel

  • DPCH - Dedicated Physical Channel

  • PICH - Paging Indicator Channel

  • DPCHo - Orthogonal Channel Noise Source

  • AWGN - Additive White Gaussian Noise

Figure 1: Downlink Channels in TD-SCDMA Test Mode

There are two types of transport channels in the Downlink: Dedicated Channels (DCH) and Broadcast Channel (BCH).

  • Two DCHs are mapped to a single Coded Composite Transport Channel (CCTrCH). One carries the RMC DTCH and the other is used for signalling. The DPCH is configured for the Downlink Radio Access Bearer.

Since the test set only supports TD-SCDMA Test operating mode with no signalling, the DCH used for signalling is transmitted with no data.

  • The BCH is mapped to the P-CCPCH. It contains PRBS data and a System Frame Number (SFN).

Expected Uplink Channel in TD-SCDMA Test Mode

The test set only expects the uplink DPCH in TD-SCDMA Test mode. See Figure 2: Uplink Physical Channels.

Figure 2: Uplink Physical Channels

There are two DCHs expected from the UE. One is for DCCHs and the other is for the RMC DTCH.

When performing Loopback Bit Error Ratio (BER) Measurement in TD-SCDMA test operating mode, you must set UE Loopback Type to the loopback type 1 (the test set does not signal the loopback type to the UE), or else the measurement will fail.

The following settings are only available to TD-SCDMA Test operating mode:

  • DL TFCI Pattern

  • DL PICH Data

  • Downlink Channel Level

  • UL DPCH TFCI Control

  • UL DPCH TFCI

CW Operating Mode

When in CW operating mode, the test set operates like a signal generator. The basic features provided by CW operating mode are:

  • No over the air signaling is used. Therefore there is no synchronization between the mobile station and test set.

  • No demodulation or channel decoding is available.

  • No automatic receiver control is provided. Expected CW power, measurement receiver frequency, and uplink receiver frequency are available as manual settings only.

  • Manual receiver control settings made while using the CW operating mode can affect manual receiver settings made in other operating modes. When changing operating modes and using manual receiver settings, you should always verify that the manual receiver settings are correct for the new operating mode.

  • Any one of three test signals can be generated while analyzing another signal (at the same frequency or at a different frequency). No interaction exists between these controls.

  • All test set measurements are available while in CW operating mode. However, measurements requiring protocol triggering cannot be made. Immediate triggering should be used for most measurements because no overhead signaling is occurring. Protocol triggering will timeout or report an integrity indicator other than zero.

Test Signals Description

The test set in CW operating mode provides any one of three test signals: CW (no modulation), AM (fixed 56% amplitude modulation), and DSB-SC (dual side-band suppressed carrier). You can select any one of three signals with adjustable power level and frequency for output to the currently selected front panel RF connector.

  • With CW test signal selected (the default setting), the test set provides an unmodulated carrier. With either AM or DSB-SC test signal selected, the test set will modulate the signal as shown in Figure 3: AM and DSB-SC test signals.

  • For any of the test signals selected, the output power level is controlled by the Cell Power ( F7 ). The Cell Power refers to the power found in the entire signal including sidebands if applicable.

  • For any of the test signals selected, the frequency is adjusted by changing the RF Gen Freq ( F8 ).

  • With the CW or AM signal selected, the RF Gen Freq setting represents the center frequency of the signal (fc).

  • With the DSB-SC signal selected, the RF Gen Freq setting represents the frequency of the lower sideband signal (fL). The upper sideband (fh) is 20 kHz above the RF Gen Freq setting, that is fh = fL+20 kHz.

Figure 3: AM and DSB-SC test signals

Cell Off Operating Mode

Cell Off operating mode and Active Cell operating mode share the same settings. However, Cell Off mode allows you to change the parameters that cannot be changed during Active Cell operation but used for call processing, such as downlink and uplink channel number (UARFCN), reference measurement channel configuration (Channel Type), signalling radio bearer configuration, etc.

Use Cell Off operating mode to set up those downlink and uplink parameters before establishing a connection to the UE (mobile station). After making the settings, switch to Active Cell operating mode to begin generating the downlink signal.

No signal is generated by the test set during Cell Off operation, regardless of the Cell Power setting. All settings are deferred until the Active Cell operating mode or FDD Test operating mode is used.

Related Topics

GPIB Commands: CALL:OPERating


Originate/End Call

Description

Test Set-Originated Connection

Before originating a call from the test set, you must set Channel Type to the appropriate setting.

The UE can be paged using either an IMSI (International Mobile Subscriber Identity) or TMSI (Temporary Mobile Subscriber Identity):

  • To page the UE using its IMSI, set Paging Identity Type to IMSI. If you know the UE's IMSI, you can enter it under Paging IMSI (CALL:PAGing:IMSI[:SELected]) and proceed directly to originating a call even if the UE has not registered. Otherwise, you must wait for the UE to report its IMSI upon registering with the test set.

  • To page the UE using a TMSI, the UE must first be assigned a TMSI during the Location Update procedure. You must then set Paging Identity Type to TMSI , then originate a call from the test set.

To originate a call from the test set, select Originate Call or send the CALL:ORIGinate command. Press the same button or send the CALL:END command to end the call, which will abort the current call processing operation and returns call status to "Idle".

  • The Call Limit State must be OFF for test set origination (Paging), to be successful.

  • RB Test Mode is the only supported paging service by the test set.

Related Topics

GPIB Commands: CALL:ORIGinate, CALL:END


Paging Parameters

Description

  • Paging Identity Type

This setting determines whether the UE is paged using its IMSI or a TMSI (see Test Set-Originated Connection) for CS domain service. If you wish to page the UE using a TMSI, the test set must first assign a TMSI to the UE during registration (TMSI Assignment must be set to On when the UE registers with the test set). The TMSI used to page the UE is determined by the TMSI setting.

This parameter can only be set when call status is Idle.

GPIB Command: CALL:PAGing:IDENtity[:TYPE]

  • Paging IMSI

If you know the UE's International Mobile Subscriber Identity (IMSI), you can enter it under Paging IMSI and proceed directly to originating a call even if the UE has not registered. Otherwise, you must wait for the UE to report its IMSI value upon registering with the test set.

GPIB Command: CALL:PAGing:IMSI[:SELected]

  • TMSI Assignment

This setting determines whether the test set assigns a TMSI to the UE during the Location Update Procedure. If TMSI Assignment is set to On, when the UE registers with the test set, the test set assigns the UE a TMSI in the Location Update Accept message. The TMSI assigned to the UE is determined by the TMSI setting.

You must set TMSI Assignment to On before the UE registers in order for a TMSI to be assigned.

If you do not plan to page the UE using a TMSI, it is recommended that you leave TMSI Assignment set to Off so that the Location Update procedure executes as quickly as possible .

This parameter can only be set when call status is Idle.

GPIB Command: CALL[:CELL]:TMSI:ASSignment

  • TMSI

TMSI (Temporary Mobile Subscriber Identity) is a 32 bit number, but 3GPP TS 23.003 2.4 indicates "The network shall not allocate a TMSI with all 32 bits equal to 1 (this is because the TMSI must be stored in the SIM, and the SIM uses 4 octets with all bits equal to 1 to indicate that no valid TMSI is available)." Thus, TMSI may be set to any value between 0 and 4294967294.

When TMSI Assignment is set to On , this setting determines the TMSI that is assigned to the UE during the Location Update Procedure.

When CS Paging Identity Type is set to TMSI, this setting determines the TMSI that is used to page the UE (see Test Set-Originated Connection).

This parameter can only be set when call status is Idle .

GPIB Command: CALL[:CELL]:TMSI[:VALue]

Related Topics

GPIB Commands: CALL:PAGing, CALL:TMSI


Handovers

Last updated: June 1, 2010

Physical Channel Reconfiguration

System Handover

Manual Operation: Perform a Handover

Handover Ladder Diagrams

Physical Channel Reconfiguration

A Physical Channel Reconfiguration can be used for inter-frequency or intra-frequency handoffs and also for power control step size change while on a connection (you cannot simply change the Channel or power control algorithm settings while on a call, you must perform a handover to change them).

You must be on a call to perform a Physical Channel Reconfiguration.

Before executing a Physical Channel Reconfiguration, you must first specify the settings you wish to change (for example, the UARFCNs to which to handoff). You must then select Execute Handover (F5) or send the CALL:HANDoff[:IMMediate] command to initiate the reconfiguration.

  • PCR Channel (UARFCN)

This setting determines the channel the UE is instructed to use after the Physical Channel Reconfiguration procedure.

GPIB Command: CALL:SETup:CHANnel:TDSCdma

  • PCR UL CL Power Ctrl Step Size

This setting determines the power control step size the UE is instructed to use after the Physical Channel Reconfiguration procedure. See UL CL Power Ctrl Step Size for more information.

GPIB Command: CALL:SETup:CLPControl:UPLink:STEPsize

  • PCR DPCH Type State

This setting determines whether the PCR DPCH Type setting is enabled or not.

Only applicable when the current service type is RB Test Mode and the Channel Type is 12.2 kbps RMC SC or 12.2 kbps RMC MC.

GPIB Command: CALL:SETup:DPCHannel:TYPE:STATe

  • PCR DPCH Type

When PCR DPCH Type State is applicable and set to On, PCR DPCH Type specifies the channel type (whether 12.2 kbps RMC SC or 12.2 kbps RMC MC) the UE is to use after the physical channel reconfiguration.

GPIB Command: CALL:SETup:DPCHannel:TYPE

  • PCR Target Cell Scrambling Code

This setting determines the scrambling code ID of the target cell the UE will be handover to after the Physical Channel Reconfiguration procedure.

GPIB Command: CALL:SETup:SCODe:IDENtity

  • RB Test Mode PCR Loopback Message State

You can specify whether the UE loopback is opened and closed as part of a Physical Channel Reconfiguration. This parameter only affects the Physical Channel Reconfiguration procedure when an RB Test Mode call is active.

  • On : The test set sends an Open UE Test Loop message before sending the Physical Channel Reconfiguration message and a Close UE Test Loop message after receiving the Physical Channel Reconfiguration Complete message from the UE.

  • Off : The test set does not send any loopback control message as part of the Physical Channel Reconfiguration procedure.

GPIB Command: CALL:SETup:LOOPback:MESSage:STATe

  • PCR Activation Time

This parameter allows you to set the time offset (in frame) for the CFN (Connection Frame Number) at which the test set builds the Physical Channel Reconfiguration message.

The real value of IE "Activation Time" in the Physical Channel Reconfiguration message is: (current CFN + PCR Activation Time) % 256. A PCR Activation Time of ‘0’ means now.

Note: Do not set PCR Activation Time to a value other than 0 unless necessary, as it slows down the handover procedure.

GPIB Command: CALL:SETup:ACTivation:TIME

System Handover

The System Handover functionality allows you to handover to a GSM voice call from any of the following connection types:

  • AMR Voice

  • TD-SCDMA RB Test Mode.

Before executing a System Handover you must specify the characteristics of the target GSM cell. You must also ensure that the GSM/GPRS format is set to Active Cell operating mode. You must then select Execute Handover ( F5 ) or send the CALL:HANDoff:SYSTem[:GSM][:IMMediate] command to initiate the handover.

System Handover Setup

  • RB Test Mode to GSM Handover Alerting State

On - when performing a handover from RB test mode to a GSM voice call, the UE will ring. You must answer the ring for the connection to be completed and testing to progress (note also that the fast switch between the two applications will not complete until you answer the ring). The voice loopback function is available if the alerting handover is complete. See System Handover from TD-SCDMA RB Test Mode to GSM Voice - With Alerting.

Off - when performing a handover from RB test mode to a GSM voice call, the UE will not ring. When the handover is completed, the connection is left in the RR Connected state. Data loopback (for BER testing) is available in this state, but voice echo is not. See System Handover from TD-SCDMA RB Test Mode to GSM Voice - Without Alerting.

GPIB Command: CALL:SETup:SYSTem:GSM:ALERting[:STATe]

  • Wait for RLC Ack of Handover From UTRAN

This parameter controls whether the test set switches immediately to GSM/GPRS/EGPRS format upon sending the Handover From UTRAN Command message, or waits for the UE to confirm reception of the Handover From UTRAN Command message before switching to the GSM/GPRS/EGPRS format. By default, the test set does not switch from the TD-SCDMA to GSM/GPRS/EGPRS application until it receives an RLC Ack confirming reception of the Handover From UTRAN Command message. To shorten the handover time, some UEs do not send any ACKs for the handover command. If your UE does not acknowledge the Handover From UTRAN command, you must set this parameter to Off. Otherwise, the test set will not continue with the handover until it receives the expected acknowledgment, and the handover will fail.

Setting Wait for RLC Ack of Handover From UTRAN to Off speeds up the System Handover, but is a less robust handover method.

GPIB Command: CALL:HANDoff:SYSTem[:GSM]:RLCAck:WAIT[:STATe]

  • RB Test Mode to GSM Handover Activation Time

This parameter sets the activation time of a TD-SCDMA to GSM handover. The UE will wait for the specified number of frames before trying to find the GSM cell.

GPIB Command: CALL:HANDoff:SYSTem:GSM:ATIMe

The following settings are GSM-specific. When the test set is operating in TD-SCDMA format, change any of them will cause the update of the corresponding parameter in the GSM/GPRS format.

Changing any of the GSM cell settings while operating in the TD-SCDMA format changes the corresponding parameter settings in the GSM/GPRS format of the fast switching application. Presetting the test set while operating in the TD-SCDMA format will not reset these parameters to their default settings. Presetting the test set while operating in the GSM/GPRS format will reset these parameters to their default values. When operating in the TD-SCDMA format, these settings are not saved when using the SAVE REGISTERS utility.

The test set only supports to handover to GSM format with the GSM Logical Speech Channel to be FS, EFS or HS.

  • GSM BCC (Base Station Colour Code)

GPIB Command: CALL:CELL:BCCode:GSM

  • GSM NCC (Network Colour Code)

GPIB Command: CALL:CELL:NCCode:GSM

  • GSM Cell Band

GPIB Command: CALL:CELL:BAND:GSM

  • GSM Broadcast Channel

GPIB Command: CALL:CELL:BCHannel:ARFCn:GSM

  • GSM Traffic Band

GPIB Command: CALL:TCHannel:BAND

  • GSM Traffic Channel

GPIB Command: CALL:TCHannel[:ARFCn]

  • GSM TCH Timeslot

GPIB Command: CALL:TCHannel:TSLot

  • GSM Logical Speech Channel

GPIB Command: CALL:TCHannel:CMODe:LSPeech:CHANnel

  • GSM Half Rate Speech Sub Channel

GPIB Command: CALL:TCHannel:CMODe:HRSPeech:SCHannel

  • GSM MS TX Level

GPIB Command: CALL:MS:TXLevel

Handover Ladder Diagrams

  • Physical Channel Reconfiguration

  • System Handover from TD-SCDMA RB Test Mode to GSM Voice - With Alerting

  • System Handover from TD-SCDMA RB Test Mode to GSM Voice - Without Alerting

  • System Handover from TD-SCDMA AMR Voice to GSM Voice

Physical Channel Reconfiguration

System Handover from TD-SCDMA RB Test Mode to GSM Voice - With Alerting

System Handover from TD-SCDMA RB Test Mode to GSM Voice - Without Alerting

System Handover from TD-SCDMA AMR Voice to GSM Voice

Related Topics

Channel

UL CL Power Ctrl Step Size

Scrambling Code


Clear UE Info

Description

Clear UE Info action will clear the following information reported by the UE.

  • IMSI

  • IMEI

  • Power Class

  • Detected UpPCH Sig

  • MM Status

  • GMM Status

  • MM Authentication Result

  • GMM Authentication Result

  • UE Reported Failure Cause

  • UE Reported HS DSCH Category

  • UE Access Stratum Rel Ind

To clear the UE reported information and counters, select Clear UE Info ( F6 ) from the Call Setup screen, or send the CALL:MS:REPorted:CLEar[:ALL][:SELected] command.


Downlink Channel Level

Description

The following settings are only available when the operating mode is TD-SCDMA Test. For the downlink channel level configurations in Active Cell operating mode, see Generator Info.

TD-SCDMA Test DPCH Level specifies the power level at which the downlink DPCH is transmitted. TD-SCDMA Test DPCH Level cannot be set 30 dB below the total RF power.

Downlink Code Channel Power Level Information

In the TD-SCDMA Test operating mode, when the CALL SETUP hardkey is pressed, the Downlink Code Channel Power Level window is displayed to show the "current" and "desired" power level of each downlink channel.

All downlink time slots are transmitted with full cell power (including the Downlink Pilot Time Slot, DwPTS). The relative power of the physical channels in one time slot must sum to 100% of the time slot power.

  • The power levels of DwPCH, P-CCPCH and PICH are all fixed and shown on the Downlink Code Channel Power Level screen.

  • You can specify the TD SCDMA Test DPCH Level. However, the power levels of DwPCH, P-CCPCH and PICH are fixed in the test set, as the table below.

 | DwPCH | P-CCPCH | PICH
Power Level (in dB) | 0 | -3 | -3.02

  • The DPCHo Level is a calculated value used to balance the relative power levels in a time slot so that they sum to 100%. The Current DPCHo Level indicates the current power level in use and the Desired Level indicates the calculated level. When TD SCDMA Test DPCH Level is changed, the test set re-calculates a DPCHo level in order that the DPCH and DPCHo levels sum to 100% of the time slot power. If the state of TD SCDMA Test DPCH Level is set to Off, the downlink DPCH channel is not transmitted and the DPCHo occupies 100% of the time slot power.

The DPCHo is always active concurrently with the DPCH.

Related Topics

GPIB Commands: CALL:TDTest:DPCHannel:LEVel


Cell Power, AWGN Power and Total RF Power

Description

The test set's base station emulator provides control over the following RF power levels:

Cell Power

Îoris defined in 3GPP TS 25.102 as the received power spectral density of the downlink signal as measured at the UE antenna connector. The downlink contains one or more downlink physical channels. The Cell Power setting sets the absolute level (in dBm) of the physical channels. The individual physical channel levels account for fractions of this setting, and are set in dB relative to the cell power (see Downlink Channel Codes and Levels ). If you have accounted for path loss (see Amplitude Offset ) between the test set output port and the UE antenna connector, then cell power is equivalent to Îor .

AWGN Power

Ioc is defined in 3GPP TS 25.102 as the power spectral density of a band-limited white noise source (simulating interference from other cells) as measured at the UE antenna connector. If you have accounted for path loss, then AWGN (Additive White Gaussian Noise) power is equivalent to Ioc .

Total RF Power

Io is defined as the total received power spectral density, including signal and interference, as measured at the UE antenna connector. The total RF power is the sum of cell power and AWGN power. If you have accounted for path loss, then total RF power is equivalent to Io.

The AWGN power must not be more than 10 dB above or 25 dB below cell power when both power states are set to ON.

Cell Power, AWGN Power and Total RF Power Ranges

The range of values that you can set these power levels to differs from the actual hardware range of the source. This is due to compensation for path loss between the test set RF output port and the UE antenna connector (see Amplitude Offset ).

For example, if you enter a value of -30 dBm for desired CW cell power, this indicates that you want -30 dBm of power at the UE antenna connector. So, if you have indicated an amplitude offset of -3.5 dB exists between the test set's RF In/Out port and the UE antenna connector, the source will actually have to output -26.5 dB in order to deliver -30 dB to the UE's antenna connector. Thus, with an amplitude offset of -3.5 dB, the settable range of CW cell power is -130.5 dB to -13.5 dB. The actual power range at a given time is defined by adding the value of the associated amplitude offset to the actual hardware range. If you select an invalid combination of power levels and amplitude offsets, an error message will appear at the bottom of the screen to alert you to this condition.

Parameter | Actual Hardware Range with Amplitude Offset=0 | Setting/Query Range
Cell Power | -115 dBm/1.28 MHz to -13 dBm/1.28 MHz | +37dBm/1.28MHz to -165dBm/1.28MHz
AWGN Power | -115 dBm/1.28 MHz to -13 dBm/1.28 MHz | +35dBm/1.28MHz to -165dBm/1.28MHz
Total RF Power | -115 dBm/1.28 MHz to -13 dBm/1.28 MHz | +39.12dBm1.28MHz to -165dBm/1.28MHz

Related Topics

GPIB Commands: CALL:POWer


DL TFCI Pattern

Description

This setting is only available to TD-SCDMA Test Operating mode.

You must indicate what value the test set should transmit in the TFCI (Transport Format Combination Indicator) field. You can set DL TFCI Pattern to any value between 00 and 1F.

Related Topics

GPIB Commands: CALL:TDTest:TFCIndicator


Scrambling Code

Description

The scrambling code can be set from 0 to 127. In Active Cell operating mode, the Scrambling Code can only be changed when the call status is Idle.

To change the scrambling code while on a connection, you must perform a Physical Channel Reconfiguration. After completion of the Physical Channel Reconfiguration procedure, successful or not, the Scrambling Code setting is overwritten with the value of PCR Target Cell Scrambling Code.

The test set supports the following synchronization codes:

  • SYNC_DL used for DwPCH

  • SYNC_UL used for UpPCH

  • Basic Midamble code

  • Scrambling code used for both downlink and uplink

All the synchronization codes are divided into 32 code groups. The test set can be set to one of the code groups, along with one pair of scrambling code and basic midamble code within that code group. According to 3GPP TS25.223 8.3, relationship between the SYNC-DL and SYNC-UL sequences, the scrambling codes and the midamble codes are shown as the table below:

Table 1: Relationship between the synchronization codes

Code Group | Associated Codes
 | SYNC-DL ID | SYNC-UL ID | Scrambling Code ID | Basic Midamble Code ID
1 | 0 | 0...7 | 0 | 0
 |  |  | 1 | 1
 |  |  | 2 | 2
 |  |  | 3 | 3
2 | 1 | 8...15 | 4 | 4
 |  |  | 5 | 5
 |  |  | 6 | 6
 |  |  | 7 | 7
... | ... |  | ... | ...
32 | 31 | 248...255 | 124 | 124
 |  |  | 125 | 125
 |  |  | 126 | 126
 |  |  | 127 | 127

Related Topics

GPIB Commands: CALL:SCODe


Cell Parameters

Description

  • BCCH Update Page

If BCCH Update Page is set to Auto, when you change a parameter that causes a Broadcast Channel (BCCH) Update Procedure (SIB Contents) (which only occurs when call status is idle), the test set updates its BCCH information and sends a Paging Type I message to the UE telling it to re-read the BCCH. If BCCH Update Page is set to Inhibit , when you change a BCCH parameter that would normally cause a BCCH Update procedure, the test set updates its BCCH information but does NOT send a Paging Type I message to the UE.

If your UE does not support the BCCH Update procedure, set this field to Inhibit. However, the UE will then be unaware of the changes to the BCCH. To force your UE to re-read the BCCH, you can do one of the following:

  • Originate a call and then release it.

  • Cause the UE to perform a cell re-selection by changing the Scrambling Code and Cell Identity.

  • Turn the UE off and then back on.

You may also use this field to reduce the amount of signalling between the test set and UE as follows: if you need to change many BCCH parameters, set this field to Inhibit, change all of the parameters except one, set this field to Auto, then change the final parameter. That way, only one Paging Type I message is sent to the UE.

GPIB Command: CALL[:CELL]:BCCHannel:UPDate:PAGE

  • PS Domain Information

This parameter specifies whether the PS domain information is present in SIB 1 or not. If it is absent, the UE will not attempt to initiate any packet switched services, like GPRS Attach or PDP Context Activation, with the test set.

GPIB Command: CALL[:CELL]:PSDomain

  • MCC (Mobile Country Code)

See LAC (Local Area Code). This setting can only be changed when call status is Idle . If BCCH Update Page is set to Auto and you change this setting while your UE is camped to the test set, the test set performs a Broadcast Channel (BCCH) Update Procedure (SIB Contents). If BCCH Update Page is set to Inhibit (the default value) and you change this setting while your UE is camped to the test set, you must force your UE to re-read the BCCH to observe the change.

GPIB Command: CALL[:CELL]:MCCode[:SELected]

  • MNC (Mobile Network Code)

See LAC (Local Area Code). This setting can only be changed when call status is Idle . If BCCH Update Page is set to Auto and you change this setting while your UE is camped to the test set, the test set performs a Broadcast Channel (BCCH) Update Procedure (SIB Contents). If BCCH Update Page is set to Inhibit (the default value) and you change this setting while your UE is camped to the test set, you must force your UE to re-read the BCCH to observe the change.

GPIB Command: CALL[:CELL]:MNCode[:SELected]

  • LAC (Local Area Code)

The Local Area Code, together with MCC (Mobile Country Code) and MNC (Mobile Network Code) identify the location areas within the system coverage area.

GPIB Command: CALL[:CELL]:LACode[:SELected]

  • RAC (Routing Area Code)

This parameter determines the Routing Area Code in the SIB 1 broadcast message. The RAC 16 is only included in SIB 1 when the PS Domain Information is set to Present.

The RAC is a fixed length code (of 1 octet) identifying a routing area within a location area (see 3GPP TS 23.003 4.2).

When the BCCH Update Page is set to Present, this parameter specifies the Routing Area Code in the SIB 1 broadcast message.

GPIB Command: CALL[:CELL]:RACode[:SELected]

  • Cell Identity

3GPP TS 25.331 10.3.2.2 defines cell identity as a 28 bit number which unambiguously identifies a cell within a PLMN (Public Land Mobile Network). The Cell Identity parameter in the test set allows you to input a decimal value between 0 and 268435455, which is then transmitted to the UE as a 28 bit number, identifying the test set.

This parameter is transmitted in SIB 3 on the BCCH (see Broadcast Channel (BCCH) Update Procedure (SIB Contents)).

GPIB Command: CALL[:CELL]:IDENtity[:SELected]

  • ATT (IMSI Attach) Flag State

When ATT (IMSI Attach) Flag State is Off, the test set will not perform IMSI attach or detach procedure.

GPIB Command: CALL[:CELL]:ATTFlag[:STATe]

  • CN Domain Specific DRX Cycle Length

DRX (Discontinuous Reception) Cycle is defined in 3GPP TS 25.304 3.1 as "Individual time interval between monitoring Paging Occasion for a specific UE." 3GPP TS 25.331 8.6.3.1a states "The UE shall determine its idle mode paging occasions and PICH monitoring occasions for that CN domain..., based on the stored CN domain specific DRX cycle length, when using DRX in idle mode." This setting determines the length of the DRX cycle that the UE uses while in idle mode.

GPIB Command: CALL[:CELL]:DRX:CLENgth

  • Network Mode of Operation

A TD-SCDMA network can operate in either Network Mode I or Mode II.

  • In Mode I the MSC (Mobile Switching Centre) and the SGSN (Serving GPRS Support Node) are connected together. The primary consequence of Mode I is that UEs are allowed to perform combined GPRS Attach & IMSI Attach procedures and combined Location Update & Routing Area Update procedures.

In Mode I the UE is not required by the standards to use the combined procedures, although it is likely to do so. It is likely that the UE will only do a combined GPRS attach procedure on power up.

  • In Mode II the MSC and SGSN are not inter-connected. In this case, the UE is forced into doing separate GPRS Attach and IMSI Attach procedures and separate Routing Area Update and Location Area Update procedures.

GPIB Command: CALL[:CELL]:NMOPeration:TDSCdma

  • Protocol Revision Control

This setting specifies which 3GPP TD-SCDMA standard version the signalling messages will comply with during the call setup procedure. When Auto is selected, the protocol revision will based on the UE Reported Access Stratum Release Indicator, see UE Access Stratum Rel Ind.

Setting up a HSDPA service call requires the protocol revision to be revision 5 or above. You can either set the Protocol Revision Control to be Revision 5, or set it to Auto if the UE Reported Access Stratum Release Indicator is 5 or above.

GPIB Command: CALL:PREVision:CONTrol

Broadcast Channel (BCCH) Update Procedure (SIB Contents)

While in active cell operating mode, the test set broadcasts the System Information Message on the BCCH. The System Information Message consists of a Master Information Block (MIB) and several System Information Blocks (SIBs 1, 2, 3, 5, 7 and 11). The information in these SIBs helps the UE (mobile station) successfully communicate with the network.

The user-settable parameters contained in the MIB and SIBs are listed below. When you change any of these parameters, the test set changes the information it sends on the BCCH accordingly. Changing any of the parameters causes the test set to perform a BCCH update procedure if the call status is idle and BCCH Update Page is set to Auto (if the test set is on a connection with a UE, the test set will post an error if you try to change any of these parameters). During a BCCH update procedure, the test set sends a Paging Type I message to the UE indicating that it needs to re-read the BCCH. If your UE does not support the BCCH update procedure, you may set BCCH Update Page to Inhibit, which prevents the test set from sending a Paging Type I message to the UE (the test set still updates the BCCH). However, note that the UE will then be unaware of the changes in the BCCH.

Parameters Whose Change Triggers BCCH Update

  • MIB Settable Parameters:

  • MCC (Mobile Country Code)

  • MNC (Mobile Network Code)

  • SIB 1 Settable Parameters:

  • LAC (Local Area Code)

  • PS Domain Information

  • ATT (IMSI Attach) Flag State

  • CN Domain Specific DRX Cycle Length

  • RAC (Routing Area Code)

  • Network Mode of Operation

  • T300 RRC Conn Req Retransmit Timer

  • N300 RRC Conn Req Max Retransmits

  • T312 Link Establishment Timer (Idle)

  • T312 Link Establishment Timer (Connected)

  • N312 Link Establishment In-Sync Count (Idle)

  • N312 Link Establishment In-Sync Count (Conn.)

  • T313 Out-of-Sync Reception Timer

  • N313 Successive Out-Of-Sync Reception Max

  • N315 Successive In-Sync Reception Counter

  • T308 RRC Conn Release Comp Retransmit Timer

  • T3212 Periodic Location Update Timer

  • SIB 3 Settable Parameters:

  • Cell Identity

  • Maximum Allowed UL Tx Power

  • SIB 5 Settable Parameters:

  • Broadcast Primary CCPCH Tx Power

  • UpPCH Power Ramp Step

  • Desired UpPCH RX power

  • Sync UL Code Bitmap

  • Max Sync UL Transmissions

  • Maximum Number of Sync Attempts

  • SIB 11 Settable Parameters:

  • Scrambling Code

  • Protocol Revision Control


Generator Info

Last updated: April 21, 2010

Generated Power Level Information Screen

Downlink Channel Levels

AWGN Power

This page is only applicable for the Active Cell operating mode. See Downlink Channel Level for the downlink channel levels in TD-SCDMA Test operating mode.

Generated Power Level Information Screen

This screen displays the "current" and "desired" cell power, AWGN power and total power levels. To query the results using GPIB commands, see CALL:STATus.

Downlink Channel Levels

For TD-SCDMA, all downlink time slots are transmitted at the level of Cell Power. The power of all physical channel in one time slot sum to 100% of the cell power. See Channel Config Information for the channel code configurations.

You can set the downlink DPCH Level. The power levels of other channels are fixed in the test set, as shown in the Downlink Code Channel Levels Screen.

  • DPCH Level - This setting allows you to set the DPCH power level from -30 to 0 dB. You can also turn off the DPCH power state, in which case the UE will not be able to detect the downlink DPCH.

  • Downlink Code Channel Levels Screen

The Downlink Code Channel Power Level screen displays the downlink channel levels currently in use by the test set (known as the "current" values), as well as the "desired" levels (including DPCHo). To query the results using GPIB commands, see CALL:STATus.

The DPCHo Level is a calculated value used to balance the relative power levels in a time slot so that they sum to 100% of the cell power. The Current DPCHo Level indicates the current power level in use and the Desired Level indicates the calculated level. When DPCH Level is changed, the test set re-calculates a DPCHo level in order that the DPCH and DPCHo levels sum to 100% of the cell power. If the state of DPCH Level is set to Off, the downlink DPCH channel can not be detected by the UE and the DPCHo occupies 100% of the time slot power.

The DPCHo is always active concurrently with the DPCH.


UE Timer and Constant Parms

Description

The following settings can only be changed when call status is Idle . If BCCH Update Page is set to Auto and you change these settings while your UE is camped to the test set, the test set performs a Broadcast Channel (BCCH) Update Procedure (SIB Contents). If BCCH Update Page is set to Inhibit (the default value) and you change these settings while your UE is camped to the test set, you must force your UE to re-read the BCCH to observe the change.

  • T300 RRC Conn Req Retransmit Timer

This setting determines how long the UE waits for the RRC Connection Setup after sending an RRC Connection Setup Request.

T300 can be set to one of the following values: 400, 600, 800, 1000, 1200, 1400, 1600, 1800, 2000, 3000, 4000, 6000, 8000 ms.

GPIB Command: CALL[:CELL]:BCCHannel:T300

  • N300 RRC Conn Req Max Retransmits

This setting specifies the maximum number of retransmissions of the RRC Connection Request message.

N300 can be set to any integer value from 0 to 7.

GPIB Command: CALL[:CELL]:BCCHannel:N300

  • T312 Link Establishment Timer (Idle)

This setting determines how long the UE waits for an N312 "in-sync" indication from layer 1 when establishing a dedicated channel and the connection status is Idle. According to 3GPP TS 25.331 table 10.3.3.44, The value 0 is not used.

T312 can be set to any integer value from 1 to 15.

GPIB Command: CALL[:CELL]:BCCHannel:T312[:IDLE]

  • T312 Link Establishment Timer (Connected)

This setting determines how long the UE waits for an N312 "in-sync" indication from layer 1 when establishing a dedicated channel in connected status. According to 3GPP TS 25.331 table 10.3.3.43, The value 0 is not used.

GPIB Command: CALL[:CELL]:BCCHannel:T312:CONNected

  • N312 Link Establishment In-Sync Count (Idle)

This setting specifies the number of " in-syncs" required when establishing a dedicated channel when the connection status is Idle.

N312 can be set to one of the following values: 1, 2, 4, 10, 20, 50, 100, 200, 400, 600, 800, 1000.

GPIB Command: CALL[:CELL]:BCCHannel:N312[:IDLE]

  • N312 Link Establishment In-Sync Count (Conn.)

This setting specifies the number of " in-syncs" required when establishing a dedicated channel in connected status.

N312 can be set to one of the following values: 1, 2, 4, 10, 20, 50, 100, 200, 400, 600, 800, 1000.

GPIB Command: CALL[:CELL]:BCCHannel:N312:CONNected

  • T313 Out-of-Sync Reception Timer

3GPP TS 25.331 8.5.6 states that after receiving N313 consecutive "out of sync" indications from layer 1 (see N313 Successive Out-Of-Sync Reception Max ), the UE shall start the T313 timer. Upon receiving N315 successive "in sync" indications from layer 1 ( N315 Successive In-Sync Reception Counter ), the UE shall stop and reset the T313 timer. If T313 expires, a "Radio Link failure" has occurred, and the UE shall drop the call.

GPIB Command: CALL[:CELL]:BCCHannel:T313

  • N313 Successive Out-Of-Sync Reception Max

N313 specifies the maximum number of successive "out of sync" received from L1.

N313 can be set to one of the following integer values: 1, 2, 4, 10, 20, 50, 100, 200.

GPIB Command: CALL[:CELL]:BCCHannel:N313

  • N315 Successive In-Sync Reception Counter

N315 specifies the maximum number of successive "in sync" received from L1 during T313 is activated.

N315 can be set to one of the following integer values: 1, 2, 4, 10, 20, 50, 100, 200, 400, 600, 800, 1000.

GPIB Command: CALL[:CELL]:BCCHannel:N315

  • T308 RRC Conn Release Comp Retransmit Timer

T308 specifies the time between the transmissions of RRC Connection Release Complete message.

GPIB Command: CALL[:CELL]:BCCHannel:T308

  • N308 RRC Conn Release Comp Max Retransmits

N308 specifies the maximum number of retransmissions of the RRC CONNECTION RELEASE COMPLETE message.

GPIB Command: CALL[:CELL]:RRC:CRELease:N308

  • T3212 Periodic Location Update Timer

T3212 specifies how often the UE will perform the periodic location update procedure. It is signaled in SIB1.

When T3212 is set to zero, the UE will regard the timer to be infinite.

GPIB Command: CALL[:CELL]:BCCHannel:T3212

Related Topics

GPIB Commands: CALL:BCCHannel


Channel Config Information

Channel Configurations in Active Cell Operating Mode

  • Uplink Channel Configuration

  • TD-SCDMA Channel Configuration Information

  • HSDPA Channel Configuration Information (only applicable to the feature-licensed test application)

Channel Configurations in TD-SCDMA Test Operating Mode

Channel Configurations in Active Cell Operating Mode

For all the supported downlink and uplink channels in Active Cell operating mode, see Active Cell Operating Mode.

Uplink Channel Configuration

  • Sync UL Code Bitmap

The 8-bit digits determines which SYNC_UL codes in the SYNC_UL code group (once the setting of Scrambling Code is selected, the code group is determined, see Scrambling Code) can be used by the UE. Each bit indicates the availability of a SYNC_UL code. The value 1 of a bit indicates that the corresponding SYNC_UL code can be used. The value 0 of a bit indicates that the corresponding SYNC_UL code can not be used. For example, if the Scrambling Code is set to '4', according to the Table 1: Relationships between the synchronization codes, the available SYNC_UL ID is from 8 to 15. Setting the Sync UL Code Bitmap to "00000001" means that the SYNC_UL ID 8 can be used by the UE.

This parameter is sent in SIB 5 on the BCCH. In the Active Cell operating mode, this setting can only be changed when the call status is Idle.

GPIB Commands: CALL:UPLink:UPPChannel:SYNChronize:CBITmap

  • Max Sync UL Transmissions

This setting specifies the maximum number of SYNC_UL transmissions in a power ramping sequence during a synchronisation attempt of the UE.

This parameter is sent in SIB 5 on the BCCH. In the Active Cell operating mode, this setting can only be changed when the call status is Idle.

GPIB Commands: CALL:UPLink:UPPChannel:SYNChronize:TRANsmission[:MAXimum]

  • Maximum Number of Sync Attempts

This setting specifies the maximum number of synchronisation attempts for one random access procedure.

This parameter is sent in SIB 5 on the BCCH. In the Active Cell operating mode, this setting can only be changed when the call status is Idle.

GPIB Commands: CALL:UPLink:UPPChannel:SYNChronize:ANUMber[:MAXimum]

  • TD-SCDMA DL Dpchannel Midamble Mode

The test set supports the following midamble allocation schemes:

  • Default - The downlink midamble is allocated by layer 1 depending on the associated channelisation code. The fixed association between midambles and channelisation codes is given in 3GPP TS 22.221 Annex AA.2.

  • Common - The midamble for the DL is allocated by layer 1 depending on the number of channelisation codes currently being present in the DL time slot.

GPIB Commands: CALL:DOWNlink:DPCHannel:MIDamble:MODE

TD-SCDMA Channel Configuration Information

When the Operating Mode is Active Cell, the TD-SCDMA Downlink and Uplink channels are configured as shown in the Channel Configurations window.

Click on the red circle for more information.

Note 1: DPCHo is OCNS channels which simulates DPCHs for other users in the same time slot of DPCH. See DPCH and DPCHo Configuration for Different Channel Types.

DPCH and DPCHo Configuration for Different Channel Types

 | AMR Voice DPCH | 12.2 k RMC DPCH | 12.2 k RMC DPCHo | 64 k RMC DPCH | 64 k RMC DPCHo | 144 k RMC DPCH | 144 k RMC DPCHo | 384 k RMC DPCH | 384 k RMC DPCHo
Time Slot | 4 | 4 | 4 | 4 | 4 | 4,5 | 4,5 | 3,4,5,6 | 3,4,5,6
Channelization Codes | 16_1, 16_2 | 16_1, 16_2 | 16_3 to 16_10 | 16_1 to 16_8 | 16_9 to 16_10 | 16_1 to 16_8 | 16_9 to 16_10 | 16_1 to 16_9 | 16_10
Midamble | See TD-SCDMA DL Dpchannel Midamble Mode. K = 8
Period/Length/Offset | 1/0/0 | 1/0/0 | 1/0/0 | 1/0/0 | 1/0/0 | 1/0/0 | 1/0/0 | 1/0/0 | 1/0/0

HSDPA Channel Configuration Information

This section is only applicable to the feature-licensed test application.

When an HSDPA connection is successfully established (see Establish an HSDPA Connection ), the HSDPA Downlink/Uplink channels are configured as shown in the HSDPA Channel Configurations window.

Click on the red circle for more information.

HSDPA Channel Configuration - RMC and VRC

Note 2: The downlink HS-PDSCH configuration varies with RMC Type or VRC.

HSDPA Channel Configuration - HS-SCCH Detection

Channel Configurations in TD-SCDMA Test Operating Mode

For all the supported downlink and uplink channels in TD-SCDMA Test Operating Mode, see TD-SCDMA Test Operating Mode.

When the Operating Mode is TD-SCDMA Test, the TD-SCDMA Downlink/Uplink channels are configured as shown in the Channel Configurations window.

Click on the red circle for more information.

Note 3: DPCHo is OCNS channels which simulates DPCHs for other users in the same time slot of DPCH.

Uplink Channel Configurations

When the Operating mode is TD-SCDMA Test, there are two DCHs expected in the uplink signal from the UE: DCCH’s and the RMC DTCH. The DPCH must be configured according to the Channel Type.

The test set expects only one midamble code for all code channels of UL DPCH. The midamble code used by a channel is derived from the periodic basic midamble sequence with an offset. The offset is derived from Midamble Configuration K and Midamble shift (k = 1, &, K) (Please refer to 3GPP standard TS25.221 for more information).

You can set the midamble for uplink channels by setting the midamble configuration and midamble shift for UL DPCH, and the UE must be configured to the same midamble code as determined by Uplink DPCH Midamble Configuration and Uplink DPCH Midamble Shift.

GPIB Commands: CALL:TDTest:UPLink:DPCHannel:MCONfig, CALL:TDTest:UPLink:DPCHannel:MSHift

Orthogonal Channel Noise Simulator (OCNS)

OCNS is used to simulate additional users on the downlink. OCNS is automatically enabled when the sum of the levels of all the enabled downlink physical channels in a specific time slot is less than the Cell Power setting.


Trig Output Setup

Last updated: May 13, 2010

Description

The test set provides a 5 V, 25 us pulse at the TRIG OUT rear panel connector for triggering other test equipment from the test set.

This pulse is generated according to the Trigger Output Setup setting:

  • System Frame Clock

When Trigger Output Setup is set to System Frame Clock, pulses are generated with a period of 10 ms, in alignment with the first symbol period of each frame.

  • Measurement Generated

When Trigger Output Setup is set to Measurement Generated, pulses are generated with a period determined by the measurement that is currently running.

Related Topics

GPIB Commands: CALL:TRIGger


Security Information

Description

  • Security Parameters

  • Reset Auth SQN

  • Security Results

Security Procedure Diagrams

  • Security Procedure with Authentication Only

  • Security Procedure with Authentication and Integrity Protection

Description

When the Security Operations is set to a value other than None, the test set will perform security procedures during some call processing operations. You can specify which security procedures are performed(Auth & Int , or Auth Only ). Authentication and integrity protection are described in 3GPP TS 25.331 and TS 33.102.

During authentication, both the UE and the network confirm that the other is valid by a series of computations based on a shared secret Authentication Key. The computations are performed using one of two Authentication Algorithms, with K, SQN and the signalled values for Random (RAND) Value and AMF Value as inputs.

Security Parameters

  • Security Operations

  • None : No security procedures are performed during call processing operations.

  • Auth & Int : Both authentication and integrity protection are performed during call processing operations.

  • Auth Only : Only authentication is performed during call processing operations.

GPIB Command: CALL:SECurity:OPERation

  • Authentication Algorithm

The test set supports both the normal operation authentication algorithm ( Milenage (Rijndael)) and the conformance test algorithm described in 3GPP TS 34.108 ( Test 34.108 ).

GPIB Command: CALL:SECurity:AUTHenticate:ALGorithm

  • Authentication Key

32 hex digits representing the 128-bit subscriber key (K).

GPIB Command: CALL:SECurity:AUTHenticate: [KEY]

  • Operator Variant Parm Type

This setting specifies whether the Operator Variant Auth Alg contains the OP or OPc. If Operator Variant Auth Alg contains OP, the test set calculates OPc as per 3GPP TS 35.206.

GPIB Command: CALL:SECurity:AUTHenticate:OPVariant:PTYPe

  • Operator Variant Auth Alg

32 hex digits representing either the 128-bit OP or OPc. You must indicate, using the Operator Variant Parm Type setting, whether this setting contains OP or OPc.

This setting is only used when the Authentication Algorithm is set to Milenage (Rijndael).

GPIB Command: CALL:SECurity:AUTHenticate:OPVariant:PVALue

  • Random (RAND) Value

32 hex digits representing the 128-bit random challenge.

GPIB Command: CALL:SECurity:AUTHenticate:RANDom:TDSCdma

  • AMF Value

4 hex digits representing the 16-bit authentication management field.

GPIB Command: CALL:SECurity:AUTHenticate:AMF

Reset Auth SQN

The authentication sequence number (SQN) is set to zero each time the test set is powered on. It then increments each time an authentication procedure is performed. The SQN can be reset to zero by selecting Reset Authen. SQN or sending the CALL:SECurity:AUTHenticate:SQN:RESet:[IMMediate] command.

Security Results

MM Authentication Result

This result indicates the success or failure of the UE and test set to authenticate in the CS domain.

GPIB Command: CALL:SECurity:AUTHenticate:RESult:MM:TDSCdma?

GMM Authentication Result

This result indicates the success or failure of the UE and test set to authenticate in the PS domain.

GPIB Command: CALL:SECurity:AUTHenticate:RESult:GMM:TDSCdma?

UE Reported Failure Cause

The UE Reported Failure Cause can be any number between 1 and 255. 3GPP TS 24.008 s10.5.3.6 and s10. 5.5.14 provide mappings of the numeric values to their equivalent causes.

GPIB Command: CALL:MS:REPorted:AUTHenticate:FAILcause?

Security Procedure Diagrams

Security Procedure with Authentication Only

Security Procedure with Authentication and Integrity Protection

Related Topics

GPIB Commands: CALL:SECurity


UE Measurement Control

Last updated: March 10, 2010

Description

When there is an active connection between the UE and the test set, the UE can perform measurements on the test set's downlink signal and report the measurement results. By pressing the Send Measurement Request (F1) on the front panel or sending the CALL:MS:REPorted:MEASurement:REQuest command, the test set sends a single measurement control message to the UE, with the following measurement information:

  • the Measurement type is Intra-frequency;

  • the Measurement quantity is P-CCPCH RSCP;

  • the Measurement reporting criteria is Periodical, with the reporting interval to be 250ms.

You can view the measurement result either from the front panel, or retrieve it using the GPIB command (See CALL:MS:REPorted[:CELL]:PRIMary:CCPChannel:RSCP?).

Measurement Results

  • P-CCPCH RSCP (Received Signal Code Power): the received power on P-CCPCH. The reporting range for P-CCPCH RSCP is from -120 to -25 dBm. 3GPP standard TS 25.123 defines the following mapping table of the measurement quantity.

Reported value | Measured quantity value | Unit
P-CCPCH RSCP_LEV _-05 | P-CCPCH RSCP <-120 | dBm
P-CCPCH RSCP_LEV _-04 | -120 <=P-CCPCH RSCP < -119 | dBm
P-CCPCH RSCP_LEV _-03 | -119 <=P-CCPCH RSCP < -118 | dBm
… | … | …
P-CCPCH RSCP_LEV _89 | -27 <=P-CCPCH RSCP < -26 | dBm
P-CCPCH RSCP_LEV _90 | -26 <=P-CCPCH RSCP < -25 | dBm
P-CCPCH RSCP_LEV _91 | -25 <=P-CCPCH RSCP | dBm

This measurement results can be cleared by sending a new Measurement Request or Partial/Full Preset operation.


Voice Call

Last updated: March 10, 2010

AMR Setup

The AMR source is fixed to Echo in the test set.

AMR Radio Access Bearer

The AMR Radio Access Bearer can be set to:

  • 12.2k Voice (3GPP TS 34.108 s6.10.2.4.1.4)

  • 10.2k Voice (3GPP TS 34.108 s6.10.2.4.1.5)

  • 7.95k Voice (3GPP TS 34.108 s6.10.2.4.1.6)

  • 7.4k Voice (3GPP TS 34.108 s6.10.2.4.1.7)

  • 6.7k Voice (3GPP TS 34.108 s6.10.2.4.1.8)

  • 5.9k Voice (3GPP TS 34.108 s6.10.2.4.1.9)

  • 5.15k Voice (3GPP TS 34.108 s6.10.2.4.1.10)

  • 4.75k Voice (3GPP TS 34.108 s6.10.2.4.1.11)

This parameter can only be set when call status is idle. Note: "k" refers to kbps.

GPIB command: CALL:SERVice:AMR:RAB

Speech Echo Loopback Delay

This setting specifies the amount of time that speech frames received on the uplink are delayed before being retransmitted on the downlink.

This setting cannot be changed when the cell operating mode is Active Cell and the call/data status is any state other than IDLE, or the test set will reject the change and an error will be reported.

GPIB command: CALL:SERVice:AMR:SPEech:ECHO:LOOPback:DELay

Related Topics

Manual Operation: Set Up a Call and Make a Connection


Radio Bearer Test Mode and Channel Type

Last updated: May 12, 2010

Radio Bearer Test Mode

Radio Bearer Test Mode is a special mode of operation defined by the TD-SCDMA specifications. Its purpose is to provide for efficient manufacturing testing of a TD-SCDMA UE by offering a simplified mode of operation wherein the test set has complete control of the necessary UE functions. Radio bearer test mode and test loop function are two of the UE conformance testing functions that can be activated (and deactivated) by the test set.

The test set only supports RB Test Mode call originations to CELL_DCH state, see RB Test Mode Call Origination to CELL DCH .

According to the standard (3GPP TS 34.109), the UE test loop function can be operated in three different loopback modes: UE test loop mode 1, UE test loop mode 2 and UE test loop mode 3. The test set supports the UE test loop mode 1 and UE test loop mode 2. See in which the loopback point is located above Layer 2.

RB Test Mode Setup

  • RB Test Mode RRC State:

If CELL_FACH is selected, the UE will be set into CELL_FACH state when you initiate a RB test call setup from the test set, which is required in 3GPP TS 34.122 s6.8. Once the RRC status changed to CELL_FACH, you can only release the call back to Idle state.

If CELL_DCH is selected (normal case), the RRC status will be CELL_DCH after the RB test call setup.

Use the CALL:STATus:RRC:STATe? command to check the current RRC status.

Note: Physical Channel Reconfiguration and System Handover is not supported during CELL_FACH state.

GPIB command: CALL:SERVice:RBTest:RRC:STATe

  • UE Loopback Scenario

This setting controls which loopback mode the Test control (TC) protocol layer instructs the UE to go into. This is signaled to the UE in the Close UE Test Loop message.

  • In Type 1 loopback mode, the loopback point is just above the traffic plane RLC entities (see 3GPP TS 34.109, 5.3.2.6). The DL RLC protocol can operate in either transparent mode (TM) or acknowledged mode (AM).

  • In Type 2 loopback mode, the loopback point is just above the layer 1 transport channels (see 3GPP TS 34.109, 5.3.2.7), and both data and CRC are looped back.

Typically, you should set UE Loopback Scenarios to Type 1, RLC TM when performing the Loopback Bit Error Ratio (BER) Measurement.

You can set UE Loopback Scenarios to either Type 1, RLC AM or Type 2 when performing the Block Error Ratio (BLER) Measurement. In Type 1, RLC AM the test set calculates BLER from the ratio of number of UE retransmission requests and the total number of blocks sent to the UE. For loopback type 2, the test set calculates BLER by checking returned data and CRC and count number of block errors and the total number of sent blocks.

This setting is not applicable when the Channel Type is 12.2K + HSDPA.

GPIB command: CALL:MS:LOOPback:SCENario

Reference Measurement Channels

While it is still possible to configure layers 1 and 2 in any valid configuration in Radio Bearer Test Mode, the typical use of this mode is to set up the special test configurations known as "Reference Measurement Channels". The reference measurement channels are a defined set of configurations of layers 1 and 2 that provide stable, predictable behavior for radio testing. All aspects of these layers are explicitly defined by the definition of the Reference Measurement Channels given in the TD-SCDMA system specifications.

Symmetrical RMCs

The symmetrical RMCs are typically used for transmitter testing and for receiver testing using BER (via loopback mode 1). The symmetrical RMCs always use Transparent Mode (TM) RLC entities on the DTCH. The UE must send the Close UE Test Loop Complete message to the test set before it will start transmitting data on the downlink DTCH.

Channel Type

The Channel Type setting allows you to specify which Reference Measurement Channels (RMC) to use while operating in Radio Bearer Test Mode. The test set supports to establish symmetrical RMCs, at 12.2 kbps. Channel Type can be set to:

  • 12.2 kbps RMC SC: refers to the 12.2 kbps Reference Measurement Channel Single Code specified in 3GPP TS 25.102

  • 12.2 kbps RMC MC: refers to the 12.2 kbps Reference Measurement Channel Multi Code specified in 3GPP TS 25.102

  • 64k RMC (Active Cell operating mode only)

  • 64k UL / 144k DL AM RMC (Active Cell operating mode only)

  • 64k UL / 384k DL AM RMC (Active Cell operating mode only)

  • 12.2k RMC + HSDPA (Active Cell operating mode only) (An additional feature license is required)

  • 12.2k RMC + HSPA (An additional feature license is required)

GPIB command: CALL:SERVice:RBTest:RAB

In active cell operating mode, the Channel Type setting can only be changed when the call status is Idle.

The test set supports only one type of bearer service at a time.

Related Topics

GPIB Commands: CALL:DPCHannel


Short Message Service

This section is only applicable to the feature-licensed test application.

Short Message Service (SMS) Overview

Mobile Terminated SMS (MT SMS)- Sending a Message to the Mobile Station

Mobile Originated SMS (MO SMS)- Receiving Messages Transmitted by the Mobile Station

How Do I Use the Short Message Service (SMS) Feature?

Short Message Service (SMS) Overview

Short Message Service (SMS) provides a means to transfer short messages between a mobile station (MS) and a Short Message Entity (SME) via a Service Centre (SC). Refer to 3GPP TS 24.011 and TS 23.040 for the SMS support and technical realization standards.

The test set supports the following SMS capablities:

  • Point-to-Point SMS - Includes information on how to send and receive point-to-point SMS messages in CS (Circuit Switched) or PS (Packet Switched) domain.

  • Mobile Terminated SMS (MT SMS) (send a message from the test set to MS)

  • Mobile Originated SMS (MO SMS) (send a message from MS to the test set)

Once your mobile has successfully camped or attached to the test set, you can make an SMS at any time, regardless of the call connection status.

Mobile Terminated SMS (MT SMS)- Sending a Message to the Mobile Station

MT SMS are SMS messages sent to the mobile station.

The test set allows you to specify several MT SMS message parameters, including the transportation mechanism, the content, and some header parameters. This allows you to send SMS messages of various usages and configurations. When the SMS process is over, a report is always returned and displayed on the test set; either confirming that the MS has received the short message, or informing that it was impossible to deliver the short message to the MS, and the reason why.

Supported Mobile Terminated SMS Scenarios

The test set supports sending MT SMS over existing or non-existing circuit-switched or packet-switched connections. It is therefore possible to send the UE an MT SMS under the following conditions:

  • Transmit an MT SMS message on a circuit switched call (voice or RB Test Mode) using the existing CS connection if Transportation is set to CS domain;

  • Transmit an MT SMS message on a packet switched call (HSDPA RB Test Mode) if Transportation is set to PS domain;

  • Use a temporary circuit switched connection on a PS call if Transportation is set to CS Domain and the UE is IMSI attached;

  • Use a temporary packet switched connection on a CS call if Transportation is set to PS Domain and the UE is GMM attached.

Mobile Terminated SMS Parameters

  • Transportation

You can choose to send Point-to-Point SMS messages in either the CS or PS domain. The domain to be used is configurable by specifying the Transportation mechanism.

GPIB Command: CALL:SMService:PTPoint[:MTERminated]:TRANsport

  • Content

Several SMS message options are available which allow you to use the pre-defined (Text1 or Text2) or create the message content (Custom Text) to be sent to the mobile station.

  • Text1 - This is a predefined point to point text message. The ASCII text strings are

01234567890ABCDEFGHIJKLMNOPQRSTUVWXYZabcdefghijklmnopqrstuvwxyz

  • Text2 - This is a predefined point to point text message. The ASCII text strings are

Agilent Technologies, your partner in wireless solutions

  • Custom Text - You can customize the text sent in the SMS message when Content is set to Custom Text. The custom text message can be defined only via the remote user interface (see CALL:SMService:PTPoint[:MTERminated]:TEXT:CUSTom). The maximum length for the user defined text messages is 160 characters.

The default custom text message is: Enter your text here

GPIB Command: CALL:SMService:PTPoint[:MTERminated]:CONTents

  • Data Coding Scheme - Used to identify the coding scheme used by the SMS message contents.

It is important for you to configure the Data Coding Scheme parameter in order for the mobile station to know what type of message it is receiving. Examples of parameter values that you are likely to use are:

0 | ASCII Text Messages (concatenated or non-concatenated)
4 | General binary messages (ringtones, vcards, bitmap picture messages, etc.)
8 | UCS2 (Unicode) messages (Chinese, Japanese, Hebrew, etc.)
245 | WAP Push and MMS notification messages
247

GPIB Command: CALL:SMService:PTPoint[:MTERminated][:MESSage]:DCSCheme

Mobile Terminated SMS Information

The Status area in the Last Sent Message window displays the state of the message sent to the mobile station. The GPIB command is CALL:SMService:PTPoint[:MTERminated]:SEND:STATe?.

There are six possible MT SMS message states.

  • "IDLE" - An SMS message has not been successfully sent from the test set since power-up, preset, or SMS clear.

  • "SEND" - The test set has initiated the process of sending an SMS message.

  • "ACK" - The SMS message sent by the test set was acknowledged by the mobile station before timeout.

  • "NACK" - The SMS message sent by the test set was NOT acknowledged by the mobile station and send timeout.

  • "REJ" - The SMS message sent by the test set was rejected by the mobile station. A cause value for the reject is also reported by the mobile station, you can use the CALL:SMService:PTPoint[:MTERminated]:RCAuse? query to retrieve the reject cause value returned by the mobile station. Possible cause values and the meanings are:

Reject Cause | Hex equivalent | Description
129 | 81 | Short message Type 0 not supported
130 | 82 | Cannot replace short message
143 | 8F | Unspecified TP-PID error
145 | 90 | Message class not supported
159 | 9F | Unspecified TP-DCS error
176 | B0 | TPDU not supported
208 | D0 | (U)SIM SMS storage full
209 | D1 | No SMS storage capability in (U)SIM
210 | D2 | Error in MS
211 | D3 | Memory Capacity Exceeded
212 | D4 | (U)SIM Application Toolkit Busy
213 | D5 | (U)SIM data download error
224-254 | E0-FE | Values specific to an application
255 | FF | Unspecified error cause

  • "FAIL" - A command to send an SMS message has been received by the test set, but it cannot send the SMS message over the air because of an error. An example of a situation that would produce such an error is if the mobile station is not connected to the test set.

When sending SMS messages programmatically, you should query the SMS Message Status to delay the sending of each message until the previous message has been acknowledged by the phone. If the command to send the message is received before the sending of a previous message has been acknowledged/rejected or timed out, the current message may not be sent.

Mobile Originated SMS (MO SMS)- Receiving Messages Transmitted by the Mobile Station

Mobile Originated SMS Parameters

  • Loopback - Used to enable or disable the loopback mode of the test set. When Loopback is set to On, the test set takes the message it receives from the mobile station and sends it back to the mobile station.

This feature gives you the ability to simulate the complete transfer of an SMS message from an originating mobile station to a destination mobile station through the network.

GPIB Command: CALL:SMService:PTPoint:MORiginated:LOOPback

Last Received Message Information

The header and message elements of mobile originated SMS Submit messages are available in the Last Received Message window or by GPIB command, as listed below.

  • Transportation: CALL:SMService:PTPoint:MORiginated[:MESSage]:TRANSport?

  • Coding Scheme: CALL:SMService:PTPoint:MORiginated[:MESSage]:DCSCheme?

  • Length: CALL:SMService:PTPoint:MORiginated[:MESSage]:LENGth?

  • Destination: CALL:SMService:PTPoint:MORiginated[:MESSage]:DESTination?

  • Content: CALL:SMService:PTPoint:MORiginated[:MESSage]:TEXT?

  • Reference No: CALL:SMService:PTPoint:MORiginated[:MESSage]:MREFerence?

  • UDHI: CALL:SMService:PTPoint:MORiginated[:MESSage]:UDHind?

  • Protocol Identifier (GPIB only): CALL:SMService:PTPoint:MORiginated[:MESSage]:PIDengtifier?

  • Status (GPIB only): CALL:SMService:PTPoint:MORiginated[:MESSage]:SRRequest?

  • User Data Header Length (GPIB only): CALL:SMService:PTPoint:MORiginated[:MESSage]:UDHLength?

How Do I Use the Short Message Service (SMS) Feature?

  • Mobile-Terminated SMS Procedure

  • Mobile-Originated SMS Procedure

Mobile-Terminated SMS Procedure

This section describes general procedures for Mobile-Terminated SMS tests. You can choose to send an SMS while in idle state or on a call connection.

  1. Connect the mobile station to the test set.

  2. Power on the mobile station.

  3. If you want to send an SMS in idle state, wait for the mobile station to perform a power up registration. The mobile station information should appear in the UE Information window after a successful registration.

  4. If you want to send an SMS on a voice or data call, follow the procedure in Set Up a Call and Make a Connection to set up a call connection. When finished, verify that the call has established by checking for Connected in the Active Cell field.

  3. Press the Call Setup key.

  4. Press the More key on the lower left side of the test set two times until 3 of 3 of the Call Control menu is displayed. Press the Short Message Service (F5) and then Point to Point (F1). The Message Summary screen appears.

  5. (Optional) Press Mobile Terminated (F2) and set up the Mobile-Terminated SMS parameters as desired. For example, If you want to send message over CS domain, set the Transportation parameter to CS Domain (See Supported Mobile Terminated SMS Scenarios on what scenarios are supported by the test set). Choose the message to send by selecting the Content parameter. In this example, set the Content to Text2 to send the following message to the UE: "Agilent Technologies, your partner in wireless solutions".

  6. Press the Send Message softkey ( F1 ) to send the message. Observe the mobile station for indications that the message has been received. The test set also gives an indication.

Mobile-Originated SMS Procedure

This section describes general procedures for Mobile-Originated SMS tests. You can choose to receive an SMS while in idle state or on a call connection.

  1. Connect the mobile station to the test set.

  2. Power on the mobile station.

  3. If you want to receive an SMS in idle state, wait for the mobile station to perform a power up registration. The mobile station information should appear in the UE Information window after a successful registration.

  4. If you want to receive an SMS on a voice or data call, follow the procedure in Set Up a Call and Make a Connection to set up a call connection. When finished, verify that the call has established by checking for Connected in the Active Cell field.

  3. Press the Call Setup key.

  4. Press the More key on the lower left side of the test set two times until 3 of 3 of the Call Control menu is displayed. Press the Short Message Service (F5) and then Point to Point (F1). The Message Summary screen appears.

  5. (Optional) Press Mobile Originated (F3) and set up the Mobile-Originated SMS parameters as desired. For example, If you want the message received by the test set to be resent to the mobile station, set the Loopback parameter to On.

  6. (Optional) To clear the last received SMS message, press Clear All (F5).

  7. Use the mobile station to send a point-to-point message of "Hello" to any address.

  8. Observe the test set for indications that the message has been received. If the loopback mode is enabled, observe the mobile station for indications that the message has been received.

Related Topics

GPIB Commands: CALL:SMService


Data Channel

Description

DUT IP Setup

Data Counter

Data Throughput Monitor

DUT IP Setup

You must set up the DUT IP before setting up a packet data connection.

DUT IP Address

This setting sets up the wireless device's IP address.

GPIB Command: CALL:MS:IP:ADDRess[1]

DUT Primary DNS Server IP Address

As part of the PS data call setup procedures, the UE can include PPP/IPCP messages that ask the network for the IP addresses of the DNS servers that it should use to resolve domain names. These PPP/IPCP messages are carried as part of the PDP Context Activation message and in them the UE can request either the Primary DNS Server address or the Secondary DNS Server address or both. If the UE requests either one or both of the DNS server addresses and they are set to 0.0.0.0, the test set does not respond to the UE, returns an error, and then proceeds with the PDP Context Activation. If the UE requests both of the DNS server addresses and either one contains a value other than 0.0.0.0, that address is sent to the UE.

GPIB Command:

  • DUT Primary DNS Server IP Address - CALL:MS:DNSServer:PRIMary:IP:ADDRess

  • DUT Secondary DNS Server IP Address - CALL:MS:DNSServer:SECondary:IP:ADDRess

Data Counter

Data Counter

When a packet data connection is established, the test set keeps a count of the number of Internet Protocol (IP) data units that are transferred on both the forward (network to UE) and reverse (UE to network) directions. The recorded information is displayed on the Counters table.

  • DUT IP TX Bytes - This is the total number of IPv4 Bytes received by the test set from the UE on all activated PDP context.

  • DUT IP TX Packets - This is the total number of IPv4 Packets received by the test set from the UE on all activated PDP context.

  • DUT IP RX Bytes - This is the total number of IPv4 Bytes sent from the test set and destined for the UE on all activated PDP context.

  • DUT IP RX Packets - This is the total number of IPv4 Packets sent from the test set and destined for the UE on all activated PDP context.

GPIB Command:

  • DUT IP TX Bytes / Packets: CALL:COUNt:MS:IP:TX:[TOTal]?

  • DUT IP RX Bytes / Packets: CALL:COUNt:MS:IP:RX:[TOTal]?

Clear IP Counters

This action clears the contents of all the IP counters.

GPIB Command: CALL:COUNt:CLEar:MS:IP

Data Throughput Monitor

The Data Throughput Monitor can analyze data transfer rates under various RF and call processing conditions. You can initiate the Data Throughput Monitor by pressing the Instrument selection key. It is displayed on the Measurement/Instrument screen (accessible using the MEASUREMENT key).

Data throughput is the rate of data transfer to and from a UE.

Two sets of statistics are available from the Data Throughput Monitor:

  • OTA Rx and OTA Tx

OTA (Over the Air) throughput counts the data transmitted and received by the test set's protocol stack. The location of the measurement point in the protocol stack is dependent upon system type; this data could be a byte stream from RLP (Radio Link Protocol) or RLC (Radio Link Control) or PPP (point to point protocol). OTA throughput does not count physical layer overhead such as mid-amble, guard, or tail bits, or bits added by the encoding process.

  • IP Rx and IP Tx

IP (Internet Protocol) throughput counts the data transmitted and received by the test set. It measures the IP data transferred between the external LAN connector and the protocol stack. It provides a measure of the IP data packets being transferred to/from the wireless device.

How is Data Throughput Displayed?

When the Data Throughput Monitor is selected and a data call is connected, the test set accumulates data throughput statistics. If a data call is disconnected, data accumulation is suspended until another connection is made and data accumulation continues. Data accumulation can be cleared by performing a measurement reset or clearing the graph.

The test set provides two tools to analyze data throughput:

  • Graphical trace

  • Summary table

Graphical trace

The graphical trace presents up to the most recent 600 seconds (10 minutes) of data throughput statistics. Each of the following color-coded traces can be turned on or off:

  • OTA Tx - (Over The Air Transmitted bits-per-second). This is the rate of link-layer bit transfer sent from the wireless device. In other words, OTA translates into RLP (Radio Link Protocol) in cdma2000 and 1xEV-DO, or RLC (Radio Link Control) protocol in W-CDMA and GPRS, or PPP in GSM. Tx refers to the reverse or uplink channel direction.

  • OTA Rx - (Over The Air Received bits-per-second). This is the rate of link-layer bit transfer received by the wireless device. In other words, OTA translates into RLP (Radio Link Protocol) in cdma2000 and 1xEV-DO, or RLC (Radio Link Control) protocol in W-CDMA and GPRS, or PPP in GSM. Rx refers to the forward or downlink channel direction.

  • IP Tx - Internet Protocol Transmitted. This is the rate of network-layer bit transfer sent by the wireless device. Tx refers to the reverse or uplink channel direction.

  • IP Rx - Internet Protocol Received. This is the rate of network-layer bit transfer received by the wireless device. Rx refers to the forward or downlink channel direction.

  • Context 1 Tx - Internet Protocol Context 1 Transmitted. This is the rate of context 1 network-layer bit transfer sent by the wireless device. Tx refers to the reverse or uplink channel direction.

  • Context 1 Rx - Internet Protocol Context 1 Received. This is the rate of context 1 network-layer bit transfer received by the wireless device. Rx refers to the forward or downlink channel direction.

Four sets of Context <n> traces can be set: Context 1 Tx/Rx, Context 2 Tx/Rx, Context 3 Tx/Rx and Context 4 Tx/Rx. Totally there are 12 traces results are available form the Data Throughput Monitor, but six of them can be display on the screen at one time. The users can choose which traces are to be displayed by pressing Trace Display softkey.

Note that for an application that dose not support counters for multiple Contexts, the "Context<n>" counts will always be zero (a trace will still be available but every point will be "0").

A marker can be assigned to each trace to display instantaneous numeric data throughput values. Markers can be used in conjunction with the Freeze Graph feature to analyze points of interest on traces.

Summary table

The summary table provides the latest statistics for the four monitored measurements. Each measurement is displayed with the following statistics:

  • Marker

The data rate at the measurement's marker position in bits-per-second.

  • Current

The measurement's instantaneous data in bits-per-second.

  • Average

The measurement's average data rate in bits-per-second over the length of the data connection or since the last time the measurement was cleared.

  • Peak

The measurement's peak data rate in bits-per-second over the length of the data connection or since the last time the measurement was cleared.

  • Data Transfer

The measurement's total data throughput count, in bytes, over the length of the data connection or since the last time the measurement was cleared


Paging Service Type

Last updated: March 10, 2010

The Paging Service Type setting is used to set which type of service is initiated when the test set pages the UE. This setting does not apply to UE-originated connections.

Paging Service can be set to RB Test Mode or AMR Voice.

Related Topics

GPIB Commands: CALL:PAGing:SERVice[:TYPE]


Channel

Description

Channel specifies the UTRA Absolute RF Channel Number (UARFCN). The TD-SCDMA system uses the same frequency for both the uplink and downlink channels.

The test set supports the following TD-SCDMA frequency as defined in 3GPP 25.102.

Operating Band | Uplink/Downlink (MHz) | UARFCN=5 * (carrier frequency in MHz)
a | 2010 – 2025 | 10054 – 10121
f | 1880 – 1920 | 9404 – 9596

Related Topics

GPIB Commands: CALL:CHANnel


HSPA Parameters

  • HSDPA Parameters

  • HSUPA Parameters


UE Transmit Power Control

Description

  • Maximum Allowed UL Tx Power

This setting determines the maximum output power allowed to use while the UE is camping to the cell. The "Maximum allowed UL TX power" information element is sent in SIB3 on the broadcast channel message by the test set.

This setting affects whether the UE can camp to the test set. To ensure that your UE will camp to the test set at low cell power levels, set the Maximum Uplink Transmit Power Level to the maximum transmit power for your UE.

3GPP TS 25.102 6.2.1 specifies the following maximum transmit powers per power class:

Power Class | Nominal maximum output power | Tolerance
1 | +33 dBm | +1 dB / -3 dB
2 | +24 dBm | +1 dB / -3 dB
3 | +21 dBm | +2 dB / -2 dB
4 | +27 dBm | +1 dB / -3 dB

GPIB Command: CALL:UPLink:TXPower:LEVel:MAXimum

  • Broadcast Primary CCPCH Tx Power

Broadcast Primary CCPCH Tx Power is used in the uplink open loop power control for path loss calculation.

This parameter is sent in SIB 5 on the broadcast channel message by the test set.

GPIB Command: CALL[:CELL]:CCPChannel:PRIMary:BLEVel

  • UpPCH Power Ramp Step

The UE increases its transmission power by UpPCH Power Ramp Step for every UpPCH transmission. This parameter is sent in SIB 5 on the broadcast channel message by the test set.

GPIB Command: CALL:UPLink:UPPChannel:POWer:STEP[:LEVel]

  • Desired UpPCH RX Power

This parameter specifies the desired UpPCH RX power at the test set's receiver in dBm and is sent in SIB 5 on the broadcast channel message by the test set.

GPIB Command: CALL:UPLink:UPPChannel:POWer:LEVel

  • Desired PRACH RX Power

This parameter specifies the desired PRACH RX power at the test set's receiver. The test set sends its Desired PRACH RX Power to the UE in the FPACH response to the UE's successful SYNC_UL transmission.

GPIB Command: CALL:UPLink:PRAChannel:POWer:LEVel


RF Gen Freq Ctrl

Description

The UE must be set to receive the downlink signal on the proper frequency. You can set the downlink frequency manually or automatically, depending upon the RF Gen Freq Ctrl setting.

  • When RF Gen Freq Ctrl is set to Auto , the downlink frequency is determined by the Channel setting.

  • RF Gen Freq

When RF Gen Freq Ctrl is set to Manual , the downlink frequency is determined by the RF Gen Freq setting. The RF Gen Freq setting is only applicable to TD-SCDMA Test operating mode and CW Operating Mode (in CW operating mode, generator frequency control is always manual).

Related Topics

GPIB Commands: CALL:CONTrol, CALL:RFGenerator


DL DTCH Data

Description

The data pattern of the DL DTCH data (user data) sent on the DPCH can be set to:

  • CCITT PN15 - a continuous series of appropriate pseudo-random bits

  • CCITT PN9 - a continuous series of appropriate pseudo-random bits

  • Incrementing - a 16 bit data pattern that starts at 0000 0000 0000 0000 and increments by 1 each TTI (i.e. 0000 0000 0000 0001, 0000 0000 0000 0010 etc.).

  • All Zeros - a continuous series of 0’s

  • All Ones - a continuous series of 1’s

  • Alternating - a 16 bit data pattern that filled with the repetition of a bit pattern of ‘01’

Related Topics

GPIB Commands: CALL:DTCHannel


Call Limit State

Last updated: March 31, 2010

Description

When the Call Limit State is On, the test set does not respond to any UpPCH from the UE. Call Limit must be Off for any random access procedure, such as Location Update or BS Origination, to be successful.

Related Topics

GPIB Commands: CALL:CONNected:LIMit[:STATe][:SELected]


Call Drop Timer

Last updated: March 31, 2010

Description

The call drop timer can be enabled (turned on) or disabled (turned off).

Once a call is established, if the call drop timer is enabled, the call drop timer is started.

When the call drop timer is turned on, if the test set is unable to synchronize with the midamble in the uplink DPCH for a period of 500 ms, the call drop timer expires and the test set drops the call connection with an error message.

Related Topics

GPIB Commands: CALL:CONNected:DROP:TIMer[:STATe][:SELected]


DL PICH Data

Description

This setting is only available to TD-SCDMA Test Operating mode.

The paging indicator channel can be set to transmit either all zeroes or all ones.

Related Topics

GPIB Commands: CALL:TDTest:PICHannel:DATA


UL DPCH TFCI Control

Last updated: March 10, 2010

Description

This setting is only available to TD-SCDMA Test Operating mode.

When UL DPCH TFCI Ctrl is set to Auto, the test set uses the received TFCI value sent by the UE on the uplink DPCH. The test set uses the standard RMC TFCI table to interpret the received TFCI:

TFCI | DTCH Transport Block | DCCH Transport Block
1 | no | no
2 | yes | no
3 | no | yes
4 | yes | yes

When UL DPCH TFCI Ctrl is set to Manual, the test set ignores the TFCI value sent by the UE and uses the value specified by the UL DPCH TFCI setting.

Related Topics

GPIB Commands: CALL:TDTest:UPLink:TFCIndicator:CONTrol:AUTO


UL DPCH TFCI

Last updated: March 10, 2010

Description

This setting is only available to TD-SCDMA Test Operating mode.

When UL DPCH TFCI Ctrl is set to Manual, this setting determines which TFC the test set expects from the UE on the uplink DPCH.

Related Topics

GPIB Commands: CALL:TDTest:UPLink:TFCIndicator:MANual


MS DPCH Tgt Pwr

Description

When Power Control is set to Auto, the test set sets its receiver input power level to the value of the MS DPCH Tgt Pwr setting (see Expected Power ).

The maximum setting allowed for MS DPCH Tgt Pwr is +30 dBm.

Related Topics

GPIB Commands: CALL:MS:POWer:TARGet[:AMPLitude]


UL CL Power Control

Description

UL CL Power Ctrl Mode

UL CL Power Ctrl Mode controls what power control bit pattern is sent to the UE. It can be set to the following:

  • Active Bits - the test set sends the power control bits required to maintain the UE's DPCH power at UE Target Power. This is the default value if the Operating Mode is Active Cell.

  • Alternating bits - the test set sends alternating power-up and power-down bits to the UE. This is the default value if the Operating Mode is TD-SCDMA Test.

  • All Up bits - the test set sends a continuous pattern of power-up bits. This is often used to drive the UE to transmit at its maximum power level. Note, the test set will continuously send up bits to the UE in this mode, even if the UE exceeds the test set's specified measurement limit of +28 dBm.

  • All Down bits - the test set sends a continuous pattern of power-down bits. This is often used to drive the UE to transmit at its minimum power level.

GPIB Command: CALL[:CELL]:CLPControl:UPLink:MODE (for Active Cell operating mode) or CALL:TDTest:CLPControl:UPLink:MODE (for TD-SCDMA Test operating mode)

UL CL Power Ctrl Step Size

You can specify the size of the change in UE power for each closed loop power control TPC_cmd.

To change the power control step size while on a connection, you must perform a Physical Channel Reconfiguration. After completion of the Physical Channel Reconfiguration procedure, successful or not, the UL CL Power Ctrl Step Size setting is overwritten with the value of PCR UL CL Power Ctrl Step Size.

GPIB Command: CALL[:CELL]:CLPControl:UPLink:STEPsize

Send Step Up/Down TPC Bit Pattern

Send Step Up TPC Bit Pattern and Send Step Down TPC Bit Pattern can send individual transmit power control (TPC) commands to change the UE's power up or down by 1 dB. These functions can only be used when UL CL Power Control Mode is set to Alternating bits.

GPIB Command: CALL[:CELL]:CLPControl:UPLink:IMMediate:DOWN and CALL[:CELL]:CLPControl:UPLink:IMMediate:UP


Receiver Control

Description

You can manually tune the test set's receiver frequency and attenuation settings for the frequency and power level that you want to test. Or, you can have the test set automatically tune its receiver's frequency and attenuation settings based on other settings such as Channel and MS Target Power.

Automatic Receiver Control

Manual Receiver Control

Receiver Control Settings

Expected Power

Automatic Receiver Control

Automatic receiver control is the default for all operating modes except CW Operating Mode (only manual receiver control is available in CW operating mode). With automatic receiver control, the test set automatically tunes to the correct frequencies for making measurements and maintaining a call based on the Channel setting. Also, the test set adjusts attenuation settings according to the power level that should be present at the RF IN/OUT port given the current settings. This power level is referred to as the Expected Power.

Manual Receiver Control

In some instances, you may want to control the test set's receiver settings manually rather than allowing the test set to automatically control them. This ability is referred to as manual receiver control. Manual receiver settings can be used to override some or all of the automatic receiver settings. You can manually set the Expected Power, the measurement downconverter's tune frequency ( Measurement Frequency ), and the demodulation downconverter's tune frequency (Uplink Frequency).

In CW operating mode, you must always specify what frequencies and power the receiver should tune to, there is no automatic receiver control.

Receiver Control Settings

The following settings control the test set's receivers:

  • Power Control

When Power Control is set to Auto , the Expected Power from the UE is automatically determined by the test set. When Power Control is set to Manual, the expected power is determined by the Manual Power setting.

Note, when you switch between operating modes, Power Control is returned to its default value of Auto.

  • Manual Power

When Power Control is set to Manual, the Expected Power from the UE is determined by the Manual Power setting. Note, when you switch between operating modes, Power Control is returned to its default value of Auto .

  • Expected CW Power

Only available in CW operating mode.

The Expected CW Power setting determines the Expected Power while in CW operating mode.

You can set the Expected CW Power and Manual Power levels beyond the actual capability of the test set's hardware. This is because these settings are intended to reflect the potential range of RF power at the UE. This range of RF power is meant to accommodate the use of a gain or loss network between the mobile station and the test set. The upper and lower limits of these settings provide boundaries for the combination of amplitude offset and expected power from the UE.

  • Measurement Frequency

The Measurement Frequency setting is used to manually tune the test set's measurement downconverter input signal path.

  • Uplink Frequency

Available in TD-SCDMA Test and CW operating modes.

The Uplink Frequency setting is used to manually tune the test set's demodulation downconverter input signal path. The demodulation downconverter signal path is used to establish and maintain the call (RF link) between the UE and test set.

Expected Power

To make accurate measurements, the test set needs to know how much power to expect at its RF IN/OUT port, this is referred to as the expected power. If a measurement uses autoranging, the expected power level is calibrated by the test set before making the measurement and does not need to be set by the user. For measurements that do not use autoranging, the test set determines the expected power level in one of several ways:

  • For Active Cell operating mode:

  • when Power Control is set to Manual , expected power is determined by the Manual Power setting.

  • when Power Control is set to Auto :

  • if the call status is Idle, expected power is determined by Initial UpPCH TX Power, which means that the test set expects the UE to send UpPCH.

  • if the call status is Access Probe, expected power is determined by Initial PRACH TX Power, which means that the test set expects the UE to send PRACH.

  • if the RRC State is CELL_DCH, expected power is determined by the MS Target Power setting.

  • For TD-SCDMA Test operating mode:

  • when Power Control is set to Manual, expected power is determined by the Manual Power setting.

  • when Power Control is set to Auto, expected power is determined by the MS Target Power setting.

  • For CW operating mode, expected power is always determined by the Expected CW Power setting.

If the received signal is above or below the acceptable range for expected power, an Over Range or Under Range message is displayed and the measurement's Integrity Indicator is set to 5 or 6, respectively.

Related Topics

GPIB Commands: RFANalyzer


Call Setup Screen

Last updated: March 10, 2010

Active Cell Operating Mode Screen

TD-SCDMA Test Operating Mode Screen

CW Operating Mode Screen

Active Cell Connection State

Active Cell Operating Mode Screen

Click on the red circle for more information.

UE Information

  • IMSI: Indicates the UE-reported International Mobile Subscriber Identity (used by the network to page the UE) during the last identification procedure. See also Paging IMSI.

GPIB command: CALL:MS:REPorted:IMSI[:SELected]?

  • IMEI: Indicates the UE International Mobile Equipment Identity during the last identification procedure. The first 14 digits of this IMEI are reported directly by the UE, and the last digit is calculated by a algorithm called “Luhn formula".

GPIB command: CALL:MS:REPorted:IMEI:CALCulated:TATDscdma?

You can also query the UE direct-reported IMEI whose last digit is "0" by CALL:MS:REPorted:IMEI:TATDscdma?

  • Power Class: Indicates the power class supported by the UE, as defined in 3GPP TS 25.102 6.2. The power class indicates the UE's nominal maximum output power, see UE Transmit Power Control.

GPIB command: CALL:MS:REPorted:PCLass[:SELected]?

  • Detected UpPCH Sig: an integer representing the PRACH signature used by the UE on its final PRACH burst (the one that the test set responds to).

GPIB command: CALL:MS:REPorted:UPPChannel:DETected:SIGnature?

  • UE Access Stratum Rel Ind: Indicates the specification release that the UE supports. Possible results can be from release 4 to 8. An HSDPA service call can only be established for the UE that supports the specification release 5 or later.

GPIB command: CALL:MS:REPorted:ASTRatum:RINDicator

  • UE Reported HS-DSCH Category: Indicates the UE supported HS-DSCH Category. The 3GPP TS25.306 defines a set of TD-SCDMA HSDPA UE categories to restrict the UE data rates. Categories are specified by attributes like the Maximum number of HS-DSCH codes per timeslot, Maximum number of HS-DSCH timeslots per TTI, etc. See 3GPP TS25.306 for details.

GPIB command: CALL:HSDPa:MS:REPorted:HSDSchannel:CATegory?

UE Expected Open Loop Transmit Power

  • Initial UpPCH TX Power: This result is derived by the following calculation:

Initial UpPCH Tx Power = (Broadcast Primary CCPCH Tx Power – Cell Power – P-CCPCH Power Level Offset) + Desired UpPCH RX Power.

GPIB command: CALL:UPLink:UPPChannel:POWer:INITial[:LEVel]?

  • Initial PRACH TX Power: This result is derived by the following calculation:

Initial PRACH Tx Power = (Broadcast Primary CCPCH Tx Power – Cell Power – P-CCPCH Power Level Offset) + Desired PRACH RX Power.

GPIB command: CALL:UPLink:PRAChannel:POWer:INITial[:LEVel]?

Call Processing Status

  • RRC State: indicates whether the RB Test Mode service has set the UE up into the CELL_DCH state, or is Idle.

GPIB command: CALL:STATus:RRC:STATe?

  • MM Status

MM Status indicates whether the UE has registered, and what type of registration (Location Updating procedure) was last performed. When the UE registers with the network, its Location Updating Request message includes a Location Updating Type information element that can have a value of "Normal location updating", "Periodic updating" or "IMSI attach" (see 3GPP TS 24.008 s4.4.1, s9.2.15 and s10.5.3.5).

  • Updated (normal) : Indicates that the last Location Updating procedure was of the type "Normal location updating". Normal location updating is used to update the network with the actual Location Area of a UE (for example when the UE enters a new location area).

  • IMSI Attached : Indicates that the last Location Updating procedure was of the type "IMSI attach" (the UE performed a power-up registration). The IMSI attach procedure is used to indicate the IMSI as active in the network.

  • IMSI Detached : Indicates that the UE sent an IMSI Detach Indication message to the test set (the UE performed a power-down registration). This occurs when the UE was IMSI Attached and then was powered down or its SIM was removed.

  • None: The UE has not registered with the test set (MM Status also shows None when you clear the UE information (see Clear UE Info).

GPIB command: CALL:STATus:MM?

  • GMM Status

GMM State indicates the result of the most recent GPRS attach or detach.

  • Attached: Indicates the UE has successfully completed the GPRS Attach procedure.

  • Detached: Indicates the completion of the GPRS Detach procedure.

  • Attach Incomplete: the UE sends the test set an Attach Request but never responds to the Attach Accept with an Attach Complete.

  • None: If you clear the UE information (see Clear UE Info), power up and preset.

GPIB command: CALL:STATus:GMM?

HSDPA Information

The HSDPA Information window displays counters to help you monitor the HSDPA connection status. The results are continually updated until one of the following occurs:

  • You press the MEASUREMENT RESET key ( SYSTem:MEASurement:RESet ).

  • You change operating mode.

  • You establish a new connection in active cell operating mode.

  • Blocks Transmitted reaches 200,000.

When one of these events occurs, the counters reset to zero and then resume counting.

The HSDPA Information window provide similar results to the HSDPA BLER measurement (see HSDPA Block Error Ratio (HBLER) Measurement). However, note that because they are being calculated for a different set of blocks (the HSDPA counters are typically calculated over a much greater number of blocks), the results will often vary.

The following results can be queried together by CALL:HSDPa:RTIMe:RESults:ALL?

  • Block Error Rate

3GPP TS 34.121 F.6.3.2 defines the HSDPA block error ratio as: (NACK + statDTX)/(NACK+ statDTX +ACK).

  • Throughput: reports the data throughput of the HSDPA connection.

  • Blocks Transmitted: Indicates the number of blocks have been transmitted to the UE. It is incremented by one every time a data block is transmitted on the HS-PDSCHs. Both transmission of a new block of data or a retransmission of an old block of data will cause this number incremented.

HSUPA Information

The HSUPA Information window displays counters to help you monitor the HSUPA connection status. The results are continually updated. When one of the following events occurs, the counters reset to zero and then resume counting:

    • You press the MEASUREMENT RESET key (SYSTem:MEASurement:RESet).

    • You select Clear UE Info (CALL:MS:REPorted:CLEar[:ALL]:TATDscdma).

    • You change operating mode.

    • You establish a new connection in active cell operating mode

    • The Number of blocks transmitted reaches 200,000.

The following HSUPA information are displayed (This is front panel display only):

    • Expected MAC-e PDU

    • Throughput

    • ACKs/NAKs

TD-SCDMA Test Operating Mode Screen

Generated Power Level Information

The power levels that are currently being used by the test set (Current Level) and the "desired" levels you've input (Desired Level) are shown on the Generated Power Level Information screen as below.

If you request an invalid combination of power levels, the test set posts a persistent error and the settings you've requested will be shown in the Desired Level column. The set of levels in use by the test set does not change until you request a valid combination of levels, then the values in the Current Level and Desired Level columns will match.

Whether the combination of power levels is valid is determined by the following requirements:

  • AWGN power must not be more than 10 dB above or 25 dB below cell power when both power states are set to ON.

  • The total RF power and amplitude offset must not make the source outside its valid hardware range.

To query the power levels, use the GPIB commands for setting/querying:

Parameter | Current Level | Desired Level
Cell Power | CALL:STATus:CELL:POWer[:AMPLitude][:SELected]? | CALL[:CELL]:POWer:AMPLitude[:SELected]
AWGN Power | CALL:STATus:AWGNoise[:INTernal]:POWer[:AMPLitude][:SELected]? | CALL:AWGNoise[:INTernal]:POWer[:SAMPlitude][:SELected]
Total RF Power | CALL:STATus:TOTal:POWer[:AMPLitude][:SELected]? | CALL:TOTal:POWer[:AMPLitude][:SELected]?

Downlink Code Channel Power Level Information

See Downlink Code Channel Power Level Information

CW Operating Mode Screen

CW Parameters

  • RF Gen Freq Ctrl

  • Cell Power

FM Broadcast Parameters

  • FM Broadcast Frequency

  • FM Broadcast Power

  • Internal FM Frequency

  • Internal FM Deviation

GPS Parameters

See GPS Parameter Information

Active Cell Connection State

Additional call processing state information is also displayed in the small Active Cell window at the bottom of the Call Setup screen. Note that for single services, the respective Call Connection State or Data Connection State is displayed.

Call Connection State

The call connection state can transition between the following states:

  • Idle (IDLE)

  • Paging (PAG)

  • Access Probe (APR)

  • Alerting (CALL)

  • Setup (SREQ)

  • Registering (REG)

  • Connected (CONN)

  • Handover (HAND)

  • Releasing (REL)

GPIB command: CALL:STATus[:STATe][:VOICe]?

Data Connection State

The data connection state can transition between the following states:

  • Idle (IDLE)

  • Attaching (ATTG)

  • Detaching (DET)

GPIB command: CALL:STATus[:STATe]:DATA?

Related Topics

GPIB Commands: CALL:STATus


Call Processing Ladder Diagrams

Last updated: April 28, 2010

The following diagrams illustrate the procedures used by the test set for several key call processing operations:

RRC Connection Setup

Location Update Procedure

Paging

RB Test Mode Call Origination to CELL_DCH

RB Test Mode HSDPA PS Domain Call Setup Procedure

RB Test Mode HSDPA CS/PS Domain Call Setup Procedure

Base Station Release from RB Test Mode in CELL_DCH

RRC Connection Setup

Location Update Procedure

Paging

RB Test Mode Call Origination to CELL_DCH

RB Test Mode HSDPA PS Domain Call Setup Procedure

RB Test Mode HSDPA CS/PS Domain Call Setup Procedure

Base Station Release from RB Test Mode in CELL_DCH


GPRS Packet Data Service Ladder Diagrams

UE De-active PDP Context

Mobile Initiated GPRS Service

UE De-active PDP Context

Mobile Initiated GPRS Service

Related Topics

GPIB Commands:


FM Broadcast

Last updated: April 21, 2010

Description

When the test set is in CW operating mode, you can test the Mobile Station with full range of FM (frequency modulated) broadcast signals with the help of the audio measurement feature in the test set. The FM Broadcast signals are generated by utilizing two RF sources in the test set and an external mixing device (E5520 FM Adaptor).

The following diagram shows a typical FM Broadcast test system configuration.

The FM Broadcast test system is made up of the test set, FM Adapter and Mobile Station. The FM Adapter connects to the RF OUT ONLY port of the test set directly. The Mobile Station connects to the output of the FM Adapter with RF antenna. To make measurement on the received audio signal, the Mobile Station's demodulated FM output connects to the High AUDIO IN connector of the test set.

When the test set is in CW operating mode and FM broadcast mode, one of the test set's RF sources is fixed at 1 GHz and the other source provides an FM signal from 890 MHz to 990 MHz. The FM Adapter mixes the 1 GHz Local Oscillator signal with the FM signal, then the filters it to provide a stable and accurate resultant signal at the user specified FM broadcast frequency (10 MHz to 110 MHz). The test set also allows you to set parameters such as internal frequency deviation, FM broadcast power and amplitude offset when the test set is in FM Broadcast mode. Once the test set is generating the FM signal and is properly connected to the Mobile Station, the Mobile Station's FM receiver performance is ready to analyzed. A common method of analyzing the FM signal that has been demodulated by the Mobile Station is to connect the Mobile Station's demodulated FM output to the test set's High AUDIO INPUT connector, perform and run the appropriate Audio Analyzer measurements.

FM Broadcast Parameters

The following parameters are only applicable when the FM Broadcast Power setting is applied.

  • RF Output Config:

  • Normal: This mode is the normal CW operating mode in which the test set generates a CW signal.

  • FM broadcast: In this mode, the test set generates the signals that are sent through the RF OUT ONLY port to the FM Adapter to produce an FM Broadcast signal. The FM Broadcast parameters do not appear on the front panel of the test set and the GPIB command that set the FM Broadcast parameters do not apply until the RF Output Configure parameter is set to this mode.

  • FM Broadcast Frequency: This parameter sets the frequency at which the test set broadcasts the FM signal.

  • FM Broadcast Power

  • FM Broadcast Power State: This parameter sets whether the FM Broadcast Power setting is applied.

  • FM Broadcast Power: This parameter sets the power at which the test set broadcasts the FM signal.

  • FM Broadcast Amplitude Offset

  • Adapter Conversion Gain: This parameter sets the loss of the FM Adapter. The test set compensates for the loss by increasing the signal strength at the RF OUT ONLY port.

  • Amplitude Offset State: This parameter sets whether the FM Broadcast mode Amplitude Offset setting is applied.

  • Amplitude Offset: This parameter sets the FM Broadcast mode Amplitude Offset setting that is applied to the RF OUT ONLY port.

  • Internal FM Deviation

  • Internal FM Deviation State: This parameter sets whether the FM Broadcast mode Internal FM Deviation setting is applied.

  • Internal FM Deviation: This parameter is used to control the FM Deviation of the internal audio source. The internal audio source is the amount the modulated signal deviates from the carrier frequency.

  • Internal FM Frequency

This parameter sets the test set's internal FM frequency (the modulation frequency) and only applies when RF Output Configure is set to FM Broadcast.

How Do I Make a FM Broadcast test?

Configure the FM Broadcast Parameters

1. Turn off RF IN/OUT Amplitude Offsets.

  • Press SYSTEM CONFIG key .

  • Press RF IN/OUT Amptd Offset ( F5 ).

  • Press RF IN/OUT Amptd Offset Setup ( F2 ).

  • Set the RF IN/OUT Amplitude Offset State to Off.

2. Set the Operating Mode to CW.

  • Press CALL SETUP key .

  • Set the Operating Mode to CW.

3. Configure the FM Broadcast Parameters .

  • Press RF GEN Configure ( F10 ), this displayed the RF GEN Configure menu .

  • Use the knob to scroll to and highlight FM Broadcast. The test set is in the correct mode to perform FM receiver testing.

  • All the FM Broadcast parameters are now visible in the control menu and you can use the knob to set the FM Broadcast Parameters .

Set up and test the Mobile Station's demodulated FM output

This procedure provides an example method for testing the Mobile Station's FM receiver performance. It involves the test set's audio analyzer measurement capability.

1. Set up the FM Broadcast test system.

  • Connect the FM Adapter to the test set's RF OUT ONLY port.

  • Connect the Mobile Station's RF antenna to the output of the FM Adapter.

  • Connect the Mobile Station's demodulated FM output to the test set's HI AUDIO INPUT connector.

The test set's AUDIO INPUT connectors (HI or LO) are different inputs, therefore unless a different measurement is needed, it is recommended that you ground the LO connector and connect the audio signal to the HI connector.

2. Initiate the Audio Analyzer measurement in the test set.

  • Press Instrument Selection key .

  • Select Audio Analyzer.

  • Select Analog Audio Setup (F1) to configure the Audio Analyzer parameters. For example, to view the measurement results for SINAD and Distortion, the SINAD/Distortion State setting must be turned On.

Related Topics

GPIB Commands: CALL:RFGenerator


Single channel GPS source

This section is only applicable to the lab application or test application with the required feature license.

Description

The Single Channel GPS Source function allows you to generate GPS signals to calibrate the GPS receiver of the mobile.

GPS system employs 37 satellites in orbit to provide positioning services. Satellite GPS signal has 3 components: L1 (1575.42MHz) / L2 (1227.60MHz) carrier signals, ranging codes and navigation message. Two kinds of ranging codes are defined: coarse/acquisition (C/A) code for normal positioning and precision (P) code for finer positioning purpose. The L1 is used to carry the C/A code with 1.023Mcps spreading rate, while L2 is usually used to carry the P code with 10.23Mcps spreading rate. For each satellite, a unique Space Vehicle Identifier (SV-ID) is assigned and will be used to determine the phase of spreading code for this specific satellite. The navigation messages usually contain positioning parameters.

Normally P code and L2 are only designed for military use, so the test set only simulates single satellite signal containing C/A code carried by L1 with default navigation messages, and pseudo random sequence data for the calibration of GPS receivers.

The Single Channel GPS Source is only available when the test set is in CW Operating Mode.

GPS Parameter Information

The following diagram shows the GPS parameter information.

  • GPS RF Generator Frequency:

Since the test set only simulates single satellite signal containing C/A code carried by L1, the frequency is fixed at 1575.42MHz. It's a non-configurable parameter.

  • GPS Power:

This parameter defines the cell power of GPS signal. The power range of GPS signal is -125dBm to -70dBm.

The power range that you can set on the test set is affected when there is an Amplitude Offset.

  • GPS Satellite ID (SV ID):

This setting defines which satellite is generating the GPS signal.

  • GPS Navigation Message Type:

This setting defines the actual navigation message that will be transmitted on GPS frame. If Default Navigation is selected, the GPS frames is filled with the default navigation message defined in the GPS standard. If Raw is selected, the GPS frames is filled with PN sequence.

  • GPS Raw Payload Pattern:

This setting defines the data type that will be transmitted on GPS frames when Raw data payload is selected. You can select PN9 or PN15.

  • GPS Baseband Filter Type:

This setting defines the filter that will be used to filter the GPS baseband signal when the GPS signal is generated. A Gaussian or Rectangle filter with 10 MHz bandwidth is supported in this feature.

Manual Operation

The following procedure details how to access the Single channel GPS source.

  1. Press the CALL SETUP key.

  2. Press Operating Mode ( F1 ) and select CW .

  3. Press RF Gen Configure ( F10 ) from the Control Parms menu, then select GPS menu.

  4. Press GPS Parameters ( F9 ), Use the knob to highlight the parameter and change the value.

Related Topics

GPIB Commands: CALL:RFGenerator


Protocol Logging

Description

If you have trouble finding the information you need below, use the search field at the top of this page to search the contents of this guide.

With a lab application, the test set can capture the protocol messages exchanged between the test set and a wireless device. The protocol messages are forwarded via the test set's LAN port to the Wireless Protocol Advisor (WPA) software (which is included with your lab application), so that they can be displayed and analyzed. If you're using the data channel feature of the test set as an IP router to exchange data between the wireless device and a network server, then the WPA can also monitor these communications.

The Wireless Protocol Advisor software runs on a personal computer under the Windows operating system. It is tailored for the capture, display, and analysis of message exchange protocols between the test set (emulating a base station), and a wireless device. The software connects with the test set through the LAN port, to capture messages and data used to set up and maintain links and transfer data. Messages and data can be filtered to include specific protocol layers and message fields.

Starting and Stopping Protocol Logging

There are several ways to control the logging of signaling messages.

The primary method for starting and stopping is through features found in the WPA software.

The following information describes features available through the test set's remote and manual user interface for performing these functions:

Activating Protocol Logging From the Test Set

Once a connection is established between the PC running the WPA (Wireless Protocol Advisor) and the test set, a logging session can be activated (or deactivated) by selecting the start (or stop) softkey from the test set's front panel or by sending GPIB commands that perform the same functions:

Test Set Control of Protocol Logging

If a PC with the WPA software has not yet connected with the test set, an error message will be generated if an attempt is made to start protocol logging. Exactly one PC/WPA can be connected to a test set at one time.

Front Panel Control of Protocol Logging

  1. Press the CALL SETUP key to go to the Call Setup screen.

  2. Press the More key on the left hand Call Control menu to go to menu 3.

  3. Select Protocol Logging ( F1).

  4. Select Start Protocol Logging ( F1 ) to begin logging.

The GPIB command to control Protocol Logging is CALL:PLOGging.


Measurements

The test set includes many measurements and instruments for testing your UE. This page provides links to measurement information including: 3GPP TS 34.122 Tests Supported by the test set, and Measurement Descriptions (how the measurement is performed by the test set, setup parameters, and the measurement results available).

If you have trouble finding the information you need, use the search tab on the left to search the contents of this help.

3GPP TS 34.122 Tests Supported

What 3GPP TD-SCDMA Conformance Tests Are Supported?

Measurement Descriptions

  • Channel Power Measurement

  • Waveform Quality Measurement

  • Adjacent Channel Leakage Ratio (ACLR) Measurement

  • Spectrum Emission Mask (SEM) Measurement

  • Frequency Stability Measurement

  • Closed Loop Power Control (CLPC) Measurement

  • Occupied Bandwidth (OBW) Measurement

  • Dynamic Power (DPOW) Measurement

  • Loopback Bit Error Ratio (BER) Measurement

  • Transmit ON/OFF Power (TOOP) Measurement

  • Block Error Ratio (BLER) Measurement

  • HSDPA Block Error Ratio (HBLER) Measurement

  • Open Loop Power Control (OLPC) Measurement

  • Out-of-Synchronization of Output Power (OOS) Measurement

  • Fast Device Tune Measurement

  • Spectrum Monitor

Obtaining Measurement Results

  • Concurrent Measurements


What 3GPP TD-SCDMA Conformance Tests Are Supported?

Last updated: September 19, 2010

These tables list the supported tests specified in 3GPP TS 34.122.

3GPP TS 34.122 Section 5 Transmitter Characteristics

3GPP TS 34.122 Section 6 Receiver Characteristics

3GPP TS 34.122 Section 7 Performance Requirements

3GPP TS 34.122 Section 9 Performance requirements for HSDPA

3GPP TS 34.122 Section 5 Transmitter Characteristics

3GPP TS 34.122 | Test Description | Supported in Test Set?
5.2 | User Equipment maximum output power | Yes, see Channel Power Measurement or Closed Loop Power Control (CLPC) Measurement
5.2B | User Equipment maximum output power with HS-SICH and DPCH | Yes, (Release 5 only)
5.3 | UE frequency stability | Yes, see Waveform Quality Measurement
5.4.1.3 | Open loop power control (1,28 Mcps TDD Option) | Yes, see Open Loop Power Control (OLPC) Measurement
5.4.1.4 | Closed loop power control (1,28 Mcps TDD Option) | Yes, see Closed Loop Power Control (CLPC) Measurement
5.4.2 | Minimum output power | Yes, see Channel Power Measurement or Closed Loop Power Control (CLPC) Measurement
5.4.3 | Transmit OFF power | Yes, see Transmit ON/OFF Power (TOOP) Measurement
5.4.4 | Transmit ON/OFF Time mask | Yes, see Transmit ON/OFF Power (TOOP) Measurement
5.4.5 | Out-of-synchronisation handling of output power for continuous transmission | Yes, see Out-of-Synchronization of Output Power (OOS) Measurement
5.4.6 | Out-of-synchronisation handling of output power for discontinuous transmission | Yes, see Out-of-Synchronization of Output Power (OOS) Measurement
5.5.1 | Occupied bandwidth | Yes, see Occupied Bandwidth (OBW) Measurement
5.5.2.1 | Spectrum emission mask | Yes, see Spectrum Emission Mask (SEM) Measurement
5.5.2.2 | Adjacent Channel Leakage power Ratio (ACLR) | Yes, see Adjacent Channel Leakage Ratio (ACLR) Measurement
5.5.2.2B | Adjacent Channel Leakage power Ratio (ACLR) with HS-SICH and DPCH | Yes, (Release 5 only)
5.7.1 | Error Vector Magnitude | Yes, see Waveform Quality Measurement
5.7.1B | Error Vector Magnitude with HS-SICH and DPCH | Yes, (Release 5 only)
5.7.2 | Peak code domain error | Yes, see Waveform Quality Measurement

3GPP TS 34.122 Section 6 Receiver Characteristics

3GPP TS 34.122 | Test Description | Supported in Test Set?
6.2 | Reference sensitivity level | Yes, see Loopback Bit Error Ratio (BER) Measurement
6.3 | Maximum Input Level | Yes, see Loopback Bit Error Ratio (BER) Measurement
6.3A | Maximum Input Level for HS-PDSCH Reception (16QAM) | Yes, (Release 5 only). See HSDPA Block Error Ratio (HBLER) Measurement
6.4 | Adjacent Channel Selectivity (ACS) | Yes, see Loopback Bit Error Ratio (BER) Measurement (plus TD-SCDMA signal from a signal generator)
6.5 | Blocking Characteristics | Yes, see Loopback Bit Error Ratio (BER) Measurement (plus TD-SCDMA and CW signals from a signal generator)
6.6 | Spurious Response | Yes, see Loopback Bit Error Ratio (BER) Measurement (plus a CW signal from a signal generator)
6.7 | Intermodulation Characteristics | Yes, see Loopback Bit Error Ratio (BER) Measurement (plus TD-SCDMA and CW signals from a signal generator)
6.8 | Spurious Emissions | Yes. Camp to test set, measure spurious emissions using external spectrum analyzer

3GPP TS 34.122 Section 7 Performance Requirements

3GPP TS 34.122 | Test Description | Supported in Test Set?
7.2.1 | Demodulation of DCH | Yes, see Loopback Bit Error Ratio (BER) Measurement (plus AWGN noise source)
7.3.1 | Multipath fading Case 1 | Yes, see Loopback Bit Error Ratio (BER) Measurement (plus multi-path fading simulator and external AWGN noise source)
7.3.2 | Multipath fading Case 2 | Yes, see Loopback Bit Error Ratio (BER) Measurement (plus multi-path fading simulator and external AWGN noise source)
7.3.3 | Multipath fading Case 3 | Yes, see Loopback Bit Error Ratio (BER) Measurement (plus multi-path fading simulator and external AWGN noise source)

3GPP TS 34.122 Section 9 Performance requirements for HSDPA

3GPP TS 34.122 | Test Description | Supported in Test Set?
9.3.1A | HS-DSCH throughput for Fixed Reference Channels 0.5 Mbps UE class QPSK | Yes, see 3GPP TS34.122 9.3.1 HS-DSCH throughput for Fixed Reference Channels (plus multi-path fading simulator and external AWGN noise source)
9.3.1B | HS-DSCH throughput for Fixed Reference Channels 1.1 Mbps UE class QPSK | Yes, see 3GPP TS34.122 9.3.1 HS-DSCH throughput for Fixed Reference Channels (plus multi-path fading simulator and external AWGN noise source)
9.3.1C | HS-DSCH throughput for Fixed Reference Channels 1.6 Mbps UE class QPSK/16QAM | Yes, see 3GPP TS34.122 9.3.1 HS-DSCH throughput for Fixed Reference Channels (plus multi-path fading simulator and external AWGN noise source)
9.3.1D | HS-DSCH throughput for Fixed Reference Channels 2.2 Mbps UE class QPSK/16QAM | Yes, see 3GPP TS34.122 9.3.1 HS-DSCH throughput for Fixed Reference Channels (plus multi-path fading simulator and external AWGN noise source)
9.3.1E | HS-DSCH throughput for Fixed Reference Channels 2.8 Mbps UE class QPSK/16QAM | Yes, see 3GPP TS34.122 9.3.1 HS-DSCH throughput for Fixed Reference Channels (plus multi-path fading simulator and external AWGN noise source)
9.3.2A | HS-DSCH throughput for Variable Reference Channels 0.5 Mbps UE class | Yes, see 3GPP TS34.122 9.3.2 HS-DSCH throughput for Variable Reference Channels (plus multi-path fading simulator and external AWGN noise source)
9.3.2B | HS-DSCH throughput for Variable Reference Channels 1.1 Mbps UE class | Yes, see 3GPP TS34.122 9.3.2 HS-DSCH throughput for Variable Reference Channels (plus multi-path fading simulator and external AWGN noise source)
9.3.2C | HS-DSCH throughput for Variable Reference Channels 1.6 Mbps UE class | Yes, see 3GPP TS34.122 9.3.2 HS-DSCH throughput for Variable Reference Channels (plus multi-path fading simulator and external AWGN noise source)
9.3.2D | HS-DSCH throughput for Variable Reference Channels 2.2 Mbps UE class | Yes, see 3GPP TS34.122 9.3.2 HS-DSCH throughput for Variable Reference Channels (plus multi-path fading simulator and external AWGN noise source)
9.3.2E | HS-DSCH throughput for Variable Reference Channels 2.8 Mbps UE class | Yes, see 3GPP TS34.122 9.3.2 HS-DSCH throughput for Variable Reference Channels (plus multi-path fading simulator and external AWGN noise source)
9.3.3A | Reporting of HS-DSCH Channel Quality Indicator-0.5Mbps UE class | Yes, see Reporting of Channel Quality Indicator Measurement (plus multi-path fading simulator and external AWGN noise source)
9.3.3B | Reporting of HS-DSCH Channel Quality Indicator-1.1Mbps UE class | Yes, see Reporting of Channel Quality Indicator Measurement (plus multi-path fading simulator and external AWGN noise source)
9.3.3C | Reporting of HS-DSCH Channel Quality Indicator-1.6Mbps UE class | Yes, see Reporting of Channel Quality Indicator Measurement (plus multi-path fading simulator and external AWGN noise source)
9.3.3D | Reporting of HS-DSCH Channel Quality Indicator-2.2Mbps UE class | Yes, see Reporting of Channel Quality Indicator Measurement (plus multi-path fading simulator and external AWGN noise source)
9.3.3E | Reporting of HS-DSCH Channel Quality Indicator-2.8Mbps UE class | Yes, see Reporting of Channel Quality Indicator Measurement (plus multi-path fading simulator and external AWGN noise source)
9.3.4 | HS-SCCH Detection Performance | Yes, see 3GPP TS34.122 9.3.4 HS-SCCH Detection Performance (plus multi-path fading simulator and external AWGN noise source)


Channel Power Measurement

Last updated: March 31, 2010

Channel Power Measurement Description

Channel Power Measurement Parameters

Channel Power Measurement Results

Input Signal Requirements

Channel Power Measurement Description

The channel power measurement is made on the RF input signal after frequency downconversion and an analog to digital conversion. The actual power measurement is performed by the test set's digital signal processor (DSP).

The channel power measurement is used to measure the following power as defined in TS 34.122 Section 3.1.

  • Mean Power: The average power measured in one time slot and a bandwidth of at least (1+alpha) times the chip rate. This measurement is intended to only measure the power of TD-SCDMA modulated carrier, which in theory is 100% contained in this bandwidth.

  • RRC Filtered Mean Power: The averaged power measured in one time slot and with a Root Raised Cosine (RRC) filter with a roll-off factor of alpha=0.22 and a bandwidth equal to the chip rate. In theory, it is 0.246dB below the mean power.

This measurement requires the calibration data of the measurement receiver path gain, which are part of the results of the measurement calibration, see Calibrate Measurements.

Channel Power Measurement Parameters

  • Multi-Measurement Count: see Multi-Measurement Count

  • RRC Filter: The signal can be filtered in the DSP with a root-raised cosine (RRC) filter with a roll-off of 0.22 and a bandwidth equal to the chip rate to comply with 3GPP 34.122 conformance specifications that require RRC filtered power. The filter can also be turned off for conformance specifications requiring a mean power measurement. When the RRC filter is Off , the bandwidth of the channel power measurement is greater than (1+alpha) times the chip rate, where alpha=0.22.

  • Trigger Arm: see Trigger Arm

  • Trigger Source: see Trigger Source

  • Trigger Delay: see Trigger Delay

  • Measurement Timeout: see Measurement Timeout

Channel Power Measurement Results

  • Integrity Indicator: see Integrity Indicator

  • Channel Power (in dBm): If Multi-Measurement Count is on, average, maximum and minimum channel power results are displayed on the measurement screen.

Input Signal Requirements

  • The measured signal level is expected to be within 9 dB of the expected power.

  • Input signal level into the test set's RF IN/OUT connector is between -65 dBm and +28 dBm, in a 1.28 MHz bandwidth

  • For Non-HSDPA channel type, the frequency of the measured signal should be within 20KHz from the expected receiver frequency; For HSDPA channel type, the frequency of the measured signal should be within 2KHz from the expected receiver frequency.

Related Topics

GPIB Commands: SETup:TCPower, FETCh:TCPower


Waveform Quality Measurement

Waveform Quality Measurement Description

Waveform Quality Measurement Parameters

Waveform Quality Measurement Results

Input Signal Requirements

Waveform Quality Measurement Description

The waveform quality measurement is used to test the following measurements as defined in the test standard 3GPP TS 34.122: EVM, Frequency Stability and Peak Code Domain Error.

EVM

The Error Vector Magnitude (EVM) is a measure of the difference between the measured waveform and the theoretical modulated waveform (the error vector). Both waveforms pass through a matched Root Raised Cosine filter with bandwidth 1.28 MHz and roll-off of 022. Both waveforms are then further modified by selecting the frequency, absolute phase, absolute amplitude and chip clock timing so as to minimize the error vector. The EVM result is defined as the square root of the ratio of the mean error vector power to the mean reference signal power expressed as a %.

The waveform quality measurement in the test set compares the received signal's IQ modulation characteristics to an ideal signal, as defined in 3GPP TS 34.121.

According to the standard, the Error Vector Magnitude shall not exceed 17.5 % for UE output power more than -20dBm and Power control step size is 1dB.

Frequency Stability

The frequency stability is the difference of the modulated carrier frequency between the RF transmission from the UE and the RF transmission from the test set.

According to the standard, The UE frequency stability, observed over a period of one timeslot, shall be within ±0.1 ppm compared to signals received from the test set.

Peak Code Domain Error

The code domain error is computed by projecting the error vector power onto the code domain at a specific spreading factor. The error power for each code is defined as the ratio to the mean power of the projection onto the code, to the mean power of the composite reference waveform expressed in dB. And the Peak Code Domain Error is defined as the maximum value for Code Domain Error.

According to the standard, the peak code domain error shall not exceed -21dB at spreading factor 16 for 1,28 Mcps TDD Option.

Waveform Quality Measurement Parameters

  • Multi-Measurement Count: see Multi-Measurement Count

  • Trigger Arm: see Trigger Arm

  • Trigger Source: see Trigger Source

  • Trigger Delay: see Trigger Delay

  • Measurement Timeout: see Measurement Timeout

Waveform Quality Measurement Results

The following result items can be derived after the waveform quality measurement.

  • Integrity Indicator: see Integrity Indicator

  • EVM: Error Vector Magnitude (in % RMS), see FETCh:TWQuality:EVM[:AVERage]?

  • Peak EVM (maximum chip EVM, in %) - available through GPIB query only, see FETCh:TWQuality:EVM:PEAK[:AVERage]?

  • Frequency Error (in Hz), see FETCh:TWQuality:FERRor[:AVERage]?

  • Origin Offset (in dB), see FETCh:TWQuality:OOFFset[:AVERage]?

  • Phase Error (in degrees), see FETCh:TWQuality:PERRor[:AVERage]?

  • Magnitude Error (in %), see FETCh:TWQuality:MERRor[:AVERage]?

  • Time Error (in chips)

Time error is a measure of the timing error of the UE's transmission relative to the frame clock, see FETCh:TWQuality:TERRor[:AVERage]?

  • Peak Code Domain Error (PCDE) (Maximum PCDE, in dB)

Peak Code Domain Error (in dB) and the code channel at which it occurs (C ch,Spreading Factor,Code Number ), see FETCh:TWQuality:PCERror[:ALL]?

Input Signal Requirements

  • The measured signal level is expected to be within 9 dB of the expected power.

  • Input signal level into the test set's RF IN/OUT connector is between -25 dBm and +28 dBm, in a 1.28 MHz bandwidth.

  • For Non-HSDPA channel type, the frequency of the measured signal should be within 20KHz from the expected receiver frequency; For HSDPA channel type, the frequency of the measured signal should be within 2KHz from the expected receiver frequency.

Related Topics

GPIB Commands: SETup:TWQuality, FETCh:TWQuality


Adjacent Channel Leakage Ratio (ACLR) Measurement

Last updated: March 31, 2010

Adjacent Channel Leakage Ratio (ACLR) Measurement Description

Adjacent Channel Leakage Ratio (ACLR) Measurement Parameters

Adjacent Channel Leakage Ratio (ACLR) Measurement Results

Input Signal Requirements

Adjacent Channel Leakage Ratio Measurement Description

As defined in 3GPP TS 34.122, ACLR is the ratio of the RRC filtered mean power centered on the adjacent channel frequency to the RRC filtered mean power centered on the assigned channel frequency. The adjacent channels are located at ±1.6 MHz and ±3.2 MHz offsets.

According to the standard, the ACLR should be no more than -33dB at the offsets of ±1.6MHz and no more than -43dB at the offsets of ±3.2MHz.

This measurement requires the calibration data of the measurement receiver path gain, which are part of the results of the measurement calibration, see Calibrate Measurements.

Adjacent Channel Leakage Ratio Measurement Parameters

  • Multi-Measurement Count: see Multi-Measurement Count

  • Adjacent Limit: specifies the lower and upper adjacent (at the offset of ±1.6MHz) limit.

  • Alternate Limit: specifies the lower and upper alternate (at the offset of ±3.2MHz) limit.

  • Trigger Arm: see Trigger Arm

  • Trigger Source: see Trigger Source

  • Trigger Delay: see Trigger Delay

  • Measurement Timeout: see Measurement Timeout

Adjacent Channel Leakage Ratio Measurement Results

  • Integrity Indicator: see Integrity Indicator

  • In-Channel Power: This result provides the in-channel power in dBm/1.28 MHz.

  • Pass/Fail, Average Leakage Power Level and Mask Margin for each Offset ( -3.2 MHz, -1.6 MHz, 1.6 MHz, and 3.2 MHz offsets).

  • Pass/Fail

  • Average Leakage Power Level

  • Mask Margin

Measurement results can be displayed in either numeric or graphic form. When the graphic display is used (shown below), limits can be set for each offset to form a "limit line." When a limit is exceeded, the status changes from "Pass" to "Fail."

When the numeric display is used, the average level (in dBc), mask margin (in dB) and the pass/fail for each offset is displayed. In-Channel Power is also displayed. See the picture below.

Input Signal Requirements

  • The measured signal level is expected to be within 9 dB of the expected power.

  • Input signal level into the test set's RF IN/OUT connector is between +5 dBm and +28 dBm, in a 1.28 MHz bandwidth.

  • For Non-HSDPA channel type, the frequency of the measured signal should be within 20KHz from the expected receiver frequency; For HSDPA channel type, the frequency of the measured signal should be within 2KHz from the expected receiver frequency.

Related Topics

GPIB Commands: SETup:TACLeakage, FETCh:TACLeakage


Spectrum Emission Mask (SEM) Measurement

Spectrum Emission Mask Measurement Description

Spectrum Emission Mask Measurement Parameters

Spectrum Emission Mask Measurement Results

Input Signal Requirements

Spectrum Emission Mask Measurement Description

Spectrum Emission Mask (SEM), as defined in 3GPP TS 34.122, is a relative measurement of the out-of-channel emissions to the in-channel power. The SEM measurement is used to measure the excess emissions that would interfere to other channels or to other systems.

  • In-channel power: The in-channel power is measured on the RF input signal which is filtered with a Root-Raised Cosine (RRC) filter with a rolloff of alpha = 0.22. The measurement interval for the in-channel power is 1 timeslot (666.7 us).

  • Out-of-channel emissions: The out-of-channel emissions in frequencies between 0.8 and 4.0 MHz away from the center channel frequency are determined in three symmetrical bands on each side of the carrier (see Spectrum Emission Mask in the Test Set). The emissions are measured with either a 30 kHz or 1 MHz bandwidth Gaussian measurement filter. The spectrum emission mask measurement's pass/fail limits for the 30 kHz bandwidth filter and 1 MHz bandwidth filter can be set from the front panel.

Spectrum Emission Mask in the Test Set

 | Frequency Offset from carrier | Measurement Bandwidth
Range 1 | 0.8-1.8 | 30 kHz
Range 2 | 1.8-2.4 | 30 kHz
Range 3 | 2.4 – 4.0 | 1 MHz

This measurement requires the calibration data of the measurement receiver path gain, which are part of the results of the measurement calibration, see Calibrate Measurements.

Spectrum Emission Mask Measurement Parameters

  • Multi-Measurement Count: see Multi-Measurement Count

  • Limit 30 KHz Bandwidth: +-0.8 MHz

  • Limit 30 KHz Bandwidth: +-1.8 MHz

  • Limit 30 KHz Bandwidth: +-2.4 MHz

  • Limit 1 MHz Bandwidth: +-2.4 MHz

  • Limit 1 MHz Bandwidth: +-4.0 MHz

  • Trigger Arm: see Trigger Arm

  • Trigger Source: see Trigger Source

  • Trigger Delay: see Trigger Delay

  • Measurement Timeout: see Measurement Timeout

Spectrum Emission Mask Measurement Results

  • Integrity Indicator: see Integrity Indicator

  • In-Channel Power: see In-channel power

  • Pass/Fail for the overall spectrum emission mask: If any out-of-channel frequency range does not comply with the limit you set, the entire mask fails.

  • Results for each frequency range:

  • Level Result relative to in-channel power: Average results for each offset. This can also be used to calculate the Mask Margin in the range.

  • Frequency Offset: Specifies in which the Mask Margin was calculated.

  • Mask Margin: Mask Margin = Mask Limit – Result/Average, and the minimum Mask Margin found in the range is displayed.

  • Pass/Fail: The mask for the range fails if the Level Result exceeds the mask.

Measurement results can be displayed in either numeric or graphic form.

When the graphic display is used, the result trace of the measurement is displayed. The green line is the spectrum emission mask for each frequency band range. There are four markers in the screen: the three red markers are always on and used to marker the largest mask error of the three frequency ranges; You can also turn on the white marker to see the corresponding frequency offset, relative power level and the margin on the top of screen. The lower part in this screen has six columns, which represents the index, the frequency range, the Pass/Fail result, the frequency Offset, the average result level and the Mask Margin of the frequency bands respectively.

When the numeric display is used, the Level column displays the average leakage power values measured at each offset, the Margin column displays the Mask Margin value and P/F column shows the Pass/Fail values for each offset.

Input Signal Requirements

  • The measured signal level is expected to be within 9 dB of the expected power.

  • The level into the test set's RF IN/OUT connector must be in the range of +5 dBm to +28 dBm, in a 1.28 MHz bandwidth.

  • For Non-HSDPA channel type, the frequency of the measured signal should be within 20KHz from the expected receiver frequency; For HSDPA channel type, the frequency of the measured signal should be within 2KHz from the expected receiver frequency.

Related Topics

GPIB Commands: SETup:TSEMask, FETCh:TSEMask


Frequency Stability Measurement

Frequency Stability Measurement Description

Frequency Stability Measurement Parameters

Frequency Stability Measurement Results

Input Signal Requirements

Frequency Stability Measurement Description

The Frequency Stability measurement displays the frequency of an RF signal applied to the test set's front panel RF IN/OUT input port. After each measurement the input signal's absolute RF frequency is displayed with 1000 Hz resolution on the test set's front panel and 1 Hz resolution when queried over the GPIB.

The absolute RF signal frequency obtained during each Frequency Stability measurement is compared to the expected (measurement downconverter) frequency of the test set's measuring receiver. The difference between the expected frequency and the measured frequency is displayed as frequency error with 1 Hz resolution.

  • If the device under test is a mobile station on a call, the expected frequency can be automatically set by the base station emulator (using the Channel setting).

  • If the device under test is not on a call, the expected frequency must be set by manually controlling the receiver (manual measurement frequency).

When multi-measurement count is turned on during a Frequency Stability measurement, the test set returns statistical data acquired over a number of measurements, including the worst case frequency error, in ppm (parts per million).

Frequency Stability Measurement Parameters

  • Multi-Measurement Count: see Multi-Measurement Count

  • Additional Filter: indicates whether to use a bandwidth 30kHz filter or not.

  • Trigger Arm: see Trigger_Arm

  • Measurement Timeout: see Measurement Timeout

Frequency Stability Measurement Results

  • Frequency Error: The absolute RF signal frequency obtained during each Frequency Stability measurement is compared to the expected (measurement downconverter) frequency of the test set's measuring receiver. The difference between the expected frequency and the measured frequency is displayed as frequency error with 1k Hz resolution.

Input Signal Requirements

  • Within the frequency interval 293 MHz to 2.7 GHz.

  • Within 200 kHz of the expected frequency.

  • Greater than -30 dBm.

  • Within 3 dB of the expected power.

  • Within an FM index of three (if FM is applied).

  • Within 100 Hz and 15 kHz modulating frequency (if FM is applied).

Related Topics

GPIB Commands: SETup:FSTability, FETCh:FSTability


Closed Loop Power Control (CLPC) Measurement

Closed Loop Power Control (CLPC) Measurement Description

  • What are Measured/Checked Steps in a CLPC Measurement?

  • Performing CLPC Measurement in Different Operating Modes

Closed Loop Power Control (CLPC) Measurement Parameters

Closed Loop Power Control (CLPC) Measurement Results

Input Signal Requirements

Taking Advantage of CLPC for Dynamic Power Measurements

Closed Loop Power Control (CLPC) Measurement Description

Closed Loop Power Control (CLPC) measurement, as defined in TS 34.122 Section 5.4.1.4, is used to test the ability of the UE transmitter to adjust its output power in accordance with one or more TPC commands received in the downlink. The power control step is the change in the UE transmitter output power in response to a single TPC command (TPC_cmd) arrived at the UE.

The closed loop power is defined as the relative power differences between RRC filtered mean power of original (reference) timeslot and RRC filtered mean power of the target timeslot without transient duration. In accordance with the minimum requirements of the standard (see Minimum Requirements for the CLPC Measurement), two kinds of relative power are measured:

  • REL1POW: If the target timeslot is in subframe f, the reference timeslot is in subframe f-1.

  • REL10POW: If the target timeslot is in subframe f, the reference timeslot is in subframe f-10.

When the CLPC measurement is initiated, the UL CL Power Ctrl Mode is no longer used to control the TPC pattern. Rather, you must specify the number of Down TPC and UP TPC commands that will be sent to the UE, see Closed Loop Power Control (CLPC) Measurement Parameters. The sequence of DOWN TPC commands followed by the sequence of Up TPC commands are sent on the downlink traffic slots, one TPC command per one subframe. When the measurement is finished, the result about whether the UE passes the measurement (whether the UE has ever exceeded the limit) is displayed, see Closed Loop Power Control (CLPC) Measurement Results.

The Closed Loop Power Control measurement can not be concurrent with other measurements. Hence starting the CLPC measurement will turn off any other measurement that is active, and vice versa.

This measurement requires the calibration data of the measurement receiver path gain, which are part of the results of the measurement calibration, see Calibrate Measurements.

What are Measured/Checked Steps in a CLPC Measurement?

During the CLPC measurement,

Measured Steps: If the TPC command sequence for this measurement are from subframe f_sta to subframe f_end,

    • for absolute power, TS1 in subframe of (f_sta) to (f_end+1) will be measured. The total number of measured steps is number of DOWN TPCs + number of UP TPCs + 1.

    • for REL1POW, TS1 power in subframe of (f_sta+1) to (f_end+1) will be measured. The total number of valid steps is number of DOWN TPCs + number of UP TPCs.

    • for REL10POW, TS1 power in subframe of (f_sta+10) to (f_end+1) will be measured. The total number of valid steps is number of DOWN TPCs + number of UP TPCs – 9.

Checked Steps: For the relative power step results (either REL1POW or REL10POW), checked steps refers to the steps that will be compared (checked) with its limit.

    • During the steps in response to the DOWN TPC commands:

    • for REL1POW, the checked steps will be from the first step whose power is NOT higher than (Maximum Power – Check Offset to Maximum Power) to the step after which the power is lower than (Minimum Power + Check Offset to Minimum Power).

    • for REL10POW, the checked steps will be from the 10th step to the step after which the power is lower than (Minimum Power + Check Offset to Minimum Power).

    • During the steps in response to the UP TPC commands:

    • for REL1POW, the checked steps will be from the first step whose power is NOT lower than (Minimum Power + Check Offset to Minimum Power) to the step after which the power is higher than (Maximum Power – Check Offset to Maximum Power).

    • for REL10POW, The steps from the 10th step to the step after which the power is higher than (Maximum Power – Check Offset to Maximum Power).

The following figure shows the typical relation between the measured steps, the checked steps, maximum/minimum power and the maximum/minimum power offset.

REL1POW measurement example

Performing CLPC Measurement in Different Operating Modes

The CLPC measurement can only be initiated in TD-SCDMA Test or Active Cell operating mode.

  • When performing CLPC measurements in TD-SCDMA Test operating mode, as there are no call connection between the test set and the UE, you must set the check limits for REL1POW and REL10POW correctly based on the step size specified on the UE side.

  • When in Active Cell operating mode, the CLPC measurement can only be initiated successfully when a call connection is established. The check limits for REL1POW and REL10POW should be set based on UL Close Loop Power Ctrl Step Size.

In Active Cell operating mode, the following settings can not be changed during the CLPC measurement:

  • UL CL Power Ctrl Mode

  • UL CL Power Ctrl Step Size

  • Call Drop Timer

  • Physical Channel Reconfiguration

Besides, during a call connection, the step size can not be changed by UL Close Loop Power Ctrl Step Size whereas it can be updated by Physical Channel Reconfiguration (see PCR UL CL Power Ctrl Step Size). This may help you to perform the CLPC measurement with different step sizes without having to re-connect.

Minimum Requirements for the CLPC Measurement

TPC Cmd | Transmitter Power Control Range
 | 1dB Step Size |  | 2dB Step Size |  | 3dB Step Size
 | Lower | Upper | Lower | Upper | Lower | Upper
Up | +0.5 dB | +1.5 dB | +1.0 dB | +3.0 dB | +1.5 dB | +4.5 dB
Down | -0.5 dB | -1.5 dB | -1.0 dB | -3.0 dB | -1.5 dB | -4.5 dB
TPC Cmd | Transmitter Power Control Range after 10 equal TPC_cmd groups
 | 1dB Step Size |  | 2dB Step Size |  | 3dB Step Size
 | Lower | Upper | Lower | Upper | Lower | Upper
Up | +8.0 dB | +12.0 dB | +16.0 dB | +24.0 dB | +24.0 dB | +36.0 dB
Down | -8.0 dB | -12.0 dB | -16.0 dB | -24.0 dB | -24.0 dB | -36.0 dB

Closed Loop Power Control (CLPC) Measurement Parameters

  • Number of Down/Up Steps: specifies the number of DOWN or UP TPC commands that are sent to the UE.

  • Maximum/Minimum Power Offset: specifies the offset to the maximum or minimum power of the measurement, where the maximum/minimum power is the maximum/minimum power in all measured steps. See REL1POW measurement example.

  • One Step Upper/Lower Limit: REL1POW should follow: Lower Limit ≤ |REL1POW| ≤ Upper Limit. If the operating mode is Active Cell, you should set the REL1POW limits according to UL CL Power Ctrl Step Size.

  • Ten Steps Upper/Lower Limit: REL10POW should follow: Lower Limit ≤ |REL10POW| ≤ Upper Limit. If the operating mode is Active Cell, you should set the REL10POW limits according to UL CL Power Ctrl Step Size.

  • Maximum Power Upper/Lower Limit: the maximum absolute power should neither be lower than its lower limit nor be larger than its upper limit.

  • Minimum Power Upper Limit: only upper limit is provided for the minimum absolute power, which should not be larger than its upper limit.

  • Trigger Source: see Trigger Source. It is recommended that you use protocol as the trigger source for the CLPC measurement.

There should be no RF signal input to the receiver of the test set if RF RISE is selected as the trigger source.

  • Trigger Delay: see Trigger Delay.

  • Measurement Timeout: see Measurement Timeout

Closed Loop Power Control (CLPC) Measurement Results

  • Integrity Indicator: see Integrity Indicator.

  • Overall Pass/Fail: See FETCh:TCLPower:TRACe:FAIL?

  • Results associated with each step, including:

  • Absolute mean power of the step

  • REL1POW

  • REL10POW

  • Pass/Fail

For GPIB commands, see FETCh:TCLPower:STEP?<sp><step index>

Note that the Pass/Fail indicator is only available for the measured steps that are "checked" with the upper or lower limits. If the reference step is not available, this step is not checked. For example, the step 0 for REL1POW and step 0 to 9 for REL10POW will not be checked during the measurement.

  • Results associated with the maximum or minimum power:

  • Maximum/Minimum Power: the maximum/minimum mean power among all measured steps.

  • Step Index: the index for the maximum/minimum power step.

  • Pass/Fail: the maximum absolute power should neither be lower than its lower limit nor be larger than its upper limit. The minimum absolute power among all steps should not be larger than its upper limit.

For GPIB commands, see FETCh:TCLPower:MAXimum:POWer? and FETCh:TCLPower:MINimum:POWer?

  • Results associated with the worst step: The worst step is for the step whose relative power (REL1POW or REL10POW) is closest to its upper or lower limit among all checked steps.

  • Step Index: the index of the worst step.

  • Absolute Power: the absolute power of the worst step.

  • Worst REL1POW/REL10POW: the REL1POW/REL10POW of the worst step.

Graphical trace

The graphical trace presents up to 300 steps of closed loop power statistics. A typical measurement result is shown as below:

You can also query the trace results by GPIB commands of FETCh:TCLPower:TRACe[:ABSolute]?, FETCh:TCLPower:TRACe:RELative?, FETCh:TCLPower:TRACe:RELative10? and FETCh:TCLPower:TRACe:FAIL?.

Input Signal Requirements

  • The first step power is expected to be within ±6 dB of the expected power and the relative power difference between the adjacent step is expected to be within ±6 dB.

  • Input signal level into the test set's RF IN/OUT connector is between -55 dBm and +28 dBm, in a 1.28 MHz bandwidth

  • For Non-HSDPA channel type, the frequency of the measured signal should be within 20KHz from the expected receiver frequency; For HSDPA channel type, the frequency of the measured signal should be within 2KHz from the expected receiver frequency.

Taking Advantage of CLPC for Dynamic Power Measurement

The CLPC measurement can also be used to measure dynamic power, which also performs a series of consecutive power measurements on the UE. The following considerations should be taken if you want to perform dynamic power measurements with CLPC:

  • Requirements for the input signals:

  • The input signal should be normal TD-SCDMA bursts in accordance with the technical standards.

  • The input signal should be consecutive in time and should be in the same channel/frequency.

  • There should be only one uplink timeslot in each subframe, and the uplink timeslot should be at the same position within each subframe (e.g. all subframes with the uplink TS2 is acceptable).

  • The maximum supported step length of the signal is 300, which is also the sum of the maximum supported UP and DOWN step numbers in CLPC measurement.

  • The first step power is expected to be within ±6 dB of the expected power, and the relative power difference between the adjacent step is expected to be within ±6 dB.

  • If RF Rise is selected as the trigger source, there should be no RF signals before the first step.

  • Requirements for setting up the measurement parameters:

  • Trigger Source: It is recommended to use the RF Rise as the trigger source for dynamic power measurement. When external trigger is selected, you should supply an external trigger signal via the rear panel TRIG IN connector in order to trigger data capture.

  • The number of UP and DOWN steps: The dynamic power measurement does not require the UE to react to the UP/DOWN TPC commands, so the two numbers no longer indicate the number of UP or DOWN TPC commands the test set will send to the UE (as they do in the CLPC measurement). As the test set supports at most 150 UP TPC commands and 150 DOWN TPC commands for each measurement, you should only ensure the sum of the two numbers does not exceed 300.

  • Dynamic Power measurement results :

  • The power for all the measured steps can be queried by FETCh:TCLPower:TRACe:ABSolute?

Related Topics

  • GPIB Commands: SETup:TCLPower, FETCh:TCLPower


Occupied Bandwidth (OBW) Measurement

Occupied Bandwidth (OBW) Measurement Description

Occupied Bandwidth (OBW) Measurement Parameters

Occupied Bandwidth (OBW) Measurement Results

Input Signal Requirements

Occupied Bandwidth (OBW) Measurement Description

As defined by 3GPP TS 34.122 Section 5.5.1, Occupied Bandwidth (OBW) measurement is a measure of the bandwidth containing 99 % of the total integrated power for transmitted spectrum and is centered on the assigned channel frequency. The test set allows the percentage of total integrated power to be adjusted from 70.0 to 99.0%.

According to the standard, the occupied channel bandwidth shall be less than 1.6 MHz.

This measurement requires the calibration data of the measurement receiver path gain, which are part of the results of the measurement calibration, see Calibrate Measurements.

Occupied Bandwidth (OBW) Measurement Parameters

  • Multi-Measurement Count: see Multi-Measurement Count.

  • Percent of Total Integrated Power: the percentage of the total power used in the occupied bandwidth measurement.

  • Trigger Arm: see Trigger Arm.

  • Trigger Source: see Trigger Source.

  • Trigger Delay: see Trigger Delay.

  • Measurement Timeout: see Measurement Timeout.

Occupied Bandwidth (OBW) Measurement Results

  • Integrity Indicator: see Integrity Indicator.

  • Occupied Bandwidth: the bandwidth that contains the specified Percentage of Total Integrated Power, the value of which equals to the difference between the upper frequency and the lower frequency.

  • Lower Frequency : the lower frequency of the occupied bandwidth.

  • Upper Frequency : the upper frequency of the occupied bandwidth.

Input Signal Requirements

  • The measured signal level is expected to be within 9 dB of the expected power.

  • Input signal level into the test set's RF IN/OUT connector is between +5 dBm and +28 dBm, in a 1.28 MHz bandwidth.

  • For Non-HSDPA channel type, the frequency of the measured signal should be within 20KHz from the expected receiver frequency; For HSDPA channel type, the frequency of the measured signal should be within 2KHz from the expected receiver frequency.

Related Topics

GPIB Commands: SETup:TOBWidth, FETCh:TOBWidth


Dynamic Power (DPOW) Measurement

Dynamic Power (DPOW) Measurement Description

Dynamic Power (DPOW) Measurement Parameters

Dynamic Power (DPOW) Measurement Results

Comparison with the Closed Loop Power Control Measurement

Input Signal Requirements

Dynamic Power (DPOW) Measurement Description

The Dynamic Power (DPOW) measurement measures a series of power levels for a step sequence. It provides a fast power calibration method that covers the typical 85dB (from -55dBm to +28dBm) dynamic range of a TD-SCDMA Mobile Station (MS).

The dynamic power measurement is not specified in the 3GPP standard.

The dynamic power measurement is not performed with a call established between the test set and MS. Rather, you must place your MS into a test mode which forces it to transmit a power sequence of successive steps. During the DPOW measurement, the power levels are measured in one timeslot with the step width being one subframe (5ms).

This measurement supports to specify up to 10 trigger steps as the start of the step sequence. Trigger steps are of the same constant level, and can be used to trigger the measurement when RF Rise is selected as the trigger source. After the trigger steps are the measurement steps whose power levels change monotonously. The figure below shows the relationship between the trigger steps and the measurement steps.

Relationship Between the Trigger Steps and the Measurement Steps

  • The DPOW measurement is not available in CW operating mode.

  • The Dynamic Power measurement can not be concurrent with other measurements. Hence starting the DPOW measurement will turn off any other measurement that is active, and vice versa.

This measurement requires the calibration data of the measurement receiver path gain, which are part of the results of the measurement calibration, see Calibrate Measurements.

Dynamic Power (DPOW) Measurement Parameters

  • RRC Filter: You may choose to measure the average power of each step with or without the RRC (Root Raised Cosine) filter in place.

GPIB Command: SETup:TDPower:FILTer[:RRC]

  • Trigger Source: see Trigger Source.

Please note that the trigger source setting only applies the first step, and the protocol trigger is used for the following steps.

  • Trigger Delay: see Trigger Delay.

  • Number of Power Steps: the number of steps in the measurement sequence.

GPIB Command: SETup:TDPower:NSTep:MEASure

  • Initial Step Power: the expected power for the initial measurement step.

GPIB Command: SETup:TDPower:INITial:POWer

  • Number of Trigger Steps: the number of steps in the trigger sequence. The trigger steps are important if your MS's first step power is too low to be triggered by RF Rise. See Relationship Between the Trigger Steps and the Measurement Steps.

GPIB Command: SETup:TDPower:NSTep:TRIGger

  • Synchronization Mode: specifies whether to use midamble synchronization for the dynamic power measurement.

GPIB Command: SETup:TDPower:SYNChronize:MODE

  • Measurement Timeout: see Measurement Timeout.

Dynamic Power (DPOW) Measurement Results

  • Integrity Indicator: see Integrity Indicator.

  • Trigger Step Power: the valid power results for the trigger steps are based on Number of Trigger Steps. See also FETCh:TDPower:STEP:POWer:TRIGger?.

  • Measurement Step Power: the valid power results for the measurement steps are based on Number of Power Steps. See also FETCh:TDPower:STEP:POWer[:MEASure]?.

The graphical above shows a typical measurement result, in which each step power is represented by a graphical "Bar". The x-axis graph represents the number of the measurement steps and the y-axis represents the power of the measurement step in units of dBm/1.28 MHz.

Input Signal Requirements

  • The trigger steps must be within 9 dB of the expected input level. For the measurement steps, the adjacent step difference is required to be between -20 to +9 dB.

  • The signal level into the test set's RF IN/OUT connector must be between -55 to +28 dBm, in a 1.28 MHz bandwidth.

  • For Non-HSDPA channel type, the frequency of the measured signal should be within 20KHz from the expected receiver frequency; For HSDPA channel type, the frequency of the measured signal should be within 2KHz from the expected receiver frequency.

Comparison with the Closed Loop Power Control Measurement

You can also use the Closed Loop Power Control (CLPC) measurement for dynamic power measurements on some special cases (see Taking Advantage of CLPC for Dynamic Power Measurement). A comparison is given below for dynamic power and closed loop power control measurement when measuring a step sequence.

Similarities with the CLPC measurement:

  • The step width is one subframe (5ms).

  • The measurement interval is one time slot excluding the guard period.

  • If the trigger source is Protocol or External, the measured time slot is TS1.

  • Concurrence with other measurements is not supported.

Differences from the CLPC measurement:

  • During a DPOW measurement, no DOWN or UP TPC commands are sent to the MS to control its output power.

  • For DPOW measurement, the trigger source is only applied to the first step, and all the following steps are triggered by Protocol.

  • For DPOW measurement, the adjacent step difference requirement is from -20 to +9 dB, rather than the +/-6dB for the CLPC measurement.

  • The DPOW measurement supports to enable/disable the RRC Filter. See Dynamic Power (DPOW) Measurement Parameters.

Related Topics

GPIB Commands: SETup:TDPower, FETCh:TDPower


Loopback Bit Error Ratio (BER) Measurement

Loopback Bit Error Ratio (BER) Measurement Description

Loopback Bit Error Ratio (BER) Measurement Parameters

Loopback Bit Error Ratio (BER) Measurement Results

Input Signal Requirements

Loopback Bit Error Ratio (BER) Measurement Description

3GPP TS 34.122 F.6.1.1 defines bit error ratio (BER) as follows: "The Bit Error Ratio is defined as the ratio of the bits wrongly received to all data bits sent. The bits are the information bits above the convolutional/turbo decoder."

When the test set measures loopback bit error ratio, it sends a known data pattern on the downlink DTCH to a UE that is configured in loopback type 1 (see UE Loopback Scenario). The UE decodes the data and re-transmits it on the uplink DTCH. The test set analyzes the uplink data to see how closely it matches the data bits originally sent on the downlink and reports the BER results.

To decrease test time, you may set Confidence State to On and specify the BER Requirement , which allows the test set to stop testing when an early pass or early fail event occurs, and to report a Confidence Test Result (see 3GPP TS 34.122 F.6 and 3GPP TS 34.901).

3GPP TS 34.122 Figure F.6.1.9

To perform the loopback BER measurement while in Active Cell operating mode , you must be on an RB test mode call and:

  • if the Channel Type is 12.2k RMC SC or 12.2k RMC MC, the UE Loopback Scenario should be Type1, RLC TM.

  • if the Channel Type is 12.2k RMC + HSDPA, the UE Loopback Scenario setting is not applicable but Type1, RLC TM will be used by default by the test set.

The loopback BER measurement is not applicable for the CW and Cell Off operating mode.

Loopback Bit Error Ratio (BER) Measurement Parameters

  • Number of bits to test

When set to Off, this parameter determines the number of data bits to test during the measurement. However, the actual number of bits tested is always the largest multiple of the number of bits needed to fill a DTCH transport block for the transmitted format.

When set to On, this parameter determines the maximum number of bits to test during the measurement. However, the actual number of bits tested will be less than this number if an early pass or early fail event occurs (see Confidence Test Result). If a Confidence Test Result of Max Bits Tested is returned, then the actual number of bits tested is the largest multiple of the number of bits needed to fill a DTCH transport block for the transmitted format, as explained above.

  • Trigger Arm: see Trigger Arm.

  • Measurement Timeout: see Measurement Timeout.

  • Confidence State

To decrease test time, you may set the Confidence State to On and specify the BER Requirement, which allows the test set to stop testing when an early pass or early fail event occurs, and to report a Confidence Test Result (the Confidence Level is fixed for the measurement).

  • BER Requirement

3GPP TS 34.122 F.6 defines TR = Test Requirement. As testing progresses, the bit error ratio trajectory converges to a value (see 3GPP TS 34.122 Figure F.6.1.9). The BER value that the UE is converging to shall not exceed the Test Requirement. The BER Requirement parameter is equivalent to Test Requirement expressed as a percentage.

  • Bad CRC Block

Bad CRC Block determines whether the bad CRC block will be counted for BER calculation. If it is set to Exclude, the number of error bits, the number of tested bits, and the BER will not be updated by this bad CRC block; else this block will be used for BER calculation.

The following are fixed settings in the test set:

  • Confidence Level

3GPP TS 34.122 F.6 defines:

F = probability of a wrong decision

(1 - F) = probability of a correct decision

The probability (risk) to fail a good DUT shall be </= F according to the following definition: A DUT is failed, accepting a probability of </= F that the DUT is still better than the specified error ratio (Test requirement).

The probability to pass a bad DUT shall be </= F according to the following definition: A DUT is passed, accepting a probability of </= F that the DUT is still worse than M times the specified error ratio. (M>1 is the Bad DUT Factor ).

The Confidence Level parameter is equivalent to (1 - F). 3GPP TS 34.122 table F.6.1.8 specifies an F of 0.2% ( Confidence Level of 99.8% ) for all Receiver and Performance Characteristics tests in 3GPP TS 34.122 sections 6 and 7 (except for the fail limit for 6.5 Blocking Characteristics).

Confidence Level is thus fixed to 99.8%.

Similarly,

  • Bad DUT Factor (M) is fixed to 1.5.

  • Test Limit (Test requirement *Test Limit Factor) is fixed to 1.234

  • Target Number of Error Bits is fixed to 345

Loopback Bit Error Ratio (BER) Measurement Results

  • Bit Error Ratio: the ratio of incorrectly received bits to the bits tested, expressed as a percentage (%).

  • Bit Error Count: the number of incorrectly received bits.

  • Bits Tested

Number of bits tested to determine the Bit Error Count and Bit Error Ratio results.

  • Missing Blocks

The UE sends a TFCI for each uplink DTCH transport block. When operating in Active Cell Operating Mode , the test set monitors the uplink TFCI, and can report uplink missing blocks. If the TFCI indicates that there is no data block sent for that TTI, the test set reports a missing block. When a missing block occurs, Bit Error Count and Bits Tested are not incremented;

In TD-SCDMA Test Operating Mode, if the UL DPCH TFCI State is set to Manual, the test set does not monitor the uplink TFCI, thus the reported number of missing blocks will always be zero.

  • CRC Errors

To determine if an uplink CRC error has occurred, the test set calculates the CRC for the data sent in the uplink DTCH transport block, and compares the result to the CRC sent by the UE for that transport block. When a CRC error occurs, the data within the block is not analyzed, and the number of Bits Tested is not incremented.

  • Loopback Delay: the delay between received downlink radio frames and their corresponding uplink radio frames (produced from the received data). It can not be obtained when DL DTCH Data is set to All Zeros, All Ones or Alternating.

  • Confidence Test Result

The Confidence Test Result is only available when Confidence State is On.

  • Pass: Few enough bit errors were detected for a large enough number of Bits Tested that the test set is able to predict that the bit error ratio trajectory is converging to a value below the BER Requirement. An early pass event is determined.

  • Fail: Enough bit errors were detected for the number of Bits Tested that the test set is able to predict that the bit error ratio trajectory is converging to a value above the BER Requirement. An early fail event is determined.

  • Max Bits Tested: After testing the number of bits specified by Number of Bits to Test, the test set is unable to predict whether the bit error ratio trajectory is converging to a value above or below the BER Requirement.

Input Signal Requirements

The test set can synchronize to the UE's signal only if the bit error ratio is less than 10% on a block-by-block basis for three consecutive blocks.

Related Topics

GPIB Commands: SETup:TBERror, FETCh:TBERror


Transmit ON/OFF Power (TOOP) Measurement

Transmit ON/OFF Power (TOOP) Measurement Description

Transmit ON/OFF Power (TOOP) Measurement Parameters

Transmit ON/OFF Power (TOOP) Measurement Results

Input Signal Requirements

Transmit ON/OFF Power (TOOP) Measurement Description

Transmit On/Off Power (TOOP) measurement is to check whether the RRC filtered mean power versus time meets the specified mask. The 3GPP standard TS 34.122 Section 5.4.4 defines the TOOP time mask as the ramping time allowed for the UE between transmit OFF power and transmit ON power.

The test set measures three timeslots excluding the leading and the laging guard period (See Transmit ON/OFF Power). The transmission period refers to the burst without guard-period for a single transmission slot (from chip 0 to 847). The chip 0 refers to the first chip in the transmission period); Mask is applied to the OFF Power for the Range 1, 2 or 3 respectively.

Please be noted that specific Hardware Requirements is required in order to get accurate measurement results for the Transmit On/Off measurement.

Transmit ON/OFF Power

*If the transmission slot (Time Slot S) is TS1, then the Range 1 starts at the -160th chip. Otherwise, the Range 1 starts at the -864th chip.

This measurement requires the calibration data of the measurement receiver path gain, which are part of the results of the measurement calibration, see Calibrate Measurements.

Transmit ON/OFF Power (TOOP) Measurement Parameters

  • Multi-Measurement Count: see Multi-Measurement Count.

  • Trigger Arm: see Trigger Arm.

  • Trigger Source: see Trigger Source.

  • Trigger Delay: see Trigger Delay.

  • Measurement Timeout: see Measurement Timeout.

  • Trace State: specifies whether the trace result is available.

  • Off Power Mode: specifies the way to get the power result of the three ranges. This parameter can be set to either Average or Worst. If it is set to Average, the power result for each range is the average chip power of the range; If it is set to Worst, the power result for each range is the highest chip power in the range.

  • Off Power Range 1|2|3 Limit: specifies the OFF Power mask limit for Range 1|2|3.

Transmit ON/OFF Power (TOOP) Measurement Results

  • OFF Power results associated with the Range 1|2|3:

  • Level: the average or worst power for Range 1|2|3 based on the setting of OFFPow Mode.

  • Pass/Fail: specifies whether the power result for each range is out of the Off Power Range Limit.

  • Offset Power: Up to 12 offset can be set in order to retrieve specific offset average or worst power. The offset can be set from the front panel or by the command of SETup:TOOPower:TIME[:OFFSet].

  • Averaged ON Power: the average RRC filtered mean power of the transmission period.

  • Trace Power: the chip power of the whole trace is available if the Trace State is ON.

Graphical trace

The measurement results can be displayed in either numeric or graphical form. When the Trace State is set to On, the graphical trace result is viewable for chips from -864 to 1711 (see below). When a limit line (in green) is exceeded in the range, the range status changes from "Pass" to "Fail."

Input Signal Requirements

  • The level into the test set's RF IN/OUT connector must be in the range of -65 dBm to +28 dBm. The measured signal level is expected to be within 9 dB of the expected power.

  • For Non-HSDPA channel type, the frequency of the measured signal should be within 20KHz from the expected receiver frequency; For HSDPA channel type, the frequency of the measured signal should be within 2KHz from the expected receiver frequency.

Related Topics

GPIB Commands: SETup:TOOPower, FETCh:TOOPower


Block Error Ratio (BLER) Measurement

Last updated: March 10, 2010

Block Error Ratio Measurement Description

Block Error Ratio Measurement Parameters

Block Error Ratio Measurement Results

Block Error Ratio Measurement Description

3GPP TS 34.122, F.6.1.1 defines block error ratio (BLER) as follows: "A Block Error Ratio is defined as the ratio of the number of erroneous blocks received to the total number of blocks sent. An erroneous block is defined as a Transport Block, the cyclic redundancy check (CRC) of which is wrong."

To perform a block error ratio measurement, you must be on a Radio Bearer Test Mode call. The following test senarios are provided depending on UE Loopback Type:

  • When the UE is operating in Type 1, RLC AM loopback type, the block error ratio is calculated by the ratio of number of UE retransmission requests and the total number of blocks sent to the UE. In AM the UE indicates missing protocol units (=transport blocks) in the STATUS PDU message.

  • When the UE is operating in test loop mode 2, the block error ratio is calculated by checking returned data and CRC and count number of block errors and the total number of sent blocks.

The BLER measurement is only available when the following conditions are met:

  • Operating Mode is Active Cell;

  • UE Loopback Scenario is either Type 1, RLC AM or Type 2;

  • if the call status is Connected, the current service type is RB Test Mode or, if the call status is Idle, the Paging Service Type is set to RB Test Mode;

  • the Channel Type is 12.2k RMC.

Block Error Ratio Measurement Parameters

  • Number of Blocks to Test - Sets the number of blocks to test during the measurement.

Note, the time for the measurement to complete increases linearly with the Number of Blocks to Test . For example, to test 500 blocks while on a 12.2k RMC takes approximately 10 seconds (500 blocks x 20 ms/block = 10 seconds).

GPIB Command: SETup:TBLerror:COUNt

  • Trigger Arm - see Trigger Arm.

  • Measurement Timeout

See Measurement Timeout. Ensure that the Measurement Timeout is greater than the time the measurement needs to measure the desired Number of Blocks to Test .

Block Error Ratio Measurement Results

  • Integrity Indicator: see Integrity Indicator.

  • Block Error Ratio

The ratio of incorrectly received blocks to the total blocks sent to the UE, expressed as a percentage (%). GPIB Command: FETCh:TBLerror:RATio?

  • Block Error Count

The number of incorrectly received blocks, or "block errors". GPIB Command: FETCh:TBLerror:COUNt?

  • Blocks Tested

Number of blocks tested to determine the Block Error Ratio and Block Error Count results. GPIB Command: FETCh:TBLerror:BLOCks?

  • Uplink Missing Blocks

The UE sends a TFCI for each uplink DTCH transport block. When operating in Active Cell Operating Mode, the test set monitors the uplink TFCI, and can report uplink missing blocks. If the TFCI indicates that there is no data block sent for that TTI, the test set reports a missing block. When an uplink missing block occurs, no block comparison is done on the block, and the number of Blocks Tested is not incremented. GPIB Command: FETCh:TBLerror:MBLocks?

Related Topics

GPIB Commands: SETup:TBLError, FETCh:TBLerror


HSDPA Block Error Ratio (HBLER) Measurement

Last updated: March 10, 2010

HSDPA Block Error Ratio Measurement Description

HSDPA Block Error Ratio Measurement Parameters

HSDPA Block Error Ratio Measurement Results

How Do I Make an HSDPA Block Error Ratio Measurement

HSDPA Block Error Ratio Measurement Description

The HSDPA block error ratio (BLER) measurement can only be performed on a Radio Bearer Test Mode connection with a Channel Type of 12.2k RMC + HSDPA. To perform the HSDPA BLER measurement, the test set sends blocks of data to the UE on the downlink HS-PDSCH(s), and then monitors the positive acknowledgments (ACKs) and negative acknowledgments (NACKs) sent by the UE on the uplink HS-DPCCH.

The UE is required to respond to every block of data directed to it with either an ACK or NACK. If it does not respond to a block in its assigned TTI, the test set logs the event as a statistical DTX (statDTX). Also, if the UE responds to a block with data other than all 1s (ACK) or all 0s (NACK), the TTI is treated as a statDTX. StatDTXs are considered block errors, and are included in the BLER calculation. You can specify how the test set responds to statDTXs using the statDTX Reception Behavior setting.

HSDPA Block Error Ratio Measurement Parameters

  • Number of blocks to test

GPIB Command: SETup:THBLerror:COUNt

  • Trigger Arm - see Trigger Arm.

  • Measurement Timeout

  • See Measurement Timeout. Ensure that the Measurement Timeout is greater than the time the measurement needs to measure the desired Number of Blocks to Test .

HSDPA Block Error Ratio Measurement Results

  • Block Error Ratio

3GPP TS 34.121 F.6.3.2 defines the HSDPA block error ratio as: (NACK + statDTX)/(NACK+ statDTX +ACK).

GPIB Command:FETCh:THBLerror:RATio?

  • Information Bit Throughput (kbps)

This result reports the data throughput of the HSDPA connection. 3GPP TS 34.121 F.6.3.1 defines Information Bit Throughput R as "the sum (in kilobits) of the information bit payloads (excluding the 24-bit HS-DSCH CRC) successfully received during the test interval, divided by the duration of the test interval (in seconds)."

GPIB Command: FETCh:THBLerror:IBTHroughput?

  • ACKs

Number of positive acknowledgments received. GPIB Command: FETCh:THBLerror:ACK?

  • NACKs

Number of negative acknowledgments received. GPIB Command: FETCh:THBLerror:NACK?

  • statDTXs

Number of statistical DTXs received. GPIB Command: FETCh:THBLerror:SDTX?

  • P(Em)

3GPP TS 34.122 defines P(Em) as the probability of event Em, which is declared when the UE is signaled on HS-SCCH, but DTX is observed in the corresponding HS-SICH ACK/NACK field. P(Em) is calculated by: (statDTX)/(NACK+ statDTX +ACK). This result is used for HS-SCCH Detection Performance testing.

GPIB Command: FETCh:THBLerror:PEM?

  • Blocks Tested

Blocks tested is the number of blocks that were tested in determining the Block Error Ratio, Information Bit Throughput , ACKs , NACKs , statDTXs. GPIB Command: FETCh:THBLerror:BLOCks?

How Do I Make an HSDPA Block Error Ratio Measurement

  • 3GPP TS34.122 9.3.1 HS-DSCH throughput for Fixed Reference Channels

  • 3GPP TS34.122 9.3.2 HS-DSCH throughput for Variable Reference Channels

  • 3GPP TS34.122 9.3.4 HS-SCCH Detection Performance

3GPP TS34.122 9.3.1 HS-DSCH throughput for Fixed Reference Channels

The following procedure performs the 3GPP TS34.122 9.3.1E HS-DSCH throughput for Fixed Reference Channels 2.8 Mbps UE class QPSK/16QAM, Test 1, as an example.

  1. Connect the UE to the front panel RF IN/OUT port (For TS34.122 9.3.1E, the standard also requires the multipath fading simulator and external AWGN, please ensure all your hardware connections are correct).

  2. Configure your UE to be of 2.8 Mbps UE class.

  3. Set call parameters as following:

  4. [F7 in Call Parms 1 of 3] Set the Cell Power to the appropriate value for your test.

  5. [F8 in Call Parms 1 of 3] Set Channel Type to 12.2k RMC + HSDPA.

  6. [F11 in Call Parms 1 of 3] Select HSDPA RB Test Mode Setup (F7)

  • Set the HS-DSCH Config to RMC (default).See HSDPA Channel Configuration-RMC and VRC for the downlink and uplink channel configurations.

  • Set the RMC Type to 2.8M QPSK.

  • Select MAC-hs Parameters (F8), set the Number of transmissions to 4 (default) and RV Sequence to 0,0.0,0.0,0.0,0 (simply enter 0 and press the knob). Leave the other MAC-hs parameters as default.

  • [F1 in Call Control 2 of 3] Set the Scrambling Code to 1.

  4. [F2 in Call Control 2 of 3] In Cell Parameters, set the PS Domain Information to Present.

  5. Power the UE on and wait for it to be registered.

  6. [F3 in Call Control 1 of 3] Press Originate Call. Wait for the Active Cell area to be Connected.

  7. Press the Measurement selection key.

  8. Select HSDPA Block Error Ratio.

  9. (Optional) [F1 in Control 1 of 2] Setup the HSDPA Block Error Ratio measurement parameters.

  10. Watch the Information Bit Throuput result.

3GPP TS34.122 9.3.2 HS-DSCH throughput for Variable Reference Channels

The following procedure performs the 3GPP TS34.122 9.3.2E HS-DSCH throughput for Variable Reference Channels 2.8 Mbps UE class, Test 1, as an example.

  1. Connect the UE to the front panel RF IN/OUT port (For TS34.122 9.3.2E, the standard also requires the multipath fading simulator and external AWGN, please ensure all your hardware connections are correct).

  2. Configure your UE to be of 2.8 Mbps UE class.

  3. Set call parameters as following:

  4. [F7 in Call Parms 1 of 3] Set the Cell Power to the appropriate value for your test.

  5. [F8 in Call Parms 1 of 3] Set Channel Type to 12.2k RMC + HSDPA.

  6. [F11 in Call Parms 1 of 3] Select HSDPA RB Test Mode Setup (F7)

  • Set the HS-DSCH Config to VRC. See HSDPA Channel Configuration-RMC and VRC for the downlink and uplink channel configurations.

  • Select MAC-hs Parameters (F8), set the Number of transmissions to 1 and RV Sequence to 0,0.0,0.0,0.0,0 (simply enter 0 and press the knob). Leave the other MAC-hs parameters as default.

  • [F1 in Call Control 2 of 3] Set the Scrambling Code to 1.

  4. [F2 in Call Control 2 of 3] In Cell Parameters, set the PS Domain Information to Present.

  5. Power the UE on and wait for it to be registered.

  6. [F3 in Call Control 1 of 3] Press Originate Call. Wait for the Active Cell area to be Connected.

  7. Press the Measurement selection key.

  8. Select HSDPA Block Error Ratio.

  9. (Optional) [F1 in Control 1 of 2] Setup the HSDPA Block Error Ratio measurement parameters.

  10. Watch the Information Bit Throuput result.

3GPP TS34.122 9.3.4 HS-SCCH Detection Performance

The following procedure performs the 3GPP TS34.122 9.3.4 HS-SCCH Detection Performance, Test 1, as an example.

  1. Connect the UE to the front panel RF IN/OUT port (For TS34.122 9.3.4, the standard also requires the multipath fading simulator and external AWGN, please ensure all your hardware connections are correct).

  2. Set call parameters as following:

  3. [F7 in Call Parms 1 of 3] Set the Cell Power to the appropriate value for your test.

  4. [F8 in Call Parms 1 of 3] Set Channel Type to 12.2k RMC + HSDPA.

  5. [F11 in Call Parms 1 of 3] Select HSDPA RB Test Mode Setup (F7)

  • Set the HS-DSCH Config to HSSCCH Detection. See HSDPA Channel Configuration-HS-SCCH Detection for the downlink and uplink channel configurations.

  • Leave the H-RNTI Parameters as default. The default values for Primary H-RNTI and HS-SCCH2-4 H-RNTIs are set to match the standard.

  1. [F1 in Call Control 2 of 3] Set the Scrambling Code to 0 (default).

  2. [F2 in Call Control 2 of 3] In Cell Parameters, set the PS Domain Information to Present.

  3. Power the UE on and wait for it to be registered.

  4. [F3 in Call Control 1 of 3] Press Originate Call. Wait for the Active Cell area to be Connected.

  5. Press the Measurement selection key.

  6. Select HSDPA Block Error Ratio.

  7. (Optional) [F1 in Control 1 of 2] Setup the HSDPA Block Error Ratio measurement parameters.

  8. Watch the P(Em) result.

Related Topics

GPIB Commands: SETup:THBLerror, FETCh:THBLerror


Open Loop Power Control (OLPC) Measurement

Open Loop Power Control Measurement Description

Open Loop Power Control Measurement Parameters

Open Loop Power Control Measurement Results

Input Signal Requirements

How Do I Make an Open Loop Power Control Measurement?

Open Loop Power Control Measurement Description

As defined in the 3GPP standard TS 34.122 5.4.1.3, the open loop power control is the ability of the UE transmitter to sets its output power to a specific value.

The open loop power control measurement can only be initiated when the Operating Mode is Active Cell and the call status is Idle.

In Active Cell operating mode, when the open loop power control measurement is initiated, the test set captures the first UpPTS burst in an access sequence, and measures the RRC filtered mean power in UpPTS timeslot.

During this measurement, the Call Limit State is locked to On by the test set to prevent the call status from transiting to Connected. Besides, if the Power Control is set to Auto, changing the Cell Power, Broadcast Primary CCPCH Tx Power or the Desired UpPCH RX power will lead the expected input power level of the test set to be changed, which will accordingly cause the measurement to be aborted.

The Open Loop Power Control Measurement can not be performed in concurrence with other measurements.

  • The open loop power control measurement can only be initiated when the Operating Mode is Active Cell and the call status is Idle.

  • Before the open loop power control measurement, the UE must be informed of the following updated parameters from the downlink BCH: Broadcast Primary CCPCH Tx Power, UpPCH Power Ramp Step, Desired UpPCH RX power and Max Sync UL Transmissions etc. This can be archived by performing a registration or call origination beforehand.

  • The open loop power control measurement can only be initiated with the Trigger Arm to be Single.

Open Loop Power Control Measurement Parameters

  • Initial UpPCH Tx Power Limit: this parameter is expressed in dB and specifies the open loop power control tolerance. The difference between the measurement result and the expected power should be less than this limit.

GPIB Command: SETup:TOLPower:LIMit

  • Measurement Timeout: see Measurement Timeout.

GPIB Command: SETup:TOLPower:TIMeout[:STIMe]

Open Loop Power Control Measurement Results

You can fetch all the OLPC results all together by a single GPIB command: FETCh:TOLPower[:ALL]?

  • Initial UpPCH Tx Power Measurement Results: the RRC filtered mean power in UpPTS slot.

GPIB Command: FETCh:TOLPower:POWer? and FETCh:TOLPower:FAIL?

  • Detected UpPCH Signature

GPIB Command: FETCh:TOLPower:SIGNature?

Input Signal Requirements

  • The measured signal level is expected to be within +10 dB to -20 dB of the expected power.

  • Input level is between -60 dBm and +28 dBm.

  • Frequency is within 20KHz from the expected measurement receiver frequency.

How Do I Make an Open Loop Power Control Measurement?

The following procedure performs the 3GPP TS 34.122 5.4.1.3 Open loop power control (1,28 Mcps TDD Option), as an example.

Initial conditions

  1. Connect the UE to the front panel RF IN/OUT port.

  2. Set call parameters as following (RX-middle parameters in 3GPP TS 34.122 Table 5.4.1.3.4b):

  • [F7 in Call Parms 1 of 3] Set the Cell Power to -66 dBm.

  • [F12 in Call Parms 1 of 3] In UE Transmit Pwr Control, set as the following:

  • Set the Broadcast Primary CCPCH Tx Power to +24 dBm (default value).

  • Set the Desired UpPCH RX Power to -100 dBm (default value).

  • Set the UpPCH Power Ramp Step to 0 dB.

  3. Set call control parameters as following:

  4. [F5 in Call Control 2 of 3] In Channel Config Info, press F1 (Uplink Channel Config), set the Max SYNC UL Transmissions to 1.

  4. [F7 in Call Parms 3 of 3] Set the MS DPCH Tgt Pwr to -10 (default value).

Procedure

  1. Press the Measurement selection key.

  2. Select Open Loop Power.

  3. Select Open Loop Power Setup (F1). Set the measurement parameters as needed for your measurement situation, such as the Initial UpPCH Tx Power Limit.

  4. Press the START SINGLE key to begin the measurement. An example measurement result is shown as below:

Related Topics

GPIB Commands: SETup:TOLPower, FETCh:TOLPower


Out-of-Synch Handling of Output Power (OOS) Measurement

Out-of-Synch Handling of Output Power (OOS) Measurement Description

  • Required Initial Conditions

  • Operating Considerations

Out-of-Synch Handling of Output Power (OOS) Measurement Parameters

Out-of-Synch Handling of Output Power (OOS) Measurement Results

How Do I Make an Out-of-Synch Handling of Output Power (OOS) Measurement?

Out-of-Synch Handling of Output Power (OOS) Measurement Description

The test set only supports the Out-of-Synchronization of output power measurement for continuous transmission.

Out-of-Synchronization of Output Power (OOS) measures the UE's ability to monitor the Downlink DPCH quality and turn its transmitter on or off based on the quality level.

3GPP TS 34.122 5.4.5.1 states: The UE shall monitor the DPCH quality in order to detect a loss of the signal on Layer 1, as specified in TS 25.224. The thresholds Qout and Qin specify at what DPCH quality levels the UE shall shut its power off and when it shall turn its power on, respectively.

The DPCH power level at which the UE shall shut its transmitter off and when it shall turn it on is defined in 3GPP 34.122 Figure 5.4.5.2.2: Conditions for out-of-synch handling in the UE.

3GPP 34.122 Figure 5.4.5.2.2: Conditions for out-of-synch handling in the UE

  1. The UE shall not shut its transmitter off before point B.

  2. The UE shall shut its transmitter off before point C, which is Toff = 200 ms after point B

  3. The UE shall not turn its transmitter on between points C and E.

  4. The UE shall turn its transmitter on before point F, which is Ton = 200 ms after Point E.

You are allowed to specify the time intervals and DPCH Quality Ratio between points A and F (see Out-of-Synch Handling of Output Power (OOS) Measurement Parameters). When the measurement is initiated, the test set varies its downlink level according to these settings and generates triggers that are routed to the rear panel external trigger output. You must then measure the UE's power response using an external spectrum analyzer to determine if the UE turned its power off and on as required.

There are two trigger modes provided for the OOS measurement (GPIB only, see SETup:TOOSynch:TRIGger:OUTPut:SUBFrames). Besides, the Trig Output Setup should be set to Measurement Generated to synchronize the external spectrum monitor with the test set.

The OOS Measurement can not be performed in concurrence with other measurements.

Required Initial Conditions

The Out-of-Synch Handling of Output Power measurement can only be initiated with the following conditions:

  • Operating Mode is Active Cell;

  • Current Service Type is RB Test Mode;

  • Channel Type is 12.2k RMC;

  • UE Loopback Scenario is Type 1, RLC TM or Type 2;

  • Current call status is connected.

Operating Considerations

Before initiating the OOS measurement, it's strongly recommended you do the following:

  • Set the DPCH Quality Ratio before point A correctly. DPCH Quality levels for other periods (A-B, B-D and D-E) can be set by Out-of-Synch Handling of Output Power (OOS) Measurement Parameters.

  • Set as the following to ensure that the UE will not drop the call during the measurement: (N313 * 5 ms) + T313 – (N315 * 5 ms) > Ta-b + Tb-c(200ms) + Tc-d+ Td-e.

  • Set the UL CL Power Control to All Up Bits to drive the UE TX Power to its maximum.

  • (Test set behavior) The test set will keep the Call Drop Timer setting to Off during the OOS measurement, yet the value will be restored once the measurement is done.

  • (Test set behavior) The test set will restore the value of DPCH Quality Ratios once the measurement is done.

Out-of-Synch Handling of Output Power (OOS) Measurement Parameters

See 3GPP 34.122 Figure 5.4.5.2.2: Conditions for out-of-synch handling in the UE for a definition of points A - F.

  • Transmission Mode: This setting allows you to set the transmission mode required, either continues transmission (3GPP TS34.122 S5.4.5) or Discontinues transmission (3GPP TS34.122 S5.4.6).

Note: The default values of Downlink DPCH_Ec / Ior Ratio Settings are consistent with 3GPP TS34.122 S5.4.5 for continuous OOS test cases. If you want to test discontinuous OOS test cases, you must change these values to that you required before initiating the measurement.

GPIB Command: SETup:TOOSynch:TRANsmission:MODE

  • Segment Ta-b Interval (Default: 5.000 s): Time between points A and B.
    GPIB Command: SETup:TOOSynch:INTerval:AB

  • Segment Tc-d Interval (Default: 5.000 s): Time between points C and D.
    GPIB Command: SETup:TOOSynch:INTerval:CD

  • Segment Td-e Interval (Default: 5.000 s): Time between points D and E.
    GPIB Command: SETup:TOOSynch:INTerval:DE

  • DPCH Quality Ratio A-B (Default: -6.00 dB): DPCH level between points A and B.
    GPIB Command: SETup:TOOSynch:RATio:AB

  • DPCH Quality Ratio B-D (Default: -16.00 dB): DPCH level between points B and D.
    GPIB Command: SETup:TOOSynch:RATio:BD

  • DPCH Quality Ratio D-E (Default: -14.00 dB): DPCH level between points D and E.
    GPIB Command: SETup:TOOSynch:RATio:DE

  • DPCH Quality Ratio E+ (Default: -3.00 dB): DPCH level after point E.
    GPIB Command: SETup:TOOSynch:RATio:E

  • Measurement Timeout (Default: Off)

Out-of-Synch Handling of Output Power (OOS) Measurement Results

The Out-of-Synch Handling of Output Power measurement does not return any measurement results at this time. Initiating the measurement only causes the test set to change its DPCH level as specified by the Out-of-Synch Handling of Output Power (OOS) Measurement Parameters. You must use an external spectrum analyzer to measure the UE's resulting output power. When the Out-of-Synch Handling of Output Power measurement is initiated from the test set, the test set generates a trigger at point A that you can route to the test set's rear panel TRIG OUT connector using the Trigger Output Setup setting, to trigger the spectrum analyzer.

How Do I Make an Out-of-Synch Handling of Output Power (OOS) Measurement?

The following procedure performs the 3GPP TS34.122 5.4.5 Out-of-synchronisation handling of output power for continuous transmission (for 1,28 Mcps TDD Option), as an example.

Connect the Test Set, Spectrum Analyzer and UE

  1. Connect the UE to the test set's RF IN/OUT port and to the spectrum analyzer's RF INPUT port via an RF splitter.

  2. Connect the test set's rear panel TRIG OUT port to the spectrum analyzer's TRIGGER IN port.

Configure the Spectrum Analyzer

This example uses an Agilent E4440A PSA Series Spectrum Analyzer.

  1. Press the MODE key. Select Spectrum Analysis.

  2. Press the FREQUENCY key. Set Center Freq to the appropriate "mid range" frequency for your UE's operating band, as specified by 3GPP TS 34.108 5.1.2 (for example, for operating band a, 2017.4 MHz).

  3. Press the Amplitude key.

  4. Select More to move to the 1 of 3 menu. Set Ref Level to 52 dBm (or to the appropriate level for your test setup to allow accurate measurement of the UE's power).

  5. Select More to move to the 2 of 3 menu. Set REF Lvl OFFst to the appropriate value for the loss due to the RF splitter.

  6. Press the SPAN key and select Zero Span.

  7. Press the Det/Demod key. Set Detector to Man and choose Normal.

  8. Press the BW/Avg key. Set Res BW to 30 kHz.

  9. Press the Sweep key.

  10. Set Sweep Time to 18 s.

  11. Set Points to 8192. Select Enter.

  12. Press the Trig key and select Ext Rear or Ext Front.

Configure the Test Set

  1. Set the RF IN/OUT Amplitude Offset to the appropriate value for your test setup (press the SYSTEM CONFIG key, then select RF IN/OUT Amptd Offset (F5).

  2. Press the CALL SETUP key.

  3. Set up the required initial parameters:

  4. [F9 in Call Parms 1 of 3] Set the Paging Service Type to RB Test Mode (default);

  5. [F8 in Call Parms 1 of 3] Set the Channel Type to 12.2k RMC SC (default);

  6. [F1 in Call Control 1 of 3] Set the Operating Mode to Active Cell (default);

  7. [F4 in Call Control 3 of 3] Select RB Test Mode Setup, set the UE Loopback Scenario to Type 1, RLC TM (default);

  4. [F10 in Call Parms 1 of 3] Set the Channel to the appropriate "mid range" frequency for your UE's operating band, as specified by 3GPP TS 34.108 5.1.2 (for example, for operating band a, set the Channel to 10087 (default)).

  5. [F4 in Call Control 2 of 3] Set up the UE Timer so that the UE will not drop the call during the measurement. Select UE Timer and Constant Parms, and set as the following:

  6. Set N313 Successive Out-Of-Sync Reception Max to S200.

  7. Set T313 Out-Of-Sync Reception Timer to 15 s.

  8. Set N315 Successive In-Sync Reception Counter to S1.

  6. [F6 in Call Control 2 of 3] Set Trigger Output Setup to Measurement Generated.

  7. Establish a 12.2k RB Test Mode connection between the UE and test set.

  8. [F7 in Call Parms 3 of 3] Set MS DPCH Tgt Pwr to 24 dBm.

  9. [F8 in Call Parms 3 of 3] Select UL CL Power Ctrl Parameters. Set UL CL Power Control Mode to All Up bits.

  10. [F7 in Call Parms 1 of 3] Set Cell Power to -61 dBm.

  11. [F3 in Call Control 2 of 3] Select Generator Info, and set the AWGN Power (F4) to -60 dBm. Select DL Channel Levels (F1), then TD-SCDMA DL Chan Level (F2), and set the DPCH Level to -2.4 dB.

Initiate the Measurement from the Test Set

  1. Press the Measurement selection key and choose Out-of-Synch Handling of Output Power.

  2. Select Out-of-Sync Power Setup and set the parameters as needed. The default values are those specified by 3GPP TS 34.122 5.4.5. Select Close Menu (F6).

  3. Press the START SINGLE key.

View the Measurement Results on the Spectrum Analyzer

A typical result is shown below.

Return Test Set Settings to Their Pre-Measurement Values

If desired, when you have completed the measurement, select End Call (F3) and return the settings to their pre-measurement values.

Related Topics

GPIB Commands: SETup:TOOSynch


Fast Device Tune Measurement

This section is only applicable to the feature-licensed test application.

How Does the Test Set Support the Fast Device Tune Measurement?

  • Fast Device Tune Measurement Overview

  • Configuring the MS TX Frequency/Power Sequence

  • Configuring the MS RX Frequency/Power Sequence

  • Fast Device Tune Measurement Channel Configuration

  • Test Set Operating Considerations

  • Input Signal Requirements

How Do I Use the Fast Device Tune Measurement to Calibrate My MS?

  • Recommended Steps to Perform a Fast Device Tune Measurement

  • Example Frequency and Power Sequence - GPIB

Fast Device Tune Measurement Parameters

Fast Device Tune Measurement Results

How Does the Test Set Support the Fast Device Tune Measurement?

The Fast Device Tune measurement allows you to simultaneously calibrate your mobile station's transmitter (TX) output power and receiver (RX) input level across level and frequency in a single sweep. The measurement is not performed with a call established between the test set and mobile station (MS). Rather, you must place your MS into a test mode which forces it to transmit a predefined sequence of power steps at various frequencies, and forces it to simultaneously tune its receiver to perform measurements of the test set's signal at various frequencies and power levels.

Fast Device Tune Measurement Overview

The figure below shows a general view of the Fast Device Tune measurement. Once the Fast Device Tune measurement is initiated, the test set transmits downlink signals for the MS to do the synchronization (The power and frequency at which the test set transmits is respectively the first one in the MS RX frequency and power sequence). When the synchronization is set up, the real measurement (calibration sequence) is triggered by an output power from the MS (The MS must trigger the measurement with a power of at least 40dB above the Cell Power, see Input Signal Requirements). For the MS Rx calibration, the test set generates downlink signals at the specified power and frequency sequence, with a 5 ms re-tune time to switch to a new frequency and power; For the MS Tx calibration, the test set perform power measurements according to the specified power and frequency sequence, with a 10 ms re-tune time to switch to a new frequency.

Fast Device Tune Measurement General View

Before initiating the measurement, you must specify the power sequence that the MS will transmit (MS TX Power Sequence), and the frequencies at which the MS will transmit the power sequence (MS TX Frequency Sequence). You must also specify the power sequence you want the test set to transmit (MS RX Power Sequence), and the frequencies at which you want the test set to transmit the power sequence (MS RX Frequency Sequence). See Configuring the MS TX Frequency/Power Sequence and Configuring the MS RX Frequency/Power Sequence.

Configuring the MS TX Frequency/Power Sequence

The first step in the MS Tx sequence must be at least 40dB above the Cell Power to trigger the Fast Device Tune measurement.

The test set can measure a total of 400 power points in one measurement cycle (this means you must set Number of MS TX Power Steps and Number of MS TX Frequency Steps so that the product of the two is not more than 400). However, the measurement allows you to enter up to 40 MS TX Power Step Levels and 40 MS TX Frequency Step Values (indexed from 0 to 39, frequencies across bands are permitted). You must then use the MS TX Power Step Start Index and Number of MS TX Power Steps settings to specify which power steps comprise the MS TX Power Sequence, and the MS TX Frequency Step Start Index and Number of MS TX Frequency Steps settings to specify which frequency steps comprise the MS TX Frequency Sequence. See Example Frequency and Power Sequence - GPIB for an example illustrating how to utilize this flexibility.

The test set uses the values in the MS TX Power Sequence and the MS TX Frequency Sequence to build the MS TX Frequency/Power Sequence, which drives how the test set's receiver is tuned throughout the measurement cycle. To build the MS TX Frequency/Power Sequence, the test set simply repeats the MS TX Power Sequence at each of the frequencies in the MS TX Frequency Sequence, and inserts a frequency re-tune step (10 ms) in between each repetition of the power sequence (to allow the test set and MS to re-tune to the new frequency; no measurements are performed by the test set during the frequency re-tune steps).

Before initiating the measurement, you must ensure that your MS is set to transmit the MS TX Frequency/Power Sequence you've set in the test set, including the frequency re-tune steps.

Configuring the MS RX Frequency/Power Sequence

While the test set is measuring the MS TX Power Sequence, it also transmits a MS RX Power Sequence for the MS to measure.

The test set transmits its MS RX Power Sequence at each of the frequencies in the MS RX Frequency Sequence. The MS RX Frequency Sequence may include up to 40 frequencies.

As with the MS TX Frequency/Power sequence, the test set can transmit a total of 400 power points in one measurement cycle (this means you must set Number of MS RX Power Steps and Number of MS RX Frequency Steps so that the product of the two is not more than 400), but the measurement allows you to enter up to 40 MS RX Power Step Levels and 40 MS RX Frequency Step Values (indexed from 0 to 39). You must use the MS RX Power Step Start Index and Number of MS RX Power Steps settings to specify which power steps comprise the MS RX Power Sequence, and the MS RX Frequency Step Start Index and Number of MS RX Frequency Steps settings to specify which frequency steps comprise the MS RX Frequency Sequence. See Example Frequency and Power Sequence - GPIB for an example illustrating how to utilize this flexibility.

The test set uses the values in the MS RX Power Sequence and the MS RX Frequency Sequence to build the MS RX Frequency/Power Sequence, which drives how the test set's generator is tuned throughout the measurement cycle. To build the MS RX Frequency/Power Sequence, the test set simply repeats the MS RX Power Sequence at each of the frequencies in the MS RX Frequency Sequence, and inserts a frequency re-tune step (5 ms) in between each repetition of the power sequence. Furthermore, in the MS RX Power Sequence, each Rx power level is allowed to be repeated for MS RX Power Step Length times before switching to the next power level (See Fast Device Tune Measurement General View). A power re-tune step (5ms) is also inserted between the different power levels. The re-tune time is used to allow the test set and MS to move to the new frequency or power; the MS should not perform any measurements on the test set's signal during this time.

Before initiating the measurement, you must ensure that your MS is set to measure the MS RX Frequency/Power Sequence you've set in the test set, and that its tuning profile includes the frequency re-tune steps.

Fast Device Tune Measurement Channel Configuration

For the Fast Device Tune measurement, the downlink channel configurations are fixed in the test set, see Fast Device Tune Downlink Channel Configuration (Fixed). The Midamble configuration is fixed to 8 and the midamble shift is fixed to 1.

Fast Device Tune Downlink Channel Configuration (Fixed)

 | DwPCH | P-CCPCH | PICH | FDT Channel
Time Slot | DwPTS | 0 | 0 | TS2 - TS6
Channelization Codes | - | 16_1, 16_2 | 16_5 to 16_6 | 16_1 to 16_2

Test Set Operating Considerations

  • The Fast Device Tune measurement is only applicable when the Operating Mode is TD-SCDMA Test.

  • The Fast Device Tune measurement can NOT be initiated when the AWGN is ON.

  • The Fast Device Tune measurement can not be concurrent with other measurements. Hence starting the Fast Device Tune measurement will turn off any other measurement that is active, and vice versa.

  • During the Fast Device Tune measurement, the transmitter and receiver of the test set are exclusively controlled by this measurement. In this case, you are not allowed to set the following power and frequency parameters when the FDT measurement is running: Downlink Channel Level, Cell Power, Channel, RF Gen Freq Ctrl, MS DPCH Tgt Pwr, UL CL Power Control and Receiver Control.

  • The Fast Device Tune measurement must re-range and re-trigger for every step in the MS TX Power Sequence. To ensure that this process is not interrupted by other operations, it is recommended that you not send any GPIB commands to the test set or press any front panel keys until the measurement has completed. If the measurement misses a trigger, it aborts and returns Integrity Indicator 30 : Missed Trigger.

Input Signal Requirements

To perform the Fast Device Tune measurement, you MS is expected to transmit on time slot 1 only. Besides, you must configure your MS to range, transmit and receive on a pre-defined Tx and Rx power/frequency sequence, which are exactly the same with what are configured on the test set. See Fast Device Tune Measurement Parameters.

The MS must trigger the measurement with a power of at least 40dB above the Cell Power (the downlink TS0).

To meet performance specifications, the input signal must meet the following requirements:

  • The power of each step is expected to be within 9 dB of the power defined in the MS Tx power list.

  • Input signal level into the test set's RF IN/OUT connector is between -55 dBm and +28 dBm, in a 1.28 MHz bandwidth

  • The frequency of the measured signal should be within 20KHz from the frequency defined the MS Tx frequency list

How Do I Use the Fast Device Tune Measurement to Calibrate My MS?

Recommended Steps to Perform a Fast Device Tune Measurement

Before Fast Device Tune measurement, make sure your MS's transmission meet the Input Signal Requirements.

  1. Set the test set's initial conditions (Operating Mode etc. See Test Set Operating Considerations), and set up the MS TX and RX Frequency/Power sequence to match your MS's configuration (see Configuring the MS TX Frequency/Power Sequence and Configuring the MS RX Frequency/Power Sequence).

  2. Verify that your MS is in the proper test mode and is configured to match the MS TX/RX Frequency Power series you've specified in the test set. Moreover, before initiating the Fast Device Tune measurement, it's strongly recommended you turn off your MS's transmitter. This is to avoid an unexpected trigger to start the measurement wrongly.

  3. Initiate the Fast Device Tune measurement (this prepares the test set's hardware to execute the frequency/power sequence you've specified and arms the measurement's RF rise trigger). See INITiate:<measurement mnemonic>[:ON] for the GPIB command.

  4. Prepare your MS to receive the downlink signal (on TS0 and DwPTS) at the first frequency and power of the MS RX frequency/power sequence, to synchronize with the test set.

  5. Send the INITiate:TFDTune:ARMed? query and wait for it to return a value of 1, indicating that the measurement is armed and ready to be triggered (or wait ~2 seconds if running the measurement from the front panel).

  6. Order the MS to begin transmission of its MS TX Frequency/Power Sequence. The MS should then transmit its first step power at least 40dB above the Cell Power to trigger the measurement with an RF Rise.

  7. When the measurements is finished, retrive the MS Tx power results from the test set (see FETCh:TFDTune), and MS Rx power results from the MS.

Example Frequency and Power Sequence - GPIB

The test set can measure/transmit 400 power points in one measurement cycle. However, you can enter up to 40 power values and 40 frequencies for both the MS TX and MS RX sequences. This flexibility is present to make it more efficient for you to test different power sequences over different sets of frequencies. You must load in the superset of power levels and frequency values once. Then for each measurement cycle, you simply change the start index and number of steps as needed and initiate the measurement.

The following section gives an example on how to set the frequency and power sequence, in GPIB commands.

//Set up the MS Tx power sequence. The MS TX Power Step Start Index = 19 and the Number of MS TX Power Steps = 10. The Tx Power points are (in dBm): 12.5, 7.5, 2.5, -2.5, -7.5, -12.5, -17.5, -22.5, -27.5, -32.5

SETup:TFDTune:MS:TX:POWer:STEP:LEVels 24.0, 21.0, 15.0, 5.0, -5.0, -15.0, -25.0, -35.0, -45.0, -55.0, -50.0, -40.0, -30.0, -20.0, -10.0, 0.0, 10.0, 20.0, 17.5, 12.5, 7.5, 2.5, -2.5, -7.5, -12.5, -17.5, -22.5, -27.5, -32.5, -37.5, -42.5, -47.5, -52.5, -49.0, -39.0, -29.0, -19.0, -9.0, 1.0, 11.0

SETup:TFDTune:MS:TX:POWer:STEP:STARt:INDex 19

SETup:TFDTune:MS:TX:POWer:STEP:COUNt 10

//Set up the MS Tx frequency sequence. The MS TX Frequency Step Start Index = 0 and the Number of MS TX Frequency Steps = 40.

SETup:TFDTune:MS:TX:FREQuency:STEP:VALues 1880.8MHz, 1900.0MHz, 1919.2MHz, 2010.8MHz, 2024.2MHz, 2023.8MHz, 2022.2MHz, 2020.6MHz, 2019MHz, 2017.4MHz, 2015.8MHz, 2014.2MHz, 2012.6MHz, 2011MHz, 1919.2MHz, 1917.6MHz, 1916MHz, 1914.4MHz, 1912.8MHz, 1911.2MHz, 1909.6MHz, 1908MHz, 1906.4MHz, 1904.8MHz, 1903.2MHz, 1901.6MHz, 1900MHz, 1898.4MHz, 1896.8MHz, 1895.2MHz, 1893.6MHz, 1892MHz, 1890.4MHz, 1888.8MHz, 1887.2MHz, 1885.6MHz, 1884MHz, 1882.4MHz, 1880.8MHz, 2017.4MHz

SETup:TFDTune:MS:TX:FREQuency:STEP:STARt:INDex 0

SETup:TFDTune:MS:TX:FREQuency:STEP:COUNt 40

//Set up the MS Rx power sequence. The MS RX Power Step Length = 1, MS RX Power Step Start Index = 0 and the Number of MS RX Power Steps = 1.

SETup:TFDTune:MS:RX:POWer:STEP:LEVels -105.0, -95.0, -85.0, -75.0, -65.0, -55.0, -45.0, -35.0, -25.0, -15.0, -20.0, -30.0, -40.0, -50.0, -60.0, -70.0, -80.0, -90.0, -100.0, -97.5, -92.5, -87.5, -82.5, -77.5, -72.5, -67.5, -62.5, -57.5, -52.5, -47.5, -42.5, -37.5, -32.5, -27.5, -22.5, -17.5, -19.0, -29.0, -39.0, -49.0

SETup:TFDTune:MS:RX:POWer:STEP:LENGth 1

SETup:TFDTune:MS:RX:POWer:STEP:STARt:INDex 0

SETup:TFDTune:MS:RX:POWer:STEP:COUNt 1

//Set up the MS Rx frequency sequence. The MS RX Frequency Step Start Index = 0 and the Number of MS RX Frequency Steps = 10.

SETup:TFDTune:MS:RX:FREQuency:STEP:VALues 1880.8MHz, 1900.0MHz, 1919.2MHz, 2010.8MHz, 2024.2MHz, 2023.8MHz, 2022.2MHz, 2020.6MHz, 2019MHz, 2017.4MHz, 2015.8MHz, 2014.2MHz, 2012.6MHz, 2011MHz, 1919.2MHz, 1917.6MHz, 1916MHz, 1914.4MHz, 1912.8MHz, 1911.2MHz, 1909.6MHz, 1908MHz, 1906.4MHz, 1904.8MHz, 1903.2MHz, 1901.6MHz, 1900MHz, 1898.4MHz, 1896.8MHz, 1895.2MHz, 1893.6MHz, 1892MHz, 1890.4MHz, 1888.8MHz, 1887.2MHz, 1885.6MHz, 1884MHz, 1882.4MHz, 1880.8MHz, 2017.4MHz

SETup:TFDTune:MS:RX:FREQuency:STEP:STARt:INDex 0

SETup:TFDTune:MS:RX:FREQuency:STEP:COUNt 10

Fast Device Tune Measurement Parameters

The values in the brackets are default values.

Fast Device Tune Setup

  • Measurement Timeout (Off): see Measurement Timeout.

  • MS TX Power Step Start Index (0): Indicates which of the MS TX Power Step Levels is the first step in the MS TX Power Sequence.

This parameter can be set to any integer value between 0 and 39. However, MS TX Power Step Start Index + Number of TX Power Steps must not exceed 40.

GPIB Command: SETup:TFDTune:MS:TX:POWer:STEP:STARt[:INDex]

  • MS TX Frequency Step Start Index (0): Indicates which of the MS TX Frequency Step Values is the first frequency in the MS TX Frequency Sequence.

This parameter can be set to any integer value between 0 and 39. However, MS TX Frequency Step Start Index + Number of TX Frequency Steps must not exceed 40.

GPIB Command: SETup:TFDTune:MS:TX:FREQuency:STEP:STARt[:INDex]

  • MS RX Power Step Start Index (0): Indicates which of the MS RX Power Step Levels is the first step in the MS RX Power Sequence.

This parameter can be set to any integer value between 0 and 39. However, MS RX Power Step Start Index + Number of RX Power Steps must not exceed 40.

GPIB command: SETup:TFDTune:MS:RX:POWer:STEP:STARt[:INDex]

  • MS RX Frequency Step Start Index (0): Indicates which of the MS RX Frequency Step Values is the first frequency in the MS RX Frequency Sequence.

This parameter can be set to any integer value between 0 and 39. However, MS RX Frequency Step Start Index + Number of RX Frequency Steps must not exceed 40.

GPIB command: SETup:TFDTune:MS:RX:FREQuency:STEP:STARt[:INDex]

  • Number of MS TX Power Steps (10):

Indicates how many (consecutive) MS TX Power Step Levels are used for the MS TX Power Sequence.

This parameter can be set to any integer value between 1 and 40, but MS TX Power Step Start Index + Number of TX Power Steps must not exceed 40.

GPIB command: SETup:TFDTune:MS:TX:POWer:STEP:COUNt

  • Number of MS TX Frequency Steps (5):

Indicates how many (consecutive) MS TX Frequency Step Values are used for the MS TX Frequency Sequence.

This parameter can be set to any integer value between 1 and 40, but MS TX Frequency Step Start Index + Number of MS TX Frequency Steps must not exceed 40.

GPIB command: SETup:TFDTune:MS:TX:FREQuency:STEP:COUNt

  • Number of MS RX Power Steps (10):

Indicates how many (consecutive) MS RX Power Step Levels are used for the MS RX Power Sequence.

This parameter can be set to any integer value between 1 and 40, but MS RX Power Step Start Index + Number of TX Power Steps must not exceed 40.

GPIB command: SETup:TFDTune:MS:RX:POWer:STEP:COUNt

  • Number of MS RX Frequency Steps (5):

Indicates how many (consecutive) MS RX Frequency Step Values are used for the MS RX Frequency Sequence.

This parameter can be set to any integer value between 1 and 40, but MS RX Frequency Step Start Index + Number of MS RX Frequency Steps must not exceed 40.

GPIB command: SETup:TFDTune:MS:RX:FREQuency:STEP:COUNt

  • MS RX Power Step Length (1):

Indicates how many (consecutive) subframes for each MS RX power step.

GPIB command: SETup:TFDTune:MS:RX:POWer:STEP:LENGth

Fast Device Tune MS TX/RX Parms

  • MS TX Power Step Levels

You can specify up to 40 mobile station output power levels (indexed from 0 up to 39). You must use the MS TX Power Step Start Index and Number of MS TX Power Steps settings to specify which of these (consecutive) power levels are used for the MS TX Power Sequence.

Although you can enter any power levels between -120 and +80 dBm when running the Fast Device Tune measurement, you can only measure power levels in the range of -70 to +30 dBm and the measurement is only specified for power levels in the range of -55 to +28 dBm (these ranges assume an amplitude offset of 0; the ranges change as you change amplitude offsets, see Amplitude Offset).

GPIB command: SETup:TFDTune:MS:TX:POWer:STEP[:LEVels]

  • MS TX Frequency Step Values

You can specify up to 40 mobile station uplink frequencies (indexed from 0 up to 39). You must use the MS TX Frequency Step Start Index and Number of MS TX Frequency Steps settings to specify which of these (consecutive) frequencies are used for the MS TX Frequency Sequence.

You can test frequencies within the following two TD-SCDMA frequency bands:

  • a: 2010 – 2025 (MHz): 10054 – 10121 (UARFCN)

  • f: 1880 – 1920 (MHz): 9404 – 9596 (UARFCN)

GPIB command: SETup:TFDTune:MS:TX:FREQuency:STEP[:VALues]

  • MS RX Power Step Levels

You can specify up to 40 test set output power levels (indexed from 0 up to 39). You must use the MS RX Power Step Start Index and Number of MS RX Power Steps settings to specify which of these (consecutive) power levels are used for the MS RX Power Sequence.

Although you can enter any power levels between -165 and 37 dBm when running the Fast Device Tune measurement, the test set can only transmit test power levels in the range of -115 to -13 dBm ( RF IN/OUT ) or -115 to -5 dBm ( RF OUT ONLY ). These ranges assume an amplitude offset of 0; the allowable ranges change as you change amplitude offsets, see Cell Power, AWGN Power and Total RF Power Ranges.

GPIB command: SETup:TFDTune:MS:RX:POWer:STEP[:LEVels]

  • MS RX Frequency Step Values

You can specify up to 40 downlink frequencies (indexed from 0 up to 39). You must use the MS RX Frequency Step Start Index and Number of MS RX Frequency Steps settings to specify which of these (consecutive) frequencies are used for the MS RX Frequency Sequence.

GPIB command: SETup:TFDTune:MS:RX:FREQuency:STEP[:VALues]

Fast Device Tune Measurement Results

  • Integrity Indicator

  • MS TX Power

Power (in dBm) is returned for each step in the MS TX Frequency/Power Sequence (except for the frequency re-tune steps). The total number of results returned by the measurement is always 400 (Number of MS TX Power Steps x Number of MS TX Frequency Steps power result values are returned, followed by 9.91E+37 (NAN) for all remaining values up to 400). The power results for the first frequency in the MS TX Frequency Sequence are returned first, then the power results for the second frequency in the MS TX Frequency Sequence, etc., followed by NANs if fewer than 400 points were measured.

An graphic display of Fast Device Tune measurement results is shown as below, based on the MS Tx power and frequency sequence defined in Example Frequency and Power Sequence - GPIB.

Related Topics

GPIB Commands: SETup:TFDTune, FETCh:TFDTune


Reporting of Channel Quality Indicator Measurement

Last updated: March 10, 2010

Reporting of Channel Quality Indicator (CQI) Measurement Description

Reporting of Channel Quality Indicator (CQI) Measurement Parameters

Reporting of Channel Quality Indicator (CQI) Measurement Results

How Do I Make a Reporting of Channel Quality Indicator (CQI) Measurement?

Reporting of Channel Quality Indicator (CQI) Measurement Description

3GPP TS 34.122 9.3.3 states "The reporting accuracy of channel quality indicator (CQI) under AWGN environments is determined by the reporting variance and the BLER performance using the transport format indicated by the reported CQI median."

The Reporting of Channel Quality Indicator measurement consists of two main parts, which run in sequential order:

  • Part 1: CQI Variance Test

The test set starts the HSDPA block transmission with a fixed TBS value. The test set then decodes the CQI reports from the UE and transmits new blocks with the transport block size and modulation scheme recommended by the UE (the test set works at the VRC mode, see HS-DSCH Config). The HSDPA block transmission and UE CQI recording continues until the Number of CQI Reports to test is gathered. The test set calculates the Median CQI that meets the requirement of 50% distribution from the lower RTBS side (see more in 3GPP TS 34.122 s9.3.3). If at least Number of CQI Reports to test *Percentage of CQI values within range are within the required range, the measurement continues with Part 2, otherwise the entire test fails.

  • Part 2: BLER at Median CQI

The test set transmits the TBS according to the median-CQI value derived in Part 1 until the Number transmitted at Median CQI to test is gathered. The test set then calculates the Block Error Ratio (BLER) by ( NACK + statDTX) / (ACK + NACK + statDTX).

The HSDPA Reporting of Channel Quality Indicator measurement is only allowed to be run in the following conditions:

  • Operating Mode is Active Cell;

  • Paging Service Type is RB Test Mode;

  • Channel Type is 12.2k RMC + HSDPA.

The HSDPA Reporting of Channel Quality Indicator measurement can not be performed in concurrence with the HSDPA Block Error Ratio (HBLER) measurement.

Reporting of Channel Quality Indicator (CQI) Measurement Parameters

  • Number of CQI Reports to test

Sets the number of CQI reports to be gathered for the CQI Variance Test (Part 1 of the Reporting of Channel Quality Indicator measurement).

GPIB Command: SETup:THCQuality:CQIReports[:COUNt]

  • Percentage of CQI values within range

Sets the percentage of values that must be in the range (Median_CQI-x) to (Median_CQI+x) used during CQI Variance Test (Part 1 of the Reporting of Channel Quality Indicator measurement), where x refers to the Permitted CQI range from median.

GPIB Command: SETup:THCQuality:CQIValues:WRANge

  • Number transmitted at Median_CQI to test

Sets the number of CQI reports to be gathered for the BLER at Median CQI test (Part 2 of the Reporting of Channel Quality Indicator measurement).

GPIB Command: SETup:THCQuality:TRANsmit:MCQI[:COUNt]

  • Permitted CQI range from median

Sets the x parameter as defined in the standard. The pass condition for the CQI Variance Test (Part 1) is: the CQI indicators of at least Number of CQI Reports to test *Percentage of CQI values within range are in the range (Median CQI - x) ≤ Median CQI ≤ (Median CQI + x).

GPIB Command: SETup:THCQuality:RANGe:FMEDian

  • BLER criteria for transmitted at Median_CQI

Sets the maximum allowed BLER for median reported CQI (Part 2 of the Reporting of Channel Quality Indicator measurement). The pass condition for the Part 2 is: the BLER at Median CQI is less than this value.

GPIB Command: SETup:THCQuality:BLERatio:TRANsmit:MCQI

  • Measurement Timeout: see Measurement Timeout.

Reporting of Channel Quality Indicator (CQI) Measurement Results

Part 1: CQI Variance Results.

  • Median_CQI

This is the Median CQI value as specified by 3GPP TS 34.122 9.3.3.

GPIB Command: FETCh:THCQuality:CQINdicator:MEDian?

  • CQI in Range (%)

This result is the percentage of CQI values reported from the UE that are in the range of Median_CQI-x to Median_CQI+x, where x refers to the Permitted CQI range from median.

GPIB Command: FETCh:THCQuality:CQIReports:WRANge?

  • Reports at Median_CQI±0/1/2/3

This results reflects how many reports are gathered at Median_CQI, Median_CQI±1, Median_CQI±2, and Median_CQI±3, respectively. The CQI report distribution generated by the test set during the CQI Variance Test (Part 1) can be obtained using the GPIB query: FETCh:THCQuality:CQIReports:DISTribution?

GPIB Command: FETCh:THCQuality:CQIReports:CQIMinus1|2|3?, FETCh:THCQuality:CQIReports:CQIPlus0? and FETCh:THCQuality:CQIReports:CQIPlus1|2|3?

Part 2: Block Error Ratio (BLER) at Median CQI

  • BLER at Median CQI

This is the Block error rate when the test set transmits blocks at Median CQI value (part 2). The overall block number transmitted at Median CQI is Number transmitted at Median CQI to test.

GPIB Command: FETCh:THCQuality:BLERatio:TRANsmit?

  • Blocks Tested

Indicates how many blocks are tested at the moment for the entire measurement.

GPIB Command: FETCh:THCQuality:BLOCks?

How Do I Make a Reporting of Channel Quality Indicator (CQI) Measurement?

The following procedure performs the 3GPP TS34.122 9.3.3E Reporting of HS-DSCH Channel Quality Indicator-2.8Mbps UE class, Test 1, as an example.

Note: For TS34.122 9.3.3E, the standard also requires the multipath fading simulator and external AWGN,, which is not included in this procedure.

Initial conditions

  1. Ensure that the test set has been properly calibrated (see Calibrating the Test Set).

  2. Connect the UE to the front panel RF IN/OUT port.

  3. Set call parameters as following:

  4. [F7 in Call Parms 1 of 3] Set the Cell Power to -63 dBm (default value).

  5. [F8/F9 in Call Parms 1 of 3] Set the Paging Service to RB Test Mode, and Channel Type to 12.2k + HSDPA.

  6. [F11 in Call Parms 1 of 3] Set the HSDPA parameters.

  • [F7 in HSDPA Parms] Set HS-DSCH Config to VRC, leave other HSDPA RB Test Mode settings as default.

  • [F8 in HSDPA Parms] Set Number of Transmissions to 1, leave other MAC-hs Parameters as default.

  • Leave other HSDPA Parameters as default.

  • [F2 in Call Control 2 of 3] In Cell Parameters, set the PS Domain Information to Present.

  • Power the UE on and wait for it to be registered.

  • [F3 in Call Control 1 of 3] Press Originate Call. Wait for the Active Cell area to be Connected.

  • The test set will automatically configure the channels according to the UE Reported HS-DSCH Category. For example, UE Reported HS-DSCH Category of 15 indicates 2.8 M UE class (9.3.3E Reporting of HS-DSCH Channel Quality Indicator-2.8Mbps UE class), and the test set will automatically configure the downlink channels by 3GPP TS 34.122 Table 9.3.3E.1 as below (The following parameters are set independently in other steps: Number of HARQ Process, Number of Transmission and Îor/Ioc).

Procedure

  1. Press the Measurement selection key.

  2. Select Reporting of Channel Quality Indicator.

  3. Select HSDPA Reporting of CQI Setup (F1). Configure the setup parameters as shown in the figure below (the default settings are in accordance with 3GPP TS 34.122 9.3.3E):

  4. Press the START SINGLE key.

  5. Verify that the overall test result is Pass.

Per 3GPP TS34.122 9.3.3E, the minimum requirement for this test case is as below:

Related Topics

GPIB Commands: SETup:THCQuality, FETCh:THCQuality


Spectrum Monitor

Spectrum Monitor (SMON) Description

  • Detection Method

  • Resolution Bandwidth and Frequency Span

  • Single or Multi-Measurements

  • Trigger Source

How Do I Use the Spectrum Monitor?

Spectrum Monitor (SMON) Description

The Spectrum Monitor (SMON) can be used to locate, identify and measure transmitted signals from a device under test. The Spectrum Monitor can be used while a call is in progress.

The Spectrum Monitor is intended to be used for indication only. The Spectrum Monitor does not have the same level accuracy specifications as other measurements provided by the test set, and should therefore not be used when parametric accuracy is required (for example, calibration of a mobile). It is recommended that you use the other wireless format-specific measurements when you require accurate parametric measurements.

From the test set's front panel, the Spectrum Monitor can be accessed by pressing the Instrument Selection key, then selecting Spectrum Monitor . If you require more details on manual operation of the Spectrum Monitor, see How Do I Use the Spectrum Monitor? .

The Spectrum Monitor has the following two modes of operation:

  • Swept mode, in which the X axis represents frequency , and the Y axis represents absolute amplitude.

  • Zero span mode, in which the X axis represents time and the Y axis represents absolute amplitude.

You can use the markers on the Spectrum Monitor's graphical display to set the expected frequency and power levels that are used by the test or lab application for parametric measurements.

The center frequency used by the Spectrum Monitor is initially set at the expected frequency maintained by the test set's base station emulator. The expected frequency range is 292.5 MHz to 2700 MHz.

The range of frequencies which the spectrum monitor is calibrated to measure is determined by the range of traffic band frequencies supported by the specific test or lab application that is currently running. For example, if you are using the GSM Test Application, any of the frequencies used by the GSM traffic bands are available for you to monitor accurately. You can view signals which fall outside of any of the frequencies used by GSM, but the Spectrum Monitor will not be calibrated.

Detection Method

Frequency binning is used when the Spectrum Monitor divides the frequency span by the number of display points such that each bin contains a segment of the frequency span. Within each frequency bin, a single value representing each frequency bin is displayed on the test set's screen. The algorithm used to find the value that represents each frequency bin is determined by the detection method. There are three detection methods available in the test set's Spectrum Monitor:

  • Peak Detection

The largest spectral component in the frequency bin is used to represent each bin.

  • Sample Detection

The last spectral component in the frequency bin is used to represent each bin.

  • RMS Detection

The sum of the power across the frequency bin is used to represent each bin.

Resolution Bandwidth and Frequency Span

The resolution bandwidth can be used to resolve two or more closely spaced signals as long as the resolution bandwidth is less than the difference between the spectral components. A resolution bandwidth greater than or equal to the signal bandwidth can be used to measure the total power of a signal.

Refer to Frequency Span, Resolution Bandwidth and Dynamic Range below. When the Resolution Bandwidth Coupling State is OFF, the Frequency Span and the Resolution Bandwidth can be set to any value in their respective columns, and Resolution Bandwidth setting determines the Displayed Dynamic Range. When the Resolution Bandwidth Coupling State is On, the Resolution Bandwidth and Displayed Dynamic Range settings are coupled with the Frequency Span setting. For example, if the Frequency Span is 100 MHz, the test set automatically sets the Resolution Bandwidth to 5 MHz and the Displayed Dynamic Range to 55 dB.

Frequency Span, Resolution Bandwidth and Dynamic Range

Frequency Span | Resolution Bandwidth | Displayed Dynamic Range
100 MHz | 5 MHz | 50 dB
80 MHz | 1 MHz | 55 dB
40 MHz | 300 kHz | 60 dB
20 MHz | 100 kHz | 65 dB
12 MHz | 100 kHz | 65 dB
10 MHz | 100 kHz | 65 dB
5 MHz | 30 kHz | 70dB
4 MHz | 30 kHz | 70 dB
2.5 MHz | 10 kHz | 75 dB
1.25 MHz | 3 kHz | 80 dB
500 kHz | 1 kHz | 80 dB
125 kHz | 300 Hz | 80 dB
0 Hz (zero span mode) | 100 kHz | 65 dB
 | 300 kHz | 60 dB
 | 1 MHz | 55 dB

Single or Multi-Measurements

The Spectrum Monitor can return either single or averaged results.

  • If you set the averaging state OFF then the trace represents a single measurement sweep.

  • If you set the averaging state ON, and the averaging count number to a value greater than one, then the trace represents the rolling average of the specified number of sweeps.

Input Signal Requirements

The Spectrum Monitor will complete and meet its accuracy specifications under the following input signal conditions.

  • The signal is within 40 dB of the reference level.

  • The measurement frequency is within the traffic band frequencies supported by the specific lab or test application that is currently running, and the expected frequency is tuned to the carrier.

Trigger Source

Triggering choices available for the Spectrum Monitor are Immediate, Protocol, RF Rise, and External. For a detailed description of the trigger source, see Trigger Source

How Do I Use the Spectrum Monitor?

The following procedure shows a typical usage of the spectrum monitor in each of its two modes of operation; Swept Mode and Zero Span mode.

  1. Establish a call with the mobile.

  2. Press the Instrument selection key.

  3. Select Spectrum Monitor.

The spectrum monitor is displayed with the default settings as shown above. The center frequency is initially set at the expected frequency maintained by the test set's base station emulator. The Swap Window Positions ( F5 ) key is only displayed when other measurements are active at the same time as the spectrum monitor.

  4. Set the axis control as needed for your testing situation using the Frequency Span ( F1 ), Reference ( F2 ), and dB/div ( F3 ) keys. See Frequency Span, Resolution Bandwidth and Dynamic Range for the valid Frequency Span entries. To set the reference level manually ( Auto is the default), press the Reference ( F2) key then use the DATA ENTRY keys to enter the value you want.

  5. Press the Trigger Setup ( F4 ) key to access the Trigger Setup menu.

  6. Set the trigger settings to meet your testing needs. For example:

  7. If you want the Spectrum Monitor to sweep immediately and continuously, ensure that Trigger Arm ( F3 ) is set to Continuous .

  8. If you want to use external triggering, so that the Spectrum Monitor is triggered from a signal applied to the TRIG IN connector on the test set's rear panel, set Trigger Source ( F1 ) to External .

  9. Trigger Delay ( F2 ) allows you to specify the point, relative to the trigger event where samples are taken (a negative trigger delay value collects pre-trigger samples). The same trigger delay setting is used for swept mode and zero span mode.

  10. Res Bw allows you to set the resolution bandwidth. If you want the resolution bandwidth coupled with the with the Frequency Span , set this field to AUTO by pressing the gray DATA ENTRY softkey labeled ON , otherwise use the knob or the numeric DATA ENTRY soft keys to set the resolution bandwidth. See Frequency Span, Resolution Bandwidth and Dynamic Range to find the valid entries for the resolution bandwidth while in swept mode. Note that changing the resolution bandwidth does not modify the zero span resolution bandwidth setting.

  7. Press the Return ( F6 ) key to exit the Trigger Setup menu.

  8. Press the Display ( F6 ) key to access the display settings.

A typical spectrum monitor trace display is shown above. In this case, the Display menu is open allowing you to access all of the display control settings using the ( F1 ) through ( F12 ) keys.

The following list provides examples of some of the settings you may want to adjust:

  • Detection Method ( F2 ) determines the algorithm used to find the value that represents each frequency bin. See Detection Method for more information.

  • Peak Threshold ( F4 ) and Peak Excursion ( F5 ) set the peak threshold and peak excursion levels respectively. A peak is identified by using the peak threshold and peak excursion value. A point is only marked as a peak if it rises and falls more than the peak excursion value from the peak threshold value.

  • Marker Mode ( F8 ) sets the mode of the active marker. Position mode activates a single frequency marker. Delta mode freezes the active marker at its current location and uses it as a reference marker. A second marker is created at the position of the reference marker and is used as a delta marker, reporting any change in amplitude or frequency from that of the reference marker.

  • Peak Search ( F10 ) moves the active marker to the highest peak on the spectrum monitor display, returning the numeric amplitude and frequency values.

  • Marker -> Expected Freq ( F11 ) sets the base station emulator's expected frequency to the frequency of the active marker.

  • Marker -> Expected Power ( F12 ) sets the base station emulator's expected power level to the amplitude of the active marker.

A typical swept mode spectrum monitor display is shown above. In this case, the active marker is marker 1, which is set to Delta mode.

  9. Press the Return ( F6 ) key to exit the Display menu.

  10. To set the spectrum monitor to zero span mode, press the Frequency Span ( F1 ) key and use the numeric DATA ENTRY keys to enter a value of 0 MHz , or use the down-arrow key to reduce the span to zero.

A typical zero span mode spectrum monitor display is shown above. Like swept mode, the Y-axis represents absolute amplitude. However, the X-axis now represents time rather than frequency.

  11. Press the Trigger Setup ( F6 ) key. In zero span mode, additional trigger setup controls are available to you:

  12. If you want to change the view window over which you are looking at the signal, use the Time Span ( F8 ) and Time Offset ( F9 ) keys. The measurement is made for the duration of the time span, beginning at the time defined by the trigger event plus the trigger delay plus the time offset.

  13. If you want to change the resolution bandwidth, press the Zero Span RBW ( F7 ) key and select a value. (To measure the total power of a signal you must select a resolution bandwidth greater than or equal to the signal bandwidth.) See Frequency Span, Resolution Bandwidth and Dynamic Range to find the valid entries for the resolution bandwidth while in zero span mode. Note that changing the zero span resolution bandwidth does not modify the swept mode resolution bandwidth.

A typical zero span mode spectrum monitor display showing a bursted signal. The viewing window has been adjusted to zoom in on a single burst.

If the temperature of the test set drifts outside the calibrated temperature range of the spectrum monitor, a Measurement Uncalibrated message is displayed. To calibrate the spectrum monitor for the current temperature, press the Calibrate Measurement ( F11 ) key on the Trigger Setup menu.


Data Throughput Monitor

Description

The Data Throughput Monitor can analyze data transfer rates under various RF and call processing conditions. You can initiate the Data Throughput Monitor by pressing the Instrument selection key. It is displayed on the Measurement/Instrument screen (accessible using the MEASUREMENT key).

Data throughput is the rate of data transfer to and from a wireless device.

This feature does not attempt to monitor application layer data throughput (FTP, HTTP, TELNET, etc.)

Two sets of statistics are available from the Data Throughput Monitor:

  • OTA Rx and OTA Tx

OTA (Over the Air) throughput counts the data transmitted and received by the test set's protocol stack. The location of the measurement point in the protocol stack is dependent upon system type; this data could be a byte stream from RLP (Radio Link Protocol) or RLC (Radio Link Control) or PPP (point to point protocol). OTA throughput does not count physical layer overhead such as mid-amble, guard, or tail bits, or bits added by the encoding process.

  • IP Rx and IP Tx

IP (Internet Protocol) throughput counts the data transmitted and received by the test set. It measures the IP data transferred between the external LAN connector and the protocol stack. It provides a measure of the IP data packets being transferred to/from the wireless device.

How is Data Throughput Displayed?

When the Data Throughput Monitor is selected and a data call is connected, the test set accumulates data throughput statistics. If a data call is disconnected, data accumulation is suspended until another connection is made and data accumulation continues. Data accumulation can be cleared by performing a measurement reset or clearing the graph.

The test set provides two tools to analyze data throughput:

  • Graphical trace

  • Summary table

Graphical trace

The graphical trace presents up to the most recent 600 seconds (10 minutes) of data throughput statistics. Each of the following color-coded traces can be turned on or off:

  • OTA Tx - (Over The Air Transmitted bits-per-second). This is the rate of link-layer bit transfer sent from the wireless device. In other words, OTA translates into RLP (Radio Link Protocol) in cdma2000 and 1xEV-DO, or RLC (Radio Link Control) protocol in W-CDMA and GPRS, or PPP in GSM. Tx refers to the reverse or uplink channel direction.

  • OTA Rx - (Over The Air Received bits-per-second). This is the rate of link-layer bit transfer received by the wireless device. In other words, OTA translates into RLP (Radio Link Protocol) in cdma2000 and 1xEV-DO, or RLC (Radio Link Control) protocol in W-CDMA and GPRS, or PPP in GSM. Rx refers to the forward or downlink channel direction.

  • IP Tx - Internet Protocol Transmitted. This is the rate of network-layer bit transfer sent by the wireless device. Tx refers to the reverse or uplink channel direction.

  • IP Rx - Internet Protocol Received. This is the rate of network-layer bit transfer received by the wireless device. Rx refers to the forward or downlink channel direction.

  • Context n Tx - Internet Protocol Context 1 Transmitted. This is the rate of context 1 network-layer bit transfer sent by the wireless device. Tx refers to the reverse or uplink channel direction.

  • Context n Rx - Internet Protocol Context 1 Received. This is the rate of context 1 network-layer bit transfer received by the wireless device. Rx refers to the forward or downlink channel direction.

Four sets of Context <n> traces can be set: Context 1 Tx/Rx, Context 2 Tx/Rx, Context 3 Tx/Rx and Context 4 Tx/Rx. Totally there are 12 traces results are available form the Data Throughput Monitor, but six of them can be display on the screen at one time. You can choose which traces are to be displayed by pressing Trace Display softkey.

Note: If your application dose not support counters for multiple Contexts, the "Context<n>" counts will always be zero (a trace will still be available but every point will be "0").

A marker can be assigned to each trace to display instantaneous numeric data throughput values. Markers can be used in conjunction with the Freeze Graph feature to analyze points of interest on traces.

Summary table

The summary table provides the latest statistics for the four monitored measurements. Each measurement is displayed with the following statistics:

  • Marker

The data rate at the measurement's marker position in bits-per-second.

  • Current

The measurement's instantaneous data in bits-per-second.

  • Average

The measurement's average data rate in bits-per-second over the length of the data connection or since the last time the measurement was cleared.

  • Peak

The measurement's peak data rate in bits-per-second over the length of the data connection or since the last time the measurement was cleared.

  • Data Transfer

The measurement's total data throughput count, in bytes, over the length of the data connection or since the last time the measurement was cleared

Related Topics

GPIB Commands: CALL:COUNt


Concurrent Measurements

Description

A number of measurements can be initiated (with the INITiate command) while other measurements are being made, and the test set will perform as many operations simultaneously as its architecture allows. This technique is referred to as concurrency. Performing measurements concurrently can greatly improve test throughput.

The test set has three parallel signal paths to improve measurement throughput.

  • Demodulation downconverter path.

  • Measurement downconverter path.

  • Power detector path.

Since measurements are DSP (digital signal processor) based, and there are four A/D converters available to digitize or "sample" the input signal for analysis by the DSP, the test set will always have the capability to perform one transmitter measurement, one receiver measurement, and maintain the radio link concurrently. The test set's ability to perform multiple transmitter, or multiple receiver tests concurrently will depend on the availability of resources within the test set and availability of the signal to be tested.

Concurrent Measurements for the TD-SCDMA Applications

This table shows the concurrency considerations for the TD-SCDMA applications.

 | Reporting of Channel Quality Indicator (THCQuality) | Fast Device Tune (TFDTune) | Out-of-Synch (TOOSynch) | Open Loop Power Control (TOLPower) | HSDPA Block Error Ratio (THBLerror) | Block Error Ratio (TBLerror) | Transmit ON/OFF Power (TOOPower) | Loopback Bit Error Ratio (TBERror) | Dynamic Power (TDPower) | Occupied Bandwidth (TOBWidth) | Closed Loop Power Control (TCLPower) | Frequency Stability (FSTability) | Spectrum Emission Mask (TSEMask) | Adjacent Channel Leakage Ratio (TACLeakage) | Waveform Quality (TWQuality) | Channel Power (TCPower)
Channel Power (TCPower) | Y | E | E | E | Y | Y | Y | Y | E | Y | E | Y | Y | Y | Y |
Waveform Quality (TWQuality) | Y | E | E | E | Y | Y | Y | Y | E | Y | E | Y | Y | Y |  |
Adjacent Channel Leakage Ratio (TACLeakage) | Y | E | E | E | Y | Y | Y | Y | E | Y | E | Y | Y |  |  |
Spectrum Emission Mask (TSEMask) | Y | E | E | E | Y | Y | Y | Y | E | Y | E | Y |  |  |  |
Frequency Stability (FSTability) | Y | E | E | E | Y | Y | Y | Y | E | Y | E |  |  |  |  |
Closed Loop Power Control (TCLPower) | E | E | E | E | E | E | E | E | E | E |  |  |  |  |  |
Occupied Bandwidth (TOBWidth) | Y | E | E | E | Y | Y | Y | Y | E |  |  |  |  |  |  |
Dynamic Power (TDPower) | E | E | E | E | E | E | E | E |  |  |  |  |  |  |  |
Loopback Bit Error Ratio (TBERror) | Y | E | E | E | N | N | Y |  |  |  |  |  |  |  |  |
Transmit ON/OFF Power (TOOPower) | Y | E | E | E | Y | Y |  |  |  |  |  |  |  |  |  |
Block Error Ratio (TBLerror) | Y | E | E | E | N |  |  |  |  |  |  |  |  |  |  |
HSDPA Block Error Ratio (THBLerror) | N | E | E | E |  |  |  |  |  |  |  |  |  |  |  |
Open Loop Power Control (TOLPower) | E | E | E |  |  |  |  |  |  |  |  |  |  |  |  |
Out-of-Synch (TOOSynch) | E | E |  |  |  |  |  |  |  |  |  |  |  |  |  |
Fast Device Tune (TFDTune) | E |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
Reporting of Channel Quality Indicator (THCQuality) |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |

Table Key

  • Y: Yes, these measurements can operate concurrently with no conflicts.

  • N: No, these measurements cannot operate concurrently. The measurement which is initiated most recently will cause all other conflicting measurements to be closed.

  • E: Exclusively. When this measurement is initiated, all other measurements are closed.


How Do I...

Last updated: April 21, 2010

This page provides links on how to use the test set manually for your test including: Configure the test set, Make Measurements.

If you have trouble finding the information you need below, use the search field at the top of this page to search the contents of this hep.

Configure the test set

  • Configure the Test Set for My Test System

  • Switch Formats

  • Configure the AUDIO OUT Port

Do Call Processing Operations

  • Set Up a Call and Make a Connection

  • Perform a Handover

  • Use the Short Message Service (SMS) Feature

Make Measurements

  • How Do I Make an HSDPA Block Error Ratio Measurement

  • How Do I Make an Open Loop Power Control Measurement?

  • How Do I Make an Out-of-Synch Handling of Output Power (OOS) Measurement?

  • How Do I Make a Reporting of Channel Quality Indicator (CQI) Measurement?

  • How Do I Use the Spectrum Monitor?


Configure the Test Set for My Test System

Description

A. Configure instrument information and setup.

  1. Press the SYSTEM CONFIG key.

  2. Press the Instrument Setup ( F1 ) key.

  3. Adjust an instrument setting and then press the Close Menu ( F6 ) key.

B. Set amplitude offsets

  1. On the Configuration Summary Screen, press the RF IN/OUT Amptd Offset ( F5 ) key.

  2. On the RF IN/OUT Amplitude Offset screen, press the RF IN/OUT Amptd Offset Setup ( F2 ) key.

  3. Enter the amplitude offset for the test frequencies you use.

  4. Press the Close Menu ( F6 ) key.

  5. Press the Return ( F6 ) key.

C. Check the message log.

  1. Press the Message Log ( F7 ) key and view the message log.

  2. Press the Return ( F12 ) key.


Set Up a Call and Make a Connection

Set Up a TD-SCDMA Call

Establish an HSDPA Connection

Set Up a TD-SCDMA Call

Set Cell Parameters

  1. Press the CALL SETUP key.

  2. Press the left More key to move to the Call Control 2 of 3 menu.

  3. Press Cell Parameters ( F2 ).

  • Set BCCH Update Page to Auto , if desired, so that the UE will be notified of any changes to the BCCH information transmitted by the test set after the call is established.

  • Set ATT (IMSI Attach) Flag State to Set , if required for your UE to register with the test set.

  • It is suggested that you set the Protocol Revision Control to Auto.

  • Select Close Menu ( F6 ).

Set Call Parameters

  1. Connect the UE to the front panel RF IN/OUT port and power it on.

  2. After a few seconds the UE should register with the test set. The test set then displays UE Information such as IMSI and IMEI on the Call Setup screen and the MM Status should change from None to IMSI Attached.

.

  3. Establish the call

  4. For the Test set originated call:

  5. Select Paging Service ( F9 ) and set as needed.

  6. If Paging Service is set to RB Test Mode, select Channel Type ( F8 ) and set as needed.

  7. If Paging Service is set to AMR Voice, go to Call Control 3 of 3, Voice Call ( F3 ) and set the AMR parameters as needed.

  8. Select Originate Call ( F3 ).

  9. Answer the call if necessary, and verify that Connected is displayed in the Active Cell window.

  10. For the UE initiated call:

  • Dial a number into the UE and press send.

  • Verify that Connected is displayed in the Active Cell window.

Establish an HSDPA Connection

This section is only applicable to the feature-licensed test application.

Set Cell Parameters

To set up an HSDPA call, you need to set the following cell parameters additionally besides Set Cell Parameters described in the TD-SCDMA call section.

  • In the Cell Parameters menu, set the PS Domain Information to Present.

Set HSDPA Parameters

  1. Press the CALL SETUP key.

  2. Set Paging Service ( F9 ) to RB Test Mode.

  3. Set Channel Type ( F8 ) to 12.2k RMC + HSDPA.

  4. Select HSDPA Parameters (F11).

  5. Select HSDPA RB Test Mode Setup ( F7 ).

  6. Set the HS-DSCH Config to match your test requirements. If RMC is selected, the test set will set the downlink properties according to RMC Type, and you can use this option to test 9.3.1A to 9.3.1E; If VRC is selected, the test set will vary the downlink properties according to the UE's indication, and you can use this option to test 9.3.2A to 9.3.2E. The HSSCCH Detection option allows you to perform 9.3.4. See HS-DSCH Config.

  7. (Optional) If RMC is selected as the HS-DSCH Config, set the RMC Type as supported by your UE. You can view the UE Reported HS-DSCH Category on the UE Information Screen.

Note that the RMC Type must be set strictly to match the UE capability, or you will see the HSDPA BLER very high after connection.

  • Set CN Domain as needed. The test set supports to set up an HSDPA connection over PS or CS+PS domain.

  • Set other HSDPA RB Test Mode Setup parameters as needed, then select Close Menu ( F6 ).

  4. Set MAC-hs Parameters ( F8 ) and H-RNTI Parameters ( F9 ) as needed, then select Close Menu ( F6 ).

Establish the HSDPA Connection

  1. Connect the UE to the front panel RF IN/OUT port and power it on.

  2. After a few seconds the UE should register with the test set.

  3. Select Originate Call ( F3 ).

  4. Verify that Connected is displayed in the Active Cell. Now you can view the real-time information of the HSDPA BLER and throuput on the HSDPA Real Time Results Information window.

Related Topics

Cell Parameters

Security Information

Channel Type

Paging Service Type


Perform a Handover

The test set supports the following handover types:

Physical Channel Reconfiguration

System Handover

Physical Channel Reconfiguration

  • Establish a call with the UE and verify that Connected is shown in the Active Cell field (see Set Up a Call and Make a Connection).

  • Press the CALL SETUP key.

  • Select Handovers ( F5 ).

  • Select Physical Chan Reconfig ( F1 ).

  • To perform an inter-frequency handover, set PCR Channel (UARFCN) as desired;

  • To change the closed loop power control step size during a connection , set the PCR UL CL Power Ctrl Step Size as desired.

  • To perform a single code/multi-code RMC handover, set the PCR DPCH Type State to On and set the PCR DPCH Type as desired.

  • Set other PCR parameters.

  • Select Execute Handover ( F5 ).

  • Verify that Connected is still shown in the Active Cell field.

System Handover

Before you perform a system handover to GSM format, ensure the following: 1) The RF IN/OUT Amptd Offset (see Amplitude Offset) is set correctly for both the TD-SCDMA and GSM frequencies. 2) Your DUT is configured to automatically search the network.

  • Confirm that the GSM/GPRS format is in active cell operating mode (press the SYSTEM CONFIG key, select Format Switch ( F2 ), select GSM/GPRS, and set Operating Mode ( F1 ) to Active Cell). Return to the TD-SCDMA format by format switch.

  • Establish an RB test mode (non-HSDPA) or AMR Radio Access Bearer call with the UE and verify that Connected is shown in the Active Cell field (see Set Up a Call and Make a Connection).

  • Press the CALL SETUP key.

  • Select Handovers ( F5 ).

  • Select System Handover ( F3 ).

  • Set the GSM system parameters as needed.

  • Select Execute Handover ( F5 ).

  • When performing a handover from RB test mode to a GSM voice call with RB Test Mode to GSM Handover Alerting State set to On , the UE will ring. You must answer the ring for the connection to be completed and testing to progress.

  • Verify that SYS Type field is now GSM or GPRS, and Connected is still shown in the Active Cell field.

Related Topics

Handovers


How Do I Test Packet Data Performance of the UE

This section is only applicable to the feature-licensed test application.

This page outlines the requirements to demonstrate Packet Switched Data connections using the TD-SCDMA user equipment (UE).

Testing of TD-HSDPA packet switched data will be the means by which you can check the actual data throughput of your TD-SCDMA UE.

  • Software Requirements

  • Setup

  • Test Set Setup

  • Client PC Setup

  • Server PC Setup

  • Connection_Setup

  • Test 1, UDP_Flood

  • Test 2, FTP

  • UE_Setup

Software Requirements

  • Client PC:

  • Dialup connection using UE driver

  • FileZilla FTP Client [used for FTP]

  • iperf.exe in c:\bin [used for UDP]

  • Server PC:

  • iperf.exe in c:\bin [used for UDP]

  • FileZilla FTP server (see Appendix) [used for FTP]

  • Shared folder specified in FileZilla FTP, with large files to download [used for FTP]

Setup

Test set Setup

Use the following IP addresses as an example:

1. Press System Config, then Instrument Setup and enter:

  • LAN IP Address: 10.10.10.10

  • Subnet Mask: 255.255.255.0

  • Default Gateway: 0.0.0.0

2. Press System Config, then Instrument Setup, then scroll down and enter:

  • LAN IP Address 2: 10.10.10.40

3. Press Call Setup, then press the left handside More key until you reach page 3 of 3. Press Data Channels (F6), Press DUT IP Setup (F5) In the DUT IP Setup menu, enter:

  • DUT IP Address: 10.10.10.20 (this will be assigned to the client PC via UE)

  • DUT Primary DNS: 10.10.10.2

  • DNS Secondary DNS: 10.10.10.3

Note: You may need to turn off the firewall for the test purpose.

Server PC Setup

The server PC has a fixed IP address: 10.10.10.30. Ensure that your server PC includes all of the software and files listed under Software Requirements.

Client PC Setup

The client PC's IP address is assigned via the DUT IP Address setting in the 8960. Ensure that your client PC includes all of the software and files listed under Software Requirements.

Connection Setup

  1. Set the PS Domain Information to present. (Cell Info (F2 on Call Control 2 of 3)>>Cell Parameters (F1)>>PS Domain Information).

  2. Set the T300 RRC Conn Req Retransmit Timer to 4000ms (Cell Info (F2 on Call Control 2 of 3)>>UE Timer and Constant Parms (F3) >> T300 RRC Conn Req Retransmit Timer)

  3. Set the MNC to 1

  4. Set the MCC to 1

Note: This is only required for the UE in this test.

  5. Set the parameters related to the TD-HSDPA PS data service:

a. Set the PS Data HS-DSCH Configuration Type to UE Reported CQI (this is the default setting)

b. Set the PA Data MAC-d PDU Size to 336 (this is the default setting)

c. Set the PS Data Number of HS-PDSCH Timeslots to 5 (this is the default setting)

d. Set the PS Data First HS-PDSCH Timeslot to TS2 (this is the default setting)

e. Set the PS Data HS-PDSCH OVSF to SF1 (this is the default setting)

f. Set the PS Data Number of HS-PDSCH Channel Codes to 16 (this is the default setting)

g. Set the PS Data DL DPCH/HS-SCCH Timeslot to TS0 (this is the default setting)

h. Set the PS Data User Def Modulation Type to 16QAM (this is the default setting)

  6. Connect your UE's RF cable to the test set. Power on the UE

  7. Ensure that the UE correctly reported its HS-DSCH Category 15 (See UE Reported HS-DSCH Cat under UE Information on the front panel).

Test 1, UDP Flood

UDP flood confirms the UE's maximum data throughput at IP, without the added complication yet of acknowledgements from the UE.

  1. Initiate the Data Throughput Monitor from the Instrument Selection key.

Select Axis Control (F1) and change Stop Data Rate to 3000 kbps. Select Return (F6)

  2. On the client PC, initiate a PDP Context from the UE (see the Appendix 4.1). Call status should go to PDP Active.

Launch the command window, go to C:\bin, type “iperf –s –u”

Note: Ensure that the iperf.exe is already being put in to the folder “C:\bin”.

  3. On the server PC, launch the command window. go to C:\bin, type “iperf –c <IP> -u -b <rate> –t <time>”

Note: <IP> should be the DUT IP address , <rate> should be the bps rate of the UDP flood. Time defines how many seconds the UDP flood will run. For example, you can type “iperf –c 10.10.10.20 -u -b 2800000 –t 1000”.

  4. To ramp up the OTA Rx, you must increase the CQI Value if the “PS Data HS-DSCH Configuration Type” is defined to be “User Defined CQI” (HSDPA Parameters (F11)>>HSDPA PS Data Setup (F8)). A setting of 63 should achieve ~2.8 Mbps OTA.

  5. Stop udp_flood in the server PC using Ctrl+c.

Test 2, FTP

FTP requires TCP acknowledgements from the UE. Now all the layers are in action.

1. On the client PC, initiate a PDP Context from the UE (see the Appendix 4.1). Call status should go to PDP Active.

2. On the server PC, go to Start>>Control Panel>>Administrative Tools>>Services.

  • Start the FileZilla Server FTP service.

3. On the server PC, launch FileZilla FTP Server from the desktop shortcut.

  • Go to Edit>>Settings>>Miscellaneous

  • Set the Internal transfer buffer size to 1460.

  • Set Socket buffer size to 103360 (it must be bigger than the Internal transfer buffer size).

  • Select OK.

  • You must disconnect, then reconnect the server for the changes to take effect (using the lightning bolt icon).

4. Open FileZilla FTP Client on the client PC.

  1. Type in 10.10.10.30 under Address, anonymous under User, leave Password blank, then hit Quickconnect.

  2. Double-click on a file in the “Remote Site” window to download.

  3. Observe the Data Throughput Monitor.

  4. Change CQI Value from 63 to decrease the data throughput.

  5. Close FileZilla FTP Client.

UE Setup

  1. Insert the USB cable into the PC and power on the UE

  2. Install the USB modem driver on the client PC.

  3. Setup a PS Data connection: Click on [start], [connect to] [show all connections]

  4. Click the UE icon and select properties

  5. Then check the UE driver and enter *99# for a PS data call


GPIB Commands

This page provides links to all of the test set's GPIB subsystems. Select a subsystem link below for a description of the subsystem and links to all of the GPIB commands within that subsystem.

For more information on the GPIB Command conventions, see GPIB Command conventions

Use Help Mode if you are not sure about the GPIB Command for a specific setting.

If you have trouble finding the information you need below, use the search field at the top of this page to search the contents of this guide.

Call Processing

  • Call Subsystem

Measurement Control

  • ABORt Subsystem

  • FETCh Subsystem

  • INITiate Subsystem

  • READ Subsystem

  • SETup Subsystem

Test Set Configuration

  • SYSTem Subsystem

  • AFGenerator Subsystem

  • CALibration Subsystem

  • DISPlay Subsystem

  • RFANalyzer Subsystem

  • RFGenerator Subsystem


GPIB Command conventions

Last updated: April 21, 2010

Description

The uppercase letters of a mnemonic represent the short form of the mnemonic, whereas the long form of a mnemonic is the short form followed by the lowercase letters. The test set accepts either the long form or the short form of the mnemonic.

The mnemonics that are inside square brackets are optional. That is, a command operates the same whether or not the mnemonic in square brackets is used in the command.

A vertical bar, |, implies choices. When mnemonics are listed in parentheses separated by vertical bars ( | ), you must choose one of the mnemonics inside the parentheses.

  • Complex Command Description

  • Data Type Description

  • Unit Type Description

  • [:SELected] Mnemonic

  • Using quotes around strings

Complex Command Description

Complex commands are valuable because they set the state of the parameter and a value for that parameter. For example, a command that contains the mnemonic [:SAMPlitude] is a complex command that sets the state to ON as well as the amplitude. You can use parameters such as amplitude, frequency, gain, number, time, and value as a complex command. Refer to the specific command for the parameter that applies.

Data Type Description

num value | Integer, float or scientific values. For example, CALL:POWer -55.5 CALL:POWer -5.55E+001 CALL:CHANnel 525
string | Characters. The string will often need to be enclosed in single or double quotes, depending upon your programming environment. For example, CALL:CIDentity "#0123456789*" CALL:UPLink:PRAChannel:ASUBchannels '111111111111' The string returned by the test set is enclosed by double quotes.
choice1|choice2|choice3 | Specific character choices. For example, CALL:OPERating:MODE D2KTest SYSTem:COMMunicate:GPIB:DEBug ON

Unit Type Description

Some commands have optional units of measurement. These are displayed in square brackets. If no units are specified in the command then the default unit in bold font below is used. The test set accepts the specified unit either with or without a space inserted between the <num value> and the unit (for example, both 10S and 10 S are valid). The following table summarizes the units available.

Description | Optional Units | Example
Amplitude (linear) | V|MV | To set the spectrum monitor's timeout interval to 20 seconds, use any of the following formats: SETup:SMONitor:TIMeout:TIME 20 SETup:SMONitor:TIMeout:TIME 20S SETup:SMONitor:TIMeout:TIME 20 S
Power (logarithmic) | DBM|DBW
Level (relative) | DB
Frequency | HZ|KHZ|MHZ|GHZ
Time | S|MS|US|NS
Percentage | PCT

[:SELected] Mnemonic

The [:SELected] Mnemonic is an optional mnemonic that implies a current selection on the test set. Often there are other mnemonics that can be used in place of the [:SELected] mnemonic to configure a setting that is not the currently selected configuration on the test set. The mnemonics that can replace the [:SELected] mnemonic are listed in parentheses separated by vertical bars ( | ) in the description table title.

Using quotes around strings

When the setting and query values of a GPIB command are strings, a single quote is needed around the strings when setting the command, while the test set returns the result in double quoted strings when querying.


CALL Subsystem

Description

The CALL subsystem handles all setup, control, and query functions for call processing. This includes UE and Base Station (cell) functions.

Related Topics

  • CALL:ATTFlag

  • CALL:AWGNoise

  • CALL:BCCHannel

  • CALL:CCPChannel

  • CALL:CHANnel

  • CALL:CLPControl

  • CALL:CONNected

  • CALL:CONTrol

  • CALL:DPCHannel

  • CALL:DRX

  • CALL:DTCHannel

  • CALL:END

  • CALL:HANDoff

  • CALL:IDENtity

  • CALL:LACode

  • CALL:MCCode

  • CALL:MNCode

  • CALL:MS:POWer

  • CALL:MS:REPorted

  • CALL:NMOPeration

  • CALL:OPERating

  • CALL:ORIGinate

  • CALL:PAGing

  • CALL:POWer

  • CALL:PSDomain

  • CALL:RACode

  • CALL:RFGenerator

  • CALL:SCODe

  • CALL:SECurity

  • CALL:SETup

  • CALL:STATus

  • CALL:TDTest

  • CALL:TMSI

  • CALL:TOTal:POWer

  • CALL:TRIGger

  • CALL:UPLink


CALL:ATTFlag

  • CALL[:CELL]:ATTFlag[:STATe]

The settings below can be set in active cell operating mode only when the call status is Idle, or in other operating modes.

If BCCH Update Page is set to Auto and you change the settings while your UE is camped to the test set, the test set performs a Broadcast Channel (BCCH) Update Procedure ; If BCCH Update Page is set to Inhibit (the default value) and you change the settings while your UE is camped to the test set, the UE is informed to re-read the BCCH to observe the change (see CALL:BCCHannel:UPDAte:PAGE AUTO).

For more information on the GPIB Command conventions, see GPIB Command conventions

CALL[:CELL]:ATTFlag[:STATe]

Function | Sets/queries the ATT (IMSI Attach, Attach-detach allowed) flag state, which determines whether a flag (ATT) broadcast on the BCCH is used to indicate the attach/detach procedure is required (ON) or not (OFF).
Setting | Range: 1|ON|0|OFF
Query | Range: 0|1
*RST Setting | 1 (On)
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "CALL:ATTFlag ON"


CALL:AWGNoise

  • CALL:AWGNoise[:INTernal]:POWer[:SAMPlitude][:SELected]

  • CALL:AWGNoise[:INTernal]:POWer[:SAMPlitude]:TDSCdma

  • CALL:AWGNoise[:INTernal]:POWer:AMPlitude[:SELected]

  • CALL:AWGNoise[:INTernal]:POWer:AMPlitude:TDSCdma

  • CALL:AWGNoise[:INTernal]:POWer:STATe[:SELected]

  • CALL:AWGNoise[:INTernal]:POWer:STATe:TDSCdma

For more information on the GPIB Command conventions, see GPIB Command conventions

CALL:AWGNoise[:INTernal]:POWer[:SAMPlitude][:SELected]

Function | The setting form of this command performs two functions for the current system type: (1) sets the additive white gaussian noise (AWGN) level (see CALL:AWGNoise[:INTernal]:POWer:AMPlitude[:SELected]) and (2) turns the AWGN on/off state (see CALL:AWGNoise[:INTernal]:POWer:STATe[:SELected]) to on.
Setting | Range:+35dBm/1.28MHz to -165dBm/1.28MHz Resolution:0.01
Query | same as setting
*RST Setting | -60.0
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "CALL:AWGNoise:POWer -60"

CALL:AWGNoise[:INTernal]:POWer[:SAMPlitude]:TDSCdma

Function | The setting form of this command performs two functions for the TD-SCDMA system type: (1) sets the additive white gaussian noise (AWGN) level (see CALL:AWGNoise[:INTernal]:POWer:AMPlitude:TDSCdma) and (2) turns the AWGN on/off state (see CALL:AWGNoise[:INTernal]:POWer:STATe:TDSCdma) to on.
Setting | Range:+35dBm/1.28MHz to -165dBm/1.28MHz Resolution:0.01
Query | same as setting
*RST Setting | -60.0
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "CALL:AWGNoise:POWer:TDSCdma -80"

CALL:AWGNoise[:INTernal]:POWer:AMPlitude[:SELected]

Function

Sets/queries the additive white gaussian noise (AWGN) level when the AWGN power state is on for the current system type.

The optional [:SELected] keyword in this command specifies that the cell power level being set or queried applies to the current system type.

Setting

Range:+35dBm/1.28MHz to -165dBm/1.28MHz

Resolution:0.01

Query

same as setting

*RST Setting

-60.0

Requirements

Test Application Revision: A.01.00 and above

Programming Example

"CALL:AWGNoise:POWer:AMPLITUDE -80"

CALL:AWGNoise[:INTernal]:POWer:AMPlitude:TDSCdma

Function | Sets/queries the additive white gaussian noise (AWGN) level when the AWGN power state is on for the TD-SCDMA system type.
Setting | Range:+35dBm/1.28MHz to -165dBm/1.28MHz Resolution:0.01
Query | same as setting
*RST Setting | -60.0
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "CALL:AWGNoise:POWer:AMPLITUDE:TDSCdma -80"

CALL:AWGNoise[:INTernal]:POWer:STATe[:SELected]

Function | Sets/queries the additive white gaussian noise power state for the current system type. The optional [:SELected] keyword in this command specifies that the cell power level being set or queried applies to the current system type.
Setting | Range:1|ON|0|OFF
Query | Range:1|0
*RST Setting | OFF
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "CALL:AWGNoise:POWer:STATe OFF"

CALL:AWGNoise[:INTernal]:POWer:STATe:TDSCdma

Function | Sets/queries the additive white gaussian noise power state for the TD-SCDMA system type.
Setting | Range:1|ON|0|OFF
Query | Range:1|0
*RST Setting | OFF
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "CALL:AWGNoise:POWer:STATe:TDSCDMA OFF"


CALL:BCCHannel

  • CALL[:CELL]:BCCHannel:N300

  • CALL[:CELL]:BCCHannel:N312[:IDLE]

  • CALL[:CELL]:BCCHannel:N312:CONNected

  • CALL[:CELL]:BCCHannel:N313

  • CALL[:CELL]:BCCHannel:N315

  • CALL[:CELL]:BCCHannel:T300

  • CALL[:CELL]:BCCHannel:T308

  • CALL[:CELL]:BCCHannel:T312[:IDLE]

  • CALL[:CELL]:BCCHannel:T312:CONNected

  • CALL[:CELL]:BCCHannel:T313

  • CALL[:CELL]:BCCHannel:T3212

  • CALL[:CELL]:BCCHannel:UPDate:PAGE

The settings below can be set in active cell operating mode only when the call status is Idle, or in other operating modes.

If BCCH Update Page is set to Auto and you change the settings while your UE is camped to the test set, the test set performs a Broadcast Channel (BCCH) Update Procedure ; If BCCH Update Page is set to Inhibit (the default value) and you change the settings while your UE is camped to the test set, the UE is informed to re-read the BCCH to observe the change (see CALL:BCCHannel:UPDAte:PAGE AUTO).

For more information on the GPIB Command conventions, see GPIB Command conventions

CALL[:CELL]:BCCHannel:N300

Function | Sets/queries the N300, which determines the maximum number of retransmissions of RRC Connection Request message.
Setting | Range: 0 to 7
Query | Range: 0 to 7
*RST Setting | 0
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "CALL:CELL:BCCHannel:N300 0"

CALL[:CELL]:BCCHannel:N312[:IDLE]

Function | Sets/queries the N312 Link Establishment In-Sync Count , which determines the number of “in-syncs” required when establishing DPCH and the connection status is idle.
Setting | Range: S1 | S2 | S4 | S10 | S20 | S50 | S100 | S200 | S400 | S600 | S800 | S1000
Query | same as setting
*RST Setting | S1
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "CALL:BCCHannel:N312 S1"

CALL[:CELL]:BCCHannel:N312:CONNected

Function | Sets/queries the number of “in-syncs” required when establishing a dedicated channel when in the connection mode.
Setting | Range: S1 | S2 | S4 | S10 | S20 | S50 | S100 | S200 | S400 | S600 | S800 | S1000
Query | same as setting
*RST Setting | S1
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "CALL:BCCHannel:N312:CONNected S1"

CALL[:CELL]:BCCHannel:N313

Function | Sets/queries the N313, which determines the maximum number of successive “out of sync” before starts T313.
Setting | Range: S1 | S2 | S4 | S10 | S20 | S50 | S100 | S200
Query | Range: S1 | S2 | S4 | S10 | S20 | S50 | S100 | S200
*RST Setting | S2
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "CALL:BCCHannel:N313 S2"

CALL[:CELL]:BCCHannel:N315

Function | Sets/queries the N315, which specifies the maximum number of successive "in sync" received during T313 is activated.
Setting | Range: S1 | S2 | S4 | S10 | S20 | S50 | S100 | S200 | S400 | S600 | S800 | S1000
Query | Range: S1 | S2 | S4 | S10 | S20 | S50 | S100 | S200 | S400 | S600 | S800 | S1000
*RST Setting | S50
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "CALL:BCCHannel:N315 S50"

CALL[:CELL]:BCCHannel:T300

Function | Sets/queries the T300, which determines how long UE will wait for RRC connection setup after sending RRC Connection Request message.
Setting | Range: MS400 | MS600 | MS800 | MS1000 | MS1200 | MS1400 | MS1600 | MS1800 | MS2000 | MS3000 | MS4000 | MS6000 | MS8000
Query | same as setting
*RST Setting | MS400
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "CALL:CELL:BCCHannel:T300 MS400"

CALL[:CELL]:BCCHannel:T308

Function | Sets/queries the T308 timer.
Setting | Range: MS40 | MS80 | MS160 | MS320
Query | same as setting
*RST Setting | MS40
Requirements | Test Application Revision: A.03.00 and above
Programming Example | "CALL:BCCHannel:T308 MS40"

CALL[:CELL]:BCCHannel:T312[:IDLE]

Function | Sets/queries the T312, which determines how long UE will wait to get the N312 Link Establishment In-Sync Count (Idle) when establishing DPCH and the connection status is Idle.
Setting | Range: 1 to 15
Query | Range: 1 to 15
*RST Setting | 1
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "CALL:BCCHannel:T312 1"

CALL[:CELL]:BCCHannel:T312:CONNected

Function | Sets/queries the T312, which determines how long UE will wait to get the N312 Link Establishment In-Sync Count (Idle) when establishing DPCH in the connection mode.
Setting | Range: 1 to 15
Query | Range: 1 to 15
*RST Setting | 1
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "CALL:BCCHannel:T312:CONNected 1"

CALL[:CELL]:BCCHannel:T313

Function | Sets/queries the T313, which determines how long UE will wait to get N315 “in-syncs” after it detects N313 “out-of-sync”, before it triggers the radio link failure procedure.
Setting | Range: 0 to 15
Query | Range: 0 to 15
*RST Setting | 3
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "CALL:BCCHannel:T313 3"

CALL[:CELL]:BCCHannel:T3212

Function | Sets/queries the T3212 timer.
Setting | Range: 0 to 255 decihours
Query | Same as setting
*RST Setting | 0
Requirements | Test Application Revision: A.03.00 and above
Programming Example | "CALL:BCCHannel:T3212 0"

CALL[:CELL]:BCCHannel:UPDate:PAGE

Function | Sets/queries the BCCH Update Page state. If it is set to Auto and you change the SIB settings while your UE is camped to the test set, the test set performs a Broadcast Channel (BCCH) Update Procedure (SIB Contents); If it is set to Inhibit (the default value) and you change the SIB settings while your UE is camped to the test set, the UE is informed to re-read the BCCH to observe the change. See Broadcast Channel (BCCH) Update Procedure (SIB Contents).
Setting | Range: AUTO | INHibit
Query | Range: AUTO | INH
*RST Setting | INH
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "CALL:BCCHannel:UPDAte:PAGE INH"


CALL:CCPChannel

  • CALL[:CELL]:CCPChannel:PRIMary:BLEVel

For more information on the GPIB Command conventions, see GPIB Command conventions

CALL[:CELL]:CCPChannel:PRIMary:BLEVel

Function | Sets/queries the primary common control physical channel's initial power. The setting can be set in active cell operating mode only when the call status is Idle, or in other operating modes.
Setting | Range: +6 to +43 dBm
Query | Range: 6 to 43
*RST Setting | 24
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "CALL:CCPChannel:PRIMary:BLEVel 24"


CALL:CHANnel

  • CALL:CHANnel

For more information on the GPIB Command conventions, see GPIB Command conventions

CALL:CHANnel

Function

Sets/queries the downlink channel number.

This setting cannot be changed while in active cell operating mode and the call status is not IDLE. Attempting to change this setting under those condition results in the following error message:"TD-SCDMA call operation rejected; Change allowed only when 23 Call Status is Idle." Use other operating modes when changing this setting.

After successful completion of a Physical Channel Reconfiguration, the setting will be set the same to the value of physical channel reconfiguration target Cell UARFCN.

Setting

Range:10054 to 10121, 9404 to 9596

Query

Range:10054 to 10121, 9404 to 9596

*RST Setting

10087

Requirements

Test Application Revision: A.01.00 and above

Programming Example

"CALL:CHANnel 10087"


CALL:CLPControl

  • CALL[:CELL]:CLPControl:UPLink:IMMediate:DOWN

  • CALL[:CELL]:CLPControl:UPLink:IMMediate:UP

  • CALL[:CELL]:CLPControl:UPLink:MODE

  • CALL[:CELL]:CLPControl:UPLink:STEPsize

For more information on the GPIB Command conventions, see GPIB Command conventions

CALL[:CELL]:CLPControl:UPLink:IMMediate:DOWN

Function | This action sends an additional Down TPC command to the UE to decrease its power by one step. This operation is only allowed when the UL CL Power Ctrl Mode is set to Alternating bits.
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "CALL:CELL:CLPCONTROL:UPLINK:IMMEDIATE:DOWN"

CALL[:CELL]:CLPControl:UPLink:IMMediate:UP

Function | This action sends an additional Up TPC command to the UE to increase its power by one step. This operation is only allowed when the UL CL Power Ctrl Mode is set to Alternating bits.
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "CALL:CELL:CLPCONTROL:UPLINK:IMMEDIATE:UP"

CALL[:CELL]:CLPControl:UPLink:MODE

Function | Sets/queries the uplink closed power control mode when in the active cell operating mode. See UL CL Power Ctrl Mode.
Setting | Range: ACTive | ALTernating| UP | DOWN
Query | Range: ACT | ALT| UP | DOWN
*RST Setting | ACT
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "CALL:CELL:CLPControl:UPLink:MODE ACTive"

CALL[:CELL]:CLPControl:UPLink:STEPsize

Function | Sets/queries UL CL Power Ctrl Step Size when in the active cell operating mode.
Setting | Range: 1|2|3 dB
Query | Range: 1|2|3
*RST Setting | 1
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "CALL:CLPControl:UPLink:STEPsize 2"


CALL:CONNected

  • CALL:CONNected:ARM[:IMMediate]

  • CALL:CONNected:ARM[:IMMediate]:OPComplete?

  • CALL:CONNected:ARM[:IMMediate]:SEQuential

  • CALL:CONNected:ARM[:IMMediate]:WAIT

  • CALL:CONNected:ARM:STATe?

  • CALL:CONNected:DROP:TIMer[:STATe][:SELected]

  • CALL:CONNected:DROP:TIMer[:STATe]:TDSCdma

  • CALL:CONNected:LIMit[:STATe][:SELected]

  • CALL:CONNected:LIMit[:STATe]:TDSCdma

  • CALL:CONNected[:STATe]?

  • CALL:CONNected:TIMeout

For more information on the GPIB Command conventions, see GPIB Command conventions

CALL:CONNected:ARM[:IMMediate]

Function

Sets the call-state-change detector. It allows the control program to tell the test set that it is expecting a change in the state of a call, prior to initiating the state change.

Once armed, the detector remains armed until there is a call state change to "Idle" or "Connected" from other transition states.

Requirements

Test Application Revision: A.02.00 and above

Programming Example

"CALL:CONNECTED:ARM"

CALL:CONNected: ARM[:IMMediate]:DONE?

Function |
Query | Range: 1|0
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "CALL:CONNected:ARM:IMMediate:OPComplete?"

CALL:CONNected:ARM[:IMMediate]:OPComplete?

Function | Returns 1 in the test set's output queue when the call-state-change detector is armed, otherwise returns 0. Controlling program hangs on this query until the 1 is retrieved.
Query | Range: 1|0
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "CALL:CONNected:ARM:IMMediate:OPComplete?"

CALL:CONNected:ARM[:IMMediate]:SEQuential

Function | Forces an overlapped command to execute in the call-state-change detector.
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "CALL:CONNected:ARM:IMMediate:SEQuential"

CALL:CONNected:ARM[:IMMediate]:WAIT

Function | Forces the test set to wait until the call-state-change detector is armed before executing any more commands.
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "CALL:CONNected:ARM:IMMediate:WAIT"

CALL:CONNected:ARM:STATe?

Function | Queries the arm state of the call-state-change detector. This command never hangs and immediately returns 1if the detector is armed, or 0 if the detector is not armed.
Query | Range: 0|1
*RST Setting | 0
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "CALL:CONNected:ARM:STATe?"

CALL:CONNected:DROP:TIMer[:STATe][:SELected]

Function | Sets/queries the call drop timer timer for currently selected application, which indicates loss synchronization with uplink DPCH (ON).
Setting | Range: 1|ON|0|OFF
Query | Range: 1|0
*RST Setting | 1(ON)
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "CALL:CONNected:DROP:TIMer 1"

CALL:CONNected:DROP:TIMer[:STATe]:TDSCdma

Function | Sets/queries the call drop timer when using the TD-SCDMA application, which indicates loss synchronization with uplink DPCH (ON).
Setting | Range: 1|ON|0|OFF
Query | Range: 1|0
*RST Setting | 1(ON)
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "CALL:CONNected:DROP:TIMer:TDSCdma 1"

CALL:CONNected:LIMit[:STATe][:SELected]

Function | Sets/queries the call limit state for current selected format. When the call limit state is set to On, the test set does not respond to any UpPCH from the UE, which forces the UE to repeatedly send UpPCH.
Setting | Range: 1|ON|0|OFF
Query | Range: 1|0
*RST Setting | 0(OFF)
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "CALL:CONNected:LIMit 1"

CALL:CONNected:LIMit[:STATe]:TDSCdma

Function | Sets/queries the call limit state when using the TD-SCDMA application. When the call limit state is set to On, the test set does not respond to any UpPCH from the UE, which forces the UE to repeatedly send UpPCH.
Setting | Range: 1|ON|0|OFF
Query | Range: 1|0
*RST Setting | 0(OFF)
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "CALL:CONNected:LIMit:TDSCdma 1"

CALL:CONNected[:STATe]?

Function | Queries the connected/disconnected state of the call. If the call status is "connected", 1 is returned; else if the call status is in "idle", 0 is returned; else the call is in any other state , the query will hang until the call state transits to the connected or idle state.
Query | Range: 0|1
*RST Setting | 0
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "CALL:CONNECTED:STATE?"

CALL:CONNected:TIMeout

Function

Queries the arm state of the call-state-change detector. This command never hangs and immediately returns 1if the detector is armed, or 0 if the detector is not armed.

A timeout timer is started whenever the call-state-change detector becomes armed or gets rearmed. The timeout should be set greater than the maximum amount of time the control program needs to wait between arming the call-state-change detector and the connect/disconnect operation starting.

Setting

Range: 0 to 100 seconds

Query

Range: 0 to 100 seconds

*RST Setting

10 S

Requirements

Test Application Revision: A.02.00 and above

Programming Example

"CALL:CONNECTED:TIMEOUT 500 MS"


CALL:CONTrol

  • CALL[:CELL]:CONTrol:DOWNlink:FREQuency:AUTO

For more information on the GPIB Command conventions, see GPIB Command conventions

CALL[:CELL]:CONTrol:DOWNlink:FREQuency:AUTO

Function | Sets/queries the frequency control mode of test set. When the setting is ON, the frequency is specified by a channel number (UARFCN) in auto frequency control mode; when the setting is OFF, the frequency is independently in manual frequency control mode, see CALL:CELL:RFGenerator:FREQuency.
Setting | Range:1|ON|0|OFF
Query | Range:1|0
*RST Setting | 1 (auto)
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "CALL:CONTrol:DOWNlink:FREQuency:AUTO ON"


CALL:COUNt

Last updated: March 10, 2010

  • CALL:COUNt:CLEar:MS:IP

  • CALL:COUNt:DTMonitor:CLEar

  • CALL:COUNt:DTMonitor[:ALL]:DISPlay:DRATe:STARt

  • CALL:COUNt:DTMonitor[:ALL]:DISPlay:DRATe:STOP

  • CALL:COUNt:DTMonitor[:ALL]:DISPlay:SPAN:TIME

  • CALL:COUNt:DTMonitor[:ALL]:TRACe:HISTory:UNUMber?

  • CALL:COUNt:DTMonitor:OTATx:DISPlay:STATe

  • CALL:COUNt:DTMonitor:OTARx:DISPlay:STATe

  • CALL:COUNt:DTMonitor:IPTX:DISPlay:STATe

  • CALL:COUNt:DTMonitor:IPRX:DISPlay:STATe

  • CALL:COUNt:DTMonitor:OTATx:DRATe?

  • CALL:COUNt:DTMonitor:OTARx:DRATe?

  • CALL:COUNt:DTMonitor:IPTX:DRATe?

  • CALL:COUNt:DTMonitor:IPRX:DRATe?

  • CALL:COUNt:DTMonitor:OTATx:TRACe?

  • CALL:COUNt:DTMonitor:OTARx:TRACe?

  • CALL:COUNt:DTMonitor:IPTX:TRACe?

  • CALL:COUNt:DTMonitor:IPRX:TRACe?

  • CALL:COUNt:DTMonitor:OTATx:TRACe:HISTory?

  • CALL:COUNt:DTMonitor:OTARx:TRACe:HISTory?

  • CALL:COUNt:DTMonitor:IPTX:TRACe:HISTory?

  • CALL:COUNt:DTMonitor:IPRX:TRACe:HISTory?

  • CALL:COUNt:MS:IP[:ALL][:TOTal]?

  • CALL:COUNt:MS:IP:RX:[TOTal]?

  • CALL:COUNt:MS:IP:TX:[TOTal]?

For more information on the GPIB Command conventions, see GPIB Command conventions

CALL:COUNt:CLEar:MS:IP

Function | Clears all of the data counters for the IP (Internet Protocol) packets and bytes on both the forward and reverse channels.
Requirements | Test Application Revision: A.05.00 and above
Programming Example | "CALL:COUNt:CLEar:MS:IP"

CALL:COUNt:DTMonitor:CLEar

Function | This command clears all traces from the data throughput monitor display and resets the numeric summary table values to zero.
Requirements | Test Application Revision: A.05.00 and above
Programming Example | "CALL:COUNt:DTMonitor:CLEar"

CALL:COUNt:DTMonitor[:ALL]:DISPlay:DRATe:STARt

CALL:COUNt:DTMonitor[:ALL]:DISPlay:DRATe:STOP

Function | These commands set the data rate range (y-axis) for the data throughput monitor graphical display.
Setting | Start Range: 0 to 4999 kbps Stop Range: 1 to 5000 kbps
Query | Start Range: 0 to 4999 kbps Stop Range: 1 to 5000 kbps
*RST Setting | Start: 0 kbps Stop: 100 kbps
Requirements | Test Application Revision: A.05.00 and above
Programming Example | "CALL:COUNt:DTMonitor:DISPlay:DRATe:STARt 1" "CALL:COUNt:DTMonitor:DISPlay:DRATe:STOP 2800"

CALL:COUNt:DTMonitor[:ALL]:DISPlay:SPAN:TIME

Function | This command sets the time span (x-axis) for the data throughput monitor graphical display.
Setting | Range: 5 to 600 seconds
Query | Range: 5 to 600 seconds
*RST Setting | 600 seconds
Requirements | Test Application Revision: A.05.00 and above
Programming Example | "CALL:COUNt:DTMonitor:DISPlay:SPAN:TIME 600"

CALL:COUNt:DTMonitor[:ALL]:TRACe:HISTory:UNUMber?

Function | This query returns the number of 10-minute trace data collection periods since the last time the monitor was enabled or cleared.
Query | Range: 0 to 2,147,483,647 10-minute periods, 9.91 E+37 Resolution: 1
Requirements | Test Application Revision: A.05.00 and above
Programming Example | "CALL:COUNt:DTMonitor:TRACe:HISTory:UNUMber?"

CALL:COUNt:DTMonitor:OTATx:DISPlay:STATe

CALL:COUNt:DTMonitor:OTARx:DISPlay:STATe

CALL:COUNt:DTMonitor:IPTX:DISPlay:STATe

CALL:COUNt:DTMonitor:IPRX:DISPlay:STATe

Function | These commands set/query which data throughput traces are displayed.
Setting | Range: 1|ON|0|OFF
*RST Setting | OTA Tx - ON OTA Rx - ON IP Tx - OFF IP RX - OFF
Requirements | Test Application Revision: A.05.00 and above
Programming Example | "CALL:COUNt:DTMonitor:OTATx:DISPlay:STATe 1" "CALL:COUNt:DTMonitor:OTARx:DISPlay:STATe 1" "CALL:COUNt:DTMonitor:IPTX:DISPlay:STATe 1" "CALL:COUNt:DTMonitor:IPRX:DISPlay:STATe 1"

CALL:COUNt:DTMonitor:OTATx:DRATe?

CALL:COUNt:DTMonitor:OTARx:DRATe?

CALL:COUNt:DTMonitor:IPTX:DRATe?

CALL:COUNt:DTMonitor:IPRX:DRATe?

Function

These query commands return the summary table values (except for Marker) for any of the four traces:

  • OTA Tx

  • OTA Rx

  • IP Tx

  • IP Rx

The query results for each trace will be returned in a comma-separated string with values in the following order:

  • Average data throughput (bps)

  • Current data throughput (bps)

  • Peak data throughput (bps)

  • Total data transfer (bytes)

Query

Range: 0 to 9999999999, 9.91 E+37

Resolution: 1

Requirements

Test Application Revision: A.05.00 and above

Programming Example

"CALL:COUNt:DTMonitor:OTATx:DRATe?"

"CALL:COUNt:DTMonitor:OTARx:DRATe?"

"CALL:COUNt:DTMonitor:IPTX:DRATe?"

"CALL:COUNt:DTMonitor:IPRX:DRATe?"

CALL:COUNt:DTMonitor:OTATx:TRACe?

CALL:COUNt:DTMonitor:OTARx:TRACe?

CALL:COUNt:DTMonitor:IPTX:TRACe?

CALL:COUNt:DTMonitor:IPRX:TRACe?

Function

These query commands return the trace data values for any of the four traces:

  • OTA Tx

  • OTA Rx

  • IP Tx

  • IP Rx

The query results for each trace will be returned in a 600 comma-separated trace values for spreadsheet plotting. These values represent the most recent 10 minute trace data collection period.

Query

Range: 0 to 9999999999, 9.91 E+37

Resolution: 1

Requirements

Test Application Revision: A.05.00 and above

Programming Example

"CALL:COUNt:DTMonitor:OTATx:TRACe?"

"CALL:COUNt:DTMonitor:OTARx:TRACe?"

"CALL:COUNt:DTMonitor:IPTX:TRACe?"

"CALL:COUNt:DTMonitor:IPRX:TRACe?"

CALL:COUNt:DTMonitor:OTATx:TRACe:HISTory?

CALL:COUNt:DTMonitor:OTARx:TRACe:HISTory?

CALL:COUNt:DTMonitor:IPTX:TRACe:HISTory?

CALL:COUNt:DTMonitor:IPRX:TRACe:HISTory?

Function

These query commands return the trace data values for any of the four traces:

  • OTA Tx

  • OTA Rx

  • IP Tx

  • IP Rx

The query results for each trace will be returned in a 600 comma-separated trace values for the last 10-minute trace data collection period captured since the data throughput monitor was enabled or cleared. To find out how many 10-minute periods have elapsed,

Query

Range: 0 to 9999999999, 9.91 E+37

Resolution: 1

Requirements

Test Application Revision: A.05.00 and above

Programming Example

"CALL:COUNt:DTMonitor:OTATx:TRACe:HISTory?"

"CALL:COUNt:DTMonitor:OTARx:TRACe:HISTory?"

"CALL:COUNt:DTMonitor:IPTX:TRACe:HISTory?"

"CALL:COUNt:DTMonitor:IPRX:TRACe:HISTory?"

CALL:COUNt:MS:IP[:ALL][:TOTal]?

Function | Queries the number of IP (Internet Protocol) packets and bytes transferred between the test set and the wireless device on both the uplink and downlink. Results are returned in the following order: 1. Downlink packets 2. Downlink bytes 3. Uplink packets 4. Uplink bytes Power up, full preset, or the clear counters command will clear the counters. When IP counters reach their maximum value, they remain at that value until cleared.
Query | Range: 0 to 9999999999, 9.91 E+37
Requirements | Test Application Revision: A.05.00 and above
Programming Example | "CALL:COUNt:MS:IP?"

CALL:COUNt:MS:IP:RX:[TOTal]?

Function

Sets/queries the DUT IP RX Packets.

Power up, full preset, or the clear counters command (CALL:COUNt:CLEar:MS:IP) will clear these IP counters.

When IP counters reach their maximum value (10,000,000,000), they remain at that value until cleared.

Query

Range: 0 to 9999999999, 9.91 E+37

Requirements

Test Application Revision: A.05.00 and above

Programming Example

"CALL:COUNt:MS:IP:RX?"

CALL:COUNt:MS:IP:TX:[TOTal]?

Function

Sets/queries the DUT IP TX Packets.

Power up, full preset, or the clear counters command (CALL:COUNt:CLEar:MS:IP) will clear these IP counters.

When IP counters reach their maximum value (10,000,000,000), they remain at that value until cleared.

Query

Range: 0 to 9999999999, 9.91 E+37

Requirements

Test Application Revision: A.05.00 and above

Programming Example

"CALL:COUNt:MS:IP:TX?"


CALL:DOWNlink

Last updated: March 10, 2010

  • CALL:DOWNlink:DPCHannel:MIDamble:MODE

For more information on the GPIB Command conventions, see GPIB Command conventions

CALL:DOWNlink:DPCHannel:MIDamble:MODE

Function | Sets/queries the TD-SCDMA DL Dpchannel Midamble Mode.
Setting | Range: DEFault| COMMon
Query | Range: DEF| COMM
*RST Setting | DEFault
Requirements | Test Application Revision: A.04.00 and above
Programming Example | "CALL:DOWNlink:DPCHannel:MIDamble:MODE DEFault"


CALL:DPCHannel

  • CALL[:CELL]:DPCHannel:LEVel

  • CALL[:CELL]:DPCHannel:STATe

  • CALL[:CELL]:DPCHannel[:SLEVel]

  • CALL:DPCHann el:ORTHogonal:LEVel?

  • CALL:DPCHannel:ORTHogonal:STATe?

  • CALL:DPCHannel:TYPE

For more information on the GPIB Command conventions, see GPIB Command conventions

CALL[:CELL]:DPCHannel:LEVel

Function | Sets/queries the DL DPCH level offset. The function is used in active cell operating mode.
Setting | Range:-30.00 dB to 0 dB Resolution:0.01
Query | Same as setting
*RST Setting | 0dB
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "CALL:DPCHannel:LEVEL -7"

CALL[:CELL]:DPCHannel:STATe

Function | Sets/queries the DL DPCH level state. The function is used in active cell operating mode.
Setting | Range:On|Off
Query | Range:1|0
*RST Setting | On
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "CALL:DPCHannel:STATe ON"

CALL[:CELL]:DPCHannel[:SLEVel]

Function | The setting form of this command performs two functions: (1) sets the DL DPCH level and (2) sets DL DPCH level state to on. The query form of this command returns the DL DPCH level. The function is used in active cell operating mode.
Setting | Range:-30.00 dB to 0 dB Resolution:0.01
Query | Same as setting
*RST Setting | 0dB
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "CALL:DPCHannel -7"

CALL:DPCHannel:ORTHogonal:LEVel?

Function | Queries the calculated DPCHo Power level.
Query | returned value
*RST Setting | 9.91E37
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "CALL:DPCHannel:ORTHogonal:LEVel?"

CALL:DPCHannel:ORTHogonal:STATe?

Function | Queries the calculated DPCHo Power State.
Query | 0|1
*RST Setting | 1
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "CALL:DPCHannel:ORTHogonal:STATe?"

CALL:DPCHannel:TYPE

Function | THIS COMMAND IS OBSOLETE. Please use the CALL:SERVice:RBTest:RAB command to set/query channel type. Sets/queries the Channel Type setting.
Setting | Range: SRMC12 | MRMC12
Query | same as setting
*RST Setting | SRMC12
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "CALL:DPCHannel:TYPE SRMC12"


CALL:DRX

  • CALL[:CELL]:DRX:CLENgth

The settings below can be set in active cell operating mode only when the call status is Idle, or in other operating modes.

If BCCH Update Page is set to Auto and you change the settings while your UE is camped to the test set, the test set performs a Broadcast Channel (BCCH) Update Procedure ; If BCCH Update Page is set to Inhibit (the default value) and you change the settings while your UE is camped to the test set, the UE is informed to re-read the BCCH to observe the change (see CALL:BCCHannel:UPDAte:PAGE AUTO).

For more information on the GPIB Command conventions, see GPIB Command conventions

CALL[:CELL]:DRX:CLENgth

Function | Sets/queries the DRX cycle length (CS Domain) .
Setting | Range: FRAMes64 | FRAMes128 | FRAMes256 | FRAMes512
Query | Range: FRAM64|FRAM128|FRAM256|FRAM512
*RST Setting | FRAM64
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "CALL:DRX:CLENgth FRAMes512"


CALL:DTCHannel

  • CALL:DTCHannel:DATA

For more information on the GPIB Command conventions, see GPIB Command conventions

CALL:DTCHannel:DATA

Function | Sets/queries the downlink dedicated traffic channel's data type.
Setting | Range:PRBS9 | PRBS15 | INCRement | ZERos | ONEs |ALTernating
Query | Range:PRBS9 | PRBS15 | INCR | ZER | ONE |ALT
*RST Setting | PRBS15
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "CALL:DTCHannel:DATA PRBS9"


CALL:EHIChannel

Last updated: March 10, 2010

  • CALL[:CELL]:EHIChannel:BEHavior

For more information on the GPIB Command conventions, see GPIB Command conventions

CALL[:CELL]:EHIChannel:BEHavior

Function | Sets/queries the EHICH behavior. This setting controls what the application sends on the E-HICH0 channel (EI=0).
Setting | Range: ACKS | NACKs
Query | Range: ACKS | NACK
*RST Setting | ACK
Requirements | Test Application Revision: A.05.00 and above
Programming Example | "CALL:EHIChannel:BEHavior ACKS"


CALL:END

  • CALL:END[:AUTO]

For more information on the GPIB Command conventions, see GPIB Command conventions

CALL:END[:AUTO]

Function | Disconnects the active service. The function is used in active cell mode: if call status is Idle, the function is ignored; else if call status is Connected, the function initiates a BS Release procedure; else the function aborts the current call processing operations and returns call status to Idle.
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "CALL:END"


CALL:HANDoff

  • CALL:HANDoff[:IMMediate]

  • CALL:HANDoff:SYSTem[:GSM][:IMMediate]

  • CALL:HANDoff:SYSTem[:GSM]:ATIMe

  • CALL:HANDoff:SYSTem[:GSM]:RLCAck:WAIT[:STATe]

For more information on the GPIB Command conventions, see GPIB Command conventions

CALL:HANDoff[:IMMediate]

Function | Initiates a handoff while the call status is Connected in active cell operating mode. A handoff initiates a physical channel reconfiguration of changing the UARFCN and the power control step size. See Physical Channel Reconfiguration.
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "CALL:HANDoff"

CALL:HANDoff:SYSTem[:GSM][:IMMediate]

Function | Initiates a handoff to the GSM system when the test set is in RB Test mode. See System Handover.
Requirements | Test Application Revision: A.03.00 and above
Programming Example | "CALL:HANDoff:SYSTem:GSM"

CALL:HANDoff:SYSTem[:GSM]:ATIMe

Function | Sets/queries the activation time of a TD-SCDMA to GSM handover. The UE will wait the specified number of frames before trying to find the GSM cell.
Setting | Range: 0 to 255 Resolution: 1
Query | Same as setting
*RST Setting | 200
Requirements | Test Application Revision: A.03.00 and above
Programming Example | "CALL:HANDoff:SYSTem:GSM:ATIMe 200"

CALL:HANDoff:SYSTem[:GSM]:RLCAck:WAIT[:STATe]

Function | Sets/queries the Wait for RLC Ack of Handover setting. This setting determines whether the test set will immediately handover to GSM upon the reception of the handover command, or wait until the RLC Ack from UE to do the handover.
Setting | Range: 1|ON|0|OFF
Query | Range: 1|0
*RST Setting | 1(On)
Requirements | Test Application Revision: A.03.00 and above
Programming Example | "CALL:HANDoff:SYSTem:GSM:RLCAck:WAIT On"


CALL:HSDPa

Last updated: March 10, 2010

  • CALL:HSDPa:HRNTi[:PRIMary]

  • CALL:HSDPa:HRNTi:ALTernate:HSSCCH2|3|4

  • CALL:HSDPa:MACHs:NTRans

  • CALL:HSDPa:MACHs:RVSequence

  • CALL:HSDPa:MACHs:SDTX:RBEHavior

  • CALL:HSDPa:MACHs:T1

  • CALL:HSDPa:MACHs:WSIZe[:VALue]

  • CALL:HSDPa:RTIMe:RESults:ALL?

  • CALL:HSDPa:MS:REPorted:HSDSchannel:CATegory?

  • CALL:HSDPa:SERVice:PSData:DOWNlink:DPCHannel:TSLot

  • CALL:HSDPa:SERVice:PSData:HSDSchannel:CONFig[:TYPE]

  • CALL:HSDPa:SERVice:PSData:HSPDschannel:CCODe:NUMBer

  • CALL:HSDPa:SERVice:PSData:HSPDschannel:OVSF

  • CALL:HSDPa:SERVice:PSData:HSPDschannel:TSNumber

  • CALL:HSDPa:SERVice:PSData:HSPDschannel:TSSTart

  • CALL:HSDPa:SERVice:PSData:MACD:PDUSize

  • CALL:HSDPa:SERVice:PSData:UDEFined:MODulation[:TYPE]

  • CALL:HSDPa:SERVice:PSData:UDEFined:TBSize:INDex

  • CALL:HSDPa:SERVice:RBTest:CNDomain

  • CALL:HSDPa:SERVice:RBTest:HSDSchannel:CONFig[:TYPE]

  • CALL:HSDPa:SERVice:RBTest:HSDSchannel:DATA?

  • CALL:HSDPa:SERVice:RBTest:RMC:MACD:PDUSize

  • CALL:HSDPa:SERVice:RBTest:RMC:TYPE

For more information on the GPIB Command conventions, see GPIB Command conventions

CALL:HSDPa:HRNTi[:PRIMary]

Function | Sets/queries the Primary H-RNTI.
Setting | Range: 0 to FFFF (1 to 4 characters from the set 0123456789AaBbCcDdEeFf)
Query | Range: "0000" to "FFFF" (The return string is always 4 characters from the set 0123456789ABCDEF, enclosed by double quotes.)
*RST Setting | "0000"
Requirements | Test Application Revision: A.03.00 and above
Programming Example | "CALL:HSDPa:HRNTi '0000'"

CALL:HSDPa:HRNTi:ALTernate:HSSCCH2|3|4

Function | Sets/queries the HS-SCCH2-4 H-RNTI. See H-RNTI Parameters.
Setting | Range: 0 to FFFF (1 to 4 characters from the set 0123456789AaBbCcDdEeFf)
Query | Range: "0000" to "FFFF" (The return string is always 4 characters from the set 0123456789ABCDEF, enclosed by double quotes.)
*RST Setting | HS-SCCH2 H-RNTI: "5555" HS-SCCH3 H-RNTI: "AAAA" HS-SCCH4 H-RNTI: "FFFF"
Requirements | Test Application Revision: A.04.00 and above
Programming Example | "CALL:HSDPa:HRNTi:ALTernate:HSSCCH3 'AAAA'"

CALL:HSDPa:MACHs:NTRans

Function | Sets/queries the MAC-hs Number of Transmissions.
Setting | Range: 1-8
Query | Range: 1-8
*RST Setting | 4
Requirements | Test Application Revision: A.03.00 and above
Programming Example | "CALL:HSDPa:MACHs:NTRans 4"

CALL:HSDPa:MACHs:RVSequence

Function | Sets/queries the RV Sequence.
Setting | Range: Comma separated list of 1 to 8 characters from the set 01234567.
Query | Range: Comma separated list of 8 characters from the set 01234567, enclosed by double quotes (if you enter fewer than 8 characters, the query result will fill the remaining characters with zeros).
*RST Setting | '6,2,1,5,0,0,0,0'
Requirements | Test Application Revision: A.03.00 and above
Programming Example | "CALL:HSDPa:MACHs:RVSequence '6,2,1,5,0,0,0,0'"

CALL:HSDPa:MACHs:SDTX:RBEHavior

Function | Sets/queries the statDTX Reception Behavior.
Setting | Range: ACK | NACK | SDTX
Query | Range: ACK | NACK | SDTX
*RST Setting | SDTX
Requirements | Test Application Revision: A.03.00 and above
Programming Example | "CALL:HSDPa:MACHs:SDTX:RBEHavior SDTX"

CALL:HSDPa:MACHs:T1

Function | Sets/queries the MAC hs T1 Timer.
Setting | Range: 10 | 20 | 30 | 40 | 50 | 60 | 70 | 80 | 90 | 100 | 120 | 140 | 160 | 200 | 300 | 400 ms
Query | Same as setting
*RST Setting | 50 MS
Requirements | Test Application Revision: A.03.00 and above
Programming Example | "CALL:HSDPa:MACHs:T1 50 MS"

CALL:HSDPa:MACHs:WSIZe[:VALue]

Function | Sets/queries the MAC hs Window Size.
Setting | Range: PDU4 |PDU6 | PDU8 | PDU12 | PDU16 | PDU24 | PDU32
Query | Range: PDU4 |PDU6 | PDU8 | PDU12 | PDU16 | PDU24 | PDU32
*RST Setting | PDU16
Requirements | Test Application Revision: A.03.00 and above
Programming Example | "CALL:HSDPa:MACHs:WSIZe PDU16"

CALL:HSDPa:RTIMe:RESults:ALL?

Function | Queries the HSDPA Real Time Results in the following order: BLER Rate, Throughput, ACKs, NACKS, statDTX, Block Transmitted
Query | Range: BLER Rate: 0 to 100 Percent, 9.91E +37 (Null) Throughput: 0 to 99999.99 Kbps, 9.91E +37 (Null) ACKs: 0 to 200000 Blocks, 9.91E +37 (Null) NACKS: 0 to 200000 Blocks, 9.91E +37 (Null) statDTX: 0 to 200000 Blocks, 9.91E +37 (Null) Block Transmitted: 0 to 200000 Blocks, 9.91E +37 (Null)
*RST Setting | 9.91E +37, 9.91E +3, 9.91E +3, 9.91E +3, 9.91E +3, 9.91E +3
Requirements | Test Application Revision: A.03.00 and above
Programming Example | "CALL:HSDPa:RTIMe:RESults:ALL?"

CALL:HSDPa:MS:REPorted:HSDSchannel:CATegory?

Function | Sets/queries the UE Reported HS-DSCH Category. See UE Reported HS-DSCH Category.
Query | Range: 1 to 64, 9.91E +37 (Null)
*RST Setting | 9.91E +37 (Null)
Requirements | Test Application Revision: A.03.00 and above
Programming Example | "CALL:HSDPa:MS:REPorted:HSDSchannel:CATegory?"

CALL:HSDPa:SERVice:PSData:DOWNlink:DPCHannel:TSLot

Function | Sets/queries the PS Data DL DPCH/HS-SCCH Timeslot Configuation.
Setting | Range: TS0 | TS6
Query | Range: TS0 | TS6
*RST Setting | TS0
Requirements | Test Application Revision: A.05.00 and above
Programming Example | "CALL:HSDPa:SERVice:PSData:DOWNlink:DPCHannel:TSLot TS0"

CALL:HSDPa:SERVice:PSData:HSDSchannel:CONFig[:TYPE]

Function | Sets/queries the PS Data Configuration Type.
Setting | Range: RCQI | UDEFined
Query | Range: RCQI | UDEF
*RST Setting | RCQI
Requirements | Test Application Revision: A.05.00 and above
Programming Example | "CALL:HSDPa:SERVice:PSData:HSDSchannel:CONFig RCQI"

CALL:HSDPa:SERVice:PSData:HSPDschannel:CCODe:NUMBer

Function | Sets/queries the Number of PS Data HS-PDSCH Channel Code.
Setting | Range: 1-16
Query | Range: 1-16
*RST Setting | 16
Requirements | Test Application Revision: A.05.00 and above
Programming Example | "CALL:HSDPa:SERVice:PSData:HSPDschannel:CCODe:NUMBer 16"

CALL:HSDPa:SERVice:PSData:HSPDschannel:OVSF

Function | Sets/queries the PS Data HS-PDSCH OVSF.
Setting | Range: SF1 | SF16
Query | Range: SF1 | SF16
*RST Setting | SF1
Requirements | Test Application Revision: A.05.00 and above
Programming Example | "CALL:HSDPa:SERVice:PSData:HSPDschannel:OVSF SF1"

CALL:HSDPa:SERVice:PSData:HSPDschannel:TSNumber

Function | Sets/queries the number of timeslots for PS Data HS-PDSCH.
Setting | Range: 1 - 5
Query | Range: 1 - 5
*RST Setting | 5
Requirements | Test Application Revision: A.05.00 and above
Programming Example | "CALL:HSDPa:SERVice:PSData:HSPDschannel:TSNumber 5"

CALL:HSDPa:SERVice:PSData:HSPDschannel:TSSTart

Function | Sets/queries the start slot of PS Data HS-PDSCH.
Setting | Range: TS2 | TS3 | TS4 |TS5 | TS6
Query | Range: TS2 | TS3 | TS4 |TS5 | TS6
*RST Setting | TS2
Requirements | Test Application Revision: A.05.00 and above
Programming Example | "CALL:HSDPa:SERVice:PSData:HSPDschannel:TSSTart TS2"

CALL:HSDPa:SERVice:PSData:MACD:PDUSize

Function | Sets/queries the PS Data MAC-d PDU Size.
Setting | Range: BITS336 | BITS656
Query | Range: BITS336 | BITS656
*RST Setting | BITS336
Requirements | Test Application Revision: A.05.00 and above
Programming Example | "CALL:HSDPa:SERVice:PSData:MACD:PDUSize BITS336"

CALL:HSDPa:SERVice:PSData:UDEFined:MODulation[:TYPE]

Function | Sets/queries the PS Data User Defined Modulation TypePS Data.
Setting | Range: QPSK | QAM16
Query | Range: QPSK | QAM16
*RST Setting | QAM16
Requirements | Test Application Revision: A.05.00 and above
Programming Example | "CALL:HSDPa:SERVice:PSData:UDEFined:MODulation QAM16"

CALL:HSDPa:SERVice:PSData:UDEFined:TBSize:INDex

Function | Sets/queries the PS Data User Defined TB Index.
Setting | Range: 8-63
Query | Range: 8-63
*RST Setting | 63
Requirements | Test Application Revision: A.05.00 and above
Programming Example | "CALL:HSDPa:SERVice:PSData:UDEFined:TBSize:INDex 63"

CALL:HSDPa:SERVice:RBTest:CNDomain

Function | Sets/queries the HSDPA CN Domain.
Setting | Range: PSDomain | CSPSdomain
Query | Range: PSD| CSPS
*RST Setting | PSD
Requirements | Test Application Revision: A.03.00 and above
Programming Example | "CALL:HSDPa:SERVice:RBTest:CNDomain PSD"

CALL:HSDPa:SERVice:RBTest:HSDSchannel:CONFig[:TYPE]

Function | Sets/queries the HS-DSCH Configuration Type.
Setting | Range: RMC | VRC | CDETect
Query | Range: RMC | VRC | CDET
*RST Setting | RMC
Requirements | Test Application Revision: A.04.00 and above
Programming Example | "CALL:HSDPa:SERVice:RBTest:HSDSchannel:CONFig RMC"

CALL:HSDPa:SERVice:RBTest:HSDSchannel:DATA

Function | Sets/queries the HS-DSCH Data Pattern.
Setting | Range: PRBS23 | PRBS20 | PRBS15 | PRBS9 |ZERos | ONES | INCRement | ALTernating
Query | Same as setting
*RST Setting | PRBS20
Requirements | Test Application Revision: A.03.00 and above
Programming Example | "CALL:HSDPa:SERVice:RBTest:HSDSchannel:DATA PRBS20"

CALL:HSDPa:SERVice:RBTest:RMC:MACD:PDUSize

Function | Sets/queries the MAC_d PDU Size.
Setting | Range: BITS336 | BITS656 | MHSMax
Query | Same as setting
*RST Setting | MHSMax
Requirements | Test Application Revision: A.03.00 and above
Programming Example | "CALL:HSDPa:SERVice:RBTest:RMC:MACD:PDUSize MHSMax"

CALL:HSDPa:SERVice:RBTest:RMC:TYPE

Function | Sets/queries the RMC Type setting.
Setting | Range: M0P5QPSK | M1P1QPSK | M1P1QAM | M1P6QPSK | M1P6QAM | M2P2QPSK | M2P2QAM | M2P8QPSK | M2P8QAM | M2P8MT
Query | Same as setting
*RST Setting | M2P8QAM
Requirements | Test Application Revision: A.03.00 and above
Programming Example | "CALL:HSDPa:SERVice:RBTest:RMC:TYPE M2P8QAM"


CALL:HSUPa

Last updated: March 10, 2010

  • CALL:HSUPa:ERNTi[:PRIMary]

  • CALL:HSUPa:MS:REPorted:EDCHannel:CATegory?

  • CALL:HSUPa:SERVice:RBTest:FRC:TYPE

  • CALL:HSUPa:SERVice:RBTest:HARQ:RETRans:MAXimum

  • CALL:HSUPa:SERVice:RBTest:HARQ:RETRans:TIMer

  • CALL:HSUPa:SERVice:RBTest:RLCSdu:SIZE

  • CALL:HSUPa:SGRant:ABSolute:VALue

For more information on the GPIB Command conventions, see GPIB Command conventions

CALL:HSUPa:ERNTi[:PRIMary]

Function | Sets/queries the Primary E-RNTI (in Hex). This setting determines the primary E-RNTI that is used on the E-AGCH. This is the ID that test set will use when it is to transmit data to the UE in Active Cell.
Setting | Range: 0 to FFFF
Query | Range: 0 to FFFF
*RST Setting | AAAA
Requirements | Test Application Revision: A.05.00 and above
Programming Example | "CALL:HSUPa:ERNTi 'AAAA'"

CALL:HSUPa:MS:REPorted:EDCHannel:CATegory?

Function | Sets/queries the UE Reported E-DCH Category.
Query | Range: 1-6, NAN
*RST Setting | NAN
Requirements | Test Application Revision: A.05.00 and above
Programming Example | "CALL:HSUPa:MS:REPorted:EDCHannel:CATegory?"

CALL:HSUPa:SERVice:RBTest:FRC:TYPE

Function | Sets/queries the E-DCH FRC Type. This is defined according to 3GPP TS 34.122 Annex C.6.1.2.1 to C.6.2.1.3. This setting can only be changed while the Call Status is IDLE.
Setting | Range: FRC1a | FRC1b | FRC2 | FRC3
Query | Range: FRC1a | FRC1b | FRC2 | FRC3
*RST Setting | FRC3
Requirements | Test Application Revision: A.05.00 and above
Programming Example | "CALL:HSUPa:SERVice:RBTest:FRC:TYPE FRC3"

CALL:HSUPa:SERVice:RBTest:HARQ:RETRans:MAXimum

Function | Sets/queries the E-DCH Max Number of Retransmission. This setting determines the maximum number of retransmissions a HARQ process in the UE that will perform for a given block of data before giving up and moving onto a new block of data.
Setting | Range: 0 to 15
Query | Range: 0 to 15
*RST Setting | 3
Requirements | Test Application Revision: A.04.00 and above
Programming Example | "CALL:HSUPa:SERVice:RBTest:HARQ:RETRans:MAXimum 3"

CALL:HSUPa:SERVice:RBTest:HARQ:RETRans:TIMer

Function | Sets/queries the E-DCH Retransmission Timer. This setting determines the retransmission timer a HARQ process in the UE that will wait for the acknowledgement of a given block of data before giving up and moving onto a new block of data.
Setting | Range: MS10 | MS15 | MS20 | MS25 | MS30 | MS35 | MS40 | MS45 | MS50 | MS55 | MS60 | MS65 | MS70 | MS75 | MS80 | MS85 | MS90 | MS95 | MS100 | MS110 | MS120 | MS140 | MS160 | MS200 | MS240 | MS280 | MS320 | MS400 | MS480 | MS560
Query | Range: MS10 | MS15 | MS20 | MS25 | MS30 | MS35 | MS40 | MS45 | MS50 | MS55 | MS60 | MS65 | MS70 | MS75 | MS80 | MS85 | MS90 | MS95 | MS100 | MS110 | MS120 | MS140 | MS160 | MS200 | MS240 | MS280 | MS320 | MS400 | MS480 | MS560
*RST Setting | MS60
Requirements | Test Application Revision: A.05.00 and above
Programming Example | "CALL:HSUPa:SERVice:RBTest:HARQ:RETRans:TIMer MS60"

CALL:HSUPa:SERVice:RBTest:RLCSdu:SIZE

Function | Sets/queries the RB Test Mode Uplink E-DCH RLC SDU size. This setting determines the uplink RLC SDU size specified for the E-DCH transport channel in the Close UE Test Loop message sent during a HSUPA RB Test Mode call. The default is chosen to ensure the maximum throughput under FRC2 can be achieved (in this case, the loopback RLC SDU would be just fit into 8 UM RLC PDUs. The E-DCH RLC SDU size to achieve maximum throughput under other FRCs is less than FRC2’s).
Setting | Range: 72 to 2608
Query | Range: 72 to 2608
*RST Setting | 2608
Requirements | Test Application Revision: A.05.00 and above
Programming Example | "CALL:HSUPa:SERVice:RBTest:RLCSdu:SIZE 2608"

CALL:HSUPa:SGRant:ABSolute:VALue

Function | Sets/queries the E-AGCH Absolute Grant (Power) Value. This parameter controls the next absolute grant that the test set will transmit to the UE on E-AGCH during a HSPA connection. The UE will interpret this value according to the Table 26A in 3GPP 25.222 s4.10.1.1.
Setting | Range: 0 ~ 31
Query | Range: 0 ~ 31
*RST Setting | 31
Requirements | Test Application Revision: A.05.00 and above
Programming Example | "CALL:HSUPa:SGRant:ABSolute:VALue 31"


CALL:IDENtity

  • CALL[:CELL]:IDENtity[:SELected]

  • CALL[:CELL]:IDENtity:TATDscdma

The settings below can be set in active cell operating mode only when the call status is Idle, or in other operating modes.

If BCCH Update Page is set to Auto and you change the settings while your UE is camped to the test set, the test set performs a Broadcast Channel (BCCH) Update Procedure ; If BCCH Update Page is set to Inhibit (the default value) and you change the settings while your UE is camped to the test set, the UE is informed to re-read the BCCH to observe the change (see CALL:BCCHannel:UPDAte:PAGE AUTO).

For more information on the GPIB Command conventions, see GPIB Command conventions

CALL[:CELL]:IDENtity:TATDscdma

Function | Sets/queries Cell Identity when using the TD-SCDMA application.
Setting | Range: 0 to 268 435 455
Query | Range: 0 to 268 435 455
*RST Setting | 1
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "CALL:CELL:IDENtity:TATDscdma 1"

CALL[:CELL]:IDENtity[:SELected]

Function | Sets/queries Cell Identity for the currently selected application.
Setting | Range: 0 to 268 435 455
Query | Range: 0 to 268 435 455
*RST Setting | 1
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "CALL:CELL:IDENtity 1"


CALL:LACode

  • CALL[:CELL]:LACode[:SELected]

  • CALL[:CELL]:LACode:TATDscdma

The settings below can be set in active cell operating mode only when the call status is Idle, or in other operating modes.

If BCCH Update Page is set to Auto and you change the settings while your UE is camped to the test set, the test set performs a Broadcast Channel (BCCH) Update Procedure ; If BCCH Update Page is set to Inhibit (the default value) and you change the settings while your UE is camped to the test set, the UE is informed to re-read the BCCH to observe the change (see CALL:BCCHannel:UPDAte:PAGE AUTO).

For more information on the GPIB Command conventions, see GPIB Command conventions

CALL[:CELL]:LACode:TATDscdma

Function | Sets/queries the Local Area Code (LAC) when using the TD-SCDMA application.
Setting | Range: 0 to 65535
Query | Range: 0 to 65535
*RST Setting | 1
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "CALL:CELL:LACODE:TATDscdma 310"

CALL[:CELL]:LACode[:SELected]

Function | Sets/queries the Local Area Code (LAC) for the currently selected application.
Setting | Range: 0 to 65535
Query | Range: 0 to 65535
*RST Setting | 1
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "CALL:CELL:LACODE 310"


CALL:MCCode

  • CALL[:CELL]:MCCode[:SELected]

  • CALL[:CELL]:MCCode:TATDscdma

The settings below can be set in active cell operating mode only when the call status is Idle, or in other operating modes.

If BCCH Update Page is set to Auto and you change the settings while your UE is camped to the test set, the test set performs a Broadcast Channel (BCCH) Update Procedure ; If BCCH Update Page is set to Inhibit (the default value) and you change the settings while your UE is camped to the test set, the UE is informed to re-read the BCCH to observe the change (see CALL:BCCHannel:UPDAte:PAGE AUTO).

For more information on the GPIB Command conventions, see GPIB Command conventions

CALL[:CELL]:MCCode:TATDscdma

Function | Sets/queries the Mobile Country Code (MCC) when using the TD-SCDMA application.
Setting | Range: 0 to 999
Query | Range: 0 to 999
*RST Setting | 460
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "CALL:CELL:MCCODE:TATDscdma 460"

CALL[:CELL]:MCCode[:SELected]

Function | Sets/queries the Mobile Country Code (MCC) for the currently selected application.
Setting | Range: 0 to 999
Query | Range: 0 to 999
*RST Setting | 460
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "CALL:CELL:MCCODE 460"


CALL:MNCode

  • CALL[:CELL]:MNCode[:SELected]

  • CALL[:CELL]:MNCode:TATDscdma

The settings below can be set in active cell operating mode only when the call status is Idle, or in other operating modes.

If BCCH Update Page is set to Auto and you change the settings while your UE is camped to the test set, the test set performs a Broadcast Channel (BCCH) Update Procedure ; If BCCH Update Page is set to Inhibit (the default value) and you change the settings while your UE is camped to the test set, the UE is informed to re-read the BCCH to observe the change (see CALL:BCCHannel:UPDAte:PAGE AUTO).

For more information on the GPIB Command conventions, see GPIB Command conventions

CALL[:CELL]:MNCode:TATDscdma

Function | Sets/queries the Mobile Network Code (MNC) when using the TD-SCDMA application.
Setting | Range: 0 to 999
Query | Range: 0 to 999
*RST Setting | 2
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "CALL:CELL:MNCODE:TATDscdma 2"

CALL[:CELL]:MNCode[:SELected]

Function | Sets/queries the Mobile Network Code (MNC) for the currently selected application.
Setting | Range: 0 to 999
Query | Range: 0 to 999
*RST Setting | 2
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "CALL:CELL:MNCODE 2"


CALL:MS

  • CALL:MS:DNSServer:PRIMary:IP:ADDRess[:IP4]

  • CALL:MS:DNSServer:SECondary:IP:ADDRess[:IP4]

  • CALL:MS:LOOPback:SCENario

  • CALL:MS:POWer:TARGet[:AMPLitude]

  • CALL:MS:REPorted[:CELL]:PRIMary:CCPChannel:RSCP?

  • CALL:MS:REPorted:ASTRatum:RINDicator?

  • CALL:MS:REPorted:AUTHenticate:FAILcause?

  • CALL:MS:REPorted:CLEar[:ALL][:SELected]

  • CALL:MS:REPorted:CLEar[:ALL]:TATDscdma

  • CALL:MS:REPorted:IMEI[:SELected]?

  • CALL:MS:REPorted:IMEI:CALCulated[:SELected]?

  • CALL:MS:REPorted:IMEI:CALCulated:TATDscdma?

  • CALL:MS:REPorted:IMEI:TATDscdma?

  • CALL:MS:REPorted:IMSI[:SELected]?

  • CALL:MS:REPorted:IMSI:TATDscdma?

  • CALL:MS:REPorted:MEASurement:REQuest

  • CALL:MS:REPorted:PCLass[:SELected]?

  • CALL:MS:REPorted:PCLass:TATDscdma?

  • CALL:MS:REPorted:UPPChannel:DETected:SIGnature?

For more information on the GPIB Command conventions, see GPIB Command conventions

CALL:MS:DNSServer:PRIMary:IP:ADDRess[:IP4]

Function | Sets/queries the DUT Primary DNS Server IP Address.
Setting | Range: 0 to 15 characters formatted as A.B.C.D The range of values for A = 0 to 126 and 128 to 223. The range of values for B, C, and D = 0 to 255.
Query | Same as setting
*RST Setting | Non-volatile
Requirements | Test Application Revision: A.05.00 and above
Programming Example | "CALL:MS:DNSServer:PRIMary:IP:ADDRess '192.168.1.43'"

CALL:MS:DNSServer:SECondary:IP:ADDRess[:IP4]

Function | Sets/queries the DUT Secondary DNS Server IP Address.
Setting | Range: 0 to 15 characters formatted as A.B.C.D The range of values for A = 0 to 126 and 128 to 223. The range of values for B, C, and D = 0 to 255.
Query | Same as setting
*RST Setting | Non-volatile
Requirements | Test Application Revision: A.05.00 and above
Programming Example | "CALL:MS:DNSServer:SECondary:IP:ADDRess '192.168.1.44'"

CALL:MS:LOOPback:SCENario

Function | Sets/queries the UE loopback senario. See UE Loopback Scenario.
Setting | Range:TMTYpe1 | AMTYpe1 | TYPE2
Query | Range:TMTY1 | AMTY1 | TYPE2
*RST Setting | TMTY1
Requirements | Test Application Revision: A.03.00 and above
Programming Example | "CALL:MS:LOOPback:SCENario TMTY1"

CALL:MS:POWer:TARGet[:AMPLitude]

Function | Sets/queries the expected power level from the UE.
Setting | Range:-65 dBm to +30dBm Resolution:1 dB
Query | Range:-65 to +30
*RST Setting | -10
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "CALL:MS:POWER:TARGET:AMPLITUDE -20"

CALL:MS:REPorted[:CELL]:PRIMary:CCPChannel:RSCP?

Function | Queries the TD-SCDMA Primary CCPCH RSCP Report. This query returns an interger mapping to a range of RSCP values. See UE Measurement Control.
Query | Range: -5 to 91, 9.91E +37 (Null)
*RST Setting | 9.91E +37
Requirements | Test Application Revision: A.03.00 and above
Programming Example | "CALL:MS:REPorted:PRIMary:CCPChannel:RSCP?"

CALL:MS:REPorted:ASTRatum:RINDicator?

Function | Queries the UE reported Access Stratum Release Indicator. This results indicates which specification release that the UE supports. See UE Access Stratum Rel Ind.
Query | Range: 4 to 8, 9.91E +37 (Null)
*RST Setting | 9.91E +37
Requirements | Test Application Revision: A.03.00 and above
Programming Example | "CALL:MS:REPorted:ASTRatum:RINDicator?"

CALL:MS:REPorted:AUTHenticate:FAILcause?

Function | Queries the UE reported failure cause. See UE Reported Failure Cause.
Query | Range: 1 to 255, 9.91E +37 (Null)
*RST Setting | 9.91E +37
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "CALL:MS:REPorted:AUTHenticate:FAILcause?"

CALL:MS:REPorted:CLEar[:ALL][:SELected]

Function | Clears the UE (mobile) reported information for currently selected application.
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "CALL:MS:REPorted:CLEar"

CALL:MS:REPorted:CLEar[:ALL]:TATDscdma

Function | Clears the UE (mobile) reported information when using the TD-SCDMA application. See Clear UE Info.
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "CALL:MS:REPorted:CLEar:ALL:TATDscdma"

CALL:MS:REPorted:IMEI[:SELected]?

Function | Queries the mobile reported IMEI for the currently selected application. It is the last reported IMEI in the latest call setup procedure.
Query | Range: Range: 0 to FFF FFF FFF FFF FFF or "" (String of 0 to 15 characters, each charater from the set 0123456789ABCDEF)
*RST Setting | "" (null string)
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "CALL:MS:REPorted:IMEI?"

CALL:MS:REPorted:IMEI:CALCulated[:SELected]?

Function | Queries the mobile calculated IMEI for the currently selected application. It is the last reported IMEI in the latest call setup procedure.
Query | Range: Range: 0 to FFF FFF FFF FFF FFF or "" (String of 0 to 15 characters, each charater from the set 0123456789ABCDEF)
*RST Setting | "" (null string)
Requirements | Test Application Revision: A.03.00 and above
Programming Example | "CALL:MS:REPorted:IMEI:CALCulated?"

CALL:MS:REPorted:IMEI:CALCulated:TATDscdma?

Function | Queries the mobile calculated IMEI when using the TD-SCDMA application. It is the last reported IMEI in the latest call setup procedure. See IMEI.
Query | Range: Range: 0 to FFF FFF FFF FFF FFF or "" (String of 0 to 15 characters, each charater from the set 0123456789ABCDEF)
*RST Setting | "" (null string)
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "CALL:MS:REPorted:IMEI:CALCulated:TATDscdma?"

CALL:MS:REPorted:IMEI:TATDscdma?

Function | Queries the mobile reported IMEI when using the TD-SCDMA application. It is the last reported IMEI in the latest call setup procedure. See IMEI.
Query | Range: Range: 0 to FFF FFF FFF FFF FFF or "" (String of 0 to 15 characters, each charater from the set 0123456789ABCDEF)
*RST Setting | "" (null string)
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "CALL:MS:REPorted:IMEI:TATDscdma?"

CALL:MS:REPorted:IMSI[:SELected]?

Function | Queries the mobile reported IMSI for the currently selected application. It is the last reported IMSI in the latest call setup procedure.
Query | Range: 000000 to 999 999 999 999 999 or "" (String of 6 to 15 characters, each character from the set 0123456789)
*RST Setting | "" (null string)
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "CALL:MS:REPorted:IMSI?"

CALL:MS:REPorted:IMSI:TATDscdma?

Function | Queries the mobile reported IMSI when using the TD-SCDMA application. It is the last reported IMSI in the latest call setup procedure. See IMSI.
Query | Range: 000000 to 999 999 999 999 999 or "" (String of 6 to 15 characters, each character from the set 0123456789)
*RST Setting | ""(null string)
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "CALL:MS:REPorted:IMSI:TATDscdma?"

CALL:MS:IP:ADDRess[1]

Function | Sets/queries the DUT (Device Under Test) IP address. This command is used to set up a wireless device's IP address.
Setting | Range: 15 characters formatted as follows: A.B.C.D The range of values for A= 0 to 126 and 128 to 223. The range of values for B,C,D = 0 to 255
Query | Range: 15 characters formatted as follows: A.B.C.D The range of values for A= 0 to 166 and 168 to 223. The range of values for B,C,D = 0 to 255
*RST Setting | Null
Requirements | Test Application Revision: A.05.00 and above
Programming Example | "CALL:MS:IP:ADDRess '10.10.10.20'"

CALL:MS:REPorted:MEASurement:REQuest

Function | Sends a Measurement Control message, which orders the UE to perform measurements on cell. See UE Measurement Control. This action in only allowed when the call status is Connected.
Requirements | Test Application Revision: A.03.00 and above
Programming Example | "CALL:MS:REPorted:MEASurement:REQuest"

CALL:MS:REPorted:PCLass[:SELected]?

Function | Queries the mobile reported Power Class for currently selected application. It is set to the value of UE power class in the last RRC connection setup complete message from UE, and is cleared by the Clear UE Info action.
Query | Range: 1, 2, 3, 4, 9.91E+37
*RST Setting | 9.91E+37
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "CALL:MS:REPorted:PCLass?"

CALL:MS:REPorted:PCLass:TATDscdma?

Function | Queries the mobile reported Power Class when using the TD-SCDMA application. It is set to the value of UE power class in the last RRC connection setup complete message from UE, and is cleared by the Clear UE Info action. See Power Class.
Query | Range: 1, 2, 3, 4, 9.91E+37
*RST Setting | 9.91E+37
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "CALL:MS:REPorted:PCLass:TATDscdma?"

CALL:MS:REPorted:UPPChannel:DETected:SIGnature?

Function | Queries the mobile reported the detected SYNC_DL code index. It is set to the value of SYNC_DL code index in the last random access procedure, and is cleared by the Clear UE Info action. See Detected UpPCH Sig.
Query | Range: 0 to 255, 9.91E+37
*RST Setting | 9.91E+37
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "CALL:MS:REPorted:UPPChannel:DETected:SIGnature?"


CALL:NMOPeration

  • CALL[:CELL]:NMOPeration:TDSCdma

The settings below can be set in active cell operating mode only when the call status is Idle, or in other operating modes.

If BCCH Update Page is set to Auto and you change the settings while your UE is camped to the test set, the test set performs a Broadcast Channel (BCCH) Update Procedure ; If BCCH Update Page is set to Inhibit (the default value) and you change the settings while your UE is camped to the test set, the UE is informed to re-read the BCCH to observe the change (see CALL:BCCHannel:UPDAte:PAGE AUTO).

For more information on the GPIB Command conventions, see GPIB Command conventions

CALL[:CELL]:NMOPeration:TDSCdma

Function | Sets/queries Network Mode of Operation in TD-SCDMA network: If the setting is 1, the network operates in mode I that the MSC (Mobile Switching Centre) and the SGSN (Serving GPRS Support Node) are connected together; else if the setting is 2, the network operates in Mode II that these two network elements are not inter-connected.
Setting | Range: 1|2
Query | Range: 1|2
*RST Setting | 1
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "CALL:CELL:NMOPeration:TDSCdma 2"


CALL:OPERating

  • CALL[:CELL]:OPERating:MODE

For more information on the GPIB Command conventions, see GPIB Command conventions

CALL[:CELL]:OPERating:MODE

Function | Sets/queries the operating mode of the base station emulator.
Setting | Range: CALL (Active Cell ) | TDTest (TD-SCDMA Test Mode) | CW | OFF (Cell Off)
Query | CALL | CW | TDT | OFF
*RST Setting | CALL
Requirements | Test Application Revision: A.01.00 and above Test Application Revision: A.02.00 added CALL and OFF.
Programming Example | "CALL:CELL:OPERating:MODE OFF"


CALL:ORIGinate

  • CALL:ORIGinate[:AUTO]

  • CALL:ORIGinate:DONE?

  • CALL:ORIGinate:OPComplete?

  • CALL:ORI Ginate:SEQuential

  • CALL:ORIGinate:WAIT

For more information on the GPIB Command conventions, see GPIB Command conventions

CALL:ORIGinate[:AUTO]

Function | Generates a page attempt to the mobile station.
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "CALL:ORIGinate"

CALL:ORIGinate:DONE?

Function | Returns 1 if the page attempt is excuted, or 0 if it is not.
Query | 1|0
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "CALL:ORIGinate:DONE?"

CALL:ORIGinate:OPComplete?

Function | Returns 1 in the test set's output queue when the page attempt is done, otherwise returns 0. Controlling program hangs on this query until the 1 is retrieved.
Query | 1|0
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "CALL:ORIGinate:OPComplete?"

CALL:ORIGinate:SEQuential

Function | Forces an overlapped command to execute in a sequential page attempt.
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "CALL:ORIGinate:SEQuential"

CALL:ORIGinate:WAIT

Function | Forces the test set to wait until the page attempt is done before executing any more commands.
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "CALL:ORIGinate:WAIT"


CALL:PAGing

  • CALL:PAGing:IDENtity[:TYPE]

  • CALL:PAGing:IMSI[:SELected]

  • CALL:PAGing:IMSI:TATDscdma

  • CALL:PAGing:SERVice[:TYPE]

For more information on the GPIB Command conventions, see GPIB Command conventions

CALL:PAGing:IDENtity[:TYPE]

Function | Sets/queries the CS Paging Identity Type, which determines whether the UE is paged by the Paging International Mobile Subscriber Identity (IMSI) or Temporary Mobile Subscriber Identity (TMSI). This parameter can only be set when call status is Idle .
Setting | Range: IMSI|TMSI
Query | Range: IMSI|TMSI
*RST Setting | IMSI
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "CALL:PAGing:IDENtity:TYPE IMSI"

CALL:PAGing:IMSI[:SELected]

Function

Sets/queries the paging international mobile subscriber identity (IMSI) for the currently selected application.

Paging IMSI will be overwritten by the mobile station's reported IMSI during any call connection procedure, such as location update or call setup.

Setting

Range: 000000 to 999 999 999 999 999

(String of 6 to 15 characters, each character from the set 0123456789)

Query

same as setting

*RST Setting

"001012345678901"

Requirements

Test Application Revision: A.02.00 and above

Programming Example

"CALL:PAGing:IMSI '001012345678901'"

CALL:PAGing:IMSI:TATDscdma

Function

Sets/queries the paging international mobile subscriber identity (IMSI) when using TD-SCDMA application.

Paging IMSI will be overwritten by the mobile station's reported IMSI during any call connection procedure, such as location update or call setup.

Setting

Range: 000000 to 999 999 999 999 999

(String of 6 to 15 characters, each character from the set 0123456789)

Query

same as setting

*RST Setting

"001012345678901"

Requirements

Test Application Revision: A.02.00 and above

Programming Example

"CALL:PAGing:IMSI:TATDscdma '001012345678901'"

CALL:PAGing:SERVice[:TYPE]

Function

Sets/queries the paging service type. The paging service type is used to set which type of service is initiated when the test set pages the UE.

Setting

Range:

  • AMR: AMR Voice

  • RBTest: RB Test Mode

Query

same as setting

*RST Setting

RBTest

Requirements

Test Application Revision: A.03.00 and above

Programming Example

"CALL:PAGing:SERVice RBTest"


CALL:PLOGging

Last updated: March 10, 2010

  • CALL:PLOGging:ACTive?

  • CALL:PLOGging:CONNected?

  • CALL:PLOGging:DONE?

  • CALL:PLOGging:STARt

  • CALL:PLOGging<:STATus|:STATe>?

  • CALL:PLOGging:STOP

For more information on the GPIB Command conventions, see GPIB Command conventions

CALL:PLOGging:ACTive?

Function

This query returns an integer value of 1 if the status of the test set's protocol logging data source is:

  • ACT (Active) - Both a real-time session and a logging session have been established and data is being captured by the protocol logging software.

If the state of the test set's protocol logging data source is not Active, this query will "hang" until a transition to the Active state occurs, or a bus timeout or device clear terminates the query attempt.

Requirements

Test Application Revision: A.05.00 and above

Programming Example

"CALL:PLOGging:ACTive?"

CALL:PLOGging:CONNected?

Function

This query returns an integer value of 1 if the status of the test set's protocol logging data source is either:

  • IDLE - A real-time protocol logging session has been established between the test set and the protocol logging software, but protocol logging is not currently taking place.

  • ACT (Active) - Both a real-time session and a logging session have been established and data is being captured by the protocol logging software.

If the state of the test set's protocol logging data source is not one of the above, this query will "hang" until a transition to one of these states occurs, or a bus timeout or device clear terminates the query attempt.

Requirements

Test Application Revision: A.05.00 and above

Programming Example

"CALL:PLOGging:CONNected?"

CALL:PLOGging:DONE?

Function

This query returns an integer value of 1 if the status of the test set's protocol logging data source is either:

  • DISC (Disconnected) - There is no real-time protocol logging session established between the test set and the protocol logging software.

  • IDLE - A real-time protocol logging session has been established between the test set and the protocol logging software, but protocol logging is not currently taking place.

If the state of the test set's protocol logging data source is not one of the above, this query will "hang" until a transition to one of these states occurs, or a bus timeout or device clear terminates the query attempt.

Requirements

Test Application Revision: A.05.00 and above

Programming Example

"CALL:PLOGging:DONE?"

CALL:PLOGging:STARt

Function

Logging state the test set can begin forwarding messages to the protocol logging software.

The protocol logging software must be in real-time mode (not post-capture mode) and a real-time logging session must be connected before transition to the Active logging state is possible.

A real-time logging session is connected by entering the IP Address of the test set in the Tools, Configuration window found in the protocol logging software. When a real-time logging session is connected, the test set's front panel logging annunciator will display Logging:Idle.

After the transition from the Idle to Active logging state has occurred, the test set's front paned logging annunciator will appear as follows:

Logging:Active

Requirements

Test Application Revision: A.05.00 and above

Programming Example

"CALL:PLOGging:STARt"

CALL:PLOGging<:STATus|:STATe>?

Function

This command queries the status of the test set's protocol logging data source. The logging status can be viewed on the test set front panel's logging annunciator.

Possible query results are:DISC

  • (Disconnected) - There is no real-time protocol logging session established between the test set and the protocol logging software.

  • IDLE - A real-time protocol logging session has been established between the test set and the protocol logging software, but protocol logging is not currently taking place.

  • ACT (Active) - Both a real-time session and a logging session have been established and data is being captured by the protocol logging software.

  • STRTG (Starting) - This is a transitional state while the protocol logging software attempts to start logging test set protocol messages.

  • STPG (Stopping) - This is a transitional state while the protocol logging software attempts to stop logging test set protocol messages.

Query

Range: DISC|IDLE|ACT|STRTG|STPG

Requirements

Test Application Revision: A.05.00 and above

Programming Example

"CALL:PLOGging:STATe?"

CALL:PLOGging:STOP

Function | This command will cause the test set to transition to the Idle logging state. The test set must be in the Active state before transition to the Idle logging state is possible. After the transition from the Active to the Idle logging state, the test set's front panel logging annunciator will appear as follows Logging:Idle
Requirements | Test Application Revision: A.05.00 and above
Programming Example | "CALL:PLOGging:STOP"


CALL:POWer

  • CALL[:CELL]:POWer:AMPLitude[:SELected]

  • CALL[:CELL]:POWer:AMPLitude(:CW|TDSCdma)

  • CALL[:CELL]:POWer[:SAMPlitude][:SELected]

  • CALL[:CELL]:POWer[:SAMPlitude](:CW|TDSCdma)

  • CALL[:CELL]:POWer:STATe[:SELected]

  • CALL[:CELL]:POWer:STATe(:CW|TDSCdma)

CALL[:CELL]:POWer:AMPLitude[:SELected]
CALL[:CELL]:POWer:AMPLitude(:CW|TDSCdma)

Function

Sets/queries the desired cell power level when the cell power state is on for the CW or TDSCdma system type.

The optional [:SELected] keyword in this command specifies that the cell power level being set or queried applies to the current system type (TDSCdma or CW).

Setting

Range:

  • TDSCdma: -165 dBm to +37 dBm

  • CW: -177 dBm to +40 dBm

Resolution:0.01/1.28MHz

Query

Same as setting

*RST Setting

  • TDSCdma: -63 dBm

  • CW:-50.0dBm

Requirements

Test Application Revision: A.01.00 and above

Programming Example

"CALL:CELL:POWER:AMPLITUDE:CW -30"

CALL[:CELL]:POWer[:SAMPlitude][:SELected]
CALL[:CELL]:POWer[:SAMPlitude](:CW|TDSCdma)

Function

The setting form of this command performs two functions:

(1)sets the desired cell power level (see CALL[:CELL]:POWer:AMPLitude[:SELected])and (2)turns the cell power on/off state (see CALL[:CELL]:POWer:STATe[:SELected]) to on.

The optional [:SELected] keyword in this command specifies that the cell power level being set or queried applies to the current system type (TDSCdma or CW).

Setting

Range:

  • TDSCdma: -165 dBm to +37 dBm

  • CW: -177 dBm to +40 dBm

Resolution:0.01/1.28MHz

Note,the actual power range is defined by adding the value of the associated amplitude offset to the range

Query

Range:+37dBm/1.28MHz to -165dBm/1.28MHz or No Results Available

*RST Setting

  • TDSCdma: -63 dBm

  • CW:-50.0dBm

Requirements

Test Application Revision: A.01.00 and above

Programming Example

"CALL:CELL:POWER:SAMPLITUDE -30"

CALL[:CELL]:POWer:STATe[:SELected]
CALL[:CELL]:POWer:STATe(:CW|TDSCdma)

Function | Sets/queries the cell power state. The optional [:SELected] keyword in this command specifies that the cell power level being set or queried applies to the current system type (TDSCdma or CW).
Setting | Range:1|ON|0|OFF
Query | Range:1|0
*RST Setting | ON
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "CALL:POWer:STATe ON"


CALL:PREVision

Last updated: March 10, 2010

  • CALL:PREVision:CONTrol

For more information on the GPIB Command conventions, see GPIB Command conventions

CALL:PREVision:CONTrol

Function | Sets/queries the Protocol Revision Control.
Setting | Range: AUTO |REVision4 | REVision5 | REVision7
Query | Range: AUTO |REV4 | REV5 |REV7
*RST Setting | AUTO
Requirements | Test Application Revision: A.03.00 and above Test Application Revision: A.05.00 and above, added REV7
Programming Example | "CALL:PREVision:CONTrol Auto"


CALL:PSDomain

  • CALL[:CELL]:PSDomain

The settings below can be set in active cell operating mode only when the call status is Idle, or in other operating modes.

If BCCH Update Page is set to Auto and you change the settings while your UE is camped to the test set, the test set performs a Broadcast Channel (BCCH) Update Procedure ; If BCCH Update Page is set to Inhibit (the default value) and you change the settings while your UE is camped to the test set, the UE is informed to re-read the BCCH to observe the change (see CALL:BCCHannel:UPDAte:PAGE AUTO).

For more information on the GPIB Command conventions, see GPIB Command conventions

CALL[:CELL]:PSDomain

Function | Sets/queries whether the PS domain information is present in SIB 1 or not. If it is absent, the UE will not attempt to initiate any packet switched services, like GPRS Attach or PDP Context Activation (the test set does not support these services) with the test set.
Setting | Range: ABSent|PRESent
Query | Range: ABS|PRES
*RST Setting | ABS
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "CALL:CELL:PSDomain ABSent"


CALL:RACode

  • CALL[:CELL]:RACode[:SELected]

  • CALL[:CELL]:RACode:TATDscdma

The settings below can be set in active cell operating mode only when the call status is Idle, or in other operating modes.

If BCCH Update Page is set to Auto and you change the settings while your UE is camped to the test set, the test set performs a Broadcast Channel (BCCH) Update Procedure ; If BCCH Update Page is set to Inhibit (the default value) and you change the settings while your UE is camped to the test set, the UE is informed to re-read the BCCH to observe the change (see CALL:BCCHannel:UPDAte:PAGE AUTO).

For more information on the GPIB Command conventions, see GPIB Command conventions

CALL[:CELL]:RACode:TATDscdma

Function | Sets/queries the Routing Area Code (RAC) when using the TD-SCDMA application. It can be set when PS domain information is set to "Present".
Setting | Range: 0 to 255
Query | Range: 0 to 255
*RST Setting | 1
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "CALL:CELL:RACode:TATDscdma 2"

CALL[:CELL]:RACode[:SELected]

Function | Sets/queries the Routing Area Code (RAC) for the currently selected application. It can be set when PS domain information is set to "Present".
Setting | Range: 0 to 255
Query | Range: 0 to 255
*RST Setting | 1
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "CALL:CELL:RACode 2"


CALL:RESelection

Last updated: March 10, 2010

  • CALL[:CELL]:RESelection:RLMinimum

For more information on the GPIB Command conventions, see GPIB Command conventions

CALL[:CELL]:RESelection:RLMinimum

Function | Sets/queries the Minimum Required Rx Level. This setting controls the minimum required Rx level in the cell.
Setting | Range: -115 to -25 dBm
Query | Same as setting
*RST Setting | -100
Requirements | Test Application Revision: A.05.00 and above
Programming Example | "CALL:RESelection:RLMinimum -100"


CALL:RFGenerator

  • CALL[:CELL]:RFGenerator:CONFigure

  • CALL[:CELL]:RFGenerator:FMBRoadcast:ADAPter:GAIN

  • CALL[:CELL]:RFGenerator:FMBRoadcast:CORRection:GAIN

  • CALL[:CELL]:RFGenerator:FMBRoadcast:CORRection[:SGAIN]

  • CALL[:CELL]:RFGenerator:FMBRoadcast:CORRection:STATe

  • CALL[:CELL]:RFGenerator:FMBRoadcast:FREQuency

  • CALL[:CELL]:RFGenerator:FMBRoadcast:FM:INTernal:DEViation

  • CALL[:CELL]:RFGenerator:FMBRoadcast:FM:INTernal[:SDEViation]

  • CALL[:CELL]:RFGenerator:FMBRoadcast:FM:INTernal:FREQuency

  • CALL[:CELL]:RFGenerator:FMBRoadcast:FM:INTernal:STATe

  • CALL[:CELL]:RFGenerator:FMBRoadcast:POWer:AMPLitude

  • CALL[:CELL]:RFGenerator:FMBRoadcast:POWer[:SAMPLitude]

  • CALL[:CELL]:RFGenerator:FMBRoadcast:POWer:STATe

  • CALL[:CELL]:RFGenerator:FREQuency

  • CALL[:CELL]:RFGenerator:GPS:BFILter

  • CALL[:CELL]:RFGenerator:GPS:FREQuency ?

  • CALL[:CELL]:RFGenerator:GPS:FREQuency2?

  • CALL[:CELL]:RFGenerator:GPS:NMESsage

  • CALL[:CELL]:RFGenerator:GPS:POWer[:SAMPLitude]

  • CALL[:CELL]:RFGenerator:GPS:POWer:AMPLitude

  • CALL[:CELL]:RFGenerator:GPS:POWer:STATe

  • CALL[:CELL]:RFGenerator:GPS:RAW:PPATtern

  • CALL[:CELL]:RFGenerator:GPS:SVID

CALL[:CELL]:RFGenerator:CONFigure

Function

Sets/queries the RF Generator mode:

  • Normal: This mode is the normal CW operating mode is in which the test set generates a CW signal.

  • FM broadcast: In this mode, the test set generates the signals that are sent through the RF OUT ONLY port to the FM Adapter to produce an FM Broadcast signal.

  • GPS: In this mode, the test set generates the required GPS signal at specified frequency point and specified power level.

Setting

Range: NORMal | FMBRoadcast |GPS

Query

Range: NORM | FMBR |GPS

*RST Setting

NORMal

Requirements

Test Application Revision: A.01.00 and above

Programming Example

"CALL:RFGENERATOR:CONFigure NORMal"

CALL[:CELL]:RFGenerator:FMBRoadcast:ADAPter:GAIN

Function | Sets/queries the loss of the FM Adapter. This parameter compensates the loss by increasing the signal strength at the RF OUT ONLY port.
Setting | Range: -30 to -10 dB Resolution: 0.01 dB
Query | Same as setting
*RST Setting | -19.75 dB
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "CALL:RFGENERATOR:FMBRoadcast:ADAPter:GAIN -19.75"

CALL[:CELL]:RFGenerator:FMBRoadcast:CORRection:GAIN

CALL[:CELL]:RFGenerator:FMBRoadcast:CORRection[:SGAIN]

Function | Sets/queries the FM Broadcast mode Amplitude Offset setting that is applied to the RF OUT ONLY port.
Setting | Range: -50 to 50 dB Resolution: 0.01 dB
Query | Same as setting
*RST Setting | 0 dB
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "CALL:RFGENERATOR:FMBRoadcast:CORRection:GAIN 0"

CALL[:CELL]:RFGenerator:FMBRoadcast:CORRection:STATe

Function | Sets/queries whether the FM Broadcast mode Amplitude Offset setting is applied.
Setting | Range: 1 | ON | 0 | OFF
Query | Range: 1 | 0
*RST Setting | 0 | OFF
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "CALL:RFGENERATOR:FMBRoadcast:CORRection:STATe 0"

CALL[:CELL]:RFGenerator:FMBRoadcast:FREQuency

Function | Sets/queries the frequency at which the test set broadcasts the FM signal. The units (Hz|kHz|MHz|GHz) are optional, if no units are specified then units default to Hz.
Setting | Range: 10MHz to 110 MHz Resolution: 1 Hz
Query | Same as setting
*RST Setting | 98.1 MHz
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "CALL:RFGENERATOR:FMBRoadcast:FREQuency 100 MHz"

CALL[:CELL]:RFGenerator:FMBRoadcast:FM:INTernal:DEViation

CALL[:CELL]:RFGenerator:FMBRoadcast:FM:INTernal[:SDEViation]

Function | Sets/queries FM Deviation of the internal audio source. The internal audio source is the amount the modulated signal deviates from the carrier frequency. Operating mode = Test Mode and Downlink Function = CW. The units (Hz|kHz|MHz|GHz) are optional, if no units are specified then units default to Hz.
Setting | Range: 0 to 75 kHz Resolution: 100 Hz
Query | Range: 0 to 75 kHz Resolution: 100 Hz
*RST Setting | 22.5 kHz
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "CALL:RFGENERATOR:FMBRoadcast:FM:INTernal 22.5 kHz"

CALL[:CELL]:RFGenerator:FMBRoadcast:FM:INTernal:FREQuency

Function | Sets/queries the test set's internal FM frequency. Operating mode = Test Mode and Downlink Function = CW. The units (Hz|kHz|MHz|GHz) are optional, if no units are specified then units default to Hz.
Setting | Range: 50 to 20,000 Hz Resolution: 1 Hz
Query | Range: 50 to 20,000 Hz Resolution: 1 Hz
*RST Setting | 1 kHz
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "CALL:RFGenerator:FMBRoadcast:FM:INTernal:FREQuency 1 kHz"

CALL[:CELL]:RFGenerator:FMBRoadcast:FM:INTernal:STATe

Function | Sets/queries whether the FM Broadcast mode Internal FM Deviation setting is applied. Operating mode = Test Mode and Downlink Function = CW.
Setting | Range: 1 | ON | 0 | OFF
Query | Range: 1 | 0
*RST Setting | 1 (ON)
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "CALL:RFGENERATOR:FMBRoadcast:FM:INTernal:STATe ON"

CALL[:CELL]:RFGenerator:FMBRoadcast:POWer:AMPLitude

CALL[:CELL]:RFGenerator:FMBRoadcast:POWer[:SAMPLitude]

Function | Sets/queries the power at which the test set broadcasts the FM signal. Operating mode = Test Mode and Downlink Function = CW. Note that when this parameters is set to > -30 and < -120, "Over Range" and "Under Range" error message is displayed respectively.
Setting | Range: -140 to -20 dBm Resolution: 0.01 dBm
Query | Range: -140 to -20 dBm Resolution: 0.01 dBm
*RST Setting | -50 dBm
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "CALL:RFGENERATOR:FMBRoadcast:POWer -50 dBm"

CALL[:CELL]:RFGenerator:FMBRoadcast:POWer:STATe

Function | Sets/queries whether the FM Broadcast Power setting is applied.
Setting | Range: 1 | ON | 0 | OFF
Query | Range: 1 | 0
*RST Setting | 1 (OFF)
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "CALL:RFGENERATOR:FMBRoadcast:POWer:STATe ON"

CALL[:CELL]:RFGenerator:FREQuency

Function | Sets/queries the RF Gen Freq. If no units are specified the setting defaults to Hz.
Setting | Range: 292 MHz to 2700 MHz Resolution: 0.1 Hz
Query | Same as setting
*RST Setting | 851 MHz
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "CALL:RFGenerator:FREQuency 2015 MHZ"

CALL[:CELL]:RFGenerator:GPS:BFILter

Function | Sets/queries the filter that is used to filter the GPS baseband signal when the operating mode is CW and the RF Gen Config is GPS . A Gaussian or Rectangle filter with 10 MHz bandwidth is supported in this setting..
Setting | Range: GAUSsian | RECTangle
Query | Range: GAUS | RECT
*RST Setting | GAUSsian
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "CALL:RFGenerator:GPS:BFILter GAUS"

CALL[:CELL]:RFGenerator:GPS:FREQuency?

Function | Queries the frequency of RF source 1 when the operating mode is CW and the RF Gen Config is GPS. This parameter is fixed at 1575.42MHz and can be queried only.
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "CALL:RFGenerator:GPS:FREQuency?"

CALL[:CELL]:RFGenerator:GPS:FREQuency2?

Function | Queries the frequency of RF source 2 when the operating mode is CW and the RF Gen Config is GPS.
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "CALL:RFGenerator:GPS:FREQuency2?"

CALL[:CELL]:RFGenerator:GPS:NMESsage

Function

Sets/queries the type of GPS navigation message that is transmitted on GPS frames.

  • Default Navigation (also called TLM): the GPS frames is filled according to the default navigation data (Alternating ones and zeros in word 3 through 10)

  • Raw: the GPS frames is filled with PN sequence.

Setting

Range: DEFault | RAW

Query

Range: DEF| RAW

*RST Setting

DEFault

Requirements

Test Application Revision: A.01.00 and above

Programming Example

"CALL:RFGenerator:GPS:NMESsage DEF"

CALL[:CELL]:RFGenerator:GPS:POWer[:SAMPLitude]

Function | Sets/queries the power at which the test set generates the GPS signal. Setting this parameter is also set the GPS State to ON.
Setting | Range: -160dBm to -20dBm, after the Amplitude Offset (optional) has been included. Resolution: 0.01 dBm
Query | same as setting
*RST Setting | -80 dBm
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "CALL:RFGenerator:GPS:POWer -80"

CALL[:CELL]:RFGenerator:GPS:POWer:AMPLitude

Function | Sets/queries the power at which the test set generates the GPS signal.
Setting | Range: -160dBm to -20dBm, after the Amplitude Offset (optional) has been included. Resolution: 0.01 dBm
Query | same as setting
*RST Setting | -80dBm
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "CALL:RFGenerator:GPS:POWer:AMPLitude -80"

CALL[:CELL]:RFGenerator:GPS:POWer:STATe

Function | Sets/queries whether the GPS power setting is applied.
Setting | Range: 1 | ON | 0 | OFF
Query | Range: 1 | 0
*RST Setting | 1 | ON
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "CALL:RFGenerator:GPS:POWer:STATe ON"

CALL[:CELL]:RFGenerator:GPS:RAW:PPATtern

Function | Sets/queries the date type that is transmitted on GPS frames.
Setting | Range: PN9| PN15
Query | same as setting:
*RST Setting | PN9
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "CALL:RFGenerator:GPS:RAW:PPATtern PN9"

CALL[:CELL]:RFGenerator:GPS:SVID

Function | Sets/queries which satellite is generating the GPS signal.
Setting | Range: 1 to 37 Resolution: 1
Query | same as setting:
*RST Setting | 1
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "CALL:RFGenerator:GPS:SVID 1"


CALL:RRC

Last updated: March 10, 2010

  • CALL[:CELL]:RRC:CRELease:N308

For more information on the GPIB Command conventions, see GPIB Command conventions

CALL[:CELL]:RRC:CRELease:N308

Function | Sets/queries the N308 timer.
Setting | Range: 1 - 8
Query | Range: 1 - 8
*RST Setting | 2
Requirements | Test Application Revision: A.03.00 and above
Programming Example | "CALL:RRC:CRELease:N308 2"


CALL:SCODe

  • CALL[:CELL]:SCODe:IDENtity

CALL[:CELL]:SCODe:IDENtity

Function | Sets/queries the Scrambling Code setting. The scrambling code determines other synchronization codes.
Setting | Range:0 to 127
Query | Range:0 to 127
*RST Setting | 0
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "CALL:CELL:SCODe:IDENtity 10"


CALL:SECurity

Last updated: May 5, 2010

  • CALL:SECurity:AUTHenticate:ALGorithm

  • CALL:SECurity:AUTHenticate:AMF

  • CALL:SECurity:AUTHenticate: [KEY]

  • CALL:SECurity:AUTHenticate:OPVariant:PTYPe

  • CALL:SECurity:AUTHenticate:OPVariant:PVALue

  • CALL:SECurity:AUTHenticate:RANDom:TDSCdma

  • CALL:SECurity:AUTHenticate:RESult:GMM:TDSCdma?

  • CALL:SECurity:AUTHenticate:RESult:MM:TDSCdma?

  • CALL:SECurity:AUTHenticate:SQN:RESet:[IMMediate]

  • CALL:SECurity:OPERation

For more information on the GPIB Command conventions, see GPIB Command conventions

CALL:SECurity:AUTHenticate:ALGorithm

Function | Sets/queries the authentication algorithm.
Setting | Range: TEST34108 | MILenage
Query | Range: TEST34108 | MILenage
*RST Setting | TEST34108
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "CALL:SECurity:AUTHenticate:ALGorithm MILenage"

CALL:SECurity:AUTHenticate:AMF

Function | Sets/queries the AMF value.
Setting | Range: 0 to FFFF (String of 4 characters from the set 0123456789aAbBcCdDeEfF)
Query | Range: "0000" to "FFFF"
*RST Setting | "0000"
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "CALL:SECurity:AUTHenticate:AMF '0000'"

CALL:SECurity:AUTHenticate:[KEY]

Function | Sets/queries the authentication key.
Setting | Range: 0 to FFFFFFFF FFFFFFFF FFFFFFFF FFFFFFFF (String of 32 characters from the set 0123456789aAbBcCdDeEfF)
Query | Range: "00000000:00000000:00000000:00000000" to "FFFFFFFF:FFFFFFFF:FFFFFFFF:FFFFFFFF" (The return string is enclosed by double quotes and is always four colon separated groups in the order of upper, upper middle, lower middle and lower, each group with 8 characters from the set 0123456789ABCDEF)
*RST Setting | "4147494C:454E5420:54454348:4E4F0000"
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "CALL:SECurity:AUTHenticate '4147494C454E5420544543484E4F0000'"

CALL:SECurity:AUTHenticate:OPVariant:PTYPe

Function | Sets/queries whether the operator variant authentication algorithm contains the OP or Opc.
Setting | Range: OP|OPC
Query | Range: OP|OPC
*RST Setting | OPC
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "CALL:SECurity:AUTHenticate:OPVariant:PTYPe OPC"

CALL:SECurity:AUTHenticate:OPVariant:PVALue

Function | Sets/queries the value of the operator variant authentication algorithm.
Setting | Range: 0 to FFFFFFFF FFFFFFFF FFFFFFFF FFFFFFFF (String of 32 characters from the set 0123456789aAbBcCdDeEfF)
Query | Range: "00000000:00000000:00000000:00000000" to "FFFFFFFF:FFFFFFFF:FFFFFFFF:FFFFFFFF"
*RST Setting | "00000000:00000000:00000000:00000000"
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "CALL:SECurity:AUTHenticate:OPVariant:PVALue '00000000:00000000:00000000:00000000'"

CALL:SECurity:AUTHenticate:RANDom:TDSCdma

Function | Sets/queries the random (RAND) value when the current format is TD-SCDMA.
Setting | Range: 0 to FFFFFFFF FFFFFFFF FFFFFFFF FFFFFFFF (String of 32 characters from the set 0123456789aAbBcCdDeEfF)
Query | Range: "00000000:00000000:00000000:00000000" to "FFFFFFFF:FFFFFFFF:FFFFFFFF:FFFFFFFF" (The return string is enclosed by double quotes and is always four colon separated groups in the order of upper, upper middle, lower middle and lower, each group with 8 characters from the set 0123456789ABCDEF)
*RST Setting | "00000000:00000000:00000000:00000001"
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "CALL:SECurity:AUTHenticate:RANDom:TDSCdma '00000000:00000000:00000000:00000001'"

CALL:SECurity:AUTHenticate:RESult:GMM:TDSCdma?

Function

Queries the authentication result in GMM when using TD-SCDMA application:

  • SUCCess - MS Authentication Success

  • MSFAILMAC - MS Authentication Failure, with a reject cause of MAC Does not Match

  • MSFAILSYNC - MS Authentication Failure, with a reject cause of Synch Failure

  • MSFAILUNKNOWN - MS Authentication Failure, with a reject cause of Unknown

  • RESLENERR - MS Authentication Failure, with a reject cause of Incorrect RES Length

  • RESNOTMATCH - MS Authentication Failure, with a reject cause of RES does not Match

  • NULL - No results is available

Query

Range: SUCCess| MSFAILMAC | MSFAILSYNC | MSFAILUNKNOWN | RESLENERR | RESNOTMATCH | NULL

*RST Setting

NULL

Requirements

Test Application Revision: A.02.00 and above

Programming Example

"CALL:SECurity:AUTHenticate:RESult:GMM:TDSCdma?"

CALL:SECurity:AUTHenticate:RESult:MM:TDSCdma?

Function

Queries the authentication result in MM when using TD-SCDMA application:

  • SUCCess - MS Authentication Success

  • MSFAILMAC - MS Authentication Failure, with a reject cause of MAC Does not Match

  • MSFAILSYNC - MS Authentication Failure, with a reject cause of Synch Failure

  • MSFAILUNKNOWN - MS Authentication Failure, with a reject cause of Unknown

  • RESLENERR - MS Authentication Failure, with a reject cause of Incorrect RES Length

  • RESNOTMATCH - MS Authentication Failure, with a reject cause of RES does not Match

  • NULL - No results is available

Query

Range: SUCC| MSFAILMAC | MSFAILSYNC | MSFAILUNKNOWN | RESLENERR | RESNOTMATCH | NULL

*RST Setting

NULL

Requirements

Test Application Revision: A.02.00 and above

Programming Example

"CALL:SECurity:AUTHenticate:RESult:MM:TDSCdma?"

CALL:SECurity:AUTHenticate:SQN:RESet:[IMMediate]

Function | Resets the authentication sequence number (SQN) to zero.
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "CALL:SECurity:AUTHenticate:SQN:RESet"

CALL:SECurity:OPERation

Function

Sets/queries the security operations setting:

  • NONE: No security procedures are performed

  • AUTHONLY : Authentication only

  • AUTHINT: Authentication and integrity protection

Setting

Range: NONE|AUTHONLY|AUTHINT

Query

Range: NONE|AUTHONLY|AUTHINT

*RST Setting

AUTHINT

Requirements

Test Application Revision: A.02.00 and above

Programming Example

"CALL:SECurity:OPERation AUTHINT"


CALL:SERVice

Last updated: March 10, 2010

  • CALL:SERVice:AMR:RAB

  • CALL:SERVice:AMR:SPEech:ECHO:LOOPback:DELay

  • CALL:SERVice:RBTest:RAB

  • CALL:SERVice:RBTest:RRC:STATe

For more information on the GPIB Command conventions, see GPIB Command conventions

CALL:SERVice:AMR:RAB

Function | Sets/queries the AMR Radio Access Bearer.
Setting | Range: AMR475 | AMR515 | AMR590 | AMR670 | AMR740 | AMR795 | AMR1020 | AMR1220
Query | Same as setting
*RST Setting | AMR1220
Requirements | Test Application Revision: A.03.00 and above
Programming Example | "CALL:SERVice:AMR:RAB AMR1220"

CALL:SERVice:AMR:SPEech:ECHO:LOOPback:DELay

Function

Sets/queries the Speech Echo Loopback Delay. This parameter determines the amount of time that speech frames received on the uplink are delayed before being retransmitted on the downlink.

This setting cannot be changed when the cell operating mode is Active Cell and the call/data status is any state other than IDLE, or the test set will reject the change and an error will be reported.

Setting

Range: 0.1 to 4 s

Resolution: 0.02

Query

Same as setting

*RST Setting

0.5

Requirements

Test Application Revision: A.03.00 and above

Programming Example

"CALL:SERVice:AMR:SPEech:ECHO:LOOPback:DELay 0.5"

CALL:SERVice:RBTest:RAB

Function | Sets/queries the Channel Type setting.
Setting | Range: SRMC12 | MRMC12 | HSDP12 | RMC64 | RMCAM64144 | RMCAM64384 |HSParmc12
Query | same as setting
*RST Setting | SRMC12
Requirements | Test Application Revision: A.03.00 and above Test Application Revision: A.04.00 and above, added RMC64, RMCAM64144 and RMCAM64384. Test Application Revision: A.05.00 and above, added HSParmc12
Programming Example | "CALL:SERVice:RBTest:RAB SRMC12"

CALL:SERVice:RBTest:RRC:STATe

Function | Sets/queries the RB Test Mode RRC State setting.
Setting | Range: FACH | DCH
Query | same as setting
*RST Setting | DCH
Requirements | Test Application Revision: A.05.00 and above
Programming Example | "CALL:SERVice:RBTest:RRC:STATe DCH"


CALL:SETup

  • CALL:SETup:ACTivation:TIME

  • CALL:SETup:CHANnel:TDSCdma

  • CALL:SETup:CLPControl:UPLink:STEPsize

  • CALL:SETup:DPCHannel:TYPE

  • CALL:SETup:DPCHannel:TYPE:STATe

  • CALL:SETup:LOOPback:MESSage:STATe

  • CALL:SETup:SCODe:IDENtity

  • CALL:SETup:SYSTem:GSM:ALERting[:STATe]

For more information on the GPIB Command conventions, see GPIB Command conventions

CALL:SETup:ACTivation:TIME

Function | Sets/queries the relative time offset (in 10ms frame) to calculate the activation time parameter included in physical channel reconfiguration message. The activation time parameter is get by: Activation Time = (current CFN + this setting) % 256
Setting | Range: 0 to 255
Query | Range: 0 to 255
*RST Setting | 0
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "CALL:SETup:ACTivation:TIME 255"

CALL:SETup:CHANnel:TDSCdma

Function | Sets/queries the physical channel reconfiguration target cell UARFCN for TD-SCDMA application.
Setting | Range: 10054 to 10121, 9404 to 9596
Query | Range: 10054 to 10121, 9404 to 9596
*RST Setting | 10054
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "CALL:SETup:CHANnel:TDSCdma 10054"

CALL:SETup:CLPControl:UPLink:STEPsize

Function | Sets/queries the physical channel reconfiguration uplink closed loop power control step size.
Setting | Range: 1|2|3
Query | Range: 1|2|3
*RST Setting | 1
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "CALL:SETup:CLPControl:UPLink:STEPsize 1"

CALL:SETup:DPCHannel:TYPE

Function | Sets/queries the physical channel reconfiguration DPCH Type setting.
Setting | Range: SRMC12|MRMC12
Query | Same as setting
*RST Setting | SRMC12
Requirements | Test Application Revision: A.03.00 and above
Programming Example | "CALL:SETup:DPCHannel:TYPE SRMC12"

CALL:SETup:DPCHannel:TYPE:STATe

Function | Sets/queries the physical channel reconfiguration DPCH Type State setting.
Setting | Range: 1|ON|0|OFF
Query | Range: 1|0
*RST Setting | 0
Requirements | Test Application Revision: A.03.00 and above
Programming Example | "CALL:SETup:DPCHannel:TYPE:STATe On"

CALL:SETup:LOOPback:MESSage:STATe

Function | Sets/queries physical channel reconfiguration loopback message state. If the state is "ON", the test set sends an open UE test loop message before the physical channel reconfiguration message, and sends a close UE test loop message after receiving the physical channel reconfiguration complete message; else if the state is "OFF", the test set does not send any loop control message.
Setting | Range: 1|ON|0|OFF
Query | Range: 1|0
*RST Setting | 0(OFF)
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "CALL:SETup:LOOPback:MESSage:STATe 0"

CALL:SETup:SCODe:IDENtity

Function | Sets/queries the scrambling code ID of the target cell the UE will be handover to after physical channel reconfiguration.
Setting | Range: 0 to 127
Query | same as setting
*RST Setting | 0
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "CALL:SETup:SCODe:IDENtity 0"

CALL:SETup:SYSTem:GSM:ALERting[:STATe]

Function | Sets/queries the RB Test Mode to GSM Handover Alerting State.
Setting | Range: 1|ON|0|OFF
Query | Range: 1|0
*RST Setting | 0 (OFF)
Requirements | Test Application Revision: A.03.00 and above
Programming Example | "CALL:SETup:SYSTem:GSM:ALERting Off"


CALL:SMService

Last updated: March 10, 2010

  • CALL:SMService:PTPoint[:MTERminated][:MESSage]:DCSCheme

  • CALL:SMService:PTPoint[:MTERminated]:CONTents

  • CALL:SMService:PTPoint[:MTERminated]:RCAuse?

  • CALL:SMService:PTPoint[:MTERminated]:SEND[:IMMediate]

  • CALL:SMService:PTPoint[:MTERminated]:SEND:STATe?

  • CALL:SMService:PTPoint[:MTERminated]:TEXT:CUSTom

  • CALL:SMService:PTPoint[:MTERminated]:TRANsport

  • CALL:SMService:PTPoint[:MTERminated]:TXT1?

  • CALL:SMService:PTPoint[:MTERminated]:TXT2?

  • CALL:SMService:PTPoint:MORiginated[:MESSage]:CLEar[:ALL]

  • CALL:SMService:PTPoint:MORiginated[:MESSage]:COUNt?

  • CALL:SMService:PTPoint:MORiginated[:MESSage]:DCSCheme?

  • CALL:SMService:PTPoint:MORiginated[:MESSage]:DESTination?

  • CALL:SMService:PTPoint:MORiginated[:MESSage]:FORMat?

  • CALL:SMService:PTPoint:MORiginated[:MESSage]:LENGth?

  • CALL:SMService:PTPoint:MORiginated[:MESSage]:MREFerence?

  • CALL:SMService:PTPoint:MORiginated[:MESSage]:PIDengtifier?

  • CALL:SMService:PTPoint:MORiginated[:MESSage]:SRRequest?

  • CALL:SMService:PTPoint:MORiginated[:MESSage]:TEXT?

  • CALL:SMService:PTPoint:MORiginated[:MESSage]:TRANSport?

  • CALL:SMService:PTPoint:MORiginated[:MESSage]:UDHind?

  • CALL:SMService:PTPoint:MORiginated[:MESSage]:UDHLength?

  • CALL:SMService:PTPoint:MORiginated:LOOPback

For more information on the GPIB Command conventions, see GPIB Command conventions

CALL:SMService:PTPoint[:MTERminated][:MESSage]:DCSCheme

Function | Sets/queries the Data Coding Scheme. See Mobile Terminated SMS Parameters.
Setting | Range: 0 to 255
Query | Range: 0 to 255
*RST Setting | 0
Requirements | Test Application Revision: A.04.00 and above
Programming Example | "CALL:SMService:PTPoint:DCSCheme 0"

CALL:SMService:PTPoint[:MTERminated]:CONTents

Function | Sets/queries the content to be sent in mobile terminated SMS messages.
Setting | Range: TXT1 | TXT2 | CTEXt
Query | Range: TXT1 | TXT2 | CTEX
*RST Setting | TXT1
Requirements | Test Application Revision: A.04.00 and above
Programming Example | "CALL:SMService:PTPoint:CONTents TXT1"

CALL:SMService:PTPoint[:MTERminated]:RCAuse?

Function | Queries the reject cause value when a mobile terminated message is rejected by the mobile station. If the last message sent to the mobile station was not rejected, NAN is returned for the reject cause value. If the last message sent to the mobile station was rejected, this query returns the decimal value of the reject cause.
Query | Range: 0 to 255 (decimal) See Reject Cause and 9.91 E+37 (NAN)
*RST Setting | 9.91 E37 (NAN)
Requirements | Test Application Revision: A.04.00 and above
Programming Example | "CALL:SMService:PTPoint:RCAuse?"

CALL:SMService:PTPoint[:MTERminated]:SEND[:IMMediate]

Function | Sends a Point to Point SMS message.
Requirements | Test Application Revision: A.04.00 and above
Programming Example | "CALL:SMService:PTPoint:SEND"

CALL:SMService:PTPoint[:MTERminated]:SEND:STATe?

Function | Queries the state of the last message sent to the mobile station.
Query | Range: IDLE | SEND | ACK | NACK | REJ | FAIL IDLE: No message has been sent SEND: Message send in progress ACK: Message acknowledged by mobile station NACK: Message was not acknowledged by mobile station and send timed out REJ: Message was rejected by the mobile station FAIL: Message could not be sent
*RST Setting | IDLE
Requirements | Test Application Revision: A.04.00 and above
Programming Example | "CALL:SMService:PTPoint:SEND:STATe?"

CALL:SMService:PTPoint[:MTERminated]:TEXT:CUSTom

Function | This sets the text of the custom message to be sent.
Setting | String: 7 bit ASCII characters up to 160 characters in length
Query | String: 7 bit ASCII characters up to 160 characters in length, enclosed by double quotes.
*RST Setting | "Enter your text here"
Requirements | Test Application Revision: A.04.00 and above
Programming Example | "CALL:SMService:PTPoint:TEXT:CUSTom `Hello World'"

CALL:SMService:PTPoint[:MTERminated]:TRANsport

Function | Sets/queries the transportation mechanism to be used.
Setting | Range: CSDomain|PSDomain
Query | Range: CSD|PSD
*RST Setting | PSD
Requirements | Test Application Revision: A.04.00 and above
Programming Example | "CALL:SMService:PTPoint:TRANsport PSD"

CALL:SMService:PTPoint[:MTERminated]:TXT1?

Function | Queries the fixed Text Message 1.
Query | Returns a string.
*RST Setting | "0123456789ABCDEFGHIJKLMNOPQRSTUVWXYZabcdefghijklmnopqrstuvwxyz"
Requirements | Test Application Revision: A.04.00 and above
Programming Example | "CALL:SMService:PTPoint:TXT1?"

CALL:SMService:PTPoint[:MTERminated]:TXT2?

Function | Queries the fixed Text Message 2.
Query | Returns a string.
*RST Setting | "Agilent Technologies, your partner in wireless solutions"
Requirements | Test Application Revision: A.04.00 and above
Programming Example | "CALL:SMService:PTPoint:TXT2?"

CALL:SMService:PTPoint:MORiginated[:MESSage]:CLEar[:ALL]

Function | Clears all Received Message data. This includes Transport, Length, Format, Contents, Text, Destination Address, Message Count, More Messages to Send Indication, Data Coding Scheme, User Data Header Indication, User Data Header Length, Status Report Request, and Message Reference. Empties the message queue if it is enabled.
Requirements | Test Application Revision: A.04.00 and above
Programming Example | "CALL:SMService:PTPoint:MORiginated:CLEar"

CALL:SMService:PTPoint:MORiginated[:MESSage]:COUNt?

Function | Queries the number of messages received by the test set.
Query | Range: 0 to 255 Resolution: 1
*RST Setting | 0
Requirements | Test Application Revision: A.04.00 and above
Programming Example | "CALL:SMService:PTPoint:MORiginated:COUNt?"

CALL:SMService:PTPoint:MORiginated[:MESSage]:DCSCheme?

Function | Queries the Data Coding Scheme (TP-DCS) of the last message received by the test set or the current message available in the message queue.
Query | Range: 0 to 255 or 9.91E+37 (NAN) Resolution: 1
*RST Setting | 9.91E+37
Requirements | Test Application Revision: A.04.00 and above
Programming Example | "CALL:SMService:PTPoint:MORiginated:DCSCheme?"

CALL:SMService:PTPoint:MORiginated[:MESSage]:DESTination?

Function | Queries the destination address of the last SMS message received by the test set.
Query | Returns a string.
*RST Setting | "" (null string)
Requirements | Test Application Revision: A.04.00 and above
Programming Example | "CALL:SMService:PTPoint:MORiginated:DESTination?"

CALL:SMService:PTPoint:MORiginated[:MESSage]:FORMat?

Function | Queries the Last Received Message Format.
Query | ASC|BIN|UCS2|INV|UNKN ASC: 7 bit ASCII string BIN: Binary data UCS2: Unicode Character Set 2 INV: Invalid (returned when no messages have been received) UNKN: Unknown message format
*RST Setting | INV
Requirements | Test Application Revision: A.04.00 and above
Programming Example | "CALL:SMService:PTPoint:MORiginated:FORMat?"

CALL:SMService:PTPoint:MORiginated[:MESSage]:LENGth?

Function | Queries the Last Received Message Length.
Query | Returns a number value or 9.91E+37 (NAN). ASCII - the number of characters in the ASCII text message Binary/UCS2 - the number of octets of data in the message No message received - NAN
*RST Setting | 9.91E+37
Requirements | Test Application Revision: A.04.00 and above
Programming Example | "CALL:SMService:PTPoint:MORiginated:LENGth?"

CALL:SMService:PTPoint:MORiginated[:MESSage]:MREFerence?

Function | Queries the Message Reference (TP-MR) of the last message received by the test set or the current message available in the message queue.
Query | Range: 0 to 255 or 9.91E+37 (NAN)
*RST Setting | 9.91E+37
Requirements | Test Application Revision: A.04.00 and above
Programming Example | "CALL:SMService:PTPoint:MORiginated:MREFerence?"

CALL:SMService:PTPoint:MORiginated[:MESSage]:PIDengtifier?

Function | Queries the Protocol Identifier (TP-PID) of the last message received by the test set or the current message available in the message queue.
Query | Range: 0 to 255 or 9.91E+37 (NAN)
*RST Setting | 9.91E+37
Requirements | Test Application Revision: A.04.00 and above
Programming Example | "CALL:SMService:PTPoint:MORiginated:PIDengtifier?"

CALL:SMService:PTPoint:MORiginated[:MESSage]:SRRequest?

Function | Queries the Status Report Request (TP-SRR) of the last message received by the test set or the current message available in the message queue.
Query | 0 | 1 | 9.91E+37 (NAN)
*RST Setting | 9.91E+37
Requirements | Test Application Revision: A.04.00 and above
Programming Example | "CALL:SMService:PTPoint:MORiginated:SRRequest?"

CALL:SMService:PTPoint:MORiginated[:MESSage]:TEXT?

Function | Queries the text from the last SMS message received by the test set.
Query | Returns a string.
*RST Setting | "" (null string)
Requirements | Test Application Revision: A.04.00 and above
Programming Example | "CALL:SMService:PTPoint:MORiginated:TEXT?"

CALL:SMService:PTPoint:MORiginated[:MESSage]:TRANSport?

Function | Queries the reported transportation mechanism used by the mobile station when it originates a point-to-point SMS message.
Query | Range: CSD|INV|PSD CSD: CS Domain was used INV: Invalid (returned when no messages have been received by the test set) PSD: PS Domain was used
*RST Setting | INV
Requirements | Test Application Revision: A.04.00 and above
Programming Example | "CALL:SMService:PTPoint:MORiginated:TRANSport?"

CALL:SMService:PTPoint:MORiginated[:MESSage]:UDHind?

Function | Queries the User Data Header Indication (TP-UDHI) of the last message received by the test set or the current message available in the message queue.
Query | 0 | 1 | 9.91E+37 (NAN)
*RST Setting | 9.91E+37
Requirements | Test Application Revision: A.04.00 and above
Programming Example | "CALL:SMService:PTPoint:MORiginated:UDHind?"

CALL:SMService:PTPoint:MORiginated[:MESSage]:UDHLength?

Function | Queries the User Data Header Length of the last message received by the test set or the current message available in the message queue.
Query | Range: 0 to 140 bytes or 9.91E+37 (NAN)
*RST Setting | 9.91E+37
Requirements | Test Application Revision: A.04.00 and above
Programming Example | "CALL:SMService:PTPoint:MORiginated:UDHLength?"

CALL:SMService:PTPoint:MORiginated:LOOPback

Function | Sets/Queries the loopback state of MO point-to-point message. See Mobile Originated SMS Parameters
Setting | 0|OFF|1|ON
Query | 0|1
*RST Setting | 0
Requirements | Test Application Revision: A.04.00 and above
Programming Example | "CALL:SMService:PTPoint:MORiginated:LOOPback 0"


CALL:STATus

The CALL:STATus commands are query only. They return values that indicate the test set's actual hardware settings. Actual hardware settings can differ from settings the user has entered, most frequently due to an error condition. When no error conditions exist, the commands used to enter values return the same results as the commands used to query actual hardware settings. For example, "CALL:AWGNoise:POWer?" returns the same value as "CALL:STATus:AWGNoise:POWer?" when no error conditions exist.

  • CALL:STATus:AWGNoise[:INTernal]:POWer[:AMPLitude][:SELected]?

  • CALL:STATus:AWGNoise[:INTernal]:POWer[:AMPLitude]:TDSCdma?

  • CALL:STATus:AWGNoise[:INTernal]:POWer:STATe[:SELected]?

  • CALL:STATus:AWGNoise[:INTernal]:POWer:STATe:TDSCdma?

  • CALL:STATus:CELL:POWer[:AMPLitude][:SELected]?

  • CALL:STATus:CELL:POWer[:AMPLitude]:TDSCdma?

  • CALL:STATus:CELL:POWer:STATe[:SELected]?

  • CALL:STATus:CELL:POWer:STATe:TDSCdma?

  • CALL:STATus:CELL:SYSTem[:TYPE]?

  • CALL:STATus:DPCHannel[:LEVel]?

  • CALL:STATus:DPCHannel:ORTHogonal:LEVel?

  • CALL:STATus:DPCHannel:ORTHogonal:STATe?

  • CALL:STATus:DPCHannel:STATe?

  • CALL:STATus:GMM?

  • CALL:STATus:MM?

  • CALL:STATus:RRC:STATe?

  • CALL:STATus[:STATe]:DATA?

  • CALL:STATus[:STATe][:VOICe]?

  • CALL:STATus:SERVice:TYPE?

  • CALL:STATus:TOTal:POWer[:AMPLitude][:SELected]?

  • CALL:STATus:TOTal:POWer[:AMPLitude]:TDSCdma?

  • CALL:STATus:TOTal:POWer:STATe[:SELected]?_

  • CALL:STATus:TOTal:POWer:STATe:TDSCdma?

For more information on the GPIB Command conventions, see GPIB Command conventions

CALL:STATus:AWGNoise[:INTernal]:POWer[:AMPLitude][:SELected]?

Function

Queries the additive white gaussian noise (AWGN) level when the AWGN power state is on for the current system type.

The optional [:SELected] keyword in this command specifies that the cell power level being set or queried applies to the current system type.

Query

Range:+35dBm/1.28MHz to -165dBm/1.28MHz or 9.91 E+37 (NAN)

Resolution:0.01

Requirements

Test Application Revision: A.01.00 and above

Programming Example

"CALL:STATus:AWGNoise:POWer:AMPLITUDE?"

CALL:STATus:AWGNoise[:INTernal]:POWer[:AMPLitude]:TDSCdma?

Function | Queries the additive white gaussian noise (AWGN) level when the AWGN power state is on for the TD-SCDMA system type.
Query | Range:+35dBm/1.28MHz to -165dBm/1.28MHz or 9.91 E+37 (NAN) Resolution:0.01
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "CALL:STATus:AWGNoise:POWer:AMPLITUDE:TDSCdma?"

CALL:STATus:AWGNoise[:INTernal]:POWer:STATe[:SELected]?

Function | Queries the additive white gaussian noise power state for the current system type. The optional [:SELected] keyword in this command specifies that the cell power level being set or queried applies to the current system type.
Query | Range: 0(off)|1(on)
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "CALL:STATus:AWGNoise:POWer:STATe?"

CALL:STATus:AWGNoise[:INTernal]:POWer:STATe:TDSCdma?

Function | Queries the additive white gaussian noise power state for the TD-SCDMA system type.
Query | Range: 0(off)|1(on)
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "CALL:STATus:AWGNoise:POWer:STATe:TDSCDMA?"

CALL:STATus:CELL:POWer[:AMPLitude][:SELected]?

Function | Queries the current cell power level. The optional [:SELected] keyword in this command specifies that the cell power level being set or queried applies to the current system type (TDSCdm or CW).
Query | Range:+37dBm/1.28MHz to -165dBm/1.28MHz or 9.91 E+37 (NAN) Resolution:0.01/1.28MHz
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "CALL:STATus:CELL:POWER:AMPLITUDE?"

CALL:STATus:CELL:POWer[:AMPLitude]:TDSCdma?

Function | Queries the current cell power level for the TD-SCDMA system type.
Query | Range:+37dBm/1.28MHz to -165dBm/1.28MHz or 9.91 E+37 (NAN) Resolution:0.01/1.28MHz
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "CALL:STATus:CELL:POWER:AMPLITUDE:TDSCdma?"

CALL:STATus:CELL:POWer:STATe[:SELected]?

Function | Queries the current cell power state. The optional [:SELected] keyword in this command specifies that the cell power level being set or queried applies to the current system type.
Query | Range: 0(off)|1(on)
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "CALL:STATus:CELL:POWer:STATe:TDSCdma?"

CALL:STATus:CELL:POWer:STATe:TDSCdma?

Function | Queries the current cell power state for the TD-SCDMA system type.
Query | Range: 0(off)|1(on)
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "CALL:STATus:CELL:POWer:STATe:TDSCdma?"

CALL:STATus:CELL:SYSTem[:TYPE]?

Function | Queries the current system type of the base station emulator. When the cell operating mode is "CW", current system type is CW; When the cell operating mode is "TD-SCDMA Test Mode", current system type is TDSCdma; When in other operating mode, current system type is determined by active cell system type.
Query | Range:TDSCdma | CW
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "CALL:STATus:CELL:SYSTem?"

CALL:STATus:DPCHannel[:LEVel]?

Function | Queries the TD-SCDMA Test DL DPCH power offset.
Query | Range:-30.00 dB to 0 dB Resolution:0.01
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "CALL:STATUS:DPCHannel:LEVel?"

CALL:STATus:DPCHannel:ORTHogonal:LEVel?

Function | Queries the current DPCHo power level.
Query | Range:-30.00 dB to 0 dB or -9.9E37 or 9.91 E+37 (NAN) Resolution:0.01 Note, if there is no power being placed into the DPCHo channel then the value of minus 4 infinity is returned, which is -9.9E37.
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "CALL:STATus:DPCHannel:ORTHogonal:LEVel?"

CALL:STATus:DPCHannel:ORTHogonal:STATe?

Function | Queries current DPCHo power state.
Query | Range: 0(off)|1(on)
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "CALL:STATus:DPCHannel:ORTHogonal:STATe?"

CALL:STATus:DPCHannel:STATe?

Function | Queries the current TD-SCDMA Test DL DPCH power state.
Query | Range:0(off)|1(on)
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "CALL:STATus:DPCHannel:STATe?"

CALL:STATus:RRC:STATe?

Function | Queries RRC State. DCH indicates the RB test mode service has set the UE up into CELL_DCH state.
Query | Range: DCH | IDLE | FACH
Requirements | Test Application Revision: A.02.00 and above Test Application Revision: A.05.00 and above, added FACH
Programming Example | "CALL:STATus:RRC:STATe?"

CALL:STATus:MM?

Function

Queries MM Status:

  • NORM: updated normally, which indicates update the network with the actual Location Area of a UE.

  • IATT: IMSI attached, which indicates the IMSI as active in the network.

  • IDET: IMSI detached, which indicates the UE was IMSI Attached and then was powered down or its USIM was removed.

  • NONE: indicates the UE has not registered with the test set.

Query

Range: NORM | IATT | IDET | NONE

Requirements

Test Application Revision: A.02.00 and above

Programming Example

"CALL:STATus:MM?"

CALL:STATus:GMM?

Function

Queries the status of the latest GPRS attach or detach:

  • ATT: attached, which indicates the UE has successfully completed the GPRS attach procedure.

  • ATTINC: attach incomplete, which indicates the UE sends the test set an Attach Request but never responds to the Attach Accept with an Attach Complete.

  • DET: detached, which indicates the completion of the GPRS Detach procedure.

  • NONE: indicates the UE does not set an Attach Request.

Query

Range: ATT | ATTINC | DET | NONE

Requirements

Test Application Revision: A.02.00 and above

Programming Example

"CALL:STATus:GMM?"

CALL:STATus[:STATe][:VOICe]?

Function

Queries the status of the call:

  • IDLE: the test set is not on a call.

  • PAG: the test set is in the process of paging the UE.

  • SREQ: the test set is in the process of assigning a channel to the UE as part of a page or a UE-originated call setup.

  • CONN: the test set and UE are connected on a call.

  • REL: the test set is in the process of releasing the UE from a call using over the air signalling as part of a UE or test set originated release procedure.

  • HAND: the test set is in the process of handing off the UE.

  • REG: the test set is in the process of performing a registration with the UE.

  • APR: the test set is receiving access probes from UE

Query

Range: IDLE | PAG |SREQ | CONN | REL | HAND | REG | APR

Requirements

Test Application Revision: A.02.00 and above

Programming Example

"CALL:STATus?"

CALL:STATus[:STATe]:DATA?

Function

Queries the status of the data connection:

  • ATT: attached, which indicates the UE has successfully completed the GPRS attach procedure.

  • DET: detached, which indicates the completion of the GPRS Detach procedure.

Query

Range: IDLE | ATT | DET | PDPAG | PDP | PDPD

Requirements

Test Application Revision: A.02.00 and above

Test Application Revision: A.05.00 and above, added PDPAG | PDP | PDPD

Programming Example

"CALL:STATus:DATA?"

CALL:STATus:SERVice:TYPE?

Function

Queries the current paging service type.

The current service type will be set to NONE when an event occurs that causes the service to be stopped. These events include:

  • End Call

  • A call processing error that results in a dropped call

  • UE initiated end of service

  • Full or Partial Preset

Query

Range:

  • AMR: AMR Voice

  • RBT: RB Test Mode

  • RBTH: RB Test Mode - HSDPA

  • 9.91 E+37 (NONE)

Requirements

Test Application Revision: A.03.00 and above

Programming Example

"CALL:STATus:SERVice:TYPE?"

CALL:STATus:TOTal:POWer[:AMPLitude][:SELected]?

Function | Queries the current total RF power for the current system type.
Query | Range: -165dBm/1.28MHz to 39.12dBm/1.28MHz, or 9.91 E+37 (NAN)
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "CALL:STATus:TOTal:POWer?"

CALL:STATus:TOTal:POWer[:AMPLitude]:TDSCdma?

Function | Queries the current TD-SCDMA total RF power.
Query | Range: -165dBm/1.28MHz to 39.12dBm/1.28MHz, or 9.91 E+37 (NAN)
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "CALL:STATus:TOTal:POWer:TDSCdma?"

CALL:STATus:TOTal:POWer:STATe[:SELected]?

Function | Queries the current total RF power state for the current system type.
Query | Range: 0(off)|1(on)
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "CALL:STATus:TOTal:POWer:STATe?"

CALL:STATus:TOTal:POWer:STATe:TDSCdma?

Function | Queries the current TD-SCDMA total RF power state.
Query | Range: 0(off)|1(on)
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "CALL:STATus:TOTal:POWer:STATe:TDSCdma?"


CALL:TDTest

  • CALL:TDTest:CLPControl:UPLink:MODE

  • CALL:TDTest:DPCHannel:LEVel

  • CALL:TDTest:DPCHannel[:SLEVel]

  • CALL:TDTest:DPCHannel:STATe

  • CALL:TDTest:PICHannel:DATA

  • CALL:TDTest:TFCIndicator

  • CALL:TDTest:UPLink:DPCHannel:MCONfig

  • CALL:TDTest:UPLink:DPCHannel:MSHift

  • CALL:TDTest:UPLink:TFCIndicator:CONTrol:AUTO

  • CALL:TDTest:UPLink:TFCIndicator:MANual

For more information on the GPIB Command conventions, see GPIB Command conventions

CALL:TDTest:CLPControl:UPLink:MODE

Function | Sets/queries the Uplink Closed Loop Power Control Mode in TD-SCDMA operating mode.
Setting | Range:DOWN | UP | ALTernating | ACTive
Query | Range:DOWN | UP | ALT | ACT
*RST Setting | ALTernating
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "CALL:TDTest:CLPControl:UPLink:MODE UP"

CALL:TDTest:DPCHannel[:SLEVel]

Function | The setting form of this command performs two functions: (1) sets the TD-SCDMA Test DL DPCH level and (2) sets TD-SCDMA Test DL DPCH level state to on. The query form of this command returns the TD-SCDMA Test DL DPCH level.
Setting | Range:-30.00 dB to 0 dB Resolution:0.01
Query | Same as setting
*RST Setting | 0dB
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "CALL:TDTest:DPCHannel -7"

CALL:TDTest:DPCHannel:STATe

Function | Sets/queries the TD-SCDMA Test DL DPCH level state.
Setting | Range:On|Off
Query | Range:1|0
*RST Setting | On
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "CALL:TDTest:DPCHannel:STATe ON"

CALL:TDTest:DPCHannel:LEVel

Function | Sets/queries the TD-SCDMA Test DL DPCH level offset.
Setting | Range:-30.00 dB to 0 dB Resolution:0.01
Query | Same as setting
*RST Setting | 0dB
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "CALL:TDTest:DPCHannel:LEVel -7"

CALL:TDTest:PICHannel:DATA

Function | Sets/queries the TD-SCDMA Test DL PICH Data . The pattern can be set to either all ones or all zeros.
Setting | Range: ZERos | ONES
Query | Range: ZER | ONES
*RST Setting | ZERos
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "CALL:TDTest:PICHannel:DATA ZER"

CALL:TDTest:TFCIndicator

Function | Sets/queries the TD-SCDMA Test DL TFCI Pattern.
Setting | Range: "00" to "1F"
Query | Same as setting
*RST Setting | "00"
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "CALL:TDTest:TFCIndicator '00'"

CALL:TDTest:UPLink:DPCHannel:MCONfig

Function | Sets/queries the TD-SCDMA Test UL DPCH midamble configuration.
Setting | Range:2, 4, 6, 8, 10, 12, 14, 16
Query | Same as setting
*RST Setting | +8
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "CALL:TDTest:UPLink:DPCHannel:MCONfig 8"

CALL:TDTest:UPLink:DPCHannel:MSHift

Function | Sets/queries the TD-SCDMA Test UL DPCH midamble shift.
Setting | Range:1 to 16
Query | Same as setting
*RST Setting | +1
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "CALL:TDTest:UPLink:DPCHannel:MSHift 1"

CALL:TDTest:UPLink:TFCIndicator:CONTrol:AUTO

Function | Sets/queries the TD-SCDMA Test UL TFCI control: If the setting is 1(auto mode), the test set uses the received TFCI from UE; else the setting is 0(manual mode), the test set uses the TFCI set by CALL:TDTest:UPLink:TFCIndicator:MANual command.
Setting | Range:1|ON|0|OFF
Query | 1|0
*RST Setting | 0 (manual)
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "CALL:TDTest:UPLink:TFCIndicator:CONTrol:AUTO 1"

CALL:TDTest:UPLink:TFCIndicator:MANual

Function

Sets/queries manual uplink TFCI that controls which transport format combination the test set expects from the uplink DPCH.

This setting is only applicable when CALL:TDTest:UPLink:TFCIndicator:CONTrol:AUTO is set to OFF (manual).

Setting

Range:NONE|DCCHannel|DTCHannelDTDCchannel

Query

1 to 4

*RST Setting

DCCHannel

Requirements

Test Application Revision: A.02.00 and above

Programming Example

"CALL:TDTest:UPLink:TFCIndicator:MANual DCCHannel"


CALL:TMSI

  • CALL[:CELL]:TMSI:ASSignment

  • CALL[:CELL]:TMSI[:VALue]

For more information on the GPIB Command conventions, see GPIB Command conventions

CALL[:CELL]:TMSI:ASSignment

Function

Sets/queries the TMSI assignment to be ON/OFF. When the setting is ON, TMSI will be assigned to mobile subscriber after a successful location update procedure, and the test set can page the UE using the TMSI.

This parameter can be set in active cell operating mode only when the call status is Idle, or in other operating modes.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (OFF)

Requirements

Test Application Revision: A.02.00 and above

Programming Example

"CALL:TMSI:ASSignment ON"

CALL[:CELL]:TMSI[:VALue]

Function

Sets/queries the Temporary Mobile Subscriber Identity (TMSI), which shall be used to page if CS Paging Identity Type is set to TMSI.

This parameter can be set in active cell operating mode only when the call status is Idle, or in other operating modes.

Setting

Range: 0 to 4 294 967 294

Query

Range: 0 to 4 294 967 294

*RST Setting

0

Requirements

Test Application Revision: A.02.00 and above

Programming Example

"CALL:TMSI 1348339801"


CALL:TOTal:POWer

  • CALL:TOTal:POWer[:AMPLitude][:SELected]?

  • CALL:TOTal:POWer[:AMPLitude]:TDSCdma?

  • CALL:TOTal:POWer:STATe[:SELected]?

  • CALL:TOTal:POWer:STATe:TDSCdma?

For more information on the GPIB Command conventions, see GPIB Command conventions

CALL:TOTal:POWer[:AMPLitude][:SELected]?

Function | Queries the desired total RF power for the current operating mode. The total RF power is a calculated value, which is the sum of cell power and AWGN power.
Query | Range:+39.12dBm/1.28MHz to -165dBm/1.28MHz or 9.91 E+37 (NAN)
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "CALL:TOTal:POWer?"

CALL:TOTal:POWer[:AMPLitude]:TDSCdma?

Function | Queries the desired total RF power when in the TD-SCDMA Test operating mode. The total RF power is a calculated value, which is the sum of cell power and AWGN power.
Query | Range:+39.12dBm/1.28MHz to -165dBm/1.28MHz or 9.91 E+37 (NAN)
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "CALL:TOTal:POWer:TDSCdma?"

CALL:TOTal:POWer:STATe[:SELected]?

Function | Queries the total RF power state for the current operating mode. Note,the total RF power state is on if either cell power or AWGN power is on,and the return value for this query is not necessarily the total power state at the moment this command is processed by the test set.
Query | Range:1|0
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "CALL:TOTal:POWer:STATe?"

CALL:TOTal:POWer:STATe:TDSCdma?

Function | Queries the total RF power state when in the TD-SCDMA Test operating mode. Note,the total RF power state is on if either cell power or AWGN power is on,and the return value for this query is not necessarily the total power state at the moment this command is processed by the test set.
Query | Range:1|0
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "CALL:TOTal:POWer:STATe:TDSCdma?"


CALL:TRIGger

  • CALL:TRIGger[:OUTPut]:SIGNal

For more information on the GPIB Command conventions, see GPIB Command conventions

CALL:TRIGger[:OUTPut]:SIGNal

Function | Sets/queries Trigger Output Setup.
Setting | Range: SFCLock|MGENerated
Query | Range:SFCL|MGEN
*RST Setting | SFCL
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "CALL:TRIGger:SIGNal MGENerated"


CALL:UPLink

  • CALL:UPLink:PRAChannel:POWer:LEVel

  • CALL:UPLink:PRAChannel:POWer:INITial[:LEVel]?

  • CALL:UPLink:TXPower:LEVel:MAXimum

  • CALL:UPLink:UPPChannel:POWer:INITial[:LEVel]?

  • CALL:UPLink:UPPChannel:POWer:LEVel

  • CALL:UPLink:UPPChannel:POWer:STEP[:LEVel]

  • CALL:UPLink:UPPChannel:SYNChronize:ANUMber[:MAXimum]

  • CALL:UPLink:UPPChannel:SYNChronize:CBITmap

  • CALL:UPLink:UPPChannel:SYNChronize:TRANsmission[:MAXimum]

For more information on the GPIB Command conventions, see GPIB Command conventions

CALL:UPLink:TXPower:LEVel:MAXimum

Function

Sets/queries the Maximum Allowed UL TX Power setting.

The setting can be set in active cell operating mode only when the call status is Idle, or in other operating modes.

If BCCH Update Page is set to Auto and you change the setting while your UE is camped to the test set, the test set performs a Broadcast Channel (BCCH) Update Procedure ; If BCCH Update Page is set to Inhibit (the default value) and you change the setting while your UE is camped to the test set, the UE is informed to re-read the BCCH to observe the change (see CALL:BCCHannel:UPDAte:PAGE AUTO).

Setting

Range: -50 to +33 dBm

Query

Range: -50 to +33

*RST Setting

33

Requirements

Test Application Revision: A.02.00 and above

Programming Example

"CALL:UPLink:TXPower:LEVel:MAXimum 33"

CALL:UPLink:UPPChannel:POWer:STEP[:LEVel]

Function | Sets/queries the UpPCH Power Ramp Step setting.
Setting | Range: 0|1|2|3 dB
Query | Range: 0|1|2|3
*RST Setting | 3
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "CALL:UPLink:UPPChannel:POWer:STEP 3"

CALL:UPLink:UPPChannel:POWer:LEVel

Function | Sets/queries Desired UpPCH RX Power. The setting can be set in active cell operating mode only when the call status is Idle, or in other operating modes.
Setting | Range: -120 to -58 dBm
Query | Range: -120 to -58
*RST Setting | -100
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "CALL:UPLink:UPPChannel:POWer:LEVel -100"

CALL:UPLink:UPPChannel:POWer:INITial[:LEVel]?

Function | Queries the Initial UpPCH TX Power.
Query | Range: -65 to +30
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "CALL:UPLink:UPPChannel:POWer:INITial?"

CALL:UPLink:UPPChannel:SYNChronize:CBITmap

Function | Sets/queries SYNC UL Code Bitmap setting.
Setting | Range: 0000 0001 to 1111 1111
Query | Range: 0000 0001 to 1111 1111
*RST Setting | 1111 1111
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "CALL:UPLink:UPPChannel:SYNChronize:CBITmap '00000001'"

CALL:UPLink:UPPChannel:SYNChronize:TRANsmission[:MAXimum]

Function | Sets/queries the maximum numbers of SYNC_UL transmissions in a synchronisation attempt initiated by the UE. This parameter will be sent in SIB5 on BCCH.
Setting | Range: TRANsmit1 | TRANsmit2 | TRANsmit4 | TRANsmit8
Query | Range: TRAN1|TRAN2|TRAN4|TRAN8
*RST Setting | TRANsmit8
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "CALL:UPLink:UPPChannel:SYNChronize:TRANsmission:MAXimum TRANsmit8"

CALL:UPLink:UPPChannel:SYNChronize:ANUMber[:MAXimum]

Function | Sets/queries the maximum number of synchronisation attempts in one random access procedure. This parameter will be sent in SIB5 on BCCH.
Setting | Range: 1 to 32
Query | Range: 1 to 32
*RST Setting | 32
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "CALL:UPLink:UPPChannel:SYNChronize:ANUMber:MAXimum 32"

CALL:UPLink:PRAChannel:POWer:LEVel

Function | Sets/queries Desired PRACH RX Power. The setting can be set in active cell operating mode only when the call status is Idle, or in other operating modes.
Setting | Range: -120 to -80 dBm
Query | Range: -120 to -80
*RST Setting | -100
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "CALL:UPLink:PRAChannel:POWer:LEVel -100"

CALL:UPLink:PRAChannel:POWer:INITial[:LEVel]?

Function | Queries the Initial PRACH TX Power.
Query | Range: -65 to +30
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "CALL:UPLink:PRAChannel:POWer:INITial:LEVel?"


ABORt Subsystem

Last updated: March 31, 2010

Description

The ABORt command causes a measurement cycle in progress to stop. If the measurement is not being continuously armed (trigger arm set to single) , the measurement will remain in the idle state after this event. If the measurement is being continuously armed (trigger arm set to continuous), a new measurement cycle will begin after ABORt. If an ABORt command is issued from any measurement state other than measuring, the command is ignored.

Other Commands that Execute an ABORt Action

INITiate:<meas> will execute an ABORt:<meas> as part of the INITiate:<meas> command.

READ:<meas>? will execute an ABORt:<meas> action that aborts just one trigger sequence and then combines the INITiate and FETCh? commands.

Related Topics

  • ABORt


ABORt

Last updated: March 31, 2010

  • ABORt[:ALL]

  • ABORt<:measurement mnemonic>

For more information on the GPIB Command conventions, see GPIB Command conventions

ABORt[:ALL]

Function | Stops all measurements that are active. If the trigger arm is set to single, the measurements will go to the idle state. If the trigger arm is set to continuous, the measurements will re-arm and initiate again.
Setting | No setting
Query | No Query
*RST Setting | None
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "ABORt"

ABORt<:measurement mnemonic>

Function

Stops the selected measurement if it is active.

If the trigger arm is set to single, the measurements will go to the idle state.

If the trigger arm is set to continuous the measurements will re-arm and initiate again.

Setting

  • TCP (Channel Power Measurement)

  • TWQ (Waveform Quality Measurement)

  • TACL (Adjacent Channel Leakage Ratio

  • TSEMask (Spectrum Emission Mask Measurement )

  • FSTability (Frequency Stability Measurement)

  • TCLPower (Closed Loop Power Control Measurement)

  • TOBWidth (Occupied Bandwidth Measurements)

  • TDPower (Dynamic Power Measurement)

  • TOOPower (Transmit ON/OFF Power Measurement)

  • TBERror (Loopback Bit Error Rate Measurement)

  • TOLPower (Open Loop Power Control Measurement)

  • TBLerror (Block Error Ratio Measurement)

  • THBLerror (HSDPA Block Error Ratio Measurement)

  • TOOSynch (Out-of-Synchronization of Output Power Measurement)

  • TFDTune (Fast Device Tune Measurement)

  • THCQuality (Reporting of Channel Quality Indicator Measurement )

Query

No Query

*RST Setting

None

Requirements

Test Application Revision: A.01.00 and above
Test Application Revision: A.02.00 and above, added TOB, TDP, and TOOP, TBERror.

Test Application Revision: A.03.00 and above, added TOLP, TBLerror and THBLerror.

Test Application Revision: A.04.00 and above, added TOOSynch, TFDT, THCQuality.

Programming Example

"ABORt:TCPower"


FETCh Subsystem

Description

The FETCh? query is a function that allows users to query results from a measurement that was previously INITiated or READ. It does NOT begin a measurement. If no measurement is in progress it will return the integrity and measurement values from the last measurement made, or return an integrity of No Result Available and results of NAN. If a measurement is in process, the query will hang until the results are available, or the measurement fails or times out. The exact results returned with a FETCh? will depend on the specific measurement. A measurement may have a number of different results or combination of results for a FETCh?. The FETCh? queries are intended to be used to provide overlapped operation access to measurement results from the test set. When used along with SETup and INITiate commands , FETCh? is the primary way for the user to retrieve measurement results. In order to use the test set's concurrent test capabilities the overlapped commands of INITiate and FETCh? must be used. Overlapped commands allow the user to send commands and not wait for completion.

Related Topics

  • FETCh:FSTability

  • FETCh:TACLeakage

  • FETCh:TBERror

  • FETCh:TCLPower

  • FETCh:TCPower

  • FETCh:TDPower

  • FETCh:TOBWidth

  • FETCh:TOOPower

  • FETCh:TSEMask

  • FETCh:TWQuality


FETCh:FSTability

Last updated: April 26, 2010

  • FETCh:FSTability[:ALL]?

  • FETCh:FSTability:FERRor[:WORSt]?

  • FETCh:FSTability:FERRor:ALL?

  • FETCh:FSTability:FERRor:AVERage?

  • FETCh:FSTability:FERRor:MAXimum?

  • FETCh:FSTability:FERRor:MINimum?

  • FETCh:FSTability:FREQuency[:AVERage]?

  • FETCh:FSTability:FREQuency:ALL?

  • FETCh:FSTability:FREQuency:MAXimum?

  • FETCh:FSTability:FREQuency:MINimum?

  • FETCh:FSTability:FREQuency:SDEViation?

  • FETCh:FSTability:ICOunt?

  • FETCh:FSTability:INTegrity?

For more information on the GPIB Command conventions, see GPIB Command conventions

For the measurement, see Frequency Stability Measurement.

FETCh:FSTability[:ALL]?

Function

Queries the frequency stability measurement. Returns integrity, worst-case frequency error, and average frequency.

Query

Worst-case frequency error:

  • Range: -500 to 500 parts per million (ppm)

  • Resolution: 0.01 ppm

Average frequency:

  • Range: 100 E+6 to 3 E+9 Hz

  • Resolution: 0.01 ppm

Requirements

Test Application Revision: A.01.00 and above

Programming Example

"FETCH:FSTABILITY:ALL?"

FETCh:FSTability:FERRor[:WORSt]?

Function | Queries the frequency stability frequency error measurement.
Query | Range: -500 to 500 parts per million (ppm) Resolution: 0.01 ppm
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "FETCH:FSTABILITY:FERROR:WORST?"

FETCh:FSTability:FERRor:ALL?

Function

Queries the frequency stability frequency error measurements.

Measurement results are returned in the following order: minimum frequency error, maximum frequency error, average frequency error, worst-case frequency error.

Query

Maximum, minimum frequency error:

  • Range: -500 E+3 to 500 E+3 Hz

  • Resolution: 1 Hz

Average frequency error:

  • Range: -500 E+3 to 500 E+3 Hz

  • Resolution: 1 Hz

Worst-case frequency error:

  • Range: -500 to 500 parts per million (ppm)

  • Resolution: 0.01

Requirements

Test Application Revision: A.01.00 and above

Programming Example

"FETCH:FSTABILITY:FERROR:ALL?"

FETCh:FSTability:FERRor:AVERage?

Function | Queries the average frequency error measurement.
Query | Range: -500 E+3 to 500 E+3 Hz Resolution: 1 Hz
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "FETCH:FSTABILITY:FERROR:AVERAGE?"

FETCh:FSTability:FERRor:MAXimum?

Function | Queries the maximum frequency error measurement.
Query | Range: -500 E+3 to 500 E+3 Hz Resolution: 1 Hz
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "FETCH:FSTABILITY:FERROR:MAXIMUM?"

FETCh:FSTability:FERRor:MINimum?

Function | Queries the minimum frequency error measurement.
Query | Range: -500 E+3 to 500 E+3 Hz Resolution: 1 Hz
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "FETCh:FSTability:FERRor:MINimum?"

FETCh:FSTability:FREQuency[:AVERage]?

Function | Queries the frequency stability average frequency measurement.
Query | Range: 100 E+6 to 3 E+9 Hz Resolution: 1 Hz
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "FETCH:FSTABILITY:FREQUENCY:AVERAGE?"

FETCh:FSTability:FREQuency:ALL?

Function

Queries the frequency stability frequency measurement.

Measurement results are returned in the following order: minimum frequency, maximum frequency, average frequency, and standard deviation frequency.

Query

Minimum, maximum, average frequency:

  • Range: 100 E+6 to 3 E+9

  • Resolution: 1 Hz

Standard deviation frequency:

  • Range: 0 to 500 E+3 Hz

  • Resolution: 0.1 Hz

Requirements

Test Application Revision: A.01.00 and above

Programming Example

"FETCH:FSTABILITY:FREQUENCY:ALL?"

FETCh:FSTability:FREQuency:MAXimum?

Function | Queries the maximum frequency stability frequency.
Query | Range: 100 E+6 to 3 E+9 Resolution: 1 Hz
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "FETCH:FSTABILITY:FREQUENCY:MAXIMUM?"

FETCh:FSTability:FREQuency:MINimum?

Function | Queries the minimum frequency stability frequency.
Query | Range: 100 E+6 to 3 E+9 Resolution: 1 Hz
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "FETCH:FSTABILITY:FREQUENCY:MINIMUM?"

FETCh:FSTability:FREQuency:SDEViation?

Function | Queries the standard deviation frequency stability frequency.
Query | Range: 0 to 500 E+3 Hz Resolution: 0.1 Hz
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "FETCH:FSTABILITY:FREQUENCY:SDEVIATION?"

FETCh:FSTability:ICOunt?

Function | Queries the intermediate count of measurements completed in a multi-measurement.
Query | Range: 0 to 999
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "FETCH:FSTABILITY:ICOUNT?"

FETCh:FSTability:INTegrity?

Function | Queries the measurement integrity indicator for the last frequency stability measurement completed. Zero indicates a normal measurement.
Query | Range: see Integrity Indicator
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "FETCH:FSTABILITY:INTEGRITY?"


FETCh:TACLeakage

Last updated: April 26, 2010

  • FETCh:TACLeakage[:ALL]?

  • FETCh:TACLeakage:ICOunt?

  • FETCh:TACLeakage:ICPower[:AVERage]?

  • FETCh:TACLeakage:ICPower:ALL?

  • FETCh:TACLeakage:ICPower:MAXimum?

  • FETCh:TACLeakage:ICPower:MINimum?

  • FETCh:TACLeakage:ICPower:SDEViation?

  • FETCh:TACLeakage:INTegrity?

  • FETCh:TACLeakage:LOWer:ADJacent?

  • FETCh:TACLeakage:LOWer:ALTernate?

  • FETCh:TACLeakage:UPPer:ADJacent?

  • FETCh:TACLeakage:UPPer:ALTernate?

For more information on the GPIB Command conventions, see GPIB Command conventions.

For the measurement, see Adjacent Channel Leakage Ratio (ACLR) Measurement.

FETCh:TACLeakage[:ALL]?

Function

Queries all the ACLR measurement results, which are returned in the following order: Integrity Indicator, Overall Pass/Fail, Lower adjacent (-1.6MHz) Pass/Fail, Upper adjacent (+1.6MHz) Pass/Fail, Lower alternated (-3.2MHz) Pass/Fail, Upper alternated (+3.2MHz) Pass/Fail, Lower adjacent (-1.6MHz) Result, Upper adjacent (+1.6MHz) Result, Lower alternated (-3.2MHz) Result, Upper alternated (+3.2MHz) Result.

Query

Integrity Indicator (see Integrity Indicator)

Overall Pass/Fail, Lower/Upper adjacent Pass/Fail, Lower/Upper alternated Pass/Fail

  • Range: 0 (Pass) | 1 (Fail)

Lower/Upper adjacent Results, Lower/Upper alternated Results

  • Range: Measured Value, 9.91 E+37

  • Resolution: 0.01

Requirements

Test Application Revision: A.01.00 and above

Programming Example

"FETCh:TACLeakage:ALL?"

FETCh:TACLeakage:ICOunt?

Function | Queries the intermediate count of measurements completed in a multi-measurement.
Query | Range: 0 to 999
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "FETCh:TACLeakage:ICOunt?"

FETCh:TACLeakage:ICPower[:AVERage]?

Function | Queries the average in-channel power results of several adjacent channel leakage measurements.
Query | Range: Measured Value in dBm, 9.91 E+37 Resolution: 0.01
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "FETCh:TACLeakage:ICPower:AVERage?"

FETCh:TACLeakage:ICPower:ALL?

Function | Queries all the ACLR in-channel power results, which are returned in the following order: Minimum, Maximum, Average and standard Deviation in-channel power.
Query | Range: Measured Value in dBm, 9.91 E+37
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "FETCh:TACLeakage:ALL?"

FETCh:TACLeakage:ICPower:MAXimum?

Function | Queries the maximum in-channel power results of several adjacent channel leakage measurements.
Query | Range: Measured Value in dBm, 9.91 E+37 Resolution: 0.01
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "FETCh:TACLeakage:ICPower:MAXimum?"

FETCh:TACLeakage:ICPower:MINimum?

Function | Queries the minimum in-channel power results of several adjacent channel leakage measurements.
Query | Range: Measured Value in dBm, 9.91 E+37 Resolution: 0.01
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "FETCh:TACLeakage:ICPower:MINimum?"

FETCh:TACLeakage:ICPower:SDEViation?

Function | Queries the standard deviation in-channel power results of several adjacent channel leakage measurements.
Query | Range: Measured Value in dB, 9.91 E+37 Resolution: 0.001 dB
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "FETCh:TACLeakage:ICPower:SDEViation?"

FETCh:TACLeakage:INTegrity?

Function | Queries the measurement integrity indicator for the last adjacent channel leakage measurement completed.
Query | Range: see Integrity Indicator
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "FETCh:TACLeakage:INTegrity?"

FETCh:TACLeakage:LOWer:ADJacent?

Function

Queries the -1.6 MHz Offset Result, which are returned in the following order: In-Channel Power, -1.6 MHz Offset Pass/Fail, -1.6 MHz Offset Result/Average, -1.6 MHz Offset Mask Margin.

Query

In-Channel Power/-1.6 MHz Offset Average/-1.6 MHz Offset Mask Margin

  • Range: Measured Value in dBc, 9.91 E+37

  • Resolution: 0.01

-1.6 MHz Offset Pass/Fail

  • Range: 0 (Pass) | 1 (Fail)

Requirements

Test Application Revision: A.01.00 and above

Programming Example

"FETCh:TACLeakage:LOWer:ADJacent?"

FETCh:TACLeakage:LOWer:ALTernate?

Function

Queries the -3.2 MHz Offset Result, which are returned in the following order: In-Channel Power, -3.2 MHz Offset Pass/Fail, -3.2 MHz Offset Result/Average, -3.2 MHz Offset Mask Margin.

Query

In-Channel Power/-3.2 MHz Offset Average/-3.2 MHz Offset Mask Margin

  • Range: Measured Value in dBc, 9.91 E+37

  • Resolution: 0.01

-3.2 MHz Offset Pass/Fail

  • Range: 0 (Pass) | 1 (Fail)

Requirements

Test Application Revision: A.01.00 and above

Programming Example

"FETCh:TACLeakage:LOWer:ALTernate?"

FETCh:TACLeakage:UPPer:ADJacent?

Function

Queries the +1.6 MHz Offset Result, which are returned in the following order: In-Channel Power, +1.6 MHz Offset Pass/Fail, +1.6 MHz Offset Result/Average, +1.6 MHz Offset Mask Margin.

Query

In-Channel Power/+1.6 MHz Offset Average/+1.6 MHz Offset Mask Margin

  • Range: Measured Value in dBc, 9.91 E+37

  • Resolution: 0.01

+1.6 MHz Offset Pass/Fail

  • Range: 0 (Pass) | 1 (Fail)

Requirements

Test Application Revision: A.01.00 and above

Programming Example

"FETCh:TACLeakage:UPPer:ADJacent?"

FETCh:TACLeakage:UPPer:ALTernate?

Function

Queries the +3.2 MHz Offset Result, which are returned in the following order: In-Channel Power, +3.2 MHz Offset Pass/Fail, +3.2 MHz Offset Result/Average, +3.2 MHz Offset Mask Margin.

Query

In-Channel Power/+3.2 MHz Offset Average/+3.2 MHz Offset Mask Margin

  • Range: Measured Value in dBc, 9.91 E+37

  • Resolution: 0.01

+3.2 MHz Offset Pass/Fail

  • Range: 0 (Pass) | 1 (Fail)

Requirements

Test Application Revision: A.01.00 and above

Programming Example

"FETCh:TACLeakage:UPPer:ALTernate?"


FETCh:TBERror

Last updated: April 26, 2010

  • FETCH:TBERror[:ALL]?

  • FETCh:TBERor:BITS?

  • FETCh:TBERor:COUNt?

  • FETCh:TBERor:CRCerrors?

  • FETCh:TBERror:ICOunt?

  • FETCh:TBERror:INTegrity?

  • FETCh:TBERror:LDELay?

  • FETCh:TBERor:MBLocks?

  • FETCh:TBERor:RATio?

  • FETCh:TBERror:RATio:FAIL?

For more information on the GPIB Command conventions, see GPIB Command conventions

For the measurement, see Loopback Bit Error Ratio (BER) Measurement.

FETCH:TBERror[:ALL]?

Function

Returns measurement results in the following order: integrity, bit error ratio, bit error count, bits tested.

Query

Integrity: see Integrity Indicator .

Bit Error Ratio

  • Range: 0 to 99.0000%, 9.91 E+37

  • Resolution: 0.01

Bit Error Count

  • Range: 0 to 999 999 999, 9.91 E+37

  • Resolution: 1

Bits Tested

  • Range: 0 to 999 999 999, 9.91 E+37

  • Resolution: 1

Requirements

Test Application Revision: A.02.00 and above

Programming Example

"FETCH:TBERror?"

FETCh:TBERor:BITS?

Function | Queries the bits tested.
Query | Range: 0 to 999 999 999, 9.91 E+37
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "FETCh:TBERror:BITS?"

FETCh:TBERor:COUNt?

Function | Queries the bit error count.
Query | Range: 0 to 999 999 999, 9.91 E+37
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "FETCh:TBERror:COUNt?"

FETCh:TBERor:CRCerrors?

Function | Queries number of uplink CRC errors.
Query | Range: 0 to 999 999 999, 9.91 E+37
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "FETCh:TBERror:CRCerrors?"

FETCh:TBERror:ICOunt?

Function | Queries the intermediate count of measurements completed in a multi-measurement.
Query | Range: 0 to 999
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "FETCh:TBERror:ICOunt?"

FETCh:TBERror:INTegrity?

Function | Queries the measurement integrity indicator for the last loopback BER measurement completed. Zero indicates a normal measurement. See Integrity Indicator for information about non-zero integrity results.
Query | Range: see Integrity Indicator
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "FETCh:TBERror:INTegrity?"

FETCh:TBERror:LDELay?

Function | Queries the Loopback Delay result, in frame. Loopback Delay results can not be obtained when DL DTCH Data is set to All Zeros, All Ones or Alternating.
Query | Range: 0 to 50, 9.91 E+37
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "FETCh:TBERror:LDELay?"

FETCh:TBERor:MBLocks?

Function | Queries the Missing Blocks result.
Query | Range: 0 to 999 999 999, 9.91 E+37
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "FETCh:TBERror:MBLocks?"

FETCh:TBERor:RATio?

Function | Queries Bit Error Ratio result, which is the ratio of incorrectly received bits to the bits tested, expressed as a percentage (%).
Query | Range: 0 to 99.0000%, 9.91 E+37
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "FETCh:TBERror:RATio?"

FETCh:TBERror:RATio:FAIL?

Function | Queries the Confidence Test Result. The query result is only available when Confidence State is On.
Query | Range: 0 (Pass) |1 (Fail)|2 (Max Bits) |9.91 E+37
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "FETCh:TBERror:RATio:FAIL?"


FETCh:TBLerror

Last updated: March 10, 2010

  • FETCH:TBLerror[:ALL]?

  • FETCh:TBLerror:BLOCks?

  • FETCh:TBLerror:COUNt?

  • FETCh:TBLerror:ICOunt?

  • FETCh:TBLerror:INTegrity?

  • FETCh:TBLerror:MBLocks?

  • FETCh:TBLerror:RATio?

For more information on the GPIB Command conventions, see GPIB Command conventions.

For the measurement, see Block Error Ratio (BLER) Measurement.

FETCH:TBLerror[:ALL]?

Function

Queries the block error ratio measurement results in the following order: integrity, block error ratio, block error count, blocks tested, uplink missing blocks.

Query

Integrity

  • Range:see Integrity Indicator .

  • Resolution: 1

Block Error Ratio

  • Range: 0 to 99%, 9.91 E+37

  • Resolution: 0.01%

Block Error Count

  • Range: 0 to 99000, 9.91 E+37

  • Resolution: 1

Blocks Tested

  • Range:0 to 99000, 9.91 E+37

  • Resolution: 1

Uplink Missing Blocks

  • Range: 0 to 99000, 9.91 E+37

  • Resolution:1

Requirements

Test Application Revision: A.03.00 and above

Programming Example

"FETCH:TBLerror?"

FETCh:TBLerror:BLOCks?

Function | Queries the tested blocks for the block error ratio measurement.
Query | Range:0 to 99000, 9.91 E+37 Resolution: 1
Requirements | Test Application Revision: A.03.00 and above
Programming Example | "FETCh:TBLerror:BLOCks?"

FETCh:TBLerror:COUNt?

Function | Queries the Block Error Count result for the block error ratio measurement.
Query | Range: 0 to 99000, 9.91 E+37 Resolution: 1
Requirements | Test Application Revision: A.03.00 and above
Programming Example | "FETCh:TBLerror:COUNt?"

FETCh:TBLerror:ICOunt?

Function | Queries the the intermediate count of blocks tested in the block error ratio measurement.
Query | Range:
Requirements | Test Application Revision: A.03.00 and above
Programming Example | "FETCh:TBLerror:ICOunt?"

FETCh:TBLerror:INTegrity?

Function | Queries the integrity of the block error ratio measurement result.
Query | Range:see Integrity Indicator . Resolution: 1
Requirements | Test Application Revision: A.03.00 and above
Programming Example | "FETCh:TBLerror:INTegrity?"

FETCh:TBLerror:MBLocks?

Function | Queries the Uplink Missing Blocks result for the block error ratio measurement.
Query | Range: 0 to 99000, 9.91 E+37 Resolution:1
Requirements | Test Application Revision: A.03.00 and above
Programming Example | "FETCh:TBLerror:MBLocks?"

FETCh:TBLerror:RATio?

Function | Queries the Block Error Ratio result for the block error ratio measurement.
Query | Range: 0 to 99%, 9.91 E+37 Resolution: 0.01%
Requirements | Test Application Revision: A.03.00 and above
Programming Example | "FETCh:TBLerror:RATio?"


FETCh:TCLPower

Last updated: April 26, 2010

  • FETCh:TCLPower[:ALL]?

  • FETCh:TCLPower:INTegrity?

  • FETCh:TCLPower:MAXimum:POWer?

  • FETCh:TCLPower:MINimum:POWer?

  • FETCh:TCLPower:STEP?<sp><step index>

  • FETCh:TCLPower:TRACe[:ABSolute]?

  • FETCh:TCLPower:TRACe:FAIL?

  • FETCh:TCLPower:TRACe:RELative?

  • FETCh:TCLPower:TRACe:RELative10

For more information on the GPIB Command conventions, see GPIB Command conventions.

For the closed loop power control measurement description, see Closed Loop Power Control (CLPC) Measurement.

FETCh:TCLPower[:ALL]?

Function

Queries the closed loop power control measurement results in the following order: integrity indicator, overall pass/fail, maximum power, minimum power, worst REL1POW step index, worst REL1POW absolute power, worst REL1POW, worst REL10POW step index, worst REL10POW absolute power and worst REL10POW.

The Pass/Fail indicator is a decimal number that combines the pass/fail results of the REL1POW and the REL10POW together. If the binary expression of this decimal number is "b3b2b1b0", then the meaning of each digit is as follows:

  • b0 : REL1POW trace Pass(0)/Fail(1)

  • b1 : REL10POW trace Pass(0)/Fail(1)

  • b2 : Maximum Power Pass(0)/Fail(1)

  • b3 : Minimum Power Pass(0)/Fail(1)

The worst step refers to the step whose relative power (REL1POW or REL10POW) is closest to its upper or lower limit among all checked steps.

The REL1POW or REL10POW power trace is failed If there is at least one step in the trace is failed or no step in the trace is checked.

Query

Integrity Indicator (see Integrity Indicator)

Overall Pass / Fail

  • Range: 0 to 15, 9.91 E+37 (NAN)

  • Resolution: 1

Maximum Power (the maximum absolute power among all measured steps)

  • Range: value in dBm, 9.91 E+37 (NAN)

  • Resolution: 0.01

Minimum Power (the minimum absolute power among all measured steps)

  • Range: value in dBm, 9.91 E+37 (NAN)

  • Resolution:0.01

Worst REL1POW Step Index:

  • Range: 0 to 300, 9.91 E+37 (NAN)

  • Resolution: 1

Worst REL1POW Absolute Power:

  • Range: value in dBm, 9.91 E+37 (NAN)

  • Resolution: 0.01

Worst REL1POW:

  • Range: value in dB, 9.91 E+37 (NAN)

  • Resolution: 0.01

Worst REL10POW Step Index:

  • Range: 0 to 300, 9.91 E+37 (NAN)

  • Resolution: 1

Worst REL10POW Absolute Power:

  • Range: value in dBm, 9.91 E+37 (NAN)

  • Resolution: 0.01

Worst REL10POW:

  • Range: value in dB, 9.91 E+37 (NAN)

  • Resolution:0.01

Requirements

Test Application Revision: A.01.00 and above

Programming Example

"FETCh:TCLPower?"

FETCh:TCLPower:INTegrity?

Function | Queries the measurement integrity indicator for the closed loop power control measurement results. Zero indicates a normal measurement.
Query | Range: see Integrity Indicator
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "FETCH:TCLPower:INTegrity?"

FETCh:TCLPower:MAXimum:POWer?

Function

Queries the maximum power results in the following order: pass/fail indicator, maximum power step index, the maximum mean power among all measured steps.

The pass/fail indicator is based on the maximum power limits. See SETup:TCLPower:MAXimum:POWer:LIMit.

The maximum power step index is the index of the step that has the maximum power.

The maximum power is the maximum mean power (NOT RRC filtered) among all measured steps.

Query

Pass/Fail

  • Range: 0 (Pass) | 1( Fail)

Maximum Power Step Index

  • Range: 0 to 300, 9.91 E+37 (NAN)

  • Resolution: 1

Maximum Mean Power

  • Range:value in dBm, 9.91 E+37 (NAN)

  • Resolution: 0.01

Requirements

Test Application Revision: A.01.00 and above

Programming Example

"FETCh:TCLPower:MAXimum:POWer?"

FETCh:TCLPower:MINimum:POWer?

Function

Queries the minimum power results in the following order:: pass/fail indicator, minimum power step index, the minimum mean power among all measured steps.

The pass/fail indicator is based on the minimum power limits. See SETup:TCLPower:Minimum:POWer:LIMit.

The minimum power step index is the index of the step that has the minimum power.

The minimum power is the minimum mean power (NOT RRC filtered) among all measured steps.

Query

Pass/Fail

  • Range: 0 (Pass) | 1( Fail)

Minimum Power Step Index:

  • Range: 0 to 300, 9.91 E+37 (NAN)

  • Resolution:1

Minimum Power:

  • Range: value in dBm, 9.91 E+37 (NAN)

  • Resolution:0.01

Requirements

Test Application Revision: A.01.00 and above

Programming Example

"FETCh:TCLPower:MINimum:POWer?"

FETCh:TCLPower:STEP?<sp><step index>

Function

Queries the specific step results in the following order: Pass/Fail indicator, absolute power of this step, REL1POW and REL10POW.

This query must include the <step index> parameter, which ranges from 0 to 300.

The Pass/Fail indicator is a decimal number that combines the pass/fail result of the REL1POW and the REL10POW together. The meaning of each range is as follows:

  • 0: Both REL1POW and REL10POW are passed.

  • 1: REL1POW trace failed, and REL10POW trace passed or NOT checked*.

  • 2: REL10POW trace failed, and REL1POW trace passed.

  • 3: Both the REL1POW and REL10POW traces are failed.

  • 9.91E37 (NAN) : Both REL1POW and REL10POW are NOT checked*.

*The relative power is NOT checked if there is at least one step between the reference step and the measured step out of checking range, or the reference step is not available (such as step 0 for REL1POW and step 0 to 9 for REL10POW).

Query

Pass/Fail

  • Range: 0 to 3, 9.91 E+37 (NAN)

  • Resolution: 1

Step Absolute power:

  • Range: value in dBm and 9.91 E+37 (NAN)

  • Resolution: 0.01

Step REL1POW:

  • Range: value in dB and 9.91 E+37 (NAN)

  • Resolution: 0.01

Step REL10POW:

  • Range: value in dB and 9.91 E+37 (NAN)

  • Resolution: 0.01

Requirements

Test Application Revision: A.01.00 and above

Programming Example

"FETCh:TCLPower:STEP? 0"

FETCh:TCLPower:TRACe[:ABSolute]?

Function | Queries the 301 comma-separated trace values for absolute power.
Query | Range: value in dBm, 9.91 E+37 (NAN) Resolution: 0.01
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "FETCH:TCLPower:TRACE?"

FETCh:TCLPower:TRACe:FAIL?

Function

Queries the 301 comma-separated trace values for Pass/Fail indicators.

The Pass/Fail indicator is a decimal number that combines the pass/fail result of the REL1POW and the REL10POW together. The meaning of each range is as follows:

  • 0 : Both REL1POW and REL10POW passed.

  • 1 : REL1POW trace failed, and REL10POW trace passed or NOT checked*.

  • 2 : REL10POW trace failed, and REL1POW trace passed.

  • 3 : Both the REL1POW and REL10POW traces are failed.

  • 9.91 E+37 (NAN) : Both REL1POW and REL10POW are NOT checked*.

*The relative power is NOT checked if there is at least one step between the reference step and the measured step out of checking range, or the reference step is not available (such as step 0 for REL1POW and step 0 to 9 for REL10POW).

Query

Range: 0 to 3, 9.91 E+37

Resolution: 1

Requirements

Test Application Revision: A.01.00 and above

Programming Example

"FETCH:TCLPower:TRACE:FAIL?"

FETCh:TCLPower:TRACe:RELative?

Function | Queries the 301 comma-separated trace values for REL1POW.
Query | Range: value in dB, 9.91 E+37 (NAN) Resolution: 0.01
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "FETCH:TCLPower:TRACE:RELative?"

FETCh:TCLPower:TRACe:RELative10?

Function | Queries the 301 comma-separated trace values for REL10POW.
Query | Range:value in dB, 9.91 E+37 (NAN) Resolution:0.01
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "FETCH:TCLPower:TRACE:RELative10?"


FETCh:TCPower

Last updated: April 26, 2010

  • FETCh:TCPower[:ALL]?

  • FETCh:TCPower:ICOunt?

  • FETCh:TCPower:INTegrity?

  • FETCh:TCPower:POWer:ALL?

  • FETCh:TCPower:POWer[:AVERage]?

  • FETCh:TCPower:POWer:MAXimum?

  • FETCh:TCPower:POWer:MINimum?

  • FETCh:TCPower:POWer:SDEViation?

For more information on the GPIB Command conventions, see GPIB Command conventions.

For the channel power measurement description, see Channel Power Measurement.

FETCh:TCPower[:ALL]?

Function | Queries the channel power measurement result. This query returns an integrity indicator followed by the average channel power measurement result.
Setting | No setting
Query | Range: -99 to 99 dBm, 9.91 E+37 Resolution: 0.01 dBm
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "FETCH:TCPOWER:ALL?"

FETCh:TCPower:ICOunt?

Function | Queries the intermediate count of measurements completed in a multi-measurement.
Setting | No setting
Query | Range: 0 to 999
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "FETCH:TCPOWER:ICOUNT?"

FETCh:TCPower:INTegrity?

Function | Queries the measurement integrity indicator for the last channel power measurement completed. Zero indicates a normal measurement. See Integrity Indicator for information about non-zero integrity results.
Setting | No setting
Query | Range: see Integrity Indicator
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "FETCH:TCPOWER:INTegrity?"

FETCh:TCPower:POWer:ALL?

Function | Queries the statistical measurement results for several channel power measurements. Results are returned in the following order: minimum, maximum, average, and standard deviation channel power
Setting | No setting
Query | Range: -99 to 99 dBm, 9.91 E+37 Resolution: 0.01 dB
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "FETCH:TCPOWER:POWER:ALL?"

FETCh:TCPower:POWer[:AVERage]?

Function | Queries the average of the results of several channel power measurements.
Setting | No setting
Query | Range: -99 to 99 dBm, 9.91 E+37 Resolution: 0.01 dB
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "FETCH:TCPOWER:POWER:AVERAGE?"

FETCh:TCPower:POWer:MAXimum?

Function | Queries the maximum power of several channel power measurements.
Setting | No setting
Query | Range:-99 to 99 dBm, 9.91 E+37 Resolution: 0.01 dB
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "FETCH:TCPOWER:POWER:MAXIMUM?"

FETCh:TCPower:POWer:MINimum?

Function | Queries the minimum power of several channel power measurements.
Setting | No setting
Query | Range: -99 to 99 dBm, 9.91 E+37 Resolution: 0.01 dB
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "FETCH:TCPOWER:POWER:MINIMUM?"

FETCh:TCPower:POWer:SDEViation?

Function | Queries the standard deviation of several channel power measurements.
Setting | No setting
Query | Range: 0 to 99 dB, 9.91 E+37 Resolution: 0.001 dB
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "FETCH:TCPOWER:POWER:SDEVIATION?"


FETCh:TDPower

Last updated: April 26, 2010

  • FETCh:TDPower[:ALL]?

  • FETCh:TDPower:INTegrity?

  • FETCh:TDPower:STEP:POWer[:MEASure]?

  • FETCh:TDPower:STEP:POWer:TRIGger?

For more information on the GPIB Command conventions, see GPIB Command conventions

For the measurement, see Dynamic Power (DPOW) Measurement.

FETCh:TDPower[:ALL]?

Function

Queries an dynamic power measurement result.

This query returns a comma-separated list of values in the following order: Integrity Indicator, power of all measurement steps.

The power of all measurement steps can also be queried by FETCh:TDPower:STEP:POWer[:MEASure]?.

Query

Integrity Indicator (See Integrity Indicator)

Measurement Step Power

  • Range: Measured Value in dBm, 9.91 E+37 (NAN)

  • Resolution: 0.01

Requirements

Test Application Revision: A.02.00 and above

Programming Example

"FETCh:TDPower?"

FETCh:TDPower:INTegrity?

Function | Queries the measurement integrity indicator for the last dynamic power measurement completed. Zero indicates a normal measurement. See Integrity Indicator for information about non-zero integrity results.
Query | Integrity Indicator (See Integrity Indicator)
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "FETCh:TDPower:INTegrity?"

FETCh:TDPower:STEP:POWer[:MEASure]?

Function

Queries the measurement step power.

This query returns 300 comma-separated values, in which the valid results are based on Measure Step Number.

Query

  • Range: Measured Value in dBm, 9.91 E+37 (NAN)

  • Resolution: 0.01

Requirements

Test Application Revision: A.02.00 and above

Programming Example

"FETCh:TDPower:STEP:POWer?"

FETCh:TDPower:STEP:POWer:TRIGger?

Function

Queries the trigger step power.

This query returns 10 comma-separated values, in which the valid results are based on Trigger Step Number.

Query

  • Range: Measured Value in dBm, 9.91 E+37 (NAN)

  • Resolution: 0.01

Requirements

Test Application Revision: A.02.00 and above

Programming Example

"FETCh:TDPower:STEP:POWer:TRIGger?"


FETCh:THCQuality

Last updated: March 10, 2010

  • FETCh:THCQuality[:ALL]?

  • FETCh:THCQuality:BLERatio:TRANsmit?

  • FETCh:THCQuality:BLOCks?

  • FETCh:THCQuality:CQINdicator:MEDian?

  • FETCh:THCQuality:CQIReports:CQIMinus1|2|3?

  • FETCh:THCQuality:CQIReports:CQIPlus0?

  • FETCh:THCQuality:CQIReports:CQIPlus1|2|3?

  • FETCh:THCQuality:CQIReports:DISTribution?

  • FETCh:THCQuality:CQIReports:WRANge?

  • FETCh:THCQuality:FAIL?

  • FETCH:THCQuality:ICOunt?

  • FETCh:THCQuality:INTegrity?

For more information on the GPIB Command conventions, see GPIB Command conventions

FETCh:THCQuality[:ALL]?

Function

Queries the Reporting of Channel Quality Indicator measurement results and returns the following comma separated values: Integrity Indicator, Reporting of Channel Quality Indicator overall Pass/Fail.

Pass is returned only when both the Median CQI and the BLER at Median CQI are within the their limits.

Query

Integrity Indicator - see Integrity Indicator

Reporting of Channel Quality Indicator overall Pass/Fail

  • Range: 0 (pass), 1 (fail), 9.91E+37

Requirements

Test Application Revision: A.04.00 and above

Programming Example

"FETCh:THCQ?"

FETCh:THCQuality:BLERatio:TRANsmit?

Function | Queries the BLER at Median CQI. This is the Block error rate when the test set transmits blocks at Median CQI value in part 2 of the HSDPA reporting of Channel Quality Indicator measurement, see Reporting of Channel Quality Indicator Measurement.
Query | Range: 0.00 to 100.00 %, 9.91E+37 Resolution: 0.01
Requirements | Test Application Revision: A.04.00 and above
Programming Example | "FETCh:THCQuality:BLERatio:TRANsmit?"

FETCh:THCQuality:BLOCks?

Function | Queries the number of tested blocks in part 2 of the HSDPA reporting of Channel Quality Indicator measurement, see Reporting of Channel Quality Indicator Measurement.
Query | Range: 0 to 99000, 9.91E+37 Resolution: 1
Requirements | Test Application Revision: A.04.00 and above
Programming Example | "FETCh:THCQuality:BLOCks?"

FETCh:THCQuality:CQINdicator:MEDian?

Function | Queries the Median CQI.
Query | Range: 0 to 63, 9.91E+37 Resolution: 1
Requirements | Test Application Revision: A.04.00 and above
Programming Example | "FETCh:THCQuality:CQINdicator:MEDian?"

FETCh:THCQuality:CQIReports:CQIMinus1|2|3?

Function | Queries the Reports at Median_CQI-1, Median_CQI-2 or Median_CQI-3.
Query | Range: 0 to 99000, 9.91E+37 Resolution: 1
Requirements | Test Application Revision: A.04.00 and above
Programming Example | "FETCh:THCQuality:CQIReports:CQIMinus2?"

FETCh:THCQuality:CQIReports:CQIPlus0?

Function | Queries the number of Report at Median_CQI.
Query | Range: 0 to 99000, 9.91E+37 Resolution: 1
Requirements | Test Application Revision: A.04.00 and above
Programming Example | "FETCh:THCQuality:CQIReports:CQIPlus0?"

FETCh:THCQuality:CQIReports:CQIPlus1|2|3?

Function | Queries the reports at Median_CQI+1, Median_CQI+2 or Median_CQI+3.
Query | Range: 0 to 99000, 9.91E+37 Resolution: 1
Requirements | Test Application Revision: A.04.00 and above
Programming Example | "FETCh:THCQuality:CQIReports:CQIPlus2?"

FETCh:THCQuality:CQIReports:DISTribution?

Function | Queries the detailed distribution of Reported CQI values, in a array of 64 integers.
Query | Range: 0 to 99000, 9.91E+37 Resolution: 1
Requirements | Test Application Revision: A.04.00 and above
Programming Example | "FETCh:THCQuality:CQIReports:DISTribution?"

FETCh:THCQuality:CQIReports:WRANge?

Function | Queries the CQI in Range.
Query | Range: 0 to 100, 9.91E+37 Resolution: 0.01
Requirements | Test Application Revision: A.04.00 and above
Programming Example | "FETCh:THCQuality:CQIReports:WRANge?"

FETCh:THCQuality:FAIL?

Function | Queries the overall pass/fail result of the HSDPA reporting of Channel Quality Indicator measurement.
Query | Range: 0 (pass), 1 (fail), 9.91E+37
Requirements | Test Application Revision: A.04.00 and above
Programming Example | "FETCh:THCQuality:FAIL?"

FETCH:THCQuality:ICOunt?

Function | Queries the intermediate count of the number of CQI reports collected during the HSDPA reporting of Channel Quality Indicator measurement.
Query | Range: 1 to 99000
Requirements | Test Application Revision: A.04.00 and above
Programming Example | "FETCH:THCQuality:ICOunt?"

FETCh:THCQuality:INTegrity?

Function | Queries the Integrity Indicator for the HSDPA Reporting of Channel Quality Indicator measurement.
Query | Range: 0 to the number of available integrity indicators. Resolution: 1
Requirements | Test Application Revision: A.04.00 and above
Programming Example | "FETCh:THCQuality:INTegrity?"


FETCh:TFDTune

Last updated: March 10, 2010

  • FETCh:TFDTune:INTegrity?

  • FETCh:TFDTune[:ALL]?

For more information on the GPIB Command conventions, see GPIB Command conventions

FETCh:TFDTune[:ALL]?

Function

Queries the fast device tune measurement results.

Results are returned in the following order:

  • Integrity Indicator

  • Number of Tx Frequency Steps

  • Number of Tx Power Steps

  • Number of MS TX power steps measured (in most cases, it equals Number of Tx Frequency Steps multiplied by Number of Tx Power Steps)

  • Comma-separated list of 400 MS Tx Power results. 400 results are always returned; if the test set measured fewer than 400 power steps from the mobile, the remaining values are NANs (9.91E+37). The power results for the first frequency in the MS TX Frequency Sequence are returned first, then the power results for the second frequency in the MS TX Frequency Sequence, etc., followed by NANs if fewer than 400 points were measured.

Query

Integrity

  • Range: see Integrity Indicator

  • Resolution: 1

Number of Tx Frequency Steps

  • Range: 1 to 40, 9.91 E+37

  • Resolution: 1

Number of Tx Power Steps

  • Range: 1 to 40, 9.91 E+37

  • Resolution: 1

Number of MS Tx Power Steps Measured

  • Range: 1 to 400, 9.91 E+37

  • Resolution: 1

MS Tx Power Results Array

  • Range: -100.00 to +100.00 dBm, 9.91 E+37

  • Resolution: 0.01 dBm

Requirements

Test Application Revision: A.04.00 and above

Programming Example

"FETCh:TFDT?"

FETCh:TFDTune:INTegrity?

Function | Queries the measurement integrity indicator for the last FDT measurement completed. Zero indicates a normal measurement. See Integrity Indicator for information about non-zero integrity results.
Query | Range: See Integrity Indicator
Requirements | Test Application Revision: A.04.00 and above
Programming Example | "FETCh:TFDTune:INTegrity?"


FETCh:THBLerror

Last updated: March 10, 2010

  • FETCH:THBLerror[:ALL]?

  • FETCh:THBLerror:ACK?

  • FETCh:THBLerror:BLOCks?

  • FETCh:THBLerror:IBTHroughput?

  • FETCh:THBLerror:ICOunt?

  • FETCh:THBLerror:INTegrity?

  • FETCh:THBLerror:NACK?

  • FETCh:THBLerror:PEM?

  • FETCh:THBLerror:RATio?

  • FETCh:THBLerror:SDTX?

For more information on the GPIB Command conventions, see GPIB Command conventions.

For the measurement, see HSDPA Block Error Ratio (HBLER) Measurement.

FETCH:THBLerror[:ALL]?

Function

Queries an HSDPA block error ratio measurement result and returns the following comma separated values: Integrity Indicator, Block Error Ratio in %, Information Bit Throughput in kbps, Positive Acknowledgment, Negative Acknowledgment, Statistical DTXs and Number of Blocks Tested.

Query

Integrity Indicator - See Integrity Indicator

Block Error Ratio

  • Range: 0.00 to 100.00%, 9.91E+37

  • Resolution: 0.01%

Information Bit Throughput

  • Range: 0.000 to 14000.000 kbps, 9.91E+37

  • Resolution: 0.001 kbps

Positive Acknowledgment

  • Range: 0 to 99000, 9.91E+37

  • Resolution: 1

Negative Acknowledgment

  • Range: 0 to 99000, 9.91E+37

  • Resolution: 1

Statistical DTXs

  • Range: 0 to 99000, 9.91E+37

  • Resolution: 1

Number of Blocks Tested

  • Range: 0 to 99000, 9.91E+37

  • Resolution: 1

Requirements

Test Application Revision: A.03.00 and above

Programming Example

"FETCH:THBLerror?"

FETCh:THBLerror:ACK?

Function | Returns the number of positive acknowledgments ( ACKs ) received during the measurement interval (number of blocks tested).
Query | Range: 0 to 99000, 9.91E+37 Resolution: 1
Requirements | Test Application Revision: A.03.00 and above
Programming Example | "FETCh:THBLerror:ACK?"

FETCh:THBLerror:BLOCks?

Function | Returns the number of Blocks Tested .
Query | Range: 0 to 99000, 9.91E+37 Resolution: 1
Requirements | Test Application Revision: A.03.00 and above
Programming Example | "FETCh:THBLerror:BLOCks?"

FETCh:THBLerror:IBTHroughput?

Function | Returns the Information Bit Throughput (kbps) for the measurement interval (number of blocks tested).
Query | Range: 0.000 to 14000.000 kbps, 9.91E+37 Resolution: 0.001 kbps
Requirements | Test Application Revision: A.03.00 and above
Programming Example | "FETCh:THBLerror:IBTHroughput?"

FETCh:THBLerror:ICOunt?

Function | Queries the intermediate count of blocks tested for the HSDPA block error ratio measurement.
Query | Range: 0 to 99,000 blocks Resolution: 100 blocks
Requirements | Test Application Revision: A.03.00 and above
Programming Example | "FETCh:THBLerror:ICOunt?"

FETCh:THBLerror:INTegrity?

Function | Returns the Integrity Indicator for the HSDPA block error ratio measurement result
Query | Range: See Integrity Indicator
Requirements | Test Application Revision: A.03.00 and above
Programming Example | "FETCh:THBLerror:INTegrity?"

FETCh:THBLerror:NACK?

Function | Returns the number of negative acknowledgments ( NACKs ) received during the measurement interval (number of blocks tested).
Query | Range: 0 to 99000, 9.91E+37 Resolution: 1
Requirements | Test Application Revision: A.03.00 and above
Programming Example | "FETCh:THBLerror:NACK?"

FETCh:THBLerror:PEM?

Function | Returns the ratio of P(Em). 3GPP TS 34.122 defines P(Em) as the probability of event Em, which is declared when the UE is signaled on HS-SCCH, but DTX is observed in the corresponding HS-SICH ACK/NACK field. P(Em) is calculated by: (statDTX)/(NACK+ statDTX +ACK). This result is used for HS-SCCH Detection Performance testing.
Query | Range: 0.00 to 100.00%, 9.91E+37 Resolution: 0.01%
Requirements | Test Application Revision: A.04.00 and above
Programming Example | "FETCh:THBLerror:PEM?"

FETCh:THBLerror:RATio?

Function | Returns the Block Error Ratio in %.
Query | Range: 0.00 to 100.00%, 9.91E+37 Resolution: 0.01%
Requirements | Test Application Revision: A.03.00 and above
Programming Example | "FETCh:THBLerror:RATio?"

FETCh:THBLerror:SDTX?

Function | Returns the number of statistical DTXs ( statDTXs ) during the measurement interval (number of blocks tested).
Query | Range: 0 to 99000, 9.91E+37 Resolution: 1
Requirements | Test Application Revision: A.03.00 and above
Programming Example | "FETCh:THBLerror:SDTX?"


FETCh:TOBWidth

Last updated: April 26, 2010

  • FETCh:TOBWidth[:ALL]?

  • FETCh:TOBWidth:BANDwidth[:AVERage]?

  • FETCh:TOBWidth:BANDwidth:ALL?

  • FETCh:TOBWidth:BANDwidth:MAXimum?

  • FETCh:TOBWidth:BANDwidth:MINimum?

  • FETCh:TOBWidth:BANDwidth:SDEViation?

  • FETCh:TOBWidth:FREQuency:LOWer?

  • FETCh:TOBWidth:FREQuency:UPPer?

  • FETCh:TOBWidth:ICOunt?

  • FETCh:TOBWidth:INTegrity?

For more information on the GPIB Command conventions, see GPIB Command conventions

For the measurement, see Occupied Bandwidth (OBW) Measurement.

FETCh:TOBWidth[:ALL]?

Function

Queries an occupied bandwidth measurement result.

This query returns a comma-separated list of values in the following order: integrity indicator, occupied bandwidth, lower frequency, upper frequency.

These results can also be queried individually using the

FETCh:TOBWidth:INTegrity?, FETCh:TOBWidth:BANDwidth[:AVERage]?, FETCh:TOBWidth:FREQuency:LOWer?, FETCh:TOBWidth:FREQuency:UPPer? commands.

If the multi-measurement state is on, the result represents the average of a number of occupied bandwidth measurements. Multi-measurement state, by default, is off.

Query

Integrity indicator (see Integrity Indicator)

Occupied Bandwidth

  • Range: measured value in Hz, 9.91 E+37

  • Resolution: 0.01

Lower frequency

  • Range: measured value in Hz, 9.91 E+37

  • Resolution: 0.01

Upper frequency

  • Range: measured value in Hz, 9.91 E+37

  • Resolution: 0.01

Requirements

Test Application Revision: A.02.00 and above

Programming Example

"FETCh:TOBWidth?"

FETCh:TOBWidth:BANDwidth[:AVERage]?

Function | Queries the occupied bandwidth result. If the Multi-Measurement State is On, this command returns the average result of several occupied bandwidth measurement.
Query | Range: measured value in Hz, 9.91 E+37 Resolution: 0.01
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "FETCh:TOBWidth:BANDwidth?"

FETCh:TOBWidth:BANDwidth:ALL?

Function

Queries the statistical measurement results for several occupied bandwidth measurements.

Results are returned in the following order: minimum, maximum, average, and standard deviation of occupied bandwidth.

Query

Range:

  • minimum: measured value in Hz, 9.91 E+37

  • maximum: measured value in Hz, 9.91 E+37

  • average: measured value in Hz, 9.91 E+37

  • standard deviation: measured value, 9.91 E+37

Requirements

Test Application Revision: A.02.00 and above

Programming Example

"FETCh:TOBWidth:BANDwidth:ALL?"

FETCh:TOBWidth:BANDwidth:MAXimum?

Function | Queries the maximum bandwidth of several occupied bandwidth measurements. When the Multi-Measurement Count State is OFF or Multi- Measurement Count Number is 0, the single measured result is returned.
Query | Range: measured value in Hz, 9.91 E+37
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "FETCh:TOBWidth:BANDwidth:MAXimum?"

FETCh:TOBWidth:BANDwidth:MINimum?

Function | Queries the minimum bandwidth of several occupied bandwidth measurements. When the Multi-Measurement Count State is OFF or Multi- Measurement Count Number is 0, the single measured result is returned.
Query | Range: measured value in Hz, 9.91 E+37
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "FETCh:TOBWidth:BANDwidth:MINimum?"

FETCh:TOBWidth:BANDwidth:SDEViation?

Function | Queries the standard deviation of several occupied bandwidth measurements. When the Multi-Measurement Count State is OFF or Multi- Measurement Count Number is 0, then 0 is returned.
Query | Range: measured value, 9.91 E+37
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "FETCh:TOBWidth:BANDwidth:SDEViation?"

FETCh:TOBWidth:FREQuency:LOWer?

Function | Queries the lower frequency result of the occupied bandwidth measurement.
Query | Range: measured value in Hz, 9.91 E+37 Resolution: 0.01
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "FETCh:TOBWidth:FREQuency:LOWer?"

FETCh:TOBWidth:FREQuency:UPPer?

Function | Queries the upper frequency result of the occupied bandwidth measurement.
Query | Range: measured value in Hz, 9.91 E+37 Resolution: 0.01
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "FETCh:TOBWidth:FREQuency:UPPer?"

FETCh:TOBWidth:ICOunt?

Function | Queries the intermediate count of measurements completed in a multi-measurement.
Query | Range: 0 to 999
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "FETCh:TOBWidth:ICOunt?"

FETCh:TOBWidth:INTegrity?

Function | Queries the measurement integrity indicator for the last OBW measurement completed. Zero indicates a normal measurement.
Query | Range: see Integrity Indicator
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "FETCh:TOBWidth:INTegrity?"


FETCh:TOLPower

Last updated: March 10, 2010

  • FETCh:TOLPower[:ALL]?

  • FETCh:TOLPower:FAIL?

  • FETCh:TOLPower:INTegrity?

  • FETCh:TOLPower:POWer?

  • FETCh:TOLPower:SIGNature?

For more information on the GPIB Command conventions, see GPIB Command conventions

For the measurement, see Open Loop Power Control (OLPC) Measurement

FETCh:TOLPower[:ALL]?

Function

Queries the open loop power control measurement result in the following order: Integrity Indicator, Pass/Fail, Open Loop Power Result, Detected UpPCH signature.

Query

Integrity Indicator: see Integrity Indicator.

Pass/Fail

  • Range: 0 | 1, 9.91 E+37

Initial UpPCH Tx Power Measurement Results

  • Range: Measured Value in dBm, 9.91 E+37

  • Resolution: 0.01

Detected UpPCH signature

  • Range: 0 to 255, 9.91 E+37

  • Resolution: 1

Requirements

Test Application Revision: A.03.00 and above

Programming Example

"FETCh:TOLPower?"

FETCh:TOLPower:FAIL?

Function | Queries the pass/fail indication for the Initial UpPCH Tx Power Measurement Results. If the following condition is met, it fails: Initial UpPCH Tx Power (in dBm) – Expected Initial UpPCH Tx Power (in dBm) > Initial UpPCH Tx Power Limit(in dB),
Query | Range: 0 | 1, 9.91 E+37
Requirements | Test Application Revision: A.03.00 and above
Programming Example | "FETCh:TOLPower:FAIL?"

FETCh:TOLPower:INTegrity?

Function | Queries the measurement integrity indicator for the last open loop power control measurement completed. Zero indicates a normal measurement.
Query | Range: 0 to 32
Requirements | Test Application Revision: A.03.00 and above
Programming Example | "FETCh:TOLPower:INTegrity?"

FETCh:TOLPower:POWer?

Function | Queries the initial UpPCH Tx power result.
Query | Range: Measured Value in dBm, 9.91 E+37 Resolution: 0.01
Requirements | Test Application Revision: A.03.00 and above
Programming Example | "FETCh:TOLPower:POWer?"

FETCh:TOLPower:SIGNature?

Function | Queries the Detected UpPCH signature in the open loop power control measurement.
Query | Range: 0 to 255, 9.91 E+37 Resolution: 1
Requirements | Test Application Revision: A.03.00 and above
Programming Example | "FETCh:TOLPower:POWer?"


FETCh:TOOPower

Last updated: April 26, 2010

  • FETCh:TOOPower[:ALL]?

  • FETCh:TOOPower:ICOunt?

  • FETCh:TOOPower:ICPower?

  • FETCh:TOOPower:INTegrity?

  • FETCh:TOOPower:OFFPower[:ALL]?

  • FETCh:TOOPower:OFFPower:RANGe[1]|2|3?

  • FETCh:TOOPower:TIME:POWer?

  • FETCh:TOOPower:TRACe[:DATA]?

For more information on the GPIB Command conventions, see GPIB Command conventions.

For the measurement, see Transmit ON/OFF Power (TOOP) Measurement.

FETCh:TOOPower[:ALL]?

Function

Queries all the transmit ON/OFF power measurement results in the following order: Integrity, Overall Pass Fail, Averaged ON Power, Range 1 Pass/Fail, Range 1 averaged power, Range 2 Pass/Fail, Range 2 averaged power, Range 3 Pass/Fail, Range 3 averaged power.

The overall pass/fail result will be fail if any of the three ranges fails.

Range 1 refers to chips from -864 to -34; Range 2 refers to chips from-33 to -14; Range 3 refers to chips from 860 to 1711.

Query

Integrity (see Integrity Indicator)

Overall Pass/Fail

  • Range: 0 (pass), 1 (fail)

Averaged ON Power

  • Range: value in dBm, 9.91 E+37 (NAN)

  • Resolution: 0.01

Range 1 Pass/Fail

  • Range: 0 (pass), 1 (fail)

Range 1 Averaged Power

  • Range: value in dBm, 9.91 E+37 (NAN)

  • Resolution: 0.01

Range 2 Pass/Fail

  • Range: 0 (pass), 1 (fail)

Range 2 Averaged Power

  • Range: value in dBm, 9.91 E+37 (NAN)

  • Resolution: 0.01

Range 3 Pass/Fail

  • Range: 0 (pass), 1 (fail)

Range 3 Averaged Power

  • Range: value in dBm, 9.91 E+37 (NAN)

  • Resolution: 0.01

Requirements

Test Application Revision: A.02.00 and above

Programming Example

"FETCh:TOOPower?"

FETCh:TOOPower:ICOunt?

Function | Queries the intermediate count of measurements completed in a multi-measurement.
Query | Range: 0 to 999
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "FETCh:TOOPower:ICOunt?"

FETCh:TOOPower:ICPower?

Function | Queries the Averaged ON Power of the transmit ON/OFF power measurement. The average ON power refers to the averaged RRC filtered mean power of the chips from 0 to 847.
Query | Range: measured values in dBm and 9.91 E+37 (NAN) Resolution: 0.01
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "FETCh:TOOPower:ICPower?"

FETCh:TOOPower:INTegrity?

Function | Queries the measurement integrity indicator for the last TOOP measurement completed. Zero indicates a normal measurement.
Query | Range: see Integrity Indicator
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "FETCh:TOOPower:INTegrity?"

FETCh:TOOPower:OFFPower[:ALL]?

Function

Queries all OFF power results in the transmit ON/OFF power measurement. The results are returned in the following order: Overall Pass Fail, Range 1 Pass/Fail, Range 1 Level, Range 2 Pass/Fail, Range 2 Level, Range 3 Pass/Fail, Range 3 Level.

Range 1 refers to chips from -864 to -34; Range 2 refers to chips from-33 to -14; Range 3 refers to chips from 860 to 1711.

Query

Overall Pass/Fail

  • Range: 0 (pass), 1 (fail)

Range 1 Pass/Fail

  • Range: 0 (pass), 1 (fail)

Range 1 Average Power

  • Range: value in dBm and 9.91 E+37 (NAN)

  • Resolution: 0.01

Range 2 Pass/Fail

  • Range: 0 (pass), 1 (fail)

Range 2 Average Power

  • Range:value in dBm and 9.91 E+37 (NAN)

  • Resolution: 0.01

Range 3 Pass/Fail

  • Range: 0 (pass), 1 (fail)

Range 3 Average Power

  • Range:value in dBm and 9.91 E+37 (NAN)

  • Resolution: 0.01

Requirements

Test Application Revision: A.02.00 and above

Programming Example

"FETCh:TOOPower:OFFPower?"

FETCh:TOOPower:OFFPower:RANGe[1]|2|3?

Function

Queries the OFF power results for Range 1, 2 or 3. Whether the OFF power result is the average or highest value in the range is determined by Off Power Mode.

The result will be fail if the range power is larger than its mask limit. (see SETup:TOOPower:LIMit)

Query

Range:

  • Pass/Fail Result : 0 (pass), 1 (fail)

  • Averaged power in range: value in dBm, 9.91 E+37 (NAN)

Requirements

Test Application Revision: A.02.00 and above

Programming Example

"FETCh:TOOPower:OFFPower:RANGe2?"

FETCh:TOOPower:TIME:POWer?

Function | Queries the power of the specified offsets in the form of an array. The number of the offsets are specified by SETup:TOOPower:TIME[:OFFSet].
Query | Range: measured value in dBm Resolution: 0.01
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "FETCh:TOOPower:TIME:POWer?"

FETCh:TOOPower:TRACe[:DATA]?

Function

Queries the trace results for the transmit ON/OFF power measurement. The results is in the form of an array, in which the first element indicates the number of points in the trace, and the left are the power results for each chip.

When the Multi-Measurement State is On, the returned trace is the average trace from all measurements.

The command is available only when the trace state is ON.

Query

The number of points in the trace:

  • Range: measured value

  • Resolution: 1

Power for each chip:

  • Range: measured value in dBm, 9.91 E+37

  • Resolution: 0.01

Requirements

Test Application Revision: A.02.00 and above

Programming Example

"FETCh:TOOPower:TRACe?"


FETCh:TSEMask

Last updated: April 26, 2010

  • FETCh:TSEMask[:ALL]?

  • FETCh:TSEMask:BAND:LOWer[1]|2|3?

  • FETCh:TSEMask:BAND:UPPer[1]|2|3?

  • FETCh:TSEMask:BAND[:ALL]?

  • FETCh:TSEMask:ICOunt?

  • FETCh:TSEMask:ICPower[:AVERage]?

  • FETCh:TSEMask:ICPower:MAXimum?

  • FETCh:TSEMask:ICPower:Minimum?

  • FETCh:TSEMask:ICPower:SDEViation?

  • FETCh:TSEMask:ICPower:ALL?

  • FETCh:TSEMask:INTegrity?

  • FETCh:TSEMask:RANGe:RANGe[1]|2|3?

  • FETCh:TSEMask:RANGe[:ALL]?

For more information on the GPIB Command conventions, see GPIB Command conventions.

For the measurement, see Spectrum Emission Mask (SEM) Measurement.

FETCh:TSEMask[:ALL]?

Function

Queries the measurement suite integrity, Spectrum Emission Mask overall pass/fail result, pass/fail results for all three frequency ranges, and average levels for all three frequency ranges.

Query

Integrity Indicator (see Integrity Indicator)

Overall pass/fail result: 0 (pass), 1 (fail)

For each of the three measurement ranges:

  • Overall pass/fail result: 0 (pass), 1 (fail)

  • Average level for offset range:value in dBc and 9.91 E+37 (NAN)

Requirements

Test Application Revision: A.01.00 and above

Programming Example

"FETCh:TSEMask?"

FETCh:TSEMask:BAND:LOWer[1]|2|3?

Function

Queries the in-channel power (in dBm/1.28 MHz), number of points tested for the specified lower band, and the power level vectors relative to in-channel power for all points tested in the specified lower band.

Query

in-channel power

  • Range:value in dBm and 9.91 E+37 (NAN)

  • Resolution:0.01

Number of Points Tested = ((Last Offset - First Offset) / Frequency Step) + 1, where:

  • LOWer[1]:

  • Last Offset is -0.8 MHz

  • First Offset is -1.8 MHz

  • step size 10 kHz, BW 30 KHz 1:99

  • LOWer2:

  • Last Offset is -1.8 MHz

  • First Offset is -2.4 MHz

  • step size 10 kHz, BW 30 KHz 1:59

  • LOWer3:

  • Last Offset is -2.4 MHz

  • First Offset is -4.0 MHz

  • step size 200 kHz, BW 1 MHz 1:4

Power level vectors for the specified lower band:

  • Range:value in dBc and 9.91 E+37 (NAN)

  • Resolution:0.01

Requirements

Test Application Revision: A.01.00 and above

Programming Example

"FETCh:TSEMask:BAND:LOWer2?"

FETCh:TSEMask:BAND:UPPer[1]|2|3?

Function

Queries the in-channel power (in dBm/1.28 MHz), number of points tested for the specified upper band, and the power level vectors relative to in-channel power for all points tested in the specified upper band.

Query

In-channel Power

  • Range:value in dBm and 9.91 E+37 (NAN)

  • Resolution:0.01

Number of Points Tested = ((Last Offset - First Offset) / Frequency Step) + 1, where:

  • LOWer3:

  • Last Offset is -2.4 MHz

  • First Offset is -4.0 MHz

  • step size 200 kHz, BW 1 MHz 1:4

  • LOWer2:

  • Last Offset is -1.8 MHz

  • First Offset is -2.4 MHz

  • step size 10 kHz, BW 30 KHz 1:59

  • LOWer1:

  • Last Offset is -0.8 MHz

  • First Offset is -1.8 MHz

  • step size 10 kHz, BW 30 KHz 1:99

  • UPPer1:

  • Last Offset is 1.8 MHz

  • First Offset is 0.8 MHz

  • step size 10 kHz, BW 30 KHz 1:99

  • UPPer2:

  • Last Offset is 2.4 MHz

  • First Offset is 1.8 MHz

  • step size 10 kHz, BW 30 KHz 1:59

  • UPPer3:

  • Last Offset is 4.0 MHz

  • First Offset is 2.4 MHz

  • step size 200 kHz, BW 1 MHz 1:4

Power level vectors for the specified lower band:

  • Range:value in dBc and 9.91 E+37 (NAN)

  • Resolution:0.01

Requirements

Test Application Revision: A.01.00 and above

Programming Example

"FETCh:TSEMask:BAND:UPPer2?"

FETCh:TSEMask:BAND[:ALL]?

Function

Queries the measurement suite integrity, in-channel power (in dBm/1.28 MHz), number of measurement points for all bands, and the power level vectors relative to in-channel power for all points tested in all bands.

Query

Integrity Indicator (see Integrity Indicator)

in-channel power

  • Range:value in dBm and 9.91 E+37 (NAN)

  • Resolution:0.01

Number of points in trace for all bands,where:

  • UPPer[1]:

  • Last Offset is 1.8 MHz

  • First Offset is 0.8 MHz

  • step size 10 kHz, BW 30 KHz 1:99

  • UPPer2:

  • Last Offset is 2.4 MHz

  • First Offset is 1.8 MHz

  • step size 10 kHz, BW 30 KHz 1:59

  • Upper3

  • Last Offset is 4.0 MHz

  • First Offset is 2.4 MHz

  • step size 200 kHz, BW 1 MHz 1:4

Power level vectors for the specified lower band:

  • Range:value in dBc and 9.91 E+37 (NAN)

  • Resolution:0.01

Requirements

Test Application Revision: A.01.00 and above

Programming Example

"FETCh:TSEMask:BAND?"

FETCh:TSEMask:ICOunt?

Function | Queries the intermediate count of measurements completed in a multi-measurement
Query | Range: 0 to 999
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "FETCH:TSEMASK:ICOUNT?"

FETCh:TSEMask:ICPower[:AVERage]?

Function | Queries the in-channel average power of a set of values in the multi-measurement. If Multi-Measurement Count State is off or Multi-Measurement Count Number is 0,the average power equals to the result.
Query | Range:value in dBm and 9.91 E+37 (NAN) Resolution:0.01
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "FETCh:TSEMask:ICPower?"

FETCh:TSEMask:ICPower:MAXimum?

Function | Queries the in-channel maximum power of a set of values in the multi-measurement. If Multi-Measurement Count State is off or Multi-Measurement Count Number is 0,the maximum power equals to the result.
Query | Range:value in dBm and 9.91 E+37 (NAN) Resolution:0.01
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "FETCh:TSEMask:ICPower:MAXimum?"

FETCh:TSEMask:ICPower:Minimum?

Function | Queries the in-channel minimum power of a set of values in the multi-measurement.. If Multi-Measurement Count State is off or Multi-Measurement Count Number is 0,the maximum power equals to the result.
Query | Range:value in dBm and 9.91 E+37 (NAN) Resolution:0.01
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "FETCh:TSEMask:ICPower:Minimum?"

FETCh:TSEMask:ICPower:SDEViation?

Function | Queries the in-channel minimum power. If Multi-Measurement Count State is off or Multi-Measurement Count Number is 0,the maximum power equals to the result.
Query | Range:value in dB and 9.91 E+37 (NAN) Resolution:0.001
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "FETCh:TSEMask:ICPower:SDEViation?"

FETCh:TSEMask:ICPower:ALL?

Function

Queries statistical results of the Spectrum Emission Mask measurement,including:

  • Minimum value

  • Maximum value

  • Average (arithmetic mean)

  • Standard Deviation

Query

Range:value in dBm and 9.91 E+37 (NAN)

Requirements

Test Application Revision: A.01.00 and above

Programming Example

"FETCh:TSEMask:ICPower:ALL?"

FETCh:TSEMask:INTegrity?

Function | Queries the measurement integrity indicator for the last spectrum emissions mask measurement completed.
Query | Range: see Integrity Indicator
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "FETCH:TSEMASK:INTegrity?"

FETCh:TSEMask:RANGe:RANGe[1]|2|3?

Function

Queries the following results for the specified range(1|2|3): in-channel power (in dBm/1.28 MHz), pass/fail result, average level, frequency offset in which the worst case mask margin is found, and the worst case mask margin.

Query

in-channel power/Avg

  • Range:value in dBm and 9.91 E+37 (NAN)

  • Resolution:0.01

Pass/Fail Result

  • Range: 0 = pass, 1 =fail

Level Result/Avg

  • Range:value in dBc and 9.91 E+37 (NAN)

  • Resolution:0.01

Frequency Offset

  • Range 1: +/- (0.815 to 1.795) MHz | NaN (undetermined)

  • Range 2: +/- (1.805 to 2.385) MHz | NaN (undetermined)

  • Range 3: +/- (2.9 to 3.5) MHz | NaN (undetermined)

  • Resolution, all ranges: 10KHz

Mask Margin

  • Range:value in dB and 9.91 E+37 (NAN)

  • Resolution:0.01

Requirements

Test Application Revision: A.01.00 and above

Programming Example

"FETCh:TSEMask:RANGe:RANGe3?"

FETCh:TSEMask:RANGe[:ALL]?

Function

Queries the following for each of the three measurement ranges: in-channel power (in dBm/1.28 MHz), pass/fail result, average level, frequency offset in which the worst case mask margin is found, and the worst case mask margin.

Query

Integrity Indicator

Overall Pass/Fail

  • Range: 0 = pass, 1 =fail

  • Fail is indicated anytime the mask offset is negative.

in-channel power/Avg

  • Range:value in dBm and 9.91 E+37 (NAN)

  • Resolution:0.01

For each of the three measurement ranges:

  • Pass/Fail Result

  • Range: 0 = pass, 1 =fail

  • Level Result/Avg

  • Range:value in dBc and 9.91 E+37 (NAN)

  • Resolution:0.01

  • Frequency Offset

  • Range 1: +/- (0.815 to 1.795) MHz | NaN (undetermined)

  • Range 2: +/- (1.805 to 2.385) MHz | NaN (undetermined)

  • Range 3: +/- (2.9 to 3.5) MHz | NaN (undetermined)

  • Resolution, all ranges: 10KHz

  • Mask Margin

  • Range:value in dB and 9.91 E+37 (NAN)

  • Resolution:0.01

Requirements

Test Application Revision: A.01.00 and above

Programming Example

"FETCh:TSEMask:RANGe?"


FETCh:TWQuality

Last updated: April 26, 2010

  • FETCh:TWQuality[:ALL]?

  • FETCh:TWQuality:EVM[:AVERage]?

  • FETCh:TWQuality:EVM:ALL?

  • FETCh:TWQuality:EVM:MAXimum?

  • FETCh:TWQuality:EVM:MINimum?

  • FETCh:TWQuality:EVM:SDEViation?

  • FETCh:TWQuality:EVM:PEAK[:AVERage]?

  • FETCh:TWQuality:EVM:PEAK:ALL?

  • FETCh:TWQuality:EVM:PEAK:MAXimum?

  • FETCh:TWQuality:EVM:PEAK:MINimum?

  • FETCh:TWQuality:EVM:PEAK:SDEViation?

  • FETCh:TWQuality:FERRor[:AVERage]?

  • FETCh:TWQuality:FERRor:ALL?

  • FETCh:TWQuality:FERRor:MAXimum?

  • FETCh:TWQuality:FERRor:MINimum?

  • FETCh:TWQuality:FERRor:SDEViation?

  • FETCh:TWQuality:FERRor:WORSt?

  • FETCh:TWQuality:ICOunt?

  • FETCh:TWQuality:INTegrity?

  • FETCh:TWQuality:OOFFset[:AVERage]?

  • FETCh:TWQuality:OOFFset:ALL?

  • FETCh:TWQuality:OOFFset:MAXimum?

  • FETCh:TWQuality:OOFFset:MINimum?

  • FETCh:TWQuality:OOFFset:SDEViation?

  • FETCh:TWQuality:PCERror[:ALL]?

  • FETCh:TWQuality:PCERror:CHANnel?

  • FETCh:TWQuality:PCERror:MAXimum?

  • FETCh:TWQuality:PERRor[:AVERage]?

  • FETCh:TWQuality:PERRor:ALL?

  • FETCh:TWQuality:PERRor:MAXimum?

  • FETCh:TWQuality:PERRor:MINimum?

  • FETCh:TWQuality:PERRor:SDEViation?

  • FETCh:TWQuality:MERRor[:AVERage]?

  • FETCh:TWQuality:MERRor:ALL?

  • FETCh:TWQuality:MERRor:MAXimum?

  • FETCh:TWQuality:MERRor:MINimum?

  • FETCh:TWQuality:MERRor:SDEViation?

  • FETCh:TWQuality:TERRor[:AVERage]?

  • FETCh:TWQuality:TERRor:ALL?

  • FETCh:TWQuality:TERRor:MAXimum?

  • FETCh:TWQuality:TERRor:MINimum?

  • FETCh:TWQuality:TERRor:SDEViation?

  • FETCh:TWQuality:TERRor:WORSt?

For more information on the GPIB Command conventions, see GPIB Command conventions.

For the waveform quality measurement description, see Waveform Quality Measurement.

FETCh:TWQuality[:ALL]?

Function

Queries all the waveform quality measurements results.

Measurement results are returned in the following order: Integrity, Average RMS EVM, Average Frequency Error, Average Origin Offset, Average Phase Error, Average Magnitude Error, Average Time Error, Maximum PCDE.

Query

Integrity (see Integrity Indicator)

Average RMS (Root Mean Square) EVM

  • Range: Positive Float Value, 9.91 E+37 (NAN)

  • Resolution: 0.01

  • Unit: %

Average Frequency Error

  • Range: Measured Value, 9.91 E+37 (NAN)

  • Resolution: 0.01

  • Unit: Hz

Average Origin Offset

  • Range: Measured Value, 9.91 E+37 (NAN)

  • Resolution: 0.01

  • Unit: dBc

Average Phase Error

  • Range: -180 to 180, 9.91 E+37 (NAN)

  • Resolution: 0.01

  • Unit: Degree

Average Magnitude Error

  • Range: Positive Float Value, 9.91 E+37 (NAN)

  • Resolution: 0.01

  • Unit: %

Average Timing Error

  • Range: Measured Value, 9.91 E+37 (NAN)

  • Resolution: 0.01

  • Unit: Chip

Maximum Peak Code Domain Error

  • Range: Measured Value, 9.91 E+37 (NAN)

  • Resolution: 0.01

  • Unit: dB

Requirements

Test Application Revision: A.01.00 and above

Programming Example

"FETCh:TWQuality:ALL?"

FETCh:TWQuality:EVM[:AVERage]?

Function | Queries the average RMS EVM when the Multi-Measurement Count State is ON.
Query | Range: Positive Float Value, 9.91 E+37 (NAN) Resolution: 0.01 Unit: %
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "FETCh:TWQuality:EVM:AVERage?"

FETCh:TWQuality:EVM:ALL?

Function

Queries all the RMS EVM measurement results, which are returned in the following order: minimum, maximum, average and standard deviation RMS EVM.

Query

Minimum EVM

  • Range: Positive Float Value, 9.91 E+37 (NAN)

  • Resolution: 0.01

  • Unit: %

Maximum EVM

  • Range: Positive Float Value, 9.91 E+37 (NAN)

  • Resolution: 0.01

  • Unit: %

Average EVM

  • Range: Positive Float Value, 9.91 E+37 (NAN)

  • Resolution: 0.01

  • Unit: %

Standard Deviation EVM

  • Range: Positive Float Value, 9.91 E+37 (NAN)

  • Resolution: 0.001

  • Unit: %

Requirements

Test Application Revision: A.01.00 and above

Programming Example

"FETCh:TWQuality:EVM:ALL?"

FETCh:TWQuality:EVM:MAXimum?

Function | Queries the RMS maximum EVM when the Multi-Measurement Count State is ON.
Query | Range: Positive Float Value, 9.91 E+37 (NAN) Resolution: 0.01 Unit: %
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "FETCh:TWQuality:EVM:MAXimum?"

FETCh:TWQuality:EVM:MINimum?

Function | Queries the RMS minimum EVM when the Multi-Measurement Count State is ON.
Query | Range: Positive Float Value, 9.91 E+37 (NAN) Resolution: 0.01 Unit: %
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "FETCh:TWQuality:EVM:MINimum?"

FETCh:TWQuality:EVM:SDEViation?

Function | Queries the RMS EVM Standard Deviation when the Multi-Measurement Count State is ON.
Query | Range: Positive Float Value, 9.91 E+37 (NAN) Resolution: 0.001 Unit: %
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "FETCh:TWQuality:EVM:SDEViation?"

FETCh:TWQuality:EVM:PEAK[:AVERage]?

Function | Queries the average peak EVM when the Multi-Measurement Count State is ON.
Query | Range: Measured Value, 9.91 E+37 (NAN) Resolution: 0.01 Unit: %
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "FETCh:TWQuality:EVM:PEAK:AVERage?"

FETCh:TWQuality:EVM:PEAK:ALL?

Function

Queries all the peak EVM results, which are returned in the following order: minimum, maximum, average and standard deviation peak EVM.

Query

Minimum

  • Range: Measured Value, 9.91 E+37 (NAN)

  • Resolution: 0.01

  • Unit: %

Maximum

  • Range: Measured Value, 9.91 E+37 (NAN)

  • Resolution: 0.01

  • Unit: %

Average

  • Range: Measured Value, 9.91 E+37 (NAN)

  • Resolution: 0.01

  • Unit: %

Standard Deviation

  • Range: Measured Value, 9.91 E+37 (NAN)

  • Resolution: 0.001

  • Unit: dB

Requirements

Test Application Revision: A.01.00 and above

Programming Example

"FETCh:TWQuality:EVM:PEAK:ALL?"

FETCh:TWQuality:EVM:PEAK:MAXimum?

Function | Queries the maximum peak EVM when the Multi-Measurement Count State is ON.
Query | Range: Measured Value, 9.91 E+37 (NAN) Resolution: 0.01 Unit: %
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "FETCh:TWQuality:EVM:PEAK:MAXimum?"

FETCh:TWQuality:EVM:PEAK:MINimum?

Function | Queries the minimum peak EVM when the Multi-Measurement Count State is ON.
Query | Range: Measured Value, 9.91 E+37 (NAN) Resolution: 0.01 Unit: %
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "FETCh:TWQuality:EVM:PEAK:MINimum?"

FETCh:TWQuality:EVM:PEAK:SDEViation?

Function | Queries the Standard deviation peak EVM when the Multi-Measurement Count State is ON.
Query | Range: Measured Value, 9.91 E+37 (NAN) Resolution: 0.001 Unit: dB
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "FETCh:TWQuality:EVM:PEAK:SDEViation?"

FETCh:TWQuality:FERRor[:AVERage]?

Function | Queries the average frequency error when the Multi-Measurement Count State is ON.
Query | Range: Measured Value, 9.91 E+37 (NAN) Resolution: 0.01 Unit: Hz
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "FETCh:TWQuality:FERRor:AVERage?"

FETCh:TWQuality:FERRor:ALL?

Function

Queries the frequency error measurements when the Multi-Measurement Count State is ON.

Results are returned in the following order: minimum, maximum, average, standard deviation and worst case frequency error.

Query

Minimum Frequency Error

  • Range: Measured Value, 9.91 E+37 (NAN)

  • Resolution: 0.01

  • Unit: Hz

Maximum Frequency Error

  • Range: Measured Value, 9.91 E+37 (NAN)

  • Resolution: 0.01

  • Unit: Hz

Average Frequency Error

  • Range: Measured Value, 9.91 E+37 (NAN)

  • Resolution: 0.01

  • Unit: Hz

Standard Deviation Frequency Error

  • Range: Measured Value, 9.91 E+37 (NAN)

  • Resolution: 0.001

  • Unit: Hz

Worst Case Frequency Error

  • Range: Measured Value, 9.91 E+37 (NAN)

  • Resolution: 0.01

  • Unit: Hz

Requirements

Test Application Revision: A.01.00 and above

Programming Example

"FETCh:TWQuality:FERRor:ALL?"

FETCh:TWQuality:FERRor:MAXimum?

Function | Queries the maximum frequency error when the Multi-Measurement Count State is ON.
Query | Range: Measured Value, 9.91 E+37 (NAN) Resolution: 0.01 Unit: Hz
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "FETCh:TWQuality:FERRor:MAXimum?"

FETCh:TWQuality:FERRor:MINimum?

Function | Queries the minimum frequency error when the Multi-Measurement Count State is ON.
Query | Range: Measured Value, 9.91 E+37 (NAN) Resolution: 0.01 Unit: Hz
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "FETCh:TWQuality:FERRor:MINimum?"

FETCh:TWQuality:FERRor:SDEViation?

Function | Queries the standard deviation of frequency error results when the Multi-Measurement Count State is ON.
Query | Range: Measured Value, 9.91 E+37 (NAN) Resolution: 0.001 Unit: Hz
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "FETCh:TWQuality:FERRor:SDEViation?"

FETCh:TWQuality:FERRor:WORSt?

Function | Queries the worst case frequency error. (The test set returns either the Minimum or Maximum Frequency Error result, whichever is furthest from zero).
Query | Range: Measured Value, 9.91 E+37 (NAN) Resolution: 0.01 Unit: Hz
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "FETCh:TWQuality:FERRor:WORSt?"

FETCh:TWQuality:ICOunt?

Function | Queries the intermediate count of measurements completed in a multi-measurement.
Query | Range: 0 to 999
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "FETCH:TWQuality:ICOUNT?"

FETCh:TWQuality:INTegrity?

Function | Queries the measurement integrity indicator for the last waveform quality measurement completed. Zero indicates a normal measurement.
Query | Range: see Integrity Indicator
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "FETCH:TWQuality:INTegrity?"

FETCh:TWQuality:OOFFset[:AVERage]?

Function | Queries the average origin offset when the Multi-Measurement Count State is ON.
Query | Range: Measured Value, 9.91 E+37 (NAN) Resolution: 0.01 Unit: dBc
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "FETCh:TWQuality:OOFFset:AVERage?"

FETCh:TWQuality:OOFFset:ALL?

Function

Queries the origin offset measurement results when the Multi-Measurement Count State is ON. The results are returned in the following order: minimum, maximum, average, standard deviation origin offset.

Query

Minimum Origin Offset

  • Range: Measured Value, 9.91 E+37 (NAN)

  • Resolution: 0.01

  • Unit: dBc

Maximum Origin Offset

  • Range: Measured Value, 9.91 E+37 (NAN)

  • Resolution: 0.01

  • Unit: dBc

Average Origin Offset

  • Range: Measured Value, 9.91 E+37 (NAN)

  • Resolution: 0.01

  • Unit: dBc

Standard Deviation Origin Offset

  • Range: Measured Value, 9.91 E+37 (NAN)

  • Resolution: 0.001

  • Unit: dB

Requirements

Test Application Revision: A.01.00 and above

Programming Example

"FETCh:TWQuality:OOFFset:ALL?"

FETCh:TWQuality:OOFFset:MAXimum?

Function | Queries the maximum origin offset when the Multi-Measurement Count State is ON.
Query | Range: Measured Value, 9.91 E+37 (NAN) Resolution: 0.01 Unit: dBc
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "FETCh:TWQuality:OOFFset:MAXimum?"

FETCh:TWQuality:OOFFset:MINimum?

Function | Queries the minimum origin offset when the Multi-Measurement Count State is ON.
Query | Range: Measured Value, 9.91 E+37 (NAN) Resolution: 0.01 Unit: dBc
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "FETCh:TWQuality:OOFFset:MINimum?"

FETCh:TWQuality:OOFFset:SDEViation?

Function | Queries the standard deviation origin offset when the Multi-Measurement Count State is ON.
Query | Range: Measured Value, 9.91 E+37 (NAN) Resolution: 0.001 Unit: dB
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "FETCh:TWQuality:OOFFset:SDEViation?"

FETCh:TWQuality:PCERror[:ALL]?

Function

Queries the peak code domain error results. There are three number returned for each measurement and the results are returned in the following order: peak code domain error maximum result, channelization code and spreading factor .

Query

Peak Code Domain Error Maximum

  • Range: Measured Value, 9.91 E+37

  • Resolution: 0.01

  • Unit: dB

Channelization Code

  • Range: 1, 2, 4, 8, 16 or -1 (None)

Spread Factor

  • Range: 1, 2, 4, 8, 16 or -1 (None)

Requirements

Test Application Revision: A.01.00 and above

Programming Example

"FETCh:TWQuality:PCERror:ALL?"

FETCh:TWQuality:PCERror:CHANnel?

Function | Queries the Channelization Code (K) and Spread Factor (SF) for the Peak Code Domain Error result orderly.
Query | Range: 1, 2, 4, 8, 16 or -1 (None)
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "FETCh:TWQuality:PCERror:CHANnel?"

FETCh:TWQuality:PCERror:MAXimum?

Function | Queries the Maximum Peak Code Domain Error when the Multi-Measurement Count State is ON.
Query | Range: Measured Value, 9.91 E+37 Resolution: 0.01 Unit: dB
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "FETCh:TWQuality:PCERror:MAXimum?"

FETCh:TWQuality:PERRor[:AVERage]?

Function | Queries the average phase error when the Multi-Measurement Count State is ON.
Query | Range: -180 to 180 degrees, 9.91 E+37 Resolution: 0.01
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "FETCh:TWQuality:PERRor:AVERage?"

FETCh:TWQuality:PERRor:ALL?

Function

Queries the phase error measurement results, which are returned in the following order: minimum, maximum, average and standard deviation phase error.

Query

Minimum Phase Error

  • Range: -180 to 180 degrees, 9.91 E+37

  • Resolution: 0.01

Maximum Phase Error

  • Range: -180 to 180 degrees, 9.91 E+37

  • Resolution: 0.01

Average Phase Error

  • Range: -180 to 180 degrees, 9.91 E+37

  • Resolution: 0.01

Standard Deviation Phase Error

  • Range: -180 to 180 degrees, 9.91 E+37

  • Resolution: 0.001

Requirements

Test Application Revision: A.01.00 and above

Programming Example

"FETCh:TWQuality:PERRor:ALL?"

FETCh:TWQuality:PERRor:MAXimum?

Function | Queries the maximum phase error when the Multi-Measurement Count State is ON.
Query | Range: -180 to 180 degrees, 9.91 E+37 Resolution: 0.01
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "FETCh:TWQuality:PERRor:MAXimum?"

FETCh:TWQuality:PERRor:MINimum?

Function | Queries the minimum phase error when the Multi-Measurement Count State is ON.
Query | Range: -180 to 180 degrees, 9.91 E+37 Resolution: 0.01
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "FETCh:TWQuality:PERRor:MINimum?"

FETCh:TWQuality:PERRor:SDEViation?

Function | Queries the standard deviation phase error when the Multi-Measurement Count State is ON.
Query | Range: -180 to 180 degrees, 9.91 E+37 Resolution: 0.001
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "FETCh:TWQuality:PERRor:SDEViation?"

FETCh:TWQuality:MERRor[:AVERage]?

Function | Queries the Average Magnitude Error when the Multi-Measurement Count State is ON.
Query | Range: 0 to 99%, 9.91 E+37 Resolution: 0.01
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "FETCh:TWQuality:MERRor:AVERage?"

FETCh:TWQuality:MERRor:ALL?

Function

Queries the Magnitude Error results, which are returned in the following order: minimum, maximum, average, standard deviation magnitude error.

Query

Minimum Magnitude Error

  • Range: 0 to 99%, 9.91 E+37

  • Resolution: 0.01

Maximum Magnitude Error

  • Range: 0 to 99%, 9.91 E+37

  • Resolution: 0.01

Average Magnitude Error

  • Range: 0 to 99%, 9.91 E+37

  • Resolution: 0.01

Standard Deviation Magnitude Error

  • Range: 0 to 99%, 9.91 E+37

  • Resolution: 0.001

Requirements

Test Application Revision: A.01.00 and above

Programming Example

"FETCh:TWQuality:MERRor:ALL?"

FETCh:TWQuality:MERRor:MAXimum?

Function | Queries the Maximum Magnitude Error when the Multi-Measurement Count State is ON.
Query | Range: 0 to 99%, 9.91 E+37 Resolution: 0.01
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "FETCh:TWQuality:MERRor:MAXimum?"

FETCh:TWQuality:MERRor:MINimum?

Function | Queries the Minimum Magnitude Error when the Multi-Measurement Count State is ON.
Query | Range: 0 to 99%, 9.91 E+37 Resolution: 0.01
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "FETCh:TWQuality:MERRor:MINimum?"

FETCh:TWQuality:MERRor:SDEViation?

Function | Queries the Standard Deviation Magnitude Error when the Multi-Measurement Count State is ON.
Query | Range: 0 to 99%, 9.91 E+37 Resolution: 0.01
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "FETCh:TWQuality:MERRor:SDEViation?"

FETCh:TWQuality:TERRor[:AVERage]?

Function | Queries the Average Timing Error when the Multi-Measurement Count State is ON.
Query | Range: -99.99 to 99.99 chips, 9.91 E+37 Resolution: 0.01 chips
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "FETCh:TWQuality:TERRor:AVERage?"

FETCh:TWQuality:TERRor:ALL?

Function

Queries the timing error results in the following order: Minimum, Maximum, Average, Std Deviation and Worst timing error.

Query

Minimum Timing Error

  • Range: -99.99 to 99.99 chips, 9.91 E+37

  • Resolution: 0.01 chips

Maximum Timing Error

  • Range: -99.99 to 99.99 chips, 9.91 E+37

  • Resolution: 0.01 chips

Average Timing Error

  • Range: -99.99 to 99.99 chips, 9.91 E+37

  • Resolution: 0.01 chips

Standard Deviation Timing Error

  • Range: -99.99 to 99.99 chips, 9.91 E+37

  • Resolution: 0.001 chips

Worst Timing Error

  • Range: -99.99 to 99.99 chips, 9.91 E+37

  • Resolution: 0.001 chips

Requirements

Test Application Revision: A.01.00 and above

Programming Example

"FETCh:TWQuality:TERRor:ALL?"

FETCh:TWQuality:TERRor:MAXimum?

Function | Queries the maximum timing error when the Multi-Measurement Count State is ON.
Query | Range: -99.99 to 99.99 chips, 9.91 E+37 Resolution: 0.01 chips
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "FETCh:TWQuality:TERRor:MAXimum?"

FETCh:TWQuality:TERRor:MINimum?

Function | Queries the minimum timing error when the Multi-Measurement Count State is ON.
Query | Range: -99.99 to 99.99 chips, 9.91 E+37 Resolution: 0.01 chips
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "FETCh:TWQuality:TERRor:MINimum?"

FETCh:TWQuality:TERRor:SDEViation?

Function | Queries the Standard Deviation Timing Error when the Multi-Measurement Count State is ON.
Query | Range: -99.99 to 99.99 chips, 9.91 E+37 Resolution: 0.001 chips
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "FETCh:TWQuality:TERRor:SDEViation?"

FETCh:TWQuality:TERRor:WORSt?

Function | Queries the worst case timing error. (The test set returns either the Minimum or Maximum Timing Error result, whichever is furthest from zero).
Query | Range: -99.99 to 99.99 chips, 9.91 E+37 Resolution: 0.001 chips
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "FETCh:TWQuality:TERRor:WORSt?"


INITiate Subsystem

Description

The INITiate subsystem is used to:

  • Start (activate) individual or multiple (concurrent) measurements.

  • Turn individual measurements off.

  • Determine the number of measurements currently active (INIT:COUNT?).

  • Determine the names of the measurements currently active (INIT:ON?).

  • Determine which measurements are finished (INIT:DONE?).

When a measurement is started using INITiate commands, a new measurement cycle is started. If the selected measurement is currently in a measurement cycle, it is aborted. If a timeout is specified, the timeout period begins when a measurement is initiated.

Related Topics

  • INITiate


INITiate

These commands allow you to start and stop measurements.

  • INITiate:<measurement mnemonic>[:ON]

  • INITiate<:measurement mnemonic>:OFF

  • INITiate:DONE?

  • INITiate:DONE:FLAG<:measurement mnemonic>

  • INITiate:ON?

  • INITiate:TFDTune:ARMed?

For more information on the GPIB Command conventions, see GPIB Command conventions

INITiate:<measurement mnemonic>[:ON]

Function

These commands initiate (start) the specified measurements:

  • TCP (Channel Power Measurement)

  • TWQ (Waveform Quality Measurement)

  • TACL (Adjacent Channel Leakage Ratio

  • TSEMask (Spectrum Emission Mask Measurement)

  • FSTability (Frequency Stability Measurement)

  • TCLPower (Closed Loop Power Control Measurement)

  • TOBWidth (Occupied Bandwidth Measurements)

  • TDPower (Dynamic Power Measurement)

  • TOOPower (Transmit ON/OFF Power Measurement)

  • TBERror (Loopback Bit Error Rate Measurement)

  • TOLPower (Open Loop Power Control Measurement)

  • TBLerror (Block Error Ratio Measurement)

  • THBLerror (HSDPA Block Error Ratio Measurement)

  • TOOSynch (Out-of-Synchronization of Output Power Measurement)

  • TFDTune (Fast Device Tune Measurement)

  • THCQuality (Reporting of Channel Quality Indicator Measurement)

Setting

No setting

Query

No query:

*RST Setting

None

Requirements

Test Application Revision: A.01.00 and above
Test Application Revision: A.02.00 and above, added TOB, TDP, TOOP and TBERror.

Test Application Revision: A.03.00 and above, added TOLP, TBLerror and THBLerror.

Test Application Revision: A.04.00 and above, added TOOSynch, TFDT, THCQuality.

Programming Example

"INITiate:TCPower"

INITiate<:measurement mnemonic>:OFF

Function | Deactivates the selected measurement. See INITiate:<measurement mnemonic>[:ON] for a list of measurements.
Setting | No setting
Query | No query:
*RST Setting | None
Requirements | Test Application Revision: A.01.00 and above Test Application Revision: A.02.00 and above, added TOB, TDP, TOOP and TBERror. Test Application Revision: A.03.00 and above, added TOLP, TBLerror and THBLerror. Test Application Revision: A.04.00 and above, added TOOSynch, TFDT, THCQuality.
Programming Example | "INITiate:TCPower:OFF"

INITiate:DONE?

Function

Queries (one at a time) which measurements, if any, are finished or have timed-out.

Setting

No setting

Query

  • TCP (Channel Power Measurement)

  • TWQ (Waveform Quality Measurement)

  • TACL (Adjacent Channel Leakage Ratio

  • TSEMask (Spectrum Emission Mask Measurement)

  • FSTability (Frequency Stability Measurement)

  • TCLPower (Closed Loop Power Control Measurement)

  • TOBWidth (Occupied Bandwidth Measurements)

  • TDPower (Dynamic Power Measurement)

  • TOOPower (Transmit ON/OFF Power Measurement)

  • TBERror (Loopback Bit Error Rate Measurement)

  • TOLPower (Open Loop Power Control Measurement)

  • TBLerror(Block Error Ratio Measurement)

  • THBLerror (HSDPA Block Error Ratio Measurement)

  • TOOSynch (Out-of-Synchronization of Output Power Measurement)

  • TFDTune (Fast Device Tune Measurement)

  • THCQuality (Reporting of Channel Quality Indicator Measurement)

*RST Setting

None

Requirements

Test Application Revision: A.01.00 and above
Test Application Revision: A.02.00 and above, added TOB, TDP, TOOP and TBERror.

Test Application Revision: A.03.00 and above, added TOLP, TBLerror and THBLerror.

Test Application Revision: A.04.00 and above, added TOOSynch, TFDT, THCQuality.

Programming Example

"INITIATE:DONE?"

INITiate:DONE:FLAG<:measurement mnemonic>

Function | Specifies if a measurement done flag is considered (using the INCLude or EXCLude settings) when the INITiate:DONE? query is sent. See INITiate<:measurement mnemonic>[:ON] for a list of measurement mnemonics.
Setting | INCLude | EXCLude
Query | INCL|EXCL
*RST Setting | None
Requirements | Test Application Revision: A.01.00 and above Test Application Revision: A.02.00 and above, added TOB, TDP, TOOP and TBERror. Test Application Revision: A.03.00 and above, added TOLP, TBLerror and THBLerror. Test Application Revision: A.04.00 and above, added TOOSynch, TFDT, THCQuality.
Programming Example | "INITIATE:DONE:FLAG:TCP EXCLUDE"

INITiate:ON?

Function

Queries the measurements that are on. Returns a comma separated list of measurement mnemonics.

Setting

No setting

Query

  • TCP (Channel Power Measurement)

  • TWQ (Waveform Quality Measurement)

  • TACL (Adjacent Channel Leakage Ratio

  • TSEMask (Spectrum Emission Mask Measurement)

  • FSTability (Frequency Stability Measurement)

  • TCLPower (Closed Loop Power Control Measurement)

  • TOBWidth (Occupied Bandwidth Measurements)

  • TDPower (Dynamic Power Measurement)

  • TOOPower (Transmit ON/OFF Power Measurement)

  • TBERror (Loopback Bit Error Rate Measurement)

  • TOLPower (Open Loop Power Control Measurement)

  • TBLerror (Block Error Ratio Measurement)

  • THBLerror (HSDPA Block Error Ratio Measurement)

  • TOOSynch (Out-of-Synchronization of Output Power Measurement)

  • TFDTune (Fast Device Tune Measurement)

  • THCQuality (Reporting of Channel Quality Indicator Measurement)

*RST Setting

None

Requirements

Test Application Revision: A.01.00 and above
Test Application Revision: A.02.00 and above, added TOB, TDP, TOOP and TBERror.

Test Application Revision: A.03.00 and above, added TOLP, TBLerror and THBLerror.

Test Application Revision: A.04.00 and above, added TOOSynch, TFDT, THCQuality.

Programming Example

"INITiate:ON?"

INITiate:TFDTune:ARMed?

Function

Queries the arm state of the fast device tune measurement.

  • This command immediately returns a 1 if the fast device tune measurement has been initiated and is ready to be triggered.

  • This command hangs if the fast device tune measurement has been initiated but is not ready to be triggered (it will return a 1 once the measurement becomes ready to be triggered).

  • This command immediately returns a 0 if the fast device tune measurement is not in the process of preparing for a trigger (for example, if the fast device tune measurement has not been initiated, has been aborted, or has already been triggered).

Query

Range: 0 | 1

Requirements

Test Application Revision: A.04.00 and above

Programming Example

"INITiate:TFDTune:ARMed?"


READ Subsystem

Description

The READ? command provides a sequential method to make measurements and retrieve the results. READ? will hang the GPIB bus until the measurement is completed, or until the timeout value has been exceeded. Associated SETup commands (for each measurement) are used with the READ? command to retrieve desired measurement results in a sequential manner.

Sending a READ? command is equivalent to an INITiate/FETCh cycle for a measurement. A READ? command executes an abort action on that measurement followed by an INITiate and a FETCH?.

READ? commands can be mixed with FETCH? queries in order to make combinations of sequential and overlapped operations. One measurement can be issued a READ? command (sequential), and the next measurement can be issued INITiate/FETCh? commands (overlapped), if necessary.

The advantage of using the READ? commands to obtain measurement results, as opposed to the INITiate/FETCh method is:

  • It is simpler. Fewer commands are required to obtain measurement results.

Some disadvantages of using READ? over INITiate and FETCh are:

  • The test set does not process any additional GPIB commands until the requested measurement results are available.

  • The sequential nature of the READ? command does not allow the user to make concurrent measurements. Concurrent measurements require the overlapped commands INITiate, DONE? and FETCh? .

  • The READ? command does not provide measurement results such as statistics that are available using the INITiate/FETCh method.

  • The READ? commands have pre-defined measurement results. If additional results are needed from a measurement they may be obtained with a FETCh? query.

Related Topics

  • READ


READ

  • READ:FSTability[:ALL]?

  • READ:TACLeakage[:ALL]

  • READ:TBERror[:ALL]?

  • READ:TCLPower[:ALL]?

  • READ:TCPower[:ALL]?

  • READ:TDPower[:ALL]?

  • READ:TFDTune[:ALL]?

  • READ:TOBWidth[:ALL]?

  • READ:TOLPower[:ALL]?

  • READ:TOOPower[:ALL]?

  • READ:TSEMask[:ALL]?

  • READ:TWQuality[:ALL]?

For more information on the GPIB Command conventions, see GPIB Command conventions

READ:FSTability[:ALL]?

Function

Initiates and fetches a frequency stability measurement as a sequential operation.

Measurement results are returned in the following order: integrity, worst-case frequency error, average frequency

Query

Worst-case frequency error

  • Range: -500 to 500 parts per million (ppm)

  • Resolution: 0.01

Average frequency

  • Range: 100 E+6 to 3 E+9 Hz

  • Resolution: 1 Hz

Requirements

Test Application Revision: A.01.00 and above

Programming Example

"READ:FSTability?"

READ:TACLeakage[:ALL]?

Function

Initiates and fetches an ACLR measurement as a sequential operation.

The results are returned in the following order: Integrity Indicator, Overall Pass/Fail, Lower adjacent (-1.6MHz) Pass/Fail, Upper adjacent (+1.6MHz) Pass/Fail, Lower alternated (-3.2MHz) Pass/Fail, Upper alternated (+3.2MHz) Pass/Fail, Lower adjacent (-1.6MHz) Result, Upper adjacent (+1.6MHz) Result, Lower alternated (-3.2MHz) Result, Upper alternated (+3.2MHz) Result.

Query

Integrity Indicator

  • Range: 0 to 23

Overall Pass/Fail, Lower/Upper adjacent Pass/Fail, Lower/Upper alternated Pass/Fail

  • Range: 0 (Pass) | 1 (Fail)

Lower/Upper adjacent Results, Lower/Upper alternated Results

  • Range: Measured Value, 9.91 E+37

  • Resolution: 0.01

Requirements

Test Application Revision: A.01.00 and above

Programming Example

"READ:TACLeakage:ALL?"

READ:TCLPower[:ALL]?

Function

Initiates and fetches closed loop power control measurement as a sequential operation. Results are returned in the following order: integrity indicator, overall pass/fail, maximum power, minimum power, worst REL1POW step index, worst REL1POW absolute power, worst REL1POW, worst REL10POW step index, worst REL10POW absolute power and worst REL10POW.

The Pass/Fail indicator is a decimal number that combines the pass/fail results of the REL1POW and the REL10POW together. If the binary expression of this decimal number is "b3b2b1b0", then the meaning of each digit is as follows:

  • b0 : REL1POW trace Pass(0)/Fail(1)

  • b1 : REL10POW trace Pass(0)/Fail(1)

  • b2 : Maximum Power Pass(0)/Fail(1)

  • b3 : Minimum Power Pass(0)/Fail(1)

The worst step refers to the step whose relative power (REL1POW or REL10POW) is closest to its upper or lower limit among all checked steps.

The REL1POW or REL10POW power trace is failed If there is at least one step in the trace is failed or no step in the trace is checked.

Query

Integrity Indicator (see Integrity Indicator)

  • Range: 0 to 23

Overall Pass / Fail

  • Range: 0 to 15, 9.91 E+37 (NAN)

  • Resolution: 1

Maximum Power (the maximum absolute mean power among all measured steps)

  • Range: value in dBm, 9.91 E+37 (NAN)

  • Resolution: 0.01

Minimum Power (the minimum absolute mean power among all measured steps)

  • Range: value in dBm, 9.91 E+37 (NAN)

  • Resolution:0.01

Worst REL1POW Step Index (the index of the worst step):

  • Range: 0 to 300, 9.91 E+37 (NAN)

  • Resolution: 1

Worst REL1POW Absolute Power:

  • Range: value in dBm, 9.91 E+37 (NAN)

  • Resolution: 0.01

Worst REL1POW:

  • Range: value in dB, 9.91 E+37 (NAN)

  • Resolution: 0.01

Worst REL10POW Step Index:

  • Range: 0 to 300, 9.91 E+37 (NAN)

  • Resolution: 1

Worst REL10POW Absolute Power:

  • Range: value in dBm, 9.91 E+37 (NAN)

  • Resolution: 0.01

Worst REL10POW:

  • Range: value in dB, 9.91 E+37 (NAN)

  • Resolution:0.01

Requirements

Test Application Revision: A.01.00 and above

Programming Example

"READ:TCLPower?"

READ:TCPower[:ALL]?

Function

Initiates and fetches a channel power measurement as a sequential operation.

Measurement results are returned in the following order: integrity, average channel power.

If the multi-measurement state is on, the result represents the average of a number of channel power measurements. Multi-measurement state, by default, is off.

Query

integrity:

  • Range: 0 to 23

  • Resolution: 1

average channel power:

  • Range: -99 to 99 dBm

  • Resolution: 0.01 dB

Requirements

Test Application Revision: A.01.00 and above

Programming Example

"READ:TCPower?"

READ:TDPower[:ALL]?

Function | Initiates and fetches a dynamic power measurement as a sequential operation. Measurement results are returned in the following order: integrity, measurement step results in array.
Query | see FETCh:TDPower
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "READ:TDPower:ALL?"

READ:TFDTune[:ALL]?

Function

Initiates and fetches a fast device tune measurement as a sequential operation.

Results are returned in the following order:

  • Integrity Indicator

  • Tx Frequency Step Count

  • Tx Power Step Count

  • Number of MS TX power steps measured (in most cases, it equals Number of Tx Frequency Steps multiplied by Number of Tx Power Steps)

  • Comma-separated list of 400 MS Tx Power results. 400 results are always returned; if the test set measured fewer than 400 power steps from the mobile, the remaining values are NANs (9.91E+37). The power results for the first frequency in the MS TX Frequency Sequence are returned first, then the power results for the second frequency in the MS TX Frequency Sequence, etc., followed by NANs if fewer than 400 points were measured.

Query

Integrity

  • Range: see Integrity Indicator

  • Resolution: 1

Number of Tx Frequency Steps

  • Range: 1 to 40, 9.91 E+37

  • Resolution: 1

Number of Tx Power Steps

  • Range: 1 to 40, 9.91 E+37

  • Resolution: 1

Number of MS Tx Power Steps Measured

  • Range: 1 to 400, 9.91 E+37

  • Resolution: 1.0

MS Tx Power Results Array

  • Range: -100.00 to +100.00 dBm, 9.91 E+37

  • Resolution: 0.01 dBm

Requirements

Test Application Revision: A.04.00 and above

Programming Example

"READ:TFDT?"

READ:TOBWidth[:ALL]?

Function

Initiates and fetches an occupied bandwidth measurement as a sequential operation.

Measurement results are returned in the following order: integrity, occupied bandwidth, lower frequency, upper frequency.

Query

Integrity Indicator

  • Range: 0 to 23

  • Resolution: 1

Occupied Bandwidth

  • Range: measured value in Hz, 9.91 E+37

  • Resolution: 0.01

Lower Frequency

  • Range: measured value in Hz, 9.91 E+37

  • Resolution: 0.01

Upper Frequency

  • Range: measured value in Hz, 9.91 E+37

  • Resolution: 0.01

Requirements

Test Application Revision: A.02.00 and above

Programming Example

"READ:TOBWidth?"

READ:TOLPower[:ALL]?

Function

Initiates and fetches an open loop power control measurement as a sequential operation.

Measurement results are returnedr in the following order: Integrity Indicator, Pass/Fail, Open Loop Power Result, Detected UpPCH signature.

Query

Integrity Indicator: see Integrity Indicator.

Pass/Fail

  • Range: 0 | 1, 9.91 E+37

Open Loop Power

  • Range: Measured Value in dBm, 9.91 E+37

  • Resolution: 0.01

Detected UpPCH signature

  • Range: 0 to 255, 9.91 E+37

  • Resolution: 1

Requirements

Test Application Revision: A.03.00 and above

Programming Example

"READ:TOLPower"

READ:TOOPower[:ALL]?

Function

Initiates and fetches an transmit ON/OFF Power measurement as a sequential operation.

The transmit ON/OFF power measurement results are returned in the following order: Integrity, Overall Pass Fail, Averaged ON Power, Range 1 Pass/Fail, Range 1 averaged power, Range 2 Pass/Fail, Range 2 averaged power, Range 3 Pass/Fail, Range 3 averaged power.

The overall pass/fail result will be fail if any of the three ranges fails.

Range 1 refers to chips from -864 to -34; Range 2 refers to chips from-33 to -14; Range 3 refers to chips from 860 to 1711.

Query

Integrity

  • Range: 0 to 23

Overall Pass/Fail

  • Range: 0 (pass), 1 (fail)

Averaged ON Power

  • Range: value in dBm, 9.91 E+37 (NAN)

  • Resolution: 0.01

Range 1 Pass/Fail

  • Range: 0 (pass), 1 (fail)

Range 1 Averaged Power

  • Range: value in dBm, 9.91 E+37 (NAN)

  • Resolution: 0.01

Range 2 Pass/Fail

  • Range: 0 (pass), 1 (fail)

Range 2 Averaged Power

  • Range: value in dBm, 9.91 E+37 (NAN)

  • Resolution: 0.01

Range 3 Pass/Fail

  • Range: 0 (pass), 1 (fail)

Range 3 Averaged Power

  • Range: value in dBm, 9.91 E+37 (NAN)

  • Resolution: 0.01

Requirements

Test Application Revision: A.02.00 and above

Programming Example

"READ:TOOPower?"

READ:TBERror[:ALL]?

Function

Initiates and fetches a loopback BER measurement as a sequential operation.

Measurement results are returned in the following order: integrity, bit error ratio, bit error count, bits tested.

Query

Range:

  • Integrity: see Integrity Indicator .

  • Bit Error Ratio: 0 to 99.0000%, 9.91 E+37

  • Bit Error Count: 0 to 999 999 999, 9.91 E+37

  • Bits Tested: 0 to 999 999 999, 9.91 E+37

Requirements

Test Application Revision: A.02.00 and above

Programming Example

"READ:TBERror:ALL?"

READ:TSEMask[:ALL]?

Function | Initiates and fetches a Spectrum emission mask (SEM) measurement as a sequential operation. Measurement results are returned in the following order: integrity, overall pass/fail result, pass/fail results for all three frequency ranges, and average levels for all three frequency ranges.
Query | See FETCh:TSEMask
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "READ:TSEMask?"

READ:TWQuality[:ALL]?

Function

Initiates and fetches a waveform quality measurement as a sequential operation. Measurement results are returned in the following order: integrity, RMS EVM/Average, Frequency Error/Average, Origin Offset/Average, Phase Error/Average, Magnitude Error/Average, Time Error/Average, PCDE/Average.

Query

Integrity

  • Range: 0 to 23

  • Resolution: 1

RMS EVM

  • Range: 0.0 to 99.0%, 9.91 E+37

  • Resolution: 0.01

Frequency Error

  • Range: -99.0 to 99.0 kHz, 9.91 E+37

  • Resolution: 0.01

Origin Offset

  • Range: -99.0 to 0.0 dB, 9.91 E+37

  • Resolution: 0.01

Phase Error

  • Range: 0 to 180 degrees, 9.91 E+37

  • Resolution: 0.01

Magnitude Error

  • Range: 0.0 to 99.0%, 9.91 E+37

  • Resolution: 0.01

Timing Error

  • Range: -99.99 to 99.99 chips, 9.91 E+37

  • Resolution: 0.01 chips

Peak Code Domain Error

  • Range: -99 to 0 dB, 9.91 E+37

  • Resolution: 0.01

Requirements

Test Application Revision: A.01.00 and above

Programming Example

"READ:TWQuality:ALL?"


SETup Subsystem

Last updated: April 21, 2010

Description

The SETup subsystem is used to configure the test set for each measurement. Typical settings include:

  • Multi-Measurement Count, how many measurements will be made each time a measurement is initiated.

  • Trigger Arm, determines if a measurement will make one measurement then return to idle (single), or automatically rearm on completion of a measurement and repeat the process (continuous).

  • Trigger Source, how a measurement is triggered.

  • Trigger Delay, controls the delay time between the trigger and the start of sampling.

  • Measurement Timeout, length of time before a measurement times out.

Related Topics

  • SETup:FSTability

  • SETup:TACLeakage

  • SETup:TBERror

  • SETup:TCLPower

  • SETup:TCPower

  • SETup:TDPower

  • SETup:TOBWidth

  • SETup:TOOPower

  • SETup:TSEMask

  • SETup:TWQuality


SETup:FSTability

  • SETup:FSTability:AFILter

  • SETup:FSTability:CONTinuous

  • SETup:FSTability:COUNt[:SNUMber]

  • SETup:FSTability:COUNt:NUMBer

  • SETup:FSTability:COUNt:STATe

  • SETup:FSTability:TIMeout[:STIMe]

  • SETup:FSTability:TIMeout:STATe

  • SETup:FSTability:TIMeout:TIME

For more information on the GPIB Command conventions, see GPIB Command conventions

For the measurement, see Frequency Stability Measurement.

SETup:FSTability:AFILter

Function | Sets/queries the additional filter for the frequency stability measurement.
Setting | Range: NONE|BWKH30
Query | Range:NONE|BWKH30
*RST Setting | NONE
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "SETup:FSTability:AFILter NONE"

SETup:FSTability:CONTinuous

Function | Sets/queries the trigger arm state for the frequency stability measurement. Determines whether measurement will make one measurement then stop (0|OFF (single)), or automatically rearm upon completion of one measurement and repeat the process (1|ON (continuous)).
Setting | Range: 1|ON|0|OFF
Query | Range: 1|0
*RST Setting | 0 (off)
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "SETUP:FSTABILITY:CONTINUOUS ON"

SETup:FSTability:COUNt[:SNUMber]

Function | Sets/queries the number of frequency stability measurements to be made in a multi-measurement setup. This command sets the count, and automatically sets the multi-measurement STATe command to 1 (on).
Setting | Range: 1 to 999
Query | Range: 1 to 999
*RST Setting | 10, on
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "SETUP:FSTABILITY:COUNT:SNUMBER 5"

SETup:FSTability:COUNt:NUMBer

Function | Sets/queries the number of frequency stability measurements to be made when multi-measurement state is ON.
Setting | Range: 1 to 999
Query | Range: 1 to 999
*RST Setting | 10
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "SETUP:FSTABILITY:COUNT:NUMBER 5"

SETup:FSTability:COUNt:STATe

Function | Sets/queries the multi-measurement state of the frequency stability measurement.
Setting | Range: 1|ON|0|OFF
Query | Range: 1|0
*RST Setting | 0 (off)
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "SETUP:FSTABILITY:COUNT:STATE ON"

SETup:FSTability:TIMeout[:STIMe]

Function | Sets/queries the frequency stability measurement's timeout setting and automatically sets the timeout state to ON.
Setting | Range: 0.1 to 999.9 seconds Resolution: 0.1 second
Query | same as setting
*RST Setting | 10 seconds, on
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "SETUP:FSTABILITY:TIMEOUT:STIME 5S"

SETup:FSTability:TIMeout:STATe

Function | Sets/queries the frequency stability measurement's timeout state.
Setting | Range: 1|ON|0|OFF
Query | Range: 1|0
*RST Setting | 0 (off)
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "SETUP:FSTABILITY:TIMEOUT:STATE ON"

SETup:FSTability:TIMeout:TIME

Function | Sets/queries the frequency stability measurement's timeout setting.
Setting | Range: 0.1 to 999.9 seconds Resolution: 0.1 second
Query | same as setting
*RST Setting | 10 seconds, on
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "SETUP:FSTABILITY:TIMEOUT:TIME 5S"


SETup:TACLeakage

  • SETup:TACLeakage:CONTinuous

  • SETup:TACLeakage:COUNt[:SNUMber]

  • SETup:TACLeakage:COUNt:NUMBer

  • SETup:TACLeakage:COUNt:STATe

  • SETup:TACLeakage:LIMit

  • SETup:TACLeakage:TIMeout[:STIMe]

  • SETup:TACLeakage:TIMeout:STATe

  • SETup:TACLeakage:TIMeout:TIME

  • SETup:TACLeakage:TRIGger:DELay

  • SETup:TACLeakage:TRIGger:SOURce

For more information on the GPIB Command conventions, see GPIB Command conventions.

For the measurement, see Adjacent Channel Leakage Ratio (ACLR) Measurement.

SETup:TACLeakage:CONTinuous

Function | Sets/queries the trigger arm state for the adjacent channel leakage measurement. The trigger arm state determines whether the adjacent channel leakage measurement will be made once then stop (0|OFF (single)), or automatically re-arm upon completion of one measurement and repeat the process (1|ON (continuous)).
Setting | Range: 1|ON|0|OFF
Query | Range: 1|0
*RST Setting | 0 (off)
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "SETup:TACLeakage:CONTinuous OFF"

SETup:TACLeakage:COUNt[:SNUMber]

Function

The setting form of this command performs two functions: (1) sets the number of adjacent channel leakage measurements to be made in a multi-measurement, and (2) sets the multi-measurement STATe command to 1 (on).

The query form returns the number of adjacent channel leakage multi-measurements to be made when multi-measurement state is ON.

Setting

Range: 1 to 999

Query

Range: 1 to 999

*RST Setting

Off (10 when STATe = On)

Requirements

Test Application Revision: A.01.00 and above

Programming Example

"SETup:TACLeakage:COUNt:SNUMber 5"

SETup:TACLeakage:COUNt:NUMBer

Function | Sets/queries the number of adjacent channel leakage measurements to be made when the multi-measurement state is ON.
Setting | Range: 1 to 999
Query | Range: 1 to 999
*RST Setting | 10
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "SETup:TACLeakage:COUNt:NUMBer 5"

SETup:TACLeakage:COUNt:STATe

Function | Sets/queries the adjacent channel leakage multi-measurement state.
Setting | Range: 1|ON|0|OFF
Query | Range: 1|0
*RST Setting | 0 (off)
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "SETup:TACLeakage:COUNt:STATe ON"

SETup:TACLeakage:LIMit

Function | Sets/queries the Adjacent (±1.6MHz) and the Alternate (±3.2MHz) limit for the ACLR measurement.
Setting | Range: -80 to +10 dBc Resolution: 0.01
Query | Same as setting
*RST Setting | -33, -43 ( adjacent limit, alternate limit)
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "SETup:TACLeakage:LIMit -33, -43"

SETup:TACLeakage:TIMeout[:STIMe]

Function | The setting form of this command performs two functions: (1) sets the adjacent channel leakage measurement's timeout value, and (2) sets the adjacent channel leakage measurement's timeout STATe to 1 (on). The query form returns the adjacent channel leakage measurement's timeout value.
Setting | Range: 0.1 to 999.9 seconds Resolution: 0.1 second Unit: S | MS | US | NS
Query | Range: 0.1 to 999.9
*RST Setting | 10 seconds, off
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "SETup:TACLeakage:TIMeout:STIMe 5 S"

SETup:TACLeakage:TIMeout:STATe

Function | Sets/queries the adjacent channel leakage measurement's timeout state.
Setting | Range: 1|ON|0|OFF
Query | Range: 1|0
*RST Setting | 0 (off)
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "SETup:TACLeakage:TIMeout:STATe ON"

SETup:TACLeakage:TIMeout:TIME

Function | Sets/queries the adjacent channel leakage measurement's timeout setting to be used when the timeout state is set to ON.
Setting | Range: 0.1 to 999.9 seconds Resolution: 0.1 second Unit: S | MS | US | NS
Query | Range: 0.1 to 999.9
*RST Setting | 10 seconds
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "SETup:TACLeakage:TIMeout:TIME 5 S"

SETup:TACLeakage:TRIGger:DELay

Function | Sets/queries the adjacent channel leakage measurement's Trigger Delay setting. This setting can be used to delay the measurement trigger in order to start a measurement during a specific timeslot in the frame. For example, a 1.333 ms delay would cause the trigger to wait until after the first two timeslots have elapsed.
Setting | Range: -10 to 10 ms Resolution: 0.1 us Unit: S | MS | US | NS
Query | Same as setting
*RST Setting | 0 seconds
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "SETup:TACLeakage:TRIGger:DELay 1 MS"

SETup:TACLeakage:TRIGger:SOURce

Function | Sets/queries the adjacent channel leakage measurement's Trigger Source .
Setting | Range: AUTO | IMMediate | RISE | EXTernal | PROTocol
Query | Range: AUTO | IMM | RISE | EXT |PROT
*RST Setting | AUTO
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "SETup:TACLeakage:TRIGger:SOURce AUTO"


SETup:TBERror

  • SETup:TBERror:BCRC[:BLOCk]

  • SETup:TBERror:CONFidence:STATe

  • SETup:TBERror:CONTinuous

  • SETup:TBERror:COUNt

  • SETup:TBERror[:RATio]:REQuirement

  • SETup:TBERror:TIMeout[:STIMe]

  • SETup:TBERror:TIMeout:STATe

  • SETup:TBERror:TIMeout:TIME

For more information on the GPIB Command conventions, see GPIB Command conventions

For the measurement, see Loopback Bit Error Ratio (BER) Measurement.

SETup:TBERror:BCRC[:BLOCk]

Function | Sets/queries the Bad CRC Block which determines whether the data block is counted for BER calculation. See Bad CRC Block.
Setting | Range: EXCLude | INCLude
Query | Range: EXCL | INCL
*RST Setting | EXCLude
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "SETup:TBERror:BCRC EXCLude"

SETup:TBERror:CONFidence:STATe

Function | Sets/queries Confidence State. See Confidence State.
Setting | Range: 1|ON|0|OFF
Query | Range: 1|0
*RST Setting | 0 (Off)
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "SETup:TBERror:CONFidence:STATe OFF"

SETup:TBERror:CONTinuous

Function | Sets/queries the trigger arm state for the loopback BER measurement. The trigger arm state determines whether the loopback BER measurement will be made once then stop (0|OFF (single)), or automatically re-arm upon completion of one measurement and repeat the process (1|ON (continuous)).
Setting | Range: 1|ON|0|OFF
Query | Range: 1|0
*RST Setting | 0 (OFF)
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "SETUP:TBERror:CONTinuous OFF"

SETup:TBERror:COUNt

Function | Sets/queries the number of bits to test. See Number of bits to test.
Setting | Range: 1000 to 999 999 999 Resolution: 1
Query | same as setting
*RST Setting | 10000
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "SETup:TBERror:COUNt 10000"

SETup:TBERror[:RATio]:REQuirement

Function | Sets/queries the BER Requirement, in percent. When the confidence state is On, as testing progresses the bit error ratio trajectory converges to a BER value, which shall not be exceed this setting as test requirement. See BER Requirement.
Setting | Range: 0.10 to 50.00 Resolution: 0.01
Query | Range: 0.10 to 50.00
*RST Setting | 0.10
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "SETup:TBERror:RATio:REQuirement 0.1"

SETup:TBERror:TIMeout[:STIMe]

Function | The setting form of this command performs two functions: (1) sets the loopback BER measurement's timeout value, and (2) sets the loopback BER measurement's timeout state to 1 (ON). The query form returns the loopback BER measurement's timeout value.
Setting | Range: 0.1 to 999.9 seconds Unit: S | MS | US | NS
Query | Range: 0.1 to 999.9
*RST Setting | 10 s, on
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "SETup:TBERror:TIMeout:STIMe 5S"

SETup:TBERror:TIMeout:STATe

Function | Sets/queries the loopback BER measurement's timeout state.
Setting | Range: 1|ON|0|OFF
Query | Range: 1|0
*RST Setting | 0(OFF)
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "SETup:TBERror:TIMeout:STATe ON"

SETup:TBERror:TIMeout:TIME

Function | Sets/queries the loopback BER measurement's timeout.
Setting | Range: 0.1 to 999.9 seconds Unit: S | MS | US | NS
Query | Range: 0.1 to 999.9
*RST Setting | 10 s
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "SETup:TBERror:TIMeout:TIME 5S"


SETup:TBLerror

Last updated: March 10, 2010

  • SETup:TBLerror:CONTinuous

  • SETup:TBLerror:COUNt

  • SETup:TBLerror:TIMeout[:STIMe]

  • SETup:TBLerror:TIMeout:STATe

  • SETup:TBLerror:TIMeout:TIME

For more information on the GPIB Command conventions, see GPIB Command conventions

For the measurement, see Block Error Ratio (BLER) Measurement.

SETup:TBLerror:CONTinuous

Function | Sets/queries the trigger arm state for the block error ratio measurement. The trigger arm state determines whether the block error ratio measurement will be made once then stop (0|OFF (single)), or automatically re-arm upon completion of one measurement and repeat the process (1|ON (continuous)).
Setting | Range: 1|ON|0|OFF
Query | Range: 1|0
*RST Setting | 0 (off)
Requirements | Test Application Revision: A.03.00 and above
Programming Example | "SETup:TBLerror:CONTinuous 0"

SETup:TBLerror:COUNt

Function | Sets/queries the number of blocks to test in the block error ratio measurement.
Setting | Range: 1 to 99,000 blocks Resolution: 1 block
Query | Same as setting
*RST Setting | 500
Requirements | Test Application Revision: A.03.00 and above
Programming Example | "SETup:TBLerror:COUNt 500"

SETup:TBLerror:TIMeout[:STIMe]

Function | The setting form of this command performs two functions: (1) sets the block error ratio measurement's timeout value, and (2) sets the block error ratio measurement's timeout STATe to 1 (on). The query form returns the block error ratio measurement's timeout value.
Setting | Range: 0.1 to 999.9 seconds Resolution: 0.1 second
Query | Same as setting
*RST Setting | 20 seconds, off
Requirements | Test Application Revision: A.03.00 and above
Programming Example | "SETup:TBLerror:TIMeout 20"

SETup:TBLerror:TIMeout:STATe

Function | Sets/queries the block error ratio measurement's timeout state.
Setting | Range: 1|ON|0|OFF
Query | Range: 1|0
*RST Setting | 0 (off)
Requirements | Test Application Revision: A.03.00 and above
Programming Example | "SETup:TBLerror:TIMeout:STATe Off"

SETup:TBLerror:TIMeout:TIME

Function | Sets/queries block error ratio measurement's timeout setting to be used when the timeout state is set to ON.
Setting | Range: 0.1 to 999.9 seconds Resolution: 0.1 second
Query | Same as setting
*RST Setting | 20 seconds
Requirements | Test Application Revision: A.03.00 and above
Programming Example | "SETup:TBLerror:TIMeout:TIME 20"


SETup:TCLPower

  • SETup:TCLPower:MAXimum:POWer:LIMit

  • SETup:TCLPower:MINimum:POWer:LIMit

  • SETup:TCLPower:NSTep

  • SETup:TCLPower:OFFSet

  • SETup:TCLPower:STEP[1]|10:LIMit

  • SETup:TCLPower:STEP[1]|10:LIMit:DB1

  • SETup:TCLPower:STEP[1]|10:LIMit:DB2

  • SETup:TCLPower:STEP[1]|10:LIMit:DB3

  • SETup:TCLPower:TIMeout[:STIMe]

  • SETup:TCLPower:TIMeout:STATe

  • SETup:TCLPower:TIMeout:TIME

  • SETup:TCLPower:TRIGger:DELay

  • SETup:TCLPower:TRIGger:SOURce

For more information on the GPIB Command conventions, see GPIB Command conventions.

For the closed loop power control measurement description, see Closed Loop Power Control (CLPC) Measurement.

SETup:TCLPower:MAXimum:POWer:LIMit

Function | Sets/queries the lower limit and the upper limit of the maximum absolute power among all measured steps, in a comma-separated manner.
Setting | Range: -80 to 40 dBm (lower limit), -80 to 40 dBm (upper limit) Resolution:0.01
Query | same as setting
*RST Setting | 21,25
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "SETup:TCLPower:MAXimum:POWer:LIMit 21,25"

SETup:TCLPower:MINimum:POWer:LIMit

Function | Sets/queries the upper limit of the minimum absolute power among all measured steps.
Setting | Range:-80 to 40 dBm Resolution:0.01
Query | same as setting
*RST Setting | -49
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "SETup:TCLPower:MINimum:POWer:LIMit -49"

SETup:TCLPower:NSTep

Function | Sets/queries the number of DOWN and UP TPC commands sent to the UE, in a comma-separated manner.
Setting | Range: 0 to 150 (the number of DOWN TPC commands), 0 to 150 (the number of UP TPC commands) Resolution: 1
Query | same as setting
*RST Setting | 100,100
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "SETup:TCLPower:NStep 50,50"

SETup:TCLPower:OFFSet

Function

Sets/queries the check offset to the maximum and the minimum power, in a comma-separated manner. The maximum/minimum power is the maximum/minimum power among all measured steps.

Setting

Parameters are two check offsets separated by comma, representing offset to the maximum power comes first and offset to the minimum power comes second, respectively. For each offset:

  • Range: -10.0 to 40.0 dB

  • Resolution:0.01

Query

same as setting

*RST Setting

0.5, 0.5

Requirements

Test Application Revision: A.01.00 and above

Programming Example

"SETup:TCLPower:OFFSet 0.5,0.5"

SETup:TCLPower:STEP[1]|10:LIMit

Function

Sets/queries the lower and upper limit (in a comma-separated manner) for either REL1POW or REL10POW when in TD-SCDMA Test operating mode.

  • For the steps in response to an UP TPC command, the corresponding closed loop power x should be: Lower Limit ≤ x ≤ Upper Limit,

  • For the steps in response to a DOWN TPC command, the corresponding closed loop power x should be: -Upper Limit ≤ x ≤ -Lower Limit.

Setting

Range:

  • REL1POW limits: -10.0 to 40.0dB (lower limit), -10.0 to 40.0dB (upper limit)

  • REL10POW limits: -10.0 to 80.0dB (lower limit), -10.0 to 80.0dB (upper limit)

Resolution:0.01

Query

same as setting

*RST Setting

  • REL1POW limits: 0.5,1.5

  • REL10POW limits: 8.0,12.0

Requirements

Test Application Revision: A.01.00 and above

Programming Example

"SETup:TCLPower:STEP10:LIMIT 10.0,30.0"

SETup:TCLPower:STEP[1]|10:LIMit:DB1

Function

Sets/queries the lower and upper limit (in a comma-separated manner) for either REL1POW or REL10POW when the step size is set to 1dB in Active Cell operating mode.

  • For the steps in response to an UP TPC command, the corresponding closed loop power x should be: Lower Limit ≤ x ≤ Upper Limit,

  • For the steps in response to a DOWN TPC command, the corresponding closed loop power x should be: -Upper Limit ≤ x ≤ -Lower Limit.

Setting

Range:

  • REL1POW limits: -10.0 to 40.0dB (lower limit), -10.0 to 40.0dB (upper limit)

  • REL10POW limits: -10.0 to 80.0dB (lower limit), -10.0 to 80.0dB (upper limit)

Resolution:0.01

Query

same as setting

*RST Setting

  • REL1POW limits: 0.5,1.5

  • REL10POW limits: 8.0,12.0

Requirements

Test Application Revision: A.02.00 and above

Programming Example

"SETup:TCLPower:STEP10:LIMit:DB1 10.0,30.0"

SETup:TCLPower:STEP[1]|10:LIMit:DB2

Function

Sets/queries the lower and upper limit (in a comma-separated manner) for either REL1POW or REL10POW when the step size is set to 2dB in Active Cell operating mode.

  • For the steps in response to an UP TPC command, the corresponding closed loop power x should be: Lower Limit ≤ x ≤ Upper Limit,

  • For the steps in response to a DOWN TPC command, the corresponding closed loop power x should be: -Upper Limit ≤ x ≤ -Lower Limit.

Setting

Range:

  • REL1POW limits: -10.0 to 40.0dB (lower limit), -10.0 to 40.0dB (upper limit)

  • REL10POW limits: -10.0 to 80.0dB (lower limit), -10.0 to 80.0dB (upper limit)

Resolution:0.01

Query

same as setting

*RST Setting

  • REL1POW limits: 1.0,3.0

  • REL10POW limits: 16.0,24.0

Requirements

Test Application Revision: A.02.00 and above

Programming Example

"SETup:TCLPower:STEP10:LIMit:DB2 10.0,30.0"

SETup:TCLPower:STEP[1]|10:LIMit:DB3

Function

Sets/queries the lower and upper limit (in a comma-separated manner) for either of the two cases (REL1POW or REL10POW) when the step size is set to 3dB in Active Cell operating mode, so that

  • For the steps in response to an UP TPC command, the corresponding closed loop power x should be: Lower Limit ≤ x ≤ Upper Limit,

  • For the steps in response to a DOWN TPC command, the corresponding closed loop power x should be: -Upper Limit ≤ x ≤ -Lower Limit.

Setting

Range:

  • REL1POW limits: -10.0 to 40.0dB (lower limit), -10.0 to 40.0dB (upper limit)

  • REL10POW limits: -10.0 to 80.0dB (lower limit), -10.0 to 80.0dB (upper limit)

Resolution:0.01

Query

same as setting

*RST Setting

  • REL1POW limits: 1.5,4.5

  • REL10POW limits: 24.0,36.0

Requirements

Test Application Revision: A.02.00 and above

Programming Example

"SETup:TCLPower:STEP10:LIMit:DB3 10.0,30.0"

SETup:TCLPower:TIMeout[:STIMe]

Function | The setting form of this command performs two functions: (1) sets the closed loop power control measurement's timeout value, and (2) sets the measurement's timeout STATe to 1 (on)
Setting | Range: 0.1 to 999.9 seconds Resolution: 0.1 second Unit: S | MS | US | NS (If no units are specified in the command then 'S' is used as the default)
Query | Range: 0.1 to 999.9 seconds
*RST Setting | 10 seconds,off
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "SETup:TCLPower:TIMeout:STIMe 5 S"

SETup:TCLPower:TIMeout:STATe

Function | Sets/queries the closed loop power control measurement's timeout (see Measurement Timeouts ) state
Setting | Range: 1|ON|0|OFF
Query | Range: 1|0
*RST Setting | 0 (off)
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "SETUP:TCLPOWER:TIMEOUT:STATE ON"

SETup:TCLPower:TIMeout:TIME

Function | Sets/queries the closed loop power control measurement's timeout setting to be used when the timeout state is set to ON.
Setting | Range: 0.1 to 999.9 seconds Resolution: 0.1 second Unit: S | MS | US | NS (If no units are specified in the command then 'S' is used as the default)
Query | Range: 0.1 to 999.9 seconds
*RST Setting | 10 seconds
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "SETup:TCLPower:TIMeout:TIMe 5 S"

SETup:TCLPower:TRIGger:DELay

Function | Sets/queries the Trigger Delay setting of the closed loop power control measurement.
Setting | Range: -10 to 10 ms Resolution: 0.1 us
Query | Range: -10 to 10 ms Resolution: 0.1 us
*RST Setting | 0ms
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "SETup:TCLPower:TRIGger:DELay 1 MS"

SETup:TCLPower:TRIGger:SOURce

Function | Sets/queries the Trigger Source of the closed loop power control measurement.
Setting | Range: RISE | EXTernal | PROTocol
Query | Range: RISE | EXT | PROT
*RST Setting | PROT
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "SETup:TCLPower:TRIGger:SOURce PROTocol"


SETup:TCPower

  • SETup:TCPower:CONTinuous

  • SETup:TCPower:COUNt[:SNUMber]

  • SETup:TCPower:COUNt:NUMBer

  • SETup:TCPower:COUNt:STATe

  • SETup:TCPower:FILTer[:RRC]

  • SETup:TCPower:TIMeout[:STIMe]

  • SETup:TCPower:TIMeout:STATe

  • SETup:TCPower:TIMeout:TIME

  • SETup:TCPower:TRIGger:SOURce

  • SETup:TCPower:TRIGger:DELay

For more information on the GPIB Command conventions, see GPIB Command conventions.

For the channel power measurement, see Channel Power Measurement.

SETup:TCPower:CONTinuous

Function | Sets/queries the trigger arm state for the channel power measurement. The trigger arm state determines whether the channel power measurement will be made once then stop (0|OFF (single)), or automatically re-arm upon completion of one measurement and repeat the process (1|ON (continuous)).
Setting | Range:1|ON|0|OFF
Query | Range:1|0
*RST Setting | 0 (off)
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "SETUP:TCPOWER:CONTINUOUS OFF"

SETup:TCPower:COUNt[:SNUMber]

Function

The setting form of this command performs two functions: (1) sets the number of channel power measurements to be made in a multi-measurement, and (2) sets the multi-measurement STATe command to 1 (on).

The query form returns the number of channel power multi-measurements to be made when multi-measurement state is ON.

Setting

Range:1 to 999

Query

Range:1 to 999

*RST Setting

Off (10 when STATe = On)

Requirements

Test Application Revision: A.01.00 and above

Programming Example

"SETUP:TCPOWER:COUNT:SNUMBER 5"

SETup:TCPower:COUNt:NUMBer

Function | Sets/queries the number of channel power measurements to be made when the multi-measurement state is ON.
Setting | Range:1 to 999
Query | Range:1 to 999
*RST Setting | 10
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "SETUP:TCPOWER:COUNT:NUMBER 5"

SETup:TCPower:COUNt:STATe

Function | Sets/queries the channel power multi-measurement state.
Setting | Range:1|ON|0|OFF
Query | Range:1|0
*RST Setting | 0 (off)
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "SETUP:TCPOWER:COUNT:STATE ON"

SETup:TCPower:FILTer[:RRC]

Function | Sets/queries the state of the root-raised cosine (RRC) filter.
Setting | Range:1|ON|0|OFF
Query | Range:1|0
*RST Setting | 0 (off)
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "SETUP:TCPOWER:FILTER:RRC ON"

SETup:TCPower:TIMeout[:STIMe]

Function | The setting form of this command performs two functions: (1) sets the channel power measurement's timeout value, and (2) sets the channel power measurement's timeout STATe to 1 (on). The query form returns the channel power measurement's timeout value.
Setting | Range:0.1 to 999.9 seconds Resolution: 0.1 second Unit: S | MS | US | NS
Query | Range:0.1 to 999.9
*RST Setting | 10 seconds, on
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "SETUP:TCPOWER:TIMEOUT:STIME 5 S"

SETup:TCPower:TIMeout:STATe

Function | Sets/queries the channel power measurement's timeout state.
Setting | Range:1|ON|0|OFF
Query | Range:1|0
*RST Setting | 0 (off)
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "SETUP:TCPOWER:TIMEOUT:STATE ON"

SETup:TCPower:TIMeout:TIME

Function | Sets/queries the channel power measurement's timeout setting to be used when the timeout state is set to ON.
Setting | Range: 0.1 to 999.9 seconds Resolution: 0.1 second Unit: S | MS | US | NS
Query | Range: 0.1 to 999.9
*RST Setting | 10 seconds
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "SETUP:TCPOWER:TIMEOUT:TIME 5 S"

SETup:TCPower:TRIGger:SOURce

Function | Sets/queries the channel power measurement's Trigger Source .
Setting | Range: AUTO | IMMediate | RISE |EXTernal | PROTocol
Query | AUTO | IMM | RISE |EXT| PROT
*RST Setting | AUTO
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "SETUP:TCPOWER:TRIGGER:SOURCE IMMEDIATE"

SETup:TCPower:TRIGger:DELay

Function | Sets/queries the channel power measurement's Trigger Delay setting.
Setting | Range:-10 to 10 ms Resolution: 0.1 usec Unit: S | MS | US | NS
Query | Same as setting
*RST Setting | 0 seconds
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "SETUP:TCPOWER:TRIGGER:DELAY 1MS"


SETup:TDPower

  • SETup:TDPower:FILTer[:RRC]

  • SETup:TDPower:INITial:POWer

  • SETup:TDPower:NSTep:MEASure

  • SETup:TDPower:NSTep:TRIGger

  • SETup:TDPower:SYNChronize:MODE

  • SETup:TDPower:TIMeout[:STIMe]

  • SETup:TDPower:TIMeout:TIME

  • SETup:TDPower:TIMeout:STATe

  • SETup:TDPower:TRIGger:SOURce

  • SETup:TDPower:TRIGger:DELay

For more information on the GPIB Command conventions, see GPIB Command conventions

For the measurement, see Dynamic Power (DPOW) Measurement.

SETup:TDPower:FILTer[:RRC]

Function | Sets/queries the state of the root-raised cosine (RRC) filter. If the setting is OFF, the measured results will be the mean Power, else the results will be the RRC filtered mean power.
Setting | Range: 1|ON|0|OFF
Query | Range: 1|ON|0|OFF
*RST Setting | 0|OFF
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "SETup:TDPower:FILTer ON"

SETup:TDPower:INITial:POWer

Function | Sets/queries the expected initial step power in the measurement sequence.
Setting | Range: -80 to +40dbm
Query | Range: -80 to +40dbm
*RST Setting | 0
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "SETup:TDPower:INITial:POWer 0"

SETup:TDPower:NSTep:MEASure

Function | Sets/queries the number of the measurement steps.
Setting | Range: 1 to 300
Query | Range: 1 to 300
*RST Setting | 100
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "SETup:TDPower:NSTep:MEASure 200"

SETup:TDPower:NSTep:TRIGger

Function | Sets/queries the number of the trigger steps.
Setting | Range: 0 to 10
Query | Range: 0 to 10
*RST Setting | 0
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "SETup:TDPower:NSTep:TRIGger 5"

SETup:TDPower:SYNChronize:MODE

Function | Sets whether midamble synchronization is used during the dynamic power measurement.
Setting | Range: MIDamble | NONE
Query | MID | NONE
*RST Setting | MID
Requirements | Test Application Revision: A.03.00 and above
Programming Example | "SETup:TDPower:SYNChronize:MODE MID"

SETup:TDPower:TIMeout[:STIMe]

Function | The setting form of this command performs two functions: (1) sets the dynamic power measurement's timeout value, and (2) sets the dynamic power measurement's timeout state to 1 (ON). The query form returns the dynamic power measurement's timeout value.
Setting | Range: 0.1 to 999.9 seconds Unit: S | MS | US | NS
Query | Range: 0.1 to 999.9
*RST Setting | 10 s, on
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "SETup:TDPower:TIMeout:STIMe 5S"

SETup:TDPower:TIMeout:TIME

Function | Sets/queries the dynamic power measurement's timeout.
Setting | Range: 0.1 to 999.9 seconds Unit: S | MS | US | NS
Query | Range: 0.1 to 999.9
*RST Setting | 10 s
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "SETup:TDPower:TIMeout:TIME 5S"

SETup:TDPower:TIMeout:STATe

Function | Sets/Queries the dynamic power measurement's timeout state.
Setting | Range: 1|ON|0|OFF
Query | Range: 1|0
*RST Setting | 0(OFF)
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "SETup:TDPower:TIMeout:STATe ON"

SETup:TDPower:TRIGger:SOURce

Function | Sets/queries the dynamic power measurement's trigger source. The setting only applies for the first burst of the measurement, the following bursts are triggered by protocal.
Setting | Range: RISE | EXTernal | PROTocol
Query | Range: RISE |EXT| PROT
*RST Setting | RISE
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "SETUP:TDPower:TRIGGER:SOURCE RISE"

SETup:TDPower:TRIGger:DELay

Function | Sets/queries the dynamic power measurement's trigger delay setting.
Setting | Range:-25 to 25 ms Resolution: 0.1 us Unit: S | MS | US | NS
Query | Same as setting
*RST Setting | 0 ms
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "SETup:TDPower:TRIGger:DELay 0MS"


SETup:TFDTune

Last updated: March 10, 2010

  • SETup:TFDTune:MS:RX:FREQuency:STEP[:VALues]

  • SETup:TFDTune:MS:RX:FREQuency:STEP:COUNt

  • SETup:TFDTune:MS:RX:FREQuency:STEP:STARt[:INDex]

  • SETup:TFDTune:MS:RX:POWer:STEP[:LEVels]

  • SETup:TFDTune:MS:RX:POWer:STEP:COUNt

  • SETup:TFDTune:MS:RX:POWer:STEP:LENGth

  • SETup:TFDTune:MS:RX:POWer:STEP:STARt[:INDex]

  • SETup:TFDTune:MS:TX:FREQuency:STEP[:VALues]

  • SETup:TFDTune:MS:TX:FREQuency:STEP:COUNt

  • SETup:TFDTune:MS:TX:FREQuency:STEP:STARt[:INDex]

  • SETup:TFDTune:MS:TX:POWer:STEP[:LEVels]

  • SETup:TFDTune:MS:TX:POWer:STEP:COUNt

  • SETup:TFDTune:MS:TX:POWer:STEP:STARt[:INDex]

  • SETup:TFDTune:TIMeout[:STIMe]

  • SETup:TFDTune:TIMeout:STATe

  • SETup:TFDTune:TIMeout:TIME

For more information on the GPIB Command conventions, see GPIB Command conventions

SETup:TFDTune:MS:RX:FREQuency:STEP[:VALues]

Function | Sets/queries the MS RX Frequency Step Values. You can set up to 40 values as the MS Rx Frequency step. Which Frequency step levels are to be actually used for the measurement are also defined by Frequency Start Index and Number of Frequency Step. The test set allows you to set the frequency across different bands (see Channel).
Setting | Range: 1880.0 to 1920.0, 2010.0 to 2025.0 MHz Resolution: 0.01 Hz
Query | Same as setting
*RST Setting | 1880.8, 1900.0, 1919.2, 2010.8, 2024.2, [2023.8 to 011.0 (step= -1.6)], [1919.2 to 1880.0 (step = -1.6)], 2017.4
Requirements | Test Application Revision: A.04.00 and above
Programming Example | "SETup:TFDTune:MS:RX:FREQuency:STEP 1880.8, 1900.0, 1919.2, 2010.8, 2024.2, 2017.4"

SETup:TFDTune:MS:RX:FREQuency:STEP:COUNt

Function | Sets/queries the Number of Rx Frequency Steps.
Setting | Range: 1 to 40 Resolution: 1
Query | Range: 1 to 40
*RST Setting | 5
Requirements | Test Application Revision: A.04.00 and above
Programming Example | "SETup:TFDTune:MS:RX:FREQuency:STEP:COUNt 5"

SETup:TFDTune:MS:RX:FREQuency:STEP:STARt[:INDex]

Function | Sets/queries the Rx Frequency Start Index.
Setting | Range: 0 to 39 Resolution: 1
Query | Range: 0 to 39
*RST Setting | 0
Requirements | Test Application Revision: A.04.00 and above
Programming Example | "SETup:TFDTune:MS:RX:FREQuency:STEP:STARt 0"

SETup:TFDTune:MS:RX:POWer:STEP[:LEVels]

Function | Sets/queries the MS RX Power Step Levels. You can set up to 40 values as the MS Rx Power step. Which power step levels are to be actually used for the measurement are also defined by MS RX Power Start Index and Number of MS RX Power Step.
Setting | Range: +37 to -165. Resolution: 0.01
Query | Range: +37 to -165
*RST Setting | -105.0, -95.0, -85.0, -75.0, -65.0, -55.0, -45.0, -35.0, -25.0, -15.0, -20.0, -30.0, -40.0, -50.0, -60.0, -70.0, -80.0, -90.0, -100.0 , -97.5, -92.5, -87.5, -82.5, -77.5, -72.5, -67.5, -62.5, -57.5, -52.5, -47.5, -42.5, -37.5, -32.5, -27.5, -22.5, -17.5, -19.0, -29.0, -39.0, -49.0
Requirements | Test Application Revision: A.04.00 and above
Programming Example | "SETup:TFDTune:MS:RX:POWer:STEP -105.0, -95.0, -85.0, -75.0, -65.0, -55.0, -45.0, -35.0, -25.0, -15.0, -20.0, -30.0, -40.0, -50.0, -60.0, -70.0, -80.0, -90.0, -100.0 , -97.5, -92.5, -87.5, -82.5, -77.5, -72.5, -67.5, -62.5, -57.5, -52.5, -47.5, -42.5, -37.5, -32.5, -27.5, -22.5, -17.5, -19.0, -29.0, -39.0, -49.0"

SETup:TFDTune:MS:RX:POWer:STEP:COUNt

Function | Sets/queries the Number of MS Rx Power Steps .
Setting | Range: 1 to 40 Resolution: 1
Query | Same as setting
*RST Setting | 10
Requirements | Test Application Revision: A.04.00 and above
Programming Example | "SETup:TFDTune:MS:RX:POWer:STEP:COUNt 10"

SETup:TFDTune:MS:RX:POWer:STEP:LENGth

Function | Sets/queries the Rx Power Step Length. The unit is Subframe (5ms).
Setting | Range: 1 to 10 Resolution: 1
Query | Range: 1 to 10
*RST Setting | 1
Requirements | Test Application Revision: A.04.00 and above
Programming Example | "SETup:TFDTune:MS:RX:POWer:STEP:LENGth 1"

SETup:TFDTune:MS:RX:POWer:STEP:STARt[:INDex]

Function | Sets/queries the MS RX Frequency Step Start Index .
Setting | Range: 0 to 39 Resolution: 1
Query | Range: 0 to 39
*RST Setting | 0
Requirements | Test Application Revision: A.04.00 and above
Programming Example | "SETup:TFDTune:MS:RX:POWer:STEP:STARt 0"

SETup:TFDTune:MS:TX:FREQuency:STEP[:VALues]

Function | Sets/queries the MS Tx Frequency Step Values. You can set up to 40 values as the MS Tx Frequency step. Which Frequency step levels are to be actually used for the measurement are also defined by Tx Frequency Start Index and Number of MS Tx Frequency Step. The test set allows you to set the frequency across different bands (see Channel).
Setting | Range: 1880.0 to 1920.0, 2010.0 to 2025.0
Query | Range: 1880.0 to 1920.0, 2010.0 to 2025.0
*RST Setting | 1880.8,1900.0,1919.2,2010.8,2024.2,[2023.8 to 2011.0 (step = -1.6], [1919.2 to 1880.0 (step = -1.6)], 2017.4
Requirements | Test Application Revision: A.04.00 and above
Programming Example | "SETup:TFDTune:MS:TX:FREQuency:STEP 1880.8,1900.0,1919.2,2010.8,2024.2, 2017.4"

SETup:TFDTune:MS:TX:FREQuency:STEP:COUNt

Function | Sets/queries the Number of Tx Frequency Steps.
Setting | Range: 1 to 40 Resolution: 1
Query | Range: 1 to 40
*RST Setting | 5
Requirements | Test Application Revision: A.04.00 and above
Programming Example | "SETup:TFDTune:MS:TX:FREQuency:STEP:COUNt 5"

SETup:TFDTune:MS:TX:FREQuency:STEP:STARt[:INDex]

Function | Sets/queries the Tx Frequency Start Index.
Setting | Range: 0 to 39 Resolution: 1
Query | Range: 0 to 39
*RST Setting | 0
Requirements | Test Application Revision: A.04.00 and above
Programming Example | "SETup:TFDTune:MS:TX:FREQuency:STEP:STARt 0"

SETup:TFDTune:MS:TX:POWer:STEP[:LEVels]

Function | Sets/queries the MS TX Power Step Levels. You can set up to 40 values as the MS Tx Power step. Which power step levels are to be actually used for the measurement are also defined by Tx Power Start Index and Number of Tx Power Step.
Setting | Range: +80 to -120 Resolution: 0.01
Query | Range: +80 to -120
*RST Setting | +24.0, +21.0, +15.0, +5.0, -5.0, -15.0, -25.0, -35.0, -45.0, -55.0, -50.0, -40.0, -30.0, -20.0, -10.0, -0.0, +10.0, +20.0, +17.5, +12.5, +7.5, +2.5, -2.5, -7.5, -12.5, -17.5, -22.5, -27.5, -32.5, -37.5, -42.5, -47.5, -52.5, -49.0, -39.0, -29.0, -19.0, -9.0, 1.0, 11.0
Requirements | Test Application Revision: A.04.00 and above
Programming Example | "SETup:TFDTune:MS:TX:POWer:STEP +24.0, +21.0, +15.0, +5.0, -5.0, -15.0, -25.0, -35.0, -45.0, -55.0, -50.0, -40.0, -30.0, -20.0, -10.0, -0.0, +10.0, +20.0, +17.5, +12.5, +7.5, +2.5, -2.5, -7.5, -12.5, -17.5, -22.5, -27.5, -32.5, -37.5, -42.5, -47.5, -52.5, -49.0, -39.0, -29.0, -19.0, -9.0, 1.0, 11.0"

SETup:TFDTune:MS:TX:POWer:STEP:COUNt

Function | Sets/queries the Number of Tx Power Steps .
Setting | Range: 1 to 40 Resolution: 1
Query | Same as setting
*RST Setting | 10
Requirements | Test Application Revision: A.04.00 and above
Programming Example | "SETup:TFDTune:MS:TX:POWer:STEP:COUNt 10"

SETup:TFDTune:MS:TX:POWer:STEP:STARt[:INDex]

Function | Sets/queries the MS TX Frequency Step Start Index .
Setting | Range: 0 to 39 Resolution: 1
Query | Range: 0 to 39 Resolution: 1
*RST Setting | 0
Requirements | Test Application Revision: A.04.00 and above
Programming Example | "SETup:TFDTune:MS:TX:POWer:STEP:STARt 1"

SETup:TFDTune:TIMeout[:STIMe]

Function | The setting form of this command performs two functions: (1) sets the Fast Device Tune measurement's timeout (see Measurement Timeouts ) value, and (2) sets the Fast Device Tune measurement's timeout state to 1 (on). The query form returns the Fast Device Tune measurement's timeout value.
Setting | Range: 0.1 to 999.9 seconds Resolution: 0.1 second
Query | Range: 0.1 to 999.9
*RST Setting | 10 seconds, off
Requirements | Test Application Revision: A.04.00 and above
Programming Example | "SETup:TFDTune:TIMeout 5s"

SETup:TFDTune:TIMeout:STATe

Function | Sets/queries Fast Device Tune measurement's timeout state (see Measurement Timeout).
Setting | Range: 1|ON|0|OFF
Query | Range: 1|0
*RST Setting | 0 (off)
Requirements | Test Application Revision: A.04.00 and above
Programming Example | "SETup:TFDTune:TIMeout:STATe ON"

SETup:TFDTune:TIMeout:TIME

Function | Sets/queries Fast Device Tune measurement's timeout (see Measurement Timeout) setting to be used when the timeout state is set to ON.
Setting | Range: 0.1 to 999.9 seconds Resolution: 0.1 second
Query | Range: 0.1 to 999.9
*RST Setting | 10 seconds
Requirements | Test Application Revision: A.04.00 and above
Programming Example | "SETup:TFDTune:TIMeout:TIME 5S"


SETup:THBLerror

Last updated: March 10, 2010

  • SETup:THBLerror:CONTinuous

  • SETup:THBLerror:COUNt

  • SETup:THBLerror:TIMeout[:STIMe]

  • SETup:THBLerror:TIMeout:STATe

  • SETup:THBLerror:TIMeout:TIME

For more information on the GPIB Command conventions, see GPIB Command conventions.

For the measurement, see HSDPA Block Error Ratio (HBLER) Measurement.

SETup:THBLerror:CONTinuous

Function | Sets/queries the trigger arm state for the measurement. The trigger arm state determines whether the measurement will be made once then stop (0|OFF (single)), or automatically re-arm upon completion of one measurement and repeat the process (1|ON (continuous)).
Setting | Range: 1|ON|0|OFF
Query | Range: 1|0
*RST Setting | 0 (off)
Requirements | Test Application Revision: A.03.00 and above
Programming Example | "SETup:THBLerror:CONTinuous 0"

SETup:THBLerror:COUNt

Function | Sets/queries the Number of blocks to test .
Setting | Range: 1 to 99,000 blocks Resolution: 1 block
Query | Same as setting
*RST Setting | 1000 blocks
Requirements | Test Application Revision: A.03.00 and above
Programming Example | "SETup:THBLerror:COUNt 1000"

SETup:THBLerror:TIMeout[:STIMe]

Function | The setting form of this command performs two functions: (1) sets the measurement's timeout value, and (2) sets the measurement's timeout state to 1 (on). The query form returns the measurement's timeout value.
Setting | Range: 0.1 to 999.9 seconds Resolution: 0.1 second
Query | Same as setting
*RST Setting | Timeout value: 20 seconds Timeout state: off
Requirements | Test Application Revision: A.03.00 and above
Programming Example | "SETup:THBLerror:TIMeout 5"

SETup:THBLerror:TIMeout:STATe

Function | Sets/queries the measurement's timeout state.
Setting | Range: 1|ON|0|OFF
Query | Range: 1|0
*RST Setting | 0 (off)
Requirements | Test Application Revision: A.03.00 and above
Programming Example | "SETup:THBLerror:TIMeout:STATe 0"

SETup:THBLerror:TIMeout:TIME

Function | Sets/queries the measurement's timeout setting to be used when the timeout state is set to ON.
Setting | Range: 0.1 to 999.9 seconds Resolution: 0.1 second
Query | Same as setting
*RST Setting | 20 seconds
Requirements | Test Application Revision: A.03.00 and above
Programming Example | "SETup:THBLerror:TIMeout:TIME 20"


SETup:THCQuality

Last updated: March 10, 2010

  • SETup:THCQuality:BLERatio:TRANsmit:MCQI

  • SETup:THCQuality:CQIReports[:COUNt]

  • SETup:THCQuality:CQIValues:WRANge

  • SETup:THCQuality:RANGe:FMEDian

  • SETup:THCQuality:TIMeout[:STIMe]

  • SETup:THCQuality:TIMeout:STATe

  • SETup:THCQuality:TIMeout:TIME

  • SETup:THCQuality:TRANsmit:MCQI[:COUNt]

For more information on the GPIB Command conventions, see GPIB Command conventions

SETup:THCQuality:BLERatio:TRANsmit:MCQI

Function | Sets/queries the BLER criteria for transmitted at Median_CQI. If the calculated BLER rate for median CQI is higher than this setting, Report of CQI measurement will fail the UE.
Setting | Range: 0 to 100 % Resolution: 0.01
Query | Same as setting
*RST Setting | 10
Requirements | Test Application Revision: A.04.00 and above
Programming Example | "SETup:THCQuality:BLERatio:TRANsmit:MCQI 10"

SETup:THCQuality:CQIReports[:COUNt]

Function | Sets/queries the Number of CQI Reports to test.
Setting | Range: 1 to 99000 Resolution: 1
Query | Same as setting
*RST Setting | 2000
Requirements | Test Application Revision: A.04.00 and above
Programming Example | "SETup:THCQuality:CQIReports 2000"

SETup:THCQuality:CQIValues:WRANge

Function | Sets/queries the Percentage of CQI values within range.
Setting | Range: 0 to 100 %
Query | Same as setting
*RST Setting | 90 (%)
Requirements | Test Application Revision: A.04.00 and above
Programming Example | "SETup:THCQuality:CQIValues:WRANge 90"

SETup:THCQuality:RANGe:FMEDian

Function | Sets/queries the Permitted CQI range from median
Setting | Range: 0 to 5 Resolution: 1
Query | Same as setting
*RST Setting | 2
Requirements | Test Application Revision: A.04.00 and above
Programming Example | "SETup:THCQuality:RANGe:FMEDian 2"

SETup:THCQuality:TIMeout[:STIMe]

Function | The setting form of this command performs two functions: (1) sets the measurement's timeout value (see Measurement Timeout), and (2) sets the measurement's timeout state to 1 (on). The query form returns the measurement's timeout value.
Setting | Range: 0.1 to 999.9 seconds Resolution: 0.1 second
Query | Same as setting
*RST Setting | Timeout value: 20 seconds Timeout state: off
Requirements | Test Application Revision: A.04.00 and above
Programming Example | "SETup:THCQuality:TIMeout 20"

SETup:THCQuality:TIMeout:STATe

Function | Sets/queries the measurement's timeout state (see Measurement Timeout).
Setting | Range: 1|ON|0|OFF
Query | Range: 1|0
*RST Setting | 0 (off)
Requirements | Test Application Revision: A.04.00 and above
Programming Example | "SETup:THCQuality:TIMeout:STATe 0"

SETup:THCQuality:TIMeout:TIME

Function | Sets/queries the measurement's timeout setting to be used when the timeout state is set to ON (see Measurement Timeout).
Setting | Range: 0.1 to 999.9 seconds Resolution: 0.1 second
Query | Same as setting
*RST Setting | 20 seconds
Requirements | Test Application Revision: A.04.00 and above
Programming Example | "SETup:THCQuality:TIMeout:TIME 20"

SETup:THCQuality:TRANsmit:MCQI[:COUNt]

Function | Sets/queries the Number transmitted at Median CQI to test.
Setting | Range: 1 to 99000 Resolution: 1
Query | Same as setting
*RST Setting | 1000
Requirements | Test Application Revision: A.04.00 and above
Programming Example | "SETup:THCQuality:TRANsmit:MCQI 1000"


SETup:TOBWidth

  • SETup:TOBWidth:COUNt[:SNUMber]

  • SETup:TOBWidth:COUNt:NUMBer

  • SETup:TOBWidth:COUNt:STATe

  • SETup:TOBWidth:CONTinuous

  • SETup:TOBWidth:PERCent

  • SETup:TOBWidth:TIMeout[:STIMe]

  • SETup:TOBWidth:TIMeout:STATe

  • SETup:TOBWidth:TIMeout:TIME

  • SETup:TOBWidth:TRIGger:SOURce

  • SETup:TOBWidth:TRIGger:DELay

For more information on the GPIB Command conventions, see GPIB Command conventions

For the measurement, see Occupied Bandwidth (OBW) Measurement.

SETup:TOBWidth:COUNt[:SNUMber]

Function

The setting form of this command performs two functions: (1) sets the number of occupied bandwidth measurement to be made in a multi-measurement, and (2) sets the multi-measurement state to 1 (ON).

The query form returns the number of occupied bandwidth multi-measurements to be made when multi-measurement state is ON.

Setting

Range: 1 to 999

Query

Range: 1 to 999

*RST Setting

OFF (10 when STATe = ON)

Requirements

Test Application Revision: A.02.00 and above

Programming Example

"SETUP:TOBWidth:COUNT 5"

SETup:TOBWidth:COUNt:NUMBer

Function | Sets/queries the number of occupied bandwidth measurement to be made when the multi-measurement state is ON.
Setting | Range: 1 to 999
Query | Range: 1 to 999
*RST Setting | 10
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "SETUP:TOBWidth:COUNT:NUMBER 5"

SETup:TOBWidth:COUNt:STATe

Function | Sets/queries the occupied bandwidth multi-measurement state.
Setting | Range: 1|ON|0|OFF
Query | Range: 1|0
*RST Setting | 0 (OFF)
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "SETup:TOBWidth:COUNt:STATe ON"

SETup:TOBWidth:CONTinuous

Function | Sets/queries the trigger arm state for the occupied bandwidth measurement. The trigger arm state determines whether the occupied bandwidth measurement will be made once then stop (0|OFF (single)), or automatically re-arm upon completion of one measurement and repeat the process (1|ON (continuous)).
Setting | Range: 1|ON|0|OFF
Query | Range: 1|0
*RST Setting | 0 (OFF)
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "SETup:TOBWidth:CONTinuous OFF"

SETup:TOBWidth:PERCent

Function | Sets/queries the percentage of total power used in the occupied bandwidth measurement. The total power is measured in a 4.8 MHz bandwidth.
Setting | Range: 70.0 to 99.0 percent Resolution: 0.01 percent
Query | Same as setting
*RST Setting | 99
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "SETup:TOBWidth:PERCent 99"

SETup:TOBWidth:TIMeout[:STIMe]

Function | The setting form of this command performs two functions: (1) sets the occupied bandwidth measurement's timeout value, and (2) sets the occupied bandwidth measurement's timeout state to 1 (on). The query form returns the occupied bandwidth measurement's timeout value.
Setting | Range: 0.1 to 999.9 seconds Unit: S | MS | US | NS
Query | Same as setting
*RST Setting | 10 s, on
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "SETup:TOBWidth:TIMeout:STIMe 5S"

SETup:TOBWidth:TIMeout:STATe

Function | Sets/Queries the occupied bandwidth measurement's timeout state.
Setting | Range: 1|ON|0|OFF
Query | Range: 1|0
*RST Setting | 0(OFF)
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "SETup:TOBWidth:TIMeout:STATe ON"

SETup:TOBWidth:TIMeout:TIME

Function | Sets/queries the occupied bandwidth measurement's timeout setting to be used when the timeout state is set to ON..
Setting | Range: 0.1 to 999.9 seconds Resolution: 0.1 second Unit: S | MS | US | NS
Query | Range: 0.1 to 999.9
*RST Setting | 10 s
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "SETup:TOBWidth:TIMeout:TIME 10S"

SETup:TOBWidth:TRIGger:DELay

Function | Sets/queries the occupied bandwidth measurement's trigger delay setting. This setting can be used to delay the measurement trigger in order to start a measurement during a specific timeslot in the frame.
Setting | Range: -10 to 10 ms Resolution: 0.1 us Unit: S | MS | US | NS
Query | Same as setting
*RST Setting | 0 ms
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "SETUP:TOBWidth:TRIGGER:DELAY 0MS"

SETup:TOBWidth:TRIGger:SOURce

Function | Sets/queries the occupied bandwidth measurement's trigger source.
Setting | Range: AUTO | IMMediate | RISE | EXTernal | PROTocol
Query | Range: AUTO | IMM | RISE | EXT | PROT
*RST Setting | AUTO
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "SETUP:TOBWidth:TRIGGER:SOURCE AUTO"


SETup:TOLPower

Last updated: June 12, 2010

  • SETup:TOLPower:LIMit

  • SETup:TOLPower:TIMeout[:STIMe]

  • SETup:TOLPower:TIMeout:STATe

  • SETup:TOLPower:TIMeout:TIME

For more information on the GPIB Command conventions, see GPIB Command conventions

For the measurement, see Open Loop Power Control (OLPC) Measurement

SETup:TOLPower:LIMit

Function | Sets/queries the Initial UpPCH Tx Power Limit for the open loop power control measurement. The result fails if the difference between the measured power and the expected power is larger than this limit.
Setting | Range: 0 to 20 dB Resolution: 0.01
Query | Same as setting
*RST Setting | 9
Requirements | Test Application Revision: A.03.00 and above
Programming Example | "SETup:TOLPower:LIMit 9"

SETup:TOLPower:TIMeout[:STIMe]

Function | The setting form of this command performs two functions: (1) sets the open loop power control measurement's timeout value, and (2) sets the open loop power control measurement's timeout state to 1 (on). The query form returns the open loop power control measurement's timeout value.
Setting | Range: 0.1 to 999.9 seconds Unit: S | MS | US | NS
Query | Same as setting
*RST Setting | 10 s, on
Requirements | Test Application Revision: A.03.00 and above
Programming Example | "SETup:TOLPower:TIMeout 10s"

SETup:TOLPower:TIMeout:STATe

Function | Sets/Queries the open loop power control measurement's timeout state.
Setting | Range: 1|ON|0|OFF
Query | Range: 1|0
*RST Setting | 0(OFF)
Requirements | Test Application Revision: A.03.00 and above
Programming Example | "SETup:TOLPower:TIMeout:STATe ON"

SETup:TOLPower:TIMeout:TIME

Function | Sets/queries the open loop power control measurement's timeout.
Setting | Range: 0.1 to 999.9 seconds Resolution: 0.1 second Unit: S | MS | US | NS
Query | Range: 0.1 to 999.9
*RST Setting | 10 s
Requirements | Test Application Revision: A.03.00 and above
Programming Example | "SETup:TOLPower:TIMeout:TIME 5S"


SETup:TOOPower

  • SETup:TOOPower:CONTinuous

  • SETup:TOOPower:COUNt[:SNUMber]

  • SETup:TOOPo wer:COUNt:NUMBer

  • SETup:TOOPower:COUNt:STATe

  • SETup:TOOPower:LIMit

  • SETup:TOOPower:OFFPower:MODE

  • SETup:TOOPower:TIME[:OFFSet]

  • SETup:TOOPower:TIMeout[:STIMe]

  • SETup:TOOPower:TIMeout:STATe

  • SETup:TOOPower:TIMeout:TIME

  • SETup:TOOPower:TRACe[:STATe]

  • SETup:TOOPower:TRIGger:DELay

  • SETup:TOOPower:TRIGger:SOURce

For more information on the GPIB Command conventions, see GPIB Command conventions.

For the measurement, see Transmit ON/OFF Power (TOOP) Measurement.

SETup:TOOPower:CONTinuous

Function | Sets/queries the trigger arm state for the Transmit ON/OFF Power measurement. The trigger arm state determines whether the Transmit ON/OFF Power measurement will be made once then stop (0|OFF (single)), or automatically re-arm upon completion of one measurement and repeat the process (1|ON (continuous)).
Setting | Range: 1|ON|0|OFF
Query | Range: 1|0
*RST Setting | 0 (OFF)
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "SETUP:TOOPower:CONTINUOUS OFF"

SETup:TOOPower:COUNt[:SNUMber]

Function

The setting form of this command performs two functions: (1) sets the number of Transmit ON/OFF Power measurements to be made in a multi-measurement, and (2) sets the multi-measurement STATe command to 1 (on).

The query form returns the number of Transmit ON/OFF power measurements to be made when multi-measurement state is ON.

Setting

Range:1 to 999

Query

Range:1 to 999

*RST Setting

OFF (10 when STATe = ON)

Requirements

Test Application Revision: A.02.00 and above

Programming Example

"SETup:TOOPower:COUNt 5"

SETup:TOOPower:COUNt:NUMBer

Function | Sets/queries the number of Transmit ON/OFF power measurement to be made when the multi-measurement state is set to ON.
Setting | Range: 1 to 999
Query | Range: 1 to 999
*RST Setting | 10
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "SETUP:TOOPower:COUNT:NUMBER 5"

SETup:TOOPower:COUNt:STATe

Function | Sets/queries the Transmit ON/OFF Power multi-measurement state.
Setting | Range: 1|ON|0|OFF
Query | Range: 1|0
*RST Setting | 0 (OFF)
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "SETup:TOOPower:COUNt:STATe ON"

SETup:TOOPower:LIMit

Function

Sets/queries the OFF power mask limits for each range. There are three parameters (separated by comma) for this command, representing the mask limit for Range1, Range 2, Range 3 respectively.

Setting

For each of the three parameters:

  • Range: -80 to +30 dBm

  • Resolution:0.01

Query

Same as setting

*RST Setting

-65.0,-50.0,-65.0

Requirements

Test Application Revision: A.02.00 and above

Programming Example

"SETup:TOOPower:LIMit -65.0,-50.0,-65.0"

SETup:TOOPower:OFFPower:MODE

Function

Sets/queries the way to get the power result of the three ranges. This parameter can be set to either Average or Worst. If it is set to Average, the power result for each range is the average chip power of the range; If it is set to Worst, the power result for each range is the highest chip power in the range.

Note: If the highest power of the mobile phone can reach as much as -65 dBm, It is recommended that you use Average as the OFF power mode. Otherwise the measurement may be easily to fail.

Setting

Range: AVERage |WORSt

Query

Range: AVER|WORS

*RST Setting

AVERage

Requirements

Test Application Revision: A.02.00 and above

Programming Example

"SETup:TOOPower:OFFPower:MODE AVERage"

SETup:TOOPower:TIME[:OFFSet]

Function

Sets/queries the measurement offsets. These offsets determine which chip results will be retrieve by FETCh:TOOPower:TIME:POWer?. Up to 12 offsets are set/returned in the form of an array (separated by comma).

Setting

An array of up to 12 offset values separated by comma. For each of the offsets:

  • Range: -864 to 1711

  • Resolution: 1 (chip)

Query

Same as setting

*RST Setting

-160,-100,-34,-33,-14,-1,0,847,848,860,1200,1711

Requirements

Test Application Revision: A.02.00 and above

Programming Example

"SETup:TOOPower:TIME:OFFSet -160,-100,-34,-33,-14,-1,0,847,848,860,1200,1711"

SETup:TOOPower:TIMeout[:STIMe]

Function | The setting form of this command performs two functions: (1) sets the Transmit ON/OFF Power measurement's timeout value, and (2) sets the Transmit ON/OFF Power measurement's timeout state to 1 (on). The query form returns the Transmit ON/OFF Power measurement's timeout value.
Setting | Range: 0.1 to 999.9 seconds Resolution: 0.1 second Unit: S | MS | US | NS
Query | Range: 0.1 to 999.9
*RST Setting | 10 seconds
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "SETup:TOOPower:TIMeout 5S"

SETup:TOOPower:TIMeout:STATe

Function | Sets/Queries the Transmit ON/OFF Power measurement's timeout state.
Setting | Range: 1|ON|0|OFF
Query | Range: 1|0
*RST Setting | 0(OFF)
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "SETup:TOOPower:TIMeout:STATe ON"

SETup:TOOPower:TIMeout:TIME

Function | Sets/queries the Transmit ON/OFF Power measurement's timeout.
Setting | Range: 0.1 to 999.9 seconds Resolution: 0.1 second Unit: S | MS | US | NS
Query | Range: 0.1 to 999.9
*RST Setting | 10 s
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "SETup:TOOPower:TIMeout:TIME 5S"

SETup:TOOPower:TRACe[:STATe]

Function | Sets/queries whether the whole trace results are available.
Setting | Range: ON | OFF | 0 | 1
Query | Range: 0|1
*RST Setting | OFF
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "SETup:TOOPower:TRACe ON"

SETup:TOOPower:TRIGger:DELay

Function | Sets/queries the Transmit ON/OFF Power measurement's trigger delay setting.
Setting | Range:-10 to 10 ms Resolution: 0.1 us Unit: S | MS | US | NS
Query | Same as setting
*RST Setting | 0 s
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "SETUP:TOOPower:TRIGGER:DELAY 0MS"

SETup:TOOPower:TRIGger:SOURce

Function | Sets/queries the Transmit ON/OFF Power measurement's Trigger Source.
Setting | Range: AUTO | IMMediate | RISE |EXTernal | PROTocol
Query | Range: AUTO | IMM | RISE |EXT| PROT
*RST Setting | AUTO
Requirements | Test Application Revision: A.02.00 and above
Programming Example | "SETUP:TOOPower:TRIGGER:SOURCE AUTO"


SETup:TOOSynch

Last updated: March 10, 2010

  • SETup:TOOSynch:INTerval:AB

  • SETup:TOOSynch:INTerval:CD

  • SETup:TOOSynch:INTerval:DE

  • SETup:TOOSynch:RATio:AB

  • SETup:TOOSynch:RATio:BD

  • SETup:TOOSynch:RATio:DE

  • SETup:TOOSynch:RATio:E

  • SETup:TOOSynch:TIMeout:[STIMe]

  • SETup:TOOSynch:TIMeout:STATe

  • SETup:TOOSynch:TIMeout:TIME

  • SETup:TOOSynch:TRANsmission:MODE

  • SETup:TOOSynch:TRIGger:OUTPut:SUBFrames

For more information on the GPIB Command conventions, see GPIB Command conventions

See Out-of-Synchronization of Output Power (OOS) Measurement for the measurement description.

SETup:TOOSynch:INTerval:AB

Function | Sets/queries Segment Ta-b Interval.
Setting | Range: 40 to 5000 ms Resolution: 40 ms
Query | Same as setting
*RST Setting | 5000 ms
Requirements | Test Application Revision: A.04.00 and above
Programming Example | "SETup:TOOSynch:INTerval:AB 5000 ms"

SETup:TOOSynch:INTerval:CD

Function | Sets/queries Segment Tc-d Interval.
Setting | Range: 40 to 5000 ms Resolution: 40 ms
Query | Same as setting
*RST Setting | 5000 ms
Requirements | Test Application Revision: A.04.00 and above
Programming Example | "SETup:TOOSynch:INTerval:CD 5000 ms"

SETup:TOOSynch:INTerval:DE

Function | Sets/queries Segment Td-e Interval.
Setting | Range: 40 to 5000 ms Resolution: 40 ms
Query | Same as setting
*RST Setting | 5000 ms
Requirements | Test Application Revision: A.04.00 and above
Programming Example | "SETup:TOOSynch:INTerval:DE 5000 ms"

SETup:TOOSynch:RATio:AB

Function | Sets/queries DPCH Quality Ratio A-B.
Setting | Range: -20 to 0 dB Resolution: 0.1
Query | Same as setting
*RST Setting | -6 dB
Requirements | Test Application Revision: A.04.00 and above
Programming Example | "SETup:TOOSynch:RATio:AB -6"

SETup:TOOSynch:RATio:BD

Function | Sets/queries DPCH Quality Ratio B-D.
Setting | Range: -20 to 0 dB Resolution: 0.1
Query | Same as setting
*RST Setting | -16 dB
Requirements | Test Application Revision: A.04.00 and above
Programming Example | "SETup:TOOSynch:RATio:BD -16"

SETup:TOOSynch:RATio:DE

Function | Sets/queries DPCH Quality Ratio D-E.
Setting | Range: -20 to 0 dB Resolution: 0.1
Query | Same as setting
*RST Setting | -14 dB
Requirements | Test Application Revision: A.04.00 and above
Programming Example | "SETup:TOOSynch:RATio:DE -14"

SETup:TOOSynch:RATio:E

Function | Sets/queries DPCH Quality Ratio E+.
Setting | Range: -20 to 0 dB Resolution: 0.1
Query | Same as setting
*RST Setting | -3 dB
Requirements | Test Application Revision: A.04.00 and above
Programming Example | "SETup:TOOSynch:RATio:E -3"

SETup:TOOSynch:TIMeout:[STIMe]

Function | The setting form of this command performs two functions: (1) sets the measurement's timeout (see Measurement Timeout) value, and (2) sets the measurement's timeout STATe to 1 (on). The query form returns the measurement's timeout value.
Setting | Range: 0.1 to 999.9 seconds Resolution: 0.1 second
Query | Same as setting
*RST Setting | 20 seconds, (off)
Requirements | Test Application Revision: A.04.00 and above
Programming Example | "SETup:TOOSynch:TIMeout 5"

SETup:TOOSynch:TIMeout:STATe

Function | Sets/queries the measurement's timeout state (see Measurement Timeout)
Setting | Range: 1|ON|0|OFF
Query | Range: 1|0
*RST Setting | 0 (off)
Requirements | Test Application Revision: A.04.00 and above
Programming Example | "SETup:TOOSynch:TIMeout:STATe 0"

SETup:TOOSynch:TIMeout:TIME

Function | Sets/queries the measurement's timeout setting to be used when the timeout state is set to ON (see Measurement Timeout).
Setting | Range: 0.1 to 999.9 seconds Resolution: 0.1 second
Query | Same as setting
*RST Setting | 20 seconds
Requirements | Test Application Revision: A.04.00 and above
Programming Example | "SETup:TOOSynch:TIMeout:TIME 20"

SETup:TOOSynch:TRANsmission:MODE

Function | Sets/queries the link transmission mode (see Transmission Mode).
Setting | Range: Continue/Discontinue
Query | Same as setting
*RST Setting | Continue
Requirements | Test Application Revision: A.05.00 and above
Programming Example | "SETup:TOOSynch:TRANsmission:MODE Continue"

SETup:TOOSynch:TRIGger:OUTPut:SUBFrames

Function

Sets/queries the OOS trigger to be routed to the rear panel TRIG OUT.

The test set provides two trigger modes:

  • One trigger: The test set generates one short trigger at point A. This option may need the external spectrum analyzer to measure a little long time as the total OOS measurement normally costs more than 15 seconds. Considering the spectrum analyzer's capability, if the measurement interval is bigger than one timeslot, some bursts may be missed;

  • Multiple triggers: The test set generates triggers every subframe from point A to point F. If your spectrum analyzer is able to measure the burst with “gate”, then this option is helpful. As most spectrum analyzers are not real-time, trigger missing may be occurred when this kind of trigger is used.

This setting is GPIB only.

Setting

Range: ONE | MULTiple

Query

Range: ONE | MULT

*RST Setting

ONE

Requirements

Test Application Revision: A.04.00 and above

Programming Example

"SETup:TOOSynch:TRIGger:OUTPut:SUBFrames ONE"


SETup:TSEMask

  • SETup:TSEMask:CONTinuous

  • SETup:TSEMask:COUNt[:SNUMber]

  • SETup:TSEMask:COUNt:NUMBer

  • SETup:TSEMask:COUNt:STATe

  • SETup:TSEMask:LIMit

  • SETup:TSEMask:TIMeout[:STIMe]

  • SETup:TSEMask:TIMeout:TIME

  • SETup:TSEMask:TRIGger:SOURce

  • SETup:TSEMask:TRIGger:DELay

For more information on the GPIB Command conventions, see GPIB Command conventions.

For the measurement, see Spectrum Emission Mask (SEM) Measurement.

SETup:TSEMask:CONTinuous

Function | Sets/queries the trigger arm state for the Spectrum Emission Mask measurement. The trigger arm state determines whether the measurement will be made once then stop (0|OFF (single)) or automatically re-arm upon completion of one measurement and repeat the process (1|ON (continuous)).
Setting | Range: 1|ON|0|OFF
Query | Range: 1|0
*RST Setting | 0(Off)
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "SETUP:TSEMASK:CONTINUOUS OFF"

SETup:TSEMask:COUNt[:SNUMber]

Function | Sets/queries the number of the Spectrum Emission Mask measurement to be made in a multi-measurement setup. This command sets the count, and automatically sets the multi-measurement STATe command to 1 (on).
Setting | Range: 1 to 999
Query | Range: 1 to 999
*RST Setting | Off (10 when STATe = On)
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "SETup:TSEMask:COUNt:SNUMber 5"

SETup:TSEMask:COUNt:NUMBer

Function | Sets/queries the number of the Spectrum Emission Mask measurement to be made when multi-measurement state is ON:
Setting | Range: 1 to 999
Query | Range: 1 to 999
*RST Setting | 10
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "SETup:TSEMask:COUNt:NUMber 5"

SETup:TSEMask:COUNt:STATe

Function | Sets/queries the multi-measurement state of Spectrum Emission Mask measurement.
Setting | Range: 1|ON|0|OFF
Query | Range:1|0
*RST Setting | 0 (off)
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "SETUP:TSEMask:COUNT:STATE ON"

SETup:TSEMask:LIMit

Function

Sets/queries the pass/fail limits for the following frequency offsets in the Spectrum Emission Mask measurement:

  • 30 kHz filter ±0.8 MHz

  • 30 kHz filter ±1.8 MHz

  • 30 kHz filter ±2.4 MHz

  • 1 MHz filter ±2.4 MHz

  • 1 MHz filter ±4.0 MHz

Setting

Range:-80 to 10 dBc

Query

Range:-80 to 10 dBc

*RST Setting

  • 30 kHz filter ±0.8 MHz: -35.0 dBc

  • 30 kHz filter ±1.8 MHz: -49.0 dBc

  • 30 kHz filter ±2.4 MHz: -59.2 dBc

  • 1 MHz filter ±2.4 MHz: -44.0 dBc

  • 1 MHz filter ±4.0 MHz: -44.0 dBc

Requirements

Test Application Revision: A.01.00 and above

Programming Example

"SETup:TSEMask:LIMit -35,-49,-59,-44,-44"

SETup:TSEMask:TIMeout[:STIMe]

Function | (1) sets the Spectrum Emission Mask measurement's timeout value, (2) sets the measurement's timeout STATe to 1 (on)
Setting | Range: 0.1 to 999.9 seconds Resolution: 0.1 second
Query | Range: 0.1 to 999.9 seconds
*RST Setting | 10 seconds,off
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "SETup:TSEMask:TIMeout:STIMe 5 S"

SETup:TSEMask:TIMeout:TIME

Function | Sets/queries the Spectrum Emission Mask measurement's timeout setting to be used when the timeout state is set to ON.
Setting | Range: 0.1 to 999.9 seconds Resolution: 0.1 second
Query | Range: 0.1 to 999.9 seconds
*RST Setting | 10 seconds
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "SETup:TSEMask:TIMeout:TIMe 5 S"

SETup:TSEMask:TRIGger:SOURce

Function | Sets/queries the Trigger Source of the Spectrum Emission Mask measurement.
Setting | Range:AUTO | IMMediate | RISE | EXTernal | PROTocol
Query | Range:AUTO | IMM | RISE | EXT | PROT
*RST Setting | AUTO
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "SETup:TSEMask:TRIGger:SOURce IMMEDIATE"

SETup:TSEMask:TRIGger:DELay

Function | Sets/queries the Trigger Delay setting of the Spectrum Emission Mask measurement: This setting can be used to delay the measurement trigger in order to start a measurement during a specific timeslot in the frame.
Setting | Range: -10 to 10 ms Resolution: 0.1 us
Query | Range: -10 to 10 ms Resolution: 0.1 us
*RST Setting | 0ms
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "SETup:TSEMask:TRIGger:DELay 1MS"


SETup:TWQuality

  • SETup:TWQuality:CONTinuous

  • SETup:TWQuality:COUNt[:SNUMber]

  • SETup:TWQuality:COUNt:NUMBer

  • SETup:TWQuality:COUNt:STATe

  • SETup:TWQuality:TIMeout[:STIMe]

  • SETup:TWQuality:TIMeout:STATe

  • SETup:TWQuality:TIMeout:TIME

  • SETup:TWQuality:TRIGger:DELay

  • SETup:TWQuality:TRIGger:SOURce

For more information on the GPIB Command conventions, see GPIB Command conventions

For the waveform quality measurement description, see Waveform Quality Measurement.

SETup:TWQuality:CONTinuous

Function | Sets/queries the trigger arm state for the Waveform Quality measurement. The trigger arm state determines whether the Waveform Quality measurement will be made once then stop (0|OFF (single)), or automatically rearm upon completion of one measurement and repeat the process (1|ON (continuous)).
Setting | Range:1|ON|0|OFF
Query | Range:1|0
*RST Setting | 0 (off)
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "SETup:TWQuality:CONTinuous OFF"

SETup:TWQuality:COUNt[:SNUMber]

Function

The setting form of this command performs two functions: (1) sets the number of Waveform Quality measurements to be made in a multi-measurement, and (2) sets the multi-measurement STATe command to 1 (on).

The query form returns the number of Waveform Quality multi-measurements to be made when multi-measurement state is ON.

Setting

Range:1 to 999

Query

Range:1 to 999

*RST Setting

Off (10 when STATe = On)

Requirements

Test Application Revision: A.01.00 and above

Programming Example

"SETup:TWQuality:COUNt:SNUMber 5"

SETup:TWQuality:COUNt:NUMBer

Function | Sets/queries the number of Waveform Quality measurements to be made when the multi-measurement state is ON.
Setting | Range:1 to 999
Query | Range:1 to 999
*RST Setting | 10
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "SETup:TWQuality:COUNt:NUMBer 10"

SETup:TWQuality:COUNt:STATe

Function | Sets/queries the multi-measurement state of the Waveform Quality measurement.
Setting | Range:1|ON|0|OFF
Query | Range:1|0
*RST Setting | 0 (off)
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "SETup:TWQuality:COUNt:STATe ON"

SETup:TWQuality:TIMeout[:STIMe]

Function | The setting form of this command performs two functions: (1) sets the Waveform Quality measurement's timeout value, and (2) sets theWaveform Quality measurement's timeout STATe to 1 (on). The query form returns the waveform quality measurement's timeout value.
Setting | Range:0.1 to 999.9 seconds Resolution: 0.1 second Unit: S | MS | US | NS
Query | Range:0.1 to 999.9
*RST Setting | 10 seconds, on
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "SETUP:TWQuality:TIMEOUT:STIME 5 S"

SETup:TWQuality:TIMeout:STATe

Function | Sets/queries the Waveform Quality measurement's timeout state.
Setting | Range:1|ON|0|OFF
Query | Range:1|0
*RST Setting | 0 (off)
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "SETUP:TWQuality:TIMEOUT:STATE ON"

SETup:TWQuality:TIMeout:TIME

Function | Sets/queries the Waveform Quality measurement's timeout setting to be used when the timeout state is set to ON.
Setting | Range: 0.1 to 999 seconds Resolution: 1 second Unit: S | MS | US | NS
Query | Range:1 to 999
*RST Setting | 10 seconds
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "SETup:TWQuality:TIMeout:TIME 10 S"

SETup:TWQuality:TRIGger:DELay

Function | Sets/queries the Waveform Quality measurement's Trigger Delay setting.
Setting | Range:-10 to 10 ms Resolution: 0.1 us Unit: S | MS | US | NS
Query | Same as setting
*RST Setting | 0 seconds
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "SETUP:TWQuality:TRIGGER:DELAY 1MS"

SETup:TWQuality:TRIGger:SOURce

Function | Sets/queries the trigger source of the Waveform Quality measurement.
Setting | Range: AUTO | IMMediate | RISE |EXTernal | PROTocol
Query | Range: AUTO | IMM | RISE |EXT| PROT
*RST Setting | AUTO
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "SETup:TWQuality:TRIGger:SOURce AUTO"


SYSTem Subsystem

Description

The SYSTem subsystem collects the functions that are not related to test set performance. Examples include functions for performing general housekeeping and functions related to setting global configurations, such as TIME or CORRection (amplitude offset).

Related Topics

  • SYSTem:APPLication

  • SYSTem:AUDio

  • SYSTem:BEEPer

  • SYSTem:COMMunicate

  • SYSTem:CONFigure

  • SYSTem:CORRection

  • SYSTem:CURRent:TA

  • SYSTem:DATE

  • SYSTem:ERRor?

  • SYSTem:FATal

  • SYSTem:INSTrument

  • SYSTem:LOG

  • SYSTem:MEASurement:RESet

  • SYSTem Preset

  • SYSTem:REGister

  • SYSTem:ROSCillator

  • SYSTem:SYNChronized

  • SYSTem:TIME

  • SYSTem:TZONe

  • SYSTem:UTC


SYSTem:APPLication

  • SYSTem:APPLication[:CURRent][:NAME]?

  • SYSTem:APPLication[:CURRent]:REVision?

  • SYSTem:APPLication:CATalog[:NAME]?

  • SYSTem:APPLication:CATalog[:NAME]:COUNt?

  • SYSTem:APPLication:CATalog:FORMat?

  • SYSTem:APPLication:CATalog:FORMat:COUNt?

  • SYSTem:APPLication:CATalog:LICense?<sp>'<application name>','<revision>'

  • SYSTem:APPLication:CATalog:LICense:APPLication:ALL?

  • SYSTem:APPLication:CATalog:LICense:APPLication:COUNt?

  • SYSTem:APPLication:CATalog:R2Current:COVerage?

  • SYSTem:APPLication:CATalog:R2Current:STATus?

  • SYSTem:APPLication:CATalog:REVision?<sp>'<application name>'

  • SYSTem:APPLication:CATalog:REVision:COUNt?<sp>'<application name>'

  • SYSTem:APPLication:FORMat[:NAME]

  • SYSTem:APPLication:FORMat:LICense?<sp>'<format name>'

  • SYSTem:APPLication:SELect[:NAME]

  • SYSTem:APPLication:SELect:REVision

  • SYSTem:APPLication:SELect:REVision?<sp>'<application name>'

For more information on the GPIB Command conventions, see GPIB Command conventions

SYSTem:APPLication[:CURRent][:NAME]?

Function | Queries the name of the currently running application. To query the revision of the currently running application, see SYSTem:APPLication[:CURRent]:REVision? . To switch applications, see SYSTem:APPLication:SELect[:NAME] and SYSTem:APPLication:SELect:REVision .
Query | Range: see SYSTem:APPLication:SELect[:NAME]
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "SYSTem:APPLication?"

SYSTem:APPLication[:CURRent]:REVision?

Function | Queries the revision of the currently running application. To query the name of the currently running application, see SYSTem:APPLication[:CURRent][:NAME]? . To switch to a different revision of an application, see SYSTem:APPLication:SELect[:NAME] and SYSTem:APPLication:SELect:REVision .
Query | Range: 0 to 20 characters from the set .0123456789aAbBcCdDeEfF, enclosed by double quotes. For example, "A.01.01"
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "SYSTem:APPLication:REVision?"

SYSTem:APPLication:CATalog[:NAME]?

Function | Queries the names of the applications stored on the test set (whether they are licensed or not). This query returns a comma-separated list of double-quoted strings (one for each application stored on the test set).
Query | Range: One or more of the comma-separated strings. Examples can be: "TD-SCDMA_GSM Fast Switch","WCDMA Lab App E".
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "SYSTem:APPLication:CATalog?"

SYSTem:APPLication:CATalog[:NAME]:COUNt?

Function | Queries the total number of applications stored on the test set. To query the names of the applications stored on the test set, see SYSTem:APPLication:CATalog[:NAME]? .
Query | Range: 0 through 30 Resolution: 1
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "SYSTem:APPLication:CATalog:COUNt?"

SYSTem:APPLication:CATalog:FORMat?

Function

Queries the names of the formats in the current application.

This query returns a comma-separated list of double-quoted strings (one for each format in the application).

Query

Range: One or more of the following strings separated by commas -

  • "TD-SCDMA"

  • "GSM/GPRS"

Requirements

Test Application Revision: A.01.00 and above

Programming Example

"SYSTem:APPLication:CATalog:FORMat?"

SYSTem:APPLication:CATalog:FORMat:COUNt?

Function | Queries the number of formats in the current application. To query the names of the formats in the current application, see SYSTem:APPLication:CATalog:FORMat? .
Query | Range: 0 to 30 Resolution: 1
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "SYSTem:APPLication:CATalog:FORMat:COUNt?"

SYSTem:APPLication:CATalog:LICense?<sp>'<application name>','<revision>'

Function

Queries the license status for the specified application/revision. The application/revision does not have to be installed in the test set.

The query must include a parameter for the application name and revision, enclosed by single quotes and separated by a comma. For application names and revisions, see SYSTem:APPLication:CATalog[:NAME]? and SYSTem:APPLication:CATalog:REVision?<sp>'<application name>' . Note that the application name and revision parameters are not case-sensitive.

Query

Range: LIC|NLIC|PART|UNKN

  • "LIC" indicates this is a licensed application/revision.

  • "NLIC" indicates this is not a licensed application/revision.

  • "PART" indicates that not all of the formats in this application/revision are licensed. (To determine the license status of each format, see SYSTem:APPLication:FORMat:LICense?<sp>'<format name>' .)

  • "UNKN" indicates that license status is unknown.

Requirements

Test Application Revision: A.01.00 and above

Programming Example

"SYSTem:APPLication:CATalog:LICense? 'TD-SCDMA_GSM Fast Switch','A.01.04'"

SYSTem:APPLication:CATalog:LICense:APPLication:ALL?

Function

Queries the names of the applications, formats and features that are licensed for the test set. The applications, formats and features do not have to be installed in the test set to be returned by this query.

This query returns a comma-separated list of double-quoted strings (two for each application, one for each format or feature).

To query the number of licensed applications, formats and features for the test set, see SYSTem:APPLication:CATalog:LICense:APPLication:COUNt? .

Query

Range: One or more of the comma-separated strings. Examples would be:

Applications -

"E1960A","GSM Mobile Test"

Formats -

"E1968A-101","GSM TA"

Features -

"E1969A-101","TD-SCDMA Non-Signal"

Requirements

Test Application Revision: A.01.00 and above

Programming Example

"SYSTem:APPLication:CATalog:LICense:APPLication:ALL?"

SYSTem:APPLication:CATalog:LICense:APPLication:COUNt?

Function

Queries the number of applications, formats and features that are licensed for the test set. The applications, formats and features do not have to be installed in the test set to be included in the query result.

To query the names of the licensed applications, formats and features for the test set, see SYSTem:APPLication:CATalog:LICense:APPLication:ALL? .

Query

Range: 0 to 300

Resolution: 1

Requirements

Test Application Revision: A.01.00 and above

Programming Example

"SYSTem:APPLication:CATalog:LICense:APPLication:COUNt?"

SYSTem:APPLication:CATalog:R2Current:COVerage?

Function | Queries the coverage date of the installed R2C license.
Query | Range: three comma-separated values with the format <year>, <month>, <day>.
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "SYSTem:APPLication:CATalog:R2Current:COVerage?"

SYSTem:APPLication:CATalog:R2Current:STATus?

Function | Queries the R2C license status.
Query | Range: LIC | NLIC | PART
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "SYSTem:APPLication:CATalog:R2Current:STATus?"

SYSTem:APPLication:CATalog:REVision?<sp>'<application name>'

Function

Queries the revisions stored on the test set for the specified application.

The query must include a parameter for the application name enclosed by single quotes. For application names, see SYSTem:APPLication:CATalog[:NAME]? . Note that the application name parameter is not case-sensitive.

This query returns a comma-separated list of double-quoted strings (one for each revision of the application).

Note, if you have several revisions of the application stored on the test set, you may need to increase your GPIB controller's timeout time to avoid a timeout condition.

To query the number of revisions stored on the test set for the specified application, see SYSTem:APPLication:CATalog:REVision:COUNt?<sp>'<application name>' .

To switch to a different revision of an application, see SYSTem:APPLication:SELect[:NAME] and SYSTem:APPLication:SELect:REVision .

Query

Range: Comma-separated list of 0 to 20 characters from the set .0123456789aAbBcCdDeEfF, enclosed by double quotes. For example, "A.01.01","A.02.01"

Requirements

Test Application Revision: A.01.00 and above

Programming Example

"SYSTem:APPLication:CATalog:REVision? 'TD-SCDMA_GSM FAST SWITCH'"

SYSTem:APPLication:CATalog:REVision:COUNt?<sp>'<application name>'

Function

Queries the number of revisions stored on the test set for the specified application.

The query must include a parameter for the application name enclosed by single quotes. For application names, see SYSTem:APPLication:CATalog[:NAME]? . Note that the application name parameter is not case-sensitive.

To query the revision numbers stored on the test set for the specified application, see SYSTem:APPLication:CATalog:REVision?<sp>'<application name>' .

Query

Range: 0 to 30

Requirements

Test Application Revision: A.01.00 and above

Programming Example

"SYSTem:APPLication:CATalog:REVision:COUNt? 'TD-SCDMA_GSM FAST SWITCH'"

SYSTem:APPLication:FORMat[:NAME]

Function

Switches to the specified format (in the current application). Only fast switching applications include more than one format. To determine what formats are available in the current application, see SYSTem:APPLication:CATalog:FORMat? . To determine the license status of a format, see SYSTem:APPLication:FORMat:LICense?<sp>'<format name>' .

Queries the name of the currently active format in the current application.

Setting

Range:

  • "TD-SCDMA"

  • "GSM/GPRS"

Query

same as setting

Note: The query result is returned within a pair of double quotation marks. For example, if the current application is GSM/GPRS, the test set returns "GSM/GPRS" .

Requirements

Test Application Revision: A.01.00 and above

Programming Example

"SYST:APPL:FORM 'TD-SCDMA'"

"SYST:APPL:FORM?"

SYSTem:APPLication:FORMat:LICense?<sp>'<format name>'

Function

Queries the license status of the specified format in the current application.

The query must include a parameter for the format name enclosed by single quotes. For format names, see SYSTem:APPLication:CATalog:FORMat? . Note that the format name parameter is not case-sensitive.

Query

Range: LIC|NLIC|UNKN

  • "LIC" indicates this is a licensed format.

  • "NLIC" indicates this is not a licensed format.

  • "UNKN" indicates that the license status is unknown.

Requirements

Test Application Revision: A.01.00 and above

Programming Example

"SYSTem:APPLication:FORMat:LICense? 'TD-SCDMA'"

SYSTem:APPLication:SELect[:NAME]

Function | Switches to the specified application (this includes a reboot of the test set). Queries the name of the application that will be loaded after the next reboot of the test set.
Setting | Range: see SYSTem:APPLication:CATalog[:NAME]? .
Query | same as setting
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "SYSTem:APPLication:SELect 'TD-SCDMA_GSM Fast Switch'" "SYSTem:APPLication:SELect?"

SYSTem:APPLication:SELect:REVision

Function | Sets/queries the revision that will be loaded when the application is switched to using the SYSTem:APPLication:SELect[:NAME] command.
Setting | Range: see SYSTem:APPLication:CATalog[:NAME]? and SYSTem:APPLication:CATalog:REVision?<sp>'<application name>' .
Query | same as setting
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "SYSTem:APPLication:SELect:REVision 'TD-SCDMA_GSM Fast Switch', 'A.01.04'"

SYSTem:APPLication:SELect:REVision?<sp>'<application name>'

Function

Queries the revision that will be loaded when the specified application is switched to using the SYSTem:APPLication:SELect[:NAME] command.

The query must include a parameter for the application name enclosed by single quotes. For application names, see SYSTem:APPLication:CATalog[:NAME]? . Note that the application name parameter is not case-sensitive.

To set the revision that will be loaded when the specified application is switched to, see SYSTem:APPLication:SELect:REVision .

Query

Range: 0 to 20 characters from the set .0123456789aAbBcCdDeEfF, enclosed by double quotes. For example, "A.01.01"

Requirements

Test Application Revision: A.01.00 and above

Programming Example

"SYSTem:APPLication:SELect:REVision? "TD-SCDMA_GSM Fast Switch""


SYSTem:AUDio

  • SYSTem:AUDio:OUTPut:SOURce

  • SYSTem:AUDio:OUTPut:FMDemod:BPFilter:STATe

  • SYSTem:AUDio:OUTPut:FMDemod:EXPandor:STATe

  • SYSTem:AUDio:OUTPut:FMDemod:DEEMphasis:STATe

For more information on the GPIB Command conventions, see GPIB Command conventions

SYSTem:AUDio:OUTPut:SOURce

Function | Set/queries whether the audio generator signal or the FM demodulation signal is selected to be routed to the AUDIO OUT port of the test set's front panel.
Setting | Range: AFGenerator|FMDemod
Query | Range: AFG|FMD
*RST Setting | AFG
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "SYSTem:AUDio:OUTPut:SOURce FMDemod"

SYSTem:AUDio:OUTPut:FMDemod:BPFilter:STATe

Function

Sets/queries whether the fixed bandpass filter is inserted or bypassed in the FM Demod signal path. It is useful only when FM Demod signal is selected for output at the front-panel AUDIO OUT port.

When the state is ON, a 300 Hz to 3 KHz bandpass filter is inserted in the audio signal path. When the state is OFF, the bandpass filter is bypassed in the audio signal path.

Setting

Range: 0|OFF|1|ON

Query

Range: 0|1

*RST Setting

0 (OFF)

Requirements

Test Application Revision: A.01.00 and above

Programming Example

"SYSTem:AUDio:OUTPut:FMDemod:BPFilter:STATe ON"

SYSTem:AUDio:OUTPut:FMDemod:EXPandor:STATe

Function

Sets/queries whether the expandor filter is inserted or bypassed in the FM Demod signal path. It is useful only when FM Demod signal is selected for output at the front-panel AUDIO OUT port.

When the state is ON, the expandor filter is inserted in the audio signal path. When the state is OFF, the expandor filter is bypassed in the audio signal path.

Setting

Range: 0|OFF|1|ON

Query

Range: 0|1

*RST Setting

0 (OFF)

Requirements

Test Application Revision: A.01.00 and above

Programming Example

"SYSTem:AUDio:OUTPut:FMDemod:EXPandor:STATe ON"

SYSTem:AUDio:OUTPut:FMDemod:DEEMphasis:STATe

Function

Sets/queries whether the deemphasis filter is inserted or bypassed in the FM Demod signal path. It is useful only when FM Demod signal is selected for output at the front-panel AUDIO OUT port .

When the state is ON, the deemphasis filter is inserted in the audio signal path. When the state is OFF, the deemphasis filter is bypassed in the audio signal path.

Setting

Range: 0|OFF|1|ON

Query

Range: 0|1

*RST Setting

0 (OFF)

Requirements

Test Application Revision: A.01.00 and above

Programming Example

"SYSTem:AUDio:OUTPut:FMDemod:DEEMphasis:STATe ON"


SYSTem:BEEPer

  • SYSTem:BEEPer:STATe

For more information on the GPIB Command conventions, see GPIB Command conventions

SYSTem:BEEPer:STATe

Function | Sets/queries the beeper state of the test set.
Setting | Range: 0|OFF | 1|ON
Query | Range: 0|1
*RST Setting | 1 (on)
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "SYSTem:BEEPer:STATe OFF"


SYSTem:COMMunicate

  • SYSTem:COMMunicate:GPIB[:SELF]:ADDRess

  • SYSTem:COMMunicate:GPIB:DEBug[:STATe]

  • SYSTem:COMMunicate:LAN[:SELF]:ADDRess[:IP4]

  • SYSTem:COMMunicate:LAN[:SELF]:ADDRess:IP6:IID?

  • SYSTem:COMMunicate:LAN[:SELF]:ADDRess:IP6:PREFix

  • SYSTem:COMMunicate:LAN[:SELF]:ADDRess2[:IP4]

  • SYSTem:COMMunicate:LAN[:SELF]:ADDRess2:IP6:IID?

  • SYSTem:COMMunicate:LAN[:SELF]:DGATeway[:IP4]

  • SYSTem:COMMunicate:LAN[:SELF]:DGATeway:IP6:IID

  • SYSTem:COMMunicate:LAN[:SELF]:SMASk[:IP4]

For more information on the GPIB Command conventions, see GPIB Command conventions

SYSTem:COMMunicate:GPIB[:SELF]:ADDRess

Function | Sets/queries the test set's GPIB address.
Setting | Range: 0 to 30
Query | Range: 0 to 30
*RST Setting | 14
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "SYSTem:COMMunicate:GPIB:SELF:ADDRess 14"

SYSTem:COMMunicate:GPIB:DEBug[:STATe]

Function

Sets/queries the test set's SCPI debugger state.

When the state is on; enhanced error messages (generated from GPIB commands with syntax errors) are shown the test set display.

The error message is printed along with the syntax. <ERR> is displayed at the end of the incorrect node. Non-printable characters will be replaced with the $ symbol. See Troubleshooting for a list of the errors.

The debugger state should be set to on only during GPIB code development. Test times will increase if the debugger state is left on.

Setting

Range: 0|OFF | 1|ON

Query

0|1

*RST Setting

0 (off)

Requirements

Test Application Revision: A.01.00 and above

Programming Example

"SYSTEM:COMMUNICATE:GPIB:DEBUG:STATE ON"

SYSTem:COMMunicate:LAN[:SELF]:ADDRess[:IP4]

Function | Sets/queries the test set's LAN IP address supported in IP version 4. The LAN IP address cannot be changed when the operating mode is set to Active Cell.
Setting | Range:15 characters formatted as A.B.C.D, where A= 0 to 126 and 128 to 223, B.C.D = 0 to 255 (no embedded spaces) or blank field
Query | Range:15 characters formatted as "A.B.C.D"
*RST Setting | blank field
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "SYSTem:COMMunicate:LAN:SELF:ADDRess '146.208.235.165'"

SYSTem:COMMunicate:LAN[:SELF]:ADDRess:IP6:IID?

Function | Queries the LAN IPv6 Address (IID) showed in the Instrument IP Addressing screen.
Query | Range: 19 characters formatted as: AAAA:BBBB:CCCC:DDDD where A, B, C and D are all hex numbers ranging from 0 to F.
*RST Setting | Fixed value "0230:D3FF:FE02:8F58".
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "SYSTem:COMMunicate:LAN:ADDRess:IP6:IID?"

SYSTem:COMMunicate:LAN[:SELF]:ADDRess:IP6:PREFix

Function

Sets/queries the test set's IPv6 address prefix.

Query

Range: 19 characters formatted as: AAAA:BBBB:CCCC:DDDD where A, B, C and D are all hex numbers.

  • "" (Null) or

  • 2000:0000:0000:0000 to 3FFF:FFFF:FFFF:FFFF or

  • FC00:0000:0000:0000 to FDFF:FFFF:FFFF:FFFF

Double-colon "::" can be used in the IPv6 address as valid. Moreover, "::" can be suffixed at the end of the 19 characters which is also a valid IPv6 address prefix. For example: 2009:1:2:3 and 2009:1:2:3:: are all valid IPv6 address prefixes for the GPIB parameter setting.

Query

Range: 19 characters formatted as: AAAA:BBBB:CCCC:DDDD where A, B, C and D are all hex numbers ranging from 0 to F.

*RST Setting

"" (Null)

Requirements

Test Application Revision: A.01.00 and above

Programming Example

"SYSTem:COMMunicate:LAN:ADDRess:IP6:PREFix '2009:8960:8960:8960'"

"SYSTem:COMMunicate:LAN:ADDRess:IP6:PREFix '2009:1:2:3'"

"SYSTem:COMMunicate:LAN:ADDRess:IP6:PREFix '2009:1:2:3::'"

SYSTem:COMMunicate:LAN[:SELF]:ADDRess2[:IP4]

Function | Sets/queries the test set's LAN IP address supported in IP version 4. The LAN IP address cannot be changed when the operating mode is set to Active Cell.
Setting | Range:15 characters formatted as A.B.C.D, where A= 0 to 126 and 128 to 223, B.C.D = 0 to 255 (no embedded spaces) or blank field
Query | Range:15 characters formatted as "A.B.C.D"
*RST Setting | blank field
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "SYSTem:COMMunicate:LAN:SELF:ADDRess2 '146.208.235.165'"

SYSTem:COMMunicate:LAN[:SELF]:ADDRess2:IP6:IID?

Function | Queries the LAN 2 IPv6 Address (IID) showed in the Instrument IP Addressing screen.
Query | Range: 19 characters formatted as: AAAA:BBBB:CCCC:DDDD where A, B, C and D are all hex numbers ranging from 0 to F.
*RST Setting | Fixed value "0230:D3FF:FE02:BE5A"
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "SYSTem:COMMunicate:LAN:ADDRess2:IP6:IID?"

SYSTem:COMMunicate:LAN[:SELF]:DGATeway[:IP4]

Function | Sets/queries the LAN IP router/gateway address for the test set in IP version 4.
Setting | Range: 15 characters formatted as A.B.C.D, where A= 0 to 126 and 128 to 223, B.C.D = 0 to 255 (no embedded spaces) or blank field
Query | Range: 15 characters formatted as "A.B.C.D"
*RST Setting | blank field
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "SYSTem:COMMunicate:LAN:SELF:DGATeway '255.2.6.200'"

SYSTem:COMMunicate:LAN[:SELF]:DGATeway:IP6:IID

Function

Sets/queries the test set's IPv6 Default Router Interface ID.

Setting

Range: 19 characters formatted as: AAAA:BBBB:CCCC:DDDD where A, B, C and D are all hex numbers.

  • "" (Null) or

  • 0000:0000:0000:0001 to FFFF:FFFF:FFFF:FFFF

Double-colon "::" can be used in the IPv6 Default Router Interface ID as valid. Moreover, "::" can be prefixed at the beginning of the 19 characters which is also a valid IPv6 Default Router Interface ID. For example: 8960::1, ::1:2 and 8960:8960:146.208.232:220 are all valid IPv6 Default Router Interface IDs for the GPIB parameter setting.

The IPv6 Default Router Interface parameter is also IPv4 address-compatible with the format: ::W.X.Y.Z, where W.X.Y.Z is the dotted decimal representation of an IPv4 address. For example, ::8960:8960:146.208.232:220 and 8960:8960:146.208.232:220 are all valid IPv6 Default Router Interface IDs for the GPIB parameter setting.

Query

Range: 19 characters formatted as: AAAA:BBBB:CCCC:DDDD where A, B, C and D are all hex numbers ranging from 0 to F.

*RST Setting

"" (Null)

Requirements

Test Application Revision: A.01.00 and above

Programming Example

"SYSTem:COMMunicate:LAN:DGATeway:IP6:IID '0000:0000:821D:B001'"

SYSTem:COMMunicate:LAN[:SELF]:SMASk[:IP4]

Function | Sets/queries the subnet mask of the test set based on the LAN IP address selected in IP version 4.
Setting | Range: 15 characters formatted as A.B.C.D, where A, B, C, D are between = 0 to 255 or blank field
Query | Range: 15 characters formatted as follows: A.B.C.D where A,B,C,D are between = 0 to 255 (no embedded spaces)
*RST Setting | 0.0.0.0
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "SYSTem:COMMunicate:LAN:SELF:SMASk '255.255.0.0'"


SYSTem:CONFigure

  • SYSTem:CONFigure:INFormation:HARDware:VERBose?

For more information on the GPIB Command conventions, see GPIB Command conventions

SYSTem:CONFigure:INFormation:HARDware:VERBose?

Function | Query the manufacturer, model number, model number of the test application running, serial number, revision, board ID, and cal file information. The information provided by the query represents the configuration that existed when the test set was powered up.
*RST Setting | Resets have no effect on this information. The information is gathered during the power up cycle.
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "SYSTEM:CONFIGURE:INFORMATION:HARDWARE:VERBOSE?"


SYSTem:CORRection

  • SYSTem:CORRection[:SGAin]

  • SYSTem:CORRection:FREQuency

  • SYSTem:CORRection:GAIN

  • SYSTem:CORRection:POINts

  • SYSTem:CORRection:SFRequency

  • SYSTem:CORRection:STATe

For more information on the GPIB Command conventions, see GPIB Command conventions

SYSTem:CORRection[:SGAin]

Function | Sets/queries up to 60 comma-separated amplitude offset values in dB. This command sets the state to On. See Amplitude Offset. The units, dB, are optional. If no units are specified then units default to dB. Sending a null list (no values) sets the state of all offsets to Off.
Setting | Range: 0 to 60 values between -100 to +100 Resolution: 0.01
Query | Range: 0 to 60 values between -100 to +100 Resolution: 0.01
*RST Setting | Offsets 1 through 60, are set to 0.00 dB, state is set to Off
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "SYSTEM:CORRECTION:SGAIN -2.55,-3.12,-3.68,-4.23,-4.74,-5.3"

SYSTem:CORRection:FREQuency

Function | Sets/queries up to 60 comma separated frequency values in MHz. Each frequency value corresponds with a gain setting. The units, (GHz, MHz, kHz, Hz) are optional. If no units are specified, units default to Hz. Sending a null list (no values) sets the state of all frequencies to Off.
Setting | Range: 1 to 60 comma separated values ranging from 292.5 MHz to 2700 MHz
Query | the same to the setting
*RST Setting | All the 60 frequencies are off
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "SYSTem:CORRection:FREQuency 1784.8 MHZ,1879.8 MHZ"

SYSTem:CORRection:GAIN

Function | Sets/queries the up to 60 comma separated offset gain values in units of dB. Each gain value corresponds with a frequency setting. The units, dB, are optional. If no units are specified, units default to dB. Sending a null list (no values) sets the state of all offsets to Off.
Setting | Range: 0 to 60 values between -100 to +100
Query | the same to the setting
*RST Setting | Offsets 1 through 60 are set to 0.00 dB,
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "SYSTem:CORRection:GAIN -3.12,-3.68"

SYSTem:CORRection:POINts

Function | Query returns the number of offsets that are in their On state when the RF IN/OUT Amplitude Offset State is also set to On.
Query | Range: 1 to 60, and NAN (9.91E+37) Resolution: 1
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "SYSTEM:CORRECTION:POINTS?"

SYSTem:CORRection:SFRequency

Function | Sets/queries up to 60 comma separated frequency values in MHz. This command sets the state to On. The units (GHz, MHz, kHz, Hz) are optional. If no units are specified, units default to MHz.
Setting | Range: 0 to 60 comma separated values from 292.5 MHz to 2700 MHz Resolution: 1 Hz
Query | Range: 1 to 60 comma separated values from 292.5 MHz to 2700 MHz, and NAN (9.91E+37) Resolution: 1 HZ
*RST Setting | All the 60 frequencies are off
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "SYSTEM:CORRECTION:SFREQUENCY 1710.2 MHZ,1805.2 MHZ,1784.8 MHZ,1879.8 MHZ"

SYSTem:CORRection:STATe

Function

Sets/queries the RF IN/OUT Amplitude Offset State.

The state must be On before any of the offsets are active regardless of the state for any of the frequencies or offsets.

Setting any of the frequency or offset states to On will set the RF IN/OUT Amplitude Offset State to On.

Setting

Range: 0|OFF | 1|ON

Query

Range: 0|1

*RST Setting

0 (off)

Requirements

Test Application Revision: A.01.00 and above

Programming Example

"SYSTem:CORRection:STATe ON"


SYSTem:CURRent:TA

  • SYSTem:CURRent:TA:MODel?

  • SYSTem:CURRent:TA:NAME?

  • SYSTem:CURRent:TA:REVision?

For more information on the GPIB Command conventions, see GPIB Command conventions

SYSTem:CURRent:TA:MODel?

Function | Query the model number of the test application running. Printable ASCII characters up to a 15 character string.
Query | Range: ASCII codes 32 - 126 decimal excluding comma and semicolon
*RST Setting | non volatile, read from the test set's hard disk
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "SYSTem:CURRent:TA:MODel?"

SYSTem:CURRent:TA:NAME?

Function | Query the name of the test application running. Printable ASCII characters up to a 25 character string. This command is not recommended.
Query | Range: ASCII codes 32 - 126 decimal excluding comma and semicolon.
*RST Setting | non volatile, read from the test set's hard disk
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "SYSTem:CURRent:TA:NAME?"

SYSTem:CURRent:TA:REVision?

Function | Query the coordinated codeware revision for the test application running. Printable ASCII characters up to a 20 character string. This command is not recommended.
Query | Range: ASCII codes 32 - 126 decimal excluding comma and semicolon
*RST Setting | non volatile, read from the test set's hard disk.
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "SYSTem:CURRent:TA:REVision?"


SYSTem:DATE

  • SYSTem:DATE

For more information on the GPIB Command conventions, see GPIB Command conventions

SYSTem:DATE

Function

Sets/queries the date.

Setting

Range:

  • <year> 2000 to 2099

  • <month> 1 to 12 (the number 1 corresponds to January)

  • <day> 1 to the number of days in the month specified by the <month> parameter

Query

Range: "<year>,<month>,<day>"

*RST Setting

This feature is not affected by instrument preset

Requirements

Test Application Revision: A.01.00 and above

Programming Example

"SYSTem:DATE 2009,11,11"


SYSTem:ERRor?

  • SYSTem:ERRor?

For more information on the GPIB Command conventions, see GPIB Command conventions

SYSTem:ERRor?

Function

Queries the contents of the Error/Event Queue. The Error/Event Queue may contain one or more messages with an error or event description.

Manual users may view the Message Log from the SYSTEM CONFIG screen. See Message Log .

The contents of the Error/Event Queue and the Message Log may not match. For example, Manual User Error Messages are not returned by the SYSTem:ERRor? query, they are only viewable from the Error Message Log.

Query

Error/Event Queue

Range: 0 to 100 messages up to 255 characters in length

Requirements

Test Application Revision: A.01.00 and above

Programming Example

"SYSTem:ERRor?"


SYSTem:FATal

  • SYSTem:FATal:ERRor:RESTart

For more information on the GPIB Command conventions, see GPIB Command conventions

SYSTem:FATal:ERRor:RESTart

Function | Sets/queries the state of the Restart on Fatal Error parameter.
Setting | Range: ON|1|OFF|0
Query | Range: 1|0
*RST Setting | 0
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "SYSTem:FATal:ERRor:RESTart ON"


SYSTem:INSTrument

  • SYSTem:INSTrument:TEMPerature?

  • SYSTem:INSTrument:THERmal:POWer:NULL:ADJust?

For more information on the GPIB Command conventions, see GPIB Command conventions

SYSTem:INSTrument:TEMPerature?

Function | Queries the current internal operating temperature.
Query | Range: -60.0 to 100.0 (°C)
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "SYSTem:INSTrument:TEMPerature?"

SYSTem:INSTrument:THERmal:POWer:NULL:ADJust?

Function

Starts the Thermal Power Null Adjustment .

Note: you should ensure that your test set has warmed up at least 30 minutes and that no power is present at the front panel RF connectors before performing any calibrations.

When this adjustment has completed, a value is returned to indicate the success or failure of the adjustment. 0 indicates the adjustment completed successfully, 1 indicates that it failed.

Query

Range: 0 (success), 1 (failure)

Requirements

Test Application Revision: A.01.00 and above

Programming Example

"SYSTem:INSTrument:THERmal:POWer:NULL:ADJust?"


SYSTem:LOG

  • SYSTem:LOG:UI:CLEAR

  • SYSTem:LOG:UI:COUNt?

  • SYSTem:LOG:UI:GPIB[:STATe]

  • SYSTem:LOG:UI:REPort?

For more information on the GPIB Command conventions, see GPIB Command conventions

SYSTem:LOG:UI:CLEAR

Function | GPIB Command to Clear the UI Log
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "SYSTem:LOG:UI:CLEAR"

SYSTem:LOG:UI:COUNt?

Function | Query the number of lines containing GPIB commands in the UI Log.
Query | returns the number of lines in the log since the last time the log was cleared.
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "SYSTem:LOG:UI:COUNt?"

SYSTem:LOG:UI:GPIB[:STATe]

Function | Sets/queries the UI log GPIB state.
Setting | Range: ON|OFF
Query | Range: 1(ON)|0(OFF)
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "SYSTem:LOG:UI:GPIB ON"

SYSTem:LOG:UI:REPort?

Function | Query the string at the specified line in the UI Log. The GPIB query in the following table returns the string located at the line in the log that you specify. Note that issuing this command turns off GPIB logging. You must turn it back on using the SYSTem:LOG:UI:GPIB[:STATe] command to continue GPIB logging.
Setting | Range: An integer
Query | Range: the string located at the line in the log that you specify.
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "SYSTem:LOG:UI:REPort?"


SYSTem:MEASurement:RESet

  • SYSTem:MEASurement:RESet

For more information on the GPIB Command conventions, see GPIB Command conventions

SYSTem:MEASurement:RESet

Function | Sets all measurements to abort. If continuous triggering is enabled, measurements will begin a new measurement cycle.
Setting | Sets all measurements to abort. If continuous triggering is enabled, measurements will begin a new measurement cycle.
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "SYSTem:MEASurement:RESet"


SYSTem:PRESet

  • SYSTem:PRESet2

  • SYSTem:PRESet3

For more information on the GPIB Command conventions, see GPIB Command conventions

SYSTem:PRESet2

Function

Performs a full preset of the test set. This is the remote equivalent of pressing the SHIFT Preset keys on the front panel of the test set.

All parameters are set to their default values. All measurements are aborted the trigger arm is set to continuous.

The *RST command will set the trigger arm to single.

Requirements

Test Application Revision: A.01.00 and above

Programming Example

"SYSTEM:PRESET2"

SYSTem:PRESet3

Function

Performs a partial preset. This is the recommended command for users when a partial preset is needed during remote operation of the test set.

Any call in process is disconnected and all measurements are aborted and inactivated. Measurement parameters are not changed.

A partial preset will not modify any measurement settings including trigger arm.

Requirements

Test Application Revision: A.01.00 and above

Programming Example

"SYSTEM:PRESET3"


SYSTem:REGister

  • SYSTem:REGister:DELete

  • SYSTem:REGister:NAME

  • SYSTem:REGister:RECall

  • SYSTem:REGister:SAVe

For more information on the GPIB Command conventions, see GPIB Command conventions

SYSTem:REGister:DELete

Function | Deletes any contents saved in the selected register.
Setting | Range: 1|2|3|4|5|6|7|8|9|10
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "SYSTem:REGister:DELete 1"

SYSTem:REGister:NAME

Function

Set/Queries the name of a specific register.

Setting

Range: two parameters separated with comma,

  • Register number: 1|2|3|4|5|6|7|8|9|10

  • Register name: any printable ASCII character, the maximum length is 20.

Requirements

Test Application Revision: A.01.00 and above

Programming Example

"SYSTem:REGister:NAME 1,'NOKIA TEST'"

SYSTem:REGister:RECall

Function | Recalls a saved register from one of ten registers. If this command is used to recall a register that is empty, an error message will be displayed.
Setting | Range:1|2|3|4|5|6|7|8|9|10
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "SYSTem:REGister:RECall 1"

SYSTem:REGister:SAVe

Function | Saves the current test set settings to one of ten available registers. If this command is used to save to a register that is already full, the old contents of the register will be overwritten.
Setting | 1|2|3|4|5|6|7|8|9|10
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "SYSTem:REGister:SAVe 1"


SYSTem:ROSCillator

  • SYSTem:ROSCillator[:TIMebase]?

  • SYSTem:ROSCillator:LOCKed?

For more information on the GPIB Command conventions, see GPIB Command conventions

SYSTem:ROSCillator[:TIMebase]?

Function

Queries the timebase source.

If an external timebase is used, it must have these characteristics:

  • an output level of 0 to +13 dBm

  • frequency of 10 MHz

Query

Range:

INT = internal source

EXT = external source

Requirements

Test Application Revision: A.01.00 and above

Programming Example

"SYSTem:ROSCillator?"

SYSTem:ROSCillator:LOCKed?

Function

Queries the timebase to find out if it is locked or unlocked. Returns 0 or 1.

Query

Range:

  • 0 = unlocked

  • 1 = locked

Requirements

Test Application Revision: A.01.00 and above

Programming Example

"SYSTem:ROSCillator:LOCKed?"


SYSTem:SYNChronized

  • SYSTem:SYNChronized

For more information on the GPIB Command conventions, see GPIB Command conventions

SYSTem:SYNChronized

Function | Sets/queries the test set to see that all prior sequential commands have completed or that all prior overlapped commands have started, indicating that the input buffer is synchronized.
Setting | Bit 12 of the status operation condition register is pulsed.
Query | Range: 1
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "SYSTem:SYNChronized?"


SYSTem:TIME

  • SYSTem:TIME

For more information on the GPIB Command conventions, see GPIB Command conventions

SYSTem:TIME

Function

Sets/queries the local time of day.

UTC time will track changes made directly to local time settings. Also, if new settings are made to UTC time, local time will track UCT time.

Changes to time zone will cause changes to local time, but will not directly affect UTC time.

Setting

Range:

  • <hour> 0 to 23

  • <minute> 0 to 59

  • <second> 0 to 59

Query

Range: "<hour>,<minute>,<second>"

*RST Setting

This feature is not affected by instrument preset

Requirements

Test Application Revision: A.01.00 and above

Programming Example

"SYSTem:TIME 11,10,10"


SYSTem:TZONe

  • SYSTem:TZONe

For more information on the GPIB Command conventions, see GPIB Command conventions

SYSTem:TZONe

Function

Sets/queries the time zone.

The format of entry is hh,mm or -hh,-mm and the resolution is 15 minutes. Therefore, any entry that does not fall evenly on a 15 minute (quarter hour) boundary is rounded to the nearest 15 minutes. If -hh,mm is entered an error message is generated.

Changes to time zone will cause changes to local time, but will not directly affect UTC time.

Setting

Range:

  • <hour> -19 to 0

<minute> -59 to 0

or

  • <hour> 0 to 17

<minute> 0 to 59

Query

Range:"<hour>, <minute>"

*RST Setting

This feature is not affected by instrument preset

Requirements

Test Application Revision: A.01.00 and above

Programming Example

"SYSTem:TZONe 8,0"


SYSTem:UTC

  • SYSTem:UTC[:TIME]

  • SYSTem:UTC:DATE

For more information on the GPIB Command conventions, see GPIB Command conventions

SYSTem:UTC[:TIME]

Function

Sets/queries the Universal Coordinated Time (UTC) time of day.

Local time will track UTC time settings. Also, if new settings are made to local time, UTC time will track local time.

Setting

Range:

  • <hour> 0 to 23

  • <minute> 0 to 59

  • <second> 0 to 59

Query

Range: "<hour>,<minute>,<second>"

*RST Setting

This feature is not affected by instrument preset

Requirements

Test Application Revision: A.00 and above

Programming Example

"SYSTem:UTC:TIME 11,10,10"

SYSTem:UTC:DATE

Function

Sets/queries Universal Coordinated Time (UTC) date.

Setting

Range:

  • <year> 2000 to 2099

  • <month> 1 to 12 (the number 1 corresponds to January)

  • <day> 1 to the number of days in the month specified by the <month> parameter

Query

Range: "<year>,<month>,<day>"

*RST Setting

This feature is not affected by instrument preset

Requirements

Test Application Revision: A.01.00 and above

Programming Example

"SYSTem:UTC:DATE 2009,11,11"


AFGenerator Subsystem

Last updated: March 31, 2010

  • AFGenerator:FREQuency

  • AFGenerator:PULSe[:STATe]

  • AFGenerator:VOLTage[:SAMPlitude]

  • AFGenerator:VOLTage:AMPlitude

  • AFGenerator:VOLTage:STATe

For more information on the GPIB Command conventions, see GPIB Command conventions

AFGenerator:FREQuency

Function | Sets/queries the frequency of the audio generator. The units (HZ|KHZ|MHZ|GHZ) are optional. If no units are specified, then units default to HZ.
Setting | Range: 1 Hz to 20 kHz
Query | Range: 1 Hz to 20 kHz
*RST Setting | 1 kHz
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "AFGenerator:FREQuency 1000"

AFGenerator:PULSe[:STATe]

Function

Sets/queries the audio generator pulse state.

The pulse state must be on when the test set's audio generator is used for audio stimulation during a decoded audio measurement.

When the state is on, the audio signal from the test set is pulsed at a 10 Hz rate with a 50% duty cycle.

Setting

Range: 0 | OFF | 1 |ON

Query

Range: 0|1

*RST Setting

0 (off)

Requirements

Test Application Revision: A.01.00 and above

Programming Example

"AFGenerator:PULSe:STATe ON"

AFGenerator:VOLTage[:SAMPlitude]

Function | Sets /queries the amplitude of the audio generator in volts and turns the state to on. The units (V|mV) are optional. If no units are specified, then units default to V.
Setting | Range: 0 to 9 V
Query | Range: 0 to 9 V
*RST Setting | 0 V
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "AFGenerator:VOLTage 2.1"

AFGenerator:VOLTage:AMPlitude

Function | Sets/queries the amplitude for the audio generator when the audio generator state is on. The units (V|mV) are optional. If no units are specified, then units default to V.
Setting | Range: 0 to 9 V
Query | Range: 0 to 9 V
*RST Setting | 0 V
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "AFGenerator:VOLTage:AMPlitude 2.1"

AFGenerator:VOLTage:STATe

Function | Sets/queries audio generator state.
Setting | Range: 0 | OFF | 1 |ON
Query | Range: 0|1
*RST Setting | 0 (off)
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "AFGenerator:VOLTage:STATe ON"


CALibration Subsystem

Last updated: March 31, 2010

  • CALibration:IQ[1]?

  • CALibration:IQ2?

  • CALibration:MEASurements?

For more information on the GPIB Command conventions, see GPIB Command conventions

CALibration:IQ[1]?

Function

Queries the calibration of the IQ modulator for RF generator 1. It takes some time to complete calibration and can't be aborted except by cycling the power switch.

  • Calibrates the IQ modulator for RF generator 1.

  • Returns a value indicating success or failure of calibration.

Query

Range:

  • 0 = Pass

  • -340 = Fail

Requirements

Test Application Revision: A.01.00 and above

Programming Example

"CALibration:IQ1?"

CALibration:IQ2?

Function

Queries the calibration of the IQ modulator for RF generator 2. It takes some time to complete calibration and can't be aborted except by cycling the power switch.

  • Calibrates the IQ modulator for RF generator 2.

  • Returns a value indicating success or failure of calibration.

Query

Range:

  • 0 = Pass

  • -340 = Fail

Requirements

Test Application Revision: A.01.00 and above

Programming Example

"CALibration:IQ2?"

CALibration:MEASurements?

Function

Starts the Calibrate Measurements routine. When this calibration has completed, a value is returned to indicate the success or failure of the calibration. Zero indicates the calibration completed successfully.

Ensure that your test set has warmed up at least 30 minutes and that no power is present at the front panel RF connectors before performing any calibrations.

Query

Range:

  • 0: Measurement calibration completed successfully.

  • 1: Measurement calibration failed due to temperature drift. Wait for temperature to stabilize.

  • 2: Measurement calibration failed due to oven out of range.

  • 3: Measurement calibration failed due to loopback switch problem.

  • 4: Measurement calibration failed due to under range condition.

  • 5: Measurement calibration failed due to over range condition.

  • 6: Measurement calibration failed due to correlation problem.

  • -340: Measurement calibration failed. This is a SCPI defined value indicating an unexpected case.

Requirements

Test Application Revision: A.00 and above

Programming Example

"CALIBRATION:MEASUREMENTS?"


DISPlay Subsystem

  • DISPlay:BRIGhtness

  • DISPlay:MESSage:MASKable:STATe

  • DISPlay:MODE

For more information on the GPIB Command conventions, see GPIB Command conventions

DISPlay:BRIGhtness

Function | Sets/queries the test set's display brightness.
Setting | Range: MEDium | HIGH
Query | Range: MED | HIGH
*RST Setting | HIGH
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "DISPlay:BRIGhtness MEDium"

DISPlay:MODE

Function | Sets/queries the test set's display mode.
Setting | Range: FAST | TRACK
Query | Range: FAST | TRAC
*RST Setting | TRACK
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "DISPlay:MODE FAST"

DISPlay:MESSage:MASKable:STATe

Function | Blocks maskable messages from appearing on the test set display screen but not from the Message Log. Maskable messages are reported to the Message Log in either state.
Setting | Range: 1|ON|0|OFF
Query | Range: 1|0
*RST Setting | On
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "DISPlay:MESSage:MASKable:STATe OFF"


RFANalyzer Subsystem

  • RFANalyzer:CONTrol:MEASurement:FREQuency:AUTO

  • RFANalyzer:CONTrol:POWer:AUTO

  • RFANalyzer:CONTrol:UPLink:FREQuency:AUTO

  • RFANalyzer:CW:EXPected:POWer

  • RFANalyzer:MANual:MEASurement[:MFRequency]

  • RFANalyzer:MANual:MEASurement:FREQuency

  • RFANalyzer:MANual:POWer[:SELected]

  • RFANalyzer:MANual:POWer:TDSCdma

  • RFANalyzer:MANual:UPLink[:MFRequency]

  • RFANalyzer:MANual:UPLink:FREQuency

For more information on the GPIB Command conventions, see GPIB Command conventions

RFANalyzer:CONTrol:MEASurement:FREQuency:AUTO

Function | Turns on/off the auto Measurement Frequency which determines the measurement downconverter signal path frequency control mode. ON = automatic OFF = manual (see RFANalyzer:MANual:MEASurement[:MFRequency])
Setting | Range:0 | OFF | 1 | ON
Query | Range:0 | 1
*RST Setting | 1 | ON
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "RFANalyzer:CONTrol:MEASurement:FREQuency:AUTO OFF"

RFANalyzer:CONTrol:POWer:AUTO

Function | Sets/queries power control . ON = automatic OFF = manual
Setting | Range:0 | OFF | 1 | ON
Query | Range:0 | 1
*RST Setting | 1 |ON
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "RFANalyzer:CONTrol:POWer:AUTO OFF"

RFANalyzer:CW:EXPected:POWer

Function | Sets/queries the expected CW receiver input power. This setting is only used when the operating mode is set to CW.
Setting | Range: -29 dBm to +44 dBm
Query | same as setting
*RST Setting | +13 dBm
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "RFANALYZER:CW:EXPECTED:POWER -20"

RFANalyzer:MANual:MEASurement[:MFRequency]

Function

The setting form of this command performs two functions: (1) sets Measurement Frequency , the tune frequency of the test set's measurement signal path, and (2) selects manual tune mode for the test set's measurement signal path.

The query form of this command returns the tune frequency of the test set's measurement signal path.

Setting

Range: 292.5 MHz to 2700 MHz

Resolution: 0.1 Hz

Query

same as setting

*RST Setting

896.000 MHz

Requirements

Test Application Revision: A.01.00 and above

Programming Example

"RFANALYZER:MANUAL:MEASUREMENT:MFREQUENCY 896 MHZ"

RFANalyzer:MANual:MEASurement:FREQuency

Function | Sets/queries the frequency of measurement frequency when the frequency mode is manual.
Setting | Range: 292.5 MHz to 2700 MHz Resolution: 0.1 Hz
Query | same as setting
*RST Setting | 896.000 MHz
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "RFANALYZER:MANUAL:MEASUREMENT:FREQUENCY 896 MHZ"

RFANalyzer:MANual:POWer[:SELected]

Function | Sets/queries manual power.
Setting | Range: Test application and system type dependent (approximately-69 to + 31 dBm). Resolution: 0.01 dBm
Query | same as setting
*RST Setting | 0 dBm
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "RFANALYZER:MANUAL:POWER:SELECTED 24 DBM"

RFANalyzer:MANual:POWer:TDSCdma

Function | Sets/queries manual power when TDSCdma is the current system type.
Setting | Range: -70 dBm to +30 dBm actual hardware range with amplitude offset = 0 Resolution: 0.01 dBm
Query | same as setting
*RST Setting | 0 dBm
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "RFANalyzer:MANual:POWer:TDSCdma 24 DBM"

RFANalyzer:CONTrol:UPLink:FREQuency:AUTO

Function | Turns on/off the auto Uplink Frequency which determines the test set's demodulation signal path frequency control mode. ON = automatic OFF = manual
Setting | Range:0 | OFF | 1 | ON
Query | Range:0 | 1
*RST Setting | 1 | ON
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "RFANalyzer:CONTrol:UPLink:FREQuency:AUTO OFF"

RFANalyzer:MANual:UPLink[:MFRequency]

Function

The setting form of this command performs two functions: (1) sets uplink Frequency , the tune frequency of the test set's demodulation signal path, and (2) selects manual tune mode for the test set's demodulation signal path.

The query form of this command returns the tune frequency of the test set's demodulation signal path.

Setting

Range: 292.5 MHz to 2700 MHz

Resolution: 0.1 Hz

Query

same as setting

*RST Setting

896 MHz

Requirements

Test Application Revision: A.01.00 and above

Programming Example

"RFANALYZER:MANUAL:UPLINK:MFREQUENCY 896 MHZ"

RFANalyzer:MANual:UPLink:FREQuency

Function | Sets/queries the frequency of uplink frequency when the frequency mode is manual.
Setting | Range: 292.5 MHz to 2700 MHz Resolution: 0.1 Hz
Query | same as setting
*RST Setting | 896 MHz
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "RFANALYZER:MANUAL:UPLINK:FREQUENCY 896 MHZ"


RFGenerator Subsystem

  • RFGenerator:OUTPut[:DESTination]

For more information on the GPIB Command conventions, see GPIB Command conventions

RFGenerator:OUTPut[:DESTination]

Function | Sets/queries the RF output port destination: RF IN/OUT (IO) or RF OUT ONLY (OUT).
Setting | Range: IO|OUT
Query | Range: IO|OUT
*RST Setting | IO
Requirements | Test Application Revision: A.01.00 and above
Programming Example | "RFGenerator:OUTPut OUT"


Troubleshooting

Contact Us

To find information about technical support, equipment service and repair, and training, visit the following Agilent Technologies Web site:

http://www.agilent.com/find/contactus/

Error Messages

When an error occurs, an error message is shown in a message window at the center of the test set's display. When an error message is displayed, an audio beep occurs; the beeper state of the test set can be set to on or off.

Click the number range below if you want to find a specific error message information.

  • +100 through +199 Error Message Descriptions

  • +200 through +299 Error Message Descriptions

  • +500 through +599 Error Message Descriptions

  • +700 through +799 Error Message Descriptions

  • Manual User Error Messages

Integrity Indicator

To interpret Integrity Indicator values in measurements, see:

  • Integrity Indicator


+1 through +199 Error Message Descriptions

Last updated: March 31, 2010

A device-specific error indicates that the instrument has detected an error that occurred because some operations did not properly complete, possibly due to an abnormal hardware or firmware condition. For example, an attempt by the user to set an out of range value will generate a device specific error.

These are general errors generated by the core instrument.

Error Message | Description
+120 TATD call operation rejected; Handoff to GSM requires a multi-format application with both GSM and TDSCDMA | This error occurs when the application that is running does not contain both TD-SCDMA and GSM/GPRS, or the required license is not installed.
+180 TD-SCDMA settings deferred; AWGN power > +10 or < -25 dB relative to cell power | A setting is deferred when that setting causes incompatibility between related settings. The test set will allow the entry of incompatible settings but the change will not affect signal levels until the incompatibility is resolved.
+181 TD-SCDMA settings deferred; One or more Test Mode code channel power levels > 30 dB below total RF power | A setting is deferred when that setting causes incompatibility between related settings. The test set will allow the entry of incompatible settings but the change will not affect signal levels until the incompatibility is resolved.
+182 TD-SCDMA settings deferred; One or more Active Cell code channel power levels > 30 dB below total RF power | A setting is deferred when that setting causes incompatibility between related settings.
+183 TD-SCDMA warning; RF power at the front panel is turned off due to HSDPA not being supported in current operating mode | This error occurs when the operating mode is TD-SCDMA Test, but the channel type is 12.2k + HSDPA at the same time.
+184 TD-SCDMA warning; RF power at the front panel is turned off due to Multi-Rate Channel not being supported in current operating mode | The Channel Types of 64 kbps RMC, 64k UL/144k DL AM RMC and 64k UL/384k DL AM RMC do not function when the Operating Mode is TD-SCDMA Test.


+200 through +299 Error Message Descriptions

Last updated: June 8, 2010

A device-specific error indicates that the instrument has detected an error that occurred because some operations did not properly complete, possibly due to an abnormal hardware or firmware condition. For example, an attempt by the user to set an out of range value will generate a device specific error.

These are call processing errors generated by the core instrument.

Error Message | Description
+200 TD-SCDMA call processing error; Uplink DPCH midamble shift cannot be greater than midamble configuration | This error message is displayed for information purposes only.
+201 TD-SCDMA call processing error; Operation not allowed due to current call status | If the Cell Operating Mode is "Active Cell", this setting can only be changed when the call status is Idle.
+202 TD-SCDMA call processing error; Operation not allowed due to incorrect closed loop power control | This action is only allowed when the closed loop power control mode is set to "Alternating bits".
+203 TD-SCDMA call processing error; No response to Activate RB Test Mode Request | During the "RB Test Mode Call Origination to CELL_DCH" procedure, the test set does not receive Activate Radio Bearer Test Mode Complete message from the UE within 2.5 seconds of sending the Activate Radio Bearer Test Mode message.
+204 TD-SCDMA call processing error; No response to Close UE Test Loop | During the "RB Test Mode Call Origination to CELL_DCH" procedure, the test set does not receive Close UE Test Loop Complete message from the UE within 2.5 seconds of sending the Close UE Test Loop message
+205 TD-SCDMA call processing error; No response to RRC Connection Setup | During the RRC Connection Setup procedure, the test set does not receive the RRC connection Complete message from the UE within 9 seconds of sending the RRC Connection Setup message
+206 TD-SCDMA call processing error; No response to Radio Bearer Setup | During the "RB Test Mode Call Origination to CELL_DCH" procedure, the test set does not receive Radio Bearer Setup Complete message from the UE within 9 seconds of sending the Radio Bearer Setup message
+207 TD-SCDMA call processing error; No response to Identity Request | During the identification procedure, the test set does not receive the Identity Response message from the UE within some seconds of sending the Identity Request message
+208 TD-SCDMA call processing error; No response to Deactivate RB Test Mode | This error message is displayed for information purposes only.
+209 TD-SCDMA call disconnected; No response to RRC Connection Release | During the Base Station Release from RB Test Mode in CELL_DCH procedure, the test set does not receive RRC Connection Release Complete message from the UE within 9 seconds of transmitting the RRC connection Release message
+210 TD-SCDMA call disconnected; Call setup aborted | This error message is displayed for information purposes only.
+211 TD-SCDMA call processing error; No Physical Channel Reconfig Complete received | During the Physical Channel Reconfiguration Procedure, the test set finds the uplink DPCH but fails to receive the appropriate "Reconfiguration Complete" message within 9 seconds of sending a physical channel reconfiguration message
+212 TD-SCDMA call processing error; GPRS attach not completed | During the GPRS Attach Procedure, the test sest fails to receive the GPRS Attach Complete message within 6 seconds of sending the GPRS Attach Accept message
+213 TD-SCDMA call processing error; No response to Authentication Request | During the authentication procedure, the test set fails to receive the Authentication (and Ciphering) Response or Authentication (and Ciphering) Failure message within certain seconds of sending the Authentication (and Ciphering) Request message
+214 TD-SCDMA call processing error; No response to Security Mode Command | During the authentication procedure, the test set fails to receive the Security Mode Complete message
+215 TD-SCDMA call processing error; Authentication failed | During the authentication procedure, the test set receives an Authentication (and Ciphering) Failure message
+216 TD-SCDMA call processing error; Security Mode failed | During the authentication procedure, the test set receives the Security Mode Failure message
+217 TD-SCDMA call disconnected; No response to Open UE Test Loop | During the Base Station Release from RB Test Mode in CELL_DCH procedure, the test set does not receive the Open UE Test Loop Complete message from the UE
+218 TD-SCDMA call disconnected; Max no. RLC Retransmissions exceeded. Starting RLC Reset Proc. | This error message is displayed for information purposes only.
+219 TD-SCDMA call disconnected; No signal found on uplink DPCH | During some call processing procedure (for example, the RRC Connection Setup or Physical Channel Reconfigure Procedure), the test set fails to find a valid DPCH
+220 TD-SCDMA call disconnected; Signal lost on uplink DPCH | When the Call Drop Timer State is "On", the test set finds a link failure has occurred due to loss of synchronization with the midamble in the Uplink DPCH
+221 TD-SCDMA call processing error; Signal not found on uplink PRACH | During the RRC Connection Setup procedure, the test set fails to receive a correct RACH message within 200 milliseconds after having received a valid UpPCH.
+222 TD-SCDMA call processing error; UE Periodical Measurement Control Failure occurred | The UE responds to the Measurement Control message with a Measurement Control Failure message.
+224 TD-SCDMA call processing error; No response to CC Connect | During the mobile initiated AMR service procedure, the test set does not receive the Connect Acknowledged message within the corresponding timer.
+225 TD-SCDMA call disconnected; Bearer capability not supported |
+226 TD-SCDMA call processing error; No response to CC Release | During the mobile station release from AMR voice procedure, the test set does not receive Release Complete message within the corresponding timer.
+228 TD-SCDMA call processing error; No response to CC Disconnect | During the test set release from AMR voice procedure, the test set does not receive the release message within the corresponding timer.
+229 TD-SCDMA call processing error; No CC Call Confirmed received from the UE | During the test set initiated AMR voice procedure, the test set does not receive the Call Confirmed message within the corresponding timer.
+230 TD-SCDMA call processing error; No CC Alerting received from the UE | During the test set initiated AMR voice procedure, the test set does not receive the Alerting message within the corresponding timer.
+231 Call operation rejected; Call processing in progress | The setting cannot be changed while in Active Cell Mode and the Call Status is not IDLE.
+231 TD-SCDMA call processing error; No CC Connect received from the UE | During the test set initiated AMR voice procedure, the test set does not receive the Connect message within the corresponding timer.
+233 TD-SCDMA call processing error; Call connection failed due to UE ’s capability or 8960’s configuration | This error occurs when you are trying to set up an HSDPA call, but the Protocol Revision Control being set is not comply with the UE's capability.
+234 TD-SCDMA call processing error; No response to Radio Bearer Release | This error occurs when the test set does not receive Radio Beaer Release Complete message after sending the Radio Beaer Release message.
+235 TD-SCDMA call processing error; Physical Channel Reconfig Failure received | During the Physical Channel Reconfigure Procedure, the test set receives the Reconfiguration Failure message.
+236 TD-SCDMA call processing error; Radio Bearer Setup Failure received | During the RB Test Mode Call Origination to CELL_DCH procedure, the test set receives Radio Bearer Setup Fail message from the UE.
+237 TD-SCDMA call processing error; No response to Location Update Accept | During the Location Update Procedure, the test set does not receive the TMSI Reallocation Complete message from the UE within the required timer.
+238 TD-SCDMA call disconnected; No response to RLC Poll. | This is for information only.
+239 TD-SCDMA call disconnected; RLC Reset Procedure Failed. | This is for information only.
+240 TD-SCDMA call processing error; Operation not allowed due to conflict H-RNTIs | See H-RNTI Parameters.
+241 TD-SCDMA call processing error; The simultaneous services feature is not supported | The E1969A doesn’t support the simultaneous services


+500 through +599 Error Message Descriptions

Last updated: March 31, 2010

A device-specific error indicates that the instrument has detected an error that occurred because some operations did not properly complete, possibly due to an abnormal hardware or firmware condition. For example, an attempt by the user to set an out of range value will generate a device specific error.

These are hardware errors generated by the core instrument.

Error Message | Description
+502 TD-SCDMA Test Application hardware failure; Hardware doesn’t support TD-SCDMA format. Module; BBB. See www.agilent.com/find/8960upgrades for additional information | This error message is displayed when the “BBB” board is missing or unsupported. The "BBB" could be “Baseband Generator 1 Board”, “Analog LSS Board”, “Digital Mother Board”, “RTI Board” or “Digital LSS Board”.


+700 through +799 Error Message Descriptions

Last updated: March 31, 2010

A device-specific error indicates that the instrument has detected an error that occurred because some operations did not properly complete, possibly due to an abnormal hardware or firmware condition. For example, an attempt by the user to set an out of range value will generate a device specific error.

These are non-core measurement errors generated by the core instrument.

Error Message | Description
+701 TD-SCDMA measurement failure; Channel power measurement is not responding | The error message is generated when a measurement cannot be instantiated, or a problem occurs when attempting to control the measurement’s hardware.
+702 TD-SCDMA measurement failure; Adjacent channel leakage ratio measurement is not responding | The error message is generated when a measurement cannot be instantiated, or a problem occurs when attempting to control the measurement’s hardware.
+703 TD-SCDMA measurement failure; Waveform quality measurement is not responding | The error message is generated when a measurement cannot be instantiated, or a problem occurs when attempting to control the measurement’s hardware.
+704 TD-SCDMA measurement failure;Spectrum emission mask measurement is not responding | The error message is generated when a measurement cannot be instantiated, or a problem occurs when attempting to control the measurement’s hardware.
+705 TD-SCDMA measurement failure;Closed loop power measurement is not responding | The error message is generated when a measurement cannot be instantiated, or a problem occurs when attempting to control the measurement’s hardware.
+706 TD-SCDMA measurement failure; Occupied bandwidth measurement is not responding | The error message is generated when a measurement cannot be instantiated, or a problem occurs when attempting to control the measurement’s hardware.
+707 TD-SCDMA measurement failure; Dynamic power measurement is not responding | The error message is generated when a measurement cannot be instantiated, or a problem occurs when attempting to control the measurement’s hardware.
+708 TD-SCDMA measurement failure; Loopback Bit Error Rate measurement is not responding | The error message is generated when a measurement cannot be instantiated, or a problem occurs when attempting to control the measurement’s hardware.
+709 TD-SCDMA measurement failure; Transmit on off power measurement is not responding | The error message is generated when a measurement cannot be instantiated, or a problem occurs when attempting to control the measurement’s hardware.
+730 TD-SCDMA measurement failure;Closed loop power measurement is not allowed due to incorrect operating mode | A measurement has been requested to run in an operating mode in which it is not available.
+731 TD-SCDMA measurment failure; Close loop power measurement not allowed due to incorrect call status | A measurement has been requested to run in an operating mode in which it is not available.
+732 TD-SCDMA measurment failure; Dynamic power measurement not allowed due to incorrect operating mode | A measurement has been requested to run in an operating mode in which it is not available.
+733 TD-SCDMA measurement failure; Loopback Bit Error Rate measurement not available in this configuration | The Loopback BER measurement is initiated in an unsupported configuration.
+734 TD-SCDMA measurement failure; Block Error Rate measurement not available in this configuration | The BLER measurement is initiated in an unsupported configuration.
+735 TD-SCDMA measurement failure; HSDPA Block Error Ratio measurement not available in this configuration | The HSDPA Block Error Ratio measurement can be run only in Active Cell operating mode, when the Paging Service type is RB Test Mode and Channel type is 12.2k RMC + HSDPA;
+736 TD-SCDMA measurement failure; Open loop power measurement not available in this configuration | The Open loop power measurement is only available when the operating mode is Active Cell and the call status is Idle.
+737 TD-SCDMA measurement failure; Close loop power measurement not allowed due to incorrect channel type | The Close loop power measurement can not be run with 12.2k + HSDPA channel type.
+738 TD-SCDMA measurement failure; Dynamic power measurement not allowed due to incorrect channel type | The dynamic power measurement is not allowed if the Channel Type is set to 12.2k RMC + HSDPA.
+739 TD-SCDMA measurement failure; Out-of-Synch Handling of Output Power measurement not available in this configuration | See Required Initial Conditions for the conditions that are required to run Out-of-Synch Handling of Output Power measurement.
+740 TD-SCDMA measurement waning; UL CL Power Control is not set to ALL_UP | The UL CL Power Ctrl Mode must be set to ALL Up bits when running measurements such as Out-of-Synch Handling of Output Power.
+741 TD-SCDMA measurement warning; UE Call Drop Timer setting too short. | See Operating Considerations.
+742 TD-SCDMA measurement failure; HSDPA Reporting of Channel Quality Indicator measurement not available in this configuration. | See Reporting of Channel Quality Indicator (CQI) Measurement Description for the conditions that the measurement is allowed to run.
+743 TD-SCDMA measurement failure; Fast Device Tune measurement setup is not correct. Refer to your documentation CD or go to www.agilent.com/find/8960 for correct setup steps |
+744 TD-SCDMA measurement failure; Fast Device Tune measurement MS Tx/Rx frequency step sequence table start index + frequency step count must be less than or equal to 40 | See Fast Device Tune Measurement Parameters.
+745 TD-SCDMA measurement failure; Fast Device Tune measurement MS Tx/Rx power step sequence table start index + power step count must be less than or equal to 40 | See Fast Device Tune Measurement Parameters.
+746 TD-SCDMA measurement failure; Fast Device Tune measurement MS Tx/Rx frequency values in use must not be NAN | This error message is returned if the Fast Device Tune Measurement Parameters are not correctly set.
+747 TD-SCDMA measurement failure; Fast Device Tune measurement MS Tx/Rx power levels in use must not be NAN | This error message is returned if the Fast Device Tune Measurement Parameters are not correctly set.
+748 TD-SCDMA measurement failure; Fast Device Tune measurement MS Tx frequency values in use are out of range | See the GPIB commands for the Fast Device Tune Measurement Parameters for the valid range.
+749 TD-SCDMA measurement failure; Fast Device Tune measurement MS Rx frequency values in use are out of range | See the GPIB commands for the Fast Device Tune Measurement Parameters for the valid range.
+750 TD-SCDMA measurement failure; Fast Device Tune measurement MS Tx power levels in use are out of range | See the GPIB commands for the Fast Device Tune Measurement Parameters for the valid range.
+751 TD-SCDMA measurement failure; Fast Device Tune measurement MS Rx power levels in use are out of range | See the GPIB commands for the Fast Device Tune Measurement Parameters for the valid range.
+752 TD-SCDMA measurement failure; Fast Device Tune measurement setup is not correct. The number of frequency steps * the number of power steps must be less than or equal to 400 | See Fast Device Tune Measurement Parameters.
+753 TD-SCDMA measurement failure; Fast Device Tune measurement the first step of MS Rx power level not > 40 dB below the first step of MS Tx power level | See Input Signal Requirements.


Manual User Error Messages

These messages are intended to be displayed on the manual user interface only.

Error Message | Description
MUI 340 TD-SCDMA measurement warning; Channel power measurement has been closed | This error message is displayed for information purposes only
MUI 341 TD-SCDMA measurement warning; Adjacent channel leakage ratio measurement has been closed | This error message is displayed for information purposes only
MUI 342 TD-SCDMA measurement warning; Waveform quality measurement has been closed | This error message is displayed for information purposes only
MUI 343 TD-SCDMA measurement warning; Spectrum emission mask measurement has been closed | This error message is displayed for information purposes only.
MUI 344 TD-SCDMA measurement warning; Closed loop power control measurement has been closed | This error message is displayed for information purposes only.
MUI345 TD-SCDMA measurement warning; Occupied bandwidth measurement has been closed | This error message is displayed for information purposes only.
MUI346 TD-SCDMA measurement warning; Dynamic power measurement has been closed | This error message is displayed for information purposes only.
MUI347 TD-SCDMA measurement warning; Loopback Bit Error Rate measurement has been closed | This error message is displayed for information purposes only.
MUI348 TD-SCDMA measurement warning; Transmit on off power measurement has been closed | This error message is displayed for information purposes only.
MUI349 TD-SCDMA measurement warning; Block Error Ratio measurement has been closed | This error message is displayed for information purposes only.
MUI350 TD-SCDMA measurement warning; HSDPA Block Error Ratio measurement has been closed | This error message is displayed for information purposes only.
MUI351 TD-SCDMA measurement warning; Open loop power measurement has been closed | This error message is displayed for information purposes only.
MUI352 TD-SCDMA measurement warning; Out-of-Synch Handling of Output Power measurement has been closed | This error message is displayed for information purposes only.
MUI353 TD-SCDMA measurement warning; HSDPA Reporting of Channel Quality Indicator measurement has been closed | This error message is displayed for information purposes only.
MUI354 TD-SCDMA measurement warning; Fast Device Tune measurement has been closed | This error message is displayed for information purposes only.


Integrity Indicator

Description

The test set can evaluate its own performance and make a determination as to the validity of a measurement result. The test set evaluates the conditions surrounding a measurement and reports to the user its evaluation of these conditions in a parameter called the measurement integrity indicator. A measurement integrity indicator value is returned for every completed measurement. It is recommended that the user take advantage of this feature in every measurement.

The returned value defines whether or not a problem was encountered by the measurement process. It is not, however, guaranteed to be the only or root cause of the measurement problem. This is because some of the conditions surrounding a measurement may interact, and the test set may have insufficient information to determine the root cause of the measurement problem. However, in most cases, the value returned is the most likely cause of the problem.

Not all of the integrity indicator values are available for each measurement or test application, if a value doesn't apply it will not be available.

Integrity Indicator Values

  • 0: Normal: Indicates the measurement completed successfully without error and the result is accurate.

  • 1: No Result Available: Indicates that there is no measurement result and returns NAN (not a number).

  • 2: Measurement Timeout: Indicates that a measurement has timed out. The measurement timeout state must be set to ON.

  • 4: Hardware Error: Indicates that a hardware failure has occurred. These include failures such as a phase lock loop out-of-lock, defective DSP samplers, or power detectors that can not be calibrated.

  • 5: Over Range: Indicates that the input signal is over range. The amplitude of the device-under test's (DUT's) signal is causing the voltage at a DSP sampler to be above its maximum input level or the frequency is too high or the voltage measured is beyond the maximum voltmeter range, either positive or negative.

  • 6: Under Range: Indicates that the input signal is under range. The amplitude of the DUT's signal is not high enough for the DSP sampler to produce accurate results with the measurement algorithm.

  • 8: Trigger Early or Fall Early: Indicates that the DUT's burst amplitude fell prematurely or, due to an early trigger (early relative to a transmitted burst) the measurement sampling operation terminated before the falling edge of the burst.

  • 9: Trigger Late or Rise Late: Indicates that either the rising edge of the DUT's burst was late or, due to a late trigger (late relative to a transmitted burst) the measurement sampling operation didn't start until after the rising edge of the transmitted burst.

  • 11: Sync Not Found: The given midamble is not found. Possible reasons include: frequency is out of range, trigger location is out of range, or the midamble ID and/or shift is not correct.

  • 12: Oven Out of Range: Indicates that a temperature controlled oven (other than the internal timebase oven) is outside of its operating range. The power meter's oven is checked and its condition reported with this value. (The internal timebase generates a temporary error message (out of lock) that is sent to the system error queue and the display. This is not an integrity indicator value, it is an error message.)

  • 13: Unidentified Error: Indicates errors which are not covered by the other integrity values. Examples include: parameter errors, algorithm memory errors (too many measurements), measurements unavailable (unable to control), autorange unable to converge, default calibration data used.

  • 19: Uncalibrated Due To Temperature: Indicates that the ambient temperature changes more than 10 degrees C since latest calibration, when attempting a Channel Power Measurement.

  • 20: Potential Receiver Saturation: Indicates that an input signal immediately prior to the measured input was high enough to potentially saturate the receiver hardware.

  • 21: Parameter Error: Indicates that a measurement setup parameter has been set in a way that gives invalid measurement results.

  • 22: Unsupported Configuration: Indicates that some parameter, other than a measurement setup parameter has been set so that it causes an invalid measurement result. Typically this would be a base station emulator parameter.

  • 23: Call Processing Operation Failed: Indicates that a call processing operation, (base station emulator) needed in the course of making the measurement could not complete.

  • 24: Calibration Error

  • 25: Burst Not Found

  • 26: Missing Loopback Packets or AT Buffer Overflow: Indicates that Loopback Packets are missing, or the Access Terminal had an overflow. This integrity indicator was added for the 1xEV-DO Packet Error Rate measurement.

  • 27: No AT Loopback Packets: Indicates that no Loopback Packets from the Access Terminal were detected for a period of several seconds.

  • 28: Questionable MS-to-Cell Data: Indicates that a condition exists on the uplink or reverse channel that has caused the measurement results to be in question.

  • 30: Trigger Missed: Indicates one or more triggers were missed during the measurement.

  • 32: Measurement Not Licensed: Indicates that the required feature license for the measurement is not present. See http://www.agilent.com/find/8960upgrades for details on hardware and software requirements to run a specific feature.


Release Notes

E1969A TD-SCDMA_GSM Fast Switch Test Application Revision Information

Last updated: April 19, 2012

This page describes the features in the Agilent Technologies E1969A TD-SCDMA_GSM Test Application releases. This document contains the original features, as well as enhancements that have been added over time.

The most current version of this user's guide is available online at http://wireless.agilent.com/rfcomms/refdocs/tdscdma.

Select the appropriate link below to view the required release.

A.05.14 - April 2012

A.05.12 - March 2012

A.04.07 - March 2011

A.03.12 - December 2010

A.02.08 - July 2010

A.01.08 - December 2009 (original release)

A.05.14- April 2012

This is a maintenance release. The features offered in this release are identical to those offered in the A.05.12 - March 2012.

A.05.12 - March 2012

The following sections list the brief descriptions of the new features introduced in this release, and the links to their details.

Hardware Requirements

This release has specific hardware requirements. Test sets with serial number <MY5210 require a HW upgrade to run this release.

To determine if a hardware upgrade is required for this release, please review the hardware requirement information at:

http://www.agilent.com/find/8960upgrades

Base Station Emulation

  • HSDPA Packet Service data connection. (An additional feature license is required to enable this functionality in the licensed test application).

  • See HSDPA PS Data Setup and Data Channel for the parameters

  • See Protocol Logging on how to capture the protocol messages exchanged between the test set and the UE

  • See Data Throughput Monitor on how to monitor the OTA and IP layer throughput

  • See How Do I Test Packet Data Performance of the UE on how to set up a packet data connection for testing

  • CELL_FACH RRC status. See RB Test Mode RRC State. (An additional Revision to Current (R2C) license is required to enable this functionality in a licensed test application).

  • HSUPA RB test mode. (An additional feature license is required to enable this functionality in the licensed test application).

  • FRC Channel configurations defined in 34.122 Annex C.6.1.2.1 – C.6.1.2.3. See HSUPA Parameters

  • UE’s E-DCH Category and HSUPA real-time results display. See HSUPA Information

  • HSUPA frequency handover using PCR. See Handovers.

Measurements

  • Data Throughput Monitor

  • Out-of-Synchronization of Output Power (OOS) Measurement enhancement: allows you to test OOS measurement for discontinuous transmission (by setting Transmission Mode).

A.04.07 - March 2011

The following sections list the brief descriptions of the new features introduced in this release, and the links to their details.

Hardware Requirements

To determine if a hardware upgrade is required for this release, please review the hardware requirement information at:

http://www.agilent.com/find/8960upgrades

Base Station Emulation

  • HSDPA enhancements (An additional Revision to Current (R2C) license is required to enable this functionality in a licensed test application).

  • Support Variable Reference Channels (VRC) for HSDPA performance testing. When HS-DSCH Config is set to VRC, the test set varies the downlink properties according to the UE's indication. This option makes it possible to test 3GPP TS 34.122 9.3.2A to 9.3.2E. See HSDPA Parameters and 3GPP TS34.122 9.3.2 HS-DSCH throughput for Variable Reference Channels.

  • Point to Point SMS: The test set supports the following point-to-point SMS over either CS (Circuit Switched) or PS (Packet Switched) domain: Mobile Terminated SMS (MT SMS) and Mobile Originated SMS (MO SMS). See Short Message Service. (An additional Revision to Current (R2C) license is required to enable this functionality in a licensed test application).

  • Extend the Channel Type to allow for multi-rate RMC: 64k RMC, 64k UL / 144k DL AM RMC and 64k UL / 384k DL AM RMC. These new options are only used under active cell operating mode. (An additional Revision to Current (R2C) license is required to enable this functionality in a licensed test application).

  • TD-SCDMA downlink midamble scheme selection (default or common). See TD-SCDMA DL Dpchannel Midamble Mode.

Measurements

  • New HSDPA measurements (An additional Revision to Current (R2C) license is required to enable this functionality in a licensed test application):

  • Reporting of Channel Quality Indicator Measurement

  • HS-SCCH Detection Performance measurement. The detection performance of the HS-SCCH is determined by P(Em). When HS-DSCH Config is set to HSSCCH Detection, P(Em) is available by performing the HSDPA Block Error Ratio (HBLER) measurement. See 3GPP TS34.122 9.3.4 HS-SCCH Detection Performance for the manual operations to perform 3GPP TS34.122 9.3.4.

  • Add Out-of-Synchronization of Output Power (OOS) Measurement for continuous transmission (An additional Revision to Current (R2C) license is required to enable this functionality in a licensed test application).

  • Add Fast Device Tune Measurement (An additional feature license is required to enable this functionality in the licensed test application).

A.03.12 - December 2010

The most current version of this user's guide is available online at http://wireless.agilent.com/rfcomms/refdocs/tdscdma.

This firmware release provides you with the following functionalities: HSDPA RMC call setup, system handover, AMR voice call, etc. Also there are some new measurements added.

An additional feature license is required to enable the HSDPA functionalities in this test application.

The following sections list the feature descriptions and the links to their details.

Hardware Requirements

To determine if a hardware upgrade is required for this release, please review the hardware requirement information at:

http://www.agilent.com/find/8960upgrades

Base Station Emulation

  • Support for HSDPA in active cell operating mode. (An additional feature license is required to enable this functionality in the licensed test application).

  • Allows you to set up a HSDPA RB test mode call over either PS or PS/CS domain. See Channel Type, HSDPA Parameters, HSDPA Channel Configuration Information and Downlink Code Channel Levels Screen for more HSDPA configurations. See Establish an HSDPA Connection on how to establish an HSDPA connection manually.

  • HS-DSCH throughput tests defined in 3GPP TS 34.122 9.3.1A to 9.3.1E are supported by configuring the RMC Type. BLER and ACK/NACK results are updated in real-time on the HSDPA Real Time Results Information screen.

  • HSDPA inter-frequency handover can be performed by Physical Channel Reconfiguration.

  • System Handover: Allows you to handover to a GSM voice call from either TD-SCDMA AMR or TD-SCDMA RB test mode. See also System Handover on how to perform a system handover manually. (An additional Revision to Current (R2C) license is required to enable this functionality in a licensed test application).

  • UE Measurement Control: Supports for the UE reported P-CCPCH RSCP (Received Signal Code Power). (An additional Revision to Current (R2C) license is required to enable this functionality in a licensed test application)

  • Support for SC/MC handoff by Physical Channel Reconfiguration. (An additional Revision to Current (R2C) license is required to enable this functionality in a licensed test application)

  • Add the following new timers: T308 RRC Conn Release Comp Retransmit Timer, N308 RRC Conn Release Comp Max Retransmits and T3212 Periodic Location Update Timer.

  • AMR Voice Call: You can make an AMR voice call from either the test set (by setting the Paging Service Type to AMR Voice) or the mobile station. Eight AMR radio access bearers can be set, see Voice Call. Supports of the AMR source to be echo only. (An additional Revision to Current (R2C) license is required to enable this functionality in a licensed test application)

Measurements

  • Enhance the following Tx measurements to support HSDPA: Channel Power, Waveform Quality, Adjacent Channel Leakage Ratio (ACLR), Spectrum Emission Mask (SEM), Occupied Bandwidth (OBW) and Transmit ON/OFF Power (TOOP).

  • Add the following HSDPA Rx measurement: HSDPA Block Error Ratio (HBLER) Measurement. See also SETup:THBLerror and FETCh:THBLerror.

  • Add Open Loop Power Control (OLPC) Measurement. (An additional Revision to Current (R2C) license is required to enable this functionality in a licensed test application)

  • Add Block Error Ratio (BLER) Measurement. (An additional Revision to Current (R2C) license is required to enable this functionality in a licensed test application)

  • Add a new parameter, Synchronization Mode, to the dynamic power measurement. See Dynamic Power (DPOW) Measurement Parameters.

A.02.08 - July 2010

This firmware release provides you with call processing functionalities, including to set up a RMC 12.2 kbps call connection, physical layer reconfiguration, etc. Some new or enhanced measurements are also supported.

An additional feature license is required to enable the call processing functionalities in this test application.

The following sections provide descriptions of TD-SCDMA features introduced with this release.

Hardware Requirements

To determine if a hardware upgrade is required for this release, please review the hardware requirement information at:

http://www.agilent.com/find/8960upgrades

Base Station Emulation

  • Add the following operating modes:

  • Active Cell Operating Mode: allows you to make a signalling connection between the test set (emulating a base station in a network) and a UE.

  • Cell Off Operating Mode: allows you to change the parameters that cannot be changed during Active Cell operation but used for call processing.

  • Originate/End Call: allows you to originate or end a RB Test Mode service call from the test set. See Paging Parameters, Cell Parameters and UE Timer and Constant Parms on the related parameters.

  • Support of downlink channel level settings in Active Cell operating mode. See Generator Info.

  • Physical Channel Reconfiguration: allows you to perform frequency handover or power control step size change while on a connection.

  • Support for clearing UE reported information by pressing the Clear UE Info button or sending the CALL:MS:REPorted:CLEar[:ALL][:SELected] command.

  • Security Operation (see Security Information): allows you to specify whether to perform security procedures during some call processing operations, and what kind of security procedures to be performed.

  • Add the UE Transmit Power Control parameters used to determine the UE open loop transmit power.

  • Provide uplink closed loop power control in Active Cell operating mode, which allows the test set to send power control bits to the UE according to the uplink signal level and the target power. See UL CL Power Control.

  • Add the following TD-SCDMA Test mode parameters: UL DPCH TFCI Control and UL DPCH TFCI.

Measurements

  • Closed Loop Power Control (CLPC) Measurement enhancement: Support for CLPC measurement operating in Active Cell operating mode. See Closed Loop Power Control (CLPC) Measurement.

  • Occupied Bandwidth (OBW) Measurement (An additional Revision to Current (R2C) license is required to enable this functionality in a licensed test application)

  • Dynamic Power (DPOW) Measurement (An additional Revision to Current (R2C) license is required to enable this functionality in a licensed test application)

  • Transmit ON/OFF Power (TOOP) Measurement: Please be noted that this measurement has specific Hardware Requirements. (An additional Revision to Current (R2C) license is required to enable this functionality in a licensed test application)

  • Loopback Bit Error Ratio (BER) Measurement (An additional Revision to Current (R2C) license is required to enable this functionality in a licensed test application)

A.01.08 - December 2009 (original release)

This is the original release of the Agilent E1969A TD-SCDMA GSM fast switch test application. An additional feature license is required to enable all TD-SCDMA test mode functionalities in this test application.

The following sections provide descriptions of TD-SCDMA features introduced with this release.

Hardware Requirements

To determine if a hardware upgrade is required for this release, please review the hardware requirement information at:

http://www.agilent.com/find/8960upgrades

Base Station Emulation

The test set supports to send a configurable downlink signal that the UE can synchronize to in order to transmit a corresponding uplink signal. Downlink signal parameters that can be configured include the following settings:

  • TD-SCDMA Test operating mode: TD-SCDMA Test Mode provides downlink signal that emulates a subset of the layer 1 features of a TD-SCDMA Node B without any signalling information. See Operating Mode.

  • CW signal source: the test set operates like a signal generator and provides any one of three test signals: CW (no modulation), AM (fixed 56% amplitude modulation) and DSB-SC (dual side-band suppressed carrier).

  • Downlink Channel Configuration. See Channel Type, DL DTCH Data, Channel Config Info, DL TFCI Patten, DL PICH Data and Channel Config Info etc.

  • Uplink Channel Configuration: See Channel Config Info.

  • Synchronisation Codes: allow you to set synchronisation codes for Node B, see Scrambling Code.

  • Uplink Channel Power Control: see UL CL Power Control.

  • UE Target Tx Power: allow you to set UL DPCH power, see MS Target Power.

  • Measurement Receiver Control over power and frequency: allow you to control the test set's receiver frequency and attenuation settings, see Receiver Control.

Measurements

  • Channel Power Measurement

  • Waveform Quality Measurement

  • Adjacent Channel Leakage Ratio (ACLR) Measurement

  • Spectrum Emission Mask (SEM) Measurement

  • Frequency Stability Measurement

  • Closed Loop Power Control (CLPC) Measurement

Other features

  • AWGN: provide AWGN to emulate interference from other cells, see AWGN Power.

  • Audio Generator

  • Audio Analyzer

  • Amplitude Offset can be set up to 60 offsets. (An additional feature license is required to enable the amplitude offset 20 to 60 in a licensed test application)

  • FM Broadcast: allows to test the mobile station with full range of FM (frequency modulated) Broadcast signals.

  • Single channel GPS source :allows the test set to generate GPS signals to calibrate the GPS receiver of the mobile. (An additional feature license is required to enable this functionality in a licensed test application)

  • Save/Recall registers: allows you to store the test set's current settings to up 10 registers and retrieve them later, eliminating the task of reconfiguring the test set. See Save and Recall Registers. (An additional Revision to Current (R2C) license is required to enable the register 6 to 10 or setting register names in a licensed test application)

  • Spectrum Monitor: The Spectrum Monitor measurement allows you to find, identify and measure transmitted signals from your UE (mobile phone). It can also be used for spurious measurements in the transmit band.

  • IPv6 Support: the test set supports to be set up an IPv6 address.

  • Help Mode


HSDPA Parameters

Last updated: March 10, 2010

This section is only applicable to the feature-licensed test application.

HSDPA RB Test Mode Setup

HSDPA PS Data Setup

MAC-(e)hs Parameters

H-RNTI Parameters

HSDPA RB Test Mode Setup

  • HS-DSCH Config

You can choose one of the three HS-DSCH configurations to do different HSDPA performance tests in 3GPP TS 34.122 9.3. If RMC is selected, the test set will set the downlink properties according to RMC Type, and you can use this option to test 9.3.1A to 9.3.1E; If VRC is selected, the test set will vary the downlink properties according to the UE's indication, and you can use this option to test 9.3.2A to 9.3.2E. The HSSCCH Detection option allows you to perform 9.3.4. See HSDPA Channel Configuration Information for the detailed downlink channel configuration for each HS-DSCH configuration.

GPIB Command: CALL:HSDPa:SERVice:RBTest:HSDSchannel:CONFig[:TYPE]

  • RMC Type

When HS-DSCH Config is RMC, this parameter determines the HSDPA RMC configuration that is used to perform the HS-DSCH throughput test as in 3GPP TS 34.122 9.3.1A to 9.3.1E.

Each RMC is associated with a particular UE class/category and defines a static configuration at the transport channel and physical channel level as below:

HSDPA RMC Configuration

RMC Configuration | Modulation | HS-DSCH TSs | HS-PDSCH codes | No. of HARQ | IR Buffer Allocation | TB Size | Throughput (kbps)
HSDPA RMC for 0.5M UE Class | QPSK | 2 | 10 (SF16) | 4 | implicit | 996 | 199.2
HSDPA RMC for 1.1M UE Class | QPSK/16QAM | 2 | 10/12 (SF16) | 4 | implicit | 995/2893 | 199.0/578.6
HSDPA RMC for 1.6M UE Class | QPSK/16QAM | 3 | 10/12 (SF16) | 4 | implicit | 1787/3173 | 357.4/634.6
HSDPA RMC for 2.2M UE Class | QPSK/16QAM | 4 | 10/12 (SF16) | 4 | implicit | 2695/3911 | 539/782.2
HSDPA RMC for 2.8M UE Class | QPSK/16QAM | 5 | 10/12 (SF16) | 4 | implicit | 3105/6393 | 621/1278.6
2.8M UE Class Max Throughput* | 16QAM | 5 | 1 (SF1) | 4 | implicit | 14043 | 2808.6

* The option of 2.8M UE Class Max Throughput is not standard-specified configuration.

This setting cannot be changed in Active Cell operating mode and the Call Status is not Idle.

GPIB Command: CALL:HSDPa:SERVice:RBTest:RMC:TYPE

  • RMC MAC-d PDU Size

This setting determines the MAC-d PDU size that is used for MAC-hs PDU. You can set it to 336 bits, 656 bits, or Maximize. When Maximize is selected, it means that the MAC_d PDU size is the smaller one of the largest PDU size fit for the MAC-hs PDU and 5000 bits.

This setting cannot be changed in Active Cell operating mode and the Call Status is not Idle.

GPIB Command: CALL:HSDPa:SERVice:RBTest:RMC:MACD:PDUSize

  • CN Domain

Non-HSDPA RB test mode connections are always established using CS domain (Core Network Domain) entities. In contrast, an HSDPA RB test mode connection can be established using PS domain or CS+PS domain.

  • If CN Domain is set to PS Domain, the 12.2k RMC connection is established on the PS domain. See RB Test Mode HSDPA PS Domain Call Setup Procedure. The PS domain is used to establish the RMC and FRC.

  • If CN Domain is set to CS/PS Domain, the HSDPA RMC connection is established as shown in RB Test Mode HSDPA CS/PS Domain Call Setup Procedure. The CS domain is used to establish the RMC and the PS domain is used to establish the FRC.

This setting cannot be changed in Active Cell operating mode and the Call Status is not Idle.

GPIB Command: CALL:HSDPa:SERVice:RBTest:CNDomain

  • HS-DSCH Data Pattern

This parameter determines the data pattern that is sent in each HS-DSCH transport block.

GPIB Command: CALL:HSDPa:SERVice:RBTest:HSDSchannel:DATA?

HSDPA PS Data Setup

  • PS Data HS-DSCH Configuration Type

This parameter controls how the HS-DSCH is configured.

  • If it is set to User Defined CQI, the test set uses PS Data User Defined Modulation Type and PS Data User Defined TB Index to configure the HS-DSCH.

  • If it is set to UE Reported CQI, the test set uses UE reported CQI to configure the HS-DSCH, except that:

  • If the UE reported CQI is smaller than the lower limit of CQI (TB Index) calculated based on MAD-d PDU size, the lower limit of CQI(TB Index) is used to configure the HS-DSCH;

  • If the UE reported CQI is greater than the CQI upper limit, the upper limit of CQI(TB Index) is used to configure the HS-DSCH.

GPIB Command: CALL:HSDPa:SERVice:PSData:HSDSchannel:CONFig[:TYPE]

  • PS Data MAC-d PDU Size

This parameter determines MAC-d PDU size that is used on DTCH for a HSDPA PS data connection. This DTCH is the logical channel that carries the downlink user traffic data (i.e. the IP datagrams).

This setting is only allowed to be changed when call status is Idle.

GPIB Command: CALL:HSDPa:SERVice:PSData:MACD:PDUSize

  • PS Data Number of HS-DPSCH Timeslots

Sets the number of HS-PDSCH timeslots transmitted by the test set. The valid range of this setting depends on PS Data Start of HS-PDSCH Timeslot.

GPIB Command: CALL:HSDPa:SERVice:PSData:HSPDschannel:TSNumber

  • PS Data Start of HS-PDSCH Timeslot

This parameter determines the start timeslot for the HS-PDSCH allocation. This setting, together with PS Data Number of HS-DPSCH Timeslots, determines the valid HS-PDSCH channels that are used by the test set.

GPIB Command: CALL:HSDPa:SERVice:PSData:HSPDschannel:TSSTart

  • PS Data HS-PDSCH OVSF

This parameter determines the OVSF code for the HS-PDSCH channel. If it is set to TS1, then PS Data Number of HS-PDSCH Channel Codes is not available.

GPIB Command: CALL:HSDPa:SERVice:PSData:HSPDschannel:OVSF

  • PS Data Number of HS-PDSCH Channel Codes

This parameter is only available when PS Data HS-PDSCH OVSF is set to SF16.

This parameter determines the number of channel codes are used for HS-PDSCH when PS Data HS-PDSCH OVSF is set to SF16.

GPIB Command: CALL:HSDPa:SERVice:PSData:HSPDschannel:CCODe:NUMBer

  • PS Data DL DPCH/HS-SCCH Timeslot

This parameter determines how to allocate the downlink DPCH and HS-SCCH channels.

  • If TS0 is selected, the downlink channel codes and power levels (except DPCH) are configured as in HSDPA RMC mode;

  • If TS6 is selected, the downlink channel codes and power levels (except DPCH) are configured as in HSDPA HS-SCCH detection mode. See Generator Info and Channel Config Information.

This setting is only allowed to be changed when call status is Idle.

GPIB Command: CALL:HSDPa:SERVice:PSData:DOWNlink:DPCHannel:TSLot

  • PS Data User Def Modulation Type

This parameter is only applicable when PS Data HS-DSCH Configuration Type is set to User Defined CQI.

GPIB Command: CALL:HSDPa:SERVice:PSData:UDEFined:MODulation[:TYPE]

  • PS Data User Def Transport Block Size Index

This parameter is only applicable when PS Data HS-DSCH Configuration Type is set to User Defined CQI.

GPIB Command: CALL:HSDPa:SERVice:PSData:UDEFined:TBSize:INDex

MAC-(e)hs Parameters

  • Number of Transmissions

This parameter determines the number of times a MAC-hs HARQ process will attempt to transmit a particular data block from the MAC-hs queue.

GPIB Command: CALL:HSDPa:MACHs:NTRans

  • RV Sequence

This parameter determines the Redundancy Version (RV) parameter that the test set shall use for each transmission of a particular block. The first element in the list is the RV parameter that the test set will use for the first transmission of a block, the second element is for the second transmission of the same block etc.

You may specify up to eight integer values (between 0 and 7), but the number of RV parameters actually used by the test set is determined by the Number of Transmissions setting (the RV parameters at the end of the sequence are not used if the Number of Transmissions setting is less than the number of RV parameters in the sequence). If you enter fewer than eight values for the RV sequence, the test set fills the remaining values with zeroes.

GPIB Command: CALL:HSDPa:MACHs:RVSequence

  • MAC-hs Window Size

This parameter determines the value of the MAC-hs window size that is signaled to the UE during the call setup procedure.

This setting cannot be changed in Active Cell operating mode and the Call Status is not Idle.

GPIB Command: CALL:HSDPa:MACHs:WSIZe[:VALue]

  • MAC-hs T1

This parameter determines the value of the MAC-hs T1 timer that is signaled to the UE. It is signaled to the UE in the Radio Bearer Setup message in the 25.331 s10.3.5.1a "Added or reconfigured MAC-d flow" information element.

This setting cannot be changed in Active Cell operating mode and the Call Status is not Idle.

GPIB Command: CALL:HSDPa:MACHs:T1

  • statDTX Reception Behavior

This parameter determines how the test set handles the statDTX when it was expecting an ACK or NACK on the HS-SICH.

  • Handle as ACK: When a statDTX occurs, the test set transmits a new block from the MAC-hs transmit queue using the first entry in the RV Sequence and resets the transmission counter to one.

  • Handle as NACK: When a statDTX occurs, if the transmission counter is less than the Number of Transmissions setting, the test set transmits the same block using the next entry in the RV Sequence and increments the transmission counter by one. If the transmission counter equals the Number of Transmissions setting, then the Handle as ACK process is followed instead.

  • Handle as statDTX: When a statDTX occurs, the test set transmits the same block using the same entry in the RV Sequence and does not increment the transmission counter.

This setting does not affect the HSDPA throughput or the HSDPA BLER results.

GPIB Command: CALL:HSDPa:MACHs:SDTX:RBEHavior

H-RNTI Parameters

  • Primary H-RNTI (Hex)

This parameter determines the primary H-RNTI that is used on the HS-SCCH. This is the ID that the test set uses when it wishes to transmit data to the UE in Active Cell operating mode.

This setting cannot be changed in Active Cell operating mode and the Call Status is not Idle.

GPIB Command: CALL:HSDPa:HRNTi[:PRIMary]

  • HS-SCCH2-4 H-RNTIs (Hex)

These are the H-RNTIs that the test set does not transmit data to. The default values are set to match 3GPP TS34.122 s9.3.4 HS-SCCH Detection Performance measurement.

Each HS-SCCH H-RNTI should not be set identical to other HS-SCCH H-RNTIs, nor should it be identical with the Primary H-RNTI (Hex).

GPIB Command: CALL:HSDPa:HRNTi:ALTernate:HSSCCH2|3|4


HSUPA Parameters

HSUPA RB Test Mode Setup

  • FRC Type

This is defined according to 34.122 Annex C.6.1.2.1 to C.6.2.1.3.

GPIB Command: CALL:HSUPa:SERVice:RBTest:FRC:TYPE

  • E-AGCH Absolute Grant Value

This parameter controls the next absolute grant that the test set will transmit to the UE on E-AGCH during a HSPA connection. The UE should interpret this value according to the 3GPP 25.222 s4.10.1.1 Table 26A. The default value is set to give the UE full grant to entire uplink.

GPIB Command: CALL:HSUPa:SGRant:ABSolute:VALue

  • E-HICH Behavior

  • If it is set to All Acks, the test set will always send an Ack on the E-HICH regardless of whether the block passes its CRC check (including the case that test set doesn’t detect the E-PUCH channel from UE when it expects. In TD-SCDMA HSUPA, when the network sends an AG to UE, UE will always response on E-PUCH even when it is unable to send data from MAC-d flows. SI will be sent in this case).

  • If it is set to All Nacks, the test set will always send a Nacks regardless of whether the block passes its CRC check (also including the case mentioned above).

GPIB Command: CALL[:CELL]:EHIChannel:BEHavior

  • E-DCH Max Number of Retransmission

This setting controls the maximum number of retransmissions a HARQ process in the UE that will perform for a given block of data before giving up and moving onto a new block of data. The default value is in line with 3GPP TS34.108 s9.1.2.

This setting can only be changed while call status is idle.

GPIB Command: CALL:HSUPa:SERVice:RBTest:HARQ:RETRans:MAXimum

  • E-DCH Retransmission Timer

The default value is in line with 3GPP TS34.108 s9.1.2.

This setting can only be changed while call status is idle.

GPIB Command: CALL:HSUPa:SERVice:RBTest:HARQ:RETRans:TIMer

  • E-DCH RLC SDU Size

This setting controls the uplink RLC SDU size specified for the E-DCH transport channel in the Close UE Test Loop message sent during a HSUPA RB Test Mode call. The default value is to meet the maximum throughput for FRC2.

This setting can only be changed while call status is idle.

GPIB Command: CALL:HSUPa:SERVice:RBTest:RLCSdu:SIZE

E-RNTI Parameters

  • Primary E-RNTI (Hex)

This setting determines the primary E-RNTI that is used on the E-AGCH. The default value is in line with 3GPP 34.108 s9.1.2.

This setting can only be changed while call status is idle.

GPIB Command: CALL:HSUPa:ERNTi[:PRIMary]

Related Topics

HSDPA Parameters


Legal Information

Acknowledgements

Microsoft ® is a U.S. registered trademark of Microsoft Corporation

Windows ® and MS Windows ® are U.S. registered trademarks of Microsoft Corporation.

Adobe ® Acrobat ® are trademarks of Adobe Systems Incorporated.

Notice

The hardware and/or software described in this document are furnished under a license and may be used or copied only in accordance with the terms of such license.

If software is for use in the performance of a U.S. Government prime contract or subcontract, Software is delivered and licensed as "Commercial computer software" as defined in DFAR 252.227-7014 (June 1995), or as a "commercial item" as defined in FAR 2.101(a) or as "Restricted computer software" as defined in FAR 52.227-19 (June 1987) or any equivalent agency regulation or contract clause. Use, duplication or disclosure of Software is subject to Agilent Technologies' standard commercial license terms, and non-DOD Departments and Agencies of the U.S. Government will receive no greater than Restricted Rights as defined in FAR 52.227-19(c)(1-2) (June 1987). U.S. Government users will receive no greater than Limited Rights as defined in FAR 52.227-14 (June 1987) or DFAR 252.227-7015 (b)(2) (November 1995), as applicable in any technical data.

© Agilent Technologies, Inc. 2009


Measurement Timeout

Description

The primary use of measurement timeouts is to regain control of the test set's GPIB in cases where the bus could potentially "hang."

The time normally required for a measurement to complete may vary greatly depending on the individual measurement, its settings, it's multiple measurement count value, and so forth. Because of this, you may need to set the timeout longer than the default for measurements where a large number of multiple measurements are requested or where measurement triggers may be infrequent.

Be careful when setting a timeout that is shorter than the default. It is possible to specify a timeout that is so short the measurement does not even have a chance to begin. Measurement timeouts should always be at least several seconds long.

Timeout units default to S (seconds). The seconds suffix is an optional part of the command. If you want MS (milliseconds), US (microseconds) or NS (nanoseconds), you must specify these units in the suffix.


Multi-Measurement Count

Description

Most measurements have a setup window that provides for the entry of a multi-measurement count value. This specifies how many measurements the test set will perform to obtain a set of values from which to calculate the following statistical measurement results:

  • Average (arithmetic mean) of measurement set

  • Minimum value from measurement set

  • Maximum value from measurement set

  • Standard Deviation of measurement set

The advantages of using the multi-measurement feature to obtain statistical measurement data include: reduced time associated with GPIB bus traffic, and reduced time configuring hardware. This is because the number of measurements specified in the multi-measurement count value are performed during one measurement cycle.


Triggering of Measurements

Description

Trigger Source

Triggering Process Description

Trigger Arm

Trigger Delay

Trigger Qualifier

Trigger Source

A measurement trigger causes hardware (for example, a sampler) to capture data which is used by a measurement algorithm to produce a measurement result. Not all of the trigger source choices are available in every measurement, or every test application.

  • RF Rise:

When RF rise triggering is selected, a measurement dependent threshold is used to define the trigger point on the envelope of the signal being measured. The envelope amplitude must fall below this threshold and remain there for a measurement-dependent period of time before the trigger is armed. After the trigger is armed, a trigger will occur as the envelope amplitude increases and passes through the threshold.

  • Protocol:

When protocol triggering is selected, a data capture is triggered by a protocol generated signal. The test set's protocol engine knows when the DUT's signal should be present and generates a trigger signal for use by the measurement to trigger the data capture.

  • External Trigger Source:

When external triggering is selected, the user supplies an external trigger signal via the rear panel TRIG IN connector in order to trigger data capture. The trigger will occur on the rising edge of this signal.

  • Immediate Trigger Source:

When immediate triggering selected, the trigger occurs as soon as any pre-trigger samples required by the measurement algorithm are taken. Data capture is triggered when the measurement is initiated.

  • Auto Trigger Source:

When auto triggering is selected, the test set automatically chooses the best trigger source for that measurement. This trigger source setting is convenient because the measurement trigger doesn't need to be changed when switching parameters. Auto trigger source is the best choice for most users.

Triggering Process Description

The triggering process controls the present and future states of the test set during the measurement cycle. Triggers are set up using the SETup commands and can be set up when a measurement is in the inactive state. A measurement is activated (selected) with an INITiate command. If a measurement is initiated while in its measurement cycle, it will terminate that measurement and restart it. The active state is not a single state but a collection of any state other than the inactive state. Deactivating (de-selecting) the measurement is accomplished through an INITiate:<MEAS>:OFF command.

Manually, a measurement is activated by selecting it from the Measurement Selection menu. A measurement is deactivated by pressing the Measurement Selection key, scrolling to measurement in the Measurement Selection menu, and then pressing F4 (Close Measurement) .

The Test Set's Measurement States

Measurement States

The following examples describe states of the test set under various conditions. Refer to The Test Set's Measurement States .

  • Inactive State

If the test set has just been powered on, or any form of preset has been performed, then the measurement state is inactive.

  • Wait for Trigger State

If a measurement has been initiated with the INITiate command but has not been triggered, or a measurement has been selected from the Measurement Selection menu but has not been triggered, then the measurement state is wait for trigger.

  • Measuring and Idle States (Trigger Arm Single)

If the trigger arm is set to single, the trigger source is available, and the trigger qualifier (optional) is satisfied, the measurement state transitions to measuring and measurement results are now available to the user. The state then transitions to idle (awaiting another INITiate).

  • Measuring State (Trigger Arm Continuous)

If the trigger arm is set to continuous, the trigger source is available, and the trigger qualifier (optional) is satisfied, the measurement state transitions to measuring and measurement results are now available to the user. The measurement is continually triggered until the measurement is deactivated. Measurement results are only available after the measurement completes and before it rearms. The measurement is deactivated using the INITiate:<MEAS>:OFF. or Close Measurement .

Trigger Arm (Single or Continuous) Description

Trigger arm determines if a measurement will make one measurement then return to idle (single), or automatically rearm on completion of a measurement and repeat the process (continuous).

When operating the test set remotely, the recommended setting for the trigger arm parameter is single. This ensures proper operation of the INIT:DONE? query which is used to control the retrieval of measurement results when measurements are initiated concurrently.

When a continuously armed measurement gets a result, it is available to any currently pending (waiting, hanging) FETCh? query. Then another measurement cycle is started immediately. At this point the results are no longer valid. The INIT:DONE? query is used to determine when there is a completed measurement with valid results that can be fetched. If you look for a continuously armed measurement with valid results that can be fetched using INIT:DONE? then you are unlikely to get anything but WAIT. Each time the Test Set is queried, it is 99% likely to be making another measurement. Even if it did return a measurement name, by the time the control program determines which FETCh? query to send, it is too late to fetch the results and the FETCh? query just hangs until the next measurement cycle is done, nullifying the efficiency provided by the INIT:DONE? query.

Pressing the Start Single key on the front panel will cause all currently active measurements with trigger arm set to single to arm and make the measurement.

Pressing Shift, Start Single (Stop) causes all measurements with trigger arm set to single to abort the measurement.

It is unnecessary for you to arm a measurement if the trigger arm is set to continuous. When in continuous mode, the measurement is automatically rearmed after completing a measurement.

Trigger Arm Default Settings

Action | Trigger Arm Default Setting
Power up of test set | Continuous
Manual Full Preset | Continuous
*RST (Remote) Full Preset | Single
Partial Preset | No change

Trigger Delay

Trigger delay controls the delay time between the trigger and the start of sampling. Resolution is 1 nanosecond per measurement and the units are in seconds. A negative value indicates the sampling should occur prior to the trigger. The default is zero seconds which is preferred for most measurements.

Trigger Qualifier

When the trigger qualifier is on, the test set samples the input signal when a trigger is received. It then determines if the input signal was valid by looking at its power level. If the power level during sampling did not meet the requirements of a valid signal, the state returns to wait for trigger without processing the samples. Trigger qualifier is available for GSM/GPRS TX Power and Phase Frequency Error measurements only.

If a valid signal is present, then it is qualified, and the samples are processed.