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1 Introduction

Use the instructions in this Guide to install and set up the N109228CA OIF CEI 3.1 Compliance Test 
Application. Once the procedures in this document are completed, you can begin compliance testing. 
Information on using the application is included in the application’s Online Help.

Your licenses determine where you install the N109228CA and FlexDCA applications. The 
N109228CA license allows you to install the application on either a specific PC or a specific 86100D 
or N1000A DCA-X instrument. This selection is made at the time you redeem your licenses.

Installing the N109228CA OIF CEI 3.1 Compliance Test Application

1 Select from one of the three different test-equipment configurations shown in the following 
pages. The configuration that you select depends on where the N109228CA OIF CEI 3.1 
Compliance Test Application is installed, as determined by the licenses, and whether you are 
using the N1010A FlexDCA application.

2 After locating the figure that matches your setup, follow the recommended procedure.

Configuration DCA-X Supported Configurations DCA-M Supported Configurations

N109228CA on a PC with 
FlexDCA

A PC attached to N1000A or 86100D 
DCA-X oscilloscope (in Legacy 
configuration) over LAN. The PC has 
N109228CA OIF CEI 3.1 software 
application, N1010A FlexDCA, 
86100DU-400 for 86100D, N1010100A 
(F-AEYE) or 86100DU-401 license, and IO 
Connection Expert installed on it.

A PC directly connected to the N109X with a USB cable. The PC has N109228CA OIF 
CEI 3.1 software application, N1010A FlexDCA, N109x-401 or N1010100A License, 
and IO Connection Expert installed on it.

N109228CA on a PC without 
FlexDCA

A PC attached to N1000A or 86100D 
DCA-X oscilloscope (in Standard 
configuration) over LAN. The PC has 
N109228CA OIF CEI 3.1 software 
application, 86100DU-400 for 86100D, 
N1010100A (F-AEYE) or 86100DU-401 
licenses, and IO Connection Expert 
installed on it.

Configuration 1: Connect the primary test system PC to a low-cost modern PC via 
LAN. The FlexDCA interface resides on the second PC. The second PC is then 
connected to the N109x via USB. This eliminates most issues of compatibility 
between an existing test system PC and the N109X hardware and can greatly simplify 
converting an 86100D system to an N109X system.
Configuration 2: An N1000A or 86100D mainframe connected to the N109X with a 
USB cable. The N1000A or 86100D has FlexDCA installed on it. The N1000A or 
86100D can then be controlled via GPIB or LAN by a PC that has N109228CA 
installed on it.
The PC with N109228CA has N109x-401 or N1010100A License and IO Connection 
Expert installed on it.

N109228CA on the 
oscilloscope

N1000A or 86100D DCA-X oscilloscope in 
Standard configuration. The oscilloscope 
has N109228CA OIF CEI 3.1, FlexDCA, and 
IO Connection Expert installed on it.

An N1000A or 86100D mainframe connected to the N109X with a USB cable. The 
N1000A or 86100D has FlexDCA and N109228CA installed on it.
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Recommended Equipment

Table 1 lists the recommended equipment. The equipment you select depends on the supported test 
equipment that is available to you.

Table 1 Recommended equipment to run tests on the N109228CA OIF CEI 3.1 Compliance Test Application

Equipment CEI 6G-LR/SR
CEI 11G-LR/MR/SR

CEI 6G-LR/SR
CEI 11G-LR/MR/SR
CEI 25G-LR
CEI 28G-SR/VSR

Qty

Oscilloscope N1000A DCA-X with options:
N1000A-LOJ Low jitter timebase

N1000A-PLK Pattern lock trigger hardware
F-JIT Enhanced Jitter Analysis option under N1010100A R&D package

F-EQ Equalizers option under N1010100A R&D package
Or

86100D DCA-X with options:
86100D-ETR Extended Trigger

86100D-200 Enhanced Jitter Analysis or F-JIT Enhanced Jitter Analysis option under N1010100A R&D package
86100D-201 Advanced Waveform Analysis or F-EQ Equalizers option under N1010100A R&D package

Or any of these
N1092 C/E Optical + Two Electrical Channels

N1094A Two Electrical Channels
N1094B Four Electrical Channels

1

Single Module Solution 86108A or 86108B-LBW/216
N1060A

86108B-HBW/232
N1060A

1

Multiple Module Solution 86112A, 86117A, 86118A-H01, N1045A, N1045B, 
N1046A 75/85/100 GHz, N1055A, or 54754A

86117A, 86118A-H01, N1045A, N1045B, N1046A 
75/85/100 GHz, or N1055A

1

86107A (any option) 86107A (any option) 1

Clock/Data Recovery and 
Demultiplexer *

N4877A-216 or N4877A-232
N1076 A/B, N1077A, N1078A Clock Data Recovery

N4877A-232
N1076 A/B, N1077A, N1078A Clock Data Recovery

1

Software N109228CA
FlexDCA A.05.80 or higher
Keysight I/O Libraries, 16.3 or higher
86100DU-400 (for Jitter Transfer) †

86100DU-401 or Advanced Eye Analysis option under N1010100A R&D package (for PRBS31) ‡

Keysight I/O Libraries, 16.3 or higher, 16.3 if running N1010A on a PC

1
1
1
1

Performance Network Analyzer ** N5221A, N5222A, N5230C-120/125, or N5241A N5224A, N5222A, N5227A, N5230C-420/425, or N5244A 1

Impedance Analyzer †† ‡‡ — 4294A Precision Impedance Analyzer (recommended), or 
E5061B ENA Series Network Analyzer (recommended)

1

Matched Cable Set 86108B-CA3 (recommended) 86108B-CA2 (recommended) 1

Phase Trimmers 86108B-PT3 (recommended) 86108B-PT2 (recommended) 2

DC Block 86108B-DC3 (recommended) 86108B-DC2 (recommended) 2

Pick-Off N4815A-015 (recommended) N4915A-015 (recommended) 2

* Required if using the multiple module solution instead of an 86108A/B.

† The 86100DU-400 software is required only for testing the CEI 11G-SR (Short Reach) interface only, when running the Jitter Transfer 
Bandwidth, 11G-SR and Jitter Transfer Peaking, 11G-SR tests.
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‡ The 86100DU-401 software is only required for testing the CEI 6G and CEI 11G interfaces, when you select a PRBS31 pattern length when 
testing jitter. 

**Required for return-loss tests. Later PNA models with higher frequency range will also work with the N109228CA.

†† Required for Very Short Reach (VSR) tests. The instrument must be able to measure impedance at 1 MHz.

‡‡ The impedance analyzer is not remotely controlled by the N109228CA.

NOTE The N109228CA OIF CEI 3.1 Compliance Test Application cannot be installed on an 86100A, 
86100B, or 86100C.
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Installing N109228CA and N1010A FlexDCA on a PC

If your licenses allow for installing the software as marked by the red star in the following 
diagrams, go to Chapter 2, “Installing N109228CA and FlexDCA on a PC”.

Figure 1 N109228CA and N1010A FlexDCA installed on PC connected to 86100D DCA-X Oscilloscope
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Figure 2 N109228CA and N1010A FlexDCA installed on PC connected to N1000A DCA-X Oscilloscope
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Figure 3 N109228CA and N1010A FlexDCA Installed on PC connected to N1094B DCA-M Oscilloscope
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Installing the N109228CA on a PC without FlexDCA

If your licenses allow for installing the software as marked by the red star in this diagram, 
go to Chapter 3, “Installing N109228CA on a PC Without N1010A FlexDCA”.

Figure 4 N109228CA Installed on PC connected to 86100D DCA-X Oscilloscope
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Figure 5 N109228CA Installed on PC connected to N1000A DCA-X Oscilloscope
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Figure 6 N109228CA Installed on PC Without N1010A FlexDCA connected to N1094B DCA-M Oscilloscope via an-
other PC
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Figure 7 N109228CA Installed on PC Without N1010A FlexDCA connected to N1094B DCA-M Oscilloscope via 
86100 DCA-X Oscilloscope
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Figure 8 N109228CA Installed on PC Without N1010A FlexDCA connected to N1094B DCA-M Oscilloscope via 
N1000A DCA-X Oscilloscope
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Installing N109228CA on the DCA-X Oscilloscope

If your licenses allow for installing the software as marked by the red star in this diagram, 
go to Chapter 4, “Installing N109228CA on the oscilloscope”.

Figure 9 N109228CA Installed on 86100D
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Figure 10 N109228CA Installed on N1000A
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Figure 11 N109228CA Installed on 86100D connected to a DCA-M setup
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Figure 12 N109228CA Installed on N1000A connected to a DCA-M setup
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Starting the N109228CA OIF CEI 3.1 Compliance Test Application

After you install the N109228CA OIF CEI 3.1 Compliance Test Application on a PC (with or without 
the N1010A FlexDCA interface) or on the N1000A or 86100D Oscilloscope, refer to the following 
sections to start the N109228CA OIF CEI 3.1 Compliance Test Application:

• If the N109228CA OIF CEI 3.1 Compliance Test Application and the N1010A FlexDCA Software 
are installed on the same PC and the DCA-X or DCA-M Oscilloscope is being accessed remotely, 
see  “Starting the N109228CA OIF CEI 3.1 Compliance Test Application” on page 53.

• If the N109228CA OIF CEI 3.1 Compliance Test Application is installed on a PC (but the N1010A 
FlexDCA Software is not installed) and the DCA-X or DCA-M Oscilloscope is being accessed 
remotely, see  “Starting the N109228CA OIF CEI 3.1 Compliance Test Application” on page 77.

• If the N109228CA OIF CEI 3.1 Compliance Test Application is installed on the N1000A or 86100D 
Oscilloscope, see  “Starting the N109228CA OIF CEI 3.1 Compliance Test Application” on 
page 92.



OIF CEI 3.1 Compliance and Debug Application Getting Started 21

Introduction 1

Connecting to External Instruments

Most of the measurements in the N109228CA OIF CEI 3.1 Compliance Test Application use an 
N1000A or 86100D DCA-X or a supported DCA-M (N1092C/E, N1094A, N1094B) sampling 
oscilloscope. However, for return loss compliance tests, a network analyzer is required.

The current version of the N109228CA OIF CEI 3.1 Compliance Test Application requires Socket 
connections for PNAs.

Note that the Keysight I/O Library Suite must be installed before you proceed with connecting to the 
network analyzer. The user interface for Keysight Connection Expert 2017 (Version 18.0) and higher 
is slightly different from its previous versions, such as Version 17.2 or earlier.

Connection using Keysight Connection Expert v17.2 (or earlier)

1 Locate and record the PNA instrument’s Hostname (Full Computer Name). Refer to the 
respective network analyzer’s documentation for locating this information.

2 From the Windows Start menu, click All Programs>Keysight Connection Expert to launch Connection 
Expert. Refer to Keysight IO Libraries Suite for information on how to install the Keysight 
Connection Expert.

Figure 13 Launching the Keysight Connection Expert

3 In Keysight Connection Expert, click the Manual Configuration tab.

http://www.keysight.com/en/pd-1985909/io-libraries-suite?nid=-33330.977662.00&cc=IN&lc=eng&cmpid=zzfindiosuiteproductcounter
http://www.keysight.com/en/pd-1985909/io-libraries-suite?nid=-33330.977662.00&cc=IN&lc=eng&cmpid=zzfindiosuiteproductcounter
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Figure 14 Tabs within Keysight Connection Expert

4 Under Add New Instruments / Interfaces, select LAN instrument.

Figure 15 Performing Manual Configuration in Keysight Connection Expert



OIF CEI 3.1 Compliance and Debug Application Getting Started 23

Introduction 1

5 In the Add a LAN device pane, perform the following steps:

a Under Set LAN Address:, enter the Hostname (recorded in step 1) in the Hostname or IP Address: 
field. Note that your Hostname entry will be different from what is shown in the image.

b Under Set Protocol:, select Socket and enter the port number.

c Under Verify Connection:, click Test This VISA Address to verify the connection.

Figure 16 Adding a LAN device information in the Keysight Connection Expert

6 Once you verify the entered data, click Accept to complete the process.
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7 Copy Network Analyzer SICL Address to the Clipboard:

a Click the Instruments tab of the Keysight Connection Expert.

b Click the PNA listing on the left pane, and copy the SICL address using Ctrl + C keys. Note that 
the address on your end will be different from what is shown in the image.

Figure 17 Copying Network Analyzer’s SICL Address

8 Start the N109228CA OIF CEI 3.1 Compliance Test Application. Refer to “Starting the 
N109228CA OIF CEI 3.1 Compliance Test Application” on page 20 for instructions.
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9 Connect to the Network Analyzer:

Figure 18 Default view of External Instruments area in the N109228CA OIF CEI 3.1 Application

a In the Name: field of the External Instruments area at the bottom of the N109228CA OIF CEI 
application’s main window, select PNA from the drop-down list.

b Click Connect. The Connect to PNA window appears.

Figure 19 Connecting to the selected Network Analyzer

c In the Enter/Select VISA address/alias (or SICL address) field, paste the SICL address using Ctrl + V 
keys.

d Click Get to confirm the connection.

e Click OK to close the dialog box. 

f The External Instruments field displays the relevant information once the connection to the 
selected network analyzer is established.

Connection using Keysight Connection Expert 2017 (v18.0 or higher)

1 Locate and record the PNA instrument’s Hostname (Full Computer Name). Refer to the 
respective network analyzer’s documentation for locating this information.

2 From the Windows Start menu, click All Programs>Keysight Connection Expert to launch Connection 
Expert. Refer to Keysight IO Libraries Suite for information on how to install the Keysight 
Connection Expert.

http://www.keysight.com/en/pd-1985909/io-libraries-suite?nid=-33330.977662.00&cc=IN&lc=eng&cmpid=zzfindiosuiteproductcounter
http://www.keysight.com/en/pd-1985909/io-libraries-suite?nid=-33330.977662.00&cc=IN&lc=eng&cmpid=zzfindiosuiteproductcounter
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Figure 20 Launching the Keysight Connection Expert
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3 In Keysight Connection Expert, click the + Add button to manually add instruments and 
interfaces.

Figure 21 Adding LAN device manually in the Keysight Connection Expert 2017

4 From the drop-down list that appears, select LAN instrument.

Figure 22 Selecting LAN instrument in the Keysight Connection Expert 2017
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5 In the Add a LAN device window, 

a Select the Enter Address tab.

b Under Set LAN Address:, enter the Hostname (recorded in step 1) in the Hostname or IP Address: 
field. Note that your Hostname entry will be different from what is shown in the image.

c Under Set Protocol:, select Socket and enter the port number.

d Under Verify Connection:, click Test This VISA Address to verify the connection.

Figure 23 Adding a LAN device information in the Keysight Connection Expert 2017

6 Once you verify the entered data, click OK to complete the process.
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7 Copy Network Analyzer SICL Address to the Clipboard:

a Click the Instruments tab of the Keysight Connection Expert.

Figure 24 Selecting the connected Network Analyzer for SICL Address information
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b Click the PNA listing on the left pane, and copy the SICL address using Ctrl + C keys. Note that 
the address on your end will be different from what is shown in the image.

Figure 25 Copying Network Analyzer’s SICL Address

8 Start the N109228CA OIF CEI 3.1 Compliance Test Application. Refer to “Starting the 
N109228CA OIF CEI 3.1 Compliance Test Application” on page 20 for instructions.
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9 Connect to the Network Analyzer:

Figure 26 Default view of External Instruments area in the N109228CA OIF CEI 3.1 Application

a In the Name: field of the External Instruments area at the bottom of the N109228CA OIF CEI 3.1 
application’s main window, select PNA from the drop-down list. 

b Click Connect. The Connect to PNA window appears.

Figure 27 Connecting to the selected Network Analyzer

c In the Enter/Select VISA address/alias (or SICL address) field, paste the SICL address using Ctrl + V 
keys.

d Click Get to confirm the connection.

e Click OK to close the dialog box. 

f The External Instruments field displays relevant information once the connection to the selected 
network analyzer is established.
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2 Installing N109228CA and 
FlexDCA on a PC

Follow the instructions in this chapter when you are installing both the N109228CA OIF CEI 3.1 
application and the FlexDCA application on the PC. You must purchase and install a license for the 
86100DU-401. Once the license is installed, the 86100DU-401 software will be enabled.

Figure 28 N109228CA and N1010A FlexDCA Installed on PC (with 86100D DCA-X oscilloscope)

NOTE When you redeem an N109228CA OIF CEI 3.1 license, you must select whether to install the 
application on a specific 86100D or N1000A oscilloscope or a specific PC.
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Figure 29 N109228CA and N1010A FlexDCA Installed on PC (with N1000A DCA-X oscilloscope)
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Figure 30 N109228CA and N1010A FlexDCA Installed on PC connected to N1094B DCA-M Oscilloscope

NOTE If you do not connect a network analyzer, you will not be able to perform the return loss 
compliance tests.

NOTE The 86100DU-400 software is required only for testing the CEI 11G-SR (Short Reach) interface, 
when running the Jitter Transfer Bandwidth, 11G-SR and Jitter Transfer Peaking, 11G-SR tests.

NOTE The 86100DU-401 or N109X-401 software is required only for testing the CEI 6G and CEI 11G 
interfaces, when you select a PRBS31 pattern length when testing jitter.
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Connecting the Equipment

1 For a DCA-X oscilloscope, install one of the module combinations listed in Table 2 into the 
86100D or N1000A.

Table 2 Module combinations for DCA-X Oscilloscope

2 For a DCA-M oscilloscope, keep in mind the information in the following table.

Table 3 Supported configurations for DCA-M Oscilloscope

3 Connect the equipment as shown in Figure 28 or Figure 30 and power on all of the instruments.

Installed Module Configurations Requires
N4877A

Limited to CEI 6G-LR/SR
and CEI 11G-LR/MR/SR
Testing Only

86108A √

86108B-LBW/216 √

86108B-HBW/232

86112A and 86107A √ (N4877A-216) √

54754A and 86107A √ (N4877A-216) √

86117A and 86107A √ (N4877A-232)

86118A-H01 and 86107A √ (N4877A-232)

N1045A and 86107A √ (N4877A-232)

N1045B and 86107A √ (N4877A-232)

N1055A and 86107A √ (N4877A-232)

54754A and 86107A √ (N4877A-232)

N1046A and 86107A √ (N4877A-232)

N1060A

Configurations for DCA-M Requires N107x

N1094A √ (N107xA-232)

N1094B √ (N107xA-232)

N1092 C/E √ (N107xA-232)
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Installing the I/O Library Suite

1 Navigate to www.keysight.com/find/iosuite and download the Keysight I/O Library Suite.

2 Install the I/O Library Suite on the PC.

NOTE Keysight’s I/O Library Suite is free software that automatically detects instruments connected to 
your PC and configures the interfaces. It reduces the overall setup and configuration time. The 
N109228CA OIF CEI 3.1 Compliance Test Application requires I/O Libraries Suite 16.3 or higher.

http://www.keysight.com/en/pd-1985909/io-libraries-suite?nid=-33330.977662.00&cc=IN&lc=eng&cmpid=zzfindiosuite
http://www.keysight.com/en/pd-1985909/io-libraries-suite?nid=-33330.977662.00&cc=IN&lc=eng&cmpid=zzfindiosuite
http://www.keysight.com/en/pd-1985909/io-libraries-suite?nid=-33330.977662.00&cc=IN&lc=eng&cmpid=zzfindiosuite
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Installing the N1010A FlexDCA Application

Follow the steps below to install the N1010A FlexDCA Software and its license as well as the license 
for the 86100DU-401.

1 Search for the N1010A FlexDCA Software on Keysight website. 

2 Download the installer file and install the application on the PC for which you have redeemed the 
license.

3 Save the license file that you received from Keysight in a folder on the local disk or in an 
accessible memory device.

4 From the Windows Start menu, click All Programs>Keysight License Manager to launch the Keysight 
License Manager.

Figure 31 Launching Keysight Connection Expert from the Start menu

NOTE When you redeem an N1010A FlexDCA Software license, you must specify the information for the 
PC, where the software will be installed for remotely accessing the Oscilloscope.

NOTE Keysight License Manager version 5.1 (and higher) have a different user interface than version 
5.0 (or earlier). Even though the path to launch the Keysight License Manager is the same for 
both versions, refer to the Keysight License Manager Online Help for the respective versions to 
find more information about the functionality of the application.
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To install the N1010A FlexDCA Software license using Keysight License Manager version 5.1 or higher

1 Click the Tools icon on the top-right corner of the Keysight License Manager window.

Figure 32 Installing license file on Keysight License Manager version 5.1 & above

2 Click Install License File.... The Select License File(s) to Install on <PC Hostname> appears.

Figure 33 Selecting license file from the folder

3 Navigate to the folder where the N1010A FlexDCA Software licenses are saved.

4 Select the license and click Open. The license files are installed and an entry is displayed in the 
Keysight License Manager.
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Figure 34 Licenses displayed in Keysight License Manager version 5.1 & above

5 Close the Keysight License Manager.

To install the N1010A FlexDCA’s license using Keysight License Manager version 5.0 or earlier

1 From the Keysight License Manager window’s main menu, click File>Install... or right-click within 
the left pane of the Keysight License Manager window and select Install....

Figure 35 Installing license file on Keysight License Manager version 5.0 or earlier
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2 The Install License File(s) dialog box appears.

Figure 36 Selecting license file from the folder

3 Navigate to the folder where the N1010A FlexDCA Software licenses are saved.
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4 Select the license and click Open. The license files are installed and an entry is displayed in the 
Keysight License Manager.

Figure 37 Licenses displayed in Keysight License Manager version 5.0 or earlier

5 Close the Keysight License Manager.
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Installing the N109228CA OIF CEI 3.1 Compliance Test Application

Follow the steps below to install the N109228CA OIF CEI 3.1 Compliance Test Application and its 
license as well as the license for the 86100DU-401.

1 Search for the N109228CA OIF CEI 3.1 Compliance Test Application on Keysight website.

2 Download the installer file and install the application on the PC for which you have redeemed the 
license.

3 Save the license file that you received from Keysight in a folder on the local disk or in an 
accessible memory device.

4 If not already done, purchase an 86100DU-401 or N109x-401 license. Save the license file that 
you received from Keysight in a folder on the local disk or in an accessible memory device.

5 If the FlexDCA is running on your PC, close FlexDCA.

6 From the Windows Start menu, click All Programs>Keysight License Manager to launch the Keysight 
License Manager.

Figure 38 Launching Keysight Connection Expert from the Start menu

NOTE When you redeem an N109228CA OIF CEI 3.1 license, you must select whether to install the 
application on the Oscilloscope or a specific PC.

NOTE Keysight License Manager version 5.1 (and higher) have a different user interface than version 
5.0 (or earlier). Even though the path to launch the Keysight License Manager is the same for 
both versions, refer to the Keysight License Manager Online Help for the respective versions to 
find more information about the functionality of the application.
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To install the N109228CA OIF CEI 3.1 Compliance Test Application’s license using Keysight License Man-
ager version 5.1 or higher

1 Click the Tools icon on the top-right corner of the Keysight License Manager window.

Figure 39 Installing license file on Keysight License Manager version 5.1 & above

2 Click Install License File.... The Select License File(s) to Install on <PC Hostname> appears.

Figure 40 Selecting license file from the folder

3 Navigate to the folder where the N109228CA OIF CEI 3.1 licenses are saved.

4 Select the license and click Open. The license files are installed and an entry is displayed in the 
Keysight License Manager.

5 Close the Keysight License Manager.
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To install the N109228CA OIF CEI 3.1 Compliance Test Application’s license using Keysight License Man-
ager version 5.0 or earlier

1 From the Keysight License Manager window’s main menu, click File>Install... or right-click within 
the left pane of the Keysight License Manager window and select Install....

Figure 41 Installing license file on Keysight License Manager version 5.0 or earlier

2 The Install License File(s) dialog box appears.

Figure 42 Selecting license file from the folder

3 Navigate to the folder where the N109228CA OIF CEI 3.1 licenses are saved.

4 Select the license and click Open. The license files are installed and an entry is displayed in the 
Keysight License Manager.

5 Close the Keysight License Manager.
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Connecting N1010A FlexDCA to 86100D or N1000A

1 On the 86100D Oscilloscope, launch the Keysight FlexDCA application.

2 From the FlexDCA’s main menu, click Help > About FlexDCA.... The About 86100D dialog box 
appears.

3 In the System Information area, scroll down to view the Computer Name entry.

Alternatively, you can obtain the computer name from the Windows System properties.

Figure 43 86100D Oscilloscope’s hostname

4 Record the Computer Name (corresponds to hostname) as you will need this name later in this 
procedure.

86100D Computer Name: ________________________

NOTE If you are using the N1010A FlexDCA Software on your PC to launch the N109228CA OIF CEI 
3.1 Compliance Test Application, make sure that the Oscilloscope and your PC are connected 
to the LAN.

NOTE This section lists the steps for 86100D DCA-X oscilloscope. Perform similar steps for the 
N1000A DCA-X oscilloscope.
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5 Close the About 86100D dialog box.

6 On the Windows Start menu on your PC, click All Programs>Keysight FlexDCA>Keysight FlexDCA to 
launch the N1010A FlexDCA Software.

Figure 44 Launching the N1010A FlexDCA Software on PC

NOTE If you are accessing the 86100D Oscilloscope’s FlexDCA interface remotely on your PC using 
any remote connectivity applications, Keysight recommends closing the remote-connection 
application before you try establishing connectivity between FlexDCA Software and the remote 
86100D Oscilloscope.
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7 When FlexDCA starts, the Extended Module Configuration window is displayed automatically. Click 
Connect if the 86100D Oscilloscope’s Hostname is already displayed else click Setup.

Figure 45 Extended Module Configuration dialog box for connecting N1010A FlexDCA to 86100D

If the Extended Module Configuration window does not appear, from the FlexDCA interface’s main 
menu, click Setup>DCA Connection Setup.
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8 On the FlexDCA Connection Setup dialog box,

a Ensure that LAN is selected in the Connect Using: area.

b Enter the 86100D’s Hostname that you recorded in step 4.

Alternatively, you may also enter the IP Address of the remote 86100D Oscilloscope.

Figure 46 N1010A FlexDCA Connection Setup to connect to 86100D Oscilloscope



2 Installing N109228CA and N1010A FlexDCA on a PC

50 OIF CEI 3.1 Compliance and Debug Application Getting Started

9 Click Connect.

If connection is established successfully, the FlexDCA Connection Setup dialog box displays status 
as Connected.

Figure 47 86100D Oscilloscope connection status on the FlexDCA Connection Setup

10 Click Close to exit the FlexDCA Connection Setup dialog box.

11 Click Close to exit the Extended Module Configuration window.

Figure 48 86100D Oscilloscope connection status on the Extended Module Configuration window
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12 In FlexDCA, click Tools > SCPI Programming Tools > SCPI Server Setup to open the dialog box.

13 Confirm that the Sockets and HiSLIP interfaces are selected (Enabled) as shown in Figure 49.

14 Close the dialog box.

Figure 49 FlexDCA’s SCPI Server Setup Dialog Box

15 Once the connection is established, you may proceed to launch the N109228CA OIF CEI 3.1 
Compliance Test Application on your PC.
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Connecting N1010A FlexDCA to N109X Oscilloscope and N107X

Perform the following steps to connect your N109X oscilloscope with N107X clock data recovery 
using FlexDCA:

1 Launch FlexDCA.

2 When FlexDCA starts, the Extended Module Configuration window is displayed automatically. If the 
Extended Module Configuration window does not appear, from the FlexDCA interface’s main menu, 
click Setup>Configure Extended Modules....

3 Configure Slot 7 to be the N109X module.

4 Configure Slot 8 to be the N107X module.

5 Remove any other N109X/N107X that is configured for Slot 5 and Slot 6.

6 Click Close to exit the Extended Module Configuration window.

7 Once the connection is established, you may proceed to launch the N109228CA Compliance Test 
Application on your PC.
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Starting the N109228CA OIF CEI 3.1 Compliance Test Application

After you install the N109228CA OIF CEI 3.1 Compliance Test Application on a PC along with the 
N1010A FlexDCA interface, start the N109228CA OIF CEI 3.1 Compliance Test Application in one of 
the following ways:

Access the N109228CA OIF CEI 3.1 Compliance Test Application directly from the Start menu

Refer to “Starting the N109228CA OIF CEI 3.1 Compliance Test Application” on page 77, where the 
procedure to start the application directly (that is, without launching the N1010A FlexDCA Software) 
is described.

Access the N109228CA OIF CEI 3.1 Compliance Test Application using the N1010A FlexDCA Software on 
your PC

1 Ensure that the N1010A FlexDCA Software is connected to the Oscilloscope. Refer to the earlier 
sections for steps.

2 After a connection between the N1010A FlexDCA Software and the Oscilloscope is established, 
the N1010A FlexDCA Software on your PC may indicate that it is remotely controlled, as shown in 
Figure 50.

Figure 50 N1010A FlexDCA Remote App under Remote Control

To view the N1010A FlexDCA's main menu, click the Local button (towards the upper right 
corner).

Figure 51 N1010A FlexDCA under Remote Control
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3 From the FlexDCA's main menu, click Apps>Automated Test Apps>N109228CA OIF CEI 31.

4 The N109228CA OIF CEI 3.1 Compliance Test Application banner appears.
Afterwards. the default view of the N109228CA OIF CEI 3.1 Compliance Test Application appears.

Figure 52 Default window of the N109228CA OIF CEI 3.1 Compliance Test Application
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Connecting to the Network Analyzer

Refer to “Connecting to External Instruments” on page 21 for connecting to the network analyzer you 
are using.
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Connecting to the N4877A

The N4877A is used whenever multiple 86100D or N1000A modules are used in the test setup rather 
than an 86108A/B module. Refer to Table 2 on page 36.

On the 86100D, click Setup > Configure Extended Modules. In the dialog box, perform the following two 
steps:

1 Configure Slot 8 to be the N4877A.

2 Remove any other N4877A that is configured for Slot 5, Slot 6, or Slot 7.

For more information, click the Help button that is in the title bar of the Extended Module 
Configuration dialog box.

Figure 53 The Extended Module Configuration with the N4877A in Slot 8
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3 Installing N109228CA on a PC 
Without N1010A FlexDCA

Follow the instructions in this chapter when you are installing the N109228CA OIF CEI 3.1 
application on a PC, but you are not installing the N1010A FlexDCA application on the same PC. You 
must purchase and install a license for the 86100DU-401. Once the license is installed, the 
86100DU-401 software will be enabled.

Figure 54 N109228CA Installed on PC Without N1010A FlexDCA connected to 86100D DCA-X Oscilloscope
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Figure 55 N109228CA Installed on PC Without N1010A FlexDCA connected to N1000A DCA-X Oscilloscope
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Figure 56 N109228CA Installed on PC Without N1010A FlexDCA connected to N1094B DCA-M Oscilloscope via an-
other PC
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Figure 57 N109228CA Installed on PC Without N1010A FlexDCA connected to N1094B DCA-M Oscilloscope via 
86100 DCA-X Oscilloscope
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Figure 58 N109228CA Installed on PC Without N1010A FlexDCA connected to N1094B DCA-M Oscilloscope via 
N1000A DCA-X Oscilloscope

NOTE If you do not connect a network analyzer, you will not be able to perform the return loss 
compliance tests.

NOTE The 86100DU-400 software is required only for testing the CEI 11G-SR (Short Reach) interface, 
when running the Jitter Transfer Bandwidth, 11G-SR and Jitter Transfer Peaking, 11G-SR tests.

NOTE The 86100DU-401 or N109X-401 software is required only for testing the CEI 6G and CEI 11G 
interfaces, when you select a PRBS31 pattern length when testing jitter.
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Connecting the Equipment

1 For a DCA-X oscilloscope, install one of the module combinations listed in Table 4 into the 
86100D or N1000A.

Table 4 Module combinations for DCA-X Oscilloscope

2 For a DCA-M oscilloscope, keep in mind the information in the following table.

Table 5 Supported configurations for DCA-M Oscilloscope

3 Connect the equipment as shown in the connection diagrams above and power on all of the 
instruments.

Installed Module Configurations Requires
N4877A

Limited to CEI 6G-LR/SR
and CEI 11G-LR/MR/SR
Testing Only

86108A √

86108B-LBW/216 √

86108B-HBW/232

86112A and 86107A √ (N4877A-216) √

54754A and 86107A √ (N4877A-216) √

86117A and 86107A √ (N4877A-232)

86118A-H01 and 86107A √ (N4877A-232)

N1045A and 86107A √ (N4877A-232)

N1045B and 86107A √ (N4877A-232)

N1055A and 86107A √ (N4877A-232)

54754A and 86107A √ (N4877A-232)

N1046A and 86107A √ (N4877A-232)

N1060A

Configurations for DCA-M Requires N107x

N1094A √ (N107xA-232)

N1094B √ (N107xA-232)

N1092 C/E √ (N107xA-232)
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Installing the I/O Library Suite

1 Navigate to www.keysight.com/find/iosuite and download the Keysight I/O Library Suite.

2 Install the I/O Library Suite on the PC.

NOTE Keysight’s I/O Library Suite is free software that automatically detects instruments connected to 
your PC and configures the interfaces. It reduces the overall setup and configuration time. The OIF 
CEI 3.1 Compliance Test Application requires I/O Libraries Suite 16.3 or higher.

http://www.keysight.com/en/pd-1985909/io-libraries-suite?nid=-33330.977662.00&cc=IN&lc=eng&cmpid=zzfindiosuite
http://www.keysight.com/en/pd-1985909/io-libraries-suite?nid=-33330.977662.00&cc=IN&lc=eng&cmpid=zzfindiosuite
http://www.keysight.com/en/pd-1985909/io-libraries-suite?nid=-33330.977662.00&cc=IN&lc=eng&cmpid=zzfindiosuite
http://www.keysight.com/en/pd-1985909/io-libraries-suite?nid=-33330.977662.00&cc=IN&lc=eng&cmpid=zzfindiosuite
http://www.keysight.com/en/pd-1985909/io-libraries-suite?nid=-33330.977662.00&cc=IN&lc=eng&cmpid=zzfindiosuite
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Installing the N109228CA OIF CEI 3.1 Compliance Test Application

Follow the steps below to install the N109228CA OIF CEI 3.1 Compliance Test Application and its 
license as well as the license for the 86100DU-401. When the license for 86100DU-401 is installed, 
the 86100DU-401 software is enabled.

1 Search for the N109228CA OIF CEI 3.1 Compliance Test Application on the Keysight website. 
Download and install the application on the PC for which you have redeemed the license.

2 Save the license file that you received from Keysight in a folder on the local disk or in an 
accessible memory device.

3 If not already done, purchase an 86100DU-401 or N109X-401 license. Save the license file that 
you received from Keysight in a folder on the local disk or in an accessible memory device.

4 If the N1010A FlexDCA is running on your PC, close FlexDCA.

5 From the Windows Start menu, click All Programs>Keysight License Manager to launch the Keysight 
License Manager.

Figure 59 Launching Keysight Connection Expert from the Start menu

NOTE When you redeem an N109228CA OIF CEI 3.1 license, you must select whether to install the 
application on the Oscilloscope or a specific PC.

NOTE Keysight License Manager version 5.1 (and higher) have a different user interface than version 
5.0 (or earlier). Even though the path to launch the Keysight License Manager is the same for 
both versions, refer to the Keysight License Manager Online Help for the respective versions to 
find more information about the functionality of the application.
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To install the N109228CA OIF CEI 3.1 Compliance Test Application’s license using Keysight License Man-
ager version 5.1 or higher

1 Click the Tools icon on the top-right corner of the Keysight License Manager window.

Figure 60 Installing license file on Keysight License Manager version 5.1 & above

2 Click Install License File.... The Select License File(s) to Install on <PC Hostname> appears.

Figure 61 Selecting license file from the folder

3 Navigate to the folder where the N109228CA OIF CEI 3.1 licenses are saved.

4 Select the license and click Open. The license files are installed and an entry is displayed in the 
Keysight License Manager.

5 Close the Keysight License Manager.
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To install the N109228CA OIF CEI 3.1 Compliance Test Application’s license using Keysight License Man-
ager version 5.0 or earlier

1 From the Keysight License Manager window’s main menu, click File>Install... or right-click within 
the left pane of the Keysight License Manager window and select Install....

Figure 62 Installing license file on Keysight License Manager version 5.0 or earlier

2 The Install License File(s) dialog box appears.

Figure 63 Selecting license file from the folder

3 Navigate to the folder where the N109228CA OIF CEI 3.1 licenses are saved.

4 Select the license and click Open. The license files are installed and an entry is displayed in the 
Keysight License Manager.

5 Close the Keysight License Manager.
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Validating 86100D’s or N1000A’s SCPI Server Setup

1 On the 86100D/N1000A Oscilloscope or the PC hosting the FlexDCA software, launch the 
Keysight FlexDCA application.

2 Click Tools > SCPI Programming Tools > SCPI Server Setup.

3 In the SCPI Server Setup dialog, confirm that the Sockets and HiSLIP interfaces are selected and 
enabled as shown in Figure 64.

Figure 64 86100D’s SCPI Server Setup Dialog Box

4 Close the SCPI Server Setup dialog box.
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Adding 86100D or N1000A to Keysight Connection Expert

Most of the measurements in the N109228CA OIF CEI 3.1 Compliance Test Application use a 
supported DCA-X or DCA-M sampling oscilloscope.

Note that the Keysight I/O Library Suite must be installed before you proceed with connecting to the 
network analyzer. The user interface for Keysight Connection Expert 2017 (Version 18.0 or higher) is 
slightly different from its previous versions, such as Version 17.2 or earlier.

Connection using Keysight Connection Expert v17.2 (or earlier)

1 On the 86100D Oscilloscope, launch the Keysight FlexDCA application.

2 From the FlexDCA’s main menu, click Help > About FlexDCA.... The About 86100D dialog box 
appears.

3 In the System Information area, scroll down to view the Computer Name entry.

Alternatively, you can obtain the computer name from the Windows System properties.

Figure 65 86100D Oscilloscope’s hostname

4 Record the Computer Name (corresponds to hostname) as you will need this name later in this 
procedure.

NOTE This section lists the steps for 86100D DCA-X oscilloscope. Perform similar steps for the 
N1000A DCA-X oscilloscope.
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86100D Computer Name: ________________________

5 Close the About 86100D dialog box.

6 On the Windows Start menu of your PC, click All Programs>Keysight Connection Expert to launch 
Connection Expert. Refer to Keysight IO Libraries Suite for information on how to install the 
Keysight Connection Expert.

Figure 66 Launching the Keysight Connection Expert

7 In Keysight Connection Expert, click the Manual Configuration tab.

Figure 67 Tabs within Keysight Connection Expert

8 Under Add New Instruments / Interfaces, select LAN instrument.

Figure 68 Performing Manual Configuration in Keysight Connection Expert

http://www.keysight.com/en/pd-1985909/io-libraries-suite?nid=-33330.977662.00&cc=IN&lc=eng&cmpid=zzfindiosuiteproductcounter
http://www.keysight.com/en/pd-1985909/io-libraries-suite?nid=-33330.977662.00&cc=IN&lc=eng&cmpid=zzfindiosuiteproductcounter
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9 In the Add a LAN device pane, 

a Under Set LAN Address:, enter the Hostname (recorded in step 1) in the Hostname or IP Address: 
field. Note that your Hostname entry will be different from what is shown in the image.

b Under Set Protocol:, select Socket and enter the port number.

c Under Verify Connection:, click Test This VISA Address to verify the connection.

Figure 69 Adding the 86100D device information in the Keysight Connection Expert

10 Once you verify the entered data, click Accept to complete the process.
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11 To verify that the 86100D Oscilloscope is connected, click the Instruments tab of the Keysight 
Connection Expert.

12 Click the 86100D Oscilloscope’s listing on the left pane. A check mark encircled in green 
indicates that the Oscilloscope is connected to your PC remotely on the LAN. Note that the 
address on your end will be different from what is shown in the image.

Figure 70 Validating 86100D Oscilloscope’s connection

13 Close the Keysight Connection Expert window.
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Connection using Keysight Connection Expert 2017 (v18.0 or higher)

1 On the 86100D Oscilloscope, launch the Keysight FlexDCA application.

2 From the FlexDCA’s main menu, click Help > About FlexDCA.... The About 86100D dialog box 
appears.

3 In the System Information area, scroll down to view the Computer Name entry.

Alternatively, you can obtain the computer name from the Windows System properties.

Figure 71 86100D Oscilloscope’s hostname

4 Record the Computer Name (corresponds to hostname) as you will need this name later in this 
procedure.

86100D Computer Name: ________________________

5 Close the About 86100D dialog box.

6 On the Windows Start menu of your PC, click All Programs>Keysight Connection Expert to launch 
Connection Expert 2017. Refer to Keysight IO Libraries Suite for information on how to install the 
Keysight Connection Expert 2017.

http://www.keysight.com/en/pd-1985909/io-libraries-suite?nid=-33330.977662.00&cc=IN&lc=eng&cmpid=zzfindiosuiteproductcounter
http://www.keysight.com/en/pd-1985909/io-libraries-suite?nid=-33330.977662.00&cc=IN&lc=eng&cmpid=zzfindiosuiteproductcounter
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Figure 72 Launching the Keysight Connection Expert 2017

7 In Keysight Connection Expert 2017, click the + Add button to manually add instruments and 
interfaces.

Figure 73 Adding 86100D Oscilloscope manually in the Keysight Connection Expert 2017

8 From the drop-down list that appears, select LAN instrument.

Figure 74 Selecting LAN instrument in the Keysight Connection Expert 2017
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9 In the Add a LAN device window, 

a Select the Enter Address tab.

b Under Set LAN Address:, enter the Hostname (recorded in step 1) in the Hostname or IP Address: 
field. Note that your Hostname entry will be different from what is shown in the image.

c Under Set Protocol:, select Socket and enter the port number.

d Under Verify Connection:, click Test This VISA Address to verify the connection.

Figure 75 Adding 86100D Oscilloscope’s device information in the Keysight Connection Expert 2017

10 Once you verify the entered data, click OK to complete the process.
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11 To verify that the 86100D Oscilloscope is connected, click the Instruments tab of the Keysight 
Connection Expert. 

12 Click the 86100D Oscilloscope’s listing on the left pane. A check mark encircled in green 
indicates that the Oscilloscope is connected to your PC remotely on the LAN. Note that the 
address on your end will be different from what is shown in the image.

Figure 76 Validating 86100D Oscilloscope’s connection

13 Close the Keysight Connection Expert window.
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Connecting N1010A FlexDCA to N109X Oscilloscope and N107X

Perform the following steps to connect your N109X oscilloscope with N107X clock data recovery 
using FlexDCA:

1 Launch FlexDCA.

2 When FlexDCA starts, the Extended Module Configuration window is displayed automatically. If the 
Extended Module Configuration window does not appear, from the FlexDCA interface’s main menu, 
click Setup>Configure Extended Modules....

3 Configure Slot 7 to be the N109X module.

4 Configure Slot 8 to be the N107X module.

5 Remove any other N109X/N107X that is configured for Slot 5 and Slot 6.

6 Click Close to exit the Extended Module Configuration window.

7 Once the connection is established, you may proceed to launch the N109228CA Compliance Test 
Application on your PC.



OIF CEI 3.1 Compliance and Debug Application Getting Started 77

Installing N109228CA on a PC Without N1010A FlexDCA 3

Starting the N109228CA OIF CEI 3.1 Compliance Test Application

After you install the N109228CA OIF CEI Compliance Test Application on a PC without the N1010A 
FlexDCA interface, follow the steps below to start the N109228CA OIF CEI 3.1 Compliance Test 
Application:

1 Ensure that the 86100D or N1000A Oscilloscope is added to the Keysight Connection Expert and 
that the connection is active. Refer to “Adding 86100D or N1000A to Keysight Connection 
Expert” on page 68.

2 From the Windows Start menu, navigate to Start>All Programs>Keysight FlexDCA 
Applications>N109228CA OIF CEI 3_1and click Launch 'N109228CA OIF CEI 3_1'.

3 The N109228CA OIF CEI 3.1 Compliance Test Application banner appears followed by the 
Connect to FlexDCA dialog.

Figure 77 N109228CA OIF CEI 3.1 Application launching banner

4 Enter the SICL address or VISA alias, if known, else select the Select from Keysight Connection Expert 
option to find the SICL Address/VISA alias.

5 Click OK to connect.
The default view of the N109228CA OIF CEI 3.1 Compliance Test Application appears.
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Figure 78 Default window of the N109228CA OIF CEI 3.1 Compliance Test Application

NOTE If you click the View 'N109228CA OIF CEI 3_1' in Demo Mode option under Start>All 
Programs>Keysight FlexDCA Applications>N109228CA OIF CEI 3_1, click File>Connect to 
Scope... to access the Connect to FlexDCA dialog. However, since it is a demo application, it 
has limited features.
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Connecting to the Network Analyzer

Refer to “Connecting to External Instruments” on page 21 for connecting to the network analyzer you 
are using.
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Connecting to the N4877A

The N4877A is used whenever multiple 86100D or N1000A modules are used in the test setup rather 
than an 86108A/B module. Refer to Table 4 on page 62.

On the 86100D, click Setup > Configure Extended Modules. In the dialog box, perform the following two 
steps:

1 Configure Slot 8 to be the N4877A.

2 Remove any other N4877A that is configured for Slot 5, Slot 6, or Slot 7.

For more information, click the Help button that is in the title bar of the Extended Module 
Configuration dialog box.

Figure 79 The Extended Module Configuration with the N4877A in Slot 8
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Getting Started

4 Installing N109228CA on the 
oscilloscope

Follow the instructions in this chapter when you are installing both the N109228CA application and 
the FlexDCA application on the 86100D or N1000A oscilloscope. You must purchase and install a 
license for the 86100DU-401. Once the license is installed, the 86100DU-401 software will be 
enabled.

Figure 80 N109228CA Installed on 86100D
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Figure 81 N109228CA Installed on N1000A
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Figure 82 N109228CA Installed on 86100D connected to a DCA-M setup
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Figure 83 N109228CA Installed on N1000A connected to a DCA-M setup

NOTE If you do not connect a network analyzer, you will not be able to perform the return loss 
compliance tests.

NOTE The 86100DU-400 software is required only for testing the CEI 11G-SR (Short Reach) interface, 
when running the Jitter Transfer Bandwidth, 11G-SR and Jitter Transfer Peaking, 11G-SR tests.

NOTE The 86100DU-401 or N109X-401 software is required only for testing the CEI 6G and CEI 11G 
interfaces, when you select a PRBS31 pattern length when testing jitter.
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Connecting the Equipment

1 For a DCA-X oscilloscope, install one of the module combinations listed in Table 6 into the 
oscilloscope.

Table 6 Module combinations for 86100D Oscilloscope

2 For a DCA-M oscilloscope, keep in mind the information in the following table.

Table 7 Supported configurations for DCA-M Oscilloscope

3 Connect the equipment as shown in the relevant diagrams above and turn on all of the 
instruments.

Installed Module Configurations Requires
N4877A

Limited to CEI 6G-LR/SR
and CEI 11G-LR/MR/SR
Testing Only

86108A √

86108B-LBW/216 √

86108B-HBW/232

86112A and 86107A √ (N4877A-216) √

54754A and 86107A √ (N4877A-216) √

86117A and 86107A √ (N4877A-232)

86118A-H01 and 86107A √ (N4877A-232)

N1045A and 86107A √ (N4877A-232)

N1045B and 86107A √ (N4877A-232)

N1055A and 86107A √ (N4877A-232)

54754A and 86107A √ (N4877A-232)

N1046A and 86107A √ (N4877A-232)

N1060A

Configurations for DCA-M Requires N107x

N1094A √ (N107xA-232)

N1094B √ (N107xA-232)

N1092 C/E √ (N107xA-232)
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Installing the I/O Library Suite

1 Navigate to www.keysight.com/find/iosuite and download the Keysight I/O Library Suite.

2 Install the I/O Library Suite on the same 86100D or N1000A where you will install the 
N109228CA.

NOTE Keysight’s I/O Library Suite is free software that automatically detects instruments connected to 
your PC and configures the interfaces. It reduces the overall setup and configuration time. The 
N109228CA OIF CEI 3.1 Compliance Test Application requires I/O Libraries Suite 16.3 or higher.

http://www.keysight.com/en/pd-1985909/io-libraries-suite?nid=-33330.977662.00&cc=IN&lc=eng&cmpid=zzfindiosuite
http://www.keysight.com/en/pd-1985909/io-libraries-suite?nid=-33330.977662.00&cc=IN&lc=eng&cmpid=zzfindiosuite
http://www.keysight.com/en/pd-1985909/io-libraries-suite?nid=-33330.977662.00&cc=IN&lc=eng&cmpid=zzfindiosuite
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Installing the N109228CA OIF CEI 3.1 Compliance Test Application

Follow the steps below to install the N109228CA OIF CEI 3.1 Compliance Test Application and its 
license as well as the license for the 86100DU-401. A version of the 86100DU-401 is automatically 
installed for use with the N109228CA. When the license for 86100DU-401 is installed, the 
86100DU-401 software is enabled.

1 Search for the N109228CA OIF CEI 3.1 Compliance Test Application on the Keysight website. 
Download the application and install it on the Oscilloscope for which you have redeemed the 
license.

2 Save the license file that you received from Keysight in a folder on the local disk or in an 
accessible memory device.

3 If not already done, purchase an 86100DU-401 or N1010100A license. Save the license file that 
you received from Keysight in a folder on the local disk or in an accessible memory device.

4 If the FlexDCA software is running on the Oscilloscope, close FlexDCA.

5 From the Windows Start menu, click All Programs>Keysight License Manager to launch the Keysight 
License Manager.

Figure 84 Launching Keysight Connection Expert from the Start menu

NOTE When you redeem an N109228CA OIF CEI 3.1 license, you must select whether to install the 
application on the Oscilloscope or a specific PC.

NOTE Keysight License Manager version 5.1 (and higher) have a different user interface than version 
5.0 (or earlier). Even though the path to launch the Keysight License Manager is the same for 
both versions, refer to the Keysight License Manager Online Help for the respective versions to 
find more information about the functionality of the application.
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To install the N109228CA OIF CEI 3.1 Compliance Test Application’s license using Keysight License Man-
ager version 5.1 or higher

1 Click the Tools icon on the top-right corner of the Keysight License Manager window.

Figure 85 Installing license file on Keysight License Manager version 5.1 & above

2 Click Install License File.... The Select License File(s) to Install on <PC Hostname> appears.

Figure 86 Selecting license file from the folder

3 Navigate to the folder where the N109228CA OIF CEI 3.1 licenses are saved.

4 Select the license and click Open. The license files are installed and an entry is displayed in the 
Keysight License Manager.

5 Close the Keysight License Manager.
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To install the N109228CA OIF CEI 3.1 Compliance Test Application’s license using Keysight License Man-
ager version 5.0 or earlier

1 From the Keysight License Manager window’s main menu, click File>Install... or right-click within 
the left pane of the Keysight License Manager window and select Install....

Figure 87 Installing license file on Keysight License Manager version 5.0 or earlier

2 The Install License File(s) dialog box appears.

Figure 88 Selecting license file from the folder

3 Navigate to the folder where the N109228CA OIF CEI 3.1 licenses are saved.

4 Select the license and click Open. The license files are installed and an entry is displayed in the 
Keysight License Manager.

5 Close the Keysight License Manager.
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Configuring FlexDCA’s SCPI Server Setup

1 On the 86100D or N1000A, click Apps > FlexDCA to start FlexDCA.

2 In FlexDCA, click Tools > SCPI Programming Tools > SCPI Server Setup to open the dialog box.

3 Confirm that the Sockets and HiSLIP interfaces are selected (Enabled) as shown in Figure 89.

4 Close the dialog box.

Figure 89 FlexDCA’s SCPI Server Setup Dialog Box

5 Minimize the FlexDCA application and the 86100D application so that you can view the Windows 
desktop.
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Connecting N1010A FlexDCA to N109X Oscilloscope and N107X

Perform the following steps to connect your N109X oscilloscope with N107X clock data recovery 
using FlexDCA:

1 Launch FlexDCA.

2 When FlexDCA starts, the Extended Module Configuration window is displayed automatically. If the 
Extended Module Configuration window does not appear, from the FlexDCA interface’s main menu, 
click Setup>Configure Extended Modules....

3 Configure Slot 7 to be the N109X module.

4 Configure Slot 8 to be the N107X module.

5 Remove any other N109X/N107X that is configured for Slot 5 and Slot 6.

6 Click Close to exit the Extended Module Configuration window.

7 Once the connection is established, you may proceed to launch the N109228CA Compliance Test 
Application on your PC.
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Starting the N109228CA OIF CEI 3.1 Compliance Test Application

After you install the N109228CA OIF CEI 3.1 Compliance Test Application on the 86100D or N1000A 
Oscilloscope, follow the steps below to start the N109228CA OIF CEI 3.1 Compliance Test 
Application:

1 On the Oscilloscope, launch the Keysight FlexDCA application.

2 From the FlexDCA's main menu, click Apps>Automated Test Apps>N109228CA OIF CEI 3_1.

3 The N109228CA OIF CEI 3.1 Compliance Test Application banner appears.
Afterwards, the default view of the N109228CA OIF CEI 3.1 Compliance Test Application appears.

Figure 90 Default window of the N109228CA OIF CEI 3.1 Compliance Test Application
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Connecting to the Network Analyzer

Refer to “Connecting to External Instruments” on page 21 for connecting to the network analyzer you 
are using.
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Connecting to the N4877A

The N4877A is used whenever multiple 86100D or N1000A modules are used in the test setup rather 
than an 86108A/B module. Refer to Table 6 on page 85.

On the 86100D or N1000A, click Setup > Configure Extended Modules. In the dialog box, perform the 
following two steps:

1 Configure Slot 8 to be the N4877A.

2 Remove any other N4877A that is configured for Slot 5, Slot 6, or Slot 7.

For more information, click the Help button that is in the title bar of the Extended Module 
Configuration dialog box.

Figure 91 The Extended Module Configuration with the N4877A in Slot 8
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